Az előző parancsok beállításainak módosítása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. A Beállítások lap Előző parancsok megjegyzése csoportjában adja meg a pufferméretet, majd határozza meg a használni kívánt pufferek számát.

Megjegyzések

  • A pufferméret módosításával megváltozik a pufferben tárolható parancsok száma. A pufferek számának módosításával megváltozik azoknak a folyamatoknak a száma, amelyeknek külön előzménypuffere lehet. A pufferek számának vagy méretének növelésével nő a memóriaigény.
  • Ha az előző parancsok között a többször kiadott parancsokat csak egyszer szeretné látni, jelölje be a Régi előfordulások törlése jelölőnégyzetet.
  • Ha az előző parancsok beállításait csak az aktuális parancssorablakra vonatkozóan szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.

Kapcsolódó témakörök


A parancssori kurzor méretének megváltoztatása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. A Beállítások lap Kurzorméret csoportjában állítsa be a kurzorméretet.

Megjegyzések

  • Ha csak az aktuális parancssorablak kurzorméretét szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.


A parancssor megjelenítési beállításainak módosítása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. A Beállítások lap Megjelenítési beállítások csoportjában kattintson az Ablakban vagy a Teljes képernyőn elemre.

Megjegyzések

  • Intel alapú számítógépeken az ALT+ENTER billentyűkombinációval lehet az ablakban történő és a teljes képernyős megjelenítés között váltani.
  • Ha csak az aktuális parancssorablak megjelenítési beállításait szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.


MS-DOS parancssorablak betűtípusának módosítása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. Kattintson a Betűtípus fülre.
  4. A Betűtípus listában válasszon egy betűtípust.
    • Ha TrueType betűtípust választ, a Méret listában kiválaszthat egy pontértéket, vagy megadhat egy értéket a Méret mezőben.
    • Ha a Raszter betűtípusok elemet választja, a Méret ablakban megjelenő méretek a parancssor ablakára vonatkozó méretlehetőségeket jelentik.
  5. Ha TrueType betűkészlet esetén félkövér betűket szeretne használni, jelölje be a Félkövér betűk jelölőnégyzetet.

Megjegyzések

  • Az ablak képe mezőben az látható, hogy a jelenlegi ablakméret hogyan változik a kiválasztott betűtípus és betűméret függvényében.
  • A Kijelölt betűtípus mezőben az látható, hogy a karakterek hogyan fognak megjelenni a kiválasztott betűtípus-beállításokkal. A Félkövér betűk lehetőség nem áll rendelkezésre Raszter betűtípusok esetén.
  • Az ablak az Elrendezés lapon megadott maximális méretig méretezhető át. A könnyű olvashatóság és kezelhetőség érdekében ajánlott olyan ablakméretet választani, amely az Asztal felét vagy negyedét foglalja el.
  • Ha csak az aktuális parancssorablak betűtípusát szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.


A parancssori elemek színének módosítása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. A Színek lapon válassza ki a képernyő szövegének, a képernyő hátterének, a felbukkanó ablak szövegének és a felbukkanó ablak hátterének a színét oly módon, hogy a módosítani kívánt elemre, majd a használni kívánt színre kattint.

Megjegyzések

  • A Kijelölt képernyőszínek mezőben látható, hogy a kiválasztott szöveg- és háttérszínek hogyan fognak megjelenni a képernyőn.
  • Az Előugró elemek kijelölt színe mezőben látható, hogy a kiválasztott szöveg- és háttérszínek hogyan fognak megjelenni egy felbukkanó ablakban.
  • Ha csak az aktuális parancssorablak színeit szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.


A parancssorképernyő elrendezésének módosítása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. Kattintson az Elrendezés fülre.
  4. A Képernyőpuffer mérete csoportban adja meg a képernyő szélességét és magasságát a pufferba beírt karakterek száma alapján.
  5. Az Ablakméret csoportban adja meg az ablak szélességét és magasságát.
  6. Az Ablak helyzete csoportban adja meg az ablak bal felső sarkának kezdeti elhelyezkedését.

Megjegyzések

  • Ha azt szeretné, hogy az ablakot a Windows 2000 helyezze el a képernyőn, jelölje be A rendszer helyezi el jelölőnégyzetet.
  • Az ablakban görgetősávok jelennek meg, ha az ablak mérete kisebb a képernyőpuffer méreténél.
  • Az ablak nem állítható a képernyőpuffer beállításaiban meghatározott területnél nagyobb méretre.
  • Ha egy Intel alapú számítógépen teljes képernyős módba vált, a Windows 2000 megjeleníti, hogy melyik az a hardver által támogatott sorszám (25, 43 vagy 50), amely az ablakbeállításhoz legközelebb áll.
  • Ha csak az aktuális Parancssor ablak elhelyezési beállításait szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.


A parancssorablak szerkesztési beállításainak módosítása

  2. Kattintson a jobb oldali egérgombbal a címsorra, majd kattintson az Alapértelmezés menüpontra.
  3. Az Általános lap Beállítások csoportjában tegye a következőket:
    • Ha az egérrel kivágás és beillesztés műveleteket szeretne végrehajtani, válassza a Gyorsszerkesztés beállítást.
    • Ha a kurzor pozíciójánál felülírás helyett szöveget szeretne beszúrni, válassza a Beszúrási mód elemet.

Megjegyzések

  • Ha csak az aktuális parancssorablak beállításait szeretné megváltoztatni, kövesse a fenti lépéseket azzal a módosítással, hogy a 2. lépésben kattintson a Tulajdonságok menüpontra a parancssor tulajdonságait tartalmazó párbeszédpanel megjelenítéséhez.


OS/2 konfigurációs információk módosítása

Egy Windows 2000 rendszert futtató, külön OS/2 partícióval rendelkező számítógép OS/2 konfigurációjának módosítása

  1. A Windows 2000 Professional operációs rendszerben indítson el egy ablakban egy OS/2 szövegszerkesztőt a következő módon: kattintson a Start gombra, majd a Futtatás parancsra. A megjelenő ablakba írja be az OS/2 szövegszerkesztő fájlnevét és elérési útját, majd kattintson az OK gombra.
  2. Az OS/2 szövegszerkesztőben nyissa meg a Config.sys fájlt. A Config.sys fájl a merevlemez gyökérkönyvtárában található.

    3. A Windows 2000 Professional kiolvassa a konfigurációs információt a rendszerleíró adatbázisból, és egy ideiglenes fájlban tárolja azt.

  3. A kívánt eredmény elérése érdekében szükség szerint módosítsa a konfigurációs információt.
  4. Mentse el és zárja be a fájlt az OS/2 szövegszerkesztőben.
  5. Lépjen ki a szövegszerkesztőből.

    6. A Windows 2000 Professional eltárolja az új információt a rendszerleíró adatbázisba.

  6. Lépjen ki a Windows 2000 Professional rendszerből, és indítsa újra a számítógépet. A számítógép újraindításához kattintson a Start gombra, válassza a Leállítás parancsot, majd kattintson az Újraindítás elemre.

Megjegyzések

  • Az elérési út megadásához írja be a meghajtó betűjelét, majd egy kettőspontot (:) és egy fordított ferde vonalat (\), adja meg a fájlt tartalmazó mappák és almappák nevét (a neveket fordított ferde vonallal elválasztva), végül írja be a megnyitni kívánt fájl vagy mappa nevét.
  • Az OS/2 operációs rendszer és a szövegszerkesztő használatával kapcsolatban tanulmányozza az OS/2 kézikönyvét.


MS-DOS parancsikon ikonjának módosítása

  1. Kattintson a jobb oldali egérgombbal az MS-DOS parancsikonra, majd kattintson a Tulajdonságok parancsra.
  2. Kattintson a Program (vagy a Parancsikon) fülre.
  3. Kattintson az Ikoncsere gombra.
  4. Az Ikoncsere párbeszédpanelen válasszon ki egy ikont a parancsikon számára, vagy más ikon kereséséhez kattintson a Tallózás gombra.


PIF fájlok létrehozása és módosítása Windows 2000 Professional rendszeren

Programinformációs fájl (PIF fájl) létrehozása és módosítása Windows 2000 rendszeren

  1. Nyissa meg a Sajátgép ablakot.
  2. Hajtsa végre az alábbi műveletek egyikét:
    • Ha egy programhoz PIF fájlt szeretne létrehozni, keresse meg a programot, majd kattintson rá a jobb oldali egérgombbal. Ezután kattintson a Tulajdonságok parancsra, és a program igényeinek megfelelően módosítsa az alapértelmezett beállításokat.
    • Ha egy létező PIF fájl beállításait szeretné módosítani, keresse meg a programfájlhoz tartozó parancsikont, majd kattintson rá a jobb oldali egérgombbal. Kattintson a Tulajdonságok parancsra, és végezze el a szükséges módosításokat.

Megjegyzések

  • Ha egy MS-DOS alapú programhoz létrehoz egy programinformációs fájlt (PIF fájlt), egy parancsikon jön létre a végrehajtható programhoz. A parancsikon a PIF fájlba mentett minden beállítást tartalmaz.
  • A PIF fájl létrehozása vagy módosítása előtt olvassa el az MS-DOS alapú program dokumentációját. A PIF fájl módosítása hatással van a program és a Windows 2000 Professional együttműködésére. Előfordulhat, hogy a program csak adott beállításokkal működik megfelelően.
  • Annak megadásához, hogy az MS-DOS alapú program teljes képernyőn vagy ablakban induljon el, módosítsa a Program (vagy a Parancsikon) lap Futtatás tulajdonságát.
  • Ha az MS-DOS alapú program kimenetét gyorsabban szeretné megjeleníteni, miután a 2. lépésben a Tulajdonságok lehetőségre kattintott, a Képernyő lap Teljesítmény csoportjában válassza a Gyors ROM emulációja beállítást. Olvassa el a videokártyához adott dokumentációt annak ellenőrzésére, hogy az támogatja-e a gyors ROM emulációját.
  • Az MS-DOS alapú program teljesítményének növelése érdekében lefoglalhat több memóriát a program számára. Ehhez, miután a 2. lépésben a Tulajdonságok parancsra kattintott, a Memória lapon a Bővített (EMS) memória vagy a Kiterjesztett (XMS) memória beállítást állítsa Auto értékre, így azok mérete nem lesz korlátozva. Ha programhibákat tapasztal, az Összesen értéket állítsa 8192-re. A memóriabeállításokkal kapcsolatos további tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A Tulajdonságok párbeszédpanel a Windows korábbi verzióiban található PIF szerkesztőt váltja fel.


Szöveg másolása parancssorablakból

  2. A parancssorablakban a menü megjelenítéséhez kattintson a jobb oldali egérgombbal a címsorra, mutasson a Szerkesztés elemre, majd kattintson a Megjelölés parancsra.
  3. Kattintson a másolni kívánt szöveg elejére.
  4. A SHIFT billentyű nyomva tartása közben kattintson a másolni kívánt szöveg végére (vagy az egérgomb nyomva tartása közben húzza a kurzort a szöveg kijelöléséhez).
  5. Kattintson a jobb oldali egérgombbal a címsorra, mutasson a Szerkesztés menüpontra, majd kattintson a Másolás parancsra.
  6. Helyezze a kurzort arra a helyre, ahová be szeretné szúrni a szöveget.
    • Az MS-DOS alapú programban vagy a parancssorablakban kattintson a jobb oldali egérgombbal a címsorra, mutasson a Szerkesztés menüpontra, majd kattintson a Beillesztés parancsra.
    • Ha a szöveget Windows alapú programba illeszti be, kattintson a Szerkesztés menü Beillesztés parancsára.

Megjegyzések

  • Teljes képernyőn futó MS-DOS alapú programba vagy parancssorablakba nem lehet szöveget beilleszteni. Az MS-DOS alapú programok PIF fájljainak konfigurálásával kapcsolatban tanulmányozza a Kapcsolódó témaköröket.


Egyéni indítófájlok létrehozása MS-DOS alapú programokhoz

Egyéni indítófájlok létrehozása speciális beállítást igénylő, MS-DOS alapú programokhoz

  1. Egy szövegszerkesztő, például a Jegyzettömb segítségével módosítsa a Config.nt és az Autoexec.nt fájlt (ezek a rendszergyökér\System32 mappában találhatók).
  2. Mentse a fájlokat más néven.
  3. Kattintson a jobb oldali egérgombbal az MS-DOS alapú program parancsikonjára, majd kattintson a Tulajdonságok parancsra.
  4. Kattintson a Program fülre, majd a Speciális gombra.
  5. Az Egyéni MS-DOS indítófájlok csoportban adja meg az egyéni indítófájlok neveit.

Megjegyzések

  • Erre az eljárásra azért lehet szükség, mert egyes MS-DOS programok speciális memória- és képkezelő utasításokat használnak, vagy futtatásukhoz más programok előzetes telepítése szükséges. Indítófájl létrehozása előtt tanulmányozza a program dokumentációját.
  • Az MS-DOS alapú program dokumentációja alapján hozzon létre egy parancsikont, vagy tanulmányozza a Kapcsolódó témaköröket.
  • Ez a lehetőség egyes MS-DOS alapú programok esetén nem áll rendelkezésre.
  • Ha egy MS-DOS alapú programhoz egyéni indítófájlt szeretne használni, a programot a parancsikonja segítségével kell elindítani.
  • Ha egy MS-DOS alapú programhoz létrehoz egy programinformációs fájlt (PIF fájlt), egy parancsikon jön létre a végrehajtható programhoz. A parancsikon a PIF fájlba mentett minden beállítást tartalmaz.


MS-DOS parancshoz tartozó súgó megjelenítése

  2. A parancssorban írja be azt a parancsot, amellyel kapcsolatban segítségre van szüksége, majd gépelje be a /? karaktereket.

    3. Ha például a chdir paranccsal kapcsolatban kér segítséget, írja be: chdir /?

Megjegyzések

  • Ha a súgó szövegét szeretné megállítani a képernyő alján, írja be a megfelelő parancsot, majd a | more karaktereket. Ha például a dir parancshoz tartozó súgót szeretné megtekinteni, írja be a dir /? | more parancsot.


Kompatibilis hardveróra-emuláció beállítása

  1. Nyissa meg a Sajátgép ablakot.
  2. Keresse meg a módosítani kívánt a MS-DOS alapú programot (.exe fájl), illetve a hozzá tartozó programinformációs fájlt vagy parancsikont.
  3. Kattintson a jobb oldali egérgombbal a programfájlra vagy a parancsikonra, válassza a Tulajdonságok parancsot, majd a Program lapon kattintson a Speciális gombra.
  4. A Windows PIF-beállítások párbeszédpanelen jelölje be a Kompatibilis hardveróra-emuláció jelölőnégyzetet.

Megjegyzések

  • A kompatibilis hardveróra-emuláció lehetővé teszi az MS-DOS alapú programok számára, hogy csökkentsék a számítógép időmérője által küldött időzítőjelek gyakoriságát. Minél nagyobb a számítógép processzorának az órajele (200MHz, 300MHz stb.), annál gyorsabban továbbítódnak a jelek a hardver és a szoftver között, amely a legtöbb Windows alapú program gyorsabb futását eredményezi.
  • A legtöbb MS-DOS alapú program tervezésekor nem gondoltak a gyors processzorokra. Ha egy MS-DOS alapú program túl magasra állítja ezt a gyakoriságot a telepítés során, előfordulhat, hogy a program nem fog működni. Csak akkor jelölje be ezt a jelölőnégyzetet, ha elolvasta a program dokumentációját. Ellenkező esetben csökkenhet a program teljesítménye, vagy előfordulhat, hogy a program nem jól kezeli az időt.
  • A parancsikont programinformációs fájlnak vagy PIF fájlnak is nevezik.
  • Ez a lehetőség egyes MS-DOS alapú programok esetén nem áll rendelkezésre.


Az egérmutató elrejtése MS-DOS programokban

Az egérmutató elrejtése egeret nem igénylő MS-DOS programokban

  • Az MS-DOS alapú program dokumentációjában keresse ki, hogy a program képes-e „fogd és vidd” művetek végzésére, vagy használja-e az egérmutatót. Ha nem, kattintson a jobb oldali egérgombbal az MS-DOS ablak címsorára a menü megjelenítéséhez, majd kattintson az Egérmutató elrejtése parancsra.

Megjegyzések

  • Ha a programnak karakteres és grafikus részei is vannak, szükség lehet az egérmutató újbóli elrejtésére.
  • Ha az egérmutató el van rejtve, az nem látható sem a programablakban, sem azon kívül. Az egérmutató megjelenítéséhez a parancssorablakban nyomja meg az ALT+SPACEBAR billentyűkombinációt, majd kattintson a menü Egérmutató megjelenítése parancsára.
  • Ez a lehetőség egyes MS-DOS alapú programok esetén nem áll rendelkezésre.


Rendszererőforrások lefoglalása MS-DOS alapú programok számára

Rendszererőforrások lefoglalása MS-DOS alapú programok számára, és az üresjárati idő módosítása

  1. Nyissa meg a Sajátgép ablakot.
  2. Keresse meg a módosítani kívánt MS-DOS alapú programot (.exe fájl), illetve a hozzá tartozó programinformációs fájlt vagy parancsikont. A programfájl nevét a program dokumentációjából tudhatja meg.
  3. Kattintson az ikonra a jobb oldali egérgombbal, majd kattintson a Tulajdonságok parancsra.
  4. Kattintson a Tulajdonságok párbeszédpanel Vegyes fülére.
  5. Állítsa be az Üresjárati érzékenység csúszkát a következők alapján:
    • Ha egy háttérben futó programhoz több erőforrást szeretne hozzárendelni, tolja a csúszkát az Alacsony érték felé.
    • Ha egy háttérben futó programhoz kevesebb erőforrást szeretne hozzárendelni, tolja a csúszkát a Magas érték felé.

Megjegyzések

  • Megadható, hogy egy MS-DOS alapú program milyen hosszú üresjárat után csökkentse erőforrás-lefoglalását annak érdekében, hogy az erőforrásokat más programok használhassák.
  • Ez a lehetőség egyes MS-DOS alapú programok esetén nem áll rendelkezésre.
  • Ha egy MS-DOS alapú programhoz létrehoz egy programinformációs fájlt (PIF fájlt), egy parancsikon jön létre a végrehajtható programhoz. A parancsikon a PIF fájlba mentett minden beállítást tartalmaz.


MS-DOS - áttekintés

Az MS-DOS, amely a Microsoft Disk Operating System rövidítése, személyi számítógépeken használt, parancssori kezelőfelülettel rendelkező operációs rendszer. Más operációs rendszerekhez (például az OS/2 rendszerhez) hasonlóan a felhasználó által leütött billentyűket a számítógép által végrehajtható formára fordítja le, felügyeli a lemezműveleteket, a képkezelést, a billentyűzetvezérlést, valamint a programok végrehajtásához és a fájlok kezeléséhez szükséges számos műveletet.

Az MS-DOS parancsokat a parancssorablakba lehet beírni. Egy MS-DOS munkamenet befejezéséhez a parancssorablakba, a villogó kurzornál írja be: exit.

Az MS-DOS mód egy olyan rendszerhéj, amelyben az MS-DOS környezet emulálása 32 bites rendszerekben (például Windows 98, Windows NT vagy Windows 2000 rendszerben) történik. Az MS-DOS alapú programok futtathatók Windows 2000 operációs rendszerben, és létrehozhatók számukra programinformációs (PIF) fájlok, amelyek a Windows 2000 rendszerben parancsikonként jelennek meg.

Megjegyzések

  • Ha egy MS-DOS alapú programhoz létrehoz egy programinformációs fájlt (PIF fájlt), egy parancsikon jön létre a végrehajtható programhoz. A parancsikon a PIF fájlba mentett minden beállítást tartalmaz.


Memóriarezidens programok futtatása ablakban

  1. Indítsa el a memóriarezidens programot (más néven TSR programot) a programhoz tartozó dokumentáció alapján.
  2. A program indulhat parancssor stílusú ablakban, vagy a dokumentációjában leírt felhasználói felülettel.
  3. Az ALT+ENTER billentyűkombináció megnyomásával válthat az ablakban történő megjelenítés és az eredeti felhasználói felülettel történő megjelenítés között.

Megjegyzések

  • A TSR program határozza meg a program ablakban történő futtatásához szükséges billentyűkombinációt. Egyes MS-DOS alapú programok nem futtathatók ablakban.
  • TSR programok például az MS-DOS alapú naptárprogramok, számológépek, helyesírás-ellenőrzők és szótárak.
  • Az MS-DOS alapú programok az ALT+ENTER billentyűkombinációt használják a teljes képernyős és az ablakban történő megjelenítés közötti váltásra.
  • A Windows 2000 Professional lehetővé teszi a memóriarezidens programok és a szabványos Windows 2000 programok közötti könnyű váltást.
  • Ha a memóriarezidens program egy Windows 2000 számára fenntartott billentyűkombinációt használ, tanulmányozza a Kapcsolódó témaköröket.


MS-DOS szöveg másolása és beillesztése az egér segítségével

  2. Kattintson a jobb oldali egérgombbal a parancssorablak címsorára, majd kattintson a Tulajdonságok menüpontra.
  3. A Beállítások lap Szerkesztési beállítások csoportjában jelölje be a Gyorsszerkesztés jelölőnégyzetet, majd kattintson az OK gombra.
  4. A Beállítások alkalmazása párbeszédpanelen kattintson a következők egyikére:
    5. :
    • Beállítások alkalmazása csak az aktuális ablakra, ha a gyorsszerkesztési módot csak az aktuális ablakban szeretné használni.
    • Beállítások alkalmazása a jelenlegivel azonos című ablakokra, ha a gyorsszerkesztési módot az MS-DOS alapú program minden futtatásakor használni szeretné.
    Kattintson az OK gombra.
  5. Az egérgomb nyomva tartása közben húzza az egérmutatót a parancssorablakban a másolni kívánt szöveg fölött.
  6. Helyezze a kurzort arra a helyre, ahová be szeretné szúrni a szöveget, majd tegye a következők egyikét:
    • Ha a szöveget MS-DOS alapú programba szeretné beilleszteni, kattintson a jobb oldali egérgombbal a program címsorára, mutasson a Szerkesztés elemre, majd kattintson a Beillesztés parancsra.
    • Ha a szöveget Windows alapú programba illeszti be, kattintson a Szerkesztés menü Beillesztés parancsára. Vagy kattintson a jobb oldali egérgombbal, és a megjelenő menüben válassza a Beillesztés parancsot.

Megjegyzések

  • A gyorsszerkesztési mód egyes MS-DOS alapú programok esetén nem használható.
  • Teljes képernyőn futó MS-DOS alapú programba vagy parancssorablakba nem lehet szöveget beilleszteni.


Billentyűparancsok lefoglalása MS-DOS alapú programok számára

  1. Nyissa meg a Sajátgép ablakot.
  2. Keresse meg a módosítani kívánt MS-DOS alapú programot (.exe fájl), illetve a hozzá tartozó programinformációs fájlt vagy parancsikont. Kattintson a fájlra a jobb oldali egérgombbal, majd kattintson a Tulajdonságok parancsra.
  3. Kattintson a Tulajdonságok párbeszédpanel Vegyes fülére.
  4. A Windows billentyűparancsok csoportban törölje azon billentyűkombinációk mellett található jelölőnégyzeteket, amelyeket az MS-DOS program használ. Ha töröl egy jelölőnégyzetet, az MS-DOS alapú program használatakor a Windows 2000 figyelmen kívül hagyja az adott billentyűparancsot.

    5. Csak az alábbi billentyűparancsok foglalhatók le MS-DOS alapú programok számára:

    • ALT+TAB
    • ALT+ESC
    • CTRL+ESC
    • PRINT SCREEN
    • ALT+PRINT SCREEN
    • ALT+ENTER
    • ALT+SZÓKÖZ

Megjegyzések

  • Ez a lehetőség egyes MS-DOS alapú programok esetén nem áll rendelkezésre.
  • Egyes MS-DOS alapú programok bizonyos funkciók eléréséhez billentyűleütések kombinációját (azaz adott billentyűk egyszerre történő lenyomását) igénylik, amit billentyűparancsnak is neveznek.
  • Akkor lehet szükség billentyűparancsok lefoglalására, ha az MS-DOS alapú program ugyanazokat a billentyűparancsokat használja, mint a Windows 2000. Például ha az MS-DOS alapú programban az ALT+TAB billentyűkombinációval érhető el egy művelet, akkor a Windows 2000 meg fogja szakítani a művelet végrehajtását, és helyette át fog váltani egy másik alkalmazásra. (A Windows 2000 rendszerben az ALT+TAB billentyűparanccsal lehet váltani a programok között.)


Memóriarezidens program futtatása más programmal

  1. Indítsa el a memóriarezidens programot (más néven TSR programot) a programhoz tartozó dokumentáció alapján.
  2. Indítsa el a másik programot ugyanabban az ablakban oly módon, hogy beírja a nevét a parancssorba, majd leüti az ENTER billentyűt.

Megjegyzések

  • Egy TSR programot egy másik programmal együtt úgy is el lehet indítani, hogy létrehoz egy parancsfájlt, amely elindítja mindkét programot, majd létrehoz egy parancsikont ehhez a parancsfájlhoz.
  • TSR programok például a naptárprogramok, számológépek, helyesírás-ellenőrzők és szótárak.
  • Ha a TSR programot működésben kívánja tartani a Windows 2000 Professional használata közben, indítsa el és hagyja futni a programot egy ablakban. Így bármikor visszaválthat az ablakra, ugyanúgy mint más programokra.


Egyéni indítófájlok megadása MS-DOS alapú programokhoz

  1. Nyissa meg a Sajátgép ablakot.
  2. Keresse meg a módosítani kívánt MS-DOS alapú programot (.exe fájl), illetve a hozzá tartozó programinformációs fájlt vagy parancsikont.
  3. Kattintson a jobb oldali egérgombbal a programfájlra (.exe), a programinformációs fájlra vagy a parancsikonra, majd kattintson a Tulajdonságok parancsra.
  4. Kattintson a Program fülre.
  5. A Parancssor mezőbe írja be a program nevét.
  6. Kattintson a Speciális gombra.
  7. Írja be a létrehozott egyéni indítófájlok nevét.

Megjegyzések

  • A beállítások módosítása előtt olvassa el az MS-DOS alapú program dokumentációját.
  • Ez a lehetőség csak egyes MS-DOS alapú programok esetén áll rendelkezésre.
  • Ha egy MS-DOS alapú programhoz létrehoz egy programinformációs fájlt (PIF fájlt), egy parancsikon jön létre a végrehajtható programhoz. A parancsikon a PIF fájlba mentett minden beállítást tartalmaz. A Windows 2000 a PIF fájlokat parancsikonként jeleníti meg.


Billentyűparancsok megadása

Billentyűparancsok megadása egy programhoz

  1. Nyissa meg a Sajátgép ablakot.
  2. Keresse meg a programfájlt (.exe) vagy a program parancsikonját. Kattintson a jobb oldali egérgombbal a programfájlra vagy a parancsikonra, majd kattintson a Tulajdonságok parancsra.
  3. MS-DOS program esetén kattintson a Program fülre, Windows program esetén pedig kattintson a Parancsikon fülre.
  4. Miközben a kurzor a Billentyűparancs mezőben van, válassza ki azt a billentyűt, amelyet a CTRL+ALT billentyűkkel együtt kíván használni. A billentyűparancsok automatikusan a CTRL+ALT billentyűkombinációval kezdődnek. A Billentyűparancs mezőben mindaddig a Nincs érték látható, amíg ki nem választott egy billentyűt; ekkor a mezőben megjelenik a Ctrl+Alt+ a kiválasztott billentyű. Az ESC, ENTER, TAB, SZÓKÖZ, PRINT SCREEN, SHIFT és BACKSPACE billentyűk nem használhatók.

Megjegyzések

  • A művelet végrehajtása előtt olvassa el a program dokumentációjában, hogy a program használ-e billentyűparancsokat.
  • Miután hozzárendelt egy billentyűparancsot egy adott programhoz, ez a billentyűparancs már nem használható más programokban. A Windows 2000 által használt összes billentyűparancs megtalálható a Kapcsolódó témakörökben.
  • Ha elfelejti a parancsikonhoz tartozó billentyűkombinációt, hajtsa végre a 2. és 3. lépést, és nézze meg a billentyűparancsot.
  • Billentyűparancsokkal a programok sok esetben gyorsabban megnyithatók, mint mutatóeszközzel, különösen hordozható számítógép használata esetén.


MS-DOS programok megnyitása a parancssorablakból

  2. Írja be a megnyitni kívánt MS-DOS alapú program nevét, majd nyomja meg az ENTER billentyűt.

Megjegyzések

  • A teljes képernyőn és az ablakban történő megjelenítés között az ALT+ENTER billentyűkombinációval lehet váltani.
  • Egy parancssori munkamenet befejezéséhez a parancssorablakba írja be az exit parancsot.


Két parancsikon létrehozása egy MS-DOS programhoz

  1. Nyissa meg a Sajátgép ablakot.
  2. Keresse meg a módosítani kívánt MS-DOS alapú programot (.exe fájlt), illetve a hozzá tartozó programinformációs fájlt (.pif fájlt) vagy parancsikont.
  3. Kattintson a fájlra a jobb oldali egérgombbal, majd kattintson a Parancsikon létrehozása parancsra. Hozzon létre két parancsikont az MS-DOS programhoz, és mindegyiknek adjon különböző nevet. Ha már létezik egy parancsikon, az újat mentse más néven.
  4. Tanulmányozza az MS-DOS alapú program dokumentációját a Tulajdonságok párbeszédpanelen meghatározandó beállításokkal kapcsolatban.

Megjegyzés

  • Ha egy MS-DOS alapú programhoz több különböző PIF fájlt hoz létre, a program különböző beállításokkal indítható; ezek a beállítások a program parancsikonnal történő indítása esetén automatikusan érvénybe lépnek.


PIF fájlok - áttekintés

Ha egy MS-DOS alapú program tulajdonságait módosítja, vagy egy parancsikont hoz létre, egy programinformációs fájl (PIF fájl) jön létre. A PIF fájlok lehetővé teszik az MS-DOS programok alapértelmezett tulajdonságainak, például a betűtípus méretének, a képernyőszíneknek és a memóriakiosztásnak a meghatározását.

Ha egy MS-DOS alapú program bármely beállítását módosítja, automatikusan létrejön egy PIF fájl. A megadott beállítások akkor lépnek érvénybe, ha a programot az ikonjára történő dupla kattintással elindítja. Ha a programot a parancssorablakból indítja, ezek a beállítások nem lesznek érvényben.

Ha egy MS-DOS alapú programhoz létrehoz egy programinformációs fájlt (PIF fájlt), egy parancsikon jön létre a végrehajtható programhoz. A parancsikon a PIF fájlba mentett minden beállítást tartalmaz. A Windows 2000 a PIF fájlokat parancsikonként jeleníti meg.