Windows Script Host példák letöltése

  1. A Microsoft webhelyen keresse meg a Windows Script Technologies webhelyet (http://www.microsoft.com/), kattintson a Windows Script Host, Samples, Download the samples hivatkozásokra, majd a Fájl letöltése párbeszédpanelen kattintson az OK gombra.
  2. A Mentés másként párbeszédpanelen válassza ki azt a mappát, ahova menteni akarja a példafájlokat, majd kattintson a Mentés gombra.
  3. Nyissa meg a Sajátgép ablakot, nyissa meg azt a mappát, amelybe a samples.exe fájlt mentette, majd a parancsfájlpéldák kibontásához kattintson duplán a fájlra.
  4. Az Unzip To Folder mezőbe írja be azt az elérési útvonalat, ahová a parancsfájlpéldákat menteni akarja, majd kattintson az Unzip gombra.

Kapcsolódó témakörök


A Windows Script Host objektummodell

A Windows Script Host objektummmodell az ActiveX-illesztők két fő kategóriáját biztosítja:

Parancsfájl-végrehajtás és hibakeresés

A parancsfájl-végrehajtáshoz közvetlenül kapcsolódó tulajdonságok és metódusok. Az illesztők e csoportja lehetővé teszi a parancsfájlok számára a Windows Script Host alapvető módosítását, a képernyőn üzenetek megjelenítését, valamint olyan alapvető műveletek végrehajtását, mint a CreateObject és a GetObject.

Segítő funkciók

Olyan műveletekhez tartozó tulajdonságok és metódusok, mint például a hálózati meghajtók , nyomtatók csatlakoztatása, környezeti változók olvasása és módosítása, valamint a rendszerleíró adatbázis kulcsainak módosítása. A rendszergazdák a Windows Script Host segítő funkcióit bejelentkezési parancsfájlok létrehozására is használhatják.

A Windows Script Host által biztosított objetumillesztőkön kívül a rendszergazdák bármilyen ActiveX-vezérlőt használhatnak, amely lehetővé teszi az automatizálási illesztők használatát a Windows platform különböző műveleteinek végrehajtására. Például a rendszergazdák írhatnak olyan parancsfájlokat, amelyek az Active Directory címtárszolgáltatásokat kezelik.

További tudnivalókért látogassa meg a Windows Script Technologies webhelyet a Microsoft webhelyen (http://www.microsoft.com/).


Windows Script Host – áttekintés

A Windows Script Host lehetővé teszi parancsfájlok közvetlen futtatását Windows 2000 operációs rendszerben a Windows Asztalon levő parancsfájlra történő kattintással, vagy a parancsfájl nevének parancssorba történő beírásával. A Microsoft Internet Explorer programhoz hasonlóan a Windows Script Host az ActiveX parancsfájl-feldolgozók vezérlésére szolgál. Az Internet Explorer programmal ellentétben a Windows Script Host memóriaigénye nagyon alacsony, és egyaránt ideális az interaktív és a nem interaktív parancsfájlok (például a bejelentkezési vagy adminisztrációs parancsfájlok) létrehozásához.

A Windows Script Host támogatja a Visual Basic Scripting Edition (VBScript) vagy Jscript nyelveken írt parancsfájlok használatát. A parancsfájlt a Windows Asztalról vagy a parancssorból történő elindításakor a parancsfájlfuttató beolvassa és átadja a megadott parancsfájl tartalmát a regisztrált parancsfálj-feldolgozónak. A parancsfájl-feldolgozó a fájlkiterjesztések (.vbs VBScript esetén; .js Jscript esetén) alapján, és nem a (a HTML-ben szokásos) SCRIPT címke alapján azonosítja a parancsfájlokat. Így a parancsfájl készítőjének nem kell ismernie a különböző parancsfájl-feldolgozók pontos programazonosítóját (ProgID). A parancsfájlfuttató fenntart egy táblázatot a parancsfájl-kiterjesztések programazonosítókká (ProgID) történő leképezéséhez, és a Windows hozzárendelési modell segítségével indítja el az adott parancsfájlhoz tartozó feldolgozót.

Kétféle Windows Script Host létezik: egy windows alapú verzió (wscript.exe), amelyben windows alapú tulajdonságlapokon állíthatók be a parancsfájl tulajdonságai, és egy parancssor alapú verzió, (cscript.exe), amelyben parancssori kapcsolókkal állíthatók be a parancsfájl tulajdonságai. Ezek a wscript.exe vagy a cscript.exe parancssorba történő beírásával futtathatók.

Régebben a Windows operációs rendszer által támogatott egyetlen natív parancsfájlnyelv az MS-DOS parancsnyelv volt. Bár az MS-DOS kicsi és gyors, a VBScripthez és a Jscripthez hasonlítva csak korlátozott szolgáltatásokkal rendelkezik. Manapság az ActiveX parancsfájl-architektúra lehetővé teszi ezeknek a hatékony parancsnyelveknek a kihasználását, miközben az MS-DOS parancsnyelv továbbra is használható.

További tudnivalókért látogassa meg a Windows Script Technologies webhelyet a Microsoft webhelyen (http://www.microsoft.com/).


Parancsfájlok futtatása a parancssor alapú parancsfájl-futtató (cscript.exe) segítségével

  • Írja be következő parancsot a parancssorba:

    cscript [parancsfájl neve] [parancsfájl-futtató paraméterei] [parancsfájl-paraméterek]

    Ahol:

    a parancsfájl neve a parancsfájlnak a neve kiterjesztéssel és az elérési út szükséges adataival együtt.

    a parancsfájl-futtató paraméterei azok a parancssori kapcsolók, amelyek segítségével be- vagy kikapcsolhatók az egyes Windows Script Host tulajdonságok. A parancsfájl-futtató paramétereket mindig két ferde vonalnak (//) kell megelőznie.

    A parancsfájl-paraméterek a parancsfájlnak átadni kívánt parancssori kapcsolók. A parancsfájl-paramétereket mindig egy ferde vonalnak (/) kell megelőzie.

Megjegyzések

  • A paraméterek megadása nem kötelező, de a parancsfájl-paraméterek a parancsfájl megadása nélkül nem adhatók meg. Ha nem ad meg parancsfájlt vagy egyetlen parancsfájl-paramétert sem, a Cscript.exe program a szintaxist és az érvényes paramétereket jeleníti meg.
  • A parancssor alapú Cscript.exe programmal az alábbi paraméterek használhatók:
    Paraméter | Művelet
    //B | A kötegelt módot jelenti, amelyben nem jelennek meg figyelmeztetések, hibák és beviteli kérdések.
    //D | Bekapcsolja a hibakeresést.
    //E:futtató | Megadja a parancsfájl futtatásához használni kívánt parancsfájlnyelvet.
    //H:cscript vagy //H:wscript | A Cscript.exe vagy a Wscript.exe program beállítása a parancsfájlok futtatásához használt alapértelmezett programként. Ha egyik sincs megadva, akkor a Wscript.exe az alapértelmezett.
    //I | Az interaktív módot jelenti, amelyben megjelennek a figyelmeztetések, a hibák és a beviteli kérdések. Ez az alapértelmezett beállítás. A //B ellentéte.
    //Job:xxxx | Futtatja a megadott feladatot.
    //Logo | A futtatáskor megjelenő fejlécet határozza meg. Ez az alapértelmezett beállítás. A //Nologo ellentéte.
    //Nologo | Megadja, hogy futtatáskor ne jelenjen meg fejléc.
    //S | Menti a felhasználó aktuális parancssori beállításait.
    //T:nnnnn | Megadja azt a leghosszabb időtartamot másodpercben, ameddig a parancsfájl futhat. Legfeljebb 32 767 másodperc adható meg. Alapértelmezés szerint nincs időkorlát.
    //X | Elindítja a parancsfájlt a hibakeresőben.
    //? Megjeleníti a rendelkezésre álló parancssori paramétereket és segítséget nyújt a használatukhoz (a Cscript.exe parancs paraméterek és parancsfájl nélküli megadásával egyenértékű).
  • Az időkorlát (//T:nnnnn) paraméterrel beállítható időzítő segítségével megelőzhető a parancsfájl túl hosszú végrehajtási ideje. Ha a végrehajtási idő túllépi a megadott értéket, az IActiveScript::InterruptThread metódus segítségével a Cscript.exe megszakítja a parancsfájl-futtatót, és leállítja a folyamatot.
  • A Windows Script Host lehetővé teszi .ws parancsfájlok létrehozását is. A .ws parancsfájlok használata esetén több parancsfájl-futtató hívható meg és több feladat hajtható végre egyetlen fájlból. További tudnivalók ezekről a fájlokról a Microsoft webhely Windows Script Technologies webhelyén található (http://www.microsoft.com/).


Parancsfájlok futtatása a Windows alapú parancsfájl-futtató (Wscript.exe) segítségével

  1. A parancssorba vagy a Futattás párbeszédpanelbe írja be a következőt:

    wscript.exe

    majd kattintson az OK gombra vagy nyomja le az ENTER billentyűt.

  2. Állítsa be a parancsfájl-futtató tulajdonságait, majd kattintson az OK gombra.
  3. A Windows Intézőben vagy a Sajátgép ablakban kattintson duplán a futtatni kívánt parancsfájl nevére.

Megjegyzések

  • Ha egy olyan parancsfájlra kattint duplán, amelynek a kiterjesztése még nincs társítva a wscript.exe programmal, megjelenik a Társítás párbeszédpanel, ahol beállítható a fájl megnyitásához használni kívánt program. A Windows alapú Script Host (wscript.exe) elem kiválasztása után Az ilyen típusú fájlok megnyitása mindig ezzel jelölőnégyzet bejelölése esetén alapértelmezés szerint a rendszer minden ilyen kiterjesztésű fájlt a wscript programmal társít össze. Ha például a chart.vbs fájl futtatása esetén jelöli be ezt a jelölőnégyzetet, akkor a wscript.exe program lesz minden .vbs kiterjesztésű fájl alapértelmezett alkalmazása.
  • A wscript.exe tulajdonságok lapján a wscript.exe által a helyi számítógépen futtatott minden parancsfájlra vonatkozó globális parancsfájl-tulajdonságok állíthatók be. Az egyes parancsfájlokhoz külön-külön is beállíthatók a tulajdonságok. Ezzel kapcsolatban tanulmányozza a Kapcsolódó témaköröket.
  • Egy parancsfájl tulajdonságai úgy is beállíthatók, ha a Windows Intézőben vagy a Sajátgép ablakban a jobb oldali egérgombbal a fájl nevére kattint, kiválasztja a Tulajdonságok parancsot, majd a Parancsfájl fülre kattint.
  • A Windows Script Host lehetővé teszi .ws parancsfájlok létrehozását is. A .ws parancsfájlok használata esetén több parancsfájl-futtató hívható meg és több feladat hajtható végre egyetlen fájlból. További tudnivalók ezekről a fájlokról a Microsoft webhely Windows Script Technologies webhelyén található (http://www.microsoft.com/).


A Windows Script Host példák futtatása

  1. Kattintson a Start menüre, mutasson a Programok, majd Kellékek pontra, végül kattintson a Parancssor parancsra.
  2. Írja be következő parancsot a parancssorba:

    cscript példák_mappája\parancsfájl_neve

    Ahol:

    a példák_mappája annak a mappának az elérési útvonala, amelybe a példákat letöltötte.

    a parancsfájl_neve a futtatni kívánt parancsfájlnak a neve (kiterjesztéssel együtt, például .js vagy .vbs).

    Ha például a példákat a C:\Példák mappába mentette, és a Network.vbs példát akarja futtatni, akkor a következő parancsot kell beírnia:

    cscript c:\példák\network.vbs

Megjegyzések

  • A Windows Script Host példafájlok futtatásához azokat először le kell tölteni a Microsoft webhelyről.
  • A wscript.exe parancsfájl-futtatóval úgy is futtatható egy parancsfájlpélda, ha duplán kattint a fájlra.


Adott parancsfájl tulajdonságainak beállítása

  1. A Windows Intézőben vagy a Sajátgép ablakban kattintson a jobb oldali egérgombbal arra a parancsfájlra, amelynek az egyedi tulajdonságait be akarja állítani, majd kattintson a Tulajdonságok parancsra.
  2. Kattintson a Parancsfájl fülre, állítsa be a parancsfájlhoz használni kívánt beállításokat, majd kattintson az OK gombra.

Megjegyzések

  • A tulajdonság beállításait .wsh kiterjesztésű fájlba menti a rendszer. Például ha a parancsfájl neve Chart.vbs, a beállításokat a Chart.wsh nevű szövegfájlba menti a rendszer.
  • A .wsh fájl olyan szövegfájl, amelynek formátuma hasonlít az .ini fájlok formátumára. A .wsh fájl tartalmaz egy [ScriptFile] bekezdést, amely azonosítja a parancsfájlt, amelyhez a .WSH fájl tartozik, és egy [Options] bekezdést, amely alatt a Parancsfájl oldalon kiválasztott beállítások találhatók.
  • A .wsh fájl a régebbi 16-bites alkalmazások futtatásához használt .pif fájlokhoz hasonlít. A futtatható vagy parancsfájlokkal megegyező módon kezelhető. Például ha a saját.vbs nevű fájlhoz létrehozta a saját.wsh nevű .wsh fájlt, akkor a saját.vbs a saját.wsh fájlban beállított értékekkel való futtatásához a Windows Intézőben kattintson duplán a saját.wsh fájlra, vagy adja meg a saját.wsh fájlt a Cscript.exe vagy a Wscript.exe program argumentumaként a parancssorban vagy a Futtatás párbeszédpanelen.