Windows Installer

A Windows Installer leegyszerűsíti a szoftver telepítésének és eltávolításának folyamatát, és segítségével könnyen módosíthatók, javíthatók és meghirdethetők a meglevő alkalmazások.

  • A Windows Installer használata előtt tanulmányozza a következő témakört: Feladatlista: A Windows Installer beállítása.
  • A Windows Installer használatával kapcsolatos tippek találhatók a Gyakorlati tanácsok című fejezetben.
  • Adott feladattal kapcsolatos tudnivalókért tanulmányozza az Útmutató című témakört.
  • Általános alapismeretekkel kapcsolatos tudnivalókért tanulmányozza a Fogalmak című témakört.
  • Problémamegoldással kapcsolatos útmutatásért tanulmányozza a Hibaelhárítás című témakört.


Feladatlista: A Windows Installer beállítása

Lépés | Forrásmunkák
Áttekinti a Szoftver telepítése beépülő modullal, a Csoportházirend beépülő modullal és az Active Directory címtárral kapcsolatos alapvető fogalmakat. | Active Directory – felhasználók és számítógépek; Csoportházirend – áttekintés; Szoftver telepítése
Csoportházirend létrehozása a szervezetben | Feladatlista: Csoportházirend megvalósítása az Active Directory címtárban
Indítsa el a Csoportházirend beépülő modult, majd alkalmazza arra a helyre, tartományra vagy szervezeti egységre, amely az adott felhasználókat és számítógépeket tartalmazza. | Csoportházirend indítása; A Csoportházirend beépülő modul indításának módjai
Szerezze be a szoftver Windows Installer csomagjait (.msi). | Forduljon a szoftverforgalmazóhoz
Indítsa el a Szoftver telepítése beépülő modult. | A Szoftver telepítése beépülő modult elindítása


Gyakorlati tanácsok

  • Alkalmazáskategóriák létrehozása a vállalat számára.
    A kategóriák révén a felhasználók könnyebben megtalálhatják a kívánt alkalmazást a Vezérlőpult Programok telepítése/törlése segédprogramjában. Létrehozhatók olyan kategóriák, mint például Értékesítési alkalmazások, Számviteli alkalmazások stb. További tudnivalókért tanulmányozza a Kategóriák létrehozása a telepíteni kívánt alkalmazásokhoz című témakört.
  • Nem feledje, hogy az átalakító fájlokat a központi telepítéskor alkalmazza a rendszer.
    Az átalakító, más néven .mst fájlok valójában a Windows Installer csomagokra alkalmazott egyedi beállítások. A rendszer az átalakító fájlt a telepítésre való kijelöléskor vagy a közzététel végrehajtásakor alkalmazza, nem pedig a telepítés ideje alatt. Éppen ezért fontos, hogy a felhasználó az OK gombra kattintás előtt ellenőrizze, hogy a csomag tulajdonságai párbeszédpanel Módosítások lapján a kívánt beállítások szerepelnek-e. Ha ezt elmulasztja, azaz központi telepítést hajt végre egy helytelenül átalakított csomagon, a szoftver eltávolítása után újra telepítenie kell azt, vagy helyesen átalakított verzióra kell frissítenie a szoftvert. Ennek végrehajtásával kapcsolatos további tudnivalókért tanulmányozza a Kezelt alkalmazás eltávolítása és a Kezelt alkalmazás frissítése című témakört.
  • Telepítési csomag csoportházirend-objektumként csak egyszer jelölhető ki telepítésre vagy tehető közzé.
    A Windows Installer csomag csak egyszer jelölhető ki telepítésre, vagy tehető közzé ugyanabban a csoportházirend-objektumban. Például ha a csoportházirend-objektum hatálya alá tartozó számítógépekhez hozzárendeli a Microsoft Office alkalmazást, akkor az objektum hatálya alá tartozó felhasználókhoz már nem rendelheti hozzá vagy nem teheti közzé ugyanazt az alkalmazást.
  • A szerkesztőeszközök által biztosított előnyök kihasználása.
    A fájlokat, rendszerleíróadatbázis-bejegyzéseket és az alkalmazás megfelelő működéséhez szükséges más követelményeket ismerő fejlesztők számára számos szoftverforgalmazó által készített szerkesztőeszköz áll rendelkezésre a natív Windows Installer csomagok létrehozásához.
  • Meglevő szoftver újracsomagolása.
    A natív .msi kiterjesztésű fájlokat nem tartalmazó szoftverek Windows Installer csomagjai kereskedelmi forgalomban beszerezhető eszközök használatával létrehozhatók. Ezek az eszközök összehasonlítják a számítógép telepítés előtti és utáni állapotát. A legjobb eredmény elérése érdekében a szoftvert olyan számítógépre érdemes telepíteni, amely nem tartalmaz más alkalmazást (tiszta telepítés).
  • A System Management Server és a Dfs használata.
    A Microsoft Systems Management Server és a Windows 2000 elosztott fájlrendszere (Dfs) hasznos eszköz a szoftverterjesztési pontok (SPD) kezeléséhez. Szoftverterjesztési pontnak nevezik azt a hálózati megosztást, amelyről a felhasználók a kezelt szoftvereket telepítik.
  • Telepítésre kijelölés és közzététel az Active Directory hierarchia magasabb szintjén.
    Az alkalmazások terjesztése a vállalaton belül az öröklődés segítségével. A csoportházirend-objektum biztonsági leíróival (hozzáférés-szabályozási bejegyzéseivel – ACE) a szoftvert fogadó személyek vagy számítógépek hatékonyabban meghatározhatók. További tudnivalókért tanulmányozza a Biztonsági csoportok használata a csoportházirend szűrésére című témakört.

    Megjegyzések

    • A Hitelesített felhasználók csoportba tartozó felhasználók számára a szoftverterjesztési pontból való telepítéshez szükséges az Olvasás és a Csoportházirend alkalmazása hozzáférés-szabályozási bejegyzés (ACE).
    • A Rendszergazdák csoportba tartozó felhasználóknak a szoftverek kezeléséhez Teljes hozzáférés engedéllyel kell rendelkezniük.
  • A Szoftvertelepítési tulajdonságok használata a széleskörű ellenőrzéshez.
    A Csoportházirend konzolon kattintson a jobb oldali egérgombbal a Szoftver telepítése csomópontra, majd a helyi menüben kattintson a Tulajdonságok parancsra.

    Helye:

    • vonatkozó csoportházirend neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftver telepítése
    • Így leegyszerűsíthető az egyetlen csoportházirend-objektumban található, hasonló tulajdonságokkal rendelkező, nagy számú csomag közzétételével és telepítésre kijelölésével járó felügyeleti folyamat – például az ugyanabból a szoftverterjesztési pontból származó teljes szoftver közzétételekor.
  • Finomhangolás a Windows Installer csomag tulajdonságainak segítségével.
    Az előzőekben bemutatott módon lépjen a Szoftver telepítése csomópontra, a részletek ablaktáblán a jobb oldali egérgombbal kattintson a csomagra, majd kattintson a Tulajdonságok parancsra. Ezt a műveletet egyetlen csomag telepítésre kijelölése vagy közzététele esetén érdemes használni.


Útmutató

  • A Windows Installer csomagok használata a Windows Intézővel
  • A Windows Installer csomagok használata a Programok telepítése/törlése segédprogrammal
  • A Windows Installer használata a parancssorból
  • A Windows Installer csoportházirendjének beállítása


A Windows Installer csomagok használata a Windows Intézővel

  1. Nyissa meg a Windows Intéző ablakot.
  2. Kattintson a jobb oldali egérgombbal a Windows Installer csomagra (.msi fájl), majd kattintson a Telepítés, Javítás vagy Eltávolítás parancsok egyikére.

Megjegyzés

  • A Windows Intéző megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Windows Intéző parancsra.

Kapcsolódó témakörök


A Windows Installer csomagok használata a Programok telepítése/törlése segédprogrammal

  1. Nyissa meg a Programok telepítése/törlése segédprogramot a Vezérlőpulton.
  2. Kattintson a Programok módosítása vagy eltávolítása lapra, majd a módosítani vagy eltávolítani kívánt programra.
  3. A program módosításához kattintson a Módosítás gombra.
  4. A program eltávolításához kattintson az Eltávolítás gombra.

Megjegyzés

Kapcsolódó témakörök


A Windows Installer használata a parancssorból

  • Csomag telepítése a parancssorból
  • Csomag eltávolítása a parancssor használatával
  • Csomag javítása a parancssor használatával
  • Csomag meghirdetése a parancssor használatával
  • Felügyeleti telepítőcsomag létrehozása a parancssorból
  • Telepítési naplófájl létrehozása a parancssorból


Csomag telepítése a parancssorból

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssor ablakába írja be az msiexec /i [csomag|termékkód] parancsot, majd nyomja meg az ENTER billentyűt.

    3. Ahol:

    csomag – a Windows Installer csomagfájl neve.

    termékkód – a Windows Installer csomag globálisan egyedi azonosítója (GUID).

Megjegyzések

  • A parancssor ablakának megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.
  • A Windows Installer parancssori kapcsolói kis- és nagybetűkkel is írhatók.
  • A parancssori beállításokkal kapcsolatos további tudnivalókért kattintson a Kapcsolódó témakörökre.

Kapcsolódó témakörök


Csomag eltávolítása a parancssor használatával

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssor ablakába írja be az msiexec /x [csomag|termékkód] parancsot, majd nyomja meg az ENTER billentyűt.

    3. Ahol:

    csomag – a Windows Installer csomagfájl neve.

    termékkód – a Windows Installer csomag globálisan egyedi azonosítója (GUID).

Megjegyzések

  • A parancssor ablakának megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.
  • A Windows Installer parancssori kapcsolói kis- és nagybetűkkel is írhatók.
  • A parancssori beállításokkal kapcsolatos további tudnivalókért kattintson a Kapcsolódó témakörökre.

Kapcsolódó témakörök


Csomag javítása a parancssor használatával

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssor ablakába írja be az msiexec /f[p][o][e][d][c][a][u][m][s][v] {csomag|termékkód} parancsot, majd nyomja meg az ENTER billentyűt.

    3. Ahol:

    /f – az alábbi egy vagy több parancssori beállítást engedélyezi:

    p – újratelepítés csak hiányzó fájl esetén.

    o – újratelepítés hiányzó fájl vagy telepített régi verzió esetén.

    e – újratelepítés hiányzó fájl vagy telepített azonos vagy régebbi verzió esetén.

    d – újratelepítés hiányzó fájl vagy telepített különböző verzió esetén.

    c – újratelepítés hiányzó fájl vagy a tárolt ellenőrzőösszeg és a kiszámított érték különbözősége esetén.

    a – valamennyi fájl újratelepítése.

    u – az összes szükséges, felhasználófüggő rendszerleíróadatbázis-bejegyzés újraírása.

    m – az összes szükséges, számítógépfüggő rendszerleíróadatbázis-bejegyzés újraírása.

    s – valamennyi meglévő parancsikon felülírása.

    v – futtatás forrásból, valamint a helyi csomag ismételt gyorsítótárazása.

    csomag – a Windows Installer csomagfájl neve.

    termékkód – a Windows Installer csomag globálisan egyedi azonosítója (GUID).

Megjegyzések

  • A parancssor ablakának megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.
  • A Windows Installer parancssori kapcsolói kis- és nagybetűkkel is megadhatók.
  • A fenti parancssori beállítás alapértelmezett paramétere: /fpecms.
  • A parancssori beállításokkal kapcsolatos további tudnivalókért kattintson a Kapcsolódó témakörökre.

Kapcsolódó témakörök


Csomag meghirdetése a parancssor használatával

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssor ablakába írja be az msiexec /j[u][m] csomag parancsot, majd nyomja meg az ENTER billentyűt.

    3. Ahol:

    u – a jelenlegi felhasználó számára hirdeti meg a csomagot.

    m – a számítógép valamennyi felhasználója számára meghirdeti a csomagot.

    csomag – a Windows Installer csomagfájl neve.

Megjegyzések

  • A parancssor ablakának megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.
  • Az alkalmazás magasabb szintű rendszerjogosultságokkal való telepítéséhez használja a /jm kapcsolót.
  • A Windows Installer parancssori kapcsolói kis- és nagybetűkkel is megadhatók.
  • A parancssori beállításokkal kapcsolatos további tudnivalókért kattintson a Kapcsolódó témakörökre.

Kapcsolódó témakörök


Felügyeleti telepítőcsomag létrehozása a parancssorból

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssor ablakába írja be az msiexec /a csomag parancsot, majd nyomja meg az ENTER billentyűt.

    3. Ahol:

    csomag – a Windows Installer csomagfájl neve.

Megjegyzések

  • A parancssor ablakának megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.
  • A Windows Installer parancssori kapcsolói kis- és nagybetűkkel is írhatók.
  • A parancssori beállításokkal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Telepítési naplófájl létrehozása a parancssorból

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssor ablakába írja be az msiexec /i csomag [/L][i][w][e][a][r][u][c][m][p][v][+][!] naplófájl.txt parancsot, majd nyomja meg az ENTER billentyűt.

    3. Ahol:

    csomag – a Windows Installer csomag neve

    /L – a naplóadatokat jelzi. Az alábbi jelzők határozzák meg, mely adatokat rögzíti a parancs a naplóba:

    i – állapotüzenetek

    w – nem súlyos hibára utaló figyelmeztetések

    e – valamennyi hibaüzenet

    a – műveletek indítása

    r – műveletfüggő bejegyzések

    u – felhasználói kérelmek

    c – felhasználói felület kezdeti paraméterei

    m – kevés memória

    p – Termináltulajdonságok

    v – részletes kimenet

    + – hozzáfűzés meglévő fájlhoz

    ! – minden sor hozzáadása a naplóhoz

    * – helyettesítő karakter: a v kapcsoló által megadott adatok kivételével minden adat naplózása.

    naplófájl.txt – a szöveges naplófájl neve és elérési útvonala.

Megjegyzések

  • A parancssor ablakának megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.
  • A Windows Installer parancssori kapcsolói kis- és nagybetűkkel is megadhatók.
  • Ha kapcsolóként a helyettesítő karakter használata esetén a v kapcsolóhoz tartozó adatokat is naplózni kívánja, akkor a parancssorba a következő parancsot írja be: /L*v.
  • A Windows Installer naplófájl-beállításai az eltávolítási és helyreállítási folyamatban is használhatók.
  • A parancssori beállításokkal kapcsolatos további tudnivalókért kattintson a Kapcsolódó témakörökre.

Kapcsolódó témakörök


A Windows Installer csoportházirendjének konfigurálása

  • A Windows Installer csoportházirend számítógéppel kapcsolatos beállításainak megadása
  • A Windows Installer csoportházirend felhasználókkal kapcsolatos beállításainak megadása


A Windows Installer csoportházirend számítógéppel kapcsolatos beállításainak megadása

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A konzolfán kattintson a Windows Installer csomópontra.

    3. Helye:

    • vonatkozó csoportházirend neve
    • Számítógép konfigurációja
    • Felügyeleti sablonok
    • Windows-összetevők
    • Windows Installer
  3. A részletek ablaktáblán kattintson duplán az alábbi házirendek egyikére:
    • A Windows Installer letiltása
    • Telepítés mindig magasabb szintű rendszerjogosultságokkal
    • Új forrás tallózásának letiltása
    • Javítások telepítésének letiltása
    • A Windows Installer parancsfájlokra vonatkozó IE biztonsági kérdés letiltása
    • Telepítések vezérlésének engedélyezése felhasználó számára
    • Naplózás
  4. A Csoportházirend tulajdonságai párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra.

Megjegyzések

  • A Windows Installer csoportházirend számítógéppel kapcsolatos beállításairól további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Csoportházirend beépülő modul indításával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A Windows Installer csoportházirend felhasználókkal kapcsolatos beállításainak megadása

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A konzolfán kattintson a Windows Installer csomópontra.

    3. Helye:

    • vonatkozó csoportházirend neve
    • Felhasználó konfigurációja
    • Felügyeleti sablonok
    • Windows-összetevők
    • Windows Installer
  3. A részletek ablaktáblán kattintson duplán az alábbi házirendek egyikére:
    • Telepítés mindig magasabb szintű rendszerjogosultságokkal
    • Keresési sorrend
    • Visszaállítás letiltása
  4. A Csoportházirend tulajdonságai párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra.

Megjegyzések

  • A Windows Installer csoportházirend felhasználóval kapcsolatos beállításairól további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Csoportházirend indításával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Fogalmak

Ez a fejezet a Windows Installer általános bemutatását tartalmazza.

  • Windows Installer – áttekintés
  • A Windows Installer ismertetése
  • A Windows Installer használata
  • Forrásmunkák


Windows Installer – áttekintés

A Windows Installer a Windows 2000 operációs rendszer összetevőjeként leegyszerűsíti az alkalmazások telepítésének folyamatát.

A Windows Installer a telepítési folyamat során központilag megadható telepítési szabályok érvényesítésével kezeli az alkalmazások telepítését és eltávolítását. Ezek a telepítési szabályok definiálják a telepített alkalmazás telepítésének és beállításának módját. A fentieken túl ezzel a szolgáltatással a meglevő alkalmazások módosíthatók, javíthatók vagy eltávolíthatók. A Windows Installer technológia a Windows operációs rendszerek Windows Installer szolgáltatását és az alkalmazások telepítésére vonatkozó adatokat tároló csomag (.msi) fájlformátumát foglalja magában.

A Windows Installer nem csak telepítőprogram, hanem bővíthető szoftverkezelő-rendszer. A Windows Installer kezeli a szoftverösszetevők telepítését, hozzáadását és törlését, figyeli a fájlrugalmasságot, és a visszaállítási szolgáltatása révén alapvető katasztrófaelhárítási szolgáltatást biztosít. A Windows Installer támogatja a szoftverek több forrásból történő telepítését és futtatását, továbbá egyedi alkalmazások telepítéséhez a fejlesztők a Windows Installer testreszabását is elvégezhetik.


A Windows Installer ismertetése

A következő szakasz tartalma:

  • A Windows Installer szolgáltatásai
  • Windows Installer technológiák


A Windows Installer szolgáltatásai

A Windows Installer és az .msi csomagfájlformátum révén megbízhatóbbá és rugalmasabbá vált a szoftverek telepítésének és eltávolításának folyamata, és a korábbiakhoz képest több telepítési beállítás használható. A Windows Installer a következő feladatok végrehajtására használható:

  • Sikertelen telepítés esetén visszaállítja a számítógép eredeti állapotát: A Windows Installer nyomon követi az alkalmazás telepítése során a rendszerben bekövetkező változásokat. Ha a telepítés sikertelenül végződik, a Windows Installer segítségével visszaállítható a rendszer kezdeti állapota.
  • Segít elkerülni az alkalmazások közötti bizonyos ütközéseket: A Windows Installer olyan telepítési szabályokat követel meg, amelyek megakadályozzák a megosztott erőforrások miatt a meglevő alkalmazásokkal való esetlegesen ütközéseket. Ütközés akkor fordul elő, amikor a telepítési művelet frissít egy meglevő alkalmazással közösen használt dinamikus csatolású függvénytárat (.dll), vagy töröl egy alkalmazással közösen használt dinamikus csatolású függvénytárat.
  • Megbízhatóan végzi a meglevő programok eltávolítását: A Windows Installer megbízhatóan eltávolít minden olyan programot, amely telepítése a Windows Installer használatával történt. Eltávolítja a rendszerleíró adatbázis összes vonatkozó bejegyzését és az alkalmazáshoz tartozó összes fájlt, amennyiben más telepített szoftver nem használja azokat. Sikeres telepítés után bármikor eltávolítható az adott alkalmazás. (Az eltávolítást nem szabad összetéveszteni a visszagörgetéssel, amely sikertelen telepítés esetén a számítógép kiinduló állapotának visszaállítására szolgál.)
  • Megkeresi és megjavítja a sérült alkalmazások hibáit: Az alkalmazás a Windows Installer lekérdezésével meghatározhatja, hogy a telepített alkalmazáshoz megvan-e az összes szükséges fájl, illetve azok nem sérültek-e. Hiányzó vagy sérült fájl észlelése esetén a Windows Installer megjavítja az alkalmazást a hiányzó vagy sérült fájlok ismételt átmásolásával.
  • Támogatja az alkalmazások szolgáltatásainak igény szerinti telepítését: A Windows Installer beállítható úgy, hogy kezdetben az alkalmazásnak csak minimális részét telepítse. Később a többi összetevő automatikusan telepíthető, ha a felhasználó olyan szolgáltatást próbál használni, amely valamilyen hiányzó összetevő telepítését igényli. Ez az úgynevezett meghirdetés. Például a Windows Installer minimális szolgáltatáskészlettel telepítheti a Microsoft Word szövegszerkesztőt. Amikor a felhasználó először próbálja használni a körlevél funkciót (amelyet az eredeti telepítés nem tartalmaz), a Windows Installer automatikusan telepíti a körlevél összetevőt. Hasonlóképpen a Windows Installer képes az alkalmazás nem használt összetevőinek törlésére is. Például beállítható úgy a Windows Installer, hogy távolítsa el a körlevél összetevőt, ha azt 60 napig nem használják.
  • Támogatja az alkalmazások felügyelet nélküli telepítését: A telepítőcsomag megfelelő beállításával elérhető, hogy a telepítési folyamat felhasználói beavatkozás nélkül fusson. A telepítési folyamat során a Windows Installer a számítógéptől az Asztal attribútumainak lekérdezésével meghatározhatja, hogy korábban telepítette-e már az adott alkalmazást.


Windows Installer technológiák

A Windows Installer technológia két, egymással együttműködő részre osztható: ügyfél-oldali telepítő szolgáltatás (Msiexec.exe) és csomagfájl (.msi fájl). A Windows Installer a csomagfájlban tárolt információ használatával telepíti az alkalmazásokat.

Telepítő szolgáltatás
A Windows Installer olyan operációs rendszer szolgáltatás, amely lehetővé teszi az operációs rendszer számára a telepítési folyamat kezelését.
Telepítőprogram
Az Msiexec.exe program a Windows Installer egyik össztevője. A program egy dinamikus csatolású függvénytár, az Msi.dll révén olvassa a csomagfájlokat (.msi), alkalmazza az átalakító fájlokat (.mst) és foglalja magában a parancssori beállításokat. A telepítő valamennyi telepítéssel kapcsolatos feladatot végrehajtja: fájlok másolása a merevlemezre, a rendszerleíró adatbázis módosításainak elvégzése, parancsikonok létrehozása az Asztalon, párbeszédpanelek megjelenítése felhasználói preferenciák lekérdezésére.

A Windows Installer telepítésekor a számítógép operációs rendszerének fájltársítási képességei is megfelelően módosulnak, azaz képes lesz az .msi fájltípus felismerésére. Ha a felhasználó duplán rákattint egy .msi kiterjesztésű fájlra, az operációs rendszer az .msi fájlt a Windows Installer programhoz társítja, és futtatja az Msiexec.exe alkalmazást.

Telepítő csomagfájl
Minden egyes csomagfájl (.msi) tartalmaz egy relációs típusú adatbázist, amely a program több telepítési forgatókönyv alapján történő telepítéséhez (és eltávolításához) szükséges utasításokat és adatokat tárolja. A csomagfájl tartalmazhat például arra vonatkozó utasításokat, miként kell telepíteni egy alkalmazást, ha az alkalmazás korábbi verziója már telepítve van. A csomagfájlban tárolt utasítások azt is meghatározhatják, hogyan kell telepíteni a szoftvert olyan számítógépre, ahol az adott alkalmazás még sohasem fordult elő.

Mivel relációs adatbázisról van szó, az egyik táblában végzett módosítás automatikusan az adatbázis egészére hatással van. Ez nagyon hatékony folyamatnak bizonyul, amikor a felhasználó konzisztens módosításokat kíván bevezetni a telepítési folyamatba a nagy alkalmazások vagy alkalmazáscsoportok testreszabásának leegyszerűsítése céljából. A Windows Installer adatbázistáblák a teljes alkalmazáscsoport általános elrendezéséről adnak tájékoztatást, beleértve a következőket:

  • Rendelkezésre álló szolgáltatások
  • Összetevők
  • Szolgáltatások és összetevők közötti kapcsolatok
  • Szükséges rendszerleíró adatbázis beállítások

A Windows Installer adatbázis (.msi fájl) több egymással összekapcsolt táblából áll, amelyek együttesen valamely szolgáltatáscsoport telepítéséhez szükséges információt tároló relációs adatbázist alkotnak. A következő táblázat leírja az egymással kapcsolatban álló táblák csoportjait:

Csoport | Leírás
Fő táblacsoport | Leírja az alkalmazás és a telepítőcsomag alapvető szolgáltatásait és összetevőit.
Fájl táblacsoport | A telepítőcsomaghoz társított fájlokat tartalmazza.
Rendszerleíró adatbázis táblacsoport | A rendszerleíró adatbázis bejegyzéseket tartalmazza.
Rendszer táblacsoport | Nyomon követi a telepítési adatbázis tábláit és oszlopait.
Azonosító táblacsoport | A rendszerleíró adatbázisban, a telepítési konfigurációs adatokban, a könyvtárfában vagy .ini fájlokban megkeresi valamely fájl egyedi aláírását.
Programtelepítési csoport | Az alkalmazás telepítéséhez szükséges tulajdonságokat, bitképeket, parancsikonokat és más elemeket foglal magában.
Telepítési folyamat csoport | A telepítés során végrehajtott feladatokat kezeli szabványos és egyedi műveletek révén.
Átalakító fájlok
A telepítési folyamat átalakító fájlok (.mst) telepítési adatbázisra történő alkalmazásával kezelhető. Az átalakító fájlok az adatbázis egyes elemeit módosítják. A Windows Installer például átalakító fájlt használhat abból a célból, hogy egy alkalmazás felhasználói kezelőfelületének nyelvét megváltoztassa. A Windows Installer átalakító fájlok a telepítés során módosítják a telepítő csomagfájlokat, így dinamikus hatást gyakorolnak a telepítés folyamatára.

A testreszabást végző átalakító fájlok — a szervizcsomagokhoz hasonlóan — a számítógép gyorsítótárában maradnak. Ezek az átalakító fájlok mindannyiszor módosítják az alap csomagfájlt, valahányszor a Windows Installer konfigurációs módosítást végez a telepítőcsomagon. Az átalakító fájlok az első telepítés során érvényesülnek, már telepített alkalmazás esetében nem használhatók.


A Windows Installer használata

A következő szakasz tartalma:

  • A Windows Installer használata kezelt környezetekben
  • Parancssori beállítások
  • A számítógépre vonatkozó beállítások kezelése a csoportházirend használatával
  • A felhasználókra vonatkozó beállítások kezelése a csoportházirend használatával


A Windows Installer használata kezelt környezetekben

A Windows Installer az IntelliMirror szerves része, és legfőbb összetevője a Windows 2000 csoportházirend alapú módosítás- és konfigurációkezelési technológiájának. Az IntelliMirror szolgáltatással kapcsolatos tudnivalókért tanulmányozza az IntelliMirror című témakört.

Az IntelliMirror szolgáltatások, a Csoportházirend, valamint a módosítás- és konfigurációkezelési szolgáltatások révén a rendszergazdák jóváhagyhatnak bizonyos alkalmazásokat, azaz meghatározhatják, hogy az adott alkalmazásokra vonatkozó valamennyi konfigurációs művelet (telepítés, eltávolítás és javítás) helyi rendszerfiókként fusson. Míg a rendszergazda szabályozza és kezeli a fájlrendszert és a rendszerleíró adatbázist, a Windows Installer hajtja végre a felhasználók által kezdeményezett szoftvertelepítéseket. Csak a rendszergazda által jóváhagyott alkalmazások futnak magasabb szintű rendszerjogosultságokkal. A Csoportházirend beépülő modullal és a szoftvertelepítéssel kapcsolatos tudnivalókért tanulmányozza a A Szoftver telepítése beépülő modul használata című témakört.

A Windows Installer segítségével helyileg is elvégezhető a telepítés, illetve a Systems Management Server használata révén központilag is vezérelhető a szoftverterjesztés és -telepítés. A Csoportházirend beépülő modullal kapcsolatos további tudnivalókért tanulmányozza a Csoportházirend és A Windows Installer használata című témaköröket.

A rendszergazdák a Windows 2000 Active Directory, az IntelliMirror és a Csoportházirend beépülő modul használatával jelölnek ki és tesznek közzé alkalmazásokat a vállalaton belüli felhasználók és számítógépek csoportjai számára. Az Active Directory olyan biztonságos, elosztott, partícionált és replikált címtárszolgáltatás, amely kezelőszolgáltatásokat biztosít a felhasználók számára. Ezek a szolgáltatások magukban foglalják az erőforrások vállalaton belüli megkeresésének szabványosított módszerét, és csoportházirendek alkalmazását az Active Directory címtárban kezelt objektumok esetében. Az Active Directory címtárszolgáltatással kapcsolatos további tudnivalókért tanulmányozza az Active Directory című témakört.

A Windows Installer a szoftverek telepítésének és karbantartásának fő összetevőjeként működik az ügyfél számítógépeken. A szoftverek telepítésével kapcsolatos további tudnivalókért tanulmányozza a Szoftvertelepítés ismertetése című témakört. A Windows Installer fejlett rugalmassági szolgáltatásokat kínál a Windows 2000 Asztalra vonatkozóan, függetlenül attól, hogy az Asztal Windows 2000 kiszolgáló által kezelt környezetben helyezkedik-e el.


Parancssori beállítások

A Windows Installer parancssori szintaxisa az alábbi beállítások használatát teszi lehetővé:

Beállítás | Paraméter | Definíció
/I | {csomag|termékkód} | A termék telepítése vagy konfigurálása. Az A:\Példa.msi fájlból például a termék az alábbi parancs használatával telepíthető: msiexec /I A:\Példa.msi További tudnivalókért tanulmányozza a Csomag telepítése a parancssorból című témakört.
/a | csomag | Felügyeleti telepítés beállítása. További tudnivalókért tanulmányozza a Felügyeleti telepítőcsomag létrehozása a parancssorból című témakört.
/f | [p][o][e][d][c][a][u][m][s][v] {csomag|termékkód} | A termék javítása. Ez a beállítás figyelmen kívül hagyja parancssorból megadott összes tulajdonság értékét. p – újratelepítés csak hiányzó fájl esetén. o – újratelepítés hiányzó fájl vagy telepített régi verzió esetén. e – újratelepítés hiányzó fájl vagy telepített azonos vagy régebbi verzió esetén. d – újratelepítés hiányzó fájl vagy telepített különböző verzió esetén. c – újratelepítés hiányzó fájl vagy a tárolt ellenőrzőösszeg és a kiszámított érték különbözősége esetén. a – valamennyi fájl újratelepítése. u – az összes szükséges, felhasználófüggő rendszerleíróadatbázis-bejegyzés újraírása. m – az összes szükséges, számítógépfüggő rendszerleíróadatbázis-bejegyzés újraírása. s – az összes meglevő parancsikon felülírása. v – futtatás forrásból, valamint a helyi csomag ismételt gyorsítótárazása. Például a telepítőcsomag az alábbi parancs használatával javítható meg: msiexec /fpecms Példa.msi További tudnivalókért tanulmányozza a Csomag javítása a parancssor használatával című témakört.
/x | {csomag|termékkód} | x – termék eltávolítása. A csomag például az alábbi parancs használatával távolítható el: msiexec /x Példa.msi További tudnivalókért tanulmányozza a Csomag eltávolítása a parancssor használatával című témakört.
/j | [u|m]csomag [u|m]csomag /t átalakítási_lista [u|m]csomag /g nyelvazonosító | A termék meghirdetése. Ez a beállítás figyelmen kívül hagyja parancssorból megadott összes tulajdonság értékét. u – meghirdetés a jelenlegi felhasználó számára. m – meghirdetés a számítógép valamennyi felhasználója számára. g – nyelvazonosító. t – átalakító fájl alkalmazása a meghirdetett csomagra. A csomag például az alábbi parancs használatával hirdethető meg a számítógép összes felhasználója számára: msiexec /jm Példa.msi További tudnivalókért tanulmányozza a Csomag meghirdetése a parancssor használatával című témakört.
/L | [i][w][e][a][r][u][c][m][p][v][+][!]naplófájl | A naplófájl elérési útvonalának meghatározása. Az alábbi jelzők határozzák meg, mely adatokat rögzíti a parancs a naplóban: i – állapotüzenetek w – nem súlyos hibára utaló figyelmeztetések e – valamennyi hibaüzenet a – elindított műveletek r – műveletfüggő bejegyzések u – felhasználói kérelmek c – felhasználói felület kezdeti paraméterei m – kevés memória p – termináltulajdonságok v – részletes kimenet + – hozzáfűzés meglevő fájlhoz ! – minden sor hozzáadása a naplóhoz * – helyettesítő karakter; a v kapcsoló által megadott adatok kivételével minden adat naplózása. A v kapcsoló az /L*v kapcsoló megadásával vehető fel a parancsba. Csomag telepítéséhez vagy az állapottal, memóriahiánnyal és hibaüzenetekkel kapcsolatos adatokat tartalmazó naplófájl létrehozásához például az alábbi parancs használható: msiexec /i Példa.msi /Lime naplófájl.txt További tudnivalókért tanulmányozza a Telepítési naplófájl létrehozása a parancssorból című témakört.
/p | szervizcsomag | Szervizcsomag alkalmazása. Ha szervizcsomagot szeretne telepített felügyeleti programkódra alkalmazni, a beállításokat az alábbi módon kell használnia: /p - szervizcsomag /a - csomag Szervizcsomag az alábbi szintaxis használatával alkalmazható felügyeleti telepítési programkódra: msiexec /p <szervizcsomag> /a Példa.msi
/q | {n|b|r|f} | A felhasználói felület szintjének beállítása. qn – nincs felhasználói felület. qb – alapszintű felhasználói felület. qr – csökkentett szintű felhasználói felület, a telepítés végén megjelenő modális párbeszédpanellel. qf – teljes felhasználói felület, a telepítés végén megjelenő modális párbeszédpanellel. qn+ – nincs felhasználói felület, viszont telepítés végén megjelenik egy modális párbeszédpanel. qb+ – alapszintű felhasználói felület, a telepítés végén megjelenő modális párbeszédpanellel. qb- – alapszintű felhasználói felület modális párbeszédpanel nélkül. Megjegyzés: a /qb+- felhasználói felületi szint használatát nem támogatja a rendszer. A modális párbeszédpanel nem jelenik meg, ha a felhasználó megszakítja a telepítést. Például a csomag telepítése közben az alapszintű felhasználói felületi beállítások a következő paranccsal használhatók: msiexec /qb Példa.msi
/? vagy /h | nincs | A Windows Installer szerzői jogi információinak megjelenítése. ? vagy h – a Windows Installer verziójának és a szerzői jogi információinak megjelenítése. A verzió és a szerzői jogi információ az alábbi parancs használatával jeleníthető meg: msiexec /?
/y | modul | y – a parancssorból indított modulok önregisztrálása érdekében meghívja a DllRegisterServer szolgáltatást (rendszer API). Például: msiexec /y saját_fájl.dll. Ez a beállítás csak olyan rendszerleíróadatbázis-adatok esetén használható, amelyek nem adhatók hozzá a rendszerleíró adatbázishoz az .msi fájl rendszerleíró tábláinak használatával.
/z | modul | z – a parancssorból indított modulok eltávolítása érdekében meghívja a DllUnRegisterServer szolgáltatást (rendszer API). Például: msiexec /z saját_fájl.dll. Ez a beállítás csak olyan rendszerleíróadatbázis-adatok esetén használható, amelyek nem távolíthatók el az .msi fájl rendszerleíró tábláinak használatával.


A számítógépre vonatkozó beállítások kezelése a csoportházirend használatával

A Windows Installer a csoportházirend vagy az Active Directory használatával beállítható a számítógépre vonatkozó telepítési beállítások kezelésére.

Az alábbi táblázat azokat a házirendeket tartalmazza, amelyek a csoportházirend Windows Installer szolgáltatásra vonatkozó számítógép-beállításainak kezelését szabályozzák. A házirendek beállításához indítsa el a Csoportházirend beépülő modult a Csoportházirend beépülő modul indítása című témakörben leírtaknak megfelelően, majd kattintson a konzolfa Windows Installer csomópontjára.

Helye:

  • vonatkozó csoportházirend neve
  • Számítógép konfigurációja
  • Felügyeleti sablonok
  • Windows Installer
Házirend Részletek
A Windows Installer letiltása Letiltja vagy korlátozza a Windows Installer használatát.

Ez a házirend megakadályozza, hogy a felhasználók szoftvert telepítsenek a rendszerre, vagy csak a rendszergazda által felkínált programok telepítését engedélyezi.

A házirend engedélyezése esetén a telepítési házirendek létrehozásához A Windows Installer letiltása panel beállításai használhatók.

Soha
A Windows Installer teljeskörűen engedélyezve van. A felhasználók szoftvereket telepíthetnek és frissíthetnek. A Windows 2000 rendszerben alapértelmezés szerint engedélyezve van a Windows Installer.
Csak nem kezelt alkalmazásokhoz
A felhasználók csak azokat a programokat telepíthetik, amelyeket a rendszergazda telepítésre kijelöl (felkínál az Asztalon) vagy közzétesz (hozzáad a Programok telepítése/törlése szolgáltatáshoz).
Mindig
A Windows Installer le van tiltva.

Megjegyzés

  • A házirend csak a Windows Installer segédprogramra vonatkozik. Nem tudja megakadályozni azt, hogy a felhasználók más módszerrel telepítsenek vagy frissítsenek programokat.
Telepítés mindig magasabb szintű rendszerjogosultságokkal A rendszerre program telepítésekor a Windows Installer rendszerengedélyeket használ.

Ez a házirend a magasabb szintű rendszerjogosultságokat kiterjeszti valamennyi programra, bár ezek a jogosultságok rendszerint csak a felhasználóhoz rendelt (Asztalon felkínált), a számítógéphez rendelt (automatikusan telepített) vagy a Vezérlőpult Programok telepítése/törlése szolgáltatásban használható programok esetén állnak rendelkezésre. A házirend lehetővé teszi, hogy a felhasználók olyan könyvtár-hozzáférési (megtekintés vagy módosítás) engedélyeket igénylő programokat telepítsenek, amelyekkel esetleg nem rendelkeznek, beleértve az erősen korlátozott hozzáférésű számítógépeken elhelyezkedő könyvtárakat is.

A házirend letiltásának vagy beállításának kihagyása esetén a rendszer a rendszergazda által nem terjesztett vagy nem felkínált programok telepítésénél a jelenlegi felhasználó engedélyeit használja.

Megjegyzés

  • Ez a házirend a Számítógép konfigurációja és a Felhasználó konfigurációja mappában egyaránt megjelenik. A házirend alkalmazásához mindkét mappában engedélyeznie kell a házirendet.
Az új forrás tallózására szolgáló panel letiltása Megakadályozza a felhasználókat abban, hogy a telepített programhoz szolgáltatások vagy összetevők hozzáadásakor telepítési fájlokat keressenek.

Ez a házirend letiltja a Windows Installer párbeszédpanel Szolgáltatás használata a következőről lista melletti Tallózás gombot. Ennek eredményeként a felhasználóknak a rendszergazda által beállított Szolgáltatás használata a következőről listáról kell kiválasztaniuk a telepítési fájlforrást.

Ez a házirend akkor is érvényben van, ha a telepítés a felhasználó biztonsági környezetében fut.

Ha letiltja vagy nem állítja be ezt a házirendet, a Tallózás gomb használható, amikor a felhasználó biztonsági környezetében fut a telepítés, de csak rendszergazdák tallózhatnak abban az esetben, ha a telepítés magasabb szintű rendszerjogosultságokkal fut, mint például az Asztalon vagy a Programok telepítése/törlése segédprogramban felkínált telepítések esetében.

A házirend csak a Windows Installer segédprogramra vonatkozik. Nem akadályozza meg a felhasználókat abban, hogy más böngészőket, például a Windows Explorer vagy a Hálózati helyek segédprogramot használják a telepítési fájlok megkereséséhez.
Javítások telepítésének letiltása Megakadályozza a felhasználókat abban, hogy a programok frissítése érdekében szervizcsomagokat telepítsenek.

A szervizcsomag olyan frissítés, amely csak a módosított programfájlokat cseréli le. Mivel a szervizcsomagok rosszindulatú programokat tartalmazhatnak, bizonyos telepítések tiltják használatukat.

Ez a házirend csak olyan telepítésekre vonatkozik, amelyek a felhasználó biztonsági környezetében futnak. Alapértelmezés szerint a nem rendszergazdai engedéllyel rendelkező felhasználók nem telepíthetnek szervizcsomagot magasabb rendszerjogosultsággal futó telepítések, például az Asztalon vagy a Programok telepítése/törlése segédprogramban felkínált telepítések esetében.
A Windows Installer parancsfájlokra vonatkozó IE biztonsági kérdés letiltása Engedélyezi a webes programok számára, hogy a felhasználó értesítése nélkül szoftvert telepítsenek a számítógépre.

Amikor az Internet-böngészőben futó parancsfájl programot kísérel telepíteni a rendszerre, a rendszer figyelmezteti a felhasználót, és lehetővé teszi a telepítés elfogadását vagy visszautasítását. Ez a házirend felfüggeszti a figyelmeztetést, és engedélyezi a telepítés folytatását.

A házirend olyan vállalatok számára készült, amelyek webes eszközökkel juttatják el programjaikat az alkalmazottakhoz. Mivel biztonsági kockázatot jelenthet, óvatosan kell bánni vele.
Telepítések vezérlésének engedélyezése felhasználó számára

Lehetővé teszi a felhasználók számára a telepítési beállítások módosítását, amit rendszerint csak rendszergazdák tehetnek meg.

Ez a házirend figyelmen kívül hagyja a Windows Installer bizonyos biztonsági szolgáltatásait. Lehetővé teszi az olyan telepítések befejezését, amelyek a biztonság megsértése miatt egyébként nem folytatódhatnának.

A Windows Installer biztonsági szolgáltatásai megakadályozzák a felhasználókat abban, hogy a rendszergazdák számára fenntartott telepítési beállításokat módosítsák, azaz maguk határozzák meg például a telepítési könyvtárat. Ha a Windows Installer észleli, hogy a telepítőcsomag lehetővé teszi a felhasználó számára valamely védett beállítás módosítását, megállítja a telepítést és hibaüzenetet jelenít meg. Ezek a biztonsági funkciók csak akkor vannak érvényben, ha a telepítőprogram kiemelt biztonsági környezetben fut, azaz a program olyan könyvtárakhoz fér hozzá, amelyek a felhasználó számára nem elérhetők.

Ennek a házirendnek a használata olyan környezetben javasolt, amelyre kevesebb korlátozás vonatkozik. Segítségével megkerülhetők a telepítőprogramnak azok a hibái, amelyek egyébként akadályozzák a szoftver sikeres telepítését.
Naplózás

A telepítés naplózásának alábbi módjai közül egy vagy több is megadható:

[i][w][e][a][r][u][c][m][p][v][o]

Meghatározza azokat az eseménytípusokat, amelyekről a Windows Installer a telepítések során bejegyzést készít a tranzakciónaplójába. Az Msi.log nevű napló a rendszerkötet Temp könyvtárában található meg.

A házirend engedélyezése esetén megadhatók azok az eseménytípusok, amelyekről a Windows Installer naplóbejegyzést készít. A rögzíteni kívánt esemény típusának kijelöléséhez írja be az eseménytípust képviselő betűt. A betűk bármilyen sorrendben és bármely mennyiségben megadhatók. A naplózás letiltásához törölje az összes betűt a panelről.

A Windows Installer lehetséges naplózási beállításai a következők:

Mód | Naplóbejegyzés
i | Állapotüzenetek
w | Nem súlyos hibára utaló figyelmeztetések
e | Minden hibaüzenet
a | Műveletek elindítása
r | Műveletfüggő bejegyzések
u | Felhasználói kérelmek
c | Felhasználói felület kezdeti paraméterei
m | Kevés a memória
p | Termináltulajdonságok
v | Részletes kimenet
o | A lemezen elfogyott helyre figyelmeztető üzenetek

Megjegyzések

  • Ha letiltja vagy nem állítja be ezt a házirendet, a Windows Installer az iweap betűkkel jelölt, alapértelmezett eseménytípusokat naplózza.
  • Ha az összes lehetséges eseményt fel kívánja venni a telepítési naplófájlba, a következő betűket kell beírnia: iwearucmpvo. Ez azonban a telepítési folyamat idejének jelentős növekedését eredményezi.


A felhasználókra vonatkozó beállítások kezelése a csoportházirend használatával

A Windows Installer a csoportházirend vagy az Active Directory segítségével beállítható a felhasználókra vonatkozó telepítési beállítások kezelésére.

Az alábbi táblázat azokat a házirendeket tartalmazza, amelyek a csoportházirend a Windows Installer szolgáltatásra vonatkozó felhasználói beállításainak kezelését szabályozzák. A házirendek beállításához indítsa el a Csoportházirend beépülő modult a Csoportházirend beépülő modul indítása című témakörben leírtaknak megfelelően, majd kattintson a konzolfa Windows Installer csomópontjára.

Helye:

  • vonatkozó csoportházirend neve
  • Felhasználó konfigurációja
  • Felügyeleti sablonok
  • Windows Installer
Házirend Részletek
Telepítés mindig magasabb szintű rendszerjogosultságokkal A Windows Installer rendszerengedélyeket használ, amikor programot telepít a rendszerre.

Ez a házirend a magasabb szintű rendszerjogosultságokat kiterjeszti valamennyi programra, bár ezek a jogosultságok rendszerint csak a felhasználóhoz rendelt (Asztalon felkínált), a számítógéphez rendelt (automatikusan telepített) vagy a Vezérlőpult Programok telepítése/törlése szolgáltatásban használható programok esetén állnak rendelkezésre. A házirend lehetővé teszi, hogy a felhasználók olyan könyvtár-hozzáférési (megtekintés vagy módosítás) engedélyeket igénylő programokat telepítsenek, amelyekkel esetleg nem rendelkeznek, beleértve az erősen korlátozott hozzáférésű számítógépeken elhelyezkedő könyvtárakat is.

A házirend letiltása vagy beállításának kihagyása esetén a rendszer a rendszergazda által nem terjesztett vagy nem felkínált programok telepítésénél a jelenlegi felhasználó engedélyeit használja.

Megjegyzés

  • Ez a házirend a Számítógép konfigurációja és a Felhasználó konfigurációja mappában egyaránt megjelenik. A házirend alkalmazásához mindkét mappában engedélyeznie kell a házirendet.
Keresési sorrend

A keresési sorrend alábbi beállításai közül egy vagy több is megadható:
[n][m][u]

 Megadja azt a sorrendet, amely alapján a Windows Installer a telepítési fájlokat keresi.

Alapértelmezés szerint a Windows Installer először a hálózaton keres, majd a cserélhető adathordozókat (hajlékonylemez, CD-ROM vagy DVD), végül az Internetet (URL) ellenőrzi.

A keresési sorrend módosításához engedélyezze a házirendet, majd írja be a fájlforrásokat jelölő betűket abban a sorrendben, amelyet a Windows Installer számára keresési sorrendként meg kíván határozni:

Beállítás | Adathordozó típusa
n | Ez a beállítás hozzáadja a hálózatot a forrásfájlok keresési helyeihez.
m | Ez a beállítás hozzáadja a cserélhető adathordozót a forrásfájlok keresési helyeihez.
u | Ez a beállítás hozzáadja az Internetet a forrásfájlok keresési helyeihez.

Megjegyzés

  • A fájlforrás kizárásához hagyja ki, vagy törölje a fájlforrás típusát jelölő betűt.
Visszaállítás letiltása Meggátolja, hogy a Windows Installer létrehozza és elmentse azokat a fájlokat, amelyek egy megszakított vagy sikertelen telepítési folyamat helyreállításához szükségesek.

A házirend hatására a Windows Installer nem rögzíti a rendszer eredeti állapotát, valamint a telepítés során végzett módosításokat sem. A házirend abban is meggátolja a Windows Installer segédprogramot, hogy a később törölni kívánt fájlokat megtartsa. Így befejezetlen telepítés esetén a Windows Installer nem tudja visszaállítani a számítógép eredeti állapotát.

A házirend célja az, hogy lecsökkentse az alkalmazások telepítéséhez szükséges ideiglenes lemezterület méretét. Ezzel párhuzamosan megakadályozza a rossz szándékú felhasználókat abban, hogy a telepítés megszakításával hozzáférjenek a számítógép belső állapotával kapcsolatos adatokhoz, vagy titkos rendszerfájlokat kutassanak át. Mivel azonban a befejezetlen telepítés hatására a rendszer vagy az alkalmazás működésképtelenné válhat, ajánlatos ezt a házirendet csak a legszükségesebb esetben igénybe venni.

Megjegyzés

  • Ez a házirend a Számítógép konfigurációja és Felhasználó konfigurációja mappában jelenik meg. A házirend akkor is engedélyezett, ha engedélyezve van az egyik mappában, viszont kifejezetten le van tiltva a másik mappában.


Forrásmunkák

  • Frissített technikai információk
  • Windows 2000 Resource Kit
  • Microsoft MSDN webhely (http://msdn.microsoft.com/default.asp)


Hibaelhárítás – Windows Installer

Mi a probléma?

Nem lehet hibátlanul telepíteni a telepítőcsomagot.

Oka: Ennek egyik oka az lehet, hogy a telepítőcsomag sérült.

Megoldás: Javítsa meg a telepítőcsomagot a Windows Installer helyrállítási beállításának segítségével. A telepítőcsomagok javításával kapcsolatos további tudnivalókért tanulmányozza a Csomag javítása a parancssor használatával című témakört.

A telepítési folyamat leáll a telepítés befejezése előtt.

Oka: A Windows Installer nem tudta beolvasni a telepítőcsomagot, vagy a számítógép állapota nem tette lehetővé a csomag sikeres telepítését.

Megoldás: A Windows Installer bejegyzéseket készít a Windows 2000 eseménynaplójába. Nyissa meg az Eseménynapló beépülő modult, és az alkalmazásnaplóban tekintse át a Windows Installer bejegyzéseit. A Windows Installer beállítható egyedi telepítési naplófájl létrehozására. A Windows Installer naplófájl-beállításaival kapcsolatos további tudnivalókért tanulmányozza a Telepítési naplófájl létrehozása a parancssorból című témakört.

Megjegyzés

  • Az Eseménynapló beépülő modul megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Eseménynapló ikonra.