Terminálszolgáltatások

A Terminálszolgáltatások program termináltámogatást nyújt a Windows 2000 Server operációs rendszer számára. Ez egy olyan több munkamenetes környezet, amely a távoli számítógépeknek hozzáférést biztosít a kiszolgálón futó, Windows alapú programokhoz. A Windows 2000 Server tartalmazza a Terminálszolgáltatások ügyfele programot mind 16, mind 32 bites Windows alapú ügyfelek támogatásához.

  • A Terminálszolgáltatások használatba vétele előtt olvassa el a Feladatlista: Terminálszolgáltatások telepítése című témakört.
  • Azok a funkciók, amelyeknek elérési helye a Windows 2000 Server rendszerben megváltozott, a Megszokott feladatok végrehajtásának új módjai című témakörben találhatók.
  • A terminálszolgáltatások használatával kapcsolatos ötletek a Gyakorlati tanácsok című témakörben találhatók.
  • A terminálszolgáltatásokkal, annak összetevőivel és engedélyezésükkel kapcsolatos háttérinformációk a Bevezetés a Terminálszolgáltatások használatába című témakörben olvashatók.
  • A terminálkiszolgáló kezelési információi a Terminálszolgáltatások kezelése című témakörben találhatók.
  • A problémák elhárításával kapcsolatos útmutató a Hibaelhárítás című témakörben található.


Feladatlista: A terminálszolgáltatások telepítése

Lépés | Hivatkozás
Tekintse át a terminálszolgáltatásokkal kapcsolatos alapfogalmakat. | Bevezetés a terminálszolgáltatások használatába
Tekintse át a rendszerméretezést. | Rendszertervezés
Engedélyezze a terminálszolgáltatásokat. | A terminálszolgáltatások engedélyezése
Engedélyezze a Terminálszolgáltatások licencelése programot. | A Terminálszolgáltatások licencelése program engedélyezése
Licencelje a terminálszolgáltatások ügyfeleit. | Terminálszolgáltatások licencelése
Konfigurálja a terminálszolgáltatások kapcsolatait. | A terminálszolgáltatások kapcsolatainak konfigurálása
Telepítse a programokat. | Programtelepítés
Telepítse az ügyfeleket. | Ügyfelek létrehozása és telepítése


Megszokott feladatok végrehajtásának új módjai

Az alábbi táblázat a terminálszolgáltatásokkal kapcsolatban előforduló leggyakoribb feladatokat tartalmazza. A feladatok végrehajtásához használt felhasználói felület a Windows 2000 rendszerben eltér a Windows NT 4.0, Terminal Server Edition rendszernél megszokottól.

Cél | Windows NT 4.0 rendszerben | Windows 2000 rendszerben
Terminálszolgáltatások kapcsolatainak létrehozása vagy módosítása | Terminal Server Connection Configuration (Terminálkiszolgálói kapcsolatok konfigurálása) az Administrative Tools (Felügyeleti eszközök) menüben. | A Terminálszolgáltatások konfigurálása program További információ a Terminálszolgáltatások konfigurálása című témakörben olvasható.
A terminálkiszolgáló kezelése, valamint az összes munkamenet, felhasználó és folyamat megtekintése | Terminal Server Administration (Terminálkiszolgáló felügyelete) az Administrative Tools (Felügyeleti eszközök) menüben. | A Terminálszolgáltatások kezelője program További információkat a Terminálszolgáltatások felügyelete című témakörben talál.
A terminálszolgáltatások licenceinek kezelése | Terminal Server License Manager (Terminálkiszolgáló licenckezelője) az Administrative Tools (Felügyeleti eszközök) menüben. | A Terminálszolgáltatások licencelése program Bővebben a Terminálszolgáltatások licencelése című témakörben tájékozódhat.
Terminálszolgáltatások felhasználói fiókjainak kezelése | User Manager (Felhasználókezelő) az Administrative Tools (Felügyeleti eszközök) menüben. | Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot. Helyi felhasználói fiók esetén. További információt a Terminálszolgáltatások felhasználói fiókjai című témakörben olvashat.


Gyakorlati tanácsok

  • A terminálszolgáltatásokat önálló kiszolgálóként és ne tartományvezérlőként telepítse.
    Ha a terminálszolgáltatásokat tartományvezérlőként telepíti, akkor ez hatással lehet a teljesítményre, mivel a tartományvezérlő feladatainak ellátásához több memória és processzoridő, valamint nagyobb hálózati forgalom szükséges.
  • A terminálszolgáltatásokat telepítse NTFS fájlrendszerhez formázott partícióra.
    Az NTFS többmunkamenetes környezetben nagyobb biztonságot nyújt azoknak a felhasználóknak, akik ugyanazokat az adatszerkezeteket használják.
  • A terminálkiszolgáló leállításához ne a Start menü Leállítás parancsát, hanem a tsshutdn parancsot használja. Így a kiszolgálót ellenőrzött módon állíthatja le. A Start menü Leállítás parancsának használata esetén a rendszer nem értesíti a felhasználókat a felhasználói munkamenetek befejezéséről, ezért nem ajánlott az alkalmazása. Egy felhasználó munkamenetének figyelmeztetés nélküli befejezése az ügyfélen lévő adatok elvesztését eredményezheti. A tsshutdn parancs használatáról további információ a A tsshutdn parancs című témakörben található.
  • Rendszeresen készítsen biztonsági másolatot a licenckiszolgálón lévő adatokról.
    Ha a licenckiszolgálóról rendszeresen készít biztonsági másolatot, elkerülheti a hardver- vagy memóriahiba miatti véletlen adatvesztést. Készítsen másolatot a merevlemez adatairól, és archiválja az adatokat egy másik tárolóeszközön, például szalagon vagy egy másik merevlemezen. Ha a merevlemezen tárolt eredeti adatok véletlenül törlődnek vagy felülíródnak, illetve elérhetetlenné válnak a merevlemez meghibásodása miatt, az adatok könnyen visszaállíthatók az archivált másolatról.

Programtelepítés

  • Az alkalmazások terminálkiszolgálóra történő telepítéséhez a használja a Vezérlőpulton található Programok telepítése/törlése eszközt. Ezzel a módszerrel többmunkamenetes felhasználáshoz telepíthet programokat. Az alkalmazások terminálkiszolgálóra történő telepítéséről további információk a Telepítés megkezdése című témakörben találhatók.
  • Miután engedélyezte a terminálszolgáltatások használatát és telepítette a programokat, ne kapcsolja be és ki a terminálszolgáltatásokat.
    A Terminálszolgáltatások program többmunkamenetes környezetben történő használatra telepíti a programokat. A terminálszolgáltatások telepítésekor telepített programok bizonytalanul működhetnek, ha a terminálszolgáltatásokat bezárja. Ha a terminálszolgáltatásokat eltávolítja, az összes programot újra kell telepítenie terminálszolgáltatások nélküli használatra.
  • A terminálszolgáltatásokkal használandó programok telepítése előtt ellenőrizze, hogy van-e hozzájuk alkalmazáskompatibilitási parancsfájl.
    A legtöbb gyakran használt program kompatibilitása ellenőrzésre került, néhány programnál azonban a telepítést kicsit módosítani kell. Ezekhez a programokhoz parancsfájlok állnak rendelkezésre, amelyeket a telepítés után kell futtatni. A parancsfájlok a rendszergyökér \Application Compatibility Scripts\Install mappában találhatók.

Felhasználók kezelése

  • Használjon terminálszolgáltatások-specifikus csoportokat
    Hozzon létre felhasználói csoportokat kimondottan a terminálszolgáltatások felhasználói számára. A felhasználók csoportokban történő kezelése sokkal könnyebb, és kevésbé időigényes, mint az egyenkénti kezelés.
  • Használjon terminálszolgáltatások-specifikus profilokat
    A terminálszolgáltatásokba történő bejelentkezéséhez rendeljen egy külön profilt. A profilokban tárolt leggyakoribb beállítások többsége, mint például a képernyőkímélők és az animált menühatások, nem ajánlatosak a terminálszolgáltatások használatánál. Külön profil hozzárendelésével lehetővé válik a felhasználók számára, hogy a lehető leghatékonyabban használhassák a rendszert, anélkül, hogy további kiszolgálói erőforrásokat kötnének le. A terminálszolgáltatások-specifikus profilok hozzárendeléséről a Felhasználó Terminálszolgáltatások profiljához tartozó elérési út módosítása című témakörben tájékozódhat.
  • Használjon kötelező profilokat
    Alkalmazzon kötelező Terminálszolgáltatások profilt, amely megfelel az összes, különböző típusú ügyfél igényeinek, és a legnagyobb kiszolgálóteljesítményt biztosítja. Vegye figyelembe, hogy a 16 bites számítógépek és a Windows alapú terminálok néhány képernyőfelbontást nem támogatnak.
  • Állítson be időkorlátokat
    Az ügyfélkapcsolatok idejének korlátozása javíthatja a kiszolgáló teljesítményét. Megadhatja, hogy egy munkamenet mennyi ideig tartson, meddig maradjon aktív a kiszolgálón a leválasztott munkamenet, és mennyi ideig maradjon egy munkamenet csatlakoztatott állapotban üresjárat esetén. A munkamenetek időkorlátjaival kapcsolatos beállításokról további információt a Munkamenetek című témakörben olvashat.
  • Használja a Kezdőprogram beállítást
    Olyan felhasználók esetén, akiknek a terminálkiszolgálón csak egy alkalmazásra van szükségük, használja a Kezdőprogram beállítást, így a felhasználók csak az adott alkalmazást érhetik el. Munkamenet csatlakozásakor induló program megadása.
  • Készítsen előre beállított kapcsolatokat a felhasználók vagy felhasználói csoportok számára
    A terminálszolgáltatásokhoz való csatlakozás megkönnyítése érdekében a felhasználók számára előre beállított kapcsolatokat biztosíthat. A szervezet különböző osztályai, illetve a különböző beosztások számára is készíthet előre beállított kapcsolatokat. Előre beállított kapcsolatokat az Ügyfélkapcsolat kezelője programmal hozhat létre. További információ A terminálszolgáltatások felhasználói kapcsolatainak kezelése című témakörben olvasható.


Bevezetés a terminálszolgáltatások használatába

Ez a témakör a Terminálszolgáltatások program használatába bevezető lépéseket ismerteti. Az alábbi témakörökben tájékozódhat:

  • Terminálszolgáltatások - áttekintés
  • A terminálszolgáltatások felügyeleti eszközei
  • Terminálszolgáltatások engedélyezése
  • Terminálszolgáltatások be- és kikapcsolása
  • Rendszertervezés


Terminálszolgáltatások - áttekintés

Terminálszolgáltatások – áttekintés

A Terminálszolgáltatások program a terminálemulátorként működő „sovány ügyfél” szoftveren keresztül távoli hozzáférést biztosít a kiszolgáló Asztalához. A terminálszolgáltatások csak a program felhasználói felületét továbbítja az ügyfélhez. Az ügyfél a billentyűzet- és az egérmozgatás jeleit küldi vissza a kiszolgálóra. Minden felhasználó csak saját munkamenetébe jelentkezhet be, és csak ezt látja. A kiszolgáló operációs rendszere a felhasználó számára láthatatlanul és egymástól függetlenül kezeli az ügyfélmunkameneteket. Az ügyfélszoftver számos hardvereszközön futhat, beleértve a számítógépeket és a Windows alapú terminálokat. Egy kiegészítő szoftver segítségével más eszközök, például Macintosh számítógépek vagy UNIX alapú munkaállomások is csatlakozhatnak a terminálkiszolgálóhoz.

A terminálszolgáltatások alkalmazáskiszolgálói vagy távfelügyeleti módban telepíthető a kiszolgálóra. Alkalmazáskiszolgálói módban a terminálszolgáltatások hatékony és megbízható eszközt biztosít a Windows alapú programok megosztott használatához egy hálózati kiszolgálón keresztül. Alkalmazáskiszolgálói módban a terminálszolgáltatások a Windows futtatására nem képes számítógépek számára továbbítja a Windows 2000 Asztalt és az aktuális Windows alapú alkalmazásokat. Távfelügyeleti módban a terminálszolgáltatások távoli felügyeletet biztosít a saját kiszolgálóhoz a hálózat bármely pontjáról.

A terminálszolgáltatások előnyei:

  • Gyorsabban elérhetővé teszi az eszközök számára a Windows 2000 rendszert. A terminálszolgáltatások áthidalja azt az időtartamot, amíg a régi eszközöket a Windows 2000 Professional rendszerrel frissítik: „virtuálisan” biztosítja a Windows 2000 Asztalt a számítógépnek nem tekinthető eszközök, illetve az olyan számítógépek számára is, amelyeknél a hardver felújítására van szükség a teljes Windows 2000 operációs rendszer helyi futtatásához. A terminálszolgáltatások ügyfelei számos különböző platform számára elérhetők, beleértve az MS-DOS-t, a Windows alapú terminálokat, a Macintosh és a UNIX rendszereket. (Az MS-DOS, a Macintosh és a UNIX alapú számítógépekhez kiegészítő szoftver szükséges.)
  • Biztosítja a meglévő hardvereszközök által nyújtott összes lehetőséget. A terminálszolgáltatások kiterjeszti az elosztott feldolgozás modelljét, hiszen a számítógépek működését egyszerre sovány ügyfél módban, illetve az összes szolgáltatást futtató személyi számítógép módban is lehetővé teszi. A számítógépek a megszokott módon használhatók a meglévő hálózatokban, de sovány ügyfélként is képesek működni és a Windows2000 Professional Asztalt emulálni.
  • Központosítja a programok kezelését. A Windows 2000 Server rendszert használó számítógépen futó terminálszolgáltatások az összes programfuttatást, adatfeldolgozást és adattárolást a kiszolgálón hajtja végre, központosítva ezzel a programok kezelését. A terminálszolgáltatások minden ügyfél számára biztosítja a programok aktuális verzióihoz való hozzáférést. A szoftvert csak a kiszolgálóra kell telepíteni, nem pedig a szervezet összes számítógépére, csökkentve ezzel az egyes számítógépek frissítésével járó költségeket.
  • Távfelügyeletet biztosít. A terminálszolgáltatások lehetővé teszi a Windows 2000 Server rendszert futtató kiszolgálók távoli felügyeletét, biztosítva ezzel a rendszergazdák számára a kiszolgáló bármely ügyfélről történő távoli kezelését WAN hálózaton vagy telefonos kapcsolaton keresztül.

Jellemzők:

  • Egyszerű használat
  • Kezelhetőség
  • Biztonság

Egyszerű használat

Szolgáltatás | Leírás | További információt a következő témakörökben talál:
Helyi nyomtatók automatikus támogatása | A Windows 2000 Server terminálszolgáltatások programja hozzáadja és automatikusan újracsatlakoztatja a terminálszolgáltatások ügyfeleihez csatolt nyomtatókat. | Ügyfélhozzáférés biztosítása helyi nyomtatókhoz
Vágólap átirányítása | A felhasználók a helyi számítógépeken és a terminálkiszolgálón futó programok között kivágási és beillesztési műveleteket hajthatnak végre. | Megosztott vágólap
Nagyobb teljesítmény | A gyorsítótárazás - beleértve az állandó gyorsítótárazást -, a csomaghasznosítás és a keretméret továbbfejlesztése jelentősen megnövekedett teljesítményt biztosítanak a terminálszolgáltatásokban. | Bitképek gyorsítótárazása
Központi leválasztás támogatása | Ez a szolgáltatás lehetővé teszi a felhasználók számára a munkamenetről történő leválást kijelentkezés nélkül. A leválasztott munkamenet aktív marad, lehetővé téve a felhasználó visszacsatlakozását akár egy másik számítógépről, vagy egy későbbi időpontban is. A visszacsatlakozáskor újra be kell jelentkezi, ami a munkamenetek biztonságát szolgálja. | Kijelentkezés vagy leválasztás
Több bejelentkezés támogatása | A felhasználóknak lehetőségük van egy vagy több ügyfélről egyszerre több munkamenethez bejelentkezni, egyszerre több Windows 2000 Server rendszert futtató számítógépre bejelentkezni, illetve ugyanarra a kiszolgálóra többször is bejelentkezni. Így a felhasználók egyidőben több feladatot is végrehajthatnak, illetve több különálló Asztalon futtathatnak munkameneteket. | Felhasználók és ügyfelek kezelése

Kezelhetőség

Szolgáltatás | Leírás | További információt a következő témakörökben talál:
Munkamenet távvezérlése | A tanácsadással foglalkozó szakemberek megtekinthetik vagy irányíthatják a terminálszolgáltatások egy másik munkamenetét. A billentyűleütések, az egérmozgatások és a grafikák megjelenítése ilyenkor megosztott módon történik a terminálszolgáltatások két munkamenete között, ami lehetőséget biztosít a konfigurációs problémák diagnosztizálásra és megoldására, továbbá a felhasználó távoktatására. Ez a szolgáltatás különösen a fiókirodákkal rendelkező szervezetek számára hasznos. | Távvezérlés
Hálózati terheléselosztás | A hálózati terheléselosztás lehetővé teszi a terminálszolgáltatások ügyfelei számára, hogy ahhoz, a terminálszolgáltatásokat futtató kiszolgálóhoz csatlakozzanak, amely a legkevésbé foglalt. | A hálózati terheléselosztás és a terminálszolgáltatások
Windows alapú terminálok | A Windows CE operációs rendszer és a Remote Desktop protokoll (RDP) testreszabott változatára alapozva számos gyártó kínál Windows alapú terminálokat. |
Ügyfélkapcsolat kezelője program | A rendszergazdák és a felhasználók adott programok, illetve a teljes Asztal eléréséhez előre meghatározott kiszolgálói kapcsolatokat konfigurálhatnak. Az Ügyfélkapcsolat kezelője szolgáltatás segítségével az ügyfél képernyőjén elhelyezhető egy parancsikon, amelynek használatával az ügyfél egyetlen kattintással csatlakozhat egy vagy több terminálkiszolgálóhoz. Ha a rendszergazdák a teljes számítógépes környezet számára szeretnék biztosítani a hozzáférést egy adott programhoz, létrehozhatnak egy csatlakozást, amelyet azután a Terminálszolgáltatások ügyfele programmal együtt szétoszthatnak. | A terminálszolgáltatások felhasználói kapcsolatainak kezelése
Terminálszolgáltatások licencelése program | A terminálszolgáltatások licencelése lehetővé teszi a rendszergazdák és a beszerzési irodák számára az ügyfelek és licencengedélyeik nyomon követését. | Terminálszolgáltatások licencelése
Elosztott fájlrendszer (Dfs) támogatása | Az elosztott fájlrendszer (Dfs) támogatása lehetővé teszi a felhasználók számára, hogy egy Dfs-megosztáshoz csatlakozzanak, a rendszergazdák számára pedig, hogy a terminálkiszolgálóról létrehozzanak egy Dfs-megosztást. | Elosztott fájlrendszer – áttekintés
Terminálszolgáltatások kezelője program | A rendszergazdák a Terminálszolgáltatások kezelője program segítségével a Windows 2000 Server rendszert futtató számítógépeken lekérdezhetik és kezelhetik a terminálszolgáltatások munkameneteit, felhasználóit és folyamatait. | Terminálszolgáltatások felügyelete
Terminálszolgáltatások konfigurálása program | A terminálszolgáltatások kapcsolatainak konfigurálásával munkamenetek és munkamenetcsoportok készíthetők, módosíthatók és törölhetők a Windows 2000 Server rendszert futtató számítógépen, illetve hozzáférhetővé válnak a kiszolgáló beállításai. | Terminálszolgáltatások konfigurálása
Integráció a Windows 2000 Server Helyi felhasználók és csoportok, illetve Active Directory - felhasználók és számítógépek beépülő modulokkal | A rendszergazdák a terminálszolgáltatások felhasználói számára ugyanúgy készíthetnek fiókokat, mint a Windows 2000 Server felhasználói számára. A terminálszolgáltatások speciális információinak megadásához, mint például a profil és a kezdőkönyvtár elérési útvonala, külön mezők állnak rendelkezésre. | A terminálszolgáltatások felhasználói fiókjai
Integráció a Windows 2000 Server Rendszerfigyelő programmal | A Windows 2000 Server Rendszerfigyelő programmal való integráció lehetővé teszi a rendszergazdák számára a terminálszolgáltatások rendszerteljesítményének figyelését, köztük a processzorkihasználtság, a memórialefoglalás, a lapozhatómemória-használat, valamint a lapozási tevékenység felhasználói munkamenetenkénti nyomon követését. | A teljesítmény figyelése
Üzenetküldés támogatása | A rendszergazdák a felhasználókat értesíthetik a fontosabb eseményekről, például a rendszerleállításról, a frissítésekről vagy az új programokról. | A Terminálszolgáltatások kezelője program használata
Távfelügyelet | A rendszergazdai és a terminálszolgáltatások felügyeleti eszközeihez hozzáférési jogosultsággal rendelkező felhasználók a terminálszolgáltatásokat futtató kiszolgálót teljes körűen távvezérelhetik. |
Konfigurálható munkamenet-időkorlátok | A rendszergazdák a munkamenetek időkorlátjainak beállításaival csökkenthetik a kiszolgálói erőforrások használatát. A rendszergazdák meghatározhatják az aktív munkamenet időtartamát, illetve a munkamenetek üresjáratban történő futásának időkorlátját. | Munkamenet időkorlátjainak konfigurálása

Biztonság

Szolgáltatás | Leírás | További információt a következő témakörökben talál:
Titkosítás | Három titkosítási szint áll a rendszergazdák rendelkezésére, hogy a biztonsági követelményeknek megfelelően titkosíthassák a Windows 2000 Server és a terminálszolgáltatások ügyfelei közötti összes vagy néhány adatot: az alacsony, a közepes és a magas titkosítási szint. A terminálszolgáltatások bejelentkezési folyamata emellett jelszómódosítási, valamint munkaasztal- és képernyőkímélő-feloldási szolgáltatásokat tartalmaz. A bejelentkezési folyamat titkosított, ami biztosítja a felhasználónév és a jelszó biztonságos átvitelét. A terminálszolgáltatások mind a 40, mind a 128 bites (csak az USA és Kanada területén) titkosítást támogatja a kiszolgáló és az ügyfél között. | A titkosítási szint meghatározása
A bejelentkezési kísérletek és a csatlakozási idő korlátozása | A rendszergazdák a jogtalan hozzáférés megakadályozása érdekében korlátozhatják a kiszolgálóhoz történő bejelentkezési kísérletek számát. Korlátozható a felhasználó vagy a felhasználói csoportok csatlakozási ideje is. | Terminálszolgáltatások konfigurálása


A terminálszolgáltatások felügyeleti eszközei

A terminálkiszolgálók felügyeletéhez a Windows 2000 Server rendszer összes felügyeleti eszköze rendelkezésre áll. A terminálszolgáltatások az alábbi kiegészítő eszközöket, Windows 2000 eszközbővítéseket és rendszerfelügyeleti parancsokat tartalmazza:

  • Terminálszolgáltatások kezelője program
  • Terminálszolgáltatások konfigurálása program
  • Bővítmények az Active Directory - felhasználók és számítógépek, valamint a Helyi felhasználók és csoportok beépülő modulokhoz
  • Terminálszolgáltatások licencelése program
  • Rendszerfigyelő-számlálók
  • Kiegészítő mezők a Feladatkezelő programhoz
  • Ügyféllétrehozó program
  • Ügyfélkapcsolat kezelője program
  • Több felhasználó támogatása a Programok telepítése/törlése programban
  • Parancsok

Terminálszolgáltatások kezelője program

A Terminálszolgáltatások kezelője program segítségével a hálózaton található, terminálszolgáltatásokat futtató bármely számítógép felhasználói, munkamenetei és folyamatai megfigyelhetők és kezelhetők. A program a következőkre alkalmazható:

  • Kiszolgálók, munkamenetek, felhasználók és folyamatok információinak megjelenítése.
  • Munkamenethez való csatlakozás és leválás.
  • Munkamenet figyelése.
  • Munkamenet törlése.
  • Üzenetküldés a felhasználóknak.
  • Felhasználók kiléptetése.
  • Folyamatok bezárása.

Terminálszolgáltatások konfigurálása program

A Windows 2000 Server rendszer és a terminálszolgáltatások telepítése során a rendszer konfigurál egy TCP/IP-kapcsolatot. Ezen a kapcsolaton keresztül jelentkezhetnek be az ügyfelek a kiszolgáló egy munkamenetébe. Telepítés után a Terminálszolgáltatások konfigurálása program használatával ennek a kapcsolatnak a jellemzői módosíthatók, illetve új kapcsolatok hozhatók létre. A program a következőkre használható:

  • Kapcsolat elnevezése.
  • Kapcsolattípus megadása.
  • Kapcsolatátvitel megadása és az átviteli jellemzők beállítása.
  • Engedélyezett munkamenetek maximális számának meghatározása.
  • Adott kapcsolaton keresztül történő bejelentkezések engedélyezése vagy letiltása.
  • Kapcsolat időtúllépésének beállítása.
  • Titkosítási szint beállítása.
  • Megszakadt kapcsolat leválasztásának beállítása.
  • Munkamenet távvezérlésének engedélyezése vagy letiltása.
  • Automatikus bejelentkezés engedélyezése vagy letiltása.
  • Felhasználó bejelentkezésekor automatikusan induló program megadása.
  • Tapétára vonatkozó felhasználói profilbeállítás felülírása.
  • Csatlakozási engedélyek beállítása.
  • Ügyféleszköz-hozzárendelések és kapcsolatok paramétereinek beállítása.

Bővítmények az Active Directory - felhasználók és számítógépek, valamint a Helyi felhasználók és csoportok beépülő modulokhoz

A Terminálszolgáltatások program az Active Directory - felhasználók és számítógépek, valamint a Helyi felhasználók és csoportok beépülő modulokhoz egy Terminálszolgáltatások bővítményt ad hozzá, ami minden felhasználónál lehetővé teszi a terminálszolgáltatások jellemzőinek ellenőrzését. A Terminálszolgáltatások bővítmény az alábbiakra használható:

  • Terminálszolgáltatások felhasználói profiljához tartozó útvonal beállítása minden felhasználónál.
  • Bejelentkezés engedélyezése vagy letiltása.
  • Munkamenet időkorlátjainak beállítása.
  • Megszakadt kapcsolat leválasztásának vagy törlésének beállítása.
  • Munkamenet távvezérlésének engedélyezése vagy letiltása.
  • Felhasználó bejelentkezésével automatikusan induló program megadása.
  • Ügyfélmeghajtók és -nyomtatók automatikus csatalakoztatása bejelentkezéskor.

Nyissa meg az Active Directory – felhasználók és számítógépek ablakot.

Terminálszolgáltatások licencelése program

A Terminálszolgáltatások licencelése program segítségével regisztrálhatók és nyomon követhetők a terminálszolgáltatásokat használó ügyfelek licencei.

Rendszerfigyelő-számlálók

A Terminálszolgáltatások program a Rendszerfigyelővel nyomon követhető objektumokhoz hozzáadja a Felhasználó és a Munkamenet objektumokat, valamint ezek számlálóit. Ezekkel az objektumokkal és számlálókkal a munkamenetek és ügyfelek által használt erőforrások figyelhetők meg. A Terminálszolgáltatások program a Folyamat és Rendszer nevű objektumokhoz is ad hozzá számlálókat.

Kiegészítő mezők a Feladatkezelő programhoz

A Terminálszolgáltatások két további mezőt ad hozzá a Feladatkezelőhöz a munkamenetek folyamatainak figyeléshez és bezárásához.

Ügyféllétrehozó program

Az Ügyféllétrehozó program a Terminálszolgáltatások ügyfele program telepítőlemezeinek létrehozására használható.

Ügyfélkapcsolat kezelője program

Amikor a Terminálszolgáltatások ügyfele programot a számítógépre telepíti, az Ügyfélkapcsolat kezelője program is telepítésre kerül. Az Ügyfélkapcsolat kezelője program segítségével a Terminálszolgáltatások kiszolgálóhoz történő kapcsolódás és a bejelentkezés automatikussá tehető. Meghatározható a bejelentkezéskor automatikusan induló program is.

Több felhasználó támogatása a Programok telepítése/törlése programban

A Programok telepítése/törlése biztosítja az alkalmazások telepítését többmunkamenetes környezetben való használathoz.

Nyissa meg a Programok telepítése/törlése ablakot.

Parancsok

Parancs | Funkció
change logon | Ideiglenesen letiltja az adott terminálkiszolgálóra irányuló bejelentkezéseket.
change port | Módosítja a COM-porthozzárendeléseket az MS-DOS alapú programokkal való kompatibilitás érdekében.
change user | Módosítja az .ini fájl hozzárendelését az aktuális felhasználónál.
cprofile | Eltávolítja a felhasználóspecifikus fájltársításokat a felhasználói profilból.
dbgtrace | Engedélyezi vagy letiltja a hibakeresés nyomkövetését.
flattemp | Engedélyezi vagy letiltja az ideiglenes könyvtárak használatát.
logoff | Bezár egy ügyfélmunkamenetet.
msg | Üzenetet küld egy vagy több ügyfélnek.
query process | Megjeleníti a folyamatokkal kapcsolatos információkat.
query session | Megjeleníti a terminálszolgáltatások munkameneteivel kapcsolatos információkat.
query termserver | Kilistázza a hálózaton lévő, terminálszolgáltatásokat futtató kiszolgálókat.
query user | Megjeleníti a rendszerbe bejelentkezett felhasználókkal kapcsolatos információkat.
register | Speciális végrehajtási jellemzőkkel regisztrál egy programot.
reset session | Lehetővé teszi egy munkamenet alaphelyzetbe állítását (törlését) a terminálkiszolgálóról.
shadow | Lehetővé teszi egy másik felhasználó aktív munkamenetének figyelését vagy távvezérlését.
tscon | Csatlakozik egy másik terminálkiszolgálón futó munkamenethez.
tsdiscon | Leválaszt egy ügyfelet egy adott terminálkiszolgálón futó munkamenetről.
tskill | Bezár egy folyamatot.
tsprof | Átmásolja a felhasználói konfigurációt, és módosítja a profil elérési útvonalát.
tsshutdn | Leállít egy adott, terminálszolgáltatásokat futtató kiszolgálót.


Terminálszolgáltatások engedélyezése

A terminálszolgáltatásokat két különböző módban engedélyezheti: távfelügyeleti és alkalmazáskiszolgálói módban. Távfelügyeleti módban a terminálszolgáltatások lehetővé teszi, hogy a kiszolgáló táveléréssel a hálózat bármely pontjáról felügyelhető legyen. Alkalmazáskiszolgálói módban a terminálszolgáltatások hatékony és megbízható eszközt biztosít a Windows alapú programok használatának megosztásához egy hálózati kiszolgálón keresztül. A terminálszolgáltatások egyszerre nem engedélyezhető mindkét módban. A terminálszolgáltatások módjainak engedélyezésével kapcsolatos útmutatások az alábbi témakörökben találhatók:

  • A terminálszolgáltatások távfelügyeleti módban való engedélyezése
  • A terminálszolgáltatások alkalmazáskiszolgálói módban való engedélyezése


A terminálszolgáltatások távfelügyeleti módban való engedélyezése

A terminálszolgáltatások ezen módban történő engedélyezése előtt tekintse át a következőket:

  • A terminálszolgáltatásokat engedélyezze NTFS fájlrendszerhez formázott partícióra telepített kiszolgálón.
  • Olvassa el a Windows 2000 Deployment Guide című dokumentumot a terminálszolgáltatások üzembe helyezésével kapcsolatos részletes információkért.
  • A terminálszolgáltatások távfelügyeleti módban történő engedélyezése esetén a Terminálszolgáltatások licencelése programot nem szükséges engedélyezni. Távfelügyeleti módban maximum két párhuzamos csatlakozás van automatikusan engedélyezve a terminálkiszolgálón.
  • Windows NT 4.0 Terminal Server Edition programról történő frissítés esetén a terminálszolgáltatások automatikusan alkalmazáskiszolgálói módba kerül. A terminálszolgáltatások távfelügyeleti módban történő használatához célszerű a programot egy előzőleg újonnan telepített (nem frissített) Windows 2000 Server kiszolgálóra telepíteni.
  • A terminálszolgáltatások távfelügyeleti módban történő engedélyezésekor nem szükséges a programok többmunkamenetes hozzáféréséhez történő speciális telepítése. A programok a terminálszolgáltatások engedélyezése előtt és után is telepíthetők.

A terminálszolgáltatások ilyen módban történő engedélyezésével kapcsolatos tudnivalók az útmutató azonos, A terminálszolgáltatások távfelügyeleti módban való engedélyezése című témakörében találhatók.


A terminálszolgáltatások alkalmazáskiszolgálói módban való engedélyezése

A terminálszolgáltatások ezen módban történő engedélyezése előtt tekintse át a következőket:

  • Olvassa el a Rendszertervezés című témakört a rendszerméretezéssel és a teljesítménnyel kapcsolatos tudnivalókért.
  • Olvassa el a Windows 2000 Deployment Guide című dokumentumot a terminálszolgáltatások üzembe helyezésével kapcsolatos részletes információkért.
  • A terminálszolgáltatások alkalmazáskiszolgálói módban történő engedélyezését ne tartományvezérlőn, hanem önálló kiszolgálón hajtsa végre. Ha tartományvezérlőn engedélyezi a terminálszolgáltatásokat, a tartományvezérlői feladatok elvégzéséhez szükséges nagyobb memóriaigény, hálózati adatforgalom és processzoridő miatt csökkenhet a terminálkiszolgáló teljesítménye.
  • A terminálszolgáltatásokat engedélyezze NTFS fájlrendszerhez formázott partícióra telepített kiszolgálón. Az NTFS többmunkamenetes környezetben nagyobb biztonságot nyújt a felhasználóknak.
  • A terminálszolgáltatásokkal együtt használandó programokat telepítse a terminálszolgáltatások engedélyezése után. Ez lehetővé teszi a terminálszolgáltatások számára a programok többmunkamenetes hozzáférésre történő regisztrálását, így a programok könnyebben kezelhetővé válnak. A programok telepítéséről bővebben a Programok telepítése a terminálszolgáltatások alkalmazáskiszolgálói módban való használatához című témakörben tájékozódhat.

A terminálszolgáltatások ilyen módban történő engedélyezésével kapcsolatos tudnivalók az útmutató azonos, A terminálszolgáltatások alkalmazáskiszolgálói módban való engedélyezése című témakörében találhatók.


Terminálszolgáltatások be- és kikapcsolása

A terminálszolgáltatások futása a Vezérlőpult Programok telepítése/törlése parancsával kapcsolható be- és ki. A terminálszolgáltatások alapértelmezés szerint engedélyezve van, ha a Windows 2000 Server rendszer telepítése közben került telepítésre választható összetevőként, illetve ha a rendszer a Windows NT Server 4.0 Terminal Server Edition verzióról lett frissítve. Ha a Windows 2000 Server rendszer telepítésekor nem engedélyezte a terminálszolgáltatásokat, ezt később a Programok telepítése/törlése programmal teheti meg. Ha a Terminálszolgáltatások program alkalmazáskiszolgálói módban van engedélyezve, ne feledje, hogy letiltásakor számos probléma merülhet fel. Érintheti például az alkalmazásokat, és azok többfelhasználós, illetve egyfelhasználós környezetben való alkalmazhatóságát is. Ha a terminálszolgáltatások távfelügyeleti módban van engedélyezve, akkor a letiltás nincs hatással az alkalmazásokra.

A terminálszolgáltatások be- és kikapcsolásának hatása az alkalmazásokra

Számos régebbi alkalmazás nem használható többfelhasználós környezetben, ezért a terminálkiszolgálókon való megfelelő működés érdekében módosítani kell őket. Ha úgy dönt, hogy letiltja a terminálszolgáltatások alkalmazáskiszolgálói módját, a terminálkiszolgálón való működéshez telepített és konfigurált alkalmazások nem fognak futni a legközelebbi engedélyezéskor. Ilyenkor az alkalmazásokat újra kell konfigurálni vagy telepíteni.

A többfelhasználós környezetben történő használatra tervezett alkalmazásokra a terminálszolgáltatások letiltása és engedélyezése nincs hatással.

Megjegyzés

  • Ha a terminálszolgáltatásokat ideiglenesen kell letiltani (például egy alkalmazás telepítésekor), használja a Terminálszolgáltatások konfigurálása programban található Kapcsolat tiltása beállítást. További információk a Kapcsolat tiltása című témakörben találhatók.


Rendszertervezés

Ez a fejezet a terminálkiszolgáló azon rendszerméretező elemeit és rendszerelemeit ismerteti, amelyek segítenek meghatározni a felhasználók igényeit kielégítő, legoptimálisabb teljesítményt biztosító hardverkonfigurációt.

  • Rendszerméretezés
  • A teljesítményt befolyásoló perifériák
  • Az alkalmazások teljesítménye
  • A teljesítmény figyelése
  • A hálózati terheléselosztás és a terminálszolgáltatások


Rendszerméretezés

A felhasználók többsége három kategóriába sorolható:

  • Egyszerű felhasználók. Az egyszerű felhasználók általában egyszerre csak egy programot futtatnak (például egy szövegszerkesztő programot vagy egy Visual Basic nyelven írt, üzleti tevékenységhez kapcsolódó programot).
  • Több programot futtató felhasználók. A több programot futtató felhasználók párhuzamosan két vagy több programot futtatnak, de nem váltogatnak túl gyakran közöttük. Az ilyen felhasználók olyan programokat futtatnak, amelyek adatfeldolgozása nem foglal le túl nagy rendszererőforrásokat (például termelékenységmérő, szövegszerkesztő vagy Internet-böngésző programokat).
  • Teljesítményigényes felhasználók. A teljesítményigényes felhasználók sokkal hozzáértőbb felhasználók, akik több programot futtatnak egyszerre, és ezek közül általában elég sok aktív egyszerre. A teljesítményigényes felhasználók olyan programokat futtatnak, amelyek adatfeldolgozása igen nagy rendszererőforrásokat igényel (például nagy adatbázisok részletes lekérdezése).

A kiszolgáló kívánt teljesítményének meghatározásakor figyelembe kell venni a felhasználók típusait is. Az egyszerű felhasználók alig igényelnek erőforrásokat, a teljesítményigényes felhasználók viszont nagy erőforrásokat foglalhatnak le. A kiszolgálón futó programok típusát is figyelembe kell venni. Ne feledje, hogy a terminálkiszolgáló megosztja a futtatható erőforrásokat az egyes felhasználók között, ugyanúgy, mint ahogyan a Windows 2000 megosztja a futtatható erőforrásokat (.dll, .exe stb.) az egyes programok között. Emiatt azoknak a további felhasználóknak a memóriaigénye, akik az ugyanazt a programot futtatják, általában kisebb, mint a programot elsőként elindító felhasználóé.

A megfelelő teljesítmény érdekében a terminálkiszolgálón Pentium vagy annál erősebb processzort kell telepíteni. A terminálkiszolgáló minimális memóriaigénye 128 MB RAM, plusz minden felhasználó esetén további RAM-ok a felhasználói programok kiszolgálón történő futtatásához. Célszerű további 10 MB RAM telepítése egyszerű felhasználónként, és maximum 21 MB teljesítményigényes felhasználónként.

A processzor- és memóriaigények általában lineárisan nőnek. A processzorok számának és a memória mennyiségének megduplázása esetén egy többprocesszoros Pentiumos rendszer kétszer annyi felhasználót képes kiszolgálni. Így a többprocesszoros rendszerek vásárlása a követelmények növekedésével lehetővé teszi a kapacitás egyszerű növelését, még ha kezdetben csak egy processzort használnak is.

A teljesítmény erősen függhet a terminálkiszolgálón futó programoktól. A rendszert a felhasználó feldolgozási teljesítményének és memóriaigényének felmérése érdekében a programok futtatásával kell tesztelni.

Az egy- és többprocesszoros rendszerekben a buszok felépítése is befolyásolja a rendszer működését. Az ISA (AT-busz) felépítéséből adódóan alacsony sávszélességű, ezért használata nem ajánlott terminálkiszolgálók esetében. A legjobb teljesítmény érdekében célszerű nagyobb teljesítményű, például EISA-, MCA-, vagy PCI-buszokat alkalmazni. Ezek a buszok mind támogatják a tartós nagysebességű adatátvitelt, amely általában a terminálszolgáltatások futtatásához szükséges.


A teljesítményt befolyásoló perifériák

A merevlemez átviteli képessége szintén hatással van a terminálkiszolgáló teljesítményére. Az SCSI-lemezmeghajtók és -csatolók, különösen a Fast SCSI és az SCSI-2 típusokkal kompatibilis eszközök átviteli képessége lényegesen jobb, mint az ST-506, IDE vagy ESDI típusú lemezmeghajtóké és csatolóké.

A legnagyobb lemezteljesítmény elérése érdekében legjobb az SCSI RAID vezérlő használata. A RAID (független lemezek redundáns tömbje) típusú vezérlők automatikusan, több lemezre viszik fel az adatokat, így növelve a lemezteljesítményt és javítva az adatok megbízhatóságát.

A terminálkiszolgálóval használt RDP (Remote Desktop protokoll) minimális hálózati terhelést okoz, mégis célszerű a nagyteljesítményű hálózati csatoló használata. Ez különösen akkor fontos, ha sok felhasználó igényel hozzáférést a hálózati kiszolgálón tárolt adatokhoz, illetve sokan szeretnének ügyfél-/kiszolgálóprogramokat futtatni. Ugyancsak hasznos lehet a két hálózati csatoló használata is, amelyek közül az egyik kizárólag az RDP-forgalmat kezeli.

Ha a telefonos felhasználók számára többportos aszinkron kommunikációs csatoló van telepítve, a megszakítástöbbletek csökkentése és az átvitel növelése érdekében ajánlott intelligens (mikroprocesszor alapú) csatolót használni.


Az alkalmazások teljesítménye

A Windows 2000 Server rendszer 32 bites környezetű, a Windows 3.11 pedig 16 bites. A Windows 2000 Server a 16 bites programokat WOW (Windows on Windows) eljárással futtatja, a programokat kiterjesztett módban lefordítva. Az eljárás során a 16 bites programok további rendszererőforrásokat igényelnek. A 16 bites programok terminálkiszolgálón történő futtatása 40 százalékkal csökkentheti a processzor által támogatott felhasználók számát, és felhasználónként 50 százalékkal növelheti a memóriaigényt. Ezért, amikor csak lehetséges, célszerű a programok 32 bites verzióját használni.

Az alkalmazásokkal kapcsolatos további szempontok:

  • Néhány videót használó alkalmazás csökkentheti a teljesítményt. A jobb teljesítmény érdekében kapcsolja ki az alkalmazások videohatásait.
  • Az MS-DOS alapú alkalmazások használata nem ajánlott, mert ezek a rendelkezésre álló teljes CPU-teljesítményt leköthetik.
  • Az olyan szolgáltatások, amelyek állandóan aktívak, és a háttérben futnak – mint például az automatikus helyesírás- és nyelvhelyesség-ellenőrző a Microsoft Word szövegszerkesztőben – több rendszererőforrást igényelnek.


A teljesítmény figyelése

A Windows 2000 Server teljesítményfigyelő eszközeivel a rendszerteljesítmény, valamint a konfigurációban végrehajtott változásoknak a rendszer átviteli képességére gyakorolt hatása követhető nyomon. A teljesítményfigyelés legfontosabb mérőszámai az alábbiak:

  • Processzorkihasználtság
  • Merevlemez I/O-sebessége
  • Memóriakihasználtság
  • Lapozófájllal kapcsolatos tevékenység

Annak meghatározására, hogy egy kiszolgáló hány felhasználót képes támogatni, az egyik legjobb módszer a rendszer tesztelése 2-5 felhasználóval. A kapott eredményeket aztán megfelelően arányosítani kell.

A Terminálszolgáltatások program a Rendszerfigyelővel nyomon követhető objektumokhoz hozzáadja a Terminálszolgáltatások és a Terminálszolgáltatások-munkamenet objektumokat, valamint ezek számlálóit.


A hálózati terheléselosztás és a terminálszolgáltatások

A hálózati terheléselosztás több, TCP/IP hálózati protokollt használó kiszolgálóprogramot futtató számítógépet fog össze. Ezt a szolgáltatást számos terminálkiszolgálón használhatja. A szolgáltatás lényege, hogy egy adott terminálkiszolgálóhoz érkező ügyfélkéréseket több kiszolgáló között oszthat el, így javítható az adott terminálkiszolgáló teljesítménye. A terheléselosztás terminálkiszolgálókon való alkalmazásának azonban vannak bizonyos korlátai. Mivel az egyes felhasználók egy csoporton belül különböző terminálkiszolgálókhoz kapcsolódhatnak, a felhasználói munkamenetek megszakadhatnak, amikor másik terminálkiszolgálóhoz irányítódnak át. Biztosítani kell, hogy a felhasználói információk és beállítások a terminálszolgáltatások terheléselosztással együtt történő alkalmazása érdekében elérhetőek maradjanak a felhasználók számára.

Ügyfélaffinitás

A Hálózati terheléselosztás szolgáltatás ügyfél affinitással, illetve anélkül is használható. A terminálszolgáltatások esetén az ügyfélaffinitást azért kell alkalmazni, hogy a hálózati terheléselosztás az ugyanazon IP-címről érkező ügyfélkéréseket ugyanahhoz a terminálkiszolgálóhoz irányítsa. Amíg az ügyfél ugyanazt az IP-címet használja, mindig ugyanahhoz a terminálkiszolgálóhoz fog kapcsolódni, ahol a felhasználói információk és beállítások hozzáférhetők.

Az IP-címek azonban nem maradnak mindig ugyanazok. Ha az IP-címek kiosztását az ügyfél bejelentkezésekor DHCP protokoll végzi, az ügyfél minden bejelentkezéskor más IP-címet kap. Emellett, ha az ügyfélnek különböző helyekről kell bejelentkeznie (például otthonról vagy a munkahelyről), az ügyfélaffinitás nem működik, mert az IP-címek eltérőek lesznek.

A hálózati terheléselosztás ügyfélaffinitás nélkül is használható. Ehhez azonban célszerű beállítani, hogy egy munkamenet automatikusan befejeződjön, ha a kapcsolat megszakad (vagy leválasztják). Ha egy munkamenet befejeződik, törlődik a terminálkiszolgálóról, és ezután már nem lehet újra csatlakozni hozzá. Így ennek a beállításnak a használata esetén a felhasználónak nem lehetnek leválasztott munkamenetei a csoporton belül található különböző kiszolgálókon. Mivel a munkamenet automatikus befejezése adatvesztéssel járhat az ügyfélnél, ez a módszer csak olyan alkalmazások futtatásánál használható, amelyek nem igénylik a pillanatnyi munka mentését. Ilyen például az adatbázisok lekérdezése. A kiszolgálónak a munkamenet automatikus befejezésére történő beállításáról A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása című témakörben olvashat.

A felhasználói információk és beállítások átirányítása

Olyan esetekben, amikor az IP-címek változása miatt a felhasználók másik terminálkiszolgálóhoz történő csatlakozása megszakad, a felhasználói adatok és beállítások átirányíthatók más helyekre, például egy dedikált fájlkiszolgálóra. Ez lehetővé teszi a felhasználók számára az adatok és beállítások elérhetőségét, függetlenül attól, hogy mely terminálkiszolgáló támogatja a kapcsolatot. A terminálszolgáltatások alkalmazásánál az egyes felhasználók fájljai és beállításai rendszerint automatikusan azon a terminálkiszolgálón találhatók, amelyre a felhasználó aktuálisan csatlakozik. A felhasználói információk és beállítások más helyre történő átirányításához a terminálszolgáltatások felhasználói profiljait be kell állítani a felhasználói adatok meghatározott tárolóhelyen történő tárolásához. További információ a Terminálszolgáltatások felhasználói fiókjainak kezelése című témakörben található.

Munkamenetekkel kapcsolatos kérdések

Amikor a felhasználói adatok és beállítások másik fájlkiszolgálóra irányítódnak át, az a munkamenet, amelyikben a fájl keletkezett, továbbra is fenntartja a nyitott fájlt, és ezzel értékes rendszererőforrásokat foglal le. A munkamenet állapota attól a terminálszolgáltatásokat futtató számítógéptől függ, amelyikben a munkamenet keletkezett, és nem osztható meg a terminálkiszolgálók között.


Terminálszolgáltatások kezelése

Ez a fejezet a következő témakörökkel foglalkozik:

  • Terminálszolgáltatások licencelése
  • Programtelepítés
  • Terminálszolgáltatások konfigurálása
  • Felhasználók és ügyfelek kezelése
  • Terminálszolgáltatások felügyelete
  • Terminálszolgáltatások parancsmutató


Programtelepítés

Ez a fejezet a többmunkamenetes használatra szánt programok terminálkiszolgálóra történő telepítését ismerteti.

  • Az alkalmazások telepítése előtt olvassa el a következő témakört: Alkalmazáskompatibilitási parancsfájlok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Programok telepítése a terminálszolgáltatások alkalmazáskiszolgálói módban való használatához.


Alkalmazáskompatibilitási parancsfájlok

Számos gyakran használt alkalmazásnál tesztelték a terminálszolgáltatásokkal való kompatibilitást. A terminálkiszolgáló alkalmazáskiszolgáló üzemmódjában a maximális teljesítmény eléréséhez egyes alkalmazásoknál a telepítés után kisebb módosítások szükségesek. Ehhez parancsfájlok állnak rendelkezésre, amelyeket az alkalmazás telepítése után kell futtatni. A parancsfájlok a rendszergyökér \Application Compatibility Scripts\Install könyvtárban találhatók.

Megjegyzés

  • A parancsfájlok egyes funkcióival és azoknak egy adott telepítéshez történő módosításával kapcsolatos tudnivalók a telepítendő program parancsfájljában lévő megjegyzésekben találhatók. A parancsfájlok szövegszerkesztővel (például a Jegyzettömb programmal) módosíthatók.

Az alábbiakban az alkalmazások és a hozzájuk tartozó parancsfájlok nevei láthatók:

Program neve | Parancsfájl neve
Corel Perfect Office 7.0, 32 bites | coffice7.cmd
Corel Perfect Office 8,0, 32 bites | coffice8.cmd
Microsoft Exchange Client 5.5 | winmsg.cmd
Lotus SmartSuite 97, 32 bites | ssuite97.cmd
Lotus SmartSuite 9.0 | ssuite9.cmd
Microsoft Office 4.3 | office43.cmd
Microsoft Office 95 | office95.cmd
Microsoft Office 97 SR1 | office97.cmd
Microsoft Project 95 | msproj95.cmd
Microsoft Project 98 | msproj98.cmd
Netscape Communicator 4.0 | netcom40.cmd
Netscape Navigator 3.0 | netnav30.cmd
Microsoft Outlook 98 | outlk98.cmd
Peachtree 2000 | pchtree6.cmd
Microsoft SNA Server 3.0 | mssna30.cmd
Microsoft SNA Client 4.0 | sna40cli.cmd
Microsoft SNA Server 4.0 | sna40srv.cmd
Microsoft Visual Studio 6.0 | msvs6.cmd

Megjegyzés

  • Nem szükséges alkalmazáskompatibilitási parancsfájlt használni, ha a Terminálszolgáltatások komponens telepítése távfelügyeleti módban történt.


Útmutató

  • Program telepítése a Programok telepítése/törlése eszközzel
  • Program telepítése a change user parancs használatával


Program telepítése a Programok telepítése/törlése eszközzel

  1. Jelentkezzen be a terminálkiszolgálóra rendszergazdaként, és zárjon be minden programot.
  2. Nyissa meg a Programok telepítése/törlése ablakot a Vezérlőpulton.
  3. A Programok telepítése/törlése ablakban kattintson az Új programok hozzáadása gombra.
  4. Válassza ki a program telepítésének módszerét, és kövesse a varázsló utasításait.
  5. A telepítő varázsló végigvezeti a telepítési folyamat lépésein. Biztonsági okokból a programot NTFS fájlrendszerhez formázott partícióra kell telepíteni.
  6. Ha szükséges, szerkessze és futtassa a program telepítőfájlját.

Megjegyzések

  • Ha a telepítés befejezésekor utasítást kap a számítógép újraindítására, kattintson a Befejezés gombra a Programok telepítése/törlése ablakban, mielőtt a számítógépet újraindítaná. Az alkalmazás telepítésének megfelelő befejezéséhez a kiszolgáló újraindítása után szükség lehet egy újbóli bejelentkezésre ugyanazon a felhasználónéven. Ne engedélyezze más felhasználók belépését ennek a lépésnek a végrehajtása előtt.

Kapcsolódó témakörök


Program telepítése a change user parancs használatával

  1. Jelentkezzen be a terminálkiszolgálóra rendszergazdaként, és zárjon be minden alkalmazást.
  2. Mutasson a Start menü Programok pontjára, majd a Kellékek pontra, ezután kattintson a Parancssor parancsra. Megjelenik a Parancssor ablak.
  3. Írja be a change user /install parancsot, és nyomja meg az ENTER billentyűt.
  4. Telepítse a programot helyi, NTFS fájlrendszerhez formázott meghajtón, ahogyan azt a telepítőprogram előírja.
  5. Miután a telepítést befejezte, a parancssorba gépelje be a change user /execute parancsot.
  6. Ha szükséges, szerkessze és futtassa a program telepítőfájlját.

Megjegyzések

  • Ha a program egy további program telepítését kéri, kiléphet az első futó programból.
  • A change user /query parancs parancssorba történő beírásával ellenőrizheti, hogy a végrehajtási mód engedélyezve van-e, és az .ini fájl hozzárendelése be van-e kapcsolva.

Kapcsolódó témakörök


Programok telepítése a terminálszolgáltatások alkalmazáskiszolgálói módban való használatához

Ez a rész általános információkat nyújt arról, hogy hogyan kell telepíteni azokat a programokat, amelyeket az alkalmazáskiszolgáló üzemmódban lévő Terminálkiszolgálón, többmunkamenetes környezetben kíván használni. A terminálszolgáltatások többmunkamenetes lehetőségei miatt a programok olyan telepítési módját igénylik, amely biztosítja az egyes munkamenetek számára a programok futtatását a kiszolgálón anélkül, hogy ez zavarná a kiszolgáló működését vagy más munkameneteket.

  • Programokkal kapcsolatos szempontok
  • Programok telepítése
  • Programok kompatibilitása

Megjegyzés

  • A Terminálszolgáltatások távfelügyeleti módja nem igényli semmilyen speciális program telepítését.


Programokkal kapcsolatos szempontok

A Terminálszolgáltatások alkalmazáskiszolgálói módjában futtatandó programok kiválasztásakor és telepítésekor számos tényezőt kell figyelembe venni. Ebben a részben a következő témakörök szerepelnek:

  • Hozzárendelt és közzétett programok
  • 16 bites és 32 bites programok
  • Rendszererőforrásokkal kapcsolatos szempontok
  • Programokat indító programok


Hozzárendelt és közzétett programok

A Windows 2000 a Windows Installer programmal biztosítja a szervezeten belüli központi programtelepítést. Egy program hozzárendelhető számítógépekhez vagy felhasználókhoz vagy közzétehető a felhasználók számára. További tudnivalók a A szoftvertelepítés ismertetése című témakörben találhatók.

Mivel a Terminálszolgáltatások komponens a programokhoz többmunkamenetes hozzáférést biztosít, további megfontolások szükségesek, mielőtt a terminálkiszolgálót tartalmazó környezetbe alkalmazásokat telepítene.

A terminálszolgáltatásoknál az alkalmazások telepítése számítógépekhez van rendelve, ami azt jelenti, hogy ezek bármely felhasználó számára rendelkezésre állnak, aki a terminálkiszolgálóhoz hozzáfér. A Terminálszolgáltatások komponens nem képes fogadni a közzétett programokat, mert a közzététel mindig felhasználónként történik. A programhozzárendelést nem felhasználónkénti, hanem számítógépenkénti alapon kell elvégezni.

Hozzárendelt program telepítésekor a programot a terminálkiszolgálón rendszergazdai jogosultsággal rendelkező felhasználó a konzolról vagy távoli munkamenetből is telepítheti.

Figyelmeztetés

  • A programtelepítés gyakran a rendszer újraindítását igényli. Programtelepítés előtt mindig biztosítsa, hogy ne legyen a terminálkiszolgálón bejelentkezett felhasználó.
  • Ha a programot távoli munkamenetből telepíti, a munkamenet leválasztódik vagy alaphelyzetbe kerül, ha a programtelepítés a kiszolgáló újraindítását igényli. Amikor a kiszolgáló újraindul, a munkamenet alaphelyzetbe kerül. Ezután a program megfelelő telepítéséhez ismét be kell jelentkeznie a terminálkiszolgálóra.
  • Ha lehetséges, a programokat a konzrolról telepítse.

Windows Installer alapú programok központi telepítése a terminálkiszolgálókra

A Windows Installer az .msi csomag létrehozási módjától függően különböző szinten telepíti a programokat. Számos .msi csomag esetén elég a minimális telepítés is, ilyenkor a programnak csak kevés összetevője telepítődik. Amikor a felhasználó először használja a programot, elegendő összetevő van telepítve ahhoz, hogy a Windows Installer felismerje, hol keresse a program további részeit a teljes telepítéshez. A Terminálszolgáltatások alkalmazáskiszolgálói üzemmódjában a felhasználók nem vehetik igénybe a Windows Installer segítségét. Ezért fontos ezen programok helyi telepítése az első telepítéskor. Ehhez egy (.mst kiterjesztésű) átalakító fájl használható. Az átalakító fájlok az .msi csomagok módosításaiként jelennek meg és arról tájékoztatják a Windows Installer programot, hogy mely összetevőket kell helyileg telepíteni. Mivel az átalakító fájlok valószínűleg nem minden program számára állnak rendelkezésre, ezért biztosítani kell, hogy minden szükséges összetevő teljes mértékben telepítésre kerüljön, vagy létre kell hozni egy átalakító fájlt. Az átalakító fájlokkal kapcsolatos további tudnivalók a Csomagmódosítások kezelése című témakörben találhatók.

A korábbi rendszerek programjai újracsomagolhatók Windows Installer alapú programokként. Ezt olyan eszközökkel lehet megvalósítani, amelyek rögzítik azokat a módosításokat, amelyek a rendszerben a program telepítése után történtek. Ezekből a módosításokból hozhatható létre az .msi csomag a korábbi rendszerek programjai számára. Ez a módszer lehetővé teszi a szervezet számára egyedileg fejlesztett programok további használatát.


16 bites és 32 bites programok

A Terminálszolgáltatások program alkalmazáskiszolgáló üzemmódban mind a 16 bites, mind a 32 bites Windows alapú programokat támogatja. A 16 bites programok futtatása 40 százalékkal csökkentheti a processzor által támogatott felhasználók számát és minden felhasználónál 50 százalékkal növelheti a memóriaigényt. Ezenkívül egyes 16 bites programoknak tudniuk kell írni abba a könyvtárba, ahol a programhoz tartozó .ini fájl található. A 32 bites programok általában a rendszerleíró adatbázisba írják be, illetve onnan olvassák ki a programbeállításokat és csak a rendszerleíró adatbázis egyes értékeit módosítják. Mind teljesítményi, mind biztonsági okokból lehetőség szerint 32 bites programokat használjon.


Rendszererőforrásokkal kapcsolatos szempontok

Alkalmazáskiszolgáló üzemmódban a Terminálszolgáltatásokat többmunkamenetes környezetben lehet használni. A több rendszererőforrást igénylő programokat korlátozni kell. Ez jelentheti meghatározott felhasználók vagy csoportok bizonyos programtípusokhoz való hozzáférésének korlátozását, a legtöbb erőforrást igénylő, szükségtelen funkciók letiltását, vagy a programok különálló kiszolgálókra történő telepítését.

Minden programnál gondosan ellenőrizze a rendszerkövetelményeket, és vegye figyelembe, hogy a RAM- és a CPU-követelmények az adott időpontban várható munkamenetek számával arányosan nőnek. Ezen követelmények között ugyan nem áll fenn egyenes arányosság, de kiindulási alapot jelentenek a program teljesítményének tervezésére.

További tudnivalók a Rendszertervezés című témakörben találhatók.


Programokat indító programok

Vannak olyan programok, amelyek lehetővé teszik, hogy a felhasználó más programokat is elindítson. A Microsoft Access eszköztáráról például Microsoft Office programok indíthatók. Lehetősége van arra, hogy letiltsa ezt a programindító eszköztárat.

A legtöbb Microsoft termék tartalmazza a Microsoft rendszerinformáció (Msinfo.exe) programot. Fennáll a lehetősége, hogy ezzel a programmal a felhasználók megsértik a biztonságot vagy rendszerinformációkhoz (például a kiszolgáló hardverkonfigurációs információihoz) jutnak. A Microsoft rendszerinformáció program fájlengedélyeit úgy kell beállítani, hogy csak a rendszergazdák futtathassák. Így használhatják a rendszer konfigurációjával kapcsolatos információk gyűjtésére, problémamegoldásra és arra, hogy a megfelelő felhasználók programjait indítsák el.


Programok telepítése

A rész tartalma:

  • Felkészülés programok telepítésére
  • A telepítés indítása
  • A telepítés tesztelése


Felkészülés programok telepítésére

Ajánlott a programokat azelőtt telepíteni, hogy engedélyezné az ügyfelek hozzáférését a kiszolgálóhoz. Így lehetőség van a program tesztelésére hozzáférés előtt, ami csökkenti a program hangolására fordítandó időt.

Ha azután telepíti a programot, hogy a felhasználók megkapták a hozzáférési engedélyt, a program telepítése alatt biztosítania kell, hogy a felhasználók ne jelentkezhessenek be a kiszolgálóra. Ajánlatos üzenetet küldeni a felhasználóknak, megadva a programtelepítés pontos idejét és időtartamát, majd az indítás előtt letiltani minden csatlakozást.

A csatlakoztatott munkamenetekkel kapcsolatos további tudnivalók a Terminálszolgáltatások kezelője - Áttekintés című témakörben találhatók.

A felhasználóknak küldhető üzenetekről további tudnivalók az Üzenet küldése a felhasználónak című témakörben találhatók.

A csatlakozások letiltásával kapcsolatos további tudnivalók a Csatlakozás letiltása című témakörben találhatók.

Megjegyzés

  • A programok telepítéséhez rendszergazdaként kell bejelentkeznie.


A telepítés indítása

A többmunkamenetes alkalmazáskiszolgálóval elérhető programok telepítéséhez az alábbi módszerek egyikét választhatja:

  • Nyissa meg a Programok telepítése/törlése párbeszédpanelt a Vezérlőpult ablakból.
  • A parancssorban adja ki a change user parancsot a telepítés előtt és után.

A change user parancs egyik elsődleges funkciója annak biztosítása, hogy a programfájlok a rendszergyökér könyvtárba kerüljenek és ne a felhasználó kezdőkönyvtárába (%homepath%\windows). Ezzel lehetőség nyílik a programok többmunkamenetes hozzáférésére.

A program telepítésének megkezdése előtt a change user /install parancs a rendszert telepítő üzemmódba állítja, és kikapcsolja az .ini fájlokban definiált hozzárendeléseket. Ezután a rendszer rögzíti, ahogyan a telepítő API-k először elvégzik a telepítést.

A programtelepítés befejeződése után a change user /execute parancs visszaállítja a rendszert végrehajtási üzemmódba, visszaállítja az .ini fájlokban definiált hozzárendeléseket, végül visszairányítja a felhasználóspecifikus adatokat a felhasználó kezdőkönyvtárába.

Amikor a felhasználó a programot elindítja, a rendszerleíró adatbázis felhasználóspecifikus beállításait tartalmazó fájlok (.ini, .dll, .ocx stb.) szükség szerint automatikusan bekerülnek a felhasználó kezdőkönyvtárába.

A telepítéshez ajánlatos a Programok telepítése/törlése program használata, mivel ez automatikusan futtatja a change user programot. Csak akkor írja be a change user parancsot a parancssorba, ha más módszer szerint telepíti a programot és többmunkamenetes hozzáférést szeretne biztosítani. Ha például az Internet Explorer 5 felszólítja egy bővítés telepítésére, használja a change user parancsot, mivel így a programok többmunkamenetes hozzáférése biztosított lesz.

Fontos

  • Néhány programnál hangolásra van szükség a többmunkamenetes környezetben való megfelelő működéshez. Program telepítése előtt nézze meg az Alkalmazáskompatibilitási parancsfájlok listában, hogy a programnak szüksége van-e parancsfájlra vagy más információkra.

További tudnivalók a Program telepítése a Programok telepítése/törlése eszközzel című témakörben találhatók.

Megjegyzések

  • Ne másoljon programfájlokat egyik könyvtárból a másikba és ne szerkessze kézzel a rendszerleíró adatbázist a telepítés alatt.
  • A fájlkiszolgáló helyett a programokat a terminálkiszolgáló helyi meghajtójára telepítse. Ez javítja a program teljesítményét.
  • A programokat FAT-fájlrendszer helyett NTFS-fájlrendszerre formázott meghajtókra telepítse. Fájlengedélyeket csak NTFS-meghajtón lehet beállítani.


A telepítés tesztelése

Egyes, a change user paranccsal telepített programok a rendszer lezárt állapota miatt először nem biztos, hogy működnek. Egyes 16 bites programoknak írási engedéllyel kell rendelkezniük ahhoz a könyvtárhoz, ahol a programhoz tartozó .ini fájl található. Egyes 32 bites programok bejegyzéseket hoznak létre a rendszerleíró adatbázisban a megfelelő működés biztosítása érdekében.

Engedélyezze az eseménynaplózást, és jelentkezzen be a kiszolgálóra egy olyan átmeneti felhasználói fiókkal, amely a program jövőbeni felhasználóját vagy felhasználóit utánozza. Indítsa el a programot és végezze el a futtatáshoz szükséges alapvető lépéseket. Ezután az Eseménynapló segítségével határozza meg, hogy a helyes működéshez a felhasználónak mely fájloknál és könyvtáraknál szükséges írási jogosultság, illetve melyik rendszerleíró kulcshoz szükséges olvasási jogosultság.

Ajánlatos két felhasználói fiókot létrehozni és mindkettőt tesztelni. Így módosíthatja a programbeállításokat és a sablonokat és meggyőződhet róla, hogy a módosítások nincsenek hatással az ugyanahhoz a csoporthoz tartozó másik felhasználóra.

Ellenőrizzen minden fájlt és minden felmerülő problémát. A programok többmunkamenetes használatával kapcsolatban további tudnivalók a Programok kompatibilitása című témakörben találhatók.


Programok kompatibilitása

Számos programot - elsősorban a régieket - nem többmunkamenetes használatra terveztek. Emiatt ezeket a programokat a terminálkiszolgálón való futtatás előtt hangolni kell.

A Microsoft egyes programokhoz telepítési parancsfájlokat biztosít, amelyek kezelik az ismert telepítési problémákat. Ezeket a parancsfájlokat a telepítést követően, de még az alkalmazás első futtatása előtt kell végrehajtani.

Más programokkal kapcsolatban ebben a fejezetben találhatók a futtatást a terminálszolgáltatások többmunkamenetes környezetében lehetővé tévő hangolási kérdések és eljárások.

  • A rendszerleíró adatbázis beállításai
  • Fájlokkal és könyvtárakkal kapcsolatos kérdések
  • Programkompatibilitási jelzők


A rendszerleíró adatbázis beállításai

A programok a konfigurációs információkat a rendszerleíró adatbázisban tárolják, amely egy rendszeradatbázis. Ebben az alkalmazásban a rendszerleíró adatbázis két legfontosabb szakaszának címe HKEY_LOCAL_MACHINE és HKEY_CURRENT_USER.

A teljes rendszerre vonatkozó információkat a HKEY_LOCAL_MACHINE részben kell tárolni. Egy program például a következő információkat tárolhatja ebben a részben:

  • A program telepített összetevői.
  • A programösszetevők betöltésének elérési útvonala.
  • Megosztott adatbázis útvonala. Ezt használhatja például egy értékesítési program, amelyben minden felhasználó ugyanarra az adatbázisra hivatkozik.

A programok a felhasználók egyéni információit a HKEY_CURRENT_USER részben tárolják, amely a felhasználói profil része. Amikor egy felhasználó bejelentkezik, a profil betöltődik a rendszerleíró adatbázis HKEY_CURRENT_USER szakaszába. Amikor a felhasználó kilép, a HKEY_CURRENT_USER minden változása visszaíródik a felhasználói profilba. A program ebben a részben az alábbi típusú információkat tárolhatja:

  • Egyéni szótárak, postafiókok, konfigurációs fájlok és ideiglenes könyvtárak elérési útjai. Az egyes felhasználókhoz tartozó elérési utak különösen fontosak a többfelhasználós környezetben.
  • Az egyes felhasználók preferenciabeállításai. Egyes felhasználók például engedélyezni, míg mások letiltani szeretnék a háttérben futó helyesírás-ellenőrzést.

Felhasználók adatai a HKEY_LOCAL_MACHINE részben

Problémák adódhatnak, ha a felhasználókhoz tartozó adatokat a programok a HKEY_LOCAL_MACHINE részben tárolják és nem a HKEY_CURRENT_USER részben. Ha a program az egyéni beállításokat (például szín és betűméret) a HKEY_LOCAL_MACHINE részben tárolja, akkor felhasználóknak nem lesz lehetőségük egyéni beállítások megadására.

Program futtatásakor létrehozott beállítások

Elképzelhető, hogy egy program akkor hozza létre a HKEY_CURRENT_USER beállításokat, amikor a felhasználó azt először futtatja és nem a telepítéskor. Ha a programot telepítő felhasználó nem futtatja a programot, amíg a telepítési üzemmód aktív, akkor a HKEY_CURRENT_USER beállítások nem másolódnak be a HKEY_LOCAL_MACHINE részbe. Amikor a felhasználók a programot először futtatják, a HKEY_CURRENT_USER részbe az alapbeállítások töltődnek be. A programtól függ, hogy ezek megfelelőek-e. Ha az alapbeállítások nem megfelelőek, akkor ezeket minden felhasználó számára külön kell módosítani.

Ezt a problémát másképpen úgy oldhatja meg, hogy a programot a telepítési üzemmódból való kilépés előtt lefuttatja. Mielőtt rákattint a Befejezés gombra a Programok telepítése/törlése párbeszédpanelen (vagy mielőtt elindítja a change user /execute parancsot), a rendszergazda futtathatja a programot, melynek során a program létrehozza a rendszerleíró adatbázis szükséges beállításait.

Ha már kilépett a telepítési üzemmódból, és a programot nem futtatta, akkor change user /install paranccsal lépjen vissza telepítési üzemmódba, majd futtassa a programot. Ha a programot már futtatta végrehajtási üzemmódban, hozzon létre egy másik rendszergazdai fiókot, majd jelentkezzen be az új fiókra és futtassa a change user /install programot. Ezután futtassa a programot, majd a change user /execute paranccsal lépjen ki a telepítési üzemmódból.


Fájlokkal és könyvtárakkal kapcsolatos kérdések

A program által létrehozott illetve használt fájlok és könyvtárak problémákat okozhatnak, ha a programot eredetileg nem többmunkamenetes környezetre tervezték.

Felhasználók adatait tároló fájlok

Elképzelhető, hogy az egyéni felhasználói adatokat tartalmazó fájlhoz a program egyetlen útvonalat használ. Bizonyos esetekben ez azt jelentheti, hogy ha egy felhasználó frissíti ezt a fájlt, akkor ez minden felhasználót érint. Összetettebb problémát jelent megakadályozni például több felhasználó egyidejű programhasználatát vagy a fájl sérülését, amelyek azt eredményezhetik, hogy a program az összes felhasználónál leáll.

Fontos megjegyezni, hogy a legtöbb fájl nem tartalmaz egyéni felhasználói adatokat, ezért biztonságosan megosztható. Egyes fájlok a rendszergazda döntésétől függően mindkét csoportba besorolhatók. Például, a dokumentumsablon-fájlok csak olvashatóvá tehetők és így biztonságosan megoszthatók. A felhasználók használhatják saját sablonfájl-készleteiket is, amelyeket tetszés szerint frissíthetnek.

Ha problémát okoz a megosztott fájlok megtalálása, a fájlnaplózás segítségével nyomon követheti a sikeres írási műveleteket.

Egyéb elérési úttal kapcsolatos problémák jelentkeznek, amikor a programok közös könyvtárakban, például a rendszergyökér könyvtárban tárolják a fájlokat. Egyes közös könyvtárakhoz a nem rendszergazda felhasználóknak csak olvasási jogosultsága lehet, ami megakadályozza a közös fájlok véletlen módosítását. Azonban ha egy program írni akar egy fájlt az egyik ilyen megosztott könyvtárban, akkor az nem fog sikerülni.

Ez a fajta hiba gyakran úgy jelentkezik, hogy a rendszergazda tudja futtatni a programot, de a nem rendszergazda felhasználók nem. A probléma okának felderítésében segít, ha a sikertelen írási műveleteket nyomon követi a fájlnaplózás segítségével.

Néhány program ideiglenes könyvtárakat használ az aktuális felhasználó adatainak tárolására. Elképzelhető, hogy a program nem hoz létre külön könyvtárat minden felhasználónak, ilyenkor a program a felhasználók ideiglenes adatait egy helyen tárolja. Ha a program nem kezeli megfelelően az ilyen típusú adatokat, akkor az egyik felhasználó törölheti a másik felhasználó számára még szükséges adatokat.

Elérési út frissítése

Amikor olyan fájlt talál, ami az egyéni felhasználói adatokat tárolja, akkor módosítsa az elérési utat úgy, hogy a fájl egy-egy másolata bekerüljön mindegyik felhasználó kezdőkönyvtárába.

A programok az elérési utakat általában következő helyek egyikén tárolják:

  • HKEY_LOCAL_MACHINE
  • HKEY_CURRENT_USERS
  • Konfigurációs fájl
  • Gyárilag kódolt a programon belül

Egyes egyéni felhasználói fájlokat a program automatikusan hoz létre. Más egyéni felhasználói fájlokat, mint például a dokumentumsablonokat, manuálisan kell bemásolni a felhasználó kezdőkönyvtárába. Ha az elérési útvonalat a felhasználó kezdőkönyvtárának alkönyvtáraként határozta meg, akkor elképhelhető, hogy létre kell hoznia az alkönyvtárat is.

Az egyéni felhasználói feladatok a bejelentkezés során parancsfájlok futtatásával is elvégezhetők. A parancsfájl a kérdéses fájlok vagy könyvtárak létezésének megállapításához megnézi a felhasználó kezdőkönyvtárát. Ha nem létezik ilyen fájl vagy könyvtár, akkor bemásolhatja őket egy főkönyvtárból. A parancsfájl használata egyrészt lehetővé teszi, hogy az aktuális felhasználó számára beállítson egy új programot, másrészt automatikusan beállítja azokat az új felhasználókat, amelyeket később szeretne a rendszerhez hozzáadni.

Engedélyek és hozzáférési lehetőség

Egy másik, elérési úttal kapcsolatos probléma, amikor a felhasználó által futtatott program nem találja meg a fájlokat a rendszergyökér könyvtárban vagy az alatt, de megtalálja őket akkor, amikor a futtatást a rendszergazda végzi.

Ez a probléma olyan programokkal fordul elő, amelyek a GetWindowsDirectory() függvényt használják a Terminálszolgáltatások telepítési könyvtárnevének meghatározásához. Ezzel a függvénnyel a programok kihasználhatják az automatikus, újbóli hozzárendelés előnyét. Ha felhasználó futtatja, akkor a függvény a felhasználó kezdőkönyvtárának Windows alkönyvtárát adja vissza.

Másrészt a rendszergazdák számára megmarad a rendszergyökér könyvtár, amely automatikusan egyéni felhasználói fájlra alakítja át a megosztott fájlokat. Ezek a fájlok azonban nem kerülnek be a felhasználó kezdőkönyvtárába.

Ez az automatikus újbóli hozzárendelés letiltható egy programkompatibilitás jelző használatával. Ez akkor megfelelő, ha a rendszergyökér könyvtárban lévő fájlokat csak olvasási hozzáféréssel használják. A kompatibilitási jelzőkkel kapcsolatos további tudnivalók a Programkompatibilitási jelzők című témakörben találhatók.


Programkompatibilitási jelzők

A programkompatibilitási jelzők olyan bejegyzések a rendszerleíró adatbázisban, amelyek a rendszer számára kompatibilitási információkat biztosítanak az adott programról. Néhány ilyen bejegyzés alapértelmezés szerint létrejön. A rendszergazdák új bejegyzéseket hozhatnak létre, illetve módosíthatják a meglévőket, hogy megoldják a kompatibilitással kapcsolatos problémákat.

Az alábbiakban a kompatibilitásjelzők listája látható, amely a

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ Windows NT\CurrentVersion\Terminal Server\ Compatibility\Applications\alkalmazásnév könyvtárban tárolható.

A kulcsok a program végrehajtható fájlneve alapján jönnek létre, a jelzők pedig KÉTSZÓ típusú értékként tárolódnak.

Érték | Leírás
0x00000001 | MS-DOS alapú program
0x00000002 | OS/2 alapú program
0x00000004 | Windows alapú, 16 bites program
0x00000008 | Windows alapú, 32 bites program
0x0000000C | Windows alapú, 16 bites és 32 bites program
0x0000000F | A program valamelyik verziója
0x00000010 | A számítógép neve helyett a felhasználó nevét adja vissza a GetComputerName függvény.
0x00000020 | A GetVersion függvény a Windows 2000 verziószáma helyett a Terminálkiszolgáló verziószámát adja vissza.
0x00000040 | Szinkronizálja a felhasználóhoz tartozó .ini fájlt a rendszerverzióval.1
0x00000080 | A program nem helyettesíti be a felhasználó \Windows könyvtárát.2
0x00000100 | A program vagy a rendszerleíró kulcs rendszerleíró adatbázisbeli hozzárendelésének tiltása.
0x00000200 | Objektumonkénti, globális felhasználó-rendszer hozzárendelés.
0x00000400 | A GetWindowsDir függvény a felhasználó \Windows könyvtára helyett a rendszer \Windows könyvtárát adja vissza.
0x00000800 | A jelentett fizikai memória korlátozása a GlobalMemoryStatus függvénynél.
0x00001000 | Objektum létrehozásának naplózása fájlba.
0x20000000 | Nem állítja a programot alvó állapotba sikertelen billentyűzet lekérdezés esetén (csak Windows alapú, 16 bites programnál).

1 Ez a beállítás új bejegyzéseket ad hozzá az .ini fájl rendszerverziójából a felhasználói verizóhoz, de nem töröl semmilyen meglevő adatot a felhasználói .ini fájlban. Alapértelmezés szerint a felhasználói .ini fájl törlődik, ha a rendszerverzióhoz képest elavulttá válik.

2 Ehhez a beállításhoz szükséges, hogy a felhasználó \Windows könyvtára ne helyettesítse a rendszer gyökérkönyvtárát egyik elérési úton sem az .ini fájlban, amikor az .ini fájl rendszerverziója bemásolódik a felhasználó \Windows könyvtárába. Ezt a helyettesítést úgy kell végezni, hogy a program a felhasználó \Windows könyvtárát használja minden adat- vagy .ini fájl módosításához.


Útmutató

  • A terminálszolgáltatások távfelügyeleti módban való engedélyezése
  • A terminálszolgáltatások alkalmazáskiszolgálói módban való engedélyezése
  • A terminálszolgáltatások kapcsolatainak konfigurálása
  • A terminálszolgáltatások kapcsolatainak kezelése
  • Kiszolgálóbeállítások konfigurálása


A terminálszolgáltatások távfelügyeleti módban való engedélyezése

  1. Nyissa meg a Programok telepítése/törlése ablakot a Vezérlőpultról.
  2. A Windows-összetevők varázsló megnyitásához kattintson a Windows-összetevők hozzáadása/eltávolítása gombra.
  3. A Windows-összetevők ablakban jelölje be a Terminálszolgáltatások jelölőnégyzetet, majd kattintson a Tovább gombra.
  4. A Terminálszolgáltatások telepítése ablakban jelölje be a Távfelügyeleti mód választógombot.

    5. A szükséges fájlokat a rendszer átmásolja a merevelemezre, és a kiszolgálószoftver a rendszer újraindítása után használható.

Megjegyzések

  • A terminálszolgáltatások távfelügyeleti módban történő engedélyezése esetén a Terminálszolgáltatások licencelése programot nem szükséges engedélyezni.
  • Bizonyos Windows-összetevőket használatuk előtt konfigurálni kell. Ha az ilyen típusú összetevők közül egyet vagy többet konfigurálás nélkül telepített, a Windows-összetevők hozzáadása/eltávolítása gombra kattintva megjelenik a konfigurálandó összetevők listája. A Windows-összetevők varázsló elindításához kattintson az Összetevők gombra.


A terminálszolgáltatások alkalmazáskiszolgálói módban való engedélyezése

  1. Nyissa meg a Programok telepítése/törlése ablakot a Vezérlőpultról.
  2. A Windows-összetevők varázsló megnyitásához kattintson a Windows-összetevők hozzáadása/eltávolítása gombra.
  3. A Windows-összetevők ablakban jelölje be a Terminálszolgáltatások jelölőnégyzetet, majd kattintson a Tovább gombra.

    A Terminálszolgáltatások licencelése program az ügyfelek engedélyezéséhez szükséges az alkalmazáskiszolgálói üzemmódban futó terminálkiszolgálón. A Terminálszolgáltatások licencelése programot nem ajánlott ugyanazon a számítógépen engedélyezni, amelyen a Terminálszolgáltatások program is fut.

  4. A Terminálszolgáltatások telepítése ablakban jelölje be az Alkalmazáskiszolgálói mód választógombot.
  5. A Terminálszolgáltatások telepítése ablakban előfordulhatnak olyan programok is, amelyek nem fognak megfelelően működni a terminálszolgáltatások engedélyezése után. Ezeket a programokat többmunkamenetes hozzáféréshez a Programok telepítése/törlése programmal a Terminálszolgáltatások engedélyezése után újra kell telepíteni.
  6. A következő képernyőn adja meg, hogy az engedélyek a Windows 2000 felhasználói vagy a Terminal Server 4.0 felhasználói engedélyeivel legyenek-e kompatibilisek. Ha A Windows 2000 felhasználóival kompatibilis engedélyek elemet választja, az alkalmazásokat a legbiztonságosabb környezetben futtathatja.
  7. A Terminálszolgáltatások licencelése telepítése ablakban adja meg, hogy a licenckiszolgálót engedélyezni szeretné-e a teljes vállalatra, illetve tartományra/munkacsoportra, majd adja meg az adatbázis könyvtárának helyét. Kattintson a Tovább gombra, majd a Befejezés gombra.

    8. A szükséges fájlokat a rendszer átmásolja a merevlemezre, és a kiszolgálószoftver a rendszer újraindítása után használható.

Megjegyzések

  • A Terminálszolgáltatások és a Terminálszolgáltatások licencelése programok a Windows 2000 Server Telepítő futtatása közben is engedélyezhetők.
  • Bizonyos Windows-összetevőket használatuk előtt konfigurálni kell. Ha az ilyen típusú összetevők közül egyet vagy többet konfigurálás nélkül telepített, a Windows-összetevők hozzáadása/eltávolítása gombra kattintva megjelenik a konfigurálandó összetevők listája. A Windows-összetevők varázsló elindításához kattintson az Összetevők gombra.


A terminálszolgáltatások kapcsolatainak konfigurálása

  • Új kapcsolat létrehozása
  • A kiszolgálóhoz csatlakoztatható munkamenetek maximális számának meghatározása
  • A titkosítási szint módosítása
  • A felhasználó belépésekor automatikusan induló program meghatározása
  • Felhasználó automatikus bejelentkezésének engedélyezése a kiszolgálóra
  • Távvezérlés kezelése
  • Időtúllépési és újracsatlakozási beállítások konfigurálása
  • Ügyfélbeállítások kezelése
  • Csatlakozási engedélyek kezelése


Új kapcsolat létrehozása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A Művelet menüben kattintson az Új kapcsolat létrehozása parancsra.
  4. Megjelenik a Terminálszolgáltatások csatlakoztatása varázsló. A kapcsolat beállításához kövesse a képernyőn megjelenő utasításokat.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Egy terminálkiszolgálón minden hálózati csatolóhoz csak egy RDP-kapcsolat (Remote Desktop protokoll) konfigurálható. Általában csak egyetlen, a Terminálszolgáltatások program telepítésekor automatikusan konfigurált RDP-kapcsolatra van szükség. Az RDP segítségével további kapcsolatokat is beállíthat, ha a számítógépen minden egyes kapcsolathoz telepít hálózati csatolót.

Kapcsolódó témakörök


A kiszolgálóhoz csatlakoztatható munkamenetek maximális számának meghatározása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyhez a munkamenetek maximális számát meg szeretné határozni, majd kattintson a Tulajdonságok parancsra.
  4. A Hálózati kártya lapon jelölje be a Kapcsolatok maximális száma választógombot, írja be a kiszolgálóhoz csatlakoztatható maximális munkamenetek számát, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Alapértelmezés szerint a kapcsolat úgy van beállítva, hogy a kiszolgálóhoz korlátlan számú munkamenet csatlakozását engedélyezi.
  • A munkamenetek számának korlátozása javítja a teljesítményt, mivel kevesebb munkamenet foglalja le a rendszererőforrásokat.

Kapcsolódó témakörök


A titkosítási szint módosítása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblán kattintson jobb gombbal a módosítani kívánt kapcsolatra, majd kattintson a Tulajdonságok parancsra.

  4. Az Általános lapon, a Titkosítási szint mezőben válassza ki a szervezetnek megfelelő szintet. Az alábbi titkosítási szintek közül választhat:

    Az Alacsony szint 40 bites vagy 56 bites kulccsal titkosítja az ügyféltől a kiszolgáló felé továbbított összes adatot. A Windows 2000 terminálkiszolgáló Windows 2000 ügyfél csatlakozása esetén 56 bites titkosítási kulcsot használ, korábbi verziót használó ügyfél csatlakozása esetén pedig 40 bites titkosítási kulcsot. Ezt a - csak bevitt adatokra vonatkozó - titkosítást olyan érzékeny adatokhoz használják, mint amilyen például a felhasználó jelszava.

    A Közepes szint 40 bites vagy 56 bites kulccsal titkosítja az ügyfél és kiszolgáló között továbbított összes adatot. A Windows 2000 terminálkiszolgáló Windows 2000 ügyfél csatlakozása esetén 56 bites titkosítási kulcsot használ, korábbi verziót használó ügyfél csatlakozása esetén pedig 40 bites titkosítási kulcsot. A közepes titkosítási szint a hálózat távoli ügyfeleinek képernyőire küldött bizalmas adatok védelmének biztosítására használható azok továbbítása közben.

    Ha az Egyesült Államokban vagy Kanadában van, választhatja a Magas titkosítási szintet is, amely az ügyfél és a kiszolgáló között továbbított adatforgalmat erős, 128 bites titkosítás használatával biztosítja.

  5. Ha a kapcsolatot úgy szeretné beállítani, hogy egy másik hitelesítési csomag kiszolgálóra történő telepítése esetén alapértelmezés szerint szabványos Windows-hitelesítést használjon, jelölje be a Szabványos Windows hitelesítés használata jelölőnégyzetet.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Az összes szint a szabványos RSA RC4 típusú titkosítást használja.

Kapcsolódó témakörök


A felhasználó belépésekor automatikusan induló program meghatározása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyhez meg kívánja határozni a kezdőprogramot, majd kattintson a Tulajdonságok parancsra.
  4. A Környezet lapon, a Kezdőprogram területen jelölje be A felhasználói profilból és a Csatlakozáskezelő varázslótól származó beállítások felülírása jelölőnégyzetet.

    Ezzel lehetővé teszi a kezdőprogram megadását a kapcsolathoz.

  5. A Program elérési útja és fájlneve mezőbe írja be annak a programnak a fájlnevét és elérési útját, amelyet a felhasználó terminálkiszolgálóra történő bejelentkezésekor el kíván indítani.
  6. Az Indítás helye mezőben adja meg a program munkakönyvtárának elérési útját.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Felhasználó automatikus bejelentkezésének engedélyezése a kiszolgálóra

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyen keresztül engedélyezni kívánja a felhasználó automatikus bejelentkezését, majd kattintson a Tulajdonságok parancsra.
  4. A Bejelentkezési beállítások lapon jelölje be a A következő bejelentkezési információk használata mindig választógombot.

    Ezzel lehetővé teszi a felhasználó bejelentkezési információinak megadását.

  5. A Felhasználónév mezőbe írja be annak a felhasználónak a nevét, aki számára engedélyezni kívánja a kiszolgálóra történő automatikus belépést.
  6. A Tartomány mezőbe írja be annak a tartománynak a nevét, amelyhez a felhasználó számítógépe tartozik.
  7. A Jelszó és a Jelszó megerősítése mezőkbe írja be a felhasználó jelszavát.
  8. Jelölje be a Jelszót mindig meg kell adni jelölőnégyzetet, ha azt szeretné, hogy a felhasználó a kiszolgálóra történő belépés előtt mindig kapjon felszólítást a jelszó megadására.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Távvezérlés kezelése

  • Távvezérlési beállítások konfigurálása
  • Távvezérlés letiltása


Távvezérlési beállítások konfigurálása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyhez távvezérlést kíván meghatározni, majd kattintson a Tulajdonságok parancsra.
  4. A távvezérlés konfigurálásához a Távvezérlés lapon jelölje be a Távvezérlés használata a következő beállításokkal választógombot.
  5. Ha az ügyfélnek üzenetet kíván küldeni, amelyben a megfigyeléshez vagy a munkamenetben való részvételhez kér engedélyt, jelölje be a Felhasználó engedélye szükséges jelölőnégyzetet.
  6. A Vezérlési szintje területen jelölje be A munkamenet figyelése választógombot, ha azt szeretné, hogy a felhasználói munkamenet csak megfigyelhető legyen, vagy válassza a Beavatkozás a munkamenetbe választógombot, ha azt szeretné, hogy a felhasználó munkamenete a billentyűzettel és egérrel aktívan irányítható legyen.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Másik felhasználó munkamenetének távvezérlését a Terminálszolgáltatások kezelője programból kezdeményezheti. A távvezérléssel kapcsolatos bővebb információkért kattintson a Kapcsolódó témakörök hivatkozásra.
  • A távvezérlés kapcsolatonként történő konfigurálása a kapcsolatot használó összes munkamenetet érinti. A távvezérlés felhasználónként is konfigurálható a Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményével.

Kapcsolódó témakörök


Távvezérlés letiltása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelynek a távvezérlését le kívánja tiltani, majd kattintson a Tulajdonságok parancsra.
  4. A Távvezérlés lapon jelölje be A távvezérlés nincs engedélyezve választógombot.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Időtúllépési és újracsatlakozási beállítások konfigurálása

  • Időtúllépés beállítása leválasztott, aktív és üresjárati munkamenetekhez
  • A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása
  • Leválasztott munkamenetek újracsatlakoztatására vonatkozó beállítások módosítása


Időtúllépés beállítása leválasztott, aktív és üresjárati munkamenetekhez

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelynek az időtúllépési beállításait módosítani szeretné, majd kattintson a Tulajdonságok parancsra.
  4. A Munkamenetek lapon jelölje be a Leválasztott munkamenet befejezése terület fölött található Felhasználói beállítások felülbírálása jelölőnégyzetet.

    Ezzel lehetővé teszi a kapcsolat időtúllépésének beállítását.

  5. Konfigurálja a kívánt időtúllépési beállításokat:
    • A Leválasztott munkamenet befejezése mezőben adja meg azt a maximális időtartamot, amíg a leválasztott munkamenet a kiszolgálón futhat. Ha letelik a megadott időtartam, a leválasztott munkamenet véget ér. Amikor a munkamenet véget ér, véglegesen törlődik a kiszolgálóról. Ha azt szeretné, hogy a leválasztott munkamenetek korlátlan ideig futhassanak a kiszolgálón, válassza a Soha lehetőséget.
    • Az Aktív kapcsolat időkorlátja mezőben adja meg azt a maximális időtartamot, amíg a felhasználói munkamenet a kiszolgálón aktív maradhat. Ha letelik a megadott időtartam, a rendszer leválasztja a felhasználót a munkamenetről, vagy a munkamenet befejeződik. Amikor a munkamenet véget ér, véglegesen törlődik a kiszolgálóról. Ha azt szeretné, hogy a munkamenet korlátlan ideig futhasson, válassza a Soha lehetőséget.
    • Az Üresjárat időkorlátja mezőben adja meg azt maximális időtartamot, amíg az üresjárati (ügyféltevékenység nélküli) munkamenet a kiszolgálón futhat. Ha letelik a megadott időtartam, a rendszer leválasztja a felhasználót a munkamenetről, vagy a munkamenet befejeződik. Amikor a munkamenet véget ér, véglegesen törlődik a kiszolgálóról. Ha azt szeretné, hogy az üresjárati munkamenetek korlátlan ideig futhassanak a kiszolgálón, válassza a Soha lehetőséget.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Ezek a beállítások minden ügyfelet érintenek, akik az adott kapcsolatot használják a terminálkiszolgálóhoz történő csatlakozásra. A Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek modulok Terminálszolgáltatások bővítményének használatával a beállítások felhasználónként is megadhatók.

Kapcsolódó témakörök


A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal a módosítani kívánt kapcsolatra, majd kattintson a Tulajdonságok parancsra.
  4. A Munkamenetek lapon jelölje be A munkamenet határértékénél vagy a kapcsolat megszakadásakor: terület fölött található Felhasználói beállítások felülbírálása jelölőnégyzetet.

    Ezzel lehetővé teszi a kapcsolat ezen beállításainak megadását.

  5. A munkamenet határértékénél vagy a kapcsolat megszakadásakor: területen tegye a következők egyikét:
    • Ha a felhasználót le kívánja választani a munkamenetről úgy, hogy később visszacsatlakozhasson hozzá, jelölje be a Leválás a munkamenetről választógombot.
    • Ha be kívánja zárni a munkamenetet, jelölje be a Munkamenet befejezése választógombot. Amikor a munkamenet befejeződik, véglegesen törlődik a kiszolgálóról. Minden futó alkalmazás bezáródik, ami az ügyfél adatainak elvesztését eredményezheti.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • A kiszolgálóval való kapcsolat bármilyen okból megszakadhat: kérésre, csatlakozási hiba esetén, illetve az üresjárati időkorlát vagy a csatlakozási időkorlát túllépése miatt.
  • Ezek a beállítások minden ügyfelet érintenek, akik az adott kapcsolatot használják a terminálkiszolgálóhoz történő csatlakozásra. A Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek modulok Terminálszolgáltatások bővítményének használatával a beállítások felhasználónként is megadhatók.

Kapcsolódó témakörök


Leválasztott munkamenetek újracsatlakoztatására vonatkozó beállítások módosítása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal a módosítani kívánt kapcsolatra, majd kattintson a Tulajdonságok parancsra.
  4. A Munkamenetek lapon jelölje be a Visszacsatlakozás engedélyezése terület fölött található Felhasználói beállítások felülbírálása jelölőnégyzetet.

    Ezzel lehetővé teszi a kapcsolat visszacsatlakozási beállításainak konfigurálását.

  5. A Visszacsatlakozás engedélyezése területen tegye a következők egyikét:
    • Ha azt szeretné, hogy a felhasználó a leválasztott munkamenethez bármely számítógépről visszacsatlakozhasson, jelölje be a Bármely ügyféltől választógombot.
    • Ha azt szeretné, hogy a felhasználó csak arról az ügyfélgépről csatlakozhasson vissza a leválasztott munkamenethez, amelyen a munkamenetet elindította, jelölje be az Előző ügyféltől választógombot.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • A rendszer ezt a beállítást csak Citrix CA alapú ügyfelek esetén támogatja.
  • A rendszer alapértelmezés szerint bármelyik számítógépről engedélyezi a leválasztott munkamenetekhez való visszacsatlakozást.

Kapcsolódó témakörök


Ügyfélbeállítások kezelése

  • Ügyfélmeghajtók és -nyomtatók csatalakoztatása bejelentkezéskor
  • Ügyféleszköz-hozzárendelések beállításainak konfigurálása


Ügyfélmeghajtók és -nyomtatók csatlakoztatása bejelentkezéskor

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyhez az ügyfélmeghajtókat és -nyomtatókat csatlakoztatni szeretné, majd kattintson a Tulajdonságok parancsra.
  4. Az Ügyfél beállításai lapon jelölje be a Kapcsolat területen található A kapcsolat beállításainak öröklése a felhasználótól jelölőnégyzetet.

    Ezzel lehetővé teszi a kapcsolat ezen beállításainak megadását.

  5. Válasszon az alábbi lehetőségek közül:
    • Ha bejelentkezéskor minden hozzárendelt ügyfélmeghajtót automatikusan kíván újracsatlakoztatni, jelölje be az Ügyfélmeghajtók csatlakoztatása bejelentkezéskor jelölőnégyzetet. A rendszer ezt a beállítást csak Citrix CA alapú ügyfelek esetén támogatja.
    • Ha bejelentkezéskor minden hozzárendelt helyi ügyfélnyomtatót automatikusan kíván újracsatlakoztatni, jelölje be az Ügyfélnyomtatók csatlakoztatása bejelentkezéskor jelölőnégyzetet.
    • Ha nyomtatáshoz az ügyfél alapértelmezett nyomtatóját kívánja használni, jelölje be Az alapértelmezett nyomtató az ügyfél fő nyomtatója jelölőnégyzetet. Ha nem adja meg ezt a beállítást, az ügyfél minden munkamenetben a kiszolgálón beállított alapértelmezett nyomtatót fogja használni.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Ne feledje, hogy az ügyfélmeghajtók és -nyomtatók automatikus újracsatlakozatása az összes olyan ügyfelet érinti, amely az adott kapcsolatot használja a terminálkiszolgálóra történő bejelentkezéshez. A Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek modulok Terminálszolgáltatások bővítményének használatával a beállítások felhasználónként is megadhatók.

Kapcsolódó témakörök


Ügyféleszköz-hozzárendelések beállításainak konfigurálása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyhez az ügyféleszköz-hozzárendeléseket be szeretné állítani, majd kattintson a Tulajdonságok parancsra.
  4. Az Ügyfél beállításai lapon, A következő lehetőségek tiltása területen a következő lehetőségek közül választhat:
    • Ha le kívánja tiltani az ügyfélmeghajtó hozzárendelését, jelölje be a Meghajtó hozzárendelése jelölőnégyzetet. Ez a szolgáltatás alapértelmezés szerint engedélyezve van. A rendszer ezt a beállítást csak Citrix CA alapú ügyfelek esetén támogatja.
    • Ha le kívánja tiltani az ügyfél Windows-nyomtatójának hozzárendelését, jelölje be a Windows-nyomtató hozzárendelése jelölőnégyzetet. Ez a szolgáltatás alapértelmezés szerint engedélyezve van. Ha ez a jelölőnégyzet nincs bejelölve, az ügyfelek Windows-nyomtatókat rendelhetnek hozzá, és bejelentkezéskor a rendszer az ügyfelek összes nyomtatási várólistáját automatikusan újracsatlakoztatja. Ha azonban mind az LPT-, mind a COM-port hozzárendelése le van tiltva, akkor nem lehet manuálisan létrehozni nyomtatókat. Ha a jelölőnégyzet be van jelölve, az ügyfelek nem rendelhetnek hozzá Windows-nyomtatókat, és bejelentkezéskor a rendszer nem csatlakoztatja újra az ügyfelek nyomtatási várólistáit. Manuálisan azonban újra csatlakoztatni lehet a nyomtatókat, ha az LPT- vagy a COM-port hozzárendelése engedélyezve van.
    • Ha le kívánja tiltani az LPT-port hozzárendelését, jelölje be az LPT-port hozzárendelése jelölőnégyzetet. Ez a szolgáltatás alapértelmezés szerint engedélyezve van. Ha a jelölőnégyzet nincs bejelölve, az ügyfél LTP-portjait a rendszer automatikusan hozzárendeli a nyomtatáshoz, és elérhetővé teszi a Nyomtató hozzáadása varázsló portlistáján. Az LPT-porthoz csatlakozó nyomtatót a Nyomtató hozzáadása varázsló segítségével manuálisan kell létrehoznia. Ha a jelölőnégyzet be van jelölve, a rendszer nem rendeli hozzá automatikusan az ügyfél LTP-portjait. Ebben az esetben nem lehet manuálisan létrehozni LPT-porthoz csatlakozó nyomtatót.
    • Ha le kívánja tiltani a COM-port hozzárendelését, jelölje be a COM-port hozzárendelése jelölőnégyzetet. Ez a szolgáltatás alapértelmezés szerint le van tiltva. Ha a jelölőnégyzet nincs bejelölve, az ügyfél COM-portjait a rendszer automatikusan hozzárendeli a nyomtatáshoz, és elérhetővé teszi a Nyomtató hozzáadása varázsló portlistáján. A COM-porthoz csatlakozó nyomtatót a Nyomtató hozzáadása varázsló segítségével manuálisan kell létrehoznia. Ha a jelölőnégyzet be van jelölve, a rendszer nem rendeli hozzá automatikusan az ügyfél COM-portjait. Ebben az esetben nem lehet manuálisan létrehozni COM-porthoz csatlakozó nyomtatót.
    • Ha le kívánja tiltani a vágólap hozzárendelését, jelölje be a Vágólap hozzárendelése jelölőnégyzetet. Ez a szolgáltatás alapértelmezés szerint engedélyezve van.
    • Ha le kívánja tiltani a hangeszközök hozzárendelését, jelölje be a Hangeszközök hozzárendelése jelölőnégyzetet. Ez a szolgáltatás alapértelmezés szerint le van tiltva. A rendszer ezt a beállítást csak Citrix CA alapú ügyfelek esetén támogatja.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Csatlakozási engedélyek kezelése

  • Felhasználók és csoportok hozzáadása az engedélylistákhoz
  • Felhasználó vagy csoport csatlakozási engedélyének módosítása
  • Felhasználó vagy csoport eltávolítása az engedélylistákról


Felhasználók és csoportok hozzáadása az engedélylistákhoz

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelynek az engedélyeit konfigurálni kívánja, majd kattintson a Tulajdonságok parancsra.
  4. Az Engedélyek lapon kattintson a Hozzáadás gombra, amellyel megnyitható a Felhasználók, Számítógépek vagy Csoportok kijelölése ablak.
  5. Válasszon egy elemet a Név oszlopban található objektumlistából, majd kattintson a Hozzáadás gombra.
  6. Kattintson az OK gombra. A választott objektum megjelenik a Név listában.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Hozzáadásukkor a felhasználókhoz és csoportokhoz az alapértelmezett beállítások kerülnek megadásra. Az engedélyek módosításával kapcsolatos információkért kattintson a Kapcsolódó témakörök hivatkozásra.

Kapcsolódó témakörök


Felhasználó vagy csoport csatlakozási engedélyének módosítása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelynek az engedélyét módosítani szeretné, majd kattintson a Tulajdonságok parancsra.
  4. Az Engedélyek lapon kattintson a Speciális gombra a Hozzáférés-vezérlési beállítások párbeszédpanel megnyitásához.
  5. Az Engedélybejegyzések listában válassza ki azt a felhasználót vagy csoportot, amelynek az engedélyét módosítani szeretné, majd kattintson a Megjelenítés/szerkesztés gombra az Engedélybejegyzés párbeszédpanel megnyitásához.
  6. Az Engedélyek listában jelölje be vagy törölje a jelet a beállítani kívánt engedélyek mellett található Engedélyezés vagy Megtagadás jelölőnégyzetekből.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Felhasználó vagy csoport eltávolítása az engedélylistákról

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelynek az engedélyeit módosítani szeretné, majd kattintson a Tulajdonságok parancsra.
  4. Az Engedélyek lapon a Név listában válassza ki azt a felhasználót vagy csoportot, amelyet el kíván távolítani, majd kattintson az Eltávolítás gombra.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


A terminálszolgáltatások kapcsolatainak kezelése

  • Kapcsolat tiltása
  • Kapcsolat engedélyezése
  • Kapcsolat átnevezése
  • Kapcsolat törlése


Kapcsolat tiltása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.

  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyet le szeretne tiltani, mutasson a Minden feladat pontra, majd kattintson a Kapcsolat tiltása parancsra.

    Kattintson az Igen gombra a kapcsolat tiltásának megerősítéséhez. Ha a kiszolgálón aktív munkamenetek futnak, figyelmeztetést kap, hogy a munkamenetek befejeződnek, ha a kapcsolatot letiltja. Egy aktív munkamenet figyelmeztetés nélküli befejezése az ügyfél adatainak elvesztését eredményezheti.

  4. Ha a kapcsolatot letiltja, a felhasználók azt addig nem használhatják a kiszolgálóhoz történő csatlakozáshoz, amíg újra nem engedélyezi.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Új programok telepítésekor célszerű minden kapcsolatot letiltani. Így megakadályozható, hogy a felhasználók telepítés közben jelentkezzenek be a kiszolgálóra.


Kapcsolat engedélyezése

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.

  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyet engedélyezni szeretne, mutasson a Minden feladat pontra, majd kattintson a Kapcsolat engedélyezése parancsra.

    Ha a kapcsolatot engedélyezi, a felhasználók a kapcsolaton keresztül a terminálkiszolgálóhoz csatlakozhatnak.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.


Kapcsolat átnevezése

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal arra a kapcsolatra, amelyet át szeretne nevezni, mutasson a Minden feladat pontra, majd kattintson a Kapcsolat átnevezése parancsra.
  4. Az Új név mezőbe írja be a kapcsolat új nevét.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.


Kapcsolat törlése

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kapcsolatok elemére.

  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal a törölni kívánt kapcsolatra, majd kattintson a Törlés parancsra.

    Kattintson az Igen gombra a kapcsolat törlésének megerősítéséhez. Ha a kiszolgálón aktív munkamenetek futnak, figyelmeztetést kap, hogy a munkamenetek befejeződnek, ha a kapcsolatot törli. Egy aktív munkamenet figyelmeztetés nélküli befejezése az ügyfél adatainak elvesztését eredményezheti.

  4. A munkamenet véglegesen törlődik a kiszolgálóról.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.


Kiszolgálóbeállítások konfigurálása

  • A terminálkiszolgáló üzemmódjának megtekintése
  • Ideiglenes mappák törlése vagy megőrzése kilépéskor
  • Eltérő ideiglenes mappák használata az egyes munkamenetekhez
  • Az internetes csatlakozás licencelésének engedélyezése vagy letiltása
  • Az Active Desktop letiltása
  • Váltás az alapértelmezett engedélyek között az alkalmazáskompatibilitás érdekében


A terminálkiszolgáló üzemmódjának megtekintése

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kiszolgáló beállításai elemére.

  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal a Terminálkiszolgáló üzemmódja elemre, majd kattintson a Tulajdonságok parancsra.

    Megjelenik egy párbeszédpanel, amelyen megtekintheti, hogy a terminálszolgáltatások pillanatnyilag milyen üzemmódban fut.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Ideiglenes mappák törlése vagy megőrzése kilépéskor

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kiszolgáló beállításai elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal az Ideiglenes mappák törlése kilépéskor elemre, majd kattintson a Tulajdonságok parancsra.
  4. Ha az ideiglenes mappákat kilépéskor automatikusan töröltetni szeretné, jelölje be az Igen választógombot, a mappák megőrzéséhez válassza a Nem választógombot.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Eltérő ideiglenes mappák használata az egyes munkamenetekhez

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kiszolgáló beállításai elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal a Munkamenetenkénti ideiglenes mappák használata elemre, majd kattintson a Tulajdonságok parancsra.
  4. Ha minden új munkamenetben más-más ideiglenes mappát kíván használni, jelölje be az Igen választógombot.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.
  • Ha nem akar minden munkamenetben más ideiglenes mappát használni, válassza a Nem választógombot.

Kapcsolódó témakörök


Az internetes csatlakozás licencelésének engedélyezése vagy letiltása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kiszolgáló beállításai elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal az Internetes csatlakozás licencelése elemre, majd kattintson a Tulajdonságok parancsra.
  4. Az Internetes csatlakozás licencelése területen, a kívánt céltól függően, válassza az Engedélyezés vagy a Tiltás lehetőséget. Alapértelmezés szerint az internetes csatlakozás licencelése le van tiltva.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.

Kapcsolódó témakörök


Az Active Desktop letiltása

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. Kattintson a konzolfa Kiszolgáló beállításai elemére.
  3. A részleteket tartalmazó ablaktáblában kattintson jobb gombbal az Active Desktop elemre, majd kattintson a Tulajdonságok parancsra.
  4. Jelölje be Az Active Desktop tiltása jelölőnégyzetet.

Megjegyzés

  • A Terminálszolgáltatások konfigurálása program elindításához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások konfigurálása parancsra.


Váltás az alapértelmezett engedélyek között az alkalmazáskompatibilitás érdekében

  1. Nyissa meg a Terminálszolgáltatások konfigurálása ablakot.
  2. A konzolfán kattintson a Kiszolgáló beállításai elemre.
  3. A részleteket megjelenítő ablaktáblában kattintson jobb gombbal az Engedélykompatibilitás elemre, majd válassza a Tulajdonságok parancsot.
  4. A legbiztonságosabb környezetet A Windows 2000 felhasználóival kompatibilis engedélyek kiválasztásával érheti el. Ha olyan környezetet szeretne kialakítani, mely a legtöbb örökölt alkalmazással kompatibilis, válassza A Terminal Server 4.0 felhasználóival kompatibilis engedélyek lehetőséget.

Megjegyzések

  • A Terminálszolgáltatások konfigurálása megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül válassza a Terminálszolgáltatások konfigurálása parancsot.
  • A beállítás csak akkor konfigurálható, ha a Terminálszolgáltatások alkalmazáskiszolgálói módban fut.
  • Ha A Windows 2000 felhasználóival kompatibilis engedélyek elemet választja, a Terminálkiszolgáló felhasználói ugyanazokkal az engedélyekkel fognak rendelkezni, mint a Felhasználók csoport tagjai, és kevés örökölt alkalmazást tudnak futtatni.
  • Ha A Terminal Server 4.0 felhasználóival kompatibilis engedélyek elemet választja, minden felhasználó teljeskörű hozzáféréssel rendelkezik a rendszerleíró adatbázis és a fájlrendszer legfontosabb helyeihez. A legtöbb örökölt alkalmazás csak így futtatható.


Fogalmak

Ez a fejezet a terminálszolgáltatások kapcsolatainak konfigurálását mutatja be.

  • Terminálszolgáltatások konfigurálása program – áttekintés
  • A Terminálszolgáltatások konfigurálása program használata


Terminálszolgáltatások konfigurálása – áttekintés

A terminálszolgáltatások kapcsolata olyan kapcsolat, amelyen keresztül az ügyfelek a kiszolgálón futó munkamenetekbe bejelentkezhetnek. A TCP/IP-kapcsolat konfigurálása automatikusan történik, amikor a Windows 2000 kiszolgálón engedélyezi a terminálszolgáltatásokat. A Terminálszolgáltatások konfigurálása program használatával megváltoztathatók a kapcsolat jellemzői, illetve az új kapcsolatok hozzáadásának jellemzői.

Terminálszolgáltatások konfigurálása

A Terminálszolgáltatások konfigurálása program megnyitásakor látható, hogy már létezik egy konfigurált csatlakozás. Ezt RDP-TCP csatlakozásnak nevezik. A terminálkiszolgáló használatához általában csak ezt az egy csatlakozást kell konfigurálni az ügyfelek számára. A terminálkiszolgálók esetén minden hálózati csatolóhoz csak egy RDP-csatlakozás (Remote Desktop protokoll) konfigurálható. Ha további RDP-kapcsolatokat szeretne konfigurálni, további hálózati csatolókat kell telepítenie.

A Terminálszolgáltatások konfigurálása programmal megváltoztathatók az RDP-TCP-kapcsolat jellemzői, beleértve annak az időnek a megadását, amíg az ügyfélmunkamenet aktív marad a kiszolgálón, a titkosítás védelmi szintjének beállítását, illetve a felhasználók és csoportok engedélyeinek kiválasztását. A Helyi felhasználók és csoportok Terminálszolgáltatások bővítményével néhány kapcsolat tulajdonsága felhasználónként is konfigurálható. Az egyes felhasználók munkameneteihez például eltérő időkorlátokat adhat meg. A Terminálszolgáltatások konfigurálása programmal a munkamenetek időkorlátai csak kapcsolatonként adhatók meg, ami azt jelenti, hogy a kiszolgálóra ugyanazon a kapcsolaton keresztül bejelentkezett összes felhasználóra ugyanaz az időkorlát vonatkozik.

A Terminálszolgáltatások konfigurálása programmal nemcsak a kapcsolatok konfigurálhatók, hanem a terminálkiszolgálóra vonatkozó beállítások is megadhatók. Ilyenek például az ideiglenes mappák beállításai, az alapértelmezett kapcsolatbiztonság beállítása, valamint az internetes csatlakozás licencelésének engedélyezése vagy letiltása. További információ a Kiszolgálóbeállítások konfigurálása című témakörben található.

Citrix ICA alapú ügyfelek

A Terminálszolgáltatások konfigurálása program Citrix ICA alapú ügyfelek kapcsolatainak a beállításához is használható. Ha a rendszerhez Citrix ICA protokoll és Citrix ICA alapú ügyfélszoftver kerül hozzáadásra, ezek a kapcsolatok TCP/IP, aszinkron, IPX/SPX vagy NetBIOS átviteli protokollokkal konfigurálhatók.


A Terminálszolgáltatások konfigurálása program használata

A rész tartalma:

  • A titkosítási szint meghatározása
  • Távvezérlés használata
  • Munkamenet időkorlátjainak konfigurálása
  • Csatlakozási engedélyek kezelése
  • Ügyfelekhez történő meghajtó-, nyomtató- és eszköz-hozzárendelések kezelése
  • Kiszolgálóbeállítások konfigurálása


A titkosítási szint meghatározása

A terminálszolgáltatások kapcsolatainál az adatok védelmét az ügyfél és a kiszolgáló közötti kommunikációs kapcsolaton történő titkosítással lehet megoldani. Mindenképp engedélyezze a titkosítást, ha az ügyfél és a kiszolgáló között fennállhat az adatokhoz való jogosulatlan hozzáférés lehetősége. A terminálszolgáltatások több titkosítási szintet támogat; ezért a kapcsolat titkosítási szintjének beállítása előtt határozza meg a saját szervezete számára megfelelő szintet. Minden szint a szabványos RSA RC4 titkosítási eljárást használja.

Három titkosítási szint áll rendelkezésre:

Titkosítási szint | Leírás
Alacsony | Ez a szint 56 bites vagy 40 bites kulccsal titkosít minden, az ügyféltől a kiszolgáló felé küldött adatot. A Windows 2000 terminálkiszolgáló a Windows 2000 ügyfelek csatlakozása esetén 56 bites, régebbi verziójú ügyfeleknél 40 bites kulcsot használ. Ezt a - csak bevitt adatokra vonatkozó - titkosítást olyan bizalmas adatokhoz használják, mint amilyen például a felhasználó jelszava.
Közepes | Ez a szint mindkét irányban (az ügyféltől a kiszolgáló, illetve a kiszolgálótól az ügyfél felé), 56 bites vagy a 40 bites kulcsok alkalmazásával titkosítja az adatforgalmat. A Windows 2000 terminálkiszolgáló Windows 2000 ügyfél esetében 56, korábbi verziót használó ügyfél csatlakozása esetén 40 bites kulcsot alkalmaz. A közepes titkosítási szint a hálózat távoli ügyfeleinek képernyőire küldött bizalmas adatok védelmének biztosítására használható azok továbbítása közben.
Magas | Ha az Egyesült Államokban vagy Kanadában van, választhatja a magas titkosítási szintet is. A magas titkosítási szint az összes adatot titkosítja mindkét irányban, de a titkosítás a nem exportálható 128 bites kulccsal történik.


Távvezérlés használata

A terminálkiszolgálóra bejelentkezett ügyfél műveleteit a felhasználó munkamenetének másik munkamenetből történő távvezérlésével felügyelheti. A távvezérlés lehetővé teszi más munkamenetek megfigyelését, illetve aktív irányítását is. Ha a felhasználói munkamenet aktív irányítását választja, lehetősége van billentyűzet- és egérműveletek alkalmazására is a munkamenetben. A munkamenet távvezérlése előtt az ügyfél munkamenetén üzenetben engedély kérhető a munkamenet megtekintésére vagy az abban való részvételre. A Terminálszolgáltatások konfigurálása program használatával megadhatók a kapcsolatra vonatkozó távvezérlési beállítások, a Terminálszolgáltatások kezelője programban pedig elindíthatja egy adott ügyfél munkamenetének távvezérlését. A távvezérlés konfigurálásával kapcsolatban a Távvezérlési beállítások konfigurálása című témakörben tájékozódhat. A távvezérlés használatával kapcsolatos útmutatások a Munkamenet távvezérlése című témakörben találhatók.

Megjegyzések

  • A Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményében a távvezérlés felhasználói alapon is konfigurálható.
  • A konzolmunkamenet nem távvezérelhet másik munkamenetet, és ügyfélmunkamenet sem távvezérelheti a konzolmunkamenetet.
  • A távvezérlő munkamenetet futtató számítógépnek támogatnia kell a távvezérelt ügyfél munkamenete által használt képernyőfelbontást. Ellenkező esetben a távvezérlés meghiúsul.


Munkamenet időkorlátjainak konfigurálása

A terminálszolgáltatások kapcsolatai esetében meghatározhatja, hogy az aktív, megszakadt vagy üresjárati (ügyféltevékenység nélküli) munkamenetek meddig fussanak tovább a kiszolgálón. Ez azért hasznos, mert a kiszolgálón meghatározatlan ideig futó munkamenetek értékes rendszererőforrásokat foglalnak le. Amikor az aktív vagy az üresjárati munkamenet eléri a megadott időkorlátot, leválaszthatja a felhasználót a munkamenetről, illetve bezárhatja a munkamenetet. A munkamenetről leválasztott felhasználó később visszacsatlakozhat ugyanahhoz a munkamenethez. Amikor egy munkamenet befejeződik, véglegesen törlődik a kiszolgálóról, és a benne futó összes alkalmazás megszakad, ami az ügyfélnél adatok elvesztését eredményezheti. Amikor egy megszakadt munkamenet eléri a megadott időkorlátot, a munkamenet befejeződik, és véglegesen törlődik a kiszolgálóról. A munkamenetek futása korlátozás nélkül is engedélyezhető.

A Terminálszolgáltatások konfigurálása programban beállított, munkamenetre vonatkozó időkorlátok az összes olyan munkamenetet érintik, amelyek az adott kapcsolatot használják a kiszolgálóra történő bejelentkezéshez. A Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményében a munkamenetek időkorlátjai felhasználói alapon is konfigurálhatók.

Megszakadt kapcsolatok

A kapcsolatot az alábbi esetekben kell megszakadtnak tekinteni: ha kérték a kapcsolat bontását, ha csatlakozási hiba történt, illetve ha a munkamenet elérte az aktív vagy az üresjárati időkorlátot.

Visszacsatlakozás megszakadt munkamenetre

Alapesetben a terminálkiszolgáló a megszakadt munkamenethez bármely számítógépről engedélyezi a visszacsatlakozást. Megadható azonban, hogy a felhasználók csak arról a számítógépről kapcsolódhassanak vissza, ahonnan a munkamenetet elindították. Ez a beállítás csak olyan ügyfelek számára adható meg, amelyek sorozatszámot biztosítanak a csatlakozáshoz. Ilyenek például a Citrix ICA alapú ügyfelek.


Csatlakozási engedélyek kezelése

Az engedélyek korlátozzák a felhasználók és csoportok terminálkiszolgálóhoz való hozzáférését, lehetővé téve ezzel a kiszolgáló védelmét. A terminálszolgáltatásokkal együtt, automatikusan telepített TCP/IP-kapcsolatokhoz számos alapértelmezett engedély van beállítva. Ezeket az alapértelmezett engedélyeket úgy is módosíthatja, hogy a különböző felhasználók vagy csoportok számára különböző engedélyeket ad meg oly módon, hogy az engedélyek megfeleljenek a szervezeti követelményeknek. A csatlakozási engedélyek kezeléséhez rendszergazdai jogosultság szükséges.

A Terminálszolgáltatások objektumaihoz megadott alapértelmezett engedélyek az alábbiak:

Csoport | Engedély
Rendszergazdák | Teljes hozzáférés
RENDSZER | Teljes hozzáférés
Felhasználók | Felhasználói hozzáférés
Vendégek | Vendégként való hozzáférés

A felhasználók és a csoportok engedélyeinek kezelésével kapcsolatos információk a Felhasználók és csoportok hozzáadása című témakörben találhatók.

A terminálszolgáltatásokhoz való hozzáférés szabályozására szolgáló engedélyek típusairól bővebben a Csatlakozási hozzáférés szabályozása című témakörben tájékozódhat.


Csatlakozási hozzáférés szabályozása

A terminálszolgáltatásokhoz rendelkezésre álló engedélyek segítségével szabályozható a felhasználók és a csoportok hozzáférése a kiszolgálóhoz. Az alapértelmezett engedélyek megváltoztatásával egyes felhasználók és csoportok számára megtilthatja bizonyos műveletek végrehajtását, például egy felhasználó más munkamenetből történő kiléptetését vagy a munkamenetek bezárását. Az engedélyek a Terminálszolgáltatások konfigurálása programban állíthatók be. A engedélyek megadásához rendszergazdai jogosultság szükséges.

Alapértelmezés szerint az engedélyeknek három típusa létezik: teljes hozzáférés, felhasználói hozzáférés és vendégként való hozzáférés.

Ezeket az engedélyeket a felhasználók és a csoportok által végrehajtható műveletek megadásával lehet konfigurálni. A következőket állíthatja be.
Engedély | Leírás
Információ lekérdezése | Lehetővé teszi a munkamenetek és kiszolgálók lekérdezését.
Információ beállítása | Lehetővé teszi a csatlakozási jellemzők konfigurálását.
Alaphelyzetbe állítás | Lehetővé teszi egy munkamenet bezárását. Ne feledje, hogy a munkamenet figyelmeztetés nélküli befejezése az ügyfél adatainak elvesztését eredményezheti.
Távvezérlés | Lehetővé teszi egy másik felhasználó munkamenetének figyelését vagy aktív irányítását.
Bejelentkezés | Lehetővé teszi a belépést egy, a kiszolgálón futó munkamenetbe.
Kijelentkezés | Lehetővé teszi egy felhasználó kiléptetését egy adott munkamenetből. Ne feledje, hogy a felhasználó figyelmeztetés nélküli kiléptetése az ügyfél adatainak elvesztését eredményezheti.
Üzenet | Lehetővé teszi az üzenetküldést egy másik felhasználó munkamenetébe.
Csatlakozás | Lehetővé teszi a csatlakozást egy másik munkamenethez.
Leválasztás | Lehetővé teszi egy munkamenet megszakítását.
Virtuális csatornák | Lehetővé teszi a virtuális csatornák használatát.


Felhasználók és csoportok hozzáadása

Engedélyek beállításával korlátozhatja a felhasználók és csoportok terminálkiszolgálóhoz való hozzáférését. A megadott engedélyeknek tükrözniük kell az engedélyezni kívánt hozzáférési szinteket. Mielőtt a felhasználókat és csoportokat meghatározott engedélylistákhoz adná hozzá, át kell gondolnia, hogy az egyes felhasználóknak és csoportoknak milyen hozzáférési engedélyre van szükségük. Az engedélytípusokról bővebben a Csatlakozási hozzáférés szabályozása című témakörben olvashat.

Az engedélyezési listákra a hálózaton szereplő bármely felhasználó, csoport vagy számítógép felvehető. Ha a kiszolgáló egy tartomány részét képezi, akkor a helyi tartományból és a meghatalmazott tartományból is felvehetők felhasználói fiókok és globális csoportok. Bizonyos tartományok helyi csoportjainak hozzáadása is lehetséges.


Teljes hozzáférés

A teljes hozzáférés a következőket teszi lehetővé a felhasználók számára:

  • Egy adott munkamenetre vonatkozó információk lekérdezését.
  • A csatlakozási paraméterek módosítását.
  • Egy munkamenet alaphelyzetbe állítását (vagy bezárását).
  • Egy másik felhasználó munkamenetének távvezérlését.
  • Belépést egy, a kiszolgálón futó munkamenetbe.
  • Egy felhasználó munkamenetből való kiléptetését.
  • Üzenet küldését egy másik felhasználó munkamenetébe.
  • Csatlakozást egy másik munkamenethez.
  • Egy adott munkamenet leválasztását.
  • Virtuális csatornák használatát, amelyek lehetővé teszik az ügyféleszközökhöz való hozzáférést a kiszolgálói programokból.


Felhasználói hozzáférés

A felhasználói hozzáférés a következőket teszi lehetővé a felhasználók számára:

  • Bejelentkezést egy, a kiszolgálón futó munkamenetbe.
  • Egy adott munkamenetre vonatkozó információk lekérdezését.
  • Üzenetek küldését más felhasználói munkamenetekbe.
  • Egy másik munkamenethez való csatlakozást.


Vendégként való hozzáférés

A vendégként való hozzáférés a felhasználó számára a következőt teszi lehetővé:

  • Bejelentkezést egy, a kiszolgálón futó munkamenetbe.


Ügyfelekhez történő meghajtó-, nyomtató- és eszköz-hozzárendelések kezelése

Mivel az ügyfélmunkamenetek több adatcsatornát is létesíthetnek az ügyfél és a kiszolgáló között, a felhasználók helyi eszközöket, például meghajtókat és nyomtatókat rendelhetnek hozzájuk. Alapértelmezés szerint az ügyfél által az ügyfélmunkamenetben megadott meghajtó- és nyomtató-hozzárendelések csak ideiglenesek, és a felhasználó következő bejelentkezésekor már nem állnak rendelkezésre. A Terminálszolgáltatások konfigurálása programban azonban megadható, hogy az ügyfél-hozzárendelések automatikusan visszaálljanak, amikor a felhasználó újra bejelentkezik. Bizonyos ügyféleszközök le is tilthatók, hogy a felhasználók ne rendelhessék hozzá őket. A felhasználók az alábbi eszközöket rendelhetik hozzá:

  • Meghajtók (ez a lehetőség csak Citrix ICA alapú ügyfelek számára áll rendelkezésre)
  • Windows-nyomtatók
  • LPT-portok
  • COM-portok
  • Vágólap
  • Audio (ez a lehetőség csak Citrix ICA alapú ügyfelek számára áll rendelkezésre)

Megjegyzés

  • A Terminálszolgáltatás konfigurálása programban beállított meghajtó-, nyomtató- és eszköz-hozzárendelések a kiszolgáló minden ügyfélmunkamenetére érvényesek. Ha az ügyfélbeállításokat felhasználói alapon szeretné konfigurálni, használja a Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményét.


Ideiglenes mappák használata a terminálkiszolgálókkal

Alapértelmezés szerint a terminálkiszolgáló külön ideiglenes mappát készít minden, a kiszolgálón futó új munkamenethez, lehetővé téve minden felhasználó számára saját ideiglenes fájlok tárolását. A szabad lemezterület növelése érdekében ezek az ideiglenes mappák automatikusan törlődnek, amikor a felhasználó kilép a munkamenetből. Ha ezeket az alapértelmezett beállításokat meg szeretné változtatni egy adott terminálkiszolgálóra vonatkozóan, azt a Terminálszolgáltatások konfigurálása programban teheti meg. További információ az Ideiglenes mappák törlése vagy megőrzése kilépéskor és az Eltérő ideiglenes mappák használata az egyes munkamenetekhez című témakörökben található.


A terminálkiszolgáló üzemmódja

A terminálszolgáltatások alkalmazáskiszolgálói vagy távfelügyeleti módban telepíthető a kiszolgálóra. Alkalmazáskiszolgálói módban a terminálszolgáltatások a Windows futtatására nem képes számítógépek számára továbbítja a Windows 2000 Asztalt és az aktuális Windows alapú alkalmazásokat. Távfelügyeleti módban a terminálszolgáltatások távoli felügyeletet biztosít a saját kiszolgálóhoz a hálózat bármely pontjáról.


Windows 2000 Terminálszolgáltatások Internetes Csatlakozás licenc

Ezt a licencet külön kell megvásárolni a Terminálszolgáltatások licenc mellé. Ez a licenc lehetővé teszi maximum 200 névtelen felhasználó egyidejű csatlakozását a terminálkiszolgálóhoz az Interneten keresztül. Ez olyan szervezetek számára lehet hasznos, akik Internet-felhasználóknak szeretnének Windows alapú szoftvereket bemutatni anélkül, hogy a Windows alapú alkalmazásokat web alapú alkalmazásokká kellene átalakítani. Azok a felhasználók, aki ilyen engedéllyel csatlakoznak a terminálkiszolgálóhoz, nem lehetnek alkalmazottak.

Ez a licenc nem vásárolható meg a Windows 2000 rendszer kereskedelmi csatornákon keresztül történő beszerzése esetén.

Ez a licenc a Terminálszolgáltatások konfigurálása program használatával engedélyezhető és tiltható le. Az internetes csatlakozás licencelésének engedélyezésével és letiltásával kapcsolatban Az internetes csatlakozás licencelésének engedélyezése vagy letiltása című témakörben tájékozódhat.


Felhasználók és ügyfelek kezelése

Ez a témakör a terminálszolgáltatások felhasználóinak és ügyfeleinek kezelését ismerteti. Az alábbi témakörökben tájékozódhat:

  • A konkrét feladatokról a következő oldalon olvashat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.


Útmutató

  • Ügyfelek létrehozása és telepítése
  • A Terminálszolgáltatások ügyfele program használata
  • Az Ügyfélkapcsolat kezelője program használata
  • Terminálszolgáltatások felhasználói fiókjainak kezelése


Ügyfelek létrehozása és telepítése

  • Ügyféllemezek készítése
  • Kapcsolatfájl létrehozása
  • A 16 bites Terminálszolgáltatások ügyfele program telepítése
  • A 32 bites Terminálszolgáltatások ügyfele program telepítése
  • A Terminálszolgáltatások ügyfele program eltávolítása


Ügyféllemezek készítése

  1. Kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Terminálszolgáltatások ügyféllétrehozója parancsra.
  2. A Hálózati ügyfél vagy szolgáltatás ablakban válassza ki, hogy milyen terminálszolgáltatások-ügyfelet szeretne létrehozni.
  3. Helyezzen be egy lemezt és kattintson az OK gombra.

Kapcsolódó témakörök


Kapcsolatfájl létrehozása

  1. Telepítse a Terminálszolgáltatások ügyfele programot a kiszolgálóra.
  2. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra, végül kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. A Fájl menüben kattintson az Új kapcsolat parancsra.

    Az új ügyfélkapcsolat kívánt megjelenési formában történő létrehozásához kövesse a varázsló utasításait.

  4. Kattintson a kapcsolatra, majd a Fájl menü Exportálás parancsára.

    Ha több kapcsolata van, és mindet exportálni szeretné, kattintson az Összes exportálása parancsra.

  5. Adja meg azt a helyet, ahová a kapcsolatfájlt menteni szeretné. Mentse a .cns fájlt az ügyfél telepítőlemezére (16 bites ügyfelek esetén másolja a fájlt az 1-es lemezre), vagy helyezze a telepítőfájlokat tartalmazó hálózati megosztott mappába. A rendszer a kapcsolatokat a .cns fájlba exportálja.

Megjegyzés

  • Ha létező fájlba exportál, a rendszer a kapcsolatokat hozzáfűzi a fájlhoz. Létező fájlba történő exportálás során a rendszer nem írja automatikusan felül a fájlt.

Kapcsolódó témakörök


A 16 bites Terminálszolgáltatások ügyfele program telepítése

  1. Írja be a parancssorba a meghajtó:setup parancsot (ahol a meghajtó a terminálszolgáltatások ügyfele lemez meghajtójának betűjele, vagy a megosztott telepítőfájlok elérési útvonala), majd nyomja meg az ENTER billentyűt.

    2. Megjelenik a Terminálszolgáltatások ügyfele telepítése párbeszédpanel.

  2. Zárjon be minden alkalmazást, majd kattintson az OK gombra.
  3. A Név mezőbe írja be a teljes nevét. A Szervezet mezőbe írja be a szervezet nevét.
  4. A Licencszerződés párbeszédpanelen olvassa el a szerződés feltételeit, és ha elfogadja, kattintson az Elfogadom gombra.
  5. A Terminálszolgáltatások ügyfele telepítése párbeszédpanelen kezdje meg a telepítést, majd kattintson a nagy gombra.
  6. A Programcsoport választása párbeszédpanelen válasszon programcsoportot a listából, vagy írja be egy új programcsoport nevét, majd kattintson a Folytatás gombra.
  7. A telepítés befejezéséhez a Terminálszolgáltatások ügyfele telepítése párbeszédpanelen kattintson az OK gombra.

Kapcsolódó témakörök


A 32 bites Terminálszolgáltatások ügyfele program telepítése

  1. Írja be a parancssorba a meghajtó:setup parancsot (ahol a meghajtó a terminálszolgáltatások ügyfele lemez meghajtójának betűjele, vagy a megosztott telepítőfájlok elérési útvonala), majd nyomja meg az ENTER billentyűt.

    2. Megjelenik a Terminálszolgáltatások ügyfele telepítése – üdvözli a varázsló párbeszédpanel.

  2. Olvassa el az információkat, majd kattintson a Folytatás gombra.
  3. A Név mezőbe írja be a teljes nevét. A Szervezet mezőbe írja be a szervezet nevét.
  4. A Terminálszolgáltatások ügyfele telepítése párbeszédpanelen adja meg a termék azonosítószámát, majd kattintson az OK gombra.
  5. A Licencszerződés párbeszédpanelen olvassa el a szerződés feltételeit, és ha elfogadja, kattintson az Elfogadom gombra.
  6. A Terminálszolgáltatások ügyfele telepítése párbeszédpanelen kezdje meg a telepítést, majd kattintson a nagy gombra.
  7. Ha az ügyfélszoftvert minden felhasználó számára telepíteni kívánja, kattintson az Igen lehetőségre. Ha a szoftvert csak az aktuális felhasználó számára kívánja telepíteni, akkor kattintson a Nem lehetőségre.
  8. A telepítés befejezéséhez a Terminálszolgáltatások ügyfele telepítése párbeszédpanelen kattintson az OK gombra.

Kapcsolódó témakörök


A Terminálszolgáltatások ügyfele program eltávolítása

  1. A Terminálszolgáltatások ügyfele csoportban kattintson az Eltávolítás gombra.
  2. A Terminálszolgáltatások ügyfele program összes fájljának az eltávolításához a Terminálszolgáltatások ügyfele telepítése párbeszédpanelen kattintson a Teljes eltávolítás elemre.
  3. Az eltávolítás megerősítéséhez kattintson az Igen gombra.
  4. A befejezéshez a Terminálszolgáltatások ügyfele – A Windows újraindítása párbeszédpanelen kattintson a Windows újraindítása gombra.

Megjegyzés

  • Ha az ügyfélprogramot hajlékonylemezről telepítette, a telepítőlemeznek az eltávolítás alatt végig benne kell lennie a meghajtóban. Ha eltávolítás közben behelyezi a lemezt a meghajtóba, ez újraaktiválja a lemezt, így az ügyfélprogram más felhasználók számára is telepíthető lesz.

Kapcsolódó témakörök


A Terminálszolgáltatások ügyfele program használata

  • Csatlakozás a terminálkiszolgálóra 32 bites ügyfélről
  • Csatlakozás a terminálkiszolgálóra 16 bites Windows for Workgroups 3.11 rendszert futtató ügyfélről
  • A terminálkiszolgáló billentyűparancsainak használata
  • 16 bites Windows Workgroups 3.11 rendszert futtató ügyfél verziószámának ellenőrzése
  • 32 bites ügyfél verziószámának ellenőrzése
  • Leválasztás a munkamenet befejezése nélkül
  • Kijelentkezés és a munkamenet befejezése


Csatlakozás a terminálkiszolgálóra 32 bites ügyfélről

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra, végül kattintson a Terminálszolgáltatások ügyfele parancsra.

    Megjelenik a Terminálszolgáltatások ügyfele párbeszédpanel.

  2. A Kiszolgáló mezőbe írja be a terminálkiszolgáló nevét vagy TCP\IP-címét. A kiszolgálót az Elérhető kiszolgálók listából is kiválaszthatja.

  3. A Képernyőterület legördülő listában kattintson egy ablakméretre, amelyben majd a Terminálszolgáltatások ügyfele program megjelenik.

  4. Kattintson a Csatlakozás gombra.

    Megjelenik a Bejelentkezési információ párbeszédpanel.

  5. Írja be (ha szükséges) a felhasználónevet, a jelszót és a tartományt, majd kattintson az OK gombra.

Kapcsolódó témakörök


Csatlakozás a terminálkiszolgálóra 16 bites Windows for Workgroups 3.11 rendszert futtató ügyfélről

  1. A Programkezelőben kattintson duplán a TSClient ikonra.

  2. A TSClient ablakban kattintson duplán a TSClient ikonra.

    Megjelenik a Terminálszolgáltatások ügyfele párbeszédpanel.

  3. A Kiszolgáló mezőbe írja be a terminálkiszolgáló nevét vagy TCP\IP-címét. Kiszolgálót az Elérhető kiszolgálók listájából is választhat.

  4. A Felbontás legördülő listában kattintson egy ablakméretre, amelyben a Terminálszolgáltatások ügyfele program megjelenik.

  5. Kattintson a Csatlakozás gombra.

    The Megjelenik a Bejelentkezési információ párbeszédpanel.

  6. Írja be (ha szükséges) a felhasználónevet, a jelszót és a tartományt, majd kattintson az OK gombra.

Megjegyzés

  • Ha előzőleg már bontotta a kapcsolatot a terminálkiszolgálóval a munkamenet befejezése nélkül, a Terminálszolgáltatások ügyfele program automatikusan visszakapcsolja a munkamenethez (ha a kapcsolat a megszakított munkamenetek visszacsatlakoztatására van beállítva).

Kapcsolódó témakörök


A terminálkiszolgáló billentyűparancsainak használata

Billentyűparancs | Leírás
ALT+PAGE UP | Átkapcsol a programok között balról jobbra haladva.
ALT+PAGE DOWN | Átkapcsol a programok között jobbról balra haladva.
ALT+INSERT | Vált a programok között azok indításának sorrendjében.
ALT+HOME | Megjeleníti a Start menüt.
CTRL+ALT+BREAK | Vált az ügyfél ablakos és teljes képernyős megjelenítése között.
CTRL+ALT+END | Megjeleníti a Windows 2000 rendszerbiztonság párbeszédpanelt.
ALT+DELETE | Megjeleníti a Windows-menüt.
CTRL+ALT+Mínusz (-) jel a numerikus billentyűzeten | Az ügyfél aktív ablakának pillanatfelvételét a terminálkiszolgáló vágólapjára helyezi (ugyanazt a funkciót látja el, mint PrintScrn billentyű lenyomása a helyi számítógépen).
CTRL+ALT+Plusz (+) jel a numerikus billentyűzeten | Az ügyfél teljes képernyőjének pillanatfelvételét a terminálkiszolgáló vágólapjára helyezi (ugyanazt a funkciót látja el, mint az ALT+PrintScrn billentyű lenyomása a helyi számítógépen).

Megjegyzés

  • NEC98 számítógépen két billentyűparancs eltér:
    • A CTRL+ALT+BREAK billentyűkombinációt az F12 helyettesíti.
    • A CTRL+ALT+END billentyűkombinációt az F15 helyettesíti.

Kapcsolódó témakörök


16 bites Windows Workgroups 3.11 rendszert futtató ügyfél verziószámának ellenőrzése

  1. A Programkezelőben kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A Terminálszolgáltatások ügyfele programcsoportban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

    Megjelenik a Terminálszolgáltatások ügyfele párbeszédpanel.

  3. Kattintson a Névjegy gombra.

Kapcsolódó témakörök


32 bites ügyfél verziószámának ellenőrzése

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra, végül kattintson a Terminálszolgáltatások ügyfele parancsra.

    Megjelenik a Terminálszolgáltatások ügyfele párbeszédpanel.

  2. Kattintson a Névjegy gombra.

Kapcsolódó témakörök


Leválasztás a munkamenet befejezése nélkül

  1. A Terminálszolgáltatások ügyfele ablakban kattintson a Start menü Kapcsolat bontása parancsára.

    Megjelenik a Leválás a Windows munkamenetről párbeszédpanel.

Megjegyzés

  • A Terminálszolgáltatások ügyfele program automatikusan visszacsatlakoztatja ehhez a munkamenethez, amikor újra bejelentkezik erre a terminálkiszolgálóra (ha a kapcsolat a megszakított munkamenet újracsatlakoztatására van konfigurálva).

Kapcsolódó témakörök


Kijelentkezés és a munkamenet befejezése

  1. A Terminálszolgáltatások ügyfele ablakban kattintson a Start menü Leállítás parancsára.

    Megjelenik A Windows leállítása párbeszédpanel.

  2. Kattintson a Kijelentkezés lehetőségre, majd az OK gombra.

Kapcsolódó témakörök


Az Ügyfélkapcsolat kezelője program használata

  • Új kapcsolat létrehozása
  • A csatlakoztatni kívánt kiszolgáló módosítása
  • A bejelentkezési információ módosítása
  • Ügyfél képernyőterületének módosítása
  • Kapcsolat megnyitása teljes képernyős módban
  • Adattömörítés használata
  • Bitképek gyorsítótárazása lemezen
  • A kezdőprogram módosítása
  • A kapcsolat ikonjának módosítása
  • A programcsoport módosítása
  • Kapcsolat törlése
  • Kapcsolat exportálása fájlba
  • Az összes kapcsolat exportálása fájlba
  • Kapcsolatok importálása fájlból


Új kapcsolat létrehozása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. A Fájl menüben kattintson az Új kapcsolat parancsra, és kövesse a varázsló utasításait.

Megjegyzés

  • Ha nem ad meg adatokat az automatikus bejelentkezéshez, a rendszer a kapcsolat létrehozása előtt kérni fogja a felhasználónevet, a jelszót és a tartományt.

Kapcsolódó témakörök


A csatlakoztatni kívánt kiszolgáló módosítása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. Az Általános lapon, a Kiszolgáló neve vagy IP-címe mezőbe írja be a kiszolgáló nevét vagy TCP/IP-címét, majd kattintson az OK gombra. A kiszolgáló megkereséséhez kattintson a Tallózás gombra.

Kapcsolódó témakörök


A bejelentkezési információ módosítása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. Az Általános lapon, a Bejelentkezési információ területen írja be az új felhasználónevet, jelszót, és tartománynevet, majd kattintson az OK gombra.

Kapcsolódó témakörök


Ügyfél képernyőterületének módosítása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Kapcsolati beállítások lapon, a Képernyőterület területen jelölje be azt a képernyőméretet, amelyet az ügyfélablak megjelenítéséhez használni kíván, majd kattintson az OK gombra.

Kapcsolódó témakörök


Kapcsolat megnyitása teljes képernyős módban

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Kapcsolati beállítások lapon, a Kapcsolat kezdete területen jelölje be a Teljes képernyő választógombot, majd kattintson az OK gombra.


Adattömörítés használata

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Kapcsolati beállítások lapon jelölje be az Adattömörítés engedélyezése jelölőnégyzetet, majd kattintson az OK gombra.

Kapcsolódó témakörök


Bitképek gyorsítótárazása lemezen

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Kapcsolati beállítások lapon, a Bitképek gyorsítótárazása területen jelölje be a Bitképek gyorsítótárba helyezése a lemezen jelölőnégyzetet, majd kattintson az OK gombra.

Kapcsolódó témakörök


A kezdőprogram módosítása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Program lapon jelölje be A következő program indítása jelölőnégyzetet, majd írja be a program elérési útját és nevét. Ha nem ad meg kezdőprogramot, a kapcsolat a Windows 2000 Asztallal indul.

Kapcsolódó témakörök


A kapcsolat ikonjának módosítása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Program lapon kattintson az Ikoncsere gombra.
  6. Ha a program alapértelmezett ikonját kívánja használni, kattintson az Alapértelmezés használata gombra, új ikon kereséséhez pedig a Tallózás gombra.
  7. Az Ikoncsere ablakban jelölje ki az új ikont, majd kattintson az OK gombra.


A programcsoport módosítása

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a módosítani kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Tulajdonságok parancsra.
  5. A Program lapon, a Programcsoport mezőbe írja be az új nevet, vagy válasszon a listából egy új programcsoportot, majd kattintson az OK gombra.

Kapcsolódó témakörök


Kapcsolat törlése

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Kattintson a törölni kívánt kapcsolatra.
  4. A Fájl menüben kattintson a Törlés parancsra.

Kapcsolódó témakörök


Kapcsolat exportálása fájlba

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. Jelölje ki az exportálni kívánt kapcsolatot, majd kattintson a Fájl menü Exportálás parancsára. Megjelenik az Exportálás másként párbeszédpanel.
  4. Válassza ki azt a fájlt, amelybe exportálni kívánja a kapcsolatot, majd kattintson a Mentés gombra.

Megjegyzés

  • Ha létező fájlba exportál, a rendszer a kapcsolatokat hozzáfűzi a fájlhoz. Létező fájlba történő exportálás során a rendszer nem írja automatikusan felül a fájlt.

Kapcsolódó témakörök


Az összes kapcsolat exportálása fájlba

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. A Fájl menüben kattintson az Összes exportálása parancsra. Megjelenik az Exportálás másként párbeszédpanel.
  4. Adja meg azt a fájlt, amelybe a kapcsolatot exportálni szeretné, majd kattintson a Mentés gombra.

Megjegyzések

  • Ha létező fájlba exportál, a rendszer a kapcsolatokat hozzáfűzi a fájlhoz. Létező fájlba történő exportálás során a rendszer nem írja automatikusan felül a fájlt.
  • Abban a programcsoportban, amelybe az ügyfélszoftvert telepítette, a Terminálszolgáltatások ügyfele az alapértelmezett kapcsolat. Amikor a kiszolgálóhoz történő csatlakozáshoz ezt a kapcsolatot használja, az alapértelmezett kapcsolat menti a megadott adatokat (kiszolgálónév, felbontás, felhasználónév és tartomány). A Terminálszolgáltatások ügyfele kapcsolat nem jelenik meg az Ügyfélkapcsolat kezelője ablakban, de ha az Összes exportálása parancsot használja, a rendszer az ott felsorolt összes kapcsolattal együtt azt is exportálja. Ez a kapcsolat importáláskor felülírja a létező alapértelmezett kapcsolatot, és nemkívánatos információkat is átvihet a másik számítógépre.

Kapcsolódó témakörök


Kapcsolatok importálása fájlból

  1. Kattintson a Start menüre, mutasson a Programok, majd a Terminálszolgáltatások ügyfele pontra.

    16 bites ügyfél esetén a Programkezelő ablakban kattintson duplán a Terminálszolgáltatások ügyfele ikonra.

  2. A megjelenő menüben kattintson az Ügyfélkapcsolat kezelője parancsra.
  3. A Fájl menüben kattintson az Importálás parancsra. Megjelenik az Importálás helye párbeszédpanel.
  4. Jelölje ki az importálni kívánt fájlt, majd kattintson a Megnyitás gombra.

Kapcsolódó témakörök


Terminálszolgáltatások felhasználói fiókjainak kezelése

  • A Terminálszolgáltatások bővítmény hozzáadása a Helyi felhasználók és csoportok beépülő modulhoz
  • Terminálszolgáltatások felhasználójának létrehozása
  • Terminálszolgáltatások felhasználójának törlése
  • Felhasználó Terminálszolgáltatások profiljához tartozó elérési út módosítása
  • Felhasználói kezdőkönyvtár elérési útjának módosítása
  • Felhasználó bejelentkezésének engedélyezése a terminálszolgáltatásokba
  • Aktív munkamenet maximális időtartamának beállítása
  • Leválasztott munkamenet maximális aktív időtartamának beállítása
  • Munkamenet maximális üresjárati idejének beállítása
  • A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása
  • Leválasztott munkamenetek újracsatlakoztatására vonatkozó beállítások módosítása
  • Munkamenet csatlakozásakor induló program megadása
  • Ügyfélmeghajtók csatlakoztatása bejelentkezéskor (csak Citrix ICA ügyfelek számára)
  • Ügyfélnyomtatók csatlakoztatása bejelentkezéskor
  • A fő ügyfélnyomtató beállítása alapértelmezettként
  • Távvezérlés engedélyezése
  • Felhasználó engedélyének kérése munkamenet figyeléséhez vagy vezérléséhez
  • A felhasználói munkamenet vezérlési szintjének beállítása


A Terminálszolgáltatások bővítmény hozzáadása a Helyi felhasználók és csoportok beépülő modulhoz

  1. Kattintson a Start menü Futtatás parancsára.
  2. A Megnyitás mezőbe írja be az MMC parancsot, majd kattintson az OK gombra. Megjelenik egy új Microsoft Management Console (MMC).
  3. A Konzol menüben kattintson a Beépülő modul hozzáadása/eltávolítása parancsra. Megjelenik a Beépülő modul hozzáadása/eltávolítása párbeszédpanel.
  4. Kattintson a Hozzáadás gombra. Megjelenik a Magában álló beépülő modul hozzáadása párbeszédpanel.
  5. Jelölje ki a Helyi felhasználók és csoportok modult, majd kattintson a Hozzáadás gombra. Megjelenik a Célszámítógép kiválasztása párbeszédpanel.
  6. Válassza ki, melyik számítógéphez szeretné hozzáadni a konzolt, majd kattintson a Befejezés gombra.
  7. A Magában álló beépülő modul hozzáadása párbeszédpanelen kattintson a Bezárás gombra.
  8. A Beépülő modul hozzáadása/eltávolítása párbeszédpanelen kattintson a Bővítések fülre.
  9. Jelölje be a Terminálszolgáltatások - bővítmény jelölőnégyzetet, majd kattintson az OK gombra.
  10. A Konzol menüben kattintson a Mentés parancsra. Megjelenik a Mentés párbeszédpanel.
  11. Írja be a konzol tárolásához használni kívánt fájlnevet, és elérési utat, majd kattintson a Mentés gombra.

Megjegyzés

  • Ha a terminálszolgáltatások engedélyezve van a kiszolgálón, a Helyi felhasználók és csoportok beépülő modul már tartalmazza a Terminálszolgáltatások bővítményt.

Kapcsolódó témakörök


Terminálszolgáltatások felhasználójának létrehozása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. A Művelet menüben mutasson az Új pontra, majd kattintson a Felhasználó parancsra.
  3. A Vezetéknév, az Utónév, és a Bejelentkezési név mezőkbe írja be a megfelelő adatokat, majd kattintson a Tovább gombra.
  4. A Jelszó és a Jelszó megerősítése mezőkbe írja be a megfelelő információkat, ezután kattintson a Tovább, majd a Befejezés gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Terminálszolgáltatások felhasználójának törlése

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson a törölni kívánt felhasználóra.
  3. A Művelet menüben kattintson a Törlés parancsra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Felhasználó Terminálszolgáltatások profiljához tartozó elérési út módosítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek profiljához tartozó elérési utat módosítani szeretné.
  3. A Terminálszolgáltatások profilja lapon, a Felhasználói profil mezőbe írja be a felhasználói profil új elérési útvonalát, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Felhasználói kezdőkönyvtár elérési útjának módosítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek kezdőkönyvtárát módosítani szeretné.
  3. A Terminálszolgáltatások profilja lapon tegye a következők egyikét:
    • Ha a Terminálszolgáltatások kezdőkönyvtára a helyi kiszolgálón található, jelölje be a Helyi elérési út választógombot, majd írja be a profil elérési útját.
    • Ha a Terminálszolgáltatások kezdőkönyvtára hálózati megosztáson található, jelölje be a Csatlakozás választógombot, válassza ki a kívánt meghajtót, majd írja be a hálózati elérési utat.
  4. Kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Felhasználó bejelentkezésének engedélyezése a terminálszolgáltatásokba

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek beállításait módosítani szeretné.
  3. A Terminálszolgáltatások profilja lapon jelölje be a Bejelentkezés engedélyezése a terminálkiszolgálóra jelölőnégyzetet, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Aktív munkamenet maximális időtartamának beállítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Elérési út:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán a módosítani kívánt felhasználóra.
  3. A Munkamenetek lapon, az Aktív kapcsolat időkorlátja mezőben válassza ki azt az időtartamot, amelynek letelte után a kiszolgáló megszakítja a kapcsolatot. Kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Leválasztott munkamenet maximális aktív időtartamának beállítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek beállításait módosítani szeretné.
  3. A Munkamenetek lapon, a Leválasztott munkamenet befejezése mezőben válassza ki azt az időtartamot, amelynek lejárta után a leválasztott munkamenetet a rendszer törli, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Munkamenet maximális üresjárati idejének beállítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek a beállításait módosítani szeretné.
  3. A Munkamenetek lapon, az Üresjárat időkorlátja mezőben válassza ki azt az időtartamot, amíg a leválasztott munkamenet törlés előtt aktív maradhat, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek a beállításait módosítani szeretné.
  3. Ha engedélyezni kívánja a munkamenet újracsatlakoztatását, a Munkamenetek lapon, a Munkamenet korlátának elérésekor vagy a kapcsolat megszakadásakor: területen jelölje be a Leválás a munkamenetről választógombot.

    Ha be kívánja zárni a munkamenetet, jelölje be a Munkamenet befejezése választógombot.

  4. Kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Leválasztott munkamenetek újracsatlakoztatására vonatkozó beállítások módosítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek a beállításait módosítani szeretné.
  3. Ha azt szeretné, hogy a felhasználó a leválasztott munkamenethez bármely számítógépről visszacsatlakozhasson, a Munkamenetek lapon, a Visszacsatlakozás engedélyezése területen jelölje be a Bármely ügyféltől választógombot.

    Ha a visszacsatlakozást csak arról az ügyfélgépről kívánja engedélyezni, amelyiken a munkamenetet elindították, válassza a Csak a kapcsolatot eredetileg kezdeményező ügyféltől jelölőnégyzetet. A rendszer ezt a beállítást csak Citrix CA alapú ügyfelek esetén támogatja.

  4. Kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Munkamenet csatlakozásakor induló program megadása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek a kezdőprogramját módosítani szeretné.
  3. A Környezet lapon, a Kezdőprogram területen jelölje be A következő program indítása bejelentkezéskor: jelölőnégyzetet.
  4. A Program fájlneve mezőbe írja be a felhasználó bejelentkezésekor indítani kívánt program nevét. Munkakönyvtárat is megadhat, ha elérési útját beírja az Indítás helye: mezőbe.
  5. Kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra

Kapcsolódó témakörök


Ügyfélmeghajtók csatlakoztatása bejelentkezéskor (csak Citrix ICA ügyfelek számára)

Ügyfélmeghajtók csatlakoztatása a bejelentkezéskor (csak Citrix ICA ügyfelek számára)

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelyhez ügyfélmeghajtókat szeretne csatlakoztatni.
  3. A Környezet lapon, az Ügyféleszközök területen jelölje be az Ügyfélmeghajtók csatlakoztatása bejelentkezéskor jelölőnégyzetet, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Ügyfélnyomtatók csatlakoztatása bejelentkezéskor

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelyhez ügyfélnyomtatókat szeretne csatlakoztatni.
  3. A Környezet lapon, az Ügyféleszközök területen jelölje be az Ügyfélnyomtatók csatlakoztatása bejelentkezéskor jelölőnégyzetet, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.
  • Csak helyi nyomtatók csatlakoztathatók.

Kapcsolódó témakörök


A fő ügyfélnyomtató beállítása alapértelmezettként

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelynek alapértelmezett nyomtatóját módosítani szeretné.
  3. A Környezet lapon, az Ügyféleszközök területen jelölje be Az alapértelmezett nyomtató az ügyfél fő nyomtatója jelölőnégyzetet, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Távvezérlés engedélyezése

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelyhez a távvezérlést engedélyezni szeretné.
  3. A Távvezérlés lapon jelölje be a Távvezérlés engedélyezése jelölőnégyzetet, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Felhasználó engedélyének kérése munkamenet figyeléséhez vagy vezérléséhez

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelyiktől engedélyt kíván kérni.
  3. A Távvezérlés lapon jelölje be a Felhasználó engedélye szükséges jelölőnégyzetet, majd kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


A felhasználói munkamenet vezérlési szintjének beállítása

  1. Válasszon az alábbi lehetőségek közül:
    • Tartományi felhasználói fiók esetén nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

      A konzolfán bontsa ki a tartományi csomópontot, majd kattintson arra a mappára, amely a felhasználókat tartalmazza.

    • Helyi felhasználói fiók esetén nyissa meg a Számítógép-kezelés (Helyi) ablakot.

      Kattintson a konzolfa Felhasználók elemére.

      Helye:

      • Számítógép-kezelés
      • Rendszereszközök
      • Helyi felhasználók és csoportok
      • Felhasználók
  2. Kattintson duplán arra a felhasználóra, amelyhez a vezérlési szintet be kívánja állítani.
  3. Ha csak a munkamenet megfigyelését kívánja engedélyezni, a Távvezérlés lapon, a Vezérlés szintje területen jelölje be A felhasználó munkamenetének megfigyelése választógombot.

    Ha a munkamenet teljes távvezérlését engedélyezni kívánja, jelölje be a Beavatkozás a munkamenetbe választógombot.

  4. Kattintson az Alkalmaz gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd az Active Directory - felhasználók és számítógépek ikonra.

Kapcsolódó témakörök


Fogalmak

A rész tartalma:

  • Gyakorlati tanácsok
  • A terminálszolgáltatások felhasználói fiókjai
  • Terminálszolgáltatások ügyfele – áttekintés
  • Ügyfélszoftver biztosítása
  • Ügyféllétrehozó - áttekintés
  • Bitképek gyorsítótárazása
  • Megosztott vágólap
  • Ügyfélhozzáférés biztosítása helyi nyomtatókhoz
  • Kijelentkezés vagy leválasztás
  • A terminálszolgáltatások felhasználói kapcsolatainak kezelése
  • Telefonos kapcsolat használata a terminálkiszolgáló eléréséhez


Gyakorlati tanácsok

  • Használjon terminálszolgáltatások-specifikus csoportokat
    Hozzon létre felhasználói csoportokat kimondottan a terminálszolgáltatások felhasználói számára. A felhasználók csoportokban történő kezelése sokkal könnyebb, és kevésbé időigényes, mint az egyenkénti kezelés.
  • Használjon terminálszolgáltatások-specifikus profilokat
    A terminálszolgáltatásokba történő bejelentkezéséhez rendeljen egy külön profilt. A profilokban tárolt leggyakoribb beállítások többsége, mint például a képernyőkímélők és az animált menühatások, nem ajánlatosak a terminálszolgáltatások használatánál. Külön profil hozzárendelésével lehetővé válik a felhasználók számára, hogy a lehető leghatékonyabban használhassák a rendszert, anélkül, hogy további kiszolgálói erőforrásokat kötnének le. A terminálszolgáltatások-specifikus profilok hozzárendeléséről a Felhasználó Terminálszolgáltatások profiljához tartozó elérési út módosítása című témakörben tájékozódhat.
  • Használjon kötelező profilokat
    Alkalmazzon kötelező Terminálszolgáltatások profilt, amely megfelel az összes, különböző típusú ügyfél igényeinek, és a legnagyobb kiszolgálóteljesítményt biztosítja. Vegye figyelembe, hogy a 16 bites számítógépek és a Windows alapú terminálok néhány képernyőfelbontást nem támogatnak.
  • Állítson be időkorlátokat
    Az ügyfélkapcsolatok idejének korlátozása javíthatja a kiszolgáló teljesítményét. Megadhatja, hogy egy munkamenet mennyi ideig tartson, meddig maradjon aktív a kiszolgálón a leválasztott munkamenet, és mennyi ideig maradjon egy munkamenet csatlakoztatott állapotban üresjárat esetén. A munkamenetek időkorlátjaival kapcsolatos beállításokról további információt a Munkamenetek című témakörben olvashat.
  • Használja a Kezdőprogram beállítást
    Olyan felhasználók esetén, akiknek a terminálkiszolgálón csak egy alkalmazásra van szükségük, használja a Kezdőprogram beállítást, így a felhasználók csak az adott alkalmazást érhetik el. Ez az összes felhasználó számára a Terminálszolgáltatások konfigurálása programmal állítható be, felhasználónként történő beállításhoz használja a Helyi felhasználók és csoportok, illetve az Aktív Directory - felhasználók és számítógépek Terminálszolgáltatások bővítményét. A Kezdőprogram használatáról bővebben a Munkamenet csatlakozásakor induló program megadása című témakörben tájékozódhat.
  • Készítsen előre beállított kapcsolatokat a felhasználók vagy felhasználói csoportok számára
    A terminálszolgáltatásokhoz való csatlakozás megkönnyítése érdekében a felhasználók számára előre beállított kapcsolatokat biztosíthat. A szervezet különböző osztályai, illetve a különböző beosztások számára is készíthet előre beállított kapcsolatokat. Előre beállított kapcsolatokat az Ügyfélkapcsolat kezelője programmal hozhat létre. További információ A terminálszolgáltatások felhasználói kapcsolatainak kezelése című témakörben olvasható.


Terminálszolgáltatások felhasználói fiókjai

A terminálkiszolgálóra bejelentkezett összes ügyfélnek felhasználói fiókkal kell rendelkeznie a kiszolgálón vagy a hálózat valamelyik tartományában. A terminálszolgáltatások felhasználói fiókjai pótlólagos információkat tartalmaznak a felhasználókról, amelyek meghatározzák, hogy bejelentkezéskor milyen feltételek mellett, és mennyire speciális asztalbeállítások legyenek érvényesek.

Terminálszolgáltatások felhasználói fiókot egy, a Helyi felhasználók és csoportok beépülő modult használó számítógép vagy az Active Directory - felhasználók és számítógépek beépülő modult használó számítógép-tartomány számára állíthat be.

Ebben a fejezetben a következő témakörökkel ismerkedhet meg:

  • Környezet
  • Munkamenetek
  • Távvezérlés
  • Terminálszolgáltatások profilja


Környezet

A Környezet lap az ügyfél munkakörnyezetének létrehozásával kapcsolatos beállításokat tartalmazza.

Kezdőprogram

Ha van megadva kezdőprogram, az a felhasználó terminálkiszolgálóhoz történő csatlakozásakor automatikusan elindul. Ez az egyetlen olyan alkalmazás, amelyet a felhasználó futtathat. Az alkalmazás bezárásakor a terminálkiszolgálóval való kapcsolat megszakad.

Kezdőprogramot a Terminálszolgáltatások konfigurálása programban is megadhat, de az lesz az egyetlen alkalmazás, amelyhez a felhasználók hozzáférhetnek. Az automatikusan induló alkalmazások kapcsolatonként történő megadásáról A felhasználó bejelentkezésekor automatikusan induló program meghatározása című témakörben olvashat.

Ügyféleszközök

Az ügyfél bejelentkezésekor a terminálszolgáltatások képes automatikusan csatlakoztatni a helyi ügyfélnyomtatókat. Amikor az ügyfél bejelentkezik a kiszolgálóra, a rendszer megkeresi a helyi nyomtatót, és a megfelelő illesztőprogramot telepíti a terminálkiszolgálón. Ha több nyomtató van csatlakoztatva, beállítható, hogy minden nyomtatási feladat alapértelmezés szerint a fő ügyfélnyomtatóhoz kerüljön. További információ az Ügyfélnyomtatók csatlakoztatása bejelentkezéskor vagy az Ügyfélhozzáférés biztosítása helyi nyomtatókhoz című témakörökben található.

Megjegyzés

  • Az ügyfélmeghajtók bejelentkezéskor csak Citrix ICA ügyfelek esetén csatlakoztathatók. Az Ügyfélmeghajtók csatlakoztatása bejelentkezéskor beállítás jelenleg nem támogatott RDP-ügyfelek esetén.


Munkamenetek

A Terminálszolgáltatások bővítmény Munkamenetek lapján a pillanatnyi állapotuktól függően (aktív, üresjárat vagy leválasztott) beállíthatók a munkamenetek időtartamai. Az is megadható, hogy mi történjen a munkamenet időkorlátjának elérése esetén.

Időúllépési beállítás | Leírás
Leválasztott munkamenet befejezése | Meghatározza azt a maximális időtartamot, ameddig egy leválasztott munkamenet visszakapcsolódhat. Az időkorlát elérése után a munkamenetet a rendszer alaphelyzetbe állítja, és többé nem lehet újracsatlakoztatni. További információ a Leválasztott munkamenet maximális aktív időtartamának beállítása című témakörben olvasható.
Aktív kapcsolat időkorlátja | Meghatározza a maximális csatlakozási időtartamot. Az időkorlát elérésekor a munkamenet vagy leválasztódik, és továbbra is aktív marad a kiszolgálón, vagy törlődik. Aktív munkamenet maximális időtartamának beállítása.
Üresjárat időkorlátja | Meghatározza a munkamenet leválasztásáig, illetve törléséig megengedett maximális üresjárati időt (az aktivitás nélküli kapcsolat időtartamát). A munkamenet leválasztódik, vagy törlődik, ha az aktivitás nélküli időtartam eléri a megadott időkorlátot. Munkamenet maximális üresjárati idejének beállítása.

Megjegyzés

  • Ha a Soha lehetőséget választja, az időmérő le lesz tiltva.

Ha a kapcsolat a kiszolgálóval bármely oknál fogva megszakad (például kérésre vagy kapcsolathiba esetén, illetve az üresjárati vagy aktív időkorlát elérése miatt), az ügyfél munkamenetét leválaszthatja vagy törölheti. A törölt munkamenet befejeződik, azt a felhasználó nem aktiválhatja újra. A leválasztott munkamenet a kiszolgálón továbbra is aktív marad, a felhasználó később visszacsatlakozhat hozzá. További információ A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása című témakörben található.

Leválasztott munkamenetek

Alapértelmezés szerint a terminálkiszolgáló bármely számítógépről lehetővé teszi a visszacsatlakozást a leválasztott munkamenethez. Azt is beállíthatja azonban, hogy csak az eredeti ügyfélgépéről történhessen a visszacsatlakozás. Ehhez meg kell adnia, hogy a felhasználók csak arról a számítógépről csatlakozhassanak vissza egy leválasztott munkamenethez, amelyen a munkamenetet elindították. Ez a lehetőség csak Citrix ICA ügyfelek esetén áll rendelkezésre, amelyek csatlakozáskor sorozatszámot adnak meg.


Távvezérlés

A terminálkiszolgálóra bejelentkezett ügyfél tevékenységét távvezérlés segítségével megfigyelheti egy másik munkamentből. A távvezérlés lehetővé teszi egy másik ügyfélmunkamenet megfigyelését, illetve aktív irányítását is. Ha egy felhasználói munkamenetet aktívan szeretne irányítani, a munkamenetben billentyűzet- és egérműveleteket is használhat. Az ügyfelet üzenetben figyelmeztetheti munkamenete távvezérlésére, és az ügyféltől az üzenetben engedélyt kérhet munkamenetei megfigyelésére vagy irányítására. A felhasználói fiókok távvezérlését (helyi felhasználók esetén) a Helyi felhasználók és csoportok, illetve (tartományi felhasználók esetén) az Active Directory - felhasználók és számítógépek segítségével engedélyezheti. További információk a Távvezérlés engedélyezése című témakörben találhatók.

Megjegyzések

  • Ügyfélmunkamenet nem távvezérelhet rendszerkonzolt, és rendszerkonzol sem távvezérelhet ügyfélmunkamenetet.
  • A távvezérlő munkamenet számítógépének támogatnia kell a távvezérelt ügyfélmunkamenet által használt képernyőfelbontást. Ellenkező esetben a távvezérlés meghiúsul.
  • A távvezérlés befejezéséhez nyomja meg a CTRL+CSILLAG (*) billentyűkombinációt. A funkció befejezéshez más gyorsbillentyű is definiálható.


Terminálszolgáltatások profilja

Terminálszolgáltatások profilja

A terminálszolgáltatások profilja segítségével a felhasználókhoz olyan profilokat rendelhet hozzá, amelyek a terminál-munkamenetek során kerülnek alkalmazásra. A rendszergazdák így olyan felhasználói profilokat hozhatnak létre, amelyek teljes mértékben a terminálszolgáltatások környezetéhez vannak testre szabva.

A terminálszolgáltatások profiljaival korlátozható a hozzáférés bizonyos alkalmazásokhoz úgy, hogy egyszerűen eltávolítja az alkalmazásokat a felhasználó Start menüjéből. A rendszergazdák hálózati kapcsolatokat is létrehozhatnak nyomtatókhoz és más erőforrásokhoz, amelyeket a felhasználó a munkamenetek alatt használhat.

A profilokról további információ a Felhasználói profilok című témakörben olvasható.

Terminálszolgáltatások kezdőkönyvtára

A terminálkiszolgáló munkamenetei számára megadhat kezdőkönyvtárat is. Ez a könyvtár lehet helyi könyvtár vagy hálózati megosztott könyvtár.

Bejelentkezés engedélyezése a terminálszolgáltatásokba

Felhasználónként határozhatja meg, hogy egy adott felhasználó hozzáférhet-e a terminálszolgáltatásokhoz. Ha ez a beállítás le van tiltva, akkor a felhasználó egyetlen terminálkiszolgálóra sem tud bejelentkezni.


Terminálszolgáltatások ügyfele – áttekintés

A Terminálszolgáltatások ügyfele egy olyan “sovány” ügyfél, amely számos régebbi rendszert futtató számítógép eszközei számára biztosítja a 32 bites Windows 2000 rendszer funkcióit. Az ügyfél a helyi számítógépes környezetben ablakként jelenik meg, és csak azokat a szoftvereket tartalmazza, amelyek a kiszolgálóval való kapcsolat felvételéhez és a felhasználói felület megjelenítéséhez szükségesek. Az operációs rendszer egyéb funkciói, illetve az alkalmazások a kiszolgálón futnak. Az ügyfél a következő számítógépeken használható:

  • Windows alapú termináleszközök (beágyazva).
  • Windows 95, Windows 98, Windows NT 3.51 és Windows NT 4.0 rendszert futtató Intel számítógépek, valamint Windows 2000 rendszert futtató Intel alapú számítógépek.
  • Windows Workgroups 3.11 rendszert futtató számítógépek.


Ügyfélszoftver biztosítása

A felhasználók számára többféle módszerrel biztosíthat ügyfélszoftvert. A Terminálszolgáltatások ügyféllétrehozója programmal készíthető egy lemez, amely tartalmazza az ügyfélszoftvert. A Terminálszolgáltatások ügyféllétrehozója program használatáról bővebben az Ügyfelek létrehozása és telepítése című témakörben olvashat.

Az ügyfélkönyvtárat is megoszthatja a hálózaton. Azzal kapcsolatban, hogyan teheti elérhetővé az ügyfélprogramot egy hálózati megosztáson a Kapcsolatfájl létrehozása című témakörben tájékozódhat.


Ügyféllétrehozó - áttekintés

Az Ügyféllétrehozó a felhasználó számítógépén telepítendő ügyfélszoftverhez szükséges telepítő lemezek készítéséhez használható. Ezeken a lemezeken minden felhasználónak eljuttathatja a megfelelő Terminálszolgáltatások ügyfele programot. Minden számítógépnek, amelyen a Terminálszolgáltatás ügyfele program fut, rendelkeznie kell saját lemezzel vagy lemezkészlettel, amelyről a program telepíthető.

Megjegyzések

  • Ha az ügyfelek számára az előre beállított kapcsolatokra mutató parancsikonokat kíván biztosítani, hozzon létre egy fájlt és mentse az ügyféltelepítő lemezre. Az ügyfél telepítésekor ezt a fájlt a rendszer az Ügyfélkapcsolat kezelője programba importálja. Ezek a kapcsolatok ezután megjelennek az ügyfél Start menüjében és az Ügyfélkapcsolat kezelője programban.
  • Az ügyféltelepítő fájlok egy példánya a kiszolgáló egy megosztható mappájába is bekerülnek. A mappa elérési útja a kiszolgálón a következő: \\%rendszergyökér%\System32\Clients\Tsclient\Net. Az ügyfélszámítógépnek kapcsolódnia kell a megosztott mappához, és az ahhoz tartozó meghajtó betűjelét kell kiválasztania telepítéskor.
  • Mielőtt a Terminálszolgáltatások ügyfele programot telepíti, az ügyfélszámítógépet megfelelően konfigurálnia kell és csatlakoztatnia kell a hálózathoz. Ha a 16 bites ügyfelet egy Windows Workgroups 3.11 rendszert futtató számítógépen telepíti, akkor – ha eddig még nem tette meg – telepítenie kell a TCP/IP protokollt is.

További információk Az Ügyfélkapcsolat kezelője program használata témakörben találhatók.


Bitképek gyorsítótárazása

A bitképek gyorsítótárazása azt jelenti, hogy a leggyakrabban használt bitképeket, mint például a Start gombon megjelenő képet, a rendszer az ügyfélgépen található fájlban helyezi el. Ez javítja a teljesítményt, mert minimalizálja a kapcsolaton keresztül továbbítandó, megjelenítéssel kapcsolatos adatokat.

A bitképek gyorsítótárazását munkamenetenként engedélyezheti az ügyfélszoftverből. A gyorsítótárazáshoz 10 MB szabad területre van szükség az ügyfélgép merevlemezén.

További információk a Bitképek gyorsítótárazása lemezen című témakörben találhatók.


Megosztott vágólap

A Windows 2000 Terminálszolgáltatások program fennakadás nélküli vágólapmegosztást biztosít, így az alkalmazások a felhasználói számítógépeken és a terminálszolgáltatások munkamenetein belül helyileg elérhetik a vágólap tartalmát.

A megosztott vágólap tartalmát a rendszer szinkronizálja a helyi vágólappal. A tartalom ezután a Windows Vágókönyv-megjelenítővel tekinthető meg (clipbrd.exe). A szinkronizálást követően például szöveget másolhat a munkamenet egy dokumentumából, és beillesztheti azt a számítógép helyi dokumentumába. De nem másolhat és nem illeszthet be fájlokat vagy mappákat. A megosztott vágólap csak szöveges és képi adatok kezelésére alkalmas.

A vágólapmegosztás letiltása kapcsolatonként, a Terminálszolgáltatások konfigurálása programmal állítható be. További információ az Ügyfelekhez történő meghajtó-, nyomtató- és eszköz-hozzárendelések kezelése című témakörben található.

A Windows 2000 Vágókönyv-megjelenítőről a Vágókönyv-megjelenítő – áttekintés című témakörben tájékozódhat.


Ügyfélhozzáférés biztosítása helyi nyomtatókhoz

A terminálszolgáltatások használatakor átirányíthatja a nyomtatást, ami azt jelenti, hogy a terminálkiszolgálón elindított nyomtatási feladatokat a program az ügyfél helyi nyomtatójára irányítja át.

A nyomtatásátirányítás a Terminálszolgáltatások konfigurálása programban kapcsolatonként tiltható le. Erről bővebben az Ügyfélmeghajtók és -nyomtatók csatlakoztatása bejelentkezéskor című témakörben olvashat. Ha az átirányítást felhasználónként kívánja letiltani, ezt az Active Directory - felhasználók és számítógépek vagy a Helyi felhasználók és számítógépek párbeszédpanelen teheti meg. Ezzel kapcsolatban az Ügyfélnyomtatók csatlakoztatása bejelentkezéskor című témakörben tájékozódhat.

A helyi nyomtatók elérése a következő két módon biztosítható az ügyfelek számára:

  • Automatikus nyomtatóátirányítás - a Windows 2000 rendszerben található, 32 bites Terminálszolgáltatások ügyfelei számára.
  • Kézi nyomtatóátirányítás - olyan 16 bites ügyfelek, Windows alapú terminálok és helyi nyomtatók számára, amelyek a Windows 2000 Server rendszerben biztosított illesztőprogramoktól eltérő illesztőprogramokat igényelnek.

Megjegyzések

  • A kétirányú nyomtatás nem támogatott.
  • Az átirányított nyomtatók a kiszolgálón futó alkalmazások számára is rendelkezésre állnak. Az átirányított nyomtatók a Vezérlőpult Nyomtatók mappájában jelennek meg, a következő névformátummal: Ügyfélnyomtató neve/Ügyfélszámítógép neve/Munkamenet száma.
  • Az ügyfelek csak saját átirányított nyomtatóikat látják a Nyomtatók párbeszédpanelen.

Automatikus nyomtatóátirányítás

A 32 bites, Windows 2000 Terminálszolgáltatások ügyfelei számára a nyomtatóátirányítás automatikus, ha a helyi nyomtató a Windows 2000 kiszolgálón telepített illesztőprogramot használja.

Amikor egy ügyfél bejelentkezik a Terminálszolgáltatások programba, az ügyfélszámítógép LPT-, COM- és USB-portjaira kapcsolódó helyi nyomtatókat a rendszer automatikusan felismeri, és a kiszolgálón létrehoz egy helyi várólistát. A kiszolgáló az ügyfélszámítógép nyomtatójának alapbeállításait és néhány egyéb jellemzőjét (például a kétoldali nyomtatást) használja.

Amikor egy ügyfél bontja a kapcsolatot vagy befejezi a munkamenetet, a rendszer törli a nyomtatási várólistát, és az esetleges befejezetlen vagy függő nyomtatási feladatok elvesznek. Az ügyfél helyi nyomtatójával és beállításaival kapcsolatos információkat a rendszer az ügyfélgépre menti. Az újabb bejelentkezések alkalmával a rendszer újra létrehozza a nyomtatási várólistát az ügyfélszámítógépen tárolt információk alapján.

Ha a nyomtatóillesztő-program nem található a kiszolgálón, a rendszer eseményt rögzít a naplóba, és nem hozza létre az ügyfélnyomtatót. A nyomtató elérhetősége érdekében az illesztőprogramot kézzel kell telepíteni a kiszolgálón.

Kézi nyomtatóátirányítás

Az ügyfél helyi számítógépének LPT- és COM-portjaihoz csatlakoztatott nyomtatók a Terminálszolgáltatások ügyfelei számára kézzel is átirányíthatók.

Megjegyzés

  • Az USB-portokhoz csatlakoztatott nyomtatók kézi átirányítása nem támogatott.

Az ügyfélnyomtató kézi átirányításához lépjen kapcsolatba a rendszergazdával, és adja meg a számítógépének a nevét (Windows alapú terminál esetén az IP-címet). A kézi átirányítás során az ügyfélnek kapcsolódnia kell terminálkiszolgálóhoz.

A rendszergazda a nyomtatót a Vezérlőpultról megnyitható Nyomtatók párbeszédpanel Nyomtató hozzáadása parancsával telepíti. A rendszergazda az ügyfélszámítógép nevét használja a nyomtatóport kiválasztásához a rendelkezésre álló nyomtatóportok listájából a Nyomtató hozzáadása párbeszédpanelen. A Port oszlopban megjelenik minden aktuálisan csatlakoztatott ügyfél portja. A Terminálszolgáltatások ügyfeleinek portjai az alábbiak szerint jelennek meg:

Port | Megnevezés
TS | számítógépnév:PortX (ahol a Port a port típusa, az X a port száma)

Amikor egy ügyfél bontja a kapcsolatot vagy befejezi a munkamenetet, a rendszer törli a nyomtatási várólistát, és az esetleges befejezetlen vagy függő nyomtatási feladatok elvesznek. Az ügyfél helyi nyomtatójával és a beállításokkal kapcsolatos információkat a rendszer az ügyfélgépre menti. Az újabb bejelentkezések alkalmával a rendszer újra létrehozza a nyomtatási várólistát az ügyfélszámítógépen tárolt információk alapján.

Megjegyzések

  • Ha a 32 bites ügyfélnyomtató automatikus átirányítása sikertelen, akkor a rendszer eseményt rögzít a naplóba. Ez az esemény tartalmazza az átirányítás sikertelenségének okát, és ha megállapítható azt, hogy melyik kiszolgálóoldali illesztőprogram hiányzik.
  • Amikor egy ügyfél bontja a kapcsolatot vagy kilép, a rendszer törli a nyomtatási várólistát, és az esetleges befejezetlen vagy függő nyomtatási feladatok elvesznek.
  • Az első kézi átirányítás után a következő belépések alkalmával a nyomtatók automatikusan átirányítódnak.


Kijelentkezés vagy leválasztás

A Terminálszolgáltatások program két lehetőséget kínál az ügyfél bezárására: a leválasztást, illetve a kijelentkezést.

Leválasztás esetén a munkamenet tovább fut a kiszolgálón, így később visszakapcsolódhat a kiszolgálóhoz és folytathatja a munkamenetet. Ha a kiszolgálón egy feladatot futtat, például egy időigényes adatbázis-lekérdezést, akkor lehetősége van a feladat elindítására, majd a kapcsolat bontására. Később újra bejelentkezhet a kiszolgálóra és visszaléphet a munkamenetbe, majd vagy visszatér a feladathoz, vagy már csak az eredményt ellenőrzi. Ez különösen akkor hasznos, ha távolsági vonalon létrehozott távelérésű kapcsolaton keresztül dolgozik.

A hálózati rendszergazdák korlátozhatják azt az időt, amíg a megszakított munkamenetek a kiszolgálón tovább futhatnak. Egyeztesse a rendszergazdával a munkamenetek hosszával kapcsolatos korlátozásokat.

A munkamenet bezárását kijelentkezésnek nevezik. Ilyenkor a munkamenet futása leáll a kiszolgálón. A munkameneten belül futó alkalmazások bezáródnak, és a nem mentett változtatások a nyitott fájlokban elvesznek. A kiszolgálóra történő legközelebbi bejelentkezéskor új munkamenet jön létre.


A terminálszolgáltatások felhasználói kapcsolatainak kezelése

Az Ügyfélkapcsolat kezelője program a - Terminálszolgáltatások ügyfele program részeként - lehetővé teszi a rendszergazdák és a felhasználók számára, hogy előre meghatározott, egy vagy több kiszolgálóra mutató kapcsolatokat hozzanak létre egyetlen program, illetve a teljes Asztal elérése céljából. Az Ügyfélkapcsolat kezelője program az ügyfél Asztalán egy ikont helyez el, amely egyetlen kattintással biztosítja a csatlakozást egy vagy több terminálkiszolgálóhoz. Így azok a rendszergazdák, akik a teljes számítógépes környezet számára biztosítani szeretnének egy egyszerű, üzleti tevékenységhez kapcsolódó programot, ezzel a módszerrel létrehozhatják a kapcsolatot, menthetik az ikont, majd a Terminálszolgáltatások ügyfele program segítségével minden Asztalon elhelyezhetik a kapcsolatot.

Ha az ügyfelek számára előre meghatározott kapcsolatokhoz szeretne parancsikonokat biztosítani, létrehozhat egy fájlt, amelyet a rendszer az ügyfél telepítésekor az Ügyfélkapcsolat kezelője programba importál. Ezek a kapcsolatok a telepítést követően az ügyfél Start menüjében és az Ügyfélkapcsolat kezelője programban is megjelennek.

Abban a programcsoportban, amelybe az ügyfélszoftvert telepíti, a Terminálszolgáltatások ügyfele kapcsolat lesz az alapértelmezett kapcsolat. Ha ezt a kapcsolatot használja egy kiszolgáló eléréséhez, a kapcsolat létrehozásához megadott információkat (kiszolgálónév, felbontás, felhasználónév és tartomány) a kapcsolat elmenti. A Terminálszolgáltatások ügyfele kapcsolat nem jelenik meg az Ügyfélkapcsolat kezelője programban, de az ott felsorolt összes kapcsolattal együtt exportálásra kerül, ha az Összes exportálása lehetőséget választja. Ne feledje, hogy a kapcsolat importálása során a rendszer felülírja az alapértelmezett kapcsolatot, és nemkívánatos információkat is továbbíthat egy másik számítógépre.

Az ügyfél telepítése során a telepítőprogram automatikusan megkeresi az összes .cns fájlt a telepítési könyvtárban, importálja őket az Ügyfélkapcsolat kezelője programba, majd hozzáadja a Start menühöz. További információt az Ügyfélkapcsolat kezelője program súgójában olvashat.

Az Ügyfélkapcsolat kezelője program használatáról Az Ügyfélkapcsolat kezelője program használata című témakörben tájékozódhat.


Telefonos kapcsolat használata a terminálkiszolgáló eléréséhez

Ha egy felhasználónak olyan hálózathoz van távoli hozzáférése, amely terminálkiszolgálókat tartalmaz, akkor ezen a kapcsolaton keresztül valamely terminálkiszolgálót is elérheti.

Terminálkiszolgálók táveléréséhez először telepítenie kell a Hálózati és telefonos kapcsolatok szolgáltatást a számítógépre. A távoli hálózat telepítése után a felhasználó csatlakozhat a terminálkiszolgálót tartalmazó hálózathoz, majd elindíthatja a Terminálszolgáltatások ügyfele programot. Ezután a szokásos módon bejelentkezhet a terminálkiszolgálóra.

A rendszergazdák biztosíthatják a felhasználók számára a munkamenethez történő visszacsatlakozást arra az esetre, ha a kapcsolat, azaz például a telefonvonal megszakad. Az újracsatlakozás kapcsolatonkénti engedélyezéséhez olvassa el az Időtúllépés beállítása leválasztott, aktív és üresjárati munkamenetekhez témakört, a felhasználónként történő engedélyezéséhez pedig A munkamenet időkorlátjának elérésére, illetve a kapcsolat megszakadására vonatkozó beállítások módosítása témakört.


A terminálszolgáltatások felügyelete

A rendszergazdák a Terminálszolgáltatások kezelője programmal megtekinthetik a megbízási tartományokban lévő terminálkiszolgálók információit. Ez tartalmazza az összes terminálkiszolgáló minden munkamenetének, felhasználójának és folyamatának információit. Ezenkívül ez a segédprogram használható a kiszolgáló kezelésével kapcsolatos feladatok elvégzésére is.

  • A konkrét feladatokkal kapcsolatos további tudnivalók az Útmutató című témakörben találhatók.
  • Az általános háttérinformációk a Fogalmak című témakörben találhatók.


Útmutató

  • Felhasználók, munkamenetek és folyamatok kezelése
  • Műveletek végzése terminálkiszolgálókkal


Felhasználók, munkamenetek és folyamatok kezelése

  • Csatlakozás másik munkamenethez
  • Leválasztás a munkamenetről
  • Felhasználó kiléptetése a munkamenetből
  • Üzenet küldése a felhasználónak
  • Munkamenet alaphelyzetbe állítása
  • Munkamenet állapotinformációinak megtekintése
  • Munkamenet távvezérlése
  • Folyamat leállítása


Csatlakozás másik munkamenethez

  1. Indítsa el a Terminálszolgáltatások kezelője programot.

  2. Kattintson a jobb gombbal arra a munkamenetre, amelyhez csatlakozni szeretne, majd kattintson a Csatlakozás parancsra.

    Megtörténik a csatlakozás az új munkamenethez és a leválasztás az előző munkamenetről.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, majd kattintson a Terminálszolgáltatások kezelője programra.
  • Mindig csatlakozhat ahhoz a munkamenethez, amelyre ugyanazzal a felhasználói fiókkal jelentkezett be. Egy másik felhasználói munkamenethez való csatlakozáshoz teljes hozzáférési vagy felhasználói hozzáférési joggal kell rendelkeznie.
  • Másik munkamenethez csak előző munkamenetből csatlakozhat. Egy munkamenetből egy másik munkamenethez való csatlakozáshoz meg kell nyitni a Terminálszolgáltatások kezelője ablakot vagy futtatni kell a tscon programot.
  • Csak aktív vagy leválasztott állapotban lévő munkamenethez lehet csatlakozni.
  • A rendszerkonzolról nem lehet másik munkamenethez csatlakozni.

Kapcsolódó témakörök


Leválasztás a munkamenetről

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.
  2. Kattintson a jobb egérgombbal a leválasztani kívánt munkamenetre, majd kattintson a Leválasztás parancsra.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, ezután mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.
  • A saját munkamenetről mindig leválhat, de más felhasználó munkamenetének leválasztásához teljes hozzáférési engedély szükséges.
  • A munkamenet leválasztás után továbbra is kapcsolódik a Terminálkiszolgálóhoz és a futó alkalmazások tovább futnak. Az alkalmazások a munkamenet újracsatlakozásakor adatvesztés nélkül futnak tovább.
  • A felhasználók automatikusan ugyanahhoz a munkamenethez kapcsolódnak vissza, amelyről leválasztódtak. Ha egy felhasználó a kiszolgálón több mint egy munkamenetre jelentkezett be, akkor egy listában megjelennek azok a folyamatok, amelyeket a felhasználó az újracsatlakozáshoz választhat.
  • A munkamenet leválasztására használható a tsdiscon parancs is.
  • A leválasztott állapotban lévő munkamenetet alapállapotba állíthatja – ezzel törli azt a kiszolgálóról. Ennek végrehajtásához teljes hozzáférési engedély szükséges.

Kapcsolódó témakörök


Felhasználó kiléptetése a munkamenetből

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.
  2. A Felhasználók lapon kattintson jobb gombbal arra a felhasználóra, akit ki akar léptetni, majd kattintson a Kilépés parancsra.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.
  • A saját munkamenetéről mindig kijelentkezhet, de más felhasználó munkamenetének leválasztásához teljes hozzáférési engedély szükséges.
  • A felhasználó figyelmeztetés nélküli kiléptetése a munkamenetből a felhasználói munkamenetben adatvesztéssel járhat. A Műveletek menüben az Üzenet küldése opcióval figyelmeztető üzenetet kell küldeni a felhasználónak, mielőtt a kiléptetést elvégzi.
  • Amikor egy felhasználót kijelentkeztet, minden folyamat befejeződik, a munkamenet pedig törlődik a kiszolgálóról.
  • A felhasználó a logoff paranccsal is kiléptethető a munkamenetből.
  • A konzolmunkamenetből nem léptetheti ki a felhasználót.

Kapcsolódó témakörök


Üzenet küldése a felhasználónak

  1. Nyissa meg a Terminálszolgáltatások kezelőjét.

  2. Kattintson jobb gombbal arra a munkamenetre vagy felhasználóra, amelynek üzenetet szeretne küldeni, majd kattintson az Üzenet küldése parancsra.

    Megjelenik az Üzenet küldése párbeszédpanel.

  3. Az üzenet címe mezőbe írja be az üzenet címét.
  4. Az Üzenet mezőbe írja be a felhasználónak küldendő információt. Ha új bekezdést akar kezdeni, nyomja le a CTRL+ENTER billentyűkombinációt.
  5. Az üzenet küldéséhez kattintson az OK gombra.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.
  • Ha üzenetet kíván küldeni egy felhasználónak, akkor ehhez felhasználói hozzáférési vagy teljes hozzáférési engedély szükséges.
  • Ennek a szolgáltatásnak a segítségével értesítheti a felhasználókat a hamarosan bekövetkező leválasztásról, a kiszolgáló állapotáról és egyéb rendszerinformációkról.
  • Csak olyan felhasználónak küldhet üzenetet, akinek a munkamenete aktív vagy csatlakoztatott állapotban van, beleértve a konzolmunkamenetet is. Az üzenetküldés hasznos lehet akkor, ha a felhasználókat bejelentkezésük előtt figyelmeztetni szeretné a kiszolgáló rövid időn belüli újraindításáról.
  • A felhasználóknak az msg paranccsal is küldhet üzeneteket.

Kapcsolódó témakörök


Munkamenet alaphelyzetbe állítása

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.

  2. Kattintson jobb gombbal arra a munkamenetre, amelyet alaphelyzetbe szeretne állítani, majd kattintson az Alaphelyzet parancsra.

    A munkamenet azonnal törlődik a kiszolgálóról.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, majd kattintson a Terminálszolgáltatások kezelője parancsra.
  • A saját munkamenetét mindig alaphelyzetbe állíthatja, de más felhasználó munkameneténél ezt csak teljes hozzáférési engedéllyel teheti.
  • A felhasználói munkamenet alaphelyzetbe állítása a munkamenetnél adatvesztést eredményezhet.
  • Csak akkor szabad egy munkamenetet alaphelyzetbe állítani, ha az hibásan működik vagy nem válaszol.
  • Ha egy figyelő munkamenetet állít alaphelyzetbe, akkor minden, ugyanezt a kapcsolatot használó munkamenet törlődik.
  • A munkamenet alaphelyzetbe állítására használható a reset session parancs is.

Kapcsolódó témakörök


Munkamenet állapotinformációinak megtekintése

  1. Indítsa el a Terminálszolgáltatások kezelője programot.

  2. Kattintson a jobb gombbal arra a munkamenetre, amelyről állapotinformációt szeretne, majd kattintson az Állapot parancsra.

    Megjelennek a munkamenetre vonatkozó számlálók Állapot információi.

  3. Az információ frissítéséhez kattintson a Frissítés most parancsra.

    A számlálók nullázásához kattintson a Számlálók nullázása parancsra.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start menüre, mutasson a Programok, Felügyeleti eszközök menüpontokra, végül kattintson a Terminálszolgáltatások kezelője programra.
  • A saját munkamenetének állapotinformációit bármikor megtekintheti, de más felhasználók munkamenetére vonatkozó információk megtekintéséhez teljes hozzáférési vagy felhasználói hozzáférési engedély szükséges.
  • Nem tekintheti meg a konzol- illetve a figyelő munkamenetek állapotinformációit.

Kapcsolódó témakörök


Munkamenet távvezérlése

  1. Indítsa el a Terminálszolgáltatások kezelője programot.

  2. Kattintson a jobb gombbal a figyelni kívánt munkamenetre, majd kattintson a Távvezérlés parancsra.

    Megjelenik a Távvezérlés párbeszédpanel.

  3. A Gyorsbillentyű résznél válassza ki a távvezérlés befejezéséhez használni kívánt billentyűket, majd kattintson az OK gombra. Az alapbeállítású gyorsbillentyű a CTRL+* ( a * csak a számbillentyűzetről).

    Amikor be akarja fejezni a távvezérlést, nyomja meg a CTRL+* billentyűket (vagy a definiált billentyűparancsot).

Megjegyzések

  • A Terminálszolgáltatások kezelője program megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, majd kattintson a Terminálszolgáltatások kezelője parancsra.
  • Egy másik munkamenet távvezérléséhez teljes hozzáférési engedélyre van szükség.
  • Egy adott kapcsolat távvezérlésének beállítása a Terminálszolgáltatások konfigurálása programmal lehetséges. A távvezérlés felhasználónként is konfigurálható a Terminálszolgáltatások Helyi felhasználók és csoportok bővítményével és az Active Directory – felhasználók és számítógépek eszközzel.
  • Ha a figyelmeztetés nincs letiltva, akkor a figyelés megkezdése előtt a kiszolgáló figyelmezteti a felhasználót, hogy a munkamenetet rövidesen távvezérelni fogják. Munkamenete néhány másodpercig lefagyottnak tűnhet, amíg a felhasználótól válaszra vár.
  • Amikor belép a távvezérlő munkamenetbe, a munkamenet minden bemenete és kimenete megegyezik a figyelt munkamenetével.
  • A saját munkamenetének támogatnia kell azt a képernyőfelbontást, amelyet a távvezérelt munkamenetben használnak, különben a távvezérlés sikertelen lesz.
  • A konzolmunkamenet nem távvezérelhető és nem használható másik munkamenet távvezérlésre.
  • Egy másik munkamenet távvezérlésére használható a shadow parancs is.

Kapcsolódó témakörök


Folyamat leállítása

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.
  2. A Folyamatok fülön, a Felhasználó című oszlop alatt a jobb gombbal kattintson arra a folyamatra, amelyet le akar állítani, majd kattintson a Folyamat leállítása parancsra.

Megjegyzések

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, ezután mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.
  • Egy folyamatot ne állítson le figyelmeztetés nélkül, mert ennek során a felhasználó munkameneténél adatvesztés történhet.
  • Egy folyamatot leállíthat például azért, mert az alkalmazás nem válaszol.
  • A folyamatok leállítására használható a tskill parancs is.

Kapcsolódó témakörök


Műveletek végzése terminálkiszolgálókkal

  • Csatlakozás egy vagy több terminálkiszolgálóhoz
  • Leválasztás egy vagy több terminálkiszolgálóról
  • A tartomány összes terminálkiszolgálójának keresése


Csatlakozás egy vagy több terminálkiszolgálóhoz

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.
  2. Bontsa ki azt a tartományt, amely azokat a kiszolgálókat tartalmazza, amelyekhez csatlakozni szeretne.
  3. Végezze el a következő műveletek egyikét:
    • Egy adott terminálkiszolgálóhoz úgy csatlakozhat, ha az egér jobb gombjával rákattint a kiszolgálóra, majd a menüben a Csatlakozás parancsot választja.
    • Ha a tartomány összes terminálkiszolgálójához szeretne csatlakozni, akkor kattintson az egér jobb gombjával a tartományra, majd a menüben a Csatlakozás a tartomány összes kiszolgálójához parancsra.

Megjegyzések

  • A Terminálszolgáltatások kezelője program elindításához kattintson a Start gombra, ezután mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.
  • Ajánlott egy időben csak egy terminálkiszolgálóhoz csatlakozni. Miután létrejött a kapcsolat egy kiszolgálóval, a Terminálszolgáltatások kezelője program lekérdezi a munkamenetre és a folyamatra vonatkozó információkat. Ha egyszerre több kiszolgálóhoz csatlakozik, akkor az túlterhelheti a rendszer erőforrásait.
  • Ha a hálózat összes tartományában lévő összes kiszolgálóhoz akar csatlakozni, akkor kattintson jobb gombbal a Minden figyelt kiszolgáló elemre, majd kattintson a Csatlakozás az összes kiszolgálóhoz parancsra.

Kapcsolódó témakörök


Leválás egy vagy több terminálkiszolgálóról

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.
  2. Nyissa meg azt a tartományt, amely azokat a kiszolgálókat tartalmazza, amelyekkel bontani akarja a kapcsolatot.
  3. Végezze el a következő műveletek egyikét:
    • Egy adott terminálkiszolgálóról való leváláshoz kattintson jobb gombbal a kiszolgálóra, majd a Leválasztás parancsra.
    • A tartomány összes terminálkiszolgálójáról való leválasztáshoz kattintson jobb gombbal a tartományra, majd kattintson a Leválasztás a tartomány összes kiszolgálójáról parancsra.

Megjegyzések

  • A Terminálszolgáltatások kezelője program megnyitásához kattintson a Start gombra, ezután mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.
  • Ha a hálózat összes tartományában lévő összes kiszolgálóval bontani akarja a kapcsolatot, akkor kattintson jobb gombbal a Minden figyelt kiszolgáló opcióra, majd a Leválasztás az összes kiszolgálóról parancsra.

Kapcsolódó témakörök


A tartomány összes terminálkiszolgálójának keresése

  1. Nyissa meg a Terminálszolgáltatások kezelője ablakot.
  2. Kattintson az egér jobb gombjával arra tartományra, amelynek terminálkiszolgálóit meg akarja találni, majd kattintson a Kiszolgálók keresése a tartományban parancsra.

Megjegyzés

  • A Terminálszolgáltatások kezelője elindításához kattintson a Start gombra, ezután mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson a Terminálszolgáltatások kezelője parancsra.

Kapcsolódó témakörök


Fogalmak

Ez a fejezet háttérinformációkat nyújt a terminálkiszolgálók felügyeletéről.

  • Terminálszolgáltatások kezelője - Áttekintés
  • A Terminálszolgáltatások kezelőjének használata
  • A Terminálszolgáltatások kezelője ablak


Terminálszolgáltatások kezelője - Áttekintés

A rendszergazdák a Terminálszolgáltatások kezelőjével megtekinthetik a meghatalmazott tartományokban lévő terminálkiszolgálókra vonatkozó információkat. Ezzel a segédprogrammal figyelhetők a felhasználók, a munkamenetek és az alkalmazások minden terminálkiszolgálón, ezen kívül lehetőség van különböző kiszolgálókezelő műveletek elvégzésére is.

Amikor a felhasználó létrehoz egy munkamenetet, vagyis az ügyfélszámítógépével csatlakozik a terminálkiszolgálóhoz, a munkamenet megjelenik a Terminálszolgáltatások kezelőjének Munkamenet listájában. A munkamenet során bejelentkezett felhasználó neve pedig a Felhasználók listában is megjelenik. Bármely alkalmazás, amely a felhasználó munkamenete alatt fut, a Folyamatok listában látható. Így egy terminálkiszolgálón minden felhasználó, munkamenet és folyamat egy helyről ellenőrizhető.

A Terminálszolgáltatások kezelője program Művelet menüjében található parancsokkal végezhető a terminálkiszolgáló kezelése. További tudnivalók a A Terminálszolgáltatások kezelőjének használata című témakörben találhatók.

Konzolmunkamenet

A Terminálszolgáltatások kezelőjében a rendszerkonzol munkamenete automatikusan megjelenik a Munkamenet listában, amikor ön egy terminálkiszolgálóhoz kapcsolódik. A konzol annak a számítógépnek a billentyűzetét, egerét és képernyőjét jelenti, amelyen a terminálkiszolgáló telepítve van. A konzolmunkamenetről ugyanúgy lehet a terminálkiszolgálóra bejelentkezni, mint egy ügyfélmunkamenetről. A konzolmunkamenetnek üzenet küldhető, de rajta semmilyen felügyeleti tevékenység nem végezhető.

Figyelő munkamenetek

A figyelő munkamenetek különböznek a normál munkamenetekől. Ezek a munkamenetek figyelik és elfogadják az új RDP-ügyfélcsatlakozásokat, valamint új munkameneteket hoznak létre az ügyfelek kérésére. Ha a Terminálszolgáltatások konfigurálása modulban több mint egy csatlakoztatás van beállítva, akkor több figyelő munkamenet létezhet.

Lehetőség van egy figyelő munkamenet befejezésére is, de ez nem ajánlott, mert ezzel befejez minden munkamenetet, amely ugyanazt a terminálszolgáltatás-kapcsolatot használja. Egy felhasználó munkamenetének figyelmeztetés nélküli befejezése az ügyféloldalon adatvesztéssel jár.

Üresjárati munkamenetek

A terminálkiszolgáló működésének optimalizálásához a kiszolgáló automatikusan üresjárati munkameneteket kezdeményez, mielőtt az ügyfelek kapcsolódnának. Ezek a munkamenetek állnak rendelkezésre az ügyfelek számára a kapcsolódásnál. Alapértelmezésként két üresjárati munkamenet jön létre.


A Terminálszolgáltatások kezelőjének használata

A Terminálszolgáltatások kezelőjével figyelhetők a meghatalmazott tartományokban lévő terminálkiszolgálók munkamenetei, felhasználói és folyamatai. A figyelésen túl a Terminálszolgáltatások kezelője parancsaival lehetőség van a terminálkiszolgáló kezelésére is. A Művelet menüben található parancsok leírása az alábbiakban olvasható. Legtöbbjük végrehajtásához speciális jogok szükségesek.

Művelet | Leírás | Szükséges engedélyezési szint
Csatlakozás | Engedélyezi egy felhasználó másik munkamenethez való kapcsolódását. Megjegyzendő, hogy amikor egy másik felhasználó által használt munkamenethez történik a csatlakozás, akkor ez a felhasználónál adatvesztéssel járhat. Amikor ön egy másik munkamenthez kapcsolódik, akkor az előző munkamenettel automatikusan megszűnik a kapcsolata. Ha több mint egy munkamenetben vesz részt egy kiszolgálón, ezzel a paranccsal átkapcsolhat az egyes munkamenetek között. A rendszerkonzolról nem lehet másik munkamenethez kapcsolódni. További tudnivalók a Kapcsolódás másik munkamenethez című témakörben találhatók. | Felhasználói hozzáférés vagy teljes hozzáférés
Leválasztás | Leválasztja a felhasználót egy munkamenetről. A munkamenet leválasztott állapotban továbbra is a kiszolgálóhoz kapcsolódik, a pillanatnyilag futó alkalmazások pedig tovább futnak. Ha megkísérli az újracsatlakozást a kiszolgálóra, ugyanahhoz a munkamenethez kapcsolódik, mint amelyről le lett választva, akkor is, ha másik számítógépről kapcsolódik vissza. A leválasztáskor nyitva maradt alkalmazások tovább futnak, amikor újracsatlakozik a munkamenethez, így nem történik adatvesztés. Ez rendkívül hasznos, ha gyakran változtatja a helyét (például a munkahelyről haza). További tudnivalók a Leválasztás a munkamenetről című témakörben találhatók. | Teljes hozzáférés
Üzenetküldés | Engedélyezi egy felhasználónak, hogy üzenetet küldjön egy másik felhasználó munkamenetéhez. Elképzelhető például, hogy a rendszergazda üzenetet szeretne küldeni az egyik felhasználónak, mielőtt leválasztja őt egy munkamenetről vagy kijelentkezteti a rendszerből. További tudnivalók az Üzenet küldése a felhasználónak című témakörben találhatók. | Felhasználói hozzáférés vagy teljes hozzáférés
Távvezérlés | Engedélyezi a felhasználó számára, hogy figyeljen egy másik felhasználói munkamenetet és abba beavatkozzon, illetve lehetővé teszi a munkamenet tevékenységeinek figyelését, valamint a munkamenetek közötti kommunikációt. A figyelés megkezdése előtt üzenetet küldhet a felhasználónak, hogy a munkamenetének működését mostantól nyomon követi. A távvezérlés beállítása történhet a Terminálszolgáltatások konfigurációja párbeszédpanelen vagy felhasználónkénti alapon a Terminálszolgáltatások Helyi felhasználók és csoportok bővítményével és az Active Directory – felhasználók és számítógépek eszközzel. A rendszerkonzolról nem lehet másik munkamenetet távvezérelni. További háttérinformációk a Távvezérlés használata című témakörben találhatók. A távvezérlés használatáról a Munkamenet távvezérlése című témakörben található útmutató. | Teljes hozzáférés
Alaphelyzetbe állítás | Lehetővé teszi egy munkamenet azonnali törlését. Megjegyzendő, hogy a felhasználó munkamenetének alaphelyzetbe állítása a munkamenet adatainak elvesztésével járhat. Csak akkor szabad egy munkamenetet alaphelyzetbe állítani, ha az hibásan működik vagy nem válaszol. Egy figyelő munkamenet alaphelyzetbe állítása minden olyan munkamenet alaphelyzetbe állítását eredményezi, amely ugyanazt a kapcsolatot használja. További tudnivalók a Munkamenet alaphelyzetbe állítása című témakörben találhatók. | Teljes hozzáférés
Állapot | Lehetővé teszi a munkamenettel kapcsolatos számlálók figyelését, mint például beérkező és kimenő bájtok, keretek. A konzol- és a figyelő munkamenetek állapotinformációi nem jelezhetők ki. További tudnivalók a Munkamenet állapotinformációinak megtekintése című témakörben találhatók. | Felhasználói hozzáférés vagy teljes hozzáférés
Kijelentkezés | Lehetővé teszi egy felhasználó kiléptetését a kiszolgálón futó munkamenetből. Megjegyzendő, hogy a felhasználó figyelmeztetés nélküli kijelentkeztetése a munkamenet adatainak elvesztését eredményezheti. Amikor egy felhasználót kijelentkeztet, annak minden folyamata befejeződik, és a munkamenet törlődik a kiszolgálóról. További tudnivalók a Felhasználó kiléptetése a munkamenetből című témakörben találhatók. | Teljes hozzáférés
Folyamat vége | Lehetővé teszi egy felhasználói munkamenet alatt futó folyamat leállítását. Ez akkor hasznos, ha egy alkalmazás nem válaszol. Megjegyzendő, hogy a folyamat figyelmeztetés nélküli leállítása a felhasználói munkamenet adatainak elvesztését eredményezheti. További tudnivalók a Folyamat leállítása című témakörben találhatók. | Teljes hozzáférés


A Terminálszolgáltatások kezelője ablak

A Terminálszolgáltatások kezelője ablak két táblából áll. A navigációs ablaktábla a hálózaton lévő tartományokat, terminálkiszolgálókat és munkameneteket mutatja. A részletek ablaktáblában a fülek a navigációs ablaktáblán kiválasztott tételek eredményét jelenítik meg. Ha például rákattint egy kiszolgálóra a navigációs ablaktáblán, a részletek ablaktáblában megjelenik egy sor fül, amelyek megjelenítik a felhasználók listáját, a munkameneteket, valamint a kiszolgálóhoz kapcsolódó folyamatokat.

A feladatok végrehajtása általában úgy történik, hogy a navigációs táblán ki kell választani az adott elemet, majd a részletek táblán az egér jobb gombjávál előhívható menü, illeve az eszköztárak segítségével el kell végezni a szükséges műveleteket.

A terminálkiszolgálók figyelésével kapcsolatos tudnivalókért kattintson a témakörök valamelyikére:

  • A kiszolgálóhoz vagy tartományhoz tartozó felhasználók megtekintése
  • A kiszolgálóhoz vagy tartományhoz tartozó munkamenetek megtekintése
  • A kiszolgálóhoz vagy tartományhoz tartozó folyamatok megtekintése
  • A munkamenethez tartozó folyamatok megtekintése
  • Az ügyfélinformációk megtekintése
  • Munkamenet-állapotok


A kiszolgálóhoz vagy tartományhoz tartozó felhasználók megtekintése

A Terminálszolgáltatások kezelője információkat biztosít a felhasználó munkamenetéről, a munkamenet állapotáról és a terminálkiszolgálóhoz kapcsolódott valamennyi felhasználó egyéb tulajdonságairól. A terminálkiszolgálóra csatlakozott felhasználó információinak megtekintéséhez kattintson a kiszolgálóra vagy a tartományra a navigációs ablaktáblán, majd kattintson a Felhasználók fülre.

A Felhasználók lapon található mezők leírása az alábbi táblázatban látható:

Mező | Leírás
Kiszolgáló | Megjeleníti azokat a kiszolgálókat, amelyekre felhasználók jelentkeztek be. Ez a mező csak akkor jelenik meg, amikor rákattint egy tartományra a navigációs ablaktáblán.
Felhasználó | Megjeleníti a kiszolgálóhoz vagy tartományhoz tartozó összes felhasználót.
Munkamenet | Megjeleníti a kiszolgálóhoz vagy egy tartomány összes kiszolgálójához tartozó munkameneteket. Az állapottól függetlenül minden munkamenet megjelenik.
Azonosító | Megjeleníti azt számot, amely a kiszolgálón a munkamenetet azonosítja.
Állapot | Megjeleníti a munkamenet pillanatnyi állapotát. A munkamenet állapotai az alábbiak lehetnek: active, conn, connq, shadow, listen, disc, idle, down és init. További tudnivalók a Munkamenet-állapotok című témakörben találhatók.
Üresjárati idő | Megjeleníti a munkamenet alatt a billentyűzetről vagy az egérről érkezett utolsó bevitel óta eltelt perceket.
Bejelentkezési idő | A felhasználó bejelentkezési időpontja, ha elérhető.


A kiszolgálóhoz vagy tartományhoz tartozó munkamenetek megtekintése

A Terminálszolgáltatások kezelője programmal megjelenítheti a terminálkiszolgálón futó munkamenetek állapotaival, felhasználóival és egyéb tulajdonságaival kapcsolatos információkat. A terminálkiszolgáló egy munkamenetének megtekintéséhez kattintson a kiszolgálóra vagy a tartományra a navigációs ablaktáblán, majd kattintson a Munkamenetek fülre.

A Munkamenetek fül mezőinek leírása az alábbi táblázatban található.

Mező | Leírás
Kiszolgáló | Megjeleníti a munkamenetekhez tartozó kiszolgálókat. Ez a mező csak akkor jelenik meg, amikor rákattint egy tartományra a navigációs ablaktáblán.
Munkamenet | Megjeleníti a kiszolgálóhoz tartozó munkameneteket. Az állapottól függetlenül minden munkamenet megjelenik.
Felhasználó | Megjeleníti a kiszolgálóhoz vagy tartományhoz tartozó felhasználókat.
Azonosító | Megjeleníti azt a számot, amely azonosítja a munkamenetet a kiszolgáló számára.
Állapot | Megjeleníti egy munkamenet pillanatnyi állapotát. A munkamenet állapotai az alábbiak lehetnek: active, conn, connq, shadow, listen, disc, idle, down és init. További tudnivalók a Munkamenet-állapotok című témakörben találhatók.
Típus | Megadja a munkamenetet használó ügyfél típusát vagy azt, hogy a munkamenet a rendszerkonzolon fut-e.
Ügyfél neve | Meghatározza a munkamenetet használó ügyfélszámítógép nevét, ha az elérhető.
Üresjárati idő | Megjeleníti egy munkamenet alatt a billentyűzetről vagy az egérről érkezett utolsó bevitel óta eltelt perceket.
Bejelentkezési idő | A felhasználó bejelentkezési időpontja, ha elérhető.
Megjegyzés | További információkat ad meg a munkamenetről (például annak helyét). Ezt a mezőt nem kötelező kitölteni.


A kiszolgálóhoz vagy tartományhoz tartozó folyamatok megtekintése

A Terminálszolgáltatások kezelője programmal megtekinthetők a terminálkiszolgáló folyamatainak aktuális információi. A folyamatok megtekintéséhez kattintson a kiszolgálóra vagy a tartományra a navigációs ablaktáblán, majd kattintson a Folyamatok fülre.

A Folyamatok fül mezőinek leírása a következő táblázatban található.

Mező | Leírás
Kiszolgáló | Megjeleníti a folyamatokhoz tartozó kiszolgálókat. Ez a mező csak akkor jelenik meg, amikor rákattint egy tartományra a navigációs ablaktáblán.
Felhasználó | Megjeleníti a folyamatokhoz tartozó felhasználókat.
Munkamenet | Megjeleníti a folyamatokhoz tartozó munkameneteket. Az állapottól függetlenül minden munkamenet megjelenik.
Azonosító | Megjeleníti azt az azonosító számot, amely azonosítja a munkamenetet a kiszolgáló számára.
PID | Megjeleníti azt az azonosító számot, amely azonosíja a folyamatot a kiszolgáló számára.
Bináris fájl | Megadja azt a végrehajtható programot, amely létrehozta a folyamatot.


A munkamenethez tartozó folyamatok megtekintése

A Terminálszolgáltatások kezelője programmal megtekinthetők egy adott munkamenethez tartozó folyamatok aktuális információi. A folyamatok megtekintéséhez kattintson a navigációs ablaktáblán a munkamenetre, majd a Folyamatok fülre.

A Folyamatok fül mezőinek leírása a következő táblázatban található.

Mező | Leírás
Azonosító | Megjeleníti azt az azonosító számot, amely azonosítja a munkamenetet a kiszolgáló számára.
PID | Megjeleníti azt az azonosító számot, amely azonosíja a folyamatot a kiszolgáló számára.
Bináris fájl | Meghatározza azt a végrehajtható programot, amely létrehozta a folyamatot.


Az ügyfélinformációk megtekintése

A Terminálszolgáltatások kezelője programmal megtekinthetők egy adott munkamenet ügyfélinformációi. Az ügyfélinformációk megtekintéséhez kattintson a navigációs ablaktáblán a munkamenetre, majd az Információ fülre.

Az alábbi információk jelennek meg:

  • Felhasználónév
  • Ügyfél neve
  • Ügyfél buildszáma
  • Ügyfél könyvtára
  • Ügyfél termékazonosítója
  • Ügyfél hardverazonosítója
  • Ügyfél címe
  • Kiszolgálói pufferek
  • Ügyfélpufferek
  • Ügyfél színmélysége
  • Ügyfél felbontása
  • Modem neve, ha van
  • Titkosítási szint
  • Ügyfél licencei


Munkamenet-állapotok

A munkamenetek lehetséges állapotainak leírása az alábbi táblázatban látható.

Munkamenet állapota | Leírás
Aktív | A munkamenet kapcsolódott és a felhasználó bejelentkezett a kiszolgálóra.
Kapcsolódott | A munkamenet kapcsolódott, de felhasználó nem jelentkezett be a kiszolgálóra.
Kérdéses kapcsolódás | A munkamenet a kapcsolódás állapotában van. Ha ez az állapot folytatódik, az kapcsolódási problémát jelez.
Távvezérlés | A munkamenet jelenleg egy másik munkamenetet távvezérel.
Figyelés | A munkamenet kész fogadni az ügyfél kapcsolódását.
Leválasztott | A felhasználó kapcsolata megszűnt a munkamenettel, de a munkamenet továbbra is a kiszolgálóhoz kapcsolódik, és bármikor visszacsatlakoztatható.
Üresjárat | A munkamenet elindult és kész fogadni kapcsolódást. A kiszolgáló működésének optimalizálásához két alapértelmezett (üresjárati) munkamenet automatikusan elindul, mielőtt ügyfélkapcsolódás történne.
Leállt | A munkamenet inicializálása sikertelen volt vagy a munkamenetet nem lehet befejezni és jelenleg nem elérhető. Ha ez az állapot folytatódik, az problémát jelez a munkamenet csatlakozásával.
Inicializálás | A munkamenet inicializálása folyamatban van.


A terminálszolgáltatások parancsai

A terminálszolgáltatások legtöbb felügyeleti segédprogramja a parancssorból is elérhető. Az alábbi táblázat ezeket a segédprogramokat ismerteti.

Parancs | Funkció
change logon | Ideiglenesen letiltja az adott terminálkiszolgálóra irányuló bejelentkezéseket.
change port | Módosítja a COM-porthozzárendeléseket az MS-DOS alapú programokkal való kompatibilitás érdekében.
change user | Módosítja az .ini fájl hozzárendelését az aktuális felhasználónál.
cprofile | Eltávolítja a felhasználóspecifikus fájltársításokat a felhasználói profilból.
dbgtrace | Engedélyezi vagy letiltja a hibakeresés nyomkövetését.
flattemp | Engedélyezi vagy letiltja az ideiglenes könyvtárak használatát.
logoff | Kiléptet egy felhasználót a munkamenetből, és törli a munkamenetet a kiszolgálóról.
msg | Üzenetet küld egy felhasználónak vagy felhasználói csoportnak.
query process | Megjeleníti az adott terminálkiszolgálón futó folyamatokra vonatkozó információkat.
query session | Megjeleníti az adott terminálkiszolgálón futó munkamenetekre vonatkozó információkat.
query termserver | Megjeleníti a hálózat terminálkiszolgálóit tartalmazó listát.
query user | Megjeleníti az adott terminálkiszolgálón futó felhasználói munkamenetekre vonatkozó információkat.
register | Az alkalmazásokat a rendszer globális környezetében végrehajthatóként regisztrálja.
reset session | Visszaállítja a munkamenetet az ismert kiindulási értékekre.
shadow | Figyelemmel kísér egy másik felhasználói munkamenetet.
tscon | Csatlakozik egy másik terminálkiszolgálón futó munkamenethez.
tsdiscon | Leválaszt egy ügyfelet egy adott terminálkiszolgálón futó munkamenetről.
tskill | Bezár egy folyamatot.
tsprof | Átmásolja a felhasználói konfigurációt, és módosítja a profil elérési útvonalát.
tsshutdn | Leállít egy adott terminálkiszolgálót.


A change logon parancs

Engedélyezi vagy tiltja az ügyfélmunkamenetekből érkező bejelentkezéseket, illetve jelzi az aktuális bejelentkezési állapotot. Ez a parancs a rendszerkarbantartásnál hasznos.

change logon {/enable | /disable | /query}

Paraméterek

/enable

Engedélyezi a bejelentkezést az ügyfélmunkamenetből, de a konzolból nem.

/disable

Tiltja ügyfélmunkamenetekből érkező további bejelentkezéseket, de a konzolról érkezőket nem. A már bejelentkezett felhasználókat ez nem érinti.

/query

Kijelzi a pillanatnyi bejelentkezési állapotot, függetlenül attól, hogy a bejelentkezés engedélyezve van vagy tiltva.

Biztonsági korlátozások

A change logon parancsot csak rendszergazdák használhatják.

Megjegyzés

  • A bejelentkezések újra engedélyezésre kerülnek, ha a rendszert újraindítják. Ha ügyfélmunkamenetből csatlakozik a terminálkiszolgálóhoz, és kilép, mielőtt a bejelentkezés újra engedélyezve lenne, nem tud a munkamenetből visszakapcsolódni. Jelentkezzen be a konzolon, hogy az ügyfélmunkamenetből történő bejelentkezéseket újra engedélyezhesse.


A change port parancs

Módosítja a COM-porthozzárendeléseket az MS-DOS alapú alkalmazásokkal való kompatibilitás érdekében.

change port [portx=porty | /d portx | /query]

Paraméterek

portx=porty

Hozzárendeli az x portot az y porthoz.

/d portx

Törli az x COM-port hozzárendelését.

/query

Kijelzi az érvényben lévő porthozzárendeléseket.

Megjegyzések

  • A legtöbb MS-DOS alapú alkalmazás csak a COM1 - COM4 soros portokat támogatja. A change port parancs a soros portot egy másik portszámhoz rendeli hozzá, lehetővé téve, hogy a magasabb számú COM-portokat nem támogató alkalmazások hozzáférjenek a soros porthoz. Ha a COM12-portot hozzá szeretné rendelni a COM1-porthoz annak érdekében, hogy azt egy MS-DOS alapú alkalmazás használhassa, írja be a következő parancsot: change port com12=com1. A hozzárendelés csak az aktuális munkamenetben működik, így nem lesz érvényes a munkamenetből való kilépés, majd újbóli visszalépés után.
  • A rendelkezésre álló COM-portok és az érvényben lévő hozzárendelések megjelenítéséhez írja be paraméterek nélkül a change port parancsot.


A change user parancs

Módosítja az .ini fájl hozzárendelésével kapcsolatos beállításokat.

change user {/execute | /install | /query}

Paraméterek

/execute

Engedélyezi az .ini fájl hozzárendelését a kezdőkönyvtárhoz. Ez az alapértelmezett beállítás.

/install

Tiltja az .ini fájl hozzárendelését a kezdőkönyvtárhoz. A rendszer minden .ini fájlt a rendszerkönyvtárból olvas ki és ír vissza. Amikor alkalmazásokat telepít a terminálkiszolgálóra, le kell tiltania az .ini fájl hozzárendelését.

/query

Az .ini fájl hozzárendelésének érvényben lévő beállításait jeleníti meg.

Megjegyzések

  • Alkalmazás telepítése előtt a change user /install parancs alkalmazásával hozzon létre .ini fájlokat az alkalmazás számára a rendszerkönyvtárban. Ezek a fájlok a felhasználóspecifikus .ini fájlok főmásolataiként szolgálnak. Az alkalmazás telepítése után az .ini fájl normál hozzárendelésének visszaállításához használja a change user /execute parancsot.
  • Első futtatáskor az alkalmazás az .ini fájlokat a kezdőkönyvtárban keresi. Ha az .ini fájlok nem a kezdőkönyvtárban, hanem a rendszerkönyvtárban találhatók, a Terminálszolgáltatások program átmásolja az .ini fájlokat a kezdőkönyvtárba, ezzel biztosítva, hogy minden felhasználó saját másolattal rendelkezzen az alkalmazás .ini fájljáról. Minden új .ini fájl a kezdőkönyvtárba kerül.
  • Minden felhasználónak saját másolattal kell rendelkeznie az alkalmazás .ini fájljáról. Ezzel megelőzhetők az olyan esetek, ahol a különböző felhasználóknak inkompatibilisek az alkalmazásbeállításaik, azaz például különbözőek a kezdőkönyvtárak vagy a képernyőfelbontások.
  • A rendszer telepítési üzemmódja közben (change user /install) számos dolog történik. A rendszerleíró adatbázis összes létrehozott bejegyzése árnyékozással a következő könyvtárba kerül: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServer\Install. A HKEY_CURRENT_USER könyvtárhoz hozzáadott kulcsok a \SOFTWARE könyvtárba, a HKEY_LOCAL_MACHINE könyvtárhoz hozzáadott kulcsok pedig a \MACHINE könyvtárba kerülnek. Ha az alkalmazás rendszerhívással, például a GetWindowsDirectory használatával kérdezi le a Windows könyvtárat, akkor terminálkiszolgáló a rendszergyökér könyvtárhoz tér vissza. Ha az .ini fájlban lévő bármely bejegyzés rendszerhívás, például a WritePrivateProfileString használatával kerül hozzáadásra, akkor ezek a bejegyzések a rendszergyökér könyvtárban lévő .ini fájlokba kerülnek.
  • Amikor a rendszer visszatér a végrehajtási üzemmódba (change user /execute), és az alkalmazás megpróbálja a nem létező HKEY_CURRENT_USER könyvtárból kiolvasni a rendszerleíróadatbázis-bejegyzést, a Terminálszolgáltatások program ellenőrzi, nincs-e a kulcsnak másolata a \TerminalServer\Install könyvtárban. Ha igen, a kulcsok a HKEY_CURRENT_USER könyvtár megfelelő alkönyvtárába kerülnek. Ha az alkalmazás nem létező .ini fájlból próbál olvasni, a Terminálszolgáltatások program a rendszergyökérben keresi az .ini fájlt. Ha az .ini fájl megtalálható a rendszergyökérben, a program átmásolja a felhasználó kezdőkönyvtárának \Windows alkönyvtárába. Ha az alkalmazás lekérdezi a Windows könyvtárat, a terminálkiszolgáló visszatér a felhasználó kezdőkönyvtárának \Windows alkönyvtárába.
  • Bejelentkezéskor a Terminálszolgáltatások ellenőrzi, hogy a rendszer .ini fájljai újabbak-e, mint a számítógépen lévő .ini fájlok. Ha a rendszer verziója újabb, akkor a számítógépen lévő .ini fájlokat a program lecseréli, vagy összefésüli az újabb verzióval. Ez attól függ, hogy az INISYNC bit (0x40) be van-e állítva az adott .ini fájlhoz. Az ini fájl eredeti változata az Inifile.ctx nevet kapja. Ha a \TerminalServer\Install könyvtárban található rendszerleíróadatbázis-értékek újabbak, mint a HKEY_CURRENT_USER könyvtárban lévő verzió, akkor a számítógép kulcsait a program törli és lecseréli a \TerminalServer\Install könyvtárban lévő új verzióra.

A programtelepítésről a Programok telepítése a terminálszolgáltatások alkalmazáskiszolgálói módban való használatához című témakörben olvashat bővebben.


A cprofile parancs

Törli a feleslegesen helyet foglaló profilokat, és ha a felhasználóspecifikus fájlok társítása le van tiltva, akkor a társításokat eltávolítja a rendszerleíró adatbázisból. A használatban lévő profilok nem módosulnak.

cprofile [/l] [/i] [/v] [fájllista]

cprofile [/i] [/v] fájllista

Paraméterek

/l

Töröl minden helyi profilt. További profilok a fájllista paraméterben adhatók meg.

/i

Minden profilnál interaktív módon értesíti a felhasználót.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

fájllista

Azon fájlok listája, amelyekből el szeretné távolítani a felhasználóspecifikus fájltársításokat. A listában szóközzel kell elválasztani a fájlokat egymástól. A fájlnevek helyettesítő karaktereket is tartalmazhatnak.

Megjegyzések

  • A cprofile parancsot csak rendszergazdák futtathatják.
  • A terminálkiszolgálók fájltársításokat használnak annak meghatározásához, hogy melyik alkalmazás induljon el adott típusú fájl esetén. A fájltípusok a Windows Intézővel regisztrálhatók.
  • A felhasználónkénti fájltársítások lehetővé teszik, hogy a különböző felhasználók más-más alkalmazást társítsanak ugyanahhoz a fájltípushoz. Így például az egyik felhasználó a .doc fájlokat társíthatja a Microsoft Word programhoz, a másik pedig a WordPad programhoz.
  • A felhasználóspecifikus fájltársításokat a peruser paranccsal lehet engedélyezni vagy letiltani. Ha a felhasználóspecifikus fájltársítás engedélyezve van, a cprofile parancs a felhasználói profilból csak a nem használt helyet távolítja el. Ha a felhasználóspecifikus fájltársítás le van tiltva, akkor a cprofile a megfelelő rendszerleíróadatbázis-bejegyzéseket is eltávolítja.


A dbgtrace parancs

Engedélyezi vagy letiltja a hibakeresés nyomkövetését.

dbgtrace [név | azonosító | /system ] [/all | /c:osztály /e:típus] [/d] [/t] [/o:karakterlánc] [/?]

Paraméterek

név

Meghatározza annak a célmunkamenetnek a nevét, amelyen a nyomkövetést futtatni kell.

azonosító

Meghatározza annak a célmunkamenetnek az azonosítóját, amelyen a nyomkövetést futtatni kell.

/system

Minden munkameneten futtatja a nyomkövetést. Amikor ezt a paramétert használja, a név és az azonosító megadása nem szükséges.

/all

Minden osztályt és típust nyomon követ. Amikor ezt a paramétert használja, a /c és a /e paraméterek megadása nem szükséges.

/c:osztály

Meghatároz egy osztályértéket a nyomkövetéshez.

/e:típus

Meghatároz egy típusértéket a nyomkövetéshez.

/d

Meghatározza, hogy a nyomkövetés eredményében alkalmazzon-e hibakeresést.

/t

A nyomkövetést a megszakításig futtatja.

/o:karakterlánc

Meghatározza a nyomkövetés korlátozására használható illesztőprogram-beállításokat.

Megjegyzések

  • A nyomkövetés futtatásához a /all paramétert, vagy a /c:osztály és az /e:típus paramétereket együtt kell megadnia.
  • A /all, /c:osztály és /e:típus paraméterek nélkül alkalmazott dbgtrace parancs letiltja a nyomkövetést.


A flattemp parancs

A flattemp parancs engedélyezi vagy letiltja az egyszerű ideiglenes mappák használatát. Az ideiglenes mappák (amelyekre rendszerint a TEMP és TMP környezeti változók mutatnak) több felhasználó számára történő létrehozása alapértelmezés szerint alkönyvtárak létrehozását jelenti a \Temp mappában a bejelentkezési azonosító alkönyvtárnévként történő használatával. Ha például a TEMP környezeti változó a C:\Temp könyvtárra mutat, akkor a 4-es számú felhasználói bejelentkezési azonosítóhoz hozzárendelt ideiglenes könyvtár a következő lesz: C:\Temp\4. A flattemp használatával közvetlenül a \Temp mappára mutathat, így elkerülhető az alkönyvtárak létrehozása. Ez akkor hasznos, ha azt szeretné, hogy a felhasználók ideiglenes mappái a kezdőkönyvtárakban legyenek, akár a terminálkiszolgáló helyi meghajtóján, akár egy hálózati megosztás meghajtóján. Ezt a parancsot csak akkor szabad használni, ha mindegyik felhasználó külön ideiglenes mappával rendelkezik. Az ideiglenes mappák munkamenetenkénti használatával kapcsolatban további információk az Eltérő ideiglenes mappák használata az egyes munkamenetekhez című témakörben találhatók.

Miután minden felhasználó saját ideiglenes könyvtárral rendelkezik, az egyszerű ideiglenes könyvtárak engedélyezéséhez használja a flattemp /enable parancsot.

flattemp {/query | /enable | /disable}

Paraméterek

/query

Lekérdezi az érvényes beállítást.

/enable

Engedélyezi az ideiglenes könyvtárak használatát.

/disable

Letiltja az ideiglenes könyvtárak használatát.

Megjegyzések

  • A flattemp parancsot csak rendszergazdák futtathatják.
  • Ha a felhasználó ideiglenes könyvtára hálózati meghajtón van, alkalmazáshibák léphetnek fel. Ilyen eset akkor fordulhat elő, amikor a hálózati megosztás pillanatnyilag hozzáférhetetlenné válik. Mivel ilyenkor az alkalmazás ideiglenes fájljai hozzáférhetetlenek vagy nincsenek szinkronban, úgy tűnik, mintha a lemez leállt volna. Emiatt nem ajánlott az ideiglenes fájlok hálózati meghajtóra történő áthelyezése. Alapértelmezés szerint legyen az ideiglenes könyvtárak helye a helyi meghajtó merevlemeze. Ha bizonyos alkalmazásoknál váratlan viselkedést tapasztal vagy lemezsérülési hibát észlel, stabilizálja a hálózatot, vagy helyezze át az ideiglenes könyvtárakat a helyi meghajtó merevlemezére.
  • Ha letiltja a munkamenetenként eltérő ideiglenes könyvtárak használatát, a flattemp által megadott beállítások figyelmen kívül maradnak. A letiltás a Terminálszolgáltatás konfigurálása programban állítható be.


A logoff parancs

Kiléptet egy felhasználót a munkamenetből, és törli a munkamenetet a kiszolgálóról.

logoff [munkamenet-azonosító | munkamenetnév] [/server:kiszolgálónév] [/v]

Paraméterek

munkamenet-azonosító

A kiszolgáló számára a munkamenetet azonosító szám.

munkamenetnév

A munkamenet neve.

/server:kiszolgálónév

Meghatározza annak a munkamenetnek a terminálkiszolgálóját, amelyből a felhasználót ki szeretné léptetni. Ha nincs kiszolgáló meghatározva, akkor a parancs arra a kiszolgálóra vonatkozik, amelyre Ön pillanatnyilag be van jelentkezve.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

Példák

A felhasználó aktuális munkamenetből történő kiléptetéséhez írja be a következő parancsot:

logoff

A felhasználó munkamenet-azonosító (például 12-es) alapján történő kiléptetéséhez írja be a következőt parancsot:

logoff 12

A felhasználó munkamenet-azonosító (például TERM04) és kiszolgálónév (például WF12) alapján történő kiléptetéséhez írja be a következő parancsot:

logoff TERM04 /server:WF12

Megjegyzések

  • Abból a munkamenetből, amelybe be van jelentkezve bármikor kiléptethet felhasználót. Más munkamenetek felhasználóinak kiléptetéséhez azonban teljes hozzáférési engedéllyel kell rendelkeznie.
  • A felhasználó figyelmeztetés nélküli kiléptetése a munkamenetből adatvesztést okozhat a felhasználó munkamenetében. Az msg paranccsal figyelmeztető üzenetet kell küldeni a felhasználónak, mielőtt a kiléptetést elvégezné.
  • Ha a munkamenetre vonatkozóan nem ad meg azonosítószámot vagy nevet, akkor a logoff parancs a felhasználót az aktuális munkamenetből lépteti ki. A munkamenetnév megadásakor a munkamenetnek aktívnak kell lennie.
  • A felhasználó kiléptetésekor minden folyamat véget ér, és a munkamenet törlődik a kiszolgálóról.
  • A konzolmunkamenetből nem léptethet ki felhasználót.


Az msg parancs

Üzenetet küld egy felhasználónak.

msg {felhasználónév | munkamenetnév | munkamenet-azonosító | @fájlnév | *} [/server:kiszolgálónév] [/time:másodperc] [/v] [/w] [üzenet]

Paraméterek

felhasználónév

Az üzenetet fogadó felhasználó neve.

munkamenetnév

Az üzenetet fogadó munkamenet neve.

munkamenet-azonosító

Az üzenetet fogadó felhasználó munkamenetének azonosítószáma.

@fájlnév

Az üzenetet fogadó felhasználók és munkamenetek neveit, illetve a munkamenetek azonosítószámait tartalmazó fájl neve.

*

Az üzenetet a rendszerben található összes felhasználó számára elküldi.

/server:kiszolgálónév

Meghatározza azt a terminálkiszolgálót, amelynek a munkamenete vagy felhasználója az üzenetet fogadja. Ha nincs kiszolgáló meghatározva, akkor a parancs arra a kiszolgálóra vonatkozik, amelyre Ön pillanatnyilag be van jelentkezve.

/time:másodperc

Meghatározza az üzenet megjelenésének idejét a fogadó felhasználó képernyőjén. A megadott idő után az üzenet eltűnik. Ha nincs meghatározva időkorlát, az üzenet addig marad a felhasználó képernyőjén, amíg a felhasználó az OK gombra nem kattint.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

/w

Megerősítést vár a felhasználótól az üzenet fogadásával kapcsolatban. A felhasználó késői válaszadásából származó hosszú várakozás elkerülése érdekében használja a /time:másodperc paramétert. Hasznos lehet, ha ezt a paramétert a /v paraméterrel együtt használja.

üzenet

A küldeni kívánt üzenet szövege. Ha nem ír be üzenetet, akkor felszólítást kap az üzenet megadására, vagy a rendszer az üzenetet a szabványos bemenetről (STDIN) kísérli meg beolvasni. Ha fájlban tárolt üzenetet kíván elküldeni, akkor írja be a kisebb, mint (>) szimbólumot, utána pedig a fájlnevet.

Példák

Ha a Találkozzunk ma du. 1:00 órakor! szövegű üzenetet a MIKI nevű felhasználó minden munkamenetébe el kívánja küldeni, írja be a következő parancsot:

msg MIKI Találkozzunk ma du. 1:00 órakor!

Ha ugyanezt az üzenetet a MODEM02 nevű munkamenetbe szeretné elküldeni, írja be a következőt:

msg modem02 Találkozzunk ma du. 1:00 órakor!

Ha az előbbi üzenetet a 12-es munkamenetbe szeretné elküldeni, írja a következőt:

msg 12 Találkozzunk ma du. 1:00 órakor!

Ha az üzenetet a FELHASZNÁLÓLISTA fájlban lévő minden munkamenetbe el szeretné küldeni, akkor írja be a következőt:

msg felhasználólista Találkozzunk ma du. 1:00 órakor!

Ha minden bejelentkezett felhasználónak el kívánja küldeni az üzenetet, írja be a következőt:

msg * Találkozzunk ma du. 1:00 órakor!

Ha az üzenetet minden felhasználó számára nyugtázási határidővel (például 10 másodperc) kívánja elküldeni, írja be a következőt:

msg * /TIME:10 Találkozzunk ma du. 1:00 órakor!

Megjegyzések

  • Ha nem adja meg a felhasználó vagy a munkamenet nevét, akkor az msg parancs hibaüzenetet ír ki. Munkamenetnév megadásakor a munkamenetnek aktívnak kell lennie.
  • Üzenetküldéshez a felhasználónak üzenetküldési engedéllyel kell rendelkeznie.


A query process parancs

Megjeleníti a megadott terminálkiszolgálón futó folyamatokra vonatkozó információkat. Ezzel a paranccsal megtudható, hogy egy adott felhasználó milyen programokat futtat, és az is, hogy mely felhasználók futtatnak egy adott programot.

query process [ * | folyamatazonosító | felhasználónév | munkamenetnév | /id:nn | programnév] [/server:kiszolgálónév] [/system]

Paraméterek

*

Minden munkamenet folyamatát kilistázza.

folyamatazonosító

A lekérdezendő folyamat azonosítószáma.

felhasználónév

Annak a felhasználónak a neve, akinek a folyamatait listázni szeretné.

munkamenetnév

Annak a munkamenetnek a neve, amelynek a folyamatait listázni szeretné.

/ID:munkamenet-azonosító

Annak a munkamenetnek az azonosítója, amelynek a folyamatait listázni szeretné.

programnév

Annak a programnak a neve, amelynek a folyamatait le szeretné kérdezni. A fájlnak .exe kiterjesztésűnek kell lennie.

/server:kiszolgálónév

Meghatározza azt a terminálkiszolgálót, amelynek a folyamatait listázni szeretné. Ha nincs kiszolgáló meghatározva, a parancs arra a kiszolgálóra vonatkozik, amelyre Ön pillanatnyilag be van jelentkezve.

/system

Megjeleníti a rendszerfolyamatok aktuális információit. Ha nem akarja megjeleníteni a rendszerfolyamatokat, ne használja ezt a paramétert.

Megjegyzések

  • A rendszergazdáknak teljes hozzáférésük van a query process funkcióihoz.
  • Ha nem adja meg a felhasználónév, munkamenetnév, /ID:munkamenet-azonosító, programnév vagy * paramétereket, a query process csak az aktuális felhasználóhoz tartozó folyamatokat jeleníti meg.
  • Ha egy munkamenetet ad meg paraméterként, akkor ennek a munkamenetnek aktívnak kell lennie. A folyamat megadásakor helyettesítő karaktereket is használhat.
  • A query process parancs az alábbi információkat jeleníti meg:
    • A folyamatot futtató felhasználó
    • A folyamatot futtató munkamenet
    • A munkamenet azonosítószáma
    • A folyamat neve
    • A folyamat állapota
    • A folyamat azonosítója
  • Amikor a query process megjeleníti az információkat, az aktuális munkamenethez tartozó folyamatok előtt egy kisebb, mint (>) szimbólum jelenik meg.


A query session parancs

Megjeleníti a megadott terminálkiszolgáló munkameneteire vonatkozó információkat. A parancs nemcsak az aktív munkameneteket érinti, hanem a kiszolgáló által futatott egyéb munkameneteket is.

query session [munkamenetnév | felhasználónév | munkamenet-azonosító] [/server:kiszolgálónév] [/mode] [/flow] [/connect] [/counter]

Paraméterek

munkamenetnév

A lekérdezendő munkamenet neve.

felhasználónév

A lekérdezendő munkamenet felhasználójának a neve.

munkamenet-azonosító

A lekérdezendő munkamenet azonosítója.

/server:kiszolgálónév

Meghatározza a lekérdezendő terminálkiszolgálót. Az alapértelmezett terminálkiszolgáló az aktuális kiszolgáló.

/mode

Megjeleníti az aktuális vonalbeállításokat.

/flow

Megjeleníti az aktuális folyamatvezérlési beállításokat.

/connect

Megjeleníti az aktuális csatlakozási beállításokat.

/counter

Megjeleníti az aktuális számlálóinformációkat, beleértve a létrehozott, a leválasztott és a visszakapcsolt munkamenetek számát.

Példák

A KISZOLGÁLÓ2 nevű kiszolgáló összes aktív munkamenetére vonatkozó információk megjelenítéséhez írja be a következő parancsot:

query session /server:KISZOLGÁLÓ2

A MODEM2 nevű aktív munkamenetre vonatkozó információk megjelenítéséhez írja be a következőt:

query session MODEM02

A munkamenet lekérdezésekor például a következő információ jelenhet meg:

C:\> query session
 SESSIONNAME    USERNAME       ID   STATE     TYPE   DEVICE
>konzol         rendszergazda   0   aktív     wdcon
 rdp-tcp#1      ügyfél1         1   aktív     wdtshare
 rdp-tcp                        2   figyelés  wdtshare
                                4   üresjárat
                                5   üresjárat

A kisebb mint (>) szimbólum jelzi az aktuális munkamenetet. A SESSIONNAME a munkamenet nevét jelöli. A USERNAME a munkamenethez csatlakozott felhasználó nevét jelöli. A STATE a munkamenet aktuális állapotát jelöli. További információ a Munkamenet-állapotok című témakörben olvasható. A TYPE a munkamenet típusát jelöli. A DEVICE, amely nem áll rendelkezésre a konzol- vagy a hálózatra kapcsolódó munkameneteknél, a munkamenethez rendelt eszköz nevét jelöli. A munkamenetre vonatkozó információkat követő megjegyzés a munkamenetprofilból származik.

Azok a munkamenetek, amelyekben a kezdeti állapothoz DISABLED (letiltott) beállítás van megadva, nem jelennek meg a lekérdezési listában, amíg engedélyezve nem lesznek.

Megjegyzések

  • A felhasználó mindig lekérdezheti azt a munkamenetet, amelybe épp be van jelentkezve. Más munkamenetek lekérdezéséhez azonban a felhasználónak információlekérdezési engedélyre van szüksége.
  • Ha nem adja meg a munkamenetnév, felhasználónév vagy munkamenet-azonosító paramétereket, a query session parancs a rendszerben futó összes aktív munkamenet információit megjeleníti.
  • Amikor a query process megjeleníti az információkat, az aktuális munkamenet előtt egy kisebb, mint (>) szimbólum jelenik meg.


A query termserver parancs

Megjeleníti a hálózat terminálkiszolgálóit tartalmazó listát. A query termserver megkeresi a hálózathoz kapcsolt összes terminálkiszolgálót, és az alábbi információkat jeleníti meg:

  • A kiszolgáló neve.
  • A hálózat címe (és a csomópont címe ha a /address paraméter meg van adva).

query termserver [kiszolgálónév] [/domain:tartomány] [/address] [/continue]

Paraméterek

kiszolgálónév

A terminálkiszolgálót azonosító név.

/domain:tartomány

Meghatározza azt a tartományt, amelynek a terminálkiszolgálói lekérdezésre kerülnek. Nem szükséges megadnia a tartományt, ha azt a tartományt kívánja lekérdezni, amelyben pillanatnyilag dolgozik.

/address

Megjeleníti a kiszolgálók hálózati címét és csomópontcímét.

/continue

Kiiktatja a szünetet két képernyő megjelenítése között, miután az egyik képernyő megtelt.

Példák

A hálózat összes terminálkiszolgálójára vonatkozó információk megjelenítéséhez írja be a következő parancsot:

query termserver

A hálózat kiszolgáló3 nevű terminálkiszolgálójára vonatkozó információk megjelenítéséhez írja be a következőt:

query termserver kiszolgáló3

A RENDSZER tartomány összes terminálkiszolgálójára vonatkozó információk megjelenítéséhez írja be a következőt:

query termserver /domain:rendszer

A kiszolgáló3 nevű terminálkiszolgáló hálózati címének és a csomópontcímének megjelenítéséhez írja be a következőt:

query termserver kiszolgáló3 /address


A query user parancs

Megjeleníti a megadott terminálkiszolgálón futó felhasználói munkamenetekre vonatkozó információkat. Ezzel a paranccsal többek között megtudható, hogy egy adott felhasználó bejelentkezett-e egy adott terminálkiszolgálóra. A query user parancs az alábbi információkat jeleníti meg:

  • A felhasználó neve
  • A terminálkiszolgálón futó munkamenet neve
  • A munkamenet azonosítója
  • A munkamenet állapota (aktív vagy leválasztva)
  • Az üresjárati idő (az utolsó billentyűleütés vagy egérmozgatás óta eltelt percek száma a munkamenetben)
  • A felhasználó bejelentkezési ideje

query user [felhasználónév | munkamenetnév | munkamenet-azonosító] [/server:kiszolgálónév]

Paraméterek

felhasználónév

Meghatározza a lekérdezendő felhasználó bejelentkezési nevét.

munkamenetnév

Meghatározza a lekérdezendő munkamenet nevét.

munkamenet-azonosító

Meghatározza a lekérdezendő munkamenet azonosítóját.

/server:kiszolgálónév

Meghatározza a lekérdezendő terminálkiszolgálót. Ha nincs megadva, az aktuális terminálkiszolgáló kerül lekérdezésre.

Példák

A rendszerbe belépett összes felhasználóra vonatkozó információk megjelenítéséhez írja be a következőt:

query user

A KISZOLGÁLÓ1 nevű kiszolgálón lévő FELHASZNÁLÓ1 nevű felhasználóra vonatkozó információk megjelenítéséhez írja be a következőt:

query user FELHASZNÁLÓ1 /server:KISZOLGÁLÓ1

Megjegyzések

  • A query user parancs használatához teljes hozzáférési vagy információlekérdezési engedély szükséges.
  • Ha a query user parancsot a felhasználónév, munkamenetnév vagy munkamenet-azonosító paraméterek nélkül használja, a kiszolgálóra bejelentkezett összes felhasználóra vonatkozó információ megjelenik. A kiszolgáló összes munkamenetének megjelenítéséhez a query session parancsot is használhatja.
  • Amikor a query user parancs megjeleníti az információkat, az aktuális munkamenet előtt egy kisebb, mint (>) szimbólum jelenik meg.
  • A /server paraméter csak akkor szükséges, ha a query user parancsot távoli kiszolgálóról használja.


A register parancs

Speciális végrehajtási jellemzőkkel regisztrál egy programot.

register fájlnév [/system | /user] [/v]

Paraméterek

fájlnév

A regisztrálandó fájl neve.

/system

A fájlnevet globális rendszerforrásként regisztrálja.

/user

A fájlnevet globális felhasználói forrásként regisztrálja.

/v

További információkat jelenít meg.

Megjegyzések

  • A register parancsot csak rendszergazdák használhatják.
  • Néhány összetett alkalmazásnak és alrendszernek globális rendszerkörnyezetben kell végrehajtódnia ahhoz, hogy olyan forrásokat hozzon létre, amelyek nem csak egy bejelentkezés esetén érhetők el.
  • Egy adott program regisztrációs adatai csak a program telepítése estén válnak érvényessé. Ha a register parancsot egy már telepített programnál alkalmazza, a változások csak a program következő telepítésekor lépnek érvénybe.


A reset session parancs

Lehetővé teszi egy munkamenet alaphelyzetbe állítását (törlését) a terminálkiszolgálón.

reset session {munkamenetnév | munkamenet-azonosító} [/server:kiszolgálónév] [/v]

Paraméterek

munkamenetnév

A törölni kívánt munkamenet neve. A kívánt munkamenetnév meghatározásához használja a query session parancsot.

munkamenet-azonosító

A törölni kívánt munkamenet azonosítója.

/server:kiszolgálónév

Meghatározza a törölni kívánt munkamenetet tartalmazó terminálkiszolgálót. Ha nem adja meg a nevet, az aktuális terminálkiszolgálót veszi figyelembe a parancs.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

Megjegyzések

  • A saját munkamenet mindig törölhető, de más felhasználó munkamenetének a törléséhez teljes hozzáférési engedély szükséges.
  • A felhasználói munkamenet figyelmeztetés nélküli törlése a munkamenet adatainak elvesztését eredményezheti.
  • A munkamenetet csak akkor kell törölni, ha hibásan működik, vagy nem válaszol.
  • A /server paraméter csak akkor szükséges, ha a reset session parancsot távoli kiszolgálóról használja.


A shadow parancs

Lehetővé teszi egy másik felhasználó aktív munkamenetének távvezérlését. A munkamenetet figyelheti vagy aktívan irányíthatja is. Egy felhasználói munkamenet aktív irányítása során lehetősége van billentyűzet- és egérműveletek bevitelére is.

shadow {munkamenetnév | munkamenet-azonosító} [/server:kiszolgálónév] [/v]

Paraméterek

munkamenetnév

A távvezérelni kívánt munkamenet neve.

munkamenet-azonosító

A távvezérelni kívánt munkamenet azonosítója. A munkamenetek és azonosítóik megtekintéséhez használja a query user parancsot.

/server:kiszolgálónév

Meghatározza a távvezérelni kívánt munkamenetet tartalmazó terminálkiszolgálót. Alapértelmezés szerint az aktuális terminálkiszolgálót veszi figyelembe a parancs.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

Példák

A 93-as munkamenet árnyékozásához írja be a következő parancsot:

shadow 93

Az ACCTG01 nevű munkamenet árnyékozásához írja be a következőt:

shadow ACCTG01

Megjegyzések

  • A saját munkamenetet mindig távvezérelheti (kivéve az aktuális munkamenetet), de más munkamenetek távvezérléséhez teljes hozzáférési engedély szükséges.
  • Távvezérlést a Terminálszolgáltatások kezelője programmal is kezdeményezhet. További információ a Munkamenet távvezérlése című témakörben található.
  • Mielőtt a figyelés megkezdődik, a kiszolgáló figyelmezteti a felhasználót, hogy a munkamenetet rövidesen távvezérelni fogják, hacsak ez a figyelmeztetés nincs letiltva. A saját munkamenet néhány másodpercig lefagyottnak tűnhet, amíg a felhasználótól megérkezik a válasz. A felhasználók és a munkamenetek távvezérlési beállításait a Terminálszolgáltatás konfigurálása programmal, illetve a Helyi felhasználók és csoportok, valamint az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményével konfigurálhatja.
  • A távvezérlő munkamenetnek támogatnia kell azt a képernyőfelbontást, amelyet a távvezérelt munkamenet használ, különben a művelet meghiúsul.
  • A konzolmunkamenet nem távvezérelhető, és nem használható másik munkamenet távvezérlésre sem.
  • A távvezérlés (árnyékozás) befejezéséhez nyomja meg a CTRL+* billentyűkombinációt (a * karaktert a numerikus billentyűzeten), vagy bármilyen Ön által definiált gyorsbillentyűt. Gyorsbillentyű a Terminálszolgáltatások kezelője programmal definiálható.


A tscon parancs

Csatlakozik egy másik munkamenethez.

tscon {munkamenet-azonosító | munkamenetnév} [/server:kiszolgálónév] [/dest:munkamenetnév] [/password:jelszó] [/v]

Paraméterek

munkamenet-azonosító

Annak a munkamenetnek az azonosítója, amelyhez csatlakozni kíván. Ha a választható /dest:munkamenetnév paramétert használja, akkor ez annak a munkamenetnek az azonosítója, amelyhez csatlakozni kíván.

munkamenetnév

Annak munkamenetnek a neve, amelyhez csatlakozni kíván.

/server:kiszolgálónév

Meghatározza azt a terminálkiszolgálót, amelynek munkamenetéhez csatlakozni kíván. Alapértelmezés szerint a parancs az aktuális terminálkiszolgálóra vonatkozik.

/dest:munkamenetnév

Meghatározza az aktuális munkamenet nevét. Ez a munkamenet megszakad, amikor Ön az új munkamenethez kapcsolódik.

/password:jelszó

Annak a felhasználónak a jelszava, akinek a munkamenetéhez csatlakozni kíván. Ez a jelszó akkor szükséges, ha a csatlakozni kívánó felhasználó nem saját munkamenethez szeretne kapcsolódni.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

Példák

Ha meg kívánja szakítani az aktuális munkamenetet, és az aktuális terminálkiszolgálón futó 12-es munkamenthez kíván csatlakozni, írja be a következő parancsot:

tscon 12

Ha meg kívánja szakítani az aktuális munkamenetet, és „sajátjel” jelszóval az aktuális terminálkiszolgálón futó 23-as munkamenthez kíván csatlakozni, írja be a következőt:

tscon 23 /password:sajátjel

Ha a TERM03 nevű munkamenetet a TERM05 munkamenethez kívánja csatlakoztatni, majd csatlakozás után a TERM05 munkamenetet meg szeretné szakítani, írja be a következőt:

tscon TERM03 /v /dest:TERM05

Megjegyzések

  • Más munkamenethez történő csatlakozáshoz teljes hozzáférési vagy speciális csatlakozási engedélyre van szükség.
  • A /dest:munkamenetnév paraméter lehetővé teszi, hogy egy másik felhasználó munkamenetét egy eltérő munkamenethez csatlakoztassa.
  • Ha a jelszó paramétert nem adja meg, és a célmunkamenet nem az aktuális felhasználóhoz tartozik, akkor a tscon parancs sikertelen lesz.
  • A konzolmunkamenethez nem csatlakozhat.


A tsdiscon parancs

Leválaszt egy adott munkamenetet a terminálkiszolgálóról.

tsdiscon [munkamenet-azonosító | munkamenetnév] [/server:kiszolgálónév] [/v]

Paraméterek

munkamenet-azonosító

A leválasztandó munkamenet azonosítója.

munkamenetnév

A leválasztandó munkamenet neve.

/server:kiszolgálónév

Meghatározza a leválasztandó munkamenetet futtató terminálkiszolgálót. Ha nem ad meg nevet, a parancs az aktuális terminálkiszolgálóra fog vonatkozni.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

Példák

Az aktuális munkamenet leválasztásához írja be a következő parancsot:

tsdiscon

A 10-es munkamenet leválasztásához írja be a következőt:

tsdiscon 10

A TERM04 nevű munkamenet leválasztásához írja be a következőt:

tsdiscon TERM04

Megjegyzések

  • Más felhasználó munkamenetének leválasztásához teljes hozzáférési engedélyre van szükség.
  • Ha nem ad meg munkamenet-azonosítót vagy munkamenetnevet, a tsdiscon parancs az aktuális munkamenetet választja le.
  • A munkamenet leválasztáskor futó alkalmazások újracsatlakozáskor adatvesztés nélkül, automatikusan tovább futnak. A leválasztott munkamenet futó alkalmazásainak bezárásához használja a reset session parancsot, de vegye figyelembe, hogy ez a munkamenetben adatvesztést eredményezhet.
  • A /server paraméter csak akkor szükséges, ha a tsdiscon parancsot távoli kiszolgálóról használja.
  • A konzolmunkamenet nem választható le.


A tskill parancs

Bezár egy folyamatot.

tskill {folyamatazonosító | folyamatnév} [/server:kiszolgálónév] [/id:munkamenet-azonosító | /a] [/v]

Paraméterek

folyamatazonosító

A bezárandó folyamat azonosítója.

folyamatnév

A bezárandó folyamat neve. A paraméter megadásakor helyettesítő karaktereket is használhat.

/server:kiszolgálónév

Meghatározza a bezárandó folyamatot futtató terminálkiszolgálót. Ha nem ad meg nevet, a parancs az aktuális terminálkiszolgálóra fog vonatkozni.

/id:munkamenet-azonosító

A megadott munkamenetben zárja be a futó folyamatot.

/a

Minden munkamenetben bezárja a futó folyamatot.

/v

Megjeleníti a végrehajtás alatt álló műveletekre vonatkozó információkat.

Megjegyzések

  • A tskill parancs csak saját folyamatok bezárására használható, kivéve ha Ön rendszergazda. A rendszergazdának teljes hozzáférése van a tskill minden funkciójához, és más felhasználók munkameneteinek folyamatait is bezárhatják.
  • Ha egy munkamenetben minden futó folyamatot leállít, maga a munkamenet is véget ér.


A tsprof parancs

Az egyik felhasználótól átmásolja egy másik felhasználóhoz a felhasználói konfigurációval kapcsolatos információkat (amelyek a Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményében jelennek meg). A tsprof paranccsal a felhasználói profil útvonala is beállítható.

tsprof /update {/domain:tartománynév | /local} /profile:profil_elérési_útja felhasználónév

tsprof /copy {/domain:tartománynév | /local}[/profile:profil_elérési_útja] forrásfelhasználó célfelhasználó

tsprof /q {/domain:tartománynév | /local} felhasználónév

Paraméterek

felhasználónév

Annak a felhasználónak a neve, akire vonatkozóan frissíteni vagy lekérdezni szeretné a kiszolgálóprofil elérési útját.

forrásfelhasználó

Annak a felhasználónak a neve, akitől a felhasználói konfigurációs adatokat át szeretné másolni.

célfelhasználó

Annak a felhasználónak a neve, akihez a felhasználói konfigurációs adatokat át szeretné másolni.

/domain:tartománynév

Annak a tartománynak a neve, amelyben a művelet történik.

/local

A műveletet csak a helyi felhasználói fiókokra vonatkozóan végzi el.

/profile:profil_elérési_útja

A profil elérési útja, ahogyan a Helyi felhasználók és csoportok, illetve az Active Directory - felhasználók és számítógépek beépülő modulok Terminálszolgáltatások bővítményében megjelenik.

/update

A tartománynév tartományban lévő felhasználónévhez tartozó profil elérési útjának adatait a megadott profil_elérési_útján található adatokkal frissíti.

/copy

A felhasználói konfigurációs adatokat a forrásfelhasználótól a célfelhasználóhoz másolja át, és a célfelhasználó profiljának elérési útját a megadott profil_elérési_útjára módosítja. Mind a forrásfelhasználónak, mind pedig a célfelhasználónak helyi, vagy a tartománynév tartományban lévő felhasználónak kell lennie.

/q

Megjeleníti annak a felhasználónak a profiljához tartozó elérési utat, akire vonatkozóan a kiszolgálóprofil elérési útját le kívánja kérdezni.

Biztonsági korlátozások

A tsprof parancsot csak rendszergazdák futtathatják.


A tsshutdn parancs

Lehetővé teszi a rendszergazda számára, hogy távvezérléssel leállítson vagy újraindítson egy terminálkiszolgálót. A kiszolgáló áramellátása is megszüntethető, ha a számítógép támogatja a váltóáram szoftveres vezérlését.

tsshutdn [várakozási_idő] [/server:kiszolgálónév] [/reboot] [/powerdown] [/delay:leállításkésleltetés] [/v]

Paraméterek

várakozási_idő

Meghatároz egy várakozási időtartamot (másodpercben), amelynek – a felhasználó értesítésétől számított – lejártát követően a felhasználókat kijelentkezteti a munkameneteikből. Az alapértelmezett érték 60 másodperc.

/server:kiszolgálónév

Meghatározza a leállítandó terminálkiszolgálót. Ha nem ad meg nevet, a parancs az aktuális terminálkiszolgálót állítja le.

/reboot

A felhasználói munkamenetek befejezése után újraindítja a terminálkiszolgálót.

/powerdown

Kikapcsolja a terminálkiszolgálót, ha a számítógép támogatja a váltóáram szoftveres vezérlését.

/delay:kilépéskésleltetése

Meghatároz egy várakozási időtartamot, amelynek – a felhasználók munkamenetekből történő kiléptetésétől számított – lejártát követően minden folyamatot bezár és leállítja a terminálkiszolgálót. Az alapértelmezett érték 30 másodperc.

/v

Megjeleníti a végrehajtás alatt álló műveletekkel kapcsolatos információkat.

Megjegyzések

  • A tsshutdn parancsot csak rendszergazdák futtathatják.
  • A Start menü Leállítás parancsának használata nem ajánlott terminálkiszolgálók leállításához. Ez a művelet ugyanis nem értesíti a felhasználókat munkameneteik bezárása előtt.
  • Minden csatlakozott munkamenet értesítést kap, hogy a rendszer hamarosan leállítja. A nyitott fájlokat tartalmazó alkalmazások munkamenetei felszólítják a felhasználót a fájlok mentésére. A kilépés parancs kiadása után a tsshutdn parancs vár egy meghatározott ideig (az alapérték a /delay parancs szerint 30 másodperc), mielőtt minden folyamatot bezár.
  • A tsshutdn nem indítja újra a terminálkiszolgálót, hacsak a /reboot paraméter nincs megadva.


Hibaelhárítás

Mi a probléma?

A kapcsolat nem jelentkezik be automatikusan a kiszolgálóra. Csatlakozáskor felszólítást kapok a felhasználói név és a jelszó megadására.

Ok: A Windows 2000 titkosítására szolgáló bővítmények miatt a Windows NT 4.0 verzión futó Terminálszolgáltatások ügyfele program nem ismeri fel a felhasználói nevet és a jelszót a kapcsolatfájl automatikus bejelentkezési részében.

Megoldás: A Windows NT 4.0 Client Connection Manager (Ügyfélkapcsolat kezelője) ablakában kattintson jobb gombbal a kívánt csatlakozásra, majd kattintson a Properties (Tulajdonságok) parancsra. A General (Általános) lapon jelölje be az Automatic logon (Automatikus bejelentkezés) jelölőnégyzetet, majd adja meg a felhasználónevet, a jelszót és a tartományt.

Lásd még: A bejelentkezési információ módosítása.

Az .msi csomag nem telepíthető távoli Terminálszolgáltatások munkamenetből.

Ok: Ahhoz, hogy távoli munkamenetből a terminálszolgáltatásokhoz .msi csomagokat telepíthessen rendszergazdai jogosultságok szükségesek.

Megoldás: A konzolból a Vezérlőpulton található Programok telepítése/törlése paranccsal telepítse az .msi csomagot.

Lásd még: Program telepítése a Programok telepítése/törlése eszközzel.

A telepített program nem működik megfelelően.

Ok: A program a terminálszolgáltatások alkalmazáskiszolgálói üzemmódban való engedélyezése előtt került telepítésre.

Megoldás: Távolítsa el a programot, majd telepítse újra a Programok telepítése/törlése eszközzel vagy a change user paranccsal.

Lásd még: A telepítés indítása.

Ok: A program a change user /install parancs helyett a change user /execute paranccsal került telepítésre.

Megoldás: Távolítsa el a programot, majd telepítse újra a Programok telepítése/törlése eszközzel vagy a change user /install paranccsal.

Lásd még: A telepítés indítása.

Ok: Hiba történt a programkompatibilitási parancsfájlok futása közben.

Megoldás: Futtassa újra a program parancsfájljait.

Lásd még: Programok kompatibilitása.