Telnet

A Telnet ügyfél a Telnet Server programok lehetővé teszik távoli számítógépek elérését a felhasználók számára.

A Telnet ügyfél segítségével a felhasználók csatlakozhatnak egy távoli számítógéphez, és egy terminálablakon keresztül kommunikálhatnak vele.

A Telnet Server a Telnet ügyfél felhasználói számára lehetővé teszi, hogy bejelentkezzenek a Telnet Server szolgáltatást futtató számítógépbe és szöveges alkalmazásokat futtassanak. A Telnet Server átjáróként működik, melyen keresztül a Telnet-ügyfelek kommunikálhatnak egymással. A Windows 2000 operációs rendszerhez tartozó Telnet Server szolgáltatás maximum két Telnet-ügyfelet támogat egy időben. Ha további licencekre van szüksége, használja a Telnet Server azon verzióját, mely a Microsoft Windows Services for UNIX bővítőcsomagban található.

  • A Telnet ügyfélről további tudnivalók a következő témakörben találhatók: Telnet ügyfél.
  • A Telnet Server szolgáltatásról további tudnivalók a következő témakörben találhatók: Telnet Server.


Telnet ügyfél

A Windows 2000 Telnet ügyfél program lehetővé teszi a Telnet Server szolgáltatást futtató távoli számítógéphez való csatlakozást. Ha létrejött a kapcsolat, kommunikálhat a Telnet kiszolgálóval. A végrehajtandó munkamenet típusa attól függ, hogyan van konfigurálva a Telnet szoftver. A Telnet jellemző használati területei: kommunikáció, játékok, rendszerfelügyelet és helyi bejelentkezési szimulációk.

  • A konkrét feladatokról az Útmutató című témakörben olvashat bővebben.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Telnet ügyfél – áttekintés.


Útmutató

  • A Telnet Server elindítása parancssorból
  • Kilépés a Telnetből


A Telnet elindítása a parancssorból

  1. Nyissa meg a Parancssor ablakot.
  2. Írja be a parancssorba a következő parancsot:

    telnet [állomás_neve port_száma]

Megjegyzések

  • Parancssor megnyitásához kattintson a Start menüre, mutasson a Programok majd a Kellékek pontra, végül a Parancssor elemre.
  • A portszám megadása csak akkor szükséges, ha eltér a Telnet alapértelmezett portszámától.
  • Az állomás_neve megadása nem kötelező. Állomásnév hiányában a Telnet indítás után nem csatlakozik automatikusan a kiszolgálóhoz.


Kilépés a Telnet programból

  • A Microsoft Telnet> parancssorába írja be a következő parancsot:
    quit

Kapcsolódó témakörök


Telnet ügyfélprogram – áttekintés

A Windows 2000 Telnet ügyfélprogram távoli számítógéphez hálózaton keresztül történő kapcsolódásához a TCP/IP-protokollcsalád Telnet protokollját használja. A Telnet ügyfélprogrammal a számítógép távoli kiszolgálóhoz csatlakoztatható. A Windows 2000 Telnet ügyfélprogram segítségével a távoli számítógéphez történő csatlakozáshoz előbb be kell jelentkeznie a távoli számítógépre, majd úgy dolgozhat a távoli számítógépen, mintha közvetlenül előtte ülne.

A Windows Telnet ügyfélprogram korábbi verzióit használó felhasználók néhány változást fedezhetnek fel a Windows 2000 operációs rendszerben található programverzióban. A legfeltűnőbb változás, hogy a Telnet ügyfélprogram mostantól parancssori alkalmazás, és nem Windows alkalmazás. Parancssori alkalmazásként a Telnet ügyfélprogram nagyon ismerős lesz a UNIX alapú Telnet ügyfélprogramot használóknak.

A Windows 2000 Telnet ügyfélprogram egyik legfontosabb új funkciója az NTLM-hitelesítés használatának támogatása. E funkció révén a Windows 2000 Telnet ügyfélprogram NTLM-hitelesítésen keresztül jelentkezhet be a Windows 2000 Telnet kiszolgálóra.

Megjegyzések

  • Az NTLM-hitelesítés Windows 2000 rendszerben történő használatával kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Server súgóját.
  • A Windows 2000 Telnet ügyfélprogramban a Telnet munkamenetek nem naplózhatók.


Telnet Server

A Telnet Server szolgáltatás lehetővé teszi, hogy a Telnet ügyfél program felhasználói csatlakozzanak a számítógépéhez és úgy használjanak rajta parancssori alkalmazásokat, mintha előtte ülnének.

  • A konkrét feladatokról az Útmutató című témakörben olvashat bővebben.
  • Az általános tudnivalókat a Fogalmak című témakörben találja meg.
  • A problémák elhárításával kapcsolatos tennivalókat a Hibaelhárítás című témakörben találja.


Útmutató

  • A Telnet Server elindítása és leállítása
  • A Telnet Server beállításainak módosítása parancssorból


A Telnet Server elindítása és leállítása

  • A Telnet Server elindítása
  • A Telnet Server elindítása parancssorból
  • A Telnet Server leállítása
  • A Telnet Server leállítása parancssorból


A Telnet Server elindítása

  1. Nyissa meg a Számítógép-kezelés ablakot.
  2. Kattintson a konzolfa Szolgáltatások elemére.

    Helye:

    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A jobb oldali ablaktáblában kattintson jobb gombbal a Telnet elemre, majd az Indítás parancsra.

Megjegyzés

  • A Számítógép-kezelés ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson a Számítógép-kezelés parancsra.


A Telnet Server elindítása parancssorból

  1. Nyissa meg a parancssort.
  2. Írja be a net start tlntsvr parancsot, és nyomja meg az ENTER billentyűt.

Megjegyzés

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.


A Telnet Server leállítása

  1. Nyissa meg a Számítógép-kezelés ablakot.
  2. Kattintson a konzolfa Szolgáltatások elemére.

    Helye:

    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A jobb oldali ablaktáblán kattintson jobb gombbal a Telnet, majd a Leállítás parancsra.

Megjegyzés

  • A Számítógép-kezelés ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson a Számítógép-kezelés parancsra.


A Telnet Server leállítása parancssorból

  1. Nyissa meg a parancssort.
  2. Írja be:
    net stop tlntsvr

Megjegyzés

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.


A Telnet Server beállításainak módosítása parancssorból

  • Nyissa meg a Telnet felügyeleti segédprogramot.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról.

Megjegyzések

  • A Telnet kiszolgálói felügyeleti segédprogram megnyitásához kattintson a Start menü Futtatás parancsára, írja be a tlntadmn.exe parancsot, és kattintson az OK gombra.
  • Ha nem tudja megnyitni a Telnet kiszolgálói felügyeleti segédprogramot, valószínűleg telepítenie kell a Felügyeleti eszközök csomagot.
  • A Telnet kiszolgálói felügyeleti segédprogram használatához a Rendszergazdák csoport tagjaként kell bejelentkeznie.
  • A változtatások csak akkor létnek életbe, ha leállítja és újraindítja a Telnet Server szolgáltatást.

Kapcsolódó témakörök


Fogalmak

A rész tartalma:

  • A Telnet Server használata
  • Telnet Server kapcsolat licencelése


A Telnet Server használata

A Windows 2000 Telnet Server lehetővé teszi a Telnet-ügyfelek számára, hogy azok kiszolgálóhoz csatlakozzanak, abba bejelentkezzenek és szöveges alkalmazásokat futtassanak. A Telnet Server átjáróként működik, melyen keresztül a Telnet-ügyfelek kommunikálhatnak egymással. A Telnet-kiszolgáló egyszerre legfeljebb 63 Telnet-ügyfelet támogat.

A rész tartalma:

  • Telnet hitelesítés
  • Telnet kiszolgálói felügyeleti segédprogram


Telnet hitelesítés

A Telnet kiszolgáló eléréséhez használhatja a helyi Windows 2000 felhasználónevét és jelszavát vagy tartományfiók-adatait. A biztonsági rendszer a Windows 2000 biztonságba van integrálva. Ha nem használja az NTLM-hitelesítési beállítást, a felhasználónevet és a jelszót a rendszer egyszerű szöveg formájában küldi el a Telnet kiszolgálónak.

Ha használja az NTLM-hitelesítést, az ügyfél a Windows 2000 adatvédelmi környezetet használja hitelesítésre, és a felhasználótól a rendszer nem kéri be a felhasználónevet és a jelszót. A felhasználónév és a jelszó titkosított.

Megjegyzés

  • Ha A felhasználónak a következő bejelentkezéskor meg kell változtatnia a jelszavát beállítás meg van adva egy felhasználó számára, akkor NTLM-hitelesítés használatakor a Telnet rendszerbe való bejelentkezés sikertelen lesz. A felhasználónak ebben az esetben először közvetlenül a kiszolgálóba kell bejelentkeznie, majd a jelszavának megváltoztatása után jelentkezhet be a Telnet rendszeren keresztül.


A Telnet kiszolgálói felügyeleti segédprogram

A Telnet kiszolgálói felügyeleti segédprogram segítségével elindíthatja vagy leállíthatja a Telnet Server szolgáltatást, illetve tájékoztatást kaphat róla. Használatával hozzájuthat a jelenlegi felhasználók listájához, bezárhat egy felhasználói munkamenetet vagy megváltoztathatja a Telnet Server beállításait a rendszerleíró adatbázisban.

A következő táblázat a Telnet kiszolgálói felügyeleti segédprogram beállításairól nyújt áttekintést.

Beállítás | Név | Leírás
0 | Kilépés az alkalmazásból | Befejezi a Telnet segédprogram munkamenetét.
1 | Jelenlegi felhasználók listázása | Kilistázza a jelenlegi felhasználók felhasználónevét, tartományát, távoli számítógépét, munkamenet-azonosítóját, valamint a felhasználók bejelentkezésének idejét.
2 | Felhasználói munkamenet megszakítása | Bezárja a kiválasztott felhasználói munkamenetet.
3 | A rendszerleíró adatbázis beállításainak megjelenítése/módosítása | Megjeleníti a rendszerleíró adatbázis beállításait, és lehetőséget nyújt azok megváltoztatására. Tekintse meg az alábbi táblázatot.
4 | A szolgáltatás indítása | Elindítja a Telnet Server szolgáltatást.
5 | A szolgáltatás leállítása | Leállítja a Telnet Server szolgáltatást.
A következő táblázat a Telnet Server azon beállításait tekinti át, amelyek a rendszerleíró adatbázisban módosíthatók.
Beállítás | Név | Leírás és a megengedett értékek | Alapértelmezett érték
0 | Kilépés a menüből | Kilép a menüből, és visszatér a Telnet kiszolgálói felügyeleti segédprogram eredeti beállításaihoz. | -
1 | AllowTrustedDomain | 0: Nem engedélyezi a tartományi felhasználók elérését (csak a helyi felhasználókét). 1: Engedélyezi a meghatalmazotti kapcsolattal rendelkező tartományok felhasználóinak elérését. | 1
2 | AltKeyMapping | Engedélyezi az ALT billentyű funkcióit (csak VT100 esetén működik). 0: A Ctrl-A billentyűkombinációt a rendszer alapértelmezés szerint kezeli. 1: A Ctrl-A billentyűkombinációt a rendszer Alt billentyűként kezeli. | 1
3 | DefaultDomain | A Defaultdomain érték bármely tartomány lehet, mely meghatalmazotti kapcsolattal rendelkezik a számítógéppel. Ha az AllowTrustedDomain értéke 1, és a helyi tartományt kívánja alapértelmezettként megadni, adja meg a "." értéket. | Null
4 | DefaultShell | Megmutatja, hová van telepítve a parancsértelmező program. | %rendszergyökér%\System32\Cmd.exe /q /k
5 | LogonScript | Megjeleníti a Telnet Server bejelentkezési parancsfájljának helyét. A rendszergazda beállíthatja úgy a bejelentkezési parancsfájlt, hogy minden felhasználó esetén meghatározott műveleteket hajtson végre. | %rendszergyökér%\System32\login.cmd
6 | MaxFailedLogins | Megjeleníti, hogy a kapcsolat hány sikertelen bejelentkezés után szakad meg. | 3
7 | NTLM | Hitelesítési beállítások. 0: Nem használ NTLM-hitelesítést. Akkor hasznos, ha más operációs rendszerekről, vagy rendszerekre csatlakozik. 1: Az NTLM-hitelesítést próbálja először használni. Ha ez sikertelen, a felhasználónevet és jelszót használja. Akkor hasznos, ha Windows NT vagy Windows 2000 rendszert, és más operációs rendszert futtató számítógépek között kíván kapcsolatot létesíteni. 2: Csak NTLM-hitelesítést használ. Windows NT és Windows 2000 rendszert futtató számítógépek közötti kapcsolat létrehozásakor használható. | 2
8 | TelnetPort | Megjeleníti azt a portot, melyen a telnetkiszolgáló a telnet-kérelmeket figyeli. | 23

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról.

Megjegyzések

  • Amikor megváltoztatja az alapértelmezett tartományfiókot, a beállítás csak a Telnet Server újraindítása után lép életbe.
  • A Telnet kiszolgálói felügyeleti segédprogram használatához a Rendszergazdák csoport tagjaként kell bejelentkeznie.

Kapcsolódó témakörök


Telnet Server kapcsolat licencelése

A Windows 2000 Server rendszer telepítése után két Telnet Server kapcsolat licence biztosított. Ez azt jelenti, hogy a Telnet Serverhez egyszerre két Telnet-ügyfél csatlakozhat. Ha további licencekre van szüksége, használja a Telnet Server azon verzióját, mely a Microsoft Windows Services for UNIX bővítőcsomagban található.


Hibaelhárítás

Mi a probléma?

Hiba: Érvénytelen bemenet.

Ok: A megadott érték nem elfogadható.

Megoldás: Tekintse át a választható értékeket, és adjon meg új értéket.

Hiba: Nem sikerült megnyitni a rendszerleíró kulcsot.

Ok: A rendszerleíró kulcs megnyitásához a Telnet Server szolgáltatásnak futnia kell. Ez a hiba azt jelzi, hogy a Telnet Server szolgáltatás jelenleg nem fut.

Megoldás: Indítsa el a Telnet Server szolgáltatást.

Hiba: Nem sikerült lekérdezni a rendszerleíró kulcs értékét.

Ok: A rendszerleíró kulcs értékének lekérdezéséhez a Telnet Server szolgáltatásnak futnia kell. Ez a hiba azt jelzi, hogy a Telnet Server szolgáltatás jelenleg nem fut.

Megoldás: Indítsa el a Telnet Server szolgáltatást.

Hiba: Az NTLM-hitelesítés sikertelen, mert nincs elég hitelesítő adat.

Ok: A felhasználó tiszta szöveges hitelesítés használatával próbál egy másik számítógéphez csatlakozni, mely csak NTLM-hitelesítést fogad el.

Megoldás: Tekintse át az NTLM választható értékeit és adjon új értéket.