Feladatkezelő – áttekintés

A Feladatkezelő a számítógépen futó programok és folyamatok adatait jeleníti meg. A folyamatok leggyakrabban használt teljesítményjellemzőit is megjeleníti.

A Feladatkezelő segítségével figyelhetők a számítógép teljesítményét jellemző fő mutatók. Gyorsan megtekinthető a futó programok állapota, és leállíthatók azok a programok, amelyek nem válaszolnak. A futó folyamatok tevékenységének kiértékelését 15 paraméter segíti, a CPU és a memória kihasználtságát pedig diagramok és adatok mutatják.

További tudnivalókért kattintson a következő hivatkozások egyikére:

Futó programok

Az Alkalmazások lapon a számítógépen futó programok állapota jelenik meg.

Ezen a lapon leállíthatók vagy elindíthatók a programok, és átválthat másik programra.

Kapcsolódó témakörök

Futó folyamatok

A Folyamatok lapon a számítógépen futó folyamatok adatai jelennek meg.

Például adatok jeleníthetők meg a CPU és a memória kihasználtságáról, a laphibákról, a leírók számáról és számos más paraméterről.

Kapcsolódó témakörök

A teljesítmény mérőszámai

A Teljesítmény lap a számítógép teljesítményének dinamikus megjelenítését biztosítja a következők segítségével:

  • A CPU és a memória kihasználtságát ábrázoló diagramokkal.
  • A leírókkal, szálakkal és a számítógépen futó folyamatokkal kapcsolatos összesítésekkel.
  • A fizikai, kernel és a lefoglalt memória teljes mérete bájtokban történő megjelenítésével.

A Teljesítmény lappal kapcsolatos további tudnivalókat a Windows 2000 Professional Resource Kit csomag részét képező Windows 2000 Professional Resource Guide útmutató tartalmaz.

Kapcsolódó témakörök


Program leállítása a Feladatkezelő segítségével

  1. Az Alkalmazások lapon kattintson a leállítani kívánt feladatra.
  2. Kattintson a Feladat befejezése gombra.

Megjegyzések

  • Ha egy program nem válaszol, a CTRL+ALT+DELETE billentyűkombináció megnyomásával indítsa el a Feladatkezelőt, kattintson az Alkalmazások fülre, kattintson arra a programra, amely nem válaszol, majd a Feladat befejezése gombra.
  • A programba beírt minden olyan adat, illetve végrehajtott módosítás elveszik, amelyet nem mentett.


Folyamat leállítása a Feladatkezelő segítségével

  1. Kattintson a Folyamatok lapra, majd a befejezni kívánt folyamatra.
  2. Kattintson a Folyamat leállítása parancsra.

Fontos

  • A folyamat leállításakor óvatosan járjon el. Az alkalmazás leállításakor a nem mentett adatok elvesznek. Rendszerszolgáltatás leállítása esetén előfordulhat, hogy a rendszer egyes részei nem működnek megfelelően.

Megjegyzés

  • A folyamattal együtt leállítható az általa közvetlenül vagy közvetetten létrehozott valamennyi folyamat is.

    A Folyamat lapon a jobb oldali egérgombbal kattintson a leállítani kívánt folyamatra, majd kattintson a Folyamatstruktúra leállítása parancsra.

    Például az Outlook 98-hoz hasonló elektronikus levelezőprogram folyamatstruktúrájának leállításakor a rendszer leállítja a kapcsolódó folyamatokat (például a mapisp32.exe programot és a MAPI-sorkezelőt) is.


Átváltás másik programra

  1. Az Alkalmazások lapon kattintson arra a programra, amelyre át kíván váltani.
  2. Kattintson az Átváltás gombra.

Megjegyzés

  • A Feladatkezelő megnyitásához a jobb oldali egérgombbal kattintson a Tálca üres területére, majd kattintson a Feladatkezelő parancsra.


Új program indítása

  1. Az Alkalmazások lapon kattintson az Új feladat gombra.
  2. A Megnyitás mezőbe írja be a kívánt program elérési útvonalát és nevét, majd kattintson az OK gombra.

Megjegyzés

  • Az Új feladat gomb megegyezik a Start menü Futtatás parancsával.


A számítógép teljesítményének figyelése a Feladatkezelő segítségével

  • Kattintson a Teljesítmény fülre.

Megjegyzés

  • A Feladatkezelő megnyitásához a jobb oldali egérgombbal kattintson a Tálca üres területére, majd kattintson a Feladatkezelő parancsra.


További folyamatszámlálók megjelenítése

  1. A Folyamatok lapon kattintson a Nézet menü Oszlopok kiválasztása parancsára.
  2. Kattintson az oszlopfejlécként megjeleníteni kívánt elemekre, majd az OK gombra.

Megjegyzés

  • A folyamatszámlálókkal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


A folyamatok listájának rendezése

  • A Folyamatok lapon kattintson arra az oszlopfejlécre, amely alapján rendezni kíván.

Megjegyzés

  • A rendezési sorrend megfordításához kattintson még egyszer az oszlopfejlécre.


A Feladatkezelő megjelenítési beállításainak módosítása

  1. Kattintson a módosítani kívánt megjelenítési beállításhoz tartozó fülre:
    • Az Alkalmazások lap tartalmának megjelenítéséhez választható a részletes, nagy ikonok vagy a kis ikonok megjelenítési mód.
    • A Folyamatok lapon kiválaszthatók a megjeleníteni kívánt oszlopok.
    • A Teljesítmény lapon módosítható a CPU előzmények diagram, és megjeleníthetők a kernelidők.
  2. A Nézet menüben kattintson a kívánt beállításra.

Megjegyzés

  • A Feladatkezelő megnyitásához a jobb oldali egérgombbal kattintson a Tálca üres területére, majd kattintson a Feladatkezelő parancsra.
  • A Kernelidők mutatása beállítás kiválasztása esetén piros vonal jelenik meg a CPU-használat és a CPU-használat visszamenőleg diagramon. A piros vonal jelöli a kernelműveletek által igénybe vett CPU-erőforrások mennyiségét.


A Feladatkezelő adatainak frissítése

  • Kattintson a Nézet menü Frissítés most parancsára.

Megjegyzések

  • Az adatok automatikus frissítési gyakoriságának megváltoztatásához kattintson a Nézet menü Frissítés parancsára, majd a kívánt beállításra.
  • A Feladatkezelő által megjelenített adatok frissítésének ideiglenes felfüggesztéséhez kattintson a Nézet menü Frissítés pontjára, majd a Felfüggesztve parancsra.


Futó program prioritásának módosítása

  1. A Folyamatok lapon a jobb oldali egérgombbal kattintson a módosítani kívánt programra.
  2. Mutasson a Prioritás beállítása pontra, majd kattintson a kívánt beállításra.

Megjegyzések

  • A futó programok prioritásának megjelenítéséhez kattintson a Folyamatok fülre, kattintson a Nézet menü Oszlopok kiválasztása parancsára, jelölje be az Alapprioritás jelölőnégyzetet, majd kattintson az OK gombra.
  • A folyamat prioritásásának módosításával növelhető vagy csökkenthető a futási sebesség (attól függően, hogy a prioritása nőtt vagy csökkent), de ez hátrányosan is befolyásolhatja a többi folyamat teljesítményét.


Folyamat hozzárendelése a processzorhoz

  1. A Folyamatok lapon a jobb oldali egérgombbal kattintson arra a folyamatra, amelyiket a processzorhoz kívánja rendelni.
  2. Kattintson az Affinitás beállítása parancsra, majd egy vagy több processzorra.

Megjegyzések

  • Az Affinitás beállítása parancs csak többprocesszoros számítógépeken használható.
  • Az Affinitás beállítása parancs végrehajtása esetén a program vagy folyamat végrehajtását a rendszer a kiválasztott processzorokra korlátozza, és ezáltal csökkenhet a rendszer teljesítménye.


Folyamatszámlálók

A Feladatkezelő párbeszédpanel Folyamatok lapján a következő, oszlopfejlécként megjeleníthető számlálók segítségével megfigyelhetők a futó folyamatok.

  • Alapprioritás
  • CPU-idő
  • CPU-használat
  • GDI-objektumok
  • Leírók száma
  • Programkód neve
  • Egyéb I/O
  • I/O – egyéb bájtok száma
  • I/O olvasások
  • I/O – olvasott bájtok száma
  • I/O írások
  • I/O – írott bájtok száma
  • Memórihasználat
  • Memóriahasználat változása
  • Nem lapozható készlet
  • Laphibák
  • Laphibaszám változása
  • Lapozható készlet
  • Memóriahasználat csúcsértéke
  • PID (Folyamatazonosító)
  • Munkamenet-azonosító
  • Szálak száma
  • Felhasználónév
  • USER-objektumok
  • Virtuális memória mérete


A Feladatkezelő elindítása

  • A jobb oldali egérgombbal kattintson a Tálca üres részére, majd a Feladatkezelő parancsra.

Megjegyzések

  • A Feladatkezelő a CTRL+ALT+DELETE billentyűkombináció megnyomása után a Feladatkezelő gombra kattintással is elindítható.
  • A Feladatkezelő a CTRL+SHIFT+ESC billentyűkombináció megnyomásával is elindítható.