SNMP

Az Egyszerű hálózatkezelési protokoll (SNMP) lehetőséget biztosít az állapotinformációk megfigyelésére és átvitelére több állomás között.

  • Az SNMP telepítése előtt tanulmányozza a Feladatlista: Az SNMP szolgáltatás üzembe állítása című témakört.
  • A Windows 2000 rendszerbe átkerült szolgáltatások megismeréséhez olvassa el az Ismerős feladatok elvégzésének új lehetőségei című témakört.
  • Ha egy adott feladattal kapcsolatban van szüksége segítségre, tanulmányozza az Útmutatót.
  • A háttérinformációkkal kapcsolatos további tudnivalókért tanulmányozza a Fogalmak című témakört.
  • Ha az SNMP használatával kapcsolatban van szüksége tanácsokra, nézze át a Gyakorlati tanácsok című témakört.
  • Problémamegoldással kapcsolatos tudnivalókért tanulmányozza a Hibaelhárítás című témakört.


Feladatlista: Az SNMP szolgáltatás üzembe állítása

Lépés | Hivatkozás
SNMP-kezelőszoftver beszerzése, telepítése és konfigurálása. | Az SNMP szolgáltatás
Az SNMP üzembe állításához szükséges információk összegyűjtése a hálózaton. Szükséges információk: kapcsolattartók (rendszergazda), a számítógép fizikai elhelyezkedése, beállított SNMP logikai csoportok neve, valamint a hálózaton található SNMP-kezelőrendszerek számítógépneve, IP- vagy IPX-címe. | Az SNMP használata
Az SNMP telepítése a számítógépre. | Az SNMP szolgáltatás telepítése
Az SNMP-ügynök tulajdonságainak beállítása. | Az ügynök tulajdonságainak beállítása
Ha más TCP/IP-szolgáltatás is található a hálózaton, például egy híd vagy egy útválasztó, a további konfigurálási információkkal kapcsolatban tanulmányozza az RFC 1213 szabványt a továbblépés előtt. | SNMP-szabványok (RFC-szabványok)
Trap célok konfigurálása. | Trapek konfigurálása
SNMP biztonsági tulajdonságok beállítása. | A biztonság beállítása


Ismerős feladatok elvégzésének új lehetőségei

Az alábbi táblázatban az SNMP protokollal kapcsolatban használt általános feladatok láthatók. Az ezen feladatok végrehajtásához használt felhasználói kezelőfelület különbözik a Windows 2000 és a Windows NT 4.0 rendszerben.

Teendő: | Windows NT 4.0 esetén ezt használja: | Windows 2000 esetén ezt használja:
SNMP szolgáltatás telepítése. | Windows NT TCP/IP Telepítési beállítások, SNMP-szolgáltatás. | Vezérlőpult, Programok hozzáadása segédprogram. További tudnivalókért tanulmányozza Az SNMP szolgáltatás telepítése című témakört.
SNMP-ügynök konfigurálása. | Vezérlőpult, Hálózat segédprogram, Szolgáltatások lap. | Számítógép-kezelő konzol, Szolgáltatások elem. További tudnivalókért tanulmányozza az Ügynök tulajdonságainak beállítása című témakört.
SNMP-trapek konfigurálása. | Vezérlőpult, Hálózat segédprogram, Szolgáltatások lap. | Számítógép-kezelő konzol, Szolgáltatások elem. További tudnivalókért tanulmányozza a Trapek beállítása című témakört.
SNMP-biztonság beállítása. | Vezérlőpult, Hálózat segédprogram, Szolgáltatások lap. | Számítógép-kezelő konzol, Szolgáltatások elem. További tudnivalókért tanulmányozza A biztonság beállítása című témakört.


Gyakorlati tanácsok

A Windows 2000 operációs rendszer SNMP szolgáltatása nagyban leegyszerűsíti a hálózatkezelést. Ennek legjobb kihasználása érdekében:

  • Próbálja az SNMP-közösségeket funkcionális szerveződés alapján rendezni, a Windows 2000 elosztott biztonsági modelljét követve.
  • Használja ki az SNMP biztonsági ellenőrző funkcióját: állítson be hitelesítési trapet minden SNMP-ügynökön.
  • Ha szolgáltatási összetevőket szeretne megfigyelni, például a DHCP protokollt vagy a WINS szolgáltatást, ellenőrizze, hogy ezeket a szolgáltatásokat sikeresen telepítette-e, és azok be vannak-e állítva.


Útmutató...

  • Az SNMP-szolgáltatás telepítése
  • Az ügynök tulajdonságainak beállítása
  • Trapek beállítása
  • A biztonság beállítása
  • Az SNMP szolgáltatás elindítása és leállítása
  • Esemény beállítása a trapfordítóhoz


Az SNMP szolgáltatás telepítése

  1. Nyissa meg a Windows-összetevők varázslót.
  2. Az Összetevők csoportban kattintson a Kezelő és figyelő eszközök elemre (a jelölőnégyzet bejelölése vagy törlése nélkül), majd kattintson a Részletek gombra.
  3. Jelölje be az Egyszerű hálózatkezelési protokoll jelölőnégyzetet, majd kattintson az OK gombra.
  4. Kattintson a Tovább gombra.

Megjegyzések

  • A Windows-összetevők varázsló megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/eltávolítása ikonra, végül kattintson a Windows-összetevők hozzáadása/eltávolítása ikonra.
  • Egyes Windows összetevőket használat előtt be kell állítani. Ha telepített ilyen összetevőt, de nem állította be, és a Windows összetevők hozzáadása/eltávolítása elemre kattint, a beállítandó összetevők megjelennek. A Windows-összetevők varázsló indításához kattintson az Összetevők ikonra.
  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • Telepítés után az SNMP automatikusan elindul.

Kapcsolódó témakörök


Az ügynök tulajdonságainak beállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a Szolgáltatások elemre.

    Helye:

    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A részletek ablaktáblán kattintson az SNMP szolgáltatás elemre.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. Az Ügynök lapon levő Kapcsolattartó mezőbe írja be a számítógép rendszergazdájának vagy felhasználójának a nevét.
  6. A Hely mezőbe írja be a számítógép vagy a kapcsolattartó fizikai helyét.
  7. A Szolgáltatás csoportban válassza ki a megfelelő jelölőnégyzeteket, majd kattintson az OK gombra.

    Ha meg szeretné nézni a párbeszédpanel valamely elemének a leírását, kattintson az elemre a jobb oldali egérgombbal, majd válassza ki a Mi ez? parancsot.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, majd a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd a Számítógép-kezelés ikonra.
  • Ha létező SNMP-beállításokat módosít, a módosítások azonnal érvénybe lépnek. Ha az SNMP szolgáltatást most állítja be először, a beállítások érvénybe lépéséhez újra kell indítani az SNMP szolgáltatást.

Kapcsolódó témakörök


Trapek beállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a Szolgáltatások elemre.

    Helye:

    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A részletek ablaktáblán kattintson az SNMP szolgáltatás elemre.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Trapek lapon a Logikai csoport neve mezőbe írja be annak a logikai csoportnak a nevét (kis- és nagybetűk különbözőek), amelynek a számítógép trap üzeneteket fog küldeni, majd kattintson a Hozzáadás a listához gombra.
  6. A Trap céljai részen kattintson a Hozzáadás gombra.
  7. Az Állomásnév, IP- vagy IPX-cím mezőbe írja be az állomás adatait, majd kattintson a Hozzáadás gombra.
  8. Ismételje az 5-7. lépéseket addig, amíg az összes szükséges logikai csoportot és trap célt hozzá nem adta.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, majd a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd a Számítógép-kezelés ikonra.
  • Ha létező SNMP-beállításokat módosít, a módosítások azonnal érvénybe lépnek. Az SNMP szolgáltatást nem kell újraindítani ahhoz, hogy a módosítások érvénybe lépjenek.

Kapcsolódó témakörök


A biztonság beállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a Szolgáltatások elemre.

    Helye:

    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A részletek ablaktáblán kattintson az SNMP szolgáltatás elemre.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Biztonság lapon jelölje be a Hitelesítési trap küldése jelölőnégyzetet, ha trap üzenetet szeretne küldeni minden sikertelen hitelesítéskor.
  6. Az Elfogadott logikai csoportok nevei csoportban kattintson a Hozzáadás gombra.
  7. A Logikai csoport engedélyei csoportban válassza ki a kiválasztott logikai csoportból érkező SNMP-kérések feldolgozására vonatkozó engedélyszintet.

    Ha meg szeretné nézni a párbeszédpanel valamely elemének a leírását, kattintson az elemre a jobb oldali egérgombbal, majd válassza ki a Mi ez? parancsot.

  8. A Logikai csoport neve mezőbe írja be a logikai csoport nevét (kis- és nagybetűk különbözőek), majd kattintson a Hozzáadás gombra.
  9. Az SNMP szolgáltatás tulajdonságai csopotban adja meg, hogy az állomástól el lehet-e fogadni SNMP-csomagokat:
    • Ha a hálózat minden állomásától fogadni kívánja az SNMP-kéréseket, kattintson az SNMP-csomagok elfogadása bármely állomástól elemre.
    • Az SNMP-csomagok elfogadásának korlátozásához kattintson az SNMP csomagok elfogadása a következő állomásoktól elemre, kattintson a Hozzáadás gombra, írja be a megfelelő állomásnevet, IP- vagy IPX-címet, majd kattintson újból a Hozzáadás gombra.

Fontos

  • Ha az összes logikai csoport nevét eltávolítja a listából, még az alapértelmezett Nyilvános elemet is, az SNMP nem fog válaszolni egyetlen logikai csoportnak sem.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, majd a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd a Számítógép-kezelés ikonra.
  • Szükség esetén hozzáadható további logikai csoportok és állomások neve.
  • Bármelyik bejegyzést módosíthatja, ha a bejegyzésre, majd a Szerkesztés gombra kattint. A kiválasztott bejegyzés az Eltávolítás gombra kattintással törölhető.
  • Ha létező SNMP-beállításokat módosít, a módosítások azonnal érvénybe lépnek. Az SNMP szolgáltatást nem kell újraindítani ahhoz, hogy a módosítások érvénybe lépjenek.

Kapcsolódó témakörök


Az SNMP szolgáltatás elindítása és leállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a Szolgáltatások elemre.

    Helye:

    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A részletek ablaktáblán kattintson az SNMP szolgáltatás elemre.
  4. Kattintson a Művelet menü Indítás, Leállítás vagy Újraindítás parancsára.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, majd a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd a Számítógép-kezelés ikonra.
  • Új SNMP-bővítmény hozzáadásakor a módosítások érvénybe lépéséhez nem kell újraindítani az SNMP szolgáltatást.

Kapcsolódó témakörök


Esemény-trap fordító beállítása

  1. Nyissa meg a Parancssor ablakot.
  2. A parancssorba írja be az evntcmd /? parancsot az Evntcmd parancssori eszköz szintaxisának és beállításainak megtekintéséhez.

Megjegyzés

  • A Parancssor ablak megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Parancssor parancsra.

Kapcsolódó témakörök


Fogalmak

A témakör tartalma:

  • SNMP – áttekintés
  • Az SNMP ismertetése
  • Az SNMP használata
  • Forrásmunkák


SNMP – áttekintés

  • Az SNMP definíciója
  • Az SNMP szolgáltatás


Az SNMP definíciója

Az Egyszerű hálózatkezelési protokoll (SNMP) a TCP/IP-hálózatokon (újabban az IPX-hálózatokon is) széles körben használt hálózatkezelési szabvány.

Az SNMP modell

Az SNMP protokoll lehetőséget biztosít a hálózati állomások (például munkaállomások, kiszolgáló-számítógépek, útválasztók, hidak, hubok) olyan központi számítógépről történő kezelésére, amelyen hálózatkezelő szoftver fut. Az SNMP a kezelőszolgáltatásokat a kezelőrendszerek és ügynökök elosztott architectúrájának segítségével hajtja végre.

Mivel a hálózatkezelés nagyon fontos mind a naplózáshoz, mind az erőforrás-kezeléshez, az SNMP a következőkre használható:

  • Távoli eszközök konfigurálása. A konfigurációs információkat minden hálózatba kötött állomásnak el lehet küldeni a kezelőrendszerről.
  • Hálózati teljesítmény figyelése. Követhető a feldolgozási és hálózati átvitel, valamint információ gyűjthető az adatátvitelek sikerességéről.
  • Hálózati hibák és nem megfelelő hozzáférések érzékelése. Beállíthatók hálózati eszközökre vonatkozó eseményindító-riasztások, amelyek adott események megtörténtekor lépnek működésbe. Amikor egy riasztás elindul, az eszköz egy eseményüzenetet küld a kezelőrendszernek. A riasztások általános típusai: eszköz leállítása majd újraindítása, útválasztón érzékelt vonalhiba, nem megfelelő hozzáférés.
  • Hálózathasználat naplózása. A hálózathasználat figyelésével azonosítható a felhasználók és a csoportok hozzáférése, valamint a hálózati eszközök és szolgáltatások használatának típusai. Ezen információk segítségével a felhasználók közvetlenül elszámoltathatók, valamint kiszámíthatók a jelenlegi és a tervezett hálózati költségek.


Az SNMP-szolgáltatás

Az SNMP-szolgáltatás a TCP/IP és az IPX protokollokat használó számítógépeket támogatja. Ez egy kiegészítő szolgáltatás, amit a TCP/IP protokoll sikeres konfigurálása után lehet telepíteni.

Az SNMP-szolgáltatás egy SNMP-ügynököt biztosít, amely lehetővé teszi a következő rendszereket futtató számítógépek távoli, központosított kezelését:

  • Windows 2000 Server
  • Windows 2000 Professional
  • Windows 2000 alapú WINS
  • Windows 2000 alapú DHCP
  • Windows 2000 alapú Internet Information Services
  • LAN Manager

Az SNMP-ügynökszolgáltatás által küldött információk eléréséhez legalább egy SNMP-kezelőrendszer alkalmazásra van szükség. Az SNMP szolgáltatás támogatja, de jelenleg nem tartalmaz SNMP-kezelőszoftvert. Az SNMP-kezelőszoftvernek a kezelőrendszerként működő állomáson kell futnia. Az SNMP-kezelőszoftverekkel és alkalmazásokkal kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Resource Kit kiadványt.


Az SNMP ismertetése

  • SNMP-kezelőrendszerek és -ügynökök
  • Az SNMP működése
  • SNMP-üzenetek


SNMP-kezelőrendszerek és -ügynökök

Az SNMP használatához két összetevőre van szükség:

Kezelőrendszerek és ügynökök
  • SNMP-kezelőrendszer.

    A kezelőkonzolnak is nevezett kezelőrendszer információkat és frissítési kéréseket küld egy SNMP-ügynöknek. Minden számítógép, amelyen SNMP-kezelőszoftver fut, SNMP-kezelőrendszer. A kezelőszoftvernek nem kell ugyanazon az állomáson futnia, mint az SNMP-ügynöknek.

    Az SNMP-kezelőrendszer információt kér a kezelt számítógéptől (SNMP-ügynöktől), például lekérheti a rendelkezésre álló lemezterület nagyságát vagy az aktív munkamenetek számát. A kezelőrendszer az ügynök konfigurációjának módosítását is kezdeményezheti. Ez azonban nagyon ritka, mivel a legtöbb ügynök felé csak olvasható hozzáféréssel rendelkezik.

  • SNMP-ügynök.

    • Az SNMP-ügynök válaszol az információt kérő kezelőrendszernek. Minden számítógép, amelyen SNMP-ügynökszoftver fut, SNMP-ügynök. A Windows 2000 SNMP szolgáltatása, amely egy ügynökszoftver, válaszol a kezelőrendszer(ek) felől érkező kérésekre. Az SNMP-szolgáltatásban beállítható, hogy mely adatok küldhetők el, és mely kezelőrendszerek jogosultak az információkérésre.

    Általában az ügynökök nem küldenek üzeneteket, csak válaszolnak azokra. A trap üzenet az egyetlen, ügynök által kezdeményezett SNMP-kommunikációtípus. A trap egy ügynökre vonatkozó, riasztást kiváltó esemény (például rendszer-újraindítás vagy illegális hozzáférés), amely jobb biztonságot nyújt.

    A kezelőállomások és az ügynökök egy SNMP logikai csoporthoz tartoznak, amely az állomások adminisztrációs célból történő csoportosítása. Logikai csoportok létrehozásával nő a biztonság, mivel csak az egyazon logikai csoporton belüli kezelőrendszerek és ügynökök kommunikálhatnak egymással.


Az SNMP működése

Mind az ügynökök, mind a kezelőrendszerek SNMP-üzeneteket használnak az állomásinformációk figyelésére és továbbítására. Az SNMP-üzenetek a User Datagram Protocol (UDP) segítségével kerülnek elküldésre. Az Internet Protocol (IP) segítségével történik az üzenetek útvonalának kiválasztása a kezelőrendszer és az állomás között.

A kezelőrendszer által kért információt a kezelési információbázis (management information base, MIB) tartalmazza. A MIB-adatbázis tartalmazza a hálózati számítógépek különféle adatait, például a számítógépen futó hálózati szoftver verzióját és a rendelkezésre álló merevlemez-terület méretét.

A következő példa azt mutatja, hogy az SNMP-ügynök hogyan válaszol az információt kérő kezelőrendszernek:

Az SNMP-modell
  1. A kezelőrendszer (A állomás) egy SNMP-datagramot küld az ügynöknek (B állomás) az ügynök állomásnevének, IP-címének vagy IPX-címének felhasználásával.
  2. Az SNMP-ügynök megkapja a datagramot és ellenőrzi a logikai csoport nevét, amelyhez a kezelőrendszer tartozik. Amennyiben érvényes logikai csoport neve, az ügynök a megfelelő SNMP-alügynöktől beolvassa a kért adatot. Ha a logikai csoport neve érvénytelen, az ügynök “hitelesítési hiba” trapet küld a beállított trap céloknak (a C és D állomásnak).
  3. Az SNMP-ügynök visszaküldi a kért információt tartalmazó datagramot a kezelőrendszernek.

Az SNMP-üzenettípusokkal és a MIB-adatbázissal kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Resource Kit kiadványt.


SNMP-üzenetek

Amikor egy SNMP-kezelőprogram kérést küld egy hálózati eszköz felé, az eszközön futó ügynökszoftver fogadja a kérést, és kiolvassa az információt a MIB-adatbázisból. Ezután az ügynök elküldi a kért információt a kérelmező SNMP-kezelőprogramnak. A műveletek végrehajtásához az ügynök a következő üzeneteket használja:

SNMP-üzenet | Leírás
Get | Az alapvető SNMP kérési üzenet. Ezt az üzenetet egy SNMP-kezelőrendszer küldi, mellyel információt kér egy SNMP-ügynök egy MIB-bejegyzéséről. Például lekérhető a szabad lemezterület nagysága.
Get-next | Kiterjesztett kérési üzenet, amely a kezelőobjektumok teljes fájának tallózásához használható. Egy adott objektumra vonatkozó Get-next kérés végrehajtása során az ügynök annak az objektumnak az azonosítóját és értékét küldi vissza, amely logikailag követi a kért objektumot. A Get-next kérés dinamikus táblák, például belső IP-útválasztási táblák esetén hasznos.
Set | Ha az írási hozzáférés engedélyezett, ennek az üzenetnek a segítségével lehet elküldeni az ügynöknek egy frissített MIB-értéket.
Getbulk | Aziránti kérelem, hogy a gazdaügynök által elküldött adatok mérete a lehető legnagyobb legyen, az üzenetméret megengedett korlátai között. Ezzel a nagy mennyiségű kezelőinformációk kiolvasásához szükséges protokollcserék száma minimumra csökkenthető. A maximális üzenetméret nem lehet nagyobb, mint a legnagyobb átviteli egység (a hálózaton megengedett legnagyobb keretméret), különben az üzenetek széttöredezésére lehet szükség.
Trap | Egy SNMP-ügynök által egy SNMP-kezelőrendszernek akkor küldött üzenet, amikor az ügynök érzékeli, hogy a kezelt gazdagépen adott típusú helyi esemény történt. A trap üzenetet fogadó SNMP-kezelőkonzol neve: trap cél. Például trap üzenetet lehet küldeni rendszer-újraindítási esemény esetén.


Az SNMP használata

  • A logikai csoport meghatározása
  • Az ügynök tulajdonságai
  • A trap tulajdonságai
  • Az SNMP biztonsági tulajdonságai
  • Az SNMP szolgáltatás tulajdonságai


A logikai csoportok meghatározása

Az állomások csoportjait hozzá lehet rendelni SNMP logikai csoportokhoz az ügynökök és kezelőrendszerek korlátozott biztonsági ellenőrzése érdekében, vagy adminisztrációs célokból. A logikai csoportok a hozzájuk rendelt név alapján azonosíthatók. Egy állomás egyszerre több logikai csoporthoz is tartozhat, de egy ügynök nem fogad el kérelmet olyan kezelőrendszertől, amely nem szerepel az elfogadható logikai csoportok neveinek listáján.

A logikai csoportokat logikusan érdemes meghatározni, hogy ki lehessen használni az SNMP által biztosított alapszintű hitelesítési szolgáltatást. A következő példában két logikai csoport szerepel: Nyilvános és Nyilvános 2.

Logikai csoportok
  • Az 1. ügynök trapeket és más üzeneteket küldhet a 2. kezelőnek, mert mindkettő a Nyilvános 2 logikai csoport tagja.
  • A 2-4. ügynökök trapeket és más üzeneteket küldhetnek az 1. kezelőnek, mert alapértelmezés szerint mindegyik a Nyilvános 1 logikai csoport tagja.

A logikai csoportok neve az SNMP biztonsági tulajdonságok beállításával kezelhető.

Megjegyzés

  • Nincs kapcsolat a logikai csoportok neve és a tartomány- vagy munkacsoportnevek között. A logikai csoportok neve hálózati állomások csoportjainak megosztott jelszavát jelenti, melyet ugyanúgy kell kiválasztani és módosítani, mint bármely más jelszót. Azt, hogy mely állomások tartozzanak egy logikai csoportba, általában fizikai közelségük dönti el.


Az ügynök tulajdonságai

Az SNMP-ügynök olyan tevékenységekről küld információkat a hozzá tartozó kezelőrendszernek, amelyek az Internet Protocol (IP) hálózati rétegben történnek.

Az SNMP szolgáltatás ügynökinformációkat küld válaszként egy SNMP-kérelemre vagy egy SNMP-trap üzenetben.

Az ügynök következő tulajdonságait állíthatja be az SNMP-szolgáltatás tulajdonságai párbeszédpanel Ügynök lapján:

Ügynökszolgáltatás | A következő esetekben használandó:
Fizikai | A számítógép fizikai eszközöket, például merevlemez-partíciókat kezel.
Alkalmazások | Olyan alkalmazások használata esetén, amelyek a TCP/IP protokollon keresztül küldenek adatokat. Ezt a szolgáltatást mindig engedélyezni kell.
Adatkapcsolat és alhálózat | A számítógép hidat kezel.
Internet | A számítógép IP-átjáró (útválasztó).
Végpontok közötti | A számítógép IP-állomás. Ezt a szolgáltatást mindig engedélyezni kell.

Az ügynök tulajdonságait is beállíthatja, például a következőket:

  • A kapcsolattartó személyt, például a hálózati rendszergazda nevét.

  • A kapcsolattartó személy tartózkodási helyét.

Az SNMP-ügynöktulajdonságok konfigurálásával kapcsolatos további tudnivalókért tanulmányozza Az ügynök tulajdonságainak beállítása című részt.


A trap tulajdonságai

Az SNMP-trapek korlátozott biztonsági ellenőrzésre használhatók. Ha egy ügynöknél be van állítva, az SNMP szolgáltatás adott események megtörténtekor trap üzeneteket készít. Ezeket az üzeneteket egy trap célnak küldi el. Például egy ügynök beállítható úgy, hogy egy hitelesítési trapet kezdeményezzen, ha egy ismeretlen kezelőrendszer kér információt. Trap üzenet létrehozható például állomás indítása vagy leállítása esemény bekövetkezésekor is.

A trap cél a kezelőrendszer számítógépnevét, illetve IP- vagy IPX-címét tartalmazza. A trap célnak egy hálózatba kötött számítógépnek kell lennie, amelyen SNMP-kezelőszoftver fut. A trap célokat beállíthatja a felhasználó, de a trap üzeneteket eredményező események (például a rendszer újraindítása) az SNMP-ügynökben vannak beállítva.

A trap célok az SNMP szolgáltatás tulajdonságai panel Trapek lapján állíthatók be.

Az SNMP-trapek konfigurálásával kapcsolatos további tudnivalókért tanulmányozza a Trapek beállítása című témakört.


Az SNMP biztonsági tulajdonságai

Az SNMP protokoll logikai csoportok és a hitelesítési trapek segítségével nyújt védelmet. Korlátozhatja az ügynök SNMP-kommunikációját, hogy az csak adott SNMP-kezelőrendszerekkel kommunikálhasson.

Az SNMP biztonsági beállítások a Biztonság lap SNMP szolgáltatás tulajdonságai csoportjában állíthatók be.

A következők állíthatók be az SNMP biztonság engedélyezéséhez:

  • Elfogadott logikai csoportok neve. A szolgáltatáshoz legalább egy alapértelmezett logikai csoport nevét meg kell adni. A Nyilvános elem annak az általános logikai csoportnak a neve, amelyet minden SNMP-rendszer elfogad. Több logikai csoport neve is felvehető a listára, valamint törölhető vagy módosítható az alapértelmezett logikai csoport neve. Az itt megadott logikai csoportok neve a trap célokban kerülnek felhasználásra. Ha egy olyan logikai csoporttól érkezik SNMP-kérés, amely nem szerepel a listán, az hitelesítési trapet fog okozni.

    • Vigyázat!

    • Ha az összes logikai csoport nevét eltávolítja a listából, még a Nyilvános elemet is, az SNMP nem fog válaszolni egyetlen logikai csoportnak sem.
  • Jogok. Hozzáférési szint kiválasztásával megadható, hogy az SNMP-ügynök hogyan hajtsa végre az egyes logikai csoportoktól érkező kéréseket. Be lehet állítani például olyan hozzáférési szintet, hogy az SNMP-ügynök ne hajthasson végre egy adott logikai csoportból érkező egyetlen kérést sem.
  • SNMP-csomagok elfogadása bármely állomástól. Ebben az esetben a forrásállomás és az elfogadható állomások listája az SNMP-kezelőrendszert és az elfogadható kezelőrendszerek listáját jelenti. Egyetlen SNMP-csomag sem lesz visszautasítva a forrásállomás neve vagy címe, illetve az elfogadható állomások listája alapján. Ez az alapértelmezett beállítás.
  • SNMP-csomagok elfogadása a következő állomásoktól. Ebben az esetben az elfogadható állomások listája az elfogadható SNMP-kezelőrendszereket jelenti. Ha ezt a lehetőséget választja, csak a listán szereplő állomásoktól érkező SNMP-csomagok lesznek elfogadva. Ellenkező esetben a rendszer visszautasítja az SNMP-üzenetet, és elküld egy hitelesítési trapet. Ez a beállítás nagyobb biztonságot nyújt, mint a logikai csoport nevének használata, mert egy logikai csoport sok állomásból állhat.
  • Hitelesítési trap küldése. A hitelesítés során a rendszer ellenőrzi, hogy az állomás neve és címe érvényes-e. Ha az SNMP-ügynök olyan kérést kap, amely nem tartalmazza a megfelelő logikai csoport nevét, vagy nem az elfogadható állomások listáján szereplő egyik állomás küldte, az ügynök egy hitelesítési trap üzenetet küld egy vagy több trap cél (kezelőrendszer) felé, ezzel jelezve a sikertelen hitelesítést. Ez az alapértelmezett beállítás.

Az SNMP biztonság konfigurálásával kapcsolatos további tudnivalókért tanulmányozza A biztonság beállítása című témakört.


Az SNMP szolgáltatás tulajdonságai

Az SNMP szolgáltatás tulajdonságai panel Általános, Bejelentkezés és Helyreállítás lapjai használhatók annak meghatározására, hogy az SNMP-szolgáltatás hogyan induljon el, hogyan jelentkezzen be a rendszerbe és hogyan állítsa helyre magát, ha a szolgáltatás vagy az operációs rendszer nem várt módon állt le.

A tulajdonságok módosításával kapcsolatos további tudnivalókért tanulmányozza a Szolgáltatások témakört.


Forrásmunkák

  • Az SNMP szabvány
  • SNMP szabványok (RFC szabványok)
  • Frissített technikai információ


Az SNMP szabvány

Nagy igény mutatkozott egy olyan platformra, amely hatékony hálózatkezelést biztosít TCP/IP alapú heterogén hálózatok számára. Ennek hatására 1988-ban kidolgozták az SNMP protokollt, amelyet az Internet Activities Board (IAB) 1990-ben elfogadott Internet-szabványként.

A Windows 2000 operációs rendszer az SNMP protokoll 1-es és 2C verzióit valósítja meg. Ezek a verziók olyan ipari szabványokon alapulnak, amelyek meghatározzák a hálózatkezelési információk struktúráját, tárolási módját, valamit az ügynökök és a kezelőrendszerek közötti kommunikáció módját TCP/IP alapú hálózatokon.

Az SNMP szabvány a következő, RFC-nek megfelelő konstrukciókat tartalmazza:

  • A Management Information Base II (MIB II) az RFC 1213 definíciója szerint a kezelhető objektumok olyan csoportja, amely a hálózat TCP/IP-összetevőiről különféle információkat tartalmaz, például a hálózati illesztők listáját, az útválasztási táblázatot és a TCP-kapcsolatok táblázatát. A Windows 2000 SNMP szolgáltatása a következőket támogatja: Host Resources MIB (RFC 1514), LAN Manager MIB II, DHCP MIB, WINS MIB, Internet Information Services MIB. Mások is készíthetnek olyan MIB-adatbázisokat, melyek együttműködnek a Windows 2000 SNMP szolgáltatásával. A MIB-objektumokkal kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Resource Kit kiadványt.
  • A Structure for Management Information (SMI) egy külön Internet RFC (RFC 1902) szabvány, amely leírja a MIB-adatokra való hivatkozás és a MIB-adatok tárolásának objektumszintaxisát.
  • Az SNMP protokoll az RFC 1157 definíciója szerint egy olyan szabvány, amely az SNMP protokollt használni képes eszközök közti kommunikáció módját és a megengedett üzenettípusokat határozza meg.


SNMP szabványok (RFC szabványok)

A Requests for Comments (RFC-k) az internetes közösség által használt jelentések, protokolljavaslatok és protokollszabványok fejlődő gyűjteménye. Az egyszerű hálózatkezelési protokoll (Simple Network Management Protocol, SNMP) leírását az Internet Engineering Task Force (IETF) és más munkacsoportok által kiadott RFC-k tartalmazzák.

Az alábbi RFC-k határozzák meg a fő SNMP szabványokat:

RFC | Leírás
1155 | A kezelési információk azonosítása és felépítése TCP/IP alapú hálózatokon (Structure and Identification of Management Information for TCP/IP-based Internets)
1157 | SNMP protokoll
1213 | Információbázis a TCP/IP alapú hálózatok kezeléséhez (Management Information Base for Network Management of TCP/IP-based internets): MIB-II

Az RFC-kkel és az azok beszerzésével kapcsolatos további tudnivalókért tanulmányozza a TCP/IP szabványok (RFC-k) című témakört.

Megjegyzések

  • Ha többet szeretne tudni az SNMP-vel kapcsolatos legfrissebb RFC-kről, látogassa meg az Active IETF Working Groups webhelyet. (http://www.ietf.org/html.charters/wg-dir.html#Operations_and_Management_Area)


További információ a Technikai tanácsadó szolgálattól

Frissített technikai információ

A Microsoft Technikai tanácsadó szolgálat további tájékoztatást nyújt az SNMP-ről. Lásd: Frissített technikai információ.


Hibaelhárítás

Hibaelhárítás – SNMP szolgáltatás

Mi a probléma?

Az SNMP-ügyfél nem működik.

Ok: Ismeretlen hálózati vagy SNMP-probléma.

Megoldás: Az SNMP-hibák megtalálhatók az Eseménynaplóban. Nézze meg az Eseménynaplót, ha arra gyanakszik, hogy az SNMP szolgáltatással van probléma. Beállíthat egy Nézet szűrőt, hogy csak az SNMP-üzenetek jelenjenek meg.

Lásd még: Az Eseménynapló használata.

Az SNMP-kezelőrendszer időtúllépést okoz a WINS-kiszolgáló lekérdezése közben.

Ok: Az SNMP időtúllépési érték túl alacsony.

Megoldás: Az SNMP-kezelőrendszeren növelje meg az SNMP időtúllépési értéket.

3-as hibakódú hiba történik a számítógép újraindítása során, ha annak IPX-címe trap célként van beállítva.

Ok: Ez akkor fordul elő, ha az IPX-cím hibás, a hálózati szám és a Media Access Control (MAC) cím vesszővel vagy kötőjellel van elválasztva. Például más SNMP-kezelőszoftver elfogadhatja a következő formában megadott címet: 00008022,0002C0-F7AABD. A Windows 2000 SNMP-szolgáltatása azonban nem ismeri fel a címet, ha a hálózati szám és a MAC-cím között vessző vagy kötőjel van.

Megoldás: Az IPX trap célként megadott címben a hálózati számnak és a MAC-címnek a 8.12 formátumot kell követnie. Például a következő formátum érvényes, ha xxxxxxxx a hálózati szám és yyyyyyyyyyyy a MAC-cím:

xxxxxxxx.yyyyyyyyyyyy