A biztonsági beállításokkal kapcsolatos feladatok automatizálása

A Secedit.exe parancssori alkalmazás. Kötegfájlból vagy automatikus feladatütemezőből történő végrehajtásakor automatikusan hozhatók létre és alkalmazhatók a sablonok, valamint elemezhető a rendszer biztonsága. A parancssorból dinamikusan is futtatható.

Különösen akkor hasznos, ha több számítógépen munkaidőn kívül kell elemezni vagy beállítani a biztonságot.

  • A Secedit.exe parancssori segédeszközzel végrehajtható biztonsági feladatokkal kapcsolatos tudnivalókért tanulmányozza az Útmutató című témakört.

A Biztonsági sablonok létrehozásával kapcsolatos további tudnivalókért tanulmányozza a Biztonsági sablonok című témakört.

A biztonsági beállításokkal és elemzéssel kapcsolatos további tudnivalókért tanulmányozza a Biztonsági konfiguráció és analízis című témakört.


Útmutató

  • A rendszerbiztonság elemzése
  • A rendszerbiztonság beállítása
  • Biztonsági beállítások frissítése
  • Biztonsági beállítások exportálása
  • Biztonsági beállításokat tároló fájl érvényesítése


A rendszerbiztonság elemzése

secedit /analyze

Ez a parancs a rendszer biztonságát elemzi.

Szintaxis:

secedit /analyze [/DB fájl_neve ] [/CFG fájl_neve ] [/log napló_elérési_útvonala] [/verbose] [/quiet]

Paraméterek

/DB fájl_neve
Itt adható meg az eltárolt beállításokat tartalmazó adatbázis elérési útvonala. Ezekkel a beállításokkal hasonlítja össze az elemezés az aktuális beállításokat. Kötelező paraméter. Ha a fájl_neve új adatbázist jelöl, akkor a CFG fájl_neve paramétert is meg kell adni.
/CFG fájl_neve
Ez a paraméter csak a /DB paraméterrel együtt érvényes. Ez az elemzés céljából az adatbázisba importálandó biztonsági sablon útvonala. Ha ez a paraméter hiányzik, az elemzés az adatbázisban jelenleg tárolt beállításokkal hajtja végre az összehasonlítást.
/log napló_elérési_útvonala
Itt adható meg a feldolgozás során használt napló elérési útvonala. Ha nincs megadva, az alapértelmezett fájlt használja a parancs.
/verbose
Elemzés közben részletesebb adatokat jelenít meg az elemzés állapotáról.
/quiet
Letiltja a képernyő- és naplókimenetet. Az elemzés eredménye a Biztonsági beállítás és analízis beépülő modullal tekinthető meg.

Kapcsolódó témakörök


A rendszerbiztonság beállítása

secedit /configure

Ez a parancs egy korábban eltárolt sablon alapján beállítja a rendszer biztonságát.

Szintaxis:

secedit /configure [/DB fájl_neve ] [/CFG fájl_neve ] [/overwrite][/areas terület1 terület2...] [/log napló_elérési_útvonala] [/verbose] [/quiet]

Paraméterek

/DB fájl_neve
Itt adható meg az alkalmazni kívánt biztonsági sablont tartalmazó adatbázis elérési útvonala. Kötelező paraméter.
/CFG fájl_neve
Ez a paraméter csak a /DB paraméterrel együtt érvényes. Ez az adatbázisba beimportálni, és a rendszerre alkalmazni kívánt biztonsági sablon elérési útvonala. Ha ez a paraméter hiányzik, az adatbázisban tárolt sablont alkalmazza a parancs.
/overwrite
Ez a paraméter csak a /CFG paraméterrel együtt érvényes. Itt adható meg, hogy a /CFG paraméternél megadott biztonsági sablont a rendszer ne hozzáfűzze, hanem a sablonnal felülírja az adatbázisban tárolt sablont vagy összevont sablont. Ha ez a paraméter hiányzik, a /CFG paraméternél megadott sablont a parancs hozzáfűzi az eltárolt sablonhoz.
/areas terület1 terület2...
Itt adhatók meg a rendszerre alkalmazni kívánt biztonsági területek. Az alapértelmezett érték az „összes terület”. Az egyes területeket szóközzel kell elválasztani.
Terület neve | Leírás
SECURITYPOLICY | Helyi házirend és a rendszer tartományi házirendje, amely tartalmazza például a fiókházirendet, a naplózási házirendet stb.
GROUP_MGMT | Korlátozott csoportbeállítások a biztonsági sablonban megadott bármely csoport részére
USER_RIGHTS | Felhasználói bejelentkezési engedélyek és a jogok megadása
REGKEYS | A helyi rendszerleíró kulcsok biztonsága
FILESTORE | A helyi fájltárolás biztonsága
SERVICES | Az összes megadott szolgáltatás biztonsága
/log napló_elérési_útvonala
A feldolgozás naplójának útvonala. Ha hiányzik, az alapértelmezett naplót használja a parancs.
/verbose
Részletesebb állapotadatokat jelenít meg.
/quiet
Letiltja a képernyő- és naplókimenetet.


Biztonsági beállítások frissítése

secedit /refreshpolicy

A parancs a csoportházirend-objektumra a biztonsági beállítások újbóli alkalmazásával frissíti a rendszer biztonsági beállításait.

Szintaxis:

secedit /refreshpolicy {machine_policy | user_policy}[/enforce]

Paraméterek

machine_policy
Frissíti a helyi számítógép biztonsági beállításait.
user_policy
Frissíti a számítógépre bejelentkezett felhasználó helyi felhasználói fiókjának biztonsági beállításait.
/enforce
Frissíti a biztonsági beállításokat, még akkor is, ha nem volt változás a csoportházirend-objektum beállításaiban.


Biztonsági beállítások exportálása

secedit /export

A parancs a biztonsági adatbázisban tárolt sablont exportálja ki egy biztonságisablon-fájlba.

Szintaxis:

secedit /export [/mergedPolicy] [/DB fájl_neve ] [/CFG fájl_neve ] [/areas terület1 terület2...] [/log napló_elérési_útvonala] [/verbose] [/quiet]

Paraméterek

/MergedPolicy
Összefűzi és kiexportálja a tartományi és helyi házirendek biztonsági beállításait.
/DB fájl_neve
Itt adható meg az exportálni kívánt sablont tartalmazó adatbázis elérési útvonala. Ha nem adja meg az adatbázist, a rendszerházirend-adatbázist használja a parancs.
/CFG fájl_neve
Annak a fájlnak a neve és elérési útvonala, amelybe menteni kívánja a sablont.
/areas terület1 terület2...
Itt adhatók meg a sablonba exportálni kívánt biztonsági területek. Az alapértelmezett érték az „összes terület”. Az egyes területeket szóközzel kell elválasztani.
Terület neve | Leírás
SECURITYPOLICY | Helyi házirend és a rendszer tartományi házirendje, amely tartalmazza például a fiókházirendet, a naplózási házirendet stb.
GROUP_MGMT | Korlátozott csoportbeállítások a biztonsági sablonban megadott bármely csoport részére
USER_RIGHTS | Felhasználói bejelentkezési engedélyek és a jogok megadása
REGKEYS | A helyi rendszerleíró kulcsok biztonsága
FILESTORE | A helyi fájltárolás biztonsága
SERVICES | Az összes megadott szolgáltatás biztonsága
/log napló_elérési_útvonala
A feldolgozás naplójának útvonala. Ha hiányzik, az alapértelmezett naplót használja a parancs.
/verbose
Részletesebb állapotadatokat jelenít meg.
/quiet
Letiltja a képernyő- és naplókimenetet.


Biztonsági beállításokat tároló fájl érvényesítése

secedit /validate

A parancs annak a biztonsági sablonnak a szintaxisát érvényesíti, amelyet elemzés, vagy a sablon a rendszerre való alkalmazása miatt az adatbázisba kíván importálni.

Szintaxis:

secedit /validate fájl_neve

Paraméterek

fájl_neve
A Biztonsági sablonok beépülő modullal készített biztonsági sablon fájlneve.