Távtelepítési szolgáltatás

A távtelepítési szolgáltatás a Windows 2000 Server operációs rendszer olyan választható összetevője, amely segítségével új ügyfélszámítógépeket telepíthet anélkül, hogy azokat ténylegesen a helyszínen konfigurálná.

  • A távtelepítési szolgáltatás használata előtt tanulmányozza a Feladatlista: A távtelepítési szolgáltatás telepítése oldalon leírtakat.
  • A távtelepítési szolgáltatás használatával kapcsolatban a következő témakörben találhat hasznos ötleteket: Gyakorlati tanácsok.
  • A konkrét feladatokról az Útmutató tájékoztatja.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Feladatlista: A távtelepítési szolgáltatás telepítése

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat. | Fogalmak
Ellenőrizze, hogy mind a kiszolgáló, mind pedig az ügyfélszámítógép hardvere megfelel a távtelepítési hardverkövetelményeknek. | A távtelepítési szolgáltatás rendszerkövetelményei
Bizonyosodjon meg arról, hogy a Tartománynévrendszer (DNS) kiszolgálója létezik a hálózaton. | DNS-kiszolgáló telepítése; Új zóna szabványos elsődleges DNS-kiszolgálójának konfigurálása
Ellenőrizze, hogy létezik-e hitelesített DHCP-kiszolgáló a hálózaton. | DHCP-kiszolgáló telepítése; Feladatlista: DHCP-kiszolgáló telepítése
Ellenőrizze, hogy az Active Directory megtalálható-e a hálózaton. | Active Directory – áttekintés; Feladatlista: Tartományvezérlő telepítése
Telepítse és állítsa be a távtelepítési szolgáltatást. | A távtelepítési szolgáltatás telepítése


Gyakorlati tanácsok

  • Megfelelő számú távtelepítési kiszolgáló használata a hálózaton.
    Kis helyi hálózaton (LAN) – például egy útválasztó nélküli fizikai alhálózaton – egyetlen távtelepítési kiszolgáló ki tudja szolgálni az összes PXE távoli rendszertöltésű számítógépet a hálózati sávszélesség vagy a kiszolgáló erőforrásainak határáig. Útválasztásos környezetben a távtelepítésre beállított ügyfél beállítás használatával a fizikailag legközelebbi távtelepítési kiszolgálóhoz irányíthatja az ügyfeleket. Fiókirodák esetén, ahol a fiókhely csak kis sebességű csatolásokon keresztül érhető el, fizikailag meg kell határozni egy távtelepítési kiszolgáló helyét a fiókhelyen, így elkerülhető a torlódás a helyhez vezető kis sebességű csatoláson.
  • A felhasználó számára az Ügyféltelepítő varázsló programban elérhető telepítési beállításoknak és a választható operációs rendszerek számának a korlátozása.
    A telepítési beállítások korlátozásával növelni lehet a technikai tanácsadók és a felügyeletet ellátók beavatkozását nem igénylő, sikeres operációsrendszer-telepítések arányát. Alapértelmezés szerint a távtelepítési szolgáltatás csak egyetlen telepítési beállítást és választható operációs rendszert tartalmaz, amelyeket alapértelmezés szerint nem ajánl fel a felhasználóknak. További tudnivalók az ügyféltelepítésről a Telepítési beállítások című témakörben találhatók.
  • A Windows 2000 Professional normál vállalati asztali konfigurációjának központi telepítése különböző típusú ügyfél-számítógépekre a Távtelepítést előkészítő varázsló programkód-formátumának használatával.
    A Távtelepítést előkészítő varázsló használatával a rendszergazda replikálhatja egy meglévő Windows 2000 Professional ügyfélszámítógép telepítési programkódját – a helyileg telepített alkalmazásokkal és az operációs rendszer konfigurációjának módosításaival együtt – egy hálózaton elérhető távtelepítési kiszolgálóhoz. Replikálás után a telepítési programkódot távolról telepítheti bármelyik támogatott ügyfélszámítógép, függetlenül a programkódot létrehozó forrásszámítógép és a célszámítógép hardverének különbségeitől. További tudnivalók a Telepítési programkód létrehozása című részben találhatók.
  • A távtelepítési szolgáltatás használata azokon a számítógépeken, amelyeken nincs PXE alapú távoli rendszertöltő ROM.
    Használja a távoli rendszertöltőlemez-készítőt (Rbfg.exe) olyan számítógépek hajlékonylemezének elkészítésre, amelyeken nincs PXE alapú távoli rendszertöltő ROM. Ezután használhatja a távtelepítési szolgáltatás funkciót ezeken a számítógépeken. További tudnivalók a PXE alapú távoli rendszertöltő ROM memóriáról a PXE architektúra című témakörben találhatók.
  • Az Ügyféltelepítő varázsló használata nem ASCII-karakterekkel.
    Csak normál ASCII-karaktereket (32-től 127-ig terjedő OEM-karaktereket) használjon a felhasználónévben, a jelszóban és a tartománynévben. Az Ügyféltelepítő varázsló nem támogatja a kiterjesztett (például az ü, é stb. karaktereket tartalmazó) ASCII-karakterkészleteket.


Útmutató

  • A távtelepítési szolgáltatás telepítése
  • A távtelepítési szolgáltatás beállítása
  • A kiszolgáló beállításainak kezelése
  • Ügyfélszámítógépek telepítését lehetővé tévő bináris fájlok kezelése
  • Ügyfélszámítógépek kezelése
  • Az adatvédelem kezelése


A távtelepítési szolgáltatás telepítése

  1. Mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson A kiszolgáló konfigurálása parancsra.
  2. A Kiszolgáló konfigurálása párbeszédpanelen kattintson a Telepítés befejezése hivatkozásra.
  3. A Távtelepítési szolgáltatást telepítő varázsló elindításához kattintson A távtelepítési szolgáltatás konfigurálása párbeszédpanel Beállítás gombjára.
  4. Kattintson a Távtelepítési szolgáltatást telepítő varázsló párbeszédpanel Tovább gombjára.
  5. A Távtelepítési szolgáltatást telepítő varázslóban a következő információkat kell megadnia:
    A távtelepítési szolgáltatás kiszolgálójának meghajtója és könyvtára
    Adja meg azt a meghajtót és könyvtárt, ahová a távtelepítési szolgáltatást telepíteni szeretné. A meghajtó nem lehet azonos a számítógép rendszermeghajtójával, és a meghajtón elegendő lemezkapacitás kell, hogy legyen a tervezett ügyfélszámítógépek telepítési adatait tartalmazó bináris fájloknak. Legalább 4 gigabájt kapacitású lemezre vagy partícióra van szükség.
    Windows 2000 Professional forrásútvonal
    Adja meg a Windows 2000 Professional rendszer fájljainak helyét. A fájlok lehetnek a Windows 2000 Professional CD-lemezen vagy a telepítőfájlokat tároló hálózati megosztáson.
    Rövid leírás és súgószöveg
    Írja be a számítógép rövid leírását: a kiszolgálót használó felhasználók vagy ügyfelek ezt a leírást látják majd. A súgószöveg a távtelepítési szolgáltatást igénybe vevő felhasználóknak vagy ügyfeleknek nyújt tájékoztatást az operációs rendszer telepítési lehetőségeiről.

Megjegyzések

  • A Távtelepítési szolgáltatást telepítő varázsló elindításához kattintson a Start menü Futtatás parancsára, és a Megnyitás mezőbe írja be a RIsetup parancsot.
  • Ezt az eljárást csak Rendszergazda jogosultságok birtokában tudja elvégezni.
  • A távtelepítési szolgáltatás telepítése előtt a hálózatra Windows 2000 Server kiszolgálót vagy DNS és DHCP-szolgáltatásokat futtató kiszolgálókat kell telepíteni.
  • Ha a távtelepítési szolgáltatást a Windows 2000 Server operációs rendszer telepítése után a Vezérlőpultról elérhető Windows-összetevők hozzáadása/eltávolítása szolgáltatással telepítette, a Távtelepítési szolgáltatást telepítő varázsló a számítógép újraindítását kérheti.
  • A távtelepítési szolgáltatást a Windows 2000 - kiszolgáló konfigurálása ablak bal oldali paneljének Speciális hivatkozására kattintva vagy a Vezérlőpultról elérhető Windows-összetevők hozzáadása/eltávolítása szolgáltatással telepítheti.
  • A
    \\Kiszolgálónév\Megosztásnév\REMINST\Setup\Nyelv\Images
    mappán kívül tárolt és csatlakozási pontokon keresztül hivatkozott, telepítési adatokat tartalmazó bináris fájlokra az SIS-rendszerező ügynök működése nincs hatással. E telepítési adatokat tartalmazó bináris fájlokat NTFS fájlrendszerrel formázott meghajtóra kell telepíteni.
  • A távtelepítési szolgáltatást csak NTFS fájlrendszerrel formázott meghajtóra telepítheti.
  • A távtelepítési szolgáltatás jelenleg nem támogatja a titkosított fájlrendszert (Encrypting File System, EFS) és az elosztott fájlrendszert (Distributed File System, DFS).
  • A távtelepítési kötet nem telepíthető a Windows 2000 Server operációs rendszert tartalmazó meghajtóra.
  • Ha ellenőrizni szeretné, hogy minden szolgáltatás sikeresen elindult-e, nyissa meg a Windows Eseménynapló alkalmazását, és tanulmányozza a Rendszernapló és az Alkalmazásnapló bejegyzéseit. A Windows Eseménynaplójáról a Kapcsolódó témakörök hivatkozásra kattintva tudhat meg többet.

Kapcsolódó témakörök


A távtelepítési szolgáltatás beállítása

  • A távtelepítési szolgáltatás beállítása
  • A távtelepítési szolgáltatás speciális beállításainak megadása
  • Ügyfélszámítógépek telepítését lehetővé tévő bináris fájlok kezelése
  • Hibaelhárító eszközök kezelése


A távtelepítési szolgáltatás beállítása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a helyi menü Tulajdonságok parancsára, majd az adott kiszolgáló tulajdonságlapjait megjelenítő párbeszédpanel Távtelepítés fülére.
  4. A Távtelepítés lapon jelölje be a következő jelölőnégyzetek valamelyikét:
    • Válasz ügyfélszámítógépek szolgáltatáskérelmére
    • Ismeretlen ügyfelek kérelmére ne válaszoljon

    E beállításokról az Ügyfelektől érkező szolgáltatáskérelmek megválaszolása című témakörben találhat bővebb tájékoztatást.

Megjegyzés

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.

Kapcsolódó témakörök


A távtelepítési szolgáltatás speciális beállításainak megadása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a Tulajdonságok parancsra. Kattintson a tulajdonságlapokat megjelenítő párbeszédpanel Távtelepítés fülére, majd a Speciális beállítások gombra.
  4. Kattintson az Új ügyfelek fülre.
  5. Az ügyfélgép nevének formátumát a legördülő listára vagy a Testreszabás gombra kattintva adhatja meg.
  6. A következő választógombok egyikét bejelölve megadhatja, hogy a rendszer hol hozza létre az ügyfélfiókot:
    • Alapértelmezett címtárszolgáltatás helye
    • Azon a helyen, ahol a felhasználó az ügyfélgépet telepíti
    • A következő szolgáltatás helye
  7. Ha az utolsó választógombot jelölte be, a Tallózás gombra kattintva megadhatja a számítógépfiókok létrehozásának helyét.

Fontos

  • Ha a hálózaton több távtelepítési kiszolgáló is működik, azokat úgy kell konfigurálni, hogy az ügyfélszámítógépektől érkező kérelmekre ugyanúgy válaszoljanak.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Ügyfélszámítógép telepítésekor a felhasználók csak a megfelelő jogosultságok birtokában hozhatják létre a számítógépfiókot a kiválasztott tartományban vagy szervezeti egységben.

Kapcsolódó témakörök


Ügyfélszámítógépek telepítését lehetővé tévő bináris fájlok kezelése

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a Tulajdonságok parancsra.
  4. Kattintson a tulajdonságlapokat megjelenítő párbeszédpanel Távtelepítés fülére, majd a Speciális beállítások gombra.
  5. Kattintson a megjelenő párbeszédpanel Programkódok fülére.
  6. A Programkódok lapon kattintson a telepítési programkódra vagy a felügyelet nélküli telepítési válaszfájlra.
  7. Kattintson a következő gombok valamelyikére:
    • Hozzáadás
    • Eltávolítás
    • Tulajdonságok
    • Frissítés

Megjegyzés

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.

Kapcsolódó témakörök


Hibaelhárító eszközök kezelése

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a helyi menü Tulajdonságok parancsára, majd az adott kiszolgáló tulajdonságlapjait megjelenítő párbeszédpanel Távtelepítés fülére.
  4. Kattintson a Speciális beállítások gombra, majd az Eszközök fülre.
  5. Kattintson az Eszközök lapon felsorolt valamely eszközre.
  6. Kattintson a következő gombok valamelyikére:
    • Eltávolítás
    • Tulajdonságok
    • Frissítés

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • A távtelepítési szolgáltatás nem tud eszközöket adni a listához.

Kapcsolódó témakörök


A kiszolgáló beállításainak kezelése

  • Programkód létrehozása a távtelepítést előkészítő varázslóhoz
  • Távoli rendszertöltő lemez létrehozása
  • A távtelepítési szolgáltatás beállításainak ellenőrzése


Programkód létrehozása a Távtelepítést előkészítő varázslóhoz

  1. Telepítse az operációs rendszert a távtelepítési szolgáltatással arra az ügyfélszámítógépre, amellyel a telepítési adatokat tartalmazó bináris fájlt (programkódot) létre kívánja hozni. További tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.
  2. Telepítse a szükséges alkalmazásokat, és módosítsa a forrás-ügyfélszámítógép helyi konfigurációs beállításait.
  3. Kattintson a Start gombra, majd a Futtatás parancsra.
  4. Írja be a Megnyitás mezőbe a RIPrep.exe segédprogram UNC-útvonalát, majd kattintson az OK gombra.
    Például:
    \\Kiszolgálónév\Megosztásnév\REMINST\Admin\I386\RIPrep.exe
  5. Tanulmányozza át a Távtelepítést előkészítő varázsló üdvözlőlapján látható adatokat, majd kattintson a Tovább gombra.
  6. Írja be annak a kiszolgálónak a nevét, amelyre a rendszer a programkódot (bináris fájlt) másolja, majd kattintson a Tovább gombra. Ez a kiszolgáló alapértelmezés szerint az az aktuális távtelepítési kiszolgáló, amelyről a varázslót futtatja.
  7. Adja meg a távtelepítési kiszolgáló azon mappájának nevét, amelybe a rendszer a bináris fájlt másolja, majd kattintson a Tovább gombra.
  8. Írja be a rövid leírást és a súgószöveget, majd kattintson a Tovább gombra. Ezt az információt az Ügyféltelepítő varázslóban használja a rendszer akkor, ha távtelepítéssel telepített ügyfelektől hálózati szolgáltatáskérelem érkezik.
  9. A továbblépés előtt tanácsos a forrásszámítógépen futó összes alkalmazást vagy szolgáltatást bezárni. Ellenőrizze, hogy jelenleg mely programok vagy szolgáltatások futnak a forrásszámítógépen, zárjon be minden futó alkalmazást, majd kattintson a Tovább gombra.
  10. Ellenőrizze a megadott beállításokat, majd kattintson a Tovább gombra.
  11. Ellenőrizze a Távtelepítést előkészítő varázsló befejezése oldalon látható információkat, majd a forrásszámítógép telepítési programkódjának (azaz a telepítés adatait tartalmazó bináris fájlnak) távtelepítési kiszolgálóra történő replikálásához kattintson a Tovább gombra.

Megjegyzések

  • Ezt az eljárást csak Rendszergazda jogosultságok birtokában tudja elvégezni.
  • A forrásszámítógép a programkódmásolási folyamat befejezése után leáll.
  • A forrásszámítógép újraindításakor a gyorstelepítő program automatikusan elindul. A telepítési folyamat befejezésével az ügyfélszámítógépet másik telepítési programkód (bináris fájl) létrehozására is használhatja.
  • A Távtelepítést előkészítő varázsló újbóli futtatásával további telepítési programkódokat hozhat létre.

Kapcsolódó témakörök


Távoli rendszertöltő lemez létrehozása

  1. Kattintson a Start gombra, majd a Futtatás parancsra.
  2. A Megnyitás mezőbe írja be az Rbfg.exe segédprogram UNC-útvonalát, majd kattintson az OK gombra. Például:
    \\kiszolgálónév\REMINST\Admin\I386\RBFG.exe
  3. Helyezzen egy formázott lemezt a hajlékonylemez-meghajtóba.
  4. Jelölje be a Célmeghajtó csoportban a megfelelő meghajtóhoz tartozó választógombot, majd kattintson a Lemez létrehozása gombra.
  5. Ha a rendszer létrehozta a lemezt, kattintson a Bezárás gombra, és vegye ki a lemezt a meghajtóból.

Megjegyzés

  • A távoli rendszertöltő lemezt csak olyan számítógépekkel használhatja, amelyekben támogatott, PCI alapú hálózati csatolók vannak. A támogatott hálózati csatolók listájának megtekintéséhez indítsa el az Rbfg.exe segédprogramot, és kattintson a Csatolólista gombra.

Kapcsolódó témakörök


A távtelepítési szolgáltatás beállításának ellenőrzése

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. Kattintson a konzolfán arra a mappára, amely azon számítógépet tartalmazza, amelynek konfigurációját ellenőrizni kívánja, például a Computers vagy Domain Controllers mappára.

    Helye:

    • Active Directory – felhasználók és számítógépek
    • A megfelelő tartomány
    • A kívánt tároló
  3. A részleteket tartalmazó ablaktáblában kattintson az egér jobb gombjáva a megfelelő kötetre, majd a Tulajdonságok parancsra.
  4. Kattintson a Távoli telepítés fülre, majd a Kiszolgáló ellenőrzése gombra.

Megjegyzések

  • Az Active Directory – felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory – felhasználók és számítógépek parancsra.
  • Ezt az eljárást csak Rendszergazda jogosultságok birtokában tudja elvégezni.
  • A Kiszolgáló ellenőrzése parancs csak azon kiszolgáló konzolján érhető el, amelyet ellenőrizni kíván.
  • Ha azért ellenőrzi a kiszolgáló beállítását, mert a távtelepítési szolgáltatás kötetét biztonsági másolatról kell helyreállítania, ellenőriznie kell a kiszolgáló beállításait, mielőtt a kötetet helyreállítja.

Kapcsolódó témakörök


Ügyfélszámítógépek telepítését lehetővé tévő bináris fájlok kezelése

  • Ügyfélszámítógép telepítési adatait tartalmazó új bináris fájl hozzáadása
  • Felügyelet nélküli telepítési válaszfájl társítása


Ügyfélszámítógép telepítési adatait tartalmazó új bináris fájl hozzáadása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a helyi menü Tulajdonságok parancsára, majd az adott kiszolgáló tulajdonságlapjait megjelenítő párbeszédpanel Távtelepítés fülére.
  4. Kattintson a Speciális beállítások gombra, majd a Programkódok fülre.
  5. A Hozzáadás gombra kattintva elindíthatja a Hozzáadás varázslót.
  6. Jelölje be az Új telepítési programkódot kívánok hozzáadni választógombot, majd a Telepítési programkód hozzáadása varázsló indításához kattintson a Tovább gombra.
  7. Kattintson a Tovább gombra, és adja meg a Windows 2000 Professional rendszer telepítőfájljainak helyét. A fájlok CD-lemezen vagy hálózati megosztáson lehetnek.
  8. Írja be a rövid leírást és a súgószöveget, majd kattintson a Tovább gombra.
  9. Ellenőrizze a telepítési adatokat, majd kattintson a Befejezés gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • A folyamat végrehajtásához Rendszergazda jogosultságokra van szüksége.
  • A távtelepítési szolgáltatás kiszolgálókötetét NTFS fájlrendszerrel kell formázni. A meghajtó nem lehet azonos a számítógép rendszermeghajtójával, és a meghajtón elegendő lemezkapacitás kell, hogy legyen a tervezett ügyfélszámítógépek telepítési adatait tartalmazó bináris fájloknak. Legalább 4 gigabájt kapacitású lemezre vagy partícióra van szükség.
  • A távtelepítési szolgáltatás jelenleg nem támogatja a titkosított fájlrendszert (Encrypting File System, EFS) és az elosztott fájlrendszert (Distributed File System, DFS).
  • A távtelepítési szolgáltatás kiszolgálókötete nem lehet a rendszerkötet.
  • A távtelepítési szolgáltatás jelenleg csak a Windows 2000 Professional operációs rendszert támogatja.

Kapcsolódó témakörök


Felügyelet nélküli telepítési válaszfájl társítása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a helyi menü Tulajdonságok parancsára, majd az adott kiszolgáló tulajdonságlapjait megjelenítő párbeszédpanel Távtelepítés fülére.
  4. Kattintson a Speciális beállítások gombra, majd a Programkódok fülre.
  5. A Hozzáadás gombra kattintva elindíthatja a Hozzáadás varázslót.
  6. Jelölje be az Új válaszfájlt kívánok társítani egy meglévő programkódhoz választógombot, majd kattintson a Tovább gombra.
  7. Jelölje be az alábbi három választógomb valamelyikét:
    • Windows minta-programkód
    • Másik távtelepítési kiszolgáló
    • Egyéb hely
  8. Keresse meg azt a telepítési adatokat tartalmazó bináris fájlt, amellyel a telepítési válaszfájlt társítani kívánja, majd kattintson a Tovább gombra.
  9. Írja be a rövid leírást és a súgószöveget, majd kattintson a Tovább gombra.
  10. Ellenőrizze a beállításokat, majd a varázsló bezáráshoz kattintson a Befejezés gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • A Hozzáadás varázslót csak Rendszergazda jogosultságok birtokában futtathatja.

Kapcsolódó témakörök


Ügyfélszámítógépek kezelése

  • Ügyfélszámítógépek előzetes beállítása
  • Létező ügyfélszámítógépek eltávolítása
  • Ügyfélszámítógépek keresése
  • Ügyfélszámítógépek globálisan egyedi azonosítójának (GUID) megállapítása
  • Hálózaton keresztül történő rendszerindítás


Ügyfélszámítógépek előzetes beállítása

  1. Nyissa meg az Active Directory – felhasználók és számítógépek ablakot.
  2. A konzolfán kattintson az egér jobb gombjával arra a szervezeti egységre, amely az új ügyfélszámítógépet fogja tartalmazni.

    Helye:

    • Active Directory – felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység
  3. Mutasson az Új pontra, majd kattintson a Számítógép parancsra.
  4. Írja be az ügyfélszámítógép nevét, kattintson a Tovább gombra, majd jelölje be az Ez egy vezérelt PC jelölőnégyzetet.
  5. Írja be az ügyfélszámítógép GUID azonosítóját a szövegmezőbe, majd kattintson a Tovább gombra.
  6. Jelölje be az alábbi választógombok egyikét annak megadásához, ahogy mely kiszolgáló fogja támogatni az ügyfélszámítógépet.
    • Bármely szabad távtelepítési kiszolgáló E választógomb bejelölésével jelzi, hogy ezt az ügyfélszámítógépet bármely távtelepítési szolgáltatás kiszolgálhatja.
    • A következő távtelepítési kiszolgáló E választógomb bejelölésével konkrét kiszolgálót adhat meg.

Megjegyzések

  • Az Active Directory – felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory – felhasználók és számítógépek parancsra.
  • Mielőtt tovább lép, győződjön meg róla, hogy rendelkezik az ügyfélszámítógép egyedi azonosítójával (GUID).
  • Előre meghatározhatja, hogy egy konkrét ügyfélszámítógép hálózati fiókja hogyan lesz azonosítva az ügyfélszámítógép fiókobjektum az Active Directoryban történő előzetes beállításával. A hálózati rendszerindító szolgáltatás igénylése során a kiszolgáló ezen adatok használatával azonosítja az ügyfélszámítógépeket, és adja meg azok hálózati elérési útját.
  • Győződjön meg róla, hogy a megfelelő hozzáférési engedélyeket adta meg az előre beállított számítógépek felhasználóinak. Az engedélyek beállításával kapcsolatos további információért kattintson a Kapcsolódó témakörök hivatkozásra.
  • Ha több tartományvezérlővel rendelkező tartományhoz állítja be az ügyfélszámítógépet, előfordulhat, hogy az ügyfélszámítógép-fiók (CAO) adatainak replikációs késleltetése miatt az adott ügyfélszámítógépet egy másik távtelepítési kiszolgáló szolgálja ki. Az adatreplikációval kapcsolatos további tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.

Kapcsolódó témakörök


Létező ügyfélszámítógépek eltávolítása

  1. Nyissa meg az Active Directory – felhasználók és számítógépek ablakot.
  2. Kattintson a konzolfán jobb egérgombbal a megfelelő ügyfélszámítógép-fiókra.

    Helye:

    • Active Directory – felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például a Számítógépek vagy a Tartományvezérlők)
    • A megfelelő ügyfélszámítógép-fiók
  3. Kattintson a Törlés parancsra.

Megjegyzés

  • Az Active Directory – felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory – felhasználók és számítógépek parancsra.

Kapcsolódó témakörök


Ügyfélszámítógépek keresése

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő távtelepítési kiszolgálóra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő távtelepítési kiszolgáló
  3. Kattintson a helyi menü Tulajdonságok parancsára, majd az adott kiszolgáló tulajdonságlapjait megjelenítő párbeszédpanel Távtelepítés fülére.
  4. Kattintson a Távtelepítés lap Ügyfelek mutatása gombjára.
  5. Írja be az ügyfélszámítógép globálisan egyedi azonosítóját (GUID), majd kattintson a Keresés most gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Az Ügyfelek mutatása szolgáltatás az aktuális távtelepítési kiszolgálóhoz előzőleg beállított összes ügyfélszámítógépet megkeresi.
  • Amennyiben az Ügyfelek mutatása szolgáltatást több, távtelepítési kiszolgálót futtató környezetben használja, a keresési eredmények között több kiszolgáló ügyfélszámítógépei is szerepelhetnek. Ha több távtelepítési kiszolgálót üzemeltet, és azok számítógépnevei például RISsvr1, RISsvr10 és RISsvr100, a keresési eredményekben szerepelni fognak minden kiszolgáló azon ügyfélszámítógépei, amelyek neve ugyanezekkel a számítógépnevekkel kezdődik.
  • Az ügyfélszámítógépek keresését egy adott kiszolgálóra korlátozhatja, ha a kiszolgáló nevét beírja az RI-kiszolgáló mezőbe.

Kapcsolódó témakörök


Ügyfélszámítógépek globálisan egyedi azonosítójának (GUID) megállapítása

  • A számítógép globálisan egyedi azonosítóját (GUID) a következő helyeken találhatja meg:
    • a számítógépház oldalán lévő címkén
    • a számítógépházon belül lévő címkén vagy
    • az ügyfélszámítógép BIOS-ában.

Megjegyzések

  • A számítógép globálisan egyedi azonosítóját a számítógép gyártója helyezi el.
  • A globálisan egyedi azonosító (GUID) {dddddddd-dddd-dddd-dddd-dddddddddddd} formátumú kell, hogy legyen, ahol d hexadecimális szöveges számjegyet jelöl.

    Például: 8 hexadecimális szöveges számjegy, amelyet 4, 4, 4, majd 12 szöveges számjegy követ, például:

    {921FB974-ED42-11BE-BACD-00AA0057B223}

  • Az ügyfél globálisan egyedi azonosítója (GUID) csak a következő számjegyeket és karaktereket tartalmazhatja:

    0 1 2 3 4 5 6 7 8 9 a b c d e f – A B C D E F

  • A kötőjeleket nem kötelező megadni, a szóközöket pedig figyelmen kívül hagyja a rendszer.
  • A GUID azonosítót egybeírt formátumban is meg lehet adni. Ebben a formátumban a GUID azonosító első 16 karakterét a rendszer áthelyezi. Ha az azonosítót például egybeírva,
    0123456789ABCDEF0123456789ABCDEF
    formátumban írja be, az eredmény a következő lesz:

    egybeírva:
    01234567 89AB CDEF 0123456789ABCDEF
    megjelenítve:
    {67452301-AB89-EFCD-0123-456789ABCDEF}.

Kapcsolódó témakörök


Hálózaton keresztül történő rendszerindítás

  1. Az Ügyféltelepítő varázsló indítása után nyomja le az ENTER billentyűt a folyamat folytatásához.
  2. Írja be a felhasználónevet, a jelszót és tartománynevet a megfelelő mezőkbe, a TAB billentyű segítségével haladva egyik mezőről a másikra.
  3. Az Ügyféltelepítő varázsló az alábbi beállítási lehetőségeket kínálja:
    • Automatikus telepítés. Akkor használja ezt a beállítási lehetőséget, ha azt szeretné, hogy a beállítások nagy részét a rendszergazda végezze el. A felhasználó számára az Ügyféltelepítő varázsló nem kínál fel választási lehetőségeket.
    • Egyéni telepítés. E beállítási lehetőség segítségével egyedi név adható meg a számítógép számára, és megadható, hogy a fiók az Active Directory mely helyén jöjjön létre.
    • Megkezdett telepítési kísérlet újraindítása. E beállítási lehetőség segítségével engedélyezheti az operációs rendszer telepítésének újraindítását, ha a telepítés nem fejeződik be sikeresen.
    • Karbantartás és hibaelhárítás. E beállítási lehetőségek lehetővé teszik, hogy az Ügyféltelepítő varázslóból eszközöket lehessen használni.

Megjegyzések

  • Hálózati rendszerbetöltés igénylése előtt győződjön meg róla, hogy érvényes felhasználói névvel, jelszóval és tartománynévvel rendelkezik.
  • Ha olyan ügyfélszámítógépeken kíván hálózati rendszerbetöltést végrehajtani, amelyek nem alkalmasak a távoli rendszerbetöltésre, helyezze be a rendszerbetöltő lemezt a lemezmeghajtóba, és kapcsolja be az ügyfélszámítógépet.
  • Az ügyfélszámítógép BIOS rendszerét úgy kell konfigurálni, hogy a hálózati csatolókártyát használja elsődleges rendszerbetöltési eszközként.
  • Az Ügyféltelepítő varázsló használatakor csak normál ASCII-karaktereket (32-től 127-ig terjedő OEM-karaktereket) használjon a felhasználónévben, a jelszóban és a tartománynévben. Az Ügyféltelepítő varázsló nem támogatja a bővített (például az ü, é stb. karaktereket tartalmazó) ASCII-karakterkészleteket.

Kapcsolódó témakörök


Az adatvédelem kezelése

  • Előre beállított számítógépfiókra vonatkozó engedélyek megadása
  • A felhasználók által létrehozott számítógépfiókokra vonatkozó engedélyek beállítása
  • Tartományhoz történő csatlakozás engedélyezése a Számítógépek tárolóban létrehozott számítógépeknek
  • Tartományhoz történő csatlakozás engedélyezése szervezeti egységben létrehozott számítógépeknek
  • Csoportházirend megadása az ügyféltelepítési beállításokhoz


Előre beállított számítógépfiókra vonatkozó engedélyek megadása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. Kattintson a konzolfán jobb egérgombbal a megfelelő ügyfélszámítógép-fiókra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például Számítógépek vagy Tartományvezérlők)
    • A megfelelő ügyfélszámítógép-fiók
  3. Kattintson a Tulajdonságok parancsra.
  4. A Tulajdonságok párbeszédpanelen kattintson a Biztonság fülre, majd a Hozzáadás gombra.
  5. Jelölje ki a felhasználót vagy csoportot a listában, kattintson a Hozzáadás, majd az OK gombra.
  6. Kattintson a hozzáadott felhasználóra vagy csoportra.
  7. Az Engedélyek listában jelölje be az Olvasás, Írás és a Jelszó alaphelyzetbe állítása engedélyek jelölőnégyzeteit, majd kattintson az OK gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Ezen beállítás megtekintéséhez győződjön meg róla, hogy az Active Directory - felhasználók és számítógépek konzol Nézet menüjében a Felhasználók, csoportok, számítógépek mint tárolók és a Speciális lehetőségek menüelemek ki vannak jelölve.
  • Ha egy csoportot ellát ezen engedélyekkel, ne feledjen felhasználókat adni ehhez a csoporthoz.
  • Másik Active Directory mappában előre beállított ügyfélszámítógép-fiókok esetén bontsa ki az Active Directory - felhasználók és számítógépes konzolfa ágait, és jelölje ki a megfelelő ügyfélszámítógép-fiókot.

Kapcsolódó témakörök


A felhasználók által létrehozott számítógépfiókokra vonatkozó engedélyek beállítása

  1. Nyissa meg az Active Directory – felhasználók és számítógépek ablakot.
  2. Kattintson a konzolfán jobb egérgombbal a megfelelő tartományra.

    Helye:

    • Active Directory – felhasználók és számítógépek
    • A megfelelő tartomány
  3. Kattintson a Vezérlés delegálása parancsra.
  4. Kattintson a Vezérlés delegálása varázsló Tovább gombjára.
  5. A Vezérlés delegálása párbeszédpanelen adja meg a tartomány adatait, majd kattintson a Tovább gombra.
  6. Kattintson a Választott felhasználók és csoportok lista alatt található Hozzáadás gombra.
  7. A Felhasználók, Számítógépek vagy Csoportok kijelölése párbeszédpanelen jelölje ki a kívánt felhasználói fiókot vagy azt a biztonsági csoportot (ez a javasolt beállítás), amely azon felhasználókat tartalmazza, amelyekre az engedélyeket meg kívánja adni, kattintson a Hozzáadás, majd az OK, végül a Tovább gombra.
  8. A Delegálandó feladatok párbeszédpanelen jelölje be A számítógép csatlakoztatása a tartományhoz jelölőnégyzetet, majd kattintson a Tovább gombra.
  9. Ellenőrizze a vezérlés delegálásának összefoglaló adatait, majd kattintson a Befejezés gombra.

Megjegyzések

  • Az Active Directory – felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory – felhasználók és számítógépek parancsra.
  • Ha egy csoportot ellát ezen engedélyekkel, felhasználókat kell adnia a csoporthoz.

Kapcsolódó témakörök


Tartományhoz történő csatlakozás engedélyezése a Számítógépek tárolóban létrehozott számítógépeknek

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. Kattintson a konzolfán jobb egérgombbal a megfelelő tartományra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
  3. Kattintson a helyi menü Vezérlés delegálása parancsára.
  4. Kattintson a Vezérlés delegálása varázsló párbeszédpanel Tovább gombjára.
  5. A Vezérlés delegálása párbeszédpanelen adja meg a tartomány adatait, majd kattintson a Tovább gombra.
  6. Kattintson a Választott felhasználók és csoportok mező alatt található Hozzáadás gombra.
  7. A Felhasználók, Számítógépek vagy Csoportok kijelölése párbeszédpanelen jelölje ki a tartományba tartozó ügyfélszámítógépekhez csatlakoztatandó felhasználókat tartalmazó felhasználói fiókot vagy biztonsági csoportot (ez a javasolt beállítás), kattintson a Hozzáadás, majd az OK, végül a Tovább gombra.
  8. A Delegálandó feladatok lapon jelölje be A számítógép csatlakoztatása a tartományhoz jelölőnégyzetet, majd kattintson a Tovább gombra.
  9. Ellenőrizze a vezérlés delegálásának adatait, majd kattintson a Befejezés gombra.

Megjegyzés

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.

Kapcsolódó témakörök


Tartományhoz történő csatlakozás engedélyezése szervezeti egységben létrehozott számítógépeknek

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán jobb gombbal kattintson a megfelelő szervezeti egységre.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. A csoportházirend-objektumokat megjelenítő listán kattintson a megfelelő csoportházirend-objektumra, majd a Csoportházirend ablak megnyitásához a Szerkesztés gombra.
  5. Bontsa ki egymás után a Számítógép konfigurációja, Windows-beállítások, Biztonsági beállítások, Helyi házirend listaelemeket, majd a Felhasználói engedélyek mappát.
  6. Kattintson duplán a Munkaállomás felvétele a tartományba elemre.
  7. Jelölje ki a tartományba tartozó ügyfélszámítógépekhez csatlakoztatandó felhasználókat tartalmazó felhasználói fiókot vagy biztonsági csoportot (ez a javasolt beállítás), kattintson a Hozzáadás gombra, majd az OK gombra.
  8. Zárja be a Csoportházirend ablakot, majd a Csoportházirend lapot tartalmazó párbeszédpanelen kattintson az OK gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Az Active Directory - felhasználók és számítógépek konzol Csoportházirend segédprogramján keresztül az adott tartományvezérlőn megadott biztonsági beállítások a megadott felhasználói vagy csoportfiókok beállításait még nyolc órán keresztül nem befolyásolják.

Kapcsolódó témakörök


Csoportházirend megadása az ügyféltelepítési beállításokhoz

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A konzolfán kattintson a megfelelő szervezeti egységre.

    Helye:

    • Active Directory – felhasználók és számítógépek
    • A megfelelő tartomány
    • A megfelelő szervezeti egység (például a Számítógépek vagy a Tartományvezérlők)
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. A csoportházirend indításához a Csoportházirend lapon kattintson a megfelelő csoportházirend-objektumra, majd a Szerkesztés gombra.
  5. Kattintson duplán a Felhasználó konfigurációja, majd a Windows-beállítások, végül a Távtelepítési szolgáltatások elemre.
  6. Kattintson duplán a Választási lehetőségek ikonra, majd adja meg az Ügyféltelepítő varázsló alábbi beállításait:
    • Automatikus telepítés Akkor használja ezt a beállítási lehetőséget, ha azt szeretné, hogy a beállításokat nagy részét a rendszergazda végezze el. Ekkor az Ügyféltelepítő varázsló a felhasználó számára nem kínál fel választási lehetőségeket.
    • Egyéni telepítés Az ebben a csoportban található választógombok segítségével egyedi név adható meg a számítógép számára, és megadható, hogy a fiók az Active Directory mely helyén jöjjön létre.
    • Telepítő újraindítása Az ebben a csoportban található választógombok segítségével engedélyezheti az operációs rendszer telepítésének újraindítását, ha a telepítés nem fejeződik be sikeresen.
    • Eszközök Az ebben a csoportban található választógombok lehetővé teszik, hogy az Ügyféltelepítő varázslóból eszközöket lehessen használni.
  7. Az Ügyféltelepítő varázsló előbb felsorolt csoportjaiban jelölje be az alábbi Csoportházirendre vonatkozó választógombok egyikét:
    • Engedélyezve E választógomb segítségével lehet a felhasználók számára az adott házirend által szabályozott telepítési lehetőséget engedélyezni.
    • Mindegy E választógomb segítségével elfogadja a szülőtárolóra vonatkozó házirend beállításait. Ha például az egész tartomány rendszergazdája megadott a távtelepítési szolgáltatásra vonatkozó Csoportházirendet, és az adott tároló rendszergazdája a Mindegy beállítást választja, akkor a tartományra beállított házirend minden olyan felhasználóra vonatkozik, akit az adott házirend érint.
    • Megtagadva Ha egy adott telepítési lehetőségre ezt a választógombot jelöli be, azok a felhasználók, akikre ez a házirend vonatkozik, nem férnek hozzá az Ügyféltelepítő varázsló kérdéses beállítási lehetőségéhez.
  8. Zárja be a Csoportházirend ablakot, majd a Csoportházirend lapot tartalmazó párbeszédpanelen kattintson az OK gombra.

Megjegyzések

  • Az Active Directory – felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory – felhasználók és számítógépek parancsra.
  • Az egyes házirendekben alapértelmezés szerint a Mindegy választógomb van beállítva.
  • Az Ügyféltelepítő varázsló futása alatt az ügyfélszámítógépek felhasználói számára az Automatikus telepítés az alapértelmezett megjelenítési beállítás.
  • Az Active Directory – felhasználók és számítógépek konzol Csoportházirend segédprogramján keresztül az adott tartományvezérlőn megadott biztonsági beállítások a megadott felhasználói vagy csoportfiókok beállításait még nyolc órán keresztül nem befolyásolják.

Kapcsolódó témakörök


Fogalmak

Erről az oldalról a távtelepítési szolgáltatással kapcsolatos általános háttérinformációkat ismertető témaköröket érheti el:

  • Távtelepítési szolgáltatás – áttekintés
  • A távtelepítési szolgáltatás ismertetése
  • A távtelepítési szolgáltatás használata
  • Forrásanyagok


Távtelepítési szolgáltatás – áttekintés

A távtelepítési szolgáltatás használatával új ügyfélszámítógépeket telepíthet anélkül, hogy azokat ténylegesen a helyszínen konfigurálná. Pontosabban fogalmazva úgy telepíthet operációs rendszereket távindítással indítható ügyfélszámítógépekre, hogy csatlakoztatja őket a hálózathoz, elindítja őket, és érvényes felhasználói fiók segítségével bejelentkezik.

A távtelepítési szolgáltatás és az IntelliMirror alkalmazás a Windows 2000 Server operációs rendszer új módosítás- és beállításkezelő szolgáltatásai. A távtelepítési szolgáltatás és az IntelliMirror egyéb szolgáltatásainak (felhasználói dokumentumok és beállítások kezelése, Szoftvertelepítés és Csoportházirend) együttes alkalmazásával a vállalati felhasználók korszerűbb helyreállítási lehetőségekhez jutnak, egyszerűbben kezelhetik operációs rendszereiket és alkalmazásaikat, és nem szorulnak olyan gyakran a technikai tanácsadás segítségére. További információt az IntelliMirror című témakörben talál.


A távtelepítési szolgáltatás ismertetése

A rész tartalma:

  • A távtelepítési szolgáltatás működéséhez szükséges összetevők
  • A távtelepítési szolgáltatás architektúrája


A távtelepítési szolgáltatás működéséhez szükséges összetevők

A távtelepítési szolgáltatás használatához több olyan összetevőre is szükség van, amely a Windows 2000 Server operációs rendszer részét képezi. A következő szolgáltatásokat önállóan működő kiszolgálókra vagy ugyanarra a kiszolgálóra is telepíteni lehet (a szolgáltatásoknak aktívnak és elérhetőnek kell lenniük):

  • Tartománynévrendszer (DNS)
  • Dynamic Host Configuration protokoll (DHCP)
  • Active Directory

A távtelepítési szolgáltatás ügyfélszámítógépei a hálózaton keresztül a távtelepítési kiszolgálóhoz kapcsolódnak, és globálisan egyedi azonosítójukkal (GUID) vagy univerzálisan egyedi azonosítójukkal (UUID) azonosítják magukat. A számítógép gyártója által megadott számítógép-azonosító minden egyes számítógép egyedi azonosítására szolgál. A számítógép egyedi azonosítóját az Ügyfélszámítógépek globálisan egyedi azonosítójának (GUID) megállapítása című témakörben leírtak szerint találhatja meg.

Ha az ügyfélszámítógéptől kérelem érkezik a távtelepítési szolgáltatáshoz, a válasz a hálózat beállításaitól függően kétféle lehet:

  • a távtelepítési szolgáltatás azonosítja a számítógépet annak egyedi azonosítója alapján, és elküldi a rendelkezésre álló telepítési lehetőségeket, vagy
  • a távtelepítési kiszolgáló az ügyfélszámítógépektől érkező összes hálózati szolgáltatáskérelemre válaszol.

A távtelepítési szolgáltatáshoz érkező kérelmek megválaszolási módjának beállításáról az Ügyfelektől érkező szolgáltatáskérelmek megválaszolása című témakör nyújt tájékoztatást.


A távtelepítési szolgáltatás architektúrája

A rész tartalma:

  • Kapcsolódó technológiák és szolgáltatások
  • PXE-architektúra
  • A távtelepítési szolgáltatás címtárszolgáltatásának megtervezése
  • A távtelepítési szolgáltatás rendszerkövetelményei
  • A távtelepítési szolgáltatás indítólemeze
  • Telepítési programkód létrehozása
  • Telepítési programkód létrehozása


Kapcsolódó technológiák és szolgáltatások

A távtelepítési szolgáltatás környezete több technológiából és szolgáltatásból áll egy Dynamic Host Configuration protokollt (DHCP), Tartománynévrendszert (DNS) és Active Directoryt tartalmazó hálózaton belül.

Az operációs rendszer ügyfélszámítógépre telepítése távoli forrásról a PXE (Pre-Boot eXecution Environment) DHCP alapú távoli rendszertöltő technológia használatával történik. A távoli forráson – a távtelepítési kiszolgálón – található a telepítendő operációs rendszer programkódja a CD vagy a Távtelepítést előkészítő varázsló programkód-formátumában. A CD alapú telepítés hasonló a közvetlenül a Windows 2000 Professional CD-ről történő ügyféltelepítéshez, azzal a különbséggel, hogy a forrásfájlok egy elérhető távtelepítési kiszolgálón vannak. Akkor kell a Távtelepítést előkészítő varázsló beállítást használni, ha az ügyfélszámítógépet úgy kell konfigurálni, hogy megfeleljen a szervezet egyedi, az asztali számítógépekre vonatkozó speciális vállalati előírásainak. További tudnivalók a Telepítési programkód létrehozása című részben találhatók.

Az ügyfélszámítógép hálózaton keresztül történő rendszertöltésre vonatkozó kérését kezdeményezheti a rendszer BIOS vagy a Net PC/PC98 előtti ügyfélszámítógépekhez biztosított speciális távoli rendszertöltő lemez. További tudnivalók a A távtelepítési szolgáltatás indítólemeze című témakörben találhatók. Hálózaton keresztül történő rendszertöltés kérésekor az ügyfélszámítógép fogad egy IP-címet a DHCP protokoll közvetítésével. A távtelepítési szolgáltatás válaszol a rendszertöltéskérésre, és letölti az Ügyféltelepítő varázslót. Miután a felhasználó bejelentkezett, egy menü jelenik meg a felhasználó testreszabott telepítési beállításaival, amelyeket a Csoportházirend beállításai határoznak meg.

Távtelepítési kiszolgáló
A távtelepítési kiszolgáló a következő összetevőket tartalmazza:
  • Ügyféltelepítő varázsló. Lépésről lépésre végigvezeti a felhasználót az ügyfélszámítógépek számára elérhető telepítési lehetőségeken. További tudnivalók erről az összetevőről az Ügyféltelepítő varázsló című témakörben találhatók.
  • Távtelepítést előkészítő varázsló Biztosítja a lehetőséget egy meglévő – a helyileg telepített alkalmazásokat és a megadott telepítési beállításokat is tartalmazó – Windows 2000 Professional telepítés előkészítésére és a programkód replikálására a hálózaton egy meglévő távtelepítési kiszolgálóhoz.
  • Távoli rendszertöltő lemez. Lehetővé teszi a távoli rendszertöltést engedélyező PXE hálózati csatolóval nem rendelkező ügyfélszámítógépek számára a hálózati szolgáltatások kérését a kiszolgálóról. További tudnivalók a A távtelepítési szolgáltatás indítólemeze című témakörben találhatók.
  • A távtelepítési szolgáltatás felügyelete. Lehetőséget biztosít a távtelepítési kiszolgáló konfigurálására tulajdonságlapok használatával.

Ha a távtelepítési szolgáltatás engedélyezett, akkor a következő szolgáltatások automatikusan a kiszolgálóra kerülnek:

Rendszertöltési információs egyeztetési réteg (BINL):
Ez a szolgáltatás figyeli az ügyfelek hálózati szolgáltatáskéréseit és biztosítja a távtelepítési szolgáltatás környezetének általános kezelését. A BINL-szolgáltatás ügyel arra, hogy az ügyfél a megfelelő fájlokat kapja meg, a távtelepítésre beállított ügyfél esetén pedig biztosítja, hogy azt a megfelelő távtelepítési kiszolgáló szolgálja ki. Ha az ügyfélszámítógép nincs távtelepítésre beállítva, akkor a BINL létrehozza az ügyfélszámítógép fiókját az Active Directoryban.
Trivial File Transfer Protocol Daemon (TFTPD):
A távtelepítési kiszolgáló a távtelepítés folyamatának elindításához szükséges kezdeti fájlok letöltésére használja ezt a szolgáltatást. Az ügyfélre a TFTPD használatával leggyakrabban letöltött fájl a Startrom.com, amely a Windows 2000 ügyfélszámítógép rendszerindításáért felelős. Új ügyfél esetén a távtelepítési folyamat elindításához letöldődik az OSChooser.
Egypéldányos tároló (SIS):
Az egypéldányos tároló a távtelepítési szolgáltatás kötetén szükséges összes tárolás csökkentésére szolgáló módszer. A SIS-illesztőprogramok tartalmaznak egy SIS-rendszerező ügynököt, amely megkeresi a duplikált fájlokat a távtelepítési szolgáltatás kötetén. Ha a rendszerező ügynök duplikátumokat talál, akkor az eredeti fájlt a SIS-tárolóba másolja, és a helyén hagy egy hivatkozást. A hivatkozásfájl az eredeti fájlról tartalmaz információkat, például a jelenlegi helyét (SIS-tároló), a méretét és az attribútumait. Ha egy új távtelepítést előkészítő programkód duplikált fájlokat tartalmaz, akkor minden duplikátum a tárolóba lesz másolva, hogy csökkenjen a távtelepítési kiszolgálón elfoglalt lemezterület.

Megjegyzés

  • A \\Kiszolgálónév\Megosztásnév\reminst\Setup\Nyelv\Images
    mappán kívül tárolt és csatlakozási pontokon keresztül hivatkozott, telepítési adatokat tartalmazó telepítési programkódokra a SIS-rendszerező ügynök működése nincs hatással. Ezeket a telepítési programkódokat egy NTFS fájlrendszerre formázott meghajtóra kell telepíteni.


PXE-architektúra

A távtelepítési szolgáltatás az ügyfélszámítógép rendszerindításának PreBoot eXecution Environment (PXE) architektúráját követő Dynamic Host Configuration protokollt (DHCP) használja. Amikor az új távoli rendszerindításra alkalmas PXE ügyfélszámítógép először indul el, az ügyfél a DHCP protokoll segítségével Internet protokoll (IP) címet kér, valamint egy aktív távtelepítési szolgáltatás IP-címét. A kezdő kérés részeként az ügyfél elküldi a globálisan egyedi azonosítóját (Globally Unique Identifier – GUID), amely az ügyfélszámítógép az Active Directoryban történő egyértelmű azonosítására szolgál.

Az ügyfélszámítógép az ügyfelet kiszolgáló rendszerindító kiszolgáló IP-címe mellett kap egy IP-címet is. Az ügyfél ezután megkapja annak a rendszerbetöltési programkódnak a nevét, amelyet a rendszerbetöltési kiszolgálótól a kezdeti szolgáltatás igénylésekor kért. Windows 2000 Server esetén az ügyfélkérés megtörténte után az első válaszadó távtelepítési kiszolgáló ellenőrzi a címtárszolgáltatást, és eldönti, hogy az ügyfél fel lett-e készítve. A távtelepítési szolgáltatás oly módon teszi ezt meg, hogy az Active Directoryban ellenőrzi, hogy létezik-e olyan számítógépfiók-objektum (Computer Account Object – CAO), amelynek GUID azonosítója egyezik az ügyfél által a kezdeti távtelepítési szolgáltatást igénylő kérésben küldött azonosítóval. Ha nem létezik ilyen GUID azonosítóval rendelkező számítógépfiók, a kiszolgáló futtatja az ügyfél számítógépén az Ügyféltelepítő varázslót, amely kéri, hogy a felhasználó csatlakozzon a hálózatra.


A távtelepítési szolgáltatás címtárszolgáltatásának megtervezése

A távtelepítési szolgáltatás munkakörnyezetének működése egy ésszerűen kialakított és megtervezett Active Directory architektúrán alapul. A kiszolgálók tényleges helyének meghatározása rendszerint nehéz feladat, különösen akkor, ha több, különböző helyiségben, emeleten vagy netán épületben elhelyezett kiszolgálóra van szükség. Az Active Directory egy adott tartományban olyan szervezeti egységeket (más néven tárolókat) biztosít, amelyekkel a felhasználók és erőforrások logikai felügyeleti csoportokba rendezhetők.

Ha a szóban forgó kiszolgáló tartományvezérlőként működik, akkor a távtelepítési szolgáltatás kiszolgálójaként azonosított számítógép-objektum a tartományvezérlő mappában található. A rendszergazda innen önállóan működő távtelepítési kiszolgálókat kezelhet: felügyelheti az ügyfélszámítógépek kiszolgálását, ellenőrizheti a kiszolgálókat, ügyfélszámítógépeket kereshet, valamint meghatározhatja az operációs rendszer telepítési beállításait.

Megjegyzés

  • Ha a távtelepítési szolgáltatás kiszolgálója valamely tartomány tagkiszolgálója, akkor a számítógépfiók-objektum a Számítógépek tárolóban található.


A távtelepítési szolgáltatás rendszerkövetelményei

Ez a témakör a távtelepítési szolgáltatásra alkalmas kiszolgálók, ügyfélszámítógépek és hálózati csatolók rendszerkövetelményeit mutatja be.

A kiszolgáló hardverkövetelményei

  • Pentium (legalább 166 MHz-es), illetve 200 MHz-es Pentium II vagy gyorsabb processzorral felszerelt személyi számítógép.
  • Minimálisan javasolt: 256 MB RAM (legalább 128 MB; maximum 4 GB).
  • A távtelepítési kiszolgálók könyvtárszerkezete számára 2 GB merevlemez.
  • 10 vagy 100 MB/másodperc sebességű hálózati csatoló (100MB/s ajánlott).
  • CD-ROM-meghajtó.

Az ügyfélszámítógép hardverkövetelményei

  • Pentium 166 MHz vagy gyorsabb processzorral rendelkező Net PC ügyfélszámítógép.
  • Minimum 32 MB RAM, 64 MB javasolt.
  • Egy 800 MB méretű lemezmeghajtó.
  • .99c vagy újabb verziójú PXE DHCP alapú rendszerbetöltő ROM.

Támogatott ügyfél-hálózatikártyák

A távtelepítési szolgáltatás által támogatott hálózati csatolók listáját a Rbfg.exe segédprogram futtatásával tekintheti meg. További információ a Távoli rendszertöltő lemez létrehozása című témakörben található.

Megjegyzések

  • Ne feledje, hogy a távtelepítési szolgáltatáshoz jelentős mennyiségű lemezterületre van szükség. A távtelepítési szolgáltatás könyvtárszerkezetének egy egész merevlemez-partíciót kell szentelnie.
  • A távtelepítési szolgáltatást nem lehet ugyanarra a meghajtóra telepíteni, ahol a rendszerkötet található.
  • A távtelepítési szolgáltatásnak helyet adó kötetnek NTFS fájlrendszerűnek kell lennie.
  • A távtelepítési szolgáltatás nem támogatja titkosító fájlrendszert (Encrypting File System – EFS) és az elosztott fájlrendszert (Distributed File System – DFS).
  • A Windows 2000 hardverkompatibilitási listája (Hardware Compatibility List – HCL) olyan rendszerek és hardverek felsorolását tartalmazza, amelyeket a Windows 2000 operációs rendszerrel alaposan teszteltek stabilitás és kompatibilitás szempontjából. A Microsoft Technikai Tanácsadó szolgáltatások e lista alapján határozza meg, hogy egy adott rendszert támogat-e a Windows 2000 operációs rendszer.
  • A HCL legfrissebb verziója a World Wide Weben lévő Microsoft webhelyen található.(http://www.microsoft.com/)


A távtelepítési szolgáltatás indítólemeze

A távtelepítési szolgáltatás indítólemezét olyan ügyfélszámítógépek esetén kell használni, amelyek nem tartalmaznak távoli rendszertöltő ROM memóriát. A rendszertöltő lemez szimulálja a PXE rendszertöltési folyamatot azokon a számítógépeken, amelyek nem tartalmaznak távoli rendszertöltő ROM memóriát. További tudnivalók a PXE rendszertöltési folyamatról a PXE architektúra című témakörben találhatók.

A rendszertöltő lemez hasonlóan működik a rendszertöltő ROM memóriához, amely a távtelepítési szolgáltatás kiszolgálójáról telepíti az operációs rendszert. A Windows 2000 Server rendszerben található távoli rendszertöltő lemezt létrehozó segédprogram (Rbfg.exe) a következő mappában található:
\\Kiszolgálónév\Megosztásnév\REMINST\Admin\I386\Rbfg.exe

A távoli rendszertöltő lemezt az indítási folyamat közben kell behelyezni az ügyfélszámítógépbe. Az ügyfélszámítógépnek rendelkeznie kell támogatott hálózati csatolóval. A rendszertöltő lemezt létrehozó segédprogram használatával megtudhatja, hogy milyen hálózati csatolótípusokat támogat a távtelepítési szolgáltatás. További tudnivalók a Távoli rendszertöltő lemez létrehozása című témakörben találhatók.

Hálózaton keresztül történő rendszertöltés kezdeményezéséhez is használható a távoli rendszertöltő lemez. További tudnivalók a Hálózaton keresztül történő rendszerindítás című témakörben találhatók.


Hálózaton keresztül történő rendszerindítás

Hálózaton keresztüli szolgáltatásindítást távindítással indítható PXE-ügyfélszámítógép felhasználója vagy speciális, Net PC vagy PC98 rendszerű számítógépekhez készített távoli rendszertöltő lemez kezdeményezhet. A hálózaton keresztül történő szolgáltatásindításra irányuló kérelmet a felhasználó az F12 funkcióbillentyű megnyomásával aktivizálja akkor, amikor erre az ügyfélszámítógép annak indítási folyamata közben felszólítja. Hálózaton keresztüli szolgáltatásindítás kérelmezése esetén az ügyfélszámítógép DHCP-kiszolgálón keresztül kap IP-címet, és letölti az Ügyféltelepítő varázslót. További információt a PXE-architektúra című témakörben talál.

Az Ügyféltelepítő varázsló telepítőfolyamatának elején a rendszer felhasználónév, jelszó és tartománynév megadását kéri a felhasználótól. A távtelepítési szolgáltatás az Active Directory Csoportházirend alkalmazásával határozza meg, hogy a felhasználónak mely telepítési lehetőségek és beállítások felelnek meg. A rendszer ezt követően felsorolja a felhasználó által választható telepítési lehetőségeket, attól függően, hogy a felhasználó milyen hitelesítő adatokkal vagy biztonságicsoport-tagsággal rendelkezik.


Telepítési programkód létrehozása

A Távtelepítést előkészítő varázslóval a már telepített Windows 2000 Professional előkészítését végezheti el, és az így kapott programkódot egy megfelelő, hálózati távtelepítési kiszolgálóra replikálhatja.

A programkód-konvertáló folyamat az alábbi lépésekből áll:

  1. A távtelepítési szolgáltatás segítségével végezze el az alapszintű Windows 2000 Professional operációs rendszer távtelepítését.
  2. Telepítse azokat az alkalmazásokat, amelyek nem kötődnek a Windows Installer technikához.
  3. Állítsa be a forrásszámítógépet úgy, hogy az bármely, az igénybe venni kívánt alkalmazásokkal kapcsolatos, asztali számítógépekre vonatkozó vállalati előírásnak megfeleljen. Előfordulhat például, hogy meg kíván adni bizonyos képernyőszíneket, a háttérképet egy vállalati emblémára kívánja cserélni, el kívánja távolítani az alapszintű operációs rendszer által esetleg telepített játékokat, és meg kívánja adni az Internet Explorer proxybeállításait.
  4. Zárjon be minden alkalmazást, és futtassa a Távtelepítést előkészítő varázslót. További információ a Programkód létrehozása a Távtelepítést előkészítő varázslóhoz című témakörben található.
  5. A varázsló általános állapotúra konfigurálja a forrásszámítógépet, eltávolítva mindent, ami kizárólag az ügyféltelepítéssel kapcsolatos, például a számítógép egyéni biztonsági azonosítóját (Secure ID – SID), a számítógépnevet és a rendszerleíró adatbázis azon beállításait, amelyek csak az ügyfélszámítógépre vonatkoznak.
  6. A varázsló kéri Öntől a programkód-konvertálási folyamathoz szükséges telepítési információkat. Ezen információkba többek között a következők tartoznak bele: az ügyfél számára készült telepítési programkód replikálásának helye, azon mappa neve, amelybe azt a kiszolgálón másolni kell, egy ismertető szöveg és a hozzá kapcsolódó súgószöveg, amely bemutatja a telepítési programkódot az Ügyféltelepítő varázslót futtató felhasználóknak.
  7. A replikáció végeztével a telepítési programkód automatikusan hozzáadódik a telepíthető operációs rendszerek listájához, és elérhetővé válik azon ügyfélszámítógépek számára, amelyek a távoli rendszerindítási technikát használnak.

A Távtelepítést előkészítő varázsló egyik fontos szolgáltatása, hogy a távoli rendszertöltésre alkalmas számítógépnek nem kell a telepítési programkód létrehozására használt forrásszámítógéppel azonos hardvereszközökkel rendelkeznie. A Távtelepítést előkészítő varázsló a Windows 2000 Plug and Play szolgáltatása segítségével észleli a telepítési folyamat során a forrás- és a célszámítógép közötti esetleges különbségeket.

Megjegyzések

  • Ezt az eljárást csak Rendszergazda jogosultságok birtokában tudja elvégezni.
  • Az egyes telepítési programkódok ismertető szövegeinek és súgószövegeinek hossza korlátozza az ügyfélszámítógép szempontjából választható telepítési programkódok számát. Az ügyfélszámítógépek által választható telepítési programkódok száma általában 12 és 20 között van.
  • Az ügyfélszámítógépek számára elérhető telepítési lehetőségeket a telepítési programkódokhoz tartozó .sif fájlokra vonatkozó hozzáférési engedélyek megadásával lehet szabályozni. További tudnivalók a Fájl vagy mappa engedélyeinek beállítása, megjelenítése, módosítása vagy megszüntetése című témakörben találhatók.
  • A Windows 2000 Professional az egyetlen olyan operációs rendszer, amelynek telepítési programkódja replikálható. A Távtelepítést előkészítő varázsló jelenleg egyetlen partícióra telepített Windows 2000 Professional egy távtelepítési kiszolgálóra történő replikálását teszi lehetővé. Ehhez arra van szükség, hogy a Windows 2000 Professional operációs rendszer és minden, a szabványos telepítési programkódot kitevő alkalmazás a forrásszámítógép egyetlen partícióján legyen.
  • A varázsló csak a már elérhető, távtelepítésre alkalmas kiszolgálókra történő forrásprogramkód másolását teszi lehetővé. Jelenleg a forrás más meghajtókra vagy médiatípusokra történő replikálása nem lehetséges.
  • A titkosított fájlok nem replikálhatók.
  • A célszámítógép kapacitásának a forrásszámítógép kapacitásával egyenlőnek vagy annál nagyobbnak kell lennie.
  • A célszámítógép lemez-előkészítése azonos a forrásszámítógép lemez-előkészítésével, és az esetleges megmaradó lemezterület formázásra kerül. Ha a forrásszámítógép lemezén például 1 GB szabad lemezterület van, a célszámítógép lemezkapacitása pedig 2 GB, akkor a rendszer a célszámítógépen lévő teljes 2 GB lemezterületet formázza.
  • A számítógép rendszerleíró adatbázisában a Távtelepítést előkészítő varázsló futtatása előtt végrehajtott módosítások nem jelennek meg a telepítési programkódban.
  • A RIprep telepítési programkód a forrásszámítógép fájlallokációs táblájának (File Allocation Table – FAT) méret és partíció tulajdonságait tárolja. Ha például egy 2 GB FAT méretű forrásszámítógépről hoz létre telepítési programkódot, majd a programkódot egy 4 GB méretű merevlemezzel rendelkező ügyfélszámítógépre másolja, a telepítéskor a rendszer a meghajtót 4 GB méretű FAT32 partícióként fogja formázni. A célszámítógép fájlrendszer típusának módosulását a FAT fájlrendszer korlátai okozzák. További információ a Windows fájlrendszerek című témakörben található.
  • A telepítési programkódhoz tartozó .sif fájlban tárolt adatok módosításával a merevlemez formázásának méretét olyan méretűre korlátozhatja, mint amilyen az a telepítési programkód létrehozására használt számítógépen. Nyissa meg például a \\REMINST\Setup\Megfelelő nyelv\Images\Megfelelő programkódnév\I386\Templates\Ristndrd.sif mappában található Ristndrd.sif fájlt, és módosítsa a UseWholeDisk paramétert oly módon, hogy az a NO értéket kapja. Amikor az ügyfélszámítógép telepíti ezt a programkódot, a lemez oly módon kerül formázásra, hogy a forrásszámítógép kapacitásával egyezzen, a célszámítógép fölösleges kapacitása pedig nem lesz formázva.
  • Amikor a Távtelepítést előkészítő varázsló segítségével olyan ügyfélszámítógép telepítési programkódját hozza létre, amelyre eredetileg a Windows 2000 Professional kereskedelmi verzióját telepítették, a távtelepítési szolgáltatás (Remote Installation Services – RIS) felügyelet nélküli telepítést elősegítő fájlját módosítani kell, azaz bele kell írni a termékazonosító számot (PID). A PID a Windows 2000 operációs rendszer egyes példányaihoz tartozó egyedi azonosító szám.

    • Ha a PID nem kerül bele a .sif fájlba, a telepítési folyamat meg fog állni, és a RIPrep programkód telepítése során kérni fogja a felhasználótól a termékazonosítót. Úgy kerülheti el, hogy a program a felhasználóktól kérje a PID azonosítót, hogy az ehhez a telepítési programkódhoz tartozó .sif fájl UserData szakaszába beírja a termékazonosítót. Írja be például a következőt (a kötőjelekkel és az idézőjelekkel együtt) a .sif fájl UserData szakaszába:

    ProductID = „xxxxx-xxx-xxxxxxx-xxxxx”

    A Windows 2000 Professional operációs rendszer minden egyes példánya tartalmazza a termék egyedi azonosító számát (PID). A PID segítségével lehet egyértelműen azonosítani az operációs rendszert, és számon tartani a szervezetben telepített példányokat. A termék típusától függően (Kereskedelmi, Select vagy OEM) mást-mást tapasztalhat a felhasználó, amikor a Távtelepítést előkészítő varázsló telepítési programkódját egy távtelepítési kiszolgálóról telepíti.

    • Kereskedelmi CD-ről létrehozott telepítési programkód Módosítsa RIPrep.sif fájlt, ezáltal elkerülheti, hogy a telepítési folyamat leálljon, és arra kérje a felhasználót, hogy írja be a termékazonosítót, amikor a Windows 2000 Professional CD kereskedelmi változatát használó forrásszámítógépre telepíti az operációs rendszert. Írja be a Windows 2000 Professional érvényes PID számát a \\REMINST\Setup\megfelelő_nyelv\Images\megfelelő_programkódnév\I386\Templates\Riprep.sif mappában található RIPrep.sif fájl UserData szakaszába. Minden egyes ügyféltelepítés PID azonosítója a RIPrep.sif fájlba beírt PID használatával, véletlenszerűen jön létre.
    • Select vagy OEM CD-ről létrehozott telepítési programkód Amikor a forrásszámítógép operációs rendszere a Windows 2000 Professional CD Select vagy OEM verziójáról lett telepítve, nem kell módosítani a PID azonosítót a .sif fájlban.
  • A replikált telepítési programkódokat nem lehet módosítani.
  • A forrásszámítógép leáll, amikor a programkód replikálása véget ér.
  • A gyorsított Telepítő program automatikusan fut, amikor a forrásszámítógépet újraindítják. A telepítő folyamat befejezésével ezen ügyfélszámítógépről is létre lehet hozni egy újabb telepítési programkódot.
  • A távtelepítési szolgáltatással létrehozott vagy telepített Microsoft szoftvereknek megfelelő licenccel kell rendelkezniük. A távtelepítési szolgáltatás segítségével létrehozott vagy telepített egyéb szoftverek minden példányának is jogtisztának kell lennie; a licenctulajdonos felelőssége, hogy jogtiszta módon hozza létre az említett másolatokat.


A távtelepítési szolgáltatás használata

A rész tartalma:

  • Távtelepítési kiszolgáló engedélyezése
  • Szükséges engedélyek
  • A telepítő varázsló futtása
  • A távtelepítési szolgáltatás felügyelete
  • Ügyfélszámítógépek
  • Speciális beállítások
  • A távtelepítés folyamata


Távtelepítési kiszolgáló engedélyezése

Ez a szolgáltatás megakadályozza, hogy a jogosulatlan távtelepítési kiszolgálókat olyan hálózathoz adják hozzá, ahol Windows 2000 operációs rendszer és Active Directory van használatban.

A távtelepítési kiszolgáló engedélyezését a DHCP kiszolgálókezelő-konzol segítségével lehet elvégezni. E konzollal lehet mind a DHCP-, mind a RIS-kiszolgálókat engedélyeztetni annak érdekében, hogy hálózati szolgáltatásokat nyújthassanak. További tudnivalók a DHCP-kiszolgáló engedélyezése az Active Directoryban című témakörben találhatók.

Amikor egy távtelepítési kiszolgáló megkísérli működésének megkezdését a hálózaton, az Active Directory kérést kap, és a kiszolgáló számítógépnevét vagy IP-címét összeveti az engedélyezett távtelepítési kiszolgálók listájával. Ha megtalálja a listán, a távtelepítési kiszolgáló engedélyt kap, és megkezdheti a hálózati működését. Ha nem találhatót, a kiszolgáló nem kap engedélyt. Ebben az esetben a távtelepítési szolgáltatás nem fog reagálni.


Szükséges engedélyek

Új számítógépfiók az Active Directoryban történő létrehozásához a felhasználóknak a hozzájuk tartozó jogosultságokkal és engedélyekkel kell rendelkezniük – erről bővebben A felhasználók által létrehozott számítógépfiókokra vonatkozó engedélyek beállítása című témakör szól.

Új számítógépfiókok a tartományhoz történő csatlakozásához a felhasználóknak a hozzájuk tartozó jogosultságokkal és engedélyekkel kell rendelkezniük – erről bővebben A felhasználók által létrehozott számítógépfiókokra vonatkozó engedélyek beállítása című témakör szól.

Megjegyzés

  • A rendszergazdának kell megadnia, hogy mely felhasználók hozhatnak létre új ügyfélszámítógép-fiókokat, és a felhasználói jogosultságokat és engedélyeket ennek megfelelően kell megadnia.


A telepítő varázsló futtása

A Távtelepítési szolgáltatást telepítő varázsló futtatása előtt Rendszergazdai jogokkal kell rendelkeznie, és a Feladatlista: A távtelepítési szolgáltatás telepítése oldalon leírt minden feladatot el kell végeznie.

Amikor a távtelepítési szolgáltatást a Windows 2000 Server telepítési folyamata során választható összetevőként kijelöli, a telepítő varázsló végigkalauzolja Önt a telepítés és a konfigurálás szükséges lépésein.

A telepítő varázsló az alábbi lehetőségeket kínálja fel:

  • Válasz ügyfélszámítógépek szolgáltatáskérelmére. Jelölje be ezt a jelölőnégyzetet, ha azt kívánja, hogy a kiszolgáló minden szolgáltatást igénylő ügyfélnek válaszoljon, és rendelkezésükre bocsássa az operációs rendszer telepítési lehetőségeit. Ha nem jelöli be, a távtelepítő kiszolgáló nem válaszol a szolgáltatást igénylő ügyfeleknek.
  • Ismeretlen ügyfeleknek nincs válasz. E jelölőnégyzet bejelölésével határozhatja meg, hogy ez a kiszolgáló válaszoljon-e olyan ismeretlen ügyfélszámítógépeknek, amelyek távtelepítési kiszolgálóhoz fordulnak. Az ügyfélszámítógép akkor számít ismertnek, ha rendelkezik az Active Directoryban létrehozott számítógépfiók-objektummal (computer account object – CAO). E jelölőnégyzet bejelölésével lehet megadni, hogy a szolgáltatásokban csak engedéllyel rendelkező ügyfélszámítógépek részesülhessenek. Az ügyfélszámítógépek akkor számítanak engedéllyel rendelkezőnek, ha létezik számítógépfiókjuk az Active Directoryban.
  • Kéri a Windows 2000 Professional telepítési fájljainak helyét. Ez lehet a Windows 2000 Professional CD-lemezen vagy a telepítőfájlokat tároló hálózati helyen.
  • Kéri annak a könyvtárnak a nevét, ahová a Windows 2000 Professional telepítőfájljait a távtelepítési kiszolgálón másolni kell. Célszerű a könyvtárnak olyan nevet adni, amely a másolt operációs rendszerre utal – például Win2000.pro.
  • Kéri az operációs rendszer telepítési programkódjához tartozó ismertető szöveget és súgószöveget. A távoli rendszerindításra alkalmazás ügyfélszámítógépen folyó telepítési folyamat során a felhasználók számára ez az ismertető szöveg és súgószöveg jelenik majd meg. Írjon be egy olyan ismertetést, amely tájékoztat az operációs rendszer telepítéséről – ha például az operációs rendszert az értékesítési osztálynak szánja, akkor az ismertető szöveg lehet a következő: Windows 2000 Professional az Értékesítési osztály számára. A súgószöveg akkor jelenik meg, amikor a felhasználó az Ügyféltelepítő varázslóban kiválaszt egy ismertető szöveget.
  • A telepítő varázsló megjeleníti a telepítési folyamat összefoglaló információit. A beállítások megváltoztatásához kattintson a Vissza gombra.

Megjegyzés

  • A távtelepítési szolgáltatást a Windows 2000 telepítése után is telepítheti a Programok telepítése/törlése segédprogram segítségével. Nyissa meg a Programok telepítése/törlése párbeszédpanelt.


A távtelepítési szolgáltatás felügyelete

A rész tartalma:

  • A távtelepítési szolgáltatás felügyelete – áttekintés
  • Ügyfelektől érkező szolgáltatáskérelmek megválaszolása


A távtelepítési szolgáltatás felügyelete – áttekintés

A távtelepítési szolgáltatást az Active Driectory ablakban található konkrét objektumok tulajdonságlapjain lehet kezelni.

A tulajdonságlapok megtekintéséhez kattintson az egér jobb gombjával a kezelni kívánt kiszolgálóobjektumra, majd a helyi menüben kattintson a Tulajdonságok parancsra. A távtelepítési szolgáltatás beállításával kapcsolatos további tájékoztatás A távtelepítési szolgáltatás beállítása című témakörben található.

A távtelepítési szolgáltatás tulajdonságlapon a következő beállítások adhatók meg:

Ügyfelek támogatása

Megadhatja, hogy a kiszolgálók minden ügyfél, vagy csak az ismert ügyfelek szolgáltatáskérelmére válaszoljanak. További tudnivalók az Ügyfelektől érkező szolgáltatáskérelmek megválaszolása című témakörben találhatók.

Kiszolgáló ellenőrzése

E gombra kattintva a távtelepítési kiszolgáló tulajdonságait ellenőrizheti.

Akkor használja ezt a lehetőséget, ha a kiszolgáló vélhetően nem működik megfelelően, szokatlan jelenségeket tapasztal a működése során, vagy ha a távtelepítési szolgáltatás kötetét biztonsági másolatról kell visszaállítani. A gomb megnyomásakor egy varázsló indul el, amely ellenőrzi, hogy minden beállítás, szolgáltatás és konfigurációs lehetőség megfelelően van beállítva és működik.

További információ A távtelepítési szolgáltatás beállításainak ellenőrzése című témakörben található.

Fontos

  • Ha azért ellenőrzi a kiszolgáló beállítását, mert a távtelepítési szolgáltatás kötetét biztonsági másolatról kell helyreállítania, kiszolgáló beállításait a kötet helyreállítása előtt ellenőrizze.

Megjegyzés

  • E beállítási lehetőség használata előtt készítse elő a Windows 2000 Server és a Windows 2000 Professional telepítőlemezeit. A számítógép kérheti azokat a kiszolgáló ellenőrzése során.
Ügyfelek mutatása

E gombra kattintva megkeresheti az Active Directoryban lévő, távtelepítési szolgáltatást használó ügyfeleket.

Ha ide kattint, megjelenik a kiszolgálóhoz tartozó ügyfélszámítógépek listája GUID (Globally Unique Identifier – globálisan egyedi) azonosítójuk alapján rendezve. A listán a kiszolgáló által az operációs rendszer telepítésére előkészített számítógépek is szerepelnek.

További tudnivalók az Ügyfélszámítógépek című témakörben találhatók.

Speciális beállítások

E gombra kattintva az ügyfélszámítógép telepítésének módját adhatja meg. A speciális beállítási lehetőségek a következők:

  • Automatikus ügyfélszámítógép-fiókelnevezési formátum
  • Az ügyfélszámítógép-fiókok helye az Active Directoryban
  • Az adott távtelepítési kiszolgálón található telepítési programkódok és operációs rendszer előtti karbantartási eszközök kezelése
    •

További tudnivalók a Speciális beállítások című témakörben találhatók.


Ügyfelektől érkező szolgáltatáskérelmek megválaszolása

Meghatározhatja, hogy a távtelepítési kiszolgáló hogyan válaszoljon az ügyfélszámítógépek szolgáltatáskérelmeire.

  • Válasz az ügyfélszámítógépek szolgáltatáskérelmére E jelölőnégyzet bejelölésével engedélyezi a távtelepítési szolgáltatást, és az felelni fog a szolgáltatás igénylő ügyfélszámítógépeknek.
  • Ismeretlen ügyfeleknek nincs válasz E jelölőnégyzet bejelölése esetén a távtelepítési szolgáltatás csak az ismert ügyfélszámítógépeknek fog válaszolni.


Ügyfélszámítógépek

A rész tartalma:

  • Ügyfélszámítógépek keresése
  • Ügyfélszámítógépek tulajdonságai


Ügyfélszámítógépek keresése

Minden egyes ügyfélszámítógépet annak globálisan egyedi azonosítójával (GUID) lehet azonosítani. Az Ügyfelek mutatása szolgáltatással és az egyes gépek GUID-azonosítója segítségével megkeresheti az Active Directoryban lévő, a távtelepítési szolgáltatást használó ügyfélszámítógépeket. Az Ügyfelek mutatása szolgáltatás az aktuális távtelepítési kiszolgálóhoz előzőleg beállított összes ügyfélszámítógépet megkeresi. A keresési folyamat kiterjedhet az Active Directory egészére, vagy csupán egy adott tartományra is. Az Ügyfelek mutatása szolgáltatással végrehajtott keresési folyamat felsorolja a feltételeknek megfelelő ügyfélszámítógépeket, és számítógépnevük, illetve GUID-azonosítójuk alapján rendezve jeleníti meg őket. A globálisan egyedi azonosítókról (GUID) az Ügyfélszámítógépek globálisan egyedi azonosítójának (GUID) megállapítása című témakör nyújt további információt.

Az Ügyfelek mutatása szolgáltatással végrehajtott keresési művelet helyettesítő karakteres keresési attribútumot rendel az aktuális távtelepítési kiszolgáló számítógépnevéhez. Ha a távtelepítési kiszolgáló neve például RISsvr1, az Ügyfelek mutatása szolgáltatás az RISsvr1* nevet rendeli a kiszolgáló nevéhez. Amennyiben az Ügyfelek mutatása szolgáltatást több, távtelepítési kiszolgálót futtató környezetben használja, a keresési eredmények között több kiszolgáló ügyfélszámítógépei is szerepelhetnek. Ha több távtelepítési kiszolgálót üzemeltet, és azok számítógépnevei például RISsvr1, RISsvr10 és RISsvr100, a keresési eredményekben szerepelni fognak minden kiszolgáló azon ügyfélszámítógépei, amelyek neve ugyanezekkel a számítógépnevekkel kezdődik.

Az Active Directoryban található, távtelepítést használó ügyfélszámítógép-fiókokat számítógépnevük vagy globálisan egyedi azonosítójuk (GUID) alapján is megkeresheti. Az Ügyfélszámítógépek keresése oldalon az ügyfélszámítógépek keresését ismertető lépéseket találja meg.

Megjegyzés

  • Az ügyfélszámítógépek keresését egy adott távtelepítési kiszolgálóra korlátozhatja, ha a kiszolgáló nevét beírja az RI-kiszolgáló mezőbe.


Ügyfélszámítógépek tulajdonságai

A távtelepítési szolgáltatás tulajdonságlapokon tárolja a távtelepítési szolgáltatást igénybe vevő ügyfélszámítógépekkel kapcsolatos információkat. Ezeket az információkat úgy tekintheti meg, ha a távtelepítési szolgáltatás kiszolgálójának tulajdonságlapjai között található Távtelepítés lapon lévő Ügyfelek mutatása gombra vagy jobb egérgombbal az Active Directory - felhasználók és számítógépek konzolfán az adott ügyfélszámítógépekre kattint.

A számítógép egyedi azonosítója (GUID/UUID) Az egyedi azonosítót az ügyfélszámítógép gyártója mellékeli a géphez.

Megjegyzések

  • A globálisan egyedi (GUID) és az univerzálisan egyedi azonosító (UUID) {dddddddd-dddd-dddd-dddd-dddddddddddd} formátumú kell, hogy legyen, ahol d hexadecimális szöveges számjegyet jelöl.

    Például: 8 hexadecimális szöveges számjegy, amelyet 4, 4, 4, majd 12 szöveges számjegy követ: {67452301-AB89-EFCD-0123-456789ABCDEF}. A globálisan egyedi azonosító (GUID) használatáról az Ügyfélszámítógépek globálisan egyedi azonosítójának (GUID) megállapítása című témakör nyújt további információt.

  • Az ügyfél globálisan egyedi azonosítója (GUID) csak a következő számjegyeket és karaktereket tartalmazhatja:

0 1 2 3 4 5 6 7 8 9
a b c d e f - A B C D E F
  • A kötőjeleket nem kötelező megadni, a szóközöket pedig figyelmen kívül hagyja a rendszer.
  • A GUID azonosítót egybeírt formátumban is meg lehet adni. Ha az azonosítót egybeírva adja meg, a rendszer az azonosító első 16 karakterét áthelyezi. Ha a GUID azonosítót például a „0123456789ABCDEF0123456789ABCDEF” formátumban adja meg, a megjelenített eredmény

    egybeírva 01234567 89AB CDEF 0123456789ABCDEF,

    megjelenítve {67452301-AB89-EFCD-0123-456789ABCDEF}.


Speciális beállítások

A rész tartalma:

  • Speciális beállítások – áttekintés
  • Az új ügyfelekre vonatkozó speciális beállítások
  • A telepítési programkódok speciális beállításai
  • Az eszközök speciális beállításai
  • Számítógépnevek


Speciális beállítások – áttekintés

A távtelepítési szolgáltatás speciális beállítási lehetőségei meghatározzák, hogy a szolgáltatás hogyan hoz létre ügyfélszámítógép-neveket, hogyan kezeli az operációs rendszer programkódjait, és hogyan kezeli a diagnosztikai eszközök alkalmazásait.

Ezen beállításokkal kapcsolatos további információ A speciális beállítások megadása című témakörben található.


Az új ügyfelekre vonatkozó speciális beállítások

A távtelepítési szolgáltatás speciális beállításai segítségével adja meg azt a házirendet, amely minden egyes telepítést igénylő ügyfélszámítógépnek egyedi hálózati nevet ad. Az ezzel kapcsolatos tudnivalókért olvassa el a Számítógépnevek című témakört.

Az alapértelmezett címtárszolgáltatás tárolóját is használhatja az ügyfélszámítógép-fiók objektumainak tárolására. E szolgáltatás segítségével csoportosíthatja az adott Active Directory tartományba vagy szervezeti egységbe tartozó ügyfélszámítógépeket.

A Ügyfél fiókjának helye beállítási lehetőség segítségével adható meg – a tényleges telepítés előtt – minden távtelepítést igénylő ügyfélszámítógépfiók alapértelmezett Active Directory tárolója. Az alábbi három beállítási lehetőség közül választhat:

Alapértelmezett könyvtárszolgáltatás helye
Itt adható meg, hogy a tartományhoz való csatlakozás művelete során alapértelmezés szerint jöjjön létre a számítógépfiók-objektum. Az ügyfélszámítógép ugyanazon tartomány tagja lesz, mint az ügyfelet telepítő, távoli telepítésre alkalmas kiszolgáló.
Azon a helyen, ahol a felhasználó az ügyfélgépet telepíti
Megadja, hogy az ügyfélszámítógép fiókja ugyanazon Active Directory tárolóban jöjjön létre, amelyben a felhasználó az ügyfélgépet telepíti. Ha például olyan felhasználó jelentkezik be, akinek a fiókja a Felhasználók tárolóban található, az ügyfélszámítógép fiókja is a Felhasználók tárolóban jön létre.
A következő szolgáltatás helye
Itt előre megadhatja, hogy az ügyfélszámítógép fiókjai hol jöjjenek létre az Active Directoryban. Ez a beállítási lehetőség minden, az adott kiszolgálóról telepített ügyfélszámítógépet érint.

Megjegyzés

  • Az ügyfélszámítógépet telepítő felhasználónak az Active Directoryban számítógépfiók létrehozásához rendelkeznie kell a megfelelő jogokkal. A további tudnivalók A felhasználók által létrehozott számítógépfiókokra vonatkozó engedélyek beállítása című témakörben találhatók.


A telepítési programkódok speciális beállításai

A távtelepítési szolgáltatás segítségével a szolgáltatás használóinak operációsrendszer-telepítési beállításait kezelheti. A távtelepítési szolgáltatás alaptelepítésekor a program kéri, hogy a távtelepítésre alkalmas kiszolgálóra helyezze el az alapértelmezett telepítési programkódot. Ez az operációs rendszer programkódját használó telepítési módszer a Windows 2000 Professional CD tartalmát és könyvtárstruktúráját a távoli telepítésre alkalmas kiszolgálóra másolja.

A felügyelet nélküli telepítési folyamat a telepítési információkat tartalmazó fájlok (setup inforamtion file – .sif kiterjesztésű fájlok) segítségével tárolja a telepítési programkód konfigurációs beállításait. A .sif fájlban tárolt adatokat a rendszer minden egyes alkalommal feldolgozza, amikor egy ügyfél kiválasztja a telepítési programkódot az Ügyféltelepítő varázsló használatával. A telepítési programkódra vonatkozó .sif fájl módosításával előre meghatározhatja minden egyes ügyfél konfigurációs programfájljának beállításait. Ha például minden ügyfélszámítógép ugyanolyan típusú kijelzőeszközzel rendelkezik, a képernyőfelbontást a telepítés előtt megadhatja a .sif fájl Display szakaszában található adatok módosításával.

A .sif fájl módosításának másik példája annak megváltoztatása, ahogy az ügyfélszámítógép merevlemeze formázásra kerül. Az Ügyféltelepítő varázsló futása közben a felhasználó által választott telepítési programkód az ügyfélszámítógépére másolódik. A célszámítógép lemez-előkészítése azonos a forrásszámítógép lemez-előkészítésével, és az esetleges megmaradó lemezterület formázásra kerül. Ha például a forrászámítógépen lévő szabad lemezhely 1 GB, a célszámítógép lemezkapacitása pedig 2 GB, a célszámítógépen lévő teljes 2 GB formázásra kerül.

A telepítési programkódhoz tartozó .sif fájlban tárolt adatok módosításával a merevlemez formázásának méretét olyan méretűre korlátozhatja, mint amilyen az a telepítési programkód létrehozására használt számítógépen. Tegyük fel például, hogy megnyitja a Ristndrd.sif fájlt, és a UseWholeDisk paramétert NO értékre módosítja. Amikor az ügyfélszámítógép telepít ezt a programkódot, a lemezt oly módon formázza a rendszer, hogy az a forrásszámítógép kapacitásának megfeleljen. A célszámítógép merevlemezének többi része nem lesz formázva.


Az eszközök speciális beállításai

A távtelepítési szolgáltatás eszközbeállításait akkor használja, ha szeretné, hogy a független szoftverszállítók (Independent Software Vendor – ISV) és az eredeti számítógépgyártók (Original Equipment Manufacturer – OEM) a hálózati bejelentkezés szolgáltatásának igénylése során rendszerüzemeltetéssel és hibaelhárító eszközökkel álljanak a rendszergazdák, a technikai segélyszolgálat és az ügyfélszámítógépek felhasználóinak rendelkezésére. Mivel előfordulhat, hogy az ügyfélszámítógép merevlemeze az operációs rendszer telepítse előtt üres, ezek az eszközök nagyon hasznosak lehetnek. Az üzemeltetési és hibaelhárító eszközök az ügyfélszámítógépen található rendszerek, például a flash BIOS frissítését is megkönnyítik a rendszergazdák számára, az operációs rendszer telepítése előtt és után egyaránt.

A távtelepítési szolgáltatás eszközök szolgáltatás az alábbi beállítási lehetőségeket nyújtja:

Eltávolítás
Eltávolítja az aktuálisan kiválasztott eszközhöz tartozó telepítési sablonfájlt (.sif). Ez a fájl tartalmaz egy ismertető szöveget, amely leírja az eszköz célját a távoli telepítést alkalmazó ügyfélszámítógép használói számára. Ha ezt a beállítási lehetőséget választja, a sablonfájl törlődik, és az Ügyféltelepítő varázsló nem ajánlja fel az eszközt, amikor a Távtelepítési szolgáltatás ügyfelei futtatják azt.
Tulajdonságok
Ha erre a gombra kattint, megtekintheti a kiválasztott eszköz tulajdonságait. Módosíthatja a tájékoztató szöveget, és konkrét részleteket tudhat meg a kiválasztott eszközről.
Frissítés
Erre a gombra kattintva frissítheti az ablak tartalmát.

Megjegyzés

  • A Távtelepítési szolgáltatások tulajdonságai párbeszédpanelen nem adhat hozzá eszközt. Az független szoftverszállítók és az eredeti számítógépgyártók külső telepítőprogramot bocsátanak rendelkezésre, amely a saját eszközüket helyezi el a \RemoteInstall könyvtárfában. Az eszköz hozzáadás után megjelenik az Eszközök lapon, és az Ügyféltelepítő varázsló futtatása során a rendszergazdák és a felhasználók rendelkezésére áll.


Számítógépnevek

A távtelepítési szolgáltatás speciális beállításai segítségével határozhatja meg azt az elnevezési házirendet, mely minden ügyfélszámítógépnek egyedi nevet ad. Ez a név, amely segítségével az ügyfélszámítógép a hálózaton azonosítható, hasonló a Windows és a Windows NT előző verzióiban használt NetBIOS-névhez.

Az Automatikus számítógép-elnevezés beállítási lehetőség segítségével gondoskodhat arról, hogy minden számítógép megkapja a távtelepítési kérés során az egyedi nevét. Az alapértelmezés szerinti névformátum a felhasználó neve, és egy minden egyes alkalommal növekvő szám.

Létrehozhat egyéni elnevezési házirendet is, ehhez kattintson a Testreszabás gombra. Ezután az alábbi beállítási lehetőségek közül választva hozhatja létre automatikusan a számítógépnevet:

%First
A számítógép a felhasználó keresztnevét kapja.
%Username
A számítógép neve a felhasználónév lesz.
%#
A névhez egy növekvő számsor soron következő elemét csatolja a rendszer.
%Last
A számítógép a felhasználó vezetéknevét kapja.
%MAC
A számítógép neve a hálózati kártya médiaelérés-kezelési címe lesz.

Ha korlátozni kívánja a számítógépnév hosszát, írjon be egy számot a szöveg mellé. Ha például a felhasználó vezetékneve Kovács, és három karakteresre kívánja korlátozni a nevet (Kov), akkor következő karakterláncot írja be:
%3Last

A beállítási lehetőségeket kombinálni is lehet. Ha például azt szeretné, hogy a számítógépnév a felhasználó vezetéknevének első három betűjéből álljon, majd ezt a keresztneve első három betűje kövesse, a következő karakterláncot használja:
%3First%3Last%


A távtelepítés folyamata

A rész tartalma:

  • Ügyféltelepítő varázsló
  • Telepítési beállítások
  • Támogatott operációs rendszerek
  • Ügyféltelepítések vezérlése a Csoportházirend használatával


Ügyféltelepítő varázsló

A távoli rendszertöltésű ügyfélszámítógépek felhasználói használhatják az Ügyféltelepítő varázslót a telepítési beállítások, az operációs rendszerek, a karbantartási és hibaelhárító eszközök kiválasztására.

A varázsló felszólítja a felhasználót a felhasználónév, a jelszó és a tartománynév megadására. A felhasználó hitelesítő adatainak érvényesítése után a varázsló megjeleníti a felhasználó számára elérhető telepítési beállításokat. Miután a felhasználó kiválasztott egy beállítást, a program a kiválasztott operációs rendszer telepítési programkódját az ügyfél helyi merevlemezére másolja. Előre meg lehet határozni ezeket a telepítési beállításokat a távtelepítési szolgáltatás telepítésekor vagy a távtelepítést előkészítő segédprogram futtatásakor. További tudnivalók a Telepítési programkód létrehozása című részben találhatók.

Fontos

  • Mivel az ügyfélszámítógép merevlemeze az operációs rendszer telepítésekor újraformázódik, minden helyileg tárolt fájl elveszik telepítéskor.

Megjegyzés

  • A Ügyféltelepítő varázsló használatakor csak normál ASCII-karaktereket (32-től 127-ig terjedő OEM-karaktereket) használjon a felhasználónévben, a jelszóban és a tartománynévben. Az Ügyféltelepítő varázsló nem támogatja a kiterjesztett (például az ü, é stb. karaktereket tartalmazó) ASCII-karakterkészleteket.


Telepítési beállítások

Az Ügyféltelepítő varázsló egy szöveges alapú telepítő varázsló, amely végigvezeti a felhasználót a távtelepítési folyamaton. A Csoportházirend használatával megszabhatja, mely telepítési beállítások álljanak a felhasználók rendelkezésére. További tudnivalók ennek módjáról az Ügyféltelepítések vezérlése a Csoportházirend használatával című témakörben találhatók.

Az automatikus vagy az egyéni telepítés között választhat.

Automatikus telepítés

Az automatikus telepítés alapértelmezés szerint elérhető a távoli rendszertöltésű ügyfélszámítógépet telepítő felhasználók számára. Ha úgy dönt, hogy több operációs rendszer közti választást telepít a felhasználó számára, akkor a felhasználó kiválaszthatja a szükségletéhez vagy a vállalatnál betöltött szerepéhez megfelelő telepítési programkódot. A Windows 2000 Távtelepítési szolgáltatás felügyelet nélküli telepítési sablonokat használ, így a rendszergazdák határozhatják meg a felhasználó által telepített operációs rendszer programkódjának típusát. További tudnivalók a Speciális beállítások című témakörben találhatók.

Egy felügyelet nélküli telepítési információs (.sif) fájl használatával létrehozhat több telepítési beállítást egy, a távtelepítési kiszolgálón található operációsrendszer-telepítő programkód alapján. Azt is testreszabhatja, hogy mely elemek legyenek telepítve és hogy az ügyfélszámítógép beállításai hogyan legyenek konfigurálva az operációs rendszer telepítésekor. Létrehozhat például egy speciális operációsrendszer-típust, amely telepíti a TCP/IP protokollt, a képernyő felbontását 800 x 600-ra állítja, és beállítja az alapértelmezett cégnevet. Rövid leírást is adhat ehhez az operációsrendszer-típushoz, például Windows 2000 Professional az Értékesítési osztály számára. A rövid leírás szövege módosítható az ügyfélszámítógép operációs rendszerének kezdeti telepítése után. Amikor a felhasználók bejelentkeznek és kiválasztják az automatikus telepítés beállítást, akkor egy listát kapnak, amely a választható operációsrendszer-telepítési típusokat tartalmazza.

Mivel a telepítési folyamat újraformázza az ügyfélszámítógép merevlemezét, az Ügyféltelepítő varázsló figyelmezteti a felhasználót, hogy minden tárolt adat el fog veszni.

Előre definiálhatja a számítógépnevet és az ügyfélszámítógép fiókjainak helyét az Active Directoryban. További tudnivalók a Speciális beállítások című témakörben találhatók.

Egyéni telepítés

Ezzel a beállítással az operációs rendszer telepítési folyamata közben meg lehet adni a számítógépnevet és a számítógépfiók-objektum tárolóját az Active Directoryban. Az egyéni beállítást akkor kell használni, amikor egy szervezeten belül valaki más számítógépére végzi a telepítést. A távtelepítési szolgáltatást lehet úgy konfigurálni, hogy automatikusan létrehozza a számítógépneveket az operációs rendszer telepítése előtt az ügyfélszámítógépre bejelentkező felhasználó alapján.

Megkezdett telepítési kísérlet újraindítása

Ezzel a beállítással újra lehet indítani egy sikertelen operációsrendszer-telepítési kísérletet, ha a telepítési folyamat nem fejeződött be.

Karbantartás és hibaelhárítás

Hozzáférést biztosít az ügyfélszámítógépek karbantartásához és hibaelhárításához szükséges eszközökhöz. Ilyenek például a memória víruskeresői, a flash BIOS-frissítések és a számítógép-diagnosztikai segédprogramok.

Megjegyzések

  • A Windows 2000 távtelepítési szolgáltatása nem támogatja teljes mértékben a felügyelet nélküli telepítést az ISA-eszközöket tartalmazó és a Plug and Play eszközöket nem támogató számítógépeken.
  • A távoli rendszertöltésű ügyfélszámítógépet telepítő felhasználóknak nem állnak rendelkezésére telepítési választások, ha az automatikus telepítés az egyetlen telepítési beállításuk. További tudnivalók az Ügyféltelepítések vezérlése a Csoportházirend használatával című témakörben találhatók.
  • A felügyelet nélküli telepítési válaszfájlok (.sif) olyan szövegfájlok, amelyek egy telepítési programkódhoz tartozó telepítési folyamat leírását tartalmazzák. A .sif fájlt az egyik elérhető telepítési programkóddal kell társítani. További tudnivalók a felügyelet nélküli telepítési válaszfájlok létrehozásáról a Windows 2000 Resource Kit kézikönyvben találhatók.
  • Alapértelmezés szerint az Ügyféltelepítő varázsló a \RemoteInstall\OSChooser mappában tárolt Welcome.osc fájlt használja az ügyféltelepítési programkód választási lehetőségeinek kezeléséhez. A telepítési programkód többnyelvű beállításainak eléréséhez el kell távolítani a Welcome.osc fájlt, a Multilng.osc fájlnak pedig a Welcome.osc nevet kell adni. Ekkor az Ügyféltelepítő varázsló felajánlja a felhasználónak a többnyelvű választási lehetőségeket tartalmazó menüt. A Welcome.osc fájl módosításával egyedi nyelvbeállításokat is létrehozhat.


Támogatott operációs rendszerek

Az Ügyféltelepítő varázsló az operációs rendszer programkódjának két típusát támogatja: a CD alapú telepítés és a Távtelepítést előkészítő varázsló programkód-formátumát. A CD alapú telepítés hasonló a közvetlenül a Windows 2000 Professional telepítő CD-ről történő ügyféltelepítéshez, azzal a különbséggel, hogy az operációs rendszer programkódjának forrásfájljai egy elérhető távtelepítési kiszolgálón vannak. Ha a Távtelepítést előkészítő varázsló beállítást választja, akkor telepítheti a szükséges ügyfélszámítógép-alkalmazásokat, és konfigurálhatja az ügyfélszámítógép-beállításokat, például a képernyőbeállításokat és a hálózati nyomtatókat. További tudnivalók a Programkód létrehozása a Távtelepítést előkészítő varázslóhoz című témakörben találhatók.

A CD alapú programkód-formátum és a Távtelepítést előkészítő varázsló programkód-formátuma is megjelenik az elérhető telepítési beállítások listájában. A telepítési folyamat akkor kezdődik, amikor az ügyfélszámítógép felhasználója kiválasztja valamelyik beállítást az operációs rendszer programkódjához.

Megjegyzés

  • A távtelepítési szolgáltatás jelenleg csak a Windows 2000 Professional operációs rendszert támogatja.


Ügyféltelepítések vezérlése a Csoportházirend használatával

A Csoportházirend beépülő modul használatával meghatározhatja, hogy az Ügyféltelepítő varázsló mely választási lehetőségeket jelenítse meg egy adott felhasználónak vagy csoportnak. A Csoportházirend helyekre, tartományokra és szervezeti egységekre vonatkozik, és az Active Directory szolgáltatáson belül öröklődhet. A Csoportházirenddel kapcsolatos további tudnivalók a Csoportházirend – áttekintés című témakörben találhatók.

A Csoportházirend beállításai a következők:

Engedélyezés
Azoknak a felhasználóknak, akikre ez a házirend vonatkozik, rendelkezésére áll ez a telepítési beállítás.
Mindegy
A szülőtároló házirend-beállításai vonatkoznak az adott beállításra. Ha például a Mindegy beállítást választja, és az egész tartomány rendszergazdája megadott egy, a Távtelepítési szolgáltatásra vonatkozó Csoportházirendet, akkor a tartományra beállított házirend vonatkozik minden felhasználóra, akit az adott házirend érint.
Megtagadva
Azoknak a felhasználóknak, akikre ez a házirend vonatkozik nem áll rendelkezésére ez a telepítési beállítás. A Csoportházirend használatával vezérelt hozzáférés műveleteivel kapcsolatos tudnivalók a Csoportházirend megadása az ügyféltelepítési beállításokhoz című témakörben találhatók.

Az Ügyféltelepítő varázsló által felajánlott beállításokkal kapcsolatos tudnivalók a Telepítési beállítások című témakörben találhatók.


Forrásmunkák

  • Frissített technikai információ
  • Windows 2000 Resource Kit


Hibaelhárítás – Távtelepítési szolgáltatás

Mi a probléma?

Lehet, hogy a számítógépen nem a helyes PXE ROM-verzió van telepítve.

Megoldás: Távoli rendszertöltő ROM memóriát tartalmazó Net PC vagy ügyfélszámítógép indításakor a PXE ROM verziója megjelenik a képernyőn. A távtelepítési szolgáltatás a .99c vagy nagyobb verziójú PXE ROM-memóriákat támogatja, ez alól csak az a néhány eset kivétel, amikor a .99L verzióra van szükség. Ha az adott ügyfélszámítógépen telepített ROM-verzióval kapcsolatban hibák lépnek fel, újabb verziójú PXE ROM-kód beszerzésére lehet szükség. A ROM-kód újabb verzióját az eredeti berendezésgyártótól (original equipment manufacturer, OEM) szerezheti be.

Lehet, hogy az ügyfélszámítógép nem lépett kapcsolatba a távtelepítési szolgáltatás kiszolgálójával, és nem kapott IP-címet.

Megoldás: Az ügyfélszámítógép indításakor látható, ahogyan a rendszer elindítja a PXE rendszertöltő ROM-memória betöltését és inicializálását. A legtöbb PC98 számítógép, Net PC, PXE ROM alapú számítógép, illetve a távtelepítési szolgáltatás indítólemezét használó számítógép esetében a betöltés folyamata a következő:

A távoli rendszertöltő ROM betöltési sorrendje

1. lépés:
Az ügyfélszámítógép megjeleníti a „DHCP” üzenetet: ez azt jelzi, hogy az ügyfél IP-címet kér a DHCP-kiszolgálótól. Az üzenet azt is jelentheti, hogy az ügyfél kapott már IP-címet a DHCP-kiszolgálótól, és választ vár a távtelepítési kiszolgálótól. Ha ellenőrizni kívánja, hogy az ügyfél valóban kap-e IP-címet, ellenőrizze a DHCP-kiszolgálón megadott IP-címbérleteket.
Hibaelhárítás
Ha az ügyfél nem kapja meg az üzenetet, elképzelhető, hogy nem kapott IP-címet, vagy a BINL-kiszolgáló (BINL, boot information negotiation layer – rendszerindítási információegyeztetési réteg) nem válaszol. Vegye figyelembe az alábbiakat:
  • Elérhető-e a DHCP-kiszolgáló, és elindult-e a szolgáltatás? A DHCP-kiszolgálók és a távtelepítési kiszolgálók csak akkor tudnak ügyfeleket kiszolgálni, ha azokat az Active Directoryban hitelesítették. Ellenőrizze, hogy a szolgáltatás valóban elindult-e, és, hogy azok a más ügyfelek, amelyeket nem lehet távolról elindítani, kapnak-e IP-címeket ezen a szegmensen.
  • Rendelkezik-e a DHCP-kiszolgáló meghatározott IP-címtartományhatókörrel, illetve aktiválták-e azt?
  • Nincs olyan útválasztó az ügyfél és a DHCP-kiszolgáló között, amely nem engedélyezi DHCP-csomagok továbbítását?
  • Nincs hibaüzenet a DHCP-szolgáltatás rendszernaplójában található eseménynaplóban?
  • Kapnak-e IP-címeket más ügyfélszámítógépek (azaz távolról nem indítható ügyfelek) ezen a szegmensen?
2. lépés:
Miután az ügyfél megkapta az IP-címet a DHCP-kiszolgálótól, a képernyőn eddig látható üzenet „BINL” üzenetre változhat. Ez azt jelzi, hogy az ügyfél sikeresen IP-címbérletet kapott, és a távtelepítési kiszolgálóhoz történő csatlakozásra vár. Az ügyfél az időtúllépés miatt végül a „Nem érkezett rendszerindítási fájl a DHCP-, BINL- vagy a Bootp szolgáltatástól.” hibaüzenetet jeleníti meg.
Hibaelhárítás
Ha az ügyfél nem kapja meg a BINL-üzenetet, az azt jelzi, hogy az ügyfél nem kap választ a távtelepítési kiszolgálótól. Vegye figyelembe az alábbiakat:
  • Elérhető-e a távtelepítési kiszolgáló, és fut-e a távtelepítési szolgáltatás? A távtelepítési szolgáltatás kiszolgálói csak úgy működhetnek a hálózaton, ha hitelesítve vannak. Hitelesítse az Active Directoryban a Dhcpmgmt.msc beépülő modullal mind a DHCP-, mind pedig a távtelepítési szolgáltatás kiszolgálóit.
  • Elindult-e az Ügyféltelepítő varázsló más, távindítással indítható ügyfeleken? Ha igen, akkor ez az ügyfélszámítógép nem támogatott vagy problémák adódtak a távoli rendszertöltő ROM-mal. Ellenőrizze az ügyfélszámítógép PXE ROM-memóriájának verzióját. Azt is ellenőrizze az Active Directoryban, hogy a rendszergazda előzőleg beállította-e ezt az ügyfélszámítógépet olyan távtelepítési kiszolgálóhoz történő csatlakozásra, amely pillanatnyilag kapcsolat nélküli üzemmódban van, illetve nem érhető el.
  • Van-e olyan útválasztó az ügyfél és a távtelepítési kiszolgáló között, amely nem engedélyezi DHCP alapú kérelmek vagy válaszok továbbítását? A szolgáltatáskérelmek elküldésének és az azokra érkező válaszok fogadásának kezdeti folyamata során a távtelepítési szolgáltatás kiszolgálója a DHCP-csomagtípus alkalmazásával kommunikál. Lehet, hogy az útválasztót konfigurálni kell a DHCP-csomagok továbbítására.
  • Vannak-e a távtelepítési szolgáltatással (BINLSVC), a Tartománynévrendszerrel (DNS) vagy az Active Directoryval kapcsolatos hibaüzenetek a rendszer-vagy alkalmazásnaplóban található eseménynaplóban?
3. lépés:
Az ügyfél átvált a TFTP-kiszolgálóra vagy az F12 funkcióbillentyű megnyomását kéri a felhasználótól. Ez azt jelzi, hogy az ügyfél kapcsolatba lépett a távtelepítési szolgáltatás kiszolgálójával, és az első bináris fájl (CIW) fogadására vár. A BINL- és a TFTP-üzenet nem biztos, hogy külön-külön látható, mivel a folyamat nagyon gyorsan megy végbe.
Hibaelhárítás
Amennyiben az ügyfélszámítógép nem kap választ a távtelepítési kiszolgálótól, az ügyfélen időtúllépés lép fel, és hibaüzenetet jelenít meg, amelyben közli, hogy nem érkezett fájl a DHCP-, BINL- vagy a TFTP-kiszolgálótól. Ebben az esetben a távtelepítési szolgáltatás kiszolgálója nem válaszolt az ügyfélszámítógépnek. Hajtsa végre a következő műveleteket:
  • Állítsa le, majd indítsa újra a távtelepítési szolgáltatást: kattintson a Start gombra, majd a Futtatás parancsra.
  • A Futtatás párbeszédpanel Megnyitás mezőjébe gépelje be a cmd parancsot, majd kattintson az OK gombra.
  • A megjelenő konzolablakban gépelje be a következő parancsokat:
    Net Stop BINLSVC
    Net Start BINLSVC
  • Ellenőrizze a távtelepítési kiszolgáló tulajdonságait annak megállapítása végett, hogy a Válasz az ügyfélszámítógépek szolgáltatáskérelmére jelölőnégyzet be van-e jelölve, illetve, hogy az Ismeretlen ügyfeleknek nincs válasz jelölőnégyzet nincs-e bejelölve, hacsak előzőleg nem állította be az ügyfélszámítógépet az Active Directoryban annak elindítását megelőzően.
  • Ellenőrizze az eseménynaplóban, hogy nincsenek-e a DHCP-, a DNS-, a távtelepítési (BINLSVC) szolgáltatással vagy az Active Directoryval kapcsolatos hibaüzenetek. Ha az ügyfélszámítógép nem kap választ a szolgáltatás leállítását és újraindítását követően, és a megfelelő beállítások érdekében ellenőrizte a távtelepítési kiszolgáló beállításait, ellenőrizze a távtelepítési szolgáltatás kiszolgálóján lévő eseménynaplót, hogy nem találhatók-e benne a DHCP-, a DNS-, valamint a távtelepítési szolgáltatással (BINLSVC) kapcsolatos hibaüzenetek.
4. lépés:
Ekkorra az ügyfél már minden bizonnyal letöltötte az Ügyféltelepítés varázsló alkalmazást, amelynek meg is jelenítette üdvözlőlapját.

Támogatja-e a távtelepítési szolgáltatás a távoli rendszerindítást lehetővé tévő régebbi RPL (Remote Program Load) protokollon alapuló ROM-memóriákat?

Megoldás: A távtelepítési szolgáltatás a PXE DHCP alapú távoli rendszertöltő ROM memóriákat támogatja, ebből kifolyólag a Windows 2000 nem támogatja a régebbi, RPL alapú távolról történő rendszerindítást.

Támogatja-e a távtelepítési szolgáltatás a Windows 2000 Server CD alapú vagy a távtelepítést előkészítő operációs rendszer telepítési bináris fájljainak távolról történő telepítését?

Megoldás: Nem, a távtelepítési szolgáltatás nem támogatja a Windows 2000 Server operációs rendszer távolról történő telepítését.

Biztonságosnak tekinthető-e a PXE alapú távoli rendszertöltő ROM rendszerindítás előtti része?

Megoldás: Nem. A teljes rendszerindító ROM-folyamat és az operációs rendszer telepítési vagy replikációs folyamata nem tekinthető biztonságosnak a csomagtípusú titkosítás, az ügyfél és a kiszolgáló közötti hozzáférési jogosultságok, illetve a vezetékes adattovábbításon alapuló hálózatfigyelő (sniffer) mechanizmusok miatt. Emiatt érdemes óvatosnak lennie a távtelepítési szolgáltatás vállalati hálózaton történő alkalmazásakor. Ellenőrizze, hogy a hálózaton csak hitelesített távtelepítési kiszolgálók működnek-e, és, hogy kellő felügyelettel rendelkezik-e a távtelepítési kiszolgálók telepítésére és beállítására jogosult rendszergazdák fölött.

Megőrzi-e a távtelepítési szolgáltatás a forrásszámítógépen definiált fájlattribútumokat és biztonsági beállításokat a távtelepítést előkészítő (RIPrep) típusú bináris fájlok alkalmazásakor?

Megoldás: Igen. A forrásszámítógépen megadott fájlattribútumok és biztonsági beállítások változatlanok maradnak azon a célszámítógépen is, amelyre a bináris fájlt telepítik. A távtelepítést előkészítő (RIPrep) szolgáltatás azonban nem támogatja a forrásszámítógépen engedélyezett és használt titkosított fájlrendszert.

Támogatja-e a távtelepítési szolgáltatás távtelepítést előkészítő (RIPrep) szolgáltatása a RIPrep alapú operációs rendszer telepítési adatait tartalmazó bináris fájl létrehozásához használt, illetve a bináris fájlt telepítő célszámítógép különböző hardvereit?

Megoldás: Igen. A forrás- és a célszámítógép eltérő hardverrel rendelkezhet. Ez alól csak egyetlen hardver a kivétel: a hardverabsztrakciós réteg (HAL) illesztőprogramja nem lehet eltérő. Ha a forrásszámítógép például egy Speciális konfiguráció és energiagazdálkodás (ACPI) alapú számítógép, akkor az ACPI HAL eszközillesztőt használ. Ha az adott RIPrep bináris fájlt olyan számítógépre kísérli meg telepíteni, amely nem használ ACPI-t, illetve az nincs engedélyezve rajta, az operációs rendszer telepítése sikertelen lesz.

Támogatja-e a Távtelepítést előkészítő varázsló az adott számítógépen telepített több lemezt vagy partíciót?

Megoldás: Nem. A Távtelepítést előkészítő varázsló segédprogram a távtelepítési szolgáltatás ezen verziójában csak egy, egyetlen partícióval rendelkező lemezt (C:\meghajtó) támogat.

Hogyan kezeli a Távtelepítést előkészítő varázsló a bináris fájl létrehozására használt számítógépen és a bináris fájlt telepítő célszámítógépen lévő különböző méretű lemezeket?

Megoldás: A célszámítógép lemez-előkészítése azonos a forrásszámítógép lemez-előkészítésével, és az esetleges megmaradó lemezterület formázásra kerül. Ha a forrásszámítógép lemezén például 1 GB szabad lemezterület van, a célszámítógép lemezkapacitása pedig 2 GB, akkor a rendszer a célszámítógépen lévő teljes 2 GB lemezterületet formázza. A távtelepítési szolgáltatás támogatja a célszámítógép merevlemezének a forrásszámítógép merevlemezének méretével megegyező méretűre formázását. Az ügyfélszámítógép-lemezek újraformázási folyamatának kezeléséről a Telepítési programkód létrehozása című témakör nyújt tájékoztatást.

Hogyan replikálható az adott távtelepítési kiszolgálón lévő valamennyi, az operációs rendszer telepítését lehetővé tévő bináris fájl a hálózat más távtelepítési kiszolgálóira az összes ügyfélszámítógép operációs rendszereinek egységességét biztosítandó?

Megoldás: A távtelepítési szolgáltatás jelenleg nem teszi lehetővé az operációs rendszerek telepítéséhez használt bináris fájlok egyik távtelepítési kiszolgálóról másik távtelepítési kiszolgálóra történő replikálását, de a probléma számos más megoldással orvosolható. Használja a Systems Management Server alkalmazás hatékony replikációs szolgáltatásait. Ez a program lehetővé teszi az ütemezett replikációt, a tömörítést, valamint a lassú kapcsolatok esetében is alkalmazható szolgáltatások használatát. Az operációs rendszer telepítését lehetővé tévő bináris fájlok replikálását más gyártók eszközeivel is végrehajthatja. Ne feledje azonban, hogy az alkalmazott replikációs megoldásnak támogatnia kell a bináris forrásfájlok fájlattribútumait, illetve biztonsági beállításait.

Üzemeltethető-e egyidejűleg a hálózaton távtelepítési kiszolgáló, illetve egy távoli rendszerindítást lehetővé tévő, más gyártó által készített kiszolgáló? Ha igen, milyen tényezőket kell figyelembe venni?

Megoldás: Igen, ugyanazon a fizikai hálózaton több, távindítást és távtelepítést (RB/RI) lehetővé tévő, más gyártó által szállított kiszolgáló is működhet. Fontos azonban szem előtt tartani azt, hogy a távoli rendszertöltő PXE ROM-memóriakód jelenleg nem tud különbséget tenni a különböző gyártók távindítást és távtelepítést (RB/RI) lehetővé tévő kiszolgálói között. Emiatt, ha egy távindítást használni képes ügyfélszámítógép elindul, és egy RB/RI-kiszolgáló IP-címét kéri, az összes elérhető kiszolgáló válaszolni fog az ügyfélnek, így nem biztosítható az, hogy az ügyfelet a megfelelő RB/RI-kiszolgáló szolgálja ki.

A távtelepítési szolgáltatás segítségével a rendszergazdák előre beállíthatják az ügyfélszámítógépeket az Active Directoryban, és meghatározhatják, hogy melyik távtelepítési kiszolgáló fogja kiszolgálni az ügyfelet. Ha a távtelepítési kiszolgálót úgy konfigurálja, hogy csak ismert (előre beállított) ügyfélszámítógépeknek válaszoljon, a rendszergazda biztos lehet abban, hogy az ügyfelet a megfelelő távtelepítési kiszolgáló szolgálja ki.

A távindítást és távtelepítést lehetővé tévő (RB/RI-) kiszolgálók gyártói közül nem mindegyik alkalmazta termékében a szolgáltatáskérelmek figyelmen kívül hagyásának lehetőségét. Ha azt szeretné, hogy bizonyos gyártók hálózaton található RB/RI-kiszolgálói ne válaszoljanak az ügyfélkérelmekre, különítse el őket.

Kezelhetők-e távolról a távtelepítési szolgáltatás kiszolgálói a hálózat Windows 2000 Professional operációs rendszert futtató számítógépeiről?

Megoldás: Igen. Ha Ön a tartomány egyik rendszergazdája, és telepítette a Felügyeleti eszközök (Administrator Tools) telepítőcsomagot, felügyelheti a távtelepítési szolgáltatás konfigurációs beállításainak zömét. Van azonban néhány olyan beállítás, amelyeket nem lehet ezzel a módszerrel kezelni: Windows 2000 Professional operációs rendszert futtató számítógépekről távtelepítési kiszolgálókra távolról például nem küldhet több, az operációs rendszer telepítését lehetővé tévő bináris fájlt.

Lehet-e további hálózati csatolókat adni a távtelepítési szolgáltatás indítólemezéhez?

Megoldás: Nem. Az Rbfg.exe segédprogram a távtelepítési szolgáltatás jelen verziójában támogatott hálózati csatolók számának szempontjából nem módosítható. A Microsoft a közeljövőben hálózatikártya-csatolókat fog az alkalmazásba építeni, és a frissített Rbfg.exe segédprogramot a megszokott módon és helyeken (az interneten, Windows-frissítésekben, valamint a később kiadandó szerviz- és szolgáltatáscsomag-frissítéseken keresztül) elérhetővé teszi.

Használhatók-e az Active Directory objektumattribútumai a távtelepítési szolgáltatás automatikus számítógép-elnevezési szolgáltatása által alkalmazott elnevezési formátum létrehozásához?

Megoldás: Nem. Az automatikus számítógép-elnevezési szolgáltatással támogatott létező attribútumok jelenleg az Active Directoryt használják. Az Active Directory objektumattribútumai közül azonban nem mindegyik támogatott.

Hol található az ügyfélszámítógép globálisan egyedi (GUID) vagy univerzálisan egyedi azonosítója (UUID) az ügyfél Active Directoryban végrehajtott, távtelepítési szolgáltatáshoz történő beállításához?

Megoldás: A legtöbb PC98- vagy Net PC-kompatibilis ügyfélszámítógép esetén ezek az azonosítók a BIOS-ban találhatók. A számítógépgyártók ma már rendszerint hajlékonylemezen tárolt, vesszővel tagolt fájlban vagy adatbázis-állomány formájában mellékelik a GUID- és UUID-azonosítókra utaló sorozatszámokat. Ezzel a megoldással lehetővé válik az ügyfélszámítógépek Active Directoryban elvégzett előzetes beállítása.

A könnyebb azonosítás és a számítógépfiókok előzetes beállítása érdekében az azonosítókat néha a számítógép burkolatán is el szokták helyezni. Ha a globálisan egyedi azonosító (GUID) a fent ismertetett helyek egyikén sem található, megfelelő hálózati segédprogrammal figyelheti az ügyfélszámítógép hálózati adatforgalmát, és megkeresheti a DHCPDiscover nevű csomagot – a 128 bites, 16 bájtos GUID/UUID-azonosítót abban találja meg.

A felügyelet nélküli telepítés során a rendszer nem dolgozza fel a parancsbeállításokat.

Ok: Ha valamely .sif kiterjesztésű fájlban az „OemPreinstall = yes” beállítást adja meg, a rendszernek szüksége van a megfelelő könyvtár adataira is.

Megoldás: Módosítsa a könyvtáradatokat a következők szerint: \\RemoteInstall\Setup\alkalmazandó_nyelv\Images\alkalmazandó_név\$oem$.

Az Ügyféltelepítő varázsló munkamenete során a rendszer nem jeleníti meg a nyelvi beállítások megadását lehetővé tévő beállítási lehetőségeket.

Ok: A távtelepítési szolgáltatás alapértelmezés szerint a Welcome.osc fájlt használja az ügyfélszámítógépen végrehajtandó telepítés adatait tároló bináris fájl létrehozásához. Ha a bináris fájlban többnyelvű operációs rendszer telepítési adatait szeretné elhelyezni, cserélje ki a Welcome.osc fájlt a Multilng.osc nevű fájlra.

Megoldás: Az Ügyféltelepítő varázsló a \\RemoteInstall\OSChooser mappában tárolt Welcome.osc fájlt használja az ügyfélszámítógépen végrehajtandó telepítés adatait tartalmazó bináris fájl létrehozásához. A Welcome.osc fájl eltávolításával és a Multilng.osc fájl Welcome.osc nevű fájllá történő átnevezésével biztosítható, hogy az Ügyféltelepítő varázsló több nyelv megadását lehetővé tévő menüt is felajánljon a felhasználónak. A Welcome.osc fájl módosításával egyedi nyelvbeállításokat is létrehozhat.

Az adott távtelepítési kiszolgálóhoz előzőleg beállított ügyfélszámítógépet mégsem a megfelelő kiszolgáló szolgálja ki.

Ok: Ha tartományvezérlőkkel rendelkező tartományhoz állítja be az ügyfélszámítógépet, az ügyfélszámítógép-fiók (CAO) adatainak replikációs késleltetése miatt az adott ügyfélszámítógépet lehet, hogy egy másik távtelepítési kiszolgáló szolgálja ki.

Megoldás: Megvárhatja, amíg a következő ütemezett replikációs munkamenet folyamán a számítógépfiók adatai a megfelelő kiszolgálóra kerülnek, vagy módosíthatja a tartományvezérlők közötti replikáció gyakoriságát. A replikáció beállításáról A replikáció célja és módszerei című témakör nyújt bővebb tájékoztatást.

Az adott távtelepítési szolgáltatás valamely kötetéről készült biztonsági másolat visszaállítását követően nem működik megfelelően a távtelepítési szolgáltatás.

Ok: A biztonsági mentés egypéldányos (SIS) könyvtár nélkül állította vissza a kötetet.

Megoldás: Ellenőrizze a távtelepítési szolgáltatás kötetének konfigurációját, majd állítsa vissza a kötetet ismét.

Ha ellenőrizni szeretné a távtelepítési szolgáltatás köteteinek konfigurációját, kövesse A távtelepítési szolgáltatás beállításainak ellenőrzése című oldalon ismertetett lépéseket.