A Rendszerházirend és a Rendszerházirend-szerkesztő

A Rendszerházirend-szerkesztő (poledit.exe) egy Windows NT 4.0-stílusú segédprogram, mely a Windows NT 4.0 ügyfelek rendszerházirendjének beállítására, illetve Windows 2000 rendszerű ügyfelek esetén Windows NT 4.0–stílusú rendszerházirendek beállítására használatos. Windows 2000 ügyfelek esetében célszerű csoportházirendet alkalmazni rendszerházirend helyett.

Az alábbi táblázat összefoglalja, hogy a rendszerházirend-fájlok a Windows operációs rendszer mely verzióival kompatibilisek.

A .POL fájlt létrehozó operációs rendszer | Kompatibilis rendszerek
Windows 2000 | Windows 2000, Windows NT 4.0
Windows NT 4.0 | Windows 2000, Windows NT 4.0
Windows 98 | Windows 98, Windows 95
Windows 95 | Windows 98, Windows 95

A konkrét feladatokról az Útmutató című témakörben olvashat bővebben.

A Windows 2000 ügyfelekkel kapcsolatban lásd a Csoportházirend című témakört.


    Útmutató

  • Új házirend létrehozása a tartományban
  • Házirend beállítása egyetlen számítógépen
  • Csoportprioritás beállítása
  • Házirendsablon hozzáadása
  • Házirendsablon eltávolítása
  • A rendszerleíró adatbázis módosítása hálózati számítógépen


Új házirend létrehozása a tartományban

  1. Nyissa meg a Rendszerházirend-szerkesztőt.
  2. A Fájl menüben kattintson az Új házirend parancsra.
  3. A következő módon adhatja meg, hogy a rendszerleíró adatbázis beállításaiban végrehajtott módosítások mire vonatkozzanak:

    4. Kattintson duplán az Alapértelmezett felhasználó ikonra, ha a HKEY_CURRENT_USER rendszerleíróadatbázis-beállítást a tartomány összes felhasználójára vonatkozóan meg szeretné változtatni.

    Kattintson duplán az Alapértelmezett számítógép ikonra, ha a HKEY_LOCAL_MACHINE rendszerleíróadatbázis-beállítást a tartomány összes sztámítógépére vonatkozóan meg szeretné változtatni.

  4. Ha bővíteni szeretné a rendszerleíró adatbázis beállításait, kattintson a Szerkesztés menü megfelelő parancsára az alábbi műveletek végrehajtásához:

    5. Ha egyes felhasználókra vonatkozóan szeretné módosítani a HKEY_CURRENT_USER beállítást, kattintson a Felhasználó hozzáadása parancsra.

    Ha egyes számítógépekre vonatkozóan szeretné módosítani a HKEY_LOCAL_MACHINE beállítást, kattintson a Számítógép hozzáadása parancsra.

    Ha egyes csoportokra vonatkozóan szeretné módosítani a HKEY_CURRENT_USER beállítást, kattintson a Csoport hozzáadása parancsra.

  5. Szükség esetén adja meg a további hozzáadott házirendfájlok beállításait, majd kattintson a Fájl menü Mentés másként parancsára.
  6. A Mentés helye mezőben adja meg a Netlogon mappát az elsődleges tartományvezérlőn (PDC). Például:

    7. \\PDCKiszolgálóNév\netlogon

  7. A Fájlnév mezőbe írja a NTconfig.pol fájlnevet (Windows 98 és Windows 95 ügyfelek esetén a Config.pol fájlnevet), majd kattintson a Mentés gombra.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról.

Megjegyzések

  • A Rendszerházirend-szerkesztő megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: poledit.exe.
  • A Rendszerházirend-szerkesztőben kattintson duplán a megfelelő könyvikonra a rendelkezésre álló beállítások megtekintéséhez. Ha a házirendbeállítás jelölőnégyzete be van jelölve, akkor a rendszer alkalmazza azt.
  • A házirend a felhasználók bejelentkezésekor végrehajtásra kerül minden Windows NT 4.0, Windows 98 és Windows 95 rendszerű számítógépen.
  • A rendszerházirenddel kapcsolatos további tudnivalók Az áttéréssel kapcsolatos kérdések című témakörben találhatók.


Házirend beállítása egyetlen számítógépen

  1. Nyissa meg a Rendszerházirend-szerkesztőt.
  2. Az adott számítógépen, a Fájl menüben kattintson a Rendszerleíró adatbázis megnyitása parancsra, majd kattintson duplán a Helyi számítógép ikonra.
  3. Kattintson a plusz jelre (+) a Hálózat felirat mellett.
  4. Kattintson a Rendszerházirendek frissítése felirat melletti plusz jelre, majd a Távoli frissítés jelölőnégyzetre.
  5. Ha azt szeretné, hogy rendszerleíró adatbázis feldolgozza az ügyfélszámítógépeken megjelenített hibaüzeneteket, jelölje be a Hibaüzenetek megjelenítése jelölőnégyzetet.
  6. Ha a házirendfájlt a tartományvezérlőtől eltérő kiszolgálóról szeretné letölteni, a Frissítési mód listán kattintson a Kézi (a megadott elérési út használata) elemre, majd adja meg az elérési útvonalat.
  7. Szükség szerint adja meg az esetleges további házirendbeállításokat a számítógépen, majd mentse a házirendfájlokat a megfelelő mappába.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról.

Megjegyzések

  • A Rendszerházirend-szerkesztő megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: poledit.exe.
  • Győződjünk meg arról, hogy a házirendfájl .pol kiterjesztéssel rendelkezik-e.
  • A rendszerleíró adatbázishoz csak olyan számítógépről férhet hozzá, amelyhez rendszergazdai jogosultsággal rendelkezik.


Csoportprioritás beállítása

  1. Nyissa meg a Rendszerházirend-szerkesztőt.
  2. A Fájl menüben kattintson az Új házirend vagy a Házirend megnyitása parancsra. Ha új házirendet hoz létre, a csoportprioritások beállítása előtt csoportokat kell hozzáadnia a házirendhez.
  3. Kattintson a Beállítások menü Csoportprioritás parancsára.
  4. A Csoportsorrend listán jelöljön ki egy csoportot, majd kattintson a Fel, illetve a Le gombra.

Megjegyzések

  • A Rendszerházirend-szerkesztő megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: poledit.exe.
  • A Csoportprioritás menüparancs nem érhető el, ha csoportok vannak megjelenítve az aktuális házirendhez.
  • A lista elején található csoportok rendelkeznek a legmagasabb prioritással.
  • A csoportok kiértékelésének sorrendje akkor lényeges, ha egyes felhasználók több olyan csoportnak is tagjai, amelyhez házirend van meghatározva, illetve ha az ezen csoportokban lévő házirend különböző beállításokat tartalmaz ugyanarra a házirendre vonatkozóan.


Házirendsablon hozzáadása

  1. Zárja be az összes házirendfájlt.
  2. Másolja az .ADM fájlokat az .INF fájlokat tartlmazó mappába (ez általában a C:\winnt\inf mappa).
  3. Nyissa meg a Rendszerházirend-szerkesztőt.
  4. A Rendszerházirend-szerkesztő Beállítások menüjében kattintson a Házirendsablon parancsra, majd a Hozzáadás gombra.
  5. Adja meg a házirendsablon fájlnevét (.ADM), majd kattintson az OK gombra.

Megjegyzések

  • A Rendszerházirend-szerkesztő megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: poledit.exe.
  • A szoftvergyártók is fejleszthetnek házirendsablonokat, melyekkel házirend alkalmazható az illető programra. Az új házirendsablonok létrehozásával kapcsolatos információkat a Microsoft Win32 Software Developers Kit (SDK) című dokumentációban találja.


Házirendsablon eltávolítása

  1. Zárja be az összes házirendfájlt.
  2. Nyissa meg a Rendszerházirend-szerkesztőt.
  3. Kattintson a Beállítások menü Házirendsablon parancsára.
  4. Kattintson az eltávolítani kívánt házirendre, majd az Eltávolítás gombra.

Megjegyzés

  • A Rendszerházirend-szerkesztő megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: poledit.exe.


A rendszerleíró adatbázis módosítása hálózati számítógépen

  1. Nyissa meg a Rendszerházirend-szerkesztőt.
  2. A Fájl menüben kattintson a Csatlakoztatás parancsra.
  3. Írja be a hálózati számítógép nevét.
  4. A Felhasználók a távoli számítógépen párbeszédpanelen kattintson az éppen bejelentkezett felhasználóra, majd kattintson az OK gombra. Általában csak egy felhasználó jelentkezik be.
  5. Kattintson duplán a Helyi felhasználó ikonra, és módosítsa a rendszerleíró adatbázis HKEY_CURRENT_USER elemét.
  6. Kattintson duplán a Helyi számítógép ikonra, és módosítsa a rendszerleíró adatbázis HKEY_LOCAL_MACHINE elemét.
  7. Kattintson a Fájl menü Mentés parancsára, majd a Kapcsolat bontása parancsra.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról.

Megjegyzések

  • A Rendszerházirend-szerkesztő megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: poledit.exe.
  • A rendszerleíró adatbázishoz csak olyan számítógépről férhet hozzá, amelyhez rendszergazdai jogosultsággal rendelkezik.