ODBC Microsoft Access beállítások párbeszédpanel

Az ODBC Microsoft Access beállítások párbeszédpanel többek között az alábbi vezérlőket tartalmazza:

Adatforrás információk | Itt adható meg az Access adatbázis azonosítóneve, amely alapértelmezés szerint a gyártó által megadott név. Az adatforrásra vonatkozó minősítéseket az alapértelmezés szerint üresen hagyott Leírás mezőben adhatja meg.
Adatbázis | Sérült Access adatbázis kijavításához kattintson a Helyreállítás, az elfoglalt lemezterület csökkentéséhez pedig a Tömörítés gombra. Meglévő adatbázis megnyitásához kattintson a Kiválasztás gombra, új adatbázis létrehozásához pedig a Létrehozás gombra.
Rendszeradatbázis | Ha megosztott adatbázist kíván létrehozni, kattintson ide. Az alapértelmezett felhasználónév Admin, a hozzá tartozó Microsoft Access jelszó pedig egy üres karakterlánc lesz.
Egyebek Erre a gombra kattintson, ha az illesztőprogram alábbi beállításait szeretné módosítani:
  • Várakozási idő: Az az idő (tizedmásodpercben), amíg a nem használt lapok a pufferben maradnak. Az értéknek mindig nagyobbnak kell lennie 0-nál.

  • Pufferméret: A Microsoft Access által a lemezről, illetve a lemezre történő adatátvitel során használt belső puffer mérete kilobájtban. Az érték bármely 256-tal osztható egész szám lehet.

  • Adatbázis-hozzáférési megkötések
Speciális | Az illesztőprogram egyéb beállításainak konfigurálásához kattintson ide.

Megjegyzés Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapot, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) További információk a súgófájl alábbi címszavai alatt találhatók: Adatforrás-konverzió, Access fájlok, IISAM rendszerleíró bejegyzések és Az ODBC összetevők általánosan használt fájljai. Terméktámogatás is igénybe vehető.


.topic 2
Kilépés a párbeszédpanelből a változások mentése nélkül.

.topic 3
Az adatforrás neve, például Bérszámfejtés vagy Alkalmazottak. A Microsoft Excel 3.0-s vagy 4.0-s verziójú illesztőprogram használata esetén az az alapértelmezett adatkönyvtár, amelyben az ODBC illesztőprogram adatfájlokat keres. A Microsoft Excel 5.0-s, 7.0-s vagy 97-es verzió esetén az az alapértelmezett munkafüzet, amelyben az ODBC illesztőprogram adatfájlokat keres.

.topic 4
Itt írhatja le az adatforrásban szereplő adatokat, például: „Munkábaállás dátuma, Fizetésváltozások, Jelenlegi alkalmazottak adatai" (nem kötelező kitölteni).

.topic 5
A párbeszédpanel Súgójának megjelenítése.

.topic 6
Kilépés a Beállítások párbeszédpanelből a változások mentésével.

.topic 7
Kijelölésével írásvédetté teszi az adatbázist, mellyel meggátolja módosítását.

.topic 8
Az egyes oszlopok adattípusának megállapításához használt sorok száma. A Microsoft Excel illesztőprogram esetén bármely 1 és 16 közötti szám. Az alapértelmezett érték 8. Ha 0-ra állítja, minden sort megvizsgál.

.topic 9
Ide kattintva megnyithatja a Könyvtár választása párbeszédpanelt, ahol kijelölheti az elérni kívánt fájlokat tartalmazó könyvtárat. Az adatforráskönyvtár megadásakor azt a könyvtárat adja meg, amely a Microsoft Excel 3.0 vagy 4.0 által leggyakrabban használt Excel fájlokat tartalmazza.

.topic 10
Ide kattintva megnyithatja a Munkafüzet választása párbeszédpanelt, ahol kijelölheti az elérni kívánt munkafüzetet.

.topic 11
Kijelölésével az alkalmazás aktuális munkakönyvtára lesz az adatforráskönyvtár. Ha üresen hagyja a jelölőnégyzetet, a Könyvtár választása gombra kattintva jelölheti ki az adatforráskönyvtárat. Microsoft Excel 5.0, 7.0 és 97 esetén nem érhető el.

.topic 12
A használt fájlok Excel verziója.

.topic 13
E beállításokkal megváltoztatható az Excel fájlok helye és verziója.

.topic 14
E beállításokkal konfigurálhatja az illesztőprogram-specifikus attribútumokat.

.topic 15
Ide kattintva konfigurálhatja az illesztőprogram-specifikus attribútumokat.

.topic 16
A kijelölt Excel könyvtár helye.

.topic 17
A kijelölt Excel munkafüzet helye.

.topic 201
Ide kattintva veheti fel a Kiterjesztés mezőben megadott kiterjesztéseket.

.topic 202
Kilépés a párbeszédpanelből a változások mentése nélkül.

.topic 203
Itt adható meg az adatforrás neve, például Bérszámfejtés vagy Alkalmazottak, és az az alapértelmezett adatkönyvtár, ahol az ODBC illesztőprogram adatfájlokat keres.

.topic 204
Kijelölése esetén a könyvtárban lévő összes fájl használhatóvá válik. Ha a jelölőnégyzetet üresen hagyja, a Kiterjesztések lista tartalma az alapértelmezett *.asc, *.csv, *.tab és *.txt kiterjesztésekre módosul, és tetszése szerint hozzáadhat vagy törölhet meghatározott kiterjesztéseket.

.topic 205
Ide kattintva megnyithatja a Szövegformátum megadása párbeszédpanelt, ahol meghatározhatja az oszlopok formátumát, és megadhatja az adatforráskönyvtár táblasémáit.

.topic 206
Itt írhatja le az adatforrásban szereplő adatokat, például: „Munkábaállás dátuma, Fizetésváltozások, Jelenlegi alkalmazottak adatai" (nem kötelező kitölteni).

.topic 207
Ide írható be a hozzáadni kívánt fájlkiterjesztés *.xxx formában. Ha például .dat fájlokat kíván használni, írja be a *.dat szöveget.

.topic 208
Megjeleníti az adatforrásban található szövegfájlok kiterjesztéseinek listáját, annak függvényében, hogy az Alapértelmezett jelölőnégyzet be van-e jelölve .

.topic 214
E beállítások segítségével meghatározott fájltípusokat formázhat.

.topic 215
E beállításokkal adhatja hozzá a nem alapértelmezett fájlkiterjesztéseket a Kiterjesztések listához illetve távolíthatja el őket onnan. Fájlkiterjesztés hozzáadásához törölje a jelet az Alapértelmezett jelölőnégyzetből, írja be az új kiterjesztést a Kiterjesztés mezőbe, majd kattintson a Hozzáadás gombra.

.topic 216
E beállításokkal jelölheti ki a szövegfájl helyét és jelenítheti meg a fájl nevét.

.topic 209
E párbeszédpanel Súgójának megjelenítése.

.topic 210
Kilépés a Beállítások párbeszédpanelből a változások mentésével.

.topic 211
Ide kattintva eltávolíthatja a kijelölt fájlkiterjesztést a Kiterjesztések közül.

.topic 212
Ide kattintva nyithatja meg a Könyvtár választása párbeszédpanelt, ahol kijelölheti az elérni kívánt fájlokat tartalmazó mappát.

.topic 213
Kijelölésével az alkalmazás aktuális munkakönyvtára lesz az adatforráskönyvtár. Ha üresen hagyja a jelölőnégyzetet, a Könyvtár választása gombra kattintva jelölheti ki az adatforráskönyvtárat.

.topic 217
Ide kattintva konfigurálhatja a szövegfájl attribútumait, és vehet fel vagy távolíthat el szövegfájltípusokat.

.topic 218
A szövegfájl helye.

.topic 301
Ide kattintva az Adattípus, Név és Szélesség mezőkben szereplő értékek felhasználásával új oszlopot vehet fel.

.topic 302
Kilépés a párbeszédpanelből a változások mentése nélkül.

.topic 321
Karakterkészlet meghatározása ANSI vagy OEM karakterkészletként.

.topic 303
A Táblák listában kiválasztott elem formátumának meghatározása ANSI karakterkészletként.

.topic 304
Jelzi, hogy a kijelölt tábla oszlopainak első sora lesz-e az oszlopnév (TRUE, ha be van jelölve, FALSE, ha üresen marad).

.topic 305
Megjeleníti a Táblák listában kijelölt tábla oszlopainak nevét az oszlopoknak a táblában elfoglalt sorrendje szerint.

.topic 319
Itt határozhatja meg a kijelölt szövegfájl oszlopattribútumait.

.topic 306
Megjeleníti az adattípusokat, amelyek az alábbiak lehetnek: BIT, BYTE, CHAR, CURRENCY, DATE, FLOAT, INTEGER, LONGCHAR, SHORT vagy SINGLE.

.topic 307
Az oszlopok elválasztására használt alapértelmezett határoló karakter. Csak egy karakter hosszúságú lehet; az idézőjel (") nem használható. Akkor lép érvénybe, amikor a Formátum mezőben az Egyéni tagolású elemet választja.

.topic 308
Tagolt vagy adott hosszúságú, ha tagolt, akkor jelzi a határoló karakter típusát.

.topic 309
Generálja a kijelölt tábla oszlopainak adattípus-, név- és szélességértékeit a tábla tartalmának pásztázásával a Formátum listamezőben kijelölt beállításnak megfelelően. A lehetőség akkor érhető el, ha a tábla tagolt formátumú.

.topic 310
E párbeszédpanel Súgójának megjelenítése.

.topic 311
Itt módosítható a kijelölt oszlop az Adattípus, Név és Szélesség mezőben szereplő értékek felhasználásával.

.topic 312
Megjeleníti a kijelölt oszlop nevét. Alkalmazásával új nevet adhat egy már létező vagy új oszlopnak.

.topic 313
Kilépés a párbeszédpanelből a változások mentésével.

.topic 314
A kijelölt oszlop törlése.

.topic 315
A Telepítő vagy az illesztőprogram által az oszlopok és azok adattípusainak beállításánál pásztázott sorok száma. Ha a Táblák listából kijelölt elem formátuma nincs megadva, az alapértelmezett érték 25 lesz, de bármilyen számot megadhat 1 és 32767 között.

.topic 316
Megjelenít minden olyan fájlt, amelynek kiterjesztése megegyezik az ODBC szövegbeállítások párbeszédpanelen meghatározott kiterjesztésekkel. Egy fájl táblaattribútumainak megjelenítéséhez vagy módosításához jelölje ki a fájlt.

.topic 320
E beállításokkal adhatja meg a kijelölt szövegfájl táblaattribútumait.

.topic 317
Az oszlop szélessége; az érték a CHAR és LONGCHAR oszlopokra vonatkozóan módosítható. A többi adattípusnál a Szélesség beállítás nem érhető el, érték pedig nem jelenik meg. Ha a Táblák listából kijelölt elem formátuma nincs megadva, az alapértelmezett érték 1-re módosul.

.topic 318
Itt adható meg a nem ANSI karakterkészlet (alapértelmezett)a Táblák listában kijelölt elem formátuma számára.

.topic 401
Kilépés a párbeszédpanelből a változások mentése nélkül.

.topic 402
A mezők rendezésének sorrendje - lehet ASCII (alapértelmezett), Nemzetközi, Svéd-Finn vagy Norvég-Dán.

.topic 403
Itt adható meg az adatforrás neve, például Bérszámfejtés vagy Alkalmazottak, és az az alapértelmezett adatkönyvtár, ahol az ODBC illesztőprogram adatfájlokat keres.

.topic 404
Itt írhatja le az adatforrásban szereplő adatokat, például: „Munkábaállás dátuma, Fizetésváltozások, Jelenlegi alkalmazottak adatai" (nem kötelező kitölteni).

.topic 405
Ha a jelölőnégyzetet be van jelölve, az adatbázis Kizárólagos módban nyílik meg. Így egyszerre csak egy felhasználó férhet hozzá, és javul a teljesítmény. Ha a jelölőnégyzet nincs bejelölve, az adatbázis Megosztott módban nyílik meg, így egyszerre több felhasználó is hozzáférhet.

.topic 406
E párbeszédpanel Súgójának megjelenítése.

.topic 407
Itt adható meg a Paradox adatok hálózati eléréséhez használt hozzáférési mód: „3.x" a Paradox 3.x esetén, „4.x" a Paradox 4.x vagy 5.x esetén. 4.x-es vagy 5.x-es Paradox esetén mind „3.x"-re, mind „4.x"-re állítható; Paradox 3.0 esetén „3.x"-nek kell lennie a hozzáférési módnak.

.topic 408
Kilépés a Beállítások párbeszédpanelből a változások mentésével.

.topic 409
Az a tizedmásodpercben mért idő, amíg a nem használt lapok a pufferben maradnak. Az alapértelmezett érték 600 tizedmásodperc (azaz 60 másodperc); ennek az értéknek nagyobbnak kell lennie 0-nál.

.topic 410
Ide kattintva nyithatja meg a Könyvtár választása párbeszédpanelt, ahol kijelölheti az elérni kívánt fájlokat tartalmazó mappát.

.topic 415
A Paradox fájl helye.

.topic 411
A hálózati könyvtár megadása előtt be kell írnia a Felhasználónév mezőbe a Paradox felhasználói nevét. Ezután kattintson a Hálózati könyvtár választása gombra.

.topic 416
Annak a könyvtárnak az elérési útja, amely a Paradox lock adatbázis mellett a Pdoxusrs.net fájlt (Paradox 4.x-ben) vagy a Paradox.net fájlt (Paradox 5.x-ben) tartalmazza. Ha a könyvtár valamelyik fájlt nem tartalmazza, a Paradox illesztőprogram létrehozza azt.

.topic 412
Kijelölésével az alkalmazás aktuális munkakönyvtára lesz az adatforráskönyvtár. Ha üresen hagyja a jelölőnégyzetet, a Könyvtár választása gombra kattintva jelölheti ki az adatforráskönyvtárat.

.topic 413
Zárolás esetén a Paradox fájlok többi felhasználója számára ez a Paradox felhasználónév jelenik meg.

.topic 414
A használt fájlok Paradox verzióját jelzi: például Paradox 4.x vagy 5.x.

.topic 417
E beállítások segítségével jelölheti ki és jelenítheti meg a Paradox adatbázis verzióját és helyét.

.topic 418
E beállítások segítségével konfigurálhatja a Paradox illesztőprogramot.

.topic 419
Ide kattintva konfigurálhatja az illesztőprogram-specifikus attribútumokat.

.topic 501
Itt adható meg, hogy a táblaméretű statisztikák kerekített értékeket tartalmazzanak-e. Ez a beállítás minden dBASE illesztőprogramot használó adatbázisforrásra vonatkozik.

.topic 502
Kilépés a párbeszédpanelből a változások mentése nélkül.

.topic 503
A mezők rendezésének sorrendje - lehet ASCII (alapértelmezett) vagy bizonyos nyelvek számára megfelelő.

.topic 504
Itt adható meg az adatforrás neve, például Bérszámfejtés vagy Alkalmazottak, és az az alapértelmezett adatkönyvtár, ahol az ODBC illesztőprogram adatfájlokat keres.

.topic 505
Itt írhatja le az adatforrásban szereplő adatokat, például: „Munkábaállás dátuma, Fizetésváltozások, Jelenlegi alkalmazottak adatai" (nem kötelező kitölteni).

.topic 506
Ha a jelölőnégyzetet be van jelölve, az adatbázis Kizárólagos módban nyílik meg. Így egyszerre csak egy felhasználó férhet hozzá, és javul a teljesítmény. Ha a jelölőnégyzet nincs bejelölve, az adatbázis Megosztott módban nyílik meg, így egyszerre több felhasználó is hozzáférhet.

.topic 507
E párbeszédpanel Súgójának megjelenítése.

.topic 508
Kilépés a Beállítások párbeszédpanelből a változások mentésével.

.topic 509
Az a tizedmásodpercben mért idő, amíg a nem használt lapok a pufferben maradnak. Az alapértelmezett érték 600 tizedmásodperc (azaz 60 másodperc), és mindig nagyobbnak kell lennie 0-nál.

.topic 515
A dBASE adatbázis helye.

.topic 510
Ide kattintva nyithatja meg a Könyvtár választása párbeszédpanelt, ahol kijelölheti az elérni kívánt fájlokat tartalmazó mappát.

.topic 511
Ide kattintva nyithatja meg az Indexek választása párbeszédpanelt, ahol dBASE fájlokat társíthat indexfájlokkal.

.topic 512
Itt adható meg, hogy a töröltnek jelzett sorok visszanyerhetők-e és a helyük meghatározható-e. Ha a jelölőnégyzet nincs bejelölve (alapértelmezett beállítás), a törölt sorok nem láthatók; ha be van jelölve, a törölt sorokat ugyanúgy kezeli a program, mint a nem törölt sorokat.

.topic 513
Kijelölésével az alkalmazás aktuális munkakönyvtára lesz az adatforráskönyvtár. Ha üresen hagyja a jelölőnégyzetet, a Könyvtár választása gombra kattintva jelölheti ki az adatforráskönyvtárat.

.topic 514
Ide kattintva adható meg a használt dBASE fájlok verziója: például dBASE III, dBASE IV vagy dBASE 5.0.

.topic 516
E beállítások segítségével választhatja ki és jelenítheti meg a dBASE adatbázis verzióját és helyét.

.topic 517
E beállítások segítségével konfigurálhatja a dBASE illesztőprogramot.

.topic 518
Ide kattintva konfigurálhatja az illesztőprogram-specifikus attribútumokat.

.topic 701
Ide kattintva állíthatja be az illesztőprogram speciális beállításait a teljesítmény módosításához.

.topic 702
A Microsoft Access által a lemezről, illetve a lemezre történő adatátvitel során használt belső puffer mérete kilobájtban.
 Az alapértelmezett pufferméret 2048K (a panelen mértékegység nélkül (2048) látható). Írjon be egy 256-tal osztható egész számot.

.topic 703
Kilépés a párbeszédpanelből a változások mentése nélkül.

.topic 704
Ide kattintva hozhat létre Access adatbázist.

.topic 705
Ide kattintva csökkentheti a feleslegesen használt hely méretét egy létező Access adatbázisban.

.topic 706
Itt adható meg az adatforrás neve, például Bérszámfejtés vagy Alkalmazottak, és az az alapértelmezett adatkönyvtár, ahol az ODBC illesztőprogram adatfájlokat keres.

.topic 707
Az aktuálisan kijelölt Excel adatbázis helye. Adatbázis kijelöléséhez kattintson a Kiválasztás gombra.

.topic 708
Itt írhatja le az adatforrásban szereplő adatokat, például: „Munkábaállás dátuma, Fizetésváltozások, Jelenlegi alkalmazottak adatai" (nem kötelező kitölteni).

.topic 709
Ha a jelölőnégyzetet be van jelölve, az adatbázis Kizárólagos módban nyílik meg. Így egyszerre csak egy felhasználó férhet hozzá, és javul a teljesítmény. Ha a jelölőnégyzet nincs bejelölve, az adatbázis Megosztott módban nyílik meg, így egyszerre több felhasználó is hozzáférhet.

.topic 710
E párbeszédpanel Súgójának megjelenítése.

.topic 711
Ha nem használ rendszeradatbázist, e beállítás kijelölésével Admin (defaultUser) felhasználóként jelentkezhet be egy meghatározott Access adatbázisba.

.topic 712
Kilépés a Beállítások párbeszédpanelből a változások mentésével.

.topic 713
Az a tizedmásodpercben mért idő, amíg a nem használt lapok a pufferben maradnak. Az alapértelmezett érték 0,5 tizedmásodperc; ennek az értéknek mindig nagyobbnak kell lennie 0-nál.

.topic 714
Kijelölésével írásvédetté teszi az adatbázist, mellyel meggátolja módosítását.

.topic 715
Ide kattintva helyreállíthatja a sérült Access adatbázisokat.

.topic 716
Ide kattintva kijelölhet egy konkrét Access adatbázist.

.topic 723
Kijelölésével rendszeradatbázist használhat. Ezután kattintson a Rendszeradatbázis gombra.

.topic 717
Ide kattintva megnyílik a Rendszeradatbázis választása párbeszédpanel, ahol kiválaszthatja a használni kívánt rendszeradatbázist (munkacsoport).

.topic 718
E beállításokkal segítségével tekintheti meg az Access adatbázis helyét és végezheti el az adatbázis karbantartásával kapcsolatos feladatokat.

.topic 719
E beállítások segítségével választhatja ki a rendszeradatbázist (munkacsoport) és tekintheti meg a helyét.

.topic 720
Az aktuálisan kijelölt Excel adatbázis helye.

.topic 721
E beállítások segítségével konfigurálhatja az Access illesztőprogramot.

.topic 722
Ide kattintva konfigurálhatja az illesztőprogram-specifikus attribútumokat.


Access fájlok

Az ODBC Desktop Database Drivers 4.0 a következő ISAM fájlokat tartalmazza a Microsoft Access illesztőprogramhoz:

32 bites ISAM | Microsoft Access verzió
Nincs (az Msjet40.dll tartalmazza) | 7.0 és 97
Msrd2x40.dll | 2.0
Msrd3x40.dll | 3.0

Megjegyzés Ha Microsoft Windows 95/98-at (és nem Microsoft Windows NT/Windows 2000-et) használ, számítógépére pedig nem telepítette a Microsoft Access programot, a Config.sys fájl végére írja be „FILES= 50” sort.


Bejelentkezés Access rendszeradatbázisba

Ha egy korábban rendszeradatbázisként megadott Access adatbázishoz szeretne kapcsolódni, a Bejelentkezés párbeszédpanelen írhatja be hitelesített Access bejelentkezési nevét és jelszavát. A bejelentkezési nevet és jelszót az adatbázis kezelője osztja ki, és azokat pontosan az előírt formában kell beírni.

Az Adatforrás mező azt az adatforrást mutatja, amelyhez éppen csatlakozik.

Megjegyzés Ha nincs kijelölt adatforrás, az Adatbázis gombra kattintva jelölhet ki egyet.

A párbeszédpanel bezárásához és a bejelentkezés megkezdéséhez kattintson az OK gombra.

A párbeszédpanel bezárásához és a bejelentkezés megszakításához kattintson a Mégse gombra.


Az ODBC összetevők általánosan használt fájljai

Az alábbi táblázat felsorolja azokat a fájlokat, amelyek az ODBC Desktop Database Drivers 4.0 egyes összetevőihez szükségesek. Windows 95 vagy újabb rendszer esetében ezeknek a fájloknak a telepítése a \Windows\System könyvtárba, Windows NT vagy Windows 2000 esetében pedig a \Windows\System32 könyvtárba történik. Ha egy másik könyvtárba korábban már telepített ODBC fájlokat, győződjön meg róla, hogy a \Windows\System (vagy System32) könyvtárban található újabb fájlokat használja.

Egyes fájlokat több összetevő is igényelhet. Ha kereskedelmi forgalomba kerülő alkalmazásai részeként terjeszteni kívánja az ODBC Desktop Database Drivers szoftvert, az alábbi fájlokat is csatolnia kell.

A következő fájlok azok, melyeket minden ODBC Desktop Database Drivers program használ:

Ds16gt.dll
Ds32gt.dll
Expsrv.dll
Msjint40.dll
Msjet40.dll
Msjter40.dll
Msjtes40.dll
Msvcrt40.dll 		Odbc16gt.dll
Odbc32.dll
Odbc32gt.dll
Odbccp32.cpl
Odbccp32.dll
Odbccr32.dll
Odbcinst.chm
Odbcint.dll 		Odbcjet.chm
Odbcji32.dll
Odbcjt32.dll
Odbctl32.dll
Vbajet32.dll
Odbctrac.dll


Tömörítendő adatbázis választása párbeszédpanel

Az adatbázisok tömörítésével eltávolíthatja a feleslegesen lekötött üres területeket anélkül, hogy adatait elveszítené. A Tömörítendő adatbázis választása párbeszédpanel a tömörítendő adatbázisra vonatkozó beállítások elvégzésére szolgál és lehetővé teszi a tömörítés alatti hozzáférési jogosultság beállítását: Megosztva olvasható/írható (alapértelmezés), Olvasásra (ezzel letiltja a frissítéseket), vagy Kizárólagos.

Az adatok tömörítése az ODBC Microsoft Access beállítások párbeszédpanelen végezhető el. Kattintson a Tömörítés gombra, majd a Tömörítendő adatbázis választása párbeszédpanelen adja meg a fájl elérési útvonalát. Kattintson az OK gombra. A tömörített adatbázis új nevének megadása párbeszédpanelen adja meg a fájl nevét és elérési útját, a létrejövő tömörített fájl verziószámát, a helyet, majd kattintson az OK gombra. A tömörített fájl neve megegyezhet az eredeti fájl nevével. Ha a tömörített fájl neve egy másik meglévő fájlnévvel azonos, hibaüzenet jelenik meg. A jelszóval védett fájlok tömörítése előre nem látható következményekkel járhat.


Új adatbázis párbeszédpanel

Adja meg a létrehozni kívánt új Microsoft Access adatbázis teljes elérési útját.

A Microsoft Access illesztőprogram használata esetén az új adatbázis létrehozásához kattintson a Létrehozás gombra.

Megjegyzés Az így létrehozott adatbázis csak a Microsoft Access 7.0-s vagy újabb verziójával használható.

Ha telepítéskor nem ad meg adatbázist, az adatforráshoz való csatlakozáskor a program kérni fogja, hogy jelöljön ki egy adatbázisfájlt.

Az Új adatbázis párbeszédpanelen többek között az alábbi vezérlők találhatók:

Adatbázis neve és helye | Itt adható meg az új adatbázis neve és helye.
Területi beállítás | Itt adható meg az adatbázis földrajzi helye (LCID – Local character set identifier – Lokális karakterkészlet azonosítója) és nyelve.
Formátum | A Microsoft Jet Database Engine formátuma. Egyebek: 4.x-es verzió (a legújabb, Unicode formátum), 3.x-es verzió (ANSI formátum) vagy 2.x-es verzió (ANSI formátum).
Egyebek | Ha a Rendszeradatbázis elemre kattint, megosztható adatbázist hozhat létre, melyet a program az ODBC adatforrás-felügyelő Rendszeradatforrás lapjára rögzít. A Titkosítás jelölőnégyzet bejelölésével ezt az Access funkciót állíthatja be. A Microsoft Jet Database Engine 4.0-s verziójától kezdve az adatbázisok létrehozásánál lehetséges az adatbázisok titkosítása is. További információért lásd: Jet Database Engine Programmer's Reference (Jet Database Engine programozói kézikönyv). A titkosítás csak akkor alkalmazható, ha a 4.x-es formátumot választotta.


Adatforrás-konverzió

Az ODBC Desktop Database Drivers 2.0-s verziójával használt 32 bites adatforrásokat a program automatikusan a 4.0-s verziónak megfelelő, új 32 bites adatforrásokká konvertálja. 16 bites adatforrások esetében nem kerül sor konverzióra. Ha 16 bites adatforrást 32 bitesre szeretne alakítani, hozzon létre egy új 32 bites adatforrást, majd szükség esetén törölje a régi 16 bitest. Egy 32 bites és egy 16 bites adatforrás nem rendelkezhet azonos névvel.


dBASE fájlok

Az ODBC Desktop Database Drivers 4.0 a következő ISAM fájlokat tartalmazza a Microsoft dBASE illesztőprogramhoz:

32 bites ISAM | dBASE verzió
Msxbse40.dll Oddbse32.dll | dBASE III dBASE IV dBASE 5.0


ODBC dBASE beállítások párbeszédpanel

Az ODBC dBASE beállítások párbeszédpanel többek között az alábbi vezérlőket tartalmazza:

Adatforrás információ | Itt adható meg a dBASE adatbázis azonosítóneve, amely alapértelmezés szerint a gyártó által megadott név. Az adatforrásra vonatkozó minősítéseket az alapértelmezés szerint üresen hagyott Leírás mezőben adhatja meg.
Adatbázis | Itt adhatja meg a telepített dBASE adatbázis-verziókat és azok helyét. Ha bejelöli az Aktuális könyvtár használata jelölőnégyzetet, a Könyvtár választása és az Indexek választása lehetőségek nem lesznek elérhetők.
Egyebek Erre a gombra kattintson, ha az alábbi vezérlőbeállításokat szeretné módosítani:
  • Rendezési sorrend: Rendezés.

  • Várakozási idő: Az az idő (tizedmásodpercben), amíg a nem használt lapok a pufferben maradnak. Az értéknek mindig nagyobbnak kell lennie 0-nál.

  • Kizárólagos: Az adatbázishoz való hozzáférést egy felhasználóra korlátozza.

  • Törölt sorok mutatása: Itt adható meg, hogy a töröltnek jelzett sorok visszanyerése vagy pozicionálása lehetséges-e.

  • Sorszám közelítése: Itt adható meg, hogy a táblaméretű statisztikák kerekített értékeket tartalmazzanak-e.

Megjegyzés Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapot, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) További információk a súgófájl alábbi címszavai alatt találhatók:Adatforrás-konverzió, dBASE fájlok, IISAM rendszerleíró bejegyzések és Az ODBC összetevők általánosan használt fájljai. A dBASE az Inprise Corporation terméke és saját súgófájl tartozik hozzá.


Szövegformátum megadása párbeszédpanel

A kijelölt fájl oszlopformátumainak megadását és az egyes adattáblák sémameghatározását a Szövegformátum megadása párbeszédpanelen végezheti el. A Szövegformátum megadása párbeszédpanel többek között az alábbi vezérlőket tartalmazza:

Hozzáadás | Itt adhat hozzá új oszlopot az Adattípus, Név és Szélesség mezőkben szereplő értékek felhasználásával.
Karakterek | ANSI vagy OEM. Az OEM nem ANSI karakterkészletet jelent és akkor alapértelmezett, ha a Táblák listában kijelölt elem formátuma nincs definiálva.
Fejléc oszlopnevekkel | Itt adható meg, hogy a kijelölt tábla oszlopainak első sora az oszlopneveket tartalmazza-e. Ha a Táblák listában kijelölt elem formátuma nincs definiálva, az alapértelmezett érték FALSE (HAMIS, vagyis nincs bejelölés).
Oszlopok | Itt láthatók a Táblák listában kijelölt tábla oszlopainak nevei az oszlopok sorrendje szerint.
Adattípus | Lehet BIT, BYTE, Char, CURRENCY, Date, Float, Integer, LONGCHAR, SHORT vagy SINGLE. Dátum adattípus esetén az „nn-hhh-éé”, „hh-nn-éé”, „hhh-nn-éé”, „éééé-hh-nn” vagy „éééé-hhh-nn” forma használható. (A „hh” a számmal jelzett, a „hhh” a betűvel kiírt hónapokat jelenti.)
Határoló | Az oszlopok elválasztására használandó határoló karakter. Csak egyetlen karakter lehet. A kettős idézőjel (") nem használható. Ez a beállítás akkor érhető el, ha a Formátum mezőben az Egyéni tagolású lehetőséget választja.
Formátum | Lehet tagolt vagy adott hosszúságú. Ha tagolt, itt adható meg a használandó határoló karakter típusa: vessző (CSV), tabulátor vagy speciális karakter (egyéni). Ha a Táblák listában kijelölt elem formátuma nincs definiálva, az alapértelmezett érték CSV. Ha adott hosszúságú Formátum van beállítva és bejelölte a Fejléc oszlopnevekkel lehetőséget is, az első sor elválasztó karakterének vesszőnek kell lennie.
Becslés | Kattintson ide, ha a Formátum listában kijelölt lehetőségnek megfelelően a tábla tartalmának pásztázásával kívánja a kijelölt tábla oszlopainak adattípus-, név- és szélességértékeit generálni. A lehetőség akkor érhető el, ha a tábla tagolt formátumú. Az Oszlopok listában korábban megadott oszlopok törlődnek, helyükre pedig új bejegyzések kerülnek. Ha a Fejléc oszlopnevekkel lehetőséget nem választotta ki, az oszlopok neve sorrendben „F1”, „F2” stb. lesz. A funkció csak a 64 513 bájtnál kisebb méretű oszlopok esetében működik.
Módosítás | Ha az Adattípus, Név és Szélesség mezőkben szereplő értékek felhasználásával módosítani kívánja a kijelölt oszlopot, kattintson ide.
Név | Itt adható meg a kijelölt oszlop neve. Arra használhatja, hogy egy már létező vagy új oszlopnak új nevet adjon. Ha a Fejléc oszlopnevekkel lehetőséget bejelölte, a program a képernyőn látható oszlopnevet figyelmen kívül hagyja.
Eltávolítás | Törli a kijelölt oszlopot.
Pásztázandó sorok | A Telepítő vagy az illesztőprogram által az oszlopok és azok adattípusainak beállításánál pásztázott sorok száma. Ha a Táblák listában kijelölt elem formátuma nincs definiálva, az alapértelmezett érték 25 lesz, de bármilyen számot megadhat 1 és 32767 között.
Táblák | Itt láthatók azok a fájlok, melyek az ODBC szövegbeállítások párbeszédpanelen kijelölt könyvtárban megadott kiterjesztéseknek megfelelnek. Ha az <alapértelmezett> lehetőséget választja, az Oszlopok lista nem érhető el.
Szélesség | Az érték a CHAR és LONGCHAR oszlopokra vonatkozóan módosítható. A többi adattípusnál a Szélesség beállítás nem érhető el és érték sem jelenik meg. Ha a Táblák listában kijelölt elem formátuma nincs definiálva, az alapértelmezett érték 1.


Excel fájlok

Az ODBC Desktop Database Drivers 4.0 az alábbi ISAM fájlokat tartalmazza az Excel számára:

32 bites ISAM | Microsoft Excel verzió
Msexcl40.dll Odexl32.dll | 3.0, 4.0, 5.0, 7.0, 97

A Microsoft Excel illesztőprogram az Excel 3.0-s formátumnál korábbi fájlokat nem tudja olvasni. Ha ilyen fájlokat kíván használni, nyissa meg őket a Microsoft Excel egyik újabb kiadásában, és mentse az illesztőprogram által olvasható formátumban - 3.0, 4.0, 5.0, 7.0, vagy 97.


IISAM rendszerleíró bejegyzések

Az IISAM rendszerleíró bejegyzések felvétele az egyes IISAM DLL fájlok DLLRegisterServer függvényének meghívásakor, törlésük pedig a DLLUnregisterServer függvény meghívásakor történik. A DLLRegisterServer függvényt minden IISAM DLL esetében a Jet ODBC függvény hívja meg dinamikusan. Ha például kapcsolatot próbál létrehozni valamelyik IISAM fájl használatával és a kapcsolat nem jön létre, az illesztőprogram megpróbálja (a DLLRegisterServer függvény meghívásával) inicializálni az adott IISAM fájlt, és újra létrehozni a kapcsolatot.


ODBC Microsoft Excel beállítások párbeszédpanel

Az ODBC Microsoft Excel beállítások párbeszédpanel többek között az alábbi vezérlőket tartalmazza:

Adatforrás információ | Itt adható meg az Excel fájl azonosítóneve. Az adatforrásra vonatkozó minősítéseket az alapértelmezés szerint üresen hagyott Leírás mezőben adhatja meg.
Adatbázis | Itt módosíthatja a fájlok alapértelmezett helyét. Ha másik helyet szeretne megadni, kattintson a Könyvtár választása vagy a Munkafüzet választása gombra, attól függően, hogy a Verzió mezőben melyik Excel verziót adta meg.
Illesztőprogram | A Pásztázandó sorok a Telepítő vagy az illesztőprogram által az oszlopok és azok adattípusainak beállításánál pásztázott sorok számát adja meg. 1 és 16 között bármilyen szám lehet. Az Excel fájl frissítésének letiltásához válassza az Olvasásra lehetőséget.

Megjegyzés Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapot, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) További információk a súgófájl alábbi címszavai alatt találhatók: Adatforrás-konverzió, Excel fájlok, IISAM rendszerleíró bejegyzések és Az ODBC összetevők általánosan használt fájljai. Terméktámogatás is igénybe vehető.


ODBC szövegbeállítások párbeszédpanel

Az ODBC szövegbeállítások párbeszédpanel többek között az alábbi vezérlőket tartalmazza:

Adatforrás információ | Itt adható meg a fájl azonosítóneve. Az adatforrásra vonatkozó minősítéseket az alapértelmezés szerint üresen hagyott Leírás mezőben adhatja meg.
Adatbázis | A fájl alapértelmezett helye. Ha másik helyet szeretne kijelölni, kattintson a Könyvtár választása gombra.
Fájlok | Az adatforrás szöveges fájljainak kiterjesztését sorolja fel. Ha a könyvtár valamennyi fájlját használni szeretné, jelölje be az Alapértelmezett (*.*) jelölőnégyzetet. Ha csak bizonyos kiterjesztésű fájlokkal kíván dolgozni, törölje a jelet az Alapértelmezett (*.*) jelölőnégyzetből, és írja be a kívánt kiterjesztéseket. Az Alapértelmezett (*.*) jelölőnégyzet kijelölésének megszüntetése után az alapértelmezett kiterjesztések a következők: *.asc, *.csv, *.tab és *.txt. Ha új kiterjesztéssel szeretné kiegészíteni a listát, írja be azt a Kiterjesztés mezőbe és kattintson a Hozzáadás gombra. A kiterjesztésnek *.xxx formátumban kell lennie. Ha például .dat fájlokat kíván használni, írja be: *.dat. Ha valamelyik kiterjesztést szeretné eltávolítani, jelölje ki azt a Kiterjesztések listában és kattintson az Eltávolítás gombra.
Formátum megadása | A kijelölt fájl oszlopformátumainak megadását és az egyes adattáblák sémameghatározását a Szövegformátum megadása párbeszédpanelen végezheti el. Megjegyzés Ha a szöveg-illesztőprogram használatakor a CREATE TABLE utasítás végrehajtásához kiterjesztés nélkül adja meg a tábla nevét, kiterjesztés nélküli fájl jön létre. A Szövegformátum megadása párbeszédpanelen akkor jelenítheti meg a kiterjesztés nélküli fájlokat, ha az ODBC szövegbeállítások párbeszédpanel Kiterjesztések listájára felveszi a „*.” bejegyzést.

Megjegyzés Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapot, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) További információk a súgófájl alábbi címszavai alatt találhatók: Adatforrás-konverzió, IISAM rendszerleíró bejegyzések, Text ISAM fájlok és Az ODBC összetevők általánosan használt fájljai.


Paradox fájlok

Az ODBC Desktop Database Drivers 4.0 az alábbi ISAM fájlokat tartalmazza a Paradox számára:

32 bites ISAM | Paradox verzió
Mspdox40.dll Odpdx32.dll | Paradox 3.x Paradox 4.x Paradox 5.x


Terméktámogatás

Miután az ODBC számos Microsoft termékben egy alapvető összetevő, a termékek pedig tartalmazzák az ODBC illesztőprogramokat is, a Microsoft Terméktámogatási szolgáltatás minden termékhez igénybe vehető, mely összetevőként tartalmazza az ODBC-t. Az ODBC-hez nyújtott támogatás az adott termék garanciális szerződésének megfelelően történik. További információt az adott termék dokumentációjában találhat.


Adatbázis helyreállítása párbeszédpanel

Az Adatbázis helyreállítása párbeszédpanel a kijavítandó adatbázisra vonatkozó beállítások elvégzésére szolgál. Itt állítható be a javítás alatti hozzáférési jogosultság: Megosztva olvasható/írható (alapértelmezés), Olvasásra (ezzel letiltja a frissítéseket), vagy Kizárólagos.

Ha a végrehajtási folyamat alatt ügyfélhiba történik, az érintett adatbázis megsérülhet és javítást igényelhet. A javítások elvégzéséhez az ODBC Microsoft Access beállítások párbeszédpanel nyújt segítséget. Kattintson a Helyreállítás gombra, majd az Adatbázis helyreállítása párbeszédpanelen adja meg a fájl elérési útvonalát. Ezután kattintson az OK gombra.


Adatbázis választása párbeszédpanel

Ha telepítéskor nem ad meg adatbázist, az adatforráshoz való csatlakozáskor a program kérni fogja, hogy jelöljön ki egy adatbázisfájlt.

A Microsoft Access illesztőprogram használata esetén egy meglévő adatbázis megnyitásához kattintson a Kiválasztás gombra az ODBC Microsoft Access beállítások párbeszédpanelen. Ekkor megjelenik az Adatbázis választása párbeszédpanel, amelyen többek között az alábbi vezérlők találhatók:

Adatbázis neve | Az adott adatbázisfájl neve .mdb kiterjesztéssel.
Olvasásra | Az adatbázist írásvédetté teszi, így megakadályozza a frissítéseket.
Kizárólagos | Ha ezt a jelölőnégyzetet bejelöli, az adatbázis Kizárólagos módban nyílik meg. Így egyszerre csak egy felhasználó férhet hozzá és javul a teljesítmény. Ha a jelölőnégyzet nincs bejelölve, az adatbázis Megosztott módban nyílik meg, így egyszerre több felhasználó is hozzáférhet.


Indexek választása párbeszédpanel

Az Indexek választása párbeszédpanelen többek között az alábbi vezérlők találhatók:

Táblák | Itt láthatók a kijelölt adatforrás fájljai.
Indexek | Itt láthatók a Táblák listában kijelölt fájlhoz rendelt indexek.
Fájltípus | Itt adható meg, milyen típusú fájlok jelenjenek meg az Indexek listában.

Az ODBC dBASE illesztőprogram automatikusan megnyitja és frissíti a dBASE IV indexfájlokat. Ha a dBASE III .ndx fájlokhoz dBASE fájlokat szeretne rendelni, az Indexek választása párbeszédpanelt kell használnia.

dBASE indexek létrehozásánál az alábbi korlátozások vannak érvényben:

  • Minden oszlopnévnek érvényes névnek kell lennie.

  • Az oszlopoknak ugyanazt az emelkedő vagy csökkenő sorrendet kell követniük.

  • A csak szöveget tartalmazó oszlopok hossza nem lehet több 100 bájtnál.

  • Ha több oszlop is van, mindnek szöveges oszlopnak kell lennie és az oszlopok összesített mérete nem haladhatja meg a 100 bájtot.

  • A megjegyzésmezők nem indexelhetők.

  • Az aktuális mezőkészlethez nem tartozhat korábban létrehozott index. (Vagyis többszörös indexek nem használhatók.)

  • Az indexek neveinek a dBASE elnevezési szabályokat kell követniük. A dBASE III esetében minden indexnek külön fájlban kell lennie, kiterjesztésük pedig csak .ndx lehet. A dBASE IV indexei címkenévként kerülnek létrehozásra és egyetlen .mdx fájlban tárolódnak, amely az adatbázisfájllal azonos alapnevet visel. (Az Emp.mdx például az Emp.dbf adatbázis indexfájlja.)

Index hozzárendelése táblához

  1. A Táblák listából válasszon egy fájlt.

  2. Az Indexek listából válasszon egy indexet.

  3. A tábla/index hozzárendelés mentéséhez kattintson az OK gombra.

Megjegyzés Az illesztőprogram csak akkor ismeri fel a dBASE III indexeket, ha a hozzárendelést ezen a párbeszédpanelen végezte.


Rendszeradatbázis választása párbeszédpanel

A Microsoft Access illesztőprogram használata esetén a rendszeradatbázis kijelöléséhez kattintson az Adatbázis, majd a Rendszeradatbázis gombra az ODBC Microsoft Access beállítások párbeszédpanelen. Ekkor megjelenik a Rendszeradatbázis választása párbeszédpanel. A rendszer biztonsági beállításaitól függően az illesztőprogram kérheti a rendszeradatbázis nevét és a jelszót. Az alapértelmezett név Admin, a hozzá tartozó Microsoft Access jelszó pedig egy üres karakterlánc.

A Rendszeradatbázis választása párbeszédpanelen többek között az alábbi vezérlők találhatók:

Adatbázis neve | Az adott adatbázisfájl neve .mdb kiterjesztéssel.
Olvasásra | Az adatbázist írásvédetté teszi, így megakadályozza a frissítéseket.
Kizárólagos | Ha ezt a jelölőnégyzetet bejelöli, az adatbázis Kizárólagos módban nyílik meg. Így egyszerre csak egy felhasználó férhet hozzá és javul a teljesítmény. Ha a jelölőnégyzet nincs bejelölve, az adatbázis Megosztott módban nyílik meg, így egyszerre több felhasználó is hozzáférhet.


Munkafüzet választása párbeszédpanel

A Microsoft Excel munkafüzetfájlok kereséséhez és kiválasztásához használja a Munkafüzet választása párbeszédpanelt. Az Adatbázis neve mező a kijelölt fájlt mutatja. Ha meg szeretné tiltani a fájl frissítését, jelölje be az Olvasásra jelölőnégyzetet. A szükséges munkafüzetfájlt a Könyvtár, Fájltípus és Meghajtó mezők segítségével, hálózaton a Hálózat gombra történő kattintással keresheti meg.


Speciális beállítások párbeszédpanel

A Speciális beállítások párbeszédpanel használata előtt meg kell adnia az illesztőprogram bejelentkezési nevét és jelszavát.

A rendszer biztonsági beállításaitól függően az illesztőprogram kérheti a belépő nevét és jelszavát, ha az adatforrás rendszeradatbázist (munkacsoport-adatbázist) használ. Az alapértelmezett név Admin, az Admin felhasználóhoz tartozó Microsoft Access jelszó pedig egy üres karakterlánc.

Az Access adatbázisokhoz való hozzáféréskor az illesztőprogram az alábbi, a Speciális beállítások párbeszédpanelen elérhető beállításokat használja.

DefaultDir | Itt adható meg az illesztőprogram által elérendő alapértelmezett könyvtár.
Driver | Az Access illesztőprogramnak itt adhat egyéni nevet.
FIL | A fájl típusa. Microsoft Access fájloknál a típus „MS Access”.
ExtendedAnsiSQL | Kapcsolódási karakterlánc attribútuma. "1"-es beállítás esetén engedélyez olyan Jet 4.0 szolgáltatásokat, mint nézetek és eljárások létrehozása és elengedése, adatcsonkítás észlelése, új adattípusok, illetve az SQL-92 fenntartott szólista használata. Alapértelmezett beállítása "0", mely a fenti szolgáltatások egyikét sem engedélyezi.
ImplicitCommitSync | Itt adhatja meg, hogy a tranzakciókon kívüli módosítások miként kerüljenek az adatbázisba. Az érték alapértelmezés szerint „Igen”, ami azt jelenti, hogy a Microsoft Access illesztőprogram megvárja a belső/implicit tranzakciók utasításainak végrehajtását.
MaxBufferSize | A Microsoft Access által a lemezről, illetve a lemezre történő adatátvitelre használt belső puffer mérete kilobájtban. Az alapértelmezett pufferméret 2048K (a panelen mértékegység nélkül (2048) látható). Bármely 256-tal osztható egész szám megadható. Ezt a beállítást a Beállítások párbeszédpanel Pufferméret mezőjében is elvégezheti.
MaxScanRows | Az adott oszlopba bevitt adatokon alapuló adattípus-beállításkor pásztázandó sorok száma. A szám 1 és 16 között lehet. Az alapértelmezett érték 8. Ha az értéket 0-ra állítja, a program minden sort pásztázni fog. (Határértéken kívüli szám beírásakor hibaüzenet jelenik meg.)
PageTimeout | Az az idő (tizedmásodpercben), amíg a nem használt lapok a pufferben maradnak. A Microsoft Access illesztőprogram esetében az alapértelmezett érték 0,5 másodperc. Az értéknek nagyobbnak kell lennie 0-nál. A beállítás minden adatforrásra érvényes, mely a Microsoft Access illesztőprogramot használja.
ReadOnly | Az adatbázist írásvédetté teszi, így megakadályozza a frissítéseket.
SafeTransactions | Ha az alapértelmezett 0 értéket választja, a program minden tranzakciót azonnal végrehajt. Ha az értéket 1-re állítja, a tranzakciók lemezre mentése csak végrehajtási művelet esetében következik be, de a teljesítmény kis mértékben csökken.
Threads | A motor által használandó háttérszálak száma. Az alapértelmezett érték 3. Ha az adatbázis tevékenysége nagy, növelheti a szálak számát.
UserCommitSync | Itt adhatja meg, hogy a Microsoft Access illesztőprogram végrehajtson-e explicit felhasználói tranzakciókat aszinkron módon. Az érték alapértelmezés szerint „Igen”, ami azt jelenti, hogy a Microsoft Access illesztőprogram megvárja a felhasználói tranzakciók utasításainak végrehajtását. Többfelhasználós környezetben beláthatatlan következményekkel járhat, ha az értéket „Nem”-re állítja.


Text ISAM fájlok

Az ODBC Desktop Database Drivers 4.0 az alábbi két 32 bites ISAM fájlt tartalmazza a Text fájlokhoz: Mstext40.dll és Odtext32.dll.


ODBC Paradox beállítások párbeszédpanel

Az ODBC Paradox beállítások párbeszédpanel többek között az alábbi vezérlőket tartalmazza:

Adatforrás információ | Itt adható meg a Paradox adatbázis azonosítóneve, amely alapértelmezés szerint a gyártó által megadott név. Az adatforrásra vonatkozó minősítéseket az alapértelmezés szerint üresen hagyott Leírás mezőben adhatja meg.
Adatbázis | Itt keresheti meg a Paradox adatbázis helyét, vagy választhatja az aktuális könyvtárat. A telepített adatbázisok megfelelő verzióját is kijelölheti.
Egyebek Az illesztőprogram hozzáférésre, szolgáltatásokra és teljesítményre vonatkozó beállításainak módosítását az alábbi vezérlőkkel végezheti el:
  • Rendezési sorrend: Itt írható le a mezők rendezési sorrendje.

  • Kizárólagos: A hozzáférést egy felhasználóra korlátozza és javítja a teljesítményt.

  • Várakozási idő: Az az idő (tizedmásodpercben), amíg a nem használt lapok a pufferben maradnak.

  • Felhasználónév: Zárolás esetén a Paradox fájlok többi felhasználója számára ez a Paradox felhasználónév jelenik meg.

  • Hálózattípus: A Paradox adatok hálózati eléréséhez használt hozzáférési mód.

Megjegyzés Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapot, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) További információk a súgófájl alábbi címszavai alatt találhatók: Adatforrás-konverzió, Paradox fájlok, IISAM rendszerleíró bejegyzések és Az ODBC összetevők általánosan használt fájljai. A Paradox az INPRISE Corporation terméke és saját súgófájl tartozik hozzá.