Append

Lehetővé teszi, hogy a megadott mappában tárolt fájlokat úgy nyithassák meg a programok, mintha az aktuális mappában lennének.

Az így megadott mappa az úgynevezett hozzáfűzött mappa, mivel az adatfájlok megnyitása érdekében úgy használható, mintha az aktuális mappához tartozna.

append [;] [[meghajtó:]elérési_útvonal[;...]] [/x:{on | off}][/path:{on | off}] [/e]

Paraméterek

;

Törli a hozzáfűzött mappák listáját.

[meghajtó:]elérési_útvonal

Itt adható meg az aktuális mappához hozzáfűzni kívánt meghajtó (ha különbözik az aktuális meghajtótól) és mappa. Pontosvesszővel elválasztva több [meghajtó:]elérési_útvonal bejegyzés is megadható. Paraméterek nélkül használva a hozzáfűzés parancs törli a hozzáfűzött mappák meglevő listáját.

/x:{on | off}

Itt adható meg, hogy a programok végrehajtásakor az MS-DOS alrendszer keressen-e hozzáfűzött mappákat. Az /x:on kapcsoló használatakor a program megkeresi a hozzáfűzött mappákat. Az /x:off kapcsoló használatakor a program nem keres hozzáfűzött mappákat. Az /x:on paraméter helyett használható a /x paraméter is. Az /x:on paramétert az append parancs rendszerindítás utáni első használatakor kell megadni. Később lehetőség van az /x:on és /x:off állapotok közötti átkapcsolásra.

/path:{on | off}

Itt adható meg, hogy a program az adatfájl keresésekor keressen-e a hozzáfűzött mappákban akkor is, ha a keresett fájl nevével együtt az elérési útvonala is meg van adva. Az alapértelmezett beállítás: /path:on.

/e

A hozzáfűzött mappák listáját hozzárendeli az APPEND nevű környezeti változóhoz. Ez a paraméter csak az append parancs rendszerindítás utáni első kiadásakor használható. Az /e paraméter használatakor a hozzáfűzött mappák listája a set paranccsal jeleníthető meg. A környezeti változókkal kapcsolatos tudnivalók a Kapcsolódó témakörök között a set témakörre kattintással jeleníthetők meg.

Kapcsolódó témakörök


Példák az Append parancs használatára

Append

Példák

Ha azt kívánja beállítani, hogy a B: meghajtó Levelek mappájában levő adatfájlokat és az A: meghajtó Jelentések mappájában levő adatfájlokat úgy lehessen megnyitni, mintha ezek a fájlok az aktuális mappában lennének, akkor írja be a következő parancsot:

append b:\letters;a:\reports

Ha a mappák hozzáfűzése mellett és a hozzáfűzött mappák listáját a Windows 2000 környezetben is el kívánja tárolni, akkor a következő parancsokat írja be:

append /e

append b:\letters;a:\reports

A rendszer indítása után ezeknek kell az első append parancsoknak lenniük.

Megjegyzés

  • Az append parancs kiadásakor ne használja az .exe fájlnév kiterjesztést.


Megjegyzések az Append parancshoz

Append

Megjegyzések

A hozzáfűzött mappák listájának tárolása a környezetben

Az append parancs /e kapcsolójával a hozzáfűzött mappák listája hozzárendelhető az append nevű környezeti változóhoz. Ehhez először adja ki az append parancsot csak az /e kapcsolóval. Ezután ismét adja ki az append parancsot a hozzáfűzni kívánt mappákkal. Az /e kapcsoló és a [meghajtó:]elérési_útvonal paraméter nem használható ugyanabban a parancssorban.

Több hozzáfűzött mappa megadása

Több mappa hozzáfűzéséhez pontosvesszővel válasszal el a bejegyzéseket. Ha az append parancsot újból kiadja a meghajtó:]elérési_útvonal paraméterekkel, akkor az újonnan megadott mappa vagy mappák kiváltják (lecserélik) a korábbi append parancsban megadott mappákat.

A hozzáfűzött mappák és a dir parancs

A dir parancs nem jeleníti meg a hozzáfűzött mappákban tárolt fájlokat a dir parancs által megjeleníthető fájllistához.

Fájlnévütközések

Ha a hozzáfűzött mappában levő fájl neve megegyezik az aktuális mappában tárolt egyik fájl nevével, akkor a programok az aktuális mappában található fájlt nyitják meg.

Az append parancs használata új fájlokat létrehozó programokkal

Ha a program a hozzáfűzött mappában levő fájlt nyitja meg, a fájl úgy használható, mintha az aktuális mappában lenne. Ha a program ezután ugyanezen a néven új fájlként menti a fájlt, az új fájl az aktuális mappába kerül (nem a hozzáfűzött mappába). Az append parancs olyan adatfájlok esetén használható megfelelően, amelyeket a felhasználó nem módost, vagy módosítás esetén nem új fájlként menti a fájlt. Az adatfájlok módosítás esetén az adatbázis-kezelő programok általában nem hoznak létre új másolatot. A szövegszerkesztő programok azonban a módosított fájlokat általában új fájlként mentik el. A hibák elkerülése érdekében jobb, ha ezekkel a programokkal az append parancsot nem használja.

Az /x:on kapcsoló és a path parancs használata

Az /x:on paraméter megadása esetén a parancssorba a program nevének beírásával futtathatók a hozzáfűzött mappában található programok. A programokat tartalmazó mappák általában a path paranccsal adhatók meg. Amennyiben a program hozzáfűzött mappában található, a mappa megadásához nincs szükség a path parancs használatára. A hozzáfűzött mappában a Windows 2000 az általában használt keresési sorrend alapján keresi a programokat: először az aktuális mappában, aztán a hozzáfűzött mappákban, majd a keresési útvonalakon.


Arp

Megjeleníti és módosítja az Address Resolution Protocol (ARP) által az IP-Ethernet vagy IP-token ring fizikai címek fordításához használt táblát. Ez a parancs csak akkor használható, ha telepítve van a TCP/IP protokoll.

arp -a [Internet_cím] [-N [kártya_címe]]

arp -d Internet_cím [kártya_címe]

arp -s Internet_cím ethernet_cím [kártya_címe]

Paraméterek

-a

A TCP/IP lekérdezésével megjeleníti a jelenlegi ARP-bejegyzéseket. Az Internet_cím változó megadásakor csak a megadott számítógép IP- és fizikai címe jelenik meg.

-g

Megegyezik az -a változóval.

Internet_cím

Pontokkal tagolva tízes számrendszerben itt adható meg az IP-cím.

-N

Megjeleníti az kártya_címe változóban megadott hálózati kártyához tartozó ARP-bejegyzéseket.

kártya_címe

Megadja annak a kártyának az IP-címét (ha van), amelynek módosítani kell a címfordítási tábláját. Ha ilyen nincs, akkor az első alkalmazható kártyát használja a parancs.

-d

Törli az Internet_cím. által megadott bejegyzést.

-s

Új bejegyzést vesz fel az ARP-gyorsítótárban az Internet_cím IP-cím és az ethernet_cím fizikai cím társításához. A fizikai cím 6, kötőjelekkel elválasztott hexadecimális bájtként adható meg. Az IP-cím tízes számrendszerben, pontokkal tagolva adható meg. A bejegyzés állandó, azaz az időtúllépés határidejének lejárata után a rendszer automatikusan törli a gyorsítótárból.

ethernet_cím

Fizikai címet ad meg.


Assoc

Megjeleníti vagy módosítja a fájlnévkiterjesztések társításait.

assoc [.kiterjesztés[=[fájltípus]]]

Paraméterek

nincs

Megjeleníti az aktuális fájltársításokat. A társítások képernyőnkénti megtekintéséhez a parancshoz fűzze hozzá a |more parancsot is. Ha az eredményt fájlba kívánja irányítani, a parancshoz fűzze hozzá a >fájlnév.kit parancsot.

.kit

Itt adható meg az a fájlnévkiterjesztést, amelynek társításait megjeleníteni vagy módosítani kívánja.

  • A fájlnévkiterjesztéshez tartozó jelenlegi társítások megtekintéséhez írja be az assoc .kit parancsot.
  • A fájlnévkiterjesztéshez tartozó társítás törléséhez írja be az assoc . kit= parancsot.

filetype

Meghatározza azt a fájltípust, amelyet a Windows 2000 társít az adott fájlnévkiterjesztéshez.


At

Felsorolja az ütemezett parancsokat, vagy beütemezi a parancsok vagy programok megadott időben és napon történő futtatását. Az at parancs használatához futnia kell az Ütemező szolgáltatásnak.

at [\\számítógépnév] [[azonosító] [/delete] | /delete [/yes]]

at [\\számítógépnév] idő [/interactive] [/every:dátum[,...] | /next:dátum[,...]] parancs

Paraméterek

nincs

Paraméterek nélkül használva az at parancs listázza az ütemezett parancsokat.

\\számítógépnév

Távoli számítógépet ad meg. Ha ez a paraméter kimarad, a parancsok ütemezése a helyi számítógépen történik.

id

Megadja az ütemezett parancshoz tartozó azonosítószámot.

/delete

Megszakítja az ütemezett parancsot. Ha az id paraméter kimarad, akkor minden ütemezett parancs megszakad.

/yes

Igen választ kér a rendszertől az ütemezett események törlésekor.

idő

Megadja a parancs futásának idejét. Az idő kifejezése óra:perc formában, 24 órás beosztásban történik (00:00-tól [éjféltől] 23:59-ig).

/interactive

Lehetővé teszi a feladat és a feladat futtatásakor bejelentkezett felhasználó munkaasztala közötti kapcsolatot.

/every:dátum[,...]

Futtatja a programot a hét vagy hónap megadott napján vagy napjain (például minden csütörtökön, vagy minden hónap harmadik napján). Dátumként adja meg a hét (M,T,W,Th,F,S,Su) vagy a hónap (1-től 31-ig) egy vagy több napját. A bejegyzéseket válassza el vesszővel. Ha a dátum paramétert kihagyja, a hónap aktuális napját használja a parancs.

/next:dátum[,...]

Futtatja a parancsot a megadott nap következő bekövetkezésekor (például a következő csütörtökön). Dátumként adja meg a hét (M,T,W,Th,F,S,Su) vagy a hónap (1-től 31-ig) egy vagy több napját. A bejegyzéseket válassza el vesszővel. Ha a dátum paramétert kihagyja, a hónap aktuális napját használja a parancs.

parancs

Meghatározza a futtatni kívánt Windows 2000 parancsot, programot (.exe vagy . com fájlt) vagy kötegfájlt (.bat vagy .cmd fájlt). Ha a parancshoz paraméterként elérési útvonalat kell megadni, használja a teljes elérési útvonalat, a meghajtóbetűjellel kezdve. Ha a parancs távoli számítógépen van, a távoli meghajtó betűjele helyett inkább univerzális névkonvenciót használjon a kiszolgáló és a megosztás névének megadásához. Ha a fájl nem végrehajtható (.exe) fájl, akkor a parancsot a cmd /c parancs használatával kell végrehajtani, például így:

cmd /c dir > c:\teszt.out


Példák az At parancs használatára

At

Példák

A Marketing nevű kiszolgálón ütemezett parancsok listájának megjelenítéséhez írja be a következő parancsot:

at \\marketing

Ha többet szeretne megtudni a Központ nevű kiszolgáló 3-as azonosítószámú parancsáról, írja be a következő parancsot:

at \\központ 3

Ha azt kívánja beütemezni, hogy net share parancs 8.00 órakor fusson a Központ nevű kiszolgálón, és a listát át kívánja irányítani az Üzemeltetés nevű kiszolgáló Jelentések könyvtárában található Központ.txt fájlba, akkor írja be a következő parancsot:

at \\központ 08:00 cmd /c "net share reports=d:\marketing\reports >> \\üzemeltetés\jelentések\központ.txt"

Ha a Marketing nevű kiszolgáló merevlemezéről minden ötödik napon éjfélkor biztonsági mentést szeretne készíteni, akkor hozzon létre egy olyan kötegfájlt (Archiválás.cmd), amely a biztonsági mentéshez szükséges parancsokat tartalmazza. Ezután a kötegfájl futtatása a következő parancs beírásával ütemezhető:

at \\marketing 00:00 /every:5,10,15,20,25,30 arhiválás

Az aktuális kiszolgálón ütemezett összes parancs ütemezésének megszüntetéséhez törölje az at parancs ütemezési adatait a következő parancs segítségével:

at /delete


Megjegyzések az At parancshoz

At

Megjegyzések

Az at parancsot a helyi Rendszergazdák csoport tagjai használhatják. Továbbá a parancsok végrehajtása előtt az at parancs nem tölti be automatikusan a cmd parancsértelmezőt. Ha nem végrehajtható fájlt (.exe) futtat, a parancs elején külön be kell tölteni a Cmd.exe fájlt, például:

cmd /c dir > c:\test.out.

Ütemezett parancsok megtekintése

Az at parancs kétféle kimenettel rendelkezik. Az at parancs beállítások nélküli használatakor a következőhöz hasonló kimenet látható:

Állapot | ID | Nap | Idő | Parancssor
OK | 0 | Mindegyik F | 16:30 | net send group leads status due
OK | 2 | Mindegyik M | 12:00 | chkstor > check.fil
OK | 3 | Mindegyik F | 23:59 | backup2.bat

A parancs azonosítószámának megadásakor az adott elem adatai jelennek meg a közvetkezőhöz hasonlóan:

Feladatazonosító: 0

Állapot: OK

Ütemezés: Mindegyik F

Időpont: 16:30

Parancs: net send group leads status due

A parancs (különösen a kapcsolókat tartalmazó parancsok esetén) az at paranccsal történő ütemezése után az at parancs kapcsolók nélküli elindításával ellenőrizze, hogy helyesen adta-e meg a parancsot. Ha a Parancssor oszlopban nem a helyes adatok láthatók, törölje a parancsot, majd írja be újra. Ha továbbra sem megfelelő, kevesebb választható beállítás (kapcsoló) megadásával írja be a parancsot.

Az eredmények megtekintése

Az at paranccsal ütemezett parancsok háttérfolyamatként futnak, így a számítógép képernyőjén nem jelenik az ütemezett feladatok kimenete. A parancs kimenete a (>) átirányítási szimbólum segítségével irányítható át fájlba. A parancs kimenetének fájlba történő átirányításakor az átirányítási szimbólum előtt használja az escape szimbólumot (^). Az escape szimbólumot az at parancs parancssorban vagy kötegfájlban való alkalmazásakor mindig használni kell a következő példában bemutatott módon:

at 14:45 c:\teszt.bat ^>c:\kimenet.txt.

A végrehajtó parancs jelenlegi könyvtára a %rendszergyökér% könyvtár.

A rendszeridő módosítása

Ha módosítja egy olyan számítógép rendszeridejét, amelyen korábban az at paranccsal parancsokat ütemezett be, az at parancs beállítások nélküli futtatásával a módosított rendszeridőnek megfelelően szinkronizálni kell az at parancs ütemezőjét.

Parancsok tárolása

Mivel az ütemezett parancsokat a rendszer a rendszerleíró adatbázisban tárolja, így az ütemezett feladatok nem vesznek el, ha újra kell indítani az ütemező szolgáltatást.

Csatlakozás hálózati meghajtókhoz

Ne használja a felhasználó által átirányított meghajtókat a hálózathoz kapcsolódó ütemezett feladatokban. Előfordulhat, hogy az ütemező szolgáltatás nem képes csatlakozni ezekhez a meghajtókhoz, vagy a meghajtó nem lesz elérhető, ha az ütemezett feladat futásakor más felhasználó van bejelentkezve. Ezért az ütemezett feladatok esetén lehetőleg az univerzális elnevezési konvencióval adja meg az elérési utvonalakat:

at 1:00pm biztonsági_mentés \\kiszolgáló\megosztás

Kerülendő a következő példában bemutatott használati mód, ahol az x: a felhasználó által létrehozott kapcsolat:

at 1:00pm biztonsági_mentés x:

Ha olyan at parancsot ütemez be, amely meghajtóbetűjel használatával kapcsolódik a megosztott könyvtárhoz, akkor a meghajtó használatának befejezése után az at parancs segítségével gondoskodni kell a meghajtó kapcsolatának bontásáról. Ha nem történik meg a meghajtó leválasztása, akkor a meghajtóhoz rendelt betűjel nem használható, és nem jelenik meg a parancssorban.


Atmadm

A parancs segítségével aszinkron átviteli módú (ATM) hálózaton az ATM hívásvezérlő segédprogram által regisztrált kapcsolatok és címek figyelhetők meg. Ezzel a segédprogrammal az ATM kártyán keresztül beérkező és kimenő hívások statisztikája jeleníthető meg.

atmadm [-c][-a] [-s]

Paraméterek

-c

A számítógépre telepített ATM hálózati kártyához kapcsolódó összes jelenlegi kapcsolat hívásadatait jeleníti meg.

-a

A számítógépre telepített kártyákhoz tartozó regisztrált ATM NSAP-címeket (Network Service Access Point – Hálózati szolgáltatás elérési pontja) jeleníti meg.

-s

Az aktív ATM-kapcsolatok állapotának megfigyelésére szolgáló statisztikát jelenít meg.


Példák az Atmadm parancs használatára

Atmadm

Példák

Hívásadatok megjelenítése

A számítógépre telepített ATM hálózati kártyához kapcsolódó összes jelenlegi kapcsolat hívásadatának megjelenítéséhez írja be a következő parancsot:

atmadm -c

A következő példa a C:\atmadm -c parancs kimenetét mutatja be:

Windows ATM hívásvezérlő statisztika

ATM-kapcsolatok a következő felülethez: [009] Olicom ATM PCI 155 Adapter

   Kapcsolat    VPI/VCI   Távoli cím/
                          Adathordozó jellemzői (bájt/másodpercben)
   In  PMP SVC    0/193   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   Out P-P SVC    0/192   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   In  PMP SVC    0/191   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   Out P-P SVC    0/190   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   In  P-P SVC    0/475   47000580FFE1000000F21A2E180000C110081501
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9188
   Out PMP SVC    0/194   47000580FFE1000000F21A2E180000C110081501 (0)
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9180
                          Rx:UBR,Peak 0,Avg 0,MaxSdu 0
   Out P-P SVC    0/474   4700918100000000613E5BFE010000C110081500
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
                          Rx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
   In  PMP SVC    0/195   47000580FFE1000000F21A2E180000C110081500
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 0
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9180

A példa minden elemének leírása megtalálható az alábbi A.1. táblázatban.

Adat típusa | Képernyőn megjelenő adatok | Leírás
Kapcsolat adatai | In/Out | A hívás iránya. In, ha egy másik eszköztől az ATM hálózati kártya felé irányul, Out, ha az ATM hálózati kártyától egy másik eszköz felé irányul.
 | PMP | Egy pontból több pontba irányuló hívás.
 | P-P | Pont-pont közötti hívás
 | SVC | Kapcsolat kapcsolt virtuális áramkörön.
 | PVC | Kapcsolat permanens virtuális áramkörön.
VPI/VCI adatok | VPI/VCI | A bejövő vagy kimenő hívás virtuális útvonala és virtuális csatornája.
Távoli cím/Adathordozó jellemzői | 47000580FFE1000000F21A2E180000C110081500 | A hívó (In) vagy a hívott (Out) ATM-eszköz NSAP-címe.
 | Tx | A Tx paraméter a következő három elemet foglalja magában: Az alapértelmezett vagy beállított átviteli sebesség típusát (UBR,CBR, VBR vagy ABR) Az alapértelmezett vagy beállított vonalsebességet A beállított szolgáltatási adategység (SDU) méretét
 | Rx | Az Rx paraméter a következő három elemet foglalja magában: Az alapértelmezett vagy beállított átviteli sebesség típusát (UBR,CBR, VBR vagy ABR) Alapértelmezett vagy beállított vonalsebességet Beállított SDU-méretet

Megjeleníti az összes bejegyzett címet

A számítógépre telepített kártyákhoz tartozó regisztrált ATM NSAP-címek (Network Service Access Point – Hálózati szolgáltatás elérési pontja) megjelenítéséhez írja be a következő parancsot.

atmadm -a

A következő példa a C:\atmadm -a parancs kimenetét mutatja be:

Windows ATM hívásvezérlő statisztika

ATM-címek a következő kártyán: [009] Olicom ATM PCI 155 Adapter

47000580FFE1000000F21A2E180000C110081500

Statisztika megjelenítése

Az aktív ATM-kapcsolatok állapotának megfigyelésére szolgáló statisztika megjelenítéséhez írja be a következő parancsot:

atmadm -s

A következő példa a C:\atmadm -s parancs kimenetét mutatja be:

Windows ATM hívásvezérlő statisztika

ATM hívásvezérlő statisztika a következő kártyán : [009] Olicom ATM PCI 155 Adapter

    Jelenlegi aktív hívások                 = 4
    Összes sikeres bejövő hívás             = 1332
    Összes sikeres kimenő hívás             = 1297
    Sikertelen bejövő hívások               = 1
    Sikertelen kimenő hívások               = 1
    Távolról lezárt hívások                 = 1302
    Helyileg lezárt hívások                 = 1323
    Elküldött jel- és ILMI-csomagok         = 33655
    Fogadott jel- és ILMI-csomagok          = 34989

Az alábbiakban a példa minden elemének leírása megtalálható az A.2. táblázatban.

Call Manager Statistic | Leírás
Jelenlegi aktív hívások | Jelenlegi aktív hívások száma a számítógépre telepített ATM-kártyán.
Összes sikeres bejövő hívás | Az ATM-hálózat más eszközeitől sikeresen fogadott hívások.
Összes sikeres kimenő hívás | A számítógépről az ATM-hálózat más eszközeivel sikeresen létrehozott hívások száma.
Sikertelen bejövő hívások | A sikertelen beérkező kapcsolódási kísérletek száma.
Sikertelen kimenő hívások | A számítógépről más hálózati eszközökhöz kezdeményezett sikertelen kapcsolódási kísérletek száma.
Távoli bezárt hívások | Távoli hálózati eszköz által bezárt hívások száma.
Helyileg lezárt hívások | A számítógép által befejezett hívások száma.
Elküldött jel- és ILMI-csomagok | Azoknak az ILMI-csomagoknak (Integrated Local Management Interface – Integrált helyi kezelőfelület) a száma, amelyeket ahhoz a kapcsolóhoz küldött a rendszer, amelyhez a számítógép megpróbál kapcsolódni.
Fogadott jel- és ILMI-csomagok | Az ATM-kapcsolótól fogadott ILMI-csomagok száma.


Attrib

Megjeleníti vagy módosítja a fájlattribútumokat.

A paranccsal megjeleníthetők, beállíthatók vagy törölhetők a fájlokhoz vagy könyvtárakhoz rendelt írásvédett, archiválandó, rendszer, illetve rejtett tulajdonságok.

attrib [+r|-r] [+a|-a] [+s|-s] [+h|-h] [[meghajtó:][elérési_útvonal] fájlnév] [/s[/d]]

Paraméterek

+r

Beállítja az írásvédett attribútumot.

-r

Törli az írásvédett attribútumot.

+a

Beállítja az archiválandó attribútumot.

-a

Törli az archiválandó attribútumot.

+s

A fájlt rendszerfájlként jelöli meg.

-s

Törli a rendszerfájl attribútumot.

+h

A fájlt rejtett fájlként jelöli meg.

-h

Törli a rejtett fájl attribútumot.

[[meghajtó:][elérési_útvonal] fájlnév]

A feldolgozni kívánt könyvtár, fájl vagy fájlok elérési helyét és nevét adja meg. A fájlnév paraméter megadásakor helyettesítő karakterek (? és *) is használhatók több fájl attribútumának megjelenítéséhez vagy módosításához.

/s

Az aktuális könyvtárban, valamint annak valamennyi alkönyvtárában feldolgozza a feltételeknek megfelelő fájlokat.

/d

Könyvtárakat dolgoz fel.


Példák az Attrib parancs használatára

Attrib

Példák

Az aktuális meghajtón található Hírek86 nevű fájl attribútumai a következő parancs beírásával jeleníthetők meg:

attrib hírek86

A Jelentés.txt nevű fájl írásvédett attribútuma a következő parancs beírásával állítható be:

attrib +r jelentés.txt

A B meghajtóban található lemez \Közös\János könyvtárában, és annak alkönyvtáraiban levő összes fájl írásvédett attribútuma a következő paranccsal távolítható el:

attrib -r b:\közös\jános\*.* /s

Utolsó példaként nézzünk meg egy olyan példát, melyben a kollégájának olyan lemezt kíván adni, amely az A meghajtóban található lemez alapértelmezett könyvtárában elhelyezkedő valamennyi fájlt tartalmazza, a .bak kiterjesztésű fájlok kivételével. Mivel az xcopy parancs segítségével csak az archiválandó attribútummal megjelölt fájlok másolhatók, ezért a másolni kívánt fájlok esetén be kell állítani az Archiválandó attribútumot. Ehhez a következő két paranccsal előbb be kell állítani az A meghajtóban levő lemez összes fájlján az Archiválandó attribútumot, majd a .bak kiterjesztésű fájlok esetében törölni kell ezt az attribútumot:

attrib +a a:*.* attrib -a a:*.bak

Ezután az xcopy paranccsal átmásolhatók az A meghajtóban található lemezen levő fájlok a B meghajtóban található lemezre. A parancsban az /a kapcsoló megadása esetén az xcopy csak az Archiválandó attribútummal rendelkező fájlokat másolja át:

xcopy a: b: /a

Ha a másolás után az xcopy parancs segítségével törölni kívánja a fájlok Archiválandó attribútumát, akkor az alábbi példában látható módon az /a kapcsoló helyett használja az /m kapcsolót:

xcopy a: b: /m


Megjegyzések az Attrib parancshoz

Attrib

Megjegyzések

Fájlcsoportok

A fájlnév paraméter megadásakor helyettesítő karakterek (? és *) is használhatók több fájl attribútumának megjelenítéséhez vagy módosításához. Ha a fájl a Rendszer vagy a Rejtett attribútummal rendelkezik, akkor a többi attribútum módosításához előtt törölni kell ezeket az attribútumokat.

Az archiválandó attribútum

Az Archiválandó attribútum (+a) azoknak a fájloknak a megjelölésére szolgál, amelyek a legutóbbi biztonsági mentés óta módosultak. Az xcopy parancs ezt az Archiválandó attribútumot használja. Az xcopy parancshoz tartozó Archiválandó attribútummal kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Kötegfájlban használható parancsok

További tudnivalókért válassza ki a parancsot.

call | goto | setlocal
echo | if | shift
endlocal | pause | %
for | rem |

A kötegfájlok (vagy más néven kötegelt fájlok) lehetővé teszik a rutinszerű vagy ismétlődő feladatok leegyszerűsítését. A kötegfájl .bat vagy .cmd fájlnévkiterjesztésű formázatlan szövegfájl, amely egy vagy több parancsot tartalmaz. A parancssorba a fájlnév beírása után a rendszer egymás után végrehajtja a fájlban szereplő parancsokat.

A kötegfájl bármilyen parancsot tartalmazhat. A parancsokkal együtt használható for, goto és if utasítások a kötegfájlban található parancsok feltételes feldolgozását is lehetővé teszik. Az if utasítás például egy feltétel eredményétől függően hajtja végre a parancsot. Más utasításokkal a parancsok bemenete és kimenete szabályozható, vagy másik kötegfájl hívható meg. A % helyettesíthető paraméter a kötegfájl paraméter-változóit bővíti ki.


Break

A Windows 2000 nem használja ezt a parancsot. Kizárólag az MS-DOS fájlokkal való kompatibilitás miatt fogadja el a rendszer.


Buffers

A Windows 2000 és az MS-DOS alrendszer nem használja ezt a parancsot. Kizárólag az MS-DOS fájlokkal való kompatibilitás miatt fogadja el a rendszer.


Cacls

A fájlok hozzáférés-vezérlési listáját (ACL) jeleníti meg, vagy módosítja.

cacls fájlnév [/t] [/e] [/c] [/g felhasználó:engedély] [/r felhasználó [...]] [/p felhasználó:engedély [...]] [/d felhasználó [...]]

Paraméterek

fájlnév

Megjeleníti a megadott fájlok hozzáférés-vezérlési listáját.

/t

Módosítja az aktuális könyvtárban, és annak alkönyvtáraiban található megadott fájlok hozzáférés-vezérlési listáját.

/e

Csere helyett szerkeszti a meglévő hozzáférés-vezérlési listát.

/c

A hibák mellőzésével folytatja a hozzáférés-vezérlési listák módosítását.

/g felhasználó:engedély

Biztosítja a megadott felhasználói engedélyeket. Az engedély paraméter a következők egyike lehet:

n Nincs

r Olvasás

c Módosítás (Írás)

f Teljes hozzáférés

/r felhasználó

Visszavonja a megadott felhasználói engedélyeket.

/p felhasználó:engedély

Lecseréli a megadott felhasználói engedélyeket. Az engedély paraméter a következők egyike lehet:

n Nincs

r Olvasás

c Módosítás (Írás)

f Teljes hozzáférés

/d felhasználó

Letiltja a megadott felhasználói hozzáférést.

A parancson belül több fájl vagy felhasználó is megadható.


Call

Másik kötegfájlt hív meg úgy, hogy a szülő kötegfájl futása nem áll le. A call parancsban a hívás céljaként most már címkék is megadhatók.

call [meghajtó:][elérési_útvonal] fájlnév [kötegfájl-paraméterek]

call :címke [paraméterek]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

A meghívni kívánt kötegfájl elérési helyét és nevét adja meg. A Fájlnév paraméternek .bat vagy .cmd kiterjesztéssel kell rendelkeznie.

kötegfájl-paraméterek

A kötegfájl számára esetleg szükséges parancssori adatokat adja meg. A kötegfájl-paraméterek kiterjesztéseivel kapcsolatos tudnivalókért tanulmányozza a paraméterek szakaszt alább.

:címke

Azt a címkét adja meg, amelyre a kötegfájl vezérlésének ugrania kell. Ha a call parancsot ezzel a paraméterrel használja, akkor a rendszer új kötegfájlkörnyezet hoz létre, és a vezérlést átadja a megadott címke után következő utasításnak. Ha a parancsfájl végrehajtása (a címkére ugrás után) eléri a kötegfájl végét, a rendszer visszaadja a vezérlést a CALL utasítás után következő utasításnak. Ha a rendszer másodszor is eléri a kötegfájl végét , befejezi a fájl végrehajtását. A kötegfájlból való visszatérést biztosító goto :eof kiterjesztéssel kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a goto témakörre.


Példák a Call parancs használatára

Call

Példák

Ha az ellenőzés.bat programot egy másik kötegfájlból kívánja futtatni, akkor a szülő kötegfájlba vegye fel a következő parancsot:

call ellenőrzés

Tegyük fel, hogy a szülő kötegfájl két helyettesíthető paramétert fogad el, és ezeket a paramétereket át kívánja adni az ellenőzés.bat számára. A szülő kötegfájlban a következő parancs használható erre a célra:

call ellenőrzés %1 %2


Megjegyzések a Call parancshoz

Call

Megjegyzések

A kötegfájl-paraméterek használata

A kötegfájl-paraméterek a kötegfájlnak átadni kívánt bármilyen adatot tartalmazhatnak. Ezek az adatok kapcsolók, fájlnevek, a %1-től %9-ig terjedő helyettesíthető paraméterek és a %baud% változóhoz hasonló változók lehetnek.

Cső és átirányító jel használata

A call parancsban ne használjon csőt és átirányító jeleket.

Rekurzív hívás létrehozása

Létrehozható önmagát meghívó kötegfájl; ilyenkor azonban kilépési feltételt kell megadni. Ellenkező esetben a szülő és a gyerek kötegfájl végtelen ciklusba kerülhet.


Chcp

Megjeleníti az aktív konzol által használt kódlap számát, vagy lecseréli azt az aktív kódlapot, amelyet a Windows 2000 a konzolon használ. A raszteres betűkészletet használó parancssor ablakban csak a Windows 2000 operációs rendszerrel telepített OEM kódlap jelenik meg helyesen. Más kódlapok csak teljes képernyős üzemmódban, vagy TrueType betűkészletet használó parancssor ablakban jelennek meg helyesen.

chcp [nnn]

Paraméter

nincs

Paraméterek nélkül a chcp parancs megjeleníti az aktív konzol által használt kódlap számát.

nnn

A kódlapot adja meg. A következő lista a Windows 2000 rendszerben használható kódlapokat mutatja be, a kódlapot használó országgal/területtel vagy nyelvvel együtt:

437 Egyesült Államok
850 többnyelvű (Latin I)
852 szláv (Latin II)
855 cirill (orosz)
857 török
860 portugál
861 izlandi
863 kanadai francia
865 északi
866 orosz
869 modern görög


Példák a Chcp parancs használatára

Chcp

Példák

Az aktív kódlapbeállítás megtekintéséhez írja be a következő parancsot:

chcp

A Windows 2000 a következőhöz hasonló üzenetet jelenít meg:

Az aktív kódlap: 852

Aktív kódlapként a 850-es (Többnyelvű) kódlap a következő parancs beírásával állítható be:

chcp 850

Érvénytelen kódlap megadásakor a Windows 2000 figyelmeztetést jelenít meg. A következő hibaüzenet jelenik meg:

Érvénytelen kódlap


Megjegyzések a Chcp parancshoz

Chcp

Megjegyzések

A kódlapokat nem kell előkészíteni

A kódlapokat nem szükséges az MS-DOS-ban megszokott módon előkészíteni.

Új kódlap hozzárendelése

Az új kódlap kiválasztása után elindított programok az új kódlapot használják. Az új kódlap kiválasztása előtt indított programok (a Cmd.exe kivételével) azonban valószínűleg az eredeti kódlapot próbálják továbbra is használni.


Chdir (Cd)

Megjeleníti az aktuális könyvtár nevét, vagy megváltoztatja az aktuális könyvtárat.

chdir [/d] [meghajtó:][elérési_útvonal] [..]

-vagy-

cd [/d] [meghajtó:][elérési_útvonal] [..]

Paraméterek

nincs

Paraméterek nélkül a chdir parancs az aktuális meghajtó és mappa nevét jeleníti meg. Csupán a meghajtó betűjelének megadásakor (például cd C:) a chdir parancs a megadott meghajtó aktuális könyvtárát jeleníti meg.

[/d]

Megváltoztatja az aktuális meghajtót, valamint a meghajtó aktuális könyvtárát. A parancskiterjesztések engedélyezése esetén (a Windows 2000 esetében ez az alapértelmezett beállítás) az aktuális könyvtár neve átalakul, és a lemezen található könyvtár tényleges nevének megfelelően tartalmazza a kis- és nagybetűket. Például a cd C:\Temp paranccsal a C:\Temp könyvtár adható meg aktuális könyvtárként, ha az a lemezen is ilyen néven szerepel.

[[meghajtó:][elérési_útvonal]

Azt a meghajtót (ha különbözik az aktuális meghajtótól) és könyvtárat adja meg, amelyre át kíván váltani.

[..]

Azt jelzi, hogy a szülőmappára kíván váltani.


Példák az Chdir parancs használatára

Chdir

Példák

A következő parancsok bármelyikével a Jelentések könyvtár adható meg aktuális könyvtárként:

chdir \jelentések

cd \jelentések

Tegyük fel, hogy létezik egy Speciális nevű könyvtár, és azon belül egy nevű Szponzorok alkönyvtár. Az aktuális könyvtár a következő parancs beírásával változtatható a \Speciális\Szponzorok könyvtárra:

cd \speciális\szponzorok

Ha az aktuális könyvtár a \Speciális könyvtár, akkor a következő paranccsal válthat a \Speciális\Szponzorok könyvtárra:

cd szponzorok

A könyvtárból a következő paranccsal válthat a könyvtár szülőkönyvtárára:

cd ..

Az aktuális könyvtár neve a chdir vagy a cd parancs paraméterek nélküli megadásával jeleníthető meg. Ha például a B meghajtóban található lemezen az aktuális könyvtár neve \Közös\János, akkor a chdir parancs beírásakor a következő válasz jelenik meg:

B:\Közös\János

Ha a D meghajtón dolgozik, akkor a következő parancsokkal a C meghajtó \Közös\Jásnos és \Közös\Lajos könyvtárában található valamennyi fájl a D meghajtó főkönyvtárába másolható:

chdir c:\közös\jános

copy c:*.* d:\

chdir c:\közös\lajos

copy c:*.* d:\

A következő parancsok beírásával pedig a \Közös\János és a \Közös\Lajos könyvtár tartalma a D meghajtó aktuális könyvtárába másolható:

chdir c:\közös\jános

copy c:*.* d:

chdir c:\közös\lajos

copy c:*.* d:


Megjegyzések a Chdir parancshoz

Chdir

Megjegyzések

Szóközök használata a chdir parancsban

A parancskiterjesztések engedélyezése (a Windows 2000 rendszerben ez az alapértelmezett beállítás) esetén a chdir parancs segítségével idézőjelek használata nélkül is átválthat egy szóközt vagy szóközöket tartalmazó könyvtárnévre. Például:

cd \winnt\profiles\username\programs\start menu

megegyezik a következő paranccsal:

cd "\winnt\profiles\username\programs\start menu"

amelyet akkor kell így beírni, ha nincsenek engedélyezve a kiterjesztések.

Váltás a gyökérkönyvtárra

A gyökérkönyvtár az adott meghajtón a könyvtár-hierarchia tetején helyezkedik el. A gyökérkönyvtárba a következő parancs beírásával juthat vissza:

cd\

Másik meghajtó aktuális könyvtárának használata

Ha a C meghajtón található \Közös\János könyvtárban dolgozik és átvált a D meghajtóra, akkor a fájlok a \Közös\János könyvtárba vagy könyvtárból való másolásához elegendő a C meghajtó betűjelének megadása.

Könyvtárváltás másik meghajtón

Más meghajtón is megváltoztatható az aktuális könyvtár, ha a chdir parancs használatakor a meghajtó nevét is megadja a parancssorban.


Chkdsk

A használt fájlrendszer alapján állapotjelentést hoz létre és jelenít meg a lemezről. A Chkdsk felsorolja és ki is javítja a lemezen található hibákat. Ha a chkdsk nem képes zárolni a lemezt, akkor felajánlja, hogy az ellenőrzést a számítógép következő újraindításakor végzi el.

Merevlemez esetén a chkdsk parancsot csak a Rendszergazdák csoporthoz tagjai használhatják.

chkdsk [meghajtó:][[elérési_útvonal] fájlnév] [/f] [/v] [/r] [/l[:méret]] [/x]

Paraméterek

nincs

Paraméterek nélkül a chkdsk parancs az aktuális meghajtóban található lemez állapotát jeleníti meg.

meghajtó:

A chkdsk segítségével ellenőrizni kívánt lemezt tartalmazó meghajtót adja meg.

[[elérési_útvonal] fájlnév

Annak a fájlnak vagy azoknak a fájloknak a nevét adja meg, amelyeknek ellenőrizni kívánja a töredezettségét a chkdsk paranccsal. Több fájl megadásához használhatók a helyettesítő karakterek (* és ?).

/f

Javítja a lemezen található hibákat. A lemeznek zárolt állapotban kell lennie. Ha a chkdsk nem képes zárolni a lemezt, akkor felajánlja, hogy az ellenőrzést a számítógép következő újraindításakor végzi el.

/v

A lemez ellenőrzése az összes könyvtárban megjeleníti az egyes fájlok nevét.

/r

Megkeresi a hibás szektorokat és helyreállítja az olvasható adatokat. A lemeznek zárolt állapotban kell lennie.

/l[:méret]

Csak NTFS fájlrendszer esetén használható. A naplófájl méretét változtatja meg a beírt méretre. Ha nem ad meg új méretet, akkor az aktuális méretet jeleníti meg.

/x

Csak NTFS fájlrendszer esetén használható. Szükséges esetén előbb leválasztja a kötetet. Ezt követően a kötetre vonatkozó valamennyi nyitott leíró érvénytelenné válik. Ez a kapcsoló az /f kapcsoló funkcióit is kiváltja.

/i

Csak NTFS fájlrendszer esetén használható. Kevésbe mélyreható módon ellenőrzi a tárgymutató bejegyzéseit, így csökkenthető a chkdsk futásához szükséges idő.

/c

Csak NTFS fájlrendszer esetén használható. Kihagyja a mappaszerkezeten belüli ciklusok ellenőrzését, így lerövidíti a chkdsk futásához szükséges időt.


Példák a Chkdsk parancs használatára

Chkdsk

Példák

A következő parancs beírásával ellenőrizhető a D meghajtóban található lemez, és a Windows 2000 rendszerrel kijavíttathatók az esetleges hibák:

chkdsk d: /f

Hiba esetén felfüggeszti a Chkdsk parancs végrehajtását, és üzenetet jelenít meg. A Chkdsk parancs végrehajtása a lemez állapotáról szóló jelentés megjelenítésével ér véget. A megadott meghajtón nem nyithatók meg fájlok.

FAT fájlrendszerű lemezen a nem összefüggő tömbök a következő paranccsal ellenőrizhetők:

chkdsk *.*

A Chkdsk parancs állapotjelentést jelenít meg, majd felsorolja a megadott feltételeknek megfelelő, nem összefüggő tömböket tartalmazó fájlokat.


Megjegyzések a Chkdsk parancshoz

Chkdsk

Megjegyzések

A Chkdsk parancs az NTFS és FAT fájlrendszerű meghajtók lemezterületét és használatát vizsgálja meg. Az egyes fájlrendszerekre jellemző adatok az állapotjelentésben jelennek meg. Az állapotjelentés tartalmazza a fájlrendszerben felfedezett hibákat.

Ha hibák találhatóak a lemezen, akkor a chkdsk figyelmeztető üzenetet jelenít meg, és kijavítja a hibákat, amennyiben a /f kapcsolót is megadta a parancsban. A hibák kijavításához a Chkdsk parancsnak zárolnia kell a meghajtót. Ha a meghajtó hibákat tartalmaz, de nem zárolható, akkor hibaüzenet jelenik meg. Ha a chkdsk parancsot az /f kapcsoló nélkül futtatja az aktív partíción, akkor a parancs valótlan hibákat jelezhet, mivel nem képes a kötet zárolására.

Az esetleges hibák megkeresése érdekében ajánlatos a chkdsk parancsot valamennyi lemezen rendszeresen lefuttatni.

Zárolt meghajtó ellenőrzése újraindításkor

Nem lehetnek nyitott fájlok azon a meghajtón, amelyen a chkdsk hibát javít. Ha nyitott fájlok találhatóak a meghajtón, akkor a chkdsk felajánlja, hogy a meghajtót a számítógép legközelebbi újraindításakor ellenőrzi. Ha úgy dönt, hogy a meghajtót a számítógép következő újraindításakor ellenőrzi, akkor a rendszer a meghajtót az újraindításkor automatikusan ellenőrzi, a hibákat automatikusan javítja. Ha a meghajtó adott partíciója rendszerindító partíció, akkor a meghajtó ellenőrzése után a számítógép újraindul.

FAT fájlrendszerű lemez ellenőrzése

A FAT lemezekről a Windows 2000 a következő formátumban jeleníti meg a chkdsk paranccsal készített állapotjelentést:

A kötet sorozatszáma: B1AF-AFBF

72214528 bájt teljes lemezterület

73728 bájt 3 rejtett fájlban

30720 bájt 12 mappában

11493376 bájt 386 fájlban

61440 bájt hibás szektorokban

69393905 bájt használható lemezterület

2048 bájt foglalási egységenként

35261 foglalási egység van összesen a lemezen

29568 foglalási egység van a lemezen

NTFS fájlrendszerű lemez ellenőrzése

Az NTFS lemezekről a Windows 2000 a következő formátumban jeleníti meg a chkdsk paranccsal készített állapotjelentést:

A fájlrendszer típusa: NTFS.

A CHKDSK a fájlokat ellenőrzi...

A fájlvizsgálat befejeződött.

A CHKDSK az indexeket ellenőrzi...

Az indexvizsgálat befejeződött.

A CHKDSK a biztonsági leírókat ellenőrzi...

A biztonsági leírók vizsgálata véget ért.

12372 KB teljes lemezterület

3 KB 1 fájlban.

2 KB 1 indexben.

4217 KB a rendszer által használva.

8150 KB szabad lemezterület.

512 bájt foglalási egységenként.

24745 foglalási egység van összesen a lemezen.

16301 foglalási egység van a lemezen.

Lemezhibák javítása

A chkdsk parancs csak az /f kapcsoló megadása esetén javítja ki a lemezhibákat. Mivel a javítás általában módosítja a lemez fájlfoglalási tábláját (FAT) és néha adatvesztést okozhat, ezért a chkdsk az alábbihoz hasonló, jóváhagyást kérő üzenetet jelenít meg a javítás végrehajtása előtt:

10 elveszett foglalási egység van 3 láncban.

Fájllá konvertálja az elveszett szektorláncokat?

Az I billentyű lenyomásakor a Windows 2000 az egyes elveszett láncokat Filennnn.chk formátumú néven fájlként a gyökérkönyvtárba menti. A chkdsk parancs végrehajtásának befejezése után ellenőrizhetők ezek a fájlok, hogy nem tartalmaznak-e szükséges adatokat. Az N billentyű lenyomása esetén a Windows 2000 javítja a lemezt, de nem menti az elveszett foglalási egységeket.

Ha nem használja az /f kapcsolót, akkor a chkdsk üzenettel jelzi a javításra szoruló hibás fájlokat, de nem javítja ki a hibákat.

Ha a chkdsk /f parancsot nagyon nagy méretű (például 70 GB), vagy sok (több millió) fájlt tartalmazó lemezen futtatja, akkor a chkdsk parancs végrehajtása hosszú időt (akár több napot) vehet igénybe. Eközben a számítógép nem használható, mivel a chkdsk az ellenőrzés futása közben nem adja át a vezérlést.

A chkdsk használata nyitott fájlok esetén

Az /f kapcsoló megadásával a chkdsk hibát jelez, ha a lemezen nyitott fájlok találhatók. Ha az /f kapcsoló nincs megadva, és nyitott fájlok vannak a meghajtón, akkor a chkdsk elveszett foglalási egységeket találhat a lemezen. Ez akkor történhet meg, ha a nyitott fájlokat még nem jegyezte be a rendszer a fájlfoglalási táblába. Ha a chkdsk sok elveszett foglalási egységet talál, akkor érdemes megfontolni a lemez javítását.

Fizikai lemezhibák

Az /r kapcsoló segítségével megkereshetők a fájlrendszer fizikai lemezhibái. A fizikailag hibás fájlok helyreállításával kapcsolatos tudnivalókért tanulmányozza a recover parancsot.

Hibás lemezszektorok

A chkdsk által megtalált hibás szektorok már a lemez első működése előtt is hibás szektoroként voltak megjelölve. Nem jelentenek veszélyt.

Kilépési kódok

0 | Nem található hiba.
1 | Az ellenőrzés hibákat talált, és ezeket javította.
2 | A rendszer végrehajtotta a lemez karbantartását (például a szemét összegyűjtése), vagy a karbantartás nem történt meg, mert az /f kapcsolót nem adta meg.
3 | A lemez nem ellenőrizhető, a hibák nem javíthatók ki vagy a hibák kijavítása nem zajlott le, mivel a /f kapcsolót nem adta meg.


Chkntfs

Megjeleníti vagy beállítja, hogy a számítógép indításakor be van-e ütemezve az automatikus rendszerellenőrzés a FAT, FAT32 vagy NTFS köteten.

A chkntfs parancsot csak a helyi Rendszergazdák csoport tagjai használhatják.

chkntfs [/t[:idő]] [/x] [/c] kötet: [...]

chkntfs /d

Paraméterek

kötet:

Megjeleníti, milyen fájlrendszert használ a megadott kötet, valamint ha az automatikus fájlellenőrzés be van ütemezve, akkor a megjelenő üzenetben figyelmeztet a kötet esetleges serüléseire, amelyek javításához a chkdsk parancs futtatása szükséges.

/d

Az automatikus fájlellenőrzéshez tartozó visszaszámlálás időtartamának kivételével visszaállítja az chkntfs parancs valamennyi alapértelmezett beállítását. Az alapértelmezett beállítás szerint a számítógép indításakor az összes kötet ellenőrzése megtörténik.

/t

Megjeleníti vagy módosítja az automatikus fájlellenőrzéshez tartozó visszaszámlálás időtartamát. Például:

chkntfs /t Megjeleníti az automatikus fájlellenőrzéshez tartozó visszaszámlálás időtartamát.

chkntfs /t:30 A visszaszámlálás időtartamát 30 másodpercre állítja be.

Bár a visszaszámlálás időtartama nullára is beállítható, ebben az esetben a felhasználó nem képes az esetleg időigényes automatikus fájlellenőrzés kihagyására.

/x

Kihagyja a megadott kötetet a számítógép indításakor ellenőrzött kötetek közül, még abban az esetben is, ha a köteten be van állítva a chkdsk futtatása.

A parancs többszöri futtatása esetén a beállítások nem adódnak össze. Több parancs kiadása esetén az újabb parancs felülírja az előzőt. Több kötet kihagyásához sorolja fel a parancsokat egy parancson belül. Például:

chkntfs /x e: f: parancs kihagyja az e és az f kötetet.

A chkntfs /x e: parancs után a chkntfs /x f: parancs megadása esetén csak az f kötetet hagyja ki a rendszer.

/c

Beütemezi a megadott kötet ellenőrzését a számítógép indításakor.

A parancs többszöri futtatása esetén a beállítások összeadódnak. Egy adott kötet ellenőrzéséhez először az előző parancs törléséhez állítsa vissza az alapértelmezett beállításokat, hagyja ki az összes kötetet az ellenőrzés alól, majd ütemezze be az automatikus fájlellenőrzést a kívánt kötetre.

Például ha csak a d köteten kívánja beütemezni az automatikus fájlellenőrzést, akkor írja be a következő parancsokat:

chkntfs /d (Ez visszaállítja az alapértelmezett beállításokat.)

chkntfs /x c: d: e: (Ez kihagyja a c, d és e kötetet az ellenőrzésből.)

chkntfs /c d: (Automatikus fájlellenőrzést ütemez be a d köteten.)


Cipher

Megjeleníti, vagy módosítja az NTFS köteteken található mappák és fájlok titkosítását.

cipher [/e| /d] [/s:könyvtár] [/a][/i] [/f] [/q] [/h] [elérési_útvonal [...]]

Paraméterek

nincs

Paraméterek nélkül az aktuális mappa, valamint a benne található fájlok titkosítási állapotát jeleníti meg.

/e

Titkosítja a megadott mappákat. A parancs megjelöli a mappákat, így a mappához a későbbiekben hozzáadott fájlokat is titkosítja a rendszer.

/d

Visszafejti a megadott mappákat. A parancs megjelöli a mappákat, így a mappához a későbbiekben hozzáadott fájlokat sem titkosítja a rendszer.

/s: könyvtár

Végrehajtja a kiválasztott műveletet a megadott mappában található mappákon, valamint az összes almappán.

/a

Végrehajtja a kiválasztott műveletet a megadott névű fájlokon. Ha nincs a feltételekkel egyező fájl, akkor a parancs figyelmen kívül hagyja ezt a paramétert.

/i

Megadásakor a megadott művelet végrehajtását még hibák esetén is folytatja a rendszer. Alapértelmezés szerint a cipher parancs hiba esetén leáll.

/f

Megköveteli az összes megadott objektum titkosítását vagy visszafejtését. Alapértelmezés szerint a parancs kihagyja a már titkosított vagy visszafejtett fájlokat.

/q

Megadása esetén a jelentés csak a leglényegesebb adatokat tartalmazza.

/h

Megjeleníti a rejtett vagy rendszer attribútummal rendelkező fájlokat. Alapértelmezés szerint ezek a fájlok kimaradnak a titkosításból vagy visszafejtésből.

elérési_útvonal

Fájlmintát, fájlt vagy mappát ad meg.


Példák a Cipher parancs használatára

Cipher

Példák

A Havi_jelentések mappában a Május almappa a cipher parancs segítségével helyezhető el titkosítva:

cipher /e havi_jelentések\május

A Havi_jelentések mappa, a benne található összes mappa (Január – December és a Gyártás mappa) a következő paranccsal titkosítható:

cipher /e /s:havi_jelentések

Kizárólag a Május almappában található Marketing.xls fájlt az alábbi paranccsal titkosítható:

cipher /e /a havi_jelentések\május\marketing.xls

A Május mappában található Marketing.xls és Malom.doc fájl, valamint a Magok almappa a következő paranccsal titkosítható:

cipher /e /a havi_jelentések\május\ma*

A következő paranccsal ellenőrizhető, hogy a Május mappa titkosítva van-e:

cipher havi_jelentések\május

A következő paranccsal ellenőrizhető, hogy a Május mappa mely fájljai vannak titkosítva:

cipher havi_jelentések\május\*


Megjegyzések a Cipher parancshoz

Cipher

Megjegyzések

Fájlok titkosítása vagy visszafejtése

Ha gondoskodni kíván arról, hogy a titkosított fájl módosításakor ne kerüljön visszafejtésre, akkor célszerű a fájlt, és a fájlt tartalmazó mappát egyaránt titkosítani.

Több mappanév

Több mappanév, és helyettesítő karakterek is használhatók.

Több paraméter

Több paraméter megadásakor legalább egy szóközzel el kell választani a paramétereket.


Cls

Törli a képernyőt.

A törölt képernyőn csak a parancssor és a beviteli pont látható.

cls


Cmd

A Windows 2000 parancsértelmező (Cmd.exe) új példányát indítja el.

A parancsértelmező jeleníti meg a parancssort, amelybe beírhatók parancsok. Az exit parancs használatával leállítható az új parancsértelmező, a vezérlés pedig visszaadható a régi parancsértelmező számára.

cmd [ [/c | /k] [/q] [/a | /u] [/t:fg] [/x | /y] karakterlánc]

Paraméterek

/c

Végrehajtja a karakterlánc által megadott parancsot, majd leáll.

/k

Végrehajtja a karakterlánc által megadott parancsot, majd folytatódik.

/q

Kikapcsolja a visszhangot.

/a

ANSI kimenetet hoz létre.

/u

Unicode kimenetet hoz létre.

/t:fg

Beállítja az előtér és a háttér színét. (További tudnivalókért kattintson a Kapcsolódó témakörökben a szín témakörre.)

/x

Engedélyezi a Cmd.exe program Windows 2000 verziójához tartozó kiterjesztések használatát, így gazdagabb rendszerhéj-programozási környezetet biztosít. A következő parancsok használják a kiterjesztéseket: del (erase), color, cd (chdir), md (mdir), prompt, pushd, popd, set, setlocal, endlocal, if, for, call, shift, goto, start, assoc és ftype. Az egyes parancsokkal kapcsolatos tudnivalókért tanulmányozza a Súgót.

/y

Letiltja a Cmd.exe program Windows 2000 verziójának kiterjesztéseit a korábbi verziókkal való kompatibilitás miatt. Alapértelmezés szerint használhatók a kiterjesztések.

karakterlánc

Megadja a végrehajtani kívánt parancsot.


Témakörök a Tartalom megtekintéséhez.

 A Tartalom megtekintéséhez kattintson a Témakörök elemre.


Codepage

Kiválasztja azokat a kódlapokat, amelyeket a rendszer az MS OS/2 alrendszerhez használ. Ha használni kívánja a parancsot, helyezze el az OS/2 C:\Config.sys fájlban.

codepage=xxx[,yyy]

Paraméterek

xxx

Megadja az első kódlapot. Egy háromjegyű számnak kell lennie a következő listáról:

437 Egyesült Államok
850 többnyelvű (Latin I)
852 szláv (Latin II)
855 cirill (orosz)
857 török
860 portugál
861 izlandi
863 kanadai francia
865 skandináv
866 orosz
869 modern görög

yyy

Ezt a paramétert nem használja az OS/2 alrendszer. Csak az MS OS/2 1.3-as, vagy annál régebbi verziókból származó fájlokkal való kompatibilitás miatt fogadja el a parancs.


Példa a Codepage parancs használatára

Codepage

Példa

Ha az MS OS/2 alrendszert a 437-es és a 850-es kódlapok használatára kívánja beállítani, akkor a következő sort kell felvennie a C:\Config.sys fájlba:

codepage=437,850


Megjegyzések a Codepage parancshoz

Codepage

Megjegyzések

A Codepage, keyboard és country parancsok kölcsönösen kapcsolódnak egymáshoz. A kódlap a képernyőn megjeleníthető, a nyomtatáshoz használható vagy más kimeneti eszközre küldhető karakterek készletét tartalmazza. A billentyűzetkiosztás adja meg a rendszer száméra, hogy a karakterkészlet egyes karakterei mely billentyűleütéseknek felelnek meg; ez az Országtól/Körzet beállításától függően változik. Az Ország/Körzet, ahol dolgozik (vagy amelynek megfelelően be kívánja állítani a rendszert), meghatározza a két szükséges kódlapot. (A Kapcsolódó témakörökben az ország témakörre kattintással megtekinthetők az Ország/Körzet kódok és a hozzájuk tartozó kódlapok listája.) A billentyűzetkiosztás kódlapváltás nélkül is módosítható. A következő kódlapok használhatók:
437 Egyesült Államok
850 többnyelvű (Latin I)
852 szláv (Latin II)
855 cirill (orosz)
857 török
860 portugál
861 izlandi
863 kanadai francia
865 skandináv
866 orosz
869 modern görög

A billentyűzet vagy a képernyő által használt kódlap beállítása esetén a devinfo paranccsal a külső eszközök által használható kódlapot is meg kell adnia. További tudnivalókért a Kapcsolódó témakörök között kattintson a devinfo témakörre.


Color

Beállítja a konzol alapértelmezett előtér- és háttérszínét.

color bf

Paraméterek

bf

A konzolkimenet színtulajdonságait határozza meg. A b olyan hexadecimális számjegy, amely a háttérszínt adja meg; az f érték pedig az előtér színét határozza meg. A hexadecimális számjegyek a következő értékeket vehetik fel:

0 Fekete

1 Kék

2 Zöld

3 Vízszín

4 Piros

5 Sötétlila

6 Sárga

7 Fehér

8 Szürke

9 Világoskék

A Világoszöld

B Világos vízszín

C Világos piros

D Világoslila

E Világossárga

F Fényes fehér

A color fc parancs használatával például világos piros szín állítható be fényes fehér háttér előtt.

Paraméter nélkül visszaállítja a Cmd.exe indulásakor érvényes színbeállításokat. Ez az érték az aktuális konzolablakból, a /t parancssori kapcsolóból vagy a DefaultColor rendszerleíró értékből származik.

Ha a megadott előtér- és háttérszín megegyezik, akkor a color parancs ERRORLEVEL 1 hibaüzenettel tér vissza.


Parancsszimbólumok és szűrőparancsok

További tudnivalókért válassza ki a kívánt témakört.

Átirányítás ( > < >> )

Szűrőparancsok ( | more, sort, find )

Feltételes feldolgozószimbólumok (& && || () ^ )


Comp

Két fájl vagy fájlkészlet tartalmát hasonlítja össze bájtonként.

A Comp parancs ugyanazon vagy különböző meghajtókon elhelyezkedő, valamint ugyanabban a könyvtárban vagy különböző könyvtárakban található fájlokat is képes összehasonlítani. A fájlok összehasonlítás közben a comp parancs megjeleníti a fájlok elérési helyét és nevét.

comp [adat1] [adat2] [/d] [/a] [/l] [/n=szám] [/c]

Paraméterek

adat1

Az összehasonlításban résztvevő első fájl vagy fájlkészlet helyét és nevét adja meg. Több fájl megadásához használhatók a helyettesítő karakterek (* és ?).

adat2

Az összehasonlításban résztvevő második fájl vagy fájlkészlet helyét és nevét adja meg. Több fájl megadásához használhatók a helyettesítő karakterek (* és ?).

/d

A különbséget decimális formátumban jeleníti meg. (Az alapértelmezett formátum a hexadecimális.)

/a

A különbségeket karakterként jeleníti meg.

/l

A bájttávolság helyett a különbséget tartalmazó sorok a számát jeleníti meg.

/n=szám

A fájlok kezdetétől számítva a megadott számú sort hasonlítja össze még akkor is, ha a fájlok mérete különböző.

/c

A kis- és nagybetűk megkülönböztetése nélkül hajtja végre az összehasonlítást.


Példák a Comp parancs használatára

Comp

Példák

A következő parancs beírásával összehasonlítható a C:\Jelentések könyvtár tartalma a \\Kereskedelem\Mentés\Április biztonsági másolatokat tároló könyvtár tartalmával:

comp c:\jelentések \\kereskedelem\mentés\április

A \Számlák könyvtárban található szövegfájlok első tíz sora a következő paranccsal hasonlítható össze:

comp \számlák\*.txt \számlák\mentés\*.txt /n=10 /d


Megjegyzések a Comp parancshoz

Comp

Megjegyzések

Azonos nevű fájlok összehasonlítása

Az összehasonlítani kívánt fájlok neve csak abban az esetben egyezhet meg, ha más könyvtárban vagy meghajtón helyezkednek el. Ha nem ad meg fájlnevet az adat2 adathalmazban, akkor az adat2 alapértelmezett fájlneve az adat1 halmazban megadott név lesz. A fájlnevek megadásához helyettesítő karakterek (* és ?) is használhatók.

Az adat1 és adat2 halmazok különleges esetei.

Ha az adat1 vagy adat2 halmaz szükséges összetevője kimarad, vagy ha kimarad az adat2, akkor a comp parancs kéri a hiányzó adatok megadását. Ha az adat1 halmazként fájlnév nélkül csak a meghajtó betűjelét vagy könyvtárnevet ad meg, akkor a comp parancs a megadott könyvtár valamennyi fájlját összehasonlítja az adat2 halmazként megadott fájllal. Ha az adat2 halmazként csak a meghajtó betűjelét vagy a könyvtár nevét adja meg, akkor az adat2 halmazhoz használt alapértelmezett fájlnév az adat1 halmazban megadott fájlnév lesz.

Hogyan különbözteti meg a comp parancs az eltérő adatokat

Az összehasonlítás során a comp parancs üzeneteket jelenít meg, amelyek a két fájlban található eltérő adatok helyét jelölik meg. Ezek az üzenetek az eltérő bájtok eltolási memóriacímét, illetve a bájtok tartalmát mutatják meg (hexadecimális jelölésekkel, ha nem adta meg az /a vagy a /d kapcsolók valamelyikét). Az üzenetek az alábbi formátumban jelennek meg:

Összehasonlítási hiba; helye: xxxxxxxx

1. fájl = xx

2. fájl = xx

Tíz eltérés után a comp parancs befejezi a fájlok összehasonlítását, és az alábbi üzenetet jeleníti meg:

10 eltérés – az összehasonlítás befejeződik

Különböző méretű fájlok összehasonlítása

Az /n kapcsoló megadása nélkül nem hasonlíthatók össze különböző méretű fájlok. Ha a fájlméret különbözik, a comp parancs az alábbi üzenetet jeleníti meg:

A fájlok különböző méretűek

Kíván további fájlokat összehasonlítani (I/N)?

Újabb fájlpár összehasonlításához nyomja meg az I billentyűt. A comp parancs leállításához nyomja meg az N billentyűt.

Az I billentyű megnyomása esetén a comp parancs a parancssorban előzőleg megadott összes kapcsolót figyelembe veszi a következő összehasonlítások végrehajtása során mindaddig, amíg nem az N billentyűt választja, vagy amíg be nem írja újra a parancsot.

Különböző méretű fájlok összehasonlításakor használja a /n kapcsolót, mert ekkor csak a fájlok első részét hasonlítja össze a parancs.

Több fájl összehasonlítása

Ha több fájl kijelöléséhez helyettesítő karaktereket (* és ?) használ, akkor a comp parancs megkeresi az adat1 halmazban megadott feltételt kielégítő első fájlt, és összehasonlítja az adat2 halmazban található megfelelő fájllal, ha létezik ilyen. A comp parancs jelentést készít az összehasonlítás eredményéről, majd ugyanezt teszi az adat1 halmaz feltételének megfelelő valamennyi fájl esetében. A művelet végén a comp parancs a következő üzenetet jeleníti meg:

Kíván további fájlokat összehasonlítani (I/N)?

További fájlok összehasonlításához nyomja meg az I billentyűt. A comp parancs kéri az új fájlok helyét és nevét. Az összehasonlítás leállításához nyomja meg az N billentyűt. Az I billentyű megnyomása után a comp parancs kéri a használni kívánt kapcsolók megadását. Ha nem ad meg kapcsolókat, akkor a comp parancs az előzőleg megadott kapcsolókat használja.

Ha a comp parancs nem találja a fájlokat

Ha a comp parancs nem találja a megadott fájl(oka)t, akkor rákérdez, hogy kíván-e további fájlokat összehasonlítani.


Compact

Az NTFS partíciókon található fájlok vagy könyvtárak tömörítési állapotának megjelenítésére, illetve módosítására szolgál.

compact [/c|/u] [/s[:könyvtár]] [/a] [/q] [/i] [/f] [fájlnév[...]]

Paraméterek

nincs

Paraméterek nélkül a compact parancs az aktuális könyvtár tömörítési állapotát jeleníti meg.

/c

Tömöríti a megadott könyvtárat vagy fájlt.

/u

Kibontja a megadott könyvtárat vagy fájlt.

/s:könyvtár

Megadása esetén a kért művelet (tömörítés vagy kibontás) a kiválasztott könyvtár valamennyi alkönyvtárára vonatkozik. Ha nem ad meg könyvtárat a paraméter számára, akkor a műveletet az aktuális könyvtár alkönyvtárain hajtja végre a parancs.

/a

Megjeleníti a rejtett vagy rendszerfájlokat.

/q

Megadása esetén a jelentés csak a leglényegesebb adatokat tartalmazza.

/i

Figyelmen kívül hagyja a hibákat.

/f

Megköveteli az adott könyvtár vagy fájl tömörítését, illetve kibontását. Ezt a paramétert akkor kell használni, amikor a fájl tömörítése rendszerösszeomlás miatt félbeszakadt. Ha teljesen be kívánja fejezni a fájl tömörítését, akkor használja a /c és az /f paramétereket, és adja meg a részlegesen tömörített fájlt.

fájlnév

A fájlt vagy könyvtárat adja meg. Több fájlnév és helyettesítő karakterek (* és ?) is használhatók.


Példák a Compact parancs használatára

Compact

Példák

Az aktuális könyvtárban és annak alkönyvtáraiban található fájlok tömörítéséhez, valamint az aktuális könyvtár és annak alkönyvtárain a tömörített attribútum beállításához írja be a következő parancsot:

compact /c /s

Ha a \Tmp könyvtárban, valamint a \Tmp könyvtár valamennyi alkönyvtárában található összes .bmp kiterjesztéssel rendelkező fájlt tömöríteni kívánja, de nem szeretné a könyvtárak tömörített attribútumát megváltoztatni, akkor írja be a következő parancsot:

compact /c /s:\tmp *.bmp

A következő paranccsal befejezhető a Zebra.bmp fájl tömörítése, amelyet egy rendszerösszeomlás miatt csak részben tömörített össze a rendeszer:

compact /c /f zebra.bmp

A következő parancs beírásával távolítható el a tömörített attribútum a C:\Tmp könyvtárról anélkül, hogy a könyvtárban található bármely fájl tömörítési állapotát megváltoztatná:

compact /u c:\tmp


Megjegyzések a Compact parancshoz

Compact

Megjegyzések

A compact parancs, amely a Windows 2000 tömörítési funkciójának parancssorról elérhető változata, az NTFS partíciókon található fájlok és könyvtárak tömörítési attribútumait jeleníti meg, illetve módosítja. A könyvtárak tömörítési állapota azt jelzi, hogy a könyvtárba kerülő fájlokat automatikusan tömöríti-e a rendszer. A könyvtár tömörítési állapotának módosítása nem feltétlenül vonja maga után a könyvtárban található fájlok tömörítési állapotának megváltozását.

A compact parancs nem használható a DriveSpace vagy DoubleSpace eszközök segítségével tömörített kötetek olvasására, írására vagy csatlakoztatására.


Compile Date

 Fordítás: HU kiadás, 2000.2.24.


Feltételes feldolgozási szimbólumok

A feltételes feldolgozási szimbólumokkal szabályozható a parancsok végrehajtása.

A parancsok feltételes feldolgozása

A feltételes feldolgozási szimbólumok segítségével több parancs adható ki ugyanabból a parancssorból, és a további műveletek egy parancs eredményeitől tehetők függővé.

  • Az és (&) karakter a parancssorban több parancs elkülönítésére szolgál.
  • Zárójelek segítségével több parancs csoportosítható.
  • A pontosvessző vagy vessző (; ,) segítségével a parancs paraméterei elválaszthatók.
  • A beszúrási jel (^) törli az utána következő parancsszimbólum különleges jelentését, így a parancsszimbólum szövegként használható.
  • A dupla és (&&) karakterek után következő parancsot csak abban az esetben hajtja végre a rendszer, ha a karaktereket megelőző parancs futása sikeresen befejeződött.
  • A dupla függőleges vonás (||) karakter után következő parancsot csak abban az esetben hajtja végre a rendszer, ha a karaktert megelőző parancs sikertelen volt.


Convert

A FAT és FAT32 kötetet NTFS kötetté konvertálja. Az aktuális meghajtó nem konvertálható. Ha a convert parancs nem képes a meghajtó zárolására, akkor felajánlja, hogy a konvertálást a számítógép következő újraindításakor végzi el.

convert [meghajtó:] /fs:ntfs [/v]

Paraméterek

meghajtó:

Megadja azt a meghajtót, amelyet NTFS rendszerűvé kíván konvertálni.

/fs:ntfs

Megadja, hogy a kötetet NTFS rendszerűvé kívánja konvertálni.

/v

Megadja a részletes üzemmódot. Használata esetén a konvertálás során minden üzenet megjelenik.


Példák a Convert parancs használatára

Convert

Példák

Az E meghajtón található kötet a következő parancs beírásával konvertálható az összes üzenet megjelenítése mellett:

convert e: /fs:ntfs /v

Az alábbi paranccsal az E meghajtón található kötet konvertálható, és létrehozható egy Konfigfájl.log nevű névtábla a konvertált kötet gyökérkönyvtárában:

convert e: /fs:ntfs /nametable:konfigfájl.log


Megjegyzések a Convert parancshoz

Convert

Megjegyzések

Ha rendszerindítás közben sikertelen az automatikus konvertálás, akkor a részletek az Eseménynapló beépülő modul alkalmazásnaplójának Winlogon bejegyzésénél tekinthetők meg. Az alkalmazásnapló felsorolja a konvertálás sikertelenségének okait. Ha a konvertálás a szokatlan nevű fájlok konvertálása miatt szakad meg, akkor adja ki újra a convert parancsot a /nametable kapcsoló használatával, és próbálja meg újra az automatikus konvertálás végrehajtását. A rendszer az automatikus konvertálás során felhasználja a convert parancs által létrehozott névtábla adatait.


Copy

Egy vagy több fájlt más helyre másol.

A parancs fájlok kombinálására is használható. Több fájl másolása esetén a Windows 2000 minden egyes fájl nevét megjeleníti a művelet során.

copy [/a | /b] forrás [/a | /b] [[/a | /b] + forrás [/a | /b] [+ ...]] [[/v] [/n] [/y | /-y] [/z] [/a | /b] [cél [/a | /b]]

Paraméterek

forrás

A másolni kívánt fájl vagy fájlkészlet helyét adja meg. A Forrás paraméter a meghajtó-betűjelből, kettőspontból, mappanévből és fájlnévből, vagy ezek kombinációjából állhat.

cél

Annak a fájlnak vagy fájlkészletnek a helyét határozza meg, amelybe másolni kíván. A cél paraméter a meghajtó-betűjelből, kettőspontból, mappanévből és fájlnévből, vagy ezek kombinációjából állhat.

/a

ASCII szövegfájlt jelez. Ha az /a kapcsoló a parancssorban megelőzi a fájlnevek listáját, akkor a kapcsoló az /a kapcsolót követő valamennyi fájlra vonatkozik egészen addig, amíg a copy parancs el nem ér a /b kapcsolóig. Ilyenkor a /b kapcsoló arra fájlra vonatkozik, amelyik a /b kapcsolót megelőzi.

Ha az /a kapcsoló egy fájlnév után áll, akkor arra a fájlra vonatkozik, melynek neve megelőzi az /a kapcsolót, és az összes olyan fájlra, amelynek neve az /a kapcsoló után áll egészen addig, amíg a copy parancs el nem ér a /b kapcsolóig. Ilyenkor a /b kapcsoló arra fájlra vonatkozik, amelyik a /b kapcsolót megelőzi. Az ASCII szövegfájl a fájl végét fájl vége karakterrel (CTRL+Z) jelezheti. Fájlok egyesítésekor a copy parancs alapértelmezés szerint ASCII szövegfájlként kezeli a fájlokat.

/b

Bináris fájlt jelez. Ha a /b kapcsoló a parancssorban megelőzi a fájlnevek listáját, akkor a /b kapcsolót követő valamennyi fájlra vonatkozik egészen addig, amíg a copy parancs el nem ér az /a kapcsolóig. Ilyenkor az /a kapcsoló arra fájlra vonatkozik, amelyik az /a kapcsolót megelőzi.

Ha a /b kapcsoló egy fájlnév után áll, akkor arra a fájlra vonatkozik, melynek neve megelőzi a /b kapcsolót, és az összes olyan fájlra, amelynek neve az /b kapcsoló után áll egészen addig, amíg a copy parancs el nem ér az /a kapcsolóig. Ilyenkor az /a kapcsoló arra fájlra vonatkozik, amelyik az /a kapcsolót megelőzi.

A /b kapcsoló megadásakor a parancsértelmező a könyvtárban a fájlméretben szereplő mennyiségű bájtot olvassa be. A copy parancshoz tartozó alapértelmezett érték a /b kapcsoló, kivéve, amikor a copy parancs fájlok egyesítésére használja.

/v

Ellenőrzi, hogy az új fájlokat hibamentesen írta-e a rendszer.

/n

Ez a kapcsoló a fájl rövid nevét használja (ha van), ha a másolni kívánt fájl neve hosszabb nyolc karakternél, vagy három karakternél hosszabb a kiterjesztés.

/y

Megadásakor a parancs nem kéri a létező célfájlok felülírásának megerősítését.

Az /y kapcsoló a COPYCMD környezeti változóban is szerepelhet. Ez a beállítást a /-y kapcsoló parancssorba történő beírásával felülírható. Az alapértelmezés szerint a parancs kéri a megerősítést, ha a copy parancsot nem kötegfájlból hajtja végre a rendszer.

Fájlok hozzáfűzéséhez egy fájlt kell megadni célként, de több fájlt kell megadni forrásként (helyettesítő karakterek használatával vagy a fájl1+fájl2+fájl3 formátum alkalmazásával).

/-y

Használata esetén a parancs kéri a célként megadott, de már létező fájl felülírásának megerősítését.

/z

A hálózaton keresztül másolt fájlokat újraindítható módon másolja. Ha a hálózati kapcsolat megszakad a másolási folyamat közben (például a kiszolgáló megszünteti a kapcsolatot), akkor a kapcsolat ismételt létrehozása után a parancs folytatja a másolást. Ennek a parancskapcsolónak a használatakor az egyes fájlok másolásának állapota százalékban jelenik meg.

Az xcopy paranccsal kapcsolatos további tudnivalókért a Kapcsolódó témakörökben kattintson az xcopy témakörre.


Példák a Copy parancs használatára

Copy

Példák

A következő parancs átmásol egy fájlt, és gondoskodik a fájl végén a fájl vége karakter elhelyezéséről:

copy feljegyzés.doc levél.doc /a

Az aktuális meghajtóról és könyvtárból a Robi.typ nevű fájl a következő paranccsal kíván a C meghajtón található, már létrehozott Birds nevű könyvtárba másolni, akkor a következő parancsot írja be:

copy robin.typ c:\birds

Ha a Birds könyvtár nem létezik, akkor a Windows 2000 a Robin.typ fájlt egy Birds nevű fájlba másolja, amely a C meghajtó gyökérkönyvtárában jön létre.

Ha több fájlt kíván egy fájlba másolni, akkor a copy parancssorban soroljon fel tetszőleges számú forrás paramétert. A fájlneveket plusz karakterrel (+) kell elválasztani, majd a következő példa szerint nevet kell megadni a létrejövő kombinált fájlnak:

copy mar89.rpt + apr89.rpt + may89.rpt report

Ez a parancs az aktuális meghajtón és könyvtárban található Mar89.rpt, Apr89.rpt és May89.rpt nevű fájlokat kombinálja, és az aktuális meghajtó aktuális könyvtárában létrejövő Report nevű fájlban helyezi el őket. Fájlok kombinálásakor a célfájl a pillanatnyi dátummal és időponttal jön létre. Ha nem ad meg célt, akkor a Windows 2000 a fájlok kombinálása után az elsőként megadott fájl neve alatt tárolja őket. Ha például létezik már egy Report nevű fájl, akkor a következő paranccsal kombinálható mind a négy fájl a Report fájlba:

copy report + mar89.rpt + apr89.rpt + may89.rpt

A következő példa szerint helyettesítő karakterek (* és ?) használatával is lehet több fájlt egy fájlba kombinálni:

copy *.txt combin.doc

Ez a parancs az aktuális meghajtó aktuális könyvtárában található összes .txt kiterjesztéssel rendelkező fájlt a Combin.doc nevű fájlba kombinálja, amely szintén az aktuális meghajtó aktuális könyvtárában helyezkedik el.

Ha helyettesítő karakterek használatával kíván több bináris fájlt egy fájllá kombinálni, akkor a következő példa szerint használja a /b kapcsolót:

copy /b *.exe combin.exe

Ezzel a Windows 2000 a CTRL+Z karaktert nem fogja fájlvég-karakterként értelmezni.

Vigyázat

  • Bináris fájlok kombinálásakor előfordulhat, hogy az eredményként kapott bináris fájl a belő formázás miatt esetleg nem lesz használható.

Az alábbi példában a copy parancs az egyes .txt kiterjesztéssel rendelkező fájlokat a nekik megfelelő .ref kiterjesztésű fájlokkal kombinálja. Az eredmény egy azonos nevű, de .doc kiterjesztéssel rendelkező fájl. Ezen a módon a copy parancs a Fájl1.txt fájlt a Fájl1.ref fájllal kombinálja, a Fájl1.doc fájlt eredményezve. Ezután a copy parancs a Fájl2.txt fájlt kombinálja a Fájl2.ref fájllal, létrehozva a Fájl2.doc fájlt, és így tovább.

copy *.txt + *.ref *.doc

A következő copy parancs először a .txt kiterjesztéssel rendelkező összes fájlt, majd az összes .ref kiterjesztésű fájlt egy Combin.doc nevű fájlba kombinálja:

copy *.txt + *.ref combin.doc


Megjegyzések a Copy parancshoz

Copy

Megjegyzések

Másolás eszközökre vagy eszközökről

A forrás vagy a cél paraméterként egy vagy több helyen is megadható valamilyen eszköz neve.

A /b kapcsoló megadása vagy kihagyása eszközre történő másoláskor

Ha a cél egy eszköz (például a Com1 vagy az Lpt1), akkor a /b kapcsoló megadásakor a Windows 2000 bináris üzemmódban másolja az adatokat az eszközre. Bináris üzemmódban valamennyi karaktert (beleértve a CTRL+C, CTRL+S, CTRL+Z és a kocsivissza-karakterekhez hasonló karaktereket is) adatként másolja a parancs az eszközre. A /b kapcsoló elhagyása esetén a Windows 2000 ASCII üzemmódban másolja az adatokat az eszközre. ASCII üzemmódban az előbb felsoroltakhoz hasonló különleges karakterek esetén a Windows 2000 a következő szakaszban leírtak szerint speciális műveletet hajthat végre.

Az alapértelmezett célfájl használata

Ha nem ad meg célfájlt, akkor a Windows 2000 az aktuális meghajtó aktuális könyvtárában azonos néven, azonos létrehozási dátummal és létrehozási időponttal létrehozza az eredeti fájl másolatát. Ha a forrásfájl az aktuális meghajtó aktuális könyvtárában található, és a célfájl számára nem ad meg más meghajtót vagy könyvtárat, akkor a copy parancs leáll, és a Windows 2000 a következő hibaüzenetet jeleníti meg:

Fájlt nem lehet önmagára másolni

0 fájl másolása történt meg

A /v kapcsoló használata

Hibaüzenet jelenik meg, ha a Windows 2000 nem tud egy írási műveletet ellenőrizni. Bár a copy parancs végrehajtása során ritkán fordul elő mentési hiba, a /v kapcsoló megadásával ellenőrizhető, hogy a fontos adatok mentése hibátlanul megtörtént-e. A /v kapcsoló használatakor lelassul a copy parancs végrehajtása, mivel a mentés során a Windows 2000 minden egyes írt szektort ellenőriz a lemezen.

Az /a és /b kapcsoló használata

Az /a és a /b kapcsoló funkciója a parancssorban elfoglalt helyétől függ. Ha az /a vagy a /b kapcsoló a forrásfájl neve után áll, akkor a copy parancsot az alábbi lista szerint hajtja végre a rendszer:

/a A fájlt ASCII (szöveg) fájlként kezeli a parancs, és az első fájlvégkarakter előtti adatokat másolja át. A copy parancs sem az első fájl vége karaktert, sem a fájl többi részét nem másolja.

/b Az egész fájlt másolja, a fájl vége karakterekkel együtt.

Ha az /a vagy a /b kapcsoló a célfájl neve után áll, akkor a copy parancsot az alábbi lista szerint hajtja végre a rendszer:

/a Utolsó karakterként fájl vége karaktert szúr be fájlba.

/b Nem szúr be fájl vége karaktert.

Fájlok egyesítése a copy parancs segítségével

Ha több forrást ad meg, és az egyes bejegyzéseket plusz karakterrel (+) választja el, akkor a copy parancs a fájlok egyesítésével egyetlen fájlt hoz létre. Ha a forrás megadásakor helyettesítő karaktereket (* vagy ?) használ, de célként csak egy fájlt ad meg, akkor a copy parancs egyesíti a forrás paraméterként megadott feltétellel egyező nevű összes fájlt, és egyetlen fájlt hoz létre a célként megadott néven.

A copy parancs mindegyik esetben ASCII fájlként kezeli az egyesített fájlokat, ha nem adja meg a /b kapcsolót.

Fájlok másolása alkönyvtárba

A könyvtárban levő összes fájl és alkönyvtár az xcopy paranccsal másolható.

Nulla hosszúságú fájl másolása

A copy paranccsal nem másolhatók 0 bájt hosszúságú fájlok. Ezek a fájlok az xcopy paranccsal másolhatók.

Fájl idejének és dátumának módosítása

Az aktuális időpont és dátum a következő formátumú paranccsal rendelhető a fájlhoz a fájl módosítása nélkül. A vesszők a cél paraméter kihagyását jelzik.

copy /b source+,,


Country

Lehetővé teszi az MS-DOS alrendszer számára a nemzetközi idő, dátum, pénznem, kis- és nagybetű átalakítás, valamint a tizedesjelek alkalmazását.

A country parancs segítségével az MS-DOS alrendszer beállítható, hogy a támogatott nyelvek valamelyikének használatakor felismerje a karakterkészletet és az írásjelek használatának szabályait. Az Ország/Terület beállításainak betöltéséhez a %rendszergyökér%\System32\Config.nt fájl, vagy egy ezzel egyenértékű, a program PIF fájljában megadott indítófájl használható.

country=xxx[,[yyy][,[meghajtó:][elérési_útvonal] fájlnév]]

Paraméterek

xxx

Az Ország/Terület kódját adja meg.

yyy

Az Ország/Terület kódlapját adja meg.

[meghajtó:][elérési_útvonal] fájlnév

Az Ország/Terület adatait tartalmazó fájl elérési útvonalát és nevét adja meg.


Példák a Country parancs használatára

Country

Példák

Ha a nemzetközi pénznem, idő, dátum és betű beállításokat a francia szabályok szerint kívánja megadni, akkor vegye fel a következő parancsot a Config.nt fájlba:

country=033

Franciaország országkódjával együtt egy kódlap a következő paranccsal adható meg:

country=033,850

A kódlap kihagyása, de a [meghajtó:][elérési_útvonal] fájlnév paraméter megadása esetén a következő példában látható módon továbbra is meg kell adni azt a vesszőt, amely a kódlapot előzte volna meg:

country=033,,c:\winnt\system32\country.sys


Megjegyzések a Country parancshoz

Country

Megjegyzések

A támogatott nyelvek megadása

A következő táblázat a Windows 2000 MS-DOS alrendszere által támogatott valamennyi Országot/területet és nyelvet tartalmazza. A táblázatban azok a kódlapok is megtalálhatók, amelyek az egyes Országhoz/területhez tartozó kódokkal használhatók. Például a 003-as Ország/terület kód használata esetén csak a 437-es vagy a 850-es kódlap adható meg az yyy paraméterként. Az egyes Ország/terület vagy nyelv beállításnál megadott első két kódlap az adott beállításhoz tartozó alapértelmezett kódlap.

Ország/terület vagy nyelv | Ország/terület kód | Kódlapok
Egyesült Államok | 001 | 437, 850
Kanadai francia | 002 | 863, 850
Hollandia | 031 | 850, 437
Belgium | 032 | 850, 437
Franciaország | 033 | 850, 437
Spanyolország | 034 | 850, 437
Magyarország | 036 | 852, 850
Olaszország | 039 | 850, 437
Svájc | 041 | 850, 437
Cseh Köztársaság | 042 | 852, 850
Szlovákia | 042 | 852, 850
Egyesült Királyság | 044 | 437, 850
Dánia | 045 | 850, 865
Svédország | 046 | 850, 437
Norvégia | 047 | 850, 865
Lengyelország | 048 | 852, 850
Németország | 049 | 850, 437
Brazília | 055 | 850, 437
Nemzetközi angol | 061 | 437, 850
Portugál | 351 | 850, 860
Finnország | 358 | 850, 437

Nemzetközi idő- és dátumformátumok megadása

Az Ország/terület kód a következő parancsok által használt idő- és dátumformátumokat határozza meg: backup, date és time.

A következő táblázat az egyes Ország/terület kódhoz tartozó idő- és dátumformátumokat sorolja fel. Az egyes Ország/terület kódokhoz tartozó Dátumformátum oszlop az 1994. január 3. dátum megjelenítési formátumát, az Időformátum oszlop pedig a 17:35 időponthoz (0 másodperc és 0 századmásodperc) tartozó megjelenítési formátumot tartalmazza.

Ország/terület vagy nyelv | Ország/terület kód | Dátumformátum | Időformátum
Egyesült Államok | 001 | 01/03/1994 | 5:35:00.00p
Kanadai francia | 002 | 1994-01-03 | 17:35:00
Latin-Amerika | 003 | 03/01/1994 | 5:35:00.00p
Hollandia | 031 | 03-01-94 | 17:35:00
Belgium | 032 | 03/01/94 | 17:35:00
Franciaország | 033 | 03.01.1994 | 17:35:00
Spanyolország | 034 | 3/01/94 | 17:35:00
Magyarország | 036 | 1994.01.03 | 17:35:00
Olaszország | 039 | 03/01/94 | 17.35.00
Svájc | 041 | 03.01.94 | 17 35.00
Cseh Köztársaság | 042 | 03.01.1994 | 17:35:00
Szlovákia | 042 | 03.01.1994 | 17:35:00
Egyesült Királyság | 044 | 03/01/94 | 17:35:00.00
Dánia | 045 | 03-01-94 | 17.35.00
Svédország | 046 | 1994-01-03 | 17.35.00
Norvégia | 047 | 03.01.94 | 17:35:00
Lengyelország | 048 | 1994-01-03 | 17:35:00
Németország | 049 | 03.01.1994 | 17:35:00
Brazília | 055 | 03/01/94 | 17:35:00
Nemzetközi angol | 061 | 03/01/1994 | 17:35:00.00
Portugál | 351 | 03-01-1994 | 17:35:00
Finnország | 358 | 3.1.1994 | 17.35.00


Date

Megjeleníti a dátumot, illetve lehetővé teszi a dátum módosítását a számítógépről vagy kötegfájlból.

date [hh-nn-éé]

date [/t]

Paraméterek

hh-nn-éé

Beállítja a megadott dátumot. A nap, hónap és év értékét ponttal (.), kötőjellel (-) vagy ferde vonallal (/) kell egymástól elválasztani.

A hh értéke 1 és 12 között lehet

A nn értéke 1 és 31 között lehet

Az éé értéke 80 és 99, vagy 1980 és 2099 között lehet

/t

Ezzel a kapcsolóval a program megjeleníti az aktuális dátumot anélkül, hogy új dátumot kérne be.

További tudnivalókért a Kapcsolódó témakörök között kattintson az Idő témakörre.


Példa a Date parancs használatára

Date

Példa

A dátum a következő paranccsal állítható be 1994 január 12-re:

date 1994/01/12

Az aktuális rendszerdátum a következő paranccsal jeleníthető meg:

date /t


Megjegyzések a Date parancshoz

Date

Megjegyzések

A napok beállítása a hónapnak megfelelően

A Windows 2000 a hónapot és az évet automatikusan váltja, függetlenül attól, hogy a hónap 28, 29, 30 vagy 31 napos.


Debug

Elindítja a Debug segédprogramot, amelynek segítségével tesztelhetők és hibák kereshetők az MS-DOS végrehajtható fájlokban.

debug [[meghajtó:][elérési_útvonal] fájlnév [paraméterek]]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

A tesztelni kívánt végrehajtható fájl helyét és nevét adja meg.

paraméterek

Minden olyan parancssori adat, amely a tesztelni kívánt végrehajtható fájl futtatásához szükséges.


Debug: A (összeállítás)

8086/8087/8088 mnemonikokat állít össze közvetlenül a memóriában.

Ez a parancs végrehajtható gépi kódú utasításokat hoz létre assembly nyelven írt parancsokból. Minden számértéket hexadecimális formátumban kell megadni 1-4 karakteren. Megadható előtag mnemonik azon műveletkód előtt, amelyre a mnemonik vonatkozik.

a [cím]

Paraméterek

cím

Megadja azt a helyet, ahová az assembly nyelvű mnemonikokat beírja. A cím értéke hexadecimális értékkel adható meg a kezdő „h” karakter beírása nélkül. A cím kihagyása esetén az a paraméter ott kezdi az összeállítást, ahol a legutóbb abbahagyta.

Az adatok megadott bájtba történő bevitelével kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug E (bevitel) című témakörre.

A bájtok visszafejtésével kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug U (visszafejtés) című témakörre.


Példák a Debug: A parancs használatára

Példák a Debug: A

parancs használatára

Az a parancs a regiszter-indirekt parancsok minden formáját támogatja, ahogy az alábbi példa is mutatja:

add bx,34[bp+2].[si-1]
pop [bp+di]
push [si] )

A parancs a műveleti kód összes szinonimáját is támogatja, ahogy ezt az alábbi példa mutatja:

loopz 100
loope 100
ja 200
jnbe 200

A 8087 műveleti kódok használata esetén az alábbi példában bemutatott módon meg kell adni a wait vagy az fwait előtagot:

fwait fadd st,st(3) ; ez a sor
; fwait előtagot állít össze


Megjegyzések a Debug: A parancs használatához

Megjegyzések a Debug: A

parancs használatához

Mnemonikok használata

A szegmenseket felülíró mnemonikok a következők: cs:, ds:, es:, és ss:. A távoli visszatérés mnemonikja a retf. A karakterláncokra vonatkozó mnemoniknak tartalmaznia kell a karakterlánc hosszát. Például a movsw mnemonik segítségével szó karakterláncok (16 bit) helyezhetők át, és a movsb mnemonik segítségével bájt karakterláncok (8 bit) helyezhetők át.

Ugrások és hívások összeállítása

Az assembly fordító (assembler) a bájteltolástól függően a célként megadott címhez automatikusan összeállítja a rövid, közeli vagy távoli ugrást. Az ilyen ugrások vagy hívások felülbírálhatók a near vagy a far előtag használatával, az alábbi példában bemutatott módon:

-a0100:0500
0100:0500 jmp 502 ; 2 bájtos rövid ugrás
0100:0502 jmp near 505 ; 3 bájtos közeli ugrás
0100:0505 jmp far 50a ; 5 bájtos távoli ugrás

A near előtag az ne rövidítéssel helyettesíthető.

A szó és a bájt memóriacímek megkülönböztetése

Ha egy operandus szó és bájt memóriacímére is hivatkozhat, akkor meg kell adni az adattípust a word ptr vagy a byte ptr előtaggal. E két előtag érvényes rövidítése a wo és a by rövidítés. Az alábbi példa mindkét formátumot bemutatja:

dec wo [si]
neg byte ptr [128]

Operandusok megadása

A Debug parancs azt az elfogadott jelölésmódot alkalmazza, hogy a szögletes zárójelek ([ ]) közé helyezett operandusok memóriacímek. Ez azért van így, mert különben a Debug parancs nem tudna különbséget tenni a közvetlen operandusok és a memóriacímek között. Az alábbi példa mindkét formátumot bemutatja:

mov ax,21 ; töltse fel az AX regisztert 21h-val
mov ax,[21] ; töltse fel az AX regisztert
; a 21h memóriahely
; tartalmával

A pszeudoparancsok használata

Két gyakori pszeudoparancs használható az a parancshoz: a db műveleti kód, amely bájt értékeket fordít közvetlenül a memóriába, és a dw műveleti kód, amely szó értékeket fordít közvetlenül a memóriába. Az alábbi példa mindkét pszeudoparancsot bemutatja:

db 1,2,3,4,"EZ EGY PÉLDA"
db 'EZ EGY IDÉZŐJEL: "'
db "'EZ EGY IDÉZŐJEL: '"
dw 1000,2000,3000,"KÖTEG"


Példák a Debug: C (összehasonlítás) parancs használatára

Összehasonlít két memóriaterületet.

c tartomány cím

Paraméterek

tartomány

Megadja az összehasonlítani kívánt első memóriaterület kezdetének és végének címét, vagy a kezdőcímét és a hosszát. A tartomány érvényes értékeivel kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Megjegyzések a Debug parancshoz témakörre.

cím

Megadja az összehasonlítani kívánt második memóriaterület kezdőcímét. A tartomány érvényes értékeivel kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témakörök között a Megjegyzések a Debug parancshoz című témakört.


Példák a Debug: C parancs használatára

Példák a Debug: C

Példa

Az alábbi parancsoknak ugyanaz az eredményük:

c100,10f 300
c100l10 300

Mindkét parancs a memória 100h-tól 10Fh-ig tartó részét összehasonlítja a 300h-tól 30Fh-ig tartó résszel.

A Debug parancs az előző parancsok mindegyikére az alábbihoz hasonló kimenetet jelenít meg (feltéve, hogy DS = 197F):

197F:0100 4D E4 197F:0300
197F:0101 67 99 197F:0301
197F:0102 A3 27 197F:0302
197F:0103 35 F3 197F:0303
197F:0104 97 BD 197F:0304
197F:0105 04 35 197F:0305
197F:0107 76 71 197F:0307
197F:0108 E6 11 197F:0308
197F:0109 19 2C 197F:0309
197F:010A 80 0A 197F:030A
197F:010B 36 7F 197F:030B
197F:010C BE 22 197F:030C
197F:010D 83 93 197F:030D
197F:010E 49 77 197F:030E
197F:010F 4F 8A 197F:030F

Figyelje meg, hogy a 197F:0106 és a 197F:0306 memóriacím hiányzik a listából. Ez azt jelenti, hogy ezeknek a memóriahelyeknek a tartalma megegyezik.


Megjegyzés a Debug: C parancs használatához

Megjegyzés a Debug: C

parancs használatához

Ha a tartomány és cím memóriaterület ugyanaz, a Debug segédprogram nem jelenít meg semmit, és visszatér közvetlenül a Debug parancssorhoz. Az eltéréseket a Debug segédprogram az alábbi formátumban jeleníti meg (ha van):

cím1 bájt1 bájt2 cím2


A Debug: D (memóriakép kiírása) parancs

Megjeleníti az adott memóriacímek tartományának tartalmát.

d [tartomány]

Paraméter

tartomány

Megadja a megjeleníteni kívánt memóriaterület kezdetének és végének címét, vagy kezdőcímét és hosszát. A tartomány érvényes értékeivel kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Megjegyzések a Debug parancshoz című témakörre. A tartomány érték kihagyása esetén a Debug parancs 128 bájt tartalmát jeleníti meg úgy, hogy a címtartomány kezdete az a cím, ahol a legutóbbi d parancs végződött.

A regiszterek tartalmának megjelenítésével kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug R (regiszter) című témakörre.


Példák a Debug: D parancs használatára

Példák a Debug: D

parancs használatára

A következő parancs beírása esetén:

dcs:100 10f

a Debug parancs a tartomány tartalmát a következő formátumban jeleníti meg:

04BA:0100 54 4F 4D 00 53 41 57 59-45 52 00 00 00 00 00 00 TOM.SAWYER......

Ha a d parancsot paraméterek nélkül adja meg, akkor a Debug parancs a kimenetet az előző példában bemutatott módon jeleníti meg. Minden sor egy olyan címmel kezdődik, ami 16 bájttal nagyobb, mint az előző sorban található cím (vagy 8 bájttal, ha 40 oszlop széles a képernyő).

Minden egymást követő paraméter nélküli d parancs esetén a Debug az utoljára megjelenített bájt után következő bájt tartalmát mutatja meg.

Az alábbi parancs kiadásakor a Debug a CS:100-nál kezdődő 20h bájt tartalmát mutatja meg:

dcs:100 l 20

Az alábbi parancs a CS szegmens 100h és 115h között található összes bájtjának a tartalmát írja ki:

dcs:100.115


Megjegyzés a Debug: D parancs használatához

Megjegyzés a Debug: D

parancs használatához

A d parancs használata esetén a Debug segédprogram a memória tartalmát két részben jeleníti meg: egy hexadecimális részben (minden bájt értéke hexadecimális formátumban jelenik meg) és egy ASCII részben (minden bájt értéke ASCII karakterként jelenik meg). A nem nyomtatható karakterek helyén pont (.) látható a megjelenítés ASCII részében. Minden sor 16 bájt tartalmát jeleníti meg, a nyolcadik és kilencedik bájt között egy gondolatjel látható. Minden sor egy 16 bájtos szakasz határán kezdődik.


Debug: E (bevitel)

A megadott memóriacímre adatot tölt be.

Az adat hexadecimálisan vagy ASCII formátumban is megadható. Az adott címen tárolt minden korábbi adat elveszik.

e cím [lista]

Paraméterek

cím

Megadja az első memóriahelyet, ahová adatot szeretne betölteni.

lista

Megadja a memória egymást követő bájtjaiba betölteni kívánt adatokat.

A mnemonikok használatával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug A (összeállítás) című témakörre.

A memória adott részének megjelenítésével kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug D (memóriakép kiírása) című témakörre.


Példák a Debug: E parancs használatára

Példák a Debug: E

parancs használatára

A következő parancs beírása esetén:

ecs:100

a Debug parancs az első bájt tartalmát a következő formátumban jeleníti meg:

04BA:0100 EB._

Ha ezt az értéket 41-re szeretné módosítani, az alábbi példának megfelelően a beviteli pontnál írja be a 41 értéket:

04BA:0100 EB.41_

Több egymást követő érték is megadható egyetlen e paranccsal. Az új érték megadása után az ENTER helyett a SZÓKÖZ billentyűt nyomja meg. A Debug segédprogram ilyenkor megjeleníti a következő értéket. Ebben a példában a SZÓKÖZ billentyű háromszori megnyomásakor a Debug segédprogram a következő értékeket jeleníti meg:

04BA:0100 EB.41 10. 00. BC._

Ha a hexadecimális BC értéket 42-re szeretné módosítani, az alábbi példában bemutatott módon a beviteli pontnál írja be a 42 értéket:

04BA:0100 EB.41 10. 00. BC.42_

Most tételezzük fel, hogy a 10-es értéket 6F-re szeretné cserélni. Ennek az értéknek a módosítása érdekében a 0101-es címre (értéke 10) való visszatéréshez nyomja meg kétszer a KÖTŐJEL billentyűt. A Debug segédprogram a következőt jeleníti meg:

04BA:0100 EB.41 10. 00. BC.42-
04BA:0102 00.-
04BA:0101 10._

Az alábbi példa alapján a beviteli ponton írja be a 6f értéket:

04BA:0101 10.6f_

Az ENTER billentyű megnyomásával megszakítható az e parancs futtatása, és visszatérhet a Debug parancssorhoz.

Az alábbi példa karakterlánc bevitelét mutatja be:

eds:100 "Ez szöveges példa"

Ez a karakterlánc 17 bájtot foglal a DS:100 címtől kezdődően.


Megjegyzések a Debug: E parancshoz

Megjegyzések a Debug: E

parancshoz

A cím paraméter használata

Ha a cím paraméter megadásakor a szabadon megadható lista paraméternek nem ad meg értéket, a Debug segédprogram megjeleníti a memóriacímet és annak tartalmát, megismétli a memóriacímet a következő sorban és vár az adatbevitelre. Ekkor az alábbi lehetőségek közül választhat:

  • Cseréli a bájt tartalmát. Ehhez az aktuális érték után meg kell adni az új értéket. Ha a megadott érték érvénytelen hexadecimális érték vagy kettőnél több számjegyből áll, akkor a Debug segédprogram nem írja be az érvénytelen karaktert.
  • Továbblép a következő bájtra. Ehhez nyomja meg a SZÓKÖZ billentyűt. Ha ennek a bájtnak az értékét szeretné megváltoztatni, adja meg az új értéket az aktuális érték után. Ha a SZÓKÖZ billentyű többszöri megnyomása esetén elhagy egy 8 bájtos határt, a Debug segédprogram új sort kezd, és az új bájt tartalma az új sor elején jelenik meg.
  • Visszatér az előző bájtra. Ehhez nyomja meg a KÖTŐJEL billentyűt. A KÖTŐJEL billentyű többszöri megnyomásával egy bájtnál többet is visszaléphet. A KÖTŐJEL billentyű megnyomásakor a Debug segédprogram új sorban jeleníti meg az aktuális memóriacímet és annak tartalmát.
  • Leállítja az e parancs futtatását. Ehhez nyomja meg az ENTER billentyűt. Az billentyű bármely bájtnál megnyomható.

A lista paraméter használata

A lista paraméter megadásakor az e parancs egymás után felülírja a bájt aktuális értékeket a lista soron következő értékével. Hiba esetén a bájt tartalma nem változik.

A Lista paraméter értékei hexadecimális bájtértékek vagy karakterláncok lehetnek. Az értékek szóközzel, vesszővel vagy tabulátor karakterrel választhatók el. A karakterláncokat szimpla (nyomdai) vagy kettős idézőjelek közé kell írni.


Debug: F (kitöltés)

Az adott memóriaterületet feltölti a megadott értékekkel.

Az adatok hexadecimális vagy ASCII formátumban adhatók meg. Az adott memóriacím korábbi tartalma elvész.

f tartomány lista

Paraméterek

tartomány

Meghatározza a feltölteni kívánt memóriaterület kezdetének és végének címét, vagy a kezdőcímét és a hosszát. A tartomány érvényes értékeivel kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Megjegyzések a Debug parancshoz című témakörre.

lista

Megadja a bevinni kívánt adatokat. A Lista paraméter hexadecimális számokat, vagy idézőjelek között egy karakterláncot tartalmazhat.


Példa a Debug: F parancs használatára

Példa a Debug: F

parancs használatára

A következő parancs beírása esetén:

f04ba:100l100 42 45 52 54 41

a Debug segédprogram a 04BA:100 és 04BA:1FF közötti memóriatartományt feltölti a megadott értékekkel. A Debug segédprogram addig ismétli a megadott 5 értéket, amíg mind a 100h bájt tartalmát fel nem tölti.


Megjegyzések a Debug: F parancshoz

Megjegyzések a Debug: F

parancshoz

A tartomány paraméter használata

Ha a tartomány több bájtot tartalmaz, mint a listában található értékek száma, akkor a Debug segédprogram a listában található értékeket újra meg újra hozzárendeli, amíg a tartomány összes bájtját fel nem tölti.

Ha a tartomány valamely része rossz vagy nem létező memória, akkor a Debug segédprogram hibaüzenetet jelenít meg, és megszakítja az f parancs végrehajtását.

A lista paraméter használata

Ha a lista több értéket tartalmaz, mint a tartományban található bájtok száma, a Debug segédprogram figyelmen kívül hagyja a lista extra elemeit.


Debug: G (futtatás)

Futtatja a jelenleg a memóriában levő programot.

g [=cím] [töréspontok]

Paraméterek

=cím

Megadja azt a memóriacímet, ahonnan a program futtatását el szeretné kezdeni. Ha nem adja meg a cím paramétert, a Windows 2000 a CS:IP regiszterek aktuális értékétől kezdi a program futtatását.

töréspontok

Meghatároz a g parancs részeként megadható 1–10 ideiglenes töréspontot.

Hurok, ismételt karakterlánc utasítás, szoftvermegszakítás vagy eljárás végrehajtásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug P (folytatás) című témakörre.

Egy utasítás végrehajtásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug T (nyomkövetés) című témakörre.


Példák a Debug: G parancs használatára

Debug: G

Példák

A következő parancs beírása esetén:

gcs:7550

a Windows 2000 a CS szegmens 7550-es címén található töréspontig lefuttatja a jelenleg a memóriában található programot. A Debug segédprogram ekkor megjeleníti a regiszterek tartalmát és a jelzők állapotát, és leállítja a g parancs futását.

A következő parancs két töréspontot állít be:

gcs:7550, cs:8000

Ha a Debug segédprogram elért egy törésponthoz és ismételten beírja a g parancsot, a program futtatása a normál kezdőpont helyett a töréspont utáni parancstól folytatódik.


Megjegyzések a Debug: G parancshoz

Debug: G

Megjegyzések

A cím paraméter használata

A kezdőcím (cím) és a töréspontok címének (töréspontok) megkülönböztetése érdekében a cím paraméter elé mindig egyenlőségjelet (=) kell írni.

Töréspontok megadása

A program megáll az első töréspontnál függetlenül attól, hogy azt hol adta meg a töréspontok listában. A Debug segédprogram a töréspont helyén található eredeti utasítást kicseréli egy megszakításkóddal.

Amikor a program törésponthoz ér, a Debug segédprogram az összes törésponton visszaállítja az eredeti utasítást, megjeleníti az összes regiszter tartalmát, az összes jelző értékét, és dekódolt formában az utolsó futtatott parancsot. A Debug segédprogram ugyanazokat az adatokat jeleníti meg, mintha a Debug r (regiszter) parancs használta esetén megadott volna egy töréspontcímet.

Ha valamely töréspontnál nem állítja meg a program futását, a Debug segédprogram a megszakításkódok helyére nem írja vissza az eredeti utasításokat.

A töréspontok beállítására vonatkozó korlátozások

Csak olyan címekre helyezhető el töréspontokat, amelyek egy 8086-os műveleti kód első bájtját tartalmazzák. 10-nél több töréspont elhelyezése esetén a Debug segédprogram az alábbi üzenet jeleníti meg:

bp hiba

A felhasználói veremmutatóra vonatkozó követelmények

Kizárólag érvényes felhasználói veremmutató adható meg, és a g parancs számára legalább 6 bájtnak rendelkezésre kell állnia. Ez a parancs az iret utasítás segítségével ugrik a tesztelt programra. A Debug segédprogram beállítja a felhasználói veremmutatót, és a felhasználói jelzőket, a kódszegmensregisztert és az utasításmutatót a verembe helyezi. (Ha a felhasználói verem nem érvényes vagy túl kicsi, akkor az az operációs rendszer hibáját okozhatja.) A Debug segédprogram megszakításkódot (0CCh) helyez a megadott töréspont(ok)ra.

Program újraindítása

Ne kísérelje meg egy program újraindítását, miután a Windows 2000 az alábbi üzenetet jelenítette meg:

A program végrehajtása sikeresen befejeződött

A program megfelelő futtatásához újra be kell tölteni a programot a Debug n (név) és l (betöltés) paranccsal.


Debug: H (hexadecimális)

Hexadecimális műveletet hajt végre a két megadott paraméterrel.

h érték1 érték2

Paraméterek

érték1

Bármely 0 és FFFFh közé eső hexadecimális szám lehet.

érték2

A második hexadecimális szám, amely 0 és FFFFh közé eső hexadecimális szám lehet.


Példa a Debug: H parancs használatára

Debug: H

Példa

A következő parancs beírása esetén:

h19f 10a

a Debug sedédprogram az alábbi formátumban jeleníti meg az adatokat:

02A9 0095


Megjegyzés a Debug: H parancshoz

Debug: H

Megjegyzés

A Debug segédprogram először összeadja a két megadott paramétert, majd az elsőből kivonja a másodikat. Ezeknek a számításoknak az eredményét egyetlen sorban jeleníti meg: először az összeget, majd a különbséget.


Debug: I (bemenet)

Beolvassa és megjeleníti a megadott portra érkező bájt értékét.

i port

Paraméter

port

Megadja az bemeneti port címét. A cím 16 bites érték lehet.

A kimeneti portra küldhető bájtértékkel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug: O (kimenet) című témakörre.


Példa a Debug: I parancs használatára

Debug: I

Példa

A következő parancs beírása esetén:

i2f8

tegyük fel, hogy a portra érkező bájt értéke 42h. A Debug segédprogram beolvassa a bájt értékét és megjeleníti a következőképpen:

42


Debug: L (betöltés)

Betölti a fájlt vagy a lemez adott szektorainak tartalmát a memóriába.

A BC:CX regiszterben megadott számú bájt tartalma a következő szintaxissal tölthető be a memóriába egy fájlból:

l [cím]

A Windows 2000 fájlrendszerének kihagyásával a megadott szektorok a következő szintaxissal tölthetők be közvetlenül:

l cím meghajtó kezdet szám

Paraméterek

cím

Megadja azt a memóriahelyet, ahová be kívánja tölteni a fájl vagy a szektor tartalmát. A cím kihagyása esetén a Debug segédprogram a CS regiszterben található címet használja.

meghajtó

Megadja azt a meghajtót, amelyen a beolvasni kívánt szektorokat tartalmazó lemez található. Ez egy numerikus érték: 0 = A, 1 = B, 2 = C stb.

kezdet

Megadja az első beolvasni kívánt szektor hexadecimális sorszámát.

szám

Megadja az egymás után beolvasni kívánt szektorok számát hexadecimális számként. Csak adott szektorok beolvasása esetén javasolt a meghajtó, kezdet és szám paraméterek használata. A debug parancssorban, vagy a legutóbbi Debug n (név) parancsban megadott fájl betöltésekor nem szükségesek ezek a paraméterek.

Az l parancsban a fájl megadásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug n (név) című témakörre.

A Debug segédprogrammal vizsgált fájl lemezre írásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug w (írás) című témakörre.


Példák a Debug: L parancs használatára

Debug: L

Példák

A Debug segédprogram elindítása után beírja a következő parancsot:

nfile.com

Az l parancs segítségével betölthető a File.com fájl. A Debug segédprogram betölti a fájlt, és megjeleníti a Debug parancssort.

A C meghajtó 15 (0Fh) logikai szektorával kezdődő 109 (6Dh) szektorai a következő paranccsal tölthetők be a 04BA:0100 címmel kezdődő memóriaterületre:

l04ba:100 2 0f 6d


Megjegyzések a Debug: L parancshoz

Debug: L

Megjegyzések

Az l parancs használata paraméterek nélkül

Az l parancs paraméter nélküli megadása esetén a debug parancssorban megadott fájlt a CS:100 címtől kezdődően betölti a memóriába a parancs. A Debug segédprogram a BX és CX regiszter értékét is beállítja a betöltött bájtok számának megfelelően. Amennyiben a debug parancssorban nincs megadva fájl, az n paranccsal legutóbb megadott fájl tölthető be a memóriába.

Az l parancs használata a cím paraméterrel

Az l parancs a cím paraméterrel együtt történő megadása esetén a Debug segédprogram betölti a fájlt vagy a megadott szektor tartalmát a memória a cím paraméterben megadott részétől kezdődően.

Az l parancs használata az összes paraméterrel

Az l parancs összes paraméterének megadása esetén a Debug segédprogram a megadott lemezszektorok tartalmát tölti be, és nem egy adott fájl.

Megadott szektorok tartalmának betöltése

A tartomány összes szektorát beolvassa a parancs a lemezről. A Debug segédprogram a kezdet paraméterben megadott szektornál kezdi a beolvasást, és addig folytatja, amíg a szám paraméterben megadott számú szektor tartalmát be nem tölti.

.exe fájl betöltése

Az .exe fájlok esetén a Debug segédprogram figyelmen kívül hagyja a cím paramétert. Az .exe fájl megadásakor a Debug segédprogram az .exe fájl fejlécében meghatározott betöltési címre helyezi át a fájlt. A memóriába olvasás előtt az .exe fájl fejlécét eltávolítja a rendszer, így a meghajtón levő fájl és a memóriába betöltött fájl mérete különbözik. A teljes .exe fájl vizsgálatához nevezze át más kiterjesztésűre a fájlt.

Hexadecimális fájl megnyitása

A hexadecimális fájl olyan fájl, amely a The MS-DOS Encyclopedia (Microsoft Press, 1988) című könyvben leírt módon az Intel hexadecimális formátumot használja. A Debug segédprogram feltételezi, hogy a .hex kiterjesztésű fájlok hexadecimális formátumú fájlok. A hexadecimális fájl a fájlban megadott címmel kezdődően betölthető az l parancs paraméter nélküli kiadásával. Az l parancsban a cím paraméter megadása esetén a Debug segédprogram a kezdőcím meghatározásához a megadott címhez hozzáadja a hexadecimális fájlban található címet.


Debug: M (áthelyezés)

Az adott memóriablokk adatait átmásolja egy másik memóriablokkba.

m tartomány cím

Paraméterek

tartomány

Megadja a másolni kívánt memóriaterület kezdetének és végének címét, vagy kezdőcímét és hosszát.

cím

Megadja annak a területnek a kezdőcímét, ahová a tartomány paraméterben megadott memóriaterület tartalmát átmásolja a parancs.


Példa a Debug: M parancs használatára

Debug: M

Példa

A következő parancs beírása esetén:

mcs:100 110 cs:500

a Debug segédprogram először átmásolja a CS:110 cím tartalmát a CS:510 címre, majd átmásolja a CS:10F cím tartalmát a CS:50F címre stb. Végül átmásolja a CS:100 cím tartalmát a CS:500 címre. Az eredmény a Debug d (memóriakép kiírása) paranccsal jeleníthető meg az m parancsban célcímként megadott paraméterrel.


Megjegyzések a Debug: M parancshoz

Debug: M

Megjegyzések

A másolási művelet hatása a meglevő adatokra

Amennyiben a másolni kívánt memóriaterületre nem ír a program új adatot, a korábbi adatok sértetlenek maradnak. Ha azonban a célként megadott terület adatokat tartalmaz (ami átlapolt másolási művelet esetén előfordulhat), ezeket az adatokat felülírja a parancs. (Átlapolt másolási műveletnek nevezzük az olyan másolást, amikor a célként megadott terület egy része fedi a forrásterület egy részét.)

Átlapolt másolási művelet végrehajtása

Az m parancs adatvesztés nélkül hajtja végre az átlapolt másolási műveleteket. Először az átfedett terület másolását végzi el. Így ha az adatokat magasabb memóriaterületről alacsonyabb címre másolja, akkor a másolás a forrásblokk legkisebb címénél kezdődik és a magasabb címek felé folytatódik. Ha viszont az adatokat alacsonyabb memóriaterületről magasabb címekre másolja, akkor a másolás a forrásblokk legnagyobb címénél kezdődik, és az alacsonyabb címek felé folytatódik.


Debug: N (név)

A Debug l (betöltés) vagy w (írás) parancs számára ad meg egy végrehajtható fájlt, vagy a Debug segédprogramban vizsgált végrehajtható fájlhoz ad meg paramétereket.

n [meghajtó:][elérési_útvonal] fájlnév

A tesztelt végrehajtható fájl számára a következő szintaxissal adhatók meg paraméterek:

n fájlparaméterek

Paraméterek

Paraméterek nélkül az n parancs törli az aktuális beállításokat.

[meghajtó:][elérési_útvonal] fájlnév

A tesztelni kívánt végrehajtható fájl helyét és nevét adja meg.

fájlparaméterek

A tesztelt végrehajtható fájl paramétereit és kapcsolóit adja meg.

Fájlok vagy adott lemezszektorok tartalmának memóriába olvasásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug L (betöltés) című témakörre.

A Debug segédprogrammal vizsgált fájl lemezre írásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug W (írás) című témakörre.


Példák a Debug: N parancs használatára

Debug: N

Példák

Indítsa el a Debug segédprogramot, és töltse be a Prog.com fájlt a hibakereséshez. Ezután egymás után adjon meg két paramétert a Prog.com programhoz, majd futtassa a programot. A következőkben láthatók a fenti példát megvalósító parancsok:

debug prog.com
nparaméter1 paraméter2
g

Ebben az esetben a Debug g (futtatás) parancs úgy futtatja a programot, mintha a következő parancsot adta volna meg a Windows 2000 parancssorban:

prog paraméter1 paraméter2

Így a tesztelés és hibakeresés tipikus futtatási környezetet biztosít a Prog.com program számára.

A következő parancssorozatban az első n parancs megadja a Fájl1.exe fájlt, melyet a következő l (betöltés) parancs betölt a memóriába. A második n parancs megadja, hogy mely paramétereket használja a Fájl1.exe program. Végül a g parancs úgy futtatja a Fájl1.exe programot, mintha a Windows 2000 parancssorban a Fájl1 Fájl2.dat Fájl3.dat parancsot írta volna be.

nfájl1.exe
l
nfájl2.dat fájl3.dat
g

Megjegyzés

  • Az n parancs második szintaxissal történő használata után az l parancs nem adható ki. Figyeljen arra, hogy ezután a w (írás) parancs használata esetén a Windows 2000 a debug segédprogramban használt Fájl1.exe fájlt menti el Fájl2.dat néven. Ennek elkerülése érdekében az l vagy a w parancs használata előtt mindig adja ki az n parancsot az első szintaxissal.


Megjegyzések a Debug: N parancshoz

Debug: N

Megjegyzések

Az n parancs használatának két módja

Az n parancs kétféle módon használható. Segítségével megadható egy olyan fájl, amelyet később az l (betöltés) vagy a w (írás) parancs használ. Ha a Debug segédprogramot fájl megadása nélkül indítja el, akkor az l (betöltés) parancs használata előtt használni kell az n fájlnév parancsot. A fájlnév helyes formátumban kerül a CS:5C regiszter fájlvezérlő blokkjába (FCB). Másodsorban az n parancs a Debug segédprogramban használt fájl parancssori paramétereinek és kapcsolóinak megadására is használható.

Memóriaterületek

Az n parancs a memória következő négy területére lehet hatással:

Memóriahely | Tartalom
CS:5C | Fájlvezérlő blokk (FCB) az 1-es fájlhoz
CS:6C | Fájlvezérlő blokk (FCB) a 2-es fájlhoz
CS:80 | Az n parancssor hossza (karakterben)
CS:81 | Az n parancssor karaktereinek kezdete

Az n paranccsal megadott első fájlnév a CS:5C memóriacímen található fájlvezérlő blokkba kerül. A másodikként megadott fájlnév a CS:6C memóriacímen található fájlvezérlő blokkba kerül. Az n parancssorban megadott karakterek száma (az első n karaktert kivéve) a CS:80 memóriacímre kerül. Az n parancssorban megadott karaktereket (most is az első n karaktert kivéve) a CS:81 memóriacímtől kezdődően tárolja a parancs a memóriában. Megjegyzés: bármely olyan kapcsoló vagy elválasztó jel megadható karakterként, amely érvényes egy Windows 2000 parancssorban megadott parancs esetén.


Megjegyzések a Debug parancshoz

Debug

Megjegyzések

A Debug parancs használata vizsgált fájl megadása nélkül

A Debug parancs hely és fájlnév nélküli használatakor a Debug parancsokat a Debug programsorba (ezt kötőjel jelzi -) kell beírni.

Debug parancsok

A Debug parancsok listája.

? | Megjeleníti a Debug parancsok listáját.
a | Lefordítja a 8086/8087/8088 mnemonikokat.
c | Összehasonlítja a memória két részét.
d | Megjeleníti a memória valamely részének tartalmát.
e | Megadott címtől kezdődően adatokat ír a memóriába.
f | Megadott értékekkel tölt ki egy memóriatartományt.
g | Futtatja a memóriában levő végrehajtható fájlt.
h | Hexadecimális aritmetikai műveleteket hajt végre.
i | Egybájtos értékétet jelenít meg egy adott portról.
l | A fájl vagy lemez szektorainak tartalmát betölti a memóriába.
m | Átmásolja egy memóriablokk tartalmát.
n | Megadja az l vagy a w paranccsal használható fájlt, vagy megadja a vizsgált fájl paramétereit.
o | Egybájtos értéket küld a kimeneti portra.
p | Hurkot, ismételt karakterlánc utasítást, szoftveres megszakítást vagy eljárást hajt végre.
q | Megállítja a Debug munkamenetet.
r | Megjeleníti vagy megváltoztatja egy vagy több regiszter értékét.
s | Adott memóriatartományban megkeresi a megadott egy- vagy több bájtos minta előfordulásait.
t | Végrehajt egy parancsot, majd megjeleníti az összes regiszter tartalmát, minden jelző állapotát és a Debug segédprogram által következőként végrehajtandó parancsot visszafejtett formában.
u | Visszafejti a bájtokat, és megjeleníti a megfelelő forrásutasításokat.
w | Lemezre írja a vizsgált fájlt.
xa | Lefoglalja a bővített memóriát.
xd | Felszabadítja a bővített memóriát.
xm | Leképezi a bővített memória lapjait.
xs | Megjeleníti a bővített memória állapotát.

A parancssori paraméterek elválasztása

A q parancs kivételével minden Debug parancsnak lehetnek paraméterei. A paraméterek vesszőkkel vagy szóközökkel választhatók el, de ezeket az elválasztó jeleket csak hexadecimális értékek között szükséges megadni. Tehát a következő parancsok megegyeznek:

dcs:100 110

d cs:100 110

d,cs:100,110

Érvényes cím megadása

A Debug parancsokban a cím paraméter egy memóriahelyet jelöl ki. A Cím két részből álló jelölő, amelynek az első része betűkből álló szegmensregiszter vagy négyjegyű szegmenscím, a második része pedig az eltolás mértéke. A szegmensregiszter és a szegmenscím kihagyható. Az a, g, l, t, u, és w parancsok esetében az alapértelmezett szegmens a CS. A többi parancs esetében az alapértelmezett szegmens a DS. Minden számérték hexadecimális formátumban van.

A következők érvényes címet adnak meg:

CS:0100

04BA:0100

A szegmensnév és az eltolás értéke között a kettőspont használata kötelező.

Érvényes tartomány megadása

A Debug parancsokban a tartomány paraméter memóriatartományt jelöl ki. A tartomány kétféle módon adható meg: a kezdetének és a végének a címével, vagy a kezdőérték és a tartomány hosszának (l betűvel jelölve) megadásával.

A következő két példa a CS:100 memóriacímmel kezdődő 16 bájt hosszú memóriatartományt határozza meg:

cs:100 10f

cs:100 l 10


Debug: O (kimenet)

Adott bájtértéket küld a kimeneti portra.

o port bájtérték

Paraméterek

port

Megadja a kimeneti port címét. A portcím 16 bites érték lehet.

bájtérték

Megadja a portra küldeni kívánt bájt értékét.

A bájtérték bemeneti portról történő beolvasásával kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug: I (bemenet) című témakörre.


Példa a Debug: O parancs használatára

Debug: O

Példa

A 4Fh bájtérték a 2F8h címen levő kimeneti portra a következő paranccsal küldhető el:

o2f8 4f


Debug: P (végrehajtás)

Hurkot, ismételt karakterlánc utasítást, szoftveres megszakítást vagy eljárást hajt végre, vagy nyomon követi bármelyik más utasítást.

p [=cím] [szám]

Paraméterek

=cím

Megadja az első végrehajtani kívánt utasítás helyét. A cím kihagyása esetén az alapértelmezett cím a CS:IP regiszterben megadott cím.

szám

Megadja a Debug segédprogramhoz való visszatérés előtt végrehajtani kívánt utasítások számát. Az alapértelmezett érték 1.

A memóriában levő program futtatásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug G (futtatás) című témakörre.

Egy utasítás végrehajtásával kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug T (nyomkövetés) című témakörre.


Példa a Debug: P parancs használatára

Debug: P

Példa

Tegyük fel, hogy a vizsgált program tartalmaz egy call utasítást a CS:143F címen. A call parancs által meghívott szubrutin futtatásához, majd a vezérlés a Debug segédprogramnak való visszaadásához írja be a következő parancsot:

p=143f

A Debug segédprogram a következő formában jeleníti meg az eredményeket:

AX=0000 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
DS=2246 ES=2246 SS=2246 CS=2246 IP=1443 NV UP EI PL NZ AC PO NC
2246:1442 7505 JNZ 144A


Megjegyzések a Debug: P parancshoz

Debug: P

Megjegyzések

A vezérlés átadása a vizsgált programnak

Amikor a p parancs a Debug segédprogramtól átadja a vezérlést a vizsgált program számára, a program megszakítás nélkül fut mindaddig, amíg a megadott helyen a program végre nem hajtja a hurkot, ismételt karakterlánc utasítást, szoftveres megszakítást illetve eljárást, vagy amíg a végre nem hajtja a megadott számú gépi utasítást. Ezután a vezérlés visszakerül a Debug segédprogramhoz.

A cím paraméter korlátozásai

Ha a cím paraméter nem adja meg a szegmenst, a Debug segédprogram a vizsgált program CS regiszterében található értéket használja. A cím paraméter kihagyása esetén a programot a CS:IP regiszterben megadott címtől kezdődően hajtja végre a rendszer. A szám paramétertől való megkülönböztetés érdekében a cím paraméter előtt egyenlőség jelnek (=) kell állnia. Ha a megadott címen található utasítás nem hurok, ismételt karakterlánc utasítás, szoftveres megszakítás vagy eljárás, a p parancs ugyanúgy működik, mint a Debug t (nyomkövetés) parancs.

A p paranccsal által megjelenített üzenetek

Miután a p parancs végrehajt egy utasítást, a Debug segédprogram megjeleníti a program regisztereinek értékét, a jelzők állapotát és a következő végrehajtani kívánt utasítás visszafejtett formáját.

Figyelmeztetés

  • A p parancs nem használható a csak olvasható memória (ROM) nyomkövetésére.


Debug: Q (kilépés)

A vizsgált fájl mentése nélkül leállítja a Debug munkamenetet.

A q parancs beírása után a Windows 2000 parancssor kapja vissza a vezérlést.

q

Paraméterek

A parancsnak nincsenek paraméterei.

Fájl mentésével kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug W (írás) című témakörre.


Debug: R (regiszterek)

Megjeleníti vagy módosítja egy vagy több CPU regiszter tartalmát.

r [regiszter_neve]

Paraméter

nincs

Az r parancs paraméter nélküli használatakor megjelenik a regisztereket tároló terület összes regiszterének és jelzőjének tartalma.

regiszter_neve

A megjeleníteni kívánt regiszter nevét adja meg.

A memória egy adott részének megjelenítésével kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug D (memóriakép kiírása) című témakörre.

A bájtok visszafejtésével kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug U (visszafejtés) című témakörre.


Példák a Debug: R parancs használatára

Debug: R

Példák

Az összes regiszter tartalmának, az összes jelző állapotának és a jelenlegi utasítás visszafejtett formájának megjelenítéséhez írja be a következő parancsot:

r

Ha a jelenlegi memóriacím CS:11A, a következőhöz hasonló eredmény jelenik meg:

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21

Csak a jelzők állapotának megjelenítéséhez írja be a következő parancsot:

rf

A Debug segédprogram a következő formában jeleníti meg az adatokat:

NV UP DI NG NZ AC PE NC - _

Bármilyen sorrendben beírható egy vagy több érvényes jelző értéke szóközökkel vagy szóközök nélkül a következő példában látható módon:

nv up di ng nz ac pe nc - pleicy

A Debug segédprogram leállítja az r parancs futtatását, és megjelenik a Debug parancssor. A változások megtekintéséhez írja be az r vagy az rf parancsot. A Debug segédprogram a következőt jeleníti meg:

NV UP EI PL NZ AC PE CY - _

Az ENTER billentyű megnyomásával térhet vissza a Debug parancssorhoz.


Megjegyzések a Debug: R parancshoz

Debug: R

Megjegyzések

Az r parancs használata

A regiszternév megadása esetén a Windows 2000 megjeleníti a regiszter 16 bites értékét hexadecimális formátumban, és parancssorként kettőspont látható. A regiszterben tárolt érték módosításához adja meg az új értéket, és nyomja meg az ENTER billentyűt. A Debug parancssorhoz való visszatéréshez nyomja meg az ENTER billentyűt.

Érvényes regiszternevek

A következő regiszternevek használhatók: ax, bx, cx, dx, sp, bp, si, di, ds, es, ss, cs, ip, pc és f. Az ip és a pc egyaránt az utasításmutatóra utal.

Ha a fenti listában nem szereplő regiszternevet ad meg, a Windows 2000 a következő üzenetet jeleníti meg:

br hiba

Az f karakter használata regiszternév helyett

A regiszternév helyett az f karakter beírása esetén a Debug segédprogram kétbetűs kódként jeleníti meg az összes jelző jelenlegi beállítását, majd visszatér a Debug parancssorhoz. A jelző értékének a módosításához írja be a megfelelő kétbetűs kódot a következő táblázat alapján:

Jelző neve | Set | Clear
Túlcsordulás | ov | nv
Irány | dn (csökkentés) | up (növelés)
Megszakítás | ei (engedélyezett) | di (tiltott)
Jelölés | ng (negatív) | pl (pozitív)
Nulla | zr | nz
Kiegészítő vonal | ac | na
Paritás | pe (páros) | po (páratlan)
Vonal | cy | nc

A jelzők új értéke bármilyen sorrendben megadható. Az értékek között szóközt kell hagyni. Az r parancs leállításához nyomja meg az ENTER billentyűt. Nem változik azoknak a jelzőknek az értéke, amelyek nem kaptak új értéket.

Az r paranccsal megjelenő üzenetek

A jelzőhöz több érték megadása esetén a Debug segédprogram a következő üzenetet jeleníti meg:

df hiba

Az előző táblázatban nem szereplő kódú jelző megadásakor a Debug segédprogram a következő üzenetet jeleníti meg:

bf hiba

Mindkét esetben a Debug segédprogram figyelmen kívül hagyja a hibás bevitelt követően megadott beállításokat.

A Debug segédprogram alapértelmezett beállításai

A Debug segédprogram indításakor a szegmensregiszterek értéke a szabad memória aljára mutat, az utasításmutató értéke 0100h, minden jelző törölve lesz, a többi regiszter értéke nulla, kivéve az sp regisztert, amelynek értéke FFEEh.


Debug: S (keresés)

Adott memóriatartományban megkeresi egy vagy több bájt előfordulásait.

s tartomány lista

Paraméterek

tartomány

Megadja a vizsgálni kívánt tartomány kezdetének és végének címét. A tartomány paraméter érvényes értékeivel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug című témakörre.

lista

Megadja a keresni kívánt egy vagy több bájtos mintát vagy karakterláncot. A bájtok értékét szóközzel vagy vesszővel kell egymástól elválasztani. A karakterláncokat idézőjelek közé kell tenni.


Példák a Debug: S parancs használatára

Debug: S

Példák

A CS:100 és CS:110 közötti memóriatartományban a 41-es érték minden előfordulása a következő paranccsal kereshető meg:

scs:100 110 41

A Debug segédprogram a következő formában jeleníti meg az eredményeket:

04BA:0104
04BA:010D
-

A következő parancs a CS:100 és CS:1A0 közötti tartományban keresi meg a „Ph” karakterláncot:

scs:100 1a0 "Ph"


Megjegyzés a Debug: S parancshoz

Debug: S

Megjegyzés

A lista paraméterben több bájt értékének megadásakor a Debug segédprogram csak a bájtérték első előfordulásának címét jeleníti meg. Ha a lista paraméter csak egy bájt értékét tartalmazza, a Debug segédprogram megjeleníti a tartomány összes olyan címét, ahol az érték előfordul.


Debug alparancsok

További tudnivalókért válassza ki a kívánt Debug parancsot.

Debug: A (assembler kód)
Debug: C (összehasonlítás)
Debug: D (memóriakép kiírása)
Debug: E (adatbevitel)
Debug: F (feltöltés)
Debug: G (futtatás)
Debug: H (hexa aritmetika)
Debug: I (beolvasás)
Debug: L (betöltés)
Debug: M (áthelyezés)
Debug: N (név)
Debug: O (kiírás)
Debug: P (végrehajtás)
Debug: Q (kilépés)
Debug: r (regiszterek)
Debug: s (keresés)
Debug: T (nyomkövetés)
Debug: U (visszafejtés)
Debug: W (írás)
Debug: XA (bővített memória lefoglalása)
Debug: XD (bővített memória felszabadítása)
Debug: XM (bővített memória lapjainak leképezése)
Debug: XS (bővített memória állapotának megjelenítése)


Debug: T (nyomkövetés)

Végrehajt egy utasítást, majd megjeleníti minden regiszter tartalmát, minden jelző állapotát és a végrehajtott utasítás visszafejtett formáját.

t [=cím] [szám]

Paraméterek

=cím

Megadja azt a memóriacímet, ahonnan a Debug segédprogram elkezdi nyomon követni az utasításokat. A cím paraméter kihagyása esetén a nyomkövetés a program CS:IP regiszterében megadott címen kezdődik. A cím paraméter érvényes értékeivel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug című témakörre.

szám

A nyomon követni kívánt utasítások számát adja meg. Ez egy hexadecimális érték. Az alapértelmezett érték 1.

Hurok, ismételt karakterlánc utasítás, szoftveres megszakítás vagy eljárás végrehajtásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug P (végrehajtás) című témakörre.

A memóriában levő program végrehajtásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug G (futtatás) című témakörre.


Példa a Debug: T parancs használatára

Debug: T

Példa

A parancs végrehajtásához (amelyre a CS:IP regiszter mutat), a regiszterek tartalmának, a jelzők állapotának és az utasítás visszafejtett alakjának megjelenítéséhez írja be a következőt:

t

Ha az utasítás a programban a 04BA:011A címen található, akkor a Debug segédprogram a következőt jeleníti meg:

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21


Megjegyzések a Debug: T parancshoz

Debug: T

Megjegyzések

Utasítások nyomon követése csak olvasható memóriában

A t parancs a 8086-os és 8088-as mikroprocesszorok hardveres nyomkövetés üzemmódját használja. Így nyomon követhetők a csak olvasható memóriában (ROM) tárolt utasítások is.

A cím paraméter használata

A szám paramétertől való megkülönböztethetőség érdekében a cím paraméter előtt egyenlőség jelnek (=) kell állnia.


Debug: U (visszafejtés)

Visszafejti a bájtokat, és megjeleníti a hozzájuk tartozó forrásutasításokat címükkel és bájtértékükkel együtt. A visszafejtett kód egy összeállított fájl listájára hasonlít.

u [tartomány]

Paraméter

nincs

Paraméter nélkül az u parancs 20h bájtot fejt vissza (alapértelmezés) az előző u parancs által megjelenített cím utáni első címtől kezdődően.

tartomány

Megadja a visszafejteni kívánt kód kezdetének és végének címét, vagy a kezdeti címét és hosszát. A tartomány paraméter érvényes értékeivel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug című témakörre.

A fordításhoz használható mnemonikokkal kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Debug A (assembler kód) című témakörre.

A memória adott tartományának megjelenítésével kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug D (memóriakép kiírása) című témakörre.


Példák a Debug: U parancs használatára

Debug: U

Példák

A 04BA:0100 memóriacímtől kezdődően 16 (10h) bájt visszafejtéséhez írja be a következő parancsot:

u04ba:100l10

A Debug segédprogram a következő formában jeleníti meg az eredményeket:

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH
04BA:0109 65 DB 65
04BA:010A 63 DB 63
04BA:010B 69 DB 69
04BA:010C 66 DB 66
04BA:010D 69 DB 69
04BA:010E 63 DB 63
04BA:010F 61 DB 61

A 04BA:0100 – 04BA:0108 tartományba eső címekre vonatkozó adatok megjelenítéséhez írja be a következő parancsot:

u04ba:0100 0108

A Debug segédprogram a következőt jeleníti meg:

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH


Debug: W (írás)

Lemezre ír egy fájlt vagy adott szektorokat.

A BX:CX regiszterben megadott számú bájt tartalmának lemezre írásához használja a következő szintakszist:

w [cím]

A Windows 2000 fájlrendszerének figyelmen kívül hagyásához és a megadott szektorok közvetlen betöltéséhez használja a következő szintaxist:

w cím meghajtó kezdet szám

Paraméterek

cím

Megadja a lemezre írandó fájl vagy fájlrészlet kezdetének memóriacímét. A cím paraméter kihagyása esetén a Debug segédprogram a CS:100 regisztert használja kezdő memóriacímként. A cím paraméter érvényes értékeivel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug című témakörre.

meghajtó

Megadja a céllemezt tartalmazó meghajtót. Numerikus érték: 0 = A, 1 = B, 2 = C stb.

kezdet

Megadja az első szektor hexadecimális sorszámát, ahol a Debug segédprogram elkezdi az írást.

szám

Megadja azoknak a szektoroknak a számát, ahová a Debug segédprogram ír.

A w paranccsal kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug N (név) című témakörre.

Fájl vagy fájlszektorok tartalmának memóriába töltésével kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Debug L (betöltés) című témakörre.


Példa a Debug: W parancs használatára

Debug: W

Példa

A CS:100 címtől kezdődő memóriatartomány a B meghajtóban található lemez 37h sorszámú logikai szektorától kezdődően 2Bh darab szektorba történő kiírásához használja a következő módszert. Írja be a következő parancsot:

wcs:100 1 37 2b

Az írási művelet befejezése után a Debug segédprogram újra megjeleníti a Debug parancssort.


Megjegyzések a Debug: W parancshoz

Debug: W

Megjegyzések

A Debug segédprogram elindításakor, vagy az előző Debug n (név) parancs során megadott egy fájlnevet. Mindkét módszer helyes formátumban adja át a fájlnevet a CS:5C címen található fájlvezérlő blokk számára.

A BX:CX regiszterek tartalmának alaphelyzetbe állítása a w parancs paraméter nélküli kiadásával

A Debug g (futtatás), t (nyomkövetés), p (végrehajtás) vagy r (regiszterek) parancs használata után a BX:CX regisztereket alaphelyzetbe kell hozni a w parancs paraméter nélküli használata előtt.

Módosított fájl lemezre írása

A fájl módosítása után, ha a fájl neve, hossza és kezdőcíme nem változik, a Debug segédprogram továbbra is helyesen tudja a fájlt a lemezen az eredeti helyére írni.

A w parancs korlátozásai

Ezzel a paranccsal .exe és .hex fájlok nem írhatók.

Figyelmeztetés

  • Bizonyos szektorokba különösen veszélyes írni, mivel ez a művelet kikerüli a Windows 2000 fájlkezelőjét. Rossz érték beírása esetén könnyen megsérülhet a fájlstruktúra.


Debug: XA (bővített memória lefoglalása)

Lefoglalja a megadott számú lapot a bővített memóriában.

Bővített memória használatához a bővített memóriát kezelő, a Lotus/Intel/Microsoft Bővített Memória Specifikáció 4.0-s verziójának (LIM EMS) megfelelő eszközillesztőt kell telepíteni.

xa [darab]

Paraméter

darab

Megadja a bővített memóriából lefoglalni kívánt 16 kilobájtos lapok számát.

A bővített memóriát kezelő többi Debug paranccsal kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson az XD (bővített memória felszabadítása), XM (bővített memória lapjainak leképezése) vagy XS (bővített memória állapotának megjelenítése) című témakörre.


Példa a Debug: XA parancs használatára

Debug: XA

Példa

A bővített memóriában nyolc lap lefoglalásához írja be a következő parancsot:

xa8

A parancs sikeres befejezése esetén a következőhöz hasonló üzenetet jelenik meg:

Leíró létrehozva=0003


Megjegyzés a Debug: XA parancshoz

Debug: XA

Megjegyzés

Ha a megadott számú lap rendelkezésre áll, a Debug parancs megjeleníti a létrehozott leírók számát hexadecimálisan. Ellenkező esetben hibaüzenet jelenik meg:


Debug: XD (bővített memória felszabadítása)

Felszabadít egy a bővített memóriához tartozó leírót.

Bővített memória használatához a bővített memóriát kezelő, a Lotus/Intel/Microsoft Bővített Memória Specifikáció 4.0-s verziójának (LIM EMS) megfelelő eszközillesztőt kell telepíteni.

xd [leíró]

Paraméter

leíró

Megadja a felszabadítani kívánt leírót.

A bővített memóriát kezelő többi Debug paranccsal kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson az XA (bővített memória lefoglalása), XM (bővített memória lapjainak leképezése) vagy XS (bővített memória állapotának megjelenítése) című témakörre.


Példa a Debug: XE parancs használatára

Debug: XD

Példa

A 0003 leíró felszabadításához írja be a következő parancsot:

xd 0003

A parancs sikeresen befejezése esetén a következő üzenet jelenik meg:

Felszabadított leíró: 0003


Debug: XM (bővített memória lapjainak leképezése)

A bővített memória megadott leírójához tartozó logikai lapot leképezi a bővített memória fizikai lapjára.

Bővített memória használatához a bővített memóriát kezelő, a Lotus/Intel/Microsoft Bővített Memória Specifikáció 4.0-s verziójának (LIM EMS) megfelelő eszközillesztőt kell telepíteni.

xm [llap] [flap] [leíró]

Paraméterek

llap

Az flap fizikai lapra leképezni kívánt logikai lap sorszámát adja meg.

flap

Annak a fizikai lapnak a sorszámát adja meg, amelyre az llap logikai leképezése történik.

leíró

Megadja a leírót.

A bővített memóriát kezelő többi Debug paranccsal kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson az XA (bővített memória lefoglalása), XD (bővített memória felszabadítása) vagy XS (bővített memória állapotának megjelenítése) című témakörre.


Példa a Debug: XM parancs használatára

Debug: XM

Példa

A 0003 leíró 5-ös logikai lapjának a 2-es fizikai lapra történő leképezéséhez írja be a következő parancsot:

xm 5 2 0003

A parancs sikeresen befejezése esetén a következő üzenet jelenik meg:

05 logikai lap leképezése megtörtént a következő fizikai lapra: 02


Debug: XS (bővített memória állapotának megjelenítése)

Megjeleníti a bővített memória állapotának adatait.

Bővített memória használatához a bővített memóriát kezelő, a Lotus/Intel/Microsoft Bővített Memória Specifikáció 4.0-s verziójának (LIM EMS) megfelelő eszközillesztőt kell telepíteni.

xs

Paraméterek

A parancsnak nincsenek paraméterei.

A bővített memóriát kezelő többi Debug paranccsal kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson az XA (bővített memória lefoglalása), XD (bővített memória felszabadítása) vagy XM (bővített memória lapjainak leképezése) című témakörre.


Példa a Debug: XS parancs használatára

Debug: XS

Példa

A bővített memória adatainak megjelenítéséhez írja be a következő parancsot:

xs

A Debug segédprogram a következőhöz hasonló adatokat jelenít meg:

A(z) 0000 leírónak 0000 lefoglalt lapja van
    A(z) 0001 leírónak 0002 lefoglalt lapja van

    Fizikai lap 00 = Keretszegmens C000
    Fizikai lap 01 = Keretszegmens C400
    Fizikai lap 02 = Keretszegmens C800
    Fizikai lap 03 = Keretszegmens CC00
       80 EMS lapból összesen 2 foglalt
       FF EMS leíróból 2 foglalt


Megjegyzés a Debug: XS parancshoz

Debug: XS

Megjegyzés

A Debug segédprogram az adatokat az alábbi formátumban jeleníti meg:

A(z) xx leírónak xx lefoglalt lapja van
Fizikai lap xx = Keretszegmens xx
xx EMS lapból xx foglalt
xx EMS leíróból xx foglalt


Del (törlés)

Törli a megadott fájlokat.

del [meghajtó:][elérési_útvonal] fájlnév [ ...] [/p] [/f] [/s] [/q] [/a[:attribútumok]]

erase [meghatjó:][elérési_útvonal] fájlnév [ ...] [/p] [/f] [/s] [/q] [/a[:attribútumok]]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

A törölni kívánt fájl vagy fájlkészlet helyét és nevét határozza meg. Több fájlnév is megadható. A fájlnevek vesszővel, szóközzel vagy pontosvesszővel választhatók el egymástól.

/p

A megadott fájl(ok) törlését jóvá kell hagynia a felhasználónak.

/f

Törli az írásvédett fájlokat is.

/s

Törli a megadott fájlokat az aktuális könyvtárból és annak minden alkönyvtárából. Megjeleníti az éppen törölt fájl nevét.

/q

Csendes üzemmód. A parancs nem kéri a fájlok törlésének jóváhagyását.

/a

Törli a megadott attribútummal rendelkező fájlokat.

attribútumok

A következő fájlattribútumok használhatók:

Attribútum | Leírás
r | Írásvédett
a | Archiválandó
s | Rendszer
h | Rejtett
- | Az “ellentétre” vonatkozó előtag

Megjegyzés

  • A parancskiterjesztések letiltása esetén (a Windows 2000 rendszerben a parancskiterjesztések alapértelmezésben engedélyezve vannak) az /s kapcsoló jelentése fordítottá válik. Az éppen törölt fájl nevének megjelenítése helyett a nem található fájlok nevét jeleníti meg.


Példák a Del parancs használatára

Del

Példák

A C meghajtó Teszt mappájában található összes fájl az alábbi parancsok bármelyikével törölhető:

del c:\teszt

del c:\teszt\*.*


Megjegyzések a Del parancshoz

Del

Megjegyzések

A /p kapcsoló használata

A /p kapcsoló használatakor a del parancs megjeleníti a fájl nevét, és a következő üzenetet:

fájlnév, Törli (I/N)?

A törlés jóváhagyásához nyomja meg az I billentyűt, a törlés leállításához és a következő fájl megjelenítéséhez (több fájl megadásakor) nyomja meg az N billentyűt. A del parancs futásának leállításához nyomja meg a CTRL+C billentyűkombinációt.

Több fájl egyidejű törlése

A mappában található összes fájl törléséhez írja be a del parancsot a mappa útvonalával: [meghajtó:]elérési_útvonal. Például:

del \munka

Ez a parancs törli az összes fájlt a \Munka mappában.

Több fájl törléséhez helyettesítő karakterek (* és ?) is használhatók. A helyettesítő karakterek használata esetén azonban vigyázni kell a del parancs kiadásakor, mivel könnyen törölhetők olyan fájlok is, amelyeket nem kíván törölni. A következő parancs beírása esetén:

del *.*

a del parancs a következő kérdést jeleníti meg:

A könyvtárban levő összes fájlt törli! Biztos benne (I/N)?

Az aktuális könyvtárban található összes fájl törléséhez nyomja meg az I billentyűt, a törlés megszakításához nyomja meg az N, majd az ENTER billentyűt.

A del parancs helyettesítő karakterekkel történő használata előtt adja ki a dir parancsot ugyanazokkal a helyettesítő karakterekkel a parancs által törölt fájlok megjelenítése érdekében.

Figyelmeztetés

  • Előfordulhat, hogy törlés után a fájl nem állítható vissza.

A parancskiterjesztések engedélyezése esetén az /s kapcsoló kimenetként megjeleníti a törölt fájlokat. Ellenkező esetben a nem található fájlok nevét jeleníti meg.


Device

Betölti a megadott eszközillesztőt a memóriába.

A rendszergyökér\System32\Config.nt fájlban vagy egy program PIF fájljában megadható indítófájlban határozhatók meg az MS-DOS alrendszerbe betölteni kívánt eszközillesztők.

device=[meghajtó:][elérési_útvonal] fájlnév [dd-paraméterek]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

A betölteni kívánt eszközillesztő elérési helyét és nevét adja meg.

[dd-paraméterek]

Az eszközillesztő számára szükséges parancssori adatokat adja meg.

További tudnivalókért a Kapcsolódó témakörök között kattintson a Devicehigh című témakörre.


Példa a Device parancs használatára

Device

Példa

Az MS-DOS alrendszer képernyőjének és billentyűzetének ANSI átváltási sorozattal történő vezérléséhez vegye fel a következő parancsokat a Config.nt fájlba, vagy annak megfelelő indítófájlba:

device=c:\winnt\system32\ansi.sys


Devicehigh

Eszközillesztőket tölt be a felső memóriaterületre. Így megnöveli a más programok által használható alapmemória méretét. A rendszergyökér\System32\Config.nt fájlban vagy egy program PIF fájljában megadható indítófájlban határozhatók meg az MS-DOS alrendszerbe betölteni kívánt eszközillesztők.

devicehigh=[meghajtó:][elérési_útvonal] fájlnév [dd-paraméterek]

A devicehigh parancs által az eszközillesztő a felső memóriaterületre történő töltéséhez szükséges minimális memóriaméret a következő szintaxissal határozható meg:

devicehigh size=hexméret [meghajtó:][elérési_útvonal] fájlnév [dd-paraméterek]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

Megadja a felső memóriaterületre betölteni kívánt eszközillesztő elérési útvonalát és nevét.

dd-paraméterek

Az eszközillesztő számára szükséges parancssori adatokat adja meg.

hexméret

Megadja a devicehigh parancs által az eszközillesztő a felső memóriaterületre történő töltéséhez szükséges minimális memóriaméretet (a bájtok száma hexadecimális formátumban). A méret és a hexméret paramétert a második szintaxissorban bemutatott módon kell használni.

További tudnivalókért a Kapcsolódó témakörök között kattintson a Loadhigh vagy a Device című témakörre.


Példa a Devicehigh parancs használatára

Devicehigh

Példa

Ha a Config.nt fájlba vagy a megfelelő indítófájlba felveszi a következő parancsokat, az MS-DOS alrendszer megpróbálja az Illeszto.sys nevű eszközillesztőt a felső memóriaterületre betölteni:

device=c:\winnt\system32\himem.sys
dos=umb
devicehigh=illeszto.sys


Megjegyzések a Devicehigh parancshoz

Devicehigh

Megjegyzések

A dos=umb parancs használata

A devicehigh parancs használatához a Config.nt fájlba, vagy az annak megfelelő indítófájlba fel kell venni a dos=umb parancsot. Ha ez a parancs nincs megadva, minden eszközillesztőt az alapmemóriába tölt be a rendszer, mint a device parancs használata esetén. Az umb kapcsolóval kapcsolatos további tudnivalókért a Kapcsolódó témakörökben kattintson a dos című témakörre.

A Himem.sys telepítése

Az eszközillesztő a felső memóriaterületre történő betöltése előtt a device parancs segítségével telepíteni kell a Himem.sys eszközillesztőt. Ezt a parancsot a Config.nt fájlban, vagy az annak megfelelő indítófájlban a devicehigh parancsok előtt kell szerepeltetni.

Méretkorlát megadása

Ha a devicehigh parancsban megadott eszközillesztő a felső memóriaterület blokkjában felhasználható pufferterületnél többet próbál lefoglalni, a rendszer lefagyhat. A hexméret paraméter használatával elkerülhető ez a probléma. A hexméret paraméter jelzi, hogy az eszközillesztő számára mennyi memória szükséges (hexadecimális formátumban). Adott eszközillesztő esetén ez az érték a mem /debug parancs segítségével határozható meg. Ez a módszer általában hatásos, de nem minden esetben.

Ha nem használható felső memóriaterület

Ha nincs elegendő szabad felső memóriaterület a devicehigh parancsban megadott eszközillesztő betöltéséhez, az MS-DOS alrendszer az alapmemóriába tölti az eszközillesztőt (ahogy a device parancs használata esetén).


Devinfo

Előkészíti az eszközt kódlap használatához. Ha használni kívánja a parancsot, helyezze el az OS/2 C:\Config.sys fájlban.

devinfo=eszözktípus,altípus,[meghajtó:][elérési_útvonal]fájlnév [,ROM=[[(]xxx[,yyy)]][,...]]

Paraméterek

eszköztípus

Meghatározza az eszköz típusát: billentyűzet, monitor vagy párhuzamos nyomtató. A lehetséges értékek megtekintéséhez a Kapcsolódó témakörök között kattintson a Megjegyzések a Devinfo parancshoz című témakörre.

altípus

Megadja az eszköz stílusát vagy modelljét. Billentyűzet esetén ez a paraméter a billentyűzetkiosztást határozza meg. A lehetséges értékek megtekintéséhez a Kapcsolódó témakörök között kattintson a Megjegyzések a Devinfo parancshoz című témakörre.

meghajtó:elérési_útvonalfájlnév

Megadja az adott eszköz számára a kódlap adatait tartalmazó fájl elérési útvonalát. A lehetséges értékek megtekintéséhez a Kapcsolódó témakörök között kattintson a Megjegyzések a Devinfo parancshoz című témakörre.

ROM=

Ezt a paramétert nem használja az OS/2 alrendszer. Csak az MS OS/2 1.3-as vagy annál régebbi verzióiból származó fájlokkal való kompatibilitás miatt fogadja el a rendszer.

xxx

Ezt a paramétert nem használja az OS/2 alrendszer. Csak az MS OS/2 1.3-as vagy annál régebbi verzióiból származó fájlokkal való kompatibilitás miatt fogadja el a rendszer.

yyy

Ezt a paramétert nem használja az OS/2 alrendszer. Csak az MS OS/2 1.3-as vagy annál régebbi verzióiból származó fájlokkal való kompatibilitás miatt fogadja el a rendszer.


Példák a Devinfo parancs használatára

Devinfo

Példák

A billentyűzet felkészítéséhez a codepage paranccsal megadott kódlap használatára, a magyar billentyűzet kiosztás használatához és a kódlap adatait tartalmazó fájl helyének megadásához (OS/2 könyvtár a C: meghajtón) vegye fel a következő parancsot a C:\Config.sys fájlba:

devinfo=kbd,hu,c:\os2\keyboard.dcp


Megjegyzések a Devinfo parancshoz

Devinfo

Megjegyzések

A kódlap váltása akkor lehetséges, ha a rendszerhez csatlakoztatott minden eszközhöz, beleértve a billentyűzetet és a monitort is, külön devinfo parancs tartozik az OS/2 C:\Config.sys fájlban. A devinfo parancs megadja a rendszerhez kapcsolt eszköz fajtáját, és az eszközhöz tartozó kódlap vagy billentyűzet adatainak elérési útvonalát.

A következő listában az eszköztípus, altípus és fájlnév paraméterek lehetséges értékei láthatók:

Paraméter | Billentyűzet | Monitor
eszköztípus | KBD | SCR
altípus | billentyűzet kód | EGA, VGA
fájlnév | Keyboard.dcp | Viotbl.dcp

A billentyűzetkód azonosít egy adott országhoz vagy területhez tartozó billentyűzetkiosztást. Ha az adott ország vagy terület több kibővített billentyűzettel is rendelkezik, adja meg az alkódot, de ne tegyen szóközt a kétbetűs kód és az alkód közé. Például a francia 120-as kibővített billentyűzet megadásához használja az FR120 billentyűzetkódot.


Dir

Megjeleníti a könyvtárban található fájlok és alkönyvtárak listáját.

dir [meghajtó:][elérési_útvonal][fájlnév] [...] [/p] [/w] [/d] [/a[[:]attribútumok]][/o[[:]rendezési_sorrend]] [/t[[:]időmező]] [/s] [/b] [/l] [/n] [/x] [/c]

Paraméterek

nincs

Ha kapcsolók és paraméterek nélkül használja a dir parancsot, először a lemez kötetcímkéje és sorozatszáma jelenik meg, amit a lemezen található könyvtárak és fájlok listája követ (a nevek mellett a módosítás dátuma és időpontja is megjelenik). A fájlok esetében a dir parancs a név kiterjesztését és a fájlok bájtban számított méretét is megjeleníti. A fentiek mellett a dir parancs a megjelenített fájlok és könyvtárak számát, az együttes méretüket és a rendelkezésre álló szabad lemezterületet is kiírja.

[[meghajtó:][elérési_útvonal]

Megadja a megjeleníteni kívánt könyvtárat és elérési útvonalat.

[fájlnév]

Megadja a megjeleníteni kívánt fájlt vagy fájlcsoportot. Több fájlnév is megadható. A fájlnevek vesszővel, szóközzel vagy pontosvesszővel választhatók el egymástól. Helyettesítő karakterek (? és *) is használhatók a fájlnév paraméterben, ha fájlcsoportot szeretne megjeleníteni.

/p

Egyszerre a listának csak egy oldalát jeleníti meg. A következő oldal megjelenítéséhez nyomjon meg egy billentyűt.

/w

A lista széles formátumban jelenik meg, így minden sorban öt fájl vagy könyvtár neve látható.

/d

Megegyezik a /w kapcsolóval, de a fájlokat oszlop szerint rendezi.

/a[[:] attribútumok]

Csak azoknak a könyvtáraknak és fájloknak a neve jelenik meg, amelyeknek az attribútumai megegyeznek a megadott értékekkel. A kapcsoló kihagyása esetén a dir parancs a rejtett és rendszerfájlok kivételével az összes fájlt megjeleníti. Ha ezt a kapcsolót attribútumok megadása nélkül használja, a dir parancs az összes fájl nevét megjeleníti, beleértve a rejtett és rendszerfájlokat is. Az alábbi lista az attribútumok lehetséges értékeit tartalmazza. A kettőspont (:) használata nem kötelező. Az értékek együtt is használhatók, de ilyenkor ne válassza el szóközzel az attribútumokat.

/o [[:]rendezési_sorrend]

Érték | Leírás
h | Rejtett fájlok
s | Rendszerfájlok
d | Könyvtárak
a | Archiválandó fájlok (biztonsági mentés)
r | Írásvédett fájlok
-h | Nem rejtett fájlok
-s | Nem rendszerfájlok
-d | Csak fájlok (alkönyvtárak nem)
-a | Azok a fájlok, amelyek a legutóbbi biztonsági mentés óta nem változtak
-r | Nem írásvédett fájlok

Meghatározza, hogy a dir parancs milyen sorrendben rendezze és jelenítse meg a könyvtárneveket és fájlneveket. A kapcsoló kihagyása esetén a dir parancs abban a sorrendben jeleníti meg a neveket, ahogy a könyvtárban előfordulnak. Ha ezt a kapcsolót rendezési_sorrend megadása nélkül adja meg, a dir parancs először a könyvtárneveket, majd a fájlneveket jeleníti meg ábécésorrendben. A kettőspont (:) nem kötelező. Az alábbi lista a rendezési_sorrend lehetséges értékeit tartalmazza. Az értékek együtt is használhatók, de ilyenkor azokat ne válassza el szóköz karakterrel.

/t[[:]időmező]

Érték | Leírás
n | Nevek ábécésorrendben
e | Kiterjesztés szerint ábécésorrendben
d | Dátum és idő szerint, a korábbiak szerepelnek elöl
s | Méret szerint, a kisebbek kerülnek előre
g | A könyvtárak a fájlok előtt jelennek meg
-n | Név szerinti csökkenő ábécésorrendben (Z-től A-ig)
-e | Kiterjesztés szerinti csökkenő ábécésorrendben (.ZZZ-től .AAA-ig)
-d | Dátum és idő szerint, a későbbiek kerülnek előrébb
-s | Méret szerint, a nagyobbak kerülnek előrébb
-g | A könyvtárak a fájlok után jelennek meg

Az alábbi lista az időmező lehetséges értékeit tartalmazza. Meghatározza, hogy melyik időmező jelenjen meg, vagy képezze a rendezés alapját.

Érték | Leírás
c | Létrehozás
a | Legutolsó elérés
w | Legutolsó írás
/s | Megjeleníti a megadott fájlnév az adott könyvtárban és annak összes alkönyvtárában található összes előfordulását.
/b | Megjeleníti az összes könyvtár és fájl nevét, soronként egyet (a fájlnév kiterjesztése is megjelenik). E kapcsoló használatakor a parancs nem jeleníti meg a fejlécet és az összesítést. A /b kapcsoló felülírja a /w kapcsoló beállítását.
/l | A könyvtárak és fájlok nevét kisbetűsen, rendezés nélkül jeleníti meg. A kapcsoló nem alakítja át a kiterjesztett karaktereket kisbetűre.
/n | Hosszú lista formátumban jeleníti meg a listát, a fájlneveket jobb oldalra igazítja.
/x | Megjeleníti az NTFS- és FAT-köteteken tárolt fájlok rövid nevét. Ez ugyanolyan megjelenítést biztosít, mint az /n kapcsoló, de a hosszú név mellett a rövid név is látható.
/c | A fájlméret kijelzésekor megjeleníti az ezres elválasztót.

További tudnivalókért a Kapcsolódó témakörök között kattintson a Tree című témakörre.


Példák a Dir parancs használatára

Dir

Példák

Tegyük fel, hogy a dir paranccsal egymás után kívánja megjeleníteni az aktuális meghajtón található összes könyvtárat, egyik könyvtár tartalmát a másik után. Továbbá tegyük fel, hogy a dir paranccsal ábécésorrendben és széles formátumban kívánja megjeleníteni mindegyik könyvtár tartalmát képernyőnként.

Ehhez lépjen a gyökérkönyvtárba, és írja be a következő parancsot:

dir /s/w/o/p

A dir parancs megjeleníti a gyökérkönyvtár nevét, a gyökérkönyvtár alkönyvtárainak nevét és a gyökérkönyvtárban található fájlok nevét (kiterjesztéssel együtt). Ezután a dir parancs megjeleníti a fában található összes alkönyvtár és fájl nevét.

Ha az előző példát úgy szeretné módosítani, hogy a dir parancs megjelenítse a fájlok nevét és kiterjesztését, de a könyvtárak neve ne jelenjen meg, akkor az alábbi parancsot írja be:

dir /s/w/o/p/a:-d

A könyvtárlista kinyomtatásához az alábbi példában látható módon bármely dir parancs után írja be az átirányító szimbólumot és a PRN karaktersort:

ir > prn

A dir parancssorban a PRN megadása esetén a könyvtárlistát az LPT1 portra csatlakoztatott nyomtatóra küldi a rendszer. Ha a nyomtató másik portra kapcsolódik, a PRN helyett adja meg a megfelelő port nevét.

Ha a dir parancs kimenetét fájlba kívánja átirányítani, akkor a PRN helyett a fájl nevét adja meg. Elérési útvonal is megadható a parancssorban. A dir parancs kimenete a következő paranccsal irányítható át a Felvetel könyvtárban található Konyv.doc fájlba:

dir > \felvetel\konyv.doc

Ha a Konyv.doc fájl nem létezik, a Windows 2000 létrehozza (ha a Felvetel könyvtár létezik). Ha a Felvetel könyvtár nem létezik, a Windows 2000 az alábbi üzenetet jeleníti meg:

Fájllétrehozási hiba

A C meghajtón található összes .txt kiterjesztésű fájl a következő paranccsal jeleníthető meg:

dir c:\*.txt /w/o/s/p

A dir parancs széles formátumban, ábécésorrendben jeleníti meg az összes könyvtárban a feltételnek megfelelő fájlneveket, és minden alkalommal, ha megtelik a képernyő, vár egy billentyűleütésre.


Dir parancshoz

Dir

Megjegyzések

Helyettesítő karakterek használata a dir parancsban

A fájlok és alkönyvtárak adott csoportjának megjelenítéséhez használhatók a helyettesítő karakterek (? és *). A Kapcsolódó témakörök között a helyettesítő karakterek használatát bemutató példa található.

Fájlmegjelenítési attribútumok magadása

Ha az /a kapcsolót több attribútummal adja meg, a dir parancs csak azokat a fájlokat jeleníti meg, amelyek az összes megadott attribútummal rendelkeznek. Például ha az /a kapcsolót az r és a -h értékkel adja meg az /a:r-h vagy az /ar-h formában, akkor a dir parancs csak az írásvédett, nem rejtett fájlok nevét jeleníti meg.

A fájlnevek rendezésének megadása

A rendezési_sorrend több értékének megadásakor a dir parancs először az első megadott érték szerint rendez, aztán a második szerint stb. Például ha az /o kapcsolót az e és az -s rendezési_sorrend értékkel adja meg az /o:e-s vagy az /oe-s beírásával, a dir parancs a fájlok és könyvtárak nevét kiterjesztésük szerint rendezi, méret szerint csökkenő sorrendben. A kiterjesztések alapján történő ábécé szerinti rendezés miatt először a kiterjesztés nélküli fájlok jelennek meg, majd a könyvtárak, végül a kiterjesztéssel rendelkező fájlnevek.

Átirányító szimbólumok és csövek használata

Ha átirányító szimbólummal (>) a dir parancs kimenetét fájlba irányítja át, vagy egy csővel (|) a dir parancs kimenetét másik parancsnak küldi, akkor csak a fájlnevek megjelenítéséhez használja az /a:-d és a /b kapcsolót. A /b és /s kapcsoló a fájlnév paraméterrel együtt történő használata esetén megadható, hogy a dir parancs az aktuális könyvtárban és az összes alkönyvtárában keresse meg az összes olyan fájlt, melynek neve megegyezik a fájlnév értékével. A dir parancs ilyenkor minden egyező értékre csak a meghajtó betűjelét, a könyvtár nevét, a fájl nevét és kiterjesztését jeleníti meg, soronként egy előfordulást kiírva.

Csövek használata előtt az Autoexec.nt fájlban be kell állítani a TEMP környezeti változó értékét.

A dir parancs paramétereinek és kapcsolóinak előzetes beállítása

Előre megadhatók a dir parancs paraméterei és kapcsolói, ha az Autoexec.nt fájlban felveszi a set parancsot a DIRCMD környezeti változóval. A dir parancs összes érvényes paramétere és kapcsolója használható a set dircmd parancsban, beleértve a helyeket és fájlneveket is.

Például a DIRCMD környezeti változó segítségével alapértelmezésként a széles megjelenítési formátum (/w) beállításához írja be az alábbi sort az Autoexec.nt fájlba:

set dircmd=/w

A dir parancs használatakor a DIRCMD környezeti változóval beállított értékek felülbírálhatók. Ehhez az alábbi példában bemutatott módon mínusz jellel kell szerepeltetni a dir parancs sorában az adott kapcsolót:

dir /-w

A DIRCMD alapértelmezett beállításai a parancssorban kiadott set paranccsal módosíthatók. Az egyenlőség jel (=) után adja meg az új értékeket. Az új alapértelmezett értékek a dir parancs összes ezt követő futtatása során érvényesek egészen addig, amíg újból ki nem adja a set dircmd parancsot, vagy újra nem indítja a Windows 2000 rendszert.

Az összes alapértelmezett érték a következő paranccsal törölhető:

set dircmd=

A DIRCMD környezeti változó aktuális értékei a következő paranccsal jeleníthetők meg:

set

A Windows 2000 megjeleníti az összes környezeti változót, és azok értékét. A környezeti változók beállításával kapcsolatos további tudnivalókért tanulmányozza a set parancs leírását.


Diskcomp

Összehasonlítja két hajlékonylemez taralmát.

diskcomp [meghajtó1: [meghajtó2:]]

Paraméterek

meghajtó1

Megadja az egyik hajlékonylemezt tartalmazó meghajtót.

meghajtó2

Megadja a másik hajlékonylemezt tartalmazó meghajtót.

További tudnivalókért a Kapcsolódó témakörök között kattintson a Comp vagy az Fc című témakörre.


Példák a Diskcomp parancs használatára.

Diskcomp

Példák

Ha a rendszer csak egy hajlékonylemezes meghajtó tartalmaz (az A meghajtót), akkor két hajlékonylemez tartalma következő paranccsal hasonlítható össze:

diskcomp a: a:

A diskcomp parancs a megfelelő időpontban kéri a lemezek behelyezését.

Az alábbi példa egy kötegprogram, amely az if parancs és az errorlevel paraméter segítségével feldolgozza a diskcomp parancs kimenetét:

rem az Ellenőrzés.bat fájl összehasonlítja az A és a B meghajtóban található hajlékonylemezeket
echo off
diskcomp a: b:
if errorlevel 4 goto ini_error
if errorlevel 3 goto hard_error
if errorlevel 1 goto no_compare
if errorlevel 0 goto compare_ok
:ini_error
echo ERROR: Nincs elég memória vagy érvénytelen parancs
goto exit
:hard_error
echo ERROR: Helyrehozhatatlan hiba történt
goto exit
:break
echo "A CTRL+C billentyűkombináció lenyomásával" megállította az összehasonlítást
goto exit
:no_compare
echo A lemezek nem egyeznek
goto exit
:compare_ok
echo Az összehasonlítás sikeres, a lemezek megegyeznek
goto exit
:exit


Megjegyzések a Diskcomp parancshoz

Diskcomp

Megjegyzések

A diskcomp paranccsal nem használható meghajtók

A diskcomp parancs csak hajlékonylemezes meghajtókkal működik. A diskcomp parancs nem használható merevlemezekkel. A meghajtó1 vagy a meghajtó2 értékeként merevlemez megadásakor a diskcomp parancs a következő hibaüzenetet jeleníti meg:

Érvénytelen meghajtó
A megadott meghajtó nem létezik,
vagy nem cserélhető.

A diskcomp parancs üzenetei

Ha a két lemezen található összes sáv megegyezik, a diskcomp parancs a következő üzenetet jeleníti meg:

A két lemez egyforma.

Ha a sávok nem egyeznek meg, a diskcomp az alábbihoz hasonló üzenetet jelenít meg:

Összehasonlítási hiba:
oldal: 1, sáv: 2

Amikor a diskcomp parancs befejezi az összehasonlítást, az alábbi üzenet jelenik meg:

Folytatja az összehasonlítást másik lemezzel (I/N)?

Az I billentyű lenyomása esetén a diskcomp parancs kéri az összehasonlítani kívánt lemezek behelyezését. Ha az N billentyűt választja, a diskcomp parancs megállítja az összehasonlítást.

A lemezek összehasonlításakor a diskcomp parancs nem figyeli a lemezek kötetszámát.

A meghajtóparaméterek kihagyása

A meghajtó2 paraméter kihagyása esetén a diskcomp parancs az aktuális meghajtót tekinti a meghajtó2 értékeként. Mindkét paraméter kihagyásakor a diskcomp parancs mindkét paraméterként az aktuális meghajtót használja. Ha az aktuális meghajtó megegyezik a meghajtó1 paraméterként megadott meghajtóval, a diskcomp parancs kéri a lemezek cseréjét.

Összehasonlítás egy meghajtó használatával

Ha ugyanazt a hajlékonylemezes meghajtót adja meg a meghajtó1 és a meghajtó2 paraméter értékének, a diskcomp parancs ugyanazt a meghajtót használja az összehasonlításhoz, és kéri a lemezek cseréjét. A rendelkezésre álló memóriától és a lemezek kapacitásától függően előfordulhat, hogy egynél többször kell a lemezeket cserélni.

Különböző típusú lemezek összehasonlítása

A diskcomp paranccsal nem hasonlítható össze egyoldalú lemez kétoldalú lemezzel, vagy nagy sűrűségű lemez dupla sűrűségű lemezzel. Ha a meghajtó1 meghajtóban és a meghajtó2 meghajtóban levő lemez típusa különbözik, a diskcomp parancs az alábbi üzenetet jeleníti meg:

A meghajtók vagy a lemezek nem kompatibilisek

A diskcomp parancs használata hálózati és átirányított meghajtókkal

A diskcomp parancs nem működik hálózati meghajtóval vagy a subst paranccsal létrehozott meghajtóval. Ha a diskcomp parancsot ilyen típusú meghajtóval próbálja meg használni, a diskcomp parancs az „Érvénytelen meghajtó” hibaüzenetet jeleníti meg.

Eredeti lemez összehasonlítása másolattal

Ha a diskcomp parancsot a copy paranccsal létrehozott lemezzel használja, a diskcomp parancs az alábbihoz hasonló üzenetet jeleníthet meg:

Összehasonlítási hiba:
oldal: 0, sáv: 0

Ilyen hiba akkor is előfordulhat, ha a lemezeken található fájlok megegyeznek. Bár a copy parancs duplikálja az adatokat, nem szükségszerűen ugyanarra a helyre másolja azokat a célként megadott meghajtón, mint ahol eredetileg voltak. A két lemezen található fájlok egyenként történő összehasonlításával kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson az Fc című témakörre.

A diskcomp parancs kilépési kódjai

Az alábbi lista az összes kilépési kódot és jelentésük rövid leírását tartalmazza:

Kilépési kód | Leírás
0 | A lemezek megegyeznek
1 | A lemezek különböznek
3 | Súlyos hiba történt
4 | Inicializálási hiba történt

Kötegprogramban az if parancs és az errorlevel paraméter segítségével feldolgozhatók a diskcomp parancs kilépési kódjai.


Diskcopy

Átmásolja a forrásként megadott meghajtóban található hajlékonylemez tartalmát a célként megadott meghajtóban található formázott vagy nem formázott lemezre.

diskcopy [meghajtó1: [meghajtó2:]] [/v]

Paraméterek

meghajtó1

A forráslemezt tartalmazó meghajtót adja meg.

meghajtó2

A céllemezt tartalmazó meghajtót adja meg.

/v

Ellenőrzi, hibamentesen zajlott-e le az adatok másolása. Ennek a kapcsolónak a használata lelassítja a másolási folyamatot.

A fájlok másolásával kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a copy című témakörre.

A könyvtárak és alkönyvtárak másolásával kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson az xcopy című témakörre.


Példa a Diskcopy parancs használatára

Diskcopy

Példa

A B meghajtóban található lemez a következő paranccsal másolható át az A meghajtóban található lemezre:

diskcopy b: a:


Megjegyzések a Discopy parancshoz

Diskcopy

Megjegyzések

A diskcopy paranccsal nem használható meghajtók

A diskcopy parancs csak cserélhető lemezekkel, például hajlékonylemezzel használható. A diskcopy parancs nem használható merevlemezekkel. A meghajtó1 vagy a meghajtó2 értékeként merevlemez-meghajtó megadásakor a diskcopy parancs a következő hibaüzenetet jeleníti meg:

Érvénytelen meghajtó
A megadott meghajtó nem létezik,
vagy nem cserélhető.

Diskcopy üzenetek

A diskcopy parancs kéri a forráslemez és a céllemez behelyezését, és a művelet egy billentyű leütésével folytatható.

A másolás után a diskcopy parancs a következő üzenetet jeleníti meg:

Kíván másik lemezt másolni (I/N)?

Az I billentyű lenyomása esetén a diskcopy parancs kéri a következő művelethez használni kívánt forráslemez és céllemez behelyezését. A diskcopy folyamat megállításához nyomja meg az N billentyűt.

Ha a meghajtó2 nem formázott lemezt tartalmaz, a diskcopy parancs a lemezt ugyanannyi oldalra és ugyanolyan sűrűségűre formázza, mint a meghajtó1 meghajtóban levő forráslemez. A Diskcopy parancs formázás és másolás közben az alábbi üzenetet jeleníti meg:

Formázás másolás közben

A lemezek sorozatszáma

Ha a forráslemeznek van kötetsorozatszáma, a diskcopy létrehoz egy új kötetsorozatszámot a forráslemez számára, és megjeleníti azt a másolási folyamat végén.

A meghajtóparaméterek kihagyása

A meghajtó2 paraméter kihagyása esetén a diskcopy parancs az aktuális meghajtót tekinti a célmeghajtónak. Mindkét paraméter kihagyása esetén a diskcopy parancs mindkét meghajtóként az aktuális meghajtót használja. Ha az aktuális meghajtó megegyezik a meghajtó1 paraméterként megadott meghajtóval, a diskcopy parancs kéri a lemezek cseréjét.

Egy meghajtó használata a másoláshoz

Ha a meghajtó1 és a meghajtó2 megegyezik, a diskcopy parancs kéri a lemezek cseréjét. Mindkét meghajtó paraméter kihagyása esetén ha az aktuális meghajtó hajlékonylemezes meghajtó, akkor a diskcopy parancs minden egyes alkalommal kéri a lemezek meghajtóba helyezését. Ha a lemezek több adatot tartalmaznak mint amennyi a rendelkezésre álló memóriában eltárolható, a diskcopy parancs nem képes az összes adatot egyszerre átmásolni. A diskcopy parancs ilyenkor olvas a forráslemezről, ír a céllemezre, majd ismét olvas a forráslemezről. Ez a folyamat addig folyik, amíg az egész lemez másolása be nem fejeződik.

A lemeztöredezettség elkerülése

Mivel a diskcopy parancs pontosan másolja át a forráslemezt a céllemezre, a forráslemezen található minden töredezettség átkerül a céllemezre is. A töredezettség jelensége azt jelenti, hogy a létező fájlok között kis üres területek találhatók.

A töredezett forráslemez lassíthatja a fájlok megtalálását, olvasását vagy írását. Ha el szeretné kerülni a töredezettség átvitelét, a lemez másolásához használja a copy vagy az xcopy parancsot. Mivel a copy és az xcopy parancs a fájlokat egymás után másolja át, az új lemez nem lesz töredezett.

Figyelmeztetés

  • Az xcopy parancs nem használható indítólemez másolására.

A diskcopy parancs kilépési kódjai

Az alábbi lista tartalmazza a diskcopy parancs összes kilépési kódját (errorlevel), és azok leírását:

Kilépési kód | Leírás
0 | A másolási folyamat sikeres volt
1 | Nem kritikus írási/olvasási hiba történt
3 | Súlyos hiba történt
4 | Inicializálási hiba történt

Kötegfájlban az if parancs és az errorlevel paraméter segítségével feldolgozhatók a diskcopy parancs kilépési kódjai. A kilépési kódokat feldolgozó kötegfájlra a diskcomp parancsnál található példa.


Diskperf

Meghatározza a Rendszermonitor által megjeleníthető számlálótípusokat.

diskperf [-y[d|v]|-n[d|v] [\\számítógépnév]

Paraméterek

nincs

Ellenőrzi, hogy a lemezteljesítmény számlálói engedélyezve vannak-e a helyi vagy a megadott számítógépen, és azonosítja az engedélyezetett számlálókat: fizikai meghajtók, logikai meghajtók vagy mindkettő számára.

-y

Beállítja, hogy a rendszer újraindításakor a rendszer mind a fizikai, mind a logikai lemezekhez tartozó teljesítményszámlálókat elindítsa.

-yd

A rendszer újraindítása után lehetővé teszi a lemezteljesítmény számlálóinak használatát a fizikai meghajtókon. Ez az alapértelmezett beállítás.

-yv

A rendszer újraindítása után lehetővé teszi a lemezteljesítmény számlálóinak használatát a logikai meghajtókon.

-n

Beállítja, hogy a rendszer újraindítása után a rendszer ne használja a lemezteljesítmény számlálóit.

-nd

A rendszer újraindításánál kikapcsolja a fizikai lemezek teljesítményszámlálóit.

-nv

A rendszer újraindításánál kikapcsolja a logikai lemezek teljesítményszámlálóit.

számítógépnév

Megadja annak a számítógépnek a nevét, amelynek érvényes beállításait meg szeretné tekinteni, vagy be kívánja állítani. A számítógép nevének kihagyása esetén alapértelmezés szerint a helyi gépet veszi figyelembe a rendszer.


Példák a Diskperf parancs használatára

Diskperf

Példák

Ha a Termelés nevű számítógépen be szeretné állítani, hogy indításkor elinduljanak mind a fizikai, mind a logikai lemezekhez tartozó teljesítményszámlálók, adja ki a következő parancsot:

diskperf -y \\termelés

A helyi számítógépen a következő paranccsal indíthatók el a fizikai lemezekhez tartozó teljesítményszámlálók a rendszer indításakor:

diskperf -yd

A helyi gépen a következő paranccsal indíthatók el a logikai lemezekhez tartozó teljesítményszámlálók a rendszer indításákor:

diskperf -yv

Ha az szeretné beállítani, hogy a helyi számítógép újraindításakor a lemezteljesítmény számlálói ne induljanak el, akkor írja be az alábbi parancsot:

diskperf -n

Ha azt szeretné beállítani, hogy a Termelés nevű számítógép újraindításakor a lemezteljesítmény számlálói ne induljanak el, akkor írja be az alábbi parancsot:

diskperf -nd \\termelés

Ha újraindítás után nem kívánja elindítani a logikai lemezekhez tartozó teljesítményszámlálókat, írja be a következő parancsot:

diskperf -nv


Megjegyzések a Diskperf parancshoz

Diskperf

Megjegyzések

Alapértelmezés szerint a rendszer összegyűjti a fizikai lemezek adatait. A logikai meghajtók adatainak gyűjtése nem automatikus, így külön engedélyezni kell. Nem az alapértelmezett állapotba jut vissza, ha előbb az -n paraméterrel kikapcsolja a lemezteljesítmény számlálóit, majd az -y paraméterrel újból engedélyezi az összes teljesítményszámlálót. Az alapértelmezett állapot a következő paranccsal állítható vissza:

diskperf -yd


Dos

Megadja, hogy az MS-DOS alrendszer tartson-e kapcsolatot a felső memóriaterülettel (UMA), vagy egy részét a magas memóriaterületre (HMA) töltse-e be.

dos=high|low[,umb|,noumb]

dos=[high,|low,]umb|noumb

Paraméterek

high|low

Megadja, hogy az MS-DOS alrendszer megpróbálja-e egy részét a magas memóriaterületre betölteni. A high paraméter segítségével engedélyezhető az MS-DOS alrendszer betöltése a magas memóriaterületre. Az MS-DOS alrendszer a low paraméter használatával tartható a hagyományos memóriában. Az alapértelmezett beállítás: low.

umb|noumb

Megadja, hogy az MS-DOS alrendszer tartson-e kapcsolatot az alapmemória és a felső memóriaterület között. Az umb paraméter biztosítja ezt a kapcsolatot. A noumb paraméter megszünteti ezt a kapcsolatot. Az alapértelmezett beállítás: noumb.

További tunivalókért a Kapcsolódó témakörök között kattintson a Devicehigh vagy a Loadhigh című témakörre.


Megjegyzések a Dos parancshoz

Dos

Megjegyzések

A dos=umb és a dos=high parancs használatához telepíteni kell a Himem.sys eszközillesztőt.

A Himem.sys eszközillesztőt a dos=umb és a dos=high parancs használata előtt kell telepíteni.

Az umb paraméter használata

A programok és eszközillesztők csak a dos=umb parancs megadása esetén tölthetők be a felső memóriaterületre (UMA). A felső memóriaterület használata esetén több szabad hely marad az alapmemóriában. E parancs használatához a felső memóriablokk (UMB) szolgáltatóját is telepíteni kell.

A high paraméter használata

A high paraméter használata esetén az MS-DOS alrendszer egy részét a rendszer megpróbálja betölteni a magas memóriaterületre (HMA). Az MS-DOS egy részének a magas memóriaterületre való betöltésekor több, a programok által használható alapmemória marad szabadon.

A paraméterek kombinálása

Vesszővel elválasztva akár több paraméter is megadható a dos parancshoz. Például a következő parancssorok érvényesek:

dos=umb,low

dos=high,umb

A Config.nt fájlban, vagy az azzal egyenértékű indítófájlban bárhol elhelyezhető a dos parancs.


Az MS-DOS alrendszer parancsai

További tudnivalókért válassza ki a kívánt parancsot.

append | graphics
debug | loadfix
debug parancsok | loadhigh (lh)
edit | mem
edlin | nlsfunc
edlin parancsok | qbasic
exe2bin | setver
expand | share
fastopen |

A Windows 2000 az MS-DOS alrendszerhez és más alrendszerekhez 16 bites (nem natív) parancsokat tartalmaz. Ezek régebbi (például az edlin vagy a graphics parancs) és a speciális MS-DOS parancsok (például a debug vagy az exe2bin parancs). Ezek a 16 bites parancsok az MS-DOS rendszerrel és az MS OS/2 1. x verziójával való kompatibilitás megőrzése miatt kerültek az utasításkészletbe.

Az MS-DOS alrendszer többi parancsa (például a share parancs) olyan funkciókat képes végrehajtani, amelyek a Windows 2000 és az MS-DOS alrendszer beépített szolgáltatásai. A korábbi fájlokkal való kompatibilitás miatt a parancsokat elfogadja a rendszer, de a parancsoknak nincs hatásuk, mivel ezek a funkciók automatikusak a Windows 2000 operációs rendszerben.


Az MS-DOS konfigurációs parancsai

További tudnivalókért válassza ki a kívánt parancsot.

buffers | fcbs
country | files
device | install
devicehigh (dh) | lastdrive
dos | ntcmdprompt
dosonly | shell
driveparm | stacks
echoconfig | switches

Az MS-DOS alrendszer beállítása olyan konfigurációs parancsokkal történik, mint például a device és a lastdrive parancs. Ezeket a parancsokat a rendszergyökér\System32 alkönyvtárban található Config.nt fájlban, vagy az alkalmazás PIF fájljában megadott konfigurációs (Config) fájlban kell elhelyezni. Ezek a parancsok csak az MS-DOS alrendszerre vonatkoznak. Sok parancsot (például a buffers és a break parancs) figyelmen kívül hagy a rendszer, mert az MS-DOS alrendszer ezeket nem használja. Csak a kompatibilitás miatt fogadja el ezeket a rendszer.


Újdonságok és változások az MS-DOS parancsokban

A Windows 2000 rendszerben az MS-DOS szinte minden funkciója megtalálható. A következő táblázatokban láthatók az új Windows 2000 parancsok, amelyek nem találhatóak meg az MS-DOS rendszerben, a módosított MS-DOS parancsok és a megszűnt MS-DOS parancsok.

Windows 2000 parancsok

Ebben a táblázatban a Windows 2000 rendszernek azok a parancsai láthatók, amelyek nem találhatók meg az MS-DOS rendszerben.

Parancs | Funkció
at | Parancsok és programok futtatását időzíti adott számítógépen és időpontban.
cacls | Megjeleníti vagy módosítja a fájlok hozzáférés-szabályozási listáját (ACL).
convert | A FAT vagy FAT32 fájlrendszert NTFS fájlrendszerré konvertálja.
dosonly | Nem engedélyezi az MS-DOS alapú alkalmazásokon kívül más alkalmazások elindítását a Command.com parancssorban.
echoconfig | Üzeneteket jelenít meg az MS-DOS alrendszer Config.nt fájljának olvasásakor.
endlocal | Befejezi a környezeti változók honosítását.
findstr | Szabványos kifejezések használatával szöveget keres fájlokban.
ntcmdprompt | Memóriarezidens program futtatása vagy a parancssor MS-DOS alkalmazásból történő indítása után a Comamnd.com helyett a Windows 2000 Cmd.exe parancsértelmezőjét futtatja.
popd | A pushd paranccsal legutóbb megadott könyvtárra ugrik.
pushd | Elmenti az aktuális könyvtárat a popd parancs számára, és átvált a megadott könyvtárra.
setlocal | Elkezdi a környezeti változók honosítását.
start | A saját memóriaterületén futtat egy megadott programot vagy parancsot egy második ablakban.
Title | Megadja a parancssor ablakának címét.
&& | A szimbólum utáni parancs végrehajtása akkor kezdődik el, amikor a szimbólum előtt álló parancs végrehajtása sikeresen befejeződött.
|| | A szimbólum utáni parancs végrehajtása csak akkor kezdődik el, amikor a szimbólum előtti parancs végrehajtása sikertelen.
& | Elválasztja a parancssorban a parancsokat.
( ) | Csoportosítja a parancsokat.
^ | Escape karakter. Lehetővé teszi parancsjelek szövegként való beírását.
; vagy , | Elválasztja a paramétereket.

A módosított MS-DOS parancsok

Ebben a táblázatban a módosított és továbbfejlesztett MS-DOS parancsok láthatók.

Parancs | Módosított funkció
chcp | Csak teljes képernyős üzemmód esetén változtatja meg a kódlapot.
cmd | A Cmd.exe helyettesíti a Command.com programot.
del | Az új kapcsolók sok új funkciót biztosítanak.
dir | Az új kapcsolók sok új funkciót biztosítanak.
diskcomp | Az /1 és a /8 kapcsoló használatát nem támogatja.
diskcopy | Az /1 kapcsoló használatát nem támogatja.
doskey | Az összes pufferelt bemenetet elfogadó karakteres program számára elérhető. A doskey parancs sok fejlesztésen ment keresztül.
format | Támogatja a 20,8 MB-os optikai meghajtó használatát. A /b, az /s és az /u kapcsoló használatát nem támogatja.
label | A kötetcímkékben használható a ^ és az & jel.
mode | Jelentős változtatások.
more | Az új kapcsolók sok új funkciót biztosítanak.
path | A %PATH% környezeti változó hozzáfűzi az aktuális útvonalat egy új beállításhoz a parancssorban.
print | A /b, /c, /m, /p, /q, /s, /t és /u kapcsoló használatát nem támogatja.
prompt | Az új karakterkombinációk lehetővé teszik az és jel ($a), a zárójel ($c és $f) és a szóköz ($s) karakter használatát a parancssorban.
recover | Csak fájlokat állít helyre.
rmdir | Az új /s kapcsolóval a fájlokat és alkönyvtárakat tartalmazó könyvtárak is törölhetők.
sort | Nem szükséges a TEMP környezeti változó. A fájlméret nem korlátozott.
xcopy | Az új kapcsolók sok új funkciót biztosítanak.

Nem használható MS-DOS parancsok

A következő MS-DOS parancsok nem használhatók a parancssorban.

Parancs | Új eljárás, vagy az elavulás oka
assign | Használatát nem támogatja a Windows 2000 rendszer.
backup | Használata jelenleg nem támogatott.
choice | Használata jelenleg nem támogatott.
ctty | Használata jelenleg nem támogatott.
dblspace | Nem támogatott.
defrag | A Windows 2000 automatikusan optimalizálja a lemezhasználatot. A lemez kézi optimalizálásához a Sajátgép ablakban a jobb oldali egérgombbal kattintson a lemezre, kattintson a Tulajdonságok parancsra, majd az Eszközök lapon kattintson a Töredezettség megszüntetése gombra.
deltree | Az rmdir /s paranccsal törölhetők a fájlokat és alkönyvtárakat tartalmazó könyvtárak.
diskperf | Használata jelenleg nem támogatott.
dosshell | Nem szükséges a Windows 2000 rendszerben.
drvspace | A Drvspace segédprogram használata jelenleg nem támogatott.
emm386 | Nem szükséges a Windows 2000 rendszerben.
fasthelp | Ez az MS-DOS 6.0 parancs megegyezik a Windows 2000 help parancsával. A Windows 2000 rendszerben on-line parancsmutató is rendelkezésre áll.
fdisk | A Lemezkezelés beépülő modul felkészíti a merevlemezeket a Windows 2000 használatára.
include | Az MS-DOS alrendszer többféle konfigurációja nem támogatott.
interlnk | Az Interlnk program használata nem támogatott.
intersrv | Az Intersrv program használata nem támogatott.
join | A megnövelt partícióméret és a továbbfejlesztett fájlrendszer miatt feleslegessé vált a meghajtók egymáshoz csatolása.
memmaker | A Windows 2000 automatikusan optimalizálja az MS-DOS alrendszer memóriahasználatát.
menucolor | Az MS-DOS alrendszer többféle konfigurációja nem támogatott.
menudefault | Az MS-DOS alrendszer többféle konfigurációja nem támogatott.
menuitem | Az MS-DOS alrendszer többféle konfigurációja nem támogatott.
mirror | Használatát nem támogatja a Windows 2000 rendszer.
msav | Az Msav program használata nem támogatott.
msbackup | A Windows 2000 a szalagos egységgel rendelkező számítógépek számára biztosítja a Biztonsági mentés segédprogramot (a Vezérlőpult Felügyeleti eszközök ablakában), vagy az xcopy parancsot a szalagos egység nélküli számítógépek számára.
mscdex | A CD-ROM-meghajtó használatát nem szükséges konfigurálni az MS-DOS alrendszerben. A Windows 2000 biztosítja az MS-DOS alrendszer számára a CD-ROM elérését.
msd | Használja a Rendszerinformáció beépülő modult. A Rendszerinformáció beépülő modul elindításához kattintson a Start menü Futtatás parancsára, majd írja be az msinfo32 parancsot.
numlock | Használata jelenleg nem támogatott.
power | A Power segédprogram használata nem támogatott.
restore | Használata jelenleg nem támogatott.
scandisk | A Scandisk segédprogram használata nem támogatott.
smartdrv | A Windows 2000 automatikusan biztosítja a gyorsítótár használatát az MS-DOS alrendszerben.
submenu | Az MS-DOS alrendszer többféle konfigurációja nem támogatott.
sys | A Windows 2000 rendszer nem fér el egy hagyományos 1,2 MB-os vagy 1,44 MB-os hajlékonylemezen.
undelete | Használatát nem támogatja a Windows 2000 rendszer.
unformat | Használatát nem támogatja a Windows 2000 rendszer.
vsafe | A Vsafe program használata nem támogatott.


Doskey

Elindítja a Doskey programot, amely lehetővé teszi a Windows 2000 parancsok visszahívását, a parancssorok szerkesztését és makrók készítését.

doskey [/reinstall] [/listsize=méret] [/macros:[all | exe_név]] [/history] [/insert|/overstrike] [/exename=exe_név] [/macrofile=fájlnév] [makrónév=[szöveg]]

Paraméterek

/reinstall

Telepíti a Doskey új példányát. Törli az előző parancsokat tároló puffert.

/listsize=méret

Megadja az előzménypufferben tárolható parancsok maximális számát.

/macros

Megjeleníti a Doskey makrók listáját. Az átirányító jel (>) és a /macros kapcsolóval a lista fájlba irányítható. A /macros kapcsoló rövidíthető: /m.

all

Megjeleníti az összes végrehajtható fájlhoz tartozó Doskey makrókat.

exe_név

Megjeleníti a megadott fájlhoz tartozó Doskey makrókat.

/history

Megjeleníti a memóriában tárolt összes parancsot. Az átirányító jel (>) és a /history kapcsoló segítségével a lista fájlba irányítható. A /history kapcsoló rövidíthető: /h.

/insert | /overstrike

Megadja, hogy a begépelt új szöveg felülírja-e a régebbi szöveget. Az /insert kapcsoló használata esetén a rendszer beszúrja az új szöveget a régi szövegbe (mint az INSERT billentyű megnyomása esetén). Az /overstrike kapcsoló használata esetén az új szöveg felülírja a régi szöveget. Az alapértelmezett beállítás: /overstrike.

/exename=exe_név

Megadja, hogy a Doskey makró melyik (végrehajtható) programban fog futni.

/macrofile=fájlnév

Megadja a telepíteni kívánt makrókat tartalmazó fájlt.

makrónév=[szöveg]

Létrehoz egy makrót, amely a szöveg részben megadott parancsokat hajtja végre. A makrónév megadja a makróhoz hozzárendelni kívánt nevet. A szöveg megadja a rögzíteni kívánt parancsokat. A szöveg paraméter kihagyása esetén a makrónév névhez rendelt parancsokat törli a rendszer.


Példák a Doskey parancs használatára

Doskey

Példák

A /macros és a /history kapcsoló segítségével makrók és parancsok mentését végző parancsfájlok hozhatók létre. Például az összes aktuális Doskey makró a következő paranccsal menthető el:

doskey /macros > makinit

Ezután a Makinit fájlban tárolt makrók a következő paranccsal használhatók:

doskey /macrofile=makinit

A korábban használt parancsokat tartalmazó Tmp.bat nevű parancsfájl a következő paranccsal hozható létre:

doskey /history > tmp.bat

Több parancsot tartalmazó makró megadásához a $t karakterrel válassza el a parancsokat a következők szerint:

doskey tx=cd temp$tdir/w $*

A fenti példában a TX makró átváltja az aktuális könyvtárat a Temp könyvtárra, és széles megjelenítési formátumban a képernyőn megjeleníti a könyvtárak listáját. A makró végén a $* karakterek megadása esetén a TX makró futtatásakor a dir parancshoz további kapcsolók adhatók meg.

A következő makró egy kötegfájl paraméterét használja az új könyvtár neveként. A makró először létrehoz egy új könyvtárat, majd belelép.

doskey mc=md $1$tcd $1

Az előző makró a következő paranccsal hozhat létre és léphet be a Könyvek nevű könyvtárba:

mc könyvek

Adott programhoz (ebben az esetben az Ftp.exe programhoz) az /exename kapcsoló segítségével hozható létre Doskey makró.

doskey /exename:ftp.exe go=open 126.127.1.100$tmget *.TXT c:\reports$bye

A fenti makró használatához indítsa el ftp programot. Az ftp parancssorba írja be: go. Az Ftp segédprogram végrehajtja az open, mget és bye parancsot.


Megjegyzések a Doskey parancshoz

Doskey

Megjegyzések

A Doskey parancs használata

A Doskey parancs mindig elérhető az összes karakteres interaktív program számára (például a hibakereső programok vagy a fájlátviteli programok számára), és az összes program számára kezeli az előző parancsokat tároló puffert és a makrókat. Programból nem használhatók a doskey parancs kapcsolói. A doskey parancs kapcsolóit a program elindítása előtt kell megadni. A program billentyű-hozzárendelései felülírják a doskey parancs billentyű-hozzárendeléseit.

Parancs visszahívása

Parancs visszahívásához a Doskey parancs memóriába töltése után a következő billentyűk bármelyike használható. A Doskey parancs másik programon belüli használatakor a külső program billentyű-hozzárendelései elsőbbséget élveznek.

FEL nyíl | Visszahívja az éppen megjelenített parancs előtt használt parancsot.
LE nyíl | Visszahívja az éppen megjelenített parancs után használt parancsot.
PAGE UP | Visszahívja a jelenlegi munkamenetben először használt parancsot.
PAGE DOWN | Visszahívja a legutóbb használt parancsot.

A parancssor szerkesztése

A Doskey parancs segítségével szerkeszthető az aktuális parancssor. A Doskey parancs másik programon belüli használatakor a külső program billentyű-hozzárendelései elsőbbséget élveznek, és néhány Doskey szerkesztőbillentyű nem működik.

A következő listában láthatók a Doskey parancs szerkesztőbillentyűi, és azok funkciói:

BALRA nyíl | A beviteli pontot egy karakterrel balra mozgatja.
JOBBRA nyíl | A beviteli pontot egy karakterrel előre mozgatja.
CTRL+BALRA nyíl | A beviteli pontot egy szóval balra mozdítja.
CTRL+JOBBRA nyíl | A beviteli pontot egy szóval jobbra mozdítja.
HOME | A beviteli pontot a sor elejére viszi.
END | A beviteli pontot a sor végére viszi.
ESC | Törli a parancsot a képernyőről.
F1 | A sablon adott oszlopában levő karaktert átmásolja a Windows 2000 parancssor ugyanazon oszlopába. (A sablon az utolsó beírt parancsot tároló memóriapuffer.)
F2 | Előrefelé keresi a sablonban az F2 billentyű lenyomása után beírt karaktert. A Doskey parancs beszúrja a sablon megadott karakter elé eső részét.
F3 | A parancssorba másolja a sablon további részét. A Doskey parancs a sablon a parancssor beviteli pontjának megfelelő pozíciójától kezdve bemásolja a karaktereket a parancssorba.
F4 | Törli a beviteli pont és a megadott karakter közötti részt. A szerkesztőbillentyű használatához nyomja meg az F4 billentyűt, majd írjon be egy karaktert. A Doskey parancs törli a karaktereket a jelenlegi beviteli ponttól a megadott betűig.
F5 | Bemásolja a sablon tartalmát a parancssorba.
F6 | A jelenlegi beviteli ponton fájlvége (CTRL+Z) karaktert szúr be.
F7 | Előugró ablakban megjeleníti a memóriában tárolt, az adott programhoz tartozó összes parancsot. Az FEL és LE nyíl segítségével válassza ki a kívánt parancsot, és a parancs futtatásához nyomja meg az ENTER billentyűt. A parancs előtt álló szám és az F9 billentyű együttes lenyomásával is elindítható a parancs.
ALT+F7 | Az aktuális előzménypufferből törli az összes ott tárolt parancsot.
F8 | Megjeleníti az előzménypufferben tárolt összes, a jelenlegi parancs karaktereivel kezdődő parancsot.
F9 | Kéri az előzménypufferben tárolt parancs sorszámát, majd megjeleníti a számhoz társított parancsot. A parancs futtatásához nyomja meg az ENTER billentyűt. A számok és a hozzájuk társított parancsok megjelenítéséhez nyomja meg az F7 billentyűt.
ALT+F10 | Törli az összes makródefiníciót.

A Doskey parancs használata programon belül

Bizonyos karakteres interaktív programok (például a hibakereső programok vagy a fájlátviteli programok (FTP)) automatikusan használják a Doskey parancsot. A Doskey parancsot a kezelőpult folyamatként működő, és a pufferbemenetet használó programok használhatják. A program billentyű-hozzárendelései felülbírálják a Doskey parancs billentyű-hozzárendeléseit. Például ha a program az F7 billentyűt használja valamilyen funkció eléréséhez, akkor az előbukkanó ablakban nem jeleníthető meg a Doskey parancs előző parancsokat tároló listája.

A Doskey parancs minden elindított programban rögzíti a kiadott parancsokat, a program parancssorában lehetővé teszi a korábban kiadott parancsok megismétlését és szerkesztését, valamint lehetővé teszi a programhoz létrehozott Doskey makrók elindítását. Ha kilép a programból és ugyanazon parancssori ablakban újraindítja a programot, akkor elérhetők a korábbi munkamenetben használt parancsok.

A Doskey parancs kapcsolóit a program indítása előtt kell megadni. A Doskey parancs kapcsolói nem használhatók a program parancssorából. Akkor sem, ha a program rendelkezik rendszerhéj paranccsal.

A program gyakori használata esetén a Doskey programbeli működése testreszabható, Doskey makrók hozhatók létre a programhoz, valamint létrehozható egy parancsfájl, amely módosítja a Doskey parancsot és elindítja a programot.

Az alapértelmezett beszúrási üzemmód megadása

Az INSERT billentyű megnyomása esetén a Doskey parancssorba úgy írható új szöveg az ott lévő szövegbe, hogy nem törli a régi szöveget. Azonban az ENTER billentyű megnyomásakor a Doskey parancs visszatér a felülíró üzemmódba. A beszúró üzemmódhoz való visszatéréshez újra meg kell nyomni az INSERT billentyűt.

Az /insert kapcsoló az ENTER billentyű minden megnyomásakor beszúró üzemmódba állítja a billentyűzetet. A billentyűzet a Doskey parancs /overstrike kapcsolóval együtt történő kiadásáig beszúró üzemmódban marad. Az INSERT billentyű megnyomásával ideiglenesen áttérhet felülíró üzemmódra, de az ENTER billentyű megnyomása után a Doskey visszatér a beszúró üzemmódba.

A beviteli pont alakja megváltozik, amikor az INSERT billentyű megnyomásával üzemmódot vált.

Makró létrehozása

A Doskey paranccsal egy vagy több parancsot végrehajtó makrók hozhatók létre.

A makró létrehozásakor a parancsműveletek vezérlésére használható speciális karaktereket a következő táblázat mutatja:

$G vagy $g | Átirányítja a kimenetet. Ezeknek a speciális karaktereknek a használata esetén a kimenet a képernyő helyett fájlba vagy eszközre küldhető. Ez a karakter egyenértékű a kimenetre vonatkozó átirányító jellel (>).
$G$G vagy $g$g | Hozzáfűzi a kimenetet egy fájl végéhez. Ezeknek a dupla karaktereknek a használatával a kimenet hozzáfűzhető egy létező fájl végéhez, amely így nem törli a fájl tartalmát. Ezek a dupla karakterek egyenértékűek a kimenethez tartozó “hozzáfűzés” átirányító jellel (>>).
$L vagy $l | Átirányítja a bemenetet. Ezeknek a speciális karaktereknek a használatával a billentyűzet helyett valamilyen eszközről vagy fájlból olvashatók a bemeneti adatok. Ez a karakter egyenértékű a bemenethez tartozó átirányító jellel (<).
$B vagy $b | Makró kimenetet küld egy parancsnak. Ezeknek a speciális karaktereknek a használata egyenértékű a parancssorban a függőleges vonás (|) karakter használatával.
$T vagy $t | Elválasztja a parancsokat. Ezeknek a speciális karaktereknek a használatával makrók létrehozásakor vagy parancsok írásakor elválaszthatók egymástól parancsok a Doskey parancssorban. Ezeknek a speciális karaktereknek a használata egyenértékű a parancssorban az és jel (&) használatával.
$$ A dollár jelet ($) adja meg.
$1-től $9-ig | Bármilyen a makró futtatásakor használt parancssori adatot jelölhet. A $1 és $9 közötti speciális karakterek kötegfájl-paraméterek, amelyek más-más adatok használatát teszik lehetővé a makró minden futtatásakor. A doskey parancsban használt $1 karakter hasonló a parancsfájlban használatos %1 karakterhez.
$* Azt jelzi, hogy a parancssori adatokat a makrónév beírásakor kell megadni. A $* speciális karakter egy helyettesítő paraméter, amely hasonló a $1-$9 kötegfájlban használható paraméterekhez. Egy lényeges különbség van. Itt a makrónév után begépelt összes adat a $* karakterek helyére kerül.

Például olyan makró létrehozásához, amely gyors és feltétel nélküli lemezformázást hajt végre, írja be a következő parancsot:

doskey qf=format $1 /q /u

A gyors és feltétel nélküli formázással kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a format című témakörre.

Doskey makró futtatása

Makró futtatásához írja be a makró nevét a parancssor első pozíciójától kezdődően. Ha a makró a $* karakterekkel, vagy a $1-$9 kötegfájl-paraméterekkel volt megadva, szóközzel válassza el a paramétereket.

A fenti példában szereplő, az A meghajtóban levő lemezt gyorsan és feltétel nélkül megformázó QF makró a következő paranccsal futtatható. Az elindításhoz írja be a következő parancsot:

qf a:

Kötegfájlból nem indítható Doskey makró.

Windows 2000 paranccsal egyező nevű makró létrehozása

Windows 2000 paranccsal egyező nevű makró is létrehozható. Ez például akkor hasznos, ha egy adott parancsot mindig ugyanazokkal a kapcsolókkal használ. A következő irányelvek alapján dönthető el, hogy mikor kívánja futtatni a Windows 2000 parancsot, és mikor a makrót:

  • A makró futtatásához írja be a makró nevét rögtön a parancssor elejére (ne legyen szóköz a parancssor és a parancsnév között).
  • A parancs elindításához írjon néhány szóközt a parancssor elejére.

Makró törlése

Makró a következő paranccsal törölhető:

doskey makrónév=


Dosonly

A Command.com parancssorban az MS-DOS alapú alkalmazásokon kívül nem engedélyezi más alkalmazások elindítását.

dosonly

Kapcsolódó témakörök


Példák a Dosonly parancs használatára

Dosonly

Példák

Adja meg a dosonly parancsot a Config.nt fájlban, vagy a PIF fájlban megadott Config indítófájlban.

dosonly

Kapcsolódó témakörök


Megjegyzések a Dosonly parancshoz

Dosonly

Megjegyzések

Alaphelyzetben az MS-DOS alapú alkalmazás bezárásakor a Windows 2000 visszatér a Cmd.exe parancsértelmezőhöz. A bezárás után azonban memóriarezidens program (TSR) futtatásakor, vagy egy MS-DOS alapú alkalmazás ideiglenes felfüggesztésekor a parancssorhoz való visszatérés érdekében a Windows 2000 futtatja a Command.com programot, az MS-DOS környezet parancsértelmezőjét. Ez megőrzi az MS-DOS környezetet, így lehetővé teszi a memóriarezidens program azonnali használatát.

Mivel a Command.com parancssorból más alkalmazások futtatása megszakíthatja a memóriarezidens programot vagy a felfüggesztett MS-DOS alapú alkalmazást, a Windows 2000 lehetővé teszi a dosonly parancs használatát. A dosonly parancs csak az MS-DOS alapú alkalmazások elindítását engedélyezi a Command.com parancssorból. A dosonly parancs megadható a Config.nt fájlban, vagy az alkalmazás PIF fájljában a megfelelő testreszabott indítófájlban.


Driveparm

A Windows 2000 és az MS-DOS alrendszer nem hajt végre semmilyen műveletet ennek a parancsnak a hatására. Csak az MS-DOS fájlokkal fenntartott kompatibilitás miatt fogadja el.


Echo

Be vagy ki kapcsolja a parancsvisszhangot, vagy megjelenít egy üzenetet.

echo [on | off] [üzenet]

Paraméterek

on | off

Be- vagy kikapcsolja a parancsvisszhangot. A jelenlegi visszhangbeállítás megjelenítéséhez használja az echo parancsot paraméter nélkül.

üzenet

Megadja a Windows 2000 által a képernyőn megjeleníteni kívánt szöveget.

További tudnivalókért a Kapcsolódó témakörök között kattintson a Pause című témakörre.


Példák az Echo parancs használatára

Echo

Példák

A következő példa olyan parancsfájlt mutat be, amely egy három soros üzenetet jelenít meg, amit egy üres sor előz meg és követ:

echo off
echo.
echo Ez a kötegfájl
echo új lemezeket formáz
echo és ellenőriz
echo.

A visszhang kikapcsolásához és magának az echo parancs megjelenítésének elkerüléséhez az alábbi példában látható módon írjon be a parancs elé kukac jelet (@):

@echo off

Az if és az echo parancs használható ugyanabban a parancssorban:

if exist *.rpt echo A jelentés megérkezett.


Megjegyzések az Echo parancshoz

Echo

Megjegyzések

Üzenet megjelenítése az echo paranccsal

Az echo üzenet parancs a visszhang kikapcsolt állapotában hasznos. Ha többsoros üzenetet kíván megjeleníteni, viszont más parancsokat nem kíván megjeleníteni, akkor több echo üzenet parancs is megadható a parancsfájlban az echo off parancs után.

A parancssor elrejtése

Az echo off parancs kiadása után a parancssor nem jelenik meg a képernyőn. A parancssor megjelenítéséhez írja be az echo on parancsot.

A sorhoz tartozó visszhang megjelenítésének megakadályozása a Windows 2000 rendszerben

A kötegfájlban a parancs elé írt kukac jel (@) segítségével megakadályozható az adott sor megjelenítése.

Üres sor megjelenítése

Üres sor megjelenítéséhez adjon meg egy pontot az echo parancs után (echo.). Nem szabad szóközt hagyni.

A függőleges vonás és az átirányító karakter megjelenítése

A függőleges vonás (|) vagy átirányító karakter (< vagy >) az echo paranccsal való megjelenítéséhez írja be a beszúrási jelet (^) közvetlenül a függőleges vonal vagy az átirányító karakter elé (például: ^>, ^<, vagy ^| ). Magának a beszúrási jelnek (^) a megjelenítéséhez írjon be egymás után két beszúrási jelet (^^).


Echoconfig

Az MS-DOS alrendszer indításakor üzeneteket jelenít meg az MS-DOS alrendszer Config.nt és Autoexec.nt fájljának feldolgozásakor. Ha ez a parancs hiányzik, az üzenetek nem jelennek meg.

Ezt a parancsot az MS-DOS alrendszer Config.nt fájljában kell megadni.

echoconfig


Edit

Elindítja az MS-DOS Editor segédprogramot, amellyel ASCII szövegfájlok szerkeszthetők és módosíthatók.

edit [[meghajtó:][elérési_útvonal] fájlnév] [/b] [/g] [/h] [/nohi]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

Megadja a nevét és a helyét egy ASCII szövegfájlnak. Ha a fájl nem létezik, az MS-DOS Editor segédprogram létrehozza. Ha a fájl létezik, az MS-DOS Editor segédprogram megnyitja, és megjeleníti a tartalmát a képernyőn.

/b

Fekete-fehérben jeleníti meg az MS-DOS Editor segédprogramot. Ezt a beállítást akkor kell használni, amikor a monokróm monitor nem jeleníti meg helyesen az MS-DOS Editor segédprogramot.

/g

A CGA monitorhoz a lehetséges leggyorsabb képernyőfrissítést használja.

/h

A használt monitor által kezelhető legtöbb sort jeleníti meg a képernyőn.

/nohi

Lehetővé teszi nyolcszínű monitorok használatát az MS-DOS Editor segédprogrammal. A Windows 2000 általában 16 színt használ.

Figyelmeztetés

  • Az MS-DOS Editor segédprogram nem működik, ha a Qbasic.exe fájl nincs az aktuális alkönyvtárban, a keresési útvonalon vagy az Edit.com fájllal azonos könyvtárban. A Qbasic.exe fájl törlése esetén az MS-DOS Editor segédprogram nem használható.

Megjegyzés

  • Néhány monitortípus alapértelmezésben nem támogatja a billentyűparancsok megjelenítését. Ha a monitor nem jeleníti meg a billentyűparancsokat, használja a /b kapcsolót (CGA monitor esetén) vagy a /nohi kapcsolót (félkövér betűket nem támogató rendszerek esetén).


Edlin

Elindítja az ASCII fájlok létrehozására és módosítására használható Edlin sor alapú szövegszerkesztőt.

Az Edlin parancs sorszámozza a memóriában található szövegfájl sorait. Az Edlin parancs segítségével a sorok törölhetők, másolhatók, áthelyezhetők, módosíthatók vagy beszúrhatók a fájlba. Teljes képernyős szövegszerkesztőként használja az edit parancsot.

edlin [meghajtó:][elérési_útvonal] fájlnév [/b]

Paraméterek

[meghajtó:][elérési_útvonal] fájlnév

Megadja az ASCII fájl helyét és nevét a lemezen. Ha a fájl létezik, az Edlin parancs megnyitja. Ha a fájl nem létezik, az Edlin parancs létrehozza a fájlt a memóriában, és az Edlin e parancs kiadásakor a megadott helyen és névvel létrehozza a lemezen is a fájlt.

/b

Megadja, hogy az Edlin parancs figyelmen kívül hagyja a fájlvége karaktert (CTRL+Z).


Megjegyzés az Edlin parancshoz

Edlin

Megjegyzések

Maximális sorhossz

Az Edlin parancs legfeljebb 253 karaktert fogad el soronként.

Edlin parancsok

A következő listában az Edlin parancsok rövid leírása látható:

Parancs | Leírás
line | Megjeleníti a megadott sort.
? | Megjeleníti az Edlin parancsok listáját.
a | Csak a fájl egy részét tölti be a memóriába, ha nincs elegendő memória a teljes fájl betöltéséhez.
c | Az egymást követő sorokból álló tömböt átmásolja a megadott sorszámú sorba.
d | Törli az egymást követő sorokból álló tömböt.
e | A szerkesztett fájlt a memóriából lemezre írja (elmenti egy fájlba), és leállítja az Edlin munkamenetet.
i | Beszúr egy vagy több sort.
l | Egymást követő sorokból álló tömböt jelenít meg .
m | Áthelyezi az egymást követő sorokból álló tömböt.
p | Laponként jeleníti meg a fájlt.
q | Leállítja az Edlin munkamenetet a szerkesztett fájl memóriából a lemezre írása nélkül.
r | Egy vagy több karakterből álló karakterláncot keres meg, és kicseréli azt.
s | Egy vagy több karakterből álló karakterláncot keres meg.
t | Összefésüli a lemezen található fájl tartalmát a memóriában levő fájl tartalmával.
w | A memóriában levő fájl első részét lemezre írja.

A csillag jel (*) szerepe az Edlin parancsban

Az Edlin parancsban a csillag jel (*) két célt is szolgál. Ha a csillag egyedüli karakterként jelenik meg a képernyő látható sorban, akkor az az Edlin parancssor, ahová az Edlin parancsok beírhatók. Ha a csillag karakter egy sorszám után jelenik meg a képernyőn látható sorban, az az aktuális sort jelzi, ahol pillanatnyilag a beviteli pont van.

Oldalnyi szöveg jelentése

Egy oldalnyi szöveg egy teljes képernyőnyi adatot jelent. A képernyő 25 soros üzemmódjában az Edlin parancs 24 sornyi szöveget képes megjeleníteni egy oldalon. Az oldalankénti sorok száma függ a képernyő üzemmódjától.

A beszúrási üzemmód elindítása és leállítása

A memóriában levő fájlba az Edlin i (beszúrás) paranccsal szúrhatók be sorok. A sorok beszúrása után nyomja meg az ENTER billentyűt, majd a CTRL+C megnyomásával lépjen ki a beszúrás üzemmódból. Sorok beszúrásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson az Edlin i (beszúrás) című témakörre.

Szerkesztőbillentyűk

A Windows 2000 több szerkesztőbillentyűt is biztosít a memóriában levő fájl szerkesztéséhez.


Edlin: A (hozzáfűzés)

Betölti a fájl egy részét a memóriába, ha nincs elegendő memória a teljes fájl betöltéséhez.

Az Edlin parancs elindításakor a lemezen tárolt fájl annyi sorát tölti be a memóriába, amennyit tud. Ha a fájl mérete meghaladja a használható memória méretét, a fájlt részekben kell szerkeszteni. Azaz először a fájl első részét kell szerkeszteni, majd lemezre írni a w (írás) paranccsal, azután lehet a fájl további részeit a szerkesztés érdekében a memóriába tölteni.

[n]a

Paraméter

n

Megadja a lemezről a memóriába tölteni kívánt sorok számát.


Példa az Edlin: A (hozzáfűzés) parancs használatára

Edlin: A (hozzáfűzés)

Példa

Tegyük fel, hogy a lemezen található fájl utolsó 100 sora nem fér a memóriába. Ez esetben a fájl első részének szerkesztése és lemezre mentése után a következő paranccsal a maradék 100 sor is a memóriába tölthető:

100a


Megjegyzések az Edlin: A (hozzáfűzés) parancshoz

Edlin: A (hozzáfűzés)

Megjegyzések

Alapértelmezett beállítások

Ha az n paraméternek nincs értéke, az Edlin parancs annyi sort tölt be a fájlból, amíg a használható memória 75 százaléka meg nem telik. Ha a használható memória 75 százaléka már betelt, az Edlin parancs nem tölt be egyetlen sort sem.

Fájl vége üzenet

Ha az a parancs a fájl utolsó sorát is betöltötte a memóriába, az Edlin parancs a következő üzenetet jeleníti meg:

Bemeneti fájl vége


Edlin: C (másolás)

Az egymást követő sorokból álló tömböt átmásolja a memóriában található fájl egy vagy több helyére.

A c parancs átmásolja a megadott egymást követő sorokból álló tömböt a megadott sorszámú sorba. Ez a tömb annyiszor másolható, ahányszor szükséges.

[sor1],[sor2],[sor3],[darab]c

Paraméterek

sor1

Megadja az Edlin paranccsal másolni kívánt első sor sorszámát.

sor2

Megadja az Edlin paranccsal másolni kívánt utolsó sor sorszámát.

sor3

Megadja annak a sornak a sorszámát, amely elé be kívánja szúrni az Edlin paranccsal a megadott tömböt.

darab

Megadja, hogy az Edlin parancs hányszor másolja át a tömböt.


Példák az Edlin: C (másolás) parancs használatára

Edlin: C (másolás)

Példák

A következő parancs hatására az Edlin parancs az első öt sort a hatodik sortól kezdődően átmásolja:

1,5,6c

Az első öt sor így megegyezik a második öt sorral (6-10. sor).

Az aktuális sor a következő paranccsal másolható az 5. sorba:

,,5c


Megjegyzések az Edlin: C (másolás) parancshoz

Edlin: C (másolás)

Megjegyzések

Alapértelmezett beállítások

A sor1 vagy a sor2 paraméter kihagyása esetén az Edlin parancs az aktuális sort másolja át. A vesszőket akkor is be kell írni a parancssorba, ha az egyik vagy mindkét paraméter nincs megadva.

A darab paraméter kihagyásakor az Edlin parancs egyszer másolja át a sorokat.

Újrasorszámozás

A sorok áthelyezése után az Edlin parancssorba az Edlin l (lista) parancs beírásával megjeleníthetők a helyesen újrasorszámozott sorok.

Átfedő sorszámok

A sor3 paraméterben megadott sor nem lehet része az átmásolni kívánt sorokból álló tömbnek. Ha mégis ilyen történik, az Edlin parancs nem tudja végrehajtani a műveletet és a következő üzenetet jeleníti meg:

Bejegyzési hiba

Például a következő parancs hibaüzenetet eredményez:

3,20,15c


Edlin: D (törlés)

Törli a megadott egymás utáni sorokat.

[sor1][,sor2]d

Paraméterek

sor1

Megadja az Edlin paranccsal törölni kívánt első sort.

sor2

Megadja az Edlin paranccsal törölni kívánt utolsó sort.


Példák az Edlin: D (törlés) parancs használatára

Edlin: D (törlés)

Példák

A hetedik sor a következő paranccsal törölhető:

7d

A 22–32. sorig tartó blokk a következő paranccsal törölhető:

22,32d

Végül ha az aktuális sor a 7. sor, és ettől kezdve egészen a 11. sorig törölni kívánja a szöveget a fájlból, akkor írja be a következő parancsot:

,11d


Megjegyzések az Edlin: D (törlés) parancshoz

Edlin: D (törlés)

Megjegyzések

A paraméterek alapértelmezett értéke

A sor2 vagy mindkét paraméter kihagyása esetén az Edlin parancs törli az aktuális sort. A sor1 paraméter kihagyása esetén azonban az Edlin parancs az aktuális sortól kezdve a sor2 paraméterben megadott sorig törli az összes sort. Ez utóbbi esetben a sor2 paraméter nem lehet kisebb az aktuális sor sorszámánál. Általánosan a sor2 paraméterként megadott érték nem lehet kisebb a sor1 paraméterként megadott értéknél. A sor1 paraméter kihagyása esetén a sor2 paraméter elé a szintaxis sorban bemutatott módon helyőrző vesszőt kell beírni.

Újrasorszámozás

A sorok törlése után az Edlin parancssorba az Edlin l (lista) parancs beírásával jeleníthetők meg a helyesen újrasorszámozott sorok.


Edlin:E (befejezés)

A memóriában levő fájlt a lemezre írja, és leállítja az Edlin munkamenetet.

Az e parancs átnevezi a lemezen levő bemeneti fájlt .bak kiterjesztéssel, és elmenti a memóriában levő fájlt a bemeneti fájlba, majd leállítja az Edlin munkamenetet. Ha azonban a memóriában levő fájlt az adott munkamenetben hozta létre és nem lemezről olvasta be, akkor az Edlin parancs biztonsági másolatként nem hozza létre a .bak fájlt a lemezen.

e


Megjegyzések az Edlin: E (befejezés) parancshoz

Edlin: E (befejezés)

Megjegyzések

Alapértelmezett meghajtó és könyvtár

Az Edlin parancs az adott munkamenet indításakor megadott meghajtó, könyvtár és fájlnév értékét használja a memóriában levő fájl lemezre írásakor. Ha a meghajtó neve nem volt megadva, akkor az Edlin parancs az aktuális meghajtót használja. Ha a könyvtár neve nem volt megadva, akkor az Edlin parancs az aktuális könyvtárat használja.

A lemezterület ellenőrzése

Az e parancs kiadása előtt győződjön meg arról, hogy a lemezen elegendő szabad terület áll rendelkezésre a teljes fájl mentéséhez. Ha nincs elég szabad lemezterület, az Edlin parancs elveszti a fájl egy részét vagy egészét.

Írásvédett .bak fájl

Tegyük fel, hogy az Edlin paranccsal lemezre próbálja menteni a memóriában szerkesztett fájlt, de a fájl .bak verziója írásvédett fájl. Ilyenkor az Edlin parancs a következő üzenettel jelzi, hogy nem képes lecserélni a .bak kiterjesztésű fájlt:

Hozzáférés megtagadva - [meghajtó:][elérési_útvonal] fájlnév.bak

A lemezen levő eredeti és biztonsági másolat is változatlan marad.


Edlin: I (beszúrás)

A memóriában levő fájl megadott sora elé sorokat szúr be.

Új fájl létrehozása esetén új sor beszúrása előtt be kell írni az i parancsot. Az Edlin parancs az ENTER billentyű megnyomásakor mindig a következő sorszámot mutatja. Az Edlin parancs a CTRL+C billentyűkombináció megnyomásáig beszúró üzemmódban marad.

i [sor]

Paraméterek

sor

Megadja annak a sornak a sorszámát, amely elé a sorok beszúrása történik. A sor paraméter alapértelmezett értéke az aktuális sor.


Példa az Edlin: I (beszúrás) parancs használatára

Edlin: I (beszúrás)

Példa

Tegyük fel, hogy az Edlin parancssorban az Edlin l (lista) paranccsal a következő szöveget jelenítette meg a képernyőn:

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: Vegyészmérnöki munkáját továbbra is
6: csodálattal figyelem.
7:
8: Tisztelettel,
9:
10: Nagy B., Vezérigazgató

Új bekezdés a következőképpen adható a levélhez. A 8. sor elé a következő paranccsal illeszthető szöveg: 8I. Az Edlin parancs a következőt jeleníti meg:

8:*_

Most a beviteli ponton gépelje be a következő sort a 8. sorba:

8:*Remélem, élvezni fogja

Minden sor befejezése után nyomja meg az ENTER billentyűt, és folytassa a gépelést a következő sorban:

9: *a munkát az új projektben Láng úrral.
10: *Kérem tudassa, ha bármiben a
11: *segítségére lehetek.

Az Edlin parancs a következőt jeleníti meg:

12:*_

Az ENTER billentyű megnyomásával hagyjon egy üres sort, majd fejezze be a beszúrást a következő sorban a CTRL+C billentyűkombináció megnyomásával. Az 1l paranccsal megjeleníthető a helyesen újrasorszámozott szöveg:

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: Vegyészmérnöki munkáját továbbra is
6: csodálattal figyelem.
7:
8: Remélem, élvezni fogja
9: a munkát az új projektben Láng úrral.
10: Kérem tudassa, ha bármiben a
11: segítségére lehetek.
12:
13: Tisztelettel,
14:
15: Nagy B., Vezérigazgató


Megjegyzések az Edlin: I (beszúrás) parancshoz

Edlin: I (beszúrás)

Megjegyzések

Újrasorszámozás

A beszúró üzemmódból való kilépéskor a beszúrt sorokat követő sor lesz automatikusan az aktuális sor. Az Edlin parancssorban az Edlin l (lista) paranccsal jeleníthetők meg a helyesen újrasorszámozott sorok.

Vezérlőkarakterek beszúrása

A szövegbe vezérlőkarakter beszúrásához a vezérlőkaraktert képviselő ASCII jel elé írja be a ^V kódot. Például a kilépő karakter (CTRL+[) beszúrásához írja be a következőket:

^V[

Hangjelzést előállító karakter (CTRL+G) megadásához írja be a következőket:

^VG

Szöveg hozzáfűzése

Ha a sor paraméter értéke meghaladja a szerkesztett fájlban levő sorok számát, vagy a sor paraméter értékeként kettős kereszt (#) karaktert ad meg, akkor az Edlin parancs hozzáfűzi a beszúrt sort vagy sorokat a fájl végéhez. Mindkét esetben az utolsó beszúrt sor marad az aktuális sor. Ha a fájlnak csak egy része van a memóriában, akkor a sorokat a fájlrész végéhez fűzi hozzá a parancs.


Edlin: L (lista)

Megjeleníti a megadott egymás utáni sorokat.

l [ sor1][,sor2]

Paraméterek

sor1

Megadja az Edlin paranccsal megjeleníteni kívánt első sort.

sor2

Megadja az Edlin paranccsal megjeleníteni kívánt utolsó sort.


Példa az Edlin: L (lista) parancs használatára

Edlin: L (lista)

Példa

A fájl 5–10. sora a következő paranccsal jeleníthető meg:

5,10l


Megjegyzések az Edlin: L (lista) parancshoz

Edlin: L (lista)

Megjegyzések

Alapértelmezett értékek

Nem szükséges megadni a sor1 és sor2 paramétert. Ezekben az esetekben a paraméterek alapértelmezett értéke a következő listában látható:

  • Ha csak a sor1 paraméter nincs megadva, az Edlin parancs oldalanként jeleníti meg a szöveget, az aktuális sor előtt 11 sorral kezdődően a sor2 paraméterben megadott sorig. A sor1 paraméter kihagyása esetén a paraméter helyét vesszővel kell jelezni.
  • A sor2 paraméter kihagyása esetén az Edlin parancs egy oldalnyi adatot jelenít meg a sor1 paraméterben megadott sortól kezdődően.
  • Az Edlin l (lista) parancs paraméter nélküli megadásakor az Edlin parancs egy oldalnyi adatot jelenít meg az aktuális sor előtt 11 sorral kezdődően. Ha az Ansi.sys eszközillesztő telepítve van, az oldalon megjelenő sorok száma függ a használt monitor típusától. Ez a szám 24-nél nagyobb is lehet.

Több oldalból álló tömbök

Ha egy tömb egy oldalnál több sort tartalmaz, az Edlin parancs egy oldalnyi adatot jelenít meg, és a következő üzenetet írja ki:

Folytatja (I/N)?

Minden igen válasz esetén az Edlin parancs megjelenít egy újabb oldalt.


Edlin: [sor]

Megjeleníti a megadott sor tartalmát.

A sorszám parancsként történő megadásakor az Edlin parancs két sort jelenít meg. Az első sorban megjelenik a megadott szám, és a hozzá tartozó szöveg. A második sorban ismét megjelenik a megadott szám, és a beviteli pont. Az első megjelenített sor a második sor sablonjaként szolgál. A második megjelenített sorban a parancsból való kilépéshez és a szöveg meghagyásához megnyomható az ENTER billentyű, beírható az új szöveg vagy szerkeszthető a régi szöveg.

[sor]

Paraméter

sor

Megadja a megjeleníteni kívánt sor sorszámát. Az aktuális sor sorszámának és a hozzá tartozó szöveg megjelenítéséhez nyomja meg az ENTER billentyűt.


Példa az Edlin: [sor] parancs használatára

Edlin: [sor]

Példa

Tegyük fel, hogy a memóriában a következő fájl szerkesztésre kész. Az Edlin l (lista) paranccsal megjeleníthető a fájl tartalma.

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: Vegyészmérnöki munkáját továbbra is
6: csodálattal figyelem.

A 6. sor szerkesztéséhez írja be a következő parancsot: 6. Az Edlin parancs a következő két sort jeleníti meg:

6:*csodálattal figyelem.
6:*_

Az első sorban a megadott sorszám és a hozzá tartozó szöveg jelenik meg. A második sorban ugyanez a sorszám és a beviteli látható.

A fenti példában a két szó közé szúrja be az „adózva” szót. Az Edlin paranccsal jelenítse meg a sor elejét a beviteli ponttal kezdődően. Először nyomja meg az F2 billentyűt, majd írja be az l parancsot. Az Edlin parancs megjeleníti a szöveget az első „l” betűig (az „l” betűt már nem) a következőképpen:

6:*csodá_

Most nyomja meg az F2 billentyűt, és írja be az f betűt. Az Edlin parancs megjeleníti a szöveget az „f” betűig (az „f” betűt már nem) a következőképpen:

6:*csodálattal _

Nyomja meg az INSERT billentyűt és írja be az adózvaszót, majd nyomja meg a SZÓKÖZ billentyűt. Nyomja meg az F3 billentyűt. Az Edlin parancs megjeleníti a szerkesztett sort a következőképpen:

6:*csodálattal adózva figyelem._

Nyomja meg az ENTER billentyűt a módosítás elfogadásához.

Az Edlin parancssorban adja ki az Edlin l (lista) parancsot a memóriában levő szerkesztett fájl jelenlegi állapotának megjelenítéséhez. Az Edlin parancs a következőt jeleníti meg:

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: Munkáját továbbra is
6:*csodálattal adózva figyelem.


Megjegyzés az Edlin: [sor] parancshoz

Edlin: [sor]

Megjegyzés

Változások bevitele a memóriába

A sor szerkesztése után az ENTER billentyű megnyomásával menthetők el a módosítások a memóriába.

Figyelmeztetés

  • Ha úgy nyomja meg az ENTER billentyűt, hogy a beviteli pont a sor közepén van, az Edlin parancs törli a beviteli pont és a sor vége közé eső részt.

A memóriában szerkesztett fájl lemezre írásával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson az Edlin E (befejezés) vagy az Edlin W (írás) című témakörre.


Edlin: M (áthelyezés)

Az egymás utáni megadott sorokat áthelyezi a memóriában levő fájl más helyére.

[sor1],[sor2],sor3 m

[sor1],+n,sor3 m

Paraméterek

sor1

Megadja az Edlin paranccsal áthelyezni kívánt első sort.

sor2

Megadja az Edlin paranccsal áthelyezni kívánt utolsó sort.

sor3

Megadja azt a sort, amely elé az Edlin parancs áthelyezi a megadott sorokat.

+n

Megadja, hogy az Edlin paranccsal áthelyezett tömb a sor1 paraméterrel megadott sorral kezdődjön, és n darab sort tartalmazzon. A sor1 paraméter kihagyása esetén az áthelyezni kívánt tömb első sora lesz az aktuális sor.


Példák az Edlin: M (áthelyezés) parancs használatára

Edlin: M (áthelyezés)

Példák

Tegyük fel, hogy a memóriában a következő fájl szerkesztésre kész. Az Edlin parancssorban az 1l paranccsal megjeleníthető a fájl tartalma.

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: Vegyészmérnöki munkáját továbbra is
6: csodálattal adózva figyelem.
7:
8: Remélem élvezni fogja
9: a munkát az új projektben Láng kisaszonnyal.
10: Kérem tudassa, ha bármiben a
11: segítségére lehetek.
12:
13: Tisztelettel,
14:
15: Nagy B., Vezérigazgató
16: Sziklaszilárd Rt.
17: "Világelső a technológiában"

A szlogen a 16. és 17. sorok áthelyezésével helyezhető a levél elejére az 1. sor elé. Ez a következő paranccsal végezhető el:

16,170,1m

Az Edlin parancssorba írja be az Edlin l (lista) parancsot a helyesen újrasorszámozott sorok megjelenítéséhez.

1: Sziklaszilárd Rt.
2: "Világelső a technológiában"
3: Tisztelt Kovács Úr!
2:
5: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
7: Vegyészmérnöki munkáját továbbra is
8: csodálattal adózva figyelem.
7:
10: Remélem élvezni fogja
9: a munkát az új projektben Láng kisaszonnyal.
12: Kérem tudassa, ha bármiben a
13: segítségére lehetek.
12:
15: Tisztelettel,
14:
17: Nagy B., Vezérigazgató

A következő Edlin parancs áthelyezi az aktuális sortól kezdődő 25 sort tartalmazó tömböt közvetlenül a 100. sor elé:

,+25,100m


Megjegyzések az Edlin: M (áthelyezés) parancshoz

Edlin: M (áthelyezés)

Megjegyzések

Újrasorszámozás

A sorok áthelyezése után az Edlin l (lista) paranccsal megjeleníthetők a helyesen újrasorszámozott sorok.

Átfedő sorszámok

A sor3 paraméterként megadott sor nem lehet része az áthelyezni kívánt sorokat tartalmazó tömbnek. Például a következő parancs hibaüzenetet eredményez:

16,170,1m

Ha mégis ilyen történik, az Edlin parancs nem tudja végrehajtani a műveletet, és a következő üzenetet jeleníti meg:

Bejegyzési hiba


Edlin: P (oldal)

Egészben vagy oldalanként (teljes képernyőnyi szöveg) jelenít meg a fájlt.

Mindig a képernyőn utoljára megjelenített sor lesz az aktuális sor.

[sor1][, sor2]p

Paraméterek

sor1

Megadja az Edlin által megjeleníteni kívánt első sort.

sor2

Megadja az Edlin által megjeleníteni kívánt utolsó sort.


Edlin: P (oldal) parancs használatára

Edlin: P (oldal)

Példa

A 100 – 200. sor oldalanként való megjelenítéséhez írja be a következő parancsot:

100,200p


Edlin: P (oldal) parancshoz

Edlin: P (oldal)

Megjegyzések

A sor1 paraméter kihagyása

A sor1 paraméter kihagyása esetén az Edlin parancs egy oldalnyi szöveget jelenít meg az aktuális sortól kezdődően a sor2 paraméterrel megadott sorig.

A sor2 paraméter kihagyása

A sor2 paraméter kihagyása esetén az Edlin egy oldalnyi szöveget jelenít meg a sor1 paraméterben megadott sorral kezdődően.

Mindkét paraméter kihagyása

Mindkét paraméter kihagyása esetén az Edlin parancs egy oldalnyi szöveget jelenít meg az aktuális sortól kezdődően.


Edlin: Q (kilépés)

Leállítja az aktuális Edlin munkamenetet a memóriában levő (szerkesztés alatt álló) fájl lemezre mentése nélkül.

A q parancs használata esetén az Edlin munkamenet megszakad, és a Windows 2000 parancssor jelenik meg.

Az aktuális munkamenet befejezése előtt a memóriában levő (szerkesztett) fájl lemezre mentéséhez használja az Edlin e (befejezés) parancsot.

q


Edlin: Q (kilépés) parancshoz

Edlin: Q (kilépés)

Megjegyzések

A q és az e parancs közötti különbség

Tegyük fel, hogy a memóriában levő fájl olyan fájl, amelyet az Edlin parancs indításakor a lemezről olvasott be a rendszer, és nem a munkamenet közben létrehozott fájl. Ha a q paranccsal lép ki a munkamenetből, az eredeti bemeneti fájl és a biztonsági másolat (.bak) (ha van ilyen) egyaránt változatlan marad. Az e paranccsal történő kilépés esetén azonban, ha a szerkesztett fájl megváltozott a munkamenet alatt, a változtatások mentése megtörténik az eredeti bemeneti fájlba, és az eredeti fájlból biztonsági másolat lesz (.bak).

Kilépés az Edlinből parancsból a szerkesztett fájl memóriából lemezre írása nélkül

A következőképpen léphet ki az Edlin parancsból a szerkesztett fájl memóriából lemezre való írása nélkül:

  1. Az Edlin parancssorba írja be a q parancsot. Az Edlin parancs a következő üzenetet jeleníti meg:

    Megszakítja a szerkesztést (I/N)? _

  2. Nyomja meg az I billentyűt.


Edlin: R (csere)

Egymást követő sorokból álló blokkban megkeresi egy karakter vagy karakterlánc minden előfordulását, és kicseréli a megadott karakterláncra.

Az a sor lesz az aktuális sor, amelyben az utolsó csere történt.

[sor1][,sor2][?]r[karakterlánc1][elválasztó karakterlánc2]

Paraméterek

sor1

Az első sor, amelyben az Edlin parancs keresi a lecserélni kívánt karakterlánc1 paramétert.

sor2

Az utolsó sor, amelyben az Edlin parancs keresi a lecserélni kívánt karakterlánc1 paramétert.

? (kérdőjel)

E paraméter megadása esetén a karakterlánc1 paraméterben megadott karakterlánc minden előfordulása esetén az Edlin parancs a csere végrehajtása előtt kéri a csere megerősítését.

karakterlánc1

Megadja az Edlin parancs által kicserélni kívánt karakterláncot.

elválasztó

Elválasztja a karakterlánc1 és karakterlánc2 paraméter értékeit. A paraméternek az egyetlen érvényes értéke a fájl vége karakter (CTRL+Z).

karakterlánc2

Megadja azt a karakterláncot, amelyre az Edlin parancs a karakterlánc1 paraméterben megadott karakterláncot kicseréli.


Edlin: R (csere) parancs használatára

Edlin: R (csere)

Példák

A következő művelettel az Edlin parancs a szerkesztett fájl első 20 sorában kicseréli az „enyém” szó összes előfordulását a „miénk” szóra, és minden csere esetén kéri a jóváhagyást. Írja be a parancs első felét a következőképpen, de ne nyomja meg az ENTER billentyűt:

1,20?renyém

A parancs befejezéséhez nyomja meg a CTRL+Z billentyűkombinációt (ez a képernyőn így jelenik meg: ^Z), írja be a miénk szót, és nyomja meg az ENTER billentyűt. A teljes parancs a következőképpen jelenik meg a képernyőn:

1,20?renyém^Zmiénk

Tegyük fel, hogy a memóriában a következő, szerkesztésre kész fájl van. A fájl tartalmának megjelenítéséhez írja be az 1l parancsot az Edlin parancssorba.

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: Vegyészmérnöki munkáját továbbra is
6: csodálattal adózva figyelem.
7:
8: Remélem, élvezni fogja
9: a munkát az új projektben Láng kisaszonnyal.
10: Kérem tudassa, ha bármiben a
11: segítségére lehetek.
12:
13: Tisztelettel,
14:
15: Nagy B., Vezérigazgató
16: Sziklaszilárd Rt.
17: "Világelső a technológiában"

Az Edlin paranccsal az 5–10. sor között a „Vegyészmérnöki” szó összes előfordulása az „Orvosi” szóra cserélhető le a csere jóváhagyásának kérése nélkül az alábbiak szerint. Írja be a parancs első felét a következőképpen, de ne nyomja meg az ENTER billentyűt:

3,10rVegyészmérnöki

A parancs befejezéséhez nyomja meg a CTRL+Z billentyűkombinációt (ez a képernyőn így jelenik meg: ^Z), írja be az Orvozi szót, és nyomja meg az ENTER billentyűt. A teljes parancs a következőképpen jelenik meg a képernyőn:

3,10rVegyészmérnöki^ZOrvosi

Mivel a ? paraméter nincs megadva, az Edlin parancs kérdés nélkül kicseréli a „Vegyészmérnöki” szó két előfordulását. Az Edlin parancs a cserék végrehajtása után a csere eredményeként a következő két sort jeleníti meg:

5: Orvosi kinevezéséhez
6: Orvosi munkáját továbbra is

Az előző példában véletlen csere is előfordulhatott, mivel a ? paraméter nem volt megadva a parancsban. A teljes parancs a következőképpen jelenik meg:

3,10?rVegyészmérnöki^ZOrvosi

Most az Edlin parancs a karakterlánc1 paraméterben megadott érték minden előfordulásakor kéri a csere jóváhagyását, és csak a jóváhagyott cseréket hajtja végre a következő példa szerint:

5: Orvosi kinevezéséhez
OK? i
6: Orvosi munkáját továbbra is
OK? n

A ? paraméter használatakor az Edlin parancs nem jeleníti meg automatikusan a jóváhagyás eredményeként megváltoztatott sorokat. Az Edlin parancs parancssorába az Edlin l (lista) parancs beírásával megjeleníthető a memóriában levő fájl:

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Orvosi kinevezéséhez.
5: . Vegyészmérnöki munkáját továbbra is
6: csodálattal adózva figyelem.
7:
8: Remélem, élvezni fogja
9: a munkát az új projektben Láng kisaszonnyal.
10: Kérem tudassa, ha bármiben
11: segítségére lehetek.
12:
13: Tisztelettel,
14:
15: Nagy B., Vezérigazgató
16: Sziklaszilárd Rt.
17: "Világelső a Technológiában"


Edlin: R (Csere) parancshoz

Edlin: R (Csere)

Megjegyzések

Szóközök használata a parancssorban

Az r és az azt követő paraméterek közé nem szabad szóközöket tenni a parancssorban.

Alapértelmezett beállítások

A sor1 paraméter kihagyása esetén az Edlin parancs az aktuális sor utáni sorban kezdi a keresést. A sor2 paraméter kihagyása esetén az Edlin parancs a fájl utolsó soráig, vagy a memóriában levő rész végéig végzi a keresést.

A karakterlánc1 paraméter kihagyása esetén az Edlin parancs a következő két érték közül a legutóbb használt értéket használja a kereséshez: a karakterlánc paraméter értékét az s parancs legutóbbi használatakor, vagy a karakterlánc1 paraméter értékét az r parancs legutóbbi használatakor. Ha a karakterlánc1 paraméter kihagyása esetén és a munkamenet során sem az r, sem az s parancs nem volt még használva, akkor a parancs végrehajtása leáll.

A karakterlánc2 paraméter kihagyása esetén az Edlin parancs az r parancs legutóbbi futtatásakor használt értéket használja. Ha a karakterlánc2 paraméter kihagyása esetén és a munkamenet során az r parancs nem volt használva, az Edlin parancs a karakterlánc1 paraméter minden előfordulását törli.

Az elválasztó paraméter használata

A karakterlánc1 és karakterlánc2 paraméterek értékét el kell választani a CTRL+Z billentyűkombinációval. A karakterlánc1 paraméter kihagyása esetén is meg kell nyomni a CTRL+Z billentyűkombinációt, amely a karakterlánc2 paraméter kezdetét jelzi. A CTRL+Z billentyűkombináció megnyomásának hatására nem a „CTRL+Z” karakterek jelennek meg. Ehelyett a következő jelenik meg:

^Z

A kérdőjel (?) használata

Ha a ? paraméter meg van adva a parancsban, az Edlin parancs megjeleníti az első olyan sort, amelyben a karakterlánc1 paraméter értéke megtalálható, és a következő kérdést jelenik meg:

OK? _

Az I (Igen) vagy az ENTER megnyomása esetén az Edlin parancs kicseréli a karakterlánc1 paraméternek ezt az előfordulását a karakterlánc2 értékre, és folytatja a keresést. Az N (Nem) billentyű megnyomása esetén az Edlin parancs nem cseréli ki a karakterlánc1 aktuális előfordulását, és folytatja a keresést.

A parancs használata kérdőjel (?) nélkül

Ha nem adja meg a ? paramétert a cserék jóváhagyásához, az Edlin parancs elvégzi az összes előfordulás cseréjét, majd megjeleníti azokat a sorokat, amelyekben csere történt. Ha egy sorban két vagy több csere történt, az Edlin parancs minden csere esetében egyszer megjeleníti a sort.


Edlin: S (keresés)

Megkeresi a megadott egy- vagy több karakterből álló karakterláncot.

Az Edlin parancs megjeleníti az első olyan sort, amely tartalmazza a keresett karakterláncot. A keresés ekkor leáll, és ez a sor lesz az aktuális sor.

[sor1][,sor2][?]s[karakterlánc]

Paraméterek

sor1

Megadja az első sort, amelyben az Edlin parancs keresi a megadott karakterláncot.

sor2

Megadja az utolsó sort, amelyben az Edlin parancs keresi a megadott karakterláncot.

? (kérdőjel)

Használata esetén az Edlin parancs jóváhagyást kér a karakterlánc paraméter értékének első megtalálásakor.

karakterlánc

Megadja az Edlin paranccsal keresni kívánt karakterláncot. Ez elé a paraméter elé nem szabad szóközt írni, kivéve, ha az a keresett karakterlánc része.


Edlin: S (keresés) parancs használatára

Edlin: S (keresés)

Példák

Tegyük fel, hogy a memóriában a következő fájl szerkesztésre kész. A fájl tartalmának megtekintéséhez írja be az 1l parancsot az Edlin parancssorba.

1: Tisztelt Kovács Úr!
2:
3: Gratulálunk a Vezető
4: Vegyészmérnöki kinevezéséhez.
5: . Vegyészmérnöki munkáját továbbra is
6: csodálattal adózva figyelem.
7:
8: Remélem, élvezni fogja
9: a munkát az új projektben Láng kisasszonnyal.
10: Kérem tudassa, ha bármiben a
11: segítségére lehetek.
12:
13: Tisztelettel,
14:
15: Nagy B., Vezérigazgató

A következő parancs hatására az Edlin megkeresi az „mun” karakterlánc első előfordulását a 2. és 12. sor között.

2,12smun

Az Edlin parancs a következőt jeleníti meg:

6: Vegyészmérnöki munkáját továbbra is

Ha azt kívánja beállítani, hogy az Edlin parancs a „mun” karakterlánc első megtalálása után jóváhagyást kérő üzenetet jelenítsen meg, akkor írja be a következő parancsot:

1,?smun

Az Edlin parancs a következő sorokat jeleníti meg:

6: Vegyészmérnöki munkáját továbbra is
OK? _

Az I és az ENTER billentyűktől különböző billentyű megnyomása esetén a keresés folytatódik. Például nyomja meg az N (Nem) gombot:

OK? n

Az Edlin parancs folytatja a keresést és a következő sort jeleníti meg:

9: a munkát az új projektben Láng kisasszonnyal.
OK? _

A keresés leállításához nyomja meg az I billentyűt.


Edlin: S (keresés) parancshoz

Edlin: S (keresés)

Megjegyzések

Alapértelmezett beállítások

Ha a sor1 paraméter nincs megadva, az Edlin parancs az aktuális sor utáni sorban kezdi a keresést. A sor2 paraméter kihagyása esetén az Edlin parancs a fájl utolsó soráig végzi a keresést.

A karakterlánc paraméter kihagyása esetén az Edlin parancs a következő két érték közül a legutóbb használt értéket keresi: a karakterlánc paraméter értéke az s parancs legutóbbi használatakor, vagy a karakterlánc1 paraméter értéke az r parancs legutóbbi használatakor. Ha a karakterlánc paraméter kihagyása esetén a munkamenet során sem az r, sem az s parancs nem volt még használva, akkor az s parancs végrehajtása azonnal leáll.

A ? (kérdőjel) használata

Ha a ? paraméter megadása esetén az Edlin parancs megjeleníti az első olyan sort, amelyben a karakterlánc paraméterben megadott érték megtalálható, és a következő kérdés jelenik meg:

OK? _

Az I (Igen) vagy az ENTER megnyomása esetén a megjelenített sor lesz az aktuális sor, és a keresés leáll. Az N (Nem) billentyű megnyomása esetén a keresés folytatódik a karakterlánc következő előfordulásáig, vagy a következő üzenet megjelenéséig, ami a fájl végének elérését jelzi:

Nem található


Edlin alparancsok

További tudnivalókért válassza ki az Edlin parancsok egyikét.

Edlin: [sor]
Edlin: A (hozzáfűzés)
Edlin: C (másolás)
Edlin: D (törlés)
Edlin: E (befejezés)
Edlin: I (beszúrás)
Edlin: L (lista)
Edlin: M (áthelyezés)
Edlin: P (oldal)
Edlin: Q (kilépés)
Edlin: R (csere)
Edlin: S (keresés)
Edlin: T (átvitel)
Edlin: W (írás)


Edlin: T (átvitel)

A lemezen levő fájl tartalmát beilleszti a memóriában levő fájlba.

[sor]t[meghajtó:][elérési_útvonal] fájlnév

Paraméterek

sor

Megadja, hogy melyik sor elé fogja az Edlin parancs beilleszteni a lemezen levő fájlt. Ennek a paraméternek az alapértelmezett értéke az aktuális sor.

[meghajtó:][elérési_útvonal] fájlnév

Megadja annak a fájlnak a helyét és nevét, amely a sor paraméterrel megadott sor elé illeszt be a parancs. A meghajtó paraméter alapértelmezett értéke az aktuális meghajtó, az elérési_útvonal paraméter alapértelmezett értéke az aktuális könyvtár.


Edlin: T (átvitel) parancs használatára

Edlin: T (átvitel)

Példa

Az Adók.mem nevű fájl a szerkesztett fájl 12 sorától kezdődően történő beillesztéséhez írja be a következő parancsot:

12t adók.mem


Edlin: T (átvitel) parancshoz

Edlin: T (átvitel)

Megjegyzés

Miután az Edlin parancs beillesztette a lemezen levő fájlt, az Edlin l (lista) paranccsal az Edlin parancssorban megjeleníthetők a helyesen újrasorszámozott sorok.


Edlin: W (írás)

A memóriából a lemezre írja a szerkesztett fájl első részét.

Az Edlin parancs elindításakor a lemezen tárolt fájl annyi sorát tölti be a memóriába, amennyit tud. Ha a fájl mérete meghaladja a használható memória méretét, a fájlt részekben kell szerkeszteni. Azaz a fájl egy részének szerkesztése után a fájlnak ezt a részét a w paranccsal a lemezre kell írni, majd az a (hozzáfűzés) paranccsal beolvasható a fájl következő része.

[n]w

Paraméter

n

Megadja, hogy a memóriában levő fájl az aktuális sorával kezdődően az Edlin parancs hány sort írjon a lemezre.


Edlin: W (írás) parancs használatára

Edlin: W (írás)

Példa

Tegyük fel, hogy a fájl utolsó 100 sora nem fér el a memóriában. A fájl első részének szerkesztése után a következő parancs segítségével felszabadítható annyi memória, hogy a fájl maradék része is betölthető legyen:

125w


Edlin: W (írás) parancshoz

Edlin: W (írás)

Megjegyzések

A w parancs működése

A fájl megnyitásakor az Edlin parancs addig olvas a fájlból, amíg a memória 75%-a meg nem telik. Így 25% áll rendelkezésre a szövegben végzett módosítások tárolására. Ha teljes fájl elfér a memóriában, az Edlin parancs a következő üzenetet jeleníti meg:

Bemeneti fájl vége

Ha megjelenik ez az üzenet, akkor nem kell a w és az a (hozzáfűzés) parancsot használni.

Ha az Edlin parancs nem jeleníti meg ezt az üzenetet a fájl megnyitásakor, akkor a fájl mérete nagyobb, mint a használható szabad memória mérete. Ekkor a fájlt részletekben kell szerkeszteni a w és az a parancs segítségével a fájl adott részének írásával és olvasásával.

A w parancs nem írja a változtatásokat a lemezre, ha a w parancs használata nem szükségszerű. Azaz ha a w parancsot használja annak ellenére, hogy a teljes fájl elfér a memóriában, majd az Edlin parancsból való kilépéshez kiadja a q (kilépés) parancsot, a fájlban történt változásokat nem menti a rendszer.

Újrasorszámozás

A memóriában levő fájl első részének a lemezre írása után az Edlin parancssorban az Edlin l (lista) paranccsal megjeleníthetők a megfelelően újrasorszámozott sorok az 1-es sorszámtól kezdődően.

Alapértelmezett beállítások

Ha az n paraméter nincs megadva, az Edlin parancs a memóriában levő fájlból annyit ír ki a lemezre, hogy utána a memóriának csak 25%-a legyen foglalt.


Endlocal

A kötegfájlban befejezi a környezet változásainak lokalizálását, visszaállítja a környezeti változókat a setlocal parancs kiadása előtti állapotba.

A kötegfájl végén van egy endlocal parancs.

endlocal

A parancskiterjesztések engedélyezése esetén (Windows 2000 alapértelmezés) az endlocal parancs visszaállítja a parancskiterjesztések engedélyezett/tiltott állapotát a setlocal parancs végrehajtása előtti állapotba.


Példa az Endlocal parancs használatára

Endlocal

Példa

A kötegfájlban lokalizálhatók a környezeti változók.

@echo off

rem Ez a program elindítja a hálózaton a szuperalk nevű kötegfájlt,

rem a kimenetet fájlba irányítja át, és a Jegyzettömb segédprogrammal

rem megjeleníti a fájlt.

setlocal

path=g:\programs\szuperalk;%path%

call szuperalk>c:\szuperalk.out

endlocal

start notepad c:\szuperalk.out


Evntcmd

Megjeleníti az SNMP-eseményeket.

evntcmd [/? | /h] [/s rendszernév][/v szám] [/n]

Paraméterek

[/?|/h]

Megjeleníti az eventcmd parancshoz tartozó súgót.

/s rendszernév

Megadja a konfigurációhoz használható célrendszernevet.

/v szám

Megadja az evntcmd parancs által adott eredmény részletességének a szintjét. 0=csendes, 10=részletes.

/n

Beállítja, hogy trapmódosítások érkezése esetén az SNMP szolgáltatás ne induljon újra.


Exe2bin

Bináris formátumúvá alakítja át a .exe (futtatható) fájlokat.

Az Exe2bin parancs a szoftverfejlesztők munkájának segítése érdekében került bele a Windows 2000 operációs rendszerbe. Ez a program az átlagos felhasználók számára nem hasznos.

exe2bin [meghajtó1:][elérési_útvonal_1]bemeneti_fájl [[meghajtó2:][elérési_útvonal_2]kimeneti_fájl]

Paraméterek

[meghajtó1:][elérési_útvonal_1]bemeneti-fájl

Megadja a konvertálni kívánt fájl helyét és nevét.

[meghajtó2:][elérési_útvonal_2]kimeneti-fájl

Megadja a létrehozni kívánt kimeneti fájl helyét és nevét.


Megjegyzések az Exe2bin parancshoz

Exe2bin

Megjegyzések

Az exe2bin használatának korlátozásai

Az exe2bin parancs használatakor a következő korlátozások érvényesek:

  • A bemeneti fájlnak érvényes .exe formátumban kell lennie, és nem lehet tömörített.
  • Az összes rezidens vagy valódi kód- és adatrésznek kevesebbnek kell lennie 64 kB-nál.
  • Nem lehet benne verem szegmens.

A paraméterek alapértelmezett értéke

Az exe2bin parancs a bemeneti_fájl és a kimeneti_fájl paraméterként megadott értékektől függően adott műveletet hajt végre.

  • A bemeneti_fájl alapértelmezett kiterjesztése .exe. Az exe2bin parancs a bemeneti .exe fájlt .bin formátumú kimenetté konvertálja (a program memóriaképe), és ezt a fájlt a [meghajtó2:][elérési_útvonal2]kimeneti_fájl paraméterként megadott helyen a megadott fájlnéven tárolja.
  • Ha a meghajtó2 vagy az elérési_útvonal2 paraméter nincs megadva, akkor az exe2bin az aktuális meghajtó aktuális könyvtárába menti el a kimeneti fájlt.
  • Ha nincs megadva kimeneti fájlnév, az exe2bin parancs a bementi fájlnevet használja.
  • A kimeneti fájlként megadott fájlnév alapértelmezett kiterjesztése .bin.

Az exe2bin paranccsal végrehajtható konverziók típusai

A konverziónak két lehetséges módja van attól függően, hogy a kezdeti CS:IP (kódszegmens:utasításmutató) érték meg van-e adva az .exe fájlban. A következő listában látható a két típus:

  • Ha a CS:IP nincs megadva az .exe fájlban, az exe2bin normál bináris konverziót hajt végre. Ha szegmensáthelyezés (fixup) szükséges (azaz a program olyan utasítást tartalmaz, amely egy szegmens áthelyezését igényli), az exe2bin kéri az áthelyezés értékét. Az érték az az abszolút szegmens, amelynél a program betöltendő. Az eredményül kapott program csak akkor használható, ha a betöltése a program által megadott abszolút memóriacímnél történik. A parancsértelmező nem képes betölteni a programot.
  • Ha a CS:IP érték meg van adva (pl.: 0000:100H), a fájl .com fájlként fut az ORG gépi kódú utasítás által 100H értékre beállított utasításmutatóval. A kimeneti_fájl paraméterben meg kell adni a .com kiterjesztést is. A szegmensáthelyezések (fixup) nem engedélyezettek, mert a .com fájloknak a szegmensek között áthelyezhetőnek kell lenniük, azaz meg kell felelniük a Microsoft Macro Assembler kézikönyvben leírt feltételeknek. A parancsértelmező ezután ugyanúgy képes futtatni a programot, mint ahogy betölti és futtatja a Windows 2000 lemezen kapott .com programokat is.


Exit

Kilép a Cmd.exe programból (a parancsértelmezőből), és visszatér a Cmd.exe programot indító programhoz, ha ilyen létezik, vagy a Programkezelőhöz.

exit


Expand

Kibont egy vagy több tömörített fájlt. Ez a parancs a telepítőlemezen kapott tömörített fájlok kibontására használható.

expand [-r] forrás [cél]

expand -d forrás.cab [-f:fájlok]

expand forrás.cab -f:fájlok cél

Paraméterek

-r

Átnevezi a kibontott fájlokat.

-d

Megjeleníti a forráshelyen található fájlok listáját. Nem bontja ki a fájlokat.

-f:fájlok

Megadja a kibontani kívánt fájlokat a kabinetfájlban (.cab). Helyettesítő karakterek is (* és ?) használhatók.

forrás

Megadja a kibontani kívánt fájlokat. A forrás a meghajtó-betűjelből, kettőspontból, mappanévből és fájlnévből, vagy ezek kombinációjából állhat. Helyettesítő karakterek is használhatók.

cél

Megadja, hova bontsa ki a program a fájlokat. Ha a forrás paraméter több fájlt ad meg és nincs megadva a -r paraméter, akkor a cél paraméternek könyvtárnak kell lennie. A forrás a meghajtó-betűjelből, kettőspontból, mappanévből és fájlnévből, vagy ezek kombinációjából állhat.


Fastopen

A Windows 2000 és az MS-DOS alrendszer nem használja ezt a parancsot. Kizárólag az MS-DOS való kompatibilitás miatt fogadja el a rendszer.


Fc

Összehasonlít két fájlt, és megjeleníti a különbségeket.

fc [/a] [/b] [/c] [/l] [/lb n] [/n] [/t] [/u] [/w] [/nnnn] [meghajtó1.:][elérési_útvonal_1]fájlnév1 [meghajtó2:][elérési_útvonal_2]fájlnév2

fc /b [meghajtó1:][elérési_útvonal_1]fájlnév1 [meghajtó2:][elérési_útvonal_2]fájlnév2

Paraméterek

/a

Lerövidíti az ASCII összehasonlítás kimenetét. Az összes különböző sor megjelenítése helyett az fc parancs az egymást követő különböző sorokból csak az első és az utolsó sort jeleníti meg.

/b

A fájlokat bináris módon hasonlítja össze. Az Fc parancs bájtonként hasonlítja össze a fájlokat, és eltérés esetén nem próbálja meg újból szinkronizálni a két fájlt. Ez az alapértelmezett üzemmód az .exe, .com, .sys, .obj, .lib és .bin kiterjesztésű fájlok esetén.

/c

Figyelmen kívül hagyja a kis- és nagybetűk különbözőségét.

/l

A fájlokat ASCII módban hasonlítja össze. Az Fc parancs soronként hasonlítja össze a fájlokat, és különbözőség esetén megpróbálja újra szinkronba hozni a fájlokat. Ez az alapértelmezett üzemmód a nem .exe, .com, .sys, .obj, .lib vagy .bin kiterjesztésű fájlok esetén.

/lbn

Beállítja a belső sorpuffer sorainak a számát. A sorpuffer alapértelmezett hossza 100 sor. Ha az összehasonlított fájlok ennél több egymás utáni sorban térnek el egymástól, az fc leállítja az összehasonlítást.

/n

Az ASCII összehasonlítás alatt megjeleníti a sorszámokat is.

/t

Nem bontja ki a tabulátorokat szóközökké. Alapértelmezésben a tabulátorokat 8 szóközből álló egységként kezeli a parancs.

/u

Unicode szövegként hasonlítja össze a fájlokat.

/w

Az összehasonlítás során összefogja az üres karaktereket (tabulátorok és szóközök). Ha egy sor sok egymás utáni szóközt vagy tabulátort tartalmaz, a /w kapcsoló használatakor a parancs egyetlen szóközként kezeli ezeket. A /w kapcsoló megadásakor az fc parancs figyelmen kívül hagyja (és nem hasonlítja össze) az üres helyeket a sorok elején és végén.

/nnnn

Megadja, hogy az fc parancs hány darab egymás utáni sor egyezősége esetén próbálja a sorokat újra szinkronba hozni. Ha az egyező sorok száma a fájlban kevesebb ennél a számnál, akkor az fc különbözőnek tünteti fel az egyező sorokat. Az alapértelmezett érték 2.

[meghajtó1:][elérési_útvonal_1]fájlnév1

Megadja az első összehasonlítani kívánt fájl helyét és nevét.

[meghajtó2:][elérési_útvonal_2]fájlnév2

Megadja a második összehasonlítani kívánt fájl helyét és nevét.


Példák az FC parancs használatára

Fc

Példák

Két (Havi.rpt és Bevétel.rpt nevű) szövegfájl ASCII összehasonlítása és az eredmény rövidített formátumban való megjelenítése. Az összehasonlítás végrehajtásához írja be a következő parancsot: fc /a havi.rpt bevétel.rpt

Két parancsfájl (Profit.bat és Nyereség.bat) bináris összehasonlításához írja be a következő parancsot:

fc /b profit.bat nyereség.bat

Ennek a parancsnak az eredménye a következőhöz hasonló:

00000002: 72 43
00000004: 65 3A
0000000E: 56 92
00000012: 6D 5C
00000013: 0D 7C
00000014: 0D 0A
00000015: 0A 0D
0000001E: 43 7A
0000001F: 09 0A
00000022: 72 44
...
...
...
000005E0: 00 61
000005E1: 00 73
000005E2: 00 73
000005E3: 00 69
000005E4: 00 67
000005E5: 00 6E
000005E6: 00 6D
000005E7: 00 65
000005E8: 00 6E
FC: A Nyereség.bat hosszabb, mint Profit.bat

Ha a Profit.bat és a Nyereség.bat fájl azonos, az fc parancs a következő üzenetet jeleníti meg:

FC: Nincs különbség.

Az aktuális könyvtárban található összes .bat kiterjesztésű fájl az Új.bat fájllal való összehasonlításához írja be a következő parancsot:

fc *.bat új.bat

A C meghajtón található Új.bat fájl és a D meghajtón található Új.bat fájl összehasonlításához írja be a következő parancsot:

fc c:új.bat d:*.bat

A C meghajtó gyökérkönyvtárában található parancsfájlok a D meghajtó gyökérkönyvtárában található ugyanolyan nevű fájlokkal való összehasonlításához írja be a következő parancsot:

fc c:*.bat d:*.bat


Megjegyzések az Fc parancshoz

Fc

Megjegyzések

A fájlok közötti különbségről szóló jelentés ASCII összehasonlítás esetén

A Windows 2000 fc parancsa ASCII összehasonlítás esetén, ha a két fájl között különbséget talál, megjeleníti az első fájl nevét és a különböző sorokat a fájlnév1 fájlból, majd a két fájlban közös első sort. A Windows 2000 ezután megjeleníti a második fájl nevét és a fájlnév2 fájlból a különböző sorokat, majd az első közös sort.

A /b kapcsoló használata bináris összehasonlításra

Bináris összehasonlítás esetén a Windows 2000 a következő formátumban jeleníti meg a két fájl közötti különbséget:

xxxxxxxx: yy zz

Az xxxxxxxx érték megadja a bájtpár relatív hexadecimális helyzetét a fájl kezdetéhez képest. A címek sorszámozása a 00000000 értéktől kezdődik. A hexadecimális yy és zz paraméterek a fájlnév1 és fájlnév2 fájlok különböző bájtértékeit jelenítik meg.

Helyettesítő karakterek

Az fc parancs használatakor a fájlnevek megadásánál lehet használni helyettesítő karaktereket. Ha a fájlnév1 paraméterben vannak helyettesítő karakterek, a fc a megadott összes fájlt összehasonlítja a fájlnév2 paraméterben megadott fájllal. Ha a fájlnév2 paraméterben vannak helyettesítő karakterek, az fc a fájlnév1 paraméter megfelelő értékét helyettesíti be.

Az fc memórihasználata

ASCII fájlok összehasonlítása esetén az fc egy belső puffert használ a sorok tárolására (100 sor tárolására elegendő terület). Ha a fájlok nagyobbak a puffernél, az fc annyit hasonlít össze, amennyi belefér a pufferbe. Ha az fc nem talál egyező részeket a betöltött fájlrészekben, a futás meg áll, és a következő üzenet jelenik meg:

Az újraszinkronizálás meghiúsult A fájlok túlságosan különbözőek.

Ha a bináris fájlok mérete nagyobb az elérhető memóriánál, az fc fájlrészenként összehasonlítja az egész fájlt a memóriában folyamatosan felülírva a fájlokat. A kimenet azonos a memóriában elférő fájlok esetén kapott kimenettel.


Fcbs

Megadja az MS-DOS alrendszer által egy időben megnyitható fájlvezérlési blokkok (FCB) számát. A fájlvezérlési blokkok száma a rendszergyökér\System32\Config.nt fájlban, vagy az ezzel egyenértékű, a program PIF fájljában megadott indítófájlban adható meg.

A fájlvezérlési blokk olyan adatstruktúra, amely fájlhoz kapcsolódó adatokat tárolja.

fcbs=x

Paraméter

x

Megadja az MS-DOS alrendszer által egy időben megnyitható fájlvezérlési blokkok számát. Az x paraméter érvényes értéke 1 és 255 között lehet. Az alapértelmezett érték a 4.


Példa az Fcbs parancs használatára

Fcbs

Példa

Annak megadásához, hogy az MS-DOS alrendszer egyszerre legfeljebb 8 fájlt nyithat meg, a következő sort írja be a Config.nt fájlba:

fcbs=8


Megjegyzések az Fcbs parancshoz

Fcbs

Megjegyzések

A fájlok megnyitásának korlátja

Ha a program a fájlvezérlési blokkok segítségével az x paraméter értékénél több fájlt próbál megnyitni, az MS-DOS alrendszer a korábban megnyitott fájlokból néhányat bezár.

Az fcbs parancs javasolt használata

Az fcbs parancs használata csak akkor tanácsolt, ha egy programnak szüksége van rá. A legtöbb új programhoz nincs szükség a fájlvezérlési blokkokra. Néhány régi program számára azonban szükséges lehet az fcbs parancs beírása a Config.nt fájlba.


Files

Megadja az MS-DOS alrendszer által egyszerre elérhető fájlok számát. A rendszergyökér\System32\Config.nt fájlban, vagy egy program PIF fájljában megadott indító fájlban adható meg a files paraméter.

files=x

Paraméter

x

Megadja az MS-DOS alrendszer által egyszerre elérhető fájlok számát: Az x paraméter érvényes értéke 8 és 255 között lehet. Az alapértelmezett érték: 8.


Példa a Files parancs használatára

Files

Példa

Ha azt kívánja beállítani, hogy az MS-DOS alrendszer egyszerre legfeljebb 20 fájlt érhessen el, akkor írja be a következő sort a Config.nt fájlba.

files=20


Megjegyzés a Files parancshoz

Files

Megjegyzés

Bár az x paraméter alapértelmezett értéke 8, néhány programnak ennél nagyobb értékre van szüksége. A szokásos beállítás a 20.


Szűrőparancsok

A szűrőparancsok lehetővé teszik a parancs kimenetek rendezését, megjelenítését és részeinek kiválasztását.

Adatátadás szűrőparancsokon keresztül

A szűrőparancsok a részükre átadott adatokat szétosztják, átrendezik vagy részeit kigyűjtik. A Windows 2000 három szűrőparancsot tartalmaz:

  • A more parancs a fájlt vagy a parancs kimenetét képernyőnyi részekre bontva jeleníti meg.
  • A find parancs megkeresi a megadott karaktereket a fájlokban vagy a parancs kimenetében.
  • A sort parancs ábécérendbe rendezi a fájlokat vagy a parancs kimenetét.

Fájlból a kisebb jel (<) segítségével küldhetők bemeneti adatok a szűrőparancs számára. A függőleges vonás (|) karakter segítségével adhatók át adatok a szűrőparancs részére egy másik parancsból.

A megjelenítés vezérlése a More parancs használatával

A more parancs a fájlt vagy a parancs kimenetét képernyőnyi részekre bontva jeleníti meg. Például a következő more parancs a Lista.txt fájl tartalmát laponként jeleníti meg:

more < lista.txt

A képernyőnyi adat megjelenése után a “Tovább” szó jelenik meg. Az adatok következő lapja bármelyik billentyű megnyomásával megjeleníthető. A parancs a CTRL+C billentyűkombináció megnyomásával állítható le.

A more parancs akkor hasznos, ha valamelyik parancs egy képernyőnél több adatot jelenít meg. Például a merevlemez fastruktúrájának megjelenítésekor. Ha több könyvtár jelenik meg, mint amennyit a Windows 2000 egy képernyőn képes megjeleníteni, akkor a tree parancs után adja meg a függőleges vonás (|) és karaktert és a more parancsot is a következő példa szerint:

tree c:\ | more

Megjelenik a tree parancs kimenetének első képernyője, és a képernyő alján a “Tovább” szó látható. A Windows 2000 vár a billentyűzet egy gombjának lenyomásáig (kivéve a PAUSE billentyűt).

Szöveg keresése a find paranccsal

A find parancs egy vagy több fájlban képes egy megadott szöveget megkeresni. A Windows 2000 megjeleníti a megadott szöveget tartalmazó összes sort. A find parancs szűrőparancsként és normál Windows 2000 parancsként is használható. A find parancs normál Windows 2000 parancsként való használatával kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a find témakörre.

A find parancs szűrőparancsként való használatához írja be a kisebb jelet (<) és a fájlnevet, amelyben keresni kíván. Vegye figyelembe, hogy a fájlnév megadásakor a keresés megkülönbözteti a kis- és nagybetűket. Például a következő parancs megkeresi az “EU tagországok” kifejezés minden előfordulását a Kereskedelem.txt fájlban:

find "EU tagországok" < kereskedelem.txt

A find parancs kimenetének fájlba mentéséhez a nagyobb jel (>) megadása után írja be azt a fájlnevet, amelybe a kimenetet akarja menteni. Például a következő parancs megkeresi az “EU tagországok” kifejezés minden előfordulását a Kereskedelem.txt fájlban, és a kimenetet elmenti az Eu.txt fájlban:

find "EU tagországok" < kereskedelem.txt > eu.txt

Szövegfájlok sorbarendezése

A sort parancs ábécérendbe rendez egy szövegfájlt vagy egy parancs kimenetét. Például a lista.txt fájl tartalmának rendezéséhez és képernyőn történő megjelenítéséhez használja a következő parancsot:

sort < lista.txt

Ebben a példában a sort parancs rendezi a Lista.txt fájl sorait, és a fájl megváltoztatása nélkül megjeleníti az eredményt a képernyőn. A sort parancs kimenetének fájlba mentéséhez a nagyobb jel (>) megadása után írja be a fájlnevet. Például a Lista.txt fájl sorainak ábécérendbe rendezéséhez, és az eredmény az abclista.txt fájlba való mentéséhez használja a következő parancsot:

sort < lista.txt > abclista.txt

A parancs kimenetének sorba rendezéséhez a parancs után írjon be egy függőleges vonalat (|) és a sort parancsot. Például a következő parancs rendezi a find parancs kimenetét:

find "János" címek.txt | sort

A parancs kiadásakor a Windows 2000 ábécé sorrendben felsorolja az összes olyan sort, amelyben a “János” karakterlánc megtalálható.

A parancsok kombinálása átirányító karakterek segítségével

A normál parancsok, szűrőparancsok és fájlnevek kombinálásával sokféle parancs felépíthető. Például a “LOG” karakterláncot tartalmazó fájlnevek a következő paranccsal menthetők el:

dir /b | find "LOG" > loglista.txt

A Windows 2000 a dir parancs kimenetét átadja a find szűrőparancsnak, és elmenti a Loglista.txt fájlba azokat a fájlneveket, amelyek tartalmazzák a “LOG” karakterláncot. Az eredmény egy fájlneveket tartalmazó lista (például: A.log, Logok.svd és Újlog.bat).

Egy parancson belül több szűrő használatakor a szűrők elválasztásához használja a függőleges vonás (|) karaktert. Például a következő parancs megkeresi a C meghajtón található összes olyan fájlnevet, amely tartalmazza a “Log” karakterláncot és képernyőnként megjeleníti azokat.

dir c:\ /s /b | find "LOG" | more

A függőleges vonás (|) karakter miatt a Windows 2000 átadja a dir parancs eredményét a find parancsnak. A find parancs kiválasztja azokat a fájlneveket, amelyek tartalmazzák a “Log” karakterláncot. A more parancs a find parancs által kiválasztott fájlneveket képernyőnként megjeleníti a képernyőn.


Find

Megkeresi az adott szöveget a megadott fájl(ok)ban.

A megadott fájlok ellenőrzése után a find parancs megjeleníti a karakterláncot tartalmazó sorokat.

find [/v] [/c] [/n] [/i] "karakterlánc" [[meghajtó:][elérési_útvonal]fájlnév[...]]

Paraméterek

/v

Megjeleníti az összes olyan sort, amely nem tartalmazza a megadott karakterláncot.

/c

Csak a megadott karakterláncot tartalmazó sorok számát jeleníti meg.

/n

A megjelenített sorok fájlon belüli sorszámát jeleníti meg.

/i

Megadja, hogy a keresés során a parancs a kis- és nagybetűket ne különböztesse meg.

"karakterlánc"

Megadja a keresni kívánt karakterláncot. A karakterláncot idézőjelek közé kell írni.

[meghajtó:][elérési_útvonal] fájlnév

Megadja annak a fájlnak a helyét és nevét, amelyben a parancs keresni fog.


Példák a Find parancs használatára

Find

Példák

A Ceruza.ad fájlban a „ceruzahegyező” szót tartalmazó sorok megjelenítéséhez írja be a következő parancsot:

find "ceruzahegyező" ceruza.ad

Idézőjeleket tartalmazó szöveg kereséséhez, először a teljes szöveget idézőjelek közé kell írni, másodszor a szövegben előforduló minden idézőjel helyett két idézőjelet kell írni, a következő példa szerint:

find "A tudósok a publikációt ""csak megbeszélésre"" minősítéssel látták el. Ez nem egy végleges jelentés." jelentés.doc

Több fájlban történő kereséshez használja a find parancsot a for paranccsal együtt. A következő parancs először megkeresi a .bat kiterjesztésű fájlokat az aktuális könyvtárban, majd ezekben megkeresi a „PROMPT” szót:

for %f in (*.bat) do find "PROMPT" %f

A find paranccsal a C meghajtón megkereshető és megjeleníthető az összes olyan fájlnév, amely tartalmazza a „CPU” karakterláncot. Ehhez használja a függőleges vonás (|) karaktert a dir parancs eredményének átadásához a find parancs számára a következő példa szerint:

dir c:\ /s /b | find "CPU"

Mivel a find parancs megkülönbözteti a kis- és nagybetűket, valamint a dir parancs nagybetűs kimenetet ad, ezért csupa nagybetűvel kell írni a "CPU" karakterláncot, vagy használni kell az /i kapcsolót a find paranccsal.


Megjegyzések a Find parancshoz

Find

Megjegyzések

A karakterlánc megadása

Ha az /i kapcsoló nincs megadva, a find pontosan a megadott karakterláncot keresi. Például a find parancs számára az “a” és az “A” karakterek különbözőek. Az /i kapcsoló megadása esetén azonban a find parancs nem különbözteti meg a kis- és nagybetűket, azaz az “a” és az “A” karakter megegyezik.

Ha a keresett szöveg idézőjeleket tartalmaz, minden ilyen esetben két idézőjelet kell írni.

A find parancs használata szűrőparancsként

Ha nincs megadva a fájlnév, a find a normál Windows 2000 bemenetet használja (általában a billentyűzet, a függőleges vonal, vagy egy átirányított fájl) és a karakterláncot tartalmazó összes sort megjeleníti.

A parancs sorrendje

A paraméterek és kapcsolók bármely sorrendben megadhatók a find parancs esetében.

Helyettesítő karakterek használata a find paranccsal

A find parancshoz megadott fájlnevek és kiterjesztések esetén nem használhatók helyettesítő karakterek (? és *). Helyettesítő karakterekkel megadott fájlokban kereséshez használja a find parancsot a for paranccsal.

A /v vagy /n kapcsoló használata a /c kapcsolóval

A /c és a /v kapcsolók együttes megadása esetén a find parancs a megadott karakterláncot nem tartalmazó sorok számát jeleníti meg. A /c és az /n kapcsolók együttes megadása esetén a find parancs figyelmen kívül hagyja az /n kapcsolót.

A find parancs használata sortörést tartalmazó fájlok esetén

A find parancs nem ismeri fel a kocsivissza karaktert. A find parancs kocsivissza karaktert tartalmazó fájllal történő használatakor a keresni kívánt szöveget úgy kell megadni, hogy ne tartalmazza a kocsivissza karaktert, azaz a karakterláncot ne szakítsa meg sortörés. Például a find parancs nem találja meg az “adónemek fájl” szöveget, ha az “adónemek” és a “fájl” szavak között kocsivissza karakter van.


Findstr

A fájlokban megkeres egy adott karakterláncot, amely lehet hagyományos szöveg vagy szabályos kifejezés. A findstr parancs által a szabályos kifejezésekben elfogadott jelekkel kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson a Megjegyzések a Devinfo parancshoz témakörre.

findstr [/b] [/e] [/l] [/c:karakterlánc] [/r] [/s] [/i] [/x] [/v] [/n] [/m] [/o] [/g:fájl] [/f:fájl] [/d:könyvtárlista] [/a:szín_attribútum] [karakterláncok] [[meghajtó:][elérési_útvonal] fájlnév [...]]

Paraméterek

/b

A sor elején keresi a mintát.

/e

A sor végén keresi a mintát.

/l

A keresendő karakterláncot betű szerint értelmezi.

/c: karakterlánc

A megadott szöveget betű szerinti keresendő karakterláncként értelmezi.

/r

A megadott karakterláncot szabályos kifejezésként értelmezi. Ezt a kapcsolót nem kötelező megadni, mert a findstr minden metakaraktert szabályos kifejezésként értelmez, ha a /l kapcsoló nincs megadva.

/s

A megfelelő fájlokat az aktuális könyvtárban és annak minden alkönyvtáraiban keresi.

/i

Megadja, hogy a keresés során a parancs a kis- és nagybetűket ne különböztesse meg.

/x

Kiírja a pontosan egyező sorokat.

/v

Azokat a sorokat írja ki, amelyek nem felelnek meg a keresésnek.

/n

A sorok elejére a sorszámot is kiírja.

/m

A fájlnevet csak akkor jeleníti meg, ha a fájl tartalmaz egyező részt.

/o

Minden megfelelő sor elé kiírja a keresési eltolást.

/g fájl

A keresendő karakterláncokat a megadott fájlból olvassa be.

/f fájl

A fájlok listáját a megadott fájlból olvassa be.

/d könyvtárlista

A vesszővel elválasztott könyvtárakban keres.

/a szín_attribútum

A szín attribútumot adja meg két hexadecimális számjeggyel.

Szóközzel válassza el a keresni kívánt karakterláncokat, ha az argumentumot nem előzi meg a /c előtag, a következő példa szerint:

findstr "helló világ" x.y

A fenti parancs a „helló” vagy a „világ” szavakat keresi az x.y nevű fájlban. A következő parancs azonban a „helló világ” karakterláncot keresi az x.y fájlban:

findstr /c:"helló világ" x.y


Példák a Findstr parancs használatára

Findstr

Példák

A „Windows” szó (nagy kezdőbetűvel) minden előfordulása a következő paranccsal kereshető meg a Javaslat.txt fájlban:

findstr Windows javaslat.txt

A Windows szó (a nagy- és kisbetűk közötti különbség figyelmen kívül hagyásával) a következő paranccsal kereshető meg az aktuális könyvtárban és annak alkönyvtáraiban levő fájlokban:

findstr /s /i Windows *.*

A „FOR” szó minden előfordulásának megkereséséhez úgy, hogy bármennyi szóköz lehet előtte (mint egy programciklusban), és az adott sor sorszámának megjelenítéséhez írja be:

findstr /b /n /c:" *FOR" *.bas

Ugyanazon fájlokban több keresés is végrehajtható. Ehhez szükség van egy olyan fájlra, amely a keresési feltételeket soronként tartalmazza. A keresésbe bevonni kívánt fájlok is pontosan megadhatók egy szövegfájlban. A következő parancs a Keresésadat.txt fájlban található kritériumok alapján keres a Fájllista.txt fájlban található fájlokban, és az eredményt az Eredmény.out nevű fájlban tárolja:

findstr /g:keresésadat.txt /f:fájllista.txt > eredmény.out

Megkereshető az összes olyan fájl az aktuális könyvtárban vagy annak alkönyvtáraiban, amely tartalmazza a számítógép szót a kis- és nagybetűk közötti különbség figyelmen kívül hagyásával. A számítógép szót tartalmazó összes fájl a következő parancs segítségével sorolható fel:

findstr /s /i /m "\<számítógép\>" *.*

Nem csak a „számítógép” szó kereshető meg, hanem minden olyan szó, amely a „szám” betűkkel kezdődik, mint például a „számítás” és a „számonkérés”. Írja be:

findstr /s /i /m "\<szám.*" *.*


Megjegyzések a Findstr parancshoz

Findstr

Megjegyzések

A Findstr paranccsal bármilyen szöveg megkereshető az ASCII fájlban vagy fájlokban. Néha azonban a keresett adatoknak csak egy része ismert, vagy szélesebb körű információ keresése szükséges. Ilyenkor a findstr képes szabályos kifejezések használatával szövegmintákat keresni.

A szabályos kifejezések olyan jelöléseket használnak, amelyekkel szövegminták adhatók meg, a szövegben levő karakterek pontos megadása helyett. Ez a jelrendszer hagyományos és metakaraktereket használ. Minden olyan karakter, amelynek az adott szintaxisban nincsen speciális jelentése, hagyományos karakternek számít, és ennek a karakternek az előfordulását keresi a parancs. Például a betűk és számok hagyományos karakterek. A metakarakter speciális jelentéssel bíró jel (egy művelet vagy elválasztójel) a szabályos kifejezés szintaxisában. A findstr parancs által elfogadott metakarakterek a következők:

. | Helyettesítő karakter: bármilyen karakter
* | Ismétlés: az előző karakter vagy osztály nulla vagy több előfordulása
^ | Sorbeli elhelyezkedés: sor eleje
$ | Sorbeli elhelyezkedés: sor vége
[osztály] | Karakterosztály: a készlet bármely karaktere
[^osztály] | Invertált osztály: a készletben nem található bármely karakter
[x-y] | Tartomány: bármely karakter a megadott tartományban
\x | Escape: a metakarakter hagyományos karakterként való értelmezése x
\<xyz | Szóbeli elhelyezkedés: szó eleje
xyz\> | Szóbeli elhelyezkedés: szó vége

A szabályos kifejezésekben a speciális karakterek együtt használva a leghatásosabbak. Például a helyettesítő karakter (.) és az ismétlő karakter (*) következő kombinációjának:

.*

bármely karakterlánc megfelel. Ez a kifejezés nagyobb kifejezés részeként is használható:

c.*ás

Ennek a karakterláncnak megfelel minden „C”-vel kezdődő és „ás”-sal végződő karakterlánc.


Finger

A Finger szolgáltatás segítségével megjeleníti egy adott rendszer felhasználójának adatait. A kimenet függ a távoli rendszertől. Ez a parancs csak a TCP/IP protokoll telepítése esetén használható.

finger [-l] [felhasználó]@számítógép[...]

Paraméterek

-l

Az adatokat hosszú lista formátumban jeleníti meg.

felhasználó

Megadja a felhasználót, akiről az adatokat kéri. A felhasználó paraméter kihagyása esetén a parancs az adott számítógép összes felhasználójáról jelenít meg adatokat.

@számítógép


For

Futtatja a megadott parancsot fájlok egy adott halmazának minden fájljára.

A for parancs parancsfájlban is használható, vagy közvetlenül a parancssorban is kiadható.

A for parancs fájlban történő használatához használja a következő szintaxist:

for %%változó in (halmaz) do parancs [parancs_paraméterek]

A for parancs parancssorban történő használatához használja a következő szintaxist:

for %változó in (halmaz) do parancs [parancs_paraméterek]

Paraméterek

%%változó vagy %változó

Helyettesíthető paramétert jelöl. A for parancs behelyettesíti a %%változó (vagy %változó) helyére a halmazban megadott összes karakterláncot mindaddig, amíg a parancs_paraméterekben megadott parancs feldolgozza az összes fájlt. A %%változó használatával a for parancs parancsfájlokban használható. A %változó használatával a for parancs parancssorban használható. A változónevek esetében a kis- és nagybetűk különbözőek.

(halmaz)

A megadott parancs által feldolgozandó fájlokat vagy szöveges karakterláncokat ad meg. A zárójeleket kötelező használni.

parancs

A meghatározott halmazban lévő fájlokra végrehajtani kívánt parancsot adja meg.

parancs_paraméterek

Megadja a paranccsal használni kívánt paramétereket és kapcsolókat (ha a megadott parancsnak vannak paraméterei vagy kapcsolói).

A parancskiterjesztések engedélyezése esetén (a Windows 2000 alapértelmezett beállítása) a for parancs további formái is használhatók.


A For parancs további formátumai

A parancskiterjesztések engedélyezése esetén a for parancs következő formátumai is használhatók:

csak könyvtárak esetén

for /D [%% | %]változó in (halmaz) do parancs [parancs_paraméterek]

Ha a halmaz paraméter helyettesítő karaktereket tartalmaz (* és ?), akkor fájlnevek helyett a megfelelő könyvtárneveket keresi a program.

Rekurzív

for /R [[meghajtó:]elérési_útvonal] [%% | %]változó in (halmaz) do parancs [parancs_paraméterek]

Végig megy a [meghajtó:]elérési_útvonal paraméter által megadott könyvtár alatt található könyvtárfán, és minden könyvtárban végrehajtja a for utasítást. Ha az /R paraméter után nincs könyvtár megadva, a parancs az aktuális könyvtárat használja. Ha a halmaz paraméter csak egy pont (.), a parancs csak végigmegy a könyvtárfán.

Iterációs

for /L [%% | %]változó in (első,lépésköz,utolsó) do parancs [parancs_paraméterek]

Ez esetben a halmaz egy számsorozat, amely az 'első' számmal kezdődik, az 'utolsó' számmal ér véget és a számok 'lépésközönként' követik egymást. Tehát az (1,1,5) számhármas az (1 2 3 4 5) sorozatot adja meg, az (5,-1,1) számhármas az (5 4 3 2 1) sorozatot adja meg.

Fájltördelés

for /F [”beállítások”] [%% | %]változó in (fájlnév_halmaz) do parancs [parancs_paraméterek]

for /F [”beállítások”] [%% | %]változó in (”normál karakterlánc”) do parancs [parancs_paraméterek]

for /F [”beállítások”] [%% | %]változó in ('parancs') do parancs [parancs_paraméterek]

vagy, ha a usebackq beállítás használható:

for /F [”beállítások”] [%% | %]változó in (fájlnév_halmaz) do parancs [parancs_paraméterek]

for /F [”beállítások”] [%% | %]változó in (”normál karakterlánc”) do parancs [parancs_paraméterek]

for /F [”beállítások”] [%% | %]változó in ('parancs') do parancs [parancs_paraméterek]

A fájlnévhalmaz egy vagy több fájlnevet ad meg. A parancs megnyitja, beolvassa és feldolgozza az összes fájlt a fájlnév_halmazban lévő következő fájlra való átlépés előtt.

A fájl feldolgozása során a fájl beolvasása után a parancs a fájlt szövegsorokra bontja, majd szétbontja nulla, vagy több alapelemre. A for hurok törzse ezután az alapelemként megtalált karakterlánco(ka)t használja a változó(k) értékeként. Alapértelmezésben az /F paraméter minden fájl minden sorának első üres elkülönített alapelemét adja át.

Az üres sorokat átugorja a parancs. Az alapértelmezett elemzési viselkedés megváltoztatható a választható „options” paraméterrel. Ez idézőjelek közé írt karakterlánc, amely a különböző elemzési lehetőségeket egy vagy több kulcsszóval állítja be. A kulcsszavak a következők:

Kulcsszó | Leírás
eol=c | megadja a sorvégi megjegyzés karaktert (csak egy karakter)
skip=n | megadja a sor elején átugrandó sorok számát.
delims=xxx | Meghatározza a listaelválasztó-készletet. Ez helyettesíti a szóközből és tabulátorból álló alapértelmezett elválasztókészletet.
tokens=x,y,m-n | megadja, hogy mely alapelemeket adja át a parancs a for utasítás törzsének. Ez további változó nevek lefoglalását eredményezi. Az m-n formátum egy tartományt ad meg. Az m. és az n. alapelem közötti alapelemeket adja át a parancs törzsének. Ha a tokens= karakterlánc utolsó karaktere a csillag, a sor utolsó elemzett alapelemén túl eső része egy újabb változóba kerül.
usebackq | Megadja, hogy az idézőjelben lévő karakterláncot parancsként kell végrehajtani. Az aposztrófok közé írt karakterlánc egy normál karakterlánc parancs. A fájlnévhalmazban a fájlneveket dupla idézőjelek közé kell írni.

Változócsere

A for parancs változóhivatkozásaihoz használható helyettesítő módosítók is fejlődtek. Ezentúl a következő választható szintaxis is használható (bármely I változó esetén):

Változó (módosítóval) | Leírás
%~I | Az %I változót idézőjelek nélkül bontja ki.
%~fI | Az %I változó a teljesen megadott elérési útvonal értéket veszi fel.
%~dI | Az %I változó csak a meghajtóbetűjel értéket veszi fel.
%~pI | Az %I változó csak az elérési útvonal értékét veszi fel.
%~nI | Az %I változó csak a fájlnév értékét veszi fel.
%~xI | Az %I változó csak egy fájl kiterjesztésének értékét veszi fel.
%~sI | Az elérési utvonalat úgy bontja ki, hogy csak rövid neveket tartalmazzon.
%~aI | Az %I változó a fájl fájlattribútumainak értékét veszi fel.
%~tI | Az %I változó a fájl dátumának és időpontjának értékét veszi fel.
%~zI | Az %I változó a fájl méretének értékét veszi fel.
%~$PATH:I | Átvizsgálja a PATH környezeti változóban megadott könyvtárakat, és az %I változó az első megtalált fájl teljesen megadott elérési útvonalának értékét veszi fel. Ha a környezeti változó neve nincs megadva, vagy a fájl nem található, ez a módosító az üres értéket veszi fel.

A módosítók kombinálásával összetett eredmények is létrehozhatók:

Változó (kombinált módosítóval) | Leírás
%~dpI | Az %I változó a meghajtó betűjelének és az elérési útvonalnak az értékét veszi fel.
%~nxI | Az %I változó a fájl nevének és kiterjesztésének értékét veszi fel.
%~fsI | Az %I változó a csak rövid nevekkel megadott teljes elérési útvonal értékét veszi fel.
%~dp$PATH:I | Elkezdi az %I változóban megadott fájlt keresni a PATH környezeti változóban megadott könyvtárakban, és az %I paraméter az első megtalált fájl meghajtóbetűjelének és elérési útvonalának értékét veszi fel.
%~ftzaI | Az %I változót egy dir-szerű kimeneti sorrá bontja ki.

Megjegyzések

  • A fenti példákban az %I és a PATH változók bármely érvényes értékkel helyettesíthetők. A %~ szintaxis végén mindig egy érvényes for változónévnek kell szerepelnie.
  • Nagybetűs változónevek használata esetén (mint %I) a programkód jobban olvashatóvá válik, és elkerülhető a módosítókkal való összekeverésük, amelyek nem különböztetik meg a kis- és nagybetűket.


Példák a For parancs használatára

For

Példák

Könyvtárban lévő fájlok megjelenítése

A következő módszerrel a type parancs segítségével megjeleníthető az aktuális könyvtárban lévő összes .doc vagy .txt kiterjesztésű fájl tartalma. Ehhez a %f behelyettesíthető változó használatával írja be a következő parancsot a parancssorba:

for %f in (*.doc *.txt) do type %f

Ebben a példában minden, az aktuális könyvtárban található .doc és .txt kiterjesztésű fájl behelyettesítésre kerül a %f változóba, és a parancs minden ilyen fájlt megjelenít. A parancs parancsfájlban történő használatakor helyettesítse a %f paramétert mindenhol a %%f paraméterrel. Egyébként a Windows 2000 figyelmen kívül hagyja a változót, és hibaüzenetet jelenít meg.

Kimenet átirányítása nyomtatóra

A Windows 2000 támogatja az adott paranccsal használt parancskapcsolókat, függőleges vonalat és átirányítást. Például az előző példában szereplő parancs kimenetének nyomtatóra irányításához írja be a következő parancsot:

for %f in (*.doc *.txt) do type %f > prn:

Fájlelemzés

Egy fájl elemzéséhez (a megjegyzéssorok figyelmen kívül hagyásával) a következő parancs használható:

for /F "eol=; tokens=2,3* delims=," %i in (fájl.txt) do @echo %i %j %k

Ez a parancs elemzi a fájl.txt fájl minden sorát, figyelmen kívül hagyva a pontosvesszővel kezdődő sorokat, és átadja minden sor második és harmadik alapelemét a for parancs törzsének vesszővel és/vagy szóközzel elválasztva az alapelemeket. A FOR utasítás törzse az %i változóval hivatkozik a második alapelemre, a %j változóval hivatkozik a harmadik alapelemre és a %k változóval hivatkozik a fennmaradó alapelemekre. Szóközöket tartalmazó fájlnevek esetén a fájlneveket idézőjelek közé kell helyezni. Az idézőjelek ilyen módon történő használatához a usebackq beállítást kell használni, egyébként az idézőjeleket úgy értelmezi a rendszer, mint normál karakterláncot megadó kifejezést.

A %i paraméter ténylegesen szerepel a FOR utasításban, és a %j és a %k paramétereket a tokens= beállítás definiálja. A tokens= sor használatával legfeljebb 26 alapelem adható meg, feltéve, hogy az nem próbál meg a 'z' vagy 'Z' betűnél magasabb változót létrehozni.

Figyeljen arra, hogy a for változói megkülönböztetik a kis- és nagybetűket, és egy időben nem lehet 52-nél több aktív változó.

Karakterlánc elemzése

A for /F elemzési logika közvetlenül alkalmazható karakterláncra is, ha a zárójelben lévő fájlnévhalmaz paraméter értékeként egy idézőjelekkel közrezárt karakterláncot ad meg. A parancs ezt egyetlen sor bementként értelmezi és elemzi.

Kimenet elemzése

Végezetül a for /F parancs egy parancs kimenetének elemzésére is használható. Ennek végrehajtásához a zárójelek között lévő fájlnévhalmaz paraméter értékeként egy idézőjelbe tett szöveget kell megadni. Ezt a rendszer parancssorként kezeli, amelyet átad egy utód Cmd.exe fájlnak és a kimenet a memóriába kerül, amit a parancs azután úgy elemez, mintha egy fájl lenne. Tehát a következő példa:

for /F "usebackq delims==" %i IN (`halmaz`) DO @echo %i

Ez a parancs felsorolja az aktuális környezet környezeti változóit.


Megjegyzések a For parancshoz

For

Megjegyzések

Az in és a do kulcsszavak használata

Az In és a do kulcsszavak nem paraméterek, hanem a for parancs részei. Ha ezen kulcsszavak valamelyike nincs megadva, a Windows 2000 hibaüzenetet jelenít meg.

A helyettesíthető változó használata

A parancsfájlok %0 és %9 közötti paramétereitől való megkülönböztetés érdekében bármilyen karakter használható a változó paraméterben a számok kivételével (0-9). Egyszerű parancsfájlok esetében a %%f paraméter használata is elegendő.

Összetett parancsfájlokban több érték is használható a paraméter számára a különböző helyettesíthető változók megkülönböztetésének érdekében.

Fájlcsoport megadása

A halmaz paraméter megadhat egy vagy több fájlcsoportot. Helyettesítő karakterek (* és ?) is használhatók a fájlhalmaz megadásához. A következő példák érvényes fájlhalmazt jelölnek:

(*.doc)
(*.doc *.txt *.me)
(jan*.doc jan*.rpt feb*.doc feb*.rpt)
(ar??1991.* ap??1991.*)

A for parancs használatakor a halmaz paraméter első értékét helyettesíti be a parancs a %%változó (vagy %változó) értékeként, és a Windows 2000 végrehajtja a megadott parancsot ezen érték feldolgozásához. Ez mindaddig ismétlődik, amíg a Windows 2000 feldolgozza a halmaz paraméter értékének megfelelő összes fájlt (vagy fájlcsoportot).


Forcedos

A megadott programot az MS-DOS alrendszerben indítja el. Ez a parancs csak azon MS-DOS programok esetén szükséges, amelyeket a Windows 2000 nem ismer fel.

forcedos [/d könyvtár] fájlnév [paraméterek]

Paraméterek

/d könyvtár

Megadja a program által használandó aktuális könyvtárat.

fájlnév

Megadja az elindítandó programot. Ha a program nincs az aktuális könyvtárban vagy a PATH változóban megadott könyvtárban, meg kell adni a programhoz tartozó meghajtót és elérési útvonalat.

paraméterek

Megadja a program paramétereit.


Példa a Forcedos parancs használatára

Forcedos

Példa

A \Régialk könyvtárban található Saját nevű program elindításához a \Jelentés könyvtár használatával:

forcedos /d jelentés \régialk\saját


Megjegyzések a Forcedos parancshoz

Forcedos

Megjegyzések

Néhány MS-DOS programot a Windows 2000 nem ismer fel MS-DOS programként. A forcedos parancs segítségével ezen programok is elindíthatók.

A forcedos paranccsal elindított programokat MS-DOS alkalmazásként nyitja meg a Windows 2000.


Format

A megadott kötetben lévő lemezt olyan formátumúra formázza, hogy az elfogadja a Windows 2000 fájlokat. Merevlemezt csak a Rendszergazdák csoport tagjai formázhatnak.

format kötet [ /fs:fájlrendszer] [/v:címke] [/q] [/a:egységméret] [/f:méret] [/t:sávok/n:szektorok] [/c] [/x] [/1] [/4] [/8]

Paraméterek

kötet:

Megadja a formázni kívánt meghajtó csatlakozási pontját, kötetnevét vagy meghajtóbetűjelét. Ha a következő kapcsoló egyike sincs megadva, a format parancs a kötet típusa alapján állapítja meg a lemez alapértelmezett formátumát.

/fs:fájlrendszer

Megadja a használni kívánt fájlrendszert: FAT, FAT32 vagy NTFS. A hajlékonylemezek csak a FAT fájlrendszert használhatják.

/v:címke

Megadja a kötetcímkét. Ha a /v kapcsoló nincs megadva, vagy címke nélkül szerepel a parancsban, a Windows 2000 a formázás befejezése után kéri a kötetcímke megadását. A /v: szintaxis használatával megelőzhető a kötetcímkére vonatkozó kérdés megjelenítése. Ha ugyanazzal a format paranccsal több lemezt formáz, mindegyik lemeznek ugyanaz lesz a kötetcímkéje. A /v kapcsoló nem kompatíbilis a /8 kapcsolóval. Kötetcímkékkel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a Dir, Label és Vol című témakörre.

/a:egységméret

Meghatározza a FAT, FAT32 vagy NTFS kötetek lefoglalási egységméretét. Egységméretként a következő értékek használhatók. Ha az egységméret nincs megadva, a parancs a kötet mérete szerint választja azt meg.

512 | 512 bájtot hoz létre szektorcsoportonként.
1024 | 1024 bájtot hoz létre szektorcsoportonként.
2048 | 2048 bájtot hoz létre szektorcsoportonként.
4096 | 4096 bájtot hoz létre szektorcsoportonként.
8192 | 8192 bájtot hoz létre szektorcsoportonként.
16K | 16 kilobájtot hoz létre szektorcsoportonként.
32K | 32 kilobájtot hoz létre szektorcsoportonként.
64K | 64 kilobájtot hoz létre szektorcsoportonként.

/q

Törli a fájltábláját és a gyökérkönyvtárát az előzőleg formázott kötetnek, de nem keres a lemezen hibás szektorokat. A /q kapcsoló csak előzőleg formázott, jó állapotban lévő köteten használható.

/f:méret

Megadja a formázni kívánt hajlékonylemez méretét. Ha lehetséges, a /t és az /n kapcsolók helyett használja ezt a kapcsolót. Méretként a következő értékek használhatók:

160, 160k vagy 160kb
160 Kb-os, egyoldalas, dupla sűrűségű, 5,25 hüvelykes lemezhez;

180, 180k vagy 180kb
180 Kb-os, egyoldalas, dupla sűrűségű 5,25 hüvelykes lemezhez;

320, 320k vagy 320kb
320 Kb-os, két oldalas, dupla sűrűségű, 5,25 hüvelykes lemezhez;

360, 360k vagy 360kb
360 Kb-os, kétoldalas, dupla sűrűségű 5,25 hüvelykes lemezhez;

720, 720k vagy 720kb
720 Kb-os, kétoldalas, dupla sűrűségű, 3,5 hüvelykes lemezhez;

1200, 1200k, 1200kb, 1.2, 1.2m vagy 1.2mb
1,2 Mb-os, kétoldalas, négyszeres sűrűségű 5,25 hüvelykes lemezhez;

1440, 1440k, 1440kb, 1.44, 1.44m vagy 1.44mb
1,44 Mb-os, kétoldalas, négyszeres sűrűségű, 3,5 hüvelykes lemezhez;

2880, 2880k, 2880kb, 2.88, 2.88m vagy 2.88mb
2,88 Mb-os, két oldalas, 3,5 hüvelykes lemezhez;

20.8, 20.8m vagy 20.8mb
20,8 Mb-os, 3,5 hüvelykes optomágneses hajlékonylemezhez

/t:sávok

Megadja a sávok számát a lemezen. Ha lehet, ezen kapcsoló helyett használja az /f kapcsolót. A /t kapcsolóval együtt használni kell az /n kapcsolót is. Ez a két kapcsoló egy másik lehetőséget nyújt a formázandó lemez méretének megadására. Az /f kapcsoló nem használható a /t kapcsolóval együtt.

/n:szektorok

Megadja a szektorok sávonkénti számát. Ha lehet, ezen kapcsoló helyett használja az /f kapcsolót. A /t kapcsolóval együtt használnia kell az /n kapcsolót is. Ez a két kapcsoló egy másik lehetőséget nyújt a formázandó lemez méretének megadására. Az /f kapcsoló nem használható a /t kapcsolóval együtt.

/c

Az új köteten létrehozott fájlokat alapértelmezés szerint tömöríti a rendszer.

/x

Formázás előtt leválasztja a kötetet, ha szükséges. A kötet nyitott leírói érvénytelenek lesznek.

/1

A hajlékonylemez egyik oldalát formázza csak meg.

/4

Az 1,2 Mb-os meghajtóban egy 5,25 hüvelykes, 360 Kb-os, kétoldalas, dupla sűrűségű lemezt formáz meg. Néhány 360 Kb-os meghajtó nem tudja megbízhatóan olvasni ezeket a lemezeket. Az /1 kapcsolóval együtt használva, ez a kapcsoló egy 5,25 hüvelykes, 180 Kb-os, egyoldalas lemezt formáz meg.

/8

Egy 5,25 hüvelykes lemezt formáz meg úgy, hogy sávonként 8 szektor legyen rajta. Ez a kapcsoló úgy formázza meg a lemezt, hogy az kompatíbilis legyen az MS-DOS 2.0 előtti verzióval.


Példák a Format parancs használatára

Format

Példák

Új hajlékonylemez az A meghajtóban az alapértelmezett méretűre a következő paranccsal formázható meg:

format a:

Előzőleg már formázott lemezen az A meghajtóban a következő paranccsal végezhető gyorsformázás:

format a: /q

Az A meghajtóban levő hajlékonylemez a következő paranccsal formázható meg az „ADAT” kötetcímkével:

format a: /v:ADAT


Megjegyzések a Format parancshoz

Format

Megjegyzések

A Format parancs használata

A format parancs új gyökérkönyvtárat és fájlrendszert hoz létre a lemezen. Ezenkívül megkeresheti a lemezen található hibás szektorokat, illetve törölheti a lemezen található összes adatot. Ahhoz, hogy a Windows 2000 használni tudjon egy új lemezt, először formázni kell ezzel a paranccsal.

Kötetcímke megadása

A hajlékonylemez formázása után a következő üzenet jelenik meg:

Kötetcímke (11 karakter vagy ENTER, ha nincs)

A kötetcímke maximum 11 karakter lehet (szóközökkel együtt). Ha nem kíván kötetcímkét megadni, csak nyomja meg az ENTER billentyűt. A kötetcímkékkel kapcsolatos további tudnivalókért a Kapcsolódó témakörök között kattintson a label című témakörre.

Merevlemez formázása

Merevlemez format paranccsal történő formázásakor a Windows 2000 a következő üzenetet jeleníti meg a formázás megkezdése előtt:

VIGYÁZAT: Az összes adat a nem cserélhető meghajtón
(x:) törlődik!
Folytatja a formázást (I/N)?_

A merevlemez formázásához nyomja le az I billentyűt. A formázás megszakításához nyomja meg az N billentyűt. Merevlemez csak rendszergazdai engedéllyel formázható.

Egységméret

A FAT fájlrendszerben a szektorcsoportok száma nem lehet nagyobb, mint 65526. A FAT32 fájlrendszerben a szektorcsoportok számának 65527 és 268435445 között kell lennie.

Az NTFS tömörítés használata nem támogatott 4096-nál nagyobb egységméret esetén.

A Format parancs üzenetei

A formázás befejezése után a Windows 2000 megjeleníti a teljes lemezterületet, a hibás területet és a fájlok által használható területet.

Gyorsformázás

A formázási folyamat felgyorsítható a /q kapcsoló segítségével. Ezt a kapcsolót csak abban az esetben használja, ha nincsenek hibás szektorok a merevlemezen.

A format parancs használata virtuális és hálózati meghajtókkal

A format parancs nem használható a subst paranccsal létrehozott meghajtón. Hálózaton keresztül nem formázhatók a lemezek.

A format parancs kilépési kódjai

Az alábbi lista az összes kilépési kódot és jelentésüket tartalmazza:

0 | A formázási művelet sikeresen befejeződött.
1 | A megadott paraméterek hibásak.
4 | Súlyos hiba történt (a 0, 1, 5 hibakódoktól eltérő minden hiba).
5 | A felhasználó az N billentyűt nyomta meg a „Folytatja a formázást (I/N)” kérdésre a formázás megszakításához.

Ezek a kilépési kódok az errorlevel feltétel használatával lekérdezhetők a parancsfájl if utasításával.


Ftp

Fájlokat visz át két számítógép között, FTP-kiszolgáló szolgáltatás (más néven démon) futtatásával. Az ftp parancs interaktívan használható. A rendelkezésre álló ftp alparancsok leírásáért a Kapcsolódó témakörök között kattintson a kívánt ftp alparancsra. Ez a parancs csak a TCP/IP protokoll telepítése esetén érhető el. Az ftp szolgáltatás az elindításakor létrehoz egy alkörnyezetet, amelyben az ftp parancsokat használhatja, és amelyből a quit alparancs beírásával térhet vissza a Windows 2000 parancssorába. Az ftp alkörnyezet futását az ftp parancssor jelzi.

ftp [-v] [-n] [-i] [-d] [-g] [-s:fájlnév] [-a] [-w:ablakméret] [számítógép]

Paraméterek

-v

Felfüggeszti a távoli kiszolgáló válaszainak megjelenítését.

-n

Felfüggeszti az automatikus bejelentkezést a kapcsolódás kezdetekor.

-i

Többszörös fájlátvitel folyamán kikapcsolja az interaktív rákérdezést.

-d

Engedélyezi a hibakeresést, megjeleníti a kiszolgáló és az ügyfél között átadott összes ftp parancsot.

-g

Leállítja a fájlnév globbolását, amely lehetővé teszi a helyettesítő karakterek (* és ?) használatát a helyi fájlok és elérési útvonalak nevében. (A glob paranccsal kapcsolatos tudnivalókért tanulmányozza az on-line Parancsmutatót.)

-s:fájlnév

Meghatározza az ftp parancsokat tartalmazó szövegfájlt, a parancs az ftp elindulásakor automatikusan fut. Ebben a paraméterben nem állhat szóköz. Az átirányítás (>) helyett használja ezt a kapcsolót.

-a

Adatkapcsolat kötésekor használja valamelyik helyi összeköttetést.

-w:ablakméret

Felülbírálja az átviteli puffer alapértelmezett méretét (4096).

számítógép

Meghatározza annak a számítógépnek a számítógépnevét vagy IP-címét, amelyhez kapcsolódni kíván. A számítógépnek, ha megadja azt, a sor utolsó paraméterének kell lennie.


Ftp: append

Az aktuális fájltípus-beállítások használatával hozzáfűz egy helyi fájlt a távoli számítógép egy fájljához.

append helyi_fájl [távoli_fájl]

Paraméterek

helyi_fájl

Meghatározza a hozzáadni kívánt helyi fájlt.

távoli_fájl

Meghatározza a távoli számítógépen azt a fájlt, amelyhez a helyi_fájlt hozzáadja. Ha nem ad meg távoli_fájlt, akkor a helyi fájl nevét használja a távoli fájl neveként.


Ftp: ascii

Az átvitel típusát ASCII típusúra állítja, alapértelmezett beállítás.

ascii

Megjegyzések

  • Az FTP két átviteltípus (ASCII és bináris kép) használatát támogatja. Az ASCII típus használata szövegfájlok átviteléhez ajánlott. A bináris fájlátvitellel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témakörök Ftp: binary című témakörét.

    ASCII módban a rendszer karakterkonvertálást hajt végre a hálózat szabványos karakterkészletére és vissza. Például a sorvég karaktereket a célként szereplő operációs rendszertől függően szükség esetén konvertálja a parancs.


Ftp: !

Kilépés az ftp alrendszerből a rendszerhéjba.

!

Megjegyzés

  • A parancsnak nincsenek paraméterei. Akkor használja, ha befejezte az ftp parancsok használatát, és vissza kíván térni a Windows 2000 rendszerhéjba.


Ftp: bell

Minden befejezett fájlátvitel után megszólaltat egy csengőt. Alaphelyzetben a csengő nincs bekapcsolva.

bell


Ftp: binary

Az átvitel típusát binárisra állítja be.

binary

Megjegyzés

  • Az Ftp két átviteltípus (ASCII és bináris kép) használatát támogatja. Végrehajtható fájlok átviteléhez a bináris módot kell választani. Bináris módban a fájl átvitele bájtonként történik. Az ASCII fájlátvitellel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témakörök FTP: ascii című témnakörét.


Ftp: bye

Befejezi az FTP kapcsolatot a távoli számítógéppel, és kilép az ftp segédprogramból.

bye


Ftp: cd

Módosítja a munkakönyvtárat a távoli számítógépen.

cd távoli_könyvtár

Paraméter

távoli_könyvtár

Megadja a távoli számítógépen azt a könyvtárat, amelyre át kíván váltani.


Ftp: close

Befejezi az FTP kapcsolatot a távoli kiszolgálóval, és visszatér a parancsértelmezőhöz.

close


Ftp: debug

Be- és kikapcsolja a hibakeresést. A hibakeresés bekapcsolása esetén a rendszer a távoli számítógépnek küldött összes parancsot kinyomtatja a > karakter után. Alapértelmezés szerint a hibakeresés ki van kapcsolva.

debug


Ftp: delete

Fájlokat töröl a távoli számítógépen.

delete távoli_fájl

Paraméter

távoli_fájl

Megadja a törölni kívánt fájlt.


Ftp: dir

Megjeleníti a távoli könyvtárban levő fájlok és alkönyvtárak listáját.

dir [távoli_könyvtár] [helyi_fájl]

Paraméterek

távoli_könyvtár

Megadja a listázni kívánt könyvtárat. Ha nincs megadva könyvtár, akkor a parancs a távoli számítógép aktuális munkakönyvtárát használja.

helyi_fájl

Megad egy helyi fájlt a listázáshoz. Ha nincs megadva, a kimenet a képernyőn jelenik meg.


Ftp: disconnect

Bontja a kapcsolatot a távoli számítógéppel, de nem zárja le az ftp parancssort.

disconnect


Ftp: get

Az aktuális fájlátviteli mód használatával átmásol egy távoli fájlt a helyi számítógépre.

get távoli_fájl [helyi_fájl]

Paraméterek

távoli_fájl

Meghatározza a másolni kívánt távoli fájlt.

helyi_fájl

Meghatározza a helyi számítógépen használni kívánt nevet. Ha nincs megadva, akkor a távoli_fájl nevét adja a parancs a fájlnak.


Ftp: glob

Be- és kikapcsolja a helyettesítést. A helyettesítés lehetővé teszi a helyettesítő karakterek (* és ?) használatát a helyi fájlnevekben és elérési útvonalakban. Alapértelmezésben a helyettesítés be van kapcsolva.

glob


Ftp: hash

Be- és kikapcsolja a kettős kereszt (#) karakter nyomtatását az átvitt adatblokkok esetén. Az adatblokkok mérete 2048 bájt. Alapértelmezésben a kettős kereszt karakter nyomtatása ki van kapcsolva.

hash


Ftp: help

Megjeleníti az ftp parancsok leírását.

help [parancs]

Paraméter

parancs

Megadja a parancsot, amelynek a leírását meg kívánja jeleníteni. Ha nincs megadva parancs, az ftp megjeleníti az összes parancs leírását.


Ftp: ?

Megjeleníti az ftp parancsok leírását. A ? parancs megegyezik a help paranccsal.

? [parancs]

Paraméter

parancs

Megadja a parancsot, amelynek a leírását meg kívánja jeleníteni. Ha nincs megadva parancs, az ftp megjeleníti az összes parancs leírását.


Ftp: lcd

Módosítja a munkakönyvtárat a helyi számítógépen. Alapértelmezés szerint a munkakönyvtár az a könyvtár, amelyben a felhasználó elindította az ftp parancsot.

lcd [könyvtár]

Paraméter

könyvtár

Megadja a helyi számítógépen azt a könyvtárt, amelyre át kíván váltani. Ha nincs megadva könyvtár, akkor a helyi számítógép aktuális munkakönyvtára jelenik meg.


Ftp: literal

A megadott argumentumokat szó szerint elküldi távoli FTP-kiszolgálóra. A parancs egyszerű FTP-válaszkódot vár.

literal argumentum [ ...]

Paraméter

argumentum

Megadja az FTP-kiszolgálónak küldeni kívánt argumentumot.


Ftp: ls

Megjeleníti a távoli könyvtárban levő fájlok és alkönyvtárak rövidített listáját.

ls [távoli_könyvtár] [helyi_fájl]

Paraméterek

távoli_könyvtár

Megadja a listázni kívánt könyvtárat. Ha nincs megadva könyvtár, akkor a parancs a távoli számítógép aktuális munkakönyvtárának tartalmát jeleníti meg.

helyi_fájl

Megad egy helyi fájlt a listázáshoz. Ha nincs megadva, a kimenet a képernyőn jelenik meg.


Ftp: mdelete

Fájlokat töröl a távoli számítógépen.

mdelete távoli_fájlok [ ...]

Paraméter

távoli_fájlok

Megadja a törölni kívánt távoli fájlokat.


Ftp: mdir

Megjeleníti a távoli könyvtárakban levő fájlok és alkönyvtárak listáját. Az mdir paranccsal több fájl is kijelölhető.

mdir távoli_fájlok [ ...] helyi_fájl

Paraméterek

távoli_fájlok

Megadja a listázni kívánt könyvtárat. A távoli_fájlok paramétert meg kell adni. Adja meg a

-

karaktert a távoli számítógépen az aktuális munkakönyvár tartalmának megjelenítéséhez.

helyi_fájl

Megadja a listát tároló helyi fájlt. Adja meg a

-

karaktert a lista képernyőn való megjelenítéséhez.


Ftp: mget

Távoli fájlokat másol a helyi számítógépre az aktuális fájlátviteltípus használatával.

mget távoli_fájlok [ ...]

Paraméter

távoli_fájlok

Megadja a helyi számítógépre másolni kívánt távoli fájlokat.


Ftp: mkdir

Távoli könyvtárat hoz létre.

mkdir könyvtár

Paraméter

könyvtár

Megadja az új távoli könyvtár nevét.


Ftp: mls

Megjeleníti a távoli könyvtárakban levő fájlok és alkönyvtárak rövidített listáját.

mls távoli_fájlok [ ...] helyi_fájl

Paraméterek

távoli_fájlok

Meghatározza a fájlokat, amelyek listázását kéri. A távoli számítógépen a munkakönyvtár tartalmának megjelenítéséhez a távoli_fájlok paraméterként a

-

karaktert kell megadnia.

helyi_fájl

Megadja a listát tároló helyi fájlt. Adja meg a

-

karaktert a lista képernyőn való megjelenítéséhez.


Ftp: mput

Helyi fájlokat másol a távoli számítógépre az aktuális fájlátvitel típus használatával.

mput helyi_fájlok [ ...]

Paraméter

helyi_fájlok

Megadja a távoli számítógépre másolni kívánt helyi fájlokat.


Ftp: open

Kapcsolódik a megadott FTP-kiszolgálóhoz.

open számítógép [port]

Paraméterek

számítógép

Megadja a távoli számítógépet, amelyhez kapcsolódni kíván. A számítógép megadható IP-címe vagy számítógépnéve (elérhetőnek kell lennie egy DNS vagy Hosts fájlnak) alapján. Az automatikus bejelentkezés bekapcsolt állapotában (alapbeállítás) az ftp segédprogram automatikusan megkísérli bejelentkeztetni a felhasználót az FTP-kiszolgálóra (az automatikus bejelentkezés kikapcsolásával kapcsolatos tudnivalókért a Kapcsolódó témakörök között kattintson az ftp témakörre.

port

Megadja az FTP-kiszolgálóhoz való kapcsolódáshoz használni kívánt port számát.


Ftp: prompt

Be- és kikapcsolja az interaktív üzemmódot. Az ftp segédprogram több fájl átvitele esetén egyenként lehetővé teszi a fájlok letöltését és tárolását, míg az interaktív üzemmód kikapcsolása esetén az mget és az mput parancs minden fájl átvitelét végrehajtja. Alapértelmezés szerint az interaktív üzemmód be van kapcsolva.

prompt


Ftp: put

Az aktuális fájlátviteli típus használatával a helyi fájlt átmásolja a távoli számítógépre.

put helyi_fájl [távoli_fájl]

Paraméterek

helyi_fájl

Megadja a másolni kívánt helyi fájlt.

távoli_fájl

Megadja a távoli számítógépen használni kívánt nevet. Ha nincs megadva, a fájl a heli_fájl nevét kapja.


Ftp: pwd

Megjeleníti a távoli számítógép aktuális könyvtárát.

pwd


Ftp: quit

Befejezi az FTP-kapcsolatot a távoli számítógéppel, és kilép az ftp segédprogramból.

quit


Ftp: quote

A megadott argumentumokat szó szerint elküldi a távoli FTP-kiszolgálóra. A parancs egyszerű FTP-válaszkódot vár. A quote parancs megegyezik a literal paranccsal.

quote argumentum [ ...]

Paraméter

argumentum

Megadja az FTP-kiszolgálónak küldeni kívánt argumentumot.


Ftp: recv

Az aktuális fájlátviteli mód használatával a távoli fájlt a helyi számítógépre másolja. A recv parancs megegyezik a get paranccsal.

recv távoli_fájl [helyi_fájl]

Paraméterek

távoli_fájl

Meghatározza a másolni kívánt távoli fájlt.

helyi_fájl

Meghatározza a helyi számítógépen használni kívánt nevet. Ha nincs megadva, akkor a távoli fájl nevét adja a parancs a fájlnak.


Ftp: remotehelp

Megjeleníti a távoli parancsok súgóját.

remotehelp [parancs]

Paraméter

parancs

Megadja a parancs nevét, amelyhez a súgót meg kívánja jeleníteni. Ha nincs megadva parancs, az ftp segédprogram megjeleníti az összes távoli parancs leírását.


Ftp: rename

Távoli fájlokat nevez át.

rename fájlnév új_fájlnév

Paraméterek

fájlnév

Megadja az átnevezni kívánt fájl nevét.

új_fájlnév

Megadja az új fájlnevet.


Ftp: rmdir

Távoli könyvtárt töröl.

rmdir könyvtár

Paraméter

könyvtár

Meghatározza a törölni kívánt távoli könyvtár nevét.


Ftp: send

Az aktuális fájlátviteli típus használatával a helyi fájlt átmásolja a távoli számítógépre. A send parancs megegyezik a put paranccsal.

send helyi_fájl [távoli_fájl]

Paraméterek

helyi_fájl

Megadja a másolni kívánt helyi fájlt.

távoli_fájl

Megadja a távoli számítógépen használni kívánt nevet. Ha nincs megadva, a fájl a heli_fájl nevét kapja.


Ftp: status

Megjeleníti az FTP-kapcsolatok és a kétállapotú beállítások aktuális állapotát.

status


Ftp parancsok

További tudnivalókért válassza ki a kívánt ftp parancsot.

Ftp: ! | Ftp: glob | Ftp: put
Ftp: ? | Ftp: hash | Ftp: pwd
Ftp: append | Ftp: help | Ftp: quit
Ftp: ascii | Ftp: lcd | Ftp: quote
Ftp: bell | Ftp: literal | Ftp: recv
Ftp: binary | Ftp: ls | Ftp: remotehelp
Ftp: bye | Ftp: mdelete | Ftp: rename
Ftp: cd | Ftp: mdir | Ftp: rmdir
Ftp: close | Ftp: mget | Ftp: send
Ftp: debug | Ftp: mkdir | Ftp: status
Ftp: delete | Ftp: mls | Ftp: trace
Ftp: dir | Ftp: mput | Ftp: type
Ftp: disconnect | Ftp: open | Ftp: user
Ftp: get | Ftp: prompt | Ftp: verbose


Ftp: trace

Be- és kikapcsolja a csomag nyomkövetését. A trace parancs egy ftp parancs futtatásakor megjeleníti minden egyes csomag útvonalát.

trace


Ftp: type

Beállítja vagy megjeleníti a fájlátvitel típusát.

type [típusnév]

Paraméter

típusnév

Megadja a fájlátvitel típusát. Az alapértelmezett típus az ascii. Ha nincs megadva típusnév, az aktuális típus jelenik meg.

Megjegyzések

  • Az ftp parancs két átviteltípus (ascii és bináris kép) használatát támogatja.
  • Szövegfájlok átvitelére az ascii típus használható. Az Ascii mód használata esetén a rendszer karakterkonverziót hajt végre a hálózat szabványos karakterkészletére és viszont. Például a cél operációs rendszerének alapján szükség esetén elvégzi a sorvége karakterek konvertálását.
  • Végrehajtható fájlok átvitelére a bináris mód használható. Bináris módban a fájl átvitele bájtonként történik.


Ftp: user

A távoli számítógép számára megadja a felhasználó adatait.

user felhasználónév [jelszó] [fiók]

Paraméterek

felhasználónév

Meghatározza azt a felhasználónevet, amellyel bejelentkezik a távoli számítógépre.

jelszó

Meghatározza a felhasználónévhez tartozó jelszót. Ha nincsen megadva, de szükséges, akkor az ftp segédprogram kéri a jelszó megadását.

fiók

Meghatározza azt a fiókot, amellyel bejelentkezik a távoli számítógépre. Ha nincs megadva fiók, de szükséges, akkor az ftp segédprogram kéri a fiók megadását.


Ftp: verbose

Be- és kikapcsolja a részletes módot. Bekapcsolása esetén minden ftp válasz megjelenik. A fájlátvitel befejezésekor az átvitel hatékonyságát bemutató statisztikai adatok is megjelennek. Alapértelmezés szerint a részletes mód be van kapcsolva.

verbose


Ftype

Megjeleníti vagy módosítja a fájlnévkiterjesztésekhez társított fájltípusokat.

Ftype [fájltípus[=[parancs]]]

Paraméterek

fájltípus

Megadja a megjelenítendő vagy módosítandó fájltípust.

parancs

Megadja az adott típusú fájlok megnyitásakor használt megnyitó parancsot.

Írja be az ftype parancsot paraméterek nélkül a megnyitó paranccsal rendelkező fájltípusok listázásához.

Az ftype fájltípus parancs kiadásával megjeleníthető az adott fájltípushoz tartozó megnyitó parancssor.

Írja be az ftype fájltípus= parancsot az adott fájltípushoz tartozó megnyitó parancssor törléséhez.

Egy megnyitó parancssoron belül az ftype parancs a következő változókat helyettesíti be:

A %0 vagy a %1 változók helyére a megnyitandó fájl neve kerül.

A %* változó helyére a paraméterek kerülnek.

A %~n változó helyére a fennmaradó paraméterek kerülnek az n-dik paraméterrel kezdődően, ahol n bármilyen szám lehet 2 és 9 között.

A %3 paraméter helyére az első paraméter értéke kerül, a %4 paraméter helyére a második paraméter értéke kerül és így tovább.


Példák az Ftype parancs használatára

Ftype

Példák

A következő parancs:

    ASSOC .pl=PerlScript
    FTYPE PerlScript=perl.exe %1 %*

lehetővé teszi a Perl parancsfájlok futtatását a következőképpen:

    script.pl 1 2 3

A kiterjesztések begépelésének szükségessége kiküszöbölhető a következő módszerrel:

    set PATHEXT=.pl;%PATHEXT%

Ezután a parancsfájl megnyitható a következőképpen:

    script 1 2 3


Goto

Parancsfájlban átirányítja a Windows 2000 rendszert a megadott címkével megjelölt sorba.

A goto parancs átirányítja a Windows 2000 rendszert egy parancsfájlon belül az adott címkével azonosított sorra. Amikor a Windows 2000 megtalálja a címkét, a parancsfájl feldolgozását a címkét követő sorral folytatja.

goto címke

Paraméter

címke

Megadja azt a sort a parancsfájlban, amelyre a Windows 2000 átlép. Ha a parancskiterjesztések engedélyezettek (a Windows 2000 alapértelmezett beállítása), a goto parancs működése a következőképpen változik meg:

A goto parancs az :EOF címkével átirányítja a programot az aktuális parancsfájl végére, és kilép a parancsfájlból címke definiálása nélkül. A goto parancs :EOF címkével történő használatakor a címke elé kötelező kettőspontot írni. Például:

goto :EOF

Leírást a call parancs kiterjesztéseiről, amely ezt a szolgáltatást hasznossá teszi, és információt a parancskiterjesztések engedélyezéséről a Kapcsolódó témakörök között talál, a cmd parancsra kattintva.


Péda a Goto parancs használatára

Goto

Példa

A következő parancsfájl rendszerlemezként megformázza az A meghajtóban lévő lemezt. Ha a művelet sikeresen befejeződik, a goto parancs átirányítja a Windows 2000 rendszert a ”vége” címkére.

echo off
format a: /s
if not errorlevel 1 goto vege
echo Hiba történt a formázás közben.
:vege
echo A parancsfájl vége.


Megjegyzések a Goto parancshoz

Goto

Megjegyzések

Címkék érvényes értékei

A label paraméter tartalmazhat szóközöket, de nem tartalmazhat más elválasztó jeleket, például pontosvesszőt vagy egyenlőségjelet. A goto parancs EOF címkével történő használatakor a címke elé kötelező kettőspontot írni. Például:

goto :EOF

A Goto parancs a címkék első 8 karakterét használja

A goto parancs a címkéknek csak az első 8 karakterét használja. Ezért a ”:ittvan001” és ”:ittvan002” címkék megegyeznek az ”:ittvan00.” címkével.

A címke paraméterének egyeztetése a parancsfájlban lévő címkével

A goto parancsban megadott címke paraméter értékének meg kell egyeznie a parancsfájlban lévő címkével. A parancsfájlban lévő címkének egy kettősponttal kell kezdődnie.

Ha a parancsfájl nem tartalmazza a megadott címkét, a parancsfájl futása leáll és a Windows 2000 a következő üzenetet jeleníti meg:

A címke nem található

A Windows 2000 a kettősponttal kezdődő sorokat címkének veszi és nem dolgozza fel parancsként. Ha egy sor kettősponttal kezdődik, a Windows 2000 figyelmen kívül hagyja a sorban található összes parancsot.

A goto parancs használata feltételes műveletek esetén

A goto parancs gyakran áll más parancsokkal egy parancssorban feltételes műveletek elvégzése céljából. A goto parancs feltételes műveletekben történő használatáról további információt a Kapcsolódó témakörök között talál, az if parancsra kattintva.


Graftabl

Engedélyezi, hogy a Windows 2000 megjelenítse agy adott kódlap bővített karaktereit teljes képernyős üzemmódban. Ablakos üzemmódban a bővített karakterek nem jelennek meg.

graftabl [xxx] [/status]

Paraméterek

xxx

Megadja azt a kódlapot, amely kódlap bővített karaktereinek megjelenítését grafikus üzemmódban engedélyezni szeretné a Windows 2000 számára. A következő listában megtalálható az összes érvényes kódlap azonosítószáma és a hozzá tartozó ország, terület vagy nyelv:
437 Egyesült Államok
850 Többnyelvű (Latin I)
852 Szláv (Latin II)
855 Cirill (orosz)
857 Török
860 Portugál
861 Izlandi
863 Kanadai angol
865 Északi
866 Orosz
869 Újgörög

/status

Azonosítja a graftabl számára kiválasztott kódlapot.

A kódlapok használatával kapcsolatban további információt kaphat, ha a Kapcsolódó témakörök között a chcp vagy a mode (eszközkódlap beállítása) parancs témakörére kattint.


Példa a Graftabl parancs használatára

Graftabl

Példa

A 437-es (Egyesült Államok) kódlap grafikus karaktereinek memóriába olvasásához a írja be a következő parancsot:

graftabl 437

A 850-es (többnyelvű) kódlap grafikus karaktereinek memóriába olvasásához írja be a következő parancsot:

graftabl 850


Megjegyzések a Graftabl parancshoz

Graftabl

Megjegyzések

A Graftabl parancs nem változtatja meg a kezelőpult bemeneti kódlapját. A Graftabl parancs csak a megadott kódlap bővített karaktereinek monitoron történő megjelenítését befolyásolja. A használt kódlap megváltoztatásához használja a mode vagy a chcp parancsot.

A Graftabl parancs kilépési kódjai

Az alábbi lista az összes kilépési kódot és jelentésük rövid leírását tartalmazza:

0 | A karakterkészlet sikeresen betöltődött. Nem volt szükség korábbi kódlap betöltésére.
1 | Hibás paraméter lett megadva, semmilyen művelet nem lett végrehajtva.
2 | Fájlhiba történt.

Az errorlevel paramétert az if paranccsal használva feldolgozhatja a graftable parancs kilépési kódjait egy parancsfájlban.


Graphics

Betölt egy programot a memóriába, amely lehetővé teszi a Windows 2000 számára, hogy színes vagy grafikus csatoló használata esetén a képernyő tartalmát ki tudja nyomtatni egy nyomtatón.

graphics [típus] [[meghajtó:][elérési út] fájlnév] [/r] [/b] [/lcd] [/printbox:std | /printbox:lcd]

Paraméterek

típus

Megadja a nyomtató típusát. A következő listában látható a paraméter összes érvényes értéke egy rövid leírással együtt.

Paraméter | Leírás
color1 | IBM Personal Computer Color nyomtató fekete festékszalaggal
color4 | IBM Personal Computer Color nyomtató RGB (vörös, zöld, kék és fekete) festékszalaggal
color8 | IBM Personal Computer Color nyomtató CMY (cián, lila, sárga és fekete) festékszalaggal
hpdefault | Bármely Hewlett-Packard PCL nyomtató
deskjet | Hewlett-Packard DeskJet nyomtató
grafika | IBM Personal Graphics nyomtató, IBM Proprinter vagy IBM Quietwriter nyomtató
graphicswide | IBM Personal Graphics nyomtató 11 hüvelyk széles kocsival
laserjet | Hewlett-Packard LaserJet nyomtató
laserjetii | Hewlett-Packard LaserJet II nyomtató
paintjet | Hewlett-Packard PaintJet nyomtató
quietjet | Hewlett-Packard QuietJet nyomtató
quietjetplu | Hewlett-Packard QuietJet Plus nyomtató
ruggedwriter | Hewlett-Packard RuggedWriter nyomtató
ruggedwriterwide | Hewlett-Packard RuggedWriterwide nyomtató
thermal | IBM PC átalakítható Thermal nyomtató
thinkjet | Hewlett-Packard ThinkJet nyomtató

[meghajtó:][elérési_út] fájlnév

Megadja a nyomtatóprofil helyét és nevét, amely az információkat tartalmazza az összes támogatott nyomtatóról. Ha ez a paraméter nincs megadva, a Windows 2000 egy Graphics.pro nevű fájlt keres az aktuális könyvtárban és a Graphics.com nevű fájlt tartalmazó könyvtárban.

/r

A képernyő tartalmát úgy nyomtatja ki, ahogyan az látszik (fehér karakterek fekete háttéren) és nem fordítva (fekete karakterek fehér háttéren). A második beállítás az alapértelmezett.

/b

A hátteret színesben nyomtatja. Ez a kapcsoló color4 és color8 nyomtatók esetén érvényes.

/lcd

A kép kinyomtatásakor a folyadékkristályos kijelző (LCD) oldalarányát használja, nem CGA oldalarányt. Ennek a kapcsolónak a hatása azonos a /printbox:lcd kapcsoló hatásával.

/printbox:std | /printbox:lcd

Megadja a nyomtatási terület méretét. A printbox paraméter nevét lehet pb-nek rövidíteni. Ellenőrizze a printbox utasítás első operandusát a Graphics.pro fájlban és adja meg a /printbox:std beállítást, ha az operandus std, vagy a /printbox:lcd beállítást, ha az operandus lcd.


Példa a Graphics parancs használatára

Graphics

Példa

Egy grafikus képernyő kinyomtatásának előkészítéséhez írja be a következő parancsot:

grafika

A kinyomtatni kívánt információ megjelenítése után nyomja meg a SHIFT+PRINT SCREEN billentyűkombinációt. A Windows 2000 végigolvassa a megjelenített információt és elküldi azt a nyomtatóra.


Megjegyzések a Graphics parancshoz

Graphics

Megjegyzések

A képernyő tartalmának kinyomtatása

A képernyő tartalmának kinyomtatásához nyomja meg a SHIFT+PRINT SCREEN billentyűkombinációt. Ha a számítógép 320 x 148 x 200 színes grafikus üzemmódban van, és a nyomtató típus color1 vagy graphics, a graphics parancs a képernyő tartalmát négy szürkeárnyalattal nyomtatja ki. Ha a számítógép 640 x 148 x 200 színes grafikus üzemmódban van, a graphics parancs a képernyő tartalmát oldalirányban (fekvő) nyomtatja ki. A SHIFT+PRINT SCREEN billentyűkombinációval nem lehet a képernyő tartalmát PostScript nyomtatóval nyomtatni.

A parancs hatása a memóriára

A graphics parancs csökkenti az elérhető alapmemória mennyiségét.

Új profil betöltése

Ha már egy nyomtatóprofil be van töltve és a graphics parancs segítségével másik profil betöltése szükséges, az új profilnak kisebbnek kell lennie a már betöltött profilnál.

Egy, a már betöltöttnél nagyobb profil betöltéséhez újra kell indítani a számítógépet és a graphics paranccsal be lehet tölteni az új profilt.

Az aktuális profilnál nagyobb méretű profil betöltése esetén a graphics paranccsal a Windows 2000 a következő üzenetet jeleníti meg:

A megadott profil betöltése nem lehetséges.


Help

Online információt biztosít a Windows 2000 parancsairól (nem hálózati).

help [parancs]

Paraméter

parancs

Megadja annak a parancsnak a nevét, amelyről információt szeretne kapni. Ha parancsnév nincs megadva, a help parancs egy rövid leírással listázza az összes Windows 2000 rendszerparancsot.

Megjegyzés

  • Kétféleképpen lehet a parancsokkal kapcsolatos tudnivalókat a képernyőn megjeleníteni. Egy parancsról kétféleképpen kaphat információt: a help parancssorban megadva a parancs nevét, vagy a parancs után a /? kapcsolót beírva. Például ha az xcopy paranccsal kapcsolatban van szüksége segítségre, a következők bármelyikét beírhatja:

    help xcopy
    xcopy /?

    A második parancs egy kicsivel gyorsabb.

    A hálózati parancsokkal kapcsolatos segítségről további információt kaphat, ha a Kapcsolódó témakörök között a net help parancsra kattint.


Hostname

Kinyomtatja az aktuális számítógép nevét (gazda). Ez a parancs csak telepített TCP/IP protokoll esetén érhető el.

hostname


If

Feltételes végrehajtást tesz lehetővé parancsfájlokban. Ha az if parancsban megadott feltétel igaz, akkor a Windows 2000 a feltételt követő parancsot hajtja végre. Ha a feltétel hamis, a Windows 2000 figyelmen kívül hagyja az if tagmondatban lévő parancsot, és az else tagmondatban megadott parancsot hajtja végre, ha van ilyen.

if [not] errorlevel szám parancs [else kifejezés]

if [not] karakterlánc1==karakterlánc2 parancs [else kifejezés]

if [not] exist fájlnév parancs [else kifejezés]

Ha a parancskiterjesztések engedélyezve vannak:

if [/i] karakterlánc1 összehasonlító operátor karakterlánc2 parancs [else kifejezés]

if cmdextversion szám parancs [else kifejezés]

if defined változó parancs [else kifejezés]

Paraméterek

nincs

Megadja, hogy a Windows 2000 csak akkor hajtsa végre a parancsot, ha a feltétel hamis.

errorlevel szám

Csak akkor ad meg igaz feltételt, ha a Cmd.exe által futtatott előző program visszatérési kódja nagyobb vagy egyenlő a szám paraméterben megadott értékkel.

parancs

Megadja azt a parancsot, amelyet a Windows 2000 végrehajt, ha az előző feltétel igaz.

karakterlánc1==karakterlánc2

Csak akkor ad meg igaz feltételt, ha a karakterlánc1 és a karakterlánc2 paraméterek értéke megegyezik. Ezek az értékek lehetnek normál karakterláncok vagy parancsfájlváltozók (például %1). A literális karakterláncokat nem kell idézőjelek közéírni.

exist fájlnév

Akkor ad meg igaz feltételt, ha a fájlnév nevű fájl létezik.

összehasonlító operátor

Egy a következő hárombetűs összehasonlító operátorok közül:

Operátor | Leírás
EQU | egyenlő
NEQ | nem egyenlő
LSS | kisebb, mint
LEQ | kisebb vagy egyenlő
GTR | nagyobb, mint
GEQ | nagyobb vagy egyenlő

/i

Az /i kapcsoló megadásakor a karakterláncok összehasonlítása a kis- és nagybetűk közötti különbség figyelmen kívül hagyásával történik. Az /i kapcsolót az if parancs karakterlánc1==karakterlánc2 formátumával is lehet használni. Ezek az összehasonlítások általánosak abban az értelemben, hogy ha karakterlánc1 és karakterlánc2 is számokból áll, akkor a karakterláncokat a parancs átalakítja számokká és azokat hasonlítja össze.

cmdextversion szám

A cmdextversion feltétel ugyanúgy működik, mint az errorlevel feltétel, csak ez a Cmd.exe Parancskiterjesztések szolgáltatásával kapcsolatos belső verziószámot hasonlítja össze. Az első verzió az 1. Ez az érték eggyel növekszik minden jelentős javítás hozzáadásakor a parancs kiterjesztésekhez. A cmdextversion feltétel mindig hamis, ha a parancskiterjesztések nincsenek engedélyezve.

defined változó

A defined feltétel ugyanúgy működik, mint az exist feltétel, csak ez azt vizsgálja meg, hogy egy adott környezeti változó név definiálva van-e (igaz érték). Ezzel a feltétellel használható három további változó is: %errorlevel% , %cmdcmdline% és %cmdextversion%.

Az %errorlevel% változó az errorlevel aktuális értékének megfelelő karakterláncot veszi fel értékként, feltéve hogy nincs egy ERRORLEVEL nevű másik környezeti változó, mert ekkor ennek az értékét vizsgálja a parancs. Egy program futtatásán keresztül a következő példa bemutatja az errorlevel használatát:

    goto valasz%errorlevel%
    :valasz0
    echo A program visszatérési kódja: 0
    :valasz1
    echo A program visszatérési kódja: 1

Az összehasonlító operátor részben felsorolt összehasonlító operátorok is használhatók:

    if %errorlevel% LEQ 1 goto rendben

A %cmdcmdline% változó a Cmd.exe programnak átadott eredeti parancssort veszi fel értékként, feltéve hogy nincs egy cmdcmdline nevű másik környezeti változó, mert ekkor ennek az értékét vizsgálja a parancs.

A %cmdextversion% változó a cmdextversion aktuális értékének megfelelő karakterláncot veszi fel értékként, feltéve hogy nincs egy CMDEXTVERSION nevű másik környezeti változó, mert ekkor ennek az értékét vizsgálja a parancs.

kifejezés

Az else tagmondatban a kifejezés egy Windows 2000 parancsból és annak paramétereiből áll.


Példák az If parancs használatára

If

Példák

Egy fájl létezésének ellenőrzése

A következő üzenet jelenik meg, ha a Windows 2000 nem találja a Product.dat fájlt:

  if not exist product.dat echo Az adatfájl nem található

Üzenet küldése hiba esetén

A következő példa egy hibaüzenetet jelenít meg, ha hiba történik az A: meghajtóban lévő lemez formázása közben:

  :begin
  @echo off
  format a: /s
  if not errorlevel 1 goto vege
  echo Hiba történt a formázás közben.
  :vege
  echo A parancsfájl vége.

Ha nem történik hiba, a hibaüzenetet átugorja a program.

Egy könyvtár létezésének ellenőrzése

A következő példa ellenőrzi egy könyvtár létezését. Az if paranccsal nem lehet közvetlenül ellenőrizni egy könyvtár létezését, de az üres (NUL) eszköz minden könyvtárban létezik. Tehát, az üres eszköz keresésével ellenőrizhető, hogy egy könyvtár létezik-e.

  if exist c:konyvtar\nul goto feldolgozas

Az else tagmondat használata

Az else tagmondatnak ugyanabban a sorban kell lennie, mint az if parancs után álló parancs. Például:

    IF EXIST fájlnév (
        del fájlnév
    ) ELSE (
        echo fájlnév nem található.
    )

A következő példa hibás, mert a del parancsot be kell fejezni egy új sor karakterrel:

    IF EXIST fájlnév del fájlnév ELSE echo fájlnév nem található.

A következő példa hibás, mert az else parancsnak ugyanabban a sorban kell lennie, mint az if parancs vége:

    IF EXIST fájlnév del fájlnév
    ELSE echo fájlnév nem található.

Az eredeti utasítás következő alakja működik az egészet egy sorba írva:

    IF EXIST filename. (del fájlnév) ELSE echo filename. missing


Megjegyzések az If parancshoz

If

Megjegyzések

Amikor egy program leáll, egy kilépési kódot ad vissza a Windows 2000 programnak. Az errorlevel paraméter lehetővé teszi ezen kilépési kódok felhasználását feltételekben.


Install

Betölt egy memóriarezidens programot a memóriába. A rendszergyökér\System32\Config.nt fájlban, vagy egy program PIF fájljában megadott indítófájlban határozható meg a beolvasandó program.

install=[meghajtó:][elérési_út] fájlnév [parancsparaméterek]

Paraméterek

[meghajtó:][elérési_út] fájlnév

Megadja a futtatni kívánt memóriarezidens program helyét és nevét.

parancsparaméterek

A fájlnév paraméterben megadott program paramétereit adja meg.


Példa az Install parancs használatára

Install

Példa

Egy program memóriába töltéséhez a Config.nt fájlban, írja be:

install

Kapcsolódó témakörök


Megjegyzések az Install parancshoz

Install

Megjegyzések

Az Install parancs memóriarezidens programok memóriába töltésére használatos, a memóriarezidens programot igénylő alkalmazás indítása előtt. Ha a memóriarezidens programot az Autoexec.nt fájllal tölti be, a memóriarezidens program a parancssor minden elindításakor a memóriába kerül, ezzel memóriát pazarolva.

Ne használja az install parancsot olyan program betöltésére, amely környezeti változókat vagy billentyűparancsokat használ, vagy amelynek szüksége van a Cmd.exe jelenlétére a kritikus hibák kezeléséhez.


Ipconfig

Ez a diagnosztikai parancs megjeleníti az összes aktuális TCP/IP hálózati konfigurációs értéket. A parancs különösen hasznos a DHCP-t futtató rendszerek esetén, lehetővé téve felhasználók számára a DHCP által konfigurált TCP/IP konfigurációs értékek meghatározását.

ipconfig[/all | /renew [kártya] | /release [kártya]]

Paraméterek

all

Teljes megjelenítést eredményez. Ezen kapcsoló nélkül az ipconfig parancs csak az egyes kártyákhoz tartozó az IP címet, alhálózati maszkot és az alapértelmezett átjáró értékeket jeleníti meg.

/renew [kártya]

Megújítja a DHCP konfigurációs paramétereket. Ez a beállítás csak a DHCP-ügyfélszolgáltatást futtató rendszereken elérhető. A kártyanév megadásához írja be azt a nevet, amelyet az ipconfig parancs jelenít meg paraméterek nélkül kiadva.

/release [kártya]

Felszabadítja az aktuális DHCP konfigurációt. Ez a beállítás letiltja a TCP/IP-t a helyi rendszeren, és csak DHCP-ügyfeleken elérhető. A kártyanév megadásához írja be azt a nevet, amelyet az ipconfig parancs jelenít meg paraméterek nélkül kiadva.

Paraméter nélkül megadva az ipconfig segédprogram megjeleníti az aktuális TCP/IP konfigurációs értékeket, beleértve az IP-címet és az alhálózati maszkot. Ez a segédprogram különösen hasznos a DHCP-t futtató rendszerek esetén, lehetővé téve a felhasználók számára DHCP által konfigurált TCP/IP konfigurációs értékek meghatározását.


Ipxroute

Megjeleníti és módosítja az IPX protokoll által használt útválasztó táblák adatait. A parancsnak különböző beállításai vannak IPX és forrásútválasztás esetére. A beállításokat szóközzel kell elválasztani.

IPX útválasztás beállításai

ipxroute servers [/type=x]

ipxroute stats [/show] [ /clear]

ipxroute table

Paraméterek

servers [/type=x]

Megjeleníti a megadott kiszolgáló típus szolgáltatáshozzáférési pont (SAP) táblázatát. Az x paraméternek egész számnak kell lennie. Például a /type=4 beállítás megjeleníti az összes fájlkiszolgálót. Ha a /type paraméter nincs megadva, akkor az összes kiszolgálótípus megjelenik. A listában a kiszolgálók név szerint vannak rendezve.

stats [/show] [/clear]

Megjeleníti vagy törli az IPX útválasztó interfész statisztikáit. A /show (megjelenítés) az alapértelmezett. A /clear kapcsoló törli a statisztikát.

table

Megjeleníti az IPX útválasztó táblát hálózati szám szerint rendezve.

Forrásútválasztási beállítások

ipxroute board=n [clear] [def] [gbr] [mbr] [remove=xxxxx]

ipxroute config

Paraméterek

board=n

Megadja azt a hálózati kártyát, amelynek a paramétereit lekérdezi vagy beállítja a parancs.

clear

Törli a forrásútválasztó táblát.

def

A csomagokat ALL ROUTES csomagszórásként küldi. A forrásútválasztó táblában nem szereplő egyedi Macintosh címre küldött csomagot a rendszer alapértelmezés szerint SINGLE ROUTES csomagszórásként küldi.

gbr

A csomagokat ALL ROUTES csomagszórásként küldi. A szórási címre (FFFFFFFFFFFF) küldött csomagot a rendszer alapértelmezés szerint SINGLE ROUTES csomagszórásként küldi.

mbr

A csomagokat ALL ROUTES csomagszórásként küldi. A csoportos címre (C000xxxxxxxx) küldött csomagot, a rendszer alapértelmezettként SINGLE ROUTES csomagszórásként küldi.

remove=xxxxx

Eltávolítja a megadott csomópontcímet a forrásútválasztó táblából.

config

Információt jelenít meg azokról a kötésekről, amelyekre az IPX konfigurálva van.


Irftp

Fájlokat küld infravörös kapcsolaton keresztül (ehhez szükség van egy infravörös eszközre).

irftp [/h] [[meghajtó:][elérési_út]fájlnév [további_fájlnevek]]

irftp /s

/h

Bekapcsolja a rejtett üzemmódot. Így a forrás fájlok átvitele az infravörös kapcsolaton keresztül a Vezeték nélküli kapcsolat párbeszédpanel megjelenése nélkül történik.

[[meghajtó:][elérési_út]fájlnév [további_fájlnevek]

Megadja az infravörös kapcsolaton keresztül átvinni kívánt fájlok helyét és nevét. Ha nincs fájl megadva, megnyílik a Vezeték nélküli kapcsolat fájlmegnyitási párbeszédpanel, amelyen kiválaszthatók az átküldendő fájlok.

/s

Megnyitja a Vezeték nélküli kapcsolat tulajdonságait.


Label

Létrehozza, megváltoztatja vagy törli egy lemez kötetcímkéjét (nevét).

A Windows 2000 a kötetcímkét a könyvtárlista részeként jeleníti meg. Ha kötetnek van sorozatszáma, a Windows 2000 azt is megjeleníti.

label [meghajtó:][címke]

Paraméterek

nincs

Az aktuális kötet kötetcímkéjének módosításához vagy törléséhez írja be a label parancsot paraméterek nélkül.

meghajtó:

Megadja az elnevezendő lemez helyét.

címke

Megadja az új kötetcímkét. A meghajtó és a címke között egy kettőspontnak (:) kell lennie.


Példa a Label parancs használatára

Label

Példa

Az A meghajtóban lévő, júliusi kereskedelmi adatokat tartalmazó lemez címkéjének megadásához írja be a következő parancsot:

label a:ker-julius


Megjegyzések a Label parancshoz

Label

Megjegyzések

A Label parancs üzenetei

Ha a label parancs kiadásakor nincs címke megadva, a Windows 2000 a következő üzenetet jeleníti meg:

A meghajtóban (A) található kötet: xxxxxxxxxxx
A kötet sorozatszáma: xxxx-xxxx
Kötetcímke (11 karakter; ENTER, ha nincs)

Az üzenet ”Kötet sorozatszáma” része nem jelenik meg, ha a lemeznek nincs sorozatszáma.

Írja be a kívánt kötetcímkét, vagy csak nyomja meg az ENTER billentyűt az aktuális címke törléséhez. Ha a lemeznek már van címkéje, az ENTER billentyű megnyomása esetén a Windows 2000 a következő üzenetet jeleníti meg:

Törli a jelenlegi kötetcímkét (I/N)?

A címke törléséhez nyomja meg az I billentyűt, a címke megtartásához nyomja meg az N billentyűt.

A kötetcímkenevek korlátozásai

A kötet hossza NTFS kötetek esetén 32 karakter lehet, FAT kötetek esetén 11 karakter lehet, melyek tartalmazhatnak szóközöket, de tabulátorokat nem.

A FAT kötetcímkék nem tartalmazhatják a következő karaktereket:

* ? / \ | . , ; : + = [ ] < > "

Ez a korlátozás nincs NTFS kötetek esetében.

A Windows 2000 a FAT kötetcímkéket nagybetűkkel jeleníti meg. Ha kisbetűkkel adja meg a kötetcímkét, a label parancs átalakítja a kisbetűket nagybetűkké. Az NTFS kötetcímkék megőrzik a megadáskor használt kis- és nagybetűket.


Lastdrive

A Windows 2000 és az MS-DOS alrendszer nem hajt végre semmilyen műveletet ennek a parancsnak a hatására. Csak az MS-DOS rendszerrel való kompatibilitás érdekében fogadja el a rendszer.

A meghajtók mindig a maximumra vannak beállítva (Z).


Libpath

Megadja az OS/2 alrendszer számára, hogy a dinamikus csatolású függvénytárakat (DLL-ek) mely könyvtárakban keresse. A parancs használatához egy OS/2 szerkesztő programban módosítsa a C:\CONFIG.SYS fájlt.

libpath=[meghajtó:]elérési_út[;[meghajtó:]elérési_út][...]

Paraméterek

meghajtó:

Megadja a meghajtót, amelyen a DLL-ek találhatók. Ha nincs megadva meghajtó, az OS/2 alrendszer az aktuális meghajtón keres.

elérési út

Megadja könyvtárat, amelyben a DLL-ek találhatók. Több könyvtárat is meg lehet adni, neveiket pontosvesszővel (;) elválasztva.


Példa a Libpath parancs használatára

Libpath

Példa

Ahhoz, hogy az OS/2 alrendszer a merevlemez (C meghajtó) aktuális könyvtárában és a DYNLIB könyvtárában keresse a dinamikus csatolású függvénytárakat (DLL-ek), vegye fel a következő sort a C:\Config.sys fájlba egy OS/2 szerkesztő használatával:

libpath=.;c:\dynlib


Loadfix

Biztosítja, hogy egy program az alapmemória első 64KB-ja fölé legyen betöltve és futtatja a programot.

loadfix [meghajtó:][elérési_út] fájlnév

[meghajtó:][elérési út]

Megadja a meghajtót és könyvtárat, amelyben a program található.

fájlnév

Megadja a program nevét.


Példa a Loadfix parancs használatára

Loadfix

Példa

Egy alkalm.exe nevű program betöltéséhez a C meghajtó APPS könyvtárából, és a /c paraméter használatához (például karakteres üzemmódban történő elindításhoz), írja be a következőt a parancssorba, vagy vegye fel egy parancsfájlba:

loadfix c:\apps\alkalm.exe /c


Megjegyzés a Loadfix parancshoz

Loadfix

Megjegyzés

Néhány program a ”A csomagolt fájl sérült” üzenetet jeleníti meg, amikor a program vagy annak egy része az alapmemória első 64 KB-jába töltődik be és nem tud sikeresen lefutni. Ez a hiba akkor fordulhat elő, ha az eszközillesztők a felső memóriaterületre (UMA) vannak betöltve, és az alapmemória első 64 KB-jából több hely marad szabadon. Ha a Windows 2000 ezt az üzenetet jeleníti meg, akkor használja a loadfix parancsot, hogy a program biztosan az alapmemória első 64KB-ja fölé legyen betöltve.

A loadfix parancsot írja be a programot indító parancssor elejére.


Loadhigh (Lh)

Egy programot a felső memóriaterületre (UMA) tölt be. A programok UMA-ba töltése révén több alapmemória marad szabadon más programok számára. A rendszergyökér\System32\Config.nt fájlban, vagy egy program PIF fájljában megadható indítófájlban határozhatók meg a felső memóriába beolvasandó programok.

loadhigh [meghajtó:][elérési_út] fájlnév [paraméterek]

lh [meghajtó:][elérési_út] fájlnév [paraméterek]

Paraméterek

[meghajtó:][elérési_út] fájlnév

Megadja a betöltendő program helyét és nevét.

paraméterek

A program számára szükséges parancssori információkat adja meg.


Példa a Loadhigh (lh) parancs használatára

Loadhigh (lh)

Példa

Egy illesztőprogram magas memóriaterületre (HMA) történő beolvasásához vegye fel a következő sort az Autoexec.nt fájlba vagy az azzal egyenértékű indítófájlba:

lh %systemroot%\system32\dosx


Megjegyzések a Loadhigh (lh) parancshoz

Loadhigh (lh)

Megjegyzések

A Dos=Umb parancs szükséges.

A loadhigh parancs használatához szükség van a dos=umb parancs kiadására a Config.nt fájlban vagy az azzal egyenértékű indítófájlban. A dos=umb paranccsal kapcsolatos további információ a Kapcsolódó témakörök között a dos parancsra kattintva kapható.

A felső memóriaterülethez (UMA) egy kezelőt kell telepíteni.

Egy program felső memóriaterületre töltése előtt telepíteni kell a Himem.sys kiterjesztett memória kezelő programot. A Himem.sys telepítéséhez használja a device parancsot a Config.nt fájlban vagy az azzal egyenértékű indítófájlban.

A loadhigh parancs működése

Egy parancs loadhigh paranccsal történő beolvasásakor a Windows 2000 megkísérli azt a felső memóriaterületre tölteni. Ha nincs elegendő terület az UMA-n, a Windows 2000 az alapmemóriába tölti be a programot. A Windows 2000 nem jelzi, hogy melyik memóriaterületet használja.

A loadhigh parancs használata az Autoexec.nt fájlban

A loadhigh parancs használatának legkényelmesebb módja, ha az Autoexec.nt fájlban vagy az azzal egyenértékű indítófájlban van megadva.


Lpq

Ennek a diagnosztikai segédprogramnak a segítségével le lehet kérdezni egy LPD-kiszolgálót futtató számítógépen egy nyomtatási sor állapotát.

lpq -S Kiszolgáló -P Nyomtató [-l]

Paraméterek

-S Kiszolgáló

Megadja a számítógép nevét, amelyhez a nyomtató csatlakozik.

-P Nyomtató

Megadja a kívánt nyomtatási sor nyomtatójának nevét.

-l

E kapcsoló hatására a parancs részletes állapotinformációt jelenít meg.


Lpr

Ezen összeköttetést biztosító segédprogram segítségével kinyomtatható egy fájl LPD-kiszolgálót futtató számítógépen keresztül.

lpr -S Kiszolgáló -P Nyomtató [-C Osztály] [-J Feladatnév] [-O beállítás] fájlnév

Paraméterek

-SKiszolgáló

Megadja annak a számítógépnek a nevét vagy IP címét, amelyhez a nyomtató csatlakozik.

-P Nyomtató

Megadja a kívánt nyomtatási sorhoz tartozó nyomtató nevét.

-C Osztály

Meghatározza a fejléces lap tartalmát az osztály számára.

-J Feladatnév

Megadja a feladat nevét.

-O beállítás

Jelzi a fájl típusát. Az alapértelmezés szövegfájl. Bináris fájl (például PostScript) esetén használja a -Ol (kis 'L' betű) kapcsolót.

fájlnév

A nyomtatandó fájl neve.


Mem

Információt jelenít meg a lefoglalt memóriaterületekről, a szabad memóriaterületekről és a jelenleg betöltött programokról az MS-DOS alrendszerben.

mem [/program|/debug |/classify]

Paraméterek

nincs

A mem parancsot paraméterek nélkül kiadva megjelenítheti az MS-DOS alrendszer által használt és a szabad memória állapotát.

/program

Megjeleníti a jelenleg memóriába töltött programok állapotát. A /program kapcsoló a /debug vagy a /classify kapcsolóval együtt nem használható. A /program kapcsoló röviden /p alakban is megadható.

/debug

Az éppen betöltött programok és a belső illesztőprogramok állapotát, valamint egyéb programozási információt jelenít meg. A /debug kapcsoló a /program és a /classify kapcsolóval együtt nem használható. A /debug kapcsoló röviden /d alakban is megadható.

/classify

Az alapmemóriába és a felső memóriaterületre betöltött programok állapotát jeleníti meg. Ez a kapcsoló megadja az egyes programok méretét decimális és hexadecimális megjelöléssel, összegzi a memóriahasználatot és megjeleníti a rendelkezésre álló legnagyobb memóriablokkokat. A /classify kapcsoló a /program és a /debug kapcsolóval együtt nem használható. A /classify kapcsoló röviden /c alakban is megadható.


Példa a Mem parancs használatára

Mem

Példa

Tegyük fel, hogy az MS-DOS alrendszer bővített memória használatára lett beállítva. A teljes (alap-, bővített, kiterjesztett) rendszermemória állapotának megjelenítéséhez és a memóriába pillanatnyilag betöltött programok felsorolásához írja be a következő parancsot:

mem /program

Az eredmény a következőképpen néz ki:

  Cím         Név          Méret       Típus

  000000                   000400      Megszakítási vektor
  000400                   000100      ROM kommunikációs terület
  000500                   000200      DOS kommunikációs terület

  000700      IO           000310      Rendszeradatok

  000A10      MSDOS        0014D0      Rendszeradatok

  001EE0      IO           0018D0      Rendszeradatok
              KBD          000800      Rendszerprogramok
              HIMEM        000420      DEVICE=
                           000340      FILES=
                           000090      FCBS=
                           000170      LASTDRIVE=
                           000710      STACKS=
  0037C0      COMMAND      000A40      program
  004210      MSDOS        000070      - szabad -
  004290      COMMAND      0001F0      környezet
  004490      MEM          0001D0      környezet
  004670      MEM          017550      program
  01BBD0      MSDOS        084410      - szabad -
  09FFF0      SYSTEM       028000      Rendszerprogram

  0C8000      IO           0083D0      Rendszeradatok
              MOUSE        0083C0      Rendszerprogram
  0D03E0      MSDOS        000050      - szabad -
  0D0440      REDIR        0009F0      program
  0D0E40      DOSX         007CA0      program
  0D8AF0      DOSX         001030      adatok
  0D9B30      MSDOS        0164C0      - szabad -

    Az alapmemória teljes mérete: 655360 bájt
    Az  MS-DOS által használható: 655360 bájt
    A legnagyobb végrehajtható program mérete: 637296

    Összefüggő kiterjesztett memória teljes mérete: 1048576
    Összefüggő szabad kiterjesztett memória mérete: 0 bájt
    A szabad kiterjesztett (XMS) memóriába mérete: 405504 bájt
    Az MS-DOS a felső memóriaterületen van.

Az ”alapmemória teljes mérete” az MS-DOS alrendszerben lefoglalt virtuális memória mennyisége, az első 640 KB-ig.

Az ”MS-DOS által használható” memória a teljes lefoglalt alapmemória mennyisége, beleértve a Cmd.exe számára szükséges memóriát is.

A ”Legnagyobb végrehajtható program mérete” a programok számára rendelkezésre álló legnagyobb összefüggő alapmemóriablokk.

A ”Teljes EMS memória” (a példában nem szerepel) az MS-DOS alrendszer számára beállított bővített memória mennyisége.

A ”Szabad EMS memória” a programok számára rendelkezésre álló bővített memória mennyisége.

Az ”Összefüggő kiterjesztett memória teljes mérete” a memória 1 MB fölötti mennyisége.

Az ”Összefüggő szabad kiterjesztett memória mérete” a 15h megszakítás illesztője számára rendelkezésre álló kiterjesztett memória. Ezt a memóriát nem kezelik a kiterjesztettmemória-kezelők, például a Himem.sys. Egyes régebbi programok ezt az eltérő kiterjesztettmemória-sémát használják.

A ”szabad XMS memória” a kiterjesztettmemória-kezelők, például a Himem.sys által kezelt, és az azt használni képes programok számára elérhető memória.


Megjegyzések a Mem parancshoz

Mem

Megjegyzések

A memóriaállapot megjelenítése

Az MS-DOS alrendszer csak akkor jeleníti meg a kiterjesztett memória állapotát, ha 1 MB fölött foglalt le memóriát.


Mkdir (md)

Létrehoz egy könyvtárat vagy alkönyvtárat.

mkdir [meghajtó:]elérési út

md [meghajtó:]elérési út

Paraméterek

meghajtó:

Megadja azt a meghajtót, amelyen új könyvtárat szeretne létrehozni.

elérési út

Megadja az új könyvtár nevét és helyét. Az elérési utak maximális hosszát a fájlrendszer határozza meg.


Példák a Mkdir (md) parancs használatára

Mkdir (md)

Példák

Közbenső könyvtárak létrehozása

A parancskiterjesztések engedélyezése esetén (a Windows 2000 rendszerben ez az alapértelmezett beállítás) egy egyszerű mkdir paranccsal közbenső könyvtárakat hozhat létre a megadott elérési úton. Például ha ”Adók” néven kíván létrehozni könyvtárat, amely a ”Jellemző” könyvtárat, ez pedig az ”Aktuális” könyvtárat tartalmazza, írja be a következőket:

    mkdir \Adók\Jellemző\Aktuális

Ezzel megegyező hatású a parancskiterjesztések tiltása esetén a következő parancssorozat:

    mkdir \Adók
    chdir \Adók
    mkdir Jellemző
    chdir Jellemző
    mkdir Aktuális


Mode

A rendszereszközöket konfigurálja. A mode parancs különféle feladatokat hajt végre, például megjeleníti a rendszer állapotát, megváltoztatja a rendszer beállításait, és átkonfigurálja a portokat és eszközöket.

A mode parancs használata

Mivel a mode paranccsal egy sor különféle feladat végrehajtható, az egyes feladatok végrehajtásához szükséges szintaxis is különböző. Ezért az egyes feladatokat külön kell tárgyalni. Alább találja azoknak a feladatoknak a listáját, amelyeket a mode parancs segítségével elvégezhet.

  • Párhuzamos porthoz (PRN, LPT1, LPT2 és LPT3) csatlakoztatott nyomtató újrakonfigurálása 80 vagy 132 karakter/sor, 6 vagy 8 sor/hüvelyk vagy mindkettő beállítással (ha a nyomtató támogatja ezeket a szolgáltatásokat).
  • Az adatátviteli sebesség, a paritás, illetve az adatbitek és stopbitek számának beállítása soros kommunikációs port (COM1, COM2, COM3 vagy COM4) esetén adott nyomtatóhoz, modemhez vagy más soros eszközhöz.
  • Egyetlen vagy minden egyes eszköz állapotának megjelenítése.
  • A nyomtatókimenet átirányítása párhuzamos portról soros portra úgy, hogy a soros port lesz a rendszer alapértelmezett nyomtatóportja.
  • A parancssorablak méretének megváltoztatása.
  • A billentyűzet karakterismétlési sebességének beállítása.
  • A konzol kódlapja számának kijelölése, frissítése és megjelenítése.


Mode (nyomtató konfigurálása)

A párhuzamos nyomtatóporthoz csatlakoztatott nyomtatót konfigurálja.

A mode parancs ezen verziója a párhuzamos porthoz (PRN, LPT1, LPT2 vagy LPT3) csatlakoztatott IBM kompatibilis és Epson kompatibilis nyomtatók jellemzőit állítja be.

mode lpt n[:] [c][, [l][,r]]

mode lpt n[:] [cols=c] [lines=l]

Paraméterek

lpt n

Megadja azt a párhuzamos portot, amelyhez az eszköz csatlakozik.

cols=c

Megadja a karakterek (oszlopok) soronkénti számát: 80 vagy 132. Az alapértelmezett érték 80. Ezt a paramétert rövid alakban is megadhatja, ha a cols= kihagyásával értéket ad meg a c számára.

lines=l

Megadja a függőleges sortávolságot és a sorok hüvelykenkénti számát: 6 vagy 8. Az alapértelmezett érték 6. Ezt a paramétert rövid alakban is megadhatja, ha a lines= kihagyásával értéket ad meg a l számára.


Mode (soros port konfigurálása)

A soros kommunikációs portot konfigurálja.

A mode parancs ezen verziója a soros port (COM1, COM2, COM3 stb.) paramétereit állítja be.

mode com m[:] [baud=b] [parity=p] [data=d] [stop=s] [to=on |off] [xon=on|off] [odsr=on|off] [octs=on|off] [dtr=on|off|hs] [rts=on|off |hs|tg] [idsr=on|off]

Paraméterek

com m:

Megadja az aszinkron kommunikációs (COM) port számát.

baud=b

Megadja az átviteli sebességet bit/s mértékegységben. A következő lista a b érték és a kapcsolódási sebesség érvényes rövidítéseit tartalmazza:

11 110 baud

15 150 baud

30 300 baud

60 600 baud

12 1200 baud

24 2400 baud

48 4800 baud

96 9600 baud

19 19.200 baud

parity=p

Megadja, hogy a rendszer milyen módon használja a paritásbitet az átviteli hibák kiszűrésére. A p a következő értékeket veheti fel: n (none), e (even), o (odd), m (mark) vagy s (space). Az alapértelmezett érték az e. Nem minden számítógép támogatja az més az s értékeket.

data=d

Megadja az adatbitek számát karakterben. A d értéke 5-től 8-ig terjedhet. Az alapértelmezett érték 7. Nem minden számítógép támogatja az 5 és a 6 értéket.

stop=s

Megadja a karakter végét jelző stopbitek számát: 1, 1.5 vagy 2. Ha a sebesség 110 baud, az alapértelmezett érték 2; egyébként az alapértelmezett érték 1. Nem minden számítógép támogatja az 1.5 értéket.

to=on|off

Megadja, hogy a végtelen időtúllépés-feldolgozás bekapcsolt állapotban van-e. Az alapértelmezett érték a kikapcsolt állapot.

xon=on|off

Megadja, hogy az adatfolyamot vezérlő xon vagy xoff protokoll be van-e kapcsolva.

odsr=on|off

Megadja, hogy a Data Set Ready (DSR) áramkört használó kimeneti kézfogás be van-e kapcsolva.

octs=on|off

Megadja, hogy a Clear To Send (CTS) áramkört használó kimeneti kézfogás be van-e kapcsolva.

dtr=on|off|hs

Megadja, hogy a Data Terminal Ready (DTR) áramkör be van-e kapcsolva, illetve kézfogás állapotban van-e.

rts=on|off|hs|tg

Megadja, hogy a Request To Send (RTS) áramkör bekapcsolt, kikapcsolt, kézfogás vagy váltás állapotban van-e.

idsr=on|off

Megadja, hogy a DSR áramkör érzékenysége be van-e kapcsolva.


Mode (eszköz állapotának megjelenítése)

A rendszerben telepített eszközök egyikének vagy mindegyikének állapotát jeleníti meg.

mode [eszköz] [/status]

Paraméterek

nincs

A mode parancsot paraméterek nélkül kiadva megjelenítheti a rendszerben telepített valamennyi eszköz állapotát.

eszköz

Megadja annak az eszköznek a nevét, amelynek állapotát a felhasználó meg akarja jeleníteni.

/status

Lekéri minden átirányított párhuzamos nyomtató állapotát. A mode parancs e kapcsoló nélkül az átirányított párhuzamos nyomtatók kivételével minden telepített eszköz állapotát megjeleníti. A /status kapcsolót röviden /sta alakban is használhatja.


Mode (nyomtatás átirányítása)

Átirányítja a kimenetet egy párhuzamos portról soros kommunikációs portra.

A nyomtatás átirányítása csak akkor lehetséges, ha a felhasználó a Rendszergazdák csoport tagja.

mode lpt n[:]=com m[:]

Paraméterek

lpt n

Megadja a párhuzamos portot. Az n az 1-től 3-ig terjedő tartományban vehet fel értékeket.

com m [:]

A soros portot adja meg. Az m az 1 - 4-ig terjedő tartományban vehet fel értékeket.


Mode (eszköz kódlapjainak beállítása)

Kijelöli, frissíti vagy megjeleníti a konzol kódlapjainak számát.

mode device codepage select=yyy

mode eszköz codepage [ /status]

Paraméterek

eszköz

Megadja azt az eszközt, amelyhez a felhasználó kódlapot kíván választani. Az eszköz neve csak CON lehet.

yyy

Megadja a kiválasztott kódlap számát. A következő lista a Windows 2000 által támogatott egyes kódlapokat mutatja be, a hozzájuk tartozó országgal/területtel vagy nyelvvel együtt:
437 Egyesült Államok
850 Többnyelvű (Latin I)
852 Szláv (Latin II)
855 Cirill (orosz)
857 Török
860 Portugál
861 Izlandi
863 Kanadai francia
865 Északi
866 Orosz
869 Újgörög

codepage select

Megadja (kiválasztja) a megadott eszközön használni kívánt kódlapot. A codepage és a select röviden cp, illetve sel alakban is megadható.

codepage

Megadja az adott eszközhöz kiválasztott kódlap számát (ha van ilyen).

/status

Megadja az adott eszközhöz jelenleg kiválasztott kódlapok számát. Ezt a kapcsolót röviden /sta alakban is megadhatja. A /status kapcsoló megadásától függetlenül a mode parancsot eszköznévvel és a codepage paraméterrel kiadva a parancs a megadott eszközhöz kiválasztott kódlapok számát jeleníti meg.


Mode (Megjelenítési mód beállítása)

Megváltoztatja a parancssori képernyőpuffer méretét (karakterek és sorok száma).

mode con[:] [cols=c] [lines=n]

Paraméterek

con[:]

Jelzi, hogy a módosítás a parancssorablakra vonatkozik.

cols=c

Megadja a parancssori képernyőpufferben a karakterek számát (oszlopok szélességét).

lines=n

Megadja a parancssori képernyőpufferben a sorok magasságát (sorok számát).


Mode (karakterismétlési sebesség beállítása)

Beállítja a billentyűzet karakterismétlési sebességét, amellyel a Windows 2000 a karaktert ismétli a hozzá tartozó billentyű lenyomva tartása esetén.

A karakterismétlési sebesség két összetevője a sebesség és a késleltetés. Egyes billentyűzetek nem ismerik fel ezt a parancsot.

mode con[:] [rate=r delay=d]

Paraméterek

con[:]

A billentyűzetre vonatkozik.

rate=r

Megadja azt a sebességet, amellyel a karakter ismétlődik a képernyőn a hozzá tartozó billentyű lenyomva tartása esetén. Az érvényes értékek az 1-től 32-ig terjedő tartományba esnek. Ezek az értékek körülbelül 2 - 30 karakter per másodperc sebességnek felelnek meg. Az alapértelmezett érték IBM AT-kompatibilis billentyűzetek esetén 20, IBM PS/2-kompatibilis billentyűzetek esetén 21. A sebesség beállítása esetén a késleltetést is be kell állítani.

delay=d

Megadja azt az időt, amelynek elteltével a Windows 2000 a billentyű lenyomása és lenyomva tartása esetén elkezdi ismételni a karaktert. A d 1, 2, 3 és 4 értéket vehet fel (ezek 0.25, 0.50, 0.75, és 1 másodpercnek felelnek meg). Az alapértelmezett érték 2. A késleltetés beállítása esetén a sebességet is be kell állítani.


Példák a Mode (nyomtató konfigurálása) parancs használatára

Mode (nyomtató konfigurálása)

Példák

Tegyük fel, hogy a második párhuzamos porthoz (LPT2) csatlakoztatott párhuzamos nyomtatón soronként 80 karaktert és hüvelykenként 8 sort kíván nyomtatni. Írja be a következő parancsot:

mode lpt2:80,8

Mivel azonban a soronkénti 80 karakter érték az alapértelmezett beállítás, ezért ugyanazt az eredményt érheti el, ha a következő parancsot írja be:

mode lpt2:0,8


Példák a Mode (nyomtatás átirányítása) parancs használatára

Mode (nyomtatás átirányítása)

Példák

Tegyük fel, hogy úgy akarja beállítani a rendszert, hogy a párhuzamos nyomtató kimenetét soros nyomtatóra küldi. Ehhez kétszer kell kiadni a mode parancsot. Először a mode parancs segítségével konfigurálja a soros portot. Másodszor a mode parancs segítségével a párhuzamos nyomtató helyett az első mode parancsban megadott soros portra irányítja át a kimenetet.

Ha például a soros nyomtató 4800 baud sebességgel, páros paritással működik, és a COM1 porthoz (a számítógép első soros csatlakozójához) csatlakozik, a következő két parancsot kell beírni:

mode com1 48,e,,,b
mode lpt1=com1

Ha a párhuzamos nyomtatóra irányuló kimenetet átirányítja az LPT1 portról a COM1 portra, de később mégis az LPT1 porton keresztül kíván fájlt nyomtatni, a fájl nyomtatása előtt ki kell adni a következő parancsot. Ez a parancs megakadályozza, hogy a Windows 2000 a fájlt az LPT1 portról a COM1 portra irányítsa át.

mode lpt1


More

A kimenetből egyszerre egy képernyőnyi részt jelenít meg. Ezt a parancsot általánosan használják hosszú fájlok megjelenítésére. A parancs használható magában, vagy használható más parancs, például a type kimenetének vezérlésére. Amikor a fájl tartalma megtölti a rendelkezésre álló megjelenítési területet, a megjelenő more promptnál a felhasználó számos parancs segítségével megadhatja, hogyan kívánja megjeleníteni a fájl további részét.

parancs | more [/c] [/p] [/s] [/t n] [+n]

more [[/c] [/p] [/s] [/t n] [+n]] < [meghajtó:] [elérési út] fájlnév

more [/c] [/p] [/s] [/t n] [+n] [fájlok]

Paraméterek

[meghajtó: [[elérési út] fájlnév

Megadja a megjeleníteni kívánt fájlt.

parancs

Megadja azt a parancsot, amelynek kimenetét meg kell jeleníteni.

/c

A lap megjelenítése előtt törli a képernyőt.

/p

Kibontja a lapdobás karaktereket.

/s

Több egymást követő üres sor helyett csak egy üres sort jelenít meg.

/t n

A tabulátorokat n számú szóközzé alakítja.

+n

Az első fájlt az n sortól kezdve jeleníti meg.

fájlok

Megadja a megjeleníteni kívánt fájlok listáját. A fájlneveket szóközzel kell elválasztani egymástól.

A More segédparancsai

A more parancssorba (-- More --) a következő parancsokat lehet beírni:

Kulcs | Művelet
szóköz | Megjeleníti a következő lapot.
ENTER | Megjeleníti a következő sort.
F | Megjeleníti a következő fájlt.
q | Kilép.
? | Megmutatja a rendelkezésre álló parancsokat.
= | Megmutatja a sor számát.
P n | Megjeleníti a következő n sort.
S n | Átugorja a következő n sort.

További információt kaphat, ha a Szűrőparancsok, az Átirányító jelek, a Dir vagy a Type elemre kattint a Kapcsolódó témakörök listában.


Példák a More parancs használatára

More

Példák

Ha meg akarja tekinteni a Clients.new fájlt a képernyőn, írja be a következő két parancs egyikét:

more < clients.new

type clients.new | more

A more parancs megjeleníti a Clients.new fájl első képernyőnyi részét, majd kiírja a következő üzenetet:

-- Tovább --

Ezután a SZÓKÖZ billentyűt megnyomva megjelenítheti a következő képernyőt.

Ha törölni akarja a képernyőt, és el akar távolítani minden felesleges üres sort a Clients.new fájl megjelenítése előtt, írja be a következő két parancs egyikét:

more /c /s < clients.new

type clients.new | more /c /s

A more parancs megjeleníti a Clients.new fájl első képernyőnyi részét, majd kiírja a következő üzenetet:

-- Tovább --

Ha a fájlt soronként kívánja megjeleníteni, nyomja meg az ENTER billentyűt.

Ha a következő lapot kívánja megjeleníteni, nyomja meg a SZÓKÖZ billentyűt.

Ha a parancssorban található következő fájlt kívánja megjeleníteni, nyomja meg az f billentyűt.

Ha ki akar lépni a more programból, nyomja le a q billentyűt.

Ha meg akarja jeleníteni a more parancssornál használható parancsok listáját, nyomja meg a ? billentyűt. A rendelkezésre álló parancsok megjelennek a more parancssor mellett, ahogy azt az alábbi példa mutatja:

-- Tovább [Kapcsolók: psfq=<szóköz><Enter>] --

Ha meg akarja jeleníteni az aktuális sor számát, nyomja meg az = billentyűt. Az aktuális sor száma megjelenik a more parancssor mellett, amint azt az alábbi példa mutatja:

-- Tovább [24. sor] --

Ha egy adott számú sort kíván megjeleníteni, nyomja meg a p billentyűt. A more kéri a megjeleníteni kívánt sorok számát.

-- Tovább -- Sorok:

Írja be a megjeleníteni kívánt sorok számát, majd nyomja meg az ENTER billentyűt. A more megjeleníti a megadott számú sort.

Ha megadott számú sort át akar ugrani, nyomja meg az s billentyűt. A more kéri az átugrani kívánt sorok számát.

-- Tovább -- Sorok:

Írja be az átugrani kívánt sorok számát, majd nyomja meg az ENTER billentyűt. A more átugorja a megadott számú sort, majd megjeleníti a következő képernyőt.


Megjegyzések a More parancshoz

More

Megjegyzések

Adatforrások

Az átirányító karakter (<) használatakor meg kell adni a forrásfájl nevét. A függőleges vonás (|) karakterrel olyan parancsokat használhat, mint a dir, a sort és a type.


Mountvol

Kötetcsatlakoztatási pontot hoz létre, töröl, illetve listáz. A mountvol paranccsal úgy csatolhat kötetpartíciókat, hogy nincs szükség külön meghajtóbetűjelre a Windows 2000 rendszerben.

mountvol [meghajtó:]elérési út Kötetnév

mountvol [meghajtó:]elérési út /d

mountvol [meghajtó:]elérési út /l

Paraméterek

[meghajtó:]elérési út

Megadja azt a létező NTFS könyvtármappát, ahova a csatlakoztatási pont lesz helyezve.

Kötetnév

Megadja a csatlakoztatási pont céljául szolgáló kötet nevét. Ha nem ad meg kötetnevet, a mountvol listázza az egyes partíciókon található valamennyi kötet nevét.

/d

Eltávolítja a kötetcsatlakoztatási pontot a megadott mappából.

/l

Megjeleníti a megadott mappához tartozó csatlakoztatott kötet nevét.


Megjegyzések a Mountvol parancshoz

Mountvol

Megjegyzések

  • Ha már csak kevés felhasználható meghajtóbetűjellel rendelkezik, csatlakoztassa a helyi köteteket meghajtóbetűjel használata nélkül.
  • Ha meg akarja növelni a kötetek területét anélkül, hogy újraformázná vagy kicserélné a merevlemezt, vegyen fel csatlakoztatási útvonalat egy másik kötethez.
  • A több csatlakoztatási útvonallal rendelkező kötet használatának előnye, hogy minden helyi kötetet elérhet egyetlen meghajtóbetűjel (például a C:) segítségével. Nem kell fejben tartania, melyik kötet melyik meghajtóbetűjelhez tartozik, bár szükség esetén a csatlakoztatott helyi kötetekhez meghajtóbetűjelet is hozzárendelhet.


Move

Egy vagy több fájlt az egyik könyvtárból a megadott másik könyvtárba helyez át.

move [/y | /-y] [forrás] [cél]

Paraméterek

/y

Kikapcsolja a rákérdezéseket, amelyek a meglévő célfájlok felülírásának megerősítését kérik.

Az /y kapcsoló előre beállítható a COPYCMD környezeti változóban. Ez felülbírálható a parancssorban megadott /-y paraméterrel. Alapértelmezés szerint a rendszer megerősítést kér, kivéve, ha a copy parancsot parancsfájlból hajtja végre.

/-y

Bekapcsolja a rákérdezéseket, amelyek a létező célfájlok felülírásának megerősítését kérik.

forrás

Megadja az áthelyezni kívánt fájl vagy fájlok elérési útját és nevét. Ha könyvtárat kíván áthelyezni vagy átnevezni, forrásként a könyvtár jelenlegi elérési útját és nevét kell megadni.

cél

Adja meg az elérési utat és nevet, ahová a fájlokat át akarja helyezni. Ha könyvtárat akar áthelyezni vagy átnevezni, célként a könyvtár kívánt elérési útját és nevét kell megadni.


Példa a Move parancs használatára

Move

Példa

Az összes .xls kiterjesztésű fájl \Adatok könyvtárból a \Második_n_év\Jelentések könyvtárba helyezéséhez írja be:

move \adatok\*.xls \második_n_év\jelentések\


Nbtstat

Ez a diagnosztikai parancs a protokollstatisztikát, illetve az NBT-t (NetBIOS TCP/IP fölött) használó TCP/IP kapcsolatokat jeleníti meg. Ez a parancs csak telepített TCP/IP protokoll esetén érhető el.

nbtstat [-a távoli_név] [-A IP-cím] [-c] [-n] [-R] [-r] [-S] [-s] [időköz]

Paraméterek

-a távoli_név

Listázza a távoli számítógép névtábláját, annak nevét használva.

-A IP-cím

Listázza a távoli számítógép névtábláját, annak IP-címét használva.

-c

Listázza a NetBIOS névgyorsítótár tartalmát, minden névhez megadva az IP-címet.

-n

Listázza a helyi NetBIOS neveket. A Regisztrált azt jelzi, hogy a név szórásos küldés (B-csomópont) vagy WINS (egyéb csomóponttípusok) útján regisztrálva van.

-R

Újra betölti az Lmhosts fájlt, miután kiürítette a neveket a NetBIOS névgyorsítótárból.

-r

Listázza a Windows hálózati névfeloldás névfeloldási statisztikáját. Egy WINS-t használó Windows 2000 számítógépen ez a beállítás a szórásos küldés illetve a WINS útján feloldott és regisztrált nevek számát adja vissza.

-S

Megjeleníti az ügyfél- és a kiszolgáló-munkameneteket, a távoli számítógépeket csupán IP-címmel jelölve.

-s

Megjeleníti az ügyfél- és kiszolgáló-munkameneteket. A Hosts fájl segítségével megkísérli a távoli számítógépek IP-címét névre alakítani.

időköz

Újra megjeleníti a kijelölt statisztikákat az időköz paraméterrel megadott másodpercnyi hosszúságú szünetekre megállva két statisztika megjelenítése között. A statisztika megjelenítését a CTRL+C billentyűk megnyomásával állíthatja le. Ha azt a paramétert kihagyja, az nbtstat egyszer jeleníti meg a képernyőn az aktuális konfigurációadatokat.


Megjegyzések a Nbtstat parancshoz

Nbtstat

Megjegyzések

Az nbtstat segédprogram által létrehozott oszlopfejlécek a következő jelentésekkel bírnak:

Bemenet

A fogadott bájtok száma.

Kimenet

Az elküldött bájtok száma.

Fogadott/küldött

Attól függően, hogy a kapcsolat a számítógéptől ered (kimenő) vagy másik rendszertől a helyi számítógéphez irányul (bejövő).

Élettartam

A névtábla-gyorsítótár bejegyzésének ürítésig hátralévő élettartama.

Helyi név

A kapcsolathoz tartozó helyi NetBIOS név.

Távoli állomás

A távoli számítógéphez tartozó név vagy IP-cím.

Típus

A név típusára utal. A név lehet egyedi név és csoportnév.

<03>

Minden NetBIOS név 16 karakter hosszú. Ez az utolsó bájt gyakran különleges jelentőséggel bír, mivel ugyanaz a név számos példányban szerepelhet a számítógépen úgy, hogy csak az utolsó bájtban különbözik. Ez a jelölés egyszerűen a hexadecimális értékre alakított utolsó bájttal azonos; például a <20> ASCII szöveges megfelelője a szóköz.

Állapot

A NetBIOS kapcsolatok állapota. A lehetséges állapotok a következők:

Állapot | Jelentése
Csatlakoztatva | A munkamenet létrejött.
Társítva | A kapcsolat végpontjának létrehozása és IP-címhez társítása megtörtént.
Figyelés | A végpont elérhető a bejövő kapcsolatok számára.
Üresjárat | A végpont megnyitása megtörtént, de nem tud kapcsolatot fogadni.
Kapcsolódás | A munkamenet a kapcsolódási fázisban van, amikor a cél nevének IP-címre történő feloldása megtörtént.
Elfogadás | A bejövő munkamenetet a rendszer elfogadta, és hamarosan kapcsolódik.
Újracsatlakozás | A munkamenet megpróbál újra kapcsolódni, ha az első kísérlet alkalmával a kapcsolódás nem sikerült.
Kimenő | A munkamenet a kapcsolódási fázisban van, a TCP-kapcsolat létrehozása éppen folyamatban van.
Bejövő | A bejövő munkamenet a kapcsolódási fázisban van.
Kapcsolat bontása | A munkamenet a szétkapcsolódás állapotában van.
Szétkapcsolva | A helyi számítógép szétkapcsolódás utasítást adott ki, és megerősítésre vár a távoli rendszertől.


Net accounts

Frissíti a felhasználói fiókokat tartalmazó adatbázist, és megváltoztatja az egyes fiókokhoz tartozó jelszót és bejelentkezési követelményeket. A Net Logon szolgáltatásnak futnia kell azon a számítógépen, amelyen meg akarja változtatni a fiókparamétereket.

net accounts [/forcelogoff:{percek száma | no}] [/minpwlen:hossz] [/maxpwage:{napok száma| unlimited}] [/minpwage:napok száma] [/uniquepw:szám] [/domain]

net accounts[/sync] [/domain]

Paraméterek

nincs

A net accounts parancsot paraméterek nélkül beírva megjelenítheti a jelszóra, a bejelentkezési korlátozásokra és a tartományinformációra vonatkozó aktuális beállításokat.

/forcelogoff:{percek száma | no}

Beállítja azt az időtartamot percekben, amelynek eltelte után a felhasználó kiszolgálóval létrejött munkamenetét a kiszolgáló felbontja, ha a felhasználói fiók vagy a maximális bejelentkezési idő lejárt. A no beállítás megakadályozza a kényszerkijelentkezést. Az alapértelmezett érték no.

Amikor a /forcelogoff:percek száma beállítás meg van adva, a Windows 2000 a megadott percnyi idővel korábban figyelmeztetést küld a felhasználónak, mielőtt kijelentkezteti a hálózatról. Megnyitott fájlok esetén a Windows 2000 figyelmezteti a felhasználót. Ha a percek száma értéke kettőnél kevesebb, a Windows 2000 azonnal figyelmezteti a felhasználót, hogy jelentkezzen ki a hálózatból.

/minpwlen:hossz

Beállítja a felhasználói fiókhoz tartozó jelszó minimális hosszát karakterekben. A tartomány 0-127 karakter, az alapértelmezett érték 6 karakter.

/maxpwage:{napok száma | unlimited}

Beállítja azt az időtartamot napokban, amelynek elteltéig a felhasználói fiókhoz tartozó jelszó érvényes. Az unlimited érték megadása esetén a jelszó korlátlan ideig érvényes. A /maxpwage beállítás értékének nagyobbnak kell lennie a /minpwage beállítás értékénél. Az érvényes tartomány 1 és 49 710 nap (unlimited) közötti, az alapértelmezett érték 90 nap.

/minpwage:napok száma

Beállítja azt az időtartamot napokban, amelynek eltelte előtt a felhasználó nem változtathatja meg az új jelszót. 0 érték megadása esetén nincs minimális idő. Az érvényes tartomány 0-49 710 nap, az alapértelmezett érték 0 nap.

/uniquepw:szám

Bizonyos számú jelszóváltoztatáson belül nem engedélyezi, hogy a felhasználó ugyanazt a jelszót adja meg. Az érvényes tartomány 0-24 jelszóváltoztatás, az alapértelmezett érték 5 jelszóváltoztatás.

/domain

A műveletet az aktuális tartomány elsődleges tartományvezérlőjén hajtja végre. Ellenkező esetben a művelet végrehajtása a helyi számítógépen történik.

Ez a paraméter csak azokra a Windows 2000 Workstation operációs rendszerrel rendelkező számítógépekre vonatkozik, amelyek Windows 2000 Server tartomány részeiként működnek. A Windows 2000 Server számítógépek alapértelmezés szerint az elsődleges tartományvezérlőn hajtják végre a műveleteket.

/sync

Elsődleges tartományvezérlőn használva a tartományban található valamennyi másodlagos tartományvezérlő szinkronizál. Másodlagos tartományvezérlőn használva a másodlagos tartományvezérlő csak az elsődleges tartományvezérlővel szinkronizál. Ez a paraméter csak azokra a számítógépekre vonatkozik, amelyek Windows 2000 Server tartomány részeiként működnek.


Példák a Net accounts parancs használatára

Net accounts

Példák

Ha meg akarja jeleníteni a kényszerkijelentkezésre, a jelszókövetelményekre és a kiszolgáló kiszolgálószerepére vonatkozó aktuális beállításokat, adja ki a következő parancsot:

net accounts

Ha a felhasználói fiókhoz tartozó jelszók minimális hosszát 7 karakterre kívánja beállítani, adja ki a következő parancsot:

net accounts /minpwlen:7

Ha meg akarja adni, hogy ugyanaz a jelszó öt jelszóváltozáson belül ne legyen újra használható, adja ki a következő parancsot:

net accounts /uniquepw:5

Ha meg akarja akadályozni, hogy a felhasználók hét napnál gyakrabban jelszót változtassanak, de kötelezővé akarja tenni a jelszómódosítást 30 naponként, és a bejelentkezési idő lejártakor 5 perces előzetes figyelmeztetéssel kényszerűen ki akarja jelentkeztetni a felhasználókat a hálózatról, adja ki a következő parancsot:

net accounts /minpwage:7 /maxpwage:30 /forcelogoff:5

Ha az előző feladatot Windows 2000 Workstation számítógépen kívánja végrehajtani, és biztosítani akarja, hogy a beállítások azon a Windows 2000 Server tartományon is hatályba lépjenek, amelyre a számítógép be van jelentkezve, adja ki a következő parancsot:

net accounts /minpwage:7 /maxpwage:30 /domain

Ha minden tagkiszolgálón frissíteni kívánja a felhasználói fiókokat tartalmazó adatbázist, adja ki a következő parancsot:

net accounts /sync


Net (a parancs kapcsolói)

A Windows 2000 hálózati parancsainak jelentős része a net szóval kezdődik. Ezek a net parancsok néhány közös tulajdonsággal bírnak:

  • A rendelkezésre álló net parancsok listáját a net /? parancsot kiadva kérheti le.
  • A net parancs szintaxisával kapcsolatban a parancssorban segítséget kaphat a net help parancs parancsot kiadva. Például ha a net accounts paranccsak kapcsolatban kíván segítséget kérni, írja be net help accounts parancsot.
  • Minden net parancs elfogadja a /yes és /no beállítást (röviden /y és /n formában is megadható). A /y beállítás automatikusan igen választ ad a parancs által feltett kérdésekre, míg a /n ugyanezekre a kérdésekre nem választ ad. Például a net stop server parancs általában megkérdezi, hogy a felhasználó a Kiszolgáló szolgáltatástól függő valamennyi szolgáltatást le akarja-e állítani, míg a net stop server /y automatikusan igen választ ad erre a kérdésre, és a Kiszolgáló szolgáltatás leáll.


Net computer

Számítógépeket vesz fel, illetve töröl a tartomány-adatbázisból. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el.

net computer \\számítógép_neve {/add | /del}

Paraméterek

\\számítógép neve

Megadja a tartományba felvenni, illetve onnan törölni kívánt számítógépet.

/add

A megadott számítógépet felveszi a tartományba.

/del

A megadott számítógépet eltávolítja a tartományból.


Példák a Net computer parancs használatára

Net computer

Példák

Ha fel akarja venni a GRIZZLIMEDVE nevű számítógépet a bejelentkezett tartományba, adja ki a következő parancsot:

net computer \\grizzlimedve /add


Megjegyzések a Net computer parancs használatára

Net computer

Megjegyzések

A net computer parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el.

Minden számítógépfelvételt és -törlést a rendszer az elsődleges tartományvezérlőhöz továbbít.


Net config

Megjeleníti azokat a futó szolgáltatásokat, amelyeket konfigurálni lehet, illetve megjeleníti és megváltoztatja egy szolgáltatás beállításait.

net config [szolgáltatás [beállítások]]

Paraméterek

nincs

A net config parancsot paraméterek nélkül kiadva megjelenítheti a konfigurálható szolgáltatások listáját.

szolgáltatás

Megadja azt a szolgáltatást (kiszolgáló vagy munkaállomás), amelyet a net config parancs segítségével konfigurálhat.

beállítások

A szolgáltatásra jellemzőek. A teljes szintaxissal kapcsolatban további információt kaphat, ha a Kapcsolódó témakörök között a net config server vagy net config workstation elemre kattint.


Példa a Net config parancs használatára

Net config

Példa

Ha meg akarja jeleníteni konfigurálható futó szolgáltatásokat, adja ki a következő parancsot:

net config

Kapcsolódó témakörök


Megjegyzések a Net config parancshoz

Net config

Megjegyzések

A net config service parancs segítségével megváltoztathatja a konfigurálható Kiszolgáló vagy Munkaállomás szolgáltatás paramétereit. A módosítások azonnal érvénybe lépnek, és maradandóak.


Net config server

Megjeleníti vagy módosítja a Kiszolgáló szolgáltatás beállításait a szolgáltatás futása során.

net config server [/autodisconnect:időtartam] [/srvcomment:"szöveg "] [/hidden:{yes | no}]

Paraméterek

nincs

Adja ki a net config server parancsot, ha meg akarja jeleníteni a Kiszolgáló szolgáltatás aktuális konfigurációját.

/autodisconnect:időtartam

Beállítja azt az időtartamot, amelynek eltelte után a felhasználó inaktív munkamenetét a rendszer szétkapcsolja. A -1 értéket megadva a szétkapcsolás nem történik meg, időtartamtól függetlenül. Az érvényes tartomány -1-től 65535 percig terjedhet, az alapértelmezett érték 15.

/srvcomment:"szöveg "

Megjegyzést fűz a kiszolgálóhoz, amely megjelenik a Windows 2000 képernyőkön, illetve megjeleníthető a net view parancs segítségével. A megjegyzés legfeljebb 48 karaktert tartalmazhat. A szöveget zárja idézőjelek közé.

/hidden:{yes | no}

Megadja, hogy a kiszolgáló számítógép neve megjelenik-e a kiszolgálók listájában. Ne feledje, hogy a kiszolgáló elrejtése nem változtatja meg a kiszolgálóhoz tartozó engedélyeket. Az alapértelmezett érték no.


Példák a Net config server parancs használatára

Net config server

Példák

Ha információt akar megjeleníteni a helyi kiszolgálóról, és meg akarja akadályozni, hogy az információ kezdete kifusson a képernyőről, adja ki a következő parancsot:

net config server | more

Ha el akarja rejteni a kiszolgáló számítógépnevét az elérhető kiszolgálók listáján, adja ki a következő parancsot:

net config server /hidden:yes

Ha 15 perc inaktivitás után le akarja választani a felhasználókat, adja ki a következő parancsot:

net config server /autodisconnect:15


Megjegyzések a Net config server parancshoz

Net config server

Megjegyzések

A net config server parancs segítségével megváltoztathatja a Kiszolgáló szolgáltatás konfigurálható paramétereit. A módosítások azonnal érvénybe lépnek, és maradandóak.

A Kiszolgáló szolgáltatás nem minden paraméterét lehet megváltoztatni a net config server parancs segítségével; azonban a net config server további információkat is megjelenít. A megjelenített információk a következő adatokat tartalmazzák a kiszolgálóról:

  • A kiszolgáló számítógépneve, leíró megjegyzés és a szoftver verziója.
  • A hálózat leírása.
  • A kiszolgáló rejtett beállításai.
  • A kiszolgáló megosztott erőforrásait egyidejűleg használni tudó felhasználók maximális száma.
  • A kiszolgálón egyidejűleg megnyitható fájlok maximális száma.
  • A munkamenet-üresjárati idő beállítás.


Net config workstation

Megjeleníti vagy módosítja a Munkaállomás szolgáltatás beállításait a szolgáltatás futása során.

net config workstation [/charcount:bájtok száma] [/chartime:ezredmásodpercek száma] [/charwait:másodpercek száma]

Paraméterek

nincs

Adja ki a net config workstation parancsot, ha meg akarja jeleníteni a Munkaállomás szolgáltatás aktuális konfigurációját.

/charcount:bájtok száma

Megadja azt az adatmennyiséget, amelyet a Windows 2000 összegyűjt, mielőtt az adatokat egy kommunikációs eszközre küldi. Ha a /chartime:ezredmásodpercek száma beállítás is meg van adva, a Windows 2000 az elsőként teljesülő beállítás alapján jár el. Az érvényes tartomány 0-tól 65535 bájtig terjedhet, az alapértelmezett érték 16 bájt.

/chartime:ezredmásodpercek száma

Megadja azt az időtartamot ezredmásodpercben, amely alatt a Windows 2000 adatokat gyűjt, mielőtt az adatokat egy kommunikációs eszközre küldi. Ha a /charcount:bájtok száma beállítás is meg van adva, a Windows 2000 az elsőként teljesülő beállítás alapján jár el. Az érvényes tartomány 0 ezredmásodperctől 65535000 ezredmásodpercig tejed, az alapértelmezett érték 250 ezredmásodperc.

/charwait:másodpercek száma

Megadja azt az időtartamot másodpercben, amely alatt a Windows 2000 a kommunikációs eszköz elérhetővé válására vár. Az érvényes tartomány 0 másodperctől 65535 másodpercig tejed, az alapértelmezett érték 3600 másodperc.


Példa a Net config workstation parancs használatára

Net config workstation

Példa

Ha meg akarja jeleníteni a Munkaállomás szolgáltatás aktuális konfigurációját, adja ki a következő parancsot:

net config workstation

Ha 500 ezredmásodpercben akarja meghatározni azt az időtartamot, amely alatt a Windows 2000 adatokat gyűjt, mielőtt az adatokat egy kommunikációs eszközhöz küldi, adja ki a következő parancsot:

net config workstation /chartime:500


Megjegyzések a Net config workstation parancshoz

Net config workstation

Megjegyzések

A net config workstation parancs segítségével megváltoztathatja a Munkaállomás szolgáltatás konfigurálható paramétereit. A módosítások azonnal érvénybe lépnek, és maradandóak.

A Kiszolgáló szolgáltatás nem minden paraméterét lehet megváltoztatni a net config workstation parancs segítségével. A további paramétereket a konfigurációs rendszerleíró adatbázisban módosíthatja.


Net continue

Újraaktiválja a felfüggesztett szolgáltatásokat.

net continue szolgáltatás

Paraméterek

szolgáltatás

A folytatható szolgáltatások a következők: Macintosh fájlszolgáltatások (csak Windows 2000 Server esetén), ftp szolgáltatás, lpdsvc, hálózati bejelentkezés, hálózati DDE, hálózati DDE DSDM, NT LM biztonsági támogatás szolgáltatója,távelérés-kiszolgáló, ütemezés, kiszolgáló, egyszerű TCP/IP szolgáltatások vagy munkaállomás.


Példa a Net continue parancs használatára

Net continue

Példa

Ha folytatni akarja a Munkaállomás szolgáltatást, adja ki a következő parancsot:

net continue workstation


Megjegyzések a Net continue parancshoz

Net continue

Megjegyzések

A net continue parancs segítségével újraaktiválhatja a felfüggesztett szolgáltatásokat. A szolgáltatás felfüggesztése a szolgáltatás leállítása előtt azért ajánlott, hogy a felhasználóknak módjuk legyen a feladatok befejezésére, illetve az erőforrásokról történő lekapcsolódásra. Az erőforráson végzett kisebb módosításhoz a szolgáltatás vagy a nyomtató felfüggesztése is elegendő lehet. Ezután a net continue parancs segítségével újraaktiválhatja a szolgáltatást vagy a nyomtatót a felhasználói kapcsolatok megszakítása nélkül.

A felfüggesztés és a folytatás hatása szolgáltatásonként változó lehet.


Net file

Megjeleníti a kiszolgálón megnyitott minden megosztott fájl nevét, és a fájlokon fennálló esetleges fájlzárolások számát. Ez a parancs egyben bezárja az egyes megosztott fájlokat, és eltávolítja a fájlzárolásokat.

net file [azonosító [/close]]

Paraméterek

nincs

A net file parancsot paraméterek nélkül kiadva megtekintheti a kiszolgálón megnyitott fájlok listáját.

azonosító

Megadja a fájl azonosítószámát.

/close

Bezárja a megnyitott fájlt, és feloldja a zárolt rekordokat. Ezt a parancsot azon a kiszolgálón kell kiadni, ahol a fájl meg van osztva.


Példák a Net file parancs használatára

Net file

Példák

Ha információt akar kapni a megosztott fájlokról, adja ki a következő parancsot:

net file

Ha be akarja zárni az 1 azonosítószámmal rendelkező fájlt, adja ki a következő parancsot:

net file 1 /close


Megjegyzések a Net file parancshoz

Net file

Megjegyzések

A parancsot net files alakban is kiadhatja.

A net file parancs a hálózaton megosztott fájlok megtekintésére és felügyeletére használható. A megosztott fájlok néha tévedésből megnyitva, illetve zárolva maradnak. Ekkor a fájl zárolt részeihez a hálózat többi számítógépe nem fér hozzá. A net file parancs /close kapcsolója segítségével eltávolíthatja a zárolást és bezárhatja a fájlt.

A net file parancs kimenete a következőképpen néz ki:

Fájl      Elérési út       Felhasználónév      Zárolások száma

-----------------------

0         C:\EGYFÁJL.TXT   KILONA              0

1         C:\DATABASE      NBERNADETT          2


Net group

Globális csoportokat vesz fel, jelenít meg illetve módosít a Windows 2000 Server tartományokban. Ez a parancs csak Windows 2000 Server tartományvezérlőkön használható.

net group [csoport_neve /comment: "szöveg"]] [/domain]

net group csoport_neve {/add [/comment:"szöveg"] | /delete} [/domain]

net group csoport_neve felhasználó_neve[ ...] {/add | /delete} [/domain]

Paraméterek

nincs

A net group parancsot paraméterek nélkül kiadva megjelenítheti a kiszolgáló nevét, illetve a kiszolgálón található csoportok nevét.

csoport neve

Megadja a felvenni, kibővíteni vagy törölni kívánt csoport nevét. Ha csak a csoport nevét adja meg, megjelenítheti a csoportban található felhasználók listáját.

/comment:"szöveg"

Megjegyzést fűz az új vagy meglévő csoporthoz. A megjegyzés legfeljebb 48 karaktert tartalmazhat. A szöveget zárja idézőjelek közé.

/domain

A műveletet az aktuális tartomány elsődleges tartományvezérlőjén hajtja végre. Ellenkező esetben a művelet végrehajtása a helyi számítógépen történik.

Ez a paraméter csak azokra a Windows 2000 Professional operációs rendszerrel rendelkező számítógépekre vonatkozik, amelyek Windows 2000 Server tartomány tagjaiként működnek. A Windows 2000 Server számítógépek alapértelmezés szerint az elsődleges tartományvezérlőn hajtják végre a műveleteket.

felhasználó neve[ ...]

Egy vagy több felhasználót vehet fel vagy törölhet a csoportból. Az egyes felhasználóneveket szóközzel kell elválasztani.

/add

Csoportot, illetve csoportba felhasználót vesz fel. A parancs segítségével a csoportba felvett felhasználók számára fiókot kell létrehozni.

/delete

Csoportot, illetve csoportból felhasználót távolít el.


Példák a Net group parancs használatára

Net group

Példák

Ha a helyi kiszolgálón található valamennyi csoport listáját meg akarja jeleníteni, adja ki a következő parancsot:

net group

Ha fel akarja venni az exec nevű csoportot a helyi felhasználói fiókokat tartalmazó adatbázisba, adja ki a következő parancsot:

net group exec /add

Ha egy Windows 2000 Professional operációs rendszerrel rendelkező számítógépről fel kívánja venni az exec nevű csoportot a Windows 2000 Server tartomány felhasználói fiókokat tartalmazó adatbázisba, adja ki a következő parancsot:

net group exec /add /domain

Ha a vistvan, probert, és manna nevű meglévő felhasználói fiókokat fel akarja venni a helyi számítógépen található exec csoportba, adja ki a következő parancsot:

net group exec vistvan probert manna /add

Ha a vistvan, probert, és manna nevű meglévő felhasználói fiókokat fel akarja venni a Windows 2000 Server tartományban található exec nevű csoportba olyan számítógépről, amely Windows 2000 Professional operációs rendszerrel rendelkezik, adja ki a következő parancsot:

net group exec vistvan probert manna /add /domain

Ha meg akarja jeleníteni az exec csoportban található felhasználókat, adja ki a következő parancsot:

net group exec

Ha megjegyzést kíván fűzni az exec csoport rekordjához, adja ki a következő parancsot:

net group exec /comment:"Vezetők"


Megjegyzések a Net group parancshoz

Net group

Megjegyzések

A parancsot net groups alakban is beírhatja.

A net group parancs segítségével azonos csoportba rendezheti azokat a felhasználókat, akik hasonló módon használják a hálózatot. Amikor a csoporthoz jogokat rendel, a csoport minden egyes tagja automatikusan megkapja ezeket a jogokat.

A kiszolgálón található csoportok listája a következőképpen néz ki:

\\TERMELES csoportfiókjai

________________________________________

*Tartománygazdák           *Tartományfelhasználók

Figyelje meg, hogy minden csoportnév előtt csillag (*) áll. A csillag segítségével lehet megkülönböztetni a csoportokat olyan listákban, amelyek felhasználókat és csoportokat is tartalmaznak.


Net help

Megjeleníti azoknak a hálózati parancsoknak és témaköröknek a listáját, amelyekkel kapcsolatban segítség kérhető, illetve segítséget nyújt egy adott paranccsal vagy témakörrel kapcsolatban. A rendelkezésre álló net parancsok a Parancsmutató Parancsok ablakában, az N betű alatt is fel vannak sorolva. Kattintson a Windows 2000 parancsmutató elemre a Kapcsolódó témakörök listában.

net help [parancs]

net parancs {/help | /?}

Paraméterek

nincs

A net help parancsot paraméterek nélkül kiadva megjelenítheti azoknak a parancsoknak a listáját, amelyekkel kapcsolatban segítséget kérhet.

parancs

Az a parancs, amellyel kapcsolatban segítségre van szüksége. A net szót ne írja be a parancs részeként.

{/help | /?}

Megjeleníti a parancs helyes szintaxisát. A /help kapcsolót megadva is megjeleníthető a súgó szövege.


Példák a Net help parancs használatára

Net help

Példák

Ha a net use paranccsal kapcsolatban szeretné ugyanazt az információt megjeleníteni a net help parancs kétféle formáját használva, adja ki a következő parancsot:

net help use

vagy adja ki a következő parancsot:

net use /help

Ha meg akarja jeleníteni a net use parancs szintaxisát, adja ki a következő parancsot:

net use /?


Net helpmsg

Segítséget nyújt a Windows 2000 hibaüzenetekhez.

net helpmsg üzenet_száma

Paraméter

üzenet száma

Annak a Windows 2000 üzenetnek a négyjegyű számát adja meg, amellyel kapcsolatban segítségre van szüksége.


Példa a Net helpmsg parancs használatára

Net helpmsg

Példa

Ha segítséget kíván kérni a NET 2182 számú Windows 2000 hibaüzenettel kapcsolatban, adja ki a következő parancsot:

net helpmsg 2182

Megjelenik a hibaüzenet és a súgó szövege.


Megjegyzések a Net helpmsg parancshoz

Net helpmsg

Megjegyzések

Amikor egy hálózati művelet végrehajtása nem sikerül, a felhasználó a következőhöz hasonló üzenetet kap:

NET 2182: A kért szolgáltatás már elindult.

A Windows 2000 hibaüzenetek előtt a net szó áll, de a net szót nem kell beírni az üzenet száma elé.

A net helpmsg parancs magyarázatot ad a hibára és tájékoztat a hiba elhárításához szükséges műveletekről.


Net localgroup

Helyi csoportokat vesz fel, jelenít meg, illetve módosít.

net group [csoport neve /comment:"szöveg"]] [/domain]

net localgroup csoport neve {/add [/comment:"szöveg"] | /delete} [/domain]

net localgroup csoport neve név [ ...] {/add | /delete} [/domain]

Paraméterek

nincs

A net localgroup parancsot paraméterek nélkül kiadva megjelenítheti a kiszolgáló nevét és a számítógépen található helyi csoportok nevét.

csoport neve

Megadja a felvenni, kibővíteni vagy törölni kívánt helyi csoport nevét. Ha csak a csoport neve paramétert adja meg, megjelenítheti a helyi csoportban található felhasználók vagy globális csoportok nevét.

/comment:"szöveg"

Megjegyzést fűz az új vagy meglévő csoporthoz. A megjegyzés legfeljebb 48 karaktert tartalmazhat. A szöveget zárja idézőjelek közé.

/domain

A műveletet az aktuális tartomány elsődleges tartományvezérlőjén hajtja végre. Ellenkező esetben a művelet végrehajtása a helyi számítógépen történik.

Ez a paraméter csak azokra a Windows 2000 Professional operációs rendszerrel rendelkező számítógépekre vonatkozik, amelyek Windows 2000 Server tartomány tagjaiként működnek. A Windows 2000 Server számítógépek alapértelmezés szerint az elsődleges tartományvezérlőn hajtják végre a műveleteket.

név [ ...]

Egy vagy több felhasználót, illetve csoportot vehet fel vagy törölhet a helyi csoportból. Az egyes bejegyzéseket szóközzel kell elválasztani. A nevek paraméter értékként felveheti helyi felhasználók, más tartományban található felhasználók és globális csoportok nevét, de más helyi csoportok nevét nem. Ha a felhasználó másik tartományban található, a felhasználó neve előtt adja meg a tartomány nevét (például ERTEKESITES\PROBERT).

/add

Globális csoportot vagy felhasználót vesz fel a helyi csoportba. Először egy fiókot kell létrehozni a felhasználók és globális csoportok számára, azután ezzel a paranccsal egy helyi csoporthoz lehet azokat adni.

/delete

Globális csoportot vagy felhasználót távolít el a helyi csoportból.


Példák a Net localgroup parancs használatára

Net localgroup

Példák

Ha a helyi kiszolgálón található valamennyi helyi csoport listáját meg akarja jeleníteni, adja ki a következő parancsot:

net localgroup

Ha fel akarja venni az exec nevű helyi csoportot a helyi felhasználói fiókokat tartalmazó adatbázisba, adja ki a következő parancsot:

net localgroup exec /add

Ha fel akarja venni az exec nevű helyi csoportot a Windows 2000 Server tartomány felhasználói fiókokat tartalmazó adatbázisba, adja ki a következő parancsot:

net localgroup exec /add /domain

Ha a vistvan, probert (az ERTEKESITES tartományból) , és a manna nevű létező felhasználói fiókokat fel akarja venni a helyi számítógépen található exec nevű helyi csoportba, adja ki a következő parancsot:

net localgroup exec vistvan ertekesites\probert manna /add

Ha a vistvan, probert és manna nevű létező felhasználói fiókokat fel akarja venni a Windows 2000 Server tartományban található exec nevű csoportba, adja ki a következő parancsot:

net localgroup exec vistvan probert manna /add /domain

Ha meg akarja jeleníteni az exec nevű helyi csoportban található felhasználókat, adja ki a következő parancsot:

net localgroup exec

Ha megjegyzést kíván fűzni az exec nevű helyi csoport rekordjához, adja ki a következő parancsot:

net localgroup exec /comment:"Vezetők"


Megjegyzések a Net localgroup parancshoz

Net localgroup

Megjegyzések

A net localgroup parancs segítségével azonos csoportba rendezheti azokat a felhasználókat, akik hasonló módon használják a számítógépet vagy a hálózatot. Amikor a csoporthoz jogokat rendel, a csoport minden egyes tagja automatikusan megkapja ezeket a jogokat.


Net name

Üzenőnevet (más néven aliast) vesz fel vagy töröl, illetve megjeleníti azoknak a neveknek a listáját, amelyekre küldött üzeneteket a számítógép elfogadja. A net name parancs csak akkor használható, ha az Üzenetkezelő szolgáltatás fut.

net name [név [/add | /delete]]

Paraméterek

nincs

A net name parancsot paraméterek nélkül kiadva megjelenítheti a jelenleg használt nevek listáját.

név

Megadja az üzenetek fogadására használt nevet. A név legfeljebb 15 karakterből állhat.

/add

Nevet vesz fel a számítógépre. A /add kapcsoló megadása nem kötelező. A net name név parancs hatása megegyezik a net name név /add parancs hatásával.

/delete

Eltávolítja a nevet a számítógépről.


Példák a Net name parancs használatára

Net name

Példák

Ha meg akarja jeleníteni a számítógépen található nevek listáját, adja ki a következő parancsot:

net name

Ha fel akarja venni az rsvp nevet a számítógépre, adja ki a következő parancsot:

net name rsvp

Ha el akarja távolítani az rsvp nevet a számítógépről, adja ki a következő parancsot:

net name rsvp /delete


Megjegyzések a Net name parancshoz

Net name

Megjegyzések

A net name parancs segítségével megadhatja az üzenetek fogadására használt nevet. A net name parancs csak akkor használható, ha a Messenger szolgáltatás fut. Minden üzenőnév csak egyszer fordulhat elő a hálózaton. A net name paranccsal létrehozott nevek kizárólag üzenetküldésre szolgálnak, és a nevek nem csoportok.

A Windows 2000 háromféle nevet használ:

  • Üzenetküldésre szolgáló név, amelyet a net name parancs segítségével lehet felvenni.
  • A számítógép neve, amelynek felvétele a Munkaállomás szolgáltatás elindulásakor történik.
  • A felhasználó neve, amelynek felvétele a felhasználó bejelentkezésekor történik meg, feltéve, hogy a felhasználói név máshol a hálózatban nincs használatban üzenőnévként.

A számítógép nevét nem lehet törölni. A felhasználói név törölhető.


Net pause

Felfüggeszti a futó szolgáltatásokat.

net pause szolgáltatás

Paraméter

szolgáltatás

Ez lehet Macintosh fájlszolgáltatások (csak Windows 2000 Server esetén), ftp szolgáltatás, lpdsvc, hálózati bejelentkezés, hálózati DDE, hálózati DDE DSDM, NT LM biztonsági támogatás szolgáltatója, távelérés-kiszolgáló, ütemezés, kiszolgáló, egyszerű tcp/ip szolgáltatások vagy munkaállomás.


Példa a Net pause parancs használatára

Net pause

Példa

Ha szüneteltetni kívánja a Kiszolgáló szolgáltatást, adja ki a következő parancsot:

net pause server

Ha szüneteltetni kívánja a Hálózati bejelentkezés szolgáltatást, adja ki a következő parancsot:

net pause "net logon"


Megjegyzések a Net pause parancshoz

Net pause

Megjegyzések

A kiszolgálón:

A net pause parancs használata egy szolgáltatás leállítása előtt azért ajánlott, hogy a felhasználóknak módjuk legyen a feladatok befejezésére, illetve az erőforrásokról történő lekapcsolódásra. Felfüggesztés esetén a szolgáltatás megáll, de a szoftver a memóriában marad. Az erőforráshoz már kapcsolattal rendelkező felhasználók befejezhetik feladataikat, de új kapcsolatokat már nem lehet létrehozni az erőforrással.

Ha olyan szolgáltatást kíván leállítani, amely megosztott erőforrásokat érint, előbb függessze fel a szolgáltatást. Ezután a net send parancsot kiadva küldjön szét egy üzenetet, hogy a szolgáltatást hamarosan leállítja. Hagyjon elegendő időt a felhasználóknak az erőforrás használatának befejezésére, majd a net stop parancsot kiadva állítsa le a szolgáltatást.

Ha újra aktiválni kívánja a felfüggesztett szolgáltatást, adja ki a net continue parancsot.

Megjegyzés

  • Nem minden szolgáltatást lehet felfüggeszteni.

    • A felfüggesztés a következő hatással van a Windows 2000 szolgáltatásokra:

  • A hálózati bejelentkezés szolgáltatás felfüggesztése esetén a számítógép nem dolgozza fel a bejelentkezési kérelmeket. Ha a tartományban más bejelentkezési kiszolgálók is találhatók, a felhasználók továbbra is be tudnak jelentkezni a hálózatba.

  • A Kiszolgáló szolgáltatás felfüggesztése esetén a felhasználók nem tudnak újabb kapcsolatokat létesíteni a kiszolgáló megosztott erőforrásaival, és ha a hálózatban nincs másik bejelentkezési kiszolgáló, nem tudnak bejelentkezni a hálózatba. A meglévő kapcsolatokra ez nincs hatással. A rendszergazdák akkor is képesek kapcsolatot létesíteni a kiszolgálóval, ha az szünetel.

  • A Munkaállomás szolgáltatás felfüggesztése esetén a felhasználó megadott nevét, jelszavát és a létrehozott kapcsolatait a rendszer megőrzi, de a nyomtatóeszközökhöz irányuló kéréseket a rendszer a hálózati nyomtatók helyett a számítógéphez csatlakoztatott nyomtatókhoz irányítja.


Net print

A nyomtatási feladatok és a nyomtatási sorok megjelenítésére és vezérlésére szolgál.

net print \\számítógép_neve\megosztási_név

net print [\\számítógép_neve] feladat_száma [/hold | /release | /delete]

Paraméterek

számítógép_neve

Megadja a nyomtatási sor(oka)t megosztó számítógép nevét.

megosztási_név

Megadja a nyomtatási sor nevét. A megosztási név és a számítógép neve együttes használata esetén fordított ferde vonal (\) segítségével válassza el egymástól a neveket.

feladat_száma

Megadja a nyomtatási sorban a nyomtatási feladathoz rendelt azonosítószámot. Az egy vagy több nyomtatási sorral rendelkező számítógép minden nyomtatási sorhoz egyedi számot rendel. A számítógép által megosztott nyomtatási sorban már használatban lévő feladatszámokat az adott számítógép más feladatokhoz nem rendeli hozzá, még a számítógépen található más nyomtatási sorokban lévő feladatokhoz sem.

/hold

A feladatszám beállítással együtt használva várakoztatja a nyomtatási feladatot a nyomtatási sorban. A nyomtatási feladat a nyomtatási sorban marad, és a többi nyomtatási feladat átlépi egészen addig, amíg fel nem szabadítják.

/release

Felszabadítja a várakoztatott nyomtatási feladatot.

/delete

Eltávolítja a nyomtatási feladatot a nyomtatási sorból.


Példák a Net print parancs használatára

Net print

Példák

Ha információt kíván kapni a \\MUNKA számítógépen található 35-ös számú feladatról, adja ki a következő parancsot:

net print \\munka 35

Ha várakoztatni akarja a \\MUNKA számítógépen található 263-as számú feladatot, adja ki a következő parancsot:

net print \\munka 263 /hold

Ha fel akarja szabadítani a \\MUNKA számítógépen található 263-as számú feladatot, adja ki a következő parancsot:

net print \\munka 263 /release

Ha meg akarja jeleníteni a \\MUNKA számítógépen található MATRIX nyomtatási sort, adja ki a következő parancsot:

net print \\munka\matrix


Megjegyzések a Net print parancshoz

Net print

Megjegyzések

A net print parancs többféle módon jelenít meg információt a nyomtatási sorokról.

A net print \\számítógépnév\megosztási_név parancsot kiadva megjeleníthet egy nyomtatási sort. A nyomtatási sor a következőképpen néz ki:

Nyomtatási várólisták a következőn: \\MUNKA

Név          	       Feladatszám      Méret      Állapot

-----------------------------------

LASER várólista          1 feladat                   *Nyomtatási sor aktív*

     AUGUSZTA            84                0         Várólista feldolgozása

A net print feladat_száma parancsot kiadva megjeleníthet egy adott nyomtatási feladatot. A megjelenített feladat a következőképpen néz ki:

Feladatszám                     35

Állapot                         Várakozás

Méret                           3096

Megjegyzés

A végrehajtást kérő felhasználó BMARIA

Értesítés                       BMARIA

Feladat-adattípus

Feladat paraméterei

További információ


Net send

Üzeneteket küld a hálózaton található más felhasználóknak, számítógépeknek vagy üzeneti neveknek. Üzeneteket csak akkor lehet fogadni, ha a Messenger szolgáltatás fut.

net send {név | * | /domain[:név] | /users} üzenet

Paraméterek

név

Megadja azt a felhasználónevet, számítógépnevet vagy üzeneti nevet, ahová az üzenetet küldeni kívánja. Ha a név olyan számítógépnév, amely üres karaktereket tartalmaz, zárja az aliast idézőjelek (" ") közé. A hosszú felhasználónevek hibákat okozhatnak, ha NetBIOS névként használják őket. A NetBIOS nevek legfeljebb 16 karakter hosszúak lehetnek, és a 16. karakter a Windows 2000 számára van lefoglalva.

*

Az üzenetet a tartományban vagy munkacsoportban található minden névnek elküldi.

/domain[:név]

Az üzenetet a számítógép tartományában található minden névnek elküldi. Ha a név meg van adva, az üzenetet a rendszer a megadott tartományban vagy munkacsoportban található minden névre elküldi.

/users

Az üzenetet a kiszolgálóhoz kapcsolódó minden felhasználónak elküldi.

üzenet

Megadja az üzenetben elküldeni kívánt szöveget.


Példák a Net send parancs használatára

Net send

Példák

Ha a ”Gyűlés mégis délután háromkor. Hely ugyanaz.” üzenetet akarja elküldeni a robertf nevű felhasználónak, adja ki a következő parancsot:

net send robertf Gyűlés mégis délután háromkor. Hely ugyanaz.

Ha a kiszolgálóhoz kapcsolódó minden felhasználónak el akarja küldeni az üzenetet, adja ki a következő parancsot:

net send /users A kiszolgáló 5 perc múlva leáll.

Ha olyan szöveget akar küldeni, amelyben perjel (/) szerepel, a következő módon adja ki a parancsot:

net send robertf "Formázd a lemezt a FORMAT /4 paranccsal!"


Megjegyzések a Net send parancshoz

Net send

Megjegyzések

Üzenetet csak olyan névre küldhet, amely aktív a hálózaton. Ha az üzenetet felhasználói névre küldi, a felhasználó csak akkor kapja meg az üzenetet, ha be van jelentkezve, és futtatja a Messenger szolgáltatást.

Üzenet küldése több felhasználónak

A Windows 2000 többféle módon biztosítja az üzenet szórásos küldését. Az üzenetet elküldheti a számítógép tartományában található összes névre (* vagy /domain), vagy egy más tartományban található összes névre (/domain:tartomány neve). A szórással küldött üzenetek legfeljebb 128 karakterből állhatnak.

A /users beállítás lehetővé teszi, hogy üzenetet küldjön azoknak a felhasználóknak, akiknek munkamenetük van a kiszolgálóval. A több felhasználónak történő üzenetküldés során ügyeljen az udvariasságra.


Net session

Felsorolja, illetve szétkapcsolja a helyi számítógép és a hozzá csatlakozó ügyfelek között létrejött munkameneteket.

net session [\\számítógépnév] [/delete]

Paraméterek

nincs

A net session parancsot paraméterek nélkül kiadva információkat jeleníthet meg a helyi számítógéppel fennálló összes munkamenetről.

\\számítógépnév

Azonosítja azt a számítógépet, amelynek munkameneteit meg kívánja jeleníteni vagy szét kívánja bontani.

/delete

Befejezi a számítógép és a \\számítógépnév által megjelölt számítógép közötti munkamenetet, és bezárja a munkamenet folyamán megnyitott összes fájlt. Ha nincs megadva \\számítógépnév, a helyi számítógép összes munkamenete megszakad.


Példák a Net session parancs használatára

Net session

Példák

Ha meg akarja jeleníteni a helyi kiszolgálóval létrejött munkamenetek adatait, adja ki a következő parancsot:

net session

Ha meg akarja jeleníteni a KATONA számítógépnévvel rendelkező ügyféllel létrejött munkamenetek adatait, adja ki a következő parancsot:

net session \\katona

Ha be akarja fejezni a kiszolgáló és a hozzá kapcsolódó ügyfelek között létrejött valamennyi munkamenetet, adja ki a következő parancsot:

net session /delete


Megjegyzések a Net session parancshoz

Net session

Megjegyzések

A net session parancsot net sessions vagy net sess alakban is kiadhatja.

A net session parancs segítségével megjelenítheti a kiszolgálóhoz kapcsolódó felhasználók és számítógépek nevét, az általuk megnyitott fájlok számát és az egyes felhasználói munkamenetek üresjáratának időtartamát.

A megjelenített adatok a következőképpen néznek ki:

Számítógép    Felhasználónév   Ügyféltípus   Nyitott fájlok   Üresjárási idő

------------------------------------------------------------------------
\\BASSETT     CHRISDR          NT             1               00:00:13
\\SHARONCA    Administrator    DOS LM 2.1     0               01:05:13

Ha egy felhasználó által létesített munkamenetet kíván megjeleníteni, adja meg a \\számítógépnév beállítást a parancsban. A felhasználóhoz tartozó információk között szerepelnek azok a megosztott erőforrások, amelyekhez a felhasználó csatlakozott.

A munkamenet akkor jön létre, amikor egy ügyfélen belépett felhasználó sikeresen kapcsolatba lép a kiszolgálóval. A munkamenet akkor sikeres, ha a két rendszer ugyanazon a hálózaton található, és a felhasználó nevét és jelszavát elfogadta a kiszolgáló. Az ügyfelet használó felhasználó csak akkor veheti igénybe a kiszolgáló erőforrásait, ha munkamenetet létesített a kiszolgálóval, a munkamenet pedig akkor jön létre, amikor a felhasználó egy erőforráshoz kapcsolódik. Az ügyfél és a kiszolgáló között csak egy munkamenet jöhet létre, de több belépési ponttal, vagyis kapcsolattal rendelkezhetnek az erőforrásokhoz.

Ha meg akarja adni, hogy a kiszolgáló mennyi idő eltelte után kapcsolja szét a tétlen munkameneteket, állítsa be az autodisconnect szolgáltatást oly módon, hogy megadja az /autodisconnect beállítást a net config server parancsban. Az automatikus szétkapcsolás a felhasználó számára észrevétlen, mert a Windows 2000 automatikusan újracsatlakoztatja, amikor a felhasználó ismét használja az erőforrást.

Ha fel akarja bontani a kiszolgálóval létesített munkamenetet, használja a /delete kapcsolót, és adja meg a \\számítógépnév beállítást.


Net share

Megosztott erőforrásokat hoz létre, töröl, illetve listáz.

net share megosztási név

net share megosztási név=meghajtó:elérési út [/users:szám| /unlimited] [/remark:"szöveg"]

net share megosztási név [/users:szám| unlimited] [/remark:"szöveg"]

net share {megosztási név | meghajtó:elérési út} /delete

Paraméterek

nincs

A net share parancsot paraméterek nélkül kiadva információkat jeleníthet meg a helyi számítógépen megosztott valamennyi erőforrásról.

megosztási név

A megosztott erőforrás hálózati neve. A net share parancs mellett a megosztási nevet megadva csak az adott megosztásról jeleníthet meg információkat.

meghajtó:elérési út

Megadja a megosztani kívánt könyvtár abszolút elérési útját.

/users:szám

Megadja a megosztott erőforrást egyszerre használni tudó felhasználók maximális számát.

/unlimited

Megadja, hogy a megosztott erőforrást egyszerre korlátlan számú felhasználó használhatja.

/remark:"szöveg"

Leíró megjegyzést fűz az erőforráshoz. A szöveget zárja idézőjelek közé.

/delete

Megszünteti az erőforrás megosztását.


Példák a Net share parancs használatára

Net share

Példák

Ha információt akar megjeleníteni a számítógépen található megosztott erőforrásokról, adja ki a következő parancsot:

net share

Ha SECRETARY megosztási néven meg akarja osztani a számítógép C:\LETTERS könyvtárát, és megjegyzést akar hozzáfűzni, adja ki a következő parancsot:

net share secretary=c:\letters /remark:"A 123-as részleg számára."

Ha meg akarja szüntetni a LETTERS könyvtár megosztását, adja ki a következő parancsot:

net share secretary /delete

Ha LIST megosztási néven meg akarja osztani a számítógép C:\ART LST könyvtárát, adja ki a következő parancsot:

net share list="c:\art lst"


Megjegyzések a Net share parancshoz

Net share

Megjegyzések

A net share parancs segítségével erőforrásokat oszthat meg.

Ha a megosztani kívánt könyvtár elérési útja üres karaktert tartalmaz, a meghajtót és a könyvtár elérési útját zárja idézőjelek (" ") közé.

Amikor megjeleníti a számítógépen található összes megosztott erőforrást, a Windows 2000 megadja az erőforrás megosztási nevét, az erőforráshoz tartozó eszközneve(ke)t vagy elérési utat, és az erőforráshoz fűzött leíró megjegyzést.

A megjelenített adatok a következőképpen néznek ki:

Megosztás  Erőforrás                    Megjegyzés
------------------------------------------------------
ADMIN$     C:\WINNT                     Remote Admin
C$         C:\                          Alapértelmezett megosztás belső használatra
print$     C:\WINNT\SYSTEM\SPOOL
IPC$                                    Remote IPC
LASER      LPT1               Hálózati  lézernyomtató

A kiszolgálón létrehozott megosztásokat a rendszer menti. A Kiszolgáló szolgáltatás leállításakor minden megosztás szétkapcsolódik, de a Kiszolgáló szolgáltatás következő indításakor, illetve a számítógép újraindításakor automatikusan újrakapcsolódnak.


Net start

Elindít egy szolgáltatást, illetve megjeleníti az elindított szolgáltatások listáját. A két vagy több szóból álló szolgáltatásneveket (pl. Net Logon vagy Computer Browser) idézőjelek közé kell zárni.

net start [szolgáltatás]

Paraméterek

nincs

A net start parancsot paraméterek nélkül kiadva megjelenítheti a futó szolgáltatások listáját.

szolgáltatás

Ezek közé tartozik a riasztási, a netware ügyfélszolgáltatás, a vágókönyv-kiszolgáló, a tartalomindex, a számítógép-tallózó, a dhcp ügyfél, a könyvtárreplikátor, az eseménynapló, az ftp közzétételi szolgáltatás, a hipermédia objektumkezelő, a logikailemez-kezelő, az lpdsvc, a médiaszolgáltatások kezelője, az üzenetkezelő, a faxszolgáltatás, a Microsoft telepítőkiszolgáló, a hálózati bejelentkezés, a hálózati dde, a hálózati dde dsdm, az nt lm security support provider, az ole, a plug and play, a távelérési csatlakozáskezelő, a távelérés isnsap szolgáltatás, a távelérés-kiszolgáló, a távoli eljáráshívás (RPC) lokátor, a távoli eljáráshívás (RPC) szolgáltatás, az ütemezés, a kiszolgáló, az egyszerű tcp/ip szolgáltatások, a Site Server ldap szolgáltatás, az intelligens kártya erőforrás-kezelője, az snmp, a nyomtatósor-kezelő, a feladatütemező, a tcp/ip netbios segítő, a telefonos szolgáltatás, a nyomonkövetés, a nyomonkövetés (kiszolgáló) szolgáltatás, a ups, a Windows időszolgáltatás és a munkaállomás.

A következő szolgáltatások csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhetők el: Macintosh fájlkiszolgáló, NetWare átjárószolgáltatás,microsoft dhcp szolgáltatás, macintosh nyomtatószolgáltatás, windows internet name service.


Példa a Net start parancs használatára

Net start

Példa

Ha meg akarja jeleníteni a jelenleg futó szolgáltatások listáját, adja ki a következő parancsot:

net start

Kapcsolódó témakörök


Megjegyzések a Net start parancshoz

Net start

Megjegyzések

A net start szolgáltatás parancs segítségével Windows 2000 szolgáltatásokat indíthat el. Egyes szolgáltatások más szolgáltatásoktól függenek.

A Szolgáltatások beépülő modul segítségével a szolgáltatásokat úgy is konfigurálhatja, hogy azok automatikusan álljanak le, illetve induljanak el. A beépülő modul segítségével kézzel is leállíthatja, elindíthatja, felfüggesztheti és folytathatja a hálózati szolgáltatásokat.

A két vagy több szóból álló szolgáltatásneveket (pl. Net Logon vagy Computer Browser) idézőjelek ("") közé kell zárni.

Ezzel a paranccsal indíthatja el azokat a hálózati szolgáltatásokat is, amelyeket nem a Windows 2000 csomaggal együtt kapott.


Net start alerter

Elindítja a Riasztási szolgáltatást. A Riasztási szolgáltatás figyelmeztető üzeneteket küld.

net start alerter

Kapcsolódó témakörök


Példa a Net start Alerter parancs használatára

Net start Alerter

Példa

Ha el akarja indítani a Riasztási szolgáltatást, adja ki a következő parancsot:

net start alerter

Kapcsolódó témakörök


Megjegyzések a Net start Alerter parancshoz

Net start Alerter

Megjegyzések

A Riasztási szolgáltatást akkor kell elindítani, ha figyelmeztető üzenetet kíván küldeni a kiszolgálóhoz kapcsolódó egyes felhasználóknak. A figyelmeztető üzenetek biztonsági és hozzáférési problémákról és a felhasználói munkamenetekkel kapcsolatos problémákról tájékoztatnak.

Használja a Kiszolgálókezelő segédprogramot (rendszergyökér\system32\srvmgr.exe) azoknak a rendszergazdáknak a megadására, akiknek a figyelmeztető üzenetekből kapniuk kell. A Kiszolgálókezelő csak a Windows 2000 Server számítógépeken áll rendelkezésre.

A figyelmeztető üzeneteket a kiszolgáló Windows 2000 üzenetként küldi a felhasználó számítógépére. A felhasználó csak akkor kapja meg a figyelmeztető üzeneteket, ha számítógépén fut az Messenger szolgáltatás.


Net start Computer Browser

Elindítja a Számítógép-tallózó szolgáltatást.

net start "computer browser"


Példa a Net start Computer Browser parancs használatára

Net start Computer Browser

Példa

Ha el akarja indítani a Számítógép-tallózó szolgáltatást, adja ki a következő parancsot:

net start "computer browser"


Megjegyzések a Net start Computer Browser parancshoz

Net start Computer Browser

Megjegyzések

A Számítógép-tallózó szolgáltatás támogatja a hálózaton található más számítógépeken történő tallózást, és a helyi számítógépen a más hálózati számítógépek által történő tallózást. A két vagy több szóból álló szolgáltatásneveket (pl. Computer Browser) idézőjelek (") közé kell zárni. A szolgáltatást a net start browser paranccsal is elindíthatja.


Net start Client Service for NetWare

Elindítja a Netware ügyfélszolgáltatás szolgáltatást. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el, ha a Netware ügyfélszolgáltatás telepítve van.

net start ”client service for netware”


Net start ClipBook Server

Elindítja a Vágókönyv-kiszolgáló szolgáltatást. A két vagy több szóból álló szolgáltatásneveket (pl. Clipbook Server) idézőjelek (") közé kell zárni.

net start "clipbook server"


Példa a Net start ClipBook server parancs használatára

Net start ClipBook server

Példa

Ha el akarja indítani a Vágókönyv-kiszolgáló szolgáltatást, adja ki a következő parancsot:

net start ”clipbook server”


Megjegyzések a Net start ClipBook server parancshoz

Net start ClipBook server

Megjegyzések

A Vágókönyv-kiszolgáló lehetővé teszi szöveg és grafika kivágását és beillesztését a hálózaton keresztül.


Net start DHCP Client

Elindítja a DHCP-ügyfél szolgáltatást. Ez a parancs csak akkor érhető el, ha a TCP/IP protokoll telepítve van.

net start ”dhcp client”


Példa a Net start DHCP Client parancs használatára

Net start DHCP Client

Példa

Ha el akarja indítani a DHCP-ügyfél szolgáltatást, adja ki a következő parancsot:

net start "dhcp client"


Megjegyzések a Net start DHCP Client parancshoz

Net start DHCP Client

Megjegyzések

A DHCP-ügyfél szolgáltatás támogatja az IP-cím megszerzését a DHCP szolgáltatástól.

A két vagy több szóból álló szolgáltatásneveket idézőjelek (") közé kell zárni. A szolgáltatást a net start dhcp paranccsal is elindíthatja.

A DHCP-ügyfél szolgáltatást nem lehet leállítani vagy felfüggeszteni.


Net start Eventlog

Elindítja az eseménynaplózó szolgáltatást, amely naplózza a helyi számítógépen előforduló eseményeket. A szolgáltatást az Eseménynapló előtt kell elindítani, ha meg akarja jeleníteni a naplózott eseményeket.

net start eventlog

Kapcsolódó témakörök


Példa a Net start Eventlog parancs használatára

Net start Eventlog

Példa

Ha el akarja indítani az Eseménynapló szolgáltatást, adja ki a következő parancsot:

net start eventlog

Kapcsolódó témakörök


Megjegyzések a Net start Eventlog parancshoz

Net start Eventlog

Megjegyzések

Az Eseménynapló szolgáltatás naplózza a jelentősebb rendszer-, biztonsági és alkalmazáseseményeket, amelyekről a felhasználónak tudomást kell szereznie.

Az Eseménynaplóról és a naplókarbantartási információk konfigurálásáról további információt az Eseménynapló online súgójában talál.

Az Eseménynaplót nem lehet leállítani és felfüggeszteni.


Net start File Service for Macintosh

Elindítja a Macintosh fájlszolgáltatást, lehetővé téve ezzel a Macintosh számítógépekkel történő fájlmegosztást. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el.

net start "file service for macintosh"


Net start FTP Publishing Service

Elindítja az FTP közzétételi szolgáltatást. Ez a parancs csak akkor érhető el, ha az Internet Information Services szolgáltatás telepítve van.

net start "ftp publishing service"


Net start Gateway Service for NetWare

Elindítja a NetWare átjárószolgáltatást. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el, ha a Netware átjárószolgáltatás telepítve van.

net start "gateway service for netware"


Net start Remote Procedure Call (RPC) Locator

Elindítja a Távoli eljáráshívás (RPC) lokátor szolgáltatást. A Lokátor szolgáltatás a Microsoft Windows 2000 RPC névszolgáltatása.

net start "remote procedure call (rpc) locator"


Példa a Net start Remote Procedure Call (RPC) Locator parancs használatára

Net start Remote Procedure Call (RPC) Locator

Példa

Ha el akarja indítani a Távoli eljáráshívás (RPC) lokátor szolgáltatást, adja ki a következő parancsot:

net start "remote procedure call (rpc) locator"


Megjegyzések a Net start Remote Procedure Call (RPC) Locator parancshoz

Net start Remote Procedure Call (RPC) Locator

Megjegyzések

Elindítja az RPC-lokátor szolgáltatást, amely lehetővé teszi az elosztott alkalmazások számára a Microsoft RPC névszolgáltatás használatát. Az RPC-lokátor kezeli az RPC névszolgáltatás adatbázisát.

Az elosztott alkalmazás kiszolgálóoldali része regisztrálja elérhetőségét az RPC-lokátor szolgáltatásban. Az elosztott alkalmazás ügyféloldali része a Lokátor szolgáltatást lekérdezve keresi az elérhető kompatibilis kiszolgálóalkalmazásokat.

A két vagy több szóból álló szolgáltatásneveket idézőjelek (") közé kell zárni. A szolgáltatást a net start rpclocator paranccsal is elindíthatja.


Net start Lpdsvc

Elindítja a TCP/IP nyomtatókiszolgáló szolgáltatást. Ez a parancs csak akkor áll rendelkezésre, ha a Unix nyomtatószolgáltatások és a TCP/IP protokoll telepítve vannak.

net start lpdsvc

Kapcsolódó témakörök


Példa a Net start Lpdsvc parancs használatára

Net start Lpdsvc

Példa

A TCP/IP nyomtatókiszolgáló szolgáltatás indításához írja be a következőt:

net start lpdsvc

Úgy is elindíthatja a szolgáltatást, hogy Start gombra kattint, a Beállítások pontra mutat, majd a Vezérlőpult parancsra kattint. Kattintson duplán a Felügyeleti eszközök, majd a Szolgáltatások ikonra. Ezután jelölje ki a TCP/IP-nyomtatókiszolgáló elemet a szolgáltatáslistában, majd kattintson a Művelet menü Indítás parancsára.

A UNIX ügyfelek távoli nyomtató létrehozásával nyomtathatnak Windows 2000 kiszolgálókon. Ennek a nyomtatócsatlakozásnak a létrehozása ugyanúgy történik, mint egyéb UNIX távoli nyomtatócsatlakozásoké (pl. egy printcap bejegyzés létrehozása BSD rendszereken).

Egy Nyomtatási szolgáltatások UNIX rendszerhez szolgáltatással megosztandó nyomtatót a Nyomtatók mappában lehet megosztani. A TCP/IP nyomtatókiszolgáló szolgáltatás automatikusan megoszt minden, a Windows 2000 számítógépen megosztott nyomtatót.

Jelenleg az LPR nem tud olyan hálózati megosztásokra nyomtatni, amelyek OS/2 LAN Manager kiszolgálón találhatók.


Megjegyzések a Net start Lpdsvc parancshoz

Net start Lpdsvc

Megjegyzések

A TCP/IP nyomtatókiszolgáló szolgáltatás a UNIX ügyfelek TCP/IP alapú nyomtatásának kiszolgálóoldala. Ha a hálózaton található bármely UNIX ügyfél Windows 2000 operációs rendszerrel rendelkező számítógéphez csatlakoztatott nyomtatón kíván nyomtatni, ennek a szolgáltatásnak futnia kell a Windows 2000 operációs rendszerrel rendelkező számítógépen, mert ez fogadja a UNIX ügyfelektől érkező kéréseket. A TCP/IP nyomtatókiszolgáló szolgáltatás minden nyomtatási formátumot támogat, beleértve a sima szöveget.

A TCP/IP nyomtatókiszolgáló szolgáltatás független az LPR portoktól. Az LPR portok lehetővé teszik egy Windows 2000 számítógép (és az azt elérő ügyfelek) számára, hogy UNIX számítógéphez csatlakoztatott nyomtatón nyomtassanak.


Net start Messenger

Elindítja a Messenger szolgáltatást. A Messenger szolgáltatás lehetővé teszi a számítógép számára az üzenetek fogadását.

net start messenger

Kapcsolódó témakörök


Példa a Net start Messenger parancs használatára

Net start Messenger

Példa

Ha el akarja indítani a Messenger szolgáltatást, adja ki a következő parancsot:

net start messenger

Kapcsolódó témakörök


Megjegyzések a Net start Messenger parancshoz

Net start Messenger

Megjegyzések

Elindítja a Messenger szolgáltatást, amely lehetővé teszi a számítógép számára üzenetek fogadását. Az üzenet küldése a számítógéphez rendelt azonosítónevekre történik.


Net start Microsoft DHCP Service

Elindítja a Microsoft DHCP szolgáltatást. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el, ha a TCP/IP protokoll és a DHCP szolgáltatás telepítve van.

net start "microsoft dhcp service"


Példa a Net start Microsoft DHCP Service parancs használatára

Net start Microsoft DHCP Service

Példa

Ha el akarja indítani a Microsoft DHCP szolgáltatást, adja ki a következő parancsot:

net start "microsoft dhcp service"


Megjegyzések a Net start Microsoft DHCP Service parancshoz

Net start Microsoft DHCP Service

Megjegyzések

A Microsoft DHCP szolgáltatás IP-címekkel látja el a hálózati ügyfeleket.

A két vagy több szóból álló szolgáltatásneveket idézőjelek (") közé kell zárni. A szolgáltatást a net start dhcpservice paranccsal is elindíthatja.


Net start TCP/IP NetBIOS Helper

Engedélyezi a Netbios segítő TCP felett szolgáltatást. Ez a parancs csak akkor érhető el, ha a TCP/IP telepítve van.

net start "tcp/ip netbios helper"


Net start Net Logon

Elindítja a Hálózati bejelentkezés szolgáltatást. A Hálózati bejelentkezés szolgáltatás ellenőrzi a bejelentkezési kéréseket és vezérli a felhasználói fiókok adatbázis-replikációját a tartományban. A két vagy több szóból álló szolgáltatásneveket (pl. Net Logon) idézőjelek (") közé kell zárni. A szolgáltatást a net start netlogon paranccsal is elindíthatja.

net start "net logon"


Példa a Net start Net Logon parancs használatára

Net start Net Logon

Példa

Ha el akarja indítani a Hálózati bejelentkezés szolgáltatást, adja ki a következő parancsot:

net start "net logon"


Megjegyzések a Net start Net Logon parancshoz

Net start Net Logon

Megjegyzések

Elindítja a Hálózati bejelentkezés szolgáltatást minden olyan kiszolgálón a tartományban, amely a tartomány felhasználói fiókokat tartalmazó adatbázisát használja.

Szolgáltatások parancssorból indításakor a két vagy több szóból álló szolgáltatásneveket (pl. Net Logon) idézőjelek (") közé kell zárni. A szolgáltatást a net start netlogon paranccsal is elindíthatja.

Elsődleges tartományvezérlők a Windows 2000 és LAN Manager 2.x vegyes tartományokban

Ha Windows 2000 Server tartományokat használ, az elsődleges tartományvezérlő csak Windows 2000 Server operációs rendszerrel rendelkező számítógép lehet. A tartomány másodlagos tartományvezérlői Windows 2000 Server vagy LAN Manager 2.x számítógépek egyaránt lehetnek.

Minden Windows 2000 operációs rendszerrel rendelkező számítógépnek Windows 2000 Server elsődleges tartományvezérlőre kell bejelentkeznie. A LAN Manager 2.x számítógépek LAN Manager 2.x és Windows 2000 Server elsődleges tartományvezérlőkre is bejelentkezhetnek.


Net start Network DDE

Elindítja a Hálózati DDE szolgáltatást.

net start "network dde"


Net Start Network DDE DSDM

Elindítja a Hálózati DDE DSDM kiszolgáló szolgáltatást.

net start "network dde dsdm"


Net start NT LM Security Support Provider

Elindítja az NT LM biztonságszolgáltató szolgáltatást. Ez a parancs csak akkor érhető el, ha az NT LM biztonságszolgáltató szolgáltatás telepítve van.

net start "nt lm security support provider"


Net start OLE

Elindítja az objektumcsatolás és -beágyazás szolgáltatást.

net start ole


Net start Print Server for Macintosh

Elindítja a Macintosh nyomtatókiszolgáló szolgáltatást, amely lehetővé teszi a Macintosh számítógépekről történő nyomtatást. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el.

net start "print server for macintosh"


Net start Remote Access Connection Manager

Elindítja a Távelérési csatlakozáskezelő szolgáltatást. Ez a parancs csak akkor érhető el, ha a Távelérés szolgáltatás telepítve van.

net start "remote access connection manager"


Net start Remote Access ISNSAP Service

Elindítja a Távelérés ISNSAP szolgáltatást. Ez a parancs csak akkor érhető el, ha a Távelérés szolgáltatás telepítve van.

net start "remote access isnsap service"


Net start Remote Access Server

Elindítja a Távelérés-kiszolgáló szolgáltatást. Ez a parancs csak akkor érhető el, ha a Távelérés szolgáltatás telepítve van.

net start "remote access server"


Net start Directory Replicator

Elindítja a Könyvtárreplikátor szolgáltatást. A Könyvtárreplikátor szolgáltatás a megjelölt fájlokat a megadott kiszolgálókra másolja. A két vagy több szóból álló szolgáltatásneveket idézőjelek (") közé kell zárni. A szolgáltatást a net start replicator paranccsal is elindíthatja.

net start "directory replicator"


Példa a Net start Directory Replicator parancs használatára

Net start Directory Replicator

Példa

Ha el akarja indítani a Könyvtárreplikátor szolgáltatást, adja ki a következő parancsot:

net start "directory replicator"


Megjegyzések a Net start Directory Replicator parancshoz

Net start Directory Replicator

Megjegyzések

A Könyvtárreplikátor szolgáltatás segítségével biztosíthatja, hogy a megjelölt fájlok minden megadott kiszolgálón pontosan ugyanazok legyenek. A Könyvtárreplikátor szolgáltatást az elindítás előtt konfigurálni kell.

A két vagy több szóból álló szolgáltatásneveket (pl. Directory Replicator vagy Computer Browser) idézőjelek (") közé kell zárni. A szolgáltatást a net start replicator paranccsal is elindíthatja.


Net start Remote Procedure Call (RPC) Service

Elindítja a Távoli eljáráshívás (RPC) szolgáltatást. A Távoli eljáráshívás (RPC) szolgáltatás a Microsoft Windows 2000 RPC alrendszere. Az RPC alrendszer magába foglalja a végpontleképezőt és egyéb RPC szolgáltatásokat.

net start "remote procedure call (rpc) service"


Példa a Net start Remote Procedure Call (RPC) Service parancs használatára

Net start Remote Procedure Call (RPC) Service

Példa

A Távoli eljáráshívás (RPC) szolgáltatás elindításához adja ki a következő parancsot:

net start "remote procedure call (rpc) service"


Megjegyzések a Net start Remote Procedure Call (RPC) Service parancshoz

Net start Remote Procedure Call (RPC) Service

Megjegyzések

Elindítja a Távoli eljáráshívás (RPC) szolgáltatást, amely lehetővé teszi az elosztott alkalmazások számára dinamikus végpontok használatát. A Távoli eljáráshívás (RPC) szolgáltatás kezeli a végpontleképező adatbázist.

Az elosztott alkalmazás kiszolgálóoldali része regisztrálja végpontjait a Távoli eljáráshívás (RPC) szolgáltatásban. Az ügyfélkiszolgáló futásidejű könyvtár az elosztott alkalmazás ügyféloldali része nevében a Távoli eljáráshívás (RPC) szolgáltatást lekérdezve megszerzi a végpont-információkat.

Ha nem tudja, hogy az elosztott alkalmazás használja-e a végpontleképező szolgáltatást, olvassa el az elosztott alkalmazás dokumentációját.

A két vagy több szóból álló szolgáltatásneveket idézőjelek (") közé kell zárni. A szolgáltatást a net start rpcss paranccsal is elindíthatja.


Net start Schedule

Elindítja az Ütemezés szolgáltatást. Az Ütemezés szolgáltatás lehetővé teszi a számítógép számára a programok megadott időben történő elindítását az at paranccsal.

net start schedule

Kapcsolódó témakörök


Példa a Net start Schedule parancs használatára

Net start Schedule

Példa

Ha el akarja indítani az Ütemezés szolgáltatást, adja ki a következő parancsot:

net start schedule

Kapcsolódó témakörök


Megjegyzések a Net start Schedule parancshoz

Net start Schedule

Megjegyzések

Az at parancs csak akkor használható, ha az Ütemezés szolgáltatás fut. Az ütemezett parancsok sikeres futásához más szolgáltatások elindítása is szükséges lehet.

Az Ütemezés szolgáltatás eredeti konfigurációja szerint a helyi számítógép Rendszer fiókjában fut. Amikor az Ütemezés szolgáltatás ezt a fiókot használja, az Ütemezés szolgáltatás által végrehajtható feladatokra semmiféle korlátozás nincs. Ezek a feladatok azonban csak korlátozott hálózati hozzáféréssel rendelkeznek, mert a helyi számítógép Rendszer fiókját más számítógépek nem ismerik el.

Ha meg akarja haladni a hálózati hozzáférés korlátozásait, az Ütemező szolgáltatást úgy is konfigurálhatja, hogy az felhasználói fiókban fusson. Ezen felül az Ütemezés szolgáltatás által végrehajtott feladatokat a felhasználói fiók hálózati hozzáférése korlátozza. Mivel azonban az Ütemező szolgáltatás ebben az esetben nem a helyi Rendszer fiókot használja, csak ablak megjelenését nem igénylő feladatok futtatása lehetséges.


Net start Server

Elindítja a Kiszolgáló szolgáltatást. A Kiszolgáló szolgáltatás lehetővé teszi a számítógép számára az erőforrások megosztását a hálózaton.

net start server

Kapcsolódó témakörök


Példa a Net start Server parancs használatára

Net start Server

Példa

Ha el akarja indítani a Kiszolgáló szolgáltatást, adja ki a következő parancsot:

net start server

Kapcsolódó témakörök


Megjegyzések a Net start Server parancshoz

Net start Server

Megjegyzések

A Kiszolgáló szolgáltatás segítségével megoszthatja a kiszolgáló erőforrásait a hálózati felhasználókkal.


Net start Simple TCP/IP Services

Elindítja az Egyszerű TCP/IP szolgáltatások szolgáltatást. Ez a parancs csak akkor érhető el, ha a TCP/IP és az Egyszerű TCP/IP szolgáltatások telepítve van.

net start "simple tcp/ip services"


Példa a Net start Simple TCP/IP Services parancs használatára

Net start Simple TCP/IP Services

Példa

Ha el akarja indítani az Egyszerű TCP/IP szolgáltatások szolgáltatást, adja ki a következő parancsot:

net start "simple tcp/ip services"


Megjegyzések a Net start Simple TCP/IP Services parancshoz

Net start Simple TCP/IP Services

Megjegyzések

Az Egyszerű TCP/IP szolgáltatások szolgáltatás támogatja a Character Generator, a Daytime, a Discard, az Echo és a Quote of the Day TCP/IP szolgáltatásokat. Elindítása után a számítógép válaszolhat olyan számítógépek kéréseire, amelyek támogatják ezeket a protokollokat.

A két vagy több szóból álló szolgáltatásneveket idézőjelek (") közé kell zárni.


Net start Simple TCP/IP Services

Net start Site Server LDAP Service

Elindítja a Site Server LDAP szolgáltatást. A Site Server LDAP szolgáltatás IP csoportos küldési konferenciákat tesz közzé a Windows 2000 Active Directoryban. Ez a parancs csak akkor érhető el, ha a Site Server LDAP szolgáltatás telepítve van.

net start "site server ldap service"


Net start SNMP

Elindítja az SNMP szolgáltatást. Az SNMP szolgáltatás lehetővé teszi a kiszolgáló számára, hogy jelentse aktuális állapotát az SNMP-kezelő rendszernek a TCP/IP hálózaton keresztül. Ez a parancs csak akkor érhető el, ha a TCP/IP és az SNMP telepítve van.

net start snmp

Kapcsolódó témakörök


Példa a Net start SNMP parancs használatára

Net start SNMP

Példa

Ha el akarja indítani az SNMP szolgáltatást, adja ki a következő parancsot:

net start snmp

Kapcsolódó témakörök


Net start Spooler

Elindítja a Nyomtatósor-kezelő szolgáltatást.

net start spooler

Kapcsolódó témakörök


Net start UPS

Elindítja a Szünetmentes tápegység (UPS) szolgáltatást.

net start ups

Kapcsolódó témakörök


Példa a Net start UPS parancs használatára

Net start UPS

Példa

Ha el akarja indítani a UPS szolgáltatást, adja ki a következő parancsot:

net start ups

Kapcsolódó témakörök


Megjegyzések a Net start UPS parancshoz

Net start UPS

Megjegyzések

A UPS szolgáltatást a Vezérlőpulton található Energiagazdálkodási lehetőségek segédprogrammal konfigurálhatja. Ha a UPS szolgáltatást úgy konfigurálja, hogy a rendszer leállásakor parancsot hajtson végre, a parancsnak 30 másodperc alatt be kell fejeződnie. Ellenkező esetben a számítógép nem megfelelően áll le.


Net start Windows Internet Name Service

Elindítja a Windows Internet Name Service szolgáltatást. Ez a parancs csak a Windows 2000 Server operációs rendszerrel rendelkező számítógépeken érhető el, ha a TCP/IP és a Windows Internet Name Service szolgáltatás telepítve van.

net start "windows internet name service"


Példa a Net start Windows Internet Name Service parancs használatára

Net start Windows Internet Name Service

Példa

Ha el akarja indítani a Windows Internet Name Service szolgáltatást, adja ki a következő parancsot:

net start "windows internet name service"


Megjegyzések a Net start Windows Internet Name Service parancshoz

Net start Windows Internet Name Service

Megjegyzések

A Windows Internet Name Service szolgáltatás leképezi a hálózaton található ügyfélszámítógépek neveit TCP/IP-címekre.

A két vagy több szóból álló szolgáltatásneveket (pl. Windows Internet Name vagy Uninterruptible Power Supply) idézőjelek (") közé kell zárni. A szolgáltatást a net start wins paranccsal is elindíthatja.


Net start Workstation

Elindítja a Munkaállomás szolgáltatást. A Munkaállomás szolgáltatás lehetővé teszi a számítógép számára a hálózatra kapcsolódást és a hálózati erőforrások használatát.

net start workstation

Kapcsolódó témakörök


Példa a Net start Workstation parancs használatára

Net start Workstation

Példa

Ha el akarja indítani a Munkaállomás szolgáltatást, adja ki a következő parancsot:

net start workstation

Kapcsolódó témakörök


Megjegyzések a Net start Workstation parancshoz

Net start Workstation

Megjegyzések

Elindítja a Munkaállomás szolgáltatást, amely lehetővé teszi a számítógép számára a hálózati információk és infrastruktúra használatát.


Net statistics

Megjeleníti a helyi Munkaállomás vagy Kiszolgáló szolgáltatás, illetve az azon futó szolgáltatások elérhető statisztikanaplóját.

net statistics [workstation | server]

Paraméterek

nincs

A net statistics paraméterek nélkül kiadva kilistázza azokat a futó szolgáltatásokat, amelyekhez van statisztika.

workstation

Megjeleníti a helyi Munkaállomás szolgáltatás statisztikáját.

server

Megjeleníti a helyi Kiszolgáló szolgáltatás statisztikáját.


Példák a Net statistics parancs használatára

Net statistics

Példák

Ha meg akarja jeleníteni azokat a futó szolgáltatásokat, amelyekhez van statisztika, adja ki a következő parancsot:

net stats

Ha meg akarja jeleníteni a Kiszolgáló szolgáltatás statisztikáját, és meg akarja akadályozni, hogy az információ kezdete kifusson a képernyőről, adja ki a következő parancsot:

net statistics server | more


Megjegyzések a Net statistics parancshoz

Net statistics

Megjegyzések

Ezt a parancsot net stats alakban is kiadhatja.

A net statistics parancs segítségével megjelenítheti a megadott szolgáltatás teljesítményére vonatkozó információkat.

Kiszolgáló szolgáltatás

A Windows 2000 jelenti a számítógép nevét, a statisztika legutóbbi frissítésének dátumát és időpontját, valamint a következő információkat:

  • Az automatikusan elindított és szétkapcsolt, illetve hiba miatt szétkapcsolt munkamenetek számát;
  • az elküldött és fogadott adatok méretét kilobájtban, és a kiszolgáló átlagos válaszidejét;
  • a hibák, valamint a jelszó- és engedélykorlátok megsértésének számát;
  • a megosztott fájlok, nyomtatók és kommunikációs eszközök használatának számát;
  • és a memóriapuffer mérete túllépésének számát.

Munkaállomás szolgáltatás

A Windows 2000 jelenti a számítógép nevét, a statisztika legutóbbi frissítésének dátumát és időpontját, valamint a következő információkat:

  • A fogadott és átvitt bájtok és Kiszolgáló-üzenetblokkok (SMB) számát;
  • a sikeres és sikertelen olvasás és írás műveletek számát;
  • a hálózati hibák számát;
  • a sikertelen, szétkapcsolt vagy újracsatlakoztatott munkamenetek számát;
  • és a megosztott erőforrásokhoz irányuló sikeres és sikertelen kapcsolatok számát.


Net stop

Leállít egy Windows 2000 hálózati szolgáltatást.

net stop szolgáltatás

Paraméterek

szolgáltatás

A következő szolgáltatások választhatók:

alerter | network dde dsdm | simple tcp/ip services
client service for netware | nt lm security support provider | site server LDAP service
clipbook server | ole | snmp
computer browser | remote access connection manager | spooler
directory replicator | remote access isnsap service | tcp/ip netbios helper
ftp publishing service | remote access server | ups
lpdsvc | remote procedure call (rpc) locator | workstation
messenger | remote procedure call (rpc) service
net logon | schedule
network dde | server

A következő szolgáltatások csak Windows 2000 Server operációs rendszert futtató számítógépen érhetők el:

Macintosh fájlszolgáltatás
NetWare átjárószolgáltatás
Microsoft DHCP szolgáltatás
Macintosh nyomtatószolgáltatás
Windows Internet Name Service


Példák a Net stop parancs használatára

Net stop

Példák

Ha le akarja állítani a Kiszolgáló szolgáltatást, adja ki a következő parancsot:

net stop server


Megjegyzések a Net stop parancshoz

Net stop

Megjegyzések

A net stop parancs segítségével leállíthat egy szolgáltatást, megállíthatja a szolgáltatás által végzett funkciót és eltávolíthatja a szoftvert a memóriából.

Ha a Kiszolgáló szolgáltatást leállítja, a felhasználók nem tudnak hozzáférni a számítógép megosztott erőforrásaihoz. Ha a Kiszolgáló szolgáltatást olyan időpontban kívánja leállítani, amikor a felhasználók használják az erőforrásokat, a Windows 2000 figyelmeztető üzenetet jelenít meg, és megerősítést kér arról, hogy valóban meg akarja szakítani a kapcsolatokat. Az i (igen) válasz után a rendszer megszakítja a számítógéppel fennálló valamennyi kapcsolatot.

A Kiszolgáló szolgáltatás leállítása előtt a következőket teheti:

  • Szüneteltetheti a szolgáltatást (így megakadályozva új kapcsolatok létrejöttét).
  • Üzenetben szólíthatja fel a felhasználókat a kiszolgáló erőforrásairól történő lekapcsolódásra.

A net stop paranccsal a nem a Windows 2000 csomagban kapott szolgáltatásokat is leállíthatja.

További információk:

Téma: | Kapcsolódó témakör:
A /yes és /no kapcsoló használata | Net (a parancs kapcsolói)
Szolgáltatások elindítása, szüneteltetése és folytatása | Net Continue, Net Pause és Net Start


Net time

Szinkronizálja a számítógép óráját egy másik számítógép vagy egy tartomány órájával. A /set kapcsoló nélkül használva megjeleníti a másik számítógép vagy tartomány óráját.

net time [\\számítógépnév | /domain[:tartománynév] | /rtsdomain[:tartománynév]] [/set]

net time [\\számítógépnév] [/querysntp] | [/setsntp[:ntp-kiszolgáló_lista]]

Paraméterek

nincs

Megjeleníti a helyi számítógép Windows kiszolgálói tartományában időkiszolgálóként kijelölt számítógép által jelzett aktuális dátumot és időt.

\\számítógép neve

Megadja annak a kiszolgálónak a nevét, amelyet ellenőrizni, illetve amellyel szinkronizálni kíván.

/domain[:tartomány neve]

Megadja azt a tartományt, amelynek idejével szinkronizálni kívánja az időt.

/rtsdomain[:tartománynév]

Megadja a Pontos idő kiszolgáló tartományát, mely kiszolgálóval az idő szinkronizálva lesz.

/set

Szinkronizálja a számítógép idejét a megadott számítógép vagy tartomány idejével.

/querysntp

Megjeleníti a helyi számítógéphez aktuálisan beállított, vagy a \\computername paraméterrel megadott Network Time Protocol (NTP) kiszolgáló nevét.

/setsntp[:ntp-kiszolgáló_lista]

Listát adhat meg az NTP időkiszolgálókról, melyeket a helyi számítógép használhat. A listában lehetnek IP-címek vagy DNS-nevek, szóközökkel elválasztva. Ha több időkiszolgálót használ, a listát idézőjelek közé kell ékelni.


Net use

A számítógépet hozzákapcsolja vagy lekapcsolja egy megosztott erőforrásról, illetve információt jelenít meg a számítógép kapcsolatairól. Ez a parancs vezérli az állandó hálózati kapcsolatokat is.

net use [eszköz_neve | *] [\\számítógép_neve\megosztás_neve[\kötet]] [jelszó | *]] [/user:[tartomány_neve\]felhasználó_neve] [[/delete] | [/persistent: [yes | no}]]

net use eszköz_neve [/home[jelszó | *]] [/delete:{yes | no}]

net use [/persistent:{yes | no}]

Paraméterek

nincs

A net use parancsot paraméterek nélkül kiadva lekérheti a hálózati kapcsolatok listáját.

eszköz_neve

Megadja a kapcsolódáshoz az erőforrás nevét, vagy a leválasztani kívánt eszközt. Kétféle eszköznév létezik: lemezmeghajtók (D: - Z:) és nyomtatók (LPT1: - LPT3:). Ha konkrét eszköznév helyett csillagot ad meg, a rendszer a következő szabad eszköznevet rendeli hozzá.

\\számítógép_neve\megosztás_neve

Megadja a kiszolgáló és a megosztott erőforrás nevét. Ha a számítógép_neve üres karaktereket tartalmaz, a teljes számítógépnevet a kettős fordított ferde vonal (\\) kezdve a név végéig zárja idézőjelek (" ") közé. A számítógép neve 1 - 15 karakter hosszú lehet.

\kötet

Megadja a kiszolgálón található NetWare kötet nevét. A NetWare ügyfélszolgáltatást (Windows 2000 Professional) vagy NetWare átjáró-szolgáltatást (Windows 2000 Server) telepíteni és futtatni kell, ha NetWare kiszolgálókhoz kíván kapcsolódni.

jelszó

Megadja a megosztott erőforrás eléréséhez szükséges jelszót.

*

Parancssort jelenít meg a jelszó beírásához. A jelszó nem jelenik meg a beírás során.

/user

A kapcsolat létrehozásához használt felhasználói névtől eltérő felhasználónevet ad meg.

tartomány_neve

Másik tartományt ad meg. Például a net use d:\\server\share /user:admin\marial parancs a marial nevű felhasználót úgy csatlakoztatja, mintha a kapcsolat az admin nevű tartományból jött volna létre. Ha a tartomány_neve beállítást kihagyja, a rendszer az aktuális bejelentkezési tartományt használja.

felhasználó_neve

Megadja azt a felhasználónevet, amellyel be akar jelentkezni.

/delete

Megszakítja a megadott hálózati kapcsolatot. Ha a felhasználó a kapcsolat neve helyett csillag karaktert ad meg, minden hálózati kapcsolat megszakad.

/home

A felhasználót összekapcsolja annak kezdőkönyvtárával.

/persistent

Az állandó hálózati kapcsolatok használatát vezérli. Az alapértelmezett érték az utoljára megadott beállítás. Az eszköz nélküli kapcsolatok nem állandók.

igen

Menti a létrehozott kapcsolatokat és visszaállítja azokat a következő bejelentkezéskor.

nem

Nem menti a létrehozott és a következő kapcsolatokat. A létező kapcsolatokat a rendszer a következő bejelentkezés alkalmával helyreállítja. A /delete kapcsoló segítségével eltávolíthatja az állandó kapcsolatokat.


Példák a Net use parancs használatára

Net use

Példák

Ha az E: lemezmeghajtó-eszköznevet a \\Financial kiszolgáló Letters megosztott könyvtárához kívánja hozzárendelni, írja be a következő parancsot:

net use e: \\financial\letters

Ha az M: lemezmeghajtó-eszköznevet a \\Financial NetWare kiszolgálón található Letters kötetben lévő Maria könyvtárhoz kívánja hozzárendelni, adja ki a következő parancsot:

net use m: \\financial\letters\maria

Ha az LPT1: eszköznevet az \\Accounting kiszolgálón található Laser2 megosztott nyomtatási sorhoz kívánja hozzárendelni, adja ki a következő parancsot:

net use lpt1: \\accounting\laser2

Ha le akar kapcsolódni az LPT1: nyomtatási sorról, adja ki a következő parancsot:

net use lpt1: /delete

Ha a H: lemezmeghajtó-eszköznevet a saját könyvtárhoz kívánja hozzárendelni, mint mariel nevű felhasználó, adja ki a következő parancsot:

net use h: /home /user:mariel

Ha az F: lemezmeghajtó-eszköznevet a \\Financial kiszolgáló Indulo nevű megosztott könyvtárához kívánja hozzárendelni, amely a hctarcs jelszót kéri, de a kapcsolatot nem kívánja állandóvá tenni, adja ki a következő parancsot:

net use f: \\financial\indulo hctarcs /persistent:no

Ha le akar kapcsolódni a \\Financial\Indulo könyvtárról, adja ki a következő parancsot:

net use f: \\financial\indulo /delete

Ha a \\Financial2 kiszolgálón megosztott erőforráshoz kíván kapcsolódni, adja ki a következő parancsot:

net use k: "\\financial 2" \emlekeztetok

A szóközt tartalmazó kiszolgálóneveket idézőjelek közé kell zárni. Ha elhagyja az idézőjelet, a Windows 2000 hibaüzenetet jelenít meg.

Ha a jövőbeni változásoktól függetlenül, minden bejelentkezés alkalmával vissza akarja állítani az aktuális kapcsolatokat, adja ki a következő parancsot:

net use /persistent:yes


Megjegyzések a Net use parancshoz

Net use

Megjegyzések

A net use parancs segítségével kapcsolódhat és leválhat hálózati erőforrásokról, és megjelenítheti a hálózati erőforrásokkal fennálló jelenlegi kapcsolatait. Megosztott könyvtárról nem lehet lekapcsolódni, ha az éppen az aktuális meghajtó, illetve ha azt aktív folyamat használja.

Információ szerzése egy kapcsolatról

Ha információk kíván szerezni egy kapcsolatról, hajtsa végre a következő műveletek egyikét:

  • A net use eszköz_neve parancsot kiadva szerezzen információt az adott kapcsolatról.
  • A net use parancsot kiadva megjelenítheti a számítógép összes kapcsolatát tartalmazó listát.

Eszköz nélküli kapcsolatok

Az eszköz nélküli kapcsolatok nem állandók.

Kapcsolódás NetWare kiszolgálókhoz

A NetWare ügyfél vagy átjáró szolgáltatás telepítése és futtatása után lehetségessé válik a Novell hálózaton található NetWare kiszolgálóhoz történő kapcsolódás. Ugyanazt a szintaxist használhatja, mint a Windows hálózati kiszolgáló esetén, azzal az eltéréssel, hogy meg kell adni annak a kötetnek a nevét, amelyhez kapcsolódni kíván.


Net user

Felhasználói fiókokat vesz fel, módosít, illetve megjeleníti a felhasználói fiókok adatait.

net user [felhasználó neve [jelszó | *] [beállítások]] [/domain]

net user felhasználó neve {jelszó | *} /add [beállítások] [/domain]

net user felhasználó neve [/delete] [/domain]

Paraméterek

nincs

A net user parancsot paraméterek nélkül kiadva megjelenítheti a számítógépen található felhasználói fiókok listáját.

felhasználónév

Megadja a felvenni, törölni, módosítani, illetve megjeleníteni kívánt felhasználói fiók nevét. A felhasználói fiók neve legfeljebb 20 karakterből állhat.

jelszó

Hozzárendeli vagy módosítja a felhasználói fiók jelszavát. A jelszó minimális hosszának ki kell elégíteni a /minpwlen kapcsolóval megadott követelményt, amelyet a net accounts parancs segítségével adhat meg. Legfeljebb 127 karaktert tartalmazhat. Ha a Windows 2000 rendszert olyan hálózaton használja, amelyre Windows 95 vagy Windows 98 rendszert használó számítógépek is csatlakoznak, ne adjon meg 14 karakternél hosszabb jelszót. A Windows 95 és a Windows 98 legfeljebb 14 karakter hosszú jelszavak használatát támogatja. Ha a jelszó hosszabb, nem biztos, hogy be tud jelentkezni a hálózatra a Windows korábbi verzióját futtató számítógépről.

*

Parancssort jelenít meg a jelszó beírásához. A jelszó nem jelenik meg a jelszó parancssorba történő beírás során.

/domain

A műveletet a számítógép elsődleges tartományának elsődleges tartományvezérlőjén hajtja végre.

Ez a paraméter csak azokra a Windows 2000 Professional operációs rendszerrel rendelkező számítógépekre vonatkozik, amelyek Windows 2000 Server tartomány tagjaiként működnek. A Windows 2000 Server számítógépek alapértelmezés szerint az elsődleges tartományvezérlőn hajtják végre a műveleteket.

Megjegyzés

  • A művelet a számítógép elsődleges tartományának elsődleges tartományvezérlőjén lesz végrehajtva. Ez nem minden esetben egyezik meg a bejelentkezési tartománnyal.

/add

Felhasználói fiókot vesz fel a felhasználói fiókokat tartalmazó adatbázisba.

/delete

Felhasználói fiókot távolít el a felhasználói fiókokat tartalmazó adatbázisból.

beállítások

Megadja a következő beállításokat:

/active:{no | yes}

Engedélyezi vagy tiltja a felhasználói fiókot. Ha a felhasználói fiók nem aktív, a felhasználó nem fér hozzá a számítógép erőforrásaihoz. Az alapértelmezett érték yes (aktív).

/comment:"szöveg"

Leíró megjegyzést fűz a felhasználói fiókhoz. A megjegyzés legfeljebb 48 karaktert tartalmazhat. A szöveget zárja idézőjelek közé.

/countrycode:nnn

Az operációs rendszer országkódjai segítségével határozza meg a nyelvi fájlokat a felhasználó súgójához és hibaüzeneteihez. A 0 érték az alapértelmezett országkódot jelzi.

/expires:{dátum | never}

A felhasználói fiók lejár, ha a dátum beállítás meg van adva; időkorlátot nem alkalmaz a felhasználói fiókra. A lejárati dátumot hh/nn/éé, nn/hh/éé vagy hhh,nn,éé formátumban lehet megadni, az országkódtól függően. Ügyeljen arra, hogy a fiók a megadott dátum kezdetével jár le. A hónapot megadhatja számmal, betűvel, vagy hárombetűs rövidítéssel. Az éveket megadhatja kettő vagy négy számjeggyel. A dátum részeit vesszővel vagy perjellel választhatja el egymástól (szóközzel nem). Ha az éé beállítást kihagyja, a rendszer a dátum (a számítógép által mutatott dátum és idő szerinti) következő előfordulását veszi alapul. Például a következő dátum bejegyzések egyenértékűek, ha 1994. január 10-e és 1995. január 8-a között adja meg őket:

jan,9
1/9/95
january,9,1995
1/9

/fullname:"név"

Megadja a felhasználó teljes nevét (nem a felhasználónevet). A nevet zárja idézőjelek közé.

/homedir:elérési út

Megadja a felhasználó kezdőkönyvtárának elérési útját. Az elérési útnak léteznie kell.

/passwordchg:{yes | no}

Meghatározza, hogy a felhasználók módosíthatják-e a jelszavukat. Az alapértelmezett érték yes.

/passwordreq:{yes | no}

Megadja, hogy a felhasználói fiókhoz kötelező-e megadni jelszót. Az alapértelmezett érték yes.

/profilepath:[elérési út]

Megadja a felhasználó bejelentkezési profiljának elérési útját. Ez az elérési út a rendszerleíró adatbázis profilra mutat.

/scriptpath:elérési út

Megadja a felhasználó bejelentkezési parancsfájljának elérési útját. Az elérési út értéke nem lehet abszolút elérési út; az elérési út a könyvtárhoz képest van megadva: %systemroot%\System32\Repl\Import\Scripts.

/times:{alkalmak száma | all}

Megadja, hogy a felhasználó hányszor használhatja a számítógépet. Az alkalmak száma értékét nap[-nap][,nap[-nap]] ,időpont[-időpont][,időpont[-időpont]] formában lehet megadni, 1 órás pontosságra korlátozva. A napokat megadhatja teljes alakban vagy rövidítve (M,T,W,Th,F,Sa,Su). Az órákat megadhatja 12 órás és 24 órás jelöléssel. A 12 órás jelölés esetén használja az AM, PM vagy A.M., P.M. értékeket. Az all érték azt jelenti, hogy a felhasználó mindig bejelentkezhet. A null érték (üres) azt jelenti, hogy a felhasználó sohasem jelentkezhet be. A napokat és időpontokat vesszővel, a napok és az idő egységeit pontosvesszővel válassza el (például M,4AM-5PM;T,1PM-3PM). Az időpontok jelölésében be használjon szóköz karaktereket.

/usercomment:"szöveg"

Megadja, hogy a felhasználói fiókhoz tartozó "Felhasználói megjegyzést", amit a rendszergazdák használnak. A szöveget zárja idézőjelek közé.

/workstations:{számítógép neve[,...] | *}

Megjeleníti nyolc munkaállomás nevét, amelyekről a felhasználó bejelentkezhet a hálózatra. A lista egyes bejegyzéseit vesszővel kell elválasztani egymástól. Ha a /workstations kapcsoló nem ad listát, vagy a lista egy * karakterből áll, a felhasználó bármelyik számítógépről bejelentkezhet.


Példák a Net user parancs használatára

Net user

Példák

Ha meg akarja jeleníteni a helyi számítógépen található valamennyi felhasználói fiók listáját, adja ki a következő parancsot:

net user

Ha információt kíván megjeleníteni a peterv nevű felhasználói fiókról, adja ki a következő parancsot:

net user peterv

Ha felhasználói fiókot kíván felvenni Katona Elek számára, aki reggel 8 óra és délután 5 óra között jelentkezhet be hétfőtől péntekig (nincs szünet az időmegjelölésekben), kötelező jelszót megadnia (kelek), és a teljes felhasználónevet is meg kívánja adni, adja ki a következő parancsot:

net user kelek kelek /add /passwordreq:yes /times:monday-friday,8am-5pm/fullname:"Katona Elek"

Ha janosm bejelentkezési idejét (délelőtt 8 órától délután 5 óráig) 24 órás jelölést használva kívánja megadni, adja ki a következő parancsot:

net user janosm /time:M-F,08:00-17:00

Ha janosm bejelentkezési idejét (délelőtt 8 órától délután 5 óráig) 12 órás jelölést használva kívánja megadni, adja ki a következő parancsot:

net user janosm /time:M-F,8am-5pm

Ha marial bejelentkezési idejét hétfőn délelőtt 4 órától délután 5 óráig, kedden délután 1 órától délután 3 óráig, valamint szerdától péntekig délelőtt 8 órától délután 5 óráig akarja megadni, adja ki a következő parancsot:

net user marial /time:M,4am-5pm;T,1pm-3pm;W-F,8:00-17:00


Megjegyzések a Net user parancshoz

Net user

Megjegyzések

Ezt a parancsot net users alakban is beírhatja.

A net user parancs segítségével felhasználói fiókokat hozhat létre és kezelhet a tartományban. A felhasználói fiókok adatait a felhasználói fiókokat tartalmazó adatbázis tárolja.

Megjegyzés

  • Amikor kiadja a net user parancsot a Windows 2000 Server operációs rendszerrel rendelkező számítógépen, a felhasználói fiókokat tartalmazó adatbázis automatikusan módosul az elsődleges tartományvezérlőn, majd ezeket a rendszer replikálja a másodlagos tartományvezérlőkön. Ez csak a Windows 2000 Server tartományokra érvényes.


Net view

Megjeleníti a tartományok listáját, a számítógépek listáját, illetve a megadott számítógép által megosztott erőforrások listáját.

net view [\\számítógép neve | /domain[:tartomány neve]]

net view /network:nw [\\számítógép neve]

Paraméterek

nincs

A net view parancsot paraméterek nélkül kiadva megjelenítheti az aktuális tartományban található számítógépek listáját.

\\számítógép neve

Megadja azt a számítógépet, amelynek megosztott erőforrásait meg akarja jeleníteni.

/domain[:tartomány neve]

Megadja azt a tartományt, amelyben meg akarja jeleníteni az elérhető számítógépeket. Ha a tartomány neve beállítást nem adja meg, a parancs a hálózat minden tartományát megjeleníti.

/network:nw

Megjeleníti a NetWare hálózatban található elérhető kiszolgálókat. Számítógépnév megadásakor a parancs a NetWare hálózatban található, adott számítógépen elérhető erőforrásokat jeleníti meg. A rendszerbe felvett más hálózatok is megadhatók ezzel a kapcsolóval.


Példák a Net view parancs használatára

Net view

Példák

Ha meg akarja jeleníteni a \\Munka számítógép által megosztott erőforrások listáját, adja ki a következő parancsot:

net view \\munka

Ha meg akarja jeleníteni a \\Marketing nevű NetWare kiszolgálón elérhető erőforrások listáját, adja ki a következő parancsot:

net view /network:nw \\marketing

Ha meg akarja jeleníteni az ertekesites tartományban vagy munkacsoportban található számítógépek listáját, adja ki a következő parancsot:

net view /domain:ertekesites

Ha meg akarja jeleníteni a NetWare hálózatban található kiszolgálók listáját, adja ki a következő parancsot:

net view /network:nw


Megjegyzések a Net view parancshoz

Net view

Megjegyzések

A net view parancs számítógépek listáját jeleníti meg. A megjelenített adatok a következőképpen néznek ki:

Kiszolgálónév           Megjegyzés

-------------------------------------------------

\\Munka                 Fájlkiszolgáló

\\Print1                Nyomtatószoba az első emeleten

\\Print2                Nyomtatószoba a második emeleten


Netsh

A NetShell segédprogram (netsh) egy parancssori parancsnyelvi felület a Windows 2000 konfigurálásához és figyeléséhez. A konfigurációs eszköz egy interaktív rendszerhéj-felületet biztosít a felhasználó számára. A program látható fele egy parancshéj, amely parancsokat fogad el. A háttérben egy rendszerösszetevőhöz vagy segédprogramhoz tartozó segítő van. A segítő egy dinamikus csatolású könyvtár fájl (.dll), amely kibővíti a netsh parancs funkcióit. A segítő egy vagy több szolgáltatáshoz, segédprogramhoz vagy protokollhoz nyújt konfigurációs és/vagy figyelési támogatást, de kiegészíthet másik segítőt is. A parancshéj átirányítja a parancsot a megfelelő segítőhöz, és a segítő végrehajtja a parancsot.

A netsh parancs lehetővé teszi a NetShell segédprogram futtatását, amely megjeleníti vagy módosítja az éppen futó számítógép konfigurációját. Lehetőség van parancsfájlok használatára is, amelyekkel egy parancssorozatot lehet lefuttatni egy számítógépen.

Környezet

A parancshéj használja a környezeteket, amely egy adott hálózati összetevőre vonatkozó netsh parancsok csoportja. A környezetet egy karakterlánc azonosítja, amely hozzá van fűzve a parancsokhoz. Egy adott környezetben megadott parancsok egy hozzájuk társított segítőhöz kerülnek. Az elérhető környezetek függnek a telepített Windows 2000 összetevőktől. Például a routing utasítás hatására a netsh parancs az útválasztás környezetre vált. A ras utasítás hatására a netsh parancssor a ras (az Útválasztás és távoli elérés szolgáltatás távoli elérés része) környezetre vált.

Minden környezetben létezhetnek alkörnyezetek. Például az útválasztás környezeten belül át lehet váltani az ip és az ipx alkörnyezetre.

netsh [-r TávoliSzámítógép] [-a AliasFájl] [-c Környzet] [Parancs | -f Parancsfájl]

A környezetben használható parancsok és az alkörnyezetek listájának megjelenítéséhez a netsh parancssorban írja be a környezet nevét és egy szóközzel elválasztva egy kérdőjelet (?). Például, az útválasztás (routing) környezetben használható parancsok és az alkörnyezetek listájának megjelenítéséhez írja be a következő parancsot a netsh parancssorban:
netsh> routing ?

Netsh parancsok

A fent bemutatott környezeti parancsokhoz hasonlóan a következő parancsok is használhatók a Netsh programban. A nem kötelező paramétereket zárójelek jelölik ([ ]). A választható paraméterek között egy függőleges vonal (|) látható.

Parancsok | Eredmény
? | Megjeleníti a súgót.
abort | Eldobja az offline üzemmódban végrehajtott módosításokat. Online üzemmód esetén nincs hatása.
add segítő DLL-név | Telepíti a segítő DLL-t a netsh programban.
alias [aliasnév] [karakterlánc1] [karakterlánc2 ...] | Ha csak az alias paraméter van megadva, felsorolja az összes aliast. Az alias aliasnév formátum használata esetén az egyenértékű karakterlánc jelenik meg. Az alias aliasnév karakterlánc1 karakterlánc2 formátum használata esetén az aliasnév a megadott karakterláncot veszi fel.
bye | Kilép a programból.
commit | Véglegesíti a kapcsolat nélküli üzemmódban végrehajtott változtatásokat az útválasztó felé. Online üzemmód esetén nincs hatása.
delete helper DLL-név | Eltávolítja a netsh programból a segítő DLL-t.
dump -fájl-név | Kiírja vagy hozzáfűzi a konfigurációt egy szövegfájlba.
exec Parancsfájlnév | Betölti a parancsfájlt és végrehajtja a benne található utasításokat.
exit | Kilép a programból.
h | Megjeleníti a súgót.
help | Megjeleníti a súgót.
offline | Az aktuális üzemmódot kapcsolat nélkülire állítja. Az ebben az üzemmódban végzett módosításokat elmenti a program, de a beállítás véglegesítéséhez az útválasztón szükség van egy commit vagy egy online parancsra.
online | Az aktuális üzemmódot online-ra állítja. Az ebben az üzemmódban végzett módosítások azonnali hatással vannak az útválasztóra.
popd | Előhív egy környezetet a veremből.
pushd | Leteszi az aktuális környezetet a verembe.
quit | Kilép a programból.
set mode [mode =] online | offline | Az aktuális üzemmódot online-ra vagy kapcsolat nélkülire állítja.
show alias | helper | mode | A show alias parancs felsorolja az összes definiált aliast. A show helper parancs felsorolja az összes legfelsőbb szintű segítőt. A show mode parancs megmutatja az aktuális üzemmódot.
unalias aliasnév | Törli a megadott aliast.


Netstat

Protokollstatisztikákat és az aktuális TCP/IP hálózati kapcsolatokat jeleníti meg. Ez a parancs csak akkor érhető el, ha a TCP/IP protokoll telepítve van.

netstat [-a] [-e] [-n] [-s] [-p protokoll] [-r] [időköz]

Paraméterek

-a

Megjeleníti az összes kapcsolatot és figyelő portot. A kiszolgálókapcsolatok rendszerint nem jelennek meg.

-e

Megjeleníti az Ethernet statisztikát. Ez a kapcsoló használható az -s kapcsolóval együtt.

-n

Numerikus formában jeleníti meg a címeket és a portszámokat (nem próbálja megkeresni a neveket).

-s

Protokollok szerinti statisztikát jelenít meg. Alapértelmezés szerint a TCP, UDP, ICMP és IP protokollok statisztikája jelenik meg. A -p kapcsoló használatával megadható az alapértelmezett protokollok részhalmaza.

-p protokoll

Megmutatja a megadott protokoll kapcsolatait. A protokoll paraméter lehet tcp vagy udp. Az -s kapcsolót használva a protokollok szerinti statisztika megjelenítéséhez, a protokoll paraméter lehet tcp, udp, icmp vagy ip.

-r

Megjeleníti az útvonaltábla tartalmát.

időköz

Újra megjeleníti a kijelölt statisztikákat az időköz paraméterrel megadott másodpercnyi hosszúságú szünetekre megállva két statisztika megjelenítése között. Az újbóli megjelenítés leállításához nyomja meg a CTRL+B billentyűkombinációt. Ha ez a paraméter nincs megadva a netstat parancs egyszerre jeleníti meg a konfigurációs információkat.


Megjegyzések a Netstat parancshoz

Netstat

Megjegyzések

A Netstat segédprogram a következő hálózati összetevőkről nyújt információkat:

Külső cím

Annak a távoli számítógépnek az IP-címe és portszáma, amelyhez a szoftvercsatorna csatlakoztatva van. Ha a Hostsfile tartalmazza az IP-címet, akkor az IP-cím helyett a megfelelő név jelenik meg. Ha a port még nincs létrehozva, a portszám helyett egy csillag (*) jelenik meg.

Helyi cím

A helyi számítógép IP-címe és a kapcsolat által használt portszám. Ha a Hostsfile tartalmazza az IP-címet, akkor az IP-cím helyett a megfelelő név jelenik meg. Ha a port még nincs létrehozva, a portszám helyett egy csillag (*) jelenik meg.

Proto

A kapcsolat által használt protokoll neve.

(állapot)

Csak a TCP kapcsolatok állapotát jelzi. A lehetséges állapotok a következők:

CLOSED | FIN_WAIT_2 | SYN_RECEIVED
CLOSE_WAIT | LAST_ACK | SYN_SEND
ESTABLISHED | LISTEN | TIMED_WAIT
FIN_WAIT_1 |  |


Nlsfunc

Országtól függő információt tölt be. A Windows 2000 és az MS-DOS alrendszer nem használja ezt a parancsot. Csak az MS-DOS fájlokkal fenntartott kompatibilitás miatt fogadja el a rendszer.


Nslookup

Ez a diagnosztikai eszköz információt jelenít meg a Tartománynévrendszer (DNS) névkiszolgálókról. Az eszköz használata előtt meg kell ismernie a DNS működését. Az Nslookup csak akkor érhető el, ha a TCP/IP protokoll telepítve van.

Módok

Az Nslookup parancs kétféle módban használható: interaktív és nem interaktív módban.

Amennyiben csak egyetlen adatot kíván megkeresni, használja a nem interaktív módot. Első argumentumként írja be a keresett számítógép nevét vagy IP-címét. Második argumentumként írja be egy DNS névkiszolgáló nevét vagy IP-címét. Ha nem ír be második argumentumot, akkor az alapértelmezett DNS névkiszolgálót használja a parancs.

Ha több adatot kíván megkeresni, használja az interaktív módot. Első argumentumként írjon be egy gondolatjelet (-), majd második argumentumként írja be egy DNS névkiszolgáló nevét vagy IP-címét. Ha egyik argumentumot sem adja meg, az alapértelmezett DNS névkiszolgáló kerül felhasználásra.

nslookup [-beállítás ...] [keresendő_számítógép | - [kiszolgáló]]

Paraméterek

-beállítás ...

Egy vagy több nslookup parancsot ad meg parancssori kapcsolóként. A parancsok listáját az Nslookup alparancsok témakörnél találja. Minden egyes beállítás egy gondolatjelből (-), azt közvetlenül követően a parancs nevéből, és egyes esetekben még egy egyenlőségjelből (=), majd egy értékből áll. Például az állomás- (számítógép) információ lekérdezése alapértelmezett típusának módosításához és a kezdeti időtúllépés értékének 10 másodpercre történő beállításához a következőt kell beírni:

nslookup -querytype=hinfo -timeout=10

A parancssornak 256 karakternél rövidebbnek kell lennie.

keresendő_számítógép

Információt keres a keresendő_számítógépről, az aktuális alapértelmezett kiszolgáló, vagy egy megadott kiszolgáló használatával. Ha a keresendő_számítógép egy IP-cím, és a lekérdezés típusa A vagy PTR, a válaszban a számítógép neve jelenik meg. Ha a keresendő számítógép olyan név, amelyet nem követ pont, a rendszer az alapértelmezett DNS tartománynevet fűzi a névhez. Ez a viselkedés a következő, set beállítások állapotától függ: domains, srchlist, defname és search.

Az aktuális DNS tartományon kívüli számítógép kereséséhez írjon a név mögé egy pontot.

Ha kötőjelet (-) ad meg a keresendő_számítógép helyett, a parancssor nslookup interaktív üzemmódba vált.

kiszolgáló

Megadja, hogy ez a kiszolgáló legyen a DNS névkiszolgáló. Ha elhagyja a server beállítást, a rendszer az alapértelmezett DNS névkiszolgálót használja.


Nslookup: exit

Kilép az nslookup parancsból.

exit


Nslookup: finger

Kapcsolódik az aktuális számítógép finger-kiszolgálójához. Az aktuális számítógép meghatározása az után az előző számítógépkeresés után történik, amely sikeres volt és címinformációt adott vissza. További információért keresse meg a Kapcsolódó témakörök között a setquerytype=A parancsot.

finger [felhasználónév] [> fájlnév] | [>> fájlnév]

Paraméterek

felhasználónév

Megadja a keresendő felhasználó nevét.

fájlnév

Megadja annak a fájlnak a nevét, amelybe a kimenetet menti. A kimenet szokásos módon történő átirányításához használhatja a nagyobb (>) és a kettős nagyobb (>>) karaktereket.


Nslookup: help

Az nslookup alparancsok rövid összefoglalását jeleníti meg. A ? a help parancs szinonimája.

/help | /?


Nslookup: ls

DNS tartományról listáz információt. Az alapértelmezett kimenet számítógépneveket és azok IP-címeit tartalmazza. A kimenet fájlba irányításakor a kiszolgálótól beérkező minden ötvenedik rekord mellett kettős kereszt áll.

ls [beállítás] dns_tartomány [> fájlnév] | [>> fájlnév]

Paraméterek

beállítás

-t lekérdezéstípus

Listázza az összes megadott típusú rekordot. A lekérdezéstípus leírásáért nézze meg a set querytype témakört.

-a

Listázza a DNS tartományban lévő számítógépek aliasneveit. Ez a paraméter a -t CNAME paraméter szinonimája.

-d

Listázza a DNS tartományhoz tartozó összes rekordot. Ez a paraméter a -t ANY paraméter szinonimája.

-h

Listázza a DNS tartományhoz tartozó CPU és operációs rendszer információt. Ez a paraméter a -t HINFO paraméter szinonimája.

-s

Listázza a DNS tartomány számítógépeinek közismert szolgáltatásait. Ez a paraméter a -t WKS paraméter szinonimája.

dns_tartomány

Megadja azt a DNS tartományt, amelyről információt keres.

fájlnév

Megadja annak a fájlnak a nevét, amelybe a kimenetet menti. A kimenet szokásos módon történő átirányításához használhatja a nagyobb (>) és a kettős nagyobb (>>) karaktereket.


Nslookup: lserver

Az alapértelmezett kiszolgálót a megadott DNS-tartományra cseréli. Az lserverparancs a kezdeti kiszolgálót használja a megadott DNS-tartománnyal kapcsolatos információ kereséséhez. Ez ellentétes a server parancs működésével, amely az aktuális alapértelmezett kiszolgálót használja.

lserver dns_tartomány

Paraméter

dns_tartomány

Megadja az alapértelmezett kiszolgáló új DNS-tartományát.


Megjegyzések az Nslookup parancshoz

Nslookup

Megjegyzések

Interaktív parancsok

  1. Az interaktív parancsok megszakításához használja a CTRL+B billentyűkombinációt.
  2. A kilépéshez írja be az exit parancsot.
  3. A parancssornak 256 karakternél rövidebbnek kell lennie.
  4. Beépített parancs számítógépnévként kezeléséhez írjon a parancs elé egy escape karaktert (\).
  5. Fel nem ismert parancs értelmezése számítógépnévként történik.

Diagnosztika

Ha a lookup kérelem sikertelen, hibaüzenet jelenik meg. A hibák között lehetnek az alábbiak:

  • Időtúllépés

    • A kiszolgáló nem válaszol a kérelemre egy bizonyos (set timeout=érték paranccsal beállított) idő elteltével és egy megadott számú (set retry=érték paranccsal beállított) próbálkozás után.

  • A kiszolgáló nem válaszol

    • A kiszolgáló számítógépen nem fut DNS névkiszolgáló.

  • Nincsenek rekordok

    • A DNS névkiszolgáló nem rendelkezik erőforrásrekordokkal a számítógép aktuális lekérdezéstípusához, bár a számítógépnév érvényes. A lekérdezés típusát a set querytype parancs határozza meg.

  • Nem létező tartomány

    • A számítógépnév vagy a DNS tartománynév nem létezik.

  • Kapcsolat elutasítva

    • -vagy-

    A hálózat nem érhető el

    Nem hozható létre kapcsolat a DNS névkiszolgálóhoz vagy a finger kiszolgálóhoz. Ez a hiba rendszerint az ls és finger kérelmek során fordul elő.

  • Kiszolgálóhiba

    • A DNS névkiszolgáló belső következetlenséget talált az adatbázisában, és nem képes érvényes választ adni.

  • Megtagadva

    • A DNS névkiszolgáló megtagadta a kérelem kiszolgálását.

  • Formátumhiba

    • A DNS névkiszolgáló a kérelemcsomag formátumát nem találta megfelelőnek. Ez hibaként jelentkezhet az nslookup parancsban.

Segédkönyvek

Az nslookup parancs részletes ismertetése Paul Albitz és Cricket Liu, az O'Reilly and Associates kiadásában megjelent DNS and BIND című könyvében olvasható.


Nslookup: root

Az alapértelmezett kiszolgálót átállítja a DNS tartománynévtér gyökerének kiszolgálójára. A jelenleg használt számítógép az ns.nic.ddn.mil. Ez a parancs az lserver ns.nic.ddn.mil parancs szinonimája. A gyökérkiszolgáló neve a set root paranccsal módosítható.

root


Nslookup: server

Az alapértelmezett kiszolgálót a megadott DNS-tartományra cseréli. A server parancs az aktuális alapértelmezett kiszolgálót használja a megadott DNS-tartománnyal kapcsolatos információ kereséséhez. Ez ellentétes az lserver parancs működésével, amely a kezdeti kiszolgálót használja.

dns_tartomány

Paraméter

dns_tartomány

Megadja az alapértelmezett kiszolgáló új DNS-tartományát.


Nslookup: set

Megváltoztatja azokat a konfigurációs beállításokat, amelyek befolyásolják a keresések működését.

set kulcsszó[=érték]

Paraméter

kulcsszó

A kulcsszavak felsorolása önálló súgótémakörökben található. Lásd: set kulcsszó. Az aktuális beállítások megtekintésére használja a set all parancsot.


Nslookup: set [no]d2

Be- vagy kikapcsolja a részletes hibakeresést. Bekapcsolt állapotban az összes csomag minden mezőjét nyomtatja.

set [no]d2

Alapértelmezés = nod2


Nslookup: set [no]deb[ug]

Be- vagy kikapcsolja a hibakereső üzemmódot. A hibakeresés bekapcsolása esetén több információ jelenik meg a kiszolgálóra küldött csomagról és az arra adott válaszról.

set [no]deb[ug]

Alapértelmezés = nodebug


Nslookup: set [no]def[name]

Hozzáfűzi az alapértelmezett DNS tartománynevet egy egyszerű összetevőkeresési kéréshez. Az egyszerű összetevő olyan összetevő, amely nem tartalmaz pontokat.

set [no]def[name]

Alapértelmezés = defname


Nslookup: set [no]ig[nore]

Figyelmen kívül hagyja a csomaglevágási hibákat.

set [no]ig[nore]

Alapértelemzés = noignore


Nslookup: set [no]rec[urse]

Beállítja a DNS névkiszolgálót, hogy ha nem rendelkezik a megfelelő információval, küldjön egy lekérdezést más kiszolgálókra.

set [no]rec[urse]

Alapértelmezés = recurse


Nslookup: set [no]sea[rch]

Ha be van állítva és a keresési kérés legalább egy pontot tartalmaz és nem ponttal végződik, hozzáfűzi a DNS tartománykeresési listában található DNS tartománynevet a kéréshez, amíg válasz nem érkezik.

set [no]sea[rch]

Alapértelmezés = search


Nslookup: set [no]v[c]

Beállítja, hogy kiszolgálóhoz intézett kérés küldésekor mindig virtuális kapcsolatot használjon a rendszer.

set [no]v[c]

Alapértelmezés = novc


Nslookup: set all

Kinyomtatja a konfigurációs beállítások aktuális értékeit. Továbbá kinyomtatja az alapértelmezett kiszolgálóra és számítógépre (állomás) vonatkozó információkat.

set all


Nslookup: set cl[ass]

Megváltoztatja a lekérdezési osztályt. Az osztály megadja az információ protokollcsoportját.

set cl[ass]=érték

Alapértelmezés = IN

Paraméterek

érték

IN

Az Internet osztályt adja meg.

CHAOS

A Chaos osztályt állítja be.

HESIOD

A MIT Athena Hesiod osztályt állítja be.

ANY

A fent felsorolt helyettesítők bármelyikét állítja be.


Nslookup: set do[main]

Megváltoztatja az alapértelmezett DNS tartományt a megadott névre. Az alapértelmezett DNS tartománynév a defname és a search beállítások állapotától függően lesz a keresési kérésekhez fűzve. A DNS tartomány keresési listája tartalmazza az alapértelmezett DNS tartomány szülőit, ha legalább két összetevő van a nevében. Például, ha az alapértelmezett DNS tartomány a mfg.widgets.com, a keresési lista neve mind mfg.widgets.com, mind widgets.com. Másik lista megadásához használja a set srchlist parancsot. A lista megjelenítéséhez használja a set all parancsot.

set do[main]=név

Alapértelmezés = állomásnév értéke

Paraméter

név

Megadja az alapértelmezett DNS tartomány új nevét.


Nslookup: set po[rt]

Az alapértelmezett TCP/UDP DNS névkiszolgáló portot a megadott értékre állítja.

set po[rt]=érték

Alapértelmezés = 53

Paraméterek

érték

Megadja az alapértelmezett TCP/UDP DNS névkiszolgáló port új értékét.


Nslookup: set q[uerytype]

Megváltoztatja az információlekérdezés típusát. A típusokkal kapcsolatban bővebb információt itt talál: Request For Comment (RFC) 1035. A set type parancs a set querytype parancs szinonimája.

set q[uerytype]=érték

Alapértelmezés = A

Paraméterek

érték

A

A számítógép IP címe

ANY

Mindenféle típusú adat

CNAME

Egy alias kanonikus neve.

GID

Egy csoportnév csoportazonosítója

HINFO

A számítógép processzorának és operációs rendszerének típusa

MB

A postaláda-tartomány neve

MG

Levelezési csoport tagja

MINFO

Postaláda vagy levelezési lista információ

MR

Postafiók-átnevező tartománynév

MX

Levélküldő

NS

A megnevezett zóna DNS névkiszolgálója

PTR

Ha a lekérdezés egy IP cím, akkor a számítógép neve, egyéb esetben a további információ mutatója

SOA

A DNS tartomány SOA rekordja

TXT

Szöveges információ

UID

Felhasználói azonosító

UINFO

A felhasználó adatai.

WKS

WKS rekord leírása.


Nslookup: set ret[ry]

Megadja az újrapróbálkozások számát. Ha a kérésre nem érkezik válasz egy megadott időn belül (a set timeout paranccsal állítható be), az időtúllépési korlát megkétszereződik és a kérést a rendszer újraküldi. Az újrapróbálkozások száma azt adja meg, hogy a rendszer hányszor próbál újraküldeni egy kérést, mielőtt feladná.

set ret[ry]=szám

Alapértelmezés = 4

Paraméter

szám

Megadja az újrapróbálkozások számának új értékét.


Nslookup: set ro[ot]

Megváltoztatja a gyökérkiszolgáló nevét. Ez hatással van a root parancsra.

set ro[ot]=számítógép

Alapértelmezés = ns.nic.ddn.mil

Paraméter

számítógép

Megadja a gyökérkiszolgáló új nevét.


Nslookup: set srchl[ist]

Módosítja az alapértelmezett DNS tartománynevet és keresési listát. Legfeljebb hat nevet lehet megadni, perjellel (/) elválasztva. Ez a parancs felülbírálja a set domain paranccsal beállított alapértelmezett DNS tartománynevet és keresési listát. A lista megjelenítéséhez használja a set all parancsot.

Set srchl[ist] név1/név2...

Alapértelmezés = állomásnéven alapuló érték

Paraméter

név1/név2...

Megadja az alapértelmezett DNS tartomány és keresési lista új nevét. Például a következő parancs a DNS tartományt a mfg.widgets.com tartományra állítja be, a keresési listát pedig három névre:

set srchlist=mfg.widgets.com/mrp2.widgets.com/widgets.com


Nslookup: set ti[meout]

Módosítja a kérelemre érkező válaszra várás másodpercben mért idejét. Ha ezen az időn belül nem érkezik válasz a kérelemre, akkor az időtúllépés hosszának megkétszerezésével a kérelmet újraküldi. Az ismétlések számát a set retry beállítás vezérli.

setti[meout]=szám

Alapértelmezés = 5

Paraméter

szám

Új értéket ad meg másodpercben a válaszra várakozás hosszának.


Nslookup: set ty[pe]

Megváltoztatja az információlekérdezés típusát. A típusokkal kapcsolatban bővebb információt itt talál: Request For Comment (RFC) 1035. A set type parancs a set querytype parancs szinonimája.

set ty[pe]=érték

Alapértelmezés = A


Nslookup alparancsok

További információért válassza a következő nslookup parancsok egyikét:

Nslookup: help

Nslookup: exit

Nslookup: finger

Nslookup: ls

Nslookup: lserver

Nslookup: root

Nslookup: server

Nslookup: set

Nslookup: set all

Nslookup: set cl[ass]

Nslookup: set [no]deb[ug]

Nslookup: set [no]d2

Nslookup: set [no]def[name]

Nslookup: set do[main]

Nslookup: set [no]ig[nore]

Nslookup: set po[rt]

Nslookup: set q[uerytype]

Nslookup: set [no]rec[urse]

Nslookup: set ret[ry]

Nslookup: set ro[ot]

Nslookup: set [no]sea[rch]

Nslookup: set srchl[ist]

Nslookup: set ti[meout]

Nslookup: set ty[pe]

Nslookup: set [no]v[c]

Nslookup: view


Nslookup: view

Rendezi és listázza a megelőző ls parancs vagy parancsok kimenetét.

view fájlnév

Paraméter

fájlnév

Megadja az előző ls parancs vagy parancsok kimenetét tartalmazó fájl nevét.


Ntcmdprompt

A Windows 2000 parancsértelmezőjét, a Cmd.exe-t futtatja a Command.com helyett, TSR futtatása vagy a parancssor MS-DOS alkalmazásból történő indítása után.

ntcmdprompt

Kapcsolódó témakörök


Példák az Ntcmdprompt parancs használatára

Ntcmdprompt

Példa

Az ntcmdprompt parancs Config.nt fájlba vagy a PIF-fájlban megadott konfigurációindító fájlba foglalásához írja be a következőt:

ntcmdprompt

Kapcsolódó témakörök


Megjegyzések az Ntcmdprompt parancshoz

Ntcmdprompt

Megjegyzések

A Command.com futásakor a Windows 2000 parancssor egyes szolgáltatásai, például a parancselőzmények Doskey megjelenítése nem érhetők el. Ha inkább a Windows 2000 parancsértelmezőt futtatná egy TSR vagy a parancssor egy MS-DOS alapú alkalmazásból történt indítása után, használja a ntcmdprompt parancsot. Ne feledje azonban, hogy a Cmd.exe futtatásakor a TSR esetleg nem lesz használható. A ntcmdprompt parancsot befoglalhatja a Config.nt fájlba, vagy egy alkalmazás PIF-fájljának saját megfelelő indítófájljába.


A Windows 2000 parancsmutató használata

A Windows 2000 a parancssori funkciók gazdag választékát nyújtja, amelyek bővített és javított formában biztosítják mindazokat a lehetőségeket, amelyek a Windows és az MS-DOS korábbi verzióiban rendelkezésre álltak. Ezek a parancsok közvetlenül a parancssorból használhatók, például mappaváltásra (chdir vagy cd), egy mappa tartalmának listázására (dir), vagy fájlok másolására (copy és xcopy).

Ezek a fájlok parancsfájlba is szervezhetők. A parancsfájlok (más néven kötegfájlok) segítségével leegyszerűsíthetők a rutinszerű vagy ismétlődő feladatok. A kötegfájl egy olyan szövegfájl, amely egy vagy több parancsot tartalmaz, és .bat vagy .cmd fájlnév-kiterjesztése van. A fájlnév parancssorba írásakor a fájlban lévő parancsok végrehajtása sorrendben történik. Egy kötegfájl összeállítása lehetővé teszi az olyan programvezérlő parancsok előnyeinek kihasználását, mint például az if utasítás, a goto utasítás és a for ciklusok, amelyek szabványos programvezérlő szerkezetek.


Az OS/2 konfigurációs parancsai

További tudnivalókért válassza ki a parancsot.

codepage devinfo libpath protshell

Az OS/2 alrendszer konfigurálása Config.sys parancsokkal, például a devicename vagy a libpath paranccsal történik. A C:\Config.sys módosításához használjon egy OS/2 szerkesztőt. Ezek a parancsok csak az OS/2 alrendszert érintik.


Path

Beállítja a végrehajtható fájlok keresési útvonalát.

A Windows 2000 a path parancsot a megadott könyvtárban található végrehajtható fájlok kereséséhez használja. Alapértelmezés szerint a keresési útvonal csak az aktuális könyvtár.

path [[meghajtó:]elérési_útvonal[;...]] [%path%]

Paraméterek

nincs

A path parancs paraméterek nélkül a jelenlegi keresési útvonalat jeleníti meg.

[meghajtó:]elérési_útvonal

Megadja a kereséshez használt meghajtót, könyvtárat és alkönyvtárakat.

;

Egyetlen paraméterként történő megadásakor törli az összes keresési útvonal beállítását, és megadja, hogy a Windows 2000 csak az aktuális könyvtárban keressen.

%path%

Hozzáfűzi az aktuális elérési útvonalat az új beállításhoz.


Példák a Path parancs használatára

Path

Példák

A következő parancs megadja, hogy a Windows 2000 külső parancsokat keressen három könyvtárban. A három könyvtár elérési útjai: C:\User\Taxes, B:\User\Invest és B:\Bin:

path c:\user\taxes;b:\user\invest;b:\bin


Megjegyzések a Path parancshoz

Path

Megjegyzések

Aktuális könyvtár

Mielőtt a Windows 2000 a keresési útvonalon vizsgálná meg a könyvtárakat, először mindig az aktuális könyvtárban keres.

Azonos nevű, de eltérő kiterjesztésű fájlok

Előfordulhat, hogy egy könyvtárban néhány fájl neve azonos, de fájlkiterjesztése eltérő. Például van egy Accnt.com nevű, könyvelőprogramot indító fájl, és van egy Accnt.bat nevű fájl is, amely a rendszert kapcsolja össze a könyvelői rendszer hálózatával.

A Windows 2000 a fájlt az alapértelmezett fájlkiterjesztések alábbi sorrendjében keresi: .exe, .com, .bat és .cmd. Az Accnt.bat futtatásához, ha ugyanabban a könyvtárban van egy Accnt.com nevű fájl is, a parancssorban szerepelnie kell a .bat kiterjesztésnek is.

Kettő vagy több azonos fájlnév a keresési útvonalon

Előfordulhat, hogy a keresési útvonalon kettő vagy több fájlnak megegyezik a neve és a fájlkiterjesztése. A Windows 2000 a megadott nevű fájlt először az aktuális könyvtárban keresi. Ezután a path paranccsal megadott sorrendben vizsgálja a könyvtárakat.

Több keresési útvonal megadása

Ha több keresési útvonalat kíván megadni a Windows 2000 rendszernek a kereséshez, a bejegyzéseket válassza el pontosvesszővel (;).

A path parancs használata az Autoexec.nt fájlban

Ha elhelyezi a path parancsot az Autoexec.nt fájlban, a Windows 2000 minden egyes rendszerbe jelentkezéskor automatikusan hozzáfűzi az MS-DOS alrendszer megadott keresési útvonalát a Windows 2000 keresési útvonalához.


PathPing

Olyan útvonalkövető eszköz, amely a ping és a tracert parancsok szolgáltatásait ötvözi olyan további információkkal, melyeket e parancsok egyike sem biztosít. A pathping parancs egy adott időtartamon keresztül csomagokat küld az egyes útválasztókon keresztül a végcélhoz, majd az egyes ugrásokból visszakapott csomagok alapján kiszámítja az eredményeket. Mivel a pathping parancs megmutatja az egyes útválasztóknál vagy csatolásoknál bekövetkező csomagvesztés mértékét, meghatározható, hogy mely útválasztók, illetve csatolások okozzák a hálózati problémákat.

pathping [-n] [-h ugrások_maximális_száma] [-g állomások_listája] [-p időtartam] [-q lekérdezések_száma [-w időtúllépés] [-T] [-R] cél_neve

Paraméterek

-n

Ne oldja fel a címeket állomásnevekké.

-h ugrások_maximális_száma

Megadja a cél keresése során végrehajtható ugrások maximális számát. Az alapértelmezett érték 30 ugrás.

-g állomások_listája

Lehetővé teszi, hogy az állomások_listájában egymás után következő számítógépeket köztes átjárók válasszák el egymástól (laza forrásút).

-p periódus

Ezredmásodpercben megadja az egymás követő ping tesztek számát. Az alapértelmezett érték 250 ezredmásodperc (1/4 másodperc).

-q lekérdezések_száma

Megadja az útvonal mentén található egyes számítógéphez küldött lekérdezések számát. Az alapértelmezett érték 100.

-w időtúllépés

Ezredmásodpercben megadja az egyes válaszokra történő várakozás időtartamát. Az alapértelmezett érték 3000 ezredmásodperc (3 másodperc).

-T

2. réteg prioritási címkét csatol (például 802.1p) az útvonalon a hálózati eszközökhöz küldött csomagokhoz. Ez segít azoknak a hálózati eszközöknek a kiszűrésében, melyeken nincs konfigurálva a 2. réteg prioritás. Ezt a paramétert nagybetűvel kell megadni.

-R

Ellenőrzi, hogy az útvonalon lévő összes hálózati eszköz támogatja-e a Resource Reservation Setup protokollt (RSVP), amely lehetővé teszi, hogy az állomások az adatátvitel biztosítására a sávszélesség egy részét lefoglalják. Ezt a paramétert nagybetűvel kell megadni.

cél_neve

Megadja a célvégpontot, amelyet IP-cím vagy állomásnév azonosít.


Megjegyzések a PathPing parancshoz

PathPing

Megjegyzések

A pathping parancs a traceroute paranccsal megegyező módon azonosítja az útvonalon található útválasztókat. Ezután rendszeres időközönként ping paranccsal tesztel minden egyes útválasztót egy adott időtartamon keresztül, majd statisztikát számít az útválasztóktól visszakapott számok alapján.

A torlódás elkerülése érdekében a ping tesztet megfelelően hosszú szünetekkel kell végezni.

Ha a minimálisra kívánja csökkenteni a burst veszteségek mértékét, hagyjon elegendő időt a ping tesztek között.

-p periódus paraméter

A ping teszteket a rendszer egyenként az egyes közbenső ugrási pontokhoz küldi. Ezért az ugyanazon ugrási ponthoz küldött két ping csomag között eltelt idő (periódus) x (ugrások száma).

-w időtúllépés paraméter

Az egyes ping tesztek párhuzamosan is végezhetők, így az időtúllépés paraméter által megadott időt nem köti a ping tesztek közötti várakozásra a periódus paraméterben megadott időtartam.

-T paraméter

A 2. réteg prioritásának engedélyezése az állomáson lehetővé teszi a csomagok 2. réteg prioritási címkével való küldését, miáltal a 2. rétegbe tartozó eszközök megjelölhetik a csomag prioritását. Az örökölt eszközök nem értik a 2. réteg prioritást, a címkézett csomagok formátumát hibásnak találják, amiatt eldobják azokat. Emiatt egy örökölt hálózattal összekötő kapcsolót úgy kell konfigurálni, hogy a csomagok továbbítása előtt távolítsa el a címkét. Ez a lehetőség segít a címkézett csomagokat eldobó hálózati elemek azonosításában.

A pathping parancs megkülönbözteti a nagy- és kisbetűket. Ezt a paramétert nagybetűvel kell megadni.

-R paraméter

RSVP fenntartási üzenetet küld egy nem létező munkamenethez az útvonalban érintett minden hálózati eszköz részére. Ha az eszköz nincs RSVP támogatásra konfigurálva, az Internet Control Message Protocol (ICMP) elérhetetlenségéről szóló üzenettel fog felelni. Ha az RSVP-t támogatja, fenntartási hibát fog jelezni. Néhány eszköz az üzenetek egyikét sem adja vissza. Ebben az esetben a pathping parancs időtúllépési hibát jelez.

A pathping parancs megkülönbözteti a nagy- és kisbetűket. Ezt a paramétert nagybetűvel kell megadni.

A következő példa a pathping parancs kimenetét mutatja:

D:\>pathping -n msw

Tracing route to msw [7.54.1.196]
over a maximum of 30 hops:
  0  172.16.87.35
  1  172.16.87.218
  2  192.68.52.1
  3  192.68.80.1
  4  7.54.247.14
  5  7.54.1.196

Computing statistics for 125 seconds...
            Source to Here   This Node/Link
Hop  RTT    Lost/Sent = Pct  Lost/Sent = Pct  Address
  0                                           172.16.87.35
                                0/ 100 =  0%   |
  1   41ms     0/ 100 =  0%     0/ 100 =  0%  172.16.87.218
                               13/ 100 = 13%   |
  2   22ms    16/ 100 = 16%     3/ 100 =  3%  192.68.52.1
                                0/ 100 =  0%   |
  3   24ms    13/ 100 = 13%     0/ 100 =  0%  192.68.80.1
                                0/ 100 =  0%   |
  4   21ms    14/ 100 = 14%     1/ 100 =  1%  7.54.247.14
                                0/ 100 =  0%   |
  5   24ms    13/ 100 = 13%     0/ 100 =  0%  7.54.1.196

Útvonalkövetés kész.

A pathping parancs futtatásakor az első eredmények az útvonalat sorolják fel. Ez megegyezik a tracert parancs által megjelenített útvonallal. Ezután a pathping foglalt üzenetet jelenít meg a következő másfél percben (a pontos idő az ugrások számától függően változik). Ez idő alatt a pathping parancs információt gyűjt az előzőleg megjelenített egyes útválasztókról és a közöttük lévő kapcsolatokról. Az időtartam végén megjeleníti a teszt eredményét.

A fenti mintajelentésben a This Node/Link Lost/Sent = Pct és az Address oszlopok mutatják, hogy a 172.16.87.218 és a 192.68.52.1 című számítógépek között fennálló összeköttetésen a csomagok 13 százaléka elveszik. A 2. és 4. ugrásnál található útválasztók szintén veszítenek a nekik címzett csomagokból, de ez a veszteség nem befolyásolja továbbítási útvonalukat.

A kapcsolatokra vonatkozó veszteségarányok (| karakterrel jelölve az Address oszlopban) azt jelzik, hogy a kapcsolaton fellépő torlódás felelős az útvonalon továbbított csomagok elvesztéséért. Az (IP-címükkel azonosított) útválasztókra vonatkozó veszteségarányok azt jelzik, hogy ezen útválasztók CPU-jai vagy helyi csomagpufferei túlterheltek.


Pause

Felfüggeszti egy kötegfájl végrehajtását, és megjelenít egy üzenetet, amelyben felszólítja a felhasználót, hogy a folytatáshoz nyomjon meg egy billentyűt.

pause

Kapcsolódó témakörök


Példák a Pause parancs használatára

Pause

Példák

Tegyük fel, hogy olyan kötegfájlt kíván létrehozni, amely felszólítja a felhasználót, hogy az egyik meghajtóban cseréljen lemezt. Ehhez a következő fájlt kell létrehoznia:

@echo off
:begin
copy a:*.*
echo Kérem helyezzen egy új lemezt az A meghajtóba
pause
goto begin

Ebben a példában az A meghajtóban lévő lemezen található összes fájl át lett másolva az aktuális könyvtárba. Miután a megjelenített megjegyzés felszólítja a felhasználót egy másik lemez behelyezésére az A meghajtóba, a pause parancs felfüggeszti a végrehajtást, így kicserélheti a lemezt, majd egy billentyű lenyomásával folytathatja a feldolgozást. Ez a kötegfájl végtelen hurokban fut. A goto BEGIN parancs a parancsértelmezőt a kötegfájl kezdőcímkéjéhez küldi. A kötegfájl megállításához nyomja meg a CTRL+C, majd az I billentyűt.


Megjegyzések a Pause parancshoz

Pause

Megjegyzések

A felhasználó felszólítása a parancs folytatására

A Windows 2000 a következő üzenetet jeleníti meg a pause parancsra válaszként:

A folytatáshoz nyomjon le egy billentyűt. . .

Kötegfájl felosztása részekre

Ha egy kötegfájl végrehajtásának megállításához megnyomja a CTRL+C billentyűkombinációt, a Windows 2000 az alábbi üzenetet jeleníti meg:

Befejezi a parancsfájl futtatását (I/N)?

Ha az üzenetre válaszul megnyomja az Igen (I) gombot, akkor a kötegfájl végrehajtását befejezi a rendszer, és a vezérlést visszaadja az operációs rendszernek. Ezért a kötegfájl azon része elé, amelyet nem kíván végrehajtani, illessze be a pause parancsot. Amikor a pause parancs felfüggeszti a kötegfájl végrehajtását, a fájl megállításához lenyomhatja a CTRL+C és az I billentyűket.


Pax

Elindítja a Portable Archive Interchange (Pax) segédprogramot.

A Pax egy POSIX program, és az argumentumként megadott elérési utat POSIX formátumban kell megadni. A "C:\USERS\DEFAULT" formátum helyett a "//C/Users/Default" formátumot kell használni.

Az -r és -w parancssori argumentumok kombinációja határozza meg, hogy a pax parancs olvassa, írja vagy kilistázza a megadott archívum tartalmát, vagy a megadott fájlokat másik könyvtárba helyezi át.

pax [-cimopuvy] [-f archívum] [-s cserekarakterlánc] [-t eszköz] [minta...]

pax -r [-cimnopuvy] [-f archívum] [-s cserekarakterlánc [-t eszköz] [minta...]

pax -w [-adimuvy] [-b blokkolás] [-f archívum] [-s cserekarakterlánc] [-t eszköz] [-x formátum] [elérési_út...]

pax -rw [-ilmopuvy] [-s cserekarakterlánc] [elérési_út...] könyvtár

Paraméterek

-r

Beolvas egy archivált fájlt a normál bemenetről. Csak a valamelyik minta operandussal egyező fájlok lesznek kibontásra kiválasztva. A kiválasztott fájlokat feltételesen hozza létre és másolja a program, az aktuális fához viszonyítva, az alábbi részben leírt beállításoknak megfelelően. Alapértelmezés szerint a kiválasztott fájlok tulajdonosa és csoportja azonos lesz a meghívó folyamat tulajdonosával és csoportjával. Az engedélyek és a módosítási időpont azonos lesz az archívum megfelelő adataival. A támogatott archívumformátumokat automatikusan felismeri a rendszer a bemeneten. Az alapértelmezett kimeneti formátum ustar, de ez átállítható a -x formátum paraméter segítségével.

-w

Az elérési_út operandusokban megadott fájlokat és könyvtárakat kiírja a program a normál kimenetre a használt archívumformátum által meghatározott elérési út és állapot információkkal együtt. A könyvtár elérési_út operandus a fájlokra és a könyvtár alkönyvtáraira vonatkozik. Ha az elérési_út operandusok nincsenek megadva, a másolandó elérési utak listáját a normál bemenetről olvassa be a rendszer, soronként egy elérési útvonalat. Ebben az esetben csak a normál bemeneten lévő elérési útvonalak kerülnek másolásra.

-rw

Beolvassa az elérési út operandusok által megadott fájlokat és könyvtárakat, és átmásolja azokat a célkönyvtárba. A könyvtár elérési_út operandus a fájlokra és a könyvtár alkönyvtáraira vonatkozik. Ha az elérési út operandusok nincsenek megadva, a másolandó elérési utak listáját a normál bemenetről olvassa be a rendszer, soronként egy elérési útvonalat. Ebben az esetben csak a normál bemeneten lévő elérési útvonalak kerülnek másolásra. A könyvtár operandus által megadott könyvtárnak a másolás megkezdése előtt léteznie kell, és rendelkeznie kell a megfelelő engedélyekkel.

-a

Az elérési_út paraméter által megadott fájlokat hozzáfűzi a megadott archívumhoz.

-b blokkolás

Blokkolja a kimenetet a blokkolóbájtoknál az archív fájlba írás közben. A blokkolást a k utótag 1024-gyel szorozza, a b utótag 512-vel szorozza, az m utótag 1.048.576-tal (1MB) szorozza. Ha a blokkolás paraméter nincs megadva, a bemenet alapján automatikusan kerül megállapításra és a -rw paraméter esetén a rendszer figyelmen kívül hagyja.

-c

Kiegészíti a minta operandusok egyezésének érzékelését.

-d

Beállítja, hogy az archívumban a külön fel nem sorolt közbenső könyvtárak nem lesznek létrehozva. Ez a beállítás figyelmen kívül marad, ha az -r kapcsoló nincs megadva.

-f archívum

Az archívum paraméter megadja a bemeneti és kimeneti archívum elérési útját. Ez felülbírálja az -r paraméter esetén használt alapértelmezett normál bemenetet és a -w paraméter esetén használt normál kimenetet.

-i

Interaktívan nevezi át a fájlokat. A -s beállítással megadott helyettesítések végrehajtása az új fájlnév bekérése előtt történik. Üres sor esetén egy fájlt átugrik a pax parancs, vagy a fájl végére érve (EOF) 0 kilépési állapottal leáll.

-l

Beállítja, hogy a fájlokat a parancs csatolja, ne pedig másolja, ha ez lehetséges.

-m

Beállítja, hogy a módosítási időpontot nem kell megőrizni.

-n

Ha az -r kapcsoló meg van adva, de a -w kapcsoló nincs, a minta argumentumokat egyszerűen fájlnévként kezeli a parancs. Minden ilyen fájlt a bemeneti archívumban csak az első előfordulásakor olvas be a parancs. A listában szereplő összes fájl beolvasása után a pax parancs nulla kilépési állapottal leáll. Ha egy vagy több listán szereplő fájl nem található, a pax parancs diagnosztikát ír a normál hibakimenetre, és nem nulla kilépési állapottal leáll. A -i, -s, és -y beállítások érvényesítése előtt a parancs összehasonlítja a fájlneveket.

-o

Visszaállítja az archívumban megadott tulajdoni beállításokat. Ennek végrehajtásához a meghívó folyamatnak megfelelő jogokkal kell rendelkeznie.

-p

A másolás után megtartja a bemeneti fájlok hozzáférési időpontját.

-s cserekarakterlánc

A cserekifejezés alapján módosítja a fájlneveket az ed(1) szintaxist használva:

-s /régi/új/[gp]

Elválasztójelként bármely nem üres karakter használható (a példában perjel látható). Az -s kifejezés többszörösen is megadható. A kifejezéseket a megadott sorrendben alkalmazza a program, az első sikeres behelyettesítéssel végződően. A választható p paraméter felsorolja a sikeres hozzárendeléseket normál hiba esetén. A választható g paraméter kicseréli a régi kifejezést, ahányszor az a forráskarakterláncban előfordul. Azokat a fájlokat, amelyek nevei eltűnnének (helyettesítés üres karakterlánccal), a parancs figyelmen kívül hagyja mind bemenetként, mind kimenetként.

-t eszköz

Az eszköz kapcsolóargumentum egy megvalósítás által meghatározott azonosító, amely megnevezi a bemeneti vagy kimeneti archiváló eszközt, felülírva az -r paraméter esetén használt alapértelmezett normál bemenetet és a -w paraméter esetén használt normál kimenetet.

-u

Csak akkor másolja a fájlokat, ha azok újabbak a már létező, ugyanolyan nevű fájloknál. Ez a kapcsoló feltételezi az -a kapcsoló megadását.

-v

Munka közben listázza a használt fájlokat. Részletes tartalomjegyzéket készít a normál kimenetre, se az -r se a -w paraméter nincs megadva. Ellenkező esetben a fájlneveket a normál hibakimenetre írja az archívumban található sorrend szerint.

-x formátum

Megadja a kimeneti archív formátumot. A bemeneti formátumot a rendszer automatikusan megállapítja az -r kapcsoló használata esetén (ennek az alábbiak egyikének kell lennie). A következő formátumok támogatottak:

cpio | Bővített CPIO interchange formátum (Extended CPIO Format,1003.1-1988. IEEE szabvány)
ustar | Bővített TAR interchange formátum (Extended TAR Format, 1003.1-1988. IEEE szabvány) Ez az alapértelmezett archív formátum.

-y

Minden fájl esetén megerősítést kér. Az -s kapcsolók által megadott behelyettesítések (fentebb részletezve) a kérdés feltétele előtt megtörténnek. Az EOF karakter vagy egy q betűvel kezdődő bemeneti sor a pax parancs futásának leállását eredményezi. Ellenkező esetben minden válasz, amely nem az y betűvel kezdődik figyelmen kívül marad. Ez a kapcsoló nem használható az -i kapcsolóval együtt.

Az -f és a -t kapcsolók közül csak az utolsót veszi figyelembe a parancs.

könyvtár

Az -r és a -w kapcsolók együttes megadása esetén ez a paraméter megadja azt a célkönyvtárat, ahová a másolatok kerülnek. A könyvtárnak léteznie kell, és írás joggal kell rendelkezni a könyvtárhoz a másolás megkezdése előtt.

elérési út

Megadja a normál bemeneten megnevezett fájlok tartalma helyett használandó fájlokat. Könyvtár megadása esetén annak minden fájlja és alkönyvtára másolásra kerül.

minta

A mintahelyettesítő karakterekkel adható meg. Az alapértelmezett beállítás: minden fájl.


Példák a Pax parancs használatára

Pax

Példák

Az Olddir tartalmának Newdir-be másolásához írja be:

mkdir newdir

cd olddir

pax -rw . newdir

A Pax.out archívum “/usr” gyökérben található összes fájljának az aktuális könyvtárba kibontott olvasásához írja be:

pax -r -s ',//*usr//*,,' -f pax.out


Megjegyzések a Pax parancshoz

Pax

Megjegyzések

Más POSIX programokhoz hasonlóan a pax nem tudja kezelni a szalagos meghajtókat. Emiatt csak a lemezmeghajtókon található archív fájlok írására és olvasására használható. A Pax program olyan archív fájlok olvasására és írására képes, amelyek megfelelnek a 1003.1-1988-as IEEE szabványban megadott Archive/Interchange fájlformátumnak. A Pax az Archive/Interchange File Format leírásban meghatározott fájlformátumokon kívül számos egyéb fájlformátumot képes olvasni, de írni nem. Ezeknek a hagyományos fájlformátumoknak (például a V7 tar és a System V binary cpio formátumú archívumok) a támogatása a lefelé kompatibilitást és a legteljesebb hordozhatóságot biztosítja.

Ha sem a -r, sem a -w beállítás nincs megadva, a pax megjeleníti a megadott archívum tartalmát. Ebben az üzemmódban a pax a normál fájlokat külön sorokban, a szoros csatolású hivatkozásokat pedig a következőképpen jeleníti meg:

elérési út == csatolás neve

a szimbolikus csatolású hivatkozásokat pedig (ha azokat a megvalósítás támogatja) a következőképpen:

elérési út -> csatolás neve

ahol az elérési út a kibontani kívánt fájl neve, a csatolás neve pedig az archívumban korábban szerepelt fájl neve.

Ha a -v beállítás meg van adva, akkor a pax megjeleníti a normál elérési utakat ugyanabban a formátumban, mint amelyet az ls segédprogram a -l beállítás megadása esetén használ. A szoros csatolások a következőképpen jelennek meg:

<ls -l elem> == csatolás neve

a szimbolikus csatolások pedig (ha támogatottak) a következőképpen jelennek meg:

<ls -l elem> -> csatolás neve

Amikor a pax az adathordozó végét érzékeli olyan archívum esetén, amely még nem teljes, kéri a felhasználótól az archívum következő kötetét, illetve lehetővé teszi a felhasználó számára a következő kötet helyének megadását.

Az archívumba történő írás során a szabványos bemenetet használja az elérési út listájaként, ha nincs megadva elérési út operandus. Az elérési utak soronként jelennek meg. Ellenkező esetben a szabványos bemenet az archív fájl, amelynek formátuma az IEEE szabványban megadott Archive/Interchange fájlformátumok egyike. (Az 1003.1-1988 számú IEEE szabványában megadott Archive/Interchange File formátum egyik leírása vagy más megvalósítás által meghatározott formátum.)

A folyamat felhasználói azonosítója és csoportazonosítója a megfelelő jogosultságokkal együtt határozza meg a pax lehetőségét az archivált fájlok tulajdonjog és engedélyattribútumainak visszaállítására. Lásd az Archive/Interchange File Format formátumolvasó segédprogramot az 1003.1-1988 számú IEEE szabványban.

Az -a, -c, -d, -i, -l, -p, -t, -u és -y beállítások a régebbi cpio és tar segédprogramokkal való kompatibilitást biztosítják. A választott alapértelmezett beállítások a szóban forgó beállítások leggyakoribb használatán alapulnak, ezért a beállítások egy részének jelentése különbözik a régebbi parancsok esetében használt jelentésétől.


Pentnt

Megkeresi a Pentium processzor lebegőpontos osztás hibáját (ha van), letiltja a lebegőpontos hardvert, és bekapcsolja a lebegőpont-emulációt.

pentnt [-c] [-f] [-o] [-?|-h]

Paraméterek

-c

Lehetővé teszi a feltételes emulációt. A lebegőpontos emuláció csak akkor szükséges, ha a rendszer Pentium processzor lebegőpontos osztási hibát talál az induláskor. Ha kiválasztja ezt a paramétert, újra kell indítani a számítógépet a változtatás hatályba léptetéséhez.

-f

Lehetővé teszi az emuláció megkövetelését. A lebegőpontos hardvert letiltja, a lebegőpontos-emuláció minden esetben működik függetlenül attól, hogy a rendszer talál-e Pentium processzor lebegőpontos osztási hibát Ez a paraméter a szoftveremulátorok tesztelésekor és a rendszer által ismert lebegőpontos hardverhibák működtetése közben hasznos. Ha kiválasztja ezt a paramétert, újra kell indítani a számítógépet a változtatás hatályba léptetéséhez.

-o

Letiltja az emuláció megkövetelését, és újra engedélyezi a lebegőpontos hardvert, amennyiben van. Ha kiválasztja ezt a paramétert, újra kell indítani a számítógépet a változtatás hatályba léptetéséhez.

-?|-h

Megjeleníti a parancs súgóját.


% (behelyettesíthető paraméter)

A %0 és a %1 - %9 helyettesíthető paramétert bárhol elhelyezheti a parancsköteg-fájlban. A parancskötegfájl futtatásakor a %0 helyére a kötegfájl neve, a %1 - %9 argumentumváltozók helyére pedig a parancssorba beírt megfelelő paraméterek kerülnek.

Ha például egy mappa tartalmát egy másik mappába kívánja másolni, a következő utasítást kell felvenni a parancsfájlba:

xcopy %1\*.* %2

A fájl futtatásakor a következő parancsot kell kiadni:

parancsfajl.bat C:\a_mappa D:\b_mappa.

Ennek hatása ugyanaz, mintha az xcopy C:\a_mappa \*.* D:\b_mappa parancsot írta volna a parancsfájlba.

A % paraméter a parancsfájl argumentumváltozóit (%0, %1, ..., %9) a következőképpen bontja ki:

%* a parancsfájlban általános hivatkozás minden argumentumra. Az egyes argumentumváltozókra vonatkozó kibontási beállítások magyarázatát a következő táblázatok tartalmazzák.

Változó | Leírás
%~1 | Kibontja a %1 argumentumot és eltávolítja az azt körülvevő idézőjeleket (”).
%~f1 | Teljes elérési úttá bontja ki a %1 argumentumot.
%~d1 | Meghajtóbetűjellé bontja ki a %1 argumentumot.
%~p1 | Elérési úttá bontja ki a %1 argumentumot.
%~n1 | Fájlnévvé bontja ki a %1 argumentumot.
%~x1 | Fájlkiterjesztéssé bontja ki a %1 argumentumot.
%~s1 | A kibontott elérési út csak rövid neveket tartalmaz.
%~a1 | Fájlattribútumokká bontja ki a %1 argumentumot.
%~t1 | A fájl dátum/idő attribútumává bontja ki a %1 argumentumot.
%~z1 | Aa fájl méret attribútumává bontja ki a %1 argumentumot.
%~$PATH:1 | Átvizsgálja a PATH környezeti változóban felsorolt könyvtárakat, és az elsőként megtalált elem teljesen minősített nevévé bontja ki a %1 argumentumot. Ha a környezeti változó neve nincs meghatározva, vagy a fájl nem található, ezt a módosítót a rendszer üres karakterlánccá bontja ki.

A módosítók kombinálásával összetett eredmények is létrehozhatók:

Változó | Leírás
%~dp1 | Meghajtóbetűjellé és elérési úttá bontja ki a %1 argumentumot.
%~nx1 | Fájlnévvé és kiterjesztéssé bontja ki a %1 argumentumot.
%~dp$PATH:1 | Átvizsgálja a PATH környezeti változóban felsorolt könyvtárakat, és az elsőként megtalált elem meghajtóbetűjelévé és elérési útjává bontja ki a %1 argumentumot.
%~ftza1 | A %1 argumentumot dir kimenethez hasonló sorrá bontja ki.

A fenti példákban a %1 argumentumot és a PATH változót más érvényes értékekkel is helyettesítheti. A %~ szintaxisnak érvényes argumentumszámmal kell végződnie. A %~ módosítók és a %* együtt nem használhatók.


Ping

Ellenőrzi a távoli számítógéppel vagy távoli számítógépekkel fennálló kapcsolatokat. Ez a parancs csak akkor érhető el, ha a TCP/IP protokoll telepítve van.

ping [-t] [-a] [-n szám] [-l hossz] [-f] [-i ttl] [-v tos] [-r szám] [-s szám] [[-j számítógépek listája] | [-k számítógépek listája]] [-w időtúllépés] célok listája

Paraméterek

-t

A megadott számítógépet addig teszteli a ping paranccsal, amíg a felhasználó félbeszakítja.

-a

A címeket számítógépnevekké oldja fel.

-n szám

Elküldi a szám beállítás által megadott számú ECHO csomagot. Az alapértelmezett érték 4.

-l hossz

A hossz beállítás által megadott méretű adatot tartalmazó ECHO csomagokat küld. Az alapértelmezett érték 32 bájt; a legnagyobb érték 65,527 bájt.

-f

Fragmentálást tiltó jelzőt küld a csomagban. A csomagot az útban található átjárók nem tördelik szét.

-i ttl

A Time To Live (élettartam) mező értékét a ttl beállításban megadott értékre állítja.

-v tos

A Type Of Service mező értékét a tos beállításban megadott értékre állítja.

-r szám

Rögzíti a kimenő csomag és a visszatérő csomag útját a Record Route mezőben. A szám beállításban legalább 1 és legfeljebb 9 számítógépet lehet megadni.

-s szám

Megadja a szám beállításban megadott számú ugrás időbélyegzőjét.

-j számítógépek listája

A csomagokat a számítógépek listája beállításban megadott számítógépeken keresztül irányítja. Az egymás után következő számítógépeket közbenső átjárók választhatják el egymástól (laza forrásútválasztás). Az IP által engedélyezett legmagasabb szám 9.

-k számítógépek listája

A csomagokat a számítógépek listája beállításban megadott számítógépeken keresztül irányítja. Az egymás után következő számítógépeket közbenső átjárók nem választhatják el egymástól (szigorú forrásútválasztás). Az IP által engedélyezett legmagasabb szám 9.

-w időtúllépés

Megadja az időtúllépési időközt ezredmásodpercben.

célok listája

Megadja a ping paranccsal tesztelni kívánt számítógépeket.


Megjegyzések a Ping parancshoz

Ping

Megjegyzések

A ping parancs a következőt végzi:

  • ICMP visszhangcsomagok küldésével és a válaszul érkező csomagok fogadásával ellenőrzi az egy vagy több távoli számítógéppel fennálló kapcsolatot.
  • Egy másodpercig terjedő ideig vár az elküldött csomagokra érkező válaszokra.
  • Kiírja az elküldött és a fogadott csomagok számát.
Mindegyik fogadott csomagot összehasonlítja az elküldött párjával. Alapértelmezés szerint négy, 32 bájt adatot (nagybetűs karakterek periodikus sorozatát) tartalmazó visszhangcsomagot küld.

A ping parancs mind a számítógép nevének, mind az IP-címének ellenőrzésére használható. Ha IP-címmel a ping teszt működik, a számítógépnévvel viszont nem, névhozzárendelési probléma állhat fenn. Ebben az esetben győződjön meg róla, hogy a lekérdezett számítógépnév szerepel a helyi Hosts fájlban vagy a DNS adatbázisban.

A következő példa a ping parancs kimenetét mutatja:

C:\>ping ds.internic.net

A ds.internic.net [192.20.239.132] tesztelése 32 bájt adattal:

Válasz a következő címről: 192.20.239.132: bájt=32 idő=101ezredmp. TTL=243

Válasz a következő címről: 192.20.239.132: bájt=32 idő=100ezredmp. TTL=243

Válasz a következő címről: 192.20.239.132: bájt=32 idő=120ezredmp. TTL=243

Válasz a következő címről: 192.20.239.132: bájt=32 idő=120ezredmp. TTL=243


Popd

A pushd parancs által eltárolt könyvtárra ugrik.

A popd paranccsal csak egyszer lehet könyvtárat váltani. A puffer kiürül az első használatkor.

Ha a parancskiterjesztések engedélyezettek (a Windows 2000 alapbeállítása), a popd parancs törli a pushd által létrehozott összes ideiglenes meghajtóbetűjelet.

popd

Kapcsolódó témakörök


Példák a Popd parancs használatára

Popd

Példák

A kötegfájl indításakor használt mappába történő visszatéréshez használja a pushd és popd parancsokat az következő módon:

@echo off

rem Ez a kötegfájl törli az összes .TXT fájlt egy megadott könyvtárban

pushd %1

del *.txt

popd

cls

echo Minden szövegfájl törölve a %1 könyvtárból


Portuas

2.x verziójú LAN Manager felhasználói fiók adatbázist fésül össze egy meglévő Windows 2000 felhasználói fiók adatbázisba.

portuas -f fájlnév [-u felhasználónév] [-v] [/codepage kódlap] [/log fájlnév]

Paraméterek

-f fájlnév

Megadja a LAN Manager 2.x NET.ACC fájlt.

u felhasználónév

Meghatározza a visszaállítandó felhasználót, vagy csoportot.

-v

Megjeleníti az összes üzenetet (részletez).

/codepage kódlap

Meghatározza a LAN Manager 2.x NET.ACC fájl OEM kódlapját.

/log fájlnév

Megadja az eredményeket naplózó fájlt.


Példák a Portuas parancs használatára

Portuas

Példák

2.x verziójú LAN Manager felhasználói fiók adatbázis Windows 2000 felhasználói fiók adatbázisba fésüléséhez írja be:

portuas -f \lanman\accounts\net.acc -v

A Peterv felhasználói fiók átadásához egy 2.x verziójú LAN Manager felhasználói fiók adatbázisból Windows 2000 rendszerű számítógépre, írja be:

portuas -f a:\net.acc -u Peterv


Megjegyzések a Portuas parancshoz

Portuas

Megjegyzések

Egy LAN Manager 2.x kiszolgáló felhasználói fiókjainak és csoportjainak helyreállításához egy Windows 2000 számítógépre használja a portuas parancsot.

A portuas használatához rendszergazda jogosultságú csoport tagjának kell lenni.

A Windows 2000 számítógépen futnia kell a Kiszolgáló és a Hálózati bejelentkezés szolgáltatásoknak.

A felhasználói fiók adatbázisok LAN Manager OS/2 kiszolgálókból végzett helyreállításához kapcsolódó teljes információért nézze meg a Windows 2000 dokumentációt.


Print

Kinyomtat egy szövegfájlt vagy megjeleníti a nyomtatási sor tartalmát.

Ez a parancs képes a háttérben nyomtatni, amennyiben a rendszer egy soros vagy párhuzamos portjához egy kimeneti eszköz tartozik.

print [/d:eszköz] [[meghajtó:][elérési út] fájnév[ ...]]

Paraméterek

nincs

Paraméterek nélkül használva a print parancs megjeleníti a nyomtatási sor tartalmát.

/d:eszköz

Megadja a nyomtatóeszköz nevét. A párhuzamos port érvényes értékei a következők: LPT1, LPT2 és LPT3. A soros port érvényes értékei a következők: COM1, COM2, COM3 és COM4. Hálózati nyomtató is megadható a megosztási nevével (\\kiszolgálónév\nyomtatásmegosztás). Az alapértelmezett érték PRN. A PRN és LPT1 értékek ugyanarra a párhuzamos portra hivatkoznak.

[meghajtó:][elérési út] fájlnév

A nyomtatandó fájl vagy fájlkészlet helyét és nevét határozza meg. Egy parancssorban több fájl is megadható.

A párhuzamos porthoz kapcsolódó nyomtató konfigurálásával kapcsolatos további információért kattintson a Kapcsolódó témakörök között a Mode (nyomtató konfigurálása) elemre.

A nyomtató állapotának megjelenítésével kapcsolatos további információért kattintson a Kapcsolódó témakörök között a Mode (eszköz állapotának megjelenítése) elemre

A sorsos porthoz kapcsolódó nyomtató konfigurálásával kapcsolatos további információért kattintson a Kapcsolódó témakörök között a Mode (nyomtatás átirányítása) elemre.

A nyomtató kódlapcserére való felkészítésével kapcsolatos további információért kattintson a Kapcsolódó témakörök között a Mode (eszköz kódlapjainak beállítása) elemre.


Példák a Print parancs használatára

Print

Példa

A következő parancs kinyomtatja a Report.txt fájlt az LPT1 nyomtatón:

print /d:LPT1 report.txt


Megjegyzések a Print parancshoz

Print

Megjegyzések

Programok által létrehozott fájlok nyomtatása

Sok program saját nyomtatási parancsokkal rendelkezik. Egy adott programmal létrehozott fájlok nyomtatásához az adott program print parancsát kell használni.


Prompt

A Windows 2000 parancssor megváltoztatása (Cmd.exe)

A parancssort testreszabva tetszés szerinti szöveget jeleníthet meg, beleértve olyan adatokat, mint például az aktuális könyvtár neve, a dátum és az idő vagy a Windows 2000 verziószáma.

prompt [szöveg]

Paraméterek

nincs

A prompt parancsot paraméterek nélkül kiadva alaphelyzetbe állíthatja a parancssort, megjelenítve az aktuális meghajtó betűjelét, az aktuális könyvtár nevét és a ”nagyobb, mint” jelet (>).

szöveg

Megadja a rendszer parancssorában megjeleníteni kívánt szöveget és adatokat. A következő lista a szöveg paraméterbe a karakterlánc(ok) mellett vagy helyett felvehető karakterkombinációkat mutatja. A lista tartalmazza az egyes karakterkombinációk által a parancssor tartalmába felvett szöveg vagy adatok rövid leírását.

Karakter | Leírás
$q | = (egyenlőségjel)
$$ | $ (dollárjel)
$t | Aktuális idő
$d | Aktuális dátum
$p | Aktuális meghajtó és könyvtár
$v | A Windows 2000 verziószáma
$n | Aktuális meghajtó
$g | > (”nagyobb, mint” jel)
$l | < (”kisebb, mint” jel)
$b | | (függőleges vonás)
$_ | ENTER-LINEFEED
$e | ANSI escape kód (27-es kód)
$h | VISSZA (a parancssorba beírt karakter törlésére)
$a | & (ampersand)
$c | ( (nyitó zárójel)
$f | ) (záró zárójel)
$s | szóköz

Ha a parancskiterjesztések engedélyezve vannak (ez a Windows 2000 alapértelmezett beállítása), a prompt parancs a következő formázókaraktereket is támogatja:

Karakter | Leírás
$+ | Nulla vagy több pluszjel (+) karakter, a pushd könyvtárverem mélységétől függően, minden leküldött szint után egy karakter.
$m | Az aktuális meghajtóbetűjelhez társított távoli név vagy üres karakterlánc, ha az aktuális meghajtó nem hálózati meghajtó.


Példák a Prompt parancs használatára

Prompt

Példák

Az alábbi példa beállítja a parancssort az aktuális meghajtó és elérési út, és azt követően egy “nagyobb mint” (>) jel megjelenítéséhez:

prompt $p$g

A következő parancs egy kétsoros parancssort definiál, amelyben az első sorban megjelenik a pillanatnyi idő, a második sorban pedig az aktuális dátum:

prompt time is: $t$_date is: $d


Megjegyzések a Prompt parancshoz

Prompt

Megjegyzések

A $p érték használata szöveghez

Ha a $p karaktert befoglalja a szövegparaméterbe, a Windows 2000 minden alkalommal olvassa a lemezt, amikor megadja az egyes parancsokat az aktuális meghajtó és elérési út meghatározásához. Ez hosszabb időbe telhet, különösen hajlékonylemezes meghajtó esetén.


Protshell

A Windows 2000 és az OS/2 alrendszer nem használja ezt a parancsot. Csak az MS OS/2 1.3-as vagy korábbi verziókból származó fájlokkal való kompatibilitás miatt fogadja el a rendszer a parancsot.


Pushd

Eltárolja az aktuális könyvtár nevét a popd parancs számára, és átvált a megadott könyvtárra.

pushd [elérési_útvonal]

Paraméter

elérési_útvonal

Megadja azt könyvtárat, amelyet aktuális könyvtárrá kíván tenni. A parancs támogatja a relatív elérési útvonalak használatát. A parancskiterjesztések engedélyezése esetén (a Windows 2000 alapbeállítása) a pushd parancs elfogadja a hálózati elérési útvonalat, illetve a helyi meghajtóbetűjelet és elérési útvonalat is.

Hálózati elérési útvonal megadása esetén a pushd parancs létrehoz egy ideiglenes meghajtóbetűjelet a megadott hálózati erőforráshoz, majd az aktuális meghajtóról és könyvtárról átvált az újonnan definiált meghajtó megadott könyvtárára. Az ideiglenes meghajtóbetűjelek elhelyezése az első használaton kívüli meghajtóbetűjel felhasználásával történik. A popd parancs használata törli a pushd által létrehozott ideiglenes meghajtóbetűjelet.


Példák a Pushd parancs használatára

Pushd

Példák

A kötegfájl indításakor használt mappába történő visszatéréshez használja a pushd és popd parancsokat az következő módon:

@echo off

rem Ez a kötegfájl törli az összes .txt fájlt egy megadott könyvtárban

pushd %1

del *.txt

popd

cls

echo Minden szövegfájl törölve a %1 könyvtárból


QBasic

Elindítja a Windows 2000 QBasic programot. Ez a program olvassa a Basic programozási nyelven írt utasításokat, és lefordítja azokat futtatható gépi kóddá.

qbasic [/b] [/editor] [/g] [/h] [/mbf] [/nohi] [[/run][meghajtó:][elérési_út] fájlnév]

Paraméterek

/b

A QBasic programot fekete-fehéren jeleníti meg színes monitoron.

/editor

Elindítja az MS-DOS Editor teljes képernyős szövegszerkesztő programot.

/g

Biztosítja a CGA monitorok leggyorsabb frissítését.

/h

A maximálisan megjeleníthető számú képernyősort jeleníti meg.

/mbf

A beépített MKS$, MKD$, CVS és CVD függvényeket konvertálja MKSMBF$, MKDMBF$, CVSMBF és CVDMBF függvényekké.

/nohi

Lehetővé teszi olyan monitorok használatát, amelyek nem támogatják a nagy intenzitású videó üzemmódot. Ezt a kapcsolót ne használja COMPAQ laptop számítógépeken.

/run

Lefuttatja a megadott Basic programot, annak megjelenítése előtt. Kötelező megadni egy fájlnevet.

[meghajtó:][elérési_út] fájlnév

A QBasic indításakor beolvasandó fájl helyét és nevét adja meg.


Megjegyzések a QBasic parancshoz

QBasic

Megjegyzések

A Windows 2000 QBasic hiányában az MS-DOS Editor program nem használható.

Az MS-DOS Editor program használatához a Qbasic.exe fájlnak az aktuális könyvtárban, a keresési útvonalon, vagy az Edit.com fájllal megegyező könyvtárban kell lennie. Ha helykímélési céllal letörli a Qbasic.exe fájlt a merevlemezről, akkor az MS-DOS Editor program nem használható.

Több Basic program futtatása egymás után

A Basic system utasítás és a qbasic parancs /run kapcsolóval történő használatával több Basic program is futtatható egymás után egy kötegfájlból. A SYSTEM utasítás a Basic program lefutása után a QBasic program helyett a Windows 2000 számára adja vissza a vezérlést. Ez lehetővé teszi több Basic program lefuttatását megszakítás nélkül egy parancsfájlból.

GW-BASIC program konvertálása QBasic-ben futtatható programmá

A GW-BASIC programot QBasic programmá konvertáló Basic program Remline.bas néven található meg (a QBasic részeként).

Billentyűparancsok megjelenítése

Néhány monitortípus alapértelmezésben nem támogatja a billentyűparancsok megjelenítését. Ha a monitor nem jeleníti meg a billentyűparancsokat, használja a /b kapcsolót (CGA monitor esetén) vagy a /nohi kapcsolót (félkövér betűket nem támogató rendszerek esetén).


Rcp

Fájlokat másol a Windows 2000 operációs rendszerrel rendelkező számítógép és olyan rendszer között, amelyen az rshd, a távoli parancshéj démon fut. Az rcp kapcsolatkezelő parancs más fájlmásolási műveletre is használható két olyan számítógép között, amelyeken az rshd fut, ha a parancsot Windows 2000 operációs rendszerrel rendelkező számítógépről adja ki. Az rshd démon a UNIX számítógépeken elérhető, a Windows 2000 alatt viszont nem, így a Windows 2000 operációs rendszerrel rendelkező számítógép csak parancsok kiadására szolgáló rendszer lehet. A távoli számítógépnek kell biztosítania az rcp segédprogramot az rshd futtatásával.

rcp [-a | -b] [-h] [-r] forrás1 forrás2 ... forrásN cél

Paraméterek

-a

ASCII átviteli üzemmódot ad meg. Ebben az üzemmódban a rendszer a kocsi vissza/soremelés karaktereket kocsi vissza karakterekké alakítja a kimenő fájlokban, a soremelés karaktereket pedig kocsi vissza/soremelés karakterekké alakítja a bejövő fájlokban. Ez az alapértelmezett átviteli üzemmód.

-b

Bináris átviteli üzemmódot ad meg. A rendszer nem hajtja végre a kocsi vissza/soremelés karakterek átalakítását.

-h

Átviszi a Windows 2000 operációs rendszerrel rendelkező számítógépen rejtett attribútummal rendelkező forrásfájlokat. Ha e beállítás nélkül ad meg rejtett fájlt az rcp parancssorban, az ugyanazt a hatást váltja ki, mintha a fájl nem létezne.

-r

Rekurzív módon másolja az összes alkönyvtár tartalmát a forrásról a célra. Mind a forrás, mind a cél csak könyvtár lehet, bár a -r akkor is működik, ha a forrás nem könyvtár. Ekkor azonban nem történik rekurzió.

forrás és cél

Formája a következő lehet: [számítógép[.felhasználó]:]fájlnév. Ha a [számítógép[.felhasználó]:] részt kihagyja, a rendszer a helyi számítógépet veszi alapul. Ha a [.felhasználó] részt kihagyja, a rendszer a Windows 2000 rendszerbe jelenleg bejelentkezett felhasználó nevét használja. Ha teljesen megadott számítógépnevet használ, amely pont (.) elválasztókat tartalmaz, a felhasználó] nevét meg kell adni. Egyébként a rendszer a számítógép nevének utolsó részét értelmezi felhasználónévként. Ha több forrásfájlt ad meg, a cél csak könyvtár lehet.

Ha a fájl neve UNIX rendszer esetén nem ferde vonal (/) karakterrel, illetve Windows 2000 rendszer esetén nem fordított ferde vonal (\) karakterrel kezdődik, a rendszer az aktuális munkakönyvtárhoz viszonyítva értelmezi. Windows 2000 operációs rendszer esetén ez az a könyvtár, amelyben a parancsot kiadták. A távoli rendszerben ez a távoli felhasználó bejelentkezési könyvtára. A pont (.) az aktuális könyvtárat jelenti. A távoli elérési utakban escape karaktereket (\ , ”, vagy ') megadva használhat helyettesítő karaktereket a távoli számítógépen.


Példák az Rcp parancs használatára

Rcp

Példák

Helyi fájl a következő paranccsal másolható a távoli számítógép bejelentkezési könyvtárába:

rcp fájlnév távoli_számítógép:

Helyi fájl a következő paranccsal másolható új néven a távoli számítógép meglévő könyvtárába:

rcp fájlnév távoli_számítógép:/könyvtár/új_fájlnév

Több helyi fájl a következő paranccsal másolható a távoli számítógép bejelentkezési könyvtárában lévő alkönyvtárba:

rcp file1 file2 file3 távoli_számítógép:alkönyvtár/fájlkönyvtár

Távoli forrásból a következő paranccsal másolhatók a fájlok a helyi számítógép aktuális könyvtárába:

rcp távoli_számítógép:fájlnév

Több fájl több távoli forrásból a következő paranccsal másolható különböző felhasználónevű távoli célba:

rcp távoli1.felhasználó1:fájl1 távoli2.felhasználó2:fájl2 távolicél.célfelhasználó:könyvtár


Megjegyzések az Rcp parancshoz

Rcp

Megjegyzések

Távoli jogosultságok

Az rcp parancs nem kéri a jelszókat; az aktuális vagy megadott felhasználónévnek léteznie kell a távoli számítógépen, és lehetővé kell tennie a távoli parancsvégrehajtást az rcp útján.

A .rhosts fájl

A .rhosts fájl megadja, hogy mely távoli rendszerek illetve felhasználók férhetnek hozzá helyi fiókhoz az rsh vagy rcp parancs segítségével. Ez a fájl (vagy a HOSTS megfelelője) feltétlenül szükséges ahhoz, hogy a távoli rendszerhez hozzáférhessen ezen parancsok segítségével. Az rsh és rcp parancs is átadja a helyi felhasználónevet a távoli rendszernek. A távoli rendszer a név és az IP-cím (általában számítógépnévvé feloldva) vagy a kérelmező rendszer alapján dönti el, hogy ad-e hozzáférést. A jelszót nem kell megadni, ha ezeket a parancsokat használva kíván hozzáférni a fiókhoz.

Ha a felhasználó be van jelentkezve a Windows 2000 Server tartományba, az elsődleges tartománykiszolgálónak elérhetőnek kell lennie az aktuális bejelentkezett név feloldása érdekében, mert a bejelentkezett nevet a helyi számítógép nem tárolja. Mivel a felhasználónév az rsh protokoll része, a parancs végrehajtása meghiúsul, ha a felhasználónevet nem lehet megszerezni.

A .rhosts fájl egy szövegfájl, amelyben minden egyes sor egy bejegyzés. A bejegyzés a helyi számítógép nevét, a helyi felhasználónevet és a bejegyzéssel kapcsolatos megjegyzéseket tartalmazza. Az egyes bejegyzéseket tabulátor vagy szóköz választja el egymástól, a megjegyzések pedig kettős kereszt (#) karakterrel kezdődnek, például:

computer5marie#Ez a számítógép a 31-es szobában van

Az .rhosts fájlnak a felhasználó kezdőkönyvtárában kell lennie a távoli számítógépen. Az .rhosts fájl távoli számítógépeken történő különböző megvalósításáról további információt a távoli rendszer dokumentációjában talál.

A helyi számítógép nevét vegye fel a távoli rendszeren az /Etc/Hosts nevű fájlba. Ez lehetővé teszi a távoli rendszer számára, hogy a Microsoft TCP/IP segédprogramok segítségével hitelesítse a helyi számítógép felé irányuló távoli kéréseket.

Számítógépek (állomások) megadása

A számítógép.felhasználó változók segítségével az aktuális felhasználónévtől eltérő felhasználónevet is megadhat. Ha a számítógép.felhasználó a forrás beállítással van megadva, a távoli számítógépen található .rhosts fájlnak tartalmaznia kell a felhasználóhoz tartozó bejegyzést, például a következőképpen:

rcp csiko.rozsas:file1 bivaly.admin:file2

A Bivaly nevű gépen lévő .rhosts fájlnak tartalmaznia kell egy bejegyzést a Rozsas nevű felhasználóhoz, aki a Csiko nevű számítógépen található.

Ha a számítógép nevét teljes, pontokat tartalmazó tartománynévként adja meg, a fentebb leírtaknak megfelelően a felhasználónevet is meg kell adni a számítógép neve mellett. Ezzel megakadályozza, hogy a rendszer a tartománynév utolsó elemét felhasználónévként értelmezze, például a következőképpen:

rcp tartománynév1.felhasználó:janosm tartománynév2.felhasználó:belas

Távoli feldolgozás

A legtöbb UNIX rendszeren a felhasználó bejelentkezési parancshéjából futtatott parancs távoli feldolgozást hajt végre. A felhasználó .profile vagy .cshrc fájlját a rendszer a fájlnevek elemzése előtt hajtja végre, és az exportált parancshéjváltozók is használhatók (az escape karakter vagy idézőjelek segítségével) a távoli fájlnevekben.

Fájlok másolása

Ha fájlba, és nem könyvtárba próbál több fájlt másolni, csak az utolsó fájl másolása történik meg. Az rcp parancs a fájlt önmagára sem másolhatja.

Ha nem a helyi tartományt használva jelentkezett be a Windows 2000 operációs rendszerrel rendelkező számítógépre, és az elsődleges tartományvezérlő nem érhető el, a parancs végrehajtása meghiúsul, mert az rcp nem tudja meghatározni a helyi felhasználónevet. Ugyanez a korlátozás vonatkozik az rsh parancsra is.


Recover

Olvasható adatokat állít helyre rossz vagy sérült lemezekről.

A recover parancs szektorról szektorra olvassa a fájlt, és a jó szektorokból visszaállítja az adatokat. A hibás szektorokban lévő adat elveszik.

recover [meghajtó:][elérési_út] fájlnév

Paraméter

[meghajtó:][elérési_út] fájlnév

Megadja a helyreállítani kívánt fájl helyét és nevét.


Példák a Recover parancs használatára

Recover

Példák

A Story.txt fájl helyreállításához a D: meghajtó \Fiction könyvtárában, írja be a következőt:

recover d:\fiction\story.txt


Megjegyzések a Recover parancshoz

Recover

Megjegyzések

A [meghajtó:][elérési út] fájlnév korlátozásai

A recover paranccsal nem használhatók a helyettesítő karakterek (* és ?). Meg kell adni egy fájlt.

Elveszett adat ismételt bevitele

Mivel a hibás szektorokban lévő valamennyi adat elveszik a fájlok helyreállításakor, ezért egyszerre csak egyetlen fájt állítson helyre. Ezzel a módszerrel egy fájl helyreállítása után újra beviheti a hiányzó adatokat.

Hibás szektorok helyreállítása

A chkdsk által megtalált hibás szektorok már a lemez első működése előtt is hibás szektorként voltak megjelölve. Ezek nem jelentenek veszélyt, és a recover parancs nem érinti őket.


Átirányítás

Az átirányító karakterek azt módosítják, hogy a programok honnan veszik, illetve hová küldik az adatokat.

Parancsok be- és kimenetének átirányítása

Ha nincs másképpen megadva, a Windows 2000 a bemenetet a billentyűzetről veszi, a kimenetet pedig a képernyőre küldi. Néha hasznos lehet a be- vagy kimenetet fájlba vagy nyomtatóra átirányítani. Például előfordulhat, hogy a könyvtárlistát a képernyőről fájlba kívánja irányítani.

A parancs be- és kimenetének átirányítására az alábbi átirányító karakterek használhatók:

  • A „nagyobb mint” jel (>) a parancs kimenetét fájlba vagy egyéb eszközre, például nyomtatóra küldi. A parancsok bizonyos kimenetei, például a hibaüzenetek, nem irányíthatók át a „nagyobb mint” jel (>) használatával.
  • A „kisebb mint” jel (<) a parancshoz szükséges bemenetet a billentyűzet helyett fájlból veszi.
  • A két „nagyobb mint” jel (>>) a parancs kimenetét a fájl végéhez írja úgy, hogy nem törli az abban található adatokat.
  • A >& jel az egyik alapértelmezett I/O adatfolyam (stdout, stdin, stderr) kimenetét egy másikba irányítja át. Például a parancs >kimeneti_fájl 2>&1 utasítás a parancs feldolgozása során keletkező hibaüzeneteket a képernyőről a szabványos fájlkimenetre irányítja. A szabványos kimenetek számértékei a következők:
    Szabványos kimenet | Numerikus megfelelő
    Stdin | 0
    Stdout | 1
    Stderr | 2

Parancs kimenetének átirányítása

Majdnem valamennyi parancs a képernyőre küldi a kimenetet. Még azok a parancsok is jelenítenek meg üzenetet vagy kérdést a képernyőn, amelyek a kimenetet meghajtóra vagy nyomtatóra küldik.

A kimenet képernyőről fájlba vagy nyomtatóra történő átirányításához használja a „nagyobb mint” jelet (>). A „nagyobb mint” jel a legtöbb Windows 2000 paranccsal használható. Például az alábbi parancs a dir paranccsal készített könyvtárlistát a Könyvlis.txt fájlba irányítja át:

dir > könyvlis.txt

Ha a könyvlis.txt fájl nem létezik, a Windows 2000 létrehozza. Ha a Könyvlis.txt fájl már létezik, a Windows 2000 a fájlban található adatokat a dir parancs kimenetére cseréli.

Ha a parancs kimenetét úgy szeretné hozzáfűzni a fájl végéhez, hogy ne vesszenek el az abban már meglévő adatok, használjon két „nagyobb mint” jelet (>>). Például az alábbi parancs a dir paranccsal készített könyvtárlistát a Könyvlis.txt fájlba irányítja át:

dir >> könyvlis.txt

Parancs bemenetének átirányítása

Hasonlóan ahhoz, amikor a parancs kimenetét a képernyő helyett fájlba vagy nyomtatóra küldi, a parancs a billentyűzet helyett fájlból is kaphatja a bemenetét. A bemenet fájlból való olvasásához használja a „kisebb mint” jelet (<). Például az alábbi parancs esetében a sort parancs a bemenetet a Lista.txt fájlból veszi:

sort < lista.txt

A Windows 2000 ábécérendbe rendezi a lista.txt fájl sorait, és az eredményt a képernyőn jeleníti meg.

Related Topics


Rem

Lehetővé teszi, hogy egy kötegfájlba vagy a konfigurációs fájlokba megjegyzéseket foglaljon be.

rem [megjegyzés]

Paraméter

megjegyzés

Bármely, megjegyzésként befoglalni kívánt karaktersorozatot ad meg.


Példák a Rem parancs használatára

Rem

Példák

Az alábbi példa egy olyan kötegfájlt mutat be, amelyben megjegyzések találhatók, mind a magyarázatokhoz, mind a függőleges sortávolsághoz.

@echo off
rem Ez a kötegfájl új lemezeket formáz és ellenőriz.
rem A fájl neve Checknew.bat.
rem
echo Helyezzen be új lemezt a B meghajtóba.
pause
format b: /v
chkdsk b:

Tegyük fel, hogy a Config.nt fájlba bele kíván foglalni egy magyarázó megjegyzést a prompt parancs elé. Ehhez adja a következő sort a Config.nt fájlhoz:

rem Állítsa a parancssort az aktuális könyvtárra
prompt $p$g


Megjegyzések a Rem parancshoz

Rem

Megjegyzések

Megjegyzések megjelenítése az echo paranccsal

A rem parancs nem jeleníti meg a megjegyzéseket a képernyőn. Megjegyzések képernyőn történő megjelenítéséhez az echo on parancsot kell használnia a kötegfájlban vagy a Config.nt fájlban.

A kötegfájl megjegyzéseire vonatkozó korlátozások

Kötegfájl megjegyzésében nem használható az átirányítás karakter "(" vagy ")", illetve a függőleges vonás (|) karakter.

A rem parancs használata függőleges sortávolság megadásához

A rem megjegyzés nélküli használatával növelhető a függőleges sortávolság a kötegfájlban, azaz üres sorok szúrhatók be. A Windows 2000 figyelmen kívül hagyja az üres sorokat a kötegfájlok feldolgozásakor.


Rename (Ren)

Módosítja egy fájl vagy fájlok halmazának nevét.

Minden, a megadott fájlnévnek megfelelő fájl átnevezhető. A rename parancs nem használható fájlok átnevezésére úgy, hogy azok más meghajtóra vagy könyvtárba kerülnek az átnevezés során.

rename [meghajtó:][elérési út] fájlnév1 fájlnév2

ren [meghajtó:][elérési út] fájlnév1 fájlnév2

Paraméterek

[meghajtó:][elérési út] fájlnév1

Az átnevezni kívánt fájl vagy fájlhalmaz helyét és nevét határozza meg.

fájlnév2

Megadja a fájl új nevét. Ha helyettesítő karaktereket (* és ?) használ, a fájlnév2 paraméter határozza meg a fájlok új nevét. Fájlok átnevezése esetén nem lehet megadni új meghajtót vagy elérési utat.


Példák a Rename parancs használatára

Rename

Példák

Tegyük fel, hogy az aktuális könyvtárban található összes .txt kiterjesztésű fájl fájlkiterjesztését .doc kiterjesztésre kívánja cserélni. Ehhez a módosításhoz írja be a következőt:

ren *.txt *.doc

A Chap 10 nevű fájl vagy könyvtár átnevezéséhez Part 10 névre, írja be:

ren chap10 part10


Megjegyzések a Rename parancshoz

Rename

Megjegyzések

Helyettesítő karakterek használata a rename paranccsal

Helyettesítő karakterek (* és ?) is használhatók a fájlnév megadásához. Ha helyettesítő karaktereket használ a fájlnév2 beírásakor, akkor a helyettesítő karakterek által jelölt karakterek megegyeznek majd a fájlnév1 megfelelő karaktereivel.

Az átnevezés nem lehetséges, ha már létezik a fájlnév2.

Ha a fájlnév2 értékének már meglévő fájlnevet ad meg, akkor a rename a következő üzenetet jeleníti meg:

Megegyező fájlnév, vagy a fájl nem található


Replace

Felülírja a célkönyvtárban található fájlokat a forráskönyvtárban található azonos nevű fájlokkal. A replace paranccsal a célkönyvtárba egyedi fájlnevek is hozzáadhatók.

replace [meghajtó1:][elérési_útvonal1] fájlnév [meghajtó2:][elérési_útvonal2] [/a] [/p] [/r] [/w]

replace [meghajtó1:][elérési út1] fájlnév [meghajtó2:][elérési_útvonal2] [/p] [/r] [/s] [/w] [/u]

Paraméterek

[meghajtó1:][elérési_útvonal1] fájlnév

A forrásfájl vagy -fájlok helyét és nevét adja meg.

[meghajtó2:][elérési_útvonal2]

A célfájl helyét adja meg. Nem adható meg a cserélni kívánt fájlok neve. Ha nem adja meg a meghajtót és a könyvtárat, a replace parancs az aktuális meghajtót és könyvtárat használja célként.

/a

A meglevő fájlok felülírása helyett új fájlokat vesz fel a célkönyvtárba. Ez a kapcsoló nem használható együtt az /s vagy /u kapcsolóval.

/p

Jóváhagyást kér a célfájlok felülírása, vagy forrásfájlok hozzáadása előtt.

/r

Felülírja a csak olvasható valamint a nem védett fájlokat. Ha nem adja meg ezt a kapcsolót, de megkísérel felülírni egy csak olvasható fájlt, hibaüzenet jelenik meg és a művelet megszakad.

/w

A forrásfájlok keresésének megkezdése előtt lemez behelyezését várja. Ha nem adja meg a /w kapcsolót, a replace parancs az ENTER billentyű leütése után azonnal megkezdi a fájlok hozzáadását vagy cseréjét.

/s

Keresést végez a célkönyvtár összes alkönyvtárában és felülírja az egyező fájlokat. A /s kapcsoló nem használható együtt az /a kapcsolóval. A replace parancs nem végez keresést az elérési_útvonal1 paraméterben megadott elérési útvonal alkönyvtáraiban.

/u

A célkönyvtárban csak azokat a fájlokat írja felül (frissíti), amelyek régebbiek mint a forráskönyvtárban levő fájlok. Az /s kapcsoló nem használható együtt az /a kapcsolóval.


Példák a Replace parancs használatára

Replace

Példák

Tegyük fel, hogy a C meghajtón több könyvtár tartalmazza az ügyfélneveket és telefonszámokat magába foglaló Telefonszámok.cli fájl különböző változatait. Az összes ilyen fájl a következő paranccsal cserélhető le az A meghajtóban lévő lemezen található legfrissebb verziójú Telefonszámok.cli fájlra:

replace a:\telefonszámok.cli c:\ /s

Ha új nyomtatóillesztőt kíván hozzáadni a C meghajtó Tools könyvtárához, amelyben már több nyomtatóillesztő fájl is található egy szövegszerkesztőhöz, akkor írja be a következő parancsot:

replace a:*.prd c:\tools /a

Ez a parancs megkeresi az A meghajtón található .prd kiterjesztésű fájlokat, és hozzáadja azokat a C meghajtó Tools könyvtárához. Mivel az /a kapcsoló is szerepel a parancsban, a replace csak azokat a fájlokat másolja át az A meghajtóról, amelyek nem szerepelnek a C meghajtón.


Megjegyzések a Replace parancshoz

Replace

Megjegyzések

A replace parancs üzenetei

A fájlok hozzáadásakor vagy cseréjekor a Windows 2000 replace parancsa megjeleníti azok nevét a képernyőn. A replace parancs végrehajtása után a Windows 2000 összegző sort jelenít meg az alábbi formátumok egyikében:

nnn fájl hozzáadva
nnn fájl cserélve

nincs hozzáadott fájl
nincs cserélt fájl

Fájlok cseréje hajlékonylemezen

Ha hajlékonylemezeket használ, és a replace parancs futása alatt cserélni kívánja a lemezeket, a /w kapcsoló megadásakor a replace parancs szükség szerint megvárja a lemezek cseréjét.

A replace paranccsal kapcsolatos korlátozások

A replace parancs nem használható rejtett és rendszerfájlok frissítésére. A rejtett és rendszer attribútum módosításával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témakörök között az attrib című témakört.

A replace parancs kilépési kódjai

Az alábbi listában az egyes kilépési kódok és azok rövid leírása található:

0 | A replace parancs sikeresen kicserélte vagy hozzáadta a fájlokat.
1 | A replace parancs az MS-DOS nem megfelelő verzióját észlelte.
2 | A replace parancs nem találta a forrásfájlokat.
3 | A replace parancs nem találja a forrásként vagy célként megadott elérési útvonalat.
5 | A felhasználónak nincs hozzáférési engedélye a cserélni kívánt fájlokhoz.
8 | Nincs elegendő rendszermemória a parancs végrehajtásához.
11 | A felhasználó rossz szintaxist használt a parancssorban.

Az if parancs errorlevel paraméterének segítségével kötegfájlban feldolgozhatók a diskcomp parancs kilépési kódjait. A kilépési kódokat feldolgozó kötegfájlt mutat be a Kapcsolódó témakörök között az if című témakör.


Rexec

Parancsokat futtat távoli számítógépeken, amelyeken fut a REXEC szolgáltatás. A rexec parancs a megadott parancs végrehajtása előtt hitelesíti a felhasználónevet a távoli számítógépen. A parancs csak telepített TCP/IP protokoll esetén használható.

rexec számítógép [-l felhasználónév] [-n] parancs

Paraméterek

számítógép

Megadja azt a távoli számítógépet, amelyen a parancsot futtatja.

-l felhasználónév

Megadja a felhasználónevet a távoli számítógépen.

-n

Átirányítja a rexec parancs bemenetét a NULL eszközre.

parancs

Megadja a futtatandó parancsot.


Megjegyzések a Rexec parancshoz

Rexec

Megjegyzések

Normál működés

A rexec parancs bekéri a felhasználó jelszavát és hitelesíti azt a távoli számítógépen. Ha a hitelesítés sikeres, a program végrehajtásra kerül.

A rexec parancs átadja a normál bemenetet a távoli parancsnak, a távoli parancs normál kimenetét átmásolja a saját normál kimenetébe, és a távoli parancs normál hibáját átmásolja a saját normál hibájába. A rexec parancs normálisan akkor fejeződik be, amikor a távoli parancs.

Átirányító jelek használata

A távoli számítógépre történő átirányításhoz tegye az átirányító jeleket idézőjelek közé. Az idézőjelek hiányában az átirányítás a helyi számítógépen történik. A következő példában a parancs hozzáfűzi a remotefile nevű távoli fájlt a localfile nevű helyi fájlhoz:

rexec othercomputer cat remotefile >> localfile

A következő példában a parancs hozzáfűzi a remotefile nevű távoli fájlt az otherremotefile nevű távoli fájlhoz:

rexec othercomputer cat remotefile ">>" otherremotefile

Interaktív parancsok használata

A legtöbb interaktív parancs nem futtatható. Például a vi vagy az emacs parancsok nem futtathatók a rexec használatával. Használja helyette a telnet programot.


Rmdir (Rd)

Eltávolítja (törli) a könyvtárat.

rmdir [meghajtó:]elérési_útvonal [/s] [/q]

rd [meghajtó:]elérési_útvonal [/s] [/q]

Paraméterek

[meghajtó:]elérési_útvonal

Megadja a törölni kívánt könyvtár nevét és elérési helyét.

/s

Eltávolítja a megadott könyvtárat és annak összes alkönyvtárát valamennyi fájllal együtt. Fa eltávolítására használható.

/q

Csendes üzemmódban futtatja az rmdir parancsot. Megerősítés nélkül törli a könyvtárakat.


Példák az Rmdir parancs használatára

Rmdir

Példák

A \User\Smith könyvtár törléséhez a következő módon győződjön meg arról, hogy a könyvtár üres:

dir \user\smith /a

Ekkor csak a "." és ".." jeleknek szabad megjelenni.

Azután a \User\Smith könyvtáron kívül, valamelyik könyvtárban írja be:

rmdir \user\smith

A \User könyvtár és az abban lévő összes fájl és alkönyvtár törléséhez írja be:

rmdir /s \user


Megjegyzések az Rmdir parancshoz

Rmdir

Megjegyzések

Rejtett vagy rendszerfájlokat tartalmazó könyvtár nem törölhető

Rejtett vagy rendszerfájlokat tartalmazó könyvtárt nem lehet törölni. Ha megkísérli, a Windows 2000 az alábbi üzenetet jeleníti meg:

A könyvtár nem üres

A rejtett vagy rendszerfájlok listázásához használja a dir parancsot, a rejtett és rendszerfájl attribútumok eltávolításához pedig használja az attrib parancsot. További tájékoztatásért kattintson a Kapcsolódó témakörök között a dir és az attrib parancsra.

A fordított ferde vonal karakter használata az elérési út paraméterrel

Ha behelyez egy fordított ferde vonalat (\) az elérési út első könyvtárneve elé, a Windows 2000 a könyvtárat a gyökérkönyvtár alkönyvtáraként kezeli, tekintet nélkül az aktuális könyvtárra. Ha nem helyez be fordított ferde vonalat (\) az elérési út első könyvtárneve elé, a Windows 2000 a könyvtárat az aktuális könyvtár alkönyvtáraként kezeli.

Az aktuális könyvtár törlése

Az rmdir parancs nem használható az aktuális könyvtár törlésére. Először át kell váltani egy másik könyvtárra (amely nem lehet az aktuális könyvtár alkönyvtára), majd elérési utat megadva kell használni az rmdir parancsot. Ha megkísérli az aktuális könyvtár törlését, a Windows 2000 az alábbi üzenetet jeleníti meg:

A folyamat nem fér hozzá a fájlhoz, mert azt egy másik folyamat használja.


Route

Módosítja a hálózati útvonaltáblákat. Ez a parancs csak a TCP/IP protokoll telepítése esetén használható.

route [-f] [-p] [parancs [cél] [mask alhálózati_maszk] [átjáró] [metric költség_metrika]]

Paraméterek

-f

Törli az összes átjáróbejegyzés útvonaltábláját. Ha az alábbi parancsokkal együtt használja, akkor a táblákat a parancs futtatása előtt törli a rendszer.

-p

Az add paranccsal együtt használva az útvonalat rendszerbetöltéskor is elérhetővé teszi. Alapértelmezés szerint az útvonalak a rendszer újraindításakor nem érhetők el. A print paranccsal együtt használva megjeleníti az állandó útvonalak listáját. Minden más parancs esetében, amelyek mindig hatással vannak a megfelelő állandó útvonalakra, figyelmen kívül marad.

command

A következő parancsok egyikét adja meg.

Parancs | Cél
print | Útvonal nyomtatása
add | Útvonalat hozzáadása
delete | Útvonal törlése
change | Meglevő útvonal módosítása

destination

Megadja azt a számítógépet, amelynek küldeni kívánja a parancsot.

mask alhálózati_maszk

Az útvonalbejegyzéshez tartozó alhálózati maszkot adja meg. Ha nincs megadva, akkor a rendszer a 255.255.255.255 maszkot használja.

gateway

Megadja az átjárót.

A cél vagy átjáró paraméterekben használt összes szimbolikus név mind a Networks nevű hálózati adatbázisfájlban, mind pedig a számítógépneveket gyűjtő Hosts adatbázisban szerepel. Ha a print vagy delete parancsot használja, a cél és átjáró paraméterekben helyettesítő karakterek is használhatók, vagy az átjáró argumentum el is hagyható.

metric költség_metrika

Egész számú költségjelző (1-9999 között), amely a leggyorsabb, legmegbízhatóbb és/vagy legkevésbé költséges útvonal kiszámítására használható.


Rsh

Parancsokat futtat távoli számítógépeken, amelyeken fut az RSH szolgáltatás. Ez a parancs csak telepített TCP/IP protokoll esetén érhető el.

rsh számítógép [-l felhasználónév] [-n] parancs

Paraméterek

számítógép

Megadja azt a távoli számítógépet, amelyen a parancsot futtatja.

-l felhasználónév

Megadja a felhasználónevet a távoli számítógépen. Ha ez nincs megadva, a bejelentkező nevet használja a rendszer.

-n

Átirányítja az rsh parancs bemenetét a NULL eszközre.

parancs

Megadja a futtatandó parancsot.


Megjegyzések az Rsh parancshoz

Rsh

Megjegyzések

Normál működés

Az rsh parancs átadja a normál bemenetet a távoli parancsnak, a távoli parancs normál kimenetét átmásolja a saját normál kimenetébe, és a távoli parancs normál hibáját átmásolja a saját normál hibájába. Az Rsh parancs végrehajtása rendszerint akkor ér véget, amikor a távoli parancs befejeződik.

Átirányító jelek használata

A távoli számítógépre történő átirányításhoz tegye az átirányító jeleket idézőjelek közé. Az idézőjelek hiányában az átirányítás a helyi számítógépen történik. A következő példában a parancs hozzáfűzi a távolifájl nevű távoli fájlt a helyifájl nevű helyi fájlhoz:

rsh másikgép cat távolifájl >> helyifájl

A következő példában a parancs hozzáfűzi a távolifájl nevű távoli fájlt a másiktávolifájl nevű távoli fájlhoz:

rsh másikgép cat távolifájl ">>" másiktávolifájl

Az rsh parancs használata

Windows 2000 rendszert futtató számítógépen a bejelentkezéskor használt tartomány elsődleges tartományvezérlőjének elérhetőnek kell lennie a felhasználói név ellenőrzéséhez, egyébként az rsh parancs sikertelen.

Az .rhosts fájl

Az .rhosts fájl általánosságban engedélyezi UNIX rendszereken a hálózati hozzáférési jogokat. Az .rhosts fájl tartalmazza a távoli számítógéphez elérési engedéllyel rendelkező számítógépek nevét és a hozzájuk társított bejelentkezési neveket. A távoli rendszer számára helyesen beállított .rhosts fájl esetén az rcp, rexec vagy rsh parancsok kiadásakor, nem szükséges bejelentkezési és jelszó adatokat megadni a távoli számítógépnek.

Az .rhosts fájl egy szövegfájl, amelyben minden egyes sor egy bejegyzés. Egy bejegyzés tartalmazza a helyi számítógép nevét, a helyi felhasználói nevet és a bejegyzéssel kapcsolatos megjegyzéseket. A bejegyzéseket tabulátorral vagy szóközzel kell elválasztani, és a megjegyzések kettős kereszttel (#) kezdődnek:

számítógép5mária#Ez a számítógép a 31A irodában van

Az .rhosts fájlnak a felhasználó kezdőkönyvtárában kell lennie a távoli számítógépen. A távoli számítógépen megvalósított .rhosts fájllal kapcsolatos további tudnivalókért tanulmányozza a távoli rendszer dokumentációját.


Runas

Lehetővé teszi egy felhasználó számára, hogy a felhasználó aktuális bejelentkezéséhez tartozó jogosultságoktól eltérő jogosultságokkal futtasson egy eszközt vagy programot. Ajánlott gyakorlat a rendszergazdák számára, hogy a rutin, nem rendszergazdai feladatokat egy korlátozott jogosultságokkal rendelkező fiókon keresztül hajtsa végre, és a szélesebb jogosultsággal rendelkező fiókot csak kimondott rendszergazdai feladatok végrehajtására használja. Ennek ki- és bejelentkezés nélküli végrehajtásához jelentkezzen be egy normál felhasználói fiókba, és a szélesebb körű jogosultságokat igénylő eszközök futtatásához használja a runas parancsot.

runas [/profile] [/env] [/netonly] /user:Felhasználói_fiók_neve program

Paraméterek

/profile

Megadja a felhasználói profil nevét, ha azt be kell tölteni.

/env

Megadja, hogy az aktuális hálózati környezetet használja a parancs a felhasználó helyi környezete helyett.

/netonly

Jelzi, hogy a megadott felhasználói információ csak távoli eléréshez használható.

/user:Felhasználói_fiók_neve

Megadja annak a felhasználói fióknak a nevét, amelyen az adott programot futtatja a parancs. A felhasználói fiók megadása a következő formában lehetséges: felhasználó@tartomány vagy tartomány\felhasználó.

program

Megadja a /user paraméterrel megadott fiók használatával futtatandó programot vagy parancsot. A runas parancs más Windows 2000 parancsok elindítására való használatát bemutató példákért nézze meg a Kapcsolódó témaköröket.


Példák a Runas parancs használatára

Runas

Példák

A Windows 2000 parancssor a helyi számítógép rendszergazdájaként történő elindításához írja be a következő parancsot:

runas /user:helyi_számítógép_neve \rendszergazda cmd

A megjelenő kérdésre írja be a rendszergazda jelszavát.

A cégtartomány\tartományi_rendszergazda nevű tartományi rendszergazda fiókjának segítségével a következő paranccsal indítható el a Számítógép-kezelés beépülő modul:

runas /user:cégtartomány\tartományi_rendszergazda "mmc %windir%\system32\compmgmt.msc"

A megjelenő kérdésre írja be a rendszergazda jelszavát.

A Jegyzettömb segédprogram a user nevű tartományi rendszergazda fiókjával a tartomany.microsoft.com tartományban történő elindításához írja be a következő parancsot:

runas /user:user@tartomany.microsoft.com "notepad sajat_fájl.txt"

A megjelenő kérdésre írja be a rendszergazda jelszavát.

Egy másik erdőben lévő kiszolgálót felügyelő parancssori ablak, elmentett MMC-konzol, Vezérlőpult-elem vagy program elindításához írja be a következő parancsot:

runas /netonly /user:tartomány\felhasználónév "parancs"

tartomány\felhasználónév paraméternek olyan felhasználónak kell lennie, akinek a kiszolgáló felügyeletéhez megfelelő engedélyei vannak. A megjelenő kérdésre írja be a rendszergazda jelszavát.


Megjegyzések a Runas parancshoz

Runas

Megjegyzések

  • A runas parancs nemcsak a rendszergazda fiókkal használható, bár az a leggyakoribb. Minden több fiókkal rendelkező felhasználó használhatja a runas parancsot program, MMC-konzol vagy a Vezérlőpult valamelyik elemének más hitelesítő adatokkal való futtatására.
  • Ha a Rendszergazda fiókot a saját számítógépén szeretné használni, akkor a /user: paraméterként az alábbiakat kell megadnia: /user:Rendszergazda_fiókneve@Számítógépnév vagy /user:Számítógépnév\Rendszergazda_fiókneve.

    • Ha ezt a parancsot a tartomány rendszergazdájaként kívánja használni, akkor az alábbiakat adja meg:/user:Rendszergazda_fiókneve@Tartománynév vagy /user:Tartománynév\Rendszergazda_fiókneve.

  • A runas parancs lehetővé teszi programok (*.exe), elmentett MMC-konzolok (*.msc), programok parancsikonjának és a Vezérlőpult elemeinek futtatását. Ezek rendszergazdaként futtathatók, miközben a számítógépre másik csoport, például a Felhasználók vagy a Kiemelt felhasználók tagjaként jelentkezett be.
  • A runas paranccsal bármely program, MMC-konzol vagy Vezérlőpult-elem elindítható. Amennyiben megfelelően adja meg a felhasználói fiókkal és jelszóval kapcsolatos adatokat, a felhasználói fiók használatával bejelentkezhet a számítógépre, és a program, MMC-konzol vagy Vezérlőpult-elem rendelkezésre áll a rendszeren a felhasználói fiók számára.
  • A runas parancs lehetővé teszi, hogy a kiszolgálót egy másik erdőből felügyelje (azaz a gép, amelyről a parancsot futtatja, és a felügyelt kiszolgáló különböző tartományban található).
  • Ha hálózati helyről próbálja meg a programot, MMC-konzolt vagy a Vezérlőpult elemét elindítani a Futtatás mint segítségével, a próbálkozás sikertelen lehet, mivel a hálózati kapcsolódáshoz használt hitelesítő adatok nem egyeznek a program indításához használt hitelesítő adatokkal. Előfordulhat, hogy a későbbi hitelesítő adatok nem képesek ugyanazt a hálózati megosztást elérni.
  • Néhány elemet, mint például a Windows Intézőt, a Nyomtatók mappát és az Asztal elemeit a Windows 2000 közvetve nyitja meg. Ezek az elemek nem indíthatók a runas parancs használatával.
  • Ha a runas parancs futása sikertelen, akkor előfordulhat, hogy a RunAs szolgáltatás nem fut, vagy a használt felhasználói fiók nem érvényes. A Runas szolgáltatás állapotának ellenőrzéséhez a Számítógép-kezelés beépülő modulban kattintson a Szolgáltatások és Alkalmazások, majd a Szolgáltatások elemre. A felhasználói fiók ellenőrzéséhez próbáljon meg bejelentkezni a megfelelő tartományra a fiók használatával.


Fürtparancsok – áttekintés

A fürtparancsok segítségével a Windows 2000 parancssorból felügyelhetők a kiszolgálófürtök. A Cluster.exe program parancsfájlokból történő meghívásával a fürtfelügyelet sok feladatát lehet automatizálni. A Cluster.exe program minden Windows 2000 rendszerű számítógépen megtalálható.

A Cluster.exe program segítségével a fürtök felügyelhetők egy csomópontról, más fürtök csomópontjairól vagy más Windows NT 4.0-s 3-as vagy újabb szervizcsomaggal rendelkező számítógépről.

A parancsok parancssorból történő kiadására a következő szabályok érvényesek:

  • A szóközöket és különleges karaktereket tartalmazó neveket idézőjelbe kell tenni. Példák a különleges karakterekre: mínuszjel (-), perjel (/), idézőjelek ("), kettőspont (:), vessző (,) és egyenlőségjel (=). További példák a Kapcsolódó témakörök között a fürtparancsokra kattintva láthatók.
  • Tulajdonságok igaz vagy hamis beállításakor az 1 (egy) igazat jelent, a 0 (nulla) hamisat jelent.
  • Fürtnév beírásakor a pont (.) a helyi fürtre vonatkozik.
  • Egy parancssorban több beállítás is megadható. A Cluster.exe program balról jobbra dolgozza fel a beállításokat. Ha egy beállítás sikertelen, a parancs végrehajtása leáll a hibás beállításnál.
  • Két egymást követő idézőjel előfordulása esetén használjon dupla idézőjeleket (""). A következő példa dupla idézőjeleket mutat egy karakterláncban:

    cluster resource AResource /priv aProp="a """

Ez a témakör a fürtparancsokat, a parancsok rövidítéseit, és a tulajdonságok listáját írja le:

  • Cluster
  • Cluster node
  • Cluster group
  • Cluster network
  • Cluster netinterface
  • Cluster resource
  • Cluster resourcetype
  • A fürtparancsok rövidítései
  • Tulajdonságlisták


Cluster

A cluster parancs alapszintaxisa a következő:

cluster [[/cluster:]fürt neve] /beállítás

A fürt nevét nem kötelező megadni. Ha nincs megadva fürt, a Cluster.exe program megpróbál ahhoz a fürthöz csatlakozni, amely azon a csomóponton fut, amelyen a Cluster.exe program fut.

Ha nincs beállítás megadva, az alapértelmezett beállítás a /help beállítás.

Ha a fürt neve egyben egy fürtparancs is, vagy annak rövidítése (például: cluster vagy c), használja a /cluster: paramétert a fürt nevének pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

A következő táblázat az elérhető fürtbeállításokról ad felvilágosítást:

Beállítás | Funkciója
/rename:fürt neve | Átnevezi a fürtöt.
/version | Megjeleníti a Fürtszolgáltatás verziószámát.
/quorum[resource][:erőforrás] [/path:elérési út] [/maxlogsize:maximális méret kilobájtokban] | Megváltoztatja a quorum erőforrás nevét vagy helyét, vagy a quorum napló méretét.
/reg[admin]ext:felügyelet_kibővítő_dll [,felügyelet_kibővítő_dll...] | Egy Fürtrendszergazda bővítmény DLL-t jegyez be a fürthöz.
/unreg[admin]ext:felügyelet_kibővítő_dll [,felügyelet_kibővítő_dll...] | Egy Fürtrendszergazda bővítmény DLL fürthöz való bejegyzését törli.
/list:[tartománynév] | Megjeleníti a számítógép tartományában vagy egy adott tartományban lévő fürtök listáját. Ne használja a fürt nevét ezzel a beállítással.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja a fürt általános tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja a fürt saját tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/? vagy /help | Megjeleníti a cluster parancs szintaxisát.

Például a Furt nevű fürt átnevezéséhez Furt1-re írja be a következő parancsot a Windows 2000 parancssorba:

cluster furt /rename:furt1

A cluster parancs általános tulajdonságnevei

A következő táblázatban az általános cluster tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Általános tulajdonságnevek | Használat
AdminExtensions | A fürtobjektum Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
DefaultNetworkRole | Megadja a hálózatokhoz rendelendő alapértelmezett szerepkört.
Leírás | Megadja a fürt felügyeleti leírását.
Security | Leírja a Windows 2000 kompatibilis biztonsági leírót.
SecurityDescriptor | Leírja a Windows NT-SP4 és a Windows 2000 kompatíbilis biztonsági leírót.
Groups\AdminExtensions | A csoportok Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
NetInterfaces\AdminExtensions | A hálózati illesztők Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
Networks\AdminExtensions | A hálózatok Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
Nodes\AdminExtensions | A csomópontok Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
Resources\AdminExtensions | Az erőforrások Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
ResourceTypes\AdminExtensions | Az erőforrástípusok Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID) írja le.
EnableEventLogReplication | Megadja, hogy az eseménynapló replikációja engedélyezett-e vagy tiltott a fürtökben. (Igaz (1) - engedélyezve; Hamis (0) - tiltott.)

Fürt saját tulajdonságneve

Alapértelmezés szerint a cluster parancsnak nincsen saját tulajdonsága. A fürtfunkciók kibővítése érdekében a szállítók hozzáadhatnak saját tulajdonságokat.


Cluster node

A cluster node parancs alapszintaxisa a következő:

cluster [[/cluster:]fürt neve] node csomópont neve /beállítás

A fürt nevét nem kötelező megadni. Ha nincs csomópontnév és nincs beállítás megadva, az alapértelmezett beállítás a /status.

Ha a fürt neve egyben egy fürtparancs is vagy annak rövidítése (például: node), használja a /cluster: paramétert a fürt nevének pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

A következő táblázat az elérhető cluster node beállításokról ad felvilágosítást:

Beállítás | Funkciója
/status | Megjeleníti a fürtcsomópont állapotát (bekapcsolva, kikapcsolva, felfüggesztve). A csomópont nevét nem kötelező megadni. Ha nincs megadva csomópontnév, a parancs az összes csomópont állapotát megjeleníti.
/pause | Felfüggeszt egy csomópontot.
/resume | Újraindítja a felfüggesztett csomópontot.
/evict | Eltávolít egy csomópontot a fürtből.
/listinterfaces | Felsorolja a csomópont hálózati illesztőfelületeit.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja a csomópont általános tulajdonságait. A csomópont nevét nem kötelező megadni. Ha a csomópontnév nincs megadva, a parancs megjeleníti az összes csomópont tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja a csomópont saját tulajdonságait. A csomópont nevét nem kötelező megadni. Ha a csomópontnév nincs megadva, a parancs megjeleníti az összes csomópont saját tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/? vagy /help | Megjeleníti a cluster node parancs szintaxisát.

Egy CsomoPont1 nevű csomópont állapotának megjelenítéséhez írja be a következő parancsot a Windows 2000 parancssorba:

cluster node csomopont1 /status

A Cluster node általános tulajdonságnevei

A következő táblázatban az általános cluster node tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Általános tulajdonságnevek | Használat
Description | Leír egy csomópontot.
EventEnableLogReplication | Megadja, hogy az eseménynapló replikációja engedélyezett-e vagy tiltott a csomóponton. (Igaz (1) - engedélyezve; Hamis (0) - tiltott.) Ha a fürt eseménynaplójának replikációja tiltott, a tulajdonság beállításaitól függetlenül az eseménynapló replikációja a csomóponton tiltott.

A Cluster node saját tulajdonságneve

Alapértelmezés szerint a cluster node parancsnak nincsen saját tulajdonsága. A fürtfunkciók kibővítése érdekében a szállítók hozzáadhatnak saját tulajdonságokat.


Cluster group

A cluster group parancs alapszintaxisa a következő:

cluster [[/cluster:]fürt_neve] group csoportnév /beállítás

A fürt nevét nem kötelező megadni. Ha nincs beállítás megadva, az alapértelmezett beállítás a /status beállítás.

Ha a fürt neve egyben egy fürtparancs is vagy annak rövidítése (például: cluster vagy c), használja a /cluster: paramétert a fürt pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

A /moveto, /online és /offline kapcsolókkal a /wait[:időtúllépés másodpercekben] beállítás azt adja meg, hogy a Cluster.exe parancs milyen hosszan vár, mielőtt leállítaná a parancs futását, ha az nem fejeződik be sikeresen. Ha az időtúllépés nincs megadva, a Cluster.exe határozatlan ideig, vagy a csoport állapotának megváltozásáig várakozik.

A következő táblázat az elérhető cluster group beállításokról ad felvilágosítást:

Beállítás | Funkciója
/status | Megjeleníti a csoport állapotát (Online, Offline, vagy Részlegesen Online). A csoport nevét nem kötelező megadni. Ha a csoportnév nincs megadva, a parancs megjeleníti az összes csoport állapotát.
/create | Új csoportot hoz létre.
/delete | Törli a csoportot.
/rename: új csoportnév | Átnevezi a csoportot.
/move[to] [:csomópontnév] [/wait [:időtúllépés másodpercekben]] | Áthelyezi a csoportot egy másik csomópontra.
/online [:csomópontnév] [/wait [:időtúllépés másodpercekben]] | Online állapotba állítja a csoportot.
/offline[:csomópontnév] [/wait [:időtúllépés másodpercekben]] | Kapcsolat nélküli állapotba állít egy csoportot.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja a csoport általános tulajdonságait. A csoport nevét nem kötelező megadni. Ha a csoportnév nincs megadva, a parancs megjeleníti az összes csoport tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja a csoport saját tulajdonságait. A csoport nevét nem kötelező megadni. Ha a csoportnév nincs megadva, a parancs megjeleníti az összes csoport saját tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/listowners | Megjeleníti az elsődleges tulajdonosok listáját.
/setowners:csomópontnév[,csomópontnév...] | Megad egy elsődleges tulajdonost.
/? vagy /help | Megjeleníti a cluster group parancs szintaxisát.

Például a Furt1 fürtön található LemezCsoport 1 nevű csoport áthelyezéséhez a Csomopont1-ről a Csomopont2-re írja be a következő parancsot a Windows 2000 parancssorba:

cluster furt1 group "lemezcsoport 1" /moveto:csomopont2

A Cluster group parancs általános tulajdonságnevei

A következő táblázatban az általános cluster group tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Általános tulajdonságnevek | Használat
Név | A fürtcsoport objektum neve.
Description | Egy csoportot ír le.
PersistentState | Leírja a csoport utoljára ismert állandó állapotát (1 (igaz) - online; 0 (hamis) - kapcsolat nélkül).
FailoverThreshold | Megadja annak a számát, ahányszor a Fürtszolgáltatás megkísérli a csoport feladatát átvenni, mielőtt megállapítaná, hogy a csoportot nem lehet online állapotba hozni sehol a fürtön belül.
FailoverPeriod | Megadja azt az időtartamot (órákban), amíg a Cluster szolgáltatás megpróbálja a csoport feladatát átvenni.
AutoFailbackType | Állítsa be a ClusterGroupPreventFailback (0) beállítást a visszaállás megelőzése érdekében. A visszaállás engedélyezéséhez állítsa be a következőt: ClusterGroupAllowFailback (1).
FailbackWindowStart | Megadja a csoport elsődleges csomópontjára történő visszaállás kezdeti időpontját (24 órás formátumban). Ezeknek az értékeknek 0 (éjfél) és 23 (este 11 óra) között kell lennie helyi idő szerint. Azonnali visszaálláshoz állítsa be a -1 értéket.
FailbackWindowEnd | Megadja a csoport elsődleges csomópontjára történő visszaállás befejezésének időpontját (24 órás formátumban). Ezeknek az értékeknek 0 (éjfél) és 23 (este 11 óra) között kell lennie helyi idő szerint. Azonnali visszaálláshoz állítsa be a -1 értéket.

A Cluster group parancs saját tulajdonságneve

Alapértelmezetten a cluster group parancsnak nincsen saját tulajdonsága. A fürtfunkciók kibővítése érdekében a szállítók hozzáadhatnak saját tulajdonságokat.


Cluster resource

A cluster resource parancs alapszintaxisa a következő:

cluster [[/cluster:]fürt_neve] resourceerőforrásnév /beállítás

A fürt nevét nem kötelező megadni. Ha nincs beállítás megadva, az alapértelmezett beállítás a /status beállítás.

Ha a fürt neve egyben egy fürtparancs is vagy annak rövidítése (például: cluster vagy c), használja a /cluster: paramétert a fürt pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

Az /online és /offline kapcsolókkal a /wait[:időtúllépés másodpercekben] beállítás azt adja meg, hogy a Cluster.exe parancs milyen hosszan vár, mielőtt leállítaná a parancs futását, ha az nem fejeződik be sikeresen. Ha az időtúllépés nincs megadva, a Cluster.exe határozatlan ideig, vagy az erőforrás állapotának megváltozásáig várakozik.

A következő táblázat a rendelkezésre álló cluster resource beállításokról ad felvilágosítást:

Beállítás | Funkciója
/status | Megjeleníti a fürterőforrás állapotát (Online, Kapcsolat nélküli, vagy Sikertelen). Az erőforrás nevét nem kötelező megadni. Ha az erőforrás neve nincs megadva, a parancs az összes fürterőforrás állapotát megjeleníti.
/create /group: csoportnév /type: erőforrástípus [/separate] | Új erőforrást hoz létre a megadott csoportban. A /separate beállítás használatával megadható, hogy az erőforrás egy külön Erőforrásfigyelőben fusson.
/delete | Töröl egy erőforrást.
/rename: új erőforrásnév | Átnevez egy erőforrást.
/addowner:csomópontnév | Hozzáad egy csomópontot a lehetséges tulajdonosok listájához.
/removeowner:csomópontnév | Eltávolít egy csomópontnevet a lehetséges tulajdonosok listájából.
/listowners | Megjeleníti a lehetséges tulajdonosok listáját.
/moveto:csoport | Áthelyezi az erőforrást egy másik csoportba.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja az erőforrás általános tulajdonságait. Az erőforrás nevét nem kötelező megadni. Ha az erőforrás neve nincs megadva, a parancs megjeleníti az összes erőforrás tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja az erőforrás saját tulajdonságait. Az erőforrás nevét nem kötelező megadni. Ha az erőforrás neve nincs megadva, a parancs megjeleníti az összes erőforrás tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/fail | Erőforráshibát kezdeményez.
/online [/wait[:időtúllépés másodpercekben]] | Online állapotba állítja az erőforrást.
/offline [/wait[:időtúllépés másodpercekben]] | Kapcsolat nélküli állapotba állítja az erőforrást.
/listdependencies | Felsorolja egy erőforrás függőségeit.
/adddependency: erőforrás | Hozzáad egy függőséget az erőforráshoz.
/removedependency:erőforrás | Eltávolít egy függőséget az erőforrásból.
/addcheckpoints:kulcs[\alkulcs...][,kulcs[\alkulcs...]...] | Hozzáad egy rendszerleíró adatbázis ellenőrzőpontot az erőforráshoz.
/removecheckpoints:kulcs[\alkulcs...][,kulcs[\alkulcs...]...] | Eltávolít egy rendszerleíró adatbázis ellenőrzőpontot az erőforrásból.
/checkpoints | Felsorolja az erőforrás rendszerleíró adatbázis ellenőrzőpontjait. Az erőforrás nevét nem kötelező megadni. Ha az erőforrás neve nincs megadva, a parancs megjeleníti az összes fürterőforrás ellenőrzőpontjait.
/addcryptocheckpoints:kulcs[\alkulcs...][,kulcs[\alkulcs...]...] | Hozzáad egy titkosítási kulcs ellenőrzőpontot az erőforráshoz.
/removecryptocheckpoints:kulcs[\alkulcs...][,kulcs[\alkulcs...]...] | Eltávolít egy titkosítási kulcs ellenőrzőpontot az erőforrásból.
/cryptocheckpoints | Felsorolja egy erőforrás titkosítási kulcs ellenőrzőpontjait. Az erőforrás nevét nem kötelező megadni. Ha az erőforrás neve nincs megadva, a parancs az összes fürterőforrás ellenőrzőpontjait megjeleníti.
/? vagy /help | Megjeleníti a cluster resource parancs szintaxisát.

Például egy Nyomtatási várólista erőforrás létrehozásához az Ops Print Spoolers csoportban írja be a következő parancsot a Windows 2000 parancssorba:

cluster resource /create /group:"Ops Print Spoolers" /Type:"print spooler"

A Cluster resource parancs tulajdonságnevei

A következő táblázatban az általános cluster resource tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Általános tulajdonságnevek | Használat
Név | A fürterőforrás objektum neve.
Description | Az erőforrás leírása
Type | Megadja az erőforrástípust.
DebugPrefix | Megadja az erőforrásnak megfelelő hibakeresőt. További információért lásd a Microsoft Platform Software Development Kit csomagot.
SeparateMonitor | Megadja, hogy az erőforrás megosztja-e az Erőforrásfigyelőt. Az érvényes értékek: igaz (1) és hamis (0).
PersistentState | Megjeleníti az erőforrás utoljára ismert állandó állapotát. Az erőforrás PersistentState tulajdonságának elmentéséhez az erőforrásnak kapcsolat nélküli állapotban kell lennie.
LooksAlivePollInterval | Megadja a javasolt időtartamot ezredmásodpercekben, amennyi ideig a Fürtszolgáltatás az adott erőforrást vizsgálja, hogy az működik-e. Ha ez az érték nincs megadva, az alapértelmezett érték az erőforrástípus LooksAlivePollInterval tulajdonságának értéke.
IsAlivePollInterval | Megadja azt az időtartamot ezredmásodpercekben, amennyi ideig a Fürtszolgáltatás az adott erőforrást vizsgálja, hogy az működik-e. Ha ez az érték nincs megadva, az alapértelmezett érték az erőforrástípus IsAlivePollInterval tulajdonságának értéke. Az IsAlivePollInterval érték nem lehet nulla.
RestartAction Megadja az erőforrás hibája esetén végrehajtandó műveletet. A lehetőségek a következők:

ClusterResourceDontRestart (0): Hiba után ne induljon újra.

ClusterResourceRestartNoNotify (1): Ha az erőforrás túllépi az újraindítási küszöböt az újraindítási időszak alatt, a Fürtszolgáltatás nem próbálja meg áttéríteni a csoportot másik csomópontra.

ClusterResourceRestartNotify (2): Ha az erőforrás túllépi az újraindítási küszöböt az újraindítási időszak alatt, a Fürtszolgáltatás megpróbálja áttéríteni a csoportot egy másik csomópontra.

Ha nincs érték megadva, az alapértelmezett érték lehetővé teszi az erőforrás számára, hogy hatással legyen a csoportra, és így a csoportot a rendszer másik rendszerre téríthesse át.
RestartThreshold | Megadja, hogy a Fürtszolgáltatás hányszor próbálja meg újraindítani az erőforrást a RestartPeriod időtartam alatt, mielőtt a csoportot áttéríti.
RestartPeriod | Megadja, hogy mennyi ideig próbálhatja a Fürtszolgáltatás újraindítani az erőforrást a RestartThreshold eléréséhez, mielőtt a szolgáltatás áttéríti a csoportot.
PendingTimeout Az az időtartam, amely alatt egy folyamatban lévő online vagy folyamatban lévő kapcsolat nélküli állapotú erőforrásnak meg kell határoznia az állapotát, mielőtt a Fürtszolgáltatás kapcsolat nélküli vagy hibás állapotba állítja az erőforrást.

Az alapértelmezett érték 3 perc.

A Cluster resource parancs saját tulajdonságneve

Néhány erőforrás saját tulajdonságokat tárol. Például az L: meghajtóerőforrás lemezaláírásának megjelenítéséhez írja be a következő parancsot a Windows 2000 parancssorba:

cluster resource "disk l:" /priv


Cluster resourcetype

A cluster resourcetype parancs alapszintaxisa:

cluster [[/cluster:]fürt neve] resourcetype erőforrástípus megjelenítendő neve /beállítás

A fürt nevét nem kötelező megadni. Ha nincs beállítás megadva, az alapértelmezett beállítás a /list.

Ha a fürt neve egyben egy fürtparancs is vagy, annak rövidítése (például: cluster vagy c), használja a /cluster: paramétert a fürt nevének pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

A következő táblázat a rendelkezésre álló cluster resource beállításokról ad felvilágosítást:

Beállítás | Funkciója
/list | Felsorolja az elérhető telepített fürt erőforrástípust. Az erőforrástípus megjelenítendő nevét nem kötelező megadni. Ha az erőforrástípus megjelenítendő neve nincs megadva, a parancs megjeleníti az összes telepített erőforrástípust.
/listowners | Megjeleníti az elsődleges tulajdonosok listáját.
/create /DllName:dll_név [/type:típusnév] [/IsAlive: időköz_ezredmásodpercben] [/LooksAlive:időköz_ezredmásodpercben] | Erőforrástípust hoz létre.
/delete [/type] | Töröl egy erőforrástípust. Ha az erőforrás DLL nem elérhető a fürtszolgáltatás számára, az erőforrástípus megjelenítendő nevének megadása helyett adja meg az erőforrástípus megjelenítendő nevét a /type beállítással.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja az erőforrástípus általános tulajdonságait. Az erőforrástípus megjelenítendő nevét nem kötelező megadni. Ha az erőforrástípus megjelenítendő neve nincs megadva, a parancs megjeleníti az összes erőforrástípus tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja az erőforrástípus saját tulajdonságait. Az erőforrástípus megjelenítendő nevét nem kötelező megadni. Ha az erőforrástípus megjelenítendő neve nincs megadva, a parancs megjeleníti az összes erőforrástípus saját tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/? vagy /help | Megjeleníti a cluster resourcetype parancs szintaxisát.

Például a Furt1 fürtön található Általános alkalmazás erőforrástípus tulajdonságainak megjelenítéséhez írja be a következő parancsot a Windows 2000 parancssorba:

cluster furt1 resourcetype "általános alkalmazás" /properties

A Cluster resourcetype parancs általános tulajdonságnevei

A következő táblázatban az általános cluster resourcetype tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Általános tulajdonságnevek | Használat
Name | Megváltoztatja az erőforrástípus megjelenítendő nevét.
Description | Megváltoztatja az erőforrástípus leírását.
DllName | Megadja a dinamikus csatolású könyvtár (DLL) nevét az adott erőforrástípushoz.
DebugPrefix | Megadja a megfelelő Hibakeresőt az erőforrástípushoz. További információért lásd a Microsoft Platform Software Development Kit csomagot.
DebugControlFunctions | Megadja, hogy a hibakereső töréspontja az erőforrás vezérlőfunkciójához van-e beállítva. (Igaz (1) - beállítva; Hamis (0) - nincs beállítva.)
AdminExtensions | Leírja a Fürtrendszergazda bővítésének egy vagy több osztályazonosítóját (CLSID).
LooksAlivePollInterval | Megadja azt az időtartamot ezredmásodpercekben, ameddig a Fürtszolgáltatás az adott erőforrástípus erőforrásait vizsgálja, hogy azok működésre utaló jeleket adnak-e.
IsAlivePollInterval | Megadja azt az időtartamot ezredmásodpercekben, amennyi ideig a Fürtszolgáltatás az adott erőforrástípus erőforrásait vizsgálja, hogy azok működnek-e.

A Cluster resourcetype parancs saját tulajdonságnevei

Alapértelmezés szerint a cluster resourcetype parancsnak nincsen saját tulajdonsága. A fürtfunkciók kibővítése érdekében a szállítók hozzáadhatnak saját tulajdonságokat.


A fürtparancsok rövidítései

A következő táblázat felsorolja a Cluster.exe által támogatott kulcsszórövidítéseket.

Kulcsszó | Támogatott rövidítések
addcheckpoints | addchk, addcheck, addchkpoints
addcryptocheckpoints | addcryptochk, addcryptocheck, addcryptochkpoints
adddependency | adddep
checkpoints | chk, check, chkpoints
cluster | c
cryptocheckpoints | cryptochk, cryptocheck, cryptochkpoints
delete | del
dllname | dll
expandstring | expandstr
help | ?
listdependencies | listdep
listinterfaces | listint, listinterface
moveto | move
multistring | multistr
network | net
networkinterface | netint
offline | off
online | on
privproperties | priv, privprop, privprops
properties | prop, props
quorumresource | quorum
removecheckpoints | removechk, removecheck, removechkpoints
removecryptocheckpoints | removecryptochk, removecryptocheck, removecryptochkpoints
removedependency | removedep
removeowner | remowner
rename | ren
resource | res
resourcegroup | resgroup, group
resourcetype | restype, type
status | stat, state
string | str
version | ver


Cluster network

A cluster network parancs alapszintaxisa a következő:

cluster [[/cluster:]fürt_neve] network hálózati név /beállítás

A fürt nevét nem kötelező megadni. Ha nincs beállítás megadva, az alapértelmezett a /status beállítás.

Ha a fürt neve egyben egy fürtparancs is, vagy annak rövidítése (például: cluster vagy c), használja a /cluster: paramétert a fürt pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

A következő táblázat az elérhető cluster network beállításokról ad felvilágosítást:

Beállítás | Funkciója
/status | Megadja a fürthálózat állapotát. A hálózatnevet nem kötelező megadni. Ha a hálózatnév nincs megadva, a parancs az összes fürthálózat állapotát megjeleníti.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja a hálózat általános tulajdonságait. A hálózatnevet nem kötelező megadni. Ha a hálózatnév nincs megadva, a parancs az összes hálózat tulajdonságait megjeleníti. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja a hálózat saját tulajdonságait. A hálózatnevet nem kötelező megadni. Ha a hálózatnév nincs megadva, a parancs az összes hálózat saját tulajdonságait megjeleníti. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/rename:új név | Átnevezi a hálózatot
/listinterfaces | A hálózathoz hozzárendelt hálózati illesztőfelületeket sorolja fel.
/? vagy /help | Megjeleníti a cluster network parancs szintaxisát.

A Cluster network parancs általános tulajdonságnevei

A következő táblázatban az általános cluster netinterface tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Tulajdonságnév | Használat
Name | A hálózat neve. A fürt ugyanazt a nevet használja, mint a Hálózati és telefonos kapcsolatok mappa. További információért tanulmányozza a Nevek egyeztetése a Fürtszolgáltatás és a Hálózati és telefonos kapcsolatok között témakört.
Address | Megadja a teljes hálózat vagy alhálózat címét.
AddressMask | A hálózat alhálózati maszkja.
Description | A hálózat leírása.
Role | A hálózat kommunikációs szerepköre. A hálózati funkciókkal kapcsolatos további tudnivalókért tanulmányozza a Hálózatok témakört.

A Cluster network parancs saját tulajdonságai

Alapértelmezés szerint a cluster network parancsnak nincsen saját tulajdonsága. A fürtfunkciók kibővítése érdekében a szállítók hozzáadhatnak saját tulajdonságokat.


Cluster netinterface

A cluster netinterface parancs alapszintaxisa a következő:

cluster [[/cluster:]fürt neve] netinterface /node: csomópontnév /network: hálózati név /beállítás

A fürt nevét nem kötelező megadni. Ha nincs beállítás megadva, az alapértelmezett a /status beállítás.

Ha a fürt neve egyben egy fürtparancs is, vagy annak rövidítése (például: cluster vagy c), használja a /cluster: paramétert a fürt pontos megadásához. A fürtparancsok listája megtalálható a Kapcsolódó témakörök között.

A következő táblázat az elérhető cluster netinterface beállításokról ad felvilágosítást:

Beállítás | Funkciója
/status | Megadja a fürt hálózati kártyájának állapotát. A hálózatnevet és a csomópontnevet nem kötelező megadni. Ha a hálózatnév és a csomópontnév nincs megadva, a parancs a fürt összes hálózati kártyájának állapotát megjeleníti.
/properties [tulajdonságlista] | Megjeleníti vagy beállítja a hálózati kártya általános tulajdonságait. A hálózatnevet és a csomópontnevet nem kötelező megadni. Ha a hálózatnév és a csomópontnév nincs megadva, a parancs megjeleníti az összes hálózati kártya saját tulajdonságait. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/privproperties [tulajdonságlista] | Megjeleníti vagy beállítja a hálózati kártya saját tulajdonságait. A hálózatnevet és a csomópontnevet nem kötelező megadni. Ha a hálózatnév és a csomópontnév nincs megadva, a parancs a fürt összes hálózati kártyájának saját tulajdonságait megjeleníti. A tulajdonságlistákkal kapcsolatos további tudnivalókért tanulmányozza a Tulajdonságlisták témakört.
/? vagy /help | Megjeleníti a cluster netinterface parancs szintaxisát.

A Cluster netinterface parancs általános tulajdonságai

A következő táblázatban az általános cluster netinterface tulajdonságnevek, azok használata és érvényes beállításai láthatók:

Név | Használat
Adapter | Egyedileg azonosítja a kártyát a fürtön belül.
AdapterID | A fürtben lévő kártya globálisan egyedi azonosítója (GUID).
Address | A hálózati kártya által használt elsődleges hálózati cím.
Description | A hálózati kártya választható leírása.
Név | A fürtben található hálózati kártya objektumneve.
Network | Annak a hálózatnak a neve, amelyhez a hálózati kártya csatlakozik.
Node | Annak a csomópontnak a neve, amelyen a hálózati kártya telepítve van.

A Cluster netinterface parancs saját tulajdonságai

Alapértelmezés szerint a cluster netinterface parancsnak nincs saját tulajdonsága. A fürtfunkciók kibővítése érdekében a szállítók hozzáadhatnak saját tulajdonságokat.


Tulajdonságlisták

A Cluster.exe parancs tulajdonságlistája a következő módokon adható meg:

1. név=érték[,érték...][:formátum][név=érték[,érték...][:formátum]...]

Például:

cluster furt node csomopont /priv tul1=karl1,karl2:multistring tul2=0xa,0xb:binary

2. :tulajdonságnév1[,tulajdonságnév2,...]/usedefault

Például:

cluster furt node csomopont /priv:tul1,tul2 /usedefault

Egy általános tulajdonság alapértelmezett értékének visszaállításához, vagy egy saját tulajdonság törléséhez használja a /usedefault beállítást.

A következő táblázat a használható formátumbeállításokat mutatja:

Formátum | Leírás | Példa
Binary | 0 és 255 közötti különálló értékek. | myBinary = 12,0xab,255:binary
DWord | Duplaszó | dszo=2346:dword
String | A szóközöket tartalmazó karakterláncokat idézőjelek közé kell tenni. | karlanc=”karakterlánc értéke”:string
ExpandString | A Cluster.exe által kibontott. | kiBontottKarL=^%windir^%:expandstr
MultiString | Karakterláncok vesszővel elválasztott listája | MultiKarL=”karakterlánc érték 1”, ”karakterlánc érték 2”:multistr
Security | Beállítja a hozzáférési jogosultságokat. A hozzáférési típusok a következők: grant (megad), deny (megtagad), set (beállít) és revoke (visszavon). A grant, deny és set típusok esetén hozzáférési maszk megadása szükséges. A hozzáférési maszkok: R olvasási jog esetén, C módosítási jog esetén, F teljes jogosultság esetén. | Biztonsag= devgroup \ felhaszn1, grant, RC, devgroup \ felhaszn2, revoke, everyone, set, F:security
ULarge | Aláíratlan 64 bites érték | ULarge = 12345678901234567890:ularge


Set

Megjeleníti, beállítja vagy törli a Windows 2000 környezeti változóit.

A környezeti változók a parancsfájlok és programok működését befolyásolják, illetve a Windows 2000 és az MS-DOS alrendszer megjelenését és működését határozzák meg. A set parancsot leggyakrabban az Autoexec.nt fájlban használják a környezeti változók beállítására.

set [változó=[karakterlánc]]

Paraméterek

nincs

A set parancs paraméter nélküli kiadása esetén a jelenlegi környezeti beállítások jelennek meg.

változó

Megadja a beállítani kívánt változót.

karakterlánc

Megadja a változóhoz hozzárendelni kívánt karakterláncot.


Példák a Set parancs használatára

Set

Példák

Az INCLUDE nevű környezeti változó a következő parancs hatására a C:\Inc (az \Inc könyvtár a C: meghajtón) karakterlánc értékét kapja:

set include=c:\inc

Ezután a parancsfájlokban a C:\Inc karakterláncra két százalékjel (%) között az INCLUDE szóval lehet hivatkozni. Például az INCLUDE környezeti változóhoz társított könyvtár tartalmának megjelenítéséhez a következő parancsot lehet beírni egy parancsfájlba:

dir %include%

Amikor a Windows 2000 végrehajtja ezt a parancsot, a C:\Inc karakterláncot behelyettesíti az %include% változó helyére.

A set parancs használatára másik példa, amikor egy parancsfájlban egy új könyvtárat ad hozzá a PATH környezeti változóhoz a következőképpen:

@echo off
rem Az ADDPATH.BAT parancsfájl egy új könyvtárat
rem vesz fel a path környezeti változóhoz.
set path=%1;%path%
set

Kapcsolódó témakörök


Megjegyzések a Set parancshoz

Set

Megjegyzések

Az aktuális környezeti beállítások megjelenítése

A set parancs paraméterek nélküli beírásakor a Windows 2000 megjeleníti az aktuális környezeti beállításokat. Ezek a beállítások általában tartalmazzák a COMSPEC és a PATH környezeti változókat, amelyek segítségével a Windows 2000 a lemezen megtalálja a programokat. A Windows 2000 által használt másik két fontos környezeti változó a PROMPT és a DIRCMD.

Paraméterek használata

Ha a set parancs használatakor mind a változó, mind a karakterlánc értéke meg van adva, a Windows 2000 felveszi a megadott változóértéket a környezetbe és a karakterláncot társítja ezzel a változóval. Ha a változó már létezik a környezetben, az új karakterláncérték helyettesíti a régi karakterláncértéket.

Ha a set paranccsal csak egy változó és egy egyenlőség jel kerül megadásra, a Windows 2000 törli a változóhoz társított karakterláncértéket (mintha a változó nem is létezne).

A set parancs használata parancsfájlokban

Parancsfájlok írásakor a set parancs használható változók létrehozására, amelyeket a számozott változókkal (%0-tól %9-ig) azonos módon lehet használni. A számozott változókat (%0-tól %9-ig) a set parancs bemeneteként is lehet használni.

Set változó meghívása parancsfájlból

Változóérték parancsfájlból történő meghívásakor az értéket százalékjelek (%) közé kell írni. Például, a BAUD nevű környezeti változó parancsfájlban történő létrehozása esetén a BAUD környezeti változóval társított karakterláncot behelyettesíthető paraméterként is lehet használni a %baud% paraméter megadásával a parancssorban.


Setlocal

Elkezdi egy környezeti változó lokalizálását egy kötegfájlban. A lokalizáció a megfelelő endlocal parancs kiadásáig, vagy a kötegfájl végéig tart.

setlocal beállítás

Paraméter

beállítás

A parancskiterjesztések engedélyezése esetén (Windows 2000 alapértelmezés) a setlocal kötegfájlparancs elfogadja az enableextensions vagy disableextensions értékű választható argumentumot. Ez engedélyezi vagy letiltja a parancskiterjesztéseket a megfelelő endlocal parancsig, függetlenül a setlocal parancs végrehajtása előtti beállítástól.

A setlocal parancs beállítja az errorlevel értékét is, ha valamilyen argumentum meg van adva. Az errorlevel értéke nulla (0), ha a két érvényes argumentum valamelyike meg van adva, és egy (1) minden más esetben.


Példák a Setlocal parancs használatára

Setlocal

Példák

A környezeti változók parancsfájlban történő elhelyezése a következőképpen lehetséges:

  rem *******Megjegyzés kezdete**************
  rem Ez a program elindítja a hálózaton a superapp parancsfájlt,
  rem A kimenetet egy fájlba küldi, és a Jegyzettömb segítségével
  rem megjeleníti a fájlt.
  rem *******Megjegyzés vége**************
      @echo off
      setlocal
      path=g:\programs\superapp;%path%
      call superapp>c:\superapp.out
      endlocal
      start notepad c:\superapp.out

Parancskiterjesztések vizsgálata parancsfájlból

A setlocal parancs az errorlevel értékét nullára (0) állítja, ha a két érvényes argumentum közül egy meg van adva, és egyre (1) állítja minden egyéb esetben. Ez felhasználható parancsfájlokban annak meghatározására, hogy a kiterjesztések elérhetők-e:

    verify other 2>nul
    setlocal enableextensions
    if errorlevel 1 echo A kiterjesztések engedélyezése nem lehetséges

Mivel a cmd nem állítja be az errorlevel értékét, ha a parancskiterjesztések tiltva vannak, vagy a Cmd.exe verziója korábbi, a verify parancs egy érvénytelen argumentummal inicializálja az errorlevel értékét egy nullától különböző értékre. Ha a setlocal parancs érvényes kiterjesztéssel nem állítja az errorlevel értékét egyre, a parancs kiterjesztések szintén nem elérhetők.


Megjegyzések a Setlocal parancshoz

Setlocal

Megjegyzések

Kötegfájl végrehajtása közben a környezeti változók módosításához használja a setlocal parancsot. A setlocal parancs kiadása után végzett környezeti módosítások csak a kötegfájlra vonatkoznak. Helyreállnak az előző beállítások, ha az endlocal parancs kerül sorra vagy a kötegfájl a végére ér.

Egyetlen kötegfájlban több setlocal vagy endlocal parancs is szerepelhet (beágyazás).


Setver

Beállítja azt az MS-DOS verziószámot, amelyet az MS-DOS alrendszer átad egy programnak.

setver [meghajtó:elérési_útvonal] [fájlnév n.nn]

setver [meghajtó:elérési_útvonal] [fájlnév [/delete [/quiet]]

Az aktuális verziótábla a következő szintaxissal jeleníthető meg:

setver [meghajtó:elérési_útvonal]

Paraméterek

nincs

Paraméterek nélkül használva a setver parancs megjeleníti az aktuális verziótáblát.

[meghajtó:elérési_útvonal]

Megadja a Setver.exe fájl helyét.

fájlnév

Megadja a verziótáblába felvenni kívánt programfájl (.exe vagy .com) nevét. Helyettesítő karakterek (* vagy ?) nem használhatók.

n.nn

Megadja azt az MS-DOS verziót (például 3.3 vagy 4.01), amelyet az MS-DOS alrendszer átad a megadott programfájl számára.

/delete

Törli a megadott programfájlhoz tartozó verziótábla-bejegyzést. Ez a kapcsoló rövidíthető: /d.

/quiet

Elrejti a verziótábla-bejegyzésének törlésekor általában megjelenő üzenetet.


Példák a Setver parancs használatára

Setver

Példák

Tegyük fel, hogy a Myprog.exe fájl az MS-DOS 3.30-as verziójával fut. A Myprog.exe futtatásához először a következő setver parancsot használva létre kell hozni egy bejegyzést a verziótáblában, amelynek hatására a Myprog.exe 3.30 verziójúnak fogja értelmezni az MS-DOS alrendszert.

setver myprog.exe 3.30

A Myprog.exe bejegyzés verziótáblából való eltávolításához (a Myprog.exe fájl érintetlenül hagyásával) írja be:

setver myprog.exe /delete

A C meghajtón lévő verziótábla tartalmának listázásához írja be a következőt:

setver c:


Megjegyzések a Setver parancshoz

Setver

Megjegyzések

A verziótábla használata

Az MS-DOS korábbi verziójához készített programok legtöbbje hibátlanul működik a Windows 2000 rendszerben is. Egyes programok azonban csak abban az esetben futnak problémamentesen, ha a nevük szerepel a verziótáblában. A tábla azt jelzi a programnak, hogy abban az MS-DOS verziójú rendszerben fut, amelyhez tervezték, holott valójában az MS-DOS alrendszerben fut. Az MS-DOS 5.0-s verziójának korábbi verziókénti használatakor a program valószínűleg hibátlanul működni fog, mindazonáltal a setver parancs használata nem oldja meg a problémát, ha a program nem kompatibilis a Windows 2000 rendszerrel.

A verziótábla betöltése memóriába

A setver parancs használata előtt a device parancs Config.nt fájlba foglalásával be kell tölteni a verziótáblát a memóriába.

Újraindítás a verziótábla frissítése után

Ha bejegyzések hozzáadásával vagy törlésével módosítja a verziótáblát, akkor a verziótábla újraolvasásához új parancssort kell nyitnia.

Meglévő bejegyzések frissítése

Ha olyan fájlnevet ad meg, amelyik már szerepel a verziótáblában, az új bejegyzés lecseréli a már meglévőt.

Setver kilépési kódok

Az alábbi lista a kilépési kódokat és jelentésük rövid leírását tartalmazza:

0 | A Setver sikeresen végrehajtotta a feladatot.
1 | A felhasználó érvénytelen kapcsolót adott meg.
2 | A felhasználó érvénytelen fájlnevet adott meg.
3 | Nincs elegendő rendszermemória a parancs végrehajtásához.
4 | A felhasználó érvénytelen verziószám-formátumot adott meg.
5 | A Setver nem találja a megadott bejegyzést a verziótáblában.
6 | A Setver nem találja a Setver.exe fájlt.
7 | A felhasználó érvénytelen meghajtót adott meg.
8 | A felhasználó túl sok parancssori paramétert adott meg.
9 | A Setver hiányzó parancssori paramétereket talált.
10 | A Setver hibát talált a Setver.exe fájl olvasása közben.
11 | A Setver.exe fájl hibás.
12 | A megadott Setver.exe fájl nem támogat egy verziótáblát.
13 | A verziótáblában nincs elegendő hely új bejegyzéshez.
14 | A Setver hibát talált a Setver.exe fájl írása közben.

Az errorlevel paramétert az if paranccsal használva a setver kilépési kódjai feldolgozhatók egy parancsfájlban. Kilépési kódokat feldolgozó parancsfájlra egy példát láthat, ha a Kapcsolódó témakörök között az if parancsra kattint.


Share

A Windows 2000 és az MS-DOS alrendszer nem használja ezt a parancsot. Csak az MS-DOS fájlokkal fenntartott kompatibilitás miatt fogadja el a rendszer.


Shell

Megadja egy másodlagos parancsértelmező nevét és elérési útvonalát, amelyet a Windows 2000 az MS-DOS alrendszerhez használ.

shell= [[meghajtó:]elérési_útvonal] fájlnév [paraméterek]

Paraméterek

[[meghajtó:]elérési_útvonal] fájlnév

Meghatározza a Windows 2000 rendszerrel használni kívánt parancsértelmező helyét és nevét.

paraméterek

Meghatározza a megadott parancsértelmezővel használható parancssori paramétereket vagy kapcsolókat.


Példák a Shell parancs használatára

Shell

Példák

Tegyük fel, hogy a Newshell.com fájl az indítási meghajtó /Bin könyvtárában található, és ezt a fájlt kívánja parancsértelmezőként használni. Ehhez adja a Config.nt fájlhoz a következő parancsot:

shell=\bin\newshell.com


Megjegyzések a Shell parancshoz

Shell

Megjegyzések

Alapértelmezett beállítások

Alapértelmezés szerint az MS-DOS alrendszer a Command.com fájl egy speciális verzióját használja, amely együttműködik a többi Windows 2000 alrendszerrel (beleértve az alrendszerek közötti csőkezelést és átirányítást), ezért a shell parancs felesleges.

Bár nem ajánlott, de a shell parancsot használva megadhat saját 16 bites parancsértelmezőt.

Kapcsolók használata egy parancsértelmezővel

Maga a shell parancs nem fogad el egyetlen kapcsolót sem, ellenben ha a parancsértelmező igen, akkor befoglalhatja a kapcsolókat a shell parancssorba.


Shift

Módosítja a cserélhető paraméterek helyét egy kötegfájlban.

shift

A parancskiterjesztések engedélyezése esetén (a Windows 2000 alapbeállítása) a shift parancs támogatja az /n kapcsoló használatát, amely hatására a parancs az /n. paraméternél kezdi a műveletet, ahol az /n 1 és 8 közötti érték lehet. Például:

SHIFT /2

eltolja %3-ról %2-re, %4-ről %3-ra és így tovább, illetve a %0 és %1 érintetlenül marad.


Példák a Shift parancs használatára

Shift

Példák

Az alábbi Mycopy.bat kötegfájl szemlélteti a shift parancs tetszőleges számú paraméterrel történő használatát. Ez egy könyvtárba másolja a felsorolt fájlokat. A paraméterek a könyvtárnevekből és az azokat követő tetszőleges számú fájlnévből állnak.

@echo off
rem MYCOPY.BAT tetszőleges számú fájlt másol
rem egy könyvtárba.
rem A parancs szintaxisa a következő:
rem mycopy dir file1 file2 ...
set todir=%1
:getfile
shift
if "%1"=="" goto end
copy %1 %todir%
goto getfile
:end
set todir=
echo Készen van


Megjegyzések a Shift parancshoz

Shift

Megjegyzések

A shift parancs működése

A shift parancs %0 és %9 között módosítja a változtatható paraméterek értékét, úgy, hogy minden egyes paramétert átmásol az azt megelőző paraméterbe. Másképp kifejezve: az %1 értékét átmásolja a %0, a %2 értékét az %1 értékébe és így tovább. Ez olyan kötegfájl írásakor nyújt segítséget, amely fájl ugyanazt a műveletet hajtja végre valamennyi paraméteren.

Tíznél több parancssori paraméter kezelése

A shift parancs használatával létrehozható olyan kötegfájl is, amely tíznél több paramétert képes elfogadni. Ha több mint tíz paramétert ad meg a parancssorban, akkor a tizedik (%9) után szereplők egyesével átlépnek a %9 paraméterbe.

Paraméterek visszaléptetése

Nincs visszaléptető shift parancs. A shift parancs végrehajtása után nem állítható vissza az eltolás előtti első paraméter (%0).


Sort

Elolvassa a bemenetet, rendezi az adatokat és kiírja az eredményeket a képernyőre, fájlba vagy más eszközre.

sort [/r] [/+n] [/m kilobájt] [/l területi_beállítás] [/rec karakterek] [[meghajtó1:][elérési_út1]fájlnév1] [/t [meghajtó2:][elérési_út2]] [/o [meghajtó3:][elérési_út3]fájlnév3]

[parancs |] sort [/r] [/+n] [/m kilobájt] [/l területi_beállítás] [/rec karakterek] [[meghajtó1:][elérési_út1]fájlnév1] [/t [meghajtó2:][elérési_út2]] [/o [meghajtó3:][elérési_út3]fájlnév3]

Paraméterek

/r

Megfordítja a rendezés sorrendjét, tehát Z-től A-ig illetve 9-től 0-ig rendez.

/+n

Megadja az n karakter pozíciószámot, amelynél a sort megkezdi az összehasonlítást. A /+3 kód például azt jelzi, hogy az összehasonlítások minden alkalommal a sorok harmadik karakterénél kezdődnek. Az n karakternél rövidebb sorokat kiválogatja a többi sor elé. Alapértelmezés szerint az összehasonlítás a sor első karakterénél kezdődik.

/m kilobájt

Megadja kilobájtokban (KB), hogy rendszermemóriából a rendezéshez mennyit lehessen használni. A használt memória minden esetben legalább 160 KB. A memória méretének megadásakor a megjelölt mennyiség (de legalább 160 KB) kerül felhasználásra, függetlenül attól, hogy mennyi rendszermemória áll rendelkezésre.

Ha nincs megadva méret, akkor a legnagyobb memóriaméret alapértéke a rendelkezésre álló memória 90 százaléka lesz, abban az esetben, ha mind bemenetként, mind kimenetként fájlok szerepelnek. Egyéb esetben a rendszermemória 45 százaléka. Rendszerint az alapértelmezett beállítás nyújtja a legjobb teljesítményt.

/l területi_beállítás

Felülbírálja a rendszer alapértelmezett, a Windows 2000 telepítés során megadott Nyelv és Ország beállítása szerinti karaktersorrendet. Pillanatnyilag az alapértelmezett mellett egyedül a "C" területi beállítás választható, amely gyorsabb a természetes nyelvi rendezésnél, és a karaktereket azok bináris kódjai alapján rendezi.

/rec karakterek

Megadja a karakterek számának felső határát egy állományban vagy a bemeneti fájl egy sorában (az alapérték 4096, a maximális érték 65535).

[meghajtó1:][elérési_út1]fájlnév1

Kijelöli a fájlt a rendezéshez. Ha nincs megadva fájlnév, akkor a normál bemenet kerül rendezésre. A bemeneti fájlként megadás gyorsabb rendezést eredményez, mint ugyanannak a fájlnak az átirányítása a normál bemenetre.

/t [meghajtó2:][elérési_út2]

Megadja annak a könyvtárnak az elérési útját, amely a sort parancs munkatárolóját tartalmazza abban az esetben, ha az adatok nem férnek el a rendszermemóriában. Alapértelmezés szerint a rendszer ideiglenes könyvtára kerül felhasználásra.

/o [meghajtó3:][elérési_út3]fájlnév3

Megadja a fájlt, amely a rendezett bemenetet tárolja majd. Ha nincs megadva, akkor az adatok írása a normál kimenetre történik. A kimeneti fájlként megadás gyorsabb rendezést eredményez, mint a normál kimenet átirányítása ugyanabba a fájlba.


Példák a Sort parancs használatára

Sort

Példák

Fájl rendezése

A következő parancs beolvassa a kiadások.txt fájlt, fordított sorrendbe rendezi és megjeleníti a képernyőn:

sort /r kiadások.txt

Kimenet rendezése parancsból

A ”Jones” szó kereséséhez egy nagy fájlban, amelynek a neve Maillist.txt, és a keresés eredményének sorrendbe rendezéséhez használja a függőleges vonalat (|) a find parancs kimenetének átirányításához a sort parancs számára, a következőképpen:

find "Jones" maillist.txt | sort

A parancs készít egy rendezett listát a megadott szöveget tartalmazó sorokról.

A billentyűzetről érkező bemenet rendezése

A billentyűzetről érkező bemenet rendezéséhez és az eredmények ábécérendben történő megjelenítéséhez a képernyőn, használja a sort parancsot paraméterek nélkül, a következőképpen:

sort

Ezután írja be a rendezendő szöveget, minden sor végén lenyomva az ENTER billentyűt. A szöveg beírása után nyomja meg a CTRL+Z billentyűkombinációt, majd az ENTER billentyűt. A sort parancs a beírt szöveget ábécérendben jeleníti meg.

A rendezett, billentyűzetről bevitt szöveget fájlba is át lehet irányítani. További információért kattintson a Kapcsolódó témakörök között a redirect parancsra.


Megjegyzések a Sort parancshoz

Sort

Megjegyzések

Forrás megadása

Ha a parancs vagy a fájlnév paraméter nincs megadva, a sort parancs szűrőként viselkedik, és a bemenete a Windows 2000 normál bemenete lesz (általában a billentyűzet, egy cső vagy egy fájl).

Átirányító jelek használata a sort paranccsal

A függőleges vonal szimbólum segítségével (|) egy másik parancs kimenete átadható a sort parancsnak, vagy a sort parancs kimenete átadható egy másik parancsnak (például a more parancsnak, hogy az eredményeket képernyőnként jelenítse meg a számítógép). A “kisebb mint” (<) vagy a “nagyobb mint” (>) jelek használata a bemeneti vagy a kimeneti fájl megadására nem mindig hatásos. Ilyen esetben a bemeneti fájl a parancsszintaktika szerint közvetlenül, a kimeneti fájl a /o paraméter segítségével adható meg. Ez nagy fájlok esetén sokkal gyorsabb.

Nagybetűk és kisbetűk

A sort parancs nem különbözteti meg a kis- és nagybetűket.

A fájlméret korlátai

A sort parancsnak nincsen fájlméretre vonatkozó korlátozása.

Rendezési sorrend

A sort program az országkód és a kódlap beállításoknak megfelelő rendezési táblázatot használja. A parancs a 127-nél nagyobb ASCII kóddal rendelkező karaktereket a Country.sys fájlban vagy a Config.nt fájl country parancsának segítségével megadott fájlban lévő információ alapján rendezi.

Memóriahasználat

Ha a rendezés elfér a memóriában (vagy az alapértelmezett maximális memóriaméretbe, vagy az /m paraméter által megadott méretbe), a rendezés egy menetben megtörténik. Egyéb esetben a rendezés két lépcsőben történik úgy, hogy a rendezési és összefésülési szakaszban használt memóriaméret megegyezik. Kétlépcsős rendezés esetén a részben rendezett adatokat a parancs egy ideiglenes fájlban tárolja a lemezen. Ha nincs elég memória a rendezés kétlépcsős végrehajtásához, futásidejű hiba jelentkezik. Ha az /m beállítással az elérhetőnél több memóriát ad meg, teljesítménycsökkenés vagy futásidejű hiba léphet fel.


Stacks

A hardvermegszakítások kezeléséhez támogatja az adatvermek dinamikus használatát. Használatához ezt a környezeti változót helyezze el a Config.nt fájlban.

stacks=n,s

Paraméterek

n

Meghatározza a vermek számát. Az n érvényes értéke lehet 0, illetve a 8-tól 64-ig terjedő tartományban bármely szám.

s

Megadja bájtokban az egyes vermek méretét. Az s érvényes értéke lehet 0, illetve a 32-től 512-ig terjedő tartományban bármely szám.


Példák a Stacks parancs használatára

Stacks

Példák

Ha nyolc, egyenként 512 bájtos vermet akar foglalni hardvermegszakítás-kezelésre, adja a következő parancsot a Config.nt fájlhoz:

stacks=8,512


Megjegyzések a Stacks parancshoz

Stacks

Megjegyzések

Alapértelmezett beállítások

Az alábbi táblázat a stack parancs alapbeállításait mutatja be.

Számítógép | Stacks
IBM PC, IBM PC/XT, IBM PC-hordozható | 0,0
Egyéb | 9,128

A veremlefoglalás különleges esetei

Hardveres megszakítás fogadásakor a Windows 2000 a megadott számú veremből lefoglal egy vermet. Ha az n és az s értékéül nullát ad meg, a Windows 2000 nem foglal le vermet. Ha az értékek nullák, minden futó programnak elegendő veremhellyel kell rendelkeznie a számítógép bemeneti hardvereszközeinek kezeléséhez. Sok számítógép – a programok számára némi memória fenntartásával – hibátlanul működik, ha az n és az s értékéül nullát ad meg. Ha azonban az értékeket nullára állította be és a számítógép instabillá válik, akkor térjen vissza az alapértékekhez.


Start

Megnyit egy külön ablakot a megadott program vagy parancs futtatásához.

start [”cím”] [/d elérési út] [/i] [/min] [/max] [/separate| /shared] [/low|/normal|/high | /realtime] [/wait] [/b] [fájlnév] [paraméterek]

Paraméterek

nincs

Paraméterek nélkül használva a start parancs megnyit egy külön parancssori ablakot.

”cím”

Megadja az ablak címsorában megjelenítendő szöveget.

/d elérési út

Megadja a kezdeti könyvtárat.

/i

Átadja a Cmd.exe indító környezetét az új ablaknak.

/min

Egy új kis méretű ablakot nyit meg.

/max

Egy új teljes méretű ablakot nyit meg.

/separate

A 16 bites Windows programokat külön memóriaterületen indítja el.

/shared

A 16 bites Windows programokat megosztott memóriaterületen indítja el.

/low

Az alkalmazást az üresjárat prioritásosztályban indítja el.

/normal

Az alkalmazást a normál prioritásosztályban indítja el.

/high

Az alkalmazást a magas prioritásosztályban indítja el.

/realtime

Az alkalmazást a valós idejű prioritásosztályban indítja el.

/wait

Elindítja az alkalmazást, és vár annak befejeződésére.

/b

Nem nyit meg új ablakot. A CTRL+C kezelés figyelmen kívül marad, hacsak az alkalmazás nem engedélyezi a CTRL+C feldolgozását. Az alkalmazás megszakításához használja a CTRL+BREAK billentyűkombinációt.

fájlnév

Megadja az elindítandó programot vagy parancsot.

paraméterek

Megadja a parancsnak vagy programnak átadandó paramétereket.

A parancskiterjesztések engedélyezése esetén (a Windows 2000 alapértelmezett beállítása) a külső parancsok elindítása a parancssoron keresztül vagy a start parancs segítségével a következőképpen változik meg:

  • A nem futtatható fájlok elindíthatóak a hozzájuk rendelt programok segítségével a fájl nevének parancsként történő beírásával. Például a word.doc parancs megnyitja a .doc kiterjesztéshez rendelt alkalmazást. Ezen hozzárendelések létrehozásáról a parancssoron keresztül további információ kapható a Kapcsolódó témakörök között az assoc és az ftype parancsra kattintva.
  • 32 bites grafikus kezelőfelületű alkalmazás futtatásakor a parancssorhoz való visszatérés előtt a cmd nem várja meg az alkalmazás befejeződését. Ez az új viselkedés nem áll fenn parancsfájlok végrehajtása esetén.
  • Olyan parancssori utasítás végrehajtásakor, amelynek első alapeleme a ”CMD” karakterlánc kiterjesztés és elérési út nélkül, a ”CMD” karakterláncot a COMSPEC változó értékével helyettesíti a rendszer. Ez megakadályozza a cmd parancs aktuális könyvtárból történő elindítását.
  • Olyan parancssori utasítás végrehajtásakor, amelynek első alapeleme nem tartalmaz kiterjesztést, a CMD.EXE a PATHEXT környezeti változó értékét használja a keresendő kiterjesztések és azok sorrendjének meghatározásához. A PATHEXT változó alapértelmezett értéke:
    •         .COM;.EXE;.BAT;.CMD

    Megjegyzés

  • A szintaxis azonos a PATH változóéval: az egyes elemeket pontosvesszőkkel kell elválasztani.
  • Végrehajtható fájlok keresésekor, ha nincs egyik kiterjesztéshez sem megfelelő fájl, akkor a parancs megvizsgálja, hogy van-e a megadott névvel egyező könyvtárnév. Ha van ilyen, a start parancs megnyitja a Windows Intézőt az adott elérési úttal. Ha ez parancssorból történik, a parancs egyenértékű a cd /d parancs használatával az adott elérési úton.


Példák a Start parancs használatára

Start

Példák

A Myapp program parancssorból történő elindításához és az aktuális ablak használatának fenntartásához írja be a következőt:

start myapp


Subst

Elérési utat társít egy meghajtóbetűjellel.

subst meghajtó1: [meghajtó2.:]elérési út]

subst meghajtó1: /d

Paraméterek

nincs

Paraméterek nélkül használva a subst parancs megjeleníti az érvényben lévő virtuális meghajtók nevét.

meghajtó1:

Megadja azt a virtuális meghajtót, amelyhez elérési utat kíván hozzárendelni.

meghajtó2:

Meghatározza azt a fizikai meghajtót, amely a megadott elérési utat tartalmazza (ha az különbözik az aktuális meghajtótól).

elérési út

Megadja azt az elérési utat, amelyet a virtuális meghajtóhoz kíván hozzárendelni.

/d

Virtuális meghajtót töröl.


Példák a Subst parancs használatára

Subst

Példák

A B:\User\Betty\Forms elérési úthoz Z betűjelű virtuális meghajtó létrehozásához írja be a következőt:

subst z: b:\user\betty\forms

Ezután a teljes elérési út begépelése helyett a könyvtárat a virtuális meghajtó betűjelének és azt követően egy kettőspontnak a beírásával érheti el:

z:


Megjegyzések a Subst parancshoz

Subst

Megjegyzések

Más parancsok használata a subst paranccsal

Az alábbi parancsok nem működnek, vagy használatuk nem ajánlott azokon a meghajtókon, amelyek szerepelnek a subst parancsban:

chkdsk | format
diskcomp | label
diskcopy | recover

Érvényes meghajtó1 értékek

A meghajtó1 paraméternek a lastdrive parancs által meghatározott tartományon belül kell lennie. Ha nem, a subst a következő hibaüzenetet jeleníti meg.

Érvénytelen paraméter - drive1:


Switches

A bővített billentyűzetet hagyományos billentyűzetként működteti. Használja ezt a parancsot a Config.nt fájlban.

switches=/k


Példák a Switches parancs használatára

Switches

Példák

Ha azt kívánja, hogy annak ellenére, hogy bővített billentyűzetet használ, a Windows 2000 mégis hagyományos billentyűzetfunkciókat használjon, foglalja bele a következő parancsot a Config.nt fájlba:

switches=/k


Megjegyzések a Switches parancshoz

Switches

Megjegyzések

A Switches parancs használata

Ha egy program nem fogadja el tökéletesen a kibővített billentyűzetről bevitt adatokat, akkor adja hozzá ezt a parancsot a Config.nt fájlhoz. Így a kibővített billentyűzet hagyományos billentyűzetként fog működni.

A /k kapcsoló használata az Ansi.sys eszközillesztővel

Ha használja a switches=/k parancsot, és telepíti az Ansi.sys eszközillesztőt, akkor a device parancssorban használja hozzá a k kapcsolót.


Tcmsetup

Telepíti a telefonos ügyfelet. A tcmsetup paranccsal megadhatók a telefonos ügyfél által használt távoli kiszolgálók, vagy letiltható az ügyfél.

tcmsetup [/q] [/x] /c kiszolgáló1 [kiszolgáló2 ... kiszolgálóN]

tcmsetup [/q] /c /d

Paraméterek

/q

Megakadályozza az üzenetablakok megjelenítését.

/x

Kapcsolatorientált visszahívásokat ad meg olyan nagy forgalmú hálózatokra, ahol nagy a csomagveszteség. A paraméter elhagyása esetén a kapcsolat nélküli visszahívás az alapértelmezett.

/c

Ez a kötelező paraméter az ügyfélbeállításokat adja meg.

kiszolgáló1

Annak a távoli kiszolgálónak a neve, ahol ez az ügyfél a TAPI szolgáltatókat, valamint a szolgáltató vonalait vagy telefonjait használja. Az ügyfélnek és a kiszolgálónak ugyanabban, vagy a kiszolgálót tartalmazó tartománnyal kétirányú megbízhatósági kapcsolattal rendelkező tartományban kell lennie.

kiszolgáló2 ... kiszolgálóN

Tetszőleges számú további kiszolgáló, amely elérhető az ügyfél számára.

/d

Törli a távoli kiszolgálók listáját. A távoli kiszolgáló TAPI szolgáltatójának használatának megakadályozásával letiltja a telefonos ügyfelet.

Megjegyzések

  • A parancs futtatásához a Rendszergazdák csoport tagjának kell lennie. Ha másik csoportba jelentkezett be, olvassa el a Program indítása rendszergazdaként a Futtatás mint parancs segítségével című témakört.
  • Mielőtt az ügyfél használni tudná a TAPI kiszolgálón található telefont vagy vonalat, a telefonos kiszolgáló rendszergazdájának hozzá kell rendelnie az ügyfelet a telefonhoz vagy vonalhoz.
  • A telefonos kiszolgálók ezzel a paranccsal létrehozott listája felülírja az ügyfél számára elérhető összes létező listát. Ez a parancs nem használható meglevő listához történő hozzáadáshoz.


TCP/IP segédprogramok és szolgáltatások

További információért válasszon ki egy segédprogramot vagy szolgáltatást.

TCP/IP segédprogramok

arp | nslookup
finger | ping
ftp | rcp
hostname | rexec
ipconfig | route
lpq | rsh
lpr | tftp
nbtstat | tracert
netstat |

TCP/IP szolgáltatások

net start dhcp client | net start simple tcp/ip services
net start ftp publishing service | net start snmp
net start lpdsvc | net start tcp/ip netbios helper
net start microsoft dhcp service | net start windows internet name service

A TCP/IP segédprogramok segítségével nem Microsoft számítógépekkel, például UNIX munkaállomásokkal lehet hálózati kapcsolatot létesíteni. A TCP/IP segédprogramok használatához telepíteni kell a TCP/IP hálózati protokollt.


Tftp

Fájlokat visz át egy távoli számítógépre, illetve számítógépről a TFTP szolgáltatás segítségével. Ez a parancs csak a TCP/IP protokoll telepítése esetén érhető el.

tftp [-i] számítógép [get | put] forrás [cél]

Paraméterek

-i

A bináris képátvitel módját adja meg (oktett néven is ismert). Bináris kép üzemmódban a parancs a képet bájtonként helyezi át. Bináris fájlok átvitelekor ezt a módszert használja.

Ha nincs megadva az -i paraméter, a fájlt ASCII módban viszi át a parancs. Ez az alapértelmezett átviteli üzemmód. Ez az üzemmód az EOL (sorvége) karaktereket a UNIX esetén „kocsi vissza”, a személyi számítógépek esetében pedig ”kocsi vissza/soremelés” karakterré alakítja. Ez az üzemmód szövegfájlok átviteléhez használható. Sikeres fájlátvitel esetén megjelenik az adatátviteli sebesség.

számítógép

A helyi vagy távoli számítógépet adja meg.

put

A helyi számítógépen található cél paraméterben megadott fájlt a távoli számítógép forrás paraméterében megadott fájlba viszi át.

get

A távoli számítógépen található cél paraméterben megadott fájlt a helyi számítógép forrás paraméterében megadott fájlba viszi át.

A put parancsot akkor kell megadni, ha a helyi számítógépen található fájl-2 fájlt a távoli számítógép fájl-1 fájljába kívánja másolni. A get parancsot akkor kell megadni, ha a távoli számítógépen található fájl-2 fájlt a távoli számítógép fájl-1 fájljába kívánja másolni.

Mivel a tftp protokoll nem támogatja a felhasználó hitelesítését, ezért a felhasználó bejelentkezése után engedélyezni kell a fájlok távoli számítógépre történő írását.

forrás

Az átvinni kívánt fájl nevét adja meg. Ha a helyi fájl -, a távoli fájl a stdout eszközre nyomtatja (vétel esetén), vagy az stdin eszközről olvassa be (küldés esetén) a parancs.

cél

A fájlátvitel helyét adja meg. A cél paraméter kihagyása esetén a mentés a source paraméterben megadott helyre történik.


Time

Megjeleníti a rendszeridőt, vagy beállítja a számítógép belső óráját.

time[órák:[percek[:másodpercek[.századmásodpercek]]][A|P]]

Paraméterek

nincs

Paraméterek nélkül megadva a time parancs megjeleníti a számítógép órája szerinti időt és megkérdezi az új időt. Az idő változatlanul hagyásához nyomja meg az ENTER billentyűt, vagy adja meg az új időt a fenti szintaxist használva.

órák

Megadja az órát. Az érvényes értékek 0 és 23 között vannak.

percek

Megadja a perceket. Az érvényes értéknek 0 és 59 közé kell esnie.

másodpercek

Megadja a másodperceket. Az érvényes értéknek 0 és 59 közé kell esnie.

századmásodpercek

Megadja a századmásodperceket. Az érvényes értéknek 0 és 99 közé kell esnie.

A|P

12 órás formátum esetén megadja, hogy délelőtt (AM) vagy délután (PM). Érvényes 12 órás formátumú idő megadása esetén az A és a P paraméter megadása nélkül, a time parancs az A beállítást alkalmazza (délelőtt).


Példák a Time parancs használatára

Time

Példák

A számítógép órájának 13 óra 26 percre állításához írja be a következő parancsok egyikét:

time 13:36

time 1:36 P


Megjegyzések a Time parancshoz

Time

Megjegyzések

Érvénytelen időformátum megadása

Érvénytelen formátumú idő megadása esetén a Windows 2000 a következő üzenetet jeleníti meg és várakozik az idő megadására:

Érvénytelen idő
Adja meg az új időt:_

Az időformátum módosítása

A Vezérlőpult Dátum/Idő segédprogramjával megváltoztatható az idő formátuma. Csak az MS-DOS alrendszer időformátumának megváltoztatásához elég az ország beállítás megváltoztatása a Config.nt fájlban. Az ország/terület beállítástól függően a Windows 2000 12 órás vagy 24 órás formátumban jeleníti meg az időt. Ha az idő 12 órás formátumra van beállítva, a délutáni órákat a P betűvel kell jelezni.


Title

Címet hoz létre a parancssorablakhoz.

title [karakterlánc]

Paraméter

karakterlánc

Megadja a parancssorablak címét.


Példák a Title parancs használatára

Title

Példák

Egy kötegfájl ablakcímének beállításához írja be a következőt:

rem Ez a kötegfájl az alkalmazottak adatait frissíti:

cls

@echo off

title Fájlok frissítése

copy \\server\share\*.xls c:\users\common\*.xls

echo Fájlok frissítve

title Parancssor


Megjegyzések a Title parancshoz

Title

Megjegyzések

A kötegfájlok ablakcímének megadásához foglalja a title parancsot a kötegfájl elejébe.

Ha egyszer beállította, az ablakcímet csak a title paranccsal állíthatja alaphelyzetbe.


Tracert

Ez a diagnosztikai segédprogram változó élettartamú (TTL) Internet Control Message Protocol (ICMP) visszhangcsomagok küldésével meghatározza a célhoz vezető utat. Minden útválasztó a csomag továbbítása előtt csökkenti a TTL értékét legalább 1-gyel, így a TTL tulajdonképpen az ugrások számát méri. Ha a csomag TTL értéke eléri a nullát, az útválasztó egy ”ICMP időkorlát túllépve” üzenetet küld a forrásrendszernek. A Tracert parancs az útvonal meghatározásához a visszhangcsomagot először 1-es TTL-lel küldi el, majd mindaddig eggyel növeli a TTL értékét, amíg a cél válaszol, vagy a csomag eléri a maximális TTL értéket. Az útvonal meghatározása a közbenső útválasztók által visszaküldött ”ICMP időkorlát túllépve” üzenetek vizsgálatával történik. Néhány útválasztó a lejárt TTL értékkel rendelkező csomagokat eldobja, így azok láthatatlanok maradnak a tracert parancs számára.

tracert [-d] [-h ugrások_maximális_száma] [-j számítógép_lista] [-w időtúllépés] cél_neve

Paraméterek

-d

Megadja, hogy a címeket nem kell feloldani számítógépnevekké.

-h ugrások_maximális_száma

Megadja az ugrások maximális számát a cél keresésekor.

-j számítógép_lista

Megadja a laza forrásútvonalat a számítógép_lista mentén.

-w időtúllépés

Minden válaszra az időtúllépés paraméterben megadott számú ezredmásodpercet vár.

cél_neve

A célszámítógép neve.


Tree

Grafikusan megjeleníti egy elérési útvonal vagy a meghajtóban lévő lemez könyvtárszerkezetét.

tree [meghajtó:][elérési_útvonal] [/f] [/a]

Paraméterek

meghajtó:

Megadja azt a meghajtót, amelynek a könyvtárszerkezetét meg kívánja tekinteni.

elérési_útvonal

Meghatározza azt a könyvtárat, amelynek a könyvtárszerkezetét meg kívánja tekinteni.

/f

Az egyes könyvtárakban megjeleníti a fájlok nevét.

/a

Meghatározza, hogy a tree parancs grafikus karakterek helyett szöveges karaktereket használjon a csatolt alkönyvtárak megjelenítésére.


Példák a Tree parancs használatára

Tree

Példák

Az aktuális meghajtón található összes alkönyvtár nevének megjelenítéséhez írja be a következőt:

tree \

A C meghajtó összes könyvtárában található fájlok képernyőnkénti megjelenítéshez írja be:

tree c:\ /f | more

Az előző példában megjelenítettek nyomtatásához írja be a következőt:

tree c:\ /f prn


Megjegyzések a Tree parancshoz

Tree

Megjegyzések

A tree parancs által megjelenített struktúra a parancssorban megadott paraméterektől függ. Ha nem ad meg meghajtót vagy elérési utat, a tree parancs az aktuális meghajtó aktuális könyvtáránál kezdődő fastruktúrát jeleníti meg.


Type

Megjeleníti egy szövegfájl tartalmát. Használja a type parancsot, ha egy szövegfájlt meg akar tekinteni, de azt nem akarja módosítani.

type [meghajtó:][elérési_útvonal] fájlnév

Paraméter

[meghajtó:][elérési_útvonal] fájlnév

Megadja a megtekinteni kívánt fájl vagy fájlok helyét és nevét. A fájlneveket válassza el szóközzel.

NTFS meghajtó használata esetén ha a fájlnév szóközöket tartalmaz, a fájlnevet idézőjelek (") közé kell tenni.


Példák a Type parancs használatára

Type

Példák

A Holiday.mar nevű fájl megjelenítéséhez írja be:

type holiday.mar

Hosszú fájl képernyőnkénti megjelenítéséhez írja be a következőt:

type holiday.mar | more


Megjegyzések a Type parancshoz

Type

Megjegyzések

Bináris fájlok megjelenítése

Ha bináris fájlt vagy egy program által létrehozott fájlt jelenít meg, idegen karaktereket láthat a képernyőn, köztük lapdobás karaktereket és vezérlő jelsorozatokat. Ezek a karakterek bináris fájlban használt vezérlőkódok. Alapjában véve ne használja a type parancsot bináris fájlok megjelenítésére.


Ver

Megjeleníti a Windows 2000 verziószámot.

ver


Verify

A Windows 2000 nem használja ezt a parancsot. Csak az MS-DOS fájlokkal fenntartott kompatibilitás miatt fogadja el a rendszer.


Vol

Megjeleníti a lemez kötetcímkéjét és sorozatszámát, ha van. Sorozatszám akkor jelenik meg, ha a lemez formázása 4.0-s vagy későbbi verziójú MS-DOS programmal történt.

vol [meghajtó:]

Paraméter

meghajtó:

Megadja azt a meghajtót, amelynek a kötetcímkéjét és sorozatszámát meg kívánja tekinteni.


Winnt32

Telepíti vagy frissíti a Windows 2000 Server vagy Windows 2000 Professional operációs rendszert. A winnt32 parancs a Windows 95, a Windows 98 vagy a Windows NT parancssorában futtatható.

winnt32 [/s:forrás_elérési_út] [/tempdrive:meghajtó_betűjele] [/unattend[szám]:[válasz_fájl]] [/copydir:mappanév] [/copysource:mappanév] [/cmd:parancssor]
[/debug [szint]:[fájlnév]] [/udf:azonosító [,UDF_fájl]] [/syspart:meghajtó_betűjele] [/checkupgradeonly] [/cmdcons] [/m:mappanév] [/makelocalsource] [/noreboot]

Paraméterek

/s:forrás_elérési_út

Megadja a Windows 2000 fájlok elérési útvonalát. Fájlok egy időben történő másolásához több kiszolgálóról adjon meg több /s forrást. Több /s kapcsoló használata esetén az első megadott kiszolgálónak elérhetőnek kell lennie, egyébként a Telepítő leáll.

/tempdrive:meghajtó_betűjele

Utasítja a Telepítőt, hogy az ideiglenes fájlokat a megadott partícióra helyezze, és oda telepítse a Windows 2000 operációs rendszert.

/unattend

Az előző Windows 2000, Windows NT 4.0, Windows 3.51, Windows 95, vagy Windows 98 operációs rendszer verziót felügyelet nélküli telepítő üzemmódban frissíti. A rendszer átveszi az előző telepítés valamennyi felhasználói beállítását, így a telepítés során nincs szükség felhasználói beavatkozásra.

Az /unattend kapcsoló használatával megerősíti, hogy elolvasta és elfogadta a Windows 2000 szoftverre vonatkozó Microsoft licencszerződést. Mielőtt ezt a kapcsolót a Windows 2000 nem saját cég részére való telepítésére használná, ellenőrizni kell, hogy a végfelhasználó kézhez kapta, elolvasta és elfogadta a Windows 2000 Microsoft licencszerződést. Végfelhasználóknak értékesített gépek esetén az OEM-forgalmazók nem használhatják ezt a kapcsolót.

/unattend[szám]:[válaszfájl]

Új telepítést hajt végre felügyelet nélküli üzemmódban. A Telepítő számára a válaszfájlban adhatók meg a személyre szabott beállítások.

A Szám a fájlok másolásának befejezése és a számítógép újraindítása közötti idő másodpercben. A szám paraméter használata Windows NT vagy Windows 2000 operációs rendszert futtató számítógépen lehetséges.

A válaszfájl a válaszfájl neve.

/copydir:mappanév

Létrehoz egy mappát azon a mappán belül, ahová a rendszer a Windows 2000 fájlokat telepíti. Ha például a forrásmappa tartalmaz egy Private_drivers nevű mappát, amely a helyre jellemző módosításokat tartalmaz, a Telepítő a /copydir:Private_drivers kapcsoló hatására a telepített Windows 2000 mappába másolja a mappát, amelynek így a helye a C:\Winnt\Private_drivers könyvtár lesz. A /copydir kapcsoló tetszőleges számú mappa létrehozására használható.

/copysource:mappanév

Létrehoz egy ideiglenes mappát azon a mappán belül, ahová a rendszer a Windows 2000 fájlokat telepíti. Ha például a forrásmappa tartalmaz egy Private_drivers nevű mappát, amely a helyre jellemző módosításokat tartalmaz, a Telepítő a /copysource:Private_drivers kapcsoló hatására a telepített Windows 2000 mappába másolja a mappát, és ezeket a fájlokat használja a telepítés során, amelynek így az ideiglenes helye a C:\Winnt\Private_drivers könyvtár lesz. A /copydir kapcsolóval létrehozott mappákkal szemben a /copysource kapcsolóval létrehozott mappák a telepítés befejezése után törlődnek.

/cmd:parancssor

A telepítés utolsó fázisa előtt egy adott parancs végrehajtására utasítja a Telepítőt. A parancsot a számítógép kétszeri újraindulása és a telepítéshez szükséges konfigurációs adatok összegyűjtése után, de a telepítés befejezése előtt hajtja végre a rendszer.

/debug[szint]:[fájlnév]

Létrehoz egy megadott szintű hibakeresési naplófájlt, például: /debug4:C:\Win2000.log. Az alapértelmezett naplófájl a C:\%Windir%\Winnt32.log, 2-es szintű hibakeresési szinttel. A hibakeresési szintek a következők: 0-súlyos hibák, 1-hibák, 2-figyelmeztetések, 3-információ, 4-részletes adatok a hibakereséshez. Mindegyik szint tartalmazza az alatta levő szinteket.

/udf:azonosító[,UDB_fájl]

Megadja azt az azonosítót amelyet a Telepítő használ annak megadására, hogy az Egyediség adatbázis (UDB) fájl hogyan módosítja a válaszfájlt (lásd az /unattend bejegyzést). Az /udf paraméter felülbírálja a válaszfájl értékeit, és az azonosító dönti el azt, hogy az UDB fájlban található mely értékek kerülnek használatra. Például az /udf:RAS_user,Our_company.udb kapcsoló felülírja a Our_company.udb fájlban lévő RAS_user azonosító értékét. Ha az UDB_fájl nincs megadva, a Telepítő figyelmezteti a felhasználót, hogy helyezzen be egy lemezt, mely tartalmazza a $Unique$.udb fájlt.

/syspart:meghajtó_betűjele

Megadja, hogy a Telepítő az indítófájlokat egy merevlemezre másolhatja, aktívnak jelölheti meg a lemezt, majd a lemez másik számítógépbe telepíthető. A másik számítógép indításakor a rendszer automatikusan a Telepítő következő fázisával indul. A /syspart paramétert mindig a /tempdrive paraméterrel együtt kell használni.

/checkupgradeonly

Ellenőrzi, hogy a számítógép frissíthető-e Windows 2000 rendszerre. Windows 95 vagy Windows 98 rendszerről történő frissítés esetén a Windows mappájában létrehoz egy Upgrade.txt nevű jelentést. Windows NT 3.51 vagy 4.0 rendszerről történő frissítés esetén a jelentés a Winnt32.log fájlba kerül, a telepítési mappába.

/cmdcons

Lehetővé teszi a hibás telepítés javítását segítő Helyreállítási konzol indítását az operációs rendszer kiválasztását biztosító képernyőről. Csak a telepítés után használható.

/m:mappanév

Megadja, hogy a Telepítő a helyettesítő fájlokat egy másik helyről másolja. Arra utasítja a Telepítőt, hogy a fájlokat először a másik helyen keresse, és ha azok ott megtalálhatók, akkor azokat használja az alapértelmezett helyen levő fájlok helyett.

/makelocalsource

Utasítja a Telepítőt, hogy az összes telepítő forrásfájlt a helyi merevlemezre másolja. A /makelocalsource kapcsoló használata akkor ajánlott, ha a CD-lemezről történő telepítés során a telepítés későbbi lépéseinél a CD nem használható.

/noreboot

Utasítja a Telepítőt, hogy ne indítsa újra a számítógépet, miután a winnt32 átmásolta a fájlokat. Ezzel lehetőség nyílik más parancsok végrehajtására.


Winnt

Végrehajtja a Windows 2000 telepítését vagy az arra való frissítést.

winnt [/s:forrás_elérési_útvonala] [/t:átmeneti_meghajtó] [/u:válaszfájl][/udf:azonosító [,UDB_fájl]] [/r:mappa][/rx:mappa][/e:parancs][/a]

Paraméterek

/s:forrás_elérési_útvonala

Megadja a Windows 2000 fájlok elérési útvonalát. A helyet teljes elérési útvonallal kell megadni az alábbi formátumban: x:\[elérési_útvonal] vagy \\kiszolgáló\megosztás[\elérési_útvonal].

/t:átmeneti_meghajtó

Utasítja a telepítőt, hogy az ideiglenes fájlokat a megadott meghajtóra helyezze, és a Windows 2000 operációs rendszert az adott meghajtóra telepítse. Ha nem ad meg helyet, akkor a Telepítő próbál keresni egy meghajtót.

/u:válaszfájl

Felügyelet nélküli telepítést hajt végre egy válaszfájl segítségével. A válaszfájl választ ad néhány, vagy akár az összes kérdésre, amelyre általában a felhasználó válaszol a telepítés alatt. Ekkor használni kell a /s kapcsolót is.

/udf:azonosító [,UDB_fájl]

Azt az azonosítót (azonosító) jelzi, amelyet a Telepítő használ annak eldöntésére, hogyan módosítja az Egyediségadatbázis-fájl (UDB) a válaszfájlt (lásd: /u). Az /udf paraméter felülbírálja a válaszfájl értékeit, és az azonosító dönti el azt, hogy az UDB fájlban található mely értékeket használja a telepítés. Ha nincs megadva UDB_fájl, akkor a Telepítő kéri, hogy helyezze be a $Unique$.udb fájlt tartalmazó lemezt.

/r:mappa

Egy választható mappát telepít. Ez a mappa a Telepítő befejezése után is megmarad.

/rx:mappa

Megad egy másolni kívánt választható mappát. A mappát a telepítés befejezése után törli a Telepítő.

/e:parancs

Megadja a GUI-módú telepítés befejezése után végrehajtani kívánt parancsot.

/a

Engedélyezi a kisegítő lehetőségeket.


Xcopy

Fájlokat és könyvtárakat másol, az alkönyvtárakkal együtt.

xcopy forrás [cél] [/w] [/p] [/c] [/v] [/q] [/f] [/l] [/d [:dátum]] [/u] [/i] [/s [/e]] [/t] [/k] [/r] [/h] [/a | /m] [/n] [/exclude:fájlnév] [/y | /-y] [/z]

Paraméterek

forrás

Megadja a másolni kívánt fájlok helyét és nevét. Ennek a paraméternek tartalmaznia kell egy meghajtót vagy egy elérési utat.

cél

Megadja azt a helyet, ahová a fájlokat a parancs átmásolja. Ez a paraméter tartalmazhat meghajtóbetűjelet és kettőspontot, könyvtárnevet, fájlnevet, és ezek kombinációját.

/w

A másolás megkezdése előtt megjeleníti a következő üzenetet, és megvárja a felhasználó válaszát:

Nyomjon le egy billentyűt a fájl(ok) másolásának elkezdéséhez

/p

Megerősítést kér minden célfájl létrehozása előtt.

/c

Figyelmen kívül hagyja a hibákat.

/v

Ellenőrzi az összes célfájlt, hogy azonosak-e a forrásfájlokkal. Ez a kapcsoló hatástalan, mivel ez a funkció beépített a Windows 2000 operációs rendszerben. Csak a korábbi MS-DOS verziókkal való kompatibilitás érdekében fogadja el a rendszer.

/q

Kikapcsolja az xcopy parancs üzeneteinek megjelenítését.

/f

A másolás közben megjeleníti a forrás- és célfájlok neveit.

/l

Nem másolja át a fájlokat, csak azokat a fájlneveket sorolja fel, amelyek másolva lennének.

/d[:dátum]

Csak az adott dátum napján vagy később módosult fájlokat másolja. Ha a dátum paraméter értéke nincs megadva, az xcopy parancs átmásolja az összes olyan forrást, amelynek dátuma későbbi, mint a már létező célfájl dátuma. Ez a beállítás lehetővé teszi csak a megváltozott fájlok frissítését. Dátum megadása esetén kötőjelet (-) kell használni perjel (/) helyett elválasztóként, egyébként a dátumot paraméterként értelmezheti a rendszer.

/u

A forrásból csak a célban létező fájlok frissítését másolja át.

/i

Ha a forrás egy könyvtár vagy helyettesítő karaktereket tartalmaz, és a cél nem létezik, akkor az xcopy parancs feltételezi, hogy a cél egy könyvtárnév, létrehozza azt és átmásolja az összes megadott fájlt a létrehozott könyvtárba. Alapértelmezésben az xcopy parancs megkérdezi, hogy a megadott cél fájl-e vagy könyvtár.

/s

Átmásolja a könyvtárakat az alkönyvtárakkal együtt, amennyiben azok nem üresek. Ha ez a kapcsoló nincs megadva, az xcopy parancs csak egy könyvtárból másol.

/e

Átmásolja az alkönyvtárakat, akkor is, ha azok üresek. Az /s és /t kapcsolóval együtt használatos.

/t

Csak az alkönyvtárstruktúrát (fát) másolja át, a fájlokat nem. Üres könyvtárak átmásolásához meg kell adni az /e kapcsolót is.

/k

A fájlok átmásolása után megőrzi a forrásfájlok csak olvasható attribútumának állapotát a célfájlok esetében. Alapértelmezés szerint a csak olvasható attribútumot a másolás nem őrzi meg.

/r

Átmásolja a csak olvasható fájlokat.

/h

Átmásolja a rejtett és rendszerfájl attribútummal rendelkező fájlokat. Az xcopy parancs alapértelmezés szerint nem másolja át a rejtett- és rendszerfájlokat.

/a

Csak azokat a fájlokat másolja át, amelyek rendelkeznek az archiválandó fájlattribútummal. Ez a kapcsoló nem módosítja a forrásfájl archiválandó attribútumát. A fájlok archiválandó attribútumának beállításáról további információ az attrib parancs leírásánál található.

/m

Átmásolja azokat a fájlokat is, amelyek archiválandó fájlattribútummal rendelkeznek. Az /a kapcsolóval ellentétben az /m kapcsoló kikapcsolja a forrásfájlok archiválandó fájlattribútumát. A fájlok archiválandó attribútumának beállításával kapcsolatos további információért kattintson a Kapcsolódó témakörök között az attrib parancsra.

/n

Rövid NTFS fájl- és könyvtárneveket használva másol. Ezt a kapcsolót akkor kell használni, amikor NTFS kötetről FAT kötetre történik a másolás, vagy amikor a célköteten a 8.3-as FAT fájlelnevezési szabály használata szükséges. A célfájlrendszer lehet FAT vagy NTFS.

/exclude:fájlnév

A másolási műveletből kihagyja a megadott fájlban felsorolt fájlokat. A kihagyási fájl kihagyási mintákat is tartalmazhat (soronként egyet, és a helyettesítő karakterek nem támogatottak). Ha a fájlban található kihagyási minta egyezik a másolandó fájl elérési útvonalának bármely részével, a fájlt nem másolja át a parancs.

/y

Kikapcsolja a rákérdezéseket, amelyek a meglévő célfájlok felülírásának megerősítését kérik.

Az /y kapcsoló előre beállítható a COPYCMD környezeti változóban. Ez felülbírálható az /-y kapcsolóval a parancssorban. Alapértelmezés szerint átírás előtt a rendszer megerősítést kér, kivéve ha a copy parancs parancsfájlból kerül végrehajtásra.

Fájlok összefűzéséhez adjon meg egyetlen fájlnevet célként és az összefűzendő fájlokat forrásként (helyettesítő karaktereket vagy a fájl1+fájl2+fájl3 formátumot használva).

/-y

Bekapcsolja a rákérdezéseket, amelyek a létező célfájlok felülírásának megerősítését kérik.

/z

A hálózaton keresztül másol újraindítható üzemmódban. Ha a másolási folyamat közben megszakad a hálózati kapcsolat (például a kiszolgáló megszünteti a kapcsolatot), akkor a kapcsolat helyreállítása után folytatódik a másolás. Ennek a parancskapcsolónak a használatával a másolási folyamat százalékban kifejezett előrehaladása jelenik meg fájlonként.


Példák az Xcopy parancs használatára

Xcopy

Példák

Az A meghajtóban lévő lemezen található összes fájl és alkönyvtár (beleértve az üreseket is) átmásolásához a B meghajtóban lévő lemezre, írja be a következő parancsot:

xcopy a: b: /s /e

Az előző példában a rendszerfájlok és rejtett fájlok másolásához egészítse ki a parancsot a /h kapcsolóval:

xcopy a: b: /s /e /h

A \Jelentések könyvtárban található fájlok frissítéséhez az \Alapadatok könyvtár 1993. december 29-e óta megváltozott fájljaival, írja be a következőt:

xcopy \alapadatok \jelentések /d:12-29-93

A \Jelentések könyvtár tartalmának dátumtól független frissítéséhez írja be:

xcopy \alapadatok \jelentések /u

A fájlok listájának megtekintéséhez, amelyek az előző példa szerint át lennének másolva, írja be a következőt:

xcopy \alapadatok \jelentések /d:12-29-93 /l > xcopy.out

Az Xcopy.out fájlban az összes olyan fájl megjelenik, amely át lenne másolva.

A \Customer könyvtár és alkönyvtárainak átmásolásához a H: hálózati meghajtó \\Public\Address könyvtárába, és a csak olvasható attribútum megőrzéséhez, miközben minden, a H: meghajtón létrehozott fájl létrehozását jóvá kell hagyni, írja be a következőt:

xcopy \customer h:\public\address /s /e /k /p

Az előző parancsban annak biztosításához, hogy az xcopy parancs jóváhagyás nélkül létrehozza az \Address könyvtárat, ha az nem létezik, adja a parancshoz az /i kapcsolót:

xcopy \customer h:\public\address /s /e /k /p /i

Az xcopy parancs parancsfájlokban is használható másolásra, és hiba esetén a kilépési kódot az if parancs segítségével fel lehet dolgozni. A következő parancsfájl például helyettesítő paramétereket használ az xcopy parancs forrás- és célparamétereként:

@echo off
rem A COPYIT.BAT fájl átmásolja a forrásmeghajtón vagy
rem könyvtárban (%1) és az alkönyvtárakban található összes fájlt a cél-

rem meghajtóra vagy könyvtárba (%2)

xcopy %1 %2 /s /e

if errorlevel 4 goto memoria
if errorlevel 2 goto vege
if errorlevel 0 goto kilepes

:memoria
echo Nincs elég memória a fájlok átmásolásához,
echo vagy a meghajtó vagy szintaxis érvénytelen.
goto kilepes

:vege
echo Megnyomta a CTRL+C billentyűket a másolás befejezéséhez.
goto kilepes

:kilepes

A C:\Prgmcode könyvtárban található fájlok és alkönyvtárak átmásolásához a B meghajtóra, írja be a következőt:

copyit c:\prgmcode b:

A parancsértelmező behelyettesíti a C:\Prgmcode értéket a %1 és a B: értéket a %2 paraméter helyére, majd futtatja az xcopy parancsot az /e és /s kapcsolóval. Ha az xcopy parancs futása közben hiba történik, a parancsfájl lekérdezi a kilépési kódot és a megfelelő IF ERRORLEVEL utasítás által megadott címkére ugrik. A Windows 2000 megjeleníti a megfelelő üzenetet és kilép a parancsfájlból.


Megjegyzések az Xcopy parancshoz

Xcopy

Megjegyzések

A cél alapértelmezett értéke

Ha a cél paraméter nincs megadva az xcopy parancs a fájlokat az aktuális könyvtárba másolja.

A cél fájl vagy könyvtár

Ha a cél nem tartalmaz egy meglévő könyvtárnevet és nem fordított ferde vonal zárja le (\), az xcopy parancs a következő formátumú üzenetet jeleníti meg:

"Cél" fájlnevet vagy könyvtárnevet
határoz meg a célon?
(F = fájl, K = könyvtár)?

Az F megnyomásával a fájl(oka)t egy fájlba másolja. A K megnyomásával a fájl(oka)t egy könyvtárba másolja.

Az /i kapcsoló használatával elkerülhető ez a kérdés. Az /i kapcsoló használata esetén az xcopy parancs feltételezi, hogy a cél egy könyvtár, ha a forrás több fájlból áll vagy egy könyvtár.

A célfájlok archiválandó attribútumának beállítása az xcopy paranccsal

Az xcopy parancs az archiválandó attribútumot beállítva hozza létre a fájlokat, függetlenül attól, hogy a forrásfájl hasonló attribútuma be volt-e állítva vagy nem. A fájlattribútumokkal kapcsolatban további információt kaphat, ha a Kapcsolódó témakörök között az attrib parancsra kattint.

Az xcopy és a diskcopy parancsok összehasonlítása

Egy alkönyvtárstruktúrával rendelkező lemez átmásolásához egy eltérő formátumú lemezre, használja az xcopy parancsot a diskcopy parancs helyett. Mivel a diskcopy parancs a lemezt sávonként másolja, ehhez szükséges, hogy a forrás- és a céllemez ugyanolyan formátumú legyen. Az xcopy parancs használatához ez nem szükséges. Általában használja az xcopy parancsot, ha nem kell az egész lemezképet átmásolni.

Az xcopy parancs kilépési kódjai

Az alábbi lista az összes kilépési kódot és jelentésük rövid leírását tartalmazza:

0 | A fájlokat sikeresen átmásolta.
1 | Nem található másolandó fájl.
2 | A felhasználó a CTRL+C billentyűkombináció megnyomásával leállította az xcopy parancsot.
4 | Inicializációs hiba történt. Nincs elég memória, lemezterület, érvénytelen meghajtó vagy a parancssorban érvénytelen szintaxis lett megadva.
5 | Írási hiba a lemezen.

Az errorlevel paramétert az if paranccsal használva az xcopy kilépési kódjai feldolgozhatók egy parancsfájlban. Kattintson a Kapcsolódó témakörök között a Példák elemre.