Biztonsági másolat készítése és az adatok visszaállítása

A Biztonsági mentés egy olyan grafikus program, amelynek segítségével felhasználói adatokról készíthet biztonsági másolatokat, illetve felhasználói adatokat állíthat vissza.

  • Az adatok biztonsági másolatának készítése előtt olvassa el a Feladatlistákat.
  • Az adatok biztonsági másolatának létrehozásával és az adatok visszaállításával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Feladatlisták

  • Feladatlista: Biztonsági másolat készítése adatokról
  • Feladatlista: Adatok visszaállítása


Feladatlista: Biztonsági másolat készítése adatokról

Lépés | Hivatkozás
Tekintse át a kulcsfontosságú fogalmakat és készüljön fel az adatok biztonsági másolatának elkészítésére. | Fogalmak
Ellenőrizze, hogy a Biztonságimásolat-felelősök csoportjának vagy a Rendszergazdák csoportjának tagjaként jelentkezett-e be. | Felhasználó hozzáadása a Biztonságimásolat-felelősök csoporthoz
Ellenőrizze, hogy tud-e csatlakozni a többi számítógép minden olyan közös mappájához, amiről biztonsági másolatot kell készítenie. Megjegyzés: nem készíthet biztonsági másolatot másik számítógép rendszerleíró adatbázisáról vagy más tartományvezérlőkről. |
Ha külső tárolóeszközt használ, ellenőrizze, hogy az szerepel-e a hardverkompatibilitási listán. A külső tárolóeszköznek közvetlenül a biztonsági másolatot készítő, bekapcsolt állapotban lévő számítógéphez kell csatlakoznia. | A hardverkompatibilitás listát tartalmazó Microsoft webhely (http://www.microsoft.com/)
Tegye be a kívánt szalagot a szalagos meghajtóba. Ha lemezmeghajtóra készít biztonsági másolatot, ellenőrizze, hogy elegendő hely áll-e a rendelkezésére. |
Ha adathordozó-készletre készít biztonsági másolatot, ellenőrizze, hogy fut-e a távtároló szolgáltatás. | A távtároló szolgáltatás telepítése
Ha biztonságimásolat-készítést ütemez, ellenőrizze, hogy futnak-e az Ütemezett feladatok. | Az Ütemezett feladatok használata
Ha munkaidőben készít biztonsági másolatot, kérje meg a felhasználókat, hogy zárjanak be minden olyan fájlt, amiről biztonsági másolatot készít, illetve amit visszaállít. |
Ha a fájlok biztonsági másolatát automatikusan szeretné létrehozni, használja a Biztonságimásolat-készítő varázslót. | Biztonsági másolat készítése fájlokról a Biztonságimásolat-készítő varázsló segítségével
Amennyiben saját kezűleg kívánja elkészíteni a fájlok biztonsági másolatát, hozzon létre biztonságimásolat-készítő feladatot a Biztonsági másolat lapon. | Biztonsági másolat készítése fájlba vagy szalagra
Ha a fájlok biztonsági másolatát automatikusan szeretné létrehozni, ütemezze a biztonságimásolat-készítést. | Biztonsági másolat készítésének ütemezése


Feladatlista: Adatok visszaállítása

Lépés | Hivatkozás
Ellenőrizze, hogy a Biztonságimásolat-felelősök vagy a Rendszergazdák csoportjának tagjaként jelentkezett-e be. | Felhasználó hozzáadása a Biztonságimásolat-felelősök csoporthoz
Ellenőrizze, hogy tud-e csatlakozni a többi számítógép minden helyreállítandó közös mappájához. |
Tegye be a kívánt szalagot a szalagos meghajtóba. |
Ha adathordozó-készletről állít vissza, ellenőrizze, hogy fut-e a távtároló szolgáltatás. | A távtároló szolgáltatás telepítése
Ha a rendszerállapotot állítja vissza, a kiszolgálót Címtárszolgáltatások helyreállítási módja üzemmódban indítsa el. | A Windows 2000 indítása csökkentett módban, kattintson a Címtárszolgáltatások helyreállítási módja elemre
A fájlok automatikus visszaállításához használja a Visszaállító varázslót. | Fájlok visszaállítása a Visszaállító varázsló segítségével
Fájlok kézi visszaállításához kattintson a Visszaállítás fülre, és jelölje ki a visszaállítani kívánt fájlokat. | Fájlok visszaállítása fájlból vagy szalagról


Gyakorlati tanácsok

  • Biztonságimásolat-készítési és -visszaállítási stratégiák kidolgozása és kipróbálása
    Adatvesztés esetén csakis egy jó terv biztosíthatja az adatok gyors visszaállítását.
  • A megfelelő személyzet betanítása
    Minimális és közepes védelemmel rendelkező hálózatokban külön felhasználó kapjon biztonságimásolat-készítési jogosultságokat és egy másik felhasználó visszaállítási jogosultságokat. A visszaállítási jogosultságokkal rendelkező személyzetet be kell tanítani minden visszaállítási feladat elvégzésére arra az esetre, ha a rendszergazda nem lenne elérhető.

    Jelentős védelemmel rendelkező hálózatban csak a rendszergazdáknak szabad visszaállítani a fájlokat.

  • Biztonsági másolat készítése a teljes kötetről
    Készítsen biztonsági másolatot a teljes kötetről, így felkészülhet a lemez meghibásodásának igen valószínűtlen esetére is. Gazdaságosabb a teljes kötet visszaállítását egyetlen művelettel elvégezni.
  • Biztonsági másolat készítése címtárszolgáltatásokról
    Minden esetben készítsen biztonsági másolatot a tartományvezérlőn található címtárszolgáltatási adatbázisról, ezzel megelőzheti a felhasználói fiókok és biztonsági információk elvesztését.
  • Biztonsági másolatok naplózása
    Minden esetben készítsen és nyomtasson biztonságimásolat-naplót a biztonsági másolatokról. A konkrét fájlok könnyebben megtalálhatók, ha nyilvántartást vezet a naplókról. A biztonságimásolat-napló segítséget jelenthet az adatok visszaállításakor; a naplót nyomtathatja vagy szövegszerkesztőben olvashatja. Ugyanakkor, ha a biztonságimásolat-készlet katalógusa meghibásodik, a nyomtatott napló segítségével is megkereshet egy adott fájlt.
  • Példányok megőrzése
    Őrizzen három adathordozó-példányt. Legalább az egyik példányt őrizze a telephelytől távol, megfelelően ellenőrzött környezetben.
  • Próba-visszaállítás
    Rendszeres próba-visszaállításokkal ellenőrizze a fájlok biztonsági másolatainak megfelelőségét. A próba-visszaállítások a szoftveres ellenőrzések során nem jelentkező hardverproblémákat is feltárhatnak.
  • Eszközök és adathordozók védelme
    Biztosítania kell mind a tárolóeszközök, mind a biztonsági másolatok adathordozóinak védelmét. Lopott adathordozón tárolt adatok előhívhatók, ha az adatokat egy olyan kiszolgálón állítják vissza, amelynek rendszergazdája az illető.


Útmutató

  • Biztonsági másolat készítése adatokról
  • Adatok visszaállítása
  • Biztonsági másolatok beállításai
  • Adathordozók karbantartása
  • Biztonságimásolat-felelős hozzáadása és felhasználói jogosultságok beállítása
  • Rendszerjavítás és -helyreállítás


Biztonsági másolat készítése adatokról

  • Biztonsági másolat készítése fájlba vagy szalagra
  • Biztonsági másolat készítése rendszerállapot-adatokról
  • Biztonsági másolat készítése fájlokról a Biztonságimásolat-készítő varázsló segítségével
  • Biztonsági másolatok ütemezése
  • Biztonsági másolat készítése Microsoft Exchange kiszolgálón tárolt fájlokról


Biztonsági másolat készítése fájlokról fájlba vagy szalagra

  2. Kattintson a Biztonsági másolat fülre, majd a Feladat menü Új parancsára.
  3. A Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában kattintással jelölje be azon fájlok és mappák bal oldalán levő jelölőnégyzetet, amelyekről biztonsági másolatot akar készíteni.
  4. A Biztonsági másolat helye listában hajtsa végre az alábbi műveletek egyikét:
    • Válassza a Fájl elemet, ha biztonsági másolatként fájlt akar készíteni a fájlokról és mappákról. Ha a számítógépen nincs szalagos egység telepítve, akkor ez az alapértelmezett beállítás.
    • Válasszon egy szalagos egységet, ha szalagra akar biztonsági másolatot készíteni a fájlokról és mappákról.
  5. A Biztonsági másolat adathordozója vagy fájlneve beviteli mezőben hajtsa végre az alábbi műveletek egyikét:
    • Ha fájlba készít biztonsági másolatot a fájlokról és mappákról, akkor írja be a biztonságimásolat-fájl (.bkf) elérési útvonalát, vagy a fájl megkereséséhez kattintson a Tallózás gombra.
    • Ha szalagra készít biztonsági másolatot a fájlokról és mappákról, akkor válassza ki a használni kívánt szalagot.
  6. Az Eszközök menü Beállítások parancsára kattintás után válassza ki a biztonsági másolat kívánt beállításait, például a biztonsági másolat típusát és a naplófájl típusát. A biztonsági másolat beállításának befejezése után kattintson az OK gombra.
  7. Kattintson a Biztonsági másolat indítása gombra, majd végezzen el minden szükséges módosítást a Biztonságimásolat-készítési feladat információi párbeszédpanelen.
  8. Ha speciális beállításokat (például adatellenőrzést vagy hardveres tömörítést) akar használni a biztonsági másolat készítéséhez, akkor kattintson a Speciális gombra. A biztonsági másolat speciális beállításainak megadása után kattintson az OK gombra.
  9. A biztonsági mentés elindításához kattintson a Biztonsági másolat indítása gombra.

Fontos

  • A Biztonsági másolat segédprogrammal FAT- vagy NTFS-köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat FAT- vagy Windows NT 4.0 rendszerben használt NTFS-köteten való helyreállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az Eszközök menü Biztonságimásolat-készítő varázsló parancsával elindítható Biztonságimásolat-készítő varázslóval is készíthető biztonsági másolat a fájlokról és mappákról.
  • Ha a rendszerállapot-adatok szalagra történő biztonsági mentésekor a Biztonsági mentés segédprogram azt jelzi, hogy nincs használható adathordozó, akkor a Cserélhető tároló segédprogrammal a szalag hozzáadható a biztonsági másolat adathordozó-készlethez. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ha biztonsági másolatot akar készteni a rendszerleíró adatbázist és az Active Directory címtárszolgáltatás adatbázisát tartalmazó rendszerállapot-adatokról, akkor a Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában válassza a Rendszer állapota elemet.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • A biztonsági másolat fájlok általában .bkf kiterjesztéssel rendelkeznek, de kiterjesztésük tetszés szerint módosítható.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági mentést készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának “Biztonsági másolat használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és visszaállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Ha az adathordozók kezelésére a Cserélhető tároló segédprogramot használja vagy az adatok tárolására a Távtároló segédprogramot használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági másolatot kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távtároló és a Cserélhető tároló segédprogram összes adatának visszaállíthatóságát.

Kapcsolódó témakörök


Biztonsági mentés készítése a rendszerállapot-adatokról

  2. Kattintson a Biztonsági másolat fülre, majd a Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában jelölje be a Rendszer állapota elem melletti jelölőnégyzetet. E beállítás hatására a rendszer a többi kiválasztott adattal együtt biztonsági másolatot készít a rendszerállapot-adatokról is.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói jogokkal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatokról az Eszközök menü Biztonságimásolat-készítő varázsló parancsával futtatható Biztonságimásolat-készítő varázslóval is készíthető biztonsági másolat.
  • Ha a rendszerállapot-adatok szalagra történő biztonsági mentésekor a Biztonsági mentés segédprogram azt jelzi, hogy nincs használható adathordozó, akkor a Cserélhető tároló segédprogrammal a szalag hozzáadható a Biztonsági mentés segédprogram által használható adathordozó-készlethez. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Ha biztonsági mentést készít a rendszerállapot-adatokról, akkor a rendszer a rendszerleíróadatbázis-fájlokat elmenti a rendszergyökér/repair/regback mappába is. A rendszerleíróadatbázis-fájlok megsérülése vagy véletlenszerű törlése esetén a rendszerállapot-adatok teljes visszaállítása nélkül ezeknek a fájloknak a segítségével állítható helyre a rendszerleíró adatbázis. A rendszerleíró adatbázis helyreállításának ez a módja csak tapasztalt felhasználók számára javasolt.


Biztonsági másolat készítése fájlokról a Biztonságimásolat-készítő varázsló segítségével

  2. A biztonsági másolatot készítő varázsló elindításához kattintson az Üdvözöljük lap Biztonságimásolat-készítő varázsló gombjára.

    3. A varázsló utasításait követve jelölheti ki, hogy miről, hová és milyen egyéb biztonságimásolat-készítési szolgáltatásokkal kíván biztonsági másolatot készíteni.

Megjegyzések

  • A fájlok és mappák biztonsági másolatának elkészítéséhez rendszergazdaként vagy biztonságimásolat-felelősként kell bejelentkeznie. A hozzáférési engedélyekkel vagy a felhasználói jogosultságokkal kapcsolatos további információkért kattintson a Kapcsolódó témakörök hivatkozásra.


A biztonsági mentés ütemezése

  2. Kattintson a Biztonsági másolat fülre, majd a Feladat menü Új parancsára.
  3. A Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában jelölje be azon fájlok és mappák bal oldalán levő jelölőnégyzetet, amelyekről biztonsági másolatot akar készíteni.
  4. A Biztonsági másolat helye listában válasszon egy szalagos eszközt vagy a Fájl elemet, majd a Feladat menü Kijelölés mentése parancsára kattintással mentse el a kiválasztott fájlokat és mappákat.
  5. A Biztonsági másolat adathordozója vagy fájlneve beviteli mezőbe írja be a biztonságimásolat-fájl elérési útját és nevét, vagy válasszon egy szalagot.
  6. Az Eszközök menü Beállítások parancsára kattintás után válassza ki a biztonsági másolat kívánt beállításait, például a biztonsági másolat típusát, és a naplófájl típusát. A biztonsági másolat beállításának befejezése után kattintson az OK gombra.
  7. Kattintson a Biztonsági másolat indítása gombra, és végezzen el minden szükséges módosítást a Biztonságimásolat-készítési feladat információi párbeszédpanelen.
  8. Ha speciális beállításokat (például adatellenőrzést vagy hardveres tömörítést) akar használni a biztonsági másolat készítéséhez, akkor kattintson a Speciális gombra. A biztonsági másolat speciális beállításainak befejezése után kattintson az OK gombra.
  9. A Biztonságimásolat-készítési feladat információi párbeszédpanelen kattintson az Ütemezés elemre.
  10. A Fiókinformáció beállítása párbeszédpanelen írja be annak a felhasználónak a nevét és jelszavát, akinek a neve alatt az ütemezett biztonsági mentést futtatni akarja.
  11. Az Ütemezett feladat beállításai párbeszédpanel Feladatnév beviteli mezőjébe írja be az ütemezett biztonságimásolat-feladat nevét, kattintson a Tulajdonságok gombra és állítsa be az ütemezett biztonságimásolat-készítés dátumával, időpontjával és gyakoriságával kapcsolatos paramétereket. A beállítások megadása után kattintson az OK, majd újból az OK gombra.

Fontos

  • A Biztonsági másolat segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való helyreállításakor a engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagra történő biztonsági mentés ütemezésekor a Cserélhető tároló segédprogrammal ellenőrizze, hogy a Biztonságimásolat adathordozó-készletben használható-e a szalag. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A biztonságimásolat-készítés csak akkor ütemezhető, ha fut a Feladatütemező szolgáltatás. Ehhez nyissa meg a parancssor ablakot, és írja be a következő parancsot: net start schedule. A szolgáltatások a Számítógépkezelés segédprogram Szolgáltatások csoportjában is elindíthatók, leállíthatók, és az állapotuk is megjeleníthető.
  • Ha biztonsági másolatot akar készteni a rendszerleíró adatbázist és az Active Directory címtárszolgáltatást tartalmazó rendszerállapot-adatokról, akkor a Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában válassza a Rendszer állapota elemet.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Az Ütemezett feladat beállításai párbeszédpanelen a Törlés gombra kattintással törölhető az ütemezett biztonsági mentés a Feladatütemező szolgáltatásból.
  • A biztonságimásolat-készítés beütemezése után az ütemezés módosításához kattintson a Feladatok ütemezése fülre, majd kattintson a naptáron látható biztonságimásolat-ikonra.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági másolatot készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának “Biztonsági mentés használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és visszaállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Ha az adathordozók kezelésére a Cserélhető tároló alkalmazás használja vagy az adatok tárolására a Távtároló alkalmazást használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági másolatot kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távtároló és a Cserélhető tároló segédprogram összes adatának visszaállíthatóságát.


Biztonsági másolat készítése Microsoft Exchange Serveren tárolt fájlokról

  2. Kattintson a Biztonsági másolat fülre, és a Jelölje be azokat a meghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában jelölje be a Microsoft Exchange elem melletti jelölőnégyzetet.
  3. A Kiszolgáló beviteli mezőbe írja be annak a Microsoft Exchange Servernek a nevét, amelyről biztonsági másolatot akar készíteni. A nevet két fordított ferde vonalnak kell megelőznie (például \\Budapest).
  4. Kattintson a Csatlakozás szervezethez elemre, majd az OK gombra.

Fontos

  • A Biztonsági másolat segédprogrammal FAT- vagy NTFS-köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat FAT-vagy Windows NT 4.0 rendszerben használt NTFS-köteten való helyreállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A fentiekben bemutatott eljárás és a hozzáfűzött megjegyzések az 5.5-ös vagy korábbi verzióira érvényesek.
  • Ha a rendszerállapot-adatok szalagra történő biztonsági mentésekor a Biztonsági mentés segédprogram azt jelzi, hogy nincs használható adathordozó, akkor a Cserélhető tároló segédprogrammal a szalag hozzáadható a biztonsági másolat adathordozó-készlethez. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Microsoft Exchange Server adatainak visszaállításakor a rendszer leállítja az Information Store és a Directory szolgáltatást. A visszaállítás befejezése után a szolgáltatások elindításához kattintson az Eszközök menü Microsoft Exchange parancsára, a Szolgáltatás indítása gombra, válassza a Directory vagy Information Store elemet, majd kattintson az OK gombra.


Adatok visszaállítása

  • Fájlok visszaállítása fájlból vagy szalagról
  • Rendszerállapot-adatok visszaállítása
  • Fájlok visszaállítása a Visszaállító varázsló segítségével
  • Fájlok visszaállítása Microsoft Exchange kiszolgálón


Fájlok visszaállítása fájlból vagy szalagról

  2. A Visszaállítás lapon a Jelölje be az összes visszaállítandó meghajtót, mappát és fájlt listában a fájl vagy mappa bal oldalán található jelölőnégyzet bejelölésével válassza a visszaállítani kívánt fájlokat és mappákat.
  3. A Visszaállítás helye listában hajtsa végre az alábbi műveletek egyikét:
    • Válassza az Eredeti hely elemet, ha a biztonsági másolatban levő fájlokat és mappákat a biztonsági másolat elkészítésekor elfoglalt eredeti helyükre akarja visszaállítani. Folytassa az 5. lépéssel.
    • Kattintson az Alternatív hely elemre, ha a biztonsági másolatban levő fájlokat és mappákat egy adott mappába akarja visszaállítani. Ez a beállítás megőrzi a visszaállított adatok eredeti mappastruktúráját, de az összes mappa és almappa a megadott új mappában jelenik meg.
    • Kattintson az Egy mappa elemre, ha a biztonsági másolatban levő fájlokat és mappákat egy adott mappába akarja visszaállítani. Ez a beállítás nem tartja meg a visszaállított adatok eredeti mappastruktúráját, mivel az összes fájl a megadott új mappában jelenik meg.
  4. Az Alternatív hely vagy az Egy mappa elem kiválasztása esetén írja be a mappa elérési útvonalát a Másik hely beviteli mezőbe, vagy a mappa megkereséséhez kattintson a Tallózás gombra.
  5. Kattintson az Eszközök menü Beállítások parancsára, a Visszaállítás fülre, majd hajtsa végre az alábbi műveletek egyikét.
    • Válassza a Ne cserélje le a számítógépen lévő fájlt választókapcsolót, ha nem akarja, hogy a visszaállítás során a rendszer átmásolja a merevlemezen már meglevő fájlokat.
    • Válassza a Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsolót, ha a visszaállítás során a lemezen levő régebbi fájlokat le akarja cserélni a biztonsági másolatban levő újabb fájlokkal.
    • Válassza a Mindig cserélje le a számítógépen lévő fájlt választókapcsolót, ha a visszaállítás során a biztonsági másolatban levő fájlokkal minden esetben felül akarja írni a lemezen levő fájlokat.
    • A visszaállítás beállításainak érvényesítéséhez kattintson az OK gombra.
  6. Kattintson a Visszaállítás indítása gombra.
  7. Ha módosítani akarja a speciális visszaállítási beállításokat (például biztonsági beállítások, Cserélhető tároló adatbázisának és a csatlakozási pont adatainak a visszaállítását), akkor kattintson a Speciális gombra. A visszaállítás speciális beállításainak megadása után kattintson az OK gombra.
  8. A visszaállítás elindításához kattintson az OK gombra.

Vigyázat

  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok visszaállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági másolatban levő adatokkal. A rendszerállapot-adatok másik mappába történő visszaállításakor a rendszer csak a rendszerleírófájlokat, a SYSVOL könyvtárfájlokat, a fürtadatbázis-leíró fájlokat és a rendszerindító fájlokat állítja vissza a másik mappába. Másik mappába történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.
  • A Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsoló kiválasztása esetén előfordulhat, hogy a rendszer módosítja a lemezen levő néhány vagy összes fájlt.
  • A Mindig cserélje le a számítógépen lévő fájlt választókapcsoló beállítása esetén előfordulhat adatvesztés, ha a jelenleg módosítás alatt levő fájl szerepel a biztonsági másolatban.
  • A Biztonsági mentés segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való visszaállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • Csak a rendszergazdák vagy biztonságimásolat-felelősök állíthatják vissza a fájlokat és a mappákat. az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagról történő visszaállítás esetén a visszaállítási művelet végrehajtása előtt frissíteni kell a lemezen tárolt katalógust. A katalógus frissítésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az Eszközök menü Visszaállító varázsló parancsával elindítható Visszaállító varázslóval is elvégezhető a fájlok visszaállítása.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások visszaállító módban állíthatók vissza. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory címtárszolgáltatás adatbázisának visszaállítását.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.


A rendszerállapot-adatok visszaállítása

  2. Kattintson a Visszaállítás fülre, majd a Jelölje be az összes visszaállítandó meghajtót, mappát és fájlt: listában jelölje be a Rendszer állapota elem melletti jelölőnégyzetet. E beállítás hatására a rendszer a többi kiválasztott adattal együtt visszaállítja a rendszerállapot-adatokat is.

Vigyázat

  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok visszaállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági mentésben szereplő adatokkal. A rendszerállapot-adatok másik mappába történő visszaállításakor a rendszer csak a rendszerleírófájlokat, a SYSVOL könyvtárfájlokat, a fürtadatbázis-leíró fájlokat és a rendszerindító fájlokat állítja vissza a másik mappába. Másik mappába történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.

Megjegyzések

  • Csak a rendszergazdák vagy biztonságimásolat-felelősök állíthatják vissza a fájlokat és a mappákat. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagról történő visszaállítás esetén a visszaállítási művelet végrehajtása előtt frissíteni kell a lemezen tárolt katalógust. A katalógus frissítésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az Eszközök menü Visszaállító varázsló parancsával elindítható Visszaállító varázslóval is visszaállíthatók a rendszerállapot-adatok.
  • Tartományvezérlő rendszerállapot-adatainak visszaállításakor meg kell adni, hogy mérvadó visszaállítást vagy nem mérvadó visszaállítást akar végrehajtani. A nem mérvadó visszaállítás a tartományvezérlő rendszerállapot-adatainak alapértelmezett visszaállítási módja. Ebben a módban a rendszerállapot-adatok más tartományvezérlővel szinkronizált összetevőit (például az Active Directory címtárszolgáltatást vagy a fájlreplikációs szolgáltatást (így a SYSVOL könyvtárat)) az adatok visszaállítása után a rendszer a replikálás révén naprakésszé frissíti. Ha például az utolsó biztonsági másolat egy héttel korábban készült, és a rendszerállapot-adatokat az alapértelmezett módon (nem mérvadó) állítja vissza, akkor a biztonsági mentést követő módosításokat a rendszer replikálni fogja a többi tartományvezérlőről.

    Bizonyos esetekben nem szükséges az utolsó biztonsági mentést követő módosítások replikálása. Azaz lehetnek olyan kiszolgálók, amelyeknek a biztonsági másolatban szereplő állapottal pontosan egyező állapotban kell lenniük. Ez az állapot mérvadó visszaállítással érhető el.

    Ha például az Active Directory címtárszolgáltatásból véletlenül törölt felhasználókat, csoportokat vagy szervezeti egységeket, vissza akarja állítani és többszörözni akarja a törölt objektumokat, akkor mérvadó visszaállítást kell végrehajtania. Ehhez az adatok visszaállítását követően, de a tartományvezérlő újraindítását megelőzően az Ntdsutil segédprogramot kell futtatni. A segédprogram lehetővé teszi az objektumok központiként való megjelölését, ami garantálja, hogy minden replikált vagy továbbított adatot a rendszer megfelelően replikáljon vagy továbbítson a szervezeten belül. Az Ntdsutil parancssori segédprogram a parancssorból futtatható. Az Ntdsutil segédprogram súgója az ntdsutil /? parancs beírásával a parancssorban is használható.

  • Tartományvezérlőn a rendszerállapot-adatok csak egy speciális csökkentett módban, az ún. Címtárszolgáltatások helyreállító módban állíthatók vissza. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory címtárszolgáltatás adatbázisának visszaállítását. A számítógép csökkentett módban való elindításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.


Fájlok visszaállítása a Visszaállító varázsló segítségével

  2. A Visszaállító varázsló elindításához kattintson az Üdvözöljük lap Visszaállító varázsló gombjára.
  3. A varázsló utasításait követve jelölheti ki, hogy mit, hová és milyen egyéb visszaállítási szolgáltatásokkal kíván visszaállítani.

Megjegyzések

  • Fájlok és mappák visszaállításához rendszergazdaként vagy biztonságimásolat-felelősként kell bejelentkeznie. A hozzáférési engedélyekkel vagy a felhasználói jogosultságokkal kapcsolatos további információkért kattintson a Kapcsolódó témakörök hivatkozásra.


Microsoft Exchange Server fájlok visszaállítása

  2. A Visszaállítás lapon a Jelölje be az összes visszaállítandó meghajtót, mappát és fájlt listában válassza a visszaállítani kívánt Microsoft Exchange adatokat.
    3. Kattintson a Visszaállítás indítása gombra.

    Megjelenik a Microsoft Exchange visszaállítása párbeszédpanel.

  3. Ha az Adadttároló (Infomation Store) adatait állítja vissza, akkor a Visszaállítás helye beviteli mezőbe írja be annak a kiszolgálónak a nevét, amelyre az adatokat vissza akarja állítani.

    4. Megjegyzés

    • Ha a kijelölt kiszolgáló nem az a kiszolgáló, amelyről eredetileg a biztonsági másolat készült, akkor be kell jelölnie a Minden meglévő adat törlése jelölőnégyzetet.
  4. Adja meg a többi szükséges beállítást, majd kattintson az OK gombra.

Fontos

  • A Biztonsági mentés segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való visszaállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • Csak a rendszergazdák vagy biztonságimásolat-felelősök állíthatják vissza a fájlokat és a mappákat. az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagról történő visszaállítás esetén a visszaállítási művelet végrehajtása előtt frissíteni kell a lemezen tárolt katalógust. A katalógus frissítésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A fentiekben bemutatott eljárás és a hozzáfűzött megjegyzések a Microsoft Exchange 5.5-ös, vagy korábbi verzióira érvényesek.
  • A Microsoft Exchange Server adatainak visszaállításakor a rendszer leállítja az Information Store és a Directory szolgáltatást. A visszaállítás befejezése után a szolgáltatások elindításához kattintson az Eszközök menü Microsoft Exchange parancsára, a Szolgáltatás indítása gombra, válassza a Directory vagy Information Store elemet, majd kattintson az OK gombra.


Biztonsági másolatok beállításai

  • Biztonsági másolatok beállításai
  • Biztonsági másolat típusának megadása
  • Fájltípusok kihagyása a biztonsági másolatból
  • Biztonsági másolatok egyéb beállításai
  • Visszaállítási beállítások
  • Egyéb visszaállítási beállítások


A biztonsági mentés beállításainak megadása

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. Az Általános lapon állítsa be a kívánt beállításokat.

Megjegyzések

  • A Kiválasztási információk számítása biztonsági másolat készítése és visszaállítási műveletek előtt jelölőnégyzet bejelölésekor a biztonsági mentés vagy visszaállítás során a rendszer megbecsüli a biztonsági mentésben vagy a visszaállításban szereplő fájlok számát és méretét. Ezeket az adatokat a rendszer a biztonsági mentés vagy visszaállítás megkezdése előtt kiszámítja, és megjeleníti.
  • A katalógusok használata a visszaállítási katalógusok készítésének felgyorsításához jelölőnégyzet bejelölése azt jelzi, hogy a visszaállítási műveletekhez adathordozón tárolt katalógussal kívánja létrehozni a lemezen tárolt katalógust. Így hozható létre a leggyorsabban a lemezen tárolt katalógus. Ne jelölje be ezt a jelölőnégyzetet, ha több szalagról kívánja visszaállítani az adatokat, és hiányzik az adathordozón tárolt katalógust tároló szalag, vagy sérült adathordozóról kíván adatokat visszaállítani. A Biztonsági mentés segédprogram átvizsgálja a teljes biztonságimásolat-készletet (illetve az abból elérhető részt), és létrehozza az adathordozón tárolt katalógust. Ez több óráig is eltarthat, ha nagy a biztonságimásolat-készlet.
  • Az Adatok ellenőrzése a biztonsági másolat befejezése után jelölőnégyzet bejelölése esetén a rendszer ellenőrzi, hogy a biztonsági márolatban szereplő és a merevlemezen levő eredeti adatok megegyeznek-e. Ha nem, akkor hibás lehet a biztonsági mentéshez használt adathordozó vagy fájl. Ilyenkor másik adathordozót kell használni, vagy másik fájlt kell kijelölni, majd újból futtatni a biztonsági mentést.
  • A Biztonsági másolat készítése a csatlakoztatott meghajtók tartalmáról jelölőnégyzet bejelölése esetén a rendszer biztonsági másolatot készít a csatlakoztatott meghajtón tárolt adatokról. A jelölőnégyzet bejelölése esetén egy csatlakoztatott meghajtó biztonsági mentésekor a rendszer biztonsági másolatot készít a csatlakoztatott meghajtón tárolt adatokról. Ha nem jelöli be a jelölőnégyzetet és biztonsági mentést készít a csatlakoztatott meghajtóról, akkor a rendszer csak a csatlakoztatott meghajtó elérési útvonalát szerepelteti a biztonsági másolatban.
  • A Figyelmeztetési üzenet megjelenítése a biztonsági másolat indításakor, ha a cserélhető tároló vezérlője nem fut jelölőnégyzet bejelölése esetén a Biztonsági mentés segédprogram elindításakor megjelenik egy párbeszédpanel, ha nem fut a Cserélhető tároló beépülő modul. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha az adatokról elsőként szalagra, vagy a Cserélhető tároló beépülő modullal kezelhető adathordozóra készít biztonsági másolatot, akkor jelölje be ezt a jelölőnégyzetet.
  • A Figyelmeztetési üzenet megjelenítése a biztonsági másolat indításakor, ha van szabad kompatibilis import-adathordozó jelölőnégyzet bejelölése esetén a Biztonsági mentés segédporgram elindításakor megjelenik egy párbeszédpanel, ha az import adathordozó-készletben egy új adathordozó áll rendelkezésre. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha az adatokról elsőként szalagra, vagy a Cserélhető tároló beépülő modullal kezelhető adathordozóra készít biztonsági másolatot, akkor jelölje be ezt a jelölőnégyzetet. A Cserélhető tároló beépülő modullal és az adathordozó-készletekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Figyelmeztetési üzenet megjelenítése új adathordozó behelyezésekor a cserélhető tároló vezérlőjébe jelölőnégyzet bejelölése esetén megjelenik egy párbeszédpanel, ha a Cserélhető tároló beépülő modul új adathordozót talál. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha az adatokról elsőként szalagra, vagy a Cserélhető tároló beépülő modullal kezelhető adathordozóra készít biztonsági másolatot, akkor jelölje be ezt a jelölőnégyzetet.
  • Az új import-adathordozók mozgatása a biztonsági másolat sorba minden esetben jelölőnégyzet bejelölése esetén a rendszer a Cserélhető tároló beépülő modul által talált új adathordozót automatikusan áthelyezi a biztonsági másolat adathordozó-készletbe. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha a Cserélhető tároló beépülő modullal kezeli az adathordozókat, és csak a Biztonsági mentés segédprogram számára kívánja elérhetővé tenni az összes új adathordozót, akkor jelölje be ezt a jelölőnégyzetet.


A biztonsági másolat típusának beállítása

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. A Biztonsági másolat típusa lapon a Biztonsági másolat alapértelmezett típusa listában válassza ki, milyen típusú biztonsági másolatot akar készíteni.

Megjegyzések

  • Ötféle biztonsági másolat készíthető: másolás, napi, különbségi, növekményes és normál. A biztonsági másolat típusaival kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Fájltípusok kizárása a biztonsági mentésből

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. A Kivételfájlok lapon hajtsa végre az alábbi műveletek egyikét:
    • A Kivétel az összes felhasználó számára listában kattintson az Új hozzáadás gombra, ha az összes felhasználó tulajdonában levő fájlokat akar kizárni a biztonsági mentésből.
    • A Kivétel a következő felhasználó számára listában kattintson az Új hozzáadása gombra, ha csak az ÖN tulajdonában levő fájlokat akar kizárni a biztonsági mentésből.
  4. A Kivételfájlok hozzáadása párbeszédpanelen hajtsa végre az alábbi műveletek egyikét:
    • Ha egy regisztrált fájltípust akar kizárni, akkor a Regisztrált fájltípusok listában kattintson az adott fájltípusra.
    • Ha egy egyedi fájltípust akar kizárni, akkor az Egyéni fájlmaszk beviteli mezőbe írjon be egy pontot, majd az egy-, két- vagy hárombetűs fájlkiterjesztést.
  5. Ha csak egy adott mappára vagy merevlemez-meghajtóra akarja korlátozni a fájltípus kizárását, akkor az Alkalmazás erre az elérési útra beviteli mezőbe írja be az elérési útvonalat, majd kattintson az OK gombra.

Megjegyzések

  • Ha a fájlok kizárását egy adott eléréséi útra (mappára) korlátozza, akkor a korlátozás az elérési útvonalon található összes almappára is érvényes lesz, ha nem törli Az alkönyvtárakra is jelölőnégyzetet.
  • A biztonságimásolat-készletből fájl kizárásának módja módosítható. Ehhez a Kivétel az összes felhasználó számára vagy a Kivétel a következő felhasználó számára listában kattintson a fájlra, majd a Szerkesztés gombra. Megjelenik a Kivételfájlok hozzáadása párbeszédpanel.


A biztonsági mentés speciális beállításainak megadása

  2. Kattintson a Biztonsági mentés fülre, majd válassza ki azokat a fájlokat és mappákat, amelyekről biztonsági mentést akar készíteni.
  3. Kattintson a Biztonsági másolat indítása gombra.
  4. A Biztonságimásolat-készítési feladat információi párbeszédpanelen kattintson a Speciális gombra.
  5. Adja meg a biztonsági mentés speciális beállításait, majd kattintson az OK gombra. Az egyes beállítások leírása a Megjegyzések részen található.

Megjegyzések

  • A Biztonsági másolat a távtárolóban lévő adatokról elem kiválasztásakor a rendszer biztonsági mentést készít a Távtároló segédprogram által használt adatokról. E beállítás kiválasztásakor a Távtároló segédprogram helyfoglaló fájlokról biztonsági mentést készít a rendszer. Ha nem választja ezt a beállítás, akkor nem készül biztonsági mentést a Távtároló segédprogram helyfoglaló fájlokról. A Távtároló segédprogram adatai csak Windows 2000 rendszeren használt NTFS-kötetre állíthatók helyre.
  • Az Adatok ellenőrzése a biztonsági másolat készítése után beállítás választása esetén a rendszer ellenőrzi, hogy a biztonsági mentésben szereplő adatok teljesen megegyeznek-e az eredeti adatokkal. Ez jelentősen megnövelheti a biztonsági mentés végrehajtásához szükséges időt.
  • Az Adatok tömörítése lemeztakarékosság céljából, ha lehetséges beállítás kiválasztása esetén a rendszer a biztonsági mentés közben tömöríti az adatokat, így több adat menthető a szalagra. Általában csak a szalagos meghajtók képesek a tömörítésre. Ha ez a beállítás nem használható, akkor nem kapcsolódik szalagos meghajtó a számítógéphez, vagy a szalagos meghajtó nem képes adattömörítésre.
  • Az Automatikus biztonsági másolat a rendszer védett fájljairól a rendszerállapottal együtt beállítás választása esetén a rendszer a rendszerállapot-adatokhoz tartozó rendszerindító fájlokon kívül biztonsági mentést készít a rendszergyökér könyvtárban található rendszerfájlokról is. Ez a beállítás jelentősen megnöveli a biztonsági másolatok méretét. Ha például Windows 2000 Professional operációs rendszeren választja ezt a beállítást, akkor ez több, mint 200 megabájttal megnöveli a biztonsági másolat méretét.
  • A Biztonsági mentés típusa részen a biztonsági mentés típusának kiválasztásával adható meg, hogyan készítsen a rendszer biztonsági mentést az adatokról. A biztonsági mentés típusai: másolás, napi, különbségi, növekményes és normál.


A visszaállítás beállításainak megadása

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. A Visszaállítás lapon hajtsa végre az alábbi műveletek egyikét:
    • Válassza a Ne cserélje le a számítógépen lévő fájlt választókapcsolót, ha nem akarja, hogy a visszaállítás során a rendszer átmásolja a lemezen már meglevő fájlokat.
    • Válassza a Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsolót, ha a visszaállítás során a lemezen levő régebbi fájlokat le akarja cserélni a biztonsági másolatban levő újabb fájlokkal.
    • Válassza a Mindig cserélje le a számítógépen lévő fájlt választókapcsolót, ha a visszaállítás során a biztonsági másolatban levő fájlokkal minden esetben felül akarja írni a lemezen levő fájlokat.

Fontos

  • A Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsoló kiválasztása esetén előfordulhat, hogy a rendszer módosítja a lemezen levő néhány vagy összes fájlt.
  • A Mindig cserélje le a számítógépen lévő fájlt választókapcsoló beállítása esetén előfordulhat adatvesztés, ha a jelenleg módosítás alatt levő fájl szerepel a biztonsági másolatban.

Megjegyzés


Adja meg a helyreállítási speciális beállításait

A biztonsági mentés speciális beállításainak megadása

  2. Kattintson a Helyreállítás fülre, majd válassza ki a helyreállítani kívánt fájlokat és mappákat.
  3. Kattintson a Visszaállítás indítása gombra.
  4. A Visszaállítás megerősítése párbeszédpanelen kattintson a Speciális gombra.
  5. Adja meg a visszaállítás speciális beállításait, majd kattintson az OK gombra. Az egyes beállítások leírása a Megjegyzések részen található.

Megjegyzések

  • A Biztonsági beállítások visszaállítása beállítás választása esetén a rendszer visszaállítja az összes fájl és mappa biztonsági beállításait. A biztonsági beállítások lehetnek: engedélyek, naplóbejegyzések és tulajdonjog. Ez a beállítás csak Windows 2000 rendszerben használt NTFS-kötetről készített biztonsági mentés Windows 2000 rendszerben használt NTFS-kötetre történő visszaállításakor használható.
  • A cserélhető tároló adatbázisának visszaállítása beállítás választása esetén a rendszer visszaállítja a Cserélhető tároló segédprogram Rendszergyökér\System32\Ntmsdata mappában tárolt adatbázisát. Ha nem a Cserélhető tároló segédprogrammal menedzseli a tárolóeszközöket, akkor nem szükséges kiválasztani ezt a beállítást. A visszaállítás törli a Cserélhető tároló segédprogram meglevő adatbázisát.
  • A Csatlakozási pontok visszaállítása, az alattuk lévő fájlok és mappák visszaállítása az eredeti helyükre beállítás választása esetén a rendszer a merevlemezen visszaállítja a csatlakozási pontokat, és a csatlakozási pontok által hivatkozott adatokat. Ha nem jelöli be ezt a jelölőnégyzetet, akkor a rendszer visszaállítja a csatlakozási pontokat, de a csatlakozási pontok által hivatkozott adatok nem lesznek elérhetőek. Csatlakoztatott meghajtón tárolt adatok visszaállításához is be kell jelölni ezt a jelölőnégyzetet. Ha nem jelöli be ezt a jelölőnégyzetet, akkor a rendszer csak a csatlakoztatott meghajtót tartalmazó mappát állítja vissza.
  • A Replikált adatkészletek visszaállítása esetén az adatok megjelölése elsődleges adatként az összes másolatnál jelölőnégyzet bejelölése biztosítja, hogy a fájlreplikációs szolgáltatás visszaállított adatait a rendszer replikálja a többi kiszolgálóra. A fájlreplikációs szolgáltatás adatainak visszaállításához be kell jelölni ezt a jelölőnégyzetet. Ha nem jelöli be ezt a jelölőnégyzetet, akkor előfordulhat, hogy a fájlreplikációs szolgáltatás visszaállított adatait a rendszer nem replikálja a többi kiszolgálóra, mert a visszaállított adatok régebbinek tűnnek majd, mint a kiszolgálón tárolt jelenlegi adatok. Ennek következtében a többi kiszolgáló felülírja a visszaállított adatokat, így megakadályozzák a fájlreplikációs szolgáltatás adatainak visszaállítását.
  • A meglévő kötetekhez tartozó csatlakozási pontok megtartása jelölőnégyzet bejelölése esetén a visszaállítás során a rendszer nem írja felül a kötet csatlakozási pontjait azon a partíción vagy köteten, amelyre az adatok visszaállítását végzi. Ez a beállítás különösen hasznos, ha teljes meghajtó vagy partíció adatait állítja vissza. Például ha a meghibásodott meghajtót kiváltó meghajtóra végzi az adatok visszaállítását, partícionálta és formázta a meghajtót, valamint visszaállította a csatlakozási pontokat, akkor e beállítás választása esetén a rendszer nem kísérli meg újból a csatlakozási pontok visszaállítását. Ha az adatokat most formázott partícióra vagy meghajtóra kívánja visszaállítani, és vissza kívánja állítani a kötet régi csatlakozási pontjait, akkor ne jelölje be ezt a jelölőnégyzetet.


Adathordozók karbantartása

  • Szalag formázása
  • Szalag visszatekerése
  • Szalag törlése
  • Katalógus törlése
  • Katalógus frissítése


Szalag formázása

  2. A Visszaállítás lapon a jobb oldali egérgombbal kattintson a formázni kívánt szalagra.
  3. Kattintson a Formázás gombra.

Megjegyzések

  • Ez a művelet csak DC-2000 típusú szalagos meghajtóra vonatkozik, amely esetén a szalagot használat előtt meg kell formázni.


Szalag visszatekerése

  2. A Visszaállítás lapon kattintson a visszatekerni kívánt szalagra.
  3. Kattintson az Eszközök menüre, a Médiaeszközök pontra, majd a Visszatekerés parancsra.

Megjegyzések

  • A Visszatekerés parancs úgy is elérhető, ha a Visszaállítás lapon a jobb oldali egérgombbal a szalagra kattint.


Szalag törlése

  2. A Visszaállítás lapon kattintson a törölni kívánt szalagra.
  3. Kattintson az Eszközök menüre, mutasson a Médiaeszközök pontra, majd kattintson a Törlés parancsra.

Megjegyzések

  • A szalag csak akkor törölhető, ha a szalagos meghajtóban vagy a kazettacserélő betöltőnyílásában van.
  • Törlés után a szalag a biztonsági másolat adathordozó-készletből az üres adathordozó-készletbe kerül.
  • A szalag a Cserélhető tároló segédprogrammal is törölhető.
  • A Törlés parancs úgy is elérhető, ha a Visszaállítás lapon a jobb oldali egérgombbal a szalagra kattint.


Katalógus törlése

  2. A Visszaállítás lapon a jobb oldali egérgombbal kattintson a törölni kívánt biztonságimásolat-készletet tartalmazó katalógusra.
  3. Kattintson a Katalógus törlése parancsra, ha a biztonságimásolat-készletet fájlban tárolja, vagy a Törlés a rendszerről parancsra, ha a biztonságimásolat-készletet szalagon tárolja.

Megjegyzések

  • Ez a művelet csak akkor használható, ha sérült vagy elveszett szalagot vagy fájlt akar törölni a lemezen tárolt katalógusból.
  • Ha egy szalaghoz tartozó katalógust akar törölni, akkor ez a művelet csak akkor működik, ha a szalag nincs a szalagos meghajtóban vagy a kazettabetöltő-nyílásban.
  • A Katalógus törlése gombra kattintással törölhető a lemezen tárolt, a kijelölt biztonságimásolat-készlethez tartozó katalógus. A művelet nem törli a biztonságimásolat-fájlt.
  • A Törlés a rendszerről gombra kattintással törölhető a lemezen tárolt, a kijelölt biztonságimásolat-készlethez tartozó katalógus, és ez a művelet törli a szalagot a Cserélhető tároló adatbázisából. A művelet nem törli az adathordozón tárolt katalógust a szalagról.
  • Egy fájlhoz vagy szalaghoz tartozó katalógus visszaállítható, ha a jobb oldali egérgombbal a kategorizálni kívánt fájlra vagy szalagra, majd a Katalógusfájl vagy a Katalógus parancsra kattint. A katalógus létrehozásával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Katalógus frissítése

  2. A Visszaállítás lapon a jobb oldali egérgombbal kattintson a kategorizálni kívánt biztonságimásolat-készletre.
  3. Kattintson a Katalógus parancsra.

Megjegyzések

  • Ezzel az eljárással lemezen tárolt katalógus hozható létre. Ezzel az eljárással nem hozható létre az adathordozón tárolt katalógus.
  • Szalagra mentett biztonságimásolat-készlethez tartozó katalógus létrehozásához az eljárás végrehajtása előbb az alábbiak műveletek egyikét el kell végezni:
    • Ha a biztonságimásolat-készlet tartalmazza az összes szalagot, a szalagok nem hibásak és nem sérültek, akkor kattintson az Eszközök menü Beállítások parancsára, az Általános fülre, majd ellenőrizze, hogy A katalógusok használata a visszaállítási katalógusok készítésének felgyorsításához jelölőnégyzet be van-e jelölve. Ez meggyorsítja a kategorizálás folyamatát.
    • Ha a biztonságimásolat-készletből hiányzik szalag, vagy valamelyik szalagok hibás vagy sérült, akkor kattintson az Eszközök menü Beállítások parancsára, az Általános fülre, majd ellenőrizze, hogy A katalógusok használata a visszaállítási katalógusok készítésének felgyorsításához jelölőnégyzet törölve van-e. Ez garantálja, hogy a katalógus teljes és pontos legyen, viszont hosszabb ideig tarthat a katalógus összeállítása.


Biztonságimásolat-felelős hozzáadása és felhasználói jogosultságok beállítása

  • Felhasználó hozzáadása a Biztonságimásolat-felelősök csoporthoz
  • Felhasználó hozzáadása a tartományvezérlőn található Biztonságimásolat-felelősök csoporthoz


Felhasználó hozzáadása a Biztonságimásolat-felelősök csoporthoz

  1. Nyissa meg a Számítógépkezelés segédprogramot.
  2. A konzolfában kattintson a Helyi felhasználók és csoportok elemre.
  3. A részletek ablaktáblában kattintson duplán a Csoportok mappára, majd a Biztonságimásolat-felelősök elemre.
  4. A Biztonságimásolat-felelősök párbeszédpanelen kattintson a Hozzáadás gombra.
  5. A Felhasználók vagy csoportok párbeszédpanelen a Név mezőhöz közel írja be a biztonságimásolat-felelősként kijelölni kívánt személyt tartalmazó tartomány nevét, és a személy felhasználónevét. Előbb a tartomány, majd fordított ferde vonallal elválasztva a felhasználó nevét írja be. Például: \\Budapest\Kovacs.
  6. Kattintson a Hozzáadás, majd az OK gombra.

Fontos

  • Tartományvezérlőn a Kezelők csoporthoz csak az Active Directory Felhasználók és számítógépek segédprogrammal adhatók felhasználók. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • A Biztonságimásolat-felelősök csoporthoz csak a Rendszergazdák csoport tagja adhatnak felhasználókat.
  • A Számítógépkezelés segédprogram megnyitásához kattintson a Start menüre, majd a Vezérlőpult parancsra. A Vezérlőpult ablakban kattintson duplán a Felügyeleti eszközök, majd a Számítógépkezelés ikonra.


Felhasználó hozzáadása a tartományvezérlőn található Biztonságimásolat-felelősök csoporthoz

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. Kattintson duplán a konzolfa tartomány-csomópontjára.
  3. A Részletek munkaablakban kattintson duplán a Beépített mappára, kattintson az egér jobb gombjával a Biztonságimásolat-felelősök elemre, majd kattintson a Tulajdonságok parancsra.
  4. Kattintson a Tagok fülre, majd kattintson duplán arra a csoportra, amelyikhez tagok kíván adni.
  5. A Tagja lapon jelölje ki a csoporthoz hozzáadni kívánt tag nevét, majd kattintson a Hozzáadás gombra.
  6. A munkaablak tetején lévő Keresési hely nyílra kattintva jelenítheti meg azokat a tartományokat, ahonnan felhasználókat és számítógépeket adhat hozzá a csoporthoz, majd kattintson a hozzáadni kívánt felhasználókat és számítógépeket tartalmazó tartományra.
  7. Kattintson a hozzáadni kívánt felhasználókra, a Hozzáadás, majd az OK gombra.

Megjegyzés


Rendszerjavítás és -helyreállítás

  • A Helyreállítási konzol telepítése indítási beállításként
  • A Helyreállítási konzol törlése
  • A Helyreállítási konzol futtatása olyan rendszeren, ami nem indul
  • Helyreállító lemez készítése


Fogalmak

Ez a szakasz általános tudnivalókat tartalmaz a Windows 2000 biztonságimásolat-készítési és -visszaállítási lehetőségeiről:

  • Biztonsági másolat készítése – áttekintés
  • A biztonsági másolat készítésének lényege
  • Biztonsági másolatok készítése
  • Forrásmunkák


Biztonsági másolat készítése – áttekintés

A Biztonsági mentés segédprogrammal védheti meg adatait a véletlen adatvesztés ellen, ha a rendszerben hardver vagy tároló adathordozó hibásodna meg. A Biztonsági mentés segítségével például másolatot készíthet a merevlemezen tárolt adatokról, majd azokat egy másik tárolóeszköre, mondjuk merevlemezre vagy szalagra archiválhatja. Ha a merevlemezen tárolt eredeti adatokat véletlenül letörli vagy felülírja, vagy nem tudja elérni a merevlemez meghibásodása miatt, az adatokat könnyűszerrel visszaállíthatja az archivált példányról.

A Biztonsági mentés segítségével a következőket teheti meg:

  • Kijelölt fájlokat és mappákat archiválhat merevlemezre.
  • Az archivált fájlokat és mappákat visszaállíthatja a merevlemezre vagy más rendelkezésre álló lemezre.
  • Helyreállító lemezt (ERD) készíthet, melynek a segítségével sérülés vagy véletlen törlés esetén rendszerfájlokat tud javítani.
  • Bármilyen távtárolón lévő adatról és csatlakoztatott meghajtókon tárolt bármilyen adatról másolatot készíthet.
  • Másolatot készíthet a számítógép rendszerállapotáról, többek között a rendszerleíró adatbázisról, az Active Directory adatbázisról, valamint a Bizonyítványszolgáltatások adatbázisról.
  • Rendszeres biztonságimásolat-készítéseket ütemezve tarthat naprakészen archivált adatokat.

A Biztonsági mentés segítségével a fájlallokációs táblában (FAT) és a NTFS fájlrendszer kötetein lévő adatokról készíthet biztonsági másolatot és állíthatja vissza azokat. Ha azonban a Windows 2000 programban használt NTFS kötet adatairól készített biztonsági másolatot, ajánlatos azokat az adatokat szintén a Windows 2000 programban használt NTFS kötetre visszaállítani, különben adatok, illetve olyan fájl- és mappaszolgáltatások veszhetnek el, mint például az engedélyek, a fájlrendszer titkosításának (EFS) beállításai, a lemezkvóta-információk, a csatlakoztatott meghajtók adatai és a távtárolási információk.

A Biztonsági mentés bővítéseinek felsorolását az Új szolgáltatások között találja.


Új szolgáltatások

A Biztonsági mentés segédprogrammal a szalagos meghajtón kívül a legkülönbözőbb tárolóeszközökre készíthet biztonsági másolatot fájlokról. A biztonsági másolat adathordozója lehet logikai meghajtó, kivehető lemez, írható CD-ROM vagy akár a lemezek, illetve szalagok adathordozó-készleten rendezett és robotcserélővel vezérelt egész könyvtára. Ha nem rendelkezik külön tárolóeszközzel, másik merevlemezre vagy hajlékonylemezre is készíthet biztonsági másolatot.

Ezen kívül a Biztonsági mentés már nem kezel tárolóeszközt és adathordozót. A szalag és a lemez csatlakoztatásához hasonló feladatokat most már a Cserélhető tároló nevű szolgáltatás végzi, ez a Windows 2000 szerves része.

A Biztonsági mentés további bővítései a következők:

  • Teljes felhasználói felület Biztonságimásolat-készítő és visszaállító varázslóval, adathordozó-készletek tulajdonságlapjaival és közvetlen hozzáféréssel a Hálózati helyekhez.
  • Teljes körű támogatás a Windows 2000 rendszerállapot biztonsági másolatának elkészítéséhez és visszaállításához. A támogatás kiterjed a rendszerfájlokra, a rendszerleíró adatbázisra, a Komponensszolgáltatásokra, az Active Directory adatbázisra, a fájlreplikációs szolgáltatásra, valamint a Bizonyítványszolgáltatások adatbázisra.
  • Windows 2000 Feladatütemező integrálása a biztonságimásolat-készítési feladatok automatizálásához.
  • Távtároló integrálása az adatok archiválásához.


A biztonsági másolat készítésének lényege

A jelen szakasz tartalma:

  • A biztonsági másolat típusai
  • Engedélyek és felhasználói jogosultságok
  • Rendszerállapot-adatok
  • Mérvadó visszaállítás
  • Javítás – áttekintés
  • Helyreállítási konzol – áttekintés


A biztonsági mentés típusai

A Biztonsági mentés segédprogrammal a számítógépen és a hálózaton tárolt adatokról ötféleképpen készíthető biztonsági mentés.

Biztonsági másolat

A biztonsági másolat az összes kijelölt fájlt átmásolja, de nem jelöli meg a fájlokat, hogy biztonsági mentés készült róluk (más szóval nem törli az archiválandó attribútumot). A másolás akkor hasznos, ha normál és növekményes biztonsági mentés között akar biztonsági mentést készíteni a fájlokról, mivel a másolás nem befolyásolja ezeket a biztonsági mentéseket.

Napi biztonsági mentés

A napi biztonsági mentés az összes kijelölt, a napi biztonsági mentés napján módosított fájlt átmásolja. A biztonsági mentést a rendszer nem jelöli a fájlokon (más szóval az archiválandó attribútumot nem töli).

Különbségi biztonsági mentés

A különbségi biztonsági mentés során a rendszer az összes olyan fájlt átmásolja, amely a legutóbbi normál vagy növekményes biztonsági mentés óta keletkezett vagy módosult. A biztonsági mentést a rendszer nem jelöli a fájlokon (más szóval az archiválandó attribútumot nem töli). A normál és különbségi biztonsági mentés kombinációjának a használatakor a fájlok és mappák helyreállításához egyaránt szükséges a legutolsó normál és a legutolsó különbségi biztonsági mentés.

Növekményes biztonsági mentés

A növekményes biztonsági mentés csak a legutolsó normál vagy növekményes biztonsági mentés óta létrehozott vagy módosított fájlokról készít biztonsági mentést. A biztonsági mentés végrehajtását a rendszer jelöli a fájlokon (más szóval törli az archiválandó attribútumot). A normál és a növekményes biztonsági mentés kombinációjának a használatakor az adatok helyreállításához egyaránt szükséges a legutolsó normál és az összes növekményes biztonsági mentés.

Normál biztonsági mentés

A normál biztonsági mentés az összes kijelölt fájlt átmásolja, és az összes fájlon jelöli a biztonsági mentés végrehajtását (más szóval törli az archiválandó attribútumot). Normál biztonsági mentés esetén az összes fájl helyreállításához mindössze a biztonsági mentés fájl vagy szalag legutolsó példánya szükséges. A legelső biztonságimásolat-készlet elkészítésekor általában normál biztonsági mentést kell végrehajtani.

A normál és növekményes biztonsági mentés kombinációjának használata esetén szükséges a legkevesebb tárolókapacitás az adatok biztonsági mentéséhez. Ez biztosítja a leggyorsabb biztonsági mentést. A fájlok helyreállítása azonban időigényes és bonyolult lehet, mivel a biztonságimásolat-készletek több lemezen vagy szalagon lehetnek.

Normál és különbségi biztonsági mentés használata esetén az adatok biztonsági mentése több időt vesz igénybe, különösen gyakran módosuló adatok esetén, de könnyebb az adatok helyreállítása, mivel általában a biztonságimentés-készletet a rendszer csupán néhány lemezen vagy szalagon tárolja.


Engedélyek és felhasználói engedélyek

A fájlok és mappák biztonsági mentéséhez és visszaállításához bizonyos engedélyekkel vagy felhasználói engedélyekkel kell rendelkezni. A helyi csoport rendszergazdája vagy biztonságimásolat-felelőse biztonsági másolatot készíthet a csoportot tartalmazó helyi számítógépen levő összes fájlról és mappáról. Ehhez hasonlóan a tartományvezérlő rendszergazdái és biztonságimásolat-felelősei (a rendszerállapot-adatok kivételével, tanulmányozza a lenti megjegyzést) biztonsági másolatot készíthetnek a tartományban vagy a tartománnyal kétirányú megbízhatósági kapcsolatban levő tartományok számítógépén tárolt minden fájlról és mappáról. Ha nem rendszergazda vagy biztonságimásolat-felelős, és biztonsági másolatot akar készíteni a fájlokról, akkor tulajdonosi joggal, vagy az alábbiak közül egy vagy több engedéllyel kell rendelkezni azokhoz a fájlokhoz és mappákhoz, amelyekről biztonsági másolatot akar készíteni. Olvasás, olvasás és végrehajtás, módosítás vagy teljes hozzáférés.

Ellenőrizni kell azt is, hogy a lemezkvóta-beállítások nem korlátozhatják a merevlemez elérését, mivel az meggátolhatná az adatok biztonsági mentését. A lemezkvóta-korlátozás ellenőrzéséhez a jobb oldali egérgombbal kattintson a menteni kívánt adatokat tartalmazó merevlemezre, kattintson a Tulajdonságok parancsra, majd kattintson a Kvóta fülre.

A biztonsági másolathoz való hozzáférés korlátozható a Biztonságimásolat-készítési feladat információi párbeszédpanel Csak a tulajdonos és a rendszergazda fér hozzá a biztonsági másolathoz elemének kiválasztásával. E beállítás kiválasztása esetén csak a rendszergazda és a biztonságimásolat-fájlt készítő személy állíthatja vissza a fájlokat és a mappákat.

Megjegyzés

  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól még a távoli számítógép rendszergazdája vagy biztonságimásolat-felelőse sem készíthet biztonsági másolatot távolról.


Rendszerállapot-adatok

A Biztonsági másolat segédprogrammal a rendszer alábbi összetevőinek végezhető el a biztonsági mentése és visszaállítása:

  • Rendszerleíró adatbázis
  • COM+ osztályregisztrációs adatbázis
  • Rendszerindító fájlok, amelyek tartalmazzák a rendszerfájlokat
  • Bizonyítványszolgáltatások adatbázis
  • Active Directory címtárszolgáltatás
  • SYSVOL könyvtár
  • Fürtszolgáltatás adatai

A Biztonsági mentés segédprogram ezeket a rendszerösszetevőket együttesen rendszerállapot-adatoknak nevezi. A Windows 2000 Professional operációs rendszerben a rendszerállapot-adatok csak a rendszerleíró adatbázist, a COM+ osztályregisztrációs adatbázist és a rendszerindító fájlokat foglalják magukban. A Windows 2000 Server operációs rendszerben a rendszerállapot-adatok a rendszerleíró adatbázist, a COM+ osztályregisztrációs adatbázist, a rendszerindító fájlokat és a Bizonyítványszolgáltatások adatbázist (ha a kiszolgáló bizonyítványkiszolgálóként működik) foglalják magukban. A tartományvezérlő rendszerállapot-adatainak az Active Directory és a SYSVOL könyvtár is része. A tartományvezérlőn tartománynév-szolgáltatás (DNS) futtatásakor a rendszerállapot-adatok az Active Directory címtárra vonatkozó része is tartalmazza a DNS-zóna összes (a címtárszolgáltatásba integrált és a címtárszolgáltatásba nem integrált) adatát. Ha a kiszolgálón fut a Fürtszolgáltatás, akkor a rendszerállapot-adatok tartalmazzák az összes rendszerleíró adatbázis ellenőrzőpontot és a fürtadatbázis legfrissebb adatait tartalmazó quorum erőforrás helyreállítási naplót.

A rendszerállapot adatok biztonsági mentésekor és visszaállításakor a rendszer a számítógéphez kapcsolódó összes rendszerállapot-adat biztonsági mentését vagy visszaállítását végrehajtja, a rendszerállapot-adatok különálló összetevőinek biztonsági mentése vagy visszaállítása nem hajtható végre. Ezt a rendszerállapot-adatok közötti függőségek indokolják. A rendszerállapot-adatok azonban más helyre is visszaállíthatók. A rendszer ilyenkor csak a rendszerleírófájlokat, a SYSVOL könyvtárban tárolt fájlokat, a fürtadatbázis információs fájljait és a rendszerindító fájlokat állítja vissza az új helyre. Másik helyre történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.

Ráadásul ha a szervezetben egynél több tartományvezérlő működik, és az adott kiszolgáló az Active Directory címtárszolgáltatást a többi kiszolgáló bármelyikére replikálja, akkor az Active Directory adatainak visszaállításához a mérvadó visszaállítást kell használni. Az Active Directory adatainak mérvadó visszaállításához a rendszerállapot-adatok visszaállítása után, de a kiszolgáló újraindítása előtt az Ntdsutil segédprogramot kell futtatni. Az Ntdsutil segédprogram lehetővé teszi az Active Directory objektumok megjelölését a mérvadó visszaállításhoz. Ez garantálja, hogy minden visszaállított, replikált vagy továbbított adatot a rendszer megfelelően replikáljon vagy továbbítson a szervezeten belül.

Például ha az Active Directory címtárszolgáltatásban tárolt objektum véletlen törlését vagy módosítását a rendszer replikálta vagy továbbította más kiszolgálókhoz, akkor mérvadó visszaállításon keresztül kell az objektumot visszaállítani ahhoz, hogy a rendszer a többi kiszolgálóra replikálja vagy továbbítsa az objektumot. Ha nem mérvadó visszaállításon keresztül állítja helyre az objektumot, a rendszer soha nem replikálja vagy továbbítja majd más kiszolgálókra, mert régebbinek tűnik majd a többi kiszolgálón jelenleg tárolt objektumoknál. Ha az Ntdsutil segédprogrammal megjelöli az objektumot a mérvadó visszaállításhoz, akkor az garantálja, hogy a rendszer a visszaállítani kívánt adatokat replikálja vagy továbbítsa a szervezeten belül. Másrészről ha a rendszerlemez meghibásodik, vagy az Active Directory adatbázis megsérül, akkor az adatok a Ntdsutil segédprogram használata nélkül (nem mérvadó visszaállítással) egyszerűen visszaállíthatók.

Az Ntdsutil parancssori segédprogram a parancssorból futtatható. Az Ntdsutil segédprogram súgója az ntdsutil /? parancs beírásával a parancssorban is használható.

Megjegyzések

  • A fájlok és mappák biztonsági mentéséhez és visszaállításához bizonyos engedélyekkel vagy felhasználói engedélyekkel kell rendelkezni.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások helyreállító módban állíthatók helyre. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory visszaállítását.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Bár nem módosíthatók a rendszerállapot-adatok biztonsági mentésébe bevont összetevők, a biztonsági másolat speciális beállításainak megadásával a rendszerállapot-adatokkal együtt biztonsági másolat készíthető az összes védett rendszerfájlról. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Mérvadó visszaállítás

A Biztonsági mentés segédprogram az olyan elosztott szolgáltatásokat, mint például az Active Directory címtárszolgáltatást az ún. rendszerállapot-adatok elnevezésű gyűjteményben tárolja. A tartományvezérlő rendszerállapot-adatainak biztonsági mentésekor a rendszer biztonsági másolatot készít az Active Directory kiszolgálón tárolt összes adatáról (más olyan rendszerösszetevőkkel együtt, mint például a SYSVOL könyvtár és a rendszerleíró adatbázis). Az adott kiszolgálón az elosztott szolgáltatások visszaállításához vissza kell állítani a rendszerállapot-adatokat. Ha azonban a szervezeten belül egynél több tartományvezérlő működik, és az Active Directory adatai replikálva vannak a többi tartományvezérlő bármelyikére, akkor ún. mérvadó visszaállítást kell végrehajtani annak érdekében, hogy a visszaállított adatok replikálását a rendszer biztosan végrehajtsa az összes többi kiszolgálón.

Normál visszaállítás végrehajtása során a Biztonsági mentés segédprogram nem mérvadó visszaállítás módban működik. Azaz a visszaállított adatok (így az Active Directory objektumok) eredeti frissítési sorozatszámukat kapják meg. Az Active Directory replikálórendszer e szám alapján érzékeli és továbbítja az Active Directory változásait a szervezeten belüli kiszolgálók között. Ennek következtében a nem mérvadó visszaállítással visszaállított adatok régi adatként jelennek meg az Active Directory replikálórendszerben, és ezeket az adatokat a rendszer soha nem replikálja más kiszolgálókra. E helyett az Active Directory replikálórendszer a visszaállított adatokat frissíti a többi kiszolgálón tárolt újabb adatokkal. A mérvadó visszaállítás oldja meg ezt a problémát.

Az Active Directory adatainak mérvadó visszaállításához a rendszerállapot-adatok visszaállítása és a kiszolgáló újraindítása után az Ntdsutil segédprogramot kell futtatni. Az Ntdsutil segédprogram lehetővé teszi az Active Directory objektumok megjelölését a mérvadó visszaállításhoz. Az objektum mérvadó visszaállításhoz való megjelölése esetén a rendszer úgy frissíti az objektum frissítési sorozatszámát, hogy nagyobb legyen az Active Directory replikálórendszerben tárolt bármilyen más frissítési sorozatszámnál. Ez garantálja, hogy minden visszaállított replikált vagy továbbított adatot a rendszer megfelelően replikáljon vagy továbbítson a szervezeten belül.

Például ha az Active Directory címtárszolgáltatásban tárolt objektum véletlen törlését vagy módosítását a rendszer replikálta vagy továbbította más kiszolgálókhoz, akkor mérvadó visszaállításon keresztül kell az objektumot visszaállítani ahhoz, hogy a rendszer a többi kiszolgálóra replikálja vagy továbbítsa az objektumot. Ha nem mérvadó visszaállításon keresztül állítja vissza az objektumot, a rendszer soha nem replikálja vagy továbbítja majd más kiszolgálókra, mert régebbinek tűnik majd a többi kiszolgálón jelenleg tárolt objektumoknál. Ha az Ntdsutil segédprogrammal megjelöli az objektumot a mérvadó visszaállításhoz, akkor az garantálja, hogy a rendszer a visszaállítani kívánt adatokat replikálja vagy továbbítsa a szervezeten belül. Másrészről ha a rendszerlemez meghibásodik, vagy az Active Directory adatbázis megsérül, akkor az adatok a Ntdsutil segédprogram használata nélkül (nem mérvadó visszaállítással) egyszerűen visszaállíthatók.

Az Ntdsutil parancssori segédprogram a parancssorból futtatható. Az Ntdsutil segédprogram súgója az ntdsutil /? parancs beírásával a parancssorban is használható.

Vigyázat!

  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok helyreállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági másolatban szereplő rendszerállapot-adatokkal.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások helyreállító módban állíthatók helyre. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory visszaállítását. A számítógép csökkentett módban való elindításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.


Biztonsági másolatok készítése

A jelen szakasz tartalma:

  • Biztonsági másolatok készítése fájlokról és mappákról
  • Biztonsági másolatok készítése parancsfájlok segítségével
  • Parancssorpéldák
  • Parancssori paraméterek
  • Fájlok és mappák visszaállítása
  • Tartományvezérlő visszaállítása
  • A Helyreállítási konzol parancsai


Biztonsági mentés készítése fájlokról és mappákról

A Biztonsági mentés funkcióval az adatokról biztonsági másolat készíthető fájlba vagy szalagra. Fájlba történő biztonsági másolat készítésekor meg kell adni annak a fájlnak a nevét és helyét, amelybe az adatokat akarja menteni. A biztonsági másolat fájlok általában .bkf kiterjesztéssel rendelkeznek, de a kiterjesztés tetszés szerint módosítható. A biztonsági másolat fájlok menthetők merevlemezre, hajlékonylemezre, bármilyen cserélhető vagy nem cserélhető adathordozóra, amelyre fájlok menthetők.

Az adatokról akkor készíthető szalagra biztonsági mentés, ha a számítógéphez szalagos eszköz csatlakozik. A szalagok a Cserélhető tároló alkalmazással is kezelhetők. Bár a Biztonsági mentés alkalmazás a Cserélhető tároló alkalmazással együttműködik, bizonyos karbantartási feladatok (például a szalagok előkészítésének és kivételének) végrehajtásához a Cserélhető tároló alkalmazás szükséges.

Az egyszerű biztonsági mentés az alábbi négy lépésből áll:

Azoknak a fájloknak, mappáknak és meghajtóknak a kiválasztása, amelyről biztonsági másolatot akar készíteni.

A Biztonsági mentés alkalmazás fa nézetében választhatók ki a számítógépen levő meghajtók, fájlok és mappák közül azok a fájlok és mappák, amelyekről biztonsági mentést akar készíteni. Ez a fa nézet a Windows Intézőben megszokott módon teszi lehetővé a meghajtók és mappák megnyitását, valamint a fájlok kijelölését.

Válassza ki a biztonsági másolat tárolására szolgáló tárolóeszközt vagy fájlt.

A Biztonsági mentés alkalmazás két lehetőséget biztosít a tárolóeszköz kiválasztására:

Az adatokról egy tárolóeszközön levő fájlba is készíthető biztonsági mentés. A biztonságimásolat-fájlok menthetők merevlemezre, Zip-lemezre, bármilyen cserélhető vagy nem cserélhető adathordozóra, amelyre fájlok menthetők. Ez a beállítás mindig használható.

Az adatokról szalagos eszközre is készíthető biztonsági mentés. Ez a beállítás csak akkor használható, ha a számítógépbe szalagos egység van telepítve. Az adatok szalagos egységre történő biztonsági mentésekor az adathordozót a Cserélhető tároló alkalmazás kezeli.

A biztonsági mentés beállításainak megadása

A Biztonsági mentés alkalmazás Beállítások párbeszédpanelén tetstreszabhatók a biztonsági mentéssel kapcsolatos műveletek. A Beállítások párbeszédpanelen az alábbi beállítások megadását teszi lehetővé:

Kiválasztható a biztonsági mentés típusa. A biztonsági mentésnek a következő típusai használhatók: másolás, napi, különbségi, növekményes és normál.

Megadható, hogy akarja-e naplófájlban rögzíteni a biztonsági mentés műveleteit. E beállítás választásakor az is kiválasztható, hogy teljes, vagy összesítő naplófájlt akar készíteni.

Kiválasztható, hogy akar-e biztonsági másolatot készíteni a csatlakoztatott meghajtókon tárolt adatokról.

Megadhatók azok a fájltípusok, amelyekről nem kell biztonsági másolatot készíteni.

Kiválasztható, hogy ellenőrizni akarja-e a biztonsági mentés hibátlan végrehajtását.

Indítsa el a biztonsági mentést

A biztonsági mentés elindítása után a Biztonsági mentés alkalmazás számára adatokat kell megadni a biztonsági mentésről, valamint megadhatók a biztonsági mentés speciális beállításai. Az adatok megadása, vagy a biztonsági mentés beállításainak módosítása után a Biztonsági mentés alkalmazás elkezdi a kiválasztott fájlok és mappák biztonsági mentését.

A biztonsági mentéssel kapcsolatos adatokat akkor is meg kell adnia, ha a biztonsági mentés felügyelet nélküli futtatását ütemezte be. Az adatok megadása után azonban a Biztonsági mentés alkalmazás nem kezdi el a fájlok biztonsági mentését, hanem az ütemezett biztonsági mentést hozzáadja a Feladatütemező alkalmazáshoz.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekről vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok a rendszerleíró adatbázist, címtárszolgáltatást és további alapvető rendszerösszetevőket tartalmaznak. Biztonsági mentést kell készíteni a rendszerállapot-adatokról, ha biztonsági másolatot akar készíteni ezekről az összetevőkről.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági mentés. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági mentés.
  • A biztonsági mentés ütemezhető, így megadott időpontban és gyakorisággal felügyelet nélkül futtatható. A biztonsági mentés a Biztonsági másolat indítása gombra kattintás után ütemezhető.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági mentést készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának „Biztonsági mentés használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és helyreállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Ha az adathordozók kezelésére a Cserélhető tároló alkalmazás használja vagy az adatok tárolására a Távtároló alkalmazást használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági mentést kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távtároló és a Cserélhető tároló alkalmazás összes adatának helyreállíthatóságát.


Biztonsági mentés készítése az adatokról parancsfájl segítségével

Biztonsági másolat az ntbackup parancs és annak számos parancssori kapcsolójának segítségével parancsfájlokkal is készíthető. Az adatok parancsfájllal történő biztonsági mentésekor azonban két fontos korlátozást figyelembe kell venni:

  • Az ntbackup paranccsal csak teljes mappáról készíthető biztonsági másolat. Nem készíthető biztonsági másolat egyedi fájlokról. A parancssorban azonban kiadható egy biztonságimásolat-kijelölőfájl (.bks fájl), amely tartalmazza azoknak a fájloknak a listáját, amelyekről biztonsági másolatot akar készíteni. Biztonságimásolat-kijelölőfájl csak a grafikus Biztonsági mentés segédprogrammal készíthető.
  • Az ntbackup parancsban nem használhatók helyettesítő karakterek. Például a *.txt kifejezés megadásának hatására a rendszer nem fog biztonsági másolatot készíteni a .txt kiterjesztésű fájlokról.


Parancssori példák

Az alábbi példák bemutatják, hogyan használható az ntbackup parancs a parancssorban vagy parancsfájlban a fájlok és mappák biztonsági másolatának elkészítésére.

1. példa:

ntbackup backup \\anna-vegyes\c$ /m normal /j "1. saját mentés" /p "Backup" /n "Parancssori 1. biztonsági másolat" /d "Parancssori funkció" /v:yes /r:no /l:s /rs:no /hc:on

A példában megadott parancs “1. saját mentés” néven normál biztonsági másolatot készít az \\anna-vegyes\c$ távoli megosztásról. A parancs kivesz egy szalagot a biztonsági másolat segédprogramhoz használható adathordozó-készletből, és a szalagnak a “Parancssori 1. biztonsági mentés” nevet adja. A “Parancssori funkció” kifejezés a biztonsági mentés leírása lesz. A biztonsági mentés befejezése után a rendszer ellenőrzi az elkészült biztonsági másolatot, a hozzáférést nem korlátozza a tulajdonosra/rendszergazdára, a naplózási szintet csak az összegzés naplózására állítja be, a Cserélhető tároló segédprogram adatairól a rendszer nem készít biztonsági mentést és a parancs engedélyezi a hardveres tömörítés használatát.

2. példa:

ntbackup backup d:\ /j "2. saját mentés" /a /t "Parancssori 1. biztonsági mentés" /m copy

A példában megadott parancs “2. saját mentés” néven másolásos biztonsági másolatot készít a D:\ helyi meghajtóról. A fájlokról és mappákról készített biztonsági másolatot a parancs hozzáfűzi a “Parancssori 1. biztonsági mentés” nevű szalaghoz. Az összes többi beállítás esetén a Biztonsági mentés segédprogram alapbeállításai érvényesek.

3. példa:

ntbackup backup "@C:\Program Files\Windows NT\ntbackup\data\parancssor.bks" /j "3. saját mentés" /t "Parancssori 1. biztonsági mentés" /n "Parancssori 2. biztonsági mentés"

A példában megadott parancs a Biztonsági mentés segédprogramban beállított típusú biztonsági másolatot készít. A parancs a C:\Program Files\Windows NT\ntbackup\data\ könyvtárban elhelyezkedő parancssor.bks nevű biztonságimásolat-kijelölőfájl alapján választja ki azokat a fájlokat, amelyekről biztonsági másolatot készít. A biztonsági mentés neve “3. saját mentés”, és a “Parancssori 1. biztonsági mentés” elnevezésű szalag nevét felülírja a “Parancssori 2. biztonsági mentés” névvel.

4. példa:

ntbackup backup \\anna-vegyes\d$ /j "Parancssori 4. biztonsági mentés" /f "D:\bmentés.bkf"

ntbackup backup \\anna-vegyes\d$ /j "Parancssori 5. biztonsági mentés" /f "D:\bmentés.bkf"

ntbackup backup \\anna-vegyes\d$ /j "Parancssori 6. biztonsági mentés" /f "D:\bmentés.bkf"

A fenti példák azt mutatják be, a parancssorból hogyan végezhető el a biztonsági mentés egy fájlba. Mindhárom példában megadott parancs a Biztonsági másolat segédprogramban alapértelmezett típusú biztonsági másolatot, ellenőrzési beállításokat, naplózási szintet, hardveres tömörítést és egyéb korlátozásokat használja. Az első parancs arra példa, hogyan készíthető biztonsági mentés az \\anna-vegyes\d$ könyvtárról a D:\Bmentés.bkf fájlba. A második parancs azt példázza, hogyan fűzhető egyanez a biztonsági mentés ugyanahhoz a fájlhoz. A harmadik példa azt mutatja be, hogyan írható felül a fájl ugyanazzal a biztonsági mentéssel. Mindhárom példában a meghajtó betűjele helyettesíthető a teljes UNC-névvel (azaz a d:\bmentés.bkf helyett az \\anna-vegyes\d$\bmentés.bkf hely is megadható a biztonsági másolat helyeként).


Parancssori paraméterek

Biztonsági másolat az ntbackup parancs és annak számos parancssori kapcsolójának segítségével a parancssorból vagy parancsfájllal is készíthető.

Szintaxis:

ntbackup backup [systemstate] "bks fájl neve" /J {"feladat neve"} [/P {"készlet neve"}] [/G {"globálisan egyedi azonosító (guid) neve"}] [/T { "szalag neve"}] [/N {"adathordozó neve"}] [/F {"fájl neve"}] [/D {"készlet leírása"}] [/DS {"kiszolgáló neve"}] [/IS {"kiszolgáló neve"}] [/A] [/V:{yes|no}] [/R:{yes|no}] [/L:{f|s|n}] [/M {biztonsági másolat típusa}] [/RS:{yes|no}] [/HC:{on|off}] [/UM]

Paraméterek:

systemstate

Megadásával biztonsági másolat készíthető rendszerállapot-adatokról. Amikor biztonsági másolatot készít a rendszerállapot-adatokról, akkor a rendszer biztonsági másolatot készít az összes rendszerállapot-adatról, ezért a /s kapcsoló hatástalan. A biztonsági másolat típusa is csak normál vagy másolásos lehet.

bks fájl neve

A biztonságimásolat-készítéshez használt biztonságimásolat-kijelölőfájlt (.bks kiterjesztésű fájl) adja meg. A biztonságimásolat-kijelölőfájl azoknak a fájloknak és mappáknak az adatait tartalmazza, amelyekről biztonsági másolatot akar készíteni. Ez a fájl a grafikus felületű Biztonsági mentés segédprogrammal készíthető el.

/J {"feladat neve"}

A naplófájlban használt feladatnevet adja meg. A feladat neve általában az aktuális biztonsági mentésben szereplő fájlok és mappák leírása mellett a biztonsági másolat készítésének dátumát és időpontját tartalmazza.

/P {"készlet neve"}

Azt az adathordozó-készletet adja meg, amelyből az adathordozót akarja használni. Ez általában a biztonsági másolat adathordozó-készlet valamelyik alkészlete, például a 4 mm-es DDS. E beállítás megadása esetén nem használhatók az alábbi kapcsolók: /A /G /F /T.

/G {"globálisan egyedi azonosító (guid) neve"}

Felülírja vagy hozzáfűzi ehhez a szalaghoz. Nem használható a /P kapcsolóval együtt.

/T {"szalag neve"}

Felülírja vagy hozzáfűzi ehhez a szalaghoz. Nem használható a /P kapcsolóval együtt.

/N {"adathordozó neve"}

A szalag új nevét adja meg. Nem használható a /A kapcsolóval együtt.

/F {"fájl neve"}

A logikai lemez elérési útvonala és a fájlnév A következő kapcsolók nem használhatók ezzel a kapcsolóval: /P /G /T.

/D {"készlet leírása"}

Minden egyes biztonságimásolat-készlethez címke rendelhető.

/DS {"kiszolgáló neve"}

Biztonsági másolatot készít a megadott Microsoft Exchange Server címtárszolgáltatását tároló fájlról.

/IS {"kiszolgáló neve"}

Biztonsági másolatot készít a megadott Microsoft Exchange Serverhez tartozó adattároló fájlról.

/A

Hozzáfűzést hajt végre. A /G vagy a /T kapcsolóval kell együtt használni. Nem használható a /P kapcsolóval együtt.

/V:{yes|no}

A biztonsági mentés befejezése után ellenőrzi a biztonsági másolatban tárolt adatokat.

/R:{yes|no}

Megadása esetén csak a tulajdonos vagy a Rendszergazdák csoport tagjai használhatják a szalagot.

/L:{f|s|n}

A naplófájl típusát határozza meg: f=teljes, s=összegzés, n=nincs (a rendszer nem készít naplófájlt).

/M {biztonsági másolat típusa}

A biztonsági másolat típusát határozza meg. A következő típusok használhatók: normál, másolás, különbségi, növekményes vagy napi.

/RS:{yes|no}

Biztonsági másolatot készít a Cserélhető tároló adatbázisáról.

/HC:{on|off}

Ha a szalagos meghajtó támogatja, akkor hardveres tömörítést használ.

/UM

Megkeresi az első használható adathordozót, megformázza, és felhasználja az aktuális biztonsági mentéshez. Az /UM kapcsoló használata esetén a /P kapcsoló megadásával ki kell jelölni egy eszköztípust megadó adathordozó-készletet, így a Biztonsági mentés segédprogram a megfelelő típusú adathordozót (például 4 mm-es DDS) keresi meg. Az /UM kapcsoló használata esetén a Biztonsági másolat segédprogram a következő adathordozó-készletekben keres használható adathordozót: Üres adathordozó-készlet, Import adathordozó-készlet, Ismeretlen adathordozó-készlet, Biztonsági mentés adathordozó-készlet. A használható adathordozó megtalálása után a felhasználó bármiféle közbeavatkozása nélkül automatikusan leáll a keresés, a rendszer megformázza és használatba veszi az adathordozót. Ez a parancs nem használható szalagbetöltőknél, és csak különálló szalagos meghajtó esetén használható.

Megjegyzések

  • A parancssorban az ntbackup parancs segítségével nem állíthatók vissza a fájlok.
  • A következő kapcsolók alapértelmezett értéke a Biztonsági mentés segédprogram grafikus felületén megadott beállításokkal egyezik, ha az adott beállítás értékét nem módosítja parancssori kapcsoló: /V /R /L /M /RS /HC. Ha például a Biztonsági mentés segédprogram Beállítások párbeszédpanelén bekapcsolja a hardveres tömörítést, akkor a rendszer ezt a beállítást alkalmazza, ha a parancssorban nem szerepel a /HC kapcsoló. Ha azonban a parancssorban a /HC:off kapcsolót adja meg, akkor az felülírja a Beállítások párbeszédpanel beállítását, és a rendszer nem használja majd a hardveres tömörítést.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági másolatot készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának „Biztonsági mentés használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és visszaállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Ha az adathordozók kezelésére a Cserélhető tároló segédprogramot használja, vagy az adatok tárolására a Távtároló segédprogramot használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági másolatot kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távoli tároló és a Cserélhető tároló segédprogram összes adatának visszaállíthatóságát.


Mappák és fájlok helyreállítása

Az egyszerű helyreállítási művelet az alábbi négy lépésből áll:

Válassza ki a helyreállítani kívánt fájlokat és mappákat

A Biztonsági mentés alkalmazás fa nézetben jeleníti meg azokat a fájlokat és mappákat, amelyekről biztonsági mentést készített. Itt választhatók ki azok a fájlok és mappák, amelyeket vissza akar állítani. Ez a fa nézet a Windows Intézőben megszokott módon teszi lehetővé a meghajtók és mappák megnyitását, valamint a fájlok kijelölését.

Válassza ki, hová akarja visszaállítani azokat a fájlokat és mappákat, amelyekről biztonsági mentést készített.

A Biztonsági mentés alkalmazás három hely egyikére teszi lehetővé a visszaállított fájlok mentését:

Az adatok visszaállíthatók eredeti mappájukba vagy mappáikba, ahonnan a biztonsági mentés készült róluk. Ez a beállítás sérült vagy elveszett fájlok és mappák visszaállításához hasznos.

A biztonsági mentésben levő adatok egy másik mappába is visszaállíthatók. E beállítás választása esetén a másik mappában megmarad a mappák és fájlok a biztonsági mentés során érvényes struktúrája. Ez a beállítás akkor hasznos, ha csak néhány régi fájl szükséges, de nem akarja felülírni vagy módosítani a lemezen jelenleg levő fájlokat vagy mappákat.

A biztonsági mentésben levő fájlok egyetlen mappába is visszaállíthatók. Ez a beállítás nem tartja meg a biztonsági mentésben szereplő mappák és fájlok struktúráját. A rendszer a biztonsági mentésben szereplő fájlokat egyetlen mappába helyezi. Ez a beállítás egy olyan fájl keresése esetén hasznos, amelynek nem ismeri a helyét.

Adja meg a visszaállítási beállításokat

A Biztonsági mentés alkalmazás Beállítások párbeszédpanelének Helyreállítás lapján adhatók meg a fájlok és mappák visszaállításának beállításai. Három beállítás egyikét kell kiválasztani:

  • Ne cserélje le a számítógépen lévő fájlt. Ez megakadályozza a merevlemezen levő fájlok felülírását. Ez a fájlok visszaállításának legbiztonságosabb módja.

  • Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi. Ha az adatok legutolsó biztonsági mentése óta bármely fájlban változás történt, akkor ez a beállítás garantálja, hogy egyetlen módosítás se vesszen el.

  • Mindig cserélje le a számítógépen lévő fájlt. Ennek hatására a rendszer a merevlemezen levő összes fájlt lecseréli a biztonságimásolat-készletben levő fájlokkal. Ha az utolsó biztonsági mentés óta bármilyen változás történt, akkor e beállítás használata esetén ezek a módosítások elvesznek.

Indítsa el a visszaállítást

A visszaállítási művelet elindítása után a Biztonsági mentés alkalmazás kéri annak megerősítését, hogy minden készen áll az adatok visszaállításához. Megadhatók speciális visszaállítási beállítások is, például vissza akarja-e állítani a biztonsági beállításokat, a Cserélhető tároló adatbázisát és a csatlakozási pont adatait.

Fontos

  • A Biztonsági mentés segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági mentés esetén azonban javasolt a visszaállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való visszaállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok a rendszerleíró adatbázist, az Active Directory címtárszolgáltatást és további alapvető rendszerösszetevőket tartalmaznak. Biztonsági mentést kell készíteni a rendszerállapot-adatokról, ha el akarja végezni ezeknek az összetevőknek a biztonsági mentését vagy visszaállítását.
  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok visszaállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági mentésben szereplő adatokkal. A rendszerállapot-adatok másik mappába történő visszaállításakor a rendszer csak a rendszerleíró adatbázis fájljait, a SYSVOL könyvtárfájlokat, a fürtadatbázis-leíró fájlokat és a rendszerindító fájlokat állítja vissza a másik mappába. Másik mappába történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások visszaállító módban állíthatók vissza. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory visszaállítását.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.


Tartományvezérlő visszaállítása

Ha a tartományhoz több tartományvezérlő is tartozik, azt kétféleképpen állíthatja vissza. Vagy egy másik tartományvezérlőt használva replikációval, vagy biztonsági másolatról állítja vissza az Active Directoryt. Ha a tartományhoz nem tartozik tartományvezérlő, akkor csak biztonsági másolatról lehet visszaállítani az Active Directoryt.

Ha van rá lehetőség, helyreállító lemez segítségével javítsa a rendszert, majd folytassa az alábbi két lépés valamelyikével.

Ha a rendszer nem javítható a helyreállító lemez segítségével, vagy súlyos hardvermeghibásodás történt, és a számítógépet újra kellett építeni, telepítse újra a Windows 2000 rendszert. Ellenőrizze, hogy a lemezek száma és mérete megegyezik-e az előző rendszerével vagy nagyobb-e annál, és csak ezt követően folytassa a visszaállítást a következő két lépés valamelyikével.

Az Active Directory visszaállítása biztonsági másolatról

A Biztonsági mentés segítségével állítsa vissza a rendszerállapotot, ezzel az Active Directory, a Fájlreplikációs szolgáltatás (többek között a Sysvol) és a Bizonyítványszolgáltatások (ha ez utóbbiak telepítve vannak) is helyreállnak. Ha a hálózati kártyákat vagy a tartományvezérlő számítógépet meghibásodás miatt kicserélték, előfordulhat, hogy manuálisan kell újrakonfigurálnia a hálózatot.

A rendszerállapot visszaállítási eljárásairól bővebben a Rendszerállapot-adatok visszaállítása című részben olvashat.

A tartományvezérlőn úgy állíthatja vissza a rendszerállapot-adatokat, ha először a Címtárszolgáltatások helyreállítási módjában indítja el a számítógépet. Ebben az üzemmódban visszaállíthatja a Sysvol könyvtárat és az Active Directoryt. A számítógép csökkentett módban való újraindításához kövesse A csökkentett módú és egyéb indítási beállítások utasításait, és kattintson a Címtárszolgáltatások helyreállítási módja parancsra.

A rendszerállapot-adatok biztonsági másolatának készítése és visszaállítása csak helyi számítógépen lehetséges, távoli számítógépen nem.

Az Active Directory visszaállítása replikáról

Telepítse újra az Active Directoryt az Active Directory telepítő varázsló segítségével, ezzel a kiszolgáló tartományvezérlővé lép elő. Az Active Directory és a Sysvol frissítése replikációval történik tartományvezérlőről. Az Active Directory telepítő varázsló futtatása előtt töröljön a régi tartományvezérlőre utaló minden hivatkozást a Helyek és szolgáltatások beépülő modul segítségével.

Megjegyzések

  • A fájlok és mappák biztonsági másolatának elkészítéséhez rendszergazdaként vagy biztonságimásolat-felelősként kell bejelentkeznie.
  • A rendszerleíró adatbázist, az Active Directoryt és egyéb kulcsfontosságú rendszerösszetevőket a rendszerállapot-adatok tartalmazzák. Az említett komponensek biztonsági másolatának készítéséhez és visszaállításához a rendszerállapot-adatokról is biztonsági másolatot kell készíteni.
  • Ha a rendszerállapot-adatok visszaállításakor nem jelöl ki másik helyet a visszaállított adatok számára, a biztonságimásolat-készítő törli a számítógépen jelenleg tárolt rendszerállapot-adatokat és azok helyére a visszaállított rendszerállapot-adatokat teszi. Ugyanakkor, ha a rendszerállapot-adatokat másik helyre állítja vissza, csak a rendszerleíró fájlok, a Sysvol, a könyvtár fájlok és a rendszer betöltő fájljainak visszaállítása történik a másik helyre. Az Active Directory adatbázis, a Bizonyítványszolgáltatások adatbázis és a Komponensszolgáltatások adatbázis visszaállítása nem történik meg másik hely megadásakor.
  • A rendszergazdák és biztonságimásolat-felelősök a fájlok és mappák dekódolása nélkül is visszaállíthatnak titkosított fájlokat és mappákat.


Forrásmunkák

  • Információk a Windows 2000 Server családról a Microsoft Windows webhelyen (http://www.microsoft.com/)
  • A hardverkompatibilitási listát tartalmazó Microsoft webhely (http://www.microsoft.com/)
  • A Microsoft TechNet a magyar és az angol Microsoft TechNet webhelyen (http://www.microsoft.com/)
  • Microsoft TechNet CD-lemezek
  • Microsoft támogatás a Microsoft webhelyen (http://www.microsoft.com/)
  • Az első lépések a Windows 2000 Server használatakor
  • Windows 2000 Server Resource Kit
  • A Windows 2000 Server rendszerleíró adatbázisa
  • Frissített technikai információ


Hibaelhárítás

Mi a probléma?

A rendszer nem indul.

Ok: Számos oka lehet annak, hogy a számítógépet nem lehet elindítani. Ezek a programok összefügghetnek a rendszerleíró adatbázissal, a rendszerfájlokkal, a partícióbetöltő-szektorral, illetve az indítási környezettel. Mindazonáltal a rendszer nem javítható, ha korábban nem készített helyreállító lemezt. A lemez elkészítéséhez használja a biztonságimásolat-készítő segédprogramot.

Megoldás: Az ilyen problémák elhárításában a Windows 2000 javító szolgáltatása segít.

A következő lépések a javítási folyamat általános leírását tartalmazzák:

  1. Indítsa el a számítógépet a Windows 2000 telepítőlemezekről, illetve CD-ről.
  2. A telepítés során válassza ki a javítási beállítást.

    Miután a Telepítő az utolsó telepítőlemezről is átmásolta a fájlokat, megkezdődik a Windows 2000 szöveges telepítése. Ennek során választhat, hogy egy friss Windows 2000 verziót kíván telepíteni, vagy egy már meglévő Windows 2000 telepítést kíván kijavítani, illetve visszaállítani. Ha hibás vagy sérült rendszert kíván javítani, válassza a javítási beállítást.

  3. Válassza ki a javítási típust.

    Gyors javítás és kézi javítás között választhat. Az előbbi a legkönnyebb és nem igényel felhasználói beavatkozást, míg az utóbbi igen. A gyors javítás során a rendszerleíró adatbázissal, a rendszerfájlokkal, a rendszerindító kötet partícióbetöltő-szektorával, valamint (kettős betöltésű vagy többszörös betöltésű rendszereknél) az indítási környezettel kapcsolatos problémák elhárítására történik kísérlet. A kézi javítás során választhat, hogy rendszerfájlokat, a partícióbetöltő-szektorral kapcsolatos problémákat vagy az indítási környezettel kapcsolatos problémákat kíván elhárítani, de a rendszerleíró adatbázissal kapcsolatos problémákat nem kezelheti. A kézi javítás során például megpróbálhatja kijavítani a rendszerfájlokat, ha tudja, hogy a partíció betöltőszektora és az indítási környezet teljesen ép.

  4. Lásson hozzá a javításhoz.

    A javítás megkezdéséhez a biztonságimásolat-készítő segédprogrammal készített 1,44 megabájtos helyreállító lemezre és a Windows 2000 eredeti telepítő CD-jére lesz szüksége. A javítás során a hiányzó vagy hibás fájlok helyére új fájlok kerülnek vagy a Windows 2000 CD-ről, vagy a rendszergyökér\repair könyvtárból. Ez azt jelenti, hogy a Windows 2000 eredeti telepítése, illetve a helyreállító lemez készítése után eszközölt rendszerváltoztatások elveszhetnek.

  5. Indítsa újra a számítógépet.

    Ha a javítás sikeres volt, utasítás érkezik a számítógép újraindítására. Ezt követően már működnie kell a rendszernek.

Fontos

  • A helyreállító lemez készítésekor az aktuális rendszerbeállításokat a számítógép a rendszergyökér\repair mappába menti. Ha törli vagy megváltoztatja a mappát, előfordulhat, hogy nem tudja elhárítani a rendszerrel kapcsolatos problémákat.

Megjegyzések

  • Csak akkor használjon kézi javítást, ha gyakorlott felhasználó vagy rendszergazda.
  • A gyorsjavítás csak akkor javít rendszerleíró fájlt, ha az hiányzik vagy sérült.


Hibaelhárítás

  • El nem induló rendszer javítása