Jegyzettömb – áttekintés

A Jegyzettömb egyszerűbb dokumentumok készítéséhez használatos alapszintű szövegszerkesztő. A Jegyzettömböt leggyakrabban szövegfájlok (.txt) megtekintésére és szerkesztésére alkalmazzák, de sokak szerint az egyik legegyszerűbb weblapkészítő eszköz is.

Mivel a Jegyzettömb csak a legalapvetőbb formázást támogatja, még véletlenül sem tud speciális formázást menteni olyan dokumentumokban, melyeknek sima szövegnek kell maradniuk. Ez különösen akkor hasznos, ha HTML-dokumentumokat készít weblaphoz, hiszen előfordulhat, hogy a speciális karakterek vagy egyéb formázások nem jelennek meg a közzétett weblapon, sőt esetleg hibát is okoznak.

A Jegyzettömbben készített fájlok Unicode, ANSI, UTF-8 és fordított bájtsorrendű Unicode formátumban menthetők. Ezek a formátumok nagyobb mértékű rugalmasságot biztosítanak az eltérő karakterkészleteket használó dokumentumok alkalmazása során.

Kapcsolódó témakörök


Megadott karakterek vagy szavak keresése

Megadott betűk és szavak keresése

  1. A Szerkesztés menüben kattintson a Keresés parancsra.
  2. Írja be a keresett karaktereket vagy szavakat a Mit keres feliratú mezőbe.
  3. Kattintson a Következő gombra.

Megjegyzések

  • Ha azt szeretné, hogy a keresés a Mit keres mezőben megadott szöveg nagy- és kisbetűinek megfelelően történjen, jelölje be a Kis- és nagybetűk megkülönböztetése jelölőnégyzetet.
  • Megadhatja a keresés irányát is (a kurzor pozíciójához képest). Ha a kurzor pozíciójához képest felfelé szeretne keresni, az Irány területen kattintson a Vissza választógombra, ha pedig lefelé, akkor az Előre választógombra.


Adott betűk és szavak keresése és cseréje

  1. A Szerkesztés menüben kattintson a Csere parancsra.
  2. Írja be a keresett karaktereket vagy szavakat a Mit keres mezőbe.
  3. A Mire cseréli mezőbe írja be azt a szöveget, amit a fentiek helyére szeretne behelyettesíteni.
  4. Ha a szöveg összes előfordulását egyszerre szeretné cserélni, kattintson a Mindet gombra. Ha egyesével szeretné elvégezni a cserét, először kattintson a Következő, majd a Csere gombra.


Szöveg sorokra tördelése az ablak mérete szerint

  • A Formátum menüben kattintson a Hosszú sorok tördelése parancsra.

Megjegyzések

  • A hosszú sorok tördelésének bekapcsolásakor a menüparancs mellett egy pipa jelenik meg.
  • A szöveg sorokra tördelésével lehet elérni, hogy az egyes sorokban lévő összes szöveg látszódjon az ablakban. Ez azonban nincs hatással arra, hogy a dokumentum hogyan fog megjelenni a nyomtatásban.


Ugrás megadott sorra

  1. Kattintson a Szerkesztés menü Ugrás parancsára.
  2. Az Ugrás sorban adja meg annak a sornak a számát, amelyikre ugrani kíván.

Megjegyzések

  • A dokumentumban nem kell sorszámoknak szerepelniük ahhoz, hogy ez a parancs működjön.
  • A sorokat a program automatikusan megszámolja a dokumentum elejétől a bal oldali margó mentén.


Szöveg kivágása, másolása, beillesztése vagy törlése

  • Ha egy szövegrészt úgy szeretne kivágni, hogy utána áthelyezhesse máshová, jelölje ki, majd kattintson a Szerkesztés menü Kivágás parancsára.
  • Szöveg másik helyre történő átmásolásához jelölje ki a szövegrészt, majd kattintson a Szerkesztés menü Másolás parancsára.
  • A kivágott vagy másolt szöveg beillesztéséhez vigye a kurzort oda, ahová a szöveget be szeretné szúrni, majd kattintson a Szerkesztés menü Beillesztés parancsára.
  • Szöveg törléséhez jelölje ki a szövegrészt, majd kattintson a Szerkesztés menü Törlés parancsára.


Betűstílus és -méret módosítása

  1. A Formátum menüben kattintson a Betűtípus parancsra.
  2. Jelölje ki a kívánt beállításokat a Betűtípus, Betűstílus és Méret mezőkben.

Megjegyzés

  • A betűtípus kinézete megjelenik a Minta ablakban.


Fejléc vagy lábléc létrehozása

  1. A Fájl menüben kattintson az Oldalbeállítás parancsra.
  2. A Fejléc vagy Lábléc mezőbe írja be a kívánt betű-karakter kombinációt az alábbi táblázatból:
    3. Cél: | Beírandó jel
A megnyitott fájl nevének, vagy ennek hiányában a (névtelen) szónak a beszúrása. | &f
A dátum beszúrása. | &d
A számítógép órája által mutatott idő beszúrása. | &t
Oldalszámok beszúrása. | &p
Ampersand jel beszúrása (&). | &&
A fejléc vagy lábléc igazítása balra, középre vagy jobbra. | &l, &c vagy &r

Megjegyzések

  • A Fejléc vagy Lábléc mezőben egynél több kombinációt is megadhat. Ha az egyes kombinációk között egy vagy két betűközt hagy, a fejléc illetve lábléc könnyebben olvasható lesz.
  • A szöveget úgy zárhatja balra, középre vagy jobbra, hogy a többi használni kívánt betű-karakter kombináció elé &l, &c vagy &r betűt tesz a Fejléc, illetve a Lábléc mezőben.
  • A kombinációkhoz szöveget is társíthat. Például az &p. oldal kombináció a nyomtatásban 1. oldal, 2. oldal, és így tovább formában jelenik meg.


Nyomtatott Jegyzettömb dokumentum megjelenésének módosítása

  1. A Fájl menüben kattintson az Oldalbeállítás parancsra.
  2. Az Oldalbeállítás párbeszédpanelen az alábbi lépések közül választhat:
    • A papírméret módosításához kattintson a kívánt méretre a Méret listában.
    • A papírforrás módosításához kattintson a kívánt tálca vagy adagoló nevére a Forrás listában.
    • Ha függőlegesen kívánja nyomtatni a dokumentumot, kattintson az Álló választógombra, ha pedig vízszintesen, akkor a Fekvő választógombra.
    • A margók módosításához adjon meg szélességet a Margó mezők valamelyikében.
    • A nyomtató beállításainak módosításához kattintson a Nyomtató gombra.


Jegyzettömb dokumentumok nyomtatása

  1. A Fájl menüben kattintson a Nyomtatás parancsra.
  2. Az Általános lapon jelölje ki a kívánt nyomtatót és beállításokat, majd kattintson az Nyomtatás gombra.

Megjegyzés

  • Ha változtatni kíván a nyomtatott dokumentum kinézetén, kattintson a Fájl menü Oldalbeállítás parancsára.


Az idő és a dátum beszúrása a dokumentumba

  1. Vigye a kurzort oda, ahová az időt és a dátumot be szeretné szúrni.
  2. A Szerkesztés menüben kattintson az Idő/dátum parancsra.


Dátumnyilvántartás a dokumentumokban

  1. A Jegyzettömb dokumentum első sorába írja be a bal margóhoz a következőt csupa nagybetűvel (a ponttal együtt):

    .LOG

  2. A Fájl menüben kattintson a Mentés parancsra.

Megjegyzés

  • Valahányszor megnyitja ezt a dokumentumot, a Jegyzettömb program beszúrja a dokumentum végére a számítógép órája által megadott aktuális időt és az aznapi dátumot.


Különböző nyelvformátumok használata a Jegyzettömbben

A Jegyzettömb segítségével több formátumban is készíthet és megnyithat dokumentumokat: ANSI, Unicode, fordított bájtsorrendű Unicode és UTF-8. Ezen formátumok segítségével különböző karakterkészleteket használó dokumentumokkal tud dolgozni.

Alapértelmezésben a dokumentumok mentése szabvány ANSI szövegként történik.

Az Unicode a világon használt jelentősebb nyelvkészletek gyűjtőhalmaza. Az üzleti és a számítógépes világban elterjedt karakterkészleteket tartalmazza. Ha Unicode formátumban menti dokumentumot, az Unicode vezérlőkarakterei segítségével meghatározhatja a szöveg és az írás irányát olyan nyelveknél, mint például az arab és a héber.

A Windows 2000 néhány betűtípusa nem tud minden Unicode karaktert megjeleníteni. Ha valamilyen karakter hiányzik egy szövegfájlból, váltson olyan betűtípusra, ami tartalmazza a hiányzó karaktert. Unicode karakterekhez általában a Microsoft Sans Serif betűtípust érdemes használni.

A fordított bájtsorrendű processzorral (például Macintosh típussal) készített Unicode dokumentumok szavainak bájtjai (tárolóegységei) az Intel processzorokkal készített dokumentumok szavainak bájtjaival ellentétes sorrendben vannak elrendezve. A legfontosabb bájt címe a legalacsonyabb, az utolsónak tárolt szó pedig az első. Ahhoz, hogy dokumentumokhoz az ilyen számítógépek felhasználói is hozzáférhessenek, a Jegyzettömb fájlt fordított bájtsorrendű Unicode formátumban kell mentenie.

Az UTF a Universal Character Set Transformation Format (univerzális karakterkészlet-átlakító formátum ) rövidítése. Az UTF-8 az Unicode 8 bites formája. Akkor érdemes a dokumentumot UTF-8 formátumban menteni, ha olyan régebbi átviteli médiumot használ, ami az egyes bájtokon belül legfeljebb 8 bites értékadatot támogat.

Az említett formátumokról bővebb információt a Unicode Consortium webhelyen (http://www.unicode.org) olvashat.

Megjegyzés