Üdvözli a hírcsoport-kiszolgáló!

A Microsoft NNTP-szolgáltatás

A Microsoft NNTP-szolgáltatással létrehozott hírcsoportok használatával a vállalaton vagy szervezeten belüli felhasználók bármikor nagyon egyszerűen vitákat és megbeszéléseket indíthatnak különféle témákról, akár egymás között, akár szervezeten kívüli felhasználók bevonásával.

A dokumentáció tartalma:

  • Az egyes feladatok végrehajtásának leírása az Útmutató című részben található.
  • Az általános tudnivalókkal az Alapfogalmak című rész foglalkozik.
  • A Microsoft NNTP-szolgáltatás karbantartásáról a Karbantartás címszó alatt olvashat.
  • A felmerülő problémák megoldásához a Hibaelhárítás című részben talál segítséget.


Útmutató

Ez a rész ismerteti a Microsoft NNTP-szolgáltatás kezelését, és bemutatja a Microsoft NNTP-szolgáltatás kezeléséhez használható két felügyeleti eszközt.

A rész a következő témaköröket tartalmazza:

  • A felügyeleti eszközök használata
  • Virtuális NNTP-kiszolgálók indítása, leállítása és szüneteltetése
  • A Microsoft NNTP-szolgáltatás indítása, leállítása és szüneteltetése
  • Virtuális könyvtárak használata a cikkek több meghajtón való tárolásához
  • Hírcsoportok kezelése
  • Adatbiztonsági beállítások
  • Vezérlőüzenetek feldolgozása
  • Hírcsoportok indexelése a Microsoft Indexelő szolgáltatás használatával
  • További virtuális NNTP-kiszolgálók létrehozása
  • Virtuális kiszolgáló beállítása fürtözéshez


A felügyeleti eszközök használata

Az NNTP-szolgáltatás kezelésére szolgáló felügyeleti eszköz neve Microsoft Management Console (MMC). Ez az eszköz a szolgáltatás működtetéséhez kapcsolódó összes feladat ellátására alkalmas, használatához helyi hálózati (LAN) kapcsolatra van szükség.

A telepítőprogram ezt a felügyeleti eszközt alapértelmezés szerint telepíti a Microsoft NNTP-szolgáltatást futtató számítógépre.

Amennyiben a Microsoft Management Console használatával távoli számítógépről kívánja kezelni a szolgáltatást, mindenképpen Microsoft Windows 2000 operációs rendszer alatt működő számítógépet kell használnia, és a távoli számítógépre telepítenie kell a Windows 2000 Felügyeleti eszközöket is.

Megjegyzés A Microsoft NNTP-szolgáltatás működtetéséhez a felügyelőknek megfelelő engedélyeket kell adnia. További információt az Adatbiztonsági beállítások című részben talál.


A Microsoft Management Console használata

A Microsoft NNTP-szolgáltatás a Microsoft Management Console segítségével (MMC) kezelhető, a szolgáltatást futtató számítógépről.

Megjegyzés A virtuális NNTP-kiszolgáló felügyelete a Microsoft Management Console segítségével távoli számítógépről is elvégezhető, feltéve, hogy az a Microsoft NNTP-szolgáltatással megegyező helyi hálózaton van. Ehhez azonban a távoli számítógépnek Microsoft Windows 2000 operációs rendszer alatt kell működnie, és telepíteni kell rá a Windows 2000 Felügyeleti eszközöket is.

A Microsoft Management Console használata a Microsoft NNTP-szolgáltatást futtató számítógépen:

  1. Kattintson a Start menü Beállítások elemére, majd a Vezérlőpult menüpontra.
  2. Kattintson a Felügyeleti eszközök parancsra, majd kattintson a Számítógép-kezelés menüpontra.
  3. A konzolfában bontsa ki a Szolgáltatások és kiszolgálói alkalmazások, majd az Internet Information Services csomópontot.

Megjegyzés A szolgáltatás telepítésekor létrehozott virtuális kiszolgáló az alapértelmezett virtuális NNTP-kiszolgáló.

Virtuális NNTP-kiszolgáló tulajdonságainak megtekintése vagy módosítása

  1. Kattintással jelölje ki a módosítani kívánt virtuális NNTP-kiszolgálót.
  2. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. Kattintson a megtekinteni vagy módosítani kívánt tulajdonságlapra.
  4. Igényei szerint módosítsa a beállításokat. (A tulajdonságlapokon levő beállításokról a Tulajdonságlapok ismertetése című részben talál további információt.)

Hírcsoport, elévülési szabályzat vagy virtuális könyvtár tulajdonságainak megtekintése vagy módosítása

  1. Bontsa ki a kívánt virtuális NNTP-kiszolgáló csomópontját.
  2. Kattintson a Hírcsoportok, Elévülési szabályzatok, illetve Virtuális könyvtárak elemek egyikére.
  3. A részleteket tartalmazó ablaktáblán jelölje ki a megtekinteni vagy módosítani kívánt hírcsoportot, elévülési szabályzatot vagy virtuális könyvtárat.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. Igényei szerint módosítsa a beállításokat. (A tulajdonságlapokon levő beállításokról a Tulajdonságlapok ismertetése című részben talál további információt.)


Virtuális NNTP-kiszolgálók indítása, leállítása és szüneteltetése

A Microsoft Management Console használatával az alapértelmezett virtuális NNTP-kiszolgáló és a létrehozott további virtuális kiszolgálók bármelyike elindítható, leállítható, illetve szüneteltethető.

Megjegyzés Hasonlóképpen, a Microsoft NNTP-szolgáltatás is elindítható, leállítható és szüneteltethető. Tudni kell azonban, hogy a szolgáltatás leállítása a számítógépen futó összes virtuális NNTP-kiszolgáló leállását eredményezi. A Microsoft NNTP-szolgáltatás leállítása esetén a Microsoft Management Console nem használható a virtuális NNTP-kiszolgálók felügyeletére, kezelésére.

Egy virtuális NNTP-kiszolgáló elindítás után fogad új kapcsolatokat a felhasználóktól. Amikor leállítja a virtuális NNTP-kiszolgálót, az leválasztja a hozzá kapcsolódó felhasználókat, és nem fogad újabb kapcsolatokat. Egy virtuális NNTP-kiszolgáló szüneteltetése esetén a kiszolgáló továbbra is kiszolgálja a korábban létrejött kapcsolatokat, de nem fogad újabbakat. Amennyiben le szeretne állítani egy virtuális NNTP-kiszolgálót, de az éppen hozzá kapcsolódó felhasználókat nem kívánja leválasztani, választhatja a kiszolgáló biztonságos, rendezett leállítását.

Virtuális NNTP-kiszolgáló indítása, leállítása és szüneteltetése a Microsoft Management Console használatával

  1. Indítsa el a Microsoft Management Console-t.
  2. Az egérrel rákattintva jelölje ki a kívánt virtuális NNTP-kiszolgálót.
  3. Kattintson a Művelet menü Indítás, Leállítás vagy Szüneteltetés parancsára.

Virtuális NNTP-kiszolgáló biztonságos leállítása

  1. Szüneteltesse a virtuális kiszolgálót, ezzel megakadályozhatja, hogy a felhasználók újabb kapcsolatokat hozzanak létre.
  2. Ellenőrizze az éppen kapcsolódó felhasználókat, például a Microsoft Management Console segítségével. Válassza a konzolfán az Aktuális munkamenetek elemet. A részleteket mutató ablaktáblán megjelenik az összes kapcsolódó felhasználó.
  3. Amennyiben meg kívánja tiltani az éppen kapcsolódó felhasználóknak új cikkek közzétételét, kattintson az NNTP-kiszolgáló Beállítások tulajdonságlapjára, majd törölje a jelölést az Ügyféloldali közzététel engedélyezése jelölőnégyzetből.
  4. Amikor az összes felhasználó lekapcsolódott a szolgáltatásról, állítsa le a virtuális NNTP-kiszolgálót.


A Microsoft NNTP-szolgáltatás indítása, leállítása és szüneteltetése

A Microsoft NNTP-szolgáltatás a Microsoft Windows 2000 Server operációs rendszeren szolgáltatásként fut. Egy számítógépen ugyan több virtuális NNTP-kiszolgáló is lehet, a Microsoft NNTP-szolgáltatás azonban csak egy példányban futhat rajta.

A Microsoft NNTP-szolgáltatás futása közben egymástól függetlenül elindíthatja, leállíthatja vagy szüneteltetheti az egyes virtuális kiszolgálókat. Fontos megjegyezni azonban, hogy a teljes Microsoft NNTP-szolgáltatás szüneteltetése vagy leállítása az összes virtuális NNTP-kiszolgálóra hatással van. A szolgáltatás leállítása esetén a Microsoft Management Console nem használható a virtuális NNTP-kiszolgálók felügyeletére, kezelésére.

Megjegyzés A fenti korlátozás alól az egyetlen kivétel az, hogy a Microsoft Management Console használatával még akkor is elindíthat egy virtuális kiszolgálót, amikor a Microsoft NNTP-szolgáltatás le van állítva. Egy virtuális NNTP-kiszolgáló indítása ugyanis a teljes Microsoft NNTP-szolgáltatás újraindítását eredményezi, és ezáltal egyúttal minden — a Microsoft NNTP-szolgáltatás leállítását megelőzően futó — virtuális NNTP-kiszolgáló is újra elindul.

A Microsoft NNTP-szolgáltatás elindítás után fogad új kapcsolatokat a felhasználóktól. Amikor leállítja a Microsoft NNTP-szolgáltatást, az leválasztja a hozzá kapcsolódó felhasználókat, és nem fogad újabb kapcsolatokat. A Microsoft NNTP-szolgáltatás szüneteltetése esetén az éppen futó virtuális NNTP-kiszolgálók továbbra is kiszolgálják a korábban létrejött kapcsolatokat, de nem fogadnak újabbakat. Amennyiben le szeretné állítani a Microsoft NNTP-szolgáltatást, de az egyes virtuális kiszolgálókhoz éppen kapcsolódó felhasználókat nem kívánja leválasztani, választhatja a szolgáltatás biztonságos, rendezett leállítását.

A Microsoft NNTP-szolgáltatás indítása, leállítása vagy szüneteltetése a Felügyeleti eszközökkel

  1. Kattintson a Start menü Programok elemére, majd a Felügyeleti eszközök menüpontra.
  2. Válassza a Komponensszolgáltatások parancsot.
  3. A Komponensszolgáltatások ablakban jelölje ki a Szolgáltatások (helyi) csomópontot.
  4. Amennyiben szükséges, a jobb oldali ablaktáblán görgesse lefelé a Windows 2000 szolgáltatásait tartalmazó listát, amíg megtalálja a Microsoft NNTP-szolgáltatáshoz tartozó Network News Transfer Protocol (NNTP) bejegyzést. Kattintson az egér jobb oldali gombjával a listabejegyzésre, majd válassza a helyi menü Indítás, Leállítás vagy Szüneteltetés parancsát.
Megjegyzés Amikor újraindítja a Microsoft NNTP-szolgáltatást, a szolgáltatás leállításának pillanatában futó összes virtuális NNTP-kiszolgáló automatikusan újraindul. Ezzel szemben a szolgáltatás leállításakor már eleve nem futó virtuális NNTP-kiszolgálók a Microsoft NNTP-szolgáltatás újraindításakor nem indulnak újra.

A Microsoft NNTP-szolgáltatás biztonságos leállítása

  1. A fent ismertetett lépések végrehajtásával szüneteltesse a Microsoft NNTP-szolgáltatást, ezzel megakadályozhatja új kapcsolatok létrehozását.
  2. Ellenőrizze az egyes virtuális NNTP-kiszolgálókhoz éppen kapcsolódó felhasználókat, például a Microsoft Management Console segítségével. A konzolfán sorra kattintson az egyes virtuális NNTP-kiszolgálók alatti Aktuális munkamenetek elemre, így a részleteket mutató ablaktáblán megtekintheti az adott kiszolgálóhoz kapcsolódó felhasználókat.
  3. Amennyiben meg kívánja tiltani az éppen kapcsolódó felhasználóknak új cikkek közzétételét, kattintson a Beállítások tulajdonságlapra, majd törölje a jelölést az Ügyféloldali közzététel engedélyezése jelölőnégyzetből.
  4. Egyesével állítsa le a virtuális NNTP-kiszolgálókat, miután az összes felhasználó levált az adott kiszolgálóról.
  5. Amikor az összes felhasználó lekapcsolódott minden egyes virtuális kiszolgálóról, állítsa le a Microsoft NNTP-szolgáltatást.


Az alapértelmezett indítási beállítások módosítása

A Microsoft NNTP-szolgáltatás indításakor érvényes alapértelmezett beállításokat a Felügyeleti eszközökkel határozhatja meg.

  1. Mutasson az egérrel a Start menü Programok, majd Felügyeleti eszközök elemére, és végül kattintson a Komponensszolgáltatások menüpontra.
  2. A konzolfán jelölje ki a Szolgáltatások (helyi) csomópontot.
  3. Az egér jobb oldali gombjával kattintson a jobb oldalon látható lista Network News Transfer Protocol (NNTP) elemére, majd válassza a helyi menü Tulajdonságok parancsát.
  4. Az Általános lap Indítási típus listáján válasszon az Automatikus, Kézi és Letiltva lehetőségek közül.


Hírcsoportok kezelése

A felhasználók a hírcsoportok létrehozása után azonnal megkezdhetik cikkeik közzétételét. Ha azt szeretné, hogy az új cikkeket közzététel előtt egy moderátor jóváhagyja, használjon moderált hírcsoportot.

A létező hírcsoportok tulajdonságait igény szerint módosíthatja, illetve ha már nincs szüksége valamelyik hírcsoportra, akár törölheti is azt. Olyan beállításokat is megadhat, amelyek értelmében a Microsoft NNTP-szolgáltatás automatikusan törölheti a hírcikkeket a megadott számú óra eltelte után, vagy ha a hírcsoportok által elfoglalt lemezterület elér egy meghatározott korlátot. Mindezeken felül azt is kiszűrheti, hogy mely hírcsoportokat lássák a felhasználók, illetve megadhatja, hogy a hírcsoportok felsorolásában hány hírcsoport jelenjen meg, amikor valaki kijelöli a virtuális NNTP-kiszolgáló alatti Hírcsoportok csomópontot.

Ez a rész az alábbi műveleteket ismerteti:

  • Hírcsoportok létrehozása
  • Hírcsoportok moderálása
  • Hírcsoportok szerkesztése és törlése
  • Hírcsoportok méretének korlátozása és elévülési idejének beállítása
  • A hírcsoportok felsorolásában megjelenő elemek számának korlátozása


Hírcsoportok létrehozása

Hírcsoport létrehozásához használja az Új hírcsoport varázslót. Új hírcsoport létrehozásakor a Microsoft NNTP-szolgáltatás automatikusan létrehozza a hírcsoport könyvtárát. Ha azt szeretné, hogy az új cikkeket közzététel előtt egy moderátor jóváhagyja, létrehozhat moderált hírcsoportot is.

Hírcsoport létrehozása

  1. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon a Hírcsoportok csomópont.
  2. Az egér jobb oldali gombjával kattintson a Hírcsoportok csomópontra, a helyi menüben mutasson az Új menüpontra, majd kattintson a Hírcsoport parancsra.
  3. Kövesse az Új hírcsoport varázsló utasításait. A Név mezőbe gépelje be a létrehozni kívánt hírcsoport nevét.
  4. A Leírás mezőben megadhatja a hírcsoport funkciójának rövid leírását.
  5. Igény szerint beszédesebb nevet is adhat a hírcsoportnak, amelyet a Közérthető név mezőbe gépelhet be. A közérthető név tulajdonképpen a hírcsoport másodlagos neve, amelyet az ügyfelek a List Prettynames NNTP-paranccsal kérhetnek le a kiszolgálótól.
  6. Kattintson a Befejezés gombra.


Hírcsoportok moderálása

Amennyiben ellenőrizni kívánja a hírcsoportban közzétenni kívánt cikkeket, hozzon létre moderált hírcsoportot. A moderált hírcsoportba küldött cikkeket a rendszer mindaddig nem teszi közzé, amíg az adott hírcsoporthoz kijelölt moderátor jóvá nem hagyja azokat.

A Microsoft NNTP-szolgáltatás a felhasználók által a moderált hírcsoportban közzétenni kívánt cikkeket először elküldi a hírcsoport moderátorának. A moderátor vagy jóváhagyja a cikket, és közzétételre visszaküldi a Microsoft NNTP-szolgáltatásnak, vagy egyszerűen elutasítja azt. A cikkek elutasításáról a moderátor értesítheti az adott cikk szerzőjét, és üzenetében magyarázatot adhat a cikk elutasítására.

Bármely NNTP-ügyfélprogram alkalmas moderált hírcsoportokba szánt üzenetek közzétételére, a moderátornak azonban mindenképpen olyan NNTP-ügyfélprogramot kell használnia, amely lehetővé teszi a moderálással kapcsolatos feladatok végrehajtását.

Moderált hírcsoportok használatához meg kell adnia vagy egy Simple Mail Transfer Protocol (SMTP) levelezési kiszolgálót, amelynek segítségével a cikkek közvetlenül elküldhetők a moderátoroknak, vagy pedig azt a könyvtárat, amelyben a rendszer a moderátorok általi jóváhagyásra váró cikkeket tárolja.

Megadhat alapértelmezett moderátori tartományt is. Ha úgy dönt, hogy egy hírcsoporthoz az alapértelmezett moderátort kívánja használni, a rendszer a cikkeket a hírcsoportnév@alapértelmezett_tartomány címre küldi el, ahol hírcsoportnév az adott hírcsoport neve. Ha az alapértelmezett tartomány kiszolgalo.com, akkor például a rec.sport.tenisz hírcsoportban közzétenni kívánt cikkeket a rendszer a rec-sport-tenisz@kiszolgalo.com címre küldi el (a hírcsoport nevében szereplő pontokat a levélcímben automatikusan kötőjellel helyettesíti).

Moderált hírcsoportok engedélyezése

  1. Kattintson a Beállítások fülre.
  2. A Moderált csoportok SMTP-kiszolgálója mezőben adja meg az SMTP-kiszolgáló DNS-beli nevét vagy IP-címét, vagy gépelje be a moderátorok jóváhagyására váró cikkek tárolókönyvtárának elérési útvonalát. A könyvtárnak mindenképpen helyi könyvtárnak kell lennie. Általában célszerű az SMTP-kiszolgáló felvételi könyvtárát megadni, amely alapértelmezés szerint az \Inetpub\Mailroot\Pickup könyvtár.
  3. Az Alapértelmezett moderátori tartomány mezőbe gépelje be annak a tartománynak a nevét, amelyet a rendszer az alapértelmezett moderátoroknak szóló elektronikus levelek címzésére használhat.
  4. Kattintson az OK gombra.
  5. SMTP-kiszolgáló megadása esetén ellenőrizze, hogy a Microsoft NNTP-szolgáltatás futtatásához használt felhasználói azonosító (alapértelmezés szerint a rendszerfiók) be van-e állítva felhasználói fiókként az SMTP-kiszolgálón.

Moderált hírcsoport létrehozása

  1. Amennyiben még nem tette meg, hozza létre a hírcsoportot. Az Új hírcsoport varázsló futásának befejeződése után az eljárás új és már létező hírcsoportok esetén teljesen megegyezik.
  2. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon a Hírcsoportok csomópont.
  3. A Hírcsoportok csomópontra kattintva jelenítse meg a virtuális NNTP-kiszolgálón található hírcsoportokat a részleteket tartalmazó ablaktáblán.
  4. Kattintson a kívánt hírcsoportra az egér jobb oldali gombjával, majd válassza a helyi menü Tulajdonságok parancsát.
  5. A megjelenő párbeszédpanelen jelölje be a Moderált jelölőnégyzetet.
  6. Gépelje be a moderátor elektronikus levélcímét a Moderátor mezőbe, vagy kattintson az Alapértelmezés gombra az alapértelmezett moderátor használatához.
  7. Kattintson az OK gombra.


Hírcsoportok szerkesztése és törlése

A Microsoft NNTP-szolgáltatás létező hírcsoportjainak tulajdonságait igény szerint szerkesztheti, illetve ha már nincs szüksége valamelyik hírcsoportra, akár törölheti is azt.

Hírcsoport szerkesztése vagy törlése

  1. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon a Hírcsoportok csomópont.
  2. A Hírcsoportok csomópontra kattintva jelenítse meg a virtuális NNTP-kiszolgálón található hírcsoportokat a részleteket tartalmazó ablaktáblán.
  3. Kattintson a kívánt hírcsoportra az egér jobb oldali gombjával. A hírcsoport tulajdonságainak szerkesztéséhez válassza a helyi menü Tulajdonságok parancsát, a hírcsoport törléséhez pedig használja a Törlés menüpontot.


Hírcsoportok méretének korlátozása és elévülési idejének beállítása

Elévülési szabályzat megadásával korlátozhatja, hogy a Microsoft NNTP-szolgáltatás mennyi ideig őrizze meg a hírcsoportokban közzétett cikkeket. Egy elévülési szabályzat egy vagy több hírcsoportra is vonatkozhat. Annyi elévülési szabályzatot definiálhat, amennyire szüksége van. A rendszer az elévülési szabályzat beállításaitól függetlenül elsőként mindig a legrégebbi cikkeket törli.

Amennyiben egy hírcsoporthoz nem ad meg elévülési szabályzatot, célszerű a feleslegessé vált cikkeket rendszeres időközönként kézzel törölni.

Elévülési szabályzat létrehozása

  1. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon az Elévülési szabályzatok csomópont.
  2. Az egér jobb oldali gombjával kattintson az Elévülési szabályzatok csomópontra, a helyi menüben mutasson az Új menüpontra, majd kattintson az Elévülési szabályzat parancsra.
  3. Kövesse az Új NNTP elévülési szabályzat varázsló utasításait. Az elévülési szabályzatok paramétereiről Az Elévülési szabályzat párbeszédpanel című témakörben talál további információt.

Létező elévülési szabályzat módosításához, illetve az elévülési szabályzat hatáskörébe tartozó hírcsoportok megváltoztatásához használja az Elévülési szabályzat párbeszédpanelt.

Elévülési szabályzat módosítása

  1. A Microsoft Management Console ablakában kattintson a virtuális NNTP-kiszolgáló alatt látható Elévülési szabályzatok csomópontra.
  2. A részleteket tartalmazó ablaktáblán kattintson a módosítani kívánt elévülési szabályzatra.
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Igény szerint változtassa meg az Elévülési szabályzat párbeszédpanelen levő beállításokat.


A hírcsoportok felsorolásában megjelenő elemek számának korlátozása

A Hírcsoportok keresése párbeszédpanelen korlátozhatja, hogy hány hírcsoport jelenjen meg a felsorolásban, amikor egy felhasználó kijelöli a Microsoft Management Console (MMC) ablakában a virtuális NNTP-kiszolgáló alatt látható Hírcsoportok csomópontot.

Egy-egy kiszolgálón akár több ezer hírcsoport is lehet, és elképzelhető, hogy nem lehetséges mindet felsorolni egy listán. Ezért a rendszergazdák sokszor célszerűnek tartják korlátozni a felsorolásban megjelenő hírcsoportok számát. Ehhez szűrheti a hírcsoportokat típus szerint, beállíthatja a megjelenített hírcsoportok számának felső korlátját, vagy alkalmazhatja egyszerre mindkét módszert.

A felsorolásban megjelenő hírcsoportok számának korlátozása

  1. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon a Hírcsoportok csomópont.
  2. Kattintson a Hírcsoportok csomópontra a jobb oldali egérgombbal, majd kattintson a Csoportfelsorolás korlátozása menüpontra. Ekkor megnyílik a Hírcsoportok keresése párbeszédpanel.
  3. A Hírcsoportok mezőben megadhatja, hogy milyen típusú hírcsoportok jelenjenek meg az MMC ablakában a Hírcsoportok csomópont kijelölésekor. A program minden ettől eltérő típust kiszűr. A szűréshez használjon helyettesítő karaktereket, mint például az alt.* karakterláncban: e szűrő begépelése esetén a felhasználók csak az alt hierarchiába tartozó hírcsoportokat láthatják. Alapértelmezés szerint típustól függetlenül az összes hírcsoport megjelenik a listán.
    Megjegyzés
    A mezőbe begépelheti egy adott hírcsoport nevét is, de ebben az esetben a felhasználók csak azt az egy hírcsoportot látják majd. Egyszerre csak egy hírcsoportnév vagy helyettesítő karakteres szűrő adható meg.
  4. Amennyiben nem kívánja korlátozni a felsorolásban megjelenő hírcsoportok számát, törölje a jelölést Az eredményeknél megjelenítendő elemek számának korlátozása jelölőnégyzetből. Alapértelmezés szerint a jelölőnégyzet be van jelölve.
  5. Az elemek száma legfeljebb mezőbe gépelje, hogy az adott virtuális kiszolgálóhoz tartozó felsorolásban legfeljebb hány hírcsoportot kíván megjeleníteni. Ez a korlátozás csak akkor jut érvényre, ha bejelölte Az eredményeknél megjelenítendő elemek számának korlátozása jelölőnégyzetet. A korlát alapértelmezés szerint 100 hírcsoport.


Virtuális könyvtárak használata a cikkek több meghajtón való tárolásához

A virtuális könyvtár a hírcsoport-hierarchia egy részének gyökereként szolgáló, valamelyik helyi vagy távoli lemezmeghajtón található könyvtár. Virtuális könyvtárak használatával a hírcsoportok fájljai több meghajtón tárolhatók, aminek legfőbb előnye az, hogy több lemezmeghajtó jobb teljesítményt és nagyobb tárolókapacitást nyújt, mint egyetlen, nagy megterhelésnek kitett meghajtó. Virtuális könyvtárak használatával a hírcikkeket tároló könyvtár valós helye is bármikor megváltoztatható anélkül, hogy a hírcsoport nevét módosítani kellene.

Az egyes virtuális könyvtárak a hírcsoport-hierarchia egy-egy részét tartalmazzák. A Kutatás nevű virtuális könyvtár tartalmazhatja például a kutatas.* nevű hírcsoportokat.

A virtuális könyvtárak bármelyik helyi vagy hálózati meghajtón lehetnek. Semmiféle előnnyel nem jár, ha a virtuális könyvtárat a kezdőkönyvtáréval megegyező fizikai meghajtón hozza létre.


Virtuális könyvtár létrehozása

Annyi virtuális könyvtárat hozhat létre, amennyire szüksége van. A virtuális könyvtárak struktúráját célszerű a hírcsoportrendszer felépítésének megfelelően kialakítani.

Virtuális könyvtár létrehozása

  1. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon a Virtuális könyvtárak csomópont.
  2. Az egér jobb oldali gombjával kattintson a Virtuális könyvtárak csomópontra, a helyi menüben mutasson az Új menüpontra, majd kattintson a Virtuális könyvtár parancsra.
  3. Kövesse az Új virtuális NNTP-könyvtár varázsló utasításait. Hozzon létre egy hírcsoport al-fát az adott virtuális könyvtárhoz.
  4. A hírtartalom tárolási helyeként válassza a Fájlrendszer (helyi tárolóhely) vagy a Megosztott távoli hely lehetőséget. Ez a hely szükség esetén a későbbiekben is bármikor módosítható, ha rákattint a Virtuális könyvtár párbeszédpanelen található Tartalom gombra.
  5. Amennyiben tárolóhelyként a Fájlrendszer lehetőséget választotta, gépelje be a helyi mappa elérési útvonalát, vagy a Tallózás gombra kattintva válassza ki a megfelelő mappát. Ha a Megosztott távoli hely lehetőséget választotta, gépelje be a távoli hely elérési útvonalát, vagy a Tallózás gombra kattintva válasszon ki egy távoli mappát. Távoli hely használata esetén meg kell adnia egy felhasználónevet és jelszót is, amelynek használatával a Microsoft NNTP-szolgáltatás bejelentkezhet a távoli számítógépre. Gépeljen be egy nevet, vagy a Tallózás gombra kattintva keressen ki egyet. Az Ellenőrzés gombra kattintva meggyőződhet arról, hogy a használni kívánt felhasználónév és jelszó kombinációja érvényes-e.

    Megjegyzés Amennyiben távoli helyet használ a tartalom tárolására, a szolgáltatásnak megadott felhasználónév számára legalább olvasási/írási jogosultságot kell biztosítania a távoli számítógépen.

Virtuális könyvtár módosítása

  1. A Microsoft Management Console ablakában kattintson a virtuális NNTP-kiszolgáló alatt látható Virtuális könyvtárak csomópontra.
  2. A részleteket tartalmazó ablaktáblán jelölje ki a módosítani kívánt virtuális könyvtárat.
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Igény szerint változtassa meg a Virtuális könyvtár párbeszédpanelen levő beállításokat.


Adatbiztonsági beállítások

Alapértelmezés szerint bármely felhasználó, aki kapcsolódni tud a Microsoft NNTP-szolgáltatáshoz, megtekintheti az összes hírcsoportot. Ilyen esetben a felhasználók névtelenül, azaz felhasználónevük és jelszavuk megadása nélkül is kapcsolódhatnak a szolgáltatáshoz. A telepítőprogram a névtelenül bejelentkező felhasználók számára létrehoz egy külön Windows 2000 Server fiókot.

Az adatok biztonsága érdekében azonban beállíthatja, hogy adott felhasználók mely hírcsoportokhoz férhetnek hozzá, illetve hogy ki jogosult a Microsoft NNTP-szolgáltatás kezelésére. A hozzáférés az ügyfélszámítógépek IP-címe alapján is korlátozható. Amennyiben a felhasználók nyilvános hálózaton keresztül kapcsolódnak a Microsoft NNTP-szolgáltatáshoz, a kapcsolat az SSL protokoll használatával titkosítható, így mások illetéktelenül nem férhetnek hozzá az éppen küldött és fogadott cikkekhez.

Az adatbiztonsági szolgáltatások Windows 2000 Server fiókok és könyvtárhozzáférési engedélyek használatán alapulnak. Az pedig, hogy a hírcsoportokhoz mely felhasználók férhetnek hozzá, felhasználónév és jelszó alapján korlátozható.

Ez a rész az alábbi műveleteket ismerteti:

  • A hírcsoportokhoz való hozzáférés korlátozása
  • A hozzáférés korlátozása IP-cím alapján
  • A felügyelői hozzáférés korlátozása
  • Kapcsolatok titkosítása az SSL használatával

Az adatbiztonsági kérdésekről az IIS on-line dokumentációjának Adatbiztonság című részében talál további információt.


A hírcsoportokhoz való hozzáférés korlátozása

Az egyes hírcsoportokhoz, illetve hírcsoportok halmazaihoz való hozzáférés a hírcsoportokat tartalmazó könyvtárak Windows 2000 Serverbeli hozzáférési engedélyeinek beállításával szabályozható. Az engedélyeket egy adott könyvtárra vagy könyvtárak halmazára is beállíthatja. (A beállítás menetéről az IIS on-line dokumentációjának Fájlok vagy könyvtárak hozzáférési engedélyeinek beállítása az NTFS fájlrendszerben című részében talál részletes útmutatást.) Az ügyfélszámítógépek IP-címe alapján pedig egyszerre az összes hírcsoporthoz való hozzáférést korlátozhatja.

Amennyiben nem kívánja korlátozni a hozzáférést valamely hírcsoporthoz, engedélyezze a névtelen hozzáférést, és ne állítson be Windows 2000 Serverbeli könyvtárhozzáférési engedélyeket arra a könyvtárra, amelyben az adott hírcsoport található. A névtelen hozzáférés engedélyezéséhez kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra, majd a megjelenő párbeszédpanelen jelölje be a Névtelen engedélyezése jelölőnégyzetet.

Hírcsoporthoz való hozzáférés korlátozása

  1. Minden felhasználó számára hozzon létre egy Windows 2000 Server fiókot.
  2. Állítsa be a Windows 2000 Server hozzáférési engedélyeket az adott hírcsoportot tartalmazó könyvtárra. Fontos, hogy a helyi rendszerfióknak teljes körű hozzáférési jogokat adjon a hírcsoportokat tartalmazó összes könyvtárhoz, mert különben a Microsoft NNTP-szolgáltatás nem tud hozzáférni saját fájljaihoz.
  3. Állítsa be a Microsoft NNTP-szolgáltatás által használt hitelesítési módszert.

A Windows 2000 Server operációs rendszerben hozzon létre felhasználói fiókokat a Felhasználókezelő segítségével. Az egyszerűbb adminisztráció érdekében a felhasználókat célszerű csoportokba szervezni, és az engedélyeket csoportonként megadni. Ha lehetséges, használja a cégen vagy szervezeten belül korábban már létrehozott fiókokat és csoportokat.

A Microsoft NNTP-szolgáltatásban két módszer közül választhat a felhasználók hitelesítéséhez:

  • Alapfokú hitelesítés
  • Windows biztonsági csomag

A hitelesítési módszer beállítása

  1. Jelölje ki a virtuális NNTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra.
  3. Válasszon ki egy vagy több hitelesítési módszert a Névtelen engedélyezése, az Alapfokú hitelesítés, a Windows biztonsági csomag, illetve az SSL ügyfél-hitelesítés engedélyezése jelölőnégyzet bejelölésével.
  4. Amennyiben hozzáféréskor kötelezővé kívánja tenni az SSL-hitelesítés használatát, jelölje be az SSL ügyfél-hitelesítés szükséges jelölőnégyzetet. Az ügyfélbizonyítványok Windows felhasználói fiókokhoz való hozzárendeléséhez jelölje be az Ügyfélbizonyítványok hozzárendelésének engedélyezése Windows felhasználói fiókokhoz jelölőnégyzetet, majd kattintson az Ügyfél-hozzárendelés gombra.


A hozzáférés korlátozása IP-cím alapján

A Microsoft NNTP-szolgáltatáshoz való hozzáférést korlátozhatja az ügyfélszámítógépek IP-címe alapján. Alapértelmezés szerint minden IP-cím jogosult a Microsoft NNTP-szolgáltatás használatára.

Összeállíthat egy IP-címekből álló listát, és az ezen szereplő címek számára engedélyezheti, illetve megtilthatja a hozzáférést. Az IP-címeket megadhatja egyenként, vagy alhálózati maszk segítségével csoportos formában. Az IP-címeket tartománynévvel is megadhatja, de ebben az esetben a rendszer minden kapcsolatnál végrehajt egy DNS-beli keresést, és ez jelentősen növeli az erőforrásigényt. (Az alhálózati maszkok megadásáról a Microsoft Windows 2000 Server Hálózatkezelési útmutatójában olvashat bővebben.)

A hozzáférés korlátozása IP-cím alapján:

  1. A Microsoft Management Console ablakában jelölje ki a virtuális NNTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Kattintson a Hozzáférés lap Kapcsolatvezérlés részén található Kapcsolat gombra.
  3. A listán szereplő IP-címektől Az alábbi listán szereplők kivételével az összes választógomb bejelölésével tagadhatja meg a hozzáférést, a Csak az alábbi listán szereplők választógombra kattintva pedig engedélyezheti a hozzáférést a listára felvett IP-címek számára.
  4. A virtuális NNTP-kiszolgálóhoz való hozzáférésre jogosult vagy nem jogosult IP-címeket egyenként, a Hozzáadás gombra kattintva veheti fel a listára.
  5. A Számítógép párbeszédpanelen válasszon egyet a következő lehetőségek közül: Egyedi számítógép, Számítógépcsoport, illetve Tartomány. Ezután kövesse az alábbi lépéseket:
    • Az Egyedi számítógép beállítás választása esetén: Az IP-cím mezőbe gépelje be a számítógép IP-címét. (Ha nem tudja az IP-címet, kattintson a DNS keresése gombra.)
    • A Számítógépcsoport beállítás választása esetén: Az Alhálózati cím mezőbe gépelje be az IP-címet, majd az Alhálózati maszk mezőbe gépelje be a számítógépcsoport alhálózati maszkját.
    • A Tartomány beállítás választása esetén: A Név mezőbe gépelje be a számítógép tartományának nevét.
  6. Kattintson az OK gombra.


A felügyelői hozzáférés korlátozása

A Microsoft NNTP-szolgáltatás kezelőinek felügyelői jogokkal kell rendelkezniük. Alapértelmezés szerint a Windows 2000 Server operációs rendszer Rendszergazdák csoportjába tartozó összes felhasználó felügyelői jogokat kap.

Felügyelő hozzáadása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális NNTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Kattintson az Adatbiztonság lapon található Hozzáadás gombra, ekkor megnyílik a Felhasználók vagy csoportok kijelölése párbeszédpanel.
  3. A Keresés itt legördülő listáról válassza ki a hozzáadni kívánt felügyelő tartományát.
  4. A Név oszlopban jelölje ki a kívánt felügyelőt vagy csoportot, majd kattintson a Hozzáadás gombra.
  5. Amikor végzett a felügyelők kijelölésével, kattintson az OK gombra.

Felügyelő eltávolítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális NNTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Jelölje ki az eltávolítani kívánt felügyelőt az Adatbiztonság lap Felügyelők listáján.
  3. Kattintson az Eltávolítás gombra.
  4. Kattintson az OK gombra.


Kapcsolatok titkosítása az SSL használatával

Az SSL (Secure Sockets Layer) használata biztonságos, titkosított kapcsolatot tesz lehetővé a Microsoft NNTP-szolgáltatás és az ügyfélszámítógép között. A nyilvános hálózaton, például az Interneten keresztül kapcsolódó felhasználók esetén az SSL használatával biztosítható a bizalmas adatok védelme.

Az SSL használatához SSL-bizonyítványra is szükség van, amelyet a Windows 2000 Server operációs rendszert futtató számítógépre kell telepíteni. Az SSL használatát az ügyfélszoftvernek is támogatnia kell. A Microsoft Outlook Express támogatja az SSL-t.

Amennyiben telepítettek kiszolgálói bizonyítványt, a Microsoft NNTP-szolgáltatás az ügyfelek kérésére mindig használja majd az SSL-t. Az SSL használata igény szerint egy adott virtuális könyvtárban levő hírcsoportok, vagy akár az összes hírcsoport eléréséhez is kötelezővé tehető. Ha szükségesnek tartja, SSL ügyfél-hitelesítést is alkalmazhat.

Az SSL használatának engedélyezése

  • Szerezzen be és telepítsen egy SSL kiszolgálói bizonyítványt. (Ennek menetéről az IIS on-line dokumentációjának Adatbiztonság című részében talál további információt.)

SSL-kapcsolat kötelezővé tétele a hírcsoportok eléréséhez

  1. A Microsoft Management Console ablakában kattintson a virtuális NNTP-kiszolgáló alatt látható Virtuális könyvtárak csomópontra.
  2. A részleteket tartalmazó ablaktáblán jelölje ki a módosítani kívánt virtuális könyvtárat.
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Virtuális könyvtár párbeszédpanel Biztonságos kommunikáció részén található Biztonságos gombra.
  5. Az Adatbiztonság párbeszédpanelen jelölje be a Biztonságos csatorna szükséges jelölőnégyzetet.

Az ügyfelek SSL-hitelesítésének engedélyezése

  1. A Microsoft Management Console ablakában jelölje ki a virtuális NNTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra, majd jelölje be az SSL ügyfél-hitelesítés engedélyezése jelölőnégyzetet.


Vezérlőüzenetek feldolgozása

A vezérlőüzenetek speciálisan formázott üzenetek, amelyek a Microsoft NNTP-szolgáltatást egy hírcsoport adott cikkének törlésére, vagy akár egy egész hírcsoport hozzáadására, illetve eltávolítására utasítják. Amikor például úgy dönt, hogy a Microsoft Outlook Express Visszavonás parancsával törli egy adott hírcsoportban korábban közzétett cikkét, az ügyfél egy vezérlőüzenetet küld a Microsoft NNTP-szolgáltatásnak, amellyel az adott cikk törlésére utasítja.

A cikkek és hírcsoportok nem kívánt módosításainak elkerülése érdekében célszerű korlátozni a vezérlőüzeneteket. Hasonlóképpen érdemes szabályozni azt is, hogy más NNTP-kiszolgálók jogosultak-e a Microsoft NNTP-szolgáltatástól cikkeket lehívni.

Ez a rész bemutatja a vezérlőüzenetek használatát, illetve részletesen ismerteti, hogy a vezérlőüzenetek korlátozásával hogyan akadályozható meg a Microsoft NNTP-szolgáltatás működésébe való jogosulatlan beavatkozás.


Vezérlőüzenetek létrehozása

A vezérlőüzeneteket az NNTP-ügyfélprogramok, az NNTP-kiszolgálók és egyes speciális segédprogramok automatikusan hozzák létre.

A Microsoft NNTP-szolgáltatás az alábbi alapvető vezérlőüzeneteket fogadja el:

  • Cancel (a megadott cikk törlése)
  • Newgroup (hírcsoport létrehozása)
  • Rmgroup (létező hírcsoport törlése)

A Cancel vezérlőüzenetet az ügyfélprogramok, míg a Newgroup és az Rmgroup üzeneteket általában NNTP-kiszolgálók generálják.


Vezérlőüzenetek korlátozása

A Microsoft NNTP-szolgáltatás a beérkezett Cancel, Newgroup és Rmgroup verzérlőüzeneteket a következő speciális hírcsoportokban teszi közzé: control.cancel, control.newgroup, illetve control.rmgroup. A vezérlőüzenetek korlátozásához korlátozza a hozzáférést e hírcsoportokhoz.

Beállíthatja, hogy a speciális control.* hírcsoportok moderált hírcsoportok legyenek, vagy megszabhatja, hogy ezekhez a hírcsoportokhoz csak bizonyos felhasználók férhessenek hozzá. Amennyiben moderált hírcsoportként állítja be őket, a moderátornak minden vezérlőüzenetet jóvá kell hagynia, mielőtt a rendszer végrehajtaná a vezérlőüzenetben küldött utasítást.

A control hírcsoportok beállítása moderált hírcsoportként

  1. A Microsoft Management Console ablakában bontsa ki a kívánt virtuális NNTP-kiszolgáló faszerkezetét, hogy láthatóvá váljon a Hírcsoportok csomópont.
  2. A Hírcsoportok csomópontra kattintva jelenítse meg a virtuális NNTP-kiszolgálón található hírcsoportokat a részleteket tartalmazó ablaktáblán.
  3. Kattintson a kívánt control hírcsoportra az egér jobb oldali gombjával, majd válassza a helyi menü Tulajdonságok parancsát.
  4. A megjelenő párbeszédpanelen jelölje be a Moderált jelölőnégyzetet.
  5. Gépelje be a moderátor elektronikus levélcímét a Moderátor mezőbe, vagy kattintson az Alapértelmezés gombra az alapértelmezett moderátor használatához.
  6. Kattintson az OK gombra.
  7. A fenti lépéseket megismételve a többi control.* hírcsoportra is adja meg ezeket a beállításokat.

A control hírcsoportokhoz való hozzáférés korlátozása:

Kövesse A hírcsoportokhoz való hozzáférés korlátozása című részben leírt lépéseket. Engedélyezze a hozzáférést az arra jogosult felhasználóknak, például a Rendszergazdák csoport tagjainak.


Hírcsoportok indexelése a Microsoft Indexelő szolgáltatás használatával

A felhasználók a Microsoft Indexelő szolgáltatás segítségével kikereshetik a hírcsoportok azon cikkeit, amelyek meghatározott kifejezéseket, szövegrészeket tartalmaznak. Az Indexelő szolgáltatás meghatározott időközönként frissíti azt a katalógust, amelyben a felhasználók — egy testreszabott weblapon keresztül — kereshetnek.

Az Indexelő szolgáltatással kapcsolatos alapfogalmakról az Indexelő szolgáltatás on-line dokumentációjában olvashat bővebben.

Indexelés engedélyezése a Microsoft NNTP-szolgáltatásban:

  1. A Microsoft Management Console ablakában kattintson a virtuális NNTP-kiszolgáló alatt látható Virtuális könyvtárak csomópontra.
  2. A részleteket mutató ablaktáblán kattintson az indexelni kívánt hírcsoportot tartalmazó virtuális könyvtárra.
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. A Virtuális könyvtár párbeszédpanelen jelölje be a Hírtartalom indexelése jelölőnégyzetet.
  5. A más vagy több virtuális könyvtárban tárolt hírcsoportok indexeléséhez minden virtuális könyvtárra hajtsa végre a fenti lépéseket.


További virtuális NNTP-kiszolgálók létrehozása

Egy Windows 2000 Server operációs rendszer alatt működő számítógépen igény szerint több virtuális NNTP-kiszolgáló is létrehozható. A végfelhasználók szempontjából ezek mindegyike különálló kiszolgálóként jelenik meg, egyedi címmel és hírcsoportkészlettel, ami azt jelenti, hogy az internetszolgáltatók különböző megrendelőik és ügyfeleik számára különálló virtuális NNTP-kiszolgálókat biztosíthatnak anélkül, hogy az egyes kiszolgálókat külön számítógépen üzemeltetnék.

Ez a rész a következő témaköröket tartalmazza:

Virtuális NNTP-kiszolgáló létrehozása

Virtuális NNTP-kiszolgáló konfigurálása


Virtuális NNTP-kiszolgáló létrehozása

Annyi virtuális NNTP-kiszolgálót hozhat létre, amennyire szüksége van. Minden virtuális kiszolgálót a hozzá tartozó IP-cím és TCP portszám egyedi kombinációja azonosít. Bár különböző TCP portszámok megadása esetén több virtuális NNTP-kiszolgálónak is azonos lehet az IP-címe, ez a módszer mégsem javasolt, mert az ügyfélprogramokat ebben az esetben külön be kellene állítani a szabványostól eltérő TCP port használatára.

Virtuális NNTP-kiszolgáló létrehozásakor két könyvtár elérési útvonalát kell megadnia: az egyik könyvtárban saját belső fájljait, a másikban pedig a hírcsoportokhoz tartozó fájlokat tárolja a rendszer. Ha lehetséges, két eltérő lemezpartíción található könyvtár elérési útvonalát adja meg, mert a belső fájlok megsérülhetnek, ha a lemezpartíción nincs elegendő szabad lemezterület. A különböző fájlokat külön partíción tárolva kisebb az esélye annak, hogy a hírcsoport méretének növekedése miatt elfogy a lemezpartíción levő szabad lemezterület.

Új virtuális NNTP-kiszolgáló létrehozása a Microsoft Management Console használatával

  1. Állítson be egy IP-címet a virtuális NNTP-kiszolgáló számára. Ehhez válassza a Start menü Beállítások menüpontját, majd a Hálózat és telefonos kapcsolatok almenü megfelelő parancsát.
  2. A Microsoft Management Console ablakában jelöljön ki egy létező virtuális NNTP-kiszolgálót, majd mutasson az egérrel a Művelet menü Új menüpontjára, és kattintson a Virtuális kiszolgáló parancsra.
  3. Kövesse az Új virtuális NNTP-kiszolgáló varázsló utasításait. Mindenképpen olyan IP-címet válasszon, amelyet más virtuális NNTP-kiszolgáló nem használ.
  4. Az új virtuális NNTP-kiszolgáló automatikusan elindul. Ha ez mégsem így történne, annak valószínűleg az az oka, hogy a megadott IP-cím és TCP portszám kombinációja már foglalt. Ebben az esetben az IP-cím, illetve a TCP portszám átállításával egyedivé kell tennie a két adat kombinációját.
  5. Konfigurálja az új virtuális NNTP-kiszolgálót.


Virtuális NNTP-kiszolgáló konfigurálása

Az új virtuális NNTP-kiszolgáló konfigurálása ugyanúgy történik, mint a már létező kiszolgálóké. Igény szerint adja meg az adatbiztonsági beállításokat, hozzon létre hírcsoportokat, állítsa be a hírcsoportokra vonatkozó korlátozásokat stb. Az új virtuális NNTP-kiszolgáló létrehozásakor a rendszer a beállítások többségének alapértelmezett értéket ad.

Az Internetes szolgáltatások kezelőjében minden virtuális NNTP-kiszolgálót külön csomópont jelöl, és mindegyikhez saját tulajdonságok, elévülési szabályzatok és virtuális könyvtárak tartoznak. A tulajdonságok megváltoztatása előtt mindig győződjön meg arról, hogy a megfelelő virtuális NNTP-kiszolgálót jelölte ki.

Az új virtuális NNTP-kiszolgálón létre kell hoznia a hírcsoportokat, és ellenőriznie — vagy igény szerint módosítania — kell az alábbi beállításokat. Az itt feltüntetett kötelező jellegű beállításokon kívül továbbiakat is módosíthat, de az alábbiak megfelelő beállítása létfontosságú a kiszolgáló működése szempontjából.

  • IP-cím az Általános tulajdonságlapon
  • Hitelesítési módszer a Hozzáférés lapon
  • Hozzáférés naplózása és Hírtartalom indexelése a Virtuális könyvtár párbeszédpanelen

A virtuális NNTP-kiszolgáló beállításaival kapcsolatban az Útmutató című témakörben talál további információt.


Virtuális kiszolgáló beállítása fürtözéshez

A Windows kiszolgálófürtözési lehetősége kizárólag a Windows 2000 Advanced Server operációs rendszerben érhető el. A Fürtözési szolgáltatás a Windows 2000 - kiszolgáló konfigurálása párbeszédpanelről indítható Windows komponens telepítése varázslóval telepíthető. Bővebb információt a Windows 2000 dokumentációjában olvashat.

A kiszolgálófürt különálló számítógéprendszerek — más néven csomópontok — csoportja, amelyek egyetlen rendszerként együttműködve biztosítják azt, hogy az üzletvitelhez nélkülözhetetlen alkalmazások és erőforrások mindig az ügyfelek rendelkezésére álljanak. A kiszolgálók fürtözésével megbízható, az idő lehető legnagyobb részében rendelkezésre álló rendszer alakítható ki. Fürtözött NNTP-kiszolgálók esetében ez azt jelenti, hogy ha valamelyik virtuális kiszolgáló meghibásodik, akkor a rendszer e kiszolgáló feladatait szétosztja a fürt többi virtuális kiszolgálója között, így a szolgáltatás nem szakad meg. A kiszolgálófürtök további előnye a forrótartalékok használatának lehetősége: a kiszolgáló-erőforrások meghibásodása esetén, azaz ha valamelyik virtuális kiszolgáló leáll, egy addig tartalékként működő rendszer azonnal átveszi a leállt kiszolgáló szerepét, és folytatja a hálózati szolgáltatás ellátását.

A fürtözés szempontjából azok a rendszerek tekinthetők csomópontnak, amelyek Windows 2000 Advanced Server operációs rendszer alatt működnek, és amelyekre telepítették a Fürtözési szolgáltatást. A Microsoft azt javasolja ügyfeleinek, hogy fürtözéshez hozzanak létre egy új virtuális kiszolgálót a csomóponton, és ne az alapértelmezett virtuális NNTP-kiszolgáló átkonfigurálásával oldják meg a feladatot.

A Windows Fürtözési szolgáltatásáról és a kiszolgálófürtökről a Windows 2000 Advanced Server dokumentációjában talál további információt. A kiszolgálófürtök telepítésével és felügyeletével kapcsolatos részletes útmutatókat szintén az a dokumentáció tartalmazza.

Virtuális NNTP-kiszolgáló beállítása fürtözéshez

  1. Amennyiben szükséges, állítsa át a Microsoft NNTP-szolgáltatás alapértelmezett indítási módját Kézi beállításra.
  2. Az új virtuális kiszolgáló létrehozása előtt indítsa el a Microsoft Management Console-t, majd kattintson az egér jobb oldali gombjával az alapértelmezett virtuális NNTP-kiszolgálóra, és válassza a helyi menü Tulajdonságok parancsát.
  3. Kattintson az Általános lapon található Speciális gombra.
  4. Kattintson duplán az IP-cím listán látható (Egyik sincs kiosztva) bejegyzésre.
  5. Az Azonosítás ablakban változtassa meg a TCP port számát az alapértelmezett 119-esről például a Microsoft által ajánlott 120-as számúra, az SSL port számát pedig az 563-asról az 564-es számú portra (ezt a két portot általában nem szokták használni). A portszámok megváltoztatására azért van szükség, hogy a fürtözéshez létrehozni kívánt új virtuális NNTP-kiszolgáló portszámai semmiképpen ne ütközzenek a létező kiszolgálók portszámaival. Gépelje be az új portszámokat (győződjön meg arról, hogy kombinációjuk egyedi), majd kattintson az OK gombra.
  6. Hozzon létre egy új virtuális NNTP-kiszolgálót. Létrehozása után a kiszolgálót kézzel kell elindítania. Ellenőrizze, hogy az új virtuális kiszolgálón az alapértelmezett TCP port (a 119-es számú) és az alapértelmezett SSL port (az 563-as számú) van-e beállítva.

    Fontos

    Amikor az Új virtuális NNTP-kiszolgáló varázsló Belső fájlok kiválasztása képernyőjéhez ér, annak a megosztott erőforrásnak az elérési útvonalát adja meg, amelyet a fürtözött kiszolgálókhoz használ majd. Semmiképpen ne a helyi merevlemezre mutató elérési útvonalat adjon meg. A Tároló kiválasztása képernyőn a Fájlrendszer lehetőséget válassza. Végezetül A hírtartalom tárolási helyére vonatkozó adatok ablakban ismét a fürtözéshez használt megosztott erőforrásra, és nem egy helyi könyvtárra mutató elérési útvonalat adjon meg.

  7. Az IIS szinkronizálási parancs végrehajtásával szinkronizálja a szóban forgó csomópont és a kiszolgálófürt többi csomópontjának IIS adatait. Ehhez indítsa el a parancssort, lépjen a csomóponton levő \WINNT\System32\Inetsrv könyvtárba, majd gépelje be és hajtsa végre az iissync kiszolgálónév parancsot, ahol kiszolgálónév a kiszolgálófürt valamely másik csomópontjának neve. Az IIS szinkronizálási parancsról az IIS dokumentációjában talál további információt.
  8. A kiszolgálófürt csomópontjainak szinkronizálása után érdemes még egyszer ellenőrizni az újonnan létrehozott virtuális NNTP-kiszolgáló és az alapértelmezett virtuális kiszolgáló TCP és SSL portszámát. Elsősorban azt ellenőrizze, hogy a helyi csomópontot a kiszolgálófürt más csomópontjairól nézve a portbeállítások megegyeznek-e a helyi csomóponton megadottakkal. Az alapértelmezett virtuális NNTP-kiszolgálónak egyik csomóponton sem szabad az alapértelmezett (119-es és 563-as számú) portokra mutatnia, mert azokat az új virtuális NNTP-kiszolgálóhoz kell beállítani. Ahhoz, hogy a fürtözés működjön, a beállításoknak minden csomóponton meg kell egyezniük.
  9. Indítsa el a Fürtkezelőt. Kövesse a varázsló lépéseit, és rendeljen erőforrástípust az új virtuális NNTP-kiszolgálóhoz.

    Megjegyzés

    A Paraméterek ablakban látható legördülő listáról mindenképpen az újonnan létrehozott virtuális NNTP-kiszolgálót válassza ki, ne az alapértelmezett virtuális NNTP-kiszolgálót. A Fürtkezelőről a Windows 2000 Advanced Server dokumentációjában talál további információt.


Alapfogalmak

Ebben a részben általános tudnivalókat talál a Microsoft NNTP-szolgáltatással kapcsolatban:

  • A Microsoft NNTP-szolgáltatás jellemzőinek rövid áttekintése
  • Tulajdonságlapok ismertetése
  • Hogyan működik a Microsoft NNTP-szolgáltatás?
  • Parancsfájlok a Microsoft NNTP-szolgáltatáshoz

A dokumentáció e része két példát is bemutat:

  • Magánjellegű virtuális hírkiszolgáló
  • Nyilvános virtuális hírkiszolgáló


A Microsoft NNTP-szolgáltatás jellemzőinek rövid áttekintése

Ez a rész bemutatja a Microsoft NNTP-szolgáltatás alábbi kulcsfontosságú jellemzőit:

  • Támogatott szabványok
  • Egyszerű felügyelet
  • Integráció a Microsoft Windows 2000 Server operációs rendszerrel
  • Microsoft internetes rendszerek integrációja az IIS-sel
  • Korszerű adatbiztonsági szolgáltatások


Támogatott szabványok

A Microsoft NNTP-szolgáltatás az ügyfél-kiszolgáló és kiszolgáló-kiszolgáló közötti kommunikációhoz egyaránt a Network News Transport protokollt (NNTP) használja. A támogatás az NNTP-szabvány számos népszerű bővítésére is kiterjed, és a Microsoft NNTP-szolgáltatás teljes mértékben kompatibilis más NNTP-ügyfelekkel és kiszolgálókkal.

Ezen túlmenően a Microsoft NNTP-szolgáltatás számos tartalomformátumot támogat, többek között az alábbiakat:

  • Multipurpose Internet Mail Extension (MIME)
  • Hypertext Markup Language (HTML)
  • Graphics Interchange Format (GIF)
  • Joint Photographic Experts Group (JPEG)


Egyszerű felügyelet

A Microsoft NNTP-szolgáltatás felügyeletét a Microsoft Management Console (MMC) segítségével végezheti el, amellyel a Microsoft NNTP-szolgáltatás az adott helyi hálózat bármelyik számítógépéről kezelhető. Ez azt a további előnyt is magában hordozza, hogy így egységes felületen keresztül kezelheti a Microsoft Internet Information Services (IIS) minden összetevőjét.


Integráció a Microsoft Windows 2000 Server operációs rendszerrel

A Microsoft NNTP-szolgáltatás a teljesítmény figyeléséhez és az események naplózásához teljes mértékben kihasználja a Windows 2000 Server beépített felügyeleti eszközeit. A Microsoft NNTP-szolgáltatás telepítésekor a Telepítő a teljesítménynaplózáshoz szükséges számlálók teljes készletét telepíti. A Microsoft NNTP-szolgáltatás minden állapotjelző üzenetét és hibaüzenetét bejegyzi az Eseménynaplóba, ahol bármikor megtekinthetők. A Microsoft NNTP-szolgáltatás ezen túlmenően támogatja a Simple Network Management Protocol (SNMP) használatával történő rendszerfigyelést és naplózást is.

A Microsoft NNTP-szolgáltatás a hírcsoportokhoz való hozzáférést úgynevezett hozzáférés-szabályozási listák (ACL) használatával kezeli. Az adott hírcsoportot tartalmazó könyvtár engedélyeinek beállításával szabályozható, hogy mely felhasználók férhetnek hozzá a hírcsoporthoz. Névtelen hozzáférés engedélyezésével beállítható az is, hogy a hírcsoporthoz bárki hozzáférhessen.


Microsoft internetes rendszerek integrációja az IIS-sel

A Microsoft NNTP-szolgáltatás az IIS részét képező Microsoft Indexelő szolgáltatás használatával lehetővé teszi a hírcsoportok tartalmának teljesszöveges és tulajdonság szerinti indexelését. A hírcikktároló tartalmának indexelése után már egyes üzenetek is kikereshetők.

A külön megvásárolható Microsoft Content Replication System nevű tartalomreplikáló rendszer képes több kiszolgálón automatikusan frissíteni a Microsoft NNTP-szolgáltatáshoz tartozó hozzáférés-szabályozási listákat. Ezzel amellett, hogy időt takarít meg, az adatvédelemmel kapcsolatos felügyeleti feladatokkal is kevesebb gondja lesz.


Korszerű adatbiztonsági szolgáltatások

A Microsoft NNTP-szolgáltatásban háromféle adatbiztonsági beállítás közül választhatja ki az Önnek megfelelőt a hírcsoport-felhasználók személyazonosságának ellenőrzéséhez és szervezete bizalmas adatainak védelméhez:

  • Névtelen hozzáférés. A hírcsoporthoz bárki hozzáférhet anélkül, hogy meg kellene adnia felhasználónevét vagy jelszavát.
  • Az NNTP protokoll szabványos adatbiztonsági bővítése (AUTHINFO USER/PASS). A felhasználó köteles megadni felhasználónevét és jelszavát, amelyeket az ügyfél egyszerű szövegként küld el a hálózaton.
  • Windows biztonsági csomag (AUTHINFO GENERIC). A felhasználó köteles megadni felhasználónevét és jelszavát, amelyeket az ügyfél a biztonságos továbbítás érdekében titkosítva küld el a hálózaton. Ez a protokoll a szabványos NNTP adatbiztonsági protokoll GENERIC bővítését használja, működéséhez azonban Microsoft internetes levelező és hírolvasó ügyfélprogram szükséges.

A Microsoft NNTP-szolgáltatás a nyilvános hálózaton keresztül küldött információ védelme érdekében támogatja a Secure Sockets Layer (SSL) használatával történő csatornatitkosítást, amely bizonyítványok segítségével azonosítja az ügyfeleket és kiszolgálókat.


Tulajdonságlapok ismertetése

A szolgáltatás beállításait a virtuális NNTP-kiszolgáló tulajdonságlapjain és párbeszédpanelein található lehetőségek kiválasztásával határozhatja meg.

Megjegyzés A hírcsoportok, elévülési szabályzatok és virtuális könyvtárak tulajdonságait úgy állíthatja be, hogy a Microsoft Management Console ablakában kibontja a virtuális NNTP-kiszolgáló faszerkezetét, rákattint a virtuális kiszolgáló kívánt összetevőjére, majd a részleteket mutató ablaktáblán rákattint a megfelelő elemre az egér jobb oldali gombjával. A helyi menü Tulajdonságok parancsával ekkor megnyithatja az összetevőhöz tartozó párbeszédpanelt, amely minden esetben egyetlen Általános tulajdonságlapot tartalmaz.

  • A Hozzáférés lap
  • Az Elévülési szabályzat párbeszédpanel
  • Az Általános lap
  • A Hírcsoport párbeszédpanel
  • Az Adatbiztonság lap
  • A Beállítások lap
  • A Virtuális könyvtár párbeszédpanel


A Hozzáférés lap

A Hozzáférés lapon található beállításokkal felhasználónév alapján korlátozhatja az egyes hírcsoportokhoz vagy hírcsoportok halmazához való hozzáférést, illetve az ügyfélszámítógépek IP-címe alapján engedélyezheti vagy megtilthatja a hozzáférést az összes hírcsoporthoz egyszerre. (A hírcsoportokhoz való hozzáférés szabályozásáról az Adatbiztonsági beállítások című részben olvashat bővebben.)

A Hozzáférés lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Hozzáférés-szabályozás | Hitelesítési beállítások. Egy vagy több lehetőséget is kiválaszthat. A különböző lehetőségek megtekintéséhez kattintson a Hitelesítés gombra.
Névtelen engedélyezése | Korlátlan hozzáférést biztosít a felhasználóknak minden olyan hírcsoporthoz, amelynek tárolókönyvtárához való hozzáférést nem szabályozták a hozzáférési engedélyek beállításával. Felhasználónév és jelszó megadása nem szükséges.
Névtelen | Megnyitja a Névtelen fiók párbeszédpanelt, amelyen kiválaszthatja a névtelen bejelentkezésekhez használni kívánt Windows 2000 fiókot.
Felhasználónév | A névtelen kapcsolódások során használt Windows felhasználói fiókhoz tartozó felhasználónév. Ez a fiók határozza meg, hogy a névtelen felhasználók milyen jogosultságokkal rendelkeznek. A számítógépen korábban már létrehozott fiók kiválasztásához kattintson a Tallózás gombra.
Jelszó | A névtelen felhasználók fiókjához tartozó jelszó.
Automatikus jelszó-szinkronizálás engedélyezése | E jelölőnégyzet bejelölése esetén a Microsoft NNTP-szolgáltatás automatikusan frissíti a jelszót, amikor a Windows 2000 Server operációs rendszerben módosítják azt.
Alapfokú hitelesítés | E hitelesítési módszer használatakor a felhasználónak meg kell adnia egy — az adott könyvtárhoz hozzáférési jogosultsággal rendelkező — érvényes Windows felhasználónevet és az ahhoz tartozó jelszót. A rendszer a felhasználónevet és jelszót titkosítás nélkül, egyszerű szövegként küldi el a hálózaton. Be kell állítani a könyvtár hozzáférési engedélyeit is.
Windows biztonsági csomag | E hitelesítési módszer használatakor a rendszer titkosítva küldi el a felhasználónevet és jelszót a Microsoft NNTP-szolgáltatásnak. Az adott hírcsoport könyvtárához csak a felhasználónév és a jelszó sikeres hitelesítése után lehet hozzáférni. A Microsoft Outlook Express támogatja ezt a protokollt. Be kell állítani a könyvtár hozzáférési engedélyeit is.
SSL ügyfél-hitelesítés engedélyezése | Ezzel a beállítással engedélyezheti az SSL-titkosítás és bizonyítványok használatával történő biztonságos ügyfél-hitelesítést. Használatához SSL kiszolgálói bizonyítvány szükséges.
SSL ügyfél-hitelesítés szükséges | Kötelezővé teszi az ügyfelek számára a felhasználónév és jelszó titkosítását az SSL használatával.
Ügyfélbizonyítványok hozzárendelésének engedélyezése Windows felhasználói fiókokhoz | A felhasználó azonosítása ilyenkor az SSL ügyfélbizonyítványhoz rendelt Windows fiók használatával történik. A bizonyítványok és Windows fiókok nevének megadásához kattintson az Ügyfél-hozzárendelés gombra.
Biztonságos kommunikáció | A Kiszolgálói bizonyítvány varázsló elindításához kattintson a Bizonyítvány gombra.
Kapcsolatvezérlés | Megadhatja azokat az IP-címeket, amelyek számára engedélyezi vagy megtiltja az adott virtuális NNTP-kiszolgálóhoz való hozzáférést. A rendszer alapértelmezés szerint minden IP-cím számára engedélyezi a hozzáférést. A különböző lehetőségek megtekintéséhez kattintson a Kapcsolat gombra.
Az alábbi listán szereplők kivételével az összes | A listán szereplők kivételével az összes IP-cím számára engedélyezi a hozzáférést az adott virtuális NNTP-kiszolgálóhoz.
Csak az alábbi listán szereplők | A listán szereplők kivételével az összes IP-cím számára megtiltja a hozzáférést az adott virtuális NNTP-kiszolgálóhoz.
Hozzáadás | Erre a gombra kattintva megnyithatja a Számítógép ablakot, amelyen további számítógépeket vagy tartományokat vehet fel a listára.
IP-cím | Annak a számítógépnek az IP-címe, amelyet fel szeretne venni a listára. A számítógép DNS-beli nevéhez tartozó IP-cím kikereséséhez kattintson a DNS keresése gombra.
Alhálózati cím | Annak a számítógépcsoportnak az alap IP-címe, amelyet fel szeretne venni a listára. Az alhálózati maszk megadása is kötelező.
Alhálózati maszk | Annak a számítógépcsoportnak az IP-címtartományát meghatározó alhálózati maszk, amelyet fel szeretne venni a listára. (Az alhálózati maszkokról a Microsoft Windows 2000 Server Hálózatkezelési útmutatójában olvashat bővebben.)
Név | Ebben a mezőben a listára felvenni kívánt IP-címekhez tartozó tartománynevet adhatja meg.


Az Elévülési szabályzat párbeszédpanel

A hírcsoportokra vonatkozó elévülési szabályzatok beállításához használja az Elévülési szabályzat párbeszédpanel Általános lapját. A tulajdonságlap megnyitásához jelölje ki a virtuális NNTP-kiszolgálón létrehozott elévülési szabályzatok egyikét, majd kattintson a Művelet menü Tulajdonságok parancsára. Az elévülési szabályzatok határozzák meg, hogy a hírcsoportokban közzétett cikkek mikor számítanak elévültnek, valamint azt, hogy az elévülési szabályok mely hírcsoportokra vonatkoznak. Ha egy hírcsoportra több elévülési szabályzat is vonatkozik, a rendszer mindig a legszigorúbb szabályzatot veszi figyelembe. (Az elévülési szabályzatok létrehozásáról a Hírcsoportok méretének korlátozása és elévülési idejének beállítása című részben olvashat bővebben.)

Az Általános lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Cikkek eltávolítása, ha régebbiek, mint (óra) | A rendszer az itt megadott számú óránál régebbi cikkeket távolítja el. Alapértelmezés szerint az elévülési idő 168 óra (7 nap). Ha nem kíván beállítani időkorlátozást, törölje a jelölést a jelölőnégyzetből.
Érintett hírcsoportok | Azoknak a hírcsoportoknak a listája, amelyekre az adott szabályzat vonatkozik. A csillag (*) helyettesítő karakter több hírcsoportot jelent. A rec.* karakterlánc például a „rec.” szóval kezdődő összes hírcsoportot jelöli.
Hozzáadás | Erre a gombra kattintva megnyithatja a Hírcsoport hozzáadása párbeszédpanelt, amelyen begépelheti azoknak a hírcsoportoknak a nevét, amelyekre ki szeretné terjeszteni az elévülési szabályzat hatáskörét. A csillag (*) helyettesítő karakter használatával több hírcsoportot is megadhat.
Eltávolítás | Hírcsoportot úgy távolíthat el az elévülési szabályzatból, hogy az Érintett hírcsoportok listán kijelöli a megfelelő hírcsoport nevét, majd rákattint az Eltávolítás gombra.


Az Általános lap

Az Általános tulajdonságlapon található beállításokkal szabályozhatja, hogy az ügyfelek hogyan kapcsolódjanak a Microsoft NNTP-szolgáltatáshoz.

Az Általános lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Név | A virtuális NNTP-kiszolgáló neve, amely a Microsoft Management Console ablakában is látható. Megjegyzés A virtuális NNTP-kiszolgáló neve nem tartalmazhat a karakterkészlet kibővített részében található karaktereket.
IP-cím | Ide gépelheti be a virtuális NNTP-kiszolgáló IP-címét.
Speciális | Erre a gombra kattintva megnyílik a Speciális párbeszédpanel, amelyen több IP-címet is megadhat a virtuális NNTP-kiszolgálóhoz, és beállíthatja a TCP és SSL port számát is.
TCP port | Az a TCP port, amelyen keresztül az ügyfelek kapcsolódhatnak a Microsoft NNTP-szolgáltatáshoz. Tetszőleges egyedi TCP portszám megadható. Alapértelmezés szerint ez a 119-es számú port.
SSL port | Az a TCP port, amelyen keresztül az ügyfelek az SSL használata esetén kapcsolódhatnak a Microsoft NNTP-szolgáltatáshoz. Tetszőleges egyedi TCP portszám megadható. Alapértelmezés szerint ez az 563-as számú port.
Kapcsolat | Erre a gombra kattintva megnyithatja a virtuális kiszolgáló kapcsolódási paramétereit tartalmazó Kapcsolat párbeszédpanelt.
A kapcsolatok száma legfeljebb | Amikor a jelölőnégyzet be van jelölve, a virtuális NNTP-kiszolgálóhoz egyidejűleg kapcsolódó ügyfelek száma korlátozott. Alapértelmezés szerint 5000 kapcsolat engedélyezett.
Időkorlát (perc) | Az inaktív ügyfeleket a rendszer az itt megadott számú perc elteltével leválasztja a szolgáltatásról. Ez az időkorlát alapértelmezés szerint 10 perc.
Naplózás engedélyezése | A jelölőnégyzet bejelölésével bekapcsolhatja a virtuális NNTP-kiszolgáló felhasználóinak nyomon követésére szolgáló naplózást. A naplófájlok alapértelmezett helye a C:\WINNT\System32\LogFiles\Nntpsvc1 mappa. A naplózás engedélyezéséhez be kell jelölnie a Virtuális könyvtár párbeszédpanelen található Hozzáférés naplózása jelölőnégyzetet is.
Aktív naplóformátum | A tranzakciós napló formátuma. A napló tulajdonságainak meghatározásához kattintson a Tulajdonságok gombra.
Útvonalfejléc | A közzétett hírcikkek Útvonal (Path) sorában használt karakterlánc. A hírüzenetek az Útvonalfejléc mezőben látható útvonalon haladva érik el céljukat. Amikor egy üzenetet továbbítanak valamely hírkiszolgálóról, az hozzáfűz egy leírást tartalmazó karakterláncot az üzenet Útvonal (Path) sorához. Az útvonalfejléc elválasztására a ponton (.) kívül bármilyen írásjel használható. Az NNTP protokoll Path utasításának létrehozásáról bővebben az RFC 1036 számú dokumentumban olvashat. A mező alapértelmezett értéke a virtuális NNTP-kiszolgáló Domain Name System (DNS) rendszerbeli neve, ezt az alapértelmezett értéket nem szükséges megváltoztatni.


A Hírcsoport párbeszédpanel

A hírcsoportok beállításainak módosításához használja a Hírcsoport párbeszédpanel Általános lapját. Itt megadhatja például a hírcsoport moderátorát, akinek minden cikket jóvá kell hagynia közzététel előtt, illetve korlátozhatja a hírcsoporthoz való hozzáférést oly módon, hogy csak a moderátornak ad írási jogosultságot a hírcsoporthoz. Erről bővebben a Hírcsoportok létrehozása című témakörben olvashat.

Az Általános lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Leírás | A hírcsoport ügyfelek által megjeleníthető leírása.
Közérthető név | A hírcsoport ügyfelek által megjeleníthető másik neve, amelyet az ügyfelek a List Prettynames NNTP-paranccsal kérhetnek le a kiszolgálótól. Ebben a mezőben Unicode karaktereket is használhat, tehát a hírcsoport neve egy másik nyelv karakterkészletével is megadható.
Írásvédett | E jelölőnégyzet bejelölése esetén kizárólag a hírcsoport moderátora kap írási jogot a hírcsoporthoz.
Moderált | Amennyiben bejelöli ezt a beállítást, a rendszer a cikkeket először elküldi a moderátornak, akinek jóvá kell hagynia azokat közzététel előtt.
Moderátor | A hírcsoport moderátorának elektronikus levélcíme. Az alapértelmezett cím: hírcsoport@alapértelmezett_tartomány ahol hírcsoport a hírcsoport neve, alapértelmezett_tartomány pedig a Beállítások tulajdonságlap Alapértelmezett moderátori tartomány mezőjében megadott tartomány.


Az Adatbiztonság lap

Az Adatbiztonság lapon adhatja meg azokat a személyeket, akik felügyelői hozzáférési jogosultságot kapnak a virtuális NNTP-kiszolgálóhoz.

Az Adatbiztonság lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Felügyelők | Az adott virtuális NNTP-kiszolgálóhoz hozzáférési jogosultsággal rendelkező felügyelők, illetve felügyelőkből álló csoportok. Alapértelmezés szerint ezek az adott számítógép Rendszergazdák csoportjába tartozó felhasználók.
Hozzáadás | Kattintson erre a gombra a felügyelők kijelölésére szolgáló Felhasználók vagy csoportok kijelölése párbeszédpanel megnyitásához.
Eltávolítás | Eltávolítja a listáról a kijelölt felügyelőt.
Keresés itt (a Felhasználók vagy csoportok kijelölése párbeszédpanelen) | Erről a listáról választhatja ki azt a tartományt, amelynek felhasználói közül felügyelőt szeretne kijelölni.
Név (a Felhasználók vagy csoportok kijelölése párbeszédpanelen) | A kiválasztott tartomány összes felhasználójának és csoportjának nevét tartalmazó lista.
Hozzáadás (a Felhasználók vagy csoportok kijelölése párbeszédpanelen) | Erre a gombra kattintva felveheti a kijelölt felügyelőket vagy csoportokat a párbeszédpanel alján levő — az eddig kiválasztott neveket tartalmazó — listára. A kiválasztás befejezése után az OK gombra kattintva visszatérhet az Adatbiztonság laphoz. Az újonnan felvett nevek megjelennek a Felügyelők listán.


A Beállítások lap

A Beállítások lapon adhatja meg a cikkek közzétételére vonatkozó korlátozásokat, itt engedélyezheti a vezérlőüzeneteket, és itt adhatja meg a moderált hírcsoportok alapvető beállításait is.

A Beállítások lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Ügyféloldali közzététel engedélyezése | A jelölőnégyzet bejelölésével engedélyezi az ügyfeleknek, hogy cikkeket tegyenek közzé az adott virtuális NNTP-kiszolgálón.
Egyes üzenetek mérete legfeljebb (kB) | Itt adhatja meg (kilobájtban), hogy a felhasználók legfeljebb mekkora cikkeket tehetnek közzé. Ha nem kíván beállítani korlátozást, törölje a jelölést a jelölőnégyzetből.
A kapcsolat mérete legfeljebb (MB) | Itt adhatja meg (megabájtban), hogy a felhasználók egy kapcsolat során legfeljebb mennyi adatot tehetnek közzé egy hírcsoportban. Ha nem kíván beállítani korlátozást, törölje a jelölést a jelölőnégyzetből.
Áttöltéses közzététel engedélyezése | A jelölőnégyzet bejelölésével engedélyezi az ügyfeleknek, hogy áttöltéssel cikkeket tegyenek közzé az adott virtuális NNTP-kiszolgálón.
Egyes üzenetek mérete legfeljebb (kB) | Itt adhatja meg (kilobájtban), hogy a felhasználók legfeljebb mekkora cikkeket tehetnek közzé áttöltéssel. Ha nem kíván beállítani korlátozást, törölje a jelölést a jelölőnégyzetből.
A kapcsolat mérete legfeljebb (MB) | Itt adhatja meg (megabájtban), hogy a felhasználók egy kapcsolat során legfeljebb mennyi adatot tehetnek közzé áttöltéssel. Ha nem kíván beállítani korlátozást, törölje a jelölést a jelölőnégyzetből.
A kiszolgálók lehívhatnak hírüzeneteket erről a kiszolgálóról | A jelölőnégyzet bejelölésével engedélyezi más NNTP-kiszolgálóknak, hogy lehívásos áttöltéssel egyszerre több cikket töltsenek le az adott kiszolgálóról.
Vezérlőüzenetek engedélyezése | A jelölőnégyzet bejelölésével engedélyezheti az ügyfeleknek és más kiszolgálóknak, hogy hírcsoportok létrehozására és eltávolítására, illetve hírcikkek törlésére utasító vezérlőüzeneteket küldjenek. (További információt a Vezérlőüzenetek feldolgozása című témakörben talál.)
Moderált csoportok SMTP-kiszolgálója | Itt adhatja meg a cikkeket a hírcsoportok moderátorának elküldő SMTP levelezési kiszolgáló DNS-beli nevét, illetve a moderátor általi jóváhagyásra váró cikkek tárolására szolgáló könyvtár elérési útvonalát. A könyvtárnak mindenképpen helyi könyvtárnak kell lennie.
Alapértelmezett moderátori tartomány | A moderált hírcsoportok alapértelmezett tartománya. A tartományt minősített tartománynévvel kell megadni. Azokat a cikkeket, amelyeket olyan moderált hírcsoportban kívánnak közzétenni, amelyhez nem adtak meg moderátort, a rendszer a következő címre küldi: hírcsoportnév@alapértelmezett_moderátori_tartomány ahol hírcsoportnév annak a hírcsoportnak a neve, amelybe a cikket küldik, alapértelmezett_moderátori_tartomány pedig az ebben a mezőben megadott érték.
Rendszergazda elektronikus postafiókja | Itt adhatja meg azt az elektronikus levélcímet, amelyre a rendszer a „Nem kézbesíthető” értesítőüzeneteket küldi, amennyiben a moderált hírcsoportba szánt cikkek nem kézbesíthetők a megadott moderátornak. A „Nem kézbesíthető” értesítőüzenetek küldésének engedélyezéséhez hozzon létre egy új, MailFromHeader nevű, DWORD (duplaszó) típusú értéket az alábbi rendszerleíró kulcsban, majd állítsa be az értéket 1-re: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\NntpSvc\Parameters\


A Virtuális könyvtár párbeszédpanel

A virtuális könyvtárak helyének megadásához és tulajdonságainak beállításához használja a Virtuális könyvtár párbeszédpanel Általános lapját. (A virtuális könyvtárak létrehozásáról a Virtuális könyvtárak használata a cikkek több meghajtón való tárolásához című témakörben talál további információt.)

Az Általános lap a következő beállítási lehetőségeket tartalmazza:

Beállítás | Leírás
Könyvtár tartalma | A Tartalom gombra kattintva megnyithatja a Könyvtár tartalma párbeszédpanelt, amelyen megadhatja a virtuális könyvtár erőforrásainak tárolására szolgáló helyet.
A számítógépen levő könyvtár | A számítógép egyik helyi könyvtára, amely a virtuális könyvtárat tartalmazza.
Más számítógépen levő megosztott könyvtár | Egy másik számítógépen található hálózati könyvtár, amely a virtuális könyvtárat tartalmazza.
Helyi elérési útvonal | A virtuális könyvtár helyét meghatározó elérési útvonal (például E:\Nntp\Rec\Sport).
Hálózati könyvtár | Annak a másik számítógépen levő megosztott könyvtárnak az UNC neve, amely a virtuális könyvtárat tartalmazza. Például: \\kiszolgálónév\Rec\Sport.
Felhasználónév | Itt kell megadnia a távoli számítógéphez való kapcsolódáskor használandó érvényes felhasználónevet. Felhasználónév kiválasztásához kattintson a Tallózás gombra.
Jelszó | Ide gépelje be a megadott felhasználónévvel együtt használandó jelszót. Az Ellenőrzés gombra kattintva meggyőződhet arról, hogy érvényes felhasználónév–jelszó párt adott-e meg.
Biztonságos kommunikáció | Az adott könyvtár-hierarchiában található hírcsoportokhoz való hozzáférést korlátozhatja azokra az ügyfelekre, amelyek SSL használatával kapcsolódnak. Amennyiben kötelezővé szeretné tenni az SSL használatát, a Biztonságos gombra kattintva nyissa meg az Adatbiztonság párbeszédpanelt.
Biztonságos csatorna szükséges | A jelölőnégyzet bejelölésével az adott könyvtár-hierarchiában található hírcsoportokhoz való hozzáférést korlátozhatja azokra az ügyfelekre, amelyek SSL használatával kapcsolódnak.
128 bites titkosítás szükséges | A jelölőnégyzet bejelölésével az adott könyvtár-hierarchiában található hírcsoportokhoz való hozzáférést korlátozhatja azokra az ügyfelekre, amelyek 128 bites fokozott biztonságú SSL-titkosítás használatával kapcsolódnak.
Közzététel engedélyezése | A jelölőnégyzet bejelölésével engedélyezi a hírolvasó ügyfeleknek cikkek közzétételét az adott könyvtár-hierarchiában található hírcsoportokban.
Hírcsoport láthatóságának korlátozása | A jelölőnégyzet bejelölésével korlátozhatja a könyvtárban található hírcsoportok láthatóságát, hogy csak a hozzáférési jogosultsággal rendelkező felhasználók lássák azokat. Ez a beállítás növeli a rendszer működéséhez szükséges erőforrások mennyiségét, ezért névtelen hozzáférést engedélyező hírcsoportok esetén használata nem ajánlott.
Hozzáférés naplózása | A jelölőnégyzet bejelölésével engedélyezi, hogy a rendszer naplóbejegyzéseket írjon az IIS hozzáférési naplójába, amelyben nyomon követheti az adott könyvtár-hierarchiában található hírcsoportok használatát. A naplózás engedélyezéséhez be kell jelölnie az Általános lapon található Naplózás engedélyezése jelölőnégyzetet is.
Hírtartalom indexelése | A jelölőnégyzet bejelölésével engedélyezi az adott könyvtárban található hírcsoportok indexelését, és így lehetővé teszi a felhasználók számára adott szövegrészlet megkeresését a hírcsoportok tartalmában. (További információt a Hírcsoportok indexelése a Microsoft Indexelő szolgáltatás használatával című témakörben talál.)


Hogyan működik a Microsoft NNTP-szolgáltatás?

Ez a rész bemutatja a Microsoft NNTP-szolgáltatás működését. Az alábbi témaköröket ismerteti:

  • Cikkek közzététele
  • Cikkek megtekintése
  • A Microsoft NNTP-szolgáltatás adatszerkezetei

A Microsoft NNTP-szolgáltatás az ügyfél-kiszolgáló modellre épülő NNTP protokoll implementációja. A Microsoft NNTP-szolgáltatás a kiszolgáló szerepét tölti be, amelyhez például a Microsoft Outlook Express használható ügyfélként.

Az ügyfelek TCP/IP (Transmission Control Protocol/Internet Protocol) hálózaton keresztül kapcsolódhatnak a Microsoft NNTP-szolgáltatáshoz. Hagyományos kapcsolatok esetén a 119-es számú, míg a választható, titkosított SSL kapcsolatok használata esetén az 563-as számú az alapértelmezett TCP port.

A Microsoft NNTP-szolgáltatás a Windows 2000 Server operációs rendszer szolgáltatásaként fut, és az alapértelmezett beállítások értelmében automatikusan elindul. A szolgáltatásnak a Felügyeleti eszközök Szolgáltatások segédalkalmazásában látható neve Network News Transport Protocol (NNTP).


Cikkek közzététele

A felhasználók a Microsoft NNTP-szolgáltatáson egy hírolvasó ügyfélprogram, például a Microsoft Outlook Express használatával tehetnek közzé hírcikkeket. Az ügyfél kapcsolódik a Microsoft NNTP-szolgáltatáshoz, és kérelmezi az adott cikk egy vagy több hírcsoportban való közzétételét. A Microsoft NNTP-szolgáltatás a kapcsolódási kérelem fogadása után ellenőrzi, hogy a felhasználónak van-e megfelelő jogosultsága a megadott hírcsoportokban való közzétételhez. A Microsoft NNTP-szolgáltatás ez után hozzáadja a cikket a hírcsoportokhoz, és frissíti a hírcsoportok indexét. Ezt a folyamatot mutatja be az alábbi ábra.

A cikkek közzétételét szemléltető ábra


Cikkek megtekintése

A felhasználók a Microsoft NNTP-szolgáltatás hírcsoportjaiban közzétett cikkeket egy hírolvasó ügyfélprogram, például a Microsoft Outlook Express használatával tekinthetik meg. A hírcsoportokban közzétett cikkek megtekintéséhez először le kell kérni az elérhető hírcsoportok listáját. Az ügyfél, miután kapcsolódott a Microsoft NNTP-szolgáltatáshoz, lekéri a rendelkezésre álló hírcsoportok listáját. Amikor a Microsoft NNTP-szolgáltatás megkapja a kapcsolódásra vonatkozó kérést, ellenőrzi, hogy a felhasználónak van-e megfelelő hozzáférési jogosultsága a hírcsoportokhoz, majd összeállítja és elküldi az elérhető hírcsoportok listáját.

A felhasználó ezt követően kiválasztja a megtekinteni kívánt hírcsoportot. Az ügyfélprogram lekéri a kiválasztott hírcsoportban közzétett cikkek listáját. A Microsoft NNTP-szolgáltatás ellenőrzi, hogy a felhasználó jogosult-e az adott hírcsoporthoz való hozzáférésre, majd elküldi az ügyfélnek a hírcsoportban található cikkek listáját. A felhasználó erről a listáról választhatja ki az őt érdeklő cikkeket, amelyeket az ügyfél azonnal lekér a Microsoft NNTP-szolgáltatástól. A Microsoft NNTP-szolgáltatás erre a kérésre elküldi a kért cikkek tartalmát. Ezeket a lépéseket mutatja be az alábbi ábra.

A cikkek megtekintését szemléltető ábra


A Microsoft NNTP-szolgáltatás adatszerkezetei

A Microsoft NNTP-szolgáltatás a hírcsoportokban közzétett cikkeket egy vagy több könyvtár-hierarchiában tárolja. Minden hírcsoporthoz saját könyvtár tartozik, amelyben a rendszer az egyes cikkeket különálló fájlként tárolja.

Alapértelmezés szerint a kezdőkönyvtár a C:\Inetpub\Nntpfile\root könyvtár, de ez megváltoztatható, ha a Tartalom gombra kattint a virtuális NNTP-kiszolgáló alapértelmezett virtuális könyvtárának tulajdonságait mutató Virtuális könyvtár párbeszédpanelen. Virtuális könyvtárak létrehozásával további könyvtár-hierarchiákat is létrehozhat más lemezmeghajtókon vagy más számítógépeken.

Az egyes hírcsoportokhoz tartozó könyvtárak neve megegyezik az adott hírcsoport nevével. Új hírcsoportok létrehozása esetén a Microsoft NNTP-szolgáltatás automatikusan létrehozza a szükséges könyvtárakat. Az entertainment.news nevű hírcsoport tartalma például alapértelmezés szerint a kezdőkönyvtár \Entertainment\News alkönyvtárában, vagyis a C:\Inetpub\Nntpfile\root\Entertainment\News könyvtárban található. A hírcsoportokban közzétett cikkek fájlnevei .nws kiterjesztésűek.

A Microsoft NNTP-szolgáltatás létrehozza továbbá a tárolt cikkek tárgyának felsorolását tartalmazó fájlokat is, ezek neve .xix kiterjesztésű. A Microsoft NNTP-szolgáltatás az egyes hírcsoportok minden 128 cikkéhez készít egy ilyen tárgyjegyzékfájlt.

A Microsoft NNTP-szolgáltatás a fentieken túl számos belső adatszerkezeti fájlt is létrehoz és használ, ezek kiterjesztése .hsh, .hdr, .lst, illetve .txt lehet. E fájlok alapértelmezett helye a C:\InetPub\Nntpfile könyvtár. Ne módosítsa és ne törölje ezeket a fájlokat. Amennyiben a fájlokat véletlenül törölte, vagy azok megsérültek, használja a Microsoft NNTP-szolgáltatás újraépítése funkciót.


Magánjellegű virtuális hírkiszolgáló: osztályszintű hírcsoport

A kommunikáció munkakörtől függetlenül mindenkinek fontos, aki másokkal együtt, csoportban dolgozik. A szervezetek többségében nehéz egy csoport minden tagját összehívni, hogy rendszeres időközönként megosszák egymás között az információt.

A hírcsoportok sokféle kommunikációs probléma megoldására alkalmasak. Lehetővé teszik például, hogy a csoport minden tagja bármikor hozzáférjen az adatokhoz, illetve megossza másokkal az információt. A cikkeket a rendszer témakör szerint rendezve tárolja, így bárki egyszerűen megtalálhatja az adott témakörre vonatkozó összes tudnivalót. További előny, hogy a hírcsoportok az elektronikus levelektől eltérő módon az információ archiválására, annak későbbi felhasználására is nagyszerű megoldást nyújtanak.

Cél: Az osztály vagy részleg egy adott projekten együtt dolgozó munkatársai közötti kommunikáció javítása, valamint a projekttel kapcsolatos információ rendszerezése és archiválása.

A szükséges szoftvereszközök: Microsoft Windows NT Server 4.0 vagy Microsoft Windows 2000 Server operációs rendszer; Microsoft Internet Information Services (IIS) 4.0 verzió; Microsoft Internet Mail and News 4.0 verzió vagy Microsoft Outlook Express.

Környezet: Microsoft Windows hálózat.

Tudnivalók a telepítéshez: Az IIS telepítőprogramjával telepítse az IIS Microsoft NNTP-szolgáltatás összetevőjét.

További tudnivalók: Amennyiben a hírcsoportot az információ archiválására is használni szeretné, ne állítson be elévülési időt a cikkekre, és gyakran készítsen biztonsági másolatot a hírcsoportot tároló könyvtárról.

A főbb lépések

Ahhoz, hogy a szervezeten belül néhány magánjellegű hírcsoportot üzemeltessen, általában nem szükséges túl sok kiszolgáló erőforrás. E célra többnyire bármely Windows 2000 operációs rendszert futtató számítógép megfelel. A Microsoft NNTP-szolgáltatás a szabványos NNTP-protokollt használja, így az osztály munkatársai bármilyen NNTP-ügyfélszoftverrel elérhetik a hírcsoportokat. Ugyanakkor érdemes megemlíteni, hogy a Microsoft Outlook Express a megszokottnál magasabb szintű biztonsági szolgáltatásokat nyújt, amelyekre bizonyos esetben szükség lehet. A kiszolgálót és az ügyfeleket egyaránt a Transmission Control Protocol/Internet Protocol (TCP/IP) hálózati protokoll használatára kell beállítani.

Kezdetben célszerű egy adott projekthez csak néhány hírcsoportot létrehozni. Amennyiben a projekt célja egy jobb egérfogó megtervezése és gyártása, a hírcsoportoknak a következő neveket adhatja: egerfogo.tervezes, egerfogo.teszteles, egerfogo.gyartas. A szolgáltatás az egyes hírcsoportokban közzétett cikkeket tárgy szerint rendezi, ezért nem szükséges minden egyes témakörhöz külön-külön hírcsoportot létrehoznia.

A hírcsoportok egységes erőforrás-azonosítója (URL-címe) a következő formátumú:

news://kiszolgáló/hírcsoport

news://kiszolgáló/hírcsoport/cikk

ahol kiszolgáló a Microsoft NNTP-szolgáltatás neve vagy Internet Protocol (IP) címe, hírcsoport az adott hírcsoport neve, cikk pedig egy adott cikk azonosítója, amelyet nem kötelező megadni.

A hírcsoportban közzétett cikkek jellegétől és bizalmasságától függően szükség lehet a hírcsoportok adatbiztonsági és hozzáférési korlátozásainak beállítására is. Amennyiben az információhoz a szervezet minden tagjának hozzáférést akar biztosítani, és ha a belső hálózatot tűzfal védi, akkor többnyire engedélyezheti a névtelen bejelentkezést. Ha azonban ennél nagyobb biztonságra van szükség, a hírcsoport minden felhasználója számára hozzon létre egy Windows 2000 Server fiókot, majd korlátozza a hírcsoportot tároló könyvtárakhoz való hozzáférést ezekre a fiókokra. A Microsoft NNTP-szolgáltatás az adatbiztonságot és a hozzáférést Windows 2000 Server fiókok és engedélyek használatával szabályozza.

Az eredmény

Az osztály vagy részleg munkatársai rendszeres időközönként cikkeket tehetnek közzé és olvashatnak az adott projekttel kapcsolatban, így anélkül tájékoztathatják egymást a legfrissebb tudnivalókról, hogy gyakori megbeszéléseket kellene összehívniuk.


Nyilvános virtuális hírkiszolgáló: ügyfélszolgálati célú hírcsoportok

Az ügyfelek elégedettsége sok esetben attól függ, hogy a cég mennyire megbízható és mennyire színvonalas ügyfélszolgálati támogatást nyújt. Ez elsősorban azért fontos, mert az elégedett vásárlók visszatérnek újabb termékeket vásárolni, vagy újból igénybe veszik a cég szolgáltatásait, míg az elégedetlenek gyakran visszahozzák a nem megfelelőnek ítélt termékeket, és inkább egy versenytárshoz fordulnak. Színvonalas, sokrétű ügyfélszolgálatot azonban meglehetősen drága fenntartani.

Cél: Csökkenteni a terméktámogatási költségeket, ugyanakkor — a technikai információt az ügyfelek számára bármikor könnyen elérhetővé téve — javítani az ügyfelek kiszolgálásának minőségét.

A szükséges szoftvereszközök: Microsoft Windows 2000 Server; Microsoft Internet Information Services (IIS); névtelen hozzáférés engedélyezése esetén tetszőleges NNTP-ügyfélszoftver, fokozott adatbiztonsági igények esetén Microsoft Outlook Express.

Környezet: Az Internet.

Tudnivalók a telepítéshez: Engedélyezze a névtelen hozzáférést. A névhozzárendeléshez használja a Domain Name System (DNS) vagy a Windows Internet Naming Service (WINS) rendszert. Ha szervezete használ tűzfalat a belső hálózat védelmére, engedélyezze a hozzáférést a tűzfalon keresztül.

További tudnivalók: Érdemes lehet moderált hírcsoportok használatával megelőzni a nem kívánatos, vagy technikai szempontból pontatlan cikkek közzétételét, de figyelembe kell vennie azt is, hogy ezzel korlátozhatja az ügyfeleket az egymásnak való segítségnyújtásban, ha az ügyfélszolgálat munkatársai esetleg nem tudnak azonnal válaszolni valamely kérdésre.

A főbb lépések

Amennyiben a cég nyilvános weblapjaihoz eleve az IIS-t használja, az ügyfélszolgálati hírcsoportok kezdetben ugyanazon a számítógépen is lehetnek. A későbbiekben, a hírcsoport forgalmának növekedésével azonban célszerű áthelyezni a Microsoft NNTP-szolgáltatást egy külön számítógépre.

Létrehozhat egy-egy hírcsoportot a támogatott termékek mindegyikéhez, de szükség esetén az egyes termékekhez több hírcsoportot is fenntarthat, amelyek mindegyike az adott termékkel kapcsolatos szűkebb témakörrel foglalkozik. Ha például a cég által gyártott egérfogókhoz kíván ügyfélszolgálati célú hírcsoportot létrehozni, a hírcsoport neve lehet tamogatas.egerfogo. Ha sok hozzászólásra számít, létrehozhatja például a szűkebb témakörökkel foglalkozó tamogatas.egerfogo.telepites, tamogatas.egerfogo.kezeles, tamogatas.egerfogo.karbantartas stb. nevű hírcsoportokat.

A hírcsoportok egységes erőforrás-azonosítója (URL-címe) a következő formátumú:

news://kiszolgáló/hírcsoport

news://kiszolgáló/hírcsoport/cikk

ahol kiszolgáló a Microsoft NNTP-szolgáltatás neve vagy IP-címe, hírcsoport az adott hírcsoport neve, cikk pedig egy adott cikk azonosítója, amelyet nem kötelező megadni.

Ahhoz, hogy az ügyfelek számára a hírcsoportok tényleges segítséget jelentsenek, a terméktámogatási szolgálat munkatársainak gyakran el kell olvasniuk a cikkeket, és mielőbb válaszolniuk kell a kérdésekre. A leggyakrabban felmerülő kérdésekből és problémákból érdemes időről időre összeállítani egy gyűjteményt, és azt Gyakran Ismételt Kérdések (FAQ) címszó alatt közzétenni.

Az eredmény

Az ügyfelek elégedettebbek, mert bármikor hozzáférhetnek a megvásárolt termékekkel kapcsolatos aktuális kérdésekhez és válaszokhoz. A hírcsoportokban közzétehetik saját kérdéseiket is, és később megnézhetik, hogy a terméktámogatási szolgálattól vagy a többi ügyféltől érkezett-e válasz rájuk.

A terméktámogatással foglalkozó munkatársak munkája is hatékonyabb, mert nem kell ugyanazokat a kérdéseket egymás után többször megválaszolniuk. Az ügyfelektől a hírcsoportokon keresztül kapott visszajelzés alapján a termékfejlesztő csoportok jobb minőségű termékekkel jelentkezhetnek a piacon, a hozzáférési naplók elemzésével pedig nyomon követhető, hogy a terméktámogatási tevékenység mértéke idővel hogyan változik.


Parancsfájlok a Microsoft NNTP-szolgáltatáshoz

Ez a rész a parancsfájlokkal és a parancsfájlok futtatásakor visszakapott kódokkal kapcsolatos tudnivalókat tartalmazza. A Microsoft NNTP-szolgáltatás a VBScript nyelv legtöbb parancsát támogatja, és a parancsok helyi vagy távoli kiszolgálókról egyaránt futtathatók. Az -s kapcsoló megadásával állítható be, hogy a parancsok a Microsoft NNTP-szolgáltatást futtató kiszolgálóra vonatkozzanak.

A VBScript parancsfájlok ugyanazokat a funkciókat látják el, mint a Microsoft NNTP-szolgáltatás korábbi verzióiból ismert parancssori segédalkalmazások. A Windows 2000 operációs rendszerrel telepített Windows Scripting Host (WSH) lehetővé teszi a parancsfájlok futtatását oly módon, hogy a felhasználó csak rákattint a Windows Asztalon látható parancsfájlra, de begépelheti a parancsfájl nevét a parancssorban is.

A WSH Windows alapú állomásról (a Wscript.exe fájllal) és parancssor alapú állomásról (a Cscript.exe fájllal) egyaránt futtatható, de használata egyszerűbb a Cscript.exe fájllal. Ennek elsősorban az az oka, hogy a Microsoft NNTP-szolgáltatás VBScript parancsfájljainak futtatásakor meg kell adni néhány kapcsolót, és ezt a parancssorból sokkal egyszerűbb elvégezni. Gépelje be a cscript.exe parancsot a parancssorba.

Megjegyzés A parancsfájlok futtatásakor a fájl teljes nevét be kell írnia (a .vbs kiterjesztéssel együtt).

A következő VBScript parancsfájlokat használhatja:

  • Rexpire.vbs
  • Rgroup.vbs
  • Rserver.vbs
  • Rsess.vbs

A parancsfájlok végrehajtása során bekövetkező hibákról a rendszer hibaüzenetet küld. A hibakódok felsorolása a Parancssori visszatérési kódok témakörben található.


Rexpire.vbs

Ez a parancs elévülési szabályzatok hozzáadására, törlésére és módosítására szolgál. Az alábbi táblázat tartalmazza az Rexpire paranccsal használható paramétereket.

Paraméter | Leírás
-t művelet, ahol művelet az alábbi argumentumok egyike: |
a | Elévülési szabályzat hozzáadása.
d | Elévülési szabályzat törlése.
g | Elévülési szabályzat lekérése.
s | Elévülési szabályzat beállítása.
e | Elévülési szabályzatok felsorolása.
-s kiszolgáló | A konfigurálni kívánt kiszolgáló számítógép neve.
-v virtuális kiszolgáló azonosítója | A virtuális NNTP-kiszolgáló azonosítója (egész szám).
-i elévülési szabályzat azonosítója | Az elévülési szabályzat azonosítója.
-h elévülés ideje órában | Az az óraszám, amelynek elteltével a rendszer törli a cikkeket.
-n hírcsoportok | Azok a hírcsoportok, amelyekre a parancs vonatkozik (* helyettesítő karaktert tartalmazó karakterláncok is használhatók).
-p szabályzat neve | Az elévülési szabályzat neve.

A következő példák bemutatják a parancsfájlok használatának módját. Amikor fut a Windows Script Host, az alábbi parancsok bármelyikét begépelheti a parancssorba, és futtathatja a parancsfájlt.

Parancs Működés
Rexpire.vbs -t e -v 1
 Az 1. számú virtuális NNTP-kiszolgáló elévülési szabályzatainak listázása.
Rexpire.vbs -t d -i 1
 Az 1. számú elévülési szabályzat törlése.


Rgroup.vbs

Ez a parancs hírcsoportok hozzáadására, törlésére és módosítására szolgál. Az alábbi táblázat tartalmazza az Rgroup paranccsal használható paramétereket.

Paraméter | Leírás
-t művelet, ahol művelet az alábbi argumentumok egyike: |
f | Csoport keresése.
a | Csoport hozzáadása.
d | Csoport törlése.
g | Csoporttal kapcsolatos információ lekérése.
s | Csoporttal kapcsolatos információ beállítása.
-s kiszolgáló | Az a kiszolgáló, amelyre a változás kihat.
-v virtuális kiszolgáló azonosítója | A virtuális NNTP-kiszolgáló azonosítója.
-c létrehozás dátuma | A csoport létrehozásának dátuma.
-g csoport | A csoport neve. Kereséskor használható a * helyettesítő karakter (Rgroup.vbs -t f).
-n eredmények száma | A keresés eredményeként visszaadott hírcsoportok maximális száma (Rgroup.vbs -t f).
-m moderátor | A moderátor teljes elektronikus levélcíme.
-d leírás | A csoport leírása.
-p leírás | A List PrettyNames parancsra válaszul küldött közérthető név megadása.
-r true | false | Írásvédelem beállítása vagy feloldása.
-u true | false | Annak jelzése, hogy az alapértelmezett moderátor végzi-e a hírcsoport moderálását.

A következő példák bemutatják a parancsfájlok használatának módját. Amikor fut a Windows Script Host, az alábbi parancsok bármelyikét begépelheti a parancssorba, és futtathatja a parancsfájlt.

Parancs Működés
Rgroup.vbs -t f -g alt.*
 Az alt szócskával kezdődő hírcsoportok listázása.
Rgroup.vbs -t d -g en.regi.csoportom
 Az en.regi.csoportom nevű hírcsoport törlése.
Rgroup.vbs -t a -g en.uj.csoportom
 Az en.uj.csoportom nevű hírcsoport hozzáadása.
Rgroup.vbs -t s -g en.regi.csoportom -p NagyCsoport
       -m moderator@tartomanyom.com
 Az en.regi.csoportom nevű hírcsoport közérthető nevének beállítása NagyCsoport értékre, és a moderator@tartomanyom.com cím megadása a moderátor címeként.


Rserver.vbs

Ez a parancs virtuális NNTP-kiszolgálók hozzáadására, törlésére és módosítására szolgál. Az alábbi táblázat tartalmazza az Rserver paranccsal használható paramétereket.

Paraméter | Leírás
-t művelet, ahol művelet az alábbi argumentumok egyike: |
g | A kiszolgáló konfigurációjának lekérése. (Az -s és -v kapcsolókkal használható.)
s | A kiszolgáló konfigurációjának beállítása. (Az -s és -v kapcsolókkal használható.)
c | Új virtuális NNTP-kiszolgáló létrehozása. (Az -s és -v kapcsolókkal használható.) Megjegyzés Miután az Rserver paranccsal létrehoz egy új virtuális kiszolgálót, elindításához le kell állítania és újra kell indítania a Microsoft NNTP-szolgáltatást.
d | Virtuális NNTP-kiszolgáló törlése. (Az -s és -v kapcsolókkal használható.)
-s kiszolgáló | A konfigurálni kívánt kiszolgáló számítógép neve.
-v virtuális kiszolgáló azonosítója | A virtuális NNTP-kiszolgáló azonosítója (egész szám).
-o port azonosítója | A TCP/IP port.
-l enyhe közzétételi korlát | A kilobájtban megadott korlátnál nagyobb cikkek közzétételének visszautasítása, de a kapcsolat fenntartása. Alapértelmezés szerint a cikkméret korlátja 64 kB.
-h szigorú közzétételi korlát | A kapcsolat megszakítása, ha a fogadott cikk nagyobb a megabájtban megadott korlátnál. Alapértelmezés szerint a cikkméret korlátja 1 MB.
-m SMTP-cím | A moderátornak küldendő cikkek célcíme. (Lehet teljesen minősített tartománynév (FQDN), számítógépnév vagy IP-cím.)
-u uucpnév | Az útvonalfejlécben feltüntetett egyedi azonosító. (Alapértelmezés szerint a kiszolgáló állomásneve.)
-d tartománynév | Az alapértelmezett moderátorok tartományneve.
-c true | false | Annak jelzése, hogy engedélyezett-e az ügyféloldali közzététel. Alapértelmezés szerint igen (True).
-x true | false | Annak jelzése, hogy a rendszer feldolgozza-e a vezérlőüzeneteket. Alapértelmezés szerint igen (True).
-n útvonal | A Microsoft NNTP-szolgáltatás fájljainak teljes elérési útvonala.
-a levelezési cím | A rendszergazda elektronikus postafiókja.
-p könyvtár elérési útvonala | A Felvételi könyvtár teljes elérési útvonala.
-q könyvtár elérési útvonala | A Sikertelen felvételek könyvtárának teljes elérési útvonala.
-b true | false | Annak jelzése, hogy engedélyezett-e a Newnews parancs használata.
-r true | false | Annak jelzése, hogy a kiszolgáló figyelembe veszi-e az ügyfelek üzenetazonosítóit.

A következő példák bemutatják a parancsfájlok használatának módját. Amikor fut a Windows Script Host, az alábbi parancsok bármelyikét begépelheti a parancssorba, és futtathatja a parancsfájlt.

Parancs Működés
Rserver.vbs -t g -v 1
 Az 1. virtuális NNTP-kiszolgáló tulajdonságainak lekérése.
Rserver.vbs -t s -v 1 -c true -l 100000
       -a rendszergazda@tartomanyom.com
 Az 1. számú virtuális NNTP-kiszolgáló következő tulajdonságainak beállítása: legfeljebb 100 kB cikkméretig engedélyezze az ügyféloldali közzétételt, a rendszergazda elektronikus levélcíme pedig rendszergazda@tartomanyom.com.
Rserver.vbs -t d -v 3
 A 3. számú virtuális NNTP-kiszolgáló törlése.


Rsess.vbs

Ez a parancs a munkamenetek kezelésére szolgál. Az alábbi táblázat tartalmazza az Rsess paranccsal használható paramétereket.

Paraméter | Leírás
-t művelet, ahol művelet az alábbi argumentumok egyike: |
e | Felhasználók felsorolása.
d | Munkamenet megszakítása. (Csak az -u vagy az -i kapcsolóval együtt használható.)
a | Az összes munkamenet, illetve egy ügyféllel fenntartott kapcsolat megszakítása.
-u felhasználónév | A megszakítandó kapcsolathoz tartozó felhasználónév.
-i ip-cím | A megszakítandó kapcsolathoz tartozó IP-cím vagy állomásnév.
-s kiszolgáló | A konfigurálni kívánt kiszolgáló számítógép neve.
-v virtuális kiszolgáló azonosítója | A virtuális NNTP-kiszolgáló azonosítója (egész szám).

A következő példák bemutatják a parancsfájlok használatának módját. Amikor fut a Windows Script Host, az alábbi parancsok bármelyikét begépelheti a parancssorba, és futtathatja a parancsfájlt.

Parancs Működés
Rsess.vbs -t e -v 1
 Az 1. virtuális NNTP-kiszolgáló aktuális munkameneteinek listázása.
Rsess.vbs -t d -u rosszalkodo_felhasznalo
A rosszalkodo_felhasznalo munkamenetének megszakítása.
Rsess.vbs -t a
 Az összes munkamenet megszakítása.


Parancssori visszatérési kódok

Az alábbi táblázat a parancsfájlok sikertelen futtatásakor visszakapott kódokat tartalmazza.

Decimális visszatérési kód | Hiba | Jelentés
2114 | A kiszolgáló még nem indult el | A kiszolgáló inicializálása még nem fejeződött be, a kiszolgáló nem kezeli a távoli eljáráshívásokat.
5 | ERROR_ACCESS_DENIED | A felhasználó nem rendszergazda.
8 | ERROR_NOT_ENOUGH_MEMORY | A kiszolgáló nem tudott elég memóriát lefoglalni a kérés kezeléséhez.
2222 | Az objektum nem található | A felhasználó megpróbált valamit tenni, de a távoli eljáráshívás objektuma nem található.
267 | ERROR_DIRECTORY | Hibás könyvtár. Ez a hiba akkor fordul elő, amikor a felhasználó nem létező hírcsoport tulajdonságait próbálja beállítani.
123 | ERROR_INVALID_NAME | Ez a hiba akkor fordul elő, amikor a felhasználó megpróbál létrehozni egy hírcsoportot, de érvénytelen hírcsoportnevet ad meg.
1359 | ERROR_INTERNAL_ERROR | A hiba forrását nem sikerült azonosítani.
2140 | ERROR_INTERNAL_ERROR | A hiba forrását nem sikerült azonosítani.
87 | ERROR_INVALID_PARAMETER | A távoli eljáráshívás során megadott paraméterek valamelyike nem érvényes.


Karbantartás

Ez a rész ismerteti a Microsoft NNTP-szolgáltatás magas teljesítményének és folyamatos rendelkezésre állásának biztosításához elvégzendő karbantartási feladatokat. A nagyobb forgalmat bonyolító hírszolgáltatások több gondoskodást igényelnek, ezért a virtuális NNTP-hírkiszolgálójának működtetése során felmerülő karbantartási igények nagy mértékben függenek majd a kiszolgáló igénybevételétől.

Ez a rész a következő témaköröket tartalmazza:

  • A karbantartási feladatok áttekintése
  • A Microsoft NNTP-szolgáltatás felügyelete a Teljesítményfigyelővel
  • Üzenetek megtekintése az Eseménynaplóban
  • A Microsoft NNTP-szolgáltatás tranzakcióinak naplózása
  • A Microsoft NNTP-szolgáltatás újraépítése


A karbantartási feladatok áttekintése

A Microsoft NNTP-szolgáltatás teljesítményét és rendelkezésre állását úgy tarthatja a lehető legmagasabb szinten, hogy összeállít egy karbantartási ütemtervet, amelynek keretében rendszeresen elvégzi a szükséges feladatokat. A rendszeres karbantartás lehetővé teszi, hogy még az előtt felismerje és kiköszöbölje az esetleges problémákat, mielőtt ténylegesen bekövetkeznének és gondot okoznának a felhasználóknak.

A Microsoft NNTP-szolgáltatás karbantartása négyféle feladatkörre bontható:

  • A működés szempontjából kritikus teljesítményadatok figyelemmel kísérése
  • Az Eseménynaplóba írt üzenetek áttekintése
  • A tranzakciós adatok figyelemmel kísérése
  • Az indexek és ujjlenyomattáblák frissítése

A teljesítményszámlálók segítségével könnyen nyomon követheti, hogy a működés szempontjából kritikus teljesítményadatok között vannak-e szokatlan értékek.

A Microsoft Internet Information Services (IIS) naplóiban figyelemmel kísérheti, hogy ki és hogyan használja a virtuális NNTP-kiszolgálót.

A Microsoft NNTP-szolgáltatás újraépítési lehetőségének köszönhetően a hírcsoportokban közzétett cikkek nyomon követésére szolgáló indexek és ujjlenyomattáblák is egyszerűen frissíthetők.


A Microsoft NNTP-szolgáltatás felügyelete a Teljesítményfigyelővel

A Microsoft NNTP-szolgáltatás teljesítményének nyomon követéséhez használja a Microsoft Windows 2000 Server Felügyeleti eszközei között található Teljesítmény eszközt. A Microsoft NNTP-szolgáltatáshoz tartozó teljesítményszámlálók segítségével elemezheti a teljesítménnyel kapcsolatos lényeges adatokat, illetve diagramok és jelentések készítéséhez is felhasználhatja azokat:

  • A szolgáltatás forgalmát
  • Az adatbiztonságot
  • Az átfogó teljesítményadatokat
  • A teljesítmény terén mutatkozó irányzatokat

A Microsoft NNTP-szolgáltatás két objektumot használ a Teljesítményfigyelőben. Az egyik az NNTP-parancsok objektum, amely az ügyfél által kiadott parancsokra vonatkozó számlálókat tartalmazza, a másik pedig az NNTP-kiszolgáló objektum, amely a szolgáltatás teljesítményének mérésére használható számlálókat tartalmazza. Ez a rész csak a leggyakrabban használt teljesítményszámlálókat mutatja be.

Diagramok és jelentések készítésén túl lehetőség van riasztás kérésére is, abban az esetben, ha a figyelemmel kísért értékek átlépik a megadott határértéket.

A Microsoft NNTP-szolgáltatás figyelése

  1. Mutasson az egérrel a Start menü Programok elemére, majd a Felügyeleti eszközök menüpontra, végül kattintson a Teljesítmény parancsra.
  2. A Teljesítmény ablakban kattintson az egér jobb oldali gombjával a grafikon területére, majd válassza a Számláló hozzáadása parancsot.
  3. A Teljesítményobjektum legördülő listáról válassza ki az NNTP-parancsok vagy az NNTP-kiszolgáló elemet.
  4. A Számlálók választása listán kattintson a használni kívánt teljesítményszámlálóra. A kijelölt számláló rövid leírásának megtekintéséhez kattintson a Magyarázat gombra.
  5. Kattintson a Hozzáadás gombra.


A szolgáltatás forgalmának figyelése

A Microsoft NNTP-szolgáltatás forgalmának figyelésével ellenőrizheti, hogy a szolgáltatás fogad-e új kapcsolatokat, illetve kiszolgálja-e a már létrehozott kapcsolatokat. A szolgáltatás forgalmáról az alábbi teljesítményszámlálók adnak áttekintő képet:

  • Az NNTP-kiszolgáló objektum Összes bájt/mp számlálója, amelynek értéke normális esetben nagyobb, mint nulla, amikor a szolgáltatáshoz aktív felhasználók kapcsolódnak.
  • Az NNTP-kiszolgáló objektum Jelenlegi csatlakozások számlálója, amelynek értéke nullánál nagyobb kell, hogy legyen, amikor a szolgáltatáshoz kapcsolódnak felhasználók.
  • Az NNTP-parancsok objektum Belépési kísérletek és Sikertelen belépések számlálói. A Sikertelen belépések száma a szolgáltatás megfelelő működése esetén csak töredéke lehet a Belépési kísérletek számának.
  • Az NNTP-parancsok objektum Sikertelen belépés/mp számlálója, amelynek értéke nulla kell, hogy legyen, ha a felhasználók sikeresen kapcsolódnak.
  • Az NNTP-kiszolgáló objektum Maximális csatlakozás számlálója. Normális működés esetén ennek az értéknek lényegesen kisebbnek kell lennie, mint az Általános tulajdonságlapról elérhető A kapcsolatok száma legfeljebb mezőben megadott érték.


Az adatbiztonság figyelése

A nem nyilvános virtuális NNTP-kiszolgálók esetében az NNTP-parancsok objektum Sikertelen belépés/mp számlálóját érdemes figyelnie. A sikertelen belépési kísérletek nagy száma egyes esetekben jelezheti azt, hogy jogosulatlan felhasználók próbálnak hozzáférni a szolgáltatáshoz.


Az átfogó teljesítményadatok figyelése

A virtuális NNTP-kiszolgáló teljesítményének átfogó figyeléséhez a Microsoft NNTP-szolgáltatás teljesítményszámlálóin kívül a processzor és a merevlemez teljesítményszámlálóinak értékét is ajánlatos nyomon követni. A teljesítménybeli problémákra általában az alábbi teljesítményszámlálók hívják fel előre a figyelmet:

  • A Processzor objektum Processzor kihasználtsága (%) számlálója, amelynek értéke normális esetben kisebb, mint 75.
  • A Memória objektum Szabad virtuális memória (bájt) számlálója, ennek értéke normális esetben nagyobb, mint 4 200 000.
  • A Logikai lemez objektum Szabad hely (%) számlálója Ennek az értéknek mindig nagyobbnak kell lennie, mint 0. Idejében értesülhet arról, hogy fogytán a szabad lemezterület, ehhez állítson be riasztást a számláló 10% értékéhez. Ha a Microsoft NNTP-szolgáltatás fájljai nem egy meghajtón találhatóak, minden érintett meghajtó betűjeléhez hozza létre e számláló egy példányát.
  • A Logikai lemez objektum Lemezvezérlő-várólista átlagos hossza nevű számlálója, ennek az értéknek kisebbnek kell lennie a számítógép lemeztömbjében levő lemezek számánál. Ha a hírcikkeket nem egy meghajtón tárolják, minden érintett meghajtó betűjeléhez hozza létre e számláló egy példányát.

    Mielőtt a Teljesítmény ablakban felveszi a Logikai lemez objektum számlálóit, az alábbi parancs végrehajtásával és a számítógép újraindításával engedélyezze a lemezekre vonatkozó adatok gyűjtését:

    diskperf -y

    A Microsoft Windows csíkkészletként beállított lemezek esetén a következő parancsot gépelje be:

    diskperf -yE

    Amikor nem figyeli aktívan a lemezek teljesítményét, a teljesítménybeli problémák elkerülése végett az alábbi paranccsal kapcsolja ki a lemezek adatainak gyűjtését:

    diskperf -n


A teljesítmény terén mutatkozó irányzatok figyelése

A Teljesítmény ablakban látható diagram elsősorban a pillanatnyi teljesítményadatok megfigyelésére szolgál. A teljesítmény terén mutatkozó irányzatok nyomon követéséhez inkább a Windows 2000 Teljesítménynaplóit használja. Ezek a diagrammal megegyező teljesítményszámlálókat használnak, de nem folyamatosan, hanem csak meghatározott időközönként gyűjtik az adatokat.

Az irányzatok nyomon követésére használható Teljesítménynapló létrehozásának lépéseit a Windows 2000 dokumentációjának Teljesítménynaplók és riasztások című témaköre ismerteti. A napló létrehozásakor a Teljesítményobjektum listáról az NNTP-parancsok, illetve az NNTP-kiszolgáló objektumot válassza ki.


A Microsoft NNTP-szolgáltatás tranzakcióinak naplózása

A Microsoft NNTP-szolgáltatás a tranzakciós adatokat az IIS naplóiba írja. A tranzakciós naplók elemzésével megtudhatja, hogy kik és hogyan használják a virtuális NNTP-kiszolgálót, majd igény szerint kivonatolhatja a naplókból a szükséges adatokat. Ez után archiválja vagy törölje a naplókat, hogy ne foglalják a lemezen feleslegesen a helyet.

A Microsoft NNTP-szolgáltatás minden egyes alkalommal bejegyez egy rekordot a naplóba, amikor egy felhasználó kapcsolódik a szolgáltatáshoz, onnan cikket tölt le, cikket tesz közzé, illetve bontja a kiszolgálóval létesített kapcsolatot. A szöveges naplófájlokat egyszerű szövegszerkesző programban megnyitva is olvashatja, de elemzésükhöz inkább az adatok összegzésére képes szoftvereket szoktak használni. Naplóbejegyzéseket az alábbi négy formátumban készíthet:

  • Vesszővel elválasztott értékből álló (CSV) szövegfájlként IIS naplóformátumban.
  • CSV szövegfájlként NCSA általános naplóformátumban.
  • CSV szövegfájlként W3C bővített naplóformátumban.
  • Open Database Connectivity (ODBC) adatbázis-formátumban. Az adatok ODBC adatbázisba való írása növeli a szolgáltatás erőforrásigényét, így csökkentheti a teljesítményt.

Az IIS naplózási lehetőségeiről az IIS dokumentációjának Helytevékenység naplózása című témakörében talál további információt.

Naplózás engedélyezése

  1. Kattintson az Általános fülre.
  2. Jelölje be a Naplózás engedélyezése jelölőnégyzetet.
  3. Az Aktív naplóformátum legördülő listáról válassza ki a tranzakciós naplóbejegyzések formátumát.
  4. Kattintson a Tulajdonságok gombra, majd adja meg a kiválasztott naplóformátumra vonatkozó tulajdonságokat. (Ha szeretne bővebb információt kapni az egyes tulajdonságokról, kattintson a Súgó gombra.)
  5. Jelölje ki egyesével az összes virtuális könyvtárat, és kattintson a Művelet menü Tulajdonságok parancsára.
  6. Az adott virtuális könyvtár-hierarchiában levő hírcsoportok tranzakcióinak naplózásához jelölje be a Virtuális könyvtár párbeszédpanelen látható Hozzáférés naplózása jelölőnégyzetet.


Üzenetek megtekintése az Eseménynaplóban

Rendszeres időközönként ellenőrizze az Eseménynaplóba írt üzeneteket, hogy időben értesüljön az esetleg kialakulóban levő problémákról. A Microsoft NNTP-szolgáltatás a szolgáltatás indításakor, leállásakor, felügyelői parancs feldolgozásakor, valamint hiba érzékelése esetén minden egyes alkalommal beír egy üzenetet az Eseménynapló szolgáltatás Rendszernaplójába.

Üzenetek megtekintése az Eseménynaplóban

  1. Mutasson az egérrel a Start menü Programok elemére, majd a Felügyeleti eszközök menüpontra, végül kattintson az Eseménynapló parancsra.
  2. Jelölje ki a Rendszernapló elemet. A Microsoft NNTP-szolgáltatástól származó üzeneteknél a Forrás oszlopban az NNTPSVC bejegyzés látható.

Ha szűri az Eseménynaplóban látható üzeneteket, sokkal könnyebben megtalálja a Microsoft NNTP-szolgáltatástól származókat.

Csak a Microsoft NNTP-szolgáltatás üzeneteinek megtekintése

  1. Kattintson az Eseménynapló Nézet menüjének Szűrő parancsára.
  2. Az Eseményforrás legördülő listáról válassza ki az NNTPSVC bejegyzést.


Virtuális NNTP-kiszolgáló újraépítése

Amikor a Microsoft NNTP-szolgáltatás használatával újraépít egy virtuális NNTP-kiszolgálót, a rendszer frissíti az index- és ujjlenyomattábla-fájlokat, amelyek alapján a virtuális kiszolgáló nyilvántartja a cikkeket. Akkor érdemes újraépíteni egy virtuális NNTP-kiszolgálót, ha előzőleg kézzel törölt egyes fájlokat, ha a lemez meghibásodása után próbálja helyreállítani a rendszert, vagy ha problémát tapasztal a cikkek elérésekor. Ezen túlmenően az Eseménynapló szolgáltatás Rendszernaplójába írt egyes hibaüzenetek is utalhatnak a virtuális kiszolgáló újraépítésének szükségességére.

Megjegyzés

Ahhoz, hogy egy virtuális NNTP-kiszolgálón újraépíthesse a Microsoft hírszolgáltatást, először le kell állítania a virtuális kiszolgálót.

Az újraépítés két szintje közül választhat:

  • Szokásos: Nem végzi el az összes fájl újraépítését, de éppen ezért ez a gyorsabb módszer.
  • Alapos: Minden egyes fájlt újraépít, ezért ez a lassabb lehetőség.
Megjegyzés

Amennyiben törölte az nntpfile\root könyvtárat, mindenképpen az Alapos újraépítést kell használnia.

Virtuális NNTP-kiszolgáló újraépítése

  1. A Microsoft Management Console ablakában állítsa le a virtuális NNTP-kiszolgálót.
  2. Ellenőrizze, hogy a megfelelő virtuális NNTP-kiszolgáló van-e kijelölve, majd kattintson a Művelet menü Minden feladat parancsára.
  3. Kattintson a Kiszolgáló újraépítése menüpontra.
  4. Az Újraépítés típusa részen válassza a Szokásos vagy az Alapos szintet, majd kattintson az Indítás gombra.


Hibaelhárítás

Ez a rész ismerteti a Microsoft NNTP-szolgáltatás működése során fellépő problémák felderítésének és elhárításának módját. Amennyiben a felhasználók bármiféle hibát jelentenek, vagy hibaüzenetek érkeznek a szolgáltatástól, kövesse a bemutatott lépéseket.

A rész a következő témaköröket tartalmazza:

  • A hibaelhárítási lehetőségek áttekintése
  • Üzenetek megtekintése az Eseménynaplóban
  • A hálózati kapcsolat ellenőrzése a Ping segédprogrammal
  • A Microsoft NNTP-szolgáltatás elérhetőségének ellenőrzése a Telnet rendszerrel


A hibaelhárítási lehetőségek áttekintése

Amennyiben Ön vagy a felhasználók valamilyen hibát észlelnek a Microsoft NNTP-szolgáltatás működésében, kövesse az itt ismertetett lépéseket. Alapvetően háromféle hibaelhárítási eljárás közül választhat:

  • Az Eseménynaplóban megtekintheti a Microsoft NNTP-szolgáltatás által küldött üzeneteket. Amennyiben a szolgáltatás problémát észlel, vagy valamilyen okból nem indul el, hibaüzenetet ír az Eseménynapló szolgáltatás Rendszernaplójába.
  • A Ping programmal ellenőrizheti, hogy lehetséges-e a hálózaton keresztül kapcsolatot létesíteni a Microsoft NNTP-szolgáltatással. Ha az ügyfelek nem tudnak hálózati kapcsolatot létesíteni a szolgáltatást futtató számítógéppel, akkor nem tudnak cikkeket közzétenni, és nem tudják olvasni a hírcsoportokban található cikkeket.
  • A Telnet programmal ellenőrizheti, hogy a Microsoft NNTP-szolgáltatás egyáltalán elérhető-e, illetve meghatározhatja, hogy a hiba okát az ügyfélben vagy a szolgáltatásban kell-e keresni.


Üzenetek megtekintése az Eseménynaplóban

Amennyiben problémát tapasztal a Microsoft NNTP-szolgáltatás működésével kapcsolatban, ellenőrizze, hogy van-e a szolgáltatásra vonatkozó hibaüzenet az Eseménynaplóban. A Microsoft NNTP-szolgáltatás a szolgáltatás indításakor, leállásakor, felügyelői parancs feldolgozásakor, valamint hiba érzékelése esetén minden egyes alkalommal beír egy üzenetet az Eseménynapló szolgáltatás Rendszernaplójába.

Akkor is érdemes rendszeres időközönként megtekintenie az Eseménynaplót, és elolvasnia a hibaüzeneteket, ha a szolgáltatás látszólag hibátlanul működik, mert így időben fény derülhet a későbbiekben esetleg hibát okozó körülményekre.

Az Eseménynapló használatával kapcsolatban a Windows 2000 dokumentációjában talál további információt.


A hálózati kapcsolat ellenőrzése a Ping segédprogrammal

A Ping programmal ellenőrizheti, hogy lehetséges-e a hálózaton keresztül kapcsolatot létesíteni a Microsoft NNTP-szolgáltatással. Meggyőződhet arról is, hogy a tartománynévrendszer (DNS) a számítógép neve alapján helyesen határozza-e meg a gép Internet Protocol (IP) címét.

A hálózaton belül nagyon sok helyen adódhatnak hálózati problémák, ezért célszerű a kapcsolatot arról a számítógépről ellenőrizni, amelyről az ügyfél nem tud a Microsoft NNTP-szolgáltatáshoz kapcsolódni. Ez természetesen nem jelenti azt, hogy szükség esetén nem ellenőrizhetné a kapcsolatot a hálózat bármely más számítógépéről.

Megjegyzés

Egyes hálózati útválasztók minden esetben blokkolják a Ping üzeneteket. Ha a Ping segédprogram sem képes kapcsolatot teremteni, próbáljon a Telnet rendszerrel kapcsolódni.

A hálózati kapcsolat ellenőrzése

  1. Mutasson az egérrel a Start menü Programok, majd Kellékek elemére, és végül kattintson a Parancssor menüpontra.
  2. A parancssorban gépelje be az alábbi parancsot:

    ping kiszolgálónév

    ahol kiszolgálónév a Microsoft NNTP-szolgáltatást futtató számítógép DNS-beli neve.

  3. Amennyiben a két számítógép sikeresen hálózati kapcsolatot létesít, az alábbihoz hasonló válasz érkezik:

    Pinging news.dns.mycompany.com [123.45.12.345] with 32 bytes of data:

    Reply from 123.45.12.255: bytes=32 time=15ms TTL=128
    Reply from 123.45.12.255: bytes=32 time<10ms TTL=128
    Reply from 123.45.12.255: bytes=32 time<10ms TTL=128

    Amennyiben a két számítógépnek nem sikerül hálózati kapcsolatot létesítenie, az alábbihoz hasonló hibaüzenet érkezik:

    Bad IP address news.mycompany.com

    Ilyen hibaüzenet esetén gépelje be a következő parancsot a parancssorba:

    ping IP_cím

    ahol IP_cím a Microsoft NNTP-szolgáltatást futtató számítógép IP-címe.

    Amennyiben IP-cím alapján sikerül kapcsolatot teremteni, de a DNS-beli név megadásával nem, a probléma oka valószínűleg a tartománynévrendszerben keresendő. Ellenőrizze, hogy a Microsoft NNTP-szolgáltatás IP-címét helyesen regisztrálta-e a tartománynévrendszerben, és hogy az ügyfél a megfelelő DNS használatára van-e beállítva.

    Ha az IP-cím megadásával sem sikerül kapcsolatot teremteni, a hálózati kapcsolattal van baj. A hálózati probléma felderítése és megoldása érdekében lépjen kapcsolatba a hálózati rendszergazdával.

A Ping parancs szintaxisáról úgy kaphat bővebb információt, hogy a parancssorban begépeli a ping -? utasítást.

Megjegyzés

Amennyiben a Ping parancsra kapott válaszban az időérték nagyobb 10 ezredmásodpercnél, kérje meg a hálózati rendszergazdát, hogy ellenőrizze, nem túl nagy-e a hálózati forgalom.


A Microsoft NNTP-szolgáltatás elérhetőségének ellenőrzése a Telnet rendszerrel

A Telnet programmal ellenőrizheti, hogy a Microsoft NNTP-szolgáltatás fogadja-e a kapcsolódási kísérleteket, és megfelelően reagál-e az NNTP-parancsokra. Így meghatározhatja, hogy a hiba okát az ügyfélben vagy a szolgáltatásban kell-e keresni.

A Telnet program használata előtt a Ping segédprogrammal ellenőrizze a hálózati kapcsolatot.

Kapcsolódás a Microsoft NNTP-szolgáltatáshoz a Telnet programmal

  1. Kattintson a Start menü Futtatás parancsára.
  2. A Futtatás párbeszédpanelen gépelje be a Telnet parancsot, majd kattintson az OK gombra.
  3. Gépelje be a set LOCAL_ECHO parancsot, majd üsse le az Enter billentyűt.
  4. Gépelje be az open <név vagy cím> <port> parancsot, és üsse le az Enter billentyűt. Ebben a példában <név vagy cím> a Microsoft NNTP-szolgáltatást futtató, Windows 2000 Server operációs rendszer alatt működő kiszolgáló DNS-beli neve vagy IP-címe, <port> pedig a TCP port száma. Az NNTP-szolgáltatás alapértelmezés szerint a 119-es portot használja.
Amennyiben a szolgáltatás fogadja a kapcsolatokat, az alábbihoz hasonló üzenet érkezik:

200 NNTP-szolgáltatás Microsoft Internet Services 5.5 Version: 5.5.1717.0 Posting Allowed

Amennyiben a Telnet Sikertelen csatlakozás (Connect failed) hibaüzenetet küld, a szolgáltatás nem fut, vagy nem fogad kapcsolatokat. Ha a Microsoft NNTP-szolgáltatás 502 Kapcsolódási kísérlet elutasítva (502 Connection Refused) üzenetet küld, akkor a szolgáltatást vagy szüneteltetik, vagy a kapcsolatok száma elérte a beállított korlátot.

  • Ha a szolgáltatás fogadta a kapcsolatot, gépelje be a list parancsot, és üsse le az ENTER billentyűt.

    Amennyiben a szolgáltatás válaszol az NNTP-parancsokra, elküldi az elérhető hírcsoportok listáját.

    Ha 480 Bejelentkezés szükséges (480 Logon Required) üzenetet kap, akkor nem engedélyezett a szolgáltatáshoz való névtelen hozzáférés.

  • A Telnet munkamenet befejezéséhez gépelje be a quit parancsot, majd üsse le az ENTER billentyűt.

      Amennyiben a Telnet segítségével sikeresen kapcsolódott a szolgáltatáshoz, és a List parancsot is végre tudta hajtani, akkor a problémát valószínűleg az ügyfélprogram okozza.

      Ha nem sikerül kapcsolatot létesíteni, akkor valószínűleg a szolgáltatással van baj. Ellenőrizze a portszámot és a Microsoft NNTP-szolgáltatás további konfigurációs beállításait.


Jogi tudnivalók

Microsoft dokumentáció

A jelen dokumentumban található információ előzetes bejelentés nélkül megváltozhat. Az említett cégek, termékek vagy személyek neve és/vagy bármely más adata a képzelet szüleménye, és bármilyen egybeesés valós személyek, cégek, termékek vagy események tényleges adataival csak a véletlen műve, a külön említett eseteket kivéve. Az összes vonatkozó szerzői jogi törvény betartása a felhasználó felelőssége. A Microsoft Corporation külön írásos engedélye nélkül a jelen dokumentum egyetlen része sem reprodukálható vagy adható tovább semmilyen célból, semmilyen formában, illetve semmilyen — elektronikus vagy mechanikus — úton. Ez alól kivételt képez az az eset, amikor a felhasználó csak elektronikus úton éri el a jelen dokumentumot — ekkor egy példányban történő kinyomtatása engedélyezett.

A jelen dokumentumban foglaltak a Microsoft szabadalmai, bejegyzés előtt álló szabadalmai vagy védjegyei lehetnek, illetve szerzői jogaira vagy más szellemi alkotására vonatkozhatnak. Jelen dokumentum átadása semmilyen licencet nem biztosít a felhasználó számára e szabadalmakra, védjegyekre, szerzői jogokra, illetve más szellemi alkotásra, kivéve a Microsoft által kiadott bármely írásos licencszerződésben kifejezetten engedélyezett eseteket.

Copyright © 1999 Microsoft Corporation. Minden jog fenntartva.

A Microsoft, az MS-DOS, az MS, a Windows, a Windows 2000, az ActiveX, a JScript, a Microsoft Press, a Visual Basic, a Visual C++, a Visual J++, a Win32 és a Win32s a Microsoft Corporation védjegyei vagy bejegyzett védjegyei az Egyesült Államokban, illetve más országokban.

A Java a Sun Microsystems, Inc. védjegye.

Az Alpha AXP a Digital Equipment Corporation védjegye.

A Pentium az Intel Corporation bejegyzett védjegye.

A Macintosh és a QuickTime az Apple Computer, Inc. bejegyzett védjegye.

A dokumentumban említett más termékek és cégek neve tulajdonosuk védjegye lehet.


A Microsoft NNTP-szolgáltatással kapcsolatos kifejezések gyűjteménye

Kifejezés | Jelentés
hozzáférés-szabályozási lista (acl) | Egy fájlhoz vagy egyéb erőforráshoz való hozzáférés szabályozására szolgáló objektum.
hitelesítés | A felhasználó bejelentkezési adatainak ellenőrzési folyamata.
ügyfélszámítógép | Olyan számítógép, amely adatok küldése vagy fogadása céljából kapcsolódik egy kiszolgálóhoz. Ez tulajdonképpen a „felhasználó számítógépe”.
DNS | Tartománynévrendszer. Elosztott adatbázis, amelynek használatával az alkalmazások egy adott hálózat Internet Protocol (IP) címeit bonyolult 32 bites címekből közérthető tartománynévvé alakíthatják.
ISP | Internetszolgáltató. Magánszemélyeknek és cégeknek kereskedelmi céllal internet-hozzáférést biztosító cég.
tagsági ügynök | A Microsoft Membership System kulcsfontosságú összetevője, amely az adatbiztonsági adatbázis eléréséhez szükséges. Lehetővé teszi a hitelesítést és a hozzáférés-szabályozást elkülönült, tagsági alapon működő közösségek számára.
Membership System | Microsoft kiszolgálóalkalmazás, amely új felhasználók regisztrálására, felhasználók hitelesítésére, valamely szolgáltatás egyes részeihez való ellenőrzött hozzáférés biztosítására, valamint külső számlázóprogrammal feldolgozható számlázási események létrehozására használható.
MMC | Microsoft Management Console. A Microsoft Internet Information Services (IIS) felügyeleti eszköze, amely internetes szolgáltatások, például a Microsoft NNTP-szolgáltatás, a Microsoft SMTP-szolgáltatás, valamint webhelyek és FTP-helyek kezelésére használható.
NTFS | A Windows 2000 operációs rendszer fájlrendszere. A Microsoft NNTP-szolgáltatás által használt fájlokhoz szükséges fájlrendszer. A rendszer könyvtár- és fájlhozzáférési engedélyek használatával biztosítja az adatok védelmét, és szabályozza az adatfájlokhoz való hozzáférést.
NTLM | A Windows helyi hálózatok kezelését végző modulja, illetve a Microsoft Windows adatbiztonsági protokollja.
Ping segédalkalmazás | Packet Internet Groper. Ez a program ellenőrzi a távoli számítógéppel vagy számítógépekkel létrehozott kapcsolatot. Az ellenőrzéshez Internet Control Message Protocol (ICMP) szerinti csomagokat küld a számítógépeknek, majd figyeli az azokra érkező válaszcsomagokat.
proxy kiszolgáló | A belső hálózat és az Internet között biztonsági sorompóként működő kiszolgáló, amelynek további előnye, hogy a gyakran használt dokumentumokat helyi gyorsítótárban tárolja, és ezzel csökkenti a hálózati forgalmat.
SNMP | Simple Network Management Protocol. A vállalati szintű rendszerek és hálózatok kezelésére és felügyeletére használt programok erre az ipari szabványként elfogadott protokollra épülnek.
SSL | Secure Sockets Layer technológia. A Transmission Control Protocol/Internet Protocol (TCP/IP) hálózatokon küldött csomagok tartalmát védő titkosítási séma.
TCP/IP | Transmission Control Protocol/Internet Protocol. A hálózatba kapcsolt számítógépek közötti adatátvitelre használt szabványos internetes protokoll.
UNC | Univerzális elnevezési konvenció (Universal Naming Convention). A helyi hálózati fájlkiszolgáló valamely meghajtójára mutató elérési útvonalak szabványos formátuma.
URL | Egységes erőforrás-azonosító (Uniform Resource Locator). Egy objektumra, dokumentumra, oldalra vagy az Internet, illetve a belső hálózat (intranet) valamely pontjára mutató cím.