Hálózatfigyelő

A rendszergazda a Hálózatfigyelő segítségével tekintheti meg és derítheti fel a helyi (LAN) hálózaton előforduló hibákat.

  • A Hálózatfigyelő használata előtt tekintse át a Feladatlista: A hálózat figyelése című témakört.
  • A Windows 2000 Server operációs rendszerben a korábbi verzióktól eltérő helyen található szolgáltatásokkal kapcsolatban a Megszokott feladatok végrehajtásának új módjai részben talál tájékoztatást.
  • A Hálózatfigyelő használatával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános tudnivalókat a Fogalmak című témakörben találja meg.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Feladatlista: A hálózat figyelése

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat. Hálózatfigyelő – áttekintés;
A Hálózatfigyelő összetevői;
Gyakorlati tanácsok
Bizonyosodjon meg arról, hogy tagja a Rendszergazdák csoportnak. | Csoportok – áttekintés
Telepítse a Hálózatfigyelő eszközöket. | A Hálózatfigyelő telepítése
Hozzon létre rögzítési szűrőt. | A rögzítési szűrők használata
Hozzon létre megjelenítési szűrőt. | Megjelenítési szűrők használata
Értelmezze az eredményeket. | Nyissa meg a Hálózatfigyelő ablakot. A rögzített hálózati csomagok értelmezéséhez útmutatót talál a Hálózatfigyelő Súgó menüjében.


Megszokott feladatok végrehajtásának új módjai

Az alábbi táblázat a Windows NT 4.0 már ismert hálózatfigyelési feladatait és a Windows 2000 ezeknek megfelelő feladatait hasonlítja össze.
Cél | Windows NT 4.0 operációs rendszerben | Windows 2000 operációs rendszerben
A Hálózatfigyelő telepítése | Network (Hálózatok) ikon a Control Panel (Vezérlőpult) ablakban. | A Programok telepítése/törlése párbeszédpanelen kattintson a Windows-összetevők hozzáadása/eltávolítása gombra. További tudnivalók A Hálózatfigyelő telepítése című témakörben találhatók.
A Hálózatfigyelő illesztőprogramjának telepítése | Network ikon a Control Panel ablakban. | A Hálózati és telefonos kapcsolatok ablakból elérhető Helyi kapcsolat tulajdonságai párbeszédpanel. További tudnivalók A Hálózatfigyelő illesztőprogramjának telepítése című témakörben találhatók.
Hálózati keretek figyelése | Az Administrative Tools (Rendszergazda eszközei) közül elérhető Network Monitor (Hálózatfigyelő). | A Hálózatfigyelő a Felügyeleti eszközök programcsoportban. További tudnivalók a Dinamikus kötetek kezelése című témakörben találhatók.


Gyakorlati tanácsok

  • A Hálózatfigyelő futtatása alacsony kihasználtságú időszakokban
    Futtassa a Hálózatfigyelőt alacsony kihasználtságú időszakokban vagy rövid ideig. Ezzel enyhíthető a Hálózatfigyelőnek a rendszer teljesítményére gyakorolt hatása.
  • Minimális mennyiségű hálózati statisztikai adat rögzítése
    Csak annyi statisztikai adatot rögzítsen, amennyi az értékeléshez szükséges. Így megakadályozható, hogy a hiba viszonylag gyors felderítéséhez túl sok adatot rögzítsen.


Útmutató

  • A Hálózatfigyelő telepítése
  • A Hálózatfigyelő illesztőprogramjának telepítése
  • Hálózati keretek rögzítése


A Hálózatfigyelő telepítése

  1. Nyissa meg a Programok telepítése/törlése párbeszédpanelt.
  2. A Programok telepítése/törlése párbeszédpanelen kattintson a Windows-összetevők hozzáadása/eltávolítása gombra.
  3. A Windows-összetevők varázslóban jelölje ki a Kezelő és figyelő eszközök elemet, majd kattintson a Részletek gombra.
  4. A Kezelő és figyelő eszközök ablakban jelölje be a Hálózatfigyelő eszközök jelölőnégyzetet, majd kattintson az OK gombra.
  5. Ha a program további fájlokat kér, helyezze be a Windows 2000 Server CD-t, vagy írja be a fájlok hálózati elérési útját.

Megjegyzések

  • A Programok telepítése/törlése párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/törlése ikonra.
  • A Hálózatfigyelő csak Windows 2000 Server rendszerben érhető el.
  • Ez az eljárás automatikusan telepíti a Hálózatfigyelő illesztőprogramját is.
  • A Hálózatfigyelő használatáról részletes ismertetőt talál, ha a Hálózatfigyelő Súgó menüjére kattint.
  • Egyes Windows-összetevőket használat előtt konfigurálni kell. Ha ezek közül egy vagy több összetevő telepítésére sor került, de konfigurálásukra nem, kattintson a Windows-összetevők hozzáadása/eltávolítása gombra, és megjelenik a konfigurálásra szoruló összetevők listája. A Windows-összetevők varázsló elindításához kattintson az Összetevők gombra.
Kapcsolódó témakörök


A Hálózatfigyelő illesztőprogramjának telepítése

  1. Nyissa meg a Hálózati és telefonos kapcsolatok ablakot.
  2. A Hálózati és telefonos kapcsolatok párbeszédpanelen kattintson a Helyi kapcsolat ikonra, majd a Fájl menü Tulajdonságok parancsára.
  3. A Helyi kapcsolat tulajdonságai párbeszédpanelen kattintson a Telepítés gombra.
  4. A hálózati összetevők típusának kijelölése párbeszédpanelen jelölje ki a Protokoll elemet, majd kattintson a Hozzáadás gombra.
  5. A Hálózati protokoll kiválasztása párbeszédpanelen kattintson a Hálózatfigyelő illesztőprogramja elemre, majd az OK gombra.
  6. Ha a program további fájlokat kér, helyezze be a Windows 2000 CD-t vagy írja be a fájlok hálózati elérési útját.

Megjegyzések

  • A Hálózati és telefonos kapcsolatok megnyitásához mutasson a Start menü Beállítások pontjára, kattintson a Vezérlőpult parancsra, végül kattintson duplán a Hálózati és telefonos kapcsolatok ikonra.
  • A Hálózatfigyelő illesztőprogramja lehetővé teszi, hogy a Hálózatfigyelő hálózati csatolóról érkező csomagokat fogadjon.
  • A Hálózatfigyelő illesztőprogramja csak Microsoft Windows 2000 Professional vagy Windows 2000 Server rendszert futtató számítógépre telepíthető. A Microsoft Systems Management Server a Windows 2000 rendszertől eltérő operációs rendszerekhez készült Hálózatfigyelő-illesztőprogramokat is magában foglal. A Microsoft Systems Management Server programról bővebb felvilágosítást a Microsoft webhely nyújt. (http://www.microsoft.com/smsmgmt)
  • Ha korábban már telepítette a Hálózatfigyelőt, a Hálózatfigyelő illesztőprogramja elem nem jelenik meg a Hálózati protokoll kiválasztása párbeszédpanelen, hiszen az a Hálózatfigyelővel együtt automatikusan települt.

Kapcsolódó témakörök


Hálózati keretek rögzítése

  1. Nyissa meg a Hálózatfigyelő ablakot.
  2. Ha a program a keretek rögzítéséhez alapértelmezett hálózatot kér, válassza azt a helyi hálózatot, amelyről alapértelmezés szerint adatokat kíván rögzíteni.
  3. Kattintson a Rögzítés menü Indítás parancsára.
  4. Ha a program további fájlokat kér, helyezze be a Windows 2000 CD-t vagy írja be a fájlok hálózati elérési útját.

Megjegyzések

  • A Hálózatfigyelő ablak megnyitásához mutasson a Start menü Beállítások pontjára, kattintson a Vezérlőpult parancsra, kattintson duplán a Felügyeleti eszközök ikonra, végül kattintson duplán a Hálózatfigyelő ikonra.
  • A Hálózatfigyelő használatáról további ismertetőt talál, ha a Hálózatfigyelő Súgó menüjére kattint.

Kapcsolódó témakörök


Fogalmak

A rész tartalma:

  • Hálózatfigyelő – áttekintés
  • A Hálózatfigyelő ismertetése
  • A Hálózatfigyelő használata
  • Forrásmunkák


Hálózatfigyelő – áttekintés

A Hálózatfigyelő azon keretek (más néven csomagok) rögzítésére és megjelenítésére szolgál, amelyeket a Windows 2000 rendszert futtató számítógép fogad a helyi (LAN) hálózaton keresztül. Az eszköz segítségével a hálózati rendszergazdák felderíthetik és elháríthatják a helyi számítógép által esetleg észlelt hálózati hibákat. A rendszergazda például a Hálózatfigyelő segítségével megkeresheti a hardver- vagy szoftverhibákat abban az esetben, ha a kiszolgáló nem tud kommunikálni más számítógépekkel. A Hálózatfigyelő által rögzített keretek fájlba menthetők, majd elküldhetők szakértő hálózatelemzőknek vagy technikai tanácsadó cégeknek.

A hálózati alkalmazások fejlesztői a Hálózatfigyelő segítségével fejlesztés közben figyelhetik a hálózati alkalmazásaikat és megkereshetik azok hibáit.

Részletes tudnivalókért a Hálózatfigyelő használatáról (például a rögzítésindítókra, a rögzítési pufferekre, a protokollelemzőkre, a címtárakra, a rögzítési szűrőkre, a megjelenítési szűrőkre valamint a rögzített adatok értelmezésére vonatkozóan) kattintson a Súgó menüre a Hálózatfigyelő ablakban.

A Microsoft Systems Management Server a Hálózatfigyelő teljes verzióját tartalmazza. A Windows 2000 Hálózatfigyelőjének szolgáltatásai mellett a Systems Management Server Hálózatfigyelője egy hálózati szegmensen lévő összes számítógépre érkező és oda küldött keretek rögzítésére, valamint szerkesztésére és továbbítására is képes. A Microsoft Systems Management Server programról bővebb felvilágosítást a Microsoft webhely nyújt. (http://www.microsoft.com/smsmgmt)


A Hálózatfigyelő ismertetése

A rész tartalma:
  • A hálózati adatfolyam
  • A hálózati adatok rögzítése
  • A Hálózatfigyelő összetevői
  • A Hálózatfigyelő nyújtotta biztonság
  • A Hálózatfigyelő részét képező protokollelemzők


A hálózati adatfolyam

A Hálózatfigyelő a hálózati adatfolyamot figyeli, amely a hálózaton bármely adott időpillanatban továbbított összes információt tartalmazza. Átvitel előtt ezt az információmennyiséget a hálózati szoftver kisebb részekre bontja, melyek neve keret vagy csomag.

A keretek, attól függetlenül, hogy szórásos, csoportos küldésű vagy irányított keretek, számos különböző részből állnak, amely részek külön-külön elemezhetők. E részek némelyike olyan adatokat tartalmaz, amely segítségével a Hálózatfigyelő elháríthatja a hálózati hibákat. A cél címének vizsgálatával például megállapítható, hogy a továbbított keret szórásos vagy irányított. Az előbbit minden állomás megkapja és feldolgozza, az utóbbit csak egy adott állomás fogadja. A keretek elemzésével megállapíthatja a keret pontos eredetét, ami annak eldöntésében nyújt segítséget, hogy az adott típusú kereteket létrehozó szolgáltatás optimalizálható-e.

Az alábbi ábra egy Ethernet-keret alkotórészeit mutatja be:

Egy Ethernet-keret alkotórészei

Ha többet szeretne tudni a Hálózatfigyelő használatáról (például a rögzítésindítókra, a rögzítési pufferekre, a protokollelemzőkre, a címtárakra, a rögzítési szűrőkre, a megjelenítési szűrőkre valamint a rögzített adatok értelmezésére vonatkozóan), kattintson a Súgó menüre a Hálózatfigyelő ablakban.

A Hálózatfigyelő telepítésével kapcsolatos utasításokat A Hálózatfigyelő telepítése című témakörben olvashatja el.


A hálózati adatok rögzítése

A rögzítés az a folyamat, amely során a Hálózatfigyelő kereteket másol. Rögzíthető a helyi számítógépre érkező illetve onnan küldött összes hálózati adatforgalom, illetve rögzítési szűrők segítségével a keretek egy adott részhalmaza is. Megadhat olyan feltételrendszert is, amely a Hálózatfigyelő rögzítési szűrőjében egy eseményt indít el. Az eseményindítók segítségével a Hálózatfigyelő válaszolni tud a hálózaton bekövetkező eseményekre. Megoldható például az, hogy a Windows elindítson egy adott végrehajtható fájlt, ha a Hálózatfigyelő a hálózaton egy bizonyos feltételrendszer meglétét észleli. A rögzített adatok megtekinthetők. A Hálózatfigyelő az adatelemzés nagy részét elvégzi a felhasználó helyett azzal, hogy a nyers rögzítési adatokat saját logikai keretstruktúrájára fordítja.

A Hálózatfigyelő egy NDIS-szolgáltatás segítségével másolja az észlelt kereteket a rögzítési pufferbe.

A hálózati adatok rögzítéséről részletes útmutató található Hálózati keretek rögzítése című témakörben.

Megjegyzés

  • Mivel a Hálózatfigyelőnek a Windows 2000 rendszerhez készült verziója a kevert mód helyett az NDIS csak helyi módját alkalmazza, a Hálózatfigyelőt akkor is használhatja, ha a hálózati csatoló a kevert módot nem támogatja. A keretek rögzítéséhez használt NDIS-illesztőprogram a hálózat teljesítményére nincs hatással. (A hálózati csatoló kevert módba állítása 30 százalékkal növelheti a processzor terhelését.)


A Hálózatfigyelő összetevői

A Hálózatfigyelő a Hálózatfigyelő felügyeleti eszközből és egy hálózati protokollból áll, melynek neve a Hálózatfigyelő illesztőprogramja. Hálózati csomagok (más néven keretek) rögzítéséhez, megjelenítéséhez és elemzéséhez mindkét összetevőt telepíteni kell.

Hálózatfigyelő

A Hálózatfigyelő azon keretek rögzítésére és megjelenítésére szolgál, amelyeket Windows 2000 Server rendszert futtató számítógép fogad a helyi hálózaton keresztül. Az eszköz segítségével a hálózati rendszergazdák felderíthetik és elháríthatják a helyi számítógépen fellépő hálózati hibákat. A Hálózatfigyelő csak Windows 2000 Server rendszert futtató számítógépekre telepíthető. Telepítésével a Hálózatfigyelő illesztőprogramja is automatikusan a számítógépre kerül.

A Hálózatfigyelő telepítésével kapcsolatos útmutató A Hálózatfigyelő telepítése című témakörben található.

A Hálózatfigyelő illesztőprogramja

A Hálózatfigyelő illesztőprogramja lehetővé teszi, hogy a Hálózatfigyelő hálózati csatolóról kereteket fogadjon, és hogy a Microsoft Systems Management Server Hálózatfigyelőjének (Systems Management Server Hálózatfigyelő) a felhasználói távoli számítógépről – akár telefonos hálózaton keresztül – érkező kereteket rögzítsenek és jelenítsenek meg. Amikor a Systems Management Server Hálózatfigyelőt futtató számítógép felhasználója egy, a Hálózatfigyelő illesztőprogramjával ellátott távoli számítógéphez csatlakozik, majd ezt követően rögzítést kezdeményez, a rögzítéssel kapcsolatos statisztikai adatok a hálózaton keresztül a kezelést végző számítógépre kerülnek. A Hálózatfigyelő illesztőprogramja csak Microsoft Windows 2000 Professional vagy Windows 2000 Server rendszert futtató számítógépre telepíthető.

A Hálózatfigyelő illesztőprogramjának telepítésével kapcsolatos útmutató A Hálózatfigyelő illesztőprogramjának telepítése című témakörben található.

Megjegyzés

  • A Systems Management Server a Windows 2000 rendszertől eltérő operációs rendszerekhez készült Hálózatfigyelő-illesztőprogramokat is tartalmaz. A Windows 2000 Hálózatfigyelőjének szolgáltatásai mellett a Systems Management Server Hálózatfigyelője egy hálózati szegmensen lévő összes számítógépre érkező és oda küldött keretek rögzítésére, valamint szerkesztésére és továbbítására is képes. A Microsoft Systems Management Server programról bővebb felvilágosítást a Microsoft Systems Management Server webhely nyújt.
A Hálózatfigyelő összetevői


A Hálózatfigyelő nyújtotta biztonság

Biztonsági okokból a Hálózatfigyelő Windows 2000 rendszerhez készült verziója csak azokat a kereteket rögzíti (a csoportos küldésű- és a szórásos kereteket is beleértve), amelyeket a helyi számítógép küld vagy fogad. A Hálózatfigyelő a hálózati szegmenssel kapcsolatban olyan adatokat is megjelenít, mint amilyenek a csoportos küldésű és szórásos keretekre, a hálózat kihasználtságára, a másodpercenként fogadott bájtok számára és a másodpercenként fogadott keretek számára vonatkozó általános statisztikai adatok.

Ezenkívül megvédheti a hálózatot a Hálózatfigyelő példányainak illetéktelen használatától a Hálózatfigyelő azon szolgáltatása segítségével, amely képes felderíteni a Hálózatfigyelőnek a hálózat helyi szegmensén futó más példányait.

A Hálózatfigyelő más példányainak felderítése

A hálózat illetéktelen figyelésének megakadályozása érdekében, a Hálózatfigyelő képes a Hálózatfigyelőnek a hálózat helyi szegmensén futó más példányainak felderítésére. A Hálózatfigyelő azt is felderíti, hogy a Hálózatfigyelő illesztőprogramját hány példányban használja távolról a Systems Management Server Hálózatfigyelője vagy a Rendszerfigyelő a hálózattal kapcsolatos adatok rögzítésére.

Ha a hálózatfigyelő más Hálózatfigyelő-példányokat észlel a hálózaton, a következő adatokat jeleníti meg róluk:

  • A számítógép neve
  • A számítógépre bejelentkezett felhasználó neve
  • A távoli számítógépen futó Hálózatfigyelő állapota (fut, rögzít vagy adatot továbbít)
  • A távoli számítógép csatolójának címe
  • A távoli számítógépen lévő Hálózatfigyelő verziószáma

Egyes esetekben a hálózat architektúrája megakadályozhatja, hogy a Hálózatfigyelő észleljen más példányokat. Ha például a saját Hálózatfigyelője és a másik között olyan útválasztó van, amely nem továbbítja a csoportos küldést, akkor ez a példány nem tudja észlelni a másikat.


A Hálózatfigyelő részét képező protokollelemzők

A protokollelemző olyan dinamikus csatolású függvénytár (.dll), amely a keretek küldésére szolgáló protokollokat azonosítja a hálózaton. A protokollokra vonatkozó adatok a rögzített kereteket megjelenítő Keretmegjelenítő ablakban tekinthetők meg. Minden, a Hálózatfigyelő által támogatott protokollhoz tartozik egy elemző.

Ha többet szeretne tudni a Hálózatfigyelő használatáról (például a rögzítésindítókra, rögzítési pufferekre, protokollelemzőkre, címtárakra, rögzítési szűrőkre, megjelenítési szűrőkre valamint a rögzített adatok értelmezésére vonatkozóan), kattintson a Súgó menüre a Hálózatfigyelő ablakban.

A következő felsorolásban a Hálózatfigyelő részét képező protokollok szerepelnek.

Protokoll | Leírás
AARP | AppleTalk Address Resolution protokoll (Atalk.dll)
ADSP | AppleTalk Data Stream protokoll (Atalk.dll)
AFP | AppleTalk File protokoll (Atalk.dll)
AH | Hitelesítő IP-fejléc (Tcpip.dll)
ARP_RARP | Internet Address Resolution protokoll/Reverse Address Resolution protokoll (Tcpip.dll)
ASP | AppleTalk Session protokoll (ATALK.dll)
ATMARP | ATM Address Resolution protokoll (Atmarp.dll)
ATP | AppleTalk Transaction protokoll (Atalk.dll)
BONE | Bloodhound-Oriented Network Entity protokoll (Bone.dll)
BOOKMARK | Network Monitor BOOKMARK protokoll (Trail.dll)
BPDU | Bridge Protocol Data Unit (Llc.dll)
BROWSER | Microsoft Browser (Browser.dll)
CBCP | Callback Control protokoll (Ppp.dll)
CCP | Compression Control protokoll (Ppp.dll)
COMMENT | A Hálózatfigyelő COMMENT protokollja (Trail.dll)
DDP | AppleTalk Datagram Delivery protokoll (Atalk.dll)
DHCP | Dynamic Host Configuration protokoll (Tcpip.dll)
DNS | Domain Name System (Tcpip.dll)
EAP | PPP Extensible Authentication protokoll (Ppp.dll)
ESP | IP Encapsulating Security Payload (Tcpip.dll)
ETHERNET | Ethernet 802.3 topológia (Mac.dll)
FDDI | FDDI-topológia (Mac.dll)
FINGER | Internet Finger protokoll (Tcpip.dll)
FRAME | Alapvető kerettulajdonságok (Frame.dll)
FTP | File Transfer protokoll (Tcpip.dll)
GENERIC | A Hálózatfigyelő GENERIC protokollja (Trail.dll)
GRE | Generic Routing Encapsulation protokoll (Ppp.dll)
ICMP | Internet Control Message protokoll (Tcpip.dll)
IGMP | Internet Group Management protokoll (Tcpip.dll)
IP | Internet protokoll (Tcpip.dll)
IPCP | Internet IP Control protokoll (Ppp.dll)
IPX | NetWare Internet Packet eXchange protokoll (Ipx.dll)
IPXCP | NetWare Internetwork Packet eXchange Control protokoll (Ppp.dll)
IPXWAN | NetWare Internetwork Packet eXchange protokoll nagy kiterjedésű hálózatokhoz (Ppp.dll)
ISAKMP | Internet Security Association and Key Management protokoll (Ppp.dll)
L2TP | Layer 2 Tunneling protokoll (L2tp.dll)
LAP | AppleTalk Link Access protokoll (Atalk.dll)
LCP | Link Control protokoll (Ppp.dll)
LLC | Logical Link Control 802.2 protokoll (LLC.dll)
LPR | BSD Printer (Ppp.dll)
MESSAGE | A Hálózatfigyelő MESSAGE protokollja (Trail.dll)
MSRPC | Microsoft Remote Procedure Call protokoll (Msrpc.dll)
NBFCP | NetBIOS Frames Control protokoll (Ppp.dll)
NBIPX | NetBIOS IPX felett (Ipx.dll)
NBP | AppleTalk Name Binding protokoll (Atalk.dll)
NBT | Internet NetBIOS TCP/IP felett (Tcpip.dll)
NCP | NetWare Core protokoll (Ncp.dll)
NDR | NetWare Diagnostic Redirector (Ipx.dll)
NETBIOS | Network Basic Input/Output System protokoll (Netbios.dll)
NETLOGON | Microsoft Netlogon Broadcasts (Netlogon.dll)
NFS | NFS fájlrendszer (Tcpip.dll)
NMPI | IPX feletti Microsoft Name Management protokoll (Ipx.dll)
NSP | NetWare Serialization protokoll (Ipx.dll)
NWDP | NetWare WatchDog protokoll (Ipx.dll)
ODBC | A Hálózatfigyelő ODBC protokollja (Trail.dll)
OSPF | Open Shortest Path First (Tcpip.dll)
PAP | AppleTalk Printer Access protokoll (Atalk.dll)
PPP | Point-to-Point protokoll (Ppp.dll)
PPPCHAP | PPP Challenge Handshake Authentication protokoll (Ppp.dll)
PPPML | Point-to-Point Multilink protokoll (Ppp.dll)
PPPPAP | PPP Password Authentication protokoll (Ppp.dll)
PPTP | Point-to-Point Tunneling protokoll (Ppp.dll)
R_LOGON | A kapcsolatra történő bejelentkezéshez generált távoli eljáráshívás (Logon.dll)
R_LSARPC | A kapcsolati Lsarpc számára generált távoli eljáráshívás (Lsarpc.dll)
R_WINSPOOL | A kapcsolati Winspool számára generált távoli eljáráshívás (Winspl.dll)
RADIUS | Remote Authentication Dial-In User Service protokoll (Ppp.dll)
RIP | Internet Routing Information protokoll (Tcpip.dll)
RIPX | NetWare Routing Information protokoll (Ipx.dll)
RPC | Remote Procedure Call (Tcpip.dll)
RPL | Remote Program Load (Llc.dll)
RSVP | RSVP protokoll (Rsvp.dll)
RTMP | AppleTalk Routing Table Maintenance protokoll (Atalk.dll)
SAP | NetWare Service Advertising protokoll (Ipx.dll)
SMB | Server Message Block protokoll (Smb.dll)
SMT | FDDI MAC Station Management (Mac.dll)
SNAP | Sub-Network Access protokoll (Llc.dll)
SNMP | Simple Network Management protokoll (Snmp.dll)
SPX | NetWare Sequenced Packet eXchange protokoll (Ipx.dll)
SSP | Security Support Provider protokoll (Msrpc.dll)
STATS | A Hálózatfigyelő Capture Statistics protokollja (Trail.dll)
TCP | Transmission Control protokoll (Tcpip.dll)
TMAC | Token Ring MAC layer (Mac.dll)
TOKENRING | Token Ring 802.5 topológia (Mac.dll)
TPCTL | Test Protocol Control Language (Tpctl.dll)
TRAIL | A Hálózatfigyelő TRAIL protokollja (Trail.dll)
UDP | User Datagram protokoll (Tcpip.dll)
VINES_FRAG | Banyan Vines Fragmentation protokoll (Vines.dll)
VINES_IP | Banyan Vines Internet protokoll (Vines.dll)
VINES_TL | Banyan Vines Transport Layer protokollok (Vines.dll)
XNS | Xerox Network System (Xns.dll)
ZIP | AppleTalk Zone Information protokoll (Atalk.dll)

Megjegyzés

  • A Hálózatfigyelő teljes (a Microsoft Systems Management Server rendszerben megtalálható) verziója további protokollelemzőket támogat. Ha a Hálózatfigyelő által nem támogatott protokollban küldött adatokat kíván rögzíteni, használja a Systems Management Server Hálózatfigyelőjét, vagy adja hozzá saját elemzőjét. Mielőtt a Hálózatfigyelőhöz protokollelemzőt adna, meg kell írnia az elemző DLL fájlt. A Systems Management Server 2.0-s verzójának Toolkit csomagja teljes körű leírással szolgál a Hálózatfigyelőhöz készíthető elemzők megírásáról és telepítéséről. A Microsoft Systems Management Server programról bővebb felvilágosítást a Microsoft webhely nyújt.


A Hálózatfigyelő használata

A rész tartalma:

  • A rögzítési szűrők használata
  • Megjelenítési szűrők használata
  • Rögzített adatok megjelenítése


A rögzítési szűrők használata

A rögzítési szűrő úgy működik, mint egy adatbázis-lekérdezés – segítségével megadhatók a figyelni kívánt hálózati adatok típusai. Ha például a számítógépeknek vagy a protokolloknak csak egy adott részhalmazát szeretné megtekinteni, hozzon létre egy címadatbázist, segítségével adjon címeket a szűrőhöz, majd mentse fájlba a szűrőt. A keretek szűrésével puffererőforrásokat és időt takaríthat meg. Szükség esetén később a rögzítésszűrőfájl ismételten betölthető, és a szűrő újra használható.

Rögzítési szűrő tervezése

A rögzítési szűrő tervezéséhez adja meg a döntési utasításokat a Rögzítési szűrő párbeszédpanelen. A párbeszédpanel megjeleníti a szűrő döntési fáját, ami a szűrő logikájának grafikus képe. Amikor a rögzítési specifikációba adatokat vesz fel vagy onnan adatokat zár ki, a specifikációkat a döntési fa tükrözi.

Szűrés protokoll szerint

Egy adott protokoll használatával küldött keretek rögzítéséhez határozza meg a protokollt a rögzítési szűrő SAP/ETYPE= sorában. Ha például csak IP-kereteket szeretne rögzíteni, tiltson le minden protokollt, majd engedélyezze az IP ETYPE 0x800 és az IP SAP 0x6 protokollokat. Alapértelmezés szerint a Hálózatfigyelő által támogatott minden protokoll engedélyezett.

Szűrés cím szerint

A hálózat meghatározott számítógépeitől érkező keretek rögzítéséhez adjon meg egy vagy több címpárt a rögzítési szűrőben. Egyidejűleg legfeljebb négy megadott címpár figyelésére van lehetőség.

Egy címpár a következő elemekből áll:

  • Annak a két számítógépnek a címe, amelyek között az adatforgalmat figyelni szeretné.
  • A figyelni kívánt forgalomirányt jelző nyilak.
  • Az INCLUDE vagy az EXCLUDE kulcsszó, mely jelzi, hogy a Hálózatfigyelő hogyan válaszol a szűrő specifikációinak megfelelő keretre.

Függetlenül attól, hogy az utasítások a Rögzítési szűrő párbeszédpanelen milyen sorrendben jelennek meg, a program először az EXCLUDE utasításokat értékeli. Ezért ha egy keret megfelel egy EXCLUDE és INCLUDE utasítást egyaránt tartalmazó rögzítési szűrő valamely EXCLUDE utasításában megadott feltételnek, a keretet a program nem veszi figyelembe. A Hálózatfigyelő nem vizsgálja meg a keretet abból a szempontból, hogy az az INCLUDE utasításokba foglalt feltételeknek is megfelel-e.

Ha például a Jani számítógépétől induló összes forgalmat szeretné rögzíteni a Janitól Annához áramló forgalom kivételével, a rögzítési szűrő címrészébe a következőt kell beírnia:

Címek
include   Jani <----> Any
exclude   Jani <----> Anna

Include sorok hiányában az alapértelmezett számítógépnév <----> Any beállítás érvényesül.

Szűrés adatminta szerint

A rögzítési szűrőben mintaegyezések megadásával lehetővé válik:

  • kizárólag egy adott ASCII vagy hexadecimális adatmintát tartalmazó keretek rögzítése;
  • annak megadása, hogy a mintának a keret kezdetétől hány bájtra (milyen távolságra) kell előfordulnia.

Ha mintaegyezés szerinti szűrést végez, meg kell adnia, hogy a minta hol fordul elő a keretben (hány bájtra a keret elejétől vagy végétől). Ha a hálózati médium a médiumhozzáférés-vezérlési protokollban változó méretű (például Ethernet vagy Token Ring), akkor válassza a topológiafejléc végétől kezdett számlálást.


Megjelenítési szűrők használata

A rögzítési szűrőkhöz hasonlóan a megjelenítési szűrők is úgy működnek, mint egy adatbázis-lekérdezés, azaz lehetővé teszik bizonyos típusú adatok szűrését. Mivel azonban a megjelenítési szűrők olyan adatokra alkalmazhatók, amelyek rögzítése előzőleg már megtörtént, a Hálózatfigyelő rögzítési pufferének tartalmára nincsenek hatással.

A megjelenítési szűrők alkalmazásával szűrheti a megjelenítendő kereteket. A kereteket az alábbiak szerint szűrheti:

  • A forrás és a cél címe
  • A küldéshez használt protokoll
  • A benne lévő tulajdonságok és értékek (A tulajdonság a protokollfejlécben lévő adatmezőt jelenti. A protokoll tulajdonságai a protokoll céljára utalnak.)


Rögzített adatok megjelenítése

A Hálózatfigyelő leegyszerűsíti az adatelemzést azáltal, hogy a rögzítés során gyűjtött nyers adatokat értelmezi és a Keretmegjelenítő ablakban megjeleníti.

A Keretmegjelenítőben úgy jelenítheti meg a rögzített információt, ha a rögzítés folyamán a Rögzítés menü Leállítás és megtekintés parancsára kattint. Más megoldásként megnyithat egy (.cap kiterjesztésű) rögzítésfájlt.

Megjegyzés

  • A Network General Sniffer programjával rögzített adatok megtekintéséhez nyissa meg a tömörítetlen Sniffer fájlt. Tömörített Sniffer fájl megtekintéséhez nyissa meg a fájlt a Sniffer programban, majd tömörítetlen formában mentse el. Más lehetőségként szerezzen be egy kicsomagoló eszközt a Network General cégtől.

A Keretmegjelenítő ablak az alábbi panelekből áll:

Panel | Tartalom
Összegzés | A rögzített keretekre vonatkozó általános információ a keretek rögzítésének sorrendjében.
Részletek | A keret tartalma, beleértve a küldésére használt protokollokat is.
Hexadecimális | A rögzített adatok hexadecimális és ASCII-formátumú megjelenítése.


Forrásmunkák

  • Hálózatfigyelő Súgó. További tudnivalókért a rögzítésindítókkal, a rögzítési pufferekkel, a protokollelemzőkkel, a címtárakkal, a rögzítési szűrőkkel, a megjelenítési szűrőkkel valamint a rögzített adatok értelmezésével kapcsolatban kattintson a Súgó menüre a Hálózatfigyelő ablakban.
  • Információk a Windows 2000 Server családról a Microsoft Windows webhelyen. (http://www.microsoft.com/)
  • A Microsoft Windows hardverkompatibilitási lista a Microsoft webhelyen. (http://www.microsoft.com/)
  • A Microsoft TechNet a magyar és az angol nyelvű Microsoft TechNet webhelyen. (http://www.microsoft.com/)
  • Microsoft TechNet CD-lemezek.
  • Microsoft támogatás a Microsoft webhelyen. (http://www.microsoft.com/)
  • Az első lépések a Windows 2000 Server használatakor.
  • Windows 2000 Server Resource Kit.
  • A Windows 2000 Server rendszerleíró adatbázisa.


Hibaelhárítás

Mi a probléma?

A Windows NT 4.0-s verzióról Windows 2000 rendszerre történő frissítés után a Hálózatfigyelő 1.2-es verziója nem működik, vagy hibaüzenet jelentkezik azzal, hogy a Nal.dll nem található.

Ok: A frissítés során a Hálózatfigyelő ügynök 1.2-es verziója a Hálózatfigyelő 2.0-s illesztőprogramjára cserélődött, amely nem kompatibilis a Hálózatfigyelő 1.2-es verziójával. A Hálózatfigyelő ügynök 1.2-es verzióját a Windows 2000 nem támogatja.

Megoldás: Használja a Hálózatfigyelő 2.0-s illesztőprogramját, vagy annak újabb verzióját.

Nincs elegendő lemezterület a rögzítési puffer létrehozásához.

Ok: A rögzítési puffer beállításakor a Hálózatfigyelő a puffer méretével megegyező lemezterületet foglal le. Ha nincs elegendő szabad lemezterület, hiba lép fel.

Megoldás: Biztosítsa, hogy az ideiglenes rögzítési könyvtárban elegendő szabad lemezterület legyen (a puffer méretén felül legalább 1 MB).

A rendszer megtagadja a hozzáférést a lezárási házirendekkel ellátott számítógépen lévő alapértelmezett rögzítési könyvtárhoz.

Ok: A lezárásos rendszer nem engedélyezi a rendszerkönyvtárban és annak alkönyvtáraiban lévő fájlok írását, a Hálózatfigyelő rögzítési fájljai azonban a rendszermappa (Winnt) egyik almappájában helyezkednek el.

Megoldás: Rögzítés végrehajtása után mentse a rögzítést olyan mappába, amelyhez írási és olvasási hozzáféréssel rendelkezik. Ez a mappa a rögzítési fájlok mentésére szolgáló új alapértelmezett hellyé válik.

A Microsoft terminálszolgáltatásain keresztül a Hálózatfigyelő nem működik.

Ok: A Hálózatfigyelő nem működik a terminálkiszolgáló ügyfélkapcsolatán keresztül.

Megoldás: Futtassa a Hálózatfigyelőt helyileg. Ha a Hálózatfigyelőt távoli számítógépen szeretné futtatni, telepítse a Hálózatfigyelő illesztőprogramját erre (az adatforgalom rögzítésére használandó) számítógépre, a helyi számítógépre pedig telepítse a Hálózatfigyelőnek a Microsoft Systems Management Server részét képező verzióját. Ezután használja távolról a Hálózatfigyelőt a rögzítési munkamenet létrehozására.

„Nem található NPP” hibaüzenet jelentkezik.

Ok: A Hálózatfigyelő és/vagy a Hálózatfigyelő illesztőprogramja nincs megfelelően telepítve.

Megoldás: Biztosítsa, hogy a Hálózatfigyelő összetevői megfelelően legyenek telepítve.

  1. Ha a Hálózatfigyelő illesztőprogramja nincs telepítve, telepítse azt A Hálózatfigyelő illesztőprogramjának telepítése című témakörben ismertetett módon.
  2. Ha a Hálózatfigyelő illesztőprogramja telepítve van, törölje, majd telepítse újra.
  3. Ha a Hálózatfigyelő illesztőprogramjának újratelepítése nem oldja meg a problémát, távolítsa el a Hálózatfigyelőt, majd A Hálózatfigyelő telepítése című témakörben ismertetett módon telepítse újra.


Több hálózati csatoló használata

Ha a számítógép több hálózati csatolóval rendelkezik, és a csatolókon átáramló kereteket egyidejűleg szeretné rögzíteni és megtekinteni, mindegyik csatolóhoz a Hálózatfigyelő egy külön példányát kell futtatnia. Ha a Hálózatfigyelőnek egyszerre csak egy példányát kívánja használni, akkor egyidejűleg csak egy hálózati csatolót választhat.

Ha ki szeretné választani azt a hálózati csatolót, amelyen kereteket kíván rögzíteni, a Rögzítés menüben kattintson a Hálózatok parancsra, majd válasszon egy hálózati csatolót.