Feladatütemező

A Feladatütemező segítségével parancsokat, programokat vagy parancsfájlokat futtathat megadott időben.

  • A Feladatütemező használata előtt tekintse át a Feladatlista: A Feladatütemező konfigurálása című részt.
  • Az Feladatütemező használatával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános háttér-információkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Feladatlista: A Feladatütemező konfigurálása

Az alábbi táblázat a Feladatütemezővel elvégzett leggyakoribb feladatokat sorolja föl. A teljes használati utasítást lásd az Útmutató című részben.

Lépés | Hivatkozás
Mielőtt ütemezhetné, adja hozzá a feladatot. | Új feladat ütemezése
Az ütemezett feladatok létrehozása után módosíthatja a programot, az ütemezést vagy a konkrét feladat részleteit. | Ütemezett feladat módosítása
Távolítsa el a feleslegessé vált ütemezett feladatokat. | Ütemezett feladat eltávolítása
Ha egy ütemezett feladat a számítógép használata közben elindul, állítsa le azt, és indítsa újra később. | Folyamatban lévő ütemezett feladat leállítása
Ütemezzen egy feladatot oly módon, hogy csak akkor fusson, amikor a számítógép egy bizonyos idő óta üresjáratban van. | Ütemezett feladat futtatása a számítógép üresjáratában
Tiltsa le az ütemezett feladat futását, amikor a számítógép elemről történő üzemmódra kapcsol. | Az ütemezett feladatokra vonatkozó energiagazdálkodási beállítások megadása


Gyakorlati tanácsok

A Windows 2000 rendszerben a Feladatütemező segítségével bármely alkalmazás futását ütemezheti. Az alábbiakban elolvashatja a Feladatütemező használatára vonatkozó gyakorlati tanácsokat.

  • Győződjön meg arról, hogy a Feladatütemező fut.
  • Győződjön meg arról, hogy a számítógép rendszerideje és dátuma pontos.
  • Használja a Részletek nézetet az Ütemezett feladatok mappában.

    • A Nézet menüben kattintson a Részletek parancsra.


Útmutató

  • Feladatok ütemezése
  • Ütemezett feladatok kezelése


Feladatok ütemezése

  • A Feladatütemező indítása
  • Új feladat ütemezése
  • Ütemezett feladat módosítása
  • Ütemezett feladat eltávolítása
  • Futó ütemezett feladat leállítása
  • Ütemezett feladat azonnali futtatása
  • Ütemezett feladat futtatása a számítógép üresjárata közben
  • Ütemezett feladatok megtekintése egy távoli számítógépről


A Feladatütemező elindítása

  • Nyissa meg a Feladatütemezőt.

Megjegyzés

Kapcsolódó témakörök


Új feladat ütemezése

  1. Nyissa meg a Feladatütemezőt.
  2. Kattintson duplán az Ütemezett feladat hozzáadása elemre.
  3. Kövesse az Ütemezett feladatok varázsló útmutatásait.

Megjegyzések

  • Ha speciális beállításokat akar megadni a feladatra, akkor a varázsló utolsó lapján jelölje be Az elem speciális beállításainak megnyitása, amikor a Befejezés gombra kattintok jelölőnégyzetet.
  • Erősítse meg, hogy a számítógép rendszerdátuma és rendszerideje pontos, mivel a Feladatütemező az ütemezett feladatokat ezen adatok alapján futtatja. Ezeknek az adatoknak az ellenőrzéséhez vagy módosításához a tálcán kattintson duplán az időjelzésre.

Kapcsolódó témakörök


Ütemezett feladat módosítása

  1. Nyissa meg a Feladatütemezőt.
  2. A jobb oldali egérgombbal kattintson a módosítani kívánt feladatra, majd a Tulajdonságok parancsra.
  3. Hajtson végre egy vagy több műveletet az alábbiak közül:
    • A futtatni kívánt program módosításához a Futtatás beviteli mezőbe írja be az új program elérési útvonalát.
    • A feladat ütemezésének módosításához kattintson az Ütemezés fülre.
    • A feladat beállításainak módosításához kattintson a Beállítások fülre.
    • A feladat biztonsági beállításainak a megadásához kattintson a Biztonság fülre.

Megjegyzések

  • Ha módosítja a felhasználói fiókot vagy a futtatni kívánt programot, akkor meg kell adnia a felhasználói fiók jelszavát.
  • Ha a feladatként megadott programhoz parancssori beállításokat is meg kell adni, akkor azokat az elérési útvonal után írja be a Futtatás beviteli mezőbe.
  • Ha a feladatként megadott program elérési útvonala szóközöket tartalmaz, akkor tegye idézőjelek ("") közé a feladat teljes elérési útvonalát. Például:

    • "C:\Program Files\Windows Media Player\Mplayer2.exe"

  • Erősítse meg, hogy a számítógép rendszerdátuma és rendszerideje pontos, mivel a Feladatütemező az ütemezett feladatokat ezen adatok alapján futtatja. Ezeknek az adatoknak az ellenőrzéséhez vagy módosításához a tálcán kattintson duplán az időjelzésre.


Ütemezett feladat eltávolítása

  1. Nyissa meg a Feladatütemezőt.
  2. A jobb oldali egérgombbal kattintson az eltávolítani kívánt feladatra, majd a Törlés parancsra.

Megjegyzések

  • Az ütemezett feladat eltávolítása csak az ütemezésből törli a feladatot. A feladatot futtató programfájlt nem törli a merevlemezről.
  • Az ütemezett feladat kijelölése után a DELETE billentyű megnyomásával is eltávolítható.


Futó ütemezett feladat leállítása

  1. Nyissa meg a Feladatütemezőt.
  2. A jobb oldali egérgombbal kattintson a leállítani kívánt feladatra, majd a Befejezés parancsra.

Megjegyzések

  • Az elindított ütemezett feladat a Befejezés paranccsal történő leállítása nem állítja le az ütemezett feladat által esetlegesen elindított többi feladatot.
  • A futó ütemezett feladat leállításakor előfordulhat, hogy a feladat kis késleltetéssel (akár 3 perc) áll le.
  • A leállított feladat újraindításához a jobb oldali egérgombbal kattintson a feladatra, majd kattintson a Futtatás parancsra.

Kapcsolódó témakörök


Feladat azonnali futtatása

Ütemezett feladat azonnali futtatása

  1. Nyissa meg a Feladatütemezőt.
  2. A jobb oldali egérgombbal kattintson az indítani kívánt feladatra, majd a Futtatás parancsra.

Megjegyzések

  • A feladat a Fájl menü Ütemezett feladat befejezése parancsára kattintással állítható le.
  • Ha egy feladatnak futnia kellene, de nem fut, akkor kattintson a Speciális menü Napló megtekintése parancsára a feladatnapló megvizsgálásához.

Kapcsolódó témakörök


Ütemezett feladat futtatása a számítógép üresjárata közben

  1. Nyissa meg a Feladatütemezőt.
  2. A jobb oldali egérgombbal kattintson a számítógép üresjárata alatt futtatni kívánt feladatra, majd kattintson a Tulajdonságok parancsra.
  3. A Beállítások lapon az Üresjárási idő rész alatt jelölje be a Csak akkor indítsa a feladatot, ha az üresjárati idő legalább jelölőnégyzetet.
  4. Adja meg azt az időtartamot (percben), ameddig a számítógépnek üresjáratban kell lennie a feladat futtatása előtt.

Megjegyzések

  • A számítógép akkor van üresjáratban, ha sem az egérrel sem a billentyűzettel nem végez műveletet.
  • Megadható az az időtartam (percben), amelyet a számítógép üresjáratnak próbál meg tekinteni az ütemezett feladat futtatásához.
  • A feladat leállítása, ha a számítógép kilép az üresjáratból jelölőnégyzet bejelölésével megadhatók azok a feladatok, amelyeket a számítógép használatakor le kell állítani.

Kapcsolódó témakörök


Távoli számítógépen levő ütemezett feladatok megtekintése

  1. Az Asztalon kattintson duplán a Hálózati helyek ikonra.
  2. Hajtsa végre az alábbi művelek egyikét:
    • Kattintson duplán a Teljes hálózat ikonra, ha egy távoli számítógépet akar megkeresni.
    • Kattintson duplán a Számítógépek a hálózatban ikonra, a munkacsoportban vagy hálózati tartományban levő számítógép megkereséséhez.
  3. Kattintson duplán arra a számítógépre, amely ütemezett feladatait akarja megtekinteni.
  4. Kattintson duplán az Ütemezett feladatok ikonra.

Megjegyzések

  • A Windows operációs rendszert futtató számítógép ütemezett feladatait kizárólag akkor jelenítheti meg, ha rendszergazdai engedéllyel rendelkezik a távoli számítógépen.
  • Windows 95 vagy újabb, Windows NT 4.0, vagy Windows 2000 operációs rendszert futtató távoli számítógép feladatai csak akkor módosíthatók, ha a távoli számítógépre telepítve van a rendszerleíró adatbázis távoli szerkesztését biztosító program, és létezik az x$ megosztás, ahol az x azt a merevlemezt jelöli, amely az Ütemezett feladatok mappát tárolja.


Ütemezett feladatok kezelése

  • A Feladatütemező leállítása
  • A Feladatütemező használatának felfüggesztése
  • Értesítés a kimaradt feladatokról
  • AT szolgáltatásfiók beállítása
  • Korábbi ütemezett feladathoz tartozó napló megtekintése
  • Az energiagazdálkodás beállítása ütemezett feladatok használata esetén


A Feladatütemező leállítása

  1. Nyissa meg a Feladatütemezőt.
  2. Kattintson a Speciális menü Feladatütemező használatának befejezése parancsára.

Megjegyzések

  • A Feladatütemező leállítása után az ütemezett feladatok nem indulnak el, és a Windows 2000 következő indításakor a Feladatütemező nem indul el automatikusan.

Kapcsolódó témakörök


A Feladatütemező használatának felfüggesztése

  1. Nyissa meg a Feladatütemezőt.

  2. Kattintson a Speciális menü Feladatütemező használatának felfüggesztése parancsára.

Megjegyzések

  • A Feladatütemező használatának felfüggesztése parancs akkor hasznos, ha nem akar ütemezett feladatokat futtatni szoftvertelepítés vagy más program (például játék) használata közben.
  • A Feladatütemező felfüggesztett állapotának időpontjára ütemezett feladatok a következő ütemezett időpontban futnak le.
  • Az összes feladat ütemezésének visszaállításához kattintson a Speciális menü Feladatütemező használatának folytatása parancsára.

Kapcsolódó témakörök


Értesítés a kimaradt feladatokról

  1. Nyissa meg a Feladatütemezőt.
  2. Kattintson a Speciális menü Figyelmeztessen kimaradt feladatoknál parancsára.

Megjegyzések

  • A szolgáltatás bekapcsolt állapotát a Figyelmeztessen kimaradt feladatoknál parancs mellett megjelenő pipa jelzi. A pipa törléséhez, és a szolgáltatás kikapcsolásához kattintson újból a Figyelmeztessen kimaradt feladatoknál jelölőnégyzetre.
  • Ezt a beállítást csak a Rendszergazdák csoport tagjai módosíthatják.

Kapcsolódó témakörök


Az AT szolgáltatásfiók beállítása

  1. Nyissa meg a Feladatütemezőt.
  2. Kattintson a Speciális menü AT szolgáltatásfiók parancsára.
  3. Kattintson az Ez a fiók elemre, majd adja meg az at paranccsal ütemezett feladatokat futtató felhasználói fiókot.
  4. A Jelszó és a Jelszó megerősítése beviteli mezőbe írja be a fiók érvényes jelszavát.

Megjegyzések

  • A megadott felhasználói fióknak kellő engedéllyel kell rendelkeznie az at paranccsal ütemezett bármilyen feladat futtatásához. Csak a rendszergazda által futtatható feladatok ütemezésekor például a megadott felhasználói fióknak rendszergazdai fióknak kell lennie.
  • Az Ez a fiók helyett a Rendszerfiók elemre is kattinthat. A feladatok at parancssal történő futtatásához a Rendszerfiók használatakor az ütemezett feladatokat a rendszer az alapértelmezett Helyi rendszerfiókban futtatja.
  • Ezeket a beállításokat csak a Rendszergazdák csoport tagjai adhatják meg.

Kapcsolódó témakörök


Korábbi ütemezett feladathoz tartozó napló megtekintése

  1. Nyissa meg a Feladatütemezőt.
  2. Kattintson a Speciális menü Napló megtekintése parancsára.

Megjegyzések

  • A Feladatütemező az alapértelmezett naplófájlt SchedLog.txt néven a \Winnt mappában tárolja.
  • Az alapértelmezett naplófájl mérete 32 kilobájt.
  • Ha a naplófájl eléri maximális mértét, akkor a rendszer az új adatokat automatikusan a naplófájl elejére kezdi rögzíteni, a naplófájl régi adatainak felülírásával.


Az energiagazdálkodás beállítása ütemezett feladatok használata esetén

  1. Nyissa meg a Feladatütemezőt.
  2. A jobb oldali egérgombbal kattintson arra a feladatra, amelyhez meg akarja adni az energiagazdálkodás beállításait, majd kattintson a Tulajdonságok parancsra.
  3. A Beállítások lapon az Enregiagazdálkodás részen hajtson végre egy vagy több műveletet az alábbiak közül:
    • Ha takarékoskodni akar az akkumulátor energiájával, akkor jelölje be az Akkumulátor használata esetén ne indítsa a feladatot jelölőnégyzetet.
    • Ha le akarja állítani a feladat végrehajtását, amikor a számítógép akkumulátorról kezd el működni, akkor jelölje be Az ütemezett feladat leállítása akkumulátoros táplálás kezdésekor jelölőnégyzetet.
    • Ha a számítógép akkumulátorról történő működtetésekor a feladat futtatásához fel akarja éleszteni a számítógépet, akkor jelölje be A számítógép felébresztése a feladat futtatásához jelölőnégyzetet.

Megjegyzések

  • Alaphelyzetben az energiagazdálkodás beállításai nem engedélyezik az ütemezett feladatok elindítását, ha a számítógép akkumulátorról működik. Akkumulátorról működő hordozható számítógép használata esetén az ütemezett feladatok futtatásához törölje az alapértelmezett jelölőnégyzetek jelölését.
  • Feszültségkimaradás, vagy az akkumulátor lemerülése esetén előfordulhat, hogy a folyamatban levő ütemezett feladat nem fut le.
  • A számítógép felébresztése a feladat futtatásához jelölőnégyzet csak olyan számítógépek esetén jelenik meg, amelyeknél használható ez a funkció.

Kapcsolódó témakörök


Fogalmak

Ez a fejezet általános háttér-információkat nyújt a Feladatütemezővel kapcsolatban.

  • Feladatütemező – áttekintés
  • A Feladatütemező ismertetése
  • A Feladatütemező használata


Feladatütemező – áttekintés

A Feladatütemezővel bármilyen – a felhasználó számára legalkalmasabb – időpontra beütemezhető bármilyen parancsfájl, program vagy dokumentum futtatása. A Feladatütemező a Windows 2000 minden indulásakor elindul, és a háttérben fut.

A Feladatütemezővel az alábbi műveletek végezhetők:

  • Ütemezhető egy feladat napi, heti, havi vagy bizonyos időnként (például a rendszer indulásakor) történő futtatása.
  • Módosítható egy feladat ütemezése.
  • Leállítható egy ütemezett feladat.
  • Testreszabható, hogyan fusson a feladat az ütemezett időpontban.


A Feladatütemező ismertetése

Ez a rész az alábbiakat ismerteti:
  • A Feladatütemező használata
  • A Feladatütemező és az At parancs
  • A Feladatütemező és a biztonság


A Feladatütemező használata

A Windows 2000 operációs rendszer a Feladatütemezőt automatikusan telepíti. A feladatütemező szolgáltatás eléréséhez kattintson duplán a Vezérlőpult ablakban az Ütemezett feladatok mappára.

Feladatokat úgy ütemezhet, hogy duplán kattint az Ütemezett feladat hozzáadása ikonra, és ezzel elindítja az Ütemezett feladatok varázslót. Feladatokat a parancsfájloknak, programoknak és dokumentumoknak a Windows Intézőből vagy az Asztalról az Ütemezett feladatok ablakba történő áthúzásával ütemezhet.

A Feladatütemező segítségével módosíthatja, törölheti, letilthatja vagy leállíthatja az ütemezett feladatokat, megtekintheti az eddig ütemezett feladatok naplóját, vagy megtekinthet távoli számítógépen ütemezett feladatokat.

A hálózati rendszergazdák létrehozhatnak karbantartást végrehajtó feladatfájlokat, és szükség szerint elhelyezhetik azokat a felhasználók számítógépén. Ütemezett feladatfájlok elektronikus levélben is küldhetők, a számítógépen lévő Ütemezett feladatok mappa pedig megosztható, ha a Hálózati helyek segítségével távolról szeretné elérni.

A Feladatütemező részletes használati utasítása az Útmutató című témakörben található.

A Feladatütemező hatékony használatával kapcsolatos tudnivalók a Gyakorlati tanácsok című témakörben találhatók.

Megjegyzés

  • Ütemezett feladatot létrehozhat a helyi számítógépen, és az egér segítségével a feladatobjektumot áthúzhatja egy távoli számítógépfiókra.


A Feladatütemező és az At parancs

A Windows korábbi verzióiban az at paranccsal lehetett egy parancs, parancsfájl vagy program futtatását egy adott nap adott időpontjára ütemezni. A Windows 2000 operációs rendszerben az at parancs az ún. Feladatütemező grafikus segédprogrammal működik együtt, amely további funkciókat biztosít.

A Feladatütemező új funkciói az Ütemezett feladatok mappán keresztül használhatók. Az at paranccsal egy feladat ütemezésekor a feladat az alábbihoz hasonló néven az Ütemezett feladatok mappába kerül:

At3478

Ezután megjeleníthető vagy módosítható a feladat. Módosítás után azonban szokásos ütemezett feladattá frissíti a rendszer. A feladat többé nem érhető el az at paranccsal, és az at fiók beállításai sem vonatkoznak rá többé. Külön be kell állítani egy felhasználói fiókot és jelszót a feladathoz.

A Windows korábbi verzióihoz hasonlóan az at paranccsal létrehozott összes feladat ügyanazzal a felhasználói fiókkal fut. Az Ütemezett feladatok mappából létrehozott feladatok azonban különböző felhasználói fiókokban futhatnak.

A Windows korábbi verzióiban az at paranccsal létrehozott feladatokhoz tartozó fiók megeggyezett az Ütemezés szolgáltatás fiókjával (“at” szolgáltatásként is ismert). Ez a fiók helyi rendszerfiókként vagy bármilyen felhasználói fiókként is beállítható.

A Windows 2000 operációs rendszerben magának az Ütemezés szolgáltatásnak helyi rendszerfiókban kell futnia. Az at paranccsal létrehozott feladatokhoz az Ütemezett feladatok mappa Speciális menüjében azonban helyi rendszerfióktól különböző fiók is beállítható.

Az Ütemezett feladatok mappa használható az at paranccsal létrehozott feladatok beállításának megjelenítéséhez vagy módosításához. Ha azonban egy feladatot az Ütemezett feladatok mappán keresztül módosít, akkor a rendszer szokásos ütemezett feladattá frissíti. A feladat többé nem érhető el az at paranccsal, és az at fiók beállításai sem vonatkoznak rá többé. Külön be kell állítani egy felhasználói fiókot és jelszót a feladathoz.

Az at paranccsal kapcsolatos további tudnivalókért lásd a Windows 2000 parancsokat bemutató súgójának At témakörét.


A Feladatütemező és a biztonság

Új feladat ütemezésekor beállíthatók a biztonsági engedélyek, így más felhasználók is futtathatják a feladatot.
  • A felhasználó hitelesítő adatainak beállítása
  • Engedélyek beállítása
  • A speciális biztonsági beállítások megadása
  • A jelszó újbóli beállítása


A felhasználó hitelesítő adatainak beállítása

A feladat létrehozásakor meg kell adni egy felhasználói nevet és jelszót, azaz be kell állítani a feladat futtatásához használni kívánt biztonsági környezetet. Ha több felhasználó használja ugyanazt a számítógépet, akkor mindegyik felhasználó saját feladatokat ütemezhet.

A felhasználói név és jelszó beállítása után másik felhasználó nem szakíthatja meg és nem törölheti a feladatot, ha nem rendelkezik a megfelelő engedélyekkel.

Megjegyzések

  • Egy feladat ütemezésének befejezése előtt az Ütemezett feladatok varázslóban meg kell adnia egy felhasználónevet.
  • Az Ütemezett feladatok varázsló utolsó lapján Az elem speciális beállításainak megnyitása, amikor a Befejezés gombra kattintok jelölőnégyzet bejelölésével módosítható a jelszó, vagy állítható be egy új jelszó. Jelszót nem kell megadni.


Engedélyek beállítása

A Windows 2000 operációs rendszerben a feladatok ütemezése és az ütemezett feladatok végrehajtása a Windows 2000 szokásos biztonsági engedélyeire épül. A feladatok az NTFS fájlrendszer biztonsági leíróinak segítségével állíthatók be. E leírók segítségével adható meg, hogy mely felhasználók vagy csoportok jeleníthetik meg, törölhetik, módosíthatják vagy használhatják a feladatot. Ezenkívül a feladat elemei (parancsfájlok, programok és dokumentumok) vezérelhetők, függetlenül az egyes elemekre beállított biztonsági leíróktól.

Az ütemezett feladat biztonsági beállításai a Biztonság lapon a felhasználók hozzáadásával vagy eltávolításával adhatók meg. A felhasználó hozzáadása után beállíthatók az ütemezett feladattal kapcsolatos felhasználói engedélyek.

Ütemezett feladat esetén az alábbi engedélyek állíthatók be.

Engedély | Hatása
Teljes hozzáférés | Megjelenítés, futtatás, módosítás, törlés és a tulajdonos módosítása
Módosítás | Megjelenítés, futtatás, módosítás és törlés
Olvasás és végrehajtás | Megjelenítés és futtatás
Olvasás | Megjelenítés
Írás | Megjelenítés, futtatás, módosítás és törlés

Megjegyzések

  • Az ütemezett feladathoz tartozó biztonsági beállítások megjelenítéséhez a jobb oldali egérgombbal kattintson a feladatra, kattintson a Tulajdonságok parancsra, majd kattintson a Biztonság fülre.
  • A speciális biztonsági beállítások megjelenítéséhez vagy módosításához a Biztonság lapon kattintson a Speciális gombra.


Speciális biztonsági beállítások megadása

A fájlokra és mappákra egyaránt beállíthatók speciális engedélyek. A speciális engedélyek beállításával engedélyezhetők vagy letilthatók az ütemezett feladat megtekintését vagy módosítását biztosító felhasználói engedélyek.

Megjegyzések

  • Az ütemezett feladathoz tartozó biztonsági beállítások megjelenítéséhez a jobb oldali egérgombbal kattintson a feladatra, kattintson a Tulajdonságok parancsra, majd a Biztonság fülre.
  • A speciális biztonsági beállítások megjelenítéséhez a Biztonság lapon kattintson a Speciális gombra, kattintson arra a felhasználóra, akinek az engedélyeit meg akarja jeleníteni vagy módosítani akarja, majd kattintson a Megjelenítés/szerkesztés gombra.


A jelszó újbóli beállítása

A Windows 2000 operációs rendszerben a jelszavakhoz lejárati dátum tartozik. Lejárati határidővel nem rendelkező ismétlődő feladat ütemezésekor a felhasználónak ügyelnie kell a jelszavának lejárati dátumára. A számítógép jelszavának lejáratával egyidőben újra beállíthatja az összes ütemezett feladathoz a jelszót. A rendszergazdai jelszó soha nem jár le, így elkerülhető az összes ütemezett feladat jelszavának újbóli beállítása, ha a rendszergazda hozza létre az ütemezett feladatokat.

Megjegyzés

  • Jelszó módosításához vagy új jelszó beállításához az Ütemezett feladatok varázsló utolsó lapján jelölje be Az elem speciális beállításainak megnyitása, amikor a Befejezés gombra kattintok jelölőnégyzetet.


Hibakeresés

Ha a várt időpontban egy ütemezet feladat nem indul el, akkor a jobb oldali egérgombbal kattintson a feladatra, majd a Tulajdonságok parancsra. A Feladat lapon ellenőrizze, hogy az Engedélyezve jelölőnégyzet be van-e jelölve. Az Ütemezés lapon ellenőrizze, hogy az ütemezés helyesen van-e beállítva.

Ha a feladathoz tartozó program nem megfelelően fut, akkor előfordulhat, hogy parancssori kapcsolókat kell megadni a program elérési útvonalához. Egy adott programmal, és annak parancssori kapcsolóival kapcsolatos további tudnivalókért próbálja meg az alábbiak egyikét:

  • Ha a programnak van súgója, tanulmányozza át.
  • A parancssorba írja be a következőt (ahol a program a futtatni kívánt feladathoz tartozó program neve):
    • program /?

Ellenőrizheti az Ütemezett feladatok ablak Állapot oszlopát. Az alábbi táblázat az állapottípusokat mutatja be.

Állapot | Leírás
Üres | A feladat nem fut, vagy már sikeresen lefutott.
Fut | A feladat jelenleg fut.
Kimaradt | A feladat futtatása egy vagy több ütemezett alkalommal kimaradt.
Nem indítható | A feladat futtatására irányuló legutóbbi kísérlet sikertelen volt.

Az ütemezett feladat állapotával kapcsolatos további tudnivalókért tanulmányozható a SchedLog.txt nevű naplófájl. A Feladatütemező a \Winnt mappában tárolja a naplófájlt. Ez a fájl tárolja az ütemezett feladatok tevékenységével kapcsolatos adatokat. A naplófájl segítségével megállapítható, miért állt le egy feladat végrehajtása, vagy ellenőrizhető egy feladat állapota.

Megjegyzések

  • Ha a számítógépen egyetlen ütemezett feladat sem futtatható, forduljon a rendszergazdához, és a segítségével győződjön meg arról, hogy a Feladatütemező szolgáltatás be van-e kapcsolva.
  • Ha a feladat futtatásához beállított felhasználói fiókhoz tartozó felhasználó nincs bejelentkezve a feladat futtatásának ütemezett időpontjában, akkor a feladat lefut, de nem látható.
  • Ütemezett feladat állapotának ellenőrzéséhez kattintson a Megjelenítés menü Részletek parancsára, majd gördítse az Állapot oszlopot.


Az Ütemezett feladatok mappa elérése távolról

A hálózati rendszergazdák karbantartási céllal létrehozhatnak feladatfájlokat, amelyeket szükség esetén a felhasználó számítógépén tárolhatnak. A feladatfájlok az elektronikus levelekben levő fájlokhoz hasonlóan küldhetők és fogadhatók, és a számítógép Ütemezett feladatok mappája megosztható, így a Hálózati helyek ablak segítségével távolról elérhető.

Megjegyzés

  • Létrehozható egy ütemezett feladat a helyi számítógépen, majd a .job kiterjesztésű fájl áthúzható egy távoli számítógép fiókjába.

Kapcsolódó témakörök