Microsoft ODBC for Oracle beállítások párbeszédpanel

Az ODBC for Oracle beállítások párbeszédpanelen az alábbi vezérlők találhatók:

Adatforrás neve | Az alkalmazások által az adatforrás megnevezésére használt név vagy azonosító. A felhasználók tetszőleges nevet adhatnak az adatforrásoknak. A mező alapértelmezés szerint üres, de a név megadása szükséges.
Leírás | Leíró minősítéseket tartalmaz; alapértelmezés szerint üres.
Felhasználónév | Itt látható az adatforráshoz tartozó felhasználónév.
Kiszolgáló | Az SQL*Net Easy Configuration segítségével létrehozott adatbázis-alias vagy egy csatlakozási karakterlánc. (A karakterláncok felépítéséről szóló tudnivalók az Attribútumok a kapcsolódási karakterláncokban című részben találhatók. A személyes és távoli adatbázisokhoz tartozó csatlakozási karakterláncokról olvassa el az Oracle súgófájlját.)
Konvertálás | A betölthető adatkonverter kiválasztásához kattintson a Kiválasztás gombra; a mezőben alapértelmezés szerint a Nincs konverter beállítás jelenik meg.
Beállítások A Pufferméret beállítás megadja a lehívott adatok fogadására használható puffer méretét bájtban. Az illesztőprogram úgy optimalizálja az adatlehívást, hogy az Oracle kiszolgálóról történő egyetlen lehívás alkalmával megteljen a megadott méretű puffer. Nagyobb értékekkel jobb teljesítmény érhető el nagy mennyiségű adat lehívásakor.

A REMARKS oszlopok visszaadása a katalógusfüggvényekkel beállítással megadhatja, hogy az illesztőprogram az SQLColumns eredménykészlethez csatolja a Remarks (Megjegyzések) oszlopot. Ha a végrehajtást gyorsítani szeretné, ne jelölje be ezt a jelölőnégyzetet.

Ha a SYNONYMS visszaadása az SQLColumns eljárással beállítás értéke Igaz (1), az SQLColumns() API hívás a Tables, a Views és a Synonyms oszlopok adatat adja vissza. Az illesztőprogram gyorsabban adja vissza az oszlopok adatait, ha ez az érték nincs beállítva (vagy értéke 0).
Testreszabás Az ODBC DayOfWeek szabvány betartatása beállítás használatával adott napformátumra állíthatja az eredménykészletet. Ha a jelölőnégyzet be van jelölve, az eredménykészlet az ODBC napformátuma szerint jelenik meg (vasárnap = 1; szombat = 7). Ha nincs bejelölve, az Oracle napformátuma lesz érvényben (hétfő = 1; vasárnap = 7).

Az SQLDescribeCol mindig visszaadja a pontosság értékét beállítás hatására az SQLDescribeCol hívás által visszaadott pontossági érték 130 lesz, ha az Oracle nem adja meg ezt az információt. Az Oracle egyes numerikus adattípusainak, például a számított numerikus oszlopoknak vagy a számként definiált, pontosság és skála nélkül megadott oszlopoknak nincs megadott pontossága. Ha törli a jelet a jelölőnégyzetből, az illesztőprogram a 0 értéket adja vissza ezekre az oszlopokra.

Megjegyzés Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapját, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) A Microsoft ODBC Driver for Oracle csak az SQL*Net 2.3-as vagy újabb verzióit támogatja. Ha többet szeretne megtudni az Oracle termékeiről, olvassa el az Oracle dokumentációját. További információk találhatók a súgófájl Szoftvertámogatási szintek és Terméktámogatás című részében.


.topic 4209
Az alkalmazások által az adatforrás megnevezéséhez használt név vagy azonosító. Alapértelmezés szerint a mező üres, de a név megadása szükséges.

.topic 4210
Leíró minősítések. A mező alapértelmezés szerint üres.

.topic 4201
Az alkalmazás által egyszerre lehívható adatmennyiség, bájtban megadva.

.topic 4202
Ide írhatja adatbázis-felhasználói nevét, mely adatbázis-felhasználói azonosítója lesz.

.topic 4203
Az eredménykészletet adott napformátumra - ODBC vagy Oracle - állítja.

.topic 4204
Itt adhatja meg, hogy az illesztőprogram az SQLColumns eredménykészlethez csatolja a Remarks (Megjegyzések) oszlopot. Ha a végrehajtást gyorsítani szeretné, ne jelölje be ezt a beállítást.

.topic 4205
Itt adhatja meg, hogy az illesztőprogram visszaadja a SYNONYMS oszlophoz tartozó információkat.

.topic 4206
Itt írhatja be az elérni kívánt Oracle kiszolgálómotorhoz tartozó csatlakozási karakterláncot.

.topic 4207
Itt választhat a betöltött adatfordítók közül.

.topic 4208
A jelölőnégyzetet bejelölésével az SQLDescribeCol hívás a pontosság értékeként 130-at ad vissza, ha az Oracle nem adja meg az információt. Más esetben az illesztőprogram az ilyen típusú oszlopoknál 0-t ad vissza.


Attribútumok a kapcsolódási karakterláncokban

Egyes alkalmazásokhoz párbeszédpanel helyett kapcsolódási karakterláncra lehet szükség, amely meghatározott attribútumok által megadja, hogy az illesztőprogram milyen módon csatlakozzon az adatforráshoz. Minden attribútum egy adott információt határoz meg, melyre az illesztőprogramnak a sikeres kapcsolódáshoz szüksége van. A kapcsolódási karakterlánc formátuma a következő:

"DSN=<adatforrásnév> ;[SERVER=<érték>] [;PWD=<érték>] [;UID=<érték>] [;<Attribútum>=<érték>]"

Megjegyzés A Microsoft ODBC Driver for Oracle támogatja az illesztőprogram első verziójából (1.x) származó CONNECTSTRING argumentumot is.

Ha nem adja meg az UID, PWD, SERVER (vagy CONNECTSTRING) és DRIVER attribútumokat, meg kell adnia az adatforrás nevét. A többi attribútum megadása nem kötelező. Ha egy attribútum nincs megadva, a program az ODBC adatforrás-felügyelő párbeszédpanel DSN lapján megadott attribútumértéket fogja használni.

A kapcsolódási karakterláncok attribútumainak leírását az alábbi táblázat tartalmazza:

Attribútum | Leírás | Alapértelmezett érték
DSN Az adatforrás neve, amely az ODBC adatforrás-felügyelő párbeszédpanel Felhasználói DSN vagy Rendszer-DSN lapján található. ""
PWD Az elérni kívánt Oracle kiszolgáló jelszava. Az illesztőprogram támogatja az Oracle 30 karakteres korlátozását, és az Oracle egyéb, jelszavakat érintő korlátozásai is vonatkoznak rá. ""
SERVER Az elérni kívánt Oracle kiszolgáló karakterlánca.

A karakterlánc lehet egy Oracle adatbázis-alias, a Tnsnames.ora fájl egy bejegyzése vagy egy olyan alias, amely az Oracle Names Servert használó kiszolgálóhoz lesz rendelve.

Adatbázis-aliasok az Oracle SQL*Net Fast Configuration (vagy a Net8 Easy Configuration for Oracle8 databases) segítségével állíthatók be. Ha többet szeretne megtudni az Oracle adatbázisokhoz történő csatlakozásról, olvassa el az Oracle dokumentációját.

 ""
UID Az Oracle kiszolgálón használt felhasználónév. Ez az attribútum nem mindig opcionális – egyes adatbázisok és táblák biztonsági okokból megkövetelhetik használatát.

Az Oracle operációsrendszer-hitelesítésének jelöléséhez használja az "UID=/;" karakterláncot.

""
BUFFERSIZE Az oszlopok lehívásához használt optimális pufferméret.

Az illesztőprogram úgy optimalizálja az adatlehívást, hogy az Oracle kiszolgálóról történő egyetlen lehívás alkalmával megteljen az adott méretű puffer. Nagyobb értékekkel jobb teljesítmény érhető el nagy mennyiségű adat lehívásakor.

 65535
SYNONYMCOLUMNS | Ha a beállítás értéke igaz (1), az SQLColumns API hívás a Tables, a Views és a Synonyms oszlopok adatait adja vissza. Más esetben az SQLColumns csak a Tables és a Views oszlopait adja vissza. Ha nagyobb teljesítményre törekszik, ne állítsa be ezt az értéket. | 1
REMARKS | Ha a beállítás értéke igaz (1), az illesztőprogram az SQLColumn eredménykészlethez csatolja a Remarks (Megjegyzések) oszlopot. Ha nagyobb teljesítményt kíván elérni, ne állítsa be ezt az értéket. | 0
StdDayOfWeek | Az ODBC szabványt teszi kötelezővé a DAYOFWEEK skalárfüggvényben. Ez az alapértelmezett érték; a felhasználók a helyi igényeknek megfelelően megváltoztathatják az Oracle által visszaadott adatok napformátumát. | 1

Megjegyzés Az attribútumok gyakran érzékenyek a kis- és nagybetűhasználatra.

Példak

A következő kapcsolódási karakterlánc kapcsolatot hoz létre az Alkalmazottak adatforrással a futrinka.utca nevű Oracle kiszolgáló és a jani nevű Oracle felhasználó használatával:

"DSN=Alkalmazottak;UID=jani;PWD=secret;SERVER=futrinka.utca"

A következő kapcsolódási karakterlánc kapcsolatot hoz létre a Fizetes adatforrással az Oracle operációsrendszer-hitelesítés és a maugli Oracle kiszolgálónév használatával:

"DSN=Fizetes;UID=/;PWD=;SERVER=maugli"


Microsoft ODBC for Oracle kapcsolódás párbeszédpanel

Az ODBC for Oracle kapcsolódás párbeszédpanelen az alábbi vezérlők találhatók:

Felhasználónév | Az Oracle adatbázishoz történő kapcsolódáshoz használt név.
Jelszó | Az Oracle adatbázishoz történő kapcsolódáshoz használt jelszó, az Oracle által a jelszavak használatára vonatkozóan kötelezővé tett korlátozások figyelembevételével.
Kiszolgáló | Itt adhatja meg az Oracle adatbázis-aliast, a Tnsnames.ora fájl egy bejegyzését vagy egy olyan aliast, amely az Oracle Names Servert használó kiszolgálóhoz lesz rendelve. Az Oracle adatbázisokhoz való kapcsolódásra vonatkozó további információk az msdn.microsoft.com címen találhatók. (Nyissa meg az MSDN Library Online lapját, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.) A Tnsnames.ora fájlra vonatkozó információk az Oracle dokumentációjában találhatók.


Terméktámogatás

Az illesztőprogramról részletes szakmai ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapját, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely az ODBC Drivers (ODBC illesztőprogramok) című fejezetet tartalmazza.)

Az Oracle Corporation az Oracle ügyfélszoftverek telepítését és használatát külön dokumentációval segíti.


Szoftvertámogatási szintek

A Microsoft ODBC Driver for Oracle az alábbi szoftvereket támogatja:

  • Microsoft Windows 95 és 98, Microsoft Windows NT 4.0 és Windows 2000

  • Oracle Call Interface 7 (OCI7)

  • SQL*Net 2.3 vagy újabb

  • ODBC 2.x vagy korábbi (Az ODBC legújabb verziója is telepíthető, de nem használható minden szolgáltatása.)


SQLColumns

Eredménykészletet hoz létre egy táblához, amely a megadott tábla vagy táblák oszlopainak felsorolását tartalmazza. Amikor oszlopokat kér egy PUBLIC szinonimához, be kell állítani a SYNONYMCOLUMNS kapcsolatattribútumot és szTableOwner argumentumként üres karakterláncot kell megadni. Az illesztőprogram üres karakterláncra állítja a TABLE NAME oszlopot, amikor visszaadja az oszlopokat a PUBLIC szinonimákhoz. Az eredménykészlet minden sor végén tartalmaz egy további oszlopot, amelynek neve ORDINAL POSITION. Ez az érték azt mutatja, hogy az oszlop a tábla hányadik oszlopa.