Message Queuing

A Message Queuing egy üzenetsor-kezelési infrastruktúra és fejlesztőeszköz, amely elosztott, lazán összekapcsolt üzenetküldő alkalmazások létrehozására használható a Windows 2000 operációs rendszerben. Ezek az alkalmazások képesek a heterogén hálózatokon keresztüli, valamint az esetleg kapcsolat nélküli számítógépekkel történő kommunikációra. A Message Queuing szolgáltatás garantált üzenetkézbesítést, hatékony útválasztást, biztonságot, tranzakciókezelést és prioritás alapú üzenetküldést biztosít.

A Message Queuing szolgáltatás különösen fontos a rendszergazdák (az infrastruktúra telepítése és kezelése) és a szoftverfejlesztők (üzenetkezelő alkalmazások létrehozása) számára. Ez a dokumentáció rendszergazdák számára készült, ezért csak a Message Queuing által biztosított infrastruktúrát tárgyalja, az alkalmazásfejlesztéssel nem foglalkozik. A Message Queuing alkalmazások fejlesztésével kapcsolatban tanulmányozza a Message Queuing Software Development Kit (SDK) csomagot, amely a Microsoft Platform SDK része.

  • A Message Queuing telepítése vagy frissítése előtt tanulmányozza a Feladatlistákat.
  • Ha a Windows 2000 rendszerbe átkerült tulajdonságokra kíváncsi, olvassa el a Megszokott feladatok végrehajtásának új módjai című részt.
  • Ha a Message Queuing használatával kapcsolatban van szüksége tanácsokra, nézze át a Gyakorlati tanácsok fejezetet.
  • Ha egy adott feladattal kapcsolatban van szüksége segítségre, tanulmányozza az Útmutatót.
  • A háttérinformációkkal kapcsolatos további tudnivalókért tanulmányozza a Fogalmak című részt.
  • A problémamegoldási tanácsokkal kapcsolatos tudnivalókért tanulmányozza a Hibaelhárítás című részt.


Feladatlisták

Ez a rész feladatlistákat tartalmaz a meglévő MSMQ 1.0 vezérlők frissítésével és a Message Queuing kiszolgáló-, illetve ügyfélszoftverek új számítógépre való telepítésével kapcsolatban.

  • Feladatlista: MSMQ 1.0 vezérlőkiszolgálók frissítése
  • Feladatlista: Message Queuing kiszolgálók telepítése
  • Feladatlista: Message Queuing ügyfelek telepítése


Feladatlista: MSMQ 1.0 vezérlőkiszolgálók frissítése

Akkor használja ezt a feladatlistát, ha MSMQ 1.0 vezérlőkiszolgálókat frissít (PEC, PSC vagy BSC). A Message Queuing frissítése varázslót kell használni a PEC és minden PSC Message Queuing kiszolgálóra történő frissítéséhez.

Az MSMQ 1.0 vezérlőkiszolgálókat a következő sorrendben kell frissíteni:

  1. Az elsődleges vállalati vezérlőt (PEC).
  2. Ezután az összes hely másodlagos helyvezérlőjét (BSC).
  3. Ezután az összes hely elsődleges helyvezérlőjét (PSC).

Az MSMQ 1.0 kiszolgálófürtön történő frissítésével kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ 1.0 frissítése kiszolgálófürtön című részt.

Lépés | Hivatkozás
Az operációs rendszer frissítése előtt exportálja a kulcsbizonyítványt a Windows NT 4.0 rendszerből, és készítsen róla biztonsági másolatot, ha a számítógép MSMQ 1.0 ügyfeleket fog támogatni. | Kulcsbizonyítványok exportálása Windows NT 4.0 rendszerből
Miután a Windows 2000 Server telepítése befejeződött, nézze át a fontos frissítési fogalmakat és követelményeket. Az MSMQ 1.0 vezérlőkiszolgálókat a megadott sorrendben kell frissíteni. | A Message Queuing frissítésének követelményei és szempontjai
Jelentkezzen be vállalati rendszergazdai jogokkal. Ez a Message Queuing frissítése varázsló későbbi futtatásához szükséges. | A Message Queuing frissítésének követelményei és szempontjai
Léptesse elő a PEC számítógépet Windows 2000 tartományvezérlővé. | Kövesse a Kiszolgáló konfigurálása varázsló utasításait
Ha a számítógépet előléptette tartományvezérlővé, ellenőrizze, hogy a számítógép delegálásra meghatalmazott-e. | Számítógép delegálási meghatalmazásának beállítása
Konfigurálja a PEC számítógépet globáliskatalógus-kiszolgálóként. | Számítógép beállítása globáliskatalógus-kiszolgálóként; A Message Queuing frissítésének követelményei és szempontjai
Futtassa a Message Queuing frissítése varázslót. A rendszer kérdésére válassza ki az adatbázis átvizsgálásának módját, majd válassza ki a naplózás típusát. Szükség esetén nézze meg a létrejött naplófájlt. (Ez nem vonatkozik a BSC számítógépekre.) | Kövesse a Message Queuing frissítése varázsló utasításait
Ellenőrizze, hogy elindult-e a Message Queuing szolgáltatás. Frissített PEC számítógép esetén ellenőrizze, hogy a Message Queuing replikálás szolgáltatás is elindult-e. | A Message Queuing szolgáltatásainak indítása és leállítása
Importálja az előzőekben exportált kulcsbizonyítványt, ha a számítógép támogatni fogja az MSMQ 1.0 ügyfeleket. | Message Queuing kiszolgálói bizonyítványok importálása
Hozzon létre egy útválasztási kapcsolatot, ha a számítógépet helykapuként fogja használni az üzenetek más helyekre történő továbbításához. | Útválasztási kapcsolatok létrehozása
Küldjön egy tesztüzenetet. | Tesztüzenetek küldése

Megjegyzés

  • Ezt a feladatlistát ismételje meg minden MSMQ 1.0 vezérlőkiszolgáló frissítésekor. Nem kell egy helyen befejezni a számítógépek frissítését, mielőtt megkezdené egy másik helyen a frissítési eljárást. Több helyet is lehet egyidejűleg frissíteni, a megfelelő frissítési sorrend betartása mellett.


Feladatlista: Message Queuing kiszolgálók telepítése

Akkor használja ezt a feladatlistát, ha olyan számítógépekre telepít Message Queuing kiszolgálószoftvert, amelyeken az MSMQ 1.0 nincs telepítve. A Message Queuing alapértelmezés szerint nem kerül telepítésre a Windows 2000 telepítése során.

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat, és határozza meg a szükséges kiszolgálófunkciókat. | A Message Queuing összetevői
Tekintse át a telepítési követelményeket. | A Message Queuing telepítésének áttekintése
Jelentkezzen be megfelelő rendszergazdai jogosultságokkal. | Telepítési engedélyek
A vállalat első Message Queuing szolgáltatásának telepítése esetén, és minden Windows 2000 hely esetén, léptesse elő a számítógépet Windows 2000 tartományvezérlővé. | Kövesse a Kiszolgáló konfigurálása varázsló utasításait.
Minden Windows 2000 tartományvezérlőn ellenőrizze, hogy a számítógép delegálásra meghatalmazott-e. | Számítógép delegálási meghatalmazásának beállítása
Minden Windows 2000 hely egy gépén konfigurálja a tartományvezérlőt globáliskatalógus-kiszolgálóként. | Számítógép beállítása globáliskatalógus-kiszolgálóként
Ha egy helyen nem ez az első telepített példány, ellenőrizze, hogy a Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló megtalálható-e azon a számítógépen, ahova telepíteni szeretne. | A Message Queuing telepítésének áttekintése
Futtassa a Message Queuing telepítőjét, és válassza ki a szükséges szolgáltatásokat. | Message Queuing kiszolgálók telepítése
A vállalat első Message Queuing szolgáltatásának telepítése esetén a telepítő felszólítására gyengítse az engedélyeket, ha a számítógép támogatni fog Windows NT 4.0 vagy helyi felhasználókat. | A gyengített biztonsággal kapcsolatos megfontolások
Ellenőrizze, hogy elindult-e a Message Queuing szolgáltatás. | A Message Queuing szolgáltatásainak indítása és leállítása
Hozzon létre egy kiszolgálói bizonyítványt, ha a számítógép MSMQ 1.0 ügyfeleket fog támogatni. | Message Queuing kiszolgálói bizonyítványok létrehozása
Hozzon létre egy útválasztási kapcsolatot, ha a számítógépet helykapuként fogja használni az üzenetek más helyekre történő továbbításához. | Útválasztási kapcsolatok létrehozása
Küldjön egy tesztüzenetet. | Tesztüzenetek küldése


Feladatlista: Message Queuing ügyfelek telepítése

Akkor használja ezt a feladatlistát, ha olyan számítógépekre telepít Message Queuing ügyfélszoftvert, amelyeken az MSMQ 1.0 nincs telepítve. A Message Queuing alapértelmezés szerint nem kerül telepítésre a Windows 2000 telepítése során.

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat, és határozza meg a szükséges ügyfélfunkciókat. | A Message Queuing összetevői
Tekintse át a telepítési követelményeket. | A Message Queuing telepítésének áttekintése
Jelentkezzen be helyi rendszergazdai jogokkal. | Telepítési engedélyek
Ellenőrizze, hogy létezik-e Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló azon a helyen, ahova telepíteni szeretne. | A Message Queuing telepítésének áttekintése
Futtassa a Message Queuing telepítőjét, és válassza ki az ügyfél típusát. | Független ügyfelek telepítése; Függő ügyfelek telepítése
Ellenőrizze, hogy elindult-e a Message Queuing szolgáltatás. | A Message Queuing szolgáltatásainak indítása és leállítása
Ha a számítógépnek Windows NT 4.0 rendszeren futó MSMQ 1.0 vezérlőkiszolgálókat kell hitelesítenie, engedélyezze ezt a szolgáltatást. (Ez nem vonatkozik a függő ügyfelekre.) | MSMQ 1.0 vezérlőkiszolgálók hitelesítése
Küldjön egy tesztüzenetet. | Tesztüzenetek küldése


Ismerős feladatok elvégzésének új lehetőségei

Az alábbi táblázatban a Message Queuing szolgáltatással kapcsolatban használt megszokott feladatok láthatók. Az ezen feladatok végrehajtásához használt felhasználói kezelőfelület különbözik Windows 2000 és Windows NT 4.0 rendszerben.

A Message Queuing jelenlegi és előző verziói közötti elnevezési és szerkezeti különbség listáját megtalálja a A Message Queuing frissítése - áttekintés című részben.

Teendő: | Windows NT 4.0 esetén ezt használja: | Windows 2000 esetén ezt használja:
A Message Queuing hozzáférés-vezérlésének vagy naplózásának megadása, illetve a tulajdonos módosítása | MSMQ Explorer | Nyissa meg az Active Directory - felhasználók és számítógépek ablakot. További tájékoztatásért tanulmányozza a Message Queuing biztonság - áttekintés című részt.
A Message Queuing szolgáltatásfiók módosítása | A Vezérlőpult Szolgáltatások segédprogramja | Nyissa meg a Számítógép-kezelés segédprogramot. További tájékoztatásért tanulmányozza A Message Queuing szolgáltatásfiók módosítása című részt.
Útválasztási kapcsolatok konfigurálása | MSMQ Explorer | Nyissa meg az Active Directory - helyek és szolgáltatások ablakot. További tájékoztatásért tanulmányozza a Message Queuing hálózatok felügyelete című részt.
Idegen helyek létrehozása vagy idegen számítógépek hozzáadása | MSMQ Explorer | Nyissa meg az Active Directory - helyek és szolgáltatások ablakot. További tájékoztatásért tanulmányozza a Message Queuing hálózatok felügyelete című részt.
Message Queuing számítógépek és tulajdonságok konfigurálása; számítógépkvóták vagy tulajdonságok beállítása | MSMQ Explorer | Nyissa meg az Active Directory - felhasználók és számítógépek ablakot. További tájékoztatásért tanulmányozza a Message Queuing számítógépek felügyelete című részt.
Message Queuing számítógépek DNS- vagy IPX/SPX-tulajdonságainak beállítása | A Vezérlőpult Hálózat segédprogramja | Nyissa meg a Vezérlőpult Hálózati és telefonos kapcsolatok segédprogramját. További tájékoztatásért tanulmányozza A Message Queuing DNS-tulajdonságainak beállítása című részt.
Várólisták létrehozása, törlése vagy konfigurálása; várólistakvóták vagy tulajdonságok beállítása | MSMQ Explorer | Nyissa meg a Számítógép-kezelés vagy az Active Directory - felhasználók és számítógépek ablakot. További tájékoztatásért tanulmányozza a Message Queuing várólisták felügyelete című részt.
Üzenetek megtekintése vagy törlése; üzenetek tulajdonságainak megtekintése | MSMQ Explorer | Nyissa meg a Számítógép-kezelés vagy az Active Directory - felhasználók és számítógépek ablakot. További tájékoztatásért tanulmányozza a Message Queuing üzenetek felügyelete című részt.

Megjegyzés

  • Az Active Directory - felhasználók és számítógépek és az Active Directory - helyek és szolgáltatások beépülő modulok nem részei a Windows 2000 Professional rendszernek. Ezek a beépülő modulok a tartomány alapú Message Queuing hálózatok felügyeletéhez és az Active Directory információinak eléréséhez szükségesek. Ezek a beépülő modulok más, a kiszolgálók felügyeletére használt beépülő modulokkal együtt a Windows 2000 felügyeleti eszközök kiegészítéssel együtt telepíthetők, amely a Windows 2000 Server CD-lemezen található. Ily módon lehetővé válik a tartomány alapú felügyeleti feladatok végrehajtása és az Active Directory címtár elérése Windows 2000 Professional rendszert futtató Message Queuing számítógépekről. További tájékoztatásért tanulmányozza a Kiszolgálók kezelése távolról című fejezetet.


Gyakorlati tanácsok

Az alábbiakban a Message Queuing használatával kapcsolatos néhány gyakorlati tanács látható. Ajánlott követni ezeket az útmutatásokat, amikor csak lehetséges.

  • Teljesítse az összes követelményt a Message Queuing telepítése vagy frissítése előtt.

    Számos követelményt kell teljesíteni és megfelelő engedélyekkel kell rendelkezni a Message Queuing sikeres telepítése érdekében. További tájékoztatásért tanulmányozza A Message Queuing telepítése - áttekintés című részt.

    MSMQ 1.0-ról történő frissítés esetén további követelményeknek is eleget kell tenni és más tényezőket is figyelembe kell venni, hogy a vállalatnál a Message Queuing rendszerre történő frissítés sikeres legyen. Például az MSMQ 1.0 vezérlőkiszolgálókat adott sorrendben kell frissíteni. További tájékoztatásért tanulmányozza A Message Queuing frissítésének követelményei és szempontjai című részt.

  • Telepítsen Message Queuing kiszolgálókat minden Windows 2000 helyre.

    Az erdő minden Windows 2000 helyére legalább egy útválasztással rendelkező Message Queuing kiszolgálót kell telepíteni. Ez a következőket biztosítja:

    • Az üzenetek célba érnek a helyek között.
    • A független ügyfelek által az automatikus helyfelismerés során létrehozott szórásos kérelemre válasz fog érkezni.

    Ezenkívül a Windows NT 4.0 rendszeren futó MSMQ 1.0 ügyfelek támogatása és a teljesítmény növelése érdekében minden Windows 2000 helyen legalább egy Message Queuing kiszolgálót kell telepíteni egy olyan Windows 2000 tartományvezérlőre, amely globáliskatalógus-kiszolgálóként van beállítva.

    Egy Windows 2000 erdő első tartományvezérlője automatikusan katalógus-kiszolgálóként lesz konfigurálva.

  • Ne telepítsen útválasztással rendelkező Message Queuing kiszolgálót tartományvezérlőre.

    Ha olyan Message Queuing kiszolgálókra van szüksége, amelyek útválasztási szolgáltatásokat nyújtanak és az Active Directory címtárhoz történő hozzáférést is biztosítják, ezeket a kiszolgálókat telepítse külön számítógépekre. Például telepítsen egy útválasztással rendelkező Message Queuing kiszolgálót egy nem tartományvezérlő számítógépre, és telepítsen egy másik Message Queuing kiszolgálót egy Windows 2000 tartományvezérlőre, amely biztosítja az Active Directory címtárhoz történő hozzáférést.

  • Telepítsen Message Queuing kiszolgálókat több tartományvezérlőre.

    A jobb teljesítmény és méretezhetőség érdekében ajánlott minden Windows 2000 tartományban több Windows 2000 tartományvezérlőre telepíteni Message Queuing kiszolgálót.

  • Az összes hely összekapcsolásához használjon útválasztási kapcsolatokat.

    Minden helyet útválasztási kapcsolatokkal kell a többi hellyel összekapcsolni. Az útválasztási kapcsolatok helykapukból állnak, amelyek a helyek közötti üzenettovábbításra beállított Message Queuing kiszolgálók.

    További tájékoztatásért tanulmányozza a Helyek közötti üzenet-útválasztás című részt.

    Minden újonnan létrehozott Windows 2000 helyhez útválasztási kapcsolatot kell létrehozni.

  • Használjon egy helyen belül több bemenő és kimenő útválasztó kiszolgálót.

    Állítsa be a Message Queuing ügyfeleket, hogy azok az üzenetek továbbításához bemenő és kimenő útválasztó kiszolgálókat használjanak. A bemenő és a kimenő útválasztó kiszolgálók olyan Message Queuing kiszolgálók, amelyek feladata a helyen belüli üzenettovábbítás.

    Mivel a Message Queuing ügyfelek az üzenetek küldésében és fogadásában a bemenő és a kimenő útválasztó kiszolgálóktól függnek, ajánlott minden ügyfelet több kiszolgáló használatára beállítani. Egy ügyfélhez akár három Message Queuing kiszolgáló is hozzárendelhető, amelyek bemenő vagy kimenő útválasztó kiszolgálóként használhatók. További tájékoztatásért tanulmányozza a Helyen belüli üzenet-útválasztás című részt.

    • Ebben az értelemben a Message Queuing ügyfél egy független ügyfélre vagy egy olyan Message Queuing kiszolgálóra utal, amelyen az útválasztás nincs engedélyezve. Függő ügyfelek nem használhatnak bemenő és kimenő útválasztó kiszolgálókat.

  • Távoli ügyfelekhez használjon távelérés-kiszolgálót.

    A működtetési költségek csökkentése és a teljesítmény növelése érdekében ajánlott távelérés-kiszolgálót telepíteni minden helyen legalább egy Message Queuing kiszolgálóra. A Message Queuing ügyfelek úgy is beállíthatók, hogy azok a hálózathoz bármely helyen lévő távelérési kiszolgálón keresztül kapcsolódjanak, ez azonban nem nyújtja ugyanazokat az előnyöket. Továbbá az ilyen ügyfeleket nem lehet beállítani a NetBEUI protokoll táveléréshez történő használatára. További tájékoztatásért tanulmányozza a Távelérés használata ügyfelekkel című részt.

  • Ha lehetséges, ne telepítsen függő ügyfeleket.

    A függő ügyfelek használatakor fennálló számos korlátozás miatt ajánlott függő ügyfelek helyett független ügyfeleket használni, amikor csak lehetséges. További tájékoztatásért tanulmányozza A függő ügyfelekkel kapcsolatos megfontolások című részt.

    Ha függő ügyfeleket kell használnia, a támogató Message Queuing kiszolgáló és a függő ügyfél legyen ugyanazon a helyen. Ezzel növelhető a függő ügyfél üzenetkezelési teljesítménye.

  • Rendszeresen készítsen biztonsági másolatot az üzenet- és a naplófájlokról.

    A nagyobb megbízhatóság érdekében használja a Message Queuing szoftverhez tartozó biztonságimásolat-készítő és helyreállító segédprogramot az üzenetfájlokat és az egyéb programfájlokat tartalmazó mappák biztonsági mentéséhez. Ez lehetővé teszi az üzenetfájlok helyreállítását a merevlemez meghibásodása esetén. További tájékoztatásért tanulmányozza az Üzenetek biztonsági mentése és visszaállítása című részt.

  • Ne állítsa le a Message Queuing szolgáltatást.

    Csak akkor állítsa le egy számítógépen a Message Queuing szolgáltatást, ha az feltétlenül szükséges. Ellenkező esetben az összes sürgős üzenet elveszik. Továbbá vegyes módú tartománykörnyezetben a frissített PEC számítógépek számára szükséges, hogy ez a szolgáltatás és a Message Queuing replikációs szolgáltatás folyamatosan fusson az információk MSMQ 1.0 vezérlőkiszolgálókra történő replikálása érdekében.

  • Az üzenetfájlokat több, nagy teljesítményű lemezen tárolja.

    A jobb üzenetkezelési teljesítmény érdekében ajánlott az üzenetkezeléshez szükséges különféle fájlokat több fizikai lemezen tárolni. A Message Queuing kiszolgálókkal elérhető legjobb üzenetkezelési teljesítmény érdekében az üzenetküldő (*.mq), az üzenetnapló- és a tranzakciós naplófájlokat külön fizikai lemezeken ajánlott elhelyezni, amelyeket csak a Message Queuing használ. További tájékoztatásért tanulmányozza a Lemezek száma című részt.

    A lehető legjobb üzenetkezelési teljesítmény érdekében olyan nagy teljesítményű lemezeket alkalmazzon, amelyek hardveres csíkozást és “write-through” lemezvezérlőket használnak. További tájékoztatásért tanulmányozza a Lemezek típusa című részt.

    • Mivel a Windows 2000 NTFS fájlrendszere megbízhatóbb fájlvisszaállítást biztosít áramkimaradás vagy rendszerösszeomlás után, ajánlott ezt a fájlrendszert használni a Message Queuing kiszolgálókon.

  • Csak akkor használja a naplózást, ha szükség van rá.

    Naplózással gyorsan felélhető a szabad lemezterületet. Ha kell használnia a naplózást, az üzenetkezelési teljesítmény növelése érdekében gyakran ürítse a naplóvárólistákban és a kézbesítetlen üzenetek várólistákban lévő üzeneteket. A művelet végrehajtásával kapcsolatos további tájékoztatásért tanulmányozza a Várólista minden üzenetének törlése című részt.

  • Egy számítógépen ne tároljon 1,6 GB-nál több üzenetet.

    Bár elméletileg számítógépenként 2,0 GB üzenet tárolható, a Message Queuing használatakor fellépő tárolási többletigényt is figyelembe kell venni. Ezért nem ajánlott számítógépenként hozzávetőlegesen 1,6–1,8 GB-nál több üzenetet tárolni.

    Windows 2000 Advanced Server rendszert futtató számítógépeken ne tároljon 2,6–2,8 GB-nál több üzenetet.

  • Ne tároljon több sürgős üzenetet, mint amennyi elfér a fizikai memóriában.

    A Windows 2000 lapozófájl használatának csökkentése, és így az üzenetkezelési teljesítmény növelése érdekében ne tároljon több sürgős üzenetet, mint amennyi a fizikai memóriában elfér.

    További tájékoztatásért tanulmányozza a Memóriával kapcsolatos megfontolások című részt.

  • Lehetőleg nem módosítsa a Message Queuing szolgáltatásfiókját.

    A Message Queuing szolgáltatás alapértelmezés szerint a LocalSystem fiók alatt fut. Csak akkor módosítsa azt a fiókot, amely alatt a Message Queuing szolgáltatás fut, ha az feltétlenül szükséges. További tájékoztatásért tanulmányozza A Message Queuing szolgáltatásfiókkal kapcsolatos megfontolások című részt.

  • Rendszeresen újítsa meg a titkosítási kulcsokat.

    A nagyobb biztonság érdekében a számítógépek titkosítási kulcsait rendszeresen, például évente újítsa meg. Abban az esetben is ajánlott megújítani a titkosítási kulcsokat, ha a kulcsok illetéktelen kézbe kerülésének gyanúja áll fenn. A művelet végrehajtásával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing titkosítási kulcsainak megújítása című részt.


Útmutató

  • A Message Queuing szolgáltatás telepítése
  • Message Queuing hálózatok felügyelete
  • Message Queuing számítógépek felügyelete
  • A Message Queuing biztonságának felügyelete
  • Message Queuing várólisták felügyelete
  • Message Queuing üzenetek felügyelete
  • A Message Queuing szolgáltatás figyelése és tesztelése


A Message Queuing telepítése

  • Számítógép beállítása globáliskatalógus-kiszolgálóként
  • Számítógép delegálási meghatalmazásának beállítása
  • Az MSMQ 1.0 telepítési engedélyeinek beállítása
  • Message Queuing kiszolgálók telepítése
  • Független ügyfelek telepítése
  • Függő ügyfelek telepítése
  • Az MSMQ Exchange összekötő telepítése
  • Message Queuing erőforrások konfigurálása kiszolgálófürtök számára
  • A Message Queuing szolgáltatás eltávolítása
  • Az MSMQ-Exchange összekötő eltávolítása


Számítógép beállítása globáliskatalógus-kiszolgálóként

  2. A konzolfán kattintson a jobb oldali egérgombbal az NTDS-beállítások elemre.

    Helye:

    • Active Directory - helyek és szolgáltatások
    • Helyek
    • a megfelelő hely
    • Kiszolgálók
    • a megfelelő kiszolgáló
    • NTDS-beállítások
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lapon jelölje be a Globáliskatalógus-kiszolgáló jelölőnégyzetet.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Minden vegyes módban működő helyen kell lenni legalább egy olyan, tartományvezérlőn futó Message Queuing kiszolgálónak, amely globáliskatalógus-kiszolgálónak van beállítva. Ez a Windows 2000 helyen található, Windows NT 4.0 rendszert futtató MSMQ-ügyfelek támogatásához szükséges.

Kapcsolódó témakörök


Számítógép delegálási meghatalmazásának beállítása

  3. A konzolfán kattintson a jobb oldali egérgombbal a kívánt tartományvezérlőre.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • Tartományvezérlők
    • tartományvezérlő
  4. Kattintson a Tulajdonságok parancsra.
  5. Az Általános lapon jelölje be a Számítógép meghatalmazása delegáláshoz jelölőnégyzetet (ha szükséges).

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Ha ez a tulajdonság a tartományvezérlőn nincs engedélyezve, a Message Queuing szolgáltatás nem futtatható.

Kapcsolódó témakörök


Az MSMQ 1.0 telepítési engedélyeinek beállítása

  2. A konzolfán kattintson a jobb oldali egérgombbal a Számítógépek elemre (vagy a megfelelő szervezeti egységre).

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • szervezeti_egység (például számítógép vagy tartományvezérlő)
  3. A Vezérlés delegálása varázsló elindításához kattintson a Vezérlés delegálása elemre, majd kattintson a Tovább gombra.
  4. A Csoport vagy felhasználó kiválasztása lapon kattintson a Hozzáadás gombra.
  5. A Számítógépek vagy csoportok kiválasztása lapon hajtsa végre az alábbi műveletet:
    • Ha csak hitelesített felhasználók számára szeretné engedélyezni a Message Queuing telepítését, a Név mezőben kattintson a Hitelesített felhasználók elemre, kattintson a Hozzáadás, végül az OK gombra.
    • Ha mindenki számára szeretné engedélyezni a Message Queuing telepítését, a Név mezőben kattintson a Mindenki elemre, kattintson a Hozzáadás, végül az OK gombra.
  6. A Csoport vagy felhasználó kiválasztása lapon kattintson a Tovább gombra.
  7. Az Előre definiált delegálások lapon kattintson az Egyéni feladat elemre, majd kattintson a Tovább gombra.
  8. Az Active Directory objektumtípus lapon kattintson a Mappában lévő objektumok elemre, jelölje be a Számítógép-objektumok jelölőnégyzetet, majd kattintson a Tovább gombra.
  9. Az Engedélyek lap Szűrőbeállítások csoportjában törölje az Általános engedélyek megjelenítése jelölőnégyzet jelölését, majd jelölje be a Alobjektum-engedélyek létrehozásának/törlésének megjelenítése jelölőnégyzetet.
  10. Az Engedélyek delegálása csoportban jelölje be az MSMQ konfigurációs objektumok létrehozása és az MSMQ konfigurációs objektumok törlése jelölőnégyzeteket, majd kattintson a Tovább gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A Vezérlés delegálása varázsló segítségével adhat megfelelő engedélyeket azon felhasználók számára, akik MSMQ 1.0-t szeretnének telepíteni olyan számítógépen, amely egy Windows 2000 rendszert futtató tartomány része.
  • A Message Queuing eltávolításához az MSMQ konfigurációs objektumok törlése engedély szükséges.

Kapcsolódó témakörök


Message Queuing kiszolgálók telepítése

  1. Nyissa meg a Vezérlőpult Programok telepítése/törlése segédprogramját.
  2. Kattintson a Windows-összetevők hozzáadása/eltávolítása elemre. A Windows-összetevők varázslóban kattintson a Tovább gombra.
  3. Jelölje be a Message Queuing szolgáltatások jelölőnégyzetet, majd kattintson a Tovább gombra.
  4. A Message Queuing telepítő varázslóban kattintson a Message Queuing kiszolgáló választógombra.
  5. Az üzenetsor-kezelési szolgáltatások engedélyezéséhez jelölje be az Útválasztás engedélyezése jelölőnégyzetet.
  6. Kövesse a varázsló további utasításait.

Megjegyzések

  • A Programok telepítése/törlése segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/törlése ikonra.
  • Minden Windows 2000 rendszert futtató helyen először egy Windows 2000 tartományvezérlőre kell a Message Queuing kiszolgálót telepíteni, csak azután lehet a Message Queuing szolgáltatást a hely más számítógépeire telepíteni.
  • Message Queuing kiszolgálót nem lehet Windows 2000 Professional rendszert futtató számítógépekre telepíteni.
  • Message Queuing kiszolgálót telepíthet útválasztó szolgáltatás nélkül is egy munkacsoportos módban működő, nem tartományvezérlő számítógépre, ha a számítógép egy Windows 2000 munkacsoport tagja. Ebben az esetben az üzenetküldéshez közvetlen kapcsolat szükséges.

Kapcsolódó témakörök


Független ügyfelek telepítése

  1. Nyissa meg a Vezérlőpult Programok telepítése/törlése segédprogramját.
  2. Kattintson a Windows-összetevők hozzáadása/eltávolítása elemre. A Windows-összetevők varázslóban kattintson a Tovább gombra.
  3. Jelölje be a Message Queuing szolgáltatások jelölőnégyzetet, majd kattintson a Tovább gombra.
  4. A Message Queuing telepítő varázslóban kattintson a Független ügyfél választógombra.
  5. Amikor felszólítást kap, írja be a hely egy tartományvezérlőjén futó Message Queuing kiszolgáló DNS- vagy NetBIOS-nevét.
  6. Kövesse a varázsló további utasításait.
  7. Amikor a rendszer felajánlja a számítógép újraindítását, kattintson az Igen gombra a telepítés befejezéséhez.

Megjegyzések

  • A Programok telepítése/törlése segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/törlése ikonra.
  • Független ügyfelek csak Windows 2000 Professional rendszert futtató számítógépekre telepíthetők.
  • Független ügyfél telepítése előtt telepíteni kell egy Message Queuing kiszolgálót a hely egyik tartományvezérlőjére.
  • Ha a hely egy tartományvezérlőjén lévő Message Queuing kiszolgáló nem érhető el vagy nem létezik, a telepítés folytatódik, és a Message Queuing szolgáltatás munkacsoport módban lesz telepítve. Munkacsoport módú működés esetén közvetlen kapcsolat szükséges az üzenetküldéshez.
  • Független ügyfelet telepíthet munkacsoport módban is, ha a számítógép egy Windows 2000 munkacsoport tagja. Ebben az esetben az üzenetküldéshez közvetlen kapcsolat szükséges.

Kapcsolódó témakörök


Függő ügyfelek telepítése

  1. Nyissa meg a Vezérlőpult Programok telepítése/törlése segédprogramját.
  2. Kattintson a Windows-összetevők hozzáadása/eltávolítása elemre. A Windows-összetevők varázslóban kattintson a Tovább gombra.
  3. Jelölje be a Message Queuing szolgáltatások jelölőnégyzetet, majd kattintson a Tovább gombra.
  4. Kattintson a Függő ügyfél választógombra.
  5. Amikor felszólítást kap, írja be a hely egy Message Queuing kiszolgálójának DNS- vagy NetBIOS-nevét.
  6. Amikor a rendszer felajánlja a számítógép újraindítását, kattintson az Igen gombra a telepítés befejezéséhez.

Megjegyzések

  • A Programok telepítése/törlése segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/törlése ikonra.
  • Ha a hely valamelyik Message Queuing kiszolgálója nem érhető el, a telepítő megjelenít egy üzenetet arról, hogy a kiszolgáló nem érhető el. Ekkor megadhat egy másik Message Queuing kiszolgálót, vagy kattintson a Mégse gombra. A telepítés akkor is sikeresen befejeződik, ha a Mégse gombra kattint. Ezt a tulajdonságot kihasználva telepíthetők függő ügyfelek a támogató Message Queuing kiszolgáló telepítése előtt.

Kapcsolódó témakörök


Az MSMQ-Exchange összekötő telepítése

  1. A merevlemezen keresse meg a Winnt\System32 mappát, majd kattintson duplán az Mqexchng.exe fájlra az MSMQ-Exchange összekötő telepítőprogramjának elindításához.
  2. Kattintson a Folytatás, majd a Telepítés gombra.
  3. A Kiszolgáló választása párbeszédpanelen írja be annak a kiszolgálónak a nevét, amelyet az MSMQ-Exchange összekötő használni fog, majd kattintson a Folytatás gombra.
  4. A Hely választása párbeszédpanelen írja be a kiválasztott kiszolgáló helyének a nevét, majd kattintson a Folytatás gombra.
  5. A Telepítés párbeszédpanelen írja be a következő adatokat, majd kattintson a Folytatás gombra.
    • A Beérkező várólista mezőbe írja be annak a várólistának a címkéjét, amelyből az MSMQ-Exchange összekötő a beérkező üzeneteket fogja kiolvasni.

      Ha a várólista nem létezik, azt az MSMQ-Exchange összekötő indulásakor a rendszer létrehozza.

    • A Szolgáltatásfiók mezőbe írja be annak a felhasználói fióknak a nevét (tartomány\felhasználónév formátumban), amelyet az MSMQ-Exchange összekötő szolgáltatás használni fog.
    • A Szolgáltatás jelszava mezőbe írja be a Szolgáltatásfiók mezőben megadott felhasználói fiók tartományjelszavát.
    • A Szolgáltatás mappája mezőbe írja be annak a mappának az elérési útvonalát, amely az MSMQ-Exchange összekötő programfájljait tartalmazni fogja.

      Például írja be: C:\exchq. Ha a mappa nem létezik, a telepítő létrehozza.

Megjegyzések

  • Az MSMQ-Exchange összekötőt nem lehet Windows 2000 Professional rendszert futtató számítógépekre telepíteni.
  • Elegendő az MSMQ-Exchange összekötő egyetlen példányát telepíteni egy Microsoft Exchange szervezetben.
  • Az alábbiak csak Windows 2000 Advanced Server rendszert futtató számítógépekre vonatkoznak. Ha az MSMQ-Exchange összekötőt egy kiszolgálófürtre telepíti, ajánlott azt a Microsoft Exchange Servert futtató csomóponttól különböző csomópontra telepíteni.

Kapcsolódó témakörök


Message Queuing erőforrások konfigurálása kiszolgálófürtök számára

  1. Kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Fürtrendszergazda elemre.
  2. Kattintson a Csoportok mappára.
  3. A részletek ablaktáblán kattintson arra a fürtcsoportra, amelyhez hozzá szeretne rendelni Message Queuing erőforrásokat.
  4. A Fájl menüben mutasson az Új pontra, majd kattintson az Erőforrás parancsra.
  5. Az Új erőforrás varázslóban hozzon létre egy erőforrást a Message Queuing számára, majd írja be a megfelelő adatokat a Név és a Leírás mezőbe. Az Erőforrás típusa csoportban válassza ki a Message Queuing elemet, majd kattintson a Tovább gombra.
  6. A Lehetséges tulajdonosok lapon kattintson a Hozzáadás gombra, ha az Elérhető csomópontok listán szereplő egyes csomópontokat a Lehetséges tulajdonosok listához szeretné hozzáadni, majd kattintson a Tovább gombra.
  7. A Függőségek lap Elérhető erőforrások csoportjában kattintson a Hálózati név majd a Lemez elemre, kattintson a Hozzáadás gombra, végül a Befejezés gombra.
  8. Kattintson az Erőforrások mappára. A részletek ablaktáblán kattintson az imént létrehozott erőforrásra. Kattintson a Fájl menü On-line állapotba állítás parancsára.
  9. Az imént létrehozott erőforrásnak a Számítógép-kezelés beépülő modulból történő kezeléséhez hozzon létre még egy erőforrást a 2-5. lépések megismétlésével. Az Új erőforrás varázsló Erőforrás típusa lapján válassza az Általános alkalmazás elemet.
  10. Az Általános alkalmazás paraméterei lap Parancssor mezőjébe írja be a következőt:

    cmd.exe

    Jelölje be Az alkalmazás együttműködhet az Asztallal és a Hálózati név használata számítógépnév helyett jelölőnégyzeteket, majd kattintson a Tovább gombra.
  11. Ismételje meg a 7. lépést. Az Elérhető erőforrások csoportban kattintson a Hálózati név elemre, kattintson az 5. lépésben létrehozott erőforrásra, majd kattintson a Hozzáadás gombra. A művelet befejezése után kattintson a Befejezés gombra.
  12. Ismételje meg a 8. lépést.
  13. A megjelenő párbeszédpanelen írja be: compmgmt.msc.

Megjegyzések

  • Ez a művelet olyan számítógépen hajtható végre, amely egy kiszolgálófürt része, és amelyen Windows 2000 Advanced Server rendszer fut.
  • Az összes fürtcsoport-környezetben futó Message Queuing alkalmazás a Hálózati név erőforrástól és a Message Queuing számára létrehozott erőforrástól függ. A 9-13. lépések megismétlésével az ezen alkalmazásokhoz tartozó erőforrások megfelelően bekonfigurálhatók.
  • Miután létrehozott egy erőforrást a Message Queuing számára, azt ne nevezze át.

Kapcsolódó témakörök


A Message Queuing szolgáltatás eltávolítása

  1. Nyissa meg a Vezérlőpult Programok telepítése/törlése segédprogramját.
  2. Kattintson a Windows-összetevők hozzáadása/eltávolítása elemre.
  3. A Windows-összetevők varázslóban kattintson a Tovább gombra.
  4. Törölje a Message Queuing szolgáltatások jelölőnégyzetet jelölését, majd kattintson a Tovább gombra.
  5. Amikor egy kérdés jelenik meg, hogy véglegesen el szeretné-e távolítani az MSMQ által létrehozott tárolófájlokat, kattintson az Igen gombra.

Megjegyzés

  • A Programok telepítése/törlése segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/törlése ikonra.
  • A Message Queuing szolgáltatás többtartományos környezetből történő eltávolítása esetén várja meg, amíg az Active Directory replikálása megtörténik, mielőtt újratelepítené a Message Queuing szolgáltatást ugyanarra a számítógépre.

    • Kapcsolódó témakörök


Az MSMQ-Exchange összekötő eltávolítása

  1. A merevlemezen keresse meg a Winnt\System32 mappát, majd kattintson duplán az Mqexchng.exe fájlra az MSMQ-Exchange összekötő telepítőprogramjának elindításához.
  2. Kattintson az Eltávolítás gombra.
  3. Kattintson az eltávolítani kívánt összekötőre, majd a Folytatás gombra.


Message Queuing hálózatok felügyelete

  • Útválasztási kapcsolatok létrehozása
  • Útválasztási kapcsolat költségének módosítása
  • Útválasztási kapcsolat helykapuinak módosítása
  • Idegen helyek létrehozása
  • Idegen számítógépek hozzáadása egy helyhez


Útválasztási kapcsolatok létrehozása

  2. Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.
  4. Mutasson az Új pontra, majd kattintson az MSMQ útválasztási kapcsolat parancsra.
  5. Az 1. hely és a 2. hely mezőkben használja a lefelé mutató nyilakat annak a két helynek a kiválasztásához, amelyek között üzeneteket szeretne továbbítani.
  6. Az Útválasztási kapcsolat költsége mezőben szükség szerint módosítsa a költséget.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Minden útválasztási kapcsolathoz alapértelmezés szerint 1 költség van hozzárendelve. Csak akkor módosítsa az útválasztási kapcsolatok költségét, ha több útválasztási kapcsolat van beállítva, és az egyik útvonalat előnyben szeretné részesíteni. Ebben az esetben megadhat olyan költségeket, amelyek tükrözik a két kapcsolat közötti kommunikációs költségek különbözőségét.
  • A költség értéke 1 és 4 294 967 295 között lehet.
  • Alapértelmezés szerint csak a Vállalati rendszergazdák csoportba tartozó felhasználók hozhatnak létre vagy módosíthatnak útválasztási kapcsolatokat, ha a vállalaton belül több tartomány létezik. A Tartománygazdák csoport tagjainak az útválasztási kapcsolatok létrehozásához vagy módosításához Az összes gyermekobjektum létrehozása engedéllyel kell rendelkezniük az MsmqServices objektumhoz. Az útválasztási kapcsolatok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Útválasztási kapcsolat költségének módosítása

  2. Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.
  3. A konzolfán kattintson az MsmqServices elemre.

    Helye:

    • Active Directory - helyek és szolgáltatások
    • Szolgáltatások
    • MsmqServices
  4. A részletek ablaktáblán kattintson a jobb oldali egérgombbal a megfelelő útválasztási kapcsolatra, majd kattintson a Tulajdonságok parancsra.
  5. Az Általános lap Kapcsolat költsége mezőjében adja meg az új költséget.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Minden útválasztási kapcsolathoz alapértelmezés szerint 1 költség van hozzárendelve. Csak akkor módosítsa az útválasztási kapcsolatok költségét, ha több útválasztási kapcsolat van beállítva, és az egyik útvonalat előnyben szeretné részesíteni. Ebben az esetben megadhat olyan költségeket, amelyek tükrözik a két kapcsolat közötti kommunikációs költségek különbözőségét.
  • A költség értéke 1 és 4 294 967 295 között lehet. Két hely közötti nulla költség azt jelenti, hogy a helyek nincsenek összekapcsolva.
  • Alapértelmezés szerint csak a Vállalati rendszergazdák csoportba tartozó felhasználók hozhatnak létre vagy módosíthatnak útválasztási kapcsolatokat, ha a vállalaton belül több tartomány létezik. A Tartománygazdák csoport tagjainak az útválasztási kapcsolatok létrehozásához vagy módosításához Az összes gyermekobjektum létrehozása engedéllyel kell rendelkezniük az MsmqServices objektumhoz. Az útválasztási kapcsolatok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Útválasztási kapcsolat helykapuinak módosítása

  2. Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.
  3. A konzolfán kattintson az MsmqServices elemre.

    Helye:

    • Active Directory - helyek és szolgáltatások
    • Szolgáltatások
    • MsmqServices
  4. A részletek ablaktáblán kattintson a jobb oldali egérgombbal a megfelelő útválasztási kapcsolatra, majd kattintson a Tulajdonságok parancsra.
  5. A Helykapuk lapon hajtsa végre a következő műveletek egyikét:
    • Egy Message Queuing kiszolgálónak az útválasztási kapcsolathoz történő hozzáadásához a Helykiszolgálók listából válasszon ki egy kiszolgálót, majd kattintson a Hozzáadás gombra.
    • Egy Message Queuing kiszolgálónak az útválasztási kapcsolatból történő eltávolításához a Helykiszolgálók listából válasszon ki egy kiszolgálót, majd kattintson az Eltávolítás gombra.
  6. Szükség szerint ismételje meg a 4. lépést.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Alapértelmezés szerint csak a Vállalati rendszergazdák csoportba tartozó felhasználók hozhatnak létre vagy módosíthatnak útválasztási kapcsolatokat, ha a vállalaton belül több tartomány létezik. A Tartománygazdák csoport tagjainak az útválasztási kapcsolatok létrehozásához vagy módosításához Az összes gyermekobjektum létrehozása engedéllyel kell rendelkezniük az MsmqServices objektumhoz. Az útválasztási kapcsolatok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Idegen helyek létrehozása

  2. Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.
  4. Kattintson az Új idegen hely elemre.
  5. Írja be az új hely nevét.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Idegen számítógépek hozzáadása egy helyhez

  2. Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.
  4. Kattintson az Új idegen számítógép elemre.
  5. A Név mezőbe írja be az idegen számítógép nevét, a Hely mezőbe pedig írja be annak az idegen helynek a nevét, amelyhez a számítógépet hozzá szeretné adni.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Mielőtt egy idegen helyhez hozzáadhatna egy idegen számítógépet, létre kell hozni a helyet. Az idegen helyek létrehozásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Message Queuing számítógépek felügyelete

  • Csatlakozás tartományhoz egy munkacsoportból
  • Message Queuing kiszolgálók hozzáadása egy helylistához
  • Message Queuing kiszolgálók eltávolítása egy helylistából
  • Új hely meghatározása mobil ügyfelek számára
  • Bemenő és kimenő útválasztó kiszolgálók módosítása
  • Függő ügyfél támogató kiszolgálójának módosítása
  • Egy kiszolgálóhoz tartózó függő ügyfelek listájának megtekintése
  • A számítógépre érvényes üzenettárolási méret beállítása
  • Naplóméret beállítása
  • Üzenetek tárolása több lemezmeghajtón
  • A Message Queuing DNS-tulajdonságainak beállítása
  • A Message Queuing szolgáltatásainak indítása és leállítása
  • Message Queuing objektumok eltávolítása az Active Directoryból
  • Az MSMQ-Exchange összekötő konfigurálása


Csatlakozás tartományhoz egy munkacsoportból

  1. Nyissa meg a Vezérlőpult Rendszer segédprogramját.
  2. A Hálózati azonosítás lapon kattintson a Tulajdonságok gombra.
  3. A Tagság csoportban kattintson a Tartomány választókapcsolóra, írja be a tartomány nevét, majd kattintson az OK gombra.
  4. A megjelenő panelen írjon be egy érvényes felhasználónevet és jelszót.
  5. A módosítások érvénybe léptetéséhez indítsa újra a számítógépet.

Megjegyzések

  • A Rendszer segédprogram megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra.
  • Akkor használja ezt az eljárást, ha a Message Queuing szolgáltatást munkacsoportos környezetben futtatja, és egy tartományhoz szeretne csatlakozni (vagy újra csatlakozni). Ha egy tartományhoz csatlakozik, a számítógép hozzáférhet az Active Directory címtárban lévő nyilvános várólistákhoz.
  • Akkor is használható ez az eljárás, ha egy tartományból szeretne egy munkacsoporthoz csatlakozni. Ebben az esetben a Tagság csoportban kattintson a Munkacsoport választókapcsolóra, majd írja be a munkacsoport nevét. Ekkor lecsatlakozik a tartományról.


Message Queuing kiszolgálók hozzáadása egy helylistához

  4. Kattintson a Tulajdonságok parancsra.
  5. Kattintson a Helyek fülre, majd a Minden hely csoportban válassza ki azt a helyet, amelyhez a kiszolgálót hozzá szeretné adni, végül kattintson a Hozzáadás gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A Message Queuing kiszolgáló ténylegesen nem kerül hozzáadásra a helyhez, csak a belső és külső kiszolgálók számára fenntartott helylistához.

Kapcsolódó témakörök


Message Queuing kiszolgálók eltávolítása egy helylistából

  4. Kattintson a Tulajdonságok parancsra.
  5. Kattintson a Helyek fülre, majd a Számítógép_neve Helyek listából válassza ki azt a helyet, amelyikből el szeretné távolítani a kiszolgálót, végül kattintson az Eltávolítás gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A Message Queuing kiszolgáló ténylegesen nem kerül hozzáadásra a helyhez, csak a belső és külső kiszolgálók számára fenntartott helylistához.

Kapcsolódó témakörök


Új hely meghatározása mobil ügyfelek számára

  2. Kattintson a Mobil fülre, majd az Új hely mezőben használja a lefele nyilat annak a helynek a kiválasztásához, ahová a mobil ügyfél át fog kerülni.
  3. A megjelenő párbeszédpanelen kattintson A Windows újraindítása most gombra.

Megjegyzések

  • A Message Queuing megnyitásához mutasson a Start menü Beállítások pontjára, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Message Queuing ikonra.
  • Ez az eljárás nem vonatkozik a függő ügyfelekre, az útválasztással rendelkező Message Queuing kiszolgálókra és a tartományvezérlőre telepített Message Queuing kiszolgálókra.
  • Az új helyet azelőtt kel kiválasztani, mielőtt leválasztaná az ügyfelet a hálózatról. Így az üzenetek az új helyre lesznek továbbítva, miközben az ügyfél úton van.

Kapcsolódó témakörök


Bemenő és kimenő útválasztó kiszolgálók módosítása

  4. Kattintson a Tulajdonságok parancsra.
  5. Kattintson az Útválasztás fülre.
  6. A használt bemenő útválasztó kiszolgáló módosításához a Bemenő útválasztó kiszolgálók csoportban a lefele nyíl segítségével válasszon ki egy új Message Queuing kiszolgálót; válassza a nincs értéket, ha az adott Message Queuing kiszolgálót nem szeretné bemenő útválasztó kiszolgálóként használni.
  7. A használt kimenő útválasztó kiszolgáló módosításához a Kimenő útválasztó kiszolgálók csoportban a lefele nyíl segítségével válasszon ki egy új Message Queuing kiszolgálót; válassza a nincs értéket, ha az adott Message Queuing kiszolgálót nem szeretné kimenő útválasztó kiszolgálóként használni.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Ez az eljárás csak független ügyfelekre és a nem tartománykiszolgálóra telepített, útválasztással nem rendelkező Message Queuing kiszolgálókra vonatkozik, és csak ezeken hajtható végre.
  • Ha egy ügyfél másik helyre kerül, ezek az útválasztási beállítások le lesznek tiltva, amíg az ügyfél vissza nem kerül az eredeti helyére.
  • A bemenő és a kimenő útválasztó kiszolgálóként használt Message Queuing kiszolgálóknak ugyanazon a helyen kell lenniük, mint az ügyfélnek. Az ügyfél használhatja ugyanazt a Message Queuing kiszolgálót bemenő és kimenő útválasztó kiszolgálóként is.
  • Egy ügyfélhez ajánlott több bemenő és kimenő útválasztó kiszolgálót megadni. Ez jobb terheléselosztást és hibatűrést biztosít.

Kapcsolódó témakörök


Függő ügyfél támogató kiszolgálójának módosítása

  2. Az MSMQ-ügyfél lapon írja be a támogató Message Queuing kiszolgáló nevét.

Megjegyzések

  • Ez a feladat a függő ügyfélről hajtható végre.
  • Ha egy Windows NT 4.0 rendszeren futó régebbi verziójú függő ügyféllel rendelkezik, és a támogató kiszolgálóját egy Windows 2000 rendszeren futó Message Queuing kiszolgálóra szeretné módosítani, a függő ügyfélen a Windows NT Service Pack 4 szervizcsomagnak telepítve kell lennie.

Kapcsolódó témakörök


Egy kiszolgálóhoz tartózó függő ügyfelek listájának megtekintése

  4. Kattintson a Tulajdonságok parancsra.
  5. Kattintson a Függő ügyfelek fülre, majd kattintson a Frissítés gombra, hogy a lista a legfrissebb állapotot tükrözze.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Csak a jelenleg aktív állapotú függő ügyfelek (amelyek jelenleg üzeneteket küldenek) tekinthetők meg, ami nem feltétlenül egyezik meg a szervezetnél található összes függő ügyféllel.
  • Egy függő ügyfél támogató Message Queuing kiszolgálójának módosításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A számítógépre érvényes üzenettárolási méret beállítása

  4. Kattintson a Tulajdonságok parancsra.
  5. Az Általános lap Tárolási korlátok csoportjában jelölje be az Üzenetek maximális tárhelye (KB) jelölőnégyzetet, majd adja meg a kijelölt számítógép összes üzenet-várólistájában tárolható üzenetek maximális méretét (kilobájtban).

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Az üzenetek tárolási korlátjának elérése után a számítógép egyik várólistájába sem lehet több üzenetet küldeni mindaddig, amíg a várólistákban lévő üzenetek összesített mérete a megadott korlát alá nem esik.
  • A naplók maximális tárolási méretének (kvótájának) beállításával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Naplóméret beállítása

  4. Kattintson a Tulajdonságok parancsra.
  5. Az Általános lap Tárolási korlátok csoportban jelölje be a Napló maximális mérete (KB) jelölőnégyzetet, majd adja meg a kijelölt számítógép összes naplóvárólistájában tárolható naplóüzenetek maximális méretét (kilobájtban).

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A naplóüzenetek tárolási korlátjának elérése után a számítógép naplóvárólistájába mindaddig nem lehet több naplóüzenetet küldeni, amíg az összes várólistában lévő naplóüzenetek összesített mérete a megadott korlát alá nem esik.
  • A naplóvárólistában lévő naplóüzenetek tartalmazzák a forrás-naplóüzeneteket, a kézbesítetlen üzeneteket és tranzakció alapú kézbesítetlen üzeneteket. A naplóüzenetek nem tartalmazzák a cél-naplóvárólistákban lévő üzeneteket.
  • Az üzenetek maximális tárolási méretének (kvótájának) beállításával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Üzenetek tárolása több lemezmeghajtón

  2. A Tárolás lapon írjon be másik meghajtóbetűjelet az Üzenetfájlok mappája, az Üzenetnaplófájl mappája vagy a Tranzakciónapló mappája mezőbe.
  3. Amikor a rendszer felszólítja, hogy állítsa le a Message Queuing szolgáltatást, kattintson az Igen gombra.
  4. A megjelenő párbeszédpanelen kattintson A Windows újraindítása most gombra.

Megjegyzések

  • Alapértelmezés szerint a Message Queuing az összes üzenetfájlt, naplófájlt és tranzakciónapló-fájlt annak a meghajtónak a Winnt\System32\Msmq\Storage mappájában tárolja, amelyre a Message Queuing telepítve lett.
  • Ha további tájékoztatásra van szüksége azzal kapcsolatban, hogy a Rendszerfigyelő segítségével hogyan lehet meghatározni, hogy további lemezmeghajtók növelhetik-e az üzenetsor-kezelés teljesítményét, tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A Message Queuing DNS-tulajdonságainak beállítása

  1. Nyissa meg a Vezérlőpult Hálózati és telefonos kapcsolatok segédprogramját.
  2. A jobb oldali egérgombbal kattintson a Helyi kapcsolat elemre, majd kattintson a Tulajdonságok parancsra.
  3. A Helyi kapcsolat tulajdonságai párbeszédpanel összetevők listájában kattintson az Internet protokoll (TCP/IP) elemre.
  4. Kattintson a Tulajdonságok parancsra.
  5. Az Általános lapon kattintson a Speciális gombra.
  6. Kattintson a DNS fülre.
  7. A DNS-tartomány neve mezőbe írja be annak a tartománynak a nevét, amelyben a DNS-kiszolgáló megtalálható.

Megjegyzések

  • A Hálózati és telefonos kapcsolatok ablak megnyitásához kattintson a Start menüre, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Hálózati és telefonos kapcsolatok ikonra.
  • Ezt az eljárást csak akkor kell végrehajtani, ha a rendszer csak DNS-t használó környezetben üzemel (olyan környezetben, amely nem tartalmaz WINS-kiszolgálót). Ha a DNS nincs beállítva, a Message Queuing nem tudja a számítógépneveket helyesen hozzárendelni.


A Message Queuing szolgáltatásainak indítása és leállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a Szolgáltatások elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A részletek ablaktáblán hajtsa végre a következő műveleteket:
    • A Message Queuing szolgáltatás eléréséhez kattintson a jobb oldali egérgombbal a Message Queuing elemre.
    • A Message Queuing replikációs szolgáltatás eléréséhez kattintson a jobb oldali egérgombbal a Message Queuing replikációs szolgáltatás elemre.
    • Az MSMQ-Exchange összekötő szolgáltatás eléréséhez kattintson a jobb oldali egérgombbal az MSMQ-Exchange összekötő szolgáltatás elemre.
  4. A kijelölt szolgáltatás elindításához kattintson az Indítás parancsra.
  5. A kijelölt szolgáltatás leállításához kattintson a Leállítás parancsra.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • A szolgáltatások állapota az Állapot oszlopban látható.
Kapcsolódó témakörök


Message Queuing objektumok eltávolítása az Active Directory címtárból

  4. Kattintson a Törlés gombra. A megjelenő párbeszédpanelen kattintson az Igen gombra.
  6. A részletek ablaktáblán kattintson a jobb oldali egérgombbal az Msmq-beállítások elemre.

    Helye:

    • Active Directory - helyek és szolgáltatások
    • Helyek
    • hely
    • Kiszolgálók
    • kiszolgáló
    • MSMQ-beállítások
  7. Kattintson a Törlés gombra. A megjelenő párbeszédpanelen kattintson az Igen gombra.

Megjegyzések

  • A Windows 2000 Professional rendszert futtató számítógépekhez nem jár az Active Directory - felhasználók és számítógépek és az Active Directory - helyek és szolgáltatások beépülő modul; ez a feladat csak akkor hajtható végre, ha ezek a beépülő modulok telepítve vannak. A Windows 2000 felügyeleti eszközök segítségével telepítheti ezeket a beépülő modulokat egy Windows 2000 Professional rendszert futtató számítógépre. További tájékoztatásért tanulmányozza a Kiszolgálók kezelése távolról című fejezetet.
  • A Message Queuing objektumok Active Directory címtárból történő eltávolításának legjobb módja, ha eltávolítja a Message Queuing szoftvert a számítógépről. Csak akkor hajtsa végre a fenti eljárást, ha a Message Queuing szoftvert nem lehet eltávolítani a számítógépről, például hardverhiba után, vagy ha már nem rendelkezik fizikai hozzáféréssel a számítógéphez, illetve ha a Message Queuing telepítőjét nem lehet futtatni. A Message Queuing szoftver számítógépről történő eltávolításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ha eltávolít Message Queuing objektumokat az Active Directory címtárból, a rendszer az összes várólistát és üzenetet is eltávolítja. A Message Queuing szoftver azonban, a rendszerleíró értékekkel és a tárolófájlokkal együtt a számítógépen marad.
  • Ha egy bemenő vagy kimenő útválasztó kiszolgáló objektumait távolítja el, a kiszolgáló is eltávolításra kerül minden olyan ügyfél útválasztási listájából, amelyik ezt a kiszolgálót használja.
  • Ha egy helyátjáró objektumait távolítja el, a kiszolgáló is eltávolításra kerül a hozzá tartozó útválasztási kapcsolatból.

Kapcsolódó témakörök


Az MSMQ-Exchange összekötő konfigurálása

  1. Futtassa az Exchange Administrator programot, majd csatlakozzon az Exchange hely Exchange Server programot futtató számítógépéhez.
  2. A Konfiguráció elem mellett kattintson a megfelelő helyre.
  3. Kattintson a Kapcsolatok elemre.
  4. Kattintson duplán az MSMQ-összekötő (várólistacímke) elemre, ahol a várólistacímke a bejövő üzeneteket fogadó MSMQ-összekötő várólistájának a neve.

    Megjelenik az MSMQ-összekötő tulajdonságai párbeszédpanel.

  5. A Beállítások lapon hajtsa végre a kívánt műveleteket a következők közül:
    • A bejövő üzenetek feldolgozásának engedélyezéséhez jelölje be a Beérkezők engedélyezése jelölőnégyzetet.

      A feldolgozás letiltásához törölje a jelölőnégyzet jelölését.

    • A bejövő üzenetek feldolgozására használható szálak maximális számának megadásához írjon be egy értéket a Beérkező szálak mezőbe.
    • A kimenő üzenetek feldolgozásának engedélyezéséhez jelölje be a Kimenők engedélyezése jelölőnégyzetet.

      A feldolgozás letiltásához törölje a jelölőnégyzet jelölését.

    • A kimenő üzenetek feldolgozására használható szálak maximális számának megadásához írjon be egy értéket a Kimeneti szálak mezőbe.

Megjegyzések

  • Ha az üzenetfeldolgozás okozta terhelés az egyik irányban nagyobb, mint a másikban, vagy a számítógép nem elég gyorsan dolgozza fel az üzeneteket, növelje a szálak számát a szükséges mértékben.
  • Alapértelmezés szerint a beérkező és a kimenő üzenetek feldolgozása is engedélyezve van. Négy szál használható a bejövő üzenetek feldolgozására, és négy szál a kimenő üzenetek feldolgozására.
  • Az Exchange Administrator program használatával kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Exchange Server dokumentációját.

    • Kapcsolódó témakörök


A Message Queuing biztonságának felügyelete

  • Számítógép- és várólista-objektumok engedélyeinek beállítása
  • Útválasztási kapcsolat objektumok engedélyeinek beállítása
  • Az MSMQ-beállítások objektumok engedélyeinek beállítása
  • Message Queuing fájlok engedélyeinek beállítása
  • Számítógép- és várólista-objektumok tulajdonosának módosítása
  • A Message Queuing szolgáltatás fiókjának módosítása
  • Számítógép- és várólista-objektumokhoz történő hozzáférés naplózása
  • Útválasztási kapcsolat objektumokhoz történő hozzáférés naplózása
  • Kulcsbizonyítványok exportálása Windows NT 4.0 rendszerből
  • Message Queuing kiszolgálói bizonyítványok importálása
  • Message Queuing kiszolgálói bizonyítványok létrehozása
  • Message Queuing kiszolgálói bizonyítványok módosítása
  • MSMQ 1.0 vezérlőkiszolgálók hitelesítése
  • Message Queuing bizonyítványok regisztrálása
  • Message Queuing bizonyítványok eltávolítása
  • Message Queuing bizonyítványok megtekintése
  • Message Queuing bizonyítványok megújítása
  • Message Queuing titkosítási kulcsok megújítása
  • A biztonság gyengítése az ADSI Edit segítségével


Számítógép- és várólista-objektumok engedélyeinek beállítása

  3. A konzolfán kattintson a jobb oldali egérgombbal az msmq elemre vagy a megfelelő várólistára.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • szervezeti_egység (például számítógépek vagy tartományvezérlők)
    • számítógép
    • msmq
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  4. Ha a számítógépnek a Message Queuing szolgáltatással kapcsolatos engedélyeket szeretne adni, kattintson a jobb oldali egérgombbal az msmq elemre, majd kattintson a Tulajdonságok parancsra.

    Ha a számítógép egy várólistájához szeretne engedélyeket adni, kattintson duplán az msmq elemre, majd a megfelelő várólista mappájára, kattintson a jobb oldali egérgombbal a várólistára, végül kattintson a Tulajdonságok parancsra.

  5. A Biztonság lapon állítsa be az 5. lépésben megadott objektum engedélyeit.
    • Ha egy meglévő felhasználó vagy csoport számára szeretne objektumengedélyeket beállítani, a Név listában jelölje ki a megfelelő felhasználót vagy csoportot, majd az Engedélyezés oszlopban jelölje be a megfelelő engedélyek melletti jelölőnégyzeteket.
    • Egy felhasználó vagy csoport objektumengedélyeinek eltávolításához a Név listában jelölje ki a megfelelő felhasználót vagy csoportot, majd az Engedélyek csoport Megtagadás oszlopában jelölje be a megfelelő engedélyek melletti jelölőnégyzeteket.
    • Ha új felhasználó vagy csoport számára szeretné engedélyezni a hozzáférést, kattintson a Hozzáadás gombra. A Név listában válasszon ki egy felhasználót vagy csoportot, kattintson a Hozzáadás gombra, végül pedig az OK gombra. Ezután jelölje ki az imént létrehozott felhasználót vagy csoportot, majd jelölje be a megfelelő jelölőnégyzeteket.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Ez az eljárás bármely Message Queuing objektum engedélyeinek beállítására használható, amely az msmq objektum alatt található (beleértve az msmq objektumot is).

Kapcsolódó témakörök


Útválasztási kapcsolat objektumok engedélyeinek beállítása

  3. Kattintson a jobb oldali egérgombbal az MsmqServices elemre, majd kattintson a Tulajdonságok parancsra.
  4. A Biztonság lapon állítsa be a szükséges engedélyeket.
    • Ha egy meglévő felhasználó vagy csoport számára szeretne objektumengedélyeket beállítani, a Név listában jelölje ki a megfelelő felhasználót vagy csoportot, majd az Engedélyek csoport Engedélyezés oszlopában jelölje be Az összes gyermekobjektum létrehozása és Az összes gyermekobjektum törlése sorok melletti jelölőnégyzeteket.
    • Egy felhasználó vagy csoport objektumengedélyeinek eltávolításához a Név listában jelölje ki a megfelelő felhasználót vagy csoportot, majd az Engedélyek csoport Megtagadás oszlopában jelölje be Az összes gyermekobjektum létrehozása és Az összes gyermekobjektum törlése sorok melletti jelölőnégyzeteket.
    • Ha új felhasználó vagy csoport számára szeretné engedélyezni a hozzáférést, kattintson a Hozzáadás gombra. A Név listában válasszon ki egy felhasználót vagy csoportot, kattintson a Hozzáadás gombra, végül pedig az OK gombra. Ezután jelölje ki az imént létrehozott felhasználót vagy csoportot, majd jelölje be a megfelelő jelölőnégyzeteket.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Útválasztási kapcsolatok létrehozásához és törléséhez Az összes gyermekobjektum létrehozása és Az összes gyermekobjektum törlése engedéllyel kell rendelkezni.

Kapcsolódó témakörök


Az MSMQ-beállítások objektumok engedélyeinek beállítása

  1. Nyissa meg az Active Directory - helyek és szolgáltatások ablakot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy kiszolgálóobjektumra.

    Helye:

    • Active Directory - helyek és szolgáltatások
    • Helyek
    • hely_objektum
    • Kiszolgálók
    • kiszolgáló_objektum
  3. Kattintson a Tulajdonságok parancsra.
  4. A Biztonság lapon állítsa be a szükséges engedélyeket.
    • Ha egy meglévő felhasználó vagy csoport számára szeretne objektumengedélyeket beállítani, a Név listában jelölje ki a megfelelő felhasználót vagy csoportot, majd az Engedélyek csoport Engedélyezés oszlopában jelölje be Az összes gyermekobjektum létrehozása és Az összes gyermekobjektum törlése sorok melletti jelölőnégyzeteket.
    • Egy felhasználó vagy csoport objektumengedélyeinek eltávolításához a Név listában jelölje ki a megfelelő felhasználót vagy csoportot, majd az Engedélyek csoport Megtagadás oszlopában jelölje be Az összes gyermekobjektum létrehozása és Az összes gyermekobjektum törlése sorok melletti jelölőnégyzeteket.
    • Ha új felhasználó vagy csoport számára szeretné engedélyezni a hozzáférést, kattintson a Hozzáadás gombra. A Név listában válasszon ki egy felhasználót vagy csoportot, kattintson a Hozzáadás gombra, végül pedig az OK gombra. Ezután jelölje ki az imént létrehozott felhasználót vagy csoportot, majd jelölje be a megfelelő jelölőnégyzeteket.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Message Queuing fájlok engedélyeinek beállítása

  1. A jobb oldali egérgombbal kattintson az Asztalon található Sajátgép ikonra, majd kattintson az Intéző parancsra.
  2. Keresse meg és kattintson a jobb oldali egérgombbal arra a mappára, amely az üzenetfájlokat, a naplófájlokat és a tranzakciós naplófájlokat tartalmazza (általában a Winnt\System32\Msmq mappa alatt lévő Storage mappa), majd kattintson a Tulajdonságok parancsra.
  3. A Biztonság lap Név mezőjében kattintson a Rendszergazdák elemre.
  4. A Engedélyek csoport Engedélyezés oszlopában jelölje be a Teljes hozzáférés jelölőnégyzetet.
  5. A Név mezőben válassza ki azt a felhasználót vagy csoportot, amelyik számára nem szeretne hozzáférést engedélyezni a Message Queuing fájlokhoz, majd kattintson az Eltávolítás gombra. Szükség szerint ismételje meg a fenti lépést.

Megjegyzés

  • Fájl szintű és mappa szintű engedélyek csak NTFS fájlrendszerre formázott meghajtókon adhatók meg. Mappa szintű engedélyek nem adhatók meg FAT fájlrendszerre formázott meghajtókon (a Biztonság fül nem jelenik meg a FAT fájlrendszerű meghajtókon lévő mappák esetén).


Számítógép- és várólista-objektumok tulajdonosának módosítása

  3. A konzolfán kattintson a jobb oldali egérgombbal az msmq elemre vagy a megfelelő várólistára.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • szervezeti_egység (például számítógépek vagy tartományvezérlők)
    • számítógép
    • msmq
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  4. A számítógép (az msmq objektum) tulajdonosának módosításához kattintson a jobb oldali egérgombbal az msmq elemre, majd kattintson a Tulajdonságok parancsra.

    Ha a számítógép egy várólistájának tulajdonosát szeretné módosítani, kattintson duplán az msmq elemre, majd a megfelelő várólista mappájára, kattintson a jobb oldali egérgombbal a várólistára, végül kattintson a Tulajdonságok parancsra.

  5. A Biztonság lapon kattintson a Speciális gombra.
  6. A Tulajdonos lap Új tulajdonos részén kattintson az új felhasználóra vagy csoportra, majd kattintson az OK gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Alapértelmezés szerint az msmq objektum tulajdonosa a számítógép-objektum. Ez az eljárás az msmq objektum vagy a várólista-objektum tulajdonosának módosítására használható.
  • Ha egy helyi felhasználó (aki nem jelentkezett be egy Windows 2000 tartományba) hoz létre egy objektumot, az objektum fölött a Mindenki csoport Teljes hozzáférés engedéllyel rendelkezik.
  • Minden Message Queuing számítógépnek és várólistának csak egy tulajdonosa lehet.

Kapcsolódó témakörök


A Message Queuing szolgáltatásfiók módosítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a Szolgáltatások elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Szolgáltatások
  3. A részletek ablaktáblán kattintson duplán a Message Queuing elemre.
  4. A Bejelentkezés lapon kattintson az Ez a fiók választógombra, majd a Tallózás gombra. A Név listában válasszon ki egy felhasználót, majd kattintson az OK gombra. (Vagy egyszerűen írja be a felhasználói fiók nevét.)
  5. A Jelszó mezőbe gépelje be a felhasználói fiók jelszavát.
  6. A Jelszó megerősítése mezőbe gépelje be újra a felhasználói fiók jelszavát.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Számítógép-kezelés parancsra.
  • A Message Queuing szolgáltatás alapértelmezés szerint a LocalSystem fiók alatt fut. A Message Queuing szolgáltatást módosítani kell, hogy másik felhasználói fiók alatt fusson, ha a felügyeleti házirend nem engedélyezi a szolgáltatások LocalSystem fiók alatt történő futtatását.
  • A Message Queuing szolgáltatásnak Windows 2000 tartományvezérlők LocalSystem fiókja alatt kell futnia, hogy az Active Dirctory objektumaihoz hozzáférhessen.
Kapcsolódó témakörök


Számítógép- és várólista-objektumokhoz történő hozzáférés naplózása

  2. A konzolfán kattintson az Active Directory - felhasználók és számítógépek elemre.
  3. A konzolfán kattintson a jobb oldali egérgombbal az msmq elemre vagy a megfelelő várólistára.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • szervezeti_egység (például számítógép vagy tartományvezérlő)
    • számítógép
    • msmq
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  4. Számítógéphez történő hozzáférés naplózásához kattintson a jobb oldali egérgombbal az msmq elemre, majd kattintson a Tulajdonságok parancsra.

    Ha a számítógép egy várólistájához történő hozzáférést szeretné naplózni, kattintson duplán az msmq elemre, majd a megfelelő várólista mappájára, kattintson a jobb oldali egérgombbal a várólistára, végül kattintson a Tulajdonságok parancsra.

  5. A Biztonság lapon kattintson a Speciális gombra.
  6. A Hozzáférés-vezérlési beállítások párbeszédpanel Naplózás lapján kattintson a Hozzáadás gombra.
  7. A Felhasználók, számítógépek vagy csoportok kijelölése párbeszédpanelen, a Név oszlopban kattintson arra a felhasználóra vagy csoportra, amelyiknek a hozzáférését naplózni szeretné, majd kattintson az OK gombra.
  8. A Naplózási bejegyzés párbeszédpanelen, az Alkalmazás listában kattintson azokra az objektumokra, amelyekhez történő hozzáférést naplózni szeretné, majd a Hozzáférés listában jelölje be a sorok mellett a megfelelő jelölőnégyzeteket, végül kattintson az OK gombra.

    Az összes naplózási bejegyzés törléséhez kattintson Az összes törlése gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A naplózás során létrehozott adatokat a rendszer a Windows 2000 biztonsági naplójában tárolja. A Biztonsági naplóban lévő adatoknak az Eseményfigyelővel történő megtekintéséről további tájékoztatást a Kapcsolódó témakörökben talál.
  • Ez az eljárás bármely Message Queuing objektumhoz történő hozzáférés naplózására használható, amely az msmq objektum alatt található (beleértve az msmq objektumot is).
  • A feladat végrehajtása előtt engedélyezni kell a naplózást oly módon, hogy a helyi számítógépen létrehoz egy naplórendet.

Kapcsolódó témakörök


Útválasztási kapcsolat objektumokhoz történő hozzáférés naplózása

  2. A konzolfán kattintson az MsmqServices elemre.

    Helye:

    • Active Directory - helyek és szolgáltatások
    • Szolgáltatások
    • MsmqServices
  3. A részletek ablaktáblán kattintson egy útválasztási kapcsolatra a jobb oldali egérgombbal, majd kattintson a Tulajdonságok parancsra.
  4. A Biztonság lapon kattintson a Speciális gombra.
  5. A Hozzáférés-vezérlési beállítások párbeszédpanel Naplózás lapján kattintson a Hozzáadás gombra.
  6. A Felhasználók, számítógépek vagy csoportok kijelölése párbeszédpanelen, a Név oszlopban kattintson arra a felhasználóra vagy csoportra, amelyiknek a hozzáférését naplózni szeretné, majd kattintson az OK gombra.
  7. A Naplózási bejegyzés párbeszédpanelen, az Alkalmazás listában kattintson azokra az objektumokra, amelyekhez történő hozzáférést naplózni szeretné, majd a Hozzáférés listában jelölje be a sorok mellett a megfelelő jelölőnégyzeteket, végül kattintson az OK gombra.

    Az összes naplózási bejegyzés törléséhez kattintson Az összes törlése gombra.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A naplózás során létrehozott adatokat a rendszer a Windows 2000 biztonsági naplójában tárolja. A Biztonsági naplóban lévő adatoknak az Eseményfigyelővel történő megtekintéséről további tájékoztatást a Kapcsolódó témakörökben talál.
  • Ez az eljárás bármely Message Queuing objektumhoz történő hozzáférés naplózására használható, amely az MsmqServices objektum alatt található (beleértve az MsmqServices objektumot is).
  • A feladat végrehajtása előtt engedélyezni kell a naplózást oly módon, hogy a helyi számítógépen létrehoz egy naplórendet.

Kapcsolódó témakörök


Kulcsbizonyítványok exportálása Windows NT 4.0 rendszerből

  1. A Windows NT 4.0 és az Internet Information Services 4.0 rendszert futtató számítógépen nyissa meg az Internet Services Manager programot.
  2. A konzolfán kattintson a jobb oldali egérgombbal az Alapértelmezett webhely elemre, majd kattintson a Tulajdonságok parancsra.
  3. Kattintson a Címtárbiztonság fülre, kattintson a Szerkesztés gombra a Biztonságos kommunikáció csoportban, kattintson a Kulcskezelő elemre, majd válassza ki a Windows 2000 rendszerhez használni kívánt kulcsbizonyítványt.
  4. A Kulcs menüben mutasson a Kulcs exportálása pontra, kattintson a Biztonságimásolat-fájl elemre, majd írja be a biztonságimásolat-fájl nevét.

Megjegyzések

  • Az Internet Services Manager megnyitásához a Windows NT 4.0 rendszert futtató számítógépen kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Internet Services Manager parancsra.
  • Ez az eljárás csak arra az esetre vonatkozik, ha egy MSMQ 1.0 vezérlőkiszolgálót Message Queuing kiszolgálóra frissít.
  • A számítógép Windows 2000 rendszerre történő frissítése előtt exportálja a kulcsbizonyítványt. Ezután a bizonyítványt importálhatja a Windows 2000 rendszerbe. Csak azon Message Queuing kiszolgálókra kell importálni kiszolgálói (kulcs)bizonyítványt, amelyek Windows NT 4.0, Windows 95 vagy Windows 98 rendszeren futó MSMQ-ügyfelek Active Directory lekérdezéseire válaszolnak.

Kapcsolódó témakörök


Message Queuing kiszolgálói bizonyítványok importálása

  1. Kattintson a Start menüre, a Futtatás parancsra, írja be az mmc parancsot, majd kattintson az OK gombra.
  2. Kattintson a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsára.
  3. A Beépülő modul hozzáadása/eltávolítása párbeszédpanelen kattintson a Hozzáadás gombra, válassza az Internet Information Services elemet, kattintson a Hozzáadás gombra, majd a Bezárás és végül az OK gombra.
  4. A konzolfán kattintson az Alapértelmezett webhely elemre.

    5. Helye:

    • Konzolgyökér
    • Internet Information Services
    • Számítógép_neve
    • Alapértelmezett webhely
  5. Kattintson a Művelet menü Tulajdonságok parancsára.
  6. Kattintson a Címtárbiztonság fülre, majd kattintson a Kiszolgálói bizonyítvány elemre. A Webkiszolgáló-bizonyítvány varázslóban kattintson a Tovább gombra.
  7. Kattintson a Bizonyítvány importálása Kulcskezelő biztonságimásolat-fájlból elemre, majd a Tovább gombra.
  8. Írja be a bizonyítvány Windows NT 4.0 rendszerből történő exportálása során létrehozott biztonságimásolat-fájl nevét és elérési útját, majd kattintson a Tovább gombra.
  9. Írja be a megfelelő jelszót, kattintson a Tovább, majd a Befejezés gombra.
  10. Miután megszerezte a bizonyítványt, nyissa meg a Vezérlőpult Message Queuing segédprogramját.
  11. Kattintson a Kiszolgálói bizonyítvány fülre, majd kattintson a Bizonyítvány választása kiszolgáló hitelesítéséhez gombra.
  12. A Kiállítva a következőnek csoportban válassza ki azt a bizonyítványt, amelynek a neve megegyezik annak a Message Queuing kiszolgálónak a nevével, amelyen a bizonyítványt importálta, majd kattintson az OK gombra.

Megjegyzések

  • Az Internet Information Services beépülő modul megnyitásához azt előbb hozzá kell adni egy konzolhoz. Ehhez kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Internet Services Manager parancsra.
  • Ez az eljárás csak arra az esetre vonatkozik, ha egy MSMQ 1.0 vezérlőkiszolgálót Message Queuing kiszolgálóra frissít.
  • A számítógép Windows 2000 rendszerre történő frissítése előtt exportálja a kulcsbizonyítványt. Ezután importálja a kiszolgálói bizonyítványt. Csak azon Message Queuing kiszolgálókra kell importálni kiszolgálói (kulcs)bizonyítványt, amelyek Windows NT 4.0, Windows 95 vagy Windows 98 rendszeren futó MSMQ-ügyfelek Active Directory lekérdezéseire válaszolnak.

Kapcsolódó témakörök


Message Queuing kiszolgálói bizonyítványok létrehozása

  1. Kattintson a Start menüre, a Futtatás parancsra, írja be az mmc parancsot, majd kattintson az OK gombra.
  2. Kattintson a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsára.
  3. A Beépülő modul hozzáadása/eltávolítása párbeszédpanelen kattintson a Hozzáadás gombra, válassza a Bizonyítványok elemet, majd kattintson a Hozzáadás gombra.
  4. A Bizonyítványkezelő beépülő modul párbeszédpanelen kattintson a Számítógépfiók választógombra, majd kattintson a Következő, a Befejezés, a Bezárás és végül az OK gombra.
  5. A konzolfán kattintson duplán a Bizonyítványok, majd a Személyes elemre, kattintson a jobb oldali egérgombbal a Bizonyítványok elemre, mutasson a Feladatok parancsra, végül kattintson az Új bizonyítvány igénylése parancsra.
  6. Kövesse a Bizonyítványigénylő varázsló utasításait. Amikor felszólítást kap a bizonyítvány nevének beírására, adja meg a helyi Message Queuing kiszolgáló nevét.
  7. Miután megszerezte a bizonyítványt, nyissa meg a Vezérlőpult Message Queuing segédprogramját.
  8. Kattintson a Kiszolgálói bizonyítvány fülre, majd kattintson a Bizonyítvány választása kiszolgáló hitelesítéséhez gombra.
  9. A Kiállítva a következőnek csoportban válassza ki azt a bizonyítványt, amelynek a neve megegyezik a megfelelő Message Queuing kiszolgáló nevével, majd kattintson az OK gombra.
  10. A megjelenő párbeszédpanelen kattintson A Windows újraindítása most gombra.

Megjegyzések

  • A Bizonyítványkezelő beépülő modul megnyitásához azt előbb hozzá kell adni egy konzolhoz. Ehhez kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Bizonyítványok parancsra.
  • Csak azon Message Queuing kiszolgálók számára kell létrehoznia kiszolgálói bizonyítványt, amelyek Windows NT 4.0, Windows 95 vagy Windows 98 rendszeren futó MSMQ-ügyfelek Active Directory lekérdezéseire válaszolnak.

Kapcsolódó témakörök


Message Queuing kiszolgálói bizonyítványok módosítása

  2. Kattintson a Kiszolgálói bizonyítvány fülre, majd kattintson a Bizonyítvány választása kiszolgáló hitelesítéséhez gombra.
  3. Az MSMQ kiszolgálói bizonyítvány kiválasztása párbeszédpanelen válassza ki a megfelelő bizonyítványt, majd kattintson az OK gombra.
  4. A megjelenő párbeszédpanelen kattintson A Windows újraindítása most gombra.

Megjegyzések

  • Ez a feladat a Message Queuing kiszolgálóról hajtható végre.

Kapcsolódó témakörök


MSMQ 1.0 vezérlőkiszolgálók hitelesítése

  2. A Biztonság lapon jelölje be A Windows NT 4.0 MSMQ 1.0 vezérlőkiszolgálóval való kommunikáció biztonságosan történik jelölőnégyzetet, majd kattintson a Hitelesítő szervezetek gombra.
  3. A Hitelesítő szervezetek párbeszédpanelen kattintson a Rendszerbizonyítványok gombra.
  4. A megjelenő párbeszédpanelen kattintson az Igen gombra.
  5. Törölje azoknak a hitelesítő szervezeteknek a kijelölését, amelyekben nem bízik meg vagy nem szeretné őket biztonságos kommunikációhoz használni, majd kattintson az OK gombra.

Megjegyzések

  • Ez az eljárás csak azokra a Windows 2000 rendszert futtató ügyfelekre vonatkozik, amelyek Windows NT 4.0 rendszert futtató MSMQ 1.0 vezérlőkiszolgálókkal kommunikálnak.

Kapcsolódó témakörök


Message Queuing bizonyítványok regisztrálása

  2. A Biztonság lap Felhasználói bizonyítványok csoportjában kattintson a Regisztrálás gombra.
  3. A Személyes bizonyítványok párbeszédpanelen kattintson egy bizonyítványra, majd a Regisztrálás gombra.

Megjegyzések

  • A helyi számítógépen a telepítés során automatikusan létrejön egy belső felhasználói bizonyítvány, és a számítógépre történő első bejelentkezéskor az regisztrálva lesz az Active Directory címtárban. Akkor használja ezt az eljárást belső felhasználói bizonyítvány létrehozásához és regisztrálásához, ha ilyen nem létezik, például egy bizonyítvány eltávolítása után. Ez az eljárás külső bizonyítvány regisztrálására is használható, miután importálta azt.
  • Ha a helyi számítógép egy regisztrált bizonyítványát egy távoli számítógép használatával távolítja el, a bizonyítvány el lesz távolítva az Active Directory címtárból, de megmarad a helyi számítógépen.

Kapcsolódó témakörök


Message Queuing bizonyítványok eltávolítása

  2. A Biztonság lap Felhasználói bizonyítványok csoportjában kattintson az Eltávolítás gombra.
  3. A Személyes bizonyítványok párbeszédpanelen kattintson a megfelelő felhasználói bizonyítványra, majd az Eltávolítás gombra.

Megjegyzés

  • Bármelyik megjelenő felhasználói bizonyítványt eltávolíthatja; ha azonban egy számítógép regisztrált bizonyítványát egy másik számítógép használatával távolítja el, a bizonyítvány el lesz távolítva az Active Directory címtárból, de megmarad a helyi számítógépen.

Kapcsolódó témakörök


Message Queuing bizonyítványok megtekintése

  2. Kattintson a Biztonság fülre, majd a Felhasználói bizonyítványok csoportban kattintson a Megtekintés gombra.
  3. A Személyes bizonyítványok párbeszédpanelen kattintson egy bizonyítványra, majd a Bizonyítvány megtekintése gombra.

Megjegyzés

  • Minden felhasználói bizonyítványt meg lehet tekinteni, amelyik az Active Directory címtárban regisztrálva van.

Kapcsolódó témakörök


Message Queuing bizonyítványok megújítása

  2. A Biztonság lap Belső bizonyítvány csoportjában kattintson a Belső bizonyítvány megújítása gombra.

    A megjelenő figyelmeztetés közli, hogy a jelenlegi belső bizonyítvány használatával elküldött titkosított üzeneteket esetleg más rendszerek visszautasítják azzal az indokkal, hogy azok nem hitelesítettek.

  3. Ha nem jelent problémát az üzenetek visszautasítása, kattintson az Igen gombra.

    Ha ez problémát jelent, kattintson a Nem gombra, és a belső bizonyítványt egy későbbi időpontban újítsa meg.

Megjegyzések

Kapcsolódó témakörök


Message Queuing titkosítási kulcsok megújítása

  2. A Biztonság lap Titkosítási kulcsok csoportjában kattintson a Titkosítási kulcsok megújítása gombra.

    A megjelenő figyelmeztetés közli, hogy a bejövő üzenetek olyan titkosítási kulccsal lesznek titkosítva, amelyet a számítógépe nem ismer. Azokat az üzeneteket nem fogja tudni elolvasni.

  3. Ha nem jelent problémát, hogy nem tudja elolvasni azokat az üzeneteket, kattintson az Igen gombra.

    Ha ez problémát jelent, kattintson a Nem gombra, és a titkosítási kulcsot egy későbbi időpontban újítsa meg.

  4. Kattintson A Windows újraindítása most gombra.

Megjegyzések

  • Ez az eljárás nem vonatkozik a függő ügyfelekre.

Kapcsolódó témakörök


A biztonság gyengítése az ADSI Edit segítségével

  1. Kattintson a Start gombra, mutasson a Programok, majd a Resource Kit pontra, végül kattintson a Tools Management Console parancsra.
  2. A konzolfán kattintson a Tools A to Z elemre.

    Helye:

    • Microsoft Resource Kit
    • Windows 2000 Resource Kit
    • Tools A to Z
  3. A részletek ablaktáblán kattintson duplán az ADSI Editor elemre.
  4. A konzolfán kattintson a jobb oldali egérgombbal az ADSI Edit elemre, majd kattintson a Csatlakozás parancsra.
  5. A Csatlakozási pont csoportban kattintson a Névhasználati környezet elemre, kattintson a lefele nyílra, válassza ki a Konfigurációs tároló elemet, majd kattintson az OK gombra.
  6. A konzolfán kattintson a jobb oldali egérgombbal a common name=MsmqServices elemre.

    Helye:

    • ADSI Edit
    • common name=Configuration,...
    • common name=Services
    • common name=MsmqServices
  7. Kattintson a Tulajdonságok parancsra.
  8. Az Attribútumok lap Megtekinteni kívánt tulajdonság kiválasztása részén kattintson a lefele nyílra, majd válassza ki az mSMQNameStyle elemet.
  9. Az Attribútum szerkesztése mezőbe írja be a TRUE értéket a biztonság csökkentéséhez.

    A biztonság megerősítéséhez írja be a FALSE értéket.

  10. Kattintson a Beállítás, majd az OK gombra.

Megjegyzések

  • Az ADSI Edit használatához telepíteni kell a Windows 2000 Resource Kit csomagot. A Windows 2000 CD-lemez a Windows 2000 Resource Kit egy részét tartalmazza. További tájékoztatásért tanulmányozza a Windows 2000 Resource Kit csomagot.
  • Az eljárás segítségével gyengítheti az Active Directory biztonságát, hogy az támogassa a Windows NT 4.0 felhasználókat, a helyi felhasználókat és bizonyos működési beállításokat.
  • Az eljárás végrehajtása után újra kell indítani a Windows 2000 tartományvezérlőkön futó Message Queuing kiszolgálókat a módosítások érvénybe léptetéséhez.

Kapcsolódó témakörök


Message Queuing várólisták felügyelete

  • Várólisták létrehozása
  • Várólisták keresése
  • Várólisták törlése
  • Kimenő várólisták lekapcsolása a hálózatról
  • Kimenő várólisták működésének szüneteltetése és folytatása
  • Várólistacímkék módosítása
  • Várólisták típusazonosítójának módosítása
  • Várólisták alapprioritásának módosítása
  • Célnaplózás engedélyezése és letiltása
  • Várólisták naplótárolási méretének beállítása
  • Várólisták üzenettárolási méretének beállítása
  • Csak hitelesített üzenetek engedélyezése a várólistákban
  • Várólisták titkosítási szintjének módosítása
  • Más számítógépeken lévő várólisták és üzenetek kezelése


Várólisták létrehozása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson egy várólista mappára a jobb oldali egérgombbal.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
  3. Mutasson az Új pontra, majd kattintson a Nyilvános várólista (vagy a Privát várólista) parancsra.
  4. A Név mezőbe írja be az új várólista nevét, majd kattintson az OK gombra.

    Ha tranzakció alapú üzenetek fogadására szeretne várólistát létrehozni, írja be a várólista nevét, jelölje be a Tranzakciós jelölőnégyzetet, majd kattintson az OK gombra.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • A Kimenő várólisták és a Rendszervárólisták mappában nem hozhat létre várólistákat. Ezeket a várólistákat a rendszer automatikusan elkészíti.
  • Távoli nyilvános várólisták létrehozásához tartománygazdai engedéllyel kell rendelkezni, és tartományi felhasználói fiókkal kell bejelentkezni.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták keresése

  3. A konzolfán kattintson a jobb oldali egérgombbal egy mappára vagy objektumra.
  4. Kattintson a Keresés parancsra.
  5. A Keresés ablakban kattintson a lefele nyílra, majd kattintson az MSMQ-várólista elemre.
  6. Az MSMQ-várólista keresése lap Címke vagy Típus azonosítója mezőjébe írja be a megfelelő várólista-információkat, majd kattintson a Keresés most gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Ha a Címke és a Típus azonosítója mezőket üresen hagyja, a listában az összes várólista megjelenik. Ha a Címke és a Típus azonosítója mezőben is megad értéket, csak azok a várólisták jelennek meg, amelyek kielégítik a feltételeket.

Kapcsolódó témakörök


Várólisták törlése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Törlés gombra.
  4. A megjelenő párbeszédpanelen kattintson az Igen gombra a várólista törléséhez.

Fontos

  • Várólista törlésekor a benne lévő összes üzenet is törlődik.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • A Kimenő várólisták és a Rendszervárólisták mappából nem törölhet várólistákat.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Kimenő várólisták lekapcsolása a hálózatról

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal a Message Queuing elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
  3. Mutasson a Feladatok elemre, majd hajtsa végre az alábbi műveletek egyikét:
    • A Message Queuing szolgáltatás hálózatról történő lekapcsolásához kattintson az MSMQ állítása offline állapotba parancsra.
    • A Message Queuing szolgáltatás hálózatra történő visszakapcsolásához kattintson az MSMQ állítása on-line állapotba parancsra.
  4. A megjelenő párbeszédpanelen kattintson az Igen gombra.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Amikor a Message Queuing szolgáltatást lekapcsolja a hálózatról, a helyi számítógép összes kimenő várólistájának működését felfüggeszti. Ez telefonos kapcsolaton keresztüli kommunikáció esetén hasznos, ha el szeretné halasztani a számítógép összes kimenő várólistájában lévő üzenet elküldését.
  • Egyetlen kimenő várólista működése is szüneteltethető. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ez a feladat csak a Számítógép-kezelés beépülő modul segítségével hajtható végre.
Kapcsolódó témakörök


Kimenő várólisták működésének szüneteltetése és folytatása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal a Kimenő várólisták elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • Kimenő várólisták
  3. Kattintson a Felfüggesztés parancsra.

    A várólista működésének folytatásához kattintson a Folytatás parancsra.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Ha felfüggeszti egy kimenő várólista működését, akkor elhalasztja az üzenetek küldését abból a várólistából. Ily módon az összes várakozó üzenet később is elküldhető a célszámítógép várólistájába.
  • Az összes kimenő várólista működését is felfüggesztheti, ha a Message Queuing szolgáltatást lekapcsolja a hálózatról. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ez a feladat csak a Számítógép-kezelés beépülő modul segítségével hajtható végre.
Kapcsolódó témakörök


Várólistacímkék módosítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lap Címke mezőjébe írja be a várólista új címkéjét.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták típusazonosítójának módosítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lap Típus azonosítója mezőjébe írja be a várólista új típusazonosítóját.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • A várólista típusazonosítója a várólista által biztosított szolgáltatás típusát vagy funkcióját határozza meg. A várólista típusazonosítójának használata nem kötelező, és az a Message Queuing alkalmazástól függ. Ha például egy Message Queuing alkalmazás egy MAPI-alkalmazástól kap üzeneteket, a Message Queuing alkalmazásnak olyan bemeneti várólistára lehet szüksége, amely adott MAPI-típusazonosítóval rendelkezik.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták alapprioritásának módosítása

  4. Kattintson a Tulajdonságok parancsra.
  5. Az Általános lap Alapprioritás mezőjébe írja be az új értéket, vagy használja a fel vagy a le nyilat új érték megadásához.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Az alapprioritás értéke -32768 és 32767 között lehet. Az alapértelmezett érték 0.
  • A privát várólisták nem támogatják az alapprioritást (várólista-prioritást).

Kapcsolódó témakörök


Célnaplózás engedélyezése és letiltása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lap Napló csoportjában jelölje be az Engedélyezve jelölőnégyzetet.

    A várólista célnaplózásának letiltásához törölje az Engedélyezve jelölőnégyzet jelölését.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták naplótárolási méretének beállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lap Napló csoportjában jelölje be a Napló maximális mérete (KB) jelölőnégyzetet, majd adja meg a várólistában tárolható naplóüzenetek maximális méretét (kilobájtban).

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • A naplóüzenetek tárolási korlátjának elérése után a naplóvárólistába mindaddig nem lehet több naplóüzenetet küldeni, amíg a naplóvárólistában lévő naplóüzenetek összesített mérete a megadott korlát alá nem esik.
  • Ha törli a Napló maximális mérete (KB) jelölőnégyzet jelölését, a napló méretét csak a helyi számítógépen rendelkezésre álló lemezterület korlátozza.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták üzenettárolási méretének beállítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Jelölje be az Üzenetek maximális tárhelye (KB) jelölőnégyzetet, majd adja meg a várólistában tárolható üzenetek összesített maximális méretét (kilobájtban).

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Az üzenetek tárolási korlátjának elérése után a várólistába mindaddig nem lehet több üzenetet küldeni, amíg a várólistában lévő üzenetek összesített mérete a megadott korlát alá nem esik.
  • Ha törli az Üzenetek maximális tárhelye (KB) jelölőnégyzet jelölését, az üzenetek méretét csak a helyi számítógépen rendelkezésre álló lemezterület korlátozza.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Csak hitelesített üzenetek engedélyezése a várólistákban

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lapon jelölje be a Hitelesített jelölőnégyzetet.

    Ha a várólistában minden üzenetet fogadni szeretne, törölje a Hitelesített jelölőnégyzet jelölését.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Ha bejelöli a Hitelesített jelölőnégyzetet, a várólista csak hitelesített üzeneteket fog elfogadni.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták titkosítási szintjének módosítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
  3. Kattintson a Tulajdonságok parancsra.
  4. Az Általános lap Titkosítási szint csoportjában hajtsa végre az alábbi műveletek egyikét:
    • Ha azt szeretné, hogy a várólista elfogadja a hitelesített és a nem hitelesített üzeneteket is, kattintson a Választható lehetőségre (ez az alapértelmezett beállítás).
    • Ha azt szeretné, hogy a várólista csak hitelesített üzeneteket fogadjon el, kattintson a Törzs lehetőségre.
    • Ha azt szeretné, hogy a várólista csak nem hitelesített üzeneteket fogadjon el, kattintson a Nincs lehetőségre.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Más számítógépeken lévő várólisták és üzenetek kezelése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. Kattintson a jobb oldali egérgombbal a Számítógép-kezelés elemre, majd kattintson a Csatlakozás másik számítógéphez parancsra.
  3. A Számítógép kiválasztása párbeszédpanelen válassza ki azt a számítógépet, amelynek a várólistáit és üzeneteit kezelni szeretné, majd kattintson az OK gombra.
  4. Hajtsa végre a kívánt műveletet ugyanúgy, mintha azt egy helyi számítógép esetében tenné.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Nyilvános várólisták kezeléséhez hozzáféréssel kell rendelkeznie az Active Directory címtárhoz.
  • A távoli számítógépen lévő privát várólistákat nem lehet kezelni.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
Kapcsolódó témakörök


Message Queuing üzenetek felügyelete

  • Üzenetek tulajdonságainak megtekintése
  • A megjelenő üzenettulajdonság-oszlopok módosítása
  • Várólista minden üzenetének törlése
  • Üzenetek alapértelmezett élettartamának beállítása


Üzenetek tulajdonságainak megtekintése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal a Várólista üzenetei (vagy a Naplóüzenetek) elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
    • Várólista üzenetei (vagy Naplóüzenetek)
  3. A részletek ablaktáblán kattintson az üzenetre a jobb oldali egérgombbal, majd kattintson a Tulajdonságok parancsra.
  4. Kattintson sorban a fülekre a különféle üzenettulajdonságok és más lényeges információk megtekintéséhez.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A megjelenő üzenettulajdonság-oszlopok módosítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal a Várólista üzenetei (vagy a Naplóüzenetek) elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
    • Várólista üzenetei (vagy Naplóüzenetek)
  3. Kattintson a Nézet menüre, majd válassza az Oszlop választása parancsot.
  4. Az Oszlopok módosítása párbeszédpanelen végezze el a kívánt módosításokat:
    • Egy üzenettulajdonság-oszlop hozzáadásához kattintson egy bejegyzésre a Rejtett oszlopok listában, majd kattintson a Hozzáadás gombra.
    • Egy meglévő üzenettulajdonság-oszlop eltávolításához kattintson a bejegyzésre a Megjelenő oszlopok listában, majd kattintson az Eltávolítás gombra.
    • Az üzenettulajdonság-oszlopok megjelenési sorrendjének módosításához kattintson egy bejegyzésre a Megjelenő oszlopok listában, majd az oszlop jobbra vagy balra történő mozgatásához kattintson a Fel vagy a Le gombra.
  5. További oszlopok módosításához ismételje meg a 4. lépést.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Az eljárás eredménye a részletek ablaktáblán látható. Az üzenetek az üzenettulajdonságok szerint is rendezhetők növekvő vagy csökkenő sorrendbe, ha a megfelelő oszlopra kattint.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólista minden üzenetének törlése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a jobb oldali egérgombbal a Várólista üzenetei (vagy a Naplóüzenetek) elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Message Queuing
    • várólista_mappája (például Nyilvános várólisták vagy Privát várólisták)
    • várólista
    • Várólista üzenetei (vagy Naplóüzenetek)
  3. Mutasson a Feladatok elemre, majd kattintson az Ürítés parancsra.
  4. A megjelenő párbeszédpanelen kattintson az Igen gombra.

Megjegyzések

  • A Számítógép-kezelés segédprogram megnyitásához kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Kezelés parancsra.
  • Rendszervárólistákból nem törölhetők üzenetek.
  • Csak az összes üzenet törlésére van mód, egyes üzenetek nem törölhetők.
  • A teljesítmény növelése érdekében rendszeresen törölje a naplóvárólistákban és a kézbesítetlen üzenetek várólistákban található üzeneteket.
  • Ez az eljárás az Active Directory - felhasználók és számítógépek beépülő modul segítségével is végrehajtható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Üzenetek alapértelmezett élettartamának beállítása

  2. Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.
  4. Kattintson a Tulajdonságok parancsra.
  5. Az Általános lapon adjon meg egy új értéket és szükség szerint válasszon új egységet.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - helyek és szolgáltatások beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Az üzenetek alapértelmezett élettartama várólista-elérési időkorlát (time-to-reach-queue, TTRQ) néven is ismert.

Kapcsolódó témakörök


A Message Queuing szolgáltatás figyelése és tesztelése

  • A Message Queuing eseményeinek megtekintése
  • Message Queuing tranzakciók megtekintése
  • A számítógép teljesítményének megtekintése
  • Várólisták teljesítményének megtekintése
  • Tesztüzenetek küldése
  • Üzenetútvonalak nyomkövetésének engedélyezése
  • A kapcsolat ellenőrzése az MQPing parancs segítségével


A Message Queuing eseményeinek megtekintése

  1. Nyissa meg az Eseménynapló ablakot.
  2. A konzolfán kattintson az Alkalmazásnapló elemre.
  3. A részletek ablaktáblán kattintson a Forrás oszlopra.
  4. Görgesse a listát addig, amíg az oszlopban „MSMQ” eseményeket nem lát.

Megjegyzések

  • Az Eseménynapló megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Eseménynapló parancsra.
  • Az események Eseménynaplóban történő megtekintésekor az események az eseménytulajdonságok alapján rendezhetők, szűrhetők és kereshetők.
Kapcsolódó témakörök


Message Queuing tranzakciók megtekintése

  1. Nyissa meg az MS DTC felügyeleti konzolt.
  2. Tegye a következőket:
    • Egy tranzakció állapotának megtekintéséhez kattintson a Tranzakciók fülre.
    • Egy tranzakció statisztikai adatainak megtekintéséhez kattintson a Statisztika fülre.

Megjegyzések

  • Az MS DTC felügyeleti konzol megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be: msdtcmgr.exe.
  • Az MS DTC beállításai a Speciális lapon módosíthatók.
  • Az elosztott tranzakciók koordinátora szolgáltatásnak futni kell külső tranzakciók végrehajtásához.

Kapcsolódó témakörök


A számítógép teljesítményének megtekintése

  1. Nyissa meg a Rendszerfigyelő ablakot.
  2. A részletek ablaktábla eszköztárán kattintson a Hozzáadás (+) gombra.
  3. A Számláló hozzáadása párbeszédpanelen kattintson a Helyi számlálók használata választógombra a jelenleg használt számítógép számlálóinak megtekintéséhez.

    Másik számítógép számlálóinak megtekintéséhez kattintson a Más számítógép számlálói választógombra, majd kattintson a kívánt számítógépre.

  4. A Teljesítményobjektum csoportban kattintson a lefele nyílra, majd kattintson az MSMQ-szolgáltatás elemre.
  5. Kattintson a Minden számláló

    vagy a Számlálók választása listából választógombra. Ha ez utóbbira kattint, válassza ki a megfigyelni kívánt számlálókat.

  6. Kattintson a Minden példány

    vagy a Példányok választása listából választógombra. Ha ez utóbbira kattint, válassza ki a megfigyelni kívánt példányokat.

  7. Kattintson a Hozzáadás gombra.
  8. Egy számláló meghatározásának áttekintéséhez kattintson a Magyarázat gombra.
  9. Kattintson a Bezárás gombra.

    A grafikon megjelenik a részletek ablaktáblán.

Megjegyzések

  • A Rendszerfigyelő megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A Rendszerfigyelőben a teljesítményadatokat megjelenítheti Diagram, Jelentés vagy Hisztogram nézetben, illetve a teljesítményadatokat fájlba is naplózhatja. A Rendszerfigyelővel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Várólisták teljesítményének megtekintése

  1. Nyissa meg a Rendszerfigyelő ablakot.
  2. A részletek ablaktábla eszköztárán kattintson a Hozzáadás (+) gombra.
  3. A Számláló hozzáadása párbeszédpanelen kattintson a Helyi számlálók használata választógombra a jelenleg felügyelt számítógép számlálóinak megtekintéséhez.

    Másik számítógép számlálóinak megtekintéséhez kattintson a Más számítógép számlálói választógombra, majd kattintson a megfelelő számítógépre.

  4. A Teljesítményobjektum listából válassza ki az MSMQ-várólista elemet.
  5. Kattintson a Minden számláló

    vagy a Számlálók választása listából választógombra. Ha ez utóbbira kattint, válassza ki a megfigyelni kívánt számlálókat.

  6. Kattintson a Minden példány

    vagy a Példányok választása listából választógombra. Ha ez utóbbira kattint, válassza ki a megfigyelni kívánt példányokat.

  7. Kattintson a Hozzáadás gombra.
  8. Egy számláló meghatározásának áttekintéséhez kattintson a Magyarázat gombra.
  9. Kattintson a Bezárás gombra.

    A grafikon megjelenik a részletek ablaktáblán.

Megjegyzések

  • A Rendszerfigyelő megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A Rendszerfigyelőben a teljesítményadatokat megjelenítheti Diagram, Jelentés vagy Hisztogram nézetben, illetve a teljesítményadatokat fájlba is naplózhatja. A Rendszerfigyelővel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Tesztüzenetek küldése

  3. A konzolfán kattintson a jobb oldali egérgombbal az msmq elemre.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • szervezeti_egység (például számítógép vagy tartományvezérlő)
    • forrásszámítógép
    • msmq
  4. Kattintson a Tulajdonságok parancsra.
  5. A Diagnosztika lapon kattintson a Tesztüzenet küldése elemre.
  6. A Célvárólista listában kattintson a megfelelő tesztvárólistára, majd a Küldés gombra.

    Ha új várólistát szeretne létrehozni a tesztüzenetek küldéséhez, kattintson az Új várólista elemre, adja meg a várólista teljes elérési útvonalát (például célszámítógép\célvárólista), kattintson az OK gombra, végül pedig a Küldés gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • A kiválasztott számítógép a tesztüzenetek küldésére használt forrásszámítógép.
  • Csak tesztvárólistákba küldhet tesztüzeneteket. Minden tesztvárólista típusazonosítója {55EE8F33-CCE9-11CF-B108-0020AFD61CE9}.
  • Tranzakciós várólista nem használható tesztvárólistaként. Tranzakciós várólistákba csak tranzakció alapú üzenetek küldhetők, és a tesztüzenetek nem tranzakció alapúak. Hasonlóképpen, egy hitelesítést igénylő várólista típusazonosítóját nem módosíthatja a tesztvárólista típusazonosítójára, és nem küldhet rá tesztüzeneteket, mivel az üzenetek nem lesznek kézbesítve (kivéve, ha a várólista a forrásszámítógépen található).
  • Mivel az összes tesztüzenet esetén az üzenet útvonalának nyomon követése szolgáltatás engedélyezve van, ha a forrásszámítógépen van jelentés-várólista és a tesztvárólista egy másik számítógépen található, a rendszer nyomon követi a tesztüzenetek útvonalát. Az üzenetútvonalak nyomkövetésének más módon történő engedélyezésével kapcsolatban tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Üzenetútvonalak nyomkövetésének engedélyezése

  4. Kattintson a Tulajdonságok parancsra.
  5. Kattintson a Diagnosztika fülre, majd a Nyomon követés megadása elemre.

    Megjelenik az Üzenet útvonalának nyomon követése párbeszédpanel.

  6. A jelentéslista elérési útja részen kattintson a megfelelő jelentéslistára.

    Ha a jelentésüzenetek számára új várólistát akar létrehozni, kattintson az Új elemre, majd adja meg a várólista teljes elérési útvonalát (például Számítógép_neve\Várólista_neve).

  7. Kattintson a Minden üzenet nyomon követése

    vagy a Csak a tesztüzenet nyomon követése elemre.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • Az üzenetútvonalak nyomkövetésének engedélyezéséhez először létre kell hozni egy jelentés-várólistát. Az új sorok létrehozásával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ha a Minden üzenet nyomon követése lehetőséget választja, és a küldő alkalmazás beállította az üzenet útvonalának nyomon követése jelzőt, továbbá ha a célvárólista egy másik számítógépen található, a rendszer nyomon követi a forrásszámítógépről küldött összes üzenet útvonalát. Ez az információ ezután a jelentés-várólistába kerül. A forrásszámítógép által küldött üzenetek és egy Message Queuing kiszolgáló által továbbított üzenetek esetén is történik nyomkövetés.
  • Ha a Csak a tesztüzenet nyomon követése lehetőséget választja, a rendszer csak a tesztüzenetekről küld jelentésüzeneteket. A tesztüzenetek küldésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Egy ugyanazon a számítógépen lévő várólistába helyileg küldött üzenetek esetén nem történik nyomon követés.

Kapcsolódó témakörök


A kapcsolat ellenőrzése az MQPing parancs segítségével

  4. Kattintson az MQPing üzenet küldése parancsra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tájékoztatásért tanulmányozza a Kapcsolódó témaköröket.
  • MQPing üzenetet úgy is küldhet, ha a jobb oldali egérgombbal az msmq elemre kattint, majd sorban a Tulajdonságok, a Diagnosztika és az MQPing elemekre kattint.
  • Amikor MQPing üzenetet küld egy számítógépnek, a Message Queuing szolgáltatás 45 másodpercen keresztül próbál csatlakozni a számítógéphez. Több MQPing üzenet elküldésére is szükség lehet annak meghatározásához, hogy a számítógép a hálózatra van-e kapcsolva.

Kapcsolódó témakörök


Fogalmak

Ez a fejezet a Message Queuing szolgáltatás általános ismertetését tartalmazza.

  • Message Queuing - áttekintés
  • A Message Queuing ismertetése
  • A Message Queuing használata
  • Forrásmunkák


Message Queuing - áttekintés

A Message Queuing egy üzenetsor-kezelési infrastruktúra és fejlesztőeszköz, amely elosztott, lazán összekapcsolt üzenetküldő alkalmazások létrehozására használható a Windows 2000 operációs rendszerben. A Message Queuing számára kifejlesztett alkalmazások az üzeneteket várólistákba küldik, amelyek az üzenetek célbaérését biztosító átmeneti tárolóhelyek. Ezek az alkalmazások képesek a heterogén hálózatokon keresztüli, valamint az esetleg kapcsolat nélküli számítógépekkel történő kommunikációra. A Message Queuing szolgáltatás garantált üzenetkézbesítést, hatékony útválasztást, biztonságot, tranzakciókezelést és prioritás alapú üzenetküldést biztosít. Az ilyen szolgáltatásokat nyújtó szoftvertermékeket gyakran üzenetsor-kezelő szoftvernek, “tárolás és továbbítás” elven működő szoftvernek vagy üzenetorientált middleware-nek nevezik.

A Message Queuing segítségével a végfelhasználók hálózatokkal és számítógépekkel kommunikálhatnak, függetlenül a hálózat és a számítógépek aktuális állapotától. A rendszergazdák a Message Queuing segítségével hatékonyan kezelhetik a nagy, összetett számítógép-hálózatokat és üzenet-várólistákat. A Message Queuing szolgáltatás az informatikai döntéshozók számára megbízhatóbb kommunikációt és hatékonyabb hálózatierőforrás-használatot biztosít. A fejlesztők a hálózati kérdések helyett az üzleti folyamatokra összpontosíthatnak, mivel a Message Queuing megbízható hálózati kommunikációt biztosít.

A Message Queuing szolgáltatás különösen fontos a rendszergazdák (az infrastruktúra telepítése és kezelése) és a szoftverfejlesztők (üzenetkezelő alkalmazások létrehozása) számára. Ez a dokumentáció rendszergazdák számára készült, ezért csak a Message Queuing által biztosított infrastruktúrát és lehetőségeket tárgyalja, az alkalmazásfejlesztéssel nem foglalkozik. A Message Queuing alkalmazások fejlesztésével kapcsolatos tájékoztatásért szerezze be a Message Queuing Software Development Kit (SDK) csomagot, amely a Microsoft Platform SDK csomag része. A Message Queuing SDK-val kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Platform Software Development Kit csomagot.

A könnyebb érthetőség kedvéért ezen dokumentáció különbséget tesz a Message Queuing által biztosított szolgáltatások és a Message Queuing alkalmazások programozásán keresztül elérhető szolgáltatások között.

A Message Queuing jelenlegi verziójában számos terminológiai és felügyeleti módosítás történt az előző verziókhoz képest. Ha egy régebbi verzióról frissít, a módosítások listáját megtalálja a A Message Queuing frissítése - áttekintés című részben.

Megjegyzések

  • Az előző verziókban a Message Queuing szolgáltatás neve Microsoft Message Queuing Server vagy MSMQ 1.0 volt. A verziók megkülönböztetése érdekében a jelenlegi verzióval (Windows 2000) kapcsolatban a Message Queuing, az előző verziókkal (Windows NT 4.0, Windows 95 és Windows 98) kapcsolatban pedig az MSMQ 1.0 kifejezés található a dokumentációban. Azonban mivel néhány alösszetevőben és a felhasználói kezelőfelület egyes részein még az MSMQ kifejezés szerepel, a dokumentációban esetenként ez a kifejezés a jelenlegi verzióra utal. Az, hogy mely verzióra történik utalás, kiderül a szövegkörnyezetből.
  • Előfordulhat, hogy más irodalmakban és külső forrásmunkákban a Message Queuing szolgáltatásra esetleg MSMQ 2.0 néven hivatkoznak.

A tulajdonságok összefoglalása

Az alábbiakban a Message Queuing főbb szolgáltatásainak összefoglalása következik, a Windows 2000 rendszerben található új szolgáltatások és az előző verziókból átvett régebbi szolgáltatások szerint felosztva:

Új szolgáltatások

  • Active Directory integráció. Az Active Directory címtárszolgáltatással történő integrálódás és annak kiterjesztése az összes konfigurációs és állapotinformáció tárolására.
  • Vegyes módú működés. A Message Queuing vegyes módú tartománykörnyezetekben is működhet, ami azt jelenti, hogy a Windows NT 4.0 rendszeren futó MSMQ 1.0 vezérlőkiszolgálók és a Windows 2000 rendszeren futó Message Queuing kiszolgálók probléma nélkül kommunikálhatnak.
  • Windows 2000 biztonsági integráció. A Message Queuing továbbra is támogatja a hozzáférés-vezérlés, a naplózás, a titkosítás és a hitelesítés által nyújtott biztonságot és titkosságot, valamint kihasználja a Windows 2000 rendszerbe épített új biztonsági lehetőségeket is, mint például a Kerberos V5 biztonsági protokollt.

    Ezenkívül a Message Queuing egyesült államokbeli verziója a 40 bites titkosítás mellett a 128 bites titkosítást is támogatja.

    Továbbá csak a megfelelő engedélyekkel rendelkező és a Message Queuing alkalmazásokat helyileg futtató felhasználók jogosultak várólisták létrehozására.

  • Munkacsoport-támogatás. A Message Queuing Windows 2000 munkacsoportban is telepíthető és futtaható, nem csak tartományban. Ezenkívül egy munkacsoportba telepített Message Queuing szolgáltatás később csatlakozhat egy tartományhoz, majd le is válhat onnan.
  • Aktív/aktív fürttámogatás. A Message Queuing már teljes mértékben támogatja az aktív/aktív műveleteket kiszolgálófürtökön, ami azt jelenti, hogy a Message Queuing a kiszolgálófürt minden csomópontján képes egyidejűleg futni.
  • Windows CE támogatás. A Message Queuing ügyfél egy speciális változata van telepítve a Windows CE 3.0 (vagy újabb) operációs rendszert futtató hordozható számítógépekre.
  • Üzenetek biztonsági mentése és visszaállítása. Az üzenettároló fájlokról, a naplófájlokról, a tranzakciós naplófájlokról és a rendszerleíró adatbázis beállításairól biztonsági mentés készíthető, amely a számítógép meghibásodása esetén visszaállítható.
  • Microsoft Management Console (MMC) támogatása. A Message Queuing egy MMC konzolon található beépülő modulok segítségével felügyelhető.

Régi szolgáltatások

  • Kapcsolat nélküli üzenetkezelés. A “tárolás és továbbítás” elvű üzenetsor-kezelés miatt a számítógépekre nincsenek hatással a hálózati meghibásodások, és nem kell munkameneteket létrehozniuk. Az alkalmazási szinten a munkamenet nélküli modell használata miatt a forrásszámítógépnek és a célszámítógépnek nem kell ugyanazt a hálózati protokollt támogatnia. Az Internet Protocol (IP) és az Internet Packet Exchange (IPX) protokoll is támogatott.
  • Üzenetek priorizálása. Az üzenetek priorizálása lehetővé teszi, hogy a sürgős vagy fontos üzenetek elküldése a kevésbé fontos üzenetek elküldése előtt történjen meg, így megfelelő válaszidő garantálható a kritikus alkalmazások számára a kevésbé kritikus alkalmazások kárára.
  • Garantált üzenetkézbesítés. Az üzenetek egy lemez alapú várólistában tárolhatók, majd később továbbíthatók a garantált kézbesítés érdekében.
  • Tranzakció alapú üzenetkezelés. A tranzakciós lehetőségek segítségével több kapcsolódó művelet egyetlen tranzakcióvá fogható össze, meg lehet bizonyosodni az üzenetek sorrendben történő kézbesítéséről és arról, hogy csak egyszer lettek kézbesítve, valamint ellenőrizni lehet, hogy az üzeneteket sikeresen kiolvasták a várólistából.
  • Várólisták dinamikus létrehozása. Bármikor létre lehet hozni várólistákat vagy módosítani lehet a várólisták tulajdonságait anélkül, hogy az hatással lenne az üzenetkezelő alkalmazásokra.
  • Üzenetek útválasztása. A Message Queuing üzenet-útválasztást biztosít a hálózat fizikai topológiája, a munkamenet-koncentráció követelményei és az átviteli összekapcsolhatóság alapján. A munkamenet-koncentráció megkönnyíti a lassú kommunikációs kapcsolatok hatékony kihasználását.
  • Különböző rendszerek integrálása. A Message Queuing más cégek hálózati termékei révén a hardverplatformok széles skáláján használható.

Ezek a tulajdonságok a Message Queuing szolgáltatást ideálissá teszik félig független ügyfél-kiszolgáló rendszerek (például rendelés/bejegyzés, számlázó és raktárkészlet-kezelő alkalmazások) létrehozására, kötegelt végrehajtásra, várólista alapú ügyfél-kiszolgáló rendszerekhez (az erőforrások érkezési sorrendben történő elérése) és a régi rendszerekről történő átállásra.

A Message Queuing és az elektronikus levelezés közti különbségek

A Message Queuing nem elektronikus levelezésre való alkalmazás, és más szerepet játszik a vállalatoknál. A Message Queuing alkalmazások között továbbít adatokat a különféle számítógépeken elosztott várólistarendszer segítségével.

Ezzel ellentétben a elektronikus levelezés emberek közötti kommunikációt tesz lehetővé. Például a Microsoft Exchange Server az Exchange felhasználói között az üzeneteket egy központi postahivatal és postamappák segítségével továbbítja.

A Message Queuing szolgáltatás azonban azzal egészítheti ki az elektronikus levelezési alkalmazásokat (például a Microsoft Exchange Servert), hogy lehetővé teszi az ügyfelek egymás közötti kommunikációját.

Az elektronikus levelezéssel összehasonlítva a főbb hasonlóságok a következők:

  • Egyik technológiánál sem követelmény, hogy a felhasználók jelen legyenek, amikor valaki üzenetet küld nekik. Mindkét technológia esetén az üzenetek tárolva vannak, és csak ekkor kerülnek továbbításra, ha a címzett elérhető.
  • Mindkét típusú üzenet tartalmazza a feladó és a címzett címét.

Az elektronikus levelezéssel összehasonlítva a főbb különbségek a következők:

  • A Message Queuing használata esetén a feladó és a címzett általában alkalmazás, míg elektronikus levelezés esetén a feladó és a címzett általában valós személy.
  • A Message Queuing üzenetek törzse általában bináris adat, amely csak az üzenetet feldolgozó alkalmazás számára érthető. Az elektronikus levelek törzse általában formázott szöveg, amit bárki megért, aki elolvassa.
  • A Message Queuing alkalmazások számára nem szükséges, hogy a számítógép hálózatra legyen kapcsolva az üzenetek elküldéséhez. Elektronikus levelezés esetén általában szükséges egy kiszolgálóval vagy postahivatallal létrejött kapcsolat.
  • A Message Queuing az elektronikus levelezési alkalmazásokkal ellentétben a különösen gyors kommunikációs átvitelre optimalizált.
  • A Message Queuing biztosítja az üzenetek priorizálását, a garantál kézbesítést és az üzenetek vételének nyugtázását.
  • A Message Queuing lehetőséget biztosít az üzenetek memória alapú, lemez alapú vagy tranzakció alapú továbbítására.

Különféle platformok támogatása

A MSMQ-MQSeries Bridge kiterjeszti a Message Queuing képességeit, és az IBM MQSeries Version 2 és Version 5 platformokkal gürdülékeny tranzakciós kapcsolatot biztosít. Az MSMQ-MQSeries Bridge a Microsoft SNA Server 4.0-s verziójához tartozó 2-es vagy későbbi szervizcsomag része.

A Message Queuing Connector (MQC) a Message Queuing képességeinek kiterjesztésére használható a következő, nem Windows alapú operációs rendszerekkel történő együttműködés érdekében: UNIX, AS/400, Tandem, Digital VMS, CICS/MVS és Unisys ClearPath HMP. Az MQC megtalálható a Windows 2000 Server és a Windows 2000 Advanced Server lemezeken. A teljes megoldás érdekében az MQC-vel együtt kell használni a Level 8 Systems cég által készített ügyfélszoftvert. A Level 8 Systems termékeivel kapcsolatos további tájékoztatásért vegye fel a kapcsolatot a Level 8 Systems céggel, vagy látogassa meg a Level 8 Systems weblapját.(http://www.level8.com/)

Ezek a termékek együttesen használhatók, így segítségükkel vállalati szintű összekapcsolhatóság valósítható meg. Lehet például üzeneteket küldeni egy Message Queuing szolgáltatást futtató UNIX számítógép és egy IBM MQSeries rendszert futtató AS/4000 számítógép között.


A Message Queuing ismertetése

Ez a rész azokat a fogalmakat és kifejezéseket ismerteti, amelyek ismerete feltétlenül szükséges a Message Queuing telepítése és felügyeletének megkezdése előtt.

  • A Message Queuing hálózati topológiája
  • A Message Queuing összetevői
  • A várólista típusa
  • Üzenetek típusa és kézbesítése
  • Üzenet-útválasztás
  • Üzenettárolás
  • Message Queuing objektumok az Active Directory címtárban
  • Message Queuing alapú üzleti forgatókönyvek


A Message Queuing hálózati topológiája

A Message Queuing egy olyan számítógépekből álló üzenetkezelő infrastruktúra, amelyek különféle funkciókat biztosítanak és egy Windows 2000 hálózat tagjai. Ez a rész azt tárgyalja, hogy a Message Queuing számítógépek hogyan vannak összekapcsolva az ilyen hálózatokban.

A Message Queuing használható tartomány és munkacsoport alapú környezetben is. A Message Queuing szolgáltatással kapcsolatban a tartomány környezet címtárszolgáltatást (mint például az Active Directory) biztosító tartományvezérlőket jelent, míg a munkacsoport környezet bármely olyan környezet, amely nem biztosít ilyen címtárszolgáltatást.

Tartománykörnyezet

Tartománykörnyezetben a Message Queuing Windows 2000 tartományvezérlőkön fut, így biztosítva a hozzáférést az Active Directory címtárszolgáltatáshoz. Egy Windows 2000 hálózat tartományainak összességét erdőnek nevezik.

A Message Queuing vegyes módú tartománykörnyezetekben is működhet, ami egymással kommunikáló Windows NT 4.0 rendszeren futó MSMQ 1.0 vezérlőkiszolgálókból és Windows 2000 rendszeren futó Message Queuing kiszolgálókból álló tartományt jelent.

Helyek

Tartománykörnyezetben a Message Queuing hálózat több különböző Windows 2000 helyre van felosztva, amelyek útválasztási kapcsolatok segítségével vannak összekapcsolva. A helyek a hálózat fizikai felépítését képezik le, míg a tartományok általában a vállalat logikai felépítését. A logikai és a fizikai felépítések egymástól függetlenek, tehát akár egyetlen helyen létezhet több tartomány, vagy egyetlen tartományban létezhet több hely.

A Message Queuing szolgáltatással kapcsolatban egy hely a következőkből állhat:

  • Windows 2000 tartományvezérlőkből, amelyek a konfigurációs és állapotinformációkat az Active Directory címtárszolgáltatásban tárolják, és amelyek az ilyen információkat a helyek között helyhivatkozások segítségével replikálják. Az Active Directory az úgynevezett többfőtartományos modellt valósítja meg, amely azt jelenti, hogy bármely Windows 2000 tartományvezérlő olvashatja vagy írhatja az Active Directory címtárban tárolt objektumokat.
  • Windows 2000 számítógépekből, amelyek mindegyike ugyanazt a hálózati protokollt használja (általában IP). Egy hely bármely két számítógépe, amely ugyanazt a hálózati protokollt használja, közvetlenül összekapcsolható egymással. Az ilyen összeköttetés gyors és olcsó kommunikációt jelent.
  • Társított alhálózatokból, amelyek mindegyike egyetlen IP alhálózati címmel rendelkezik.

Amikor egy Message Queuing ügyfél egy Message Queuing kiszolgálóval kommunikál, a kérelmet egy ugyanazon a helyen lévő, előre meghatározott kiszolgálóhoz irányítja, ha van ilyen.

A Windows 2000 helyekkel kapcsolatos további tájékoztatásért tanulmányozza a Helyek című témakört.

Megjegyzés

  • Egy helyhez már nem tartozik speciális meghatározás, mint az MSMQ 1.0 esetében. MSMQ 1.0-ról történő frissítés esetén minden MSMQ 1.0 hely egy Windows 2000 helyre lesz leképezve, és minden régi idegen összekapcsolt hálózat egy vagy több idegen helyre lesz leképezve. Ha MSMQ 1.0-ról frissít, a változások listáját megtalálja a A Message Queuing frissítése - áttekintés című részben.

Útválasztási kapcsolatok

Tartomány alapú környezetben az útválasztási kapcsolatok a Message Queuing által a különböző helyek közötti üzenettovábbításhoz létrehozott logikai kommunikációs kapcsolatok, amelyek mindegyik helyen egy-egy Message Queuing kiszolgálót jelentenek. Az ezt a funkciót ellátó Message Queuing kiszolgálók neve helykapu. Ha egy útválasztási kapcsolat két helykapuval van meghatározva, csak ezek a kiszolgálók továbbíthatnak üzeneteket a meghatározott helyek között.

A hálózaton a helyek közötti üzenettovábbításhoz több útválasztási kapcsolat is használható a terheléselosztás és a redundancia érdekében. Ebben az esetben minden útválasztási kapcsolathoz hozzá lehet rendelni kapcsolatköltséget annak eldöntése érdekében, hogy melyik kapcsolaton keresztül történjen az üzenetek továbbítása (alapértelmezett kapcsolat). Az útválasztási kapcsolatok költségei jelenthetik a relatív sávszélességet vagy a kapcsolaton keresztül történő kommunikáció költségét.

Az útválasztási kapcsolatokat nem szabad összekeverni a helyhivatkozásokkal. Az útválasztási kapcsolatokat Message Queuing kiszolgálók használják a helyek közötti üzenettovábbításra. A helyhivatkozásokat tartományvezérlők használják az Active Directory információinak helyek közötti replikálására.

Az üzenetek hálózaton keresztüli útválasztásával kapcsolatos további tájékoztatásért tanulmányozza az Üzenet-útválasztás című fejezetet.

Munkacsoport alapú környezet

A Message Queuing szolgáltatás futtatható olyan környezetben, amely nem tagja tartománynak, például egy munkacsoportban, vagy bármely olyan környezetben, amely nem biztosít címtárszolgáltatást. Ha a Message Queuing olyan számítógépen fut, amely egy munkacsoport tagja, a számítógép később csatlakozhat egy Windows 2000 tartományhoz. Fordítva, egy Message Queuing számítógép tagja lehet egy tartománynak, majd később csatlakozhat egy munkacsoporthoz. Ez a számítógép később újra csatlakozhat ugyanahhoz a tartományhoz.

A következő korlátozások érvényesek a Message Queuing nem tartomány alapú környezetben történő használata esetén:

  • Az ilyen számítógép által küldött üzeneteket nem tudja Message Queuing kiszolgáló továbbítani, ezért a célszámítógéppel közvetlen összeköttetés szükséges.
  • Nem lehet hozzáférni Active Directory címtárszolgáltatáshoz. Ezért helyi számítógépen csak privát várólistákat lehet létrehozni és kezelni. Nem lehet nyilvános várólistákat vagy az Active Directory más adatait kezelni vagy megtekinteni. Azonban közvetlen kapcsolat esetén a privát várólistákra lehet üzeneteket küldeni, vagy onnan üzenetek olvasni.
  • Hitelesített üzenetek küldéséhez nem lehet belső bizonyítványokat használni; ehelyett külső bizonyítványt kell használni. A felhasználói bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a Felhasználói bizonyítványok című témakört.


A Message Queuing összetevői

A Message Queuing olyan számítógépekből álló üzenetkezelési infrastruktúra, amelyek különféle funkciókat biztosítanak és csatlakoznak egy hálózathoz. Ez a fejezet a Message Queuing szoftverösszetevőit ismerteti. Ezek a szoftverösszetevők határozzák meg a Message Queuing számítógépek által a hálózaton nyújtott szolgáltatásokat.

Message Queuing kiszolgálók

A Message Queuing kiszolgálók biztosítják a kommunikáció gerincét a Message Queuing hálózatban. Minden Message Queuing kiszolgáló futtatja a Message Queuing szolgáltatást, helyet ad a várólistáknak, helyileg tárolja az üzeneteket, valamint alapértelmezés szerint képes üzeneteket küldeni és fogadni.

A Message Queuing kiszolgálók tervezési információival kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing kiszolgáló hardverelemeinek kiválasztása című részt.

A Message Queuing kiszolgálók az alábbi kiegészítő szolgáltatásokat nyújtják:

Címtárhozzáférés

A Windows 2000 tartományvezérlőkre telepített Message Queuing kiszolgálók alapértelmezés szerint lehetővé teszik az ügyfélszámítógépek számára az Active Directory címtárszolgáltatásban szereplő információk megtekintését és módosítását.

A Windows 2000 tartományvezérlőkkel kapcsolatos általános tudnivalókért tanulmányozza a Tartományvezérlők című részt.

Útválasztási szolgáltatások

Az engedélyezett útválasztási szolgáltatással telepített Message Queuing kiszolgálók üzenet-útválasztást valamit “tárolás és továbbítás” alapú üzenetsor-kezelést biztosítanak. Ezek a kiszolgálók továbbítani tudják az üzeneteket egy helyen belül vagy különböző helyek között, ha nincs közvetlen kapcsolat az ügyfélszámítógépek között. Azokat a Message Queuing kiszolgálókat, amelyek üzenet-útválasztási funkciókat biztosítanak egy helyen belül, bemenő útválasztó kiszolgálóknak (InRS) vagy kimenő útválasztó kiszolgálóknak (OutRs) nevezik. A helyek közötti üzenet-útválasztást biztosító Message Queuing kiszolgálókat helykapuknak nevezik. Tehát két helykapu egy útválasztási kapcsolatot határoz meg két hely között.

Bár az egy helyhez tartozó, ugyanazt a hálózati protokollt használó ügyfelekről feltételezhető, hogy közvetlen kapcsolatban vannak, a bemenő és a kimenő útválasztó kiszolgálóknak a helyen belüli üzenettovábbításra történő használata csökkentheti a hálózaton a sávszélesség-követelményeket. Az ügyfelek beállíthatók kimenő és bemenő útválasztó kiszolgálók használatára annak érdekében, hogy azok végezzék el helyettük az útválasztást. Ebben az esetben az ügyfél által küldött vagy fogadott üzenetek először egy Message Queuing kiszolgálón mennek keresztül. Az ügyfél kifejezés itt bármely olyan számítógépet jelenthet, amely nem hajt végre üzenet-útválasztást, például egy függő ügyfelet vagy olyan Message Queuing kiszolgálót, amelyen az útválasztás nincs engedélyezve. Ez a szolgáltatás nem vonatkozik a függő ügyfelekre. A függő ügyfelek egy támogató kiszolgálót használnak üzeneteik küldéséhez és fogadásához.

Ha az üzenetek helyek közötti továbbítása helykapuk segítségével történik, csak ezek a Message Queuing kiszolgálók továbbíthatnak üzeneteket a helyek között. A Message Queuing kiszolgálókat be lehet állítani úgy, hogy engedélyezzék a kommunikációt a különböző hálózati protokollt (például IP és IPX) használó számítógépek között.

Fürtszolgáltatások

A Message Queuing kiszolgálók fürtcsoportok számára is nyújtanak szolgáltatásokat. Egy Message Queuing kiszolgáló kiszolgálófürtre történő telepítése során létrejön egy Message Queuing erőforrás, amely hozzáadódik a “fürtözött virtuális kiszolgáló” nevű fürtcsoporthoz. A fürtözött virtuális kiszolgáló olyan fürtcsoport, amely tartalmaz Lemez és Hálózati név erőforrásokat. A fürtözött virtuális kiszolgáló hasonlóan működik, mint egy fizikai számítógépen futó kiszolgáló, tehát egy fürtözött virtuális kiszolgálón futó Message Queuing kiszolgáló hasonlóan működik, mint egy fizikai számítógépen futó Message Queuing kiszolgáló.

A Message Queuing alkalmazások kommunikálhatnak a kiszolgálófürt egy számítógép-csomópontján futó szabványos Message Queuing kiszolgálóval, vagy ha a Message Queuing alkalmazások fel vannak készítve a fürtök kezelésére, kommunikálhatnak a fürtözött virtuális kiszolgálón futó virtuális Message Queuing kiszolgálóval. Több fürtözött virtuális kiszolgáló (és így több virtuális Message Queuing kiszolgáló) is futhat egyetlen kiszolgálófürtön.

Ha a Message Queuing egy fürtözött virtuális kiszolgálón fut, a nyújtott szolgáltatástípusok a csomóponton telepített Message Queuing kiszolgáló konfigurációjától függnek. Például ha egy Message Queuing kiszolgálót, amelyen az útválasztási szolgáltatás engedélyezve van, egy kiszolgálófürt csomópontjára telepítenek, egy útválasztást biztosító Message Queuing kiszolgáló a csomóponttal társított fürtözött virtuális kiszolgálón is elérhető lesz. Ez alól kivételt képeznek azok a csomópontok, amelyek Windows 2000 tartományvezérlők. A tartományvezérlő csomópontokon futó Message Queuing kiszolgálók hozzáférést biztosítanak az Active Directory címtárszolgáltatáshoz. Azonban ugyanezek a kiszolgálók egy fürtözött virtuális kiszolgáló környezetben nem képesek hozzáférést biztosítani az Active Directory címtárszolgáltatáshoz.

A Windows 2000 Advanced Server kiszolgálófürtjeivel kapcsolatos további tájékoztatásért tanulmányozza a Kiszolgálófürtök című részt.

Független ügyfelek

A független ügyfelek futtatják a Message Queuing szolgáltatást, helyet adnak a várólistáknak, üzeneteket küldenek és fogadnak, valamint alapértelmezés szerint akkor is működnek, ha nincsenek a hálózatra kapcsolva. A független ügyfeleknek nem kell szinkron kapcsolatban lenni egy Message Queuing kiszolgálóval ahhoz, hogy üzeneteket küldjenek vagy fogadjanak. A független ügyfelek és a Message Queuing kiszolgálók közti elsődleges különbség az, hogy a független ügyfelek nem biztosítanak hozzáférést az Active Directory címtárszolgáltatáshoz, valamint nem biztosítanak üzenet-útválasztást (ellentétben azokkal a Message Queuing kiszolgálókkal, amelyeken az útválasztás engedélyezett).

A független ügyfelek és azok a Message Queuing kiszolgálók, amelyeken nincs engedélyezve az útválasztás, hasonló szolgáltatásokat nyújtanak, azzal a különbséggel hogy a független ügyfelek csak Windows 2000 Professional rendszeren, a Message Queuing kiszolgálók pedig csak Windows 2000 Server vagy Windows 2000 Advanced Server rendszeren futhatnak. Ebben a tárgyalásban a független ügyfél és az ilyen Message Queuing kiszolgáló (ha nem tartományvezérlőre van telepítve) felcserélhető.

Ha egy független ügyfelet (vagy egy azzal egyenértékű Message Queuing kiszolgálót) lekapcsolnak a hálózatról, az továbbra is létrehozhat más számítógépeknek szóló üzeneteket. A független ügyfél helyileg tárolja ezeket az üzeneteket, és automatikusan elküldi őket, amint a hálózati kapcsolat helyreállt.

Mobil felhasználás

A mobil független ügyfelek, például amelyek hordozható számítógépre vannak telepítve, képesek üzeneteket küldeni és fogadni, miközben helyüket változtatják. Amikor egy független ügyfél például egy új helyhez kapcsolódik, az összes üzenet, amit addig küldtek az ügyfélnek, amíg nem volt a hálózatra kapcsolva, át lesz irányítva a régi helyről az új helyre. Ha az új helyet megadják a hálózatról történő lecsatlakozás előtt, az összes üzenet rögtön az új helyre kerül.

Az ügyfelek beállíthatók Message Queuing kiszolgálók (bemenő és kimenő útválasztó kiszolgálók) használatára, hogy azok végezzék el a helyen az útválasztást. Ha egy ilyen ügyfél egy másik helyre kerül, a rendszer az új helyen nem használja ezeket a bemenő és kimenő útválasztó kiszolgálókat az üzenetek továbbítására. Amikor a független ügyfél visszatér az eredeti helyére, a rendszer újra ugyanazokat a Message Queuing kiszolgálókat használja az üzenetek továbbítására.

Ha egy független ügyfél vegyes módú, tartomány alapú környezetben működik, ahol Windows NT alatt futó MSMQ 1.0 vezérlőkiszolgálóval kommunikálnak, a következő állítások érvényesek: Amikor egy független ügyfél másik helyre kerül, az ügyfél automatikusan felismeri, hogy melyik helyen tartózkodik. A hálózatra történő újrakapcsolódáskor az ügyfél kiküld egy szórásos üzenetet, és figyeli az arra érkező összes választ. Ha válaszol egy olyan Message Queuing kiszolgáló, amely nem az ügyfélhez az eredeti helyen hozzárendelt kiszolgáló, és ha ez a kiszolgáló képes kommunikálni az ügyfél eredeti helyén lévő kiszolgálóval, az ügyfél csatlakozik a hálózathoz, és az új helyet használja. Ha a válaszoló kiszolgálók egyike az, amelyik az ügyfélhez az eredeti helyen van hozzárendelve, a független ügyfél nem csatlakozik az új helyhez.

Windows CE használata

A független ügyfél egy speciális változata található a Windows CE 3.0 (vagy újabb) operációs rendszert futtató hordozható számítógépeken is. A kapacitásbeli követelmények és az RPC-támogatás hiánya miatt a független ügyfél Windows CE változatára a következő korlátozások vonatkoznak:

  • Nincs Active Directory támogatás. A Windows CE független ügyfelek nem tudják lekérdezni a Windows 2000 tartományvezérlőkön futó Message Queuing kiszolgálókat.
  • Korlátozott üzenet-útválasztás.
  • Nyilvános várólisták korlátozott támogatása.
  • Nincs üzenethitelesítés és -titkosítás. A más Message Queuing számítógépek által küldött vagy fogadott üzenetek egyszerű szövegként továbbítódnak.
  • Nem lehet az üzeneteket távolról elolvasni. A más Message Queuing számítógépeken tárolt üzeneteket nem lehet elolvasni a Windows CE független ügyfélről.
  • Nem végezhetők több üzenetet igénylő tranzakciók.
  • Más platformok nem támogatottak. Más üzenetkezelő rendszert futtató számítógépeknek nem lehet üzeneteket küldeni, illetve azoktól üzeneteket fogadni.

Függő ügyfelek

A függő ügyfeleknek egy Message Queuing kiszolgálóhoz (támogató kiszolgálóhoz) történő szinkron hozzáférésre van szükségük minden művelet végrehajtásához. A függő ügyfél helyett minden műveletet a támogató kiszolgálója hajt végre, például a várólisták és az üzenetek tárolását, az üzenetek küldését és fogadását.

Emiatt és más korlátozások miatt amikor csak lehetséges, célszerű független ügyfeleket használni függő ügyfelek helyett. További tájékoztatásért tanulmányozza A függő ügyfelekkel kapcsolatos megfontolások című részt.

MSMQ-Exchange összekötő

Az MSMQ-Exchange összekötő lehetőséget biztosít a Microsoft Exchange felhasználói számára a Message Queuing alkalmazásokhoz történő hozzáférésre. A MSMQ-Exchange összekötő segítségével elektronikus leveleket lehet küldeni a Message Queuing alkalmazásoknak, valamint Message Queuing levélüzeneteket lehet küldeni a Microsoft Exchange felhasználóinak.

Az MSMQ-Exchange összekötő a javasolt megoldás a Microsoft Exchange felhasználói és a Message Queuing alkalmazások összekapcsolására. Egy Exchange szervezetben csak egy MSMQ-Exchange összekötőre van szükség.

Amikor egy Message Queuing ügyfél egy Exchange ügyfélnek küld üzenetet, akkor az üzenet először a Message Queuing kiszolgáló egyik várólistájába kerül, majd onnan az MSMQ-Exchange összekötő továbbítja az Exchange ügyfélnek azon az Exchange kiszolgálón keresztül, amelyikkel az MSMQ-Exchange összekötő kommunikál. A Microsoft Exchange ügyfelek a Message Queuing ügyfelek várólistacímeit a megosztott Exchange címjegyzéken keresztül érhetik el.

MSMQ-MAPI szállítási szolgáltató

Az MSMQ-MAPI szállítási szolgáltató lehetővé teszi a MAPI ügyfélalkalmazások (például a Microsoft Exchange ügyfelek) és az Message Queuing alkalmazások összekapcsolását. Az MSMQ-MAPI szállítási szolgáltató az elektronikus levelek és a Message Queuing levélüzenetek között fordít. A MAPI-ügyfelek az MSMQ-MAPI szállítási szolgáltató segítségével tudnak elektronikus leveleket cserélni a Message Queuing alkalmazásokkal.

Az MSMQ-MAPI szállítási szolgáltató a következőkben különbözik az MSMQ-Exchange összekötőtől:

  • Az MSMQ-MAPI szállítási szolgáltató lehetővé teszi bármely MAPI-ügyfél számára, hogy üzeneteket küldjön Message Queuing ügyfeleknek, vagy üzeneteket fogadjon tőlük. Az MSMQ-Exchange összekötő csak a Microsoft Exchange ügyfelek számára teszi lehetővé, hogy üzeneteket küldjenek Message Queuing ügyfeleknek, vagy üzeneteket fogadjanak tőlük.
  • Az MSMQ-MAPI szállítást minden MAPI ügyfélszámítógépre telepíteni kell, amely a Message Queuing szolgáltatást használja üzenetek küldésére vagy fogadására. Az MSMQ Exchange összekötőt elég egyetlen Message Queuing kiszolgálóra telepíteni egy Exchange szervezetben.
  • Minden MAPI-ügyfél saját várólistával rendelkezik a bejövő üzenetek tárolására, amelyet az MSMQ-MAPI szállítási szolgáltató hoz létre. A Microsoft Exchange ügyfelek egyetlen várólistán keresztül kapják meg az üzeneteket, amit az MSMQ-Exchange összekötő hoz létre.
  • Az MSMQ-MAPI szállítást használó MAPI-ügyfelek csoportja számára bonyolultabb megosztani a várólisták címeit. Minden MAPI-ügyfélnek tárolnia kell a Message Queuing ügyfelek várólistáinak címeit egy helyi személyes címjegyzékben (PAB). A Microsoft Exchange ügyfelek a várólisták címeit a megosztott Exchange címjegyzéken keresztül érhetik el.

Az MSMQ-MAPI szállítási szolgáltató alapértelmezés szerint telepítésre kerül a Message Queuing telepítése során.

MSMQ-RPC szállítási szolgáltató

Az MSMQ-RPC (távoli eljáráshívás) szállítási szolgáltató megbízható átvitelként használható RPC alapú aszinkron Message Queuing alkalmazások számára.

A Message Queuing hitelesített RPC szolgáltatást használ az összes tartományvezérlővel történő kommunikációhoz. Az összes RPC-kapcsolatot először egy tartományvezérlő hitelesíti. A tartományvezérlőnek működnie kell, ellenkező esetben a Message Queuing ügyfelek nem tudják elolvasni az MSMQ-RPC szállítási szolgáltató használatával küldött üzeneteket.

Az MSMQ-RPC szállítási szolgáltató alapértelmezés szerint telepítésre kerül a Message Queuing telepítése során.

Összekötő alkalmazások és idegen számítógépek

A Message Queuing ügyfelek az idegen számítógépekkel összekötő alkalmazások segítségével tudnak kommunikálni. Az idegen számítógépek a Message Queuing által nem támogatott operációs rendszereket futtatnak, vagy más üzenetküldő rendszereket használnak. Az összekötő alkalmazások a Message Queuing kiszolgálókon futnak, és lehetővé teszik az idegen számítógépek számára a Message Queuing ügyfelekkel történő kommunikációt. Az összekötő alkalmazást futtató Message Queuing kiszolgálókon általában két további várólista található, amelyeket összekötő várólistáknak neveznek: egy a tranzakció alapú üzenetek számára, egy pedig a nem tranzakció alapú üzenetek számára. Amikor egy Message Queuing ügyfél egy idegen számítógépnek küld üzenetet, az üzenet először a Message Queuing kiszolgáló egyik összekötő várólistájába kerül, majd onnan kerül továbbításra az idegen számítógép felé.

Összekötő alkalmazás például az MSMQ-MQSeries Bridge, amely az IBM MQSeries programot futtató számítógép-platformokkal biztosít kapcsolatot, és a Message Queuing Connector (MQC), amely a nem Windows alapú platformokon futó Message Queuing alkalmazásokkal biztosít kapcsolatot.

Az MSMQ-MQSeries Bridge a Microsoft SNA Server 4.0-s verziójához tartozó 2-es vagy későbbi szervizcsomag része.

Az MQC megtalálható a Windows 2000 Server és a Windows 2000 Advanced Server lemezeken. A nem Windows alapú operációs rendszert használó idegen számítógépekre történő üzenetküldéshez először be kell szerezni és az összes idegen ügyfélen telepíteni kell a Level 8 Systems cég ügyfél programját. Ha további tájékoztatásra van szüksége, vegye fel a kapcsolatot a Level 8 Systems céggel, vagy látogassa meg a Level 8 Systems webhelyét.


A várólista típusa

A Message Queuing szolgáltatás vonatkozásában a várólisták különböző típusú üzenetek átmeneti tárolóhelyeit jelentik. Az alábbiakban a Message Queuing várólistáinak különböző típusairól, és azok céljairól lesz szó.

Nyilvános várólisták

Tartomány alapú környezetben a nyilvános várólisták azok a várólisták, amelyek közzé vannak téve az Active Directory címtárszolgáltatásban, és így replikálva vannak a teljes Windows 2000 erdőben. Ezeknek a várólistáknak csak a tulajdonságaik jelennek meg, maguk a várólisták vagy a tartalmuk nem. Egy Windows 2000 erdő bármely számítógépe elérheti a nyilvános várólisták információit.

Nyilvános várólisták nem léteznek munkacsoport alapú környezetben.

Privát várólisták

A privát várólisták nincsenek közzétéve az Active Directory címtárszolgáltatásban, és csak az őket tartalmazó helyi számítógépen jelennek meg. A privát várólistákhoz csak azok a Message Queuing alkalmazások férhetnek hozzá, amelyek ismerik a várólista teljes elérési útvonalát vagy formátumnevét. A rendszervárólista a privát várólista egy típusa.

Naplóvárólisták

Az üzenetmásolatok tárolásának folyamatát naplózásnak nevezik. Ezeket a másolatokat, a naplóüzeneteket a rendszer naplóvárólistákban tárolja. Kétféle naplózás létezik: forrásnaplózás és célnaplózás.

Forrásnaplózás

A forrásnaplózás során a kimenő, nem tranzakció alapú üzenetek kerülnek tárolásra a forrásszámítógépen. Ezt a tulajdonságot a Message Queuing alkalmazások programon keresztül állíthatják be minden üzenetre külön-külön. A forrásnaplózás alapértelmezés szerint ki van kapcsolva.

Ha a forrásnaplózás engedélyezve van egy nem tranzakció alapú üzenetre vonatkozóan, a kimenő üzenet egy másolata bekerül a forrásszámítógép forrás-naplóvárólistájába. Ez vagy akkor történik meg, amikor az üzenet megérkezik a célszámítógépre, vagy ha egy olyan Message Queuing kiszolgálóra érkezik meg, amely egy ugrással közelebb van a célszámítógéphez. Az ügyfelek üzeneteit továbbító Message Queuing kiszolgálók nem tárolnak másolatokat az ilyen üzenetekről a forrás-naplóvárólistájukban.

A függő ügyfelek kimenő üzenetei a támogató Message Queuing kiszolgáló forrás-naplóvárólistájába kerülnek.

Célnaplózás

A célnaplózás során a bejövő üzenetek másolatai kerülnek tárolásra a célszámítógépen. A célnaplózást minden várólistára külön lehet meghatározni. Engedélyezése esetén minden bejövő üzenetről másolat készül a cél-naplóvárólistában, amikor egy üzenetet elolvasnak (eltávolítja azokat egy Message Queuing alkalmazás). Minden várólistához automatikusan létrejön egy cél-naplóvárólista (melynek neve Naplóüzenetek). A célnaplózás alapértelmezés szerint ki van kapcsolva.

Kézbesítetlen üzenetek várólistája

A kézbesíthetetlen és a lejárt, nem tranzakció alapú üzenetek a kézbesítetlen üzenetek várólistájába kerülnek. A kézbesíthetetlen és a lejárt, tranzakció alapú üzenetek a tranzakciós kézbesítetlen üzenetek várólistájába kerülnek. Ezek az üzenetek annak a számítógépnek a várólistájában kerülnek tárolásra, amelyiken az üzenet lejár (vagy nem lehet onnan kézbesíteni vagy továbbítani). Ez lehet a forrásszámítógép, a célszámítógép vagy egy közbülső Message Queuing kiszolgáló.

Minden Message Queuing kiszolgálón és független ügyfélen létezik egy kézbesítetlen üzenetek várólista és egy tranzakciós kézbesítetlen üzenetek várólista. Ezek a várólisták automatikusan jönnek létre.

A kézbesítetlen üzenetek várólistában és a tranzakciós kézbesítetlen üzenetek várólistában lévő üzeneteket a rendszer mindig lemezre írja, így azok visszaállíthatók.

Ha a küldő alkalmazás biztonsági korlátozások miatt nem tud üzeneteket küldeni egy várólistára, ezek az üzenetek nem kerülnek be a kézbesítetlen üzenetek várólistába vagy a tranzakciós kézbesítetlen üzenetek várólistába. Azonban ha be van állítva, a rendszer nemleges nyugtázóüzenetet küldhet.

Az üzenetek a következő esetekben tekinthetők kézbesíthetetlennek:

  • A célvárólistát nem ismeri a küldő.
  • Az üzenet túllépi a maximálisan megengedett ugrásszámot.
  • A várólista tárolási határának vagy kvótájának elérése esetén.
  • Nem tranzakció alapú üzenet tranzakció alapú várólistába küldése esetén, vagy fordítva.
  • Tranzakció alapú üzenetek esetén, ha a küldési vagy vételi tranzakció sikertelen. A vételi tranzakció sikertelensége esetén az üzenetek nem kerülnek be a tranzakciós kézbesítetlen üzenetek várólistába.

Az üzenetek a következő esetekben tekinthetők lejártnak:

  • Az üzenetek hálózati élettartama, a várólista-elérési időkorlát (TTRQ) lejár. (Ez a Message Queuing alkalmazásokkal, programon keresztül állítható be.)
  • Az üzenet kézbesítési időkorlátja (TTBD) lejár. (Ezt mindig a Message Queuing alkalmazások állítják be.)

A tranzakció alapú üzenetküldéssel kapcsolatos további tudnivalókért tanulmányozza a Tranzakció alapú üzenetkezelés című témakört.

Felügyeleti várólisták

A Felügyeleti várólisták az elküldött üzenetek nyugtázó üzeneteit tartalmazzák; a nyugtázó üzenet kérését a küldő alkalmazás írja elő az üzenetek elküldésekor. Bármely rendelkezésre álló, nem tranzakció alapú várólista meghatározható felügyeleti várólistaként.

A felügyeleti várólisták nem tartalmaznak felügyeleti üzeneteket; azokat a rendszervárólista tartalmazza.

Válaszvárólisták

A válaszvárólisták a fogadó alkalmazás által a küldő alkalmazásnak visszaküldött válaszüzeneteket tartalmazzák. A válaszvárólistákat programból adhatja meg a küldő alkalmazás egy üzenet elküldésekor. Bármely rendelkezésre álló várólista megadható válaszvárólistaként.

Ha a válaszvárólistára és a felügyeleti várólistára is szükség van, ezek egyetlen várólistává egyesíthetők. Mivel azonban a felügyeleti várólistáknak nem tranzakció alapúaknak kell lenniük, ez a várólista csak nem tranzakció alapú üzeneteket képes fogadni.

A válaszüzenetek nem egyeznek meg a felügyeleti válaszüzenetekkel, amelyek tárolása a rendszervárólistában történik.

Jelentés-várólisták

A jelentés-várólisták jelentésüzeneteket tartalmaznak, amelyek az üzenet által a cél eléréséig bejárt utat, valamint az esetleges tesztüzeneteket tartalmazzák. Egy számítógépen csak egyetlen jelentés-várólista lehet. A jelentés-várólista csak akkor engedélyezhető, ha az üzenet útvonalának nyomon követése is engedélyezve van.

Rendszervárólisták

A Message Queuing akár öt rendszervárólistát is használhat. Mind az öt rendszervárólista privát várólista, ami azt jelenti, hogy nincsenek közzétéve az Active Directory címtárban. A rendszervárólisták nem törölhetők.

Az alábbi táblázatban a rendszervárólisták és használatuk látható:

Rendszervárólista | Használat
admin_queue$ | Felügyeleti üzenetek tárolása
msmqadminresp$ | Felügyeleti válaszüzenetek tárolása (az MQPing üzenetek kivételével)
mqis_queue$ | Visszaküldött MQPing üzenetek tárolása
notify_queue$ | Értesítő üzenetek tárolása. Ezek az üzenetek tartalmazzák a számítógép és a várólista tulajdonságainak a változásait, a várólisták létrehozását és törlését is beleértve.
order_queue$ | A megadott sorrendű kézbesítést igénylő tranzakció alapú üzenetek nyomon követése.


Üzenetek típusa és kézbesítése

A Message Queuing szolgáltatás vonatkozásában az üzenet az üzenettörzset és különféle tulajdonságokat jelent. Az üzenettörzs szöveget vagy bármilyen bináris adatot tartalmazhat, ami titkosítható. Az üzenetek legtöbb tulajdonságát a Message Queuing alkalmazások határozzák meg. Egyes tulajdonságokat, mint például a feladó biztonsági azonosítóját (SID) és az üzenet azonosítóját a Message Queuing határozza meg. Az üzenettulajdonságok nem titkosíthatók. Egy üzenet az üzenettörzzsel és a tulajdonságokkal együtt, nem lehet 4 megabájtnál (MB) nagyobb méretű.

Az üzenetek hitelesíthetők és titkosíthatók. Az üzenethitelesítéssel kapcsolatos további tájékoztatásért tanulmányozza az Üzenetek hitelesítése című fejezetet. Az üzenettitkosítással kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing titkosítása című részt.

Az üzenetek megkülönböztethetők típusuk, prioritásuk és kézbesítési módjuk szerint. Ebben a fejezetben ezeket a fogalmakat tárgyaljuk.

Az üzenet típusa

Az üzenet típusa (az üzenet osztálya) az üzenet funkcióját vagy rendeltetését mutatja. A támogatott üzenettípusok a következők:

  • Normál üzenetek. A Message Queuing alkalmazások által létrehozott minden üzenet normál üzenet. Normál üzeneteket lehet küldeni nyilvános, privát, napló-, kézbesítetlen üzenetek és tranzakciós várólistákba. A normál üzenetek nem tartalmaznak állapotinformációkat; ezeket az információkat a nyugta-, a jelentés- és a válaszüzenetek tartalmazzák.
  • Nyugtaüzenetek. A nyugtaüzenetek a normál üzenetek állapotát jelzik. Ezek az üzenetek lehetnek pozitívak vagy negatívak, és a rendszer a felügyeleti várólistára küldi ezeket. A pozitív nyugtaüzenet azt jelzi, hogy az üzenet megérkezett a célszámítógépre, és azt, hogy elolvasták-e (eltávolította-e a fogadó alkalmazás). A negatív nyugtaüzenet azt jelzi, hogy hiba történt, mielőtt az üzenetet a célszámítógépre kézbesíteni lehetett volna, illetve hogy az üzenetet miért nem olvasták el.
  • Jelentésüzenetek. A jelentésüzenetek közé a forrásszámítógép jelentés-várólistáiba küldött tesztüzenetek és nyomkövető üzenetek tartoznak.
  • Válaszüzenetek. A válaszüzenetek a fogadó alkalmazás által abba a válaszvárólistába küldött üzenetek, amelyet a küldő alkalmazás határoz meg.

Ha további tájékoztatásra van szüksége azokkal a várólistákkal kapcsolatban, amelyekbe üzenetek küldhetők, tanulmányozza A várólista típusa című részt.

Az üzenetek prioritása

Az üzeneteknek a célszámítógépre történő küldési sorrendjét, a prioritást, először a várólista-prioritás (az alapprioritás), majd az üzenetprioritás határozza meg. Az Active Directory címtárban szereplő nyilvános várólisták prioritása -32768 és 32767 között lehet. Az alapértelmezett várólista-prioritás 0. A Message Queuing alkalmazások az üzenetprioritást 0 és 7 között állítják be; a legnagyobb prioritást a 7-es prioritás jelenti.

Az üzenetek nyilvános várólistába történő küldése a célvárólista prioritásának és az egyes üzenetek prioritásának az összege alapján történik. Az így előálló legmagasabb prioritással rendelkező üzeneteket küldi el először a rendszer.

Privát várólisták esetén nem használható a várólista-prioritás. A privát várólistákba a rendszer az üzenetprioritás alapján küldi az üzeneteket.

Üzenetkézbesítés

Kétféle üzenetkézbesítési módszer használható: sürgős és helyreállítható. Lényegében a minimális erőforrás-használat melletti jobb teljesítmény (sürgős kézbesítés) és a megbízhatóság és a meghibásodás utáni helyreállítás (helyreállítható kézbesítés) között kell választani. Az üzenet kézbesítési módját a küldő alkalmazás programon keresztül határozza meg.

A helyreállítható üzenetküldés tovább osztható tranzakció alapú és nem tranzakció alapú üzenetküldésre.

Sürgős üzenetküldés

A sürgős üzenetküldés azt jelenti, hogy az üzenetek továbbítása és kézbesítése során azok tárolása a memóriában történik, ami nagy teljesítményt biztosít, de ha meghibásodik egy számítógép, amelyiken az üzenet keresztülhalad, nem lehet az üzenetet helyreállítani. A Message Queuing szolgáltatás leállítása esetén a sürgős üzenetek elvesznek.

Ha túl sok sürgős üzenet gyűlik össze a RAM-ban, akkor az üzenetek a lapozófájlba kerülnek, ami a teljesítmény csökkenéséhez vezet. Ezért nem ajánlott több sürgős üzenetet tárolni, mint amennyi számára hely van a fizikai memóriában.

A sürgős üzenetek azonban nem vesznek el hálózati meghibásodás esetén. Például ha egy Message Queuing alkalmazás egy Message Queuing kiszolgálón keresztül küld sürgős üzeneteket, és a Message Queuing kiszolgáló és a célszámítógép közötti hálózati kapcsolat meghibásodik, az üzenet a Message Queuing kiszolgáló memóriájában marad. Azonban ha a Message Queuing kiszolgáló a hálózati kapcsolat helyreállása előtt meghibásodik, az üzenetek elvesznek.

Vigyázat!

  • A Message Queuing szolgáltatás kiszolgálófürtön történő futtatása esetén az üzenetek elvesznek egy másik csomópontra történő áttérés esetén.

Helyreállítható üzenetküldés

A helyreállítható üzenetküldés használata azt jelenti, hogy az üzeneteket a továbbítás és a kézbesítés során a rendszer a lemezre írja, ami ugyan lassítja a kézbesítést a sürgős üzenetekhez viszonyítva, azonban hasznos a nem elviselhető meghibásodások esetén, vagy ha a számítógépet úgy kapcsolják ki, hogy a várólistákban vannak üzenetek (például hordozható számítógépek mobil ügyfelein). Ha egy számítógép meghibásodik, vagy kikapcsolják egy üzenet küldése közben, az üzenet megmarad a lemezen. A számítógép újraindítása esetén, amikor a Message Queuing szolgáltatás újraindul, a küldési folyamat folytatódik.

A rendszer minden helyreállítható üzenetet a lemezen memórialeképező fájlstruktúrában tárol. A teljesítmény növelhető, ha több fizikai lemezt használ a helyreállítható üzenetek tárolására. Ha további információra van szüksége, olvassa el a Lemezzel kapcsolatos megfontolások című részt.

Tranzakció alapú üzenetküldés

A helyreállítható üzenetküldés tovább osztható tranzakció alapú és nem tranzakció alapú üzenetküldésre. A tranzakció alapú üzenetek küldése és fogadása tranzakciók segítségével történik. Ez azt jelenti, hogy a rendszer vagy elküldi az üzeneteket abban a sorrendben, ahogy azok el lettek küldve (befejezett tranzakció), vagy egyáltalán nem küldi el azokat (megszakított tranzakció). Hasonlóképpen, a tranzakció alapú üzeneteket a rendszer csak akkor olvassa ki (távolítja el) a várólistából, ha a tranzakció megerősítése megtörtént, ellenkező esetben az üzenetek visszakerülnek a várólistába, ahonnan azokat később, egy másik tranzakció segítségével ki lehet olvasni.

Továbbá az ugyanarról a számítógépről kezdeményezett, ugyanabba a várólistába irányuló tranzakciók a tranzakciók kezdeményezésének sorrendjében érkeznek meg. Minden üzenet pontosan egyszer érkezik meg a célvárólistába.

A tranzakció alapú üzenetküldés lassabb a nem tranzakció alapú üzenetküldésnél, mivel az üzeneteket többször kell a lemezre írni, és több számítógép-erőforrást igényel. Tranzakció alapú üzenetek csak tranzakciós várólistákba küldhetők (emellett nem tranzakció alapú üzeneteket nem lehet tranzakciós várólistákba küldeni). A tranzakció alapú üzenetküldés kétféleképpen valósítható meg:

  • Külső (kétfázisú) tranzakció segítségével, amelyet a Microsoft elosztott tranzakciók koordinátora (MS DTC) kezel, és amely mostantól a Komponensszolgáltatások (régebbi nevén Transaction Server) része. Az MS DTC automatikusan telepítésre kerül a Message Queuing telepítése során.
  • Belső (egyfázisú) tranzakció segítségével, amelyet a Message Queuing kezel.

A külső tranzakciókat akkor használják, ha a Message Queuing szolgáltatáson kívül más erőforrások is részt akarnak venni a tranzakcióban. A Message Queuing ebben az esetben erőforrás-kezelőként működik, a DTC ellenőrzése alatt. A DTC-nek a Message Queuing tranzakciós koordinátoraként történő használata segítségével megvalósíthatók tranzakció alapú alkalmazások, amelyekkel biztosítható, hogy vagy az összes művelet sikeres vagy az összes sikertelen legyen. Például egy Message Queuing alkalmazás küldhet egy üzenetet és frissíthet egy adatbázist ugyanazon a tranzakción belül. A DTC biztosítja, hogy vagy mindkét művelet sikeres, vagy egyik sem kerül végrehajtásra.

A külső tranzakciók használhatók olyan üzenetek küldésére vagy fogadására, amelyek bármilyen COM-szabványú erőforrás-kezelő művelet részei, illetve több olyan üzenet küldésére vagy fogadására, amelyek egyetlen tranzakció részei.

Mivel kisebb a többletteljesítmény-igényük, a belső tranzakciók sokkal gyorsabban végrehajthatók, mint a DTC által koordinált külső tranzakciók. Akkor ajánlott belső tranzakciókat használni, ha a Message Queuing műveleteit nem kell külső erőforrásokat igénylő műveletekkel összehangolni. A Message Queuing olyan tranzakciós koordinátort tartalmaz, amely csak önmagát támogatja erőforrás-kezelőként.

A belső tranzakciók a következőkre használhatók:

  • Biztosítja, hogy az üzenet csak egyszer legyen kézbesítve (pontosan egyszeri kézbesítés).
  • Biztosítja, hogy az egyik számítógépről a másikra küldött üzenetek sorrendben legyen kézbesítve (sorrendbeli kézbesítés).
  • Nyugták használatával ellenőrzi, hogy a fogadott tranzakció sikeres volt-e. Nyugták használatával az is ellenőrizhető, hogy az üzenetek megérkeztek-e a célvárólistába (vagy el lettek-e távolítva onnan).

Az MS DTC szolgáltatással kapcsolatos további tudnivalókért tanulmányozza A Komponensszolgáltatások használata című témakört.


Üzenet-útválasztás

A Message Queuing ügyfelek mindig közvetlen kapcsolatot, azaz munkamenetet próbálnak létrehozni a célszámítógéppel az alsóbb hálózati átviteli protokoll segítségével. Ha közvetlen kapcsolat nem lehetséges vagy nem megengedett, Message Queuing kiszolgálók továbbíthatják az üzeneteket az ügyfélszámítógép részére. Pontosabban üzenet-útválasztás akkor történik, ha a következő feltételek legalább egyike teljesül:

  • Nem lehet munkamenetet létrehozni a forrásszámítógép és a célszámítógép között (például ha a célszámítógép nincs a hálózatra kapcsolva).
  • Meghatározott Message Queuing kiszolgálók továbbítják az üzeneteket a forrás- és a célszámítógépek helyett.
  • A számítógépek a kommunikációhoz különböző hálózati protokollokat használnak.

A munkamenet-koncentráció biztosításával a Message Queuing kiszolgálók (engedélyezett útválasztással történő) használata csökkentheti a működtetési költségeket. Az ilyen kiszolgálók egy helyen belül csökkenthetik a sávszélességigényt, valamint csökkenthetik a különböző helyek közötti munkamenetek számát. A helyen belüli üzenet-útválasztás viszonylag gyors és olcsó, míg a helyek közötti üzenet-útválasztás viszonylag lassú és drága.

Azokat a Message Queuing kiszolgálókat, amelyek üzenet-útválasztást biztosítanak egy helyen belül, bemenő útválasztó kiszolgálóknak (InRS) vagy kimenő útválasztó kiszolgálóknak (OutRS) nevezik. A helyek közötti üzenet-útválasztást egy útválasztási kapcsolaton keresztül biztosító Message Queuing kiszolgálókat helykapuknak nevezik.

Megjegyzés

  • Az üzenet-útválasztás nem használható munkacsoport alapú környezetben, ahol a célszámítógéppel közvetlen kapcsolat szükséges.

Helyen belüli üzenet-útválasztás

A helyen belüli üzenet-útválasztás mértéke az ugrás, ami azoknak a számítógépeknek a számát jelenti, amelyeken az üzenet keresztülhalad, amíg eljut a célszámítógéphez. A helyen belüli üzenettovábbításhoz a rendszer a legrövidebb útvonalat használja (azt az útvonalat, amelyik a legkevesebb ugrást tartalmazza). Az üzenet-útválasztás számára két számítógép akkor van ugyanazon a helyen, ha a helyhez tartozó IP-címek vannak hozzájuk rendelve.

A helyen belüli üzenet-útválasztást bemutató ábra

Ezen az ábrán a hely egyik számítógépéről egy másik számítógépére küldött üzenet két ugrást tesz meg: egyet a Message Queuing kiszolgálóhoz, egyet pedig a célszámítógéphez. Mivel mindegyik ugrás a helyen belül történik, az egyes ugrások többletteljesítmény-igénye minimális.

Bemenő és kimenő útválasztó kiszolgálók

Egy helyen belül üzenet-útválasztás biztosítható a Message Queuing kiszolgálókat használó ügyfelek számára. Ezeket a kiszolgálókat bemenő útválasztó kiszolgálóknak (InRs) vagy kimenő útválasztó kiszolgálóknak (OutRs) nevezik. Ebben az esetben az ügyfél elnevezés független ügyfélre vagy olyan Message Queuing kiszolgálóra utal, amelyen nincs engedélyezve útválasztás. Ebben a tárgyalásban a független ügyfél és az ilyen Message Queuing kiszolgáló (ha nem tartományvezérlőre van telepítve) felcserélhető. Függő ügyfelek nem használhatnak kimenő vagy bemenő útválasztó kiszolgálókat, mivel ezek minden üzenetküldő funkcióját egy támogató kiszolgáló hajtja végre.

Ha egy ügyfél kimenő útválasztó kiszolgáló használatára van beállítva, akkor az ügyfél által küldött minden kimenő üzenetet ez a kiszolgáló továbbít. Hasonlóképpen, ha egy ügyfél bemenő útválasztó kiszolgáló használatára van beállítva, akkor az ügyfélnek küldött minden üzenetet ez a kiszolgáló továbbít. Egy ügyfél használhatja ugyanazt a Message Queuing kiszolgálót bemenő és kimenő útválasztó kiszolgálóként.

Az összes bemenő/kimenő útválasztó kiszolgálónak az ügyfél eredeti helyén kell lennie. Ha egy hordozható ügyfél másik helyre kerül, nem fogja használni ezeket a kiszolgálókat üzenet-útválasztásra, amíg vissza nem kerül az eredeti helyére.

Hálózati sávszélesség

A helyen belüli üzenet-útválasztás csökkentheti a hálózati sávszélesség használatát a munkamenet-koncentráció segítségével. Ha például egy helyen a hálózat csillag topológiájú, és minden független ügyfél általában közvetlenül kommunikál az összes többi független ügyféllel, a sávszélesség-használat csökkenthető, ha minden ügyfelet kimenő és bemenő útválasztó kiszolgálók használatára állít be.

Egy helyen belüli munkamenet-koncentrációt bemutató ábra

Ezen az ábrán minden ügyfél ugyanazt a Message Queuing kiszolgálót használja bemenő és kimenő útválasztó kiszolgálóként.

Helyek közötti üzenet-útválasztás

A helyek közötti üzenet-útválasztás útválasztási kapcsolatok használatával lehetséges. Több útválasztási kapcsolat használata esetén az üzenet továbbítási útvonala az útválasztási kapcsolat költségétől függ. Minden útválasztási kapcsolathoz alapértelmezés szerint 1 költség van hozzárendelve. Csak akkor módosítsa az útválasztási kapcsolatok költségét, ha több útválasztási kapcsolat van beállítva, és az egyik útvonalat előnyben szeretné részesíteni.

Például ha az A-B útválasztási kapcsolat költsége 3, és a másik három útválasztási kapcsolat (B-C, B-D és C-D) költsége 1, az A helyről a C helyre küldött üzenetek először az A helyről a B helyre kerülnek, majd onnan kerülnek a C helyre. Ha azonban az A-B és a B-C útválasztási kapcsolatok költsége 3, a C-D és a B-D útválasztási kapcsolatoké pedig 1, az A helyről a C helyre küldött üzenetek először mindig a B helyre kerülnek, onnan a D helyre, végül pedig a C helyre.

A helyek közötti üzenet-útválasztást bemutató ábra

Az üzenet A és C helyek közti útvonala az útválasztási kapcsolatok költségétől függ.

Útválasztási kapcsolat | Költség
A-B | 3
B-C | 1
B-D | 1
C-D | 1

Ebben az esetben az A helyről a C helyre küldött üzenetek először az A helyről a B helyre kerülnek, majd a C helyre.

Útválasztási kapcsolat | Költség
A-B | 3
B-C | 3
B-D | 1
C-D | 1

Ebben az esetben az A helyről a C helyre küldött üzenetek először az A helyről a B helyre kerülnek, azután a D helyre, végül pedig a C helyre.

Helykapuk

Az ügyfelek üzeneteit a helyek között olyan Message Queuing kiszolgálók, azaz helykapuk segítségével lehet továbbítani, amelyek útválasztási kapcsolatot határoznak meg. Ha egy ügyfélszámítógép útválasztási kapcsolatot használ, a más helyekre küldött üzeneteket az ügyfél helyének helykapuján keresztül kell továbbítani. A Message Queuing kiszolgálónak ahhoz a helyhez kell tartoznia, amelyen helykapuként üzemel, valamint képesnek kell lennie az útválasztási kapcsolat által meghatározott másik helyhez kapcsolódni. Például az A és B helyek között meghatározott útválasztási kapcsolat esetén az A helykapunak az A helyen kell lennie, és képesnek kell lennie kapcsolódni a B helyhez, valamint a B helykapunak a B helyen kell lennie, és képesnek kell lennie kapcsolódni az A helyhez.

Munkamenetek számának csökkentése

A helyek közötti üzenet-útválasztás általában csökkenti az ügyfelek által létrehozott munkamenetek számát. Az alábbi ábra azt mutatja, hogy a helyen kívüli útválasztást a helyen belüli számítógépek a helykapu kivételével nem érzékelik. Ez egyszerűsíti az üzenet útvonalát, és csökkenti a helyek közötti munkamenetek számát. Csak a kijelölt Message Queuing kiszolgáló hozhat létre munkamenetet különböző helyek között.

A helyek közötti munkamenet-koncentrációt bemutató ábra

IPX-használat

A Message Queuing kiszolgálókat be lehet állítani úgy, hogy engedélyezzék a kommunikációt a különböző hálózati protokollt (például IP és IPX) használó számítógépek között. Ha a vállalatnál találhatók IPX protokollt használó számítógépek, akkor az alábbi követelményeket kell kielégíteni ahhoz, hogy a kommunikáció helykapukkal megvalósítható legyen:

  • Ha egy hely összes számítógépe csak az IPX protokollt használja, a hely összes Message Queuing kiszolgálóját be kell állítani az IPX és az IP protokoll támogatására.
  • A csak IPX protokollt használó ügyfeleket olyan Message Queuing kiszolgálók használatára kell beállítani, amelyek támogatják mind az IPX, mind az IP protokollt.

Az IPX protokollt használó hálózatokon a Message Queuing számára névhozzárendelésre van szükség. A névhozzárendeléshez az SAP-ügynök használható, amely a Windows 2000 része. Az SAP-ügynöknek az IPX protokollt használó Message Queuing számítógépeken kell futni. Az SAP-ügynök használatával kapcsolatos további tájékoztatásért tanulmányozza Az SAP protokoll használata című részt.

Hálózatok közötti üzenet-útválasztás

A Message Queuing használható más hálózatokba történő üzenetküldésre, vagy más hálózatokból jövő üzenetek fogadására (például más vállalatoktól vagy más Windows 2000 erdőkből). A Message Queuing számítógépek számos szolgáltatási portot használhatnak a külső hálózatokkal történő kommunikációhoz megfelelően beállított tűzfalakon keresztül, amelyek lehetővé teszik az ezeken a portokon történő kommunikációt. További tájékoztatásért tanulmányozza a Tűzfal konfigurálása című részt.


Üzenettárolás

Az üzenettárolás méretbeli korlátja, azaz a kvóta határozza meg, hogy egy adott várólistában vagy egy számítógépen összesen mennyi üzenet lehet.

Az üzenetek helyi tárolásának ismeretében meghatározható az üzenetek tárolására használt lemezterület mérete, valamint megvizsgálhatók a helyi várólisták tulajdonságai.

A következőkben erről lesz szó részletesebben.

Üzenetkvóta

Kétféle üzenetkvóta létezik, a számítógépkvóta és a várólistakvóta. Ezek a kvóták egy adott várólistában vagy számítógépen található üzenetek (a naplóvárólistákban található naplóüzeneteket is beleértve) összesített méretét határozzák meg. A várólistakvóta és a számítógépkvóta egymástól függetlenül adható meg. A várólistakvóta elérése után nem lehet több üzenetet küldeni a várólistába, amíg egy vagy több üzenetet el nem olvasnak (vagy egy Message Queuing alkalmazás el nem távolítja a várólistából). Várólistakvótát minden várólistához be lehet állítani. A számítógépkvóták nem vonatkoznak a rendszervárólistákra.

Először a számítógépkvóta lép érvénybe, tekintet nélkül az összesített várólistakvótákra. Ha például egy számítógépen található hat várólista mindegyikének kvótája 10 MB, és a számítógép kvótája 50 MB, a Message Queuing először az 50 MB-os számítógépkvótát alkalmazza. Azonban a várólistakvóta megakadályozza, hogy az egyes várólisták 10 MB üzenetnél többet tároljanak.

A várólistakvóták és a számítógépkvóták csak Message Queuing kiszolgálókon és független ügyfeleken állíthatók be. A függő ügyfeleket támogató Message Queuing kiszolgálókon beállított várólistakvóták és számítógépkvóták a kiszolgálóra és az összes függő ügyfelére is vonatkoznak. Például ha a kiszolgáló számítógépkvótája 50 MB, és egy függő ügyfél 50 MB-nyi üzenetet hoz létre, a kiszolgáló és az általa támogatott ügyfelek nem tudnak üzeneteket küldeni, amíg a teljes üzenettárolási méret a kvóta alá nem esik.

A Message Queuing kiszolgálók és a független ügyfelek hozzávetőlegesen maximum 1,6–1,8 GB üzenetet képesek tárolni egy számítógépen. A több függő ügyfelet támogató Message Queuing kiszolgálók esetén ez a határ a kiszolgálóra vonatkozik, mivel a függő ügyfelek nem tárolják helyileg az üzeneteket. Például egy három függő ügyfelet támogató Message Queuing kiszolgáló nem tárolhat 1,8 GB-nál több üzenetet a függő ügyfelek számára.

Megjegyzés

  • Windows 2000 Advanced Server operációs rendszert futtató számítógépek esetén hozzávetőlegesen maximum 2,6–2,8 GB-nyi üzenet tárolható.

Helyi üzenettárolás

Az üzenetek tárolására használt fájlok az \Msmq\Storage és az \Msmq\Storage\Lqs mappákban találhatók (alapértelmezés szerint a Winnt\System32 mappa alatt).

Az üzenetek tárolása a forrásszámítógép, a célszámítógép vagy az engedélyezett útválasztó szolgáltatásokkal rendelkező közbülső Message Queuing kiszolgáló merevlemezén történik memórialeképező fájlokban (.mq fájlokban). A lemezterület hozzárendelése sürgős és helyreállítható üzenetek esetén is 4 MB-os egységekben történik, szükség szerint. Helyreállítható üzenet esetén a rendszer a memórialeképező fájlt a lemezre írja, hogy az üzenet biztosan helyreállítható legyen. Sürgős üzenetek esetén a rendszer csak akkor írja a lemezre a memórialeképező fájlt, ha nem áll rendelkezésre elegendő erőforrás az üzenetek memóriában történő tárolására.

A memórialeképező fájlt az üzenetet küldő számítógép hozza létre. Az üzenetek útválasztására használt Message Queuing kiszolgálók is memórialeképező fájlokban tárolják az üzeneteket. Ha a forrásnaplózás be van állítva, a memórialeképező fájlok a forrásszámítógépen találhatók. Ha a célnaplózás van beállítva, a fájlok a célszámítógépen találhatók. A Message Queuing kiszolgálók az általuk támogatott összes függő ügyfél üzeneteit tárolják.

A memórialeképező fájlok bármilyen, Windows 2000 által támogatott fájlrendszeren tárolhatók. Azonban mivel a Windows 2000 NTFS fájlrendszere megbízhatóbb fájlhelyreállítást biztosít áramkimaradás vagy rendszerösszeomlás esetén, ajánlott ennek használata Message Queuing kiszolgálókon. Ezenkívül ajánlott az üzenettároló fájlokat tartalmazó mappákról biztonsági másolatot készíteni a hibatűrés érdekében. Ha az üzenetfájlokat tartalmazó merevlemez meghibásodik, és az adatokat nem lehet visszaállítani egy biztonsági mentést készítő program vagy a Message Queuing biztonsági mentési/helyreállítási segédprogramjának segítségével, az üzenetek elvesznek. Az üzenetek biztonsági mentéséhez és visszaállításához használható segédprogrammal kapcsolatos további tájékoztatásért tanulmányozza az Üzenetek biztonsági mentése és visszaállítása című részt.

Az \Msmq\Storage mappában található fájlok

Az .mq kiterjesztésű fájlok üzeneteket tároló memórialeképező fájlok. Az .mq fájlkiterjesztés előtt szereplő betű a jelenleg tárolt üzenet típusára utal a következők szerint:

  • r = Sürgős üzenetek (A sürgős üzenetek tárolása normál esetben a memóriában történik, nem a lemezen. Ez a fájl akkor jön létre, ha nem áll rendelkezésre több memória.)
  • p = Helyreállítható üzenetek
  • j = Naplóüzenetek
  • l = Indexelő bitkép a helyreállítható és a naplóüzenetek értelmezéséhez.

Egy .mq fájl nem egy bizonyos várólistát képvisel. Több várólista üzenetei is tárolhatók egyetlen .mq fájlban, és egyetlen várólista üzenetei is lehetnek több .mq fájlban. Azonban egyetlen üzenet nem tárolható több fájlban. Ezért van az üzenetméret 4 MB-os korlátja.

A QMLog fájl tartalmazza a várólista-feldolgozások eseményeit. Amikor a naplófájl megtelik, a legrégebbi adatokat felülírják az újabbak. A QMLog fájlba történő folyamatos írás biztosítása érdekében az üzenetsort és az összes aktív tranzakció állapotát a rendszer periodikusan menti a következő fájlokba:

  • MQInSeqs.lg1
  • MQInSeqs.lg2
  • MQTrans.lg1
  • MQTrans.lg2

Az MQInSeqs.* fájlok neve üzenetnaplózó fájlok, az MQTrans.* fájlok neve tranzakciónaplózó fájlok.

A rendszer felváltva írja az *.lg1 és az *.lg2 fájlokat, biztosítva ezzel, hogy a fájlpár legalább egyike helyreállítható legyen, ha a másik megsérül az írási művelet közben.

Az \Msmq\Storage\Lqs mappában található fájlok

Az Lqs (helyi várólista-tároló) mappában található fájlok olyan szövegfájlok, amelyek a helyi várólisták tulajdonságait írják le.

Az nnnnnnnn.hhhhhhhh formátumú fájlok privát várólistákat jelentenek. Az nnnnnnnn rész a várólista száma (amely a várólista közvetlen formátumnevében szerepel). A hhhhhhhh kiterjesztés a várólista útvonalának ujjlenyomata.

Az aaaaaaaabbbbccccddddeeeeeeeeeeee.hhhhhhhh formátumú fájlok helyi nyilvános várólistákat képviselnek. A fájlnév 32 karakteres része a várólista globálisan egyedi azonosítója (GUID). A hhhhhhhh kiterjesztés a várólista útvonalának ujjlenyomata.


Message Queuing objektumok az Active Directory címtárban

Tartomány alapú környezetben a telepítés során egy vagy több Message Queuing objektum jön létre az Active Directory címtárban, a függő ügyfelek kivételével minden komponenstípushoz. Ezek az objektumok különféle információkat tartalmaznak a Message Queuing szolgáltatással kapcsolatban. Egyes esetekben az objektum neve megváltozhat, például ha több azonos nevű objektum jön létre egyszerre különböző tartományvezérlőkön. Ha további tájékoztatásra van szüksége azzal kapcsolatban, hogy az Active Directory hogyan kezeli az objektumelnevezést és az ütközéseket, tanulmányozza az Objektumnevek című részt.

A következő táblázatban azok az objektumok láthatók, amelyeket a Message Queuing alapértelmezés szerint létrehoz minden komponenstípushoz, és amelyek az MMC beépülő modulokban megjelennek. Az MMC-vel és a beépülő modulokkal kapcsolatos általános tájékoztatásért tanulmányozza a Microsoft Management Console című részt.

Message Queuing komponens | Objektum neve | Objektum osztálya
Message Queuing kiszolgáló egy tartományvezérlőn | msmq; MSMQ-beállítások | MSMQ-konfiguráció; MSMQ-beállítások
Message Queuing kiszolgáló útválasztó szolgáltatásokkal | msmq; MSMQ-beállítások | MSMQ-konfiguráció, MSMQ-beállítások
Message Queuing kiszolgáló nem tartományvezérlő számítógépen | msmq | MSMQ-konfiguráció
Független ügyfél | msmq | MSMQ-konfiguráció
Függő ügyfél | nincs | nem alkalmazható

Ezeken kívül a Message Queuing szolgáltatással kapcsolatos más információkat is tárol az Active Directory címtárszolgáltatás nem Message Queuing objektumokban. A Felhasználó objektum bizonyítványinformációkat tartalmaz; a vonatkozó számítógép objektum (az msmq objektum fölött) bizonyítványinformációkat tartalmaz, míg a Helyek objektum idegen helyekkel kapcsolatos információkat tartalmaz.

Az objektumattribútumokkal kapcsolatos további információk a Microsoft Platform SDK Networking fejezetének Active Directory témakörében találhatók.

MsmqServices objektum

Az MsmqServices objektumot a Windows 2000 hozza létre az erdő első tartományvezérlőjének konfigurálásakor. Egy erdőben csak egyetlen MsmqServices objektum lehet. Az MsmqServices objektum osztálytípusa: MSMQ-vállalat-beállítások. Az MsmqServices objektum a Message Queuing vállalati szintű konfigurációs információit tartalmazza.

Az MsmqServices objektum az Active Directory - helyek és szolgáltatások beépülő modul konzolfájában (általában a bal oldali ablaktáblán) jelenik meg a következő helyen:

  • Active Directory - helyek és szolgáltatások
  • Szolgáltatások
  • MsmqServices

Útválasztási kapcsolat objektum

Minden létrehozott útválasztási kapcsolathoz létrejön egy útválasztási kapcsolat objektum, amely a kapcsolati információkat tartalmazza. Az útválasztási kapcsolat objektumok osztálytípusa: MSMQ-hely-kapcsolat.

Az útválasztási kapcsolat objektumok az MsmqServices objektum alatt találhatók az Active Directory - helyek és szolgáltatások beépülő modul részletek ablaktábláján.

MSMQ-beállítások objektum

Az MSMQ-beállítások objektum minden Windows 2000 tartományvezérlőre telepített Message Queuing kiszolgálóhoz és minden útválasztó szolgáltatással rendelkező Message Queuing kiszolgálóhoz létrejön. A MSMQ-beállítások objektum konfigurációs információkat tartalmaz, például azt, hogy a kiszolgáló mely Message Queuing szolgáltatásokat nyújtja. Az MSMQ-beállítások objektum osztálytípusa: MSMQ-beállítások.

Az MSMQ-beállítások objektum az Active Directory - helyek és szolgáltatások beépülő modul részletek ablaktábláján (általában a jobb oldali ablaktáblán) jelenik meg a következő helyen:

  • Active Directory - helyek és szolgáltatások
  • Helyek
  • hely_objektum
  • Kiszolgálók
  • kiszolgáló_objektum

msmq objektum

Az msmq objektum minden független ügyfélhez és Message Queuing kiszolgálóhoz létrejön, és a helyi számítógép konfigurációs információit tartalmazza. Az msmq objektum osztálytípusa: MSMQ-konfiguráció. Az msmq objektum alatt várólista-objektumok találhatók. Az msmq objektumot MSMQ konfigurációs objektumnak is nevezik.

Az msmq objektum az Active Directory - felhasználók és számítógépek beépülő modul konzolfájában jelenik meg a következő helyen:

  • Active Directory - felhasználók és számítógépek
  • tartomány_objektum
  • szervezeti_egység_objektuma (például Számítógépek vagy Tartományvezérlők)
  • számítógép_objektum
  • msmq
  • várólista_mappa_objektum (például Privát várólisták vagy Rendszervárólisták)
  • várólista_objektum
  • Várólista-üzenetek
  • Naplóüzenetek

Várólista-objektum

Minden várólistához létrejön egy várólista-objektum, amely az adott várólistához tartozó információkat tartalmazza. A várólista-objektumok osztálytípusa: MSMQ-várólista.

A várólista-objektumok annak a számítógépnek az msmq objektuma alatt találhatók, amelyen a várólista található (kivéve függő ügyfelek esetén, ahol a várólisták a támogató kiszolgáló msmq objektuma alatt találhatók).

MSMQ-számítógépek szervezeti egység objektum

Ezt a szervezeti egység (organizational unit, OU) objektumot a Message Queuing frissítése varázsló csak vegyes módú tartomány alapú környezet esetén hozza létre (Windows NT 4.0 rendszert futtató MSMQ 1.0 vezérlőkiszolgálók és Windows 2000 rendszert futtató Message Queuing kiszolgálók), és a Windows NT 4.0 tartományokhoz tartozó MSMQ 1.0 számítógépek számítógép-objektumait tartalmazza.

Az MSMQ-számítógépek szervezeti egység objektum az Active Directory - felhasználók és számítógépek beépülő modul konzolfájában jelenik meg a következő helyen:

  • Active Directory - felhasználók és számítógépek
  • tartomány_objektum
  • MSMQ-számítógépek

MSMQ-felhasználók szervezeti egység objektum

Ezt a szervezeti egység (organizational unit, OU) objektumot a Message Queuing frissítése varázsló csak vegyes módú tartomány alapú környezetben hozza létre (Windows NT 4.0 rendszert futtató MSMQ 1.0 vezérlőkiszolgálók és Windows 2000 rendszert futtató Message Queuing kiszolgálók), és áttelepített felhasználói objektumokat tartalmaz.

Az MSMQ-felhasználók szervezeti egység objektum az Active Directory - felhasználók és számítógépek beépülő modul konzolfájában jelenik meg a következő helyen:

  • Active Directory - felhasználók és számítógépek
  • tartomány_objektum
  • MSMQ-felhasználók

Áttelepített felhasználó objektum

Az áttelepített felhasználó objektumot a Message Queuing frissítése varázsló csak vegyes módú tartomány alapú környezetben hozza létre, és a Windows NT 4.0 tartományokhoz tartozó MSMQ 1.0 felhasználók regisztrált bizonyítványait tartalmazza. Az áttelepített felhasználó objektum osztálytípusa: MSMQ-áttelepített-felhasználó.

Az áttelepített felhasználó objektum az Active Directory - felhasználók és számítógépek beépülő modul konzolfájában jelenik meg a következő helyen:

  • Active Directory - felhasználók és számítógépek
  • tartomány_objektum
  • MSMQ-felhasználók
  • áttelepített felhasználó


Message Queuing alapú üzleti forgatókönyvek

A következő forgatókönyvek különböző üzleti helyzeteket mutatnak be, ahol kihasználhatók a Message Queuing lehetőségei. Ezek reprezentatív példaként is szolgálnak a Message Queuing használatával elérhető különböző lehetőségek bemutatására.

Mivel a Message Queuing kiszolgálók és ügyfelek használata közti különbségek csak a megvalósítás részleteire vannak hatással, a kifejezések használata elnagyolt, és a forgatókönyvek is egyszerűek. Az alkalmazásfejlesztők a Message Queuing alkalmazások fejlesztésére a Message Queuing SDK csomagban találnak példákat.

Gyártásautomatizálási forgatókönyv

A Message Queuing bármely olyan termék automatikus előállításának vezérlésére használható, amelyet numerikusan, azaz számítógép által vezérelt gép állít elő. A következő példában a Message Queuing segítségével történik a munkamegrendelések összegyűjtése és a termeléshez szükséges információáramlás kezelése.

A gyártásautomatizálási forgatókönyvet bemutató ábra

A Message Queuing alábbi szolgáltatásai nélkülözhetetlenek a sikeres gyártásautomatizáláshoz.

  • Garantált üzenetkézbesítés: Biztosítja, hogy minden üzenet kézbesítve legyen, és segít a megbízható levelezési rendszer létrehozásában.
  • Üzenetek priorizálása: Hatékonyan választja ki az üzenetek útvonalát. Példa: bár a minőségbiztosítási (QA) üzeneteket azonnal kézbesíteni kell, azok nem akadályozhatják az időben kritikus üzenetek kézbesítését.
  • Kapcsolat nélküli üzenetküldés: Lehetővé teszi a számítógépek és a gépek számára, hogy egyetlen rendszerként működjenek együtt.
  • Több platform támogatása: Integrálja a személyi számítógépeket és a más rendszereket. Például egy nagygépes IBM MVS rendszeren található számlázószoftver az MSMQ-MQSeries Bridge segítségével kommunikálhat a személyi számítógépeken található Message Queuing alkalmazásokkal. Ha további tájékoztatásra van szüksége, tanulmányozza a Különféle platformok támogatása című fejezetet.
  • Teljesítmény: Mivel az üzenetek kézbesítése nagyon gyors, vezérelhetők valós idejű folyamatok is, például a főzési hőmérséklet.
  • Aszinkron kézbesítés: Lehetővé teszi, hogy a gyorsabb egységek folytassák a feldolgozást anélkül, hogy a lassabb egységek válaszára kellene várniuk.

Jegyeladási forgatókönyv

Az alábbi ábrán az látható, hogyan férhet hozzá több ügyfél az Interneten keresztül egy jegyeladási webkiszolgálóhoz. A webes ügyfelek HTML oldalakat látnak, amelyek a rendelkezésre álló helyeket, az árakat és az ültetési ábrákat tartalmazzák.

A jegyeladási forgatókönyvet bemutató ábra

A jegyértékesítéssel foglalkozó cégek a Message Queuing következő szolgáltatásait használhatják meglévő rendszerük továbbfejlesztéséhez.

  • Internet-kapcsolat: Megrendelések fogadása az Interneten keresztül a Message Queuing alkalmazások és a COM összetevők segítségével, az Active Server Pages (ASP) és az Internet Information Services (IIS) szolgáltatásokkal együttműködve. Ez webes űrlapok segítségével történik, amelyek biztonságosak és több platformot támogatnak.
  • Kapcsolat nélküli üzenetkezelés: A számla frissítése és a jegy szállítása aszinkron módon történik.
  • Több platform támogatása: Integrálja a személyi számítógépeket és a régebbi rendszereket. A jegyeladási kiszolgáló például futhat egy UNIX számítógépen. Ha további tájékoztatásra van szüksége, tanulmányozza a Különféle platformok támogatása című fejezetet.

Publikálás és előfizetés forgatókönyv

A Message Queuing lehetővé teszi a „publikálás és előfizetés” elven működő programok (például hírszolgáltatók és pénzügyi adatszolgáltatók) egyszerűbb elkészítését. Bár a kiszolgálóprogramnak a megadott adatokat az ügyfél felé folyamatosan frissítenie kell, a kiszolgálónak nem kell újraküldenie az adatokat, ha az ügyfél nincs a hálózatra kapcsolva vagy nem érhető el.

Az alábbi ábrán egy „publikálás és előfizetés” alapú forgatókönyv látható, amely az utazó ügynököknek friss információt biztosít az elérhető termékekkel kapcsolatban. A megrendelések felvételére is használható egy Message Queuing alkalmazás, és a két rendszer integrálható. A példa egyszerűsítése érdekében azonban ez a „publikálás és előfizetés” alapú forgatókönyv csak az információk elosztásával foglalkozik.

A „publikálás és előfizetés” alapú forgatókönyvet bemutató ábra

Az előző ábrán a mobil ügyfelek a helyszínen kapják meg az adatokat. A területi kiszolgálók a főkiszolgálóról csak azokat az adattípusokat olvassák ki, amelyekre az ügyfél előfizet. Így az ügyfelek csak azokat az információkat kapják meg, amelyekre előfizettek. Ez csökkenti mind a helyek közötti, mind a mobil kommunikáció költségeit.

A következő Message Queuing szolgáltatások nélkülözhetetlenek a hagyományos „publikálás és előfizetés” elven működő programok sikeres megvalósításához:

  • Kapcsolat nélküli üzenetkezelés és az üzenetek priorizálása: Az üzenetkézbesítés terhét a Message Queuing szolgáltatásra hárítja. Nem kell törődni a lejárt (és emiatt már nem használható) és az olyan információkkal, amelyek nem kézbesíthetők megfelelő időben.
  • Biztonság: Biztosítja, hogy az információ a megfelelő ügyfélhez kerüljön, és hogy a szolgáltatást ne használják fizetés nélkül.

Megjegyzés

  • A Message Queuing natív módon nem támogatja az üzenetszórást és a csoportos küldést. Azonban egy egyszerű üzenetküldő alkalmazás segítségével egy üzenet több várólistába is elküldhető.

Pénzügyi forgatókönyv

A pénzügyi tranzakciók biztonságot és tranzakció alapú programozást igényelnek. A bankjegykiadó automata (ATM) tranzakcióihoz is kapcsolat nélküli üzenetküldésre van szükség. A következő ábrán minden bankjegykiadó automata helyi adatbázissal rendelkezik. Még ha a helyi, területi vagy központi adatbázis időlegesen nincs is a hálózatra kapcsolva, a bankjegykiadó automata akkor is tud tranzakciókat lebonyolítani.

A pénzügyi forgatókönyvet bemutató ábra

A pénzügyi forgatókönyv a Message Queuing következő szolgáltatásait használja:

  • Kapcsolat nélküli üzenetkezelés: A bankjegykiadó automaták és a területi központok közötti kommunikációhoz.
  • Tranzakció alapú üzenetküldés: Olyan üzenetek küldéséhez, amelyek egyszerre történnek a pénzügyi adatbázisok frissítésével. Az üzeneteket csak egyszer kézbesíti a rendszer.
  • Biztonság: A rendszer integritásának biztosítása érdekében. Nem lehet megszemélyesíteni egy bankjegykiadó automatát, és a tranzakciók nem figyelhetők meg a számlaszámok és az azonosító kódok ellopása céljából.

Részvénykereskedelmi forgatókönyv

A részvénykereskedelmi forgatókönyvet bemutató ábra

Az itt bemutatott példában az ügyfelek telefonon kommunikálnak a kereskedőkkel, akik az ő nevükben kereskednek. A kereskedési kiszolgáló a következő műveleteket hajtja végre az itt látható sorrendben:

  1. Lekérdezi a számlavezető kiszolgálót és ellenőrzi, hogy a tranzakció végrehajtható-e.
  2. Egyezteti a tranzakciót a kockázatelemző kiszolgálóval.
  3. Elhelyezi a kereskedelmi kérelmet a részvénykereskedelmi kiszolgálóra.

A részvénykereskedelmi kiszolgáló elvégzi a részvénytranzakciót, és aszinkron módon frissíti az ügyfél számláját és a kockázatelemző kiszolgálót.

Az alábbi részvénykereskedelmi forgatókönyv a Message Queuing következő szolgáltatásait használja:

  • Biztonság: A biztonságos környezet megvalósítása érdekében az üzenetek hitelesítéséhez, titkosításához és naplózásához.
  • Több platform támogatása: Integrálja a személyi számítógépeket és a régebbi rendszereket. Ha további tájékoztatásra van szüksége, tanulmányozza a Különféle platformok támogatása című fejezetet.
  • Tranzakciók (pontosan egyszeri kézbesítés): A garantált üzenetkézbesítéshez, ami a pontos elszámoláshoz szükséges.
  • Kapcsolat nélküli üzenetkezelés: A számlák frissítésének és a kockázati döntések aszinkron módon történő végrehajtásához.


A Message Queuing használata

Ez a rész a tervezéssel, a telepítési illetve frissítési követelményekkel, a biztonsággal és a felügyelettel kapcsolatban tartalmaz tudnivalókat.

  • A Message Queuing használatának megtervezése
  • A Message Queuing telepítése
  • A Message Queuing biztonságossá tétele
  • A Message Queuing felügyelete


A Message Queuing használatának megtervezése

Ez a rész ismerteti, hogyan lehet felkészülni a Message Queuing használatára, és hogyan lehet üzembe helyezni azt. A Message Queuing sikeres használata a Message Queuing kiszolgálók, ügyfelek és alkalmazások helyes telepítésén és megvalósításán múlik.

  • Message Queuing hálózatok tervezése
  • A Message Queuing kiszolgáló hardverelemeinek kiválasztása
  • Message Queuing alapú alkalmazásfejlesztés
  • A Message Queuing telepítése


Message Queuing hálózatok tervezése

A vállalat növekedési követelményeinek felmérése, és a hálózat eszerint történő tervezése az első lépés a Message Queuing alapú infrastruktúra és alkalmazások megvalósításához.

A Message Queuing vállalaton belüli használatának növekedésével az üzenetforgalom is növekszik. Ajánlott olyan Message Queuing kiszolgálókat telepíteni, amelyek nagyobb sávszélességű kommunikációs kapcsolatok felé továbbítják az üzeneteket. Minden helyet ajánlott útválasztási kapcsolatokkal csatlakoztatni a többi helyhez. Ha megoldható, a kapcsolatok redundanciájának érdekében ajánlott több útválasztó kapcsolatot használni a helyek közötti üzenettovábbításhoz.

Hellyel kapcsolatos megfontolások

A szervezetben működő helyeket a Windows 2000 Server telepítése során kell kijelölni. Nincs különálló helytopológia, mint a Message Queuing előző verziói esetén. Ez leegyszerűsíti a helyek tervezését.

Azonban a következő tényezőket ajánlott figyelembe venni:

Hellyel kapcsolatos megfontolás | Követelmény vagy javaslat
Kommunikációs kapcsolat | A helyek közötti kommunikációs kapcsolatnak állandónak kell lennie.
Rendelkezésre álló hálózati sávszélesség | A hálózati sávszélességnek elegendőnek kell lennie a helyen belüli üzenetmennyiség továbbítására.
Teljesítmény | Az egy helyen lévő Message Queuing kiszolgálók száma hatással van a teljesítményre. Ha egy helyen több Message Queuing kiszolgáló található, azok nagyobb hálózati forgalmat generálnak. Kompromisszumot kell kötni a kiszolgálóredundancia előnyei és az Active Directory replikálása okozta többletteljesítmény-igény között.
Szervezési | Csoportosítsa az egy helyen dolgozó felhasználókat a rendszer teljesítményének növelése, a hálózati forgalom csökkentése és az erőforrás-használat csökkentése érdekében.

Az útválasztási kapcsolattal kapcsolatos megfontolások

Ha a szervezetben egynél több Windows 2000 hely található, útválasztó kapcsolatokat kell létrehozni, hogy biztosítani lehessen az üzeneteknek a Windows 2000 helyek közötti továbbítását. A helyek közötti útválasztás függhet a hozzárendelt kapcsolatköltségtől. Minden útválasztási kapcsolathoz alapértelmezés szerint 1 költség van hozzárendelve. Csak akkor módosítsa az útválasztási kapcsolatok költségét, ha több útválasztási kapcsolat van beállítva, és az egyik útvonalat előnyben szeretné részesíteni.

A kapcsolatköltségek segítségével kiválasztható a legjobb helyek közötti üzenetútvonal, amely történhet a fizikai kommunikációs kapcsolat sebessége vagy pénzügyi költsége alapján. Miután meghatározta az erdőben lévő Windows 2000 helyek számát, el kell döntenie, hogy szükséges-e különböző költségek megadása az útválasztási kapcsolatok számára.

A Message Queuing kiszolgálóval kapcsolatos megfontolások

A vállalatnál alkalmazott Message Queuing kiszolgálók száma a következő tényezőktől függ:

  • A hálózatban található függő ügyfelek számától
  • Azon helyek számától, amelyek között üzenettovábbítás történik
  • Milyen gyakran vannak az ügyfélszámítógépek kikapcsolva. Útválasztó szolgáltatást használó Message Queuing kiszolgálók szükségesek az üzenettároló és -továbbító funkcióhoz, ha a forrás- és célszámítógépek nem mindig vannak egyszerre a hálózatra kapcsolva.

A jobb teljesítmény és méretezhetőség érdekében ajánlott minden Windows 2000 tartományban több Windows 2000 tartományvezérlőre telepíteni Message Queuing kiszolgálókat.

Továbbá, mivel az automatikus helyfelismerés során Message Queuing kiszolgálók válaszolnak az ügyfelek által létrehozott szórásos kérelmekre, az erdő minden Windows 2000 helyén legalább egy engedélyezett útválasztással rendelkező Message Queuing kiszolgálót kell telepíteni.

Azon mobil ügyfelek esetén, amelyek gyakran nincsenek a hálózatra kapcsolva, vagy egy távelérés-kiszolgálón keresztül kapcsolódnak a hálózathoz, bemenő és kimenő útválasztó kiszolgálókat kell használni.

A kiszolgáló hardverelemeivel kapcsolatos megfontolásokról A Message Queuing hardverelemeinek kiválasztása című fejezetben olvashat.

A független ügyfelekkel kapcsolatos megfontolások

A független ügyfelek alkalmazásának előnyei a következők:

  • Üzenetek küldéséhez és fogadásához nem függnek egy Message Queuing kiszolgálótól, és nincs szükségük szinkron kommunikációra egy Message Queuing kiszolgálóval.
  • Az üzenetküldési terhelés szétosztható több Message Queuing kiszolgálón, ha a független ügyfelek megadott Message Queuing kiszolgálók (bemenő és kimenő útválasztó kiszolgálók) használatára vannak beállítva.
  • A mobilitás támogatása érdekében a független ügyfelek áthelyezhetők egyik helyről a másikra.
  • A hálózatról lekapcsolt mobil ügyfelek továbbra is fogadhatnak üzeneteket a hozzárendelt bemenő útválasztó kiszolgálójukon. Mivel azonban ezeket az útválasztási beállításokat a rendszer nem veszi figyelembe, amikor a független ügyfelek új helyhez kapcsolódnak, ez a konfiguráció akkor működik legjobban, ha a független ügyfelek nem csatlakoznak a hálózathoz más helyeken.

Megjegyzés

  • Azok a mobil felhasználók, amelyek Message Queuing alkalmazásokat futtatnak, miközben nincsenek a hálózatra kapcsolva, további hálózati terhelést okozhatnak. Ez akkor történik, amikor a hálózatra történő újrakapcsolódáskor megpróbálnak nagy mennyiségű üzenetet küldeni vagy fogadni. Ez az átmeneti terhelés átirányítható további Message Queuing kiszolgálókra a teljesítménycsökkenés megelőzése érdekében.

A függő ügyfelekkel kapcsolatos megfontolások

El kell döntenie, hogy szeretne-e függő ügyfeleket alkalmazni a szervezetben. A függő ügyfelek használatának előnyei a következők:

  • Az üzenetek tárolása a kiszolgáló merevlemezén történik. Ha növelni kell a Message Queuing szolgáltatás teljesítményét, csak a kiszolgáló erőforrásait (például a memóriát vagy a lemezterületet) kell megnövelni, nem pedig az összes ügyfélszámítógépét.
  • Kevesebb számítógépről kell biztonsági mentést készíteni, valamint kevesebb naplóvárólistát és kézbesítetlen üzenetek várólistát kell figyelni.
  • Kevesebb erőforrás van használatban, ha az ügyfél gyakran nincs a hálózatra kapcsolva, de a kiszolgáló igen.

A függő ügyfelek használatának hátrányai a következők:

  • Mivel a Message Queuing szolgáltatás a támogató kiszolgálón fut, a függő ügyfelek által küldött és fogadott titkosított üzenetek továbbítása a függő ügyfél és a támogató kiszolgáló között egyszerű szövegként történik.
  • A várólisták elérési ideje függő ügyfelek esetén rosszabb, mint független ügyfelek esetén. Ez azért van így, mert a várólisták elérése RPC alapú kapcsolaton keresztül történik.
  • Csökkenhet a teljesítmény, ha egyszerre több függő ügyfél csatlakozik a támogató kiszolgálóhoz üzenetek küldése vagy fogadása céljából.
  • A függő ügyfelek várólistái a támogató kiszolgálón találhatók, és nem egyértelmű, hogy mely várólisták mely ügyfelekhez tartoznak.
  • A függő ügyfélszoftver eltávolítása esetén a kapcsolódó várólistákat a rendszer nem törli automatikusan a támogató kiszolgálóról.
  • Mivel a függő ügyfelek kommunikációja a támogató kiszolgálón megy keresztül, ha a támogató kiszolgálóval történő kommunikáció lassú vagy drága (például két hely között), az összes ügyfélkommunikáció is lassú vagy drága lesz.
  • A függő ügyfelek nem futhatnak a Helyi felhasználó fiók alatt.

Ezen korlátozások miatt amikor csak lehetséges, ajánlott függő ügyfelek helyett független ügyfeleket használni.

Licencelési megfontolások

A Message Queuing alkalmazások több kiszolgálóval kommunikálhatnak, mint az általános hálózat alapú alkalmazások. Emiatt Message Queuing számítógépek esetén a munkaállomásonkénti licencelés költséghatékonyabb lehet.

A Message Queuing használatához Windows 2000 Server ügyféllicenc szükséges. Ügyféllicenc hiányában előfordulhat, hogy a Message Queuing alkalmazások nem tudnak üzeneteket küldeni, vagy nem tudják megnyitni az összes várólistát. A Message Queuing az ügyféllicencek számolásakor a következő szabályokat használja:

  • A Windows 2000 Professional rendszeren futó független ügyfeleknek nem lehet egyszerre 10-nél több Message Queuing munkamenetük és Windows 2000 Professional rendszeren futó független ügyfelekkel létrejött távoli olvasási munkamenetük.
  • A függő ügyfelek nem növelik a szükséges ügyféllicencek számát, de a támogató kiszolgálók minden munkamenetet és várólistát számolnak, amit a függő ügyfelek számára nyitnak meg. A függő ügyfelek által megnyitott minden Message Queuing munkamenetet, távoli olvasási munkamenetet és várólistát számolnak. A támogatható függő ügyfelek számát a kiszolgálói ügyféllicencek száma korlátozza.
  • Egy Message Queuing számítógép által használt összes munkamenetet csak egyszer számol a rendszer. Például ha egy Windows 2000 Professional rendszert futtató számítógépnek van egy Message Queuing és egy távoli olvasási munkamenete egy Windows 2000 Server rendszert futtató számítógéppel, a kiszolgáló ezeket egyetlen ügyféllicencnek számolja.
  • A Windows 2000 Professional rendszert futtató számítógépek nem számolják a Windows 2000 Server rendszert futtató számítógépekkel létrejött munkameneteket, azonban a Windows 2000 Server rendszert futtató számítógépek számolják a Windows 2000 Professional rendszert futtató számítógépekkel létrejött munkameneteket.

A Windows 2000 Server licencelésével kapcsolatos további tájékoztatásért tanulmányozza A licencelés módjának kiválasztása című témakört.

Az IPX kapcsolatokra vonatkozó megfontolások

Ha a Message Queuing számítógépekben több hálózati csatoló található, és ha néhány csatolón az IPX protokoll használata van beállítva, az ilyen számítógépeknek meg kell adni egy egyedi, nullától különböző belső hálózati számot.

Az IPX protokollt használó hálózatokon a Message Queuing számára névhozzárendelésre van szükség. A névhozzárendeléshez az SAP-ügynök használható, amely a Windows 2000 része.

Az IPX tulajdonságok beállításával és az SAP-ügynök használatával kapcsolatos további tudnivalókért tanulmányozza az IPX/SPX tulajdonságok beállítása című fejezetet.


A Message Queuing kiszolgáló hardverelemeinek kiválasztása

A kiszolgáló hardverfelépítése befolyásolja a hálózat teljesítményét. A kiszolgálók hardverelemeinek kiválasztása során vegye figyelembe a későbbi üzleti követelményeket, és olyan számítógépeket válasszon, amelyek könnyen továbbfejleszthetők és bővíthetők. Így a felhasználók számának növekedésével újrakonfigurálható a meglévő hardver, és nincs szükség további számítógépek beszerzésére. A meglévő kiszolgálóhardver többféle módon is alkalmassá tehető a Message Queuing futtatására:

  • Minden kiszolgáló rendszermemóriájának növelésével.
  • A processzor gyorsabbra cserélésével, vagy további processzorok hozzáadásával.
  • A lemezek számának, sebességének vagy méretének növelésével.
  • A lemezmeghajtók és a kötetkészletek lecserélése csíkozott lemeztömbökre.
  • A számítógépen futó más szolgáltatások számának korlátozása a nem létfontosságú szoftverek más számítógépekre történő áthelyezésével. A más szolgáltatásokat is futtató kiszolgálónak több hardvererőforrásra van szüksége. Ezen további erőforrások (például nagyobb merevlemez és több memória) hiányában a kiszolgáló kevesebb függő ügyfelet képes támogatni.

A jövőre is gondolva olyan hardvert érdemes választani, amely egyszerűen továbbfejleszthető. Így ha az üzembe állítás után a teljesítmény szűk keresztmetszetté válik, frissíthetők a meglévő hardverelemek, és nem kell új számítógépeket vásárolni, vagy a hely felépítését átalakítani.

A lemezzel kapcsolatos megfontolások

A kiszolgáló lemezkezelő alrendszerével kapcsolatban a lemezek számát, méretét és típusát illetően a következő tényezőket kell figyelembe venni.

Lemezek száma

Mivel a Windows 2000 és a Message Queuing képes több lemezművelet párhuzamos végrehajtására, több fizikai lemez használata (az egyetlen, több partícióval rendelkező lemezzel ellentétben) növeli a legtöbb Message Queuing alkalmazás teljesítményét. A helyreállítható és a tranzakció alapú üzeneteket használó alkalmazások esetén tapasztalható a legnagyobb teljesítménynövekedés, mivel ezeket az üzeneteket folyamatosan lemezre kell írni, vagy lemezről kell olvasni.

A Message Queuing kiszolgálók és a független ügyfelek üzenetküldési teljesítménye növekedhet, ha az üzenetküldéshez használt különféle fájlok különböző fizikai lemezeken helyezkednek el. Akár három lemez is használható ezeknek a fájloknak a tárolására. A Message Queuing kiszolgálók legjobb üzenetkezelési teljesítménye érdekében az üzenetkezelő (*.mq), az üzenetnapló- és a tranzakciós naplófájlokat külön fizikai lemezeken ajánlott elhelyezni. Az üzenetek és a naplófájlok tárolásával kapcsolatos további tájékoztatásért tanulmányozza a Helyi üzenettárolás című fejezetet.

A maximális teljesítmény öt különböző fizikai lemez következőképp történő használata esetén érhető el:

  • Üzenetfájlok
  • Üzenetnapló-fájlok
  • Tranzakciós naplófájlok
  • Windows 2000 lapozófájlok
  • Alkalmazásadat-fájlok

Ha nem praktikus öt lemezt használni egy számítógépben, három lemez is általában megfelelő teljesítménynövekedést eredményez. Például egy háromlemezes konfiguráció által nyújtott teljesítmény kétszer vagy háromszor jobb lehet, mint egy egylemezes konfiguráció által nyújtott teljesítmény. Egy ötlemezes konfiguráció általában 50 százalékkal gyorsabb, mint egy háromlemezes. Ha csak két lemez áll rendelkezésre, ajánlott az egyik lemezen az üzenetfájlokat, az üzenetnapló-fájlokat és a tranzakciós naplófájlokat pedig a másik lemezen tárolni.

A legjobb tranzakciós teljesítmény elérése érdekében a tranzakció alapú üzenetküldést megvalósító alkalmazás adat- és naplófájljait helyezze két vagy több fizikai lemezre. Ha rendelkezik még egy további lemezzel, fontolja meg a Microsoft elosztott tranzakciók koordinátora (MS DTC) tranzakciókezelő naplófájljának külön lemezre helyezését.

Több lemez használatával biztosítható, hogy a lemezhozzáférések csak minimális hatással legyenek az üzenetkezelés teljesítményére. Azonban ha a CPU (processzor) kihasználtsága közel 100 százalék, további lemezek használatával már nem növelhető az üzenetkezelés teljesítménye. Annak meghatározásához, hogy a számítógépet a lemezhozzáférés vagy a feldolgozási teljesítmény korlátozza, használja a Rendszerfigyelő A processzor kihasználtsága (%) (a Processzor objektumban található) és Lemez várakozási sorának hossza (a Lemezhossz objektumban található) számlálóit. Ha A processzor kihasználtsága (%) számláló értéke tartósan 75 százalék fölött van az üzenetek küldése közben, a feldolgozási kapacitás növelése javíthat a teljesítményen. Ha a Lemez várakozási sorának hossza számláló értéke bármely lemeznél 0,6-nál nagyobb az üzenetek küldése közben, további lemezek hozzáadása javíthatja az üzenetkezelés teljesítményét. A Message Queuing szolgáltatás teljesítményének figyelésével kapcsolatos további tájékoztatásért tanulmányozza A teljesítmény figyelése című részt.

Lemezek mérete

A kiszolgálók minimális lemezméretének meghatározásakor vegye figyelembe a következőket:

  • Azon üzenetek összes számát, amelyek egyszerre összegyűlhetnek a kiszolgálón, és az üzenetek teljes méretét.
  • A Message Queuing programfájljai és az üzenetkezelés megvalósítására használt fájlok tárolására használt lemezterületet.

Mivel az üzenetek tárolhatók a célszámítógépen, a forrásszámítógépen vagy bármely közbülső Message Queuing kiszolgálón, nehéz lehet megbecsülni az üzenettárolási követelményeket. Azonban ha a Message Queuing kiszolgálókat munkamenet-koncentrációra (belső és külső útválasztó kiszolgálók) vagy útválasztási kapcsolatokban használja, további helyet kell biztosítani az üzeneteknek. A függő ügyfeleket támogató kiszolgálóknak is valószínűleg nagyobb lemezterületre van szükségük.

Az üzenetekhez használt lemezterület mennyisége függ az üzenetek kézbesítési típusától (helyreállítható/tranzakció alapú vagy sürgős), az üzenetek méretétől, valamint az üzenetek mennyiségétől. A Message Queuing az egyes üzenetek számára legfeljebb 4 MB lemezterületet oszt ki.

A rendszer a helyreállítható és a tranzakció alapú üzeneteket 512 bájtos egységekben írja a lemezre. Az üzenetekben körülbelül 150 bájt az üzenet fejléce (az elküldött üzenettulajdonságoktól függően).

Mivel a rendszer a sürgős üzeneteket is lemezre írja, ha nem áll rendelkezésre elegendő memória a tárolásukra, ezt a tényezőt is figyelembe kell venni a lemezterületek méretezésekor. A sürgős üzenetek tárolása 64 bájtos egységekben történik, ezért a lemezterület kihasználása hatékonyabb kis üzenetméretek esetén.

Mivel a naplóüzeneteket addig tárolja a rendszer, amíg azokat valaki nem törli, vagy egy Message Queuing alkalmazás ki nem olvassa a napló várólistát, további lemezterületet kell hagyni a naplóüzenetek tárolására.

Az azonban szabály, hogy az üzenetkézbesítési döntéseket az üzleti igények alapján, nem pedig lemezterülettel kapcsolatos követelmények alapján kell meghozni. A használható üzenetkézbesítési típusokkal kapcsolatos további tájékoztatásért tanulmányozza az Üzenetkézbesítés című témakört.

Megjegyzés

  • Ha egy Message Queuing kiszolgáló (vagy független ügyfél) számára nincs több lemezterület, az nem képes többé üzenetek küldeni és fogadni, valamint várólisták sem hozhatók rajta létre.

Lemezek típusa

Nem minden merevlemez nyújt azonos teljesítményt. Léteznek nagy teljesítményű lemezek, amelyek hardveres csíkozást és akkumulátoros védelemmel rendelkező “write-through” lemezvezérlőket használnak, amelyek addig késleltetik az írási műveleteket, amíg azok a leghatékonyabban el nem végezhetők. Ezek a lemezek jelentősen növelik az üzenetkezelési teljesítményt, különösen helyreállítható és tranzakció alapú üzenetek küldése és fogadása esetén. Bár a különböző lemezek teljesítménye változhat a gyártó és más tényezők függvényében, egy háromutas, hardveres csíkozást biztosító, 2 MB memóriájú, akkumulátoros védelmű vezérlő üzenetátvitele tízszer akkora is lehet, mint egy szabványos SCSI II lemezé.

Mivel a Windows 2000 NTFS fájlrendszere megbízhatóbb fájlvisszaállítást biztosít áramkimaradás vagy rendszerösszeomlás után, ajánlott ezt a fájlrendszert használni a Message Queuing kiszolgálókon. Három vagy több NTFS formátumú lemez segítségével megvalósítható a Windows 2000 által is támogatott RAID rendszer, mely hibatűrést biztosít.

Memóriával kapcsolatos megfontolások

Az optimális teljesítmény érdekében a Message Queuing kiszolgálóknak elegendő RAM-mal kell rendelkezniük, hogy elkerüljék a Windows 2000 lapozófájljainak a gyakori használatát. Mivel a lapozófájlok elérése sokkal lassabb, mint a fizikai memória elérése, a fizikai memória méretének növelése nagymértékben növelheti az üzenetkezelés teljesítményét. Azonban más hardvererőforrások, például a CPU vagy az I/O alrendszer, korlátozhatják a teljesítményt.

Az üzenetkezelési teljesítmény maximalizálásához a számítógépben elegendő memóriának kell lenni ahhoz, hogy ott tárolja az összes üzenetet, ami normális működés során várhatóan összegyűlik a várólistákban. Az üzenetek összegyűlhetnek a forrásszámítógépen (ha a célszámítógép nem elérhető), a célszámítógépen (ha nem fut a fogadó alkalmazás, vagy nem tud lépést tartani az üzenetek érkezési sebességével) vagy egy közbülső Message Queuing kiszolgálón.

Az összes üzenet tárolásához szükséges RAM mennyiségének kiszámításához ismerni kell az üzenetek méretét. Az üzenet mérete az üzenettörzs méretének és az üzenetfejlécben található adatok méretének az összege. Az üzenet fejléce általában 150 bájt adatot tartalmaz; az egyes fejlécek aktuális mérete a Message Queuing alkalmazás által használt tulajdonságok számától függ. Ezért 20 000 darab, egyenként körülbelül 1 kilobájtos, tipikus fejlécméretű üzenet elküldéséhez legalább 23 MB (20 000 X 1 KB + 20 000 X 150) RAM-ra van szükség az általános rendszerkövetelményeken felül.

Megjegyzés

  • A javaslat csak azokra az esetekre vonatkozik, amikor az üzenetek ténylegesen összegyűlnek egy számítógépen. Ha a rendszer normálisan olvassa (eltávolítja a várólistákból) az üzeneteket, olyan gyorsan, ahogy azok érkeznek, lényegesen kevesebb RAM-ra van szükség.

Továbbá kvóták határozzák meg egy adott várólistában vagy számítógépen található üzenetek (a naplóüzeneteket is beleértve) összesített korlátját. A számítógép- és várólistakvóták a méreten alapulnak, és külön lehet ezeket beállítani. A Message Queuing kiszolgálók és a független ügyfelek hozzávetőlegesen maximum 1,6–1,8 GB üzenetet képesek tárolni egy számítógépen (a Windows 2000 Advanced Server rendszert futtató számítógépek 1,6–1,8 GB-ot). A kvótákkal kapcsolatos további tájékoztatásért tanulmányozza az Üzenetkvóták című témakört.

A processzorral kapcsolatos megfontolások

Ha a kiszolgáló bemeneti/kimeneti alrendszere gyors és nem ez az egyetlen teljesítménykorlátozó tényező, valamint ha elegendő memóriával rendelkezik az üzeneteknek a Windows 2000 lapozófájl túlzott használata nélküli kezelésére, egy gyorsabb processzor növelheti a teljesítményt. Message Queuing kiszolgálók esetén érdemes lehet több processzort használni. Csak Intel alapú processzorok használhatók.

A hálózati csatolóval kapcsolatos megfontolások

A nagy sebességű hálózati csatolók és hálózati illesztőprogramok a nagy átviteli sebességek alacsony CPU-használat mellet történő biztosításával járulnak hozzá az üzenetkezelési teljesítmény növeléséhez.

Mivel egyszerre több ügyfél is hozzáférhet egy Message Queuing kiszolgálóhoz, ajánlott egy vagy több nagy teljesítményű hálózati csatoló használata, amelyek nagy sebességű buszt, például PCI vagy EISA buszt használnak. Több hálózati csatolónak egy többprocesszoros számítógépben történő használata azt eredményezi, hogy egyetlen számítógép több ügyfélkérelmet tud kezelni oly módon, hogy az egyes csatolók külön hálózatrészeket vagy hálózati protokollokat szolgálnak ki.

A mennyiséggel kapcsolatos megfontolások

A Message Queuing kiszolgálókhoz használható hardverek lehetnek egyprocesszoros, Pentium osztályú számítógépek, vagy akár a leggyorsabb többprocesszoros konfigurációk is azok közül, amelyeket a Windows 2000 Advanced Server támogat. Egy szervezet 10 000 ügyfele kiszolgálható úgy, hogy 100 ügyfél jut a 100 kiszolgáló mindegyikére, vagy 500 ügyfél jut a 20 kiszolgáló mindegyikére. Ez a döntés a vállalat elvárásaitól és pénzügyi helyzetétől függ.

Az alábbi táblázatban a több, kevésbé gyors számítógép használatának előnyei és hátrányai láthatók.

Előnyök | Hátrányok
Olcsóbb a kapacitás növelése | Több hardvert kell karbantartani
Többféle hardver közül lehet választani | A felhasználók vagy a terhelés kis változása esetén több hardverre van szükség
Közelebb van a felhasználókhoz, ezzel csökken az ügyfél-kiszolgáló együttműködések okozta hálózati forgalom |

Az alábbi táblázatban a kevesebb, de gyorsabb számítógépek használatának előnyei és hátrányai láthatók.

Előnyök | Hátrányok
A rendszer könnyebben bővíthető | A hálózati csatolóknak nagyobb hálózati forgalmat kell kezelniük minden kiszolgálónál
A tárolási követelmények alacsonyabbak lehetnek |
Kevesebb adatreplikálásra van szükség |


Message Queuing alapú alkalmazásfejlesztés

A Message Queuing szolgáltatás üzenetküldésre és -fogadásra történő használatához először megfelelő Message Queuing alkalmazásokat kell tervezni, fejleszteni és üzembe helyezni.

Mivel ez a dokumentáció a Message Queuing által biztosított infrastruktúra telepítése és kezelése iránt érdeklődő rendszergazdáknak szól, nem tárgyalja az alkalmazásfejlesztést. A Microsoft Platform SDK részét képező Message Queuing Software Development Kit (SDK) nyújt információt a szoftverfejlesztőknek a Message Queuing alkalmazások fejlesztésével kapcsolatban. A Message Queuing SDK-val kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Platform Software Development Kit csomagot.


A Message Queuing telepítése

Ebben a fejezetben a Message Queuing szolgáltatás közepes és nagyméretű vállatoknál történő telepítésével kapcsolatos javaslatok olvashatók. Olyan megvalósítást válasszon, amely megfelel üzleti igényeinek.

A telepítési eljárás részei:

  • Felügyeleti házirend beállítása.
  • Laboratóriumi tesztek végrehajtása.
  • Egy vagy több próbatelepítés végrehajtása.
  • A végső telepítés elvégzése.

Felügyeleti házirend beállítása

A felügyeleti házirend egy munkadokumentum. Ennek megvalósítására hatással lehetnek a felállított házirendek. A következőket kell figyelembe venni:

  • Hozzáférés-vezérlés megvalósítása a szervezeten belül.
  • Felügyeleti feladatok delegálása.
  • Munkavégzés dokumentálása.
  • Vészhelyzetekre való felkészülés.
  • Biztonsági mentés szabályos időközönként.

Felügyeleti házirendet kell megvalósítani a vészhelyzetek kezelésére is, például ha egy kiszolgáló megsérül, eltávolítják vagy megsemmisül. A vészhelyzeti tervek segítségével csökkenthető a leállások súlyossága.

Laboratóriumi tesztek végrehajtása

A laboratóriumi tesztek segítségével meghatározható, hogy a Message Queuing milyen mértékben terheli a kiszolgálókat, valamint kipróbálhatók a meglévő Message Queuing alkalmazások. A teszt helyének és felszerelésének előkészítése a következőkből áll:

  • Annak ellenőrzése, hogy az összes számítógép megfelel-e a Message Queuing hardverkövetelményeinek.
  • Annak ellenőrzése, hogy a Message Queuing alkalmazások megfelelően működnek-e.

Próbatelepítés végrehajtása

A Message Queuing a laboratóriumi tesztelése után telepíthető egy korlátozott környezetbe. A próbatelepítés méretét ajánlott korlátozni, például 15–50 felhasználóra. Ezen információk alapján elvégezhetők a végső telepítéshez szükséges módosítások a felügyeleti házirenden és a Message Queuing alkalmazásokon. Ha nagymértékű módosításokat hajt végre a végső telepítési terven, érdemes egy második próbatelepítést végrehajtani.

A végső telepítés elvégzése

A próbatelepítése eredményeinek elemzése után véglegesítheti a Message Queuing egész vállalatra kiterjedő telepítési tervét. A végső telepítési terv a próbatervezési eljárásnak a kibővítése a dokumentálás, a pénzügyi számítások és a végső logisztikai művelet elvégzésével.


A Message Queuing telepítése

Ez a rész ismerteti a Message Queuing szoftver Windows 2000 rendszerre való telepítésével és frissítésével kapcsolatos követelményeket. Azt is bemutatja, hogyan telepíthető új Message Queuing szoftver távolról, parancsfájl használatával.

  • A Message Queuing telepítésének áttekintése
  • A Message Queuing frissítése
  • Új Message Queuing kiszolgálók telepítése
  • Új Message Queuing ügyfelek telepítése
  • Új MSMQ-Exchange összekötő telepítése
  • A Message Queuing felügyelet nélküli telepítése
  • A Message Queuing telepítése kiszolgálófürtre
  • A Message Queuing eltávolítása


A Message Queuing telepítésének áttekintése

A Message Queuing alapértelmezés szerint nem kerül telepítésre a Windows 2000 telepítése során. Egy számítógépen a Message Queuing a következő eljárásokkal telepíthető:

  • A Windows 2000 telepítése után a Vezérlőpulton található Programok telepítése/törlése segédprogram segítségével.
  • A Windows 2000 telepítése után a Kiszolgáló konfigurálása varázsló segítségével. Amikor a Windows 2000 telepítése végén megjelenik a Kiszolgáló konfigurálása varázsló, kattintson sorban a Speciális, a Message Queuing, majd a Beállítás elemre. Ez az eljárás csak Windows 2000 Server és Windows 2000 Advanced Server használata esetén használható.
  • A Windows 2000 telepítése során a Message Queuing szolgáltatások jelölőnégyzet bejelölésével. A Message Queuing szolgáltatásnak a Windows 2000 telepítése során történő telepítése két lépésből áll. Az első lépésben, a Windows 2000 telepítése közben, a telepítő a fájlokat a helyi lemezre másolja. A második lépésben, amely a Windows 2000 telepítése utáni első bejelentkezéskor történik, a Message Queuing telepítése befejeződik. Amikor a Kiszolgáló konfigurálása varázsló megjelenik, kattintson a Telepítés befejezése gombra, majd a Message Queuing szolgáltatások beállítása részen kattintson a Beállítás gombra. Kövesse a Message Queuing telepítése varázsló ablakban megjelenő utasításokat. Ez az eljárás csak Windows 2000 Server és Windows 2000 Advanced Server használata esetén használható.

Az első két módszer új Message Queuing szoftver telepítése esetén ajánlott.

A Message Queuing egy számítógépre történő telepítésekor alapértelmezés szerint a Microsoft elosztott tranzakciók koordinátora (MS DTC) is telepítésre kerül. Az MS DTC a tranzakció alapú üzenetkezeléshez szükséges.

A Message Queuing telepíthető akár tartomány alapú környezetbe, amely Active Directory címtárszolgáltatást biztosít, vagy akár munkacsoport alapú környezetbe (vagy bármely olyan környezetbe, amely nem nyújt címtárszolgáltatást, például Active Directory címtárat).

Telepítési követelmények

Függetlenül attól, hogy új Message Queuing szolgáltatást telepít, vagy MSMQ 1.0-ról frissít, az alábbi követelményeknek kell eleget tenni a Message Queuing sikeres telepítéséhez egy Windows 2000 rendszert futtató számítógépen:

  • Megfelelő felügyeleti jogosultsággal kell rendelkeznie azon a számítógépen, amelyen a Message Queuing szolgáltatást telepíteni vagy frissíteni szeretné. A telepítéshez szükséges engedélyekkel kapcsolatos további tájékoztatásért tanulmányozza a Telepítési engedélyek című fejezetet.
  • Hálózati kapcsolat szükséges, ha a Message Queuing szolgáltatást olyan számítógépen szeretné telepíteni vagy frissíteni, amely egy Windows 2000 tartomány része.
  • Minden Windows 2000 tartományban először a Windows 2000 tartományvezérlőn kell a Message Queuing szolgáltatást telepíteni vagy frissíteni, csak azután lehet ezt elvégezni a tartomány más számítógépein. Ennek a követelménynek nem kell eleget tenni, ha a Message Queuing szolgáltatást olyan számítógépen telepíti vagy frissíti, amely egy MSMQ 1.0 vezérlőkiszolgálókat (például PEC, PSC vagy BSC) tartalmazó Windows NT 4.0 tartomány része.
  • A Message Queuing telepítése során meg kell adni annak a Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálónak a nevét, amely ugyanabban a tartományban található, mint amelyikben a telepítés történik. Ha ezt nem adja meg, a Message Queuing telepítés munkacsoport módban történik meg. Munkacsoport módú működés esetén közvetlen kapcsolat szükséges az üzenetküldéshez.

Telepítési korlátozások

A Message Queuing sikeres telepítéséhez vagy frissítéséhez a következő korlátozásokat kell figyelembe venni:

  • A Message Queuing szolgáltatást ne telepítse egyszerre több Windows 2000 tartományvezérlőre. Az Active Directory címtárban, ha egy ugyanolyan nevű objektum jön létre egyszerre több tartományvezérlőn, az objektumnevek megváltozhatnak. Ez azért történhet meg, mert bizonyos időre van szükség, amíg a módosítások replikálása megtörténik a tartományvezérlők között.
  • Ne hozzon létre kézzel Message Queuing objektumokat (például msmq objektumot) az Active Directory címtárban a Message Queuing telepítése vagy frissítése előtt.
  • Ha át szeretne helyezni egy Message Queuing számítógépet egy másik tartományba, akkor először el kell távolítani a Message Queuing szolgáltatást, majd az új tartományban újra kell azt telepíteni.

Ezenkívül létezhetnek további korlátozások is a várólisták számítógépeken történő létrehozására vonatkozóan, amelyek meghatározása a Message Queuing telepítése során történik meg. További tájékoztatásért tanulmányozza Az msmq objektumok biztonsági leírója című részt.

Telepítési platformok

Az alábbi táblázat azt mutatja, hogy az egyes Message Queuing szoftverkomponensek mely Windows platformokra telepíthetők.

Message Queuing komponens | Windows 2000 platform
Message Queuing kiszolgáló | Windows 2000 Server és Windows 2000 Advanced Server
Független ügyfél | Windows 2000 Professional
Függő ügyfél | Windows 2000 Professional, Windows 2000 Server és Windows 2000 Advanced Server
MSMQ-Exchange összekötő | Windows 2000 Server és Windows 2000 Advanced Server

Telepítési engedélyek

A következő táblázatban a különböző Message Queuing szoftverkomponensek telepítéséhez szükséges felügyeleti engedélyek láthatók. Alapértelmezés szerint ilyen engedélyekkel rendelkező felhasználói fiókkal történő bejelentkezés esetén a Message Queuing telepítése során létrehozhatók a megfelelő Message Queuing objektumok az Active Directoryban.

Message Queuing komponens | Szükséges engedély
Message Queuing kiszolgáló egy tartományvezérlőn | tartománygazdai engedély (vagy a Tartománygazdák csoporthoz kell tartozni)
Message Queuing kiszolgáló nem tartományvezérlőn, engedélyezett útválasztással | vállalati rendszergazdai engedély (vagy a Vállalati rendszergazdák csoporthoz kell tartozni)
Message Queuing kiszolgáló nem tartományvezérlőn, nem engedélyezett útválasztással | helyi rendszergazdai engedély (vagy a Helyi rendszergazdák csoporthoz kell tartozni)
Független ügyfél | helyi rendszergazdai engedély (vagy a Helyi rendszergazdák csoporthoz kell tartozni)
függő ügyfél | helyi rendszergazdai engedély (vagy a Helyi rendszergazdák csoporthoz kell tartozni)

A Windows 2000 felügyeleti csoportjaival kapcsolatos további tájékoztatásért tanulmányozza a Beépített és előre beállított csoportok című részt.

Megjegyzések

  • Egy engedélyezett útválasztással rendelkező Message Queuing kiszolgáló nem tartományvezérlőre történő telepítése esetén elegendő a tartománygazdai jog, feltéve ha a telepítés során megadja egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló nevét, és ha rendelkezik az alábbi táblázatban látható objektumengedélyekkel.
  • A Message Queuing szolgáltatás kiszolgálófürtre történő telepítése esetén a felhasználói fióknak, amely alatt a fürtszolgáltatás fut, rendelkezni kell engedéllyel számítógép-objektumok és Message Queuing objektumok létrehozásához. Az alábbi táblázatban az egyes objektumok létrehozásához szükséges engedélyek láthatók.

Ha nem akar a felhasználóknak a Message Queuing telepítéséhez ilyen általános vagy széles körű jogosultságokat adni, adjon megfelelő jogosultságokat a Message Queuing komponensek telepítéséhez szükséges objektumok létrehozásához. Az alábbi táblázatban az Active Directory gyermekobjektumai láthatók, amelyek létrehozásához engedéllyel kell rendelkezni a Message Queuing sikeres telepítése érdekében.

Message Queuing komponens | Szükséges engedély | Melyik objektumhoz
Message Queuing kiszolgáló (vagy egy tartományvezérlő, vagy egy nem tartományvezérlő engedélyezett útválasztással) | MSMQ konfigurációs objektumok létrehozása | az Active Directory - felhasználók és számítógépek csomópont alatt található tartományvezérlő objektum
 | Minden gyermekobjektum létrehozása | az Active Directory - helyek és szolgáltatások csomópont alatt található Kiszolgálók mappaobjektum
Message Queuing kiszolgáló (nem tartományvezérlőn, útválasztás nélkül) | MSMQ konfigurációs objektumok létrehozása | az Active Directory - felhasználók és számítógépek csomópont alatt található számítógép-objektum
Független ügyfél | MSMQ konfigurációs objektumok létrehozása | az Active Directory - felhasználók és számítógépek csomópont alatt található számítógép-objektum
Függő ügyfél | nincs | nem alkalmazható

Ezek a jogok megadhatók egyes felhasználóknak, vagy akár egy tartomány összes felhasználójának a Vezérlés delegálása varázsló segítségével.

Ha további információra van szüksége a Message Queuing objektumokkal, azok létrehozási helyével, valamint azok Active Directory címtáron belüli helyével kapcsolatban, tanulmányozza a Message Queuing objektumok az Active Directory címtárban című részt.

Az objektumengedélyekkel kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing hozzáférés-vezérlése című fejezetet.

Megjegyzés

  • A Message Queuing eltávolításához MSMQ konfigurációs objektumok törlése engedéllyel kell rendelkezni.

Telepítési forgatókönyvek

Az alábbiakban néhány telepítési forgatókönyvről olvashat.

Sikertelen telepítési kísérlet

Ha a Message Queuing telepítése valamilyen okból nem sikerül, törölni kell a megfelelő objektumokat az Active Directory címtárból a telepítés újbóli megkísérlése előtt. Ha ezt nem teszi meg, az Active Directory címtárban ugyanolyan nevű objektumok jönnek létre, ami kiszámíthatatlan működéshez vezethet. Ha további információra van szüksége a Message Queuing objektumokkal, azok létrehozási helyével, valamint azok Active Directory címtáron belüli helyével kapcsolatban, tanulmányozza a Message Queuing objektumok az Active Directory címtárban című részt.

A Message Queuing objektumok Active Directory címtárból történő eltávolításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing objektumok eltávolítása az Active Directory címtárból című részt.

Megjegyzés

  • Az MsmqServices objektumot csak akkor szabad törölni, ha a Message Queuing szolgáltatást a vállalat minden számítógépéről eltávolítja. Ez az objektum a Message Queuing “vállalati” objektuma.

A Message Queuing telepítése Windows NT 4.0 felhasználói fiók használatával

Ha a Message Queuing szolgáltatást egy Windows 2000 rendszert futtató számítógépre telepíti, és egy Windows NT 4.0 tartományi felhasználói fiókkal jelentkezett be, legalább egy Message Queuing kiszolgálónak kell futnia egy Windows 2000 tartományvezérlőn, amely ugyanabban a tartományban található, amelyben a telepítést el szeretné végezni. Ellenkező esetben a telepítés során meg kell adni a Windows NT 4.0 tartomány elsődleges helyvezérlőjének (primary site controller, PSC) a nevét.

Az MSMQ 1.0 telepítése Windows 2000 tartományban

Az alábbiak arra az esetre vonatkoznak, ha az MSMQ 1.0-t olyan Windows NT 4.0, Windows 95 vagy Windows 98 rendszert futtató számítógépre telepíti, amely egy Windows 2000 tartomány tagja.

Amikor a telepítés közben az elsődleges helyvezérlő (PSC) nevének megadására felszólító üzenet megjelenik, ehelyett a Message Queuing kiszolgáló nevét adja meg. Ennek a Message Queuing kiszolgálónak egy Windows 2000 tartományvezérlőn kell futnia, globáliskatalógus-kiszolgálónak kell lennie, valamint ugyanabban a tartományban kell lennie, amelybe telepíteni szeretne.

Ha az MSMQ 1.0-t Windows NT 4.0 rendszert futtató számítógépekre akarja telepíteni egy új Windows 2000 tartományban, jelölje be A Windows 2000 előttiekkel kompatibilis jelölőnégyzetet az új tartomány első tartományvezérlőjének telepítése során. Ha az MSMQ 1.0-t egy meglévő Windows 2000 tartomány Windows NT 4.0 rendszert futtató számítógépeire szeretné telepíteni, ellenőrizze, hogy a tartományban a Mindenki csoport hozzá lett-e adva a “Hozzáférés korábbi Windows-verziókkal” csoporthoz. Ehhez nyissa meg az Active Directory - felhasználók és számítógépek ablakot. A konzolfán kattintson a Beépített lehetőségre, kattintson a jobb oldali egérgombbal a Hozzáférés korábbi Windows-verziókkal elemre, kattintson a Tulajdonságok parancsra, majd ellenőrizze, hogy a Tagok lapon szerepel-e a Mindenki csoport. Ha nem, kattintson a Hozzáadás gombra, majd válassza a Mindenki csoportot.

Továbbá a Windows NT 4.0 rendszert futtató függő ügyfeleken telepítve kell lenni a Windows NT Service Pack 4 (SP4) vagy későbbi szervizcsomagnak. A tranzakció alapú üzenetküldéshez legalább SP4 szükséges.

Ezenkívül a Windows 95 vagy Windows 98 rendszert futtató számítógéphez Számítógép-objektumok létrehozása jogosultsággal kell rendelkeznie az Active Directory Számítógépek mappaobjektumában, mivel az ilyen számítógépekhez nincs számítógép-objektum az Active Directory címtárban.

Ha engedélyezni szeretné a felhasználók számára az MSMQ 1.0 Windows 2000 tartományba történő telepítését, a Vezérlés delegálása varázsló segítségével adhat jogokat a tartomány összes felhasználója számára. További tájékoztatásért tanulmányozza Az MSMQ 1.0 telepítési engedélyeinek beállítása című fejezetet.


A Message Queuing frissítése

Ez a rész ismerteti a Message Queuing korábbi verzióinak (MSMQ 1.0) frissítését olyan számítógépeken, amelyeket a Windows 2000 operációs rendszerre frissítettek.

  • A Message Queuing frissítése - áttekintés
  • A Message Queuing frissítésének követelményei és szempontjai
  • MSMQ 1.0 számítógépek frissítése


A Message Queuing frissítése - áttekintés

Ebben a fejezetben áttekintés olvasható arról, hogyan kell Windows NT 4.0, Windows 95 vagy Windows 98 rendszerre telepített MSMQ 1.0-ról frissíteni.

Az MSMQ 1.0 kiszolgáló egyes komponenseinek frissítése a Message Queuing frissítése varázsló segítségével történik, amely a Windows 2000 Server telepítésének befejeződése után automatikusan elindul a Kiszolgáló konfigurálása varázslóval együtt. Más MSMQ 1.0 szoftverkomponensek frissítése automatikusan megtörténik a Windows 2000 telepítése során.

Fontos

  • A Message Queuing frissítése varázsló használata előtt olvassa el a frissítési követelményeket és a frissítéssel kapcsolatos megfontolásokat. Először olvassa el a Frissítési követelmények című részt, majd A Message Queuing frissítése varázsló használata című fejezetet.

A Message Queuing, a Windows 2000 rendszerrel szállított verzió neve, kompatibilis az MSMQ 1.0-val. A különböző verziójú kiszolgálószoftverek egy tartományon belül történő egyidejű futtatásának a neve vegyes módú működés. Az MSMQ 1.0 vezérlőkiszolgálók (PEC, PSC vagy BSC) Message Queuing kiszolgálókra történő frissítését áttelepítésnek nevezik.

Az alábbi táblázatban a Message Queuing előző verziói és a jelenlegi verzió közti különbségek láthatók:

Előző verziók | Jelenlegi verzió | Megjegyzések
Microsoft Message Queue Server (MSMQ) vagy MSMQ 1.0 | Message Queuing | Előfordulhat, hogy más irodalmakban és külső forrásmunkákban a Message Queuing szolgáltatásra esetleg MSMQ 2.0 néven hivatkoznak.
MSMQ vállalat | Windows 2000 erdő |
MSMQ hely | Windows 2000 hely | Már nem léteznek MSMQ-specifikus helyek
MSMQ helyhivatkozás | útválasztási kapcsolat |
MQIS | Active Directory címtárszolgáltatás | Már nem létezik MSMQ-specifikus címtárszolgáltatás
összekapcsolt hálózat | nincs | Az összekapcsolt hálózatokat már nem használják.
MSMQ (vagy MQIS) vezérlőkiszolgáló | Message Queuing kiszolgáló egy Windows 2000 tartományvezérlőn | Az MSMQ vezérlőkiszolgálók a PEC, a PSC és a BSC.
MSMQ útválasztó kiszolgáló | Message Queuing kiszolgáló útválasztó szolgáltatásokkal |
MSMQ független ügyfél (Windows NT Server 4.0 rendszeren) | Message Queuing kiszolgáló | Egy útválasztással nem rendelkező, nem tartományvezérlőn lévő Message Queuing kiszolgáló ugyanazokat a funkciókat nyújtja, mint egy Windows NT Server 4.0 rendszeren futó független ügyfél.
MSMQ független ügyfél (Windows NT Workstation 4.0, Windows 95 vagy Windows 98 rendszeren) | független ügyfél | A független ügyfél kifejezés már csak Windows 2000 Professional rendszerekre vonatkozik
MSMQ függő ügyfél | függő ügyfél |
MSMQ Explorer | Microsoft Management Console (MMC) beépülő modul | A Message Queuing felügyeletére használt beépülő modulok a Számítógép-kezelés, az Active Directory -felhasználók és számítógépek, valamint az Active Directory - helyek és szolgáltatások.

Az MSMQ 1.0-ban használt fogalmakkal és elnevezésekkel kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Message Queue Server Administrator's Guide című kiadványt.


A Message Queuing frissítésének követelményei és szempontjai

Ebben a fejezetben azokról a követelményekről és szempontokról olvashat, amelyeket szem előtt kel tartani, ha Windows NT 4.0, Windows 95 vagy Windows 98 rendszerre telepített MSMQ 1.0-ról szeretne frissíteni.

Az MSMQ 1.0 kiszolgáló egyes komponenseinek frissítése a Message Queuing frissítése varázsló segítségével történik, amely a Windows 2000 Server telepítésének befejeződése után automatikusan elindul a Kiszolgáló konfigurálása varázslóval együtt. Más MSMQ 1.0 szoftverkomponensek frissítése automatikusan megtörténik a Windows 2000 telepítése során.

A frissítés követelményei

Az áttekintő részben tárgyalt telepítési követelményeken kívül az alábbi követelményeket is teljesíteni kell az MSMQ 1.0 szoftver sikeres frissítése érdekében.

  • Egyes MSMQ 1.0 vezérlőkiszolgálók kiszolgálói bizonyítványát exportálni kell a számítógép Windows 2000 rendszerre történő frissítése előtt. További tájékoztatásért tanulmányozza a Kiszolgálóhitelesítés című részt.
  • Szinkronizálja az összes MSMQ 1.0 vezérlőkiszolgálót az áttelepítés előtt. Ha egy MSMQ 1.0 vezérlőkiszolgáló nincs szinkronizálva (nem elérhető vagy nincs a hálózatra kapcsolva), amikor objektumokat töröl egy másik MSMQ 1.0 vezérlőkiszolgáló MQIS adatbázisából, akkor a PEC frissítésekor az Active Directory és a nem szinkronizált MSMQ 1.0 vezérlőkiszolgáló MQIS adatbázisa nem lesz konzisztens. Tegyük fel, hogy törli az 1. várólistát a PEC MQIS adatbázisából. Ez a módosítás replikálva lesz a PSC2 kivételével az összes többi MSMQ 1.0 vezérlőkiszolgálón, amely jelenleg nem elérhető. A PEC-et még azelőtt frissíti, hogy a PSC2-n megjelentek volna a módosítások. Az Active Directory nem tartalmaz adatokat az 1. várólistáról, de a PSC2 MQIS adatbázisa igen.
  • A PEC számítógépet Windows 2000 tartományvezérlővé kell előléptetni az MSMQ szoftverek frissítése előtt.
  • A PSC számítógépeket Windows 2000 tartományvezérlőkké kell előléptetni. A BSC számítógépek Windows 2000 tartományvezérlőkké történő előléptetése nem kötelező.
  • Az MSMQ szoftver frissítése előtt ellenőrizze, hogy az egyes előléptetett tartományvezérlők delegálásra meghatalmazottak-e. Ez a tulajdonság alapértelmezés szerint engedélyezve van. Ha ez a tulajdonság nincs engedélyezve, a Message Queuing szolgáltatás nem tud futni. Ennek a tulajdonságnak az ellenőrzésével kapcsolatos további tájékoztatásért tanulmányozza a Számítógép delegációs meghatalmazásának beállítása című témakört.
  • Minden vegyes módban működő Windows 2000 helyen kell lenni legalább egy olyan Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálónak, amely globáliskatalógus-kiszolgálónak van beállítva. Ez a Windows 2000 helyen található, Windows NT 4.0 rendszeren futó MSMQ-ügyfelek támogatásához szükséges, emellett növeli a teljesítményt is. Egy számítógép globáliskatalógus-kiszolgálóként történő konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza a Számítógép beállítása globáliskatalógus-kiszolgálóként című fejezetet.
  • Az MSMQ 1.0 vezérlőkiszolgálókat a következő sorrendben kell frissíteni:
    1. Az elsődleges vállalati vezérlőt (PEC).
    2. Ezután az összes hely másodlagos helyvezérlőjét (BSC).
    3. Ezután az összes hely elsődleges helyvezérlőjét (PSC).
  • A PEC és minden PSC frissítéséhez a Message Queuing frissítése varázslót kell használni.
  • A Message Queuing frissítése varázsló futtatáshoz vállalati rendszergazdai jogosultsággal kell rendelkeznie, vagy a Vállalati rendszergazdák csoport tagjának kell lennie.
  • Egy Windows NT 4.0 vállalatnál az MSMQ nem frissíthető az elsődleges tartományvezérlőn (PDC), hacsak az nem a PEC is egyben. Minden más esetben a frissítés előtt először el kell távolítani az MSMQ 1.0 szoftvert, majd újra kell telepíteni azt.
  • Minden Windows 2000 tartományban kell lenni egy Windows 2000 tartományvezérlőnek, amelyen a globáliskatalógus-kiszolgáló engedélyezve van.

Frissítéssel kapcsolatos korlátozások

Az áttekintő részben tárgyalt telepítési korlátozásokon kívül az alábbi korlátozásokat is szem előtt kell tartani:

  • Nem telepíthet át egynél több vállalati szintű MSMQ 1.0 hálózatot egy Windows 2000 erdőbe. Több MSMQ 1.0 vállalati szintű hálózat esetén minden MSMQ 1.0 vállalati szintű hálózatot különböző Windows 2000 erdőbe kell áttelepíteni.
  • A PEC frissítése után nem telepíthető több PSC a Windows 2000 erdőben. BSC még telepíthető, ha a telepítés során megadja egy PSC nevét. Továbbra is telepíthetők MSMQ útválasztó kiszolgálók és MSMQ-ügyfelek. Azonban a telepítés során megadott kiszolgálónévnek egy olyan Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló nevének kell lennie, amelynek globáliskatalógus-kiszolgálónak kell lennie.
  • Nem hozhat létre több MSMQ-helyet, ha az erdőben Message Queuing kiszolgálószoftver fut.
  • Nem hozhat létre több szabványos összekapcsolt hálózatot, ha az erdőben Message Queuing kiszolgálószoftver fut. Továbbra is létrehozhat azonban idegen összekapcsolt hálózatokat.
  • A PEC frissítése után nem szabad egy PSC objektumait törölni (vagy a PSC-ről eltávolítani az MSMQ szoftvert), mert akkor kézzel kell eltávolítani a megfelelő objektumokat az Active Directory címtárból. A Message Queuing objektumok Active Directory címtárból történő eltávolításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing objektumok eltávolítása az Active Directory címtárból című részt.

A címtárszolgáltatással kapcsolatos megfontolások

Az MSMQ 1.0 egy, a Microsoft SQL Server kiszolgálón alapuló adatbázist használt (az MQIS adatbázist) az MSMQ számítógépek, a várólisták és a felhasználók konfigurációs információinak tárolására. Minden MSMQ 1.0 vezérlőkiszolgálón megtalálható volt az MQIS másolata, amely egy dedikált algoritmus segítségével teljes mértékben replikálva volt a vezérlőkiszolgálók között.

A Message Queuing a konfigurációs információk tárolására az MQIS adatbázis helyett az Active Directory címtárszolgáltatást használja. Az MSMQ 1.0 vezérlőkiszolgálók frissítésekor az MQIS adatbázisban tárolt adatok automatikusan konvertálódnak, és átkerülnek az Active Directory címtárba.

Vegyes módú környezetben az MSMQ 1.0 vezérlőkiszolgálók és a Message Queuing kiszolgálók között mindkét irányban történik adatreplikálás, tekintet nélkül arra, hogy hol történt a módosítás.

Az MSMQ MQIS visszaállító varázsló (a Windows NT Service Pack 4 tartalmazza) a meghibásodott MSMQ 1.0 vezérlőkiszolgálók MQIS adatbázisának visszaállítására használható. Egy MQIS adatbázis csak vagy egy másik PSC számítógépről állítható helyre, vagy egy olyan hely egy BSC számítógépéről, amely tartalmaz egy PSC számítógépet. Egy MQIS adatbázis nem állítható vissza egy frissített MSMQ 1.0 vezérlőkiszolgálóról (amely már az Active Directory címtárszolgáltatást használja). Vegyes módú környezetben történő használat esetén figyelni kell arra, hogy legalább egy ilyen számítógép rendelkezésre álljon. Ha ez már nem lehetséges, ajánlott frissíteni az összes többi PSC számítógépet.

A Message Queuing felügyelete Microsoft Management Console (MMC) beépülő modulok segítségével történik. Az MSMQ 1.0 számítógépek objektumainak ezen beépülő modulok segítségével történő módosításához a módosításokat arról a frissített MSMQ 1.0 vezérlőkiszolgálóról kell elvégezni, amelyik az objektum tulajdonosa. A módosítások replikálása ezután a teljes Windows 2000 erdőben megtörténik. Az MSMQ Explorer segítségével létrehozott vagy módosított MSMQ 1.0 számítógépek objektumainak replikálása a teljes Windows 2000 erdőben megtörténik.

Hellyel kapcsolatos megfontolások

Áttelepítés esetén minden MSMQ-hely egy Windows 2000 helyre lesz leképezve, és minden idegen összekapcsolt hálózat egy vagy több idegen helyre lesz leképezve.

Ha vegyes módú környezetben új Windows 2000 helyet hoz létre, egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló replikálja a módosításokat a többi PSC számítógépre, lehetővé téve számukra az üzeneteknek az új helyre történő továbbítását.

Összekapcsolt hálózatokkal kapcsolatos megfontolások

Az MSMQ 1.0 az összekapcsolt hálózatok elvét használta, amely szerint bármely két számítógép közvetlenül kommunikálhat. A kommunikációs hálózatok terén történt fejlődés, a virtuális magánhálózatok bevezetése, valamint az internetes protokollok elterjedése feleslegessé tette az összekapcsolt hálózatokat. Ezért a Message Queuing már nem támogatja az összekapcsolt hálózatokat.

Ha a vállalatnál nincs közvetlen kapcsolat az összes ügyfélszámítógép között, és az összekapcsolt hálózatokat a kapcsolati topológia meghatározására használta, az áttelepítés befejeződése után szükség lehet a hálózat konfigurálására. A helyek közötti útválasztási kapcsolatokkal ugyanolyan szintű összeköttetés érhető el, mint az összekapcsolt hálózatok esetén. Ez biztosítja, hogy az összes üzenet továbbítható legyen a céljához.

Az útválasztási kapcsolatok létrehozásával kapcsolatos további tájékoztatásért tanulmányozza az Útválasztási kapcsolatok létrehozása című részt.

Az alábbiakban néhány jellemző összekapcsolt hálózati forgatókönyv látható, és bemutatunk néhány lehetőséget az áttelepítés utáni hálózati konfigurációra:

  • A vállalat minden számítógépe támogatja az IP és az IPX protokollt. Nincs szükség konfigurálásra. Az üzenetek továbbítása IP protokollon keresztül történik.
  • Egy helyen egyes számítógépek csak az IPX protokollt használják, míg mások csak az IP protokollt. Ha a csak IPX protokollt használó helyeken az összes Message Queuing kiszolgáló az IP és az IPX protokollt is használja, nincs szükség konfigurálásra. Ha egy csak IPX-et vagy csak IP-t ismerő számítógép nem tud létrehozni egy munkamenetet, a számítógép továbbítja az üzenetet egy Message Queuing kiszolgálónak. Ha a helyen nem minden Message Queuing kiszolgáló használja mindkét protokollt, érdemes mindkét protokollt beállítani az összes Message Queuing kiszolgálón, vagy belső vagy külső útválasztó kiszolgálókat használni a csak az IPX protokollt használó számítógépek támogatásához.
  • A vállalat több, nem összekapcsolt IP-hálózatot használ. Érdemes lehet útválasztókat vagy távelérést használni az összekapcsolhatóság érdekében. További tájékoztatásért tanulmányozza az Útválasztás és távelérés című részt. A nem összekapcsolt IP-hálózatok különálló Windows 2000 helyekként is konfigurálhatók.
  • A vállalatnál idegen számítógépeket használnak az üzenetküldéshez. Az idegen számítógépek általában úgy vannak beállítva, hogy a helyen egy olyan Message Queuing kiszolgálónak továbbítsák az üzeneteket, amelyen egy összekötő alkalmazás fut. Ezek a Message Queuing kiszolgálók a hely idegen számítógépeinek kimenő és bemenő útválasztó kiszolgálóiként is használhatók. Érdemes ezeket a Message Queuing kiszolgálókat és az összes idegen számítógépet egyetlen idegen helyre áthelyezni, majd útválasztási kapcsolatokat létrehozni a helyhez.

A felügyeleti eszközökkel kapcsolatos megfontolások

Az MSMQ 1.0 felügyeletéhez használt eszköz az MSMQ Explorer volt. Windows 2000 esetén a Message Queuing felügyelete az MMC konzol Számítógép-kezelő, Active Directory -felhasználók és számítógépek, valamint Active Directory - helyek és szolgáltatások beépülő moduljainak segítségével történik.

Vegyes módú működés esetén, ahol egy Message Queuing kiszolgáló egy MSMQ 1.0 vezérlőkiszolgálóval kommunikál, az MSMQ 1.0 vezérlőkiszolgálón található információk eléréséhez továbbra is használni kell az MSMQ Explorer.

Message Queuing szoftverre történő frissítés esetén az MSMQ Explorer fájljai a számítógépen maradnak, csak a futtatáshoz szükséges parancsikonok lesznek eltávolítva. Létrehozhat egy parancsikont az MSMQ Explorer futtatásához a frissített számítógépen, ha az Mqxplore.exe fájlt az Asztalra másolja.

Ha a Message Queuing szoftvert olyan számítógépre telepíti, amelyen az MSMQ 1.0 nincs telepítve, az új számítógépre a következő fájlokat kell átmásolnia egy olyan számítógépről, amelyen az MSMQ 1.0 telepítve van:

  • Mqxplore.exe
  • Mqxplore.hlp
  • Mqxplore.cnt

Ezek a fájlok az MSMQ 1.0-t futtató számítógép \Program Files\Msmq mappájában találhatók, és az új számítógép \System32\Msmq mappájába kell őket másolni.

Megjegyzés

  • Az MSMQ Explorer programra csak azokon a (Windows 2000 rendszert futtató) Message Queuing számítógépeken van szükség, amelyek MSMQ 1.0 vezérlőkiszolgálókkal kommunikálnak. Ha egy MSMQ 1.0 vezérlőkiszolgálót Message Queuing kiszolgálóra frissít, az MSMQ Explorer programra többé nincs szükség, és az nem is fog működni az ügyfélszámítógépen.


MSMQ 1.0 számítógépek frissítése

Az elsődleges vállalati vezérlő (primary enterprise controller, PEC) és az elsődleges helyvezérlők (primary site controller, PSC) frissítése a Message Queuing frissítése varázsló segítségével történik, amely a Windows 2000 Server telepítése után a Kiszolgáló konfigurálása varázslón keresztül érhető el. Más MSMQ szoftverkomponensek frissítése automatikusan megtörténik a Windows 2000 telepítése során.

Az MSMQ 1.0 vezérlőkiszolgálókat a következő sorrendben kell frissíteni:

  1. Az elsődleges vállalati vezérlőt (PEC).
  2. Ezután az összes hely másodlagos helyvezérlőjét (BSC).
  3. Ezután az összes hely elsődleges helyvezérlőjét (PSC).

Nem kell egy helyen befejezni a számítógépek frissítését, mielőtt megkezdené egy másik helyen a frissítési eljárást. Egyidejűleg több hely is frissíthető.

Az MSMQ 1.0 vezérlőkiszolgálók frissítésével kapcsolatos további tájékoztatásért tanulmányozza a Feladatlista: Az MSMQ 1.0 vezérlőkiszolgálók frissítése című részt.

Az MSMQ 1.0 kiszolgálófürtön történő frissítésével kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ 1.0 frissítése kiszolgálófürtön című részt.

A Message Queuing frissítése varázsló használata

Ebben a fejezetben arról olvashat, hogy a Message Queuing frissítése varázslót hogyan kell használni a vállalatnál található PEC és PSC kiszolgálók frissítéséhez. A Message Queuing frissítése varázsló használata előtt olvassa el a frissítési követelményeket és a frissítéssel kapcsolatos megfontolásokat.

Ha minden frissítési követelménynek eleget tett, a számítógépet előléptette Windows 2000 tartományvezérlővé, és bejelentkezett a Vállalati rendszergazdák csoport tagjaként, készen áll a Message Queuing frissítése varázsló futtatására. A varázsló az MQIS adatbázisban található információkat átviszi az Active Directory címtárszolgáltatásba. A frissített számítógépen a Message Queuing szolgáltatás a Message Queuing frissítése varázsló befejezése után elindul.

A varázsló először hibákat és inkonzisztenciákat keres az MQIS adatbázisban, majd az eredményt egy naplófájlba menti, ahol azt meg lehet vizsgálni. Ezután importálja az MQIS adatbázist az Active Directory címtárba. Erősen ajánlott a varázsló kérdésére az adatbázis-vizsgálati beállítás megadása, majd egy naplózási típus kiválasztása. Ez lehetővé teszi a naplófájl vizsgálatát, és eldöntheti, hogy szeretné-e folytatni a varázsló futtatását.

Megjegyzés

  • Ha számítógépen a varázslót másodszor is futtatni kell, akkor előbb a Message Queuing szolgáltatást le kell állítani. A varázsló befejeződése után újraindíthatja a Message Queuing szolgáltatást.

Az MSMQ elsődleges vállalati vezérlő frissítése

A Message Queuing frissítése varázsló először az elsődleges vállalati vezérlőt (PEC) frissíti. Ezt a számítógépet először olyan Windows 2000 tartományvezérlővé kell előléptetni, amely globáliskatalógus-kiszolgálónak van beállítva, valamint rajta a delegációs meghatalmazás engedélyezve van.

Egy számítógép Windows 2000 tartományvezérlőként történő konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza a Feladatlista: Tartományvezérlő telepítése című részt. Egy tartományvezérlő globáliskatalógus-kiszolgálóként történő konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza a Számítógép beállítása globáliskatalógus-kiszolgálóként című fejezetet. A delegálásra történő meghatalmazás beállításával kapcsolatos további tájékoztatásért tanulmányozza a Számítógép delegációs meghatalmazásának beállítása című témakört.

A frissített PEC számítógépen elindul a Message Queuing replikációs szolgáltatás, amely szinkronizálja az összes MSMQ 1.0 vezérlőkiszolgálón lévő MQIS adatbázis és az Active Directory adatait. A frissített számítógépen a Message Queuing szolgáltatásnak is futnia kell ahhoz, hogy a replikációt végre lehessen hajtani. Alapértelmezés szerint a replikáció 15 percenként történik. A számítógépről nem lehet eltávolítani a Message Queuing szoftvert, miközben a Message Queuing replikációs szolgáltatás fut (egyes PSC-k vagy BSC-k még nincsenek frissítve). A vállalatnál található utolsó PSC vagy BSC frissítése után a Message Queuing replikációs szolgáltatás automatikusan megáll.

Ha a vállalatnál több Windows tartomány található, a Message Queuing replikációs szolgáltatásnak egy vállalati rendszergazda felhasználói fiók alatt kell futnia (vagy a Vállalati rendszergazdák csoporthoz kell tartoznia). Ha további információra van szüksége azzal kapcsolatban, hogyan lehet módosítani a felhasználói fiókot, amely alatt egy szolgáltatás fut, olvassa el a Message Queuing szolgáltatásfiók módosítása című részt. Ezt ellenőrizheti, ha duplán kattint a részletek ablaktáblán a Message Queuing replikálás elemre (a Message Queuing helyett).

Vegyes módú környezetben a Windows NT 4.0 rendszert futtató MSMQ 1.0 számítógépek támogatása érdekében a Message Queuing frissítése varázsló automatikusan gyengíti a biztonságot a frissített PEC számítógépen az Active Directory számára. További tájékoztatásért tanulmányozza A gyengített biztonsággal kapcsolatos megfontolások című fejezetet.

Az MSMQ másodlagos helyvezérlők frissítése

A BSC számítógépeket minden helyen a PSC számítógépek frissítése előtt kell frissíteni (kivéve azt a helyet, ahol a PEC található, amely annak a helynek a PSC-je is egyben).

A másodlagos helyvezérlők (BSC-k) útválasztó szolgáltatással rendelkező Message Queuing kiszolgálókra történő frissítése automatikusan megtörténik a Windows 2000 Server telepítése során, felhasználói közreműködés nélkül. Ha az operációs rendszer frissítése során a számítógépet Windows 2000 tartományvezérlővé léptette elő, a frissített kiszolgáló az Active Directory címtárszolgáltatáshoz is hozzáférést biztosít. Ebben az esetben a számítógépnek delegálásra meghatalmazottnak is kell lennie.

Az MSMQ elsődleges helyvezérlők frissítése

A BSC számítógépeket minden helyen a PSC számítógépek frissítése előtt kell frissíteni (kivéve azt a helyet, ahol a PEC található, amely annak a helynek a PSC-je is egyben). Minden PSC számítógépet először Windows 2000 tartományvezérlővé kell előléptetni, engedélyezni kell rajtuk a delegálásra történő meghatalmazást, valamint esetleg globáliskatalógus-kiszolgálóként kell őket konfigurálni (ha a hely egyik tartományvezérlőjén nem fut másik Message Queuing kiszolgáló).

A Message Queuing frissítése varázsló összehasonlítja a PSC-n található MQIS adatbázist az Active Directory címtárral, és kijavítja a kettő közötti ellentmondásokat. Ha a PSC-n található MQIS és az Active Directory között ellentmondások vannak, a rendszer az Active Directory címtárat változtatja meg, hogy az megegyezzen a PSC számítógépen található MQIS adatbázissal. Ezért fontos, hogy az összes MSMQ 1.0 vezérlőkiszolgáló szinkronizálva legyen a frissítés megkezdése előtt.

Az MSMQ útválasztó-kiszolgálók, az MSMQ-ügyfelek és az MSMQ-Exchange összekötő frissítése

Az MSMQ útválasztó kiszolgálók, a független és függő MSMQ-ügyfelek, valamint az MSMQ-Exchange összekötő frissítése automatikusan megtörténik a Windows 2000 telepítése során, felhasználói beavatkozás nélkül. A telepítés során meg kell adni a hely Windows 2000 tartományvezérlőjén futó Message Queuing kiszolgáló nevét.

Ezeket a számítógépeket nem szükséges meghatározott sorrendben frissíteni.

Az MSMQ 1.0 frissítése egy kiszolgálófürtön

A következő témakör csak azokra Windows 2000 Advanced Server felhasználókra vonatkozik, akiknek frissíteni kell egy MSMQ 1.0-t futtató meglévő kiszolgálófürtöt. A Windows 2000 Message Queuing szolgáltatása már támogatja az aktív/aktív feladatátvételt (a várólistákét is). A Message Queuing által a kiszolgálófürtökön biztosított szolgáltatásokkal kapcsolatos további tájékoztatásért tanulmányozza a Fürtszolgáltatások című részt.

Az előzőekben említett frissítési követelményeken és megfontolásokon kívül a kiszolgálófürtökre az alábbiak is vonatkoznak:

  • Egy fürt csomópontjának Windows 2000 Advanced Server rendszerre történő frissítéséhez azon Windows NT Server Enterprise Edition rendszernek kell futni Service Pack 4 (SP4) vagy Service Pack 5 (SP5) szervizcsomaggal.
  • Mielőtt egy csomóponton frissítené az MSMQ 1.0 szoftvert, a csomópont operációs rendszerét kell frissíteni Windows 2000 Advanced Server rendszerre. További tájékoztatásért tanulmányozza a Windows 2000 Advanced Server - Az első lépések című kiadványt, vagy nyissa meg a Windows 2000 Server CD-ROM \Setuptxt mappáját.
  • A Message Queuing fürterőforrások konfigurálása varázsló (és a Message Queuing frissítése varázsló) futatásához vállalati rendszergazdai jogosultsággal kell rendelkeznie (vagy a Vállalti rendszergazdák csoporthoz kell tartoznia).
  • Az MSMQ 1.0 kiszolgálófürtön történő gördülő frissítése (rolling upgrade) nem támogatott.

A következő részekben részletes információ olvasható arról, hogyan lehet egy kiszolgálófürtön a különböző MSMQ 1.0 számítógéptípusokat frissíteni. Külön megjegyzés hiányában az MSMQ 1.0 frissítése egy kiszolgálófürt minden számítógéptípusán a következő sorrendben történik:

  1. A Message Queuing frissítése varázsló (Mqmig.exe) futtatása a PEC és a PSC számítógépeken.
  2. Az operációs rendszer frissítése Windows 2000 Advanced Server rendszerre.
  3. Az MS DTC erőforrás frissítése.
  4. Az MSMQ erőforrás frissítése.

Megjegyzés

  • Olyan MSMQ 1.0-t futtató számítógép is frissíthető Windows 2000 kiszolgálófürtre, amely nem tagja egy meglévő kiszolgálófürtnek. Ehhez először a számítógép operációs rendszerét kell Windows 2000 Advanced Server rendszerre frissíteni, telepíteni kell a fürtszoftvert, ezután lehet létrehozni egy új Message Queuing erőforrást. Az erőforrások Message Queuing számára történő létrehozásával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing erőforrások konfigurálása kiszolgálófürtök számára című részt.

Az MS DTC erőforrás frissítése

Miután minden csomópont operációs rendszerét frissítette Windows 2000 Advanced Server rendszerre, de még mielőtt bármely csomóponton frissítené az MSMQ 1.0 szoftvert, a Fürtfelügyelet program segítségével frissítenie kell a Microsoft elosztott tranzakciók koordinátora (MS DTC) erőforrást aktív/aktív konfigurációra.

Az MS DTC erőforrás kiszolgálófürtön történő frissítéséhez használja a következő eljárást:

  1. Kapcsolja le a hálózatról az MS DTC fürterőforrást.
  2. Ellenőrizze, hogy az MS DTC fürterőforrástól függő összes szolgáltatás le lett-e állítva, beleértve a következőket: Message Queuing, Komponensszolgáltatások, Microsoft SQL Server és Microsoft COMTI.
  3. Futtassa a Comclust.exe programot a parancssorból azon a csomóponton, amelyen az MS DTC fürterőforrást tartalmazó fürtözött virtuális kiszolgáló található. Ez a program a rendszermappában található (általában C:\Winnt\System32).
  4. Futassa a Comclust.exe programot az összes többi csomóponton is. Csak akkor kapcsolja vissza az MS DTC fürterőforrást a hálózatra, ha a Comclust.exe program már a kiszolgálófürt minden csomópontján fut.
  5. Indítsa újra kézzel az összes függő szolgáltatást, majd kapcsolja vissza a hálózatra az MS DTC fürterőforrást.

A Fürtfelügyelet programmal kapcsolatos további tájékoztatásért tanulmányozza A Fürtfelügyelet használata című fejezetet. A fürterőforrások kezelésével kapcsolatos további tájékoztatásért tanulmányozza az Erőforrások kezelése című részt.

Az MSMQ erőforrás frissítése

Miután az előzőekben leírtak szerint sikeresen frissítette az MS DTC erőforrást, a Message Queuing fürterőforrások konfigurálása varázsló segítségével frissítse az MSMQ erőforrást annak érdekében, hogy az támogassa az aktív/aktív feladatátvételt.

A Message Queuing fürterőforrások konfigurálása varázsló (és a Message Queuing frissítése varázsló) futatásához vállalati rendszergazdai jogosultsággal kell rendelkeznie (vagy a Vállalti rendszergazdák csoporthoz kell tartoznia).

A Kiszolgáló konfigurálása ablakban kattintson a Telepítés befejezése gombra, majd kattintson a Message Queuing fürterőforrások konfigurálása elemre. Kövesse a Message Queuing fürterőforrások konfigurálása varázsló ablakban megjelenő utasításokat.

A PEC frissítése egy kiszolgálófürtön

A PEC kiszolgálófürtön történő frissítése három lépésből áll. Először az MQIS-ben lévő adatok importálása történik meg a PEC-ről egy olyan Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálóba, amely a kiszolgálófürtön kívül helyezkedik el. Ezután a vállalat összes többi PSC és BSC számítógépének frissítése történik meg oly módon, hogy a rendszer a PEC nevét annak a tartományvezérlőnek a nevére cseréli le, amelyre az MQIS importálva lett. Végül a PEC frissítése történik meg egy engedélyezett útválasztással rendelkező Message Queuing kiszolgálóra.

A Message Queuing frissítése varázsló importálja az MQIS adatbázist az Active Directory címtárszolgáltatásba, majd a PEC helyén lévő összes BSC-n és az összes PSC-n szereplő nevet a PEC nevéről annak a tartományvezérlőnek a nevére módosítja, amelyen a varázsló fut.

A varázsló futásának befejeződése után vizsgálja meg az All Servers To Update szakaszt az Mqseqnum.ini fájlban, amely a rendszermappában található (általában C:\Winnt\System32). Ebben a szakaszban azok a kiszolgálók láthatók, amelyeken nem volt sikeres a név frissítése. A Message Queuing frissítése varázsló nem tudja frissíteni azokat a BSC és PSC számítógépeket, amelyek a varázsló futatásakor nem voltak elérhetők, vagy ki voltak kapcsolva.

A Message Queuing frissítése varázsló futtatását addig kell ismételgetni, amíg egyetlen kiszolgáló sem szerepel az Mqsecnum.ini fájl All Servers To Update szakaszában.

Egy kiszolgálófürtben levő PEC frissítéséhez kövesse az alábbi eljárást:

  1. Állítsa le az MSMQ szolgáltatást a PEC számítógépen.
  2. Jelentkezzen be vállalati rendszergazdai engedéllyel egy, a kiszolgálófürtön kívül elhelyezkedő Message Queuing kiszolgálón, amely egy globáliskatalógus-kiszolgálóként konfigurált Windows 2000 tartományvezérlőn fut.
  3. Futtassa a Message Queuing frissítése varázslót ezen a tartományvezérlőn oly módon, hogy a következő parancsot írja be a parancssorba:

    mqmig /c /s az_MSMQ_Explorerben_megjelenő_PEC_neve

  4. Vizsgálja meg a rendszermappában (általában C:\Winnt\System32) található Mqseqnum.ini fájl All Servers To Update szakaszát, ahol azok a PSC és BSC számítógépek láthatók, amelyek a varázsló futtatásakor nem voltak bekapcsolva, vagy más okból nem voltak elérhetők. Ezeket a kiszolgálókat a Message Queuing frissítése varázsló nem frissíti az új információkkal.
  5. Ha az Mqseqnum.ini fájlban szerepelnek PSC vagy BSC számítógépek, futtassa újra a varázslót (ugyanazon a tartományvezérlőn) oly módon, hogy a parancssorban kiadja az mqmig /u parancsot.
  6. Addig ismételje az előző két lépést, amíg nem szerepel több kiszolgáló az Mqsecnum.ini fájl All Servers To Update szakaszában.
  7. Amikor az összes PSC és BSC számítógépet sikeresen frissítette a varázsló, a PEC helyén lévő minden egyes BSC számítógépen állítsa le, majd indítsa újra az MSMQ szolgáltatást.
  8. Az összes többi helyen állítsa le, majd indítsa újra a PSC számítógépen az MSMQ szolgáltatást.
  9. Az összes többi helyen állítsa le, majd indítsa újra a hely összes BSC számítógépén az MSMQ szolgáltatást.
  10. Frissítse minden csomópont operációs rendszerét Windows 2000 Advanced Server rendszerre.
  11. Minden csomóponton frissítse az MS DTC erőforrást a Comclust.exe program segítségével, a fentiekben leírtak szerint.
  12. Minden csomóponton frissítse az MSMQ 1.0 erőforrást a Message Queuing fürterőforrások konfigurálása varázsló segítségével, a fentiekben leírtak szerint.

A BSC számítógépek frissítése egy kiszolgálófürtön

A BSC számítógépek frissítése egy kiszolgálófürtben engedélyezett útválasztással rendelkező Message Queuing kiszolgálókra történik.

A BSC számítógépek kiszolgálófürtben történő frissítéséhez kövesse az alábbi eljárást:

  1. Frissítse minden csomópont operációs rendszerét Windows 2000 Advanced Server rendszerre.
  2. Minden csomóponton frissítse az MS DTC erőforrást a Comclust.exe program segítségével, a fentiekben leírtak szerint.
  3. Minden csomóponton frissítse az MSMQ 1.0 erőforrást a Message Queuing fürterőforrások konfigurálása varázsló segítségével, a fentiekben leírtak szerint.

PSC számítógép frissítése kiszolgálófürtön

Egy kiszolgálófürtön levő PSC frissítése három lépésből áll. Először az MQIS-ben lévő adatok importálása történik meg a PSC-ről egy olyan Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálóba, amely a kiszolgálófürtön kívül helyezkedik el. Ezután a Message Queuing frissítése varázsló frissíti az Active Directory címtárszolgáltatást azokkal az információkkal, amelyek nem voltak replikálva a PEC-en, amikor a PEC frissítése megtörtént. Végül a PSC frissítése történik egy engedélyezett útválasztással rendelkező Message Queuing kiszolgálóra.

A PSC számítógépek kiszolgálófürtben történő frissítéséhez kövesse az alábbi eljárást:

  1. Állítsa le az MSMQ szolgáltatást a PSC számítógépen.
  2. Jelentkezzen be vállalati rendszergazdai engedéllyel egy, a kiszolgálófürtön kívül elhelyezkedő Message Queuing kiszolgálón, amely egy globáliskatalógus-kiszolgálóként konfigurált Windows 2000 tartományvezérlőn fut.
  3. Futtassa a Message Queuing frissítése varázslót ezen a tartományvezérlőn oly módon, hogy a következő parancsot írja be a parancssorba:

    mqmig /c /s az_MSMQ_Explorerben_megjelenő_PSC_neve

  4. Frissítse minden csomópont operációs rendszerét Windows 2000 Advanced Server rendszerre.
  5. Minden csomóponton frissítse az MS DTC erőforrást a Comclust.exe program segítségével, a fentiekben leírtak szerint.
  6. Minden csomóponton frissítse az MSMQ 1.0 erőforrást a Message Queuing fürterőforrások konfigurálása varázsló segítségével, a fentiekben leírtak szerint.

MSMQ útválasztó-kiszolgálók és független ügyfelek frissítése egy kiszolgálófürtön

Az MSMQ 1.0 útválasztó-kiszolgálók frissítése egy kiszolgálófürtben engedélyezett útválasztással rendelkező Message Queuing kiszolgálókra történik. Az MSMQ 1.0 független ügyfeleket a rendszer Message Queuing független ügyfelekre frissíti.

Ezen számítógépek kiszolgálófürtben történő frissítéséhez kövesse az alábbi eljárást:

  1. Frissítse minden csomópont operációs rendszerét Windows 2000 Advanced Server rendszerre.
  2. Minden csomóponton frissítse az MS DTC erőforrást a Comclust.exe program segítségével, a fentiekben leírtak szerint.
  3. Minden csomóponton frissítse az MSMQ 1.0 erőforrást a Message Queuing fürterőforrások konfigurálása varázsló segítségével, a fentiekben leírtak szerint.


Új Message Queuing kiszolgálók telepítése

Ebben a fejezetben a Message Queuing kiszolgáló olyan számítógépekre történő telepítéséről olvashat, amelyeken az MSMQ 1.0 nincs telepítve. Az MSMQ 1.0 kiszolgálószoftver frissítésével kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing frissítése - áttekintés című fejezetet.

A Message Queuing programot minden Windows 2000 tartományban először egy Windows 2000 tartományvezérlőre kell telepíteni. Ha a Message Queuing szolgáltatást a hely vagy tartomány más számítógépeire is telepíti, a rendszer ennek a tartományvezérlőnek a nevét használja a telepítéshez. Ha egy későbbi telepítés során nem lehet ilyen tartományvezérlőt találni, a Message Queuing telepítése munkacsoport módban történik meg. Munkacsoport módú működés esetén az üzenetküldéshez közvetlen kapcsolat szükséges. Az ilyen számítógépek minden újraindításakor a Message Queuing megpróbál megkeresni egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálót. Ha sikerrel jár, a Message Queuing tartomány módban folytatja a működését, amelyhez az Active Directory címtárszolgáltatáshoz történő hozzáférés szükséges.

A Message Queuing kiszolgáló telepítése előtt eleget kell tenni az alábbi követelményeknek:

  • A Message Queuing kiszolgáló Windows 2000 tartományvezérlőre történő telepítéséhez tartománygazdai engedélyekkel kell rendelkeznie, vagy a Tartománygazdák csoporthoz kell tartoznia.
  • Útválasztási szolgáltatással rendelkező Message Queuing kiszolgáló nem tartományvezérlőre történő telepítéséhez vállalati rendszergazdai engedélyekkel kell rendelkeznie, vagy a Vállalati rendszergazdák csoporthoz kell tartoznia.
  • A Message Queuing eltávolításához MSMQ konfigurációs objektumok törlése engedéllyel kell rendelkezni.

A telepítéshez szükséges felügyeleti engedélyekkel kapcsolatos további tájékoztatásért tanulmányozza a Telepítési engedélyek című fejezetet.

Message Queuing kiszolgáló telepítése Windows 2000 tartományvezérlőre

A jobb teljesítmény és méretezhetőség érdekében ajánlott minden tartományban több Windows 2000 tartományvezérlőre telepíteni a Message Queuing kiszolgálószoftvert, valamint minden helyen legalább egy tartományvezérlőre telepíteni kell Message Queuing kiszolgálót. Ezen kívül nem ajánlott engedélyezni az útválasztási szolgáltatásokat a tartományvezérlőkön futó Message Queuing kiszolgálók számára; az ilyen Message Queuing kiszolgálókat inkább nem tartományvezérlőként működő számítógépekre telepítse.

Olyan Message Queuing kiszolgáló telepítéséhez, amely hozzáférést fog biztosítani az Active Directory címtárszolgáltatáshoz, a számítógépet először Windows 2000 tartományvezérlővé kell előléptetni. Egy számítógép Windows 2000 tartományvezérlővé történő előléptetésével kapcsolatos további tájékoztatásért tanulmányozza a Feladatlista: Tartományvezérlő telepítése című részt.

Minden helyen az első Message Queuing kiszolgáló telepítésekor a tartományvezérlőt globáliskatalógus-kiszolgálónak is be kell állítani. Egy tartományvezérlő globáliskatalógus-kiszolgálóként történő konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza a Számítógép beállítása globáliskatalógus-kiszolgálóként című fejezetet. Az Active Directory globális katalógusával kapcsolatos további tájékoztatásért tanulmányozza a Globális katalógus című fejezetet.

A megfelelő tartományvezérlőkön a Message Queuing telepítése előtt ellenőrizze azt is, hogy azok delegálásra meghatalmazottak-e. Ez a tulajdonság alapértelmezés szerint engedélyezve van. Ha ez a tulajdonság nincs engedélyezve, a Message Queuing szolgáltatás nem tud futni. Ennek a tulajdonságnak az ellenőrzésével kapcsolatos további tájékoztatásért tanulmányozza a Számítógép delegációs meghatalmazásának beállítása című témakört.

Az erdő első Message Queuing kiszolgálójának telepítésekor meg kell adnia, hogy szükség van-e a biztonság gyengítésére. Ez egy választható működési mód. A Windows NT 4.0 alatt futó MSMQ 1.0 ügyfeleket futtató és a Helyi felhasználói fiókkal bejelentkezett számítógépek hatékony támogatásához az Active Directory biztonságát gyengíteni kell. További tájékoztatásért tanulmányozza A gyengített biztonsággal kapcsolatos megfontolások című fejezetet.

A Message Queuing kiszolgálók telepítésével kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing kiszolgálók telepítése című fejezetet.

További Message Queuing kiszolgálók telepítése

Ha egy tartomány alapú környezetben ugyanazon a helyen további számítógépekre szeretne Message Queuing kiszolgálót telepíteni, a telepítő megpróbál automatikusan megkeresni a helyen egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálót. Ha nem talál, a telepítés folytatásához meg kell adnia egy ilyen Message Queuing kiszolgálónak a DNS- vagy NetBIOS-nevét.

Ha egy útválasztási szolgáltatásokkal rendelkező Message Queuing kiszolgálót egy vegyes módú, tartomány alapú környezetbe telepít, meg kell adnia egy ugyanabban a tartományban található Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló nevét (nem egy MSMQ 1.0 vezérlőkiszolgáló nevét).

Egy útválasztással nem rendelkező Message Queuing kiszolgálót telepíthet nem tartományvezérlőre is munkacsoport környezetben (vagy bármely olyan környezetbe, amely nem nyújt címtárszolgáltatást, például Active Directoryt). Ebben az esetben az üzenetküldéshez közvetlen kapcsolat szükséges.


Új Message Queuing ügyfelek telepítése

Ebben a fejezetben a Message Queuing ügyfélszoftver olyan számítógépekre történő telepítéséről olvashat, amelyeken az MSMQ 1.0 nincs telepítve. Telepíthet független ügyfeleket vagy függő ügyfeleket. Amikor csak lehetséges, ajánlott független ügyfeleket telepíteni. Az MSMQ 1.0 ügyfélszoftver frissítésével kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing frissítése - áttekintés című fejezetet.

A Message Queuing ügyfélszoftver telepítése előtt eleget kell tenni az alábbi követelményeknek:

  • Egy ugyanazon a helyen lévő Windows 2000 tartományvezérlőn már telepítve kell lennie és futnia kell egy Message Queuing kiszolgálónak.
  • Helyi rendszergazdai engedéllyel kell bejelentkeznie.
  • A Message Queuing eltávolításához MSMQ konfigurációs objektumok törlése engedéllyel kell rendelkezni.

A telepítéshez szükséges engedélyekkel kapcsolatos további tájékoztatásért tanulmányozza a Telepítési engedélyek című fejezetet.

Független ügyfél telepítése

Független ügyfelek csak Windows 2000 Professional rendszert futtató számítógépekre telepíthetők.

A telepítő megpróbál automatikusan megkeresni a helyen egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálót. Ha nem talál, meg kell adnia egy ilyen Message Queuing kiszolgálónak a DNS- vagy NetBIOS-nevét. Ha nem létezik ilyen tartományvezérlő, a Message Queuing telepítése munkacsoport módban történik meg. Munkacsoport módú működés esetén közvetlen kapcsolat szükséges az üzenetküldéshez. Az ilyen számítógépek minden újraindításakor a Message Queuing megpróbál megkeresni egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálót. Ha sikerrel jár, a Message Queuing tartomány módban folytatja a működését, amelyhez az Active Directory címtárszolgáltatáshoz történő hozzáférés szükséges.

Független ügyfelet telepíthet nem tartományvezérlőre is munkacsoport környezetben (vagy bármely olyan környezetben, amely nem nyújt címtárszolgáltatást, például Active Directoryt). Ebben az esetben az üzenetküldéshez közvetlen kapcsolat szükséges.

Windows 2000 Server esetén, egy útválasztással nem rendelkező, nem tartományvezérlőn futó Message Queuing kiszolgáló ugyanazokat a funkciókat nyújtja, mint egy független ügyfél.

A független ügyfelek telepítésével kapcsolatos további tájékoztatásért tanulmányozza a Független ügyfelek telepítése című fejezetet.

Függő ügyfél telepítése

A függő ügyfélszoftver telepíthető Windows 2000 Server vagy Windows 2000 Professional rendszert futtató számítógépekre, de nem telepíthető Windows 2000 tartományvezérlőkre.

A függő ügyfeleket (a várólisták és az üzenetek tárolásában) támogató Message Queuing kiszolgáló neve támogató kiszolgáló. A telepítő megpróbál automatikusan megtalálni a helyen egy ilyen Message Queuing kiszolgálót. Ha nem talál ilyet, egy üzenet jelenik meg, hogy a kiszolgáló nem elérhető. Ekkor megadhat egy másik Message Queuing kiszolgálót, vagy kattintson a Mégse gombra. A telepítés akkor is sikeresen befejeződik, ha a Mégse gombra kattint. Ezt a tulajdonságot kihasználva telepíthetők függő ügyfelek a támogató Message Queuing kiszolgáló telepítése előtt.

A függő ügyfeleknek és a támogató kiszolgálóknak nem kell ugyanazon a helyen lenniük. Mivel azonban a függő ügyfelek minden kommunikációja a támogató Message Queuing kiszolgálón megy keresztül, ha a támogató kiszolgálóval történő kommunikáció lassú vagy drága, az összes ügyfélkommunikáció is lassú vagy drága lesz.

A függő ügyfelek telepítésével kapcsolatos további tájékoztatásért tanulmányozza a Függő ügyfelek telepítése című fejezetet.

Megjegyzés

  • Ha egy MSMQ 1.0 függő ügyfél Windows NT 4.0 rendszeren fut, és a támogató kiszolgálóját egy Windows 2000 rendszeren futó Message Queuing kiszolgálóra szeretné módosítani, a függő ügyfélen a Windows NT Service Pack 4 szervizcsomagnak telepítve kell lennie, ellenkező esetben a tranzakció alapú üzenetküldés nem fog működni.


Új MSMQ-Exchange összekötő telepítése

Csak akkor telepítse az MSMQ-Exchange összekötőt, ha szükség van arra, hogy a Message Queuing ügyfelek kommunikálhassanak Microsoft Exchange ügyfelekkel. A MSMQ-Exchange összekötő nem kerül telepítésre a Message Queuing telepítése során, mivel ahhoz külön telepítőprogram tartozik. Az MSMQ-Exchange összekötőt Message Queuing kiszolgálóra kell telepíteni.

Az MSMQ-Exchange összekötő működéséhez a Microsoft Exchange Server 4.0a (4.0 és a Microsoft Exchange Service Pack 2) vagy újabb verziója szükséges, és az Exchange Administrator programnak telepítve kell lennie.

Az MSMQ-Exchange összekötőt (és a szükséges Message Queuing kiszolgálószoftvert) nem kell feltétlenül Microsoft Exchange Server kiszolgálót futtató számítógépre telepíteni. Az MSMQ-Exchange összekötő telepíthető másik számítógépre is, és beállítható az Exchange Server kiszolgálót futtató számítógéppel történő kommunikációra. Az MSMQ-Exchange összekötő ilyen módon történő telepítéséhez először az Exchange Server kiszolgálót futtató számítógépre kell telepíteni az Exchange Administrator programot. Az Exchange Administrator program telepítéséhez futtassa az Exchange Server telepítőjét, kattintson a Teljes/Egyedi lehetőségre, majd jelölje be (csak) a Microsoft Exchange Administrator jelölőnégyzetet.

Az MSMQ-Exchange összekötő telepítője módosítja a jelenlegi Microsoft Exchange helykonfigurációt annak érdekében, hogy az felismerje az összekötőt. A Microsoft Exchange helykonfigurációjának módosításához a helyre rendszergazdai engedéllyel kell bejelentkeznie, amikor az MSMQ-Exchange összekötő telepítőjét futtatja. A Microsoft Exchange helyek szerepköreinek beállításával kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Exchange Server dokumentációját.

A Microsoft Exchange ügyfélszoftvert nem kell telepíteni az Exchange ügyfeleknek üzenetet küldő Message Queuing ügyfélszámítógépeken, valamint a Message Queuing szoftvert sem kell telepíteni az Exchange ügyfélszámítógépeken.

Megjegyzés

  • Ha az MSMQ-Exchange összekötőt egy kiszolgálófürtre telepíti, ajánlott azt egy másik számítógépre telepíteni, mint amelyiken a Microsoft Exchange Server telepítve van. Mivel a Microsoft Exchange Server kiszolgálón további beállítások szükségesek ahhoz, hogy az fürtkörnyezetben is helyesen működjön, ellenben az MSMQ-Exchange összekötő esetén erre nincs szükség, ami megkönnyíti a telepítést és a hibaelhárítást.

Az MSMQ-Exchange összekötő telepítése

Állapítsa meg a következőket az MSMQ-Exchange összekötő telepítőjének futtatása előtt:

  • A Microsoft Exchange Server kiszolgálót futtató számítógép neve, amellyel az MSMQ-Exchange összekötő kommunikálni fog.
  • A Microsoft Exchange helynek a neve, amelyet az MSMQ-Exchange összekötő támogatni fog.
  • Az összekötő-várólistának a neve (a Message Queuing kiszolgálón), amelyből az MSMQ-Exchange összekötő a bejövő Message Queuing üzeneteket fogja kiolvasni. Ha az MSMQ-Exchange összekötő telepítésekor a megadott várólista nem létezik, az MSMQ-Exchange összekötő szolgáltatás létrehozza azt az első indulás alkalmával.
  • A felhasználói fiókhoz tartozó felhasználónév és jelszó, amely alatt az MSMQ-Exchange összekötő szolgáltatás fut. Az MSMQ-Exchange összekötő szolgáltatásnak olyan felhasználói fiók alatt kell futnia, amely megfelelő engedélyekkel rendelkezik a Microsoft Exchange Server helyén történő működéshez. Ezenkívül a felhasználói fióknak a Microsoft Exchange hely szerepköre View Only Admin értékű kell legyen. Ennek nem kell megegyezni azzal a felhasználói fiókkal, amely alól az MSMQ-Exchange összekötő telepítőjét futtatja.
  • Annak a mappának az elérési útvonala, amely az MSMQ-Exchange összekötő üzenet- és naplófájljait fogja tartalmazni. Ha az MSMQ-Exchange összekötő telepítése során megadott mappa nem létezik, a telepítő létrehozza azt.

Az MSMQ-Exchange összekötő telepítésével kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ-Exchange összekötő telepítése című részt.

Az MSMQ-Exchange összekötő telepítése utáni konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ-Exchange összekötő felügyelete című részt.

Az MSMQ-Exchange összekötő eltávolításával kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ-Exchange összekötő eltávolítása című részt.

Megjegyzés

  • Ha a Message Queuing szoftver eltávolításához a Message Queuing telepítőjét futtatja, miközben az MSMQ-Exchange összekötő szolgáltatás fut azon a számítógépen, a telepítő megjelenít egy üzenetet, hogy egy Message Queuing alkalmazás még fut, majd kilép a rendszerből. Ezért a Message Queuing eltávolítása előtt le kell állítani az MSMQ-Exchange összekötő szolgáltatást. További tájékoztatásért tanulmányozza A Message Queuing szolgáltatásainak elindítása és leállítása című részt.


A Message Queuing felügyelet nélküli telepítése

A Message Queuing szoftver távoli telepítése a Windows felügyelet nélküli telepítése segítségével végezhető el, egy válaszfájl felhasználásával. Ennek a fájlnak vagy annak a forrásszámítógépnek a Message Queuing telepítési mappájában kell lennie, amelyen a felügyelet nélküli telepítést futtatja, vagy annak a célszámítógépnek a Windows rendszermappájában (általában C:\Winnt), amelyre a Message Queuing szoftvert telepíteni szeretné.

A Windows 2000 felügyelet nélküli telepítésével kapcsolatos további tájékoztatásért tanulmányozza A telepítő használata felügyelet nélküli módban című témakört.

A Message Queuing felügyelet nélküli telepítése során nem jelennek meg sem üzenetek, sem párbeszédpanelek. A hibák naplózása az Msmqinst.log fájlba történik, amely a célszámítógép Windows rendszermappájában (általában C:\Winnt) található.

Mivel egyes telepítési típusok esetén meg kell adni egy működő Message Queuing kiszolgáló nevét, ajánlott minden egyes Windows 2000 hely számítógépei számára külön telepítési parancsfájlt létrehozni. Ugyan több helyen is használható egyetlen parancsfájl, ebben az esetben azonban minden olyan számítógép számára külön bejegyzést kell létrehozni, amelyik nem a megadott (alapértelmezett) helyen található.

A Message Queuing felügyelet nélküli telepítésének futtatásához írja be a parancssorba a következő parancsot:

sysocmgr.exe /i:sysoc.inf /u:a válaszfájl neve és elérési útja

A válaszfájl bejegyzései

A válaszfájlban számos telepítési beállítás található:

Msmq=

A Message Queuing szoftver felügyelet nélküli telepítéséhez ennek msmq=ON értékűnek kell lennie. A Message Queuing szoftver felügyelet nélküli eltávolításához ennek msmq=OFF értékűnek kell lennie.

A felügyelet nélküli eltávolítás során a rendszer automatikusan eltávolítja az összes üzenetet és naplófájlt.

Type=

Ez a bejegyzés határozza meg, hogy melyik típusú Message Queuing összetevőt kell telepíteni. Három lehetséges értéke van: IND, RS és DEP.

Windows 2000 Server vagy Windows 2000 Advanced Server esetén az IND érték hatására a rendszer egy Message Queuing kiszolgálót telepít útválasztási szolgáltatások nélkül. Windows 2000 Professional esetén az IND érték hatására a rendszer egy független ügyfelet telepít. Ha a bejegyzés nincs megadva, a független ügyfél az alapértelmezett telepítési típus.

Windows 2000 Server vagy Windows 2000 Advanced Server esetén az RS érték hatására a rendszer egy Message Queuing kiszolgálót telepít engedélyezett útválasztási szolgáltatásokkal. Windows 2000 Professional rendszert futtató számítógép esetén nem adható meg az RS érték.

A DEP érték hatására a rendszer egy függő ügyfelet telepít. Függő ügyfél nem telepíthető Windows 2000 tartományvezérlőre.

ControllerServer=

Ez a bejegyzés annak a Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálónak a NetBIOS- vagy DNS-nevét adja meg, amely az adott helyen telepítésre kerülő Message Queuing telepítési típussal (IND vagy RS) fog kommunikálni. Ezt a bejegyzést nem feltétlenül kell megadni. A telepítő megkísérel automatikusan megtalálni egy ilyen kiszolgálót. Ha azonban nem jár sikerrel, a telepítés nem fog folytatódni. Ha meg van adva egy bejegyzés, a felügyelet nélküli telepítés során a rendszer nem kísérli meg automatikusan megtalálni a kiszolgálót.

Ne használja ezt a bejegyzést a Message Queuing szolgáltatás Windows 2000 tartományvezérlőre történő telepítésekor.

SupportingServer=

Ez a bejegyzés annak a Message Queuing kiszolgálónak a NetBIOS- vagy DNS-nevét adja meg, amely a telepítés alatt lévő függő ügyfelet fogja támogatni. Ezt a bejegyzést kötelező megadni.

ServerAuthenticationOnly=

Csak olyan ügyfelek esetén használja ezt a bejegyzést, amelyek Windows NT 4.0 rendszeren futó MSMQ 1.0 vezérlőkiszolgálókkal fognak kommunikálni, és amelyeknek hitelesíteniük kell az ilyen kiszolgálókat.

SupportLocalAccountsOrNT4=

Ez a bejegyzés azon számítógépekhez szükséges, amelyek Windows NT 4.0 rendszeren MSMQ 1.0-t futtatnak, illetve amelyeken Helyi felhasználói fiókkal jelentkeznek be. Ha ennek a bejegyzésnek az értéke true (igaz), ezek a számítógépek lekérdezhetik az Active Directory címtárat, és megtekinthetik a Message Queuing objektumokat. Ha értéke false (hamis), az ilyen számítógépek nem kérdezhetik le az Active Directory címtárat.

Az erdő egy Windows 2000 tartományvezérlőjére elsőként telepített Message Queuing kiszolgáló esetén ezt a bejegyzést true (igaz) értékre kell állítani.

Ez a beállítás gyengíti az Active Directory biztonságát. A bejegyzés beállításának biztonsági vonatkozásaival kapcsolatos további tájékoztatásért tanulmányozza a Gyengített biztonsági megfontolások című fejezetet.

Site=

Akkor használja ezt a bejegyzést, ha engedélyezett útválasztási szolgáltatásokkal rendelkező Message Queuing kiszolgálót telepít (RS telepítési típus). Előfordulhat, hogy a Message Queuing telepítője nem tudja automatikusan hozzárendelni a megfelelő helyet, ha a hálózat alhálózatai nincsenek megfelelően konfigurálva. Azt az alapértelmezett helyet kell megadnia, amely azt a Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálót tartalmazza, amellyel ez a kiszolgáló kommunikálni fog.

DisableAD=

Ezt a bejegyzést akkor kell használni, ha a Message Queuing szoftvert munkacsoport környezetbe vagy bármely olyan környezetbe telepíti, amely nem biztosít Active Directory címtárszolgáltatást. Ha értéke true (igaz), a rendszer a ControllerServer bejegyzést figyelmen kívül hagyja, és nem próbál meg kapcsolódni egy tartományvezérlőhöz az Active Directory eléréséhez. Ezeknek a számítógépeknek közvetlen kapcsolattal kell rendelkezniük a többi számítógéppel, hogy tudjanak üzeneteket küldeni és fogadni.

Ennek a bejegyzésnek csak akkor van hatása, ha egy független ügyfelet vagy egy útválasztással nem rendelkező Message Queuing kiszolgálót telepít egy nem tartományvezérlő számítógépre (Type=IND).

Minta-válaszfájl

Az alábbi minta-válaszfájlt sablonként használhatja. Egy szövegszerkesztő segítségével módosíthatja a bejegyzések értékeit.

Megjegyzés

  • A felügyelet nélküli telepítés figyelmen kívül hagyja azokat a bejegyzéseket, amelyek pontosvesszővel (;) kezdődnek. Ennek segítségével helyezhet el megjegyzéseket a válaszfájlban.

[Version]
  Signature = "$Windows NT$"

  [Global]
  FreshMode = Custom
  MaintenanceMode = RemoveAll
  UpgradeMode =  UpgradeOnly

  [Components]
  msmq = on | off

  [Msmq]
  Type = IND | RS | DEP
  ControllerServer = egy_tartományvezérlőn_lévő_message_queuing_kiszolgáló
  SupportingServer = egy_message_queuing_kiszolgáló_a_függő_ügyfelek_számára
  ServerAuthenticationOnly = false | true
  SupportLocalAccountsOrNT4 = false | true
  Site = a_tartományvezérlő_helye
  DisableAD = false | true

Mindig tesztelje a felügyelet nélküli telepítési parancsfájlt annak alkalmazása előtt.


A Message Queuing telepítése kiszolgálófürtre

Ez a fejezet azon felhasználók számára készült, akik a Windows 2000 Advanced Server rendszert kiszolgálófürt konfigurációban futtatják. A Message Queuing kiszolgálófürtre történő telepítésével aktív/aktív várólista-feladatátvétel valósítható meg egy számítógép meghibásodása esetén.

A Message Queuing szoftver egy kiszolgálófürt egy csomópontjára ugyanúgy telepíthető, mint bármely más kiszolgálóra. Azonban létezik néhány követelmény és megfontolás, amit figyelembe kell venni a Message Queuing kiszolgálófürtre történő telepítésekor:

  • A kiszolgálófürt minden számítógépére ugyanolyan típusú Message Queuing szolgáltatást kell telepíteni. Például ha az egyik csomópontra engedélyezett útválasztással rendelkező Message Queuing kiszolgálót telepít, akkor a többi csomópontra is olyan Message Queuing kiszolgálókat kell telepíteni, amelyeken engedélyezett az útválasztás.
  • Az MS DTC erőforrásnak on-line állapotban kell lennie a Message Queuing bármely csomópontra történő telepítése előtt.
  • A Message Queuing telepítése után a Message Queuing szolgáltatást minden csomóponton kézzel kell elindítani.

A Message Queuing szolgáltatás elindításával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing szolgáltatásainak elindítása és leállítása című részt.

A Message Queuing szolgáltatás kiszolgálófürtre történő telepítése után létre kell hozni egy erőforrást a Message Queuing számára a Fürtfelügyelet program segítségével, majd azt hozzá kell adni a fürtözött virtuális kiszolgálóhoz. A fürtözött virtuális kiszolgáló olyan fürtcsoport, amely tartalmaz Lemez és Hálózati név erőforrásokat. Egy fürtözött virtuális kiszolgáló egy fizikai kiszolgálóhoz hasonlóan működik.

A Message Queuing erőforrások kiszolgálófürtök számára történő beállításával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing erőforrások beállítása kiszolgálófürtök számára című részt.

Az erőforrások Fürtfelügyelet program segítségével történő beállításával kapcsolatos további tájékoztatásért tanulmányozza az Erőforrások kezelése című részt.

Az MSMQ 1.0 kiszolgálófürtön történő frissítésével kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ 1.0 frissítése kiszolgálófürtön című részt.


A Message Queuing eltávolítása

A Message Queuing szoftver számítógépről történő eltávolításához MSMQ konfigurációs objektum törlése engedéllyel kell rendelkezni. A telepítési engedélyekkel kapcsolatos további tájékoztatásért tanulmányozza a Telepítési engedélyek című fejezetet.

A Message Queuing telepítő futtatása

A Message Queuing eltávolítható a Vezérlőpulton levő Programok telepítése/törlése segédprogram használatával. A Message Queuing számítógépről történő eltávolításakor a Message Queuing telepítő eltávolítja a számítógép összes várólistáját (a privát várólistákat is) az Active Directory címtárból és a helyi számítógépről.

A Message Queuing kiszolgáló eltávolításakor az összes vonatkozó számítógép- és várólista- objektum törlésre kerül, valamint a kiszolgáló nevét is eltávolítja a rendszer a kiszolgálót használó ügyfelek üzenet-útválasztási listájából.

A Message Queuing szoftver eltávolításával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing eltávolítása című részt.

Ha át szeretne helyezni egy Message Queuing számítógépet egy másik tartományba, akkor el kell távolítani a számítógépről a Message Queuing szolgáltatást, majd az új tartományban újra kell azt telepíteni.

Message Queuing objektumok eltávolítása az Active Directory címtárból

Ha a Message Queuing szoftvert nem lehet eltávolítani egy számítógépről, például hardverhiba miatt, vagy ha már nem rendelkezik fizikai hozzáféréssel a számítógéphez, eltávolíthatja a számítógép Message Queuing objektumait az Active Directory címtárból.

Ha eltávolítja a Message Queuing objektumokat az Active Directory címtárból, a helyi számítógépen lévő várólistákat és üzeneteket is eltávolítja a rendszer. Azonban a Message Queuing szoftver, a rendszerleíró értékekkel és az üzenetküldő fájlokkal együtt a számítógépen marad.

Ha további információra van szüksége a Message Queuing objektumokkal, azok létrehozási helyével, valamint azok Active Directory címtáron belüli helyével kapcsolatban, tanulmányozza a Message Queuing objektumok az Active Directory címtárban című részt.

A Message Queuing objektumok Active Directory címtárból történő eltávolításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing objektumok eltávolítása az Active Directory címtárból című részt.

Megjegyzés

  • Az MsmqServices objektumot csak akkor szabad törölni, ha a Message Queuing szolgáltatást a vállalat minden számítógépéről eltávolítja. Ez az objektum a Message Queuing „vállalati” objektuma.


A Message Queuing biztonságossá tétele

Ez a rész azokat a biztonsági fogalmakat ismerteti, amelyek a Message Queuing vállalaton belüli használatához és telepítéséhez szükségesek.

  • A Message Queuing biztonságkezelése - áttekintés
  • A Message Queuing hozzáférés-vezérlése
  • A Message Queuing hitelesítése
  • A Message Queuing titkosítása
  • A Message Queuing naplózása


A Message Queuing biztonságkezelése - áttekintés

A Message Queuing kihasználja a Windows 2000 operációs rendszer beépített biztonsági szolgáltatásait. A Message Queuing a hozzáférés-vezérlést, a hitelesítést, a titkosítást és a naplózást használja a biztonságkezeléshez. Ugyanezekek a biztonsági folyamatokat használta az MSMQ 1.0 rendszer is. Azonban a Message Queuing a 40 bites titkosítás mellett mostantól a 128 bites titkosítást is támogatja.

Az Active Directoryban a Message Queuing objektumok felhasználói elérésének korlátozása a hozzáférés-vezérlés szolgáltatással történik, amely az objektumokhoz rendelt biztonsági leírókkal valósítható meg. Message Queuing objektumok lehetnek a következők: számítógép (msmq), várólista, útválasztási kapcsolat és MSMQ-beállítások objektumok. A biztonsági leíró tartalmazza azokat a felhasználókat és csoportokat, amelyek hozzáférhetnek vagy nem férhetnek hozzá az objektumhoz, emellett tartalmazza az ezekhez a felhasználókhoz és csoportokhoz hozzárendelt engedélyeket.

A hitelesítés nyilvános kulcsú bizonyítványok, a Kerberos V5 biztonsági protokoll és a Windows NTLM használatával van megvalósítva (a Windows NT 4.0 rendszeren futó MSMQ 1.0-val való kompatibilitás érdekében). Az üzenetek hitelesítése nyilvános kulcsú bizonyítványokkal történik, amelyek ellenőrzik az üzenet küldőjét (az ügyfelet) a Message Queuing kiszolgáló számára. A Kerberos V5 és az NTLM protokollokat a kiszolgáló hitelesítésére használják, amely ellenőrzi a Message Queuing kiszolgálót az ügyfél számára.

A titkosítás a nyilvános kulcsú (aszimmetrikus) és a titkos kulcsú (szimmetrikus) algoritmusokkal van megvalósítva. A titkosítást a Message Queuing alkalmazások a Message Queuing számítógépek között küldött üzenetek titkosítására használják.

A naplózást annak rögzítésére használják, hogy mely felhasználók próbáltak hozzáférni az Active Directory Message Queuing objektumaihoz. Az objektum biztonsági leírója határozza meg, hogy az objektum mely hozzáférési eseményeit kell naplózni.

Az objektumok biztonsági tulajdonságainak kezelésével beállíthatók az engedélyek, megváltoztatható a tulajdonos, valamint figyelhetők a felhasználói hozzáférések.

Ezenkívül további tényezőket is figyelembe kell venni, mielőtt a hálózaton konfigurálná a Message Queuing biztonságkezelést:

A gyengített biztonsággal kapcsolatos megfontolások

A Windows 2000 tartományvezérlőkön futó Message Queuing kiszolgálók az Active Directory gyengített biztonságát is használhatják. A gyengített biztonság engedélyezése (ha azt használják) az erdő Windows 2000 tartományvezérlőjének első Message Queuing kiszolgálója telepítése során történik meg. Ezt a beállítást ezután a rendszer az erdő minden tartományvezérlőjére átmásolja. A gyengített biztonságot a következő esetekben kell engedélyezni:

  • Vegyes módú tartománykörnyezetben, ahol a felhasználók MSMQ 1.0-t (Windows NT 4.0, Windows 95 vagy Windows 98 rendszerben) használnak a Windows 2000 tartományvezérlőkön futó Message Queuing kiszolgálók eléréséhez. (Ez akkor is érvényes, ha ezek a felhasználók Windows 2000 tartományfiókokkal jelentkeznek be.)
  • Vegyes módú tartománykörnyezetben, ahol a felhasználók Windows NT 4.0 tartományban futtatják a Message Queuing szolgáltatást (Windows 2000 rendszeren) MSMQ 1.0 vezérlő-kiszolgálók eléréséhez.
  • Olyan Windows 2000 tartományban, ahol a Message Queuing szolgáltatást (Windows 2000 rendszeren) futtató felhasználók Windows NT 4.0 tartományfiókokkal jelentkeznek be.
  • Olyan Windows 2000 tartományban, ahol a felhasználók csak az IPX protokollt támogató számítógépeket használnak.
  • Ha a felhasználók Helyi felhasználói fiókkal jelentkeznek be (tekintet nélkül az operációs rendszerre).

Ha a gyengített biztonság engedélyezve van, akkor ezek a számítógépek képesek lekérdezni a tartományvezérlőket, és megtekinthetik az Active Directory objektumok tulajdonságait. Ha nincs engedélyezve, ezek a számítógépek alapértelmezés szerint nem kérdezhetnek le az Active Directory címtárból. Pontosabban, ha engedélyezve van, a Mindenki csoport Olvasás engedéllyel rendelkezik a várólista tulajdonságaihoz és a várólista biztonságához.

Windows NT 4.0 rendszeren MSMQ 1.0-t használó felhasználók esetén, amikor az MSMQ szolgáltatás egy RPC hívást kezdeményez egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálóhoz, a rendszer a hívást névtelen bejelentkezésnek tekinti. Az Active Directory címtárszolgáltatáshoz történő névtelen hozzáférések engedélyezéséhez a tartománybiztonságot oly módon kell csökkenteni, hogy a hívást nem kell megszemélyesíteni. Következésképpen a Message Queuing kiszolgálók minden Active Directory objektum iránti lekérdezést elfogadnak. Ez azt jelenti, hogy a Message Queuing objektumok tulajdonságait meg lehet tekinteni, de az üzeneteket nem lehet elolvasni (eltávolítani) a nyilvános várólistákból.

A biztonságot később is gyengíthető az ADSI Edit program segítségével. Ha az eljárással kapcsolatban további információra van szüksége, tanulmányozza A biztonság gyengítése az ADSI Edit segítségével című részt.

A Windows NT 4.0 felhasználók támogatása a biztonság gyengítése nélkül is lehetséges. Ebben az esetben a Mindenki csoportnak Tartalom listázása engedélyt kell adni minden tartomány minden számítógép-objektumához. Ez azonban nem ajánlott, mivel nagyobb mértékben csökkenti a tartománybiztonságot.

A Message Queuing szolgáltatásfiókkal kapcsolatos megfontolások

Más programokkal ellentétben, amelyeket egy rendszerbiztonsági tag (felhasználó vagy számítógép) hajt végre, a szolgáltatások a saját biztonsági környezetükben futnak. A biztonsági környezet létrehozásához a szolgáltatásnak be kell jelentkeznie a számítógépre, csakúgy mint a rendszerbiztonsági tagoknak. A Message Queuing szolgáltatás a számítógép LocalSystem vagy más felhasználói fiókja alatt futhat. A LocalSystem fiók a Windows 2000 rendszer egy standard hitelesített tartományfiókja. A Message Queuing szolgáltatás alapértelmezés szerint a LocalSystem fiók alatt fut, és ez alatt kell futnia, hogy a Windows 2000 tartományvezérlőkre telepített Message Queuing kiszolgálók elérhessék az Active Directory címtárat. Más Message Queuing számítógépek esetén meg lehet változtatni, hogy mely felhasználói fiók alatt fusson a szolgáltatás. Ez akkor lehet hasznos, ha a szolgáltatásnak meghatározott jogokat szeretne adni.

Az alábbiakban az olvasható, milyen előnyöket biztosít az, ha a Message Queuing szolgáltatás a LocalSystem fiók alatt fut:

  • A LocalSystem fiók tagja a helyi Rendszergazdák csoportnak.
  • A LocalSystem fiók rendelkezik a megfelelő jogokkal, hogy szolgáltatásként futhasson.
  • A LocalSystem fiók rendelkezik Biztonsági napló létrehozása joggal.

Csak akkor módosítsa a fiókot, amely alatt a Message Queuing szolgáltatás fut, ha nem akar Olvasás jogot adni a hitelesített felhasználók számára. Ebben az esetben a Message Queuing szolgáltatás más felhasználói fiók alatt történő futtatásának követelményei:

  • A felhasználói fióknak Olvasás joggal kell rendelkeznie az Active Directory minden Message Queuing objektumához.
  • A felhasználói fiókot fel kell venni a helyi Rendszergazdák csoportba.
  • A felhasználói fióknak meg kell adni a következő jogokat: Bejelentkezés szolgáltatásként, Működés az operációs rendszer részeként, Folyamatszintű token lecserélése, Kvóta növelése, Biztonsági napló létrehozása.

Továbbá ha Windows 2000 független ügyfeleken a Message Queuing alkalmazások futtatásához helyi felhasználói fiókot használ, ezek az ügyfelek nem tudják hitelesíteni a Windows 2000 tartományvezérlőkön futó Message Queuing kiszolgálókat. Az ilyen tartományvezérlők hozzáférést biztosítanak az Active Directory címtárhoz. Ha szükség van ezeknek a Message Queuing kiszolgálóknak a hitelesítésére, akkor tartományfelhasználói fiókot kell használni.

Ha további információra van szüksége azzal kapcsolatban, hogyan lehet módosítani azt a fiókot, amely alatt a Message Queuing szolgáltatás fut, olvassa el a Message Queuing szolgáltatásfiók módosítása című részt.

Egyéb biztonsági szempontok

A Message Queuing garantálja a forrásszámítógépről a célszámítógépre küldött összes üzenet biztonságát. A teljes biztonság biztosítása érdekében a fogadó alkalmazásnak és a célvárólistának ugyanazon a számítógépen kell lennie. Ez azért van így, mert az üzenetek a célvárólistában egyszerű szövegként vannak tárolva. Azt a műveletet, amikor egy várólista tartalmát a várólistát tartalmazó számítógépről érik el, helyi olvasásnak nevezik. Azt a műveletet, amikor egy várólista tartalmát egy másik számítógépről érik el, távoli olvasásnak nevezik. Távoli olvasás esetén az üzenetek nincsenek titkosítva és hitelesítve. Azt azonban a Message Queuing garantálja, hogy az üzeneteket nem hamisították meg.

A Microsoft Active Server Pages parancsfájlok futhatnak egy helyi felhasználói fiók biztonsági beállításaival, az Internet Information Services (IIS) biztonsági beállításaitól függően. Az ilyen parancsfájlok segítségével küldött üzenetek csak akkor érkeznek meg sikeresen a célvárólistákba, ha a várólisták nem korlátozzák a bejövő üzenetek hozzáférését.


A Message Queuing hozzáférés-vezérlése

Az Active Directory Message Queuing objektumaihoz történő felhasználói hozzáférések korlátozására a hozzáférés-vezérlés szolgáltatással történik, amely biztonsági leírók objektumokhoz történő hozzárendelése segítségével valósítható meg. A biztonsági leíró tartalmazza azokat a felhasználókat és csoportokat, amelyek hozzáférhetnek vagy nem férhetnek hozzá az objektumhoz, emellett tartalmazza az ezekhez a felhasználókhoz és csoportokhoz hozzárendelt engedélyeket. A biztonsági leírónak ezt a részét tulajdonosi hozzáférés-szabályozási listának (DACL) nevezik. Az objektum engedélyeinek beállításával az objektum tulajdonosa határozza meg a megengedett hozzáféréseket. Message Queuing objektumok lehetnek a következők: számítógép (msmq), várólista, útválasztási kapcsolat és MSMQ-beállítások objektumok. Ha további információra van szüksége a Message Queuing objektumokkal, azok létrehozási helyével, valamint azok Active Directory címtáron belüli helyével kapcsolatban, tanulmányozza a Message Queuing objektumok az Active Directory címtárban című részt.

Engedélyekkel korlátozható, hogy egy számítógép adott várólistájából lehet-e olvasni, illetve lehet-e egy várólistába üzenetet küldeni. Bár az üzenetek nem az Active Directory objektumai, védelmüket a várólista objektum biztonsági leírója biztosítja.

Mivel a Message Queuing aszinkron üzenetküldést biztosít, a forrás- és a célszámítógépnek nem kell egyidejűleg on-line állapotban lenniük. Ebben az esetben a Message Queuing a kapcsolat nélküli felhasználók hozzáférés-vezérlését a küldő biztonsági azionosítója (SID) segítségével valósítja meg. Mivel egy várólista korlátozhatja a hozzá történő hozzáférést, a küldő alkalmazásnak a várólistának küldött üzenethez csatolnia kell a küldő biztonsági azonosítóját. A célszámítógép Message Queuing szolgáltatása ellenőrzi a biztonsági azonosítót, és ellenőrzi, hogy a feladó rendelkezik-e a megfelelő engedélyekkel a várólistához történő hozzáféréshez.

Megjegyzés

  • A Message Queuing telepítéséhez és eltávolításához is megfelelő engedélyekkel kell rendelkezni. További tájékoztatásért tanulmányozza a Telepítési engedélyek című részt.

Ha további információt szeretne kapni a Windows 2000 hozzáférés-vezérléséről, tanulmányozza a Hozzáférés-vezérlés témakört.

Felügyeleti csoportok használata

A hozzáférés-vezérlés adminisztrációja egyszerűsíthető egy vagy több felügyeleti felhasználói csoport használatával, majd a csoportokra vonatkozó megfelelő engedélyek beállításával. Ezek után az egyes felhasználók felvehetők a csoportokba, így azok megkapják a csoportok jogait. Például létrehozhat egy Helyi rendszergazdák csoportot a Windows 2000 erdő minden helyéhez. Ezután tartomány-rendszergazdai engedélyt adhat a Helyi rendszergazdák csoportnak a hely összes Message Queuing kiszolgálójához.

A Windows 2000 felügyeleti csoportjaival kapcsolatos további tájékoztatásért tanulmányozza a Beépített és előre beállított csoportok című részt.

Az msmq objektumok biztonsági leírója

Azt, hogy egy számítógépen mely felhasználók hozhatnak létre várólistákat, a számítógép msmq objektumának biztonsági leírója határozza meg, amelynek meghatározása a Message Queuing telepítése során történik meg.

Ha egy független ügyfelet vagy útválasztó nélküli Message Queuing kiszolgálót (nem tartományvezérlőt) telepít, és nem ad meg kiszolgálót vagy egy Message Queuing kiszolgáló (amely Windows 2000 alatt fut) nevét adja meg a telepítés során, az msmq objektum alapértelmezett biztonsági leírója a következő felhasználók számára engedélyezi várólista létrehozását a számítógépen:

  • A vállalati vagy tartomány-rendszergazdai engedéllyel rendelkezők létrehozhatnak várólistákat a számítógépen.
  • A vállalati vagy tartomány-rendszergazdai engedéllyel rendelkezők létrehozhatnak várólistákat a számítógépen.
  • A számítógépen futó alkalmazások létrehozhatnak várólistákat a számítógépen, feltéve hogy a számítógép Windows 2000 alapú Message Queuing kiszolgálóval kommunikál.
  • Minden felhasználó létrehozhat várólistákat másik számítógépen.

Ha egy független ügyfelet vagy útválasztó nélküli Message Queuing kiszolgálót (nem tartományvezérlőt) telepít, és megadja egy MSMQ 1.0 vezérlőkiszolgáló (amely Windows 4.0 alatt fut) nevét a telepítés során, az msmq objektum alapértelmezett biztonsági leírója minden felhasználó számára engedélyezi várólisták létrehozását a számítógépen:

Ha az MSMQ 1.0-t olyan számítógépre telepíti, amely egy Windows 2000 tartomány tagja, az msmq objektum alapértelmezett biztonsági leírója mindenki számára engedélyezi a várólisták létrehozását a számítógépen.

Az msmq objektumok engedélyeinek beállítása

Ha egy msmq objektum engedélyeit állítja be, akkor a szülő számítógép Message Queuing szolgáltatásra vonatkozó engedélyeit állítja be. Az Active Directory - felhasználók és számítógépek beépülő modulban az msmq objektum a számítógép objektum gyermekobjektuma. Az msmq objektumot MSMQ konfigurációs objektumnak is nevezik.

Módosíthatja az objektum Active Directory által meghatározott objektumengedélyeit, és további Message Queuing-specifikus engedélyeket is megadhat. Alapértelmezés szerint a Mindenki csoport jogosult egy msmq objektum tulajdonságainak és biztonsági leíróinak megtekintésére.

Az alábbi táblázatban az msmq objektumokhoz beállítható, Message Queuing-specifikus engedélyek összefoglalása látható. Ezek az engedélyek megadhatók felhasználónként, vagy a Vezérlés delegálása varázsló segítségével megadhatók a tartomány egy csoportjának, mint például a Hitelesített felhasználók csoportnak.

Message Queuing engedélyek | Egy felhasználó vagy csoport számára ezt engedélyezi:
Kézbesítetlen üzenet fogadása | Kézbesítetlen üzenetek elolvasása (eltávolítása) a számítógép kézbesítetlen üzenetek várólistájából.
Kézbesítetlen üzenet megtekintése | Kézbesítetlen üzenetek megtekintése a számítógép kézbesítetlen üzenetek várólistájában.
Számítógépnapló fogadása | Naplóüzenetek elolvasása (eltávolítása) a számítógép naplóvárólistájából.
Számítógépnapló megtekintése | A számítógép-naplóvárólistában lévő üzenetek megtekintése.

Ha egy felhasználó vagy csoport Kézbesítetlen üzenetek fogadása vagy Számítógépnapló fogadása engedéllyel rendelkezik, akkor automatikusan rendelkezik Üzenet megtekintése engedéllyel is. (A Kézbesítetlen üzenetek fogadása és a Számítógépnapló fogadása engedélyeknek az Üzenet megtekintése engedély nélkül nincs értelmük.)

Az msmq objektumok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza a Számítógép és várólista objektumok engedélyeinek beállítása című részt.

Az msmq objektumok tulajdonosának módosításával kapcsolatos további tudnivalókért tanulmányozza a Számítógép és várólista objektumok tulajdonosának módosítása című részt.

A várólista objektumok engedélyeinek beállítása

Az Active Directory - felhasználók és számítógépek beépülő modulban a várólista objektumok az msmq objektum gyermekobjektumai.

Módosíthatja az objektum Active Directory által meghatározott objektumengedélyeit, és további Message Queuing-specifikus engedélyeket is megadhat a várólistáknak.

Az alábbi táblázatban a várólista objektumokhoz beállítható Message Queuing-specifikus engedélyek összefoglalása látható. Ezek az engedélyek megadhatók felhasználónként, vagy a Vezérlés delegálása varázsló segítségével megadhatók a tartomány egy csoportjának, mint például a Hitelesített felhasználók csoportnak.

Message Queuing engedélyek | Egy felhasználó vagy csoport számára ezt engedélyezi:
Napló fogadása | Naplóüzenetek olvasása (eltávolítása) a várólistából.
Üzenet fogadása | Normál üzenetek olvasása (eltávolítása) a várólistából.
Üzenet megtekintése | A várólistában és a várólistanaplóban lévő üzenetek megtekintése.
Üzenet küldése | Üzenet küldése a várólistára.

Alapértelmezés szerint a Mindenki csoport általános Írás engedéllyel rendelkezik a várólistához, a várólistát létrehozó személy pedig általános Teljes hozzáférés joggal rendelkezik. Ha egy felhasználó Írás engedéllyel rendelkezik egy várólistához, üzeneteket küldhet a várólistába; ezek a felhasználók automatikusan rendelkeznek az Üzenet küldése engedéllyel is.

Ha egy felhasználó általános Olvasás engedéllyel rendelkezik egy várólistához, a várólistának csak a tulajdonságait és a biztonsági leíróját tekintheti meg.

Ha egy felhasználó vagy csoport Üzenet fogadása vagy Napló fogadása engedéllyel rendelkezik, akkor automatikusan rendelkezik Üzenet megtekintése engedéllyel is. (Az Üzenet fogadása és a Napló fogadása engedélyeknek az Üzenet megtekintése engedély nélkül nincs értelmük.)

A várólista objektumok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza a Számítógép és várólista objektumok engedélyeinek beállítása című részt.

A várólista objektumok tulajdonosának módosításával kapcsolatos további tudnivalókért tanulmányozza a Számítógép és várólista objektumok tulajdonosának módosítása című részt.

Megjegyzés

  • A tartományok között Meghatalmazotti kapcsolatok szükségesek a hozzáférést korlátozó várólistákba történő üzenetküldéshez. Ha egy felhasználó olyan várólistára küld üzenetet, amely korlátozza azok körét, akik üzenetet küldhetnek számára, a várólistát tartalmazó számítógépnek vagy ugyanabban a tartományban kell lennie, mint a feladónak, vagy egy olyan tartományban, amely megbízik a feladó tartományában. Ellenkező esetben a számítógép visszautasítja az üzenetet, és megtagadja a várólistához történő hozzáférést. A tartományokkal kapcsolatos általános tudnivalókért tanulmányozza a Tartományok című részt.

Útválasztási kapcsolat objektumok engedélyeinek beállítása

Ha egy útválasztási kapcsolat objektumhoz állít be engedélyeket, akkor a szülő MsmqServices objektumnak ad engedélyt a gyermekobjektumok létrehozásához és törléséhez. Az Active Directory - helyek és szolgáltatások beépülő modulban az útválasztási kapcsolat objektum az MsmqServices objektum gyermekobjektuma.

Az objektumnak csak az Active Directory által biztosított alapértelmezett engedélyeit lehet módosítani. Ehhez az objektumhoz nem tartoznak Message Queuing-specifikus engedélyek.

Alapértelmezés szerint csak a vállalati rendszergazdai engedéllyel rendelkező (vagy a Vállalati rendszergazdák csoportba tartozó) felhasználók hozhatnak létre vagy módosíthatnak útválasztási kapcsolatokat, ha a vállalaton belül több tartomány létezik. A Tartománygazdák csoport tagjainak az útválasztási kapcsolatok létrehozásához vagy módosításához Az összes gyermekobjektum létrehozása engedéllyel kell rendelkezniük az MsmqServices objektumhoz.

A útválasztási kapcsolatok objektumok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza az Útválasztási kapcsolatok objektumok engedélyeinek beállítása című részt.

Az MSMQ-beállítások objektumok engedélyeinek beállítása

Ha egy MSMQ-beállítások objektumhoz állít be engedélyeket, akkor a szülő kiszolgálóobjektumnak ad engedélyt a gyermekobjektumok létrehozásához és törléséhez. Az Active Directory - helyek és szolgáltatások beépülő modulban az MSMQ-beállítások objektum a kiszolgálóobjektum gyermekobjektuma.

Az objektumnak csak az Active Directory által biztosított alapértelmezett engedélyeit lehet módosítani. Ehhez az objektumhoz nem tartoznak Message Queuing-specifikus engedélyek.

Az MSMQ-beállítások objektumok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza az MSMQ-beállítások objektumok engedélyeinek beállítása című részt.

Az üzenetfájlok engedélyeinek beállítása

Alapértelmezés szerint csak a helyi Rendszergazdák csoport tagjai rendelkeznek teljes hozzáféréssel a helyileg tárolt üzenetfájlokhoz, naplófájlokhoz és LQS (helyi várólista-tároló) fájlokhoz. Más felhasználók nem rendelkeznek hozzáférési joggal.

Alapértelmezés szerint fájl szintű hozzáférés van beállítva a \Storage és az \LQS mappákhoz. Minden alkalommal, amikor egy új fájl kerül ezekbe a mappákba, a fájl örökli a mappa biztonsági beállításait. Azonban ha a Vezérlőpult Message Queuing segédprogramjának segítségével áthelyezi az üzenetfájlt egy másik mappába, az eredeti mappa biztonsági beállításai nem kerülnek át az új mappába. Az alapértelmezett mappákból az új mappákba átkerülő fájlok csak a saját biztonsági beállításaikat viszik magukkal (a \Storage vagy az \LQS mappák tulajdonságait nem).

A helyileg tárolt üzenet- és naplófájlok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza a Message Queuing fájlok engedélyeinek beállítása című részt.

Megjegyzés

  • NTFS meghajtókon mappa szintű és a fájl szintű hozzáférés egyaránt alkalmazható. FAT meghajtókon csak mappa szintű hozzáférés használható.


A Message Queuing hitelesítése

A Message Queuing hitelesítése nyilvános kulcsú bizonyítványok, a Kerberos V5 biztonsági protokoll, és a Windows NTLM segítségével történik (a Windows NT 4.0-n futó MSMQ 1.0-val történő kompatibilitás érdekében). Az üzenetek hitelesítése nyilvános kulcsú bizonyítványokkal vagy felhasználói bizonyítványokkal történik, amellyel az üzenet küldője (az ügyfél) ellenőrizhető a Message Queuing kiszolgáló számára. A Kerberos V5 és a Windows NTLM protokollokat a kiszolgáló hitelesítésére használják, amely ellenőrzi a Message Queuing kiszolgálót az ügyfél számára.

Az üzenethitelesítés használata nem kötelező. A Message Queuing alkalmazásoknak nem kötelező hitelesítést használni üzenetek küldésekor vagy fogadásakor. Azt is figyelembe kell venni, hogy az üzenethitelesítés használata lelassítja az üzenetek átvitelét. Ha azonban a használata engedélyezve van, a hitelesített üzeneteket küldő vagy fogadó Message Queuing alkalmazásoknak a Windows 2000 rendszerrel alapértelmezés szerint telepítésre kerülő titkosításszolgáltatót kell használniuk, amely az üzenetek hitelesítéséhez és titkosításához szükséges. Az üzenettitkosítással kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing titkosítása című részt.

A Windows 2000 hitelesítésével kapcsolatos további tájékoztatásért tanulmányozza a Hitelesítés című témakört.

A Windows 2000 bizonyítványaival kapcsolatos további tájékoztatásért tanulmányozza a Bizonyítványok - áttekintés című témakört.

Üzenethitelesítés

Az üzenethitelesítési eljárás során a rendszer azt ellenőrzi, hogy az üzenet feladója valóban az-e, akinek kiadja magát. Az üzenethitelesítés azt is garantálja, hogy az üzenetet nem hamisították meg.

Egy hitelesített üzenettel egy digitális aláírás és egy bizonyítvány kerül elküldésre. A digitális aláírás egyedileg azonosítja az üzenet feladóját. Mivel senki sem tud más nevében digitálisan aláírni egy üzenetet, senki nem tagadhatja le egy üzenet elküldését, ha az a megfelelő digitális aláírást tartalmazza. Másfelől a bizonyítványt a digitális aláírás ellenőrzésére használják. A digitális aláírások egy nyilvános kulcsú (aszimmetrikus) titkosítási eljárással hozhatók létre.

Mivel a Message Queuing aszinkron üzenetküldő rendszer, a forrás- és a célszámítógépnek nem kell egyidejűleg bekapcsolt és hálózatra kapcsolt állapotban lenniük. Következésképpen az üzenethitelesítés megvalósítása két lépésben történik:

Először a felhasználói bizonyítvány regisztrálása történik meg az Active Directory címtárban egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló használatával. A Message Queuing kiszolgáló megszemélyesíti a bizonyítvány feladóját, kiolvassa a feladó biztonsági azonosítóját, majd regisztrálja a megfelelő biztonsági azonosító és bizonyítvány párt az Active Directory címtárban. A felhasználói bizonyítvány automatikusan regisztrálásra kerül a számítógépre történő első bejelentkezés alkalmával.

A hitelesített üzenet elküldése során a forrásszámítógép Message Queuing alkalmazása létrehoz az üzenethez egy digitális aláírást, hozzáfűzi a felhasználói bizonyítványt és a biztonsági azonosítót az üzenethez, majd elküldi azt. A célszámítógép Message Queuing szolgáltatása érvényesíti a digitális aláírást, majd lekérdez egy Message Queuing kiszolgálót, hogy a biztonsági azonosító/bizonyítvány pár regisztrálva van-e. Ha a biztonsági azonosító/bizonyítvány pár regisztrálva van, az üzenetet hitelesítettnek tekinti.

A forrásszámítógépen a Message Queuing alkalmazás a következőket teszi:

  1. Létrehoz egy digitális aláírást egy ujjlenyomat-algoritmus használatával az adott üzenet ujjlenyomat-értékének kiszámításához.
  2. Titkosítja az ujjlenyomat értékét a forrásszámítógép személyes titkosítási kulcsának segítségével.
  3. Hozzáfűzi az üzenethez a digitális aláírást, a biztonsági azonosítót és a felhasználói bizonyítványt.

A célszámítógépen a Message Queuing szolgáltatás a következőket teszi:

  1. Dekódolja az üzenet ujjlenyomat-értékét a felhasználói bizonyítványban található nyilvános titkosítási kulcs segítségével.
  2. Újra kiszámítja az ujjlenyomat értékét, és összehasonlítja az üzenet ujjlenyomat-értékével.
  3. Ha az értékek megegyeznek, megkeresi a felhasználói bizonyítványt az Active Directory címtárban, és ellenőrzi, hogy a bizonyítványt regisztráló felhasználó megegyezik-e az üzenetben szereplő feladóval, és hogy nem hamisították-e meg az üzenetet a kézbesítés során.

A Message Queuing által használt titkosítási kulcsokkal kapcsolatos további tájékoztatásért tanulmányozza a Titkosítási kulcsok című fejezetet.

Hitelesített üzeneteket idegen számítógépeknek is lehet küldeni. A közbülső Message Queuing kiszolgáló (amelyen az összekötő alkalmazás fut) érvényesíteni tudja a hitelesített üzenetet.

Meg lehet határozni, hogy egy várólista elfogadjon-e hitelesített üzeneteket. További tájékoztatásért tanulmányozza a Csak hitelesített üzenetek engedélyezése a várólistákban című részt.

Felhasználói bizonyítványok

A felhasználói bizonyítványokat az üzenet feladója biztonsági azonosítójának hitelesítésére használják. A biztonsági azonosítót csak akkor lehet hitelesíteni, ha a felhasználói bizonyítvány már regisztrálva van az Active Directory címtárban. A Message Queuing szolgáltatás ellenőrzi, hogy az üzenethez csatolt biztonsági azonosító megegyezik-e az Active Directory címtárban található bizonyítvány hitelesítésére használt biztonsági azonosítóval. A számítógéphez a telepítés során automatikusan létrejön egy felhasználói bizonyítvány, és a számítógépre történő első bejelentkezéskor azt a rendszer regisztrálja lesz az Active Directory címtárban. Olyan tartományokba is lehet hitelesített üzeneteket küldeni, amelyek nem egyeznek meg azzal a tartománnyal, amelyben a biztonsági azonosító készült.

Kétfajta felhasználói bizonyítvány vagy nyilvános kulcsú bizonyítvány létezik, amelyet a Message Queuing szolgáltatás használni tud: belső bizonyítvány és külső bizonyítvány. A belső bizonyítványok a Message Queuing telepítése során automatikusan jönnek létre, és bárki használhatja azokat. A következő rész mindkét típusú felhasználói bizonyítványra vonatkozik.

Egy Message Queuing szolgáltatást futtató számítógép felhasználói bizonyítványai a Vezérlőpulton található Message Queuing segédprogrammal kezelhetők. Az Active Directory címtárban regisztrált felhasználói bizonyítványok megtekintésével kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing bizonyítványainak megtekintése című részt. Minden bizonyítványnak van egy érvényességi időtartama. Az érvényességi időtartam lejárta után a bizonyítvány nem tekinthető elfogadható vagy használható igazolásnak. A bizonyítványok megújításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing bizonyítványok megújítása című részt.

A felhasználói bizonyítványokat a rendszer egy Windows 2000 tartományvezérlőn futó Message Queuing kiszolgálón tárolja. Ha egy számítógépen újratelepíti a Windows 2000 operációs rendszert (a jelenlegi telepítés frissítése helyett), le kell törölnie a felhasználó előző (most már érvénytelen) bizonyítványát. A felhasználói bizonyítvány törlésével kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing bizonyítványok eltávolítása című részt. Ezután az új bizonyítványt kézzel kell regisztrálni. A felhasználói bizonyítványok regisztrálásával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing bizonyítványok regisztrálása című részt.

Megjegyzés

  • Ha a várólistákhoz történő hozzáférés engedélyekhez kötött, a felhasználói bizonyítványokat regisztrálni kell az Active Directory címtárban, hogy a Message Queuing le tudja képezni a bizonyítványt a felhasználó megfelelő biztonsági azonosítójára. Bár a korlátozott hozzáférésű várólistákba is lehet nem hitelesített üzeneteket küldeni, ez csökkentheti a biztonságot, mivel ezek az üzenetek elolvashatók vagy meghamisíthatók az átvitel alatt.

Külső bizonyítványok

A külső bizonyítványok a feladó személyének ellenőrzésére egy hitelesítő szervezet által kiadott információkat tartalmaznak, és nem a biztonsági azonosítót. A külső bizonyítványokban lévő adatokat a bizonyítványt kibocsátó hitelesítő szervezet garantálja. A célszámítógép Message Queuing szolgáltatása egy üzenet fogadásakor ellenőrzi ugyan a digitális aláírást, de nem ellenőrzi magát a külső bizonyítványt. A fogadó alkalmazás feladata a külső bizonyítványt ellenőrizni, mielőtt bármit tenne az üzenettel. A hitelesítő szervezetekkel kapcsolatos további tudnivalókért tanulmányozza a Hitelesítő szervezetek című témakört.

A külső bizonyítványok hitelesített üzenetek Windows 2000 rendszertől különböző környezetekbe történő küldéséhez szükségesek. Ha a külső bizonyítványokat hitelesített üzenetek Windows 2000 erdőn belüli számítógépekre történő küldésére használják, csak akkor kell a külső bizonyítványt regisztrálni az Active Directory címtárban, ha az üzenet hitelesítésére a feladó biztonsági azonosítóját is használják.

Ha regisztrál egy ilyen külső bizonyítványt az Active Directory címtárban, küldhet üzeneteket a hozzáférést korlátozó várólistákba. Ez azért van, mert a Message Queuing szolgáltatás ellenőrzi a feladó biztonsági azonosítóját. Egy külső bizonyítvány regisztrálása további (nem kötelező) hitelesítést biztosít, amelyet a fogadó alkalmazás felhasználhat.

A következő esetekben is ajánlott külső bizonyítványokat használni:

  • Ellenőrizni szeretné, hogy kik küldhetnek hitelesített üzeneteket a bizonyítványok ellenőrzésével (a belső bizonyítványok a Message Queuing szolgáltatás telepítése során automatikusan létrejönnek, és azokat bárki használhatja).
  • Olyan személynek szeretne hitelesített üzeneteket küldeni, aki nem fér hozzá az Active Directory címtárhoz.
  • Egy számítógépes munkacsoport tagja, és nem egy tartományé.

Egy hitelesítő szervezettől bizonyítvány igényelhető például az Internet Explorer 5-ös vagy újabb verziójának segítségével. Például a következő hitelesítő szervezetekkel veheti fel a kapcsolatot:

  • AT&T
  • InternetMCI Mail
  • Keywitness Canada
  • VeriSign Commercial Software Publishers

A beszerezhető külső bizonyítványoknak általában több szintje létezik. Egyes külső bizonyítványok nem bizonyítják a személyazonosságot. Csak azt bizonyítják, hogy mindig ugyanaz a személy küldi az üzeneteket. Ez elegendő az előfizetés alapú alkalmazások számára. A külső bizonyítványok más szintjei azt bizonyítják, hogy a bizonyítvány tulajdonosa az, akinek állítja magát.

Kiszolgálóhitelesítés

A kiszolgáló hitelesítését a ügyfelek használják a Message Queuing kiszolgálóknak küldött lekérdezések hitelesítésére. Az ügyfél ellenőrizheti, hogy a lekérdezés eredménye nem lett-e meghamisítva, és hogy az eredményt a megfelelő Message Queuing kiszolgáló küldte-e vissza. Vegyes módú tartománykörnyezetben az ügyfél által a kiszolgáló hitelesítésére használt módszer függ a kiszolgálón és az ügyfélen futó Message Queuing szolgáltatás verziójától (így az operációs rendszertől). A következő táblázatban az egyes esetekben használt módszerek láthatók.

ügyfél | kiszolgáló | kiszolgáló hitelesítésének módszere
Windows 2000 rendszeren futó Message Queuing ügyfél | Windows 2000 rendszeren futó Message Queuing kiszolgáló | Kerberos V5
Windows 2000 rendszeren futó Message Queuing ügyfél | Windows 4.0 rendszeren futó MSMQ 1.0 vezérlőkiszolgáló | Windows NTLM (kiszolgálói bizonyítvány használatával)
Windows NT 4.0, Windows 95 vagy Windows 98 rendszeren futó MSMQ 1.0 ügyfél | Windows 2000 rendszeren futó Message Queuing kiszolgáló | Windows NTLM (kiszolgálói bizonyítvány használatával)

A kiszolgálói bizonyítványokat egyes Message Queuing kiszolgálók hitelesítésére használják. Csak azokhoz a Message Queuing kiszolgálókhoz kell létrehozni és regisztrálni kiszolgálói bizonyítványt, amelyek Windows NT 4.0, Windows 95 vagy Windows 98 rendszeren futó MSMQ 1.0 ügyfelek Active Directory lekérdezéseire válaszolnak. A Message Queuing ügyfelek (Windows 2000 rendszerben) a kiszolgáló hitelesítésére a Kerberos V5 eljárást használják.

A kiszolgálói bizonyítványok létrehozásával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing kiszolgálói bizonyítványok létrehozása című fejezetet. A meglévő kiszolgálói bizonyítványok módosításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing kiszolgálói bizonyítványok módosítása című fejezetet.

Ha olyan Message Queuing ügyféllel rendelkezik (Windows 2000 alatt), amely egy MSMQ 1.0 vezérlőkiszolgálóval kommunikál (Windows NT 4.0 alatt), és szeretné hitelesíteni ezt a kiszolgáló, azt kézzel kell megtennie. Ha további tájékoztatásra van szüksége azzal kapcsolatban, hogyan lehet beállítani az ilyen ügyfeleket az MSMQ 1.0 vezérlőkiszolgálók kiszolgálói bizonyítvánnyal történő hitelesítésére, tanulmányozza Az MSMQ 1.0 vezérlőkiszolgálók hitelesítése című fejezetet.

A Message Queuing kiszolgálók hitelesítésére használt kiszolgálói bizonyítványokat minden üzenethitelesítéshez használt felhasználói (ügyfél) bizonyítványtól elkülönítve kell telepíteni. Azonban helyes beállítás esetén ugyanazt a bizonyítványt használhatja a Message Queuing szolgáltatás a kiszolgálók hitelesítésére és az Internet Information Services (IIS) a biztonságos internetes (HTTP-S) kommunikációhoz.

Ha MSMQ 1.0 vezérlőkiszolgálókat frissít, a Windows NT 4.0 rendszerből exportálja a meglévő kulcs- (kiszolgálói) bizonyítványt, és készítsen róla biztonsági másolatot, mielőtt az operációs rendszert Windows 2000 rendszerre frissítené. Ezt csak az olyan frissített kiszolgálók esetén kell megtenni, amelyek MSMQ 1.0 ügyfelek Active Directory kérelmeire válaszolnak. A Windows 2000 rendszeren futó Message Queuing ügyfelek a Kerberos V5 eljárást használják a kiszolgáló hitelesítésére. A meglévő kulcsbizonyítvány exportálásával kapcsolatos további tájékoztatásért tanulmányozza a Kulcsbizonyítványok exportálása Windows NT 4.0 rendszerből című fejezetet. Az előzőleg exportált kiszolgálói bizonyítványok importálásával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing kiszolgálói bizonyítványok importálása című fejezetet.


A Message Queuing titkosítása

A Message Queuing szolgáltatással kapcsolatban a titkosítás az üzenetek kódolását és dekódolását jelenti, amivel biztosítható, hogy azokat illetéktelen személyek ne tudják elolvasni vagy felhasználni. A Message Queuing szolgáltatás az üzenetek titkosítását szimmetrikus és aszimmetrikus (nyilvános/személyes) kulcsú titkosító algoritmusok segítségével valósítja meg. A megvalósított titkosítás a titkosítási alkalmazásprogramozási felületen (CryptoAPI) alapul, amely viszont a számítógépre telepített titkosításszolgáltatót (CSP) használja.

Az üzenetek titkosítása nem kötelező. A Message Queuing alkalmazásoknak nem kötelező titkosítást használni üzenetek küldésekor vagy fogadásakor. Azt is figyelembe kell venni, hogy az üzenettitkosítás használata lelassítja az üzenetek átvitelét. Ha azonban a használata engedélyezve van, a titkosított üzeneteket küldő vagy fogadó Message Queuing alkalmazásoknak a Windows 2000 rendszerrel alapértelmezés szerint telepítésre kerülő titkosításszolgáltatót kell használniuk, amely az üzenetek hitelesítéséhez és titkosításához szükséges. Az üzenethitelesítéssel kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing hitelesítése című fejezetet.

Bár más titkosításszolgáltatók is használhatók az olyan adatok titkosítására, amelyek nem érintik a Message Queuing szolgáltatást, a titkosított üzeneteket küldő vagy fogadó bármely Message Queuing alkalmazáshoz a Windows 2000 által biztosított titkosításszolgáltatót kell használni. A nem Message Queuing alapú alkalmazások továbbra is használhatnak más titkosításszolgáltatót a titkosításhoz.

Megjegyzés

  • A Windows 2000 egyesült államokbeli verziója a 40 bites titkosítás mellett támogatja a 128 bites titkosítást is; a Windows 2000 más verziói azonban nem támogatják a 128 bites titkosítást. Az egyesült államokbeli verzióban a 128 bites titkosításszolgáltató neve Microsoft bővített titkosításszolgáltató (Microsoft Enhanced Cryptographic Service Provider).

Az üzenettitkosítás működése

Az üzeneteket a forrásszámítógép Message Queuing szolgáltatása titkosítja, és a célszámítógép Message Queuing szolgáltatása dekódolja. A dekódolt üzeneteket a rendszer a célvárólistában egyszerű szövegként tárolja. Mivel a célszámítógép és a várólista eléréséhez megfelelő engedéllyel kell rendelkezni, a célszámítógépen lévő egyszerű szöveges üzenetek nem csökkentik a biztonságot. Az üzenettitkosítást az üzenetek átvitel közbeni jogosulatlan megtekintésének megakadályozására tervezték.

Az üzenettitkosítás használata esetén csökken a teljesítmény, bár nem olyan mértékben, mint az üzenethitelesítés használata esetén. A titkosítás okozta teljesítménycsökkenés akkor jelentős, ha több különböző számítógépnek küld titkosított üzeneteket. Ha azonban egy számítógépnek küld több üzenetet, csak az első üzenet elküldése telik több időbe, mint általában.

A teljesítménycsökkenés megértéséhez fontos ismerni a Message Queuing szolgáltatás által használt titkosítási mechanizmust.

A forrásszámítógépen a Message Queuing szolgáltatás a következőket teszi:

  1. Létrehoz egy titkos kulcsot.
  2. Titkosítja az üzenet szövegét a titkos kulccsal.
  3. Titkosítja a titkos kulcsot a célszámítógép nyilvános kulcsával.
  4. Csatolja a titkosított titkos kulcsot a titkosított üzenethez.

A célszámítógépen a Message Queuing szolgáltatás a következőket teszi:

  1. Dekódolja a titkos kulcsot a saját személyes kulcsa segítségével.
  2. Dekódolja az üzenet szövegét a titkos kulcs segítségével.

A titkos kulcsok titkosításhoz és dekódoláshoz is használhatók, ezért nevezik őket szimmetrikus kulcsnak. A nyilvános kulcs csak titkosításhoz használható, míg a személyes kulcs csak dekódoláshoz.

Az aszimmetrikus kulcsú titkosítás nagyobb többletráfordítást igényel, mint a szimmetrikus kulcsú titkosítás. Az első üzenet elküldéséhez szükséges a legnagyobb többletráfordítás, mert a titkos kulcsot a célszámítógép nyilvános kulcsával kell titkosítani. Alapértelmezés szerint a Message Queuing szolgáltatás a titkosított titkos kulcsot 10 percig tárolja a forrásszámítógépen. Ha további üzeneteket küld ugyanannak a számítógépnek az első üzenet elküldésétől számított 10 percen belül, a Message Queuing szolgáltatás ugyanazt a titkos kulcsot használja. Ezért a további üzenetek elküldéséhez szükséges többletráfordítás csak akkora lesz, amekkora az üzenetek szövegének a titkos kulccsal történő titkosításához szükséges. Ebben az esetben ugyanis a Message Queuing szolgáltatásnak nem kell újra titkosítania a titkos kulcsot a célszámítógép nyilvános kulcsával. Ugyanezek vonatkoznak a célszámítógép teljesítményére is. Az első üzenet fogadásakor a Message Queuing szolgáltatás dekódolja a titkos kulcsot a személyes kulcsa segítségével. Ezután eltárolja a dekódolt titkos kulcsot, melyet a későbbi üzenetekhez többletráfordítás nélkül fel tud használni.

A várólista titkosítási szintjének megadásával beállíthatja, hogy a várólista elfogadhat-e titkosított üzeneteket, nem titkosított üzeneteket, illetve mindkettőt. Ha a várólista titkosítási szintjét Nincs értékre állítja, a várólista csak a nem titkosított üzeneteket fogadja el. Ha a várólista titkosítási szintjét Törzs értékre állítja, a várólista csak a titkosított üzeneteket fogadja el. Ha a várólista titkosítási szintjét Választható értékre állítja, a várólista a titkosított és a nem titkosított üzeneteket is elfogadja. Az, hogy egy üzenetet a várólistába titkosítva vagy nem titkosítva küldtek-e, az Active Directory - felhasználók és számítógépek beépülő modul segítségével ellenőrizhető (vagy programból a PROPID_M_PRIV_LEVEL üzenettulajdonság ellenőrzésével).

A várólisták titkosítási szintjének beállításával kapcsolatos további tájékoztatásért tanulmányozza a Várólisták titkosítási szintjének módosítása című fejezetet.

Megjegyzés

  • Az idegen számítógépeknek küldött titkosított üzenetek titkosítva maradnak az összekötő alkalmazást futtató közbülső Message Queuing kiszolgálón. Az összekötő alkalmazás továbbíthatja a titkosított üzenetet az idegen számítógépnek, vagy továbbítás előtt dekódolhatja azt.

Titkosítási kulcsok

Egy számítógép személyes/nyilvános titkosítási kulcspárja a Message Queuing szolgáltatás telepítése során jön létre, és a Vezérlőpult Message Queuing segédprogramjával újítható meg. A függő ügyfelek kivételével minden Message Queuing számítógép használ titkosítási kulcsokat.

A Windows 2000 titkosítási kulcsaival kapcsolatos további tájékoztatásért tanulmányozza a Titkosítási kulcsok és bizonyítványkérelmek létrehozása című fejezetet.

A titkosítási kulcsok megújítása a Message Queuing egyik biztonsági szolgáltatása. Ajánlott a titkosítási kulcsokat bizonyos időszakonként, például évente egyszer megújítani. Abban az esetben is ajánlott megújítani a titkosítási kulcsokat, ha a kulcsok illetéktelen kézbe kerülésének gyanúja áll fenn. Ezzel csökkenthető annak az esélye, hogy egy személyes kulcs illetéktelen kezekbe kerüljön.

Ha egy Message Queuing szolgáltatást futtató számítógép titkosítási kulcsait megújítja, az előző kulccsal titkosított üzeneteket nem lehet dekódolni. Ez csak addig fordulhat elő, amíg a nyilvános kulcs másolatai be nem kerülnek minden Message Queuing kiszolgáló Active Directory címtárába, és a forrásszámítógépek el nem kezdik használni az új kulcsot.

A titkosítási kulcsok megújításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing titkosítási kulcsok megújítása című részt.


A Message Queuing naplózása

A naplózás annak rögzítésére használható, hogy mely felhasználók kíséreltek meg hozzáférést a Message Queuing objektumokhoz, milyen típusú volt a megkísérelt művelet, és hogy a hozzáférés sikeres volt-e. Az objektum biztonsági leírója határozza meg, hogy az objektum mely hozzáférési eseményeit kell naplózni. A biztonsági leírónak ezt a részét rendszerhozzáférés-szabályozási listának (SACL) nevezik. A SACL a következőket határozza meg:

  • Mely felhasználók és csoportok hozzáférését kell naplózni.
  • Az egyes felhasználók és csoportok mely hozzáférési eseményeit kell naplózni.
  • Minden esemény Sikeres vagy Sikertelen attribútumát, az objektum személyi hozzáférés-vezérlési listájának a felhasználókhoz és a csoportokhoz rendelt engedélyei alapján.

A Windows 2000 naplózásával kapcsolatos további tájékoztatásért tanulmányozza a Biztonsági események naplózása című témakört.

A Windows 2000 Biztonsági napló rögzíti a naplózott műveleteket (ezeket naplóüzeneteknek is nevezik), amelyek az Eseménynapló segítségével tekinthetők meg. Az Eseménynaplóval kapcsolatos további tájékoztatásért tanulmányozza az Eseménynapló című részt.

A naplózás beállítása

A naplózás megkezdése előtt ki kell alakítani a naplózási házirendet. A naplózási házirend határozza meg azokat a biztonsággal kapcsolatos eseményeket, amelyeket naplózni kell. Amikor egy Message Queuing kiszolgálóhoz naplózási házirendet határoz meg, a naplózási műveletet végrehajtó Message Queuing kiszolgálónak Naplózás és biztonsági naplók kezelése engedélyt kell adni. A naplózási házirend kialakításával kapcsolatos további tájékoztatásért tanulmányozza a Naplózási házirend kialakítása című részt.

Ezután válassza ki az objektum-hozzáférési kategóriákat, és adja meg az egyes objektumok naplózási beállításait. Miután kiválasztotta az objektum-hozzáférési kategóriát, az egyes Message Queuing objektumok Tulajdonságok lapján állíthatja be, hogy az egyes felhasználóknak vagy csoportoknak megadott engedélyek sikerességét vagy sikertelenségét kell-e naplózni. Ha további információra van szüksége azzal kapcsolatban, hogyan lehet egy számítógép (msmq) vagy várólista objektum naplózási beállításait megadni, tanulmányozza a Számítógép és várólista objektumokhoz történő hozzáférés naplózása című részt. Az útválasztási kapcsolatok objektum naplózási beállításainak megadásával kapcsolatos további tudnivalókért tanulmányozza az Útválasztási kapcsolatok objektumokhoz történő hozzáférés naplózása című részt.

Ha egy Message Queuing objektumhoz megadott naplózási beállításokat, de a műveletet végrehajtó Message Queuing kiszolgálón nincs meghatározva naplózási házirend, nem jön létre naplóüzenet.

Megjegyzés

  • Megjelenhet egy hibaüzenet, hogy a naplózás nincs engedélyezve. Ez azt jelenti, hogy a jelenleg használt számítógépen nincs engedélyezve a naplózás vagy nincs meghatározva naplózási házirend, és nem azt, hogy a naplózni kívánt számítógépen nincs engedélyezve a naplózás.

Naplóüzenetek

A naplóüzenetek a Windows 2000 biztonsági naplóban jönnek létre a műveletet végrehajtó számítógépen, amely nem feltétlenül az objektum tulajdonosa. Emiatt egy Message Queuing objektum naplóüzenetei a hálózaton szétszórtan is elhelyezkedhetnek. Például ha az ábrán a San Francisco-i 1. ügyfélen található tesztvárólistát a Seattle-i 2. ügyfél törli, a naplóüzenet a Seattle-i 2. kiszolgálón jön létre.

A naplóüzenetek létrehozását bemutató ábra

Amikor valaki hozzáfér egy várólistához, a műveletre vonatkozó naplóüzenet mindig a várólistát tartalmazó számítógépen jön létre. Mivel az Üzenet fogadása és az Üzenet megtekintése műveletek kivételével minden műveletet egy Message Queuing kiszolgáló hajt végre, a naplóüzenetek a műveletet végrehajtó Message Queuing kiszolgálón jönnek létre. Naplóüzenetek csak várólistához történő hozzáférés során jönnek létre, de nem minden alkalommal, amikor üzenetküldés vagy -fogadás történik.

Minden naplóüzenethez tartozik egy Megnyitás és egy Bezárás bejegyzés a Windows 2000 biztonsági naplóban. Ha egy várólistához Üzenet fogadása vagy Üzenet megtekintése művelet céljából történik hozzáférés, a naplóba közvetlenül a Megnyitás bejegyzés után a Bezárás bejegyzés kerül.


A Message Queuing felügyelete

Ez a rész ismerteti a számítógépek, várakozási sorok és egyéb, a Message Queuing által használt objektumok felügyeletét. Ezeket a témaköröket azután olvassa el, miután telepítette a Message Queuing szolgáltatást, és a vállalaton belül beállította a Message Queuing biztonsági paramétereit.

  • A Message Queuing felügyelete - áttekintés
  • Message Queuing hálózatok felügyelete
  • A Message Queuing számítógépek felügyelete
  • Message Queuing várólisták felügyelete
  • Message Queuing üzenetek felügyelete
  • Az MSMQ-Exchange összekötő felügyelete
  • A Message Queuing figyelése

Ez a rész nem tartalmaz információkat a biztonsági paraméterek beállításáról. A Message Queuing adatainak vállalaton belüli védelméről a következő témakörben talál információkat: Message Queuing biztonságossá tétele.


A Message Queuing felügyelete - áttekintés

A Message Queuing hálózat és számítógépek elsősorban a Microsoft Management Console (MMC) konzolon megjelenő beépülő modulok segítségével felügyelhetők. Egyes felügyeleti feladatokhoz a Vezérlőpult Message Queuing segédprogramja használható. Az alábbi táblázatban a Message Queuing kezeléséhez használható felügyeleti eszközök láthatók.

Felügyeleti eszköz neve | Az eszköz típusa | Ilyen típusú feladatokra használható
Számítógép-kezelés | MMC beépülő modul | a legtöbb munkacsoport alapú feladat; várólisták és üzenetek kezelése
Active Directory - felhasználók és számítógépek | MMC beépülő modul | a legtöbb tartomány alapú feladat; számítógépek, várólisták és üzenetek kezelése
Active Directory - helyek és szolgáltatások | MMC beépülő modul | egyes tartomány alapú feladatok; útválasztási kapcsolatok és idegen helyek kezelése
Message Queuing | Vezérlőpulton található segédprogram | egyes helyi feladatok; felhasználói bizonyítványok és titkosítási kulcsok kezelése

Az MMC és a beépülő modulok használatával kapcsolatos általános tájékoztatásért tanulmányozza a Microsoft Management Console című részt.

Az MSMQ 1.0 kezeléséhez használt eszköz az MSMQ Explorer volt. Vegyes módú tartománykörnyezet esetén, ahol egy Windows 2000 rendszeren futó Message Queuing számítógép egy Windows NT 4.0 rendszeren futó MSMQ 1.0 vezérlőkiszolgálóval kommunikál, az MSMQ 1.0 vezérlőkiszolgálón található információk eléréséhez az MSMQ Explorer programot kell használni (a Windows 2000 rendszert futtató számítógépen). További tájékoztatásért tanulmányozza A felügyeleti eszközökkel kapcsolatos megfontolások című fejezetet.

Megjegyzés

  • Ebben a fejezetben nem esik szó a Message Queuing biztonságának felügyeletéről. A Message Queuing biztonságával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing biztonság - áttekintés című részt.

Beépülő modulok használata a Message Queuing felügyeletéhez

A Message Queuing felügyeletéhez három beépülő modul használható. A Számítógép-kezelés beépülő modul hozzáférést biztosít a helyi várólisták és üzenetek információihoz. Az Active Directory - felhasználók és számítógépek és az Active Directory - helyek és szolgáltatások beépülő modul hozzáférést biztosít az Active Directory címtárban található, útválasztási beállításokkal, számítógépekkel, várólistákkal és más Message Queuing objektumokkal kapcsolatos információkhoz. A Message Queuing szolgáltatással kapcsolatos objektumokról bővebben a Message Queuing objektumok az Active Directory címtárban című fejezetben olvashat.

A legtöbb Message Queuing objektum a beépülő modulokat megjelenítő MMC konzol konzolfáján (általában a bal oldali ablaktáblán) jelenik meg. Ha egy adott Message Queuing objektum tulajdonságait szeretné megtekinteni, akkor általában a jobb oldali egérgombbal kell kattintani az objektumra a konzolfán, majd ki kell választani a Tulajdonságok parancsot. A beépülő modulokat megjelenítő MMC konzol részletek ablaktábláján (általában a jobb oldali ablaktáblán) láthatók a Message Queuing objektumok nevei, típusai és tulajdonságai (oszlopokba rendezve).

Az Active Directory replikáció késleltetheti a frissített információk megjelenését, így egy beépülő modul segítségével elvégzett módosítások addig nem jelennek meg, amíg a replikáció le nem fut. Ha például egy C helyen lévő számítógéphez hozzáad egy várólistát egy B helyen lévő számítógépről, a megfelelő beépülő modulban nem jelenik meg a módosítás, amíg az nincs replikálva a C helyről a B helyre. A beépülő modulban megjelenő információt frissítheti, ha a módosítás után megnyomja az F5 billentyűt.

Fontos

  • Az Active Directory - felhasználók és számítógépek és az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional rendszernek. Ezek a beépülő modulok a tartomány alapú Message Queuing hálózatok felügyeletéhez és az Active Directory információinak eléréséhez szükségesek. Ezek a beépülő modulok más, a kiszolgálók felügyeletére használt beépülő modulokkal együtt a Windows 2000 felügyeleti eszközök kiegészítéssel együtt telepíthetők, amely a Windows 2000 Server CD-lemezen található. Ily módon lehetővé válik a tartomány alapú felügyeleti feladatok végrehajtása és az Active Directory címtár elérése Windows 2000 Professional rendszert futtató Message Queuing számítógépekről. További tájékoztatásért tanulmányozza a Kiszolgálók kezelése távolról című fejezetet.

A Számítógép-kezelés beépülő modul

A Számítógép-kezelés beépülő modul számos mindennapi felügyeleti feladat elvégzésére használható, beleértve a számítógépek várólistáinak és üzeneteinek kezelését. Munkacsoport környezetben (amely nem része egy Windows 2000 tartománynak) ez a Message Queuing kezelésére használható egyetlen beépülő modul.

A Számítógép-kezelés beépülő modul segítségével a következő feladatok hajthatók végre:

  • Privát várólisták létrehozása és megtekintése, valamint a várólisták tulajdonságainak beállítása.
  • Gyorsítótárban tárolt nyilvános várólisták megtekintése (ha a helyi számítógép valamikor egy tartományhoz tartozott, és hozzáfért az Active Directory címtárhoz).
  • Kimenő várólisták működésének szüneteltetése és folytatása.
  • Egy számítógép minden kimenő várólistájának szüneteltetése és folytatása.
  • Az üzenetek tulajdonságainak megtekintése és a kimenő üzenetek törlése.
  • Más számítógépeken lévő várólisták és üzenetek kezelése.

A kimenő várólisták csak a Számítógép-kezelés beépülő modul segítségével láthatók, más beépülő modulokban nem jelennek meg.

A Számítógép-kezelés beépülő modul lehetővé teszi a más számítógépeken található várólisták és üzenetek kezelését (feltéve, ha rendelkezik rendszergazdai engedéllyel a többi számítógépen). A más számítógépeken lévő várólisták és üzenetek kezelésével kapcsolatos további tájékoztatásért tanulmányozza a Más számítógépeken lévő várólisták és üzenetek kezelése című fejezetet.

A munkacsoportban (vagy tartományban) lévő összes számítógép várólistáit és üzeneteit oly módon is kezelheti, ha létrehoz egy MMC konzol (.msc) fájlt, amely megjeleníti az összes ilyen számítógépet. A konzolfájlok létrehozásával kapcsolatos további tájékoztatásért tanulmányozza a Konzolok létrehozása című részt.

Megjegyzés

  • Egy fürtözött virtuális kiszolgáló esetén a Message Queuing szolgáltatás csak a Számítógép-kezelés beépülő modul segítségével kezelhető. Ebben az esetben egy fürtcsoport objektum jelenik meg, amelynek neve a fürtözött virtuális kiszolgáló Hálózati név erőforrásának nevével egyezik meg. A Message Queuing objektumok ezen objektum alatt jelennek meg.

Active Directory - felhasználók és számítógépek beépülő modul

Az Active Directory - felhasználók és számítógépek beépülő modul segítségével a Message Queuing és az Active Directory alábbi tartomány alapú felügyeleti feladatai hajthatók végre:

  • Az összes Message Queuing számítógép megtekintése és a számítógépekre jellemző tulajdonságok beállítása.
  • Az összes nyilvános várólista létrehozása, megtekintése, törlése és keresése, valamint a várólisták tulajdonságainak beállítása.
  • Helyi privát várólisták létrehozása, megtekintése és törlése, valamint a várólisták tulajdonságainak beállítása.
  • Az üzenetek tulajdonságainak megtekintése és az üzenetek törlése.
  • MQPing üzenetek és tesztüzenetek küldése, valamint az üzenetútvonal nyomkövetésének megadása.

Az Active Directory - felhasználók és számítógépek beépülő modul megnyitásához (1. lépés) használt parancsikon az MMC konzolt szerzői módban nyitja meg. A szerzői mód lehetővé teszi a beépülő modulok módosítását. Az eljárásban a következő lépés az alábbi:

“Kattintson a Nézet menü Felhasználók, csoportok és számítógépek mint tárolók parancsára, majd kattintson a Speciális beállítások elemre.”

Mentheti ezeket a beállításokat úgy, hogy ez a nézet alapértelmezés szerint engedélyezve legyen, ha a beépülő modulhoz létrehoz egy egyéni MMC konzolfájlt (.msc). Ehhez a beépülő modulban kattintson a Konzol menü Mentés másként parancsára, majd adjon meg egy mappát és egy fájlnevet a beépülő modul konzolfájljának. Az Active Directory - felhasználók és számítógépek beépülő modul ezzel a fájllal történő következő megnyitásakor kattintson a Konzol menü Beállítások parancsára, majd törölje A konzolfájlok megnyitása mindig szerzői módban jelölőnégyzet jelölését. Így a beépülő modul felhasználói módban nyílik meg, a megfelelő nézettel. A beépülő modulok felhasználói módban történő megnyitása felügyeleti szempontból biztonságosabb, mivel senki nem tudja módosítani a beépülő modul viselkedését vagy megjelenését.

Active Directory - helyek és szolgáltatások beépülő modul

Az Active Directory - helyek és szolgáltatások beépülő modul segítségével a Message Queuing és az Active Directory alábbi tartomány alapú felügyeleti feladatai hajthatók végre:

  • Útválasztási kapcsolatok létrehozása, törlése és megtekintése, valamint az útválasztási kapcsolatok (a helykapukat is beleértve) tulajdonságainak beállítása.
  • Idegen helyek és idegen számítógépek tulajdonságainak létrehozása, megtekintése és beállítása.
  • Az üzenetek hálózati élettartamának beállítása (várólista-elérési időkorlát).

Az Active Directory - helyek és szolgáltatások beépülő modul megnyitásához (1. lépés) használt parancsikon az MMC konzolt szerzői módban nyitja meg. Az eljárásban a következő lépés az alábbi:

“Kattintson a Nézet menü Szolgáltatások megjelenítése parancsára.”

Most is menthetők a beállítások úgy, hogy ez a nézet alapértelmezés szerint engedélyezve legyen, ha a beépülő modulhoz létrehoz egy .msc fájlt az előzőekben leírtak szerint.

A Vezérlőpult Message Queuing segédprogramja

A Vezérlőpult Message Queuing segédprogramjának segítségével a Message Queuing szolgáltatás következő helyi felügyeleti feladatai végezhetők el:

  • Az üzenetfájlok és naplófájlok tárolására használt helyi lemezmeghajtók és mappák megadása.
  • Felhasználói bizonyítványok regisztrálása, eltávolítása, megújítása és megtekintése.
  • A kiszolgáló bizonyítványának módosítása és megtekintése.
  • Titkosítási kulcsok megújítása.
  • Annak meghatározása, hogy kell-e használni kiszolgálóhitelesítést MSMQ 1.0 vezérlőkiszolgálókkal történő kommunikáció esetén.
  • Új Windows 2000 hely megadása, ahová az üzeneteket továbbítani kell (mobil ügyfél esetén).


Message Queuing hálózatok felügyelete

Ebben a fejezetben azon Message Queuing tulajdonságok beállításáról olvashat, amelyek a teljes hálózat szintjén érvényesek egy tartománykörnyezetben, mint például a Message Queuing útválasztási kapcsolatok és az idegen helyek konfigurálása. Az Active Directory - helyek és szolgáltatások beépülő modul segítségével hajthatók végre a teljes hálózatra kiterjedő felügyeleti feladatok.

Azt is ismertetjük, hogyan kell a tűzfalat beállítani ahhoz, hogy az lehetővé tegye a belső és a külső hálózatokon lévő Message Queuing számítógépek kommunikációját.

Útválasztási kapcsolatok konfigurálása

A Message Queuing útválasztási kapcsolatokat használ az üzenetek helyek közötti továbbításához. Amikor létrehoz egy új Windows 2000 helyet, egy megfelelő útválasztási kapcsolatot is létre kell hoznia ahhoz, hogy lehessen üzeneteket küldeni más helyekre. Új hely létrehozásakor nem jelenik meg figyelmeztetés, hogy hozzon létre útválasztási kapcsolatot. A terheléselosztás és a redundancia érdekében ajánlott több útválasztási kapcsolatot létrehozni.

Az útválasztási kapcsolatok létrehozásával kapcsolatos további tájékoztatásért tanulmányozza az Útválasztási kapcsolatok létrehozása című részt.

Megjegyzés

  • Alapértelmezés szerint csak a vállalati rendszergazdai engedéllyel rendelkező (vagy a Vállalati rendszergazdák csoportba tartozó) felhasználók hozhatnak létre vagy módosíthatnak útválasztási kapcsolatokat, ha a vállalaton belül több tartomány létezik. A Tartománygazdák csoport tagjainak az útválasztási kapcsolatok létrehozásához vagy módosításához Az összes gyermekobjektum létrehozása engedéllyel kell rendelkezniük az MsmqServices objektumhoz. Az útválasztási kapcsolatok engedélyeinek beállításával kapcsolatos további tudnivalókért tanulmányozza az Útválasztási kapcsolat objektumok engedélyeinek beállítása című részt.

Minden útválasztási kapcsolathoz alapértelmezés szerint 1 költség van hozzárendelve. Csak akkor módosítsa az útválasztási kapcsolatok költségét, ha több útválasztási kapcsolatot használ, és az egyik útvonalat előnyben szeretné részesíteni. Ebben az esetben megadhat olyan költségeket, amelyek tükrözik a két kapcsolat közötti sávszélességbeli vagy kommunikációs költségbeli különbségeket. A költség értéke 1 és 4 294 967 295 között lehet. Két hely közötti nulla költség azt jelenti, hogy a helyek nincsenek összekapcsolva.

Tegyük fel, hogy az A és B hely ugyanabban a városban van és nagy sebességű kapcsolat van közöttük, valamint a tengerentúli C hely és a B hely között egy kissebességű kapcsolat van. Ebben az esetben az A és B közötti költséget beállíthatja 1-re, a B és C közöttit pedig 2-re.

Az útválasztási kapcsolatok Message Queuing kiszolgálókat, ún. helykapukat használnak a helyek közötti üzenettovábbításra. Ha egy útválasztási kapcsolat két helykapuval van meghatározva, az útválasztási kapcsolaton keresztül csak a megadott két kiszolgáló továbbíthat üzeneteket az ügyfelek nevében. A vállalatnál lévő összes helyet össze kell kötni útválasztási kapcsolatokkal.

Egy útválasztási kapcsolathoz két helykaput kell hozzárendelni, minden helyen egyet.

Az útválasztási kapcsolatokhoz használt Message Queuing kiszolgálók módosításával kapcsolatos további tájékoztatásért tanulmányozza az Útválasztási kapcsolat helykapuinak módosítása című részt.

Idegen helyek és idegyen számítógépek konfigurálása

Az idegen számítógépekkel történő kommunikációhoz először hozzon létre egy idegen helyet, adja hozzá az idegen számítógépeket az idegen helyhez, majd adjon hozzá egy Message Queuing kiszolgálót (amelyen egy összekötő alkalmazás fut) az idegen helyhez. Az idegen számítógépeket akkor lehet ugyanahhoz az idegen helyhez hozzárendelni, ha mindegyiket ugyanaz az összekötő alkalmazás szolgálja ki. Az összekötő alkalmazások Message Queuing kiszolgálókon futnak, és lehetővé teszik az idegen számítógépek számára a hálózat többi Message Queuing számítógépével történő kommunikációt. Amikor egy Message Queuing számítógép egy idegen számítógépnek küld üzenetet, az üzenet először az idegen helyen lévő Message Queuing kiszolgáló (amelyen az összekötő alkalmazás fut) összekötő várólistájába kerül.

Message Queuing összekötő alkalmazás például az MSMQ-MQSeries Bridge és a Message Queuing Connector (MQC).

Az idegen helyek létrehozásával kapcsolatos további tájékoztatásért tanulmányozza az Idegen helyek létrehozása című részt.

Ha azzal kapcsolatban van szüksége további információra, hogy hogyan lehet egy idegen számítógépet egy idegen helyhez hozzáadni, tanulmányozza az Idegen számítógépek hozzáadása egy helyhez című részt.

Az idegen hely és minden olyan Windows 2000 hely között létre kell hoznia útválasztási kapcsolatot, amely az idegen hellyel fog kommunikálni. Az idegen helyen az összekötő alkalmazást futtató Message Queuing kiszolgáló lehet egyben a hely helykapuja is az útválasztási kapcsolathoz. Ha azonban az idegen hely helykapuja elérhetetlenné válik, az idegen hellyel kommunikáló, más helyeken lévő helykapuk nem lesznek képesek üzeneteket továbbítani az idegen helyen lévő számítógépeknek. A helykapuk mindig hozzá vannak rendelve egy adott útválasztási kapcsolathoz. Ezért ha lehetséges, érdemes több útválasztási kapcsolatot létrehozni az idegen helyhez.

Az útválasztási kapcsolatok létrehozásával és beállításával kapcsolatos további tájékoztatásért tanulmányozza az Útválasztási kapcsolatok konfigurálása című részt.

Az MSMQ-MQSeries Bridge használata

Az MSMQ-MQSeries Bridge egy összekötő alkalmazás, amely a Message Queuing alkalmazásokat futtató számítógépek és az IBM MQSeries alkalmazásokat futtató számítógépek összekapcsolására használható. Ahhoz, hogy egy Message Queuing számítógépről egy MQSeries számítógépre üzenetet lehessen küldeni, a célvárólistának az idegen (MQSeries) számítógépen már léteznie kell. Az MSMQ-MQSeries Bridge és az IBM MQSeries programot futtató számítógépek konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza az MSMQ-MQSeries Bridge dokumentációját.

Az MSMQ-MQSeries Bridge jelenleg a Microsoft SNA Server 4.0-s verziójához tartozó 2-es vagy újabb szervizcsomag része.

A Message Queuing Connector használata

A Message Queuing Connector (MQC) egy összekötő alkalmazás, amely Windows alapú operációs rendszereken futó Message Queuing alkalmazások és nem Windows alapú operációs rendszereken futó Message Queuing alkalmazások közötti kommunikációra használható. Az MQC megtalálható a Windows 2000 Server és a Windows 2000 Advanced Server lemezein, és olyan számítógépekre lehet telepíteni, amelyeken Message Queuing kiszolgáló fut. Egy nem Windows alapú operációs rendszert futtató idegen számítógépre történő üzenetküldéshez először be kell szerezni és telepíteni kell a Level 8 Systems cég ügyfél programját. Egyes idegen számítógépek a függő ügyfelekhez hasonlóan működnek, így szükségük van egy Message Queuing támogató kiszolgálóra, amelyen az MQC fut. Az MQC programmal kapcsolatos további tájékoztatásért tanulmányozza az MQC dokumentációját. Az MQC program a Windows 2000 Server és a Windows 2000 Advanced Server lemezén, a VALUEADD\3RDPARTY\LEVEL8\MQC.QUE mappában található.

Az ebben az esetben szükséges ügyfél programmal kapcsolatos további tájékoztatásért tanulmányozza a Level 8 Systems által biztosított dokumentációt, vagy látogassa meg a Level 8 Systems webhelyét. (http://www.level8.com/)

A Message Queuing, az MSMQ-MQSeries Bridge és az MQC együtt is használható a teljes vállalatra kiterjedő összekapcsolhatóság érdekében. Küldhet például üzeneteket Message Queuing programot futtató UNIX számítógépek és IBM MQSeries programot futtató AS/400 számítógépek között.

Tűzfal konfigurálása

A vállalat tűzfala beállítható oly módon, hogy lehetővé tegye a tűzfal két oldalán lévő Message Queuing számítógépek kommunikációját. Ez azt is jelenti, hogy külső hálózaton lévő számítógépek hozzákapcsolódhatnak a belső hálózaton lévő Message Queuing kiszolgálókhoz az Interneten keresztül. Ez úgy érhető el, hogy a tűzfalon szolgáltatási portokat nyit.

Fontos

  • Ha a külső hálózaton lévő Message Queuing számítógépek számára hozzáférhetővé kívánja tenni az Active Directory címtárszolgáltatást, ajánlott létrehozni egy virtuális magánhálózatot (Virtual Private Network, VPN) a Point-to-Point Tunneling Protocol (PPTP) segítségével, különben a hálózati biztonság veszélybe kerülhet. A VPN-kapcsolatokkal és a PPTP protokollal kapcsolatos további tájékoztatásért tanulmányozza a Point-to-Point Tunneling Protocol (PPTP) című fejezetet.

Megjegyzések

  • A 2103-as és 2105-ös RPC portok megnövelhetők 11-gyel, ha az RPC port kezdeti értéke használatban van a Message Queuing szolgáltatás indulásakor. A Message Queuing a 135-ös RPC portot kérdezi le a 2xxx portok állapotával kapcsolatban.
  • Az MQPing parancs a 3527-es UDP porton működik.

A következő tűzfalbeállítások három működési módot tesznek lehetővé a külső hálózatokon lévő Message Queuing számítógépek számára.

Csak üzenetek küldése

Ahhoz, hogy a távoli ügyfelek üzeneteket tudjanak küldeni, elérhetővé kell tenni számukra a tűzfal 1801-es TCP portját.

Ebben a beállításban a távoli ügyfelek nem férhetnek hozzá az Active Directory címtárhoz, és a Message Queuing kiszolgálók sem továbbítanak üzeneteket a belső hálózaton keresztül. Ez azt jelenti, hogy a távoli ügyfeleknek ezen a porton keresztül közvetlenül kell kapcsolódniuk a helyi hálózaton lévő célszámítógéphez. Ezután a távoli ügyfelek küldhetnek üzeneteket a célvárólista közvetlen formátumnevének használatával.

Ez nem vonatkozik a függő ügyfelekre.

Üzenetek küldése Active Directory hozzáféréssel

Ha a 1801-es TCP port megnyitása mellett a 135-ös és a 2101-es RPC portokhoz is hozzáférést engedélyez, a távoli ügyfelek hozzáférhetnek az Active Directory címtárszolgáltatáshoz. A 135-ös RPC port a távoli ügyfél és a Message Queuing kiszolgáló közötti kézfogáshoz szükséges. A Message Queuing kiszolgálók a 2101-es RPC portot is használják az egymás közötti kommunikációhoz.

Ha a tűzfalon a csoportcímzéses hálózati csomagok is áthaladhatnak, az 1801-es UDP porthoz történő hozzáférés engedélyezése lehetővé teszi a távoli ügyfelek számára, hogy szórásos üzeneteket küldjenek a helyük meghatározásához.

Ez nem vonatkozik a függő ügyfelekre.

Üzenetek küldése és fogadása Active Directory hozzáféréssel

Ha az 1801-es TCP port, valamint a 135-ös és a 2101-es RPC portok mellett a 2103-as és a 2105-ös RPC portokhoz is hozzáférést engedélyez, a távoli számítógépek hozzáférhetnek a belső hálózaton lévő Message Queuing számítógépek várólistáihoz és üzeneteihez.

A 2103-as és a 2105-ös RPC portokhoz történő hozzáférés a távoli függő ügyfelek számára is lehetővé teszi, hogy a hálózaton található támogató kiszolgáló segítségével küldjenek és fogadjanak üzeneteket.


Message Queuing számítógépek felügyelete

Ebben a fejezetben a hálózat Message Queuing számítógépeinek konfigurálásáról és kezeléséről olvashat. Az Active Directory - felhasználók és számítógépek beépülő modul és a Vezérlőpult Message Queuing segédprogramja segítségével hajthatók végre a számítógépre kiterjedő felügyeleti feladatok.

Csatlakozás tartományhoz egy munkacsoportból

A Message Queuing szolgáltatás használható olyan környezetben, amely nem tagja tartománynak, például egy olyan számítógépen, amely egy Windows 2000 munkacsoport tagja. Ha a Message Queuing olyan számítógépen fut, amely tagja egy munkacsoportnak, a számítógép később csatlakozhat egy tartományhoz. Fordítva, egy Message Queuing számítógép tagja lehet egy tartománynak, majd később csatlakozhat egy munkacsoporthoz. Ez a számítógép később újra csatlakozhat ugyanahhoz vagy egy új tartományhoz. Ahhoz, hogy új tartományhoz csatlakozhasson, az új tartománynak tartalmaznia kell egy olyan Windows 2000 rendszeren futó Message Queuing kiszolgálót, amelyen engedélyezve van a globáliskatalógus-kiszolgáló. Továbbá a Message Queuing számítógépek csak Windows 2000 tartományokhoz csatlakozhatnak. Ha információra van szüksége azzal kapcsolatban, hogyan lehet egy tartományhoz csatlakozni egy munkacsoportból, tanulmányozza a Csatlakozás tartományhoz egy munkacsoportból című részt.

A Message Queuing nem tartománykörnyezetben történő futtatásával kapcsolatos korlátozásokról a Munkacsoport alapú környezet című fejezetben talál bővebb tájékoztatást.

Bemenő és kimenő útválasztó kiszolgálók hozzárendelése

Az üzenetek helyen belüli továbbítására bemenő és kimenő útválasztó kiszolgálónak nevezett Message Queuing kiszolgálók használhatók. Minden független ügyfél (vagy útválasztással nem rendelkező Message Queuing kiszolgáló) beállítható legfeljebb három kimenő és bemenő útválasztó kiszolgáló használatára, hogy azok végezzék el helyettük az útválasztást.

Azon mobil ügyfelek esetén, amelyek gyakran nincsenek a hálózatra kapcsolva, vagy egy távelérés-kiszolgálón keresztül kapcsolódnak a hálózathoz, bemenő és kimenő útválasztó kiszolgálókat kell használni.

Ugyanaz a Message Queuing kiszolgáló működhet bemenő és kimenő útválasztó kiszolgálóként is. Azonban az összes ilyen kiszolgálónak az ügyfél eredeti helyén kell lennie (azon a helyen, ahol az ügyfél telepítve lett). Ha egy mobil ügyfél másik helyre kerül, nem fogja használni ezeket a kiszolgálókat üzenet-útválasztásra, amíg vissza nem kerül az eredeti helyére.

Ajánlott a redundancia érdekében az ügyfeleken több bemenő és kimenő útválasztó kiszolgálót beállítani.

A bemenő és kimenő útválasztó kiszolgálók megadásával és módosításával kapcsolatos további tájékoztatásért tanulmányozza a Bemenő és kimenő útválasztó kiszolgálók módosítása című részt.

Bemenő vagy kimenő útválasztó kiszolgáló hozzáadása vagy eltávolítása egy helylistáról

A Message Queuing szolgáltatás egy listát tart fenn a bemenő és kimenő útválasztó kiszolgálók számára, amelyet az üzenetek továbbításához és egyéb nyomon követési funkciókhoz használ. A bemenő és kimenő útválasztó kiszolgálók több hely listáján is szerepelhetnek; a helylistához hozzáadhat, illetve törölhet bemenő vagy kimenő útválasztó kiszolgálókat. A számítógépeket a rendszer valójában nem adja hozzá a Windows 2000 helyhez, illetve nem távolítja el onnan; a számítógépeket csak a Message Queuing által fenntartott listához adja hozzá vagy távolítja el.

A bemenő és kimenő útválasztó kiszolgálók helylistához történő hozzáadásával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing kiszolgálók hozzáadása egy helylistához című részt.

A bemenő és kimenő útválasztó kiszolgálók helylistából történő eltávolításával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing kiszolgálók eltávolítása egy helylistából című részt.

Mobil ügyfelek áthelyezése új helyre

A mobil Message Queuing ügyfelek áthelyezhetők más Windows 2000 helyekre. Amikor például egy független ügyfél (vagy útválasztással nem rendelkező Message Queuing kiszolgáló) új helyre kerül, az ügyfélnek küldött összes olyan üzenet, amelyet nem csatlakoztatott állapotban küldtek felé, továbbításra kerül a régi helyről az új helyre. Ha az ügyfél az új helyhez kapcsolódik, az üzeneteket közvetlenül kapja meg. Ha a hálózatról való lekapcsolódás előtt új helyet ad meg, az ügyfél számára küldött összes olyan üzenet, amelyet nem csatlakoztatott állapotban küldtek felé, közvetlenül az új helyre továbbítódik, amíg az ügyfél úton van.

A mobil ügyfelek számára történő új hely megadásával kapcsolatos további tájékoztatásért tanulmányozza az Új hely meghatározása mobil ügyfelek számára című részt.

Ez csak független ügyfelekre és útválasztással nem rendelkező Message Queuing kiszolgálókra vonatkozik. Ha egy útválasztással rendelkező Message Queuing kiszolgálót (amely útválasztási szolgáltatást biztosít ügyfelek számára) másik helyre helyez át, a számítógépről el kell távolítani a Message Queuing szolgáltatást, majd amikor a számítógép már az új helyen van, újra kell azt telepíteni.

Távelérés használata ügyfelekkel

Telefonos Message Queuing ügyfelek a hálózathoz olyan számítógépen keresztül kapcsolódhatnak, amely távelérés-kiszolgálóként van beállítva, és rajta útválasztással rendelkező Message Queuing kiszolgáló fut. A távolsági hívások költségének csökkentése érdekében és ahhoz, hogy a távoli ügyfelek mindig ugyanahhoz a helyhez csatlakozhassanak, ajánlott minden helyen beállítani távelérés-kiszolgálót. Az ügyfelek úgy is beállíthatók, hogy a hálózathoz bármely helyen lévő távelérés-kiszolgálón keresztül kapcsolódjanak, ez azonban nem nyújtja ugyanazokat az előnyöket.

Azokon a számítógépeken, amelyek Message Queuing kiszolgálóként és távelérés-kiszolgálóként is üzemelnek, csak egyetlen IP-címet szabad beállítani. Ha a számítógépen több IP-cím van beállítva, az egyes ügyfelek által végzett automatikus helyfelismerés nem fog működni. Így a hálózathoz távelérés segítségével kapcsolódó ügyfelek üzenetküldési teljesítménye rossz lesz, vagy egyáltalán nem lesznek képesek üzenetek küldésére és fogadására.

Ha az ügyfelekhez távelérést használ, figyeljen a következőkre:

  • A távelérést használó ügyfeleken nem szabad beállítani a NetBEUI protokoll használatát. Ha az ügyfél a NetBEUI protokollt használja, az ügyfél neve a kiszolgáló IP-címéhez, és nem az ügyfél IP-címéhez lesz hozzárendelve. A NetBEUI protokoll támogatása alapértelmezés szerint nincs engedélyezve.
  • Nem tárcsázzon be egymás után két különböző helyre anélkül, hogy az ügyfélen leállítaná és újraindítaná a Message Queuing szolgáltatást.

A Windows 2000 távelérés szolgáltatásával kapcsolatos további tájékoztatásért tanulmányozza a Távelérés című témakört.

Függő ügyfelek támogató kiszolgálójának módosítása

A függő ügyfeleknek folyamatosan hozzá kell férniük egy Message Queuing kiszolgálóhoz, amelyet támogató kiszolgálónak nevezünk. A támogató kiszolgáló megadása a függő ügyfél telepítésekor történik meg. A használandó támogató kiszolgáló később is módosítható.

A függő ügyfelek támogató kiszolgálójának módosításával kapcsolatos további tájékoztatásért tanulmányozza a Függő ügyfelek támogató kiszolgálójának módosítása című témakört.

Egy Message Queuing kiszolgáló által jelenleg támogatott függő ügyfelek listájának megtekintésével kapcsolatos további tájékoztatásért tanulmányozza az Egy kiszolgálóhoz tartozó független ügyfelek listájának megtekintése című témakört.

Megjegyzés

  • Ha egy Windows NT 4.0 rendszeren futó, régebbi verziójú függő ügyféllel rendelkezik, melynek támogató kiszolgálóját egy Windows 2000 rendszeren futó Message Queuing kiszolgálóra szeretné módosítani, a függő ügyfélen a Windows NT Service Pack 4 szervizcsomagnak telepítve kell lennie, ellenkező esetben a tranzakció alapú üzenetküldés nem fog működni.

Üzenetek számítógépkvótájának beállítása

A számítógépkvóta a számítógép várólistáiban tárolt üzenetek összesített korlátját határozza meg. A számítógépkvóta elérése után mindaddig nem lehet több üzenetet küldeni a számítógépre, amíg egy vagy több üzenetet el nem távolítanak (el nem olvasnak) a számítógép egy várólistájából.

A számítógépkvóta Message Queuing kiszolgálók és független ügyfelek esetén állítható be. A függő ügyfeleket támogató Message Queuing kiszolgálókon beállított számítógépkvóták a kiszolgálóra és az összes függő ügyfelére is vonatkoznak.

A kvótákkal kapcsolatos további tájékoztatásért tanulmányozza az Üzenetkvóták című témakört.

A normál üzenetek számítógépkvótájának beállításával kapcsolatos további tájékoztatásért tanulmányozza A számítógépre érvényes üzenettárolási méret beállítása című részt.

A naplóüzenetek számítógépkvótájának beállításával kapcsolatos további tájékoztatásért tanulmányozza A számítógépre érvényes naplótárolási méret beállítása című részt.

Üzenetfájlok tárolása több lemezen

A Message Queuing kiszolgálók és a független ügyfelek üzenetkezelési teljesítménye növelhető, ha az üzenetkezeléshez használt különféle fájlok különböző fizikai lemezeken helyezkednek el. A Message Queuing az üzenetkezelési funkciók megvalósításához három különböző lemezt tud használni. A Message Queuing kiszolgálók legjobb üzenetkezelési teljesítménye érdekében az üzenetkezelő (*.mq), az üzenetnapló- és a tranzakciós naplófájlokat külön fizikai lemezeken ajánlott elhelyezni.

A használandó lemezek számának meghatározásával kapcsolatos további tájékoztatásért tanulmányozza a Lemezek száma című részt.

Az üzenetfájlok több lemezen történő tárolásával kapcsolatos további tájékoztatásért tanulmányozza az Üzenetek tárolása több lemezmeghajtón című részt.

DNS-tulajdonságok beállítása

Ha a hálózatban csak DNS működik, nincs például WINS-kiszolgáló, a DNS-beállításokat minden számítógépen konfigurálni kell ahhoz, hogy a Message Queuing helyesen keresse vissza a számítógépneveket.

Továbbá azt is ellenőrizni kell, hogy minden számítógépen teljesen minősített DNS-név legyen megadva, ellenkező esetben előfordulhat, hogy egyes Message Queuing műveletek nem fognak működni. Ezt a tulajdonságot általában a Windows 2000 tartomány minden számítógépén automatikusan beállítja a Hálózati bejelentkezés szolgáltatás. A tulajdonság ellenőrzéséhez nyissa meg az Active Directory - felhasználók és csoportok ablakot. A konzolfán kattintson a jobb oldali egérgombbal a megfelelő számítógép-objektumra, kattintson a Tulajdonságok parancsra, majd az Általános lapon nézze meg a DNS-név értékét.

A Message Queuing DNS tulajdonságainak konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing DNS-tulajdonságainak beállítása című témakört.

IPX/SPX-tulajdonságok beállítása

Az IPX protokollt használó hálózatokon a Message Queuing számára névhozzárendelésre van szükség. A névhozzárendeléshez az SAP-ügynök használható, amely a Windows 2000 része. Az SAP-ügynöknek az IPX protokollt használó Message Queuing számítógépeken kell futni. Az SAP-ügynök használatával kapcsolatos további tájékoztatásért tanulmányozza Az SAP protokoll használata című részt.

Ha a Message Queuing számítógépekben több hálózati csatoló található, és ha néhány csatolón az IPX protokoll használata van beállítva, ezeken a számítógépeknek meg kell adni egy egyedi, nullától különböző belső hálózati számot. Ha nem ad meg ilyen számot, problémák lehetnek az IPX protokollt használó MSMQ-RPC szállítási szolgáltató használata során. A hálózati számok beállításával kapcsolatos további tájékoztatásért tanulmányozza az NWLink beállítása című részt.

A számítógép hálózati kapcsolatának ellenőrzése

A Message Queuing az MQPing parancsot támogatja, amely hasonló a TCP/IP protokoll által támogatott ping parancshoz. Az MQPing parancs segítségével meghatározható, hogy egy Message Queuing számítógép jelenleg a hálózatra van-e kapcsolva. Amikor egy Message Queuing szolgáltatást futtató számítógép egy MQPing kérelmet kap, egy válaszüzenetet küld az MQPing kérelmet küldő számítógép válasz várólistájába.

Az MQPing használatával kapcsolatos további tájékoztatásért tanulmányozza A kapcsolat ellenőrzése az MQPing parancs segítségével című részt.

Kiszolgálófürt csomópontjainak felügyelete

Egy kiszolgálófürt egy csomópontján futó Message Queuing szolgáltatást ugyanúgy kell felügyelni, mint egy normál Message Queuing kiszolgálót, ugyanazon beépülő modulok használatával.

Egy fürtözött virtuális kiszolgálón futó Message Queuing kiszolgáló is felügyelhető a Számítógép-kezelés beépülő modul segítségével. A fürtözött virtuális kiszolgáló olyan fürtcsoport, amely egy Lemez erőforrást és egy Hálózati név erőforrást tartalmaz. A fürtözött virtuális kiszolgáló hasonlóan működik, mint egy fizikai számítógépen futó kiszolgáló, tehát egy fürtözött virtuális kiszolgálón futó Message Queuing kiszolgáló hasonlóan működik, mint egy fizikai számítógépen futó Message Queuing kiszolgáló.

Egy fürtözött virtuális kiszolgálón futó Message Queuing felügyeletéhez annak a csomópontnak, amelyen a fürtözött virtuális kiszolgáló fut, a hálózathoz kell kapcsolódnia és elérhetőnek kell lennie.


Message Queuing várólisták felügyelete

Ebben a fejezetben a Message Queuing várólisták kezeléséről és konfigurálásáról olvashat. A várólisták kezeléséhez a Számítógép-kezelés beépülő modul és az Active Directory - felhasználók és számítógépek beépülő modul használható. További tájékoztatásért tanulmányozza A Message Queuing felügyelete - áttekintés című részt.

Várólisták létrehozása, keresése és törlése

A várólisták létrehozására bizonyos korlátozások vonatkozhatnak, amelyek meghatározása a Message Queuing telepítése során történik. További tájékoztatásért tanulmányozza Az msmq objektumok biztonsági leírója című részt.

A várólisták létrehozásával, törlésével és keresésével kapcsolatos további tájékoztatásért tanulmányozza a Várólisták létrehozása, a Várólisták törlése és a Várólisták kezelése című témaköröket.

Várólisták megtekintése

Azt a műveletet, amikor egy várólista tartalmát a várólistát tartalmazó számítógépről tekintik meg, helyi olvasásnak nevezik. Azt a műveletet, amikor egy várólista tartalmát egy másik számítógépről érik el, távoli olvasásnak nevezik.

Csak azoknak a várólistáknak a tartalmát tekintheti meg, amelyeknek megnyitásához megfelelő engedéllyel rendelkezik. Ezért lehetnek olyan nyilvános várólisták, amelyek tartalma nem jelenik meg a beépülő modulokban. További tájékoztatásért tanulmányozza A várólista-objektumok engedélyeinek beállítása című részt.

Léteznek bizonyos rendszervárólisták, amelyeket a rendszer kizárólag belső műveletekre használ. Ezek átmeneti várólisták, amelyek a célvárólista felé tartó üzeneteket tárolják és továbbítják. Az Active Directory - felhasználók és számítógépek beépülő modul nem jeleníti meg ezeket az átmeneti várólistákat. Ezért ha egy üzenet éppen egy ilyen átmeneti várólistában van, az nem jelenik meg a Privát várólisták mappában.

Megjegyzések

  • Ha egy számítógépen privát várólistákat tekint meg, az “msmqadminresp” várólista szerepel a listán. Ez egy ideiglenes válaszvárólista, és nem tartalmaz olvasható üzeneteket. Ha megpróbálja megnyitni ezt a várólistát, “A várólista nem található” hibaüzenet jelenik meg.
  • Kevés erőforrásra figyelmeztető üzenet jelenhet meg, ha több olyan Message Queuing alkalmazást futtat (vagy egy alkalmazás több példányát futtatja), amelyek távoli várólistákból olvasnak üzeneteket. A probléma megoldásával kapcsolatos tájékoztatásért tanulmányozza A Message Queuing felügyeleti problémái - hibaelhárítás című témakört.
  • A Számítógép-kezelés beépülő modul használata esetén a kimenő várólistákban lévő tranzakció alapú üzenetek nem tekinthetők meg.

Várólisták tulajdonságainak módosítása

Az üzenetek nyilvános várólistákba történő küldése a célvárólista prioritásának és az egyes üzenetek prioritásának összege alapján, azaz az alapprioritás alapján történik. A rendszer a legmagasabb prioritással rendelkező üzeneteket küldi el először. Az üzenetek elküldése először az alapprioritás, majd az üzenetprioritás alapján történik. A privát várólisták nem támogatják az alapprioritást, ezért az üzenetek küldése csak az üzenetprioritás alapján történik.

A várólisták alapprioritásának módosításával kapcsolatos további tájékoztatásért tanulmányozza a Várólisták alapprioritásának módosítása című fejezetet.

A várólista típusazonosítója a várólista típusát vagy az általa biztosított szolgáltatást határozza meg. A várólisták típusazonosítója egy adott típusú várólista kereséséhez, megnyitásához és törléséhez használható.

A várólisták típusazonosítójának módosításával kapcsolatos tájékoztatásért tanulmányozza a Várólisták típusazonosítójának módosítása című fejezetet.

A várólisták címkéjének módosításával kapcsolatos tájékoztatásért tanulmányozza a Várólistacímkék módosítása című részt.

A várólista titkosítási szintjének megadásával beállíthatja, hogy a várólista elfogadhat-e titkosított üzeneteket, nem titkosított üzeneteket, illetve mindkettőt. Ha a várólista titkosítási szintjét Nincs értékre állítja, a várólista csak a nem titkosított üzeneteket fogadja el. Ha a várólista titkosítási szintjét Törzs értékre állítja, a várólista csak a titkosított üzeneteket fogadja el. Ha a várólista titkosítási szintjét Választható értékre állítja, a várólista a titkosított és a nem titkosított üzeneteket is elfogadja. Az, hogy egy üzenetet a várólistába titkosítva vagy nem titkosítva küldtek-e, az Active Directory - felhasználók és számítógépek beépülő modul segítségével ellenőrizhető (vagy programból a PROPID_M_PRIV_LEVEL üzenettulajdonság ellenőrzésével).

A várólisták titkosítási szintjének beállításával kapcsolatos további tájékoztatásért tanulmányozza a Várólisták titkosítási szintjének módosítása című fejezetet. Az üzenettitkosítással kapcsolatos általános tájékoztatásért tanulmányozza A Message Queuing titkosítása című részt.

Az is meghatározható, hogy egy várólista csak hitelesített üzeneteket fogadjon el. További tájékoztatásért tanulmányozza a Csak hitelesített üzenetek engedélyezése a várólistákban című részt. Az üzenethitelesítéssel kapcsolatos általános tájékoztatásért tanulmányozza az Üzenetek hitelesítése című fejezetet.

Üzenetek várólistakvótájának beállítása

A várólistakvóta egy adott várólistában tárolt üzenetek összesített korlátját határozza meg. A várólistakvóta elérése után nem lehet több üzenetet küldeni a várólistára, amíg egy vagy több üzenetet el nem távolítanak (el nem olvasnak) belőle.

Várólistakvóták csak Message Queuing kiszolgálókon és független ügyfeleken állíthatók be. A függő ügyfeleket támogató Message Queuing kiszolgálókon beállított várólistakvóták a kiszolgálóra és az összes függő ügyfelére is vonatkoznak.

A kvótákkal kapcsolatos további tájékoztatásért tanulmányozza az Üzenetkvóták című témakört.

A normál üzenetek várólistakvótájának beállításával kapcsolatos további tájékoztatásért tanulmányozza a Várólisták üzenettárolási méretének beállítása című részt.

A naplóüzenetek várólistakvótájának beállításával kapcsolatos további tájékoztatásért tanulmányozza a Várólisták naplótárolási méretének beállítása című részt.

A célnaplózás engedélyezése

A célnaplózást minden várólistára külön lehet meghatározni. A célnaplózás engedélyezése esetén minden bejövő üzenetről másolat készül a cél-naplóvárólistában, amikor egy üzenetet eltávolítanak (elolvasnak) a célvárólistából.

A várólisták célnaplózásának engedélyezésével kapcsolatos tájékoztatásért tanulmányozza A célnaplózás engedélyezése és letiltása című témakört.

A kimenő várólisták működésének szüneteltetése és folytatása

A számítógép kimenő várólistáit a rendszer az üzenetek átmeneti tárolására használja, mielőtt azokat a céljuk felé elküldené. A kimenő várólisták csak a Számítógép-kezelés beépülő modul segítségével tekinthetők meg.

A helyi kimenő várólisták működése szüneteltethető, majd később folytatható, így késleltetni lehet a várólistában lévő üzenetek elküldését. Ily módon az összes várakozó üzenet később is elküldhető a célvárólistába. A kimenő várólisták működésének szüneteltetésével és folytatásával kapcsolatos tájékoztatásért tanulmányozza a Kimenő várólisták működésének szüneteltetése és folytatása című részt.

A Message Queuing lekapcsolható a hálózatról. Amikor a Message Queuing szolgáltatást lekapcsolja a hálózatról, a helyi számítógép összes kimenő várólistájának működését felfüggeszti. Ez telefonos kapcsolaton keresztüli kommunikáció esetén hasznos, ha el szeretné halasztani a számítógép összes kimenő várólistájában lévő üzenet elküldését. A Message Queuing hálózatról történő lekapcsolásával kapcsolatos további tájékoztatásért tanulmányozza A kimenő várólisták lekapcsolása a hálózatról című részt.

Tesztüzenet küldése egy várólistába

Egy független ügyfélről vagy egy Message Queuing kiszolgálóról tesztüzenetet küldhet ugyanazon Windows 2000 erdő bármely másik független ügyfelén vagy Message Queuing kiszolgálóján lévő tesztvárólistába. Ehhez először létre kell hozni egy tesztvárólistát vagy módosítani kell egy meglévő várólista típusazonosítóját, hogy tesztüzeneteket küldhessen a célszámítógép tesztvárólistájába.

A tesztvárólisták típusazonosítója {55EE8F33-CCE9-11CF-B108-0020AFD61CE9}. A legtöbb meglévő várólista módosítható úgy, hogy tesztvárólistaként működjön, ha a típusazonosítóját a tesztvárólista típusazonosítójára változtatja. Azonban tranzakciós várólistákat és üzenethitelesítést igénylő várólistákat ne konvertáljon tesztvárólistákká, mivel a rendszer nem kézbesít tesztüzenetek ilyen várólistákba.

A tesztüzenetek küldésével kapcsolatos további tájékoztatásért tanulmányozza a Tesztüzenetek küldése című részt.


Message Queuing üzenetek felügyelete

Ebben a fejezetben arról olvashat, hogyan lehet felügyelni a Message Queuing üzeneteket, azaz hogyan lehet az üzeneteket megtekinteni és törölni, hogyan lehet az üzenetek alapértelmezett élettartamát beállítani, és hogyan lehet az üzenetek tulajdonságait megtekinteni és beállítani.

Az üzenetek felügyeletéhez a Számítógép-kezelés beépülő modul és az Active Directory - felhasználók és számítógépek beépülő modul használható. További tájékoztatásért tanulmányozza A Message Queuing felügyelete - áttekintés című részt.

A tranzakció alapú üzenetek figyelésével kapcsolatos további tudnivalókért tanulmányozza a Tranzakció alapú üzenetek figyelése című témakört.

Üzenetek olvasása

Az üzenet törzse tartalmazhat szöveges vagy bináris adatokat. Ha az üzenet törzse szöveges információt tartalmaz, akkor az megjelenik. Ha az üzenet törzse bináris információt tartalmaz, hexadecimális adatok jelennek meg a szöveges fordítással együtt. Az üzenet törzse az üzenet Törzs párbeszédpanelén tekinthető meg.

Egy várólistában lévő üzenetek elolvasásához a várólistához Üzenetek fogadása engedéllyel kell rendelkezni. Nem elegendő a várólistához Olvasás engedéllyel rendelkezni. A várólisták engedélyeinek beállításával kapcsolatos további tájékoztatásért tanulmányozza A várólista-objektumok engedélyeinek beállítása című részt.

Üzenetek törlése

Bármely várólista minden üzenetét törölheti, a rendszer és a privát várólistákét kivéve. Csak az összes üzenet törlésére van mód, egyes üzenetek nem törölhetők.

Az üzenetek várólistából történő eltávolításával kapcsolatos további tájékoztatásért tanulmányozza a Várólista összes üzenetének törlése című témakört.

Üzenetek tulajdonságainak módosítása

Beállíthatja az üzenetek alapértelmezett hálózati élettartamát, más néven a várólista-elérési időkorlátot (time-to-reach-queue, TTRQ). Egy üzenet akkor tekinthető lejártnak, ha elérte a TTRQ értéket. Az üzenetek hálózati élettartamának beállításával kapcsolatos további tájékoztatásért tanulmányozza az Üzenetek alapértelmezett élettartamának beállítása című részt.

Az üzenetek számos tulajdonsága megtekinthető. Az üzenetek tulajdonságainak megtekintésével kapcsolatos további tájékoztatásért tanulmányozza az Üzenetek tulajdonságainak megtekintése című témakört.

Azt is kiválaszthatja, hogy alapértelmezés szerint mely üzenettulajdonság-oszlopok jelenjenek meg a beépülő modul részletek ablaktábláján (általában a jobb oldali ablaktáblán), és milyen sorrendben. A megjelenő üzenettulajdonságok módosításával kapcsolatos további tájékoztatásért tanulmányozza A megjelenő üzenettulajdonság-oszlopok módosítása című témakört.

Üzenetek nyomon követése

Egy üzenet hálózaton bejárt útvonalát nyomon követheti, ha egy tesztüzenetet küld egy tesztvárólistába, vagy ha engedélyezi az üzenetek nyomon követése beállítást.

Tesztüzenet küldése

Egy független ügyfélről vagy egy Message Queuing kiszolgálóról tesztüzenetet küldhet ugyanazon Windows 2000 erdő bármely másik független ügyfelén vagy Message Queuing kiszolgálóján lévő tesztvárólistába. Ehhez először létre kell hozni egy tesztvárólistát, vagy módosítani kell egy meglévő várólista típusazonosítóját, hogy tesztüzeneteket küldhessen a célszámítógép tesztvárólistájába. További tájékoztatásért tanulmányozza a Tesztüzenet küldése várólistába című részt.

Mivel az összes tesztüzenet engedélyezett nyomkövetéssel kerül elküldésre, az üzenet hálózaton megtett útvonala is nyomon követhető, ha a forrásszámítógépen létezik jelentés-várólista.

A tesztüzenetek küldésével kapcsolatos további tájékoztatásért tanulmányozza a Tesztüzenetek küldése című részt.

Üzenetek útvonalának nyomon követése

A üzenetek útvonalának nyomon követése szolgáltatás segítségével az üzenetek hálózaton bejárt útvonala ellenőrizhető. Amikor az üzenet keresztülhalad egy Message Queuing kiszolgálón, az egy jelentésüzenetet küld a forrásszámítógép jelentés-várólistájába, amely jelzi, hogy melyik kiszolgálón haladt keresztül az üzenet.

Az üzenetek nyomon követésének használata két lépésből áll. Először engedélyezni kell az üzenetek útvonalának nyomon követését oly módon, hogy a forrásszámítógépen megad egy jelentés-várólistát. Ezután a megfelelő üzenettulajdonságot a küldő alkalmazás beállítja.

Az üzenetútvonalak nyomon követésének engedélyezésével kapcsolatos további tájékoztatásért tanulmányozza az Üzenetútvonalak nyomon követésének engedélyezése című témakört. A Message Queuing SDK-val (a tulajdonságok programon keresztül történő beállításával) kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Platform Software Development Kit csomagot.

Minden üzenet csak egyetlen jelentés-várólistát támogat. Ha egy nyomkövetett útvonalú üzenet olyan Message Queuing kiszolgálón halad keresztül, amelyen szintén engedélyezve van az üzenetek útvonalának nyomon követése, a Message Queuing egy jelentésütközési üzenetet küld a forrásszámítógép jelentés-várólistájába.

Tegyük fel, hogy van három számítógép, A, B és C, és az A számítógépen engedélyezve van az üzenetek útvonalának nyomon követése. Az A számítógépen lévő Message Queuing alkalmazás egy üzenetet küld a C számítógépnek a B Message Queuing kiszolgálón keresztül. Ha az A számítógép jelentés-várólistájának neve R, a következő esetekben kerül jelentésüzenet az R várólistába:

  • Az üzenet elhagyja az A számítógépet.
  • Az üzenet megérkezik a B Message Queuing kiszolgálóra.
  • Az üzenet elhagyja a B Message Queuing kiszolgálót.
  • Az üzenet megérkezik a C számítógépre.

Ha azonban a B Message Queuing kiszolgálón is engedélyezve van az üzenetek útvonalának nyomon követése, amely az S várólistába küldi a jelentésüzeneteket, az S várólistába egy jelentésvárólista-ütközés üzenet kerül, amikor az üzenet elhagyja a B Message Queuing kiszolgálót. Az R várólista azonban továbbra is a helyes nyomon követési üzeneteket kapja.

A jelentésüzenetek formátuma a következő:

gggg:dddd:hh sent from <számítógép> to <cím> at <időpont>

gggg:dddd:hh received by <számítógép> to <cím> at <időpont>

ahol gggg a forrásvárólista globálisan egyedi azonosítójának (GUID) első négy hexadecimális számjegye, dddd a belső üzenetazonosító, hh pedig az ugrások száma.

A belső üzenetazonosító az üzenet sorozatszáma, amely a teljes üzenetazonosító része. Azért nem használják a teljes üzenetazonosítót, mert az túl hosszú ahhoz, hogy könnyen el lehessen olvasni (egy 16 bites forrás GUID azonosítóból és egy 4 bájtos sorozatszámból áll).

Üzenetek biztonsági mentése és visszaállítása

Az üzenettároló fájlok, a naplófájlok, a tranzakciós naplófájlok és a rendszerleíró adatbázis beállításainak a számítógép meghibásodása elleni védelmére a Message Queuing programmal szállított Mqbkup biztonsági mentést készítő és visszaállító segédprogramot használhatja. A segédprogram használata előtt létre kell hoznia egy mappát a biztonsági mentés számára. A segédprogram futtatásához írja be az mqbkup parancsot a parancssorba.

A segédprogram szintaxisa a következő:

mqbkup {-b mappa_útvonala | -r mappa_útvonala | -?}

ahol:

-b mappa_útvonala a fájlok biztonsági mentését végzi a megadott mappába

-r mappa_útvonala a fájlok visszaállítását végzi a megadott mappából

-? a segédprogram súgóját jeleníti meg

Az üzenetek visszaállítása előtt zárja be a Vezérlőpultot és az összes Message Queuing alkalmazást.

A segédprogram nem készít biztonsági mentést a bizonyítványinformációkról és a titkosítási kulcsok információiról.

Visszaállítás után új felhasználói bizonyítványt kell regisztrálni. A bizonyítványok regisztrálásával kapcsolatos további tájékoztatásért tanulmányozza a Message Queuing bizonyítványok regisztrálása című részt.

A segédprogram leállítja és újraindítja a Message Queuing szolgáltatást.


Az MSMQ-Exchange összekötő felügyelete

A Microsoft Exchange felhasználók az MSMQ-Exchange összekötő segítségével küldhetnek üzeneteket és űrlapokat Message Queuing alkalmazásoknak. A Message Queuing alkalmazások ugyancsak az MSMQ-Exchange összekötőt használhatják a Microsoft Exchange felhasználóknak történő üzenetküldéshez.

A következőkben az Exchange ügyfelek kifejezést általános értelemben használjuk. A kifejezés vonatkozhat a Microsoft Exchange Server, a Windows 95, a Windows 98, a Windows NT 4.0 vagy a Windows 2000 részeként szállított Microsoft Exchange ügyfélre is. Az utalások a Microsoft Outlook programra is vonatkoznak (amely a Microsoft Office 97 vagy újabb verziók része).

Üzenetküldés a Message Queuing szolgáltatásból az Exchange rendszerbe

Az alábbi ábra azt mutatja, hogy egy Message Queuing alkalmazás oly módon tud levélüzenetet küldeni egy Microsoft Exchange felhasználónak, hogy az üzenetet először az MSMQ-Exchange összekötőnek küldi el. Ezután az MSMQ-Exchange összekötő kiolvassa az üzenetet az összekötő-várólistából, feldolgozza a tartalmát, létrehoz egy Microsoft Exchange üzenetet, majd elküldi azt a megfelelő Exchange ügyfélnek az Exchange kiszolgálón keresztül.

Egy Message Queuing ügyféltől egy Exchange ügyfélnek küldött üzeneteket bemutató ábra

Üzenetküldés az Exchange rendszerből a Message Queuing szolgáltatásnak

Az alábbi ábrán az látható, hogy a Microsoft Exchange ügyfelek hogyan tudnak elektronikus leveleket és űrlapokat küldeni a Message Queuing alkalmazásoknak. Ehhez az Exchange ügyfél az elektronikus levelek címzéséhez a célvárólista várólistacímkéjét használja (“MSMQ” címtípussal). Ez a cím beállítható egyéni címzettként a Microsoft Exchange címjegyzékben.

A Microsoft Exchange kiszolgáló továbbítja az elektronikus levelet az MSMQ-Exchange összekötőnek. Ezután az MSMQ-Exchange összekötő átalakítja az elektronikus levelet Message Queuing üzenetté, majd elküldi a megfelelő célszámítógépnek. Ezután a célszámítógépem futó Message Queuing alkalmazás el tudja olvasni az üzenetet.

Egy Exchange ügyféltől egy Message Queuing ügyfélnek küldött üzeneteket bemutató ábra

Megjegyzések

  • A célszámítógépen lévő várólisták típusazonosítójának értéke {5eadc0d0-7182-11cf-a8ff-0020afb8fb50} kell legyen, hogy levélüzeneteket tudjon fogadni.
  • Mivel a Message Queuing alkalmazások eredetileg nem támogatják az Exchange által használt MAPI rich text formátumot, a Message Queuing címbejegyzéseit úgy kell beállítani, hogy az üzenetek ne rich text formátumban legyenek elküldve.

Üzenetküldés Exchange rendszerek között

A Microsoft Exchange ügyfelek küldhetnek elektronikus leveleket és űrlapokat más helyen lévő Microsoft Exchange ügyfeleknek a Message Queuing segítségével. Ez csak akkor lehetséges, ha mindkét helyen van egy olyan Message Queuing kiszolgáló, amelyre az MSMQ-Exchange összekötő telepítve van.

A Microsoft Exchange kiszolgáló továbbítja az elektronikus levelet az MSMQ-Exchange összekötőnek. Az MSMQ-Exchange összekötő átalakítja az elektronikus levelet Message Queuing üzenetté, majd elküldi a célhelyen lévő MSMQ-Exchange összekötőnek. A célhelyen lévő MSMQ-Exchange összekötő ezután átalakítja és továbbítja az elektronikus levelet a megfelelő Exchange ügyfélnek.

Az Exchange ügyfelek közötti üzeneteket bemutató ábra

Az ábrán az látható, hogy az MSMQ-Exchange összekötő hogyan használható elektronikus levelek küldésére két különböző helyen lévő Exchange ügyfél között. Ez a konfiguráció akkor hasznos, ha a két hely között nincs fizikai hálózati kapcsolat.

Azoknak az Exchange ügyfeleknek lehet üzenetet küldeni, amelyeknek a neve megjelenik az Exchange címjegyzékben. Ahhoz, hogy elektronikus leveleket tudjon küldeni egy SMTP-címre (vagy bármilyen külső címre, amit az Exchange kiszolgáló támogat), hozzon létre az Exchange címjegyzékben egy egyéni címzettet, majd címként adja meg a CustomRecipAlias@exchinqueue címet, ahol a CustomRecipAlias az elektronikus levélcím aliasa az Exchange címjegyzékben, az exchinqueue pedig az MSMQ-Exchange összekötő várólista várólistacímkéje. Címtípusként az “MSMQ” értéket kell megadni.

Mivel mindkét Microsoft Exchange ügyfél alapértelmezés szerint támogatja a MAPI rich text formátumot, a címbejegyzéseket be lehet állítani úgy, hogy az üzenetek rich text formátumban legyenek elküldve.

Az MSMQ-Exchange összekötő konfigurálása

Az MSMQ-Exchange összekötő az Exchange Administrator program segítségével állítható be, az MSMQ összekötő tulajdonságai párbeszédpanelen. Az Általános lapon adhatja meg az üzenetek maximális méretét. A Címterület lapon állíthatja be a címterületet és adhatja meg a kapcsolatok költségét (ez a Microsoft Exchange útválasztására van hatással). A Beállítások lapon a következő műveleteket hajthatja végre:

  • Engedélyezheti vagy letilthatja a bejövő üzenetek feldolgozását.
  • Megadhatja a szálak maximális számát, amelyek a bejövő üzenetek feldolgozására használhatók.
  • Engedélyezheti vagy letilthatja a kimenő üzenetek feldolgozását.
  • Megadhatja a szálak maximális számát, amelyek a kimenő üzenetek feldolgozására használhatók.

Alapértelmezés szerint négy szál használható a bejövő üzenetek feldolgozására, és négy szál a kimenő üzenetek feldolgozására. Ha a feldolgozás okozta terhelés az egyik irányban nagyobb, mint a másikban, vagy a kiszolgáló nem elég gyorsan dolgozza fel az üzeneteket, növelheti a szálak számát.

Az MSMQ-Exchange összekötő konfigurálásával kapcsolatos további tájékoztatásért tanulmányozza Az MSMQ-Exchange összekötő konfigurálása című részt.

Megjegyzés

  • Ha az MSMQ-Exchange összekötő nem tud feldolgozni egy üzenetet, azt egy Error nevű mappába teszi. Ez a mappa az MSMQ-Exchange összekötő telepítési mappájában található. Az üzenetet törölheti, vagy megpróbálhatja kijavítani és elküldeni a megfelelő célhoz.

Az Exchange Administrator program használatával kapcsolatos további tájékoztatásért tanulmányozza a Microsoft Exchange Server dokumentációját.

Az MSMQ-Exchange összekötő szolgáltatás elindítása

Az MSMQ-Exchange összekötő Windows 2000 Server alatti szolgáltatásként fut. A szolgáltatás neve MSMQ-Exchange összekötő (várólistacímke), ahol a várólistacímke a bejövő üzenetek fogadására létrehozott várólista címkéje. Ezt a címkét az MSMQ-Exchange összekötő telepítése során kell megadni.

Az MSMQ-Exchange összekötő szolgáltatás elindításával és leállításával kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing szolgáltatás elindítása és leállítása című fejezetet.


A Message Queuing figyelése

Ebben a fejezetben arról olvashat, hogyan lehet az Eseményfigyelő segítségével figyelni a Message Queuing eseményeit, hogyan lehet a Rendszerfigyelő segítségével figyelni a Message Queuing teljesítményét, és hogyan lehet a Microsoft elosztott tranzakciók koordinátora (MS DTC) segítségével figyelni a Message Queuing tranzakciókat.

Események figyelése

A Message Queuing a Windows 2000 eseménynaplókba rögzíti a működésével kapcsolatos információkat. A Message Queuing eseményei a Forrás oszlopban találhatók az “MSMQ” alatt. A legtöbb esemény (köztük az MSMQ-Exchange összekötő eseményei) az Alkalmazásnaplóba kerül. A biztonsággal kapcsolatos események a Biztonsági naplóba kerülnek rögzítésre.

A Message Queuing eseményeinek megtekintésével kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing eseményeinek megtekintése című részt.

Az Eseménynaplóval kapcsolatos további tájékoztatásért tanulmányozza az Eseménynapló című részt.

A Windows 2000 Alkalmazásnaplójában háromféle Message Queuing alkalmazásüzenet lehet.

  • Tájékoztató. Ritkán előforduló fontos események, amelyek sikeres műveleteket jeleznek.
  • Figyelmeztetés. Nem feltétlenül fontos üzenetek, de lehetséges problémákat jelezhetnek.
  • Hiba. Jelentős hibák előfordulásakor létrejövő események.

Egyes alkalmazásesemények nem kerülnek be a naplóba minden előfordulásukkor. Ha például egy Message Queuing kiszolgáló nem tud létrehozni egy munkamenetet a célszámítógéppel, csak az első sikertelen kísérletről készül naplóbejegyzés. A következő naplóbejegyzés akkor jön létre, amikor a munkamenet létrejön.

A Windows 2000 Biztonsági naplójában kétféle Message Queuing biztonsággal kapcsolatos esemény lehet.

  • Sikeres esemény. Akkor jön létre, ha a kijelölt objektumokhoz történő hozzáférés sikerrel jár.
  • Sikertelen esemény. Akkor jön létre, ha a kijelölt objektumokhoz történő hozzáférést a rendszer megtagadja.

A naplózással kapcsolatos további tájékoztatásért tanulmányozza A Message Queuing naplózása című részt.

A teljesítmény figyelése

A Message Queuing teljesítménye a hozzá adott teljesítményszámlálók segítségével figyelhető meg. Ezek a teljesítményszámlálók a Rendszerfigyelő segítségével jeleníthetők meg. Az alapértelmezett teljesítményszámlálók a következő objektumok alatt találhatók:

  • MSMQ-szolgáltatás
  • MSMQ-várólista
  • MSMQ-munkamenet
  • MSMQ replikációs szolgáltatás
  • MSMQ-Exchange összekötő

A Rendszerfigyelővel kapcsolatos további tájékoztatásért tanulmányozza a Rendszerfigyelő - áttekintés című részt.

Megjegyzés

  • A teljesítményszámlálók nem használhatók a Message Queuing kiszolgálófürtön történő futtatása esetén.

MSMQ-szolgáltatás teljesítményobjektum

Az MSMQ-szolgáltatás teljesítményobjektum Message Queuing kiszolgálókon és független ügyfeleken használható. Az MSMQ-szolgáltatás objektum olyan teljesítményszámlálókat tartalmaz, amelyek a kiválasztott számítógép munkamenet- és üzenetstatisztikáinak megfigyelésére használhatók.

A memóriahasználatot jelző érték tartalmazza a számítógép helyi várólistáiban lévő összes üzenet által elfoglalt memóriaterületet is. Mivel a helyreállítható üzenetek tárolása a lemezen történik, ez a memóriaterület a memórialeképező fájlokban található a lemezen, és nem a Windows 2000 lapozható memóriakészletében. Az üzenetek tárolásával kapcsolatos további tájékoztatásért tanulmányozza a Helyi üzenettárolás című fejezetet.

MSMQ-várólista teljesítményobjektum

Az MSMQ-várólista teljesítményobjektum olyan teljesítményszámlálókat tartalmaz, amelyek a számítógép kiválasztott várólistájához tartozó üzenetstatisztikák megfigyelésére használhatók. A számítógép minden várólistájához tartoznak számlálók. Ha egy Message Queuing alkalmazáshoz tartozik egy nyitott privát várólista egy másik számítógépen, megjelenik egy számláló a távoli várólistához is. Egy várólista-számláló neve megegyezik a várólista formátumnevével. Ha fut összekötő alkalmazás a számítógépen, az összekötő-várólistához is tartozik egy számláló. A várólista nevének formátuma: foreign=GUID.

A Példány mezőben csak a számítógépen létrehozott első 97 várólista jelenik meg (a privát várólistákat is beleértve). Egy adott számítógép várólista-számlálói több példányhoz is megjelennek. A Számítógép várólistái példány a számítógép forrás-naplóvárólistáit és kézbesítetlen üzenetek várólistáit jelenti. A Bájtok a várólistában és az Üzenetek a várólistában számlálók a számítógép kézbesítetlen üzenetek várólistáját figyelik. A Bájtok a naplóvárólistában és az Üzenetek a naplóvárólistában számlálók a számítógép forrás-naplóvárólistáját figyelik.

Egy ideiglenes várólista könnyen azonosítható, mivel a számlálópéldányban szereplő számítógépnév nem egyezik meg annak a számítógépnek a nevével, amelyen a várólista található.

MSMQ-munkamenet teljesítményobjektum

Az MSMQ-munkamenet teljesítményobjektum csak akkor jelenik meg, ha a számítógép munkamenetet hozott létre egy másik Message Queuing számítógéppel. Az objektum több példányban is megjelenhet, mivel minden munkamenethez külön példány tartozik. A Példány mezőben megjelenik annak a számítógépnek az IP vagy IPX címe, amellyel a munkamenet létrejött.

MSMQ replikációs szolgáltatás teljesítményobjektum

Az MSMQ replikációs szolgáltatás teljesítményobjektum csak vegyes módú környezetben látható, ha az MSMQ 1.0 elsődleges vállalati vezérlő (PEC) Windows 2000 alatt futó Message Queuing kiszolgálóra lett frissítve, és fut az MSMQ replikációs szolgáltatás. Az objektumhoz tartozó számlálók különféle teljesítménystatisztikákat jelenítenek meg a Windows NT 4.0 rendszert futtató MSMQ 1.0 vezérlőkiszolgálókkal történő adatreplikálás során.

MSMQ-Exchange összekötő teljesítményobjektum

Az MSMQ-Exchange összekötő teljesítményobjektum csak az MSMQ-Exchange összekötő telepítése után látható. Az objektumhoz tartozó számlálók az összekötőről jelenítenek meg különféle statisztikákat.

Az üzenetkezelési teljesítmény növelése

Ha a rendelkezésre álló feldolgozó erőforrások (CPU idő) nem korlátozzák az üzenetkezelési teljesítményt, esetleg növelhető a független ügyfelek és a Message Queuing kiszolgálók üzenetkezelési teljesítménye, ha az üzenetkezeléshez használt napló- és üzenetfájlokat több fizikai lemezen tárolja.

Annak meghatározásához, hogy a számítógépet a lemezhozzáférés vagy a feldolgozási teljesítmény korlátozza, használja A processzor kihasználtsága (%) (a Processzor objektumban található) és a Lemez várakozási sorának hossza (a Lemezhossz objektumban található) számlálókat. Ha A processzor kihasználtsága (%) számláló értéke tartósan 75 százalék fölött van az üzenetek küldése közben, a feldolgozási kapacitás növelése javíthat a teljesítményen. Ha a Lemez várakozási sorának hossza számláló értéke bármely lemeznél 0,6-nál nagyobb az üzenetek küldése közben, további lemezek hozzáadása javíthatja az üzenetkezelés teljesítményét.

Az üzenet- és a naplófájlok külön fizikai lemezeken történő tárolásával kapcsolatos további tájékoztatásért tanulmányozza az Üzenetek tárolása több lemezmeghajtón című részt.

A kiszolgálókban használandó lemezek számával kapcsolatos további tájékoztatásért tanulmányozza a Lemezek száma című részt.

Tranzakció alapú üzenetek figyelése

A Message Queuing a Windows 2000 rendszerrel szállított Microsoft elosztott tranzakciók koordinátorát (MS DTC) használja a tranzakciók megfigyeléséhez. Az MS DTC felügyeleti konzol segítségével figyelhető meg a tranzakció alapú üzenetek statisztikája és az összes MS DTC által kezelt tranzakció statisztikája. További tájékoztatásért tanulmányozza A Message Queuing tranzakciók megtekintése című részt.

Külső (vagy kétfázisú) tranzakciók megfigyelésekor a Statisztika lapon hasznos adatok láthatók az aktív, a megerősített és a félbehagyott tranzakciókkal kapcsolatban. Az elosztott tranzakciók koordinátora szolgáltatásnak futni kell a külső tranzakció alapú üzenetküldések végrehajtásához.

A tranzakció alapú üzenetküldéssel kapcsolatos további tudnivalókért tanulmányozza a Tranzakció alapú üzenetkezelés című témakört.

Az MS DTC szolgáltatással kapcsolatos további tudnivalókért tanulmányozza A Komponensszolgáltatások használata című témakört.


Forrásmunkák

Ebben a fejezetben a Message Queuing szolgáltatással és a Message Queuing szolgáltatást használó más szoftvertermékekkel kapcsolatos további információforrások találhatók.

Microsoft Platform Software Development Kit

A Message Queuing Software Development Kit (SDK) a Microsoft Platform SDK részeként érhető el. A Message Queuing SDK a Message Queuing alkalmazások fejlesztésével kapcsolatos háttérinformációkat tartalmaz, valamint egy referencia fejezetet, amely a Message Queuing által nyújtott és használt funkciókat, tulajdonságokat, struktúrákat és COM-összetevőket mutatja be. A Message Queuing SDK továbbá számos jellemző alkalmazástípushoz tartalmaz forráskód- és programfájl-példákat.

A Message Queuing SDK a Microsoft Platform SDK „Component Services” fejezetében található meg.

A Microsoft Platform SDK csomag szabályos időközönként kerül kiadásra az MSDN-en (Microsoft Developer Network) keresztül.

Webhelyek

  • A Message Queuing szolgáltatással kapcsolatos legfrissebb információkat megtalálja a Microsoft webhely Message Queuing Overview and Resources című oldalán. (http://www.microsoft.com/)
  • A Message Queuing szolgáltatással kapcsolatos legfrissebb kérdéseket és válaszokat és a Microsoft Personal Support Center oldalt megtalálja a Microsoft webhely Message Queue Frequently Asked Questions című oldalán. (http://www.microsoft.com/)
  • Az Integrity Training, Inc. által nyújtott számítógép alapú oktatási megoldásokkal kapcsolatos tájékoztatásért látogassa meg az Integrity Training webhelyet. (http://www.integritytraining.com)
  • A Level 8 Systems által biztosított, nem Windows platformok összekapcsolására szolgáló megoldásokkal kapcsolatos további tájékoztatásért látogassa meg a Level 8 Systems webhelyet. (http://www.level8.com/falcon.htm)
  • Az üzenetsor-kezelő szoftverekkel kapcsolatos további általános tájékoztatásért látogassa meg a MessageQ.Com webhelyet. (http://www.messageq.com)

Megjegyzés

  • A webcímek megváltozhatnak, így elképzelhető, hogy nem tud a fent említett webhelyekre csatlakozni.

Internetes hírcsoportok

Feliratkozhat az alábbi hírcsoportokra is - ehhez kövesse a webböngésző vagy hírcsoportolvasó programjának az internetes hírkiszolgálókhoz történő kapcsolódásra vonatkozó utasításait.

  • microsoft.public.msmq.deployment
  • microsoft.public.msmq.interop
  • microsoft.public.msmq.networking
  • microsoft.public.msmq.performance
  • microsoft.public.msmq.programming
  • microsoft.public.msmq.security
  • microsoft.public.msmq.setup

Könyvek

Ha a Message Queuing alapú alkalmazásfejlesztéssel kapcsolatos könyvek érdeklik, tanulmányozza az alábbi listát:

  • Dickman, Alan. Designing Applications With MSMQ: Message Queuing for Developers. Addison-Wesley Publishing Co., 1998.
  • Homer, Alex, and David Sussman. Professional MTS and MSMQ Programming with VB and ASP. Wrox Press Inc., 1998.
  • Sessions, Roger. 11. fejezet a következő könyvben: COM and DCOM: Microsoft's Vision for Distributed Objects. John Wiley & Sons, 1998.


Hibaelhárítás

Ez a rész a Message Queuing telepítésekor, frissítésekor vagy felügyeletekor felmerülő problémák megoldásához követendő főbb irányelveket ismerteti.

  • A Message Queuing telepítésekor felmerülő problémák elh A Message Queuing telepítési problémái - hibaelhárításárítása
  • A Message Queuing frissítési problémái - hibaelhárítás
  • A Message Queuing adminisztrálási problémái - hibaelhárítás


A Message Queuing telepítési problémái - hibaelhárítás

Ebben a fejezetben az új Message Queuing szoftver telepítésével és a Message Queuing telepítő futtatásával kapcsolatos problémákhoz található segítség.

Ha telepítési problémákba ütközik, először mindig vizsgálja meg a naplófájlokat. Ez különösen fontos felügyelet nélküli telepítés esetén, mivel ebben az esetben nem lehet tudni, hogy mi okozta a hibát. A Message Queuing telepítési naplófájlja, az Msmqinst.log fájl a Windows mappában található (általában C:\Winnt). Ha ebben nem találja meg a hiba okát, vizsgálja meg a Windows 2000 telepítési naplófájlját (Setuperr.log), amely a rendszermappában található (általában C:\Winnt\System32).

Mi a probléma?

A Windows 2000 telepítése befejeződött, de a Message Queuing szolgáltatás nem található

Ok: Alapértelmezés szerint a Message Queuing szolgáltatás nem kerül telepítésre a Windows 2000 telepítése során.

Megoldás: A Windows 2000 telepítése után telepítse a Message Queuing szolgáltatást a Vezérlőpult Programok telepítése/törlése segédprogram segítségével.

Lásd még: Message Queuing - a telepítés áttekintése

A Message Queuing szolgáltatást nem lehet telepíteni, vagy “A hozzáférés megtagadva” hibaüzenet jelenik meg

Ok: A Message Queuing ügyfelek telepítéséhez arra a számítógépre, amelyre telepíteni szeretne, helyi rendszergazda jogokkal kell bejelentkezni. A Message Queuing kiszolgálók Windows 2000 tartományvezérlőkre történő telepítéséhez tartománygazdai jogokkal kell rendelkezni. Ha nem tartományvezérlő számítógépre kíván Message Queuing kiszolgálót telepíteni útválasztással, vállalati rendszergazdai jogokkal kell rendelkeznie.

Megoldás: Ellenőrizze, hogy megfelelő engedélyekkel jelentkezett-e be arra a számítógépre, amelyre a Message Queuing szolgáltatást telepíteni szeretné.

Megoldás: Várja meg, amíg az Active Directory replikálása befejeződik, majd próbálja újra.

Lásd még: Telepítési engedélyek

A Message Queuing telepítése közben meg kell adni egy kiszolgáló nevét

Ok: A telepítő nem találta meg automatikusan a Message Queuing szolgáltatást futtató Windows 2000 tartományvezérlőt. A Message Queuing szolgáltatást először egy Windows 2000 tartományvezérlőre kell telepíteni.

Megoldás: Tegye a következőket:

  1. Ellenőrizze a tartományvezérlőnek és annak a számítógépnek a hálózati kapcsolatát, amelyre a Message Queuing szolgáltatást telepíti.
  2. Ellenőrizze, hogy a Message Queuing szolgáltatás fut-e a tartományvezérlőn.
  3. Adja meg a Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló DNS-nevét vagy NetBIOS-nevét. Ha nem létezik ilyen tartományvezérlő, akkor az MSMQ 1.0 vezérlőkiszolgáló nevét adja meg.

Lásd még: Message Queuing - a telepítés áttekintése

A Message Queuing eltávolítása során az “MSMQ alkalmazás fut” hibaüzenet jelenik meg

Ok: Egy Message Queuing alkalmazás, vagy az MSMQ-Exchange összekötő jelenleg fut.

Megoldás: Zárja be az összes Message Queuing alkalmazást, és állítsa le az MSMQ-Exchange összekötő szolgáltatást.

Lásd még: A Message Queuing szolgáltatásainak elindítása és leállítása


A Message Queuing frissítési problémái - hibaelhárítás

Ebben a fejezetben az MSMQ 1.0 vezérlőkiszolgálók frissítésével és a Message Queuing frissítése varázsló futtatásával kapcsolatos problémákhoz található segítség.

Ha telepítési problémákba ütközik, először mindig vizsgálja meg a naplófájlokat. Ez különösen fontos felügyelet nélküli telepítés esetén, mivel ebben az esetben nem lehet tudni, hogy mi okozta a hibát. A Message Queuing telepítési naplófájlja, az Msmqinst.log fájl a Windows mappában található (általában C:\Winnt). Ha ebben nem találja meg a hiba okát, vizsgálja meg a Windows 2000 telepítési naplófájlját (Setuperr.log), amely a rendszermappában található (általában C:\Winnt\System32).

Mi a probléma?

A Message Queuing frissítése varázsló nem futtatható

Ok: A varázsló futtatáshoz vállalati rendszergazda jogosultsággal kell rendelkezni, vagy a Vállalati rendszergazdák csoport tagjának kell lenni.

Megoldás: Vegye fel magát a Vállalati rendszergazdák csoportba.

Ok: Azon a helyen, ahol a varázslót futtatja, nincs globáliskatalógus-kiszolgáló.

Megoldás: Konfigurálja a hely egyik Windows 2000 rendszert futtató tartományvezérlőjét globáliskatalógus-kiszolgálónak. Ezen kívül minden tartományban, amelyben a Message Queuing frissítése varázslót futtatja, legalább egy bekapcsolt Windows NT 4.0 rendszert futtató tartományvezérlőnek kell lennie.

Ok: A Microsoft SQL Server nem fut a számítógépen.

Megoldás: Indítsa el az SQL Server szolgáltatásait.

Ok: A Message Queuing szolgáltatás fut, miközben egy számítógépen a varázslót másodszorra próbálja futtatni (például ha a varázsló hibákat vagy ellentmondásokat talált az MQIS adatbázisban).

Megoldás: Állítsa le a Message Queuing szolgáltatást, majd futtassa újra a Message Queuing varázslót.

Lásd még: A Message Queuing frissítésének követelményei és szempontjai; MSMQ 1.0 számítógépek frissítése

A Message Queuing frissítése varázsló nem tudja sikeresen importálni az MQIS adatbázist

Ok: A varázsló hibakeresést hajt végre az MQIS adatbázison az Active Directory címtárba történő importálás előtt. Olyan hibákat vagy ellentmondásokat tartalmazhat az MQIS adatbázis, amelyeket a varázsló nem képes megoldani.

Megoldás: Tegye a következőket:

  1. Futtassa újra a varázslót, majd amikor megjelenik az üzenet, jelölje be a Csak az adatbázis és a naplóeredmények vizsgálata jelölőnégyzetet, és válassza ki a naplózás típusát.
  2. Vizsgálja meg a naplófájlt, és javítsa ki az esetleges hibákat.

Lásd még: MSMQ 1.0 számítógépek frissítése

A Message Queuing Software Development Kit nem található

Ok: A Message Queuing szolgáltatáshoz tartozó Software Development Kit (SDK) csomag már nem része a Message Queuing szolgáltatásnak.

Megoldás: Szerezze be a Microsoft Platform SDK csomagot. A Message Queuing SDK a Microsoft Platform SDK “Component Services” fejezetében található meg. A Microsoft Platform SDK csomag szabályos időközönként kerül kiadásra az MSDN-en keresztül.


A Message Queuing adminisztrálási problémái - hibaelhárítás

Ez a témakör a tulajdonságok beállításával és megtekintésével, az Active Directory objektumainak elérésével és a Message Queuing beépülő moduljainak használatával kapcsolatos problémákhoz nyújt segítséget.

Mi a probléma?

Nem találhatók a Message Queuing felügyeleti eszközei vagy parancsikonjai

Ok: A Message Queuing felügyelete az MMC konzol más beépülő moduljainak a segítségével történik.

Megoldás: Nyissa meg szükség szerint a Számítógép-kezelés, az Active Directory - felhasználók és számítógépek vagy az Active Directory - helyek és szolgáltatások beépülő modult.

Megoldás: Windows 2000 Professional rendszeren először telepíteni kell a Windows 2000 felügyeleti eszközöket. Az Active Directory - felhasználók és számítógépek és az Active Directory - helyek és szolgáltatások beépülő modul nem része a Windows 2000 Professional rendszernek. Ezek a beépülő modulok a Message Queuing kiszolgálók távoli felügyeletéhez és az Active Dirctory objektumainak Windows 2000 Professional rendszert futtató számítógépről történő eléréséhez szükségesek. Ezek a beépülő modulok más kiszolgálók felügyeletére használt beépülő modulokkal együtt a Windows 2000 felügyeleti eszközök részei, amely a Windows 2000 Server CD-lemezen található.

Lásd még: Message Queuing felügyelet - áttekintés; Kiszolgálók kezelése távolról

Az Active Directory címtárban nem találhatók Message Queuing objektumok

Ok: A beépülő modulokhoz nem a megfelelő megtekintési beállításokat választotta ki.

Megoldás: Az Active Directory - felhasználók és számítógépek beépülő modul Nézet menüjében kattintson a Felhasználók, csoportok, számítógépek mint tárolók menüpontra, majd kattintson a Speciális beállítások gombra. A Message Queuing objektumok általában a Számítógépek vagy a Tartományvezérlők objektum alatt találhatók.

Megoldás: Az Active Directory - helyek és szolgáltatások beépülő modul Nézet menüjében kattintson a Szolgáltatások megjelenítése parancsra. A Message Queuing objektumok a Kiszolgálók és a Szolgáltatások objektum alatt találhatók.

Mentheti ezeket a beállításokat, hogy ezek a nézetek alapértelmezés szerint engedélyezve legyenek, ha mindegyik beépülő modulhoz létrehoz egy egyéni MMC konzolfájlt (.msc fájlt). Ehhez kattintson a Konzol menü Mentés másként parancsára, majd adjon meg egy mappát és egy fájlnevet a beépülő modul konzolfájljának. Az Active Directory - felhasználók és számítógépek vagy az Active Directory - helyek és szolgáltatások beépülő modulok ezen fájlokkal történő következő megnyitásakor kattintson a Konzol menü Beállítások parancsára, majd törölje A konzolfájlok megnyitása mindig szerzői módban jelölőnégyzetet.

Lásd még: Active Directory - felhasználók és számítógépek beépülő modul; Active Directory - helyek és szolgáltatások beépülő modul; Message Queuing objektumok az Active Directory címtárban

Nem rendelkezik engedéllyel az Active Directoryban levő Message Queuing objektumok eléréséhez

Ok: Lehet, hogy a Message Queuing szolgáltatást módosították, hogy az más felhasználói fiók alatt fusson. A szolgáltatásnak Windows 2000 tartományvezérlőn, LocalSystem fiók alatt kell futni, hogy hozzá lehessen férni az Active Directory objektumaihoz.

Megoldás: Ellenőrizze, hogy a Message Queuing szolgáltatás a Message Queuing kiszolgáló LocalSystem fiókja alatt fut-e.

Nem jön létre a kapcsolat az Active Directory címtárral

Ok: Lehet, hogy a Message Queuing kiszolgáló, amellyel kommunikálni szeretne, nincs a hálózatra kapcsolva, vagy a Message Queuing szolgáltatást leállították.

Megoldás: Ellenőrizze, hogy a Message Queuing kiszolgáló, amellyel kommunikálni szeretne, a hálózatra van-e kapcsolva, és fut-e rajta a Message Queuing szolgáltatás.

Ok: Lehet, hogy a számítógép nincs a hálózatra kapcsolva, nem működik a hálózati csatoló, vagy a számítógéphez nincs hozzárendelve IP-cím (vagy az IP-címe 0.0.0.0).

Megoldás: Ellenőrizze, hogy a számítógép hálózatra van-e kapcsolva, megfelelően működik-e a hálózati csatoló, és a TCP/IP megfelelően van-e beállítva.

Ok: A DNS-kiszolgáló nincs a hálózatra kapcsolva, nincs helyesen beállítva vagy a Message Queuing kiszolgáló IP-címe nemrég változott, és még nincs replikálva a DNS-kiszolgálón.

Megoldás: Ellenőrizze, hogy a DNS-kiszolgáló a hálózatra van-e kapcsolva, és helyesen van-e konfigurálva.

Ok: A helyen nem található olyan Windows 2000 tartományvezérlőn futó Message Queuing kiszolgáló, amely globáliskatalógus-kiszolgálónak van konfigurálva, vagy a kiszolgáló bizonyítványa lejárt vagy nem létezik. Ez hatással van a Windows NT 4.0-t futtató MSMQ 1.0 felhasználókra, valamint minden Helyi felhasználói fiókot használó felhasználóra.

Megoldás: Ellenőrizze, hogy az a Message Queuing kiszolgáló, amellyel kommunikálni szeretne, helyesen van-e konfigurálva, és hogy rendelkezik-e érvényes kiszolgálói bizonyítvánnyal.

Ok: A Message Queuing kiszolgálón nem fut az SAP-ügynök. Az SAP-ügynök azon számítógépek támogatásához szükséges, amelyek csak az IPX protokoll segítségével kommunikálnak.

Megoldás: Minden IPX protokollt használó Message Queuing számítógépen telepítse és futtassa az SAP-ügynököt.

Ok: Lehet, hogy nem rendelkezik megfelelő engedélyekkel az Active Directory címtárhoz történő hozzáféréshez.

Megoldás: Állítsa be a művelet végrehajtásához szükséges engedélyeket.

Az elvégzett módosítások nem jelennek meg az Active Directory címtárban

Ok: A replikáció késleltetheti a beépülő modulban megjelenő információk frissítését, így a beépülő modulok segítségével elvégzett módosítások nem jelennek meg, amíg a replikáció meg nem történik.

Megoldás: A módosítások végrehajtása után nyomja meg az F5 billentyűt, vagy várjon néhány percet.

A Windows NT 4.0 ügyfelek és a helyi felhasználók nem tudják elérni az Active Directory címtárat

Ok: A vállalat első Message Queuing kiszolgálójának telepítése során nem állította be a biztonsági engedélyek gyengítését. A Windows NT 4.0 alatt futó MSMQ 1.0 ügyfelek és a Helyi felhasználói fiókot használó ügyfelek hatékony támogatásához az Active Directory biztonságát gyengíteni kell.

Megoldás: A biztonság gyengítéséhez használja a Windows 2000 Resource Kit csomagban található ADSI Editor programot.

Lásd még: A gyengített biztonsággal kapcsolatos megfontolások

Nem rendelkezik engedéllyel egy adott várólista tartalmához történő hozzáféréshez

Ok: Lehet, hogy nem rendelkezik a megfelelő engedélyekkel a várólista megtekintéséhez. A Message Queuing alapértelmezés szerint az összes megtekinthető várólistát megjeleníti. Azonban csak azoknak a várólistáknak a tartalmát tekintheti meg, amelyeknek megnyitásához engedéllyel rendelkezik. Ezért lehetnek olyan nyilvános várólisták, amelyek tartalma nem jelenik meg a beépülő modulokban.

Megoldás: Adjon magának a várólistához Üzenetek megtekintése és Olvasás engedélyeket. A naplóvárólisták tartalmának megtekintéséhez a várólistához Napló megtekintése engedéllyel kell rendelkeznie.

Lásd még: Várólisták megtekintése

Nincs engedélye várólisták létrehozására

Ok: Lehet, hogy nem rendelkezik megfelelő engedéllyel a művelet végrehajtásához.

Megoldás: Állítsa be a művelet végrehajtásához szükséges engedélyeket.

Lásd még: Az msmq objektumok engedélyeinek beállítása

Nem lehet üzeneteket küldeni másik helyre

Ok: Lehet, hogy a két hely között nincs meghatározva útválasztási kapcsolat, vagy egy helykapu nem elérhető.

Megoldás: Hozzon létre egy útválasztási kapcsolatot a két hely között, és határozzon meg helykapukat az útválasztási kapcsolat számára. Ajánlott a redundancia érdekében minden hely között több útválasztási kapcsolatot létrehozni.

Lásd még: Útválasztási kapcsolatok konfigurálása

Nem lehet hitelesített üzeneteket küldeni vagy fogadni

Ok: Lehet, hogy a számítógép felhasználói bizonyítványa el lett távolítva, lejárt vagy nincs regisztrálva az Active Directory címtárban. A felhasználói bizonyítvány a hitelesített üzenetek küldéséhez szükséges. A felhasználói bizonyítvány a Message Queuing telepítése során kerül telepítésre, és az első bejelentkezés alkalmával kerül regisztrálásra az Active Directory címtárban.

Megoldás: Használja a Vezérlőpult Message Queuing segédprogramját a bizonyítvány megújításához, majd regisztrálja azt.

Ok: A Windows 2000 által biztosított Microsoft Base titkosításszolgáltatót (CSP) nem használják a Message Queuing alkalmazások. A Microsoft Base CSP szükséges minden olyan Message Queuing alkalmazás számára, amely titkosított üzeneteket küld vagy fogad.

Megoldás: Ellenőrizze, hogy a Message Queuing alkalmazások használják-e a Microsoft Base (vagy Enhanced) CSP-t az üzenetek küldéséhez vagy fogadásához.

Lásd még: Felhasználói bizonyítványok, A Message Queuing hitelesítése

Egy várólistára küldött üzenetek visszautasításra kerülnek

Ok: Lehet, hogy a várólistához történő hozzáférés korlátozva van.

Megoldás: Ellenőrizze, hogy az üzenetet küldő számítógép ugyanabban a tartományban található-e, mint a várólista, vagy egy meghatalmazott tartományban.

Lásd még: A várólista objektumok engedélyeinek beállítása

Nem lehet egy várólistában lévő üzeneteket elolvasni

Ok: A várólistában lévő üzenetek elolvasásához a várólistához Üzenetek fogadása engedéllyel kell rendelkezni. Nem elegendő a várólistához Olvasás engedéllyel rendelkezni.

Megoldás: Adjon magának a várólistához Üzenetek fogadása engedélyt.

Lásd még: Üzenetek olvasása

Egy adott várólistára vagy számítógépre nem lehet többé üzeneteket küldeni

Ok: Lehet, hogy túllépte az adott számítógép várólista- vagy számítógépkvótáját.

Megoldás: Dolgozza fel a megfelelő várólistában lévő üzeneteket, és távolítsa el őket, vagy növelje meg a megfelelő kvóta értékét.

Lásd még: Üzenetek számítógépkvótájának beállítása; Üzenetek várólistakvótájának beállítása

A sürgős üzenetek hiányoznak vagy elvesztek

Ok: A sürgős üzenetek elvesznek, valahányszor a Message Queuing szolgáltatást megállítják egy számítógépen.

Megoldás: Használja az üzenetek mentése/visszaállítása segédprogramot az üzenetek visszaállításához.

Lásd még: Üzenetek biztonsági mentése és visszaállítása

A tranzakció alapú üzenetküldés nem működik függő ügyfelek esetén

Ok: Lehet, hogy a Windows NT 4.0 rendszert futtató MSMQ 1.0 függő ügyfeleken, amelyek támogató kiszolgálóján Windows 2000 rendszer fut, nincs telepítve a Windows NT Service Pack 4 (SP4) szervizcsomag. A tranzakció alapú üzenetküldéshez legalább SP4 szükséges.

Megoldás: Telepítse a Windows NT SP4 szervizcsomagot (vagy újabbat) a megfelelő függő ügyfelekre.

Ok: Lehet, hogy az elosztott tranzakciók koordinátora (DTC) szolgáltatás nem fut. A DTC szolgáltatás szükséges a külső tranzakciókhoz.

Megoldás: Indítsa el a DTC szolgáltatást.

Nem lehet tesztüzenetet küldeni egy várólistára

Ok: Tesztüzeneteket csak tesztvárólistákra lehet küldeni, amelyek típusazonosítója {55EE8F33-CCE9-11CF-B108-0020AFD61CE9}.

Megoldás: Ellenőrizze, hogy az a várólista, amelyre tesztüzenetet szeretne küldeni, megfelelő várólista-típusazonosítóval rendelkezik-e. Tranzakciós várólistákat és hitelesítést igénylő várólistákat ne változtasson tesztvárólistára, mivel az ilyen várólistákra küldött üzenetek nem lesznek kézbesítve.

Lásd még: Tesztüzenet küldése egy várólistába

A helyi lemezen tárolt üzenetfájlok nem érhetők el

Ok: Alapértelmezés szerint csak a helyi számítógép Rendszergazdák csoportjának tagjai rendelkeznek teljes hozzáféréssel az összes helyileg tárolt üzenetfájlhoz, naplófájlhoz és LQS (helyi várólista-tároló) fájlhoz.

Megoldás: Adjon magának a számítógépen rendszergazdai jogokat, vagy vegye fel magát a helyi Rendszergazdák csoportba.

Lásd még: Az üzenetfájlok engedélyeinek beállítása

Egy művelethez tartozó naplóüzenetek nem találhatók

Ok: A naplóüzenetek a műveletet végrehajtó Message Queuing kiszolgáló Windows 2000 Biztonsági naplójába kerülnek, amely különbözhet az objektumot tulajdonló kiszolgálótól. Emellett naplóüzenetek csak egy várólista megnyitása során íródnak a Windows 2000 biztonsági naplóba, és nem minden alkalommal, amikor üzenetküldés vagy -fogadás történik.

Megoldás: Használja az Eseményfigyelőt a megfelelő számítógép Biztonsági naplójának megtekintéséhez.

Lásd még: A Message Queuing naplózása

Problémák vannak az IPX protokollt használó számítógépekkel történő kommunikáció során

Ok: A Message Queuing szolgáltatáshoz IPX-hálózatokon névhozzárendelésre van szükség.

Megoldás: A névhozzárendelés biztosításához indítsa el az SAP (Service Advertising Protocol) ügyfelet minden IPX protokollt használó Message Queuing számítógépen.

Lásd még: IPX/SPX-tulajdonságok beállítása.

Az MSMQ 1.0 ügyfelek nem tudnak hitelesíteni egy Message Queuing kiszolgálót

Ok: Vegyes módú működés esetén az MSMQ 1.0 ügyfelek (Windows NT 4.0, Windows 95 vagy Windows 98 alatt) kiszolgálói bizonyítványokat használnak a Message Queuing kiszolgálók hitelesítésére. Lehet, hogy a hiányzik a kiszolgáló bizonyítványa, vagy nincs regisztrálva az Active Directory címtárban.

Megoldás: Minden olyan Message Queuing kiszolgálóhoz hozzon létre és regisztráljon egy kiszolgálói bizonyítványt, amely MSMQ 1.0 ügyfelektől érkező lekérdezésekre válaszol.

Lásd még: Kiszolgálóhitelesítés.

Függő ügyfeleken nem lehet Message Queuing alkalmazásokat futtatni

Ok: Lehet, hogy Helyi felhasználói fiókkal vagy más, nem hitelesített fiókkal jelentkezett be. A Message Queuing alkalmazások nem futhatnak nem hitelesített fiókok alatt.

Megoldás: Jelentkezzen be olyan tartományfelhasználói fiókkal, amely hitelesítve van.

Kevés erőforrásra figyelmeztető üzenet jelenik meg több olyan alkalmazás futtatásakor, amelyek távoli várólistákból olvasnak üzeneteket

Ok: Amikor egy Message Queuing alkalmazás üzenetet olvas egy várólistából, egy szál jön létre a helyi számítógépen (azon a számítógépen, amelyen az alkalmazás fut). Message Queuing kiszolgálón alapértelmezés szerint 64 szál, független ügyfélen pedig alapértelmezés szerint 16 szál jöhet létre ebből a célból.

Megoldás: A Rendszerleíróadatbázis-szerkesztő segítségével növelje meg szükség szerint a MaxRRThreads bejegyzés értékét. Ez a bejegyzés nem jelenik meg a rendszerleíró adatbázisban, amíg azt hozzá nem adja a Rendszerleíróadatbázis-szerkesztő segítségével. Az érték növeléséhez tegye a következőket:

  1. A Rendszerleíróadatbázis-szerkesztő megnyitásához kattintson a Start gombra, kattintson a Futtatás parancsra, majd írja be a regedt32 parancsot.
  2. Kattintson a rendszerleíró-adatbázis Parameters alkulcsára.

    Helye:

    • HKEY_LOCAL_MACHINE
    • Software
    • Microsoft
    • MSMQ
    • Parameters
  3. Kattintson a Szerkesztés menü Érték hozzáadása parancsára.
  4. Az Érték hozzáadása párbeszédpanelen az Érték neve mezőbe írja be a MaxRRThreads értéket, az Adattípus mezőben kattintson a lefele nyílra, válassza ki a REG_DWORD értéket, majd kattintson az OK gombra.
  5. A Kétszószerkesztő párbeszédpanel Adat mezőjébe írja be az új (decimális) értéket, az Alap mezőben kattintson a Decimális értékre, majd kattintson az OK gombra.

Vigyázat!

  • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen lévő minden fontos adatról készítsen biztonsági másolatot.

Megjegyzés

  • Ezek a szálak szükség szerint jönnek létre, és addig léteznek, amíg a Message Queuing szolgáltatás fut a helyi számítógépen.

A Message Queuing erőforrásokon időtúllépés történik egy kiszolgálófürtön

Ok: A fürterőforrások alapértelmezett időtúllépése három perc. A Message Queuing három percnél több időt igényelhet, a visszaállítási helyzetek és a tárolt üzenetek mennyiségének függvényében.

Megoldás: Növelje a Message Queuing erőforrások alapértelmezett időtúllépési beállítását.


Várólisták és üzenetek kezelése az Active Directory - felhasználók és számítógépek beépülő modul segítségével

  3. A konzolfán kattintson a jobb oldali egérgombbal egy várólistára vagy egy üzenetre.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • tartomány
    • szervezeti_egység (például számítógép vagy tartományvezérlő)
    • számítógép
    • várólista_mappája_vagy_várólista
    • várólista_vagy_üzenet
  4. Hajtsa végre a kívánt műveletet. Útmutatásként használja a megfelelő számítógép-kezelési eljárást.

Megjegyzések

  • Ez az eljárás csak akkor használható, ha a helyi számítógép egy Windows 2000 rendszert futtató tartomány része.
  • Az Active Directory - felhasználók és számítógépek beépülő modul nem része a Windows 2000 Professional operációs rendszernek; következésképpen ez a művelet nem hajtható végre, ha ez a beépülő modul nincs telepítve. Az Active Directory - felhasználók és számítógépek beépülő modul a Windows 2000 felügyeleti eszközök segítségével telepíthető Windows 2000 Professional operációs rendszert futtató számítógépekre. A Windows 2000 felügyeleti eszközök használatával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
Kapcsolódó témakörök