(Untitled)

Szolgáltató lap

A Szolgáltató lap segítségével választható ki a megfelelő OLE DB szolgáltató az elérni kívánt adatok típusához. Nem minden alkalmazás teszi lehetővé a szolgáltató megadását vagy a beállítás módosítását; ez a lap csak akkor jelenik meg, ha az alkalmazás lehetővé teszi az OLE DB szolgáltató megváltoztatását. Az alkalmazástól függően az adatkapcsolatok az alkalmazással együtt vagy külön fájlként is menthetők. Az adatkapcsolatok létrehozásáról bővebb információért lásd: MDAC SDK, „Creating a Data Link” (Adatkapcsolatok létrehozása) című anyag.

Beállítás | Leírás
OLE DB szolgáltató(k) | Felsorolja a számítógépen észlelt összes OLE DB szolgáltatót. A szolgáltatókra vonatkozó részletesebb információkat az MDAC SDK-ban található „Microsoft OLE DB Providers Overview” (Microsoft OLE DB szolgáltatók áttekintése) című anyagban talál.
Következő | Megnyitja a választott OLE DB szolgáltató Kapcsolat lapját.

Megjegyzés Közvetlenül a Kapcsolat lapra térhet, ha duplán a megfelelő szolgáltatóra kattint. Az adatkapcsolatokra vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Speciális lap

A Speciális lapon tekintheti meg és állíthatja be az adatokkal kapcsolatos egyéb inicializálási beállításokat.

Az Adatkapcsolat tulajdonságai párbeszédpanel Speciális lapja a szolgáltatótól függ, és csak a választott OLE DB szolgáltató esetén szükséges kapcsolattulajdonságokat jeleníti meg. Amennyiben többet szeretne megtudni a speciális inicializálási beállítási lehetőségekről, olvassa el az OLE DB szolgáltató dokumentációját.

Az alábbi táblázat ismerteti az inicializálás fontosabb beállítási lehetőségeit.

Beállítás | Leírás
Megszemélyesítési szint Az ügyfél a kiszolgáló által történő megszemélyesítésnek megengedett szintje. Ez a beállítási lehetőség csak a nem Remote Procedure Call (RPC) hálózati kapcsolatokra érvényes; ezek e megszemélyesítési szintek hasonlóak az RPC-k által használt szintekhez. A beállítás értékei közvetlenül megfelelnek a hitelesített RPC-kapcsolatokhoz megadható megszemélyesítési szinteknek, de csak az azoktól eltérő kapcsolatok esetében alkalmazhatók. Az alábbi szintek közül választhat:
  • Anonymous — Az ügyfél a kiszolgáló előtt névtelen. A kiszolgálófolyamat nem kaphat azonosítási adatokat az ügyfélről, és nem személyesítheti meg az ügyfelet.

  • Delegate – A folyamat megszemélyesítheti az ügyfél adatvédelmi környezetét, miközben az ügyfél nevében cselekszik. A kiszolgálófolyamat kimenő hívásokat is végezhet más kiszolgálók felé az ügyfél nevében.

  • Identify – A kiszolgáló megkaphatja az ügyfél azonosítási adatait. A kiszolgáló megszemélyesítheti az ügyfelet a Hozzáférés-vezérlési lista (ACL) ellenőrzéséhez, de nem érhet el rendszerobjektumokat az ügyfélként.

  • Impersonate – A kiszolgálófolyamat megszemélyesítheti az ügyfél adatvédelmi környezetét, miközben az ügyfél nevében cselekszik. Az adatokat a rendszer a kapcsolat létrehozásakor olvassa ki, nem pedig minden hívás esetén.
Védelmi szint Az ügyfél és a kiszolgáló között továbbított adatok adatvédelmi szintje. Ez a tulajdonság csak a nem RPC hálózati kapcsolatokra vonatkozik; a védelmi szintek hasonlóak az RPC által nyújtottakhoz. A tulajdonság értékei közvetlenül a hitelesített RPC kapcsolatok esetén megadható védelmi szintekhez tartoznak, de a hitelesített RPC típusútól eltérő kapcsolatok esetén alkalmazhatók. Az alábbi szintek közül választhat:
  • Call – Minden kérelem elején hitelesíti az adatok forrását, mely az ügyféltől a kiszolgáló felé érkezik.

  • Connect – Csak akkor végez hitelesítést, amikor az ügyfél kapcsolatot létesít a kiszolgálóval.

  • None – Nem végzi el a kiszolgálóra küldött adatok hitelesítését.

  • Pkt – Hitelesíti, hogy minden beérkezett adat az ügyféltől származik.

  • Pkt Integrity – Hitelesíti, hogy minden beérkezett adat az ügyféltől származik, és az átvitel során az adatok nem változtak meg.

  • Pkt Privacy – Hitelesíti, hogy minden beérkezett adat az ügyféltől származik, az átvitel során az adatok nem változtak meg, valamint titkosítással védi az adatok biztonságát.
Kapcsolat időtúllépése | Azt az időmennyiséget adja meg másodpercben, amennyit az OLE DB szolgáltató az inicializálás befejezésére vár. Ha az inicializálási művelet túllépi a megszabott időt, a program hibaüzenetet küld vissza, és a kapcsolat nem jön létre.
Hozzáférési engedélyek Az alábbi engedélyek közül választhat egyet vagy többet:
  • Read – Csak olvasható.

  • ReadWrite – Olvasható és írható.

  • Share Deny None – Az olvasási és írási hozzáférés nem tagadható meg másoktól.

  • Share Deny Read – Mások nem férhetnek az adatokhoz olvasási módban.

  • Share Deny Write – Mások nem férhetnek az adatokhoz írási módban.

  • Share Exclusive – Mások nem férhetnek az adatokhoz írási és olvasási módban.

  • Write – Csak írható.

Megjegyzés Az adatkapcsolatok inicializálására vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Mind lap

A Mind lap használatával az OLE DB szolgáltatóra vonatkozó OLE DB inicializációs beállítások tekinthetők meg és szerkeszthetők. A beállítási lehetőségek különbözőek lehetnek attól függően, hogy milyen OLE DB szolgáltatót használ. Amennyiben többet szeretne megtudni az inicializálás beállítási lehetőségeiről, olvassa el az OLE DB szolgáltató dokumentációját.

Beállítás | Leírás
Inicializálási tulajdonságok listája | Az egyes tulajdonságok és aktuális értékeik felsorolása.
Érték szerkesztése | Megnyitja a kijelölt tulajdonsághoz tartozó Tulajdonságérték szerkesztése párbeszédpanelt.

Megjegyzés A Tulajdonságérték szerkesztése párbeszédpanelt a kívánt tulajdonságra történő dupla kattintással nyithatja meg. Az adatkapcsolatok inicializálására vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Kapcsolat lap

A Kapcsolat lapon adhatja meg, hogy az OLE DB használatával hogyan kíván kapcsolódni az adatokhoz.

Az Adatkapcsolat tulajdonságai párbeszédpanel Kapcsolat lapja a szolgáltatótól függ, és csak a választott OLE DB szolgáltató számára szükséges kapcsolattulajdonságokat jeleníti meg. Az adatkapcsolat tulajdonságainak beállításánál megadhatja adatai helyét és a hozzájuk történő kapcsolódás módját. Amennyiben többet szeretne megtudni, olvassa el az OLE DB szolgáltató dokumentációját.

Az alábbi táblázat ismerteti a kapcsolat fontosabb beállítási lehetőségeit.

Beállítás | Leírás
Adatforrás | Írja be az elérni kívánt adatforrás nevét – ez rendszerint egy kiszolgálónév.
Hely | Írja be az elérni kívánt adatforrás helyét – ez rendszerint egy adatbázisnév.
A Windows NT integrált adatvédelem használata | Amennyiben önmaga azonosításához hitelesítési szolgáltatást szeretne igénybe venni, kattintson ide. E lehetőség használatához az OLE DB szolgáltatónak támogatnia kell valamelyik hitelesítési szolgáltatást. Erre az SQL Server OLE DB szolgáltatója az egyik példa. A hitelesítési szolgáltatás használatához az adatforrásban is engedélyekkel kell rendelkeznie.
Meghatározott felhasználónév és jelszó használata | Ha az adatforrásba történő bejelentkezésének adatait megadott felhasználónév és jelszó használatával kívánja hitelesíteni, kattintson ide.
Felhasználónév | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt felhasználónevet.
Jelszó | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt jelszót.
Üres jelszó | Lehetővé teszi, hogy a megadott szolgáltató üres jelszót adjon vissza a kapcsolódási karakterláncban.
Jelszó mentésének engedélyezése | Engedélyezi a jelszó mentését a kapcsolódási karakterlánccal. A hívó alkalmazás működésétől függ, hogy a jelszó szerepel-e a kapcsolódási karakterláncban. Megjegyzés A jelszó mentése esetén a program a jelszót maszkolás és titkosítás nélkül adja vissza.
Adja meg a kezdeti katalógust | Adja meg a kapcsolódáskor elérni kívánt adatbázist.
Kapcsolat vizsgálata | A gombra kattintva megpróbálhat kapcsolódni a megadott adatforráshoz. Ha a kapcsolódás sikertelen, ellenőrizze a beállítások helyességét. A sikertelen kapcsolódás oka lehet például gépelési hiba, illetve a kis- és nagybetűk nem megfelelő használata.

Megjegyzés Az adatkapcsolatokra vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Kapcsolat lap: Jet

A Kapcsolat lapon adhatja meg, hogy milyen módon kíván csatlakozni a Microsoft Access adatokhoz.

Ez a Kapcsolat lap a szolgáltatótól függ, és csak a Microsoft Jet OLE DB szolgáltatója számára szükséges csatlakozási tulajdonságokat jeleníti meg.

Beállítás | Leírás
Adatbázis neve | Írja be az elérni kívánt Microsoft Access adatbázis (.mdb) nevét. Ha tallózással kívánja megkeresni a fájlt, kattintson a gombra.
Felhasználónév | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt felhasználónevet.
Jelszó | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt jelszót.
Üres jelszó | Lehetővé teszi, hogy a megadott szolgáltató üres jelszót adjon vissza a kapcsolódási karakterláncban.
Jelszó mentésének engedélyezése | Engedélyezi a jelszó mentését a kapcsolódási karakterlánccal. A hívó alkalmazás működésétől függ, hogy a jelszó szerepel-e a kapcsolódási karakterláncban. Megjegyzés A jelszó mentése esetén a program a jelszót maszkolás és titkosítás nélkül adja vissza.
Kapcsolat vizsgálata | A gombra kattintva megpróbálhat kapcsolódni a megadott adatforráshoz. Ha a kapcsolódás sikertelen, ellenőrizze a beállítások helyességét. A sikertelen kapcsolódás oka lehet például gépelési hiba, illetve a kis- és nagybetűk nem megfelelő használata.

Megjegyzés Az adatkapcsolatokra vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Kapcsolat lap: ODBC

A Kapcsolat lapon adhatja meg, hogy milyen módon kíván csatlakozni az ODBC adatokhoz.

Ez a Kapcsolat lap a szolgáltatótól függ, és csak az ODBC Microsoft OLE DB szolgáltatója számára szükséges csatlakozási tulajdonságokat jeleníti meg.

Beállítás | Leírás
Adatforrásnév használata | Válasszon a listából, vagy írja be az elérni kívánt ODBC adatforrásnevet (DSN). Az ODBC adatforrás-felügyelő segítségével további forrásokat is megadhat. A Frissítés parancsra kattintva frissítse a listát.
Kapcsolódási karakterlánc használata | Lehetővé teszi ODBC kapcsolódási karakterlánc beírását vagy összeállítását meglévő DSN használata helyett.
Felépítés Megnyitja az Adatforrás párbeszédpanelt. Az adatforrás kiválasztása után az adatforrásban lévő kapcsolódási karakterlánc megjelenik a Adatkapcsolat tulajdonságai párbeszédpanel Kapcsolat lapján.

A Fájl-DSN lehetőség választása esetén az eredményül kapott ODBC kapcsolódási karakterlánc nem DSN-alapú. Az ODBC kapcsolódási karakterlánc tárolása az adatkapcsolati fájlban (.udl) történik, és nem függ a választott fájladatforrástól.

Gépi adatforrás választása esetén az eredményül kapott ODBC kapcsolódási karakterlánc DSN-alapú. Az ODBC kapcsolódási karakterlánc a választott gépi adatforrásra hivatkozik. Ha egy másik rendszer felhasználója megkísérli az adatkapcsolati fájl (.udl) elérését, akkor ehhez a telepített gépi adatforrással is rendelkeznie kell.
Felhasználónév | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt felhasználónevet.
Jelszó | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt jelszót.
Üres jelszó | Lehetővé teszi, hogy a megadott s zolgáltató üres jelszót adjon vissza a kapcsolódási karakterláncban.
Jelszó mentésének engedélyezése Engedélyezi a jelszó mentését a kapcsolódási karakterlánccal. A hívó alkalmazás működésétől függ, hogy a jelszó szerepel-e a kapcsolódási karakterláncban.

Megjegyzés A jelszó mentése esetén a program a jelszót maszkolás és titkosítás nélkül adja vissza.
Adja meg a kezdeti katalógust | Írja be a katalógus (vagy adatbázis) nevét, vagy válassza ki azt a legördülő listából.
Kapcsolat vizsgálata | A gombra kattintva megpróbálhat kapcsolódni a megadott adatforráshoz. Ha a kapcsolódás sikertelen, ellenőrizze a beállítások helyességét. A sikertelen kapcsolódás oka lehet például gépelési hiba, illetve a kis- és nagybetűk nem megfelelő használata.

Megjegyzés Az adatkapcsolatokra vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Kapcsolat lap: Oracle

A Kapcsolat lapon adhatja meg, hogy milyen módon kíván csatlakozni az Oracle adatokhoz.

Ez a Kapcsolat lap a szolgáltatótól függ, és csak az Oracle Microsoft OLE DB szolgáltatója számára szükséges csatlakozási tulajdonságokat jeleníti meg.

Beállítás | Leírás
Kiszolgálónév | Adja meg annak a kiszolgálónak a nevét, amelyen az elérni kívánt adatbázis található.
Felhasználónév | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt felhasználónevet.
Jelszó | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt jelszót.
Üres jelszó | Lehetővé teszi, hogy a megadott szolgáltató üres jelszót adjon vissza a kapcsolódási karakterláncban.
Jelszó mentésének engedélyezése | Engedélyezi a jelszó mentését a kapcsolódási karakterlánccal. A hívó alkalmazás működésétől függ, hogy a jelszó szerepel-e a kapcsolódási karakterláncban. Megjegyzés A jelszó mentése esetén a program a jelszót maszkolás és titkosítás nélkül adja vissza.
Kapcsolat vizsgálata | A gombra kattintva megpróbálhat kapcsolódni a megadott adatforráshoz. Ha a kapcsolódás sikertelen, ellenőrizze a beállítások helyességét. A sikertelen kapcsolódás oka lehet például gépelési hiba, illetve a kis- és nagybetűk nem megfelelő használata.

Megjegyzés Az adatkapcsolatokra vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


Kapcsolat lap: SQL Server

A Kapcsolat lapon adhatja meg, hogy milyen módon kíván kapcsolódni a Microsoft SQL Serveren lévő adatokhoz.

Ez a Kapcsolat lap a szolgáltatótól függ, és csak a Microsoft SQL Server OLE DB szolgáltatójához szükséges csatlakozási tulajdonságokat jeleníti meg.

Beállítás | Leírás
Kiszolgálónév | A legördülő listából válassza ki a kiszolgáló nevét, vagy írja be az elérni kívánt adatbázist tartalmazó kiszolgáló helyét. A kiszolgálón lévő adatbázis kiválasztása külön feladat. A Frissítés parancsra kattintva frissítse a listát.
A Windows NT integrált adatvédelem használata | Ha meg kívánja adni, hogy a szolgáltató biztonságos (vagy megbízható) kapcsolatot kér a Microsoft Windows NT rendszeren futó SQL Servertől, kattintson ide. A beállítás alkalmazásával az SQL Server az adatforrás használatakor az integrált bejelentkezési adatvédelem használatával létesít kapcsolatot, függetlenül a kiszolgálón beállított bejelentkezési adatvédelmi módtól. A megadott felhasználónevet vagy jelszót a program nem veszi figyelembe. A Microsoft Windows hálózati felhasználónevét az SQL Server rendszergazdájának társítania kellett az SQL Server egyik bejelentkezési azonosítójával.
Meghatározott felhasználónév és jelszó használata | Ha az adatforrásba történő bejelentkezésének adatait megadott felhasználónév és jelszó használatával kívánja hitelesíteni, kattintson ide.
Felhasználónév | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt felhasználónevet.
Jelszó | Adja meg az adatforrásba való bejelentkezéskor a hitelesítéshez használt jelszót.
Üres jelszó | Lehetővé teszi, hogy a megadott szolgáltató üres jelszót adjon vissza a kapcsolódási karakterláncban.
Jelszó mentésének engedélyezése Engedélyezi a jelszó mentését a kapcsolódási karakterlánccal. A hívó alkalmazás működésétől függ, hogy a jelszó szerepel-e a kapcsolódási karakterláncban.

Megjegyzés A jelszó mentése esetén a program a jelszót maszkolás és titkosítás nélkül adja vissza.
Adatbázis választása Válassza az alábbi lehetőségek egyikét:
  • Írja be az elérni kívánt adatbázis nevét.

  • SQL Server 7.0 esetén adatbázisnévként mellékeljen egy SQL adatbázisfájlt. Írja be a mellékelt SQL adatbázisfájlhoz használandó adatbázisnevet.

  • SQL Server 6.5-ös vagy korábbi verzió esetén írja be a mellékelni kívánt adatbázisfájl nevét. Ezután írja be az egyfájlos adatbázisfájl nevét. Ha tallózással kívánja megkeresni a fájlt, kattintson a gombra.
Kapcsolat vizsgálata | A gombra kattintva megpróbálhat kapcsolódni a megadott adatforráshoz. Ha a kapcsolódás sikertelen, ellenőrizze a beállítások helyességét. A sikertelen kapcsolódás oka lehet például gépelési hiba, illetve a kis- és nagybetűk nem megfelelő használata.

Megjegyzés Az adatkapcsolatokra vonatkozó további információért lásd: Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyag.


További anyagok az adatkapcsolatok létrehozására szolgáló API-ról

Az adatkapcsolatok létrehozására szolgáló API-ról részletes ismertető az msdn.microsoft.com címen található. (Nyissa meg az MSDN Library Online lapját, majd a Platform SDK lapon keresse meg az MDAC SDK-t, mely a Data Link API Reference (További anyagok az adatkapcsolatok létrehozására szolgáló API-ról) című anyagot tartalmazza.)


Tulajdonságérték szerkesztése párbeszédpanel

A Tulajdonságérték szerkesztése párbeszédpanel segítségével lehet a Mind lapon kijelölt OLE DB inicializációs tulajdonságokat szerkeszteni. A beállítási lehetőségek aszerint változhatnak, hogy milyen OLE DB szolgáltatót használ.

Megjegyzés Az adott szolgáltatóra jellemző beállítási lehetőségekkel kapcsolatos további információ az OLE DB szolgáltató dokumentációjában található.

Beállítás | Leírás
Tulajdonság leírása | A kijelölt tulajdonság leírását jeleníti meg.
Tulajdonságérték | Adjon meg egy érvényes értéket.
Alaphelyzet | A kijelölt tulajdonságértéket átállítja az OLE DB szolgáltató alapértékére.