A Microsoft SMTP-szolgáltatás

A Microsoft SMTP-szolgáltatás az internetes szabványként elfogadott Simple Mail Transfer Protocol (SMTP) protokollt használja üzenetek küldéséhez és kézbesítéséhez, a Request for Comments (RFC) 821 és RFC 822 dokumentumokban megfogalmazott specifikáció szerint. A szolgáltatás a protokoll alapvető kézbesítési funkcióin túlmenően annak továbbfejlesztéseit is tartalmazza, és lehetőséget nyújt az útválasztás és az üzenetkézbesítés szabályozására, valamint biztonságos kommunikációra.

Megjegyzés
Az SMTP-szolgáltatás korábbi verzióinak felügyeletéhez ne használja a Windows 2000 operációs rendszer részét képező SMTP felügyeleti beépülő modult.

  • Az egyes feladatok végrehajtásának leírása az Útmutató című részben található.
  • Az általános tudnivalókkal az Alapfogalmak című rész foglalkozik.
  • A szolgáltatás teljesítményének figyeléséről a Karbantartás címszó alatt olvashat.
  • A felmerülő problémák megoldásához a Hibaelhárítás című részben talál segítséget.


Útmutató

Ez a rész ismerteti a Microsoft SMTP-szolgáltatás beállításának és kezelésének lépéseit.
  • A felügyeleti eszközök használata
  • A Microsoft Management Console indítása
  • Virtuális SMTP-kiszolgálók indítása, leállítása és szüneteltetése
  • A Microsoft SMTP-szolgáltatás indítása, leállítása és szüneteltetése
  • Virtuális SMTP-kiszolgálók beállítása
  • Az alapértelmezett indítási beállítások módosítása
  • További virtuális SMTP-kiszolgálók létrehozása
  • Kapcsolatok beállítása
  • Protokollnaplózás engedélyezése
  • Virtuális kiszolgáló beállítása fürtözéshez
  • Adatbiztonsági beállítások
  • Üzenetek kezelése
  • Üzenetek kézbesítése
  • Tartomány létrehozása vagy törlése
  • Helyi tartományok beállítása
  • Távoli tartományok beállítása


Adminisztrációs eszközök

A Microsoft Management Console használata

Az SMTP-szolgáltatás adminisztrációs eszközének neve Microsoft Management Console (MMC). A szolgáltatás működtetéshez szükséges összes feladatot ellátó eszköz használatához helyi hálózati (LAN) kapcsolatra van szükség.

Alapértelmezés szerint az adminisztrációs eszköz a telepítés során a Microsoft SMTP-szolgáltatást futtató számítógépre kerül fel.

Amennyiben a Microsoft Management Console-lal egy távoli számítógépről kívánja szeretné a szolgáltatás adminisztrációját végezni, mindenképpen Microsoft Windows 2000 operációs rendszert futtató számítógépre lesz szüksége, és a távoli számítógépre telepíteni kell a Windows 2000 Administration Tools eszközöket.

Megjegyzés A Microsoft SMTP-szolgáltatás működtetéséhez a felügyelőknek megfelelő engedélyeket kell adni. További információ az Adatbiztonsági beállítások megadása címszó alatt található.


A Microsoft Management Console indítása

A Microsoft SMTP-szolgáltatás a Microsoft Management Console-lal (MMC) működtethető a szolgáltatást futtató számítógépről.

Megjegyzés A virtuális SMTP-kiszolgáló a Microsoft Management Console segítségével távoli számítógépről is felügyelhető, amennyiben az a Microsoft SMTP-szolgáltatással megegyező helyi hálózaton van. Ehhez azonban a távoli számítógépnek Microsoft Windows 2000 operációs rendszer alatt kell működnie, és telepíteni kell rá a Windows 2000 Felügyeleti eszközöket is.

A Microsoft Management Console futtatása a Microsoft SMTP-szolgáltatást futtató számítógépen

  1. Mutasson a Start menü Beállítások elemére, majd kattintson a Vezérlőpult menüpontra.
  2. Kattintson duplán a Felügyeleti eszközök parancsra, majd kattintson duplán a Számítógép-kezelés elemre.
  3. Az MMC ablakában bontsa ki a Szolgáltatások és alkalmazások, majd az Internet Information Services csomópontot.

Megjegyzés A szolgáltatás telepítésekor létrehozott virtuális kiszolgáló az Alapértelmezett virtuális SMTP-kiszolgáló.

Virtuális SMTP-kiszolgáló tulajdonságainak megtekintése vagy módosítása

  1. Kattintson a módosítani kívánt virtuális SMTP-kiszolgálóra.
  2. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. Kattintson a megtekinteni vagy módosítani kívánt kartonra.
  4. Igényei szerint módosítsa a beállításokat. (A kartonon levő beállításokkal kapcsolatban a Kartonok címszó alatt található további információ.)


Virtuális SMTP-kiszolgálók indítása, leállítása és szüneteltetése

A Microsoft SMTP-szolgáltatás telepítése után az Alapértelmezett virtuális SMTP-kiszolgáló indul el. Ezt a kiszolgálót a Microsoft Management Console-ból lehet szüneteltetni, leállítani, illetve újraindítani.

Megjegyzés Hasonlóképpen történik az egész Microsoft SMTP-szolgáltatás elindítása, leállítása és szüneteltetése. Több virtuális kiszolgáló esetében azonban tudni kell, hogy a szolgáltatás leállítása a számítógépen futó összes virtuális SMTP-kiszolgáló leállását eredményezi. A Microsoft SMTP-szolgáltatás leállítása esetén a Microsoft Management Console nem használható a virtuális SMTP-kiszolgálók adminisztrációjához.

A Microsoft SMTP-szolgáltatás leállítása és indítása kézzel is történhet. Amíg működik, mindenképpen nagyon körültekintően kell eljárni a szolgáltatás leállítását, szüneteltetését vagy újraindítását illetően, hogy az minél kevésbé befolyásolja a felhasználókat.

Ebből a részből megtudhatja, hogyan lehet a Microsoft Managament Console segítségével elindítani, leállítani és szüneteltetni a Microsoft SMTP-szolgáltatást. A következő témaköröket tartalmazza:

  • Virtuális SMTP-kiszolgáló elindítása
  • Virtuális SMTP-kiszolgáló leállítása
  • Virtuális SMTP-kiszolgáló szüneteltetése


Virtuális SMTP-kiszolgáló elindítása

Amennyiben az indításhoz Kézi beállítást ad meg alapértelmezettként, a Microsoft Management Console-lal bármelyik virtuális SMTP-kiszolgálót elindíthatja.

  1. A Microsoft Management Console ablakában bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét.
  2. Kattintson a kívánt virtuális SMTP-kiszolgálóra, ezáltal kijelölve azt.
  3. Kattintson a Művelet menü Indítás parancsára.


A Microsoft SMTP-szolgáltatás szüneteltetése

Virtuális SMTP-kiszolgáló szüneteltetése

A virtuális SMTP-kiszolgáló szüneteltetésére a beállítások módosítása, illetve a szolgáltatás működtetése céljából lehet szükség. Szüneteltetéskor a kiszolgáló nem fogad újabb kapcsolatokat, de a virtuális kiszolgáló a meglévő ügyfélkapcsolatokat továbbra is feldolgozza és a felsorakoztatott üzeneteket zavartalanul kézbesíti.

  1. A Microsoft Management Console ablakában bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét.
  2. Az egérrel rákattintva jelölje ki a virtuális SMTP-kiszolgálót.
  3. Kattintson a Művelet menü Szüneteltetés parancsára.


Virtuális SMTP-kiszolgáló leállítása

A virtuális SMTP-kiszolgáló leállítására a beállítások módosítása, illetve a szolgáltatás működtetése céljából lehet szükség.

  1. A Microsoft Management Console ablakában bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét.
  2. Az egérrel rákattintva jelölje ki a virtuális SMTP-kiszolgálót.
  3. Kattintson a Művelet menü Leállítás parancsára.


A Microsoft SMTP-szolgáltatás indítása, leállítása és szüneteltetése

A Microsoft SMTP-szolgáltatás a Microsoft Windows 2000 Server operációs rendszer szolgáltatásaként fut, amely telepítéskor azonnal elindul. Habár egy számítógépen csak egyetlen egy Microsoft SMTP-szolgáltatás lehet, virtuális SMTP-kiszolgálót akár többet is létre lehet hozni. A Microsoft SMTP-szolgáltatás futtatása közben az adott virtuális kiszolgáló indítása, leállítása vagy szüneteltetése a többitől teljesen függetlenül történik.

Több virtuális SMTP-kiszolgáló használata esetén fontos, hogy a teljes Microsoft SMTP-szolgáltatás szüneteltetése vagy leállítása a virtuális SMTP-kiszolgálók mindegyikére kihat. A szolgáltatás leállítása esetén a Microsoft Management Console nem használható a virtuális SMTP-kiszolgálók adminisztrációja céljából.

Megjegyzés Az egyetlen kivétel ez alól, hogy a virtuális kiszolgáló indítása a Microsoft NNTP-szolgáltatás leállítása esetén is lehetséges. Egy virtuális SMTP-kiszolgáló indítása a teljes Microsoft SMTP-szolgáltatás újraindítását eredményezi, ami azt jelenti, hogy egyúttal minden, a Microsoft SMTP-szolgáltatás leállítását megelőzően futó virtuális SMTP-kiszolgáló is elindul.

A Microsoft SMTP-szolgáltatás indításkor új kapcsolatokat fogad a felhasználóktól. Amikor a Microsoft SMTP-szolgáltatást leállítja, az nem fogad újabb kapcsolatokat. A Microsoft SMTP-szolgáltatás szüneteltetése esetén a korábban létesített kapcsolatok megmaradnak, de egyetlen aktív virtuális SMTP-kiszolgáló sem fogad újabb kapcsolatokat.

A Microsoft SMTP-szolgáltatás indítása, leállítása és szünteteltetése a Rendszergazda eszközeivel

  1. Mutasson a Start menü Programok elemére, majd a Rendszergazda eszközei (Általános) menüpontra, azon belül pedig kattintson a Összetevők szolgáltatásai parancsra.
  2. Az MMC faszerkezetében jelölje ki a Szolgáltatások (helyi) elemet.
  3. A részleteket tartalmazó ablaktáblán kattintson az egér jobb oldali gombjával a Microsoft SMTP-szolgáltatás elemre, majd kattintson az Indítás, Leállítás vagy a Szüneteltetés parancsra.
Megjegyzés A Microsoft SMTP-szolgáltatás újraindításakor a szolgáltatás leállításakor futó minden virtuális SMTP-kiszolgáló automatikusan újraindul. Ezzel szemben az az SMTP-kiszolgáló, amely a szolgáltatás leállításakor eleve nem futott, a Microsoft SMTP-szolgáltatás újraindításának hatására sem fog elindulni.


Virtuális SMTP-kiszolgáló beállítása

A virtuális SMTP-kiszolgálót két jellemző alapján lehet beazonosítani: az ügyfélprogramban megjelenő név, illetve az IP-cím és TCP port kombináció alapján. A Telepítő adja meg az alapértelmezett virtuális SMTP-kiszolgálónak azt a nevet, amely a Microsoft Management Console-ban meg fog jelenni. Ezt a nevet (Alapértelmezett virtuális SMTP-kiszolgáló) megtarthatja, vagy az alább ismertetett lépésekkel meg is változtathatja. Hasonlóképpen az adott virtuális SMTP-kiszolgálóhoz tartozó IP-címet is ki lehet választani.

A virtuális SMTP-kiszolgáló beazonosítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Az alapértelmezett név lecseréléséhez az Általános kartonon levő Név mezőbe írja be a virtuális kiszolgáló új nevét.

    Megjegyzés
    A virtuális SMTP-kiszolgáló neve nem tartalmazhat a karakterkészlet kibővített részében található karaktereket.

  3. Az IP-cím mezőből válassza ki a virtuális kiszolgáló IP-címét. A virtuális SMTP-kiszolgáló a számítógépen beállított IP-címek bármelyikéhez érkező kapcsolódási kérésekre képes válaszolni. A virtuális kiszolgálóhoz beállított különféle IP-címekhez tartozó TCP portokat a Speciális kartonon tudja beazonosítani. A TCP port számaként célszerű az SMTP protokoll által szinte mindenhol használt 25-ös portszámot megadni. Több virtuális SMTP-kiszolgáló is használhatja a 25-ös számú portot, feltéve, hogy mindegyik különböző IP-címmel rendelkezik.
Megjegyzés

A virtuális SMTP-kiszolgáló beállításainak megváltoztatásakor ajánlatos a Leállítás parancsot használni. Szüneteltetéskor a kiszolgáló nem fogad újabb kapcsolatokat, de a Microsoft SMTP-szolgáltatás a meglevő ügyfélkapcsolatokat továbbra is feldolgozza és a felsorakoztatott üzeneteket zavartalanul kézbesíti.


Az alapértelmezett indítási beállítások módosítása

A Microsoft SMTP-szolgáltatás indításakor érvényes alapértelmezett beállítások módosítása a Rendszergazda eszközeivel történik.

  1. Mutasson a Start menü Programok elemére, majd a Rendszergazda eszközei (Általános) menüpontra, azon belül pedig kattintson a Összetevőszolgáltatások parancsra.
  2. Az MMC faszerkezetében jelölje ki a Szolgáltatások (helyi) elemet.
  3. A részleteket tartalmazó ablaktáblán kattintson az egér jobb oldali gombjával a Microsoft SMTP-szolgáltatás elemre, majd kattintson az Tulajdonságok parancsra.
  4. Az Általános karton Indítás csoportján belül válasszon az Automatikus, a Kézi, illetve a Kikapcsolva lehetőségek közül.


További virtuális SMTP-kiszolgálók létrehozása

A legtöbb esetben csak egyetlen egy virtuális SMTP-kiszolgálóra van szükség. Amennyiben több tartományt üzemeltet, és egynél több alapértelmezett tartományra van szüksége, azonban érdemes több virtuális SMTP-kiszolgálót létrehozni. A felhasználó szempontjából a virtuális SMTP-kiszolgálók mindegyike különálló kiszolgálóként jelenik meg, egyedi IP-cím/TCP port kombinációval.

Virtuális SMTP-kiszolgáló létrehozásakor meg kell adni a kezdőkönyvtár elérési útvonalát. A kezdőkönyvtárnak mindenképpen az SMTP-szolgáltatást futtató számítógép valamelyik helyi könyvtárának kell lennie.

Új virtuális SMTP-kiszolgáló létrehozása Microsoft Management Console-lal
  1. Ha a virtuális SMTP-kiszolgáló új IP-címet fog használni, az IP-cím kiválasztásához kattintson a Start menü Beállítások menüpontjára, majd ezen belül a Hálózati és telefonos kapcsolatok parancsra. A Hálózati és telefonos kapcsolatok beállításairól részletes információ a Windows 2000 operációs rendszer dokumentációjában található.
  2. Az IP-cím beállítása után a Microsoft Management Console-ban válasszon ki egy már meglévő virtuális SMTP-kiszolgálót. Ezután a Művelet menüben mutasson az Új parancsra, és kattintson a Virtuális kiszolgáló menüpontra.
  3. Kövesse az Új virtuális SMTP-kiszolgáló varázsló utasításait. Mindenképpen olyan IP-cím/TCP port kombinációt adjon meg, amelyet más virtuális SMTP-kiszolgáló biztos, hogy nem használ. Ajánlatos az SMTP protokoll által szinte mindenhol használt 25-ös számú TCP portot használni. Több virtuális SMTP-kiszolgáló is használhatja a 25-ös számú portot, feltéve, hogy eltérő IP-címet adtak meg hozzájuk.
  4. Amennyiben a Microsoft SMTP-szolgáltatás alapértelmezés szerint az Automatikus indítást használja az indításhoz, az új virtuális SMTP-kiszogláló magától elindul. Ha nem indulna el, valószínűleg egy más kiszolgáló által már használt, foglalt IP-cím/TCP port kombinációt adott meg.
  5. Állítsa be az új virtuális SMTP-kiszolgálót.


Kapcsolatok beállítása

A rendszer akkor hoz létre kapcsolatot, amikor üzenetet küld egy távoli kiszolgálóra, illetve amikor egy távoli kiszolgálóról küldött üzenetet fogad.

Bejövő kapcsolatok beállítása

Megjegyzés

A Microsoft SMTP-szolgáltatás által a bejövő üzenetek fogadására használt TCP portot a virtuális SMTP-kiszolgáló azonosító adatainak beállításakor kell megadnia.

Bejövő kapcsolatok beállítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Kapcsolatok párbeszédpanel megnyitásához kattintson az Általános lapon található Kapcsolat gombra.
  3. Jelölje be a Bejövő részen látható jelölőnégyzetet (alapértelmezés szerint nincs korlátozás), és adja meg az alábbi beállításokat:

    Beállítás | Leírás
    A kapcsolatok száma legfeljebb | A jelölőnégyzet bejelölése esetén az itt megadott érték határozza meg, hogy a bejövő üzenetek kézbesítésekor egy időben legfeljebb hány kapcsolat engedélyezett. Alapértelmezés szerint 1000 kapcsolat engedélyezett, a beállítható legkisebb érték pedig 1.
    Időkorlát (perc) | Itt határozhatja meg, hogy a rendszer mennyi idő után zárja le az inaktív kapcsolatokat. Ez az időkorlát alapértelmezés szerint 10 perc.

Kimenő kapcsolatok beállítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Kapcsolatok párbeszédpanel megnyitásához kattintson az Általános lapon található Kapcsolat gombra.
  3. A párbeszédpanel Kimenő részén adja meg az alábbi beállítások értékét:

    Beállítás | Leírás
    A kapcsolatok száma legfeljebb Alapértelmezés szerint a jelölőnégyzet be van jelölve. Az itt megadott érték határozza meg az összes távoli tartomány felé egy időben fenntartható összes kapcsolat maximális számát. Alapértelmezés szerint 1000 kapcsolat engedélyezett, a beállítható legkisebb érték pedig 1. Ha nem kíván beállítani korlátozást, törölje a jelölést a jelölőnégyzetből.

    E beállítás és az Üzenetek tulajdonságlapon levő Kapcsolatonként az üzenetek száma legfeljebb beállítás együttes használatával az esetek legnagyobb részében növelhető a rendszer teljesítménye.
    Időkorlát (perc) | Itt határozhatja meg, hogy a rendszer mennyi idő után zárja le az inaktív kapcsolatokat. Ez az időkorlát alapértelmezés szerint 10 perc.
    A kapcsolatok száma tartományonként legfeljebb | A jelölőnégyzet bejelölésével és egy szám megadásával korlátozhatja az egy-egy távoli tartomány felé irányuló kapcsolatok számát. Alapértelmezés szerint 100 kapcsolat engedélyezett. Az itt megadott számnak nem szabad nagyobbnak lennie a fenti A kapcsolatok száma legfeljebb mezőben megadott értéknél.
    TCP port | Ez a beállítás határozza meg a kimenő adatátvitelhez használt TCP port számát. Alapértelmezés szerint ez a 25-ös számú port. A kimenő és bejövő adatforgalom számára megadható ugyanaz a port, vagy megadható két különböző portszám is.

Az üzenetküldéssel kapcsolatos folyamatok áttekintése az Alapfogalmak című témakörben található.


Protokollnaplózás engedélyezése

A protokollnaplók azokat a parancsokat követik nyomon, amelyeket az SMTP-ügyfelek a virtuális SMTP-kiszolgálónak küldenek a hálózaton keresztül. Ön választhatja ki, hogy a Microsoft SMTP-szolgáltatás milyen naplóformátumban tartsa nyilván ezeket az adatokat.

A naplófájl beállításakor ne feledkezzen meg arról, hogy a naplóformátumok és az alapértelmezett fájlnevek megegyeznek az Internet Information Services (IIS) többi szolgáltatása által használt formátumokkal és nevekkel. Amennyiben az alapértelmezett neveket választja, az összes szolgáltatás ugyanabban a fájlban rögzíti az összes tranzakciót. Ahhoz, hogy külön-külön tarthassa nyilván az egyes szolgáltatások tranzakcióit, minden szolgáltatáshoz külön fájlt kell létrehoznia. Az alapértelmezettől eltérő helyen létrehozott naplófájlok esetén mindenképpen helyi meghajtót, ne hálózati helyet adjon meg. Arra is figyeljen, hogy egyes nevek nem az SMTP-szolgáltatás sajátjai, hiszen a naplózási funkciókat az IIS szolgáltatásai megosztva használhatják.

A tranzakciónaplózással és a különféle naplóformátumokkal kapcsolatban az Üzenetkezelési tranzakciók figyelése című témakörben talál további információt.

ASCII szöveges formátumot használó naplózás engedélyezése

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Jelölje be az Általános lapon található Naplózás engedélyezése jelölőnégyzetet.
  3. Az Aktív naplóformátum legördülő listáról válassza ki a kívánt naplóformátumot.
  4. Kattintson a Tulajdonságok gombra, majd az Általános tulajdonságok lapon adja meg a naplófájl méretét és helyét.
  5. Amennyiben a W3C bővített naplóformátumot választotta, kattintson a További tulajdonságok lapra, és válassza ki a nyilvántartani kívánt elemeket.

ODBC formátumot használó naplózás engedélyezése

  1. Hozzon létre egy ODBC-kompatibilis adatbázist.
  2. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  3. Jelölje be az Általános lapon található Naplózás engedélyezése jelölőnégyzetet.
  4. Az Aktív naplóformátum legördülő listáról válassza ki az ODBC naplózás lehetőséget.
  5. Kattintson a Tulajdonságok gombra, majd adja meg a naplófájl méretét és helyét.


Virtuális kiszolgáló beállítása fürtözéshez

A Windows kiszolgálófürtözési lehetősége kizárólag a Windows 2000 Advanced Server operációs rendszerben érhető el. A Fürtözési szolgáltatás a Windows 2000 - kiszolgáló konfigurálása párbeszédpanelről indítható Windows komponens telepítése varázslóval telepíthető. Bővebb információt a Windows 2000 dokumentációjában olvashat.

A kiszolgálófürt különálló számítógéprendszerek — más néven csomópontok — csoportja, amelyek egyetlen rendszerként együttműködve biztosítják azt, hogy az üzletvitelhez nélkülözhetetlen alkalmazások és erőforrások mindig az ügyfelek rendelkezésére álljanak. A kiszolgálók fürtözésével megbízható, az idő lehető legnagyobb részében rendelkezésre álló rendszer alakítható ki. Fürtözött SMTP-kiszolgálók esetében ez azt jelenti, hogy ha valamelyik virtuális kiszolgáló meghibásodik, akkor a rendszer e kiszolgáló feladatait szétosztja a fürt többi virtuális kiszolgálója között, így a levelezési szolgáltatás nem szakad meg. A kiszolgálófürtök további előnye a forrótartalékok használatának lehetősége: a kiszolgáló-erőforrások meghibásodása esetén, azaz ha valamelyik virtuális kiszolgáló leáll, egy addig tartalékként működő rendszer azonnal átveszi a leállt kiszolgáló szerepét, és folytatja a hálózati szolgáltatás ellátását.

A fürtözés szempontjából azok a rendszerek tekinthetők csomópontnak, amelyek Windows 2000 Advanced Server operációs rendszer alatt működnek, és amelyekre telepítették a Fürtözési szolgáltatást. A Microsoft azt javasolja ügyfeleinek, hogy fürtözéshez hozzanak létre egy új virtuális kiszolgálót a csomóponton, és ne az alapértelmezett virtuális SMTP-kiszolgáló átkonfigurálásával oldják meg a feladatot.

A Windows Fürtözési szolgáltatásáról és a kiszolgálófürtökről a Windows 2000 Advanced Server dokumentációjában talál további információt. A kiszolgálófürtök telepítésével és felügyeletével kapcsolatos részletes útmutatókat szintén az a dokumentáció tartalmazza.

Virtuális SMTP-kiszolgáló beállítása fürtözéshez

  1. Amennyiben szükséges, állítsa át a Microsoft SMTP-szolgáltatás alapértelmezett indítási módját Kézi beállításra.
  2. Az új virtuális kiszolgáló létrehozása előtt indítsa el a Microsoft Management Console-t, majd kattintson az egér jobb oldali gombjával az alapértelmezett virtuális SMTP-kiszolgálóra, és válassza a helyi menü Tulajdonságok parancsát.
  3. Kattintson az Általános lapon található Speciális gombra.
  4. Kattintson duplán az IP-cím listán látható (Egyik sincs kiosztva) bejegyzésre.
  5. Az Azonosítás párbeszédpanelen változtassa meg a TCP port számát az alapértelmezett 25-ösről bármelyik még ki nem osztott portszámra. A portszám megváltoztatására azért van szükség, hogy a fürtözéshez létrehozni kívánt új virtuális SMTP-kiszolgáló portszáma semmiképpen ne ütközzön a létező kiszolgálók portszámával. Gépelje be az új portszámot (győződjön meg arról, hogy máshol nem használják), majd kattintson az OK gombra.
  6. Hozzon létre egy új virtuális SMTP-kiszolgálót. Létrehozása után a kiszolgálót kézzel kell elindítania. Ellenőrizze, hogy az új virtuális kiszolgálón az alapértelmezett 25-ös számú TCP port van-e beállítva.

    Fontos

    Amikor az Új virtuális SMTP-kiszolgáló varázsló Kezdőkönyvtár kiválasztása képernyőjéhez ér, annak a megosztott erőforrásnak az elérési útvonalát adja meg, amelyet a fürtözött kiszolgálókhoz használ majd. Semmiképpen ne a helyi merevlemezre mutató elérési útvonalat adjon meg.

  7. Az IIS szinkronizálási parancs végrehajtásával szinkronizálja a szóban forgó csomópont és a kiszolgálófürt többi csomópontjának IIS adatait. Ehhez indítsa el a parancssort, lépjen a csomóponton levő \WINNT\System32\Inetsrv könyvtárba, majd gépelje be és hajtsa végre az iissync kiszolgálónév parancsot, ahol kiszolgálónév a kiszolgálófürt valamely másik csomópontjának neve. Az IIS szinkronizálási parancsról az IIS dokumentációjában talál további információt.
  8. A kiszolgálófürt csomópontjainak szinkronizálása után érdemes még egyszer ellenőrizni az újonnan létrehozott virtuális SMTP-kiszolgáló és az alapértelmezett virtuális kiszolgáló TCP portszámát. Elsősorban azt ellenőrizze, hogy a helyi csomópontot a kiszolgálófürt más csomópontjairól nézve a TCP port beállítása megegyezik-e a helyi csomóponton megadottal. Az alapértelmezett virtuális SMTP-kiszolgálónak egyik csomóponton sem szabad az alapértelmezett (25-ös számú) portra mutatnia, mert azt az új virtuális SMTP-kiszolgálóhoz kell beállítani. Ahhoz, hogy a fürtözés működjön, a beállításoknak minden csomóponton meg kell egyezniük.
  9. Indítsa el a Fürtkezelőt. Kövesse a varázsló lépéseit, és rendeljen erőforrástípust az új virtuális SMTP-kiszolgálóhoz.

    Megjegyzés

    A Paraméterek párbeszédpanelen látható legördülő listáról mindenképpen az újonnan létrehozott virtuális SMTP-kiszolgálót válassza ki, ne az alapértelmezett virtuális SMTP-kiszolgálót. A Fürtkezelőről a Windows 2000 Advanced Server dokumentációjában talál további információt.


Adatbiztonsági beállítások

Ez a rész a virtuális SMTP-kiszolgáló adatbiztonsági beállításainak részletes ismertetését tartalmazza:

  • Tudnivalók az adatbiztonsági beállításokról
  • Felügyelői engedélyek beállítása
  • Hitelesítés kötelezővé tétele a bejövő kapcsolatokon
  • Hitelesítés beállítása a kimenő üzenetek küldésére
  • A TLS titkosítás kötelezővé tétele
  • A kiszolgálóhoz való hozzáférés korlátozása IP-cím alapján
  • Virtuális kiszolgálóra vonatkozó továbbítási korlátozások feloldása


Tudnivalók az adatbiztonsági beállításokról

A virtuális SMTP-kiszolgáló biztonságára vonatkozó követelményeknek megfelelően a két adatbiztonsági tulajdonságlap beállításainak megadásával szabályozhatja a kívánt biztonsági szintet. Ezek a beállítások a virtuális kiszolgáló minden tartományára vonatkoznak.

Tulajdonságlap | Beállítások
Felügyelők | Itt adhatja meg azokat a felhasználói fiókokat, amelyeket felügyelői jogokkal ruház fel a Microsoft SMTP-szolgáltatás működtetéséhez. A felügyelők módosíthatják a virtuális SMTP-kiszolgáló tulajdonságait.
Hozzáférés | Ezen a lapon adható meg az, hogy a rendszer minden bejövő kapcsolaton kötelezővé tegye a hitelesítés és a TLS használatát. Ugyancsak itt szabályozható, hogy egyes számítógépek vagy hálózatok hozzáférhetnek-e a kiszolgálóhoz.


Felügyelői engedélyek beállítása

Kijelölheti, hogy mely felhasználói fiókoknak ad felügyelői engedélyeket a virtuális SMTP-kiszolgálóhoz. A Windows 2000 Server fiókok beállítását követően az engedélyek megadásához elég a listáról kiválasztani a megfelelő fiókot, az engedélyek visszavonásához pedig egyszerűen távolítsa el a fiókot a virtuális kiszolgáló felügyelőinek listájáról.

Felügyelői engedélyek megadása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Kattintson az Adatbiztonság lapon található Hozzáadás gombra, ekkor megnyílik a Felhasználók vagy csoportok kijelölése párbeszédpanel.
  3. A kívánt Windows 2000 Server fiók kijelölése után kattintson a Hozzáadás gombra, majd az OK gombra. A kiválasztott fiók megjelenik a Felügyelők listáján.

Felügyelői engedélyek visszavonása

A Felügyelők listáján szereplő Windows 2000 Server felhasználói fiókoktól bármikor megvonhatja a felügyelői engedélyeket.

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Az Adatbiztonság lapon kattintson az eltávolítani kívánt felügyelőre.
  3. Kattintson az Eltávolítás gombra.


Hitelesítés kötelezővé tétele a bejövő kapcsolatokon

Összesen háromféle hitelesítési módszer használható, ezek közül kiválaszthat egyet, kettőt vagy akár mind a hármat. Alapértelmezés szerint a rendszer mindhárom módszert használja.

Hitelesítési beállítás | Leírás
Névtelen hozzáférés | Felhasználónév és jelszó megadása nem kötelező. Válassza ezt a beállítást, ha nem kíván hitelesítést használni a virtuális SMTP-kiszolgálón.
Alapfokú hitelesítés | A felhasználónevet és a jelszót a rendszer titkosítatlan szövegként továbbítja a hálózaton. Meg kell adnia egy Windows tartományt is, amelyet a rendszer hitelesítéskor hozzáfűz a fiók nevéhez.
Windows biztonsági csomag | Válassza ezt a lehetőséget a Windows fióknév és jelszó ellenőrzésének kötelezővé tételéhez.

Hitelesítés kikapcsolása a bejövő kapcsolatokon

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Hitelesítés párbeszédpanel megnyitásához kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra.
  3. Jelölje be a Névtelen hozzáférés jelölőnégyzetet, és törölje a jelölést a többi beállítás jelölőnégyzetéből.

Titkosítatlan szöveges hitelesítés használata a bejövő kapcsolatokon

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Hitelesítés párbeszédpanel megnyitásához kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra.
  3. Jelölje be az Alapfokú hitelesítés jelölőnégyzetet.
  4. Gépeljen be egy Windows tartománynevet az Alapértelmezett tartomány mezőbe. Ez az alapértelmezett tartomány nem ugyanaz, mint a virtuális SMTP-kiszolgáló alapértelmezett tartománya.

Windows biztonsági csomag használata a bejövő üzenetek hitelesítéséhez

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Hitelesítés párbeszédpanel megnyitásához kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra.
  3. Jelölje be a Windows biztonsági csomag jelölőnégyzetet.


Kimenő üzenetek hitelesítésének beállítása

A virtuális SMTP-kiszolgálót beállíthatja úgy, hogy hitelesítési igazoló adatokat küldjön a fogadó kiszolgálónak, amennyiben a fogadó kiszolgáló megköveteli azokat. Háromféle hitelesítési módszer közül választhat: névtelen, alapfokú (titkosítatlan szöveges), illetve a Windows biztonsági csomag használata közül. Névtelen hozzáférés esetén a hitelesítés nem kötelező. Az alapfokú, titkosítatlan szöveges hitelesítés használata esetén a szolgáltatás titkosítatlan szövegben küldi el a fióknevet és a jelszót annak a kiszolgálónak, amelyhez kapcsolódik. A Windows biztonsági csomag használatával történő hitelesítéskor meg kell adni a Windows fióknevet és jelszót.

Az itt megadott beállítás helyett egyes távoli tartományokhoz mást is használhat. Így beállíthat a virtuális kiszolgálón a tranzakciók nagy többségének megfelelő hitelesítési szintet, míg egyes címek esetén kivételt tehet. Az alábbi táblázat különféle beállítási lehetőségeket mutat be.

Megjegyzés A kimenő üzenetek titkosításáról a TLS titkosítás kötelezővé tétele című témakörben olvashat bővebben.

SMTP-adatátvitel | Hitelesítési beállítás
Általában minden üzenetet több címre küldenek. | Kapcsolja ki a virtuális SMTP-kiszolgáló hitelesítését. Amennyiben kötelező hitelesítés miatt nem sikerül az üzenetet valamely címre kézbesíteni, vegyen fel a címhez egy távoli tartományt. A tartományhoz ez után kapcsolja be a kiszolgáló által megkövetelt hitelesítési szintet.
Általában minden üzenetet egy címre küldenek, amelyen a hitelesítés kötelező. | Határozza meg a kapcsolódáshoz szükséges hitelesítési szintet. Ez után engedélyezze ugyanezt a hitelesítési szintet a virtuális SMTP-kiszolgálón. Amennyiben később az üzeneteket más címekre is el kívánja küldeni, állítson be távoli tartományokat és adjon meg eltérő hitelesítési beállításokat. Ha ezt a beállítást használja, valószínű, hogy a felhasznált fióknév megegyezik az intelligens állomásként beállított számítógép azonosítójával.

A kimenő üzenetek hitelesítésének kikapcsolása

  1. Kattintson a Kézbesítés kartonra.
  2. A Kimeneti adatbiztonság gombra kattintva nyissa meg a Kimeneti adatbiztonság párbeszédpanelt.
  3. Kattintson a Névtelen hozzáférés választógombra.
  4. Törölje a többi beállítás bejelölését.

A kimenő üzenetek alapfokú hitelesítésének bekapcsolása

  1. Kattintson a Kézbesítés kartonra.
  2. A Kimeneti adatbiztonság gombra kattintva nyissa meg a Kimeneti adatbiztonság párbeszédpanelt.
  3. Kattintson az Alapfokú hitelesítés választógombra.
  4. A Felhasználónév és Jelszó mezőkben adja meg a kívánt számítógéphez való kapcsolódáshoz szükséges érvényes felhasználónevet és jelszót.

A kimenő üzenetek hitelesítése a Windows biztonsági csomag használatával

  1. Kattintson a Kézbesítés kartonra.
  2. A Kimeneti adatbiztonság gombra kattintva nyissa meg a Kimeneti adatbiztonság párbeszédpanelt.
  3. Kattintson a Windows biztonsági csomag választógombra.
  4. A Felhasználónév és Jelszó mezőkben adja meg a kívánt számítógépre való kapcsolódáshoz szükséges érvényes Windows fióknevet és jelszót.


TLS engedélyezése kimenő üzenetekhez

Az SMTP hely kimenő forgalmának titkosítása érdekében jelölje be a TLS titkosítás jelölonégyzetet a Kézbesítés tulajdonságlap Kimeneti adatbiztonság részén. A beállítást egyes távoli tartományok esetében felülbírálhatja. Ha általában nem akar TLS titkosítást használni a kimenő üzenetekhez, de egy adott távoli helyhez kötelező jelleggel titkosított formában kell elküldeni az üzeneteket, távolítsa el a Kimeneti adatbiztonság bekezdésben levő TLS titkosítás jelölőnégyzetből a pipát. Ezután hozzon létre egy távoli tartományt az adott távoli helyhez, és az erre vonatkozó Kimeneti adatbiztonság bekezdésben jelölje be a TLS titkosítás jelölőnégyzetet.

TLS engedélyezése minden átvitelhez

  1. Kattintson a Kézbesítés kartonra.
  2. Kattintson a Kimeneti adatbiztonság gombra, majd jelölje be a TLS titkosítás jelölőnégyzetet.


A TLS titkosítás kötelezővé tétele

Kötelezővé teheti az összes ügyfél számára a TLS titkosítás használat az alapértelmezett virtuális SMTP-kiszolgálóhoz való kapcsolódáskor. A TLS az SSL-hez hasonló általános adatbiztonsági protokoll. Ez a beállítás a kapcsolaton keresztül továbbított adatok titkosítására szolgál, de hitelesítésre nem használható.

A TLS titkosításnak a virtuális kiszolgálón való használatához először kulcspárokat kell létrehoznia, és be kell állítania a kulcsbizonyítványokat. Az ügyfelek ezt követően a TLS használatával titkosíthatják a Microsoft STMP-szolgáltatással fenntartott munkamenetet, vagyis az összes küldött üzenetet. A Microsoft SMTP-szolgáltatás távoli kiszolgálókkal folytatott munkamenetek titkosítására is használhatja a TLS protokollt.

Kulcsbizonyítványok létrehozása és kezelése

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A virtuális SMTP-kiszolgáló új kulcsbizonyítványainak beállításához, illetve a telepített kulcsbizonyítványok kezeléséhez kattintson a Hozzáférés lap Biztonságos kommunikáció részén található Bizonyítvány gombra.

A kulcspárok adott számú bitből állnak, a bitek száma jelzi a kulcs biztonsági szintjét. Az adatok nagyobb biztonsága és védelme érdekében növelheti a titkosítás szintjét az alapértelmezett 40 bites kulcshosszról 128 bitesre. Minél nagyobb a bitek száma, annál nehezebb visszafejteni az adott elemet. Azoknak a felhasználóknak, akik élni szeretnének a biztonságos hozzáférés lehetőségével, az Ön által megadott titkosítási szintet kell használniuk, különben a szolgáltatás „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldi az üzeneteket a feladónak.

Megjegyzés

A kiviteli korlátozások miatt a 128 bites titkosítás lehetősége kizárólag az Amerikai Egyesült Államok és Kanada területén értékesített termékekben vehető igénybe. Amennyiben szeretne további információt kapni a 128 bites titkosításra való átállásról, keresse fel a http://support.microsoft.com/support/ címen található webhelyet.

A kiszolgálón alkalmazott TLS titkosítási szint beállítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Hitelesítés párbeszédpanel megnyitásához kattintson a Hozzáférés lap Hozzáférés-szabályozás részén található Hitelesítés gombra.
  3. Jelölje be az Alapfokú hitelesítés jelölőnégyzetet.
  4. Jelölje be a TLS titkosítás szükséges jelölőnégyzetet.

Megjegyzés

Ezen túlmenően két további TLS titkosítási beállítás használatára is lehetősége van. Amennyiben az összes kimenő kapcsolaton TLS titkosítást kíván használni, kattintson a Kézbesítés lap Kimeneti adatbiztonság gombjára, majd jelölje be a TLS titkosítás jelölőnégyzetet. Ha pedig az Ön rendszere által gyakran használt kiszolgálók valamelyike kötelezővé teszi a TLS használatát bejövő kapcsolatain, hozzon létre egy távoli tartományt, és létrehozásakor kattintson a TLS titkosítás jelölőnégyzetre.


A kiszolgálóhoz való hozzáférés korlátozása IP-cím alapján

Kiválasztott IP-címek számára engedélyezheti, illetve megtilthatja a hozzáférést a virtuális SMTP-kiszolgálóhoz. Alapértelmezés szerint a virtuális SMTP-kiszolgáló minden IP-címről elérhető. A korlátozás beállításához egy bizonyos IP-címet, illetve alhálózati maszk vagy Windows 2000 Server tartománynév használatával címek egy csoportját kell megadnia.

A hozzáférés korlátozása IP-cím alapján

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Kapcsolat párbeszédpanel megnyitásához kattintson a Hozzáférés lap Kapcsolatvezérlés részén található Kapcsolat gombra.
  3. Jelölje be a Csak az alábbi listán szereplők vagy az Az alábbi listán szereplők kivételével az összes választógombot.
  4. A számítógépek listájának bővítéséhez kattintson a Hozzáadás gombra, ekkor megnyílik a Számítógép párbeszédpanel.
  5. A listán szereplő számítógépek törléséhez jelölje ki a törölni kívánt gépet, majd kattintson az Eltávolítás gombra.


Továbbítási korlátozások beállítása, illetve eltávolítása egy virtuális kiszolgálóról

A Microsoft SMTP-szolgáltatás alapértelmezés szerint nem engedélyezi, hogy más számítógépek nem kívánt leveleket továbbítsanak a virtuális kiszolgálón keresztül. Amennyiben a virtuális SMTP-kiszolgálón engedélyezni kívánja a továbbítást, kattintson a Hozzáférés karton Továbbítás gombjára. Alapértelmezés szerint kizárólag azok a számítógépek kapnak hozzáférést, amelyek megfelelnek a Hitelesítés párbeszédpanelen megadott követelményeknek. A párbeszédpanel megnyitásához kattintson a Hozzáférés karton Hitelesítés gombjára.

Az üzeneteket távoli tartományra is lehet továbbítani. Ezzel kapcsolatban bővebb információ a Távoli tartományok beállítása címszó alatt található. A tartományra vonatkozó beállítás felülbírálja a virtuális SMTP-kiszolgálóhoz megadott beállítást.

Megjegyzés

Ha virtuális kiszolgálója az Interneten van, a nem kívánatos elektronikus levelek továbbításának elkerülése végett inkább ne engedélyezze a továbbítást.

A továbbítási korlátozások eltávolítása egy virtuális kiszolgálóról

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Hozzáférés karton Továbbítási korlátozások bekezdésében kattintson a Továbbítás gombra. Megnyílik a Továbbítási korlátozások párbeszédpanel.
  3. Jelölje be a Csak az alábbi listán szereplők vagy az Az alábbi listán szereplők kivételével az összes választógombot.
  4. A Számítógép párbeszédpanel megnyitásához kattitnson a Hozzáadás gombra, és vegye fel azokat a számítógépeket, amelyekre a harmadik lépésben kiválasztott globális hozzáférési beállítás nem vonatkozik.

A Továbbítási korlátozások párbeszédpanelen az alábbi beállítások megadására van lehetőség.

Beállítás | Leírás
Csak az alábbi listán szereplők | Csak a listában szereplő számítógépek továbbíthatnak üzeneteket a virtuális SMTP-kiszolgálón keresztül.
Az alábbi listán szereplők kivételével az összes | A listában szereplő számítógépek kivételével bármely számítógép továbbíthat üzeneteket a virtuális SMTP-kiszolgálón keresztül. Alapértelmezés szerint ez és a Sikeresen hitelesített számítógépek számára a továbbítás a fenti listától függetlenül engedélyezett beállítás érvényes.
Hozzáadás és eltávolítás | A továbbításhoz hozzáférést kapott számítógépek listájának bővítésére, illetve az ott szereplő egyes számítógépek eltávolítására szolgál.
Sikeresen hitelesített számítógépek számára a továbbítás a fenti listától függetlenül engedélyezett | A Hitelesítés párbeszédpanelen megadott követelményeknek megfelelő számítógépek ezáltal jogosultak a virtuális SMTP-kiszolgálón keresztül üzeneteket továbbítani. Alapértelmezés szerint ez a beállítás érvényes.


Továbbításhoz szükséges hozzáférés beállítása távoli tartomány számára

Alapértelmezés szerint a Microsoft SMTP-szolgáltatás nem engedélyezi, hogy más számítógépek nem kívánt leveleket továbbítsanak egy távoli tartományba. Ha valamely tartományon engedélyezni kívánja a továbbításhoz a hozzáférést, használja a Tartomány tulajdonságai tulajdonságlap megfelelő beállítását.

A tartományhoz megadott továbbításra vonatkozó beállítás bizonyos esetekben felülbírálja a teljes virtuális SMTP-szolgáltatáshoz megadott továbbítási hozzáférés beállítást. A virtuális kiszolgáló számára megtiltható a továbbításhoz szükséges hozzáférés, ugyanakkor egyes tartománynak engedélyezhető. Ez fordítva is érvényes. A virtuális SMTP-kiszolgáló továbbítási hozzáférésével kapcsolatban bővebb információ a Továbbítási korlátozások eltávolítása egy virtuális kiszolgálóról.

A TLS titkosítás engedélyezése távoli tartomány számára

  1. Jelölje ki az adott tartomány Tartomány tulajdonságai tulajdonságlapot.
  2. Az Általános kartonon jelölje be a Bejövő üzenetek továbbításának engedélyezése ebbe a tartományba jelölőnégyzetet.


Üzenetek kezelése

Ez a rész ismerteti, hogy hogyan optimalizálható a szolgáltatás teljesítménye a kapcsolatokra vonatkozó korlátozások beállításával, hogyan korlátozható az üzenetek mérete és a címzettek száma, illetve hogy a rendszer hogyan kezeli a nem kézbesíthető üzeneteket. A következő témaköröket tartalmazza:

  • A kapcsolatonként engedélyezett üzenetek számának korlátozása
  • Az üzenetek méretének korlátozása
  • A címzettek számának korlátozása
  • A „Nem kézbesíthető” értesítőüzenetek tárolása


A kapcsolatonként engedélyezett üzenetek számának korlátozása

E beállítás használatával lehetősége nyílik az egy kapcsolódás során elküldött üzenetek számának korlátozására, továbbá engedélyezheti több kapcsolat használatát a távoli tartományba küldött üzenetek kézbesítésekor, és ezáltal növelheti a rendszer teljesítményét. Amint a rendszer az üzenetküldés során egy kapcsolaton eléri a beállított korlátot, automatikusan megnyit egy új kapcsolatot, és így folytatja a küldést, amíg az összes üzenetet nem kézbesíti.

Amennyiben bizonyos távoli tartományokba gyakran küld nagy számú üzenetet, akkor a Kapcsolatonként az üzenetek száma legfeljebb mező értékét állítsa aránylag kicsire, például 20-ra. Így, ha egy munkamenetben 100 üzenetet szeretne elküldeni, a Microsoft SMTP-szolgáltatás az első 20 üzenet elküldése után azonnal megnyit egy újabb kapcsolatot, a második 20 üzenet után még egyet stb. Ebben az esetben ugyanarra a helyre akár öt egyidejű kapcsolaton keresztül küldheti el a besorolt üzeneteket. Az üzenetkézbesítés így sokkal gyorsabbá válik, hiszen egy adott kapcsolaton kevesebb üzenet átvitelére kerül sor, és nem kell arra várni, hogy az összes üzenet egymás után, egyetlen kapcsolaton keresztül jusson el az adott célba.

A korlát értékének meghatározásához tanulmányozza a Teljesítményfigyelő SMTP-kiszolgáló objektumának Elküldött üzenet/mp teljesítményszámlálóját. A Kapcsolatonként az üzenetek száma legfeljebb mezőben beállított értéknek kisebbnek kell lennie a teljesítményszámláló által jelzett értéknél. Erre azért van szükség, mert ha a számláló értéke 30, de az üzenetek számát 50 üzenetben korlátozza, egyáltalán nem nyílna meg újabb, egyidejű kapcsolat, hiszen a kiszolgáló eleve nem lépné túl a másodpercenként 30 üzenetet. Ilyen beállítások mellett az üzenetek egyetlen kapcsolaton keresztül, egymás után kerülnének elküldésre. Ez a beállítás kizárólag a kimenő üzenetekre vonatkozik. Használatával növelheti a kiszolgáló kimeneti átviteli sebességét, de arra nincs hatással, hogy a kapcsolat másik végén levő kiszolgálók milyen gyorsan dolgozzák fel a bejövő üzeneteket.

Az egy kapcsolaton keresztül elküldött üzenetek számának korlátozása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Az Üzenetek lapon jelölje be a Kapcsolatonként az üzenetek száma legfeljebb jelölőnégyzetet, és a beviteli mezőbe gépelje be a kívánt értéket. Az érték legfeljebb 2000000000 lehet, alapértelmezés szerint 20.


Az üzenetek méretének korlátozása

Az üzenetek méretének korlátozására két beállítást használhat. Az Egyes üzenetek mérete legfeljebb beállítás azt határozza meg, hogy a virtuális kiszolgáló legfeljebb mekkora üzeneteket fogadjon el. A Microsoft SMTP-szolgáltatás az adott virtuális SMTP-kiszolgáló által elfogadott üzenetek maximális méreteként meghirdeti ezt a kilobájtban megadott méretet. Amennyiben egy levelezési ügyfél a méretkorlátnál nagyobb üzenetet küld, a rendszer nem fogadja az üzenetet, és hibaüzenetben figyelmezteti az ügyfelet. Amennyiben egy távoli kiszolgáló támogatja az EHLO parancsot, a virtuális SMTP-kiszolgálóhoz való kapcsolódáskor tudomásul veszi a meghirdetett maximális üzenetméretet, és nem is próbál majd a méretkorlátnál nagyobb üzenetet kézbesíteni. Ehelyett egyszerűen „Nem kézbesíthető” értesítőüzenetet küld az eredeti üzenet feladójának. Azok a távoli kiszolgálók, amelyek nem támogatják az EHLO parancsot, megpróbálják ugyan elküldeni majd a méretkorlátnál nagyobb üzeneteket, de amikor ezek átvitele sikertelen, szintén „Nem kézbesíthető” értesítőüzenetet küldenek a feladónak.

A munkamenet mérete legfeljebb beállítás azt a maximális adatmennyiséget határozza meg, amelyet a kiszolgáló egy kapcsolódás során elfogad. Az érték a kapcsolódás során átküldött összes üzenet összmérete (a rendszer a méret meghatározásakor csak az üzenetek törzsét veszi figyelembe).

Az üzenetek méretének korlátozása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Az Egyes üzenetek mérete legfeljebb (kB) mező értékeként adja meg (kilobájtban), hogy legfeljebb mekkora lehet egy üzenet. Alapértelmezés szerint az egyes üzenetek mérete legfeljebb 2048 kB. A beállítható legkisebb érték 1 kB.
  3. A munkamenet mérete legfeljebb (kB) mező értékeként adja meg (kilobájtban), hogy egy adott kapcsolat során legfeljebb mekkora lehet a továbbított üzenetek összmérete. Ennek a méretkorlátnak mindig nagyobbnak kell lennie az egyes üzenetek maximális méreténél, és nagyon körültekintően kell beállítani, mert a kapcsolódó üzenetszállítási ügynök (Message Transfer Agent — MTA) egy-egy üzenetet valószínűleg egymás után többször is megpróbál elküldeni. Alapértelmezés szerint az üzenetek összmérete legfeljebb 10240 kB. Az értéknek nem szabad kisebbnek lennie az Egyes üzenetek mérete legfeljebb mezőben megadott értéknél.


A címzettek számának korlátozása

Megadhatja, hogy egy bizonyos üzenetet a rendszer legfeljebb hány címzettnek küldjön el egy kapcsolaton. Az alapértelmezett érték 100 címzett, amely az RFC 821 dokumentumban meghatározott legkisebb érték. Egyes ügyfelek „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldik az üzenetet, ha olyan hibaüzenetet kapnak, amely szerint a címzettek száma meghaladja a megengedettet. A Microsoft SMTP-szolgáltatás ilyen esetekben nem küldi vissza az üzeneteket, hanem azonnal megnyit egy új kapcsolatot, és folytatja az üzenet küldését a fennmaradó címzetteknek. Ha például a címzettek száma legfeljebb 100 lehet, és olyan üzenet érkezik, amelyet 105 címzettnek küldtek el, a szolgáltatás az első 100 címzetthez egyetlen kapcsolat során juttatja el az üzenetet. Ezután megnyit egy új kapcsolatot, és elküldi az üzenetet a fennmaradó öt címzettnek.

A címzettek számának korlátozása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Az Üzenetek lapon jelölje be az Egy üzenet címzettjeinek száma legfeljebb jelölőnégyzetet, és a beviteli mezőbe gépelje be a kívánt értéket. Ha nem kíván beállítani korlátozást, törölje a jelölést a jelölőnégyzetből.


A „Nem kézbesíthető” értesítőüzenetek tárolása

Amennyiben a Microsoft SMTP-szolgáltatás nem tud kézbesíteni egy üzenetet, „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldi azt a feladónak. Megadhatja azt is, hogy a rendszer a „Nem kézbesíthető” értesítőüzenetek másolatát egy megadott helyre is elküldje. Ha egy „Nem kézbesíthető” értesítőüzenetet nem sikerült kézbesíteni az eredeti üzenet feladójának, a rendszer az üzenet másolatát elhelyezi a Hibás üzenetek tárolókönyvtárában.

A „Nem kézbesíthető” értesítőüzenetek kézbesítése a többi üzenetével megegyező módon történik, tehát a rendszer ezeket is megpróbálhatja többször újraküldeni. Ha egy „Nem kézbesíthető” értesítőüzenetet a beállított maximális számú újraküldési kísérlet során nem sikerült kézbesíteni az eredeti üzenet feladójának, a rendszer az üzenet másolatát elhelyezi a Hibás üzenetek tárolókönyvtárában. A Hibás üzenetek tárolókönyvtárába helyezett üzeneteket már nem lehet kézbesíteni vagy visszaküldeni a feladónak.

A „Nem kézbesíthető” értesítőüzenetek tárolási helyének megadása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Az Üzenetek párbeszédpanel „Nem kézbesíthető” értesítőüzenet másolatának küldése ide mezőjébe gépelje be annak a postafióknak a címét, amelyre az értesítőüzenetek másolatát kéri. Ez bármilyen érvényes SMTP elektronikus levélcím lehet. A funkció kikapcsolásához törölje a jelölést a jelölőnégyzetből.
  3. A Hibás üzenetek tárolókönyvtára mezőbe gépelje be a nem kézbesíthető üzenetek tárolására használni kívánt könyvtár nevét. Alapértelmezés szerint a gyökér:\Inetpub\Mailroot\Badmail könyvtár tölti be ezt a szerepet. Másik mappa megadásához kattintson a Tallózás gombra. A Microsoft SMTP-szolgáltatást futtató számítógép bármelyik másik könyvtárát kijelölheti.


Üzenetek kézbesítése

A kapcsolat felépülése után, ha a fogadó kiszolgáló jelezte, hogy kész az adatok fogadására, el lehet küldeni a kézbesítendő üzeneteket. Ez a rész ismerteti a kézbesítésre vonatkozó beállításokat, többek között az útválasztási beállításokat, illetve a kézbesítési kísérletek számának beállítását:

  • Tudnivalók az üzenetkézbesítési beállításokról
  • Ismétlési kísérletek számának és gyakoriságának beállítása
  • Az üzenetek ugrásszámlálójának beállítása
  • Helyettesítő tartomány beállítása
  • Teljesen minősített tartománynév beállítása
  • Intelligens állomás beállítása
  • DNS-névlekérdezés engedélyezése
  • Üzenetek kézbesítése a Felvételi könyvtár használatával


Tudnivalók az üzenetkézbesítési beállításokról

A Kézbesítés lapon állíthatja be az üzenetek kézbesítésével és az útválasztással kapcsolatos lehetőségeket. A beállítások az alábbiak szerint három kategóriába sorolhatók.

Útválasztási beállítások

  • Intelligens állomás: Itt adhatja meg azt a kiszolgálót, amelyen keresztül a kimenő üzeneteket kézbesíteni szeretné.
  • Üzenetek ugrásszámlálója: A szolgáltatás legfeljebb az itt beállított számú kiszolgálón keresztül vezető útvonalon próbálja elküldeni az üzenetet, mielőtt nem kézbesíthetőnek nyilvánítja.
  • Teljesen minősített tartománynév (FQDN): A levélváltási (message exchanger — MX) bejegyzésekben használandó cím.

Az adatátvitelre vonatkozó beállítások

  • Ismétlési kísérletek száma és gyakorisága: Ez határozza meg, hogy a szolgáltatás legfeljebb hányszor és milyen időközönként próbálkozzon az üzenet elküldésével, mielőtt nem kézbesíthetőnek nyilvánítja.

    Megjegyzés
    A kézbesítés a Felvételi könyvtár használatával is történhet. Ebben az esetben szöveges fájlformátumban létrehozott üzenetet is elküldhet. További információt az Üzenetek kézbesítése a Felvételi könyvtár használatával című témakörben talál.

Adatbiztonsági beállítások

  • Kimeneti adatbiztonság: Itt állíthatja be a hitelesítés és a TLS titkosítás használatát a kimenő üzenetek küldéséhez.
  • DNS-névlekérdezés: Segítségével ellenőrizheti, hogy az üzenetet tényleg a From (Feladó) mezőben szereplő számítógépről és tartományból küldték-e.
  • Helyettesítő tartománynév: Itt állítható be az a tartománynév, amelyre a protokoll Mail From (Feladó) soraiban található helyi tartománynevet le kívánja cserélni. Ez az a név, amelyet a kimenő üzeneteken fel szeretne tüntetni.


Ismétlési kísérletek számának és gyakoriságának beállítása

Amennyiben az üzenetet nem sikerül elsőre kézbesíteni, a Microsoft SMTP-szolgáltatás a Sorkezelő könyvtárból a megadott idő után megpróbálja újra elküldeni. Az ismétlési kísérletek közötti idő igény szerint beállítható. Azt is megadhatja, hogy a szolgáltatás hányszor kísérelje meg az üzenet kézbesítését. Amikor a szolgáltatás eléri a megadott korlátot, az üzenetet „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldi a feladónak, és az Ön által megadott helyre elküldi az üzenet és az értesítőüzenet másolatát. A „Nem kézbesíthető” értesítőüzenet a Sorkezelő könyvtárba kerül, ahol az üzenetekével megegyező kézbesítési folyamaton megy keresztül. Amennyiben a rendszer nem tudja kézbesíteni a „Nem kézbesíthető” értesítőüzenetet, és eléri az ismételt küldési kísérletek maximális számát, az eredeti üzenetet és az értesítőüzenet elhelyezi a Hibás üzenetek tárolókönyvtárában.

Az ismétlési kísérletek számának és gyakoriságának beállítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. Kattintson a Kézbesítés fülre.
  3. Az Első újrapróbálkozás ennyi idő után (perc) mezőben adja meg, hogy a szolgáltatás mennyi idő múlva próbálkozzon az üzenet kézbesítésével, mielőtt az első értesítést elküldené. Ez az idő alapértelmezés szerint 15 perc.
  4. A Második újrapróbálkozás ennyi idő után (perc) mezőben adja meg, hogy a szolgáltatás mennyi idő múlva próbálkozzon az üzenet kézbesítésével, mielőtt a második értesítést elküldené. Ez az idő alapértelmezés szerint 30 perc, ami azt jelenti, hogy a szolgáltatás 30 perccel az első újraküldési kísérlet után próbálja meg másodszor kézbesíteni az üzenetet.
  5. A Harmadik újrapróbálkozás ennyi idő után (perc) mezőben adja meg, hogy a szolgáltatás mennyi idő múlva próbálkozzon az üzenet kézbesítésével, mielőtt a harmadik értesítést elküldené. Ez az idő alapértelmezés szerint 60 perc, ami azt jelenti, hogy a szolgáltatás 60 perccel a második újraküldési kísérlet után próbálja meg harmadszor kézbesíteni az üzenetet.
  6. A Következő újrapróbálkozás ennyi idő után (perc) mezőben adja meg, hogy a szolgáltatás mennyi idő múlva próbálkozzon az üzenet kézbesítésével, mielőtt a következő értesítést elküldené. Ez az idő alapértelmezés szerint 240 perc.

Értesítés késleltetése

A hálózati késleltetések hatásának figyelembevételéhez beállíthat egy késleltetési időt, és a rendszer ebben az esetben csak a megadott késleltetés letelte után küldi el a kézbesítési állapotjelzéseket. A beállítható legkisebb késleltetés 1 perc, az alapértelmezett késleltetés 12 óra, a beállítható leghosszabb időtartam pedig 9999 nap. A beviteli mező melletti legördülő listáról választhatja ki, hogy az időtartamot percben, órában vagy napban kívánja megadni.

Elévülés időkorlátja

Ide gépelheti be azoknak az üzeneteknek az elévülési idejét, amelyeket az összes újrapróbálkozás után és a késleltetési idő leteltével sem sikerült kézbesíteni. A beállítható legrövidebb elévülési idő 1 perc, az alapértelmezett idő 2 óra, a beállítható leghosszabb időtartam pedig 9999 nap. A beviteli mező melletti legördülő listáról választhatja ki, hogy az időtartamot percben, órában vagy napban kívánja megadni.


Az üzenetek ugrásszámlálójának beállítása

A kézbesítés során az üzenetek sokszor számos kiszolgálón keresztül érik el végső céljukat. Beállíthatja, hogy a rendszer az üzeneteket legfeljebb hány kiszolgálón keresztül kézbesítheti. Ezt a számot nevezik ugrásszámnak.

Az ugrásszám beállítása után az SMTP-kiszolgáló megszámolja az üzenetek fejlécének Érkezett (Received) soraiban felsorolt ugrásokat. Amennyiben az Érkezett fejlécmezők száma meghaladja a beállított maximális ugrásszámot, a kiszolgáló „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldi az üzenetet a feladónak.

Az üzenetek ugrásszámlálójának beállítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Speciális kézbesítés párbeszédpanel megnyitásához kattintson a Kézbesítés lapon található Speciális gombra.
  3. Az Ugrások maximális száma mezőbe begépelt érték határozza meg, hogy az üzenet összesen hány ugrást tehet a forrás- és a célkiszolgáló között. Alapértelmezés szerint legfeljebb 15 ugrás engedélyezett.


Helyettesítő tartomány beállítása

A rendszer a helyi tartomány neve helyett a helyettesítő tartománynevet tünteti fel a protokoll Mail From (Feladó) fejlécsoraiban. Ez a helyettesítés csak az első ugrás során következik be.

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Speciális kézbesítés párbeszédpanel megnyitásához kattintson a Kézbesítés lapon található Speciális gombra.
  3. A Helyettesítő tartománynév mezőbe gépelje be azt a tartománynevet, amelyet az üzenetfejlécben a tartomány tényleges neve helyett meg szeretne jeleníteni.

    Megjegyzés

    Az ilyen üzenetekre küldött válaszok kézbesítése mindig a helyettesítő tartománynevet használó virtuális SMTP-kiszolgálón keresztül történik.


Teljesen minősített tartománynév beállítása

Az elektronikus levelezési tartományhoz tartozó IP-címnek szerepelnie kell a tartománynévrendszer (DNS) nyilvántartásában. Az elektronikus levelezési tartományok azonosítása két DNS-bejegyzés segítségével történik. Az esetek többségében a mail exchanger (MX — levélváltási) rekord használatával rendelik egymáshoz az elektronikus levelezési tartományt és az adott tartományhoz rendelt virtuális SMTP-kiszolgáló vagy -kiszolgálók teljesen minősített tartománynevét (FQDN). Az MX rekordban hivatkozott minden SMTP-kiszolgálóhoz tartoznia kell egy address (A - cím) rekordnak. Az A rekord tartalmazza az adott FQDN és a hozzá tartozó IP-cím megfeleltetését.

Lehetőség van arra is, hogy egy elektronikus levelezési tartományhoz kizárólag egy A rekordot használjon. Ebben az esetben az A rekord rendeli hozzá a tartományhoz az adott tartományt kiszolgáló virtuális SMTP-kiszolgáló(k) IP-címét. Ajánlatos azonban kizárólag A rekord helyett MX rekordot is használni, mert az SMTP-szolgáltatás rendszergazdája így meghatározhatja, hogy az adott elektronikus levelezési tartományba üzeneteket küldő levelezési ügyfelek kezelésére mely kiszolgálókat, milyen sorrendben kívánja használni. A Microsoft SMTP-szolgáltatás először mindig az MX rekordot keresi, csak azután nézi az A rekordot, ezért a virtuális kiszolgáló MX rekordok használata esetén jobb teljesítményt nyújthat. Ezen kívül az A rekord egyes esetekben más célt szolgál (például HTTP), míg az MX rekord kifejezetten az SMTP-szolgáltatásoknak van fenntartva. MX rekord használata esetén az egyik kiszolgáló kezelheti például a http://microsoft.com alakú címeket (a HTTP-ügyfelek az A rekordot használják), egy másik kiszolgáló pedig foglalkozhat a felhasznalo@microsoft.com alakú címekkel (az MX rekordot az SMTP-ügyfelek használják).

A Microsoft SMTP-szolgáltatásban kétféleképpen adhat meg teljesen minősített tartománynevet. Használhatja a Vezérlőpult Rendszertulajdonságok párbeszédpanelének Hálózati azonosítás lapján megadott nevet, vagy megadhat egyedi teljesen minősített tartománynevet az éppen beállított virtuális SMTP-kiszolgálóhoz.

A rendszer indításkor automatikusan a Rendszertulajdonságok párbeszédpanel Hálózati azonosítás lapján megadott nevet használja teljesen minősített tartománynévként. Ha akár kézzel, akár egy Windows 2000 tartományba való belépéssel módosítja a nevet, a számítógép a következő indításkor automatikusan az új nevet használja majd teljesen minősített tartománynévként. Ezért ilyenkor nem szükséges módosítani a virtuális kiszolgáló teljesen minősített tartománynevét.

Amennyiben nem szeretné, hogy a szolgáltatás automatikusan a Hálózati azonosítás lapon megadott számítógép- és tartománynevet használja, a Kézbesítés lapról megnyitható Speciális kézbesítés párbeszédpanelen módosítsa a teljesen minősített tartománynevet. A Microsoft SMTP-szolgáltatás ezután már a beállított egyedi nevet használhatja a Hálózati azonosítás lapon megadott helyett.

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Speciális kézbesítés párbeszédpanel megnyitásához kattintson a Kézbesítés lapon található Speciális gombra.
  3. A teljesen minősített tartománynevet gépelje be a Teljesen minősített tartománynév mezőbe.


Intelligens állomás beállítása

A távoli tartományokba küldendő kimenő üzeneteket irányíthatja intelligens állomáson keresztül is, ahelyett, hogy közvetlenül a céltartományba küldené. Ez lehetővé teszi, hogy olyan kapcsolaton, illetve útvonalon küldje az üzeneteket, amelyek közvetlenebbek vagy olcsóbbak más útvonalaknál. Az intelligens állomás beállítási lehetősége hasonló a távoli tartományokhoz megadható útvonaltartomány beállításhoz. A különbség az, hogy egy intelligens állomás kijelölése után a szolgáltatás minden kimenő üzenetet arra a kiszolgálóra irányít, útvonaltartomány megadása esetén pedig csak az adott távoli tartományba küldendő üzeneteket irányítja a kijelölt kiszolgálóra.

Egy távoli tartományhoz még intelligens állomás beállítása esetén is kijelölhet eltérő útvonalat, mert az útvonaltartomány beállítás felülbírálja az intelligens állomásnál megadott címet.

Megjegyzés

Az intelligens állomás azonosításához teljesen minősített tartománynevet vagy IP-címet használhat (de ha módosítja az IP-címet, akkor azt az összes virtuális kiszolgálón meg kell változtatnia). Amennyiben IP-címet használ a kiszolgáló azonosítására, a rendszer teljesítményének növelése érdekében tegye szögletes zárójelek [ ] közé. A Microsoft SMTP-szolgáltatás először egy kiszolgálónevet, utána pedig egy IP-címet keres a mezőben. A szögletes zárójelek egyértelműen jelzik, hogy a megadott érték egy IP-cím, ezért a rendszer nem próbálja megkeresni a DNS-ben az értékhez tartozó címet.

Az intelligens állomás beállítása

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Speciális kézbesítés párbeszédpanel megnyitásához kattintson a Kézbesítés lapon található Speciális gombra.
  3. Az Intelligens állomás mezőbe gépelje be az intelligens állomás kiszolgálónevét. A begépelt karakterlánc a kiszolgáló neve vagy IP-címe lehet.
  4. Amennyiben azt szeretné, hogy a Microsoft SMTP-szolgáltatás először próbálja meg közvetlenül kézbesíteni a távoli üzeneteket, és csak ezután továbbítsa őket az intelligens állomásnak, jelölje be a Közvetlen kézbesítési kísérlet, mielőtt elküldi az intelligens állomásnak jelölőnégyzetet. Alapértelmezés szerint a rendszer minden távoli tartományba küldendő üzenetet az intelligens állomáshoz irányít, és nem kísérli meg a közvetlen kézbesítést.


DNS-névlekérdezés engedélyezése

E jelölőnégyzet bejelölése esetén a Microsoft SMTP-szolgáltatás megpróbálja ellenőrizni, hogy az ügyfél IP-címe megfelel-e az ügyfél által az EHLO/HELO parancsban közölt állomás-, illetve tartománynévnek. Amennyiben a DNS-névlekérdezés sikeres, a rendszer nem módosítja az üzenet ÉRKEZETT (RECEIVED) fejlécszakaszát. Ha a névlekérdezés sikertelen, a szolgáltatás az üzenet ÉRKEZETT (RECEIVED) fejlécszakaszába beírja az „unverified” (nem ellenőrzött) szót az IP-cím után.

Megjegyzés

Ez a szolgáltatás minden bejövő üzenetre megpróbálja ellenőrizni a címet, ezért használata befolyásolhatja a Microsoft SMTP-szolgáltatás teljesítményét. A szolgáltatás kikapcsolásához törölje a jelölést a jelölőnégyzetből.

A DNS-névlekérdezés engedélyezése

  1. A Microsoft Management Console ablakában jelölje ki a virtuális SMTP-kiszolgálót, majd kattintson a Művelet menü Tulajdonságok parancsára.
  2. A Speciális kézbesítés párbeszédpanel megnyitásához kattintson a Kézbesítés lapon található Speciális gombra.
  3. Jelölje be a DNS-névlekérdezés végrehajtása a beérkező üzeneteknél jelölőnégyzetet.


Üzenetek kézbesítése a Felvételi könyvtár használatával

Az üzenetküldés másik módszere, ha a szövegszerkesztő programban megírt üzenetet szöveges fájlként menti és bemásolja a Felvételi könyvtárba. A Microsoft SMTP-szolgáltatás az üzenetet azonnal áthelyezi a Sorkezelő könyvtárba, ezúttal megkezdve a kézbesítési folyamatot.

A szöveges fájlban a levél „borítékjára” vonatkozó adatokat is megadhatja, de ez nem kötelező. A feladó azonosítására az „x-sender” fejléc szolgál. Egyetlen egy címzett azonosítására az „x-receiver” fejlécet használja. Amennyiben több címzettnek küldi az üzenetet, a levélben minden egyes címzetthez külön „x-receiver” fejlécet kell felvennie. A fejléceket a szöveges fájl elejére kell beírnia, elsőként az „x-sender” fejlécet feltüntetve. A fejléceket egy soremeléssel (ENTER leütésével) kell elválasztania az üzenet törzsétől. Annak érdekében, hogy az üzenet szövege jól láthatóan elkülönüljön a fejlécektől, üsse le még egyszer az ENTER (vagy a RETURN) billentyűt. A szöveg vége után egy újabb soremeléssel hagyjon még egy üres sort, hogy a Microsoft SMTP-szolgáltatás tudja, hogy ide kell beszúrnia a formázásra vonatkozó adatokat. Az alábbi példán egy, a boríték adatait is tartalmazó szöveges fájlként mentett üzenet látható.

x-sender: johns@Microsoft.com
x-receiver: mariab@MSN.com
From: johns@Microsoft.com
To: mariab@MSN.com
Subject: Üdvözlet John-tól

Szia!

Megjegyzés

A jobb teljesítmény érdekében lehetőleg a Felvételi könyvtártól eltérő könyvtárban hozza létre az üzenet, majd a másolás és beillesztés módszerével helyezze át oda. Ha a Felvételi könyvtárban írja meg az üzenetet, a Microsoft SMTP-szolgáltatás a fájl készítése közben folyamatosan próbálkozni fog a fájl felvételével és feldolgozásával. A szolgáltatás a megnyitott fájlokat nem tudja feldolgozni.


Tartomány létrehozása vagy törlése

A Microsoft SMTP-szolgáltatás tartományai sem a DNS-beli tartományokkal, sem a Windows 2000 Server tartományaival nem egyeznek meg. A Microsoft SMTP-szolgáltatás tartományaival az üzeneteket lehet rendszerezni a kézbesítéshez.

Ebben a részben a tartományokkal kapcsolatos általános tudnivalók és az alapvető működtetési feladatok leírása található. A rész a következő témaköröket tartalmazza:

  • Tudnivalók a tartományokról
  • Tartomány létrehozása
  • Tartomány törlése

Az alábbi témakörökben a tartományokhoz kapcsolódó tudnivalókról olvashat:

  • A helyi tartományokkal a Helyi tartományok beállítása című témakör foglalkozik részletesebben.
  • A távoli tartományokkal a Távoli tartományok beállítása című témakör foglalkozik.


Tudnivalók a tartományokról

A virtuális SMTP-kiszolgálón legalább egy tartomány - az alapértelmezett tartomány - be van állítva. Ezen kívül további tartományokat is fel lehet venni, és igény szerint helyi vagy távoli tartományként lehet őket beállítani. Az alapértelmezett tartomány kivételével bármelyik tartomány törölhető.

Helyi tartományok

A helyi tartomány a helyi SMTP-kiszolgáló által kiszolgált DNS tartomány. Az SMTP-kiszolgálóra beérkező, helyi tartománynevet tartalmazó üzeneteket a szolgáltatás a Kézbesítési könyvtár segítségével helyileg kézbesíti, vagy, ha ez nem sikerül, egy „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldi a feladónak. A helyi tartományokat időnként kiszolgálótartomány vagy támogatott tartomány néven is szokás emlegetni. A helyi tartománynevet tartalmazó elekronikus levélcímek másik elnevezése helyi címek.

Bármelyik helyi tartomány megadható alapértelmezett, vagy másodlagos tartományként. Alapértelmezett tartomány csak egy van. A szolgáltatás az alapértelmezett tartományt használja a tartományra vonatkozó információt nem tartalmazó üzenetek megjelöléséhez. A másodlagos tartomány az alapértelmezett tartomány helyettesítésére szolgál. Ha egy újonnan hozzáadott tartományt ad meg új alapértelmezett tartományként, a korábbi alapértelmezett tartomány másodlagos tartománnyá változik.

Távoli tartományok

A nem helyi tartományok neve távoli, avagy nem helyi tartományok, a távoli tartományokat tartalmazó elektronikus levélcímek pedig nem helyi címek. A Microsoft SMTP-szolgáltatás a DNS gyűjteményből keresi ki a távoli tartományokat.

Adott távoli tartományhoz megadhat egyedi kézbesítési követelményeket. Ehhez vegye fel a tartományt, és igényei szerint állítsa be. Egy távoli tartomány felvételével lehet például a TLS titkosítás használatát az adott tartomány munkamenetein a Microsoft SMTP-szolgáltatás számára kötelezővé tenni. Az útválasztási beállításokat is módosíthatja, így az adott távoli tartományra küldött üzenetek egy másik távoli tartományra lesznek továbbítva. A tartományokra vonatkozó beállításokat a Tartomány tulajdonságai párbeszédpanelen lehet megadni.


Tartomány létrehozása

A Microsoft SMTP-szolgáltatásban kétféle tartományt hozhat létre, másodlagos és távoli tartományt. A másodlagos tartományok révén az alapértelmezett tartományra mutató, és annak beállításait — egyebek között az ahhoz kijelölt Kézbesítési könyvtárat — használó tartományokat hozhat létre. A másodlagos tartományokba küldött üzeneteket a rendszer az alapértelmezett tartomány nevével jelöli meg.

Azokhoz a tartományokhoz, amelyekbe gyakran küldenek üzeneteket, érdemes távoli tartományt létrehozni. Az egyes távoli tartományokhoz megadhat előre meghatározott kézbesítési útvonalat, vagy a tartománnyal folytatott munkamenetek során kötelezővé teheti a TLS titkosítás használatát. A névben helyettesítő karaktert is használhat, így megadhatja, hogy a létrehozott tartományon belüli összes tartomány esetén ugyanazokat a beállításokat kívánja használni. A név első tagját helyettesítse csillaggal (*), amelyet a pont (.) követ. Az alábbi példa a csillag helyettesítő karakter használatát mutatja be:

*.Microsoft.com
Megjegyzés

A tartományokat létrehozásukat követően nem lehet átnevezni.

Másodlagos tartomány létrehozása a Microsoft Management Console használatával

  1. A Microsoft Management Console ablakában bontsa ki a virtuális SMTP-kiszolgáló csomópontját.
  2. Jelölje ki a Tartományok elemet.
  3. Mutasson a Művelet menü Új parancsára, majd kattintson a Tartomány menüpontra.
  4. Az Új tartomány varázslóban adja meg a helyi (másodlagos) tartomány beállításait.

Távoli tartomány létrehozása a Microsoft Management Console használatával

  1. A Microsoft Management Console ablakában bontsa ki a virtuális SMTP-kiszolgáló csomópontját.
  2. Jelölje ki a Tartományok elemet.
  3. Mutasson a Művelet menü Új parancsára, majd kattintson a Tartomány menüpontra.
  4. Az Új tartomány varázslóban adja meg a távoli tartomány beállításait.
  5. Útvonaltartomány megadásához, hitelesítés használatához a kimenő üzenetek kézbesítésekor, illetve TLS titkosítás használatához jelölje ki a tartományt a részleteket tartalmazó ablaktáblán, kattintson a Művelet menü Tulajdonságok parancsára, majd adja meg a kívánt beállításokat.


Tartomány törlése

A felvett tartományokat igény szerint bármikor törölheti, az egyetlen kivétel az alapértelmezett tartomány. Az alapértelmezett tartomány törléséhez először vegyen fel egy másodlagos tartományt és tegye meg azt a tartományt alapértelmezettnek.

A tartomány törlése

  1. A Microsoft Management Console ablakában bontsa ki a virtuális SMTP-kiszolgáló csomópontját.
  2. Bontsa ki a Tartományok elemet.
  3. A részleteket tartalmazó ablaktáblán jelölje ki a törölni kívánt tartományt.
  4. Kattintson a Művelet menü Törlés parancsára.


Helyi tartományok beállítása

Ez a rész a meglévő helyi tartományokra vonatkozó beállítások megadásába kínál betekintést. A következő témaköröket tartalmazza:

  • Alapértelmezett tartomány megadása
  • Másodlagos tartomány beállítása
  • Kézbesítési könyvtár megadása


Alapértelmezett tartomány megadása

A rendszer az alapértelmezett tartományt használja az olyan címekről érkező üzenetek megjelölésére, amelyekhez nem tartozik tartomány. Minden virtuális SMTP-kiszolgálónak egy alapértelmezett tartománya lehet, amely nem törölhető.

Az alapértelmezett tartomány elnevezéséhez használhatja a Vezérlőpult Hálózatok segédalkalmazásában, a TCP/IP protokoll DNS tulajdonságlapján megadott nevet. Az összes többi szolgáltatás is ezt a tartománynevet használja. Arra is van lehetősége, hogy kijelöljön egy egyedi tartományt, amely kizárólag a Microsoft SMTP-szolgáltatás alapértelmezett tartományaként szolgál.

A rendszer indításkor automatikusan a Vezérlőpult Hálózatok segédalkalmazásában, a TCP/IP protokoll DNS tulajdonságlapján megadott nevet használja alapértelmezett tartománynévként. Ha a DNS tulajdonságlapon módosítja a nevet, a szolgáltatás a következő indításkor automatikusan az új nevet használja majd alapértelmezett tartománynévként. Ezért ilyenkor nem szükséges módosítani a Microsoft SMTP-szolgáltatás alapértelmezett tartományának nevét.

Amennyiben nem szeretné, hogy a szolgáltatás automatikusan a hálózati tartományt használja, az Általános kartonon nevezze meg az alapértelmezett tartományt. A Microsoft SMTP-szolgáltatás ezután már a beállított egyedi nevet használhatja a hálózati tartomány helyett.

Az alapértelmezett tartomány megadása

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és kattintson a Tartományok elemre.
  2. Kattintson az egér jobb oldali gombjával a részletek ablaktáblára, majd kattintson a helyi menü Beállítás alapértelmezettként pontjára.


Másodlagos tartomány felállítása

Létrehozhat másodlagos tartományokat, amelyek neve eltérő, de beállításaik megegyeznek az alapértelmezett tartomány beállításaival. Azokat az üzeneteket, amelyek másodlagos tartománybeli címzettek számára érkeznek, a Microsoft SMTP-szolgáltatás az alapértelmezett tartományhoz kijelölt Kézbesítési könyvtárba helyezi.

Másodlagos tartomány felállítása

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és az egér jobb oldali gombjával kattintson a Tartományok csomópontra.
  2. Mutasson az Új menüpontra, majd kattintson a Tartomány parancsra. Elindul az Új tartomány varázsló.
  3. Az Új tartomány varázslóban a tartomány típusaként válassza a Helyi tartományt, majd kattintson a Tovább gombra.
  4. Gépelje be a másodlagos tartomány nevét, majd kattintson a Befejezés gombra.


Kézbesítési könyvtár megadása

Az alapértelmezett tartományon meg kell adni azt a könyvtárt, ahova a szolgáltatás a bejövő üzeneteket kézbesíti. Azokat az üzeneteket, amelyek másodlagos tartományok számára érkeznek, a Microsoft SMTP-szolgáltatás az alapértelmezett tartományhoz kijelölt Kézbesítési könyvtárba helyezi. Kézbesítési könyvtárként bármilyen könyvtárat kijelölhet, amely a Microsoft SMTP-szolgáltatást tartalmazó számítógépen van, és amelyet még nem jelöltek ki Felvételi könyvtárként. Alapértelmezés szerint a Kézbesítési könyvtár az SMTP Mailroot könyvtár egyik alkönyvtára.

A kézbesítési könyvtár megadása

  1. A részleteket tartalmazó ablaktáblán kattintson az egér jobb oldali gombjával az alapértelmezett tartományra, majd a helyi menü Tulajdonságok pontjára.
  2. A Kézbesítési könyvtár mezőbe írja be a bejövő üzenetk kézbesítéséhez használandó könyvtár nevét. Alapértelmezés szerint a gyökér:\Inetpub\Mailroot\Drop könyvtár tölti be ezt a szerepet. Igény szerint a Tallózás gombra kattintva is kiválaszthatja a könyvtárat. Kézbesítési könyvtárként mindenképpen a Felvételi könyvtártól eltérő könyvtárat kell megadni.


Távoli tartományok beállítása

Adott távoli tartományhoz megadhat egyedi kézbesítési követelményeket. Ehhez vegye fel a tartományt, és igényei szerint állítsa be. Megadhat például egy előre meghatározott kézbesítési útvonalat, kötelezővé teheti a hitelesítést, vagy kötelezővé teheti a TLS titkosítás használatát a tartománnyal létrehozott kapcsolatokon. Ha a távoli tartomány nincs megfelelően beállítva, a Microsoft SMTP-szolgáltatás a tartományba való kézbesítés során nem hajtja végre e műveleteket, csak a szokásos DNS-beli keresést végzi el. Ez a rész a következő témaköröket tartalmazza:

  • Útvonaltartomány beállítása
  • TLS titkosítás engedélyezése távoli tartomány számára
  • Hitelesítés beállítása távoli tartomány számára
  • ATRN beállítása távoli tartomány számára


Útvonaltartomány beállítása

Megadhat egy másik kézbesítési útvonalat, amely esetleg gyorsabb és olcsóbb a közvetlen összeköttetésnél. Annak a kiszolgálónak a nevét vagy IP-címét adja meg, amelyen keresztül az üzeneteket az adott tartománynak kézbesíteni szeretné. Amennyiben IP-címet ad meg a kiszolgáló azonosítására, a rendszer teljesítményének növelése érdekében tegye szögletes zárójelek közé. Ez a beállítás felülbírálja a Kézbesítés kartonon megadott intelligens állomás beállítást.

Az útvonaltartomány megadása

  1. Bontsa ki a kívánt virtuális SMTP-kiszolgáló csomópontot.
  2. Az egér jobb oldali gombjával kattintson a Tartományok csomópontra, majd a helyi menüben mutasson az Új menüpontra, és kattintson a Tartomány parancsra.
  3. Az Új tartomány varázslóval hozzon létre egy Távoli tartományt. A részleteket tartalmazó ablaktáblán kattintson az egér jobb oldali gombjával az új távoli tartományra, majd a helyi menü Tulajdonságok pontjára.
  4. Az Általános karton Útvonaltartomány részén jelölje be Az összes üzenet továbbítása az intelligens állomásnak választógombot, majd gépelje be annak a kiszolgálónak a nevét vagy IP-címét, amelyen keresztül az adott távoli tartományba küldendő üzeneteket kézbesíteni szeretné.

    Megjegyzés

    Az intelligens állomás azonosításához teljesen minősített tartománynevet vagy IP-címet használhat (de ha módosítja az IP-címet, akkor azt az összes virtuális kiszolgálón meg kell változtatnia). Amennyiben IP-címet használ a kiszolgáló azonosítására, a rendszer teljesítményének növelése érdekében tegye szögletes zárójelek [ ] közé. A Microsoft SMTP-szolgáltatás először egy kiszolgálónevet, utána pedig egy IP-címet keres a mezőben. A szögletes zárójelek egyértelműen jelzik, hogy a megadott érték egy IP-cím, ezért a rendszer nem próbálja megkeresni a DNS-ben az értékhez tartozó címet.


TLS titkosítás engedélyezése távoli tartomány számára

Amennyiben a virtuális SMTP-kiszolgálón általában nem kíván TLS titkosítást használni, de az adott távoli tartományhoz a TLS titkosítás jelölőnégyzet bejelölésével engedélyi azt, az SMTP-szolgáltatás az adott távoli tartományhoz való kapcsolódáskor TLS titkosítást használ. A tartományra vonatkozó beállítások mindig felülbírálják a virtuális kiszolgáló beállításait.

TLS titkosítás engedélyezése távoli tartomány számára

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és kattintson a Tartományok elemre.
  2. A részleteket tartalmazó ablaktáblán kattintson a módosítani kívánt távoli tartományra. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. A Kimeneti adatbiztonság párbeszédpanel megnyitásához kattintson az Általános kartonon található Kimeneti adatbiztonság gombra.
  4. Jelölje be a Windows biztonsági csomag választógombot.
  5. Gépelje be a Windows fiók nevét és jelszavát.
  6. Jelölje be a TLS titkosítás jelölőnégyzetet, majd kattintson az OK gombra.
Megjegyzés Amennyiben a távoli tartomány nem támogatja a TLS titkosítás használatát, az üzeneteket „Nem kézbesíthető” értesítőüzenet kíséretében visszaküldi.


Hitelesítés beállítása távoli tartomány számára

A virtuális SMTP-kiszolgálót beállíthatja úgy, hogy hitelesítési igazoló adatokat küldjön a távoli tartománynak, amennyiben a távoli tartomány megköveteli azokat. Kétféle hitelesítési módszer áll rendelkezésre: alapfokú (titkosítatlan szöveg), illetve Windows biztonsági csomag. Alapfokú hitelesítés esetén a rendszer titkosítatlan szöveg formájában küldi el a fióknevet és a jelszót annak a kiszolgálónak, amelyhez kapcsolódik. A Windows biztonsági csomag hitelesítéshez kötelező megadni a Windows fióknevet és jelszót. A hitelesítést igény szerint le is lehet tiltani, többek között az alapértelmezett beállítás használata is ezt eredményezi.

A kiválasztott beállítás felülbírálja a virtuális SMTP-kiszolgáló Hozzáférés kartonon megadott hitelesítési beállításait. Az alábbi táblázat külfönféle beállítási lehetőségeket mutat be.

A virtuális SMTP-kiszolgáló átvitelének fajtái | Hitelesítési beállítás
Általában minden üzenetet több címre küldenek. | A virtuális SMTP-kiszolgáló hitelesítésének kikapcsolása. Amennyiben kötelező hitelesítés miatt nem sikerül az üzenetet valamely címre kézbesíteni, adjon hozzá a címhez egy távoli tartományt. A tartományon ezután kapcsolja be a kiszolgáló által megkövetelt hitelesítési szintet.
Általában minden üzenetet egy címre küldenek, ahol a hitelesítés kötelező. | Határozza meg a kapcsolódáshoz szükséges hitelesítési szintet. Majd használja ugyanezt a hitelesítési szintet a virtuális SMTP-kiszolgálóhoz. Amennyiben ezután az üzenetet más címekre is el kívánja küldeni, állítson be távoli tartományokat és adjon meg eltérő hitelesítési szintet. Ha ezt a beállítást használja, valószínű, hogy a felhasznált fióknév megegyezik az intelligens állomásként beállított számítógép azonosítójával.

A kimenő üzenetek hitelesítésének kikapcsolása

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és kattintson a Tartományok elemre.
  2. A részleteket tartalmazó ablaktáblán kattintson a módosítani kívánt távoli tartományra. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. A Kimeneti adatbiztonság párbeszédpanel megnyitásához kattintson az Általános kartonon található Kimeneti adatbiztonság gombra.
  4. Jelölje be a Névtelen hozzáférés választógombot, majd kattintson az OK gombra.

A kimenő üzenetek alapfokú hitelesítésének bekapcsolása

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és kattintson a Tartományok elemre.
  2. A részleteket tartalmazó ablaktáblán kattintson a módosítani kívánt távoli tartományra. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. A Kimeneti adatbiztonság párbeszédpanel megnyitásához kattintson az Általános kartonon található Kimeneti adatbiztonság gombra.
  4. Kattintson az Alapfokú hitelesítés választógombra.
  5. Írja be a számítógépre való kapcsolódáshoz használandó, érvényes felhasználónevet és jelszót.
  6. Kattintson az OK gombra.

A kimenő üzenetek Windows biztonsági csomag hitelesítésének bekapcsolása

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és kattintson a Tartományok elemre.
  2. A részleteket tartalmazó ablaktáblán kattintson a módosítani kívánt távoli tartományra. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. A Kimeneti adatbiztonság párbeszédpanel megnyitásához kattintson az Általános kartonon található Kimeneti adatbiztonság gombra.
  4. Kattintson a Windows biztonsági csomag választógombra.
  5. Írja be a Windows fiók nevét és jelszavát.
  6. Kattintson az OK gombra.


ATRN beállítása távoli tartomány számára

A Microsoft SMTP-szolgáltatás tárolni tudja az olyan ügyfeleknek szóló üzeneteket, akik nem tartanak fenn állandó kapcsolatot, csak rendszeres időközönként kapcsolódnak üzeneteik letöltéséhez. Ilyen esetben az ügyfél egy ATRN parancsot ad ki, mire a távoli SMTP-szolgáltatás elkezdi küldeni az üzeneteket az ATRN tartományba. Létrehozhat egy távoli tartományt egy olyan cím számára, amely csak rendszeres időközönként ellenőrzi postáját, majd engedélyezheti az ATRN használatát e tartománynak.

ATRN átvitelek engedélyezése távoli tartomány számára

  1. Bontsa ki a virtuális SMTP-kiszolgáló faszerkezetét, és kattintson a Tartományok elemre.
  2. A részleteket tartalmazó ablaktáblán kattintson a módosítani kívánt távoli tartományra. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. Ehhez kattintson a Speciális kartonra, azon belül pedig az Üzenetek besorolása távolról indított kézbesítéshez jelölőnégyzetre.
  4. Az adott tartományban ATRN átvitelekre jogosult Windows 2000 fiókok meghatározásához kattintson a Hozzáadás vagy Eltávolítás gombra.


LDAP-kiszolgálókapcsolatok beállítása

A Lightweight Directory Access Protocol (LDAP) Internet protokoll segítségével a címtár-információ közvetlenül az LDAP-kiszolgálóról is elérhető. Az LDAP használatához szükséges engedélyekkel nem csak böngészni, de olvasni és keresni is tud az LDAP-kiszolgáló címtárlistáiban.

Az LDAP-útválasztás kartonon a Microsoft SMTP-szolgáltatást beállíthatja úgy, hogy a küldők és címzettek címeinek megállapításához szükséges adatokat egy LDAP-kiszolgálótól kérje le. LDAP-kiszolgálóként használhatja például a Windows 2000 Active Directory szolgáltatását, és az Active Directory Felhasználók és számítógépek moduljában létrehozhat olyan csoportos levelezési listát, amely a virtuális SMTP-kiszolgálón automatikusan kibontva, a megfelelő címekkel jelenik meg.

Ez a rész bemutatja, hogy hogyan lehet a Microsoft SMTP-szolgáltatást LDAP-ügyfélként beállítani, és ezáltal hozzáférni az LDAP-kiszolgálón levő címtáradatokhoz. A következő témaköröket tartalmazza:

  • Az LDAP-kapcsolatok beállításához szükséges előzetes lépések
  • Sématípus kiválasztása
  • A hitelesítési szint meghatározása
  • LDAP-útválasztás adatainak megadása


Az LDAP-kapcsolatok beállításához szükséges előzetes lépések

Mivel az LDAP-útválasztás karton némelyik beállítása egyéb beállításokra is kihat, az LDAP beállítása előtt érdemes alaposan átgondolni, hogy mire van szüksége.

  1. Határozza meg, hogy milyen sématípust kíván használni.
  2. Határozza meg az LDAP-címtárhoz való kötéshez szükséges hitelesítési szintet. Amennyiben az adott LDAP-kiszolgáló nem teszi kötelezővé hitelesítés használatát, nem kell a fiók adatait megadni.
  3. Határozza meg, hogy névhasználati környezetet meg kell-e adni. Erre általában akkor van szükség, ha a felhasználói fiókok az LDAP-címtár valamelyik altárolójában találhatók. A névhasználati környezet megadása sokszor felgyorsítja az LDAP-címtár keresését, egyes esetekben pedig — amikor az LDAP-kiszolgálón több névhasználati környezet van használatban — kötelező is megadni.


Sématípus kiválasztása

Az LDAP-útválasztás kartonon található Séma legördülő listából az alábbi sématípusok közül lehet választani.

Sématípus | Leírás
Active Directory | Ezt a lehetőséget választva a Windows 2000 Active Directory-t használhatja LDAP-kiszolgálóként. A postaládák kezeléséhez használja az Active Directory Felhasználók és számítógépek modulját.
Site Server tagsági címtára | Akkor válassza ezt a lehetőséget, ha a Microsoft Commercial Internet System 2.0 verziója Mail moduljának részeként telepítette a Microsoft LDAP-szolgáltatást, és ezt használja a postaládák kezeléséhez.
Exchange LDAP-szolgáltatás | Akkor válassza ezt a lehetőséget, ha a postaládák kezeléséhez Microsoft Site Server 3.0 vagy későbbi verziójú LDAP-kiszolgálót használ.


A hitelesítési szint meghatározása

A kapcsolatokhoz használt hitelesítés szintjét négyfajta kötéstípus határozza meg. A beállítások más beállításokra is hatással vannak.

Kötéstípus | Leírás
Névtelen | A hitelesítés nem kötelező. Akkor használja ezt a beállítást, amikor a kiszolgálón a fiók és a jelszó adatok megadása nem kötelező.
Egyszerű szöveg | Amennyiben ezt a beállítást választja, a fiókadatokat és a jelszavakat titkosítatlan szövegként küldi. A fiók és a jelszó adatok megadása ebben az esetben kötelező.
Windows SSPI | Az ügyfél és a kiszolgáló megegyeznek, hogy milyen szintű, mindkettőjük számára elfogadható hitelesítést használjanak. Mindig a lehető legszigorúbb módszert választják. A fiók és a jelszó adatok megadása ebben az esetben kötelező.
Szolgáltatási fiókok | A rendszer annak a felhasználónak a fiókadatait használja, aki a Microsoft SMTP-szolgáltatást futtatja. Ezt az Adminisztratív eszközök menüpont alatti Összetevők szolgáltatásai parancsra kattintva állíthatja be.


LDAP-útválasztás adatainak megadása

  1. Kattintson a Microsoft Management Console ablakában a kívánt virtuális SMTP-kiszolgálóra, majd a Tulajdonságok parancsra.
  2. Kattintson az LDAP-útválasztás kartonra.
  3. Jelölje be az LDAP-útválasztás engedélyezése jelölőnégyzetet.
  4. Adja meg az alábbi táblázatban ismertetett beállításokat.
Beállítás | Leírás
Kiszolgáló | Ide gépelheti be az LDAP-címszolgáltatást futtató számítógép nevét. Ezt a mezőt nem kell kitöltenie, ha sématípusként az Exchange LDAP-szolgáltatást választja, mert ez a szolgáltatás automatikusan megkeres egy közeli kiszolgálót, és a továbbiakban azt használja.
Séma | Válasszon ki egy sématípust.
Kötés | Válassza ki, hogy milyen hitelesítési módszert kíván használni az LDAP-kiszolgálóval létrehozandó kötéshez. Egyszerű szöveg esetén a jelszavakat a rendszer titkosítatlan szövegben küldi el. Amennyiben a virtuális SMTP-kiszolgálón lehetséges legszigorúbb hitelesítési módszert szeretné használni, válassza a Windows SSPI beállítást. Ha egyáltalán nincs szükség hitelesítésre, használja az alapértelmezés szerinti Névtelen beállítást. Szolgáltatási fiókok beállítás mellett a rendszer mindig annak a személynek az adatait használja, aki éppen kötést próbál létrehozni az LDAP-kiszolgálóval.
Tartomány | Ide gépelheti be annak a fióknak a tartományát, amelyet az LDAP-címtárhoz való kötésre kíván használni. Ezt a mezőt akkor kell kitöltenie, ha Egyszerű szöveg vagy Windows SSPI típusú kötést választott ki.
Felhasználónév | Ide gépelheti be annak a fióknak a megkülönböztetett nevét (DN — distinguished name), amelyet az LDAP-címtárhoz való kötésre kíván használni. Például: cn=user1,ou=users,o=company. Ezt a mezőt akkor kell kitöltenie, ha Egyszerű szöveg vagy Windows SSPI típusú kötést választott ki.
Jelszó | Ide gépelheti be a címszolgáltatásra való bejelentkezéshez szükséges jelszót. Ezt a mezőt akkor kell kitöltenie, ha Egyszerű szöveg vagy Windows SSPI típusú kötést választott ki.
Alap | Ide gépelheti be az elérni kívánt címszolgáltatás valamely tárolójának megkülönböztetett nevét. Ez a beállítás határozza meg, hogy a Microsoft SMTP-szolgáltatás az LDAP-címtáron belül hol kezdje a keresést. A rendszer az itt megadott tárolóban kezdi a keresést, és szükség esetén az altárolókban folytatja.


Alapfogalmak

Az üzenetküldési- és kezelési szolgáltatások az internetes helyek alapvető, széles körben elterjedt szolgáltatásai közé tartoznak. Az internetes üzenetek küldése és kézbesítése általában a Simple Mail Transfer Protocol (SMTP) használatával történik. A Microsoft SMTP-szolgáltatás segítségével a hardverszközök belső hálózaton vagy az Interneten keresztüli üzenetkézbesítésre is beállíthatók.

A Microsoft SMTP-szolgáltatás az SMTP protokoll alapvető kézbesítési funkcióinak támogatása mellett számos egyéb lehetőséget kínál, amelyek révén a rendszer az egyedi kézbesítési és adatbiztonsági követelmények szerint alakítható ki.

Ebben a részben általános tudnivalókat talál a Microsoft SMTP-szolgáltatással kapcsolatban:

  • A Microsoft SMTP-szolgáltatás áttekintése
  • Főbb jellemzők
  • Összetevők
  • A folyamatok áttekintése


A Microsoft SMTP-szolgáltatás áttekintése

Ez a rész általános információt nyújt a Microsoft SMTP-szolgáltatás beállításával kapcsolatban. A következő témaköröket tartalmazza:

  • Tulajdonságlapok
  • A rendszer teljesítményének növelése


Tulajdonságlapok

Hat tulajdonságlapon adhatja meg a Microsoft SMTP-szolgáltatás beállításait. A tulajdonságlapok 3 kategóriába sorolhatók, ismertetésüket az alábbi táblázat tartalmazza.

Folyamat | Tulajdonságlap | Leírás
Kiszolgáló azonosítása és kapcsolatok | Általános | Az itt található beállítások határozzák meg, hogy a kiszolgáló hogyan kapcsolódjon más kiszolgálókhoz üzenetek küldésekor és fogadásakor. A naplózást is ezen a lapon engedélyezheti.
Üzenetek továbbítása | Üzenetek | Az üzenetekre vonatkozó korlátozásokat, valamint a nem kézbesíthető üzenetek feldolgozásának beállítási lehetőségeit tartalmazza.
 | Kézbesítés | Ezektől a beállításoktól függ, hogy a kiszolgáló hogyan kézbesíti az üzeneteket. Itt adható meg például az üzenetek kapcsolatonkénti maximális száma, a kézbesítési útvonal, illetve az ismételt üzenetküldési kísérletek beállításai.
A kiszolgáló biztonsági funkciói | Hozzáférés | Ezen a lapon adható meg az, hogy a rendszer minden bejövő kapcsolaton kötelezővé tegye a hitelesítés és a Transport Layer Security (TLS — az SSL titkosítás minden protokollra alkalmazható fajtája) használatát. Ugyancsak itt szabályozható, hogy egyes számítógépek vagy hálózatok hozzáférhetnek-e a kiszolgálóhoz, illetve hogy használhatják-e azt üzenetek továbbítására.
 | Felügyelők | Itt adhatja meg azokat a felhasználói fiókokat, amelyeket felügyelői jogokkal ruház fel a Microsoft SMTP-szolgáltatás beállításához.
Tartományok | LDAP-útválasztás | Az X.500 könyvtárszerkezetnek megfelelő könyvtárakhoz hozzáférést biztosító Lightweight Directory Access Protocol (LDAP) beállításait tartalmazza.

Az SMTP-szolgáltatás tulajdonságlapjainak megnyitása a Microsoft Management Console ablakából

  1. Jelölje ki a kívánt virtuális SMTP-kiszolgálót.
  2. Kattintson a Művelet menü Tulajdonságok parancsára.
  3. Kattintson a megjeleníteni kívánt tulajdonságlapra.


A rendszer teljesítményének megnövelése

Bizonyos beállítások használata befolyásolhatja a rendszer teljesítményét. Az alábbi lista áttanulmányozásával optimalizálhatja rendszere működését, így csökkentheti az üzenetek feldolgozásához szükséges időt és a kézbesítés során jobban kihasználhatja a kapcsolatokat:

  • Az egy kapcsolat alatt elküldött üzenetek számának korlátozása
  • Zárójelek az intelligens állomás IP-címében
  • A DNS-névlekérdezés kikapcsolása


Főbb jellemzők

A Microsoft SMTP-szolgáltatás főbb jellemzői a következők:

Szabványos internetes protokoll támogatása

A Microsoft SMTP-szolgáltatás minden tekintetben támogatja a Simple Mail Transfer Protocol (SMTP) protokollt, és teljes mértékben kompatibilis az SMTP rendszerű levelezési ügyfélprogramokkal.

Méretezhetőség

Egy kiszolgálón több tartomány is beállítható, így a szolgáltatás egyazon kiszolgálón akár több száz ügyfélkapcsolat kezelésére is lehetőséget nyújt.

Egyszerű felügyelet és integráció a Microsoft Windows 2000 Server operációs rendszerrel

A Microsoft SMTP-szolgáltatás felügyeletét a Microsoft Management Console (MMC) segítségével végezheti el, ez az eszköz az IIS része. Rendszergazdák számára a Windows 2000 Server egyéb felügyeleti eszközei — például a Simple Network Management Protocol (SNMP) protokoll, az eseménynaplók és a tranzakciós naplók — lehetőséget nyújtanak a szolgáltatás használatára vonatkozó statisztikai adatok gyűjtésére, üzenetek és tranzakciók nyomon követésére, valamint a felhasználói szokások elemzésére.

Korszerű adatbiztonsági szolgáltatások

A Microsoft SMTP-szolgáltatás az adatátvitel titkosításához a Transport Layer Security (TLS) használatát támogatja.

Irányított üzenetkézbesítés és -felvétel

A Microsoft SMTP-szolgáltatás beállítható úgy, hogy az alapértelmezett tartományba érkező összes üzenetet közvetlenül egy Kézbesítési könyvtárba helyezze. Ennek köszönhetően a Microsoft SMTP-szolgáltatás más alkalmazások helyett is képes leveleket fogadni.

Az alkalmazások üzenetek küldéséhez csatlakozhatnak egy TCP portra, de használhatják a Felvételi könyvtárat is. A Microsoft SMTP-szolgáltatás automatikusan kézbesít minden olyan üzenetet, amelyet szövegfájlként formázva a Felvételi könyvtárba másolnak.


Összetevők

Ez a rész ismerteti a Microsoft SMTP-szolgáltatás egyes összetevőit, azok funkcióját és együttműködésük módját. A következő témaköröket tartalmazza:

  • Összetevők és a Microsoft Management Console megjelenítési beállításai
  • Az összetevők közötti kapcsolatok
  • A Mailroot könyvtár és az alapértelmezett könyvtárak


Összetevők és a Microsoft Management Console megjelenítési beállításai

A Microsoft Management Console ablakában a számítógépre telepített és konfigurált összes Internet Information Services (IIS) összetevő megjelenik. A Microsoft SMTP-szolgáltatást külön csomópont jelzi a Microsoft Management Console ablakában látható faszerkezetben. Egy csomópont kijelölésével bővebb információt jeleníthet meg a csomópontról a részleteket tartalmazó ablaktáblán. Az alábbi táblázat ismerteti a számítógép és a Microsoft SMTP-szolgáltatás csomópontjait.

Csomópont | Ikon | Leírás
Számítógép | Számítógép | Ez az IIS fő felügyeleti összetevője. Itt láthatók az IIS egyes szolgáltatásaival kapcsolatos tudnivalók, többek között a szolgáltatás működési állapota, IP-címe és portszáma.
Alapértelmezett virtuális SMTP-kiszolgáló | SMTP-hely | Ez a Microsoft SMTP-szolgáltatás fő felügyeleti összetevője. Ezen keresztül érhetők el a hely konfigurációs beállításait tartalmazó tulajdonságlapok. A csomópontra duplán rákattintva megjelenik a tartományok és az aktuális munkamenetek felsorolása.
Tartományok | Tartományok | Ezek a Microsoft SMTP-szolgáltatás alapvető szervezeti összetevői. Ezen a csomóponton keresztül érhető el a Tartomány tulajdonságai párbeszédpanel, amelyen tartományokat hozhat létre és állíthat be, illetve megtekintheti az adott helyen létrehozott tartományok adatait.
Aktuális munkamenetek | Aktuális munkamenetek | A Microsoft SMTP-szolgáltatás aktuális állapotával és használatával kapcsolatos információt nyújt. Ezen a csomóponton keresztül megjelenítheti a kapcsolódó munkamenetek felsorolását, amely minden egyes munkamenetre tartalmazza a felhasználót, a forráshelyet, valamint a kapcsolat fennállásának idejét.


Az összetevők közötti kapcsolatok

A Microsoft SMTP-szolgáltatás és az IIS futtatásához a Microsoft Management Console ablakában megjelenő virtuális SMTP-kiszolgálót használhatja. A rendszer az ezen a kiszolgálón beállított alapértelmezett tartományt használja az olyan üzenetek megjelölésére, amelyekben a feladó címe nem tartalmaz tartománynevet. Az alapértelmezett tartomány nem törölhető, de szükség esetén létrehozhat további, úgynevezett másodlagos tartományokat. Minden másodlagos tartomány az alapértelmezett tartomány nevét használja az üzenetek megjelöléséhez.

A tartományokról a Tartományok áttekintése című témakörben talál további információt.


A Mailroot könyvtár és az alapértelmezett könyvtárak

A Telepítő öt alapértelmezett alkönyvtárat hoz létre a Mailroot könyvtárban, amelyeket a Microsoft SMTP-szolgáltatás az üzenetek feldolgozásához használ. E könyvtárak közül négyet az alábbi táblázat ismertet. A telepítés során létrehozott ötödik, SortTemp nevű könyvtárat a rendszer ideiglenes fájlok tárolására használja. A Mailroot könyvtár alapértelmezett esetben a gyökér:\Inetpub\Mailroot könyvtár, de más helyet is megadhat telepítéskor. Az alábbi táblázat ismerteti a Mailroot könyvtár alkönyvtárait, és azok tartalmát.

Mappa | Leírás
Badmail | Hibás üzenetek tárolókönyvtára: a levél feladójának vissza nem küldhető, nem kézbesíthető üzenetek tárolására szolgál.
Drop | Kézbesítési könyvtár: ebbe a könyvtárba érkezik az adott számítógépen beállított tartományokba küldött összes bejövő üzenet. Kézbesítési könyvtárként bármely könyvtár megadható, kivéve azt, amelyet korábban már megadtak Felvételi könyvtárként.
Pickup | Felvételi könyvtár: a szövegfájlként létrehozott, majd a könyvtárba másolt kimenő üzenetek feldolgozására szolgál. Amikor egy helyesen formázott — az RFC 822 specifikációnak megfelelő — üzenetet a Felvételi könyvtárba másolnak, a Microsoft SMTP-szolgáltatás azonnal begyűjti, és megkezdi kézbesítését.
Queue | Sorkezelő könyvtár: a kézbesítésre váró üzenetek tárolására szolgál. Amennyiben egy üzenet a kapcsolat foglaltsága vagy megszakadása miatt nem kézbesíthető, az üzenet a sorkezelő könyvtárba kerül. A szolgáltatás meghatározott időközönként újra megkísérli az üzenet kézbesítését.


A folyamatok áttekintése

A Microsoft SMTP-szolgáltatás az SMTP protokollt használja üzenetek küldéséhez és kézbesítéséhez, a Request for Comments (RFC) 821 és RFC 822 dokumentumokban megfogalmazott specifikáció szerint. A szolgáltatás elvégzi az üzenetek távoli levelezési kiszolgálók és az alapértelmezett tartományhoz kijelölt Kézbesítési könyvtár közötti továbbításával kapcsolatos összes feladatot. A Microsoft SMTP-szolgáltatás felépítéséből adódóan gyorsan kezeli a kapcsolatokat, ennek köszönhetően másodpercenként a lehető legtöbb üzenet feldolgozására képes.

Ez a rész ismerteti a Microsoft SMTP-szolgáltatással történő üzenettovábbítás és üzenetkézbesítés folyamatát. A következő témaköröket tartalmazza:

  • Üzenetek feldolgozása
  • Helyi üzenetkézbesítés
  • Távoli üzenetkézbesítés


Üzenetek feldolgozása

A szolgáltatás automatikusan a Sorkezelő könyvtárba helyezi a Felvételi könyvtárba másolt, illetve a kijelölt TCP porton (alapértelmezés szerint ez a 25-ös számú) keresztül beérkező üzeneteket. Helyi címzettek esetén a szolgáltatás kézbesíti az üzenetet, távoli címzettek esetén pedig elkezdi feldolgozását távoli kézbesítéshez. Ezt a folyamatot szemlélteti az alábbi ábra.

Helyi és távoli üzenetek feldolgozásának folyamata


Helyi üzenetkézbesítés

A helyi felhasználóknak címzett üzeneteket a rendszer áthelyezi a Sorkezelő könyvtárból az alapértelmezett tartományhoz kijelölt Kézbesítési könyvtárba. A Microsoft SMTP-szolgáltatás kézbesítési ciklusa akkor zárul le, amikor a rendszer elhelyezte az üzenetet a Kézbesítési könyvtárban. A Kézbesítési könyvtár az Alapértelmezett tartomány párbeszédpanelen adható meg. Ezt a folyamatot szemlélteti az alábbi ábra.

SMTP-üzenetek feldolgozásának folyamata


Távoli üzenetkézbesítés

Az alábbi táblázat ismerteti azokat a lépéseket és folyamatokat, amelyeket a Microsoft SMTP-szolgáltatás távoli üzenetek kézbesítésekor végrehajt. A táblázatból azt is megtudhatja, hogy az adott lépéssel kapcsolatos lehetőségeket melyik tulajdonságlapon állíthatja be.

Folyamat | Leírás
Üzenetek rendezése és besorolása a kézbesítéshez. | Az üzenetek ebben a lépésben még a Sorkezelő könyvtárban maradnak. A Microsoft SMTP-szolgáltatás tartomány szerint rendezi az egyes üzenetek címzettjeit, hogy az egy tartományba küldendő üzeneteket egy csoportban küldhesse el. E lépésnek köszönhetően a Microsoft SMTP-szolgáltatás a lehető legoptimálisabban használja ki a kapcsolatokat, hiszen egy munkamenet során több üzenetet kézbesíthet.
Annak megállapítása, hogy a célkiszolgáló készen áll-e üzenetek fogadására. | A Microsoft SMTP-szolgáltatás megpróbál csatlakozni a leveleket fogadó kiszolgálóhoz. Amennyiben a kiszolgáló nem áll készen üzenetek fogadására, az üzenetek továbbra is a várakozási sorban maradnak, és a rendszer mindaddig próbálkozik — a megadott időközönként — kézbesítésükkel, amíg el nem éri a próbálkozások maximális számát. Az ismételt kézbesítési kísérletekre vonatkozó beállításokat a Kézbesítés tulajdonságlapon adhatja meg.
Az üzenet elküldése. A címzettek ellenőrzését követően a szolgáltatás ténylegesen elküldi az egyes üzeneteket. A Microsoft SMTP-szolgáltatás kézbesítési folyamatának akkor van vége, amikor a fogadó kiszolgáló megerősítette az üzenet vételét. A kézbesítésre vonatkozó beállítások a következők:

Amennyiben engedélyezte a Transport Layer Security (TLS) használatát a távoli kézbesítés során, a Microsoft SMTP-szolgáltatás minden kimenő üzenetet titkosít. Távoli tartományok megadásával ezt a szolgáltatást egyes tartományokra is engedélyezheti, illetve letilthatja. A TLS titkosítás a Kimeneti adatbiztonság párbeszédpanelen kapcsolható be, amelynek megnyitásához kattintson a Kézbesítés tulajdonságlap Kimeneti adatbiztonság gombjára.

A távoli tartományba küldendő üzeneteket igény szerint intelligens állomásnak is elküldheti, amely továbbítja azokat a címzetteknek. Az intelligens állomást a Speciális kézbesítés párbeszédpanelen állíthatja be, ennek megnyitásához kattintson a Kézbesítés tulajdonságlap Speciális gombjára.

A Microsoft SMTP-szolgáltatás beállítására használható tulajdonságlapok részletes ismertetését A Microsoft SMTP-szolgáltatás áttekintése című részben találja.


A Microsoft SMTP-szolgáltatás karbantartása

Karbantartás

Ez a rész a folyamatok figyelésével, valamint a hatékony üzenetfeldolgozásra irányuló beállítások elemzésével és módosításával kapcsolatos tudnivalókat ismerteti, továbbá bemutatja, hogy a karbantartási feladatok elvégzéséhez hogyan szüneteltetheti, illetve hogyan állíthatja le a szolgáltatást. Az alábbi témaköröket tartalmazza:

  • Figyelőeszközök ismertetése
  • Rendszerfolyamatok figyelése
  • Az SMTP teljesítményének és beállításainak figyelése
  • Üzenetkezelési tranzakciók figyelése


Figyelőeszközök ismertetése

Az események nyomon követéséhez és a teljesítmény figyeléséhez számos eszköz áll rendelkezésre. Ezeket az eszközöket használhatja hibaelhárítás céljából, vagy azért, hogy megállapítsa, hogy a rendszer az új beállítások mellett ténylegesen jobb teljesítményt biztosít-e.

Windows 2000 Server eseménynapló

A jelzésértékű, figyelmeztető, vagy hibát jelző események alapján állapíthatja meg, hogy a Microsoft SMTP-szolgáltatás helyesen működik-e. Ezeket az eseményeket mindenképpen a rendszergazdának kell feldolgoznia. Háromféle napló áll rendelkezésre: Rendszer, Adatbiztonság és Alkalmazás.

Az előre meghatározott események naplózása a Windows 2000 Server indításakor automatikusan megkezdődik. Az egyes naplókhoz külön-külön meg lehet határozni, hogy méretük maximum mekkora lehet, mennyi ideig tárolják a bejegyzéseket, és, hogy a napló betelésekor automatikusan felülírják-e a korábbi bejegyzéseket, vagy kézzel kell azokat eltávolítani.

Teljesítményfigyelő

Ez méri a Microsoft SMTP-szolgáltatás rendelkezésre állását és jelzi, hogy az elvárásoknak megfelelően működik-e. A Teljesítményfigyelővel bármelyik rendszerösszetevő aktuális feladatairól készülhet statisztika. Az adatok elemzéséből kiderül, hogy kell-e módosítani a beállításokon az üzenetek hatékonyabb feldolgozása céljából. Ehhez azonban be kell kapcsolni a teljesítményfigyelést, és meg kell adni, hogy mely összetevőt kívánja figyelni.

Protokollnapló

Ez az egyes SMTP-tranzakciókat követi nyomon. Használatához először engedélyezze a naplózást, majd határozza meg a frekvenciát és a formátumot.


Rendszerfolyamatok figyelése

Összesen két Windows 2000 Server eseménynapló, a Rendszer és az Adatbiztonság eseménynapló létezik. A Microsoft SMTP-szolgáltatás mindkettőben tájékoztató jellegű, figyelmeztető, illetve hibákat jelző eseményeket rögzít.

A naplókat érdemes állandóan figyelemmel kísérni, és megadott időközönként archiválni, mielőtt a számítógépen elfogyna a szabad lemezterület. Azért, hogy az adatok véletlenül el ne vesszenek, időnként ürítse a naplókat, hogy a Microsoft SMTP-szolgáltatásnak legyen hova írnia az új eseményeket.


Az SMTP teljesítményének és beállításainak figyelése

Ebben a részben a rendszer kialakításának és teljesítményének ellenőrzésére szolgáló Teljesítményfigyelő használatával kapcsolatos tudnivalókról olvashat. A következő témaköröket tartalmazza:

  • A Teljesítményfigyelő áttekintése
  • Teljesítményfigyelés
  • A rendszer kapacitásának figyelése


A Teljesítményfigyelő áttekintése

A rendszer beállítása után érdemes a teljesítmény figyelése alapján leellenőrizni, hogy a rendszer kialakítása megfelel-e az igényeknek. A Teljesítményfigyelővel a rendszer bármelyik objektumának aktuális feladatairól készülhet statisztika. A naplóadatok elemzéséből kiderül, hogy a beállításokon az üzenetek hatékony feldolgozása céljából esetleg kell-e módosítani.

Megadhatja, hogy milyen adatokat kíván naplózni, így a naplózási folyamat teljes mértékben az egyéni igényekhez alakítható. Miután kiválasztotta a rendszerobjektumokat, állítsa be a teljesítmény nyomon követésére irányuló számlálókat. A nyomonkövetés finomhangolásával a rendszergazda reakcióideje csökkenthető. Ennek érdekében állítsa be a Teljesítményfigyelőben az értesítő küldésének lehetőségét, abban az esetben, ha a számláló az Ön által megadott értékhatárt túllépi, vagy az alá esik. A létrehozott adatokat későbbi elemzés céljából táblázatkezelő-programokba vagy adatbázisokba lehet exportálni.

Az alábbi teljesítményfigyelési lehetőségek közül választhat:

  • Egyetlen számítógép, vagy egy több számítógép egyidejű figyelésére egyaránt lehetőség van.
  • A Chart ablakban valósidőben követheti nyomon a teljesítményt, illetve későbbi felhasználás céljából naplókban is elmentheti azokat.

A Teljesítményfigyelővel kapcsolatban bővebb információ a Windows 2000 Server dokumentációjában és súgójában található.


Teljesítményfigyelés

Az üzenetek feldolgozása mellett az SMTP-kiszolgáló kapcsolatait is nyomon követheti. A jelentősebb számlálók:

Számláló | Normális értékek | Leírás
Helyi sor hossza | 0 | A helyi sorban várakozó üzenetek száma. Ha >0, a kiszolgálóhoz több üzenet érkezik, mint amennyi feldolgozására képes. A szám hirtelen megemelkedése esetén próbálja meg kideríteni, mi hátráltatja a feldolgozást.
Távoli sor hossza | 0 | A távoli sorban várakozó üzenetek száma. Ha >0, a kiszolgálóhoz több üzenet érkezik, mint amennyi feldolgozására képes. A szám hirtelen megemelkedése esetén próbálja meg kideríteni, mi hátráltatja a feldolgozást.
Bejövő kapcsolatok aktuális száma | >0 | A bejövő kapcsolatok száma az adott időpontban. Ha az érték hosszabb távon 0, valószínűleg hálózati problémákkal áll szemben.


A rendszer kapacitásának figyelése

Az aktuális kihasználtság és a rendelkezésre álló erőforrások összehasonlításával megállapíthatja, hogy mutatkozik-e hiány az erőforrások terén. A Microsoft SMTP-szolgáltatás kapacitásának figyelemmel kíséréséhez mind a fizikai erőforrások, mind a Microsoft SMTP-szolgáltatás kapacitásának alakulását figyelje meg. A fizikai erőforrások esetében akkor beszélünk a kapacitás teljes kihasználtságáról, ha az adott erőforrás a működési idő 100 százalékában foglalt. Egy szolgáltatás akkor éri el kapacitásának felső korlátját, amikor a beérkező kéréseket már nem képes időben, késés nélkül kezelni.

Megjegyzés

A fizikai erőforrások kapacitásának figyeléséhez be kell kapcsolni a diskperf teljesítményfigyelőt. A megfigyelni kívánt kiszolgálón adja ki a diskperf -y parancsot, majd indítsa újra a számítógépet.

Az alábbi táblázat ismerteti, hogy mely objektumokat célszerű figyelemmel kísérni, és hogy ehhez mely számlálók használhatók.

Objektum | Számláló | Normális értékek | Leírás
Logikai lemez | Lemez kihasználtsága (%) | <70% | Az indítás óta eltelt időnek az a része százalékban megadva, amikor a kijelölt lemezmeghajtó olvasási vagy írási kérések feldolgozása miatt foglalt volt. Amennyiben ez az érték folyamatosan 70% fölött van, érdemes lehet rendszerbe állítani egy újabb SMTP-kiszolgálót.
Rendszer | A processzorok kihasználtsága (%) | <70% | A működési időnek az az átlagos része százalékban megadva, amikor a rendszer összes processzora nem üresjárati végrehajtási szálak futtatása miatt foglalt. Amennyiben egy többprocesszoros rendszer mindegyik processzora állandóan foglalt, ez az érték 100%. Ha az összes processzor az idő 50%-ában foglalt, az érték 50%. Ha a processzorok egy negyede az idő 100%-ában foglalt, az érték 25%. Ez az érték jelzi, hogy a processzorok az idő mekkora részét töltik hasznos munkával. A rendszer minden processzorhoz kijelöli az üresjárati (idle) folyamat egy üresjárati végrehajtási szálát. Ez a szál fut a processzoron azokban az órajelciklusokban, amikor más — hasznos tevékenységet végző — szál nem használja a processzort.
Memória | Rendelkezésre álló bájtok | >a teljes memória 10%-ánál | A Nullázott (Zeroed), Szabad (Free) és Készenléti (Standby) listákon éppen rendelkezésre álló virtuális memória méretét mutatja. A nullázott és a szabad memória bármely folyamat által felhasználható, a különbség csak az, hogy a nullázott memóriaterületet a rendszer feltöltötte nullákkal. A készenléti memória valamelyik folyamat munkakészletébe tartozó, onnan kivett, de rendelkezésre álló memória. Fontos tudni, hogy ez a számláló mindig pillanatnyi értéket, nem egy megadott időszak átlagát mutatja.


Üzenetkezelési tranzakciók figyelése

Ebben a részben megtudhatja, hogyan használhatja a tranzakciós naplókat az üzenetkezelési tranzakciók figyelemmel kísérésére. A rész a következő témaköröket tartalmazza:

  • A protokollnaplózás áttekintése
  • Naplóformátumok
  • Naplóformátumok összehasonlítása
  • Tervezés
  • A protokollnaplózás engedélyezése


A protokollnaplózás áttekintése

A protokollnaplók azokat a parancsokat követik nyomon, amelyeket az SMTP-ügyfél a virtuális SMTP-kiszolgálónak küld.

Összesen négy naplóformátum áll rendelkezésre, melyek általában ugyanazokat az adatokat követik nyomon, azzal a különbséggel, hogy különféle elemzési célokból mennyire részletesen és milyen formában jelenítik meg az adatokat. A formátum kiválasztásakor gondolja át, hogy mi mindent szeretne figyelni, az adatokat milyen formában kívánja elemezni, illetve, hogy a többi IIS-szolgáltatástól érkező tranzakciót hogyan kívánja nyomon követni. További információ a Tervezés címszó alatt található.

A szolgáltatás alapértelmezés szerint a W3C bővített naplófájl formátumot használja, de ezt igény szerint bármikor módosíthatja. A formátumok közül három szöveges fájlba írja a tranzakciókat. Ön határozza meg, hogy a naplózásra milyen időközönként kerüljön sor, és, hogy a fájl mérete maximum mekkora lesz. Amikor a fájl eléri a megadott méretet, a naplózás egy új fájlban folytatódik. A régi fájlokról készítsen biztonsági másolatot és törölje őket a számítógépről, hogy az aktuális tranzakciónapló-fájl készítéséhez mindig legyen elég szabad lemezterület. A negyedik formátummal egy ODBC-megfelelő adatbázisban gyűjtheti össze az adatokat.

Megjegyzés

A naplóformátumok és az alapértelmezett fájlnevek teljes mértékben megegyeznek a többi IIS-szolgáltatás által használtakkal. Mielőtt a Microsoft SMTP-szolgáltatáshoz kiválasztja a formátumot, gondolja át, hogy az egyes szolgáltatások esetében mi mindent kíván naplózni, összesen mennyi fájlt akar használni, és maximum mekkora lehet a fájlok mérete. További információ a Tervezés címszó alatt található.


Naplóformátumok

Összesen négy naplóformátum közül választhat a tranzakciók naplózásához. Az egyes naplóformátumok összehasonlítása, illetve a naplók példákkal illusztrált részletes leírása az alábbi hivatkozásokon keresztül érhető el.

  • Naplóformátumok összehasonlítása
  • Microsoft IIS naplófájlformátum
  • NCSA általános naplófájlformátum
  • W3C bővített naplófájlformátum
  • ODBC-naplózás


Naplóformátumok összehasonlítása

Az alábbi példák bemutatják, hogy a négyféle naplóformátumban hogyan kerülnek rögzítésre és hogyan jelennek meg az üzenetkezelési tranzakciókra vonatkozó adatok. Az SMTP-tranzakciókról készült naplóbejegyzések általában több rekordból állnak. Ez a példa minden formátumhoz csak egy rekordot mutat be, amely szemlélteti a formátumok közötti különbségeket.

Mariab, az Nwtraders.com felhasználója 1997. augusztus 18-án, körülbelül délután 1:17-kor levelet küld a Microsoft-nál dolgozó egyik munkatársának.

Microsoft IIS naplófájlformátum

10.456.789.1, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<mariab@Nwtraders.com>,

NCSA általános naplófájlformátum

10.456.789.1 - Nwtraders.com [18/Aug/1997:13:17:37 - 0800] "MAIL FROM -? FROM: mariab HTTP/1.0 250 0

W3C bővített naplófájlformátum

Az alábbi példa csak az alapértelmezett mezőket tartalmazza. Szükség esetén továbbiakat is felvehet.

13:17:37 10.456.789.1 MAIL FROM - 250

ODBC-naplózás

Az adatbázis a következő rekordokat tartalmazza:

  • Ügyfél IP-címe
  • Ügyfél tartományneve
  • Kapcsolódás dátuma és időpontja
  • IIS szolgáltatás
  • Kiszolgáló-számítógép neve
  • Kiszolgáló IP-címe
  • Feldolgozási idő ezredmásodpercben
  • A kiszolgáló által fogadott bájtok száma
  • A kiszolgáló által elküldött bájtok száma
  • SMTP-protokoll szerinti válaszkód
  • Win32 állapot- vagy hibakód
  • SMTP-protokoll szerinti parancs
  • Címzett
  • Paraméterek


Microsoft IIS naplófájlformátum

  • Az információ vesszővel elválasztott ASCII szövegfájlba kerül.
  • Kizárólag a megadott adatok használhatók, a napló testreszabására nincs lehetőség.
  • Egyetlen adatátvitelhez több rekord tartozik.

A teljes listák megtekintéséhez kattintson az alábbi hivatkozásokra.

10.123.12.3,   Nwtraders.com,  8/18/97,  13:17:37,  SMTPSVC1, MAIL01,  10.200.200.1,  90, 42,  0,  250,  0,  MAIL FROM,  -,FROM:<mariab@Nwtraders.com>,
10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 0, 32, 0, 250, 0, RCPT TO, -, TO:<cim@MSN.com>,
10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 270, 480, 101, 250, 0, DATA, -, 0019E3517201287MAIL01,
10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 81, 4, 52, 0, 541, QUIT, -, MAIL01,


Microsoft IIS naplófájlbejegyzések

10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<mariab@Nwtraders.com>,

Mező | Példa
Ügyfél IP-címe | 10.123.12.3
Ügyfél tartományneve | Nwtraders.com
Kapcsolódás dátuma | 8/18/97
Kapcsolódás időpontja | 13:17:37
IIS-szolgáltatás és helyszín száma | SMTPSVC1
Kiszolgáló-számítógép neve | MAIL01
Kiszolgáló IP-címe | 10.200.200.1
Feldolgozási idő ezredmásodpercben | 90
Fogadott bájtok | 42
Elküldött bájtok | 0
SMTP-protokoll szerinti válaszkód | 250
Win32 állapot- vagy hibakód | 0
SMTP-protokoll szerinti parancs | MAIL FROM
Opcionális mező | -
Változó mező (protokollparancstól függő) | FROM:<mariab@Nwtraders.com>


W3C bővített naplófájlformátum

  • Ez a Microsoft SMTP-szolgáltatás és a többi IIS-szolgáltatás alapértelmezett naplóformátuma.
  • Az adatok változók, igény szerint kiválasztható, hogy mit kíván nyomon követni.
  • Ezzel a formátummal könnyen korlátok között tartható a napló mérete.
  • Az információ ASCII szöveges fájlba kerül.
  • Ez a formátum olyan mezőbeállításokat is lehetővé tesz, amelyek csak webes és FTP-szolgáltatások esetén használhatók.
  • Egyetlen adatátvitelhez több bejegyzés tartozik.

A teljes listák megtekintéséhez kattintson az alábbi hivatkozásokra.

1997-08-18  13:17:37  10.321.255.1  Nwtraders.com  MAIL01,   10.200.200.1  MAIL FROM  -  -  250  -  357  0  90  -  -  -  -
1997-08-18 13:17:37 10.255.255.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 RCPT TO - +TO:+<cim@MSN.com> 250 0 0 33 0 - - -
1997-08-18 13:17:37 10.255.255.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 DATA - 001b60731171d87 250 0 101 1209 250 0 - - -
1997-08-18 13:17:37 10.255.255.1 Nwtraders.com SMTPSVC1 MAIL01 19.200.200.1 QUIT - Nwtraders.com 0 3215 52 4 291 0 - - -


W3C bővített naplófájl-bejegyzések

Ezek a Microsoft SMTP-szolgáltatás naplóbejegyzései, amelyek némelyike eltér a webes és FTP-bejegyzésektől. Azokban a szöveges értéket tartalmazó mezőkben, amelyek nem vonatkoznak a Microsoft SMTP-szolgáltatásra, a naplófájlban kötőjel (-) vagy nulla (0) látható. A számértéket tartalmazó mezőkben a naplófájlban nulla (0) látható. Az alábbi táblázatban látható, félkövér szöveggel kiemelt mezők a naplófájl alapértelmezett bejegyzéseit jelölik.

Mező | Naplómező | Leírás
Dátum | date | Kapcsolódás dátuma
Idő | time | Kapcsolódás időpontja
Ügyfél IP-címe | c-ip | A kiszolgálóhoz kapcsolódott ügyfél IP-címe
Ügyfél tartományneve | cs-username | A kiszolgálóhoz kapcsolódott ügyfél
Szolgáltatás neve | s-sitename | IIS szolgáltatás
Kiszolgáló neve | s-computername | Az a kiszolgáló, amelyen a naplóbejegyzés készült
Kiszolgáló IP-címe | s-ip | Annak a kiszolgálónak az IP-címe, amelyen a naplóbejegyzés készült
Módszer | cs-method | Az ügyfél által küldött SMTP-protokoll szerinti parancs
Univerzális erőforrás-azonosítótő | cs-uri-stem | A Microsoft SMTP-szolgáltatás esetén nem használt mező
Univerzális erőforrás-azonosító lekérdezése | cs-uri-query | A Microsoft SMTP-szolgáltatás esetén változó, az SMTP-protokoll szerinti parancstól függ
HTTP állapot | sc-status | SMTP-protokoll szerinti válaszkód
Win32 állapot | sc-win32-status | Windows 2000 Server állapot- vagy hibakód, 0 a feladat sikeres végrehajtását jelzi
Elküldött bájtok | sc-bytes | A kiszolgáló által elküldött bájtok száma
Fogadott bájtok | cs-bytes | A kiszolgáló által fogadott bájtok száma
Felhasznált idő | time-taken | A művelethez szükséges idő ezredmásodpercben megadva
Kiszolgáló portszáma | s-port | A Microsoft SMTP-szolgáltatás esetén nem használt mező
Felhasználói ügynök | cs(User-Agent) | A Microsoft SMTP-szolgáltatás esetén nem használt mező
Cookie | cs(Cookie) | A Microsoft SMTP-szolgáltatás esetén nem használt mező
Referáló | cs(Referrer) | A Microsoft SMTP-szolgáltatás esetén nem használt mező


NCSA általános naplófájlformátum

  • Az információ ASCII szöveges fájlba kerül, amely a National Center for Supercomputing Applications (NCSA) által kifejlesztett formátumot használja.
  • Kizárólag a megadott adatok használhatóak, a napló testreszabására nincs lehetőség.
  • Egyetlen adatátvitelhez több rekord tartozik.

A teljes listák megtekintéséhez kattintson az alábbi hivatkozásokra.

10.321.255.1 -  Nwtraders.com  [18/Aug/1997:13:17:37 - 0800] "MAIL FROM -? FROM: mariab HTTP/1.0"  250 0
10.321.255.1 - Nwtraders.com[18/Aug/1997:13:17:37 - 0800] "RCPT TO -? TO: address@MSN.com HTTP/1.0" 250 0
10.321.255.1 - Nwtraders.com[18/Aug/1997:13:17:37 - 0800] "DATA -?000B72730441764MAIL01 HTTP/1.0" 250 97
10.321.255.1 - Nwtraders.com[18/Aug/1997:13:17:37 - 0800] "QUIT -?mariab HTTP/1.0" 0 0


NCSA általános naplófájlformátum

Az NCSA általános naplófájlformátum bejegyzései

10.321.255.1 - Nwtraders.com [18/Aug/1997:13:17:37 - 0800] "MAIL FROM -? FROM: mariab HTTP/1.0" 250 0

Mező | Példa
Ügyfél IP-címe | 10.321.255.1
Ügyfél tartományneve | Nwtraders.com
Kapcsolódás dátuma és időpontja | [18/Aug/1997:13:17:37 - 0800]
SMTP-protokollparancs és kapcsolódó információ | "MAIL FROM -? FROM: mariab HTTP/1.0"
SMTP-protokoll szerinti válaszkód | 250
Elküldött bájtok | 0


ODBC-naplózás

  • Ahhoz, hogy ezt a formátumot egyáltalán használhassa, először létre kell hoznia egy ODBC-kompatibilis adatbázist.
  • A rendszer ebbe az adatbázisba írja az adatokat.
  • Egyetlen adatátvitelhez több rekord tartozik.

Az alábbi táblázat az ODBC-formátumú tranzakciós naplófájl mezőinek és adattípusainak leírását tartalmazza.

Mezőnév | Adattípus | Leírás
ClientHost | varchar(255) (max. 255 karakternyi szöveg) | Ügyfél IP-címe
Username | varchar(255) (max. 255 karakternyi szöveg) | Ügyfél tartományneve
LogTime | datetime (dátum/idő) | Kapcsolódás dátuma és időpontja
Service | varchar(255) (max. 255 karakternyi szöveg) | IIS-szolgáltatás
Machine | varchar(255) (max. 255 karakternyi szöveg) | Számítógép neve
ServerIP | varchar(50) (max. 50 karakternyi szöveg) | Kiszolgáló IP-címe
ProcessingTime | integer (egész szám) | Feldolgozási idő ezredmásodpercben
BytesRecvd | integer (egész szám) | A kiszolgáló által fogadott bájtok száma
BytesSent | integer (egész szám) | A kiszolgáló által elküldött bájtok száma
ServiceStatus | integer (egész szám) | SMTP-protokoll szerinti válaszkód
Win32Status | integer (egész szám) | Windows 2000 Server állapot- vagy hibakód (0 a feladat sikeres végrehajtását jelzi)
Operation | varchar(255) (max. 255 karakternyi szöveg) | SMTP-protokoll szerinti parancs
Target | varchar(255) (max. 255 karakternyi szöveg) | Címzett
Parameters | varchar(255) (max. 255 karakternyi szöveg) |


Protokollnaplók megtervezése

Az alábbi információ áttanulmányozása segít eldönteni, hogy milyen naplózást érdemes használni a Microsoft SMTP-szolgáltatáshoz, illetve a többi IIS-szolgáltatáshoz.

Az alapértelmezett beállítások használata

Amennyiben minden IIS-szolgáltatáshoz az alapértelmezett beállításokat használja, minden szolgáltatáshoz naponta készül tranzakciós napló. A naplók formátuma különböző. A webes és FTP-szolgáltatások a W3C bővített naplóformátumot használják alapértelmezett formátumként. Ezeknek a szolgáltatásoknak a tranzakciói együtt, ugyanabba a fájlba kerülnek, és a formátum alapértelmezett beállításait használják. A Microsoft SMTP-szolgáltatás a Microsoft IIS naplófájl formátumot használja alapértelmezett formátumként. A tranzakciók külön-külön fájlba kerülnek.

Melyik formátumot érdemes használni?

Az IIS-szolgáltatások alapértelmezett formátumai eltérőek. Amennyiben az összes szolgáltatás rekordjait egy fájlban kívánja rögzíteni, minden szolgáltatáshoz ugyanazt a formátumot kell használnia. A formátum kiválasztásakor döntse el azt is, hogyan kívánja az adatokat megjeleníteni és megtekinteni. A négy formátum közül három ASCII szöveges fájlban rögzíti a bejegyzéseket, melyek némelyike szóközzel elválasztott, más vesszővel elválasztott formátumot használ. A negyedik opcióval egy ODBC-megfelelő adatbázisba írja a rekordokat.

A naplófájl beállításának meghatározása

A tranzakciós naplófájlok beállításakor három dolgot kell figyelembe venni.

Elem | Leírás
Bejegyzés készítésének gyakorisága | Itt határozhatja meg, hogy naponta, hetente, vagy havonta kívánja-e a fájlokat naplózni.
Naplófájl tartalma | Itt adhatja meg, hogy milyen információt szeretne a naplófájlban rögzíteni. Amennyiben minden IIS-szolgáltatás esetében az alapértelmezett fájlneveket és ugyanazt a formátumot használja, a tranzakciós bejegyzéseket akár egy naplófájlban is egyesítheti. Ha minden szolgáltatáshoz ugyanazt a formátumot használja, de a Microsoft SMTP-szolgáltatást külön fájlban szeretné naplózni, adjon meg egy külön fájlt a tranzakciós naplóhoz.
Naplófájl mérete | Itt határozhatja meg, hogy kívánja-e korlátozni a fájl méretét, és ha igen, milyen mértékben.


A protokollnaplózás engedélyezése

A portokollnaplózást az Általános kartonon engedélyezheti, illetve itt választhatja ki a kívánt naplóformátumot. A naplófájl beállításához nem árt tudni, hogy a naplóformátumok és az alapértelmezett fájlnevek megegyeznek az IIS többi szolgáltatása által használt formátumokkal és nevekkel. Amennyiben az alapértelmezett neveket választja, az összes szolgáltatás minden tranzakcióját ugyanabban a fájlban rögzíti. Ahhoz, hogy az egyes szolgáltatások tranzakcióit külön tartsa nyilván, minden szolgáltatáshoz külön fájlt kell létrehozni.

Az alapértelmezettől eltérő helyen létrehozott naplófájl esetén mindenképpen helyi meghajtót, ne hálózati helyet adjon meg.

ASCII szöveges formátumot használó naplózás engedélyezése

  1. Mutasson a Start menü Programok elemére, majd a Rendszergazda eszközei (Általános) menüpontra, azon belül pedig kattintson a Számítógép-kezelés parancsra.
  2. A Számítógép-kezelés faszerkezetében bontsa ki az Internet Information Services csomópontot.
  3. Az egér jobb oldali gombjával kattintson egyet az Alapértelmezett virtuális SMTP-kiszolgáló elemen, majd a helyi menüben válassza a Tulajdonságok parancsot.
  4. Az Általános kartonon kattintson a Naplózás engedélyezése jelölőnégyzetbe.
  5. Az Aktív naplóformátum legördülő listából válassza ki a kívánt tranzakciós naplóformátumot.
  6. Kattintson a Tulajdonságok gombra, majd határozza meg a naplófájl méretét és helyét.
  7. W3C bővített naplóformátum esetén kattintson a Extended Properties kartonra, majd válassza ki a nyilvántartandó elemeket.

ODBC formátumot használó naplózás engedélyezése

  1. Hozzon létre egy ODBC-nek megfelelő adatbázist.
  2. A Computer Management konzol faszerkezetében bontsa ki az Internet Information Services csomópontot.
    3. Right click the Az egér jobb oldali gombjával kattintson egyet az Alapértelmezett virtuális SMTP-kiszolgáló elemen, majd a helyi menüben válassza a Tulajdonságok parancsot.
  3. Az Általános kartonon kattintson a Naplózás engedélyezése jelölőnégyzetbe.
  4. Az Aktív naplóformátum legördülő listából válassza ki az ODBC-naplózás naplóformátumot.
  5. Kattintson a Tulajdonságok gombra, majd határozza meg a naplófájl méretét és helyét.


Microsoft SMTP-szolgáltatás

ODBC-nek megfelelő adatbázis létrehozása.

  1. A Microsoft Access vagy a Microsoft SQL Server adatbázis-kezelő programmal hozzon létre egy ODBC-nek megfelelő adatbázist.
  2. Az alábbi táblázatban megadott mezők alapján hozzon létre egy táblát az adatbázisban.

    A mező neve | Adattípusa
    ClientHost | varchar(255)
    Username | varchar(255)
    LogTime | datetime
    Service | varchar(255)
    Machine | varchar(255)
    ServerIP | varchar(50)
    ProcessingTime | egész szám
    BytesRecvd | egész szám
    BytesSent | egész szám
    ServiceStatus | egész szám
    Win32Status | egész szám
    Operation | varchar(255)
    Target | varchar(255)
    Parameters | varchar(255)


Hibaelhárítás

Ez a rész a szolgáltatás működtetése során gyakorta előforduló problémák megoldásához kínál segítséget. A hibaelhárítási módszer részletes leírása az alábbi témakörökhöz áll rendelkezésre:

  • A hibaelhárítással kapcsolatos általános tudnivalók
  • Kézbesítés
  • Rendszer
  • Microsoft SMTP-szolgáltatás


A hibaelhárítással kapcsolatos általános tudnivalók

Az átvitelek figyelése alapján kiderül, hogy az esetleges problémák elkerülése céljából szükség van-e a szolgáltatás beállításainak módosítására. Amennyiben a hibák ennek ellenére is jelentkeznének, a hibaelhárításhoz többféle lehetőség áll rendelkezésre.

Megadott időközönként történő ellenőrzések

A rendszer megfelelő beállítása mellett az átvitelek megadott időközönként ellenőrizhetőek, így megelőzhetőek a szűk keresztmetszet okozta problémák.

Adjon meg egy postaládát a „Nem kézbesíthető” értesítőüzenetek és a nem kézbesíthető üzenetek fogadásához

A Microsoft SMTP-szolgáltatásban nem lehet postaládákat létrehozni. Ezzel szemben megadhatja egy másik kiszolgálón levő, létező postaláda nevét és elérési útvonalát, hogy a szolgáltatás a „Nem kézbesíthető” értesítőüzeneteket és magukat a nem kézbesíthető üzeneteket oda továbbítsa. Hozzon létre például egy Postamester nevű postaládát valamelyik ügyfélen. Amikor ezt a beállítást megadta, bármikor (és folyamatosan) ellenőrizheti az értesítőüzeneteket és a nem kézbesíthető üzeneteket, így korán beazonosíthatóak az átvitellel kapcsolatos problémák. A nem kézbesíthető üzenetek a .bad kiterjesztést kapják.

Használjon teljesítményszámlálókat a kiszolgáló terhelésének felméréséhez és a szűk keresztmetszetet jelentő összetevők beazonosításához

A Teljesítményfigyelő kifejezetten az adatfolyam feldolgozásának nyomon követésére szolgál. A számlálók adatait ajánlatos időnként leellenőrizni, és a problémák elkerülése végett a beállításokat ez alapján módosítani. Többek között lehetőség van a sorban álló üzenetek számának figyelésére, a kapcsolatok számának, az újrapróbálkozások és a címzettek átlagának, valamint az elküldött bájtok számának figyelésére. A Teljesítményfigyelő a Windows 2000 Server adminisztrációs eszköze. Amennyiben valamelyik számláló értéke hirtelen megnőne, mindenképpen ajánlatos az okokat felkutatni és a szükséges módosításokat megtenni.

A Teljesítményfigyelővel kapcsolatban bővebb információ Az SMTP teljesítményének és beállításainak figyelése címszó alatt található.

Problémák megoldása

Hiba előfordulása esetén az alábbi módszerekkel állhat neki a hibakeresésnek.

Ellenőrizze az Eseménynaplóban rögzített eseményeket

A Microsoft SMTP-szolgáltatás és a számítógép többi folyamatának eseményeit a Rendszer, az Alkalmazás és az Adatbiztonság eseménynaplók rögzítik. Az események a naplókban kielemezhetőek, így meghatározható, hogy mi okozta az egyes hibákat.

Ellenőrizze a Sorkezelő könyvtárban levő .rtr fájlokat, hogy kiderüljön, miért nem sikerült az üzeneteket kézbesíteni

Az üzenetek sikertelen kézbesítésének oka sokféle lehet. Előfordulhat, hogy a távoli kiszolgáló nem áll rendelkezésre és a sorkezelő könyvtárban egyre több üzenet várakozik, vagy mert az üzenetek különféle okból kifolyóan nem kézbesíthetőek. Ebben az esetben nyissa meg a Sorkezelő könyvtárban található távoli átirat (remote transcript) fájlokat (.rtr), melyek alapján kideríthető, hogy miért nem sikerült az üzenetet elsőre kézbesíteni, illetve, hogy miért várakozik az üzenet még mindig az újraküldésre.


Kézbesítés

A kézbesítéssel kapcsolatos problémák általában a lemezterület hiányára, illetve a hibásan megadott elérési útvonalakra vezethetők vissza. Ebben a részben a következő hibaelhárítási témakörökről lesz szó:

  • A szolgáltatás nem kézbesíti az üzeneteket a Kézbesítési könyvtárba.
  • A szolgáltatás nem kézbesíti az üzeneteket a megadott távoli tartománynak.
  • A távoli üzenetek nem az intelligens állomáson keresztül érik el céljukat.
  • A helyettesítő tartomány megadása ellenére a From (Feladó) fejléc változatlan.


A szolgáltatás nem kézbesíti az üzeneteket a Kézbesítési könyvtárba

Probléma | A könyvtár vagy a lemez megtelt.
Megoldás | Ürítse ki a Kézbesítési könyvtárat, és szükség esetén szabadítson fel további helyet a lemezen.

Probléma | A megadott elérési útvonal érvénytelen.
Megoldás | A Tartomány tulajdonságai párbeszédpanelen ellenőrizze, hogy helyes-e az alapértelmezett tartományhoz megadott Kézbesítési könyvtár elérési útvonala. A könyvtárnak mindenképpen valamelyik helyi meghajtón kell lennie.


A szolgáltatás nem kézbesíti az üzeneteket a megadott távoli tartománynak

Probléma | Az útvonaltartomány elérési útvonala helytelen, ezért a szolgáltatás „Host unreachable” (az állomás nem érhető el) hibaüzenetet küld.
Megoldás | A Tartomány tulajdonságai párbeszédpanelen ellenőrizze, hogy helyes-e az alapértelmezett tartományhoz megadott elérési útvonal.
Probléma | A fogadó kiszolgáló nem áll rendelkezésre, vagy az üzenet valamilyen okból nem kézbesíthető.
Megoldás | A Sorkezelő könyvtárban levő .rtr fájlok ellenőrzésével határozza meg a hiba okát. Ellenőrizze a Teljesítményfigyelőben az ismétlési kísérletek számlálójának értékét. Ellenőrizze a fogadó kiszolgálót.

Probléma | Helytelen a megadott név, vagy érvénytelen a megadott cím.
Megoldás | Ellenőrizze a nevet és az elérési útvonalat.

Probléma | A kapcsolat létesítéséhez kötelező a Transport Layer Security (TLS) használata. A megadott kulcsbizonyítvány érvénytelen, vagy a titkosítási szintek nem egyeznek.
Megoldás | Ellenőrizze, hogy a távoli tartományra vonatkozó Tartomány tulajdonságai párbeszédpanelen megadott beállítások felülbírálják-e a TLS használatát. Az Adatbiztonság párbeszédpanelen ellenőrizze a TLS titkosítás szintjét. Fontos, hogy az itt megadott titkosítási szint megegyezzen a fogadó kiszolgáló által megkövetelt titkosítási szinttel. A Kulcskezelő segítségével állítsa be a kulcspárokat.


A távoli üzenetek nem az intelligens állomáson keresztül érik el céljukat

Probléma | A távoli tartományhoz útvonaltartományt is kijelölt, és ez a beállítás felülbírálja az intelligens állomás használatára vonatkozó beállítást.
Megoldás | Változtassa meg az útvonaltartomány beállítását. Az útvonaltartomány sem az alapértelmezett tartománnyal, sem bármelyik másodlagos tartománnyal nem egyezhet meg.

Probléma | Az alapértelmezett tartományt vagy valamelyik másodlagos tartományt adta meg intelligens állomásként. Intelligens állomásként nem használhat helyi tartományt.
Megoldás | Változtassa meg az intelligens állomás beállítását a Speciális kézbesítés párbeszédpanelen, ennek megnyitásához kattintson a Kézbesítés tulajdonságlap Speciális gombjára.


A helyettesítő tartomány megadása ellenére a From (Feladó) fejléc változatlan

Probléma | A Kezdet fejléc nem mutatja a helyettesítő tartományt.
Megoldás | A Kezdet fejléc csak az első ugráskor változik meg.


Rendszer

A megoldatlan kézbesítési problémák rendszerhibákat eredményezhetnek. Ez a rész a következő témakört tartalmazza:

  • Nincs elég memória


Nincs elég memória

Probléma A fogadott üzenetek nem küldhetők tovább kézbesítésre, ezért továbbra is a várakozási sorban maradnak. A memóriában minden egyes fogadott üzenet levélobjektumként szerepel. Az üzenetet a rendszer csak akkor távolítja el a memóriából, amikor sikerül elhelyezni a Kézbesítési könyvtárban. Ha az üzenetek nem kézbesíthetők, és az objektumok száma eléri az alapértelmezett 100 000-res korlátot, a rendszer „Nincs elég memória” hibaüzenetet küld.
Megoldás Ellenőrizze az alábbi teljesítményszámlálókat:

Helyi sor hossza

Távoli sor hossza

Helyi újrapróbálkozási sor hossza

Távoli újrapróbálkozási sor hossza

Amennyiben az első két számláló értéke 0, az üzenetek beérkezésük után azonnal kézbesítésre kerülnek. Magasabb érték esetén valami késlelteti az üzenetek kézbesítését.

Az újrapróbálkozási sorok hosszának magas értéke azt jelzi, hogy az üzenetek nem kézbesíthetők. Nyissa meg az .rtr fájlokat, hogy meghatározhassa a probléma okát.

Elképzelhető például, hogy a távoli kiszolgáló hiba miatt leállt. Ebben az esetben a távoli újrapróbálkozási sor igen hosszú lehet, és a várakozási könyvtárban levő .rtr fájlokban szerepelhet a „Host not found” (az állomás nem található) hibaüzenet.


Microsoft SMTP-szolgáltatás

Ebben a részben a Microsoft SMTP-szolgáltatás működtetése során felmerülő hibák leírása található az alábbi témakörökben:

  • A Microsoft SMTP-szolgáltatás elindul, de a virtuális SMTP-kiszolgáló nem indul el.
  • Az SMTP beépülő modul nem jelenik meg az MMC-ben.
  • A Sorkezelő könyvtár .bad kiterjesztésű fájlokat tartalmaz.
  • Az ügyfél nem képes kapcsolatot létrehozni.


Az SMTP-szolgáltatás elindul, de a virtuális SMTP-kiszolgáló nem indul el

Probléma | A helyszínt a Microsoft Management Console-ban leállították, és a Microsoft SMTP-szolgáltatást leállították, majd a parancssorból újraindították.
Megoldás | Indítsa újra a virtuális SMTP-kiszolgálót az MMC-ben.


Az SMTP beépülő modul nem jelenik meg az MMC-ben

Probléma | A Microsoft Management Console-t a parancssorból nyitották meg.
Megoldás | Adja hozzá az SMTP beépülő modult kézzel.


A Sorkezelő könyvtár .bad kiterjesztésű fájlokat tartalmaz

Probléma | A Hibás üzenetek tárolókönyvtára megtelt, ezért a .bad kiterjesztésű fájlok a Sorkezelő könyvtárban maradnak.
Megoldás | Törölje az üzeneteket a Hibás üzenetek tárolókönyvtárból.


Az ügyfél nem képes kapcsolatot létrehozni

Probléma | Az ügyfél nem kapott jogot a hozzáféréshez.
Megoldás | Ellenőrizze a számítógép hozzáférési jogosultságait az Adatbiztonság kartonon.


Az SMTP beépülő modul hozzáadása kézzel

  1. A Kezelőpult menüben kattintson a Beépülő modul hozzáadása/eltávolítása parancsra.
  2. A Felvett beépülő modulok mezoben válassza ki az Internet Information Services elemet.
  3. Kattintson a Hozzáadás gombra.
  4. A listáról válassza ki az Internet Information Services elemet.
  5. Kattintson a Bővítések kartonra.
  6. Válassza az SMTP-protokoll bővítést.


A virtuális SMTP-kiszolgáló újraindítása MMC-ben

  1. Jelölje ki a kívánt virtuális SMTP-kiszolgálót.
  2. Kattintson a Művelet menü Indítás parancsára.


Jogi tudnivalók

Microsoft dokumentáció

A jelen dokumentumban található információ előzetes bejelentés nélkül megváltozhat. Az említett cégek, termékek vagy személyek neve és/vagy bármely más adata a képzelet szüleménye, és bármilyen egybeesés valós személyek, cégek, termékek vagy események tényleges adataival csak a véletlen műve, a külön említett eseteket kivéve. Az összes vonatkozó szerzői jogi törvény betartása a felhasználó felelőssége. A Microsoft Corporation külön írásos engedélye nélkül a jelen dokumentum egyetlen része sem reprodukálható vagy adható tovább semmilyen célból, semmilyen formában, illetve semmilyen — elektronikus vagy mechanikus — úton. Ez alól kivételt képez az az eset, amikor a felhasználó csak elektronikus úton éri el a jelen dokumentumot — ekkor egy példányban történő kinyomtatása engedélyezett.

A jelen dokumentumban foglaltak a Microsoft szabadalmai, bejegyzés előtt álló szabadalmai vagy védjegyei lehetnek, illetve szerzői jogaira vagy más szellemi alkotására vonatkozhatnak. Jelen dokumentum átadása semmilyen licencet nem biztosít a felhasználó számára e szabadalmakra, védjegyekre, szerzői jogokra, illetve más szellemi alkotásra, kivéve a Microsoft által kiadott bármely írásos licencszerződésben kifejezetten engedélyezett eseteket.

Copyright © 1999 Microsoft Corporation. Minden jog fenntartva.

A Microsoft, az MS-DOS, az MS, a Windows, a Windows 2000, az ActiveX, a JScript, a Microsoft Press, a Visual Basic, a Visual C++, a Visual J++, a Win32 és a Win32s a Microsoft Corporation védjegyei vagy bejegyzett védjegyei az Egyesült Államokban, illetve más országokban.

A Java a Sun Microsystems, Inc. védjegye.

Az Alpha AXP a Digital Equipment Corporation védjegye.

A Pentium az Intel Corporation bejegyzett védjegye.

A Macintosh és a QuickTime az Apple Computer, Inc. bejegyzett védjegye.

A dokumentumban említett más termékek és cégek neve tulajdonosuk védjegye lehet.


Elektronikus levelezés

Amennyiben számítógépére telepítette az elektronikus levelezési szolgáltatást (Simple Mail Transfer Protocol vagy SMTP), a termékdokumentáció megtekintéséhez gépelje be böngészője címsorába a file:\\%systemroot%\help\mail.chm karakterláncot, majd üsse le az ENTER billentyűt.

elektronikus levél, elektronikus levelek, elektronikus levelezés, mailto:, Simple Mail Transfer Protocol, SMTP, levelezési protokollok, postaláda, Lightweight Directory Access Protocol, LDAP, internetes levelezés, elektronikus levelezési beállítások, üzenetek.


ODBC-kompatibilis adatbázis létrehozása

  1. A Microsoft Access, a Microsoft SQL Server vagy más hasonló adatbázis-kezelő programmal hozzon létre egy ODBC-kompatibilis adatbázist.
  2. Hozzon létre egy táblát az adatbázisban, amely tartalmazza az alábbi táblázatban szereplő mezőket.

    A mező neve | Adattípusa
    ClientHost | varchar(255) (max. 255 karakter hosszúságú karakterlánc)
    Username | varchar(255) (max. 255 karakter hosszúságú karakterlánc)
    LogTime | datetime (dátum/idő)
    Service | varchar(255) (max. 255 karakter hosszúságú karakterlánc)
    Machine | varchar(255) (max. 255 karakter hosszúságú karakterlánc)
    ServerIP | varchar(50) (max. 50 karakter hosszúságú karakterlánc)
    ProcessingTime | integer (egész szám)
    BytesRecvd | integer (egész szám)
    BytesSent | integer (egész szám)
    ServiceStatus | integer (egész szám)
    Win32Status | integer (egész szám)
    Operation | varchar(255) (max. 255 karakter hosszúságú karakterlánc)
    Target | varchar(255) (max. 255 karakter hosszúságú karakterlánc)
    Parameters | varchar(255) (max. 255 karakter hosszúságú karakterlánc)