A billentyűzeten nem található karakterek bevitele

  1. Tartsa lenyomva az ALT billentyűt, majd üsse le a bevinni kívánt karakter decimális kódértékének megfelelő billentyűt a numerikus billentyűzeten.
  2. A bevitelt követően engedje el az ALT billentyűt.

    3. A Windows 2000 generálja a megadott karaktert és beviszi az éppen használt programba.

Megjegyzések

  • Ha az első bevitt számjegy a 0, a megadott érték kódpontként vagy karakterértékként lesz értelmezve a jelenlegi nyelvben. Ha például a jelenlegi nyelv angol (USA-beli) (1250-es kódlap: Windows latin betűs 1), az ALT billentyűt lenyomva és 0163-t beírva a numerikus billentyűzeten a font sterling jelét (Ł, U+00A3) kapja. Ha a jelenlegi nyelv az orosz (1251-es kódlap: Windows cirill), ugyanez a billentyűsorozat a cirill „zse” nagybetűt (U+0408) eredményezi.
  • Ha az első bevitt számjegy 1 és 9 közötti érték, azt a rendszer OEM kódlapja szerinti kódpontként ismeri fel. Az eredmény a Vezérlőpult Területi beállításaiban meghatározott Windows rendszerkörnyezettől függ. Ha például a rendszerkörnyezet angol (USA-beli), a kódlap a 437-es (MS-DOS latin betűs (USA), így az ALT billentyűt lenyomva és a 163-t beírva a numerikus billentyűzeten az ú (U+00FA, a latin hosszú U) betűt kapja. Ha a rendszerkörnyezet görög (OEM kódlap 737-es MS-DOS görög), ugyanez a billentyűsorozat a görög „mű” kisbetűt (U+03BC) eredményezi.

Kapcsolódó témakörök


Többnyelvű dokumentum összeállítása

  1. Dokumentum létrehozása és megnyitása
  2. Az Tálca állapotterületén kattintson a rendszeridő melletti nyelvkijelzőre, majd kattintson az összeállításban használni kívánt nyelvre.
  3. Állítsa össze a dokumentumot.
  4. A nyelv módosításához kattintson a Tálcán lévő nyelvkijelzőre és egy másik nyelvre a listában.

Megjegyzés

  • Ha a nyelvkijelző nem látható a Tálcán, kattintson a Start gombra, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Területi beállítások parancsra. A Nyelv lapon jelölje be a Kijelző engedélyezése a Tálcán jelölőnégyzetet.


Unicode vezérlőkarakter beszúrása

  1. A szövegmezőben kattintson az egér jobb gombjával a szövegen belül oda, ahová be szeretné szúrni az Unicode vezérlőkaraktert, majd kattintson a Unicode vezérlőkarakter beszúrása parancsra.
  2. Kattintson a beszúrni kívánt vezérlőkarakterre.

Megjegyzések

  • Az Unicode vezérlőkarakterek a szövegfolyam és az írásirány megadásában segítenek olyan nyelveknél, mint például az arab és a héber.
  • Ha a számítógépen többféle nyelv is telepítve van, bármilyen Windows 2000 szerkesztő vezérlőben, például szövegmezőkben vagy a Jegyzettömb használata közben beszúrhat Unicode vezérlőkaraktereket az egér jobb gombjával kattintva.


Dokumentumok írása más nyelveken

A Vezérlőpult Területi beállításainak segítségével telepíthet többféle nyelvet a számítógépre, például hébert, arabot, japánt, koreait vagy nyugat-európai nyelveket (franciát, spanyolt, németet és számos más nyelvet). A dokumentum létrehozásához ezek közül választhat. A Windows 2000 ezt követően rendelkezésre bocsátja az adott nyelv karakterkészletét, így hozzáfoghat az íráshoz.

A WordPad és a Jegyzettömb segítségével egyaránt készíthet dokumentumokat más nyelveken is, de a szövegszerkesztő programok további szolgáltatásokkal, például helyesírás-ellenőrzéssel is segítenek a többnyelvű dokumentumok megírásában.

Ha a dokumentumot valaki másnak is elküldi, a címzettnek is rendelkeznie kell ugyanazokkal a nyelvekkel, ha olvasni vagy szerkeszteni szeretné a fájlt.


Szövegirány beállítása

  • A szövegmezőben kattintson az egér jobb gombjával oda, ahonnan meg szeretné változtatni a szövegirányt, majd kattintson a Szövegirány parancsra.
    • .

Megjegyzések

  • A szövegirány megváltozása mellett a szövegigazítás is megváltozik, az arab és héber szövegek például jobbrazártak lesznek.
  • Ha a számítógépen többféle nyelv is telepítve van, bármilyen Windows 2000 szerkesztő vezérlőben, például szövegmezőkben vagy a Jegyzettömb használata közben megváltoztathatja a szövegirányt az egér jobb gombjával kattintva.


Unicode vezérlőkarakterek megjelenítése

  • Kattintson az egér jobb gombjával bárhová a szövegmezőben, majd kattintson a Unicode vezérlőkarakterek megjelenítése parancsra.
    • .

Megjegyzések

  • Az Unicode vezérlőkarakterek a szövegfolyam és az írásirány megadásában segítenek olyan nyelveknél, mint például az arab és a héber.
  • Ha a számítógépen többféle nyelv is telepítve van, bármilyen Windows 2000 szerkesztő vezérlőben, például szövegmezőkben vagy a Jegyzettömb használata közben megjeleníthet Unicode vezérlőkaraktereket az egér jobb gombjával kattintva.


Unicode(R) vezérlőkarakterek

Unicode® vezérlőkarakterek

A Unicode vezérlőkarakterek a szövegfolyam és az írásirány megadásában segítenek olyan nyelveknél, mint például az arab és a héber. Ezeket a nyelveket a Vezérlőpult Területi beállításaiban telepítheti.

Az alábbi leírásokat a The Unicode Consortium-tól vettük át. The Unicode Standard, Version 2.0. Reading, Massachusetts: Addison-Wesley Developers Press, 1997. február.

Balról jobbra jel (LRM)

Pontosan úgy viselkedik, mint a balról jobbra karakterek, azzal a kivétellel, hogy nem jelenik meg. Az LRM semmilyen szemantikai hatással nem bír.

Jobbról balra jel (RLM)

Pontosan úgy viselkedik, mint a jobbról balra karakterek, azzal a kivétellel, hogy nem jelenik meg. Az RLM semmilyen szemantikai hatással nem bír.

Nulla szélességű összekötő (ZWJ)

Nyomtatáskor, illetve megjelenítéskor megakadályozza az egymás utáni karakterek összekötését.

Nulla szélességű nem-összekötő (ZWNJ)

Nem-összekötőt tesz két karakter közé, így azok leképezéskor nem érintkezhetnek egymással.

Balról jobbra beágyazás eleje (LRE)

Azt jelzi, hogy az adott szövegrészt balról jobbra beágyazottként kell kezelni. Például egy arab mondat közepén lévő angol idézetet jelölhet balról jobbra beágyazott szövegként. (Az LRE a szórendet és nem a karakterrendet befolyásolja.)

Jobbról balra beágyazás eleje (RLE)

Azt jelzi, hogy az adott szövegrészt jobbról balra beágyazottként kell kezelni. Például egy angol mondat közepén lévő héber idézetet jelölhet jobbról balra beágyazottként. (Az RLE a szórendet és nem a karakterrendet befolyásolja.)

Balról jobbra felülírás eleje (LRO)

Speciális esetekben, például törteknél felülírja a kétirányú karaktertípusokat. Az LRO kikényszeríti a karakterek határozottan balról jobbra történő kezelését.

Jobbról balra felülírás eleje (RLO)

Speciális esetekben, például törteknél felülírja a kétirányú karaktertípusokat. Az RLO kikényszeríti a karakterek határozottan jobbról balra történő kezelését.

Irányformázás visszaállítása (PDF)

Megszünteti az utolsó konkrét (beágyazó vagy felülíró) kód hatását és visszaállítja az utolsó LRE, RLE, RLO vagy LRO vezérlőkarakter előtti kétirányú állapotot.

Nemzeti számjegyalak behelyettesítés (NADS)

Nemzeti számjegyalakban jeleníti meg az U+0030-U+0039 (ASCII) számokat. A nemzeti számjegyalakot a jelenlegi nyelv határozza meg.

Névleges (európai) számjegyalak (NODS)

Névleges számjegyalakban jeleníti meg az U+0030-U+0039 (ASCII) számokat. A névleges számjegyalak nyugati számjegyeket használ.

Szimmetrikus csere aktiválása (ASS)

Azt jelzi, hogy a karakterpárokban, például zárójelekben a BAL és JOBB kifejezés nyitót vagy zárót jelent. (Az alapértelmezett állapot az aktivált.)

Szimmetrikus csere blokkolása (ISS)

Kikapcsolja az olyan karakterek, mint például a zárójelek szimmetrikus cseréjét, így a BAL és a JOBB továbbra is balra és jobbra nézőt jelent, szemben a nyitóval és záróval, ahogy az a szimmetrikus csere esetén van.

Arab alakképzés aktiválása (AAFS)

Az arabbal kompatibilis karakterek képzési viselkedését vezérli. A megjelenítés folyamán bizonyos betűformák egymáshoz kapcsolhatók folyóírással vagy egybekötéssel. A képzésválasztó kódok jelzik a megjelenítési hatás eléréshez használt karakter alakmeghatározási (jelválasztási) folyamat aktiválását, illetve blokkolását. (Az alapértelmezett állapot a blokkolás.)

Arab alakképzés blokkolása (IAFS)

Blokkolja a karakter alakmeghatározási folyamatot, így a karakterek képzése nem a helyzetük alapján történik.

Törzselválasztó (tömbelválasztó) (RS)

Minden egyes sorelválasztó után új sort kezd.

Egységelválasztó (szegmenselválasztó) (US)

Minden egyes bekezdés-elválasztó után új bekezdést kezd.