Indexelő szolgáltatás

Az Indexelő szolgáltatás indexeli a meghajtókon lévő dokumentumokat és azok tulajdonságait, és az adatokat katalógusban tárolja. Az Indexelő szolgáltatás révén dokumentumokat kereshet a Start menü Keresés pontjával vagy webböngésző segítségével.

  • Az Indexelő szolgáltatás használatával kapcsolatos tippek a következő témakörben olvashatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő témakörben tájékozódhat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Gyakorlati tanácsok

Ajánlott számítógép-konfiguráció

Az Indexelő szolgáltatás minimális hardverigénye megegyezik a Microsoft Windows 2000 Server hardverigényével. Azonban az indexelés és a keresőmotorok teljesítménye az indexelni kívánt dokumentumok számától és méretétől, a lekérdezések elküldésének gyakoriságától és a lekérdezések bonyolultságától függ. A teljesítményt az Indexelő szolgáltatás számára rendelkezésre álló számítógépes erőforrások is befolyásolják. A Windows 2000 Server számára szükséges minimális hardverkonfiguráció megfelelően kezeli a lekérdezéseket, ha a párhuzamos lekérdezések száma nem túl magas. Kis szervezet számára ez elegendő lehet, de a több felhasználót kiszolgáló nagyobb szervezet számára hatékonyabb konfiguráció javasolt.

A következő tábla mutatja a javasolt memóriakonfigurációt az indexelni kívánt dokumentumok számától függően.

Indexelni kívánt dokumentumok száma | Minimális memóriamennyiség (MB) | Javasolt memóriamennyiség (MB)
Kevesebb, mint 100 000 | 64 | 64
100 000 és 250 000 között | 64 | 64 és 128 között
250 000 és 500 000 között | 64 | 128 és 256 között
500 000 vagy több | 128 | 256 vagy több

Ha a dokumentumok száma nagyon magas, a nem elegendő memória jelentősen befolyásolja a teljesítményt. Ha a teljesítmény nem megfelelő az Indexelő szolgáltatás futása közben, próbálkozzon a teljesítmény hangolásával Az Indexelő szolgáltatás teljesítményének megváltoztatása témakör alapján. A teljesítmény memória hozzáadásával, és a tulajdonság-gyorsítótár hozzárendelése céljára lefoglalt memória mennyiségének növelésével javítható. A gyorsabb CPU javítja az indexelés teljesítményét, és a lekérdezések feldolgozásának sebességét.

Az indexelni kívánt dokumentumok teljes mérete és a használt fájlrendszer típusa befolyásolja az Indexelő szolgáltatás adatainak tárolásához szükséges lemezterület nagyságát. FAT fájlrendszer esetén a katalógus és az ideiglenes munkaterület által elfoglalt hely az indexelt szövegnek körülbelül 30 százalékát teszi ki. NTFS fájlrendszer esetén az indexelt szöveg mennyisége 15 százalékának megfelelő hely szükséges.

Biztonsági tanácsok

  • Az Indexelő szolgáltatás tekintettel van az NTFS biztonsági követelményeire. Amíg a katalógus NTFS meghajtón helyezkedik el, a felhasználók számára az eredménylistában nem jelennek meg azok a dokumentumok, amelyeket jogosultság hiányában egyébként sem láthatnak.
  • Ha az univerzális elnevezési konvenciónak megfelelő megosztást indexel, a felhasználók számára a megosztáson lévő dokumentumok megjelennek az eredménylistában függetlenül attól, hogy rendelkeznek-e azokhoz jogosultsággal vagy nem. A dokumentumok megnyitása jogosultságaiktól függően lehetséges számukra.
  • Ha a katalógust FAT meghajtóra helyezi át, a felhasználók láthatják a katalógust attól függetlenül, hogy láthatják-e a benne található dokumentumokat vagy nem az engedélyeik alapján.
  • Az Indexelő szolgáltatásnak engedélyre van szüksége az indexelni kívánt dokumentumokhoz történő hozzáféréshez. A helyi számítógépen az Indexelő szolgáltatás a Rendszer fiókot használja működése során. Azokat a dokumentumokat és könyvtárakat, amelyekhez a fiók nem rendelkezik hozzáféréssel, az Indexelő szolgáltatás nem képes indexelni.
  • Az Indexelő szolgáltatás sohasem indexeli a titkosított dokumentumokat. Ha a dokumentumot indexelése után titkosítja, a dokumentumot a szolgáltatás törli a katalógusból.

Általános kezelési tanácsok

  • Ne tárolja a katalógusokat webhelyeken. Ha a katalógusfájlok a web gyökérkönyvtárban vagy virtuális könyvtárban helyezkednek el, az Internet Information Service időnként zárolja a katalógusfájlokat, és megakadályozza azok frissítését. Ez végtelen indexelési hurkot is előidézhet, amely lefoglalja a processzor teljes kapacitását.
  • Ha több katalógust használ, hozzon létre egy katalógusmappát az egyik meghajtón, és tárolja a katalógusokat ennek a mappának egy almappájában.
  • Ne futtasson víruskereső vagy biztonságimásolat-készítő szoftvert, amíg az Indexelő szolgáltatás fut. Egyes programok fájlokat zárolnak, és az Indexelő szolgáltatás időtúllépést okoz, amint megpróbálja indexelni ezeket.


Útmutató

  • Az Indexelő szolgáltatás lekérdezőűrlapjának megnyitása
  • Az Indexelő szolgáltatás felügyelete
  • A katalógus használata
  • A tulajdonság-gyorsítótár használata


Az Indexelő szolgáltatás lekérdezőűrlapjának megnyitása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Katalógus lekérdezése elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Katalógus lekérdezése

    3. A lekérdezőűrlap megjelenik a részletek ablaktáblán.

Megjegyzések

  • Az űrlap megnyitásakor megjelenő lekérdezés felsorolja azokat a dokumentumokat, amelyeket nem lehetett indexelni.

Kapcsolódó témakörök


Az Indexelő szolgáltatás felügyelete

  • Katalógus indexelési állapotának ellenőrzése
  • Az Indexelő szolgáltatás konfigurálása
  • Katalógus létrehozása
  • A nem indexelt dokumentumok listájának megjelenítése
  • Vizsgálat manuális indítása
  • Katalógus ideiglenes indexeinek egyesítése
  • Az Indexelő szolgáltatás teljesítményének módosítása
  • Katalógus indexelésének felfüggesztése
  • Katalógus vagy Indexelő szolgáltatás felfüggesztése, leállítása vagy indítása
  • A katalógus által indexelt könyvtárak megtekintése
  • Katalógus konfigurálása


A katalógus indexelési állapotának ellenőrzése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson az Indexelő szolgáltatás elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás

Megjegyzés

Kapcsolódó témakörök


Az Indexelő szolgáltatás konfigurálása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson az Indexelő szolgáltatás elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Indexelő szolgáltatás tulajdonságai párbeszédpanel Generáció lapján jelölje be a kívánt beállításokhoz tartozó jelölőnégyzeteket:
    • Ha ismeretlen fájlnévkiterjesztésű dokumentumokat kíván indexelni (melyekhez nem rendelkezik telepített szűrőkkel), jelölje be az Ismeretlen kiterjesztésű fájlok indexelése jelölőnégyzetet. Az Indexelő szolgáltatás a lehető legtöbb tartalmat és tulajdonságot kivonja a dokumentumokból.
    • Ha azt akarja, hogy az Indexelő szolgáltatás kivonatolja a dokumentumokat, és megjelenítse ezt az eredménylistában, jelölje be a Kivonatolás jelölőnégyzetet. A Maximális méret mezőbe írja be, hogy legfeljebb mennyi karaktert tartalmazhat a kivonat.
  5. Kattintson a Nyomon követés lapra.
  6. Jelölje be a Hálózati megosztási alias automatikus hozzáadása jelölőnégyzetet, ha azt akarja, hogy az Indexelő szolgáltatás a megosztott könyvtár megosztási nevét az adott könyvtár aliasneveként használja.
  7. A módosítások hatályba lépése érdekében állítsa le és indítsa újra az Indexelő szolgáltatást.

Megjegyzés

Kapcsolódó témakörök


Katalógus létrehozása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson az Indexelő szolgáltatás elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
  3. A Művelet menüben mutasson az Új menüpontra, majd kattintson a Katalógus parancsra.
  4. Írja be a katalógus nevét.
  5. Kattintson a Tallózás gombra, és jelölje ki azt a mappát, ahová az új katalógust helyezni kívánja. Kattintson az OK gombra.

Megjegyzések

  • A katalógus felvétele után az indexelési folyamat elindításához le kell állítani, majd újra kell indítani az Indexelő szolgáltatást.
  • Nem lehet katalógust felvenni távoli számítógépre, ha a távoli számítógépen az alapértelmezett felügyeleti megosztásokat eltávolították.

Kapcsolódó témakörök


A nem indexelt dokumentumok listájának megjelenítése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Katalógus lekérdezése elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Katalógus lekérdezése
  3. A részletek ablaktáblán megjelenő lekérdezés űrlapba írja be az @unfiltered=true értéket, majd kattintson a Keresés gombra.

Megjegyzés

Kapcsolódó témakörök


A pásztázás kézi indítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Könyvtárak mappára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Könyvtárak
  3. A részletes ablaktáblán kattintson az átvizsgálni kívánt könyvtárra.
  4. A Művelet menüben mutasson a Minden feladat menüpontra, és kattintson az Újrapásztázás (teljes) parancsra, ha teljes átvizsgálást, illetőleg az Újrapásztázás (növekményes) elemre, ha növekményes átvizsgálást kíván végrehajtani.

Megjegyzések

  • A teljes pásztázás sokáig tarthat. Ha teljes átvizsgálást kell végrehajtani, a rendszer legkevésbé terhelt időszakában hajtsa azt végre.
  • Az átvizsgálás kézi indítása csak akkor lehetséges, ha az Indexelő szolgáltatás fut.

Kapcsolódó témakörök


Ideiglenes indexek összefésülése katalógusba

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a megfelelő katalógusra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
  3. A Művelet menüben mutasson a Minden feladat menüpontra, majd kattintson az Összefésülés parancsra.
  4. A Katalógus egyesítése párbeszédpanelen kattintson az Igen gombra.

Megjegyzések

  • Az indexek egyesítése csak akkor lehetséges, ha az Indexelő szolgáltatás fut.

Kapcsolódó témakörök


Az Indexelő szolgáltatás teljesítményének megváltoztatása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson az Indexelő szolgáltatás elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
  3. Kattintson a Művelet menü Leállítás parancsára.
  4. A Művelet menüben mutasson a Minden feladat menüpontra, majd kattintson a Teljesítmény hangolása parancsra.
  5. Az Indexelő szolgáltatás használata párbeszédpanelen válassza ki azt a beállítást, amely a legjobban megfelel az Indexelő szolgáltatás használati módjának.
  6. Ha a Testreszabás lehetőséget választotta, kattintson a Testreszabás gombra, és folytassa a 8. lépéssel. Ha nem a Testreszabás lehetőséget választotta, ugorjon a 11. lépésre.
  7. A Kívánt teljesítmény párbeszédpanelen az Indexelés csúszkát a Lusta illetve az Azonnali beállítások felé húzva állítsa be az új és a módosított dokumentumok indexelésének módját. A lusta indexelési mód kevesebb erőforrást használ; az azonnali indexelési mód a számítógép lehető legtöbb erőforrását igénybe veszi.
  8. A Lekérdezés csúszkát állítsa Kis terhelés értékre, ha egyszerre csak kevés lekérdezést fog feldolgozni, illetve Nagy terhelés értékre, ha egyszerre sok lekérdezést fog feldolgozni. A kis terhelés kevesebb erőforrást, a nagy terhelés több erőforrást használ.
  9. Zárja be a Kívánt teljesítmény párbeszédpanelt.
  10. Zárja be Az Indexelő szolgáltatás használata párbeszédpanelt, és indítsa újra az Indexelő szolgáltatást.

Megjegyzés

Kapcsolódó témakörök


Az indexelés szüneteltetése egy katalógus esetében

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a megfelelő katalógusra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
  3. A Művelet menüben mutasson a Minden feladat menüpontra, majd kattintson a Felfüggesztés parancsra.

Megjegyzések

  • Az Indexelő szolgáltatás felfüggesztése esetén a részletes ablaktábla Állapot oszlopa a Csak lekérdezés értéket mutatja. A szolgáltatás szünetelése alatt a dokumentumok indexelése szünetel, de a lekérdezések feldolgozása továbbra is megtörténik.
  • A Művelet menüben a Minden feladat menüpontra mutatva, majd az Indítás parancsra kattintva indítsa újra a katalógust.

Kapcsolódó témakörök


A katalógus és az Indexelő szolgáltatás felfüggesztése, leállítása és elindítása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson az Indexelő szolgáltatás elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
  3. Ha felfüggeszteni, leállítani vagy elindítani kíván egy adott katalógust, kattintson a katalógusra.
  4. A Művelet menüben kattintson a Minden feladat menüpontra, majd a megfelelő beállításra.

Megjegyzések

  • A Művelet menü használata helyett kattintson az Indexelő szolgáltatás elemre, és a Microsoft Management Console (MMC) jobb felső sarkában található gombok segítségével elindíthatja, szüneteltetheti és leállíthatja a katalógust vagy a teljes szolgáltatást.

Kapcsolódó témakörök


A katalógus által indexelt könyvtárak megjelenítése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Könyvtárak mappára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Könyvtárak

Megjegyzés

Kapcsolódó témakörök


A katalógus konfigurálása

  • Hálózati megosztási aliasnevek automatikus hozzáadása
  • Webkiszolgáló indexelése
  • Ismeretlen kiterjesztésű fájlok indexelése
  • Kivonatok létrehozása


Hálózati megosztási aliasnevek automatikus hozzáadása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a megfelelő katalógusra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Tulajdonságok párbeszédpanel Nyomon követés fülére.
  5. Ha azt akarja, hogy az Indexelő szolgáltatás a megosztott könyvtár megosztási nevét az adott könyvtár fedőneveként használja, jelölje be a Hálózati megosztási alias automatikus hozzáadása jelölőnégyzetet.

    Ha ugyanazokat a beállításokat kívánja használni, mint a szolgáltatás, jelölje be A fenti beállítások öröklése a szolgáltatástól jelölőnégyzetet.

  6. A módosítások hatályba lépése érdekében állítsa le és indítsa újra a katalógust.

Megjegyzés

  • A Művelet menüben a Minden feladat menüpontra mutatva, majd az Indítás parancsra kattintva indítsa újra a katalógust.

Kapcsolódó témakörök


Webkiszolgáló indexelése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a megfelelő katalógusra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Tulajdonságok párbeszédpanel Nyomon követés fülére.
  5. A WWW-kiszolgáló listában kattintson az indexelni kívánt webkiszolgálóra. (Ha az Internet Information Services nincs telepítve a számítógépen, a webkiszolgáló vezérlése nem lehetséges.)
  6. A módosítások hatályba lépése érdekében állítsa le és indítsa újra a katalógust.

Megjegyzés

  • A Művelet menüben a Minden feladat menüpontra mutatva, majd az Indítás parancsra kattintva indítsa újra a katalógust.

Kapcsolódó témakörök


Ismeretlen kiterjesztésű fájlok indexelése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a megfelelő katalógusra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Tulajdonságok párbeszédpanel Generáció fülére.
  5. Ha ismeretlen fájlnévkiterjesztésű dokumentumokat kíván indexelni (ezekhez nem rendelkezik telepített szűrőkkel), jelölje be az Ismeretlen kiterjesztésű fájlok indexelése jelölőnégyzetet. Az Indexelő szolgáltatás a lehető legtöbb tartalmat és tulajdonságot kivonja a dokumentumokból.

    6. Ha ugyanazokat a beállításokat kívánja használni, mint a szolgáltatás, jelölje be A fenti beállítások öröklése a szolgáltatástól jelölőnégyzetet.

  6. A módosítások hatályba lépése érdekében állítsa le és indítsa újra a katalógust.

Megjegyzés

  • A Művelet menüben a Minden feladat menüpontra mutatva, majd az Indítás parancsra kattintva indítsa újra a katalógust.

Kapcsolódó témakörök


Kivonatok létrehozása

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson a megfelelő katalógusra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Tulajdonságok párbeszédpanel Generáció fülére.
  5. Ha azt akarja, hogy az Indexelő szolgáltatás kivonatot készítsen a lekérdezés eredménylistájában szereplő dokumentumokból, jelölje be a Kivonatolás jelölőnégyzetet.
  6. A Maximális méret mezőben állítsa be a kivonatok méretkorlátját.
  7. A módosítások hatályba lépése érdekében állítsa le és indítsa újra az Indexelő szolgáltatást.

Megjegyzés

Kapcsolódó témakörök


A katalógus használata

  • Katalógus törlése
  • Könyvtár felvétele vagy törlése a katalógusból
  • NTFS-könyvtár vagy dokumentum indexelésének megakadályozása
  • Könyvtár eltávolítása a katalógusból


Katalógus törlése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán kattintson az Indexelő szolgáltatás elemre.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
  3. Az Indexelő szolgáltatás leállítához a Művelet menüben kattintson a Leállítás parancsra.
  4. Kattintson a törölni kívánt katalógusra.
  5. Kattintson a Művelet menü Törlés parancsára.
  6. A megerősítést kérő párbeszédpanelen kattintson az Igen gombra.
  7. Az Indexelő szolgáltatás újraindítása érdekében a Művelet menüben kattintson az Indítás parancsra.

Megjegyzések

  • A törölt katalógusok eltűnnek a lemezről.

Kapcsolódó témakörök


Könyvtár felvétele és kizárása egy katalógusból

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Könyvtárak mappára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Könyvtárak
  3. A Művelet menüben mutasson az Új menüpontra, majd kattintson a Könyvtár elemre.
  4. A Könyvtár hozzáadása párbeszédpanelen található Elérési út beviteli mezőbe írja be a felvenni kívánt könyvtár elérési útját.

    A Tallózás gombra kattintva meg is keresheti a könyvtárat.

  5. Az Alias (UNC) beviteli mezőbe írja be a könyvtár fedőnevét, ha létezik.
  6. Ha a felvenni kívánt könyvtár másik számítógépen található, a Felhasználónév beviteli mezőbe írja be a számítógéphez hozzáféréssel rendelkező felhasználó tartományát és felhasználónevét. A tartománynevet a felhasználónévtől válassza el fordított ferde vonal karakterrel (\). A könyvtár felvétele csak akkor lehetséges, ha engedéllyel rendelkezik a helyi számítógépre történő bejelentkezéshez.
  7. A Jelszó mezőbe írja be a másik számítógéphez megadott felhasználónévhez tartozó jelszót.
  8. Az Igen választógombra kattintva vegye fel a könyvtárat a katalógusba, vagy a Nem gombra kattintva zárja ki.

Megjegyzések

  • Ha a katalógus webkiszolgálót követ nyomon, a könyvtárak felvétele automatikusan megtörténik.
  • Ha meg akarja változtatni a könyvtár beállításait, a részletes ablaktáblán duplán kattintva nyissa meg a Könyvtár hozzáadása párbeszédpanelt.

Kapcsolódó témakörök


NTFS könyvtár és dokumentum indexelésének megakadályozása

  1. A Windows Intézőben válassza ki a dokumentumot vagy mappát.
  2. Kattintson a Fájl menü Tulajdonságok parancsára.
  3. Az Általános lapon kattintson a Speciális gombra.
  4. Törölje a jelölést a Tartalom indexelése a gyors fájlkeresés érdekében jelölőnégyzetből.

Megjegyzés

  • Ha a FAT dokumentumok indexelését meg akarja akadályozni, vegye fel az ezeket tartalmazó könyvtárat a katalógusba, és állítsa a Belefoglalás katalógusba beállítást Nem értékre.


Könyvtár eltávolítása egy katalógusból

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Könyvtárak mappára.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Könyvtárak
  3. Kattintson az eltávolítani kívánt könyvtárra.
  4. Kattintson a Művelet menü Törlés parancsára.

Megjegyzések

  • A könyvtár katalógusból történő eltávolítása során a könyvtárból semmi nem törlődik.
  • Virtuális könyvtárat nem lehet eltávolítani.

Kapcsolódó témakörök


A tulajdonság-gyorsítótár használata

  • Tulajdonság hozzáadása a tulajdonság-gyorsítótárhoz
  • Tulajdonság szerkesztése a tulajdonság-gyorsítótárban
  • Tulajdonság eltávolítása a tulajdonság-gyorsítótárból
  • A katalógusra vonatkozó, gyorsítótárba helyezett tulajdonságok megtekintése


Tulajdonság felvétele a tulajdonság-gyorsítótárba

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Tulajdonságok gombra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Tulajdonságok
  3. A részletes ablaktáblán a Tulajdonságkészlet oszlopban kattintson a gyorsítótárba felvenni kívánt tulajdonság tulajdonságazonosítójára.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Tulajdonságok párbeszédpanelen jelölje be a Gyorsítótár használata jelölőnégyzetet.
  6. A Méret mezőben változó méretű tulajdonságok számára állítsa be a tulajdonság méretét bájtban. (A rögzített méretű tulajdonság méretét nem lehet megváltoztatni.)
  7. Ha a tulajdonságot a gyorsítótár elsődleges szintjén kívánja tárolni, a Tárolás listában kattintson az Elsődleges elemre.

Fontos

  • A tulajdonság-gyorsítótáron végzett módosítás jelentősen befolyásolhatja az Indexelő szolgáltatás teljesítményét.

Megjegyzések

  • A módosítások az Indexelő szolgáltatás következő elindításakor lépnek hatályba.
  • Az Adattípus lista automatikusan megmutatja a tulajdonság számára megfelelő adattípust, ha a tulajdonság ismert az Indexelő szolgáltatás számára. Ha a tulajdonság nem ismert, VT_LPWSTR jelenik meg. A listából másik adattípust lehet választani.
  • Ha a gyorsítótár elsődleges szintjére tulajdonságokat vesz fel, a teljesítmény csökkenhet.
  • Az elsődleges szint a rögzített hosszúságú tulajdonságokhoz van optimalizálva. Itt ne tároljon változó hosszúságú tulajdonságokat, mert ezzel nagy mértékben megnövekszik a gyorsítótár számára szükséges terület.
  • Miután kiválasztotta a tulajdonság tárolási szintjét, és újraindította az Indexelő szolgáltatást, a tárolási szintet nem lehet megváltoztatni.
  • Az új tulajdonságok tárolása előtt újra át kell vizsgálni valamennyi indexelt dokumentumot.

Kapcsolódó témakörök


Tulajdonság módosítása a tulajdonság-gyorsítótárban

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Tulajdonságok gombra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Tulajdonságok
  3. A részletes ablaktáblán, a Tulajdonságkészlet oszlopban kattintson a módosítani kívánt tulajdonság tulajdonságazonosítójára.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A megjelenő párbeszédpanelen végezze el a kívánt módosításokat.

Fontos

  • A tulajdonság-gyorsítótáron végzett módosítás jelentősen befolyásolhatja a teljesítményt.

Megjegyzések

  • A Tulajdonságok párbeszédpanelt a tulajdonságazonosítóra duplán kattintva is megnyithatja.
  • A módosítások az Indexelő szolgáltatás következő elindításakor lépnek hatályba.

Kapcsolódó témakörök


Tulajdonság eltávolítása a tulajdonság-gyorsítótárból

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Tulajdonságok gombra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Tulajdonságok
  3. A részletes ablaktáblán a Tulajdonságkészlet oszlopban kattintson a gyorsítótárból eltávolítani kívánt tulajdonság tulajdonságazonosítójára.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Tulajdonságok párbeszédpanelen törölje a jelölést a Gyorsítótár használata jelölőnégyzetből.

Fontos

  • A tulajdonság-gyorsítótáron végzett módosítás jelentősen befolyásolhatja a teljesítményt.

Megjegyzések

  • A módosítások az Indexelő szolgáltatás következő elindításakor lépnek hatályba.

Kapcsolódó témakörök


A gyorsítótárban tárolt tulajdonságok megjelenítése

  1. Nyissa meg a Számítógép-kezelés segédprogramot.
  2. A konzolfán a megfelelő katalógus alatt kattintson a Tulajdonságok gombra.

    Helye:

    • Számítógép-kezelés
    • Szolgáltatások és kiszolgálói alkalmazások
    • Indexelő szolgáltatás
    • katalógus
    • Tulajdonságok

Megjegyzések

  • Ha a tulajdonság Tárolási szint mezője üres, a tulajdonság nincs a gyorsítótárban.
  • A tulajdonságlistát csak akkor lehet megjeleníteni, ha a katalógus fut (nincs leállítva vagy szüneteltetve).
  • A Művelet menüben a Minden feladat menüpontra mutatva, majd a Frissítés parancsra kattintva frissítse a tulajdonságlistát.

Kapcsolódó témakörök


Fogalmak

Ez a rész az Indexelő szolgáltatással kapcsolatban nyújt általános háttérinformációkat.

  • Indexelő szolgáltatás – áttekintés
  • Az Indexelő szolgáltatás ismertetése
  • Az Indexelő szolgáltatás használata


Indexelő szolgáltatás – áttekintés

Az Indexelő szolgáltatás dokumentumok készletéből von ki információt, és azt úgy rendezi, hogy a Windows 2000 Keresés funkciója, az Indexelő szolgáltatás lekérdező űrlapja vagy egy webböngésző segítségével gyorsan és egyszerűen el lehessen érni. Ez az információ lehet a dokumentumból származó szöveg (annak tartalma) vagy a dokumentum jellemzői és paraméterei (annak tulajdonságai), például a szerző neve. Az index létrehozása után lehetséges az indexben a kulcsszavakat, kifejezéseket vagy tulajdonságokat tartalmazó dokumentumok lekérdezése. Például le lehet kérdezni a “termék” szót tartalmazó valamennyi dokumentumot, vagy lekérdezheti az egy adott szerző által írt Microsoft Office dokumentumokat. Az Indexelő szolgáltatás visszaadja a keresési feltételeknek megfelelő dokumentumok listáját. A lekérdezés létrehozásának különböző módjaival kapcsolatos további tudnivalókért tanulmányozza a Lekérdezések létrehozása témakört.

Az indexelés folyamata során az Indexelő szolgáltatás dokumentumszűrőt használ a dokumentum átolvasására, és az indexelőnek átadandó szöveg és tulajdonságok kigyűjtésére. Az indexeléssel kapcsolatos további tudnivalókért tanulmányozza az Indexelés témakört.

Az Indexelő szolgáltatás automatikusan tárolja az indexinformációkat a Rendszer vagy Web katalógusban. A katalógusokkal kapcsolatos további tudnivalókért tanulmányozza a Katalógusok témakört.

Az Indexelő szolgáltatás a következő dokumentumtípusokat indexeli:

  • HTML
  • Szöveg
  • Microsoft Office 95 vagy újabb
  • Internet levél és hírek (ha az Internet Information Services szolgáltatás telepítve van)
  • Bármely dokumentum, amelyhez rendelkezésre áll dokumentumszűrő

Az Indexelő szolgáltatást folyamatosan futtatásra tervezték, és kevés karbantartást igényel. Beállítása után minden művelet automatikus, beleértve az index létrehozását, frissítését, és a rendszerösszeomlás utáni helyreállítást áramkimaradás esetén. Az Indexelő szolgáltatás felügyeletével kapcsolatos további tudnivalókért tanulmányozza Az Indexelő szolgáltatás felügyelete témakört.

A rendszergazdák és az alkalmazásfejlesztők egyéb típusú dokumentumokhoz is létrehozhatnak egyéni szűrőket. Az egyéni szűrők fejlesztésével kapcsolatos további tudnivalókért tanulmányozza a Microsoft Platform Software Development Kit csomagot.


Az Indexelő szolgáltatás ismertetése

A rész tartalma:

  • Vizsgálat
  • Keresés
  • Katalógusok
  • Indexelés


Pásztázás

Az pásztázás során a könyvtárak feltérképezése zajlik annak meghatározása érdekében, hogy mely dokumentumokat kell indexelni. Az Indexelő szolgáltatás szükség esetén automatikusan végrehajtja a teljes és növekményes pásztázásokat.

Teljes pásztázás

A teljes pásztázás során a szolgáltatás feltérképezi a katalógusba felvett könyvtárakban található dokumentumokat, és felveszi őket az indexelni kívánt dokumentumok listájára. Az Indexelő szolgáltatás a következő helyzetekben hajt végre teljes átvizsgálást a számítógéphez csatlakoztatott lemezmeghajtókon (az eltávolítható eszközök kivételével):

  • A telepítés után első alkalommal történő futtatásakor
  • Egy mappának a katalógusba történő felvétele után
  • Súlyos hiba esetén a helyreállítás részeként

Növekményes pásztázás

Az Indexelő szolgáltatás nem tudja követni a dokumentumok módosításait, amikor le van állítva. Az Indexelő szolgáltatás újraindításakor növekményes átvizsgálást hajt végre annak érdekében, hogy az inaktív állapota alatt módosított dokumentumok megkeresése után frissíthesse az indexet.

A növekményes átvizsgálást akkor is végre lehet hajtani, ha az Indexelő szolgáltatás elveszíti a változtatásokról szóló értesítéseket. Ez akkor történhet meg, ha a dokumentumok módosításának mértéke nagyon nagy, és a Windows 2000 által a módosításokról küldött értesítések tárolására használt puffer túlcsordul.

A teljes és növekményes átvizsgálást kézzel is bármikor el lehet indítani. További információt A pásztázás kézi indítása című témakörnél talál.

Értesítés a módosításokról

A fájlrendszer által a módosításokról küldött értesítések elindítják a fájlok indexelését, így nem kell hosszan tartó lemezpásztázásokat végrehajtani. A dokumentum megváltoztatása esetén a fájlrendszer értesíti az Indexelő szolgáltatást, hogy a dokumentumot újra kell indexelni. Ha azonban a dokumentum távoli számítógépen helyezkedik el, előfordulhat, hogy az Indexelő szolgáltatás nem kap értesítést a módosításról. Ebben az esetben az Indexelő szolgáltatás rendszeresen növekményes pásztázást hajt végre az említett számítógépeken.


Keresés

A dokumentumok keresése az Indexelő szolgáltatáshoz intézett lekérdezések segítségével lehetséges. Az Indexelő szolgáltatás átvizsgálja az indexet, és visszaadja a lekérdezésen szereplő feltételeknek megfelelő dokumentumokat.

A lekérdezés irányulhat a dokumentum tartalmára, a dokumentum adott tulajdonságaira, vagy mindkettőre. A Microsoft Office dokumentumok bármely tulajdonságára is lehet keresni.

A Windows 2000 rendszerben háromféle módon kereshet:

  • A Start menüben kattintson a Keresés menüpontra.
  • Használja az Indexelő szolgáltatás lekérdezőűrlapját.
  • Egy weblapon küldje el a lekérdezést az Internet Information Service (IIS) útján.

A Start menü Keresés szolgáltatásának használata

A Start menü Keresés szolgáltatása segítségével bármilyen szót vagy kifejezést megkereshet. További információt a Fájlok és mappák keresése című témakörnél talál.

Az Indexelő szolgáltatás lekérdezőűrlapjának használata

Az Indexelő szolgáltatás minden katalógusához tartozik egy lekérdezőűrlap. Az űrlap lehetővé teszi bármilyen fajtájú lekérdezés futtatását, és a lekérdezésnyelv valamennyi szolgáltatásának kihasználását. A lekérdezőűrlap megnyitásáról további információt Az Indexelő szolgáltatás lekérdezőűrlapjának megnyitása című témakörnél talál. A lekérdezésnyelvről további információt a Lekérdezések létrehozása című témakörnél talál.

Weblap használata

A Weben keresztül csak akkor lehet lekérdezéseket elküldeni, ha a webgazda vagy a rendszergazda olyan weblapot hoz létre, amelyen be lehet írni a lekérdezést. Az oldal testreszabható, amivel megkönnyíthető a lekérdezések beírása és finomítása, valamint a különböző tulajdonságok keresése. Az oldal szerzője megadhatja, melyik katalógusokban kell keresni. A keresés eredménye egy weblapon jelenik meg.

Az eredmények megtekintése

Az Indexelő szolgáltatás visszaadja a lekérdezésnek megfelelő dokumentumok listáját, amelynek neve eredményhalmaz. Az eredményhalmaz egyes elemei a találatok. Az Indexelő szolgáltatás képes rangsorolni a találatokat annak megfelelően, hogy mennyire felelnek meg a lekérdezésnek, és több szintre rendezheti az eredményeket bármelyik dokumentumtulajdonság értéke alapján. A weblapokon a rendszergazda korlátozhatja a felhasználónak visszaadott találatok számát. Például a 200 találatot tartalmazó eredményhalmazt a felhasználó 10, egyenként 20 találatot tartalmazó oldalon tekintheti meg.

Bár tetszőleges dokumentumtulajdonságra lehet keresni, az eredménylista csak azokat a tulajdonságértékeket tartalmazza majd, amelyek a gyorsítótárban vannak tárolva, illetve amelyek ActiveX dokumentumokban találhatók. A tulajdonságokról további információt A dokumentum tulajdonságai című témakörnél talál.

A tulajdonságértékek visszaadása mellett az Indexelő szolgáltatás a dokumentumból kivonatot is képes készíteni, amelyeket szintén vissza lehet adni a weblapon megjelenő eredményhalmazban. A kivonatok létrehozásáról további információt a Katalógusok létrehozása című témakörnél talál.

Ha az indexelt dokumentumokat helyi NTFS köteten tárolja, a hozzáférési jogok határozzák meg, hogy a rendszer a dokumentumot visszaadja-e az eredményhalmazban. A felhasználó számára nem jelennek meg az azokra a dokumentumokra vonatkozó hivatkozások az eredményhalmazban, amely dokumentumokhoz nem rendelkezik olvasási jogosultsággal.


Katalógusok

Az Indexelő szolgáltatás minden indexinformációt katalógusokban tárol. A katalógus a fájlrendszerben található könyvtárak adott csoportjához tartozó indexadatokat és tárolt tulajdonságokat tartalmazza. Ha az Indexelő szolgáltatást a Windows 2000 rendszerrel együtt telepíti, ez automatikusan felépíti a Rendszer katalógust, felsorolva az állandó lemezmeghajtók tartalmát. A Rendszer katalógus bizonyos rendszer- és ideiglenes fájlok kivételével minden dokumentumhoz tartalmaz indexet. Ha az Internet Information Services (IIS) telepítve van, az Indexelő szolgáltatás egy webkatalógust is létrehoz, amely az IIS, a World Wide Web alapértelmezett virtuális kiszolgálójának indexét tartalmazza.

A katalógusok hatóköre alatt a felvett és a kizárt könyvtárak halmazát értjük. A könyvtárak felvétele és kizárása a katalógusból beállítható. A felvett vagy kizárt könyvtárak valamennyi alkönyvtárára is vonatkozik a felvétel, illetve kizárás. A könyvtárak katalógusba történő felvételéről illetve kizárásáról további információt a Könyvtár felvétele és kizárása a katalógusból című témakörnél talál. A katalógusok létrehozásáról további információt a Katalógusok létrehozása című témakörnél talál.

Dokumentumok tartalma

Az index tartalmazza minden dokumentum tartalmát, kivéve a kivétellistán szereplő szavakat (például névelőket, elöljárókat, névmásokat). A kivétellistát a Kivétellista című témakörnél találja. A dokumentum tartalmához tartozik:

  • A HTML dokumentum szövege
  • A hírcsoport cikk vagy elektronikus levél törzse
  • A szövegszerkesztővel készített vagy más dokumentum törzse

A katalógus legnagyobb részét kitevő index mérete az indexelt dokumentumok méretének 15-30 %-a.

A dokumentum tulajdonságai

A dokumentum tulajdonságai a dokumentum jellemzőinek felelnek meg (például a létrehozás dátuma, a szerző neve vagy a dokumentum mérete). A tulajdonságértékek az adott dokumentumra jellemző adatok. Egyes tulajdonságértékeket a dokumentumot létrehozó program állít be, a többit a felhasználó adja meg. Egyes dokumentumok, például a Microsoft Office alkalmazásokban létrehozott dokumentumok esetén a felhasználók egyedi tulajdonságokat is létrehozhatnak. A HTML-dokumentumok szerzői a metakódokban hozhatnak létre egyedi tulajdonságokat.

A rendszer minden tulajdonságot és tulajdonságértéket a dokumentum tartalmával együtt indexel, és ezekben keresni lehet. A legtöbb tulajdonságot a keresési eredmények listájában is meg lehet jeleníteni. Azonban egyes tulajdonságokat, például a HTML-dokumentumok metacímkéiben lévőket, a dokumentum indexelésekor a tulajdonság-gyorsítótárban kell tárolni. Ellenkező esetben az Indexelő szolgáltatás nem tudja lekérni és a keresés eredményében megjeleníteni azokat. Azt is meg lehet adni, hogy mely tulajdonságokat kívánja menteni a tulajdonság-gyorsítótárba, ha az alapértelmezett kiválasztások nem megfelelőek.

A tulajdonság-gyorsítótárban tárolni kívánt tulajdonságokat A gyorsítótárban tárolt tulajdonságok megjelenítése című témakörnél találja.

A tulajdonságoknak a gyorsítótárba történő felvételéről információt a Tulajdonság felvétele a tulajdonság-gyorsítótárba című témakörnél talál.

  • Oszlopok a könyvtárak részletes ablaktábláján
  • Oszlopok a tulajdonságok részletes ablaktáblán


A könyvtárak részleteit tartalmazó ablaktábla oszlopai

A következő táblázat a könyvtárak részletes ablaktábláján (a jobb oldali ablaktáblán) található oszlopokat írja le.

Oszlop | Jelentése
Könyvtár A fizikai könyvtárak listája. Az ezen könyvtárak alatt található minden dokumentum indexelése megtörténik (vagy ki van zárva az indexelésből). A virtuális könyvtárakhoz tartozó bejegyzéseket különleges mappaikon jelöli. A részletek ablaktáblán háromféle könyvtár található:
  • A fizikai könyvtárak, amelyeket sárga mappaikon jelöl.
  • Az árnyékkönyvtárak, amelyeket sötétsárga mappaikon jelöl. Az árnyékkönyvtárak olyan megosztott könyvtárak, amelyekhez fedőnevek (alias) tartoznak.
  • A virtuális könyvtárak, amelyeket egy mappa-és-földgömb ikon jelöl. A virtuális könyvtárak a virtuális gyökérre hivatkoznak.
Alias | A kiszolgáló neve és a könyvtár elérési útja: \\Kiszolgáló_neve\Könyvtár_aliasneve. Az aliast a rendszer a lekérdezés eredménylistájában visszaadja azoknak a felhasználóknak, akik távoli számítógépről küldik a lekérdezést. Ez az oszlop üres is lehet.
Belefoglalás katalógusba | Igen beállítás esetén a könyvtár és valamennyi alkönyvtára belekerül a katalógus hatókörébe, és valamennyi indexelése megtörténik. Nem esetén a könyvtár és alkönyvtárai nincsenek a katalógus hatókörében, és indexelésük nem történik meg.


A tulajdonságok részletes ablaktáblájának oszlopai

A következő táblázat megmagyarázza az Indexelő szolgáltatás tulajdonságait tartalmazó oszlopokat, melyek a Microsoft Microsoft Management Console részletes (jobb oldali) ablaktábláján találhatók.

Oszlop | Jelentése
Tulajdonságkészlet | A tulajdonságcsoport tulajdonságszáma
Tulajdonság | A tulajdonság hexadecimális vagy karakterlánc-azonosítója
Rövid név | A tulajdonság címkéje lekérdezés-korlátozásokban, illetve rendezési módokban
Adattípus | A tulajdonság gyorsítótárban történő tárolásához szükséges adattípus
Gyorsítótárazott méret | A gyorsítótárban a tulajdonság számára lefoglalt terület mérete bájtban
Tárolási szint | A tulajdonság-gyorsítótár azon szintje (elsődleges vagy másodlagos), amelyen a tulajdonságérték tárolása történik


Indexelés

Minden indexelni kívánt dokumentum esetén az Indexelő szolgáltatás a következő műveleteket hajtja végre:

  1. A megfelelő dokumentumszűrőt használva az Indexelő szolgáltatás beolvassa a dokumentumot, és kivonatolja annak tartalmát és tulajdonságértékeit. A dokumentum tulajdonságértékeit és elérési útját az indexben tárolja.
  2. Az Indexelő szolgáltatás meghatározza a dokumentum nyelvét, és a tartalomfolyamot különálló szavakra tördeli.
  3. Az Indexelő szolgáltatás ezután eltávolítja a kivétellistán található szavakat (például a névelőket, elöljárókat és névmásokat). Minden nyelv saját kivétellistával rendelkezik. Az amerikai angol nyelv kivétellistáját a Kivétellista című témakörnél találja.
  4. Az Indexelő szolgáltatás a többi szót az indexbe menti.
  5. Az Indexelő szolgáltatás a kijelölt tulajdonságok értékét a tulajdonság-gyorsítótárban tárolja.

Dokumentumszűrők

A dokumentumszűrők olyan szoftverösszetevők, amelyek egy adott típusú dokumentum, például egy Microsoft Word vagy HTML dokumentum szerkezetét értelmezik. Az Indexelő szolgáltatás a szűrő segítségével kivonatolja a katalógusba felvett dokumentum szöveges tartalmát és tulajdonságértékeit, és átadja ezeket az indexelőmotornak.

Az Indexelő szolgáltatás a következő dokumentumtípusokhoz rendelkezik szűrőkkel:
  • Microsoft Office alkalmazások által létrehozott dokumentumok.
  • HTML dokumentumok.
  • Szöveges dokumentumok.
  • Internet Mail és hírek dokumentumok

Egyéb alkalmazások segítségével létrehozott dokumentumokhoz a szoftverforgalmazótól szerezhető be szűrő. Ezekről a szűrőkről további információt a szoftverforgalmazótól tudhat meg. A dokumentumszűrőt a szűrő forgalmazója által adott telepítési utasításoknak megfelelően telepítse.

Tulajdonság-gyorsítótár

A tulajdonság-gyorsítótár a fájlrendszer és az ActiveX tulajdonságokon kívül azoknak a tulajdonságoknak az értékeit tárolja, amelyeket a keresési eredmények listájában meg szeretne jeleníteni. A tulajdonság-gyorsítótár két tárolási szinttel rendelkezik: elsődleges és másodlagos. Az elsődleges tárolási szinten a viszonylag kevés leggyakrabban használt érték található. Ez hagyományosan kis méretű, hogy biztosítva legyen az itt tárolt értékek gyors elérése. A ritkábban keresett értékeket a másodlagos szinten kell tárolni. Az alapértelmezés szerint tárolt tulajdonságértékek listáját a Katalógusok létrehozása című témakörnél találja.

Szólisták

A dokumentum indexelésekor az indexadatok először a szólistába kerülnek. Ez a kicsi, ideiglenes index csak néhány dokumentum indexadatait tartalmazza. A szólista gyorsan létrehozható, és nem igényeli a tárolt adatok frissítését.

Mivel a szólisták a memóriában találhatók, az Indexelő szolgáltatás leállításakor és újraindításakor automatikusan újraindexeli a szólistában található dokumentumokat.

Mentett indexek

A lemezen tárolt indexek neve mentett index. A mentett indexadatokat a rendszer erősen tömörített formátumban tárolja, melyet a keresés meggyorsítására és az erőforrások legjobb kihasználására terveztek.

Indexek összefésülése

Az összefésülés több szólista és mentett index adatainak a lekérdezések hatékony végrehajtása érdekében történő egyesítését jelenti egy állandó főindexbe. Az összefésülés során eltűnnek az ismétlődő adatok, és felszabadulnak az erőforrások, így a lekérdezések feldolgozása gyorsabbá válik. A folyamat során az indexelt dokumentumokat mindig le lehet kérdezni.

Az Indexelő szolgáltatás egy meghatározott mennyiségű szólista összegyűlését követően, de legalább naponta egyszer automatikusan ideiglenes mentett indexekbe fésüli a szólistákat. Később az ideiglenes indexeket automatikusan egy főindexbe egyesíti.

Ha a katalógusba felvett dokumentumokon kiterjedt módosításokat végzett, ajánlatos kézzel elindítani az egyesítést. Az egyesítés elindításáról további információt az Ideiglenes indexek összefésülése katalógusba című témakörnél talál.

Az összefésülés általában hosszú, a processzort erősen igénybe vevő folyamat. A lekérdezések végrehajtása észrevehetően lelassulhat az egyesítés alatt. Azonban az egyesítést követően a lekérdezéseket sokkal gyorsabban lehet végrehajtani.

  • Kivétellista
  • Az indexelés állapotüzenetei


Kivétellista

A kivétellisták Noise.xxx nevű szövegfájlok, ahol az xxx hárombetűs kiterjesztés a lista nyelvét jelöli. A kivétellisták módosíthatók bármely szövegszerkesztő programmal, például a Microsoft WordPad segítségével is.

Az amerikai angol dokumentumok indexelése során az Indexelő szolgáltatás a következő szavakat, betűket és számokat hagyja figyelmen kívül:

about | can | how | of | the | were
after | come | if | on | their | what
all | could | in | only | them | when
also | did | into | or | then | where
an | do | is | other | there | which
and | does | it | our | these | while
another | each | its | out | they | who
any | else | just | over | this | will
are | for | like | re | those | with
as | from | make | said | through | would
at | get | many | same | to | you
be | got | me | see | too | your
because | has | might | since | under | a b c d e
been | had | more | should | up | f g h i j
before | he | most | so | use | k l m n o
being | have | much | some | very | p q r s t
between | her | must | still | want | u v w x y
both | here | my | such | was | z $
but | him | never | take | way | 1 2 3 4 5
by | himself | no | than | we | 6 7 8 9 0
came | his | now | that | well |


Az indexelés állapotüzenetei

A Microsoft Management Console (MMC) részletek ablaktábláján (jobb ablaktábla) található oszlopok megadják az Indexelő szolgáltatás különböző elemeinek állapotát. A következő táblázat megmagyarázza az egyes oszlopok jelentését.

Oszlop | Jelentése
Katalógus | A katalógus neve
Hely | A katalógus elérési útja és neve
Méret (MB) | A katalógus mérete megabájtban
Az összes dokumentum | Az indexelt dokumentumok teljes száma
Indexelendő dokumentumok | Az indexelésre váró dokumentumok száma
Nem kívánt indexelés | Azoknak a dokumentumoknak a száma, amelyek indexelése szükséges, de nem lehetséges, mert használatban vannak.
Szólisták | A memóriában található szólisták száma
Mentett indexek | A katalógusba mentett indexek (árnyékindexek és főindexek) száma
Állapot | A katalógus állapota

A következő táblázat megmagyarázza a katalógushoz tartozó különböző típusú állapotüzenetek jelentését és a végrehajtandó műveletet.

Üzenet | Magyarázat/kijavítás
Az indexelés fel van függesztve (magas I/O) | Az indexelés szünetel a bemeneti/kimeneti (I/O) tevékenység magas szintje miatt. Az I/O tevékenység csökkentése érdekében zárjon be néhány alkalmazást.
Az indexelés fel van függesztve (kevés a memória) | Az indexelés szünetel, mert kevés a memória. Néhány alkalmazást bezárva szabadítson fel memóriát.
Az indexelés fel van függesztve (energiaellátás) | Az indexelés szünetel az akkumulátor kímélése érdekében.
Az indexelés fel van függesztve (aktív felhasználó) | Az indexelés szünetel a felhasználó tevékenységével történő ütközés elkerülése érdekében.
Összefésülés | Összefésülés van folyamatban.
Teljes összefésülés (felfüggesztve) | Az egyesítés szünetel a kevés rendelkezésre álló erőforrás miatt.
Leállítva | A katalógus indexelése le van állítva.
Csak lekérdezés | Az index csak lekérdezés céljából elérhető.
Helyreállítás | Az Indexelő szolgáltatás a váratlan lezárás utáni helyreállítást végzi.
Vizsgálat szükséges | Egy vagy több dokumentumot indexelni kell. Ha ez az üzenet hosszabb ideig (néhány másodpercet meghaladóan) fennmarad, ellenőrizze az eseménynaplót.
Pásztázás | A rendszer egy vagy több könyvtárban új vagy módosított dokumentumokat keres.
Pásztázás (NTFS) | A rendszer egy vagy több NTFS kötetben új vagy módosított dokumentumokat keres.
Indulófélben | Az Indexelő szolgáltatás éppen indul.
Elindítva | Az Indexelő szolgáltatás elindult.


Az Indexelő szolgáltatás használata

A rész tartalma:

  • Lekérdezések készítése
  • Az Indexelő szolgáltatás felügyelete


Lekérdezések készítése

A lekérdezések segítségével dokumentumokat kereshet az általuk tartalmazott szavak és kifejezések, vagy tulajdonságaik, például a dokumentum neve vagy szerzője alapján. A lekérdezés legegyszerűbb módja egyetlen szó lekérdezése. Ha például a „művelet” szót keresi, az Indexelő szolgáltatás visszaadja a „művelet” szót tartalmazó valamennyi dokumentumot.

Olyan dokumentumokat is lehet keresni, amelyek tulajdonságértékei megfelelnek egy adott feltételnek. A lekérdezhető tulajdonságok között vannak a dokumentum alapvető adatai, például a dokumentum neve és a dokumentum mérete. Lekérdezhet ActiveX tulajdonságok, például a dokumentum adatlapja alapján is. ActiveX tulajdonságok az ActiveX-et használó programok, például a Microsoft Office alkalmazások által létrehozott dokumentumokban találhatók.

A lekérdezéseknek öt fajtája létezik:

  • Szabadszöveges lekérdezés
  • Kifejezéses lekérdezések
  • Mintázategyeztető lekérdezések
  • Relációs lekérdezések
  • Vektoros lekérdezések

Ez a szakasz a következő témakörökről tartalmaz információt:

  • A lekérdezések általános szabályai
  • A Tartalmaz és az Egyenlő operátor
  • Logikai operátorok
  • Szabadszöveges és kifejezéses lekérdezések
  • Mintalekérdezések
  • Lekérdezésnyelv formátumai
  • Mintázategyeztető lekérdezések
  • Vektoros lekérdezések


A lekérdezések általános szabályai

A következő szabályok a lekérdezések minden fajtájára vonatkoznak:

  • A lekérdezésekben a kis- és nagybetűk nem különböznek.
  • A kivétellistán szereplő szavak kivételével bármely szóra lehet keresni. Az amerikai angol nyelv kivétellistáját a Kivétellista című témakörnél találja.
  • Ha különleges karaktereket (például &, |, ^, #, @ és $) kíván használni a lekérdezésben, zárja a lekérdezést idézőjelek közé.
  • A dátum- és időértékek formája a következő: éééé/hh/nn óó:pp:ss vagy éééé-hh-nn óó:pp:ss. Az év első két karaktere és az idő elhagyható. Ha az év első két karakterét elhagyja, a dátumot a rendszer 1930 és 2029 között értelmezi. A másodpercérték után három számjegyen ezredmásodperc értéket lehet megadni. Minden dátum és időpont univerzális időben van megadva. Például 1997/12/8 13:10:03:452

Megjegyzések

  • A jelenlegi dátumhoz és időponthoz képest viszonylagos dátumot és időt a mínuszjelet (-) követően beírt egy vagy több egész szám és időegység párokban lehet megadni. Az időegységek megadása a következő: y = év, q = negyedév (három hónap), m = hónap, w = hét, d = nap, h = óra, n = perc és s = másodperc.
  • A numerikus értékek alakja lehet decimális és hexadecimális. A hexadecimális értékeket "0x" előzi meg.


A Tartalmaz és az Egyenlő operátor

A CONTAINS (Tartalmaz) operátor segítségével szót vagy kifejezést kereshet egy tulajdonságon belül. Ha nincs megadva operátor, a rendszer alapértelmezés szerint a CONTAINS operátort használja.

A következő lekérdezések eredménye megegyezik:

@DocTitle “a vörös kutya”
@DocTitle Contains “a vörös kutya”

A következő táblázat a CONTAINS operátor használatát mutatja be mind hosszú alakos, mind rövid alakos formában.

Hosszú alak | Rövid alak
{prop name=DocTitle} Contains {phrase}a vörös kutya{/phrase}{/prop} | @DocTitle”a vörös kutya”

Mindkét lekérdezést kielégítené az a dokumentum, amely cím tulajdonságának értéke “A vörös kutya története”.

Az EQUALS operátor megadja, hogy a tulajdonság értékének pontosan meg kell egyeznie a lekérdezésben szereplő szóval vagy kifejezéssel. Az operátor hosszú alakja EQUALS. Az operátor rövid alakja az egyenlőségjel (=).

Például:

@DocTitle = “a vörös kutya”

Csak az a dokumentum elégíti ki a lekérdezést, amelynek Cím tulajdonságának értéke “a vörös kutya”. Az Indexelő szolgáltatás ekkor nem adja vissza “A vörös kutya története” című dokumentumot, mert ez olyan szavakat is tartalmaz, amelyek nem szerepelnek a lekérdezésben.

Megjegyzések

  • Ha a “contains” vagy “equals” szóra kíván keresni, használjon idézőjeleket.
  • Az Indexelő szolgáltatásban a @contents = szöveg lekérdezés érvénytelen.

A lekérdezésekről további információt A lekérdezések általános szabályai című témakörnél talál.


Logikai operátorok

Az AND, OR és NOT logikai operátorokat mind a tartalomban, mind a tulajdonságokban kereső lekérdezésekben használhatja. A NEAR logikai operátort csak a tartalomban kereső lekérdezésekben használhatja. A logikai operátorok mind a hosszú alakos, mind a rövid alakos lekérdezésekben használhatók. A hosszú alakos és a rövid alakos lekérdezésekről további információt A lekérdezési nyelv alakjai című témakörnél talál.

A lekérdezésben NEAR operátort alkalmazva a lekérdezésnek azok a dokumentumok felelnek meg, amelyekben a szavak legfeljebb 50 szó távolságban vannak egymástól. Minél közelebb helyezkednek el a szavak egymáshoz, annál magasabb helyet foglal el a dokumentum az eredményhalmaz rangsorában. Ha a szavak több mint 50 szó távolságra helyezkednek el egymástól, az nem minősül elég közelinek, és a dokumentum a rangsorban nulla értéket kap. A NEAR operátort csak szavakra vagy kifejezésekre lehet alkalmazni.

Tartalomban kereső lekérdezésekben a NOT operátort csak az AND operátor után használja. Használja a NOT operátort a korábbi tartalmi korlátozásnak megfelelő, de nem kívánt dokumentumok kizárására. Tulajdonságértékekben kereső lekérdezések esetén a NOT operátor az AND operátortól függetlenül is használható.

A következő táblázat a logikai operátorokat és a hozzájuk társított szimbólumokat magyarázza meg.

Operátor | Hosszú alak | Rövid alak
AND | AND | &
OR | OR | |
NOT | AND NOT | &!
NEAR | NEAR | Near, ~

A logikai operátorok csak a fenti formában, angolul használhatók.

A következő táblázat a logikai operátorok használatára mutat példákat.

Keresés tárgya | Hosszú alak | Rövid alak | Eredmény
Mindkét szó ugyanabban a dokumentumban | vörös and kutya | vörös & kutya | A “vörös” és a “kutya” szót is tartalmazó dokumentumok
Két szó egyike a dokumentumban | vörös or kutya | vörös | kutya | A “vörös” vagy a “kutya” szót tartalmazó dokumentumok
Csak az egyik szó, a másik szó nélkül | vörös and not kutya | vörös & ! kutya | A “vörös” szót tartalmazó, de a “kutya” szót nem tartalmazó dokumentumok
Adott tulajdonságértéknek nem megfelelő dokumentumok | not {prop name=size} = 100 | ! @size = 100 | A nem 100 bájt méretű dokumentumok
Két szó közel egymáshoz a dokumentumban | vörös near kutya | vörös ~ kutya | A “vörös” szóhoz közel a “kutya” szót tartalmazó dokumentumok
Két szó egyikét, de két másik szót nem, ha azok közel vannak egymáshoz | vörös or kutya and not (fekete near macska) | vörös | kutya &! (fekete~macska) | A “vörös” vagy a “kutya” szót tartalmazó, de a “fekete” és “macska” szót egymástól számítva 50 szó közelségben nem tartalmazó dokumentumok.

Megjegyzés

  • A lekérdezésben használt kifejezést idézőjelek közé kell zárni, ha olyan szót tartalmaz, amely logikai operátor. Például a “horse and rider” karakterláncot kifejezésként, és nem logikai kifejezésként értelmezi a program.

Elsőbbségi szabályok

A logikai operátorok kiértékelésére a következő sorrendben kerül sor:

  1. NOT
  2. AND vagy NEAR
  3. OR

Az elsőbbségi szabályok kiértékelése után az operátorokat a rendszer balról jobbra dolgozza fel. A szokásos elsőbbségi sorrend zárójelek (( )) segítségével felülbírálható. Például az első három lekérdezés egymással egyenértékű, de a negyedik nem:

a AND b OR c

c OR a AND b

c OR (a AND b)

(c OR a) AND b

A negyedik lekérdezésben az OR operátor kiértékelése történik meg először, mert a kifejezés zárójelek közé van zárva.


Szabadszöveges és kifejezéskeresés

Szabadszöveges lekérdezések

A szabadszöveges lekérdezésekben megadhat szócsoportot vagy teljes mondatot. Az Indexelő szolgáltatás megkeresi azokat az oldalakat, amelyek legjobban megfelelnek a szabadszöveges lekérdezésben található szavaknak és kifejezéseknek. Ennek során inkább azokat az oldalakat keresi meg, amelyek a lekérdezés értelmének, nem pedig a pontos szövegezésének felelnek meg. Az Indexelő szolgáltatás figyelmen kívül hagyja a logikai, a közelségi és a helyettesítő karakteres operátorokat.

A szabadszöveges lekérdezések segítségével mind a tartalomban, mind a tulajdonságértékekben kereshet. Ha a lekérdezés típusa vagy a tulajdonság megadása nélkül csak a lekérdezés szövegét adja meg, az Indexelő szolgáltatás alapértelmezés szerint a szabadszöveges lekérdezést és a Tartalom tulajdonságot használja.

A következő lekérdezések azokat a dokumentumokat adják vissza, amelyek a “Hogyan lehet nyomtatni a Microsoft Excelben?” mondattal legjobban megegyező szöveget tartalmazzák.

Hosszú alak | Rövid alak
{freetext} {prop name=contents} Hogyan lehet nyomtatni a Microsoft Excelben? | Hogyan lehet nyomtatni a Microsoft Excelben? vagy $contents Hogyan lehet nyomtatni a Microsoft Excelben?

Kifejezéskeresés

Ha kifejezést keres, zárja idézőjelek közé, vagy írja elé a {phrase} címkét. A kifejezéses lekérdezés a beírt szavakat a dokumentumban csak akkor találja meg, ha azok ugyanabban a sorrendben jelennek meg, közbeeső szavak nélkül.

A következő kifejezések jelentése megegyezik:

{phrase} nagy piros teherautó {/phrase}

"nagy piros teherautó"

Ha a "phrase" címkét használja, a szavak sorrendje és helyzete jelentős abból a szempontból, hogy a dokumentum megfelel-e a lekérdezésnek. A {phrase} és {freetext} címkék kölcsönösen kizáró jellegűek, és nem lehet őket egymásba ágyazni. A kifejezéskeresés segítségével mind a tartalomban, mind a tulajdonságértékekben kereshet.

A következő táblázat példákat tartalmaz a "phrase" címkék hosszú és rövid alakjaira.

Hosszú alak | Rövid alak
{phrase} nagy piros teherautó {/phrase} | "nagy piros teherautó"

Megjegyzés

  • A kifejezéskeresésekben a kivétellistán lévő szavakat a rendszer helyfoglalóként kezeli. Például ha a “Word for Windows” kifejezésre keresett, az eredményben előfordulhat a “Word for Windows” és a “Word and Windows” kifejezés is, mert a “for” szó szerepel a kivétellistában.


Mintalekérdezések

A következő táblázat különböző célt szolgáló lekérdezésekre hoz példákat.

Keresés tárgya | Hosszú alak | Rövid alak | Eredmény
Egy adott érték | {prop name=DocAuthor}= Kis Virág{/prop} | @DocAuthor = Kis Virág | Azok a dokumentumok, amelyek szerzője Kis Virág
Előtaggal kezdődő értékek | {prop name=DocAuthor} {regex}Nagy*{/regex}{/prop} | #DocAuthor Nagy* | Azok a dokumentumok, amelyek Szerző tulajdonsága a “Nagy” szóval kezdődik
Tetszőleges kiterjesztésű dokumentumok | {prop name=filename} {regex}*.|(exe|,dll|,sys|){/regex}{/prop} | #filename *.|(exe|,dll|,sys|) | Exe, dll vagy sys kiterjesztéssel rendelkező fájlok
Adott dátumot, illetve időpontot követően módosított dokumentumok | {prop name=write}>96/2/14 13:00:00{/prop} | @write > 96/2/14 13:00:00 | Az univerzális idő szerint 1996 február 14. 13:00 óra után módosított dokumentumok
Viszonylagos dátumot követően módosított dokumentumok | {prop name=write}> -1d2h{/prop} | @write > -1d2h | Az utolsó 26 órán belül módosított dokumentumok
Adott vektorral egyező vektorok | {prop name=vectorprop}={ 10, 15, 20 }{/prop} | @vectorprop={ 10, 15, 20 } | Azok az ActiveX dokumentumok, amelyek vectorprop értéke { 10, 15, 20 }
Azok a vektorok, amelyeknek minden értéke megfelel egy feltételnek | {prop name=vectorprop}>^a 15{/prop} | @vectorprop >^a 15 | Azok az ActiveX dokumentumok, amelyek vectorprop értékében minden érték nagyobb, mint 15
Azok a vektorok, amelyeknek legalább egy értéke megfelel egy feltételnek | {prop name=vectorprop}=^s 15{/prop} | @vectorprop =^s 15 | Azok az ActiveX dokumentumok, amelyek vectorprop értékében legalább egy érték 15


Lekérdezésnyelv formátumai

Az Indexelő szolgáltatás támogatja mind a hosszú alakos, mind a rövid alakos lekérdezéseket. A hosszú alakos lekérdezések nyitó és záró lekérdezési kódok segítségével épülnek fel, melyeket kapcsos zárójelek ({ }) jelölnek. A lekérdezési kódok a lekérdezés tagmondatait nyitják meg, illetve zárják le. A lekérdezési kódok a tagmondat további finomítására attribútumokat vagy paramétereket is tartalmazhatnak.

Hosszú alakos és rövid alakos lekérdezések

A lekérdezési nyelvben a legtöbb operátor hosszú alakkal és ennek megfelelő rövid alakkal is rendelkezik. Például a @docauthor a Szerző tulajdonság rövid neve, míg a {prop name=DocAuthor} ennek hosszú alakja.

A kifejezés rövid alakja kompatibilis a lekérdezésnyelv korábbi verzióival, így ha azt kívánja, hogy a lekérdezés a nyelv minden verziójában működjön, használja a kifejezések rövid alakját a lekérdezésekben. A kifejezés hosszú alakja támogatja a lekérdezésnyelv minden szolgáltatását. Ez lesz a nyelv újabb verzióinak az alapja.

Módszimbólumok a rövid alakos lekérdezésekben

A rövid alakos lekérdezésekben a következő szimbólumok jelzik a módot.

Szimbólum | Mód
@ | Kifejezéses lekérdezés (ugyanaz, mint a {phrase})
# | Szabványos kifejezéses lekérdezés (ugyanaz, mint a {regex})
$ | Szabad szöveges lekérdezés (ugyanaz, mint a {freetext})

A lekérdezésnyelv korábbi verzióival való kompatibilitás

A következő táblázat a lekérdezésnyelv 1-es és a 2-es (a jelenlegi) verziói közötti különbségeket mutatja:

Szolgáltatás | 1-es verzió | 2-es verzió | Megjegyzések
Vektorértékek | Az a, b és c elemekből álló vektort {a,b,c} alakban kell megadni. | A vektort (a;b;c) alakban kell megadni. | A kapcsos zárójelek ({ }) helyett zárójeleket (( )), a vesszők (,) helyett pedig pontosvesszőket (;) kell használni.
Súlymegadás | A súlyok a 0 - 1 000 tartományba esnek. | A súlyok a 0,0 - 1,0 tartományba esnek. | A 2-es verzió tartománya lehetővé teszi a végtelen felbontást.
 | A T kifejezéshez 100-as súlyt T [100] formában lehet hozzárendelni. | A T kifejezéshez 0,1 súlyt {weight value = 0.1} T formában lehet hozzárendelni. |
Alapértelmezett mód | Kifejezés | Szabadszöveg | Az okos kutya lekérdezést a rendszer az 1-es verzióban kifejezéses, a 2-es verzióban szabadszöveges lekérdezésként kezeli.

Az vektorokról további információt a Vektoros lekérdezések című témakörnél talál.

A súlyozásról további információt a Kifejezések súlyozása című témakörnél talál.

Ez a szakasz a következőkről is tartalmaz információt:

  • Tulajdonságnevek megadása
  • Dokumentumtulajdonságok


Tulajdonságnevek megadása

A tulajdonságneveket hosszú alakban és rövid alakban is meg lehet adni, a következőképpen:

Hosszú alak | Példa | Rövid alak | Példa
{prop name=name} | {prop name="Number of pages"} | @name | @"Number of pages"
 | {prop name=title} | #name | #title

A tulajdonságnév kis- és nagybetűkkel is írható. Ha több szóból áll, mind a hosszú alakos, mind a rövid alakos lekérdezésekben idézőjelek közé kell zárni.

A {/prop} címke zárja le a tulajdonságnév-hivatkozást. Ha a lekérdezésben több tulajdonságnevet is használ, az első {/prop} a legközelebbi megelőző tulajdonságnevet zárja le, és az ezt megelőző tulajdonságnév vezérli a lekérdezést. Például a következő lekérdezésben:

{prop name=all} Excel and {prop name=size} > 1000
and < 100000 {/prop} and Microsoft

a {/prop} címke a {prop name=size} tulajdonságnevet zárja le. A {prop name=all} címke nem rendelkezik lezáró címkével.

Ez a lekérdezés megkeres minden dokumentumot, amelynek mérete 1 000 és 100 000 bájt között van, és az “Excel” és “Microsoft” szavak szerepelnek tartalmában vagy bármelyik tulajdonságában.

Két különleges tulajdonságnév létezik: Tartalom és Mind. A Tartalom tulajdonság a dokumentum tartalmát tartalmazza. Ha a lekérdezésben a Tartalom van megadva, az Indexelő szolgáltatás csak a dokumentum tartalmában keres. Ha a lekérdezésben a Minden van megadva, az Indexelő szolgáltatás a dokumentum tartalmában és tulajdonságértékeiben is keres. Például a {prop name=all} futball lekérdezés azokat a dokumentumokat adja vissza, amelyeknek tartalmaában vagy bármely tulajdonságában szerepel a "futball" szó.

Ha nincs megadva tulajdonság a lekérdezésben, az Indexelő szolgáltatás alapértelmezés szerint a Tartalom tulajdonságot válassza.

A valamennyi dokumentum esetén rendelkezésre álló tulajdonságok többek között a következők:

Tulajdonság neve | Leírás
All (Mind) | Minden tulajdonság, beleértve a Tartalom tulajdonságot. Csak szöveges lekérdezések esetén működik, numerikus értékeket tartalmazó lekérdezések esetén nem.
Contents (Tartalom) | Szavak és kifejezések a dokumentumban
Filename (Fájlnév) | A dokumentum neve
Size (Méret) | A dokumentum mérete bájtban
Write (Írás) | A dokumentum legutóbbi módosításának napja és időpontja

Az ActiveX tulajdonságértékeket szintén lehet használni a lekérdezésekben. A legtöbb ActiveX-et használó alkalmazással készített dokumentumokat tartalmazó webhelyet a következő tulajdonságokra lehet lekérdezni.

ActiveX tulajdonság neve | Leírás
DocTitle | A dokumentum címe
DocSubject | A dokumentum tárgya
DocAuthor | A dokumentum szerzője
DocKeywords | A dokumentum kucsszavai
DocComments | A dokumentumra vonatkozó megjegyzések

A lekérdezhető dokumentumtulajdonságok teljes körű listáját Dokumentumtulajdonságok című témakörnél találja.

A lekérdezések létrehozására vonatkozó általános szabályokat A lekérdezések általános szabályai című témakörnél találja.


Dokumentumtulajdonságok

Ez a táblázat a lekérdezések létrehozásakor mindig elérhető szabványos tulajdonságnevek listáját tartalmazza. Egyéb tulajdonságnevek is rendelkezésre állhatnak.

A tulajdonságnevek segítségével történő lekérdezésről további információt a Tulajdonságnevek megadása című témakörnél talál.

A táblázatban látható adattípusok segítségével tulajdonságokat lehet felvenni a tulajdonság-gyorsítótárba. Ezek nem szükségesek a lekérdezések létrehozásához.

Rövid név | Leírás | Adattípus
Access | A dokumentumhoz történő legutóbbi hozzáférés ideje | VT_FILETIME
All | Minden tulajdonságban keresi a karakterláncot. Ennek lekérdezése lehetséges, de lekérése nem. | Nem alkalmazható
AllocSize | A dokumentum számára lefoglalt lemezterület mérete | VT_I8
Attrib | A dokumentum attribútumai. Lásd a Windows 2000 Platform Software Development Kit készletet. | VT_UI4
ClassId | A dokumentum objektum osztályazonosítója (például Microsoft Word) | VT_CLSID
Characterization | A dokumentum jellemzése vagy kivonata. Ezt az Indexelő szolgáltatás hozza létre. | VT_LPWSTR
Contents | A dokumentum lényeges tartalma. Ennek lekérdezése lehetséges, de lekérése nem. | Nem alkalmazható
Created | A dokumentum létrehozásának időpontja | VT_FILETIME
Directory | A dokumentum fizikai elérési útja a dokumentum neve nélkül | VT_LPWSTR
DocAppName | A dokumentumot létrehozó alkalmazás neve | VT_LPSTR
DocAuthor | A dokumentum szerzője | VT_LPSTR
DocByteCount | A dokumentum által tartalmazott bájtok száma | VT_I4
DocCategory | A dokumentum típusa (például feljegyzés, ütemezés vagy részletes technikai leírás) | VT_LPSTR
DocCharCount | A dokumentum által tartalmazott karakterek száma | VT_I4
DocComments | A dokumentumra vonatkozó megjegyzések | VT_LPSTR
DocCompany | A cég neve, amely számára a dokumentum létre lett hozva | VT_LPSTR
DocCreatedTm | A dokumentum létrehozásának ideje | VT_FILETIME
DocEditTime | A dokumentum szerkesztésére fordított teljes idő | VT_FILETIME
DocHiddenCount | A Microsoft PowerPoint dokumentumban található rejtett diák száma | VT_I4
DocKeywords | A dokumentum kulcsszavai | VT_LPSTR
DocLastAuthor | A dokumentumot utoljára szerkesztő felhasználó | VT_LPSTR
DocLastPrinted | A dokumentum legutóbbi nyomtatásának időpontja | VT_FILETIME
DocLastSavedTm | A dokumentum legutóbbi mentésének időpontja | VT_FILETIME
DocLineCount | A dokumentumban található sorok száma | VT_I4
DocManager | A dokumentum szerzője vezetőjének neve | VT_LPSTR
DocNoteCount | A Microsoft PowerPoint dokumentum megjegyzésekkel ellátott oldalainak száma | VT_I4
DocPageCount | A dokumentum által tartalmazott oldalak száma | VT_I4
DocParaCount | A dokumentum által tartalmazott bekezdések száma | VT_I4
DocPartTitles | A dokumentum részeinek címe, mint például a munkafüzetek neve a Microsoft Excel dokumentumban, vagy a diák címe a Microsoft PowerPoint diavetítésben. | VT_LPSTR
DocPresentationTarget | A Microsoft PowerPoint előadás célformátuma (például 35 mm-es film, nyomtató vagy videó) | VT_LPSTR
DocRevNumber | A dokumentum jelenlegi verziószáma | VT_LPSTR
DocSlideCount | A Microsoft PowerPoint dokumentumban található diák száma | VT_I4
DocSubject | A dokumentum tárgya | VT_LPSTR
DocTemplate | A dokumentum sablonjának neve | VT_LPSTR
DocTitle | A dokumentum címe | VT_LPSTR
DocWordCount | A dokumentum által tartalmazott szavak száma | VT_I4
FileIndex | A dokumentum egyedi azonosítója | VT_I8
FileName | A dokumentum neve | VT_LPWSTR
HitCount | A találatok (eredménylista elemeinek) száma a dokumentumban | VT_I4
HtmlHRef | A HTML link (HREF) szövege. Ennek lekérdezése lehetséges, de lekérése nem. | VT_LPWSTR
HtmlHeading1-6 | H1-H6 stílusú szövegek a HTML-dokumentumban. Ennek lekérdezése lehetséges, de lekérése nem. | VT_LPWSTR
MediaEditor | A dokumentum elsődleges szerkesztőjének neve | VT_LPWSTR
MediaOwner | A dokumentum tulajdonosa, például a dokumentumot licencelő csoport | VT_LPWSTR
MediaProduction | A média létrehozásának napja | VT_FILETIME
MediaProject | Az a projekt, amelyhez a dokumentum tartalma tartozik | VT_LPWSTR
MediaRating | A minőség vagy tartalom minősítése | VT_LPWSTR
MediaSequence_No | A médiadokumentum sorozatszáma a csoportban | VT_LPWSTR
MediaSource | A dokumentum forrásának, például a kép felvevőjének a neve | VT_LPWSTR
MediaStatus | A dokumentum állapota a projekt munkafolyamatában, ahol 0=Vázlat, 1=Szerkesztés, 2=Végleges, 3=Folyamatban, 4=Új, 5=Normál, 6=Egyéb, 7=Előzetes, 8=Ellenőrzés és 9=Áttekintés. | VT_UI4
MediaSupplier | A dokumentum forrásának neve, például az a fél, akitől a dokumentumot licencelték | VT_LPWSTR
Path | A dokumentum teljes fizikai elérési útja, beleértve a dokumentum nevét | VT_LPWSTR
Rank | Annak sorrendje, hogy az eredménylistában található elem mennyire egyezik meg a lekérdezés feltételeivel. A tartomány 0 - 1 000-ig terjed. A nagyobb szám a jobb egyezést jelzi. | VT_I4
RankVector | A vektoros lekérdezés egyedi összetevőinek sorrendje. A tartomány 0 - 1 000-ig terjed. A nagyobb szám a jobb egyezést jelzi. | VT_I4
ShortFileName | A dokumentum rövid (8.3 formátumú) neve. | VT_LPWSTR
Size | A dokumentum mérete bájtban. | VT_I8
VPath | A dokumentum teljes virtuális elérési útja, beleértve a dokumentum nevét. Ha több lehetséges útvonal létezik, a rendszer az adott lekérdezéshez tartozó legjobb egyezést választja. | VT_LPWSTR
WorkId | A dokumentum belső azonosítója. Ez az Indexelő szolgáltatáson belül használatos. | VT_I4
Write | A dokumentum legutóbbi módosításának (írásának) időpontja | VT_FILETIME


Mintaegyeztető lekérdezések

A mintaegyeztető lekérdezések során az Indexelő szolgáltatás a megadott mintának megfelelő dokumentumokat választja ki. Ez a rész az alábbi mintaegyeztető lekérdezéseket tárgyalja:

  • Helyettesítő karakterek
  • Szóalakok lekérdezése
  • Relációs operátorok
  • Szabályos kifejezések
  • A szabályos kifejezések operátorai


Helyettesítő karakterek

A mintaegyeztető lekérdezés legegyszerűbb formájában egy szó vagy szótöredék és egy helyettesítő karakter szerepel. A csillag (*) és a kérdőjel (?) használható a lekérdezésekben helyettesítő karakterként. A csillag bármilyen karakterek tetszőleges hosszúságú láncát helyettesítheti, míg a kérdőjel egy karaktert helyettesít.

Például a hír* lekérdezésnek megfelel a “hírvivő”, a “híres” stb. szó is. A f?t lekérdezésnek megfelel a “fut” és a “fát” szó, de a “fiát” szó nem.

Az Indexelő szolgáltatásban az egyenlőségjel (=) jelzi, hogy helyettesítő karakterek használhatók. Ha egyenlőségjel nem található, az Indexelő szolgáltatás alapértelmezés szerint a Tartalom operátort használja.

A következő táblázat példát tartalmaz a helyettesítő karakteres lekérdezések hosszú és rövid alakos formájára.

Rövid alak | Hosszú alak | Eredmény
@filename=*.doc | {prop name=filename}=*.doc{/prop} {prop name=filename}{regex}=*.doc{/regex}{/prop} | Bármely, szövegszerkesztővel létrehozott fájl (ezek kiterjesztése .doc)
@filename=olvassel.* | {prop name=filename}=olvassel.*{/prop} {prop name=filename}{regex}=olvassel.*{/regex}{/prop} | olvassel.fájl, olvassel.
@filename=olvassel.??? | {prop name=filename}=olvassel.???{/prop} {prop name=filename}{regex}=olvassel.???{/regex}{/prop} | olvassel.doc, olvassel.txt


Szóalakok lekérdezése

A szóalakos lekérdezések esetén az Indexelő szolgáltatás a megadott szó különböző alakjait keresi. Ezek a szóalakok lehetnek a lekérdezésben szereplő szó ragozott alakjai, vagy olyan szavak, amelyek a lekérdezésben szereplő szó utótagjai. Például:

  • Ragozott alakok: A lekérdezésben szereplő “hajolni” szó ragozott alakjai a hajlik és a hajlott.
  • Előtagok: A lekérdezésben szereplő “föld” szó alakjai a föld, földek, földmunka, földagad, és így tovább.

A szóalakos lekérdezések a Generate Method (Metódus létrehozása) címke segítségével adják meg a szó keresni kívánt alakjait. A szóalakos lekérdezések segítségével mind a tartalomban, mind a tulajdonságértékekben kereshet.

A következő táblázat példákat tartalmaz a szóalakos lekérdezések hosszú és rövid alakjaira.

 | Hosszú alak | Rövid alak | Eredmények
Előtag | {Generate method=prefix} föld {/Generate} | föld* | A “föld” előtaggal rendelkező szavak, például földes és földmunka.
Ragozott | {Generate method=inflect} hajolni {/Generate} | hajolni** | A hajolni szó különböző alakjai, mint például hajlik és hajlott.

Megjegyzés

  • Az előtagos alakok keresése az Indexelő szolgáltatás által támogatott valamennyi nyelven lehetséges. A ragozott alakok keresése nem minden támogatott nyelven lehetséges.


Relációs operátorok

A relációs operátorok segítségével végrehajtott lekérdezéssel megkeresheti azokat a dokumentumokat, amelyek tulajdonságértékei megfelelnek a megadott kapcsolatnak. Például a relációs lekérdezések segítségével meg lehet keresni a 100 000 bájtnál nagyobb méretű, vagy az 1999 január 1-én vagy azelőtt létrehozott dokumentumokat.

A következő táblázat a relációs operátorok leírását tartalmazza:

Operátor | Leírás
< | Kisebb, mint
<= | Kisebb vagy egyenlő, mint
= | Egyenlő
>= | Nagyobb vagy egyenlő, mint
> | Nagyobb, mint
!= | Nem egyenlő

A következő tábla példákat tartalmaz a relációs operátorokat használó lekérdezések hosszú és rövid alakos formájára.

Hosszú alak | Rövid alak | Eredmény
{prop name=DocPageCount} >6 {/prop} | @DocPageCount>6 | Több, mint 6 oldalas dokumentumok

Megjegyzés

  • Az Indexelő szolgáltatásban a @contents = szöveg lekérdezés érvénytelen, mert a Tartalom tulajdonságot nem lehet relációs lekérdezésekben használni.

A relációs összehasonlítások a legutóbb megadott tulajdonságra vonatkoznak. A következő lekérdezések eredménye megegyezik:

@DocPageCount>6AND<10
@DocPageCount>6AND@DocPageCount<10

Relációs operátorok és vektorok

Az értékek rendezett sorozata, vagyis vektorok között használt relációs operátorokat a szolgáltatás a megfelelő vektorelemekkel vizsgálja. A vektorokra vonatkoztatott állítás igaz (eredményt ad), ha az egyes állítások mindegyike igaz.

Vegyünk két vektort:

A (a1; a2; a3)

B (b1; b2; b3)

Az A>B állítás akkor és csak akkor igaz, ha a1>b1 és a2>b2 és a3>b3.

Ha az egyik vektor több elemből áll, mint a másik, a rendszer csak azokat az elemeket vizsgálja, amelyek párral rendelkeznek. A pár nélküli elemek figyelmen kívül maradnak.

AllOf és SomeOf operátorok

Az AllOf (^a) és SomeOf (^s) operátorok vektortulajdonság-összehasonlítások esetén használhatók, a relációs operátorokkal együtt. Az AllOf operátor használata esetén a relációs operátor bal oldalán található minden vektorelemre igaznak kell lennie az állításnak a jobb oldalon található minden vektorelemet véve. A SomeOf operátor használata esetén legalább az egyik vektorelemre igaznak kell lennie az összehasonlításnak, hogy az állítás igaz legyen.

Vegyük a következő példákat:

Állítás | Eredmény
(1,2,3)^a>(1,2) | Ez az állítás hamis, mert a bal oldalon található első elem nem nagyobb, mint a jobb oldalon található első elem.
(1,2,3)^s>(2,1) | Ez az állítás igaz , mert a bal oldalon található harmadik elem nagyobb, mint a jobb oldalon található első elem.

Bitösszehasonlítás

A hagyományos relációs operátorok mellett a lekérdezés bitösszehasonlító operátorokkal is lehetséges. Az AllOf és a SomeOf operátorok lehetővé teszik a tulajdonságértékek bitmintával történő összehasonlítását bitről bitre haladva.

Operátor | Példa | Megjegyzés
^a | @attrib^a 0x820 | Ebben a példában az Indexelő szolgáltatás csak azokat a tömörített dokumentumokat találja meg, amelyek archiválási bit attribútuma be van állítva.
^s | @attrib^s 0x20 | Ebben a példában az Indexelő szolgáltatás csak azokat a tömörített és tömörítés nélküli dokumentumokat találja meg, amelyek archiválási bit attribútuma bekapcsolt állapotú.


Reguláris kifejezések

A reguláris kifejezések olyan szimbólumkészletek, amelyek segítségével olyan lekérdezések hozhatók létre amelyek nem a Tartalom és Mind tulajdonságokban keresnek tulajdonságértékeket. A lekérdezésnyelv által támogatott reguláris kifejezéseket a Reguláris kifejezés operátorok témakörnél találja.

A Tartalom és a Mind tulajdonságokat nem lehet a reguláris kifejezésekkel együtt használni.

A következő táblázat példákat tartalmaz a reguláris kifejezéses lekérdezések hosszú és rövid alakjaira.

Rövid alak | Hosszú alak | Eredmény
#filename *.avi | {prop name=filename} {regex}*.avi {/regex} | Bármely .avi kiterjesztésű fájl (általában hang- és mozgóképfájlok)

Megjegyzés

  • Ha a tulajdonságlekérdezés csillag (*), kérdőjel (?) vagy függőleges vonal (|) karaktert tartalmaz, a rendszer ezt automatikusan reguláris kifejezésként kezeli, függetlenül attól, hogy milyen mód van beállítva.

Reguláris kifejezéses mintalekérdezések

Példa | Lekérdezés | Eredmény
Csoport | #filename = *|(ss|,ing|).cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve “ss” vagy “ing” karakterekre végződik, és .cxx kiterjesztéssel rendelkezik.
NOT operátor (^) | #filename = |[^f]*.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve nem “f” karakterrel kezdődik, és .cxx kiterjesztéssel rendelkezik.
Tartomány operátor (–) | #filename = |[a-d]*.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve az “a” betűtől a “c” betűig terjedő tartományba eső karakterrel kezdődik, és .cxx kiterjesztéssel rendelkezik.
Pontos számú egyezés | #filename = *s|{2|}.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve pontosan két “s” karakterre végződik, és .cxx kiterjesztéssel rendelkezik.
Legalább egy egyezés | #filename = es|{1,|}.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve az “es” karakterlánc kombinációja, és .cxx kiterjesztéssel rendelkezik Az “es.cxx” és az “eses.cxx” nevű fájlok megfelelnek, de az “esese.cxx” nevű fájl nem.
Egyezések két változó között | #filename = ci|{2,4}.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve a “ci” karakterlánc két vagy négy példányának kombinációja, és .cxx kiterjesztéssel rendelkezik A “cici.cxx” és a “cicicici.cxx” nevű fájlok megfelelnek, de a “ci.cxx” nevű fájl nem.
Nulla vagy több egyezés | #filename = c|*ss.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve nulla vagy több “c” karakterrel kezdődik, “ss” karakterekre végződik, és .cxx kiterjesztéssel rendelkezik. Az “ss.cxx”, a “css.cxx” és a “cccccss.cxx” nevű fájlok megfelelnek, de a “cctss.cxx” nevű fájl nem.
Nulla vagy egy egyezés | #filename = c|*ss.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve nulla vagy egy “c” karakterrel kezdődik, “ss” karakterekre végződik, és .cxx kiterjesztéssel rendelkezik. Az “ss.cxx” és a “css.cxx” nevű fájlok megfelelnek.
Egy vagy több egyezés | #filename = c|*ss.cxx | Minden olyan dokumentumot visszaad, amelynek fájlneve egy vagy több “c” karakterrel kezdődik, “ss” karakterekre végződik, és .cxx kiterjesztéssel rendelkezik. A “css.cxx” és a “cccccss.cxx” nevű fájlok megfelelnek, de a “cctss.cxx” és az “ss.cxx” nevű fájlok nem.


Reguláris kifejezés operátorok

A reguláris kifejezés operátorok használatára vonatkozó szabályok a következők:

  • Lekérdezéskor a csillag (*) és a kérdőjel (?) karakterek ugyanúgy viselkednek, mint a Windows alatt. A csillag (*) tetszőleges karakterek tetszőleges hosszúságú láncának felel meg. A pont (.) a karakterlánc végének felel meg. A kérdőjel (?) egyetlen tetszőleges karakternek felel meg.
  • A csillag (*), a kérdőjel (?), a pont (.) és a függőleges vonal (|) kivételével minden karakter önmagának felel meg.
  • A reguláris kifejezéseket páros idézőjelek (" ") közé lehet zárni, de feltétlenül idézőjelek közé kell zárni, ha szóközt vagy záró zárójelet ( ) ) tartalmaznak.

Ha függőleges vonal (|) előzi meg őket, a következő karakterek különleges jelentéssel bírnak.

Karakter | Leírás
( | Megnyitja a csoportot. Megfelelő záró zárójelnek kell követnie ( ) ).
) | Bezárja a csoportot. Megfelelő nyitó zárójelnek kell megelőznie ( ( ).
[ | Megnyitja a karakterosztályt. Megfelelő záró szögletes zárójelnek kell követnie (]).
] | Bezárja a karakterosztályt. Megfelelő nyitó szögletes zárójelnek kell megelőznie ([).
{ | Megnyitja a megszámolt egyezést. Megfelelő záró kapcsos zárójelnek kell követnie (}).
} | Bezárja a megszámolt egyezést. Megfelelő nyitó kapcsos zárójelnek kell megelőznie ({).
, | Elkülöníti az OR tagmondatokat.
* | A megelőző kifejezés nulla vagy több előfordulásának felel meg.
? | A megelőző kifejezés nulla vagy egy előfordulásának felel meg.
+ | A megelőző kifejezés egy vagy több előfordulásának felel meg.
Minden egyéb | Önmagának felel meg.

Szögletes zárójelek

Szögletes zárójelek ([ ]) között a következő karakterek különleges jelentéssel rendelkeznek:

Karakter | Leírás
^ | Az első karakternek kell lennie. Tetszőleges utána következő osztálynak felel meg.
] | Bezárja az osztályt. Csak beszúrási jel előzheti meg (^).
- | Tartomány operátor. Más karakterek előzik meg és követik.
Minden egyéb | Önmagának felel meg, tartományt kezd vagy bezár.

Kapcsos zárójelek

Kapcsos zárójelek ({ }) között az értelmezés a következő.

Karakter | Leírás
m | A megelőző kifejezés pontosan m számú előfordulásának felel meg (0< m < 256).
m, | A megelőző kifejezés legalább m számú előfordulásának felel meg (1< m < 256).
m,n | A megelőző kifejezés legalább m és n közötti számú előfordulásának felel meg, beleértve a szélső értékeket (0 < m < 256, 0 < n < 256).

Ha a csillag (*), a pont (.) vagy a kérdőjel (?) karakterre keres, tegye kapcsos zárójelbe. Ha például a "helló?" karakterláncot keresi, helló[?] alakban írja be a lekérdezésbe.


Vektoros lekérdezések

A vektoros lekérdezések azokat a dokumentumokat adják vissza, amelyek megfelelnek egy szó- és kifejezéslistának. A vektoros lekérdezések által visszaadott dokumentumok nem szükségszerűen felelnek meg minden szónak a lekérdezésben. A dokumentum rangsorban elfoglalt helye jelzi, mennyire felelt meg a lekérdezésnek.

Súlyozó tényezők hozzárendelésével befolyásolni lehet a szavak viszonylagos fontosságát, amelyen az eredmények rangsorolása alapul. A súlyok a 0,0 - 1,0 tartományba eshetnek. Például a következő vektoros lekérdezésben: ajándék, ló, mindkét szó azonos súllyal vesz részt az eredmények rangsorolásában. A következő lekérdezésben: {weight value=.3} ajándék, {weight value=.1} ló,
{weight value=.6} ajándék ló, az “ajándék” szó háromszor fontosabb a “ló” szónál, és a “ajándék ló” kifejezés kétszer fontosabb az “ajándék” szónál. Ha nincs megadva súlyozás, az Indexelő szolgáltatás alapértelmezés szerint az 1,0 súlyt használja. A szavak súlyozásáról további információt A szavak súlyozása című témakörnél talál.

A következő táblázat példákat mutat a vektoros lekérdezésekre.

Keresés tárgya | Példa | Eredmény
Adott szavakat tartalmazó dokumentumok | ajándék, ló | Azok a dokumentumok, amelyek tartalmazzák a keresett szavak egyikét, vagy mindkettőt. A mindkét szót tartalmazó dokumentumok a rangsorban megelőzik a csak az egyik szót tartalmazó dokumentumokat.
Előtagokat, szavakat és kifejezéseket tartalmazó dokumentumok | fog*, {weight value=.3} ajándék, {weight value=.1} ló, {weight value=.6} “ajándék ló” | Azok a dokumentumok, amelyek “fog” kezdetű szavakat, valamint az “ajándék”, a “ló” szavakat és az “ajándék ló” kifejezést tartalmazzák. Az “ajándék” szót tartalmazó dokumentumok a rangsorban a “ló” szót tartalmazó dokumentumok előtt, de az “ajándék ló” kifejezést tartalmazó dokumentumok mögött helyezkednek el.

Alább egy példa látható hosszú alakos vektoros lekérdezésre:

{vector RankMethod = max} {ve} {weight value=.250}osztály {ve} {weight value=.500}előfordulás {ve} {weight value=1.000}kurzor {/vector}

A vektoros lekérdezésnek nincs rövid alakos formája.

A RankMethod paraméter adja meg az Indexelő szolgáltatás által a lekérdezés eredménye rangsorának kiértékelésére használt algoritmust. A lekérdezés vektorainak megadását a {/vector} címkével kell lezárni.

A {ve} (vektorelem) címke azt jelzi, hogy az utána következő lekérdezésmegadás a vektoros lekérdezés eleme. A {ve} címke és a következő {ve} címke között található valamennyi szöveget a rendszer lekérdezésként értelmezi. A {ve} címkének nincs záró címkepárja.

Például:

{vector RankMethod = “Jaccard”} {ve} {weight value=0.200} @contents CONTAINS “nyomtatók” OR {coerce} “nyomtató-illesztőprogram” {ve} {prop name=DocTitle} {freetext} Hewlett Packard HP laser jet nyomtató{/freetext}{/prop} {ve} @contents hang** {/vector}.

  • Kifejezések súlyozása


A szavak súlyozása

A lekérdezésben szereplő szavak viszonylagos fontosságát a {weight} címke segítségével súlyozva befolyásolható az eredmények rangsorolása. Ez a címke a lekérdezésben szereplő szó előtt szerepel, és nincs záró címkepárja.

{weight value = n} szó

Az érték paraméter a szóhoz rendelt relatív súlyt adja meg. Ez az érték a 0,0 - 1,0 tartományba eshet.

Vegyük például a következő súlyozott lekérdezést.

{weight value=.250}kutya AND {weight value=.500}macska AND {weight value=1.000}malac

A “malac” szót tartalmazó dokumentumok megelőzik a rangsorban a “macska” szót tartalmazó dokumentumokat, amelyek viszont előbb állnak a rangsorban, mint a “kutya” szót tartalmazó dokumentumok.

Ha nem ad meg súlyt, az Indexelő szolgáltatás alapértelmezés szerint az 1,0 értéket használja. A súlyozásnak nincs rövid alakos formája, és nem kell zárócímkét megadni.


Az Indexelő szolgáltatás felügyelete

A szakasz tartalma:

  • Az Indexelő szolgáltatás felügyelete a Számítógép-kezelés segítségével
  • Katalógusok létrehozása
  • A tulajdonság méretének beállítása
  • Vizsgálat manuális indítása
  • A teljesítmény figyelése
  • Az Indexelő szolgáltatás teljesítményének beállítása


Az Indexelő szolgáltatás felügyelete a Számítógép-kezelés segítségével

Az Indexelő szolgáltatás megnyitásakor a részletek ablaktáblája tartalmazza a helyi számítógépen található valamennyi katalógus listáját. Minden egyes katalógus esetén a következő információkat mutatja:

  • Katalógus. A katalógus neve.
  • Hely. Az a lemezmeghajtó és könyvtár, ahol a katalógus található.
  • Méret (MB). A katalógus mérete megabájtban.
  • Összes dokumentum. A katalógusban indexelt dokumentumok és könyvtárak teljes száma.
  • Indexelni kívánt dokumentumok. Az indexelésre váró dokumentumok száma.
  • Nem kívánt indexelés. A pillanatnyilag nem indexelhető dokumentumok száma.
  • Szólisták. A memóriában található szólisták száma.
  • Mentett indexek. A lemezen mentett indexek száma.
  • Állapot. A katalógus jelenlegi állapota. (Az állapotkódok listáját a Katalógus indexelési állapotának ellenőrzése témakörnél találja.)

Egy katalógus kibontásakor a Könyvtárak és a Tulajdonságok mappa és az Indexelő szolgáltatás lekérdezés űrlapja jelenik meg. A Könyvtárak mappa kibontásakor a részletes ablaktábla megjeleníti a katalógus hatókörében lévő valamennyi könyvtár listáját, az egyes könyvtárak aliasait, és jelzi, hogy a könyvtárat kell-e indexelni.

A Tulajdonságok mappára kattintva a részletes ablaktábla megjeleníti a telepített szűrőkben azonosított valamennyi tulajdonság listáját. A részletes ablaktábla a következő oszlopokkal rendelkezik:

  • Tulajdonságkészlet. A tulajdonságcsoport tulajdonságszáma.
  • Tulajdonság. A tulajdonság hexadecimális vagy karakterlánc-azonosítója.
  • Rövid név. A tulajdonság érthető neve.
  • Adattípus. A tulajdonság adattípusa.
  • Méret a gyorsítótárban. A gyorsítótárban a tulajdonságérték számára foglalt terület mérete.
  • Tárolási szint. A tulajdonságérték tárolásának szintje a gyorsítótárban.

A tulajdonságokkal kapcsolatban további tudnivalókért tanulmányozza a Katalógusok létrehozása témakört.

A Microsoft Management Console használatával kapcsolatos további tudnivalókért tanulmányozza a Microsoft Management Console témakört.

Megjegyzés

  • Az Indexelő szolgáltatás felügyeletéhez rendszergazdai jogok szükségesek.


Katalógusok létrehozása

A telepítés során az Indexelő szolgáltatás létrehozza a Rendszer nevű alapértelmezett katalógust. Katalógusokat bármikor létre lehet hozni és el lehet távolítani. A meglévő katalógusok konfigurálása is lehetséges.

Ha a rendszer az Internet Information Services jelenlétét észleli, az Indexelő szolgáltatás Web néven is létrehoz egy katalógust. A katalógusokkal kapcsolatos további tudnivalókért tanulmányozza a Katalógusok témakört.

Katalógus felvétele

Katalógusokat az Indexelő szolgáltatás beépülő moduljaival is fel lehet venni. Katalógus felvételével kapcsolatban további tudnivalókért tanulmányozza a Katalógus létrehozása témakört.

Könyvtárak felvétele és kizárása a katalógusból

A katalógus felvétele után fel kell venni azokat a könyvtárakat, amelyeket bele kíván venni a katalógus hatókörébe. Ez a lefedett könyvtárak halmazát jelenti, amelybe beletartoznak az indexelni kívánt, illetve az indexelésből kifejezetten kizárt könyvtárak is. Alapértelmezés szerint a Rendszer katalógus felöleli a helyi tárolóeszközökön található valamennyi könyvtárat, kivéve az ideiglenes Internet-fájlokat és az előzményfájlokat. A könyvtárakat fel lehet venni a katalógus hatókörébe, és kifejezetten ki lehet zárni egyes könyvtárakat az indexelésből. Tegyük fel például, hogy a helyi D meghajtón a következő könyvtárak találhatók:

D:\Marketing

D:\Marketing\Személyes

D:\Marketing\Vegyes

Ha a D:\Marketing könyvtárat felveszi a katalógus hatókörébe, akkor a D:\Marketing\Személyes és a D:\Marketing\Vegyes könyvtárak indexelése is megtörténik. Ha nem kívánja indexelni a D:\Marketing\Személyes nevű könyvtárban található dokumentumokat, vegye fel a könyvtárat a Könyvtárak listába, és a Belekerüljön az indexbe beállításnál kattintson a Nem lehetőségre.

Ha egy alkönyvtár olyan könyvtárban található, amely ki van zárva az indexelésből, a tartalmazott könyvtár is ki van zárva, még akkor is, ha külön bejegyzésként veszi fel a katalógusba, és a Belekerüljön a katalógusba elemnél az Igen lehetőség ki van választva.

A katalógus hatókörének korlátozásában helyettesítő karakterek is használhatók. Például felveheti a következőket a könyvtárak listájába:

Könyvtár | Felvétel a katalógusba | Magyarázat
C:\ | Igen | Mindent felvesz a C meghajtóról.
C:\Winnt\Profiles\*\ Temporary Internet Files\* | Nem | Minden dokumentum kizárása a C:\WINNT\Profiles könyvtárban található bármely Temporary Internet Files nevű almappában.

A könyvtárak katalógusba történő felvételével és kizárásával kapcsolatos további tudnivalókért tanulmányozza a Könyvtár felvétele és kizárása egy katalógusból témakört.

A katalógus beállítása

Egy katalógus beállítása során a következőket kell megadni:

  • Sor kerüljön-e automatikusan a hálózati aliasnevek felvételére.
  • Kell-e webkiszolgálókat indexelni, és melyeket.
  • Sor kerüljön-e az ismeretlen kiterjesztésű dokumentumok indexelésére.
  • Készítsen-e az Indexelő szolgáltatás kivonatokat az indexelt dokumentumokból, és ha igen, mekkora legyen a kivonat maximális mérete.

Katalógus konfigurálásával kapcsolatban további tudnivalókért tanulmányozza a Katalógus beállítása témakört.

Menteni kívánt tulajdonságok megadása

A következő tulajdonságértékek tárolása alapértelmezés szerint a Rendszer katalógus tulajdonság-gyorsítótárában történik.

Tulajdonság | Rövid név | Gyorsítótár tárolási szintje | Leírás
0x8 | FájlIndex | Elsődleges | NTFS partíción található dokumentum egyedi azonosítója. Ez a dokumentumok módosításainak nyomon követéséhez szükséges.
0xd | Attrib | Elsődleges | Dokumentumattribútumok (mint például Archiválandó, Írásvédett vagy Könyvtár). Ezek gyorsítótárba helyezésére a könyvtárakat kizáró (csak dokumentumokat lekérdező) lekérdezések optimalizálása érdekében kerül sor.
0x5 | ----- | Elsődleges | Kötetazonosító. Ez az NTFS kötetek egyedi kötetazonosítója. A FájlIndex tulajdonsággal együtt használva egyedileg azonosíthatók az NTFS fájlok.
0x6 | ----- | Elsődleges | Szülő munkaazonosító. A munkaazonosító a belső fájlközötti rendszerazonosító. A szülő munkaazonosító a szülőkönyvtár munkaazonosítója (például a C:\Munkák\Jelentések könyvtár szülő munkaazonosítója a C:\Munkák könyvtár munkaazonosítója). Ennek gyorsítótárba helyezésére a lekérdezések hatókör-ellenőrzésének optimalizálása érdekében kerül sor.
0x7 | ----- | Elsődleges | Másodlagos tárolási azonosító. Ez az adott elsődleges rekordnak megfelelő, a tulajdonság-gyorsítótár másodlagos szintjén található rekord azonosítója. Ez az azonosító belső használatra van fenntartva.
0xe | Írás | Másodlagos | A dokumentum utolsó írásának időpontja.
0xc | Méret | Másodlagos | A dokumentum mérete.
0xb | Elérési út | Másodlagos | A dokumentum elérési útja.
0x2 | DocTitle | Másodlagos | A dokumentum címe (HTML <TITLE> vagy az ActiveX adatlap címe).

Más tulajdonságértékek is felvehetők a gyorsítótár bármelyik szintjén való tárolásra.

Fontos

  • Egy tulajdonságérték eltávolítása azt jelenti, hogy az eredmények listáján esetleg nem jelenik meg. Tulajdonságértékek felvétele bármelyik szintre, de különösen az elsődleges szintre, csökkentheti a teljesítményt, és nagy lemezterületet foglal.

    A tulajdonságértékek mentésével kapcsolatos további tudnivalókért tanulmányozza a Tulajdonság felvétele a tulajdonság-gyorsítótárba témakört.


A tulajdonság méretének beállítása

A tulajdonság mérete a tulajdonság értékének tárolásához szükséges bájtok száma. A tulajdonság mérete lehet állandó vagy változó. Ha állandó méretű tulajdonságot vesz fel a katalógusba, az Indexelő szolgáltatás állítja be a tulajdonság számára a megfelelő méretet. A méretet nem lehet megváltoztatni.

Változó méretű tulajdonságok esetén a méret kiválasztható. A rendszer a kiválasztott tulajdonságok teljes értékét tárolja minden dokumentum esetén még akkor is, ha az nagyobb a beállított méretnél. A beállított méret befolyásolja a katalógus számára szükséges lemezterületet, és a lekérdezés feldolgozásához szükséges időtartamot.

Két megoldás lehetséges:

  • Ha nagy méretet állít be, a katalógus több lemezterületet foglal, de a lekérdezés teljesítménye javulhat.
  • Ha kis méretet állít be, lemezterületet takaríthat meg, de mindez a teljesítmény rovására történik.

A változó méretű tulajdonság méretének beállításakor becsülje meg a lehető legpontosabban a legtöbb dokumentum számára elegendő méretet, figyelembe véve, hogy egyes dokumentumok esetén a tulajdonság üres lehet, majd állítsa a tulajdonság méretét kissé nagyobb értékre. Ezzel biztosíthatja, hogy a tulajdonság legtöbb értéke elfér a lefoglalt területen.

A tulajdonság mérete csökkenthető a teljesítmény vagy a lemezkihasználtság javítása érdekében. Azonban minden egyes módosítás alkalmával teljes átvizsgálást kell végrehajtani, hogy a változás minden dokumentumra nézve életbe lépjen.

A tulajdonságok méretének beállításáról további információt a Tulajdonság felvétele a tulajdonság-gyorsítótárba című témakörnél talál.

A teljes átvizsgálás végrehajtásáról további információt az A pásztázás kézi indítása című témakörnél talál.


Vizsgálat manuális indítása

Az indexelt könyvtárak bármelyikén lehetséges a teljes vagy növekményes vizsgálat kézi elindítása. A következő helyzetekben kell teljes vizsgálatot indítani:

  • Új szűrőt telepített, szűrőt távolított el, vagy kijavította a szűrő regisztrációs információját.
  • Megváltoztatta a kivonat méretét.
  • Megváltoztatta az ismeretlen dokumentumkiterjesztések indexelését.
  • Új szóelválasztó szoftvert telepített.
  • Tulajdonságot vett fel a tulajdonság-gyorsítótárba.
  • Megváltoztatta a tulajdonság típusát vagy méretét a tulajdonság-gyorsítótárban.
  • Új nyelvet vett fel a Vezérlőpulton.
  • Módosította a kivételszavak listáját.

Megjegyzés

  • Teljes vizsgálat indításakor a katalógus hatókörében lévő valamennyi dokumentum átvizsgálása újra megtörténik, ami hosszú időt vehet igénybe. A lekérdezések továbbra is visszaadnak dokumentumokat, de a lekérdezés sebessége lelassulhat a vizsgálat és az indexelés alatt.

A vizsgálat kézi indításával kapcsolatos további tudnivalókért tanulmányozza a Vizsgálat manuális indítása témakört.


A teljesítmény figyelése

A Windows 2000 beépített teljesítményfigyelő képessége segítségével megfigyelheti az Indexelő szolgáltatást. A Rendszerfigyelővel kapcsolatos további tudnivalókért tanulmányozza A teljesítmény elemzése témakört.

Indexeléssel kapcsolatos teljesítményszámlálók

A következő teljesítményszámlálók az indexeléssel és az egyesítéssel kapcsolatosak (a Rendszerfigyelőben található Indexelő szolgáltatási objektum alatt).

Számlálónév | Magyarázat
Index mérete (MB) | A mentett indexek összmérete megabájtban
Mentett indexek | A mentett indexek száma
Egyesítési folyamat | Az elvégzett egyesítés százaléka
Szólisták | Szólisták száma
Egyedi kulcsok | Egyedi szavak száma az indexben
Indexelt dokumentumok száma | A jelenlegi indexelési munkamenet kezdete óta indexelt dokumentumok száma. Ügyeljen arra, hogy ez nem foglalja magába az Indexelő szolgáltatás korábbi munkameneteiben indexelt dokumentumokat.
Indexelni kívánt dokumentumok | Azon dokumentumok minimális száma, melyek indexelése szükségessé vált.
Nem kívánt indexelés | Azon dokumentumok száma, amelyeknek indexelése szükséges, de nem lehetséges, mert használatban vannak.
Dokumentumok száma | Az indexelés által ismert dokumentumok száma.

A következő számlálók a Rendszerfigyelőben, az Indexelő szolgáltatás szűrője objektum alatt találhatók.

Számlálónév | Magyarázat
Kötési idő (ms) | Szűrőfájlhoz kötéshez szükséges átlagos idő (ezredmásodpercben)
Indexelési sebesség (MB/ó) | A dokumentumok indexelésének sebessége (megabájt/óra). Ez nem foglalja magába a kivonatok készítését.
Teljes indexelési sebesség | A dokumentumok indexelésének sebessége (megabájt/óra). Ez magába foglalja a kivonatok készítését.

Lekérdezéssel kapcsolatos teljesítményszámlálók

A következő, lekérdezéssel kapcsolatos számlálók találhatók a Rendszerfigyelőben, az Indexelő szolgáltatás objektum alatt.

Számlálónév | Magyarázat
Futó lekérdezések | Feldolgozás alatt lévő lekérdezések száma
Az összes lekérdezés száma | A jelenlegi indexelési munkamenet alatt feldolgozott lekérdezések száma


Az Indexelő szolgáltatás teljesítményének hangolása

Az Indexelő szolgáltatás teljesítményét a szolgáltatás használatának módjától függően be lehet állítani. A beállítás során módosul az indexeléshez és a lekérdezések feldolgozására használt számítógépes erőforrások mennyisége.

Az Indexelő szolgáltatás teljesítményének módosításáról további információt Az Indexelő szolgáltatás teljesítményének megváltoztatása című témakörnél talál.


Hibaelhárítás

A rész tartalma:

  • Hibák észlelése és javítása
  • Az Indexelő szolgáltatás eseményüzenetei


Az Indexelő szolgáltatás eseményüzenetei

A következő táblázat az eseménynaplóban előforduló eseményüzeneteket ismerteti. A CI megjelölés az Indexelő szolgáltatást jelöli.

Üzenet száma | Üzenet | Megjegyzések
4097 | A CI szolgáltatás sikeresen elindult. | Nincs teendő. Ez az üzenet mindig megjelenik az Indexelő szolgáltatás elindulásakor.
4098 | A CI szolgáltatás sikeresen leállt. | Nincs teendő. Ez az üzenet mindig megjelenik az Indexelő szolgáltatás leállásakor.
4101 | A fájl (<teljes elérési út>) fájl tartalomindex-szűrője ennyiszer több tartalomadatot generált, mint a fájl mérete: <n>. | A <teljes elérési út> fájl indexelése nem sikerült, mert túl sok adat keletkezett a fájl fizikai méretéhez viszonyítva. A fájl a nem szűrt listában jelenik meg. Ez a jelenség lehet normális, de okozhatja a használt szűrő hibája is. Ha ellenőrizte, hogy a hibát nem a szűrő okozza, növelheti az Indexelő szolgáltatás által dokumentumonként engedélyezett adatmennyiséget. Ezzel kapcsolatban olvassa el a Microsoft Platform Software Development Kit készletben a MaxFilesizeMultiplier rendszerleíróadatbázis-beállítás megadásával kapcsolatos információkat.
4102 | A teljes összefésülés megkezdődött a következőn: <katalógus elérési útja>. | Nincs teendő.
4103 | A teljes összefésülés befejeződött a következőn: <katalógus elérési útja>. | Nincs teendő.
4104 | A teljes összefésülés felfüggesztődött a következőn: <katalógus elérési útja> a következő hiba miatt: <hibakód>. Későbbre lesz ütemezve. Későbbi időpontra lett átütemezve. | Nincs teendő. Az Indexelő szolgáltatás nem tudta befejezni a teljes összefésülést a <hiba> miatt, de az összefésülés automatikusan újraindul. A hiba legvalószínűbb oka a túl kevés lemezterület.
4105 | Nem kezdeményezhető teljes összefésülés <hibakód> hiba miatt a következőn: <katalógus elérési útja>. | Nincs teendő. Az Indexelő szolgáltatás nem tudta elindítani a teljes összefésülést a <hiba> miatt, de az összefésülés automatikusan újraindul. A hiba legvalószínűbb oka a túl kevés lemezterület.
4106 | Nem indítható újra a teljes összefésülés <hibakód> hiba miatt a következőn: <katalógus elérési útja>. | Nincs teendő. A teljes összefésülést nem lehetett újraindítani a szünetelés után a <hibakód> hiba miatt, de az összefésülés automatikusan újraindul. A hiba legvalószínűbb oka a túl kevés lemezterület.
4107 | A tartalomindex nem tudta szűrni a következő fájlt: <teljes elérési út>. A szűrési művelet <n> alkalommal is sikertelenül próbálkozott újra. | A <teljes elérési út> fájl a nem szűrt listában jelenik meg. Ez a fájl sérülését vagy a dokumentumszűrő hibáját jelezheti.
4108 | Teljes összefésülés kezdeményezése történt a következőn: <katalógus elérési útja>, mert az árnyékindexek mérete meghaladta a lemez <n%>-át. | Nincs teendő.
4109 | Teljes összefésülés kezdeményezése történt a következőn: <katalógus elérési útja>, mert több, mint <n> dokumentum változott az utolsó összefésülés óta. | Nincs teendő.
4110 | Teljes összefésülés kezdeményezése történt a következőn: <katalógus elérési útja>, mert a maradék lemezterület kisebb, mint <n%>. | Nincs teendő.
4111 | Az NTFS szűrőszolgáltatás a következő hibakóddal állt le: <hibakód>. | Lépjen kapcsolatba a Microsoft technikai tanácsadó szolgálattal.
4112 | A szűrőszolgáltatás nem tudott futni, mert a fájl (<teljes elérési út>) nem található a rendszeren. | Lépjen kapcsolatba a Microsoft technikai tanácsadó szolgálattal.
4118 | A tartalom vizsgálatát nem lehetett befejezni a következőn: <könyvtár>. | A <könyvtár> könyvtárban található fájlok hiányozhatnak az indexből. Kézzel indítsa el a teljes újravizsgálatot.
4119 | A fájlban (<fájl teljes elérési útja>) lévő egy vagy több beágyazást nem sikerült szűrni. | Nincs teendő. Az indexelni kívánt dokumentum olyan beágyazott dokumentumot tartalmazott, amelyhez nem volt szűrő.
4120 | A bővítmény (< bővítmény>) osztálya ismeretlen. Mintafájl: <fájl teljes elérési útja> | Ha ismeretlen kiterjesztéssel rendelkező fájlokat indexel, ez az üzenet azonosítja az ismeretlen kiterjesztéseket.
4121 | A teljes összefésülés újraindult a következőn: <katalógus elérési útja>. | Nincs teendő.
4122 | A CI szűrődémon leállt, és ezért újra lesz indítva. | A CIDaemon.exe megállt, valószínűleg azért, mert az indexelni kívánt dokumentumhoz nem rendelkezett szűrővel.
4123 | A meghajtón (<meghajtó>) lévő tartalomindex-metaadatok megsérültek. Az index automatikusan helyre lesz állítva. Ajánlatos kiadni a chkdsk /f parancsot. | A metaadatok sérültek. Megvárhatja, amíg az Indexelő szolgáltatás automatikusan újraindexeli a tartalmat, vagy ha rendelkezik biztonsági másolattal, az indexet visszaállíthatja abból is.
4124 | A következő tartalomindexe sérült: <meghajtó>. Állítsa le, és indítsa újra az Indexelő szolgáltatást (cisvc). | Az indexadatok megsérültek, és az Indexelő szolgáltatás nem tudja automatikusan újraindexelni a tartalmat. Állítsa le, majd indítsa újra az Indexelő szolgáltatást.
4126 | Sérült tartalomindex-metaadatok törlése a következőn: <meghajtó elérési útja>. Az index helyreállítása a dokumentumok újraszűrése után automatikusan megtörténik. | A metaadatok sérültek. Megvárhatja, amíg az Indexelő szolgáltatás automatikusan újraindexeli a tartalmat, vagy ha rendelkezik biztonsági másolattal, az indexet visszaállíthatja abból is.
4127 | Nem lehetett inicializálni a következőn lévő tartalomindexet. <katalógus elérési útja>. Hiba: <hibakód>. | Lépjen kapcsolatba a Microsoft technikai tanácsadó szolgálattal.
4128 | Hiba (<hibakód>) észlelhető a következő tartalomindexén: <katalógus elérési útja>. | Lépjen kapcsolatba a Microsoft technikai tanácsadó szolgálattal.
4129 | A PropertyStore helyreállítása megkezdődik a következő katalógusban: <katalógus elérési útja>. | Nincs teendő. Az Indexelő szolgáltatás sérült adatokat talált a tulajdonságtárban, és megpróbálja kijavítani.
4130 | A helyreállítás sikeresen végre lett hajtva a PropertyStore-on a következő katalógusban: <katalógus elérési útja>. | Nincs teendő.
4131 | A PropertyStore inkonzisztens a következő katalógusban: <katalógus elérési útja>. | Sérült adatok találhatók a tulajdonságtárban.
4132 | <n> inkonzisztencia található a PropertyStoreban <katalógus elérési útja> katalógus helyreállítása közben. | A tulajdonságtárban <n > sérült rekord található. Az Indexelő szolgáltatás automatikusan újraépíti a tulajdonságtárat.
4133 | Nagyon kevés lemezterület van a következő meghajtón: <meghajtó>. Szabadítson fel legalább <n> MB lemezterületet a tartalomindex folytatásához. | Az indexelés leállt a lemezterület hiánya miatt.
4134 | A fájlváltozásokról szóló értesítések a következő hiba miatt ki vannak kapcsolva <könyvtár > hatókörre: <hibakód>. Ez a hatókör időnként újra lesz vizsgálva. | Ez az üzenet általában hálózati hiba eredménye. Próbálja leállítani, majd újraindítani az Indexelő szolgáltatást.
4135 | A hatókör (<könyvtár>) fájlmódosítási értesítése nincs engedélyezve a következő hiba miatt: <hibakód >. Ez a hatókör időnként át lesz vizsgálva. | Ez az üzenet általában hálózati hiba eredménye. Próbálja leállítani, majd újraindítani az Indexelő szolgáltatást.
4136 | A(z) <összetevő> nem tudta bejelentkeztetni <felhasználónév> felhasználót, mert <hibakód > kódú hiba történt. | Ez általában azt jelenti, hogy rossz jelszót írt be az egyetemes elnevezési konvenció katalógus számára.
4137 | A CI megkezdődött a következő katalógus számára: <katalógus elérési útja>. | Nincs teendő.
4138 | A tartalomindex megsérült a következő összetevőben: <katalógus elérési útja>. A verem nyoma: <veremnyomkövetés>. | Ha ez megismétlődik, jegyezze fel a veremnyomkövetés értékét, és hívja fel a Microsoft terméktámogatást.
4139 | Az elérési út (<könyvtár>) túl hosszú a tartalomindexhez. | A katalógus elérési útja legfeljebb 250 karakter hosszúságú lehet.
4140 | Az értesítések nem engedélyezettek a következőn. <könyvtár>, mert ez DFS-megosztás. Ez a hatókör időnként meg lesz vizsgálva. | Nincs teendő.
4141 | Ellenőrizze a rendszeridőt. Lehet, hogy érvénytelen időt mutat. | Ellenőrizze a rendszeridőt.
4142 | A virtuális gyökér (<virtuális gyökér>) hozzáadása az indexhez. Hozzárendelve a következőhöz: <könyvtár>. | Nincs teendő.
4143 | A virtuális gyökér (<virtuális gyökér >) eltávolítása az indexből. | Nincs teendő.
4144 | A hatókör (<könyvtár>) hozzáadása az indexhez. | Nincs teendő.
4145 | A hatókör (<könyvtár >) eltávolítása az indexből. | Nincs teendő.
4146 | A fiók (<felhasználónév>) nem rendelkezik az interaktív bejelentkezési joggal ezen a számítógépen. Interaktív bejelentkezési jogot ezen a számítógépen a Felhasználókezelő felügyeleti eszközzel adhat a következőnek. <felhasználónév>. | Adjon a(z) <felhasználónév> fióknak interaktív bejelentkezési jogosultságot, vagy válasszon másik fiókot a bejelentkezéshez.
4147 | Az IISADMIN szolgáltatás nem érhető el, így a virtuális gyökereket nem lehet indexelni. | Indítsa el az IIS felügyeleti szolgáltatást (vagy keresse meg annak okát, hogy miért nem indult el). Ha már nincs szüksége az IIS szolgáltatásra, el is távolíthatja a virtuális gyökereket az Indexelő szolgáltatásból.
4148 | A fájl (<teljes elérési út>) törlése újbóli vizsgálatot eredményezett, mert potenciálisan rövid fájlnév volt. Próbálja elkerülni a "~" karakterek használatát nevekben, vagy tiltsa le a "8 PONT 3" nevek létrehozását. | Hajtsa végre az üzenet utasításait.
4149 | Az NTFS kötet (%1) USN-naplójának olvasása nem sikerült, hibakód: <hibakód>. A kötet kapcsolat nélkül marad mindaddig, amíg az Indexelő szolgáltatás (cisvc) újra nem indul. | Lépjen kapcsolatba a Microsoft technikai tanácsadó szolgálattal.
4150 | A CI szolgáltatás megpróbált elindulni, de nem sikerült, mert a DonotStartCiSvc rendszerleíró paraméter be volt állítva. | A DonotStartCiSvc rendszerleíróadatbázis-beállítás törlésével kapcsolatban a Microsoft Platform Software Development Kit készletből tájékozódhat.

Az Indexelő szolgáltatás teljesítményének módosításáról további információt Az Indexelő szolgáltatás teljesítményének hangolása című témakörnél talál.

Az Indexelő szolgáltatás teljesítményének figyeléséről további információt A teljesítmény figyelése című témakörnél talál.


Hibák észlelése és javítása

Mi a probléma?

A dokumentumértesítések elvesznek

Ok: Az Indexelő szolgáltatás normális működése során a rendszer a dokumentumok minden módosítását nyomon követi, ha az indexelt könyvtárak NTFS vagy FAT köteteken helyezkednek el. Ha a dokumentummódosítások sebessége nagyon nagy, előfordulhat, hogy egyes értesítések elvesznek, különösen FAT köteteken.

Megoldás: Nincs szükség kézi beavatkozásra. Az Indexelő szolgáltatás automatikusan beütemezi az értesítéseket elvesztett könyvtár növekményes vizsgálatát.

A hálózati kapcsolat megszakadt

Ok: Ha a könyvtár fizikailag egy távoli megosztáson helyezkedik el, és a távoli megosztással a kapcsolat megszakad, az Indexelő szolgáltatás észleli ezt, és a távoli megosztást vizsgálva észleli a kapcsolat aktívvá válását.

Megoldás: Nincs szükség kézi beavatkozásra.

A dokumentumokat nem lehet indexelni

Ok: Ha az Indexelő szolgáltatás sérült dokumentumokat észlel, vagy huzamosabb időn keresztül nem tud hozzáférni egy dokumentumhoz, ezek a dokumentumok nem indexelt megjelölést kapnak. Előfordulhat az is, hogy az adott dokumentumok indexelésére használt szűrő hibás.

Megoldás:A nem indexelt dokumentumok listáját az Indexelő szolgáltatás lekérdező űrlapja segítségével kaphatja meg. Ha bizonyos típusú dokumentumokat következetesen nem lehet indexelni, lépjen kapcsolatba az adott szűrő szállítójával. A nem indexelt dokumentumok listájának megszerzésével kapcsolatos további tudnivalókért tanulmányozza A nem indexelt dokumentumok listájának megszerzése témakört.

A lemez megtelt

Ok: Ha a katalógust tároló partíció kezd megtelni, az indexelés átmenetileg szünetel. Ha a partíción csak nagyon kevés szabad lemezterület áll rendelkezésre (20 megabájtnál kevesebb), az Indexelő szolgáltatás szünetel, amíg több lemezterület válik elérhetővé. Az alkalmazás eseménynaplójába üzenet kerül, ha a partíció kezd megtelni.

Megoldás: Figyelje az eseménynaplóban ezeket az üzeneteket, és szükség szerint tegyen elérhetővé több lemezterületet.

Az adatok sérültek

Ok: Abnormális körülmények között az indexelési adatok helyreállíthatatlanul megsérülhetnek.

Megoldás: Az Indexelő szolgáltatás meglévő adatait törölni kell, és újra kell indexelni valamennyi dokumentumot. Ha a rendszer sérülést észlel az Indexelő szolgáltatás indításakor, az újraindexelés automatikusan megtörténik. Ha azonban a sérülést a rendszer normális működés során észleli, az eseménynaplóba írt üzenettel jelzi, és további lekérdezéseket nem engedélyez. Ha az eseménynaplóban ezt a feljegyzett eseményt találja, állítsa le, és indítsa újra az Indexelő szolgáltatást.

Amikor az Indexelő szolgáltatás automatikus helyreállítást hajt végre, eseményüzenetet ír az eseménynaplóba.

Az eseményüzenetekkel kapcsolatos további tudnivalókért tanulmányozza Az Indexelő szolgálat eseményüzenetei témakört.