Bevezető a Windows 2000 Server használatakor

Bevezető témakörei maximum száz ügyfelet ellátó, 2-5 kiszolgálóból álló tartomány (csoport) telepítésében nyújtanak segítséget. Ha ennél több kiszolgálóból álló tartomány rendszergazdájaként működik, Bevezető témakörei akkor is hasznosak, ám a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című anyagát is érdemes elolvasnia. Ha többet kíván megtudni a Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.

További információt az alábbi témakörökben talál:

  • Segédletek: A Windows 2000 üzembe helyezése
  • A Windows 2000 Server újdonságai
  • A Windows 2000 Server telepítése
  • Kisegítő lehetőségek megváltozott munkaképességűek számára


Segédletek: A Windows 2000 üzembe helyezése

A Microsoft webhely olyan segédleteket kínál, melyekből megtanulhatja a Windows 2000 operációs rendszer üzembe helyezésének módját. Ezek a technikai segédletek lépésről-lépésre elmagyarázzák és bemutatják a Windows 2000 Server alapvető szolgáltatásainak telepítését és beállítását.

Active Directory

  • Segédlet az Active Directory – helyek és szolgáltatások programhoz (Acitve Directory Sites and Services Walk-through) (http://www.microsoft.com/)

    Bemutatja az Active Directory - helyek és szolgáltatások program használatát mutatja, melynek segítségével a vállalati környezetben található replikációs topológiát felügyelheti.

  • Az Active Directory speciális kezelése a séma és a megjelenítésleíró segítségével (Advanced Management of Active Directory Using the Schema and Display Specifiers) (http://www.microsoft.com/)

    Az Active Directory speciális felügyeletének bemutatása az Active Directory Séma beépülő modul és a megjelenítésleíró használatával.

  • Az elosztott szolgáltatások biztonsági mentése és helyreállítása (Backup and Recovery of the Distributed Services) (http://www.microsoft.com/)

    A biztonságimásolat-készítő segédprogram segítségével végezhető végzetes probléma utáni helyreállításba és az elosztott szolgáltatások ismertetése.

  • Tömeges importálás és exportálás az Active Directoryba (Bulk Import and Export to Active Directory) (http://www.microsoft.com/)

    Az Active Directory kötegfelügyeletének bemutatása.

  • Elosztott fájlrendszer (Distributed File System) (http://www.microsoft.com/)

    A könyvtárak és fájlok logikai megjelenítésére szolgáló elosztott fájlrendszer használatának ismertetése.

  • A Vezérlés delegálása varázsló használata (Using the Delegation of Control Wizard) (http://www.microsoft.com/)

    Példák az objektumok vezérlésének delegálására egy Active Directory mappában az Active Directory - felhasználók és számítógépek program segítségével.

  • Független szoftvereladók Active Directory kezelésére képes termékei (Products from ISVs Extend Active Directory Management) (http://www.microsoft.com/)

    A vezető független szoftvereladóknak az Active Directory kezelésére szolgáló termékeinek és bővítéseinek leírása.

  • Segédlet az Active Directory kezeléséhez (Managing the Active Directory Walk-through) (http://www.microsoft.com/)

    Bevezetés az Active Directory címtárszolgáltatás felügyeletébe.

Kommunikációs és hálózati szolgáltatások

  • Segédlet az ISM-SMTP replikáció telepítéséhez (Setting up ISM-SMTP Replication Walk-through) (http://www.microsoft.com/)

    Két Windows 2000 alapú, különböző tartományokban lévő tartományvezérlő közötti Simple Mail Transfer protokoll (SMTP) replikáció konfigurációjának, valamint a Windows 2000 Active Directory helyközi üzenőszolgáltatás (ISM) architektúrájának rövid leírása.

Kezelési szolgáltatások

  • Közös infrastruktúra a módosítások és konfigurációk kezeléséhez (A Common Infrastructure for Change and Configuration Management Walk-through) (http://www.microsoft.com/)

    Egy olyan közös infrastruktúra leírása, mely minden Windows 2000 operációs rendszer kezelésére használható.

  • Segédlet a Microsoft Management Console használatához (Microsoft Management Console Walk-through) (http://www.microsoft.com/)

    A Microsoft Management Console (MMC) fő szolgáltatásainak leírása, amely tartalmazza az új konzol létrehozásának és a beépülő modulok testreszabásának módját. Az MMC egy független szoftvereladói termékekkel is bővíthető közös, konzol alapú, alkalmazások kezelésére szolgáló keret.

  • Segédlet a távtelepítési szolgáltatáshoz (Remote Installation Services Walk-through) (http://www.microsoft.com/)

    A Windows 2000 Server egyik választható szolgáltatása, a Távtelepítési szolgáltatás telepítéséhez, beállításához és használatához szükséges lépések.

  • Segédlet a Csoportházirend használatához (Group Policy Walk-through) (http://www.microsoft.com/)

    A Csoportházirend leírása. Ez az összetevő a Windows 2000 módosítás- és konfigurációkezelő szolgáltatásainak alapja.

  • Távtároló (Remote Storage) (http://www.microsoft.com/)

    A távtároló szolgáltatás telepítésének és felügyeletének leírása.

  • A másodlagos bejelentkezés (Futtatás mint) használata a Windows 2000 operációs rendszerben (Using Secondary Logon (Run As) in Windows 2000) (http://www.microsoft.com/)

    A másodlagos bejelentkezési szolgáltatás leírása, melynek segítségével a rendszergazda számára elkerülhető, hogy minden feladathoz rendszergazdai fiókkal jelentkezzen be.

  • Segédlet a szoftvertelepítéshez és -karbantartáshoz (Software Installation and Maintenance Walk-through) (http://www.microsoft.com/)

    A Windows 2000 operációs rendszer szoftvertelepítési és -karbantartási munkáinak leírása.

  • Segédlet a felhasználói adatok és felhasználói beállítások kezeléséhez (User Data and User Settings Management Walk-through) (http://www.microsoft.com/)

    Az IntelliMirror felhasználói adat- és beállításkezelő szolgáltatásainak leírása.

  • Segédlet az alkalmazások Windows Telepítő számára történő újracsomagolásához a WinINSTALL LE segítségével (Using WinINSTALL LE to Repackage Applications for the Windows Installer Walk-through) (http://www.microsoft.com/)

    A szoftvertelepítési csomagok létrehozásának és testreszabásának leírása Windows 2000 rendszerben történő működéshez.

Biztonsági szolgáltatások

  • Segédlet a bizonyítványszolgáltatások felügyeletéhez (Administering Certificate Services Walk-through) (http://www.microsoft.com/)

    A bizonyítványok Bizonyítványkezelő beépülő modul segítségével történő beszerzésének és kezelésének leírása.

  • Segédlet a speciális bizonyítványkezeléshez (Advanced Certificate Management Walk-through) (http://www.microsoft.com/)

    A bizonyítványok Bizonyítványkezelő beépülő modul segítségével történő beszerzésének és kezelésének leírása.

  • Segédlet a számítógépek automatikus bizonyítványigénylésének beállításához (Automatic Certificate Request for Computers Walk-through) (http://www.microsoft.com/)

    A Csoportházirend használatának ismertetése automatikus számítógépes bizonyítványigénylés beállítására Windows 2000 tartományban.

  • Segédlet a bizonyítványszolgáltatások webhelyeinek használatához (Certificate Services Web Pages Walk-through) (http://www.microsoft.com/)

    Hitelesítő szervezet által kiadott bizonyítványok, felhasználói bizonyítványok és más különleges bizonyítványok igénylési módjának leírása.

  • Végfelhasználói bizonyítványok kezelése (End User Certificate Management) (http://www.microsoft.com/)

    Annak a folyamatnak a leírása, melynek során a végfelhasználók a hitelesítő szervezetektől beszerzik a bizonyítványokat, és azokat kezelik.

  • Titkosított fájlrendszer (Encrypting File System) (http://www.microsoft.com/)

    A Titkosított fájlrendszer végfelhasználói és felügyeleti jellemzőinek bemutatása.

  • Bizonyítványok hozzárendelése felhasználói fiókokhoz (Mapping Certificates to User Accounts) (http://www.microsoft.com/)

    A nyilvános kulcsú bizonyítványok felhasználói fiókokhoz rendelésének módja az Internet Information Services programmal való használathoz.

  • MIT Kerberos 5 (krb5 1.0) együttműködés (MIT Kerberos 5 (krb5 1.0) Interoperability) (http://www.microsoft.com/)

    A MIT Kerberos együttműködési szolgáltatások használat a Windows 2000 operációs rendszerben.

  • Segédlet az Outlook 98 nyilvános kulccsal kapcsolatos szolgáltatásaihoz (Public Key Features in Outlook 98 Walk-through)(http://www.microsoft.com/)

    A Microsoft Outlook 98 üzenetkezelő és együttműködési szoftvereiben található nyilvános kulcsra épülő infrastruktúrához tartozó alapvető szolgáltatások magyarázata.

  • Segédlet az Outlook Express nyilvános kulccsal kapcsolatos szolgáltatásaihoz (Public Key Features in Outlook Express Walk-through) (http://www.microsoft.com/)

    A Microsoft Outlook Express 5.0-s verziójú üzenetkezelő és együttműködési szoftvereiben található nyilvános kulcsra épülő infrastruktúrához tartozó alapvető szolgáltatások magyarázata.

  • Segédlet a nyilvános kulcs alapú ügyfélhitelesítés használatához az Internet Explorer programban (Public Key-based Client Authentication in Internet Explorer Walk-through) (http://www.microsoft.com/)

    A Microsoft Internet Explorer 5 program nyilvános kulcsra épülő infrastruktúrájával kapcsolatos alapvető szolgáltatások magyarázata, különös tekintettel arra, hogyan használhatók a nyilvános kulcsú bizonyítványok ügyfélhitelesítésre biztonságos HTTP-kapcsolaton keresztül.

  • Segédlet adott tartomány hitelesítő szervezetekben való megbízhatóságának beállításához (Setting Up Certification Authority Trust for a Domain Walk-through) (http://www.microsoft.com/)

    Annak leírása, hogyan állítható be a Windows 2000 tartomány a Csoportházirend segítségével arra, hogy megbízzon külső hitelesítő szervezetekben.

  • Segédlet az intelligenskártya-bizonyítványok beiktatásához (Smart Card Certificate Enrollment Walk-through) (http://www.microsoft.com/)

    Az intelligenskártyák támogatási eljárásának részletes leírása, amely tartalmazza a nyilvános/személyes kulcsok létrehozását, a bizonyítványbeiktatást, valamint a kulcsok és bizonyítványok tárolását.

  • Segédlet az intelligenskártyás bejelentkezéshez (Smart Card Logon Walk-through) (http://www.microsoft.com/)

    A Windows 2000 operációs rendszer intelligenskártyás bejelentkezéssel kapcsolatos szolgáltatásainak beállítására és használatára vonatkozó részletes leírás.

  • Segédlet az intelligenskártya-olvasók telepítéséhez (Smart Card Reader Installation Walk-through) (http://www.microsoft.com/)

    A Plug and Play intelligenskártya-olvasók Windows 2000 rendszerben történő telepítésének leírása.

  • Biztonsági konfigurációs eszközök használata (Using the Security Configuration Tool Set) (http://www.microsoft.com/)

    A helyi biztonsági házirend és a biztonsági beállítások megtekintésének, konfigurálásának és elemzésének módja.


A Windows 2000 Server újdonságai

A Windows 2000 Server rendszer fejlettebb hálózati, alkalmazás- és webes szolgáltatásokat biztosít. Hatékony, rugalmas kezelőszolgáltatásai nagyobb megbízhatóságot és skálázhatóságot nyújtanak, csökkentik a számítástechnikával kapcsolatos költségeket, és jó alapot biztosítanak az üzleti alkalmazások futtatásához.

Ha tudni szeretné, hogyan hajthatja végre a korábban a Windows NT Server 4.0 rendszerrel végzett feladatokat, olvassa el a Megszokott feladatok végrehajtásának új módjai című témakört. A Windows 2000 Server új szolgáltatásairól a következő táblázatban, illetve A szolgáltatások betűrendes listája című témakörben olvashat.

Funkció A szolgáltatás leírása
vagy a támogatás típusa 		A használatmódja
Fájlkiszolgáló
  • Active Directory
  • Lemez- és fájlkezelő szolgáltatások
  • Active Directory – áttekintés
  • Fájlok és nyomtatók
  • Adattárolás
Nyomtatókiszolgáló
  • Active Directory
  • Nyomtatók és protokollok támogatása
  • Active Directory – áttekintés
  • Nyomtatás
Internet-kiszolgáló
  • Internet Information Services szolgáltatásai
  • Alkalmazás támogatása

    • Kapcsolódó területek:
    Alkalmazáskiszolgáló
    Hálózat/kommunikáció
    Kiszolgáló biztonsága
  • Internet Information Services
  • Alkalmazások és programozási eszközök
Multimédia-
kiszolgáló
  • Multimédia-támogatás

    • Kapcsolódó terület:
    Internet-kiszolgáló
  • A Windows Media szolgáltatások használata
Alkalmazás-
kiszolgáló
  • A meglévő rendszerek támogatása
  • A Terminálszolgáltatások lehetőségei
  • Alkalmazás támogatása
  • Alkalmazások kezelése és alkalmazása
  • Teljesítménybeállítási és hangolási szolgáltatások

    • Kapcsolódó terület:
    Fejlesztési támogatás
  • Hálózati együttműködés
  • Terminálszolgáltatások
  • Alkalmazások és programozási eszközök
  • Házirendeken alapuló felügyelet
  • IntelliMirror
  • Figyelő- és diagnosztikai eszközök
  • QoS belépésvezérlés
  • Windows ATM-szolgáltatások
Fejlesztés
támogatása
  • Fejlesztési támogatás
  • Alkalmazások és programozási eszközök
    Lásd még: Microsoft Platform SDK csomag
Hálózat/
kommunikáció
  • Hálózati protokollok és technológiák
  • A meglévő rendszerek támogatása
  • Teljesítménybeállítási és hangolási szolgáltatások
  • Hálózat
  • Kapcsolatok
  • Hálózati együttműködés
  • Figyelő- és diagnosztikai eszközök
  • QoS belépésvezérlés
  • Windows ATM-szolgáltatások
A kiszolgáló
megbízhatósága,
elérhetősége
és skálázhatósága
  • A kiszolgáló megbízhatósága
  • A kiszolgáló elérhetősége
  • A kiszolgáló méretezhetősége
  • Katasztrófa elleni védelem
  • Figyelő- és diagnosztikai eszközök
  • Plug and Play – áttekintés
Kiszolgáló
biztonsága
  • Hitelesítés és intelligens kártyák támogatása
  • További biztonsági szolgáltatások
  • Biztonság
  • Információvédelem (az Active Directoryban)
  • Hitelesítés
  • Internetes hitelesítési szolgáltatás
  • Internet-protokoll biztonság
Konfiguráció
és
kezelés
  • Active Directory
  • Az IntelliMirror szolgáltatásai
  • A Terminálszolgáltatások lehetőségei
  • Távoli kezelés

  • Lemez- és fájlkezelő szolgáltatások
  • Honosítási szolgáltatások

    • Kapcsolódó terület:
    Fájlkiszolgáló
  • Active Directory – áttekintés
  • IntelliMirror
  • Terminálszolgáltatások
  • A Microsoft Management Console használata
  • Kiszolgálók távoli kezelése (a Felügyeleti eszközök segítségével)
  • Felügyeleti feladatok automatizálása
  • Távtelepítési szolgáltatás


A szolgáltatások betűrendes listája

Az alábbi lista a Windows 2000 Server operációs rendszer új szolgáltatásainak részleges listája. A szolgáltatások részletes leírása és a listán nem található további szolgáltatásokkal kapcsolatos információ A Windows 2000 Server újdonságai című témakörben található.

A Windows Script Host

A Windows Script Host (WSH) használatával automatizálni lehet olyan műveleteket, mint a parancsikonok létrehozása, hálózati kiszolgálóhoz történő csatlakozás vagy a kapcsolat bontása. A WSH szempontjából lényegtelen, hogy milyen parancsleíró nyelvet használ. A parancsfájlokat megírhatja valamelyik ismert parancsleíró nyelven, mint amilyen a Visual Basic Scripting Edition vagy a JScript.

Active Directory

Az Active Directory egy vállalati szintű címtárszolgáltatás, amely tetszőlegesen bővíthető, az alapoktól Internet-szabványú technológiákra épül, és az operációs rendszer szintjén teljes mértékben integrált. Az Active Directory egyszerűbbé teszi a felügyeletet és megkönnyíti a felhasználók számára az erőforrások megtalálását. Az Active Directory a szolgáltatások és lehetőségek széles körét kínálja, ezek közül néhány például a csoportházirendek, az átlátható méretezhetőség, számos szerzői protokoll támogatása és az Internet-szabványok használata. Részletesebb leírás az Active Directory című témakörben található.

Active Directory Service Interfaces

Az Active Directory Service Interfaces címtárszolgáltatás-modell és COM-felületek gyűjteménye. Lehetővé teszi, hogy a Windows 95, a Windows 98, a Windows NT és a Windows 2000 rendszereken futó alkalmazások elérjenek különböző hálózati címtárszolgáltatásokat (például az Active Directoryt). Ezt a Software Development Kit (SDK) csomag tartalmazza.

Aszinkron átviteli mód

Az aszinkron átviteli mód (Asynchronous Transfer Mode – ATM) egy nagy sebességű kapcsolatokhoz tervezett protokoll, mely többféle forgalom hálózaton át történő átvitelére szolgál. Helyi és nagy kiterjedésű hálózatokon egyaránt használható. Az ATM használatával a hálózat egy időben a hálózati adatforgalom széles skáláját továbbíthatja: hangot, adatokat, képet vagy videót.

Az Internet-protokoll biztonságának támogatása

Az Internet-protokoll biztonsága (IPSec) az intraneten belül zajló kommunikáció biztosítására és az Interneten biztonságos virtuális magánhálózat létrehozására szolgál. Az IPSec biztonságot az Internet Engineering Task Force (IETF) tervezte, és a TCP/IP-forgalom titkosításának ipari szabványa.

Bizonyítványszolgáltatások

A Bizonyítványszolgáltatások és a Windows 2000 bizonyítványkezelő eszközei segítségével saját nyilvános kulcsú infrastruktúrát alkalmazhat. A nyilvános kulcsú infrastruktúra segítségével olyan szabvány alapú eljárásokat alkalmazhat, mint az intelligenskártyás bejelentkezési lehetőségek, az ügyfélhitelesítés (a Secure Sockets Layer vagy a Transport Layer Security protokollok segítségével), a biztonságos elektronikus levelezés, a digitális aláírások és a biztonságos kapcsolatok (az Internet-protokoll biztonsága segítségével). A Bizonyítványszolgáltatásokkal olyan hitelesítő szervezeteket állíthat be és kezelhet, melyek X.509 V3 bizonyítványokat bocsátanak ki és vonnak vissza. Ez azt jelenti, hogy hálózata így nem függ a kereskedelmi ügyfélhitelesítési szolgáltatásoktól, bár ezeket a szolgáltatásokat saját nyilvános kulcsú infrastruktúrájába is beépítheti.

Cserélhető tároló és távtároló szolgáltatás

A Cserélhető tároló megkönnyíti a cserélhető adathordozók (szalagok és optikai lemezek) nyilvántartását és az azokat tartalmazó hardverkönyvtárak (például váltók és lemeztárak) kezelését. A távtároló a megadott kritériumoknak megfelelően automatikusan cserélhető adathordozóra másolja a ritkán használt fájlokat. Ha a merevlemez-terület a megadott szint alá csökken, a távtároló eltávolítja a (gyorsítótárban lévő) fájltartalmat a lemezről. Ha a fájlra később szükség van, a tartalom automatikusan visszaíródik a tárolóból.

Mivel a cserélhető optikai lemezek és szalagok megabájtonkénti költsége alacsonyabb, mint a merevlemezeké, a Cserélhető tároló és a távtároló szolgáltatás használatával csökkentheti a költségeket.

Csoportházirend (az Active Directory része)

A házirendek segítségével megadhatja a felhasználók és a számítógépek számára megengedett műveleteket és beállításokat. A helyi házirenddel ellentétben, a Csoportházirend segítségével az Active Directoryban szereplő adott helyre, tartományra vagy szervezeti egységre érvényes házirendeket állíthat be. A házirenden alapuló kezelés egyszerűbbé teszi például az operációs rendszer frissítését, az alkalmazások telepítését, a felhasználói profilok kezelését és az asztali rendszerek zárolását.

Dinamikus DHCP DNS és Active Directory szolgáltatásokkal

A Dynamic Host Configuration protokoll (DHCP) együttműködik a DNS és az Active Directory szolgáltatásokkal az IP-hálózatokban ezzel feleslegessé téve a statikus IP-címek hozzárendelésének és nyomon követésének feladatait. A DHCP dinamikusan rendeli hozzá az IP-címeket az IP-hálózathoz csatlakozó számítógépekhez és más erőforrásokhoz.

Grafikus lemezkezelés

A Lemezkezelés egy grafikus eszköz a lemezes tárolás kezelésére. Számos új funkciót tartalmaz, például a következőket:

  • Új dinamikus kötetek támogatása, amelyekre nem érvényes a lemezenkénti négy partícióra vonatkozó korlátozás.
  • On-line lemezkezelés (kevesebb újraindítás szükséges).
  • Helyi és távoli lemezkezelés.
  • A Kötetcsatlakoztatási pontok segédprogram, amelynek segítségével csatlakoztathatja az adott helyi meghajtót egy NTFS fájlrendszerű kötet üres mappájához.

Hálózati címfordítás

A Hálózati címfordítás (Network Address Translation – NAT) elrejti a belső kezelésű IP-címeket a külső hálózatok elöl azáltal, hogy a magáncélú belső címeket lefordítja nyilvános külső címekre. Ez csökkenti az IP-címek regisztrációs költségeit azáltal, hogy lehetővé teszi regisztrálatlan IP-címek belső használatát kis számú regisztrált IP-cím külső használatával. Elrejti a belső hálózati struktúrát is, ezzel csökkentve a belső rendszert érő támadások kockázatát.

Indexelő szolgáltatás

Az Indexelő szolgáltatás használatával gyors, egyszerű és biztonságos módot biztosíthat a felhasználóknak az információk megtalálására mind helyileg, mind a hálózaton keresztül. A felhasználók hatékony lekérdezésekkel kereshetnek különböző formátumú és nyelvű fájlokban, a Start menüből elérhető Keresés paranccsal vagy böngészőben megtekinthető HTML-lapokon.

Intelligenskártyás infrastruktúra

A Bizonyítványszolgáltatások és a Windows 2000 bizonyítványkezelő eszközei segítségével saját nyilvános kulcsú infrastruktúrát alkalmazhat. A nyilvános kulcsú infrastruktúra segítségével olyan szabvány alapú technológiákat alkalmazhat, mint az intelligenskártyás bejelentkezési lehetőségek, az ügyfélhitelesítés (a Secure Sockets Layer vagy a Transport Layer Security protokollok segítségével), a biztonságos elektronikus levelezés, a digitális aláírások és a biztonságos kapcsolatok (az Internet-protokoll biztonsága segítségével).

IntelliMirror

A költségek csökkentése érdekében a rendszergazdák a hordozható és az asztali rendszerek legmagasabb szintű szabályzását igénylik. Az IntelliMirror biztosítja ezt a szabályzást a Windows 2000 Professional rendszert futtató ügyfélrendszereken. Az IntelliMirror segítségével az egyes felhasználók üzleti szerepe, csoporttagsága és helye alapján lehet házirendeket meghatározni. Az ilyen házirendek használatával a Windows 2000 Professional rendszert futtató asztali számítógépek újrakonfigurálása a felhasználók igénye szerint minden bejelentkezéskor automatikusan megtörténik, függetlenül a bejelentkezés helyétől. A IntelliMirror szolgáltatásaival kapcsolatos további információ Az IntelliMirror szolgáltatásai című témakörben található.

Internet Information Services 5.0

A Microsoft Windows 2000 Server részét képező Internet Information Services (IIS) hatékony funkciói megkönnyítik a dokumentumok és az információ megosztását egy vállalati intraneten vagy az Interneten. Az IIS használatával telepíthet méretezhető és megbízható Web alapú alkalmazásokat, és közzétehet meglévő adatokat és alkalmazásokat a Weben. Az IIS az Active Server Pages szolgáltatáson kívül számos más szolgáltatást tartalmaz. További információ az Internet Information Services szolgáltatások című témakörben található.

Internetes hitelesítési szolgáltatás

Az Internetes hitelesítési szolgáltatás (IAS) a telefonos vagy virtuális magánhálózati felhasználók hitelesítésének, engedélyezésének, számlázásának és naplózásának központi eszköze. Az IAS a Remote Authentication Dial-In User Service (RADIUS) néven ismert Internet Engineering Task Force (IETF) protokollt használja.

Internet-kapcsolat megosztása

A Hálózati és telefonos kapcsolatok szolgáltatás Internet-kapcsolat megosztása funkciójának segítségével a Windows 2000 az otthoni hálózat vagy a kis irodai hálózat Internet csatlakozása hozható létre. Lehet például olyan otthoni hálózata, amely telefonos kapcsolat segítségével csatlakozik az Internethez. Ha a telefonos kapcsolattal rendelkező számítógépen engedélyezi az Internet-kapcsolat megosztását, hálózati címfordítási, címzési és névhozzárendelési szolgáltatásokat tehet elérhetővé az otthoni hálózat összes számítógépe számára. További információ az Internet-kapcsolat megosztása című témakörben található.

Kerberos V5 protokoll támogatása

A Kerberos V5 egy korszerű, ipari szabványoknak megfelelő hálózati hitelesítési protokoll. A Kerberos V5 támogatása gyors, egylépcsős bejelentkezési folyamat segítségével biztosítja a felhasználók számára a Windows 2000 Server alapú vállalati erőforrásokhoz és a protokollt támogató egyéb környezetekhez való szükséges hozzáférést. A Kerberos V5 hitelesítés támogatása olyan további előnyökkel jár, mint amilyen a kölcsönös hitelesítés (az ügyfél és a kiszolgáló egyaránt hitelesítést nyújt) és a delegált hitelesítés (a rendszer a felhasználó hitelesítési adatait követi nyomon két végpont között).

Komponensszolgáltatások

A Komponensszolgáltatások a komponensobjektum-modell (COM) és a Microsoft Transaction Server (a komponens alapú tranzakciófeldolgozó rendszerek egyik korábbi verziója) bővítésein alapulnak. A Komponensszolgáltatások a korábbinál jobb szálkezelési, biztonsági, tranzakciókezelési, objektumkészletezési, komponensvárakoztatási valamint alkalmazásfelügyeleti és -csomagolási szolgáltatásokkal rendelkeznek.

Layer 2 Tunneling protokoll támogatása

Layer 2 Tunneling protokoll (L2TP), a Point-to-Point Tunneling protokoll (PPTP) biztonságosabb változata, mely bújtatásra, címhozzárendelésre és hitelesítésre szolgál.

Lemezkvóta-támogatás

Az NTFS fájlrendszerre formázott köteteken lemezkvótákat használhat, így figyelheti és korlátozhatja az egyes felhasználók által elérhető lemezterület nagyságát. Megadhatja, hogy a rendszer milyen választ adjon, ha a felhasználók túllépik a megadott határértékeket.

Lightweight Directory Access protokoll támogatása

A Lightweight Directory Access protokoll (LDAP) ipari szabvány, az Active Directory elsődleges hozzáférési protokollja. Az LDAP 3-as verzióját az Internet Engineering Task Force (IETF) definiálta.

Message Queuing

A Windows 2000 integrált üzenetsor-kezelési funkciói segítséget nyújtanak a fejlesztőknek a hálózatokon (például az Interneten) futó megbízhatóbb alkalmazások létrehozásához és alkalmazásához. Ezek az alkalmazások együttműködhetnek a különböző platformokon, például mainframe vagy UNIX alapú rendszereken futó alkalmazásokkal.

Microsoft Management Console

A Microsoft Management Console (MMC) használatával egyetlen felületre rendezheti a szükséges felügyeleti eszközöket és folyamatokat. Adott felhasználókhoz feladatokat is delegálhat úgy, hogy előre konfigurált MMC-konzolokat hoz létre számukra. A konzol biztosítja a felhasználó számára a kiválasztott eszközöket.

Nyilvános kulcsokra épülő infrastruktúra és intelligenskártyás infrastruktúra

A Bizonyítványszolgáltatások és a Windows 2000 bizonyítványkezelő eszközei segítségével saját nyilvános kulcsokra épülő infrastruktúrát alkalmazhat. A nyilvános kulcsokra épülő infrastruktúra segítségével olyan szabvány alapú technológiákat alkalmazhat, mint az intelligenskártyás bejelentkezési lehetőségek, az ügyfélhitelesítés (a Secure Sockets Layer vagy a Transport Layer Security protokollok segítségével), a biztonságos elektronikus levelezés, a digitális aláírások és a biztonságos kapcsolatok (az IPSec segítségével). A Bizonyítványszolgáltatásokkal olyan hitelesítő szervezeteket állíthat be és kezelhet, melyek X.509 V3 bizonyítványokat bocsátanak ki és vonnak vissza. Ez azt jelenti, hogy hálózata így nem függ a kereskedelmi ügyfélhitelesítési szolgáltatásoktól, bár ezeket a szolgáltatásokat saját nyilvános kulcsú infrastruktúrájába is beépítheti.

Operációs rendszerek áttelepítése, támogatása és integrációja

A Windows 2000 operációs rendszer zökkenőmentesen integrálja a meglévő rendszereket, valamint támogatja a korábbi Windows verziókat, és új szolgáltatásaival a többi népszerű operációs rendszert is. A Windows 2000 a következőket biztosítja:

  • A kölcsönös kezelhetőséget a Windows NT Server 3.51-es és 4.0-s verziókkal.
  • Windows 3.x, Windows 95, Windows 98 vagy Windows NT Workstation 4.0-s operációs rendszereket alkalmazó ügyfelek támogatását.
  • Mainframe és középtávú kapcsolatokat S/390 és AS/400 tranzakció- és várólista-kezelő átjárók alkalmazásával SNA Server kiszolgálón keresztül.
  • Macintosh rendszerhez fájlkiszolgálót, lehetővé téve a Macintosh ügyfelek számára a TCP/IP protokoll (AFP az IP-n keresztüli) használatát fájlok megosztására és a Windows 2000 kiszolgálón lévő megosztásokhoz való hozzáférésre.

Plug and Play

A kombinált hardver- és szoftvertámogatást jelentő Plug and Play technológia segítségével a kiszolgáló automatikusan felismeri a hardverkonfiguráció változásait és alkalmazkodik azokhoz, beavatkozás és újraindítás nélkül.

Rendszerindítás csökkentett módban

Csökkentett módban a Windows 2000 rendszert a lehető legkevesebb illesztőprogrammal és szolgáltatással indíthatja, majd megtekintheti az indításkor futó események naplóját. Az ilyen típusú rendszerindítással diagnosztizálhatja az illesztőprogramok és egyéb összetevők hibáit, amelyek megakadályozhatják a normál indítást.

Szolgáltatás minősége

A Windows Szolgáltatás minősége (QoS) használatával szabályozhatja a sávszélesség kiosztásának módját az alkalmazások számára. A fontos alkalmazások nagyobb sávszélességet, a kevésbé fontos alkalmazások kisebb sávszélességet kaphatnak. A QoS alapú szolgáltatások és protokollok az információk garantált, végpontok közötti, expressz kézbesítését biztosítja a hálózaton.

TAPI 3.0

A TAPI 3.0 egyesíti az IP alapú és a hagyományos telefont, lehetővé téve a fejlesztők számára, hogy a hatékony számítógépes telefonos alkalmazások új generációját hozzák létre, amelyek ugyanolyan hatékonysággal működnek az Interneten vagy egy intraneten keresztül, mint a hagyományos telefonvonalon.

Távtelepítési szolgáltatás

A Távtelepítési szolgáltatással a Windows 2000 Professional rendszert távolról telepítheti anélkül, hogy minden ügyfélhez oda kellene mennie. A célügyfélnek vagy támogatnia kell a Pre-Boot eXecution Environment (PXE) ROM memóriával történő távoli rendszerindítást, vagy távoli rendszerindító lemezről kell elindítani az ügyfelet. Így egyszerűbbé válik több ügyfél telepítése.

Terminálszolgáltatások

A Windows 2000 Server család az egyetlen olyan kiszolgálói operációs rendszer, mely integrálja a terminálemulációs szolgáltatásokat. A Terminálszolgáltatások segítségével a felhasználó különféle régebbi eszközök használatával is hozzáférhet a kiszolgálón futó programokhoz. A felhasználó például hozzáférhet egy virtuális Windows 2000 Professional asztalhoz és 32-bites alkalmazásokhoz olyan hardverről is, amely nem tudja e szoftvereket helyileg futtatni. A Terminálszolgáltatások biztosítják ezt a lehetőséget Windows alapú és nem Windows alapú ügyféleszközökhöz is. (A nem Windows alapú eszközökhöz a Citrix Systems által készített bővítőszoftverre van szükség.) További információ a Terminálszolgáltatásokról a Terminálszolgáltatások lehetőségei című témakörben található.

Titkosított fájlrendszer

A Titkosított fájlrendszer (EFS) a Windows 2000 operációs rendszerben kiegészíti a meglévő hozzáférés-felügyeletet, és az adatvédelem új szintjét valósítja meg. A Titkosított fájlrendszer integrált rendszerszolgáltatásként fut, leegyszerűsíti a rendszer kezelését, megnehezíti megtámadását és a felhasználó számára átláthatóvá teszi.

Útválasztás és távelérés szolgáltatás

Az Útválasztás és távelérés szolgáltatás egyetlen integrált szolgáltatás, amely megszakítja a betárcsázásos vagy a virtuális magánhálózati ügyfelek által létrehozott kapcsolatokat, vagy biztosítja az (IP, IPX vagy AppleTalk) útválasztást, illetve mindkét feladatot ellátja. Az útválasztás és távelérés szolgáltatás lehetővé teszi, hogy a Windows 2000 kiszolgáló távelérési kiszolgálóként, VPN-kiszolgálóként, átjáróként vagy egy fiókiroda útválasztójaként működjön.

Virtuális magánhálózat

Virtuális magánhálózat (VPN) megvalósításával a felhasználóknak azonnali hozzáférés biztosítható a hálózathoz, akkor is, ha az irodán kívül tartózkodnak; ezáltal a hozzáférés költsége csökkenthető. A VPN hálózatok használatával a felhasználók egyszerűen és biztonságosan csatlakozhatnak a vállalati hálózathoz. A csatlakozás helyi Internet-szolgáltatón keresztül történik, ami csökkenti a kapcsolódási idő költségét.

A virtuális magánhálózatok létrehozására a Windows 2000 Server rendszerben több új, biztonságosabb protokollt használhat, melyek többek között a következők:

  • Layer 2 Tunneling protokoll (L2TP), a Point-to-Point Tunneling protokoll (PPTP) biztonságosabb változata. Az L2TP bújtatásra, címhozzárendelésre és hitelesítésre szolgál.
  • Az Internet-protokoll biztonsága (IPSec) egy szabványokon alapuló protokoll, amely a legmagasabb szintű biztonságot biztosítja a VPN számára. Az IPSec használatával a hálózati réteg felett gyakorlatilag minden titkosítható.

Windows Media szolgáltatások

A Windows Media szolgáltatások használatával kiváló minőségben biztosíthatja a médiatartalom folyamatos átvitelét az Internet és az intranetek felhasználóinak.


Új teljesítménynövelő, biztonságnövelő és a kezelést megkönnyítő szolgáltatások

  • A kiszolgáló megbízhatósága
  • Egyenletes kiszolgálóműködés
  • A kiszolgáló méretezhetősége
  • Teljesítménybeállítási és hangolási szolgáltatások
  • Hitelesítés és intelligens kártyák támogatása
  • További biztonsági szolgáltatások
  • Az IntelliMirror szolgáltatásai
  • Távoli kezelés
  • Honosítási szolgáltatások


A kiszolgáló megbízhatósága

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található. A kiszolgáló működésének egyenletességét biztosító szolgáltatásokat – melyek szorosan kapcsolódnak a kiszolgáló megbízhatóságához – az A kiszolgáló elérhetősége című témakör ismerteti.

A Windows 2000 Server legalapvetőbb felépítési szempontja a nagyobb megbízhatóság. A rendszer az alábbi tulajdonságainak köszönhetően biztosít nagyobb megbízhatóságot:

Jobb memóriakezelés
A jobb memóriakezelés gyorsabb, megbízhatóbb és rugalmasabb kiszolgálókat eredményez.
Szilárdabb rendszerfelépítés
A szilárdabb rendszer nagyobb megbízhatóságot eredményez akkor is, ha egy alkalmazás vagy szolgáltatás nem megfelelően működik.
Jobb diagnosztikai eszközök
A jobb diagnosztikai eszközök megkönnyítik a rendszer állapotának figyelését és a hibák megelőzését.
Indítás csökkentett módban
A csökkentett mód használatával a Windows 2000 rendszert a lehető legkevesebb illesztőprogrammal és szolgáltatással indíthatja, majd megtekintheti az indításkor futó események naplóját. A csökkentett mód használatával felderítheti az illesztőprogramok és egyéb összetevők problémáit, amelyek megakadályozhatják a normál indítást.
Helyreállítási konzol
A Helyreállítási konzol segítségével egy parancssori konzolt indíthat el a rendszeren, ha valamilyen szoftverhiba (például illesztőprogram vagy fájl hibája) megakadályozza a rendszerindítást. A Helyreállítási konzolban alaputasítások használatával megkísérelheti a rendszer helyreállítását.
Windows fájlvédelem
A Windows 2000 rendszerben a Windows fájlvédelem megakadályozza a védett rendszerfájlok, például az operációs rendszer által használt .sys, .dll, .ocx, .ttf, .fon és .exe fájlok felülírását. A Windows fájlvédelem a háttérben fut és megakadályozza, hogy más programok módosítsák az operációs rendszer számára szükséges fájlokat.
Bővített biztonságimásolat-készítő segédprogram
A Windows 2000 Server rendszerrel többféle adathordozóra készíthet az adatokról biztonsági másolatot, például szalagos meghajtókra, külső merevlemez-meghajtókra, Zip lemezekre és írható CD-kre.
Lemeztöredezettség-mentesítő
Megszüntetheti a FAT, a FAT32 és az NTFS formátumú lemezkötetek töredezettségét, növelve ezzel a kiszolgáló megbízhatóságát és teljesítményét.


A kiszolgáló elérhetősége

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található. A kiszolgáló működésének megbízhatóságát biztosító szolgáltatásokat – melyek szorosan kapcsolódnak a kiszolgáló elérhetőségéhez – A kiszolgáló megbízhatósága című témakör ismerteti.

A Windows 2000 Server olyan új szolgáltatásokat tartalmaz, amelyek jelentősen megnövelik a rendszer működési idejét, hogy az megfeleljen a nagy fontosságú üzleti igényeknek. A Plug and Play használata több mint 90 százalékkal csökkenti a rendszer tervezett újraindításainak számát. A rendszer speciális hibatűrést és fájlrendszer-helyreállító szolgáltatásokat biztosít.

Kevesebb kiszolgáló-újraindítás
A Windows 2000 Server megkönnyíti a hardver és a szoftver konfigurálását, és jelentősen csökkenti a szükséges rendszer-újraindítások számát. A kiszolgáló újraindítása nélkül végrehajtható műveletek például a következők:
  • Tárolókötet kibővítése
  • Hálózati protokollok konfigurálása
  • A tárolás dinamikus kezelése (Dinamikus kötetkezelés)
  • A PCI vagy más Plug and Play hardverek beállításainak újrakonfigurálása
Plug and Play
A Plug and Play használatával, amely kombinált hardver- és szoftvertámogatást jelent, a kiszolgáló automatikusan felismeri a hardverkonfiguráció változásait és beavatkozás és újraindítás nélkül alkalmazkodik azokhoz.
Indítás tükrözött vagy csíkozott kötetekről
Megfelelő előkészítéssel el lehet indítani a kiszolgálót tükrözött vagy csíkozott köteten lévő biztonsági másolatról, egyenletesebb rendszer-elérhetőséget biztosítva a kiszolgáló helyreállítása és a rendszeres karbantartás során.


A kiszolgáló méretezhetősége

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat a A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 kiszolgálócsalád méretezhetősége következtében kis munkacsoportok és vállalati adatközpontok megvalósítására is alkalmas. A Windows 2000 kiszolgálócsalád tartalmaz olyan termékeket, amelyek támogatják 32 processzor és speciális I/O használatát. Ezen kívül egyesíti a hálózati terhelés egyensúlyozását és az új multiprocesszor-optimalizálásokat az üzleti alkalmazások számára.

Méretezhető hardver
Ha a Windows 2000 kiszolgálócsalád termékei közül választ, kihasználhatja az egyre több versenyképes árú, egyre gyorsabb hardvertechnológiát használó 2, 4, 16, és 32 processzort tartalmazó multiprocesszoros számítógép előnyeit.
I2O-támogatás
Az új I2O (Intelligent Input/Output) architektúra nagyobb bemeneti és kimeneti teljesítményt tesz lehetővé a kiszolgálón, mert bizonyos I/O műveletekhez egy másodlagos tehermentesítő processzort használ. Az I2O javítja a be- és kimeneti teljesítményt a nagy sávszélességet használó alkalmazásoknál, például a hálózati videoalkalmazásoknál, a csoportmunka-szoftvereknél és az ügyfél-kiszolgáló folyamatoknál.
Hálózati terheléselosztás (a Windows 2000 Advanced Server szolgáltatása)
A korábban WLBS néven ismert Hálózati terheléselosztás elosztja a bejövő TCP/IP-forgalmat több kiszolgáló között. A fürtözött alkalmazások, különösen a webkiszolgáló alkalmazások így nagyobb forgalmat képesek kezelni és rövidebb a válaszidejük.


Teljesítménybeállítási és hangolási szolgáltatások

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat a A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server új szolgáltatásai, melyek jobb teljesítményt biztosítanak és lehetőséget adnak arra, hogy a kiszolgálót a szükségleteinek és a környezetnek megfelelően hangolja.

I2O-támogatás
Az új I2O (Intelligent Input/Output) architektúra nagyobb bemeneti és kimeneti teljesítményt tesz lehetővé a kiszolgálón, mert bizonyos I/O műveletekhez egy másodlagos tehermentesítő processzort használ. Az I2O javítja a be- és kimeneti teljesítményt a nagy sávszélességet használó alkalmazásoknál, például a hálózati videoalkalmazásoknál, a csoportmunka-szoftvereknél és az ügyfél-kiszolgáló folyamatoknál.
A processzorhasználat korlátozása webalkalmazásokhoz, vagy webhelyekhez.
A Windows 2000 Server feladatobjektumainak használatával korlátozni lehet, hogy egy webalkalmazás vagy egy webhely mennyit használ a CPU feldolgozási idejéből. Ez processzoridőt szabadít fel a többi alkalmazás számára.
Folyamatszámlázás webalkalmazásokhoz vagy webhelyekhez.
A Folyamatszámlázás használatával információhoz juthat a webhelyek CPU-erőforráshasználatáról. Ez az információ döntő lehet a hardver és az alkalmazások cseréjével vagy fejlesztésével kapcsolatos döntések meghozatalakor. Fontos szerepe lehet a parancsfájlok és az alkalmazások figyelésekor és a problémáik diagnosztizálásakor is.
HTTP-tömörítés
HTTP-tömörítés használatával sávszélességet lehet megtakarítani és az oldalak gyorsabb átvitelét lehet elérni a webkiszolgáló és a HTTP-tömörítést kezelni képes ügyfelek között. Az Internet Explorer 4 és az Internet Explorer 5 támogatja a Windows 2000 Server által használt tömörítési módszereket.
Előre látható végpontok közötti szolgáltatásminőség
A Windows Szolgáltatás minősége (QoS) lehetővé teszi a sávszélesség az alkalmazások számára való kiosztásának vezérlését. A fontos alkalmazások nagyobb sávszélességet, a kevésbé fontos alkalmazások kisebb sávszélességet kaphatnak. A QoS alapú szolgáltatások és protokollok garantált, végpontok közötti, expressz kézbesítési rendszert biztosítanak az információknak a hálózaton.
Resource Reservation protokoll
A Resource Reservation protokoll (RSVP) a multimédiás és más olyan alkalmazásokhoz használható, amelyek állandó sávszélességet vagy válaszszinteket igényelnek a hálózaton. Az RSVP használatával ezek az alkalmazások megkaphatják a megfelelő szolgáltatási minőséget a hálózatról és segítségével kezelhető az alkalmazások hálózati erőforrásokra gyakorolt hatása. Az RSVP egy kérés-engedélyezés típusú szolgáltatás, ahol az ügyfelek foglalási kéréseit a rendszer vagy elfogadja, vagy megtagadja, a házirendek és a rendelkezésre álló hálózati erőforrások alapján.
Hálózati terheléselosztás (a Windows 2000 Advanced Server szolgáltatása)
A korábban WLBS néven ismert Hálózati terheléselosztás elosztja a bejövő TCP/IP-forgalmat több kiszolgáló között. A fürtözött alkalmazások, különösen a webkiszolgáló alkalmazások így nagyobb forgalmat képesek kezelni és rövidebb a válaszidejük.


Hitelesítés és intelligens kártyák támogatása

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server operációs rendszer a hitelesítési technológiák (többek között az intelligens kártyák használatát támogató technológiák) széles skáláját nyújtja.

A Kerberos V5 protokoll teljes támogatása
A Kerberos V5 támogatása gyors, egylépcsős bejelentkezési folyamat segítségével biztosítja a felhasználók számára a Windows 2000 Server alapú vállalati erőforrásokhoz és a protokollt támogató egyéb környezetekhez való hozzáférést. A Kerberos V5 hitelesítés támogatása további előnyökkel jár, mint például a kölcsönös hitelesítés (az ügyfél és a kiszolgáló egyaránt hitelesítést nyújt) és a delegált hitelesítés (a felhasználó hitelesítési adatait követi nyomon a két végpont között).
Nyilvános kulcsokra épülő infrastruktúra, Bizonyítványszolgáltatások, valamint intelligens kártyák
A Bizonyítványszolgáltatások és a Windows 2000 bizonyítványkezelő eszközei segítségével saját nyilvános kulcsokra épülő infrastruktúrát hozhat létre. A nyilvános kulcsokra épülő infrastruktúra segítségével olyan szabványos technológiákat alkalmazhat, mint az intelligens kártyás bejelentkezési lehetőség, ügyfélhitelesítés (a Secure Sockets Layer vagy a Transport Layer Security protokoll segítségével), biztonságos elektronikus levelezés, digitális aláírások és biztonságos kapcsolatok (az IP-biztonság segítségével). A Bizonyítványszolgáltatások segítségével olyan hitelesítő szervezeteket állíthat be és kezelhet, melyek X.509 V3 bizonyítványokat bocsátanak ki és vonnak vissza. Ez azt jelenti, hogy hálózata a továbbiakban nem függ a kereskedelmi ügyfélhitelesítési szolgáltatásoktól, bár ezeket a szolgáltatásokat saját nyilvános kulcsokra épülő infrastruktúrájába is beépítheti.
Virtuális magánhálózat
Virtuális magánhálózat (VPN) megvalósításával a felhasználóknak azonnali hozzáférést biztosíthat a hálózathoz, akkor is, ha az irodán kívül tartózkodnak, valamint ezáltal csökkentheti a hozzáférés költségét. A VPN hálózatok lehetővé teszik a felhasználók számára, hogy egyszerűen és biztonságosan csatlakozzanak a vállalati hálózathoz. A csatlakozás valamelyik helyi Internet-szolgáltatón keresztül történik, ami csökkenti a kapcsolódási idő költségét.
A Windows 2000 Server rendszerben több új, biztonságosabb protokollt használhat a virtuális magánhálózatok létrehozására, például:
  • Layer 2 Tunneling protokoll (L2TP), a Point-to-Point Tunneling protokoll (PPTP) biztonságosabb változata. Bújtatásra, címhozzárendelésre és hitelesítésre alkalmazzák.
  • Az Internet-protokoll biztonság (IPSec) egy olyan szabvány alapú protokoll, amely biztosítja a virtuális magánhálózat legmagasabb szintű biztonságát . Az IPSec alkalmazásával a hálózati réteg felett gyakorlatilag minden titkosítható.
Útválasztás és távelérés szolgáltatás
Az Útválasztás és távelérés szolgáltatás egyetlen integrált szolgáltatás, amely vagy megszakítja a telefonos vagy VPN-ügyfelek által létrehozott kapcsolatokat, vagy biztosítja az (IP, IPX vagy AppleTalk) útválasztást, vagy mindkét feladatot ellátja. Az Útválasztás és távelérés szolgáltatás lehetővé teszi, hogy a Windows 2000 kiszolgáló távelérési kiszolgálóként, VPN-kiszolgálóként, átjáróként vagy egy fiókiroda útválasztójaként működjön.
Távelérés biztosításakor az Útválasztás és távelérés szolgáltatás támogatja a PPP protokollt (a szabványos telefonos protokollt). Az új Extensible Authentication protokollt is támogatja, amely lehetővé teszi a forgalmazók által biztosított hitelesítési módszerek (például a retinaellenőrzés) használatát a távoli ügyfelek számára.
Amikor útválasztóként működik, az Útválasztás és távelérés szolgáltatás a helyi (LAN hálózatok közötti) és a távoli (igény szerint tárcsázó) útválasztást is támogatja. A fizikai telefonos, kerettovábbító, ISDN- és X.25-kapcsolaton kívül a kapcsolat formája vállalati hálózathoz közvetlen kapcsolattal csatlakozó vagy az Interneten keresztül létrejövő pontról pontra küldéses, fiókirodai VPN-kapcsolat is lehet. Az Útválasztás és távelérés szolgáltatás támogatja az OSPF és RIP2 az IP számára útválasztást vezérlő protokollokat, valamint a RIP és SAP az IPX számára protokollokat. A Windows 2000 Server útválasztási és átjárószolgáltatásai lehetővé teszik a fiókirodák (vagy peremhálózatok) és a vállalati hálózat közötti rugalmas csatlakozások létrehozását.
Internetes hitelesítési szolgáltatás
Az Internetes hitelesítési szolgáltatás (IAS) központi helyet biztosít a telefonos vagy VPN-felhasználók hitelesítéséhez, engedélyezéséhez, számlázásához és naplózásához. Ez a szolgáltatás a Remote Authentication Dial-In User Service (RADIUS) néven ismert Internet Engineering Task Force (IETF) protokollt használja.


További biztonsági szolgáltatások

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat a A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 számos szolgáltatást nyújt (például a fájltitkosítást és az Active Directory beépített biztonsági funkcióit) erős, rugalmas biztonsági rendszer létrehozására. A Windows 2000 rendszerben rendelkezésre álló hitelesítési típusokról további tudnivalók a Hitelesítés és intelligens kártyák támogatása című témakörben találhatók.

Titkosított fájlrendszer
A Titkosított fájlrendszer (EFS) a Windows 2000 operációs rendszerben kiegészíti a létező hozzáférés-felügyeletet és az adatvédelem új szintjét valósítja meg. A Titkosított fájlrendszer integrált rendszerszolgáltatásként fut, a rendszer kezelését leegyszerűsítve, az ellene intézett támadás lehetőségeit csökkentve és a felhasználó számára észrevétlenül.
Rugalmas, biztonságos hitelesítés és engedélyezés
A rugalmas és biztonságos hitelesítési és engedélyezési szolgáltatások az Interneten végezhető feladatok minimális korlátozása mellett biztosítják az adatvédelmet. Az Active Directory támogatja több hitelesítési protokoll (például a Kerberos V5 protokoll, a Secure Sockets Layer v3 protokoll és az X.509v3 bizonyítványokat használó Transport Layer Security protokoll) és a tartományokat hatékonyan átfogó biztonsági csoportok használatát.
Internet-protokoll biztonság
Az Internet-protokoll biztonság (IPSec) az intraneten belül zajló kommunikáció biztosítására és az Interneten biztonságos virtuális magánhálózat létrehozására szolgál. Az IPSec biztonságot az Internet Engineering Task Force (IETF) tervezte és a TCP/IP forgalom titkosításának ipari szabványa.


Az IntelliMirror szolgáltatásai

Az IntelliMirror szolgáltatásait a Windows 2000 más szolgáltatásaival összehasonlító táblázat a A Windows 2000 Server újdonságai című témakörben található. Az IntelliMirror használatával kapcsolatos információ az IntelliMirror című témakörben található.

A költségek csökkentése érdekében a rendszergazdák igénylik a hordozható és az asztali rendszereken történő legmagasabb szintű szabályzást. Az IntelliMirror biztosítja ezt a Windows 2000 Professional rendszert futtató ügyfélrendszerekhez. Az IntelliMirror segítségével az egyes felhasználók üzleti szerepe, csoporttagsága és helye alapján lehet házirendeket megadni. Az ilyen házirendek használatakor a Windows 2000 Professional rendszert futtató asztali számítógépek újrakonfigurálása automatikusan megtörténik a felhasználó minden bejelentkezésekor, függetlenül a bejelentkezés helyétől.

Az IntelliMirror alapja három szolgáltatás:

  • A felhasználói adatok kezelése
  • Szoftverek telepítése és karbantartása
  • A felhasználói beállítások kezelése

Az IntelliMirror szolgáltatásai a környezet igényeinek megfelelően külön és együtt is használhatók. Ez lehetővé teszi a konzisztencia és a megbízhatóság biztosítását a felhasználók számára függetlenül attól, hogy milyen számítógépet használnak.


Távoli kezelés

A Windows 2000 Server újdonságai című témakörben egy táblázat található, amely az ezen témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival kapcsolja össze.

A Windows 2000 számos bővítést tartalmaz a távoli rendszerkezeléshez, többek között például a felügyelettámogatás, a terminálszolgáltatások és a Microsoft Management Console delegálását.

Távoli kezelés a terminálszolgáltatások használatával
A terminálszolgáltatások használatával a hálózat bármely helyéről távolról bejelentkezhet és kezelheti a Windows 2000 rendszert, ahelyett, hogy helyileg kellene a kiszolgálón dolgoznia. Ehhez 28,8 Kbps sebességű (vagy gyorsabb) hálózati kapcsolat szükséges. A terminálszolgáltatásokkal kapcsolatos további információ a Terminálszolgáltatások tulajdonságai című témakörben található.
Feladatok szervezése és delegálása a Microsoft Management Console használatával
A Microsoft Management Console használatával egyetlen felületen elrendezheti a szükséges felügyeleti eszközöket és folyamatokat. Delegálhat is feladatokat adott felhasználókhoz úgy, hogy előre beállított MMC-konzolokat hoz létre számukra. A konzol biztosítja a felhasználó számára a kijelölt eszközöket.
Távoli kezelés a felügyeleti eszközök használatával
A Windows 2000 Felügyeleti eszközök használatával bármely Windows 2000 rendszert futtató számítógépről (Windows 2000 Professional rendszert futtató számítógépekről is) kezelhet távolról egy kiszolgálót. A felügyeleti eszközök a Windows 2000 Server CD-ROM-on találhatók. A CD Microsoft Management Console beépülő modulokat és a Windows 2000 Professional rendszerhez nem biztosított egyéb felügyeleti eszközöket tartalmaz.
Parancsfájlok futtatása a Windows Script Host programmal
A Windows Script Host (WSH) használatával automatizálni lehet olyan műveleteket, mint a parancsikon létrehozása, a hálózati kiszolgálóhoz történő csatlakozás vagy a kapcsolat bontása. A WSH nyelvtől független. A parancsfájlokat valamely ismert parancsnyelven írhatja meg, mint a Visual Basic Scripting Edition vagy a JScript.
Távtelepítési szolgáltatás
A távtelepítési szolgáltatás segítségével a távolról elindítható ügyfélszámítógépekre távolról telepítheti a Windows 2000 Professional operációs rendszert. Így több ügyfél esetén egyszerűbbé válik a telepítés.


Honosítási szolgáltatások

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server operációs rendszer már egyetlen rendszerben is képes több nyelvet támogatni, és helyi változata a későbbiekben harmincnál több nyelven készül el.

A Windows 2000 rendszerarchitektúrájának köszönhetően az operációs rendszer, a segédprogramok és a megfelelő alkalmazások több száz nyelvre lefordíthatók, a helyi verziók így elkészíthetők. A helyi rendszergazdák számára a továbbiakban nem szükséges az angol szakkifejezések átfogó ismerete.


A fájl- és nyomtatókiszolgálók új szolgáltatásai

A fájlrendszerek, nyomtatási szolgáltatások és a kötetkezelés kibővítése ideális fájl- és nyomtatókiszolgálóvá teszi a Windows 2000 rendszert, és megkönnyíti a felhasználóknak az információk és szolgáltatások keresését.

  • Active Directory
  • Lemez- és fájlkezelési szolgáltatások
  • Nyomtatók és protokollok támogatása


Active Directory

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található. Az Active Directory használatáról bővebben az Active Directory című témakörben olvashat.

Az Active Directory egy vállalati szintű címtárszolgáltatás, amely tetszőlegesen bővíthető, az alapoktól Internet-szabványú technológiákra épül, és az operációs rendszer szintjén teljes mértékben integrált. Az Active Directory egyszerűbbé teszi a felügyeletet és megkönnyíti a felhasználók számára az erőforrások megtalálását. Az Active Directory szolgáltatások és lehetőségek széles körét biztosítja:

A felhasználók és hálózati erőforrások egyszerűbb kezelése
Az Active Directory segítségével hierarchikus információszerkezeteket építhet fel, amelyek megkönnyítik a felügyeleti jogok és más biztonsági beállítások szabályzását, és a felhasználók számára megkönnyítik a hálózati erőforrások, például a fájlok és a nyomtatók keresését.
Csoportházirend
A házirendek segítségével megadhatja a felhasználók és a számítógépek számára megengedett műveleteket és beállításokat. A helyi házirenddel ellentétben, a Csoportházirend segítségével az Active Directoryban szereplő adott helyre, tartományra vagy szervezeti egységre érvényes házirendeket állíthat be. A házirenden alapuló kezelés egyszerűbbé teszi például az operációs rendszer frissítését, az alkalmazások telepítését, a felhasználói profilokat és az asztali rendszerek zárolását.
Rugalmas, biztonságos hitelesítés és engedélyezés
A rugalmas és biztonságos hitelesítési és engedélyezési szolgáltatások az Interneten végezhető feladatok minimális korlátozása mellett biztosítják az adatvédelmet. Az Active Directory támogatja több hitelesítési protokoll (például a Kerberos V5, a Secure Sockets Layer 3 és az X.509v3 bizonyítványokat használó Transport Layer Security protokoll) és a tartományokat hatékonyan átfogó biztonsági csoportok használatát.
Egységes címtár
Szervezetté és egyszerűbbé teheti a felhasználók, számítógépek, alkalmazások és eszközök kezelését, valamint megkönnyítheti a felhasználók számára a szükséges információk megtalálását. LDAP alapú felületek segítségével kihasználhatja a szinkronizálás támogatását, és kezelheti az alkalmazások egységes címtárra vonatkozó igényeit.
Címtárszolgáltatásokkal együttműködő alkalmazások és infrastruktúra
Az Active Directory szolgáltatásai megkönnyítik az alkalmazások és a címtárszolgáltatásokkal együttműködő egyéb hálózati összetevők konfigurálását és kezelését.
Átlátható méretezhetőség
Az Active Directory tartományonként több millió objektumot képes kezelni, és indexelési eljárást, illetve speciális replikációs eljárásokat alkalmaz a teljesítmény növelésére.
Internet-szabványok használata
Az Active Directory LDAP protokollon keresztül biztosítja a hozzáférést, és Tartománynévrendszer (DNS) alapú névteret használ.
Hatékony fejlesztői környezet
Az Active Directory hatékony fejlesztőeszközt kínál az Active Directory Service Interfaces szolgáltatáson keresztül. Az Active Directoryval együttműködő alkalmazások számos forgalmazó, például a SAP, a Baan, a J.D. Edwards, a Cisco stb. tetszését elnyerték.


Lemez- és fájlkezelési szolgáltatások

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található.

A lemez-, kötet és fájlkezelés kibővítése hatékony, rugalmas fájlkiszolgálóvá teszi a Windows 2000 Server rendszert, és megkönnyíti a felhasználók számára a Windows 2000 Server rendszerben lévő információk megtalálását és az azokhoz való hozzáférést.

Lemezkvóta-támogatás
Az NTFS fájlrendszerűre formázott köteteken lemezkvótákat használhat, így figyelheti és korlátozhatja az egyes felhasználók által elérhető lemezterület nagyságát. Megadhatja a megadott küszöböknek a felhasználók által történő átlépésekor küldendő válaszokat.
Elosztott fájlrendszer
Az Elosztott fájlrendszer (Dfs) használatával létrehozhat egy könyvtárfát, amely egy csoportban, részlegben vagy vállalatnál található több fájlkiszolgálót és fájlmegosztást tartalmaz. Ez lehetővé teszi, hogy a felhasználók könnyen megtalálják a hálózaton elosztott fájlokat és mappákat. A Dfs megosztásokat közzé lehet tenni Kötetobjektumokként az Active Directoryban.
Elosztott hivatkozáskövetés
Az Elosztott hivatkozáskövetés és az NTFS használatával lehetővé teheti az ügyfélalkalmazások számára olyan hivatkozott források követését, amelyek helye megváltozott. Egy ügyfélalkalmazás például bármikor hozzá tud férni egy hivatkozott adatbázishoz, akkor is, ha az adatbázis helye megváltozik.
Distributed Authoring and Versioning
A Distributed Authoring and Versioning lehetővé teszi, hogy távoli felhasználók a kiszolgálón található fájlokat, fájltulajdonságokat, könyvtárakat és könyvtártulajdonságokat HTTP-csatlakozáson keresztül szerkesszék, áthelyezzék vagy töröljék.
Nagyteljesítményű tartalomindexelés
Az Indexelő szolgáltatás használatával gyors, egyszerű és biztonságos módot biztosíthat a felhasználóknak a helyileg vagy a hálózaton történő információkeresésre. A felhasználók hatékony lekérdezésekkel kereshetnek különböző formátumú és nyelvű fájlokban, a Start menüből elérhető Keresés paranccsal vagy böngészőben megtekinthető HTML-lapokról.
Titkosított fájlrendszer
A Titkosított fájlrendszer (EFS) a Windows 2000 operációs rendszerben kiegészíti a meglévő hozzáférés-felügyeletet, és az adatvédelem új szintjét valósítja meg. A Titkosított fájlrendszer integrált rendszerszolgáltatásként fut, leegyszerűsíti a rendszer kezelését, csökkenti az az ellen intézett támadás lehetőségeit, miközben észrevétlen marad a felhasználó előtt.
A Cserélhető tároló és a távtároló szolgáltatás
A Cserélhető tároló megkönnyíti a cserélhető adathordozók (szalagok és optikai lemezek) nyomon követését és az azokat tartalmazó hardverkönyvtárak (például váltók és lemeztárak) kezelését. A távtároló a megadott kritériumoknak megfelelően, automatikusan cserélhető adathordozóra másolja a ritkán használt fájlokat. Ha a merevlemez-terület a megadott szintek alá csökken, a távtároló eltávolítja a (gyorsítótárban lévő) fájltartalmat a lemezről. Ha a fájlra később szükség van, a tartalom automatikusan visszaíródik a tárolóból.
Mivel a cserélhető optikai lemezek és szalagok MB-ra lebontott költsége alacsonyabb, mint a merevlemezeké, a Cserélhető tároló és a távtároló szolgáltatás használatával csökkentheti a költségeket.
Grafikus lemezkezelés
A Lemezkezelés egy grafikus eszköz a lemezes tárolás kezelésére. Több új szolgáltatást tartalmaz, például:
  • Azoknak az új dinamikus köteteknek a támogatása, amelyekre nem érvényes a lemezenkénti négy partíciós korlát.
  • On-line lemezkezelés (kevesebb újraindítás szükséges).
  • Helyi és távoli lemezkezelés.
  • A Kötetcsatlakoztatási pontok segédprogram, mely segítségével csatlakoztathatja az adott helyi meghajtót egy NTFS-formátumú kötet üres mappájához.


Nyomtatók és protokollok támogatása

A Windows 2000 Server újdonságai című témakörben egy táblázat található, amely az ezen témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival kapcsolja össze.

A Windows 2000 Server különféle nyomtatási szolgáltatásokat biztosít:

Az Active Directory-ban közzétett nyomtatók
A felhasználók gyorsan megkereshetik a legmegfelelőbb nyomtatási erőforrásokat a továbbfejlesztett felhasználói felület segítségével.
Széles eszköz- és protokolltámogatás
A Windows 2000 Server rendszerben több mint 2500 különböző nyomtató közül választhat.
Plug and Play
A Plug and Play használatával, amely kombinált hardver- és szoftvertámogatást jelent, a kiszolgáló automatikusan felismeri a hardverkonfiguráció változásait és alkalmazkodik azokhoz, beavatkozás és újraindítás nélkül.
Internet Printing protokoll
Az Internet Printing protokoll (IPP) használatával a felhasználók az intraneten vagy az Interneten keresztül közvetlenül nyomtathatnak egy adott URL-címre. A Windows 2000 Server ezenkívül automatikusan előállítja a nyomtatási feladatokkal kapcsolatos információkat HTML-formátumban, így a felhasználók azokat megtekinthetik a böngészőben.
Fejlettebb nyomtatókezelés
A Rendszerfigyelő segítségével nyomon követheti a helyi és a távoli nyomtatók működését. A számlálókat többféle kritérium alapján állíthatja be, például a másodpercenként nyomtatott bájtok, a feladatvégrehajtási hibák vagy az összes nyomtatott oldal szerint.
Fejlettebb hálózati nyomtatás
Az MMC-konzolok segítségével a hálózat bármely helyéről távolról felügyelhet egy Windows 2000 nyomtatókiszolgálót. Ezenkívül már nem kell a Windows 2000 ügyfélszámítógépekre nyomtatóillesztő-programot telepíteni ahhoz, hogy a gépek nyomtatót használhassanak. Az illesztőprogram a Windows 2000 nyomtatókiszolgálóhoz való csatlakozáskor automatikusan letöltődik az ügyfélre. Ez megkönnyíti a hálózaton keresztül történő nyomtatást.


Új Internet-, alkalmazás- és hálózattámogatási szolgáltatások

A Windows 2000 Server számos hatékony internetes lehetőséget, alkalmazás- és alkalmazásfejlesztés-támogatást, valamint hálózati és kommunikációs képességet tartalmaz.

  • Internet- és multimédiás szolgáltatások
  • Alkalmazás és fejlesztés-támogatás
  • Hálózati protokollok és technológiák


Internet- és multimédiás szolgáltatások

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található.

  • Internet Information Services szolgáltatásai
  • Multimédia-támogatás


Internet Information Services szolgáltatásai

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server több hatékony internetes megoldást tartalmaz.

Integráció az Internet Information Services 5.0 szolgáltatással
A Microsoft Windows 2000 Server részét képező Internet Information Services (IIS) szolgáltatásai megkönnyítik a dokumentumok és az információ vállalati intraneten vagy az Interneten keresztül történő megosztását. Az IIS használatával központilag telepíthet méretezhető, megbízható, Web alapú alkalmazásokat, valamint közzétehet a Weben meglévő adatokat és alkalmazásokat. Az IIS tartalmazza az Active Server Pages környezetet és a listában felsorolt többi szolgáltatást.
Active Server Pages
Az Active Server Pages (ASP) dinamikus, interaktív Webkiszolgáló-alkalmazások létrehozására szolgáló kiszolgálóoldali parancsnyelvi környezet. Az ASP lapok segítségével a fejlesztők igény szerint kombinálhatják a HTML-lapokat, a szkriptutasításokat és a COM-komponenseket, miáltal rugalmas és hatékony Web alapú alkalmazásokat hozhatnak létre.
Windows Media szolgáltatások
A Windows Media szolgáltatások használatával kiváló minőségben biztosíthatja a médiatartalom folyamatos átvitelét az Interneten vagy intraneten keresztül a felhasználókhoz.
Distributed Authoring and Versioning
A Distributed Authoring and Versioning lehetővé teszi, hogy távoli felhasználók a kiszolgálón található fájlokat, fájltulajdonságokat, könyvtárakat és könyvtártulajdonságokat HTTP-csatlakozáson keresztül szerkesszék, áthelyezzék vagy töröljék.


Multimédia-támogatás

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat a A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server számos szolgáltatást nyújt a kiszolgáló multimédiás lehetőségeinek kiterjesztésére.

Windows Media szolgáltatások
A Windows Media szolgáltatások használatával kiváló minőségben biztosíthatja a médiatartalom folyamatos átvitelét az Internet és az intranetek felhasználóinak.
Előre látható végpontok közötti szolgáltatásminőség
A Windows Szolgáltatás minősége (QoS) lehetővé teszi a sávszélesség az alkalmazások számára való kiosztásának vezérlését. A fontos alkalmazások nagyobb sávszélességet, a kevésbé fontos alkalmazások kisebb sávszélességet kaphatnak. A QoS alapú szolgáltatások és protokollok garantált, végpontok közötti, expressz kézbesítési rendszert biztosítanak az információknak a hálózaton.
Resource Reservation protokoll
A Resource Reservation protokoll (RSVP) a multimédiás és más olyan alkalmazásokhoz használható, amelyek állandó sávszélességet vagy válaszszinteket igényelnek a hálózaton. Az RSVP használatával ezek az alkalmazások megkaphatják a megfelelő szolgáltatási minőséget a hálózatról és segítségével kezelhető az alkalmazások hálózati erőforrásokra gyakorolt hatása. Az RSVP egy kérés-engedélyezés típusú szolgáltatás, ahol az ügyfelek foglalási kéréseit a rendszer vagy elfogadja, vagy megtagadja, a házirendek és a rendelkezésre álló hálózati erőforrások alapján.
Aszinkron átviteli mód
Az aszinkron átviteli mód (ATM) egy nagy sebességű kapcsolatorientált protokoll, mely többféle hálózati forgalom lebonyolítására szolgál. Helyi és nagy kiterjedésű hálózatokon egyaránt használható. Az ATM használatával a hálózat egy időben a hálózati adatforgalom széles skáláját továbbíthatja: hangot, adatokat, képet vagy mozgóképet.


Alkalmazás és fejlesztés támogatása

Az ebben a témakörben ismertetett támogatási típusokat és a Windows 2000 más támogatási típusait összevető táblázat A Windows 2000 Server újdonságai című témakörben található.

  • A meglévő rendszerek támogatása
  • Alkalmazás támogatása
  • Alkalmazások kezelése és központi telepítése
  • A Terminálszolgáltatások lehetőségei
  • Fejlesztés támogatása


A meglévő rendszerek támogatása

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összefüggésben bemutató táblázat A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server támogatja a UNIX, a Novell NetWare, a Windows NT Server 4.0 és a Macintosh rendszerekkel való együttműködést, lehetővé téve a Windows 2000 Server rendszernek egy már meglévő környezetbe való integrálását. A Windows 2000 Server rendszert fokozatosan is bevezetheti a hálózati környezetbe, mert a rendszer biztosítja az áttérést tetszőleges számú meglévő rendszerről, eszközről és alkalmazásról.

Megjegyzés

  • A Microsoft termékekkel kapcsolatos legfrissebb 2000 évi információ megtekintéséhez látogasson el a Microsoft year 2000 readiness disclosure and resource center webhelyre (http://www.microsoft.com/year2000). A Windows 2000 Server az euró szimbólumát is támogatja.

A Windows 2000 alábbi tervezési sajátosságai teszik lehetővé a legtöbb rendszerrel és alkalmazással való együttműködést:

Iparági szabványok
A Windows 2000 Server többek között az alábbi legújabb iparági szabványokat támogatja:
  • Lightweight Directory Access protokoll (LDAP)
  • DNS
  • Active Directory Service Interfaces
  • Kerberos V5
A meglévő alkalmazások támogatása
A Windows 2000 Server támogatja a meglévő BackOffice alkalmazásokat, például a Microsoft Exchange és a Microsoft SQL Server alkalmazásokat. A Microsoft Active Directory Connector segítségével az Exchange fiókok könnyedén szinkronizálhatók a Windows 2000 kiszolgálófiókokkal arra az időre, amíg az Exchange új, az Active Directoryt használó verziójának kibocsátására sor kerül. A BackOffice emblémával jelzett alkalmazásokat az együttműködés szempontjából is tesztelték.
Integráció meglévő operációs rendszerekkel
A Windows 2000 integrálható meglévő rendszerekkel és támogatja a korábbi Windows operációs rendszereket, illetve szolgáltatásokkal rendelkezik más ismert operációs rendszerek támogatásához is. A Windows 2000 sajátosságai:
  • Együttműködés a Windows NT Server 3.51 és 4.0 rendszerekkel.
  • Windows 3.x, Windows 95, Windows 98 vagy Windows NT Workstation 4.0 operációs rendszereket alkalmazó ügyfelek támogatása.
  • Együttműködés UNIX rendszerekkel a Windows Services for UNIX bővítőcsomag segítségével. A bővítőcsomag tartalmazza az NFS fájlrendszer, a jelszószinkronizálás, a UNIX parancsértelmező héj és a UNIX-segédprogramok gyűjteményének támogatását. A bővítőcsomag támogatja a Network Information Services (NIS) szolgáltatást is. A Telnet (távelérési és felügyeleti) szolgáltatások a Windows 2000 rendszerben és a bővítőcsomagban is megtalálhatók.
  • Kapcsolódási lehetőség a nagy és közepes számítógépekhez SNA-Server igénybevételével, S/390 és AS/400 tranzakciós és várakozási kapuk használatával.
  • Macintosh fájlkiszolgáló, amely lehetővé teszi a Macintosh ügyfelek számára a TCP/IP protokoll (AFP az IP-n keresztül) használatát fájlok megosztására és a Windows 2000 kiszolgálón lévő megosztások eléréséhez.


Alkalmazás támogatása

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server operációs rendszer a független szoftverszállítókkal kapcsolatban számos kulcsrakész megoldást nyújt az ügyfelek számára, illetve az egyéni alkalmazások gyors fejlesztése céljából az internetes alkalmazásszolgáltatások széles körét biztosítja.

Kulcsrakész alkalmazások széles skálája
A Windows NT Server operációs rendszerben jelenleg több mint 3800 alkalmazás áll rendelkezésre, a Windows 2000 Server operációs rendszer megjelenése utáni hónapokban pedig több száz új alkalmazás megjelenése várható.

A Microsoft Windows 2000 rendszerrel kompatibilis és bevizsgált alkalmazások legfrissebb listáját a Directory of Windows 2000 Applications webhelyen találja a következő címen. (http://www.microsoft.com/)

A jelenlegi, valamint külön a Windows 2000 rendszer számára tervezett alkalmazásokkal kapcsolatban ezen a helyen talál információt.

Széles körű internetes alkalmazásszolgáltatások
A Windows 2000 rendszer integrált web-, komponenskezelési, tranzakciófeldolgozási, valamint üzenetsor-kezelési szolgáltatásai révén a programozók gyorsan fejleszthetnek és helyezhetnek üzembe méretezhető, komponens alapú alkalmazásokat.
Active Accessibility
Az Active Accessibility a Windows 2000 rendszer olyan beépített alkalmazásfejlesztői felülete, amely az operációs rendszer kulcsszolgáltatásait bővíti ki. A szolgáltatás kisegítő lehetőséget (vagy egyéb Active Accessibility ügyfelet) biztosít annak érdekében, hogy a rendszer értelmezhető adatokat nyerjen az adott alkalmazásról, amit utána a felhasználóhoz továbbít. Mivel az Active Accessibility csökkenti az alkalmazásfüggő kódok szükségességét, az általános karbantartási költségek is csökkennek. Ez lehetővé teszi a szoftverfejlesztők számára, hogy olyan újításokat eszközöljenek felhasználói felületükön, amelyek nem csökkentik a kisegítő lehetőséggel való kompatibilitást. További információ a Microsoft Accessibility webhelyén található (http://www.microsoft.com/).
TAPI 3.0
A TAPI 3.0 egyesíti az IP- és a hagyományos telefont, lehetővé téve a fejlesztők számára, hogy a hatékony számítógépes telefonalkalmazások új generációját hozzák létre, amely egyforma hatékonysággal működik az Interneten, az intraneten és a hagyományos telefonvonalon is.
Tranzakciószolgáltatások
A Windows 2000 Server operációs rendszer integrált tranzakciószolgáltatásai olyan egyszerű részegységeket biztosítanak, melyek segítségével széleskörű elosztott hálózatokon keresztül is megbízhatóan és hatékonyan végezhet bonyolult tranzakciókat.
Message Queuing
A Windows 2000 integrált üzenetsor-kezelési funkciói a fejlesztőket segítik olyan alkalmazások készítésében és üzembe helyezésében, amelyek a hálózatokon (például az Interneten) megbízhatóbban működnek. Ezek az alkalmazások együttműködhetnek a különböző felületeken, például a mainframe vagy UNIX alapú rendszereken futó alkalmazásokkal.
Komponensszolgáltatások
A Komponensszolgáltatások a Component Object Model (COM) és a Microsoft Transaction Server (a komponens alapú adattovábbítást feldolgozó rendszer egy korábbi kiadása) bővítésein alapulnak. A Komponensszolgáltatások a korábbinál jobb szálkezelési és biztonsági, tranzakciókezelési, objektumkészletezési, alkalmazásfelügyeleti és -csomagolási valamint aszinkron komponensekkel kapcsolatos szolgáltatásokkal rendelkeznek.
Feladatobjektumok
A Windows 2000 Server operációs rendszer bővítményt tartalmaz a feladat nevű eljárásmodellhez. A feladatobjektumok olyan megnevezhető, biztosítható és megosztható objektumok, amelyek a hozzájuk rendelt eljárások attribútumait szabályozzák. A feladatobjektumok alapfunkciója az, hogy az eljárások csoportjait egyetlen egységként kezeljék és irányítsák. Egy webalkalmazás például feladatobjektum használatával a CPU-igénybevételt is figyelheti.
Állomások adatainak integrálása
A Windows 2000 Server rendszer az ODBC, az Oracle és a Microsoft SQL Server natív üzemmódú támogatásával kitűnő platformot biztosít adatbázis-alkalmazások futtatásához.


Alkalmazások kezelése és telepítése

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat a A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server alábbi szolgáltatásai egyszerűvé teszik az alkalmazások asztali és hordozható rendszereken való telepítését. A Terminálszolgáltatások további, az alkalmazások telepítését egyszerűsítő lehetőségeket és szolgáltatásokat nyújtanak. További információ a Terminálszolgáltatások tulajdonságai című témakörben található.

Egységes címtár az Active Directoryban
Szervezetté és egyszerűbbé teheti a felhasználók, számítógépek, alkalmazások és eszközök kezelését, valamint megkönnyítheti, hogy a felhasználók a szükséges információt megtalálják. Kihasználhatja a szinkronizálás LDAP alapú felületek segítségével történő támogatását és kezelheti az alkalmazások speciális egységes címtárigényeit.
Címtárszolgáltatásokkal együttműködő alkalmazások és infrastruktúra az Active Directoryban
Az Active Directory szolgáltatásai megkönnyítik az alkalmazások és az egyéb, címtárszolgáltatásokkal együttműködő hálózati összetevők konfigurálását és kezelését.
IntelliMirror
A költségek csökkentése érdekében a rendszergazdák a legmagasabb szintű felügyeletet igénylik a hordozható és az asztali rendszerek felett. Az IntelliMirror biztosítja ezt a Windows 2000 Professional rendszert futtató ügyfélrendszerekhez. Az IntelliMirror segítségével a házirendek az egyes felhasználók üzleti szerepe, csoporttagsága és helye alapján határozhatók meg. Az ilyen házirendek használatakor a Windows 2000 Professional rendszert futtató asztali számítógépek újrakonfigurálása automatikusan megtörténik a felhasználó minden bejelentkezésekor, függetlenül a bejelentkezés helyétől.

Az IntelliMirror alapja három szolgáltatás:

  • A felhasználói adatok kezelése
  • Szoftverek telepítése és karbantartása
  • A felhasználói beállítások kezelése

Az IntelliMirror szolgáltatásai külön és együtt is használhatók, a környezet igényeinek megfelelően. Ezzel biztosítható a konzisztencia és a megbízhatóság a felhasználóknak, függetlenül attól, hogy milyen számítógépet használnak.

Windows Management Instrumentation (WMI)
A Web-Based Enterprise Management (WBEM) egységes hozzáférést biztosít a kezelési információkhoz. A WBEM a Distributed Management Task Force (DMTF) kezdeményezése a DMTF által tervezett Common Information Model (CIM) ipari szabvány széleskörű elterjesztésére. A CIM egy bővíthető objektum-orientált séma rendszerek, hálózatok, alkalmazások, adatbázisok és eszközök kezelésére.

A Windows Management Instrumentation (WMI) – amelyre használják a CIM for Windows elnevezést is – ennek a technológiának a Microsoft általi WBEM-kompatibilis megvalósítása. A WMI segítségével figyelheti, nyomon követheti és vezérelheti a szoftveralkalmazásokkal, hardverösszetevőkkel és hálózatokkal kapcsolatos rendszereseményeket. A WMI lényegében kiterjeszti a CIM sémát a Win32 rendszerkörnyezetre és a Microsoft alkalmazásokra. Használhatja a CIM sémát különböző forrásokból származó adatok közös, normalizált és logikusan szervezett módon történő hozzárendelésére, és a kezelési adatok közti összefüggések és társítások kialakítására, típustól, tartalomtól és forrástól függetlenül.

A WMI működése

A WMI egyetlen felület használatával helyi és távoli hozzáférést biztosít a rendszergazdáknak és a kezelőalkalmazások fejlesztőinek a Win32 rendszerhez, a Rendszerfigyelő eszközhöz, a WMI for Windows Driver Model (WDM) felülethez, a rendszerleíró adatbázishoz, az eseménynaplókhoz, a Desktop Management Interface (DMI) felülethez, a Simple Network Management protokollhoz (SNMP) és bármely más, a WMI által előállított adathoz. Ez azt jelenti, hogy a rendszergazdáknak és a fejlesztőknek nem kell több API felületet (például a Win32, az RPC, a rendszerleíró adatbázis és a WinSNMP API felületeket) megismerniük ahhoz, hogy hatékony kezelőeszközöket készíthessenek.

A WMI biztosítja a rendszerfigyeléshez szükséges infrastruktúrát: az események összesítését, a CIM-lekérdezésen alapuló eseményküszöböket és szűrést. Ez az infrastruktúra a WMI által előállított bármely kezelési adathoz használható. Ez egyetlen keretet biztosít korábban különálló események figyelésére, például:

  • A szabad lemezterület egy előre beállított küszöb alá csökkenése
  • A TCP/IP-szolgáltatás leállása
  • Kapcsolat megszűnését jelző SNMP-trap fogadása az adott számítógép alapértelmezett útválasztóján keresztül
  • A kiszolgáló terhelésének növekedése egy (összesített WMI-adatok alapján) megadott küszöb fölé

A WMI tartalmazza a CIM objektumkezelőt (CIMOM) és támogatja a bővíthető szolgáltatói architektúrát, amely információk széles tartományát állítja elő egységes séma szerint. A WMI tartalmazza a szabvány szállítókat (Win32, rendszerleíró adatbázis, Rendszerfigyelő, SNMP, ADSI, DMI, eseménynaplók és WMI for WDM). A WMI használatával más szoftverszállítók bővíthetik a sémát és növelt értéket építhetnek a már kialakított CIM Win32 osztályokra.

A WMI-felületek működnek a (korábban COM+ néven ismert) Komponensszolgáltatásokkal és a parancsnyelvekkel (a Visual Basic, a Visual Basic Scripting Edition, a JScript és a Perl nyelvekkel), lehetővé téve a C++ nyelven írt parancsfájlok és kifinomult alkalmazások gyors fejlesztését. A Windows 2000 Windows Script Host objektummodelljét kiegészíti a CIM objektummodell, lehetővé téve egyszerű és hatékony parancssori vagy weblap-parancsfájlok készítését.

Computer Associates’ Real World Interface
Számos kezelési megoldáshoz rendelkezésre áll a WMI rendszer- és alkalmazáskezelő eszközstruktúrája. A Computer Associates (CA ) Real World Interface for Windows 2000 programja olyan hatékony kezelőalkalmazás, amely a CA Unicenter TNG Framework technológiáján alapul. Könnyű hozzáférést biztosít a kezelési adatokhoz azzal, hogy automatikusan megtalálja a WMI-erőforrásokat, tárházában információkat tárol róluk és könnyen érthető két- és háromdimenziós Windows vagy Java böngészőfelületen megjeleníti azokat. Ez az alkalmazás a Windows 2000 CD-ROM Valueadd mappájában található.


A Terminálszolgáltatások nyújtotta lehetőségek

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található. A Terminálszolgáltatások használatával kapcsolatos információ a Terminálszolgáltatások című témakörben található.

Egyedül a Windows 2000 Server család kínál olyan kiszolgálói operációs rendszereket, amelyek terminálemulációs szolgáltatásokat foglalnak magukba. A Terminálszolgáltatások segítségével a felhasználó különféle régebbi eszközökről is hozzáférhet a kiszolgálón futó programokhoz. A felhasználó hozzáférhet például egy virtuális Windows 2000 Professional Asztalhoz és 32 bites alkalmazásokhoz olyan hardverről is, amely nem képes ezeknek a szoftvereknek a helyi futtatására. A terminálszolgáltatások mind a Windows alapú, mind a nem Windows alapú ügyféleszközök esetén is biztosítják ezt a lehetőséget. (A nem Windows alapú eszközökhöz a Citrix Systems bővítőszoftvere szükséges.) A terminálszolgáltatások a következő előnyöket biztosítják:

Központi hozzáférés az alkalmazásokhoz
A terminálszolgáltatások használatakor minden alkalmazás a kiszolgálón található és a kiszolgálón fut. A gyakran frissítendő alkalmazások esetén a terminálszolgáltatásokkal hatékonyan, jól kezelhetően biztosítható a felhasználó számára a legfrissebb verzió.
Alkalmazások távelérése
A Terminálszolgáltatások program azért hatékony, mert az alkalmazásokat úgy jeleníti meg az ügyfélen, hogy annak adatai a kiszolgálón maradnak. Ily módon kisebb sávszélességű (például 28,8 kB/s sebességű telefonos) kapcsolaton keresztül is hozzáférést biztosíthat a felhasználók számára a sok adattal dolgozó alkalmazásokhoz, és nagyobb teljesítményt tehet lehetővé, mint amely a terminálszolgáltatások nélkül lehetséges lenne.
Egyetlen alkalmazás elérése
A terminálszolgáltatásokkal biztosíthatja a felhasználók számára egyetlen közzétett alkalmazás elérését, ha nincs szükség a teljes Windows 2000 Professional Asztalra.

A terminálszolgáltatások távoli üzemeltetésre is használható. További információ a Távoli kezelés című témakörben található.


Fejlesztés támogatása

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összekapcsoló táblázat A Windows 2000 Server újdonságai című témakörben található.

A kiszolgáló alapú alkalmazásokat készítő fejlesztők a Microsoft Visual Studio hatékony eszközeivel és egyéb fejlesztési eszközökkel is dolgozhatnak. A Windows 2000 operációs rendszer architektúrája lehetővé teszi a fejlesztők számára, hogy olyan alkalmazásokat hozzanak létre, amelyeket könnyű honosítani.

Visual Studio 6.0
A Visual Studio 6.0 a modern vállalati megoldásokat létrehozó szervezetek fő szükségleteinek megoldását szolgálja. A Visual Studio 6.0 létrehozásának céljai a következők:
  • A komponens alapú fejlesztést szolgáló eszközök teljes választéka
  • Bővített életciklusú produktivitás
  • Vállalati adatbáziseszközök
  • Bővített támogatás munkacsoportok számára
  • Integráció az alkalmazásszolgáltatásokkal
Többnyelvűséget biztosító technológia
A Windows 2000 rendszer architektúrája következtében az operációs rendszer, a segédprogramok, valamint a megfelelően megírt alkalmazások több száz nyelvre lefordíthatók, amelyek így könnyen honosíthatók.


Hálózati protokollok és technológiák

Az ebben a témakörben ismertetett szolgáltatásokat a Windows 2000 más szolgáltatásaival összehasonlító táblázat A Windows 2000 Server újdonságai című témakörben található.

A Windows 2000 Server operációs rendszer számos hálózati protokollt és technológiát tartalmaz a kiszolgáló lehetőségeinek bővítésére. A hálózatokkal kapcsolatos technológiákról további információ a Teljesítménybeállítási és hangolási lehetőségek című témakörben található.

DHCP protokoll használata DNS-kiszolgálóval és Active Directoryval
A Dynamic Host Configuration protokoll (DHCP) együttműködik a DNS-rendszerrel és az Active Directoryval az IP-hálózatokon, mentesítve a felhasználót az IP-címek hozzárendelésének és nyomon követésének feladata alól. A DHCP dinamikusan rendeli hozzá az IP-címeket az IP-hálózathoz csatlakozó számítógépekhez illetve más erőforrásokhoz.
Az Internet-kapcsolat megosztása
A Hálózati és telefonos kapcsolatok Internet-kapcsolat megosztása szolgáltatásával az Internethez csatlakoztathatja Windows 2000 rendszert futtató otthoni hálózatát vagy kis irodai hálózatát. Olyan otthoni hálózata is lehet például, amely telefonos kapcsolat segítségével csatlakozik az Internethez. Ha a telefonos kapcsolattal rendelkező számítógépen engedélyezi az Internet-kapcsolat megosztását, hálózati címfordítást, címzést, valamint névhozzárendelési szolgáltatásokat tehet elérhetővé az otthoni hálózat összes számítógépe számára. További információ az Internet-kapcsolat megosztása című témakörben található
.
Hálózati címfordítás
A hálózati címfordítás (NAT – Network Address Translation) elrejti a belső kezelésű IP-címeket a külső hálózatok elől azáltal, hogy a magáncélú belső címeket nyilvános külső címekre fordítja le. Ez csökkenti az IP-címek regisztrációs költségeit azáltal, hogy lehetővé teszi regisztrálatlan IP-címek belső használatát kis számú regisztrált IP-cím külső használatával. A belső hálózati struktúrát is segít elrejteni, csökkentve a belső rendszert érő támadások kockázatát.
Virtuális magánhálózat
Virtuális magánhálózat (VPN) megvalósításával a felhasználóknak azonnali hozzáférést biztosíthat a hálózathoz, akkor is, ha az irodán kívül tartózkodnak, valamint ezáltal csökkentheti a hozzáférés költségét. A VPN hálózatok lehetővé teszik a felhasználók számára, hogy egyszerűen és biztonságosan csatlakozzanak a vállalati hálózathoz. A csatlakozás valamelyik helyi Internet-szolgáltatón keresztül történik, ami csökkenti a kapcsolódási idő költségét.
A Windows 2000 Server rendszerben a virtuális magánhálózat létrehozása céljából több új, biztonságosabb protokollt használhat, mint például:
  • A Layer 2 Tunneling protokoll (L2TP), ami a Point to Point Tunneling protokoll (PPTP) biztonságosabb változata. Az L2TP bújtatásra, címhozzárendelésre és hitelesítésre szolgál.
  • Az Internet-protokoll biztonság (IPSec) egy olyan szabvány alapú protokoll, amely biztosítja a virtuális magánhálózat legmagasabb szintű biztonságát . Az IPSec használatával a hálózati réteg felett gyakorlatilag minden titkosítható.
Útválasztás és távelérés szolgáltatás
Az Útválasztás és távelérés szolgáltatás egyetlen integrált szolgáltatás, amely vagy megszakítja a telefonos, illetve VPN-ügyfelek által létrehozott kapcsolatokat, vagy biztosítja az (IP, IPX vagy AppleTalk) útválasztást, vagy mindkét feladatot ellátja. Az Útválasztás és távelérés szolgáltatás lehetővé teszi, hogy a Windows 2000 kiszolgáló távelérési kiszolgálóként, VPN-kiszolgálóként, átjáróként vagy egy fiókiroda útválasztójaként működjön.
Távelérés biztosításakor az Útválasztás és távelérés szolgáltatás támogatja a PPP protokollt (a szabványos telefonos protokollt). Az új Extensible Authentication protokollt is támogatja, amely lehetővé teszi a forgalmazók által biztosított hitelesítési módszerek (például a retinaellenőrzés) használatát a távoli ügyfelek számára.
Amikor a kiszolgáló útválasztóként működik, az Útválasztás és távelérés szolgáltatás a helyi (LAN hálózatok közötti) és a távoli (igény szerint tárcsázó) útválasztást is támogatja. A fizikai telefonos, kerettovábbító, ISDN- és X.25-kapcsolaton kívül a kapcsolat formája vállalati hálózathoz közvetlen kapcsolattal csatlakozó, illetve az Interneten keresztül létrejövő pontról pontra küldéses, fiókirodai VPN-kapcsolat is lehet. Az Útválasztás és távelérés szolgáltatás IP hálózatok esetében az OSPF és RIP2 útválasztást vezérlő protokollokat, IPX hálózatok esetében pedig a RIP és SAP protokollokat támogatja. A Windows 2000 Server útválasztási és átjárószolgáltatásai lehetővé teszik a fiókirodák (vagy peremhálózatok) és a vállalati hálózat közötti rugalmas csatlakozások létrehozását.
Aszinkron átviteli mód
Az aszinkron átviteli mód (ATM) egy nagy sebességű kapcsolatorientált protokoll, mely többféle hálózati forgalom lebonyolítására szolgál. Helyi (LAN) és nagy kiterjedésű (WAN) hálózatokon egyaránt használható. Az ATM használatával a hálózaton egy időben többféle adatot vihet át: hangot, adatokat, képet vagy videót.
Fibre Channel
A Fibre Channel olyan technológia, amely 1 gigabit/másodperc sebességű adatátvitelre képes, leképezi az általános átviteli protokollokat (mint például az SCSI vagy az IP), miközben a hálózatot és a nagy sebességű kimeneti/bemeneti (I/O) műveleteket egyetlen kapcsolattechnológiába egyesíti. A Fibre Channel technológia lehetőséget nyújt a felhasználónak arra, hogy a hagyományos csatornatechnológiák távolság- és címkorlátozásait más módon közelítse meg.


A Windows 2000 Server telepítése

Az alábbi témakörök a Windows 2000 Server 2-5 kiszolgálóból álló – maximum száz ügyfelet kiszolgáló – tartományban (csoportban) történő telepítéséhez nyújt segítséget. Több kiszolgálóból álló tartományok megtervezéséhez a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezetében talál útmutatást. Ha további információra van szüksége a Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.

  • Feladatlisták
  • Gyakorlati tanácsok
  • Útmutató
  • Fogalmak
  • Hibaelhárítás


Feladatlisták

  • Feladatlista: Frissítés végrehajtása
  • Feladatlista: Új telepítés végrehajtása


Feladatlista: Frissítés végrehajtása

Lépés | Hivatkozás
Ellenőrizze a rendszerkövetelményeket. | Rendszerkövetelmények
Olvassa el a Fontos.txt és az Olvassel.doc fájlokat, valamint a hardverkompatibilitással kapcsolatos információkat. | Lényeges tudnivalókat tartalmazó fájlok Hardverkompatibilitás
Állapítsa meg, hogy jelenlegi operációs rendszerén elvégezhető-e frissítés a Windows 2000 Server operációs rendszerre. | A frissítés és a telepítés összehasonlítása
Tekintse át a létező tartomány frissítésére vonatkozó alapfogalmakat. | Tartomány frissítése
Döntse el, hogy a FAT vagy FAT32 fájlrendszerű partíciókat NTFS fájlrendszerűre szeretné-e frissíteni. | A fájlrendszer megválasztása
Készítsen biztonsági másolatot a fájlokról. | A rendszer előkészítése frissítéshez
Bontsa ki a DriveSpace vagy a DoubleSpace segédprogrammal tömörített köteteket. | A rendszer előkészítése frissítéshez
Tiltsa le a lemeztükrözést. | A rendszer előkészítése frissítéshez
Válassza le az UPS-eszközöket. | A rendszer előkészítése frissítéshez
Tekintse át az alkalmazásokat. | A rendszer előkészítése frissítéshez
Indítsa a Telepítőt, és kövesse a képernyőn megjelenő utasításokat. | A Telepítő indítása


Feladatlista: Új telepítés végrehajtása

Lépés | Hivatkozás
Ellenőrizze a rendszerkövetelményeket. | Rendszerkövetelmények
Olvassa el a Fontos.txt és az Olvassel.doc fájlban található, valamint a hardverkompatibilitással kapcsolatos információkat. | Lényeges tudnivalókat tartalmazó fájlok Hardverkompatibilitás
Döntse el, hogy frissítést vagy telepítést szeretne-e végrehajtani. | Frissítés vagy telepítés
Döntse el, milyen licencelési módot szeretne használni: Munkaállomásonként vagy Kiszolgálónként. | A licencelési mód megválasztása
Döntse el, hogy szeretne-e élni azzal a lehetőséggel, hogy a számítógép minden egyes bekapcsolásakor különböző operációs rendszerek között választhat. | Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre?
Döntse el, milyen fájlrendszert szeretne használni: NTFS, FAT vagy FAT32. | A fájlrendszer megválasztása
Döntse el, melyik partícióra szeretné a rendszert telepíteni, illetve hogy a telepítéshez szüksége lesz-e új partícióra. | Lemezpartíciók tervezése új telepítés esetén
Döntse el, milyen összetevőket szeretne telepíteni. | A telepítendő összetevők kiválasztása
Döntse el, miként szeretné kezelni a hálózatot, az IP-címeket, valamint a TCP/IP -névhozzárendelést. | Hálózat: TCP/IP, IP-címek és névhozzárendelés
Döntse el, hogy kiszolgálói számára tartományokat vagy munkacsoportokat szeretne-e kialakítani. | Mikor érdemesebb munkacsoportot, mikor tartományt választani?
Készítsen biztonsági másolatot a fájlokról. | A rendszer előkészítése új telepítéshez
Bontsa ki a DriveSpace vagy a DoubleSpace segédprogrammal tömörített köteteket. | A rendszer előkészítése új telepítéshez
Tiltsa le a lemeztükrözést. | A rendszer előkészítése új telepítéshez
Válassza le az UPS-eszközöket. | A rendszer előkészítése új telepítéshez
Indítsa a Telepítőt, és kövesse a képernyőn megjelenő utasításokat. | A Telepítő indítása


Gyakorlati tanácsok

Az alábbi lista a kiszolgálók telepítésének előkészítéséhez, illetve minden egyes kiszolgáló telepítés utáni ellenőrzéséhez nyújt gyakorlati tanácsokat. A telepítéssel kapcsolatos alapvető tudnivalókért tanulmányozza az Útmutató és a Fogalmak témakörök telepítéssel kapcsolatos részeit.

  • A kiszolgálók előkészítése frissítéshez

    • Ha frissítést hajt végre, az alábbi témaköröket tanulmányozza:

    • Feladatlista: Frissítés végrehajtása
    • A rendszer előkészítése frissítéshez
  • A kiszolgálók előkészítése új telepítéshez

    • Ha új telepítést hajt végre, az alábbi témaköröket tanulmányozza:

    • Feladatlista: Új telepítés végrehajtása
    • A rendszer előkészítése új telepítéshez
  • A kiszolgálók ellenőrzése a telepítés után

    • A telepítés után ellenőrizheti, hogy helyes-e a kiszolgálók alapkonfigurációja.

    • Az Eseménynapló ellenőrzése. Ellenőrizze az Eseménynaplót, hogy érkezett-e a telepítéssel vagy az indítási eljárással kapcsolatos üzenet. További tájékoztatásért olvassa el az Eseménynapló című témakört.
    • Az Eseménynapló sortörési beállításainak és a napló méretének meghatározása. Határozza meg az eseménynapló, valamint a napló sortörésének méretét (szükség szerinti felülírás, törlés kézzel, felülírás meghatározott időtartam után), hogy megfeleljen üzleti, illetve biztonsági igényeinek. További információ Az eseménynaplózás beállításainak megadása című témakörben található.
    • A Számítógép-kezelés szolgáltatásainak áttekintése Nyissa meg a Számítógép-kezelés ablakot A Számítógép-kezelés használata temakörben leírtak szerint. A Szolgáltatások mappában ellenőrizze, hogy az Automatikus indítás oszlopban az összes szolgáltatás Automatikus módra van-e állítva, azaz a szolgáltatások a felhasználó beavatkozása nélkül, illetve az első próbálkozás után indulnak. Emellett a fölösleges vagy nem használt szolgáltatások indítási értékét állítsa Kézi beállításra. Azon számítógépeknél például, amelyek nem rendelkeznek megosztott vagy saját nyomtatóval, a Nyomtatásisor-kezelő szolgáltatás nem használt szolgáltatásnak számít.
    • A kiszolgáló optimalizálásának ellenőrzése Ellenőrizze a kiszolgáló beállítását a Vezérlőpult Hálózati és telefonos kapcsolatok szolgáltatásában. Módosítsa a kiszolgáló beállítását aszerint, hogy számítógépe a vállalaton belül milyen szerepet tölt be. Ha a kiszolgáló optimalizálási beállításaihoz történő hozzáféréssel kapcsolatban további információra van szüksége, tanulmányozza A számítógép memóriával kapcsolatos beállításainak konfigurálása című témakört.
    • Az IP, a DNS, a WINS, valamint az alapértelmezett átjáró beállításainak ellenőrzése A Hálózat szolgáltatásban leírt felügyeleti eszközök segítségével módosíthatja és ellenőrizhati a beállításokat. A beállításokat úgy is ellenőrizheti, ha a parancssorba begépeli a ipconfig /all parancsot, majd ellenőrzi a képernyőn megjelenő adatokat.
    • A teljesen minősített számítógépnév megtekintése A teljesen minősített számítógépnév megtekintéséhez gépelje be a parancssorba a net config rdr parancsot. Az eredményt vesse össze az Active Directory nevével, hogy megbizonyosodjon arról, hogy a két név egyezik. Ha szükséges, módosíthatja is a nevet.
    • A lapozófájl méretének és elhelyezkedésének beállítása A lapozófájl méretét és elhelyezkedését a memória mérete és a kiszolgáló használata alapján állítsa be. További információ A virtuális memóriát használó lapozófájl méretének módosítása című témakörben található. Ha létfontosságú kiszolgálóknál a lapozófájl mérete nem kisebb a RAM memória méreténél, akkor a fájlnak az operációs rendszerrel azonos partíción kell lennie.
    • Biztonsági másolat készítése, illetve egyéb megelőző karbantartási műveletek végrehajtása Készítsen biztonsági másolatokat, valamint a létfontosságú kiszolgálóknál gyakorolja vagy szimulálja a helyreállítási műveletek végrehajtását (amikor alacsony a kiszolgáló igénybevétele). További információt a következő témakörökben talál:
      • Hibatűrés
      • Katasztrófa után helyreállítás
  • Egyéb információforrások és eszközök megismerése Az egyéb források listája a Windows 2000 Resource Kit csomaggal együtt az Egyéb források című témakörben található. A lista a Microsoft webhelyen is megtalálható (http://www.microsoft.com/) A lista pontos meghatározásához használja a webhely keresési lehetőségeit. További információ a Frissített technikai információ című témakörben található.
  • A felhasználó által használni kívánt lehetőségekkel és összetevőkkel összefüggő Gyakorlati tanácsok témakörök és feladatlisták áttekintése A Gyakorlati tanácsok témakörök listája a Gyakorlati tanácsok című témakörben található. A Feladatlisták listája a Feladatlisták című témakörben található.


Útmutató

Az alábbi szakaszok a Windows 2000 Server telepítését ismertetik. Új telepítés végrehajtása előtt tekintse át a Feladatlista: Új telepítés végrehajtása című témakört.

  • A Telepítő indítása
  • A kiszolgálói beállítások megadása új telepítéskor
  • A kiszolgáló konfigurálása


A Telepítő indítása

  • A Telepítő indítása CD-ről Windows rendszert futtató számítógépen
  • A Telepítő indítása hálózatról
  • A Telepítő indítása és új telepítés végrehajtása CD-ről MS-DOS rendszert futtató számítógépen
  • A Telepítő indítása és új telepítés végrehajtása a számítógép CD-ről történő indításával
  • A Telepítő indítása és új telepítés végrehajtása a számítógép hajlékonylemezről történő indításával
  • A Telepítő indítása és háttértároló-illesztőprogram vagy HAL-fájl megadása


A Telepítő indítása CD-ről Windows rendszert futtató számítógépen

  1. Helyezze be a CD–ROM-ot a meghajtóba.
  2. A Telepítő indításához hajtsa végre a következők valamelyikét:
    • A Windows 3.x kivételével bármelyik Windows-verziót futtató számítógépen várjon, amíg a Telepítő párbeszédpanele megjelenik.
    • Windows 3.x rendszerrel működő számítógépen a Fájlkezelő eszközben váltson a CD-ROM meghajtóra, majd az I386 könyvtárra. Ezután kattintson duplán a Winnt.exe fájlra.
  3. Kövesse a Telepítő utasításait.

Megjegyzések

  • Ha a Telepítőt Windows 3.x rendszerrel működő számítógépen futtatja, a hatékonyság növelése érdekében használjon lemezes gyorsítótárazást. Egyébként a telepítés folyamata (a Winnt.exe programmal indítva) sok időt venne igénybe. Windows 3.x rendszerrel működő számítógépeken a lemezes gyorsítótárazást általában a SMARTDrive használatával lehet engedélyezni. A SMARTDrive használatával kapcsolatos tudnivalók a Windows 3.x dokumentációjában találhatók.
  • A telepítés több lépésben megy végbe: információ bekérése, fájlok másolása és újraindítás. A rendszer kétszer vagy háromszor is újraindulhat a Telepítő indításának módjától függően. A telepítés A kiszolgáló konfigurálása képernyővel ér véget, amelynek segítségével elvégezheti az igényeinek megfelelő beállításokat.
  • A felügyelet nélküli telepítésről további információt a Kapcsolódó témakörök hivatkozásra kattintva kaphat.
  • Ha van háttértároló-vezérlője (például SCSI, RAID vagy Fibre Channel csatoló) a merevlemezhez, akkor a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a vezérlő illesztőprogramját a Telepítő program számára.
  • Ha specializált hardverrel rendelkezik, amely egyéni, a számítógépgyártó által biztosított HAL-fájlt igényel, a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a HAL-fájlt telepítés közben.

Kapcsolódó témakörök


A Telepítő indítása hálózatról

  1. Ossza meg a telepítőfájlokat a hálózati kiszolgálón: helyezze be a CD-ROM-ot és ossza meg annak meghajtóját vagy másolja egy megosztott mappába a CD-ROM I386 mappájának tartalmát.
  2. Arról a számítógépről, amelyre a Windows 2000 rendszert telepíteni kívánja, kapcsolódjon a megosztott telepítőfájlokhoz:
    • Ha megosztott CD-ROM-meghajtót használ, kapcsolódjon a meghajtóhoz és váltson az I386 mappára.
    • Ha megosztott mappát használ, csatlakozzon a megosztott mappához.
  3. Keresse meg és futtassa a megfelelő fájlt a CD–ROM I386 mappájából vagy a megosztott mappából:
    • MS–DOS vagy Windows 3.x rendszerrel működő számítógépen futassa a Winnt.exe fájlt.
    • Windows 95, Windows 98, Windows NT 3.51, Windows NT 4.0 rendszerrel vagy a Windows 2000 valamelyik verziójával működő számítógépen futtassa a Winnt32.exe fájlt.
  4. Kövesse a Telepítő utasításait.

Megjegyzések

  • A telepítés több lépésben történik: információ bekérése, fájlok másolása és újraindítás. A rendszer kétszer vagy háromszor is újraindulhat a Telepítő indításának módjától függően. A telepítés A kiszolgáló konfigurálása képernyővel ér véget, amelynek segítségével elvégezheti az igényeinek megfelelő beállításokat.
  • A felügyelet nélküli telepítésről további információt a Kapcsolódó témakörök hivatkozásra kattintva kaphat.
  • Ha van háttértároló-vezérlője (például SCSI, RAID vagy Fibre Channel csatoló) a merevlemezhez, akkor a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a vezérlő illesztőprogramját a Telepítő program számára.
  • Ha specializált hardverrel rendelkezik, amely egyéni, a számítógépgyártó által biztosított HAL-fájlt igényel, a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a HAL-fájlt telepítéskor.

Kapcsolódó témakörök


A Telepítő indítása és új telepítés végrehajtása CD-ről MS-DOS rendszert futtató számítógépen

A Telepítés indítása és új telepítés végrehajtása CD-ről MS-DOS rendszert futtató számítógépen

  1. Helyezze be a CD–t a meghajtóba.
  2. Írja be a parancssorba a következőt:

    d:

    ahol d a CDROM-meghajtó betűjele, majd nyomja meg az ENTER billentyűt.

  3. Írja be az alábbi sort:

    cd i386

    és nyomja meg az ENTER billentyűt.

  4. Írja be az alábbi sort:

    winnt

    és nyomja meg az ENTER billentyűt.

  5. Kövesse a Telepítő utasításait.

Megjegyzések

  • Ha a Telepítőt Windows 3.x vagy MS–DOS rendszerrel működő számítógépen futtatja, a hatékonyság növelése érdekében használjon lemezes gyorsítótárazást. Egyébként a telepítés folyamata (a Winnt.exe programmal indítva) sok időt venne igénybe. A Windows 3.x vagy MS–DOS rendszerrel működő számítógépeken a lemezes gyorsítótárazást általában a SMARTDrive használatával lehet engedélyezni. A SMARTDrive használatával kapcsolatos tudnivalók a Windows 3.x vagy az MS–DOS dokumentációjában találhatók.
  • A telepítés több lépésben történik: információ bekérése, fájlok másolása és újraindítás. A rendszer kétszer vagy háromszor is újraindulhat a Telepítő indításának módjától függően. A telepítés A kiszolgáló konfigurálása képernyővel ér véget, amelynek segítségével elvégezheti az igényeinek megfelelő beállításokat.
  • További információt a felügyelet nélküli telepítésről a Kapcsolódó témakörök hivatkozásra kattintva kaphat.
  • Ha van háttértároló-vezérlője (például SCSI, RAID vagy Fibre Channel csatoló) a merevlemezhez, akkor a Kapcsolódó témakörök hivatkozásra kattintva információt kaphat arról, hogy milyen módon teheti elérhetővé a vezérlő illesztőprogramját a Telepítő program számára.
  • Ha specializált hardverrel rendelkezik, amely egyéni, a számítógépgyártó által biztosított HAL-fájlt igényel, a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a HAL-fájlt telepítéskor.

Kapcsolódó témakörök


A Telepítő indítása és új telepítés végrehajtása a számítógép CD-ről történő indításával

  1. Állapítsa meg, hogy azt a számítógépet, amelyen el akarja indítani a Telepítőt, el lehet-e indítani CD-ROM-ról és hogy új telepítést (nem frissítést) kell-e végrehajtani. Csak akkor folytassa az alábbiak szerint, ha mindkettő igaz.
  2. Helyezze be a CD–ROM-ot a kikapcsolt számítógép meghajtójába.
  3. Indítsa el a számítógépet, majd várjon a Telepítő párbeszédpanelének megjelenéséig.
  4. Kövesse a Telepítő utasításait.

Megjegyzések

  • Ez a módszer csak új telepítéskor alkalmazható, frissítéskor nem. Ezzel a módszerrel a rendszert operációs rendszerrel nem rendelkező és operációs rendszerrel rendelkező számítógépre is telepítheti.
  • A telepítés több lépésből áll: információ bekérése, fájlok másolása és újraindítás. A telepítés A kiszolgáló konfigurálása képernyővel ér véget, amelynek segítségével elvégezheti az igényeinek megfelelő beállításokat.
  • A felügyelet nélküli telepítésről további információt a Kapcsolódó témakörök hivatkozásra kattintva kaphat.
  • Ha van háttértároló-vezérlője (például SCSI, RAID vagy Fibre Channel csatoló) a merevlemezhez, akkor a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a vezérlő illesztőprogramját a Telepítő program számára.
  • Ha specializált hardverrel rendelkezik, amely egyéni, a számítógépgyártó által biztosított HAL-fájlt igényel, a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a HAL-fájlt telepítés közben.

Kapcsolódó témakörök


A Telepítő indítása és új telepítés végrehajtása a számítógép hajlékonylemezről történő indításával

  1. Döntse el, hogy új telepítést vagy frissítést szeretne végezni. Csak akkor folytassa az alábbiak szerint, ha új telepítést kíván végrehajtani.
  2. Készítse elő a Windows 2000 Telepítő hajlékonylemezeket és a Windows 2000 CD–ROM-ot.
  3. A számítógép kikapcsolt állapotában helyezze be az első telepítőlemezt a számítógép A jelű meghajtójába.
  4. Kapcsolja be a számítógépet.
  5. Kövesse a Telepítő utasításait.

Megjegyzések

  • Ez a módszer csak új telepítésre alkalmazható, frissítésre nem. A módszer segítségével a rendszert olyan számítógépre is telepítheti, amely nem rendelkezik operációs rendszerrel, de operációs rendszerrel rendelkező számítógépen is használható.
  • A Telepítő több lépésben működik: várakozik a lemezek és a CD-ROM behelyezésére, információkat kér, fájlokat másol és újraindítja a számítógépet. A telepítés A kiszolgáló konfigurálása képernyővel ér véget, amelynek segítségével elvégezheti az igényeinek megfelelő beállításokat.
  • A hajlékonylemezek elkészítéséhez használja a Windows 2000 Setup CD-ROM Bootdisk mappájában található Makeboot segédprogramot. További tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.
  • A felügyelet nélküli telepítésről további információt a Kapcsolódó témakörök hivatkozásra kattintva kaphat.
  • Ha van háttértároló-vezérlője (például SCSI, RAID vagy Fibre Channel csatoló) a merevlemezhez, akkor a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a vezérlő illesztőprogramját a Telepítő program számára.
  • Ha specializált hardverrel rendelkezik, amely egyéni, a számítógépgyártó által biztosított HAL-fájlt igényel, a Kapcsolódó témakörök hivatkozásra kattintva információkat kaphat arról, hogy milyen módon teheti elérhetővé a HAL-fájlt telepítés közben.

Kapcsolódó témakörök


A Telepítő indítása és háttértároló-illesztőprogram vagy HAL-fájl megadása

  1. Állapítsa meg, hogy szükséges-e a Telepítő program számára a hardver gyártója által biztosított speciális fájl (háttértároló illesztőprogramja vagy HAL-fájl).
    • Ha van a merevlemezhez háttértároló-vezérlője (például SCSI, RAID vagy Fibre Channel csatoló), akkor győződjön meg róla, hogy a vezérlő szerepel-e a szoftverrel forgalomba hozott hardverkompatibilitási listán (HCL), amely a Windows 2000 Server CD-ROM Support mappájában található Hcl.txt néven. Ez a fájl a Microsoft webhelyen található frissített Microsoft Windows hardverkompatibilitási listával ellentétben (http://www.microsoft.com/) csak azokat az eszközöket sorolja fel, amelyek illesztőprogramjai megtalálhatók a Windows 2000 Server CD-ROM-on. Ha a vezérlője nem szerepel a CD-ROM-on található HCL listában, akkor nézze meg, hogy a gyártó biztosított-e külön illesztőprogramot a Windows 2000 rendszerhez.
    • Ha nagyon specializált a számítógépes rendszer, akkor nézze meg a hardver dokumentációjában, hogy a számítógép gyártója biztosított-e egyéni HAL-fájlt.
  2. Ha megállapította, hogy szükség van a hardver gyártójától származó illesztőprogramra vagy HAL-fájlra, akkor a telepítés megkezdése előtt készítse elő a fájlt tartalmazó hajlékonylemezt.
  3. A telepítés elején a képernyő alján figyelmeztetés jelenik meg, melyben a számítógép az F6 billentyű megnyomását kéri. Nyomja meg a megfelelő billentyűt a következők alapján:
    • Ha egy háttértároló illesztőprogramját akarja megadni a Telepítő számára, akkor az utasítás szerint nyomja meg az F6 billentyűt.
    • Ha egy HAL-fájlt akar megadni a Telepítő számára, akkor nyomja meg az F5 billentyűt.
  4. A további utasítások követésével adja meg a Telepítő programnak az illesztőprogramot, amelynek segítségével az hozzáfér a háttértároló vezérlőjéhez.

Megjegyzés

  • Ha nem biztos benne, hogy a rendszer támogatja a háttértároló vezérlőjét, megpróbálkozhat a Telepítő futtatásával. Ha a rendszer nem támogatja a vezérlőt, hibaüzenet fogja jelezni, hogy a rendszerindító eszköz nem elérhető.

Kapcsolódó témakörök


A kiszolgálói beállítások megadása új telepítéskor

  • Területi beállítások, név és licencelési mód meghatározása
  • A számítógépnév megadása
  • A Rendszergazda fiók jelszavának beállítása
  • A Windows 2000 Server összetevőinek kiválasztása a telepítés során
  • A dátum és az idő beállítása
  • IP-cím hozzárendelésnek vagy kérésének engedélyezése a Windows 2000 Telepítő számára
  • A DNS és a WINS számára szükséges statikus helyi IP-cím és beállítások megadása
  • Munkacsoport vagy tartománynév megadása

Megjegyzések

  • E rész témakörei arról közölnek bővebb tudnivalókat, hogy miként kell megadni a kiszolgáló beállításait új telepítéskor. Ha frissíti a kiszolgálót, ezeket a témaköröket átugorhatja, mert a Telepítő az előző beállításokat használja.
  • Ha rendelkezik a merevlemezhez tartozó háttértároló-vezérlővel (például SCSI-, RAID- vagy Fibre Channel csatolóval), vagy ha a számítógéphez egyéni, a gyártó által nyújtott egyéni hardverabsztrakciós rétegre (Hardware Abstraction Layer – HAL) van szükség, olvassa el A Telepítő indítása és háttértároló-illesztőprogram vagy HAL-fájl megadása című témakört.
  • A Telepítő indítását követően a program a szükséges telepítőfájlokat a lemezre másolja. Ezalatt a Telepítő megjeleníti azokat a párbeszédpaneleket, melyek segítségével a különböző beállítások elvégezhetők. A rendszer a telepítés módjától függően kétszer vagy háromszor is újraindulhat.


Területi beállítások, név és licencelési mód meghatározása

  1. Telepítés közben a Területi beállítások párbeszédpanelen kövesse a megjelenő utasításokat, és adja meg a használandó nyelvi és területi beállításokat, valamint a kisegítő lehetőségeket. A Windows 2000 rendszert úgy is telepítheti, hogy több nyelvet és területi beállítást használjon.
  2. A szoftver testreszabása párbeszédpanelen adja meg nevét és szükség esetén vállalata nevét.
  3. A Licencelési módok párbeszédpanelen jelölje ki az ügyféllicencelési módot, mely lehet Munkaállomásonként vagy Kiszolgálónként.

Megjegyzés

  • Ha nem biztos benne, melyik módot használja, jelölje be a kiszolgálónkénti módot, mert erről egy alkalommal térítésmentesen áttérhet a munkaállomásonkénti módra. A licencelési módokkal kapcsolatos további tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.

Kapcsolódó témakörök


A számítógépnév megadása

  • Adjon meg egy számítógépnevet. A legtöbb nyelvben a név javasolt hossza 15 karakter vagy annál kevesebb. Azon nyelvek esetében, melyek karakterei nagyobb tárolóhelyet igényelnek (például a kínai, japán vagy koreai), 7 vagy annál kevesebb karakterből álló nevet ajánlatos megadni.

Megjegyzések

  • A számítógépnév megadásakor ajánlatos az Internet-szabványnak megfelelő karaktereket használni. A szabványos karakterek közé tartoznak a számjegyek 0-tól 9-ig, az ékezet nélküli kis- és nagybetűk A-tól Z-ig, valamint a kötőjel (-). Ha a hálózaton a Microsoft DNS szolgáltatást használja, sok egyéb karaktert is használhat, beleértve a Unicode karaktereket és egyéb, nem szabványos karaktereket (például az „&” jelet). A nem szabványos karakterek használata hatással lehet a hálózaton található nem Microsoft szoftverekkel való együttműködésre. A DNS szolgáltatással kapcsolatos további tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.
  • A számítógépnév maximális mérete 63 bájt lehet. Ha a név 15 bájtnál nagyobb (ez a legtöbb nyelvben 15, egyes nyelvekben 7 karakter), a Windows 2000 előtti operációs rendszerrel működő számítógépek csak a név első 15 karakterét ismerik fel. Ezenkívül a 15 bájtnál nagyobb nevek használata további beállításokat igényel. További információt a Kapcsolódó témakörök „Tartományok és fiókok elnevezése” és „Más DNS-név használatának engedélyezése a számítógép számára” című részeiben talál.
  • Ha a számítógép egy tartomány részévé válik, a számítógépnévnek különböznie kell az összes, a tartományban található számítógép nevétől. Ha a számítógép egy tartomány tagja lesz és több operációs rendszert tartalmaz, a különböző telepített operációs rendszerekhez használjon különböző számítógépneveket. Ha a számítógép neve például Windows NT Server 4.0 operációs rendszer futtatásakor FileServerNT, Windows 2000 Server operációs rendszer használata esetén egy másik nevet, mondjuk a FileServer2000-t kell használnia. Ez a követelmény az olyan számítógépekre is vonatkozik, melyek a Windows 2000 különböző telepített változatait futtatják.

Kapcsolódó témakörök


A Rendszergazda fiók jelszavának beállítása

  1. Telepítés közben a Rendszergazda jelszava mezőbe írjon be egy maximum 127 karakter hosszúságú jelszót. A legnagyobb rendszerbiztonság elérése érdekében legalább 7 karakterből álló jelszót adjon meg, melyben kis- és nagybetűk, számjegyek és egyéb karakterek (például *, ? vagy $) egyaránt szerepelnek.
  2. A Jelszó megerősítése mezőbe ismét írja be a jelszót.
  3. Folytassa a Telepítő futtatását.

Fontos

  • Biztonsági okokból ajánlatos a Rendszergazda fiókhoz erős jelszót megadni.

Megjegyzések

  • A Windows 2000 telepítőprogramja a számítógépen létrehoz egy felhasználói fiókot Rendszergazda névvel, mely rendelkezik a számítógép minden beállításának kezelésére vonatkozó felügyeleti jogokkal. A Rendszergazda fiók a számítógépet kezelő személy számára készült. Biztonsági okokból ajánlatos jelszót megadni a Rendszergazda fiókhoz. Ha a Rendszergazda jelszava mezőt üresen hagyja, a fiókra nem ad meg jelszót.
  • A Jelszó megerősítése mezőbe beírt jelszónak pontosan meg kell egyeznie a Rendszergazda jelszava mezőbe beírttal. Fordítson különös gondot a jelszó megőrzésére és védelmére.
  • A Telepítő befejeztével biztonsági intézkedésként változtassa meg a Rendszergazda fiók nevét (nem törölhető), és mindig használjon erős jelszót a fiók védelmére.


A Windows 2000 Server összetevőinek kiválasztása a telepítés során

  1. A Windows 2000 összetevői párbeszédpanelen jelölje ki a megfelelő összetevőket.
  2. Folytassa a Telepítő futtatását.

Megjegyzések

  • A TCP/IP protokollt használó hálózatokon gyakran szükséges összetevő a DHCP, a DNS és a WINS. Az összetevők kiválasztásához A Windows 2000 összetevői párbeszédpanelen jelölje be a Hálózati szolgáltatások jelölőnégyzetet, kattintson a Részletek gombra, majd jelölje ki a megfelelő összetevőket.
  • Ha a telepítés befejezése után újabb összetevőkre van szüksége, azokat később is hozzáadhatja. Ehhez a telepítés után kattintson a Start gombra, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Programok telepítése/törlése ikonra. A Programok telepítése/törlése párbeszédpanelen kattintson a Windows-összetevők hozzáadása/eltávolítása gombra.

Kapcsolódó témakörök


A dátum és az idő beállítása

  1. Telepítés közben a Dátum és idő tulajdonságai párbeszédpanelen állítsa be a dátumot, az időt és az időzónát.
  2. Amennyiben azt szeretné, hogy a rendszer automatikusan átálljon a nyári időszámításra, jelölje be az Automatikus átállás a nyári időszámításra jelölőnégyzetet.
  3. Folytassa a Telepítő futtatását.


IP-cím hozzárendelésnek vagy kérésének engedélyezése a Windows 2000 Telepítő számára

  • Telepítés közben a Hálózati beállítások párbeszédpanelen jelölje be a Tipikus beállítások választógombot.

Megjegyzések

  • Ha a Hálózati beállítások párbeszédpanelen bejelöli a Tipikus beállítások választógombot, a Windows 2000 Telepítő ellenőrzi, hogy a tartományban található-e DHCP-kiszolgáló. Amennyiben a tartományban található DHCP-kiszolgáló, ez a kiszolgáló adja meg az IP-címet. Ha a tartományban nincs DHCP-kiszolgáló, a számítógéphez a Privát IP-címek automatikus hozzárendelése (APIPA) rendel IP-címet.
  • A TCP/IP-től eltérő protokollok használatáról információt a hálózati csatoló dokumentációjában talál.

Kapcsolódó témakörök


A DNS és a WINS számára szükséges statikus helyi IP-cím és beállítások megadása

  1. Telepítéskor a Hálózati beállítások párbeszédpanelen jelölje be az Egyéni beállítások választógombot.
  2. A Hálózati összetevők párbeszédpanelen kattintson az Internet-protokoll (TCP/IP) elemre, majd kattintson a Tulajdonságok gombra.
  3. Az Internet protokoll (TCP/IP) tulajdonságai párbeszédpanelen jelölje be A következő IP-cím használata választógombot.
  4. Az IP-cím és az Alhálózati maszk mezőkbe írja be a megfelelő számokat. (Ha szükséges, töltse ki az Alapértelmezett átjáró mezőt is.)
  5. A következő DNS-kiszolgálócímek használata területen adja meg az elsődleges DNS-kiszolgáló címét. Beírhat egy másodlagos DNS-kiszolgálót is. Ha a helyi kiszolgáló az elsődleges vagy a másodlagos DNS-kiszolgáló, akkor írja be ugyanazt az IP-címet, amelyet az előző lépésben.
  6. Ha WINS-kiszolgálót fog használni, kattintson a Speciális gombra és a WINS lapon kattintson a Hozzáadás gombra, amellyel hozzáadhatja egy vagy több WINS-kiszolgáló IP-címét. Ha a helyi kiszolgáló WINS-kiszolgáló, akkor írja be az 5. lépésben megadott IP-címet.
  7. Kattintson az OK gombra minden párbeszédpanelen és folytassa a telepítést.

Megjegyzések

  • A TCP/IP-től eltérő protokollok használatával kapcsolatos információkat a hálózati csatoló dokumentációjában talál.
  • Ha nem ismeri a DHCP protokollt vagy a statikus IP-cím és az ahhoz hozzárendelt alhálózati maszk választási lehetőségeit, akkor ajánlott a Privát IP-címek automatikus hozzárendelése (APIPA) szolgáltatás használata, amely automatikusan hozzárendeli az IP-címeket. Az APIPA használata után átválthat egy DHCP protokollt használó konfigurációra. További tudnivalók az APIPA szolgáltatásról a Kapcsolódó témakörök „IP-cím hozzárendelésének vagy kérésének engedélyezése a Windows 2000 Telepítő számára” című témakörében találhatók.

Kapcsolódó témakörök


Munkacsoport- vagy tartománynév megadása

  1. Telepítéskor adja meg, hogy a kiszolgáló munkacsoportban vagy tartományban fog működni.
  2. Adja meg a munkacsoport vagy a tartomány nevét.
  3. Folytassa a telepítést.

Kapcsolódó témakörök


A kiszolgáló konfigurálása

Miután a Telepítő varázsló befejezte a Windows 2000 telepítését, a számítógép újraindul. A Telepítő ezzel végrehajtotta az alapvető telepítést. A kiszolgáló konfigurálása program (amely akkor jelenik meg a képernyőn, ha a felhasználó a számítógép rendszergazdájaként jelentkezik be a rendszerbe) megkönnyíti a további beállításokat. Itt regisztrálhatja a Windows 2000 Server operációs rendszer példányát, és konfigurálhatja a kiszolgálót.

A kiszolgáló konfigurálása program indításához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson A kiszolgáló konfigurálása parancsra. A Felügyeleti eszközök menüből egyéb konfigurációs eszközök is elérhetők.

Ikon Elemek További tudnivalók
Active Directory Active Directory

Felhasználói fiókok, tartományok, kiszolgálói szerepkörök, engedélyek és egyéb biztonsági funkciók.

 Active Directory – áttekintés
Fájlkiszolgáló Fájlkiszolgáló

Megosztott mappák és egyéb megosztott hálózati erőforrások.

 Elosztott fájlrendszer

Megosztott mappák
Nyomtatókiszolgáló Nyomtatókiszolgáló

Nyomtatók, nyomtatási várólisták és egyéb, nyomtatással kapcsolatos elemek.

 Nyomtatás
Webkiszolgáló Web- és médiakiszolgáló

Webhelyek, multimédiahelyek, FTP-helyek és egyéb funkciók. A szolgáltatások használatához telepítenie kell a Windows 2000 Server megfelelő összetevőit.

 A telepítendő összetevők kiválasztása

Internet Information Services

A Windows Media szolgáltatások használata
Hálózat Hálózat

Protokollok, távelérés, valamint útválasztás.

 Hálózat
Alkalmazáskiszolgáló Alkalmazáskiszolgáló

Komponensszolgáltatások, valamint ehhez kapcsolódó támogatás a hálózaton keresztül terjesztett alkalmazásokhoz, beleértve a Terminálszolgáltatásokat is.

 Alkalmazás- és programozási eszközök

Terminálszolgáltatások
Speciális Speciális

A Windows 2000 Resource Kit csomag támogató eszközei, valamint választható összetevők, mint például a Távtelepítés.


Fogalmak

Ez a témakör a Windows 2000 Server operációs rendszer telepítésének tervezésével kapcsolatban nyújt háttérinformációt. Annak eldöntésével kapcsolatban, hogy az adott témakör frissítés vagy új telepítés végrehajtására vonatkozik-e, további információ az alábbi két témakörben található:

  • Feladatlista: Frissítés végrehajtása
  • Feladatlista: Új telepítés végrehajtása

Az alábbi témakörök a telepítés tervezéséhez nyújtanak segítséget.

  • Lényeges tudnivalókat tartalmazó fájlok
  • A licencelési mód megválasztása
  • A telepítendő összetevők kiválasztása
  • Felügyelet nélküli telepítés megtervezése
  • Rendszerkövetelmények és hardverkompatibilitás
  • Frissítés vagy telepítés
  • Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre?
  • A fájlrendszer megválasztása
  • Lemezpartíciók tervezése új telepítés esetén
  • Hálózat: TCP/IP, IP-címek és névhozzárendelés
  • Mikor érdemesebb munkacsoportot, mikor tartományt választani?
  • A rendszer előkészítése a Telepítő futtatása előtt


Lényeges tudnivalókat tartalmazó fájlok

A Telepítő futtatását megelőző tervezés folyamán ismerkedjen meg a Windows 2000 Server CD-ROM gyökérkönyvtárában található néhány fontos fájllal:

  • Fontos.txt. Ez a fájl a telepítés előtti tudnivalókkal kapcsolatos jegyzeteket tartalmaz, melyek létfontosságúak a sikeres telepítéshez.
  • Olvassel.doc. Ez a fájl a hardver, a hálózat, az alkalmazások és a nyomtatás használatával kapcsolatos lényeges tudnivalókat tartalmazza.

Ezek mellett érdemes áttekinteni a Windows 2000 Server rendszerhez kibocsátott hardverkompatibilitási listát. További információ a Hardverkompatibilitás című témakörben található.

A Microsoft Windows 2000 rendszerrel kompatibilis és bevizsgált alkalmazások legfrissebb listáját a Directory of Windows 2000 Applications webhelyen találja meg (http://www.microsoft.com/). A jelenlegi, valamint a külön a Windows 2000 rendszerhez tervezett alkalmazásokkal kapcsolatban ezen a helyen talál információt.

A Bevezetés témaköreiben olvasható legtöbb információ a Windows 2000 Server CD-ROM Setuptxt mappájában is megtalálható az Srv*.txt nevű szövegfájlokban.


A licencelési mód megválasztása

A Windows 2000 Server operációs rendszer két licencelési módot támogat: a Munkaállomásonkénti és a Kiszolgálónkénti módot. Ha a Munkaállomásonkénti licencelési módot választja, minden egyes, Windows 2000 kiszolgálóhoz hozzáférő számítógépnek külön ügyféllicencre van szüksége. Az adott ügyfélszámítógép egyetlen ügyféllicenccel meghatározatlan számú Windows 2000 kiszolgálóhoz tud csatlakozni. Ez a leggyakrabban használt licencelési mód az olyan vállalatoknál, ahol egynél több Windows 2000 kiszolgáló üzemel.

Ezzel ellentétben a Kiszolgálónkénti licencelési mód azt jelenti, hogy a kiszolgálóhoz egyidejűleg beérkező minden egyes csatlakozásnak külön ügyféllicenccel kell rendelkeznie. Más szóval a Windows 2000 kiszolgáló bármelyik pillanatban csupán egy meghatározott számú kapcsolat létrejöttét támogatja. Ha például a Kiszolgálónkénti licencelési mód használata és öt egyidejű kapcsolat támogatása mellett dönt, akkor a Windows 2000 kiszolgálóhoz egyszerre öt számítógépet (ügyfelet) lehet csatlakoztatni. A csatlakoztatott számítógépeknek további licencre nincs szükségük.

A Kiszolgálónkénti licencelési mód általában a kisebb vállalatoknak felel meg, ahol egyetlen Windows 2000 kiszolgáló üzemel. Ez a mód azoknál az Internet- vagy távélérést biztosító számítógépeknél is hasznos, ahol az ügyfélszámítógépek nem rendelkeznek Windows 2000 hálózati ügyféllicenccel. Meghatározhatja a kiszolgálón egy időben létrejövő csatlakozások számát, a további bejelentkezési kísérleteket a rendszer pedig visszautasítja.

Ha nem biztos benne, melyik módot szeretné használni, válassza a Kiszolgálónkénti módot, mert erről egy alkalommal térítésmentesen áttérhet a Munkaállomásonkénti licencelési módra. (Ha viszont a Terminálszolgáltatásokat alkalmazáskiszolgálóként szeretné használni, olvassa el az alábbi bekezdést.)

Ha a Terminálszolgáltatásokat alkalmazáskiszolgálóként (tehát nem csak távfelügyelet céljából) szeretné használni, a Munkaállomásonkénti licencelési mód a megfelelő, ha viszont a Terminálszolgáltatások Internetes csatlakozás licencét is használja, akkor mindig a Kiszolgálónkénti licencelési mód a megfelelő. Emellett ha használni szeretné a Terminálszolgáltatásokat, a következő összetevőket is telepítenie kell: a Terminálszolgáltatásokat és (alkalmazáskiszolgáló esetében) a Terminálszolgáltatások licencelését. Az említett összetevőkkel kapcsolatban további információ A telepítendő összetevők kiválasztása című témakörben található.


A telepítendő összetevők kiválasztása

A Windows 2000 Server számos alapösszetevőt tartalmaz, többek között a Telepítő által automatikusan telepített felügyeleti eszközöket. Emellett számtalan, a Windows 2000 Server lehetőségeit bővítő, nem kötelezően telepítendő összetevő közül választhat. Ezen összetevők telepíthetők a telepítés során, de később is hozzáadhatók (a Vezérlőpulton lévő Programok telepítése/törlése párbeszédpanel segítségével). Minél több ilyen összetevőt telepít, annál sokoldalúbbá teszi a kiszolgálót. Mindazonáltal csak azokat az összetevőket telepítse, amelyekre szüksége van, hiszen minden összetevő további lemezterületet foglal. Az alábbi táblázat és az azt követő felsorolás a szükséges összetevők kiválasztásához nyújt segítséget.

Kiszolgálói funkciók, valamint a kapcsolódó szoftverösszetevők

Kiszolgálói funkció | Lehetséges összetevők
DHCP-, DNS- és/vagy WINS-kiszolgáló (TCP/IP-hálózatban) | Dynamic Host Configuration protokoll (DHCP), Tartománynévrendszer (DNS) és/vagy Windows Internet Name Service (WINS), mindegyik a Hálózati szolgáltatások összetevője
Hálózatok központi felügyelete | Kezelő- és figyelőeszközök Távtelepítési szolgáltatás Terminálszolgáltatások (távfelügyeleti mód)
Hitelesítés és biztonságos kommunikáció | Internetes hitelesítési szolgáltatás (a Hálózati szolgáltatások része) Bizonyítványszolgáltatások
Fájlhozzáférés | Indexelő szolgáltatás Távtároló Egyéb hálózati fájl- és nyomtatószolgáltatások (támogatás Macintosh és UNIX operációs rendszerekhez)
Nyomtatóelérés | Egyéb hálózati fájl- és nyomtatószolgáltatások (támogatás Macintosh és UNIX operációs rendszerekhez)
Terminálszolgáltatások | Terminálszolgáltatások (alkalmazáskiszolgálói mód); Terminálszolgáltatások licencelése
Alkalmazás támogatása | Message Queuing QoS belépésvezérlés (a Hálózati szolgáltatások része)
Internetes (Web) infrastruktúra | Internet Information Services Site Server ILS szolgáltatása (a Hálózati szolgáltatások része)
Telefonos hozzáférés támogatása | Csatlakozáskezelő felügyeleti csomag és a Csatlakozási pont szolgáltatás (a Kezelő- és figyelőeszközök része) Megjegyzendő, hogy az Útválasztás és távelérés szolgáltatás a Windows 2000 alapeleme, ezért összetevőként való telepítésére nincs szükség.
Multimédiás kommunikáció | Windows Media szolgáltatások
Támogatás különböző ügyfél-operációsrendszerekhez | Egyéb hálózati fájl- és nyomtatószolgáltatások (támogatás Macintosh és UNIX operációs rendszerekhez) Lásd még a táblázat korábbi, „Hálózatok központi felügyelete” című részét.

A következő felsorolásban a fenti táblázatban szereplők mellett a többi telepíthető összetevő leírása is megtalálható.

Kellékek és segédprogramok
Ezek olyan asztali kellékek, mint a Wordpad, a Paint, a Számológép, a CD-lejátszó, valamint játékok, mint a Pasziánsz. Az egyes elemek kiválasztásához kattintson a Részletek gombra, és válasszon a listából.
Bizonyítványszolgáltatások
Biztonsági és hitelesítési támogatást nyújt, beleértve a biztonságos elektronikus levelezést, a web alapú, valamint az intelligens kártyás hitelesítést. A telefonos felhasználók hitelesítésével kapcsolatban a jelen felsorolás Hálózati szolgáltatások pontjában kaphat bővebb információt.
Indexelő szolgáltatás
A lemezen tárolt dokumentumok indexeléséhez kínál lehetőségeket, lehetővé téve, hogy a felhasználók adott dokumentumok szövegrészeire vagy -tulajdonságaira keressenek rá.
Internet Information Services (IIS)
Webhelyek létrehozásához, konfigurálásához és kezeléséhez nyújt támogatást a Network News Transfer protokollal (NNTP), a File Transfer protokollal (FTP) és a Simple Mail Transfer protokollal (SMTP) együtt.
Kezelő- és figyelőeszközök
A kommunikáció felügyeletéhez, figyeléséhez és kezeléséhez kínál eszközöket; ide tartoznak a távoli felhasználók egyéni ügyféltárcsázóinak fejlesztését és a központi kiszolgálóról automatikusan frissíthető telefonkönyvek létrehozását támogató programok. Tartalmazza továbbá a Simple Network Management protokollt (SNMP).
Message Queuing
Elosztott üzenetkezelő alkalmazások létrehozására szolgáló fejlesztői eszközt és kommunikációs infrastruktúrát biztosít. Az ilyen alkalmazások egymástól különböző hálózatokon is képesek kommunikálni akár olyan számítógépekkel is, melyek kapcsolat nélküli állapotban vannak. A Message Queuing garantálja az üzenetek kézbesítését, valamint hatékony útválasztást, adatvédelmet, tranzakciós támogatást és prioritás alapú üzenetküldést biztosít.
Hálózati szolgáltatások
Fontos hálózati támogatást nyújt, beleértve a következő felsorolásban szereplőket. A hálózat figyelésével kapcsolatban a jelen felsorolás „Kezelő- és figyelőeszközök” pontjában tájékozódhat. Az IP-címekről és a névhozzárendelésről háttérinformáció a fejezet Hálózatkezelés: TCP/IP, IP-címek és névhozzárendelés című részében található.
  • COM Internet-szolgáltatások proxyja. Az Internet Information Services szolgáltatáson keresztül történő kommunikációhoz HTTP protokollt használó elosztott alkalmazásokhoz nyújt támogatást.
  • Tartománynévrendszer (DNS). A Windows 2000 rendszert futtató ügyfelek számára névhozzárendelést biztosít. Ezzel a felhasználók a kiszolgálókhoz a nehezen felismerhető és megjegyezhető IP-címek helyett nevük alapján férhetnek hozzá.
  • Dynamic Host Configuration protokoll (DHCP). Lehetővé teszi, hogy a kiszolgálók dinamikusan rendeljenek IP-címeket a hálózati eszközökhöz. Ezek az eszközök általában kiszolgálók és munkaállomások, de lehetnek például nyomtatók vagy lapolvasók is. A DHCP segítségével nem kell válik statikus IP-címeket beállítani ezen eszközökhöz, illetve e címeket karbantartani, kivéve, ha DHCP, DNS és/vagy WINS szolgáltatásokat nyújtó intranetes kiszolgálókról van szó.
  • Internetes hitelesítési szolgáltatás (IAS). Telefonos és virtuális magánhálózati (VPN) felhasználók hitelesítését, engedélyezését és számlázását végzi. Az IAS támogatja a RADIUS-protokollt.
  • QoS belépésvezérlés. Lehetővé teszi az egyes alkalmazások számára kiosztott hálózati sávszélesség szabályzását. A fontos alkalmazások nagyobb sávszélességet, a kevésbé fontos alkalmazások kisebb sávszélességet kaphatnak.
  • Egyszerű TCP/IP-szolgáltatások. A következő TCP/IP-szolgáltatásokat támogatja: Character Generator, Daytime, Discard, Echo, Quote of the Day.
  • Site Server ILS szolgáltatása. Támogatja az IP alapú telefonos alkalmazásokat. Közzéteszi a hálózaton a csoportos IP-címes küldésű konferenciákat, valamint a H.323 szabványú IP alapú telefonálásban használt felhasználói IP-címhozzárendeléseket. A telefonos alkalmazások (például a Windows Kellékekben lévő NetMeeting és Tárcsázó) a Site Server ILS szolgáltatása segítségével jeleníti meg a közzétett címmel rendelkező felhasználóneveket és konferenciákat. A Site Server ILS szolgáltatása az Internet Information Services (IIS) szolgáltatásra támaszkodik.
  • Windows Internet Name Service (WINS). Windows NT vagy a Microsoft által korábban készített operációs rendszert futtató ügyfelek számára nyújt névhozzárendelést. Ezzel a felhasználók a kiszolgálókhoz a nehezen felismerhető és megjegyezhető IP-címek helyett nevük alapján férhetnek hozzá.
Egyéb hálózati fájl- és nyomtatószolgáltatások
Macintosh operációs rendszerhez fájl- és nyomtatószolgáltatásokat, UNIX rendszerhez nyomtatószolgáltatásokat biztosít.
Távtelepítési szolgáltatás
Olyan szolgáltatásokat nyújt, melyek segítségével új ügyfélszámítógépeket konfigurálhat távolról anélkül, hogy azokat ténylegesen a helyszínen konfigurálná. A célügyfélnek vagy támogatnia kell a Pre-Boot eXecution Environment (PXE) ROM memóriával történő távoli rendszerindítást, vagy távoli rendszerindító lemezről kell elindítani az ügyfelet. A kiszolgálón a távtelepítési szolgáltatáshoz külön partícióra van szükség. További információ a Lemezpartíciók tervezése új telepítés esetén című témakörben található.
Távtároló szolgáltatás
Kiterjeszti a lemezterületet azáltal, hogy elérhetőbbé teszi a cserélhető adathordozókat, például a szalagos egységeket. A ritkán használt adatok automatikusan szalagra vihetők át, ahonnan szükség esetén visszanyerhetők.
Szkripthibakereső
A szkriptfejlesztéshez nyújt támogatást.
Terminálszolgáltatások
Két módja van: a távfelügyeleti mód és az alkalmazáskiszolgálói mód.

Alkalmazáskiszolgálói módban a Terminálszolgáltatások lehetővé teszik ügyfélalkalmazások futtatását a kiszolgálón, miközben a „sovány ügyfél” szoftver az ügyfélen terminálemulátorként működik. Mindegyik felhasználó egy Windows 2000 asztalként megjelenített külön munkamenetet lát, az egyes munkameneteket a kiszolgáló a többi ügyfél munkamenetétől függetlenül kezeli. Ha a Terminálszolgáltatásokat alkalmazáskiszolgálóként telepíti, a Terminálszolgáltatások licencelését is telepítenie kell (noha nem feltétlenül ugyanarra a számítógépre). A terminálkiszolgálók használatát lehetővé tevő ügyfeleknek ideiglenes licenc azonban legfeljebb 90 napra adható.

Távfelügyeleti módban a Terminálszolgáltatások használatával a Windows 2000 rendszerre bejelentkezhet távolról, és azt gyakorlatilag a hálózat bármely pontjáról kezelheti (ahelyett, hogy helyileg a kiszolgálón kellene dolgoznia). A távfelügyeleti mód két egyidejű kapcsolatot tesz lehetővé az adott kiszolgálóval, és egyúttal minimalizálja a kiszolgáló teljesítményére gyakorolt hatást. A távfelügyeleti módhoz nem szükséges telepíteni a Terminálszolgáltatások licencelését.

Terminálszolgáltatások licencelése
Licencelési szolgáltatást nyújt, mely lehetővé teszi licencek letöltését, kibocsátását és nyomon követését a Terminálszolgáltatások ügyfelei számára. Ha a Terminálszolgáltatásokat alkalmazás módban (nem távfelügyeleti módban) telepíti, a Terminálszolgáltatások licencelését is telepítenie kell (noha nem feltétlenül ugyanarra a számítógépre). A terminálkiszolgálók használatát lehetővé tevő ügyfeleknek ideiglenes licenc azonban legfeljebb 90 napra adható.

Ha egy licenckiszolgálót gyorsan szeretne regisztrálni, telepítse azt Internet-eléréssel rendelkező számítógépre.

A Terminálszolgáltatások licencelésének telepítésekor két licenckiszolgáló-típus közül választhat, melyek a következők: tartományi licenckiszolgáló (alapértelmezés szerint) vagy vállalati licenckiszolgáló. A tartományi licenckiszolgáló csak a vele egy tartományban lévő terminálkiszolgálókat támogatja. Akkor kell a tartományi licenckiszolgáló mellett döntenie, ha a licenckiszolgáló munkacsoportban vagy Windows NT 4.0 tartományban van. A tartomány típusától függetlenül akkor is dönthet tartományi licenckiszolgáló mellett, ha az egyes tartományokhoz külön licenckiszolgálót kíván fenntartani. Windows 2000 tartományokban a tartományi licenckiszolgálót tartományvezérlőre kell telepíteni. Munkacsoportokban vagy Windows NT 4.0 tartományokban a tartományi licenckiszolgáló bármely kiszolgálóra telepíthető.

Licenckiszolgáló vállalati licenckiszolgálóként is telepíthető. A vállalati licenckiszolgáló Windows 2000 tartományokban és vegyes tartományokban lévő terminálkiszolgálókat egyaránt támogat. (Vegyes tartomány az, amelyben egyes tartományvezérlők Windows 2000, míg mások Windows NT 4.0 rendszert futtatnak). Vállalati licenckiszolgáló mellett kell döntenie, ha azt szeretné, hogy a licenckiszolgáló több Windows 2000 tartományban lévő terminálkiszolgálókat támogasson.

Windows Media szolgáltatások
Multimédiás támogatást nyújt, mely lehetővé teszi Advanced Streaming Format formátumban lévő tartalmak továbbítását intraneten vagy az Interneten keresztül.


Felügyelet nélküli telepítés megtervezése

Ebben a részben a felügyelet nélküli telepítés általános ismertetését találja. Részletes információt a felügyelet nélküli (más néven automatizált) telepítésről a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című részében talál. A Resource Kit csomag leírását a Windows 2000 Resource Kit című témakörben találja.

A felügyelet nélküli telepítés segítségével leegyszerűsíthető a Windows 2000 telepítése több számítógépre. Ehhez készítsen egy válaszfájlt, egy olyan egyéni parancsfájlt, amely automatikusan megválaszolja a Telepítő kérdéseit. Ezután futtassa a Telepítőt a parancssorból a felügyelet nélküli telepítéshez szükséges kapcsolók használatával.

A felügyelet nélküli telepítés ugyanazzal a paranccsal indítható, mint az interaktív telepítés:

  • Felügyelet nélküli telepítés indításához MS-DOS vagy Windows 3.x rendszerrel működő számítógépen futtassa a Winnt.exe fájlt (a megfelelő kapcsolókkal).
  • Felügyelet nélküli telepítés indításához Windows NT 4.0, Windows 95 vagy Windows 98 rendszerrel működő számítógépen futtassa a Winnt32.exe fájlt (a megfelelő kapcsolókkal).

Ha többet szeretne megtudni a felügyelet nélküli telepítésről, az alábbi források állnak rendelkezésre:

  • Részletes információt a felügyelet nélküli (más néven automatizált) telepítésről a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című részében talál. A Resource Kit csomag leírását a Windows 2000 Resource Kit című témakörben találja.
  • A Winnt.exe fájl lehetséges kapcsolóinak megtekintéséhez helyezze be a Windows 2000 Telepítő CD–ROM-ot egy Windows 3.x vagy MS-DOS rendszerrel működő számítógép CD–ROM-meghajtójába, és jelenítse meg a parancssort. Ezután váltson a CD–ROM-meghajtóra, majd az I386 könyvtárra, és írja be a következőt:
    winnt /?
  • A Winnt32.exe fájl lehetséges kapcsolóinak megtekintéséhez helyezze be a Windows 2000 Telepítő CD–ROM-ot egy Windows 95, Windows 98 vagy Windows NT rendszerrel működő számítógép CD–ROM-meghajtójába, és jelenítse meg a parancssort (kattintson a Start gombra, majd a Futtatás parancsra, és írja be a cmd parancsot). Ezután váltson a CD–ROM-meghajtóra, majd az I386 könyvtárra, és írja be a következőt:
    winnt32 /?

A Winnt.exe vagy a Winnt32.exe parancsok interaktív (nem felügyelet nélküli) telepítéskor való használatáról további információkat a következő témakörben talál: A Telepítő indítása.


Rendszerkövetelmények és hardverkompatibilitás

  • Rendszerkövetelmények
  • A hardver – áttekintés
  • Hardverkompatibilitás
  • Választható eszközleltár készítése
  • A háttértároló illesztőprogramjai és a telepítési folyamat
  • Az ACPI BIOS ismertetése


Rendszerkövetelmények

A megfelelő teljesítmény biztosítása érdekében győződjön meg arról, hogy azok a számítógépek, melyekre a Windows 2000 Server rendszert telepíteni kívánja, megfelelnek-e az alábbi követelményeknek:

  • 133 MHz-es vagy gyorsabb Pentium processzor.

    Számítógépenként legfeljebb négy processzor támogatott.

  • Minimálisan javasolt: 256 MB RAM (legalább 128 MB; maximum 4 GB).
  • A telepítéshez elegendő méretű szabad helyet biztosító merevlemez-partíció. A minimális helyigény körülbelül 1 GB. Ennél több helyre is szükség lehet az alábbiaktól függően:
    • A telepítendő összetevők: minél több összetevőt telepít, annál több szabad hely szükséges.
    • A használt fájlrendszer: a FAT fájlrendszer 100-200 MB-tal több szabad helyet igényel, mint más fájlrendszerek.
    • A telepítés módja: ha a telepítés hálózaton keresztül történik, 100-200 MB-tal több helyre lesz szüksége, mintha a telepítést CD-ROM-ról végezné el. (Hálózati telepítés során több elérhető illesztőprogramra van szükség.)
    • A lapozófájl mérete.

    Ezenkívül előfordulhat, hogy a frissítés sokkal több szabad helyet igényel, mint az új telepítés, mivel az Active Directory funkcióinak hozzáadásával a felhasználói fiókok meglévő adatbázisa akár tízszeresére is növekedhet.

    Megjegyzés

    • A telepítéshez az előbbi bekezdésekben leírt mennyiségű szabad lemezterület szükséges. Amikor a telepítés befejeződött, a (felhasználói fiókok nélküli) operációs rendszerhez – a telepített rendszerösszetevőktől függően – általában kisebb merevlemez-terület szükséges, mint a telepítéshez.

    További tudnivalók a lemezpartíciók méretének tervezéséről és külön partíció létrehozásáról a Távtelepítési szolgáltatás számára a Figyelembe veendő szempontok a lemezpartíciók tervezésekor című témakörben találhatók.

  • VGA vagy ennél nagyobb felbontású monitor.
  • Billentyűzet.
  • Egér vagy más mutatóeszköz (választható).

CD-ROM-ról történő telepítéshez:

  • CD-ROM- vagy DVD-ROM-meghajtó.
  • Nagy sűrűségű 3,5 hüvelykes lemezmeghajtó, ha a számítógépet a telepítési adathordozóról kívánja indítani, de számítógépe nem támogatja a CD-ROM-ról történő indítást. Ha a számítógépen nincs működő operációs rendszer és a CD-ROM-ról történő indítás nem támogatott, szükség van egy nagy sűrűségű 3,5 hüvelykes lemezmeghajtóra.

Hálózati telepítéshez:

  • Egy vagy több Windows 2000-kompatibilis hálózati csatoló a megfelelő kábelekkel. Nézze meg a Windows 2000 CD-ROM Support mappájában található Hcl.txt fájlban lévő hardverkompatibilitási listát. A lista frissített verziói a következő helyen találhatók:

    Microsoft webhely (http://www.microsoft.com/).

  • A Telepítő fájljaihoz való hálózati hozzáférést biztosító kiszolgáló.


Hardverkompatibilitás

A Windows 2000 Telepítő automatikusan ellenőrzi a számítógépben lévő hardvert és szoftvert, és jelenti az esetleges ütközéseket. A sikeres telepítés biztosítása érdekében azonban a telepítés megkezdése előtt ellenőrizze, hogy a számítógép hardvere kompatibilis-e a Windows 2000 Server rendszerrel.

Ehhez tekintse át a Windows 2000 hardverkompatibilitási listát (Hardware Compatibility List – HCL). Ha hardvere nem szerepel a listán, előfordulhat, hogy a telepítés nem sikerül. (Vegye figyelembe, hogy egy hardvertípus, nevezetesen a mikrocsatornás busz támogatása megszűnt.)

A Windows 2000 rendszerrel együtt kibocsátott hardverkompatibilitási lista verziójának megtekintéséhez nyissa meg a Hcl.txt fájlt, mely a Windows 2000 CD-ROM Support mappájában található.

A HCL frissített verziói a Microsoft Windows Hardverkompatibilitási listán találhatók meg (http://www.microsoft.com/).

Ellenőrizze továbbá, hogy rendelkezik-e a hardvereszközök frissített illesztőprogramjaival és a rendszer-BIOS legfrissebb verziójával. Ezek beszerzéséhez az eszközök gyártói nyújthatnak segítséget. A Speciális konfiguráció és energiagazdálkodást (ACPI) alkalmazó számítógéphez tartozó legfrissebb rendszer-BIOS fontosságáról Az ACPI BIOS ismertetése című témakörben olvashat.

Végezetül, mielőtt elkezdené a Windows 2000 Server telepítését, vegye fontolóra a számítógépben lévő hardvereszközök számbavételét. Erről bővebben a Választható eszközleltár készítése című részben olvashat.


Választható eszközleltár készítése

A csatolók és más eszközök számítógéppel való zökkenőmentes együttműködésének biztosítására tekintse meg az alábbi témaköröket:

  • Rendszerkövetelmények
  • Hardverkompatibilitás
A háttértároló-vezérlő (például SCSI, RAID vagy Fibre Channel csatoló) és a gyártó által biztosított illesztőprogram együttes használatával kapcsolatos konkrét adatok A háttértárolók illesztőprogramjai és a telepítési folyamat című témakörben találhatók.

A Windows 2000 a Plug and Play technológiát alkalmazza, melynek köszönhetően az egyes eszközöket (például a videokártyákat vagy hálózati csatolókat) az operációs rendszer automatikusan felismeri, így elkerülhetők a konfigurációs ütközések és nincs szükség az eszközök beállításainak kézzel történő megadására. Ha azonban olyan eszközei vannak, amelyek nem használják a Plug and Play technológiát, vagy ha Plug and Play eszközök nem felelnek meg teljes mértékben a szabványoknak, előfordulhat, hogy az eszközkonfigurációk ütközésének elkerülése érdekében bizonyos műveleteket kell végrehajtania. Ez a rész abban nyújt segítséget, hogy a telepítés előtt megismerhesse a számítógépben lévő eszközök konfigurációját, amennyiben erre szüksége van.

A számítógépben lévő eszközök konfigurációját úgy ismerheti meg legjobban, ha leltárt készít az eszközökről. Ha van operációs rendszer a számítógépen, segítségével megtudhatja az aktuális beállításokat, például az eszközöknél használt memóriacímeket és megszakításkéréseket (IRQ-kat). Windows NT 4.0 esetében ezeket a Vezérlőpulton tekintheti meg (a Start menüben mutasson a Settings (Beállítások) pontra, kattintson a Control Panel (Vezérlőpult) parancsra, majd kattintson duplán a Network (Hálózat) vagy a Ports (Portok) ikonra). Szükség lehet a rendszer BIOS-ában tárolt információk megtekintésére is. Ehhez a számítógép indulásakor figyelje a képernyőt, majd, amikor a rendszer erre kéri, nyomja meg a megfelelő billentyűt.

A telepítés során a Windows 2000 is automatikusan készít eszközleltárt. Saját leltár készítésével azonban megelőzheti a következő problémákat:

  • Ha két vagy több csatoló osztozik ugyanazon az IRQ-beállításon vagy memóriacímen, a Windows 2000 nem feltétlenül tudja feloldani az ütközést. A probléma megoldására két lehetőség kínálkozik.

    A Telepítő futtatása előtt eltávolíthatja a csatolók egyikét, és utána újra telepítheti. További információt a következő témakörökben talál:

    • A hardver – áttekintés
    • Általános feladatok

    A másik megoldás az, hogy a telepítés előtt módosítja az egyik csatoló IRQ-beállítását és memóriacímét, így mindegyik csatoló egyedi beállításokkal fog rendelkezni.

  • Amennyiben a csatolók nem a szabványos módon válaszolnak a Windows 2000 észlelési és számbavételi műveleteire, előfordulhat, hogy a Windows 2000 megfejthetetlen vagy pontatlan információhoz jut. Ilyen esetben lehetséges, hogy ezeket az eszközöket a Telepítő futtatása előtt el kell eltávolítani, majd azt követően újra kell telepíteni. További információt a következő témakörökben talál:
    • A hardver – áttekintés
    • Általános feladatok

A következő táblázat azokat az információkat tartalmazza, amelyeket a telepítés előtt célszerű megismerni:

Csatoló | Szükséges információ
Video | A kártya vagy a chipkészlet típusa, a videokártyák száma
Hálózat | IRQ, I/O-cím, DMA (ha az eszköz használja), a csatlakozó típusa (például BNC vagy sodrott érpár), a busz típusa
SCSI-vezérlő | Csatolómodell vagy chipkészlet, IRQ, a busz típusa
Egér | Az egér típusa, a használt port (COM1, COM2, busz vagy PS/2) vagy USB
I/O port | IRQ, I/O-cím, az egyes I/O portok által (esetleg) használt DMA
Hangkártya | IRQ, I/O-cím, DMA
Univerzális soros busz (USB) | A csatlakoztatott eszközök és hubok
PC-kártya | A csatolókártyák jellege, az általuk használt bővítőhelyek
Plug and Play | A BIOS-ban engedélyezett vagy letiltott
BIOS-beállítások | A BIOS verziója és dátuma
Külső modem | COM port csatlakozások (COM1, COM2 stb.)
Belső modem | COM port csatlakozások, nem szabványos konfigurációknál az IRQ és az I/O-cím
Speciális konfiguráció és energiagazdálkodás (ACPI), Energiagazdálkodás | Engedélyezett vagy letiltott, aktuális beállítás
PCI | A PCI-kártyák jellege és az általuk használt bővítőhelyek


A háttértároló illesztőprogramjai és a telepítési folyamat

Ha a merevlemezhez háttértároló-vezérlő áll rendelkezésére (például SCSI, RAID-, vagy Fibre Channel-csatoló), ellenőrizze, hogy a vezérlő szerepel-e a szoftverrel forgalomba hozott Hardverkompatibitási listán (HCL), azaz a Windows 2000 Server CD-ROM Support mappájában lévő Hcl.txt fájlban. Ez a fájl (ellentétben a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen (http://www.microsoft.com/) található frissített listával), csak azokat az eszközöket sorolja fel, amelyek illesztőprogramjai megtalálhatók a Windows 2000 Server CD-n. Ha a vezérlője nem szerepel a CD-ROM hardverkompatibilitási listáján, de a gyártó biztosított egy külön illesztőprogramot a Windows 2000 rendszerhez, készítse elő a programot tartalmazó lemezt a telepítés megkezdése előtt. A telepítés elején egy, a képernyő alján található sorban figyelmeztetést fog kapni az F6 billentyű megnyomására. A Telepítő ezt követően segítséget nyújt az illesztőprogram biztosításában annak érdekében, hogy a háttértároló-vezérlőhöz hozzáférjen.

Ha nem biztos abban, hogy a rendszer támogatja-e háttértároló-vezérlőt, megpróbálkozhat a Telepítő futtatásával. Ha a rendszer nem támogatja a vezérlőt, hibaüzenet jelenik meg azzal, hogy a rendszerbetöltő eszköz nem érhető el.


Az ACPI BIOS ismertetése

A számítógép alapvető bemeneti/kimeneti rendszere (BIOS-a) egy olyan szoftverkészlet, melyen keresztül az operációs rendszer (vagy a Telepítő) a hardvereszközökkel kommunikál. A speciális konfiguráció és energiagazdálkodás (ACPI) a BIOS működési módjának jelenleg érvényes szabványa. A Windows 2000 nemcsak az ACPI-kompatibilis BIOS-verziókat támogatja, hanem néhány, a régebbi speciális energiagazdálkodáson és Plug and Play technológián alapuló BIOS-verziókat is.

Egyes ACPI alapú BIOS-verziók nem felelnek meg a szabványnak. Minél frissebb egy ACPI BIOS-verzió, annál valószínűbb, hogy a szabványnak megfelel. Előfordulhat, hogy az olyan ACPI alapú BIOS, amely nem felel meg az ACPI szabványnak, nem teszi lehetővé az operációs rendszer (vagy a Telepítő) és a hardver megfelelő kommunikációját. Ha a működő kommunikáció nem támogatott, a Telepítő leáll és utasításokat jelenít meg, melyek értelmében a hardver gyártójához kell fordulni, vagy más lépéseket kell tenni a probléma megoldása érdekében. Ebben az esetben kövesse a megjelenő utasításokat.

A BIOS ACPI-kompatibilitásával kapcsolatban további részleteket tudhat meg az alábbi forrásokból:

  • Ha tudni szeretné, hogy mely ACPI alapú BIOS-verziók felelnek meg az ACPI szabványnak, olvassa el a Windows 2000 rendszerre érvényes Hardverkompatibilitási listát (HCL), melyről bővebben a Hardverkompatibilitás című témakörben olvashat. Ez a legmeghatározóbb forrás a szóban forgó információ szempontjából.
  • Ha a számítógép BIOS-verziójára kíváncsi, a telepítés előtt indítsa újra a számítógépet, és tekintse meg a képernyőn megjelenő szöveget. Jelen szempontból a „BIOS” és az „ACPI BIOS” szavakat tartalmazó szövegblokkok tartalma fontos különösen.
  • A hardverhez rendelkezésre álló BIOS-verziókkal kapcsolatban ellenőrizze a hardver dokumentációját és forduljon a gyártóhoz.
  • Amennyiben úgy gondolja, hogy BIOS-verziója nem ACPI BIOS-kompatibilis, olvassa el az Első lépések című nyomtatott kézikönyv „Rendszerhelyreállítás és hibaelhárítás” című függelékének az ACPI BIOS-szal foglalkozó részét. Ugyanezt az információt megtalálja a Windows 2000 Server CD-ROM \Setuptxt mappájában, a szövegfájlokban (.txt) is.


Frissítés vagy telepítés

Az alábbi részben található információk segítségével eldöntheti, hogy frissítést vagy telepítést kell-e végrehajtania. Ebben a részben részletes információk találhatók a frissítésről és a telepítésről. Megtalálható például a frissíthető operációs rendszerek listája is. Azt is megtudhatja, milyen lépések szükségesek egy kisméretű tartomány frissítéséhez.

  • A frissítés és a telepítés összehasonlítása
  • Tartomány frissítése


A frissítés és a telepítés összehasonlítása

Figyelem

  • A frissítendő rendszer nyelvétől eltérő nyelvű frissítés nem telepíthető. Mivel a Windows NT Server korábbi verzióinak nem volt magyar változata, a rendszerfrissítési információk csak tájékoztató jelleggel szerepelnek itt, mivel segíthetnek a Windows 2000 rendszerre való áttérés megtervezésében.

Miután elolvasta a jelen fejezet Rendszerkövetelmények és hardverkompatibilitás és Lényeges tudnivalókat tartalmazó fájlok című részeit, és mielőtt futtatná a Windows 2000 Server Telepítőjét, el kell döntenie, hogy frissítést vagy új telepítést kíván-e végrehajtani. A frissítés nem más, mint a Windows NT valamely verziójának kicserélése a Windows 2000 Server rendszerrel. A frissítéssel szemben a telepítés a korábbi operációs rendszer eltávolítását, vagy a Windows 2000 Server rendszer olyan lemezre vagy lemezpartícióra történő telepítését jelenti, amely korábban nem tartalmazott operációs rendszert.

Megjegyzés

  • Tömörített meghajtóra ne telepítsen Windows 2000 rendszert, és ne végezzen frissítést sem, kivéve, ha a meghajtó tömörítése az NTFS fájlrendszer tömörítő segédprogramjával történt. A DriveSpace vagy a DoubleSpace segédprogrammal tömörített kötetet bontsa ki, mielőtt Windows 2000 rendszert telepítene rá.

Ha eldöntötte, hogy frissítést vagy új telepítést szeretne végrehajtani, olvassa el a Feladatlista: Frissítés végrehajtása vagy a Feladatlista: Új telepítés végrehajtása című témaköröket.

A frissítés mellett történő döntésnek számos oka lehet. (Annak megállapításához, hogy operációs rendszerének verziója alkalmas-e a frissítésre, olvassa el e témakör későbbi, „Frissítés” című részét.) A rendszer beállítása egyszerűbb, egyúttal megőrződnek a meglévő felhasználók, beállítások, csoportok és engedélyek. Ezen kívül a fájlok és alkalmazások újratelepítésére sincs szükség. Azonban mint a merevlemezen végzett minden nagyszabású változtatás alkalmával, ebben az esetben is tanácsos a lemezről biztonsági másolatot készíteni a Telepítő futtatása előtt.

Ha a frissítés mellett dönt, és az alkalmazásokat az eddig megszokott módon szeretné futtatni, feltétlenül olvassa el a Fontos.txt fájlt, valamint az Olvassel.doc alkalmazásokról szóló részét (mindkettő a Windows 2000 CD-ROM gyökérkönyvtárában található). A Microsoft Windows°2000 rendszerrel kompatibilis és bevizsgált alkalmazások legfrissebb listáját a Directory of Windows 2000 Applications webhelyen találja meg a következő címen (http://www.microsoft.com/).

Arra is mód van, hogy a Windows 2000 Server telepítése után a számítógépen időnként más operációs rendszert futtasson. A számítógép ily módon történő beállítása azonban, a fájlrendszerekkel kapcsolatos problémák miatt bonyolult eljárás. További tudnivalók a Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre? című témakörben találhatók.

Frissítés

Frissítéskor a Telepítő automatikusan a frissítendő operációs rendszer mappájába telepíti a Windows 2000 Server rendszert. A Windows következő verziói frissíthetők:

  • Windows NT Server 3.51-es verzió (kivéve a Citrix szoftverrel történő telepítéseket)
  • Windows NT Server 4.0-s verzió
  • Windows NT Terminal Server 4.0-s verzió

Ha a Windows NT 4.0 Server Enterprise Edition verziójával rendelkezik, csak Windows 2000 Advanced Server rendszerre történő frissítésre van mód, Windows 2000 Server rendszerre történő frissítés nem lehetséges.

Megjegyzés

  • A Windows NT Server 3.51-esnél korábbi verzióit nem lehet közvetlenül Windows 2000 rendszerre frissíteni. Először a Windows NT Server 3.51-es vagy 4.0-s verzióra történő frissítése kell végrehajtani.

Telepítés

Ha új telepítést óhajt végrehajtani, vegye figyelembe a következőket:

  • Ha olyan lemezpartícióra kíván új telepítést végrehajtani, amely megőrzendő alkalmazásokat tartalmaz, az alkalmazásokról biztonsági másolatot kell készítenie, majd a Windows 2000 Server telepítése után újra kell azokat telepítenie.
  • Ha olyan partícióra szeretné a Windows 2000 Server új telepítését végrehajtani, amelyen korábban Windows 2000 Server volt, és a Dokumentumok mappa mentett és megőrzendő dokumentumokat tartalmaz, készítsen biztonsági másolatot az (általában a gyökérkönyvtárban lévő) Documents and Settings mappa dokumentumairól, majd a telepítés után másolja vissza azokat a Documents and Settings mappába.


Tartomány frissítése

Ez a rész a 2-5 kiszolgálóból álló tartományok frissítésének lépéseit ismerteti. Nagyobb tartományok frissítéséről a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezete ad tájékoztatást. A Resource Kit csomag leírása a Windows 2000 Resource Kit című témakörben található.

  • Meglévő Windows NT tartomány frissítése
  • A kiszolgálók frissítési sorrendjének megtervezése
  • Tartomány frissítése először a tartományvezérlők frissítésével
  • Tartomány frissítése először a tagkiszolgálók frissítésével


Meglévő Windows NT tartomány frissítése

A tartományok rendszere mind a Windows NT Server, mind a Windows 2000 Server fontos szolgáltatása. A tartomány voltaképpen fiókok és hálózati erőforrások egyetlen tartománynév alá vett és közös biztonsági határral rendelkező csoportja. Amennyiben a tartomány alapú felhasználói fiókokat vagy a Windows 2000 Server más tartományi biztonsági szolgáltatásait igénybe kívánja venni, legalább egy tartományt létre kell hoznia. (Ez a Windows NT Server esetében is érvényes volt.)

Windows 2000 rendszer használatával a tartomány szempontjából a kiszolgálók három szerepkört láthatnak el:

  • A tartományvezérlők az adott tartományhoz tartozó felhasználói fiókok és más Active Directorybeli adatok egyező másolatát tartalmazzák.
  • A tagkiszolgálók a tartományhoz tartoznak, de nem tartalmazzák az Active Directoryban tárolt adatok másolatát.
  • Az önálló kiszolgálók nem tartományhoz, hanem munkacsoporthoz tartoznak.
A tartománynak legalább egy tartományvezérlővel kell rendelkeznie. A rugalmasság biztosítása érdekében hasznos, ha egy tartomány a bejelentkezési kérelmek és a könyvtárfrissítések kezeléséhez több tartományvezérlővel is rendelkezik.

A Telepítő futtatása előtt ajánlatos megtervezni a Windows 2000 tartományban lévő kiszolgálók szerepét. Módosításokra azonban a telepítés után is van lehetőség.

A meglévő Windows NT tartomány Windows 2000 rendszerre történő frissítésével kapcsolatban számos fontos tényezőt célszerű figyelembe venni. Ezek a következők:

  • A tartományvezérlőkön NTFS fájlrendszert kell használnia. Ezen kívül a FAT vagy FAT32 fájlrendszerű partícióval rendelkező kiszolgálók számos biztonsági szolgáltatástól elesnek. A FAT vagy FAT32 fájlrendszerű partíciókon például egy megosztott mappát csak a megosztáshoz, és nem az egyes fájlokhoz beállított engedélyekkel lehet megvédeni, a partíció helyi elérése ellen pedig nincs szoftveres védelem.
  • Ha egy kiszolgáló frissítése után ugyanazokat az alkalmazásokat szeretné használni, mint korábban, feltétlenül tájékozódjon az alkalmazások kompatibilitásáról.

    Ehhez fontos forrásul szolgál a Fontos.txt, valamint az Olvassel.doc alkalmazásokról szóló része (mindkettő a Windows 2000 CD-ROM gyökérkönyvtárában található). E fájlokkal kapcsolatban további információ a Lényeges tudnivalókat tartalmazó fájlok című témakörben található.

    A Microsoft Windows 2000 rendszerrel kompatibilis és bevizsgált alkalmazások legfrissebb listáját a Directory of Windows 2000 Applications webhelyen találja meg a következő címen (http://www.microsoft.com/).

    Ezen a helyen az aktuális és a külön a Windows 2000 számára tervezett alkalmazásokra vonatkozó információt találhat.

  • A tagkiszolgálókat a tartományvezérlő frissítése előtt és után is frissítheti. Ha azonban Windows NT tartományban lévő kiszolgálókat Windows 2000 rendszerre frissít, először az elsődleges tartományvezérlőt kell frissítenie.
  • Amikor elkezdi a tartományvezérlők frissítését, a tagkiszolgálóként működő távelérési kiszolgálót, ha van ilyen, tanácsos az utolsó tartományvezérlő előtt frissíteni. További információ a Tartomány frissítése először a tartományvezérlők frissítésével című témakörben található.

A tartományban lévő kiszolgálók szerepeinek elnevezése a Windows 2000 Server rendszerben némileg eltér a Windows NT Server rendszerben megszokottól. Windows NT Server esetében a lehetséges szerepek a következők voltak: elsődleges tartományvezérlő (tartományonként legfeljebb egy), tartalék tartományvezérlő, tagkiszolgáló vagy önálló kiszolgáló. A Windows 2000 rendszerben csak egyféle tartományvezérlő van (az „elsődleges” vagy a „tartalék” jelző nélkül), amely egyesíti a tagkiszolgáló és az önálló kiszolgáló szerepkörét. Frissítéskor a Windows 2000 a következő módon osztja ki a kiszolgálói szerepköröket:

Windows NT tartománybeli szerepkör | Windows 2000 tartománybeli szerepkör
Elsődleges tartományvezérlő | Tartományvezérlő
Tartalék tartományvezérlő | Tetszés szerint tartományvezérlő vagy tagkiszolgáló
Tagkiszolgáló | Tagkiszolgáló
Önálló kiszolgáló | Önálló kiszolgáló


A kiszolgálók frissítési sorrendjének megtervezése

Amikor megtervezi a tartományban lévő kiszolgálók frissítésének sorrendjét, két némileg különböző módszert követhet: először vagy a tartományvezérlőket frissíti, vagy pedig a tagkiszolgálókat. A két módszer vegyíthető. Ha azonban a tartományvezérlőkkel kezdi a frissítést, először feltétlenül az elsődleges tartományvezérlőt kell frissítenie.

Ha először a tagkiszolgálókat frissíti (a tartományvezérlők nélkül), akkor számos szolgáltatás válik elérhetővé, de csak azok, amelyek nem igénylik az Active Directoryt. A tartományvezérlők frissítésekor az Active Directoryra épülő szolgáltatások is elérhetővé válnak.

A kiszolgálói szerepkörökről (amelyek megértésére feltétlenül szükség van a kiszolgálók frissítési sorrendjének megtervezéséhez) háttérinformációt talál a Meglévő Windows NT tartomány frissítése című témakörben. A tartományok frissítésével (beleértve az ötnél több kiszolgálót tartalmazó tartományokat is) bővebben a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezete foglalkozik. Ha további információra van szüksége a Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.

A kiszolgálók frissítésének két módszerével járó előnyöket és hátrányokat az alábbi táblázat foglalja össze:

Sorrend | Előnye: | Hátránya:
Tartományvezérlők először (kezdve az elsődleges tartományvezérlővel) | A Windows 2000 Server egyéb szolgáltatásai mellett az Active Directory szolgáltatásai is elérhetőek (ezek felsorolását lásd alább). | Az Active Directory szerkezetét a frissítéskor kell kialakítani. Kisméretű (kettőtől ötig terjedő számú kiszolgálóval rendelkező) tartományok esetében azonban ez nem jelent komoly erőfeszítést.
Tagkiszolgálók először | A tartományvezérlők frissítése és az Active Directory szerkezetének kialakítása nélkül is protokolltámogatást nyújt és egyéb szolgáltatásokat biztosít (ezek felsorolását lásd alább). | Az Active Directory részét képező szolgáltatások nem érhetők el.

Az alábbi listák bemutatják a kiszolgálók frissítésekor az egyes frissítési módszereket követően elérhető szolgáltatásokat. Részletesebb tudnivalókat a következő témakörökben találhat:

  • A Windows 2000 Server újdonságai
  • Active Directory
  • A szolgáltatások betűrendes listája

A tartományvezérlők frissítése után elérhető szolgáltatások

Amikor a tartományvezérlők frissítése megtörténik és elkezdik a hálózati kommunikációt, e kiszolgálókon keresztül a Windows 2000 Server minden szolgáltatása elérhetővé válik. Ezek közül a jelen részben az Active Directory szolgáltatásai szerepelnek, míg számos más szolgáltatást a témakör „Bármely kiszolgáló frissítése után elérhető szolgáltatások” című része ismertet. További tudnivalókat az Active Directory szolgáltatásaival kapcsolatban az Active Directory című témakörben talál.

Megjegyzés

  • A tartományvezérlők frissítése után nem csak az itt szereplő szolgáltatások érhetők el, hanem a témakör „Bármely kiszolgáló frissítése után elérhető szolgáltatások” című részében ismertetett szolgáltatások is.

Az Active Directory a következő szolgáltatásokat nyújtja:

  • A hálózati erőforrásokkal és a felhasználókkal kapcsolatos adatok egyszerűbb kezelése.
  • Csoportházirend, melynek segítségével az Active Directoryban egy megadott helyre, tartományra vagy szervezeti egységre érvényes házirendeket állíthat be.
  • Biztonsági és hitelesítési szolgáltatások, például Kerberos V5, Secure Sockets Layer (SSL) v3 és az X.509v3 bizonyítványokat használó Transport Layer Security (TLS).
  • Egységes címtár, mellyel szervezetté és egyszerűbbé teheti a felhasználók, számítógépek, alkalmazások és eszközök kezelését, valamint megkönnyítheti, hogy a felhasználók a szükséges információt megtalálják. Kihasználhatja a szinkronizálás támogatását LDAP alapú felületek segítségével és kezelheti az alkalmazások speciális egységes címtárigényeit.
  • Könyvtárak használatára képes alkalmazások és infrastruktúra, mely leegyszerűsíti az alkalmazások és más, könyvtárak használatára képes hálózati összetevők konfigurálását és kezelését.
  • Átlátható méretezhetőség, amely annak köszönhető, hogy az Active Directory tartományonként több millió objektumot képes kezelni, emellett indexelési eljárást és speciális replikációs eljárásokat alkalmaz a teljesítmény növelésére.
  • Internet szabványok alkalmazása, beleértve az LDAP protokollon keresztüli hozzáférést és a Tartománynévrendszeren (DNS) alapuló névteret.
  • Active Directory Service Interfaces (ADSI), egy sokoldalú fejlesztői környezet.
  • További szolgáltatások, melyek ismertetése az Active Directory című témakörben található.

Egyéb kiszolgálókkal kezdett frissítéskor elérhető szolgáltatások

Az itt szereplő szolgáltatások a tartományban lévő tagkiszolgálók frissítésekor válnak elérhetővé függetlenül attól, hogy a tartományvezérlők frissítésére sor került-e. A tartományvezérlők frissítésekor nem csak a következő felsorolásban, hanem az előző részben ismertetett szolgáltatások is elérhetővé válnak. Az új szolgáltatásokról részletesebb információkat a következő témakörben olvashat: A Windows 2000 Server újdonságai.

  • Kezelőeszközök:
    Microsoft Management Console
    Plug and Play
    Eszközkezelő
    Hardver hozzáadása/eltávolítása varázsló (a Vezérlőpulton)
    Univerzális soros busz támogatása
    Biztonsági másolat készítésére szolgáló új segédprogram
  • Fájlrendszer-támogatás: Az NTFS fájlrendszer legújabb verziójának bővítései tartalmazzák a lemezkvóták támogatását, alkalmasak könyvtárstruktúrák töredezettségmentesítésére és tömörített hálózati I/O-t biztosítanak.
  • Alkalmazás-szolgáltatások: Win32 Driver Model, DirectX 5.0 és Windows Script Host.
  • Nyomtatóprotokollok támogatása: Az eszköz- és protokolltámogatás segítségével több, mint 2500 nyomtató közül választhat. Egyéb nyomtatási bővítések is az új rendszer részei, például az Internet Printing protokoll támogatása, amely lehetővé teszi, hogy a felhasználó intraneten vagy az Interneten keresztül közvetlenül egy URL-címre nyomtasson.
  • Méretezhetőség és elérhetőség: Továbbfejlesztett támogatás szimmetrikus multiprocesszorokhoz.
  • Biztonság: Titkosított fájlrendszer.

További tudnivalók

További információ a tartományfrissítés folyamatáról:

  • Tartomány frissítése először a tartományvezérlők frissítésével
  • Tartomány frissítése először a tagkiszolgálók frissítésével

A tartományokról további tudnivalókat a következő témakörökben talál:

  • Részletes információk a tartományokról és a tartományokon belüli elemekről az Active Directory című témakörben találhatók.
  • Több tartomány strukturált kapcsolatban való telepítéséről információt a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezete tartalmaz. Ha további információra van szüksége a Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.


Tartomány frissítése először a tartományvezérlők frissítésével

Tartományt két általános módszerrel frissíthet: elsőként a tartományvezérlők, vagy elsőként a kiszolgálók frissítésével. Ha nem tudja eldönteni, hogy melyik módszert érdemes használnia, akkor olvassa el A kiszolgálók frissítési sorrendjének megtervezése című témakört.

Ha a Windows NT tartomány frissítését a tartományvezérlők frissítésével kezdi, a művelet a következő három fázisból áll:

  • Biztonsági másolatok készítése és más előkészületi feladatok végrehajtása azért, hogy szükség esetén a korábbi verziót helyre lehessen állítani.
  • Az elsődleges tartományvezérlő frissítése. Ezt a tartalék tartományvezérlők frissítése előtt kell elvégezni.
  • A tartományban lévő többi kiszolgáló frissítése.

Ez a rész a három fázis műveleteit ismerteti. További információ a következő oldalakon olvasható:

  • A tartományvezérlők frissítésével kapcsolatos részletesebb tudnivalók a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezetében találhatók (a Resource Kit csomag leírása a Windows 2000 Resource Kit című témakörben található).
  • További tudnivalók a Windows NT Windows 2000 Server rendszerre frissíthető verzióiról a Frissítés vagy telepítés című témakörben találhatók.

Biztonsági másolatok készítése és más előkészületi feladatok

Mint a kiszolgálók merevlemezének tartalmán végrehajtott minden nagyobb változtatás esetében, a frissítés előtt is célszerű a kiszolgálókról biztonsági másolatot készíteni. Feltétlenül tekintse át A rendszer előkészítése frissítéshez című témakört.

A meglévő hálózati integritás megőrzése érdekében érdemes fontolóra venni egy tartalék tartományvezérlő ideiglenes eltávolítását a hálózatról. Ehhez a meglévő Windows NT hálózatban válasszon egy tartalék tartományvezérlőt, győződjön meg arról, hogy megtalálható rajta a felhasználói fiókok adatbázisának aktuális másolata, majd készítsen a kiszolgálóról biztonsági másolatot. Ezután húzza ki a számítógépből a hálózati kábelt. Az elsődleges tartományvezérlő Windows 2000 rendszerre történő frissítése után (a frissítési folyamatot ezzel kell kezdeni), a leválasztott rendszer szükség esetén Windows NT elsődleges tartományvezérlővé léptethető elő. Eseménytelen frissítés során azonban nincs szükség (és lehetőség) a Windows NT tartalék tartományvezérlő elsődleges tartományvezérlővé való előléptetésére. Ehelyett érdemes folytatni a frissítést, melynek befejeztével a leválasztott kiszolgáló újra a hálózatba kapcsolható és frissíthető.

Ezenkívül minden olyan számítógép merevlemezén, amely a Windows 2000 tartomány tartományvezérlője lesz, az operációs rendszerhez szükséges területen kívül nagy mennyiségű szabad területet kell biztosítani. (Az operációs rendszer lemezszükségletével kapcsolatos tudnivalók a Rendszerkövetelmények című témakörben találhatók.) Amikor a Telepítő a felhasználói fiókok adatbázisát a Windows 2000 Server által használt formátumra frissíti, az adatbázis eredeti méretének tízszeresére is nőhet.

A kiszolgálók frissítése

A Windows NT tartományvezérlői közül először az elsődleges tartományvezérlőt kell frissíteni. A kiszolgáló frissítése közben választási lehetőség nyílik új tartomány vagy gyermektartomány, valamint új erdő vagy egy meglévő erdőn belüli új tartományfa létrehozására. A 2-5 kiszolgálóból álló tartomány (Bevezető témaköreiben tárgyalt tartományméret) frissítéséhez hozzon létre új tartományt vagy új erdőt. A több kiszolgálóból álló tartományok megtervezésével kapcsolatos tudnivalók a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezetében találhatók.

Frissítéskor három fontos elem helyét lehet megadni: a felhasználói fiókokat és egyéb Active Directory adatokat tartalmazó adatbázist, a naplófájlt és a rendszerkötet (Sysvol) mappát. Az adatbázis és a naplófájl tetszőleges típusú partíción lehet (FAT, FAT32 vagy NTFS); az adatbázis a Windows NT rendszerbeli méretének akár tízszeresére is nőhet, ezért célszerű sok helyet biztosítani a számára. (A naplófájl helyfoglalása kezdetben kicsi.) A rendszerkötetnek egy NTFS-partíción kell lennie. (Az NTFS és más fájlrendszerekkel kapcsolatos tudnivalók A fájlrendszer megválasztása című témakörben találhatók.)

Az elsődleges tartományvezérlő a Windows 2000 tartományvezérlőre történő frissítés után lefelé teljesen kompatibilis. Ez azt jelenti, hogy a tartományvezérlő Windows 2000 tartományvezérlőként jelenik meg a Windows 2000 kiszolgálóknak és ügyfeleknek, de a többi kiszolgáló és ügyfél számára emulálja a Windows NT elsődleges tartományvezérlőt.

Ha frissítette az elsődleges tartományvezérlőt és meggyőződött arról, hogy megfelelően működik, a következő lépés a tartalék tartományvezérlők frissítése. (Ha lehetséges, legjobb minél hamarabb elkezdeni a frissítéseket, hosszabb késleltetés nélkül.) Ha van olyan távelérési kiszolgálója, amelyik tagkiszolgáló, akkor célszerű azt az utolsó tartalék tartományvezérlő előtt frissíteni. A távelérési kiszolgálók a felhasználói adatok szempontjából a tartományvezérlőktől függenek, ezért nem szabad utoljára hagyni őket a tartományvezérlők frissítésekor. Más megoldásként gyengítheti az Active Directoryhoz beállított biztonsági engedélyeket annak érdekében, hogy a Windows NT rendszert futtató távelérési kiszolgáló el tudja olvasni a Windows 2000 rendszerrel működő tartományvezérlőkön lévő felhasználói attribútumokat. További tudnivalók a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezetében találhatók. (Leírása a Windows 2000 Resource Kit című témakörben található.)

Megjegyzés

  • A második tartományvezérlő frissítéskor lemásolja az elsőt (a korábbi elsődleges tartományvezérlőt). Ezért a második tartományvezérlő frissítésekor győződjön meg arról, hogy az első tartományvezérlő működik és elérhető a hálózaton. Hasonló módon, a harmadik, a negyedik és a többi Windows NT tartományvezérlő frissítésekor győződjön meg arról, hogy legalább egy Windows 2000 tartományvezérlő elérhető a hálózaton.

A tartalék tartományvezérlőket egyenként frissítse (gondoskodjon mindegyik biztonsági mentéséről a frissítés előtt). Indítson el és teszteljen minden kiszolgálót a hálózaton és győződjön meg arról, hogy az megfelelően működik, mielőtt újabb tartalék tartományvezérlőt frissít.

Amikor minden tartományvezérlőt frissített Windows 2000 tartományvezérlőre, megváltoztathatja a tartományt vegyes üzemmódú tartományról (amely tartalmazhat Windows NT tartományvezérlőket) natív üzemmódú tartományra (amely csak Windows 2000 tartományvezérlőket tartalmaz). Ez fontos döntés, mert natív üzemmódra történt váltás után nem lehet visszatérni vegyes módra.

A tartományfákkal, a vegyes móddal és a natív üzemmóddal kapcsolatos tudnivalók és a tartományokkal kapcsolatos egyéb tudnivalók az Active Directory című témakörben találhatók. Az ötnél több kiszolgálóból álló tartományok frissítésével kapcsolatos tudnivalók a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezetében találhatók.


Tartomány frissítése először a tagkiszolgálók frissítésével

Egy tartomány frissítését két általános módszerrel lehet elvégezni: elsőként a tartományvezérlők, vagy elsőként a kiszolgálók frissítésével. E módszerek előnyeiről és hátrányairól további tudnivalók A kiszolgálók frissítési sorrendjének megtervezése című témakörben találhatók.

Megjegyzés

  • Ha olyan távelérési kiszolgálóval rendelkezik, amely tagkiszolgáló, és már elkezdte a tartományvezérlők frissítését, feltétlenül olvassa el a Tartomány frissítése először a tartományvezérlők frissítésével című témakört.

Az adott kiszolgáló frissítése előtt készítsen biztonsági másolatot, és olvassa át A rendszer előkészítése frissítéshez című témakört.

Ha úgy frissít egy tartományt, hogy a frissítést a tagkiszolgálókkal kezdi, akkor választhat, hogy egyszerre egy, illetve egyszerre az összes tagkiszolgálót frissíti. A megfelelő frissítési formát attól függően válassza ki, hogy melyik kiszolgáló esetében van a legnagyobb szükség a Windows 2000 Server által biztosított szolgáltatásokra. A tagkiszolgálók frissítése után rendelkezésre álló szolgáltatásokról további tudnivalók A kiszolgálók frissítési sorrendjének megtervezése című témakörben találhatók.

Az adott tartomány tagkiszolgálóinak frissítése után a tartományvezérlők frissítéséhez kövesse a Tartomány frissítése először a tartományvezérlők frissítésével című témakör utasításait.


Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre?

  • Az egynél több operációs rendszert tartalmazó számítógépekkel kapcsolatos tudnivalók
  • Több operációs rendszer használata és a fájlrendszerek kompatibilitása
  • Windows NT 4.0-s verziójú és Windows 2000 Server rendszert tartalmazó számítógépek
  • A Windows 2000 Server mellett Windows 95 vagy Windows 98 operációs rendszert tartalmazó számítógépek
  • MS-DOS és Windows 2000 operációs rendszert tartalmazó számítógépek
  • Több Windows 2000 partíciót tartalmazó számítógépek


Az egynél több operációs rendszert tartalmazó számítógépekkel kapcsolatos tudnivalók

A számítógép konfigurálható oly módon, hogy újraindításakor minden alkalommal két vagy több operációs rendszer közül lehessen választani. Beállíthat egy kiszolgálót például úgy, hogy általában a Windows 2000 Server fusson rajta, de lehetőség legyen Windows NT 4.0-s verzió futtatására is, ha esetleg régebbi alkalmazásokat kíván használni. (Ehhez azonban megfelelő fájlrendszereket kell választani, és előfordulhat, hogy a legfrissebb Service Pack csomagra is szükség lesz – erről részletesebben a Több operációs rendszer használata és a fájlrendszerek kompatibilitása című témakörben olvashat.) Az újraindítások során ilyenkor adott ideig megjelenik egy menü, lehetővé téve a két operációs rendszer közötti választást. (Megadhat egy alapértelmezett operációs rendszert, amely akkor indul el, ha az újraindításkor a felhasználó egyik operációs rendszert sem választja.)

Megjegyzés

  • Ha úgy állít be egy számítógépet, hogy a telepített operációs rendszerek között a Windows 2000 is szerepel, a Windows 2000 rendszert a számítógép külön partíciójára kell telepítenie. Ezzel biztosíthatja, hogy a Windows 2000 ne írja felül a másik operációs rendszer által használt kulcsfontosságú fájlokat

Általános tényezők

Azért lehet szükség arra, hogy a számítógép indításakor két vagy több operációs rendszer közül is választani lehessen, mert így használni lehet olyan alkalmazásokat, amelyek csak egy adott operációs rendszerrel működnek. Vannak azonban egyértelmű hátrányai a számítógép ily módon történő konfigurálásának: minden egyes operációs rendszer értékes lemezterületet foglal, és összetett problémák jelentkezhetnek a kompatibilitás (különösen a fájlrendszer-kompatibilitás) terén. (További tudnivalókat alább, a táblázatban felsorolt témakörökben talál.) A dinamikus lemezformátum (a Windows 2000 új beállítási lehetősége) nem működik több operációs rendszerrel. A Windows 2000 az egyetlen olyan operációs rendszer, amely hozzáfér a dinamikus lemezformátumot használó merevlemezhez.

Megjegyzés

  • Ha azért szeretne több operációs rendszert telepíteni, hogy mindig el tudja indítani a számítógépet (illesztőprogram- vagy lemezhibák ellenére is), számoljon a Windows 2000 sokféle, katasztrófa utáni helyreállításra tervezett szolgáltatásával. Ezen szolgáltatások egyike a csökkentett mód, amikor is a Windows 2000 alapértelmezett beállításokkal indul, a lehető legkevesebb illesztőprogrammal (lehetővé téve az újraindítást akkor is, amikor új illesztőprogram okozza a hibát). Az ehhez hasonló szolgáltatásoknak köszönhetően nem szükséges több operációs rendszert is telepíteni a rendszerproblémák kiküszöbölése érdekében. A több operációs rendszer használatának elkerülése azt is jelenti, hogy nem kell szembenéznie a fájlrendszer-kompatibilitás jelentette problémákkal és egyéb hátrányokkal. A csökkentett módban való indítással és egyéb beállításokkal kapcsolatban további tudnivalókat talál a Katasztrófa utáni helyreállítás témakör Fogalmak című részében.

Konkrét, megfontolandó részletek

Mielőtt úgy dönt, hogy több operációs rendszert telepít egy számítógépre, tekintse át azokat a témaköröket, amelyek a saját számítógépes környezetére vonatkoznak.

A Windows 2000 rendszerrel
felváltva használható
operációs rendszerek 		Áttekintendő témakörök
Windows NT 4.0
  • Több operációs rendszer használata és a fájlrendszerek kompatibilitása
  • Windows NT 4.0-s verziójú és Windows 2000 Server rendszert tartalmazó számítógépek
Windows 95 vagy Windows 98
  • A Windows 2000 mellett Windows 95 vagy Windows 98 operációs rendszert tartalmazó számítógépek
MS-DOS
  • MS-DOS és Windows 2000 operációs rendszert tartalmazó számítógépek
Több példányban telepített Windows 2000
  • Több Windows 2000 partíciót tartalmazó számítógépek


Több operációs rendszer használata és a fájlrendszerek kompatibilitása

Több operációs rendszert tartalmazó számítógépeken a kompatibilitás kérdése igen összetetté válik, amikor a fájlrendszerek megválasztására kerül sor. A választható fájlrendszerek a következők: NTFS, FAT és FAT32. (További információ A fájlrendszer megválasztása című témakörben található.)

Általában az NTFS a javasolt fájlrendszer, mivel fontos szolgáltatásokat tesz lehetővé, beleértve az Active Directoryt és a tartomány alapú biztonságot. Az NTFS fájlrendszer esetében azonban figyelembe kell venni a fájlrendszer kompatibilitását, ha azt fontolgatja, hogy több operációs rendszert is telepít egy számítógépre, mivel a Windows 2000 Server rendszer NTFS verziója a Windows NT Server rendszeréhez képest új szolgáltatásokkal is rendelkezik. Az új szolgáltatásokat használó fájlok csak akkor lesznek teljes mértékben használhatók vagy olvashatók, ha a számítógép a Windows 2000 Server rendszerrel indul. Nem lesznek például olvashatók az olyan fájlok, amelyek az új titkosítási szolgáltatást használják, amikor a számítógép Windows NT Server 4.0-s rendszerrel indul, mivel az még a titkosítási szolgáltatás létezése előtt készült. (A Windows 2000 Server rendszernek a fájlok elérhetőségét érintő szolgáltatásairól bővebben az NTFS című témakörben olvashat.)

Megjegyzések

  • Ha egy számítógépre mind a Windows NT, mind a Windows 2000 operációs rendszert telepíteni kívánja, és szeretne NTFS-partíciót kialakítani, a Windows NT erre a célra megfelelő verziója egyedül a legutóbb kiadott Service Pack csomaggal frissített Windows NT 4.0. A legfrissebb Service Pack csomag használata biztosítja a legjobb kompatibilitást a Windows NT 4.0 és a Windows 2000 Server rendszerrel használt NTFS fájlrendszer között. (A két fájlrendszer közötti kompatibilitást konkrétan a Service Pack 4 és az azt követő Service Pack csomagok biztosítják.) Még a legfrissebb Service Pack sem biztosítja azonban az NTFS új szolgáltatásait használó fájlokhoz való hozzáférést.
  • Az NTFS fájlrendszer használata nem javasolt olyan számítógépen, amely mind a Windows 2000, mint a Windows NT rendszert tartalmazza. Ezeken a számítógépeken a Windows NT 4.0 operációs rendszert tartalmazó FAT-partíció biztosítja, hogy amikor Windows NT 4.0 rendszerrel indul, a számítógép hozzáférjen a szükséges fájlokhoz.
  • Ha úgy állítja be a számítógépet, hogy Windows NT 3.51 rendszerrel induljon egy régebbi FAT-partíción, valamint a Windows 2000 Server rendszerrel NTFS-partíción, ez utóbbi partíció nem lesz látható, amikor a számítógép Windows NT 3.51 rendszerrel indul.


Windows NT 4.0-s verziójú és Windows 2000 Server rendszert tartalmazó számítógépek

Ha úgy konfigurálja a számítógépet, hogy az Windows NT 4.0 és egyszersmind Windows 2000 operációs rendszert tartalmazzon, akkor először olvassa el az alábbiakat:

  • Ha csak az a célja, hogy mindig el tudja indítani a számítógépet, akkor nem szükséges úgy konfigurálnia, hogy különböző operációs rendszerekkel is lehessen indítani. További tudnivalók a Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre? című témakörben találhatók.
  • Az NTFS fájlrendszer használata nem javasolt olyan számítógépen, amely mind a Windows 2000, mint a Windows NT rendszert tartalmazza. További információ a Több operációs rendszer használata és a fájlrendszerek kompatibilitása című témakörben található.
  • A Windows NT 4.0-s rendszert feltétlenül frissítse a legújabb Service Pack csomaggal. További információ a Több operációs rendszer használata és a fájlrendszerek kompatibilitása című témakörben található.
  • Telepítse az egyes operációs rendszereket külön meghajtóra vagy partícióra.

    Amikor a Windows 2000 Server rendszer új telepítését hajtja végre (szemben a frissítéssel), alapértelmezés szerint a telepített példány olyan partícióra kerül, amelyen nincs másik operációs rendszer. A telepítés során megadhat másik partíciót is.

  • Tömörített meghajtóra csak akkor telepítsen Windows 2000 rendszert, ha a meghajtó tömörítése az NTFS fájlrendszer tömörítő segédprogramjával történt.
  • Ha a Windows 2000 rendszert újonnan telepíti egy meghajtóra (a frissítéssel szemben), a Telepítő futtatása után újra kell telepítenie az azon lévő korábbi programokat, például a szövegszerkesztőt vagy az elektronikus levelező szoftvert.
  • Telepítse az egyes operációs rendszerek által használt programokat az adott rendszer partíciójára. Ha azt szeretné, hogy a programok több operációs rendszerrel fussanak, a programokat minden egyes operációs rendszer partíciójára telepítenie kell.
  • Ha a számítógép Windows NT vagy Windows 2000 tartományban van, a Windows NT 4.0 Server vagy a Windows 2000 Server minden egyes telepített példányának más számítógépnevet kell adni.

A több operációs rendszert tartalmazó számítógépekkel kapcsolatos további információ a Windows 2000 Resource Kit című csomagban található. (A Resource Kit csomagról a Windows 2000 Resource Kit című témakörből tudhat meg többet.)


A Windows 2000 mellett Windows 95 vagy Windows 98 operációs rendszert tartalmazó számítógépek

Ha egy számítógépre a Windows 2000 operációs rendszer mellé Windows 95 vagy Windows 98 rendszert is telepíteni kíván, a következőket kell figyelembe vennie:

  • A DriveSpace vagy a DoubleSpace segédprogrammal tömörített kötetek nem lesznek elérhetők a Windows 2000 futtatása során. Nem szükséges e kötetek tömörítésének megszüntetése, ha csak a Windows 95 vagy Windows 98 rendszerrel fogja azokat használni.
  • Windows 95 és Windows 2000 operációs rendszert tartalmazó számítógép beállításakor utoljára a Windows 2000 rendszert telepítse. Ellenkező esetben előfordulhat, hogy a Windows 2000 indításához szükséges fontos fájlok felülíródnak. (Ha a számítógép Windows 98 és Windows 2000 operációs rendszert fog tartalmazni, akkor az operációs rendszerek telepítésének nincs előre meghatározott sorrendje.)
  • Olyan számítógépen, amely Windows 2000 és Windows 95 operációs rendszert fog tartalmazni, az elsődleges partíciót FAT fájlrendszerűre kell formázni. Olyan számítógépen, amely Windows 2000 és Windows 95 OSR2 vagy Windows 98 operációs rendszert fog tartalmazni, az elsődleges partíciót FAT vagy FAT32 és nem NTFS fájlrendszerűre kell formázni.
  • A fájlrendszer kompatibilitásával kapcsolatban problémák léphetnek fel. További információ a Több operációs rendszer használata és a fájlrendszerek kompatibilitása című témakörben található.


MS-DOS és Windows 2000 operációs rendszert tartalmazó számítógépek

Ha egy számítógépre mind MS-DOS, mind Windows 2000 operációs rendszert telepíteni kíván, a következőket kell figyelembe vennie:

  • Az elsődleges partíciót FAT fájlrendszerűre kell formázni.
  • A Windows 2000 rendszert kell utoljára telepíteni. Ellenkező esetben előfordulhat, hogy a Windows 2000 indításához szükséges fontos fájlok felülíródnak.
  • A fájlrendszer kompatibilitásával kapcsolatban problémák léphetnek fel. További információ a Több operációs rendszer használata és a fájlrendszerek kompatibilitása című témakörben található.


Több Windows 2000 partíciót tartalmazó számítógépek

Beállíthat kiszolgálót úgy is, hogy rajta több partíción több Windows 2000 legyen telepítve (Windows 2000 Professional és/vagy Server). Minden telepítéshez külön számítógépnevet kell azonban használnia, ha a számítógép Windows 2000 tartomány része. Mivel a Windows 2000 minden, tartományban történő telepítéséhez egyedi biztonsági azonosító (SID) használatos, minden telepített számítógép nevének különbözőnek kell lennie, még ha egy számítógépre is kerülnek.


A fájlrendszer megválasztása

  • Választás az NTFS, a FAT és a FAT32 között
  • NTFS
  • FAT és FAT32


Választás az NTFS, a FAT és a FAT32 között

Windows 2000 Server operációs rendszert futtató számítógép lemezpartíciói számára a következő három fájlrendszer közül választhat: NTFS, FAT vagy FAT32. Az ajánlott rendszer az NTFS. A FAT és a FAT32 két hasonló fájlrendszer azzal a különbséggel, hogy a FAT32 a nagyobb lemezek számára készült. (A nagy lemezek számára a legmegfelelőbb fájlrendszer az NTFS.) Ez a témakör a fájlrendszerek összehasonlításában nyújt segítséget. Az egyes fájlrendszerekről további információ az alábbi témakörökben található:

  • NTFS
  • FAT és FAT32

Az NTFS mindig is hatékonyabb fájlrendszer volt, mint a FAT vagy a FAT32. A Windows 2000 Server operációs rendszer az NFTS fájlrendszer új verzióját tartalmazza, amely számos szolgáltatás mellett az Active Directoryt is támogatja, amelyre a tartományok, felhasználói fiókok, valamint egyéb fontos biztonsági szolgáltatások használatánál van szükség.

A Telepítő program segítségével könnyen konvertálhatja partícióit az NTFS új verziójára, beleértve a FAT vagy FAT32 rendszerű partíciókat is. Ez a fajta konvertálás sértetlenül megőrzi a fájlokat (ellentétben a partíció formázásával). Ha FAT vagy FAT32 rendszerű partícióval rendelkezik, és nincs szüksége arra, hogy megtartsa a fájlokat, a FAT vagy FAT32 fájlrendszer konvertálása helyett a partíciót ajánlott NTFS fájlrendszerrel formázni. Partíció formázásakor a partíción lévő összes adat törlődik, de az NTFS fájlrendszerrel formázott partíció kevésbé töredezett és jobb teljesítményű lesz, mint a FAT vagy FAT32 fájlrendszerről konvertált partíció.

Az NTFS fájlrendszer használata mindenképpen előnyös, függetlenül attól, hogy a partíciót NTFS rendszerrel formázta vagy arra konvertálta. A partíciók a Convert.exe használatával a telepítés után is konvertálhatók. A Convert.exe programmal kapcsolatos további tudnivalókhoz a telepítés befejezése után kattintson a Start gombra, majd a Futtatás parancsra, írja be a cmd parancsot, végül nyomja le az ENTER billentyűt. A parancsablakba írja be a help convert parancsot, majd nyomja le az ENTER billentyűt.

Megjegyzés

  • Csak az NTFS fájlrendszer alkalmazása esetén használhat olyan fontos szolgáltatásokat, mint például az Active Directory vagy a tartomány alapú biztonság.

Egyetlen esetben érdemes a FAT vagy FAT32 fájlrendszert választani. Mégpedig akkor, ha olyan számítógéppel rendelkezik, amelyen a Windows 2000 operációs rendszert egy korábbi operációs rendszerrel fölváltva szeretné használni. Ebben az esetben a merevlemez elsődleges (vagy indítási) partíciójának FAT vagy FAT32 fájlrendszerűnek kell lennie. Az előző operációs rendszerek (egy kivétellel) a legújabb verzióval rendelkező NTFS fájlrendszerű partíciókhoz ugyanis nem férnek hozzá. Az egyetlen kivétel, amely (némi korlátozással) hozzáfér az NTFS legújabb verziójához, a Windows NT 4.0 operációs rendszer (a Service Pack 4 vagy annál újabb szervizcsomaggal frissített változata). A Windows NT 4.0 rendszer azokhoz a fájlokhoz nem fér hozzá, amelyek tárolásánál az NTFS fájlrendszer olyan szolgáltatásait is igénybe vették, amelyek a Windows NT 4.0 megjelenésekor még nem léteztek. További információt a következő témakörökben talál:

  • Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre?
  • Több operációs rendszer használata és a fájlrendszerek kompatibilitása

Azt az esetet kivéve, amikor a számítógépen több operációs rendszer található, az ajánlott fájlrendszer mindig az NTFS.

Az alábbi táblázat az egyes fájlrendszerek a különböző operációs rendszerekkel való kompatibilitását tartalmazza.

NTFS | FAT | FAT32
Windows 2000 rendszert futtató számítógép eléri az NTFS fájlrendszerű partíción található fájlokat. A Windows NT 4.0 Service Pack 4 vagy újabb szervizcsomaggal frissített operációs rendszer csupán egyes fájlokat ér el. A többi operációs rendszer nem fér hozzá az NTFS rendszerű fájlokhoz. | Az MS-DOS, a Windows összes verziója, a Windows NT, a Windows 2000, valamint az OS/2 rendszer is hozzáfér a FAT rendszerű fájlokhoz. | Csak a Windows 95 OSR2, a Windows 98, valamint a Windows 2000 operációs rendszer fér hozzá az ilyen típusú fájlokhoz.

Az alábbi táblázat az egyes fájlrendszerek lemez- és fájlméreteit veti össze.

NTFS | FAT | FAT32
Az ajánlott minimális kötetméret körülbelül 10 MB. A kötetek ajánlott tényleges maximális mérete 2 TB (terabájt). Ennél jóval nagyobb méretek is lehetségesek. Hajlékonylemezen nem használható. | A kötetek mérete a hajlékonylemez méretétől egészen 4 GB-ig terjed. Nem támogatja a tartományokat. | A kötetek mérete 512 MB és 2 TB között mozog. Windows 2000 rendszerben legfeljebb 32 GB-os FAT32 rendszerű kötetet lehet formázni. Nem támogatja a tartományokat.
A fájlméretet csupán a kötetméret korlátozza. | A maximális fájlméret 2 GB. | A maximális fájlméret 4 GB.


NTFS

Az NTFS fájlrendszer néhány szolgáltatása:

  • Active Directory, amelynek használatával könnyen megtekintheti és szabályozhatja a hálózati erőforrásokat.
  • Tartományok, amelyek az Active Directory részét képezik, és amelyeket a biztonsági beállítások finomhangolására használhat, megtartva a felügyelet egyszerűségét. A tartományvezérlők NTFS fájlrendszert igényelnek.
  • Fájlok titkosítása, amely nagymértékben fokozza a biztonságot.
  • Engedélyek, amelyek nemcsak mappákhoz, hanem egyes fájlokhoz is beállíthatók.
  • Ritka fájlok. Ezek nagyon nagy fájlok, amelyeket alkalmazások hoznak létre úgy, hogy csak korlátozott lemezterületre van szükségük. Vagyis, az NTFS fájlrendszer csak a fájl azon része számára foglal le lemezterületet, amelyre írni fog.
  • Távtároló, amely kiterjeszti a lemezterületet azzal, hogy könnyebben elérhetővé teszi a cserélhető adathordozókat, például a szalagos egységeket.
  • A lemeztevékenységek helyreállítási naplózása, amely segítséget nyújt az adatok gyors helyreállításához áramszünet, vagy más rendszerproblémák esetén.
  • Lemezkvóták, amelyek az egyes felhasználók által használt lemezterület mennyiségének figyelésére és szabályozására használhatók.
  • Nagy meghajtók jobb méretezhetősége. Az NTFS esetében a meghajtó maximális mérete sokkal nagyobb, mint a FAT esetében, és a meghajtó méretének növekedése az NTFS esetében nem jár együtt a teljesítmény csökkenésével (ami a FAT jellemzője).

Ez csak egy részleges listája az NTFS legújabb változatában található szolgáltatásoknak. Az új szolgáltatásokról további információt a következő témakörben olvashat: A Windows 2000 Server újdonságai.

A Telepítő program segítségével könnyen átalakíthatja partícióit az NTFS új változatára, beleértve a FAT vagy FAT32 rendszerű partíciókat is. Ez a fajta átalakítás sértetlenül megőrzi a fájlokat (ellentétben a partíció formázásával). A Telepítő először ellenőrzi a meglévő fájlrendszert. NTFS esetén az átalakítás automatikusan megtörténik. FAT vagy FAT32 esetén a Telepítő felajánlja a választási lehetőséget, hogy NTFS fájlrendszerre konvertáljon-e. Ha nincs szüksége arra, hogy megtartsa a fájljait és FAT vagy FAT32 partícióval rendelkezik, ajánlott a partíciót NTFS fájlrendszerrel formázni a FAT vagy FAT32 fájlrendszerről való átalakítás helyett. A partíció formázása következtében a partíción lévő összes adat törlődik, de az NTFS fájlrendszerrel formázott partíció kevésbé töredezett és jobb teljesítményű lesz, mint a FAT vagy FAT32 fájlrendszerről átalakított partíció.

Azonban még így is előnyös az NTFS használata, függetlenül attól, hogy NTFS fájlrendszerrel formázta, vagy átalakította a partíciót. A partíciók a telepítés után is átalakíthatók a Convert.exe használatával. A Convert.exe programmal kapcsolatos további tudnivalókhoz a telepítés befejezése után kattintson a Start gombra, kattintson a Futtatás parancsra, írja be a cmd parancsot, majd nyomja le az ENTER billentyűt. A parancsablakba írja be a help convert parancsot, majd nyomja le az ENTER billentyűt.


FAT és FAT32

A FAT és a FAT32 választható fájlrendszerek. Használatukra akkor van szükség, ha úgy állítja be a számítógépet, hogy időnként a korábbi operációs rendszer fusson (máskor pedig a Windows 2000). További információt az alábbi témakörökben talál:

  • Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre?
  • Több operációs rendszer használata és a fájlrendszerek kompatibilitása
  • Windows NT 4.0-s verziójú és Windows 2000 Server rendszert tartalmazó számítógépek
  • Választás az NTFS, a FAT és a FAT32 között

A FAT- és a FAT32-fájlrendszerek közötti különbségeket a Választás az NTFS, a FAT és a FAT32 között című témakörben található táblázatok tartalmazzák. A FAT és a FAT32 közötti választás legfontosabb meghatározó kérdése a telepítésre szolgáló partíció mérete. A 2 GB-os vagy nagyobb partíciókon célszerű FAT32-fájlrendszert használni FAT helyett.

Megjegyzés

  • A Windows 2000 bármekkora, Windows 95 vagy Windows 98 operációs rendszerrel létrehozott FAT32-kötetet támogat, a Windows 2000 azonban csak maximum 32 GB méretű FAT32-kötetet tud formázni. Az NTFS jobb megoldás, és a 32 GB-osnál nagyobb köteteken ezt kell használni.

    Ha telepítéskor FAT-fájlrendszerűre formáz egy olyan partíciót, amely 2 GB-nál nagyobb, a Telepítő a partíciót automatikusan FAT32 fájlrendszerűvé formázza.


Lemezpartíciók tervezése új telepítés esetén

  • A lemezpartíciók tervezésének szempontjai
  • Lehetőségek lemezpartícionáláskor


A lemezpartíciók tervezésének szempontjai

Csak akkor kell a Telepítő futtatása előtt megterveznie a lemezpartíciókat, ha új telepítést és nem frissítést hajt végre. A lemez partícionálása nem más, mint a fizikai lemezterület felosztása, melynek eredményeként minden egyes szakasz külön egységként működik. Partícionáláskor a lemezt egy vagy több területre osztja, amelyek mindegyike egy-egy fájlrendszer, például FAT vagy NTFS használatához formázható. Az elsődleges partíción, más néven rendszerpartíción az operációs rendszer (például a Windows 2000) betöltéséhez szükséges fájlok találhatók. Az elsődleges partíció adott fájlrendszerrel van formázva, és meghajtóbetűjel (például a „C”) van hozzárendelve.

Fontos

  • Ha a merevlemez egyes partícióit ki szeretné törölni, illetve újabbakat szeretne létrehozni, a lemez tartalmáról mindenképpen készítsen biztonsági másolatot, mivel ezek a műveletek minden meglévő adatot megsemmisítenek. Mint bármilyen, a lemez tartalmát érintő komolyabb módosításnál, úgy a partíciókkal való munka előtt is célszerű a merevlemez teljes tartalmáról másolatot készíteni, még akkor is, ha egy vagy több partícióhoz nem szándékozik nyúlni.

Tömörített meghajtóra csak akkor telepítsen Windows 2000 rendszert, ha a meghajtó tömörítése az NTFS fájlrendszer tömörítő segédprogramjával történt. (A DriveSpace vagy DoubleSpace segédprogrammal tömörített meghajtókat a Windows 2000 telepítése előtt bontsa ki.)

Az új telepítés végrehajtása előtt határozza meg annak a partíciónak a méretét, amelyre a Windows 2000 Server operációs rendszert szeretné telepíteni. A partíció méretének kiszámolásához nincs előre meghatározott képlet. Az alapelv az, hogy a telepítési partíción csoportosítandó operációs rendszer, alkalmazások és/vagy egyéb fájlok számára elegendő helyet kell hagyni. A Rendszerkövetelmények című témakörben leírtak szerint a Windows 2000 Server operációs rendszer működéséhez szükséges fájlok legkevesebb 1 GB szabad helyet igényelnek a lemezen. A legkevesebb szükséges szabad helynél ajánlott jóval több helyet hagyni a merevlemezen. Nem túlzás 2-4 GB szabad helyet hagyni a partíción, nagyobb telepítések esetén a 10 GB szabad lemezterület is ésszerű megoldásnak számít. Ily módon számtalan elem számára jut elegendő lemezterület, például választható összetevőknek, felhasználói fiókoknak, az Active Directory adatainak, naplóknak, további szervizcsomagoknak, az operációs rendszer által használt lapozófájlnak és más elemeknek.

A Windows 2000 Server új telepítésekor kiválaszthatja, mely partícióra szeretné telepíteni a rendszert. Ha olyan partíciót választ, amelyen már van operációs rendszer, a rendszer a választás megerősítését kéri.

A telepítés során csak azt a partíciót kell létrehozni és méretezni, amelyen a Windows 2000 telepítését szeretné végrehajtani. A Windows 2000 telepítése után a Lemezkezelés segédprogram segítségével hajthat végre változtatásokat, illetve hozhat létre új lemezeket és köteteket. Ide tartozik a nem particionált lemezterület particionálása; a meglévő partíciók átnevezése és újraformázása; merevlemezek hozzáadása és eltávolítása; valamint merevlemezek alap- vagy dinamikus formátumúra történő frissítése és visszaállítása. (Vegye figyelembe, hogy a dinamikus lemezformátum nem működik több operációs rendszert tartalmazó számítógépeken. A Windows 2000 az egyetlen olyan operációs rendszer, amely a dinamikus lemezformátumot használó merevlemezhez hozzá tud férni.

Megjegyzés

  • Ha a számítógépet több operációs rendszer használatára állítja be, a Windows 2000 rendszert saját partíciójára kell telepítenie. Ezzel biztosíthatja, hogy a Windows 2000 nem írja felül a másik operációs rendszer által használt kulcsfontosságú fájlokat. További információ a Hogyan döntheti el, hogy telepítsen-e több operációs rendszert a számítógépre? című témakörben található.

A távtelepítési szolgáltatás lemezpartíciós követelményei

Ha a kiszolgálón távtelepítési szolgáltatásokat szeretne használni (annak érdekében, hogy más számítógépekre operációs rendszereket telepítsen), a távtelepítési szolgáltatáshoz külön partícióra van szüksége. E partíción NTFS fájlrendszert alkalmazzon. Erre a távtelepítési szolgáltatás egypéldányos tároló szolgáltatása számára van szükség. Ha a távtelepítési szolgáltatáshoz új partíciót kell létrehoznia, ezt a telepítést követően végezze el, és a szolgáltatások számára hagyjon elegendő nem partícionált lemezterületet (az ajánlott mennyiség 2 GB, de a kiszolgáló használatának módjától függően kevesebb is elegendő lehet). Más megoldásként dinamikus lemezformátumot is használhat, amely az alapformátummal szemben nagyobb rugalmasságot biztosít a lemezterület használata terén. (A dinamikus lemezformátum azonban nem működik több operációs rendszert tartalmazó számítógépeken. A Windows 2000 az egyetlen olyan operációs rendszer, amely a dinamikus lemezformátumot használó merevlemezhez hozzá tud férni.

Ha a távtelepítési szolgáltatás követelményeivel kapcsolatban további információra van szüksége, tanulmányozza A távtelepítési szolgáltatás rendszerkövetelményei című témakört. Ha a lemezformátumokkal kapcsolatban további információra van szüksége, tanulmányozza a Lemezkezelés című témakört. A távtelepítési szolgáltatás áttekintését, feladatlistáit, valamint használatával kapcsolatos egyéb információkat a Távtelepítési szolgáltatás című témakörben találja.


Lehetőségek lemezpartícionáláskor

Telepítés közben csak akkor van mód a partíciók módosítására, ha új telepítést és nem frissítést hajt végre. A telepítés után a lemezpartíciókat a Lemezkezelés segédprogrammal módosíthatja.

Ha új telepítést hajt végre, a Telepítő megvizsgálja a merevlemezt, megállapítja meglévő konfigurációját, majd a következő lehetőségeket kínálja fel:

  • Ha a merevlemez még nincs partícionálva, létrehozhatja és méretezheti a Windows 2000 partíciót.
  • Ha a merevlemez partícionálva van, de elegendő nem partícionált lemezterület is található, a Windows 2000 partíciót a nem partícionált területen is létrehozhatja.
  • Ha a merevlemezen megfelelő méretű partíció található, telepítheti rá a Windows 2000 rendszert a partíció újraformázása nélkül. Egy partíció újraformázásakor a partíción lévő összes adat elvész. Ha a partíciót nem formázza újra, és a Windows 2000 rendszert egy meglévő operációs rendszerre telepíti, akkor a Telepítő ezt az operációs rendszert felülírja, és a Windows 2000 rendszerrel használni kívánt összes alkalmazást újra kell telepítenie.
  • Ha a merevlemezen már van egy partíció, akkor annak törlésével területet szabadíthat fel a lemezen a Windows 2000 partíció számára. Ha töröl egy meglévő partíciót, akkor az abban tárolt összes adatot törli a merevlemezről.


Hálózat: TCP/IP, IP-címek és névhozzárendelés

  • A hálózat és a TCP/IP áttekintése
  • IP-címek
  • TCP/IP névhozzárendelés


A hálózat és a TCP/IP áttekintése

A TCP/IP az Internet-elérést biztosító hálózati protokoll. Ez a legtöbb kiszolgáló által használt protokoll, bár használhat a kiszolgálón további, vagy más típusú hálózati csatolókat is a hozzájuk tartozó protokollokkal együtt. (A más hálózati csatolók használatával kapcsolatos tudnivalókat a hálózati csatoló dokumentációjában és a Választható eszközleltár készítése című témakörben talál.) A Telepítőt és a Kiszolgáló konfigurálása programot úgy tervezték, hogy megkönnyítse a TCP/IP és az azt támogató szolgáltatások konfigurálását.

A TCP/IP használata esetén ellenőrizze, hogy minden egyes kiszolgáló rendelkezik-e szoftver által szolgáltatott dinamikus vagy automatikus, vagy Ön által megkapott és beállított statikus IP-címmel. Mivel ezek a címek számok és így nehezen megjegyezhetők, könnyebben megjegyezhető neveket is biztosítania kell a felhasználóknak. Az ilyen neveknek az IP-címekhez rendelését névhozzárendelésnek hívják, és számos módszerrel végezhető el, elsősorban a Tartománynévrendszer (DNS) és a Windows Internet Name Service (WINS) segítségével. További tudnivalókat az IP-címek és a TCP/IP névhozzárendelés című témakörökben talál.


IP-címek

A TCP/IP használatához minden számítógépnek IP-címet kell adni – A hálózat és a TCP/IP áttekintése című témakörben leírtak szerint. Az IP-címek kiosztását a Windows 2000 elvégezheti automatikusan, de azok az (Ön által beállított) DHCP-szolgáltatáson keresztül dinamikusan, vagy (a kapott IP-cím használatával) statikusan is megadhatók.

Engedélyezheti, hogy a Windows 2000 a telepítés során automatikusan kiossza az IP-címeket, majd a telepítés után módosíthatja a beállítást oly módon, hogy a rendszer Dynamic Host Configuration protokollt (DHCP) és/vagy statikus címzést használjon. A DHCP protokollal és az IP-címzéssel kapcsolatos további információ a DHCP című témakörben található.

Az alábbi lista azokat a módszereket tartalmazza, amelyek segítségével IP-címet adhat meg:

  • Kis magánhálózatban lévő korlátozott számú (öt vagy kevesebb) kiszolgálón a Windows 2000 Server APIPA (Automatic Private IP Addressing – Privát IP-címek automatikus hozzárendelése) nevű szolgáltatása segítségével automatikusan hozzárendelheti a számítógépekhez az IP-címeket. További információ az IP-cím hozzárendelésének vagy kérésének engedélyezése a Windows 2000 Telepítő számára című témakörben található.

    A telepítés befejezése után folytathatja az automatikusan hozzárendelt címek használatát vagy beállíthat DHCP- és/vagy statikus IP-címeket. A DHCP protokollal és az IP-címzéssel kapcsolatos további információ a DHCP című témakörben található.

  • Ha a hálózaton egynél több alhálózat van, csak egy kiszolgálón telepítse és állítsa be a DHCP-összetevőt. A DHCP-kiszolgáló dinamikusan látja el a többi számítógépet IP-címmel. A DHCP-kiszolgálóhoz statikus IP-címet kell rendelni (hogy más számítógépek megtalálhassák).

    Ebben a helyzetben az ügyfelek támogatása érdekében lehet, hogy egy vagy több, Domain Name System (DNS) összetevővel és/vagy Windows Internet Name Service (WINS) összetevővel rendelkező kiszolgálóra van szükség. A DNS és WINS szolgáltatásokat a TCP/IP névhozzárendelés című témakör ismerteti. Egy vagy több kiszolgáló nyújthat DHCP, DNS és/vagy WINS szolgáltatást. Az ilyen szolgáltatást nyújtó mindegyik kiszolgálóhoz statikus IP-címet kell rendelni (hogy más számítógépek megtalálhassák).

    A statikus IP-cím telepítés közbeni megadásával kapcsolatos további információt A DNS és a WINS számára szükséges statikus helyi IP-cím megadása című témakörben talál. Arról, hogy miként lehet futtatni a Telepítőt olyan kiszolgálón, amely DHCP-kiszolgálótól fogja dinamikusa megkapni az IP-címet, az IP-cím hozzárendelésének vagy kérésének engedélyezése a Windows 2000 Telepítő számára című témakörben olvashat.

  • Ha egy adott kiszolgáló az Interneten keresztül közvetlenül biztosít hozzáférést a felhasználókhoz, akkor ehhez a kiszolgálóhoz statikus IP-címet kell rendelni. A címet és a hozzá tartozó tartománynevet az Internet-szolgáltatótól vagy az Internet Network Information Center (InterNIC) nevű szervezettől szerezheti be. Az InterNIC-ről további tudnivalókat az InterNIC webhelyen talál (http://internic.net). Ha a számítógép több hálózati csatolóval rendelkezik, mindegyik csatolóhoz külön IP-címre van szükség. A statikus IP-cím megadásával kapcsolatos további információt A DNS és a WINS számára szükséges statikus helyi IP-cím megadása című témakörben talál.

Miután a kiszolgálót ellátta IP-címmel, a következő lépésben a névhozzárendelésről gondoskodó összetevők telepítésére van szükség. A névhozzárendelés nem más mint a (felhasználók által felismerhető és megjegyezhető) számítógépnevek hozzárendelése a megfelelő IP-címekhez. További információ a TCP/IP névhozzárendelés című témakörben található.


TCP/IP névhozzárendelés

A névhozzárendelés egy olyan folyamat, amelynek során a rendszer a felhasználókat könnyen megjegyezhető kiszolgálónevekkel látja el, ahelyett, hogy a számokból álló IP-címek használatát igényelné tőlük, amelyek alapján a kiszolgálók azonosítják magukat a TCP/IP hálózaton. A névhozzárendelési szolgáltatások a DNS és a WINS.

Tartománynévrendszer (DNS)
A DNS egy hierarchikus elnevezési rendszer, amelyet számítógépeknek az Interneten és magán TCP/IP hálózatokon való megjelölésére használnak. A legtöbb telepítésben egy vagy több DNS-kiszolgálóra van szükség. A DNS szükséges az Internetes elektronikus levelezéshez, a webböngészéshez és az Active Directory használatához. Ugyancsak szükség van a DNS-re olyan tartományokban, amelyekben Windows 2000 rendszert futtató ügyfelek vannak. A DNS-t a rendszer automatikusan telepíti, amikor tartományvezérlőt hoz létre (vagy egy kiszolgálót tartományvezérlővé léptet elő), kivéve ha a Windows 2000 szoftver észleli, hogy már létezik DNS-kiszolgáló a tartományban. (Azt is megteheti, hogy közvetlenül kiválasztja a DNS-t mint a telepítés alatt, vagy után telepítendő összetevőt.)

Ha a DNS-t kiszolgálóra telepíti, meg kell adnia egy statikus IP-címet a kiszolgálón. Továbbá úgy kell beállítania a DNS-ügyfeleket, hogy felismerjék az adott IP-címet. A statikus IP-cím megadásával kapcsolatos további információt a A DNS és a WINS számára szükséges statikus helyi IP-cím megadása című témakörben talál. A DNS beállításával kapcsolatos további információ a DNS című témakörben található.
Windows Internet Name Service (WINS)
Ha támogatást nyújt Windows NT, vagy más korábbi Microsoft operációs rendszert futtató ügyfelek számára, szüksége van a Windows Internet Name Service (WINS) telepítésére a tartomány egy vagy több kiszolgálóján. A WINS választható szoftverösszetevő és a Hálózati szolgáltatások alatt található az összetevők listájában. (További információ a WINS összetevő telepítéséről a következő témakörben található:A telepítendő összetevők kiválasztása.) Ha a WINS szolgáltatást kiszolgálóra telepíti, meg kell adnia egy statikus IP-címet az adott kiszolgálón. Továbbá úgy kell konfigurálnia a WINS-ügyfeleket, hogy felismerjék az adott IP-címet.

A statikus IP-cím megadásával kapcsolatos további információt a A DNS és a WINS számára szükséges statikus helyi IP-cím megadása című témakörben talál. A WINS beállításával kapcsolatos további információ a WINS című témakörben található.


Mikor érdemesebb munkacsoportot, mikor tartományt választani?

Az ebben a részben található információ segítségével eldöntheti, hogy a kiszolgálókat munkacsoportba vagy tartományba helyezze. Olyan tudnivalókat is tartalmaz, amelyek, tartomány létrehozása esetén, segítenek a tartományban lévő kiszolgálók szerepének megtervezésében.

Ha már létező tartományt frissít, feltétlenül tekintse át a Meglévő Windows NT tartomány frissítése című témakörben található információkat. Az ötnél több kiszolgálóból álló tartományokkal kapcsolatos tudnivalók a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezetében találhatók. (Ha többet kíván megtudni a Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.)

További információt az alábbi témakörökben talál:

  • A munkacsoportok és a tartományok összehasonlítása
  • A tartományvezérlők és tagkiszolgálók megtervezése
  • A Windows 2000 tartományvezérlők különleges tulajdonságai
  • További információ a tartományokról


A munkacsoportok és a tartományok összehasonlítása

A tartomány lényegében fiókok és hálózati erőforrások egyetlen tartománynév alatt összevont és közös biztonsági határral rendelkező csoportja. A munkacsoport ennél egyszerűbb csoportosítás, melynek célja csupán annyi, hogy megkönnyítse a felhasználóknak például a csoporthoz tartozó nyomtatók és megosztott mappák megtalálását. A kevés felhasználót tartalmazó, igen kis kiterjedésű hálózatok kivételével minden hálózatban célszerű tartományokat kialakítani.

A munkacsoportokban a felhasználóknak egyszerre több jelszóra is emlékezniük kell, mivel minden hálózati erőforrás külön jelszóval rendelkezik. (Emellett a különböző felhasználók minden erőforráshoz más-más jelszót is használhatnak.) A tartományban könnyebb a jelszavak és engedélyek nyomon követése, mivel a tartományban a felhasználói fiókok, engedélyek és más hálózati adatok egyetlen, központi adatbázisban tárolódnak. Az adatbázisban tárolt információk automatikusan replikálódnak a tartományvezérlők között. Szabadon meghatározható, hogy a kiszolgálók közül melyek legyenek tartományvezérlők, és melyek csak egyszerű tagjai a tartománynak. A szerepkörökre vonatkozó döntés nem csak a telepítés közben, hanem a telepítés után is meghozható.

A tartományok és az Active Directory könyvtárrendszere (melynek részei a tartományok) számos lehetőséget nyújt arra, hogy a felhasználók könnyen hozzáférhessenek az erőforrásokhoz, miközben a megfigyelés és a biztonság színvonala változatlan marad. További tudnivalók az Active Directory című témakörben találhatók.


A tartományvezérlők és tagkiszolgálók megtervezése

Windows 2000 esetén a tartományban lévő kiszolgálók lehetnek tartományvezérlők, amelyek az adott tartományhoz tartozó felhasználói fiókok és az Active Directory más adatainak egyező másolatát tartalmazzák, és tagkiszolgálók, amelyek a tartományhoz tartoznak, de nem tartalmazzák az Active Directoryban tárolt adatok másolatát. (Az olyan kiszolgálót, amely nem tartományhoz, hanem munkacsoporthoz tartozik önálló kiszolgálónak nevezik.) A Windows 2000 rendszerben lehetséges a kiszolgálók szerepének változtatása tartományvezérlőről tagkiszolgálóra (vagy önálló kiszolgálóra) és vissza, még a telepítés befejezése után is. Ennek ellenére célszerű, ha még a Telepítő futtatása előtt megtervezi a tartományt, és csak akkor változtatja meg a kiszolgálók szerepét, ha szükséges.

A telepítés előtt tanácsos alaposan átgondolni a tartományvezérlők elnevezését. A kiszolgáló nevét nem változtathatja meg, amíg az tartományvezérlőként működik. Ehhez tagkiszolgálóra, vagy önálló kiszolgálóra kell változtatnia, megadni az új nevet, majd ismét tartományvezérlővé kell tennie.

Ha több tartományvezérlője van, jobb támogatást nyújthat a felhasználóknak, mint ha csak eggyel rendelkezne. A több tartományvezérlő automatikus biztonsági másolatot készít a felhasználói fiókokról és az Active Directory más adatairól, és együttműködik a tartományvezérlői funkciók ellátásában (például a bejelentkezések érvényesítésében).

További információt a Kiszolgálói szerepkörök című témakörben találhat.


A Windows 2000 tartományvezérlők speciális tulajdonságai

A Windows 2000 tartomány kezelése közben a Windows 2000 tartományvezérlők számos olyan tulajdonságával találkozhat, melyekről többet szeretne megtudni. Ez a témakör ezeket a tulajdonságokat ismerteti röviden. A tartományokra vonatkozó kérdésekkel kapcsolatosan bővebben az Active Directory című témakörben tájékozódhat.

A tartományok egyik fontos tulajdonsága, melyről több információra lehet szüksége, a műveleti főkiszolgáló szerepkörök hozzárendelése. Ezek különleges szerepkörök, melyeket egy Active Directory tartományban egy vagy több tartományvezérlőhöz rendelhet. Azok a tartományvezérlők, melyekhez ezt a szerepkört rendelte hozzá, olyan műveleteket hajtanak végre, melyek egyetlen főkiszolgálóval végzett műveletek (ugyanabban az időben a hálózatban csak egy helyen fordulhatnak elő). Ilyen például a biztonsági azonosítók új erőforrásokhoz (például számítógépekhez) való hozzárendelése, melyet egy tartományvezérlőnek kell átlátnia ahhoz, hogy biztosíthassa az azonosítók egyediségét.

A tartományhoz elsőként rendelt tartományvezérlő automatikusan betölti a műveleti főkiszolgáló szerepet. A Telepítő futtatásának végeztével a műveleti főkiszolgáló szerepkört módosíthatja, ez azonban legtöbbször nem szükséges. A műveleti főkiszolgáló szerepkörökre akkor kell különösen ügyelni, ha egy műveleti főkiszolgálón problémák lépnek fel, vagy egyiküket el kívánja távolítani a hálózatból. A műveleti főkiszolgáló szerepkörökkel kapcsolatban további információ az Egyetlen főkiszolgálóval végzett műveletek című témakörben található.

A tartománykezelés egy másik tulajdonsága a globális katalógus. Több tartomány telepítésekor legalább egy olyan tartományvezérlőnek kell futnia, mely tárolja a globális katalógust, és a bejelentkezni kívánó felhasználók rendelkezésére áll. A globális katalógusokkal kapcsolatban bővebb információt a Globális katalógus című témakörben talál.


További információ a tartományokról

Egy meglévő tartomány frissítésével kapcsolatos további információt a Meglévő Windows NT tartomány frissítése című témakörben találhat.

A tartományokról, műveleti főkiszolgálói szerepekről, a globális katalógusról és más tartományokkal kapcsolatos témákról az Active Directory című témakörben olvashat.

Több tartomány strukturált kapcsolatban való telepítéséről információt a Windows 2000 Server Resource Kit csomag Deployment Planning Guide című fejezete tartalmaz. Ha további információra van szüksége a Windows 2000 Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.


A rendszer előkészítése a Telepítő futtatása előtt

  • A rendszer előkészítése frissítéshez
  • A rendszer előkészítése új telepítéshez


A rendszer előkészítése frissítéshez

A Windows 2000 Server rendszerre történő frissítéshez számos alapvető előkészületi lépés szükséges: fájlok biztonsági mentése, meghajtók kibontása, lemezek tükrözésének letiltása, szünetmentes áramforrások (UPS) leválasztása, valamint a számítógépen található alkalmazások áttekintése.

Fájlok biztonsági mentése

A frissítés megkezdése előtt ajánlatos az aktuális fájlokról biztonsági másolatot készíteni. A biztonsági másolatot készítheti lemezre, szalagos meghajtóra vagy a hálózat egy másik számítógépére.

Meghajtó kibontása

A Windows 2000 rendszerre történő frissítés előtt bontson ki minden, a DriveSpace vagy a DoubleSpace segítségével tömörített kötetet. Ne kísérelje meg a frissítést tömörített meghajtón, csak akkor, ha a tömörítést az NTFS fájlrendszer tömörítő szolgáltatásával végezte.

Lemez tükrözésének letiltása

A frissítés megkezdése előtt a célszámítógép esetleges lemeztükrözéseit tiltsa le. A telepítés befejeztével a tükrözést ismét engedélyezheti.

Szünetmentes áramforrások leválasztása

Ha a célszámítógépre szünetmentes áramforrás (UPS) van csatlakoztatva, a Telepítő futtatása előtt húzza ki annak soros kábelét. A Windows 2000 Telepítő ugyanis megkísérli automatikusan felismerni a soros portra csatlakoztatott eszközöket, és a szünetmentes áramforrás problémát okozhat e folyamat során.

Alkalmazások áttekintése

A Windows 2000 Server telepítőprogramjának indítása előtt olvassa el az Olvassel.doc fájl (amely a Windows 2000 Server CD-ROM gyökérkönyvtárában található) alkalmazásokra vonatkozó részét. Nézze meg, van-e olyan alkalmazás a gépen, amelyet a telepítés előtt le kell tiltani, vagy el kell távolítani.

A Microsoft Windows 2000 rendszerrel kompatibilis és bevizsgált alkalmazások legfrissebb listáját a Directory of Windows 2000 Applications webhelyen találja meg, a következő címen: (http://www.microsoft.com/). Ezen a helyen az aktuális és a külön a Windows 2000 számára tervezett alkalmazásokra vonatkozó információkat olvashat.


A rendszer előkészítése új telepítéshez

A Windows 2000 Server rendszer új telepítéséhez számos alapvető előkészületi lépés szükséges: fájlok biztonsági mentése, meghajtók kibontása, lemezek tükrözésének letiltása és a szünetmentes áramforrások (UPS) leválasztása.

Fájlok biztonsági mentése

A Windows 2000 Server új telepítésének megkezdése előtt ajánlatos az aktuális fájlokról biztonsági másolatot készíteni, kivéve, ha a számítógépen nincsenek fájlok, vagy ha a jelenlegi operációs rendszer fájljai megsérültek. A biztonsági másolatot készítheti lemezre, szalagos meghajtóra vagy a hálózat egy másik számítógépére.

Meghajtó kibontása

A Windows 2000 rendszer új telepítése előtt bontson ki minden, a DriveSpace vagy a DoubleSpace segítségével tömörített kötetet. Ne telepítse a Windows 2000 rendszert tömörített meghajtóra, csak akkor, ha a tömörítést az NTFS fájlrendszer tömörítő szolgáltatásával végezte.

Lemez tükrözésének letiltása

Az új telepítés megkezdése előtt a célszámítógép esetleges lemeztükrözéseit tiltsa le. A telepítés befejeztével a tükrözést ismét engedélyezheti.

Szünetmentes áramforrások leválasztása

Ha a célszámítógépre szünetmentes áramforrás (UPS) van csatlakoztatva, a Telepítő futtatása előtt húzza ki annak soros kábelét. A Windows 2000 Telepítő ugyanis megkísérli automatikusan felismerni a soros portra csatlakoztatott eszközöket, és a szünetmentes áramforrás problémát okozhat e folyamat során.


Hibaelhárítás

Ez a rész a STOP üzenetekkel jelzett hibák elhárítását ismerteti. Ezek az üzenetek a Windows 2000 operációs rendszerben bekövetkező hibák esetén jelennek meg. Rendszerhiba esetén a számítógép nem válaszol, és kék vagy fekete háttér előtt megjelenik egy üzenet.

A terméktámogatáshoz való hozzáférés módjáról a Microsoft Technikai Tanácsadó Szolgáltatások című témakörben találhat bővebb információt.

  • Hibaelhárítás – STOP üzenetek: általános stratégiák
  • Hibaelhárítás – Meghatározott STOP hibaüzenetek


Hibaelhárítás – STOP üzenetek: általános stratégiák

Ez a témakör a STOP üzenetek általános hibaelhárítási módszereit tárgyalja. Kövesse az alábbi lépéseket, ha olyan STOP hibával találkozik, ami nem jelenít meg azonosító szöveget vagy konkrét hibaelhárítási lépéseket. Azoknak a STOP üzeneteknek a hibaelhárításához, melyek azonosító szöveget jelenítenek meg, tekintse meg a Hibaelhárítás – Meghatározott STOP hibaüzenetek című témakört, vagy tekintse át a Microsoft Windows 2000 Resource Kit csomagot. Ha többet kíván megtudni a Windows 2000 Resource Kit csomagról, olvassa el a Windows 2000 Resource Kit című témakört.

A terméktámogatás igénybevételéről bővebb információt a Microsoft Technikai Tanácsadó Szolgáltatások című témakörben találhat.

A témakörben lévő lépéseket vázlatosan a STOP üzenet képernyőjén is megtalálja. Kövesse ezeket a lépéseket a meghatározott sorrendben. Ha az adott lépés végrehajtása után a STOP hibaüzenet újból megjelenik, hajtsa végre a következő lépést.

  1. Az Ön által használt vírusölő szoftver friss verziójával végezzen vírusellenőrzést a számítógépen. Ha vírust talál a rendszeren, annak eltávolításához tegye meg a szükséges lépéseket. Ezen lépésekről további tudnivalók a vírusölő szoftver dokumentációjában találhatók.
  2. Ha el lehet indítani a Windows 2000 rendszert, ellenőrizze, hogy az Eseménynaplóban van-e olyan információ, amely segít azonosítani a hibát okozó eszközt vagy illesztőprogramot. Ehhez mutasson a Start menü Beállítások pontjára, kattintson a Vezérlőpult parancsra, ezután kattintson duplán a Felügyeleti eszközök, majd az Eseménynapló ikonra, végül a konzol Rendszernapló elemére.

    Ahhoz, hogy az Eseménynaplón megjelenítse egy esemény leírását, kattintson duplán az eseményre.

  3. Tiltson le minden újonnan telepített illesztőprogramot, és távolítson el minden újonnan hozzáadott programot. Ha nem tudja elindítani a számítógépet, kísérelje meg az indítást Legutolsó helyes konfiguráció módban vagy csökkentett módban, majd tiltsa le az újonnan hozzáadott programokat vagy illesztőprogramokat. A számítógép csökkentett módban való elindításáról bővebben A csökkentett módú indítás beállításai vagy a Nem induló rendszer helyreállítása című témakörökben olvashat.

    4. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.
  4. Tiltson le vagy távolítson el minden újonnan telepített hardvert (RAM-ot, csatolót, merevlemezt, modemet stb.).
  5. Ellenőrizze, hogy a hardvereszközök illesztőprogramjai frissítve vannak-e, és a rendszer BIOS-ának legújabb verziójával rendelkezik-e. Ezek beszerzéséhez az eszközök gyártói nyújthatnak segítséget.
  6. Futtassa a számítógép gyártójától származó rendszerdiagnosztizáló szoftvert, különös tekintettel a memóriaellenőrzésre.
  7. Ellenőrizze a Microsoft hardverkompatibilitási listán (HCL), hogy minden rendelkezésére álló hardver és illesztőprogram kompatibilis-e a Windows 2000 rendszerrel.

    A HCL Windows 2000 CD-ROM-on való megtekintéséhez nyissa meg a Support mappában a Hcl.txt nevű fájlt. A HCL legfrissebb változata a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen található. (http://www.microsoft.com/).

  8. A BIOS-ban tiltsa le a memória gyorsítótárba mentését. Amennyiben a fenti lépések bármelyikének végrehajtásában nehézségekbe ütközik, lépjen kapcsolatba a hardver gyártójával.
  9. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    Fontos

    • A Legutolsó helyes konfiguráció indítási mód használatakor a rendszer a számítógép legutóbbi sikeres indításakor használt beállításokat állítja vissza a számítógépen.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat a STOP hibaüzenetekkel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszavak megadásakor írja be a STOP hibaüzenet számát (például: stop 0x0000000A).

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.


Hibaelhárítás – Meghatározott STOP hibaüzenetek

Ez a témakör azt tárgyalja, hogyan háríthatók el adott STOP üzenetekkel jelzett hibák. A STOP hibaüzenetekkel kapcsolatos általános hibaelhárításról a Hibaelhárítás – STOP hibaüzenetek: általános stratégiák című témakörben olvashat.

A terméktámogatás igénybevételéről bővebb információt a Microsoft Technikai Tanácsadó Szolgáltatások című témakörben találhat.

A STOP üzenet típusa

0x0000000A STOP üzenet meglévő telepítésen

Hiba leírása: IRQL_NOT_LESS_OR_EQUAL

Leggyakoribb ok: Az illesztőprogramok nem a megfelelő memóriacímeket használják.

Megoldás:

  1. Ha el lehet indítani a Windows 2000 rendszert, ellenőrizze, hogy az Eseménynaplóban van-e olyan információ, amely segít azonosítani a hibát okozó eszközt vagy illesztőprogramot. Ehhez mutasson a Start menü Beállítások pontjára, kattintson a Vezérlőpult parancsra, ezután kattintson duplán a Felügyeleti eszközök, majd az Eseménynapló ikonra, végül a konzol Rendszernapló elemére.
  2. Tiltson le minden újonnan telepített illesztőprogramot, és távolítson el minden újonnan hozzáadott programot. Ha nem tudja elindítani a számítógépet, próbálja meg az indítást Legutolsó helyes konfiguráció módban vagy csökkentett módban, majd tiltsa le az újonnan hozzáadott programokat vagy illesztőprogramokat. A számítógép csökkentett módban való elindításáról bővebben A csökkentett módú indítás beállításai vagy a Nem induló rendszer helyreállítása című témakörökben olvashat.

    3. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.
  3. Tiltson le vagy távolítson el minden újonnan telepített hardvert (RAM-ot, csatolót, merevlemezt, modemet stb.).
  4. Ellenőrizze, hogy a hardvereszközök illesztőprogramjai frissítve vannak-e, és a rendszer BIOS-ának legújabb verziójával rendelkezik-e. Ezek beszerzéséhez az eszközök gyártói nyújthatnak segítséget.
  5. Futtassa a hardver forgalmazójától származó rendszerdiagnosztizáló szoftvert, különös tekintettel a memóriaellenőrzésre.
  6. Ellenőrizze a Microsoft hardverkompatibilitási listán (HCL), hogy a hardver és annak illesztőprogramjai kompatibilisek-e a Windows 2000 rendszerrel.

    A HCL Windows 2000 CD-ROM-on való megtekintéséhez nyissa meg a Support mappában a Hcl.txt nevű fájlt. A HCL legfrissebb változata a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen található (http://www.microsoft.com/).

  7. A BIOS-ban tiltsa le a memória gyorsítótárba mentését. Amennyiben a fenti lépések bármelyikének végrehajtásában nehézségekbe ütközik, lépjen kapcsolatba a hardver gyártójával.
  8. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000000A.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x0000000A STOP üzenet új telepítésen

A hiba leírása: IRQL_NOT_LESS_OR_EQUAL

Leggyakoribb ok: Az illesztőprogramok nem a megfelelő memóriacímeket használják.

Megoldás:

  1. Telepítés közben „A Telepítő vizsgálja a számítógép hardverkonfigurációját” üzenet megjelenésekor nyomja le az F5 billentyűt. Felszólításra jelölje ki a megfelelő számítógéptípust. Ha egyprocesszoros számítógéppel rendelkezik jelölje be a Szabványos PC lehetőséget.
  2. A BIOS-ban tiltsa le a memória gyorsítótárba mentését. Amennyiben a fenti lépések bármelyikének végrehajtásában nehézségekbe ütközik, lépjen kapcsolatba a hardver gyártójával.
  3. Távolítsa el az összes csatolót, és válasszon le minden hardvereszközt, ami nem alapvető fontosságú a számítógép elindításához, majd telepítse a Windows 2000 Server operációs rendszert.
  4. Amennyiben SCSI csatolót használ, a csatoló gyártójától szerezze be a legfrissebb Windows 2000 Server illesztőprogramot, tiltsa le a szinkronegyeztetést, ellenőrizze a megszakítást és az eszközök SCSI-azonosítóit.
  5. Ha IDE-eszközöket használ, az alaplapon lévő IDE-portot adja meg Csak elsődleges beállítással. Ellenőrizze az IDE-eszközök Fő/Szolga/Egyetlen beállításait. A merevlemez kivételével távolítson el minden IDE-eszközt.
  6. Futtassa a hardver eladójától származó rendszerdiagnosztizáló szoftvert, különös tekintettel a memóriaellenőrzésre.
  7. Ellenőrizze a Microsoft hardverkompatibilitási listán (HCL), hogy hardverei és azok illesztőprogramjai kompatibilisek-e a Windows 2000 rendszerrel.

    A HCL Windows 2000 CD-ROM-on való megtekintéséhez nyissa meg a Support mappában a Hcl.txt nevű fájlt. A HCL legfrissebb változata a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen található (http://www.microsoft.com/).

  8. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    9. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha rendelkezik hozzáféréssel, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000000A.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x0000001E STOP üzenet

A hiba leírása: KMODE_EXCEPTION_NOT_HANDLED

Leggyakoribb ok: Ennek a hibaüzenetnek számos oka lehet. Olvassa el az alábbiakban ismertetett lépéseket követő Megjegyzést.

Megoldás:

  1. Ellenőrizze (különösen új telepítéskor), hogy rendelkezik-e elegendő szabad lemezterülettel.
  2. Tiltsa le a STOP üzenetben meghatározott illesztőprogramot vagy bármely újonnan telepített illesztőprogramot. Ha nem tudja elindítani a számítógépet, próbálja meg az indítást Legutolsó helyes konfiguráció módban vagy csökkentett módban, majd tiltsa le az újonnan hozzáadott programokat vagy illesztőprogramokat. A számítógép csökkentett módban való elindításáról, valamint az egyéb indítási lehetőségekről bővebben A csökkentett módú indítás beállításai vagy a Nem induló rendszer helyreállítása című témakörökben olvashat.

    3. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.
  3. Ha a videokártya illesztőprogramját nem a Microsoft szállította, váltson át szabványos VGA-illesztőprogramra vagy más, a Windows 2000 rendszerrel szállított megfelelő illesztőprogramra.
  4. Ellenőrizze, hogy a rendszer BIOS-ának legújabb verziójával rendelkezik-e. Amennyiben a fenti lépések bármelyikének végrehajtásában nehézségekbe ütközik, lépjen kapcsolatba a hardver gyártójával.
  5. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    6. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000001E.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x00000023 és 0x00000024 STOP üzenetek

A hiba leírása: FAT_FILE_SYSTEM vagy NTFS_FILE_SYSTEM

Leggyakoribb ok: Erősen töredezett meghajtó, sok fájl I/O, a lemeztükröző szoftverek vagy a vírusirtó szoftverek néhány típusa által okozott hiba.

Megoldás:

  1. Tiltsa le a vírusellenőrző és biztonságimásolat-készítő programokat, valamint a töredezettségmentesítő segédprogramokat.
  2. A CHKDSK /f futtatásával ellenőrizze a merevlemez esetleges sérüléseit, majd indítsa újra a számítógépet.
  3. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    4. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x00000023 vagy stop 0x00000024.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x0000002E STOP üzenet

A hiba leírása: DATA_BUS_ERROR

Leggyakoribb ok: Paritáshiba a rendszermemóriában.

Megoldás:

  1. Futtassa a hardver forgalmazójától származó rendszerdiagnosztizáló szoftvert, különös tekintettel a memóriaellenőrzésre.
  2. A BIOS-ban tiltsa le a memória gyorsítótárba mentését. Amennyiben a fenti lépések bármelyikének végrehajtásában nehézségekbe ütközik, lépjen kapcsolatba a hardver gyártójával.
  3. Próbálja meg a csökkentett módú indítást. További információ A csökkentett módú indítás beállításai és a Katasztrófa utáni helyreállítás – áttekintés című témakörökben található. Amennyiben a számítógép csökkentett módban elindítható, próbáljon meg szabványos VGA-illesztőprogramra váltani. Ha ez nem oldja meg a problémát, váltson át egy másik videokártyára.
    A támogatott videokártyák listáját a hardverkompatibilitási listán (HCL) találja meg.

    A HCL Windows 2000 CD-ROM-on való megtekintéséhez nyissa meg a Support mappában a Hcl.txt nevű fájlt. A HCL legfrissebb változata a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen található (http://www.microsoft.com/).

  4. Ellenőrizze, hogy hardvereszközök illesztőprogramjai frissítve vannak-e és a rendszer BIOS-ának legújabb verziójával rendelkezik-e. Ezek beszerzéséhez az eszközök gyártói nyújthatnak segítséget.
  5. Tiltson le vagy távolítson el minden újonnan telepített hardvert (RAM-ot, csatolót, merevlemezt, modemet stb.).
  6. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    7. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000002E.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x0000003F STOP üzenet

A hiba leírása: NO_MORE_SYSTEM_PTES

Leggyakoribb ok: Valamelyik illesztőprogram nem megfelelően működik.

Megoldás:

  • Távolítson el minden újonnan telepített szoftvert, beleértve a biztonságimásolat-készítő segédprogramokat vagy a lemez erőforrásait jelentős mértékben igénybe vevő alkalmazásokat, mint a töredezettségmentesítő, a vírusellenőrző vagy a biztonságimásolat-készítő segédprogramok.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000003F.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x00000058 STOP üzenet

A hiba leírása: FTDISK_INTERNAL_ERROR

Leggyakoribb ok: Valamely hibatűrési készletben található elsődleges meghajtó meghibásodása.

Megoldás:

  1. Indítsa el a számítógépet a Windows 2000 indítólemez segítségével a tükrözött (másodlagos) rendszermeghajtóról.
  2. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    3. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x00000058.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x0000007B STOP üzenet

A hiba leírása: INACCESSIBLE_BOOT_DEVICE

Leggyakoribb ok: Az I/O rendszer (legtöbbször az indítóeszköz vagy a fájlrendszer) inicializálása közben bekövetkező hiba.

Megoldás:

  1. Ellenőrizze, hogy nincs-e vírus a számítógépen. Ez a STOP üzenet leggyakrabban olyankor fordul elő, ha a rendszertöltő szektorban vírus található.
  2. A merevlemez javításának módjai a Katasztrófa utáni helyreállítás – áttekintés és A Helyreállítási konzol című témakörökben találhatók.
  3. Távolítson el minden újonnan hozzáadott merevlemez-meghajtót vagy vezérlőt.
  4. Amennyiben SCSI csatolót használ, a csatoló gyártójától szerezze be a legfrissebb Windows 2000 illesztőprogramot, tiltsa le a szinkronegyeztetést, ellenőrizze a megszakítást és az eszközök SCSI-azonosítóit.
  5. Ha IDE-eszközöket használ, az alaplapon lévő IDE-portot adja meg Csak elsődleges beállítással. Ellenőrizze az IDE-eszközök Fő/Szolga/Egyetlen beállításait. A merevlemez kivételével távolítson el minden IDE-eszközt.
  6. Futtassa a CHKDSK segédprogramot. Lehetséges, hogy a fájlrendszer megsérült. Ha a Windows 2000 nem tudja elindítani a CHKDSK segédprogramot, előfordulhat, hogy a meghajtót át kell tenni egy másik Windows 2000 rendszert számítógépbe, és a CHKDSK parancsot ott kell alkalmazni.
  7. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    8. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000007B.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x0000007F STOP rendszerindító szektor

A hiba leírása: UNEXPECTED_KERNEL_MODE_TRAP

Leggyakoribb ok: Hardver- vagy szoftverproblémák, legtöbbször hardverhiba.

Megoldás:

  1. Futtassa a hardver forgalmazójától származó rendszerdiagnosztizáló szoftvert, különös tekintettel a memóriaellenőrzésre. Ez a STOP üzenet legtöbbször hibás vagy nem illeszkedő memória esetén jelenik meg.
  2. A BIOS-ban tiltsa le a memória gyorsítótárba mentését. Amennyiben a fenti lépések bármelyikének végrehajtásában nehézségekbe ütközik, lépjen kapcsolatba a hardver gyártójával.
  3. Ellenőrizze a Microsoft hardverkompatibilitási listán (HCL), hogy a hardver és annak illesztőprogramjai kompatibilisek-e a Windows 2000 rendszerrel.

    A HCL Windows 2000 CD-ROM-on való megtekintéséhez nyissa meg a Support mappában a Hcl.txt nevű fájlt. A HCL legfrissebb változata a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen található (http://www.microsoft.com/). Ezt a hibát a számítógép alaplapjával való inkompatibilitás is okozhatja.

  4. Indítsa újra a számítógépet. Az indítóképernyő megjelenésekor nyomja le az F8 billentyűt a speciális indítási beállítások megjelenítéséhez, majd válassza a Legutolsó helyes konfiguráció lehetőséget.

    5. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x0000007F.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x000000B4 STOP üzenet

A hiba leírása: VIDEO_DRIVER_INIT_FAILURE

Leggyakoribb ok: A videoillesztő-program hibás, megsérült, hiányzik vagy le van tiltva.

Megoldás:

  1. Próbálja meg a számítógépet csökkentett módban elindítani, vagy engedélyezze a VGA-módot. További információ A csökkentett módú indítás beállításai című témakörben található. Ha a számítógépet nem lehet csökkentett módban, vagy a VGA-mód engedélyezésével elindítani, tekintse át a Nem induló rendszer helyreállítása című témakört.
  2. Ha a számítógépet el lehet indítani csökkentett módban, a Hardver hozzáadása/eltávolítása segítségével távolítsa el a videoillesztő-programot. A Hardver hozzáadása/eltávolítása párbeszédpanel megnyitásához mutasson a Start menü Beállítások pontjára, kattintson a Vezérlőpult parancsra, majd kattintson duplán a Hardver hozzáadása/eltávolítása ikonra.
  3. Az előző lépés végrehajtása után az alábbi eljárások egyikével telepítse újra a videoillesztő-programot:
    • Amennyiben tudja, hogy a videokártya nem Plug and Play eszköz, próbálja meg a videoillesztő-programot csökkentett módban vagy a VGA-mód engedélyezésével újratelepíteni. Az előző részben említett Hardver hozzáadása/eltávolítása segítségével telepítse újra az illesztőprogramot, és indítsa újra a számítógépet.
    • Ha tudja, hogy a videokártya Plug and Play eszköz, az illesztőprogram eltávolítása után indítsa újra a számítógépet. Az illesztőprogramot a videokártya észlelésekor a rendszer automatikusan újratelepíti.
    • Ha nem biztos abban, hogy a videokártya Plug and Play eszköz, próbálja meg újraindítani a számítógépet. Ha a képernyő az újraindítás után sem működik, indítsa újra csökkentett módban vagy a VGA-mód engedélyezésével, majd az előző lépésben leírtak szerint a Hardver hozzáadása/eltávolítása segítségével telepítse újra az illesztőprogramot. Végül indítsa újra a számítógépet.

    A támogatott videokártyák listáját a hardverkompatibilitási listán (HCL) találja meg. A HCL Windows 2000 CD-ROM-on való megtekintéséhez nyissa meg a Support mappában a Hcl.txt nevű fájlt. A HCL legfrissebb változata a Microsoft Windows hardverkompatibilitási listát tartalmazó webhelyen található (http://www.microsoft.com/).

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x000000B4.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.

0x000000BE STOP üzenet

A hiba leírása: ATTEMPTED_WRITE_TO_READONLY_MEMORY

Leggyakoribb ok: Az egyik illesztőprogram rossz, megsérült vagy nem működik megfelelően.

Megoldás:

  1. Tiltsa le a STOP üzenetben meghatározott illesztőprogramot vagy az újonnan telepített illesztőprogramokat. Ha nem tudja elindítani a számítógépet, próbálja meg az indítást Legutolsó helyes konfiguráció módban vagy csökkentett módban, majd tiltsa le az újonnan hozzáadott programokat vagy illesztőprogramokat. További információ A csökkentett módú indítás beállításai című témakörben található. Ha a számítógépet nem lehet csökkentett módban elindítani, tekintse át a Nem induló rendszer helyreállítása című témakört.

    2. Fontos

    • Ha a Legutolsó helyes konfiguráció indítási lehetőséget használja, a legutóbbi sikeres indítást követő rendszerbeállításokat érintő módosítások elvesznek.
  2. Próbálja meg kicserélni az illesztőprogramot a telepítőlemezen lévő másolat vagy a gyártó által rendelkezésre bocsátott frissített verzió segítségével.

Megjegyzés

  • Ha van hozzáférése, az Interneten frissített információhoz juthat ezzel a STOP hibaüzenettel kapcsolatban. Ehhez látogassa meg a Microsoft webhelyet (http://www.microsoft.com/), használja a Keresés lehetőséget, majd kövesse az oldalon megjelenő utasításokat. A kulcsszó megadásakor írja be: stop 0x000000BE.

    A cikkekkel, a hibaelhárító varázslóval és a letölthető elemekkel kapcsolatban a Frissített technikai információ című témakörben olvashat bővebben.


Kisegítő lehetőségek megváltozott munkaképességűek számára

A Microsoft szeretné elérni, hogy termékei és szolgáltatásai mindenki számára könnyen használhatóak legyenek. Ebben a témakörben azokról a jellemzőkről, termékekről és szolgáltatásokról találhat információt, melyek a Microsoft Windows 2000 operációs rendszert a megváltozott munkaképességűek számára is elérhetővé teszik.

Megjegyzés

  • Az ebben a témakörben található információ csak azokra a felhasználókra érvényes, akik az Egyesült Államokban szereznek használati jogot a Microsoft termékekre. Amennyiben e terméket az Egyesült Államok területén kívül szerezte be, a szoftvercsomag tartalmaz egy képviseleti információs kártyát, melyen a Microsoft ügyfélszolgálatok telefonszáma és címe található. A képviselettől megtudhatja, hogy a jelen témakörben ismertetett termékek és szolgáltatások hozzáférhetőek-e lakóhelyén.

Bővebb információt a megváltozott munkaképességűek számára elérhető Microsoft termékekről a Microsoft Accessibility webhelyen, az alábbi címen talál: (http://www.microsoft.com/).

További információt a kisegítő lehetőségekről, a billentyűparancsokról és a kisegítő lehetőségeket bemutató programról a Kisegítő lehetőségek súgójában talál.

Az alábbi témakörök a kisegítő szolgáltatásokról, lehetőségekről és erőforrásokról kínálnak információt.

  • Kisegítő szolgáltatások és lehetőségek
  • További felvilágosítás a kisegítő lehetőségekről

Megjegyzés

  • A Kisegítő lehetőségek súgójának megjelenítéséhez kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra. A menüsoron kattintson a Súgó menüre, majd a Témakörök parancsra. A Tartalom lapon kattintson a Kisegítő lehetőségek elemre.


Kisegítő szolgáltatások és lehetőségek

A Windows 2000 operációs rendszer számos olyan kisegítő lehetőséget tartalmaz, melyek segítségével a képernyő, a hang, az egér és a billentyűzet beállíthatók vak, mozgássérült, illetve siket és halláskárosult személyek számára. Ezen szolgáltatások közül több hasznos lehet a normál munkaképességűek számára is.

A kisegítő lehetőségekről, a billentyűparancsokról és a kisegítő lehetőségeket bemutató programról további információt a Kisegítő lehetőségek súgója tartalmaz.

  • Kisegítő lehetőségek
  • Kisegítő lehetőségek telepítése
  • Az egérmutató mozgatása a billentyűzet segítségével

Megjegyzés

  • A Kisegítő lehetőségek súgójának megjelenítéséhez kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra. A menüsoron kattintson a Súgó menüre, majd a Témakörök parancsra. A „Kisegítő lehetőségek” címsor alatt kattintson a megfelelő témakörre.


Kisegítő lehetőségek

A Windows 2000 az alábbi segédprogramokkal segíti a látásukban, hallásukban vagy mozgásukban korlátozott felhasználókat:

  • Nagyító. A képernyő egy részletét a láthatóság érdekében egy külön ablakban felnagyítja.
  • Narrátor. Felolvassa a képernyőn található információt például a párbeszédpanelek nevét, menüket, beírt szöveget stb. A Narrátor alapvető kisegítő lehetőséget nyújt a vak és gyengénlátó személyeknek ahhoz, hogy a konfiguráció vagy vészhelyzet esetén kapcsolatba léphessenek a Windows 2000 rendszerrel.

    • Megjegyzés

    • A Narrátor csak angol nyelvű Windows 2000 operációs rendszerben érhető el, a szolgáltatáshoz nem létezik magyar nyelvű felolvasó programmag.
  • Képernyőbillentyűzet. Egy virtuális billentyűzetet jelenít meg, melynek segítségével egy mutatóeszköz, például az egér, vagy egy kapcsoló segítségével információk vihetők be. A Képernyőbillentyűzet sok, de nem minden billentyűzettel és billentyűzet-beállítással kompatibilis.

A Windows 2000 ezeken kívül testreszabási lehetőségeket kínál olyan felhasználók számára is, akik vakok, mozgáskorlátozottak, siketek vagy nagyothallók:

  • Kontrasztos színsémák. További lehetőségeket kínálnak a képernyő színeinek és a betűméretek módosítására.
  • Hangsémák. Hasznos hallható visszajelzést adnak a képernyőn történő fontos eseményekről, például az ablakok megnyitásáról és bezárásáról.
  • Jól látható egérmutató sémák. Megkönnyítik az egérmutató szemmel történő követését.


Kisegítő lehetőségek telepítése

A Windows 2000 kisegítő lehetőségeit számos módon beállíthatja, hogy azok megfeleljenek a felhasználók látási, hallási és mozgási képességeinek. A kisegítő lehetőségek alapértelmezés szerint telepítésre kerülnek.

A kisegítő lehetőségek gyors telepítéséhez használja a Kisegítő lehetőségek varázslót. A varázsló kérdéseket tesz fel a képességeire vonatkozóan, majd automatikusan elvégzi a szükséges beállításokat. A vezérlőpult Kisegítő lehetőségek ikonjára kattintva közvetlenül is elvégezheti a billentyűzet, a képernyő és az egér beállítását.

Megjegyzés

  • Ha egértől eltérő beviteli eszközt használ, kattintás helyett hajtsa végre a megfelelő műveletet a parancsok végrehajtásához és az elemek kijelöléséhez.

Kisegítő lehetőségek beállítása a Kisegítő lehetőségek varázsló segítségével

  1. Kattintson a Start gombra, mutasson a Programok, a Kellékek, majd a Kisegítő lehetőségek pontra, és kattintson a Kisegítő lehetőségek varázsló parancsra.
  2. Kövesse a képernyőn megjelenő utasításokat.

A kisegítő lehetőségek beállítása a Vezérlőpult segítségével

  1. Kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra.
  2. A Vezérlőpulton kattintson duplán a Kisegítő lehetőségek ikonra.

Néhány kisegítő lehetőséget billentyűkombináció segítségével is ki- és bekapcsolhat, függetlenül attól, hogy az adott szolgáltatásokat engedélyezte-e vagy sem. Az alábbi billentyűkombinációk használatakor a számítógép hallhatóan (hangjelzéssel) és vizuálisan (párbeszédpanelekkel) is jelzi az adott kisegítő lehetőség be- illetve kikapcsolását.

Cél | Billentyűparancs
Billentyűszűrés be- és kikapcsolása | JOBB SHIFT nyolc másodpercig
Kontrasztos megjelenítés be- és kikapcsolása | BAL ALT + BAL SHIFT + PRINT SCREEN
Billentyűzetegér be- és kikapcsolása | BAL ALT + BAL SHIFT + NUM LOCK
Beragadó billentyűk be- és kikapcsolása | SHIFT ötször
Állapotjelző hangok be- és kikapcsolása | NUM LOCK 5 másodpercig


Az egérmutató mozgatása a billentyűzet segítségével

Ha problémái vannak az egér kezelésével, a Billentyűzetegér megfelelő beállítása után a numerikus billentyűzet segítségével mozgathatja az egérmutatót. Ezt elvégezheti a Kisegítő lehetőségek varázslóban, vagy a Vezérlőpulton az alábbiak szerint.

A Billentyűzetegér bekapcsolása

  2. Az Egér lapon jelölje be a Billentyűzetegér használata jelölőnégyzetet.

Az egérmutató mozgatásához használható billentyűket az alábbi ábra szemlélteti.

A Billentyűzetegér illusztrációja

Megjegyzés

  • A Vezérlőpult egy adott elemének megnyitásához kattintson a Start gombra, mutasson a Beállítások menüpontra, kattintson a Vezérlőpult parancsra, majd kattintson duplán a megfelelő ikonra.


További felvilágosítás a kisegítő lehetőségekről

A kisegítő lehetőségekkel, a billentyűparancsokkal és a kisegítő lehetőségeket bemutató programokkal kapcsolatos további információt a Kisegítő lehetőségek súgójában talál.

További információt az alábbi témakörökben talál:

  • Könnyebben kezelhető dokumentáció
  • A Kisegítő lehetőségek szolgáltatáshoz kapcsolódó megjegyzések és segédprogramok letöltése
  • Egyéb kisegítő lehetőségeket tartalmazó termékek és szolgáltatások

Megjegyzés

  • A Kisegítő lehetőségek súgójának megjelenítéséhez kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra. A menüsoron kattintson a Súgó menüre, majd a Témakörök parancsra. A Tartalom lapon kattintson a Kisegítő lehetőségek elemre.


Könnyebben kezelhető dokumentáció

Számos Microsoft termék dokumentációja többféle formátumban is hozzáférhető. Ha a nyomtatott dokumentáció olvasása vagy kezelése nehézséget okoz, számos Microsoft kiadvány elérhető a Microsoft Accessibility webhelyen. (http://www.microsoft.com/)

A legtöbb Microsoft kiadvány a Recording for the Blind & Dyslexic, Inc. cégtől is beszerezhető. Ez a cég hangkazettákon és hajlékonylemezeken terjeszti kiadványait a terjesztési hálózat regisztrált tagjai számára. A cég kínálata a Microsoft termékek dokumentációival és a Microsoft Press által kiadott könyvekkel együtt több mint 80 000 kiadványt foglal magában.

Ha további felvilágosításra van szüksége, forduljon a Recording for the Blind & Dyslexic céghez az alábbi címen:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540
Telefon: (609) 452-0606
Fax: (609) 987-8116

A Recording for the Blind and Dyslexic webhelye (http://www.rfbd.org/)


A Kisegítő lehetőségek szolgáltatáshoz kapcsolódó megjegyzések és segédprogramok letöltése

Ha modemes vagy egyéb hálózati kapcsolattal rendelkezik, a kisegítő lehetőséggel kapcsolatos fájlokat az alábbi hálózati szolgáltatásoktól töltheti le:

  • Microsoft Accessibility webhely (http://www.microsoft.com/).
  • Az ftp.microsoft.com címen található Microsoft Internet-kiszolgáló

    Nyissa meg a Softlib mappát, és a readme és/vagy az index fájl segítségével tanulmányozza a webhelyet. Az index fájlban keressen rá a „customizing” és a „disabilities” szavakra. Válasszon egy fájlt, majd keresse meg a /Softlib/Mslfiles mappában. Hozzon létre egy mappát a merevlemezen, majd futtassa a kiválasztott fájlt a jelenlegi helyéről. Kövesse az utasításokat, és csomagolja ki a fájlt a létrehozott mappába.

  • Microsoft Download Service (MSDL), amelyet az Egyesült Államokban a (425) 936-6735-ös telefonszámon érhet el a nap minden szakában, kivéve 1:00 és 2:30 óra között (csendes-óceáni idő).

    Az MSDL a 1200, 2400, 9600, illetve 14 400 kb/s (V.22bis, V.32, V.32bis és V.42 szabványú) adatátviteli sebességeket támogatja, 8 adatbittel, paritásbit nélkül és 1 stopbittel. Az MSDL nem támogatja a 28 800 és az 56 000 kb/s átviteli sebességet és az ISDN-kapcsolatokat.


Egyéb kisegítő lehetőségeket tartalmazó termékek és szolgáltatások

A Microsoft és más szervezetek további termékeket, szolgáltatásokat és forrásokat kínálnak a megváltozott munkaképességű személyek számára. A Microsoft katalógussal rendelkezik a Windows, a Windows°NT és a Windows°2000 operációs rendszerben használható kisegítő lehetőségekről. A katalógus a Microsoft Accessibility webhelyén, illetve telefonon keresztül is beszerezhető:

Microsoft Sales Information Center
One Microsoft Way
Redmond, WA 98052-6393
Telefon: (800) 426-9400
Szöveges telefon: (800) 892-5234

Microsoft Accessibility webhely (http://www.microsoft.com/)

A megváltozott munkaképességűek számára készült Macintosh termékekre és szolgáltatásokra vonatkozóan a következő webhelyen és telefonszámon kaphat információt:

Apple Disability Resources webhely (http://www.apple.com/disability/)

A Wisconsin-Madison Egyetemen működő Trace Kutató és Fejlesztő Központ készített egy adatbázist, mely több mint 18 000 terméket és egyéb információt tartalmaz a megváltozott munkaképességűek számára. Az adatbázis hozzáférhető a Központ webhelyén. A Trace R&D Center kiadványa a Trace Resourcebook című könyv is, amely mintegy kétezer termék leírását és fényképét tartalmazza. Ezek az anyagok az alábbi címen szerezhetők be:

Trace R&D Center
University of Wisconsin-Madison
5901 Research Park Boulevard
Madison, WI 53719-1250
Fax: (608) 262-8848

A Trace Research and Development Center webhelye (http://www.trace.wisc.edu/)

Magyarországon a kisegítő lehetőségekkel kapcsolatban a Magyar Vakok és Gyengénlátók Országos Szövetsége nyújt tájékoztatást. A következő címen, illetve telefonszámon érdeklődhet:

Magyar Vakok és Gyengénlátók Országos Szövetsége
1146 Budapest
Hermina út 47.
Telefon: 321-0440
Telefax: 343-7028