DNS

A DNS (Tartománynévrendszer) egy internet- és TCP/IP-szabvány szerinti névszolgáltatás. A DNS-szolgáltatás lehetővé teszi, hogy a hálózat ügyfélszámítógépei DNS-tartományneveket regisztráljanak és oldjanak fel. A nevek segítségével megtalálhatók és elérhetők a saját hálózaton, vagy más hálózatokon (például az Interneten) található számítógépek által kínált erőforrások.

  • Mielőtt DNS-kiszolgálóként használná a számítógépet, nézze át a Feladatlista: DNS-kiszolgáló telepítése című témakört.
  • Azokról a szolgáltatásokról, amelyek helye a Windows 2000 operációs rendszerben megváltozott, a következő témakörben olvashat: Megszokott feladatok végrehajtásának új módjai.
  • A DNS használatával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokról az Útmutató című részben olvashat.
  • Általános háttérinformációk a Fogalmak című témakörben találhatók.
  • A problémák elhárításáról a Hibaelhárítás című témakörben olvashat.


Feladatlisták

  • Feladatlista: DNS-kiszolgáló telepítése
  • Feladatlista: A DNS üzembe helyezése
  • Feladatlista: A DNS üzembe helyezése az Active Directoryhoz


Feladatlista: DNS-kiszolgáló telepítése

Lépés | Hivatkozás
(Kezdőknek javasolt) Ha most kezd a tartománynévrendszerrel (DNS) dolgozni, először ismerje meg a DNS működési elveit, a DNS-sel kapcsolatos eszközöket és a DNS ügyfél-kiszolgáló szolgáltatásait. | A DNS – áttekintés
(Javasolt) Ismerkedjen meg a DNS rendszer működésének további részleteivel, és a Windows 2000 DNS-sel kapcsolatos szolgáltatásaival. | A DNS ismertetése; A DNS használata
DNS-kiszolgáló telepítése előtt határozza meg, hogy a kiszolgáló jelenleg tartományvezérlő-e, vagy az lesz-e a jövőben. | Kiszolgáló tervezése DNS-szolgáltatáshoz; A DNS Active Directoryval kapcsolatos szempontjai
Telepítse az első Windows 2000 DNS-kiszolgálót a hálózatra. Ha Active Directoryt használ, nevezze ki a kiszolgálót tartományvezérlővé a DNS-kiszolgáló telepítéséhez. Ellenkező esetben telepítse a DNS-szolgáltatást választható összetevőként. | DNS-kiszolgáló telepítése; Tartományvezérlő telepítése
Válassza ki az igényeinek legjobban megfelelő feladatlistát, és kövesse a benne lévő útmutatót a DNS telepítéséhez. | Feladatlista: a DNS üzembe helyezése; Feladatlista: A DNS üzembe helyezése az Active Directoryhoz


Feladatlista: A DNS üzembe helyezése

Lépés | Hivatkozás
(Ajánlott) Tanulmányozza át azokat a gyakorlati tanácsokat és tervezési szempontokat, melyek az Active Directory nélkül telepített DNS-kiszolgálókra vonatkoznak. | A tervezés alapvető szempontjai; Gyakorlati tanácsok
A vállalat tartománynévszabványának meghatározásával tervezze meg a névteret. | Névtér tervezése a Tartománynévrendszerhez (DNS)
Tervezze meg, hogy az igényeket figyelembe véve milyen címlekérdezési és névlekérdezési zónákra osztja a DNS-tartománynévteret és a hálózati címteret. | Zóna tervezése a DNS névrendszerhez; Névlekérdezés
Tervezze meg, hogy hány DNS-kiszolgálóra van szükség és hová kell azokat a hálózaton helyezni. | Kiszolgáló tervezése DNS-szolgáltatáshoz
(Választható - haladó) A DNS teljesítményoptimalizáló és teljesítményfigyelő eszközeinek használatával tesztelje és értékelje a kiszolgáló teljesítményét. | Kiszolgálók figyelése és optimalizálása
Tanulmányozza az áttérési és együttműködési kérdéseket, ha szükséges. | Kiszolgálók áttelepítése; Együttműködés más szolgáltatásokkal
Ha a hálózati ügyfeleknek képesnek kell lenniük külső DNS-nevek feloldására, fontolja meg, hogy érdemes-e továbbítókat használni a hálózaton. | Továbbítók használata; Továbbítók használata DNS-kiszolgálóval
Jegyeztesse be a vállalat tartománynevét az internetes tartományneveket regisztráló szervezetnél. Ez a név az alapja a vállalat által az Interneten használt DNS-neveknek.

Internet DNS

Név: ____________________._____

Megjegyzés

  • Csak akkor szükséges egy szülő vagy második szintű DNS-tartománynév bejegyeztetése a vállalat számára egy ezzel foglalkozó szervezetnél, ha azt az Interneten is használni kívánja.
 Névtér tervezése a Tartománynévrendszerhez (DNS); Együttműködés más szolgáltatásokkal
Döntse el, hogyan kezeli a DNS-ügyfél feloldási konfigurációit. | Ügyfelek kezelése
Adjon zónákat az első DNS-kiszolgálóhoz és konfigurálja azokat. | Új DNS-kiszolgáló beállítása; Címkeresési zóna hozzáadása; Névkeresési zóna hozzáadása
Telepítsen és konfiguráljon további DNS-kiszolgálókat, ha a kezdeti zónák másodlagos kiszolgálóiként kívánja azokat használni. | DNS-kiszolgáló telepítése; Másodlagos kiszolgáló hozzáadása meglévő zónához; Másodlagos kiszolgálók használata
(Csak elsődleges zónák esetében) Ha az előző lépést elvégezte, adja a meglévő zónák másodlagos kiszolgálóit az NS rekordhoz, hogy a zónában mérvadók legyenek. | Egyéb mérvadó DNS-kiszolgálók kijelölése a zónában
(Választható) Telepítsen további zónákat (és DNS-kiszolgálókat) az altartományok számára, melyeket az első DNS-kiszolgálótól és annak zónáitól delegálni kíván. | Új DNS-kiszolgáló beállítása; Új elsődleges kiszolgáló beállítása
Ha elvégezte az előző lépést, adjon delegálásokat az altartományok szülőzónáihoz az előző lépés szerint.

Például az al.pelda.microsoft.com nevű új DNS-tartomány hozzáadásakor hozzá kell adni a pelda.microsoft.com zónában egy delegálást.

 Zónadelegálás létrehozása; Zónák delegálása
Adjon hozzá DNS-erőforrásrekordokat (például A, PTR, CNAME és MX) a zóna konfigurálásának befejezéséhez. | Erőforrásrekordok kezelése; Erőforrásrekord hozzáadása egy zónához; Erőforrásrekordok
Szükség szerint engedélyezze vagy tiltsa a zónák dinamikus frissítését. | Dinamikus frissítések engedélyezése; Dinamikus frissítés
(választható) A kijelölt zónák számára engedélyezze a WINS-névlekérdezést. | A WINS-névhozzárendelés használatának engedélyezése a DNS számára; A WINS-keresés integrálása; A WINS-keresés használata
(választható - haladó) Ha a frissítéseket a zónában egy másodlagos kiszolgálóra szeretné küldeni, állítson be DNS-értesítést az elsődleges kiszolgálón. | Zóna értesítési listáinak létrehozása és kezelése; A zónák és a zónaletöltés ismertetése
A DNS-konzol figyelőszolgáltatásainak (például az egyszerű és a rekurzív lekérdezéstesztelés) használatával ellenőrizze, hogy a DNS-kiszolgálók megfelelően működnek-e. | Kiszolgálók figyelése
Hárítsa el a DNS-sel kapcsolatos általános hibákat, ha ilyenek felmerülnek. | Hibaelhárítás


Feladatlista: A DNS üzembe helyezése az Active Directoryhoz

Lépés | Hivatkozás
Tekintse át az Active Directory és a DNS telepítésével és használatával kapcsolatos gyakorlati tanácsokat. | Gyakorlati tanácsok (DNS); Gyakorlati tanácsok (Active Directory)
(Ajánlott) Ismerje meg, hogyan működik a Windows 2000 DNS-kiszolgálók és az Active Directory integrálása. | Az Active Directory integrálása
(Közepes és nagyméretű vállalatok számára ajánlott) Az Active Directory névtértervek véglegesítése előtt tanulmányozza a speciális névtértervezési kérdéseket, melyek befolyásolhatják a DNS-névtér tervezését és használatát.

A hálózat tervezése előtt szerezzen be további információkat a Windows 2000 névtér tervezésével kapcsolatban a Microsoft webhelyéről vagy a Microsoft Press kiadványaiból.

 DNS-névtértervezés az Active Directoryhoz; Microsoft webhely (http://www.microsoft.com/); Microsoft webhely (http://www.microsoft.com/)
(Ajánlott) Tanulmányozza át az Active Directoryt támogató DNS-kiszolgálók telepítésére vonatkozó tervezési szempontokat. | A tervezés alapvető szempontjai
A vállalat tartománynévszabványának meghatározásával tervezze meg a névteret. | Névtér tervezése a Tartománynévrendszerhez (DNS)
Jegyeztesse be a vállalat tartománynevét az internetes tartományneveket regisztráló szervezetnél, ha szükséges. Ez a név a vállalat Interneten használt DNS-neveinek alapját képezi, de az intraneten használt nevek alapjául is szolgálhat.

Internet DNS

Név: ____________________._____

Megjegyzés

  • Csak akkor szükséges egy szülő vagy második szintű DNS-tartománynév bejegyeztetése a vállalat számára egy ezzel foglalkozó szervezetnél, ha azt az Interneten is használni kívánja.
 Az első DNS-tartománynév kiválasztása; Névválasztás; Együttműködés más szolgáltatásokkal
Tervezze meg, hogy az igényeket figyelembe véve milyen címlekérdezési és névlekérdezési zónákra osztja a DNS-tartománynévteret és a hálózati címteret. | Zóna tervezése a DNS névrendszerhez; Névlekérdezés
Tervezze meg, hogy hány DNS-kiszolgálóra van szükség és hová kell azokat a hálózaton helyezni.

Az Active Directory használatakor ne feledje, hogy alapértelmezés szerint a tartományvezérlővé kinevezendő kiszolgálók is DNS-kiszolgálóként működnek.

 Kiszolgáló tervezése DNS-szolgáltatáshoz
(Választható - haladó) Tesztelje és értékelje a kiszolgáló teljesítményét, mielőtt a kiszolgálóterveket véglegesítené. A DNS-kiszolgálók teszteléséhez használja a megfelelő teljesítmény- és eseményfigyelő eszközöket. | Kiszolgálók figyelése és optimalizálása
Tanulmányozza az áttérési és együttműködési kérdéseket, ha szükséges. | Kiszolgálók áttelepítése; Együttműködés más szolgáltatásokkal
Ha a hálózati ügyfeleknek képesnek kell lenniük külső DNS-nevek feloldására, fontolja meg, hogy érdemes-e továbbítókat beállítani és használni a hálózat DNS-kiszolgálóin. | Továbbítók használata; Továbbítók használata DNS-kiszolgálóval
Döntse el, hogyan kezeli a DNS-ügyfél feloldási konfigurációit. | Ügyfelek kezelése
Ha szükséges, hozzon létre további zónákat a hálózathoz adandó altartományokhoz. | Címkeresési zóna hozzáadása; Másodlagos zóna hozzáadása; Névkeresési zóna hozzáadása
(Választható - ajánlott) A zónabeállítások módosításával engedélyezze a dinamikus frissítéseket és módosítsa a zónatípusokat a zónatárolás integrálása érdekében az Active Directoryban. | Dinamikus frissítések engedélyezése; Zónatípus módosítása; Csak biztonságos dinamikus frissítések engedélyezése
Telepítse és konfigurálja a tartományvezérlőket (vagy esetleg a további, nem integrált DNS-kiszolgálókat) és tartományokat, ha azok a saját zónák tárolására fognak szolgálni. | Tartományvezérlő telepítése; DNS-kiszolgáló konfigurálása az Active Directoryval való használatra; DNS-kiszolgáló telepítése; Új DNS-kiszolgáló konfigurálása
Ha szükséges, adjon delegálásokat az altartományok szülőzónáihoz az előző lépés szerint.

Például az al.pelda.microsoft.com nevű új Active Directory tartomány hozzáadásakor hozzá kell adni a pelda.microsoft.com zónában egy delegálást.

 Zónadelegálás létrehozása; Zónák delegálása
(Csak szabványos elsődleges zónák esetében) Adjon új, a zónák tárolásához szükséges DNS-kiszolgálókat az NS rekordhoz az elsődleges zónában/kiszolgálón, hogy azok a zónában mérvadók legyenek. | Egyéb mérvadó DNS-kiszolgálók kijelölése a zónában
Adjon hozzá DNS-erőforrásrekordokat (például A, PTR, CNAME és MX) a zóna konfigurálásának befejezéséhez. | Erőforrásrekordok kezelése; Erőforrásrekord hozzáadása egy zónához; Erőforrásrekordok
(Választható) A kijelölt zónák számára engedélyezze a WINS-névlekérdezést. | A WINS-névhozzárendelés használatának engedélyezése a DNS számára
(Választható) Telepítsen és konfiguráljon másodlagos kiszolgálóként működő DNS-kiszolgálókat, ha szükséges. | DNS-kiszolgáló telepítése; Másodlagos kiszolgáló hozzáadása meglévő zónához; Másodlagos kiszolgálók használata
A DNS-konzol figyelőszolgáltatásainak (például az egyszerű és a rekurzív lekérdezéstesztelés) használatával ellenőrizze, hogy a DNS-kiszolgálók megfelelően működnek-e. | Kiszolgálók figyelése
Hárítsa el a DNS-sel kapcsolatos hibákat, ha ilyenek felmerülnek. | Hibaelhárítás; A DNS szolgáltatás hibaelhárítása parancssori eszközökkel


Megszokott feladatok végrehajtásának új módjai

Az alábbi táblázat összefoglalja azokat a megszokott feladatokat és Windows 2000 Server rendszerbeli végrehajtásuk módját, amelyek a DNS beépülő modul segítségével végezhetők el. A Windows NT Server korábbi verzióit használók számára a táblázat azt is megmutatja, hogyan lehetett ezeket a feladatokat a Windows NT Server 4.0-s verziójához tartozó DNS-kezelő segítségével elvégezni.

Feladat | Windows NT 4.0 operációs rendszerben | Windows 2000 operációs rendszerben
DNS-kiszolgáló telepítése erre a számítógépre. | A Control panel (Vezérlőpult) Network (Hálózat) ikonja. | Windows-összetevők varázsló. További információ a DNS-kiszolgáló telepítése című témakörben található.
DNS-kezelő elindítása. | A Start menü Administrative Tools (Felügyeleti eszközök) pontjában lévő DNS Manager (DNS-kezelő) alkalmazásra mutató parancsikon. | Nyissa meg a DNS-konzolt. További információ a DNS-konzol megnyitása című témakörben található.
A DNS-kiszolgáló elindítása és leállítása. | A Control Panel Services (Szolgáltatások) ikonja. | A DNS-kiszolgáló indításához vagy leállításához használja a DNS-konzolt. További információ a DNS-kiszolgáló elindítása és leállítása című témakörben található.
Távoli kiszolgáló hozzáadása a DNS-kezelőhöz. | A DNS Manager Server (Kiszolgáló) menüje. | Távoli kiszolgálót adja hozzá a DNS-konzolhoz. További információ a Kiszolgáló hozzáadása a DNS-konzolhoz című témakörben található.


Gyakorlati tanácsok

  • Minden DNS-kiszolgálóra felvett és ott kezelt zónához írja be a zónáért felelős személy pontos e-mail címét.

    Ezt a mezőt az alkalmazások használják a DNS-rendszergazdák különféle okokból történő értesítésére. Ez a mező többek között lekérdezési hibáknál, a lekérdezésre válaszul küldött helytelen adatoknál és biztonsági problémáknál használható. Bár a legtöbb internetes e-mail cím az elektronikus levelező alkalmazásokban egy @ jelet tartalmaz, ha egy e-mail címet ebbe a mezőbe ír, ezt a jelet egy ponttal (.) kell helyettesíteni. A „pelda@microsoft.com” helyett például a „pelda.microsoft.com” formátum a helyes.

    A zónáért felelős személy konfigurálásával kapcsolatos további tudnivalókat a Zóna SOA rekordjának módosítása című témakörben talál.

  • Aliasrekordok zónákba történő felvételével legyen óvatos.

    Kerülje a CNAME erőforrásrekordok használatát ott, ahol egy A erőforrásrekordban lévő állomásnév aliassal való ellátásához nincs rájuk szükség. Ugyanígy gondoskodjon arról is, hogy egyetlen használatban lévő aliasnevet se használjon más erőforrásrekordokban. Ha például CNAME erőforrásrekordot szeretne használni egy „alias.pelda.microsoft.com” aliasnév támogatására, a „pelda.microsoft.com” zónához más erőforrásrekordokban nem használhatja az első névre utaló címkét (ami a példában: "alias").

    A Windows 2000 alapú DNS lehetővé teszi más típusú erőforrásrekordokban (például NS, MX vagy TXT rekordban) használt névcímke megismétlését a névtérfa azonos tartományszintjén. Az RFC-dokumentumok alapján a CNAME neveknél elvárás, hogy olyan szakaszos feldolgozási sémát kövessenek, amelyben a más A erőforrásrekordokban szereplő hozzárendelt állomásnevekhez lekérdezésként küldött aliassal ellátott állomásnevet rendelnek. A CNAME nevek szabványos és elvárt hozzárendeléséhez a zónákat manuálisan kell kényszeríteni arra, hogy e művelet támogatására használt erőforrásrekordokhoz egyedi neveket használjanak.

    További tudnivalók a CNAME erőforrásrekordok című témakörben találhatók.

  • A DNS-hálózat megtervezésénél alkalmazza a szabványos irányelveket, és ahol lehet, kövesse az elsődleges gyakorlatot a DNS infrastruktúra kezelésében.

    A DNS a nevek hozzárendelésekor bizonyos hibatűrési szintet alkalmaz. Ha lehetséges, minden zónához legalább két névkiszolgáló álljon rendelkezésére.

Kiszolgálóra vonatkozó gyakorlati tanácsok

A DNS-szolgáltatást használó hálózaton működtetett kiszolgálók rutinkezelésénél és felügyeleténél a következő irányelveket érdemes figyelembe venni és a DNS üzemelésének megfelelő módon alkalmazni:

  • Ha Active Directoryt használ, a legjobb eredmény, valamint az egyszerű működtetés és hibaelhárítás biztosítása érdekében a zónáknál alkalmazzon címtárral integrált tárolást.

    A zónák integrálásával egyszerűsítheti a hálózat megtervezését. Minden Active Directory tartomány tartományvezérlője például közvetlenül megfelel egy DNS-kiszolgálónak. Ez egyszerűsítheti a tervezést és a DNS, valamint az Active Directory replikációval kapcsolatos problémáinak elhárítását, mivel mindkét topológiában ugyanazok a kiszolgáló-számítógépek vannak használatban.

    Ha a DNS-ügyfélszámítógépeken Windows 2000 fut, azok beállítása a DNS dinamikus frissítéseinek végrehajtására szintén egyszerűsíthető. Az egyes ügyfelekhez használandó elsődleges és másodlagos DNS-kiszolgálók listájának összeállításánál például csupán az ügyfelek mellett található tartományvezérlőknek megfelelő kiszolgálók IP-címeit kell használni. Ha egy ügyfél frissítése az elsődleges kiszolgálóról nem sikerül (mert a kiszolgáló nem érhető el), a frissítés megkísérelhető egy másik kiszolgálóról. Ez lehetővé teszi az ügyfél rekordjainak frissítését egy másik, a címtárral integrált DNS-zónákat betöltő kiszolgálón.

  • Ha nem használ Active Directoryt, legyen tisztában azokkal a meghibásodási pontokkal és beállítási problémákkal, amelyek a szabványos elsődleges típusú zónák dinamikus frissítésekor fellépnek.

    Ha nem használ Active Directoryt, szabványos elsődleges zónák szükségesek ahhoz, hogy a DNS-névtérben zónákat tudjon létrehozni és kezelni. Ebben az esetben az egyetlen főkiszolgálós frissítési modell érvényesül egy, a zónához elsődleges kiszolgálóként kijelölt DNS-kiszolgálóval. Csak a zónához tartozó SOA rekord tulajdonságaiban meghatározott elsődleges kiszolgáló dolgozhatja fel a zóna frissítését.

    Ezért győződjön meg arról, hogy az ügyfelek olyan elsődleges DNS-kiszolgáló használatára vannak-e beállítva, amely a frissítések feldolgozásának és átirányításának szempontjából megbízható és elérhető. Ellenkező esetben az ügyfelek nem tudják sikeresen frissíteni A vagy PTR erőforrásrekordjaikat.

  • A DNS lekérdezési forgalmának tehermentesítésére fontolja meg másodlagos vagy csak gyorsítótárazást végző kiszolgálók használatát a zónákhoz minden olyan esetben, amikor ez ésszerűnek tűnik.

    A másodlagos kiszolgálók felhasználhatók a DNS-ügyfelek tartalék kiszolgálóiként vagy az örökölt DNS-ügyfelek elsődleges DNS-kiszolgálóiként. Vegyes üzemmódú környezetek esetében ez lehetővé teszi másodlagos kiszolgálók használatát a hálózaton a DNS lekérdezési forgalmának terheléselosztó eszközeként és egyúttal a DNS használatára képes elsődleges kiszolgálók fenntartását csak azon ügyfelek számára, amelyek A és PTR erőforrásrekordjaik dinamikus regisztrálásához és frissítéséhez ezt igénylik.

    A másodlagos vagy csak gyorsítótárazást végző kiszolgálók használatára vonatkozó további tájékoztatást a következő részek tartalmazzák.

Az internetes DNS szolgáltatásra vonatkozó gyakorlati tanácsok

Az Internet Engineering Task Force (IETF) nem egy RFC-dokumentumot tett közzé, amely az internetes DNS számos fejlesztője és tervezője által ajánlott gyakorlati tanácsokat tartalmazza. E dokumentumok áttekintése igen hasznos, különösen akkor, ha egy kiterjedt DNS-struktúrát tervez, például egy olyan nagy Internet-szolgáltatót (ISP), amely támogatja a DNS-névszolgáltatás használatát.

Az internetes DNS szolgáltatásra vonatkozó gyakorlati tanácsokat tartalmazó RFC-ket a következő táblázatban találja meg.

RFC | Cím
1912 | Common DNS Operational and Configuration Errors (Gyakori hibák a DNS működtetésében és beállításában)
2182 | Selection and Operation of Secondary DNS Servers (Másodlagos DNS-kiszolgálók megválasztása és működtetése)
2219 | Use of DNS Aliases for Network Services (DNS-aliasok használata hálózati szolgáltatásokhoz)

Ezek az RFC-k megtalálhatók a Request for Comments webhelyen. Ezt a webhelyet jelenleg az Information Sciences Institute (ISI) tagjai tartják fenn, akik az RFC-ket kategóriákba sorolva teszik közzé. Az RFC-k a következő kategóriákba sorolhatók: jóváhagyott Internet-szabványok, javasolt Internet-szabványok (felülvizsgálatra tervezet formájában terjesztve), gyakorlati tanácsok az Internethez és információs (FYI) dokumentumok.

A DNS-szabványok meghatározásával leginkább összefüggő legfrissebb RFC-k megtekintéséhez kattintson az Active IETF Working Groups megfelelő webhelyeihez vezető hivatkozásokra:

  • Növekményes zónaletöltés a DNS-ben (IXFR), értesítés és dinamikus frissítés
  • DNS-műveletek
  • A DNS biztonsága

Megjegyzés


Útmutató

  • Kiszolgálók telepítése és beállítása
  • Ügyfelek telepítése és beállítása
  • Kiszolgálók kezelése
  • Kiszolgálók optimalizálása
  • Kiszolgálók figyelése
  • Zónák hozzáadása és eltávolítása
  • Zónatulajdonságok beállítása
  • Zónák kezelése
  • Erőforrásrekordok kezelése
  • Az elévülés és a kitakarítás használata
  • A DNS szolgáltatás hibaelhárítása parancssori eszközökkel


Kiszolgálók telepítése és beállítása

  • DNS-kiszolgáló telepítése
  • DNS-kiszolgáló konfigurálása az Active Directoryval való használatra
  • Új DNS-kiszolgáló konfigurálása
  • Másodlagos kiszolgáló hozzáadása meglévő zónához
  • Csak gyorsítótárazó DNS-kiszolgáló telepítése
  • A DNS-kiszolgáló által figyelt címek meghatározása
  • Továbbítók használata DNS-kiszolgálóval


DNS-kiszolgáló telepítése

  1. Nyissa meg a Windows-összetevők varázslót.
  2. Az Összetevők listában kattintson a Hálózati szolgáltatások elemre, majd a Részletek gombra.
  3. A Hálózati szolgáltatások alösszetevői listában jelölje be a Tartománynévrendszer (DNS) jelölőnégyzetet, kattintson az OK, majd a Következő gombra.
  4. A Fájlok másolása a következő helyről mezőbe írja be a Windows 2000 terjesztési fájljainak teljes elérési útját, majd kattintson az OK gombra.

    A szükséges fájlokat a rendszer a merevlemezre másolja, és a kiszolgálószoftver a rendszer újraindítása után használatba vehető.

Megjegyzések

  • A Window1s-összetevők varázsló megnyitásához kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra.

    A Vezérlőpult ablakban kattintson duplán a Programok telepítése/törlése ikonra, majd kattintson a Windows-összetevők hozzáadása/eltávolítása gombra.

  • Egyes Windows-összetevőket használat előtt konfigurálni kell. Ha ezek közül egy vagy több összetevőt telepített, de nem konfigurálta őket, kattintson a Windows-összetevők hozzáadása/eltávolítása gombra, és megjelenik a konfigurálásra szoruló összetevők listája. A Windows-összetevők varázsló elindításához kattintson az Összetevők gombra.
  • Ajánlott a számítógépet manuálisan úgy beállítani, hogy az statikus IP-címeket használjon.
  • A DNS-kiszolgáló telepítése után eldöntheti, hogyan felügyeli azt és annak zónáit. Bár lehetőség van a kiszolgáló rendszerindítási és zónafájljainak módosítására szövegszerkesztővel, ez a módszer nem ajánlott. A DNS-konzol leegyszerűsíti a fájlok karbantartását; érdemes azt használni, ha lehetséges. Ha megkezdi a konzol használatát a fájlok kezelésére, azok közvetlen szerkesztése már nem ajánlott.
  • Az Active Directoryval integrált zónák esetén a fájl alapú zónakezelés nem használható.
  • A kiszolgáló rendszerindítási és zónaadatainak szövegfájlba írásakor a Windows 2000 DNS-kiszolgálók a Berkeley Internet Name Domain (BIND) fájlformátumot használják, melyet a korábbi, BIND 4 kiszolgálók is felismernek, nem pedig a legújabb, BIND 8 formátumot.

Kapcsolódó témakörök


DNS-kiszolgáló konfigurálása az Active Directoryval való használatra

  • Az Active Directory szolgáltatás telepítését követően a rendszer felkínálja a DNS-kiszolgáló automatikus telepítését és konfigurálását.

    Az Active Directory szolgáltatás telepítéséhez használja az Active Directory telepítő varázslót. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzések

  • Ez az eljárás csak a tartományvezérlőként használt kiszolgálókra érvényes. Ha tagkiszolgálók töltik be a DNS-kiszolgáló szerepét, azok nincsenek az Active Directory szolgáltatással integrálva.
  • A Windows 2000 Resource Kit további információt tartalmaz arról, hogy a DNS szolgáltatás hogyan használható az Active Directoryval. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Új DNS-kiszolgáló beállítása

  1. Nyissa meg a DNS ablakot.
  2. Adja hozzá és csatlakoztassa a vonatkozó kiszolgálót a konzolon, ha szükséges.
  3. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • Vonatkozó DNS-kiszolgáló
  4. Kattintson a Művelet menü A kiszolgáló konfigurálása parancsára.
  5. Kövesse a DNS-kiszolgáló konfigurálása varázsló utasításait.

Megjegyzések

  • Használja az on-line súgóban található feladatlistát az új DNS-kiszolgáló telepítésekor.

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

  • Ha befejezte a kiszolgáló beállítását, szükség lehet további feladatok végrehajtására is, például a kapcsolódó zónák dinamikus frissítésének engedélyezésére, vagy erőforrásrekordok hozzáadására.
  • A 2. lépésnél csak akkor kell a DNS-kiszolgálót a konzolhoz adni, ha az nem helyileg fut a kezelésre használt számítógépen.

Kapcsolódó témakörök


Másodlagos kiszolgáló hozzáadása meglévő zónához

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • Vonatkozó DNS-kiszolgáló
  3. A Művelet menüben kattintson az Új zóna parancsra.
  4. Kövesse az Új zóna varázsló utasításait.

    A zóna hozzáadásakor válassza a Szabványos másodlagos zónatípust.

Megjegyzések

  • Annak érdekében, hogy meglévő zónához másodlagos kiszolgálót adjon, hálózati eléréssel kell rendelkeznie a kiszolgáló főkiszolgálójaként működő kiszolgálóhoz és annak zónahasználatához. A főkiszolgáló a zónaadatok forrása. Szükség esetén az ügyfelek a főkiszolgáló segítségével újítják meg a zónát és töltik le a zónafrissítéseket.
  • A 2. lépésnél lehet, hogy először a vonatkozó DNS-kiszolgálót szükséges a konzolhoz adni, ha az nem helyileg, a kezelésre használt számítógépen fut. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Csak gyorsítótárazó DNS-kiszolgáló telepítése

  1. Csak gyorsítótárazó DNS-kiszolgáló telepítéséhez telepítsen egy DNS-kiszolgálót a számítógépre.

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

  2. Ne konfigurálja a DNS-kiszolgálót (mint más esetben tenné) zónák betöltésére.
  3. Ellenőrizze, hogy a kiszolgáló gyökérútmutatói megfelelően vannak-e konfigurálva vagy frissítve.

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzések

  • A csak gyorsítótárazó DNS-kiszolgálók nem szolgálnak ki egyetlen zónát sem és nem mérvadók egy tartományban. Ezek olyan DNS-kiszolgálók, melyek az ügyfeleik rekurzív lekérdezéseinek kiszolgálása közben egy helyi kiszolgáló-gyorsítótárat építenek az előforduló nevekből. Az információ ezután az ügyfelek ismétlődő lekérdezéseinél már a gyorsítótárban rendelkezésre áll.
  • Egy csak gyorsítótárazó DNS-kiszolgáló hasznos lehet egy olyan helyen, ahol a DNS működésére helyben szükség van, de felügyeleti szempontból nem szükséges egy külön tartomány vagy zóna létrehozása a helyen.
  • Egy számítógép DNS-kiszolgálóként való használatakor ajánlott a TCP/IP protokoll manuális konfigurálása és statikus IP-címek használata.

Kapcsolódó témakörök


A DNS-kiszolgáló által figyelt címek meghatározása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Összeköttetések lapon kattintson a Csak a következő IP-címeken választógombra.
  5. Az IP-cím mezőbe írja be a használni kívánt DNS-kiszolgáló IP-címét, majd kattintson a Hozzáadás gombra.
  6. Szükség esetén ismételje meg az előző lépést, és adja meg újabb kiszolgálók IP-címeit, melyeket a DNS-kiszolgálóval kíván használni.

    Ha törölni szeretne egy IP-címet a listából, kattintson a megfelelő címre, majd az Eltávolítás gombra.

Megjegyzések

  • Alapértelmezés szerint a DNS szolgáltatás a kiszolgáló minden beállított IP-címén figyeli a DNS-üzeneteket. Ha a kiszolgáló összeköttetéseit korlátozni kívánja, legalább egy IP-címet a listához kell adni.
  • Az itt hozzáadott kiszolgálói IP-címeket statikusan kell kezelni. Ha később itt megadott címeket módosít vagy távolít el a kiszolgálón kezelt TCP/IP-konfigurációkból, frissítse a listát a változásoknak megfelelően.
  • Ha frissíti vagy módosítja a korlátozott összeköttetések listáját, az új lista alkalmazásához le kell állítani, majd újra kell indítani a DNS-kiszolgálót.

Kapcsolódó témakörök


Továbbítók használata DNS-kiszolgálóval

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Továbbítók fülre.
  5. Jelölje be a Továbbítók engedélyezése jelölőnégyzetet.
  6. Ha azt szeretné, hogy a DNS-kiszolgáló csak használja a továbbítókat, jelölje be a Rekurzió használata nélkül jelölőnégyzetet.
  7. Adja hozzá az egyéb, a kiszolgáló továbbítójaként működő DNS-kiszolgálók IP-címeit.
  8. A Továbbítási kérelem elévülése (mp) beállítás értéke módosítható, ha a Rekurzió használata nélkül jelölőnégyzet nincs bejelölve.

Megjegyzések

  • A továbbítók olyan DNS-kiszolgálók, melyek a többi DNS-kiszolgálónak nyújtanak rekurzív szolgáltatást. Ha továbbítók vannak megadva, azok feladata a kiszolgáló által megválaszolatlan DNS-nevek feloldása.

Kapcsolódó témakörök


Ügyfelek telepítése és beállítása

  • A DNS konfigurálása statikus ügyfelekhez
  • A DNS engedélyezése DHCP-engedélyezett ügyfelek számára
  • Ügyfélszámítógép elsődleges DNS-utótagjának beállítása
  • Az ügyfél névhozzárendelő gyorsítótárának előtöltése


A DNS konfigurálása statikus ügyfelekhez

  • Ha a DNS szolgáltatást statikus IP-címet használó ügyfelekhez kívánja konfigurálni, valószínűleg be kell állítania a következőket:
    1. DNS-állomásnév (vagy -nevek) az ügyfélszámítógép számára.
    2. Elsődleges és másodlagos DNS-kiszolgálók, melyek segítenek a DNS-tartománynevek hozzárendelésében az ügyfélnek.
    3. Lista a DNS-utótagokról, melyeket a nem minősített tartománynevekhez kell fűzni kiegészítésül, és az ügyfél által indított DNS-lekérdezések keresésénél és végrehajtásánál használatosak.
    4. A kapcsolatfüggő dinamikus frissítés és regisztráció (például annak beállítása, hogy az ügyfélre telepített hálózati csatolók dinamikusan regisztráltassák-e a beállított IP-címüket egy DNS-kiszolgálón).

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzés

  • Ha olyan statikus ügyfelekhez kívánja konfigurálni a DNS szolgáltatást, melyek nem Windows 2000 rendszert futtatnak, olvassa el a TCP/IP vagy DNS dokumentációját, melyet a forgalmazó bocsát rendelkezésre.

Kapcsolódó témakörök


A DNS engedélyezése DHCP-engedélyezett ügyfelek számára

  • Ha olyan ügyfelekhez kívánja konfigurálni a DNS szolgáltatást, melyek DHCP-kiszolgáló által biztosított dinamikus IP-címet használnak, általában a következőket kell beállítania a DHCP-kiszolgálón vagy a megfelelő ügyfélen:
    1. DNS-állomásnév (vagy -nevek) az ügyfélszámítógép számára.

      A Windows 2000 DHCP ügyfelek esetében ezt az ügyfélszámítógépen kell beállítani, vagy a felügyelet nélküli telepítés során hozzárendelni.

    2. Elsődleges és másodlagos DNS-kiszolgálók, melyek segítenek a DNS-tartománynevek hozzárendelésében az ügyfélnek.

      Windows 2000 DHCP-ügyfelek esetében ez a DNS-kiszolgáló szolgáltatás beállítás (6. lehetőség) hozzárendelésével és egy olyan lista biztosításával állítható be, mely az ügyfél által használható DNS-kiszolgálók sorba rendezett IP-címeit tartalmazza.

    3. A DNS-utótagok listája, melyeket az ügyfél által indított DNS-lekérdezések keresésénél és végrehajtásánál használt nem minősített tartománynevekhez kell fűzni.

      A Windows 2000 DHCP-ügyfelek esetében ez a DNS-tartománynév beállítás (15. lehetőség) hozzárendelésével és egy olyan egyszeres DNS-utótag biztosításával állítható be, melyet az ügyfél a kereséseknél a nevekhez fűz. További DNS-utótagok beállításához konfigurálja kézileg a TCP/IP protokoll DNS-beállításait.

    4. A kapcsolatfüggő dinamikus frissítés és regisztráció (például annak beállítása, hogy az ügyfélre telepített hálózati csatolók dinamikusan regisztráltassák-e a beállított IP-címüket egy DNS-kiszolgálón).

      A Windows 2000 DHCP-ügyfelek esetében alapértelmezés szerint az ügyfelek regisztrálják beállított IP-címeiket egy DNS-kiszolgálón. Az ügyfél viselkedésének módosításához konfigurálja kézileg a TCP/IP protokoll DNS-beállításait.

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzés

  • Ha olyan DHCP-ügyfelekhez kívánja konfigurálni a DNS szolgáltatást, melyek nem Windows 2000 rendszert futtatnak, olvassa el a TCP/IP vagy DNS dokumentációját, melyet a forgalmazó bocsát rendelkezésre.

Kapcsolódó témakörök


Ügyfélszámítógép elsődleges DNS-utótagjának beállítása

  1. Nyissa meg a Rendszer ablakot a Vezérlőpulton.
  2. Kattintson a Hálózati azonosítás fülre.

    Ez a lap jeleníti meg a számítógépnevet, a munkacsoportot vagy tartományt, amelyhez tartozik, és a számítógép rövid leírását.

  3. Kattintson a Tulajdonságok, majd a Részletek gombra.
  4. A DNS-utótag és NetBIOS számítógépnév területen végezze el a következő műveleteket:

    A számítógép elsődleges DNS-utótagja mezőben adja meg a szóban forgó számítógép nevéhez fűzendő DNS-utótagot. A kettő együtt a teljesen minősített tartománynevet (FQDN) alkotja.

  5. A módosítások elvégzése után indítsa újra a számítógépet az új DNS tartománynévvel való inicializáláshoz.
  6. Ha a számítógép előzőleg Windows 2000 DNS-kiszolgálóként lett telepítve és beállítva, ellenőrizze, hogy a zónahitelesítő rekordokat a DNS-kiszolgáló szolgáltatás frissítette-e.

    Ezek közé tartozik a SOA rekord és az NS rekord, melyek helyettesítik az új FQDN nevet az addig használt egyszeres címkenév lecserélésére. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzések

  • A Rendszer ablak megnyitásához mutasson a Start menü Beállítások pontjára, majd kattintson a Vezérlőpult parancsra. A Vezérlőpulton kattintson duplán a Rendszer ikonra.
  • A DNS-utótag nem Windows 2000 rendszert futtató ügyfelekhez való konfigurálásáról a TCP/IP vagy a DNS dokumentációjában találhat további információt, melyet az adott forgalmazó bocsát rendelkezésre az ügyfélhez.
  • Ha úgy állít be egy elsődleges DNS-utótagot, hogy annak neve eltér attól az Active Directory tartománytól, melyhez a számítógép tartozik, további konfigurálásra van szükség. A tartomány- és számítógépfiókok elnevezési lehetőségeiről további információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Az ügyfél névhozzárendelő gyorsítótárának előtöltése

  1. Az ügyfélszámítógépen nyissa meg a Parancssor ablakot.
  2. A parancssorba írja be a következő parancsot:

    notepad %rendszergyökér%\system32\drivers\etc\hosts

    A Hosts fájl megnyílik a Jegyzettömb programban.

  3. A fájl alapértelmezés szerinti bejegyzésének mintájára (a helyi állomás hozzárendelése a 127.0.0.1 visszacsatolt IP-címhez) adjon soronként további állomásnév-cím hozzárendeléseket a listához, melyeket az ügyfél névhozzárendelő gyorsítótárába kíván előre tölteni. Példa a hozzáadásra:

    10.0.0.1 a-allomas a-allomas.pelda.microsoft.com

    A Host fájl formázásával és egyéb megkötésekkel kapcsolatos információk a megjegyzésekben olvashatók.

  4. A Fájl menüben kattintson a Mentés, majd a Kilépés parancsra.
  5. Lehetőség van a névhozzárendelő gyorsítótár tartalmának megtekintésére is, ha ellenőrizni kívánja, hogy az a módosításokkal frissítve lett-e.

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzések

  • A Parancssor megnyitásához kattintson a Start gombra, mutasson a Programok pontra, majd kattintson a Parancssor parancsra.
  • A Jegyzettömb megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Jegyzettömb parancsra.
  • A hozzáadott bejegyzések megválaszolása először a helyi névhozzárendelő gyorsítótár alapján történik, és nem kerülnek a DNS rendszerhez, ha helyi kérés érkezik a nevek állomás (A) típusú erőforrásrekordokhoz való rendelésére.
  • A Hosts fájl minden sora egy IP-cím, melyet egy vagy több állomásnév követ. Hozzáadhat a listához például egy olyan sort, mely egy IP-címet (10.0.0.1) több DNS-állomásnévhez is rendel:

    10.0.0.1 a-allomas a-allomas.pelda.microsoft.com b-allomas.pelda2.microsoft.com

    Ugyanígy egy DNS-állomásnév is tartozhat több IP-címhez, ha a hozzárendelt címek külön sorban szerepelnek. Egy többhelyű vagy több címmel rendelkező DNS-számítógép esetén például az alábbi sorokat adhatja a fájlhoz:

    10.0.0.1 a-allomas.pelda.microsoft.com
    10.0.0.2 a-allomas.pelda.microsoft.com
    10.0.0.3 a-allomas.pelda.microsoft.com

  • Ha többször előforduló nevek vagy IP-címek vannak a fájlban, a DNS-ügyfél szolgáltatásnak futnia kell ahhoz, hogy a lekérdezések megválaszolásakor a válasz tartalmazza az összes bejegyzést. Ha a DNS-ügyfél szolgáltatás nem fut, csak a fájl első bejegyzése kerül a lekérdezésekre adott válaszokba.

Kapcsolódó témakörök


Kiszolgálók kezelése

  • A DNS-konzol megnyitása
  • DNS-kiszolgáló indítása és leállítása
  • Kiszolgáló hozzáadása a DNS-konzolhoz
  • Kiszolgáló eltávolítása a DNS-konzolról
  • Kiszolgáló adatfájljainak kézi frissítése
  • DNS-kiszolgáló rendszerindítási módszerének módosítása
  • DNS-kiszolgáló névellenőrzési módszerének módosítása


A DNS-konzol megnyitása

  • Nyissa meg a DNS ablakot.

Megjegyzések

  • A DNS-konzol egy felügyeleti eszköz, amely a Windows 2000 DNS-kiszolgálók kezelésére szolgál. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


DNS-kiszolgáló indítása és leállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • Vonatkozó DNS-kiszolgáló
  3. A Művelet menüben mutasson a Feladatok pontra, majd kattintson az alábbiak egyikére:
    • A szolgáltatás indításához kattintson az Indítás parancsra.
    • A szolgáltatás leállításához kattintson a Stop parancsra.
    • A szolgáltatás megszakításához kattintson a Felfüggesztés parancsra.
    • A szolgáltatás leállításához, majd automatikus újraindításához kattintson az Újraindítás parancsra.

Megjegyzések

  • A DNS-kiszolgáló szolgáltatás egy választható összetevő a Windows 2000 Server rendszerhez. Ha a kezelt számítógépen ez a szolgáltatás nem volt előzetesen telepítve, nem jelenik meg a felsorolt szolgáltatások között.
  • Ha a szolgáltatást felfüggesztette vagy leállította, a Művelet menü Minden feladat pontjának Folytatás parancsával a szolgáltatást azonnal újraindíthatja.
  • E feladatok többségét a parancssorban is elvégezheti az alábbi parancsok használatával:
    • net start dns
    • net stop dns
    • net pause dns
    • net continue dns

Kapcsolódó témakörök


Kiszolgáló hozzáadása a DNS-konzolhoz

  1. Nyissa meg a DNS ablakot.
  2. A Művelet menüben kattintson a Kapcsolódás számítógéphez parancsra.
  3. A Célszámítógép kiválasztása listából válassza a következők valamelyikét:
    • Ezen a számítógépen, ha a kiszolgáló, amelyhez csatlakozni, és amelyet kezelni kíván a kezeléshez használt számítógépen fut.
    • A következő számítógépen, ha a kiszolgáló, amelyhez csatlakozni, és amelyet kezelni kíván egy távoli számítógépen fut.

    Ha egy távoli kiszolgálóhoz csatlakozik, adja meg a DNS-számítógépnevét vagy az IP-címét.

  4. Jelölje be a Kapcsolódás a megadott számítógéphez most jelölőnégyzetet, majd kattintson az OK gombra.

Megjegyzések

  • A DNS-konzol egy felügyeleti eszköz, amely csak Windows 2000 DNS-kiszolgálók kezelésére szolgál. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Kiszolgáló eltávolítása a DNS-konzolról

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. A Művelet menüben kattintson a Törlés parancsra.
  4. Amikor a rendszer a kiszolgáló törlésének jóváhagyását kéri, kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


Kiszolgáló adatfájljainak kézi frissítése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menüben a Kiszolgálói adatfájlok frissítése parancsra.

Megjegyzések

  • Szabványos elsődleges zónák esetében az eljárással a DNS-kiszolgáló azonnal a zónafájlba írja a memóriában tárolt módosításokat. Szokásos esetben a rendszer a módosításokat csak az előre definiált frissítési időközönként, vagy a DNS-kiszolgáló leállítása esetén írja lemezre.
  • Az Active Directoryval integrált zónáknál az eljárás nem alkalmazható, mivel a címtárral integrált zónák adataiban végzett módosítások többsége azonnal visszaíródik a címtárral integrált zóna megfelelő adatbázisába.

Kapcsolódó témakörök


DNS-kiszolgáló indítási módszerének módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Zónaadatok betöltése induláskor listából jelölje ki a Rendszerleíró adatbázisból, a Fájlból vagy az Active Directoryból és rendszerleíró adatbázisból elemet.

Megjegyzések

  • Alapértelmezés szerint a Windows 2000 DNS-kiszolgálók a Windows 2000 rendszerleíró adatbázisában tárolt információk alapján inicializálják a szolgáltatást és töltik a kiszolgálóra a zónaadatokat. Kiegészítő lehetőségként a DNS-kiszolgáló beállítható úgy is, hogy fájlból induljon, vagy (Active Directory környezetben) kiegészítheti a helyi rendszerleíró adatokat a címtárba integrált zónákról lekért és az Active Directory adatbázisában tárolt zónaadatokkal. Ha a fájlmódszert használja, egy Boot nevű szövegfájlra van szükség az adott számítógép \Winnt\System32\Dns mappájában.

Kapcsolódó témakörök


DNS-kiszolgáló névellenőrzési módszerének módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Névellenőrzés listában jelölje ki a Nem RFC (ANSI), a Szigorúan RFC (ANSI) vagy a Több bájtos (UTF8) elemet.

Megjegyzések

  • A Windows 2000 DNS-kiszolgálók három lehetséges módszert támogatnak a kiszolgáló normális működése közben kapott és feldolgozott nevek ellenőrzésére:
    • Szigorúan RFC (ANSI) Ez a módszer szigorúan megköveteli a kiszolgáló által feldolgozott nevek esetében az RFC szabványnak megfelelő elnevezési szabályok betartását. Az RFC szabványnak meg nem felelő neveket a kiszolgáló hibás adatként kezeli.
    • Nem RFC (ANSI) Ez a módszer lehetővé teszi az RFC szabványnak meg nem felelő nevek használatát a DNS-kiszolgálón, például az ASCII-karakterekből álló, de az RFC szabvány állomáselnevezési szabályait nem követő nevek használatát.
    • Több bájtos (UTF8) Ez a módszer megengedi a 8 bites Unicode fordítási kódolássémát használó neveket, mely egy DNS-kiszolgálókra javasolt RFC-tervezet.

    Alapértelmezés szerint a kiszolgálók a Nem RFC (ANSI) beállítással ellenőrzik a neveket. Ez a beállítás szabad névellenőrzést tesz lehetővé, és a kiszolgálónak megengedi bármilyen DNS-név feldolgozását, amely szabványos ANSI vagy ASCII kódolású karaktereket használ, ily módon a legnagyobb fokú együttműködést biztosítja a DNS-kiszolgálók és az állomásrendszerek között.

Kapcsolódó témakörök


Kiszolgálók optimalizálása

  • Gyors letöltési formátum engedélyezése vagy tiltása a zónaletöltések során
  • Zóna letöltésének tiltása hibás adatok érkezése esetén
  • Ciklikus multiplexelés tiltása többhelyű nevek esetében
  • Helyi alhálózati rangsorolás tiltása többhelyű nevek esetében
  • A kiszolgáló alapértelmezett beállításainak visszaállítása
  • Rekurzió letiltása DNS-kiszolgálón
  • A DNS-kiszolgáló gyökérútmutatóinak frissítése
  • Kiszolgáló gyorsítótárának védelme névszennyezés ellen
  • A kiszolgáló névgyorsítótárának ürítése


Gyors letöltési formátum engedélyezése vagy tiltása a zónaletöltések során

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Kiszolgáló beállításai listában jelölje be a BIND másodlagos jelölőnégyzetet, majd kattintson az OK gombra.

Megjegyzések

  • Ez a beállítás csak a Windows 2000 DNS-kiszolgálók és más típusú DNS-kiszolgálók közötti zónaletöltések optimalizálására szolgál. A Windows alapú DNS-kiszolgálók között mindig a gyors átviteli formátum használatos a zónaletöltéseknél.
  • A Berkeley Internet Name Domain (BIND) kiszolgálómegvalósítást futtató DNS-kiszolgálók 4.9.4-es verziónal korábbi változat esetén nem támogatják a gyors átviteli formátumot. Csak akkor engedélyezze ezt a beállítást, ha 4.9.4-es vagy újabb verziójú BIND-kiszolgálókra tölt le zónát.

Kapcsolódó témakörök


Zóna letöltésének tiltása hibás adatok érkezése esetén

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Kiszolgáló beállításai területen jelölje be a Rossz zónaadat esetén hiba a betöltéskor jelölőnégyzetet, majd kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


Ciklikus multiplexelés tiltása többhelyű nevek esetében

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Kiszolgáló beállításai területen törölje a jelölést a Ciklikus multiplexelés engedélyezése jelölőnégyzetből, majd kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


Helyi alhálózati rangsorolás tiltása többhelyű nevek esetében

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Kiszolgáló beállításai területen törölje a jelölést a Hálózati maszk elrendezésének engedélyezése jelölőnégyzetből, majd kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


A kiszolgáló alapértelmezett beállításainak visszaállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. Kattintson az Alapértelmezések visszaállítása, majd az OK gombra.

Megjegyzés

Kapcsolódó témakörök


Rekurzió letiltása DNS-kiszolgálón

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Kiszolgáló beállításai területen jelölje be a Rekurzió tiltása jelölőnégyzetet, majd kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


A DNS-kiszolgáló gyökérútmutatóinak frissítése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Gyökérútmutató fülre.
  5. Módosítsa a kiszolgáló gyökérútmutatóit az alábbiak szerint:
    • Ha gyökérkiszolgálót szeretne a listához adni, kattintson a Hozzáadás gombra, majd adja meg a listához adandó kiszolgáló nevét és IP-címét.
    • Ha egy listában szereplő gyökérkiszolgálót módosítani szeretne, kattintson a Szerkesztés gombra, majd adja meg a módosítandó kiszolgáló nevét és IP-címét.
    • Ha törölni szeretne egy gyökérkiszolgálót a listából, jelölje ki, majd kattintson az Eltávolítás gombra.

Megjegyzés

Kapcsolódó témakörök


Kiszolgáló gyorsítótárának védelme névszennyezés ellen

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. A Kiszolgáló beállításai területen jelölje be a Biztonságos gyorsítótár a szennyeződés ellen jelölőnégyzetet, majd kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


A kiszolgáló névgyorsítótárának ürítése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Gyorsítótár törlése parancsára.

Megjegyzés

Kapcsolódó témakörök


Kiszolgálók figyelése

  • DNS-kiszolgáló hibanaplózási beállításainak megadása és engedélyezése
  • DNS-kiszolgáló hibakeresési naplózásának letiltása
  • Egyszerű lekérdezés tesztelése DNS-kiszolgálón
  • Rekurzív lekérdezés tesztelése DNS-kiszolgálón
  • DNS-kiszolgáló automatikus lekérdezéstesztelésének engedélyezése
  • DNS-kiszolgáló rendszeresemény-naplójának megtekintése
  • DNS-kiszolgáló hibakeresési naplójának megtekintése


DNS-kiszolgáló hibanaplózási beállításainak megadása és engedélyezése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Naplózás fülre.
  5. Jelölje be azokat az eseményeket, amelyeket a DNS-kiszolgáló hibakeresési naplójában rögzíteni kíván, majd kattintson az OK gombra.

Megjegyzések

  • A hibakeresési naplózás csökkenti a DNS-kiszolgáló teljesítményét, ezért alapértelmezés szerint minden hibakeresési naplózási lehetőség le van tiltva.

Kapcsolódó témakörök


DNS-kiszolgáló hibakeresési naplózásának letiltása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Naplózás fülre.
  5. Kattintson az Alapértelmezések visszaállítása, majd az OK gombra.

Megjegyzés

Kapcsolódó témakörök


Egyszerű lekérdezés tesztelése DNS-kiszolgálón

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Figyelés fülre.
  5. Jelölje be A DNS-kiszolgáló egyszerű lekérdezése jelölőnégyzetet.
  6. Kattintson a Teszt most gombra.

Megjegyzések

  • A lekérdezési teszt eredménye a Teszteredmények mezőben jelenik meg.

Kapcsolódó témakörök


Rekurzív lekérdezés tesztelése DNS-kiszolgálón

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Figyelés fülre.
  5. Jelölje be Más DNS-kiszolgálók rekurzív lekérdezése jelölőnégyzetet.
  6. Kattintson a Teszt most gombra.

Megjegyzések

  • A lekérdezési teszt eredményei a Teszteredmények listában jelennek meg.

Kapcsolódó témakörök


DNS-kiszolgáló automatikus lekérdezéstesztelésének engedélyezése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Figyelés fülre.
  5. Jelölje ki az automatikus lekérdezéstesztelés során használni kívánt teszt típusát. Az alábbiak közül lehet választani:
    1. A DNS-kiszolgáló egyszerű lekérdezése
    2. Más DNS-kiszolgálók rekurzív lekérdezése
    3. Mindkét lekérdezési teszttípus
  6. Jelölje be az Automatikus teszt végrehajtása a következő időközönként jelölőnégyzetet.
  7. Adja meg a megfelelő beállítást a Tesztelési időköz mezőben.

    A rendszer az itt megadott értéknek megfelelő gyakorisággal hajtja végre a kiválasztott lekérdezési teszteket. Az alapértelmezés szerinti lekérdezési időköz 1 perc.

Megjegyzések

  • Az automatikus lekérdezési tesztek eredménye a Teszteredmények mezőben jelenik meg. és minden egyes teszt után frissül.

Kapcsolódó témakörök


DNS-kiszolgáló rendszeresemény-naplójának megtekintése

  1. Nyissa meg az Eseménynapló ablakot.
  2. Ha a DNS-kiszolgáló, melynek naplóját meg kívánja tekinteni, egy másik számítógépen fut, az alábbiak szerint járjon el:
    1. A Művelet menüben kattintson a Csatlakozás más számítógéphez parancsra.
    2. Válassza a Másik számítógép beállítást, és adja meg a távoli számítógép nevét vagy IP-címét.
  3. Kattintson a konzolfán a DNS-kiszolgáló elemre.
  4. A részleteket megjelenítő ablaktáblában megtekintheti a DNS-kiszolgáló szolgáltatás által naplózott események listáját.

    Egy esemény további részleteinek megtekintéséhez kattintson duplán az eseményre.

Megjegyzés

  • Az Eseménynapló megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Eseménynapló parancsra.

Kapcsolódó témakörök


DNS-kiszolgáló hibakeresési naplójának megtekintése

  1. Állítsa le a DNS-kiszolgáló szolgáltatást.

    További információt a Kapcsolódó témakörök hivatkozás alatt talál.

  2. Nyissa meg a WordPad programot.
  3. A Fájl menüben kattintson a Megnyitás parancsra.
  4. A Megnyitás párbeszédpanel Fájlnév mezőjében adja meg a DNS-kiszolgáló hibakeresési naplófájljának elérési útját.

    Ha a kiszolgáló helyileg fut, a fájl és elérési útja alapértelmezés szerint a következő:

    %rendszergyökér%\System32\Dns\Dns.log

  5. Ha megadta a helyes elérési utat és fájlnevet, kattintson a Megnyitás gombra a naplófájl megtekintéséhez.

Megjegyzések

  • A WordPad program megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a WordPad parancsra.
  • Alapértelmezés szerint a Dns.log fájl üres, ha előzőleg nem engedélyezett hibakeresési naplózást.
  • A hibakeresési naplózás csökkenti a DNS-kiszolgáló teljesítményét, ezért csak átmenetileg ajánlott engedélyezni.

Kapcsolódó témakörök


Zónák hozzáadása és eltávolítása

  • Címkeresési zóna hozzáadása
  • Névkeresési zóna hozzáadása
  • Zóna törlése
  • Zóna felfüggesztése
  • Zóna indítása


Címkeresési zóna hozzáadása

  1. Nyissa meg a DNS ablakot.
  2. Kattintson a konzolfa Címkeresési zónák elemére.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák
  3. A Művelet menüben kattintson az Új zóna parancsra.
  4. Az Új zóna varázslóban kövesse a megjelenő utasításokat az új címkeresési zóna létrehozásához.

Megjegyzés

Kapcsolódó témakörök


Névkeresési zóna hozzáadása

  1. Nyissa meg a DNS ablakot.
  2. Kattintson a konzolfa Névkeresési zónák elemére.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Névkeresési zónák
  3. A Művelet menüben kattintson az Új zóna parancsra.
  4. Az Új zóna varázslóban kövesse a megjelenő utasításokat az új névkeresési zóna létrehozásához.

Megjegyzés

Kapcsolódó témakörök


Zóna törlése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A Művelet menüben kattintson a Törlés parancsra.
  4. Amikor a rendszer a zóna törlésének jóváhagyását kéri, kattintson az OK gombra.

Figyelem!

  • Az Active Directoryval integrált zóna törlésekor az összes olyan Windows 2000 DNS-kiszolgálón törlődik a zóna, melyek ugyanazt a címtárat használják a zónaadatok letöltésére és helyi frissítésére.

Megjegyzések

  • Ez az eljárás leggyakrabban egy zóna másodlagos példányának törlésére használatos, bár használható elsődleges zóna törlésére is.
  • Egy szabványos elsődleges zóna törlése általában nem szükséges, hacsak nem alakítja át a DNS névteret, és a zónára nincs szükség. Legtöbb esetben a zóna módosítása elvégezhető a zónatípus megváltoztatásával. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Zóna felfüggesztése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. A vonatkozó zóna tulajdonságai párbeszédpanel Általános lapján kattintson a Felfüggesztés, majd az OK gombra.

Megjegyzések

  • Alapértelmezés szerint a zónák létrehozás vagy betöltés után indulnak el. Ha felfüggeszt egy zónát, akkor ahhoz, hogy ügyfeleket szolgálhasson ki vagy zónafrissítéseket végezhessen, a zónát újra kell indítani.

Kapcsolódó témakörök


Zóna indítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. A vonatkozó zóna tulajdonságai párbeszédpanel Általános lapján kattintson az Indítás, majd az OK gombra.

Megjegyzések

  • Alapértelmezés szerint a zónák létrehozás vagy betöltés után indulnak el. Csak a korábban felfüggesztett zónákat kell újraindítani.

Kapcsolódó témakörök


Zónatulajdonságok beállítása

  • Zóna típusának megváltoztatása
  • Zónafájl nevének módosítása
  • Zóna SOA rekordjának módosítása
  • Zóna értesítési listáinak létrehozása és kezelése
  • Zónadelegálás létrehozása
  • Egyéb mérvadó DNS-kiszolgálók kijelölése a zónában
  • Másodlagos zóna főkiszolgálójának frissítése
  • A WINS-névhozzárendelés használatának engedélyezése a DNS számára


Zóna típusának megváltoztatása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon figyelje meg az aktuális zónatípust, majd kattintson a Módosítás gombra.
  5. A Zóna típusának megváltoztatása mezőben jelöljön ki egy másik zónatípust, majd kattintson az OK gombra.

Megjegyzések

  • Választhatja a Szabványos elsődleges vagy a Szabványos másodlagos típust minden zóna esetén. Ha a Szabványos másodlagos zónatípust választja, meg kell adni egy másik DNS-kiszolgáló IP-címét, ahonnan a zóna frissített információi fognak érkezni.
  • Ha a DNS-kiszolgáló számítógép tartományvezérlőként működik, a zóna típusának megváltoztatásakor választható az Active Directoryval integrált beállítás is. Ez a beállítási lehetőség egyébként nem érhető el. Amikor ez a zónatípus van kijelölve, a zónaadatokat az Active Directory adatbázisának részeként tárolja és replikálja a rendszer.
  • Egy zóna típusának másodlagosról elsődlegesre való módosítása a zóna más tevékenységeit is befolyásolhatja, beleértve a dinamikus frissítések és zónaletöltések kezelését, valamint a DNS értesítési listák használatát más kiszolgálók értesítésére a zónában történt változásokról. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Zónafájl nevének módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon a Zónafájl neve mezőbe írja be az új fájlnevet a zónához.
  5. Kattintson az OK gombra, ha végzett az új zónafájlnév bevitelével.

Figyelem!

  • Ha módosította a zónafájl nevét, ne felejtse el frissíteni a Zónafájl neve beállítást a többi DNS-kiszolgálón, melyek a zónát karbantartják. Enélkül a soron következő zónaletöltések és -frissítések hibásak lehetnek. Ez a következő esetekben fordulhat elő:
    • A szóban forgó kiszolgálón a zóna típusa elsődleges.
    • A szóban forgó kiszolgálón a zóna típusa másodlagos, és a kiszolgáló a zóna forrás- vagy főkiszolgálójaként működik más, a zóna másodlagos példányát tároló DNS-kiszolgálók felé.

Megjegyzések

  • A zónafájl neve módosul, nem a zóna neve. A Windows Intéző használatával megtekintheti, vagy ellenőrizheti a zónafájl új nevét.
  • A zónafájlnév nem használatos az Active Directoryval integrált zónák esetében, mert ezek a zónák az Active Directory adatbázisában tárolják a zónaadatokat, nem egy szövegfájlban a DNS-kiszolgálóként működő számítógépen.

Kapcsolódó témakörök


Zóna SOA rekordjának módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a SOA rekord fülre.
  5. Igény szerint módosítsa a SOA rekord tulajdonságait.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

  6. Ha befejezte a módosítást, kattintson az OK gombra.

Megjegyzések

  • A SOA rekord beállításai befolyásolják a kiszolgálók közötti zónaletöltések módját. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Zóna értesítési listáinak létrehozása és kezelése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Zónaletöltés fülre.
  5. Kattintson az Értesítés gombra.
  6. Győződjön meg róla, hogy az Automatikus értesítés jelölőnégyzet be van jelölve.
  7. Jelölje ki a módszert, melyet használni kíván a többi DNS-kiszolgálót a zónában történt változásokról értesítő lista létrehozására. A lehetőségek a következők:
    1. Használja az alapértelmezés szerinti A Névkiszolgálók fülön megadott kiszolgálók esetén beállítást, ha csak azokat a kiszolgálókat akarja az értesítési listába felvenni, melyek IP-címe a Névkiszolgálók lapon fel van tüntetve.
    2. Válassza A következő kiszolgálók esetén beállítást, ha módosítani szeretné az értesítési listát.
  8. Ha az előző lépésben A következő kiszolgálók esetén beállítást jelölte ki, tetszés szerint adjon az értesítési listához neveket, vagy távolítson el abból:
    • Kiszolgálót úgy adhat az értesítési listához, hogy beírja az IP-címét az IP-cím mezőbe, és a Hozzáadás gombra kattint.
    • Kiszolgálót úgy távolíthat el az értesítési listáról, hogy a listában kijelöli a kiszolgáló IP-címét, majd az Eltávolítás gombra kattint.

Megjegyzések

  • Az értesítési lista tulajdonságai csak az elsődleges zónákban módosíthatók. Másodlagos zónák esetén a tulajdonságok írásvédettek. A DNS-értesítés a DNS szabvány egyik bővítése, melyet az 1996-os számú, „A Mechanism for Prompt Notification of Zone Changes” (A zónaváltozások gyors közlésének mechanizmusa) RFC- dokumentum ismertet.

Kapcsolódó témakörök


Zónadelegálás létrehozása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó altartományra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
    • vonatkozó tartomány (ha használatban van)
    • vonatkozó altartomány
  3. A Művelet menüben kattintson az Új delegálás parancsra.
  4. Az Új delegálás varázslóban kövesse a megjelenő utasításokat az új delegált tartomány létrehozásához.

Megjegyzések

  • Minden tartományt (vagy altartományt), mely a vonatkozó zónadelegáció részeként jelenik meg, az aktuális zónában létre kell hozni, mielőtt az itt leírt delegálást elvégezné. Szükség esetén használja a DNS-konzolt, hogy az eljárás előtt tartományokat adjon a zónához. További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Kapcsolódó témakörök


Egyéb mérvadó DNS-kiszolgálók kijelölése a zónában

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Névkiszolgálók fülre.
  5. Kattintson a Hozzáadás gombra.
  6. Adja meg további DNS-kiszolgálók IP-címét, majd a Hozzáadás gombra kattintva adja őket a listához.

    A zónában mérvadó kiszolgálók listáját akár a kiszolgáló IP-címe, akár annak DNS-neve megadásával bővítheti. Nevek bevitelekor kattintson a Címfeloldás gombra, így a kiszolgáló nevéhez a rendszer hozzárendeli a megfelelő IP-címet, mielőtt a listához adná.

Megjegyzések

  • A leírt eljárással megadott DNS-kiszolgálók hozzáadódnak azokhoz a kiszolgálói IP-címekhez, melyeket a zóna meglévő névkiszolgálói (NS) erőforrásrekordjai használhatnak. Ezt az eljárást általában csak az elsődleges zónában kell elvégezni, amikor másodlagos kiszolgálóként működő DNS-kiszolgálókat vesz fel, illetve annak megadásakor, hogy mérvadók-e a kiszolgálók a zónaadatok lekérdezésének megválaszolásakor.
  • A Windows 2000 DNS-kiszolgálók minden új, kiszolgálóhoz adott elsődleges zónatípushoz automatikusan hozzáadják az NS erőforrásrekordot és elvégzik a kezdeti beállítását.

Kapcsolódó témakörök


Másodlagos zóna főkiszolgálójának frissítése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó másodlagos zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon az IP-cím mezőben adja meg az új főkiszolgáló IP-címét, majd a Hozzáadás gombra kattintva frissítse a listát az új címmel.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

Megjegyzés

Kapcsolódó témakörök


A WINS-névhozzárendelés használatának engedélyezése a DNS számára

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a megfelelő fülre:
    • A WINS fülre, ha a vonatkozó zóna címkeresési zóna.
    • A WINS-R fülre, ha a vonatkozó zóna névkeresési zóna.
  5. Jelölje be a megfelelő jelölőnégyzetet a WINS-névhozzárendelés engedélyezéséhez:
    • A WINS címkeresés használata jelölőnégyzetet, ha a vonatkozó zóna címkeresési zóna.
    • A WINS-R névlekérdezés használata jelölőnégyzetet, ha a vonatkozó zóna névkeresési zóna.
  6. Írja be egy WINS-kiszolgáló IP-címét, mely a DNS-ben nem található nevek hozzárendelésében fog segíteni. (Névkeresési zóna esetében írjon egy nevet A visszaadott névhez csatolandó tartomány mezőbe.)
  7. A Hozzáadás gombra kattintva adja a kiszolgáló IP-címét a listához.
  8. Ha további WINS-kiszolgálók címeit kell használni a WINS-keresés során, a 6. és 7. lépések ismétlésével adja őket a listához.
  9. Szükség esetén jelölje be az Ez a rekord ne replikálódjon jelölőnégyzetet a WINS-rekordhoz. Ha olyan DNS-kiszolgálók között replikálja a zónát, melyek nem ismerik fel a WINS vagy WINS-R erőforrásrekordokat, jelölje be ezt a jelölőnégyzetet. Ezzel megakadályozza, hogy az ilyen kiszolgálókon replikálódjanak a rekordok a zónaletöltések során.
  10. A Speciális gombra kattintva beállíthatja a WINS speciális keresési paramétereit.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

Megjegyzések

  • Ha meg van adva ez a beállítás, a zónában nem található nevek keresésére a rendszer az itt beállított WINS-kiszolgálókat használja.

Kapcsolódó témakörök


Zónák kezelése

  • Dinamikus frissítések engedélyezése
  • Csak biztonságos dinamikus frissítések engedélyezése
  • Zónaletöltés kezdeményezése másodlagos kiszolgálóról
  • Zóna frissítési időtartamának beállítása
  • Zóna újrapróbálkozási időközének beállítása
  • Zóna elévülési időtartamának beállítása
  • Címtárba integrált zóna biztonsági beállításának módosítása


Dinamikus frissítések engedélyezése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon ellenőrizze, hogy a zóna típusaként az Elsődleges vagy az Active Directoryval integrált beállítás van-e megadva.
  5. A Dinamikus frissítések engedélyezése listában kattintson az Igen elemre.

Megjegyzések

  • A dinamikus frissítés a DNS szabvány egyik bővítése. A DNS-frissítési folyamat ismertetése a 2136-os számú, „Dynamic Updates in the Domain Name System (DNS UPDATES)” (Dinamikus frissítések a tartománynévrendszerben) című RFC-dokumentumban található.

Kapcsolódó témakörök


Csak biztonságos dinamikus frissítések engedélyezése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon-e ellenőrizze, hogy a zóna típusaként az Active Directoryval integrált beállítás van-e megadva.
  5. Az Dinamikus frissítések engedélyezése legördülő listában kattintson a Csak biztonságos frissítések elemre.

Figyelem!

  • A Windows 2000 rendszerben a biztonságos dinamikus frissítések használatát veszélyeztetheti egy tartományvezérlőn futó DHCP-kiszolgáló, ha a Windows 2000 DHCP-kiszolgáló úgy van konfigurálva, hogy a DNS-rekordokat az ügyfelei nevében regisztrálja. A probléma elkerüléséhez a DHCP-kiszolgálókat és a tartományvezérlőket külön számítógépre kell telepíteni. Ha nem tartja fontosnak a névlekérdezési (PTR) rekordok biztonságát, ez az óvintézkedés csak akkor tanácsolt, ha a DHCP-kiszolgáló az állomás (A) típusú rekordok ügyfelek részére történő regisztrációjára van beállítva (ez nem az alapértelmezett viselkedés). További információt a Kapcsolódó témakörök hivatkozás alatt talál.

Megjegyzések

  • A biztonságos dinamikus frissítés csak az Active Directoryval integrált zónák esetén támogatott. Ha a zóna típusa másképp van beállítva, meg kell változtatni a zónatípust, és a címtárba kell integrálni a zónát a dinamikus DNS-frissítések biztonságossá tétele előtt.
  • A dinamikus frissítés a DNS szabvány egyik szerinti bővítése. A DNS-frissítési folyamat ismertetése a 2136-os számú, „Dynamic Updates in the Domain Name System (DNS UPDATES)” (Dinamikus frissítések a tartománynévrendszerben) című RFC-dokumentumban található.

Kapcsolódó témakörök


Zónaletöltés kezdeményezése másodlagos kiszolgálóról

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna (csak másodlagos típusú)
  3. A Művelet menüben kattintson a Letöltés főkiszolgálóról parancsra.

Megjegyzés

Kapcsolódó témakörök


Zóna frissítési időtartamának beállítása

Zóna elévülési időtartamának beállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon ellenőrizze, hogy a zóna típusaként az Elsődleges vagy az Active Directoryval integrált beállítás van-e megadva.
  5. Kattintson a SOA rekord fülre.
  6. A Frissítési időköz beállításához jelölje ki, hogy percben, órában vagy napban fejezi-e ki az időtartamot, és írjon be egy számot a mezőbe.
  7. Kattintson az OK gombra a beállított időtartam mentéséhez.

Megjegyzések

  • Alapértelmezés szerint a frissítési időköz 1 óra minden zóna esetén. A frissítési időtartam határozza meg, hogy a zónát betöltő és tároló egyéb DNS-kiszolgálók milyen gyakran újítják meg a zónát.

Kapcsolódó témakörök


Zóna újrapróbálkozási időközének beállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon ellenőrizze, hogy a zóna típusaként az Elsődleges vagy az Active Directoryval integrált beállítás van-e megadva.
  5. Kattintson a SOA rekord fülre.
  6. Az Újrapróbálkozási időköz beállításához jelölje ki, hogy percben, órában vagy napban fejezi-e ki az időközt, és írjon be egy számot a mezőbe.
  7. Kattintson az OK gombra a beállított időköz mentéséhez.

Megjegyzések

  • Alapértelmezés szerint az újrapróbálkozási időköz 10 perc minden zóna esetén. Az újrapróbálkozási időköz határozza meg, hogy a zónát betöltő és tároló egyéb DNS-kiszolgálók milyen gyakran próbálják meg a zóna frissítését kérni, ha a frissítési időtartam lejár.

Kapcsolódó témakörök


Zóna elévülési időtartamának beállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon ellenőrizze, hogy a zóna típusaként az Elsődleges vagy az Active Directoryval integrált beállítás van-e megadva.
  5. Kattintson a SOA rekord fülre.
  6. Az Ezután lejár beállítás legördülő listájában jelölje ki, hogy percben, órában vagy napban fejezi-e ki az időtartamot, és írjon be egy számot a mezőbe.
  7. Kattintson az OK gombra a beállított időtartam mentéséhez.

Megjegyzések

  • Alapértelmezés szerint az elévülési időtartam 1 nap minden zóna esetén. Az elévülési időtartamot a zónát betöltő és tároló egyéb DNS-kiszolgálók használják annak megállapítására, hogy a zónaadatok mikor évülnek el azok megújításának elmaradása esetén.

Kapcsolódó témakörök


Címtárba integrált zóna biztonsági beállításának módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon-e ellenőrizze, hogy a zóna típusaként az Active Directoryval integrált beállítás van-e megadva.
  5. A Biztonság lapon szükség szerint módosítsa az adott zóna biztonságos frissítésére felhatalmazott tagfelhasználók vagy csoportok listáját, majd állítsa alaphelyzetbe a hozzájuk tartozó engedélyeket.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

Megjegyzések

  • A biztonságos dinamikus frissítések csak az Active Directoryval integrált zónák esetén támogatottak.

Kapcsolódó témakörök


Erőforrásrekordok kezelése

  • Állomás (A) típusú erőforrásrekord hozzáadása egy zónához
  • MX erőforrásrekord hozzáadása egy zónához
  • CNAME (Alias) erőforrásrekord hozzáadása egy zónához
  • Új tartomány hozzáadása zónához
  • PTR erőforrásrekord hozzáadása egy névkeresési zónához
  • Erőforrásrekord hozzáadása egy zónához
  • Zóna meglévő erőforrásrekordjának módosítása
  • Erőforrásrekord törlése egy zónából
  • Nem támogatott erőforrásrekordok megtekintése egy zónában
  • Erőforrásrekord biztonsági beállításainak módosítása


Állomás (A) típusú erőforrásrekord hozzáadása egy zónához

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó címkeresési zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák
    • vonatkozó zóna
  3. A Művelet menüben kattintson az Új állomás parancsra.
  4. A Név mezőbe írja be az új állomás DNS-nevét.
  5. Az IP-cím mezőbe írja be az új állomás IP-címét.
  6. A Hozzárendelt mutatórekord (PTR) létrehozása jelölőnégyzet bejelölésével további mutatórekordokat hozhat létre az állomás egyik névkeresési zónájában a Név és az IP-cím mezőkben megadott információk alapján.
  7. Kattintson az Állomás hozzáadása gombra az új állomásrekord zónához való hozzáadásához.

Megjegyzés

Kapcsolódó témakörök


MX erőforrásrekord hozzáadása egy zónához

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó címkeresési zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák
    • vonatkozó zóna
  3. A Művelet menüben kattintson az Új MX rekord parancsra.
  4. Az Állomás vagy tartomány mezőbe írja be azt a tartománynevet, amelynél ez a rekord lesz használva a levelek kézbesítésére.
  5. A Levelezőkiszolgáló mezőbe írja be annak annak a levelezőkiszolgálónak a DNS-nevét, amely a megadott tartománynévhez a leveleket kézbesíti.

    A Tallózás gombra kattintva megtekintheti a DNS-névtér olyan MX állomásait a tartományban, melyek állomás (A) típusú rekordja már meg van adva.

  6. Adja meg A levelezőkiszolgáló prioritása beállítást a zóna igényeinek megfelelően.
  7. Kattintson az OK gombra az új rekord a zónához való hozzáadásához.

Megjegyzés

Kapcsolódó témakörök


CNAME (alias) erőforrásrekord hozzáadása egy zónához

  1. Nyissa meg a DNS beépülő modult.
  2. A konzolfán kattintson a megfelelő címkeresési zónára.

    Helye:

    • DNS
    • megfelelő DNS-kiszolgáló
    • Címkeresési zónák
    • megfelelő zóna
  3. A Művelet menüben kattintson az Új alias parancsra.

  4. Az Aliasnév mezőbe írja be az aliasnevet.

  5. A célállomás teljesen minősített neve mezőbe írja be annak a DNS állomás-számítógépnek a teljesen minősített tartománynevét, melyre az alias vonatkozik.

    6. Kattinthat a Tallózás gombra is, ha a DNS-névtér olyan állomásait szeretné megkeresni a tartományban, melyek A (állomás) rekordja már meg van adva.

  6. Kattintson az OK gombra az új rekord zónához való hozzáadásához.

Megjegyzés

Kapcsolódó témakörök


Új tartomány hozzáadása zónához

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a megfelelő zónára.

    Helye:

    • DNS
    • megfelelő DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A Művelet menüben kattintson az Új tartomány parancsra.
  4. Az Új tartomány mezőbe írja be az új tartomány nevét, de pontokat ne használjon.
  5. Az OK gombra kattintva adja hozzá az új tartományt a zónához.

Megjegyzés

Kapcsolódó témakörök


PTR erőforrásrekord hozzáadása egy névkeresési zónához

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó névkeresési zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Névkeresési zónák
    • vonatkozó zóna
  3. A Művelet menüben kattintson az Új mutató parancsra.
  4. Az Állomás IP-címe mezőbe írja be az állomás IP-címének oktettszámát.
  5. Az Állomás neve mezőbe írja be a DNS-számítógép teljesen minősített tartománynevét, melyhez a mutatórekord névlekérdezést fog biztosítani.

    6. A Tallózás gombra kattintva a DNS-névtér olyan állomásait keresheti a tartományban, melyek állomás (A) típusú rekordja már meg van adva.

  6. Az OK gombra kattintva adja hozzá az új rekordot a zónához.

Megjegyzés

Kapcsolódó témakörök


Erőforrásrekord hozzáadása egy zónához

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A Művelet menüben kattintson az Egyéb új rekordok parancsra.
  4. A Válassza ki az erőforrásrekord típusát mezőben keresse meg a hozzáadni kívánt erőforrásrekord típusát és jelölje ki.
  5. Kattintson a Rekord létrehozása gombra.
  6. Az Új erőforrásrekord párbeszédpanelen adja meg az erőforrásrekord létrehozásához szükséges információkat.

    7. Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

  7. Ha az erőforrásrekordhoz szükséges minden információt megadott, kattintson az OK gombra, és az új rekord a zónához adódik.

Megjegyzés

Kapcsolódó témakörök


Zóna meglévő erőforrásrekordjának módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A részletek ablaktáblán kattintson a módosítani kívánt erőforrásrekordra.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Tulajdonságok ablakban módosítsa a megfelelő tulajdonságokat.

    Szükség esetén megtekintheti és módosíthatja a DNS-konzol speciális erőforrásrekord-tulajdonságait is. A speciális tulajdonságok megjelenítéséhez kattintson a Nézet menü Speciális parancsára.

  6. Ha befejezte a rekord módosítását, kattintson az OK gombra.

Megjegyzés

  • Speciális nézetben módosíthatja a meglévő erőforrásrekordok további beállításait, például a rekordfüggő Élettartam (TTL) beállítást, vagy megadhat egy rekordfüggő időbélyegzőt, melyet az elévülési és kitakarítási funkcióknál használ a rendszer.

Kapcsolódó témakörök


Erőforrásrekord törlése egy zónából

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A részleteket megjelenítő ablaktáblán kattintson a törölni kívánt erőforrásrekordra.
  4. A Művelet menüben kattintson a Törlés parancsra.
  5. Amikor a rendszer a kijelölt erőforrásrekord törlésének jóváhagyását kéri, kattintson az OK gombra.

Megjegyzés

Kapcsolódó témakörök


Nem támogatott erőforrásrekordok megtekintése egy zónában

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A részleteket megjelenítő ablaktáblában kattintson a megtekinteni kívánt rekordra.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Tulajdonságok párbeszédpanelen tekintse meg a rekord tulajdonságait.
  6. Ha megtekintette a rekordot, kattintson az OK gombra.

Megjegyzések

  • A DNS-konzol lehetővé teszi, hogy megtekintse azokat a nem támogatott erőforrásrekordokat a másodlagos zónákban, melyek más típusú DNS-kiszolgálókról származnak, például a BIND valamely verzióját futtató DNS-kiszolgálókról. Ezeket a rekordokat a Windows 2000 DNS-kiszolgálók nem használják, és nem kezelhetők a DNS-konzolon. A következő rekordtípusok tartoznak ebbe a csoportba:
    • Örökölt rekordok, például az MF (levéltovábbító) és MD (levéltartomány) rekordok
    • Biztonságos vagy titkosított DNS-rekordok, például az SG (aláírás) és az NXT (következő) rekordok

Kapcsolódó témakörök


Erőforrásrekord biztonsági beállításainak módosítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A részletek ablaktáblán kattintson a megtekinteni kívánt rekordra.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. A Biztonság lapon szükség szerint módosítsa az adott rekord biztonságos frissítésére felhatalmazott tagfelhasználók vagy csoportok listáját, majd állítsa alaphelyzetbe a hozzájuk tartozó engedélyeket.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

Megjegyzések

  • Biztonságos dinamikus frissítések csak az Active Directoryval integrált zónákban tárolt erőforrásrekordok esetében támogatottak vagy konfigurálhatók.

Kapcsolódó témakörök


Az elévülés és a kitakarítás használata

  • DNS-kiszolgáló elévülési/takarítási tulajdonságainak beállítása
  • Kijelölt zóna elévülési/takarítási tulajdonságainak beállítása
  • Régi erőforrásrekordok automatikus kitakarításának engedélyezése
  • Régi erőforrásrekordok kitakarításának azonnali indítása
  • Annak megtekintése, hogy egy zónában mikor kezdődik meg a régi rekordok kitakarítása
  • Erőforrásrekord elévülési és kitakarítási tulajdonságainak alaphelyzetbe állítása


DNS-kiszolgáló elévülési/takarítási tulajdonságainak beállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Takarítás/elévülés beállítása az összes zónára parancsára.
  4. Jelölje be a Régi erőforrásrekordok kitakarítása jelölőnégyzetet.
  5. Módosítsa a többi elévülési és kitakarítási tulajdonságot, ha szükséges.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

Megjegyzések

  • Az ily módon beállított elévülési és kitakarítási tulajdonságokat a kiszolgáló alapértelmezésként alkalmazza az Active Directoryval integrált zónákra. Szabványos elsődleges zónák esetében a tulajdonságokat a zónán kell beállítani.
  • Ha módosította a kiszolgáló elévülési/kitakarítási beállításait, a DNS-konzol megerősítést kér. Ekkor lehetőség van a módosításokat csak az új, Active Directoryval integrált zónákra alkalmazni, de szükség esetén a módosítások a meglévő zónákra is alkalmazhatók, melyek integrálva vannak az Active Directoryval.
  • A Régi erőforrásrekordok kitakarítása jelölőnégyzet 4. lépésben leírt bejelölésétől függetlenül a szabványos elsődleges zónák esetében ez a szolgáltatás le van tiltva, hacsak manuálisan nem engedélyezi.

Kapcsolódó témakörök


Kijelölt zóna elévülési/takarítási tulajdonságainak beállítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Az Általános lapon kattintson az Elévülés gombra.
  5. Jelölje be a Régi erőforrásrekordok kitakarítása jelölőnégyzetet.
  6. Módosítsa a többi elévülési és kitakarítási tulajdonságot, ha szükséges.

    Ha további információt szeretne kapni a párbeszédpanel valamelyik eleméről, kattintson a Mi ez? gombra, mutasson az elemre, majd kattintson rá.

Megjegyzés

Kapcsolódó témakörök


Régi erőforrásrekordok automatikus kitakarításának engedélyezése

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. Kattintson a Művelet menü Tulajdonságok parancsára.
  4. Kattintson a Speciális fülre.
  5. Jelölje be a Régi rekordok automatikus kitakarítása jelölőnégyzetet.
  6. A Takarítási időköz beállítás megadásához jelölje ki a legördülő listából, hogy órában vagy napban fejezi-e ki az időközt, majd írjon be egy számot a mezőbe.

Megjegyzés

Kapcsolódó témakörök


Régi erőforrásrekordok kitakarításának azonnali indítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó DNS-kiszolgálóra.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
  3. A Művelet menüben kattintson a Régi erőforrásrekordok kitakarítása parancsra.

Megjegyzés

Kapcsolódó témakörök


Annak megtekintése, hogy egy zónában mikor kezdődik meg a régi rekordok kitakarítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A Nézet menüben kattintson a Speciális parancsra.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. Az Általános lapon kattintson az Elévülés gombra.
  6. A Zóna elévülési és kitakarítási tulajdonságai párbeszédpanelen nézze meg a Dátum és idő mező értékét. Az érték megadja, hogy a zónában mikor ajánlott először a régi erőforrásrekordok kitakarítása.

Megjegyzések

  • A kitakarítást indító dátum- és időbélyegző határozza meg a zóna kitakarításának indítását. További információt a Kapcsolódó témakörök hivatkozás alatt talál.
  • Ha a kitakarítást indító dátum- és időbélyegző által meghatározott időpont elérkezett, és a Régi erőforrásrekordok kitakarítása jelölőnégyzet be van jelölve, a kitakarítás megkezdődik. Ha a jelölőnégyzet nincs bejelölve, a zóna kitakarítása elmarad.

Kapcsolódó témakörök


Erőforrásrekord elévülési és kitakarítási tulajdonságainak alaphelyzetbe állítása

  1. Nyissa meg a DNS ablakot.
  2. A konzolfán kattintson a vonatkozó zónára.

    Helye:

    • DNS
    • vonatkozó DNS-kiszolgáló
    • Címkeresési zónák (vagy Névkeresési zónák)
    • vonatkozó zóna
  3. A részleteket megjelenítő ablaktáblában kattintson duplán arra az erőforrásrekordra, melynek elévülési és kitakarítási tulajdonságait alaphelyzetbe kívánja állítani.

    Megjelennek a kijelölt erőforrásrekord tulajdonságai.

  4. Attól függően, hogy az erőforrásrekord eredetileg hogyan lett a zónához adva, tegye értelemszerűen az alábbiakat a Rekord törlése az elévülés után jelölőnégyzet alaphelyzetbe állítására:
    1. Ha a rekord dinamikusan, a dinamikus frissítési DNS protokoll használatával lett hozzáadva, törölheti a jelölést a jelölőnégyzetből, hogy elévülését vagy a kitakarítási folyamat alatti esetleges eltávolítását megakadályozza.
    2. Ha a rekordot statikusan adta hozzá, bejelölheti a jelölőnégyzetet, hogy elévülését vagy a kitakarítási folyamat alatti esetleges eltávolítását engedélyezze.

Megjegyzések

  • Ez az eljárás csak a dinamikusan regisztrált erőforrásrekordok esetében szükséges. A kézzel hozzáadott rekordok esetében mindig egy nulla értékű időbélyegző tartozik a rekordhoz, mely kizárja a kitakarítási folyamatból.

Kapcsolódó témakörök


A DNS szolgáltatás hibaelhárítása parancssori eszközökkel

  • Az ügyfél névhozzárendelő gyorsítótárának megjelenítése és megtekintése az ipconfig paranccsal
  • Az ügyfél névhozzárendelő gyorsítótárának ürítése és alaphelyzetbe állítása az ipconfig paranccsal
  • DNS-ügyfél regisztrációjának megújítása az ipconfig paranccsal
  • DNS-kiszolgáló válaszképességének ellenőrzése az nslookup paranccsal
  • Zónadelegálás ellenőrzése az nslookup paranccsal
  • Tartományvezérlők DNS-regisztrációjának ellenőrzése az nslookup paranccsal
  • A WINS szolgáltatás ellenőrzése a DNS-lekérdezések megválaszolásának forrásaként


Az ügyfél névhozzárendelő gyorsítótárának megjelenítése és megtekintése az ipconfig paranccsal

  • Írja be a parancssorba a következőt:

    ipconfig /displaydns

    Az ipconfig /displaydns|more parancsot adja meg, ha a parancs által előállított listát képernyőnként kívánja megjeleníteni.

Megjegyzések

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.
  • Az ipconfig /displaydns parancs segítségével megjelenítheti a DNS-ügyfelek névhozzárendelési gyorsítótárát, amely a helyi Hosts fájlból előzetesen betöltött bejegyzéseket, valamint a rendszer által azóta hozzárendelt nevek rekordjait tartalmazza. Ezt az információt a DNS-ügyfél szolgáltatás használja a gyakran lekérdezett nevek gyors hozzárendelésére, mielőtt a lekérdezést elküldené a konfigurált DNS-kiszolgálókhoz.
  • Amikor az ipconfig /displaydns paranccsal megjeleníti az aktuális névhozzárendelő gyorsítótár tartalmát, az eredmény általában a helyi állomás és a visszacsatolási IP-cím (127.0.0.1) hozzárendeléseit tartalmazza. Ennek oka, hogy ezek a hozzárendelések általában szerepelnek az alapértelmezés szerinti (nem módosított) helyi Hosts fájlban.
  • Ha állomás-hozzárendelési bejegyzéseket vesz fel a helyi Hosts fájlba, és menti a fájlt, akkor a parancs ezeket a bejegyzéseket is megjeleníti. További tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.
  • A névhozzárendelő gyorsítótár a sikertelen hozzárendeléseket és érvénytelen DNS-neveket is tárolja. Ezeket a bejegyzéseket a DNS-ügyfél szolgáltatás adja hozzá, amikor egy lekérdezett névre egy DNS-kiszolgálótól negatív választ kap. A negatív válasz rövid időre bekerül a gyorsítótárba. Ezzel elkerülhetők az ismételt lekérdezések, amelyek csökkenthetnék a lekérdezések teljesítményét.

    A DNS hibaelhárítása közben kiürítheti és alaphelyzetbe állíthatja a gyorsítótárat, törölve ezzel a gyorsítótár negatív bejegyzéseit és a dinamikusan felvett, előzetesen be nem töltött bejegyzéseket. További tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.

  • Bár az ipconfig parancs a Windows korábbi verzióiban is megtalálható, a /displaydns kapcsoló csak akkor használható, ha a DNS-ügyfél szolgáltatást elindító számítógépen Windows 2000 operációs rendszer fut.

Kapcsolódó témakörök


Az ügyfél névhozzárendelő gyorsítótárának ürítése és alaphelyzetbe állítása az ipconfig paranccsal

  • Írja be a parancssorba a következőt:

    ipconfig /flushdns

Megjegyzések

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.
  • Az ipconfig /flushdns parancs segítségével ürítheti és visszaállíthatja a DNS-ügyfelek névhozzárendelési gyorsítótárának tartalmát. Ha szükséges, a DNS hibaelhárítása során ezzel az eljárással törölheti a negatív bejegyzéseket, valamint a dinamikusan hozzáadott egyéb bejegyzéseket a gyorsítótárból.
  • A gyorsítótár visszaállítása nem törli a helyi Hosts fájlból előzőleg betöltött bejegyzéseket. Ha ezeket a bejegyzéseket is törölni szeretné a gyorsítótárból, akkor a fájlból kell eltávolítani azokat. További tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.
  • Bár az ipconfig parancs a Windows korábbi verzióiban is megtalálható, a /flushdns kapcsoló csak olyan számítógépeken használható, melyek a Windows 2000 rendszert és a DNS-ügyfél szolgáltatást futtatják.

Kapcsolódó témakörök


DNS-ügyfél regisztrációjának megújítása az ipconfig paranccsal

  • Írja be a parancssorba a következőt:

    ipconfig /registerdns

    Vagy írja be az ipconfig /registerdns [csatoló] parancsot,

    ahol a csatoló az arra a számítógépre telepített csatoló neve, amelyen a regisztrációkat megújítani vagy frissíteni kívánja.

Megjegyzések

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.
  • Az ipconfig /registerdns parancs segítségével kézzel kezdeményezheti a konfigurált DNS-nevek és IP-címek dinamikus regisztrációját. Ez segítséget nyújthat a sikertelen DNS-névregisztrációk hibaelhárításához, és ahhoz, hogy az ügyfél és a DNS-kiszolgáló közötti dinamikus frissítési problémákat az ügyfél újraindítása nélkül lehessen megoldani.
  • Alapértelmezés szerint az ipconfig /registerdns parancs frissíti az összes DHCP-címbérletet, és regisztrálja az ügyfélszámítógép által konfigurált és használt összes kapcsolódó DNS-nevet.
  • Ha szeretné megtudni, hogy a paranccsal mely csatolókat adhatja meg, akkor először paraméter nélkül írja be az ipconfig parancsot. A parancs megjeleníti a számítógép számára elérhető csatolók nevét.
  • Bár az ipconfig parancs a Windows korábbi verzióiban is megtalálható, a /registerdns kapcsolót csak akkor használhatja, ha a számítógépen Windows 2000 operációs rendszer és a DNS-ügyfél szolgáltatás fut.
  • A Windows 2000-ben a DHCP-ügyfél szolgáltatás szolgál a dinamikus regisztrációk és frissítések végrehajtására, függetlenül attól, hogy a számítógép DHCP-kiszolgáló segítségével vagy statikus konfiguráció szerint állítja elő IP-címét.
  • Ha egy ügyfélszámítógép, illetve az ügyfélszámítógép DNS-neveinek dinamikus DNS-regisztrációja sikertelen, akkor a hibaelhártás során érdemes ellenőrizni, hogy a hibát nem az alábbi okok egyike váltja-e ki:
    1. A zóna, amelyben az ügyfél a frissítést vagy a regisztrációt kéri, nem képes fogadni a dinamikus frissítéseket.
    2. Az ügyfelek számára beállított DNS-kiszolgálók nem támogatják vagy nem ismerik fel a DNS dinamikus frissítési protokollt.
    3. A zóna elsődleges (vagy címtárba integrált) DNS-kiszolgálója elutasította a frissítési kérelmet. Ennek többnyire az az oka, hogy az ügyfél nem jogosult az aktuális zóna használatára, vagy az erőforrásrekordok adatbiztonsága nem ad elegendő hozzáférési jogot saját nevének frissítéséhez.
    4. A kiszolgáló vagy a zóna más probléma, például hálózati vagy kiszolgálóhiba miatt nem érhető el.

Kapcsolódó témakörök


DNS-kiszolgáló válaszképességének ellenőrzése az nslookup paranccsal

  1. Írja be a parancssorba a következőt:

    nslookup kiszolgáló_ip-címe 127.0.0.1

    ahol a kiszolgáló_ip-címe annak a DNS-kiszolgálónak az IP-címe, amelynek válaszadási képességét ellenőrizni kívánja.

    Ha például a DNS-kiszolgáló IP-címe 10.0.0.1, akkor a következőket kell beírni:

    nslookup 10.0.0.1 127.0.0.1

  2. Ha a kiszolgáló válaszol, akkor a parancs a „localhost” nevet adja vissza.

    Ha a kiszolgáló nem válaszol, folytassa a DNS-kiszolgáló hibaelhárítását. További tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.

Megjegyzés

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.

Kapcsolódó témakörök


Zónadelegálás ellenőrzése az nslookup paranccsal

  1. Írja be a parancssorba a következőt:

    nslookup gyökérkiszolgáló_ip-címe

    ahol a gyökérkiszolgáló_ip-címe a hálózat egyik érvényes gyökérkiszolgálójának IP-címe.

  2. Az nslookup parancssorába írja be a következőt:

    set norecursion

  3. Az előző parancs végrehajtása után írja be a következőt:

    set q=rr_típus

    ahol az rr_típus a sikertelenül lekért névhez tartozó erőforrásrekord típusa, amelyhez a zónadelegálást ellenőrizni (vagy javítani) kívánja.

    Például a set q=a parancsot írja be, ha a sikertelenül kért név által használt erőforrásrekord állomás (A) típusú.

  4. Írja be a sikertelenül kért névre vonatkozó teljesen minősített tartománynevet (FQDN).

    A nevet beíráskor ponttal (.) zárja le. Ha a zónadelegálások beállítása helyes, akkor válasz a delegált kiszolgálókhoz tartozó névkiszolgálók erőforrásrekordjainak listáját tartalmazza.

  5. Ha a névkiszolgáló lekérdezésére adott válasz nem tartalmaz delegált kiszolgálókra vonatkozó neveket vagy IP-címeket, írja be a q=ns parancsot, és hajtsa végre ismét a lekérdezést úgy, hogy a sikertelenül kért név szülőzónájaként a teljesen minősített tartománynevet (FQDN) adja meg.

    Ha például az előző lépésben sikertelenül kért név a pelda.microsoft.com volt, kérdezze le a microsoft.com nevet.

  6. Ha a válasz NS rekordokat tartalmaz, állomás (A) típusú rekordokat azonban nem, írja be a set recursion parancsot, majd külön kérdezze le az NS rekordokban felsorolt valamelyik A típusú erőforrásrekordot.

    Ha egy adott zónában előforduló minden egyes NS rekordhoz nem talál legalább egy érvényes IP-címet valamelyik A típusú erőforrásrekordban, akkor a delegálás sérült.

  7. Ebben az esetben javítsa ki a sérült delegálást, vagy másik IP-cím használatával hajtsa végre újból az előző lépésben leírt delegálási tesztet.

    Ha egynél több A típusú erőforrásrekord vagy IP-cím található, akkor azok használatával hajtsa végre az előző lépésben ismertetett delegálási tesztet. Delegálás javításához a szülőzóna egyik A típusú erőforrásrekordját egészítse ki vagy frissítse a delegált zóna számára megfelelő DNS-kiszolgáló érvényes IP-címével.

Megjegyzés

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.

Kapcsolódó témakörök


Tartományvezérlők DNS-regisztrációjának ellenőrzése az nslookup paranccsal

  1. Írja be a parancssorba a következőt:

    nslookup

  2. Az előző parancs végrehajtását követően írja be a következőt az nslookup parancs által adott („>”) jel után:

    set q=rr_típus

    ahol az rr_típus az az erőforrásrekord-típus, amelyet a következő keresésekben szűrőként kíván alkalmazni.

    Ha például a soron következő névlekérdezések során csak a megadott nevet használó SRV típusú rekordokat kívánja kiszűrni és megkapni, akkor írja be a következőt:

    set q=srv

  3. Az előző parancs végrehajtása után írja be a következőt:

    _ldap._tcp.dc._msdcs.Active_Directory_tartománynév

    ahol az Active_Directory_tartománynév az a DNS-név, amely az Active Directory tartományhoz és annak bármely hozzárendelt tartományvezérlőjéhez van konfigurálva.

    Ha például az Active Directory tartomány DNS-tartományneve pelda.microsoft.com, akkor írja be a következőt:

    _ldap._tcp.dc._msdcs.pelda.microsoft.com.

  4. Vizsgálja át a korábbi SRV-lekérdezés eredményét, és annak sikeressége vagy sikertelensége szerint döntse el, hogy van-e szükség további műveletre:
    • Ha a lekérdezés sikeres volt, akkor vizsgálja meg, hogy az eredményül kapott SRV rekordok tartalmazzák-e az Active Directory tartomány valamennyi tartományvezérlőjét, és azok érvényes IP-címekkel vannak-e regisztrálva.
    • Ha a lekérdezés sikertelen, folytassa a dinamikus frissítéssel vagy a DNS-kiszolgálóval kapcsolatos problémák elhárítását, és határozza meg a probléma pontos okát.

    További információért olvassa el a megjegyzéseket, vagy kattintson a Kapcsolódó témakörök hivatkozásra.

Megjegyzések

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.
  • A fenti eljárás közben előfordulhat, hogy többször időtúllépésre vonatkozó üzenet jelenik meg. Ez akkor fordul elő, ha a névkeresés nincs azokhoz a DNS-kiszolgálókhoz konfigurálva, amelyek az Active Directory tartománnyal azonos DNS-tartományt kiszolgálják.
  • A következő példa egy Nslookup munkamenet parancssori kimenetét mutatja be, amely a Windows 2000 tartományvezérlők által regisztrált SRV típusú rekordok ellenőrzésére szolgál. Ebben a példában a dc1 és dc2 nevű tartományvezérlők a „pelda.microsoft.com” tartományhoz vannak regisztrálva.

C:\>nslookup
Alapértelmezett kiszolgáló:  dc1.pelda.microsoft.com
Cím:  10.0.0.14
> set type=srv
> _ldap._tcp.dc._msdcs.pelda.microsoft.com
Kiszolgáló:  dc1.pelda.microsoft.com
Cím:  10.0.0.14
_ldap._tcp.dc._msdcs.pelda.microsoft.com   SRV:
          prioritás      = 0
          súly            = 0
          port           = 389
          svr állomásnév   = dc1.pelda.microsoft.com
_ldap._tcp.dc._msdcs.pelda.microsoft.com   SRV service location:
          prioritás      = 0
          súly           = 0
          port           = 389
          svr állomásnév   = dc2.pelda.microsoft.com
dc1.pelda.microsoft.com     Internet-cím = 10.0.0.14
dc2.pelda.microsoft.com     Internet-cím = 10.0.0.15
  • Az nslookup egy szabványos parancssori segédprogram, amely a DNS szolgáltatás legtöbb megvalósításában, így a Windows 2000 operációs rendszerben is megtalálható. A parancs lehetővé teszi DNS-kiszolgálók tesztelését, valamint adatainak részletes lekérdezését. A kiszolgálóval kapcsolatos egyéb problémák feltárása mellett ez az információ a névhozzárendeléssel kapcsolatos hibák elhárításakor hasznos, annak ellenőrzésére, hogy az erőforrásrekordok hozzáadása vagy frissítése egy adott zónában megtörtént-e.
  • Ellenőrizze, hogy a szolgáltatások és létfontosságú állomások, például a tartományvezérlők regisztrálásához használt erőforrásrekordok megfelelően hozzáadódtak-e a zónákhoz.

    Előfordulhat, hogy a Windows 2000 tartományvezérlőinek támogatására szolgáló SRV típusú rekordokat kézzel kell hozzáadni vagy ellenőrizni.

    A tartományvezérlők számára létrehozott SRV típusú rekordok hozzáadásához tekintse meg a Netlogon.dns fájl tartalmát, amelyet az Active Directory telepítő varázsló hozott létre a kiszolgáló számítógép tartományvezérlővé történő előléptetésekor. A fájl helye:

    rendszergyökér\System32\Config\Netlogon.dns

  • A fájl az RFC-előírásoknak megfelelő szöveges formátumban tartalmazza az erőforrásrekordokat. A következő rekordokat keresse meg:

    _ldap._tcp.Active_Directory_tartománynév IN SRV 0 0 389 ldap_kiszolgáló_neve
    _ldap._tcp.dc._msdcs.Active_Directory_tartománynév IN SRV 0 0 389 tartományvezérlő_neve

    Néhány esetben szükség lehet a Lightweight Directory Access protokoll (LDAP) kiszolgálónév módosítására, ha nem tartományvezérlőt használ hálózati LDAP-kiszolgálóként.

  • A Windows 2000 tartományvezérlők Net Logon szolgáltatása szükség szerint sokféle DNS-rekordot regisztrálhat a DNS-kiszolgálókon. Ha többet szeretne tudni ezekről a rekordokról és arról, hogy a Net Logon szolgáltatás hogyan hajtja végre a DNS frissítését, olvassa el a Microsoft webhelyén a Windows 2000 DNS-kiszolgálókra vonatkozó további technikai információkat. További tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.

Kapcsolódó témakörök


A WINS szolgáltatás ellenőrzése a DNS-lekérdezések megválaszolásának forrásaként

  1. Írja be a parancssorba a következőt:

    nslookup

  2. Az előző parancs végrehajtását követően írja be a következőt az nslookup parancs által adott („>”) jel után:

    set debug

    Ezzel engedélyezheti az nslookup parancs hibakereső üzemmódját, melyben több információ jelenik meg a parancs által létrehozott kimenetben.

    Ebben az üzemmódban tekintheti meg a lekérdezésre adott választ abban a tekintetben, hogy a lekérdezésre adott válasz forrása:

    • mérvadó (DNS-zóna vagy WINS-kiszolgáló adatbázisa)
    • nem mérvadó (a DNS-kiszolgáló korábbi lekérdezéseiből származó gyorsítótárazott, illetve a gyökérútmutatóból beolvasott adatok)
  3. Ezután írja be a

    set qtype=a

    parancsot a WINS címlekérdezés, illetve a

    set qtype=ptr

    parancsot a WINS-R névlekérdezés teszteléséhez.

    Ezzel a két paranccsal beállíthatja, hogy a lekérdezést A vagy PTR típusú rekordok szerint kívánja-e szűrni, címlekérdezéshez és névlekérdezéshez egyaránt.

  4. Attól függően, hogy a cím- vagy névlekérdezésre vonatkozó lehetséges WINS-forrásokat kívánja-e ellenőrizni, írja be a megfelelő teljesen minősített tartománynevet (FQDN).

    Ha például a vizsgált címlekérdezés az a-allomas.pelda.microsoft.com tartománynévre vonatkozik, akkor a következőt írja be:

    a-allomas.pelda.microsoft.com.

    Ha a vizsgált névlekérdezés a 10.0.0.1 IP-címre vonatkozik, akkor a következőt írja be:

    1.0.0.10.in-addr.arpa.

  5. A válaszból állapítsa meg, hogy a kiszolgáló válasza mérvadó-e, és nézze meg az élettartam értékét.
  6. Ha a kiszolgáló válasza mérvadó, ismételje meg a 4. lépésben végrehajtott lekérdezést.
  7. A válaszból állapítsa meg, hogy csökkent-e az élettartam értéke a második lekérdezésre adott válasz értékével, vagy megmaradt az első lekérdezésre adott válaszban szereplő élettartam.

    Ha egy mérvadóan megválaszolt lekérdezés esetén az élettartam értéke csökken, akkor a lekérdezésre WINS-kiszolgáló válaszolt.

  8. A hibakereső üzemmódból való kilépéshez és a parancssorhoz való visszatéréshez írja be az exit parancsot.

Megjegyzések

  • A parancssor megnyitásához mutasson a Start menü Programok, majd Kellékek pontjára, végül kattintson a Parancssor parancsra.
  • Amikor egy Windows 2000 DNS-kiszolgáló mérvadó zónaadataiból válaszol egy lekérdezésre, akkor vagy a zónára beállított minimális vagy alapértelmezés szerinti élettartamértéket használja, vagy a rekordhoz rendelt élettartamértéket (ha van ilyen konfigurálva). A kiszolgáló válaszaiban foglalt élettartamértékek csökkennek, ha a válasz nem mérvadó, például a kiszolgáló gyorsítótárában lévő adatokon alapul.

    A WINS-keresések kivételes esetet jelentenek, mert itt a WINS-kiszolgálótól visszaérkezett választ a DNS-kiszolgáló gyorsítótárba helyezi, de az mégis mérvadó adatnak tekinthető. Ebben az esetben a WINS által küldött adatokat az ügyfelek mérvadó adatként kapják meg, amelyek azonban elavulnak, mialatt a DNS-kiszolgálónevek gyorsítótárában vannak, és ennek következtében a kiszolgáló által használt élettartamérték idővel csökken.

Kapcsolódó témakörök


Fogalmak

Ez a rész általános tájékoztatást ad a Tartománynévrendszerről (DNS) és a Windows 2000 Server által nyújtott DNS-szolgáltatásról, valamint részletesen ismerteti a Microsoft operációs rendszerek alatt futó DNS-ügyfelek számára biztosított szoftvereket.

  • A DNS – áttekintés
  • A DNS ismertetése
  • A DNS használata
  • Forrásmunkák


A DNS – áttekintés

A rész tartalma:

  • A DNS meghatározása
  • DNS-rendszereszközök
  • A DNS-kiszolgáló szolgáltatásai
  • Ügyfélszolgáltatások


A DNS meghatározása

A DNS a Domain Name System (Tartománynévrendszer) kifejezés rövidítése, olyan rendszer, amely számítógépek és hálózati szolgáltatások elnevezésére szolgál, és tartományok hierarchikus struktúrájából áll. A DNS elnevezési rendszert TCP/IP-hálózatokon, például az Interneten alkalmazzák, ahol a számítógépek és szolgáltatások megkeresésére használatos azok felhasználóbarát nevei alapján. Amikor a felhasználó egy alkalmazásban megad egy DNS-nevet, a DNS-szolgáltatások a névhez más, vele társított adatot rendelnek, ami lehet például egy IP-cím.

A legtöbb felhasználó szívesen alkalmaz rövid nevet (ilyen a pelda.microsoft.com is) egy számítógép, például levelezőkiszolgáló vagy webkiszolgáló, hálózaton való megkeresésére. A rövid név könnyen megtanulható és felidézése nem okoz gondot. A számítógépek azonban a hálózaton numerikus címek alapján kommunikálnak egymással. A hálózati erőforrások használatának megkönnyítése érdekében a névszolgáltatások, például a DNS, a rövid számítógép- vagy szolgáltatásneveket hozzárendelik azok numerikus címeihez. Aki már használt webböngészőt, az használt DNS-t is.

Az alábbi ábrán a DNS fő felhasználási módja látható, a számítógép neve alapján a hozzá tartozó IP-cím megkeresése.

Példa a DNS címkeresési szolgáltatására

Ebben a példában az ügyfélszámítógép lekérdezi a kiszolgálót, hogy megkapja az a-allomas.pelda.microsoft.com DNS-tartománynév használatára beállított számítógép IP-címét. Mivel a kiszolgáló a saját helyi adatbázisában tárolt adatok alapján válaszolni tud a lekérdezésre, elküldi a kért információt tartalmazó választ, amely nem más, mint egy, az a-allomas.pelda.microsoft.com IP-címét tartalmazó A (állomás) erőforrásrekord.

A példa egy egyszerű DNS-lekérdezést mutat egyetlen ügyfél és kiszolgáló részvételével. A gyakorlatban a DNS-lekérdezések ennél bonyolultabbak lehetnek, és olyan lépéseket is tartalmazhatnak, amelyek itt nincsenek bemutatva. További információ A DNS-lekérdezés működése című témakörben található.

Megjegyzés

  • A DNS rendszerrel kapcsolatos egyéb fogalmakról további háttér-információ A DNS ismertetése című témakörben található.


DNS-rendszereszközök

A Windows 2000 mind a DNS-kiszolgálók, mind a DNS-ügyfelek számára számos felügyeleti, figyelési és hibaelhárítási segédprogramot biztosít. Ezek a segédprogramok a következők:

  • A Felügyeleti eszközök részét képező DNS-konzol.
  • A parancssorból futtatható segédprogramok, mint például a DNS-szolgáltatással kapcsolatos hibák elhárítására szolgáló Nslookup program.
  • Naplózási szolgáltatások, például az Eseménynaplóban megjeleníthető DNS-kiszolgálónapló. A fájl alapú naplózás mint speciális hibaelhárítási lehetőség is alkalmazható ideiglenesen a szolgáltatás kijelölt eseményeinek naplózására és nyomon követésére.
  • Teljesítményfigyelő segédprogramok, például olyan, statisztikai adatokat megjelenítő számlálók, amelyek a Rendszerfigyelőben a DNS-kiszolgáló tevékenységét mérik és figyelik.

A DNS-konzol

A Windows 2000 alapú DNS-kiszolgálók kezelésére elsősorban a DNS-konzol használható, amely a Vezérlőpult Felügyeleti eszközök mappájában található. A DNS-konzol voltaképpen egy Microsoft Management Console (MMC) beépülő modul, így a DNS-felügyeleti funkciók szorosan illeszkednek a hálózatkezelés egészébe.

DNS-kiszolgáló telepítése után a DNS-konzol az alábbi felügyeleti feladatok ellátására használható:

  1. Új DNS-kiszolgálók kezdeti konfigurációjának beállítása.
  2. Csatlakozás az ugyanazon a számítógépen levő helyi, vagy más számítógépen levő távoli DNS-kiszolgálóhoz és ezek kezelése.
  3. Címlekérdezési és névlekérdezési zónák hozzáadása és eltávolítása szükség szerint.
  4. A zónákon belüli erőforrásrekordok hozzáadása, eltávolítása és frissítése.
  5. A zónáknak a kiszolgálók közötti tárolási és replikálási módjának megváltoztatása.
  6. Annak módosítása, hogy a kiszolgálók hogyan dolgozzák fel a lekérdezéseket és hogyan kezeljék a dinamikus frissítéseket.
  7. Kijelölt zónák vagy erőforrásrekordok biztonsági beállításainak módosítása.

A DNS-konzol segítségével a fentieken kívül a következő feladatokat is lehet elvégezni:

  • Karbantartási feladatok a kiszolgálón. A kiszolgáló működésének elindítása, leállítása, szüneteltetése, folytatása vagy az adatfájlok kézi frissítése.
  • A kiszolgálón lévő gyorsítótár tartalmának figyelése, szükség esetén törlése.
  • A kiszolgáló speciális beállításainak optimalizálása.
  • A kiszolgálón tárolt régi erőforrásrekordok elévülésének és kitakarításának beállítása és végrehajtása.

Emellett egy nem kiszolgálóként működő számítógépről a DNS-konzol segítségével a Windows 2000 DNS-kiszolgálók távoli felügyeletét is el lehet végezni (feltéve, hogy ezekre a számítógépekre előzetesen telepítette a DNS-kiszolgálószolgáltatást). További információ a Kiszolgálók kezelése távolról című témakörben található.

Fontos

  • A DNS-konzol csak Windows 2000 alapú DNS-kiszolgálók kezelésére alkalmas.

Megjegyzések

  • A DNS-konzol a megszokott DNS-felügyeleti feladatok végrehajtásának új módjait biztosítja. Ezeket korábban a Windows NT Server 4.0-s verzióban a DNS-kezelő nyújtotta. További információ a Megszokott feladatok végrehajtásának új módjai című témakörben található.
  • Windows 2000 Server esetében a DNS-konzol a DNS-kiszolgáló telepítése után jelenik meg. Ha a DNS-konzolt egy másik, nem kiszolgálóként működő számítógépről kívánja használni, például egy olyan számítógépről, amelyen Windows 2000 Professional fut, akkor telepítse a Felügyeleti eszközök csomagot.

Parancssorból futtatható segédprogramok

A Windows 2000 rendszerben több, parancssorból futtatható segédprogram áll rendelkezésre. Ezek a DNS-kiszolgálók és -ügyfelek kezelését és hibáinak elhárítását segítik. Az alábbi táblázat ismerteti ezeket a segédprogramokat. A parancsok futtathatók közvetlenül a parancssorból, de kötegfájlba foglalva parancsfájlként is indíthatók.

Parancs | Leírás
Nslookup | A DNS-névtér lekérdezésének tesztelésére szolgál. További információ A DNS szolgáltatás hibaelhárítása parancssori eszközökkel című témakörben található.
Dnscmd | A DNS-kiszolgálók kezelését biztosítja a parancssorból. Ezzel a segédprogrammal olyan parancsfájlok állíthatók elő, amelyekkel automatizálni lehet a DNS kezelésével kapcsolatos szokásos feladatokat, és el lehet végezni a hálózaton az új DNS-kiszolgálók egyszerű, felügyelet nélküli telepítését és beállítását. További információ A kiszolgáló felügyeletének automatizálása a Dnscmd paranccsal című témakörben található.
Ipconfig | Ezzel a paranccsal lehet megjeleníteni és módosítani a számítógép aktuális IP-beállításainak részleteit. A Windows 2000 rendszerben e segédprogramhoz a parancssorban további kapcsolók adhatók meg, amelyek a DNS-ügyfelek támogatásában, illetve hibáik elhárításában nyújtanak segítséget. További információ Az ügyfél névfeloldó gyorsítótárának ürítése és alaphelyzetbe állítása az ipconfig paranccsal és A DNS-ügyfél regisztrációjának megújítása az ipconfig paranccsal című témakörben található.

Eseményfigyelő segédprogramok

A Windows 2000 Server a DNS-kiszolgálók figyelésére két lehetőséget kínál:

  • A DNS-kiszolgáló eseményüzeneteinek alapértelmezés szerinti naplózása a DNS-kiszolgálónaplóba.

    Windows 2000 Server esetében a kiszolgáló eseményüzenetei egy külön rendszer-eseménynaplóba, a DNS-kiszolgálónaplóba kerülnek, amely az Eseménynapló szolgáltatással tekinthető meg.

    A DNS-kiszolgálónapló a DNS-kiszolgálószolgáltatás által naplózott alapvető eseményeket tartalmazza. A DNS-kiszolgáló indításakor vagy leállításakor például ennek megfelelő eseményüzenetek kerülnek a naplóba. Szintén ide kerül néhány, a DNS-kiszolgálóval összefüggő kritikus esemény, például ha a kiszolgáló elindul, de nem találja az inicializálási adatokat, például a zónákat vagy a Windows 2000 rendszerleíró adatbázisában vagy (egyes esetekben) az Active Directoryban tárolt rendszerindítási információt.

    Az, hogy a Windows 2000 alapú DNS-kiszolgálók milyen eseményeket naplózzanak, előre meghatározott. További információ A DNS-kiszolgálónapló című témakörben található.

    Az ügyféllel kapcsolatos DNS-események megjelenítésére és figyelésére felhasználható az Eseménynapló is. Az eseményeket a (bármely verziójú) Windows 2000 rendszerrel működő számítógépen futó DNS-ügyfélszolgáltatás írja be a Rendszernaplóba. További tudnivalókat Az Eseménynapló használata című témakörben találhat.

  • Választható hibakeresési lehetőségek a DNS-kiszolgálószámítógépen szövegfájlba kerülő nyomon követési adatokhoz.

    A DNS-konzol segítségével külön engedélyezhető néhány további, hibakeresési naplózással kapcsolatos lehetőség ahhoz, hogy a DNS-kiszolgáló tevékenységének nyomon követésével kapcsolatos adatok naplózása ideiglenesen egy szövegfájlba történjen. Az e szolgáltatáshoz létrehozott és használt fájl, a Dns.log, a rendszergyökér\System32\Dns mappában található.

    További információ A kiszolgáló hibakeresés-naplózási beállításainak használata című témakörben található.

Teljesítményfigyelő segédprogramok

A teljesítményfigyelést a Windows 2000 alapú DNS-kiszolgálók esetében további szolgáltatás-specifikus számlálók biztosítják, amelyek a DNS-kiszolgálók teljesítményét mérik. Ezekhez a számlálókhoz a Teljesítmény konzolban található Rendszerfigyelő szolgáltatással lehet hozzáférni.

A Rendszermonitorral bármely Windows 2000 alapú DNS-kiszolgálóhoz diagramok és grafikonok készíthetők, amelyek az idő függvényében ábrázolják a kiszolgáló teljesítményének alakulását. Ezeket tanulmányozva eldöntheti, hogy szükség van-e a kiszolgáló működésének további optimalizálására.

Ha a kiszolgáló metrikáját hosszabb időn át méri és figyeli, teljesítménymutatókat állíthat fel, amelyek alapján eldöntheti, hogy a rendszer működésének optimalizálása érdekében van-e mód további beállítások elvégzésére. További információ A kiszolgálók teljesítményének figyelése című témakörben található.

Megjegyzés

  • Ha korábban már használt Windows alapú DNS-kiszolgálót, akkor érdemes tudnia, hogy a DNS-konzol a Windows NT Server 4.0-s verzióján lévő DNS-kezelő szolgáltatásnak felel meg. További információ a Megszokott feladatok végrehajtásának új módjai című témakörben található.


A DNS-kiszolgáló szolgáltatásai

A Windows 2000 Server rendszeren futó DNS-szolgáltatás a következőket biztosítja:

  • Az RFC-dokumentumokba foglalt irányelveknek megfelelő DNS-névkiszolgáló

    A DNS nyitott protokoll, amelyet számos Request for Comments (RFC) dokumentum szabványosít. A Microsoft termékei megfelelnek e szabványoknak és támogatják őket.

    További tudnivalók A DNS-szolgáltatással kapcsolatos RFC-dokumentumok című témakörben találhatók.

  • Együttműködés más rendszerű DNS-kiszolgálókkal

    Mivel a DNS-szolgáltatás megfelel az RFC-dokumentumokban lefektetett előírásoknak és szabványos formátumú DNS-adatfájlokat és erőforrásrekordokat használ, sikeresen együtt tud működni a legtöbb más rendszerű DNS-kiszolgálóval, amilyenek például a BIND (Berkeley Internet Name Domain) szoftvert használók.

    További tudnivalók az Együttműködés más szolgáltatásokkal című témakörben találhatók.

  • Az Active Directory támogatása

    Az Active Directory támogatásához a DNS szükséges. Ha egy kiszolgáló-számítógépre Active Directoryt telepít, a Windows 2000 Server automatikusan telepíthet és beállíthat egy DNS-kiszolgálót, ha a kiszolgáló-számítógép aktuális beállításai alapján nem talál DNS-kiszolgálót.

    Az Active Directory telepítő varázslóban először adja meg annak az Active Directory tartománynak a DNS-nevét, amelyhez a kiszolgálót tartományvezérlőként kívánja használni. A telepítés folyamán a varázsló később a következőket vizsgálja:

    1. Saját TCP/IP-ügyfélbeállításai alapján ellenőrzi, hogy van-e hozzá elsődleges DNS-kiszolgáló konfigurálva.
    2. Ha van elsődleges DNS-kiszolgáló, akkor lekérdezést küld annak, hogy megkeresse a varázslóban korábban megadott DNS-tartomány elsődleges mérvadó kiszolgálóját.
    3. Ezt követően megvizsgálja, hogy az elsődleges mérvadó kiszolgáló támogat-e, illetve fogad-e dinamikus frissítéseket a DNS dinamikus frissítési protokoll című témakörben leírtak szerint.
    4. Ha ekkor a telepítő nem talál olyan DNS-kiszolgálót, amely támogatja és fogadja az Active Directoryval használt DNS-tartománynév frissítéseit, telepítésre felkínál egy olyan kiszolgálót, amely DNS-kiszolgálószolgáltatást használ.

    Általában véve a Windows 2000 alapú DNS-kiszolgálószolgáltatás használata kifejezetten ajánlott, mert leginkább így biztosítható a DNS-kiszolgáló magas szintű szolgáltatásai és az Active Directory támogatása és integrációja. Az Active Directory támogatásához azonban telepíthet más típusú DNS-kiszolgálót is.

    Amennyiben más DNS-kiszolgálókat alkalmaz, vegye figyelembe a DNS-rendszerek együttműködésével kapcsolatos tényezőket. További információ Az Active Directoryt támogató más rendszerű DNS-kiszolgálók című témakörben található.

  • A DNS-kiszolgáló integrációja a Microsoft más hálózati szolgáltatásaival

    A DNS-szolgáltatás integrálható a Windows 2000 más szolgáltatásaival, és az RFC-dokumentumokban előírtakat meghaladó lehetőségeket nyújt. Ilyenek az Active Directoryval, a WINS- és DHCP-szolgáltatásokkal való integráció.

    További információ A Windows 2000 alapú DNS rendszer témakörben található.

  • Egyszerűbb rendszerfelügyelet

    A DNS beépülő modul a DNS-szolgáltatás kezeléséhez egy fejlett grafikus felhasználói felületet biztosít. A Windows 2000 Server emellett számos új, a szokásos felügyeleti munkát segítő konfigurációs varázslót tartalmaz. A DNS beépülő modulon kívül más eszközök is segítik a DNS-kiszolgálók és ügyfeleik kezelését és támogatását a hálózaton.

    További információ a DNS-rendszereszközök című témakörben található.

  • Az RFC-dokumentumokba foglalt irányelveknek megfelelő dinamikus frissítési protokoll támogatása

    A DNS-szolgáltatás, a dinamikus frissítési protokoll alapján, lehetővé teszi az ügyfelek számára erőforrásrekordjaik dinamikus frissítését (lásd: 2136-os számú RFC). Ez úgy javítja a DNS felügyeletét, hogy megtakarítja azt az időt, ami az ezeken a rekordokon végzett kézi műveletekhez lenne szükséges. A Windows 2000 rendszerrel működő számítógépek saját DNS-neveiket és IP-címeiket dinamikus tudják regisztrálni.

    További információ a Dinamikus frissítés című témakörben található.

  • A kiszolgálók közötti növekményes zónaletöltés támogatása

    A DNS-kiszolgálók közötti zónaletöltések a DNS-névtér egy részével kapcsolatos adatok replikációjára használatosak. Növekményes zónaletöltéskor a zónának csak a módosult része kerül letöltésre, amihez így kisebb hálózati sávszélesség is elegendő.

    További információ A zónák és a zónaletöltések ismertetése című témakörben található.

  • Új típusú erőforrásrekordok támogatása

    A DNS-szolgáltatás több új erőforrásrekord-típus támogatását tartalmazza. Ezek az új típusok, mint amilyen az SRV (szolgáltatáshely) és az ATMA (ATM-cím), kiterjesztik a DNS-szolgáltatás névadatbázis-szolgáltatásként való felhasználási lehetőségeit.

    További információ az Erőforrásrekordok című témakörben található.


Ügyfélszolgáltatások

A Windows 2000 alapú DNS-ügyfélszolgáltatás a DNS-tartománynevek hozzárendelésére szolgál, és a következő szolgáltatásokat nyújtja:

  • Az egész rendszerre kiterjedő gyorsítótárazás

    Amikor az alkalmazások lekérdezik a DNS-kiszolgálókat, a válaszokban lévő erőforrásrekordok az ügyfél gyorsítótárába kerülnek. Az információ a gyorsítótárban a beállított TTL (Élettartam) érték idejéig marad, ezalatt felhasználható a lekérdezések megválaszolására.

  • A negatív válaszok gyorsítótárazásának támogatása az RFC-szabványnak megfelelően

    A DNS-ügyfélszolgáltatás nem csak a DNS-kiszolgálóktól a lekérdezésekre kapott pozitív válaszokat (amelyek erőforrásrekordokat tartalmaznak) helyezi a gyorsítótárba, hanem a lekérdezésekre kapott negatív válaszokat is. Negatív válasz akkor érkezik, ha a lekérdezett névhez tartozó erőforrásrekord nem létezik.

    A negatív lekérdezések gyorsítótárazása megakadályozza a nem létező nevek ismételt lekérdezését, ami hátrányosan hatna az ügyfélrendszer teljesítményére. A lekérdezésre érkezett negatív válaszok rövidebb ideig maradnak a gyorsítótárban, mint a pozitív válaszok; alapértelmezés szerint legfeljebb 5 percig. Ezzel elkerülhető a régi adatok folyamatos gyorsítótárazása, ha a rekordok később már rendelkezésre állnak.

    A negatív gyorsítótárazás új DNS-szabvány, amelyet a 2308-as RFC-dokumentum tartalmaz. További tudnivalók az RFC-dokumentumban találhatók. Az RFC-dokumentumok beszerzésével kapcsolatban további információ A TCP/IP protokollal kapcsolatos RFC-dokumentumok című témakörben található.

  • A nem válaszoló DNS-kiszolgálók megkerülése

    A DNS-ügyfélszolgáltatás keresési listát alkalmaz, melyben a kiszolgálók prioritási sorrendben szerepelnek. A lista minden olyan elsődleges és másodlagos DNS-kiszolgálót tartalmaz, amely a rendszer aktív hálózati kapcsolataihoz be van állítva.

    A Windows 2000 ezt a listát a következő feltételek alapján rendezi át:

    1. Az elsődleges DNS-kiszolgálók kapják a legmagasabb prioritást.
    2. Ha nincs elérhető elsődleges DNS-kiszolgáló, a rendszer a másodlagos DNS-kiszolgálókat használja.
    3. A nem válaszoló kiszolgálók átmenetileg lekerülnek a listáról.

Fontos

  • Windows 2000 rendszerben a DHCP-ügyfélszolgáltatás kezdeményezi az DNS rendszerű ügyfélnevek dinamikus regisztrálását. További információ a Dinamikus frissítés és a DNS-kiszolgálók használata a DHCP protokollal című témakörökben található.


A DNS ismertetése

A rész tartalma:

  • DNS-tartománynevek
  • A DNS-lekérdezés működése
  • A zónák és a zónaletöltés ismertetése
  • A névlekérdezés
  • Dinamikus frissítés
  • A Windows 2000 alapú DNS rendszer


DNS-tartománynevek

A tartománynévrendszer (DNS – Domain Name System) meghatározása eredetileg az 1034-es és 1035-ös RFC-dokumentumokban található, melyek a DNS-sel kapcsolatos összes szoftverben azonos elemeket írják le. Például:

  • A DNS-névtér, amely a nevek szervezéséhez használt tartományok struktúráját adja meg.
  • Az erőforrásrekordok, amelyek a DNS-tartományneveket egy meghatározott információhoz rendelik, ami akkor kerül felhasználásra, amikor a nevet a névtérben regisztrálják vagy feloldják.
  • A DNS-kiszolgálók, amelyek az erőforrásrekordokra vonatkozó lekérdezések tárolását és a válaszok küldését végzik.
  • A feloldó néven is ismert DNS-ügyfelek, amelyek lekérdezést küldenek a kiszolgálónak, hogy az a nevekhez a lekérdezésben megadott típusú erőforrásrekordot keressen.

A DNS-névtér ismertetése

Az alábbi ábrán látható DNS-névtér azon az elven alapszik, hogy a nevekkel rendelkező tartományok egy fastruktúra szerint helyezkednek el. A fában az egyes szintek a fa egy ágát vagy levelét jelképezik. Az ág egy olyan szint, ahol az elnevezett erőforrások egy csoportját egynél több név azonosítja. A levél egy nevet jelent, amely az adott szinten egyszer használt, és meghatározott erőforrást azonosít.

DNS-tartományi névtér

Az előző ábrán látható, hogy az internetes gyökérkiszolgálók hogyan hitelesítik a Microsoftot a DNS-tartományi névtér saját tulajdonát képező részében. A DNS-kiszolgálók és -ügyfelek a lekérdezések használatával rendelnek a fában található nevekhez meghatározott típusú erőforrás-információkat. Az információt a DNS-kiszolgálók küldik el az ügyfeleknek a lekérdezésekre adott válaszokban. Az ügyfelek feldolgozzák az információt és továbbítják az alkalmazás felé, amely a név feloldását kérte.

A névfeloldás folyamán szem előtt kell tartani, hogy a DNS-kiszolgálók gyakran DNS-ügyfélként működnek, amikor a lekérdezett név feloldása érdekében lekérdezéseket küldenek más kiszolgálóknak. További információ A DNS-lekérdezés működése című témakörben található.

A DNS-tartományi névtér szervezeti felépítése

A fában előforduló tartománynevek technikai szempontból egy tartományt jelentenek. A DNS-sel foglalkozó anyagok többségében azonban a neveket ötféleképpen különböztetik meg, a név szintjétől és használatának módjától függően. A Microsoft számára regisztrált DNS-tartománynév (microsoft.com) például egy második szintű tartomány. Ennek oka az, hogy a név két részből áll (ezeket címkéknek nevezik), azaz a gyökér vagy a fa csúcsa alatt két szinttel helyezkedik el. A legtöbb DNS-név két vagy több címkéből áll, és minden címke a fa egy szintjének felel meg. A nevekben a címkéket pontok választják el.

A második szintű tartomány megnevezésén kívül a DNS-tartományneveket meg lehet különböztetni a névtérben betöltött funkciójuk alapján (lásd az alábbi táblázatot).

Név típusa | Leírás | Példa
A tartomány gyökere | Ez a fa csúcsa, egy meg nem nevezett szint, melyet néha a nulla értéket képviselő két egymás melletti idézőjel ("") ábrázol. A DNS-névben a gyökeret egy záró pont mutatja (.), ami azt jelzi, hogy a név a gyökér szintjén, a tartományi hierarchiában legfelül található. A példában a DNS-tartománynév megadása teljesnek tekinthető, és az a névtérfa pontosan meghatározott helyére mutat. Az így megadott neveket teljesen minősített tartományneveknek nevezik (FQDN). | A nevet egy pont (.) zárja le, például a „pelda.microsoft.com.” névben látható módon.
Legfelső szintű tartomány | Itt egy két vagy három betűből álló név azonosítja az országot vagy körzetet, illetve a nevet használó szervezetet típusát. További információ a Legfelső szintű tartományok című témakörben található. | A „.com” azt jelzi, hogy a név az Interneten üzleti célú felhasználásra van regisztrálva.
Második szintű tartomány | Az Interneten egy magánszemélyt vagy szervezetet egy változó hosszúságú név azonosít. Ezek a nevek mindig egy legfelső szintű tartományhoz tartoznak, attól függően, hogy a nevet milyen szervezetben vagy földrajzi helyen használják. | A második szintű „microsoft.com.” nevet a Microsoft számára regisztrálta az Internet tartományneveinek bejegyzője.
Altartomány | Egy szervezet további neveket képezhet, amelyek a regisztrált második szintű tartománynévből származnak. Ezek a nevek egy szervezeten belül egy DNS-fát képeznek a szervezeti egységek vagy földrajzi helyek alapján. | A „pelda.microsoft.com.” név a Microsoft által kijelölt fiktív altartománynév, amelyet a dokumentációban példaként használ.
Állomás vagy erőforrás neve | Ezek a nevek a DNS-fában egy levelet jelképeznek és egy adott erőforrást azonosítanak. A DNS-tartománynév bal szélső címkéje általában egy adott számítógépet azonosít a hálózaton. Ha például a név egy A típusú erőforrásrekordban található, akkor az az IP-cím hozzárendelésére szolgál. | Az „a-allomas.pelda.microsoft.com.” név első címkéje („a-allomas”) a hálózaton található adott számítógép DNS-neve.

A DNS-tartománynév értelmezése

A DNS módszere, amellyel a DNS-tartománynévhez vezető teljesen minősített utat megjeleníti és értelmezi, hasonló ahhoz, ahogyan a parancssorban a fájlok vagy alkönyvtárak elérési útja megjelenik.

Például a könyvtárfa elérési útja megadja a számítógépen a fájl pontos helyét. A Windows rendszerű számítógépeken a fordított vonal jel (\) azonosítja azokat a alkönyvtárakat, amelyek egy fájl pontos helyéhez vezetnek. A DNS-rendszerben ennek a pont (.) felel meg, ami a néven belül egy új tartományi szintet ad meg.

Vegyünk egy Services elnevezésű fájlt, melynek teljes elérési útja a Windows parancssorban az alábbi módon jelenik meg:

C:\Winnt\System32\Drivers\Etc\Services

Az elérési utat balról jobbra haladva kell értelmezni, a legmagasabb szintű vagy legáltalánosabb információtól (a C meghajtó, amelyen a fájl található) a leginkább specifikus információig, ami a fájl neve (Services). A példában ötszintű hierarchián keresztül juthat el a Services fájlhoz a C meghajtón.

  1. A C meghajtó gyökérmappája (C:\).
  2. A rendszer gyökérmappája, amelyben a Windows telepítése történt (Winnt).
  3. A rendszerelemek tárolására szolgáló rendszermappa (System32).
  4. Az eszközillesztők tárolására szolgáló almappa (Drivers).
  5. Egy további almappa, amelyben a rendszer és a hálózati illesztőprogramok által használt különböző fájlok találhatók (Etc).

A DNS-rendszernél az alábbi példában egy többszintű teljesen minősített tartománynév (FQDN) látható:

a-allomas.pelda.microsoft.com.

A fájlnévnél leírtaktól eltérően, ha a teljesen minősített DNS-tartománynevet balról jobbra olvassa, akkor a leginkább specifikus információtól (az „a-allomas” számítógépnév) a legmagasabb szintű (vagy legáltalánosabb) információ felé halad (a záró pont (.), ami a DNS-névtérfa gyökerét jelzi). A példában az „a-allomas”: helytől távolodva négy különböző DNS-tartományi szint látható.

  1. A „pelda” az az altartomány, amelyben az „a-allomas” nevű számítógép regisztrálva van.
  2. A „microsoft”, amely a „pelda” altartomány szülőtartománya vagy gyökere.
  3. A „com” tartomány, ami az üzleti és kereskedelmi szervezetek számára létrehozott legfelső szintű tartománynak felel meg, ez a „microsoft” tartomány gyökere.
  4. A záró pont (.), amely egy szabványos elválasztó karakter. Ez a teljes DNS-tartománynevet a DNS-névtérfa gyökérszintjéhez rendeli hozzá.

Háttérinformációk a DNS rendszerről és az Internetről

A DNS (Domain Name System) tartománynévrendszert azért fejlesztették ki, hogy az Internetet használó számítógépek számára biztosítsák a nevek címekhez való hozzárendelésének lehetőségét. Mielőtt a DNS-rendszert 1987-ben bevezették, a rövid számítógépnevek IP-címekhez való rendelése gyakorlatilag kizárólag a „Hosts” nevű megosztott statikus fájl alapján történt.

Kezdetben az Internet kis méretének még megfelelt egy központilag felügyelt fájl, amelyet az Internethez csatlakozó felhasználók az FTP protokoll felhasználásával tettek közzé és töltöttek le. Az internetes helyek rendszeresen elküldték Hosts fájljaik másolatát, és megkapták a hálózat változásait tükröző frissített változatú Hosts fájlokat.

Ahogyan az Internethez csatlakozó számítógépek száma növekedett, működésképtelenné vált az a módszer, hogy egy központi szervezet biztosította a Hosts fájlt minden internetes állomás számára. A fájl egyre nagyobb és így nehezen kezelhető lett, és nehezen lehetett a felhasználókhoz aktuális és frissített formában eljuttatni.

A DNS-szabványt azért fejlesztették ki, hogy a Hosts fájlok alternatíváját biztosítsák. Az alapprotokollok legnagyobb része az 1034-es és 1035-ös számú RFC-dokumentumokban van leírva, amelyekhez az IETF (Internet Engineering Task Force) munkacsoport további RFC-dokumentumokat mellékelt. Az IETF folyamatosan áttekint és jóváhagy új tervezeteket, így a DNS-szabványok az igényeknek megfelelően folyamatosan fejlődnek és változnak.

További tudnivalók A DNS rendszerrel kapcsolatos RFC-dokumentumok című témakörben találhatók.

Megjegyzések

  • A DNS-tartományneveknek minden szinten egyedieknek kell lenniük, de egy adott címke más tartományokban újra felhasználható. A „levelezokiszolgalo” név például a pelda.microsoft.com és microsoft.com tartományokban csak egyszer használható fel.
  • A címkék használatáról, az FQDN nevekről és az állomások DNS-nevére vonatkozó egyéb követelményekről további információ a Névválasztás című témakörben található.
  • A Windows 2000 rendszer támogatja a Hosts fájlok alkalmazását. Ez a módszer a helyi statikus fájlok alapján biztosítja az állomások DNS-tartományneveinek és IP-címeinek hozzárendelését. Ezen az elsődleges és hagyományos módszeren kívül a DNS-ügyfél szolgáltatás elindításakor a Windows 2000 az összes számítógépen feltölti a DNS-nevek helyi gyorsítótárát a fájl tartalmával.
  • A Hosts fájl a rendszergyökér\System32\Drivers\Etc mappában található. A fájl megjelenítéséhez vagy módosításához a Jegyzettömb vagy bármely más szövegszerkesztő program használható. A fájl létrehozásával és szerkesztésével kapcsolatban lásd a fájlban található megjegyzéseket és példákat.


A DNS-lekérdezés működése

Ha egy DNS-ügyfélnek meg kell keresnie egy program által használt nevet, lekérdezést küld a DNS-kiszolgálóknak a név feloldására. Az ügyfél által küldött lekérdezések három információt tartalmaznak, amelyek a kiszolgáló által megválaszolandó kérdést képezik:

  • Egy meghatározott DNS-tartománynév teljesen minősített tartománynévként megadva
  • Egy meghatározott lekérdezéstípus, amely egy lekérési művelet speciális típusát, vagy egy erőforrásrekordot határozhat meg típus szerint
  • A DNS-tartománynév egy adott osztálya

    Windows DNS-kiszolgálók esetén ezt mindig Internet (IN) osztályként kell meghatározni.

A megadott név lehet például egy számítógép teljesen minősített tartományneve (például „a-allomas.pelda.microsoft.com”), és az A rekord kereséséhez megadott lekérdezéstípus. A DNS-lekérdezést egy olyan kérdésként lehet elképzelni, melyet az ügyfél tesz fel a kiszolgálónak, például: „Van A rekordja az 'allomasnev.pelda.microsoft.com.' nevű számítógéphez?” A kiszolgáló válaszának beérkezésekor az ügyfél elolvassa és értelmezi a válaszban szereplő A rekordot, és ezzel meghatározza a név szerint lekért számítógép IP-címét.

A DNS-lekérdezések megválaszolása számos módon történhet. Az ügyfelek néha helyileg is válaszolhatnak a lekérdezésekre a korábbi lekérdezések alapján létrehozott gyorsítótár használatával. A lekérdezések megválaszolására a DNS-kiszolgálók felhasználhatják saját gyorsítótárukat, melyben az erőforrásrekordokra vonatkozó információk szerepelnek. A DNS-kiszolgáló lekérdezhet más DNS-kiszolgálókat és kapcsolatba léphet azokkal az ügyfél nevében, majd visszaküldi a választ az ügyfélnek. Ez a művelet rekurzió néven ismert.

Ezenkívül az ügyfél is megpróbálhat kapcsolatba lépni más DNS-kiszolgálókkal egy név feloldása érdekében. Ehhez a kiszolgálóktól kapott válaszok alapján további lekérdezéseket küld. Ez a művelet iteráció néven ismert.

A DNS-lekérdezési művelet általában két részből áll:

  • A névlekérdezés az ügyfélszámítógépnél indul, mely a DNS-ügyfél szolgáltatásnak adja át a lekérdezést feloldás céljából.
  • Ha a lekérdezés helyileg nem oldható fel, DNS-kiszolgálók vehetők igénybe a névfeloldáshoz.

A következő fejezetek részletesen ismertetik ezeket a műveleteket.

1. rész: A helyi feloldó

A következő ábrán a DNS-lekérdezési folyamat áttekintése látható.

A DNS-lekérdezés működése

A lekérdezési folyamat azzal kezdődik, hogy egy, a helyi számítógépen futtatott program DNS-tartománynevet használ. A lekérést a DNS-ügyfél szolgáltatás fogadja, mely a helyi gyorsítótárban tárolt információk alapján próbálja feloldani a nevet. Ha a lekérdezett név megtalálható a gyorsítótárban, akkor a szolgáltatás megválaszolja a lekérdezést, és a folyamat véget ér.

A helyi gyorsítótárban lévő információk két forrásból származhatnak:

  • Ha van konfigurált helyi Hosts fájl, akkor a DNS-ügyfél szolgáltatás indításakor a rendszer betölti a fájlban lévő hozzárendelési információkat a gyorsítótárba.
  • A korábbi DNS-lekérdezésekre küldött válaszból származó erőforrásrekordok a gyorsítótárba kerülnek és egy ideig ott maradnak.

Ha a helyi gyorsítótár alapján nem lehet megválaszolni a lekérdezést, akkor az ügyfél lekérdezést küld egy DNS-kiszolgálónak a név feloldása érdekében.

2. rész: DNS-kiszolgáló lekérdezése

Amint azt az előző ábra mutatja, az ügyfél lekérdez egy elsődleges DNS-kiszolgálót. A rendszer kiválasztja a folyamat első részében használt aktuális kiszolgálót egy globális listából. Ha további információkra van szüksége arról, hogyan állítja össze és frissíti a Windows 2000 ezt a globális listát, olvassa el az Ügyfélszolgáltatások című témakört.

A DNS-kiszolgáló a lekérdezés beérkezésekor ellenőrzi, hogy a helyileg beállított zónájában lévő erőforrásrekord-információk alapján képes-e mérvadóan megválaszolni a lekérdezést. Ha a lekérdezett név megegyezik a helyi zónainformációk egyik erőforrásrekordjával, a kiszolgáló mérvadóan válaszol, és feloldja a lekérdezett nevet.

Ha a lekérdezett névhez nem található zónainformáció, a kiszolgáló ellenőrzi, hogy képes-e feloldani a nevet a korábbi lekérdezések gyorsítótárazott információi alapján. Ha van egyezés, a kiszolgáló megválaszolja a lekérdezést. Ha az elsődleges kiszolgáló képes a lekérdezés megválaszolására a gyorsítótár alapján, a lekérdezés befejeződik.

Ha a kiszolgáló gyorsítótára vagy zónainformációi alapján a lekérdezést nem lehet megválaszolni, a lekérdezés rekurzió használatával folytatódik. Ennek során a lekérdezés megválaszolásához más DNS-kiszolgálók is lekérdezhetők. Alapértelmezés szerint a DNS-ügyfél szolgáltatás azt kéri, hogy a kiszolgáló rekurziót használjon az ügyfél nevében a válasz visszaküldése előtt. A legtöbb esetben a DNS-kiszolgáló alapértelmezés szerint úgy van beállítva, hogy támogassa a rekurziót. Lásd az alábbi ábrát:

A rekurzió működése

Ahhoz, hogy a DNS-kiszolgáló megfelelően végezze a rekurziót, információkra van szüksége a DNS-tartományi névtérben található más DNS-kiszolgálókról. Ezek az információk a gyökérútmutató formájában érhetők el. A gyökérútmutató olyan erőforrásrekordok listája, melyeket a DNS-szolgáltatás használ olyan más DNS-kiszolgálók megkeresésére, melyek mérvadók a DNS-tartományi névtérfa gyökere számára. A gyökérkiszolgálók a tartomány gyökeréhez és a DNS-tartományi névtérfa legfelső szintjéhez mérvadók. További tájékoztatásért olvassa el a Gyökérútmutatók frissítése című témakört.

A DNS-kiszolgálók gyökérútmutatók használatával keresik meg a gyökérkiszolgálókat, ezzel képesek a rekurzió megvalósítására. Elméletileg ez a művelet bármely DNS-kiszolgáló számára lehetővé teszi azoknak a kiszolgálóknak a megtalálását, amelyek a névtérfa valamelyik szintjén használt más DNS-tartománynevekre mérvadók.

A „b-allomas.pelda.microsoft.com” név keresésekor például vegye számításba a rekurzió használatát, ha az ügyfél egyetlen DNS-kiszolgálót kérdez le. A rekurzió akkor következik be, amikor egy DNS-kiszolgáló és egy ügyfél először indul el, ezért helyi gyorsítótáruk még nem tartalmaz információkat a névfeloldások elvégzésére. Ez feltételezi, hogy az ügyfél által lekérdezett név egy olyan tartománynévre vonatkozik, amelyről a kiszolgáló nem rendelkezik adatokkal a konfigurált zónái alapján.

Az elsődleges kiszolgáló elsőként elemzi a teljes nevet és megállapítja, hogy szüksége van a legfelső szintű tartományhoz („com.”) mérvadó kiszolgáló helyére. Ezután iteratív lekérdezést küld a „com” DNS-kiszolgálónak, és megszerzi a „microsoft.com” kiszolgáló hivatkozását. A „microsoft.com” kiszolgáló ezután választ küld, mely hivatkozást tartalmaz a „pelda.microsoft.com” DNS-kiszolgálóra.

Végül a rendszer kapcsolatba lép a „pelda.microsoft.com” kiszolgálóval. Mivel ez a kiszolgáló konfigurált zónáinak részeként tartalmazza a lekérdezett nevet, mérvadó választ küld a rekurziót kezdeményező kiszolgálónak. Amikor az eredeti kiszolgáló fogadja a mérvadó válasz szerzéséről értesítő választ, továbbítja azt a lekérdezést küldő ügyfélnek, és ezzel a rekurzív lekérdezés befejeződik.

A rekurzív lekérdezések a fentiek szerint végrehajtva nagy erőforrásigényűek lehetnek, azonban biztosítanak bizonyos előnyöket a DNS-kiszolgáló számára a teljesítménnyel kapcsolatban. A rekurzió végrehajtása során például a rekurzív keresést végző DNS-kiszolgáló információkhoz jut a DNS-tartományi névtérről. Az információkat a kiszolgáló tárolja a gyorsítótárában, és felhasználhatja a jövőbeli lekérdezések megválaszolása során. Az információ mennyiségének növekedésével a gyorsítótár jelentős területet foglalhat a kiszolgáló memóriájából annak ellenére, hogy a DNS-szolgáltatás minden egyes be- és kikapcsolásakor törlődik.

Másodlagos lekérdezésekre adott válaszok

A DNS-lekérdezések előző leírása feltételezi, hogy a művelet az ügyfélnek visszaküldött pozitív válasszal fejeződik be. A lekérdezésekre azonban más válasz is érkezhet. A következők a leggyakoribbak:

  • Mérvadó válasz
  • Pozitív válasz
  • Átirányító válasz
  • Negatív válasz

A mérvadó válasz egy olyan pozitív válasz, melyet az ügyfél a hitelesítő bitkészlettel kap meg a DNS-üzenetben. Ez jelzi, hogy a válasz a lekérdezett névhez közvetlen jogosultsággal rendelkező kiszolgálóról érkezett.

A pozitív válasz a lekért erőforrásrekordot vagy erőforrásrekordok listáját (ez rekordkészlet néven is ismert) tartalmazza, melyek megfelelnek a lekérdezésben szereplő DNS-tartománynévnek és rekordtípusnak.

Az átirányítási válasz a lekérdezésben név vagy típus szerint meg nem határozott további erőforrásrekordokat tartalmaz. Az ilyen típusú válasz visszakerül az ügyfélhez, ha a rekurziót a rendszer nem támogatja. A rekordok segítségével az ügyfelek iteráció használatával folytathatják a lekérdezést.

Az átirányító válasz olyan további adatokat (például erőforrásrekordokat) tartalmazhat, amelyek eltérnek a lekérdezett típustól. Ha a lekérdezett állomásnév például „www” volt és a zónában nem találhatók A rekordok ehhez a névhez, egy CNAME erőforrásrekord a „www”-hez azonban igen, a DNS-kiszolgáló által küldött válasz tartalmazhatja ezt az információt.

Ha az ügyfél képes az iteráció használatára, további lekérdezéseket küldve maga is megpróbálhatja feloldani a nevet az átirányítási információ használatával. További tájékoztatásért olvassa el Az iteráció működése című témakört.

A negatív válasz azt jelzi, hogy az alábbi két esemény valamelyike következett be, miközben a kiszolgáló a lekérdezés feldolgozását és a név rekurzív hozzárendelését végezte:

  • Egy mérvadó kiszolgáló jelezte, hogy a lekérdezett név nem szerepel a DNS-névtérben.
  • Egy mérvadó kiszolgáló jelezte, hogy létezik a lekérdezett név, de nincs hozzá a kért típusú rekord.

A feloldó pozitív vagy negatív válasz formájában visszaküldi a lekérdezés eredményét a kérést küldő programnak és gyorsítótárazza azt.

Megjegyzések

  • Ha a lekérdezésre kapott válasz nem fér el egy UDP-üzenetcsomagban, a DNS-kiszolgáló feladatátvételt kezdeményezhet az 53-as TCP porton keresztül, és így TCP-kapcsolat használatával válaszolhat az ügyfélnek.

  • A DNS-kiszolgálókon a rekurzió használatát általában akkor tiltják le, ha a DNS-ügyfelek által végzett névfeloldás egy meghatározott DNS-kiszolgálóra (például az intranet DNS-kiszolgálójára) van korlátozva. A rekurzió akkor is le lehet tiltva, ha a DNS-kiszolgáló nem képes külső DNS-neveket feloldani és az ügyfeleknek más DNS-kiszolgálót kell igénybe venniük a névfeloldás elvégzéséhez.

    A Windows 2000 Server rendszerben a rekurzió használata az adott kiszolgálón tiltható le a DNS-konzolban található Speciális tulajdonságok beállításával. További tájékoztatásért olvassa el a Rekurzió letiltása DNS-kiszolgálón című témakört.

  • Alapértelmezés szerint a Windows 2000 DNS-kiszolgálók több alapértelmezett időzítést használnak, amikor rekurzív lekérdezéseket hajtanak végre és más DNS-kiszolgálókra csatlakoznak. Ezek a következők:
    • Három másodperces újrapróbálkozási időköz a rekurzióhoz. A DNS szolgáltatás ennyi ideig vár, mielőtt megpróbálná újra végrehajtani a lekérdezést a rekurzív keresés során.
    • Tizenöt másodperces időkorlát a rekurzióhoz. A DNS szolgáltatás ennyi idő elteltével nyilvánítja sikertelennek a rekurzív keresést.

    A legtöbb esetben ezeket a paramétereket nem kell módosítani. Ha a rekurzív lekérdezést alacsony sebességű WAN-kapcsolaton keresztül végzi, kisebb módosításokkal javítható a kiszolgáló és a lekérdezés teljesítménye. További információ a Speciális kiszolgálóparaméterek hangolása című témakörben található.

Az iteráció működése

Az iteráció egy olyan névfeloldási típus, melyet a DNS-ügyfelek és -kiszolgálók az alábbi feltételek teljesülése esetén alkalmaznak:

  • Az ügyfél rekurzió használatát kéri, de az a DNS-kiszolgálón le van tiltva.
  • A DNS-kiszolgáló lekérdezésekor az ügyfél nem kéri rekurzió használatát.

Az iteratív lekérdezés tudatja a DNS-kiszolgálóval, hogy az ügyfél az elérhető legalkalmasabb választ szeretné kapni úgy, hogy a DNS-kiszolgáló nem lép kapcsolatba más DNS-kiszolgálókkal.

Az iteráció használata esetén a DNS-kiszolgáló a névtérről helyileg tárolt információi alapján válaszol az ügyfélnek. Ha az intraneten lévő egyik helyi ügyfél például lekérdezi a DNS-kiszolgálótól a „www.microsoft.com” nevet, a kiszolgáló saját névgyorsítótárának használatával is válaszolhat a lekérdezésre. Ha a lekérdezett név nem található kiszolgáló gyorsítótárában, akkor átirányítással, azaz egy olyan listával is válaszolhat, mely az ügyfél által kért névhez közelebb lévő DNS-kiszolgálók NS és A rekordjait tartalmazza.

Átirányítás esetén a DNS-ügyfél felelős azért, hogy folytassa az iteratív lekérdezések küldését más DNS-kiszolgálóknak a név feloldása céljából. A bonyolultabb esetekben például a DNS-ügyfél akár a tartomány gyökérkiszolgálóiig is kiterjesztheti azon DNS-kiszolgálók keresését, melyek a „com” tartományhoz mérvadók. Ha az ügyfél kapcsolatba lépett az Internet gyökérkiszolgálóival, további iteratív válaszokat kaphat azoktól, melyek a „microsoft.com” tartomány DNS-kiszolgálóira mutatnak az Interneten. Ha az ügyfél megkapja a DNS-kiszolgálók rekordjait, újabb iteratív lekérdezést küldhet az Interneten lévő külső Microsoft DNS-kiszolgálóknak, melyek egyértelmű és mérvadó választ küldhetnek számára.

Az iteráció használatakor a DNS-kiszolgáló további segítséget is nyújthat a névfeloldásban azon túl, hogy az általa elérhető legalkalmasabb információt elküldi az ügyfélnek. Az iteratív lekérdezések többségénél az ügyfél a DNS-kiszolgálókat tartalmazó, helyileg beállított lista használatával lép kapcsolatba más névkiszolgálókkal a DNS-névtéren keresztül, ha elsődleges DNS-kiszolgálója nem képes a lekérdezés megválaszolására.

A gyorsítótárazás működése

A DNS-kiszolgálók a rekurzió és iteráció használata során nagy mennyiségű információhoz jutnak a DNS-névtérről. A megszerzett információk a kiszolgáló gyorsítótárába kerülnek.

A gyorsítótárazás segítségével növelhető a jövőbeli lekérdezések megválaszolásának sebessége, és lényegesen csökkenthető a DNS-sel kapcsolatos forgalom a hálózaton.

A DNS-kiszolgálók az ügyfelek nevében végzett rekurzív lekérdezések során átmenetileg gyorsítótárba helyezik az erőforrásrekordokat. A gyorsítótárazott erőforrásrekordok olyan DNS-kiszolgálóktól kapott információkat tartalmaznak, amelyek mérvadók az iteratív lekérdezések végrehajtása során szerzett nevekhez. Amikor később más ügyfelek olyan lekérdezéseket küldenek, melyeknek a gyorsítótárban szereplő információk megfelelnek, a DNS-kiszolgáló a gyorsítótár használatával válaszol a lekérdezésre.

Az információk gyorsítótárba helyezésekor minden erőforrásrekord kap egy élettartam (TTL) értéket. Amíg egy gyorsítótárazott erőforrásrekord élettartama nem jár le, a DNS-kiszolgáló felhasználhatja azt az ügyféltől érkező és az adott erőforrásrekordoknak megfelelő lekérdezések megválaszolására. A zónák többségében az erőforrások a Minimális (alapértelmezett) TTL élettartamértéket kapják, amely a zóna SOA rekordjában állítható be. A minimális TTL-érték alapértelmezés szerint 3600 másodperc (1 óra). Az érték módosítható, de szükség esetén akár minden erőforrásrekordhoz is megadható külön élettartam.

Megjegyzések

  • Olyan Windows 2000 DNS-kiszolgálót is telepíthet, melyen nincsenek konfigurált zónák, hanem csak gyorsítótárazást végez. További információkat a Csak gyorsítótárazást végző kiszolgálók használata című témakörben találhat.
  • A Windows 2000 DNS-kiszolgálók alapértelmezés szerint egy gyökétútmutató-fájlt használnak (Cache.dns), mely a kiszolgáló %rendszergyökér%\System32\Dns mappájában található. A szolgáltatás indításakor a fájl a kiszolgáló memóriájába töltődik, és a DNS-névtér gyökérkiszolgálóira mutató információkat tartalmaz, melyben a DNS-kiszolgálók működnek. A fájllal és annak használatával kapcsolatban további információ A DNS-szolgáltatáshoz tartozó fájlok című témakörben található.


A zónák és a zónaletöltés ismertetése

A tartománynévrendszer (DNS) lehetővé teszi a DNS-névtér felosztását zónákra, amelyek egy vagy több DNS-tartományról tárolnak névinformációkat. A zónában lévő DNS-tartománynevekhez a zóna lesz a mérvadó információforrás az adott tartományról.

A zónák és a tartományok közötti különbség ismertetése

A zóna először egy DNS-tartománynév adatbázisának szerepét tölti be. A zóna létrehozásához használt tartomány alá hozzáadott tartományok lehetnek ugyanannak a zónának a részei, vagy tartozhatnak más zónához. A hozzáadott altartomány a következők valamelyike lehet:

  • Az eredeti zónarekordok részeként kezelt vagy belefoglalt
  • Az altartomány támogatására létrehozott más zónához delegált

A következő ábrán például a microsoft.com tartomány látható, amely a Microsoft tartományneveit tartalmazza. Amikor egy különálló kiszolgálón először hozzák létre a microsoft.com tartományt, egyedüli zónaként állítják be az összes Microsoft DNS-névtérhez. Ha azonban a microsoft.com tartományban altartományokat kell használni, azokat be kell foglalni a zónába vagy más zónához kell delegálni.

A zónák és tartományok közötti különbség

Ebben a példában a pelda.microsoft.com tartomány egy új altartományt mutat be (pelda.microsoft.com), mely a microsoft.com zónából más zónába van delegálva és önmagában van kezelve. A microsoft.com zónának azonban tartalmaznia kell néhány rekordot az olyan delegálási információk biztosítása érdekében, melyek a delegált pelda.microsoft.com altartományra mérvadó DNS-kiszolgálókra hivatkoznak.

A microsoft.com zóna által nem delegált altartományok adatai a microsoft.com zóna részei maradnak. A dev.microsoft.com altartomány például nincs delegálva, hanem a microsoft.com zóna kezeli.

A zónareplikálás és zónaletöltés szükségességének okai

Mivel a zónák fontos szerepet töltenek be a DNS-ben, fontos, hogy egynél több DNS-kiszolgálóról is elérhetők legyenek a hálózaton, biztosítva ezzel a jobb elérhetőséget és nagyobb hibatűrést a névlekérdezések feldolgozása során. Egyetlen kiszolgáló használata esetén sikertelen lehet a névlekérdezés, ha a kiszolgáló nem válaszképes. A többi kiszolgálón zónaátvitelt kell végezni a zóna összes olyan másolatának replikálása és szinkronizálása érdekében, melyet a zónát tároló kiszolgálók használnak.

A hálózatra kerülő új, másodlagos kiszolgálóként konfigurált DNS-kiszolgálók a zóna teljes kezdeti letöltésével beszerzik és replikálják a zónában található rekordok teljes másolatát. A DNS-kiszolgáló első megvalósításaiban is ezt a módszer használják, amikor a zóna módosításai után frissítésre van szükség. A Windows 2000 Server rendszerben a DNS-szolgáltatás támogatja a növekményes zónaletöltést, mely egy továbbfejlesztett zónaletöltési eljárás.

A növekményes zónaletöltések

A DNS-szabvány kiegészítését képező növekményes zónaletöltések ismertetése az 1995-ös számú RFC-dokumentumban található. A zónában bekövetkezett változások és frissítések terjesztése sokkal hatékonyabban végezhető, ha mind a zónaforrás szerepét betöltő DNS-kiszolgáló, mind az arról másolást végző kiszolgálók támogatják a növekményes letöltést.

A DNS korábbi megvalósításaiban a zónaadatok frissítésének kérésekor a teljes zónaadatbázist le kellett tölteni egy AXFR lekérdezés segítségével. A növekményes zónaletöltésnél ehelyett egy másodlagos lekérdezéstípus (IXFR) használható. Ez lehetővé teszi, hogy a másodlagos kiszolgáló csak azokat a zónamódosításokat használja fel, amelyek a zónamásolat és a forrás (a zóna elsődleges vagy másodlagos másolata, melyet egy másik DNS-kiszolgáló tárol) szinkronizálásához szükségesek.

Az IXFR alapú zónaletöltéseknél a rendszer elsőként meghatározza, hogy mi a zóna forrása és annak replikált verziói közötti különbség. Ha a zónák azonos verziójúak (ez a zónák SOA rekordjában lévő sorozatszám mezőből állapítható meg), nem történik zónaletöltés.

Ha a forrás sorozatszáma nagyobb, mint a kérést kezdeményező másodlagos kiszolgálón, csak a módosított erőforrásrekordok lesznek letöltve. A zóna DNS-kiszolgálójának tárolnia kell a növekményes zónaváltozások előzményeit ahhoz, hogy az IXFR-lekérdezés sikeres legyen. A növekményes letöltési eljárás lényegesen kisebb hálózati forgalmat igényel és az így végzett zónaletöltések sokkal gyorsabbak.

Példa: zónaletöltés

Zónaletöltés a következő események esetén történhet:

  • A zóna frissítési időközének lejártakor
  • Amikor egy másodlagos kiszolgálót annak főkiszolgálója zónamódosításokról értesít
  • Amikor a DNS-kiszolgáló szolgáltatás elindítása a zóna másodlagos kiszolgálójáról történik
  • Amikor a zóna másodlagos kiszolgálójáról kézileg kezdeményeznek letöltést a főkiszolgálóról a DNS-konzol használatával.

A zónaletöltések a zóna másodlagos kiszolgálóiról indíthatók. A kérést a főkiszolgáló kapja meg, amely a zóna forrásaként működik. A főkiszolgáló lehet bármelyik más DNS-kiszolgáló, amelyik betölti a zónát, például a zóna elsődleges kiszolgálója, vagy másik másodlagos kiszolgáló. Amikor a főkiszolgáló a zónára vonatkozó kérést kap, megválaszolhatja azt akár részleges, akár teljes zónaletöltéssel.

Amint azt a következő ábra mutatja, a kiszolgálók közötti zónaletöltés rendezett művelet szerint történik. A művelet attól függően változik, hogy a zónát előzőleg már replikálták-e, vagy egy új zóna kezdeti replikálása van-e folyamatban.

Példa: zónaletöltés

Ebben a példában a következő műveletek mennek végbe a lekérdezést végző másodlagos kiszolgálón (célkiszolgáló) és annak forráskiszolgálóján (a zónát tároló másik DNS-kiszolgáló):

  1. Az új konfiguráció során a célkiszolgáló egy „minden zóna” letöltési kérelmet (AXFR) küld a zónaforrásként beállított fő DNS-kiszolgálónak.
  2. A fő (forrás-) kiszolgáló válaszol és teljesen letölti a zónát a másodlagos (cél-) kiszolgálóra.

    A zóna továbbítódik a letöltést kérő célkiszolgálóra a SOA rekord tulajdonságaiban lévő Sorozatszám mező használatával meghatározott verziószámmal. A SOA rekord tartalmaz egy másodpercekben megadott frissítési időközt (alapértelmezés szerint 900 másodperc vagy 15 perc), mely meghatározza, hogy a célkiszolgálónak mikor kell kérnie a zóna frissítését a forráskiszolgálótól.

  3. Amikor a frissítési időköz lejár, a célkiszolgáló egy SOA-lekérdezéssel kéri a zóna frissítését a forráskiszolgálótól.
  4. A forráskiszolgáló megválaszolja a SOA rekordját érintő lekérdezést.

    Ez a válasz tartalmazza a zóna sorozatszámát a forráskiszolgálón lévő jelenlegi állapotában.

  5. A célkiszolgáló ellenőrzi a válaszban lévő SOA rekord sorozatszámát és meghatározza, hogyan kell a zónát megújítani.

    Ha a SOA-válaszban lévő sorozatszám értéke megegyezik az érvényes helyi sorozatszámmal, azt a következtetést vonja le, hogy a zóna mindkét kiszolgálón azonos, és nincs szükség zónaletöltésre. A célkiszolgáló ezután megújítja a zónát és alaphelyzetbe állítja annak frissítési időközét a forráskiszolgálótól kapott SOA-válasz alapján.

    Ha a SOA-válaszban lévő sorozatszám értéke nagyobb, mint az érvényes helyi sorozatszám, azt a következtetést vonja le, hogy a zónát frissítették és zónaletöltésre van szükség.

  6. Ilyen esetben a célkiszolgáló egy IXFR-lekérdezést küld a forráskiszolgálóra, amely tartalmazza a zóna SOA rekordjában lévő sorozatszám aktuális értékét.
  7. A forráskiszolgáló növekményes vagy teljes zónaletöltéssel válaszol.

    Ha a forráskiszolgáló a zónaváltozások előzményeinek tárolásával támogatja a növekményes letöltést, válaszolhat a zóna növekményes letöltésével (IXFR).

    Ha a forráskiszolgáló nem támogatja a növekményes letöltést vagy nem rendelkezik a zónamódosítások előzményeivel, akkor a választ egy teljes (AXFR) zónaletöltéssel tudja megadni.

Megjegyzés

  • A Windows 2000 Server rendszer támogatja a növekményes zónaletöltést az IXFR-lekérdezéseken keresztül. A Windows NT Server 4.0-s verziója, illetve a DNS-kiszolgáló más megvalósításain futó egyes DNS-szolgáltatások nem támogatják a növekményes zónaletöltést, ezért a zónák replikálásához csak a teljes zónalekérdezés (AXFR) és -letöltés alkalmazható.

DNS-értesítés

A Windows DNS-kiszolgálók támogatják a DNS-értesítés szolgáltatást, az eredeti DNS protokoll egyik frissítését, amely módot ad a másodlagos kiszolgálók értesítésére, ha a zónában változások következnek be (1996-os számú RFC). A DNS-értesítés segítségével értesíthetők egy zóna kiválasztott másodlagos kiszolgálói a zóna frissítése esetén. Az értesített kiszolgálók a fent ismertetett eljárással kezdeményezhetik a zónaletöltést a zóna változásainak letöltése és a zóna helyi replikájának frissítése érdekében.

A másodlagos kiszolgálókat akkor értesíti a zónájuk forrásaként beállított DNS-kiszolgáló, ha azok IP-címe szerepel a forráskiszolgáló értesítési listájában. A DNS-konzolban ez a lista az Értesítés párbeszédpanelen található, amely a zóna Tulajdonságai párbeszédpanel Zónaletöltés lapjáról érhető el.

A felsorolt kiszolgálók értesítésén túl a DNS-konzol lehetővé teszi, hogy a zónaletöltés lehetőségét a listában megadott másodlagos kiszolgálókra korlátozza. Ez segít megakadályozni, hogy egy ismeretlen vagy jóvá nem hagyott DNS-kiszolgáló megkíséreljen zónafrissítést kérni. További tájékoztatást az Elsődleges zóna értesítési listáinak létrehozása és kezelése című témakörben talál.

A következők a zónafrissítések esetén végzett DNS-értesítési eljárás rövid összefoglalását tartalmazzák:

  1. Frissül a főkiszolgálóként működő DNS-kiszolgáló helyi zónája, mely más kiszolgálók forrásaként szolgál. A zóna frissítésekor a SOA rekordban lévő sorozatszám mező szintén frissítve lesz, mely jelzi a zóna új verzióját.
  2. A főkiszolgáló egy DNS-értesítési üzenetet küld azoknak a kiszolgálóknak, amelyek szerepelnek az értesítési listájában.
  3. Az értesítési üzenetet fogadó másodlagos kiszolgálók ezután egy zónaletöltési kérelemmel válaszolnak az értesítést küldő főkiszolgálónak.

Ezután az előző részben leírtak szerint folytatódik a zónaletöltési művelet.

Fontos

  • A DNS-értesítést csak a zóna másodlagos kiszolgálóiként működő kiszolgálók értesítésére használja. A címtárba integrált zónák replikálásához nincs szükség DNS-értesítésre.

    Ez annak köszönhető, hogy a zónát az Active Directoryból betöltő DNS-kiszolgálók automatikusan lekérdezik a címtárat (körülbelül 15 percenként) a zóna frissítése érdekében.

    Ezekben az esetekben egy értesítési lista beállítása csökkentheti a rendszer teljesítményét, mivel felesleges letöltési kéréseket okoz.


A névlekérdezés

A DNS-keresések során az ügyfelek általában címkeresést hajtanak végre, ami egy másik számítógép A rekordjában tárolt DNS-neve alapján végrehajtott keresés. Ez a lekérdezés egy IP-címet tartalmazó rekordot vár a válaszban.

A DNS a névkeresést is lehetővé teszi, így az ügyfelek akár egy meglévő IP-cím alapján is megkereshetik egy számítógép nevét. A névkeresés egy kérdés formájában valósul meg, például: „Meg tudja mondani annak a számítógépnek a DNS-nevét, amelynek IP-címe 192.168.1.20?”.

A DNS-t eredetileg nem tervezték az ilyen lekérdezések támogatására. A névlekérdezés támogatásának egyik problémája abból a különbségből adódik, ahogy a DNS-névtér a neveket szervezi és indexeli, és ahogy az IP-címek kiadása történik. Ha az előző kérdés megválaszolásának egyetlen módja a DNS-névtérben lévő összes tartomány keresése lenne, a névlekérdezés túl hosszú ideig tartana és túl sok műveletet igényelne.

A probléma megoldására a DNS-szabványokban egy speciális tartományt határoztak meg (az in-addr.arpa tartományt), melynek segítségével megbízhatóan és egyszerűen elvégezhetők a névlekérdezések. A fordított névterek létrehozásához az in-addr.arpa tartományon belüli altartományokat az IP-címekben lévő számok fordított sorrendjével alakították ki.

Az tartományokat azért kell fordított sorrendben szerepeltetni minden oktettérték esetén, mert a DNS-nevekkel ellentétben az IP-címek olvasása balról jobbra, értelmezése viszont fordított értelemben történik. Az IP-címek balról jobbra olvasva a legáltalánosabb információktól (IP-hálózati címtől) haladnak az egyre pontosabb információk felé (IP-állomás címe).

Az IP-címekben lévő oktettek sorrendjét ezért meg kell fordítani az in-addr.arpa tartományfa felépítésekor. Ezzel az elrendezéssel a DNS in-addr.arpa fa alsóbb ágainak felügyelete átadható a vállalatoknak, mivel azok rendelkeznek az IP-címek egy meghatározott vagy korlátozott készletével az Internet által definiált címosztályokban.

A DNS-be épített in-addr.arpa tartományfa egy további rekordtípus (a PTR rekord) meghatározását is igényli. Ezt az erőforrásrekordot a rendszer egy olyan hozzárendelés létrehozására használja, mely általában egy állomás DNS-számítógépnevéhez tartozó A rekordnak felel meg annak címkeresési zónájában.

Megjegyzés

  • Az in-addr.arpa tartomány használata az összes olyan TCP/IP-hálózaton érvényes, amely az Internet Protokoll 4-es verziójú (IPv4) címzésen alapul. Az Új zóna varázsló automatikusan feltételezi ennek a tartománynak a használatát, amikor egy új névkeresési zónát hoz létre.

    Ha egy 6-os verziójú IP-hálózatra (IPv6) telepíti a DNS-t és állítja be a névkeresési zónákat, az Új zóna varázslóban megadhat egy konkrét nevet. Ez lehetővé teszi olyan névkeresési zónák létrehozását a DNS-konzolban, amelyek felhasználhatók az eltérő tartománynevet (ip6.int tartományt) használó IPv6-hálózatok támogatására.

    Az IPv6-tal és a DNS-sel, valamint az ip6.int tartománynevek létrehozásával és használatával kapcsolatban további információk találhatók az 1886-os számú RFC-dokumentumban, melynek címe: „DNS Extensions to support IP version 6” (DNS-kiterjesztések a 6-os IP-verzió támogatására). Ha további információkra van szüksége, olvassa el az RFC-dokumentumot, mely a Request for Comments webhelyen található.

Példa: Névlekérdezés (IPv4 alapú hálózatokhoz)

A következő ábra olyan névlekérdezést mutat be, amelyet egy DNS-ügyfél (b-allomas) kezdeményezett egy másik állomás (a-allomas) nevének megszerzése érdekében annak IP-címe alapján (192.168.1.20).

Példa: DNS-névlekérdezés

Az ábrán látható módon a névlekérdezés a következő lépések végrehajtásával történik:

  1. Az ügyfél („b-allomas”) lekérdezi a DNS-kiszolgálótól azt a PTR rekordot, mely az „a-allomas” IP-címéhez (192.168.1.20) van rendelve.

    Mivel a lekérdezés a PTR rekordra vonatkozik, a feloldó megfordítja a címet és az in-addr.arpa tartományt hozzáfűzi a fordított cím végéhez. Ez alkotja a névkeresési zónában keresendő teljesen minősített tartománynevet („20.1.168.192.in-addr.arpa.”).

  2. Ha a keresett információkat a rendszer megtalálja, a „20.1.168.192.in-addr.arpa” tartomány mérvadó DNS-kiszolgálója elküldi a PTR rekordot. Ez tartalmazza az „a-allomas” DNS-tartománynevét, így a névkeresési művelet befejeződik.

Ne feledje, hogy ha a lekérdezett név nem válaszolható meg a DNS-kiszolgálóról, szokásos DNS-feloldás (rekurzív vagy iteratív) használatával is megkereshető az a DNS-kiszolgáló, mely mérvadó a névkeresési zónához és tartalmazza a lekérdezett nevet. A névlekérdezésnél használt névfeloldás ebben az esetben megfelel a címkeresés során végzett művelettel.

Megjegyzés

  • A Windows 2000 Server rendszerben a DNS beépülő modul segítségével konfigurálható egy alhálózati, osztállyal nem rendelkező névkeresési zóna, ha a Speciális nézet van kijelölve. Ez lehetővé teszi egy olyan zóna beállítását az in-addr.arpa tartományban a kijelölt IP-címekhez, melyben a címekhez nem alapértelmezett IP-alhálózati maszk használható. További tudnivalók A névlekérdezési zónák kezelése című témakörben találhatók.

Inverz lekérdezések

Az inverz lekérdezés egy elavult műveletsor, amelyet eredetileg a DNS szabvány részeként javasoltak az állomásnevek IP-cím alapján történő keresésére. Ezek a lekérdezések nem szabványos DNS-lekérdezési műveletet használnak és alkalmazásuk a DNS-szolgáltatás hibakeresését és ellenőrzését szolgáló parancssori segédprogram, az Nslookup néhány korábbi verziójára korlátozódik.

Windows 2000 Server rendszerben a DNS-szolgáltatás felismeri és elfogadja az inverz lekérdezési üzeneteket és azokra hamis inverz lekérdezési választ ad. A Windows NT Server 4.0-s verzióját futtató DNS-kiszolgálók esetén ez a lehetőség alapértelmezés szerint rendelkezésre áll, ha a kiszolgáló számítógép frissítve van a 4-es szervizcsomaggal.

Megjegyzések

  • A PTR rekordok és a névkeresési zónák beállítása az állomások névlekérdezéssel történő azonosításához a DNS-szabvány egyik választható része. A névkeresési zónák használata nem elengedhetetlen, bár néhány hálózati alkalmazásnál a biztonsági ellenőrzések végrehajtásához alkalmazzák azokat.


Dinamikus frissítés

A dinamikus frissítés lehetővé teszi, hogy a DNS-ügyfélszámítógépek regisztrálják és dinamikusan frissítsék megváltozott erőforrásrekordjaikat a DNS-kiszolgálón. Így csökkenthető a zónarekordok kézi felügyelete, különösen olyan ügyfelek esetén, melyek gyakran változtatják helyüket, és a DHCP protokollt alkalmazzák IP-cím igénylésére.

A Windows 2000 a 2136-os számú RFC-dokumentumban leírtaknak megfelelően mind az ügyfél-, mind a kiszolgálóoldalon támogatja a dinamikus frissítések használatát. A DNS-kiszolgálókon a DNS-szolgáltatás a dinamikus frissítések engedélyezését és tiltását zónánként biztosítja. A kiszolgálók szabványos elsődleges vagy címtárba integrált zóna letöltésére lehetnek beállítva. Alapértelmezés szerint a Windows 2000 tetszőleges verziójával működő, a TCP/IP használatához beállított ügyfélszámítógépek dinamikusan frissítik A típusú erőforrásrekordjaikat a DNS rendszerben.

A DNS-nevek frissítése a Windows 2000 rendszerrel működő számítógépeken

Alapértelmezés szerint a Windows 2000 rendszert futtató és a TCP/IP használatához statikusan beállított számítógépek megpróbálják dinamikusan regisztrálni állomás (A) és mutató (PTR) típusú erőforrásrekordjaikat azon IP-címek esetén, amelyek a telepített hálózati kapcsolatokhoz vannak beállítva és használva. Alapértelmezés szerint a rekordokat minden számítógép A számítógép teljes neve alapján regisztrálja.

A Windows 2000 rendszerű számítógépeknél a számítógép teljes neve, azaz a teljesen minősített tartománynév az alábbi rendszerbeállításokon alapul:

A Számítógép elsődleges DNS-utótagja hozzáfűzve a Számítógépnévhez .

Ezek a beállítások a Rendszertulajdonságok párbeszédpanel Hálózati azonosítás lapján tekinthetők meg és módosíthatók. További információ A számítógép hálózati azonosításának megjelenítése és az Ügyfélszámítógép elsődleges DNS-utótagjának beállítása című témakörben található.

A dinamikus frissítések küldésére az alábbi okok és események miatt lehet szükség:

  • IP-cím hozzáadása, eltávolítása vagy módosítása a TCP/IP-tulajdonságok beállításában valamelyik hálózati kapcsolatnál.
  • Ha egy IP-címbérlet valamelyik telepített hálózati kapcsolatnál a beállítások megváltoztatását vagy felújítását kéri a DHCP-kiszolgálótól. Ez történik például a számítógép bekapcsolásakor vagy az ipconfig /renew parancs kiadásakor.
  • Az ipconfig /registerdns paranccsal kézileg adhatja meg, hogy a DNS frissítse az ügyfélnév regisztrációját.
  • A számítógép bekapcsolásakor történő rendszerindításnál.

Ha az említett események valamelyike elindítja a dinamikus frissítést, a DHCP-ügyfél szolgáltatás (nem a DNS-ügyfél szolgáltatás) frissítéseket fog küldeni. Ez azért van így, hogy ha a DHCP miatt az IP-cím megváltozik, akkor a számítógéphez tartozó név-cím hozzárendelések frissítésével azok szinkronban maradjanak a DNS-rendszerben. A DHCP-ügyfél szolgáltatás ezt a műveletet a rendszeren használt minden hálózati kapcsolatnál elvégzi, beleértve azokat a kapcsolatokat is, amelyek nincsenek a DHCP használatához beállítva.

Megjegyzések

  • A saját IP-címük megszerzéséhez DHCP-t használó, Windows 2000 rendszert futtató számítógépek esetén a dinamikus frissítések eltérően működnek az itt leírtaktól. További információ a DNS-kiszolgálók használata a DHCP protokollal című témakörben található.
  • Az itt ismertetett frissítési eljárás feltételezi, hogy a Windows 2000 alapértelmezett beállításai vannak érvényben. Az alapértelmezettől eltérő DNS-beállításokat alkalmazó speciális TCP/IP tulajdonságok esetén meghatározott nevek használhatók és módosítható a frissítési folyamat.

    A számítógép teljes nevén (vagy elsődleges nevén) kívül még további kapcsolatspecifikus DNS-neveket lehet beállítani és regisztrálni vagy frissíteni a DNS rendszerben. További információ a Több DNS beállítása és A TCP/IP beállítása a DNS használatához című témakörben található.

Példa: A dinamikus frissítés működése

A Windows 2000 rendszerben a számítógép általában akkor kér dinamikus frissítést, ha a DNS-neve vagy IP-címe megváltozik. Tegyük fel például, hogy a „regiallomas” nevű ügyfélnél a Rendszertulajdonságok párbeszédpanelen először a következő neveket állítja be:

Számítógép neve | regiallomas
DNS-tartománynév | pelda.microsoft.com
A számítógép teljes neve | regiallomas.pelda.microsoft.com

A fenti példában nincs kapcsolatspecifikus DNS-tartománynév a számítógéphez. Később a számítógép „regiallomas” neve az „ujallomas” névre változik, ami a rendszerben az alábbi névváltozásokat eredményezi:

Számítógép neve | ujallomas
DNS-tartománynév | pelda.microsoft.com
A számítógép teljes neve | ujallomas.pelda.microsoft.com

Ha a felhasználó a Rendszertulajdonságok párbeszédpanelen megváltoztatja a nevet, a Windows 2000 figyelmezteti, hogy indítsa újra a számítógépet. A Windows újraindításakor a DHCP-ügyfél szolgáltatás a DNS frissítéséhez az alábbi műveleteket végzi el:

  1. A DHCP-ügyfél szolgáltatás a számítógép DNS-tartománynevének használatával egy SOA típusú lekérdezést küld.

    Az ügyfélszámítógép a jelenleg beállított teljesen minősített tartománynevet használja a lekérdezésben (például az „ujallomas.pelda.microsoft.com” nevet).

  2. Az ügyfél teljesen minősített tartománynevét tartalmazó zóna mérvadó DNS-kiszolgálója válaszol a SOA típusú lekérdezésre.

    Szabványos elsődleges zónák esetén a SOA-lekérdezésre adott válaszban lévő elsődleges kiszolgáló (tulajdonos) rögzített és statikus. Mindig pontosan egyezik a zónával tárolt SOA erőforrásrekordban megjelenő DNS-névvel. Ha azonban a frissítendő zóna címtárba integrált, a zónát letöltő bármely DNS-kiszolgáló válaszolhat, és a SOA-lekérdezésre adott válaszba dinamikusan beillesztheti a saját nevét elsődleges kiszolgálóként (tulajdonosként).

  3. Ezt követően a DHCP-ügyfél szolgáltatás megpróbál kapcsolatot teremteni az elsődleges DNS-kiszolgálóval.

    Az ügyfél a SOA-lekérdezésre kapott válasz alapján megállapítja annak a DNS-kiszolgálónak az IP-címét, amely a nevének fogadására vonatkozóan elsődleges kiszolgálóként van hitelesítve. Ezután szükség szerint elvégzi az alábbi műveleteket, és kapcsolatba lép az elsődleges kiszolgálóval, valamint frissíti azt:

    1. Dinamikus frissítési kérelmet küld a SOA-lekérdezés válaszában meghatározott elsődleges kiszolgálónak.

      Ha a frissítés sikeres, nincs további teendő.

    2. Ha a frissítés sikertelen, akkor az ügyfél egy NS típusú lekérdezést küld a SOA rekordban meghatározott zóna nevével kapcsolatban.
    3. Ha választ kap erre a lekérdezésre, egy SOA-lekérdezést küld a válaszban lévő listán szereplő első DNS-kiszolgálónak.
    4. A SOA-lekérdezés válaszát megkapva az ügyfél dinamikus frissítést küld a SOA rekordban megadott DNS-kiszolgálónak.

      Ha a frissítés sikeres, nincs további teendő.

    5. Ha a frissítés sikertelen, akkor az ügyfél a válaszlistán szereplő következő DNS-kiszolgáló számára küldi a SOA-lekérdezést.
  4. Miután az ügyfél kapcsolatot létesített a frissítés elvégzésére képes elsődleges kiszolgálóval, elküldi annak a frissítési kérelmet, és a kiszolgáló feldolgozza azt.

    A frissítési kérelem utasításokat tartalmaz az „ujallomas.pelda.microsoft.com” név A típusú (és esetleg PTR típusú) rekordjainak bejegyzésével és a korábban regisztrált „regiallomas.pelda.microsoft.com” név azonos típusú rekordjainak eltávolításával kapcsolatban.

    A kiszolgáló ellenőrzi, hogy a frissítések végrehajtása engedélyezve van-e az ügyfélkérelem számára. A szabványos elsődleges zónák esetén a dinamikus frissítések nincsenek biztonsági szempontból ellenőrizve, így bármely ügyfél frissítési próbálkozása sikeres lesz. Az Active Directoryval integrált zónák esetén a frissítésekre az Active Directory biztonsági beállításai vonatkoznak. További információ a Biztonságos dinamikus frissítések című témakörben található.

A dinamikus frissítések rendszeresek. Alapértelmezés szerint a Windows 2000 24 óránként küld el egy frissítést. Ha a frissítés hatására a zónaadatok nem változnak meg, akkor a zóna változatlan marad, és nem lesznek változások bejegyezve. A frissítés csak akkor eredményez tényleges zónaváltozást vagy zónaletöltést, ha a nevek vagy címek megváltoznak.

Tudni kell, hogy az inaktívvá vált, vagy a frissítési időtartamon (24 órán) belül nem frissített nevek a DNS-zónákban maradnak. A DNS nem szabadítja fel és nem jelöli ki törlésre a neveket, bár a DNS-ügyfelek a név vagy a cím megváltozásakor megpróbálják törölni vagy frissíteni a régi neveket tartalmazó rekordokat.

Ha a DHCP-ügyfél szolgáltatás A és PTR típusú erőforrásrekordokat regisztrál egy Windows 2000 rendszerrel működő számítógépre vonatkozóan, az állomásrekordok alapértelmezett élettartamát a gyorsítótárban 15 percre állítja be. Ez meghatározza, hogy más DNS-kiszolgálók és -ügyfelek mennyi ideig tartsák a gyorsítótárban egy számítógép rekordjait, amikor azok egy lekérdezésre adott válaszban szerepelnek.

Biztonságos dinamikus frissítés

A Windows 2000 rendszerben a biztonságos DNS-frissítés csak olyan zónáknál érhető el, amelyek integrálva vannak az Active Directoryval. Ha egy zóna integrálva van az Active Directoryval, akkor a DNS-konzolban elérhetők a hozzáférés-szabályozási lista szerkesztési funkciói, melyekkel felhasználókat és csoportokat adhat a hozzáférés-szabályozási listához, illetve távolíthat el róla egy adott zónára vagy erőforrásrekordra vonatkozóan. További információ az Erőforrásrekord biztonsági beállításainak módosítása és a Címtárba integrált zóna biztonsági beállításának módosítása című témakörben található.

Alapértelmezés szerint a Windows 2000 DNS-kiszolgálók és -ügyfelek esetében a dinamikus frissítés adatbiztonsága a következőképpen működik:

  • A Windows 2000 DNS-ügyfelek először nem biztonságos dinamikus frissítést próbálnak elvégezni. Ha ezt a kiszolgáló elutasítja, az ügyfél megpróbálkozik a biztonságos frissítéssel.

    Az ügyfelek a frissítésre létrehozhatnak alapértelmezett házirendet, amely lehetővé teszi számukra, hogy egy korábban regisztrált erőforrásrekordot felülírjanak, ha azt a frissítés adatbiztonsága nem tiltja.

  • Ha egy zóna integrálttá válik az Active Directoryval, a Windows 2000 DNS-kiszolgálók alapértelmezés szerint csak biztonságos dinamikus frissítéseket engedélyeznek.

    Szabványos zónatárolás használata esetén a DNS-kiszolgáló szolgáltatás alapértelmezés szerint nem engedélyezi zónáinak dinamikus frissítését. Mind a címtárba integrált, mind a szabványos fájlban tárolt zónák esetén engedélyezni lehet a dinamikus frissítések elfogadását és a biztonságos frissítés mellőzését.

Fontos

  • A Windows 2000 Server rendszer DHCP-kiszolgáló szolgáltatása végzi a DNS-rekordok proxyregisztrációját és frissítését olyan régebbi verziójú ügyfelek számára, melyek nem támogatják a dinamikus frissítést.

    Ha a hálózatán több Windows 2000 DHCP-kiszolgálót alkalmaz, és a zónái úgy vannak beállítva, hogy csak biztonságos dinamikus frissítést lehessen végezni, a DHCP-kiszolgálókat az Active Directory – felhasználók és számítógépek használatával adhatja a beépített DnsUpdateProxyGroup csoporthoz. Ezáltal minden DHCP-kiszolgáló számára engedélyezve lesz, hogy bármelyik DHCP-ügyfél számára proxyfrissítéseket végezzen.

    További információ a DNS-kiszolgálók használata a DHCP protokollal és a Csoportok kezelése című témakörben található.

Vigyázat

  • A Windows 2000 rendszerben a biztonságos dinamikus frissítéseket veszélyeztetheti az, ha DHCP-kiszolgálót futtat egy tartományvezérlőn, és a Windows 2000 DHCP-kiszolgáló úgy van beállítva, hogy a DNS-rekordok regisztrálását az ügyfelek nevében végezze. Ennek elkerülése érdekében a DHCP-kiszolgálókat és a tartományvezérlőket külön számítógépeken kell telepíteni. Ha a névkeresési (PTR) rekordok adatbiztonsága nem fontos, akkor ez az elővigyázatosság csak akkor indokolt, ha a DHCP-kiszolgáló úgy van beállítva, hogy az A típusú rekordok regisztrálását az ügyfelek nevében végezze (ami nem egy alapértelmezett beállítás). További információ A DnsUpdateProxy nevű csoport használata során felmerülő biztonsági kérdések című témakörben található.

Megjegyzések

  • A dinamikus frissítés a DNS-szabvány egyik új kiegészítése, melynek leírása a 2136-os számú RFC-dokumentumban található. További információ az RFC-dokumentumban áll rendelkezésre. Az RFC-dokumentumok beszerzésével kapcsolatban további információ A TCP/IP protokollal kapcsolatos RFC-dokumentumok című témakörben található.
  • A Windows 2000 DNS-kiszolgálókra és -ügyfelekre vonatkozó további információt a Windows 2000 Server Resource Kit tartalmaz a dinamikus frissítésekkel és a biztonságos frissítésekkel kapcsolatban. További információkért olvassa el a Windows 2000 Resource Kit című témakört.


A Windows 2000 alapú DNS rendszer

A rész tartalma:

  • Az Active Directory integrálása
  • Az elévülés és a takarítás ismertetése
  • Unicode karakterek támogatása
  • A WINS-keresés integrálása


Az Active Directory integrálása

A Windows 2000 Server rendszerben a DNS-kiszolgáló szolgáltatást gondosan integrálták a következő generációs címtárszolgáltatás, az Active Directory kialakításával, amelyet a Microsoft a Windows NT technológiát használó hálózatok számára tervezett. Az Active Directory vállalati szintű eszközt biztosít egy hálózatban az erőforrások szervezéséhez, kezeléséhez és kereséséhez.

Két jelentős változás tapasztalható, ha Windows 2000 DNS-kiszolgálókat telepít az Active Directoryval együtt:

  • A Windows 2000 tartományvezérlők kereséséhez szükség van a DNS-re.

    A Netlogon szolgáltatás új módon támogatja a DNS-kiszolgálót a DNS-tartomány névterében lévő tartományvezérlők regisztrálásának biztosítására.

  • A Windows 2000 DNS-kiszolgálók az Active Directoryt használhatják a zónák tárolására és replikálására.

    A zónákat integráló címtár segítségével kihasználhatók a Windows 2000 DNS szolgáltatásának további előnyei, például a biztonságos dinamikus frissítési, illetve rekordelévülési és -takarítási szolgáltatások.

    További tájékoztatás a Biztonságos dinamikus frissítés és Az elévülés és a takarítás ismertetése című témakörökben található.

A DNS és az Active Directory integrálása

Ha telepíti az Active Directoryt egy kiszolgáló számítógépre, a kiszolgáló az adott tartomány tartományvezérlőjévé lép elő. A művelet befejezésekor felszólítást kap az Active Directory tartomány DNS-tartománynevének megadására, amelyhez majd csatlakozhat, és amelyben a kiszolgálót használni kívánja.

Ha a művelet alatt a megadott tartomány mérvadó DNS-kiszolgálója nem található a hálózaton, vagy nem támogatja a DNS dinamikus frissítési protokollt, lehetőséget kap egy Windows 2000 DNS-kiszolgáló telepítésére. Ez a lehetőség azért áll rendelkezésre, mert az Active Directory használatához és ahhoz, hogy a Windows 2000 rendszert futtató számítógépek megtalálják a kiszolgálót vagy más tartományvezérlőket, egy DNS-kiszolgálóra van szükség. Ha további információkra van szüksége arról, hogyan keresi meg a Windows 2000 a tartományvezérlőket a DNS segítségével, olvassa el a Windows 2000 Resource Kit című témakört.

Az Active Directory telepítése után két lehetőség közül választhat a zónák tárolására és replikálására, ha új tartományvezérlőn használja a DNS-kiszolgálót:

  • Szabványos zónatárolás, szöveg alapú fájl használatával.

    Az így tárolt zónák .Dns fájlokban helyezkednek el, amelyek a DNS-kiszolgálót futtató számítógépen a %rendszergyökér%\System32\Dns mappában találhatók. A zónafájlok neve megfelel a zóna létrehozásakor választott névnek, például pelda.microsoft.com.dns, ha a zóna neve „pelda.microsoft.com”.

  • Címtárral integrált zónatárolás, az Active Directory adatbázisának használatával.

    Az így tárolt zónák az Active Directory fában találhatók a tartomány tárolóobjektuma alatt. A címtárral integrált zónák egy dnsZone objektumtárolóban tárolódnak, melyet a zóna létrehozásakor megadott név azonosít.

Az Active Directory integrálásának előnyei

Az Active Directory támogatásához DNS-t alkalmazó hálózatok esetén javasolt a címtárral integrált elsődleges zónák használata a következő előnyök biztosítására:

  • Több főkiszolgálós frissítés és fokozott rendszerbiztonság az Active Directory képességeinek köszönhetően.

    Szabványos zónatárolási modellben a DNS-frissítések végrehajtása az egy főkiszolgálós frissítési modell alapján történik. Ebben a modellben egyetlen mérvadó DNS-kiszolgáló van kijelölve a zóna elsődleges erőforrásaként.

    Ez a kiszolgáló tartja karban a zóna eredeti példányát egy helyi fájlban. Ebben a modellben a zóna elsődleges kiszolgálója jelenti a meghibásodás egyetlen pontját. Ha a kiszolgáló nem elérhető, a DNS-ügyfelekről érkező frissítési kérelmek feldolgozása nem történik meg.

    Címtárba integrált zónatárolási modell esetén a dinamikus DNS-frissítések végrehajtása a több főkiszolgálós frissítési modell alapján történik.

    Ebben a modellben bármelyik mérvadó DNS-kiszolgáló (például egy, a Windows 2000 DNS-kiszolgáló szolgáltatást futtató tartományvezérlő) kijelölhető a zóna elsődleges forrásaként. Mivel a zóna eredeti példányát az Active Directory adatbázisa tartalmazza, amelyet a rendszer minden tartományvezérlőre replikál, a zóna bármely tartományvezérlőn működő DNS-kiszolgálóról frissíthető.

    Az Active Directory több főkiszolgálós frissítési modelljében a címtárba integrált zóna bármelyik elsődleges kiszolgálója feldolgozhatja a DNS-ügyfelektől érkező zónafrissítési kérelmeket mindaddig, amíg hozzáférhető és elérhető a hálózaton.

    Ehhez hasonlóan a címtárba integrált zónák használatakor a hozzáférés-szabályozási lista (ACL) szerkesztésével biztosítható a könyvtárfában lévő dnsZone tárolóobjektum. Ez a szolgáltatás differenciált hozzáférést biztosít akár a zónához, akár a zóna egy megadott erőforrásrekordjához.

    Egy zóna erőforrásrekordjához tartozó hozzáférés-szabályozási lista például korlátozható úgy, hogy dinamikus frissítéseket csak meghatározott ügyfélszámítógép vagy biztonsági csoport (például tartomány-rendszergazdai csoport) végezhessen. Ez a biztonsági szolgáltatás a szabványos elsődleges zónák esetén nem áll rendelkezésre.

    Ne feledje, hogy ha címtárba integrálttá alakítja a zónát, a zóna frissítésének alapértelmezése úgy módosul, hogy csak biztonságos frissítések végezhetők.

  • Ha új tartományvezérlőt ad az Active Directory tartományhoz, a rendszer automatikusan replikálja rá a zónákat és elvégzi a szinkronizálást.

    Bár a DNS-szolgáltatás külön is eltávolítható egy tartományvezérlőről, a címtárba integrált zónákat az egyes tartományvezérlők már tárolják, így a zónatárolás és kezelés nem képez további erőforrást. Ehhez hasonlóan a címtárban tárolt információk szinkronizálására használt módszerek teljesítményjavulást eredményeznek a szabványos zónafrissítési módszerekkel szemben, amelyeknek szükségük lehet a teljes zóna letöltésére.

  • Ha integrálja a DNS-zóna adatbázisainak tárolását az Active Directoryba, egyszerűsítheti az adatbázisok replikálásának kivitelezését a hálózaton.

    Ha a DNS és az Active Directory névtereinek tárolása és replikálása külön történik, minden egyes névteret külön kell megtervezni és felügyelni. Szabványos DNS-zónatárolás és az Active Directory együttes használatakor például két eltérő adatbázis-replikálási topológiát kell megtervezni, kivitelezni, tesztelni és karbantartani. Egy replikálási topológia szükséges például a címtáradatok replikálásához a tartományvezérlők között, egy másik pedig a zóna adatbázisainak replikálásához a DNS-kiszolgálók között.

    Ez tovább nehezíti a hálózat tervezését és esetleges növekedésének felügyeletét. A DNS-tárolás integrálásával egységesítheti a tárkezeléssel és a replikálással kapcsolatos feladatokat mind a DNS, mind az Active Directory esetében, és egy felügyeleti egységként kezelheti azokat.

  • A címtárreplikálás gyorsabb és hatékonyabb, mint a szabványos DNS-replikálás.

    Mivel az Active Directory replikálásának feldolgozása tulajdonságok alapján történik, a rendszer csak a megfelelő módosításokat továbbítja. Így a címtárban tárolt zónák frissítésekor kevesebb adatot kell felhasználni és továbbítani.

Megjegyzések

  • A címtárban csak elsődleges zónák tárolhatók. A DNS-kiszolgálók nem tudnak másodlagos zónákat tárolni a címtárban. Azokat szabványos szövegfájlokban kell tárolnia.
  • A Windows 2000 DNS-kiszolgáló lehetőséget ad a tartományvezérlőn futó DNS-kiszolgáló inicializálására és az összes DNS-zóna, valamint az Active Directoryban tárolt ide vonatkozó beállítási részletek betöltésére. További információ A kiszolgáló alapértelmezett beállításainak megváltoztatása című témakörben található.


Az elévülés és a takarítás ismertetése

A Windows 2000 DNS-kiszolgálók elévülési és takarítási szolgáltatásokat biztosítanak. Segítségükkel elvégezhető a zónaadatokban idővel összegyűlő elévült erőforrásrekordok eltávolítása.

A dinamikus frissítéssel az erőforrásrekordok automatikusan hozzáadódnak a zónákhoz, amikor a hálózaton a számítógépek elindulnak. Bizonyos esetekben azonban a rendszer nem távolítja el őket automatikusan, amikor a számítógép levál a hálózatról. Ha egy számítógép például az indulásnál regisztrálja saját A rekordját és később a gépet helytelenül kapcsolják le a hálózatról, az A rekord esetleg nem lesz törölve. Ha a hálózaton mobil felhasználók és számítógépek találhatók, ez gyakran előfordulhat.

A feleslegesen megmaradt erőforrásrekordok jelenléte problémákat okozhat a zónaadatokban. Például:

  • Ha sok elavult erőforrásrekord marad a kiszolgáló zónáiban, idővel sok helyet foglalnak a kiszolgáló lemezterületén és szükségtelenül hosszú zónaletöltéseket okoznak.
  • Az elavult erőforrásrekordokat tartalmazó zónákat betöltő DNS-kiszolgálók elavult információkat adhatnak válaszul az ügyfelek lekérdezéseire, ezzel névhozzárendelési problémákat okozva a hálózaton.
  • Az elavult erőforrásrekordok összegyűlése a DNS-kiszolgálón csökkentheti annak teljesítményét és válaszképességét.
  • Bizonyos esetekben egy elavult erőforrásrekord jelenléte a zónában meggátolhatja, hogy a DNS-tartománynevet más számítógép vagy állomás is használhassa.

A problémák megoldásához a DNS-kiszolgáló szolgáltatás az alábbi lehetőségeket biztosítja:

  1. A kiszolgálón beállított aktuális dátumon és időn alapuló időbélyegzés az elsődleges típusú zónákba dinamikusan felvett bármelyik erőforrásrekord számára. Az időbélyegzők bejegyzése a szabványos elsődleges zónákba történik, ha az elévülés és takarítás engedélyezve van.

    A kézzel hozzáadott erőforrásrekordok esetén az időbélyegző értéke nulla, mely azt jelzi, hogy azokat nem érinti az elévülési folyamat és korlátozás nélkül a zónaadatokban maradhatnak, amíg nem módosítja az időbélyegzőt vagy nem törli őket.

  2. Helyi adatok erőforrásrekordjainak elévülése egy adott frissítési időtartam alapján bármelyik alkalmas zóna esetén.

    Csak a DNS-kiszolgáló szolgáltatás által betöltött elsődleges típusú zónák alkalmasak arra, hogy részt vegyenek a műveletben.

  3. A megadott frissítési időtartamon túl is megmaradó erőforrásrekordok takarítása.

    Ha egy Windows 2000 DNS-kiszolgáló takarítási műveletet hajt végre, képes meghatározni az elévülési pontot elért erőforrásrekordokat és el tudja azokat távolítani a zónaadatokból. A kiszolgálók beállíthatók úgy, hogy automatikusan hajtsák végre a takarítási műveleteket, de a művelet saját kezűleg is kezdeményezhető.

    További tájékoztatásért olvassa el a Régi erőforrásrekordok automatikus kitakarításának engedélyezése vagy a Régi erőforrásrekordok kitakarításának azonnali indítása című témaköröket.

Vigyázat

  • A Windows 2000 DNS-kiszolgálóknál alapértelmezés szerint az elévülési és takarítási mechanizmus tiltva van. Engedélyezni csak az összes paraméter teljes megértése után szabad. Ellenkező esetben a kiszolgáló véletlenül beállítható a nem törlendő rekordok törlésére. Egy rekord véletlen törlése esetén nem csak a rekord lekérdezése lesz sikertelen, de bármelyik felhasználó létre is hozhatja a rekordot és birtokolhatja azt, még a biztonságos dinamikus frissítésekre beállított zónákon is.

A kiszolgáló az egyes erőforrásrekord-specifikus időbélyegzők tartalmát használja a beállított más elévülési és takarítási tulajdonságokkal együtt annak meghatározására, hogy mikor kell törölni a rekordokat.

Az elévülés és takarítás előfeltételei

A Windows 2000 DNS szolgáltatásának elévülési és takarítási funkcióinak használatához bizonyos feltételeket ki kell elégíteni:

  1. A takarítást és elévülést engedélyezni kell mind a DNS-kiszolgálón, mind a zónában.

    Alapértelmezés szerint az erőforrásrekordok elévülése és takarítása tiltott.

  2. Az erőforrásrekordokat dinamikusan kell hozzáadni a zónákhoz, vagy kézzel kell módosítani azokat ahhoz, hogy az elévülési és takarítási műveletekben használhatók legyenek.

    Általában csak a DNS dinamikus frissítési protokoll segítségével dinamikusan hozzáadott erőforrásrekordok esetén alkalmazható az elévülés és a takarítás. További információ a Dinamikus frissítés című témakörben található.

    Olyan erőforrásrekordok takarítása is engedélyezhető, melyek hozzáadása nem dinamikus eszközökkel történt. A zónákhoz más DNS-kiszolgálóról származó szöveges zónafájl betöltésével vagy kézzel hozzáadott rekordok esetén az időbélyegző beállítása nulla. Ez a rekordokat az elévülési és takarítási műveletekhez való felhasználásra alkalmatlanná teszi.

    Az alapértelmezés módosításához az erőforrásrekordok egyedi felügyeletével alaphelyzetbe állíthatja őket és engedélyezheti számukra az aktuális (nem nulla) időbélyegző-érték használatát. Ez lehetővé teszi, hogy a rekordok elévüljenek és a rendszer időszakosan takarítsa őket.

    További tájékoztatásért olvassa el az Erőforrásrekord elévülési és kitakarítási tulajdonságainak alaphelyzetbe állítása című témakört.

Megjegyzés

  • Abban az esetben, ha egy zónát szabványos elsődlegesről Active Directoryval integráltra módosít, szüksége lehet a zónában meglévő összes erőforrásrekord takarításának engedélyezésére. A zónában meglévő valamennyi erőforrásrekord elévülésének engedélyezéséhez felhasználható a dnscmd parancssori eszközön keresztül elérhető AgeAllRecords parancs. További információ A kiszolgáló felügyeletének automatizálása a Dnscmd paranccsal című témakörben található.

Az elévüléssel és takarítással kapcsolatban használt terminológia

Az elévülési és takarítási folyamat a Windows 2000 Server új szolgáltatása. A következő táblázat azokat az új és módosított kifejezéseket tartalmazza, amelyek kifejezetten ehhez a szolgáltatáshoz tartoznak.

Kifejezés | Leírás
Erőforrásrekord időbélyegzője | A DNS-kiszolgáló által használt dátum és idő, mely alapján a DNS-kiszolgáló a takarítási műveletek végrehajtása során meghatározza, hogy mely erőforrásrekordokat kell eltávolítani.
Aktuális kiszolgálóidő | Az aktuális dátum és idő a DNS-kiszolgálón. Ez a szám bármely időpont esetén kifejezhető egy pontos értékként.
Frissítés nélküli időköz Az egyes zónákhoz meghatározott időköz, a következő két eseményhez kötve:
  1. A rekord utolsó frissítésének, valamint az időbélyegző beállításának dátuma és időpontja.
  2. A rekord következő frissítésének és a rekordhoz tartozó időbélyegző alaphelyzetbe állításának dátuma és időpontja.

Ez az érték az Active Directory adatbázisában végzett írási műveletek számának csökkentéséhez szükséges. Alapértelmezés szerint az időköz beállítása 7 nap. Nem ajánlott indokolatlanul megnövelni ezt az értéket, mert az elévülési és takarítási szolgáltatás előnyei elveszhetnek.
Frissítési időköz Az egyes zónákhoz meghatározott időköz, a következő két eseményhez kötve:
  1. A rekord frissítésének és a rekordhoz tartozó időbélyegző alaphelyzetbe állításának legkorábbi dátuma és időpontja.
  2. A rekord takarításának és a zónaadatbázisból történő eltávolításának legkorábbi dátuma és időpontja.

Ennek az értéknek kellően nagynak kell lennie ahhoz, hogy az összes ügyfél frissíthesse rekordjait. Alapértelmezés szerint az időköz beállítása 7 nap. Nem ajánlott indokolatlanul megnövelni ezt az értéket, mert az elévülési és takarítási szolgáltatás előnyei elveszhetnek.
Takarítás kezdete | Egy számmal kifejezett konkrét időpont. Ezt az időpontot a kiszolgáló használja annak meghatározására, mikor lesz egy zóna elérhető takarítás céljából. További tájékoztatásért olvassa el A takarítás kezdésének időpontja című témakört.
Takarítási időköz | Ha a kiszolgálón engedélyezett az automatikus takarítás, ez az érték határozza meg az automatikus takarítások elvégzése közötti időtartamot. Az alapértelmezés szerinti érték 7 nap. A DNS-kiszolgáló teljesítményromlásának elkerülése érdekében az engedélyezett legalacsonyabb érték 1 óra.
Rekordfrissítés Egy erőforrásrekord DNS dinamikus frissítésének feldolgozása, amikor csak az erőforrásrekord időbélyegzője módosul, más jellemzője nem.

A frissítések általában a következő okok miatt történnek meg:

  1. Amikor a hálózaton egy számítógép újraindul és neve, illetve IP-címe megegyezik a leállítás előtt használttal, frissítést küld az erőforrásrekordok megújítása érdekében.
  2. Működés közben a számítógép rendszeresen küld frissítést.

    A Windows 2000 rendszer használatakor valamennyi számítógép 24 óránként megújítja erőforrásrekordjainak DNS-regisztrációját. Az ilyen frissítési kísérletek esetén a frissítési kérelem frissítésnek, és nem erőforrás-frissítésnek tekinthető, ha ugyanazok a DNS-név és IP-cím hozzárendelési információk vannak érvényben.

  3. Más hálózati szolgáltatások is végeznek frissítési kísérleteket, például: Az ügyfelek címbérleteit megújító DHCP-kiszolgálók, egy fürt rekordjait regisztráló és frissítő fürtkiszolgálók, valamint az Active Directory tartományvezérlők által használt erőforrásrekordok regisztrálására és frissítésére képes Net Logon szolgáltatás.
Rekordfrissítés Egy erőforrásrekord DNS dinamikus frissítésének feldolgozása, mely során az időbélyegzőn kívül más jellemzők is módosulnak.

A frissítések általában a következő okok miatt történnek meg:

  1. Ha a hálózat egyik új számítógépe rendszerindításnál frissítést küld, mellyel regisztrálni kívánja erőforrásrekordjait a konfigurált zónában.
  2. Ha megváltozik egy olyan számítógép IP-címe, mely már rendelkezik rekordokkal a zónában, és ezzel frissítést küld a nevéhez rendelt IP-cím módosítására a DNS-zónaadatokban.
  3. Amikor a Net Logon szolgáltatás egy új Active Directory tartományvezérlőt regisztrál.
Kiszolgálók takarítása Olyan speciális zónaparaméter, amely lehetővé egy meghatározott IP-címeket tartalmazó lista létrehozását a zóna takarításának végrehajtására engedélyezett DNS-kiszolgálók számára.

Ha ez a paraméter nincs megadva, akkor alapértelmezés szerint minden olyan Windows 2000 DNS-kiszolgáló megpróbálja elvégezni a zóna takarítását, melyeken a takarítás engedélyezve van és címtárba integrált zónát (melyen a takarítás szintén engedélyezett) töltenek be. Ez a paraméter akkor lehet hasznos, ha a takarítás végrehajtását csak meghatározott kiszolgálókon kívánja engedélyezni.

A paraméter beállításához a zóna ScavengingServers paraméterében meg kell határozni a zóna takarítására engedélyezett kiszolgálók IP-címének listáját. Ez a Windows DNS-kiszolgálók felügyeletére szolgáló parancssori eszközzel, a dnscmd parancs segítségével végezhető el. További információ A kiszolgáló felügyeletének automatizálása a Dnscmd paranccsal című témakörben található.

A takarítás indításának időpontja

Ha a takarítás használatához szükséges összes feltétel adott, akkor a takarítás olyan esetben kezdődik, ha az aktuális kiszolgálóidő meghaladja a zóna takarításkezdési idejét.

A kiszolgáló zónánként állítja be a takarítás kezdetének idejét, valahányszor a következő események valamelyike bekövetkezik:

  • A zóna dinamikus frissítése engedélyezetté válik.
  • Változás történt a Régi erőforrásrekordok kitakarítása jelölőnégyzet állapotában. A beállítás a DNS-konzol használatával módosítható egy megfelelő DNS-kiszolgálón, vagy annak valamelyik elsődleges zónájában.
  • A DNS-kiszolgáló betölt egy takarítás használatára engedélyezett elsődleges zónát.

    Ez a kiszolgáló számítógép vagy a DNS-kiszolgáló szolgáltatás elindításakor fordul elő.

  • Amikor egy zóna szüneteltetés után folytatja a szolgáltatást.

Amikor az előző esemény bekövetkezik, a DNS-kiszolgáló a következő összeg kiszámításával állítja be a takarítás kezdetének időpontját:

Aktuális kiszolgálóidő + frissítési időköz = takarítás kezdete

Ez az érték a takarítási műveletek során összehasonlítási alapként szolgál.

Példa egy mintarekord elévülési és takarítási műveletére

A kiszolgáló által végzett elévülési és takarítási művelet megértéséhez figyelembe kell venni egy erőforrásrekord élettartamát és egymást követő fázisait, annak hozzáadását azokhoz a kiszolgálókhoz és zónákhoz, melyeken a művelet engedélyezve van, majd elévülését és eltávolítását az adatbázisból.

  1. Egy minta DNS-állomás, az „allomas-a.pelda.microsoft.com” regisztrálja A rekordját az elévülés és takarítás használatára engedélyezett zóna DNS-kiszolgálójánál.
  2. A rekord regisztrálásakor a DNS-kiszolgáló az aktuális kiszolgálóidő alapján egy időbélyegzőt helyez el a rekordban.

    A rekord időbélyegzőjének megírása után a DNS-kiszolgáló a zóna frissítés nélküli időköze alatt nem fogad el frissítéseket a rekordhoz. Módosításokat azonban elfogadhat az időpont előtt is. Ha például az „allomas-a.pelda.microsoft.com” IP-címe megváltozik, a DNS-kiszolgáló elfogadhatja a frissítést. Ebben az esetben a kiszolgáló frissíti (alaphelyzetbe állítja) a rekord időbélyegzőjét is.

  3. A frissítés nélküli időszak lejártakor a kiszolgáló fogadni kezdi a rekord frissítési kísérleteit.

    A kezdeti frissítés nélküli időszak vége után azonnal elkezdődik a rekord frissítési időszaka. Ez alatt az idő alatt a kiszolgáló a rekord fennmaradó élettartamára nem tiltja a frissítési kísérleteket.

  4. A frissítési időszak alatt és után a kiszolgáló feldolgozza a beérkezett rekordfrissítéseket.

    Ez alaphelyzetbe állítja a rekord időbélyegzőjét a 2. lépésben leírt módszer alapján.

  5. Amikor a kiszolgáló végrehajtja a „pelda.microsoft.com” zóna következő takarítását, megvizsgálja a rekordot (és az összes többi zónarekordot).

    A rekordokat összehasonlítja az aktuális kiszolgálóidővel a következő összeg alapján, és megállapítja, hogy a rekordot el kell-e távolítani:

    Rekord időbélyegzője + a zóna frissítés nélküli időköze + a zóna frissítési időköze

    • Ha az összeg értéke meghaladja az aktuális kiszolgálóidőt, nem történik semmilyen művelet és a rekord a zónában marad.
    • Ha az összeg értéke alacsonyabb az aktuális kiszolgálóidőnél, a rendszer törli a rekordot a kiszolgálón betöltött zónaadatokból és a megfelelő DnsZone objektumtárolóból, mely az Active Directoryban található a címtárba integrált „pelda.microsoft.com” zóna számára.

Megjegyzés

  • További tájékoztatásért olvassa el a Kiszolgálóadatok elévülésének és takarításának kezelése című témakört.


Unicode karakterek támogatása

Az internetes állomások neveit eredetileg a 952-es és az 1123-as számú RFC-dokumentumokban meghatározott karakterkészlet használatával lehetett megadni. Ezek alapján a nevekben ékezetek nélküli nagy- és kisbetűket (A-Z, a-z), számokat (0-9) és kötőjelet (-) lehet használni. A DNS-név első karaktere lehet egy szám, és a neveket az US-ASCII karakterek használatával kell kódolni és megjeleníteni.

Ezek a követelmények akkor voltak érvényben, amikor a DNS-t az egyik alapvető DNS-szabvány, az 1035-ös számú RFC részeként bevezették. Nemzetközi beállítások esetén ez a követelmény jelentős korlátozást jelentett azokon a helyeken, ahol kiterjesztett karakterkészleteket használnak.

A korlátozások megszüntetése érdekében a Microsoft a Windows 2000 Server fejlesztésekor lehetővé tette olyan karakterek használatát is, melyek nem szerepelnek az 1035-ös számú RFC-dokumentumban lévő specifikációban. Ebben a kiadásban a szolgáltatás már alapértelmezés szerint bővítetten támogatja az UTF-8 (Unicode transformation format) formátumot.

Az UTF-8 formátum

Az UTF-8 a javasolt karakterkészlet az ASCII használatán túlra terjedő protokollokhoz. Az UTF-8 protokoll biztosítja a kiterjesztett ASCII-karakterek támogatását és az UCS-2 lefordítását, amely egy olyan 16 bites Unicode karakterkészlet, mely a világ írásmódjainak többségét magába foglalja. Az UFT-8 sokkal több név használatát teszi lehetővé, mint az ASCII vagy a kiterjesztett ASCII kódolás.

A Windows 2000 Server rendszerben a DNS-szolgáltatás már támogatja az UTF-8 formátumot. Ez azt jelenti, hogy UTF-8 kódolású karakterek fogadásakor és használatakor a kiszolgáló képes az adatok betöltésére és tárolására a zónáiban. Amellett, hogy a Windows 2000 Server rendszeren futó DNS-kiszolgálók képesek az UTF-8 formátum értelmezésére, kompatibilisek maradnak más olyan DNS-kiszolgálókkal is, amelyek a hagyományos US-ASCII adatkódolást és a jelenlegi DNS-szabványokat használják.

Az UTF-8 megvalósítása a DNS-szolgáltatásban

A DNS más megvalósításaival való kompatibilitás és együttműködési képesség megőrzése érdekében a DNS-szolgáltatás a beérkezett karakteradatokat egységesen kisbetűsre alakítja. Ennek során a DNS-szolgáltatás a szabványos US-ASCII formátumú adatokban használt nagybetűs karaktereket kisbetűssé alakítja, a következő okokból:

  • A kompatibilitás megtartására a jelenlegi és meglévő DNS-szabványokkal.
  • Az együttműködés biztosítására a DNS-kiszolgáló olyan megvalósításaival, amelyek nem ismerik fel vagy nem támogatják az UTF-8 kódolást.

Az egységes kisbetűsítés használatának megértéséhez elsőként a DNS-sel kapcsolatos jelenlegi internetes szabványok egyes pontjait kell megvizsgálni. A szabvány több kulcsfontosságú része közvetlenül arra vonatkozik, hogyan kell a karakteradatokat kezelni a DNS-kiszolgálók és más kiszolgálók, valamint az ügyfelek között. Ide tartoznak a következők:

  • Egy DNS-névben bármilyen bináris karakterlánc használható. (2181-es RFC)
  • A DNS-kiszolgálóknak össze kell tudniuk hasonlítani a neveket a kis- és nagybetűk megkülönböztetése nélkül. (1035-ös RFC)
  • A rendszerbe érkező adatokat csak akkor kell kis- vagy nagybetűsíteni, ha az feltétlenül szükséges. (1035-ös RFC)

Mivel a kis- és nagybetűk egységes kezelését az alapvető DNS-szabvány megköveteli, a betűnagyság megőrzése azonban csak egy választható javaslat, a szabványnak való megfelelés érdekében a rendszer az egységes kisbetűsítést alkalmazza. Ha a továbbítás előtt a rendszer kisbetűsre alakítja az UTF-8 kódolású neveket, akkor más DNS-kiszolgálók (amelyek nem ismerik az UTF-8 formátumot) is képesek lesznek az adatok vételére és bináris összehasonlításának sikeres végrehajtására, valamint a várt eredmény megszerzésére.

Az UTF-8 formátummal való együttműködés szempontjai

A Windows 2000 Server rendszerben a DNS-szolgáltatás kiszolgálónként állítható be az UTF-8 formátumú karakterek használatának engedélyezésére vagy letiltására. Az DNS-kiszolgáló UTF-8 formátumot nem ismerő megvalósításai képesek lehetnek UTF-8 kódolású neveket tartalmazó zónák letöltésére, de a nevek visszaírására vagy zónafájlból való ismételt betöltésére már nem. A rendszergazdáknak elővigyázatosnak kell lenniük, amikor UTF-8 formátumú neveket tartalmazó zónát töltenek le olyan DNS-kiszolgálóra, amelyik nem ismeri az UTF-8 formátumot.

Néhány protokoll korlátozza a névben használható karaktereket. A globálisan láthatónak szánt nevek (1958-as RFC) ezen túlmenően csak ASCII-karaktereket tartalmazhatnak az 1123-as RFC-dokumentum javaslata szerint.

Megjegyzések

  • Az UTF-8 formátum használata az Unicode karakterek átalakítására az általános felhasználók számára nem észrevehető. Az UTF-8 kódolású karakterek csak akkor jelennek meg, ha a fizikai hálózat DNS-sel kapcsolatos forgalmának elemzéséhez a Hálózatfigyelőt vagy más hasonló programot használják.
  • Azon túl, hogy a DNS-kiszolgáló támogatja az UTF-8 kódolási formátumot, a Windows 2000 Server ügyfélfeloldója alapértelmezés szerint használja az UTF-8 karakterkódolási formátumot.
  • Az UFT-8 formátumban kódolt nevek nem léphetik túl a 2181-es RFC-dokumentumban megszabott méretkorlátozást, amely címkénként maximálisan 63 oktettet és nevenként 255 oktettet ír elő. A méret meghatározásához nem elegendő a karakterszám, mivel néhány UTF-8 karakter hosszúsága meghaladja az egy oktettet.
  • Az UTF-8 kódolási protokoll alkalmazkodik a DNS-protokoll meglévő megvalósításaihoz, melyek US-ASCII formátumú karaktereket használnak, mivel az UTF-8 formátumban az US-ASCII-karakterek ábrázolása bájtról bájtra megegyezik az US-ASCII formátumú ábrázolással. A Windows NT korábbi verzióiban található DNS-ügyfelek, illetve a DNS-kiszolgáló más megvalósításai, melyek nem ismerik az UTF-8 formátumú karaktereket, mindig US-ASCII formátumban kódolják a neveket. Ezeket a neveket a Windows 2000 Server rendszer DNS-szolgáltatása mindig megfelelően értelmezi.
  • A DNS-szolgáltatás lehetővé teszi a névellenőrzés beállítását a DNS-adatokban lévő UTF-8 karakterek engedélyezésére vagy korlátozására. Ez a beállítás kiszolgálónként és zónánként is megadható. További információkért olvassa el a DNS-kiszolgáló névellenőrzési módszerének módosítása című témakört.

    Alapértelmezés szerint a rendszer a több bájtos UTF-8 névellenőrzést használja, mely a legnagyobb tűréshatárt biztosítja a DNS-szolgáltatás által végzett karakterfeldolgozáskor. Ez a névellenőrzési módszer ajánlott azon privát működtetésű DNS-kiszolgálók számára, melyek nem biztosítanak névszolgáltatást az internetes állomások számára.


A WINS-keresés integrálása

Azok a nevek, amelyek a DNS-tartományi névtér lekérdezésével nem oldhatók fel, a Windows Internet Name Service (WINS) szolgáltatás segítségével kereshetők meg. A WINS-keresés végrehajtásához az alábbi két rekordtípus használatos és engedélyezhető a DNS-szolgáltatás által letöltött zónákhoz:

  • A WINS rekord, amellyel a WINS-keresés a címkeresési zónákba integrálható.
  • A WINS rekord, amellyel a WINS-névlekérdezés a névkeresési zónákba integrálható.

A WINS rekord

A WINS- és a DNS-szolgáltatások a NetBIOS-névtérben, illetve a DNS-tartományi névtérben végzett névfeloldás során használhatók. Mind a DNS, mind a WINS képes névszolgáltatást biztosítani az ügyfelek számára, de a WINS főként az olyan régebbi ügyfelek és programok támogatásához szükséges, amelyek NetBIOS-neveket használnak.

A DNS-szolgáltatás a WINS-szolgáltatással együttműködve képes névkeresést végezni mindkét névtérben is a zónainformációkban nem található DNS-tartománynevek feloldásakor. Az együttműködés biztosítása érdekében egy új rekordot (a WINS rekordot) határoztak meg a zóna adatbázisfájljában.

A WINS rekord a Windows 2000 Server és a korábbi verziójú Windows NT Server rendszerekhez tartozik, és csak a zónák eredeti tartományához csatolható. A WINS rekord meglétekor a DNS-szolgáltatás a WINS-szolgáltatást használhatja azon címlekérdezések végrehajtására, melyek a zóna adatbázisában nem található állomásnevekre vagy nevekre vonatkoznak. Ez a lehetőség különösen hasznos, ha a WINS-et nem használó ügyfelek (például UNIX) olyan nevek feloldását kérik, melyek nincsenek regisztrálva a DNS-ben (például Windows 95 vagy Windows 98 rendszert futtató számítógépek).

A WINS-keresés működése

A következő ábrán egy DNS-ügyfél („b-allomas”) látható, mely DNS-kiszolgálójától az „a-allomas.pelda.microsoft.com” nevű számítógép címét kérdezi le.

Példa a WINS-keresés és a DNS integrálására

Az 1. lépésben az ügyfél lekérdezi az elsődleges DNS-kiszolgálót. A 2-8. lépésben a rekurzió folytatódik, mely során az elsődleges DNS-kiszolgáló lekérdezéseket küld más DNS-kiszolgálóknak az ügyfél nevében. A művelet a 8. lépéssel fejeződik be, amikor az átirányító válaszok eredményeként a rendszer azonosítja a pelda.microsoft.com zóna DNS-kiszolgálóját. Ezen a ponton a rendszer egy Windows DNS-kiszolgálóval lép kapcsolatba, mely Windows NT Server 4.0 vagy Windows 2000 Server rendszert futtat.

Amikor a pelda.microsoft.com zóna Windows DNS-kiszolgálója lekérdezést kap az „a-allomas” nevű állomásra vonatkozóan, keresést hajt végre annak megállapítására, hogy az alapértelmezett zónája tartalmaz-e egyező A rekordot. Ha nem talál A rekordot, és a zónában használható WINS-keresés, akkor a kiszolgáló a következőket végzi:

  • Leválasztja a DNS-lekérdezésben lévő teljesen minősített tartománynévről azt a részt, mely az állomásra vonatkozik (a-allomas).

    A névben az első címke vonatkozik az állomásra, mely az első pont előtt áll.

  • A kiszolgáló ezután egy NetBIOS-névlekérdezést küld a WINS-kiszolgálóra az „a-allomas” név használatával.
  • Ha a WINS-kiszolgáló képes a név feloldására, visszaküldi az IP-címet a DNS-kiszolgálónak.
  • A Windows DNS-kiszolgáló ezután visszaküldi ezt az IP-címet az eredeti elsődleges DNS-kiszolgálónak, amelyet a „b-allomas” nevű ügyfél kérdezett le.
  • Az elsődleges DNS-kiszolgáló ezután visszaküldi a lekérdezésre adott választ az ügyfélnek.

A WINS-névlekérdezés működése

A névkeresési zónákhoz egy WINS-R rekord vagy WINS-névlekérdezési bejegyzés is engedélyezhető és hozzáadható. A WINS adatbázisa azonban IP-cím szerint nincs indexelve, ezért a DNS-szolgáltatás nem tudja IP-cím szerint lekérdezni a WINS-től a számítógépek neveit.

Mivel a WINS nem biztosít névlekérdezést, a DNS-kiszolgáló egy csomópontcsatoló állapotlekérdezést küld közvetlenül a DNS-névlekérdezésben található IP-címre. Amikor a DNS-kiszolgáló megkapja a NetBIOS-nevet a csomópont állapotának lekérdezésére kapott válaszból, hozzáfűzi a DNS-tartománynevet a válaszban kapott NetBIOS-név végéhez, és továbbítja az eredményt az ügyfélnek.

Megjegyzés

  • A WINS és a WINS-R rekordok a Windows 2000 Server és a korábbi verziójú Windows NT Server rendszerek DNS-szolgáltatásának részei. Szükség esetén megakadályozhatja, hogy a rekordok azokban a zónaletöltésekben is szerepeljenek, melyek a DNS-kiszolgáló más megvalósításai felé irányulnak. További tudnivalók A WINS-keresés használata című részben találhatók.


A DNS használata

A rész tartalma:

  • A tervezés alapvető szempontjai
  • Kiszolgálók kezelése
  • Ügyfelek kezelése
  • Zónák kezelése
  • Kiszolgálók figyelése és optimalizálása
  • A kiszolgáló speciális beállításai


A tervezés alapvető szempontjai

A rész tartalma:

  • Névtér tervezése a Tartománynévrendszerhez (DNS)
  • Zóna tervezése DNS névrendszerhez
  • DNS-kiszolgáló működésének megtervezése
  • Kiszolgálók áttelepítése
  • Együttműködés más szolgáltatásokkal


Névtér tervezése a Tartománynévrendszerhez (DNS)

Mielőtt elkezdené a DNS használatát a hálózaton, tervezze meg a DNS-tartomány névterét. A névtér megtervezésekor el kell döntenie, hogy miként szándékozik alkalmazni a DNS névrendszert és milyen célokat kíván megvalósítani használatával. E szakaszban felmerülhet néhány kérdés, például:

  • Választott és regisztráltatott már DNS-tartománynevet internetes használatra?
  • Magánhálózatra vagy az Internetre fogja telepíteni a DNS-kiszolgálókat?
  • Ki szeretné-e használni a DNS Active Directoryt támogató szolgáltatását?
  • Milyen elnevezési követelményeket kell betartani a számítógépek DNS-tartományneveinek kiválasztásakor?

Ezeket a kérdéseket egyenként a következő részek tárgyalják.

Az első DNS-tartománynév kiválasztása

DNS-kiszolgálók telepítésekor ajánlatos először kiválasztani és regisztráltatni egy olyan egyedi DNS-szülőtartománynevet, mint amilyen a „microsoft.com”, ami majd cégének állomásul szolgál az Interneten. Ez a név az Interneten használt legfelsőbb szintű tartományokon belül egy második szintű tartományt jelöl. Az Interneten használt legáltalánosabb legfelsőbb szintű tartományok listáját és leírását a Legfelsőbb szintű tartományok című témakörben találja.

Miután kiválasztotta a szülőtartomány nevét, összekapcsolhatja ezt a nevet a cégen belül használt hely vagy szervezeti egység nevével, így további altartományneveket alakíthat ki. Ha például hozzáadna egy altartományt, mint amilyen az ics.pelda.microsoft.com tartományfa (a cég informatikai csoportja által használt erőforrásokhoz), e névvel további altartományneveket alakíthat ki. A részlegnél elektronikus adatcserével (EDI) foglalkozó programozók egy csoportjának lehet egy „eacs.ics.pelda.microsoft.com” nevű altartománya. Hasonlóképpen a részlegben tanácsadással foglalkozó más munkacsoport használhatja a „tanacs.ics.pelda.microsoft.com” altartományt.

Mielőtt eldöntené, hogy mi legyen a cégnek az Interneten használt DNS-szülőtartományneve, kereséssel győződjön meg arról, hogy ezt a nevet nem regisztrálta-e már más cég vagy személy. Az Internet DNS-névteret jelenleg az Internetes hálózati tájékoztató központ (InterNIC) kezeli. A jövőben más tartománynév-regisztráló szervezetek is elérhetők lesznek.

További tudnivalók A DNS használata az Interneten című témakörben találhatók.

DNS-névtér tervezése Active Directoryhoz

Ha Active Directoryt használ, először létre kell hoznia egy névtér tervet. Ahhoz, hogy Windows 2000 rendszerben a DNS-tartománynévteret megfelelően megvalósíthassa, rendelkezni kell az Active Directory struktúrával. Ezért először tervezze meg az Active Directoryt és támogassa azt a megfelelő DNS-névtérrel. Ha bármelyik terv áttekintése során előre nem látott vagy nem kívánatos következményeket fedez fel, végezze el a szükséges módosításokat.

A Windows 2000 rendszerben az Active Directory tartományok DNS-neveket kapnak. Az Active Directory tartományokhoz használt DNS-nevek kiválasztásakor kezdje azzal a regisztrált DNS-tartománynév utótaggal, amit a cég az internetes használatra lefoglalt (például „microsoft.com”), és az Active Directory tartományok teljes nevének kialakításához kapcsolja össze ezt a nevet a cégnél használt földrajzi nevekkel vagy részlegnevekkel.

Például a Microsoft Windows-tesztcsoportjának tartománya lehet „wintest.example.microsoft.com”. Ez az elnevezési módszer biztosítja, hogy mindegyik Active Directory tartománynév globálisan egyedi legyen. Bevezetése után ez az elnevezési módszer megkönnyíti a meglévő nevek szülőkénti használatát további altartománynevek létrehozásához, valamint a névtér növelését a szervezet új részlegeinek befogadásához.

Egyetlen tartományt vagy kis többtartományos modellt használó kis cég esetében a tervezés egyszerű lehet és az előző példákhoz hasonló megközelítést követhet. Bonyolultabb tartománymodellt alkalmazó nagyobb cég esetében használja útmutatóul a további Microsoft forrásanyagokat, például a Windows 2000 Server Resource Kit Deployment Planning Guide című dokumentumot, amely részletesebben ismerteti az Active Directory névtérmodell megtervezését.

E könyv vagy az Active Directoryhoz esetleg hasznos forrásanyagot nyújtó más Microsoft Press kiadvány beszerzéséhez keresse fel a Microsoft webhelyet.(http://www.microsoft.com/).

Megjegyzés

Vigyázat

  • A DNS- és Active Directory-névtér tervezésekor ajánlatos megkülönböztető, egymástól eltérő és egymást nem fedő nevekből álló készletet használni a DNS belső és külső használatának alapjaként. Példaként a cég szülőtartományneve legyen „pelda.microsoft.com”.
    • Belső DNS-névhasználathoz alkalmazható egy olyan név, mint a „belso.pelda.microsoft.com”.
    • Külső DNS-névhasználathoz alkalmazható egy olyan név, mint a „kulso.pelda.microsoft.com”.

    A belső és külső névterek ilyen elkülönítésével és megkülönböztetésével lehetősége van olyan beállítások egyszerűbb karbantartására, mint a tartománynév szűrő vagy a kizárási listák.

Nevek kiválasztása

Kifejezetten ajánlatos csak olyan karaktereket használni a nevekben, amelyek szerepelnek a DNS-állomáselnevezéshez engedélyezett Internet szabványú karakterkészletben. Az engedélyezett karaktereket az 1123-as számú RFC határozza meg, mely szerint használható valamennyi nagybetű (A-Z), kisbetű (a-z), számjegy (0-9) és a kötőjel (-).

A korábbi Microsoft NetBIOS technológiát alkalmazó cégeknél előfordulhat, hogy a meglévő számítógépnevek a NetBIOS elnevezési szabványnak felelnek meg. Ebben az esetben érdemes megfontolni a számítógépek nevének módosítását az Internet DNS szabványának megfelelően.

A másik elnevezési konvencióra való áttérés időigényes műveletnek bizonyulhat. A Windows NT 4.0 NetBIOS-nevekről Windows 2000 DNS-tartománynevekre történő átállás megkönnyítéséhez a DNS-szolgáltatás támogatja az ASCII és a Unicode karaktereket is. Ez a kiegészítő karaktertámogatás azonban csak tiszta Windows 2000 hálózati környezetben használható. Ennek oka az, hogy a legtöbb más DNS-névfeloldó ügyfélszoftver az 1123-as számú RFC dokumentumon alapul, azon a specifikáción, amely szabványosítja az Internet-állomások elnevezésére vonatkozó követelményeket. Ha a Windows 2000 telepítése során nem szabványos DNS-tartománynevet ír be, egy figyelmeztető üzenet jelenik meg, amely a szabványos DNS-név használatát javasolja.

Windows NT 4.0-s és korábbi verziók esetében a hálózaton lévő Windows alapú számítógép azonosítására szolgáló név NetBIOS-név volt. A Windows 2000 rendszerben egy számítógép a következő módokon azonosítható:

  • NetBIOS-név; ez választható, és a korábbi Windows rendszerekkel való együttműködéshez használható.
  • A számítógép teljes neve, ami a számítógéphez tartozó teljesen minősített tartománynév (FQDN) és elsődleges (vagy alapértelmezett) név.

Ezek mellett egy számítógép azonosítható a számítógépnévből (vagy állomásnévből) és egy kapcsolat-specifikus tartománynévből álló teljesen minősített tartománynévvel is, ahol ilyet a számítógépen a speciális hálózati kapcsolathoz beállítanak és alkalmaznak.

A teljes számítógépnév a számítógép nevéből és DNS-tartománynevéből áll. A számítógép DNS-tartományneve a számítógép Rendszer tulajdonságainak része, és nincs kapcsolatban semmilyen, speciálisan telepített hálózati összetevővel. Windows 2000 rendszerrel működő olyan számítógépek azonban, amelyek nem használnak sem hálózatot, sem a TCP/IP protokollkészletet, nem rendelkeznek DNS-tartománynévvel.

A következő táblázat a NetBIOS és a DNS rendszerű számítógépneveket hasonlítja össze.

 | NetBIOS-számítógépnév | DNS-számítógépnév
Típus | Nem hierarchikus | Hierachikus
Karakterkorlátozások | Unicode karakterek, számok, üres hely Szimbólumok: ! @ # $ % ^ & ' ) ( . - _ { } ~ | Ugyanaz, mint a NetBIOS rendszerben, de az üres hely nem megengedett A pont (.) speciális, lefoglalt jelentéssel bír
Maximális hosszúság | 15 karakteres bájt | 63 oktett címkénként 255 oktett teljesen minősített tartománynevenként (FQDN)
Névszolgáltatás | Windows Internet Name Service (WINS) NetBIOS csomagszórás | Tartománynévrendszer (DNS) szolgáltatás

A NetBIOS és a Windows 2000 DNS rendszerű névhasználata közötti együttműködés biztosítására egy új elnevezési paraméter, a NetBIOS számítógépnév bevezetésére került sor. Ennek a tiszta Windows 2000 környezetben felesleges paraméternek az értéke a teljes DNS-számítógépnév első 25 oktettjéből származik.

Ha a teljes számítógépnév a számítógép nevéből és DNS-tartománynevéből áll, az átnevezés és a NetBIOS-névtérről a DNS-névtérre történő áttérés hatása minimális lehet. A felhasználók továbbra is a rövid számítógépnevet látják. Ha ez a név 15 karakteres vagy rövidebb, azonos lehet a NetBIOS-számítógépnévvel. Ezután a rendszergazda mindegyik számítógéphez hozzárendelhet egy DNS-tartománynevet is. Ez távfelügyeleti eszközökkel elvégezhető.

Ily módon a Rendszer tulajdonságainak Hálózati azonosítás lapján (vagy kapcsolódó párbeszédpaneljein) a következő beállítások lehetnek:

Számítógépnév | tizenöt_karakternél_hosszabb_név
NetBIOS számítógépnév | tizenöt_karakternél_hosszabb
A számítógép elsődleges DNS-utótagja | pelda.microsoft.com

Megjegyzés

  • A számítógép elsődleges DNS-tartománynevén túl, a Windows 2000 kapcsolat-specifikus DNS-névhasználatot is biztosít. További tudnivalók a Több név beállítása című témakörben találhatók.

Az integráció megtervezése: Több névtér támogatása

A Windows 2000 és az Active Directory által használt belső DNS-névtér támogatáson túl sok hálózat igényli a külső DNS-nevek hozzárendelésének támogatását, például azokét, melyek az Interneten használatosak. A DNS-szolgáltatás módot ad az össze nem függő névterek integrálására és kezelésére, azaz ilyenkor mind a belső, mind a külső DNS-nevek hozzárendelése megtörténik a hálózaton.

A névterek integrálási módjának tervezésekor, állapítsa meg, hogy melyik forgatókönyv áll közelebb az adott helyzethez és a DNS tervezett használatához:

  • Belső DNS-névtér, csak a saját hálózaton történő használatra
  • Belső DNS-névtér, külső névtérre való átirányítással és ahhoz való hozzáféréssel, például átirányítás és továbbítás egy, az Interneten lévő DNS-kiszolgálóra
  • Külső DNS-névtér, csak nyilvános hálózaton, például az Interneten történő használatra

Ha úgy dönt, hogy a DNS névszolgáltatását a belső névtérre korlátozza, ennek kialakításához és megvalósításához nincsenek megkötések. Választhat például bármilyen DNS elnevezési szabványt, beállíthatja DNS-kiszolgálóit úgy, hogy a hálózat DNS terjesztésű modelljének érvényes gyökérkiszolgálói legyenek, vagy kialakíthat egy teljesen önálló DNS tartományfa-struktúrát és -hierachiát.

Abban az esetben, ha külső DNS-névtérre történő átirányítást vagy az Interneten teljes DNS-szolgáltatást indít be, figyelembe kell vennie a belső és a külső névterek közötti kompatibilitást. Az Internet-szolgáltatáshoz ezen kívül regisztráltatni kell a cég szülőtartományneveit.

Ha többet szeretne tudni arról, hogy az internetes DNS-nevek biztonságos magánhálózaton (például egy Microsoft Proxy Server vagy más tűzfal jellegű termék által támogatott hálózaton) keresztül történő átirányításának biztonságos integrációját miként lehet megtervezni, tanulmányozza a Windows alapú DNS megtervezéséről szóló, a Microsoft által kibocsátott további forrásanyagokat, amelyek hozzáférhetők a Microsoft webhelyen (http://www.microsoft.com/)..

Megjegyzések

  • Amikor a DNS-konzollal először ad hozzá egy Windows 2000 alapú DNS-kiszolgálót vagy először csatlakozik hozzá, a gyökérútmutató-fájl (Cache.dns) automatikusan felkészül a hálózati használatra. Ezt a felhasználó nem észleli, elvégzése sem igényel további műveleteket.

    Attól függően, hogy a DNS-szolgáltatást miként használja, ezt a fájlt a következőképpen frissítheti:

    • Ha csatlakozott az Internethez, ezt a fájlt akkor szerkesztheti vagy frissítheti, amikor a gyökérútmutatófájl (Named.root) frissítésére és felszabadítására sor került. A fájl legfrissebb másolatát névtelen FTP-kapcsolattal a következő helyről szerezheti be: ftp://rs.internic.net/domain/named.root.
    • Ha nem csatlakozott az Internethez, eltávolíthatja a fájlban lévő alapértelmezett erőforrásrekordokat és lecserélheti azokat a saját helye gyökértartományában lévő mérvadó DNS-kiszolgálókhoz tartozó NS és A erőforrásrekordokkal. A magánhálózaton lévő gyökértartomány kiszolgálói esetében ezt a fájlt biztonságosan és teljesen eltávolíthatja, mivel ezen a tartományszinten működő kiszolgálók nem igényelnek vagy használnak gyökérútmutató-gyorsítótárat.
  • Ha egy belső gyökértartomány kiszolgálójához tartozó Cache.dns fájlt töröl és ha a DNS-szolgáltatás beállításánál a betöltéshez a Fájlból módszert választotta az alapértelmezett Rendszerleíró adatbázisból beállítás helyett, a DNS-szolgáltatás újraindítása előtt el kell távolítania a kiszolgáló betöltőfájljából a cache utasítást is.


Zóna tervezése a DNS névrendszerhez

Amikor a névteret először osztja fel zónákra, vizsgálja felül jelenlegi vagy tervezett hálózatának forgalmi modelljét. Bár a DNS célja a helyi alhálózatokon belüli és az alhálózatok közötti szórásos forgalom csökkentése, valamennyi adatforgalmat mégis okoz a kiszolgálók és az ügyfelek között, amit érdemes áttekinteni. Ez különösen igaz olyan esetben, amikor a DNS szolgáltatást útválasztásos hálózaton használják.

A DNS-forgalom felülvizsgálatához használhatja a DNS-kiszolgáló statisztikáit vagy a Rendszerfigyelő által biztosított DNS-teljesítményszámlálókat. További tájékoztatást a Kiszolgáló beállításának ellenőrzése vagy A kiszolgálók teljesítményének figyelése című témakörben talál.

Az útválasztásos forgalmon kívül vegye figyelembe a DNS-specifikus kommunikáció következő általános típusainak hatásait, különösen, ha nagy kiterjedésű hálózaton kis sebességű kapcsolatokat használ:

  • Kiszolgálók közötti forgalom: ennek oka lehet a más DNS-kiszolgálókkal végzett zónaletöltés vagy a DNS más rendszerű kiszolgálókkal való együttműködése (például ha WINS keresés engedélyezett).
  • Ügyfél és kiszolgáló közötti forgalom: ennek oka lehet a DNS-ügyfélszámítógépek által küldött lekérdezésekkel és dinamikus frissítésekkel járó forgalom vagy dinamikus frissítést nem támogató, korábbi verziójú DNS-ügyfeleknek dinamikus frissítést nyújtó Windows 2000 DHCP-kiszolgálók okozta forgalom.

Kisméretű, lineáris névtereknél az összes DNS-zóna teljes replikációját lehet alkalmazni a hálózaton lévő valamennyi DNS-kiszolgálóra. Nagy, vertikális névtereknél ez nem lehetséges és nem javasolt. Nagyobb hálózatokon gyakran szükséges a megfigyelt vagy becsült forgalmi viszonyokra alapozott zónamodellek tanulmányozása, vizsgálata, elemzése és módosítása. Gondos elemzés után elvégezhető a DNS-zónák felosztása és delegálása annak alapján, hogy mi szükséges az egyes helyek hatékony és hibatűrő névszolgáltatásának biztosításához.

Zónák létrehozásakor, ha kezelésükre a DNS beépülő modult szándékozik használni, tartsa szem előtt az új zónák hozzáadásával vagy a meglévők bővítésével kapcsolatos következő javasolt korlátozásokat:

  • Ne kíséreljen meg egy zónához 65 553 erőforrásrekordnál többet hozzáadni.
  • Egyetlen DNS-kiszolgálón se kíséreljen meg 1000 zónánál többet hozzáadni vagy betölteni.

E javasolt határértékek megállapítása a jelenlegi Windows 2000 alapú DNS rendszerek alapján történt. További tudnivalók erről, illetve a zónákkal végzett munka során felmerülő határértékek frissítéséről a Frissített technikai információ a DNS-ről című témakörben találhatók.

Megjegyzések

  • Ha többféle Windows alapú DNS-kiszolgálót használ, legyen tisztában azzal, hogy a DNS-szolgáltatás és néhány más DNS-kiszolgálóeszköz közti zónaletöltések néha lassúak lehetnek. További tudnivalókat a Zónaletöltés BIND- és egyéb DNS-kiszolgálókkal című témakörben találhat.
  • A Windows 2000 Server esetében a DNS-szolgáltatás támogatja a növekményes zónaletöltést a szabványos zónát replikáló kiszolgálók között. E szolgáltatás csökkentheti a DNS replikációs forgalmat, és a zóna megtervezésénél célszerű figyelembe venni. További tudnivalók A zónák és a zónaletöltés ismertetése című témakörben találhatók.
  • Bár a zónák megtervezése hasznos, érdemes lehet számításba venni a csak gyorsítótárazást végző (azaz DNS-zónáknak állomásul nem szolgáló) DNS-kiszolgálók használatát. A csak gyorsítótárazást végző kiszolgálók jó megoldásnak bizonyulhatnak olyan kisméretű, távoli helyeken, ahol a DNS-névszolgáltatás használata folyamatos és minimális, de olyan nagy kiterjedésű hálózaton helyezkednek el, ahol a nagyméretű zónák letöltése lassúbb kapcsolaton keresztül erőforrás-igényes. További tudnivalók a Csak gyorsítótárazást végző kiszolgálók használata című témakörben találhatók.


DNS-kiszolgáló működésének megtervezése

A DNS-kiszolgálók tervezésénél fontos figyelembe venni a következőket:

  • Végezze el a teljesítménytervezést, és tekintse át a kiszolgáló hardverigényeit.
  • Határozza meg a DNS-kiszolgálók szükséges számát és szerepüket a hálózatban.

    A használandó DNS-kiszolgálók számának meghatározásakor döntse el, melyik kiszolgáló fog helyet adni a zónák elsődleges és másodlagos másolatainak. Ezenkívül ha Active Directoryt használ, döntse el, hogy a kiszolgáló tartományvezérlőként vagy a tartomány egyik tagkiszolgálójaként működjön-e.

  • Döntse el, hogy hová helyezi a DNS-kiszolgálókat a hálózaton a forgalmi terhelés, a replikáció és a hibatűrés szempontjából.
  • Döntse el, hogy csak Windows 2000 alapú DNS-kiszolgálókat használ-e az összes DNS-kiszolgálóhoz, vagy Windows és más DNS-kiszolgálókat egyaránt működtet.

    A DNS-szolgáltatás áttelepítésével, illetve más DNS-kiszolgálóeszközökkel való együttműködésével kapcsolatban további tudnivalókat a Kiszolgálók áttelepítése vagy az Együttműködés más szolgáltatásokkal című témakörben talál.

A kiszolgálók teljesítményének megtervezése

A DNS-kiszolgálók hálózati használatra történő megtervezése és üzembe helyezése magába foglalja a hálózat különböző szempontok szerinti vizsgálatát és a hálózaton használni kívánt bármely DNS-kiszolgáló teljesítményigényét. A tervezés során figyelembe veendő néhány kérdés:

  • Várhatóan hány zónát tölt le és foglal magába a DNS-kiszolgáló?
  • Milyen nagyok a szolgáltatáshoz a kiszolgáló által letöltött egyes zónák (a zónafájl méretének vagy a zónában használt erőforrásrekordok számának alapján)?
  • Többhelyű DNS-kiszolgáló esetében hány csatolón érdemes engedélyezni a DNS-ügyfelek figyelését és kiszolgálását a kiszolgáló mindegyik csatlakoztatott alhálózatán?
  • Az ügyfelektől várhatóan összesen hány DNS-lekérdezési igényt fogad és szolgál ki a DNS-kiszolgáló?

Sok esetben akkor lesz a teljesítmény javulása a legészrevehetőbb, ha a DNS-kiszolgálóba több RAM memóriát épít. Ennek az az oka, hogy a DNS-kiszolgálószolgáltatás induláskor az összes beállított zónát a memóriába tölti. Ha a kiszolgáló sok zónát működtet és tölt be, valamint ha a dinamikus frissítésre gyakran kerül sor az ügyfelek számára, több memória hasznos lehet.

Ne feledje, hogy átlagos használatnál a DNS-kiszolgáló a következők szerint veszi igénybe a rendszermemóriát:

  • A DNS-kiszolgáló közelítőleg 4 MB RAM-ot használ, ha zónák nélkül indul.
  • Minden további zóna vagy erőforrásrekord használata további memóriamennyiséget igényel a kiszolgálón.
  • Becslések szerint minden egyes erőforrásrekord hozzáadása a kiszolgáló zónájához átlagosan és hozzávetőlegesen 100 bájt memóriát foglal el a kiszolgálón.

    Ha például egy 1000 erőforrásrekordot tartalmazó zónát ad a kiszolgálóhoz, ehhez közelítőleg 100 kB (kilobájt) memória szükséges.

A kiszolgálóval kapcsolatos tervek elkészítésekor a munkát a Windows 2000 alapú DNS szolgáltatást fejlesztő és vizsgáló csoport által összegyűjtött, és DNS-kiszolgálók teljesítményével kapcsolatos vizsgálati eredményminták áttekintésével kezdheti. Ezenkívül a hálózaton létesített Windows 2000 alapú DNS-kiszolgálók teljesítményének méréséhez használhatja a Windows 2000 figyelő eszközeihez tartozó, DNS-kiszolgálóval kapcsolatos számlálókat. További tájékoztatást A kiszolgálók teljesítményének figyelése című rész tartalmaz.

Fontos

  • A méréseknek nem az volt a céljuk, hogy a Windows 2000 alapú DNS-kiszolgálók maximális teljesítményét vagy korlátait megmutassák.
  • A számok csak közelítő jellegűek, és a zónába bejegyzett erőforrásrekordok típusa, az azonos tulajdonosnévvel rendelkező erőforrásrekordok száma és az adott DNS-kiszolgálón használt zónák száma befolyásolhatja azokat.

Hol érdemes elhelyezni a DNS-kiszolgálókat?

Általában elmondható, hogy a DNS-kiszolgálókat a hálózaton olyan helyre célszerű helyezni, amely központilag hozzáférhető az ügyfelek számára. Gyakran a legcélszerűbb egy DNS-kiszolgálót használni mindegyik alhálózaton. Számos tényezőt érdemes figyelembe venni annak eldöntésére, hogy hol van szükség DNS-kiszolgálóra. Ezek közül néhány:
  • Az Active Directory támogatására létesített DNS esetében a DNS-kiszolgáló egyben tartományvezérlő is lesz, illetve a jövőben előlép-e azzá?
  • Ha a DNS-kiszolgáló működése leáll, a helyi ügyfelei hozzá tudnak-e férni egy másik DNS-kiszolgálóhoz?
  • Ha a DNS-kiszolgáló olyan alhálózaton van, amely néhány ügyféltől távoli esik, milyen más DNS-kiszolgáló vagy névhozzárendelési lehetőség áll rendelkezésre, ha az útválasztásos kapcsolat nem válaszol?

Olyan DNS-kiszolgálóknál, melyeknél az Active Directory használata gondot okoz, tekintse át a speciális együttműködési problémákat és a telepítéssel kapcsolatos részleteket. További tudnivalók A DNS Active Directoryval kapcsolatos szempontjai című részben találhatók.

Az összes DNS-kiszolgáló esetében, ideértve azokat is, melyeknél az Active Directory használata nem okoz problémát, hasznosan alkalmazhatók a következő irányelvek, melyek a kiszolgáló elhelyezésére és megtervezésére vonatkoznak.

Ha például útválasztásos helyi hálózattal és jól megbízható, nagy sebességű kapcsolatokkal rendelkezik, egyetlen DNS-kiszolgáló is használható egy nagy, több alhálózatra osztott hálózati körzethez. Ha egyetlen alhálózati modellen sok ügyfélcsomóponttal rendelkezik, tartalékolási és feladatátvételi célokból szükség lehet több DNS-kiszolgáló hozzáadására az alhálózathoz arra az esetre, ha az elsődleges DNS-kiszolgáló nem válaszol.

A szükséges DNS-kiszolgálók számának megállapításánál becsülje fel a hálózat lassabb kapcsolatain történő zónaletöltések és a DNS-lekérdezési forgalom hatását. Bár a DNS olyan kialakítású, hogy csökkentse a szórásos forgalmat az alhálózatok között, bizonyos forgalmat mégis eredményez a kiszolgálók és az ügyfelek között, amit felül kell vizsgálni, különösen bonyolult útválasztású LAN és WAN környezetekben.

Vegye figyelembe a zónaletöltések hatását lassabb kapcsolatok esetében, mint amilyeneket általában a nagy kiterjedésű hálózati (WAN-) kapcsolatoknál használnak. Bár a DNS-szolgáltatás támogatja a növekményes zónaletöltést, és a Windows 2000 alapú DNS-ügyfelek és -kiszolgálók a nemrégiben használt neveket a gyorsítótárba tudják helyezni, a forgalomra vonatkozó megfontolások még mindig problémát jelentenek, különösen akkor, ha a DHCP-címbérletek lerövidülnek, és ennek eredményeként a DNS dinamikus frissítései gyakrabban fordulnak elő. A távoli helyek WAN-kapcsolaton történő eléréséből fakadó gondokra megoldás lehet, ha egy DNS-kiszolgálót telepít ezekre a helyekre csak gyorsítótárazást végző DNS-szolgáltatás biztosításához.

Hibatűrési megfontolásokból a legtöbb telepítéshez legalább két kiszolgáló-számítógéppel kell rendelkeznie, amelyek helyet adnak az egyes DNS-zónáknak. A DNS-szolgáltatást úgy alakították ki, hogy mindegyik zónához két kiszolgálóval rendelkezzen, melyek közül az egyik elsődleges, a másik tartalék vagy másodlagos. Az üzembe helyezendő kiszolgálók számával kapcsolatos végső döntésnél először mérje fel a hálózathoz szükséges hibatűrési szintet.

Megjegyzések

  • Amikor egyetlen alhálózattal rendelkező környezetben lévő kis helyi hálózaton egyetlen Windows 2000 Server rendszert használ, e kiszolgálót beállíthatja úgy, hogy egyszerre szimulálja a zóna elsődleges és másodlagos kiszolgálóját.
  • A legjobb eredmény és a DNS egyszerűbb felügyelete érdekében megfontolhatja a Windows 2000 Server rendszerrel forgalomba hozott DNS-szolgáltatás felhasználását valamennyi DNS-kiszolgálóhoz.
  • A DNS-szolgáltatás által létrehozott zónafájlok felügyeletekor a módosítások elvégzéséhez ajánlatos a DNS-konzolt használni. A DNS-zónafájlok felügyeletét, más lehetőségként, kézzel is el lehet végezni bármilyen szöveges üzemmódú fájlmentést támogató alkalmazással. Valahányszor a zónafájlok szerkesztése mellett dönt, akár kézzel egy szövegszerkesztőben akár a DNS-konzollal, a zónák frissítéséhez egyetlen módszert válasszon, és használja azt következetesen. Ez segít meggátolni a zóna módosításainak felülíródását vagy visszautasítását, ami előfordulhat, ha egyik módszert a másikra cseréli.


Kiszolgálók áttelepítése

Windows 2000 Server esetében a DNS áttelepítése a következő módok valamelyike szerint történhet:

  1. Windows NT Server 4.0-s verziójával forgalmazott DNS-szolgáltatást futtató számítógép frissítése Windows 2000 Server rendszerre.
  2. Zónafájlok áthelyezése egy olyan meglévő DNS-kiszolgálóról, amelyen a DNS-kiszolgáló egy másik rendszerű, például a Berkeley Internet Name Domain (BIND) egyik verzióján alapuló, példánya fut.
  3. Zónák áttelepítése fő- és másodlagos kiszolgálók közti zónaletöltéssel BIND alapú kiszolgálókról Windows 2000 alapú DNS-kiszolgálókra.

DNS-kiszolgálók frissítése Windows NT Server 4.0-s verzióról.

Ilyen esetben – Windows NT Server 4.0-s környezetben futó DNS-kiszolgáló Windows 2000 Server rendszerre történő frissítésekor – nincs ismert probléma. A DNS-szolgáltatás Windows NT Server 4.0 alapú verziójával létrehozott és tárolt bármilyen zóna vagy kiszolgálói konfigurációs fájl és paraméter tárolása ugyanazokban a rendszermappákban történik. A frissítési művelet során nincs szükség az adatok átalakítására.

BIND alapú fájlok áthelyezése

BIND alapú DNS-kiszolgálóról DNS-szolgáltatásra történő áttéréskor azonban szükség van a DNS-szolgáltatással használni kívánt minden, a BIND által létrehozott zóna vagy rendszerindító fájl másolására és átnevezésére. Ezenkívül ha továbbra is egy BIND alapú rendszerindító fájlt szeretne használni a DNS-kiszolgáló indításakor használt kezdeti beállítások biztosítására, módosítania kell a DNS-szolgáltatás rendszerindítási módszerét. A további tudnivalók A DNS-kiszolgáló rendszerindítási módszerének módosítása című témakörben találhatók.

Ne feledje, hogy a BIND szoftvert használó UNIX alapú DNS-kiszolgálókon létrehozott és tárolt minden zónafájlt kézzel kell átmásolni ezekről a kiszolgálókról a Windows 2000 Server rendszert futtató számítógép rendszergyökér\System32\Dns mappájába, és ott azokat megfelelően át kell nevezni. A BIND-zónafájlok elnevezési konvenciója eltér a Windows operációs rendszerek DNS-szolgáltatása alatt futó DNS-kiszolgálókétól.

A következő táblázat példákkal illusztrálja, hogy a BIND-kiszolgáló fájljainak átnevezése milyen formában történik a Windows 2000 Server alapú DNS-szolgáltatásban.

Leírás | UNIX stílusú fájlnév | Windows 2000 stílusú fájlnév
Rendszerindító fájl | named.boot | Boot
Címlekérdezési zónafájl | db.tartománynév | tartománynév.dns
Névlekérdezési zónafájl | db.IP_hálózati_címlekérdezési_jel | IP_hálózati_névlekérdezési_jel.dns

Névlekérdezési zónához a BIND olyan konvenciót használ, amelyben a névtartományban szereplő neveket a hozzárendelt IP-hálózat címeinek alapján jelöli, például egy 192.1.168 hálózati IP-címhez a db.192.168.1.0 névlekérdezési zónát rendeli. A Windows 2000 alapú DNS-kiszolgálók azonban a zóna teljesen minősített tartománynevét (FQDN) használják, ami a teljes fájlnévnél tartalmazza az in-addr.arpa tartományt. Ebben a példában a Windows 2000 Server azonos zónájához, a fájl másolása és átnevezése során használt helyes név a 168.1.192.in-addr.arpa.dns.

Megjegyzések

  • Ha áttérés után a BIND rendszerindító fájlját használja a DNS-szolgáltatással, más korlátozások is érvényesek e fájl DNS-szolgáltatás általi használatára. Néhány BIND rendszerű rendszerindítási direktíva például nem támogatott – konkrétan a BIND 8.1.1-es vagy későbbi verzióval forgalmazott xfrnets és egy egyéb direktívák.
  • Ha megszokta a DNS-zónafájlok kézi szerkesztését, legyen tisztában azzal, hogy a DNS-szolgáltatás RFC-kompatibilis jelölést használ az általa támogatott erőforrásrekordokhoz. A legtöbb esetben a DNS-szolgáltatás az eredetileg a BIND alapú DNS-kiszolgálókhoz készült zónafájlokból úgy értelmezi és tölti be az erőforrásrekordokat, hogy nincs szükség a fájlok módosítására. Ha azonban nem szabványos rekordformázást használ, a DNS-szolgáltatás rossz vagy hibás zónaadatként érzékelheti ezeket a módosításokat.

Áttérés BIND-kiszolgálókról zónaletöltéssel

A kiszolgálók áttelepítésének másik lehetséges forgatókönyve a zónaletöltés alkalmazása a BIND alapú kiszolgálók zónáinak Windows 2000 alapú DNS-kiszolgálókra történő áttelepítésére. Ez a következő lépésekkel végezhető el:

  1. Telepítsen egy DNS-kiszolgálót a Windows 2000 rendszerrel működő kiszolgáló-számítógépre.
  2. A DNS-konzol segítségével az új kiszolgálón vegyen fel másodlagos zónákat a BIND alapú DNS-kiszolgálókon meglévő valamennyi zónához.

    A BIND-kiszolgálókat mindegyik létrehozandó másodlagos zóna számára főkiszolgálóként állítsa be.

  3. A Windows 2000 alapú DNS-kiszolgálókról indítsa el a BIND-kiszolgálókon lévő zónák letöltését.
  4. A zónaletöltések befejezése után alakítsa át az összes olyan másodlagos zónát elődleges zónává, amelyet a BIND-kiszolgálók elsődleges zónáitól kapott.
  5. A megmaradt többi másodlagos zóna főkiszolgálóit frissítse, hogy a Windows 2000 Server rendszert futtató új elsődleges kiszolgálókat használják.

A további tudnivalók a DNS-kiszolgáló telepítése, a Másodlagos kiszolgáló hozzáadása meglévő zónához, a Zónaletöltés kezdeményezése másodlagos kiszolgálón, a Zónatípus módosítása és a Másodlagos zóna főkiszolgálójának frissítése című témakörökben találhatók.

Megjegyzés

  • Ha úgy dönt, hogy továbbra is BIND alapú DNS-kiszolgálókat használ másodlagos kiszolgálóként azokhoz a zónákhoz, amelyek elsődleges kiszolgálója Windows 2000 Server rendszert futtató DNS-kiszolgáló, érdemes áttekintenie az ilyen konfiguráció melletti zónaletöltéssel kapcsolatos együttműködési problémákat. További tudnivalókat a Zónaletöltés BIND- és egyéb DNS-kiszolgálókkal című témakörben találhat.


Együttműködés más szolgáltatásokkal

A DNS-szolgáltatás támogat és alkalmaz néhány olyan RFC-specifikációt, amely a DNS Interneten történő használatának definiálására szolgál. Általában a DNS-szolgáltatás fejlesztési támogatást nyújt a legtöbb elfogadott (azaz „szükséges” minősítésű) RFC számára amelyek a jelenlegi, vagyis használatban levő DNS protokollszabványt alkotják. Ez a fejlesztési szolgáltatás egyértelmű előnyöket biztosít a Windows alapú DNS-kiszolgálók vegyes, heterogén környezetben történő működéséhez.

Az ilyen környezetekben való együttműködés legfőbb előnyei a következők:

  • Teljes együttműködés más DNS-kiszolgálókkal, amelyek a DNS névszolgáltatás RFC-kompatibilis működését valósítják meg.
  • Windows DNS-kiszolgálók használata DNS-szolgáltatás biztosítására az Interneten.

Az együttműködés ellenőrzésére a Windows 2000 fejlesztőcsoport a Windows 2000 DNS kiszolgálói szolgáltatását a következő verziójú Berkeley Internet Name Domain (BIND) DNS-kiszolgálók esetében vizsgálta meg:

  • BIND 4.9.7
  • BIND 8.1.2
  • BIND 8.2

A Windows 2000 alapú DNS használatával vagy a DNS-kiszolgálók Interneten történő használatával kapcsolatos együttműködési és beállítási problémákat a következő részek tartalmazzák.

A DNS Active Directoryval kapcsolatos szempontjai

Az Active Directoryhoz szükséges a DNS. Ezért megválaszthatja, hogy a DNS-kiszolgálókat az Active Directory telepítésének részeként telepíti és a kiszolgáló-számítógépet tartományvezérlővé lépteti elő.

Amikor egy Windows 2000 kiszolgálót tartományvezérlővé léptet elő, lehetősége nyílik DNS-kiszolgáló telepítésére, valamint új zónák automatikus hozzáadására az Active Directory telepítésének részeként. DNS-kiszolgáló külön telepítése a kiszolgáló-számítógépre csak akkor szükséges, ha az jelenleg nem tartományvezérlő vagy előreláthatóan a jövőben sem lesz az.

Ha azt a lehetőséget választja, hogy az Active Directory Telepítő varázslójával telepíti és állítja be a DNS-kiszolgálót, a kiszolgálónak tartományvezérlővé történő előléptetésekor megadott DNS-nevek alapján zónák jönnek létre. Miután megtörtént a tartomány első kiszolgálójának előléptetése tartományvezérlővé; egyéb feladatok elvégzése is hasznos lehet, például a zónatípus módosítása a Szabvány elsődleges beállításról Active Directoryval integrált beállításra, illetve a zóna frissítési házirendjének Csak biztonságos frissítések lehetőségre történő módosítása.

Ha DNS-szolgáltatást helyez üzembe az Active Directory támogatására, a redundancia és hibatűrés tervezésének egyszerű módja az, ha mindegyik tartományvezérlőn futtat egy DNS-kiszolgálót. Mindegyik alhálózat esetében hasznos követendő szabály lehet két Windows 2000 Server beállítása tartományvezérlőként, amelyek DNS-kiszolgálóként is működnek és kizárólag Active Directoryval integrált zónákat töltenek be és tárolnak.

A DNS és az Active Directory egyszerűsített beállításaival kapcsolatos ezen irányelvek betartásával lehetővé válik, hogy a DNS-kiszolgálók teljesen kihasználják az Active Directory és a Windows 2000 DNS-kiszolgálók alkalmazásának fokozott előnyeit, mint amilyen az integrált tárolás, az Active Directory és a DNS adatainak egyesített replikálása, valamint a biztonságos hitelesítés a dinamikus frissítések engedélyezésekor.

Zónaletöltés BIND és más DNS-kiszolgáló esetében

Két Windows DNS-kiszolgáló közötti zónaletöltéskor a DNS kiszolgálói szolgáltatása mindig egy gyors, tömörítést alkalmazó letöltési módszert használ. Ez a módszer a kiszolgálók közötti zónaletöltés végrehajtásához küldött mindegyik üzenetben több erőforrásrekordot foglal magában. Windows 2000 DNS-kiszolgálóknál ez az alapértelmezett módszer használatos más DNS-kiszolgálókkal történő letöltés kezdeményezésekor.

Amennyiben szükséges, a Windows 2000 DNS-kiszolgáló beállítható úgy, hogy a zónaletöltést a lassúbb, tömörítés nélküli letöltési formában végezze. Ez lehetővé teszi a sikeres zónaletöltést olyan DNS-kiszolgálóknál, amelyek nem támogatják a gyorsabb letöltési módszert, mint amilyenek például a 4.9.4-es verziónál régebbi BIND-kiszolgálók.

Ha a kiszolgáló speciális tulajdonságaiban bejelöli a BIND másodlagosak lehetőséget, a letöltés nem lesz gyors. Alapértelmezés szerint a jelölőnégyzet üres, azaz a gyors letöltés engedélyezett. További tájékoztatás a Gyors letöltési formátum engedélyezése vagy tiltása a zónaletöltések során című témakörben olvasható.

Active Directory támogatása más DNS-kiszolgálók esetében

Számos nagy cégnél már megvalósították a DNS-t olyan más megoldásokkal, mint például a BIND szoftverek örökölt verzióit futtató UNIX alapú DNS-kiszolgálók. Néhány esetben ezek a DNS-kiszolgálók nem támogatják a DNS szolgáltatásnak az Active Directory megvalósítására vonatkozó követelményeit. Ez a probléma a következő két módon orvosolható:

  • Frissítse a BIND DNS-kiszolgálókat a BIND-szoftver 8.1.2-es vagy újabb verziójával, hogy eleget tegyen a DNS szolgáltatásnak az Active Directory támogatására vonatkozó követelményeinek.
  • Használja a Windows 2000 Server rendszerrel forgalomba kerülő DNS-szolgáltatást bármelyik jelenlegi DNS zóna áttelepítéséhez, ha az lehetséges, a Windows 2000 DNS-kiszolgálókra.

Bár az Active Directory támogatására a DNS-szolgáltatás javasolt, erre a célra más DNS-kiszolgálót is használhat. Ezen más eszközöknek azonban támogatniuk kell a következő szabványelőírásokat:

  • Az SRV erőforrásrekordot, amint azt az „A DNS RR for specifying the location of services (DNS SRV)” (DNS erőforrásrekord (DNS SRV) a szolgáltatások helyének meghatározására) című internetes dokumentum meghatározza.
  • A DNS dinamikus frissítéseit, a 2136-os számú RFC előírásai szerint.

A dinamikus frissítések támogatás ajánlott, de nem elengedhetetlen. Az SRV erőforrásrekord támogatása kötelező, mivel ez az Active Directory alapvető DNS-támogatásához szükséges. Például, egy DNS-kiszolgáló, amely nem támogatja a dinamikus frissítéseket, mint amilyen a Windows NT Server 4.0-s (a Service Pack 4-es vagy frissebb verziójával ellátott) változatával forgalomba került, támogatja az Active Directory DNS- követelményeit, mivel az SRV rekord támogatása bekerült a 4-es szervizcsomagba.

Az SRV erőforrásrekordok további kézi felügyeletére van szükség ahhoz, hogy a DNS Active Directoryt támogató beállítása megfelelően működjön olyan DNS-kiszolgálón, ami nem támogatja a dinamikus frissítéseket. További tájékoztatás az SRV erőforrásrekordok című témakörben található.

Windows alapú DNS-kiszolgálók együttműködése más DNS-kiszolgálókkal

Abban az esetben, ha úgy dönt, hogy Windows alapú DNS-szolgáltatást használ, és azt a osztott DNS-konfigurációval kezeli, ahol:

  • A gyökérzónák meglévő DNS-kiszolgálóit nem kell frissíteni vagy más DNS-típusra áttelepíteni.
  • A DNS-szolgáltatás és a Windows 2000 Server kerül üzembe helyezésre, amelyek biztosítják a regisztráláshoz, a frissítéshez és az Active Directory támogatásához szükséges DNS-tartománynevek kezelését.

A DNS-névtér kiépítésének modellje a következő módszerek egyikével módosítható:

  1. A jelenlegi DNS-tartomány névtérében hozzon létre egy új altartományt, ami az első Active Directory tartomány gyökere lesz.

    Ha például a cég egy második szintű tartománynevet regisztrált és használ, mint amilyen a microsoft.com, létrehozhat egy altartományt, például pelda.microsoft.com néven, amit aztán az Active Directory által használt DNS-tartomány névterének gyökereként használhat. Az első tartományvezérlő telepítésekor a DNS-szolgáltatás automatikusan úgy konfigurálódik, hogy támogassa az Active Directoryt.

    Mielőtt a DNS kiszolgálói szolgáltatását futtató számítógépen létrehozna egy zónát az új altartomány számára, ezeket az altartományokat a második szintű tartományba, mint amilyen a „microsoft.com”, delegálhatja az elsődleges zónából. Bizonyos esetekben csak arra van szükség, hogy a cég egy másik DNS- vagy UNIX-rendszergazdáját megkérje, hogy végezze el a delegálást Ön helyett. További tudnivalók a Zónák delegálása című témakörben találhatók.

  2. A második szintű DNS-tartomány alapján hozzon létre több altartományt az Active Directory DNS szolgáltatásban való regisztrálásának támogatására.

    Ha például a cég már használ egy regisztrált második szintű DNS-tartománynevet (mint amilyen a microsoft.com), létrehozhat további altartományokat, amelyeket Windows DNS-kiszolgálókhoz delegál és csak az Active Directoryval kapcsolatos DNS-nevek regisztrálására használ.

    E módszer megvalósítása bonyolultabb, de kevesebb módosítást igényel a jelenleg működő nem Windows alapú DNS-infrastruktúrában. Ezzel a névtérmodellel csak azokat a további altartományokat és megfelelő zónákat hozza létre, amelyek az Active Directory üzembe helyezésének támogatásához szükségesek. E konfigurációban például a microsoft.com tartománynév egyaránt szolgál a cég legfelső szintű DNS és Active Directory tartományneveként.

    E konfiguráció esetében egy DNS-szolgáltatást és Windows 2000 Server rendszert futtató számítógépen a DNS beépülő modul segítségével először zónákat kell létrehoznia a következő altartományokhoz:

    _msdcs.microsoft.com
    _ldap._tcp.microsoft.com

    A zónák létrehozása előtt ezeket az altartományokat az elsődleges zónából a szülő vagy második szintű tartománynevekhez delegálhatja, vagy megkérhet erre egy másik DNS-rendszergazdát, aki a cégen belül ezeket a zónákat kezeli. További tudnivalók a Zónák delegálása című témakörben találhatók.

DNS használata az Interneten

Az Interneten való jelenlét megteremtéséhez az egyénnek vagy a vállalkozásnak először egy DNS-tartománynevek regisztrálását végző hiteles hatóságnál kérnie és regisztráltatnia kell egy második szintű tartománynevet. Gyakran az Internet-szolgáltató (ISP) is megteheti ezt Ön helyett, általában többletköltségért.

A tartománynév regisztrálásához számos feladatot el kell végezni, ezek például a következők:

  • Olyan második szintű tartománynév kiválasztása és kidolgozása, amilyen még nincs regisztrálva vagy nincs használatban.

    Ha van Internet-hozzáférése, ez könnyen elvégezhető egy WHOIS lekérdezőeszköz segítségével, ami megtalálható az illetékes internetes DNS-tartománynévregisztráló hatóság webhelyén. Készüljön fel egy alternatív név megjelölésére arra az esetre , ha a WHOIS lekérdezés jelzi, hogy első választását már regisztrálták és használják.

  • Legalább egy, az Interneten történő használatra érvényes IP-cím regisztrálása és beszerzése.

    Ez a cím annak az Internethez csatlakozó DNS-kiszolgálónak kell, amelyet a második szintű tartománynéven alapuló zóna elsődleges másolatának állomásaként kíván meghatározni. Sok esetben ha az Internet-szolgáltatóra bízza a tartománynév regisztrációját, elsődlegesként vagy másodlagosként meghatározhatják egy vagy két kiszolgálójuk IP címét az Interneten.

    A regisztrációs művelet részeként a kérelmezőnek legalább két olyan aktív DNS-kiszolgálót kell biztosítania, amelyet az új tartomány számára kijelölt elsődleges vagy másodlagos kiszolgálóként használnak az Interneten. Erre a követelményre azért van szükség, hogy biztosítva legyen a megfelelő legfelső szintű internetes kiszolgálókonfiguráció, valamint az átirányítás azok számára, akik az Interneten az Ön regisztrált DNS-tartománynevét kérdezik le.

    Az IP-cím beszerzése után Ön (vagy Internet-szolgáltatója) esetenként elintézheti, hogy a zóna másodlagos kiszolgálójaként más cég vagy Internet-szolgáltató DNS-kiszolgálóját használhassa. Ha ezután mégis szükség van egy IP-cím közvetlen beszerzésére az Egyesült Államokban, az érvényes cím az Internet-számok amerikai adatbázisán keresztül (ARIN) beszerezhető. Más országokban lépjen kapcsolatba a helyi Internet- vagy telefonszolgáltatóval, ahonnan megtudhatja, hogyan kell regisztrálni és beszerezni a szükséges IP-címet.

  • Töltse ki a regisztrációs űrlapot és a regisztrációs díjjal együtt nyújtsa be azt a megfelelő internetes DNS-tartománynévregisztrációs hatósághoz. A regisztrációk általában véges időtartamig érvényesek, ezért azokat időnként meg kell újítani.

Tájékoztatásként az alábbiakban néhány kapcsolódó internetes webhelyet talál, amelyek segítséget nyújthatnak az internetes DNS-név kiválasztásához és regisztrálásához.

  • Network Solutions, Inc. (NSI) regisztrációs webhely (http://www.nsiregistry.net)
  • Internet Corporation for Assigned Names and Numbers (ICANN) webhelye (http://www.icann.org)
  • Internet Assigned Numbers Authority (IANA) webhely (http://www.iana.org)

Megjegyzés

  • A múltban a DNS-tartománynevek regisztrálását előzetesen kizárólag az NSI (korábban mint InterNIC) kezelte. Ez újabban átalakulóban van egy megosztott regisztrációs rendszerré, ám ennek részletei még kidolgozás alatt állnak.

    Frissebb tájékoztatáshoz használja útmutatóul az NSI regisztrációs webhely olyan más cégekhez mutató hivatkozásait, amelyek szintén részt vehetnek az internetes DNS-tartománynevek regisztrálására szolgáló új vagy javasolt rendszer kialakításában.

Az együttműködés megtervezése: A kapcsolódó szolgáltatások beállítása

A Windows 2000 Server számos együttműködési beállítást biztosít, ha a DNS-szolgáltatást más TCP/IP-szolgáltatással használja. Sok esetben e szolgáltatások segítségével csökkenthető a DNS-névtér felügyeletére fordított idő, és biztosítható a hálózat tökéletesített elnevezési szolgáltatásának működése.

Ezek a beállítások leggyakrabban a következő bővítéseket tartalmazzák:

  • WINS cím- és névlekérdezések.

    Windows NT Server 4.0, Windows 2000 vagy ennél újabb környezetben a DNS-szolgáltatás gondoskodik a WINS keresésről. Ez a szolgáltatás lehetővé teszi, hogy a beállított DNS-zónák a jelenlegi zóna információból megválaszolatlan lekérdezéseket további hozzárendelés céljából egy WINS-kiszolgálóra küldjék. Ezzel a kibővített WINS-névtérkereséssel a DNS és a WINS egyaránt használható egyező nevek megkeresésére a regisztrált nevek között.

    A WINS keresés mind a címkeresési, mind a névkeresési zónákat támogatja, és engedélyezhető a zónánkénti vagy a kijelölt zónákra alkalmazott keresés is. E szolgáltatást kell beállítani annak elkerülésére, hogy a WINS erőforrásrekordokat fel nem ismerő más DNS-eszközök replikálják azokat vagy elvégezzék azok zónaletöltését.

  • Dinamikus integráció DHCP-kiszolgálókkal.

    Windows 2000 Server rendszerben a DHCP-szolgáltatás alapértelmezés szerint támogatja a DNS-zónákban lévő örökölt DHCP-ügyfelek regisztrálását és adataik frissítését. Jellegzetesen az örökölt ügyfelek közé tartoznak más, a Windows 2000 előtt kibocsátott Microsoft TCP/IP ügyfél számítógépek. A Windows 2000 Server által biztosított DNS-DHCP integráció lehetővé teszi, hogy a DNS-erőforrásrekordokat dinamikusan közvetlenül frissíteni nem tudó DHCP-ügyfél a DHCP-kiszolgáló segítségével frissítse ezeket az adatokat a névkeresési DNS-zónákban.

Megjegyzések

  • A DHCP-szolgáltatás dinamikus integrációja csak Windows 2000 Server rendszerben áll rendelkezésre. A DNS-DHCP integrációt nem támogatják a Windows NT Server 4.0-s és korábbi verziói alatt futó DHCP-kiszolgálók.


Kiszolgálók kezelése

A rész tartalma:

  • Új elsődleges kiszolgáló beállítása
  • Meglévő kiszolgálók frissítése
  • Másodlagos kiszolgálók használata
  • Csak gyorsítótárazást végző kiszolgálók használata
  • Kiszolgálóadatok elévülésének és takarításának kezelése


Új elsődleges kiszolgáló beállítása

Számos olyan helyzet adódhat, amikor szükség lehet egy új DNS-kiszolgáló hozzáadására és beállítására a hálózaton, például:

  • Amikor egy új DNS-kiszolgálót ad a hálózathoz, és egy új zónát első alkalommal történő használatra beállít.
  • Amikor egy másik DNS-kiszolgálón már létrehozott egy zónát, és egy olyan kiszolgálót ad hozzá, amelynek a zóna számára szolgáltatást kell betöltenie és biztosítania.
  • Amikor már beállított egy DNS-kiszolgálót egy zónához vagy zónákhoz, de egy másik tartománynévhez (például altartományhoz) kell új zónát adnia.

Az új kiszolgáló és zóna első beállításakor legjobb, ha a DNS üzembe helyezésének megkezdéséhez felhasználja a DNS súgójában található feladatlistákat. Ha az Active Directory használata nélkül szeretne DNS-kiszolgálót telepíteni, nézze át a Feladatlista: a DNS üzembe helyezése című témakört. Ha az Active Directory támogatására helyezi üzembe a DNS szolgáltatást, nézze át a Feladatlista: a DNS üzembe helyezése az Active Directoryhoz című témakört.

Elsődleges kiszolgáló hozzáadása meglévő zónához

A zóna elsődleges kiszolgálója a zóna frissítési pontjaként működik. Az újonnan létrehozott zónák mindig ilyen típusúak. Windows 2000 Server rendszerben az elsődleges zónákat két módon használhatja, szabványos elsődleges zónákként vagy Active Directoryval integrált elsődleges zónákként.

Szabványos elsődleges típusú zónáknál csak egyetlen kiszolgáló fogadhatja és töltheti be a zóna főpéldányát. Ha zónát hoz létre, és azt szabványos elsődleges zónaként tartja, a zónának nem lehetnek további elsődleges kiszolgálói. Csak egyetlen kiszolgáló fogadhatja a dinamikus frissítéseket és dolgozhatja fel a zónák módosításait.

A szabványos elsődleges modell egyetlen meghibásodási pontot tartalmaz. Ha például valami miatt a zóna elsődleges kiszolgálója a hálózaton nem érhető el, nem végezhető el a zóna dinamikus frissítése. Ne feledje, hogy a zónában lévő nevek lekérdezéseit ez nem befolyásolja, és azok megszakítás nélkül folytatódhatnak mindaddig, amíg a zóna másodlagos kiszolgálói a válaszadáshoz hozzáférhetők.

Windows 2000 Server esetében azonban egy zónához hozzáadhat több elsődleges kiszolgálót a DNS-szolgáltatás címtárral integrált tárolási és replikációs szolgáltatásai segítségével. Ehhez a zónát módosítania és integrálnia kell az Active Directoryba.

Meglévő zóna úgy integrálható az Active Directoryba, hogy azon az elsődleges kiszolgálón módosítja a zóna típusát, ahol azt először létrehozták. Miután a zóna típusát módosította Szabványos elsődleges típusról Active Directoryval integrált típusra, a zónát más DNS-kiszolgálókhoz is hozzáadhatja, ha azokat úgy konfigurálja, hogy Az Active Directoryból és a rendszerleíró adatbázisból beállítást használják a DNS-szolgáltatás inicializálásakor.

Ha Az Active Directoryból és a rendszerleíró adatbázisból beállítást választja, az Active Directory tartomány névtérének részeként működő más DNS-kiszolgálók – például az Active Directory tartomány tartományvezérlői – lekérdezhetik a címtárat, és automatikusan betölthetik a címtáradatbázisban tárolt valamennyi címtárral integrált zónát. További lépésre nincs szükség. Az Active Directoryból és a rendszerleíró adatbázisból beállítással az Active Directory részeként működő minden DNS-kiszolgáló alapértelmezés szerint a címtárral integrált zónák elsődleges kiszolgálója is.

A zónatípus módosításával kapcsolatos további tudnivalókat a Zónatípus módosítása című témakör tartalmazza. A kiszolgáló rendszerindítási módjának módosításával kapcsolatban bővebben A DNS-kiszolgáló rendszerindítási módszerének módosítása című témakörben tájékozódhat.

Megjegyzés

  • Szabványos elsődleges típusú zónák használatakor más DNS-kiszolgálók sohasem állíthatók be úgy, hogy egy meglévő zóna elsődleges kiszolgálóiként működjenek. Ez a kialakítás nem támogatott, és hibákhoz vagy inkonzisztenciához vezethet a zónaadatokban az azonos zóna eltérő verzióit betöltő kiszolgálók között.

Új elsődleges zóna hozzáadása meglévő kiszolgálóhoz

Meglévő kiszolgálóhoz új elsődleges zóna adható, valahányszor a DNS-tartománynévtérben további tartományokra vagy altartományokra van szükség. Előfordulhat például hogy van már egy második szintű tartományhoz (például microsoft.com) tartozó zóna a rendszerben, és a pelda.microsoft.com nevű új altartományhoz egy elsődleges zónát szeretne adni.

Ebben a példában a DNS beépülő modul segítségével létrehozhat az altartományhoz egy új zónát, ha futtatja az Új zóna varázslót. Amikor ez megtörtént, a szülőzónában delegálást kell létrehoznia az új altartomány (például a microsoft.com zóna) számára az új altartomány és elsődleges zónája hozzáadásának befejezéséhez.

Az új elsődleges zóna hozzáadása után szükség szerint végrehajthat más zónakonfigurálási feladatokat is a zóna teljes beállításához. További tudnivalók a Zónák kezelése című témakörben találhatók.


Meglévő kiszolgálók frissítése

A DNS-kiszolgálók beállításának frissítésére különböző okokból lehet szükség, melyek közül néhány:

  • A kiszolgáló számítógépnevének (állomásnevének) módosítása.
  • A kiszolgáló-számítógép elsődleges vagy szülő DNS-tartománynevének módosítása.
  • A kiszolgáló-számítógép IP-címének módosítása.
  • DNS-kiszolgáló eltávolítása a hálózatról.
  • Zóna elsődleges kiszolgálójának módosítása (csak szabványos elsődleges zónák esetében).

Ezeket a következő részek tárgyalják.

A kiszolgáló számítógépnevének (állomásnevének) módosítása

Ha szükség van a DNS-kiszolgáló állomásnevének (de nem szülő vagy elsődleges DNS-tartománynevének) megváltoztatására, végezze el a következő módosításokat abban a zónában, ahol a kiszolgálót a zóna mérvadó kiszolgálójaként állította be:

  1. A Rendszer tulajdonságaiban módosítsa a kiszolgáló számítógépnevét.
  2. Indítsa újra a számítógépet a következő DNS dinamikus frissítések elindításához:
    1. A kiszolgáló új nevéhez és IP-címéhez tartozó új A (állomás) és PTR (mutató) erőforrásrekordok hozzáadása.
    2. A kiszolgáló régi nevéhez és IP-címéhez tartozó régi A és PTR erőforrásrekordok eltávolítása.
  3. Frissítse az NS (névkiszolgáló) erőforrásrekordot azokban a zónákban, ahol a kiszolgálót mérvadónak állította be, hogy azok a 2. lépésben hozzáadott új A erőforrásrekordra mutassanak.
  4. Ha a kiszolgáló egy szabványos zóna elsődleges kiszolgálója, módosítsa a zónára vonatkozó SOA erőforrásrekordban, a tulajdonosra utaló mezőben lévő nevet. (Ha a zóna könyvtárral integrált, erre a lépésre nincs szükség.)
  5. A zónák ellenőrzésével győződjön meg arról, hogy a használt delegálási rekordok – NS vagy A erőforrásrekordok – frissítése az új kiszolgálónévre megtörtént-e.

A kiszolgáló elsődleges DNS-tartománynevének módosítása

Egy számítógép DNS-tartománynevének módosításakor a kiszolgáló elsődleges DNS-tartománynevének módosíthatósága attól függ, hogy a számítógépet tartományvezérlőként használja-e vagy sem.

Ha a kiszolgáló-számítógépet tartományvezérlőként működteti, a kiszolgáló-számítógép elsődleges DNS-tartománynevének meg kell egyeznie annak az Active Directory tartománynak a nevével, amelyben a kiszolgálót tartományvezérlővé léptette elő. E név módosításához a kiszolgálót először le kell lefokozni, hogy az ne legyen tartományvezérlő. Ebben a helyzetben a módosuló szülő DNS-tartománynevű kiszolgálónál az A és PTR rekordok hozzáadása és törlése automatikusan történik az Active Directory tartományba történő belépéskor és annak elhagyásakor. Ebben az esetben a régi és új DNS-szülőtartományok NS (névkiszolgáló) erőforrásrekordjainak csak kézi frissítésére van szükség.

Egy Active Directoryt nem használó DNS-kiszolgáló (például egy tartományi tagkiszolgáló vagy egy önálló kiszolgáló) DNS-tartománynevének módosításához néhány további módosításra és kézi felügyeletre lehet szükség. Ha például a régi és az új DNS-tartománynevek két különböző zónában vannak, például az A zónában (a régi zóna) és a B zónában (az új zóna), a következő módosításokat kell elvégeznie:

  1. A Rendszer tulajdonságaiban módosítsa A számítógép elsődleges DNS-utótagja beállítást.
  2. Az A zónában távolítsa el a kiszolgáló A erőforrásrekordját.
  3. A B zónában adja hozzá a kiszolgáló A erőforrásrekordját.
  4. Az átnevezett DNS-kiszolgáló nevét tartalmazó zónákban frissítse a SOA és NS (névkiszolgáló) erőforrásrekordokat.

A kiszolgáló IP-címének módosítása

Egy meglévő DNS-kiszolgáló IP-címének módosítása ugyanúgy történik, mint bármely más DNS-állomásszámítógép esetében. Frissítse a kiszolgálócím (A) erőforrásrekordban lévő IP-címet. Ha a kiszolgáló neve nem változik, az NS és a SOA rekordokra a módosítás nincs hatással.

Egy zóna A erőforrásrekordjában lévő IP-cím módosításakor fellépő általános beállítási hiba, hogy a DNS szolgáltatásban máshol használt azonos információ frissítése elmarad. Ha például egy név- vagy címváltozás tárgyát képező DNS-kiszolgálót a szülőzónában a delegálási rekordkészlet részeként használnak, a zónarekordok frissítése megtörténhet, de a delegálási rekordok változatlanul maradnak. Ezért hasznos ellenőrizni a szülőzónát is, ha a zónában lévő DNS-kiszolgálók A erőforrásrekordjainak IP-címét módosítja vagy frissíti. Ha ez nem történik meg, előfordulhat, hogy a zónadelegálás sikertelen lesz.

Hasonlóképpen ha egy többhelyű kiszolgálót használ, tartsa szem előtt azokat az eseményeket és feltételeket, amelyek között a Windows 2000 dinamikus frissítést kezdeményezhet kapcsolatspecifikus DNS rendszerű tartományelnevezés esetén. További tájékoztatást a Több név beállítása című témakörben találhat.

DNS-kiszolgáló eltávolítása a hálózatról

Egy DNS-kiszolgáló hálózatról való eltávolításához végezze a következő módosításokat azokban a zónákban, ahol a kiszolgálót a zóna mérvadó kiszolgálójaként állította be:

  1. Távolítsa el a kiszolgáló A (cím) erőforrásrekordját.
  2. Frissítse az NS (névkiszolgáló) erőforrásrekordokat azokban a zónákban, ahol a kiszolgálót mérvadóként állította be, hogy azok ne tartalmazzák név szerint a kiszolgálót (ahogy az 1. lépésben törölt A rekordban szerepelt).
  3. Ha a kiszolgáló egy szabványos zóna elsődleges kiszolgálója, módosítsa a zóna SOA erőforrásrekordjának tulajdonos mezőjét, hogy az a zóna új elődleges DNS-kiszolgálójára mutasson. (Ha a zóna könyvtárral integrált, erre a lépésre nincs szükség.)
  4. A szülőzóna ellenőrzésével győződjön meg arról, hogy a zóna delegálásához használt rekordok (NS vagy A erőforrásrekordok) módosítása megtörtént-e, azaz, már nem mutatnak az eltávolított kiszolgálóra.

Zóna elsődleges kiszolgálójának módosítása (csak szabványos elsődleges zónák esetében)

Szabványos elsődleges zónáknál néha szükség lehet egy zóna kijelölt elsődleges kiszolgálójának módosítására. Például legyen egy szabvány elsődleges zóna aktuális kiszolgálója az A kiszolgáló és a zóna új elsődleges kiszolgálója a B kiszolgáló.

Az A kiszolgálóról a B kiszolgálóra történő állapotváltáshoz végezze el a következő módosításokat:

  1. Adjon hozzá egy új A (állomás) erőforrásrekordot a B kiszolgálóhoz.
  2. Frissítse a zónában az NS (névkiszolgáló) erőforrásrekordot az A kiszolgáló eltávolításához és az 1. lépésben hozzáadott új A rekordra mutató, mérvadóként beállított B kiszolgáló hozzáadásához.
  3. Módosítsa a zóna SOA erőforrásrekordjának tulajdonos mezőjében lévő nevet az A kiszolgálóról a B kiszolgálóra.
  4. Távolítsa el az A kiszolgáló A erőforrásrekordját.
  5. A szülőzóna ellenőrzésével győződjön meg arról, hogy minden használatban lévő delegálási rekord (NS vagy A erőforrásrekord) frissítése megtörtént-e, azaz azok a B kiszolgálóra hivatkoznak.


Másodlagos kiszolgálók használata

A DNS-modellre vonatkozó specifikációk szerint egy zóna állomásaként célszerű legalább két DNS-kiszolgálót kell használni. Szabványos elsődleges típusú zónák esetében zóna hozzáadásához és beállításához egy másodlagos kiszolgáló szükséges ahhoz, hogy az a hálózaton lévő más DNS-kiszolgálók számára is megjelenjen. A címtárral integrált elsődleges zónák esetében a másodlagos kiszolgálók támogatottak, de a célhoz nem szükségesek. Két, Windows 2000 tartományvezérlőként működő DNS-kiszolgáló például lehet egy zóna redundáns elsődleges kiszolgálója; ez a megoldás, amellett, hogy rendelkezik a másodlagos kiszolgáló hozzáadásából adódó előnyökkel, további haszonnal is jár.

Másodlagos kiszolgálók segítségével mód van a DNS-lekérdezések forgalmának tehermentesítésére a hálózat olyan területein, ahol a zónák lekérdezése és használata igen nagy méreteket ölt. Ezenkívül ha az elsődleges kiszolgáló nem működik, a másodlagos kiszolgáló változatlan módon képes a névhozzárendelés biztosítására a zónában, míg az elsődleges kiszolgáló ismét rendelkezésre nem áll.

Ha egy másodlagos kiszolgálót ad hozzá, a lehető legközelebb helyezze azt azokhoz az ügyfelekhez, amelyeknek a zónában lévő nevek iránti igénye nagy. Fontolja meg másodlagos kiszolgálók elhelyezését egy útválasztón keresztül, vagy más alhálózatokon (ha útválasztásos LAN-t használ) vagy WAN-kapcsolaton keresztül. Ez lehetővé teszi a másodlagos kiszolgáló helyi tartalékként történő jó kihasználását arra az esetre, ha egy köztes hálózati kapcsolat meghibásodik a DNS-kiszolgálók és a zónát használó ügyfelek között.

Mivel az elsődleges kiszolgáló mindig karbantartja a zóna frissítéseinek és módosításainak főpéldányát, egy másodlagos kiszolgáló a DNS zónaletöltési mechanizmusára támaszkodik adatainak beszerzéséhez és naprakészen tartásához. Az olyan tényezők, mint a zónaletöltési módszerek – akár teljes, akár növekményes zónaletöltésről van szó – , sokkal nagyobb szerepet játszanak, ha másodlagos kiszolgálók is használatban vannak. További tudnivalók A zónák és a zónaletöltés ismertetése című témakörben találhatók.

A zónaletöltéseknek a másodlagos kiszolgálók okozta hatását tekintve vegye számba a kiszolgálók mint tartalék adatforrások előnyeit, és vesse azokat össze azzal a többletköltséggel, amellyel a hálózati infrastruktúrát megterhelik. Egyszerű szabály, hogy minden egyes hozzáadott másodlagos kiszolgálóval növekszik a hálózat használata (a megnövelt zónareplikációs forgalom miatt) és ezzel együtt növekszik a másodlagos kiszolgálókon a zóna szinkronizálásához szükséges idő.

A másodlagos kiszolgálókat a címlekérdezési zónák terhelik meg leginkább. Ha névlekérdezési zónákat használ, feltételezhetően kevesebb másodlagos kiszolgálót kell hozzáadnia ezekhez a zónákhoz. A névlekérdezési zóna másodlagos kiszolgálóját általában nem használják a hálózaton és az adott zónának megfelelő alhálózaton kívül.

Megjegyzés

  • További tudnivalók a Másodlagos kiszolgáló hozzáadása meglévő zónához című témakörben találhatók.


Csak gyorsítótárazást végző kiszolgálók használata

Bár minden DNS-névkiszolgáló gyorsítótárazza a hozzárendelt lekérdezéseket, a csak gyorsítótárazást végző kiszolgálók olyan DNS-névkiszolgálók, amelyek kizárólagos feladata a lekérdezések végrehajtása, a válaszok gyorsítótárba helyezése és az eredmények visszaküldése. Ezek nem mérvadók egyetlen tartományban sem, és az általuk tárolt adatok csak azokra korlátozódnak, amelyek a lekérdezések hozzárendelésekor gyorsítótárba kerültek.

Annak eldöntésekor, hogy mikor célszerű ilyen kiszolgálót használni, vegye figyelembe, hogy amikor ez a kiszolgáló először elindul, még nem tartalmaz adatokat a gyorsítótárban. Azokat csak az ügyfélkérelmek kiszolgálása során szerzi be. Ha azonban a helyek között lassú WAN-kapcsolatokat használ, ez a lehetőség ideális lehet, mert a gyorsítótár feltöltődése után a forgalom csökken. Ezenkívül a csak gyorsítótárazást végző kiszolgálók nem hajtanak végre zónaletöltést, ami WAN környezetben jelentősen megterhelheti a hálózatot.

Megjegyzés

  • További tudnivalók A csak gyorsítótárazást végző kiszolgálók telepítése című témakörben találhatók.


A kiszolgálón lévő adatok elévülésének és kitakarításának kezelése

A régi erőforrásrekordok elévülése és kitakarítása a Windows 2000 alapú DNS olyan szolgáltatása, amely a kiszolgáló elsődleges zónákkal történő üzembe helyezésekor áll rendelkezésre.

Ahol rendelkezésre áll az elévülés és kitakarítás, a DNS-konzol segítségével elvégezhetők a DNS-kiszolgálóra és az általuk betöltött bármely címtárral integrált zónára vonatkozó következő feladatok:

  1. Kitakarítás engedélyezése vagy tiltása egy DNS-kiszolgálón.
  2. Kitakarítás engedélyezése vagy tiltása a DNS-kiszolgálón kiválasztott zónákra.
  3. Frissítés nélküli időköz módosítása egy kiszolgáló alapértelmezéseként vagy a kijelölt zónák esetében egy, az alapértelmezést hatálytalanító érték megadásával.
  4. Frissítési időköz módosítása egy kiszolgáló alapértelmezéseként vagy a kijelölt zónák esetében egy, az alapértelmezést hatálytalanító érték megadásával.
  5. Annak megadása, hogy az időszakos kitakarítás a DNS-kiszolgáló bármelyik alkalmas zónájánál automatikusan menjen végbe, illetve hogy ez milyen gyakran ismétlődjön.
  6. Egyszeri kitakarítási művelet kézi elindítása a DNS-kiszolgáló valamennyi alkalmas zónájánál.
  7. Egyéb kapcsolódó tulajdonságok megtekintése, mint például az egyedi erőforrásrekordok időbélyege vagy egy megadott zóna takarítási idejének kezdete.

Régi erőforrásrekordok kitakarításának engedélyezése

Alapértelmezés szerint az elévülési és kitakarítási szolgáltatások az összes Windows 2000 alapú DNS-kiszolgálón és azok mindegyik zónáján le vannak tiltva. E szolgáltatások használata előtt el a következő beállításokat kell konfigurálni a megfelelő kiszolgálóra és annak címtárral integrált zónáira:

  • Kiszolgáló elévülési és kitakarítási tulajdonságai e szolgáltatások kiszolgáló szintű használatának meghatározására.

    Először engedélyezni kell a kiszolgálón a régi erőforrásrekordok elévülését és kitakarítását. Ezek a beállítások a zóna szintű tulajdonságok hatásának meghatározására szolgálnak a kiszolgálóra betöltött bármely címtárral integrált zóna esetében.

    További tudnivalók A DNS-kiszolgáló elévülési és kitakarítási tulajdonságainak beállítása című részben találhatók.

  • Zóna elévülési és kitakarítási tulajdonságai e szolgáltatások zóna szintű használatának meghatározására.

    Ha a zóna-specifikus tulajdonságokat a kijelölt zónára állítja be, ezek a beállítások csak az adott zónára és annak erőforrásrekordjaira lesznek érvényesek. Ha e zóna szintű tulajdonságokat nem állítja be másként, akkor ezek alapértelmezett értékeiket a kiszolgáló elévülési és kitakarítási tulajdonágainak megfelelő beállításaitól öröklik.

    További tudnivalókat a Kijelölt zóna elévülési és kitakarítási tulajdonságainak beállítása című részben talál.

Frissítés nélküli időközök módosítása

Amikor a frissítés nélküli időköz egy adott erőforrásrekordra érvényes, az időbélyegének dinamikus frissítésére tett kísérleteket a DNS-kiszolgáló elnyomja. Az elévülési és kitakarítási mechanizmus e jellege megakadályozza, hogy az elévült erőforrásrekordok szükségtelen frissítését a kiszolgáló végrehajtsa. Ezek a korai frissítési kísérletek, ilyen kezelés hiányában, megnövelhetnék az Active Directorynak a DNS-zónák módosításaival kapcsolatos replikációs forgalmát.

A rekordok idő előtti frissítésének elkerülésére minden egyes erőforrásrekord esetében tartsa a Frissítés nélküli időköz tartamát az aktuális frissítési időközzel egybevethető értéken. Ha például növeli a Frissítési időköz értékét, hasonlóan növelje a frissítés nélküli időközt is.

A legtöbb esetben az alapértelmezett 7 napos időköz elegendő és nem igényel módosítást.

Frissítési időközök módosítása

Amikor a frissítési időköz egy erőforrásrekordra érvényes, az időbélyegének dinamikus frissítésére tett kísérletet a DNS-kiszolgáló elfogadja és feldolgozza. Az időköz beállításakor fontos, hogy az alkalmazott időtartam nagyobb legyen, mint a zónán belüli bármely erőforrásrekord maximális lehetséges frissítési időköze. Ez az időköz egyenlő azzal a maximális időtartammal, amely normál hálózati körülmények között a rekord frissítéséhez szükséges a rekord frissítését kezdeményező adott forrás alapján.

A következő táblázat például a DNS rekordjainak dinamikus frissítőjeként ismert különféle szolgáltatás maximális frissítési időközeit mutatja.

Szolgáltatás | Maximális frissítési időtartam
Hálózati bejelentkezés | 60 perc (1 óra)
Fürtképzés | 15-20 perc
DHCP-ügyfél 24 óra

Megjegyzés

  • Alapértelmezés szerint minden Windows 2000 alapú számítógép a DHCP-ügyfélszolgáltatás segítségével 24 óránként frissítési kísérletet küld. Ide tartoznak a bérelt IP-címet DHCP segítségével beszerző számítógépek és azok is, amelyek statikusan vannak TCP/IP-re beállítva.
DHCP-kiszolgáló 4 nap

Megjegyzés

  • A frissítési kísérleteket csak DHCP/DNS-integrációt nyújtó Windows 2000 alapú DHCP-kiszolgálók végzik, ahol a kiszolgáló a DNS-ben proxy alapú frissítéseket nyújt ügyfelei számára. Ez az időköz azon alapul, hogy a DHCP-ügyfelek milyen gyakran újítják meg IP-címbérletüket a kiszolgálóval. Ez általában a hatókörbérlet érvényességének félidejében következik be. Ha a Windows 2000 alapértelmezett 8 napos hatókör bérleti időtartamot használja, az ügyfelek nevében a DHCP által frissített rekordok maximális frissítési időköze 4 nap.

Alapértelmezés szerint a frissítési időköz 7 nap. A legtöbb esetben ez az érték elegendő és nem igényel módosítást, hacsak a zónában lévő valamelyik erőforrásrekord frissítése nem történik 7 napnál ritkább időközönként.

Automatikus és kézi indítású takarítás

Bár a takarítás kezdeti ideje és más tényezők meghatározzák, hogy a zónák és a rekordok ténylegesen mikor alkalmasak a takarításra, a takarítás elindítására a következő két módszer valamelyikével is lehetőség van:

  • Az Automatikus kitakarítás megadja, hogy a régi rekordok elévülését és takarítását a kiszolgáló automatikusan hajtsa végre bármelyik alkalmas zónánál a takarítási időközként megadott ismétlődési időközben. Automatikus takarítás alkalmazásával az alapértelmezett takarítási időköz 1 nap, míg a használható minimális megengedett érték 1 óra.

    További tájékoztatás a Régi erőforrásrekordok automatikus kitakarításának engedélyezése című részben olvasható.

  • A Kézi kitakarítás megadja, hogy a régi rekordok elévülése és kitakarítása nem ismétlődő műveletként kerüljön végrehajtásra a kiszolgáló valamennyi alkalmas zónáján.

    További tájékoztatás a Régi erőforrásrekordok azonnali kitakarításának indítása című részben olvasható.

Időbélyegértékek módosítása

A DNS adatai közé nem dinamikusan felvett erőforrásrekordoknál a „nulla” rekord időbélyegérték érvényes, ami megakadályozza a rekordok elévülését és eltávolítását a takarítás alatt.

A rekord tulajdonságai azonban kézzel is visszaállíthatók, így lehetővé válik bármely statikusan bevitt rekord elévülési és takarítási műveletre történő képesítése. Ilyenkor a időbélyeg módosított értéke alapján a rekord törlődik, amikor is szükséges lehet a rekord ismételt létrehozása, ha arra továbbra is szükség van.

További tudnivalók az Adott erőforrásrekord takarítási és elévülési tulajdonságainak visszaállítása című részben találhatók.

Vigyázat!

  • Az elévülés és takarítás engedélyezése a szabványos elsődleges zónáknál módosítja a zónafájlok formátumát. Ez a módosítás nem befolyásolja a másodlagos kiszolgálókra történő zónareplikációt, de a módosított fájlt nem tudja betölteni más, nem Windows 2000 alapú DNS szolgáltatást futtató DNS-kiszolgáló.
  • Mielőtt e témakör ismeretanyagát alkalmazná, feltétlenül tekintse át az elévülési és kitakarítási folyamatot, illetve beállítható tulajdonságainak és szolgáltatásainak használatát. További tudnivalókat Az elévülés és a kitakarítás ismertetése című témakörben találhat.

Megjegyzés

  • Az Active Directory és a Windows 2000 alapú DNS használatára vonatkozó ismertetőt Az Active Directory integrációja című témakör tartalmazza.


Ügyfelek kezelése

A rész tartalma:

  • Az ügyfélszámítógép beállításainak konfigurálása
  • Több név beállítása
  • Ügyfélinformáció frissítése


Az ügyfélszámítógép beállításainak konfigurálása

Windows 2000 alapú ügyfelek esetében a DNS beállítása a számítógépek TCP/IP tulajdonságainak beállításakor a következő feladatokat tartalmazza:

  • Számítógépek DNS-beli (állomás-) nevének beállítása.
  • A számítógép elsődleges DNS-utótagjának beállítása; az utótag a számítógép- vagy állomásnév után kerül együtt alkotva a teljesen minősített tartománynevet (FQDN).
  • DNS-kiszolgálók listájának összeállítása ügyfelek számára a DNS-nevek hozzárendeléséhez; a lista tartalmazza az elsődleges DNS-kiszolgálót, valamint az elsődleges kiszolgáló elérhetetlensége esetén használandó egyéb DNS-kiszolgálókat.
  • DNS-utótagok keresési listájának vagy keresési módszerének beállítása az ügyfél számára, rövid, nem minősített tartománynevek DNS-lekérdezési kereséseinek végrehajtásához.

Ezeket a feladatokat a következő fejezetek részletesen tárgyalják.

Számítógépnevek beállítása

A számítógépnevek DNS-hez történő beállításakor érdemes úgy tekinteni a nevet, mint egy teljesen minősített tartománynév (FQDN) bal szélső része. A wkstn1.pelda.microsoft.com. például a teljesen minősített tartománynévben az első pont (.) előtti rész, a (wkstn1), a számítógép neve.

Az összes Windows DNS-ügyfelet olyan számítógépnevekkel láthatja el, amelyek a Internet DNS használatára vonatkozó 1123-as számú RFC-dokumentumban meghatározott, szabványos támogatott karakterekből állnak. Az ilyen használható karakterek a következők:

  • Nagybetűk A-tól Z-ig
  • Kisbetűk a-tól z-ig
  • 0 és 9 közötti számjegyek
  • Kötőjelek (-)

Ha hálózata egyaránt támogatja a NetBIOS- és a DNS-névtereket, az egyes névtereken belül eltérő számítógépnevet használhat. Ajánlatos azonban, ha lehetséges, 15 karakterből vagy kevesebből álló számítógépneveket használni és betartani az 1123-as számú RFC fent körvonalazott elnevezési előírásait.

Alapértelmezés szerint Windows 2000 esetében az ügyfelek teljes DNS-számítógépnevének bal szélső címkéje megegyezik a NetBIOS-számítógépnévvel, kivéve, ha ez a címke 16 oktett vagy annál nagyobb. Amikor ezek a címkék túllépik a NetBIOS-ban megengedett maximális hosszúságot, a NetBIOS-számítógépnév a megadott teljes címke alapján csonkul.

Windows 2000 rendszert futtató számítógépek különböző DNS- és NetBIOS-nevekkel történő konfigurálása előtt vegye figyelembe a következő szempontokat és azok telepítéssel kapcsolatos problémáit:

  • Ha a Windows DNS-kiszolgálókon lévő zónáknál engedélyezett a WINS keresés, a NetBIOS- és a DNS-számítógépek elnevezésénél ugyanazt a nevet kell használnia. Ellenkező esetben az ügyfeleknek az e számítógépnevekre vonatkozó lekérdezési és hozzárendelési kísérletének eredménye nem lesz következetes.
  • Ha Active Directory tartományhoz csatolt számítógépeknél a A számítógép teljes neve első címkéje előreláthatóan 15 bájtnál hosszabb lesz, további felügyeletre van szükség. Így módosíthatja a címtárban lévő számítógép-objektumok hozzáférés-szabályozási bejegyzéseit (ACE) annak érdekében, hogy lehetővé váljon az olyan DNS-állomásnevek regisztrálása, amelyek első címkéje 16 bájt vagy annál hosszabb.

    A konfiguráció további módosításainak oka az, hogy a 15 karakternél hosszabb DNS-nevek eltérnek a SAM-fióknévtől, amit a rendszer alapértelmezés szerint ahhoz használ, hogy a DNS-állomásnév első címkéjében bekövetkezett változást biztonságosan a címtárba írja. Emiatt a számítógép-objektum hozzáférés-szabályozási bejegyzésének biztonsági tulajdonságait frissíteni kell annak érdekében, hogy a 15 bájtnál hosszabb DNS-nevű számítógépek is írhassanak az objektumba.

    További tudnivalókat az Eltérő DNS-nevek használatának engedélyezése a számítógép számára című témakörben találhat.

Fontos

  • A számítógép-objektumok alapértelmezett hozzáférés-szabályozásának módosítása nélkülözhetetlen a SAM-fióknévtől eltérő, hosszabb DNS-számítógépnevek írásához. Azt azonban érdemes figyelembe venni, hogy egy számítógép-objektum alapértelmezett biztonságának módosításával esetleg egy számítógép véletlenül a SAM alapú névtől eltérő névvel hirdeti magát. Ebben az esetben a biztonságos dinamikus frissítés alkalmazása erősítheti a számítógépeknél használt DNS-állomásnevek frissítési biztonságát.

    További tudnivalókat a Biztonságos dinamikus frissítések című rész tartalmaz.

Ha az örökölt Microsoft hálózati technológia támogatásához NetBIOS-nevek használata mellett dönt, ajánlatos a hálózaton lévő NetBIOS-számítógépnevek módosítása a szabványos csak DNS környezetre történő áttérés előkészületeként. Ez felkészíti a hálózatot a hosszú távú növekedésre és az együttműködésre a jövőbeni elnevezési követelményekkel. Ha például ugyanazt a számítógépnevet használja a NetBIOS- és a DNS-hozzárendeléshez, fontolja meg a jelenlegi NetBIOS-nevekben szereplő olyan speciális karakterek, például az aláhúzás (_) átalakítását, amelyek nem felelnek meg a DNS elnevezési szabványnak. Bár ezek a karakterek engedélyezettek a NetBIOS-nevekben, gyakran összeférhetetlenek a hagyományos DNS állomáselnevezési követelményekkel és a legtöbb meglévő, DNS-névfeloldó ügyfélszoftverrel.

Megjegyzések

  • Bár a DNS szabványok hagyományosan tiltják az aláhúzás karakter (_) használatát a DNS-állomásnevekben vagy az A (állomás) erőforrásrekordokban, a szolgáltatással kapcsolatos nevekben – mint amilyenek az SRV erőforrásrekordokhoz használatosak – javasolt az aláhúzás karakterek használata az elnevezéseknek az Internet DNS-névtérben való ütközésének elkerülésére. További tudnivalók A DNS szolgáltatással kapcsolatos RFC-dokumentumok című témakörben találhatók.
  • A szabványos DNS elnevezési konvenciókon túl, a Windows 2000 Server rendszerben futó DNS-szolgáltatás támogatja a bővített ASCII és az Unicode karakterek használatát. Mivel azonban a más platformokra (például a UNIX-ra) írt legtöbb névfeloldó szoftver az Internet DNS szabványokon alapul, a kibővített karakterek e támogatása csak tisztán Windows 2000 környezetű magánhálózatokban használható.
  • Windows 2000 esetén a DNS és a TCP/IP első telepítése egy figyelmeztetést jelenít meg, amely nem szabványos DNS-név beírásakor szabványos DNS-nevet kínál fel.
  • Alapértelmezés szerint a Windows 2000 rendszert futató számítógépek DNS-t használnak a 15 karakternél hosszabb nevek hozzárendelésére. Ha a név 15 karakter hosszú vagy annál rövidebb, a név hozzárendelése megkísérelhető és elvégezhető a NetBIOS és a DNS névhozzárendeléssel egyaránt.

Tartománynevek beállítása

A tartománynév az ügyfélszámítógép nevével együtt alkotja a teljesen minősített tartománynevet (FQDN), más néven a számítógép teljes nevét. Általában a DNS-tartománynév az FQDN azon része, amely nem a számítógép egyedi állomásneveként használatos.

Például egy Windows 2000 rendszert futtató ügyfélszámítógéphez használt DNS tartománynév a következő lehet: Ha a beállított FQDN (vagy A számítógép teljes neve) a wkstn1.pelda.microsoft.com, a tartománynév ennek a névnek az pelda.microsoft.com része.

A Windows 2000 tartományneveknek két változata van – egy DNS-név és egy NetBIOS-név. Windows 2000 számítógépeknél a teljes számítógépnév (egy teljesen minősített DNS-név) használatos a hálózaton lévő névvel ellátott erőforrások lekérdezésére és megkeresésére. Korábbi verziójú ügyfeleknél a NetBIOS-név használatos a hálózaton megosztott különböző típusú NetBIOS-szolgáltatások keresésére.

A NetBIOS-és a DNS-nevek együttes használatának szükségességére jó példa a Hálózati bejelentkezés szolgáltatás. A Windows 2000 Server rendszerben a tartományvezérlőn lévő Hálózati bejelentkezés szolgáltatás DNS-kiszolgálón regisztrálja SRV erőforrásrekordjait. Windows NT Server 4.0-s és korábbi verzióknál a tartományvezérlők a WINS rendszerbe egy Tartománynév [1C] bejegyzést írnak e regisztrálás elvégzéséhez és annak meghirdetésére, hogy hálózati hitelesítési szolgáltatásra készen állnak.

Amikor egy Windows 2000 rendszert futtató ügyfélszámítógép elindul a hálózaton, az a Windows 2000 névfeloldó segítségével a DNS-kiszolgálóról lekérdezi a beállított tartománynevéhez tartozó SRV erőforrásrekordokat. A számítógép e lekérdezés alapján keresi meg a tartományvezérlőket és biztosít bejelentkezési hitelesítést a hálózati erőforrásokhoz történő hozzáférés érdekében. Ha a hálózaton egy ügyfél vagy egy tartományvezérlő Windows NT Server 4.0-s vagy korábbi verziót futtat, a Windows 2000 inkább a NetBIOS névfeloldó szolgáltatását használja a WINS-kiszolgálók lekérdezésére, megkísérelve megkeresni a Tartománynév [1C] bejegyzéseket a bejelentkezési művelet elvégzéséhez.

A DNS-tartományneveknek ugyanazokat a szabványokat és javasolt gyakorlatot kell követniük, amelyek az előző fejezetben leírt DNS számítógép-elnevezésre vonatkoznak. Általában a tartománynevek elfogadható elnevezési konvencióihoz tartozik az A-tól Z-ig terjedő betűk, a 0 és 9 közötti számok, valamint a kötőjel (-). használata. A pont (.) használata egy tartománynévben mindig azt a célt szolgálja, hogy elkülönítse egy tartománynév egyes részeit, más néven címkéit. Minden címke egy, a DNS-névtérfában megadott további szintnek felel meg.

A legtöbb számítógépnél a számítógéphez beállított elsődleges DNS-utótag megegyezhet Active Directorybeli tartománynevével, bár a két érték lehet eltérő is. Ahhoz, hogy a tagszámítógépek egy módosított DNS-utótagon alapuló, A számítógép teljes neve mezőben megjelenő eltérő teljes számítógépnevet használhassanak, további lépésekre van szükség az Active Directory beállításakor.

Ha például egy számítógép elsődleges DNS-utótagja (azaz a A számítógép teljes neve első címkéjétől jobbra lévő összes többi címke) előreláthatóan eltérő lesz attól az Active Directorybeli tartománynévtől, amelyhez csatlakozik, módosítania kell az érintett tartomány alapértelmezett hozzáférés-szabályozását. Ez az Active Directory - felhasználók és számítógépek konzol segítségével végezhető el. Ez a módosítás azért szükséges, hogy biztosítva legyen a DNSHostName és a Service Principal Name (SPN) attribútumok regisztrálása ott, ahol azok eltérnek (a módosított elsődleges DNS-utótag miatt) az Active Directorybeli tartománynévtől.

További tudnivalókat az Eltérő DNS-nevek használatának engedélyezése a számítógép számára című témakörben találhat.

Fontos

  • A tartományobjektumok alapértelmezett hozzáférés-szabályozásának módosítása létfontosságú lehet egy módosított elsődleges DNS-utótagon alapuló teljes DNS-számítógépnév írása érdekében. E módosítások nélkül a számítógépek nem tudnak sikeresen egy tartományhoz csatlakozni, illetve nem tudják elhagyni azt.

    Azt is érdemes azonban figyelembe venni, hogy egy tartományobjektum alapértelmezett biztonságának módosításával további biztonságra is szükség lehet. Ilyen esetben a módosított DNS-utótagra alapuló DNS-zónák biztonságos dinamikus frissítése segíthet helyreállítani vagy megerősíteni a hálózaton használt tartománynevek frissítési biztonságát.

    További tudnivalókat a Biztonságos dinamikus frissítések című rész tartalmazza.

A DNS-kiszolgálók listájának beállítása

A DNS-ügyfelek hatékony működéséhez mindegyik számítógép részére össze kell állítani a DNS-névkiszolgálók elsőbbségi sorrendbe rendezett listáját, amit az adott számítógép a lekérdezések feldolgozásakor és a DNS-nevek hozzárendelésekor használ majd. A legtöbb esetben az ügyfélszámítógép ahhoz az elsődleges DNS-kiszolgálóhoz csatlakozik és azt használja, amelyik a helyileg beállított listában az első DNS-kiszolgáló. Akkor kapcsolódik a felsorolt alternatív DNS-kiszolgálókhoz és használja azokat, amikor az elsődleges kiszolgáló nem érhető el. Ezért fontos, hogy az elsődleges DNS-kiszolgáló rendes körülmények között a folyamatos ügyfélhasználatra alkalmas legyen.

Megjegyzések

  • Windows 2000 rendszert futtató számítógépeknél a DNS-kiszolgálók listáját az ügyfelek kizárólag a DNS-nevek hozzárendeléséhez használják. Amikor az ügyfelek dinamikus frissítéseket küldenek, például DNS-tartománynevük vagy IP-címbeállításuk módosításakor, DNS-erőforrásrekordjaik frissítése érdekében szükség szerint kapcsolatba léphetnek ezekkel a kiszolgálókkal vagy más DNS-kiszolgálókkal is. További tudnivalókat a Dinamikus frissítés című rész tartalmaz.
  • Amikor a DNS-ügyfelek konfigurálása DHCP-kiszolgálóval dinamikusan történik, lehetőségük van a rendelkezésre álló DNS-kiszolgálók nagyobb listájának a használatára. Ha a DHCP-ügyfeleknek biztosítani szeretné a DNS-kiszolgálók IP-címjegyzékét, a DHCP-kiszolgálón lévő beállítási típusoknál engedélyezze a 6. számú beállításkódot. Ezzel a Windows DHCP-kiszolgálóknál mindegyik ügyfél számára egy legfeljebb 25 DNS-kiszolgálót tartalmazó listát állíthat be.
  • A terhelés hatékony megosztásához olyan esetben, amikor egy DHCP beállításon alapuló lista több DNS-kiszolgálót tartalmaz, beállíthat egy olyan különálló DHCP-hatókört, amely váltogatja az ügyfelek számára biztosított DNS-és WINS-kiszolgálók sorrendjét a listában.

DNS utótag keresési jegyzékének beállítása

Windows-ügyfeleknél összeállítható egy olyan DNS-tartományutótag keresési jegyzék, amely kibővíti vagy módosítja keresési lehetőségeiket a DNS-ben. További utótagok listázásával több megadott DNS-tartományban kereshetők rövid, nem minősített számítógépnevek. Ezután, ha a DNS-lekérdezés nem sikerül, a DNS ügyfélszolgáltatása e lista segítségével más névutótag-végződéseket fűzhet az eredeti névhez, és ezen alternatív teljesen minősített tartománynevekre vonatkozóan megismételheti a DNS-kiszolgáló.

Windows 2000 rendszerű számítógépeknél a rövid, nem minősített nevek kereséséhez és hozzárendeléséhez a következő alapértelmezett DNS keresési viselkedés van megállapítva, illetve ezt használja a program.

Amikor az utótagkeresési lista üres vagy nincs megadva, a program a számítógép elsődleges DNS-utótagját hozzáfűzi a rövid, nem minősített nevekhez, és a DNS-lekérdezést használja az eredményéül kapott FQDN hozzárendeléséhez. Ha ez a lekérdezés sikertelen, a számítógép próbálkozhat az alternatív teljesen minősített tartománynevek hagyományos lekérdezésével úgy, hogy hozzájuk fűz valamilyen, a hálózati kapcsolatokhoz beállított kapcsolat-specifikus DNS-utótagot.

Ha nincs beállítva kapcsolat-specifikus utótag, vagy az eredményül kapott kapcsolat-specifikus teljesen minősített tartománynevek lekérdezése sikertelen, az ügyfél újra megkísérelheti a lekérdezést, szisztematikusan csökkentve az elsődleges utótagot (ez visszafejtésként is ismert).

Ha például az elsődleges utótag a „pelda.microsoft.com”, a visszafejtési művelettel újra lekérdezhető lesz a rövid név a „microsoft.com” és a „com” tartományok keresésével.

Amikor az utótagkeresési lista nem üres és legalább egy megadott DNS-utótagot tartalmaz, a rövid DNS-nevek minősítési és hozzárendelési kísérlete csak a megadott utótaglistában lévő teljesen minősített tartománynevek keresésére korlátozódik. Ha a listában szereplő egyes utótagok hozzáfűzésével kialakított bármilyen teljesen minősített tartománynév lekérdezése sikertelen, a lekérdezési művelet nem hozza létre a „nem található a név” eredményt.

Megjegyzések

  • Ha a tartomány utótaglistáját használja, az ügyfelek további alternatív lekérdezéseket küldenek a különböző DNS-tartománynevek alapján, amikor a lekérdezés válasz vagy hozzárendelés nélkül marad. Amikor egy név hozzárendelése az utótaglista egyik bejegyzéséhez már megtörtént, a próbálkozás a lista fel nem használt bejegyzéseivel nem folytatódik. Ezért a leghatásosabb a jegyzéket a használati sorrend szerint rendezni.
  • A tartománynév utótagjainak keresésére csak akkor kerül sor, ha egy DNS-névbejegyzés nem teljesen minősített. Egy DNS-név teljes minősítéséhez a név végére egy lezáró pontot (.) kell írni.


Több név beállítása

Windows 2000 környezetben a számítógépek alapértelmezésként DNS-nevet kapnak. Mindegyik Windows 2000 rendszert futtató számítógép DNS-neve két módszer valamelyikével állítható be, mely szerint ez lehet:

  • Elsődleges DNS-tartománynév: a számítógép és annak valamennyi beállított hálózati kapcsolatának alapértelmezett, teljesen minősített DNS-neve.
  • Kapcsolat-specifikus DNS-tartománynév: csak a számítógépre telepített vagy beállított egyetlen hálózati csatolóra vonatkozó másodlagos tartománynévként állítható be.

Bár a legtöbb számítógépnek nem kell a DNS rendszerben egynél több nevet támogatnia vagy használnia, néha hasznos lehet több kapcsolat-specifikus DNS-név beállítását támogatni. Több név használatával a felhasználó például meghatározhatja, hogy melyik hálózati kapcsolatot használja egy többhelyű számítógéphez való csatlakozáskor.

Példa: kapcsolat-specifikus nevek használata

Miként az a következő ábrán látható, egy „a-allomas” nevű többhelyű kiszolgáló-számítógép elnevezhető elsődleges és kapcsolat-specifikus DNS-tartományneve szerint egyaránt.

Példa: több névvel konfigurált többhelyű DNS-számítógép

Ebben a példában az a-allomas nevű kiszolgáló-számítógép két különálló alhálózathoz – 1. alhálózat és 2. alhálózat – kapcsolódik, amelyeket redundáns pontoknál két útválasztó is összekapcsol az egyes alhálózatok közötti további elérési utak biztosítására. Ilyen konfigurációban az a-allomas a következők szerint biztosít hozzáférést az eltérően elnevezett helyi hálózati (LAN-) kapcsolatain keresztül:

  • Az „a-allomas.nyilvanos.pelda.microsoft.com” név az 1. LAN-kapcsolattal biztosít hozzáférést a lassabb, (10 megabites) Ethernet LAN-kapcsolattal rendelkező 1. alhálózathoz olyan felhasználó számára, akik szokásos fájl és nyomtatási szolgáltatást igényelnek.
  • Az „a-allomas.tartalek.pelda.microsoft.com” név a 2. LAN-kapcsolattal biztosít korlátozott hozzáférést a gyorsabb, (100 megabites) Ethernet LAN-kapcsolattal rendelkező 2. alhálózathoz olyan kiszolgálóalkalmazások és rendszergazdák számára, amelyeknek, illetve akiknek speciális igényeik vannak, mint amilyen a kiszolgáló hálózati hibáinak elhárítása, hálózati alapú biztonságimásolat-készítés vagy a kiszolgálók közötti zónaadatok replikálása.

A kapcsolat-specifikus DNS-neveken túl, a számítógép az „a-allomas.pelda.microsoft.com” elsődleges DNS-tartománynév megadásával mindkét LAN-kapcsolat segítségével elérhető.

A bemutatott konfigurációban a Windows 2000 a három eltérő névnek és IP-címkészletnek megfelelően erőforrásrekordokat regisztrálhat a DNS-ben, miként az a következő táblázatban látható:

DNS-név | IP-cím | Leírás
a-allomas.pelda.microsoft.com | 10.1.1.11, 10.2.2.22 | A számítógép elsődleges DNS-neve. A számítógép az ilyen név alatt beállított összes IP-címhez A és PRT erőforrásrekordokat regisztrál a „pelda.microsoft.com” zónában.
a-allomas.nyilvanos.pelda.microsoft.com | 10.1.1.11 | Az 1. LAN-kapcsolat kapcsolat-specifikus DNS-neve, amely a 10.1.1.11 IP-címhez A és PTR erőforrásrekordokat regisztrál a „nyilvanos.pelda.microsoft.com” zónában.
a-allomas.tartalék.pelda.microsoft.com | 10.2.2.22 | A 2. LAN-kapcsolat kapcsolat-specifikus DNS-neve, amely a 10.2.2.22 IP-címhez A és PTR erőforrásrekordokat regisztrál a „tartalek.pelda.microsoft.com” zónában.

Megjegyzések

  • A DNS-nevek beállíthatók távfelügyelet vagy más távkonfigurálási szolgáltatás, például DHCP, alkalmazásával. Windows 2000 alapú számítógépen az elsődleges DNS-tartománynév beállítható akár távfelügyelettel, akár a felügyelet nélküli telepítési beállítással.
  • A kapcsolat-specifikus elnevezésnél alkalmazhatók a TCP/IP beállítási módszerek. A Hálózati és telefonos kapcsolatok mappában megjelenő mindegyik kapcsolathoz kézzel is beállítható DNS-tartománynév, de erre használható DHCP beállítási típus is (a beállítás kódszáma: 15).


Ügyfélinformáció frissítése

Időnként szükség van a számítógépen a DNS-ügyfél adatainak frissítésére – például ha egy számítógépet Active Directory tartományhoz ad hozzá vagy távolít el onnan. A legtöbb esetben az ügyfelek a tartományba való belépéskor vagy annak elhagyásakor dinamikus frissítéseket hajtanak végre a következő módosítások esetén:

  • Amikor a számítógép egy tartományhoz csatlakozik, A és PTR rekordjait a DNS-hez adja.
  • Amikor a számítógép kilép egy tartományból, A és PTR rekordjait törli a DNS-ből.

Ha engedélyezi a zónák dinamikus frissítését, ezek a módosítások automatikusan végbemennek. További tudnivalókat a Dinamikus frissítés című témakör tartalmaz.


Zónák kezelése

A rész tartalma:

  • Általános tulajdonságok kezelése
  • Hitelesítési rekordok kezelése
  • Erőforrásrekordok kezelése
  • Zónák delegálása
  • Értesítési listák beállítása
  • WINS-keresés használata
  • Névlekérdezési zónák kezelése


Általános tulajdonságok kezelése

Zóna DNS-konzollal történő hozzáadásakor a következő általános tulajdonságok kezelésére van mód:

  • Zóna felfüggesztése vagy indítása szolgáltatásának megszakításához vagy folytatásához.
  • A zóna típusának módosítása vagy átalakítása.
  • A zóna dinamikus frissítéseinek tiltása vagy engedélyezése.

Címtárral integrált zónáknál engedélyezheti a biztonságos dinamikus frissítések használatát. Ez lehetővé teszi, hogy a frissítéseket csak hitelesített felhasználók vagy rendszerek egy adott csoportjára korlátozza. Amikor a zóna számára engedélyezett a biztonságos frissítések házirendje, csak az Active Directoryn keresztül hitelesített, és az egyes címtárral integrált zónákhoz tartozó hozzáférési jogok listájában (ACL) szereplő felhasználók, rendszerek vagy csoportok frissíthetik a zónát és az abban használt egyes erőforrásrekordokat.

Az általános zónatulajdonságokon túl, a DNS-konzol segítségével a következő zónatulajdonságok beállítására és kezelésére nyílik lehetőség:

  • A SOA tulajdonságai Ide tartoznak a SOA erőforrásrekord által támogatott tulajdonságok. A SOA a zóna inicializálásáért felelős, valamint a DNS-tartománynévhez (és annak más kiszolgálóra nem delegált altartományaihoz) tartozó zóna hitelességét jelzi a DNS-névtérben lévő többi kiszolgálónak. Ez a rekord befolyásolja, hogy milyen gyakran kell a zónát megújítani és más, a zónát betöltő kiszolgálók által letölteni, továbbá hogy az ügyfelek mennyi ideig tarthatják a gyorsítótárban az erőforrásrekordokat miután a zóna névlekérdezéseire adott válaszokban visszakerülnek. A rekorddal és annak beállításával kapcsolatos további információ a Hitelesítési rekordok kezelése című témakörben található.
  • A Névkiszolgálók tulajdonságai Ide tartozik a zóna NS erőforrásrekordja által támogatott összes mező. Az NS erőforrásrekord a zóna mérvadó DNS-kiszolgálóinak nevét jelzi a többiek számára. A rekorddal és annak beállításával kapcsolatos további információ a Hitelesítési rekordok kezelése című témakörben található.
  • A zónaletöltés tulajdonságai E tulajdonsággal beállíthatja, hogy a zóna hogyan engedélyezze a letöltések végrehajtását.

    Választhatja, hogy visszautasítja a kiszolgálóra érkező, zónaletöltéssel kapcsolatos összes kérelmet, azokat csak a Névkiszolgálók lapon beállított más DNS-kiszolgálók számára engedélyezi, illetve hogy csak azokra a DNS-kiszolgálókra engedélyezi a zónaletöltést, amelyeket egy listában lévő IP-címmel meghatároz.

    Az itt található Értesítés gombra kattintva engedélyezheti és beállíthatja a DNS szolgáltatással kapcsolatos értesítést a zóna másodlagos kiszolgálói számára. Az értesítés alkalmazásával a többi kiszolgáló (a Névkiszolgálók lapon beállítottak vagy egy listán megadottak) értesítést kap, ha a zóna módosul. Ezek a kiszolgálók ezután kezdeményezhetik a zónaletöltést és lekérhetik a módosításokat a zóna frissítéséhez.

    További tudnivalókat az Értesítési listák beállítása című témakörben találhat.

  • A WINS keresés tulajdonságai A Windows Internet Name Service (WINS) keresési szolgáltatása segítségével a zónákhoz kiterjesztett DNS-névhozzárendelési út használható, ha egy lekérdezett név nem található a zónában. Ha a zóna számára a WINS keresés engedélyezett, kapcsolat létesíthető egy WINS-kiszolgálóval (vagy egy listában szereplő WINS-kiszolgálókkal) a WINS által kezelt NetBIOS-névtérben lévő állomásnév hozzárendelése érdekében. Ezt a szolgáltatást csak a Microsoft által készített DNS-kiszolgálók támogatják. További tudnivalókat A WINS keresés használata című témakör tartalmaz.


Hitelesítési rekordok kezelése

A zónák a kiszolgálói hitelesítés elvén alapulnak. Ha egy DNS-kiszolgáló zóna betöltésére van beállítva, két erőforrásrekord-típust használ a zóna mérvadó tulajdonságainak meghatározására:

  • Először is az SOA rekord a zóna származási nevét jelzi, és tartalmazza annak a kiszolgálónak a nevét, amely a zónával kapcsolatos adatok elsődleges forrása. Emellett mutatja a zóna más alapvető tulajdonságait is.
  • Másodszor az NS erőforrásrekord azt mutatja, hogy melyik DNS-kiszolgáló van kijelölve a zóna mérvadó kiszolgálójaként. Ha egy kiszolgáló szerepel az NS erőforrásrekordban, akkor ezt a többi kiszolgáló a zóna mérvadó kiszolgálójaként ismeri fel. Ez azt jelenti, hogy az NS erőforrásrekordban megadott bármelyik kiszolgálót a többi mérvadó forrásnak tekinti, amely megbízhatóan képes a zónában lévő nevekre vonatkozó lekérdezések megválaszolására.

Az SOA és az NS erőforrásrekordok speciális szerepet játszanak a zóna beállításában. Ezek minden zóna számára nélkülözhetetlen, és tipikusan a fájlokban elsőként felsorolt erőforrásrekordok. Alapértelmezés szerint az Új zóna varázsló automatikusan hozza létre ezeket a rekordokat, amikor a DNS beépülő modul segítségével új elsődleges zónát vesz fel.

Az SOA rekord

A SOA rekord mindig, minden szabványos zónában az első. Azt a DNS-kiszolgálót jelzi, amelyik eredetileg létrehozta vagy amelyik éppen a zóna elsődleges kiszolgálója. Egyéb tulajdonságok tárolására is használatos, ilyenek például a verziószámra vonatkozó információ vagy zóna megújítását és lejáratát befolyásoló időzítések. Ezek a tulajdonságok befolyásolják, hogy milyen gyakran történjen zónaletöltés a zóna mérvadó kiszolgálói között.

Az SOA rekord a következő információkat tartalmazza:

Mező | Leírás
Elsődleges kiszolgáló | A zóna elsődleges DNS-kiszolgálójának állomásneve.
Felelős személy | A zóna felügyeletéért felelős személy elektronikus levélcíme. Ebben az elektronikus levélcímben a @ jel helyett pontot (.) kell használni.
Sorozatszám | A zónafájl verziójának száma. Ez a szám növekszik, valahányszor a zónában egy erőforrásrekordot módosul. Fontos, hogy ez az érték a zóna minden egyes módosításánál növekedjen, hiszen így lehetséges, hogy a zóna részleges módosításai vagy a teljesen módosított zóna más másodlagos kiszolgálókra replikálható legyen az ismétlődő letöltések során.
Frissítési időköz | Az az idő (másodpercben), amennyit egy másodlagos DNS-kiszolgáló vár, mielőtt a zóna forrását lekérdezné a megújítására tett kísérlet előtt. Amikor a frissítési időköz lejár, a másodlagos DNS-kiszolgáló megkéri forrásától a zóna jelenlegi SOA rekordjának másolatát, amely forrás válaszol a kérésre. Ezt követően a másodlagos DNS-kiszolgáló összehasonlítja a forráskiszolgáló jelenlegi SOA rekordjának (a válaszban jelzett) sorozatszámát saját helyi SOA rekordjának sorozatszámával. Ha ezek eltérőek, a másodlagos DNS-kiszolgáló zónaletöltést kér az elsődleges DNS-kiszolgálóról. E mező alapértelmezett értéke 900 másodperc (15 perc).
Újrapróbálkozási időköz | Az az idő (másodpercben), amennyit egy másodlagos kiszolgáló vár, mielőtt egy sikertelen zónaletöltés után újra próbálkozna. Normál esetben ez az idő kevesebb, mint a frissítési időköz. Az alapértelmezett érték 600 másodperc (10 perc).
Ezután lejár | Az az idő (másodpercben), ami után egy másodlagos kiszolgáló megszünteti a lekérdezések megválaszolását az eltelt frissítési időköz után, olyankor ha a zóna frissítése nem történt meg. A lejárat azért jelentkezik, mert ekkor a másodlagos kiszolgálónak a helyi adatokat megbízhatatlannak kell tekintenie. Az alapértelmezett érték 86 400 másodperc (24 óra).
Minimális (alapértelmezett) TTL | A minimális élettartam (TTL) érték a zónában lévő minden olyan erőforrásrekordra érvényes, amely nem rendelkezik rekord-specifikus TTL értékkel. Ezt az értéket a lekérdezésre adott válaszban a zóna kiszolgálói szolgáltatják a többiek tájékoztatására, hogy meddig őrizzék a gyorsítótárban a válaszban megadott erőforrásrekordot. Az alapértelmezett érték 3600 másodperc (1 óra).

A következő egy alapértelmezett SOA rekordra mutat példát:

@   IN  SOA     nevkiszolgalo.pelda.microsoft.com.  postafonok.pelda.microsoft.com. (
                               1            ; sorozatszám
                               3600         ; frissítés   [1h]
                               600          ; újrapróbálkozás     [10m]
                               86400        ; lejár    [1d]
                               3600 )       ; min TTL   [1h]

A fenti SOA rekordmintában a zóna elsődleges vagy kezdeményező kiszolgálóját a „nevkiszolgalo.pelda.microsoft.com” jelöli. A zónával kapcsolatos kérdésekben illetékes személy elektronikus levélcíme a „postafonok.pelda.microsoft.com”.

Megjegyzések

  • A zónában lévő DNS-tartománynevek írásakor és tárolásakor az elektronikus levélcím jelölésére pont használatos. Elektronikus levelezésre szolgáló alkalmazásban az előző mintacím formátuma a következő: postafonok@pelda.microsoft.com.
  • A zónafájlban megjelenő SOA rekordban használt zárójelek a rekord sortörését teszik lehetővé többsoros szöveg esetén.
  • Ha a zóna egy meghatározott erőforrásrekordjának egyedi TTL értéket ad meg és alkalmaz, akkor ez hatálytalanítja az SOA rekordban beállított minimális (alapértelmezett) TTL értéket.

Az NS erőforrásrekord

Az NS (névkiszolgáló) erőforrásrekordok két módon használhatók a DNS-tartománynév megadott kiszolgálóinak hitelesítési jogosultsággal való felruházására:
  • A tartomány mérvadó kiszolgálóit tartalmazó lista létrehozásával, hogy az abban szereplő kiszolgálókról tudomást szerezzenek mindazok a kiszolgálók, amelyek a tartományról (zónáról) információt kérnek.
  • A zónából delegált altartományok mérvadó DNS-kiszolgálóinak jelzésével.

Abban az esetben, ha az egyazon zónában lévő állomásneveket kiszolgálókhoz rendeli, a zónában általában a megfelelő A (cím) rekordok használatosak a megadott kiszolgálók nevének azok IP-címeihez való hozzárendelésére. Olyan kiszolgálók esetében, amelyeket egy zóna altartományba történő delegálásakor ezzel az erőforrásrekorddal adott meg, az NS erőforrásrekord általában zónán kívüli neveket tartalmaz. A zónán kívüli nevek hozzárendeléséhez szükség lehet a zónán kívüli kiszolgálók A rekordjaira. Amikor a delegáláshoz ezek a zónán kívüli NS és A rekordok szükségesek, akkor e rekordok neve összekapcsoló bejegyzés.

Leírás: Egy, a tulajdonos mezőben megadott DNS-tartománynév hozzárendelésére szolgál a névkiszolgáló_tartománynév mezőben megadott DNS-kiszolgálókat működtető állomások nevéhez. Az RFC-kel és beszerzésükkel kapcsolatos további információ A TCP/IP protokollal kapcsolatos RFC-dokumentumok című témakörben található.
Szintaxis: tulajdonos ttl IN NS névkiszolgáló_tartománynév
Példa:
pelda.microsoft.com.    IN NS  nevkiszolgalo1.pelda.microsoft.com


Erőforrásrekordok kezelése

A zóna létrehozása után ahhoz további erőforrásrekordokat kell adni. A hozzáadandó leggyakoribb erőforrásrekordok a következők:

  • A (állomás) DNS-tartománynév hozzárendelésére egy számítógép által használt IP-címhez.
  • CNAME (alias) Alias DNS-tartománynév hozzárendelésére másik elsődleges azaz kanonikus névhez.
  • MX (levélváltás) DNS-tartománynév hozzárendeléséhez egy levélváltó vagy levéltovábbító számítógép nevéhez.
  • PTR (mutató) Egy számítógép IP-címén alapuló DNS-tartománynevének hozzárendeléséhez, ami ennek a számítógépnek a DNS-tartománynevére mutat.
  • SRV (szolgáltatáshely) DNS-tartománynév hozzárendeléséhez a speciális típusú szolgáltatást nyújtó DNS állomás-számítógépek, például Active Directory tartományvezérlők meghatározott listájához.
  • Szükség szerinti egyéb erőforrásrekordok.

A (állomás) erőforrásrekordok

Az A (állomás) erőforrásrekordok egy zónában használatosak számítógépek (állomások) DNS-tartománynevének e számítógépek IP-címeihez való társításához; a zónához több módon adhatók hozzá:

  • A DNS-konzol segítségével kézzel létrehozható egy A erőforrásrekord statikus TCP/IP-ügyfélszámítógép számára.
  • A Windows 2000 rendszerrel működő számítógépek a DHCP-ügyfélszolgáltatást alkalmazzák a DNS-ben lévő saját A erőforrásrekordjuk dinamikus regisztrálásához és frissítéséhez, ha egy IP-beállítás módosul.
  • Korábbi verziójú Microsoft operációs rendszereket futtató, és a DHCP-szolgáltatást használni tudó ügyfélszámítógépek proxyval regisztráltathatják és frissíttethetik A erőforrásrekordjukat, ha IP-bérletüket egy minősített DHCP-kiszolgálóról szerzik be (ezt a szolgáltatást jelenleg csak a Windows 2000 Server rendszerrel forgalomba kerülő DHCP támogatja).

Nem minden számítógép igényel A erőforrásrekordot, de a hálózaton erőforrásokat megosztó számítógépek igen. Erőforrásokat megosztó és DNS-tartománynevével azonosítandó bármely számítógép esetében szükséges az A erőforrásrekordok használata a számítógép IP-címének DNS-névhez történő hozzárendeléséhez.

A zónában szükséges legtöbb A erőforrásrekord tartalmazhat olyan más munkaállomásokat vagy kiszolgálókat, amelyek erőforrásokat, más DNS-kiszolgálókat, levelezőkiszolgálókat és webkiszolgálókat osztanak meg. Ezek a erőforrásrekordok alkotják a zóna adatbázisában lévő erőforrásrekordok többségét.

További tájékoztatás az Erőforrásrekordok: A című témakörben olvasható.

CNAME (alias) erőforrásrekordok

Az CNAME erőforrásrekordokat néha kanonikus neveknek is nevezik. Ezek a rekordok lehetővé teszik egyetlen állomásra mutató több név használatát, megkönnyítve az olyan feladatok elvégzését, mint például egyazon számítógép FTP-kiszolgáló és webkiszolgáló állomásaként való működtetése. A jól ismert kiszolgálónevek (ftp, www) regisztrálása például olyan CNAME erőforrásrekordok használatával történik, amelyek az e szolgáltatásoknak állomásul szolgáló kiszolgáló-számítógépek DNS-állomásnevére (például „kiszolgáló-1”) mutatnak.

A CNAME erőforrásrekordok használata a következő helyzetekben ajánlatos:

  • Amikor ugyanebben a zónában lévő egyik A erőforrásrekordban megadott állomást át kell nevezni.
  • Amikor egy jól ismert kiszolgáló általános nevét (például www) kell hozzárendelni olyan egyedi (saját A erőforrásrekordokkal rendelkező) számítógépek egy csoportjához, amelyek ugyanazt a szolgáltatást nyújtják. Ilyen lehet például redundáns webkiszolgálók egy csoportja.

Amikor a zónában lévő A erőforrásrekorddal rendelkező számítógépet átnevez, ideiglenesen használhat CNAME erőforrásrekordot annak érdekében, hogy haladékot adjon a felhasználók és a programok számára a régi számítógépnévről az újra történő áttéréshez. Ehhez a következők szükségesek:

  • A számítógép új DNS-tartományneve esetén egy új A erőforrásrekordot adódik a zónához.
  • Régi DNS-tartománynév esetén egy CNAME rekord adódik hozzá, amely az új A erőforrásrekordra mutat.
  • A régi DNS-tartománynév eredeti A erőforrásrekordja (és társított PRT erőforrásrekordját, ha van) törlődik a zónából.

Amikor CNAME erőforrásrekordot használ egy számítógép aliassal való ellátásához vagy átnevezéséhez, állítson be egy ideiglenes időkorlátot, ameddig a rekordot a zónában használni lehet DNS-ből való törlése előtt. Ha elfelejti törölni a CNAME erőforrásrekordot, és később törlődik annak társított A rekordja, a CNAME erőforrásrekord feleslegesen használhatja a kiszolgáló erőforrásait azáltal, hogy egy olyan név lekérdezéseit próbálja meg hozzárendelni, amely már nincs használatban a hálózaton.

A CNAME rekord használatának leggyakoribb és legnépszerűbb módja az, amikor egy állandó DNS-aliassal rendelkező tartománynevet biztosítanak egy szolgáltatás alapú név (például www.pelda.microsoft.com) több számítógéphez vagy egy webkiszolgálón lévő IP-címhez való hozzárendeléséhez. Az alábbiakban például egy CNAME erőforrásrekord használatának alapvető szintaxisa látható:

alias_név IN CNAME elsődleges_kanonikus_név

Ebben a példában egy „allomas-a.pelda.microsoft.com” nevű számítógépnek egyaránt kell „www.pelda.microsoft.com” nevű webkiszolgálóként és egy „ftp.pelda.microsoft.com” nevű FTP kiszolgálóként működnie. Ahhoz, hogy a számítógép elnevezése elérje a kívánt célt, a pelda.microsoft.com zónához a következő CNAME bejegyzéseket adhatja hozzá:

allomas-a   IN  A      10.0.0.20
ftp         IN  CNAME  allomas-a
www         IN  CNAME  allomas-a

Ha később úgy dönt, hogy az FTP-kiszolgálót egy másik, az „allomas-a” webkiszolgálótól eltérő számítógépre helyezi át, egyszerűen módosítsa az ftp.pelda.microsoft.com zónában a CNAME erőforrásrekordot, és adjon hozzá egy további A erőforrásrekordot az FTP kiszolgálónak állomásul szolgáló új számítógép zónájához.

A korábbi példa alapján ha egy új számítógépet „allomas-b.pelda.microsoft.com” névvel látott el, az új, módosított A és CNAME rekordok a következők lesznek:

allomas-a   IN  A      10.0.0.20
allomas-b   IN  A      10.0.0.21
ftp         IN  CNAME  allomas-b
www         IN  CNAME  allomas-a

További tudnivalók az Erőforrásrekordok: CNAME című témakörben találhatók.

MX erőforrásrekordok

Az MX erőforrásrekordot az elektronikus levelezésre szolgáló alkalmazások használják egy levelező kiszolgáló megkeresésére az üzenet címzettjének címében használt DNS-tartomány neve alapján. A „pelda.microsoft.com” névre vonatkozó DNS-lekérdezés például felhasználható egy MX erőforrásrekord megkeresésére, miáltal lehetővé válik, hogy egy levelezőalkalmazás a „felhasznalo@pelda.microsoft.com” levélcímű felhasználó számára levelet továbbítson vagy azzal levelezzen.

Az MX erőforrásrekord annak a számítógépnek (vagy számítógépeknek) mutatja a DNS-tartománynevét, amely a tartomány számára feldolgozza a levelet. Ha több MX erőforrásrekord létezik, a DNS-ügyfélszolgáltatás megkísérel kapcsolatba lépni a levelezőkiszolgálóval a legalacsonyabb értéktől (legmagasabb prioritástól) a legmagasabb értékig (legalacsonyabb prioritásig) terjedő elsőbbségi sorrendben. Az alábbiakban egy MX erőforrásrekord használatának alapvető szintaxisa látható:

levelezőtartomány_neve IN MX elsődleges_levelezőkiszolgáló_állomás

Az alábbi pelda.microsoft.com zónában bemutatott MX erőforrásrekordok használatával a felhasznalo@pelda.microsoft.com címzésű levél először a felhasznalo@levelezokiszolgalo0.pelda.microsoft.com címre továbbítódik, amennyiben ez lehetséges. Ha ez a kiszolgáló nem érhető el, a névfeloldó ügyfél használhatja helyette a felhasznalo@levelezokiszolgalo1.pelda.microsoft.com címet.

@         IN  MX   1    levelezokiszolgalo0
@         IN  MX   2    levelezokiszolgalo1

Ne feledje, hogy a @ jel használata a rekordokban azt jelzi, hogy a DNS-levelezőtartomány neve ugyanaz, mint a zóna származási neve (pelda.microsoft.com).

További tudnivalók az Erőforrásrekordok: MX című témakörben találhatók.

PTR erőforrásrekordok

A PTR (mutató) erőforrásrekordok a névlekérdezési művelet támogatására szolgálnak az in-addr.arpa tartományban létrehozott zónák alapján, melyeknek ugyanebben a tartományban van a gyökerük. Ezeket a rekordokat egy számítógép IP-cím alapján történő megkeresésére, és a kapott információnak a számítógép DNS-tartománynevéhez történő hozzárendelésére használják.

Zónához PTR erőforrásrekordok több módon adhatók hozzá:

  • A DNS beépülő modul segítségével kézzel létrehozhat PTR erőforrásrekordot egy statikus TCP/IP-ügyfélszámítógép számára vagy külön eljárásként vagy egy A erőforrásrekord létrehozása keretében.
  • Windows 2000 rendszerrel működő számítógépek a DHCP-ügyfél szolgáltatást alkalmazhatják a DNS-ben lévő saját PTR erőforrásrekordjuk dinamikus regisztrálásához és frissítéséhez egy IP-beállítás módosulása esetén.
  • A DHCP szolgáltatást használni képes összes többi ügyfélszámítógép a DHCP-kiszolgálóval regisztráltathatja és frissíttetheti saját PTR erőforrásrekordjait, ha IP-címbérletét egy minősített DHCP-kiszolgálóról szerzi be. A Windows 2000 Server rendszerrel szállított DHCP-szolgáltatás biztosítja ezt a lehetőséget.

A PTR erőforrásrekord csak névlekérdezési zónákban használatos a névlekérdezés támogatására. További tudnivalók az Erőforrásrekordok: PTR című témakörben találhatók.

SRV erőforrásrekordok

Windows 2000 környezetben az Active Directoryt használó tartományvezérlők megkereséséhez SRV erőforrásrekordok szükségesek. Az Active Directory telepítésekor az SRV erőforrásrekordok kézi felügyelete általában elkerülhető.

Alapértelmezés szerint az Active Directory telepítő varázsló egy DNS-kiszolgálót próbál megkeresni az elsődleges vagy egyéb DNS-kiszolgálók listája alapján. E DNS-kiszolgáló bármelyik TCP/IP-ügyfele tulajdonságaiban és bármely aktív hálózati kapcsolathoz be lehet állítva. Ha létrejön a kapcsolat egy olyan DNS-kiszolgálóval, amely elfogadja az SRV erőforrásrekord (és más, a DNS-ben az Active Directory szolgáltatásként történő regisztrálásával kapcsolatos erőforrásrekordok) dinamikus frissítését, a beállítási művelet befejeződik.

Ha a telepítés során nem található olyan DNS-kiszolgáló, amely elfogadja az Active Directory elnevezésére használt DNS-tartománynév frissítéseit, egy Windows 2000 DNS-kiszolgáló helyi telepítésére kerülhet sor, melynek konfigurálása az Active Directory tartományon alapuló zónával automatikusan megtörténik.

Ha például az erdőben első tartományként kiválasztott Active Directory tartomány a pelda.microsoft.com volt, egy, a pelda.microsoft.com DNS-tartománynévben mint gyökérben lévő zóna lesz hozzáadva és beállítva az új tartományvezérlőn futó DNS-kiszolgálóval történő használatra.

Ha nem telepíti a Windows 2000 rendszerrel forgalomba kerülő DNS-kiszolgálót, az Active Directory telepítése során egy olyan fájl (Netlogon.dns) íródik és jön létre, amely tartalmazza az Active Directory támogatásához szükséges SRV és más erőforrásrekordokat. Ez a fájl a %Rendszergyökér%\System32\Config mappában jön létre.

Ha olyan DNS-kiszolgálót használ, amelyre illik a következő leírások egyike, az Active Directory támogatásához a Netlogon.dns fájlban lévő erőforrásrekordok segítségével kézzel kell beállítania az elsődleges zónát a kiszolgálón.

  1. A DNS-kiszolgálót működtető számítógép más platformon (például UNIX) fut és nem képes elfogadni vagy felismerni a dinamikus frissítéseket.
  2. Az ezen a számítógépen lévő DNS-kiszolgáló mérvadó az Active Directory tartomány DNS-tartomány nevének megfelelő elsődleges zónában.
  3. A DNS-kiszolgáló az „A DNS RR specifying the location of services (DNS SRV)” című internetes dokumentumban foglaltak szerint támogatja az SRV erőforrásrekordot, de nem támogatja a dinamikus frissítéseket.

    A Windows NT Server 4.0-s rendszerrel forgalomba hozott DNS-szolgáltatás, ha a rendszer Service Pack 4-es vagy újabb verziójával van frissítve, megfelel e leírásnak.

A jövőben az SRV erőforrásrekord felhasználható a hálózaton lévő más ismert TCP/IP-szolgáltatások regisztrálására és keresésére is, ha az alkalmazások megvalósítják és támogatják azokat a DNS-névlekérdezéseket, amelyeket ez a rekordtípus meghatároz. További tudnivalók az Erőforrásrekordok: SRV című témakörben találhatók.

Más erőforrásrekordok

A Windows 2000 alapú DNS-kiszolgálók más, a legtöbb zónában ritkábban használt erőforrásrekordokat is támogatnak. E további erőforrásrekord-típusok szükség szerint a DNS-konzol segítségével adhatók hozzá. A támogatott erőforrásrekordokkal kapcsolatos további tájékoztató az Erőforrásrekordok című témakörben található.


Zónák delegálása

A DNS lehetőséget biztosít a névterek egy vagy több zónára történő felosztására, amelyek ezután más DNS-kiszolgálókon tárolhatók, azokra eloszthatók vagy replikálhatók. Mielőtt további zónák létrehozásához a DNS-névtér felosztása mellett döntene, vegye figyelembe, hogy új zónák használata a következők miatt lehet indokolt:

  • Ha a DNS-névtér egy részének kezelését a cégen belül más helyre vagy részleghez kell delegálni.
  • Ha egy nagy zónát több kisebb zónára kell osztani a forgalmi terhelés több kiszolgáló közti elosztása, a DNS névhozzárendelési teljesítményének javítása, illetve egy hibatűrőbb DNS-környezet kialakítása érdekében.
  • Ha a névteret ki kell bővíteni több altartomány egyidejű felvételével például egy új leányvállalat vagy hely befogadásához.

Ha a fenti okok valamelyike miatt a zónák delegálása előnyösnek mutatkozik, célszerű lehet a névtér átalakítása további zónák felvételével. A zónák felépítésének megválasztásakor olyan tervet kell létrehozni, amely tükrözi a cég szervezeti felépítését.

A zónák névtéren belül delegálásakor ne feledje, hogy minden egyes létrehozott zónához szükség lesz a többi zónába delegált rekordokra, amelyek az új zóna mérvadó DNS-kiszolgálójára mutatnak. Ez egyaránt szükséges a hitelesítési jogosultság átviteléhez és a más DNS-kiszolgálókra, valamint az új zónában mérvadó új kiszolgálók ügyfeleire történő helyes átirányításhoz.

Amikor szabványos elsődleges zónát először létrehoz, ez egyetlen DNS-kiszolgálón tárolódik olyan szövegfájlban, amely az erőforrásrekordok minden adatát tartalmazza. Ez a kiszolgáló a zóna elsődleges főkiszolgálójaként működik. A zónaadatok más DNS-kiszolgálókra replikálhatók a hibatűrés és a kiszolgáló teljesítményének javítása érdekében.

A zónák felépítésekor számos alapos oka lehet a további DNS-kiszolgálók használatának a zónareplikációhoz. Ezek a következők:

  1. A hozzáadott DNS-kiszolgálók zónaredundanciát biztosítanak, lehetővé téve az ügyfelek számára a zónában lévő DNS-nevek hozzárendelését akkor is, ha a zóna elsődleges kiszolgálója nem válaszol.
  2. A hozzáadott DNS-kiszolgálók úgy helyezhetők el, hogy csökkentsék a DNS-hálózat forgalmát. DNS kiszolgáló hozzáadása egy lassú WAN-kapcsolat másik oldalára például igen hasznos lehet a hálózati forgalom kezelésében és csökkentésében.
  3. A zónához tartozó elsődleges kiszolgáló terhelésének csökkentésére további másodlagos kiszolgálók használhatók.

Példa: altartomány delegálása új zónába

Miként az a következő ábrán látható, mikor egy altartomány (pelda.microsoft.com) számára új zóna jön létre, azt delegálni kell a szülőzónából (microsoft.com).

Példa: a zónadelegálás működése

Ebben a példában az újonnan delegált pelda.microsoft.com altartomány mérvadó DNS-kiszolgálószámítógépe az új zónában lévő származtatott altartomány (ns1.us.pelda.microsoft.com) alapján kapja nevét. Ahhoz, hogy ezt a kiszolgálót az új delegált zónán kívül mások is felismerjék, két erőforrásrekordra van szükség a microsoft.com zónában az új zónába történő delegálás elvégzéséhez.

Ezek az erőforrásrekordok a következők:

  • NS erőforrásrekord a delegálás megvalósítására. Ez a erőforrásrekord annak hirdetésére használatos, hogy az ns1.us.pelda.microsoft.com nevű kiszolgáló a delegált altartomány mérvadó kiszolgálója.
  • A erőforrásrekord (más néven összekapcsoló bejegyzés) az NS erőforrásrekordban megadott kiszolgáló nevének IP-címéhez való hozzárendeléséhez. Az ebben az erőforrásrekordban lévő állomásnévnek az NS erőforrásrekordban lévő delegált DNS-kiszolgálóhoz való hozzárendelése összekötő bejegyzés feloldásaként is ismeretes.

Megjegyzés

  • Ha a zónadelegálás helyesen van konfigurálva, a zónaátirányítás normális működése néha kijátszható, ha a DNS-kiszolgálókonfigurációban egy, a továbbítókat felsoroló listát használ. További tudnivalók a Továbbítók használata című témakörben találhatók.


Értesítési listák beállítása

Létrehozhatók és kezelhetők értesítési listák, amelyek módot adnak a zóna főkiszolgálójának (vagy az elsődleges vagy egy másik másodlagos kiszolgálónak) arra, hogy a zóna módosításakor szétküldje a másodlagos kiszolgálók listáját.

Értesítési lista létrehozásához vagy kezeléséhez használhatja a DNS-konzolt, melynek segítségével IP-címeik alapján kiszolgálók adhatók a zóna értesítési listájához, illetve távolíthatók el onnan. A zóna ilyen listájának létrehozása és kezelése a zónatulajdonságok Értesítés lapján végezhető el. Alapértelmezés szerint az értesítési lista a zóna mérvadó kiszolgálóin alapul a Névkiszolgálók lapon felsoroltak szerint.

Megjegyzések

  • A DNS értesítési szolgáltatásának működésével kapcsolatban további tudnivalókat A DNS értesítési szolgáltatása című témakör tartalmaz.
  • Az értesítési listák beállítására és kezelésére vonatkozó további tájékoztatás a Zóna értesítési listájának létrehozása és kezelése című témakörben található.


A WINS keresés használata

A DNS-szolgáltatás lehetővé teszi a Windows Internet Name Service (WINS) kiszolgálók használatát a DNS-tartomány névterében nem talált nevek megkereséséhez a WINS által kezelt NetBIOS névtér ellenőrzésével.

Ahhoz, hogy a WINS keresés integrációjának használata lehetővé váljék, az erőforrásrekordok (RR) két speciális típusának – WINS és WINS-R – engedélyezésére és a zónához való hozzáadására van szükség. A WINS erőforrásrekord használatával a zónában egyező A (állomás) erőforrásrekordot nem találó DNS-lekérdezések a WINS erőforrásrekordban beállított WINS-kiszolgálókra továbbítódnak. Névlekérdezési zónák esetében a WINS-R erőforrásrekord engedélyezhető és használható hasonlóképpen az in-addr.arpa névtartományban nem megválaszolható névlekérdezések feloldására. További tudnivalókat A WINS keresés integrációja című fejezet tartalmaz.

A WINS keresés használatára jó példa, amikor csak DNS-névhozzárendelést alkalmazó UNIX-ügyfelekből és NetBIOS-névhasználatot igénylő, korábbi verziójú Microsoft-ügyfelekből álló vegyes üzemmódú ügyfélkörnyezetet használ. Ebben a környezetben a WINS keresés módot ad arra, hogy a UNIX alapú DNS-ügyfelek, kiterjesztve a DNS-állomásnévhozzárendelést a WINS kezelésű NetBIOS névtérre, megkereshessék a WINS-ügyfeleket.

A WINS keresés integrációs szolgáltatását csak a Windows alapú DNS-kiszolgálók támogatják. Ha egy zónának állomásul Windows alapú és más DNS-kiszolgálók együttesen szolgálnak, a WINS keresési rekord használatához bármelyik elsődleges zónához be kell jelölnie az Ez a rekord ne replikálódjon jelölőnégyzetet. Ez megakadályozza, hogy a WINS keresési rekord bekerüljön olyan más DNS-kiszolgálókra való zónaletöltésekbe, amelyek nem támogatják vagy nem ismerik fel ezt a rekordot. Ha nem engedélyezi, hogy a WINS keresési rekord használatára csak a helyi kiszolgálón kerüljön sor, akkor adathibák vagy sikertelen zónaletöltések fordulhatnak elő olyan kiszolgálókon, amelyek más, a zónát replikáló DNS-kiszolgálókat futtatnak.

Az alábbi részek a WINS keresés együttműködési szempontjait tárgyalják, és a következőket ismertetik:

  • A gyorsítótárazás élettartamának (TTL) és a keresés időtúllépési értékeinek beállítása a WINS és WINS-R rekordokkal történő használathoz.
  • A WINS és WINS-R erőforrásrekordok formátuma a DNS-szolgáltatás által létrehozott zónafájlokban használva.

WINS keresés – együttműködési szempontok

A WINS keresés általában akkor biztosítja a legjobb és legkiszámíthatóbb eredményt, ha csak Windows alapú DNS-kiszolgálók vannak használatban és közvetlenül csak Windows DNS-kiszolgálókon férhető hozzá. Más DNS-kiszolgálók működése esetén is lehetőség van azonban arra, hogy a WINS keresést mint együttműködési megoldást alkalmazza.

Képzelje el például, hogy egy olyan Windows alapú DNS-kiszolgálót ad hozzá, amely egy új, WINS keresésre képes zónának szolgál állomásul. A zóna létrehozásakor és elnevezésekor használjon olyan, a meglévő DNS-névtérhez hozzáadott altartományt, amely csak a DNS-tartomány névteréhez hozzáadott WINS-specifikus átirányításokhoz használatos.

A pelda.microsoft.com tartományban például létrehozásakor adja a zónának a wins.pelda.microsoft.com nevet. Ezután ezt az új WINS átirányítási zónát gyökérszintű zónaként használhatja bármely, a WINS használatára képes számítógéphez, amelyek neve más hagyományos DNS-zónákban nem találhatók.

A WINS átirányítási zóna használatához az ügyfelek számára meg kell adnia annak tartománynevét (wins.pelda.microsoft.com) egy DNS-utótagkeresési listában. Az utótaglista beállítható egy ügyfélkapcsolat TCP/IP-tulajdonságainak részeként, és vagy kézzel vagy a DHCP segítségével frissíthető. Ameddig a WINS átirányítási zóna neve szerepel a tartomány utótaglistájában, a hagyományos zónák alapján nem hozzárendelhető DNS-nevek is hozzárendelhetők a WINS átirányítási altartomány segítségével.

Normál körülmények között ennek rekurziót kell eredményeznie más DNS-kiszolgálókról olyan Windows alapú DNS-kiszolgálókra, amelyek a WINS használatára képes zónát tartalmazzák. Ha a lekérdezett állomásnevek egyeznek a WINS-adatbázisban talált NetBIOS-számítógépnevekkel, megtörténik a WINS-adatokban hozzárendelt IP-címük hozzárendelése.

Mivel a WINS használatára képes zóna csak WINS kereséshez használatos, nem kell hozzáadni további erőforrásrekordokat.

Ha egy meghatározott altartományt csak WINS kereséshez használ, és a nevek hozzárendeléséhez és kereséséhez statikus DNS-utótaglistát ad meg, megelőzheti az olyan szokatlan helyzeteket, amikor a különböző teljesen minősített tartománynevek DNS-lekérdezéseinek hozzárendelése ugyanahhoz a WINS-ügyfélnévhez és IP-címhez történik. Ez könnyen előfordulhat, ha a névtér minden egyes szintjéhez sok zónát ad hozzá és állít be, valamint mindegyiknél engedélyezi a WINS keresés integrációjának használatát.

Képzelje el például, hogy két WINS keresésre beállított zónával rendelkezik. A zónák a következő DNS-tartománynevekből erednek:

pelda1.microsoft.com.
pelda2.microsoft.com.

Ennél a beállításnál egy ALLOMAS-A nevű WINS-ügyfél akaratlanul is hozzárendelhető a következő teljesen minősített tartománynevek valamelyikével:

allomas-a.pelda1.microsoft.com.
allomas-a.pelda2.microsoft.com.

WINS erőforrásrekord

Leírás: WINS címlekérdezési erőforrásrekord. A zónában nem található nevek DNS-lekérdezéseinek további hozzárendelésére szolgál az e rekorddal beállított és felsorolt WINS-kiszolgálók névlekérdezésével. Használata esetén a WINS rekord csak a zóna legfelső szintjére érvényes, a zónában használt altartományokra nem. A WINS erőforrásrekord megadásakor használt különféle mezők a következők:
  • tulajdonos A rekord tulajdonostartományát jelzi és beállítása mindig „@”, ami azt mutatja, hogy az aktuális tartomány ugyanaz, mint a zónakezdet.
  • osztály A rekord osztályát jelzi és beállítása mindig „IN”, mivel a Windows 2000 DNS-kiszolgálók számára az Internet osztály az egyetlen támogatott osztály.
  • LOCAL Használatakor azt jelzi, hogy a WINS erőforrásrekord csak helyileg használandó a DNS-kiszolgálón, más DNS-kiszolgálókkal való zónareplikációban nem vesz részt. Ez a mező megfelel annak a beállításnak, amit a DNS-konzolon a WINS keresés beállításakor A beállítások csak a helyi kiszolgálót érintik jelölőnégyzetnél választott. Ha a jelölőnégyzetet üresen hagyta, ez a mező nem kerül be a rekordba, amikor az a zónába íródik.
  • keresési_időtúllépés Az erre a rekordra alkalmazandó keresési időtúllépés. További tájékoztatást A WINS keresések speciális paraméterei című részben talál.
  • gyorsítótár_időtúllépése A gyorsítótárnak az erre a rekordra alkalmazandó időtúllépése. További tájékoztatást A WINS keresések speciális paraméterei című részben talál.
  • wins_ip_címek A WINS-kiszolgálók egy vagy több IP-címének megadására használatos. Egy érvényes WINS-kiszolgáló legalább egy IP-címe szükséges.
Szintaxis: tulajdonos osztály WINS [LOCAL] [L<keresési_időtúllépés>] [C<gyorsítótár_időtúllépése>] <wins_ip_címek>
Példa:
@ IN       WINS  10.0.0.1

@ IN       WINS LOCAL L1 C10 10.10.10.1 10.10.10.2 10.10.10.3
Megjegyzés: A például szolgáló WINS rekordokban a zónagyökeret az aktuális eredetnek tekintettük.

WINS-R erőforrásrekord

Leírás: WINS névlekérdezési erőforrásrekord. Névlekérdezési zónában használatos a zónában nem talált névlekérdezések további hozzárendeléséhez a lekérdezett IP-címek WINS-ben történő NetBIOS alapú csatolócsomópontos állapotlekérdezés használatával. Használatakor meg kell adni azt a szülőtartományt, amelyet a program majd a NetBIOS-számítógépnévhez fűz, ha a névlekérdezési zónában lévő IP-cím esetében sikeres WINS névlekérdezés történik. A WINS-R rekordban használt többi mező leírása és célja hasonló a WINS címlekérdezési rekordban használt, korábban leírt mezőké.
Szintaxis: tulajdonos osztály WINS [LOCAL] [L<keresési_időtúllépés>] [C<gyorsítótár_időtúllépése>] a_visszaadott_NetBIOS_nevekhez_hozzáfűzendő_tartomány
Példa:
@ IN       WINS-R LOCAL L1 C10 pelda.microsoft.com.

@ IN       WINS-R wins.pelda.microsoft.com.
Megjegyzés: A például szolgáló WINS-R rekordokban a zónagyökeret az aktuális eredetnek tekintettük.

A WINS keresések speciális paraméterei

A WINS és a WINS-R rekordoknál a következő speciális időzítési paraméterek használatosak:

  • A Gyorsítótár időtúllépése érték, amely a DNS-kiszolgáló számára jelzi, hogy a WINS keresés során visszakapott információt meddig őrizze meg a gyorsítótárban. Az alapértelmezett érték 15 perc.
  • A Keresési időtúllépés értéke, amely meghatározza, hogy a DNS-kiszolgálószolgáltatás által végzett WINS keresés időtúllépése és lejárta előtt mennyi idő teljen el. Az alapértelmezett érték 2 perc.

A paramétereket úgy állíthatja be, ha a zóna tulajdonságait megjelenítő párbeszédpanelen lévő Speciális gombra kattint, amikor a zónát telepíti. Ez a gomb vagy a WINS vagy a WINS-R lapon jelenik meg attól függően, hogy a beállítandó zónát cím- vagy névlekérdezésre használja-e.

Ha akár WINS, akár WINS-R erőforrásrekordot használ, vegye figyelembe, hogy a zóna SOA rekordjában beállított minimális élettartam (TTL) nem a rekordokhoz használt alapértelmezett élettartam. Ehelyett amikor a WINS keresés során akár egy IP-cím, akár egy állomásnév hozzárendelése megtörténik, az információt a DNS-kiszolgáló a WINS lapon beállított gyorsítótár időtúllépése értékének időtartamáig őrzi a gyorsítótárban. Ha ezután e cím másik DNS-kiszolgálóra továbbítódik, a ugyanezt a gyorsítótár időtúllépésére vonatkozó TTL értéket küldi el a program. Ha a WINS-adatok ritkán változnak, 15 percre növelhető az alapértelmezett élettartam.

Megjegyzések

  • Ha WINS keresésre beállított zónával rendelkezik, akkor a zóna összes mérvadó DNS-kiszolgálójának képesnek kell lennie WINS keresésre, ellenkező esetben a rendszer működése akadozó lesz.
  • Mivel megválaszthatja, hogy a WINS és WINS-R erőforrásrekordok más DNS-kiszolgálókra ne replikálódjanak, külön-külön engedélyezheti és beállíthatja a WINS keresést a zóna mindegyik másodlagos kiszolgálóján, ahol ezt a szolgáltatást igénybe veszi. Ez nem szabványos gyakorlat olyan más típusú erőforrásrekordoknál, amelyeket csak a zóna elsődleges kiszolgálójánál kell beállítani.


Névlekérdezési zónák kezelése

Névlekérdezési zónák hozzáadásakor a következőkkel egyszerűsítheti a PTR rekordok zónákhoz történő hozzáadásának műveletét:

  • A Társított mutatórekord (PTR) frissítése jelölőnégyzet bejelölésével az A erőforrásrekord névlekérdezési zónákhoz történő kézi hozzáadásakor.
  • Windows 2000 alapú DHCP-kiszolgálók üzembe helyezésével és a DHCP-DNS integrációs szolgáltatások engedélyezésével az örökölt ügyfelek névlekérdezési zónáinak kezeléséhez és frissítéséhez.
  • A cégnél a Windows 2000 Professional szabványos operációs rendszerkénti telepítésével új ügyfélhardver üzembe helyezéséhez.

    Ha az ügyfél-számítógépeken Windows 2000 működik, az ügyfélnek vagy annak Windows 2000 alapú DHCP-kiszolgálójának engedélyezheti a PTR rekord regisztrálását az ügyfél számára IP-címének beszerzésekor és beállításakor.

Alhálózati névlekérdezési zónák

Új névlekérdezési zóna beállításakor a DNS beépülő modul alapértelmezett alhálózati maszkokat feltételez (melyek a maszkolt értékek négy oktettjének mindegyikében 0 vagy 255 értéket használnak). Ha szükséges, egyéni alhálózati kialakítást használhat az alhálózati maszk értékének nem alapértelmezett hosszúságúra állításához.

Az alhálózati névlekérdezési zónák támogatást élveznek a Microsoft Management Console (MMC) és a DNS beépülő modul által elérhető Speciális nézet használatakor. Ez lehetővé teszi a hálózati IP-címekhez olyan névlekérdezések hozzáadását és beállítását, amelynek alhálózati maszkja nem alapértelmezett hosszúságú, például 255.255.248.0, ahol a harmadik oktettben a 248, azaz egy nem alapértelmezett alhálózati érték szerepel.

Az alhálózati névlekérdezési zónák létrehozásának érvényes eljárásaira vonatkozó tudnivalókat a Windows 2000 Server Resource Kit tartalmazza.

Megjegyzés

  • Az alhálózati névlekérdezési zónákról további ismertetőt a 2317-es számú RFC-dokumentum tartalmaz, melynek címe „Classless IN-ADDR.ARPA delegation” (Osztály nélküli IN-ADDR.ARPA delegálás). Az RFC-kel és beszerzésükkel kapcsolatos további információ A TCP/IP protokollal kapcsolatos RFC-dokumentumok című témakörben található.


Kiszolgálók figyelése és optimalizálása

A rész tartalma:

  • A kiszolgálók teljesítményének figyelése
  • A kiszolgáló hibakeresés-naplózásának használata
  • Kiszolgáló beállításainak ellenőrzése
  • Speciális kiszolgálóparaméterek hangolása


A kiszolgálók teljesítményének figyelése

A DNS-kiszolgálók a legtöbb hálózati környezetben rendkívül fontos szerepet töltenek be, ezért teljesítményük figyelése az alábbi előnyökkel jár:

  • A teljesítmény előrejelzéséhez, becsléséhez és optimalizálásához jól használható adatokat biztosít.
  • Segít a hibaelhárításban, ha a kiszolgálók teljesítménye csúcsidőn kívül vagy a túlterheléses időszakokban leromlik.

A DNS-kiszolgáló figyelésének megkezdése előtt megtekintheti azokat a teszteredménymintákat, amelyek a Windows 2000 DNS-kiszolgálókról a fejlesztés és a tesztelés során összegyűltek. Ez az információ a DNS-kiszolgálók figyelésének megkezdésekor kiindulási alapként szolgálhat a teljesítmény méréséhez és értékeléséhez.

A Windows 2000 Server ezenkívül számos teljesítményszámlálót is biztosít a DNS-kiszolgálókhoz, amelyekkel a kiszolgáló tevékenységét a Rendszerfigyelőben különféle szempontok alapján lehet mérni és figyelni.

DNS-kiszolgálók teljesítménytesztjeinek eredménymintái

A DNS fejlesztését és tesztelését végző munkacsoport a Windows 2000 Server előzetes tesztelése során a DNS-kiszolgáló teljesítményprofiljaként statisztikai adatokat állított össze. Két különböző DNS-kiszolgálói hardverkonfigurációt teszteltek, és a teljes DNS-név lekérdezési és dinamikus frissítési tevékenységet, valamint a processzor kihasználtságát mérték.

A tesztek eredményei az alábbi táblázatban láthatók.

Kiszolgálókonfiguráció | Lekérdezés/mp | Dinamikus frissítés/mp | Processzor kihasználtsága
400 MHz-es Intel P-II kétprocesszoros rendszer | 900 | 100 | 30%

A mérési adatok gyűjtése során a megfigyelt DNS-kiszolgáló egyidejűleg mind lekérdezéseket, mind dinamikus frissítéseket feldolgozott. Ez a fenti számokból is látható.

A dinamikus frissítésekhez nem az Active Directoryval integrált, hanem normál, elsődleges típusú zónákat használtak. Az Active Directoryval integrált zónák használata esetén a dinamikus frissítések feldolgozási sebessége csökken, mert a DNS-kiszolgálónak még az Active Directory adatbázisának írásával és olvasásával is foglalkoznia kell.

Ha a zóna beállítása olyan, hogy csak biztonságos dinamikus frissítéseket fogadjon, a frissítés sebessége szintén csökkenhet. Ezekben az esetekben a hálózat teljesítménye is befolyásoló tényező, mivel a frissítések feldolgozásához a címtár adatbázisának szüksége lehet hálózati műveletekre.

A tesztekhez használt kétféle kiszolgálói hardverkonfigurációval kapcsolatban további háttér-információ az alábbi részben található.

Fontos

  • A méréseknek nem az volt a céljuk, hogy a Windows 2000 alapú DNS-kiszolgálók maximális teljesítményét vagy korlátait megmutassák. Sokkal inkább az, hogy egy szabványos hardveren bemutassák a DNS-kiszolgáló tipikus teljesítményét és meghatározzák működési paramétereit, ami egy kiszolgáló kapacitásának megtervezéséhez elegendő kiindulási alapot biztosít.
  • A számok csak közelítő jellegűek, és a zónába bejegyzett erőforrásrekordok típusa, az azonos tulajdonosnévvel rendelkező erőforrásrekordok száma és az adott DNS-kiszolgálón használt zónák száma befolyásolhatja azokat.

Háttér-információ a DNS-kiszolgáló tesztmintával kapcsolatban

A Windows 2000 alapú DNS fejlesztői és tesztelői munkacsoportja az ismertetett teszteléshez az alábbi kiépítésű hardvert használta:

Hardverelemek | Mérőszámok
Processzorok száma | 2
Processzorok típusa | Intel Pentium II 400 MHz
RAM mennyisége | 256 MB (megabájt)
Merevlemez mérete | 4 GB (gigabájt)

A mérések közben a DNS-kiszolgálót futtató kiszolgálón semmilyen más szolgáltatás nem működött. Ha a Windows 2000 DNS-kiszolgálók üzembe helyezése során más hardver- vagy szoftverkonfigurációt alkalmaz, akkor a mért teljesítmény eltérhet az itt dokumentált adatoknál.

A DNS-kiszolgálók kapacitásának megtervezéséről további információ a DNS-kiszolgáló működésének megtervezése című témakörben található.

Teljesítményszámlálók a DNS-kiszolgálókhoz

A Windows 2000 Server számos teljesítményszámlálót is biztosít a DNS-kiszolgálókhoz, amelyekkel a kiszolgáló tevékenységét különféle szempontok alapján lehet mérni és figyelni. Ezek a következők:

  • Átfogó statisztika a DNS-kiszolgáló teljesítményéről, például a DNS-kiszolgáló által feldolgozott lekérdezések és válaszok teljes száma.
  • UDP- (User Datagram protokoll) és TCP- (Transmission Control protokoll) számlálók, amelyek az ezen protokollokat használó DNS-lekérdezések és válaszok számát mérik.
  • A dinamikus frissítések és biztonságos dinamikus frissítések számlálói, amelyek a dinamikus ügyfelek regisztrációs és frissítési tevékenységét mérik.
  • Memóriahasználat-számlálók, amelyek a rendszermemória használatát és a memórialefoglalási mintákat mérik, ha a számítógép Windows 2000 alapú DNS-kiszolgálóként működik.
  • Rekurzív keresések számlálói, amelyek a lekérdezések és válaszok számát mérik, amikor a DNS kiszolgálói szolgáltatása az ügyfelek nevében rekurziót alkalmaz a DNS-nevek keresésére és teljes hozzárendelésére.
  • WINS keresések számlálói, amelyek a WINS-kiszolgálóknak küldött lekérdezések és a kapott válaszok számát mérik, ha a DNS kiszolgálói szolgáltatásának integrált WINS keresési szolgáltatásait használja.
  • Zónaletöltés-számlálók a következő műveletek méréséhez: teljes zónaletöltés (AXFR), növekményes zónaletöltés (IXFR) és értesítés a DNS-zóna frissítéséről.

A DNS-kiszolgálók teljesítményszámlálóinak részletes leírása a következő részekben található.

Átfogó zónaletöltési (AXFR) számlálók

Mező | Leírás
Fogadott AXFR kérelmek | A zóna főkiszolgálójaként működő DNS-kiszolgálószolgáltatás által fogadott teljes zónaletöltési kérelmek száma összesen.
Elküldött AXFR kérelmek | A zóna másodlagos kiszolgálójaként működő DNS-kiszolgálószolgáltatás által küldött teljes zónaletöltési kérelmek száma összesen.
Fogadott AXFR válaszok | A zóna másodlagos kiszolgálójaként működő DNS-kiszolgálószolgáltatás által fogadott teljes zónaletöltési kérelmek száma összesen.
Sikeres AXFR fogadások | A zóna másodlagos kiszolgálójaként működő DNS-kiszolgálószolgáltatás által fogadott teljes zónaletöltések száma összesen.
Sikeres AXFR küldések | A zóna főkiszolgálójaként működő DNS-kiszolgálószolgáltatás által sikeresen küldött teljes zónaletöltések teljes száma.

Memóriahasználat-számlálók a DNS-kiszolgálókon

Mező | Leírás
Gyorsítótár-memória | A DNS-kiszolgálószolgáltatás által a gyorsítótárazáshoz használt rendszermemória teljes mennyisége.
Adatbáziscsomópont-memória | A DNS-kiszolgálószolgáltatás által az adatbázis csomópontokhoz használt rendszermemória teljes mennyisége.
Nbtstat-memória | A DNS-kiszolgálószolgáltatás által az Nbtstat számára fenntartott rendszermemória teljes mennyisége.
Adatfolyam-rögzítési memória | A DNS-kiszolgálószolgáltatás által az adatfolyam-rögzítés számára fenntartott rendszermemória teljes mennyisége.

A dinamikus frissítések számlálói

Mező | Leírás
Művelet nélküli dinamikus frissítések | A DNS-kiszolgáló által fogadott működés nélküli/üres dinamikus frissítési kérelmek.
Művelet nélküli dinamikus frissítések/mp | A DNS-kiszolgáló által másodpercenként fogadott működés nélküli/üres dinamikus frissítési kérelmek átlagos száma.
Várakozási sorba állított dinamikus frissítések | A DNS-kiszolgáló által várakozási sorba helyezett dinamikus frissítések száma összesen.
Fogadott dinamikus frissítés | A DNS-kiszolgáló által fogadott dinamikus frissítési kérelmek száma összesen.
Fogadott dinamikus frissítések/mp | A DNS-kiszolgáló által másodpercenként fogadott dinamikus frissítési kérelmek átlagos száma.
Visszautasított dinamikus frissítések | A DNS-kiszolgáló által visszautasított dinamikus frissítések száma összesen.
Dinamikus frissítési időtúllépések | A DNS-kiszolgáló dinamikus frissítési időtúllépéseinek száma összesen.
Adatbázisba írt dinamikus frissítések | A DNS-kiszolgáló által az adatbázisba bejegyzett dinamikus frissítések teljes száma.
Adatbázisba írt dinamikus frissítések/mp | A DNS-kiszolgáló által az adatbázisba másodpercenként bejegyzett dinamikus frissítések átlagos száma.

Növekményes zónaletöltési (IXFR) számlálók

Mező | Leírás
Fogadott IXFR kérelmek | A fő DNS-kiszolgáló által fogadott növekményes zónaletöltési kérelmek száma összesen.
Elküldött IXFR kérelmek | A másodlagos DNS-kiszolgáló által küldött növekményes zónaletöltési kérelmek száma összesen.
Fogadott IXFR válaszok | A másodlagos DNS-kiszolgáló által fogadott növekményes zónaletöltési válaszok száma összesen.
Sikeres IXFR fogadások | A másodlagos DNS-kiszolgáló által fogadott sikeres növekményes zónaletöltések száma összesen.
Sikeres IXFR küldések | A fő DNS-kiszolgáló sikeres növekményes zónaletöltéseinek száma összesen.
Sikeres IXFR TCP fogadások | A másodlagos DNS-kiszolgáló által fogadott sikeres növekményes TCP alapú zónaletöltések száma összesen.
Sikeres IXFR UDP fogadások | A másodlagos DNS-kiszolgáló által fogadott sikeres növekményes UDP alapú zónaletöltések száma összesen.

Értesítésszámlálók

Mező | Leírás
Fogadott értesítések | A másodlagos DNS-kiszolgáló által fogadott értesítések száma összesen.
Küldött értesítés | A fő DNS-kiszolgáló által küldött értesítések száma összesen.

A rekurzív lekérdezések számlálói

Mező | Leírás
Rekurzív lekérdezések | A DNS-kiszolgáló által fogadott rekurzív lekérdezések száma összesen.
Rekurzív lekérdezések/mp | A DNS-kiszolgáló által másodpercenként fogadott rekurzív lekérdezések átlagos száma.
Rekurzív lekérdezési hiba | A sikertelen rekurzív lekérdezések száma összesen.
Rekurzív lekérdezési hiba/mp | A másodpercenkénti sikertelen rekurzív lekérdezések átlagos száma.
Rekurzív időtúllépések | Az időtúllépések teljes száma rekurzív lekérdezések küldésekor.
Rekurzív időtúllépések/mp | A rekurzív lekérdezések küldésekor fellépő időtúllépések átlagos száma másodpercenként.

A biztonságos dinamikus frissítések számlálói

Mező | Leírás
Sikertelen biztonságos frissítések | A DNS-kiszolgálón sikertelenül végződött biztonságos frissítések száma összesen.
Fogadott biztonságos frissítések | A DNS-kiszolgáló által fogadott biztonságos frissítési kérelmek száma összesen.
Fogadott biztonságos frissítések/mp | A DNS-kiszolgáló által másodpercenként fogadott biztonságos frissítési kérelmek átlagos száma.

TCP-számlálók

Mező | Leírás
TCP üzenetmemória | A DNS-kiszolgáló által használt teljes TCP-üzenetmemória
Beérkezett TCP-lekérdezések | A DNS-kiszolgáló által fogadott TCP-lekérdezések száma összesen.
Beérkezett TCP-lekérdezések/mp | A DNS-kiszolgáló által másodpercenként fogadott TCP-lekérdezések átlagos száma.
Küldött TCP-válaszok | A DNS-kiszolgáló által küldött TCP-válaszok száma összesen.
Küldött TCP-válaszok/mp | A DNS-kiszolgáló által másodpercenként küldött TCP-válaszok átlagos száma.

Összesítés (átfogó teljesítmény) számlálók

Mező | Leírás
Beérkezett lekérdezések összesen | A DNS-kiszolgáló által fogadott lekérdezések száma összesen.
Beérkezett lekérdezések összesen/mp | A DNS-kiszolgáló által másodpercenként fogadott lekérdezések átlagos száma.
Küldött válaszok összesen | A DNS-kiszolgáló által küldött válaszok száma összesen.
Küldött válaszok összesen/mp | A DNS-kiszolgáló által másodpercenként küldött válaszok átlagos száma.

UDP-számlálók

Mező | Leírás
UDP üzenetmemória | A DNS-kiszolgáló által használt teljes UDP-üzenetmemória
Beérkezett UDP-lekérdezések | A DNS-kiszolgáló által fogadott UDP-lekérdezések száma összesen.
Beérkezett UDP-lekérdezések/mp | A DNS-kiszolgáló által másodpercenként fogadott UDP-lekérdezések átlagos száma.
Küldött UDP-válaszok | A DNS-kiszolgáló által küldött UDP-válaszok száma összesen.
Küldött UDP-válaszok/mp | A DNS-kiszolgáló által másodpercenként küldött UDP-válaszok átlagos száma.

A WINS keresés számlálói

Mező | Leírás
Fogadott WINS keresések | A kiszolgáló által fogadott WINS-keresési kérelmek száma összesen.
Fogadott WINS keresések/mp | A DNS-kiszolgáló által másodpercenként fogadott WINS-keresési kérelmek átlagos száma.
Elküldött WINS válaszok | A kiszolgáló által küldött WINS-keresési válaszok száma összesen.
Elküldött WINS válaszok/mp | A kiszolgáló által másodpercenként küldött WINS-keresési válaszok átlagos száma.
Fogadott WINS névkeresések | A kiszolgáló által fogadott WINS-névkeresési kérelmek száma összesen.
Fogadott WINS névkeresések/mp | A kiszolgáló által másodpercenként fogadott WINS-névkeresési kérelmek átlagos száma.
Elküldött WINS névkeresési válaszok | A kiszolgáló által küldött WINS-névkeresési válaszok száma összesen.
Elküldött WINS névkeresési válaszok/mp | A kiszolgáló által másodpercenként küldött WINS-névkeresési válaszok átlagos száma.

Zónaletöltés-számlálók

Mező | Leírás
Sikertelen zónaletöltések | A fő DNS-kiszolgáló sikertelen zónaletöltéseinek száma összesen.
Fogadott zónaletöltési kérelmek | A fő DNS-kiszolgáló által fogadott zónaletöltési kérelmek száma összesen.
Elküldött zónaletöltési SOA kérelmek | A másodlagos kiszolgáló által küldött zónaletöltési SOA kérelmek száma összesen.
Sikeres zónaletöltések | A fő DNS-kiszolgáló sikeres zónaletöltéseinek száma összesen.


A kiszolgáló hibakeresés-naplózásának használata

A Windows 2000 alapú DNS-kiszolgálók esetében a következő hibakeresés-naplózási lehetőségek állnak rendelkezésre:

  • Lekérdezés Az ügyfelektől a DNS-kiszolgálószolgáltatáshoz érkezett lekérdezések naplózása.
  • Értesítés Azoknak az értesítéseknek a naplózása, amelyeket a DNS-kiszolgálószolgáltatás más kiszolgálóktól kapott.
  • Frissítés Azoknak a dinamikus frissítéseknek a naplózása, amelyeket a DNS-kiszolgálószolgáltatás más számítógépektől kapott.
  • Kérdések A DNS-kiszolgálószolgáltatás által feldolgozott DNS-lekérdezési üzenetekben lévő kérdés rész naplózása.
  • Válaszok A DNS-kiszolgálószolgáltatás által feldolgozott DNS-lekérdezési üzenetekben lévő válasz rész naplózása.
  • Küldés A DNS-kiszolgálószolgáltatás által elküldött DNS-lekérdezési üzenetek számának naplózása.
  • Fogadás A DNS-kiszolgálószolgáltatás által fogadott DNS-lekérdezési üzenetek számának naplózása.
  • UDP A DNS-kiszolgálószolgáltatás által UDP-porton fogadott DNS-lekérdezések számának naplózása.
  • TCP A DNS-kiszolgálószolgáltatás által TCP-porton fogadott DNS-lekérdezések számának naplózása.
  • Teljes csomagok A DNS-kiszolgálószolgáltatás által írt és elküldött teljes csomagok számának naplózása.
  • Párhuzamos írás A DNS-kiszolgáló által azonnal párhuzamosan írt és a zónába visszajuttatott csomagok számának naplózása.

Alapértelmezés szerint a hibakeresési naplózás összes beállítása le van tiltva. A beállítások szelektív engedélyezése révén a DNS-kiszolgáló a kiválasztott eseményeket vagy üzeneteket nyomon követési szinten naplózhatja a kiszolgáló általános hibaelhárítása vagy hibáinak megkeresése céljából.

A hibakeresési naplózás erőforrásigénye nagy, csökkenti a kiszolgáló teljesítményét és sok merevlemez-területet igényel, ezért csak ideiglenes jelleggel célszerű alkalmazni, amikor a kiszolgáló teljesítményéről részletes információra van szükség.

Megjegyzések

  • A hibakeresési napló a Dns.log fájlban található, amely a windows_könyvtár\System32\Dns mappában található.
  • A fájlban vezetett nyomon követés engedélyezéséről és használatáról a DNS-kiszolgáló hibanaplózási beállításainak megadása és engedélyezése című témakörben olvashat bővebben.


Kiszolgáló beállításának ellenőrzése

A DNS-konzol segítségével akár kézileg, akár automatikusan ellenőrző teszteket kezdeményezhet annak figyelésére, hogy a DNS-kiszolgálók fel tudják-e dolgozni és a lekérdezéseket, illetve hogy végre tudják-e hajtani a hozzárendeléseket. Ehhez a DNS-kiszolgáló Tulajdonságok lapján kattintson a Figyelés fülre.

E funkción belül kétféle teszt közül választhat:

  1. A DNS-kiszolgáló egyszerű lekérdezése

    Ez a teszttípus azt határozza meg, hogy a DNS-kiszolgáló egyszeres vagy ismételt lekérdezést hajtson-e végre. Ez a teszt helyi lekérdezés, amely során a kiszolgáló-számítógépen lévő DNS-névfeloldó (ügyfél) lekérdezi az ugyanezen a számítógépen futó helyi DNS-kiszolgálót.

    További információ Az iteráció működése című témakörben található.

  2. Más DNS-kiszolgálók rekurzív lekérdezése

    Ez a teszttípus azt határozza meg, hogy a DNS-kiszolgáló rekurzív lekérdezést hajtson végre. Ennél a tesztnél a lekérdezés feldolgozásának első része annyiban hasonlít az előző teszthez, hogy a helyi DNS-névfeloldó (ügyfél) itt is az azonos számítógépen futó helyi DNS-kiszolgálót kérdezi le.

    A különbség az, hogy az ügyfél azt kéri a kiszolgálótól, hogy alkalmazzon rekurziót a DNS-tartománynévtérfa egyetlen ponttal megadott („.”) gyökerének NS típusú lekérdezéséhez. Az ilyen típusú lekérdezésnél általában további rekurzív feldolgozásra van szükség, amivel ellenőrizni lehet, hogy a kiszolgáló gyökérútmutatója vagy a zónadelegálások helyesen vannak-e beállítva.

    További információ A DNS-lekérdezés működése című témakörben található.

Miután kiválasztotta a végrehajtani kívánt teszteket, azokat a Teszt most gombra kattintva manuálisan azonnal elindíthatja, vagy megadhatja, hogy a program időközönként automatikus tesztelést hajtson végre.

Ha az Automatikus teszt végrehajtása a következő időközönként jelölőnégyzetet bejelöli, akkor az automatikus tesztek periodikusan a Tesztelési időköz mezőben megadott gyakorisággal hajtódnak végre.

Az összes kijelölt teszt eredménye, függetlenül attól, hogy végrehajtásuk kézileg vagy automatikusan történt-e, megtekinthető a Teszteredmények listamezőben. A lista általában a következő információt tartalmazza:

  • Az egyes lekérdezések dátuma és időpontja.
  • Az adott teszttel kapcsolatos további állapotinformáció, például hogy az egyszeres vagy rekurzív lekérdezés sikeres vagy sikertelen volt-e.


Speciális kiszolgálóparaméterek hangolása

Szolgáltatáshoz történő inicializálásakor a Windows 2000 alapú DNS-kiszolgálók konfigurációs beállításaikat egy rendszerindító fájlban megadott paraméterekből, a Windows 2000 rendszerleíró adatbázisából vagy az Active Directory integrációján keresztül szolgáltatott alapértelmezésekből veszik.

A telepítéskor létrejövő alapértelmezett beállítások a legtöbb esetben megfelelnek, további módosításukra nincs szükség. Különleges üzembe helyezési igények vagy helyzetek esetén azonban a DNS-konzol segítségével az alábbi speciális paramétereket hangolhatja.

A beállítások elvégzéséhez a DNS-kiszolgáló Tulajdonságok paneljén lévő Speciális lapot használja.

Érték | Leírás
Rekurzió tiltása | Meghatározza, hogy a DNS-kiszolgáló használ-e rekurziót. Alapértelmezés szerint a Windows 2000 alapú DNS-kiszolgálókon a rekurzió használata engedélyezett. További tudnivalók a Rekurzió tiltása című témakörben találhatók.
BIND másodlagosak Meghatározza, hogy örökölt BIND (Berkeley Internet Name Domain) rendszerű kiszolgálókon lévő DNS-kiszolgálóra történő zónaletöltéskor használható-e gyors átviteli formátum.

Alapértelmezés szerint minden Windows alapú DNS-kiszolgáló gyorsított zónaletöltési formátumot használ. Ez a formátum tömörített, és a letöltés során TCP-üzenetenként több rekordot is tartalmazhat. Ez a formátum kompatibilis az újabb BIND rendszerű, 4.9.4 vagy magasabb verziószámú DNS-kiszolgálókkal is.

További információ a Zónaletöltés BIND- és egyéb DNS-kiszolgálókkal című témakörben található.
Rossz zónaadat esetén hiba a betöltéskor Beállítása esetén a DNS-kiszolgáló szigorúan elemzi a fájlokat.

Alapértelmezés szerint a Windows 2000 alapú DNS-kiszolgálók naplózzák az adathibákat, kihagyják a zónafájl hibás adatait, és folytatják a zóna betöltését. Ezt a beállítást a DNS-konzol segítségével úgy módosíthatja, hogy a DNS-kiszolgálószolgáltatás a hibák naplózása után ne töltse be a hibás rekordadatokat tartalmazó zónafájlt.

További információ A nevek és a zónaadatok ellenőrzése című témakörben található.
Ciklikus multiplexelés engedélyezése Meghatározza, hogy a DNS-kiszolgáló használjon-e ciklikus multiplexelést az A (állomás) erőforrásrekordok váltogatására és újrarendezésére, ha e lekérdezett állomás neve egy több IP-címmel rendelkező számítógépre vonatkozik.

Alapértelmezés szerint a Windows 2000 alapú DNS-kiszolgálók használnak ciklikus multiplexelést. További információ A ciklikus multiplexelés beállítása című témakörben található.
Hálózati maszk szerinti rendezés engedélyezése Meghatározza, hogy a DNS-kiszolgáló újrarendezze-e a több A erőforrásrekordot tartalmazó listát a helyi alhálózatok prioritása alapján, ha a lekérdezett állomásnév többhelyű számítógépre utal.

Alapértelmezés szerint a Windows 2000 alapú DNS-kiszolgálók alkalmazzák a helyi alhálózati prioritást. További információ a Helyi alhálózatok prioritási sorrendbe állítása című témakörben található.
A gyorsítótár szennyezés elleni védelme Meghatározza, hogy a gyorsítótár szennyeződésének megakadályozása érdekében a kiszolgáló megpróbálja-e a válaszok törlését.

Alapértelmezés szerint a Windows 2000 alapú DNS-kiszolgálók egy, a biztonságos válaszra vonatkozó beállítás van érvényben, amelynek hatására az átirányítási válaszokban levő, nem kapcsolódó erőforrásrekordok nem kerülnek be a gyorsítótárba. Az átirányítási válaszokban szereplő nevek általában bekerülnek a gyorsítótárba, ami a további DNS-lekérdezések hozzárendelését gyorsabbá teszi.

E szolgáltatás segítségével azonban a kiszolgáló megállapíthatja, hogy az átirányított nevek nagy valószínűséggel szennyezettek vagy nem biztonságosak és törölheti őket. Azt, hogy egy átirányításban szereplő nevet elhelyezzen-e a gyorsítótárba, a kiszolgáló annak alapján dönti el, hogy a név az eredeti lekérdezésnek pontosan megfelelő DNS-tartománynévfa részét képezi-e.

Ha a gyorsítótár védelme engedélyezve van, és az eredeti lekérdezés például a „pelda.microsoft.com” névre vonatkozott, az átirányítási válasz azonban a „microsoft.com” tartománynévfán kívüli nevet tartalmazott, például az msn.com nevet, akkor az nem kerül a gyorsítótárba.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. A rendszerleíró adatbázis módosítása előtt készítsen biztonsági másolatot a számítógépen található fontos adatokról.

Megjegyzések

  • Az említett vagy más kiszolgálói paramétereknek a DNS-konzollal történő konfigurálásakor a beállítások egy részét módosíthatja, illetve bizonyos esetekben a rendszer működését dinamikusan megváltoztathatja anélkül, hogy a DNS-kiszolgálót újra kellene indítania.
  • A Windows 2000 Server további speciális paramétereit a rendszerleíró adatbázisban lehet konfigurálni. További tájékoztatás a Windows 2000 Server Resource Kit csomagban található.
  • A DNS-kiszolgáló paramétereire vonatkozó kulcsok értékeit a Windows 2000 rendszerleíró adatbázisa tartalmazza. Mindegyik érték a következő helyen található:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\DNS\Parameters

  • A rendszerleíró adatbázisban végzett konfigurálás esetén a változások csak a szolgáltatás legközelebbi inicializálásakor lépnek érvénybe. Ha tehát egy adott értéket manuálisan, közvetlenül a rendszerleíró adatbázisban változtatott meg, akkor az új érték használatához a DNS-kiszolgálót minden esetben újra kell indítani.

    További információ a DNS kiszolgáló elindítása és leállítása című témakörben található.


A kiszolgáló speciális beállításai

A rész tartalma:

  • Gyökérútmutatók frissítése
  • Továbbítók használata
  • Többhelyű kiszolgálók konfigurálása
  • A nevek és a zónaadatok ellenőrzése
  • A kiszolgáló alapértelmezett beállításainak megváltoztatása
  • A ciklikus multiplexelés beállítása
  • Helyi alhálózatok prioritási sorrendbe állítása
  • A kiszolgáló felügyeletének automatizálása a Dnscmd paranccsal


Gyökérútmutatók frissítése

A gyökérútmutató arra szolgál, hogy a nem gyökérzónák mérvadó kiszolgálóit felkészítse arra, hogy felismerjék és felderítsék azokat a mérvadó kiszolgálókat, amelyek a DNS-névtérfa magasabb szintjein vagy más részfáiban található tartományokat kezelnek. Ez az útmutató az ilyen kiszolgálók megtalálásához a névtér alacsonyabb szintjein mérvadó kiszolgálók számára nélkülözhetetlen.

Képzelje el például, hogy egy DNS-kiszolgáló (A kiszolgáló) rendelkezik egy zónával, amelynek neve sub.pelda.microsoft.com. Ha egy magasabb szintű tartományra, például a microsoft.com tartományra vonatkozó lekérdezést kap, szüksége van segítségre, hogy ehhez a tartományhoz mérvadó kiszolgálót találjon (például a B kiszolgálót).

Annak érdekében, hogy az A kiszolgáló megtalálhassa a B kiszolgálót, vagy bármely más olyan kiszolgálót, amely mérvadó a microsoft.com tartományban, le kell tudnia kérdezni a DNS-névtér gyökérkiszolgálóit. A gyökérkiszolgálók azután az A kiszolgálót a com tartomány mérvadó kiszolgálóihoz irányítják. A com tartomány kiszolgálói viszont felajánlhatják a B kiszolgálóhoz vagy más, a microsoft.com tartományban mérvadó kiszolgálókhoz történő átirányítást.

Az A kiszolgáló által használt gyökérútmutatónak használható javaslatokkal kell szolgálnia a gyökérkiszolgálókkal kapcsolatban ahhoz, hogy a B kiszolgálót (vagy más mérvadó kiszolgálót) meg lehessen találni.

A gyökérútmutató helyes beállításához és használatához először meg kell vizsgálnia, hogy saját DNS-kiszolgálóira miként érvényesek a következők:

  • A DNS szolgáltatást az Interneten vagy egy magánhálózatban használja?
  • A kiszolgáló gyökérkiszolgálóként működik?

Alapértelmezés szerint a DNS-szolgáltatás a gyökérútmutatót a kiszolgáló-számítógép %Rendszergyökér%\System32\Dns mappájában található Cache.dns fájl alapján valósítja meg. Ez a fájl rendszerint az Internet gyökérkiszolgálók NS és A erőforrásrekordjait tartalmazza. Ha azonban a DNS-szolgáltatást magánhálózatban használja, akkor a fájl rekordjait a saját belső DNS-gyökérkiszolgálókra mutató, hasonló rekordokkal helyettesítheti.

A gyökérútmutató eltérő kezelésére példa egy olyan másféle kiszolgáló-konfiguráció, amelyben a belső névtér DNS-kiszolgálói egy DNS-kiszolgálót továbbítóként használnak a külső kezelésű (például internetes) nevekre vonatkozó DNS-lekérdezésekhez. Még akkor is, ha a továbbítóként működő DNS-kiszolgáló ugyanazon a belső hálózaton található, mint az azt használó kiszolgálók, az internetes gyökérkiszolgálókkal kapcsolatban szüksége van gyökérútmutatóra ahhoz, hogy képes legyen megfelelően működni és a külső nevek hozzárendelését elvégezni.

Megjegyzések

  • Belső gyökérkiszolgálók alkalmazása esetén ne használjon gyökérútmutatót, minden gyökérkiszolgálóhoz tartozó Cache.dns fájlt töröljön le.
  • Ha egy DNS-kiszolgáló úgy van beállítva, hogy más DNS-kiszolgálókat észleljen, például saját TCP/IP-ügyféltulajdonságaiban egy telepített hálózati kapcsolathoz beállított DNS-kiszolgálókat tartalmazó listán keresztül, új kiszolgáló konfigurálásakor ez a DNS-szolgáltatás saját gyökérútmutatóját is össze tudja állítani. Ehhez a DNS-kezelőpulthoz tartozó Új kiszolgáló konfigurálása varázslót használhatja.


Továbbítók használata

A DNS-kiszolgálók beállíthatók úgy, hogy az összes rekurzív lekérdezést a kiszolgálók egy kijelölt csoportjának, a továbbítóknak küldjék. A továbbítók listáján szereplő kiszolgálók rekurzív keresést végeznek azokra a lekérdezésekre, amelyeket egy DNS-kiszolgáló kapott, és helyi zónaadatai alapján nem tudott megválaszolni. A továbbítási folyamatban az a DNS-kiszolgáló, amelyet továbbítók (a továbbítók listája alapján egy vagy több kiszolgáló) használatához állítottak be, a továbbítók szempontjából DNS-ügyfélként viselkedik.

A továbbítók használatának előnyei

Továbbítókat többek között akkor érdemes használni, ha a hozzáférés a távoli DNS-kiszolgálókhoz csak egy lassú kapcsolaton lehetséges, például amikor egy nagysebességű belső hálózat viszonylag lassú kapcsolaton keresztül csatlakozik az Internethez. Ilyenkor a továbbítók alkalmazásával kétféleképpen is mérsékelni lehet a lassú kapcsolatú forgalommal járó magas költséget:

  1. Csökkentse a lassú kapcsolaton küldött lekérdezések számát – ha például az adott DNS-kiszolgáló lassú és drága telefonos kapcsolaton keresztül csatlakozik az Internet-szolgáltatóhoz.

    Amikor a belső hálózatban továbbítóként használt DNS-kiszolgáló egy távoli internetes névre vonatkozó lekérdezést kap, közvetlen kapcsolatot létesíthet az Interneten működő távoli kiszolgálókkal. Mindaddig ismételheti a lekérdezéseket, amíg meg nem állapítja, melyik kiszolgáló mérvadó a névvel kapcsolatban. Miután megtalálta a mérvadó kiszolgálót, a továbbító kapcsolatot létesít vele, és megkapja a teljes választ.

    A forgalom csökkentésének másik módja az, hogy egy, az Interneten lévő DNS-kiszolgálót alkalmaz továbbítóként. Mielőtt e megoldás mellett döntene, engedélyt kell szereznie arra, hogy egy internetes DNS-kiszolgálót, például az adott Internet-szolgáltató által kezelt kiszolgálót, használhasson kijelölt továbbítóként. Ilyen konfiguráció esetén az Internet-szolgáltató DNS-kiszolgálója az összes távoli lekérdezést egyszerre továbbítja, és csak akkor válaszol, ha a teljes válasz a rendelkezésére áll. Minden lekérdezés egyetlen oda-vissza irányú adatforgalmat jelent a lassú kapcsolaton keresztül.

  2. A távoli lekérdezések eredményét ossza meg a helyi hálózaton.

    A továbbítók lehetővé teszik, hogy a távoli nevek lekérdezésének eredményét a körzeten belüli DNS-kiszolgálók egy csoportjával megossza. Példaként képzelje el, hogy a cég egy LAN hálózaton több DNS-kiszolgálóval rendelkezik. Ahelyett, hogy a lekérdezéseket minden kiszolgáló elküldené tűzfalon keresztül az Internetre, az összes DNS-kiszolgáló úgy van beállítva, hogy a lekérdezéseket egyetlen (esetleg a tűzfalnál levő) DNS-kiszolgálóhoz továbbítsák, amely ezeket a lekérdezéseket elküldi a távoli kiszolgálókkal. A folyamat során a továbbító gyorsítótárat épít fel, amelyben a beérkezett válaszokból származó internetes DNS-nevek kapnak helyet. A későbbiek során, ahogy a helyi DNS-kiszolgálók folyamatosan küldik a lekérdezéseket, a továbbító egyre több lekérdezésre már a saját gyorsítótára alapján válaszol, mivel egyre növekszik azon válaszok száma, amelyek az azonos vagy hasonló nevekre vonatkozó korábbi lekérdezésekre érkeztek.

Miként az az alábbi ábrán látható, a továbbítót általában a hálózat és az Internet közötti határon vagy tűzfalban helyezik el. Ez azonban csak egy ajánlott konfiguráció, a továbbítókat nem csak ily módon lehet alkalmazni.

Példa: DNS-továbbítók használata

A továbbítók listájában a felsorolt kiszolgálókat IP-címük azonosítja. A listán szereplő első kiszolgáló az elsődleges, és amely elsősorban a helyi gyorsítótár felépítésére használatos. Általában véve azonban a listán több továbbítót célszerű bejegyezni. A listán szereplő minden egyes kiszolgáló lekérdezésére csak egyszer kerül sor, minden további próbálkozáshoz meg kell ismételni a kiszolgáló IP-címét a listában.

Ha egy DNS-kiszolgáló nincs továbbítók használatához konfigurálva, akkor a szokásos iteratív lekérdezési eljárást alkalmazza a távoli nevek rekurzív lekérdezésének megválaszolására.

A továbbítók kizárólagos használata (rekurzió nélkül)

Ha egy DNS-kiszolgáló továbbítók használatához van beállítva, akkor használatukra minden egyéb névhozzárendelési eszköz előtt kerül sor. Ha a listán szereplő továbbítóktól nem kap pozitív választ, akkor a DNS-kiszolgáló iteratív lekérdezésekkel és szabványos rekurzióval saját maga próbálja meg a lekérdezést hozzárendelni.

Egy kiszolgáló úgy is beállítható, hogy ha a továbbítóktól nem kap választ, ne végezzen rekurziót. Ilyenkor nem küld további rekurzív lekérdezéseket a név hozzárendelése céljából, hanem sikertelen lekérdezést eredményez, ha egyetlen továbbítótól sem kap pozitív választ.

Ez a beállítás arra kényszeríti a DNS-kiszolgálót, hogy névlekérdezéskor a végső névhozzárendeléshez kizárólag saját beállított továbbítóit használja. Ebben az üzemmódban a továbbítók használatára beállított kiszolgáló első lépésként még mindig felhasználhatja saját beállított zónáit a lekérdezett név hozzárendelésére. Ha saját mérvadó adataiban egyezést talál, azok alapján válaszolhat a lekérdezésre.

Ha egy kiszolgáló továbbítók használatára van konfigurálva, e lehetőség alkalmazásához a Továbbítók lapon jelölje be a Rekurzió használata nélkül jelölőnégyzetet.

Megjegyzés

  • Továbbítók használata esetén a kiszolgáló a listán szereplő továbbítóknak sorban elküldi a lekérdezéseket. Ha egy továbbító a listán másodpercben megadott időtúllépési időn belül nem válaszol, akkor a következő továbbítóval próbálkozik.


Többhelyű kiszolgálók konfigurálása

Többhelyű DNS-kiszolgálók esetében a DNS-szolgáltatást beállíthatja úgy is, hogy az csak a DNS-konzolban megadott IP-címeket lássa és csak azokkal hozzon létre kötést. Alapértelmezés szerint a DNS-szolgáltatás a számítógéphez beállított összes IP-illesztővel létrehoz kötést.

Ez a következőket foglalja magába:

  • Egyetlen hálózati kapcsolathoz beállított további IP-címek.
  • Az egyes kapcsolatokhoz beállított egyedi IP-cím, ha a kiszolgáló-számítógépre több hálózati kapcsolat van telepítve.

Többhelyű DNS-kiszolgálók esetében a DNS-szolgáltatást kijelölt IP-címekre korlátozhatja. Ha használja ezt a lehetőséget, akkor a DNS-szolgáltatás csak azokra a DNS-kérelmekre figyel és válaszol, amelyeket a kiszolgáló tulajdonságai Illesztők lapján megadott IP-címekre küldött el.

Mikor érdemes illesztőket megadni?

Alapértelmezés szerint a DNS-szolgáltatás minden IP-címet figyel, és az alapértelmezett szolgáltatásportjára (UDP 53 vagy zónaletöltési kérelmeknél TCP 53) bejövő minden ügyfélkérelmet fogad. Egyes DNS-névfeloldók (többek között a Windows 95 eredeti verziójának ügyfelei) megkövetelik, hogy a DNS-válasz forráscíme megegyezzen a lekérdezésben szereplő célcímmel. Eltérő címek esetén az ügyfél visszautasíthatja a választ. Az ilyen névfeloldók kezeléséhez a DNS-kiszolgáló számára megadhat egy, a megengedett illesztőket tartalmazó listát. Ha van ilyen lista, a DNS-szolgáltatás a szoftvercsatornákat csak a számítógépen megengedett IP-címekhez köti.

Az explicit módon megadott kötéseket igénylő ügyfelek támogatásán túl az IP-címek megadása más okokból is előnyös lehet:

  1. Ha felügyeleti okok miatt egy többhelyű számítógépen bizonyos IP-címeket vagy illesztőket nem kíván használni.
  2. Ha a kiszolgáló számítógépen nagyszámú IP-cím használatára van beállítva, és a rendszer erőforrásait nagyon megterhelné, ha mindegyikkel kötést hozna létre.

A többhelyű DNS-kiszolgálókkal kapcsolatos további szempontok

Ha további IP-címeket konfigurál és engedélyez a Windows 2000 alapú DNS-kiszolgálóhoz, a következőket célszerű szem előtt tartani:

  • Több cím több rendszer-erőforrást igényel a kiszolgáló-számítógépen.
  • A DNS-kiszolgáló teljesítményét befolyásoló terhelés némileg megnövekszik, ami hatással lehet a DNS-lekérdezések fogadására.
  • Bár a Windows 2000 lehetővé teszi, hogy a telepített hálózati csatolókhoz több IP-címet állítson be, ettől nem várható a teljesítmény javulása.
  • Még akkor is, ha a DNS-kiszolgáló több, internetes használathoz regisztrált zónát kezel, az internetes regisztrációhoz nem szükséges és nem kötelező, hogy minden zónához külön IP-címek legyenek regisztrálva.

Ezek alapján:

  • Ne feledje, hogy a DNS-kiszolgáló használatának újabb IP-címekre való kiterjesztésével a kiszolgáló teljesítménye csak kis mértékben javul. Nagyszámú IP-cím esetén a kiszolgáló teljesítménye észrevehetően visszaeshet.
  • Ha a kiszolgáló-számítógépet új hálózati csatolókártyával bővíti, minden hálózati kapcsolathoz csak egy elsődleges IP-címet rendeljen.
  • A kiszolgáló aktuális TCP/IP-beállításaiból lehetőség szerint törölje a nélkülözhető IP-címeket.

Megjegyzés

  • Arról, hogy miként lehet illesztőket megadni a DNS-szolgáltatáshoz, további tudnivalókat A DNS-kiszolgáló által figyelt címek korlátozása című témakörben találhat.


A nevek és a zónaadatok ellenőrzése

A DNS-szolgáltatással az alábbi névellenőrzési módszerek használhatók, illetve a DNS beépülő modullal felügyelhetők.

Módszer | Leírás
Szigorúan RFC (ANSI) | A nevek szigorú ellenőrzése az Internet-állomások elnevezési specifikációival kapcsolatos 1123-as számú RFC útmutatásainak megfelelően.
Nem RFC (ANSI) | Megenged nem szabványos neveket, amelyek nem felelnek meg az Internet-állomások elnevezési specifikációival kapcsolatos 1123-as számú RFC útmutatásainak.
Több bájtos (UTF8) | Megengedi az ASCII szabványtól eltérő karakterek, így az Unicode karakterek használatát is, amelyeket egy oktettnél (8 bitnél) hosszabb kód határoz meg. Ezzel a módszerrel a több bájtos karakterek a Windows 2000 Server UTF8-formátumot (Unicode Transformation Format) támogató szolgáltatásával konvertálhatók és jeleníthetők meg.

Megjegyzés

  • További információt arról, hogy mikor alkalmazzon az alapértelmezettől eltérő névellenőrzést a DNS-szolgáltatásban az Unicode karakterek támogatása című témakörben olvashat.

Hibás zónaadatok ellenőrzése

A DNS-szolgáltatás beállítható úgy, hogy induláskor ellenőrizze, hogy vannak-e hibás vagy ismeretlen zónaadatok. A beállítás engedélyezésével kapcsolatban lásd a Hibás adatokat tartalmazó zóna letöltésének megakadályozása című témakört.

Helyettesítő karakterek használata a DNS-szolgáltatásban

A DNS-szolgáltatásban helyettesítő karakterek használatával több lehetséges DNS-nevet mint célt társíthat egyetlen olyan számítógéppel, amely átjáróként működik minden név számára, amelyre illik a helyettesítő karakteres név. A helyettesítő karakterek használata a DNS-bejegyzésekben leggyakrabban az MX erőforrásrekordoknál fordul elő, amikor például a DNS-ben egy Internet levelezési átjárót konfigurál, amely a levelek útválasztását végzi a magánhálózat és az Internet között.

Alapvető tudnivalók a helyettesítő karakterek DNS-nevekben történő használatáról

Amikor annak eldöntésére kerül sor, hogy hol használjon helyettesítő karaktereket a DNS-szolgáltatásban – például a levelek útválasztásához és továbbításához használt MX erőforrásrekordnál - az alábbi irányelveket kell figyelembe venni:

  • A helyettesítő karakteres nevek jelzésére a csillag karakter (*) van fenntartva.
  • A csillag karakter csak egyszer használható, a DNS-név elején (bal szélén).
  • Alkalmazása esetén a csillag karakternek meg kell hogy feleljen a teljes név elejének egy vagy több címkéje, amelyek után a név nem helyettesítő (pontos) karakterekkel megadott egyértelmű címkéi következnek.
  • A helyettesítő karaktereket nem lehet használni, ha egy egyértelműen megadott név lekérdezésére pontos egyezés található.
  • A helyettesítő karakteres erőforrásrekordok tartalmának meg kell felelniük a DNS rájuk vonatkozó formai és tartalmi szabályainak.

Általában a helyettesítő karakteres megadású neveket csak akkor szokták alkalmazni, ha a lekérdezett név egy ismert tartománynév alá rendelt köztes név. Ebben az esetben a helyettesítő karakteres névhez legközelebbi egyezés lesz felhasználva. Ha például a következő MX erőforrásrekordot használja a pelda.microsoft.com zónában:

*.pelda.microsoft.com. IN MX 10 levelezokiszolgalo1.pelda.microsoft.com

akkor a rekord hatására az alábbi lehetséges DNS-tartománynevekre címzett levelek az MX erőforrásrekordban megadott levelezési útválasztóra (levelezokiszolgalo1.pelda.microsoft.com.) lesznek irányítva:

veszprem.pelda.microsoft.com.
eger.hu.pelda.microsoft.com.
mako.hu.pelda.microsoft.com.

A (*) helyettesítő karakter használata esetén annak meg kell hogy feleljen a DNS-név legalább egy teljes címkéje a név megadott részén kívül.

Például az előző példa MX erőforrásrekordját nem lehet felhasználni a felhasznalo@pelda.microsoft.com címzésű e-mail üzenet célba juttatására. Ahhoz, hogy ezt az elektronikus levelet helyesen lehessen továbbítani, ezt a zónát egy további explicit MX erőforrásrekorddal kell bővíteni, például:

pelda.microsoft.com. IN MX 10 levelezokiszolgalo1.pelda.microsoft.com.

Az RFC szabvány tág alkalmazása a helyettesítő karakteres névmegadásban

A (Service Pack 4 előtti) Windows NT Server 4.0 DNS-szolgáltatása nem felelt meg teljes mértékben annak a módszernek, amelyet az 1034-es számú RFC-dokumentum a helyettesítő karaktereknek a DNS-névkeresésben történő alkalmazására előírt. Ez a helyettesítő karakteres keresést csak akkor fejezte be, amikor a DNS-névtérfában egy olyan csomóponthoz ért, amely a lekérdezésben szereplő típusú erőforrásrekordokkal rendelkezett.

Ha például a pelda.microsoft.com. zónában a következő rekordokat hozta létre:

      *.pelda.microsoft.com.                     IN  MX  10   levelezokiszolgalo1.pelda.microsoft.com.
      pelda.microsoft.com.                       IN  MX  10   levelezokiszolgalo2.pelda.microsoft.com.
      allomas-a.pelda.microsoft.com.             IN  A        10.0.0.1
      levelezoliszolgalo1.pelda.microsoft.com.   IN  A        10.0.0.2
      levelezoliszolgalo2.pelda.microsoft.com.   IN  A        10.0.0.3

és a B állomás az alábbi DNS-lekérdezést küldte:

A lekérdezett név: allomas-a.pelda.microsoft.com.
A lekérdezett típus: MX

ha a tág helyettesítő karakteres névmegadás van érvényben, a DNS-kiszolgáló és a B állomás között a következő események történnek:

  1. A B állomás a példában szereplő lekérdezést elküldi egy DNS-kiszolgálónak, amely az RFC szabványnak megfelelően a helyettesítő karakterek tág alkalmazására van beállítva. Ilyen például egy (Service Pack 4 előtti) Windows NT Server 4.0 rendszeren működő DNS-kiszolgáló.
  2. Egyetlen MX erőforrásrekord sem egyezik a megadott (allomas-a.pelda.microsoft.com.) névvel.
  3. A zónában van egy MX erőforrásrekord – a lekérdezésben megadott típussal – amely olyan helyettesítő karakteres nevet tartalmaz, ami a lekérdezett név szülője (*.pelda.microsoft.com.).
  4. A DNS-szolgáltatás ellenőrzi az helyettesítő karakterrel megadott MX erőforrásrekord-névhez (*.pelda.microsoft.com.) rendelt állomásneveket, talál egy, a megadott névvel egyező A erőforrásrekordot (levelezokiszolgalo1.pelda.microsoft.com.), és ennek megfelelően válaszol a B állomásnak.
  5. A B állomáson működő levelezőprogram ezután már küldhet üzenetet a levelezokiszolgalo1.pelda.microsoft.com. IP-címére.

Az RFC tág alkalmazása lehetővé teszi, hogy mindössze két MX rekord beállításával az egész zónára kiterjedő lekérdezést hajtson végre. A két MX erőforrásrekordot azonban mind a zóna gyökere (a zóna explicit módon megadott neve), mind pedig a közvetlenül ez alatt lévő helyettesítő karakteres (*) csomópont számára hozzá kell adni. Ha azonban egyedi levelezőállomásokkal rendelkezik, amelyek közvetlenül kapnak leveleket, minden ilyen állomás számára adjon hozzá MX erőforrásrekordokat, amelyek közvetlenül hivatkoznak saját állomásnevükre a regisztrált A erőforrásrekordjaikban szereplő módon.

Az RFC szabvány szigorú alkalmazása a helyettesítő karakteres névmegadásban

Az 1034-es számú RFC-dokumentumban leírt szigorú helyettesítő karakteres névmegadás alkalmazása esetén az előbbi példa eseményei módosulnak. Az előbbi zónanevet és lekérdezési információt feltételezve a DNS-szolgáltatás és a B állomás között az események most a következőképpen fognak lejátszódni:

  1. A B állomás elküldi az előző példában szereplő lekérdezést a DNS-kiszolgálónak, amely az RFC-ben szereplő szigorú helyettesítő karakteres névmegadás alkalmazására van beállítva.
  2. Egyetlen MX erőforrásrekord sem felel meg a megadott névnek (allomas-a.pelda.microsoft.com.), de a zónában e néven van egy A erőforrásrekord.

    Mivel megvan a lekérdezett név, a helyettesítő karakterek alkalmazására nem kerül sor.

  3. A DNS-szolgáltatás a lekérdezésre egy mérvadó negatív választ küld, amelyben sem hibák sem erőforrásrekordok nem szerepelnek.
  4. A B állomás levelezőprogramja most egy új lekérdezést küld ugyanerre a névre, a lekérdezett típusként az A erőforrásrekordokat jelöli meg.
  5. A DNS-szolgáltatás a lekérdezésre egy mérvadó pozitív választ küld, amelyben az A erőforrásrekord szerepel.
  6. A B állomáson működő levelezőprogram ezután már küldhet üzenetet a levelezokiszolgalo1.pelda.microsoft.com. IP-címére.

Az RFC szabvány szigorú alkalmazása a helyettesítő karakteres nevekre könnyebb, ha a levelezőállomás közvetlenül kaphat leveleket. E módszernek az a hátránya, hogy általában több MX erőforrásrekorddal kell a zónát bővíteni. Ez akkor fordulhat elő, ha a levelezőállomás nem tud közvetlenül leveleket fogadni, vagy ha olyan levelezőállomások szolgáltatását kell hirdetni, amelyek nem levelezőkiszolgálók.


A kiszolgáló alapértelmezett beállításainak megváltoztatása

A DNS beépülő modul lehetővé teszi, hogy a DNS-kiszolgáló egyes alapértelmezett beállításait módosítsa, például abban az esetben ha azok nem felelnek meg egy adott kiszolgálóhoz. Néhány a konfigurálható, nem alapértelmezés szerinti beállítások közül:

  • Más beállítási módszer választása a kiszolgálószolgáltatás inicializálására.
  • Rekurzió használatának letiltása.

Szolgáltatás inicializálásának módszerei

A DNS-szolgáltatás inicializálására és szolgáltatásainak működtetésére az alábbi módszerek állnak rendelkezésre.

Módszer | Leírás
Rendszerindítás a rendszerleíró adatbázisból | A DNS-kiszolgálószolgáltatást a Windows rendszerleíró adatbázisában tárolt paraméterértékekkel inicializálja.
Rendszerindítás fájlból A DNS-kiszolgálószolgáltatást egy megadható indítófájlból inicializálja, a Berkeley Internet Name Domain (BIND) alapú kiszolgálókon alkalmazott módszer szerint.

Ilyen fájl használatához, másoljon át egy indítófájlt egy másik, BIND rendszerű DNS-kiszolgálóról. A BIND rendszerű DNS-kiszolgálókon a fájl neve általában Named.boot. A fájl a régebbi BIND 4 formátummal rendelkezzen, az újabb BIND 8 fájlformátum nem megfelelő.

E fájl használata esetén az abban tárolt beállítások és direktívák lépnek érvénybe a DNS-kiszolgáló rendszerleíró adatbázisában tárolt beállítások helyett. Azokat a paramétereket, amelyek az indítófájlok direktíváin keresztül nem állíthatók be, a DNS-kiszolgálószolgáltatás a rendszerleíró adatbázis alapértelmezett (vagy tárolt módosított) beállításaiból veszi.

Rendszerindítás címtárszolgáltatás és a rendszerleíró adatbázis alapján | A DNS-kiszolgálószolgáltatást az Active Directory adatbázisában és a kiszolgáló rendszerleíró adatbázisában tárolt paraméterek alapján inicializálja. A Windows 2000 alapú DNS-kiszolgálóknál ez az alapértelmezett rendszerindítási mód.

Megjegyzések

  • A DNS-szolgáltatás inicializálásakor alkalmazott módszer módosításával kapcsolatos tudnivalók a DNS-kiszolgáló rendszerindítási módszerének módosítása című témakörben találhatók.

  • További információ az Active Directoryval integrált DNS-szolgáltatással kapcsolatban Az Active Directory integrálása című témakörben található.

A rekurzió tiltása

Alapértelmezés szerint a DNS-szolgáltatás számára a rekurzió engedélyezett, és amikor az ügyfelek lekérdezést küldenek, általában kérik, hogy a kiszolgáló rekurziót alkalmazzon a névhozzárendeléshez. Ha a rekurzió tiltva van, a DNS-kiszolgáló az ügyfél kérésétől függetlenül mindig átirányítást alkalmaz.

Általánosságban a DNS-kiszolgálók a mérvadó zónájukon kívüli nevekre vonatkozó lekérdezéseket kétféleképpen válaszolhatják meg:

  • Küldhetnek átirányításra vonatkozó válaszokat, vagyis azonnal elküldik a kérelmet küldő ügyfélnek az általuk ismert olyan DNS-kiszolgálók erőforrásrekordjainak a listáját, amelyek a lekérdezett névhez közeliek vagy segíthetnek a névhozzárendelésben.
  • Az ügyfél nevében más kiszolgálók lekérdezését végrehajtó kiszolgáló a név teljes hozzárendelése érdekében rekurziót alkalmazhat. A rekurzív keresések mindaddig folytatódnak, amíg a kiszolgáló a lekérdezett névvel kapcsolatban nem kap mérvadó választ. Ekkor a kiszolgáló a választ az eredeti lekérdezést küldő ügyfélnek továbbítja.

DNS-kiszolgálókon a rekurzió letiltására általában akkor kerül sor, ha azt szeretné, hogy a DNS-ügyfelek csak az adott kiszolgáló által mérvadóan kezelt nevek hozzárendelését kérjék. Ez a helyzet akkor, ha a DNS-kiszolgáló a belső hálózattal kapcsolatban csak a DNS-nevekről rendelkezik információval, vagy ha nem képes külső nevek (például internetes DNS-nevek) hozzárendelésére, és azt szeretné, hogy az ügyfelek más DNS-kiszolgálókkal próbálkozzanak.

Megjegyzés

  • A rekurzió használatának engedélyezéséről és tiltásáról további információ a Rekurzió letiltása DNS-kiszolgálón című témakörben található.


A ciklikus multiplexelés beállítása

A ciklikus multiplexelés nem más, mint egy helyi szabályozó mechanizmus, amelyet a DNS-kiszolgálók a hálózati erőforrásokra jutó terhelések megosztására és elosztására használnak. Ha egy adott állomásnévhez több A (állomás) erőforrásrekordot talál a program, segítségével a lekérdezésre adott válaszban szereplő ilyen erőforrásrekordok váltogathatók.

Alapértelmezés szerint a DNS-kiszolgálószolgáltatás a ciklikus multiplexelést a válaszban szereplő erőforrásrekordok rendezésére használja, ha az állomás neve több erőforrásrekordhoz van rendelve. E szolgáltatással egyszerűen elosztható a webkiszolgálók és más gyakran lekérdezett többhelyű számítógépek ügyfelek általi használatából adódó terhelés.

Ahhoz, hogy a ciklikus multiplexelés működjön, a lekérdezett névhez több regisztrált A erőforrásrekordnak kell tartoznia a zónában. Ha egy adott DNS-kiszolgálón a ciklikus multiplexelés le van tiltva, akkor az ilyen lekérdezésre adott válaszok sorrendje a válaszlistában lévő erőforrásrekordok azon statikus sorrendjén alapul, amelyben azokat a zóna (a zónafájl vagy az Active Directory) tartalmazza.

Példa: rekordok váltogatása ciklikus multiplexeléssel

Egy három IP-címmel rendelkező, többhelyű számítógépre (tobbhelyu.pelda.microsoft.com) címkeresési (vagyis az adott DNS-tartománynévnek megfelelő összes A erőforrásrekord keresésére vonatkozó) lekérdezés érkezik. Az állomásnévnek mindezen IP-címhez való hozzárendelésére külön A erőforrásrekordok szolgálnak a zónában. A tárolt pelda.microsoft.com zónában az erőforrásrekordok a következő rögzített sorrendben jelennek meg:

tobbhelyu IN A 10.0.0.1
tobbhelyu IN A 10.0.0.2
tobbhelyu IN A 10.0.0.3

Az első DNS-ügyfél, amely ennek az állomásnévnek a hozzárendelése céljából lekérdezést küld a kiszolgálónak, alapértelmezett sorrendben kapja meg a listát. Amikor egy második ügyfél is lekérdezést küld ugyanennek a névnek a hozzárendelése céljából, a lista a következőképpen módosul:

tobbhelyu IN A 10.0.0.2
tobbhelyu IN A 10.0.0.3
tobbhelyu IN A 10.0.0.1

Megjegyzés

  • A helyi alhálózati prioritás érvényteleníti a többhelyű nevek ciklikus multiplexelését. Engedélyezése esetén azonban másodlagos rendezési módszerként a ciklikus multiplexelés továbbra is használható a címkeresési lekérdezésekre adott válaszban lévő A erőforrásrekordok rendezésére. A helyi alhálózatok prioritási sorrendjéről bővebben a Helyi alhálózatok prioritási sorrendbe állítása című témakörben található.


Helyi alhálózatok prioritási sorrendbe állítása

Ha az ügyfél lekérdezése egy olyan állomásnevet eredményez, amelyhez egynél több IP-cím van rendelve, a DNS-szolgáltatás alapértelmezés szerint a helyi alhálózatok prioritási sorrendjét használja fel az azonos hálózathoz tartozó IP-címek sorrendjének meghatározására. Ez a szolgáltatás feltételezi, hogy az ügyfélalkalmazás az állomáshoz a saját címéhez legközelebb eső (és általában leggyorsabb) elérhető IP-címen próbál meg csatlakozni.

A DNS-szolgáltatás a helyi alhálózatok prioritási sorrendjét a következőképpen használja:

  1. A DNS-szolgáltatás megállapítja, hogy a lekérdezés megválaszolásához szükség van-e a helyi alhálózatok prioritási sorrendjére.

    Ha egynél több A (állomás) erőforrásrekordban van egyezés a lekérdezett állomás nevével, a DNS-szolgáltatás az alhálózati cím alapján átrendezheti a rekordokat. Nincs szükség a prioritási sorrendre, ha a lekérdezett állomás nevével csak egy A erőforrásrekordban van egyezés, vagy ha az ügyfél hálózati IP-címe az erőforrásrekordok válaszlistáján szereplő hozzárendelt címek egyikénél sem egyezik azok hálózati címével.

  2. A DNS szolgáltatás az egyezések listájában levő minden erőforrásrekordnál megvizsgálja, hogy az megfelel-e a kérelmet küldő ügyfél alhálózatának.
  3. Ezután a válaszlistát úgy rendezi át, hogy azok az A (állomás) erőforrásrekordok, amelyekben egyezés van a kérést küldő ügyfél helyi alhálózatával, a lista elejére kerüljenek.
  4. A kérelem küldője a válaszlistát alhálózatok szerinti sorrendbe állítva kapja meg.

Egyszerű példa: helyi hálózat prioritási sorrendbe állítása

A tobbhelyu.pelda.microsoft.com többhelyű számítógép a három különböző IP-címének megfelelően három A (állomás) erőforrásrekorddal rendelkezik a pelda.microsoft.com zónában. Az állomás minden címének egy külön A erőforrásrekord felel meg, amelyek a zónában a következő sorrendben jelennek meg:

tobbhelyu IN A 192.168.1.27
tobbhelyu IN A 10.0.0.14
tobbhelyu IN A 172.16.20.4

Ha egy, a 10.4.3.2 címen lévő DNS-ügyfélnévfeloldó lekérdezi a kiszolgálótól a tobbhelyu.pelda.microsoft.com állomás IP-címeit, a DNS-szolgáltatás megállapítja, hogy a kezdeményező ügyfél hálózati IP-címe (10.0.0.0) megegyezik az erőforrásrekordok válaszlistáján szereplő 10.0.0.4 cím hálózati (A osztály) részével. Ezután a válaszban a címeket a következőképpen rendezi át:

tobbhelyu IN A 10.0.0.14
tobbhelyu IN A 192.168.1.27
tobbhelyu IN A 172.16.20.4

Ha a kérelmet küldő ügyfél IP-címében a helyi hálózati címet tekintve nincs egyezés a válaszlistán szereplő egyetlen erőforrásrekorddal sem, akkor ez a lista nem lesz prioritás szerint rendezve.

Összetett példa: helyi alhálózatok prioritási sorrendbe állítása

Ha egy olyan hálózatban dolgozik, amelyben IP-alhálózatok vannak kialakítva (nem alapértelmezett alhálózati maszkokkal), csak néhány apró különbség mutatkozik. Ha a hálózati rész alapján összehasonlítva egynél több egyezés volt, akkor az egyező címek közül az kerül az első helyre, amely a legszorosabb egyezést mutatja az alhálózati címmel.

Képzelje el, hogy a tobbhelyu.pelda.microsoft.com többhelyű számítógép a négy különböző IP-címének megfelelően négy A erőforrásrekorddal rendelkezik a pelda.microsoft.com zónában. Az IP-címek közül kettő nem helyi hálózati cím. A másik két IP-cím ugyanazon a hálózati IP-címen osztozik, de mivel IP-alhálózatok vannak kialakítva, a két cím a 255.255.248.0 egyéni (nem alapértelmezett) alhálózati maszk alapján különböző fizikai alhálózati kapcsolatnak felel meg A példában szereplő erőforrásrekordok sorrendje a zónában a következő:

tobbhelyu IN A 192.168.1.27
tobbhelyu IN A 172.16.22.4
tobbhelyu IN A 10.0.0.14
tobbhelyu IN A 172.16.31.5

Ha a kérelmet küldő ügyfél IP-címe 172.16.22.8, az ügyfél 172.16.0.0 hálózati címével egyező mindkét IP-cím a válaszlista elejére kerül. Ebben a példában a 176.16.22.4 cím azonban a 172.16.31.5 cím elé került, mivel az a 172.16.20.0 alhálózati címen át lefelé közelebb esik az ügyfél IP-címéhez.

A DNS-szolgáltatásnak elküldött átrendezett válaszlista a következő lesz:

tobbhelyu IN A 172.16.22.4
tobbhelyu IN A 172.16.31.5
tobbhelyu IN A 192.168.1.27
tobbhelyu IN A 10.0.0.14

Megjegyzések

  • IP-alhálózatok úgy jönnek létre, ha a hálózaton előforduló összes IP-címre az egyéni, nem alapértelmezett alhálózati maszkot alkalmaz. További információ az Alhálózati maszkok című témakörben található.
  • A többhelyű neveknél a helyi alhálózatok prioritása erősebb a ciklikus multiplexelésnél. Ha azonban a ciklikus multiplexelés engedélyezve van, a válaszlistán e másodlagos rendezési szempont alapján az erőforrásrekordok váltakoznak. A ciklikus multiplexeléssel kapcsolatban további információ A ciklikus multiplexelés beállítása című témakörben található.


A kiszolgáló felügyeletének automatizálása a Dnscmd paranccsal

A Windows 2000 Server rendszerben a DNS-kiszolgálók felügyeletére a parancssorból kiadható Dnscmd parancs is lehetőséget nyújt. Ez az eszköz lehetővé teszi parancsfájlok készítését, segíti a meglévő DNS-kiszolgálókonfigurációk automatikus kezelését és frissítését, valamint új DNS-kiszolgálók telepítését és beállítását a hálózaton.

A dnscmd parancsot úgy telepítheti, hogy átmásolja a rendszer telepítő CD-jének \Support\Enterprise\Reskit mappájából. A parancs használatát ismertető súgó megjelenítéséhez írja be a dnscmd /? karaktereket a parancssorba. A dnscmd parancs teljes dokumentációját a Windows 2000 Server Resource Kit tartalmazza.


Forrásmunkák

A rész tartalma:

  • Erőforrásrekordok leírása
  • A DNS-kiszolgálónapló
  • A DNS-szolgáltatáshoz tartozó fájlok
  • Frissített technikai információ a DNS-ről
  • Egyéb források


Erőforrásrekordok leírása

Egy DNS-adatbázis a DNS-kiszolgáló által használt egy vagy több zónafájlból áll. Mindegyik zóna strukturált erőforrásrekordok gyűjteményét tartalmazza, melyek közül a Windows 2000 Server számítógépen futó DNS-szolgáltatás a következőket támogatja.

A DNS erőforrásrekordok formátuma

Minden erőforrásrekordnak (RR) meghatározott formátuma van, mely ugyanazokat a legfelső szintű mezőket használja, az alábbi táblázat szerint.

Mező | Leírás
Tulajdonos | Azt a DNS-tartománynevet jelzi, amely az erőforrásrekord tulajdonosa. Ez a név megegyezik a konzolfa azon csomópontjának a nevével, ahol az erőforrásrekord elhelyezkedik.
Élettartam (TTL) A legtöbb erőforrásrekord esetében a mezőt nem kötelező kitölteni. Azt az időtartamot jelzi, amely a többi DNS-kiszolgáló számára meghatározza, hogy a rekordadatokat mennyi ideig őrizzék a gyorsítótárban elévülésük és törlésük előtt.

A DNS-kiszolgálói szolgáltatás által létrehozott legtöbb erőforrásrekord például a minimális 1 óra (alapértelmezett) TTL értéket örökli a SOA rekordtól; e rekord akadályozza meg, hogy a többi DNS-kiszolgáló túl sokáig tartsa az erőforrásrekordokat a gyorsítótárban.

Az egyes erőforrásrekordok esetében megadható egy rekordfüggő TTL, amely hatálytalanítja a SOA erőforrásrekordtól örökölt minimális (alapértelmezett) TTL értéket. Nulla (0) TTL érték is megadható olyan ideiglenes adatokat tartalmazó erőforrásrekordok esetében, melyek gyorsítótárban tartására a folyamatban lévő DNS-lekérdezés befejezése után nincs szükség.
Osztály | Az erőforrásrekord osztályát jelző szabványos mnemonikus szöveget tartalmaz. Az „IN” beállítás például azt mutatja, hogy az erőforrásrekord az Internet osztályhoz tartozik, amely az egyetlen, a Windows 2000 DNS-kiszolgálók által támogatott osztály. Ez a mező kötelező.
Típus | Az erőforrásrekord típusát jelző szabványos mnemonikus szöveget tartalmaz. Az „A” mnemonik például azt jelzi, hogy az erőforrásrekord állomáscím-információt tárol. Ez a mező kötelező.
Rekordfüggő adatok | Egy változó hosszúságú kötelező mező, mely az erőforrást leíró információt tartalmazza. Ennek az információnak a formátuma az erőforrásrekord típusának és osztályának függvényében változik.

A

Leírás: A (állomáscím) erőforrásrekord. Egy DNS-tartománynevet rendel IP 4 (4-es verziójú Internet protokoll) alapú 32 bites címhez. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos osztály ttl A IP_4v_cím
Példa:
allomas1.pelda.microsoft.com.     IN  A  127.0.0.1

AAAA

Leírás: AAAA (IPv6 állomáscím) erőforrásrekord. Egy DNS-tartománynevet rendel IP 6 (6-os verziójú Internet protokoll) alapú 128 bites címhez. További tudnivalók az 1886-os számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos osztály ttl AAAA IP_6v_cím
Példa:
ipv6_allomas1.pelda.microsoft.com.     IN  AAAA  4321:0:1:2:3:4:567:89ab

AFSDB

Leírás: AFSDB (Andrew File System Database) erőforrásrekord. A kiszolgálónév mezőben található DNS tartománynevet a kiszolgáló altípusának megfelelő kiszolgáló-számítógép állomásnevéhez rendeli. Az altípus mező felismert és támogatott értékei az alábbiak:
  • 1 – jelzi, hogy a kiszolgáló az AFS cella 3.0-s verziójú AFS-kötet helyének kiszolgálója.
  • 2 – jelzi, hogy a kiszolgáló az Open Software Foundation (OSF) DCE hitelesített cellaelnevezési rendszert vagy a HP/Apollo's Network Computing Architecture (NCA) rendszert használó kiszolgáló cellagyökér-könyvtárcsomópontját tartalmazó hitelesített névkiszolgáló.
További tudnivalók az 1183-as számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály AFSDB altípus kiszolgálónév
Példa:
pelda.microsoft.com.   AFSDB   1 afs-kiszolgalo1.pelda.microsoft.com.

ATMA

Leírás: ATMA (aszinkron átviteli módú cím) erőforrásrekord. A tulajdonos mezőben található DNS tartománynevet rendeli az atm_cím mezőben hivatkozott ATM-címhez.

További információért tanulmányozza az „ATM Name System Specification Version 1.0” című, ATM Forum által kiadott műszaki leírást. A leírást letöltheti a következő címről: ATM Forum FTP-hely (ftp://ftp.atmforum.com/pub/approved-specs/).

Letöltéskor adja meg a letöltendő fájl nevét, mely a következő lehet:

  • af-saa-0069.000.doc – a dokumentum Microsoft Word formátumú példánya.
  • af-saa-0069.000.rtf – rich text formátumú (RTF) dokumentum, amely a WordPad alkalmazással nyitható meg.

Megjegyzés
Szintaxis:
tulajdonos ttl osztály ATMA atm_cím
Példa:
atm-allomas   ATMA   47.0079.00010200000000000000.00a03e000002.00

CNAME

Leírás: CNAME (kanonikus név) erőforrásrekord. A tulajdonos mezőben található aliast azaz másodlagos DNS-tartománynevet a kanonikus_név mezőben megadott kanonikus azaz elsődleges tartománynévhez rendeli. Az adatokban szereplő kanonikus vagy elsődleges DNS-tartománynév kötelező, és a névtér érvényes DNS-tartománynéhez kell hozzárendelni.
Szintaxis:
tulajdonos ttl osztály CNAME kanonikus_név
Példa:
alias.pelda.microsoft.com.   CNAME   1 valodi_nev.pelda.microsoft.com.

HINFO

Leírás: HINFO (állomásinformációs) erőforrásrekord. Megadja a cpu_típus és operációs_rendszer mezőkben a CPU és az operációs rendszer típusát a tulajdonos mezőben szereplő DNS-tartománynévvel jelzett állomás esetében. Az ismertebb CPU és operációs rendszer típusokat az 1700-as számú RFC-dokumentum tartalmazza. Ezt az információt az alkalmazásprotokollok használhatják (például az FTP), melyek egy ismert CPU-val és operációs rendszerrel rendelkező számítógéppel való kommunikációban speciális eljárásokat alkalmaznak.
Szintaxis:
tulajdonos ttl osztály HINFO cpu_típus operációs_rendszer
Példa:
sajatgep-neve.pelda.microsoft.com.    HINFO   INTEL-386  WIN32

ISDN

Leírás: ISDN (integrált szolgáltatású digitális hálózat) erőforrásrekord. Egy DNS tartománynevet rendel ISDN-telefonszámhoz. A rekorddal használt telefonszámoknak meg kell felelniük az ITU-T E.163 és E.164 nemzetközi telefonszám-használati szabványainak, melyek kompatibilisek a jelenlegi nemzetközi, már alkalmazott telefonszám-használati modellekkel. További tudnivalók az 1183-as számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály ISDN isdn_cím alcím
Példa:
sajat-isdn-allomas.pelda.microsoft.com.    ISDN   141555555539699 002

MB

Leírás: MB (postafiók) erőforrásrekord. A tulajdonos mezőben megadott tartományi postafiókot a postafiók_állomás_neve mezőben szereplő postafiók-állomás nevéhez rendeli. A postafiók-állomás nevének egyeznie kell egy, a zónában már egy állomás által használt A erőforrásrekord érvényes állomáscímével. Ezen felül a megadott állomásnak rendelkeznie kell egy tartományi postafiókkal, amely a kijelölt tulajdonosnak küldött üzeneteket fogadja. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály MB postafiók_állomás_neve
Példa:
postafiok.pelda.microsoft.com.    MB   levelezoallomas1.pelda.microsoft.com

MG

Leírás: MB (levelezőcsoport) erőforrásrekord. Az erőforrásrekordban a tulajdonos mezőben hivatkozott tartományi levelezőcsoporthoz ad a zóna MB erőforrásrekordjaiban megadott tartományi postafiókokat. A postafiók_neve mezőben használt névnek egyeznie kell a zónában meglévő érvényes MB erőforrásrekordok egyikével. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály MG postafiók_neve
Példa:
rendszergazda.pelda.microsoft.com.    MG   postafiok1.pelda.microsoft.com
                                           postafiok2.pelda.microsoft.com

MINFO

Leírás: MINFO (postafiók levelezési listájára vonatkozó információ) erőforrásrekord. Megadja (a felelős_postafiókja mezőben) a tulajdonos mezőben hivatkozott postafiók vagy levelezési lista karbantartásáért felelős személy tartományi postafiókját. A hiba_postafiók mező olyan tartományi postafiók megadására használható, amely a levelezési listával vagy postafiókkal kapcsolatos hibaüzeneteket fogadja. A mezőkben használt személyek postafiókjainak és a hibaüzeneteket fogadó postafiókoknak meg kell felelniük a zónában már meglévő érvényes MB erőforrásrekordok egyikével. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály MINFO felelős_postafiókja hiba_postafiók
Példa:
rendszergazda.pelda.microsoft.com.    MINFO  felelos-postafiokja.pelda.microsoft.com hiba-postafiok.pelda.microsoft.com

MR

Leírás: MR (átnevezett postafiók) erőforrásrekord. Az új_átnevezett_postafiók mezőben megadja a tulajdonos mezőben megadott meglévő postafiók új tartományi postafióknevét. Az MR erőforrásrekord gyakran használatos továbbító bejegyzésként olyan felhasználó számára, aki új postafiókot kapott. Az MR rekordok nem vezetnek további szakaszfeldolgozáshoz. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály MR új_átnevezett_postafiók
Példa:
regi_postafiok.pelda.microsoft.com.    MR  uj-atnevezett-postafiok.pelda.microsoft.com

MX

Leírás: MX (levélváltó) erőforrásrekord. Üzenetútvonalakat biztosít a levélváltó_kiszolgáló mezőben megadott levélkezelő állomáshoz a tulajdonos mezőben megadott tartománynevekhez küldött levelek esetében. Kétszámjegyű preferencia jelzi az elsődleges sorrendet abban az esetben, ha több levélváltó állomás van megadva. Mindegyik levélváltó állomásnak rendelkeznie kell egy megfelelő állomáscím (A) erőforrásrekorddal egy érvényes zónában. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis: tulajdonos ttl osztály MX preferencia levélváltó_kiszolgáló
Példa:
pelda.microsoft.com.    MX  10 levelezokiszolgalo1.pelda.microsoft.com

PTR

Leírás: PTR (mutató) erőforrásrekord. A tulajdonos mezőben lévő névtől a DNS-névtér cél_tartománynév mezőben megadott másik helyére mutat. Gyakran használatos speciális tartományokban, például az in-addr.arpa tartományfában a cím-név hozzárendelések névkeresésének biztosítására. A legtöbb esetben az egyes rekordok olyan információt tartalmaznak, amely másik DNS tartománynévre mutat, például a megfelelő A erőforrásrekordra egy címlekérdezési zónában. További tudnivalók az 1035-ös RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály PTR cél_tartománynév
Példa:
1.0.0.10.in-addr.arpa.    PTR  allomas.pelda.microsoft.com.

RP

Leírás: RP (felelős személy) erőforrásrekord. Megadja egy felelős személy tartományi postafiókjának nevét a postafiók_név mezőben. Ezt a nevet azután a szolgáltatás hozzárendeli a szöveg_rekord_név mezőben szereplő tartománynévhez, melyhez TXT erőforrásrekordok tartoznak ugyanebben a zónában. Amikor RP rekordok használatára kerül sor a DNS-lekérdezésekben, a rendszer ismétlődő lekérdezésekkel kéri le a vonatkozó TXT erőforrásrekord-információt. További tudnivalók az 1183-as számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály RP postafiók_név szöveg_rekord_név
Példa:
pelda.microsoft.com.               RP    admin.pelda.microsoft.com.  admin-info.pelda.microsoft.com.
admin_info.pelda.microsoft.com.    TXT  "Jani rendszergazda, (555) 555-0110"

RT

Leírás: RT (köztes állomás) erőforrásrekord. Egy köztes állomáson keresztüli kötést hoz létre olyan belső állomások számára, melyeknek nincs közvetlen nagy kiterjedésű hálózati (WAN-) vagy külső hálózati kapcsolatuk. Az RT rekord annyiban hasonlít az MX rekordhoz, hogy a belső állomástól jövő mindenfajta kommunikáció a tulajdonos mezőben megadott célként szereplő DNS-tartománynév köztes_állomásán vezet keresztül. Kétszámjegyű preferencia szolgál az elsőbbségi sorrend beállítására abban az esetben, ha több köztes útválasztó állomás van megadva. Mindegyik megadott köztes állomásnak rendelkeznie kell egy megfelelő állomáscím (A) erőforrásrekorddal a zónában. További tudnivalók az 1183-as számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály RT preferencia köztes_állomás
Példa:
pelda.microsoft.com.    RT    2 lan-utvalaszto.pelda.microsoft.com
                        RT   10 wan-utvalaszto.pelda.microsoft.com

SRV

Leírás: SRV (szolgáltatáshely) erőforrásrekord. Lehetővé teszi több, hasonló TCP/IP alapú szolgáltatást nyújtó kiszolgáló megtalálását egyetlen DNS-lekérdezési művelettel. Ez a rekord lehetővé teszi, hogy egy ismert kiszolgálóporthoz és átviteliprotokoll-típushoz egy kiszolgálólistát tartson fenn, DNS-tartománynévhez társított elsőbbségi sorrendben. A Windows 2000 Server rendszerben például lehetővé teszi az LDAP (Lightweight Directory Access) protokollt a 389-es TCP-porton keresztül használó tartományvezérlők megkeresését.

Az SRV erőforrásrekord egyes mezőinek rendeltetése a következő:

  • szolgáltatás A keresett szolgáltatás szimbolikus neve. Az ismert szolgáltatások univerzális szimbolikus nevét (például „_telnet” vagy „_smtp”) az 1700-as számú RFC-dokumentum tartalmazza. Ha egy ismert szolgáltatás szimbolikus neve itt nincs megadva, akkor helyi, választott nevet is lehet használni. Egyes elterjedt TCP/IP-szolgáltatások (például a POP, a Post Office protokoll), nem rendelkezik univerzális szimbolikus névvel. Ha az 1700-as számú RFC megjelöl egy nevet a mezőben jelzett szolgáltatáshoz, akkor kizárólag az ott megadott nevet szabad használni. Csak a helyileg megadott szolgáltatásokat lehet helyileg elnevezni.
  • protokoll Az átviteli protokoll típusát jelzi. Ez általában TCP vagy UDP, bár az 1700-as számú RFC-dokumentumban megnevezett bármelyik protokoll használható.
  • név A DNS tartománynév, melyre az erőforrásrekord hivatkozik. Az SRV erőforrásrekord egyedülálló a többi erőforrásrekord-típus között annyiban, hogy keresésekben, illetve lekérdezésekben nem használatos.
  • prioritás Megadja a cél mezőben megadott állomásra vonatkozó preferenciát. Az SRV erőforrásrekordokat lekérdező DNS-ügyfelek az itt felsorolt állomások közül a legalacsonyabb sorszámú elérhető állomással próbálják meg felvenni a kapcsolatot. Bár a célállomások ugyanezzel a preferenciával rendelkeznek, elérésük véletlen sorrendben is megpróbálható. A preferenciák tartománya 0 és 65535 közé esik.
  • súlyozás A preferencia melletti másik terheléselosztó mechanizmus, abban az esetben, ha a cél mezőben több kiszolgáló van megadva, és mindegyik azonos preferenciaszintre van állítva. Ha egyenlő preferenciaszintű kiszolgálók közül választ célkiszolgálót, az értékkel egy további preferenciaszintet lehet beállítani, mely egy megválaszolt SRV-lekérdezésben használt célállomások pontos sorrendjének megadására azaz a választék kiegyenlítésére használható. Nullától eltérő érték használatakor az egyenlő preferenciájú kiszolgálókat az érték súlyozásának megfelelően próbálja a rendszer elérni. Az értékek tartománya 1-65535. Ha nincs szükség terheléselosztásra, használja a 0 értéket a mezőben, ezáltal a rekord olvasása gyorsabb lesz.
  • port A kiszolgálóport a cél állomáson, amely a szolgáltatás mezőben megadott szolgáltatást nyújtja. A portszámok tartománya 0-65535, bár ez a szám gyakran egy ismert szolgáltatás portszáma, ahogy azt az 1700-as számú RFC-dokumentum meghatározza. A még ki nem osztott portok igény szerint felhasználhatók.
  • cél Megadja DNS-tartománynevét annak az állomásnak, amely a kért típusú szolgáltatást nyújtja. Az itt szereplő állomásneveknek rendelkezniük kell egy megfelelő állomáscím (A) erőforrásrekorddal a DNS-névtérben. Egy ponttal (.) lehet mérvadóan jelezni, hogy az SRV erőforrásrekordban megadott kért szolgáltatás a DNS-tartománynévben nem áll rendelkezésre.

További információért tanulmányozza az „A DNS RR for specifying the location of services (DNS SRV)” (DNS erőforrásrekord a szolgáltatások helyének megadására (DNS SRV)) című internetes dokumentumot.
Szintaxis:
szolgáltatás.protokoll.név ttl osztály SRV preferencia súlyozás port cél
Példa:
_ldap._tcp.ms-dcs    SRV  0 0   389 dc1.pelda.microsoft.com
                     SRV 10 0   389 dc2.pelda.microsoft.com

TXT

Leírás: TXT (szöveg) erőforrásrekord. A tulajdonos mezőben található DNS-tartománynevet a szöveg_karakterlánc mezőben található karakterlánchoz rendeli, mely leíró szövegként szolgál. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály TXT szöveg_karakterlánc
Példa:
pelda.microsoft.com.    TXT  "Példa a tartománynévre vonatkozó további információkra."

WKS

Leírás: WKS (ismert szolgáltatás) erőforrásrekord. Leírja az adott IP-címen egy bizonyos protokoll által támogatott ismert TCP/IP-szolgáltatásokat. A WKS rekordok a TCP és az UDP elérhetőségéről szolgáltatnak információt a TCP/IP alapú kiszolgálók számára. Ha egy kiszolgáló támogatja a TCP és az UDP protokollt is egy ismert szolgáltatás esetében, vagy több, a szolgáltatást támogató IP-címmel rendelkezik, akkor több WKS rekordot kell használni. További tudnivalók az 1035-ös számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály WKS cím protokoll szolgáltatáslista
Példa:
pelda.microsoft.com.    WKS  10.0.0.1 TCP ( telnet smtp ftp )

X25

Leírás: X.25 erőforrásrekord. A tulajdonos mezőben található DNS-tartománynevet a psdn_szám mezőben hivatkozott nyilvános kapcsolt vonalas hálózathoz (PSDN) rendeli. A rekorddal használt PSDN számoknak követniük kell az X.121-es nemzetközi számozási modellt. További tudnivalók az 1183-as számú RFC-dokumentumban találhatók.
Szintaxis:
tulajdonos ttl osztály X25 psdn_szám
Példa:
pelda.microsoft.com.    X25  52204455506


A DNS-kiszolgálónapló

Az alábbi lista a DNS-kiszolgálónaplóban rögzített események részleges felsorolása. A naplót az Eseménynapló segédprogrammal lehet megtekinteni, a Windows 2000 alapú DNS-kiszolgálónak a kiszolgáló-számítógépre történő telepítése után. További információt a DNS-kiszolgáló rendszeresemény-naplójának megtekintése című témakörben talál.

Eseményazonosító Leírás
2 A DNS-kiszolgáló elindult.

Az üzenet általában indításkor jelenik meg, azaz amikor a kiszolgáló-számítógép elindul vagy amikor a DNS-kiszolgálószolgáltatást kézzel elindítja. További információt a DNS-kiszolgáló indítása és leállítása című témakörben talál.
3 A DNS-kiszolgáló le lett állítva.

Az üzenet általában akkor jelenik meg, amikor a kiszolgáló-számítógép leáll, vagy amikor a DNS-kiszolgáló szolgáltatást kézzel leállítja.
408 A DNS-kiszolgáló nem tudott szoftvercsatornát megnyitni a(z) [IPcím] címhez. Győződjön meg róla, hogy ez a cím a kiszolgáló érvényes IP-címe.

A hibát a következőképpen javíthatja ki:

  • Ha a megadott IP-cím nem érvényes, távolítsa el a kiszolgáló korlátozott illesztőinek listájáról, és indítsa újra a kiszolgálót. További információt A DNS-kiszolgáló által figyelt címek korlátozása című témakörben talál.
  • Ha a megadott IP-cím már nem érvényes, és az volt a DNS-kiszolgálónak használatra engedélyezett egyetlen cím, az olyan konfigurációs hibát okozhatott, ami miatt a kiszolgáló nem indult el. A hiba kijavításához törölje az alábbi értéket a Windows 2000 rendszerleíró adatbázisából, és indítsa újra a DNS-kiszolgálót:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\DNS\Parameters\ListenAddress

  • Ha az IP-cím érvényes a kiszolgáló-számítógép számára, ellenőrizze, hogy nem fut-e másik alkalmazás (például másik DNS-kiszolgáló), amely ugyanazt a DNS-kiszolgálói portot próbálja használni. Alapértelmezés szerint a Windows 2000 alapú kiszolgálók az 53-as TCP-portot használják.
413 A DNS-kiszolgáló a többi DNS-kiszolgálónak nem az alapértelmezett (53-as TCP) porton fogja a kérelmeket elküldeni.

Ez a DNS-kiszolgáló többhelyű, de úgy lett konfigurálva, hogy a beállított IP-címeinek csak egy részére korlátozza a DNS-szolgáltatást. Emiatt nincs garancia arra, hogy a kiszolgáló által más, távoli DNS-kiszolgálókhoz intézett DNS-lekérdezések a DNS-kiszolgáló engedélyezett IP-címeinek valamelyikén el lesznek küldve.

Ez megakadályozhatja az említett kiszolgálók válaszainak fogadását azon a DNS-porton, amelynek használatára a kiszolgáló jelenleg konfigurálva van. A probléma elkerülése érdekében a DNS-kiszolgáló a lekérdezéseket egy tetszőleges nem DNS-porton küldi, és a rendszer a választ a használt IP-címtől függetlenül fogadja.

Ha korlátozni kívánja a DNS-kiszolgálót arra, hogy a többi DNS-kiszolgálóhoz intézett lekérdezéseket csak a beállított DNS-porton keresztül küldhesse, a DNS-konzol segítségével módosítsa a kiszolgáló tulajdonságait az Illesztők lapon az alábbi eljárások valamelyikével:

  1. Jelölje be Az összes IP-címen választógombot, ezzel engedélyezheti a DNS-kiszolgáló számára, hogy minden beállított IP-címen figyeljen.
  2. Ha a Csak a következő IP-címeken beállítást választja, az IP-cím listát korlátozza egyetlen kiszolgálói IP-címre.

További információt A DNS-kiszolgáló által figyelt címek korlátozása című témakörben talál.
414 A kiszolgáló-számítógépnek jelenleg nincs beállított elsődleges DNS-utótagja. DNS-neve jelenleg egycímkés állomásnév. Az aktuális konfiguráció szerinti név például az „allomas.pelda.microsoft.com” vagy egyéb teljesen minősített név helyett mindössze „allomas”.

Amíg a DNS-kiszolgálónak csak egycímkés neve van, a konfigurált zónáihoz létrehozott alapértelmezett erőforrásrekordok csak az egycímkés nevet használják a DNS-kiszolgáló állomásnevének hozzárendelésekor. Ez helytelen, hibás átirányításokhoz vezethet, amikor az ügyfelek és a DNS-kiszolgálók ezeket a rekordokat használják a kiszolgáló név alapján való megkereséséhez.

Általában véve a DNS-kiszolgálót újra kell konfigurálni egy teljes DNS-számítógépnévvel, amely megfelel a tartomány vagy munkacsoport hálózati használatának. További információt az Ügyfélszámítógép elsődleges DNS-utótagjának beállítása című témakörben talál.
708 A DNS-kiszolgáló sem elsődleges, sem másodlagos zónát nem talált. Csak gyorsítótárazást végző kiszolgálóként fog futni, és egyik zónára nézve sem lesz mérvadó.

További információt a Csak gyorsítótárazást végző kiszolgálók használata című témakörben talál.
3150 A DNS-kiszolgáló a(z) [zónanév] zóna új verzióját a(z) [fájlnév] fájlba írta. Az új verziószámot az Adat rögzítése fülre kattintva tekintheti meg.

Ez az esemény csak akkor fordulhat elő, ha a DNS-kiszolgáló gyökérkiszolgálóként való működésre van konfigurálva. További információt A DNS szolgáltatáshoz tartozó fájlok című témakörben talál.
6527 A(z) [zónanév] zóna lejárt, mielőtt sikeres zónaletöltésre vagy egy zónaforrásként működő főkiszolgálóról való frissítésre került volna sor. A zóna le lett állítva.

Ez az eseményazonosító akkor jelenik meg, ha a DNS-kiszolgáló olyan másik DNS-kiszolgálón lévő zóna másodpéldányának tárolására van beállítva, amely ennek a forrás- vagy főkiszolgálójaként működik. Ellenőrizze, hogy a kiszolgálónak van-e hálózati kapcsolata a beállított főkiszolgálóval.

Ha a hiba továbbra is fennáll, az alábbi eljárások jelenthetnek megoldást:

  1. Törölje a zónát majd hozza létre újra, és vagy egy másik főkiszolgálót jelöljön ki, vagy adja meg ugyanannak a főkiszolgálónak frissített vagy javított IP-címét.

    További információt a Zónák hozzáadása és eltávolítása című témakörben talál.

  2. Ha újra előfordul, hogy a zóna lejár, vegye fontolóra a lejárati időköz módosítását.

    További információt a Zóna elévülési időközének beállítása című témakörben talál.

További információt A zónák és a zónaletöltés ismertetése témakörben talál.

A témakörben nem ismertetett üzenetekkel kapcsolatban további információt maga az üzenet szövege nyújthat, miként az a DNS-kiszolgáló eseménynaplójában megjelenik.

Figyelem!

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról.

Megjegyzések

  • A DNS-ügyfélszolgáltatás által naplózott eseményüzeneteket a Rendszer napló rögzíti, és szintén az Eseménynapló segédprogrammal tekinthetők meg a megfelelő ügyfélszámítógépen. További információt Az Eseménynapló használata című témakörben talál.
  • Ha gyakran visszatérő hibák jelentkeznek, engedélyezheti a DNS-kiszolgáló speciális hibaelhárítási lehetőségeit, mellyel a kiszolgáló működésének részletesebb naplóját kapja. További információt A kiszolgáló hibakeresés-naplózásának használata vagy a DNS-kiszolgáló hibakeresési naplójának megtekintése című témakörben talál.


A DNS-szolgáltatáshoz tartozó fájlok

Az alábbi fájlok a DNS-kiszolgálók Windows 2000 rendszerben történő használatával és konfigurálásával kapcsolatosak.

Fájl | Leírás
Boot | BIND indítási konfigurációs fájl. Ezt a fájlt nem a DNS-konzol hozza létre. A DNS-kiszolgáló választható konfigurációs lehetőségeként azonban a fájl egy másik, BIND (Berkeley Internet Name Domain) alapú DNS-kiszolgáló DNS-példányából átmásolható. A fájl DNS-kiszolgálószolgáltatással való használatához a zónaadatok betöltésének forrását jelölő Fájlból listaelemet kell választani a kiszolgáló tulajdonságait megjelenítő párbeszédpanelen. A BIND-kiszolgálókon a fájl neve általában „named.boot”.
Cache.dns Erőforrásrekordok előzetes betöltésére használatos a DNS-kiszolgáló neveket tartalmazó gyorsítótárába. A Windows 2000 alapú DNS-kiszolgálók ezt a fájlt használják a gyökérkiszolgálók hálózaton vagy az Interneten való keresésének segítéséhez.

Alapértelmezés szerint a fájl azokat a DNS-erőforrásrekordokat tartalmazza, amelyek az Internethez mérvadó gyökérkiszolgálók címeivel töltik fel a kiszolgáló helyi gyorsítótárát. Ha internetes DNS-nevek hozzárendeléséhez konfigurál DNS-kiszolgálót, akkor az e fájlban tárolt információra szükség van, hacsak nem engedélyezi egy másik DNS-kiszolgáló továbbítóként való használatát e nevek hozzárendelésére.

Az internetes gyökérkiszolgálók forgalma jelentős, de mivel az állomásnevek hozzárendelése általában nem ezen a szinten történik, a terheléssel meg tudnak birkózni. A gyökérútmutató-fájl inkább átirányítási információval szolgál, amely a DNS-nevek hozzárendelésekor lehet hasznos a lekérdezés másik, a gyökér alatti nevek esetében mérvadó kiszolgálóhoz irányítására.

A belső hálózaton működő saját DNS-kiszolgálók esetében a DNS-konzol képes felismerni és felülírni a fájl tartalmát a hálózaton működő gyökérkiszolgálókkal, feltéve hogy azok a hálózaton elérhetők az új DNS-kiszolgálók telepítésekor és konfigurálásakor. A DNS-konzollal a Gyökérútmutató lapon frissíthető, amely a vonatkozó kiszolgáló tulajdonságai között található.

Ez a fájl a kiszolgáló neveket tartalmazó gyorsítótárát annak indulásakor előzetesen betölti.
Root.dns | Gyökérzónafájl. Ez a fájl Windows 2000 alapú DNS-kiszolgálóként üzemelő számítógépeken található, ha azok a hálózat gyökérkiszolgálójaként vannak konfigurálva.
zónanév.dns | Akkor használatos, ha egy szabványos (elsődleges vagy másodlagos) zónát kell a kiszolgálóhoz adni és konfigurálni. Ez a fájltípus nem jön létre, illetve nem használatos a címtárral integrált elsődleges típusú zónák esetében, melyek az Active Directory adatbázisában tárolódnak.

E fájlok a %Rendszergyökér%\System32\Dns mappában találhatók a kiszolgálón.

Megjegyzések

  • A DNS-kiszolgáló gyökérkiszolgálóként való üzemeltetésével kapcsolatban további információt a Gyökérútmutatók frissítése című témakörben talál.
  • További tudnivalókat arról, hogy saját DNS-jelenlétét hogyan valósíthatja meg az Interneten, A DNS használata az Interneten című témakörben talál.
  • A hálózati DNS-kiszolgálók továbbítók használatához való konfigurálásával kapcsolatban további információ a Továbbítók használata című témakörben található.
  • Ha kiszolgálófájlokat telepít át BIND-kiszolgálóról Windows alapú DNS-kiszolgálóval történő használatra, a fájlokat át kell neveznie, és a DNS-szolgáltatás által használt megfelelő mappába kell másolnia. Ha további információra van szüksége, olvassa el a Kiszolgálók áttelepítése című témakört.


Frissített technikai információ a DNS-ről

A DNS szolgáltatásról frissített technikai információt a Microsoft webhelyén található Technikai Tanácsadó részlegéről beszerezhető műszaki cikkekben talál. További információ a Frissített technikai információ című témakörben található.

A DNS szolgáltatásról további részletes információt talál a Windows 2000 Server Resource Kit csomagban. További tájékoztatásért tanilmányozza a Windows 2000 Resource Kit csomagot.


Egyéb források

A rész tartalma:

  • A DNS szolgáltatással kapcsolatos RFC-dokumentumok
  • Legfelső szintű tartományok
  • DNS bibliográfia


A DNS-szolgáltatással kapcsolatos RFC-dokumentumok

Az RFC-k (Request for Comments) az Internet-közösség által használt, folyamatosan fejlesztett beszámolók, protokolljavaslatok és protokollszabványok összessége. A DNS (Domain Name System, Tartománynévtér) specifikációi az Internet Engineering Task Force (IETF) és más munkacsoportok által közzétett, jóváhagyott RFC-ken alapul. Az itt felsorolt dokumentumok angol nyelvűek.

A Windows 2000 alapú DNS-szolgáltatáshoz készült RFC-dokumentumok

A Windows 2000 DNS-szolgáltatásának megtervezésében és megvalósításában az alábbi RFC-k specifikációi szolgáltak alapul:

RFC | Cím
1034 | Domain Names – Concepts and Facilities
1035 | Domain Names – Implementation and Specification
1123 | Requirements for Internet Hosts – Application and Support
1886 | DNS Extensions to Support IP Version 6
1995 | Incremental Zone Transfer in DNS
1996 | A Mechanism for Prompt DNS Notification of Zone Changes
2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)
2181 | Clarifications to the DNS Specification
2308 | Negative Caching of DNS Queries (DNS NCACHE)

Internetes tervezetek a Windows 2000 DNS szolgáltatásához

Az alábbi internetes dokumentumok olyan specifikációkat tartalmaznak, melyek alapul szolgáltak a Windows 2000 DNS-szolgáltatásának megtervezésében és megvalósításában:

Fájlnév | Cím
Draft-ietf-dnsind-rfc2052bis-02.txt | A DNS RR for Specifying the Location of Services (DNS SRV)
Draft-skwan-utf8-dns-02.txt | Using the UTF-8 Character Set in the Domain Name System
Draft-ietf-dhc-dhcp-dns-08.txt | Interaction between DHCP and DNS
Draft-ietf-dnsind-tsig-11.txt | Secret Key Transaction Signatures for DNS (TSIG)
Draft-ietf-dnsind-tkey-00.txt | Secret Key Establishment for DNS (TKEY RR)
Draft-skwan-gss-tsig-04.txt | GSS Algorithm for TSIG (GSS-TSIG)

Egyéb specifikációk a Windows 2000 alapú DNS-szolgáltatáshoz

Az alábbi egyéb specifikációk szolgáltak alapul a Windows 2000 DNS szolgáltatásának megtervezésében és megvalósításában:

Fájlnév | Cím
af-saa-0069.000.doc | ATM Name System Specifcation version 1.0 Ezt a leírást az ATM Forum tette közzé. További tájékoztatásért a leírást letöltheti a következő címről: ATM Forum FTP-hely (ftp://ftp.atmforum.com/pub/approved-specs/).

A DNS-szolgáltatással kapcsolatos RFC-k és egyéb internetes dokumentumok beszerzése

Az RFC-k és egyéb internetes dokumentumok beszerezhetők a Request for Comments webhelyen. Az RFC-dokumentumok a következő kategóriákba sorolhatók: jóváhagyott Internet-szabványok, javasolt Internet-szabványok (felülvizsgálatra tervezet formájában terjesztve), gyakorlati tanácsok az Internethez és információs (FYI) dokumentumok. Az Internet-tervezeteknek nincs RFC számuk; ezek olyan specifikációk, amelyek jelenleg javaslati stádiumban vannak, és amelyeket általában az egyik IETF munkacsoport tett közzé. E munkacsoportok közül nem egy a DNS-szolgáltatással kapcsolatos témakörökkel foglalkozik.

Megjegyzések

  • Az 1034-es és 1035-ös számú RFC-k határozzák meg az eredeti DNS-protokoll szabványt, mely a TCP/IP környezetben a tartománynév-szolgáltatásokat támogatja. Ezen dokumentumok részletesen leírják a protokollokat, kiemelve azokat az alapelveket és eljárásokat, amelyek minden rendszerű DNS-szolgáltatásban megtalálhatók.


Legfelső szintű tartományok

Az alábbi lista az Interneten leggyakrabban használt nyolc legfelső szintű tartományt tartalmazza, melyekkel a cégek tevékenységi típus szerint osztályba sorolhatók a második szintű tartománynév bejegyzésekor. A microsoft.com például (A Microsoft által bejegyzett második szintű tartománynév) a „com” tartományba van regisztrálva, mert ez a legfelső szintű tartomány tartalmazza az Interneten megjelenő üzleti (kereskedelmi) tevékenységet folytató cégeket.

Legfelső szintű név | Leírás | A tartományt használó szervezet
arpa | Az Advanced Research Project Agency (ARPA) tulajdona. Az Internet Assigned Number Authority (IANA) által kiosztott 4-es verziójú Internet protokoll (IPv4) címek DNS rendszerű tartománynévhez történő hozzárendeléseinek bejegyzésére használatos ilyen címeket használó számítógépek esetében. | Az in-addr.arpa tartomány.
com | Üzleti és kereskedelmi célokat szolgál. | Cégek, vállalkozások.
edu | Oktatási intézményeknek fenntartva. | Állami és magániskolák, főiskolák, egyetemek.
gov | Kormányzati intézmények számára fenntartva. | Helyi, állami és szövetségi állami szervek.
int | Nemzetközi használatra fenntartva. Az 1886-os számú RFC-dokumentumban szereplő tervek szerint az IANA által kiosztott 6-os verziójú Internet protokoll (IPv6) címek ip6.int tartományban lévő DNS tartománynevekhez történő hozzárendeléseinek bejegyzésére lesz használatos az ilyen címeket használó számítógépek esetében. | Az ip6.int tartomány.
mil | Katonai szervezetek számára fenntartva. | Az amerikai hadügyminisztérium, haditengerészet, hadsereg, légierő és az Egyesült Államok egyéb katonai szervezetei számára fenntartva.
net | A név olyan cégek számára van fenntartva, melyek kiterjedt internetes vagy telefonos szolgáltatásokat nyújtanak. | Az InterNIC, az AT&T és más nagyobb Internet- és telefonszolgáltatók.
org | Kereskedelmi tevékenységet nem végző nonprofit szervezetek számára fenntartva. | Egyházak, jótékonysági szervezetek.

Megjegyzés

  • Az itt felsorolt hárombetűs legfelső szintű tartományok mellett kétbetűs kódok is használatosak országok vagy földrajzi térségek jelölésére (Magyarországra például a „hu” kód utal). Ezeket az ország- vagy területkódokat a felsorolt hárombetűs kódokkal együtt is lehet használni az internetes DNS-névtérben regisztrálandó cég származási országának vagy területének pontosabb megadására.


DNS bibliográfia

A Tartománynévrendszerrel (DNS) vagy egyéb DNS-kiszolgálókkal kapcsolatban tanulmányozza az alábbi forrásmunkákat:

  • Albitz, P., Loukides, M. and C. Liu. 1998. DNS and BIND, Third Edition (A DNS és a BIND). Sebastopol, California: O'Reilly and Associates, Inc.
  • Albitz, P., Larson, M. and C. Liu. 1998. DNS on Windows NT (A DNS Windows NT rendszeren). Sebastopol, California: O'Reilly and Associates, Inc.
  • Comer, D. 1995. Internetworking with TCP/IP, Vol. 1, Third Edition (TCP/IP alapú összetett hálózatok). Englewood Cliffs, New Jersey: Prentice Hall.
  • Masterson, M., Knief, H., Vinick, S. and E. Roul. 1998. Windows NT DNS (A Windows NT alapú DNS). Indianapolis, Indiana: New Rider Publishing.


Hibaelhárítás

A rész tartalma:

  • DNS-ügyfelekkel kapcsolatos hibák elhárítása
  • DNS-kiszolgálók hibaelhárítása
  • Dinamikus frissítések hibaelhárítása
  • Zónaproblémák hibaelhárítása


A DNS-ügyfelekkel kapcsolatos hibák elhárítása

Mi a probléma?

A DNS-ügyfél a következő hibaüzenetet kapta: „A név nem található.”

Ok: A DNS-ügyfélszámítógép nem rendelkezik érvényes IP-konfigurációval a hálózathoz.

Megoldás: Ellenőrizze az ügyfélszámítógép TCP/IP-beállításait, különös tekintettel a DNS-névhozzárendelés során használt beállításokra.

Adott ügyfél IP-konfigurációját az ipconfig paranccsal ellenőrizheti. A kapott adatok alapján ellenőrizze, hogy az ügyfél rendelkezik-e érvényes IP-címmel, alhálózati maszkkal és alapértelmezett átjáróval ahhoz a hálózathoz, amelyhez csatlakozik.

Ha az ügyfél nem rendelkezik érvényes TCP/IP-konfigurációval, a következő lehetőségek közül választhat:

  1. Dinamikusan konfigurált ügyfelek esetén az ipconfig /renew paranccsal kézileg adhatja meg, hogy az ügyfélszámítógép frissítse IP-címkonfigurációját a DHCP-kiszolgálón.
  2. Statikusan konfigurált ügyfelek esetén módosítsa az ügyfél TCP/IP-tulajdonságait az érvényes konfigurációs beállítások szerint, illetve állítsa be DNS-konfigurációját a hálózatnak megfelelően.

Lásd még: Ipconfig; A TCP/IP protokoll beállítása dinamikus címzésre; A TCP/IP protokoll beállítása statikus címzésre; A TCP/IP beállítása a DNS használatához; Az ügyfélszámítógép beállításainak módosítása.

Ok: Hálózati vagy hardverhiba miatt az ügyfél nem tudott kapcsolatba lépni a DNS-kiszolgálóval.

Megoldás: Ellenőrizze, hogy az ügyfélszámítógép rendelkezik-e érvényes és működő hálózati csatlakozással. Először az ügyfélszámítógépen ellenőrizze a különböző hardverelemek (kábelek és hálózati csatolók) működését.

Ha az ügyfélhardver telepítése és működése megfelelőnek tűnik, ellenőrizze, hogy kapcsolatba tud-e lépni ugyanannak a hálózatnak a többi számítógépével.

Lásd még: Hardver hibaelhárító

Ok: A DNS-ügyfél nem tud kapcsolatba lépni konfigurált DNS-kiszolgálóival.

Megoldás: Ha a DNS-ügyfél rendelkezik hálózati kapcsolattal, ellenőrizze, hogy kapcsolatba tud-e lépni egy elsődleges (vagy másik) DNS-kiszolgálóval.

Ha ellenőrizni kívánja, hogy az ügyfél rendelkezik-e alapvető TCP/IP-hozzáféréssel a DNS-kiszolgálóhoz, küldjön ping parancsot az elsődleges DNS-kiszolgáló IP-címére.

Ha például az ügyfél elsődleges DNS-kiszolgálójának címe 10.0.0.1, akkor az ügyfélszámítógép parancssorába írja be a ping 10.0.0.1 parancsot. Ha nem ismeri pontosan az elsődleges DNS-kiszolgáló IP-címét, akkor kérdezze le az ipconfig parancs segítségével.

Például az ipconfig /all|more parancsot írja be az ügyfélszámítógépen, ha a DNS-kiszolgálók listázását szeretné megállítani, amíg a listában szereplő IP-címeket elolvassa vagy feljegyzi.

Ha egyetlen konfigurált DNS-kiszolgáló sem válaszol a ping parancsra, akkor a probléma valószínűleg az ügyfél és a DNS-kiszolgáló közötti hálózati kapcsolatból származik. Ebben az esetben a TCP/IP-hálózat hibaelhárító lépéseivel folytassa a hibaelhárítást.

Lásd még: A TCP/IP-beállítások tesztelése a ping paranccsal; Hálózati (TCP/IP) hibaelhárító.

Ok: A DNS-kiszolgáló nem működik vagy nem válaszol a lekérdezésekre.

Megoldás: Ha a DNS-ügyfél a ping parancs révén kapcsolatba tudott lépni a DNS-kiszolgálóval, akkor ellenőrizze, hogy a DNS-kiszolgáló elindult-e, továbbá megkapja-e az ügyfél kérelmeit, és válaszol-e azokra. Az nslookup paranccsal ellenőrizheti, hogy a kiszolgáló képes-e válaszolni a DNS-ügyfeleknek.

Lásd még: DNS-kiszolgáló válaszképességének ellenőrzése az nslookup paranccsal; DNS-kiszolgáló indítása és leállítása.

Ok: Az ügyfél által használt DNS-kiszolgálónak nincs jogosultsága a sikertelenül kért névhez, és nem találja az adott névhez jogosultsággal rendelkező kiszolgálót.

Megoldás: Ellenőrizze, hogy az ügyfél által hozzárendelni kívánt DNS-tartománynévhez a konfigurált DNS-kiszolgálók rendelkeznek-e jogosultsággal.

Ha például az ügyfél az allomas.pelda.microsoft.com nevet próbálja hozzárendelni, ellenőrizze, hogy az ügyfél által lekérdezett elsődleges (vagy adott esetben más) DNS-kiszolgáló letölti-e azt a jogosultsági zónát, ahol a sikertelenül kért névre vonatkozó állomás (A) típusú erőforrásrekordnak léteznie kell.

Ha az elsődleges kiszolgáló jogosult a sikertelenül kért név kezelésére és le is tölti a megfelelő zónát, akkor ellenőrizze, hogy a megfelelő rekordok nem hiányoznak-e a zónából. Ha szükséges, vegye fel a rekordokat a zónába.

Ha az elsődleges kiszolgáló nem jogosult a sikertelenül kért név kezelésére, akkor valószínűleg a DNS-kiszolgáló konfigurációs hibái okozzák a problémát. Ha szükséges, a DNS-kiszolgálón végezzen további hibaelhárítást.

Lásd még: Erőforrásrekordok kezelése; DNS-kiszolgálók hibaelhárítása.

Úgy tűnik, hogy a DNS-ügyfél elavult vagy hibás információt tartalmazó választ kapott.

Ok: Az ügyfél által használt DNS-kiszolgálónak nincs engedélye a sikertelenül kért névhez, és a helyi DNS-adatbázisból származó elavult információkat használja.

Megoldás: Állapítsa meg, hogy a DNS-kiszolgáló jogosult-e a név kezelésére, és ennek megfelelően lépjen tovább.

Ha például az ügyfél az allomas.pelda.microsoft.com nevet próbálja hozzárendelni, ellenőrizze, hogy az ügyfél által lekérdezett elsődleges (vagy adott esetben más) DNS-kiszolgáló letölti-e azt a jogosultsági zónát, ahol a sikertelenül kért állomásnévre vonatkozó (A) erőforrásrekordnak léteznie kell.

Ha az elsődleges kiszolgáló az adott név szempontjából mérvadó, és hibás adattal válaszolt, akkor ez azt jelzi, hogy a megfelelő zóna alkalmazható erőforrásrekordjai elavult vagy lejárt információkat tartalmazhatnak. Ebben az esetben a megfelelő erőforrásrekordokat felveheti a zónába, illetve törölheti onnan.

Ha a dinamikus frissítés engedélyezett, akkor egy másik lehetőség a regisztrálás és frissítés elvégzése a célszámítógépen. Ha a célszámítógépen Windows 2000 rendszer fut, akkor az erőforrásrekordjaira vonatkozó regisztráció frissítését elvégezheti az ipconfig /registerdns paranccsal.

Ha az elsődleges kiszolgáló nem közvetlen hitelesítője a lekérdezett névnek, akkor valószínű, hogy a lekérdezésre egy korábbi rekurzív keresés során kapott és gyorsítótárba helyezett információk alapján válaszolt. Ebben az esetben érdemes számításba venni a kiszolgálóneveket tartalmazó gyorsítótár törlésének lehetőségét. Ez arra kényszeríti a kiszolgálót, hogy új rekurzív lekérdezéseket használjon ezekhez az erőforrásrekordokhoz, és újraépítse a gyorsítótár tartalmát az aktuális információk alapján.

Lásd még: Erőforrásrekordok kezelése; DNS-kiszolgálók hibaelhárítása; DNS-ügyfél regisztrációjának megújítása az ipconfig paranccsal; A kiszolgáló névgyorsítótárának ürítése.

Ok: Az elsődleges DNS-kiszolgáló a célnevet tartalmazó zóna másodlagos kiszolgálója, és elavult információkat tartalmaz.

Megoldás: Ha az ügyfélnek válaszoló kiszolgáló az adott zóna tartalék kiszolgálója, akkor az azon használt zónaverzió elavult lehet, és gyakoribb frissítést igényel.

Azonnali megoldásként zónaletöltést kezdeményezhet a másodlagos kiszolgálóról annak főkiszolgálójára a zóna frissítése érdekében. A másodlagos zóna jövőbeli frissességének javítása érdekében érdemes megfontolni a következő lehetőségeket:

  1. Adjon meg további főkiszolgálókat a másodlagos kiszolgálóhoz, amelyeket zóna frissítésekor használhat.
  2. Kis mértékben módosítsa a frissítési időközt úgy, hogy a zóna összes mérvadó kiszolgálója valamivel rövidebb ideig használhassa a zónát, mielőtt azt frissítenie kellene.
  3. Konfiguráljon egy értesítési listát az egyik főkiszolgálón, amely a másodlagos kiszolgáló zónaforrásaként működik, és engedélyezze, hogy a zóna megváltozása esetén értesítse ezt a kiszolgálót.

Lásd még: Zónaletöltés kezdeményezése másodlagos kiszolgálóról; Zóna frissítési időközének beállítása; Zóna értesítési listáinak létrehozása és kezelése; Másodlagos kiszolgálók használata; A zónák és a zónaletöltés ismertetése.

Ok: A lekérdezett név hibásan lett megadva, mert a felhasználó rosszul adta meg, vagy a tárolt ügyfélkonfiguráció hibás.

Megoldás: Ellenőrizze a megadott név helyességét abban az alkalmazásban, amelyből a névlekérdezés származik.

Ha a lekérdezésre adott pozitív válaszban hibás adatok szerepelnek, akkor az az alábbi három lehetőség egyikére utal:

  • Az ügyfélszámítógépen a felhasználó hibás DNS-nevet adott meg.
  • Az ügyfélgép rövid, nem minősített nevet használ, amelyet a helyi névhozzárendelő program véletlenszerű DNS-utótaggal egészített ki.
  • A lekérdezésben megadott erőforrásrekordok nem lettek megfelelően frissítve a DNS-kiszolgálón.

Ellenőrizze, hogy a nevet a felhasználó helyesen adta-e meg. Ellenőrizze, hogy a felhasználó pontosan milyen karaktersorozatot adott meg az eredeti DNS-lekérdezés létrehozásakor, vagy ellenőrizze az alkalmazások , például az internetes levelezőprogram vagy böngésző beállításait.

Ha az első lekérdezésben használt név nem volt minősített, és az nem a teljesen minősített tartománynév (FQDN), akkor az ügyfélalkalmazásban inkább próbálkozzon a teljesen minősített tartománynév használatával és a lekérdezés megismétlésével. Ilyen esetben ne felejtsen el pontot (.) használni a név végén annak jelölésére, hogy a beírt név a pontos teljesen minősített tartománynév.

Ha a teljesen minősített tartománynévvel végzett lekérdezés sikeres és a válaszban a megfelelő adatok szerepelnek, akkor a hiba legvalószínűbb oka az ügyfél névhozzárendelő programjában használt, hibásan konfigurált DNS-utótag keresési lista lehet.

Ha olyan környezetben használja a DNS szolgáltatást, amely nem támogatja a dinamikus frissítéseket, vagy ha a zónaadatok felügyeletét rendszerint kézzel végzi, ellenőrizheti, hogy a lekérdezésekre adott válaszokban szereplő rekordok helyesen vannak-e megadva. Jelenítse meg a rekordokat, ellenőrizze a zónában tárolt adatok helyességét, és ha kell, módosítsa azokat.

Lásd még: A TCP/IP beállítása a DNS használatához; Zóna meglévő erőforrásrekordjának módosítása.

Ok: Lehet, hogy az elsődleges zóna nem tartalmazza a szükséges adatokat, vagy azok hibásak.

Megoldás: Ellenőrizze, hogy a zóna elsődleges kiszolgálója teljes és pontos adatokkal rendelkezik-e.

Egy zóna elsődleges DNS-kiszolgálója esetében az adatok hiányának vagy hiányosságának legvalószínűbb oka egy sikertelen frissítési kérelem. Lehetséges, hogy a dinamikus frissítés támogatása nincs teljesen telepítve vagy konfigurálva. A probléma megoldásához vizsgálja át a DNS dinamikus frissítési protokollt és mindazokat a követelményeket, amelyeket az azt használó DNS-kiszolgálókkal és ügyfelekkel szemben támaszt.

Címtárat használó zónák esetén az is lehetséges, hogy a hibás lekérdezéshez kapcsolódó rekordok frissítése az Active Directoryban megtörtént, a zónát betöltő DNS-kiszolgálókon viszont nem. Alapértelmezés szerint az Active Directoryból zónákat letöltő DNS-kiszolgálók előre beállított időközönként (rendszerint 15 percenként) lekérdezi azt, majd a zónát a növekményes változásoknak megfelelően frissíti. Alapértelmezett replikációs beállítások és megbízható, gyors kapcsolatok megléte esetén nem egészen 20 perc szükséges ahhoz, hogy a frissítés során a replikációk az Active Directory tartománykörnyezetekben használt valamennyi DNS-kiszolgálóra rákerüljenek.

Ha a zónák konfigurálása során letiltotta a dinamikus frissítést, ne feledje, hogy a zónákon belül használt legtöbb erőforrásrekord-típus esetében kézzel kell végrehajtani a hozzáadást és a frissítést. Ilyenkor az érintett rekordokat a DNS-konzol segítségével jelenítheti meg és frissítheti.

A hibás adatokkal kapcsolatos másik lehetőség attól függ, hogy a WINS-lekérdezés integrációja a zónában engedélyezett-e, illetve használatban van-e. Ha a zónákra a WINS-lekérdezést használja, akkor ellenőrizze, hogy nem a WINS szolgáltat-e hibás adatokat.

Lásd még: Dinamikus frissítések hibaelhárítása; Erőforrásrekordok kezelése; Erőforrásrekordok kezelése; A WINS szolgáltatás ellenőrzése a DNS-lekérdezések megválaszolásának forrásaként.

A DNS-kiszolgálót valószínűleg a fent leírtaktól eltérő probléma érinti.

Ok: A probléma leírása feljebb nem szerepel.

Megoldás: A Microsoft webhelyén keresse meg azokat a legfrissebb technikai információkat, amelyek a megfigyelt problémával kapcsolatosak lehetnek. Szükség esetén a fennálló problémával vagy hibával kapcsolatos tudnivalókhoz és utasításokhoz is hozzájuthat.

Ha rendelkezik Internet-kapcsolattal, a Windows 2000 Server legújabb frissítéseit a Microsoft webhelyen szerezheti be. (http://www.microsoft.com/)

A Windows NT Server legújabb Service Pack (javítócsomag) frissítéseit szintén a Microsoft webhelyén találja. (http://www.microsoft.com/)

Ismerkedjen meg a DNS szolgáltatással kapcsolatos más hasznos dokumentációkkal és forrásokkal. Ilyen például a DNS hibaelhárító.

Lásd még: Frissített technikai információ a DNS-ről, DNS, Windows 2000 Resource Kit, angol és magyar Microsoft webhely. (http://www.microsoft.com/)


DNS-kiszolgálók hibaelhárítása

Mi a probléma?

A DNS-kiszolgáló nem válaszol az ügyfeleknek.

Ok: A DNS-kiszolgáló működését hálózati hiba zavarja.

Megoldás: Győződjön meg róla, hogy a kiszolgáló érvényes és működő hálózati kapcsolattal rendelkezik. Elsőként ellenőrizze, hogy az ügyfelen lévő hálózati hardver (kábelek és hálózati csatolók) megfelelően működik-e.

Ha a kiszolgáló hardvereszközeinek telepítése és működése megfelelőnek tűnik, akkor a ping parancs segítségével ellenőrizze a hálózati kapcsolat épségét a hálózatban működő más számítógépekkel vagy útválasztókkal (például az alapértelmezett átjáróval).

Lásd még: Hardver hibaelhárító; Hálózati (TCP/IP) hibaelhárító

Ok: A DNS-kiszolgáló elérhető az hálózat tesztelése során, azonban nem válaszol az ügyfelek DNS-lekérdezéseire.

Megoldás: Ha a DNS-ügyfél a ping paranccsal el tudja érni a DNS-kiszolgálót, akkor ellenőrizze, hogy a DNS-kiszolgáló képes-e az ügyfelek kérelmeit figyelni és megválaszolni. Próbálja meg az nslookup paranccsal tesztelni, hogy a kiszolgáló képes-e válaszolni a DNS-ügyfeleknek.

Lásd még: A DNS-kiszolgáló válaszképességének ellenőrzése az nslookup parancs használatával; A DNS-kiszolgáló indítása és leállítása.

Ok: A DNS-kiszolgáló úgy van konfigurálva, hogy a beállított IP-címek közül csak egy meghatározott csoport számára végez szolgáltatást. A válaszképesség ellenőrzésére eredetileg használt IP-cím nem szerepel ebben a csoportban.

Megoldás: Ha a kiszolgálót előzőleg úgy konfigurálták, hogy csak bizonyos IP-címekről érkező lekérdezésekre válaszoljon, akkor lehetséges, hogy az ügyfelek által a kapcsolatfelvételre használt IP-cím nem szerepel a szolgáltatás igénybevételére engedélyezett IP-címek listájában.

Tesztelje újra a kiszolgáló válaszképességét olyan másik IP-cím megadásával, amelyről biztosan tudja, hogy szerepel a kiszolgálón beállított listában. Ha a DNS-kiszolgáló választ küld erre a címre, akkor vegye fel a hiányzó IP-címet a listába.

Lásd még: DNS-kiszolgálók válaszképességének ellenőrzése az nslookup parancs használatával; DNS-kiszolgáló működésének korlátozása kijelölt címek figyelésére.

Ok: A DNS-kiszolgáló konfigurációjában le van tiltva az automatikusan létrehozott alapértelmezés szerinti névkeresési zónák használata.

Megoldás: Ellenőrizze, hogy a kiszolgáló névkeresési zónáinak automatikus létrehozása megtörtént, illetve a kiszolgáló speciális beállításait előzőleg nem módosították.

Alapértelmezés szerint a Windows 2000 DNS-kiszolgálói, az RFC-ajánlásoknak megfelelően, az alábbi három szabványos névkeresési zónát hozzák létre automatikusan:

Ezek a zónák közös IP-címekkel jönnek létre (0.0.0.0, 127.0.0.1 és 255.255.255.255), amelyek névkeresésre nem használhatók. Mivel a DNS-szolgáltatás az említett címeknek megfelelő zónákhoz mérvadó, az ilyen típusú címekre vonatkozó névkeresések végrehajtásakor lehetőleg nem fordul szükségtelenül a gyökérkiszolgálókhoz.

Bár valószínűtlen, de lehetséges, hogy ezek az automatikus zónák nem jönnek létre. Ennek oka az, hogy a kiszolgáló rendszerleíró adatbázisában a felhasználó kézileg letiltotta a zónák létrehozását.

A következő műveletekkel ellenőrizheti, hogy ezek a zónák az adott Windows 2000 DNS-kiszolgálón valóban létrejöttek:

  1. Nyissa meg a DNS-konzolt.
  2. A Nézet menüben kattintson a Speciális parancsra.
  3. A konzolfán kattintson a Névkeresési zónák elemre.

    Helye:

    • DNS
    • az adott DNS-kiszolgáló
    • Névkeresési zónák
  4. A részleteket megjelenítő ablaktáblán ellenőrizze, hogy jelen vannak-e a következő névkeresési zónák:
    • 0.in-addr.arpa
    • 127.in-addr.arpa
    • 255.in-addr.arpa

Lásd még: A DNS-konzol megnyitása.

Ok: A DNS-kiszolgáló nem alapértelmezett szolgáltatásport használatára van konfigurálva, például különleges adatbiztonsági vagy tűzfal-konfiguráció esetén.

Megoldás: Győződjön meg róla, hogy a DNS-kiszolgáló nem használ speciális konfigurációt.

Ez ritka, de lehetséges ok. Alapértelmezés szerint az nslookup parancs az 53-as User Datagram protokoll (UDP) porton keresztül küldi a lekérdezéseket a DNS-kiszolgálókhoz. Ha a DNS-kiszolgáló egy másik, csak köztes állomáson (például csomagszűrő útválasztón vagy proxykiszolgálón) keresztül elérhető hálózathoz tartozik, akkor lehetséges, hogy a DNS-kiszolgáló nem szabványos porton keresztül figyeli és fogadja az ügyfélkérelmeket.

Ilyen esetben ellenőrizze, hogy valamelyik köztes tűzfal vagy proxykiszolgáló nincs-e úgy konfigurálva, hogy szándékosan gátolja a DNS-hez használt ismert szolgáltatásportok forgalmát. Ha nincs ilyen, akkor hozzáadhat egy olyan csomagszűrőt, melynek segítségével a szabványos DNS-portokon keresztüli adatforgalom lehetővé válik.

Ellenőrizze továbbá a DNS-kiszolgáló eseménynaplójában, hogy előfordultak-e 414-es azonosítójú, vagy a szolgáltatással kapcsolatos más kritikus események, ami magyarázatot adhatna a DNS-kiszolgáló válaszképtelenségére.

Lásd még: A DNS-kiszolgáló naplózása; A DNS-kiszolgáló rendszer-eseménynaplójának megjelenítése; Windows 2000 Resource Kit.

A DNS-kiszolgáló nem rendeli hozzá megfelelően a neveket.

Ok: A DNS-kiszolgáló hibás adatokat szolgáltat azokra a lekérdezésekre, amelyekre egyébként sikeresen válaszol.

Megoldás: Állapítsa meg a hibás adatok megjelenésének okát a DNS-kiszolgálón.

Néhány a legvalószínűbb okok közül:

  • Az erőforrásrekordok dinamikus frissítésére nem került sor egy zónában.
  • Hiba történt a statikus erőforrásrekordok kézi felvétele vagy módosítása során.
  • Gyorsítótáras keresésekből megmaradt, elavult erőforrásrekordok találhatók a DNS-kiszolgáló adatbázisában, a zónarekordok aktuális információkkal való frissítése nem történt meg, vagy a zónarekordok törlődnek, amikor már nincs rájuk szükség.

A leggyakoribb problémák elkerülése érdekében tanulmányozza a DNS-kiszolgálók telepítésével és kezelésével kapcsolatos gyakorlati tanácsokat és javaslatokat. Használja továbbá azokat a feladatlistákat, amelyek a DNS-kiszolgálók és -ügyfelek igény szerinti telepítéséhez és beállításához szükségesek.

Ha a DNS szolgáltatást az Active Directoryval kívánja használni, ne feledkezzen meg az új címtárintegrálási szolgáltatásokról. Ha a DNS-adatbázis integrálva van a címtárral, akkor ezek a szolgáltatások bizonyos eltéréseket okozhatnak a Windows 2000 DNS-kiszolgáló alapértelmezett beállításaiban a hagyományos, fájlokra épülő tárolás alapértelmezéseihez képest.

A DNS-kiszolgálókkal kapcsolatos problémák nagy része az ügyféloldali sikertelen lekérdezésekből ered, ezért érdemes a hibaelhárítást a DNS-ügyfélnél kezdeni.

Lásd még: Gyakorlati tanácsok; Feladatlisták; DNS-ügyfelekkel kapcsolatos hibaelhárítás; Egy zóna meglévő erőforrásrekordjainak módosítása; A kiszolgáló névgyorsítótárának ürítése; A kiszolgáló alapértelmezett beállításainak módosítása.

Ok: A közvetlen hálózaton kívüli, például külső hálózatokhoz vagy az Internethez kapcsolódó számítógépekhez a DNS-kiszolgáló nem végzi el a névhozzárendelést.

Megoldás: A kiszolgálónak a rekurzió végrehajtásával kapcsolatos problémája van. A DNS-konfigurációk többségében a rekurzió szolgál az olyan nevek hozzárendelésére, amelyek a DNS-kiszolgálók és ügyfelek által használt konfigurált DNS-tartománynéven kívül találhatók.

Ha egy DNS-kiszolgáló nem tud hozzárendelni egy nevet, amelyhez nem mérvadó, akkor az ok rendszerint egy sikertelen rekurzív lekérdezés. A DNS-kiszolgálók gyakran használnak rekurzív lekérdezéseket más DNS-zónákhoz és kiszolgálókhoz delegált távoli nevek hozzárendelésére.

A rekurzió sikeres működéséhez a rekurzív lekérdezés útvonalán lévő valamennyi DNS-kiszolgálónak képesnek kell lennie válaszadásra és helyes adatok továbbítására. A rekurzív lekérdezés a következő okok valamelyike miatt hiúsulhat meg:

  • A rekurzív lekérdezés befejezése előtt lejár a megszabott időhatár.
  • Egy távoli DNS-kiszolgáló nem válaszol.
  • Egy távoli DNS-kiszolgáló hibás adatokat szolgáltat.

Ha egy kiszolgáló nem tud rekurzív lekérdezést végrehajtani egy távoli névre vonatkozóan, akkor a lehetséges okok áttekintésével keresse meg a hibát. Ha nincs tisztában a rekurzióval vagy a DNS-lekérdezési folyamattal, akkor a fogalmak megértéséhez olvassa el a súgó kapcsolódó részét.

Lásd még: A DNS-lekérdezés működése.

Ok: A DNS-kiszolgáló nincs megfelelően konfigurálva ahhoz, hogy a lekérdezések megválaszolásához más DNS-kiszolgálók segítségét igénybe vegye.

Megoldás: Ellenőrizze, hogy a DNS-kiszolgáló képes-e továbbítókat és rekurziót alkalmazni.

Alapértelmezés szerint valamennyi Windows 2000 DNS-kiszolgáló esetében engedélyezett a rekurzió használata, azonban a DNS-konzol használatával a kiszolgáló speciális beállításai között ez a lehetőség letiltható. A rekurzió akkor is le lehet tiltva, ha a kiszolgáló továbbítók használatára van konfigurálva, és a rekurzió az adott konfigurációra vonatkozóan le van tiltva.

Lásd még: Rekurzió letiltása a DNS-kiszolgálón; Továbbítók használatának beállítása a DNS-kiszolgálón.

Ok: A DNS-kiszolgáló aktuális gyökérútmutatói érvénytelenek.

Megoldás: Ellenőrizze a kiszolgáló gyökérútmutatóinak érvényességét.

Megfelelő konfiguráció és használat esetén a gyökérútmutatónak mindig azokra a DNS-kiszolgálókra kell mutatnia, amelyek a tartománygyökeret és a legfelső szintű tartományokat tartalmazó zóna szempontjából mérvadók.

Alapértelmezés szerint a Windows 2000 DNS-kiszolgálói az adott telepítéshez megfelelő gyökérútmutató használatára vannak beállítva vagy frissítve. A kiszolgáló DNS-konzolon keresztül történő konfigurálásakor az alábbi választási lehetőségek állnak rendelkezésre :

  1. Ha a DNS-kiszolgáló a hálózat első DNS-kiszolgálójaként van telepítve, akkor gyökérkiszolgálóként van konfigurálva.

    Ilyen konfiguráció esetén a gyökérútmutató le van tiltva a kiszolgálón, mert a kiszolgáló a gyökérzóna szempontjából mérvadónak számít.

  2. Ha a kiszolgáló nem az első DNS-kiszolgáló a hálózaton, akkor a DNS-kiszolgáló konfigurálása varázslót beállíthatja úgy, hogy frissítse a gyökérútmutatót a hálózat egyik meglévő DNS-kiszolgálójáról.
  3. Ha a hálózaton nincs másik DNS-kiszolgáló, de továbbra is szükség van a DNS-nevek feloldására, akkor az alapértelmezett gyökérútmutató-fájl használható, amelyben megtalálható az Internet DNS-névtér számára mérvadó internetes gyökérkiszolgálók listája.

Lásd még: Gyökérútmutató frissítése a DNS-kiszolgálón; Gyökérútmutató frissítése.

Ok: A DNS-kiszolgáló a gyökérkiszolgálók felé nem rendelkezik hálózati kapcsolattal.

Megoldás: Ellenőrizze a hálózati kapcsolatot a gyökérkiszolgálók felé.

Ha a gyökérútmutató beállítása helyesnek tűnik, akkor ellenőrizze, hogy a sikertelen lekérdezésben alkalmazott DNS-kiszolgáló a ping paranccsal el tudja-e érni a gyökérkiszolgálóit azok IP-címén keresztül.

Ha az egyik gyökérkiszolgálóra küldött ping parancs végrehajtása nem sikerül, akkor lehet, hogy az adott gyökérkiszolgáló IP-címe megváltozott. Gyökérkiszolgálók átkonfigurálása azonban ritkán fordul elő.

Valószínűbb ok lehet a hálózati kapcsolat teljes elvesztése, illetve néhány esetben a DNS-kiszolgáló és annak konfigurált gyökérkiszolgálói között lévő köztes hálózati kapcsolatok gyenge teljesítménye. A TCP/IP-hálózat vizsgálatával állapítsa meg, hogy valóban ez jelenti-e a problémát.

Alapértelmezés szerint a DNS-kiszolgáló rekurziós időtúllépési korlátja 15 másodperc, amely után a rekurzív lekérdezés sikertelennek minősül. Normál hálózati feltételek mellett ezt az időtúllépést nem kell megváltoztatni, ha azonban a teljesítmény szükségessé teszi, megnövelheti ezt az értéket.

A DNS-lekérdezésekkel kapcsolatos további teljesítményadatok megtekintéséhez engedélyezheti és használhatja a DNS-kiszolgáló hibakeresési naplófájlját (Dns.log), amely bőséges információt ad a szolgáltatással kapcsolatos események néhány típusáról.

Lásd még: A TCP/IP-konfiguráció tesztelése a ping parancs használatával; A kiszolgáló hibakereső naplózási beállításainak használata; DNS-kiszolgáló hibakeresési naplófájljának megjelenítése; A kiszolgáló speciális paramétereinek beállítása.

Ok: Más problémák állnak fenn a DNS-kiszolgáló adatainak frissítésével kapcsolatban, például a zónákkal vagy a dinamikus frissítésekkel kapcsolatos hibák.

Megoldás: Állapítsa meg, hogy a probléma a zónákkal kapcsolatos-e. Szükség esetén hárítsa el a felmerült hibákat, például a zónaletöltés esetleges problémáit.

Lásd még: Dinamikus frissítésekkel kapcsolatos hibaelhárító; Zónaproblémákkal kapcsolatos hibaelhárító.

A DNS-kiszolgáló működését valószínűleg a fent leírtaktól eltérő probléma befolyásolja.

Ok: A probléma leírása feljebb nem szerepel.

Megoldás: A Microsoft webhelyén keresse meg azokat a legfrissebb technikai információkat, amelyek a megfigyelt problémával kapcsolatosak lehetnek. Szükség esetén a fennálló problémával vagy hibával kapcsolatos tudnivalókhoz és utasításokhoz is hozzájuthat.

Ha rendelkezik Internet-kapcsolattal, a Windows 2000 Server legújabb frissítéseit a Microsoft webhelyen szerezheti be. (http://www.microsoft.com/)

A Windows NT Server legújabb Service Pack (javítócsomag) frissítéseit szintén a Microsoft webhelyén találja. (http://www.microsoft.com/)

Ismerkedjen meg a DNS szolgáltatással kapcsolatos más hasznos dokumentációkkal és forrásokkal. Ilyen például a DNS hibaelhárító.

Lásd még: Frissített technikai információ a DNS-ről, DNS, Windows 2000 Resource Kit, angol és magyar Microsoft webhely. (http://www.microsoft.com/)


Dinamikus frissítések hibaelhárítása

Mi a probléma?

A DNS-ügyfél nem hajtja végre a dinamikus frissítéseket.

Ok: Az ügyfél (vagy annak DHCP-kiszolgálója) nem támogatja a DNS dinamikus frissítési protokoll használatát.

Megoldás: Ellenőrizze, hogy az ügyfelek vagy a kiszolgálók támogatják-e a DNS dinamikus frissítési protokollt a Windows 2000 által biztosított dinamikus frissítési lehetőségeknek megfelelően.

Ügyfélszámítógépeket a következő módokon regisztrálhat és frissíthet a DNS-kiszolgálón:

  1. Az ügyfélszámítógépekre telepítse a Windows 2000 operációs rendszert.
  2. Telepítsen egy Windows 2000 DHCP-kiszolgálót a hálózaton, és használja azt ügyfélszámítógépek bérlésére.

Alapértelmezés szerint a Windows 2000 bármely verziójával működő számítógépek megkísérlik DNS-neveik és IP-címeik regisztrálását és dinamikus frissítését egy DNS-kiszolgálón.

Nem Windows 2000 operációs rendszert használó számítógépekhez olyan Windows 2000 DHCP-kiszolgálókat alkalmazhat, amelyek képesek proxy alapú regisztrációk és frissítések végrehajtására a nem dinamikus ügyfelek igényeinek megfelelően.

Lásd még: A DNS-kiszolgálók és a DHCP közös használata.

Ok: Az ügyfél nem tudott regisztrációt végrehajtani a DNS-kiszolgálón a DNS-kiszolgáló vagy a hálózat átmeneti meghibásodása miatt.

Megoldás: Az ügyfélszámítógépen az ipconfig paranccsal próbálja meg ismét a regisztrálást, illetve az ügyféladatok megújítását és frissítését a DNS-kiszolgálón.

A Windows 2000 operációs rendszert futtató számítógépeken az ipconfig /registerdns parancs segítségével ismételtetheti meg kézzel a dinamikus regisztráció elvégzését.

A Windows korábbi verzióit futtató számítógépeken az ipconfig parancs segítségével ellenőrizheti, megjelenítheti, illetve megújíthatja az ügyfélgép TCP/IP-konfigurációjának adatait.

Ha például az ügyfélszámítógép az IP-címre vonatkozó bérletét egy Windows 2000 DHCP-kiszolgálótól kapja, akkor az ipconfig /renew paranccsal elvégezhető a bérlet megújítása a DHCP-kiszolgálóval. Ennek hatására a DHCP-kiszolgáló az ügyfél nevében frissítési kérelmet küld saját DNS-kiszolgálójához.

Ha a DHCP-kiszolgáló sikeresen végrehajtja a frissítést a DNS-kiszolgálóval, akkor ennek eredményeként a DNS-adatbázis tartalmazni fogja az ügyfélszámítógép frissített DNS-állomásnevét és IP-címét.

Lásd még: DNS-ügyfél regisztrációjának megújítása az ipconfig paranccsal; Ügyfélcímbérletek ellenőrzése, kiadása vagy megújítása.

Ok: Az ügyfél nem tudta végrehajtani a regisztrációt és a frissítést a DNS-kiszolgálóval, mert a DNS-konfiguráció hiányzik vagy hiányos.

Megoldás: Ellenőrizze, hogy az ügyfélszámítógép hiánytalanul és hibátlanul van konfigurálva a DNS szolgáltatáshoz, és szükség szerint frissítse annak konfigurációját.

Annak, hogy az ügyfél nem tudja végrehajtani a frissítést a DNS-kiszolgálóval, egyik gyakori oka az, hogy nincs konfigurált DNS-utótagja (amely lehet akár elsődleges utótag, akár kapcsolathoz rendelt utótag). Ennek következtében előfordul, hogy az ügyfél nem a megfelelő DNS-tartománynevet próbálja regisztrálni.

Előfordulhat például, hogy az ügyfél a rövid vagy nem minősített számítógép- vagy állomásnevet próbálja legfelső szintű tartománynévként regisztrálni a gyökérzónában. Ennek oka az, hogy nincs DNS-utótag konfigurálva az ügyfélszámítógéphez, ezért a Windows 2000 a számítógép konfigurált rövid nevét (például a-allomas) teljesen minősített tartománynévnek (FQDN) tekinti. Ez csak azért fordul elő, mert a számítógépnévhez nem létezik hozzáfűzhető DNS-utótag, amely minősítené a számítógépnevet az ügyfél regisztrálása során.

Lehetőségek az ügyfél DNS-konfigurációjának frissítésére:

  1. Konfiguráljon egy elsődleges DNS-utótagot az ügyfélszámítógépen a statikus TCP/IP-ügyfelek számára.
  2. Konfiguráljon egy kapcsolathoz rendelt DNS-utótagot, amely az ügyfélszámítógépen telepített hálózati kapcsolatok egyikén használható.

Lásd még: Ügyfélszámítógép elsődleges DNS-utótagjának beállítása; A TCP/IP beállítása a DNS használatához; Ügyfelek telepítése és beállítása; Ügyfelek kezelése.

Ok: A DNS-ügyfél megpróbálta frissíteni adatait a DNS-kiszolgálóval, de ez a kiszolgálóval kapcsolatos hiba miatt nem sikerült.

Megoldás: Ha egy ügyfél kapcsolatba tud lépni a konfigurációjának megfelelő elsődleges és további DNS-kiszolgálóival, akkor a sikertelen frissítések okát valószínűleg máshol kell keresni.

A Windows 2000 operációs rendszert használó ügyfélszámítógépeken az Eseménynapló program segítségével ellenőrizheti a Rendszernapló azon üzeneteit, amelyek magyarázattal szolgálnak arra, hogy miért nem sikerült az ügyfélnek az állomás (A) vagy mutató (PTR) típusú erőforrásrekordok dinamikus frissítése.

A Rendszernapló üzeneteinek megtekintésekor érdemes szűréssel vagy rendezéssel külön megjeleníteni azokat az üzeneteket, amelyeknél az üzenet forrásaként DnsApi szerepel. Rendszerint ezek az üzenetek vonatkoznak a DNS-műveletek, például a DNS-lekérdezések vagy dinamikus frissítések működésére.

Hordozható ügyfélszámítógép esetén a sikertelen frissítések gyakori oka, hogy a frissítés elfogadásához és végrehajtásához szükséges DNS-kiszolgáló nem válaszol, ha az ügyfél a hálózat távoli helyén lép működésbe. Ezt a hálózat teljesítményével vagy felépítésével kapcsolatos problémák okozhatják. Ha ezek a problémák fennállnak vagy valószínűsíthetők, vizsgálja felül a DNS-rendszer kialakítását, és módosítsa azt a követelményeknek megfelelően.

Lásd még: Az Eseménynapló használata; A tervezés alapvető szempontjai; Dinamikus frissítés.

A DNS-kiszolgáló nem hajt végre dinamikus frissítéseket.

Ok: A DNS-kiszolgáló nem támogatja a dinamikus frissítéseket.

Megoldás: Az ügyfél által használt DNS-kiszolgálót úgy kell beállítani, hogy támogassa a DNS dinamikus frissítési protokollt a 2136-os számú RFC-dokumentum előírásai szerint.

A Windows DNS-kiszolgálók közül csak a Windows 2000 operációs rendszert használó DNS-kiszolgálók támogatják a dinamikus frissítéseket. A Windows NT Server 4.0 DNS-kiszolgálója nem támogatja a dinamikus frissítést.

Ha más DNS-kiszolgálókat is használ a hálózatban, akkor ellenőrizze, hogy azok támogatják-e a dinamikus frissítéseket.

Lásd még: Dinamikus frissítés; A DNS-kiszolgálókkal kapcsolatos RFC-dokumentumok.

Ok: A DNS-kiszolgáló támogatja a dinamikus frissítéseket, de elfogadásukhoz nincs megfelelően konfigurálva.

Megoldás: Ellenőrizze, hogy az elsődleges zóna, ahonnan ügyfelek frissítéseket igényelnek, megfelelően van-e konfigurálva a dinamikus frissítések elfogadásához.

Windows 2000 DNS-kiszolgálók esetén az új elsődleges zónák alapértelmezés szerint nem fogadnak dinamikus frissítéseket. A megfelelő elsődleges zónát letöltő DNS-kiszolgálónál módosítsa a zóna tulajdonságait úgy, hogy engedélyezze a frissítést.

Lásd még: Dinamikus frissítések engedélyezése.

Ok: A zóna adatbázisa nem érhető el.

Megoldás: Ellenőrizze, hogy a zóna frissítésre elérhető.

Ha szükséges, elsőként azt ellenőrizze, hogy létezik-e a zóna. Szabványos elsődleges zóna esetén győződjön meg róla, hogy a kiszolgáló tartalmazza a zónafájlt, és a zóna működése nem szünetel. Az Active Directoryval integrált zónák esetén győződjön meg róla, hogy a DNS-kiszolgáló tartományvezérlőként működik, és el tudja érni az Active Directory adatbázisát, mely a zónaadatokat tartalmazza.

A másodlagos zónák nem támogatják a dinamikus frissítést. Egy szabványos zóna elsődleges kiszolgálójának meghatározásához a zónahitelesítési rekordokban tekintse meg, hogy a zóna SOA és NS rekordjaiban melyik kiszolgálóra található hivatkozás. Ez a zóna elsődleges kiszolgálója, amely fogadni tudja a dinamikus frissítéseket.

Ha szükséges, a DNS-konzol segítségével elsődlegessé tehet egy másodlagos zónát, hogy a dinamikus frissítéseket fogadni tudja. A szabványos elsődleges zónák egyetlen főkiszolgálóra épülő frissítési modellt alkalmaznak, ezért csak egyetlen kiszolgáló konfigurálható a zóna dinamikus frissítéseinek elfogadására.

Ha egy másodlagos kiszolgálón a zónatípust úgy módosítja, hogy a zóna elsődleges kiszolgálójává váljon, akkor az eredeti elsődleges kiszolgálón lévő zónát távolítsa el, vagy konvertálja más (például másodlagos) zónatípusúvá, különben a zónaadatok összekeveredhetnek, ami további problémákat okozhat.

Ha azt szeretné, hogy egynél több DNS-kiszolgáló legyen képes zónafrissítés végrehajtására, akkor ajánlatos a zónát integrálni az Active Directoryval. Ehhez telepíteni kell az Active Directoryt, a kiszolgálót pedig tartományvezérlőként kell működtetni.

A zóna integrálása és a címtárban történő tárolása után további tartományvezérlők tölthetik le automatikusan a zónát, és engedélyt kapnak annak frissítésére, ha Windows 2000 DNS-kiszolgálóként működnek. Ennek oka, hogy az Active Directory támogatja a több (vagy lebegő) főkiszolgálós frissítési modellt, amelyben egynél több számítógép is frissítheti a címtáradatbázist.

Lásd még: Zóna típusának megváltoztatása; Zónák hozzáadása és eltávolítása; Hitelesítési rekordok kezelése; Az Active Directory integrálása; Hibaelhárítás.

Ok: A DNS-kiszolgáló úgy van konfigurálva, hogy csak biztonságos dinamikus frissítéseket engedélyezzen, viszont biztonsági problémák merültek fel.

Megoldás: Győződjön meg róla, hogy a zóna vagy a rekordok védelme nincs érvényben, mert ez akadályozhatja a dinamikus frissítések végrehajtását.

A biztonságos frissítés a címtárral integrált zónák esetében engedélyezhető. Ha a biztonságos dinamikus frissítés van érvényben, akkor az aktuális zóna- vagy rekordvédelem akadályozhatja a DNS-ügyfelet (vagy annak DHCP-kiszolgálóját) az állomás (A) és a mutató (PTR) típusú erőforrásrekordok frissítésében.

A biztonságos dinamikus frissítés általában nem gátolja új rekordok létrehozását és valamelyik zónához való hozzáadását, viszont korlátozza azok körét, akik jogosultak a rekordok frissítésére vagy módosítására. Ha szükséges, a hozzáférés-szabályozási lista szerkesztési funkcióival módosíthatja a címtárral integrált zónák és erőforrásrekordok biztonsági engedélyeit, és megadhatja, hogy a frissítést másik felhasználó, csoport vagy számítógép is elvégezhesse.

Erre rendszerint csak akkor van szükség, ha a frissítést kérő számítógép nem azonos az ügyfélrekordokat tároló és eredetileg létrehozó számítógéppel.

Lásd még: Biztonságos dinamikus frissítés; Címtárba integrált zóna biztonsági beállításának módosítása; Erőforrásrekord biztonsági beállításainak módosítása.

Ok: A frissítés elvégzésére kért DNS-kiszolgáló nem érhető el a hálózaton.

Megoldás: Ellenőrizze, hogy a DNS-kiszolgáló elérhető-e a hálózaton, illetve szükség esetén végezzen további hibaelhárítást.

Lásd még: DNS-kiszolgálók hibaelhárítása.

A dinamikus frissítéssel kapcsolatban felmerült probléma nem szerepel a fentiek között.

Ok: A probléma leírása feljebb nem szerepel.

Megoldás: A Microsoft webhelyén keresse meg azokat a legfrissebb technikai információkat, amelyek a megfigyelt problémával kapcsolatosak lehetnek. Szükség esetén a fennálló problémával vagy hibával kapcsolatos tudnivalókhoz és utasításokhoz is hozzájuthat.

Ha rendelkezik Internet-kapcsolattal, a Windows 2000 Server legújabb frissítéseit a Microsoft webhelyen szerezheti be. (http://www.microsoft.com/)

A Windows NT Server legújabb Service Pack (javítócsomag) frissítéseit szintén a Microsoft webhelyén találja. (http://www.microsoft.com/)

Ismerkedjen meg a DNS szolgáltatással kapcsolatos más hasznos dokumentációkkal és forrásokkal. Ilyen például a DNS hibaelhárító.

Lásd még: Frissített technikai információ a DNS-ről, DNS, Windows 2000 Resource Kit, angol és magyar Microsoft webhely. (http://www.microsoft.com/)


Zónaproblémák hibaelhárítása

Mi a probléma?

Zónaletöltéssel kapcsolatos probléma merült fel.

Ok: A DNS-kiszolgáló szolgáltatás leállt, vagy a zóna működése szünetel.

Megoldás: Győződjön meg róla, hogy a zónaletöltés végrehajtásában résztvevő fő (forrás) és másodlagos (cél) DNS-kiszolgáló egyaránt elindult, és a zóna működése egyik kiszolgálón sem szünetel.

Lásd még: DNS-kiszolgáló indítása és leállítása; Zóna indítása; A zónák és a zónaletöltés ismertetése.

Ok: Az átvitel során használt DNS-kiszolgálók között nincs hálózati kapcsolat.

Megoldás: Gondoskodjon arról, hogy a két kiszolgáló között ne merülhessenek fel kapcsolódási problémák.

Küldjön ping parancsot a DNS-kiszolgálók IP-címére azok távoli megfelelőiről.

A forráskiszolgálón például a ping paranccsal ellenőrizheti, hogy működik-e az IP-kapcsolat a célkiszolgálóval. A célkiszolgálóról is küldjön egy ping parancsot a forráskiszolgáló IP-címére.

Mindkét tesztnek sikeresnek kell lennie. Sikertelen teszt esetén vizsgálja ki és oldja meg a hálózati csatlakozási problémákat.

Lásd még: A kapcsolatok tesztelése a ping paranccsal.

Ok: A forrás- és a célkiszolgálón lévő zóna sorozatszáma megegyezik. Mivel az érték mindkét kiszolgálón azonos, a két kiszolgáló között nem kerül sor zónaletöltésre.

Megoldás: A DNS-konzol segítségével végezze el a következő műveleteket:

  1. A fő (forrás) kiszolgálón növelje meg a zóna sorozatszámát olyan értékre, amely nagyobb a másodlagos (cél) kiszolgálón található értéknél.
  2. Miután a főkiszolgálón lévő sorozatszámot a másodlagos kiszolgálón használt értékénél nagyobbra növelte, kezdeményezzen zónaletöltést a másodlagos kiszolgálóról.

A DNS-konzollal végzett munka közben a zóna sorozatszámát a megfelelő zóna tulajdonságlapjának SOA rekord lapján tekintheti meg. Ha növelni kívánja a zóna sorozatszámát, kattintson a Növelés gombra.

Lásd még: Zóna SOA rekordjának módosítása; Zónaletöltés kezdeményezése másodlagos kiszolgálóról.

Ok: A főkiszolgáló (forrás) és a másodlagos (cél) kiszolgáló között együttműködési problémák merültek fel.

Megoldás: Vizsgálja meg azokat a lehetséges problémákat, melyek megakadályozhatják a Windows 2000 DNS-kiszolgálók és más, például a Berkeley Internet Name Domain (BIND) szoftver korábbi verzióját futtató DNS-kiszolgálók együttműködését.

A BIND régebbi verzióit futtató kiszolgálók tömörítés nélküli zónaletöltési formátumot használnak. Alapértelmezés szerint a Windows 2000 kiszolgálók (és a BIND újabb verzióit futtató kiszolgálók) a zónaletöltés során gyorsabb, tömörített formátumot használnak. Ha a zónaletöltést a BIND régebbi verzióit futtató kiszolgálókkal szeretné végezni, módosítsa a Windows 2000 DNS-kiszolgálók speciális beállításait.

Az együttműködést akadályozhatja a WINS címkeresési (WINS) erőforrásrekordok használata és beépítése egy zónába, vagy a névlekérdezési zónákhoz használt WINS névlekérdezési (WINS-R) erőforrásrekordok használata. A BIND-kiszolgálók nem ismerik fel ezeket a rekordokat, ha be vannak ágyazva az átvitt zónaadatokba, ezért ezeket hibás adatokként jelölik meg, ami a zónaletöltés sikertelenségét is okozhatja.

Annak érdekében, hogy a BIND alapú, vagy az ilyen rekordok felismerésére nem alkalmas kiszolgálók felé irányuló zónaletöltésekbe a rendszer ne építse be ezeket a rekordokat, a megfelelő zóna WINS-tulajdonságainak konfigurálásakor jelölje be az Ez a rekord ne replikálódjon jelölőnégyzetet.

Lásd még: Zónaletöltés BIND- és egyéb DNS-kiszolgálókkal; Gyors letöltési formátum engedélyezése vagy tiltása a zónaletöltések során; Együttműködés más szolgáltatásokkal; A WINS keresés használata; A WINS-névhozzárendelés használatának engedélyezése a DNS számára.

Ok: A zóna olyan erőforrásrekordokat vagy más adatokat tartalmaz, amelyeket a DNS-kiszolgáló nem tud értelmezni.

Megoldás: Ellenőrizze, hogy a zóna nem tartalmaz inkompatibilis adatokat, például nem támogatott erőforrásrekord-típusokat vagy adathibákat.

A DNS-kiszolgáló szolgáltatás a legtöbb esetben támogatja az összes erőforrásrekord-típust, amelyek szükségesek és elfogadottak az Internet szabványú DNS-használathoz.

Azt is ellenőrizze, hogy a kiszolgálót nem konfigurálták-e úgy, hogy ne töltsön be hibás adatot tartalmazó zónát, és vizsgálja meg, milyen módszereket alkalmaz a nevek ellenőrzéséhez. Ezek a beállítások a DNS-konzol használatával konfigurálhatók.

Lásd még: Erőforrásrekordok; Zóna letöltésének tiltása hibás adatok érkezése esetén; DNS-kiszolgáló névellenőrzési módszerének módosítása; A nevek és a zónaadatok ellenőrzése.

Ok: A mérvadó zónaadat hibás.

Megoldás: Ha a zónaletöltés továbbra is sikertelen, ellenőrizze, hogy a zóna nem tartalmaz-e szabványon kívüli adatokat.

A zónafájlok kézi szerkesztése közben figyeljen arra, hogy a rekordokat a szabványos rekordhasználati és formázási útmutatók alapján kell formázni és használni a DNS-re vonatkozó RFC-dokumentumok előírásai szerint. A felhasználói adatbeviteli és adathibákat a legtöbb esetben elkerülheti, ha a rekordok hozzáadására és kezelésére a DNS-konzolt használja.

Ha szeretné megállapítani, hogy hibás zónaadat okozza-e a zónaletöltés sikertelenségét, nézze meg a DNS-kiszolgáló eseménynaplójában lévő üzeneteket. Zónaletöltés szimulálására és tesztelésére használhatja az nslookup parancsot az -ls kapcsolóval, és a teljes zónaletöltés végrehajtása előtt megfigyelheti a kapott adatokat.

Lásd még: Nslookup.

Zónadelegálást próbálok alkalmazni, de a zóna sérültnek tűnik.

Ok: A zónadelegálások nincsenek megfelelően konfigurálva.

Megoldás: Nézze át a zónadelegálásokkal kapcsolatos tudnivalókat, és szükség szerint módosítsa a zónák konfigurációit.

A zónák a DNS-tartományokra és altartományokra vonatkozó információkat tartalmaznak. Először minden újonnan létrehozott zóna egyetlen DNS-tartományra vonatkozó, egycsomópontos adatbázisként jelenik meg. Szükség szerint új altartomány-csomópontokat vehet fel közvetlenül az eredeti (szülő) tartomány alá, majd egyetlen zónaként tárolhatja azokat. Az ugyanabban a zónában megmaradó új altartományokat alzónáknak nevezzük.

Az alzónákként használt új altartományok a zóna részei maradnak, replikálásuk és frissítésük egyetlen egységként történik. Az altartományokat delegálhatja is, és kezelheti őket saját zónáikban. A saját zónájukhoz delegált altartományok esetén a szülő zónához delegálási rekordokat kell hozzáadni.

A Windows 2000 DNS-kiszolgálók esetén a DNS-konzolon keresztül elérhető Új delegálás varázsló megkönnyíti ezeknek a rekordoknak a hozzáadását.

Lásd még: Zónák delegálása; Zónadelegálás létrehozása; Zónadelegálás ellenőrzése az nslookup paranccsal.

A fent leírtaktól eltérő zónaprobléma lépett fel.

Ok: A probléma leírása feljebb nem szerepel.

Megoldás: A Microsoft webhelyén keresse meg azokat a legfrissebb technikai információkat, amelyek a megfigyelt problémával kapcsolatosak lehetnek. Szükség esetén a fennálló problémával vagy hibával kapcsolatos tudnivalókhoz és utasításokhoz is hozzájuthat.

Ha rendelkezik Internet-kapcsolattal, a Windows 2000 Server legújabb frissítéseit a Microsoft webhelyen szerezheti be. (http://www.microsoft.com/)

A Windows NT Server legújabb Service Pack (javítócsomag) frissítéseit szintén a Microsoft webhelyén találja. (http://www.microsoft.com/)

Ismerkedjen meg a DNS szolgáltatással kapcsolatos más hasznos dokumentációkkal és forrásokkal. Ilyen például a DNS hibaelhárító.

Lásd még: Frissített technikai információ a DNS-ről, DNS, Windows 2000 Resource Kit, angol és magyar Microsoft webhely. (http://www.microsoft.com/)


Másodlagos zóna hozzáadása

  1. Nyissa meg a DNS ablakot.
  2. Kattintson a DNS-kiszolgálóra, melyhez a zónát hozzá kívánja adni.
  3. A Művelet menüben kattintson az Új zóna parancsra.
  4. Kövesse az Új zóna varázsló utasításait, és jelölje ki a Szabványos másodlagos zónatípust, amikor a program kéri.
  5. Kövesse tovább a varázsló utasításait a zóna létrehozásának befejezéséhez.

Megjegyzés

  • A DNS ablak megnyitásához kattintson a Start menüre, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a DNS parancsra.

Kapcsolódó témakörök