DCOM

A DCOM (Distributed component object model – Elosztottösszetevőobjektum-modell) az összetevőobjektum-modell (COM) technológia hálózati kiterjesztése, amely hálózaton keresztül lehetővé teszi a folyamatok közötti kommunikációt.

  • Mielőtt elkezdené, tanulmányozza az Ellenőrzőlista: a DCOM beállítása című témakört.
  • Ha egy adott feladattal kapcsolatban van szüksége segítségre, tanulmányozza az Útmutató című témakört.
  • A DCOM-mal kapcsolatos általános tudnivalókért tanulmányozza a Fogalmak című témakört.
  • Problémamegoldással kapcsolatos tudnivalókért tanulmányozza a Hibaelhárítás című témakört.


Ellenőrzőlista: a DCOM beállítása

Az alábbi ellenőrzőlista azokat a feladatokat összegzi, amelyeket az Elosztott COM konfiguráció tulajdonságai program elindítása előtt kell végrehajtani.

Lépés | Felelős
A konfigurálni kívánt alkalmazás kiválasztása:________________________ | A hálózati rendszergazda és a fejlesztő
Ha a program egy COM-kiszolgálóprogram, akkor annak a számítógépnek a meghatározása, ahol a program telepítve van: ________________________. | A hálózati rendszergazda és a fejlesztő
Ha a program egy COM-ügyfélprogram, akkor azon felhasználók listájának összeállítása, akik elindíthatják a COM-ügyfélprogramokat: ________________________. | A hálózati rendszergazda és a fejlesztő
A beállítást igénylő DCOM-tulajdonságok összeállítása:
  • Alkalmazás indítása _________________.
  • Felhasználói hozzáférési engedélyek_____________________.
 A hálózati rendszergazda és a fejlesztő


Útmutató...

  • Az összes DCOM-alkalmazásra vonatkozó alapértelmezett engedélyek beállítása
  • A DCOM-program helyének megadása
  • DCOM-program indítására képes felhasználói fiók beállítása
  • Egyedi engedélyek beállítása egy adott DCOM-programra
  • Felhasználó vagy csoport hozzáadása a DCOM engedélyek listához
  • A DCOM-programokra vonatkozó speciális elérési konfigurációs engedélyek beállítása
  • A DCOM kikapcsolása


Az összes DCOM-alkalmazásra vonatkozó alapértelmezett engedélyek beállítása

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Kattintson az Alapértelmezett adatvédelem fülre.
  3. Az alapértelmezett engedélyek beállításához az Alapértelmezett hozzáférési engedélyek, Alapértelmezett indítási engedélyek és Alapértelmezett konfigurációs engedélyek csoportban kattintson a Szerkesztés gombra.
  4. Szükség esetén a Név listához más felhasználói fiókok hozzáadásához kattintson a Hozzáadás gombra.
  5. A Név listában válassza ki azt a felhasználót vagy csoportot, amelynek az alapértelmezett engedélyeit módosítani akarja.
  6. A Hozzáférési típus listában válassza ki a kijelölt felhasználóra vagy csoportra vonatkozó hozzáférés típusát.

Megjegyzések

  • Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel elindításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a dcomcnfg parancsot.
  • A konfigurációs engedélyek módosításához a Rendszerleíró kulcs engedélyek párbeszédpanelben a Hozzáférési típus részen kattintson a Speciális hozzáférés gombra.

Kapcsolódó témakörök


A DCOM-program helyének megadása

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Az Alkalmazások lapon kattintson a beállítani kívánt programra, majd a Tulajdonságok gombra.
  3. Kattintson a Hely fülre, és adja meg a program helyét. Az alkalmazás az aktuális számítógéptől vagy az adatokat tároló számítógéptől különböző számítógépen való futtatásához kattintson A következő számítógépen: elemre, majd írja be annak a számítógépnek a NETBIOS-nevét, amelyen az alkalmazást futtatni akarja.

Megjegyzés

  • Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel elindításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a dcomcnfg parancsot.


DCOM-program indítására képes felhasználói fiók beállítása

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Kattintson a beállítani kívánt programra, majd a Tulajdonságok gombra.

  3. Kattintson az Azonosítás fülre, majd arra a felhasználói fiókra, amely a programot indítani fogja.

    Ahhoz, hogy a programot az interaktív vagy az alkalmazást elindító felhasználón kívül más felhasználó elindíthassa, kattintson A következő felhasználó elemre, és a lenti mezőkbe írja be a felhasználó adatait.

Megjegyzések

  • Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel indításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a dcomcnfg parancsot.
  • Ez a művelet a megadott felhasználói fiók számára lehetővé teszi a tartomány más számítógépein futó folyamatok elindítását, és az erőforrások elérését. Ha a programot szolgáltatásként telepítették, akkor a program az eljárás során létrehozott beépített rendszerfiók vagy szolgáltatásfiók azonosításával futtatható.

Kapcsolódó témakörök


Egyedi engedélyek beállítása egy adott DCOM-programra

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Az Alkalmazások lapon kattintson a beállítani kívánt programra, majd a Tulajdonságok gombra.
  3. Kattintson az Adatbiztonságiztonság fülre, szükség szerint az Egyéni hozzáférési engedélyek használata, Egyéni indítási engedélyek használata vagy az Egyéni konfigurációs engedélyek használata választógombra, majd a Szerkesztés gombra.
  4. Szükség esetén a Rendszerleíró érték engedélyek párbeszédpanel Név listájához további felhasználói vagy csoportfiókok hozzáadásához kattintson a Hozzáadás gombra.
  5. A Név listában válassza ki azt a felhasználót vagy csoportot, amelynek be akarja állítani az engedélyeit.
  6. A Hozzáférési típusa listában válassza ki a kijelölt felhasználóra vagy csoportra vonatkozó hozzáférés típusát.

Megjegyzések

  • Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel elindításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a dcomcnfg parancsot.
  • A konfigurációs engedélyek módosításához a Rendszerleíró kulcs engedélyek párbeszédpanelben a Hozzáférési típus részen kattintson a Speciális hozzáférés gombra.

Kapcsolódó témakörök


Felhasználó vagy csoport hozzáadása a DCOM engedélyek listához

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Kattintson az Alapértelmezett adatvédelem fülre.
  3. Az Alapértelmezett hozzáférési engedélyek részen kattintson a Szerkesztés gombra.

    Az Alapértelmezett indítási engedélyek csoportban a Szerkesztés gombra is kattinthat.

  4. A Rendszerleíró érték engedélyek részen kattintson a Hozzáadás gombra.
  5. A Nevek legördülő listában kattintson a felhasználókra vagy csoportokra, majd a Hozzáadás gombra.
  6. Szükség esetén a Hozzáférés típusa listában válasszon ki egy engedélyt.
  7. Szükség esetén a Nevek segítségével adhatók fiókok az engedélyek listájához.
    • Egy teljes csoport hozzáadásához kattintson a csoportra, majd a Hozzáadás gombra.
    • A kijelölt számítógép vagy tartomány valamennyi felhasználójának megjelenítéséhez kattintson a Felhasználók gombra.
    • A kijelölt csoport tagjainak megjelenítéséhez kattintson a Tagok gombra.
    • A csoport bizonyos tagjainak a hozzáadásához kattintson a kívánt tagokra bármelyik Csoporttagság párbeszédpanelben, majd a Hozzáadás gombra.

Megjegyzések

  • A felhasználó vagy csoport valamennyi alkalmazás alapértelmezett engedélyek listájára való hozzáadásához az Elosztott COM konfiguráció tulajdonságai párbeszédpanelen kattintson az Alapértelmezett adatvédelem fülre, majd a Szerkesztés gombra.
  • A felhasználó vagy csoport egyetlen alkalmazáshoz tartozó engedélylistához való hozzáadásához az Elosztott COM konfiguráció tulajdonságai párbeszédpanelen kattintson az Alkalmazás, Tulajdonságok fülre, majd a Biztonság fülre.
  • Ha nem tudja, hogy a felhasználó vagy csoport melyik tartományhoz tartozik, akkor a Felhasználók vagy csoportok hozzáadása párbeszédpanelben kattintson a Keresés gombra.
  • A Névlista forrása mező határozza meg, hogy mely számítógép vagy tartomány fiókjai jelennek meg a Név listában. Másik számítógép vagy tartomány felhasználóinak a kiválasztásához a Névlista forrása mezőben kattintson a megfelelő tartomány nevére.
  • A tartományok csak akkor jelennek meg, ha a számítógép Windows 2000 tartományhoz tartozik. A listán megjelenő tartományok megbízható kapcsolatban állnak a jelenlegi tartománnyal.


A DCOM-programokra vonatkozó speciális hozzáférési engedélyek beállítása

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Kattintson az Alapértelmezett adatvédelem fülre, az Alapértelmezett konfigurációs engedélyek alatt kattintson a Szerkesztés gombra.
  3. A Rendszerleíró-kulcs engedélyek részen a Hozzáférési típus alatt kattintson a Speciális hozzáférés gombra.
  4. A Speciális hozzáférés párbeszédpanelen kattintson a kiválasztott felhasználóhoz vagy csoporthoz hozzárendelni kívánt vezérlőtípusra.
    • A Teljes hozzáférés hozzárendeléséhez kattintson a Teljes hozzáférés (minden jog) elemre.
    • A speciális hozzáférés testreszabásához kattintson az Egyéb gombra, majd a hozzárendelni kívánt hozzáférési típusra.
    • Egy felhasználó számára a rendszerleíró kulcs értékének olvasása az Érték lekérdezése elemre kattintással engedélyezhető.
    • Egy felhasználó számára a rendszerleíró kulcs értékének beállítása az Érték beállítása elemre kattintással engedélyezhető.
    • Egy felhasználó számára a rendszerleíró kulcson belül alkulcs létrehozása az Alkulcs létrehozása elemre kattintással engedélyezhető.
    • Egy felhasználó számára egy rendszerleíró kulcs alkulcsainak megtekintése az Alkulcsok felsorolása elemre kattintással engedélyezhető.
    • Egy felhasználó számára a kulcs értesítő eseményeinek naplózása az Értesítés elemre kattintással engedélyezhető.
    • Egy felhasználó számára a rendszerleíró kulcson belül szimbolikus csatolás létrehozása az Csatolás létrehozása elemre kattintással engedélyezhető.
    • Egy felhasználó számára a kulcs törlése a Törlés elemre kattintással engedélyezhető.
    • Az Írás DAC elemre kattintással engedélyezhető egy felhasználó számára, hogy korlátlan hozzáférésvezérlési-lista megadása céljából hozzáférhessen a kulcshoz.
    • Az Írási jog tulajdonosa elemre kattintással engedélyezhető a felhasználó számára, hogy a kulcshoz annak saját tulajdonba vétele céljából hozzáférhessen.
    • A felhasználó számára a kulcs biztonsági adatainak elérése az Olvasásszabályozás elemre kattintással engedélyezhető.

Megjegyzések

  • Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel elindításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a dcomcnfg parancsot.
  • Speciális hozzáférés csak konfigurációs engedélyek hozzárendelése esetén használható.
  • A Rendszerleíróadatbázis-szerkesztő alkalmazással kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A DCOM kikapcsolása

  1. Nyissa meg az Elosztott COM konfiguráció tulajdonságai párbeszédpanelt.
  2. Kattintson az Alapértelmezett tulajdonságok gombra.
  3. Törölje a jelölést a DCOM engedélyezése a számítógépen jelölőnégyzetből.

Megjegyzések

  • Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel elindításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a dcomcnfg parancsot.
  • A beépített hálózati felhasználói fiók elérésének vagy indítási engedélyének letiltásával a DCOM kikapcsolható egy adott programra. Ehhez kattintson az Alkalmazások fülre, az alkalmazásra, a Tulajdonságok parancsra, majd az Adatbiztonság fülre. Kattintson az Egyéni hozzáférési engedélyek használata vagy az Egyéni indítási engedélyek használata elemre, majd a Szerkesztés gombra.


Fogalmak

A témakör tartalma:

  • A programok beállítása a DCOM-használatára


A programok beállítása a DCOM-használatára

A DCOM (Distributed component object model – Elosztottösszetevőobjektum-modell) a COM-technológia (Component Object Model – Összetevőobjektum-modell) kiterjesztése. A DCOM a hálózati protokollok alacsony szintű részleteinek kezelésével támogatja a hálózat különböző számítógépein elhelyezkedő objektumok közötti kommunikációt. Ez lehetővé teszi az elosztott programok használatát, amelyek egyetlen feladat végrehajtására több együttműködő folyamatot használnak. Az elsőként a Windows NT 4.0 operációs rendszer 4-es szervizcsomagjában megjelent CIS (COM Internet Services – COM Internet-szolgáltatások) biztosítja a DCOM használhatóságát az Interneten keresztül (a HTTP-protokoll alkalmazásával), amikor a kiszolgálóoldalon működő tűzfal, vagy az ügyfélhálózaton használt proxy kiszolgáló nem teszi lehetővé más protokoll használatát.

A 32 bites COM- és DCOM-programok beállításához az Elosztott COM konfiguráció tulajdonságai párbeszédpanelen állíthatók be az olyan programtulajdonságok, mint például a biztonság és a hely. Az ügyfélalkalmazást futtató számítógépen meg kell adni az elérni vagy elindítani kívánt kiszolgálóprogramot. A kiszolgálóalkalmazást futtató számítógépen meg kell adni azokat a felhasználói fiókokat, amelyek engedéllyel rendelkeznek a program eléréséhez vagy elindításához.

Az Elosztott COM konfiguráció tulajdonságai párbeszédpanel használatával kapcsolatos tudnivalókért tanulmányozza az Útmutató című témakört.


Hibakeresés

A DCOM-mal kapcsolatos hibák javítása elsősorban a program konfigurációjának és a telepítésnek az ellenőrzését jelenti. Mivel a DCOM több számítógépen futó programokat tartalmaz, ezért a hibajavítás során felmerülő problémák köre szélesebb, mint az egyetlen számítógépen használt COM esetén. Új problémaként merül fel a programok és a hálózati protokollok közötti biztonság kérdése.

Mivel a COM-adatvédelem alaphelyzetben aktív, így a rendszer biztonsági ellenőrzést hajt végre minden alkalommal, amikor egy COM-program elindít egy COM-objektumot, vagy amikor egy ügyfélprogram egy COM-objektumot próbál meg elérni.

Protokollok

Több protokoll beállítása esetén a DCOM a protokollokat a DCOM protokoll-listában megadott sorrendben próbálja meg használni.