Komponensszolgáltatások felügyelete – Súgó

A Komponensszolgáltatások felügyeleti eszköz segítségével konfigurálhatja és felügyelheti a COM-komponenseket és a COM+ alkalmazásokat. Ez az útmutató bemutatja, hogyan használhatja a Komponensszolgáltatások felügyeleti eszközt felügyeleti feladatok végrehajtásához, például a rendszer konfigurálásához, alkalmazások telepítéséhez, valamint az alkalmazások által használt szolgáltatások konfigurálásához és figyelemmel kíséréséhez. A témakörben található hivatkozások segítségével további információkhoz juthat a Komponensszolgáltatások felügyeletével kapcsolatban.

Témakör | Leírás
Útmutató a Komponensszolgáltatások felügyeletéhez | Ismerteti a felügyelettel kapcsolatos alapfogalmakat, és bemutat egy „felügyeleti életciklust”, amely kategóriákat ajánl a felügyeleti feladatok csoportosításához.
A Komponensszolgáltatások konzolfája | A konzolfában látható elemek leírásait tartalmazza.

Felügyeleti területek

A Komponensszolgáltatások felügyelete során előforduló feladatok rendszerint az alábbi területekhez fognak tartozni. Az itt található hivatkozások segítségével további információkhoz juthat az egyes területekről.

Témakör | Leírás
A rendszer konfigurálása a Komponensszolgáltatásokhoz | Ismerteti azokat a feladatokat, amelyeket a Komponensszolgáltatások telepítése után, illetve a Komponensszolgáltatások felügyeleti eszköznek a hálózatban történő alkalmazása előtt kell végrehajtani.
COM+ alkalmazások telepítése | Bemutatja a COM+ alkalmazások ügyfél- és kiszolgálóoldali elhelyezését.
Az alkalmazásbiztonság felügyelete | Áttekintést nyújt a Komponensszolgáltatások biztonsági felügyeletéről. A hivatkozások segítségével további információkat kaphat a biztonságot kikényszerítő attribútumbeállításokról.
Elosztott tranzakciók felügyelete | Bemutatja az elosztott tranzakciók felügyeletével kapcsolatos teendőket, hivatkozásokat kínál a rendszernek az MS DTC használatához történő konfigurálásával, a tranzakcióstatisztikák megjelenítésével, illetve a tranzakcióállapotok feloldásával kapcsolatos alapfogalmakhoz és feladatokhoz.
Az Aszinkron komponensek felügyelete | Bemutatja azokat az aszinkron komponenseket, amelyekkel a COM-komponensek szolgáltatásokat kérhetnek egy másik komponenstől még akkor is, ha a másik komponens nem érhető el vagy kapcsolat nélküli módban működik.

A felügyeleti feladatok ellátása mellett a komponensek fejlesztői a Komponensszolgáltatások felügyeleti eszköz segítségével konfigurálhatják a rutinkomponensek és az alkalmazások viselkedését, így például azt, hogy részt vegyenek-e a tranzakciókban és az objektumkészletezésben. Az alkalmazásoknak a Komponensszolgáltatások segítségével történő fejlesztésével kapcsolatban további információt a Microsoft Platform SDK csomag „Component Services” részében, a COM+ (Component Services) című fejezetben talál. A Platform SDK csomaghoz vezető hivatkozásokat megtalálhatja a jelen útmutató A COM+ programozása című részében.


A COM+ programozása

A Komponensszolgáltatások felügyeletével kapcsolatos témakörök csak azokat a felügyeleti beállításokat tárgyalják, amelyeket a Komponensszolgáltatások felügyeleti eszközzel el lehet végezni. A COM+ (Komponensszolgáltatások) fejlesztői beállításaival kapcsolatos tudnivalók a Microsoft Platform SDK csomag Component Services (Komponensszolgáltatások) című részében találhatók. Ha a Platform SDK nincs telepítve, az MSDN webhelyen megtekintheti, illetve onnan letöltheti azt.


Útmutató a Komponensszolgáltatások felügyeletéhez

A COM+ alkalmazások üzembe helyezésére és felügyeletére két lehetőség nyílik. Használhatja a Komponensszolgáltatások felügyeleti eszközt (amely nem más, mint a Microsoft Management Console beépülő modulja), vagy szkripteket írhat e műveletek automatizálására.

Komponensszolgáltatások felügyeleti eszköz

Ez az útmutató azt ismerteti, hogy a Komponensszolgáltatások felügyeleti eszköz miként használható a számítógépek és a COM+ alkalmazások felügyeletére. A Komponensszolgáltatások felügyeleti eszköz segítségével konfigurálhatja és felügyelheti a COM-komponenseket és a COM+ alkalmazásokat. A következő hivatkozások áttekintést nyújtanak a Komponensszolgáltatások felügyeletéről.

Témakör | Leírás
A Komponensszolgáltatások felügyeletével kapcsolatos fogalmak | A Komponensszolgáltatások felügyeletének megértéséhez szükséges fogalmak
A Komponensszolgáltatások felügyeleti életciklusa | A felügyeleti feladatok csoportosításához kategóriákat ajánló „felügyeleti életciklus”

A Komponensszolgáltatások felügyeleti eszköz indítása
  • Mutasson a Start menü Programok, majd Felügyeleti eszközök pontjára, végül kattintson a Komponensszolgáltatások parancsra.

Szkriptek a Komponensszolgáltatások felügyeletéhez

Azon túl, hogy a Komponensszolgáltatások felügyeleti eszközzel felügyeleti feladatokat hajthat végre, bármely feladatot automatizálhat is, ha a COMAdmin könyvtár-DLL által nyújtott felügyeleti objektumokat használó kódot ír. Ezen objektumok használatának leírása a Microsoft Platform SDK csomag Component Services részében, az Automating COM+ Administration című fejezetben található.


A Komponensszolgáltatások felügyeletével kapcsolatos fogalmak

A Komponensszolgáltatásokkal kapcsolatos legtöbb felügyeleti feladat a fejlesztési munka eredményének hálózati hasznosítását, illetve az üzembe helyezett alkalmazások és komponensek nagy teljesítményének és biztonságának fenntartását jelenti. Ezen belül az elvégzendő feladatok a használatban lévő alkalmazások, illetve az alkalmazások által igénybe vett szolgáltatások típusától függnek. Ez a témakör áttekintést nyújt az alkalmazások és az általuk igénybe vett szolgáltatások típusairól.

Az útmutatóban ismertetett feladatok

Érdemes megemlíteni, hogy a Komponensszolgáltatások felügyeletével kapcsolatos útmutató csak egy kis hányadát ismerteti azoknak a beállításoknak, amelyek az eszközzel elvégezhetők. Az itt nem tárgyalt beállításokat csak olyan személy végezheti el, aki alapos ismeretekkel rendelkezik a komponens vagy az alkalmazás megvalósításáról. Ezeket a beállításokat általában a fejlesztő végzi el az alkalmazás telepítése és üzembe helyezése előtt.

A COM+ fejlesztői beállításaival kapcsolatos tudnivalók a Microsoft Platform SDK csomag Component Services című részében találhatók. A Platform SDK csomaghoz vezető hivatkozást megtalálhatja a jelen útmutató A COM+ programozása című részében.

Alkalmazástípusok

A Komponensszolgáltatások felügyeleti eszközzel felügyelhető alkalmazások két kategóriába sorolhatók: COM-alkalmazások vagy COM+ alkalmazások. A jelen útmutató ezt a terminológiát alkalmazza, ahol az alkalmazás típusától függően a beállítások eltérőek lehetnek.

A COM-alkalmazások ötlete nem új; az elnevezés egyszerűen a COM-komponensek azon csoportjára utal, amelyeket együttműködésre fejlesztettek ki. COM-alkalmazás például a Microsoft Excel, amely egy elsődleges végrehajtható fájl mellett alkalmazásbővítő DLL-eket is tartalmaz – többek között a helyesírás-ellenőrzéshez vagy a Visual Basic műveletekhez.

Ezzel szemben a COM+ alkalmazások a COM-komponensek olyan csoportját képezik, amelyet a Komponensszolgáltatások (például a sorba állítás és a szerepköralapú biztonság) alkalmazására egységesen fejlesztettek ki és konfiguráltak. Ez az oka annak, hogy ezekről gyakrabban esik szó ebben az útmutatóban, mint a COM-alkalmazásokról. A COM+ alkalmazásokat megkülönböztető egyes jellemzők a komponens kódjába íródtak, míg más jellemzőket a Komponensszolgáltatások felügyeleti eszközön keresztül lehet definiálni.

A COM+ alkalmazások két további típusba sorolhatók, és az egyes típusok külön felügyeleti igényeket támasztanak. E típusok a következők: COM+ kiszolgálóalkalmazások és COM+ függvénytár-alkalmazások. A kiszolgálóalkalmazások saját folyamatterületükön futnak: egy kiszolgálóalkalmazás tartalmazhat például bérelszámolást végző DLL-csoportot. A függvénytár-alkalmazások olyan komponenseket tartalmaznak, amelyek más állomás folyamatában futnak: függvénytár-alkalmazásokba csoportosíthat például olyan DLL-eket, amelyek más alkalmazáskomponens számára nyújtanak szolgáltatásokat, megosztva ezen komponensek biztonsági jellemzőit.


A Komponensszolgáltatások felügyeleti életciklusa

A Komponensszolgáltatások felügyeleti eszközzel elvégezhető feladatok a következő négy átfogó kategóriába tartoznak:

  • a rendszer konfigurálása a Komponensszolgáltatásokhoz
  • a szolgáltatások kezdeti beállítása
  • alkalmazások telepítése és konfigurálása
  • a Komponensszolgáltatások figyelése és beállítása.

Megjegyzés Jóllehet, ez a témakör szükséges és általános feladatokat tárgyal, igény szerint más feladatok elvégzésére is van lehetőség. Ne felejtse el elolvasni a dokumentáció felügyelendő területekkel kapcsolatos azon részeit, amelyekben részletesebb magyarázatokat találhat.

A rendszer konfigurálása a Komponensszolgáltatásokhoz

Amikor először dolgozik a Komponensszolgáltatások eszközzel, néhány testreszabással kapcsolatos feladatot feltétlenül el kell végeznie, mielőtt a szolgáltatások hálózati használatba kerülnének. Először például be kell állítani a hozzáférést ahhoz az alapul szolgáló alkalmazáshoz, amely a Komponensszolgáltatások felügyeleti eszközzel elvégzett beállításokra és feladatokra válaszol. Az ilyen kezdeti feladatokkal kapcsolatos bővebb tudnivalókat A rendszer konfigurálása a Komponensszolgáltatásokhoz című témakörben találhatja meg.

A szolgáltatások kezdeti beállítása

Miután a hálózat igényeinek megfelelően elvégezte a Komponensszolgáltatások alapvető beállításait, következő lépésként sor kerülhet a hálózaton használatban lévő alkalmazásokra és szolgáltatásokra jellemző beállításokra.

A következő felsorolásban néhány példa található a hálózati számítógépeken elvégzendő beállításokra.

  • COM+ alkalmazásokba be nem épített komponensek – azaz önállóan üzembe helyezett COM-komponensek vagy COM-alkalmazások – biztonságának megvalósítása érdekében szükség lehet a számítógépeken bizonyos COM-alapú biztonsági beállításokat elvégezni. (A COM+ alkalmazások viszont kihasználhatják a szerepköralapú biztonság előnyeit.)

    A további tudnivalókat a COM-alkalmazások biztonsági beállításai című témakörben találja.

  • Ha az alkalmazások elosztott tranzakciókat használnak majd, meg kell adni, hogy az MS DTC manuálisan vagy automatikusan induljon-e el a számítógépeken. Továbbá, ha a tranzakciókat a Windows fürtözéssel kívánja használni, a hálózatot annak megfelelően be kell állítania.

    További információt Az MS DTC konfigurálása című témakörben talál.

COM+ alkalmazások telepítése és konfigurálása

Mielőtt egy adott COM+ alkalmazás működőképes lenne, az alkalmazást az általa igénybe vett szolgáltatásokra jellemző beállítások szerint konfigurálnia kell, majd a hálózati számítógépekre telepítenie kell az alkalmazás ügyfél- és kiszolgálóoldali részeit.

A következő felsorolás néhány példát mutat be a COM+ alkalmazások telepítésekor és konfigurálásakor elvégzendő feladatokra.

  • Mielőtt elvégezné a COM+ alkalmazás hálózati működését szabályozó beállításokat, először egy olyan fejlesztői számítógépre kell telepítenie az alkalmazást, ahol az konfigurálható.

    Bővebb tájékoztatásért olvassa el a Fejlesztői és termelési számítógépek című témakörben leírtakat.

  • Ha azt szeretné, hogy az alkalmazás megfelelően illeszkedjen a hálózat biztonsági sémájába (azaz mind az alkalmazáshoz történő hozzáférés, mind pedig az alkalmazás hozzáférése más erőforrásokhoz megfeleljen az igényeknek), lehet, hogy felhasználókat kell hozzáadnia az alkalmazás szerepköreihez, és be kell állítania az alkalmazás biztonsági azonosítóját.

    A további tudnivalókat a Szerepköralapú biztonság és Az alkalmazás azonosítója című témakörökben olvashatja.

  • Miután a COM+ alkalmazást a biztonsági szempontoknak és az igénybe vett szolgáltatásoknak megfelelően beállította, üzembe kell helyezni az alkalmazás ügyfél- és kiszolgálóoldali részeit a hálózatba kapcsolt termelési számítógépeken.

    További információt a COM+ alkalmazások telepítése című témakörben talál.

A Komponensszolgáltatások figyelése és beállítása

Miután telepítette és elindította a Komponensszolgáltatások eszközt használó komponenseket, nyomon követheti e szolgáltatások működését a teljesítménynövelési lehetőségek és a hibák kezelésének szempontjából. Egyes esetekben előfordulhat, hogy a beállításokon – különösen az alaposabb figyelés érdekében – végrehajtott módosítások a teljesítmény romlásához vezethetnek. Ne felejtse el elolvasni a konfigurálandó területre vonatkozó dokumentációt.

A következő felsorolás néhány példát mutat be az alkalmazások és a komponensek figyelésekor elvégzendő feladatokra.

  • Ha rendelkezésére áll egy adott COM+ alkalmazás új verziója, a frissítés azt jelenti, hogy a régi verziót el kell távolítani, az újat pedig telepíteni kell.

    További információt a COM+ alkalmazások telepítése című témakörben talál.

  • A biztonságot úgy szabályozhatja nagyobb mértékben, ha a hivatkozások nyomon követésével további biztonsági ellenőrzéseket iktat be, és a további információkat is nyomon követi – ezzel megakadályozhatja az objektumok véletlen vagy rosszindulatú, korai felszabadítását.

    További tájékoztatást A hivatkozások nyomon követése című témakörben talál.

  • Ha az alkalmazások elosztott tranzakciókban vesznek részt, a teljesítményt a tranzakcióállapot, az üzenetek és a statisztikák megtekintésével figyelheti. A rendszer teljesítménye úgy is növelhető, ha megváltoztatja a tranzakcióstatisztikát tartalmazó naplófájl méretét vagy helyét.

    Bővebb felvilágosításért olvassa el Az MS DTC teljesítményének figyelése és A naplófájl kezelése című témakörökben leírtakat.


A Komponensszolgáltatások konzolfája

A Komponensszolgáltatások felügyeleti eszköz konzolfájának segítségével megtekintheti a felügyelhető alkalmazásokat, komponenseket és biztonsági szerepköröket. Ez a témakör bemutatja azokat az elemeket, amelyek a konzolfában megjelennek.

Számítógép

Ez az elem tartalmazza a Sajátgépet és a rendszergazda által hozzáadott más számítógépeket.

Sajátgép

Alapértelmezés szerint a Sajátgép azt a helyi számítógépet jelenti, amely a Komponensszolgáltatásokat tartalmazza.

Alkalmazások

Ez az elem a számítógépre telepített alkalmazásokat jelöli. Az alkalmazások tulajdonságait úgy módosíthatja, ha az egér jobb gombjával az alkalmazásra, majd a helyi menüben az egér bal gombjával a Tulajdonságok parancsra kattint. Az alkalmazások telepítésével kapcsolatban további információt talál a COM+ alkalmazások telepítése című témakörben.

Komponensek

Ez az elem a COM+ alkalmazásban telepített komponenseknek felel meg. A komponensek tulajdonságait úgy módosíthatja, ha az egér jobb gombjával a komponensre, majd a helyi menüben az egér bal gombjával a Tulajdonságok parancsra kattint.

Szerepkörök

Ez az elem a COM+ alkalmazás számára elérhető szerepköröket jelöli. A szerepkörök tulajdonságait úgy módosíthatja, ha az egér jobb gombjával a szerepkörre, majd a helyi menüben az egér bal gombjával a Tulajdonságok parancsra kattint.

Objektumfelületek

Ez az elem a komponensben elérhető objektumfelületeket jelöli. Az objektumfelületek tulajdonságait úgy módosíthatja, ha az egér jobb gombjával az adott felületre, majd a helyi menüben az egér bal gombjával a Tulajdonságok parancsra kattint.

Módszerek

Ez az elem az objektumfelületekből elérhető metódusoknak felel meg. A metódusok tulajdonságainak módosításához az egér jobb gombjával kattintson a metódusra, majd a helyi menüben az egér bal gombjával a Tulajdonságok parancsra.

Felhasználók

Ez az elem az adott szerepkörhöz tartozó felhasználókat jelöli. Felhasználókat úgy adhat hozzá és úgy távolíthat el, ha az egér jobb gombjával a Felhasználó mappára kattint, az Új pontra mutat, végül a Felhasználó parancsra kattint. Felhasználókat úgy törölhet, ha az egér jobb gombjával a felhasználóra, majd bal gombjával a Törlés parancsra kattint.

Elosztott tranzakciók koordinátora

Ez az elem tartalmazza a Tranzakciólistát (amely azt mutatja, hogy a számítógép pillanatnyilag milyen tranzakcióban vesz részt) és a Tranzakcióstatisztikát (amely a tranzakciókkal kapcsolatos adatokat jeleníti meg). Az Elosztott tranzakciók koordinátorával kapcsolatos további tudnivalókat az Elosztott tranzakciók felügyelete című témakörben olvashatja.

Tranzakciólista

Ez az elem jeleníti meg azokat a tranzakciókat, amelyekben a számítógép pillanatnyilag részt vesz. Azokat a tranzakciókat is tartalmazza, amelyek állapota bizonytalan, vagy amelyek állapota a számítógép tulajdonságait megjelenítő párbeszédpanel Beállítások lapján megadott tranzakció-időtúllépési időszakasz óta változatlan.

Tranzakcióstatisztika

Ez az elem a tranzakciókkal kapcsolatos adatokat jeleníti meg. Ezek felölelik a teljesítményre, típusokra, sebességre vonatkozó információkat csakúgy, mint azon tranzakciók maximális és minimális válaszidejét, amelyekben a számítógép részt vesz.


A rendszer konfigurálása a Komponensszolgáltatásokhoz

A Komponensszolgáltatások telepítése után először konfigurálni kell a rendszert. Ez azzal jár, hogy a rendszeralkalmazás biztonságának beállításával engedélyezni kell a rendszergazda szabályzási lehetőségeit. A Komponensszolgáltatások eszközt továbbá úgy kell konfigurálni, hogy felismerje a hálózatot; ehhez a számítógépeket láthatóvá kell tenni a Komponensszolgáltatások számára, és az elosztott COM konfigurálásával lehetővé kell tenni a komponensek kommunikációját a számítógépek között. E konfigurációs követelmények nélkülözhetetlenek a Komponensszolgáltatások helyes telepítése szempontjából.

Témakör | Leírás
A rendszer konfigurációjával kapcsolatos fogalmak | A rendszer konfigurációjával összefüggő feladatok, és az egyes lépések leírásához vezető hivatkozások
A rendszer konfigurációjával kapcsolatos feladatok | Az egyes lépések leírásához vezető hivatkozások

A munka megkezdése előtt

A rendszer igényeitől függően a jelen rész témaköreiben bemutatott lépéseken kívül szükség lehet a Komponensszolgáltatások további konfigurációjára. Noha a következő tulajdonságokat később is konfigurálhatja, fontos, hogy a feladatokkal időben megismerkedjen.

  • Ha azt szeretné, hogy a helyi Komponensszolgáltatások elosztott tranzakciókban vegyenek részt, a Microsoft Distributed Transaction Coordinator (MS DTC) konfigurálására is szükség van. További tudnivalók az Elosztott tranzakciók felügyelete című témakörben találhatók.
  • Ha a rendszer méretezhetőségét növelni szeretné, a Komponensszolgáltatások eszközt minden használaton kívüli alkalmazásfolyamat bezárásához konfigurálhatja.


A rendszer konfigurációjával kapcsolatos fogalmak

A Komponensszolgáltatások telepítése után a rendszer konfigurálásának alábbi lépéseit kell először elvégezni.

A rendszergazda szabályozási lehetőségeinek engedélyezése a biztonság beállításával

A Komponensszolgáltatásokon belül a rendszeralkalmazás kezeli a konfigurációt és az üzembe helyezést. E fontos alkalmazáshoz történő hozzáférés védelme érdekében definiálnia kell, hogy ki felügyelheti a környezetet. Ez nélkülözhetetlen ahhoz, hogy a Komponensszolgáltatások konfigurációját módosítani lehessen, például egy alkalmazás telepítésekor vagy egy számítógép hozzáadásakor.

A rendszeralkalmazás szerepköralapú biztonsági rendszert alkalmaz két szerepkörrel, melyek a következők: Rendszergazda és Olvasó. A Rendszergazda szerepkör tagjai a rendszeralkalmazáshoz írási és olvasási jogosultsággal rendelkeznek. A Komponensszolgáltatások felügyeleti eszköz bármely beállítását módosíthatják és törölhetik, illetve bármilyen beállítást hozzáadhatnak. Legalább egy felhasználót hozzá kell rendelni a Rendszergazda szerepkörhöz, különben a Komponensszolgáltatások ellenőrzésére nincs mód. Az Olvasó szerepkör tagjai a rendszeralkalmazáshoz csak olvasási jogosultsággal rendelkeznek. Megtekinthetik a Komponensszolgáltatások felügyeleti eszköz beállításait, de nem módosíthatják vagy törölhetik azokat, illetve nem adhatnak hozzá új beállításokat.

A rendszeralkalmazás felügyeleti biztonságának beállításával kapcsolatban A biztonság beállítása című témakörben tájékozódhat. A biztonsággal kapcsolatos további tudnivalók Az alkalmazásbiztonság felügyelete című témakörben találhatók.

A számítógépek láthatóvá tétele a Komponensszolgáltatások számára

Minden számítógépet, amelyet a Komponensszolgáltatások felügyeleti eszközzel felügyelni szeretne, hozzá kell adni az eszköz konzolfájához. Ha a számítógépet a Komponensszolgáltatások felügyeleti eszköz nem látja, akkor a biztonság beállítására és alkalmazások telepítésére nem lesz lehetőség. A számítógépek hozzáadásával kapcsolatos útmutatásokat A számítógépek láthatóvá tétele a Komponensszolgáltatások számára című témakörben olvashatja.

Elosztott COM konfigurálása

Az elosztott COM (DCOM) vonalprotokoll kezeli a hálózati kommunikációt a különböző számítógépeken futó COM-komponensek között. A DCOM modellt minden, a hálózat más komponenseivel kommunikáló COM-komponenssel ellátott számítógép számára engedélyezni kell. Bár a DCOM letiltása az azonos számítógépen lévő komponensek kommunikációját nem befolyásolja, a különböző számítógépeken lévő komponensek kommunikációja megszűnik. A különböző számítógépeken lévő komponensek közötti kommunikáció engedélyezésével kapcsolatban Az elosztott COM engedélyezése és letiltása című témakörben talál bővebb tájékoztatást.

Megjegyzés A Komponensszolgáltatások felügyeleti eszköz megköveteli, hogy a számítógépen fusson a Microsoft Distributed Transaction Coordinator (MS DTC) szolgáltatás. Ha előzőleg leállította az MS DTC szolgáltatást, majd a Komponensszolgáltatások felügyeleti eszközzel módosítani próbál valamilyen beállítást, az MS DTC újraindul. Ha a Komponensszolgáltatások használatának kezdetekor hibaüzenet jelenik meg, ellenőrizze, hogy elindult-e az MS DTC, ha nem, indítsa el. Az MS DTC indításával és leállításával kapcsolatos további tudnivalókat Az MS DTC indítása és leállítása című témakörben olvashatja.


A rendszer konfigurációjával kapcsolatos feladatok

A Komponensszolgáltatások telepítése után először konfigurálni kell a rendszert.

  • A biztonság beállítása
  • A számítógépek láthatóvá tétele a Komponensszolgáltatások számára
  • Az elosztott COM engedélyezése és letiltása

A fenti feladatokkal kapcsolatos tudnivalókról A rendszer konfigurációjával kapcsolatos fogalmak című témakör tájékoztatja.


A biztonság beállítása

A Komponensszolgáltatásokon belül a rendszeralkalmazás kezeli a konfigurációt és az üzembe helyezést. Ahhoz, hogy a rendszerben bármilyen módosítást végre lehessen hajtani (például alkalmazásokat telepíteni vagy számítógépet hozzáadni), be kell állítani a biztonságot, amely meghatározza, hogy ki felügyelheti a környezetet. A következő eljárás bemutatja, hogy a rendszeralkalmazás biztonságát miként lehet beállítani.

Vigyázat! Ha engedélyezi a rendszeralkalmazás biztonságát, legalább egy felhasználót a Rendszergazda szerepkörhöz kell rendelnie. Ha ezt elmulasztja, a Komponensszolgáltatások eszköz felügyeletére nem lesz mód, így azt újra kell telepítenie.

A rendszeralkalmazás biztonságának engedélyezése
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján bontsa ki a COM+ alkalmazások ikont.
  2. Bontsa ki a Rendszeralkalmazás ikont.
  3. Bontsa ki a Szerepkörök ikont.
  4. Bontsa ki a Rendszergazda ikont.
  5. A Komponensszolgáltatásokhoz felügyeleti hozzáféréssel rendelkező felhasználók és csoportok hozzárendeléséhez kövesse a Felhasználói fiókok vagy csoportok hozzárendelése egy szerepkörhöz című témakör 3-5. lépését.
  6. A módosítások érvénybe léptetéséhez indítsa újra a számítógépet.

Előfordulhat, hogy valamely felhasználót el kell távolítania a rendszeralkalmazás Rendszergazda szerepköréből. Bővebb tájékoztatást a Felhasználói fiókok vagy csoportok eltávolítása egy szerepkörből című témakörben talál.


A számítógépek láthatóvá tétele a Komponensszolgáltatások számára

Ha egy távoli számítógépen elegendő jogosultsággal rendelkezik, akkor a saját számítógépén lévő Komponensszolgáltatások felügyeleti eszköz segítségével lehetősége van az azon lévő COM+ alkalmazások kezelésére, valamint tranzakcióinak figyelésére. A következő útmutatót követve a Komponensszolgáltatások konzolfájához számítógépeket adhat hozzá.

Számítógép hozzáadása a Komponensszolgáltatások felügyeleti eszköz hierarchiájához
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson a Számítógépek ikonra, mutasson az Új pontra és kattintson a Számítógép parancsra.
  2. A Számítógép hozzáadása párbeszédpanelen írja be a hozzáadandó számítógép nevét vagy kattintson a Tallózás gombra, és az elérhető számítógépek közül válasszon egyet.
  3. Kattintson az OK gombra.

Miután a számítógépet hozzáadta a konzolfához, láthatóvá válik az azt jelölő ikon a részleteket megjelenítő ablaktáblában. A Komponensszolgáltatások felügyeleti eszköz segítségével ugyanúgy kezelhetők az objektumok a távoli, mint a helyi számítógépen.

Ha nem szeretné, hogy az adott számítógép szerepeljen a Komponensszolgáltatások környezetében, eltávolíthatja azt a felügyeleti eszköz hierarchiájából.

Számítógép eltávolítása a Komponensszolgáltatások felügyeleti eszköz hierarchiájából
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson a Számítógépek ikonra.
  2. A részleteket megjelenítő ablaktáblában jelölje ki az eltávolítandó számítógépet vagy számítógépeket.
  3. Nyomja meg a Delete billentyűt.


Az elosztott COM engedélyezése és letiltása

Ha a Komponensszolgáltatásokkal ellátott számítógép egy hálózat része, akkor a más számítógépeken lévő COM-komponensekkel való kommunikáció érdekében a Komponensszolgáltatások számára szükség van a DCOM vonalprotokollra. A DCOM letiltható, de ebben az esetben a más számítógépeken lévő komponensekkel való kommunikáció megszűnik.

Figyelem! Ha egy távoli számítógépen letiltja a DCOM protokollt, akkor ezt követően annak újraengedélyezéséhez nem tudja távolról elérni ezt a számítógépet. A DCOM újraengedélyezéséhez fizikailag kell hozzáférni e számítógéphez.

A DCOM kézzel történő engedélyezése és letiltása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amely számára a DCOM protokollt le szeretné tiltani (vagy engedélyezni kívánja), majd válassza a Tulajdonságok parancsot.
  2. Kattintson az Alapértelmezett tulajdonságok fülre.
  3. A DCOM letiltásához törölje a jelet az Elosztott COM engedélyezése a számítógépen jelölőnégyzetből. (A DCOM engedélyezéséhez jelölje be a jelölőnégyzetet.)
  4. Kattintson az OK gombra.


COM+ alkalmazások telepítése

A rendszergazdák sok feladata kapcsolódik kiszolgálóalkalmazások fejlesztői vagy termelési számítógépekre, alkalmazásproxyk ügyfélszámítógépekre, illetve kiszolgálóról kiszolgálóra történő telepítéséhez, valamint alkalmazások eltávolításához vagy frissítéséhez. A Komponensszolgáltatások segítségével a legtöbb ilyen feladat elvégezhető a Komponensszolgáltatások felügyeleti eszközön keresztül. A Windows Scripting Host programmal pedig mindezek a feladatok automatizálhatók.

Ha az alábbi hivatkozásokra kattint, elolvashatja a háttér-információkat és a feladatokkal kapcsolatos tudnivalókat.

Témakör | Leírás
A telepítéssel kapcsolatos fogalmak | Bevezető a COM+ alkalmazások telepítésébe
A telepítéssel kapcsolatos feladatok | Hivatkozások a COM+ alkalmazások telepítésével kapcsolatos feladatokhoz

A COM+ alkalmazások leírását megtalálhatja A Komponensszolgáltatások felügyeletével kapcsolatos fogalmak című témakörben.

A munka megkezdése előtt

  • A COM+ alkalmazások telepítése általában az alkalmazás fejlesztésére és tesztelésére használt fejlesztői számítógépen lévő komponensekkel és előre gyártott COM+ alkalmazásokkal kapcsolatos feladatokkal jár. A fejlesztői számítógépekkel kapcsolatos további tudnivalók a Fejlesztői és termelési számítógépek című témakörben találhatók. A telepítés végrehajtása valószínűsíti, hogy Ön már használta a (fejlesztői számítógépen futó) Komponensszolgáltatások felügyeleti eszközt a biztonság konfigurálására, például az azonosítók beállítására és a felhasználók szerepkörökhöz történő hozzárendelésére. További tudnivalók A biztonsággal kapcsolatos felügyeleti feladatok című témakörben találhatók.

Az is előfordulhat, hogy szeretné beállítani a kiszolgálófolyamat leállítását egy bizonyos tétlen időszakasz után.


A telepítéssel kapcsolatos fogalmak

Ha egy COM+ alkalmazást telepít, ezzel a kész alkalmazást és komponenst elérhetővé teszi a számítógépen vagy a hálózaton. Az alkalmazások telepítésének hagyományos módjától eltérően a COM+ alkalmazások telepítése általában két alapvető lépésből áll, melyek a következők: kiszolgáló- és ügyféloldali telepítési fájlok exportálása, majd ezek használatával a proxyra és az alkalmazásra vonatkozó adatok telepítése a hálózaton lévő ügyfél- és kiszolgáló-számítógépekre.

További információ a következő témakörökben található:

Témakör | Leírás
Az alkalmazások telepítése előtti teendők | A telepítésre vonatkozó, és a konfigurálással, illetve a biztonsággal kapcsolatos megjegyzések
A COM+ alkalmazások telepítése – áttekintés | Telepítési forgatókönyvek és a telepítés lépésenként történő bemutatására mutató hivatkozások
Fejlesztői és termelési számítógépek | Bevezetés a fejlesztéshez és teszteléshez, illetve az alkalmazások végleges üzembe helyezéséhez használt számítógépek elkülönítésének fogalomkörébe
A COM+ alkalmazások kiszolgálóoldali telepítése | Kiszolgálóoldali komponensek telepítésének áttekintése és ellentmondásai
A COM+ alkalmazások ügyféloldali telepítése | Ügyféloldali komponensek telepítésének áttekintése és ellentmondásai


Az alkalmazások telepítése előtti teendők

Az alkalmazásoknak a Komponensszolgáltatások felügyeleti eszközzel történő telepítéséhez bizonyos rendszerbiztonsági jogosultságokra van szükség. A COM+ alkalmazások telepítésekor felmerülő biztonsági kérdésekről további tudnivalók A biztonság beállítása című témakörben találhatók.

A COM+ alkalmazásoknak a Komponensszolgáltatások felügyeleti eszközzel történő telepítésekor a biztonság beállítása mellett egyéb konfigurációs feladatokat is el kell végezni. A Komponensszolgáltatások környezetének konfigurálásával kapcsolatos további információt A Komponensszolgáltatások felügyeleti életciklusa című témakörben talál.


A COM+ alkalmazások telepítése – áttekintés

A COM+ alkalmazások telepítésére gyakran egy nagyobb alkalmazás részeként kerül sor az alkalmazás forgalmazója vagy egy belső fejlesztő által nyújtott hagyományos telepítőprogram segítségével. Előfordulhat azonban, hogy néha kézzel kell ezeket telepíteni és konfigurálni.

A COM+ alkalmazások kézzel történő telepítésének lépései a következők:

  1. A COM+ alkalmazás konfigurálása egy adott célkörnyezetnek megfelelően
  2. Környezetfüggő ügyfél- és kiszolgálóoldali telepítőfájlok exportálása
  3. Konfigurált vagy nem konfigurált COM+ alkalmazás vagy COM+ alkalmazásproxy telepítése

Attól függően, hogy az alkalmazás forgalmazója vagy fejlesztője mivel látja el az alkalmazást, előfordulhat, hogy a fenti lépések közül egyik vagy másik kihagyható. További tudnivalók az alkalmazás dokumentációjában találhatók.

A COM+ alkalmazások általában

  • a fejlesztő vagy az alkalmazásgazda által nyújtott teljes mértékben konfigurált alkalmazások, vagy
  • a fejlesztő, illetve a független szoftverforgalmazó által biztosított nem, vagy csak részben konfigurált alkalmazások lehetnek.

A teljes mértékben konfigurált alkalmazásokat gyakran cégen belül fejlesztett alkalmazásokhoz használják, hiszen ilyen esetben a fejlesztő vagy az alkalmazásgazda pontosan ismeri a célkörnyezetet (a felhasználói fiókokat vagy csoportokat, a kiszolgálóneveket stb.). Ilyenkor a fejlesztő már konfigurálta és exportálta az alkalmazást, és a rendszergazda feladata az alkalmazásnak a célrendszerre történő telepítésére korlátozódik.

A nem, vagy csak részben konfigurált alkalmazások gyakran harmadik féltől megvásárolt, üzletben beszerezhető alkalmazások. A forgalmazó esetenként hagyományos telepítőprogramot is mellékel, amely a rendszergazdát végigkalauzolja a szükséges lépéseken. Ha ilyen telepítőprogram nincs mellékelve, a COM+ alkalmazás telepítését és konfigurálását a rendszergazdának kell elvégeznie. A konfigurálás gyakran inkább fejlesztői, mint termelési számítógépen történik. Ebben az esetben a COM+ alkalmazást és a COM+ alkalmazásproxyt újra kell exportálni, majd telepíteni a termelési számítógépen. A fejlesztői számítógépek használatával kapcsolatos további tudnivalókat a Fejlesztői és termelési számítógépek című témakörben találja meg.

Az alkalmazások telepítésének lépéseiről A telepítéssel kapcsolatos feladatok című témakörben olvashat.

A COM+ alkalmazások konfigurációjának áttekintése A Komponensszolgáltatások felügyeleti életciklusa című témakörben található.

A COM+ alkalmazások verzióinak frissítése

Idővel, ahogy elavulnak vagy használaton kívül kerülnek, szükség lehet a COM+ alkalmazások eltávolítására, illetve frissítésére. Egy COM+ alkalmazás frissítéséhez először a korábban telepített változatot kell törölni, a frissített alkalmazás csak ez után telepíthető.

A frissítés részletes teendőit a COM+ alkalmazások eltávolítása és a COM+ alkalmazások telepítése című témakörökben olvashatja.


Fejlesztői és termelési számítógépek

Az alkalmazások fejlesztői számítógépekre is telepíthetők, így lehetőség nyílik olyan helyzetek szimulálására, amelyek az alkalmazásoknak a hálózaton lévő más, termelési számítógépeken történő üzembe helyezése után előfordulhatnak.

Egyes esetekben szükség lehet az alkalmazások módosítására, tekintettel a fejlesztői és a termelői környezet közti különbségekre. A biztonsági konfiguráció például eltérő lehet a különböző környezetekben. Más esetekben a konfiguráció megegyezik, a különbség csak abban áll, hogy a fejlesztői számítógép nem érhető el nyilvánosan. Ilyenkor szükség lehet az alkalmazások többszörözésére, azaz az alkalmazások és konfigurációjuk érvényesített készletének fejlesztői számítógépről termelési számítógépre történő áthelyezésére.

A többszörözéssel kapcsolatos további tudnivalók a COM+ alkalmazások többszörözése című részben találhatók.

A fejlesztői számítógépek a verziószámok kezelését és a komponensek frissítését is lehetővé teszik. Ahelyett, hogy a konfigurációk módosítását és az egyes komponensek frissítését a termelési számítógépen végezné el, az alkalmazások módosítását és tesztelését elvégezheti a fejlesztői számítógépen, majd a termelési számítógépen történő telepítéshez egy egységként exportálhatja az alkalmazást.


A COM+ alkalmazások kiszolgálóoldali telepítése

Egy COM+ kiszolgálóalkalmazás egy COM+ kiszolgálóalkalmazás-fájlt (.msi) tartalmaz. Az alkalmazás a Komponensszolgáltatások felügyeleti eszközzel vagy a Windows Installer programmal telepíthető.

Ha a COM+ alkalmazás egyik komponense számára szükség van más erőforrások (adatbázis-kapcsolatok, adat- vagy szövegfájlok, Internet Information Services (IIS) virtuálisgyökér-konfigurációja stb.) telepítésére vagy konfigurálására, akkor ezeket a Komponensszolgáltatások felügyeleti eszköztől eltérő, más eszközzel kell telepíteni. További tudnivalók az alkalmazás forgalmazója által mellékelt dokumentációban találhatók.

Az alkalmazások telepítésének lépéseiről a COM+ kiszolgálóalkalmazások telepítése című témakörben tájékozódhat.


A COM+ alkalmazások ügyféloldali telepítése

Miután megtörtént a COM+ kiszolgálóalkalmazás telepítése a számítógépre, szükség lehet annak távoli elérésére, ami a DCOM vagy a Message Queuing szolgáltatás segítségével valósítható meg. További részletek a alkalmazás forgalmazója által mellékelt dokumentációban találhatók.

Ha az alkalmazás elérése távolról valósul meg, a Komponensszolgáltatások felügyeleti eszközzel COM+ alkalmazásproxyt exportálhat. Az alkalmazásproxy-fájl (.msi) tartalmazza azokat a rendszerleíróadatbázis-adatokat, amelyek a COM+ kiszolgálóalkalmazásban lévő osztályoknak az ügyfélszámítógépről a DCOM modell segítségével történő távoli eléréséhez szükségesek. A fájl használatával telepíthető a COM+ alkalmazásproxy a hely ügyfélszámítógépeire.

Mód van olyan alkalmazásproxy létrehozására, amely egy másik kiszolgálóhoz fér hozzá, és nem ahhoz a számítógéphez, amelyről exportálása megtörtént. Ez akkor hasznos, ha a termelési számítógép alkalmazásproxyját fejlesztői számítógépről kell exportálni. A kiszolgáló nevének megváltoztatását a Komponensszolgáltatások felügyeleti eszközben, a Sajátgép tulajdonságai párbeszédpanel Beállítások lapján végezheti el, ahol beírhatja az alkalmazásproxy távoli kiszolgálójának helyes nevét (RSN).

Az alkalmazásproxyk exportálásának és telepítésének lépéseit a COM+ alkalmazásproxyk exportálása és a COM+ alkalmazásproxyk telepítése című témakörökben találja meg.


A telepítéssel kapcsolatos feladatok

A következő témakörök bemutatják a COM+ alkalmazások telepítésekor elvégzendő feladatokat. A feladatokat általában az itt felsorolt sorrendben kell végrehajtani.

  • COM+ kiszolgálóalkalmazások exportálása
  • COM+ kiszolgálóalkalmazások telepítése
  • COM+ alkalmazásproxyk exportálása
  • COM+ alkalmazásproxyk telepítése
  • COM+ alkalmazások eltávolítása
  • COM+ alkalmazások többszörözése


COM+ kiszolgálóalkalmazások exportálása

A Komponensszolgáltatások felügyeleti eszköz segítségével exportálhatja az egy vagy több másik kiszolgálóra telepítendő COM+ kiszolgálóalkalmazást. A felügyeleti eszköz használható például a COM+ alkalmazás fejlesztéséhez és teszteléséhez használt fejlesztői számítógépről a helyen lévő termelési számítógépre történő másolására.

A COM+ kiszolgálóalkalmazás exportálása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson arra az alkalmazásra, amelyet exportálni szeretne.
  2. A jobb oldali egérgombbal kattintson az alkalmazásra, majd az Exportálás parancsra.
  3. A COM alkalmazásexportálási varázsló első párbeszédpanelén kattintson a Tovább gombra.
  4. Az Alkalmazásexportálási információ párbeszédpanelen írja be a létrehozandó alkalmazásfájl teljes elérési útját, vagy a már meglévő fájl vagy könyvtár megkereséséhez kattintson a Tallózás gombra.

    A varázslóból való kilépéskor egy .msi fájl jön létre a megadott néven. A fájl a COM+ alkalmazással kapcsolatos szükséges adatokat tartalmazza.

  5. Az Exportálás a következőként csoportban jelölje be a Kiszolgálóalkalmazás - Az alkalmazás telepítése más számítógépre választógombot.
  6. Ha az alkalmazás szerepköreihez rendelt felhasználót szeretne felvenni, jelölje be a Felhasználóazonosítók exportálása szerepkörökkel együtt jelölőnégyzetet.

    Csak akkor válassza ezt a lehetőséget, ha olyan számítógépre szeretné telepíteni az alkalmazást, amely ugyanabban a Windows 2000 biztonsági tartományban helyezkedik el, mint az a számítógép, amelyről az alkalmazás exportálását végrehajtja. Ha nem így történik, akkor előfordulhat, hogy a szerepkörökhöz rendelt felhasználóazonosítók érvénytelenek lesznek, és az alkalmazás telepítésekor hibát okozhatnak.

    Körültekintően járjon el abban az esetben is, ha az alkalmazást olyan számítógépre szeretné telepíteni, amelyen a Windows 2000 rendszer nyelvi verziója eltér attól, amellyel a Windows 2000 azon a számítógépen fut, amelyről az alkalmazást exportálja. Egyes felhasználó- vagy csoportnevek, mint például az „Administrators”, a célszámítógépen honosítva lehetnek. Ezeket a felhasználókat újra hozzá kell adni a szerepkörökhöz, mert e nélkül nem férhetnek hozzá a célszámítógépen lévő alkalmazáshoz.

  7. Kattintson a Tovább gombra.
  8. A záró párbeszédpanelen kattintson a Befejezés gombra.

Megjegyzés Az alkalmazás változtatások vagy törlés elleni védelmét az alkalmazással együtt exportálja.

Fontos Ha egy komponens osztályazonosítója (CLSID), típustár azonosítója (TypeLibId) vagy csatolóazonosítója (IID) az alkalmazás exportálása után megváltozik, az alkalmazást újra kell exportálni és telepíteni.


COM+ kiszolgálóalkalmazások telepítése

A COM+ kiszolgálóalkalmazásokat a Komponensszolgáltatások felügyeleti eszközzel telepítheti.

Ezen eljárás végrehajtásához az Administrator szerepkör tagjának kell lennie a célszámítógép rendszeralkalmazásában. Az alapértelmezett konfigurációban csak a helyi számítógépek rendszergazdája van ehhez a szerepkörhöz rendelve. További információért olvassa el A biztonság beállítása című témakörben foglaltakat.

Egy alkalmazás minimális konfigurációja az, amikor nincs szükség biztonságra. Ha az alkalmazás biztonságára szükség van, a Komponensszolgáltatások felügyeleti eszköz segítségével beállíthat folyamatszintű biztonságot, vagy előre definiált szerepkörökhöz felhasználókat rendelhet az alkalmazás telepítése után. Az alkalmazás biztonságának konfigurálásáról további tudnivalókat talál A biztonsággal kapcsolatos felügyeleti feladatok című témakörben.

COM+ kiszolgálóalkalmazások a Komponensszolgáltatások felügyeleti eszközzel, a Windows Intézőből vagy a parancssorból telepíthetők.

Fontos COM+ kiszolgálóalkalmazások csak Windows 2000 rendszerrel működő számítógépre telepíthetők. A kiszolgálóalkalmazások számára szükség van a Komponensszolgáltatásokat támogató platformra.

COM+ alkalmazás telepítése a Komponensszolgáltatások felügyeleti eszközzel
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson duplán arra a számítógépre, amelyre az alkalmazást telepíteni szeretné.
  2. Kattintson az egér jobb gombjával a számítógép COM+ alkalmazások mappájára, mutasson az Új pontra, majd kattintson az Alkalmazás parancsra.
  3. A COM alkalmazástelepítési varázsló első párbeszédpanelén kattintson a Tovább gombra.
  4. Az Új alkalmazás telepítése vagy létrehozása párbeszédpanelen kattintson a Előregyártott alkalmazás(ok) telepítése gombra.
  5. A Telepítés az alkalmazásfájlból párbeszédpanelen tallózással keresse meg a telepítendő alkalmazás .msi fájlját, majd kattintson a Megnyitás gombra.
  6. Az Alkalmazásfájlok kijelölése párbeszédpanelen kattintson a Hozzáadás gombra, így tallózással kereshet további telepítendő alkalmazásokat.
  7. Kattintson a Tovább gombra.
  8. Az Alkalmazásazonosító beállítása párbeszédpanelen adja meg az alkalmazás azonosítóját, majd kattintson a Tovább gombra.

    Az alapértelmezett beállítás az Interaktív felhasználó. Az interaktív felhasználó az a felhasználó, aki az alkalmazást futtató számítógéphez tartozó Windows 2000 fiókhoz bejelentkezett. Az Adott felhasználó lehetőség választásával és egy adott Windows 2000 felhasználó vagy csoport adatainak megadásával másik felhasználót is megjelölhet.

  9. Az alkalmazás telepítési beállításai párbeszédpanelen adja meg azt a könyvtárat, ahová a COM+ alkalmazást telepíteni szeretné.

    Az alkalmazás komponensfájljai az .msi fájlból a telepítőkönyvtárba másolódnak. Az alapértelmezett telepítőkönyvtár a következő:

    %Program Files%\COMPlus Applications\[<alkalmazásazonosító>]

    Elfogadhatja az alapértelmezett könyvtárt, vagy Az itt megadott könyvtár választógombra, majd a Tallózás gombra kattintva kereshet más helyet is.

    Ezen eljárás elvégzéséhez a 9. lépésben megadott alkalmazásazonosítónak a telepítőkönyvtárhoz legalább olvasási, míg az eljárás során a Komponensszolgáltatások felügyeleti eszközt használó személynek írási hozzáférési jogosultsággal kell rendelkeznie.

  10. Kattintson a Befejezés gombra.

    Ezt követően az új alkalmazást az Intéző konzolfájának hierarchiájában, a részleteket megjelenítő ablaktáblában láthatja. Ha több alkalmazást telepít, a 9. és 10. lépésben választott beállítások mindegyikre vonatkoznak majd.

COM+ kiszolgálóalkalmazás telepítése a Windows Intézőből
  1. A Windows Intézővel keresse meg a kiszolgálóalkalmazás-fájlt (.msi) azon a számítógépen, amelyre a COM+ alkalmazást telepíteni szeretné. A fájl a helyi számítógépen vagy egy hálózati megosztáson található.
  2. Kattintson duplán a kiszolgálóalkalmazás-fájlra vagy az egér jobb gombjával a fájl nevére, majd a Telepítés parancsra. A Microsoft telepítő automatikusan a célszámítógépre telepíti a kiszolgálóalkalmazást.

COM+ kiszolgálóalkalmazás telepítése a parancssorból
  • Írja be a parancssorba a következő parancssorozatot:

    msiexec -i [<tulajdonságok_felülbírálata>] <alkalmazás_neve>.msi

    A Windows Installer szabványos tulajdonság-felülbírálati módszerei mellett megadható a következő beállítás, amely segítségével a COM+ alkalmazás telepítőkönyvtára az alapértelmezettről a megadott könyvtárra módosítható:

    TARGETDIR = <a_telepítés_célkönyvtára>

Az eljárás végrehajtása más módon

A COM+ alkalmazást úgy is telepítheti, hogy az alkalmazásfájlt áthúzza a Windows Intézőből a Komponensszolgáltatások felügyeleti eszköz részleteket megjelenítő ablaktáblájába, miközben a számítógép COM+ alkalmazások mappája nyitva van.


COM+ alkalmazásproxyk exportálása

A COM+ alkalmazásproxyt a Komponensszolgáltatások felügyeleti eszközzel telepítheti. Miután az ügyfélszámítógépeken megtörtént a proxy telepítése, a proxy adatainak felhasználásával lehetővé válik, hogy az ügyfélalkalmazások a DCOM modellen keresztül megkeressék és elérjék a termelési számítógépeken futó COM+ kiszolgálóalkalmazásokat.

COM+ alkalmazásproxy exportálása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson az alkalmazásra, majd az Exportálás parancsra.
  2. A COM alkalmazásexportálási varázsló első párbeszédpanelén kattintson a Tovább gombra.
  3. Az Alkalmazásexportálási információ párbeszédpanelen írja be a létrehozandó alkalmazásproxy-fájl teljes elérési útját, vagy a már meglévő fájl vagy könyvtár megkereséséhez kattintson a Tallózás gombra.
  4. Az Exportálás a következőként csoportban jelölje be az Alkalmazásproxy - A telepítés biztosítja, hogy más számítógépekről is hozzá lehessen férni ehhez a számítógéphez választógombot.
  5. Kattintson a Tovább gombra.
  6. A záró párbeszédpanelen kattintson a Befejezés gombra.

Alapértelmezés szerint az alkalmazásproxy-fájl tartalmazza annak a távoli kiszolgálónak az adatait, amely arra a számítógépre mutat, amelyről az alkalmazásproxyt exportálta. Ha az alkalmazásproxyt a fürtszolgáltatás segítségével virtuális kiszolgálóról exportálja, az alkalmazásproxy alapértelmezés szerint azt a csomópontot használja, amelyen a virtuális kiszolgáló a távoli kiszolgáló nevében az exportálást végrehajtotta. A Komponensszolgáltatások felügyeleti eszközzel az alapértelmezett távoli kiszolgáló megváltoztatható.

Az alkalmazásproxyk által használt más távoli kiszolgáló megadása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelyről az alkalmazásokat exportálja.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson a Beállítások fülre.
  3. Az Exportálás csoportban az Alkalmazásproxy RSN mezőbe írja be annak a távoli számítógépnek a nevét, amelyet az alkalmazásproxyk használnak majd.
  4. Kattintson az OK gombra.

Érdemes megjegyezni, hogy az alkalmazásproxy-fájlban lévő alapértelmezett távoli kiszolgáló neve a telepítéskor is felülírható. További tudnivalókat a COM+ alkalmazásproxyk telepítése című témakörben talál.

Fontos Ha egy komponens osztályazonosítója (CLSID), típustár azonosítója (TypeLibId) vagy csatolóazonosítója (IID) az alkalmazás exportálása után megváltozik, az alkalmazásproxyt újra kell exportálni és telepíteni az ügyfélszámítógépre.


COM+ alkalmazásproxyk telepítése

Az alkalmazásproxy Windows Installer (.msi) fájlként történő létrehozása után a fájlt egyszerűen lehet az ügyfélszámítógépre telepíteni. Az alkalmazásproxy telepítése biztosítja azokat a rendszerleíróadatbázis-adatokat, amelyekre az ügyfélalkalmazásoknak szükségük van ahhoz, hogy a COM+ alkalmazást az ügyfélszámítógépről távolról elérjék.

Fontos A COM+ alkalmazásproxy bármely számítógépre telepíthető, amelyen fut a Windows Installer. A Windows Installer minden Windows 2000 rendszerrel működő számítógépre automatikusan telepítésre kerül, de Windows 95, Windows 98 és Windows NT 4.0 rendszerű számítógépekhez is elérhető. Az olyan alkalmazásproxy azonban, amelynek szüksége van az aszinkron komponensek szolgáltatásra, csak Windows 2000 rendszerrel működő számítógépre telepíthető. Az aszinkron komponensek szolgáltatás csak a Komponensszolgáltatásokat támogató platformokon érhető el.

COM+ alkalmazásproxy telepítése a Windows Intézőből
  1. A Windows Intéző segítségével keresse meg az alkalmazásproxy-fájlt (.msi) az ügyfélszámítógépen. A fájl a helyi számítógépen vagy egy hálózati megosztáson található.
  2. Kattintson duplán az alkalmazásproxy-fájlra vagy az egér jobb gombjával a fájl nevére, majd a Telepítés parancsra. A Microsoft telepítő automatikusan az ügyfélszámítógépre telepíti az alkalmazásproxyt.

COM+ alkalmazásproxy telepítése a parancssorból
  • Írja be a parancssorba a következő parancssorozatot:

    msiexec -i [<tulajdonságok_felülbírálata>] <alkalmazás_neve>.msi

    A Windows Installer szabványos tulajdonság-felülbírálati módszerei mellett megadhatók a következő beállítások is:

A telepítő beállítása | Leírás
REMOTESERVERNAME = <új_célkiszolgáló> | Az exportált alapértelmezettről a megadott új célkiszolgálóra módosítja az ügyfélszámítógép által elért kiszolgálót.
ALLUSERS = 0 | Az alkalmazásproxyt csak az aktuális felhasználó számára telepíti. Alapértelmezés szerint az alkalmazásproxy telepítése a számítógép egésze számára történik.
TARGETDIR = <a_telepítés_célkönyvtára> | A COM+ alkalmazás telepítési könyvtárát az alapértelmezettről a megadottra módosítja.


COM+ alkalmazások eltávolítása

Mivel a létező alkalmazások elavulnak, vagy nincs szüksége rájuk, el is távolíthatja őket.

COM+ alkalmazás eltávolítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson duplán arra a számítógépre, amelyről az alkalmazást el szeretné távolítani.
  2. Kattintson duplán a COM+ Alkalmazások mappára, hogy a megadott számítógép alatt megjelenjen az összes alkalmazás.
  3. Kattintson az eltávolítani kívánt alkalmazásra.
  4. Ha kiszolgálóalkalmazást választ, zárja be azt. Ehhez a jobb gombbal kattintson az alkalmazásra, majd a Leállítás parancsra. Ha függvénytár-alkalmazást választ, győződjön meg arról, hogy az azt használó összes folyamat zárva van-e.
  5. A jobb oldali egérgombbal kattintson az alkalmazásra, majd a Törlés parancsra.
  6. Az alkalmazás eltávolításához kattintson az Igen gombra.

Megjegyzés Ha egy COM+ kiszolgálóalkalmazást működés közben töröl, az alkalmazás a törlés előtt figyelmeztető üzenet nélkül leáll.

Az eljárás végrehajtása más módon

A kiszolgálóalkalmazások és az alkalmazásproxyk eltávolításának számos más módja is van. Ezek a következők:

  • Használja a Vezérlőpulton lévő Programok telepítése/törlése párbeszédpanelt.
  • A jobb oldali egérgombbal kattintson az .msi fájlra, majd az Eltávolítás parancsra.
  • COM+ alkalmazás eltávolítható az alábbi Windows Installer parancssori szintaxissal is:

    msiexec -x <alkalmazás_neve>.msi

A COM+ alkalmazások eltávolításának fenti módszerei különösen olyan ügyfélszámítógépen hasznosak, amelyen nem fut a Komponensszolgáltatások felügyeleti eszköz.

Az alkalmazás törlésével annak valamennyi komponensét is törli. Ha ezek a komponensek további erőforrásoktól függnek (adatbázis-kapcsolatoktól, adat- vagy szövegfájloktól, az IIS virtuálisgyökér-konfigurációjától), akkor ezeket az erőforrásokat a Komponensszolgáltatások felügyeleti eszköztől eltérő, más eszközzel kell eltávolítani.


COM+ alkalmazások többszörözése

Előfordulhat, hogy szükség lehet valamennyi COM+ alkalmazás és konfigurációjuk egyik (fő)számítógépről másik (többszörözési cél)számítógépre történő többszörözésére. A többszörözés a következő esetekben hasznos:

  • Webtelep
  • Átvételi fürt
  • Áthelyezés fejlesztői számítógépről termelési számítógépre

A többszörözést kézzel is megvalósíthatja úgy, hogy az egyes alkalmazásokat egyenként exportálja és telepíti a főszámítógépre. A Windows 2000 által a COM+ alkalmazásokhoz nyújtott többszörözési segédprogram (COMRepl.exe) azonban egyszerűsítheti ezt a meglehetősen fárasztó és sok hibalehetőséget rejtő feladatot. Az eszköz az egész számítógépre kiterjedő COM+ konfigurációk többszörözésére is alkalmas.

A COMREPL parancssori segédprogram meghívása a következő paranccsal történhet:

COMREPL <forrásszámítógép> <célszámítógépek_listája> [/n [/v]]

A paraméterek magyarázata a következő táblázatban látható:

Paraméter | Leírás
<forrásszámítógép> | A forrásszámítógép neve
<célszámítógépek_listája> | A célszámítógépek nevei, egymástól szóközzel elválasztva
/n | A megerősítés kihagyása a többszörözés kezdete előtt
/v | Naplófájlkimenet másolása a konzolra

Megjegyzések

  • A Komponensszolgáltatásoknak minden célszámítógépen telepítve kell lenniük, hiszen nem a Komponensszolgáltatások, hanem a konfigurációs adatok és az alkalmazások többszörözése történik.
  • A felhasználónak meg kell felelnie a szerepkör-ellenőrzésnek mind a forrás-, mind a célszámítógépen.
  • A szerepkörök által használható, helyi számítógépen lévő fiókok többszörözése nem valósul meg.
  • A célszámítógép(ek)et on-line állapotba kell helyezni.
  • A felhasználó felelős minden olyan adatnak a célszámítógépre történő többszörözéséért, amely nem kapcsolódik a Komponensszolgáltatásokhoz. (Ilyen adatok például az adatbázis-táblázatok, adatfájlok stb.)
  • Windows 2000 rendszerrel működő számítógépfürtök is részt vehetnek a többszörözésben, de mivel a COMREPL csak a megnevezett számítógépeken hajtja végre a többszörözést, ha egy meghibásodott számítógép cseréjére kerül sor, a többszörözés csak a megnevezett számítógépen valósul meg.


Az alkalmazásbiztonság felügyelete

A Komponensszolgáltatások eszköz egyszerű és hatékony biztonsági modellt kínál a COM+ alkalmazások, adatok és erőforrások véletlen sérülés vagy szándékos rongálás elleni védelméhez. A szerepkörök (azaz a fejlesztő által az alkalmazáshoz definiált felhasználói kategóriák) képezik ennek központi mechanizmusát. A szerepköröket eredetileg a fejlesztő rendeli az alkalmazáshoz és annak komponenseihez, majd a rendszergazda tölti fel azokat a tényleges felhasználókkal. Miután ez megtörtént, a szerepkörök az alkalmazás hozzáférés-szabályzási házirendjeként szolgálnak.

Felügyeleti szempontból a szerepköralapú biztonság áttekinthetővé és egyszerűvé teszi a COM+ alkalmazások biztonságának karbantartását. A szerepköralapú biztonsággal kapcsolatos felügyeleti feladatok általában csak abból állnak, hogy az alkalmazás előre definiált szerepköreit fel kell tölteni Windows 2000 csoportokkal és felhasználói fiókokkal, és be kell állítani egy alkalmazásazonosítót (azaz egy felhasználói fiókot, amely alatt az alkalmazás fut).

Ha az alábbi hivatkozásokra kattint, elolvashatja a háttér-információkat és a feladatokkal kapcsolatos tudnivalókat.

Témakör | Leírás
A biztonság felügyeletével kapcsolatos fogalmak | Áttekintés és az alkalmazásbiztonság felügyeletével kapcsolatos további tudnivalókhoz vezető hivatkozások
A biztonsággal kapcsolatos felügyeleti feladatok | A biztonsággal kapcsolatos feladatok egyes lépéseinek leírásához vezető hivatkozások

A munka megkezdése előtt

A biztonság az alkalmazástervezés lényegi része kell, hogy legyen. A fejlesztő felméri a biztonsági követelményeket, és összhangba hozza azokat a teljesítménnyel és a működőképességgel szemben támasztott követelményekkel. A fejlesztő eldönti, hogy melyik szerepköralapú biztonsági szint alkalmazására van szükség, majd beépíti azokat a szerepköröket, amelyek az alkalmazás célfelhasználóinak kategóriáit jelképezik. Egy ilyen döntés az alkalmazás működőképességére minden szempontból hatással van, ezért a döntést a tervezés egészét figyelembe véve kell meghozni.

A szerepköralapú biztonsággal kapcsolatos átfogó bevezető a Microsoft Platform SDK csomagban, a Component Services témakör COM+ Security című részében található meg.

A COM-alkalmazások biztonságának kérdéseivel a Microsoft Platform SDK csomag Component Services témakörének COM Security című része foglalkozik.


A biztonság felügyeletével kapcsolatos fogalmak

A COM+ alkalmazások által használt szerepköralapú biztonsági modell a Windows 2000 és a COM biztonsági mechanizmusaira épül, és felhasználóazonosítást, hitelesítési szolgáltatásokat, valamint megszemélyesítést és delegálást foglal magába – ezek a felhasználó tudta nélkül az alaprétegeken működnek. A Windows 2000 az alapvető védelmet a bejelentkezéskor történő felhasználóazonosítás, a rendszererőforrások elérésének szabályzása, a helyi felhasználókon és csoportokon keresztül ellenőrzött biztonsági események, illetve az NTFS-fájlrendszer fájlvédelme által valósítja meg. A Komponensszolgáltatások biztonságának felügyeletéhez ismernie kell a Windows 2000 biztonsági szolgáltatásait. Bővebb tájékoztatásért olvassa el a Windows 2000 dokumentációját. Ha további információkra van szüksége, tanulmányozza a Microsoft Windows 2000 Resource Kit csomagot.

A COM+ alkalmazások biztonságának felügyelete

A COM+ alkalmazások biztonságával kapcsolatban a következő felügyeleti feladatok végezhetők el:

  • Windows 2000 felhasználók hozzárendelése az alkalmazás előre definiált szerepköreihez, majd a szerepkörök folyamatos kezelése.
  • Azon alkalmazásazonosító (általában felhasználói fiókként) történő beállítása telepítéskor, amely alatt az alkalmazás fut, és amelyet az alkalmazás akkor használ, amikor más alkalmazásokat vagy erőforrásokat hív meg. (Ez csak a kiszolgálóalkalmazásokra vonatkozik, függvénytár-alkalmazások esetében nem szükséges.)

A szerepköralapú biztonság hatékony felügyeletéhez ismerni kell az alkalmazás biztonsági igényeit, és azt, hogy ezek a szerepkörökön keresztül miként érvényesülnek. Nagyon fontos, hogy a felhasználók a nekik megfelelő szerepkörökhöz legyenek hozzárendelve az alkalmazás biztonsági házirendje szerint. További információt a következő témakörökben talál:

Témakör | Leírás
Szerepköralapú biztonság | A szerepköralapú biztonság működésének áttekintése és a kapcsolódó feladatokhoz vezető hivatkozások
Az alkalmazás azonosítója | Az alkalmazásazonosító használatának áttekintése és a kapcsolódó információkhoz vezető hivatkozások

Vigyázat! A Komponensszolgáltatások felügyeleti eszközzel megváltoztathatók a COM+ alkalmazás által használt szerepköralapú biztonsági beállítások. Kifejezetten ajánlott, hogy az alkalmazás biztonsági beállításait ne módosítsa. A szerepköralapú biztonságot használó alkalmazás olyan kódot tartalmazhat, amely a szerepkörtagság ellenőrzésére támaszkodik. Ha módosítja biztonsági beállításait, előfordulhat, hogy az alkalmazás működésképtelenné válik, vagy nem rendeltetésszerűen, illetve nem biztonságosan működik.

A COM-alkalmazások biztonságának felügyelete

A COM-alkalmazások számos biztonsági konfigurációs tulajdonságot használnak. E tulajdonságok a számítógép egészére érvényes beállításokkal rendelkeznek, amelyeket az alkalmazások alapértelmezés szerint használnak. A COM biztonsági beállítások bármely alkalmazáshoz testre is szabhatók. Ha egy adott alkalmazás nem rendelkezik egyéni biztonsági beállításokkal, akkor azon számítógép beállításait használja, amelyen fut.

A Komponensszolgáltatások felügyeleti eszközzel módosíthatók a számítógép egészére érvényes COM biztonsági tulajdonságok, a DCOMCNFG segédprogrammal pedig az egyes alkalmazásokhoz egyéni biztonsági beállítások adhatók meg. Általában nem szükséges módosításokat végrehajtani, bár az egyes alkalmazások vagy rendszerek esetében a biztonsági követelmények megkívánhatják a változtatásokat.

Témakör | Leírás
COM-alkalmazások biztonsági beállításai | A COM biztonsági konfigurációs tulajdonságainak áttekintése és a kapcsolódó információkhoz vezető hivatkozások

A COM+ és a COM-alkalmazások közötti különbségek leírását megtalálhatja A Komponensszolgáltatások felügyeletével kapcsolatos fogalmak című témakörben. A COM-alkalmazások biztonságáról átfogó leírás található a Microsoft Platform SDK csomagban, a Component Services témakör COM Security című részében. Ugyanitt megtalálhatók a DCOMCNFG használatával kapcsolatos eljárások is.


Szerepköralapú biztonság

A biztonsági szerepkörök a COM+ alkalmazásokra vonatkozó hozzáférés-szabályzási házirendet modellezik és érvényesítik. A szerepkörök a felhasználók azon kategóriái, amelyek az alkalmazás erőforrásaihoz történő hozzáférési jogosultságokat definiálják az egyes alkalmazások esetében. A szerepköröket (mint szimbolikus felhasználói kategóriákat) a fejlesztő rendeli az alkalmazáshoz és esetleg az azon belüli árnyaltabb struktúrákhoz, például komponensekhez, objektumfelületekhez, metódusokhoz vagy egyéni alkalmazás-erőforrásokhoz. Ezen szerepkör-hozzárendelések segítségével aztán megállapítható, hogy mely felhasználói kategóriák az alkalmazás mely elemeihez rendelkeznek hozzáférési jogosultsággal. Ha az alkalmazás szerepköralapú biztonságot alkalmaz, akkor az alkalmazás meghívásakor a hívó szerepkörtagságának ellenőrzésére kerül sor. Ha a hívó nem tartozik az elemhez hozzáférési jogosultsággal bíró szerepkörhöz, a hívás sikertelen lesz. A hívók az alkalmazáshoz vagy annak erőforrásaihoz hozzáférési engedélyt csak azon szerepkörben definiált határokon belül kaphatnak, amelyhez tartoznak.

Az alkalmazás számára definiált szerepkörök Windows 2000 felhasználói fiókokkal és csoportokkal történő feltöltése a rendszergazda feladata. Ez az alkalmazás biztonsági házirendje megvalósításának lényeges fázisa. A felhasználókat olyan szerepkörökhöz kell rendelni, amelyek híven tükrözik a felhasználók kapcsolatát azokkal az adatokkal és erőforrásokkal, amelyeket az alkalmazásból elérhetnek.

Felhasználói csoportok hozzárendelése

A szerepkörök felhasználókkal való feltöltésének kedvelt módja a Windows 2000 csoportok használata. Először felhasználói fiókot kell a megfelelő csoportokhoz rendelni, majd biztosítani kell, hogy a csoportok a megfelelő szerepkörökhöz legyenek hozzárendelve. Ha Windows 2000 csoportokat használ a szerepkörök feltöltésére, akkor egyszerűbbé válik a nagyszámú felhasználók kezelése. Vállalati számítógépes környezetben gyakran igen nehéz hatékonyan nyomon követni az egyes felhasználók cégen belüli elhelyezkedését, és eldönteni, hogy az adott helyzet hogyan illeszthető az egyes alkalmazásokra jellemző szerepköralapú biztonsági házirendbe. A felhasználók, a rendszergazdák és az alkalmazások számának növekedésével ez a feladat egyre bonyolultabbá válik. A legjárhatóbb utat felhasználói csoportok COM+ alkalmazások szerepköreihez történő rendelése jelenti.

Ezt megelőzően azonban alaposan meg kell ismerkednie az alkalmazás biztonsági házirendjével. Ideális esetben a szerepköröket olyan nevekkel érdemes ellátni, amelyek utalnak a hozzájuk tartozó felhasználókra, például „Igazgatók” és „Pénztárosok”. Emellett minden szerepkörhöz tartozik egy leírás – ez a Komponensszolgáltatások felügyeleti eszköz segítségével érhető el –, amely leírja, hogy az adott szerepkörhöz milyen felhasználók tartozzanak. Ha viszont nem biztos abban, hogy mely felhasználói csoportok mely szerepkörhöz tartoznak, olvassa el az alkalmazáshoz mellékelt dokumentációt vagy felvilágosításért forduljon a fejlesztőhöz.

A Komponensszolgáltatások felügyeleti eszköz segítségével egyrészt a telepítéskor végrehajtható a szerepkörök kezdeti hozzárendelése, másrészt az alkalmazás élettartama alatt elvégezhető a szerepkörtagság módosítása.

A szerepkörtagság kezelésének részfeladataival kapcsolatos utasítások az alábbi témakörökben találhatók meg:

  • Felhasználói fiókok vagy csoportok hozzárendelése egy szerepkörhöz
  • Felhasználói fiókok vagy csoportok eltávolítása egy szerepkörből
  • Felhasználói fiókok vagy csoportok áthelyezése egy másik szerepkörbe


Az alkalmazás azonosítója

Az alkalmazás azonosítója nem más, mint az a felhasználói fiók, amely alatt az alkalmazás fut. A COM+ kiszolgálóalkalmazások – azaz a saját folyamatterületükön futó COM+ alkalmazások – azonosítóját telepítéskor be kell állítani. Az azonosító beállítható az Interaktív felhasználó lehetőségre, azaz az alkalmazást futtató számítógépre bejelentkezett bármely felhasználóra, vagy egy érvényes jelszóval rendelkező adott felhasználói fiókra. Az ügyfél-azonosítóval az ügyfél folyamatterületén futó COM+ függvénytár-alkalmazásokhoz nincs szükség azonosító megadására.

Az azonosító meghatározza a biztonsági környezetet az alkalmazás által végrehajtott hívások számára. Ha az alkalmazás más alkalmazásokat hív meg, azt saját azonosítójával teszi (feltéve, hogy nem egy ügyfelet személyesít meg, amikor az ügyfél nevében hajt végre hívást). A hívást fogadó alkalmazás a hívás érvényesítése során a hívó alkalmazás azonosítóját használja saját biztonsági ellenőrzéséhez.

Az interaktív felhasználóazonosító és egy adott felhasználó közötti különbség

Egy adott felhasználó megadása általában szerencsésebb megoldás, mint az interaktív felhasználóazonosító használata. Egy adott felhasználóazonosító használata esetén a kiszolgáló akkor is működhet, ha az alkalmazást futtató számítógépre senki nincs bejelentkezve. Az adott felhasználóazonosító azért is biztonságosabb, mint az interaktív felhasználó, mert azt csak olyan személy rendelheti az alkalmazáshoz, aki ismeri az adott felhasználó jelszavát.

Ha az azonosító interaktív felhasználó számára van beállítva, az alkalmazás csak akkor fut, ha egy felhasználó bejelentkezett a számítógépre. Az interaktív felhasználó az egyetlen olyan azonosító, amely lehetővé teszi, hogy az ügyfél az alkalmazás által nyújtott grafikus felületet (GUI) lássa. Az interaktív felhasználóazonosító azonban veszélyezteti a biztonságot, mivel az alkalmazás a bejelentkezett felhasználó azonosítójával fut a felhasználó tudtán és beleegyezésén kívül. Ha egy adott számítógépen az alkalmazás például akkor fut, amikor a rendszergazda be van jelentkezve, akkor ezt a rendszergazda azonosítójával teszi, és esetleg hívásokat intéz az ügyfelek nevében.

A delegálás működésének követelményei

A delegálás azt jelenti, hogy a hálózaton a kiszolgáló személyesíti meg az ügyfelet, azaz az alkalmazás az ügyfél azonosítójával és engedélyével mint kiszolgáló intéz hívásokat a távoli számítógépeken lévő alkalmazásokhoz. Mivel az alkalmazásnak adható engedélyezési jogosultságnak ez egy igen sokoldalú, és a biztonságot veszélyeztetni képes szintje, az átruházás működése felügyeletileg szabályozható az Active Directory könyvtárszolgáltatáson keresztül. Ha egy ügyfélalkalmazás átruházásszintű megszemélyesítéshez kiszolgálói engedélyt biztosít, működéséhez a következő két feltételnek kell teljesülni:

  • A kiszolgálóalkalmazásnak olyan azonosító alatt kell futnia, amely az Active Directory szolgáltatásban „A fiók szerepköre delegálható” jelzéssel rendelkezik.
  • Az ügyfélalkalmazásnak olyan azonosító alatt kell futnia, amely az Active Directory szolgáltatásban a „Bizalmas fiók, nem delegálható” jelzéssel rendelkezik.

Ha azt szeretné, hogy az adott COM+ alkalmazás az ügyfelek nevében delegálást tudjon végrehajtani, és ehhez az alkalmazáshoz azonosítót állít be, akkor ha egy bizonyos felhasználó számára teszi ezt, ennek a felhasználónak olyan tartományi felhasználói fiókkal kell rendelkeznie, amely delegálásra meg van hatalmazva. Ha az interaktív felhasználóazonosítót használja, akkor bármely bejelentkezett felhasználót fel kell hatalmazni delegálásra. Ha az alkalmazásazonosító nincs felhatalmazva delegálásra, akkor, ha az alkalmazás megkísérel egy ügyfelet megszemélyesíteni a hálózaton, a hívás sikertelen lesz. A megszemélyesítés szintjeinek leírása a Megszemélyesítési szint című témakörben található.

Az azonosító beállításával kapcsolatos részletes ismertetőt Az alkalmazásazonosító beállítása című témakörben olvashatja.


COM-alkalmazások biztonsági beállításai

A COM-alkalmazások – például a Microsoft Word – számos biztonsági konfigurációs tulajdonságot használnak. Ilyenek például a hitelesítési szint, a megszemélyesítési szint, a hozzáférési engedélyek, az indítási engedélyek és a konfigurációs engedélyek. E tulajdonságok a számítógép egészére érvényes beállításokkal rendelkeznek, amelyeket az alkalmazások alapértelmezés szerint használnak. A COM biztonsági beállítások bármely alkalmazáshoz külön is konfigurálhatók. Ha egy adott alkalmazás nem rendelkezik megadott biztonsági beállításokkal, akkor a számítógép egészére érvényes beállításokat fogja használni.

Általában nem szükséges módosításokat végrehajtani, bár az egyes alkalmazások vagy rendszerek esetében a biztonsági követelmények megkívánhatják a változtatásokat. A Komponensszolgáltatások felügyeleti eszközzel a jelen témakörben bemutatott módon változtathatja meg a számítógép egészére érvényes COM biztonsági tulajdonságokat. Az adott COM-alkalmazás biztonsági beállításai a DCOMCNFG segédprogram segítségével módosíthatók.

A DCOMCNFG használatával kapcsolatos eljárások ismertetése a Microsoft Platform SDK csomagban, a „Component Services” című fejezet „COM Security” részének „Setting Process-Wide Security Using DCOMCNFG” című témakörében található.

A COM+ és a COM-alkalmazások közötti különbségek leírását megtalálhatja A Komponensszolgáltatások felügyeletével kapcsolatos fogalmak című témakörben.

A számítógép egészére érvényes biztonsági beállítások

A számítógép egészére érvényes COM biztonsági beállítások csak a COM-alkalmazásokra érvényesek, a COM+ alkalmazásokat nem érintik. Mindegyik COM biztonsági beállításra igaz, hogy a COM-alkalmazások használhatják a számítógép egészére érvényes beállításokat, de használhatnak egyéni beállításokat is. Ha egy alkalmazás egyéni biztonsági beállításokkal rendelkezik, a számítógép egészére érvényes beállítások nem érvényesülnek, ám egy saját biztonsági beállításokkal nem rendelkező alkalmazás a számítógép egészére érvényes beállításokat használja.

Ha az alapértelmezett értékek nem felelnek meg a rendszeren lévő alkalmazások biztonsági követelményeinek, a Komponensszolgáltatások felügyeleti eszköz segítségével módosíthatók a számítógép egészére érvényes biztonsági beállítások. Ne feledje, hogy a számítógép egészére érvényes beállítások módosítása minden olyan COM-alkalmazásra hatással van, amely nem rendelkezik egyéni konfigurációval.

Ha a számítógép egészére érvényes alapértelmezett beállításokat kívánja használni, nem szükséges módosításokat végrehajtani. A COM a számítógép egészére érvényes biztonsági beállítások gyanánt automatikusan a következő alapértelmezett értékeket használja:

  • Hitelesítési szint: Csatlakozás.
  • Megszemélyesítési szint: Azonosítás.
  • A hozzáférési engedélyek lehetővé teszik a kiszolgálóazonosítóhoz és a helyi rendszerhez történő hozzáférést.
  • A fő név a felhasználói néven és jelszón alapul.
  • A COM által a környezet számára legmegfelelőbbnek ítélt biztonságszolgáltató. Windows 2000 környezetben ez a Kerberos vagy az NTLMSSP.

Ha az alábbi hivatkozásokra kattint, elolvashatja a háttér-információkat és a feladatokkal kapcsolatos tudnivalókat.

Témakör | Leírás
Hitelesítési szint | Azon szintek áttekintése, amelyeken a hitelesítő adatok segítségével az ügyfél és a kiszolgáló ellenőrzi egymás azonosítóját, és amelyeken a közöttük áramló adatokat ellenőrzik és titkosítják
Megszemélyesítési szint | Azon szintek bemutatása, amelyeken a kiszolgáló az ügyfél nevében hívást hajt végre, miközben saját azonosítóját és hitelesítő adatait az ügyféléivel helyettesíti
Hozzáférési engedélyek | Azon engedélyek bemutatása, amelyek megadják a COM-alkalmazásokhoz hozzáférési engedéllyel rendelkező, illetve az azzal nem rendelkező felhasználók felsorolását
Indítási engedélyek | Azon engedélyek áttekintése, amelyek felsorolják a COM-alkalmazások indításához engedéllyel rendelkező, illetve az azzal nem rendelkező felhasználókat
A hivatkozások nyomon követése | Bemutatja azt az eljárást, amellyel a COM további biztonsági ellenőrzéseket hajt végre a hivatkozásszámláló hívások hitelesítése érdekében, és amellyel további adatokat követ nyomon az objektumok véletlen vagy rosszindulatú korai felszabadításának megakadályozására


Hitelesítési szint

A hitelesítés az a folyamat, amely során a hitelesítő adatok segítségével az ügyfél és a kiszolgáló kölcsönösen ellenőrzi egymás azonosítóját, és a közöttük áramló adatokat ellenőrzik és titkosítják.

A hitelesítési szint beállításai jelzik, hogy az alkalmazással történő kommunikációhoz (azaz ha az alkalmazás hívásokat kezdeményez és fogad) milyen mértékű hitelesítés szükséges. Magasabb hitelesítési szintek nagyobb biztonságot és az adatok épségének nagyobb mérvű megőrzését eredményezik, bár általában némi teljesítménycsökkenéssel járnak. A hitelesítési szint módosításakor körültekintően kell eljárni: a COM egyezteti a hitelesítési szintet az ügyfél és a kiszolgáló között, és a két fél által megadottak közül a legmagasabbat fogadja el. Előfordulhat azonban, hogy ez az egyeztetés sikertelen, ha az ügyfél olyan programozott hitelesítési szintet ad meg, amely alacsonyabb, mint amelyet a kiszolgáló igényel. A hitelesítési szint módosítása esetleg azzal járhat, hogy néhány hívás sikertelen lesz (például ha a kiszolgáló hitelesítési szintjét az ügyfél által program szerint igényeltnél magasabbra állítja). Az Ilyen hibákat gyakran nagyon nehéz meghatározni és megjósolni.

A Komponensszolgáltatások felügyeleti eszköz segítségével módosítható a hitelesítési szintnek a számítógép egészére érvényes beállítása. Ez a beállítás akkor működik, ha egy adott COM-alkalmazás nem határoz meg programszerűen hitelesítési szintet. A COM+ alkalmazásokra ez a beállítás nincs hatással. A hitelesítési szintnek a számítógép egészére érvényes alapértelmezett beállítása Csatlakozás.

A szintek – a legalacsonyabb biztonsági szinttől a legmagasabbig – a következők:

Szint | Leírás
Nincs | Nincs hitelesítés.
Csatlakozás | A hitelesítőadatokat a program csak a csatlakozás létrejöttekor hitelesíti.
Hívás | A program a hitelesítőadatokat minden hívás kezdetén hitelesíti.
Csomag | A program hitelesíti a hitelesítőadatokat, és ellenőrzi, hogy minden hívási adat beérkezett-e.
Csomag épsége | A program hitelesíti a hitelesítőadatokat, és ellenőrzi, hogy a hívási adatok az átvitel során nem módosultak-e.
Csomagbiztonság | A program hitelesíti a hitelesítőadatokat, és titkosítja a csomagot, beleértve az adatokat, valamint a küldő fél azonosítóját és aláírását.

A szintek beállításának részletes leírását A számítógép egészére érvényes hitelesítési szint beállítása című témakörben találja meg.


Megszemélyesítési szint

A megszemélyesítés az a folyamat, amely során a kiszolgáló az ügyfél nevében hívást hajt végre, miközben saját azonosítóját és hitelesítő adatait az ügyféléivel helyettesíti. Ez csak akkor történhet meg, ha az ügyfél kifejezetten felhatalmazza a kiszolgálót azonosítója használatára.

A megszemélyesítési szint beállítását az ügyfél arra használja, hogy a kiszolgálót egy adott szintű engedéllyel ruházza fel bizonyos műveletek elvégzésére a saját nevében. Ahhoz, hogy a kiszolgáló az ügyfelet a hálózaton megszemélyesíthesse, a legmagasabb szintű meghatalmazásra van szükség. A helyi megszemélyesítés szintjének elnevezése megszemélyesítés; a hálózaton történő megszemélyesítés neve delegálási szintű megszemélyesítés, vagy egyszerűen delegálás. Ahhoz, hogy a kiszolgáló delegálást hajthasson végre, azonosítóját az Active Directory szolgáltatásban „A fiók szerepköre delegálható” jelzéssel kell ellátni. Ahhoz, hogy az ügyfél delegálási szintű meghatalmazást biztosíthasson, nem szabad azt az Active Directory szolgáltatásban „Bizalmas fiók, nem delegálható” jelzéssel ellátni. (Az azonosítókról és a delegálásról további információt talál Az alkalmazás azonosítója című témakörben.)

A Komponensszolgáltatások felügyeleti eszköz segítségével módosítható a megszemélyesítési szintnek a számítógép egészére érvényes beállítása. Ez a számítógép egészére érvényes beállítás akkor használatos, ha a számítógép egy adott COM-ügyfele nem határoz meg programszerűen megszemélyesítési szintet. A COM+ alkalmazásokra ez a beállítás nincs hatással. A megszemélyesítési szintnek a számítógép egészére érvényes alapértelmezett beállítása Azonosítás.

A megszemélyesítési szintek (a legalacsonyabbtól a legmagasabbig) a következők:

Szint | Leírás
Névtelen hitelesítés | Az ügyfél a kiszolgáló számára névtelen. A kiszolgáló megszemélyesítheti az ügyfelet, de a megszemélyesítő token (azaz a helyi hitelesítőadat) az ügyfélről semmilyen adatot nem tartalmaz.
Azonosítás | A kiszolgáló beszerezheti az ügyfél azonosítóját, és ACL-ellenőrzések céljából megszemélyesítheti az ügyfelet.
Megszemélyesítés | A kiszolgáló bizonyos korlátozásokkal megszemélyesítheti az ügyfelet, miközben nevében műveleteket hajt végre. Ugyanazon a számítógépen lévő erőforrásokhoz férhet hozzá, mint az ügyfél. Ha a kiszolgáló ugyanazon a számítógépen van, mint az ügyfél, ugyanúgy hozzáférhet a hálózati erőforrásokhoz, mint az. Ha a kiszolgáló egy másik számítógép, akkor csak azokhoz az erőforrásokhoz férhet hozzá, amelyek ugyanazon a számítógépen vannak, mint a kiszolgáló.
Delegálás | A kiszolgáló megszemélyesítheti az ügyfelet, miközben nevében műveleteket hajt végre, függetlenül attól, hogy ugyanazon a számítógépen van-e, mint az ügyfél. A megszemélyesítés során az ügyfél hitelesítőadatait (a helyi és a hálózati érvényességűeket egyaránt) tetszőleges számú számítógéphez továbbíthatja.

A témával kapcsolatos részletes ismertetést A számítógép egészére érvényes megszemélyesítési szint beállítása című témakörben talál.


Hozzáférési engedélyek

A hozzáférési engedélyek azokat a felhasználókat sorolják fel, akik a COM-alkalmazásokhoz hozzáférhetnek, illetve akik nem. A számítógép egészére érvényes hozzáférési engedélyek minden olyan COM-alkalmazásra érvényesek, amelyek nem határoznak meg saját hozzáférési engedélyeket.

A Komponensszolgáltatások felügyeleti eszköz segítségével a hozzáférési engedélyekkel rendelkező felhasználók listájához hozzáadhat, illetve onnan eltávolíthat felhasználói fiókokat és csoportokat. A COM+ alkalmazásokra ez nincs hatással.

A hozzáférési engedélyek beállításakor biztosítania kell, hogy az engedéllyel rendelkező felhasználók felsorolása tartalmazza a SYSTEM elemet. Ha Mindenki számára biztosít hozzáférési engedélyeket, a SYSTEM elem eleve bekerül a listába.

Az ezzel kapcsolatos részletes leírást A számítógép egészére érvényes hozzáférési engedélyek beállítása című témakörben olvashatja.


Indítási engedélyek

Az indítási engedélyek azokat a felhasználókat sorolják fel, akik a COM-alkalmazások indításához rendelkeznek, illetve akik nem rendelkeznek engedéllyel. A számítógép egészére érvényes indítási engedélyek minden olyan COM-alkalmazásra érvényesek, amelyek nem határoznak meg saját indítási engedélyeket.

A Komponensszolgáltatások felügyeleti eszköz segítségével az indítási engedélyekkel rendelkező felhasználók listájához hozzáadhat, illetve onnan eltávolíthat felhasználói fiókokat és csoportokat. A COM+ alkalmazásokra ez nincs hatással.

Az ezzel kapcsolatos részletes leírást A számítógép egészére érvényes indítási engedélyek beállítása című témakörben találja meg.


A hivatkozások nyomon követése

Ha engedélyezi a hivatkozások nyomon követését, más néven a „biztonságos hivatkozásszámlálást”, a COM további biztonsági ellenőrzéseket hajt végre a hivatkozásszámláló hívások hitelesítése érdekében, és további adatokat követ nyomon az objektumok (véletlen vagy rosszindulatú) korai felszabadításának megakadályozására. A hivatkozások nyomon követésének engedélyezése biztonságosabbá teszi a rendszert, de a teljesítményt hátrányosan befolyásolhatja.

Az ezzel kapcsolatos részletes leírást A hivatkozások nyomon követésének a számítógép egészére érvényes beállítása című témakörben olvashatja.


A biztonsággal kapcsolatos felügyeleti feladatok

A Komponensszolgáltatások felügyeleti eszközzel elvégezhető biztonsággal kapcsolatos felügyeleti feladatok a következők:

  • Felhasználók kezelése szerepkörökben
  • Az alkalmazásazonosító beállítása
  • A számítógép egészére érvényes COM biztonsági konfiguráció beállítása

E feladatok áttekintése A biztonság felügyeletével kapcsolatos fogalmak című témakörben található.


Felhasználók kezelése szerepkörökben

A COM+ alkalmazások biztonságának konfigurálásával összefüggő legtöbb felügyeleti feladat az előre definiált szerepkörök felhasználókkal való feltöltését jelenti mind az alkalmazások telepítésekor, mind pedig azok használata során. Ezekről a biztonsági szolgáltatásokról a Szerepköralapú biztonság című témakörben talál ismertetést.

Ebben a részben a következő feladatok részletes leírását olvashatja:

  • Felhasználói fiókok vagy csoportok hozzárendelése egy szerepkörhöz
  • Felhasználói fiókok vagy csoportok eltávolítása egy szerepkörből
  • Felhasználói fiókok vagy csoportok áthelyezése egy másik szerepkörbe


Felhasználói fiókok vagy csoportok hozzárendelése egy szerepkörhöz

Egy adott szerepkör a Komponensszolgáltatások felügyeleti eszköz segítségével tölthető fel felhasználói fiókokkal vagy csoportokkal. A felhasználói fiókok szerepkörhöz történő hozzárendelésének kedvelt módja a felhasználói fiók hozzárendelése egy adott Windows 2000 csoporthoz, majd a csoport hozzárendelése a szerepkörhöz. Ha Windows 2000 csoportokat használ a szerepkörök feltöltésére, a nagyszámú felhasználók kezelése egyszerűbbé válik.

Windows 2000 csoportok létrehozásáról, illetve a felhasználói fiók Windows 2000 csoporthoz történő hozzárendeléséről a Számítógépkezelés segédprogram Helyi felhasználók és csoportok eleméből elérhető on-line súgóban olvashat. Miután a felhasználói fiókot a megfelelő Windows 2000 csoporthoz rendelte, a csoport szerepkörhöz történő hozzárendeléséhez kövesse az alábbi lépéseket.

Windows 2000 csoport hozzárendelése biztonsági szerepkörhöz
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján keresse meg azt a COM+ alkalmazást, amely azt a szerepkört tartalmazza, amelyhez felhasználói fiókot vagy csoportot kíván rendelni. Bontsa ki a nézetet a konzolfán, míg meg nem jelennek az alkalmazás szerepkörei.
  2. Keresse meg azt a szerepkört, amelyhez a felhasználói fiókot vagy a csoportot hozzá kívánja rendelni.

    Megjegyzés Ha a keresett szerepkör nem található a Szerepkörök mappában, akkor az nincs az alkalmazáshoz rendelve. A szerepkört a fejlesztőnek kell az alkalmazáshoz adnia még az előtt, hogy megtörténhetne a felhasználói fiókok szerepkörhöz rendelése.

  3. Kattintson az egér jobb gombjával a Felhasználók mappára, mutasson az Új pontra, majd kattintson a Felhasználó parancsra.
  4. A Felhasználók vagy Csoportok kijelölése párbeszédpanel alsó ablakában írja be a hozzáadandó csoport teljes nevét.

    Ha nem ismeri a nevet, a Keresés itt legördülő listából válassza ki a tartományt, a Név mezőben jelölje ki a csoportot, majd kattintson a Hozzáadás gombra.

  5. Több felhasználói fiók vagy csoport hozzáadásához ismételje meg a 4. lépést.
  6. Miután megtörtént a felhasználói fiókok és csoportok hozzáadása a szerepkörhöz, kattintson az OK gombra.

A Felhasználók mappában a szerepkörhöz rendelt minden felhasználói fiókhoz vagy csoporthoz egy ikon jelenik meg. Az új szerepkörtagság az alkalmazás következő indításakor lép érvénybe.


Felhasználói fiókok vagy csoportok eltávolítása egy szerepkörből

Ha egy adott felhasználónak vagy a csoport egyik tagjának már nincs szüksége azon alkalmazás erőforrásaihoz történő hozzáférésre, amelyhez a szerepkör tartozik, szükség lehet a felhasználó fiók vagy csoport eltávolítására.

Felhasználói fiókok vagy csoportok eltávolítása egy szerepkörből
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján keresse meg azt a COM+ alkalmazást, amely a kérdéses szerepkört tartalmazza. Bontsa ki a nézetet a konzolfán, míg meg nem jelennek a szerepkör felhasználói.
  2. Az egér jobb gombjával kattintson az eltávolítandó felhasználói fiókra vagy csoportra, majd kattintson a Törlés parancsra.
  3. Az Elem törlésének megerősítése párbeszédpanel megjelenésekor a felhasználói fiók vagy csoport törléséhez kattintson az Igen gombra.

A szerepkörből eltávolított felhasználói fiók vagy csoport nem jelenik meg a Felhasználók mappában. Az új szerepkörtagság az alkalmazás következő indításakor lép érvénybe.


Felhasználói fiókok vagy csoportok áthelyezése egy másik szerepkörbe

Ha a felhasználó jogosultságai megváltoznak, vagy az alkalmazáshoz új szerepkör hozzáadására kerül sor, előfordulhat, hogy egy fiókot az egyik szerepkörből a másikba át kell helyezni. Ahhoz, hogy az adott felhasználói fiókot vagy a felhasználók egy adott csoportját egy másik szerepkörbe lehessen áthelyezni, először el kell azt távolítani az aktuális szerepkörből, majd hozzá kell rendelni az új szerepkörhöz.

Felhasználói fiókok vagy csoportok áthelyezése egyik szerepkörből a másikba
  1. A felhasználói fiókot vagy csoportot távolítsa el abból a szerepkörből, ahová annak már nem kell tartoznia. Ehhez kövesse a Felhasználói fiókok vagy csoportok eltávolítása egy szerepkörből című részben bemutatott eljárást.
  2. Az így eltávolított felhasználói fiókot vagy csoportot rendelje hozzá ahhoz a szerepkörhöz, amelyhez ezentúl tartoznia kell. E feladat végrehajtásához a Felhasználói fiókok vagy csoportok hozzárendelése egy szerepkörhöz című részben talál segítséget.

Az új szerepkörhöz tartozó Felhasználók mappában megjelenik egy, az áthelyezett felhasználói fiókot vagy csoportot jelképező ikon. Az új szerepkörtagság az alkalmazás következő indításakor lép érvénybe.


Az alkalmazásazonosító beállítása

A Komponensszolgáltatások felügyeleti eszközzel beállítható a COM+ kiszolgálóalkalmazások azonosítója. (COM+ függvénytár-alkalmazás esetében az azonosító mindig a gazdául szolgáló folyamat azonosítója.) Az azonosító (érvényes jelszóval együtt) beállítható egy bizonyos felhasználói fiókhoz vagy az „Interaktív felhasználó” lehetőséghez. Az alkalmazás e felhasználói fiók alatt fut, amelyet akkor használ, ha más alkalmazásokat vagy erőforrásokat hív meg. Az alkalmazásazonosító áttekintése Az alkalmazás azonosítója című témakörben található.

COM+ kiszolgálóalkalmazás azonosítójának beállítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a COM+ alkalmazásra, amelyhez azonosítót kíván beállítani, majd kattintson a Tulajdonságok parancsra.
  2. A tulajdonságokat megjelenítő párbeszédpanelen kattintson az Azonosítás fülre.
  3. A Fiók csoportban a következő beállítások közül választhat:
    • Ha azt szeretné, hogy a kiszolgáló a bejelentkezett felhasználó azonosítója alatt fusson, jelölje be az Interaktív felhasználó választógombot.
    • Ha azt szeretné, hogy a kiszolgáló egy bizonyos felhasználó azonosítója alatt fusson, jelölje be az Adott felhasználó választógombot, majd írja be a felhasználó nevét és jelszavát, végül erősítse meg a jelszót.

    Ha nem ismeri a teljes felhasználói nevet, annak megkereséséhez kattintson a Tallózás gombra. Miután a Tallózás a felhasználók között párbeszédpanelben megtalálta a felhasználót, kattintson az OK gombra.

  4. Kattintson az OK gombra.

A választott azonosító az alkalmazás következő indításakor lép érvénybe.


A számítógép egészére érvényes COM biztonsági konfiguráció beállítása

A Komponensszolgáltatások felügyeleti eszköz segítségével beállíthatók a COM-alkalmazások által használt, a számítógép egészére érvényes COM biztonsági tulajdonságok. E biztonsági szolgáltatások működéséről bővebben a COM-alkalmazások biztonsági beállításai című témakörben olvashat.

Ebben a részben a következő feladatok részletes leírása található:

  • A számítógép egészére érvényes hitelesítési szint beállítása
  • A számítógép egészére érvényes megszemélyesítési szint beállítása
  • A számítógép egészére érvényes hozzáférési engedélyek beállítása
  • A számítógép egészére érvényes indítási engedélyek beállítása
  • A hivatkozások nyomon követésének a számítógép egészére érvényes beállítása


A számítógép egészére érvényes hitelesítési szint beállítása

A hitelesítési szintek azt közlik a COM modellel, hogy az ügyfelek és a kiszolgálók milyen mértékig ellenőrizzék egymás azonosítóját az alkalmazások közötti hívások során. Ha az adott számítógéphez engedélyezni kívánja a biztonsági beállításokat, a számítógép egészére érvényes hitelesítési szintnek a Nincs beállítástól eltérőnek kell lennie. A témával kapcsolatban a Hitelesítési szint című témakör nyújt áttekintést.

A számítógép egészére érvényes hitelesítési szint beállítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelynek a számítógép egészére érvényes hitelesítési szintjét módosítani kívánja, majd kattintson a Tulajdonságok parancsra.
  2. Az Alapértelmezett tulajdonságok lapon az Alapértelmezett hitelesítési szint legördülő listából válasszon egy, a (Nincs) beállítástól eltérő értéket.
  3. Kattintson az OK gombra.

A számítógép egészére érvényes új hitelesítési szint akkor lép érvénybe, amikor az adott számítógépen egy alkalmazás indítására sor kerül. Az éppen futó alkalmazásokat a változás azok újraindításáig nem érinti.


A számítógép egészére érvényes megszemélyesítési szint beállítása

Az ügyfél által beállított megszemélyesítési szint azt határozza meg, hogy a kiszolgáló milyen szintű jogosultságokat kapjon az ügyfél nevében végzendő feladatokhoz. A számítógép egészére érvényes megszemélyesítési szint beállítása azt közli a COM modellel, hogy milyen megszemélyesítési szintet alkalmazzon, ha a számítógépen lévő adott ügyfél program szerint nem határoz meg megszemélyesítési szintet. Ezzel a témával kapcsolatban a Megszemélyesítési szint című témakör nyújt áttekintést.

A számítógép egészére érvényes megszemélyesítési szint beállítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelynek a számítógép egészére érvényes megszemélyesítési szintjét módosítani kívánja, majd kattintson a Tulajdonságok parancsra.
  2. Az Alapértelmezett tulajdonságok lapon az Alapértelmezett megszemélyesítési szint legördülő listából válasszon egy értéket.
  3. Kattintson az OK gombra.

A számítógép egészére érvényes új megszemélyesítési szint akkor lép érvénybe, amikor az adott számítógépen egy alkalmazás indítására sor kerül. Az éppen futó alkalmazásokat a változás azok újraindításáig nem érinti.


A számítógép egészére érvényes hozzáférési engedélyek beállítása

A számítógép egészére érvényes hozzáférési engedélyek azon felhasználókat határozzák meg, akik a saját hozzáférési engedéllyel nem rendelkező COM-alkalmazásokhoz hozzáférhetnek. A hozzáférési engedélyek beállításakor biztosítania kell, hogy az engedéllyel rendelkező felhasználók felsorolása tartalmazza a SYSTEM elemet. Ha Mindenki számára biztosít hozzáférési engedélyeket, a SYSTEM elem eleve bekerül a listába. Erről a témáról a Hozzáférési engedélyek című témakör ad áttekintést.

A számítógép egészére érvényes hozzáférési engedélyek beállítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelynek a számítógép egészére érvényes hozzáférési engedélyeit módosítani kívánja, majd kattintson a Tulajdonságok parancsra.
  2. Az Alapértelmezett biztonság lapon az Alapértelmezett hozzáférési jogok csoportban kattintson Az alapértelmezett szerkesztése gombra.
  3. Felhasználói fiók vagy csoport eltávolításához a Rendszerleíró érték jogosultság párbeszédpanelen jelölje ki az eltávolítandó felhasználói fiókot vagy csoportot, majd kattintson az Eltávolítás gombra.

    A kijelölt felhasználói fiók vagy csoport eltűnik a listából. Miután végrehajtotta a felhasználói fiókok és csoportok eltávolítását, kattintson az OK gombra.

  4. Felhasználói fiók vagy csoport hozzáadásához kattintson a Hozzáadás gombra.
  5. A Felhasználók vagy csoportok hozzáadása párbeszédpanelen a Hozzáadandó nevek mezőbe írja be a teljes felhasználónevet.

    Ha nem ismeri a felhasználónevet, a felhasználói adatbázisban tallózva megkeresheti azt.

  6. A Hozzáférési típus listából válassza ki a hozzáférés típusát (a két lehetőség: DefaultAccessPermission engedélyezése és DefaultAccessPermission megtagadása).

    Más, a választott hozzáférési típussal rendelkező felhasználói fiókok hozzáadásához ismételje meg az 5. lépést.

  7. Ha a felhasználói fiókokat hozzáadta a választott hozzáférési típushoz, kattintson az OK gombra.
  8. Más, a választottól eltérő hozzáférési típussal rendelkező felhasználói fiókok hozzáadásához ismételje meg az 5-7. lépést.
  9. Kattintson az OK gombra.

A számítógép egészére érvényes új hozzáférési engedélyek akkor lépnek érvénybe, amikor az adott számítógépen egy alkalmazás indítására sor kerül. Az éppen futó alkalmazásokat a változás azok újraindításáig nem érinti.


A számítógép egészére érvényes indítási engedélyek beállítása

A Komponensszolgáltatások felügyeleti eszközzel beállított, a számítógép egészére érvényes indítási engedélyek azon felhasználókat határozzák meg, akik kifejezetten kapnak, illetve nem kapnak engedélyt a saját indítási beállításokkal nem rendelkező COM-alkalmazások indítására. Az indítási engedélyek beállításakor egy vagy több felhasználói fiók vagy csoport adható a listához, illetve távolítható el onnan. A kérdéskörrel kapcsolatban az Indítási engedélyek című témakör nyújt áttekintést.

A számítógép egészére érvényes indítási engedélyek beállítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelynek a számítógép egészére érvényes indítási engedélyeit módosítani kívánja, majd kattintson a Tulajdonságok parancsra.
  2. Az Alapértelmezett biztonság lapon az Alapértelmezett indítási jogok csoportban kattintson Az alapértelmezett szerkesztése gombra.
  3. Felhasználói fiók vagy csoport eltávolításához a Rendszerleíró érték jogosultság párbeszédpanelen jelölje ki az eltávolítandó felhasználói fiókot vagy csoportot, majd kattintson az Eltávolítás gombra.

    A kijelölt felhasználói fiók vagy csoport eltűnik a listából. A felhasználói fiókok és csoportok eltávolítása után kattintson az OK gombra.

  4. Felhasználói fiók vagy csoport hozzáadásához kattintson a Hozzáadás gombra.
  5. A Felhasználók vagy csoportok hozzáadása párbeszédpanelen a Hozzáadandó nevek mezőbe írja be a teljes felhasználónevet.

    Ha nem ismeri a felhasználónevet, a felhasználói adatbázisban tallózva megkeresheti azt. Miután megkereste a felhasználónevet, a Név listában jelölje be a felhasználói fiókot vagy csoportot, majd kattintson a Hozzáadás gombra.

  6. A Hozzáférési típus listából válassza ki a hozzáférés típusát (a két lehetőség: DefaultLaunchPermission engedélyezése és DefaultLaunchPermission megtagadása).

    Más, a választott hozzáférési típussal rendelkező felhasználói fiókok hozzáadásához ismételje meg az 5. lépést.

  7. Ha a felhasználói fiókokat hozzáadta a választott hozzáférési típushoz, kattintson az OK gombra.
  8. Más, a választottól eltérő hozzáférési típussal rendelkező felhasználói fiókok hozzáadásához ismételje meg az 5-7. lépést.
  9. Kattintson az OK gombra.

A számítógép egészére érvényes új indítási engedélyek akkor lépnek érvénybe, amikor az adott számítógépen egy alkalmazás indítására sor kerül. Az éppen futó alkalmazásokat a változás azok újraindításáig nem érinti.


A hivatkozások nyomon követésének a számítógép egészére érvényes beállítása

A hivatkozások nyomon követésének engedélyezésével arra utasítja a COM modellt, hogy az objektumok véletlen vagy rosszindulatú, korai felszabadításának megakadályozása érdekében további biztonsági ellenőrzéseket hajtson végre, és további információkat kövessen nyomon. A hivatkozások nyomon követésének, más néven a „biztonságos hivatkozásszámlálásnak” engedélyezésével a teljesítmény visszaeshet. A hivatkozások nyomon követéséről A hivatkozások nyomon követése című témakör nyújt áttekintést.

A hivatkozások nyomon követésének engedélyezése (vagy letiltása) a számítógépen
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelyen a hivatkozások nyomon követését be szeretné állítani, majd kattintson a Tulajdonságok parancsra.
  2. Az Alapértelmezett tulajdonságok lapon az Elosztott COM kommunikáció alapértelmezett tulajdonságai csoportban a következő beállítások közül választhat:
    • A hivatkozások nyomon követésének engedélyezéséhez jelölje be a Megnövelt biztonságú hivatkozáskövetés jelölőnégyzetet.
    • A hivatkozások nyomon követésének letiltásához törölje a jelet a Megnövelt biztonságú hivatkozáskövetés jelölőnégyzetből.
  3. Kattintson az OK gombra.

A hivatkozások nyomon követésére vonatkozó új beállítás akkor lép érvénybe, amikor az adott számítógépen egy alkalmazás indítására sor kerül. Az éppen futó alkalmazásokat a változás azok újraindításáig nem érinti.


Elosztott tranzakciók felügyelete

Az elosztott tranzakciók használatára kifejlesztett alkalmazásokban az egyszerre több ügyfélszámítógép, komponens és adatbázis által végzett munka kezelhető úgy, hogy az elősegítse az alkalmazás meghibásodások elleni védelmét. Az adott tranzakcióban vagy előfordul a résztvevő komponensek által végrehajtott valamennyi tevékenység, vagy nem. Ez leegyszerűsíti a nyomon követést és a hiba utáni helyreállítást, mivel a meghibásodások után nem marad vissza semmilyen adatmaradvány.

A Microsoft Distributed Transaction Coordinator (MS DTC) alkalmazást magába foglaló Komponensszolgáltatások felügyeleti eszköz segítségével konfigurálhatja számítógépeit és hálózatát az elosztott tranzakciók támogatására, illetve azok figyelésére és kezelésére.

Megjegyzés Az MS DTC a Windows 95, a Windows 98, a Windows NT 4.0, a Windows 2000 és későbbi operációs rendszerrel is használható.

Az alábbi hivatkozásokra kattintva háttér- és feladatinformációkhoz juthat.

Témakör | Leírás
Az elosztott tranzakciók felügyeletével kapcsolatos fogalmak | Bevezető az MS DTC használatába, további információforrásokra vonatkozó hivatkozásokkal kiegészítve.
Az elosztott tranzakciók felügyeletével kapcsolatos feladatok | Az elosztott tranzakciók felügyeletével kapcsolatos feladatokra mutató hivatkozások.

A munka megkezdése előtt

Rendszerint a komponens vagy az alkalmazás fejlesztése során születik meg a döntés a tranzakció-attribútumokról, például arról, hogy egy tranzakciós komponens mikor igényel vagy támogat egy adott tranzakciót. A felügyeleti döntések viszont általában az MS DTC konfigurálásával, indításával és leállításával, a tranzakciók menetének figyelésével és kezelésével, illetve a tranzakció teljesítményének figyelésével kapcsolatosak.


Az elosztott tranzakciók felügyeletével kapcsolatos fogalmak

Az elosztott tranzakciók felügyelete a Komponensszolgáltatások felügyeleti eszköz részét képező Microsoft Transaction Coordinator (MS DTC) alkalmazással látható el. Az MS DTC által nyújtott tranzakció-szolgáltatásokkal rendszerhibák, folyamathibák és kommunikációs hibák esetén is biztosítható a tranzakciók sikeres és teljes végrehajtása.

A Microsoft Distributed Transaction Coordinator

Az MS DTC a Windows 95, a Windows 98, a Windows NT, a Windows 2000 és újabb operációs rendszerek elosztott tranzakciók kezelésére szolgáló eszköze. Az MS DTC hangolja össze azokat a tranzakciókat, amelyek két vagy több, tranzakcióval védett erőforrást (például adatbázisokat, üzenetsorokat, fájlrendszereket stb.) frissítenek. Ezeket a tranzakcióval védett erőforrásokat tárolhatja egyetlen rendszer, de több rendszerből álló hálózaton elosztva is előfordulhatnak. Az MS DTC például azt engedélyezi az adott alkalmazás számára, hogy egy Windows 2000 rendszeren lévő Microsoft SQL Server adatbázist, egy Windows NT rendszeren lévő Microsoft Message Queue Server üzenetsort, egy UNIX rendszeren lévő Oracle adatbázist, illetve egy MVS rendszeren lévő DB2 adatbázist frissítsen egyetlen elosztott tranzakció irányítása alatt.

Az MS DTC már kipróbált, jól működő tranzakciófeldolgozó eljárásokat alkalmaz. Ellenálló a rendszerhibákkal, a folyamathibákkal és a kommunikációs hibákkal szemben, és lazán egymáshoz kapcsolt rendszereket kihasználva biztosít skálázható teljesítményt. Telepítése, konfigurálása és kezelése egyszerű.

Az MS DTC a következő előnyöket nyújtja:

  • Csökkenti a vállalat számítástechnikai kiadásait – az MS DTC részletesen kidolgozott, költségkímélő elosztott tranzakciós eszközt biztosít a hálózathoz kapcsolt, kedvező árfekvésű számítógépeket és kiszolgálókat alkalmazó felhasználók számára.
  • Egyszerűbbé teszi az alkalmazások fejlesztését – az MS DTC tranzakciói akkor is jelentősen leegyszerűsítik azokat a feladatokat, amelyeket az alkalmazás programozójának kell elvégeznie a konzisztencia fenntartása érdekében, ha az elosztott alkalmazásadatok frissítése közben hibák merülnek fel.
  • Egységes tranzakciómodellt biztosít a különböző jellegű adatforrások, köztük a relációs adatbázisok, üzenetsorok, fájlrendszerek és dokumentumtároló eszközök frissítéséhez.
  • Lehetővé teszi az elosztott, objektumorientált szoftverkomponensek alkalmazásával történő szoftverfejlesztést. Az MS DTC alapja az OLE Transactions csatolószabvány, amely egyszerű, objektumorientált alkalmazásprogramozási felületet biztosít a tranzakciók inicializálásához és irányításához.

Az alábbi hivatkozásokra kattintva háttér- és feladatinformációkhoz juthat a felügyeleti feladatokkal kapcsolatban.

Témakör | Leírás
Tranzakciók – áttekintés | Alapvető ismereteket nyújt a tranzakciókról, az elosztott tranzakciókról és az MS DTC szerepéről.
Elosztott tranzakciók – áttekintés | Részletes áttekintést ad az elosztott tranzakciókról, és tartalmazza az MS DTC által támogatott optimalizálás témaköreihez vezető hivatkozásokat.
Az MS DTC komponensei | Bemutatja az MS DTC komponenseit, és leírja azok hálózaton belüli konfigurálásnak módját.
Az MS DTC konfigurálása | Bemutatja azokat a lehetőségeket, amelyekkel az MS DTC a meghatározott hálózati igényeknek megfelelően konfigurálható.
A naplófájl kezelése | Áttekintést ad arról, hogy a tranzakciós naplófájl kezelésével hogyan érhető el az egyenletes teljesítmény.
Tranzakcióállapot feloldása | Áttekinti a rendszerleállást követő tranzakciófeloldási tevékenységet és további információkat tartalmazó hivatkozásokat ad meg.


Tranzakciók – áttekintés

Az adott tranzakcióban résztvevő valamennyi komponensnek véglegesítenie kell egy módosítási műveletet (például egy adatbázis-frissítést), mielőtt a tranzakcióra sor kerülhetne. Az MS DTC végrehajtja az érintett komponensek tranzakció-koordinálási feladatát, és tranzakciókezelőként működik minden olyan számítógép esetében, amely tranzakciókat kezel.

Az MS DTC kétfázisú véglegesítési algoritmusában az első fázisban a tranzakciókezelő az összes igénybe vett komponensnél kéri a véglegesítés előkészítését, majd ha az előkészítés sikerült, a második fázisban a tranzakciókezelő összcímes küldéssel továbbítja a véglegesítésről szóló döntést.

A tranzakciók általában a következő lépésekből épülnek fel:

  1. Az alkalmazások a tranzakció megkezdését kérik a tranzakciókezelőtől.
  2. Ha az alkalmazás felkészült a módosításokra, a tranzakciókezelőtől a tranzakció véglegesítését kéri. A tranzakciókezelő szekvenciális tranzakciónaplót vezet, így a véglegesítésre vagy a megszakításra vonatkozó döntések megőrizhetők.
    • Ha az összes komponens előkészítése megtörtént, a tranzakciókezelő véglegesíti a tranzakciót, és törli a naplófájlt.
    • Ha valamelyik komponenst nem lehet előkészíteni, a tranzakciókezelő csoportcímes küldéssel egy megszakítás döntést továbbít a tranzakció minden résztvevőjének.
    • Ha egy komponens előkészített állapotban marad, de nem történik véglegesítés vagy megszakítás, akkor bizonytalan, hogy a tranzakció véglegesítésére vagy megszakítására kerül-e sor. Ha egy komponens vagy tranzakciókezelő leáll, az újracsatlakozáskor összehangolja a bizonytalan tranzakciókat.

Ha további információt szeretne arról, hogy a tranzakciók miként biztosítják az atomitást, a konzisztenciát, az elszigeteltséget és az állandóságot, olvassa el a Tranzakciók és az ACID jellemzők című témakört.

A tranzakciókkal és a véglegesítési folyamattal kapcsolatos bővebb tájékoztatást A tranzakciók résztvevői és a kétfázisú véglegesítés című témakörben talál.


Tranzakciók és az ACID jellemzők

A tranzakciók atomitást (atomicity), konzisztenciát (consistency), elkülönítést (isolation) és állandóságot (durability) biztosítanak. Ezen tulajdonságokat nevezik (angol megfelelőik kezdőbetűi alapján) ACID jellemzőknek. Az alábbiakban az egyes jellemzők ismertetése következik.

Tulajdonság | Leírás
Atomitás | Az atomitás a tranzakciók „mindent vagy semmit” jellemzője. A tranzakció vagy véglegesítetté válik, vagy megszakad. Ha a tranzakció véglegesítésére kerül sor, valamennyi hatása érezhető marad, ha azonban megszakad, semmilyen hatása nem lesz észlelhető.
Konzisztencia | A tranzakciók a rendszer állapotát az egyik konzisztens állapotból egy másikká alakítják. Ennek következtében egy egyszerű tranzakció (vagy egy tranzakciófolyamat) a rendszert mindig valamilyen konzisztens állapotban hagyja.
Elkülönítés | Ha két tranzakció végrehajtása egyszerre történik, az egyik tranzakció által végzett módosítások elkülönülnek a másik tranzakció módosításaitól. Bár két vagy több tranzakció párhuzamosan is futtatható, a rendszer azt a látszatot kelti, mintha egyszerre csak egy tranzakcióra kerülne sor. Ez akadályozza meg, hogy az egyik tranzakcióra hatással legyenek azok a nem véglegesített frissítések, amelyeket egy másik tranzakció végez. Ezt a tulajdonságot néha sorbarendezhetőségnek is nevezik.
Állandóság | Ha egy tranzakció véglegesítésére kerül sor, annak hatásai a rendszer leállításáig érvényben maradnak.


A tranzakciók résztvevői és a kétfázisú véglegesítés

A tranzakciók rendszerint egy tranzakciós alkalmazást, egy tranzakciókezelőt és egy vagy több tranzakciós erőforrás-kezelőt foglalnak magukba.

Tranzakciós alkalmazás

A tranzakciós alkalmazások inicializálják a tranzakciókat, és megadják, hogy a tranzakció véglegesítésére, frissítésére vagy megszakítására kerüljön-e sor. Az alkalmazás programozási modellje egyszerű: a tranzakciók sikeresek vagy nem működnek. Az alkalmazások úgy inicializálnak egy új tranzakciót, hogy meghívják a tranzakciókezelő BeginTransaction metódusát, és beolvassák a tranzakció objektumát. Minden soron következő alkalmazás tevékenysége ezzel a tranzakció-objektummal van társítva. Amikor az alkalmazás konzisztens állapotba kerül, meghívja a tranzakciókezelő Commit metódusát. Ha a véglegesítés sikeres, a tranzakció folyamatos véglegesítésére kerül sor. A tranzakciókezelő és az erőforrás-kezelők biztosítják, hogy a tranzakció hatásai akkor is fennálljanak, ha a következő hiba bekövetkezik.

Az MS DTC azt is lehetővé teszi, hogy az alkalmazások vagy más elemek eldönthessék, hogy vajon egy adott tranzakció kész-e a kétfázisú véglegesítési (2PC) protokoll „előkészítési” állapotába lépésre, mielőtt az előkészítésre sor kerülne. Ez a szolgáltatás az úgynevezett nulladik fázisú értesítés. Ha az alkalmazás nem tudja biztosítani azokat az állandósági garanciákat, amelyekre a tranzakciónak szüksége van (például azt, hogy teljes körű erőforrás-kezelőként működjön és részt vegyen a 2PC protokollban, valamint a helyreállításban), akkor lehetővé kell tennie, hogy még a 2PC protokoll inicializálása előtt az összes módosított adat átkerüljön egy teljes körű erőforrás-kezelőhöz. A nulladik fázisú értesítések mechanizmusa segítségével az alkalmazások megállapíthatják egy adott tranzakcióról, hogy az használható-e egy 2PC protokollal együtt. Ehhez végrehajthatják a megfelelő műveleteket, majd közölhetik a tranzakciókezelővel, ha elkészültek. Ez a támogatás azokhoz az új alkalmazásokhoz áll rendelkezésre, amelyeket a Windows 2000 rendszerrel szállított MS DTC verzióval fejlesztettek ki.

Ha az alkalmazás nem tudja sikeresen befejezni a tranzakciót, akkor meghívhatja a tranzakciókezelő Abort metódusát. Ennek következtében a tranzakciókezelő megszakítja a tranzakciót és visszavonja a tranzakció valamennyi hatását. A tranzakciókezelő akkor is megszakítja a tranzakciót, ha az alkalmazás a tranzakció véglegesítése előtt leáll, ha az erőforrás-kezelő nem tudja véglegesíteni a tranzakciót, vagy ha a számítógép leáll. Ezekben az esetekben a tranzakciókezelő megszakítja a tranzakciót és megszünteti a tranzakció tényleges hatását.

Tranzakciókezelő

Az MSDTC tranzakciókezelő a tranzakciók összehangolásával biztosítja a tranzakciók atomitását és állandóságát. A tranzakciókezelő akkor inicializál új tranzakciót, amikor egy alkalmazás meghívja a tranzakciókezelő BeginTransaction metódusát. Ha az adott erőforrás-kezelő első ízben vesz részt egy tranzakcióban, akkor a tranzakcióhoz való kapcsolódáshoz meghívja a tranzakciókezelő Enlist metódusát. A tranzakciókezelő nyomon követi a tranzakcióban igénybe vett valamennyi erőforrás-kezelőt.

Amikor az alkalmazás meghívja a Commit metódust, a tranzakciókezelő inicializálja a kétfázisú véglegesítési protokollt. A kétfázisú véglegesítési protokoll garantálja a tranzakció eredményének atomitását (vagy az összes erőforrás-kezelőnek kell véglegesítenie a tranzakciót, vagy mindegyiküknek meg kell szakítania a tranzakciót).

Az első fázisban a tranzakciókezelő az összes igénybe vett erőforrás-kezelőt utasítja a tranzakció véglegesítésének előkészítésére. Az erőforrás-kezelők tájékoztatják a tranzakciókezelőt, ha előkészítésük megtörtént. Az összes erőforrás-kezelő előkészítése után a tranzakciókezelő meghozza a tranzakció véglegesítésére vonatkozó döntést, majd véglegesítési rekordot jegyez be a naplófájlba. Ezután a tranzakciókezelő inicializálja a kétfázisú véglegesítési protokoll második fázisát, miközben az összes erőforrás-kezelőt értesíti arról, hogy a tranzakció véglegesítése megtörtént.

A tranzakciókezelő megszakítja a tranzakciót, ha az alkalmazás az Abort metódust hívja meg, illetve ha valamelyik erőforrás-kezelő előkészítése nem sikerült, vagy ha az alkalmazás vagy a rendszer leáll, mielőtt az első fázis záró szakaszában sor kerülne a véglegesítési rekord naplózására.

Az MS DTC tranzakciókezelő a saját rendszerén MS DTC naplófájlt tárol. Az MS DTC naplófájl minden olyan információt tartalmaz, amely az MS DTC számára szükséges a tranzakcióval kapcsolatban. Normál folyamat közben a tranzakciókezelő csak a naplófájlban készít bejegyzéseket. Ha azonban a tranzakciókezelő meghibásodik, újraindításkor a naplófájl beolvasásával határozza meg a legutóbbi tranzakciók állapotát.

Tranzakciós erőforrás-kezelők

A tranzakciós erőforrás-kezelők feladata a tranzakcióval védett adatok kezelése. A tipikus tranzakciós erőforrás-kezelők SQL Server adatbázisokat, üzenetsorrendszereket, fájlrendszereket és dokumentumtároló rendszereket foglalnak magukba.

A tranzakciós alkalmazások hívják meg az erőforrás-kezelőt az alkalmazásadatok beszúrására, törlésére vagy frissítésére. Ha tranzakciós alkalmazáskérelem érkezik az új tranzakcióhoz társított alkalmazástól, az erőforrás-kezelő aktivizálja a tranzakciókezelő Enlist metódusát. Az igénybevétellel az erőforrás-kezelő azt biztosítja, hogy a tranzakciókezelő meghívja az erőforrás-kezelőt, amikor a tranzakció véglegesítésre kerül vagy törlődik. A tranzakcióban történt igénybevételt követően az erőforrás-kezelő feldolgozza a tranzakciós alkalmazás kérelmét, például rekordok beszúrását, törlését vagy frissítését végezheti egy relációs adatbázisban. Az erőforrás-kezelő mindig visszatart annyi információt, amennyi elegendő a tranzakció visszavonásához vagy megismétléséhez. Mindehhez az erőforrás-kezelő több adatváltozatot tárol, vagy naplóban rögzíti az adatokon végzett módosításokat.

Amikor az alkalmazás véglegesítést kér, a tranzakciókezelő úgy inicializálja a kétfázisú véglegesítési protokollt, hogy felkészülésre utasítja az erőforrás-kezelőket. Az erőforrás-kezelő felkészülése rendszerint abból áll, hogy a régi és új adatértékeket lemezre menti, így az adatok még akkor is helyreállíthatók, ha a rendszer leáll és a memóriában tárolt adatok elvesznek. Az erőforrás-kezelő előkészítése után értesíti a tranzakciókezelőt a felkészülés megtörténtéről, és várja a tranzakciókezelő döntését arról, hogy a tranzakció véglegesítésére vagy megszakítására kerül-e sor. Miután valamennyi erőforrás-kezelő értesítette a tranzakciókezelőt a felkészülésről, a tranzakciókezelő döntést hoz a tranzakció véglegesítéséről. Ezután a tranzakciókezelő értesíti az összes erőforrás-kezelőt a tranzakció véglegesítéséről. Az erőforrás-kezelők véglegesítik a tranzakciót, majd feloldják a tranzakcióval kapcsolatban kialakított zárolásokat.

Ha valamelyik erőforrás-kezelő nem készíthető elő megfelelően, akkor az egyoldalúan megszakítja a tranzakciót, visszavonja a tranzakció hatásait, és minderről értesíti a tranzakciókezelőt. A tranzakciókezelő megszakítási rekordot ír a naplófájlba, amely jelzi, hogy a tranzakció meg lett szakítva. Ezután értesíti az igénybe vett erőforrás-kezelőket a tranzakció megszakításáról. Mivel az MS DTC a Presumed Abort (feltételezett megszakítás) protokollt használja, semmit nem ír az MS DTC naplófájlba a megszakított tranzakciókról, feltéve, hogy az MS DTC az általános végrehajtási koordinátor.

A felkészülés után az erőforrás-kezelőnek meg kell várnia, amíg a tranzakciókezelőtől megérkezik a véglegesítésre vagy a megszakításra vonatkozó döntés. Az egész kétfázisú véglegesítési protokoll végrehajtása a másodperc töredéke alatt történik. Egy rendszer- vagy kommunikációs hiba azonban percekkel vagy akár órákkal is késleltetheti a véglegesítésről vagy megszakításról szóló értesítést. Ezalatt az erőforrás-kezelőről elmondható, hogy bizonytalan állapotú a tranzakció kimenetelét illetően, mivel nem tudja, hogy a tranzakció véglegesítésre vagy törlésre kerül-e. Mivel az erőforrás-kezelő bizonytalan állapotban van, fenntartja azokat a zárolásokat, amelyek a tranzakció által módosított adatokat védik, elkülönítve ezeket a változtatásokat a többi tranzakciótól. Ha a rendszer újra használható, a tranzakciókezelő tájékoztatja az erőforrás-kezelőt a tranzakció eredményéről. Ezután az erőforrás-kezelő véglegesíti vagy megszakítja a tranzakciót, és feloldja a zárolt adatokat.

A tranzakciókezelő garantálja a tranzakciók atomitását és állandóságát az erőforrás-kezelő hibája esetére is. Ha egy erőforrás-kezelő meghibásodik, a tranzakciókezelő leállítja mindazokat a tranzakciókat, amelyekben az erőforrás-kezelő érintett (kivéve azokat, amelyek előkészítése vagy véglegesítése a meghibásodás előtt történt). Az erőforrás-kezelő az újraindításkor a tranzakciókezelőtől lekéri azoknak a bizonytalan állapotú tranzakcióknak az eredményét, amelyekben érintett volt. A tranzakciókezelő közli az erőforrás-kezelővel az egyes bizonytalan tranzakciók eredményét, majd az erőforrás-kezelő ennek megfelelően véglegesíti vagy szakítja meg ezeket a tranzakciókat.

Az Elosztott tranzakciók – áttekintés című témakör további információkat tartalmaz arról, hogy ez a folyamat miben különbözik akkor, ha a tranzakciók számítógépek közötti határvonalakat kereszteznek.


Elosztott tranzakciók – áttekintés

Az elosztott tranzakció a hálózatba kapcsolt két vagy több számítógéprendszeren található adatokat frissíti. Problémát jelenthet azonban a stabil alkalmazások megosztott környezetben történő felhasználása, mivel ezek az alkalmazások sokféle hibának vannak kitéve akár az ügyfél, akár a kiszolgálók, akár a hálózat részéről. Elosztott tranzakciók hiányában magának az alkalmazásnak kell felderítenie a hibákat és elvégeznie a helyreállítást. Az elosztott tranzakciók leveszik ezt a terhet az alkalmazások fejlesztőinek válláról.

Az MS DTC a két vagy több Windows 95, Windows 98, Windows NT, Windows 2000 és későbbi rendszer között elosztott tranzakciókat támogatja. Minden alkalmazás és erőforrás-kezelő a saját helyi tranzakciókezelőjével tartja a kapcsolatot. A helyi tranzakciókezelő a távoli tranzakciókezelőkkel együttműködve hangolja össze a rendszereket átfogó tranzakciókat, amint az az alábbi ábrán is látható.

Ha egy új tranzakciót tartalmazó kérés halad egyik rendszertől a másik felé, kapcsolat jön létre a két rendszer tranzakciókezelői között. A kezdeményező rendszer tranzakciókezelője egy kimenő (vagy felső szintű) kapcsolatot hoz létre a célrendszer tranzakciókezelőjével. Ugyanakkor a célrendszer tranzakciókezelője egy bejövő (vagy alárendelt) kapcsolatot hoz létre a kezdeményező rendszer tranzakciókezelőjével. Ezek a kimenő és bejövő kapcsolatok alkotják a tranzakciókezelők közötti kapcsolatok fastruktúráját, amelyet tranzakció-véglegesítési fának is neveznek.

A tranzakcióban résztvevő erőforrás-kezelők ugyancsak megtalálhatók ebben a véglegesítési struktúrában. A helyi tranzakciókezelő kimenő kapcsolatban áll a vele együtt működő erőforrás-kezelőkkel. Az erőforrás-kezelők viszont bejövő kapcsolatban állnak a velük együtt működő tranzakciókezelővel.

Minden tranzakciónak csak egyetlen gyökere van. A véglegesítési fa gyökere a globális véglegesítési koordinátor. A globális véglegesítési koordinátor az a tranzakciókezelő, amely a tranzakció véglegesítésére vagy megszakítására vonatkozó döntést hozza. Az MS DTC esetében a globális véglegesítési koordinátor a tranzakciót kezdeményező rendszer tranzakciókezelője.

A globális véglegesítési koordinátor a kétfázisú véglegesítési protokollal véglegesíti vagy szakítja meg a tranzakciót. A koordinátor inicializálja a véglegesítési fához továbbításra kerülő előkészítés, véglegesítés és megszakítás üzeneteket. A fa bármely csomópontja bármikor önállóan megszakíthat egy tranzakciót, mielőtt eleget tenne az első fázisban küldött előkészítési kérelemnek. A csomópont az előkészítés után addig marad előkészített és bizonytalan állapotban, amíg a véglegesítési koordinátor nem utasítja a tranzakció véglegesítésére vagy megszakítására. A globális véglegesítési koordinátor sohasem bizonytalan állapotú, mivel a koordinátor hozza meg a döntést a véglegesítésről vagy a megszakításról.

Ha az adott számítógép leáll, majd újraindul, a tranzakciókezelő az érintett számítógépen megpróbálja meghatározni azoknak bizonytalan állapotú tranzakcióknak az eredményét, amelyekben a számítógép részt vett. A tranzakciókezelő a naplófájl alapján határozza meg azoknak a tranzakcióknak az eredményeit, amelyek véglegesítési koordinátoraként működött.

Más rendszerektől érkező tranzakciók esetében a tranzakciókezelő a naplófájlok ellenőrzésével állapítja meg, hogy kapott-e korábban értesítést a tranzakció eredményéről. A továbbra is bizonytalan állapotú beérkező tranzakciók esetében a tranzakciókezelő a felső szintű tranzakciókezelőhöz küldött lekérdezésben kéri be a tranzakció eredményét.

Kimenő tranzakciók esetében a tranzakciókezelő kapcsolatba lép minden olyan alárendelt tranzakciókezelővel, amelyhez a tranzakciót elküldte, és tájékoztatja azokat a tranzakció eredményéről. A tranzakciókezelő válaszol azokra a lekérdezésekre is, amelyekben saját alárendelt tranzakciókezelői kérnek tájékoztatást a hozzájuk küldött bizonytalan állapotú kimenő tranzakciók eredményéről.

Az erőforrás-kezelők azzal a tranzakciókezelővel lépnek kapcsolatba, amellyel a bizonytalan állapotú tranzakciók eredményét meghatározzák. A tranzakciókezelő meghatározza minden bizonytalan tranzakció eredményét, majd tájékoztatja az erőforrás-kezelőket a tranzakció véglegesítéséről, illetve megszakításáról. Ha a tranzakció egy másik rendszertől származik, akkor lehet, hogy a tranzakciókezelőnek a másik rendszer tranzakciókezelőjével kell kapcsolatba lépnie a tranzakció eredményének megállapításához.

A rendszer- vagy kommunikációs hibák hosszú ideig bizonytalan állapotban hagyhatják a tranzakciókat. Amíg egy tranzakció bizonytalan, a tranzakció által módosított erőforrások zároltak maradnak, és mások nem férhetnek hozzájuk. A rendszergazda a Komponensszolgáltatások felügyeleti eszköz segítségével kézzel oldhatja fel a túl hosszú ideje bizonytalan tranzakciókat.

A Komponensszolgáltatások felügyeleti eszköz a tranzakciók állapotának megtekintésére és feloldására használható. További információt a Tranzakciók feloldása kézzel című témakörben talál.

Az MS DTC támogatja a kétfázisú véglegesítés hatékonyságát növelő optimalizálási folyamatokat. Támogatott folyamatok például az Írásvédett tranzakció optimalizálás és a Véglegesítés átadása optimalizálás.


Írásvédett tranzakció optimalizálás

Az MS DTC lehetővé teszi, hogy az elolvasott, de nem frissített, tranzakcióval védett adatokkal rendelkező erőforrás-kezelők írásvédett választ küldjenek az első fázisban. Ebben az esetben a tranzakciókezelő nem továbbítja a második fázisú értesítést az erőforrás-kezelőhöz. Ezzel az optimalizálással csökkenthető a tranzakció véglegesítésének költsége.

Az írásvédett optimalizálás a tranzakciókezelők között is használt eljárás a tranzakciófa teljes alstruktúrájára vonatkozó véglegesítés optimalizálására. A tranzakciókezelő akkor küld írásvédett választ, ha minden alárendelt erőforrás-kezelőtől és tranzakciókezelőtől írásvédett választ kap. Ez azt jelenti, hogy az adott tranzakciókezelő és annak teljes alstruktúrája nem kér értesítést a második fázisban.


Véglegesítés átadása optimalizálás

Az MS DTC lehetővé teszi a véglegesítési koordinátor feladatainak átruházását a koordinálást végző tranzakciókezelőtől az egyik alárendelt tranzakciókezelőre vagy erőforrás-kezelőre. A véglegesítési koordinátori feladatok átruházására akkor kerül sor, ha a koordinálást végző tranzakciókezelő azt észleli, hogy a tranzakcióban csak egyetlen alárendelt erőforrás-kezelő vagy tranzakciókezelő érintett.

Az MS DTC a véglegesítési koordinátori tevékenységet akkor adja át az alárendelt tranzakciókezelőnek, amikor csak egyetlen alárendelt tranzakciókezelő van lefoglalva a tranzakcióban, és az aktuális koordináló tranzakciókezelő nem foglal le egyetlen erőforrás-kezelőt sem. Ilyen esetben a koordinálást végző tranzakciókezelő véglegesítés átadása üzenetet küld az első fázisú üzenet helyett. A véglegesítés átadása üzenet az aktuális koordináló tranzakciókezelő véglegesítés koordinálásával kapcsolatos felelősségét annak alárendelt tranzakciókezelőjének adja át. A témakörhöz tartozó ábrán például látható, hogy az A rendszer tranzakciókezelője átadta a véglegesítés koordinálásával kapcsolatos felelősségét a B rendszer tranzakciókezelőjének.

A véglegesítés átadása optimalizálás rekurzív módon alkalmazható. A véglegesítés koordinálását átvevő tranzakciókezelő ezt a felelősséget továbbadhatja saját alárendelt tranzakciókezelőjének, és így tovább.

A koordináló tranzakciókezelő akkor adja át a véglegesítés koordinálását az erőforrás-kezelőnek, ha a tranzakcióban egyetlen alárendelt tranzakciókezelő sincs lefoglalva, és csak egyetlen erőforrás-kezelő érintett a tranzakcióban. Amennyiben a koordinációt végző tranzakciókezelő az első fázisban kéri az erőforrás-kezelőt a felkészülésre, akkor azt is közli az erőforrás-kezelővel, hogy a véglegesítés koordinátoraként is működhet. Az erőforrás-kezelő választhat a véglegesítési koordinálással kapcsolatos felelősség elfogadása és elutasítása között. Bizonyos erőforrás-kezelők ezt az optimalizálást nem valósítják meg. Ha az erőforrás-kezelő nem fogadja el a véglegesítés koordinálásával kapcsolatos felelősséget, akkor a tranzakciókezelő egyszerűen megtartja azt, majd végrehajtja a normál kétfázisú véglegesítési protokollt az optimalizálás nélkül. Az előző ábrán a B rendszer tranzakciókezelője sikeresen átadta a véglegesítés koordinálásával kapcsolatos felelősséget a B rendszer erőforrás-kezelőjének.


Az MS DTC komponensei

Az MS DTC komponensei az MS DTC tranzakciókezelő, az MS DTC proxy, a rendszergazda grafikus felülete, a Komponensszolgáltatások felügyeleti eszköz és a naplófájl. Ha az MS DTC komponenseinek konfigurálásáról többet szeretne tudni, olvassa el Az MS DTC konfigurálása című témakört.

Az MS DTC tranzakciókezelő

Az MS DTC tranzakciókezelő az a folyamat, amely az MS DTC tranzakciók összehangolásáért felelős. Minden egyes Windows operációs rendszerben rendszerint csak egyetlen MS DTC tranzakciókezelő folyamat található. A rendszergazda azonban úgy is konfigurálhatja a rendszert, hogy az egy másik rendszeren futó MS DTC tranzakciókezelőtől függjön. Erre vonatkozó példát az Ügyfél hálózati protokolljának konfigurálása című témakörben talál.

Az MS DTC naplófájlja

Az MS DTC tranzakciókezelő a saját rendszerén lévő merevlemezen tárol MS DTC naplófájlt. Az MS DTC naplófájl minden olyan információt tartalmaz, amely az MS DTC számára a tranzakcióval kapcsolatban szükséges. Ez a fájl tartalmazza a tranzakció azonosítóját, de megtalálható benne azoknak az erőforrás-kezelőknek a listája is, amelyeket a tranzakciókezelő leköthet. Ha a tranzakció egy másik csomópontból importálással került az adott csomópontba, akkor a naplófájlból megállapítható, hogy melyik MS DTC tranzakciókezelő importálta a tranzakciót az adott csomópontba. Ha a tranzakciót ebből a csomópontból importálták más csomópontokba, a naplófájl megadja, hogy mely tranzakciókezelők végezték az exportált tranzakció küldését. A naplófájlból megtudható a tranzakció eredménye is, valamint az, hogy mely erőforrás-kezelők és tranzakciókezelők kaptak értesítést a tranzakció eredményéről. Bővebb tájékoztatásért olvassa el A naplófájl kezelése című részben leírtakat.

Az MS DTC által a naplófájlban tárolt információ általában rövid élettartamú. A tranzakcióval kapcsolatos minden információ feleslegessé válik, miután a tranzakció véglegesítésére vagy megszakítására sor került, és az alárendelt tranzakciókezelők és erőforrás-kezelők értesítést kaptak a tranzakció eredményéről. Emiatt az MS DTC naplófájl egyszerű körkörös fájlként működik. Az MS DTC a naplófájlt szekvenciálisan írja. Ha az MS DTC eléri a naplófájl végét, tovább folytatja az írást a naplófájl elején, azaz felülírja az elévült adatokat.

Bár az MS DTC által a naplófájlban tárolt adatok nagy része rövid életű, vannak hosszabb élettartamú információk is. Az MS DTC úgy akadályozza meg ezeknek a hosszú élettartamú adatoknak a felülírását és ezáltal elvesztését, hogy az információt időnként a naplófájl éppen aktív területére másolja. A hosszabb élettartamú adatoknak ezt a naplófájlon belüli másolását periodikus ellenőrzésnek is nevezik. Az MS DTC a periodikus ellenőrzést rendszeresen végrehajtja.

Az MS DTC naplóadatai bináris formátumúak. Jelenleg nincs olyan mechanikus eszköz, amellyel az MS DTC naplófájl tartalma megjeleníthető.

Az MS DTC proxy

Az MS DTC proxy DLL-fájlja (Msdtcprx.dll) OLE Transactions felületeket alkalmaz. Az OLE Transactions a Microsoft alkalmazásprogramozási felületekre vonatkozó szabványa a tranzakciók kezeléséhez. Az OLE Transactions definiálja azokat a felületeket, amelyeket az alkalmazások és az erőforrás-kezelők a tranzakciók végrehajtásához használhatnak. Az alkalmazások az OLE Transactions felületeket hívják meg a tranzakciókkal kapcsolatos inicializáláshoz, véglegesítéshez, megszakításhoz és lekérdezéshez. Az erőforrás-kezelők az OLE Transactions felületeket hívják meg a tranzakciókhoz, a tranzakciók folyamatról folyamatra vagy rendszerről rendszerre történő terjesztéséhez, valamint a kétfázisú véglegesítési protokollban való részvételhez.

Az alkalmazások és az erőforrás-kezelők az MS DTC proxy által létrehozott OLE Transactions felületeken keresztül tartják a kapcsolatot az MS DTC tranzakciókezelővel.

Az MS DTC rendszerfelügyeleti felhasználói felület

Az MS DTC konfigurálásához, figyeléséhez és kezeléséhez használható grafikus felhasználói felületeket a Komponensszolgáltatások felügyeleti eszköz hozza létre. A Komponensszolgáltatások felügyeleti eszköz RPC (távoli eljáráshívás) alkalmazásával kommunikál az MS DTC tranzakciókezelővel. A Komponensszolgáltatások felügyeleti eszköz feladatairól Az elosztott tranzakciók felügyeletével kapcsolatos feladatok című témakörben olvashat.

A Komponensszolgáltatások felügyeleti eszköz helyi és távoli rendszeren is felhasználható az adott MS DTC tranzakciókezelő kezelésére. Ezáltal lehetővé válik több MS DTC rendszer egyetlen központból történő irányítása.

MS DTC fájlok

Az MS DTC a következő fájlokat tartalmazza:

Fájl | Leírás
Msdtc.exe | Az MS DTC konzolprogramja
Msdtclog.dll | Az MS DTC naplókezelő DLL-fájlja
Msdtcmgr.exe | Az MS DTC felhasználói felületének alapprogramja
Msdtcprf.h | Az MS DTC teljesítményfigyelő fejlécfájlja
Msdtcprf.ini | Az MS DTC teljesítményfigyelő .ini fájlja
Msdtcprx.dll | Az MS DTC OLE Transactions felületproxy DLL-fájlja
Msdtctm.dll | Az MS DTC tranzakciókezelő DLL-fájlja
Msdtcui.dll | Az MS DTC felügyeleti komponensének DLL-fájlja
Mtxclu.dll | Az MS DTC és MTS fürttámogatás DLL-fájlja
Txfaux.dll | A TFX támogató rutinjai
Xolehlp.dll | Az MS DTC súgó API csatolóinak DLL-fájlja


Az MS DTC konfigurálása

Az MS DTC többféle módon konfigurálható. Az MS DTC rendszerint minden Windows 2000 operációs rendszeren telepítve van. Ebben az esetben minden rendszer rendelkezik egy saját MS DTC példánnyal (további információt A hálózat konfigurálása az MS DTC támogatásához és az Elosztott tranzakciók végrehajtása Windows 95, Windows 98 vagy Windows NT rendszereken című részekben talál). Ugyanakkor az is lehetséges, hogy két vagy több rendszer megosztva használjon egyetlen MS DTC példányt (erről bővebben a Helyi MS DTC tranzakciókezelő Windows 2000 rendszeren és a Távoli MS DTC tranzakciókezelő Windows 2000 rendszeren című részekben tájékozódhat). Egyes esetekben ez hatékonyabb lehet, mintha minden rendszer saját MS DTC példánnyal rendelkezne. Windows 2000 rendszerekből álló kiszolgálófürt esetében egyetlen MS DTC példány szolgálja ki az egész fürtöt (további részleteket az MS DTC tranzakciókezelő Windows 2000 rendszerekből álló kiszolgálófürtön című részben talál). Ezekről a konfigurációs lehetőségekről részletesebben is olvashat ebben a témakörben.

Az integrált adatvédelem támogatása

Ha integrált adatvédelmet alkalmaz, akkor az MS DTC tranzakciókezelőhöz olyan felhasználói nevet és jelszót kell beállítani, amely lehetővé teszi az Oracle adatbázishoz történő csatlakozást. Az integrált adatvédelem megengedi, hogy az adatbázis felhasználóinak ellenőrzésekor az adott Oracle adatbázis elfogadja a Windows 2000 hitelesítését. Ez lehetővé teszi, hogy a felhasználó külön bejelentkezési azonosító és jelszó megadása nélkül jelentkezzen be az Oracle adatbázisba. A felhasználók ugyanazt a bejelentkezési azonosítót és jelszót használhatják a Windows 2000 rendszerhez és az Oracle adatbázishoz is.

Ha a komponensek Oracle adatbázisokhoz történő csatlakoztatáskor mindig bejelentkezési azonosítót és jelszót adnak meg, akkor a rendszer még nem alkalmazza az integrált adatvédelmet. Ez akkor igaz, ha az alkalmazások a bejelentkezési azonosítót és a jelszót közvetlenül, illetve közvetve, DSN alkalmazásával adják meg. Az előző esetek egyikében sem került sor az integrált adatvédelem alkalmazására, így nem kell felhasználónevet és jelszót beállítani az MS DTC tranzakciókezelőhöz ahhoz, hogy Oracle adatbázishoz kapcsolódhasson.

Ha integrált adatvédelmet alkalmaz, akkor az MS DTC tranzakciókezelőhöz olyan felhasználói nevet és jelszót kell beállítani, amely lehetővé teszi az Oracle adatbázishoz történő csatlakozást. Erre azért van szükség, mert az adatbázis-visszaállítás során az MS DTC megnyitja az Oracle adatbázist, hogy bejegyezze a bizonytalan tranzakciók eredményét.

Az MS DTC szolgáltatásai

Az MS DTC két szolgáltatástípust biztosít: „nélkülözhetetlen szolgáltatásokat” és „választható szolgáltatásokat”. A nélkülözhetetlen szolgáltatások a Windows rendszer működése szempontjából létfontosságúak. Az MS DTC nem indítható el, ha valamelyik nélkülözhetetlen MS DTC szolgáltatás sem indul el. A többi MS DTC szolgáltatás „választható”. Az MS DTC indításakor kísérletet tesz a választható szolgáltatások elindítására. Ha ezek a szolgáltatások elindulnak, akkor elérhetővé válnak az MS DTC ügyfelei számára. Ha egy adott választható szolgáltatás nem indul el, akkor a szolgáltatás használatára tett minden kísérlet hibaüzenet kíséretében elutasításra kerül. Az MS DTC leállításával és újraindításával a választható szolgáltatásokat második alkalommal is elindíthatja. Az MS DTC leállításának és újraindításának egyes lépései Az MS DTC indítása és leállítása című témakörben találhatók.

Az MS DTC az alábbi rendszerszolgáltatásokat is használja.

NTLMSSP

Az MS DTC az NTLMSSP szolgáltatás segítségével titkosítja az XA adatbázis MS DTC naplófájlban tárolt nyitó karakterláncát. Az MS DTC az XA nyitó karakterláncot használja, ha visszaállításhoz megnyit egy XA adatbázist. A nyitó karakterlánc titkosított, mivel így biztosítható a nyitó karakterláncban esetleg előforduló felhasználói azonosítók és jelszavak védelme.

RPCSS

Az MS DTC az RPCSS szolgáltatás segítségével biztosítja az MS DTC komponensek közötti kommunikációt.

Hálózati csatlakozás konfigurációja

Ha egy adott alkalmazás két vagy több számítógépre kiterjedő tranzakciókat hajt végre, akkor ezeket a számítógépeket úgy kell konfigurálni, hogy kommunikálni tudjanak egymással (bővebb tájékoztatásért olvassa el Az MS DTC konfigurálása című témakört).

Az MS DTC csak akkor képes a tranzakciók egyik rendszerről egy másik rendszerre történő átvitelére, ha az egyik (az elsődleges) rendszeren zajló MS DTC folyamat képes kommunikálni a másik (a másodlagos) rendszeren zajló MS DTC folyamattal. Bármelyik rendszeren előfordulhat azonban olyan hálózati konfigurációs probléma, amely megakadályozhatja az MS DTC folyamatok egymás közötti kommunikációját. Ennek eredményeként az alkalmazásokban egy „Sikertelen besorolás hiba” üzenet jelentkezik. Az ilyen típusú üzenetekkel kapcsolatban Az MS DTC eszközzel összefüggő problémák kezelése című témakör nyújt tájékoztatást.


A hálózat konfigurálása az MS DTC támogatásához

Minden, MS DTC folyamatok között zajló kommunikáció helyi távoli eljáráshívással (LRPC), távoli eljáráshívással (RPC) vagy Transaction Internet protokoll (TIP) használatával folyik.

LRPC

Az MS DTC mindig az LRPC eljáráshívást alkalmazza, ha az egymással kommunikáló folyamatok ugyanazon a rendszeren találhatók. Az LRPC hívást alkalmazza például akkor, amikor az MS DTC proxy a saját helyi MS DTC tranzakciókezelőjével kommunikál. Az MS DTC ezt az eljáráshívást nagyfokú hatékonysága miatt alkalmazza a helyi kommunikációhoz.

RPC

Az MS DTC az RPC eljáráshívást alkalmazza akkor, ha az egymással kommunikáló folyamatok nem ugyanazon a rendszeren találhatók. Az RPC eljáráshívást alkalmazza például az MS DTC proxy abban az esetben, amikor egy másik rendszeren lévő MS DTC tranzakciókezelővel kommunikál. Ilyen eset akkor fordul elő, ha az MS DTC proxy a fürt egyik csomópontjában, az MS DTC tranzakciókezelő pedig a fürt másik csomópontjában működik. Ez a helyzet áll fenn akkor is, amikor az MS DTC úgy van konfigurálva, hogy egy távoli tranzakciókezelőre hagyatkozik. Egy adott MS DTC tranzakciókezelő akkor is az RPC eljáráshívást alkalmazza, ha egy másik rendszeren lévő MS DTC tranzakciókezelővel kommunikál.

Az MS DTC RPC kommunikációja TCP/IP, SPX és NetBEUI eszközön keresztül történhet. Az MS DTC kiválasztja az első olyan átviteli eszközt, amely közös abban a két rendszerben, amelyeknek kommunikálniuk kell egymással. Az MS DTC esetében az előnyben részesített átviteli eszköz a TCP/IP. Ha a TCP/IP nem használható, az MS DTC megpróbálkozik előbb az SPX, majd a NetBEUI használatával. Ha az MS DTC nem talál olyan eszközt, amely mindkét rendszerben azonos, a következő hibajelentést írja az alkalmazás eseménynaplójába:

MS DTC is unable to communicate with MS DTC on a remote system (Az MS DTC nem tud kapcsolatba lépni a távoli rendszeren lévő MS DTC-vel). No common RPC protocol is supported between the two systems (A két rendszer között nincs közös, támogatott RPC protokoll). Please ensure that one or more of the following RPC protocols are common to both systems: TCP/IP, SPX, or NetBEUI (A következő RPC protokollok közül egynek vagy többnek azonosnak kell lennie mindkét rendszeren: TCP/IP, SPX vagy NetBEUI).

TIP

Az MS DTC a Transaction Internet protokoll alkalmazásával is képes kapcsolatot teremteni különböző rendszereken lévő tranzakciókezelők között. A TIP a TCP/IP protokollon alapul, és a 3372-es portot használja.

Az MS DTC akkor választja a TIP protokollt, ha valamely alkalmazás vagy erőforrás-kezelő egyértelműen a TIP OLE Transactions felületeket használja. Az MS DTC akkor is a TIP protokollt használja, ha a TIP az egyetlen olyan kommunikációs protokoll, amely mindkét platformon előfordul. A TIP alkalmazására rendszerint akkor kerül sor, ha az MS DTC más cégek tranzakció-kezelőivel együtt kerül felhasználásra.


Elosztott tranzakciók végrehajtása Windows 95, Windows 98 vagy Windows NT rendszereken

Ha az MS DTC elosztott tranzakcióit Windows 2000 és Windows NT 4.0 rendszerek között kívánja végrehajtani, akkor a Windows NT 4.0 rendszeren az MS DTC 1998.08.762.0-s vagy újabb verzióját kell telepítenie. Ez elengedhetetlen feltétel, mivel a Windows 2000 rendszeren lévő MS DTC egy új üzenetprotokollt használ az MS DTC rendszerek egymás közötti kommunikációjához. Az MS DTC 1998.08.762.0-s verziója található a Windows NT 4.0 Service Pack 4 csomagban is. Ez a verzió már támogatja az új üzenetprotokollt.

A Windows 2000 rendszeren lévő MS DTC korlátozott mértékben támogatja az együttműködést a Windows 95, Windows 98 és Windows NT 3.51-es rendszerekkel. Egy adott MS DTC tranzakció átvihető Windows 2000 rendszerről Windows 95, Windows 98 vagy Windows NT 3.51 rendszerre, fordítva azonban nem. A Windows 2000 rendszeren működő valamely COM+ alkalmazás egyik komponense például meghívhatja a Windows 95, Windows 98 vagy Windows NT 3.51 rendszeren futó Microsoft SQL Server adatbázist. Hasonló módon, a Windows 2000 rendszeren futó Microsoft SQL Server tárolt eljárások (elosztott tranzakció-vezérlés mellett) meghívhatják a Windows 95, Windows 98 vagy Windows NT 3.51 rendszeren lévő Microsoft SQL Server tárolt eljárást.

A Windows 95, Windows 98 vagy Windows NT 3.51 rendszeren futó MTS-komponens nem hívhatja meg a Windows 2000 rendszeren futó SQL Server adatbázist. Ugyanígy a Windows 95, Windows 98 vagy Windows NT 3.51 rendszeren lévő Microsoft SQL Server tárolt eljárás elosztott tranzakció-kezelés mellett nem tudja meghívni a Windows 2000 rendszeren lévő Microsoft SQL Server tárolt eljárást.


Helyi MS DTC tranzakciókezelő Windows 2000 rendszeren

Az MS DTC tranzakciókezelő, az MS DTC proxy és a Komponensszolgáltatások felügyeleti eszköz mindig telepítve van a Windows 2000 rendszeren. Ennek eredményeként minden Windows 2000 rendszer képes tranzakciókat végrehajtani saját helyi MS DTC tranzakció-kezelőjén keresztül.

Ha a rendszeren lévő egyik alkalmazás meghívja a BeginTransaction metódust, az adott rendszer MS DTC tranzakciókezelője egy MS DTC tranzakciót fog inicializálni és koordinálni. Ha egy erőforrás-kezelő vesz részt a tranzakcióban, akkor azt saját MS DTC tranzakciókezelője veszi igénybe.

Az MS DTC tranzakciókezelő saját helyi lemezén tárol MS DTC naplófájlt.


Távoli MS DTC tranzakciókezelő Windows 2000 rendszeren

Két vagy több nem fürtözött Windows operációs rendszer egyetlen MS DTC tranzakció-kezelőn is osztozhat. Az alábbi ábrán a B rendszerhez tartozik egy MS DTC tranzakciókezelő és annak naplófájlja. A B rendszeren futó tranzakciós alkalmazások és erőforrás-kezelők saját helyi MS DTC tranzakció-kezelőjükkel kommunikálnak, amely a B rendszeren működik.

Az A rendszer a B rendszer MS DTC tranzakciókezelőjének használatára van konfigurálva. Ha az A rendszer egyik tranzakciós alkalmazása vagy erőforrás-kezelője meghív egy MS DTC függvényt, az A rendszeren lévő MS DTC proxy a kérelmet a B rendszer MS DTC tranzakció-kezelőjéhez továbbítja. A B rendszer tranzakciókezelője az A és a B rendszer valamennyi tranzakciójának kezelőjeként működik.

A tranzakciók végrehajtása hatékonyabbá tehető, ha két vagy több rendszert úgy konfigurálnak, hogy megosztva használjanak egyetlen MS DTC tranzakciókezelőt. Ha az adott tranzakció mindkét csomópontot érinti, a tranzakciókezelő akkor is csak egyetlen naplóbejegyzést készít. Ha minden rendszernek saját tranzakciókezelője lenne, mindegyik elkészítené saját naplóbejegyzését.


MS DTC tranzakciókezelő Windows 2000 rendszerekből álló kiszolgálófürtön

Az MS DTC tranzakciókezelő, az MS DTC proxy és a Komponensszolgáltatások felügyeleti eszköz a Windows 2000 telepítése során mindig telepítésre kerül egy adott Windows 2000 kiszolgálófürt valamennyi csomópontjában. A rendszerek fürtözésekor az MS DTC fürtözött módban történő konfigurálásához a COM fürtvarázslót (Comclust.exe) kell futtatni.

A Fürtvarázsló a következő módosításokat hajtja végre az MS DTC konfigurációjában:

  • Létrehoz egy MS DTC erőforrást valamelyik erőforráscsoportban, amely tartalmaz egy megosztott merevlemezt és egy hálózati néverőforrást.
  • Létrehoz egy MS DTC naplófájlt az MS DTC erőforráscsoportban lévő megosztott lemezen. Az MS DTC naplófájlnak a megosztott lemezen történő elhelyezése teszi lehetővé, hogy az MS DTC tranzakciókezelő a fürt bármelyik rendszeréből elérje az MS DTC naplófájlt.
  • Az MS DTC rendszerleíró adatbázis fontos bejegyzéseit a megosztott fürt rendszerleíró adatbázisába másolja.

Ha az MS DTC fürtözött módban fut, a fürtnek egyszerre csak egy csomópontja futtatja az MS DTC tranzakciókezelőt.

A fürt többi csomópontjában futó bármelyik csomópont használhatja az MS DTC tranzakciókezelőt. Ezek a folyamatok csupán a szokott módon hívják meg az MS DTC proxyt, amely automatikusan továbbítja az MS DTC hívásokat ahhoz az MS DTC tranzakciókezelőhöz, amely az egész fürtöt irányítja.

Ha az MS DTC tranzakciókezelőt futtató csomópont leáll, az MS DTC automatikusan újraindul a fürt egy másik csomópontjában. Az újraindított MS DTC tranzakciókezelő a megosztott lemezen tárolt MS DTC naplófájlt beolvasva határozza meg a függőben maradt, illetve a nemrég befejeződött tranzakciók eredményét. Az MS DTC tranzakcióhoz ismét hozzákapcsolódnak az erőforrás-kezelők, és a helyreállítást végrehajtva meghatározzák a bizonytalan tranzakciók eredményét. Az alkalmazások is hozzákapcsolódnak az MS DTC tranzakciókezelőhöz, így képessé válnak új tranzakciók inicializálására.

A fenti ábrán például a B rendszer MS DTC tranzakciókezelője aktív. Az A rendszer alkalmazása és erőforrás-kezelője hívja meg az MS DTC proxyt. Az A rendszeren található MS DTC proxy az összes MS DTC hívást továbbítja a B rendszer MS DTC tranzakciókezelőjéhez.

Ha a B rendszer leáll, az A rendszer MS DTC tranzakciókezelője veszi át a szerepét. Beolvassa a megosztott lemezen lévő MS DTC naplófájlt, elvégzi a helyreállítást, majd az egész fürt tranzakciókezelőjeként fog működni.


Az MS DTC kezelése távoli rendszerről

Az MS DTC távoli rendszerről történő kezeléséhez a következő lehetőségeket kell figyelembe venni:

  • Az MS DTC kezelése távoli Windows 2000 vagy Windows NT 4.0 rendszerről
  • Az MS DTC kezelése távoli Windows 95 vagy Windows 98 rendszerről
  • Biztonsági szempontok az MS DTC távolról történő kezelése kapcsán

Az MS DTC kezelése távoli Windows 2000 vagy Windows NT 4.0 rendszerről

Windows 2000 rendszeren lévő MS DTC felügyeletét távoli Windows 2000 vagy Windows NT 4.0 rendszerről is elláthatja.

Távolról nem tudja konfigurálni vagy visszaállítani az MS DTC naplófájlját. A Komponensszolgáltatások felügyeleti eszköz közvetlenül frissíti az MS DTC naplófájlt, ezért ennek azon a rendszeren kell futnia, ahol a naplófájl található.

Az MS DTC kezelése távoli Windows 95 vagy Windows 98 rendszerről

Windows 2000 rendszeren lévő MS DTC felügyeletét távoli Windows 95 vagy Windows 98 rendszerről is elláthatja.

Az MS DTC naplófájlját távolról nem tudja konfigurálni vagy visszaállítani. A Komponensszolgáltatások felügyeleti eszköz közvetlenül frissíti az MS DTC naplófájlt, ezért ennek azon a rendszeren kell futnia, ahol a naplófájl található.

Az MS DTC nem indítható el vagy állítható le távoli Windows 95 vagy Windows 98 rendszerről.

Biztonsági szempontok az MS DTC távolról történő kezelése kapcsán

A távoli kezelést a Windows 2000 rendszergazdájaként végezheti.


A naplófájl kezelése

Az MS DTC naplófájlt használ az elosztott tranzakciók statisztikai adatainak figyelésére és tárolására. A naplófájl lényeges része a tranzakciók kezelésének, mivel itt tárolódnak a megoldatlan tranzakciók adatai – azok az információk, amelyeket az MS DTC rendszerleállás esetén használ a tranzakciók megoldásához.

A naplófájl mérete és helye hatással lehet a rendszer teljesítményére

A rendszerteljesítmény kezeléséhez szükség lehet a naplófájl méretének, illetve helyének megváltoztatására. Az MS DTC naplófájl mérete határozza meg, hogy egyszerre hány tranzakció hajtható végre. (Windows 2000 operációs rendszer esetében a naplófájl legnagyobb mérete 4 MB.) A véglegesített vagy megszakított tranzakciók törlődnek a naplófájlból.

Ha a naplófájl megtelik, a helyi kiszolgálón lévő tranzakciókezelő mindaddig nem tud új tranzakciót fogadni, amíg fel nem szabadul az új tranzakció bejegyzéséhez szükséges terület. A tranzakciós terhelés egyensúlyban tartható az MS DTC tranzakciókezelőt futtató számítógépeken. Ha például az aktuális tranzakciók száma közelít a megengedett maximumhoz, a naplófájl méretének növelésével teheti lehetővé újabb tranzakciók indítását. Ha viszont az aktuális tranzakciók száma a minimális értékhez közelít, a naplófájl méretének csökkentésével lemezterületet szabadíthat fel. Növelhető a teljesítmény azzal is, ha a naplófájlt olyan helyre helyezi át, ahol sok a szabad terület, illetve alacsony a rendszer igénybevétele.

Az MS DTC naplófájl helyének kiválasztása

Az MS DTC naplófájl az MS DTC telepítésekor az alapértelmezés szerinti helyen jön létre. Windows 2000 és Windows NT operációs rendszereken a naplófájl alapértelmezett helye a %windir%\system32\DTCLog könyvtár. Előfordulhat azonban, hogy a rendszer teljesítményének növeléséhez új helyet kell keresnie a naplófájlnak. További részleteket a következő útmutatókban talál.

  • Teljesítmény – Rendkívül nagy teljesítményű tranzakciófeldolgozó rendszerek esetén érdemes lehet az MS DTC naplófájlt egy kijelölt lemezeszközön vagy egy másik, viszonylag kisebb mértékű egyéb forgalmat bonyolító eszközön elhelyezni. A legtöbb rendszer esetében azonban az MS DTC naplófájl bármilyen lemezen elhelyezhető, amelynek területe nincs túlzott mértékben kihasználva.
  • Megbízhatóság – A legnagyobb mértékű megbízhatóság biztosítása érdekében az MS DTC naplófájlt RAID-1 eszközön helyezze el. Ha az MS DTC naplófájl elvész, az MS DTC nem tudja nyomon követni a függőben lévő tranzakciókat. Ez hatással lehet a tranzakcióval védett adatbázisok, az üzenetsorok és az MS DTC által koordinált fájlok adatainak konzisztenciájára.

    A RAID-1 rendszerben az elsődleges lemezen elkészített naplóbejegyzésekről tükörmásolat készül. Mivel ezek a példányok egyszerre készülnek, a naplóbejegyzések létrehozására fordított idő most egy kicsit több, mint amikor egyetlen eszközre készül bejegyzés. Mivel az MS DTC naplóbejegyzései szinkronizáltak és szekvenciálisan követik egymást, ideálisak a RAID-1 eszközzel való alkalmazáshoz. A RAID-1 is ideális az MS DTC naplófájl számára, mivel hibatűréssel működik. Ha a tükrözött párok közül az egyik meghajtó meghibásodik, az MS DTC tovább működik a másik lemez használatával.

    A RAID-1 hardveren vagy szoftveren keresztül biztosítható. A Windows 2000 a RAID-1 rendszert szoftveren keresztül biztosítja. A Windows 2000 által nyújtott RAID-1 teljesítmény rendszerint elegendő, mivel csak kis mértékű feldolgozási terhelést ró a rendszerre. A hardveralapú RAID-1 megoldás alkalmazásával gyakran sokkal jobb teljesítmény érhető el, mint a Windows 2000 szoftveralapú RAID-1 rendszerével.

  • Fürtözött rendszerek – Fürtözött rendszerben az MS DTC naplófájlt megosztott lemezen kell elhelyezni. Ez teszi lehetővé, hogy az MS DTC tranzakciókezelő hozzáférjen a naplófájlhoz attól függetlenül, hogy az melyik fürtcsomópontban működik.

Az MS DTC naplófájl méretének kiválasztása

Az MS DTC naplófájl mérete határozza meg, hogy egyszerre hány tranzakció lehet aktív. A véglegesített vagy megszakított tranzakciók automatikusan törlődnek a naplófájlból.

Ha a naplófájl túlzsúfolttá válik, az MS DTC leállítja az új tranzakciók inicializálását és az igénybevételek engedélyezését az aktuális tranzakciókban. A BeginTransactions metódusra vonatkozó hívások XACT_E_LOGFULL hibával kerülnek elutasításra. Az erőforrás-kezelőktől az igénybevételekkel kapcsolatban érkezett hívásokat a rendszer XACT_E_LOGFULL hibával utasítja el. Ha ilyen hibát tapasztal, növelje az MS DTC naplófájl méretét.

Windows 2000 és Windows NT operációs rendszerek esetén a naplófájl alapértelmezett mérete 4 MB. Windows 95 és Windows 98 rendszerek esetében a naplófájl alapértelmezett mérete 1 MB.

Saját MS DTC naplófájlja méretének meghatározásához az alábbi útmutatót használhatja. Minden 1000, egy időben aktív tranzakció számára foglaljon le 1 MB területet. Minden 500, az alkalmazások által egy időben nyitva tartható Oracle, IBM DB2, Informix, Sybase vagy CA Ingres adatbázis-kapcsolat számára foglaljon le 1 MB területet.

Ezek óvatos útmutatások. Az MS DTC naplófájl egyes bejegyzései számára ténylegesen szükséges lemezterület nagysága a tranzakcióban érintett erőforrás-kezelők és alárendelt tranzakciókezelők számától függ. Ezen felül az MS DTC a rendelkezésre álló lemezterületből nagy részeket tart lefoglalva az MS DTC naplófájlban is, hogy legyen elegendő terület bármely korábban inicializált tranzakció véglegesítéséhez vagy megszakításához.

A legtöbb rendszer esetében az MS DTC naplófájlméretek biztonságosak és elegendőek.

Az MS DTC naplófájl ürítése

Az MS DTC naplófájl másik eszközre történő áthelyezéséhez vagy méretének módosításához üríteni kell ugyan a naplófájlt, normál körülmények között azonban erre nincs szükség. Ezzel ugyanis az MS DTC elveszítheti a függőben lévő tranzakciók nyomát, és ez befolyásolhatja a tranzakcióval védett adatbázisok, üzenetsorok és az MS DTC által koordinált fájlok konzisztenciáját.

Nem kell az MS DTC naplófájlt üríteni a fájl által lefoglalt lemezterület felszabadításához sem, ugyanis ezt az MS DTC automatikusan megteszi. Miután egy tranzakció véglegesítése vagy megszakítása megtörtént, az MS DTC értesül arról, hogy a naplóbejegyzésekre már nincs szükség, és a bejegyzések által lefoglalt területet más tranzakciókhoz használja fel.

Az MS DTC naplófájl módosításakor egyetlen tranzakció sem lehet Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés állapotban. További információt a Tranzakcióállapot feloldása című részben talál.

Ha szeretné megváltoztatni a naplófájl attribútumait, a méretezési vagy áthelyezési eljárást megtalálja Az MS DTC naplófájl konfigurálása című témakörben.

Fontos megjegyezni, hogy távoli rendszer MS DTC naplófájlját nem lehet üríteni. A Komponensszolgáltatások felügyeleti eszköz közvetlenül frissíti az MS DTC naplófájlt, ezért ennek azon a rendszeren kell futnia, ahol a naplófájl található.

Az MS DTC naplófájl ürítésére vonatkozó részletes információkat Az MS DTC naplófájl ürítése című témakörben találja meg.

A sérült naplófájlok nem állíthatók helyre

Ha az MS DTC naplófájl megsérül vagy elveszik, akkor azt nem lehet helyreállítani, másik rendszerből bemásolni vagy újrainicializálni anélkül, hogy ez ne okozna súlyos mértékű adatvesztést. Az MS DTC létfontosságú adatokat tartalmaz a tranzakciók végeredményével kapcsolatban. Az MS DTC naplófájlban tárolt adatok élettartama rendkívül változó: a néhány másodperccel ezelőtt létrejött adat szinte bizonyosan elavult, ezért helyreállítás céljára tulajdonképpen nem használható fel. Emiatt nincs értelme biztonsági másolatot készíteni az MS DTC naplófájlról, és azt helyreállítani.

Figyelem! Ha az MS DTC naplófájl elvész, az MS DTC naplófájl újrainicializálásának egyetlen módja a Komponensszolgáltatások felügyeleti eszközzel lehetséges a fájlnak a CD-lemezről történt bemásolása után.

Az egyetlen biztonságos megoldás az, ha az MS DTC naplófájlt egy hibabiztos lemezeszközön, például egy redundáns lemezcsoporton tárolja. Ha a naplófájl az óvintézkedések ellenére is elvész, az egyetlen lehetőség a naplófájl ismételt inicializálása. Ezzel az eljárással a rendszergazda egyértelműen biztosíthatja, hogy az alapvető tranzakciós erőforrás-kezelők konzisztenciája megmaradjon.

Az elveszett vagy megsérült MS DTC naplófájl problémájának megoldása

Ha az MS DTC naplófájl megsemmisül, akkor az egyetlen lehetőség a naplófájl Komponensszolgáltatások felügyeleti eszköz segítségével történő ismételt inicializálása. Ezzel az eljárással a rendszergazda egyértelműen biztosíthatja, hogy az alapvető tranzakciós erőforrás-kezelők konzisztenciája megmaradjon. Konzisztenciaprobléma merülhet fel akkor, ha az MS DTC naplófájl újrainicializálására sor kerül, miközben véglegesített tranzakciók bizonytalan állapotúak maradnak. Ebben az esetben a bizonytalan állapotú erőforrás-kezelő tévesen szakíthatja meg a tranzakciót, ha véletlenül helyreállítást hajt végre. Tekintse át a következő példát:

Tegyük fel, hogy egy alkalmazás két erőforrás-kezelőt frissít MS DTC tranzakcióvezérlés mellett, és véglegesíti a tranzakciót. Tételezzük fel azt is, hogy mindkét erőforrás-kezelő sikeresen végrehajtja az első fázist, azonban az egyik erőforrás-kezelő leáll, mielőtt megkapná a második fázisban esedékes véglegesítési értesítést. Ebben az esetben az első erőforrás-kezelő véglegesíti a tranzakciót, miközben a második erőforrás-kezelő bizonytalan állapotban marad a tranzakció eredményét illetően. Ha az MS DTC naplófájl elveszik, mielőtt a második erőforrás-kezelő végrehajtaná a helyreállítást, akkor a véglegesített, de bizonytalan állapotú tranzakció összes rekordja is elveszik. A második erőforrás-kezelő az újraindításakor rákérdez a bizonytalan tranzakcióra. Az MS DTC feltételezi, hogy a tranzakció megszakadt, mivel a tranzakció egyetlen rekordja sem található az újrainicializált naplófájlban. Az MS DTC tájékoztatja a második erőforrás-kezelőt, hogy a tranzakció egyetlen rekordja sem található, és ezért az erőforrás-kezelőnek a tranzakciót megszakítottnak kell tekintenie. Ez természetes velejárója annak a „Presumed Abort” (feltételezett megszakítás) bejelentkezési protokollnak, amelyekre a modern tranzakciókezelők számítanak. Ennek eredményeként az első erőforrás-kezelő véglegesíti a tranzakciót, miközben a második erőforrás-kezelő megszakítja azt.

Mi a teendő, ha az MS DTC naplófájl elveszik vagy megsérül?
  1. Az erőforrás-kezelő felügyeleti eszközeivel határozza meg, hogy az erőforrás-kezelő bizonytalan-e valamely MS DTC tranzakció eredményét illetően.
  2. Az erőforrás-kezelő felügyeleti eszközeivel kézzel kényszerítse ki a feloldatlan tranzakciók véglegesítését vagy megszakítását. Az MS DTC naplófájl nélkül sajnos nehézségekbe ütközhet a tranzakciók kimenetelének meghatározása. Az MS DTC naplófájl inicializálása és az MS DTC újraindítása előtt minden bizonytalan állapotú tranzakciót fel kell oldani. A feloldatlan, bizonytalan állapotú tranzakciók megszakadnak, ha sor kerül az MS DTC újraindítására és helyreállítására.
  3. A naplófájl újrainicializálásához kattintson a Napló ürítése gombra. Ha az adott naplófájl már létezik a meghajtóval és a könyvtárral megadott helyen, akkor a Napló ürítése gomb hatására törlődik az aktuális naplófájl.
  4. Az MS DTC újraindításához kattintson az Indítás gombra.


Tranzakcióállapot feloldása

Az elosztott tranzakciók célja a meghibásodás utáni helyreállítás megkönnyítése az elosztott alkalmazásokban – ott, ahol hiba merülhet fel az ügyfél vagy a kiszolgáló oldalán, illetve az ügyfél és a kiszolgáló között. Éppen ezért a tranzakciókezelés fontos része az olyan helyzetek megoldása, amikor a tranzakciók egy rendszerhibát követően bizonytalan állapotban maradtak.

A tranzakciók rendszerhiba után bizonytalan állapotban maradhatnak

Normális körülmények között az MS DTC rendszerek a rendszeren áthaladó valamennyi tranzakciót feloldják. Meghibásodás után azonban néhány rendszer nem képes a helyreállítás közben újra csatlakozni, így a tranzakciók bizonytalan állapotban maradnak. Más esetekben egy hibás alkalmazás okozhatja a tranzakciók elakadását és bizonytalan állapotban maradását. Ilyen alkalmakkor figyelemmel kísérheti és kézzel feloldhatja ezeket a tranzakciókat, feltéve, hogy ismeri azok aktuális állapotát. Az alábbiakból megtudhatja, hogyan oldható fel egy tranzakció állapota.

Az elosztott tranzakcióknak három olyan állapota létezik, amely elakadhat vagy bizonytalanná válhat: a Bizonytalan, a Sikertelen megszakítási értesítés és a Sikertelen végrehajtási értesítés állapot. A bizonytalan tranzakciók feloldására a Komponensszolgáltatások felügyeleti eszköz Tranzakciólista ablakát használhatja, ahol a következő parancsok közül választhat:

  • Végrehajtás – Ez a parancs kényszeríti ki a tranzakció végrehajtását.
  • Megszakítás – Ezzel a paranccsal kikényszerítheti a tranzakció megszakítását és eredeti állapotába történő visszaállítását.
  • Törlés – Törli a véglegesített vagy megszakított tranzakciót a DTC naplófájlból.

Ha tudni szeretné, hogy milyen lépéseket hajt végre a tranzakciókezelő egy bizonyos hiba után, olvassa el Az MS DTC és a számítógéphibák kezelése című részt.

Az egyes tranzakcióállapotok részletes leírását az MS DTC tranzakciók állapota című részben találja meg.

A lehetséges meghibásodásokra vonatkozó forgatókönyveket a Példa: Tranzakciófeloldás rendszerhibát követően című rész tartalmazza.

Tranzakció időtúllépése

Lehetőség van olyan időtúllépési periódus beállítására, amelyen belül a be nem fejezett tranzakciók automatikusan megszakadnak. Ezzel a módszerrel megakadályozható, hogy a hibásan megírt tranzakciós programok korlátlan ideig leköthessék a tranzakciós erőforrásokat. Az olyan rekordok például, amelyeket valamely tranzakció az adott Microsoft SQL Server adatbázisban frissít, zárolva maradnak a tranzakció idejére. Ha a tranzakciós program hurkolódik vagy holtpontra jut, a tranzakció időtúllépése megakadályozza az adatbázisrekordok hosszú ideig történő lekötését. Az alapértelmezett időtúllépés 60 másodperc. További tájékoztatásért olvassa el a Tranzakció időtúllépésének beállítása című témakört.

Az MS DTC által létrehozott üzenetek általános leírását a jelen dokumentum Eseményüzenetek című része tartalmazza.


Az MS DTC és a számítógéphibák kezelése

Ha egy számítógép meghibásodik, majd újraindul, a tranzakciókezelő az érintett számítógépen rendszerint meghatározza a bizonytalan állapotú tranzakciók eredményét. Az alábbi lista azokat a műveleteket tartalmazza, amelyeket egy tranzakciókezelő rendszerhibát követően hajt végre.

  • A tranzakciókezelő a naplófájl alapján határozza meg azoknak a tranzakcióknak az eredményeit, amelyek véglegesítési koordinátoraként működött.
  • Más rendszerektől érkező tranzakciók esetén a tranzakciókezelő a naplófájlból állapítja meg, hogy kapott-e korábban értesítést a tranzakció eredményéről.
  • A bizonytalan állapotban maradó beérkezett tranzakciók esetén a tranzakciókezelő a felső szintű tranzakciókezelőtől kérdezi le a tranzakció eredményét.
  • A tranzakciókezelő egyúttal válaszol azokra a lekérdezésekre, amelyekben saját alárendelt tranzakciókezelői kérik a hozzájuk küldött bizonytalan állapotú kimenő tranzakciók eredményét. Ez hasonló ahhoz a protokollhoz, amelyet a tranzakciókezelők és az erőforrás-kezelők az újraindításkor követnek. A tranzakciókezelő meghatározza minden bizonytalan tranzakció eredményét, majd – kérésre – tájékoztatja az erőforrás-kezelőket a tranzakció eredményéről.

Az elakadt bizonytalan állapotú tranzakciók feloldásáról a Példa: Tranzakciófeloldás rendszerhibát követően című részben olvashat.


Példa: Tranzakciófeloldás rendszerhibát követően

Amikor egy rendszer- vagy csatlakozási hiba után sor kerül a tranzakciókban résztvevő rendszerek újraindítására és a kapcsolatok helyreállítására, az MS DTC automatikusan feloldja a tranzakciókat. Az MS DTC azonban nem tudja feloldani a tranzakciókat, ha a rendszerek nem működnek, vagy ha a kapcsolatok nem álltak helyre. Ilyen esetben kézzel oldhatók fel azok a tranzakciók, amelyek Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés állapotúak.

Ezen tranzakciók feloldásáról gyakorlati információt talál a Tranzakciók feloldása kézzel című témakörben.

A következő példa olyan esetet mutat be, amelyben a hálózat két számítógépe közötti kommunikációs vonal megszakad. Egy adott tranzakció manuális véglegesítése vagy megszakítása után gyakran a számítógépet is manuálisan kell kényszeríteni a tranzakció törlésére, ami a helyi MS DTC naplófájlból is törli a tranzakciót.

A példában a következő feltételek érvényesülnek:

  • A véglegesítést az A jelű számítógép MS DTC szolgáltatása koordinálja.
  • A kétfázisú véglegesítési protokoll továbbítására szolgáló kommunikációs vonalak az A jelű számítógéptől a D jelűig haladnak.
  • A kétfázisú véglegesítési protokoll első fázisa befejeződött, a véglegesítési koordinátor döntött a tranzakció véglegesítéséről, és COMMITTED rekordot jegyzett be az A jelű számítógép MS DTC naplófájljába.
  • A kétfázisú véglegesítési protokoll második fázisában megszakadt a kommunikáció a B és a C jelű számítógép között. A C és D jelű számítógépek bizonytalan állapotban maradnak a tranzakció eredményét illetően.
  • Nehéz, vagy lehetetlen helyreállítani a kapcsolatot a B és C jelű rendszerek között.

A tranzakció a következő feloldatlan állapotban marad:

Mivel a kommunikációs vonal az A és B jelű számítógép között még sértetlen, a B jelű számítógép véglegesítette a tranzakciót. Az A jelű számítógép véglegesítette és törölte a tranzakciót, mivel a B jelű számítógép visszaigazolta a véglegesítésről szóló értesítés vételét. A B jelű számítógép véglegesítette a tranzakciót, de emlékeznie kell annak eredményére, amíg a C jelű számítógép nem értesül arról. A C jelű számítógép nem ismeri a tranzakció eredményét (azaz bizonytalan állapotú). A D jelű számítógép felkészült.

A tranzakció feloldása (ezáltal a C és D jelű számítógépek adatbázis-zárolásainak feloldása) céljából a rendszergazda kényszeríti a C jelű számítógépet a tranzakció véglegesítésére (lásd a következő ábrát).

Mivel a C és D jelű számítógép közötti kommunikációs vonal sértetlen, a C jelű gépen kényszerített véglegesítés lehetővé teszi a tranzakció véglegesítését a D jelű gépen is. Ekkor a D jelű számítógép megszünteti adatbázisának zárolását, és törli a tranzakciót. Amint a D jelű számítógép a C jelű gép felé megerősíti a tranzakció véglegesítését és törlését, a C jelű gép is törölheti a tranzakciót.

A tranzakció most már valamennyi számítógépen véglegesítve van. A B jelű számítógép nem tudja, hogy a C jelű gép véglegesítette a tranzakciót, mivel a két rendszer között továbbra sincs kapcsolat. A B jelű számítógép továbbra sem törli a tranzakciót. A tranzakció befejezéséhez a rendszergazda kényszeríti a B jelű gépet a tranzakció törlésére (lásd a következő ábrát). A kétfázisú véglegesítési protokoll végrehajtása manuálisan megtörtént, így a tranzakció befejeződött.

Megjegyzés A kétfázisú véglegesítési protokoll kimenő-bejövő rendszerű kommunikációja miatt a tranzakciók kézi feloldását ajánlatos a kommunikációs hibával szomszédos számítógépeken végrehajtani. Az előbbi példában ezért kényszerítették a véglegesítést a C (és nem a D), a törlést pedig a B (és nem az A) jelű számítógépen.

Ha a tranzakció véglegesítését választja, előbb mindig a C jelű (alárendelt) rendszeren kell kikényszeríteni a véglegesítést, és csak ezt követheti a B jelű (fölérendelt) rendszeren a törlés kikényszerítése. Ha előbb a B rendszert kényszeríti a törlésre, majd ezután helyreáll a kapcsolat a B és C rendszer között, a rendszer automatikusan megszakíthatja a tranzakciót a C rendszeren, mielőtt kikényszeríthetné a véglegesítést. Ennek pedig a tranzakció eredményének, illetve magának az erőforrás-kezelőnek az inkonzisztenciája lehet az eredménye.


MS DTC tranzakciók állapota

Amikor egy-egy tranzakcióra sor kerül, a Komponensszolgáltatások felügyeleti eszköz a velük kapcsolatos folyamatot állapotok halmazaként követi nyomon. E halmazok lehetővé teszik a tranzakciók figyelemmel kísérését, illetve azon tranzakciók feloldását, amelyek a köztes (Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés) állapotokban elakadhatnak. Ha többet szeretne tudni a tranzakciók állapotára vonatkozó információk megszerzéséről és a tranzakciók feloldásáról, olvassa el a Tranzakciók feloldása kézzel című témakört.

A tranzakció csak az alábbi betűrendes listában szereplő állapotok egyikében lehet.

Megszakítva

A tranzakció megszakadt. Az összes résztvevő értesítést kapott, vagy pillanatnyilag nem érhető el. A megszakadt tranzakciók eltávolítása azonnal megtörténik az MS DTC Tranzakciók ablakban található listából. A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Aktív

A tranzakció megkezdődött, és folyamatban van. A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Sikertelen megszakítási értesítés

A véglegesítési koordinátor minden csatlakoztatott alárendeltet értesített a tranzakció megszakításáról. A tranzakcióban azonban részt vesz egy IBM LU 6.2-es tranzakciókezelő, amellyel megszakadt a kapcsolat, így a megszakítási értesítés nem juthat el hozzá. Ha kényszeríteni szeretné az MS DTC tranzakciókezelőt a tranzakció törlésére, a jobb egérgombbal kattintson a Tranzakciólista ablakba, mutasson a Feloldás pontra, és kattintson a Törlés parancsra.

Ne kényszerítse ki kézzel az adott tranzakció törlését, amíg nem olvasta el a Tranzakciók feloldása kézzel című témakört.

Sikertelen végrehajtási értesítés

A véglegesítési koordinátor minden csatlakoztatott résztvevőt értesített a tranzakció véglegesítéséről. Néhány alárendelt azonban nem kaphat értesítést a véglegesítésről, mert pillanatnyilag nem érhetők el. Ez a tranzakcióállapot áll fenn akkor is, ha az MS DTC tranzakciókezelőnek nem Microsoft, hanem például IBM LU 6.2 vagy Tuxedo tranzakciókezelőt kell értesítenie a tranzakció véglegesítéséről, azonban ez nem lehetséges, mert a kapcsolat a másik tranzakciókezelővel megszakadt. Ha kényszeríteni szeretné az MS DTC tranzakciókezelőt a tranzakció törlésére, a jobb gombbal kattintson a Tranzakciólista ablakba, mutasson a Feloldás pontra, és kattintson a Törlés parancsra.

Ne kényszerítse ki kézzel az adott tranzakció törlését, amíg nem olvasta el a Tranzakciók feloldása kézzel című témakört.

Végrehajtott

A tranzakció végrehajtása megtörtént, minden résztvevő értesítést kapott. A végrehajtott tranzakciókat a program azonnal eltávolítja az MS DTC Tranzakciólista ablakban található elemek közül. A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Kényszerített megszakítás

A rendszergazda kikényszerítette a bizonytalan tranzakció megszakítását (lásd a Bizonytalan című bekezdést). A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Kényszerített végrehajtás

A rendszergazda kikényszerítette a bizonytalan tranzakció végrehajtását (lásd a Bizonytalan című bekezdést). A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Bizonytalan

A tranzakció elő van készítve, de az eredménye ismeretlen, mivel a véglegesítési koordinátorként működő távoli tranzakciókezelő nem érhető el. A véglegesítési koordinátor lehet egy másik rendszer MS DTC tranzakciókezelője, vagy egy nem Microsoft forrás tranzakciókezelője. Mindkét esetben az a helyzet áll fenn, hogy az MS DTC a tranzakció előkészítése után, de még a tranzakció eredményének közlése előtt elvesztette a kapcsolatot a tranzakciókezelővel. A tranzakció előkészített és Bizonytalan állapotban marad mindaddig, amíg a kommunikáció helyre nem áll a fölöttes tranzakciókezelővel. A rendszergazda a tranzakció végrehajtásának vagy megszakításának kikényszerítéséhez kattintson a jobb gombbal a Tranzakciólista ablakba, mutasson a Feloldás pontra, majd kattintson a Végrehajtás vagy a Megszakítás parancsra. Az eredmény kikényszerítése után a tranzakció Kényszerített végrehajtás vagy Kényszerített megszakítás jelölést kap.

Ne alkalmazzon manuális kényszerítést bizonytalan állapotú tranzakció esetében mindaddig, amíg nem olvasta el a Tranzakciók feloldása kézzel című témakörben foglaltakat.

Felkészült

Minden résztvevő azt jelentette, hogy a felkészülés sikerült. A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Felkészül

Az alkalmazás végelegesítést kért. A tranzakciókezelő kérte az erőforrás-kezelők és az alárendelt tranzakciókezelők felkészülését, és várja azok visszajelzését a felkészülés befejezéséről. A tranzakció kimenetelének megváltoztatása ezen a ponton nem lehetséges.

Ismeretlen
Azoknak a továbbítani próbált véglegesítéseknek a száma, amelyekre nem érkezett válasz (elvesztek), ezért nem vehetők figyelembe sem véglegesítettként, sem megszakítottként. További tájékoztatásért olvassa el a Véglegesítés átadása optimalizálás című részt.


XA tranzakciók kezelése

Az MS DTC XA-kompatibilis erőforrás-kezelőként és tranzakciókezelőként egyaránt működhet.

XA tranzakciók kezelése, ha az MS DTC XA erőforrás-kezelőként működik

Ha az MS DTC XA-kompatibilis erőforrás-kezelőként működik, lehetővé teszi, hogy a Microsoft SQL Server, a Microsoft Message Queue és más OLE Transactions-kompatibilis erőforrás-kezelők is részt vehessenek olyan tranzakciókban, amelyek vezérlését X/Open DTP XA-kompatibilis tranzakciófigyelők (például Encina, TopEnd és Tuxedo) végzik.

Az MS DTC a tranzakció tulajdonságait tartalmazó ablakban jeleníti meg a fölérendelt XA tranzakciókezelő tranzakció-azonosítóját (XID). Az XID felhasználható az MS DTC minden olyan bizonytalan állapotú tranzakciójának feloldására, amely rendelkezik fölérendelt XA tranzakciókezelővel. Az XA tranzakciókezelő felügyeleti eszköze segítségével meghatározható a tranzakció eredménye, és kikényszeríthető az alárendelt MS DTC megfelelő tranzakciójának az eredménye is. A tranzakció kézzel történő feloldása előtt meg kell kísérelni kapcsolatot teremteni az XA tranzakciókezelő és az MS DTC között.

XA tranzakciók kezelése, ha az MS DTC XA tranzakciókezelőként működik

Amennyiben az MS DTC XA-kompatibilis tranzakciókezelőként működik, lehetővé teszi Oracle, IBM DB/2, Sybase, Informix és más XA-kompatibilis erőforrás-kezelők részvételét az MS DTC által irányított tranzakciókban. Több XA-kompatibilis erőforrás-kezelőt átfogó tranzakciók adatainak megjelenítésekor az MS DTC nem tünteti fel a tranzakció XID azonosítóját. Ehelyett csupán az OLE Transactions felület tranzakcióra vonatkozó munkaegység-azonosítóját (Unit of Work, UOW) jeleníti meg. Az UOW és az XID között egy az egyhez hozzárendelés van érvényben az alábbiak szerint:

A következő példa egy struktúraként definiált XID azonosítót mutat be:

struct xid_t
{
  long formatID;            /* formátumazonosító */
  long gtrid_length;          /* az érték nem lehet hosszabb, mint 64 */
  long bqual_length;          /* az érték nem lehet hosszabb, mint 64 */
  char data[128];
}

Egy OLE Transactions felületnek megfelelő XID formatID mezője 0x00445443 karakterre, a gtrid_length mező 16 karakterre, az adatmező első 16 bájtja pedig az UOW értékének megfelelően van beállítva.

Az MS DTC-ben az XA-kompatibilis erőforrás-kezelő felügyeleti eszközével lehet megfeleltetni a tranzakciót.


IBM CICS LU 6.2 tranzakciók kezelése

Az MS DTC olyan IBM rendszerekkel vehet részt elosztott tranzakciókban, amelyek támogatják az IBM LU 6.2 protokollt. Ha a Windows rendszer és az IBM rendszer közötti kapcsolat megszakad és nem állítható helyre, a tranzakció eredménye hosszú ideig bizonytalan állapotú maradhat. Ilyen esetben az IBM rendszer választhat a tranzakció heurisztikus véglegesítése vagy megszakítása között. Ez lényegében azt jelenti, hogy az IBM rendszer nem várja meg, hogy értesítést kapjon az eredményről, hanem kitalálja azt. A tranzakció heurisztikus véglegesítése vagy megszakítása után az IBM rendszer feloldhatja a tranzakcióval kapcsolatos zárolásokat. Ezáltal más alkalmazások is hozzáférhetnek a tranzakció által frissített és zárolt rekordokhoz.

Ha a Windows rendszer és az IBM rendszer közötti kapcsolat helyreáll, az MS DTC tranzakciókezelő összehasonlítja a tranzakció tényleges eredményét az IBM rendszer heurisztikus döntésével. Ha az IBM rendszer megszakította vagy heurisztikus kevert eredménnyel jelölte meg a tranzakciót, miközben az MS DTC véglegesítette azt, az MS DTC jelentést küld az alkalmazás eseménynaplójába.

Az MS DTC akkor is jelentést küld az alkalmazás eseménynaplójába, ha az IBM rendszer tévesen szakította meg vagy jelölte meg kevert eredménnyel a tranzakciót, illetve ha az IBM rendszer megszakította vagy kevert eredménnyel jelölte meg az MS DTC által megszakított tranzakciót.


Eseményüzenetek

A tranzakciók figyelése közben az eseményüzenetekből értesülhet a tranzakció rendszerállapotáról. Az MS DTC háromféle eseményt hoz létre: hibát, figyelmeztetést és tájékoztatást. Windows 2000 és Windows NT operációs rendszereknél az MS DTC események rögzítése a Windows eseménynaplójában történik. Ezek az események a Windows 2000 eseménynaplója segítéségével tekinthetők meg. Az eseménynaplóval kapcsolatos információkat a Windows 2000 dokumentációjában találja meg. További tájékoztatást az Eseményüzenetek megtekintése című témakörben kaphat.

Windows 95 és Windows 98 rendszereken az MS DTC események rögzítése az Msdtc.txt nevű szövegfájlban történik. Ez a fájl a Windows könyvtár \COM+Logs alkönyvtárában található.

Az alábbi táblázat az eseménytípusokat ismerteti.

Eseménytípus | Leírás
Hibaesemények | Súlyos hiba történt (például megsérült a naplófájl).
Figyelmeztetési események | Szokatlan esemény történt.
Tájékoztató események | Megszokott esemény történt, ilyen például az MS DTC indítása vagy leállítása.


A Tranzakcióstatisztika ablak tartalma

Az MS DTC Tranzakcióstatisztika ablaka az alábbiakban ismertetett három információcsoportot tartalmazza.

Aktuális csoport
Statisztikai adat | Leírás
Aktív | Az éppen aktív tranzakciók száma.
Maximálisan aktív | Az MS DTC legutóbbi indítása óta az egy időben aktív legtöbb tranzakció száma.
Bizonytalan | Azoknak a tranzakcióknak a száma, amelyek állapota felől a tranzakciókezelő bizonytalan.

Összesítés csoport
Statisztikai adat | Leírás
Végrehajtott | A végrehajtott tranzakciók teljes száma. Ez a szám a kényszerített (manuálisan feloldott) végrehajtásokat nem tartalmazza.
Megszakítva | A megszakított tranzakciók teljes száma. Ez a szám a kényszerített (kézzel végrehajtott) megszakításokat nem tartalmazza.
Kényszerített végrehajtás | A kézzel végrehajtott tranzakciók teljes száma.
Kényszerített megszakítás | A kézzel megszakított tranzakciók teljes száma.
Összesen | Az összes tranzakció száma.

Az összesítési adatok az MS DTC minden indításakor nullára állnak vissza.

Válaszidők csoportja

A válaszidő a tranzakció időtartama annak kezdési időpontjától a véglegesítés időpontjáig számítva. Ez a statisztika nem tartalmazza a megszakított és a kényszerrel véglegesített vagy megszakított tranzakciókat. A válaszidők csoportja a tranzakciós válaszidők minimális, átlagos és maximális értékét mutatja (ezredmásodpercben).

Az átlagos és a legnagyobb tranzakciós válaszidőkre vonatkozó adatok az MS DTC minden indításakor nullára állnak vissza.


Az OLE, LU 6.2 és TIP tranzakciólista-nézetek értelmezése

Ha egy adott kommunikációs vonal meghibásodik, vagy ha egy hibásan elosztott tranzakciós alkalmazás bizonytalan állapotban hagy tranzakciókat, akkor szükség lehet a tranzakciólisták és tulajdonságok megtekintésére, a megjelenítendő tranzakciók meghatározására, a tranzakció időtúllépésének beállítására, illetve a tranzakciófrissítések gyakoriságának szabályozására.

Mivel a tranzakciók rendszerint valós idejűek, csak a viszonylag hosszú élettartamú tranzakciók jeleníthetők meg. Vagyis néhány esetben a tranzakciók „elakadnak”, és hosszú ideig láthatók maradnak. Sokszor előfordul, hogy a tranzakció időtúllépése letelik, és sok tranzakció végrehajtásának kényszerítésére kerül sor. Néhányszor azonban a rendszer leáll, megkísérli a helyreállítást, de nincs kapcsolata egyetlen erőforrás-kezelővel sem. Ilyenkor a helyreállítás nem lehet teljes, a tranzakció pedig Bizonytalan vagy sikertelen értesítés állapotba kerül. Ezekben az esetekben a tranzakciók feloldása előtt meg kell nézni a tranzakciólistát.

Az OLE Transactions felület tranzakciós tulajdonságai

Minden OLE-tranzakció esetében a Fölérendelt/alárendelt oszlop megadja a fölérendelt tranzakciókezelő nevét (ha van ilyen), majd ezt követik az alárendelt tranzakciókezelők és az erőforrás-kezelők nevei.

Ha a tranzakciót ez a rendszer kezdeményezte, akkor ez a tranzakciókezelő lesz a globális véglegesítési koordinátor, és nem lesz fölérendelt tranzakciókezelő. Ebben az esetben a Fölérendelt/alárendelt oszlop első bejegyzése <nincs fölérendelt> lesz. Ha a tranzakció kezdeményezője egy másik rendszer, akkor az oszlopban megjelenik a fölérendelt rendszer neve. A fejléc csak akkor látható, ha a lista tartalmaz tranzakciót.

Az alárendelt tranzakciókezelők és erőforrás-kezelők a fölérendelt tranzakciókezelő után következnek. Az egyes OLE Transactions tranzakciókezelők esetében a Fölérendelt/alárendelt oszlop az alárendelt tranzakciókezelő rendszer nevét tartalmazza. Az egyes OLE Transactions erőforrás-kezelők esetében az oszlop az erőforrás-kezelők megjelenített nevét tartalmazza. Az erőforrás-kezelő az MS DTC tranzakciókezelőhöz való első csatlakozás alkalmával adhatja meg saját megjelenített nevét. Az MS DTC ezt a nevet jeleníti meg, ha az erőforrás-kezelő megadja azt.

Ha a fölérendelt vagy az alárendelt egy OLE Transactions tranzakciókezelő vagy erőforrás-kezelő, akkor a tranzakció tulajdonságlapjának azonosítót tartalmazó oszlopa üresen marad. Ha a fölérendelt vagy az alárendelt egy LU 6.2, TIP vagy XA tranzakciókezelő, akkor az azonosítót tartalmazó oszlop a LU 6.2, TIP vagy XA tranzakció azonosítóját tartalmazza. Az LU 6.2, TIP és XA tranzakciókkal kapcsolatos további információk a következő részekben találhatók.

LU6.2 tranzakciók tulajdonságai

Az egyes IBM LU6.2 tranzakciók esetében a logikai egység (LU) pár jelenik meg a tranzakció tulajdonságlapjának Fölérendelt/alárendelt oszlopában, a munkaazonosító logikai egysége pedig a tulajdonságlap azonosítási oszlopában látható.

Az LU-pár a teljes elérési úttal megadott Microsoft SNA Server logikai egységből, és az azt követő, teljes elérési úttal megadott IBM SNA logikai egységből áll. Minden teljes elérési úttal megadott logikai egység tartalmazza a hálózat nevét, és ezt követi a logikai egység neve. Pillanatnyilag mindig a Microsoft rendszer a tranzakció koordinátora, az IBM rendszer pedig az alárendelt.

A munkaazonosító logikai egysége a teljes névvel megadott Microsoft SNA Server logikai egységből, a logikai munkaegység példányszámából, illetve a logikai munkaegység sorszámából áll. A példányszám és a sorszám hexadecimális formában van megadva. Ezek az értékek összhangba hozhatók az IBM rendszer megfelelő értékeivel.

TIP tranzakciók tulajdonságai

A TIP tranzakciókezelő címe minden TIP-tranzakció esetében a tranzakció tulajdonságlapjának Fölérendelt/alárendelt oszlopában jelenik meg, a TIP-tranzakció azonosítója pedig a tulajdonságlap azonosítási oszlopában látható.


Az elosztott tranzakciók felügyeletével kapcsolatos feladatok

Az elosztott tranzakciókkal kapcsolatos feladatok kiterjednek a rendszernek az elosztott tranzakciók támogatásához történő konfigurálására, a tranzakciók figyelésére és a teljesítmény kezelésére, valamint a rendszer meghibásodásával összefüggő problémák megoldására.

A következő hivatkozások a részletes ismertetőkhöz vezetnek:

Témakör | Leírás
Az MS DTC telepítése | Részletes útmutató különböző speciális telepítési esetekhez
Az MS DTC konfigurálása | Tudnivalók az MS DTC koordinátornak a hálózat és az alkalmazások igényeinek megfelelő konfigurálásáról
Az MS DTC kezelése | Az MS DTC naplófájl kezelésével, a tranzakciók kézi feloldásával, valamint az MS DTC távoli felügyeletével kapcsolatos és egyéb tudnivalók
Az MS DTC teljesítményének figyelése | A tranzakciók figyelésével, valamint a tranzakciók tulajdonságainak és statisztikáinak megtekintésével kapcsolatos témakörök
Az MS DTC eszközzel összefüggő problémák kezelése | A „Sikertelen besorolás” hibaüzenetek megjelenése esetén elvégzendő hibakereső lépések
Az MS DTC eszközzel kapcsolatos tanácsadás | Azon adatok felsorolása, amelyeket célszerű megadni, ha az MS DTC alkalmazással kapcsolatban a Microsoft technikai tanácsadáshoz fordul


Az MS DTC telepítése

A Windows 2000 telepítésekor az MS DTC telepítése automatikusan megtörténik. Egyes telepítési helyzetek azonban szükségessé teszik bizonyos speciális tényezők figyelembevételét, ha a rendszeren az MS DTC használatára kerül sor.

A következő hivatkozások a részletes ismertetőkhöz vezetnek:

  • A tranzakciók feloldása a Windows 2000 rendszerre történő frissítés előtt
  • Az MS DTC konfigurálása Windows 2000 fürtön
  • Az MS DTC újratelepítése

Bár az MS DTC a Windows 2000 egyik komponense, és annak telepítésekor az MS DTC telepítése és konfigurálása automatikusan megtörténik, a Windows 2000 operációs rendszerben az MS DTC három fontos fejlesztéssel rendelkezik, amelyeket érdemes figyelembe venni a telepítés során. E fejlesztések a következők:

  • Az MS DTC az XA szabvánnyal összefüggő visszaállítási információkat a DTCXATM.log fájl helyett az MS DTC naplófájlban tárolja – az előbbi megszűnt.
  • A Windows 95 vagy a Windows 98 rendszer Windows 2000 rendszerre történő frissítése után az MS DTC új naplófájlt használ.
  • Az MS DTC hálózati üzenetprotokollja bővült. Ez a meglévő Windows 95, Windows 98 és Windows NT rendszereken megkönnyíti az együttműködést az MS DTC eszközzel.


A tranzakciók feloldása a Windows 2000 rendszerre történő frissítés előtt

Ha Windows 95 vagy Windows 98 rendszeren Microsoft Transaction Server (MTS) vagy Microsoft SQL Server 7.0 programot használ, és a rendszert Windows 2000 rendszerre szeretné frissíteni, előtte feltétlenül tegye meg a következő óvintézkedéseket. Ez azért fontos, mert a Windows 2000 rendszerre történő frissítés után az MS DTC új naplófájlt használ, így a frissítést követően minden fel nem oldott tranzakció elvész.

XA-tranzakciók feloldása

Ha Windows 95, Windows 98 vagy Windows NT rendszeren Microsoft Transaction Server (MTS) alkalmazást használ, és elosztott tranzakciókezelés során az MTS frissítette az Oracle, az IBM DB2, az Informix, az Ingres vagy a Sybase adatbázisát, feltétlenül hajtsa végre a következő óvintézkedéseket a Windows 2000 telepítése előtt. Ez azért fontos, mert az MS DTC az XA szabvánnyal összefüggő visszaállítási információk tárolására új módszert használ. Az MS DTC ezeket az adatokat korábban egy külön DTCXATM.log fájlban tárolta. Windows 2000 rendszeren az XA szabvánnyal összefüggő visszaállítási információk (csakúgy mint a többi, MS DTC visszaállítási információ) tárolása az MS DTC naplófájljában történik. A DTCXATM.log fájl megszűnt.

A Windows 2000 telepítése előtt biztosítania kell, hogy az MS DTC ne rendelkezzen bizonytalan, visszaállítást igénylő XA-tranzakcióval.

Hogyan ellenőrizhető, hogy az MS DTC nem rendelkezik-e bizonytalan, visszaállítást igénylő XA-tranzakcióval?
  1. A frissítés előtt indítsa el az MTS Explorer programot, és a Tranzakciólista ablakban ellenőrizze, hogy nincs-e bizonytalan tranzakció a rendszeren (a tranzakciók megtekintéséhez kövesse A tranzakciókkal kapcsolatos adatok megtekintése című témakörben szereplő lépéseket). Ez, és a 2. lépés azt biztosítja, hogy ne legyenek feloldatlan MS DTC tranzakciók, amelyek befolyásolhatnák az Oracle, az IBM DB2, az Informix, a CA Ingres vagy a Sybase adatbázisát.

    Feloldatlan tranzakciók a következő állapotok egyikében lehetnek: Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés.

  2. Az Oracle, az IBM DB2, az Informix, a CA Ingres vagy a Sybase adatbázis felügyeleti eszközeivel biztosítsa, hogy ne legyenek bizonytalan adatbázis-tranzakciók.
  3. Ha vannak bizonytalan tranzakciók, el kell indítania az MS DTC programot és az adatbázist, így lehetővé válik a tranzakciók automatikus visszaállítása. Ha az MS DTC programtól származó bizonytalan tranzakciók megmaradnak, feloldásukra használja az Oracle, az IBM DB2, az Informix, a CA Ingres vagy a Sybase adatbázisának felügyeleti eszközeit.

Az MS DTC tranzakciók feloldása

Mielőtt elvégezné a Windows 2000 rendszerre történő frissítést, biztosítania kell, hogy ne legyenek feloldatlan MS DTC tranzakciók a frissítendő Windows 95 vagy Windows 98 rendszeren.

Hogyan ellenőrizhető, hogy nincsenek-e feloldatlan MS DTC tranzakciók a rendszeren?
  1. A frissítés előtt indítsa el az MTS Explorer programot, és a Tranzakciólista ablakban ellenőrizze, hogy nincs-e bizonytalan tranzakció a rendszeren (a tranzakciók megtekintéséhez kövesse A tranzakciókkal kapcsolatos adatok megtekintése című témakörben szereplő lépéseket). Ez, és a 2. lépés azt biztosítja, hogy ne legyenek feloldatlan MS DTC tranzakciók, amelyek befolyásolhatnák az Oracle, az IBM DB2, az Informix, a Ingres vagy a Sybase adatbázisát.

    Feloldatlan tranzakciók a következő állapotok egyikében lehetnek: Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés.

  2. Ha feloldatlan tranzakciók vannak a rendszeren, a jelen dokumentum Tranzakciók feloldása kézzel című részében ismertetett módon fel kell oldania azokat.


Az MS DTC konfigurálása Windows 2000 fürtön

A Windows 2000 telepítésekor az MS DTC tranzakciókezelő, az MS DTC Proxy és a Komponensszolgáltatások felügyeleti eszköz telepítése a Windows 2000 fürt mindegyik csomópontjára megtörténik.

A fürtszolgáltatás Windows 2000 környezetben történő telepítése és konfigurálása során az MS DTC automatikusan megkísérli önmagát magas elérhetőségű szolgáltatásként konfigurálni. Ennek az az oka, hogy a fürtszolgáltatás működése alatt az MS DTC csak magas elérhetőségű szolgáltatásként futhat.

Windows NT 4.0 rendszeren lévő fürt Windows 2000 fürtre történő frissítése előtt biztosítania kell, hogy a fürtkonfiguráció tartalmazzon legalább egy erőforráscsoportot, amely rendelkezik Hálózati név, IP-cím és Fizikai lemez erőforrással. Ennek elmulasztása esetén az MS DTC automatikus konfigurációja nem sikerül.

Ha a Windows 2000 rendszerre történő frissítés után a fenti helyzet áll elő
  1. Konfiguráljon egy Hálózati név, egy IP-cím és egy Fizikai lemez erőforrást tartalmazó erőforráscsoportot.
  2. A fürt mindegyik csomópontján indítsa el a COM fürtvarázsló (Comclust.exe) programot.

Érdemes megjegyezni, hogy az MS DTC nem ad lehetőséget arra, hogy meglévő fürtről Windows 2000 rendszert távolítson el. Azt is érdemes megjegyezni, hogy ha a számítógépeket az MS DTC segítségével frissíti Windows 2000 rendszeren történő fürtözéshez, a frissített számítógépeken előzőleg már Service Pack 4.0 csomaggal ellátott Windows NT 4.0 rendszernek kell futnia.


Az MS DTC újratelepítése

Az SQL Server 6.5-ös verziójának vagy az SQL Server 6.5 szervizcsomaggal ellátott verziójának minden egyes telepítését követően újra kell telepítenie az MS DTC programot. Erre azért van szükség, mert az SQL Server telepítőprogramja az MS DTC olyan elavult verzióját telepíti, amely nem kompatibilis a Windows 2000 rendszeren futó Komponensszolgáltatásokkal.

Az MS DTC újratelepítése Windows 2000 rendszerre
  1. Győződjön meg arról, hogy az MS DTC nem fut. Győződjön meg arról is, hogy az MS DTC programon alapuló szolgáltatások (például a Komponensszolgáltatások, a Microsoft SQL Server, a Message Queuing vagy a Microsoft COMTI) sem futnak.
  2. Indítsa el a System32 könyvtárban található DTCSetup.exe programot.
  3. Indítsa újra az MS DTC programon alapuló szolgáltatásokat.

Az MS DTC újratelepítése Windows 2000 kiszolgálófürtre
  1. Győződjön meg arról, hogy az MS DTC fürterőforrás már nem használja a Fürtfelügyelőt. Győződjön meg arról is, hogy az MS DTC programon alapuló szolgáltatások (például a Komponensszolgáltatások, a Microsoft SQL Server, a Message Queuing vagy a Microsoft COMTI) sem futnak.
  2. Indítsa el a <%Windows_könyvtár%>\System32 könyvtárban található DTCSetup.exe programot a fürt minden csomópontján. Addig ne töltse be újra a rendszereket, amíg a fürtben lévő összes rendszeren az MS DTC telepítőprogramjának futása sikeresen be nem fejeződött. Ezt követően minden rendszert újra kell indítani.
  3. Indítsa újra az MS DTC programon alapuló szolgáltatásokat.


Az MS DTC konfigurálása

Az elosztott tranzakciók támogatása érdekében előfordulhat, hogy kézi vagy automatikus működéshez konfigurálni kell az MS DTC programot, a Windows fürtözéshez konfigurálni kell a hálózatot, meg kell változtatni azt a felhasználóazonosítót, amely alatt az MS DTC fut, felügyelni kell az MS DTC távoli működését, és ellenőrizni kell (vagy ki kell javítani) a számítógépek közötti kommunikációt.

A következő hivatkozások a részletes ismertetőkhöz vezetnek:

  • Az MS DTC konfigurálása
  • Az Alapértelmezett koordinátor konfigurálása
  • Ügyfél hálózati protokolljának konfigurálása
  • Az MS DTC naplófájl konfigurálása
  • Az MS DTC konfigurálása tűzfalon keresztül történő működéshez
  • Tranzakció időtúllépésének beállítása


Az MS DTC konfigurálása

Beállíthatja azt is, hogy az MS DTC a számítógép indulásakor automatikusan induljon-e. Szabályozható továbbá az a bejelentkezési azonosító, amely alatt az MS DTC fut.

Ha a Komponensszolgáltatásokat fürtözött környezetben használja, olvassa el Az MS DTC indítása és leállítása című témakört, amelyben ismertető található az MS DTC Windows 2000 fürtben történő indításáról és leállításáról.

Az MS DTC indítási típusának konfigurálása

Az MS DTC szolgáltatást az előtt kell elindítani, hogy az alkalmazások és az erőforráskezelők MS DTC tranzakciókban vennének részt. Az MS DTC indítására az alábbi három lehetőség kínálkozik:

  • Az MS DTC indítása és leállítás kézzel (csak szükség esetén)
  • Az MS DTC konfigurálása oly módon, hogy a Windows 2000 rendszerrel együtt induljon

Ha a rendszeren lévő alkalmazások és erőforráskezelők soha nem vesznek részt elosztott tranzakciókban, nincs szükség az MS DTC indítására. Ebben az esetben az MS DTC letiltható, így egyéb célokra memória szabadítható fel.

A Windows 2000 Professional rendszeren az MS DTC alapértelmezés szerint kézzel indítható. A Windows 2000 kiszolgálóverzióin az MS DTC alapértelmezés szerint automatikusan indul.

Az MS DTC konfigurálása kézi vagy automatikus indításhoz a Számítógép-kezelés segítségével
  1. A Start menüben mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Számítógép-kezelés parancsra.
  2. A Számítógép-kezelés (Helyi) ablak konzolfáján kattintson duplán a Szolgáltatások és kiszolgálói alkalmazások, majd a Szolgáltatások elemre.
  3. A részleteket megjelenítő ablaktáblában kattintson duplán az Elosztott tranzakciók koordinátora szolgáltatásra.
  4. Az Elosztott tranzakciók koordinátora – Tulajdonságok (Helyi számítógép) párbeszédpanel Általános lapján az Indítási típus listából válassza az Automatikus vagy a Kézi lehetőséget.
  5. Kattintson az OK gombra.

Az MS DTC konfigurálása kézi vagy automatikus indításhoz a Komponensszolgáltatások segítségével
  1. A Start menüben mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Komponensszolgáltatások parancsra.
  2. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson duplán a Szolgáltatások elemre.
  3. A részleteket megjelenítő ablaktáblában kattintson duplán az Elosztott tranzakciók koordinátora szolgáltatásra.
  4. Az Elosztott tranzakciók koordinátora – Tulajdonságok (Helyi számítógép) párbeszédpanel Általános lapján az Indítási típus listából válassza az Automatikus vagy a Kézi lehetőséget.
  5. Kattintson az OK gombra.

Ez a módosítás nem indítja el és nem állítja le az MS DTC szolgáltatást. Az MS DTC kézzel történő elindításával és leállításával kapcsolatban Az MS DTC indítása és leállítása című témakör nyújt ismertetőt.

Az MS DTC bejelentkezési azonosítójának konfigurálása

Windows 2000 környezetben az MS DTC úgy van konfigurálva, hogy alapértelmezés szerint a Rendszer fiók azonosítója alatt fut. Az MS DTC beállítható úgy is, hogy más bejelentkezési azonosító alatt fusson. Olyan bejelentkezési azonosítót kell megadni, amely a rendszerben felügyeleti jogosultságokkal rendelkezik.

Ha a beépített biztonsági szolgáltatásokra támaszkodó Oracle XA-erőforráskezelőt használ, az MS DTC szolgáltatást úgy kell konfigurálnia, hogy olyan bejelentkezési azonosító és jelszó alatt fusson, amelynek jogosultsága van ezen XA-erőforráskezelőhöz való csatlakozásra. Erre azért van szükség, mert a visszaállítás során az MS DTC az XA-erőforráskezelőhöz csatlakozik, hogy tájékoztassa a bizonytalan tranzakciók kimeneteléről. Ilyen XA-erőforráskezelő például az Oracle, az IBM DB/2, az Informix, a Sybase vagy a CA Ingres adatbázisa.

Az MS DTC bejelentkezési azonosítójának módosítása a Komponensszolgáltatások segítségével
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson a Szolgáltatások (helyi) elemre.
  2. A részleteket megjelenítő ablaktáblában kattintson duplán az Elosztott tranzakciók koordinátora szolgáltatásra.
  3. Az Általános lapon a Szolgáltatásállapot csoportban kattintson a Leállítás gombra.
  4. A Bejelentkezés lapon jelölje be az Ez a fiók választógombot, majd a mezőkbe írja be a felhasználónevet és a jelszót.
  5. Az MS DTC indításához az Általános lapon a Szolgáltatásállapot csoportban kattintson az Indítás gombra.
  6. Kattintson az OK gombra.

Az új bejelentkezési azonosító az MS DTC újraindításakor lép érvénybe.

Az MS DTC bejelentkezési azonosítójának módosítása a Számítógép-kezelés segítségével
  1. A Számítógép-kezelés (Helyi) konzolfán kattintson duplán a Szolgáltatások és kiszolgálói alkalmazások, majd a Szolgáltatások elemre.
  2. A részleteket megjelenítő ablaktáblában kattintson duplán az Elosztott tranzakciók koordinátora szolgáltatásra.
  3. Az Általános lapon a Szolgáltatásállapot csoportban kattintson a Leállítás gombra.
  4. A Bejelentkezés lapon jelölje be az Ez az fiók választógombot, majd adja meg a felhasználónevet és a jelszót.
  5. Az MS DTC indításához az Általános lapon a Szolgáltatásállapot csoportban kattintson az Indítás gombra.
  6. Kattintson az OK gombra.

Az új bejelentkezési azonosító az MS DTC újraindításakor lép érvénybe.


Az Alapértelmezett koordinátor konfigurálása

Alapértelmezés szerint minden rendszer a helyi MS DTC tranzakciókezelőt használja a tranzakciók kezdeményezésére és összehangolására. A számítógép azonban úgy is beállítható, hogy a tranzakciók alapértelmezett koordinátoraként egy másik rendszer MS DTC tranzakciókezelőjét használja. Valahányszor a helyi rendszeren lévő ügyfél MS DTC tranzakciót kezdeményez, a program a tranzakciók koordinátoraként a megadott számítógépen lévő MS DTC tranzakciókezelőt használja, ha az ügyfél nem ad meg kifejezetten egy másik tranzakciókoordinátort. A tranzakciók alapértelmezett koordinátora összehangolja a Komponensszolgáltatások által kezdeményezett tranzakciókat. Ezen kívül minden olyan, a helyi rendszeren lévő erőforráskezelő tranzakciókoordinátoraként is szolgál, amely MS DTC tranzakciókban vesz részt.

Az alapértelmezett koordinátorként választott rendszernek megbízhatónak kell lennie. Az ehhez a koordinátorhoz rendelt hálózati csatlakozásnak szintén megbízhatónak kell lennie. Ha nem ilyen, az alapértelmezett koordinátor csökkentheti az MS DTC elérhetőségét a helyi rendszeren. Alapértelmezett koordinátorként jó megoldás egy fürtszolgáltatást futtatató Windows 2000 fürt. Ha fürtszolgáltatást futtató Windows 2000 fürtöt alapértelmezett koordinátorként konfigurál, a fürtön lévő bármely virtuális kiszolgáló neve megadható.

A tranzakciók alapértelmezett koordinátorának konfigurálásához felügyeleti jogosultságokkal kell rendelkeznie mind a helyi rendszeren, mind pedig azon a rendszeren, amelyet alapértelmezett koordinátorként kíván kijelölni. Ez teszi lehetővé a helyi MS DTC rendszer számára, hogy a tranzakciók alapértelmezett koordinátoraként működő rendszer rendszerleíró adatbázisából lekérje a megfelelő adatokat.

Távoli rendszer alapértelmezett tranzakciókoordinátorrá történő kijelölése
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson az MS DTC szolgáltatást tartalmazó számítógépre, majd kattintson a Tulajdonságok parancsra.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre.
  3. Törölje a jelet a Helyi koordinátor használata jelölőnégyzetből.
  4. A Távoli gazdaszámítógép mezőbe írja be a távoli rendszer nevét.

    Egy másik lehetőség az, ha a Kijelölés gombra kattint, és miután megjelent a hálózat összes számítógépét tartalmazó lista, kijelöli a kívánt számítógépet.

  5. Kattintson az OK gombra.

A helyi rendszer alapértelmezett tranzakciókoordinátorrá történő kijelölése
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson az MS DTC szolgáltatást tartalmazó számítógépre, majd kattintson a Tulajdonságok parancsra.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre.
  3. Jelölje be a Helyi koordinátor használata jelölőnégyzetet.
  4. Kattintson az OK gombra.


Ügyfél hálózati protokolljának konfigurálása

Ha úgy állítja be az MS DTC szolgáltatást, hogy távoli MS DTC tranzakciókoordinátorra támaszkodjon, megadhatja, hogy az MS DTC Proxy a távoli rendszeren lévő tranzakciókoordinátorral való kommunikációhoz milyen RPC-átvitelt használjon. TCP/IP, SPX és NetBEUI protokollok közül választhat. Mivel a TCP/IP a legszélesebb körben támogatott protokoll, ezért ez az MS DTC alapértelmezett és ajánlott protokollja.

Ügyfél hálózati protokolljának konfigurálása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson az MS DTC szolgáltatást tartalmazó számítógépre, majd kattintson a Tulajdonságok parancsra.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre.
  3. Az Ügyfél hálózati protokolljának konfigurációja legördülő listából válassza a TCP/IP, az SPX vagy a NetBEUI lehetőséget.
  4. Kattintson az OK gombra.

Az ügyfél hálózati protokolljának új beállítása azonnal érvénybe lép. A módosítás elvégzése előtt futó tranzakciós alkalmazásokat és erőforrás-kezelőket a változás nem érinti. A módosítás után indított tranzakciós alkalmazások és erőforráskezelők már az ügyfél új hálózati protokollját használják.


Az MS DTC naplófájl konfigurálása

Beállíthatja az MS DTC naplófájl helyét és méretét is. Az MS DTC naplófájl helye hatással lehet a rendszer teljesítményére és megbízhatóságára. A naplófájl mérete azt határozza meg, hogy az MS DTC egyidejűleg hány tranzakciót támogathat.

Vigyázat! Ha módosítja a naplófájl méretét, akkor az aktuális naplófájl törlődik, és egy új naplófájl jön létre. Az MS DTC naplófájl módosítása előtt ellenőrizze, hogy az aktuális naplófájl biztonságosan törölhető-e, azaz győződjön meg arról, hogy egyetlen tranzakció sincs Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés állapotban. További információ a Tranzakciók feloldása kézzel című témakörben olvasható.

A naplófájl méretének és helyének módosítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson az MS DTC naplófájlt tartalmazó számítógépre, majd kattintson a Tulajdonságok parancsra.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre.
  3. Az MS DTC leállításához a Szolgáltatásvezérlő állapota (MS DTC) csoportban kattintson a Leállítás gombra.

    Ha nem állítja le az MS DTC szolgáltatást, a naplófájl ürítésére tett kísérletkor egy MS DTC konzolüzenet jelenik meg, amely közli, hogy a kívánt művelet nem hajtható végre.

  4. A naplófájl helyének módosításához a Naplóadatok csoport Hely mezőjébe írja be a naplófájl új elérési útját a meghajtó betűjelével együtt.

    Egy másik lehetőség az, ha a Tallózás gombra kattint, és kijelöli a naplófájl új helyét.

  5. A naplófájl méretének módosításához a Naplóadatok csoport Kapacitás mezőjébe írja be a naplófájl új méretét megabájtban.

    Windows 2000 környezetben a naplófájl mérete 1 és 512 megabájt közötti lehet. Windows 95 és Windows 98 rendszereken a naplófájl mérete 1-től 64 megabájtig terjedhet.

  6. Az MS DTC naplófájl helyének és méretének módosításához kattintson a Napló ürítése gombra.
  7. Az MS DTC leállításához a Szolgáltatásvezérlő állapota (MS DTC) csoportban kattintson az Indítás gombra.
  8. Kattintson az OK gombra.


Az MS DTC konfigurálása tűzfalon keresztül történő működéshez

Az MS DTC beállítható tűzfalon (például hálózati címfordítási tűzfalon) keresztül történő kommunikációhoz.

Az MS DTC az RPC dinamikus portlefoglalását alkalmazza. Alapértelmezés szerint az RPC dinamikus portlefoglalás véletlenszerűen választ az 1024 feletti portszámok közül. A rendszerleíró adatbázis módosításával szabályozható, hogy az RPC mely portokat foglalja le dinamikusan a befelé irányuló kommunikációnak. A tűzfal beállítható úgy, hogy a befelé irányuló külső kommunikációhoz csak ezeket és a 135-ös portot (az RPC végpont-hozzárendelési portját) használja.

Az MS DTC számára biztosítani kell egy beérkező dinamikus portot. Előfordulhat, hogy az RPC szabványra támaszkodó más alrendszereknek további, a befelé irányuló adattovábbítást szolgáló dinamikus portokat is biztosítani kell.

A rendszerleíró adatbázis itt bemutatott kulcsai és értékei alapértelmezés szerint nem jelennek meg a rendszerleíró adatbázisban, azokat a Rendszerleíróadatbázis-szerkesztővel kell hozzáadni.

Az RPC dinamikus portlefoglalásának szabályzása
  1. A Rendszerleíróadatbázis-szerkesztő indításához a Start menüben kattintson a Futtatás parancsra, a Megnyitás mezőbe írja be a regedt32 karaktereket, majd kattintson az OK gombra

    A Regedit.exe helyett a Regedt32.exe programot kell használnia, mert a Regedit nem támogatja a Ports értékének megadásához szükséges REG_MULTI_SZ adattípust.

  2. A Rendszerleíróadatbázis-szerkesztő ablakban nyissa ki a HKEY_LOCAL_MACHINE a sajátgépen ablakot.
  3. Bontsa ki a fát, azaz kattintson duplán a következő elérési úton lévő mappákra:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc

  4. Kattintson az Rpc mappára, majd a Szerkesztés menüben a Kulcs hozzáadása parancsra.
  5. A Kulcs hozzáadása párbeszédpanelen a Kulcsnév mezőbe írja be az Internet karaktereket, majd kattintson az OK gombra.
  6. Kattintson az Internet mappára, majd a Szerkesztés menüben az Azonosító hozzáadása parancsra.
  7. Az Azonosító hozzáadása párbeszédpanelen az Azonosítónév mezőbe írja be a Ports karaktereket.
  8. Az Adattípus legördülő listából válassza a REG_MULTI_SZ lehetőséget, majd kattintson az OK gombra.
  9. A Karakterláncszerkesztő párbeszédpanel Érték mezőjében adja meg azon portot vagy portokat, amelyet vagy amelyeket az RPC számára a dinamikus portlefoglaláshoz fenn kíván tartani, majd kattintson az OK gombra.

    Az egyes karakterláncértékek vagy egyetlen portot vagy egy portokat magába foglaló tartományt adnak meg. Az 1025-ös port megnyitásához például adja meg az „1025” értéket. Az 1025-től 1030-ig terjedő portok megnyitásához adja meg az „1025-1035” értéket. Több portot vagy porttartományt is megadhat, ha ezeket külön sorba írja. Minden portnak a 0-tól 65535-ig terjedő tartományba kell esnie. Ha egy port e tartományon kívül esik, vagy ha valamelyik karakterlánc érvénytelen, az RPC az egész konfigurációt érvénytelennek tekinti.

  10. Kövesse a 6-9. lépésekben leírtakat, és az Internet kulcshoz adjon egy újabb kulcsot a következő értékekkel:

    Érték: PortsInternetAvailable

    Adattípus: REG_SZ

    Érték: Y

    Az értékek azt jelentik, hogy a Ports érték alatt felsorolt portok elérik az Internetet.

  11. Kövesse a 6-9. lépésekben leírtakat, és az Internet kulcshoz adjon egy újabb kulcsot a következő értékekkel:

    Érték: UseInternetPorts

    Adattípus: REG_SZ

    Érték: Y

    Ez azt jelenti, hogy az RPC az Internetportok között felsorolt portokat foglalja le dinamikusan.

  12. Állítsa be a tűzfalat úgy, hogy az lehetővé tegye a hozzáférést a megadott dinamikus portokon, továbbá a 135-ös porton (az RPC végpont-hozzárendelési portján).
  13. Indítsa újra a rendszert. Indulásakor az RPC a rendszerleíró adatbázisban megadott értékeket alapul véve foglalja le dinamikusan a beérkező portokat.

    Az 1025-től 1030-ig terjedő tartományban lévő portok megnyitásához például hozza létre a következő értékeket:

    Ports : REG_MULTI-SZ : 1025-1030

    PortsInternetAvailable : REG_SZ : Y

    UseInternetPorts : REG_SZ : Y

Ha többet szeretne tudni a DCOM és az RPC tűzfalakkal történő használatáról, olvassa el Michael Nelson „Using Distributed COM with Firewalls” című kitűnő munkáját. A dokumentum a http://www.microsoft.com/com/wpaper/dcomfw.asp webhelyen tekinthető meg.


Tranzakció időtúllépésének beállítása

Az MS DTC nem teszi lehetővé a tranzakció alapértelmezett időtúllépésének konfigurálását. A tranzakció időtúllépését az alkalmazás (például a Komponensszolgáltatások) állítja be a tranzakció kezdetén.


Az MS DTC kezelése

Az MS DTC olyan eszközökkel rendelkezik, amelyek segítségével a tranzakciók a hibák elhárítása és a teljesítmény optimalizálása érdekében figyelhetők és kezelhetők.

A következő hivatkozások a részletes ismertetőkhöz vezetnek:

  • Az MS DTC indítása és leállítása
  • A tranzakciókkal kapcsolatos adatok megtekintése
  • Tranzakciók feloldása kézzel
  • Az MS DTC naplófájl ürítése


Az MS DTC indítása és leállítása

Az MS DTC két szolgáltatástípust biztosít: „nélkülözhetetlen szolgáltatásokat” és „választható szolgáltatásokat”. Az MS DTC nélkülözhetetlen szolgáltatásai a Windows 2000 rendszer működése szempontjából létfontosságúak. Az MS DTC nem indítható, ha valamelyik nélkülözhetetlen MS DTC szolgáltatás nem indul el. A többi MS DTC szolgáltatás „választható”. Amikor az MS DTC elindul, kísérletet tesz a választható MS DTC szolgáltatások elindítására. Ha ezek a szolgáltatások elindulnak, akkor elérhetővé válnak az MS DTC ügyfelei számára. Ha egy adott választható szolgáltatás nem indul el, akkor a szolgáltatás használatára tett minden kísérlet hibaüzenet kíséretében elutasításra kerül. A szolgáltatások nélkülözhetetlen és választható szolgáltatásokra való felosztása növeli a rendszer általános elérhetőségét. Az MS DTC leállítható és újraindítható ezen választható szolgáltatások újraindításához.

A következő MS DTC szolgáltatások választhatók:

  • Transaction Internet Protocol (TIP)
  • XA-kompatibilis erőforráskezelők (például Oracle, IBM DB2, Informix, Sybase és CA Ingres) támogatása

Az MS DTC a következő eszközökből indítható és állítható le:

  • Komponensszolgáltatások felügyeleti eszköz
  • Parancssor
  • Számítógép-kezelés
  • Fürtfelügyelő

Az MS DTC indítására és leállítására használható ezen eszközök között a végeredmény szempontjából nincs különbség. Válassza a legkényelmesebb módszert.

Vigyázat! Ha az MS DTC nem indul el, tekintse meg a Windows Eseménynaplóját, ahol ellenőrizheti, hogy történtek-e az MS DTC szolgáltatással összefüggő események a meghibásodás ideje körül. Az MS DTC általában naplózza az eseményt, ha indítása sikertelen. További információt az Eseményüzenetek megtekintése című részben talál.

Az MS DTC indítása és leállítása Windows 2000 környezetben vagy kiszolgálófürtön a Komponensszolgáltatások felügyeleti eszköz segítségével
  • A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a számítógépre, amelynek tranzakcióit kezelni szeretné, majd kattintson az MS DTC indítása vagy az MS DTC leállítása parancsra.

Megjegyzés Az MS DTC szolgáltatásnak futnia kell ahhoz, hogy a Komponensszolgáltatások felügyeleti eszköz segítségével a beállítások módosítását véglegesíteni lehessen. Ha előzőleg leállította az MS DTC szolgáltatást, majd a Komponensszolgáltatások felügyeleti eszközzel módosítani próbál valamilyen beállítást, az MS DTC újraindul. Ha a Komponensszolgáltatások használatának kezdetekor hibaüzenet jelenik meg, ellenőrizze, hogy elindult-e az MS DTC, ha nem, indítsa el.

Az MS DTC indítása és leállítása Windows 2000 környezetben a Számítógép-kezelő segítségével

Az itt ismertetett eljárás fürtök esetében nem alkalmazható.

  1. A Start menüben mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Számítógép-kezelés parancsra.
  2. A Számítógép-kezelés (Helyi) konzolfán kattintson duplán a Szolgáltatások és kiszolgálói alkalmazások, majd a Szolgáltatások elemre.
  3. A részleteket megjelenítő ablaktáblában az egér jobb gombjával kattintson az Elosztott tranzakciók koordinátora elemre, majd kattintson az Indítás vagy a Leállítás parancsra.

Az MS DTC indítása és leállítása a parancssorból Windows 2000 környezetben vagy Windows 2000 fürtön
  • A parancssorba írja be az „msdtc -start” vagy az „msdtc -stop” karaktersorozatot.

Az MS DTC indítása és leállítása Windows 2000 fürtön a Fürtfelügyelő segítségével

A következő eljárás nem alkalmazható olyan Windows 2000 rendszeren, amely nem része fürtnek.

  1. Indítsa el a Fürtfelügyelő programot.
  2. Az egér jobb gombjával kattintson az MS DTC erőforrásra, majd kattintson a Bring Online vagy a Take Offline parancsra.

MS DTC átvétel Windows 2000 fürtözött rendszeren

A Fürtfelügyelő segítségével elérhető, hogy az MS DTC tranzakciókezelő az egyik fürtcsomópontról a másikra váltson.

Fürtön lévő MS DTC átvétele a Fürtfelügyelő segítségével
  1. Indítsa el a Fürtfelügyelő programot.
  2. Az egér jobb gombjával kattintson az MS DTC erőforrást tartalmazó MS DTC erőforráscsoportra, majd kattintson a Move Group parancsra.

A Move Group parancs azonnal végrehajtódik. Az MS DTC tranzakciókezelő az aktuális csomóponton azonnal leáll, míg a másik csomóponton elindul. Újraindulása után az MS DTC visszaállítási műveletet hajt végre. A visszaállítás során az MS DTC minden olyan tranzakciót leállít, amely az átvételkor aktív állapotban volt, és minden bizonytalan tranzakciót a megfelelő módon véglegesít vagy leállít. A tranzakciók feloldásáról a Tranzakciók feloldása kézzel című témakörben tájékozódhat.


A tranzakciókkal kapcsolatos adatok megtekintése

Ha egy adott kommunikációs vonal meghibásodik, vagy ha egy hibásan elosztott tranzakciós alkalmazás bizonytalan állapotban hagy tranzakciókat, akkor szükség lehet a tranzakciólisták és tulajdonságok megtekintésére, a megjelenítendő tranzakciók meghatározására, a tranzakció időtúllépésének beállítására, illetve a tranzakciófrissítések gyakoriságának szabályozására.

A rendszergazda érdeklődésére általában csak az olyan tranzakciók megtekintése tarthat számot, amelyek kézi beavatkozást igényelnek. Ezek a Sikertelen megszakítási értesítés, a Sikertelen végrehajtási értesítés és a Bizonytalan állapotú tranzakciókat ölelik fel.

Ezen feladatok végrehajtását követően előfordulhat, hogy meg szeretné tekinteni az MS DTC teljesítményét (további információt Az MS DTC teljesítményének figyelése című témakörben talál).

A nézetekről bővebb tájékoztatást olvashat Az OLE, LU 6.2 és TIP tranzakciólista-nézetek értelmezése című témakörben.

A tranzakciólista megtekintése
  • A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson duplán arra a számítógépre, amelynek tranzakciólistáját meg szeretné tekinteni. Kattintson duplán az Elosztott tranzakciók koordinátora elemre, majd kattintson a Tranzakciólista elemre.

    E nézetben megtekintheti a tranzakciókat, azok állapotát és azonosítóját. A tranzakciók állapotára vonatkozó leírások az MS DTC tranzakciók állapota című témakörben találhatók. A tranzakciók feloldásáról a Tranzakciók feloldása kézzel című témakörben olvashat.

A tranzakciólista megjelenésének módosítása
  • Az egér jobb gombjával kattintson a részleteket megjelenítő ablaktáblára, mutasson a Nézet pontra, ahol kattintással a következők közül választhat:
Parancs | Eredmény
Nagy ikonok | A tranzakciók mint nagy ikonok jelennek meg.
Kis ikonok | A tranzakciók kis ikonokként jelennek meg.
Lista | A tranzakciókat egymás után, egy oszlopban jeleníti meg.
Részletek | A tranzakciókat egy oszlopban sorolja fel, egy másik oszlopban pedig megjeleníti az egyes tranzakció munkaegység-azonosítóját. Ez a tranzakció általános egyedi azonosítója, amelyet a tranzakció kezdetekor az MS DTC hoz létre.

Megjegyzés A nézet módja az eszköztárból is kiválasztható. A Kis ikon és a Lista parancsok segítségével jeleníthető meg egyszerre a legtöbb tranzakció. A Tulajdonságok parancs jeleníti meg a legrészletesebben a tranzakciókkal kapcsolatos információkat, a Nagy ikon parancs pedig a legolvashatóbb formában mutatja azokat.

A tranzakciók tulajdonságait úgy tekintheti meg, hogy az egér jobb gombjával a kijelölt tranzakcióra, majd bal egérgombbal a Tulajdonságok parancsra kattint. A Tulajdonságok parancs felsorolja a tranzakcióban résztvevő valamennyi tranzakciókezelőt és erőforrás-kezelőt.

A tranzakciók tulajdonságainak megjelenítése a Komponensszolgáltatások felügyeleti eszköz segítségével
  1. A konzolfán kattintson a Tranzakciólista elemre.
  2. A részleteket megjelenítő ablaktáblában az egér jobb gombjával kattintson arra a tranzakcióra, amelynek tulajdonságait meg szeretné tekinteni, majd mutasson a Nézet pontra. Ez a lap megjeleníti a tranzakciókat és azok azonosítóit. Az adatok leírását az MS DTC tranzakciók állapota című témakörben találja meg.
  3. A tranzakciókhoz kapcsolódó szülők és gyermekek megjelenítéséhez kattintson a Tulajdonságok parancsra.


Tranzakciók feloldása kézzel

A tranzakciók véglegesítésének és megszakításának kényszerítése néha azért szükséges, hogy a zárolások feloldásával az adatbázis más hálózati felhasználók és alkalmazások számára is hozzáférhetővé váljon. Ilyen helyzet például akkor fordulhat elő, ha a hálózat két számítógépe között megszakad a kommunikációs összeköttetés. Egy tranzakció kézi véglegesítése vagy megszakítása után előfordulhat, hogy a számítógépet is kézzel kell kényszeríteni a tranzakció törlésére, ami a helyi MS DTC naplófájlból is törli a tranzakciót.

A szülőszámítógépen lévő tranzakciólista segítségével megállapítható a tranzakció kimenetele. A tranzakciólista megtekintésével kapcsolatos tudnivalókat A tranzakciókkal kapcsolatos adatok megtekintése című témakörben találja meg.

Tranzakciók feloldása kézzel
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson duplán arra a számítógépre, amelynek tranzakciólistáját meg szeretné tekinteni. Kattintson duplán az Elosztott tranzakciók koordinátora elemre, majd duplán a Tranzakciólista elemre.
  2. Az egér jobb gombjával kattintson a feloldani kívánt tranzakcióra, mutasson a Feloldás pontra, majd kattintson a Végrehajtás, a Megszakítás vagy a Törlés parancsra.

Bizonytalan állapotú tranzakciók feloldása

A Bizonytalan állapot azt jelzi, hogy a tranzakció alárendelt MS DTC koordinátoron van, a felső szintű MS DTC pedig nem érhető el. A felső szintű és alárendelt tranzakciókezelőkről további információt talál a Példa: Tranzakciófeloldás rendszerhibát követően című témakörben.

Bizonytalan állapotú tranzakciók feloldása
  1. A Tranzakciólista segítségével keresse meg a bizonytalan tranzakció közvetlen szülőjét. A tranzakciók tulajdonságainak megtekintéséről A tranzakciókkal kapcsolatos adatok megtekintése című témakörben olvashat.
  2. Keresse meg a szülő MS DTC számítógépet, majd ennek Tranzakciólista ablakában állapítsa meg a bizonytalan tranzakció kimenetelét a következő módon:
    • Ha a tranzakció nem jelenik meg a Tranzakciók lapon, akkor a tranzakció megszakadt, az alárendelt rendszeren lévő tranzakció pedig kézzel megszakítható.
    • Ha a tranzakció Sikertelen végrehajtási értesítés állapotban jelenik meg a felső szintű számítógépen, akkor a tranzakció véglegesítése megtörtént, és az alárendelt számítógépen kézzel véglegesítheti azt.
    • Ha a tranzakció Sikertelen megszakítási értesítés állapotban jelenik meg a felső szintű számítógépen, akkor a tranzakció megszakadt, és az alárendelt számítógépen kézzel megszakítható.
    • Ha a tranzakció a felső szintű rendszeren Bizonytalan állapotban jelenik meg, annak Tranzakciólista ablakában keresse meg a tranzakció második közvetlen felső szintű rendszerét. Kövesse a tranzakciót a véglegesítési struktúrában egészen addig, amíg megtalálja azt a felső szintű rendszert, amelyen vagy nem szerepel a tranzakció (tehát megszakadt), vagy szerepel, mégpedig a Sikertelen megszakítási értesítés (vagyis megszakadt), illetve a Sikertelen végrehajtási értesítés (vagyis véglegesített) állapotban. Ha a tranzakció a felső szintű rendszeren megszakadt, a tranzakció megszakítását kézzel kényszerítse ki a számítógép közvetlen alárendeltjén. Ha a tranzakció a felső szintű rendszeren véglegesített állapotú, kézzel kényszerítse ki a tranzakció véglegesítését az alárendelt rendszeren.
  3. Miután az alárendelt rendszeren kézzel kényszerítette a tranzakció véglegesítését vagy megszakítását, kézzel kényszerítse a közvetlen felső szintű rendszert a tranzakció törlésére.

Sikertelen megszakítási értesítés állapot feloldása

A Sikertelen megszakítási értesítés állapot azt jelenti, hogy a tranzakció megszakadt, de valamely alárendelt IBM LU6.2 tranzakciókezelő nem értesült a tranzakció kimeneteléről. A tranzakciót az alábbiak szerint oldhatja fel kézzel.

A Sikertelen megszakítási értesítés állapot megjelenítése
  1. Kattintson a jobb gombbal a Sikertelen megszakítási értesítés állapotú tranzakcióra. Ekkor megjelenik a felső szintű MS DTC, és megjelennek a tranzakcióhoz tartozó alárendelt tranzakciókezelők.
  2. Miután megtalálta az alárendelt IBM LU6.2 tranzakciókezelőket, kényszerítse a tranzakciót arra, hogy mindegyik IBM LU6.2 rendszeren megszakadjon.
  3. Miután minden alárendelt IBM LU6.2 rendszeren kézzel kényszerítette a megszakítást, térjen vissza a tranzakciót Sikertelen megszakítási értesítés állapotban megjelenítő MS DTC koordinátorhoz, majd kényszerítse a tranzakció törlését.

Vigyázat! Ne törölje kézzel a tranzakciót mindaddig, amíg minden alárendelt MS DTC koordinátor nem értesült a tranzakció kimeneteléről.

Sikertelen végrehajtási értesítés állapot feloldása

A Sikertelen végrehajtási értesítés állapot az jelenti, hogy a tranzakció véglegesítése megtörtént, de néhány alárendelt MS DTC tranzakciókezelő vagy erőforráskezelő nem értesült a tranzakció kimeneteléről. A tranzakciót feloldhatja kézzel.

Sikertelen végrehajtási értesítés állapot feloldása
  1. Kattintson a jobb gombbal a Sikertelen végrehajtási értesítés állapotú tranzakcióra. Ekkor megjelennek a tranzakcióhoz tartozó felső szintű és alárendelt MS DTC tranzakciókezelők.
  2. Az alárendelt MS DTC tranzakciókezelők megkeresése után mindegyiken kényszerítse a véglegesítést.
  3. Miután minden alárendelt rendszeren kézzel kényszerítette a véglegesítést, térjen vissza a tranzakciót Sikertelen végrehajtási értesítés állapotban megjelenítő MS DTC koordinátorhoz, majd kényszerítse azt a tranzakció törlésére.

Vigyázat! Ne törölje kézzel az adott tranzakciót mindaddig, amíg minden alárendelt MS DTC koordinátor nem értesült a tranzakció kimeneteléről.


Az MS DTC naplófájl ürítése

Rendes körülmények között az MS DTC naplófájlt nem szabad üríteni. Ezzel ugyanis az MS DTC elveszítheti a függőben lévő tranzakciók nyomát, és ez befolyásolhatja a tranzakcióval védett adatbázisok, üzenetsorok és az MS DTC által koordinált fájlok konzisztenciáját. Nem kell az MS DTC naplófájlt üríteni a fájl által lefoglalt lemezterület felszabadításához sem, ugyanis ezt az MS DTC automatikusan megteszi.

Üríteni kell viszont a fájlt másik eszközre történő áthelyezésekor vagy méretének módosításakor. Ha szeretné megváltoztatni a naplófájl attribútumait, a méretezési vagy áthelyezési eljárást megtalálja Az MS DTC naplófájl konfigurálása című témakörben.

Az MS DTC naplófájl ürítésekor egyetlen tranzakció sem lehet Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés állapotban.

Az MS DTC naplófájllal kapcsolatos egyéb információ A naplófájl kezelése című témakörben található.

Távoli rendszeren nem lehet üríteni az MS DTC naplófájlt. Mivel a Komponensszolgáltatások felügyeleti eszköz közvetlenül frissíti az MS DTC naplófájlt, ezért ennek azon a rendszeren kell futnia, ahol a naplófájl található.

Az MS DTC naplófájl ürítése
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson a naplófájlt tartalmazó számítógépre, majd kattintson a Tulajdonságok parancsra.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre.
  3. Az MS DTC leállításához a Szolgáltatásvezérlő állapota (MS DTC) csoportban kattintson a Leállítás gombra.
  4. A naplófájl újrainicializálásához kattintson a Naplóadatok csoport Napló ürítése gombjára.

    Ha az adott naplófájl már létezik a meghajtóval és a könyvtárral megadott helyen, akkor a Napló ürítése gomb hatására törlődik az aktuális naplófájl. Meglévő naplófájl törlésekor egyetlen tranzakció sem lehet Bizonytalan, Sikertelen megszakítási értesítés vagy Sikertelen végrehajtási értesítés állapotban. Az aktuális tranzakcióállapotot a Komponensszolgáltatások felügyeleti eszközzel, a Tranzakciólista segítségével megerősítheti.

  5. Az MS DTC újraindításához a Szolgáltatásvezérlő állapota (MS DTC) csoportban kattintson az Indítás gombra.
  6. Kattintson az OK gombra.


Az MS DTC teljesítményének figyelése

Az MS DTC tranzakciók teljesítménye a rendszerteljesítmény-figyelő vagy a Komponensszolgáltatások felügyeleti eszköz segítségével figyelhető. Ezekre a feladatokra általában a tranzakciók paramétereinek megadása után kerül sor (további információt Az MS DTC kezelése című témakörben talál).

A következő hivatkozások a részletes ismertetőkhöz vezetnek:

  • Az MS DTC teljesítményének figyelése a rendszerteljesítmény-figyelő segítségével
  • Az MS DTC teljesítményének figyelése a Komponensszolgáltatások felügyeleti eszköz segítségével
  • Eseményüzenetek megtekintése


Az MS DTC teljesítményének figyelése a rendszerteljesítmény-figyelő segítségével

Az MS DTC teljesítményének alapos figyelésére a rendszerteljesítmény-figyelőt célszerű használni. Ez az eszköz jeleníti meg az MS DTC teljesítményére vonatkozó legtöbb adatot, segítségével ezeket az adatokat különböző módokon tekintheti meg és elemezheti.

Az MS DTC teljesítményére vonatkozó adatok megjelenítése a rendszerteljesítmény-figyelő segítségével
  1. Mutasson a Start menü Programok, majd Felügyeleti eszközök pontjára, és kattintson a Teljesítmény parancsra.
  2. A Teljesítmény ablak részleteket megjelenítő ablaktáblájában az egér jobb gombjával kattintson a grafikonra, majd kattintson a Számláló hozzáadása parancsra.
  3. A Számláló hozzáadása párbeszédpanelen a Teljesítményobjektum legördülő listából válassza az Elosztott tranzakciók koordinátora elemet.
  4. A Számláló választása listából választógomb alatt jelölje be a megjeleníteni kívánt MS DTC számlálót, majd kattintson a Hozzáadás gombra.
  5. Ha elkészült a számlálók hozzáadásával, kattintson a Bezárás gombra.

Az alábbi táblázat a számlálók jelentését ismerteti:

MS DTC számláló | Jelentés
Megszakított tranzakciók | A megszakított tranzakciók száma
Megszakított tranzakciók / s | A másodpercenként megszakított tranzakciók száma
Aktív tranzakciók | Az aktuálisan aktív tranzakciók száma
Aktív tranzakciók maximális száma | Az egy időben valaha is aktív tranzakciók maximális száma
Végrehajtott tranzakciók | A végrehajtott tranzakciók száma
Végrehajtott tranzakciók / s | A másodpercenként végrehajtott tranzakciók száma
Kényszerrel megszakított tranzakciók | A rendszergazda által megszakított tranzakciók száma
Kényszerrel végrehajtott tranzakciók | A rendszergazda által végrehajtott tranzakciók száma
Bizonytalan kimenetelű tranzakciók | A bizonytalan tranzakciók száma
Válaszadási idő – Átlag | A tranzakciók kezdete és végrehajtása között eltelt átlagos idő
Válaszadási idő – Maximum | A tranzakciók kezdete és végrehajtása között eltelt maximális idő
Válaszadási idő – Minimum | A tranzakciók kezdete és végrehajtása között eltelt minimális idő
Tranzakció/s | A másodpercenként végrehajtott tranzakciók száma


Az MS DTC teljesítményének figyelése a Komponensszolgáltatások felügyeleti eszköz segítségével

A Komponensszolgáltatások felügyeleti eszköz részét képezi a Tranzakcióstatisztika ablak, amely statisztikai adatokat jelenít meg azokról a tranzakciókról, amelyekben a kiszolgáló részt vett. A tranzakcióstatisztika az MS DTC teljesítményének áttekintésére szolgál.

Tranzakcióstatisztika megtekintése
  • A Komponensszolgáltatások felügyeleti eszköz konzolfáján kattintson duplán arra a számítógépre, amelynek tranzakcióstatisztikáját meg szeretné tekinteni. Kattintson duplán az Elosztott tranzakciók koordinátora elemre, majd kattintson a Tranzakcióstatisztika elemre.

    A tranzakciók állapota a Jelenlegi, az Összesen és a Válaszidők (ezredmásodperc) csoportokban tekinthető meg. A tranzakciók állapotáról további információt talál az MS DTC tranzakciók állapota című témakörben.


Eseményüzenetek megtekintése

Az eseményüzenetek megtekintéséről Windows 2000 környezetben az Eseménynaplónak a Komponensszolgáltatások felügyeleti eszközhöz mellékelt dokumentációjában olvashat. Windows 2000 rendszeren az MS DTC eseményeket a Windows alkalmazás-eseménynaplója rögzíti.


Az MS DTC eszközzel összefüggő problémák kezelése

Az egyik leggyakoribb MS DTC hibaüzenet a „Sikertelen besorolás”. Az ODBC illesztőprogram-kezelő például akkor jelenti ezt a hibát, ha a Komponensszolgáltatásokban futó egyik tranzakciós komponens megkísérel megnyitni egy adatbázis-kapcsolatot, és az illesztőprogram-kezelő nem tudja az adatbázis-kapcsolatot besorolni az aktuális tranzakcióba. Az ODBC illesztőprogram-kezelő az adatbázis-kapcsolatot az illesztőprogram SQLSetConnectionAttr (SQL_ATTR_ENLIST_IN_DTC) eljárásának meghívásával sorolja be az aktuális tranzakcióba. Az ODBC illesztőprogram-kezelő akkor jeleníti meg a „Sikertelen besorolás” üzenetet, ha az SQLSetConnectionAttr eljárás meghívása nem sikerül.

Ha ez a hiba akkor lép fel, ha a tranzakciós komponens Oracle-adatbázist használ, olvassa el a „Sikertelen besorolás” című dokumentumot, amely az ftp://ftp.microsoft.com/bussys/viper/docs címen található.

Ha ez a hiba akkor jelentkezik, amikor a tranzakciós komponens Microsoft SQL Server adatbázist használ, végezze el a következő feladatokat:

  1. Hogyan ellenőrizhető, hogy az MS DTC elindult-e?
  2. A számítógépek közti kommunikáció ellenőrzése
  3. Az SQL Server beállítása Named Pipes helyett TCP/IP használatára
  4. A tranzakció időtúllépési beállításának ellenőrzése


Hogyan ellenőrizhető, hogy az MS DTC elindult-e?

Győződjön meg arról, hogy azon a rendszeren, amelyen a Komponensszolgáltatásokban futó komponensek üzembe vannak helyezve, az MS DTC „Elindítva” állapotban van-e.

Ha a Microsoft SQL Server adatbázisát használó alkalmazás távoli rendszeren található, azon a rendszeren is ellenőrizze, hogy az MS DTC „Elindítva” állapotban van-e. Ez gyakori oka lehet a „Sikertelen besorolás” hibaüzenetnek.

Az MS DTC indításáról és leállításáról bővebben Az MS DTC indítása és leállítása című témakörben olvashat.


A számítógépek közti kommunikáció ellenőrzése

Ha az egyik rendszeren lévő tranzakciós COM-komponens egy másik rendszeren lévő SQL Server adatbázist használ, akkor az MS DTC az MS DTC tranzakciót az első vagy „elsődleges” rendszerről a másodlagos rendszerre viszi át. A tranzakció átvitele csak akkor történhet meg, ha az elsődleges rendszeren lévő MS DTC folyamat kommunikálni tud a másodlagos rendszeren lévővel. Az MS DTC folyamatok valójában kétirányú RPC-kapcsolatokat hoznak létre, így bármelyik rendszeren előforduló hálózati konfigurációs hiba megakadályozhatja, hogy az MS DTC folyamatok sikeresen kommunikáljanak egymással. Ez az oka annak, hogy az ODBC „Sikertelen besorolás” hibaüzenetet jelenít meg.

Ha kommunikációs hiba lép fel, a Windows 2000 alkalmazás-eseménynaplója a következő eseményt rögzíti:

MS DTC is unable to communicate with MS DTC on a remote system. MS DTC on the primary system established an RPC binding with MS DTC on the secondary system. However, the secondary system did not create the reverse RPC binding to the primary MS DTC system before the timeout period expired. Please ensure that there is network connectivity between the two systems. (Az MS DTC nem tud kapcsolatot létesíteni a távoli rendszeren lévő MS DTC példánnyal. Az elsődleges rendszer MS DTC-je RPC-kötést hozott létre a másodlagos rendszer MS DTC-jével. A másodlagos rendszer azonban nem hozta létre a fordított RPC-kötést az elsődleges MS DTC felé az időkorlát letelte előtt. Ellenőrizze, hogy van-e kapcsolat a két rendszer között.)

Ez a hiba azt jelzi, hogy a rendszeren lévő MS DTC létre tudott ugyan hozni kötést az SQL Server rendszeren lévő MS DTC koordinátorral, de ez utóbbi nem tudott fordított kötést létrehozni a rendszeren lévő MS DTC koordinátorral.

Ha a hálózat konfigurációja helytelen, minden, a távoli SQL Server adatbázisához tett csatlakozási kísérlet „Sikertelen besorolás” hibával jár. Ha rendszeresen kap ilyen hibaüzenetet még az után is, hogy az MS DTC mindkét rendszeren elindult, a hiba legvalószínűbb oka a hálózat helytelen beállítása.

A számítógépek közti hálózati kommunikáció ellenőrzése
  1. A Jegyzettömb segítségével hozzon létre egy Pingtest.bat nevű fájlt, majd illessze be a következő szkriptparancsokat:
    echo off
REM Használata: pingtest távoli_számítógép_neve
REM A számítógép neve helyett nem használható annak IP-címe!
ping -n 1 %computername%
ping -n 1 %1
ipconfig /all
echo on

    A szkript a %computername% segítségével jeleníti meg a helyi IP-címet. Ezt követően megjeleníti annak a távoli számítógépnek az IP-címét, amelynek nevét a szkript végrehajtásakor a parancssorban kell megadni. A szkript meghívásakor a távoli számítógépnek a nevét, és nem az IP-címét kell megadni. A számítógépnév megadása arra kényszeríti a Ping parancsot, hogy a számítógép nevét pontosan úgy oldja fel, miként azt az MS DTC teszi, amikor a távoli MS DTC számítógéppel kötést hoz létre.

  2. Futtassa a Pingtest.bat szkriptet az elsődleges rendszeren annak megállapításához, hogy „ping” parancs segítségével a másodlagos rendszert annak neve alapján el lehet-e érni. Rögzítse a szkript kimenetét egy szövegfájlban. Ha például az elsődleges számítógép „A”, a másodlagos pedig „B”, írja be a következőket:
    Pingtest B > AResults.txt
  3. Futtassa a Pingtest.bat szkriptet a másodlagos rendszeren annak megállapításához, hogy a „ping” parancs segítségével az elsődleges rendszert annak neve alapján el lehet-e érni. Rögzítse a szkript kimenetét egy szövegfájlban. Ha például az elsődleges számítógép „A”, a másodlagos pedig „B”, írja be a következőket:
    Pingtest A > BResults.txt
  4. Vizsgálja meg a két szövegfájlt, és győződjön meg arról, hogy a két számítógép el tudja-e egymást érni a ping parancs segítségével.

Ha a TCP/IP-névfeloldáshoz Hosts vagy Lmhostst fájlokat alkalmaz, alaposan ellenőrizze azokat, és győződjön meg arról, hogy a számítógépek nevei a helyes IP-címekhez vannak-e rendelve. Ehhez ellenőrizze a %windir%>system32\drivers\etc\ mappájában lévő „Hosts” és „Lmhosts” fájlokat mind a Komponensszolgáltatásokat, mind pedig az SQL Server programot futtató rendszeren. Gyakran előfordulhat, hogy az egyik rendszeren lévő fájl helyes, míg a másik rendszeren lévő helytelen.

Alapértelmezés szerint az MS DTC a Rendszer fiók azonosítója alatt fut. Az egyik számítógépen található MS DTC szolgáltatás csak akkor tud kommunikálni a másikon találhatóval, ha mindkét számítógépen engedélyezve vannak a Vendég fiókok. Ha bármelyik számítógépen vagy azon a Windows 2000 tartományon, amelyhez tartoznak, letiltja a Vendég fiókot, akkor az MS DTC szolgáltatást úgy kell konfigurálni, hogy egy másik, a távoli számítógéppel kommunikálni képes felhasználói név alatt fusson.


Az SQL Server beállítása Named Pipes helyett TCP/IP használatára

Ha csak időnként jelenik meg „Sikertelen besorolás” hibaüzenet, akkor a hiba oka az lehet, hogy az SQL Server az ügyfél és a kiszolgáló közötti kommunikációhoz a TCP/IP helyett Named Pipes felületet használ. A Named Pipes használata az SQL Server ügyfél és kiszolgáló közötti kommunikációjához időnként „Sikertelen besorolás” hibát eredményezhet. Az SQL Server kiszolgálót a Named Pipes protokoll használata helyett a TCP/IP használatára kell konfigurálni.

Az SQL Server 6.5 konfigurálása TCP/IP használatához
  1. A Start menüben mutasson a Programok, majd a Microsoft SQL Server 6.5 pontra, és kattintson az SQL Client Configuration Utility parancsra.
  2. Kattintson a Net Library fülre.
  3. A Default Network legördülő listából válassza a TCP/IP Sockets elemet.
  4. Kattintson a Done gombra.

Az SQL Server 7.0 konfigurálása TCP/IP használatához
  1. A Start menüben mutasson a Programok, majd a Microsoft SQL Server 7.0 pontra, és kattintson a Client Network Utility parancsra.
  2. Kattintson a General fülre.
  3. A Default Network Library legördülő listából válassza a TCP/IP elemet.
  4. Kattintson az OK gombra.


A tranzakció időtúllépési beállításának ellenőrzése

Ha „Sikertelen besorolás” hibaüzenet jelenik meg, érdemes figyelembe venni, hogy a komponens tranzakciója azért szakadt-e meg, mert az adatbázisba való besorolás befejeződése előtt tranzakciós időtúllépés következett be. A Komponensszolgáltatások felügyeleti eszköz segítségével növelhető a tranzakciók időtúllépési értéke.

Nem valószínű, hogy ez a hiba oka, kivéve, ha a tranzakciók általában sok időt vesznek igénybe. Hasznos lehet azonban az időtúllépési értéket ideiglenesen növelni annak érdekében, hogy ezt az esetleges hibalehetőséget ki lehessen szűrni.

A tranzakciók időtúllépési értékének ellenőrzése
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson a tranzakciót kezdeményező számítógépre, majd kattintson a Tulajdonságok parancsra.
  2. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre.
  3. Az MS DTC leállításához kattintson a Szolgáltatásvezérlő állapota (MS DTC) csoport Leállítás gombjára.
  4. A Beállítások lapon a Tranzakció időtúllépése csoport Tranzakció időtúllépése mezőjébe írja be az időtúllépési értéket, amely másodpercben értendő.

    0-tól 4.294.967-ig tetszőleges érték megadható. A 0 érték végtelen hosszú időtúllépési időszakaszt jelent – ez megakadályozza, hogy a tranzakciók során időtúllépés következzen be. Előfordulhat, hogy különböző értékekkel kell próbálkozni, míg sikerül beállítani a rendszer számára a helyes időtúllépési értéket.

  5. Kattintson az OK gombra.

Az új beállítás a COM+ alkalmazás leállítása és újraindítása után lép érvénybe.


Az MS DTC eszközzel kapcsolatos tanácsadás

Ez a témakör azt ismerteti, hogy az MS DTC koordinátorral összefüggő hibák elhárítása érdekében miként lehet a technikai tanácsadáshoz fordulni.

Oracle és MS DTC együttes használata

Az Oracle-adatbázis és a Komponensszolgáltatások, valamint az MTS együttes használatát érintő tanácsadással kapcsolatos legújabb információkat megtalálja az „Oracle and MTS” című dokumentumban az ftp.microsoft.com/bussys/viper/docs címen.

Az MS DTC hibákról szóló jelentés beküldése

A következőkben megismerheti, hogy miként kell az MS DTC hibáit a Microsoft technikai tanácsadásnál bejelenteni.

A hibabejelentéshez célszerű mellékelni a következő információkat:

  • Adja meg az MS DTC szoftver verziószámát.

    A verziószám a Komponensszolgáltatások felügyeleti eszköz MSDTC lapján található meg. Indítsa el a Komponensszolgáltatásokat azon a rendszeren, amelyen a hiba jelentkezik. Kattintson duplán a Számítógépek, majd a jobb gombbal a Sajátgép elemre, végül kattintson a Tulajdonságok parancsra. A számítógép tulajdonságait megjelenítő párbeszédpanelen kattintson az MSDTC fülre. Az MS DTC verziószáma az MSDTC lap alján található.

  • Ha a Windows 2000 valamely szervizcsomagját telepítette, ellenőrizze Az MS DTC komponensei című témakörben felsorolt MS DTC fájlok verziószámát. A Windows 2000 szervizcsomagok csak a termék első verziója óta módosult .dll és .exe fájlokat tartalmazzák.

    A .dll és az .exe fájlok verziójának ellenőrzéséhez használja a Windows Intézőt, amellyel megkeresheti az egyes MS DTC fájlokat a System32 könyvtárban. A jobb oldali egérgombbal kattintson a fájlra, majd a Tulajdonságok parancsra. A Tulajdonságok párbeszédpanelen kattintson a Verzió fülre. Jegyezze fel a Fájlverzió értéket Az MS DTC komponensei című témakörben felsorolt összes .ddl vagy .exe fájl esetében.

  • Az MS DTC telepítésével kapcsolatos hibáknál mellékelje a %Windows_könyvtár% mappában lévő Dtcinstall.log fájlt.
  • Jegyezze fel a megjelenő MS DTC hibaüzenetek teljes szövegét, beleértve a neveket és a forrásfájlok sorszámát is.
  • Vizsgálja át a Windows 2000 alkalmazás-eseménynaplóját, és jegyezze fel az MS DTC koordinátorral kapcsolatos eseményeket a hiba időpontja körül. Jegyezze fel az Esemény részletei és az Adat rögzítése lapon található adatokat is.
  • Készítsen másolatot az MS DTC naplófájlról, hogy a Microsoft technikai tanácsadó szakembere szükség esetén megvizsgálhassa azt. Előfordulhat, hogy a naplófájl túl nagy ahhoz, hogy a hibabejelentéssel együtt benyújtsa, de a hiba kijavításáig célszerű azt megőriznie. A naplófájl általában a %Windows_könyvtár%\System32\DTCLog mappában, MSDTC.log néven található.
  • Lehetőség szerint a legpontosabban írja le azokat a körülményeket, amelyek a hibához vezettek. Ha az alkalmazás több rendszer között van elosztva, jellemezze az alkalmazás konfigurációját, és közölje, hogy az alkalmazás komponensei hol futnak.
  • Mondja el, hogy az alkalmazás milyen erőforrás-kezelőket használ, és közölje azok verziószámát. Sorolja fel az alkalmazás által használt adatbázisokat, üzenetsor-kezelő rendszert és erőforrás-kezelőket.

    Ha például Oracle-adatbázist használt, célszerű megadnia, hogy Oracle 7.3.5-ös vagy Oracle 8.1.0-s verziót használ-e. Ha az erőforrás-kezelők a hálózaton lévő rendszereken el vannak osztva, közölje, hogy hol futnak. Fontos tudni például, hogy a Microsoft SQL Server adatbázis távoli Windows rendszeren fut-e, vagy, hogy az Oracle-adatbázis Unix Solaris rendszeren fut-e.


Az Aszinkron komponensek felügyelete

A Message Queuing szolgáltatáson alapuló Aszinkron komponensek a Komponensszolgáltatások olyan szolgáltatása, amely lehetővé teszi a COM-komponensek számára, hogy más komponensekhez kérelemmel forduljanak, még akkor is, ha azok nem érhetők el vagy nincsenek hálózati kapcsolatban. A rendszer a kérelmeket rögzíti, a várakozási sorba helyezi őket, majd automatikusan lejátssza őket, ha a komponens elérhetővé válik.

Egy, a várakozási sor támogatására kifejlesztett komponens várakozási sorba történő helyezéséhez használja a Komponensszolgáltatások felügyeleti eszközt, amellyel a COM+ alkalmazás megadható úgy, mint várakozási sorba helyezett alkalmazás. Adjon komponenseket ehhez a várakozási sorba állított alkalmazáshoz, majd az alkalmazás üzenetek fogadására alkalmassá tételéhez indítsa el az Aszinkron komponensek figyelőjét.

Az alábbi hivatkozásokra kattintva elolvashatja a háttér-információkat és a feladatokkal kapcsolatos tudnivalókat.

Témakör | Leírás
Az Aszinkron komponensek felügyeletével kapcsolatos fogalmak | Az Aszinkron komponensekkel kapcsolatos fogalmak áttekintése
Az Aszinkron komponensek felügyeletével kapcsolatos feladatok | Az Aszinkron komponensek felügyeletével kapcsolatos feladatok felsorolása

A munka megkezdése előtt

Az Aszinkron komponensek használatához a Message Queuing szolgáltatást telepíteni kell a számítógépre.

Az Aszinkron szolgáltatások eszköz hitelesített üzeneteket használ. A Message Queuing megköveteli, hogy a hitelesített üzenetek feldolgozásához az egyes felhasználók érvényes hitelességi bizonyítványt regisztráljanak. A Message Queuing szolgáltatáshoz szükséges belső hitelességi bizonyítvány regisztrálásáról a Message Queuing belső hitelességi bizonyítvány beszerzése című témakörben olvashat.

A várakozási sorba helyezett komponensek fejlesztéséről a Microsoft Platform SDK csomag Component Services című témakörében olvashat, a COM+ (Component Services) fejezet Queued Components részében.


Az Aszinkron komponensek felügyeletével kapcsolatos fogalmak

A COM+ alkalmazások várakozási sorba állított alkalmazásokként is megjelölhetők. Egy adott alkalmazás várakozási sorba állított alkalmazásként történő megadásával egy Message Queuing várakozási sort hoz létre, amelyet az alkalmazással társít. Alapértelmezés szerint ez a várakozási sor tranzakciós jellegű, amely még akkor is megőrzi az üzenetben lévő adatok konzisztenciáját és integritását, ha az üzenet nem fejeződik be sikeresen. A várakozási sorba állított alkalmazás megadása után adjon komponenseket az alkalmazáshoz. E komponensek egyaránt lehetnek várakozási sorba állíthatók és várakozási sorba nem állíthatók.

Megjegyzés Ha úgy kényelmesebb, először adjon komponenseket a COM+ alkalmazáshoz, majd ezt követően adja meg az alkalmazást várakozási sorba állítottként. Annak, hogy az alkalmazást mikor adja meg várakozási sorba állított alkalmazásként, nincs jelentősége. Az adott komponens megadható várakozási sorba állított komponensként függetlenül attól, hogy az alkalmazás várakozási sorba van-e állítva vagy sem. A várakozási sorba állított alkalmazásnak azonban csak a várakozási sorba állítható komponensei hívhatók meg aszinkron módon.

Miután megadta a várakozási sorba állított alkalmazást, és hozzáadta a szükséges komponenseket, engedélyeznie kell az Aszinkron komponensek figyelőjét. Ha egy alkalmazást várakozási sorba állítottként ad meg, lehetővé teszi az alkalmazásnak, hogy üzeneteket fogadjon, de aktívan mindaddig nem figyel vagy fogad üzeneteket a bemeneti várakozási sorból, amíg az Aszinkron komponensek figyelője nincs elindítva.

A várakozási sorba állított alkalmazás minden várakozási sorba állítható komponense végrehajtható aszinkron módon. Az aszinkron végrehajtás azt jelenti, hogy elindíthat egy műveletet a kiszolgálón, és míg az a kért feladatot elvégzi, folytathatja a feldolgozást. Szinkron környezetben a komponensnek egy másik komponens meghívását követően meg kell várnia a hívás eredményét, mielőtt egy másik feladat végrehajtását elkezdhetné. A várakozási sorba állítható komponensek esetében a hívás azonnal visszaérkezik függetlenül attól, hogy történt-e feldolgozás vagy sem. A komponens szabadon áttérhet más feladatok végrehajtására. Később, ha a kérelem feldolgozása megtörtént, a kiszolgáló az eredményről értesíti a kérelmet küldő komponenst.

Időnként előfordul, hogy az üzenetet valamiért nem sikerül feldolgozni, például a kiszolgáló vagy a várakozási sorba állító rendszer meghibásodása miatt. Hiba esetén az Aszinkron komponensek szolgáltatás többször megkísérli az üzenet továbbítását, mielőtt azt egy végső nyugalmi várakozási sorba helyezné. Az üzenetek mindaddig itt maradnak, míg az Aszinkron komponensek üzenetmozgató segédprogramjával kézzel át nem helyezi őket. Az üzenetmozgató az üzeneteket egyik várakozási sorból a másikba helyezi át. Mivel az üzenet eltávolítását a várakozási sorból csak egy megbízható forrás végezheti el, az üzenetmozgatót csak a QC megbízható felhasználó szerepkörrel rendelkező felhasználók használhatják. A QC megbízható felhasználó szerepkör megadásáról a Felhasználói fiókok vagy csoportok hozzárendelése egy szerepkörhöz című témakörben olvashat.


Az Aszinkron komponensek felügyeletével kapcsolatos feladatok

A várakozási sorba állított komponensek felügyeletekor az első feladat az alkalmazás várakozási sorba állított alkalmazásként történő megadása. A várakozási sorba állított alkalmazás létrehozása után komponenseket kell az alkalmazáshoz adni. Egy várakozási sorba állított alkalmazás várakozási sorba állítható és nem állítható komponenseket egyaránt tartalmazhat. Vannak azonban bizonyos tényezők, amelyeket érdemes megfontolni, ha ugyanazon alkalmazásban várakozási sorba állítható és várakozási sorba nem állítható komponenseket együtt kíván alkalmazni. Ha csoportos feldolgozási műveleteket kíván végrehajtani a nap egy adott időpontjában, a metódusokat a nap folyamán a várakozási sorba állított komponensek segítségével tárolhatja, majd a sorból az előre definiált időpontban eltávolíthatja. Amennyiben ez az alkalmazás várakozási sorba nem állítható komponenseket is tartalmaz, az ilyen komponensekhez érkező bármilyen hívás véletlenül is elindíthatja a várakozási sor feldolgozását, hacsak a figyelőt a Komponensszolgáltatások felügyeleti eszköz segítségével kifejezetten le nem tiltja. Ha szabályozni szeretné a várakozási sorban lévő metódusok futtatásának időpontját, a következők valamelyikét kell tennie:

  • A Komponensszolgáltatások felügyeleti eszközben a Figyelő jelölőnégyzet segítségével tiltsa le a figyelőt.
  • A várakozási sorba állított és a várakozási sorba nem állított komponenseket különítse el különböző alkalmazásokba.

Miután létrehozta a várakozási sorba állított alkalmazást és komponenseket adott hozzá, a következő lépés az Aszinkron komponensek figyelőjének elindítása. Az Aszinkron komponensek figyelőjének indításakor az alkalmazás olvasni kezdi az üzeneteket a bemeneti várakozási sorból. Az üzenetek egyik várakozási sorból a másikba történő áthelyezéséhez, illetve a végső nyugalmi várakozási sorban lévő üzenetek feldolgozására tett kísérlethez az üzenetmozgatót kell használni.

A következő hivatkozások a részletes ismertetőkhöz vezetnek:

  • Message Queuing belső hitelességi bizonyítvány beszerzése
  • Alkalmazás várakozási sorba állított alkalmazásként történő megadása
  • Az Aszinkron komponensek figyelőjének indítása
  • Az üzenetmozgató használata


Message Queuing belső hitelességi bizonyítvány beszerzése

Ahhoz, hogy küldéskor az üzenet hitelesítése megtörténjen, minden felhasználó számára Message Queuing hitelességi bizonyítványt kell beszerezni. Amikor a program az üzenetet a várakozási sorból beolvassa (ha az üzenetet fogadó alkalmazás azt megköveteli), digitális aláírás ellenőrzésére kerül sor annak megállapítására, hogy az üzenet valóban attól a forrástól érkezett-e, amely annak küldését bejelentette.

Message Queuing belső hitelességi bizonyítvány beszerzése

Az alábbiak azt feltételezik, hogy a felhasználó olyan azonosítóval jelentkezett be, amelyet majd a COM+ alkalmazás végrehajtásakor használ.

  1. A Vezérlőpulton nyissa meg az MS Message Queue ablakot.
  2. Kattintson a Biztonság fülre.
  3. Kattintson a Belső bizonyítvány megújítása, majd az OK gombra.
  4. Kattintson a Bezárás gombra.


Alkalmazás várakozási sorba állított alkalmazásként történő megadása

Várakozási sorba állított alkalmazáshoz egy ahhoz társított Message Queuing várakozási sorra van szükség. Az alkalmazás várakozási sorba állított alkalmazásként történő megadásakor ezt a várakozási sort a Komponensszolgáltatás létrehozza. A várakozási sor tranzakciós jellegű, és garantálja az üzenetek kézbesítését.

Alkalmazás várakozási sorba állított alkalmazásként történő megadása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson arra a COM+ alkalmazásra, amelyet várakozási sorba kíván állítani, majd kattintson a Tulajdonságok parancsra.
  2. A Várakoztatási tulajdonságok lapon jelölje be az Aszinkron jelölőnégyzetet.

    Ha a jelölőnégyzet nem érhető el, akkor nincs várakozási sorba állítható felülettel rendelkező komponens, így az alkalmazás nem állítható várakozási sorba.

  3. Kattintson az OK gombra.


Az Aszinkron komponensek figyelőjének indítása

A várakozási sorba állított alkalmazás és az annak várakozási sorba állított komponensei létrehozását követően elkezdheti meghívni e komponenseket. Ez a folyamat az alkalmazás várakozási sorához küldött kérelmekre vonatkozó üzenetekkel jár. E várakozási sorba állított kérelmek feldolgozásához a Komponensszolgáltatások segítségével el kell indítania az Aszinkron komponensek figyelőjét.

Megjegyzés Az Aszinkron komponensek figyelőjének indításakor az alkalmazás nem futhat. Ha az alkalmazás fut, akkor nem ismeri fel az Aszinkron komponensek figyelőjének módosított állapotát, ezért be kell zárni, majd újra kell indítani, mielőtt a várakozási sorba állított üzeneteket helyesen feldolgozhatná.

Az Aszinkron komponensek figyelőjének indítása
  1. A Komponensszolgáltatások felügyeleti eszköz konzolfáján az egér jobb gombjával kattintson a várakozási sorba állított alkalmazásra, majd kattintson a Tulajdonságok parancsra.
  2. A Várakoztatási tulajdonságok lapon jelölje be a Figyelő jelölőnégyzetet.
  3. Kattintson az OK gombra.


Az üzenetmozgató használata

Időnként előfordulhat olyan helyzet (általában a rendszer vagy a konfiguráció hibája miatt), amikor az adott üzenetet nem sikerül célba juttatni. Ilyenkor az eseménynaplóban bejegyzések jelzik, hogy egyes üzeneteket nem sikerült befejezni. Ezt a Message Queuing szolgáltatással ellenőrizheti: segítségével megtekintheti a várakozási sorok állapotát. Néhány, a várakoztatással kapcsolatos hiba megoldása egyszerű. A kiszolgálót például, ha valamiért nem volt a hálózathoz csatlakoztatva, be lehet kapcsolni a hálózatba. A hiba elhárítása után az Aszinkron komponensek üzenetmozgatójával az üzeneteket újra a várakozási sorba lehet állítani. Az üzenetmozgató olyan eszköz, amely a sikertelen üzeneteket egyik várakozási sorból a másikba helyezi át, így feldolgozásukra újabb kísérlet tehető.

Az üzenetmozgató egy Automation objektum, amelynek meghívása egyszerű szkripttel történhet. Ilyen az alábbi VBScript nyelven íródott szkript is:

Dim OMessageMover as IMessageMover
Dim BatchSize
Dim MovedMessage

setIMessageMover = CreateObject("QC.MessageMover")
OMessageMover.put_SourcePath = "A forrás-várakozásisor elérési útja"
OMessageMover.put_DestPath = "A cél-várakozásisor elérési útja"
OMessageMover.put_CommitBatchSize = BatchSize ' a csoportosan áthelyezni kívánt üzenetek száma
MovedMessage = OMessageMover.MoveMessage


COM+ szójegyzék

aktiválás típusa
A COM+ alkalmazások azon kategóriája, amely azt jelzi, hogy az adott alkalmazás az ügyfél folyamatterületén belül vagy kívül fut-e. Ez határozza meg ugyanis, hogy az alkalmazás hogyan képes használni a szerepkörökre alapuló adatvédelmet, és támogatja-e a távoli hozzáférést vagy a várakozásisor-kezelést. További információ a COM+ függvénytár-alkalmazás és a COM+ kiszolgálóalkalmazás címszavaknál.

aktiválás
Olyan eseménylánc, amelynek eredményeként egy adott COM-objektum és az objektum valamely felületére vonatkozó érvényes mutató jön létre. A COM+ szolgáltatások egy meghatározott objektum megfelelő aktiválására hagyatkoznak, ennek alapja pedig az objektum konfigurációja. Az aktiválás során a rendszer meghatározza azt a környezetet, amelyben az objektum működik, inicializálja a környezet tulajdonságait, ellenőrzi a hozzáférési jogosultságokat és biztonsági azonosítót hoz létre. További információ az igény szerinti (Just-in-time, JIT) aktiválás és az aktiválás típusa címszavaknál.

alkalmazásproxy
Olyan fájlok készlete, amelyek bejegyzései az adott ügyfélalkalmazás számára lehetővé teszik valamely COM+ kiszolgálóalkalmazás távoli elérését. Egy ügyfélszámítógépen futtatott alkalmazásproxy-fájl a kiszolgálóalkalmazás adatait (köztük a CLSID-azonosítókat, a programazonosítókat, a távoli kiszolgáló nevét és a rendezési adatokat) az ügyfélszámítógépre írja. Ezután az ügyfélalkalmazások távolról is hozzáférhetnek a kiszolgálóalkalmazáshoz.

állapot
Feltétel, amely meghatározza, hogy egy objektum kezel-e példányspecifikus adatokat a metódushívások közötti belső változókban.

aszinkron komponensek
COM+ szolgáltatás, amelyen keresztül a COM-komponensek meghívhatnak egy másik komponenst, tekintet nélkül arra, hogy az adott komponens tudja-e fogadni a hívásokat vagy sem. A kérelmekről felvétel készül, a várakozási sorba kerülnek, majd automatikusan lejátszásra kerülnek, ha a komponens elérhetővé válik. Az aszinkron komponensek alapja a Message Queuing szolgáltatás.

COM+ (Komponensszolgáltatások)
Olyan, a Microsoft Transaction Server (MTS) és a Component Object Model (COM) bővítményein alapuló szolgáltatások csoportja, amelyek jobb minőségű szálkezelést és biztonságot, tranzakciókezelést, objektumkészletezést, aszinkron komponenseket, valamint alkalmazás-felügyeletet és csomagkezelést biztosítanak.

COM+ alkalmazás
Egy vagy több COM-komponens, amelyek úgy vannak konfigurálva, hogy egyetlen egységként a Windows 2000 által biztosított COM+ (Komponensszolgáltatások) közül egyet vagy többet használjanak.

COM+ függvénytár-alkalmazás
Olyan COM+ alkalmazás, amely az alkalmazást létrehozó ügyfél által kezelt folyamatban működik. A függvénytár-alkalmazások használhatják a szerepkör alapú adatvédelmi rendet, de nem támogatják a távoli hozzáférést vagy az aszinkron komponenseket.

COM+ katalógus
Olyan adattároló rendszer, amely egy adott kiszolgáló számítógépen található COM+ alkalmazások konfigurációs adatait tartalmazza. A Komponensszolgáltatások felügyeleti eszközzel végrehajtott beállítások a COM+ katalógusba íródnak.

COM+ kiszolgálóalkalmazás
Olyan COM+ alkalmazás, amely a saját folyamatában működik. A kiszolgálóalkalmazások képesek az összes COM+ szolgáltatás támogatására.

erőforrás-elosztó
Az erőforrás-elosztó karbantartja a folyamat alkalmazáskomponenseinek ideiglenes megosztott állapotát. Az erőforrás-elosztók hasonlítanak az erőforrás-kezelőkhöz, azonban nem garantálják az állandóságot.

erőforrás-kezelő
Maradandó adatokat kezelő rendszerszolgáltatás. A COM+ kiszolgálóalkalmazások az erőforrás-kezelő segítségével tartják fenn az alkalmazás állandó állapotát (például a leltár, a függőben lévő megrendelések, a fogadható fiókok nyilvántartásával). Az erőforrás-kezelők a Microsoft elosztott tranzakció koordinátorral együttműködve garantálják egy alkalmazás atomitását és elszigeteltségét.

felvevő
Aszinkron komponensek esetében a felvevő egy, a rendszer által biztosított DLL-t jelöl, amely a kiszolgálóobjektum proxy-kezelőjeként működik, és kiválasztja a sorba állítható objektumfelületeket a COM+ katalógusból.

figyelő
Aszinkron komponensek esetében olyan COM-objektumot jelöl, amely megnyitja a saját gazdaállomásához társított üzenetsort és várakozik az üzenetek érkezésére. Üzenetek érkezésekor a figyelő beütemezi az üzeneteket feldolgozó szálakat.

igény szerinti (Just-in-Time) aktiválás
Olyan mechanizmus, amelyben csak akkor kerül sor a COM-objektum aktiválására, amikor arra az ügyfelek kéréseinek feldolgozásához van szükség. Az objektumok működését még akkor is fel lehet függeszteni, ha az ügyfelek megtartják a rájuk mutató hivatkozásokat. Ezáltal lehetővé válik az egyébként ki nem használt kiszolgáló-erőforrások hatékonyabb felhasználása.

Kompenzáló erőforrás-kezelők (CRM)
A kompenzáló erőforrás-kezelők (CRM) a nem tranzakció jellegű erőforrások számára engedélyezik, hogy a Microsoft Distributed Transaction Coordinator (DTC) alkalmazással együtt kétfázisú véglegesítési tranzakcióban vegyenek részt egy olyan kompenzálási művelet alkalmazásával, amely az eredeti munkával ellentétes értelmű. A kompenzáló erőforrás-kezelők általában nem rendelkeznek a teljes körű erőforrás-kezelők elszigetelési képességeivel, a naplófájl készítésével azonban tranzakciós atomitást és állandóságot biztosítanak.

Komponensszolgáltatások felügyeleti eszköz
A Windows 2000 operációs rendszer részét képező Microsoft Management Console beépülő modul, amellyel a rendszergazdák és a fejlesztők létrehozhatják, konfigurálhatják és karbantarthatják a COM+ alkalmazásokat, illetve felügyelhetik az elosztott tranzakciókat és a memóriarezidens adatbázisokat. Ezzel az eszközzel megtekinthetők a rendszeresemények, illetve kezelhetők a rendszerszolgáltatások azon a számítógépen, amelyen az eszköz telepítve van.

konfigurált komponens
Olyan COM-komponens, amelynek telepítésére COM+ alkalmazásban került sor. A telepített komponens konfigurálása a COM+ katalógusban történik az elérhető Komponensszolgáltatások, köztük a tranzakciók, a szerepkör alapú adatvédelem, az aszinkron komponensek, az események és az objektumkészletezés használatára.

környezet
Egy vagy több COM-objektumhoz társított tulajdonságok készlete, amelyekkel a szóban forgó objektumok szolgáltatásai biztosíthatók. Minden COM-objektum egyetlen környezetben működik az aktiválástól az aktív állapot megszüntetéséig (mindig ugyanabban az apartmanban). Egy adott objektum aktiválásakor inicializált környezeti tulajdonságok az objektumhoz tartozó ügyfél és az objektum konfigurációjának környezeti tulajdonságain alapulnak.

lejátszó
Aszinkron komponensek esetében a lejátszó lekéri az üzenetet a várakozási sorból, betölti a kiszolgálóobjektumot és a felület szabványos stub objektumait az adatok bemásolásához, és meghívja a kiszolgálómetódusokat.

megosztott tulajdonságok kezelője
Olyan eszköz, amely szinkronizált hozzáférést biztosít az alkalmazás által definiált, az egész folyamatra érvényes tulajdonságokhoz (változókhoz).

.msi fájl
Olyan fájl, amelyet a Komponensszolgáltatások felügyeleti eszköz hoz létre, amikor egy másik számítógépen telepíteni kívánt COM+ alkalmazás vagy alkalmazásproxy exportálására történik kísérlet. Az .msi kiterjesztésű fájl minden olyan Windows alapú ügyfélszámítógépre telepíthető, amelyen a Windows Installer program fut.

nem konfigurált komponens
Olyan COM-komponens, amely nem lett telepítve egy adott COM+ alkalmazásban.

Nulladik fázisú értesítési felületek
Olyan illesztők, amelyek az alkalmazások számára lehetővé teszik annak felderítését, hogy egy tranzakció készen áll-e a kétfázisú véglegesítési (2PC) protokoll alkalmazására. Ennek érdekében az illesztők el tudják végezni a műveleteket, és közölni tudják a tranzakciókezelővel, ha a műveletek befejeződtek.

objektumkészletezés
Olyan COM+ szolgáltatás, amely osztálypéldányokból álló csoportot hoz létre és elvégzi annak karbantartását, így a valamely objektum szolgáltatását igénybe venni kívánó ügyfelek azonnal hozzájutnak egy működő objektumra vonatkozó mutatóhoz, és nem kell megvárniuk, amíg a rendszer létrehozza az objektumot. Az objektumkészletezés jelentősen növelheti az alkalmazás teljesítményét, ha egy adott objektum létrehozása túl költséges lenne (például azért, mert az objektumhoz adatbázis-kapcsolatok szükségesek).

semleges apartman (neutral apartment, NA) modell
A semleges apartman támogatja objektumainak bármely száltípuson történő végrehajtását. A COM-komponensekhez és COM+ alkalmazásokhoz ez az ajánlott szálkezelési modell.

szerepkör alapú adatvédelem
A COM+ adatvédelmi szolgáltatása COM+ alkalmazások számára. A szerepkör egy COM+ alkalmazáshoz definiált felhasználói kategóriát jelent, amely az alkalmazás erőforrásaira vonatkozó hozzáférési engedélyek meghatározásához alkalmazható. A szerepköröket a fejlesztő rendeli hozzá a komponensekhez, objektumfelületekhez és metódusokhoz. A felhasználókat a rendszergazda rendeli hozzá a megfelelő szerepkörökhöz, ezáltal az adott szerepkörhöz tartozó felhasználó a szerepkörhöz hozzárendelt valamennyi erőforráshoz hozzáférhet.

tevékenység
Aszinkron komponensek esetében a tevékenység egy vagy több tranzakcióból álló logikai szálat jelöl. Ez a logikai szál olyan komponenseket tartalmaz, amelyek egy COM+ alkalmazásban vannak csoportosítva.

Transaction Internet protokoll (TIP)
A Transaction Internet protokoll (TIP) egy szabványos, kétfázisú véglegesítési protokoll, amely lehetővé teszi, hogy az összetett tranzakciókezelők összehangolják az elosztott tranzakciókat, különösen az Interneten keresztül.

A TIP kétfázisú véglegesítési protokoll egyszerűen alkalmazható, és független az alkalmazások közti kommunikációs protokolltól, ezért bármilyen alkalmazásprotokollal, de főként a HTTP protokollal együtt használható.

üzenetáthelyező
Aszinkron komponensek esetében olyan eszközt jelöl, amely a kézbesíthetetlen üzeneteket visszahelyezi a bementi várakozási sorba, így később ismét sor kerülhet a kézbesítésre. Az üzenetáthelyező az üzeneteket tranzakciószerűen helyezi át, így az üzenetek nem vesznek el és nem többszöröződnek akkor sem, ha az áthelyezés közben hiba történik.

XA illesztők
Olyan illesztők, amelyek segítségével az MTS alkalmazásfejlesztők hozzáférhetnek XA-kompatibilis adatbázisokhoz, illetve létrehozhatnak olyan erőforrás-kezelőket, amelyek relációs adatbázisokkal, üzenetsorral, tranzakciós fájlokkal és objektumorientált adatbázisokkal végeznek műveleteket. Bár a Microsoft nem támogatja közvetlenül az XA-protokollt, támogatja viszont az OLE-tranzakciók és az XA kölcsönös fordításához szükséges eszközöket.


Tallózás a felhasználói adatbázisban

A Komponensszolgáltatások felügyeleti eszközben akkor lehet szükség a felhasználói adatbázisban való tallózásra, ha egy felhasználó vagy csoport teljes nevét kell megkeresni. Az adatbázisban tallózva például megkeresheti azt a felhasználót, akinek hozzáférési jogokat kíván adni.

Tallózás a felhasználói adatbázisban
  1. A Felhasználók vagy csoportok hozzáadása párbeszédpanelen a Névlista forrása legördülő listában jelölje ki a hozzáadandó felhasználót vagy csoportot tartalmazó tartományt.
  2. Ha meg szeretné tekinteni a kijelölt tartományba tartozó felhasználókat, kattintson a Felhasználók gombra.
  3. Az adott csoport tagjainak megtekintéséhez jelölje ki a Név listában a csoportot, és kattintson a Tagok gombra.
  4. Ha nem találja a hozzáadandó felhasználót vagy csoportot, kattintson a Keresés gombra.
  5. A Fiók keresése párbeszédpanelen jelölje ki azt a tartományt, amelyben keresni szeretne (vagy kattintson a Keresés mindenhol gombra), a Felhasználó vagy csoport keresése mezőbe írja be a keresendő nevet, majd kattintson a Keresés gombra.

    Sikeres keresés esetén a felhasználó vagy csoport teljes neve megjelenik A keresés eredménye mezőben.

  6. Ha A keresés eredménye mező tartalmazza a keresett nevet, kattintson a Hozzáadás gombra.