Csatlakozáskezelő felügyeleti csomag

A Microsoft Csatlakozáskezelő olyan sokoldalú ügyféltárcsázó és kapcsolatfelvételi szoftver, amelyet a Csatlakozáskezelő felügyeleti csomag (CMAK) használatával testreszabhat. A csomag tartalmazza a Csatlakozáskezelő felügyeleti csomag varázslót és a Csatlakozáskezelő felügyeleti csomag útmutatóját.

  • A Csatlakozáskezelő felügyeleti csomag telepítése előtt olvassa el az Első lépések: A Csatlakozáskezelő és a Felügyeleti csomag ismertetése című témakört.
  • A testreszabási lehetőségek és az igények kielégítéséhez legmegfelelőbb beállítások kiválasztásának leírását a következő témakörben találhatja: 1. fázis: Tervezés, mely tartalmazza a tervezőlapot a terv kivitelezésének megkönnyítése érdekében.
  • Ha információkra van szüksége arról, hogyan tervezheti meg és készíthet el az igényeinek megfelelő egyedi grafikát, szöveget, programot és más elemeket, olvassa el a 2. fázis: Egyéni elemek kifejlesztése című részt.
  • A Csatlakozáskezelő felügyeleti csomag varázsló használatáról és speciális testreszabási technikákról a következő részben olvashat: 3. fázis: A Csatlakozáskezelő felügyeleti csomag varázsló futtatása és szolgáltatásprofil készítése.
  • A továbbítási lehetőségekről és módszerekről az alábbi témakör nyújt tájékoztatást: 4. fázis: Az integráció, a továbbítás és a telepítés előkészítése.
  • A teszteléssel kapcsolatban olvassa el az 5. fázis: A szolgáltatásprofil összetevőinek tesztelése című témakört.
  • A felmerülő problémák megoldásáról és más támogatási információkról az alábbi részben olvashat: 6. fázis: Az ügyfelek támogatása.


Bevezetés

Használja ezt a Csatlakozáskezelő felügyeleti csomag útmutató dokumentumot a Csatlakozáskezelő azon egyéni elemeinek megtervezéséhez és kifejlesztéséhez, amelyeket be szeretne építeni az ügyféltárcsázó programba. Ezután egyszerűen futtassa a Csatlakozáskezelő felügyeleti csomag varázslót, válaszoljon a feltett kérdésekre, és adja meg az egyéni elemekre vonatkozó adatokat. A Csatlakozáskezelő felügyeleti csomag varázsló ezután összeállítja a szolgáltatásprofilt, amely azoknak a fájloknak a halmaza, amelyek szétosztásra kerülnek a felhasználók között, hogy egyszerűen telepíthessék és futtathassák a Csatlakozáskezelőnek a szolgáltató által kialakított egyéni verzióját.

Célcsoport

A Csatlakozáskezelő felügyeleti csomag útmutató a rendszergazdák, informatikusok és egyéb olyan munkatársak részére készült, akik azoknak a kapcsolatfelvételi szoftvereknek a tervezésével, fejlesztésével, tesztelésével és támogatásával foglalkoznak, amelyeket az általuk nyújtott Internet- vagy hálózati szolgáltatáshoz kapcsolódó felhasználók vesznek igénybe.

Néhány szó a dokumentumról

A Csatlakozáskezelő felügyeleti csomag varázsló olyan alapértelmezett megoldásokat nyújt, amelyekkel gyorsan és könnyen létrehozhatók a Csatlakozáskezelő alapvető szolgáltatásprofiljai. Ha a szolgáltató az alapváltozatokat szeretné használni, és nem kíván élni a számos egyénileg kialakítható elem nyújtotta előnnyel, akkor valószínűleg nincs is szükség erre az útmutatóra.

Ha azonban olyan ügyféltárcsázó programot szeretne kialakítani, amely reklámozza a márkanevét és támogatja az olyan fejlettebb funkciókat is, mint az automatikus telefonkönyv-frissítés és az egyéni csatlakozási műveletek, szüksége lesz erre az útmutatóra a testre szabható elemek hatékony megtervezéséhez és kialakításához. Az egyedi kialakítás megkönnyítése érdekében a program tartalmaz egy tervezőlapot is, amelynek segítségével a szolgáltató dokumentálhatja az egyedi kialakítással szemben támasztott követelményeket, és követheti az ezen követelmények megvalósításához szükséges tervezési és fejlesztési erőfeszítéseket.

Megjegyzések

  • Az Útmutatóban található információk azon a feltevésen alapulnak, hogy a CMAK-szoftver már telepítve van. A Csatlakozáskezelő értékelésével és telepítésével kapcsolatos további információk a szoftver telepítésekor használt dokumentációban, illetve a Microsoft webhelyen található. (http://www.microsoft.com/).
  • Ezt az Útmutatót megtekintheti közvetlenül a Csatlakozáskezelő felügyeleti csomag varázslóból is, ha a Súgó gombra kattint. Ha egy párbeszédpanelen kattint a Súgó gombra, az adott párbeszédpanelhez kapcsolódó súgótémakör jelenik meg.


Mielőtt elkezdené: A Csatlakozáskezelő és a felügyeleti csomag ismertetése

A Csatlakozáskezelő grafikus felhasználói felületet nyújt ahhoz, hogy a szolgáltató ügyfelei a szolgáltató által meghatározott kapcsolatjellemzők alapján tudják a szolgáltatását igénybe venni. A Csatlakozáskezelő felügyeleti csomag varázsló leegyszerűsíti az egyedi elemek készítésének folyamatát azzal, hogy grafikus felületet biztosít a szolgáltatás egyéni elemeinek megadásához. Ezután a varázsló létrehozza a testre szabott telepítőcsomagot. A Csatlakozáskezelő felügyeleti csomag Útmutató ezen fejezete azokat az információkat tartalmazza, amelyek ismerete szükséges az egyedi kialakítás megkezdése előtt.

  • A Csatlakozáskezelő összetevői és a rendszerkövetelmények
  • A Csatlakozáskezelő szolgáltatásai
  • A Csatlakozáskezelő felhasználói felülete
  • A Csatlakozáskezelő felügyeleti csomag és a testreszabási folyamat
  • Csatlakozási pont szolgáltatás
  • Internet Explorer felügyeleti csomag


A Csatlakozáskezelő összetevői és a rendszerkövetelmények

Ez a fejezet a Csatlakozáskezelő összetevőit és a telepítésükhöz szükséges rendszerkövetelményeket ismerteti.

A Csatlakozáskezelő összetevői

A Csatlakozáskezelő telepítéséhez és használatához az ügyfélnek a következő összetevőkkel kell rendelkeznie:

  • Legalább egy szolgáltatásprofil (azoknak a fájloknak a készlete, melyek a Csatlakozáskezelő telepítéséhez és a szolgáltatáshoz való kapcsolódáshoz szükségesek), amely a Csatlakozáskezelő felügyeleti csomag varázsló segítségével állítható össze.
  • Microsoft Csatlakozáskezelő 1.2-es verzió (amely az ügyfelek számára biztosított szolgáltatásprofil része lehet).

A Csatlakozáskezelő használatához szükséges rendszerkövetelmények

A Csatlakozáskezelő számára a merevlemezen legalább 1 MB szabad hely szükséges, továbbá a következő operációs rendszerek egyike:

  • Windows 98
  • Windows 95
  • Windows NT Workstation 4.0 vagy későbbi verzió. Ajánlatos előzőleg telepíteni a Windows NT Service Pack legfrissebb verzióját. A Windows NT Service Pack 3 (és minden későbbi) csomag több modem és telefonos kapcsolati parancsfájl támogatását tartalmazza. A Windows NT Service Pack 4 további támogatásokat tartalmaz a virtuális magánhálózati (VPN) kapcsolatok kialakításához. A felhasználók a legfrissebb Hálózati és telefonos kapcsolatok szoftvert mint a Microsoft Windows egyik frissítését letölthetik a Microsoft on-line támogatási webhelyéről (http://support.microsoft.com/support/downloads/default.asp).

Megjegyzés

  • A szabad lemezterületre vonatkozó követelmény az operációs rendszertől függően, a szolgáltatásprofilban lévő elemek figyelembe vételével változhat. A teljes leszállított fájlmennyiség méretének meghatározásáról A hatékony megvalósítás megtervezése című fejezetben olvasható információ.

A telefonos kapcsolatokhoz a Csatlakozáskezelő mellett még egy, legalább 9600 átviteli sebességű modemre is szükség van. A modemet a Csatlakozáskezelő automatikusan konfigurálja. Ha a szolgáltatásprofilba beágyazza a Csatlakozáskezelő 1.2-es verzióját, a felhasználó modemje a Csatlakozáskezelő támogatásához szükséges módon lesz konfigurálva.

A Csatlakozáskezelőhöz a következő protokollok szükségesek: Transmission Control protokoll/Internet (TCP/IP) protokoll (hálózatban, egyenrangú kapcsolatokhoz), Telephone Application Programming Interface (TAPI) (telefonos kapcsolathoz) és Point-to-Point Tunneling (PPTP) protokoll (VPN-kapcsolat létrehozásához). A Csatlakozáskezelő telepítésekor a program automatikusan beállítja a szoftvereket a megfelelő szintre azokon a számítógépeken, amelyeken az operációs rendszer nem a megfelelő szintre van állítva. Kivétel ez alól a Windows NT 4.0, ahol a felhasználónak (a távelérés során) kézzel kell beállítania a PPTP-protokollt. Arról, hogy milyen információkat kell megadni a felhasználóknak a PPTP protokoll Windows NT 4.0 rendszeren történő beállításával kapcsolatban, A dokumentáció csatolása című fejezetben olvashat.

A Csatlakozáskezelő hálózati és telefonos kapcsolatok segítségével kapcsolódik egy távoli számítógéphez vagy hálózathoz. A felhasználóknak a telefonos hálózati szoftver legfrissebb verziójával kell rendelkezniük. Ha a szolgáltatásprofil támogatja a virtuális magánhálózati (VPN) kapcsolatokat, a Windows 95 operációs rendszert használóknak a VPN-kapcsolatok létrehozásához a telefonos és hálózati szoftver legfrissebb verziójára van szükségük. E követelménnyel kapcsolatban további információ A VPN-támogatás megvalósítása című témakörben található. Arról, hogy a felhasználóknak milyen információkra van szükségük a telefonos hálózati szoftver frissítésével kapcsolatban, olvassa el A dokumentáció csatolása című témakört.

Megjegyzés

  • A Csatlakozáskezelő hardver- és szoftverkövetelményeivel kapcsolatos információk - a konfigurációra vonatkozó követelményeket is beleértve - a Fontos.txt fájlban találhatók. Ha a Csatlakozáskezelő felügyeleti csomag varázslóban azt adja meg, hogy a szolgáltatásprofil a Csatlakozáskezelő 1.2 szoftvert tartalmazni fogja, a Fontos.txt fájl is automatikusan bekerül a szolgáltatásprofilba. Ha többet szeretne tudni arról, hogy ez a fájl hogyan módosítható úgy, hogy megfeleljen a felhasználók igényeinek, olvassa el A dokumentáció csatolása című témakört.


A Csatlakozáskezelő szolgáltatásai

A Csatlakozáskezelő 1.2 támogatja, hogy a felhasználók helyi vagy távoli csatlakozásokkal úgy kapcsolódjanak a szolgáltatóhoz, hogy közben igénybe vesznek olyan, hozzáférési pontokból álló hálózatokat, amilyeneket például az Internet-szolgáltatók bocsátanak felhasználóik rendelkezésére. Ha a szolgáltatás biztonságos Internet-kapcsolatokat igényel, a Csatlakozáskezelő segítségével virtuális magánhálózati (VPN) kapcsolatok hozhatók létre hozzá. A Csatlakozáskezelő 1.2 támogatása az alábbi főbb területekre terjed ki:

Általános kapcsolattámogatás

A Csatlakozáskezelő 1.2 számtalan olyan szolgáltatást támogat, amellyel Ön és a felhasználók is leegyszerűsíthetik és továbbfejleszthetik a kapcsolattámogatás megvalósítását. E szolgáltatások többsége a Csatlakozáskezelő felügyeleti csomag varázsló segítségével beépíthető a rendszerbe:
Szolgáltatás | Támogatás
Márkajelzés | A Csatlakozáskezelő programban az ábrák, ikonok, üzenetek, a Súgó és a telefonkönyv testreszabásával olyan azonosítási lehetőségek és támogatások alakíthatók ki, amelyek csak a szolgáltató szolgáltatására vagy vállalatára jellemzők. Az egyedi jelzések közé felvehetők a vállalatot azonosító és jelképező egyedi emblémák, az ügyfélszolgálati adatok és a telefonkönyvek.
Csatlakozási műveletek és automatikusan futó alkalmazások | A programba beépíthetők egyedi szolgáltatások, például saját programok, amelyekkel a felhasználó számára javítható a kapcsolat minősége. Ezek a programok automatikusan futtathatók a csatlakozási folyamat különböző szakaszai során, például amikor a felhasználó bejelentkezik vagy leválik a rendszerről. A Csatlakozáskezelő jelen verziója az első, amelyik támogatja a kapcsolatfelvétel előtti és a protokollbújtatás előtti műveleteket is. Azt is be lehet állítani, hogy az automatikusan futó alkalmazások a program végén automatikusan bontsák a kapcsolatot.
A Csatlakozáskezelő 1.2 több példánya | A szolgáltató olyan szolgáltatásprofilokat is biztosíthat a felhasználók számára, amelyeket azok egyszerre futtathatnak a Csatlakozáskezelő más szolgáltatásprofiljaival. Egyszerre futtathatnak például a felhasználók egy internetes eszközt és egy vállalati VPN bújtatási alagutat.
Több felhasználó támogatása minden szolgáltatásprofilban | A szolgáltató támogatást biztosíthat azoknak a felhasználóknak is, akik az egyes számítógépeket megosztva használják. A felhasználói profilok lehetővé teszik, hogy két vagy több személy is használja ugyanazt a számítógépet és ugyanazt a szolgáltatásprofilt. A bizonyítványokat a program a felhasználó bejelentkezési azonosítója alapján tartja nyilván, tehát a felhasználóknak nem kell azokat minden csatlakozáskor újra beírni.
Egyszerű terjesztés | Miközben a szolgáltató a Csatlakozáskezelő felügyeleti csomag varázslóval automatikusan kialakítja a szolgáltatásprofilt (a felhasználóknak a Csatlakozáskezelő futtatásához szükséges, testre szabott szoftvert), sor kerül egy öntelepítő végrehajtható (.exe) fájl létrehozására is, amely CD-re írható vagy elérhetővé tehető az Interneten.
Egyéni telefonkönyvek | A szolgáltató meghatározhatja, hogy a felhasználók mely telefonkönyveket kapják meg. Letöltheti a felhasználóknak a saját telefonkönyvét, amelyet a felhasználók bejelentkezésekor automatikusan frissíthet. A telefonkönyvek frissítése leegyszerűsíthető, ha a szolgáltató meglévő szolgáltatásprofilok egybeolvasztásával egyesíti a létező telefonkönyveket.

A VPN-kapcsolat támogatása

Az alapvető telefonos kapcsolatok számára biztosított támogatás mellett a szolgáltató a Csatlakozáskezelő felügyeleti csomag varázsló segítségével támogathatja a bújtató protokollt használó VPN-kapcsolatok nyilvános hálózaton keresztül történő bújtatását is (például akkor, amikor egy vállalati kiszolgáló elérése céljából fel kell hívni egy Internet-szolgáltatót). A Csatlakozáskezelő egy már meglévő telefonos kapcsolaton, helyi hálózaton (LAN) vagy digitális előfizetői vonalon (DSL) keresztül létesíthet VPN-kapcsolatokat.
Szolgáltatás | Támogatás
Közvetlen kapcsolatok | A VPN-kapcsolatokkal támogathatja a közvetlen kapcsolatokat is (amelyek mindig bekapcsolt vagy állandó kapcsolat néven is ismertek). A közvetlen kapcsolatok támogatása magába foglalja a kábeles, az aszimmetrikus előfizetői vonalas (ADSL) és az egyéb közvetlen kapcsolattípusokat is.
Protokollok | A szolgáltató meghatározhatja, hogy kívánja-e támogatni a VPN-kapcsolatokat, ugyanis ez lehetővé teszi, hogy a felhasználók a szolgáltatásához való kapcsolódáskor Point-to-Point Tunneling protokollt (PPTP-t), illetve Windows 2000 futtatása esetén, IPsec titkosítású Layer Two Tunneling protokollt (L2TP) használjanak bújtatóprotokollként. Ezek a protokollok a közvetlen és telefonos kapcsolatok fokozott védelmét biztosítják.


A Csatlakozáskezelő felhasználói felülete

A Csatlakozáskezelő felhasználói felülete a bejelentkezési párbeszédpanelből és néhány tulajdonság-párbeszédpanelből áll. Utóbbiak segítségével a felhasználók igényeiknek megfelelő módon állíthatják be a kapcsolatokat. A szolgáltató által kialakított szolgáltatásprofiltól függ, hogy a felhasználók előtt milyen elemek jelennek meg.

Bejelentkezési párbeszédpanel

Gyakran a bejelentkezési párbeszédpanel a Csatlakozáskezelő egyetlen olyan képernyője, amely megjelenik a felhasználók előtt, amikor a szolgáltatáshoz kapcsolódnak. Ezen a párbeszédpanelen adják meg a felhasználók hitelesítő adataikat (például felhasználói nevüket és felhasználói jelszavukat), hogy csatlakozhassanak a hálózati kiszolgálókhoz. A szolgáltató igény szerint alakíthatja ki a szolgáltatás nevét, az ábrákat, a támogatási információt és a párbeszédpanel egyéb elemeit.

Bejelentkezési párbeszédpanel

Tulajdonságok párbeszédpanel

A Szolgáltatásprofil_szolgáltatásnév tulajdonságai párbeszédpanel akkor jelenik meg, amikor a felhasználó a bejelentkezési párbeszédpanelen a Tulajdonságok gombra kattint.

Megjegyzés

  • A párbeszédpanel címsorában a szolgáltatásprofil adott szolgáltatásának neve szerepel a tulajdonságai szó előtt, de ebben a dokumentumban csak mint Tulajdonságok párbeszédpanel szerepel.
Tulajdonságok párbeszédpanel

Tulajdonságok, Általános lap

Az Általános lapon a felhasználó beállíthatja, hogy rendszere hogyan kapcsolódjon az Internet-szolgáltatóhoz, amikor a kívánt szolgáltatást el szeretné érni.

  • Ha a biztosított szolgáltatásprofil támogatja a virtuális magánhálózati (VPN) csatlakozásokat, a felhasználók dönthetnek úgy, hogy egy, az Interneten keresztül már korábban létrehozott közvetlen kapcsolatot használnak, vagy pedig egy telefonos kapcsolatot létesítenek, és megadják a telefonos kapcsolat létrehozásához szükséges telefonszámokat és egyéb adatokat.
  • Ha a rendelkezésre álló szolgáltatásprofil nem támogatja a VPN-kapcsolatokat, a felhasználók előtt nem jelenik meg a közvetlen kapcsolatokra vonatkozó beállítási lehetőség, azonban a telefonos hálózati kapcsolat létrehozásához szükséges telefonszámok és egyéb adatok megadására továbbra is mód van.

Ezen a lapon a felhasználók a telefonos kapcsolathoz szükséges alábbi információkat adhatják meg:

  • A kapcsolat létrehozásához tárcsázandó telefonszám. A felhasználó beírhatja a számot, vagy a Telefonkönyv gombra kattintva egy listából kiválaszthatja azt.

    Ha a felhasználó a Telefonkönyv gombra kattint, a Telefonkönyv párbeszédpanelen található listáról kijelölheti a megfelelő kapcsolódási pontot (POP). A listán csak azok a telefonszámok jelennek meg, amelyeket a kijelölt szolgáltatástípusra, országra (vagy körzetre) és államra (vagy tartományra) vonatkozó beállítások támogatnak.

    A További telefonszámok mezőben csak akkor láthatók telefonszámok, ha a telefonkönyvet úgy állítja be, hogy az támogassa ezt a második számgyűjteményt (amely például a vonaltúlterhelés esetén igénybe vehető számokat tartalmazhatja, ha a telefonkönyv létrehozása a Csatlakozási pont szolgáltatás használatával történt). Ha a telefonkönyvben nincsenek megadva további telefonszámok a kiválasztott földrajzi területhez, akkor ez a mező üresen marad. Ha a szolgáltató a Csatlakozáskezelő felügyeleti csomag varázslóban megadja, hogy egyedi szöveg jelenjen meg a További telefonszámok mező mellett, akkor a szöveg csak abban az esetben jelenik meg, ha a kijelölt földrajzi területhez tartoznak telefonszámok.

  • Az adott körzetben érvényes tárcsázási szabályok. Ha a felhasználó az Általános lapon a Tárcsázási szabályok gombra kattint, megadhatja a tartózkodási helyén érvényes tárcsázási szabályokat, például a hívókártya-számokat, a városi vonalhoz és a távolsági híváshoz szükséges előhívó számokat, vagy más helyekre vonatkozó adatokat a későbbi felhasználás céljából.
  • Az eszköztípus, mellyel a felhasználók a szolgáltatáshoz kapcsolódnak. Csak a telepített és elérhető eszköztípusok jelennek meg az Kapcsolatkor listában.

Tulajdonságok, Internetes bejelentkezés lap

Az Internetes bejelentkezés lapon a felhasználók megadják a virtuális magánhálózati (VPN) csatlakozáshoz használni kívánt felhasználói nevüket és jelszavukat. Ez a lap csak akkor jelenik meg, ha a szolgáltató a Csatlakozáskezelő felügyeleti csomag varázslóban:

  • beállítja a VPN-kapcsolatok támogatását, és
  • nem jelöli be az Ugyanannak a felhasználónévnek és jelszónak a használata VPN-kapcsolatoknál, mint telefonos kapcsolatnál jelölőnégyzetet.

Tulajdonságok, Beállítások lap

A Beállítások lapon a felhasználók megváltoztathatják az aktív kapcsolatok létrehozására és fenntartására vonatkozó alapértelmezett beállításokat. A felhasználók módosíthatják mind a kapcsolatfelvételi kísérletek számát, mind pedig annak a tétlen időszaknak a hosszát, amely után a Csatlakozáskezelő megszakítja a kapcsolatot.

További képernyők

A szolgáltatásprofil beállításától függően más képernyők is megjelenhetnek a kapcsolatfelvétel során. Beállítható például, hogy megjelenjen-e licencszerződés, amikor a felhasználó telepíti a Csatlakozáskezelő programot. A szolgáltatásprofilba be lehet építeni súgóképernyőket és egyéb üzeneteket is.


A Csatlakozáskezelő felügyeleti csomag és a testreszabási folyamat

A Csatlakozáskezelő ellátható a cég emblémájával, ami azt jelenti, hogy a szolgáltató a megrendelőknek szállítandó telepítőcsomagot testreszabhatja, és feltüntetheti benne cége nevét. Meghatározhatja a beépítendő funkciók és szolgáltatások körét, illetve azt, hogy a Csatlakozáskezelő hogyan jelenjen meg a felhasználók előtt. Az egyéni szolgáltatásprofilok a Csatlakozáskezelő felügyeleti csomag varázsló segítségével hozhatók létre.

A szolgáltatásprofil magába foglalja mindazokat a fájlokat, amelyek a Csatlakozáskezelő számára szükségesek a telepítőfájl futtatásához, illetve ahhoz, hogy a felhasználók számára lehetővé tegye a kapcsolat létrehozását a szolgáltatóval. A szolgáltatásprofilba beágyazni kívánt összetevők mennyiségétől függően a céget azonosító elemekből több vagy kevesebb építhető be. Beépíthetők például a cég emblémái, vagy más grafikák, saját ikonok, illetve saját on-line súgó. Automatikusan elinduló alkalmazásokkal is kiegészíthető a program, a szolgáltató meghatározhatja a kapcsolat létrejötte előtt, közben vagy után végrehajtandó műveleteket, de testreszabhatja a Csatlakozáskezelő 1.2 más szolgáltatásait is.

A Csatlakozáskezelő nyújtotta támogatás és a program szolgáltatásainak testreszabásához az adott szolgáltatásprofil egyedisége kétféleképpen biztosítható:

  • A Csatlakozáskezelő felügyeleti csomag varázsló futtatása (ez szükséges a szolgáltatásprofil létrehozásához).
    A Csatlakozáskezelő felügyeleti csomag varázsló segítségével a Csatlakozáskezelő szolgáltatásainak nagy része a szolgáltatásprofil létrehozása közben szabható testre. A varázsló segítségével meg lehet adni például azt a nevet és azokat a képeket, amelyeket a Csatlakozáskezelő futtatásakor a felhasználók látnak majd, meghatározható számukra, hogy a szolgáltató a szolgáltatáshoz virtuális magánhálózati (VPN) kapcsolatot kíván-e biztosítani, illetve hogy a kapcsolat létrejöttekor sor kerül-e egyéni alkalmazások futtatására. A testreszabás mértéke a szolgáltató és ügyfelei igényeitől függ. Működése végén a varázsló automatikusan létrehozza az egyéni kialakítású szolgáltatásprofilt.
  • Speciális eljárások használata a testreszabáshoz (választható).
    Némely esetben szükség lehet olyan funkciók és szolgáltatások testreszabására, amelyek egyedi kialakítása a varázsló segítségével nem lehetséges. Miután a szolgáltató a Csatlakozáskezelő felügyeleti csomag varázsló segítségével létrehozta a szolgáltatásprofilt, más szolgáltatásokat egyéb eljárások használatával tehet egyedivé. Támogathatja például a közvetlen kapcsolatot, kikapcsolhatja a Jelszó mentése funkciót, illetve testreszabhat más összetevőket, amelyek a Csatlakozáskezelő felügyeleti csomag varázsló segítségével nem alakíthatók egyedivé.

Minden létrehozott szolgáltatásprofil tartalmazza az önálló öntelepítő csomagokba épített, azonnal használható egyéni szolgáltatásokat, így a felhasználók problémamentesen kapcsolódhatnak a szolgáltatóhoz.

Bár a Csatlakozáskezelő felügyeleti csomag varázsló segítségével könnyen létrehozhatók egyéni szolgáltatásprofilok, a saját összetevők kialakítása gondos tervezést és fejlesztést igényel. Az alábbi útmutató a tervezés, a fejlesztés és a kivitelezés hat fázisát mutatja be:

Fázis | Feladatok | Felelős személyek
1 | A Csatlakozáskezelő egyéni szolgáltatásainak kiválasztása, illetve ennek dokumentálása. Az e feladatok végrehajtásához szükséges információk az Első fázis: a tervezés című lapon olvashatók, ahol a testreszabás megtervezését és dokumentálását segítő űrlap is megtalálható. | Hálózati rendszergazda vagy technikai vezető
2 | Telefonkönyv és más egyéni összetevők, grafika, szöveg vagy kapcsolódó alkalmazások tervezése és fejlesztése (igény szerint). Az e feladatok végrehajtásához szükséges információk a Második fázis: egyéni elemek kifejlesztése című lapon találhatók. | Technikai csoport
3 | A Csatlakozáskezelő felügyeleti csomag varázsló segítségével az egyéni szolgáltatásprofilok létrehozása, majd a megfelelő további eljárások segítségével testreszabásuk befejezése a Harmadik fázis: a Csatlakozáskezelő felügyeleti csomag varázsló futtatása és szolgáltatásprofil készítése című lapon található információk alapján. | Technikai vezető vagy a technikai csoport tagja
4 | A csomag terjeszthetőségének ellenőrzése, beleértve az integrálás követelményeit. Lásd: a Negyedik fázis: az integráció, a szállítás és a telepítés előkészítése című lapot. | Technikai vezető vagy a technikai csoport tagja
5 | A Csatlakozáskezelő szállítandó összetevőinek (köztük az összes egyéni összetevő) tesztelése valamennyi célplatformon és operációs rendszeren az Ötödik fázis: a szolgáltatásprofil összetevőinek tesztelése című lapon szereplő eljárások és feltételek szerint. | Tesztelők vagy a technikai csoport más tagjai
6 | Megbízható hibaelhárítás és egyéb támogatás biztosítása az ügyfelek részére. Lásd: a Hatodik fázis: az ügyfelek támogatása című lapot. | Ügyfélszolgálati csoport


Csatlakozási pont szolgáltatás

A Microsoft csatlakozási pont szolgáltatása (CPS) segítségével egyéni telefonkönyvek automatikus terjesztésére és frissítésére nyílik lehetőség. Ezek a telefonkönyvek egy vagy több csatlakozási pont (POP) bejegyzést tartalmaznak, melyek a megadott telefonszámon keresztül biztosítanak hozzáférést egy internetes csatlakozási ponthoz. A telefonkönyvek a felhasználókat teljes körű információval látják el a csatlakozási pontokkal kapcsolatban, így nem csak egyetlen POP-átjárón át, hanem különböző pontokon keresztül érhetik el az Internetet.

Telefonkönyv-frissítési lehetőség híján (amit a Csatlakozási pont szolgáltatás automatikusan elvégez) a felhasználóknak az ügyfélszolgálathoz kellene fordulniuk, hogy tájékozódjanak a POP-információk változásairól, és újra kellene konfigurálniuk a tárcsázó ügyfélprogramot.

A Csatlakozási pont szolgáltatás két összetevőből áll:

  • Telefonkönyv-felügyelő, amely a telefonkönyv-adatbázis létrehozására és karbantartására szolgál, illetve az új információt továbbítja a Telefonkönyv-szolgáltatás részére.
  • Telefonkönyv-szolgáltatás, amely a Microsoft Internet Information Services (IIS) kiegészítése. Windows NT Server 4.0-s vagy annál újabb verziókon fut (az IIS is szükséges). A Telefonkönyv-szolgáltatás automatikusan ellenőrzi az előfizetők vagy vállalati alkalmazottak aktuális telefonkönyvét, és ha szükséges, letölti azokhoz a frissítést.

A Connection Point Services 1.2 program a Windows 2000 Server rendszer egyik komponense.

Telefonkönyvek készítésével kapcsolatban további információ a Telefonkönyv-támogatás című részben található. A Csatlakozási pont szolgáltatásról részletesebb leírás olvasható a Csatlakozási pont szolgáltatás dokumentációjában.


Internet Explorer felügyeleti csomag

A Csatlakozáskezelő testreszabható, önálló telepítő csomagként kerül terjesztésre. Ha azonban a szolgáltató az Internet Explorer Administration Kit 5 (IEAK 5) segítségével készíti el az Internet Explorer 5 telepítőcsomagját, ügyfelei számára megkönnyítheti a telepítést, ha saját Csatlakozáskezelő szolgáltatásprofilját építi be a csomagba. Az integrált telepítőcsomag használatával a felhasználók egy lépésben hajthatják végre a telepítést, és ugyanazt a felhasználónevet, jelszót, valamint telefonszámot adhatják meg mindkét programhoz.

Az IEAK 5 segítségével a Csatlakozáskezelő és az Internet Explorer 5 testreszabásával és integrálásával kapcsolatos legtöbb feladat végrehajtható. Ennek az integrációnak a hatásáról további információ A hatékony megvalósítás megtervezése című témakörben olvasható. A Csatlakozáskezelő és az Internet Explorer 5 együttes alkalmazásáról további információk A Csatlakozáskezelő integrálása az Internet Explorer telepítőcsomaggal című témakörben találhatók.


Első fázis: a tervezés

Ez a rész támogatást nyújt ahhoz a tervezéshez, amelyet el kell végezni, mielőtt a Csatlakozáskezelő felügyeleti csomag varázsló futtatásával egyéni szolgáltatásprofilok létrehozására kerülne sor:

  • Az egyéni kialakítású elemek meghatározása. Ebben a részben a Csatlakozáskezelő testreszabható és a szolgáltatásprofilba beépíthető szolgáltatásainak áttekintése található.
  • A hatékony megvalósítás megtervezése. Ez a rész azokat a tényezőket tárgyalja, amelyeket figyelembe kell venni az egyéni szolgáltatásprofil kialakításának megtervezése előtt. Így könnyebben átlátható, hogy a meghozott döntések milyen hatással lesznek a szolgáltatásprofil szállítandó összetevőire. Ez a rész bemutatja a szolgáltatásprofil más telepítőcsomaggal történő integrálásának következményeit, illetve segít a terjesztési és telepítési módszer megválasztásában.
  • Tervezőlap a Csatlakozáskezelő 1.2-es verziójához. A tervezőlap a tervezés mindazon részleteire kiterjed, amelyekre az egyéni szolgáltatásprofil, illetve az abba beépítendő egyéni összetevők létrehozásakor szükség van. Nagy segítséget nyújt az egyéni kialakítás során hozott döntések dokumentálásában. A tervezőlap kitöltése és az azon meghatározott tervezési és fejlesztési folyamatok után az egyéni profil kialakításához szükséges minden információ és egyéni összetevő rendelkezésre fog állni.


Az egyéni kialakítású elemek meghatározása

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével a szolgáltatásprofil testreszabásának nagy része elvégezhető. A Csatlakozáskezelő felügyeleti csomag varázsló futtatása előtt a szolgáltatónak el kell döntenie, hogy mely elemeket szeretné egyénivé tenni, majd meg kell adnia azokat az információkat és fájlokat, amelyekre a varázslónak szüksége van a terv megvalósításához.

Bár a szolgáltatásprofil úgy is létrehozható a varázslóval, hogy a szolgáltatás nevén, illetve a szolgáltatásprofil-fájlok névformátumán kívül más információ nincs megadva, a szolgáltató számos egyéb elemet is az igényeihez igazíthat. Például:

  • Korábban létrehozott szolgáltatásprofilokat építhet be a készítendő profilba, hogy azokból telefonkönyveket vagy más elemeket lehessen átvenni.
  • A Csatlakozáskezelő bejelentkezési párbeszédpaneljén feltüntetheti az ügyfélszolgálat telefonszámát, illetve az ügyfélszolgálattal kapcsolatos egyéb információkat.
  • Megadhatja a felhasználónévhez tartozó tartománynevet (elő- vagy utótagot). (Ezzel meghatározhatók az Internet-szolgáltató által igényelt, a hálózati útválasztásra vonatkozó, illetve hitelesítő információk, így nem az ügyfeleknek kell megismerniük és megadniuk azokat.)
  • Megadhatók a felhasználók számára biztosított telefonkönyvben szereplő telefonszámokhoz tartozó telefonos hálózati bejegyzések.
  • Támogathatja az Interneten keresztüli virtuális magánhálózati (VPN) kapcsolatokat is.
  • Beépíthet a csatlakozási folyamat megadott pontjain elinduló csatlakozási műveleteket.
  • A Csatlakozáskezelő alapértelmezett grafikáinak helyére saját grafikáit illesztheti be a bejelentkezési párbeszédpanelen, illetve a telefonkönyv-párbeszédpanelen.
  • A felhasználók számára telefonkönyvet és telefonkönyv-frissítési lehetőséget biztosíthat.
  • A Csatlakozáskezelő alapértelmezett ikonjainak helyére saját ikonjait építheti be.
  • A kapcsolat létesítésekor az állapotsoron megjelenő ikon helyi menüje is testreszabható.
  • A Csatlakozáskezelő alapértelmezett Súgója egyénivé alakítható.
  • A Csatlakozáskezelő 1.2 szoftver beépíthető a szolgáltatásprofilba.
  • A szolgáltatásprofilhoz végfelhasználói licencszerződést (EULA) lehet mellékelni, melynek elfogadása nélkül a felhasználók nem telepíthetik a szolgáltatásprofilt.
  • A szolgáltatásprofilba további támogatások (például felhasználói dokumentáció, saját programok és a megadott csatlakozási műveleteket támogató fájlok) építhetők be.

Minden létrehozandó szolgáltatásprofil esetében érdemes végiggondolni ezeket a lehetőségeket. A célközönségtől és más tényezőktől függően különböző elemek használhatók a szolgáltatásprofil elkészítéséhez. A megvalósítás előtt célszerű elgondolkodni a döntések következményein, és az esetleges integrációs kérdéseket is érdemes végiggondolni. Az integráció, a terjesztés, a telepítés és más, a megvalósítás szempontjából lényeges szempontok figyelembe vételével történő tervezéssel kapcsolatban olvassa el A hatékony megvalósítás megtervezése című témakört. Az említett fejezetben megtalálhatók a hatékony és eredményes tervezéshez és fejlesztéshez szükséges információk. Az egyedi kialakítás és a fejlesztés fázisainak követéséhez és rögzítéséhez felhasználhatja a Tervezőlap a Csatlakozáskezelő 1.2-es verziójához című részben található tervezőlapot.


A hatékony megvalósítás megtervezése

Az egyéni kialakításkor meghozott döntéseknél figyelembe kell venni, hogy ezek a döntések hogyan befolyásolják a Csatlakozáskezelő megvalósítási módszereit. A szolgáltatásprofil megtervezésekor figyelembe kell venni, hogy a megvalósítás hogyan fog hatni a következőkre:

  • A létrehozni kívánt szolgáltatásprofilok száma
  • Az alkalmazni kívánt kézbesítési mód
  • Egyszerű telepítés kiegészítő komponensek segítségével
  • A Csatlakozáskezelő szolgáltatásprofiljának integrálása az Internet Explorer telepítőcsomaggal
  • A szolgáltatásprofil mérete
  • A telepíteni kívánt telefonkönyv-támogatás
  • A szolgáltatásprofil karbantartási és frissítési igényei, beleértve a profilhoz tartozó összes fájlt

Az alábbi fejezetek bemutatják, hogy a szolgáltatásprofil testreszabása hogyan érinti annak megvalósítását. Több profil létrehozásáról, illetve azok karbantartásával kapcsolatosan további információ A szolgáltatásprofilok beállítása című témakörben található.

A szükséges szolgáltatásprofilok száma

Felhasználók vagy alkalmazottak adott csoportjának speciális igényei további szolgáltatásprofilok létrehozásával elégíthetők ki. Ha például a cég több települést szolgál ki, szükség lehet arra, hogy a különböző települések számára különböző profilok készüljenek, amelyek mindegyikébe be van építve egy helyi telefonkönyv-adatbázis. A szolgáltatás által támogatott egyes operációs rendszerekhez önálló profilok is készíthetők.

Ha a felhasználó egynél több szolgáltatásprofilt telepít, mindegyik profil külön mappába kerül. A profilok megosztva használják a Csatlakozáskezelő 1.2 programot.

Ha a szolgáltató másik nyelven szeretne támogatást biztosítani a felhasználóknak, akkor a Csatlakozáskezelő felügyeleti csomag varázslót olyan számítógépen kell futtatnia, amelyen a kívánt nyelven honosított operációs rendszer működik.

Melyik terjesztési mód a megfelelő?

A szolgáltatásprofil terjeszthető CD-n, illetve fájlként letölthető (magánhálózatról vagy az Internetről). A megfelelő terjesztési mód kiválasztásához figyelembe kell venni az egyéni profil méretét, a hozzá tartozó valamennyi fájllal együtt. Nem szabad elfeledni, hogy a letöltési idő nagy jelentőségű a felhasználók - különösen a viszonylag alacsony sebességű modemet használók - szempontjából.

Ha az Internet Explorer 5 program terjesztése az Internet Explorer Administration Kit 5 (IEAK 5) csomag segítségével történik, akkor a felhasználók számára egyszerűbbé tehető a telepítés, ha a Csatlakozáskezelő szolgáltatásprofilt a szolgáltató beépíti az Internet Explorer telepítőcsomagba. Az integrált telepítőcsomag használatával a felhasználók egy lépésben telepíthetik, és azonnal használhatják mind az Internet Explorer, mind pedig a Csatlakozáskezelő programot, mégpedig úgy, hogy bejelentkezéskor ugyanazt a felhasználónevet, jelszót és telefonszámot adhatják meg. Az Internet Explorer telepítőcsomagjában található fájlokat nem szabad beépíteni a Csatlakozáskezelő profilba.

A szolgáltatásprofil mérete

Fontos, hogy a terjesztés módja megfeleljen a szolgáltatásprofil méretének. Ehhez végig kell gondolni, hogy mely szolgáltatásokra van szükség, és a szolgáltató hogyan tervezi a profil terjesztését: CD-lemezen vagy letölthető fájlként.

Ha letölthető fájlként kívánja megoldani a terjesztést, gondolni kell például arra, hogy a letöltési idő milyen hatással lesz a felhasználókra. Előfordulhat, hogy más terjesztési módot kell választani vagy felajánlani. A Csatlakozáskezelő felügyeleti csomag varázsló nem támogatja a több lemezen terjeszthető profilokat, így ha a profil nem fér el egy lemezen, nem is ajánl fel lehetőségeket.

A Csatlakozáskezelő programot tartalmazó szolgáltatásprofilok mintegy 800 kilobájt helyet igényelnek a lemezen. A Csatlakozáskezelő programot nem tartalmazó szolgáltatásprofilok helyigénye mintegy 200 kB. A szolgáltatásprofil teljes mérete az egyéni beállításoktól függ, vagyis attól, hogy milyen a telefonkönyv-szolgáltatás típusa, vannak-e csatlakozáskor elinduló alkalmazások vagy más, választható programok, illetve milyenek a felhasznált grafikus elemek.

Megjegyzés

  • Ha a lemezen van elég hely, érdemes beépíteni a Csatlakozáskezelő programot a szolgáltatásprofilba: így biztosítható, hogy a felhasználók mindig a legújabb verzióval rendelkezzenek.

Hogyan egyszerűsíthető a telepítés a felhasználók számára?

A telepítés és a frissítések elvégzése megkönnyíthető a felhasználók számára, ha a profilba olyan programok és fájlok kerülnek beépítésre, amelyek automatikusan telepíthetők és konfigurálhatók a Csatlakozáskezelő telepítőcsomag részeként. Mindazonáltal érdemes ezeket a szolgáltatásokat az adott felhasználói kör igényeihez igazítani, hogy a terjesztendő szolgáltatásprofil mérete szabályozható legyen, és biztosítani lehessen a szolgáltatás hatékony használatát. Ha például egy vállalati ügyfél marketing és könyvelési osztállyal is rendelkezik, a két részleg számára külön profil létrehozására lehet szükség: a marketing osztály telefonkönyve lefedné az értékesítés egész területét, míg a könyvelési osztály telefonkönyvében csak a helyi telefonszámok szerepelnének.

Hogyan integrálható a szolgáltatásprofil az Internet Explorer telepítőcsomagba?

A tervezést befolyásolja, hogy a szolgáltató az egyéni szolgáltatásprofilt és a Csatlakozáskezelő programot integrálni kívánja-e az Internet Explorer telepítőcsomagjával vagy más programcsomaggal. Az integráció hatásainak meghatározásához a szolgáltatásprofil létrehozása előtt meg kell határozni a terjesztés módját.

Ha a szolgáltató például úgy dönt, hogy a Csatlakozáskezelő szolgáltatásprofilt az Internet Explorer felügyeleti csomag (IEAK) segítségével létrehozott telepítőcsomaggal integrálja, előfordulhat, hogy a profilba beépített grafikákat esetleg egyeztetni szeretné azokkal, amelyeket a telepítőcsomagba kíván beépíteni.

Ha a Csatlakozáskezelő szolgáltatásprofilt Internet Explorer telepítőcsomaggal együtt szeretné terjeszteni, mindkettőt létrehozhatja az IEAK 5 varázslóval, hiszen ebből közvetlenül meghívható a Csatlakozáskezelő felügyeleti csomag varázsló.

A szolgáltatásprofil létrehozása után olvassa el a Negyedik fázis: az integráció, a szállítás és a telepítés előkészítése című témakört, melyből meghatározhatók azok a további lépések, amelyek a szolgáltatásprofil más csomagokkal történő integrálásához szükségesek.

Milyen telefonkönyvek támogatása szükséges?

Megadható egyetlen telefonszám a felhasználók számára a csatlakozások létesítéséhez, de a központi hozzáférés is támogatható a hozzáférési pontokat tartalmazó telefonkönyv biztosításával. A csatlakozási pont szolgáltatás segítségével automatikusan frissített telefonkönyv-támogatás biztosítható, azonban létre kell hozni az alapul szolgáló telefonkönyveket, és a Csatlakozáskezelő felügyeleti csomag varázsló futtatása előtt meg kell határozni a telefonkönyv támogatásához használni kívánt módszert. További tájékoztatásért olvassa el a Csatlakozási pont szolgáltatás című témakört.

Mi szükséges a létező szolgáltatásprofilok karbantartásához és használatához?

A szolgáltatásprofilba különböző típusú fájlok építhetők be. A Csatlakozáskezelő programot a felhasználók igényeihez lehet igazítani. Módosíthatók vagy beépíthetők más profilok, programfájlok csatolhatók a csatlakozáskor végrehajtandó műveletek és az automatikusan elinduló alkalmazások támogatásához, felhasználói dokumentáció biztosítható, valamint számos egyéb típusú fájl építhető be.

A szolgáltatásprofilokat karban kell tartani, hogy mindig a beépített fájlok megfelelő verziójának alkalmazására kerüljön sor, ezért érdemes tudni azt, hogy miként építi be, illetve használja ezeket a fájlokat a Csatlakozáskezelő felügyeleti csomag varázsló. A profil fájljainak és mappáinak beállításáról további információ A szolgáltatásprofilok beállítása című témakörben található.

Amikor egy másik profillal egyesített szolgáltatásprofil módosítása történik, a Csatlakozáskezelő felügyeleti csomag varázsló a másik beépített profil legújabb verzióját próbálja használni. Ha a Csatlakozáskezelő felügyeleti csomag varázsló az adott profilt nem találja a megfelelő \Program Files\CMAK\Profiles\Szolgáltatásprofil_fájlneve mappában, akkor a varázsló a módosítandó profilba eredetileg beépített verziót tekinti alapértelmezettnek.

Az adatok és összetevők könnyebb karbantartása és frissítése érdekében a profilokat jól meg kell tervezni, különös tekintettel a beépített fájlokat tartalmazó profilokra.


Tervezőlap a Csatlakozáskezelő 1.2-es verziójához

A Csatlakozáskezelő felügyeleti csomag varázsló futtatása során számos, a munkakörnyezetre vonatkozó kérdésre kell válaszolnia, illetve meg kell adnia a szükséges adatokat. Ezeket az adatokat az ebben a témakörben megtalálható tervezőlap segítségével még a varázsló futtatása előtt összegyűjtheti, így a varázsló megszakítás vagy újraindítás nélkül futtatható. A tervezőlap egyben a testreszabási folyamat lépéseinek nyomon követésére is használható. Az alábbi tervezőlap egyaránt alkalmas a varázsló futtatásához és a speciális testreszabási beállításokhoz szükséges adatok rögzítésére. Ajánlott minden szolgáltatásprofilhoz külön tervezőlapot kitölteni. Ha bizonyos egyéni beállításokat az összes szolgáltatásprofilra vonatkozóan egységesíteni szeretne, a profilok létrehozása előtt módosíthatja a sablonfájlokban megadott alapértelmezett beállításokat. A Csatlakozáskezelő felügyeleti csomag varázsló ezeket a sablonfájlokat használja az összes szolgáltatásprofil létrehozásához. A sablonok szerkesztésével kapcsolatos információ a Speciális testreszabás: szolgáltatásprofil-fájlok szerkesztése című részben található.

A tervezőlap kitöltése során olvassa el valamennyi tételt, és döntse el, hogy melyeket kívánja felhasználni a Csatlakozáskezelő egyéni szolgáltatásprofiljának kialakításához. A felvenni kívánt tételek melletti jelölőnégyzetet jelölje be az első (Szükséges) oszlopban. Ezután adja meg a tételre vonatkozó szükséges információkat. A felvenni nem kívánt tételek jelölőnégyzetét és adatmezőit hagyja üresen.

Egyes jelölőnégyzetek már be vannak jelölve. Ezek azok a tételek, amelyekre minden szolgáltatásprofilhoz szükség van. Ezeknél a tételeknél meg kell adnia minden szükséges információt.

A tervezőlapot kitöltheti a számítógép használatával, és az ablak felső részén látható menü Nyomtatás parancsával kinyomtathatja; vagy kinyomtathatja az üres munkalapot, hogy később írja be az adatokat. Ha a tervezőlapot a képernyőn tölti ki, mindenképpen nyomtassa ki az ablak bezárása előtt, mivel az adatok mentésére nincs lehetőség. A tervezőlapon szereplő hivatkozásokkal megnyitható célfájlok mindig új ablakban jelennek meg, így az űrlapra már beírt adatok nem vesznek el.

Az egyéni elemek fejlesztése során folyamatosan frissítse a tervezőlapot, hogy megállapíthassa, mely információkat kell még megadnia.

A második (Kész) oszlop jelölőnégyzeteit csak azoknál a tételeknél jelölje be, amelyekre vonatkozóan valamennyi kivitelezési követelménynek eleget tett. (A követelményekről részletesebben a Második fázis: egyéni elemek kifejlesztése című részben olvashat.)

Megjegyzés

  • Az űrlapon megadott információk törlésig megmaradnak. Az információk törlése előtt célszerű az űrlapot kinyomtatni. A bevitt adatok törléséhez kattintson az űrlap alján vagy tetején található Alaphelyzet gombra.

1. rész: A Csatlakozáskezelő felügyeleti csomag varázsló futtatásához szükséges információk

Szükséges Kész A megvalósításhoz szükséges információ
(Kötelező)
Szolgáltatásprofil forrása.

Válassza ki a megfelelő beállítást.

Új szolgáltatásprofil létrehozása.

Meglévő szolgáltatásprofil módosítása. A meglévő szolgáltatásprofil neve:

(Kötelező)
A szolgáltatás neve. A név szóközökkel együtt körülbelül 40 karakter hosszúságú lehet. A következő karakterek használata tilos: * \ / : ? " < > | [ ]

A szolgáltatás neve:

(Kötelező)
A szolgáltatásprofil-fájlok neve. A név legfeljebb 8 alfanumerikus karakterből állhat, de nem tartalmazhatja a következőket: ! , ; <szóköz> * = \ / : ? ' " < > | . % + [ ] $ #

Fájlnév:

Egyéb, a jelenlegi profillal egyesítendő szolgáltatásprofilok.

Létező szolgáltatásprofil:

Létező szolgáltatásprofil:

Létező szolgáltatásprofil:

Létező szolgáltatásprofil:

További, egyesíteni kívánt meglévő szolgáltatásprofilokat tartalmazó lapok csatolásához jelölje be ezt a jelölőnégyzetet:
Terméktámogatással kapcsolatos információk. A szöveg szóközökkel együtt körülbelül 50 karakter hosszúságú lehet. Egy példa: Ügyfélszolgálatunkat bármikor hívhatja a 06-80-999-999-es telefonszámon.

Támogatási információ szövege:

(Kötelező)
Tartománynév. Ha azt szeretné, hogy a tartománynév elő- vagy utótagja bejelentkezéskor automatikusan megjelenjen a felhasználói név mellett, írjon be elválasztó karaktereket, például @ vagy / jelet a tartománynévbe.

Válassza ki a megfelelő beállítást.

A tartomány nevének hozzáadása nélkül.

Tartománynév automatikus hozzáadása. Válassza ki a kívánt beállítást, és adja meg a teljes tartománynevet.

    Előtag: (például Szamtech/)

    Utótag: (például @Szamtech)
A Hálózati és telefonos kapcsolatokra vonatkozó bejegyzések. Ezt pontosan úgy kell megadnia, ahogyan a telefonkönyvben szerepel. (Ha viszont alapértelmezett bejegyzést szeretne megadni, a szolgáltatásprofil nevét a Hálózati és telefonos kapcsolatokra vonatkozó, telefonkönyvbe kerülő bejegyzésként adja meg.)

Adja meg a (Hálózati és telefonos kapcsolatok támogatásához szükséges) nevet.

A Hálózati és telefonos kapcsolatokra vonatkozó, a telefonkönyvbe kerülő bejegyzés:

Válassza ki a megfelelő beállítást.

A kiszolgáló címhozzárendelésének engedélyezése.

Megadott címek használata a Hálózati és telefonos kapcsolatokhoz. Adjon meg minden vonatkozó információt.

Elsődleges DNS: ...

Másodlagos DNS: ...

Elsődleges WINS: ...

Másodlagos WINS: ...

Adja meg a parancsfájl nevét, ha lehet.

Parancsfájl a Hálózati és telefonos kapcsolatokhoz:.scp

Ha szeretne további bejegyzéseket tartalmazó lapokat csatolni, jelölje be ezt a jelölőnégyzetet:
VPN-támogatás.

Jelöljön be minden vonatkozó jelölőnégyzetet.

VPN-kapcsolat használata ehhez a szolgáltatásprofilhoz.

VPN-kapcsolat használata egyesített szolgáltatásprofilokhoz.

Adja meg a (VPN-támogatás biztosításához szükséges) címet.

Kiszolgáló címe:

Válassza ki a megfelelő beállítást.

A kiszolgáló jelölhet ki címet.

A megadott címek használata a VPN-kapcsolathoz. Adjon meg minden vonatkozó információt.

Elsődleges DNS: ...

Másodlagos DNS: ...

Elsődleges WINS: ...

Másodlagos WINS: ...

Jelölje be ezt a jelölőnégyzetet, ha szükséges:

Ugyanannak a felhasználónévnek és jelszónak a használata VPN-kapcsolatoknál, mint telefonos kapcsolatnál.
Csatlakozási műveletek. A kapcsolatfelvételi eljárás megadott pontjain elinduló programok.

Jelöljön be minden vonatkozó jelölőnégyzetet: csatlakozás előtti, protokollbújtatás előtti, csatlakozás utáni és kapcsolatbontási műveletek. Ezután írja be a kiválasztott művelettípusokhoz tartozó információkat.

Csatlakozás előtti műveletek azok, amelyekre a felhasználó csatlakozása előtt kerül sor. Adja meg az egyes csatlakozás előtti műveletekre vonatkozó információkat.

    1. A csatlakozás előtti első művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A csatlakozás előtti művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    2. A csatlakozás előtti második művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A csatlakozás előtti művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    3. Ha ehhez a szolgáltatásprofilhoz egyéb csatlakozás előtti műveletek hozzáadását, módosítását vagy a profilból való törlését kérő további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:

Protokollbújtatás előtti műveletek azok, amelyekre a VPN-kapcsolat létrejötte előtt kerül sor. Adja meg az egyes protokollbújtatás előtti műveletekre vonatkozó információkat.

    1. A protokollbújtatás előtti első művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A protokollbújtatás előtti művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    2. A protokollbújtatás előtti második művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A protokollbújtatás előtti művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    3. Ha ehhez a szolgáltatásprofilhoz egyéb protokollbújtatás előtti műveletek hozzáadását, módosítását vagy a profilból való törlését kérő további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:

Csatlakozás utáni műveletek azok, amelyekre a felhasználó csatlakozása után kerül sor. Válassza ki az egyik vagy mindkét szokásos csatlakozási műveletet, majd adja meg az egyéni műveletekre vonatkozó információkat.

    A telefonkönyv-frissítések automatikus letöltése. (Ha ezt a beállítást bejelöli, a tervezőlapon később szereplő frissítési információkat is meg kell adnia.)

    Létező előfizetői bejelentkezési adatok használata (a Microsoft Commercial Internet System Membership Authentication Services szolgáltatásához).

    1. A csatlakozás utáni első művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A csatlakozás utáni művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    2. A csatlakozás utáni második művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A csatlakozás utáni művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    3. Ha ehhez a szolgáltatásprofilhoz egyéb csatlakozás utáni műveletek hozzáadását, módosítását vagy a profilból való törlését kérő további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:

Kapcsolatbontási műveletek azok, amelyekre a felhasználóval való kapcsolat bontása után kerül sor.

Adja meg a kapcsolatbontási műveletekre vonatkozó információkat.

    1. Az első kapcsolatbontási művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A kapcsolatbontási művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    2. A második kapcsolatbontási művelet leírása:

      A futtatni kívánt program:

      Paraméterek:

      A kapcsolatbontási művelet futtatására a következő típusú VPN-csatlakozás alatt kerül sor. Ha ezen a munkalapon meghatározta, hogy ennek a szolgáltatásprofilnak támogatnia kell a VPN-kapcsolatokat, jelöljön ki egy ilyen kapcsolatot.

      Csak telefonos kapcsolat esetén

      Csak közvetlen kapcsolat esetén

      Telefonos és közvetlen kapcsolat esetén

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    3. Ha ehhez a szolgáltatásprofilhoz egyéb kapcsolatbontási műveletek hozzáadását, módosítását vagy a profilból való törlését kérő további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:
Automatikusan futó alkalmazások. Ne feledje, hogy a Csatlakozáskezelő valamennyi automatikusan futó alkalmazást figyel, és az utolsó bezáródásakor elindítja a kapcsolatbontási folyamatot. Adja meg az automatikusan futó alkalmazásokra vonatkozó információkat.
    1. Az első elindítandó automatikusan futó alkalmazás neve:

      Paraméterek:

      2. Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    2. A második elindítandó automatikusan futó alkalmazás neve:

      Paraméterek:

      Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

      Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

    3. Ha ehhez a szolgáltatásprofilhoz egyéb automatikusan futó alkalmazások hozzáadását, módosítását vagy a profilból való törlését kérő további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:
(Kötelező)
Kép a bejelentkezési párbeszédpanelhez. Válassza ki a megfelelő beállítást.

A Csatlakozáskezelő alapértelmezett bejelentkezési bitképének használata.

Saját bitkép-fájl használata: .bmp
(Kötelező)
Kép a Telefonkönyv párbeszédpanelhez. Válassza ki a megfelelő beállítást.

A Csatlakozáskezelő alapértelmezett telefonkönyv-bitképének használata.

Saját bitkép-fájl használata: .bmp
Ebbe a szolgáltatásprofilba beépítendő telefonkönyv-fájl. Ne feledje, hogy a .pbk fájlhoz szükség van a megfelelő .pbr területfájlra is. A név nem lehet hosszabb nyolc karakternél, nem tartalmazhat fájlkiterjesztést, szóközöket, és nem szerepelhetnek benne a következő karakterek: ! , ; * = \ / : ? ' " < >

Telefonkönyv-fájl neve: .pbk

A telefonkönyvben megjelenő „További telefonszámok” üzenet szövege. A maximális hosszúság körülbelül 100 karakter.

Üzenet:

Telefonkönyv-fájl neve letöltéshez és frissítésekhez. (Kötelező, ha bejelölte a A telefonkönyv-frissítések automatikus letöltése jelölőnégyzetet a tervezőlap Csatlakozás utáni műveletek részében, és nem adott meg telefonkönyvet az Ebbe a szolgáltatásprofilba beépítendő telefonkönyv-fájl részben.)

Telefonkönyv neve: .pbk
A Csatlakozási pont szolgáltatás kiszolgálójának letöltési és frissítési URL-címe. A Csatlakozási pont szolgáltatás kiszolgálójának letöltési és frissítési URL-címe. Kötelező, ha a tervezőlapon bejelölte a Telefonkönyv-frissítések automatikus letöltése jelölőnégyzetet.

http:///pbserver/pbserver/.dll
(Kötelező)
Ikonok. Csak 16 színű ikonfájlokat (.ico) adhat meg. Válassza ki a megfelelő beállítást:

A Csatlakozáskezelő három alapértelmezett ikonfájljának használata.

Saját ikonfájl(ok) használata.

    Nagy programikon fájlneve: .ico

    Kis címsorikon fájlneve: .ico

    Kis állapotjelzőterület-ikon fájlneve: .ico

    Ha a Csatlakozáskezelő felügyeleti csomag varázslóban egy négyzetet üresen hagy, az adott ikon esetében az alapértelmezett ikon használatára kerül sor.
Egyéni állapotterület-ikon menü. Adja meg a parancsokra vonatkozó megfelelő információkat.

A helyi menühöz adandó első parancs:

    A futtatni kívánt program:

    Paraméterek:

    Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

    Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

A helyi menühöz adandó második parancs:

    A futtatni kívánt program:

    Paraméterek:

A helyi menühöz adandó harmadik parancs:

    A futtatni kívánt program:

    Paraméterek:

    Csak akkor jelölje be ezt a jelölőnégyzetet, ha a program vagy a fájl nem érhető el a felhasználók számítógépein:

    Fájl vagy program csatolása ehhez a szolgáltatásprofilhoz.

Ha a helyi menühöz egyéb parancsok hozzáadását, módosítását vagy a menüből való törlését kérő további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:

(Kötelező)
Windows súgó. Adja meg, hogy az alapértelmezett súgót, vagy saját súgófájlt szeretne-e használni.

A Csatlakozáskezelő alapértelmezett súgófájljának (Cmmgr32.hlp) használata.

A következő súgófájl használata: .hlp (Nem lehet a Cmmgr32.hlp)
Microsoft Csatlakozáskezelő 1.2. Jelölje be a baloldali jelölőnégyzetet, ha a Csatlakozáskezelő programot és annak Fontos.txt fájlját be szeretné építeni ebbe a szolgáltatásprofilba.
Licencszerződés. A szolgáltatásprofil első telepítésekor jelenik meg.

Licencszerződés-fájl: .txt
További fájlok. A következő sorban, vagy szükség esetén további lapokon, soroljon fel minden egyéb fájlt. A tervezőlapon korábban meg nem határozott valamennyi beépítendő fájlt adja meg, beleértve a dokumentációt és a csatlakozási műveletek támogatási fájljait is. A fájlok teljes nevét kell megadnia, a kiterjesztéssel együtt.

A további beépítendő fájlok neve:

Ha egyéb beépítendő fájlokat tartalmazó további lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:
Felhasználói dokumentáció. A Csatlakozáskezelő és a szolgáltatásprofil telepítését és használatát segítő valamennyi fájl. Ezek a fájlok kiegészítik a Csatlakozáskezelő felügyeleti csomag varázslóban megadott súgófájlokat. A Csatlakozáskezelő felügyeleti csomag varázsló „További fájlok” részében kell megadni és ennek a tervezőlapnak az azonos című részében kell felsorolni minden további dokumentációt, amelyet a Csatlakozáskezelő és a szolgáltatásprofil telepítésének és használatának megkönnyítése érdekében a felhasználók számára biztosítani szeretne. A tervezőlapon máshol megjelölt súgó- vagy Fontos fájlokat itt nem szabad felsorolni.

Utasítások a dokumentáció összeállításához:

Ha további, a dokumentációval kapcsolatos utasításokat tartalmazó lapokat szeretne csatolni, jelölje be ezt a jelölőnégyzetet:

Ezzel megadott minden információt, amely a Csatlakozáskezelő felügyeleti csomag varázsló futtatásához szükséges.

A 2. részben hajthatja végre azoknak az elemeknek a testreszabását, amelyek nem adhatók meg a Csatlakozáskezelő felügyeleti csomag varázsló használatával.

2. rész (Nem kötelező): Információ – Speciális testreszabás: szolgáltatásprofil-fájlok szerkesztése

Szükséges Kész A megvalósításhoz szükséges információ
Sablon .inf fájl. A Csatlakozáskezelő felügyeleti csomag varázsló egyes indításaikor megadott bejegyzéseket e fájl szerkesztésével alakíthatja saját igényei szerint.

Sablonfájl neve: .inf

    A sablon .inf fájl része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    A sablon .inf fájl része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    Ha olyan további lapokat szeretne csatolni, amelyek egyéb módosítandó sablon .inf bejegyzéseket tartalmaznak, jelölje be ezt a jelölőnégyzetet:

A szolgáltatásprofil .inf fájlja. A fájl módosítása után újra kell futtatnia a Csatlakozáskezelő felügyeleti csomag varázslót, hogy a fájlban végrehajtott változtatások életbe lépjenek.

A szolgáltatásprofil fájlneve: .inf

    A szolgáltatásprofil .inf fájljának része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    A szolgáltatásprofil .inf fájljának része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    Ha olyan további lapokat szeretne csatolni, amelyek egyéb módosítandó sablon .inf bejegyzéseket tartalmaznak, jelölje be ezt a jelölőnégyzetet:

Sablon .cms fájl. A Csatlakozáskezelő felügyeleti csomag varázsló egyes indításaikor megadott bejegyzéseket e fájl szerkesztésével alakíthatja saját igényei szerint.

A szolgáltatásprofil fájlneve: .cms

    A szolgáltatásprofil .cms fájljának része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    A sablon .cms fájl része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    Ha olyan további lapokat szeretne csatolni, amelyek egyéb módosítandó sablon .cms bejegyzéseket tartalmaznak, jelölje be ezt a jelölőnégyzetet:

A szolgáltatásprofil .cms fájlja. A fájl módosítása után újra kell futtatnia a Csatlakozáskezelő felügyeleti csomag varázslót, hogy a fájlban végrehajtott változtatások életbe lépjenek.

A szolgáltatásprofil fájlneve: .cms

    A szolgáltatásprofil .cms fájljának része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    A szolgáltatásprofil .cms fájljának része:

      Módosítandó bejegyzés:

      A bejegyzés paraméterei:

    Ha olyan további lapokat szeretne csatolni, amelyek a szolgáltatásprofil egyéb módosítandó .cms bejegyzéseit tartalmazzák, jelölje be ezt a jelölőnégyzetet:

3. rész: Az integrációhoz, szállításhoz és telepítéshez szükséges információ

Szükséges Kész A megvalósításhoz szükséges információ
Internet Explorer integráció. Ha a Csatlakozáskezelő szolgáltatásprofilt az Internet Explorer Administration Kit (IEAK) segítségével létrehozott telepítőcsomagba építi be, akkor biztosítania kell, hogy az Internet Explorer telepítőcsomag támogassa a Csatlakozáskezelő integrációját.

Utasítások:

Ha olyan további lapokat szeretne csatolni, amelyek a parancssori paraméterek használatával kapcsolatos utasításokat tartalmaznak, jelölje be ezt a jelölőnégyzetet:

Parancssori paraméterek

Utasítások:

Ha olyan további lapokat szeretne csatolni, amelyek a parancssori paraméterek használatával kapcsolatos utasításokat tartalmaznak, jelölje be ezt a jelölőnégyzetet:

Kód aláírása

Utasítások:

Ha olyan további lapokat szeretne csatolni, amelyek a kód aláírásával kapcsolatos utasításokat tartalmaznak, jelölje be ezt a jelölőnégyzetet:


2. fázis: Egyéni elemek kifejlesztése

Attól függően, hogy mit szeretne testreszabni, az elemek előkészítéséhez további erőforrásokra is szüksége lehet. Ha azt szeretné például, hogy a szolgáltatásprofilja telefonkönyvet tartalmazzon, másolatot kell készítenie a telefonkönyv- és a területfájlokról. Ha pedig azt szeretné, hogy a profil egyedi ikonokat és bitképeket tartalmazzon, szüksége lehet további programokra vagy egy grafikusra azok elkészítéséhez.

Ez a rész azon szakemberek számára tartalmaz útmutatót, akik a Csatlakozáskezelő testreszabása során az igényeknek megfelelő képek, információ, programok és más speciális elemek létrehozásáért felelősek:

  • A szolgáltatásprofilok beállítása
  • Szolgáltatás- és fájlnevek megadása
  • Létező szolgáltatásprofilokban található telefonkönyvek és egyéb funkciók egyesítése
  • Támogatással kapcsolatos információ megjelenítése a bejelentkezési párbeszédpanelen
  • Tartománynév megjelenítése
  • Egyedi telefonos hálózati bejegyzések beépítése
  • VPN-támogatás megvalósítása
  • Csatlakozási műveletek beépítése
  • Automatikusan futó alkalmazások beépítése
  • Egyéni képek beépítése
  • Telefonkönyv-támogatás
  • Egyéni ikonok beépítése
  • Az állapotjelzőterület-ikon menüjének testreszabása
  • Egyéni Windows súgó
  • A Csatlakozáskezelő 1.2-es verziójának hozzáadása a szolgáltatásprofilhoz
  • Licencszerződés beépítése
  • További fájlok felvétele
  • Dokumentáció csatolása
  • Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése

Ez az útmutató sokszorosítható és terjeszthető a tervezési és fejlesztési munkálatokért felelős személyek között.

Az egyéni elemeknek már a Csatlakozáskezelő felügyeleti csomag varázsló futtatása előtt teljesnek kell lenniük. A fejlesztési tervek és a megvalósítás lépéseinek rögzítéséhez és nyomon követéséhez a Tervezőlap a Csatlakozáskezelő 1.2-es verziójához című munkalap nyújt segítséget.


A szolgáltatásprofilok beállítása

Minden alkalommal, amikor futtatja a Csatlakozáskezelő felügyeleti csomag (CMAK) varázslót, létrehoz egy szolgáltatásprofilt. Az egyes célcsoportok igényeinek megfelelően tetszőleges számú szolgáltatásprofilt hozhat létre. A profil létrehozása után azt a Csatlakozáskezelő felügyeleti csomag varázslóval módosíthatja. A módosított profilt ugyanazon a néven (ily módon az felülírja a létező profilt), illetve egy másik szolgáltatás- és fájlnév megadásával külön profilként is mentheti (így az eredeti profilt a módosítás előtti állapotában őrzi meg).

Megjegyzések

  • Ha más nyelvhez készít szolgáltatásprofilt, használja a nyelvnek megfelelő Csatlakozáskezelő felügyeleti csomag varázslót és az operációs rendszer megfelelő verzióját.
  • Ha olyan szolgáltatásprofilt módosít, amelyet a Csatlakozáskezelő valamely korábbi verziójával készítettek, a CMAK automatikusan a Csatlakozáskezelő 1.2-es verziójára frissíti azt. Az .inf fájlon kézzel (speciális testreszabási eljárásokkal) végrehajtott módosításokat a program nem őrzi meg a frissített fájlban. A Csatlakozáskezelő felügyeleti csomag varázsló azonban a régi .inf fájlról biztonsági másolatot készít, mielőtt a frissített fájlt létrehozná.
  • A fájlnév változtatásakor a szolgáltatás nevét is meg kell változtatni. Ha a felhasználó két olyan szolgáltatásprofilt telepít, melyek szolgáltatásneve megegyezik, de fájlnevük különböző, a profilok nem fognak tökéletesen működni.

Minden szolgáltatásprofil egy adott célcsoportnak megfelelő kell, hogy legyen. A következő esetekben lehet például célszerű külön profil létrehozása:

  • Ha minden operációs rendszerhez saját szolgáltatásprofilt szeretne készíteni.
  • Ha minden egyes földrajzi területhez vagy vállalathoz külön telefonkönyvet szeretne megadni.
  • Ha az egyes felhasználóknak más-más (telefonos vagy közvetlen) csatlakozási módra van szüksége.
  • Ha csak adott felhasználók esetén szükséges a virtuális magánhálózati (VPN) kapcsolatok támogatása.
  • Ha a támogatott cégek vagy csoportok mindegyike saját emblémáját vagy bejegyzett szimbólumát, illetve szövegét szeretné használni.
  • Ha a súgópult vagy egyéb támogatás nem mindenkinél ugyanaz, és minden egyes felhasználócsoport számára más adatokat kíván megadni.
  • Ha a támogatott csoportok számára különböző felügyeleti engedélyeket kíván létrehozni.

Megjegyzés

  • Több szolgáltatásprofil felügyeletét úgy egyszerűsítheti le, hogy a létező profilokat egy szülőprofilban egyesíti. További információ a Létező szolgáltatásprofilokban található telefonkönyvek és egyéb funkciók egyesítése című témakörben található.

Minden szolgáltatásprofil létrehozásakor újra kell futtatnia a Csatlakozáskezelő felügyeleti csomag varázslót, beleértve azokat a szolgáltatás-, és fájlneveket is, amelyeket a felhasználók számára kíván biztosítani. A szolgáltatás- és fájlnevekkel kapcsolatos további információ a Szolgáltatás- és fájlnevek megadása című témakörben található.

Újabb szolgáltatásprofilt úgy lehet egyszerűen létrehozni, hogy egy már létező profilt módosít, majd megváltoztatja annak szolgáltatás- és fájlnevét.

Szolgáltatásprofil létrehozásakor a Csatlakozáskezelő felügyeleti csomag varázsló az összes, profilban található fájlt a \Program Files\CMAK\Profiles\Szolgáltatásprofil_fájlneve mappába másolja. Már létező profilok módosításakor a Csatlakozáskezelő felügyeleti csomag varázsló a kapcsolódó fájlokat a …Szolgáltatásprofil_fájlneve mappából veszi. A kapcsolódó fájlok módosításához módosítsa a kívánt kapcsolódó fájlt a …Szolgáltatásprofil_fájlneve mappában, majd futtassa újra a Csatlakozáskezelő felügyeleti csomag varázslót a profil frissítése érdekében. Ha olyan fájlt módosít, amely nincs a …Szolgáltatásprofil_fájlneve mappában, indítsa el a Csatlakozáskezelő felügyeleti csomag varázslót, adja hozzá a frissített fájlt (tallózással megkeresheti), majd fejezze be a varázsló futtatását.

Megjegyzés

  • A Csatlakozáskezelő segítségével a felhasználók több szolgáltatásprofilt is telepíthetnek, egyszerre több példányban is futtathatják a Csatlakozáskezelőt, és egy szolgáltatásprofilhoz több felhasználói profil is tartozhat. Ha a felhasználó egynél több szolgáltatásprofilt telepít, mindegyik külön mappába kerül. Annyi profilt bocsáthat a felhasználók rendelkezésére, amennyi a szolgáltatás támogatásához szükséges, de mindegyiknek más szolgáltatás- és fájlnévvel kell rendelkeznie.


Szolgáltatás- és fájlnevek megadása

Saját szolgáltatásprofilja azonosításához a Csatlakozáskezelő felügyeleti csomag varázslóban meg kell adnia egy szolgáltatásnevet és egy fájlnevet.

Szolgáltatásnév

A felhasználó a szolgáltatást annak neve alapján azonosítja. A Csatlakozáskezelő csak az első 31-45 karakter megjelenítésére képes (a karakterektől, és az esetleges nagybetűktől függően). Ez a név a szolgáltatás futtatásakor többször is megjelenik:

  • A szolgáltatás bejelentkezési párbeszédpanelén, a címsor szövegében.
  • A Csatlakozáskezelő és a szolgáltatásprofil telepítésekor megjelenő párbeszédpaneleken.
  • A szolgáltatás ikonjának neveként az Asztalon.
  • A program futtatása közben megjelenő programgombon a Tálcán.
  • Abban az eszközleírásban, amely akkor jelenik meg, ha a Tálca jobb oldali végén az egérrel az állapotjelző terület ikonjára mutat.
  • A szolgáltatásprofil-fájlokon belül, adott bejegyzéseknél, például a Hálózat és telefonos kapcsolatok szolgáltatással kapcsolatos alapértelmezett bejegyzésben.
  • A távelérésű kapcsolat neveként a Hálózati kapcsolatok párbeszédpanelen.

A szolgáltatás neve gyakran egy cég neve vagy egyéb üzleti név. A fiktív Soft Számítástechnikai Kft. cégnév, amely ebben az útmutatóban gyakran szerepel példaként, lehet egyben „Soft Számítástechnikai Kft.” szolgáltatásnév is. Ha pedig a Soft Számítástechnikai Kft. minden részlege számára külön szolgáltatásprofilt szeretne létrehozni, az egyik szolgáltatás neve lehet például „Soft Számítástechnikai Kft. – Marketing”.

Fájlnév

A fájlnév azon fájlokhoz csatolt név, melyeket a Csatlakozáskezelő felügyeleti csomag varázsló hoz létre a szolgáltatásprofil készítésekor. A fájlnév legfeljebb 8 alfanumerikus karakterből állhat, az alábbi korlátozásokkal:

  • A következő karakterek használata tilos:
    ! , ; <szóköz> * = / \ : ? ' " < >
  • A fájlnév nem tartalmazhat kiterjesztett karaktereket. Elképzelhető, hogy a kiterjesztett karakterkészletekkel létrehozott fájlnevű (például ü, é és egyéb kiterjesztett karaktereket tartalmazó) fájlok telepítése nem lesz megfelelő.

Megjegyzések

  • Győződjön meg arról, hogy a szolgáltatás- és fájlnév nem egyezik meg egyetlen idáig használt névvel sem. Ha ugyanazon a számítógépen két szolgáltatásprofil szolgáltatás- vagy fájlneve megegyezik, a hozzájuk tartozó kapcsolatikonok nem fognak tökéletesen működni.
  • Ha egy létező fájl módosításakor nem kívánja felülírni az eredeti szolgáltatásprofilt, meg kell változtatnia a fájlnevet.

A fájlnév a következő, Csatlakozáskezelő felügyeleti csomag varázslóval készített fájlokhoz szükséges:
  • A Csatlakozáskezelő és a szolgáltatásprofil telepítéséhez szükséges fájlokat tartalmazó mappa, amely a következő helyen található: \Program Files\CMAK\Profiles\Szolgáltatásprofil_fájlneve.
  • Az önkicsomagoló végrehajtható (.exe) fájl.
  • Az a .cms fájl, amely a Csatlakozáskezelő szolgáltatásaihoz tartozó konfigurációs adatokat, például a telefonkönyvek neveit vagy a csatlakozási módokat tartalmazza.
  • Az a .cmp fájl, amely a felhasználó által megadott információkat, például a használandó .cms fájl nevét tartalmazza.
  • Az .inf fájl, amely a Csatlakozáskezelő program felhasználó számítógépén történő telepítéséhez és beállításához szükséges.
  • Az a .sed fájl, mely a .cab fájl tartalmát adja meg, illetve a fájlok tömörítésének módját a szolgáltatásprofil készítésekor.

A szolgáltatásprofil fájlneve ahhoz a mappához is szükséges, mely a felhasználó számítógépén az .exe fájl futtatásakor jön létre.

A Csatlakozáskezelő felügyeleti csomag varázslóval létrehozott fájlokról további információ A Csatlakozáskezelő felügyeleti csomag varázsló használata szolgáltatásprofil készítésére című témakörben található.


Létező szolgáltatásprofilokban található telefonkönyvek és egyéb funkciók egyesítése

Ha a létező szolgáltatásprofilok olyan információt tartalmaznak, amelyet az új szolgáltatásprofilhoz fel szeretne használni, az adatoknak a már meglévő profilokból az új profilba való egyesítéséhez használhatja a Csatlakozáskezelő felügyeleti csomag varázslót. Az olyan profilt, amely más szolgáltatásprofilok információit is tartalmazza, hivatkozási profilnak nevezik. Az olyan szolgáltatásprofilt, amelynek információit egy másik szolgáltatásprofilba egyesítették, egyesített profilnak nevezik.

Miért célszerű egyesíteni a szolgáltatásprofilokat?

A szolgáltatásprofilok egyesítése különösen akkor hasznos, ha több telefonkönyvből szeretne információt – például szolgáltatástípusokat, kapcsolódási pont (POP) neveket és hívószámokat – beépíteni, vagy a telefonkönyvekben szereplő különböző Internet-hozzáférési pontokat kívánja egységesíteni. A létező szolgáltatásprofilok új profilba való egyesítésével egyes, egymástól különböző hálózatokat egyetlen, egységes szolgáltatásként jeleníthet meg.

Egyesítheti például a különböző földrajzi helyekről származó szolgáltatásprofilokat egyetlen közös, a világot átfogó profilba. Létrehozhat olyan profilokat is, amelyek meghatározott felügyeleti követelményekkel rendelkeznek és megfelelő hálózati konfigurációt igényelnek, például hitelesítési és TCP/IP-jellemzőket, majd egy hivatkozási szolgáltatásprofilban egyesítheti azokat. A szolgáltatásprofilok egyesítése különösen hasznos akkor, ha több jogi személy – vállalat vagy Internet-szolgáltató (ISP) – közösen nyújtja az adott szolgáltatást. A következő példák azt szemléltetik, hogyan használhatja az egyesített szolgáltatásprofilokat a különböző hozzáférési pontokon keresztüli hálózati hozzáférés megkönnyítésére:

  • 1. példa – Szolgáltatásprofil létrehozása távoli szolgáltatókörzetekből való Internet-hozzáférés támogatásához. Ha a helyi Internet-szolgáltató központi profillal rendelkező vállalattal szerződik az elsődleges szolgáltatókörzetén kívüli telefonos szolgáltatásokról, a helyi Internet-szolgáltató létrehozhat egy olyan hivatkozási szolgáltatásprofilt, amely tartalmazza az Internet-szolgáltató hálózati információit, és egyesíti a vállalat tagjainak szolgáltatásprofiljait. Minden egyesített szolgáltatásprofil tartalmazhat egyedi telefonkönyvet és hálózati attribútumokat, beleértve az egyes Internet-szolgáltatók tartománynevét is. Az összes egyesített szolgáltatásprofil egyesítése a helyi Internet-szolgáltató azon felhasználóinak igényeit szolgálja, akik az Internet-szolgáltató elsődleges körzetén kívülről szeretnének kapcsolatot létesíteni úgy, hogy engedélyezik az együttműködő Internet-szolgáltatókon keresztüli csatlakozást. Mindegyik Internet-szolgáltató tárolja a saját szolgáltatásprofiljait, és minden frissítéskor egyszerűen továbbítja a profilokat a központi profillal rendelkező vállalat más tagjainak. Maga a vállalat is létrehozhat hivatkozási szolgáltatásprofilokat az Internet-szolgáltató összes tagjának csoportba rendezésével.
  • 2. példa – Vállalati virtuális magánhálózat (VPN) megvalósítása. Azok a vállalatok, amelyek az Interneten keresztüli bújtatási alagút létrehozásával járó munkamenetekhez VPN-kapcsolatot használnak, Internet-szolgáltató által támogatott telefonos eléréssel teszik lehetővé a vállalathoz való távoli hozzáférést. A szolgáltatásprofilok egyesítésével a vállalat egyesítheti a saját, belső telefonszámokat tartalmazó telefonkönyvét azoknak a távoli Internet-szolgáltatóknak a telefonkönyvével, amelyek a vállalat távoli felhasználóinak hozzáférési pontjait biztosítják, így akár az Internet-szolgáltató nyilvános hálózati elérési pontjain keresztül létrehozott telefonos kapcsolatokkal is használhatók VPN-kapcsolatok. A vállalat és az Internet-szolgáltatók tartják karban a saját szolgáltatásprofiljaikat, de a vállalat egyesíti az összes Internet-szolgáltató szolgáltatásprofilját a vállalati profilban. A vállalat elosztja a hivatkozási szolgáltatásprofilokat a vállalati felhasználók között, ezáltal támogatja a több helyről való hozzáférést. A hozzáférés a felhasználók számára úgy jelenik meg, mintha a vállalat saját hozzáférési pontjait vennék igénybe.

Milyen információk kerülnek egyesítésre?

A következő táblázat azt mutatja be, hogy az egyesített szolgáltatásprofil mely tulajdonságai egyesülnek a hivatkozási szolgáltatásprofilban, és a Csatlakozáskezelő felügyeleti csomag varázsló hogyan végzi el az információk egyesítését. A hivatkozási szolgáltatásprofil az egyesített szolgáltatásprofilnak csak az Egyesített tulajdonságok oszlopban listázott elemeit ismeri fel és használja.

Egyesített tulajdonságok | Megvalósítás
Fájlnév | Az egyesített szolgáltatásprofilban található fájlok megtartják az egyesített szolgáltatásprofilban használt nevüket.
Egyesített profilok | Csak egyazon szinten lévő szolgáltatásprofilok egyesíthetők. Ha az A szolgáltatásprofilt (amely a B és a C egyesített szolgáltatásprofilokat tartalmazza) egyesíti például egy másik profillal, a második szintű profilokat (B és C) a rendszer nem veszi figyelembe.
Tartománynév | Ha a hivatkozási szolgáltatásprofilban adott meg tartománynevet, a rendszer minden esetben ezt a tartományt fogja használni, és az egyesített szolgáltatásprofilban megadott tartományneveket nem fogja figyelembe venni. Ha a felhasználó a hivatkozási szolgáltatásprofilban nem adott meg tartománynevet, a rendszer az egyesített szolgáltatásprofilokban megadott tartománynevet használja az egyesített szolgáltatásprofilok bejegyzéseit használó kapcsolatokhoz.
Telefonos hálózati bejegyzések | Minden egyes telefonos hálózati bejegyzéshez megadott parancsfájlnak rendelkeznie kell egy egyedi névvel, amely különbözik a hivatkozási szolgáltatásprofilban található más parancsfájlok és az egyesített profilok nevétől.
Telefonkönyvek | Ha ugyanazok a szolgáltatástípusok több profilban is szerepelnek, a rendszer egyesíti az információt. Ha a hivatkozási és az egyesített szolgáltatásprofilok között több példányban meglévő államok vagy megyék, illetve kapcsolódási pontok is szerepelnek, a Csatlakozáskezelő a hivatkozási szolgáltatásprofil futtatásakor eltávolítja a másolatokat. A Csatlakozáskezelő két különböző telefonkönyvet másolatokként kezel abban az esetben, ha azok ugyanazt az információt jelenítik meg a felhasználói felületen (ügyeljen arra, hogy a Csatlakozáskezelő nem tesz különbséget a kis- és a nagybetűk között). Ha két telefonkönyv-bejegyzés másolatként jelenik meg, de külön hálózati és telefonos kapcsolat bejegyzésük van a kapcsolódási ponton, a Csatlakozáskezelő eltávolítja az egyik telefonkönyv-bejegyzést.
Telefonkönyv letöltése | Minden olyan alkalommal, amikor a felhasználó kapcsolatot létesít, a Csatlakozáskezelő automatikusan összehasonlítja a telefonkönyveket minden, a Telefonkönyv-szolgáltatást futtató kiszolgálóval. A Telefonkönyv-szolgáltatás ellenőrzi a telefonkönyv verzióját, és szükség esetén letölti a telefonkönyv frissítését a felhasználónak. A rendszer a hivatkozási szolgáltatásprofiloknak megfelelően letölti a hivatkozási és az egyesített telefonkönyvekben megadott telefonkönyveket.
A letöltések URL-címe | A hivatkozási és az egyesített szolgáltatásprofilokban megadott URL-címek a hivatkozási szolgáltatásprofilokhoz történő telefonkönyv-letöltéskor használatosak.

A hivatkozási profil nem egyesíti az egyesített profillal kapcsolatos alábbi tulajdonságokat. Ezen tulajdonságok beállításához meg kell adnia azokat a hivatkozási szolgáltatásprofilban.

  • A szolgáltatás neve
  • Terméktámogatással kapcsolatos információk megjelenítése a bejelentkezési párbeszédpanelen
  • VPN-támogatás

    • Megjegyzés

    • Az egyesített szolgáltatásprofilok VPN-kapcsolatainak támogatásához a Csatlakozáskezelő felügyeleti csomag varázsló VPN-támogatás párbeszédpaneljén, a VPN-kapcsolat használata csoportban jelölje be az Egyesített szolgáltatásprofilokhoz jelölőnégyzetet.
  • Csatlakozási műveletek
  • Automatikusan futó alkalmazások
  • Egyedi képek a bejelentkezési és a Telefonkönyv párbeszédpanelhez
  • Az az üzenet, amelyet a További telefonszámok mező mellett meg szeretne jeleníteni, ha alternatív telefonszámok állnak rendelkezésre a kijelölt földrajzi helyen
  • Egyedi ikonok
  • Az állapotjelzőterület-ikon menüjének testreszabása
  • Egyéni súgófájlok
  • A Csatlakozáskezelő szoftver 1.2-es verziójának beépítése a szolgáltatásprofilba
  • Licencszerződés
  • További fájlok

Hol találhatók meg a fájlok?

Szolgáltatásprofil létrehozásakor a Csatlakozáskezelő felügyeleti csomag varázsló minden olyan fájlt átmásol az adott szolgáltatásprofil \Program Files\CMAK\Profiles\SzolgáltatásprofilFájlnév mappájába, amelyekre a szolgáltatásprofil hivatkozik, beleértve az egyesített szolgáltatásprofil-fájlokat is.

Amikor a Csatlakozáskezelő felügyeleti csomag varázsló segítségével egyesíti a tulajdonságokat, a létrejövő szolgáltatásprofil tartalmazza a létező (egyesített) szolgáltatásprofilokra vonatkozó hivatkozásokat. Az egyesített szolgáltatásprofilokban lévő telefonkönyvek esetében például a létrejövő szolgáltatásprofil több fájlt telepít a profilban megadott mappában ahelyett, hogy a telefonkönyveket egyetlen fájlba egyesítené. Amikor a felhasználók azonban két másik szolgáltatásprofilból egyesített telefonkönyveket használva választanak kapcsolódási pontot, a felhasználók az összes telefonkönyv adatait egy telefonkönyvként látják megjelenni.

Ha egy másik profillal egyesített szolgáltatásprofil módosítása történik, a Csatlakozáskezelő felügyeleti csomag varázsló a másik beépített szolgáltatásprofil legújabb verzióját próbálja meg használni. Ha a Csatlakozáskezelő felügyeleti csomag varázsló az egyesített szolgáltatásprofilt nem találja a megfelelő \Program Files\CMAK\Profiles\SzolgáltatásprofilFájlnév mappában (amire a hivatkozási szolgáltatásprofil hivatkozik), akkor a varázsló az egyesített szolgáltatásprofil jelenlegi, a módosítandó profillal eredetileg tárolt verzióját tekinti alapértelmezettnek.

Az egyesített profilok létrehozásával kapcsolatos speciális szempontok

Egyesített szolgáltatásprofilok létrehozásakor a következőket is szem előtt kell tartani:

  • Ha egy 1.0-s verziójú Csatlakozáskezelő szolgáltatásprofilt 1.2-es verziójú szolgáltatásprofilba egyesít, akkor a Csatlakozáskezelő felügyeleti csomag varázsló automatikusan frissíti az egyesített információt az 1.2-es verziójú Csatlakozáskezelő profilba. Az .inf fájlon kézzel (speciális testreszabási eljárásokkal) végrehajtott módosításokat a program nem őrzi meg a frissített fájlban. A Csatlakozáskezelő felügyeleti csomag varázsló a frissített fájl létrehozása előtt azonban biztonsági másolatot készít a régi .inf fájlról.
  • Minden olyan hálózat számára külön szolgáltatásprofilt kell létrehozni, amely egyedi tulajdonságokkal vagy követelményekkel rendelkezik.
  • Biztosítsa, hogy a hivatkozási szolgáltatásprofil létrehozásakor minden, a hálózati és telefonos kapcsolat bejegyzések számára az egyesített szolgáltatásprofilokban megadott parancsfájl elérhető legyen.


Támogatással kapcsolatos információ megjelenítése a bejelentkezési párbeszédpanelen

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével beállíthatja, hogy milyen információ jelenjen meg a bejelentkezési párbeszédpanelen, közvetlenül a Kapcsolat állapota csoport fölött. Az itt megjelenő szöveg legfeljebb 50 karakterből állhat, és általában a terméktámogatás telefonszámát tartalmazza (például „Az ügyfélszolgálat telefonszáma: x-xxx-xxx”). Ehhez a beállításhoz nem tartozik alapértelmezett szöveg. Ha nem ír be semmilyen szöveget, a bejelentkezési párbeszédpanel ezen területe üresen marad.

Ajánlott a terméktámogatással vagy egyéb, telepítéssel kapcsolatos információt a fontos fájlokba menteni arra az esetre, ha a felhasználó nem tudja megjeleníteni a bejelentkezési párbeszédpanelt.

Ha az ügyfélszolgálat telefonszáma a felhasználó tárcsázási helyétől is függ, testreszabhatja a súgót úgy is, hogy az tartalmazza az összes ügyfélszolgálati telefonszámot (azon felhasználók érdekében, akik saját körzetükön kívülről tárcsáznak). Ebben az esetben a bejelentkezési párbeszédpanelen megjelenő szövegbe hivatkozást mellékelhet a súgóhoz. (Például Az ügyfélszolgálati telefonszámok megtekintéséhez kattintson a Súgó hivatkozásra.) Ha ezt a megoldást választja, adjon hivatkozást az első súgóképernyőhöz, amely az ügyfélszolgálati telefonszámokat tartalmazó témakör-azonosítóhoz ugrik. A súgó testreszabásáról az Egyéni Windows súgó című témakörben talál további információt.


Tartománynév megjelenítése

A tartományneveket hálózati útválasztáshoz és hitelesítéshez használják. A tartománynevek szolgáltatják azt az azonosítást, amely a hitelesítési kérelmek a felhasználó hitelesítési adatait tartalmazó kiszolgálóhoz történő továbbításához szükséges.

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével tartományi felhasználónév-előtagot (például Soft/) vagy -utótagot (például @Soft) adhat meg, amelyet a rendszer akkor ad a felhasználónévhez, amikor az csatlakozik a szolgáltatáshoz. A tartománynév bármilyen elválasztó karaktert tartalmazhat, például az @ vagy a / karaktert. Ha megadja a tartományt, akkor azt a felhasználóknak nem kell önállóan megadniuk, mivel a Csatlakozáskezelő automatikusan a felhasználó neve elé vagy mögé helyezi a tartománynevet, így a bejelentkezéshez a felhasználónak nem kell ismernie a hálózati útválasztás működését.

Ha szolgáltatása a hozzáféréshez több hálózatot vagy Internet-szolgáltatót használ, minden egyes hálózathoz és Internet-szolgáltatóhoz különböző tartományadatokat kell megadnia. Ilyen esetben hozzon létre minden egyes hálózathoz szolgáltatásprofilt, majd egyesítse ezeket a szolgáltatásprofilokat egyetlen hivatkozási profilban.

Megjegyzések

  • Ha a hivatkozási profil tartományadatokat tartalmaz, akkor az ott található adatok elsőbbséget élveznek az egyesített profilokban található adatokkal szemben.
  • Ha a profilok beépített többszörös tartományokba történő egyesítésével kapcsolatban további információra van szüksége, tanulmányozza a Létező szolgáltatásprofilokban található telefonkönyvek és egyéb funkciók egyesítése című témakört.

A Microsoft Internetes hitelesítési szolgáltatás (IAS) támogatja a tartománynevek távoli hitelesítéssel történő használatát. A tartománynevet hitelesítő útválasztási információként is használhatja a távoli mozgó felhasználókhoz (azon felhasználók, akik utaznak, és különböző helyekről csatlakoznak az Internethez). Ha a felhasználó hálózati hozzáférés kiszolgálóján (NAS) keresztül csatlakozik, a NAS kiszolgáló a tartománynevet, a felhasználónevet, valamint a felhasználó jelszavát elküldi a hitelesítő kiszolgálóhoz. Az IAS szolgáltatással kapcsolatos bővebb tájékoztatásért olvassa el az Internetes hitelesítési szolgáltatás (IAS) című témakörben leírtakat.


Telefonos hálózati bejegyzések felvétele

A telefonos hálózati bejegyzések a Csatlakozási pont szolgáltatás Telefonkönyv-felügyelőjében vannak megadva, és az egyes kapcsolódási pontokhoz (POP-okhoz) való hozzáférés testreszabásának módját határozzák meg. A telefonos hálózati bejegyzések egyéni tulajdonságait a Csatlakozáskezelő felügyeleti csomag varázsló segítségével adhatja meg.

Az egyes telefonos hálózati bejegyzések testreszabása a telefonkönyv kapcsolódási pontjaihoz tartozó egyedi hálózati hitelesítési vagy útválasztási igények hatékonyabb kezelését teszi lehetővé. Minden telefonos hálózati bejegyzéshez megadhatja azokat a DNS- vagy Windows Internet Name Service (WINS) címeket, amelyeket az adott bejegyzéshez társított kapcsolódási pontok használnak, és igény szerint egy, a bejegyzéshez társítani kívánt parancsfájlt is.

A Csatlakozáskezelő felügyeleti csomag varázsló futtatása előtt döntse el, hogy mely telefonos hálózati bejegyzéseket szeretné testreszabni, és milyen beállításokat kíván ezekhez használni. Igényeit a tervezőlapon rögzítheti.

Minden egyes telefonos hálózati bejegyzéshez adja meg

  • A telefonos hálózati bejegyzés nevét.

    • Fontos

    • A bejegyzésnek pontosan egyeznie kell a telefonkönyvben szereplő telefonos hálózati bejegyzéssel, vagy ha alapértelmezett beállításokat szeretne megtenni a szolgáltatásprofilhoz, a nevet SzolgáltatásprofilSzolgáltatásnév formátumban kell megadni (az adott szolgáltatásprofil fájlelnevezési szabályának megfelelően).

    A Soft Számítástechnikai Kft. (a kitalált cég szolgáltatóneve) esetében például:

    • Telefonos hálózati bejegyzés egyéni tulajdonságainak beállításához a Csatlakozáskezelő felügyeleti csomag varázslóban megadhatja a Soft TH nevet A telefonkönyv telefonos hálózatra vonatkozó bejegyzései mezőben. Ebben az esetben azok a kapcsolódási pontok, amelyeknél a Soft TH van megadva a telefonkönyv telefonos hálózati bejegyzéseként, a Csatlakozáskezelő felügyeleti csomag varázslóban a Soft TH bejegyzéshez megadott telefonos hálózati címeket, illetve parancsfájlokat használják.
    • Ahhoz, hogy a Soft Számítástechnikai Kft. szolgáltatásprofil-telefonkönyv többi kapcsolódási pontjának alapértelmezett tulajdonságait is beállíthassa, adja meg Hálózati és telefonos kapcsolatok bejegyzésként a Soft1 nevet. Ebben az esetben minden, telefonos hálózati bejegyzéssel nem rendelkező telefonkönyv-bejegyzés a Csatlakozáskezelő felügyeleti csomag varázslóban megadott telefonos hálózati címeket és parancsfájlokat használja.
  • Azt, hogy a kiszolgáló rendelje-e hozzá a címeket, vagy külön DNS-, illetve WINS-címeket kíván-e használni. Ha külön címeket kíván hozzárendelni a telefonos hálózati bejegyzéshez, megadhat elsődleges és másodlagos DNS és WINS IP-címeket is.
  • Ha az adott szolgáltatás igényli, a telefonos hálózati parancsfájl (.scp fájl) társítható a bejegyzéssel.

Egyéni hálózati és telefonos kapcsolatok telepítése

  • Adjon telefonkönyvhöz tartozó telefonos hálózati bejegyzéseket a megfelelő kapcsolódási pontokhoz:
    1. Indítsa el a Telefonkönyv-felügyelőt és kattintson a kívánt telefonkönyvre.
    2. Kapcsolódási pont hozzáadásával vagy szerkesztésével vegye fel a telefonkönyv telefonos hálózati bejegyzését a Beállítások lapon.

    További tájékoztatásért olvassa el a Csatlakozási pont szolgáltatás dokumentációt.

  • A Csatlakozáskezelő felügyeleti csomag varázsló segítségével hozzon létre egy szolgáltatásprofilt, és telepítse a Hálózati és telefonos kapcsolatok összetevőt:
    1. A Telefonos hálózat bejegyzései párbeszédpanelen kattintson a Hozzáadás gombra.
    2. A telefonkönyvben található telefonos hálózati bejegyzések mezőbe írja be ugyanazt a telefonkönyvhöz tartozó telefonos hálózati bejegyzést, amelyet a telefonkönyv-fájlban megadott. Ha külön DNS- vagy WINS-címeket szeretne hozzárendelni, netán telefonos hálózati parancsfájlt szeretne megadni a bejegyzéshez, adja meg a megfelelő adatokat.

      3. Megjegyzés

      • Ne feledje, hogy a szolgáltatásprofilban beállított telefonkönyv telefonos hálózati bejegyzésének a telefonkönyvben beállított megfelelő bejegyzésekkel, vagy, ha az alapértelmezett bejegyzést adja meg, akkor a szolgáltatónévvel kell pontosan megegyeznie.
  • A telefonos hálózati bejegyzések testreszabási lehetőségeiről további tudnivalókat talál a Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése című témakörben.

A következő példában a kapcsolódási pont a telefonos hálózati bejegyzést használja: Soft TH.

Telefonos hálózati bejegyzés

Telefonkönyv telefonos hálózati bejegyzéseinek használata

A Csatlakozáskezelő a telefonos hálózati bejegyzést a telefonszámmal társítva olvassa, és a Csatlakozáskezelő felügyeleti csomag varázslóban a bejegyzés kapcsolat létesítésére vonatkozó beállításokban megadott egyéni Hálózati és telefonos kapcsolatok beállításait (például DNS-kiszolgáló és parancsfájl) használja.

Ha a Csatlakozáskezelő nem észleli a szolgáltatásprofil telefonszámához megadott telefonos hálózati bejegyzést, akkor megkeresi az alapértelmezett telefonos hálózati bejegyzést (a SzolgáltatásprofilFájlnév nevűt).


A VPN-támogatás megvalósítása

A virtuális magánhálózati (VPN) kapcsolatok az Interneten (vagy más hálózaton) keresztül távoli hozzáférést biztosítanak a magánhálózatokhoz. A VPN-kapcsolat egy úgynevezett bújtatóprotokoll használatával jön létre, mely egy bújtatatási alagutat képez az Interneten keresztül a magánhálózathoz. Így sokkal biztonságosabb kapcsolat jön létre, mint normál csatlakozás esetén. VPN-kapcsolat létesítésekor a felhasználó vagy a helyi Internet-szolgáltató tárcsázásával létrejövő, vagy egy már meglévő (közvetlen) kapcsolat által biztosított bújtatási alagúton keresztül, közvetlenül csatlakozik a magánhálózathoz.

Ez azt jelenti, hogy a távoli felhasználók a világszerte megtalálható Internet-hozzáférési pontok segítségével épp olyan könnyen tudnak tűzfallal védett kiszolgálókhoz csatlakozni, mint a helyi felhasználók. Cégek esetén ez annyit jelent, hogy az alkalmazottak az Interneten keresztül – általában helyi telefonszám használatával – távolról is hozzáférhetnek cégük magánhálózatához.

A VPN-kapcsolatokat a Csatlakozáskezelő felügyeleti csomag varázsló segítségével konfigurálhatja, beleértve a következő beállításokat:

  • VPN-támogatás hozzáadása a szolgáltatásprofilhoz
  • VPN-kapcsolat használata egyesített szolgáltatásprofilokhoz

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével beállíthatja a VPN-kapcsolatok Point-to-Point Tunneling protokollal (PPTP) történő támogatását is. A VPN-kapcsolatok használatához olyan kiszolgálóval kell rendelkeznie a magánhálózaton, amely a PPTP protokoll támogatására van konfigurálva.

A PPTP protokoll a VPN által támogatott TCP/IP alapú magánintranetekkel és a helyi hálózatokkal való VPN-kapcsolatokat támogatja.

Fontos

  • A Windows 2000 Csatlakozáskezelő a Layer Two Tunneling protokoll (L2TP) használatát is támogatja. Ha az L2TP protokollt kívánja bújtatóprotokollként használni (az alapértelmezett PPTP helyett), speciális testreszabási eljárások segítségével meg kell változtatnia a .cms fájl VpnStrategy bejegyzését. A kiszolgálót úgy kell beállítani, hogy ugyanazt a protokollt támogassa, mint ami a Csatlakozáskezelő szolgáltatásprofiljában meg van adva.
  • Bár a PPTP és az L2TP a TCP/IP protokollon kívül több hálózati protokollt is támogat, VPN-kapcsolat esetén a Csatlakozáskezelő szolgáltatást futtató számítógépet úgy kell beállítani, hogy ugyanazokat a hálózati protokollokat használja, mint amelyeket a magánhálózat a végponton lévő kiszolgálónál használ. Ha például a magánhálózat az IPX protokollt használja, akkor azt a számítógépet, amellyel a felhasználók a szolgáltatáshoz kapcsolódnak előbb be kell állítani az IPX használatára.
  • A Windows 98 és a Windows 95 rendszereket futtató számítógépeken VPN-kapcsolat létesítéséhez a Hálózati és telefonos kapcsolatok szoftver legújabb változatára van szükség. A felhasználók a legfrissebb Hálózati és telefonos kapcsolatok szoftvert a Microsoft Support Online webhelyről tölthetik le. (http://support.microsoft.com/support/downloads/default.asp) Erről a követelményről tájékoztatni kell a felhasználókat is. A Hálózati és telefonos kapcsolatok szoftver ellenőrzéséről és telepítéséről további információ a Dokumentáció csatolása című részben található.

Megjegyzés

  • Olyan szolgáltatásprofilt is létrehozhat, amelynek segítségével a felhasználók közvetlen VPN-kapcsolatot hozhatnak létre már meglévő kapcsolatok feletti bújtatási alagút használatával.

Amikor a profilt VPN-kapcsolat támogatására állítja be, a Tulajdonságok párbeszédpanelen megjelenik egy Internetes bejelentkezés nevű lap. Ezen a lapon a felhasználó a felhasználónevet és a jelszót adja meg az Internet-szolgáltató számára. A bejelentkezési párbeszédpanelen a felhasználó megadhat egy magánhálózati felhasználónevet, egy jelszót és egy bejelentkezési tartományt.

A VPN-kapcsolatok saját szolgáltatásprofilban történő kialakításához meg kell adnia a használni kívánt kiszolgáló címét és a hitelesítés kezelésének módját. A Csatlakozáskezelő felügyeleti csomag varázsló futtatása előtt a következőkre kell ügyelnie:

  • Rendelkeznie kell a DNS-névként vagy a végponti kiszolgáló TCP/IP-címeként megadott, megfelelő kiszolgálócímmel.
  • Ha nem szeretné, hogy a kiszolgáló jelöljön ki címeket, akkor a következő, DNS vagy Windows Internet Name Service (WINS) által kijelölt címeket használhatja:
    • Egy elsődleges és egy másodlagos, DNS által biztosított IP-cím a végponton lévő kiszolgáló számára
    • Egy elsődleges és egy másodlagos, WINS által biztosított IP-cím a végponton lévő kiszolgáló hálózatán történő névhozzárendeléshez
  • Meg kell adnia, hogy a felhasználók ugyanazt a felhasználónevet és jelszót használják-e, amikor telefonos kapcsolat segítségével bejelentkeznek az Internetre, mint amikor VPN-kapcsolat használatával bejelentkeznek a magánhálózati kiszolgálóra. Ha úgy dönt, hogy a felhasználóknak mindkét esetben ugyanazt a hitelesítő adatokat kell használniuk, akkor az Internetes bejelentkezés fül nem jelenik meg, és a felhasználóknak csak egyszer kell megadniuk a hitelesítő adatokat a csatlakozáshoz.

A közvetlen kapcsolatokról további információ a Speciális testreszabás: szolgáltatásprofil-fájlok szerkesztése című részben található.


Csatlakozási műveletek beépítése

A felhasználó csatlakoztatásának folyamatát különböző programokkal egészítheti ki, melyek a szolgáltatáshoz történő csatlakozás közben indulnak el. A Csatlakozáskezelő felügyeleti csomag varázsló segítségével a szolgáltatásprofilba csatlakozási műveleteket építhet be, így ha felhasználó kapcsolódik a szolgáltatáshoz, a programok automatikusan elindulnak. Ezek a csatlakozási műveletek használhatják a felhasználó számítógépére már telepített programokat, de beépítheti a programokat a szolgáltatásprofilba is.

Melyek a támogatott csatlakozási műveletek, és mikor futnak?

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével a kapcsolatfelvételi eljárás négy pontján futtathatók csatlakozási műveletek. Futtathatók:

  • Csatlakozás előtti műveletek
  • Protokollbújtatás előtti műveletek (csak VPN-kapcsolatok esetén)
  • Csatlakozás utáni műveletek
  • Kapcsolatbontási műveletek

Megjegyzés

  • További (tárcsázás előtti, visszavonáskor vagy hibánál bekövetkező) csatlakozási műveletek a speciális testreszabási technikák használatával érhetők el, de a varázslóban nem adhatók meg.

Csatlakozás előtti műveletek

Amint a felhasználó a Csatlakozás gombra kattint, a Csatlakozáskezelő a szolgáltatásprofilban meghatározott csatlakozás előtti műveleteket futtatja. A futtatás még azelőtt történik, hogy a Csatlakozáskezelő kapcsolatot hozna létre a szolgáltatással.

Nem állíthatók be olyan csatlakozás előtti műveletek, melyekhez elő kapcsolat szükséges a szolgáltatással. Ha csak a művelet egy részéhez szükséges az elő kapcsolat, ossza a műveletet két részre. Egy csatlakozás előtti műveletre, és (a kapcsolat követelményeitől függően) egy protokollbújtatás előtti vagy egy csatlakozás utáni műveletre.

Csatlakozás előtti művelet lehet például a helyi naplófájlba történő adatrögzítés a bejelentkezési folyamat kezdetén, de ha azt szeretné, hogy a naplófájl ezeket az adatokat továbbítsa is a hálózatra, telepíthet külön egy küldő programot, amit csatlakozás utáni vagy kapcsolatbontási műveletként futtathat.

Protokollbújtatás előtti műveletek (csak VPN-kapcsolatok esetén)

A Csatlakozáskezelő a protokollbújtatás előtti műveleteket az Internet-kiszolgálóhoz történő csatlakozás után futtatja, de még azelőtt, hogy létrehozná a bújtatási alagutat a virtuális magánhálózati kiszolgálóhoz. Ez a csatlakozási művelet csak akkor érhető el, ha a szolgáltatásprofilba a VPN-támogatást beépíti, és csak akkor fut, ha a felhasználó a VPN-kapcsolatra vonatkozó beállítási lehetőséget használja.

Mivel a bújtatási alagút létrehozása után a Csatlakozáskezelő hozzáférése az Internet-kiszolgálóhoz korlátozott, virtuális kapcsolatokhoz protokollbújtatás előtti műveletként telepítse az összes olyan csatlakozási műveletet, melyhez kommunikálni kell az Internet-kiszolgálóval.

Ez lehet például olyan program, ami ellenőrzi a telefonkönyv frissítését, vagy egy tűzfal mögötti, vállalati kiszolgálóhoz történő hozzáférés előtt ellenőrzi a felhasználó hitelesítő adatait. Lehetnek más egyéb programok is, melyekhez az Internet-kiszolgálóval való kommunikáció szükséges. Ezek a bújtatási alagút létrehozása után nem hozzáférhetők.

Közvetlen kapcsolat esetén a Csatlakozáskezelő a csatlakozás előtt futtatja mind a csatlakozás előtti, mind a protokollbújtatás előtti műveleteket.

Csatlakozás utáni műveletek

A Csatlakozáskezelő a kapcsolat létrehozása, VPN-kapcsolatok esetén a bújtatási alagút létrehozása után futtatja a csatlakozás utáni műveleteket.

A Csatlakozáskezelő felügyeleti csomag varázsló Csatlakozási műveletek párbeszédpanelén az egyedi csatlakozás utáni műveleteken kívül megadhatja, hogy a Csatlakozáskezelő az alábbi szokásos csatlakozás utáni műveleteket futtassa, a kapcsolat típusától függetlenül.

  • A telefonkönyv-frissítések automatikus letöltése. Ha úgy állítja be a szolgáltatásprofilt, hogy támogassa ezt a lehetőséget, a Csatlakozáskezelő a telefonkönyv frissítését kérelmezi a Telefonkönyv-szolgáltatást futtató kiszolgálótól. A kiszolgáló összehasonlítja az ügyfél telefonkönyvét a legújabb elérhető fájlokkal, majd letölti az összes lehetséges frissítést. A Csatlakozáskezelő legközelebbi indításakor a frissített hívószámok már elérhetők. Ha telepíteni szeretné ezt a csatlakozási műveletet, meg kell adnia a telefonkönyv nevét, és a telefonkönyv-szolgáltatás URL-címét. A telefonkönyv frissítéséről további információ a Csatlakozási pont szolgáltatás témakörben található.

Megjegyzés

  • Ha olyan 1.0-s verziószámú Csatlakozáskezelő szolgáltatásprofillal rendelkezik, amely csatlakozási műveleteket tartalmaz, jó tudni, hogy ezek megegyeznek a Csatlakozáskezelő 1.2-es verziójának csatlakozás utáni műveleteivel. Valójában a Csatlakozáskezelő 1.2-es verziójában a csatlakozás utáni műveletek a .cms fájlok [Connect Actions] részében vannak megadva, mivel nincs [Post-Connect Actions] című rész. A korábbi verzióról történő átállás érdekében a terminológia ugyanaz maradt.

Kapcsolatbontási műveletek

A kapcsolatbontási műveleteket a Csatlakozáskezelő közvetlenül a szolgáltatással való kapcsolat megszakítása előtt futtatja. A kapcsolatbontási műveletek a szokásos felügyelethez is használhatók. Beállíthat például egy csatlakozási műveletet, hogy a szolgáltatásról állapotinformációkat gyűjtsön, például hogy mennyi ideig tartott a kapcsolat (ha ezt az adatot a szolgáltatás rögzíti). Az adatokat ezután a felhasználó megtekintheti.

Milyen programok használhatók csatlakozási műveletként?

A csatlakozási művelet lehet:

  • Dinamikus csatolású függvénytár (DLL). Csak a DLL-ek futnak szinkronizáltan, ami annyit jelent, hogy a Csatlakozáskezelő elindítja a műveletet, és addig nem folytatja, amíg a függvény vissza nem tér. Az első argumentum, mely a Csatlakozáskezelő felügyeleti csomag varázsló Csatlakozási műveletek hozzáadása/módosítása párbeszédpanel Paraméterek mezőjében adható meg, a DLL-ből hívandó függvény neve. Az ilyen csatlakozási műveletek szintaxisa:
    HRESULT WINAPI függvény
    [IN] HWND hWndParent
    [IN] HINSTANCE hinstDll
    [IN] LPCSTR pszCommandLine
    [IN] DWORD dwReserved

    • A támogatott DLL-paraméterek a következők:

    Paraméter | Eredmény
hWndParent | A Csatlakozáskezelő bejelentkezési párbeszédpaneléhez tartozó leíró, vagy NULL, mely minden felhasználói felületnek a csatlakozási művelet által megjelenített szülőablaka.
hinstDll | Leíró ezen DLL példányához.
pszCommandLine | Karakterlánc-mutató a parancssori argumentumokhoz.
dwReserved | Foglalt későbbi használatra.

    A DLL-ekhez gyakran tartozik megjegyzés (ez a varázsló leírás mezőjében adható meg), mely megjelenik futtatás közben. A megjegyzés formája a következő: A következő csatlakozási művelet futtatása: (leírás). Amíg ez a művelet fut, a Csatlakozáskezelő ablaka le van tiltva, és adatok nem vihetők be.

    A csatlakozási művelethez visszatérési érték szükséges. Ha a visszatérési érték 0-nál kisebb, a DLL meghívása nem sikerül. (A SUCCEEDED makró visszatérési értéke False, azaz Hamis.) Ilyenkor egy (a visszatérési értéket tartalmazó) hibaüzenet jelenik meg a képernyőn, a következő formában: „A következő csatlakozási művelet nem sikerült: (leírás) (visszatérési érték).” Ha egy csatlakozás előtti, protokollbújtatás előtti vagy csatlakozás utáni művelet nem sikerül, a csatlakozási kísérlet befejeződik.

    A függvény hívása után a DLL eltávolítódik.

    Megjegyzés

    • A program futtatásához sok időt igénylő .dll fájlok esetében a WM_PAINT függvény beépítése ajánlatos, hogy a felhasználó a képmegjelenítést ne zavarhassa meg.
  • Végrehajtható fájl (például .bat, .exe, .cmd). Ez a fajta csatlakozási művelet aszinkron módon fut, ami annyit jelent, hogy a Csatlakozáskezelő elindítja a végrehajtható fájlt és minden parancssori paramétert, a folytatáshoz viszont nem várja meg a folyamat végét. A Csatlakozáskezelő állapot mezőjében nem jelenik meg üzenet, ha ilyen programok futnak.
  • A parancsértelmező héj által végrehajtható fájl, például .txt, .doc. Ezek a műveletek aszinkron módon futnak. Az ilyen fájlok megnyitásához a megfelelő program szükséges.

Megjegyzés

  • Ahhoz, hogy a kapcsolat bizonyos programok befejeztével megszűnjön, automatikusan futó alkalmazásokként, ne pedig csatlakozási műveletekként adja meg azokat. Ha például automatikusan futtatni szeretne egy elektronikus levelezőprogramot, és amikor a felhasználó a programból kilép, akkor a kapcsolatot szeretné automatikusan megszüntetni, a levelezőprogramot automatikusan futó alkalmazásként kell beállítania, nem pedig csatlakozási műveletként.

Csatlakozási művelet megadása

Válassza ki a Csatlakozáskezelő felügyeleti csomag varázslóban, hogy a négyféle csatlakozási művelet közül melyeket kívánja beépíteni a szolgáltatásprofilba. Ha kiválaszt egy művelettípust, meg kell adnia az összes ilyen típusú csatlakozási műveletet, melyet a kapcsolatfelvételi eljárás során futtatni szeretne. Külön kell megadnia a Csatlakozás előtti műveletek, a Protokollbújtatás előtti műveletek, a Csatlakozás utáni műveletek és a Kapcsolatbontási műveletek párbeszédpanelen, hogy mely csatlakozási műveleteket kívánja futtatni. Minden csatlakozási művelet esetében be kell vinni a megfelelő adatokat a varázsló Csatlakozási műveletek hozzáadása/módosítása párbeszédpanelén:

  • Leírás: Írja le röviden a futtatandó programot. Ha nem ad leírást, a Csatlakozáskezelő felügyeleti csomag varázsló leírásként a program nevét fogja használni (melyet A futtatni kívánt program mezőben adott meg).
  • A futtatni kívánt program: Adja meg a futtatandó program vagy fájl nevét és kiterjesztését (például .dll, .exe, .bat vagy .cmd).
  • Paraméterek: Adja meg a programmal együtt futtatni kívánt parancssori paramétereket. A következő speciális parancssori paramétermakrók használhatók:
    Makró | Felcserélve a következővel
    %ServiceName% | A megadott szolgáltatásnév
    %UserPrefix% | A tartománynév megadott felhasználónév-előtagja
    %UserSuffix% | A tartománynév megadott felhasználónév-utótagja
    %UserName% | A felhasználónév minden tartományi felhasználónév-előtag vagy utótag nélkül
    %Profile% | Az aktív csatlakozásprofil (.cmp) fájljának helye és neve
    %DialRasPhoneBook% | A megadott telefonos távelérésű telefonkönyv neve
    %TunnelRasPhoneBook% | A távelérésű VPN-telefonkönyv megadott neve
    %DialRasEntry% | A Hálózati és telefonos kapcsolatok szolgáltatás neve vagy a telefonos kapcsolathoz tartozó távelérési bejegyzés neve
    %TunnelRasEntry% | A Hálózati és telefonos kapcsolatok szolgáltatás neve vagy a protokollbújtatásos kapcsolat távelérési bejegyzésének neve
    %AutoRedial% | Logikai jelző, melynek értéke 1, ha a tárcsázás automatikus újrahívás, egyébként 0
    %PopName% | A CM-telefonkönyvben lévő telefonszám leírása
    %ErrorCode% | A hibás csatlakozási műveletek WIN32 hibakódja
    Ha vannak megadott paraméterek, a Csatlakozáskezelő elolvassa a paraméterként kapott karakterláncot és átadja a .dll fájl pszCommandLine paraméterének, vagy a parancssor részeként elküldi egy végrehajtható fájlnak (a Windows API GetCommandLine függvényén keresztül).
    • Ha a csatlakozási művelet DLL-fájlból fut, a meghívandó függvény belépési pontja a paraméterként megadott karakterlánc első tokenje. A token eltávolításra kerül a paraméterek közül, mielőtt a karakterlánc a DLL-fájlhoz kerülne (így a pszCommandLine karakterlánc nem a .dll nevével, mint első paraméterrel fog kezdődni). A DLL létrehozásánál ügyeljen arra, hogy a DLL exportált neve megegyezzen az első paraméterként megadottal, mert másképpen a nevek összekeverednek. (A C++ nyelvben például a nevek összekeverése azt okozhatja, hogy az exportált név más lesz, mint a függvény valódi neve.)
    • Ha az előző táblázatban bemutatott makrókat használja, a Csatlakozáskezelő azokat a tényleges futásidejű információkra cseréli fel, és ezeket adja át paraméterként. Ha például olyan csatlakozási műveletet szeretne, amely arról gyűjt információt, hogy mely felhasználók mely csatlakozási pontokat (POP) használják, készítsen egy .dll (vagy egyéb végrehajtható) fájlt, melynek a Csatlakozáskezelő átadhatja az információkat – például a felhasználónevet (a %UserName% makró segítségével), a tartományinformációkat (a %Prefix% vagy a %Suffix% makró segítségével), illetve a POP-nevet (a %PopName% makró használatával). Ehhez a Paraméterek mezőbe írja be a következőt:
      LogUserAndPopToServer %UserPrefix% %UserName% %UserSuffix% %PopName% http://logserver.soft.hu %AutoRedial%
      A felhasználó csatlakozási módjától függően a DLL-nek átadott információ a következő lehet:
      NULL Anna @soft.hu "Eger 28,800" http://logserver.soft.hu

      A Csatlakozáskezelő a karakterláncokban szereplő null-mutatókat nem tudja értelmezni, így (minden meg nem határozott paraméter számára) a „NULL” karakterláncot adja át. A számváltozók a karakterlánc alapján határozhatók meg. Ha DLL helyett más végrehajtható fájlt használ, a függvény nevére (a fenti példában LogUserAndPopToServer) nincs szükség.
  • Ezen program beépítése a szolgáltatásprofilba: Adja meg, hogy beépíti-e a programot a szolgáltatásprofilba, vagy a felhasználóknak kell azt beszerezni. Ha a futtatni kívánt program nem része a szabványos Windows operációs rendszernek, vagy ha másképp nem érhető el a felhasználó számára, a programot beépítheti a szolgáltatásprofilba. A csatlakozási műveleteket vezérlő program telepítéskor a szolgáltatásprofil mappájába kerül.
  • A program futtatása a következő kapcsolat esetén: A VPN-támogatást meghatározó szolgáltatásprofilok esetében adja meg, hogy az egyes csatlakozási műveletek milyen típusú kapcsolatot támogatnak:
    • Csak telefonos kapcsolat
    • Csak közvetlen kapcsolat
    • Telefonos és közvetlen kapcsolatok (alapértelmezett)

Csak olyan programokat adjon meg, amelyek teljes programfájlokat alkotnak. Minden csatlakozási művelethez egy programfájl tartozhat. Ha nem végrehajtható fájlok szükségesek a csatlakozási művelet támogatásához, azokat nem mint csatlakozási műveleteket, hanem mint további fájlokat kell csatolni. Ezeknek a kiegészítő fájloknak olyanoknak kell lenniük, amelyeket a telepítőprogram a szolgáltatásprofillal együtt telepít, de amelyeknek nem kell futniuk. Ha többet szeretne tudni arról, hogyan építheti be ezen segédfájlokat a szolgáltatásprofilba, olvassa el a További fájlok csatolása című témakört.

Megjegyzés

  • A csatlakozási műveletek a Csatlakozáskezelő felügyeleti csomag varázslóban megadott sorrendben futnak.


Automatikusan futó alkalmazások beépítése

A Csatlakozáskezelő az adott kapcsolat, illetve VPN-kapcsolatok esetén a bújtatási alagút létrehozása után futtatja az automatikusan futó alkalmazásokat. A Csatlakozáskezelő felügyeleti csomag varázslóban megadott összes automatikusan futó alkalmazás annyiszor fut, ahányszor a felhasználó a szolgáltatáshoz kapcsolódik, akár telefonos kapcsolaton, akár közvetlen kapcsolaton keresztül.

Az automatikusan futó alkalmazások a kapcsolat utáni műveletekhez hasonlóak, a következők kivételével:

  • Minden automatikusan futó alkalmazás aszinkron módon fut. A dinamikus csatolású függvénytárak (DLL) viszont szinkronizáltan futnak, ezért nem futtathatók automatikusan futó alkalmazásokként.
  • A Csatlakozáskezelő valamennyi automatikusan futó alkalmazás állapotát automatikusan figyeli, és az utolsó bezárásakor elindítja a kapcsolatbontási folyamatot.

Megjegyzés

  • Az utolsó nyitva lévő automatikus alkalmazás bezárásakor a Csatlakozáskezelő párbeszédpanelt jelenít meg, amelyen a felhasználó leállíthatja a megszakítási folyamatot. A felhasználó a Kapcsolat megtartása gombra kattintva megakadályozhatja a kapcsolat bontását, a Kapcsolat bontása gombra kattintva azonnal bonthatja a kapcsolatot. Ha nem avatkozik közbe, a kapcsolat 30 másodperc múlva automatikusan megszakad.

A csatlakozás utáni műveletekre és egyéb csatlakozási műveletekre vonatkozóan a Csatlakozási műveletek beépítése című témakörben található további információ.

Akárcsak a csatlakozás utáni műveletek esetén, itt is meg kell adni a szolgáltatásprofilban meghatározott valamennyi automatikusan futó alkalmazáshoz a megfelelő adatokat, beleértve a futtatandó program nevét, azt, hogy bekerüljön-e a program a szolgáltatásprofilba, és minden olyan parancssori paramétert, amelyet a programmal együtt szeretne futtatni. A csatlakozás utáni műveletektől eltérően az automatikusan futó alkalmazásoknak nem kell leíró nevet adnia.

A csatlakozási műveletekhez biztosított speciális parancssori paramétermakrók az automatikus alkalmazásokhoz is használhatók.

Makró | Felcserélve a következővel
%ServiceName% | A szolgáltatás felhasználó által meghatározott neve.
%UserPrefix% | A felhasználó által megadott tartományi felhasználónév-előtag.
%UserSuffix% | A felhasználó által megadott tartományi felhasználónév-utótag.
%UserName% | A felhasználónév minden tartományi felhasználónév-előtag vagy -utótag nélkül.
%Profile% | Az aktív csatlakozásprofil (.cmp) fájljának helye és neve.
%DialRasPhoneBook% | A megadott telefonos távelérésű telefonkönyv neve.
%TunnelRasPhoneBook% | A távelérésű VPN-telefonkönyv megadott neve.
%DialRasEntry% | A Hálózati és telefonos kapcsolatok szolgáltatás neve vagy a telefonos kapcsolathoz tartozó távelérési bejegyzés neve.
%TunnelRasEntry% | A Hálózati és telefonos kapcsolatok szolgáltatás vagy a protokollbújtatásos kapcsolat távelérési bejegyzésének neve.
%AutoRedial% | Logikai jelző, amelynek értéke 1, ha a tárcsázás automatikus újrahívás, egyébként 0.
%PopName% | A Csatlakozáskezelő telefonkönyvében lévő telefonszám leírása.
%ErrorCode% | A hibás csatlakozási műveletek WIN32 hibakódja.

Ha a fenti makrók használatával kapcsolatban további információra van szüksége, tanulmányozza a Csatlakozási műveletek beépítése című témakört.

Fontos!

  • Csak olyan programokat adjon meg, amelyek teljes programfájlokat alkotnak. Minden automatikusan futó alkalmazáshoz egy programfájl tartozhat. Ha olyan automatikusan futó alkalmazást ad meg, amelyhez más fájlok is szükségesek, illetve amely önkicsomagoló végrehajtható (.exe) fájl, ezeknek a fájloknak a hatására a program leállhat, vagy a kapcsolat megszakadhat. Ha nem végrehajtható fájlok szükségesek az automatikusan futó alkalmazás támogatásához, azokat mint külön fájlokat kell megadni a Csatlakozáskezelő felügyeleti csomag varázslóban. Ezeknek a kiegészítő fájloknak olyanoknak kell lenniük, amelyeket a telepítőprogram a szolgáltatásprofillal együtt telepít, de amelyeknek nem kell futniuk. Ha többet szeretne tudni arról, hogyan építheti be ezen segédfájlokat a szolgáltatásprofilba, olvassa el a További fájlok felvétele című témakörben leírtakat.

Automatikusan futó alkalmazásként szabványos és egyedi programokat is megadhat. Elképzelhető például, hogy a szolgáltatásprofilba egy kereskedelmi forgalomban kapható elektronikus levelezőprogramot, egy bejegyzett árfolyamjelző programot, valamint egy belső könyvelőprogramot szeretne felvenni. A Csatlakozáskezelő felügyeleti csomag varázsló segítségével mindhárom programot megadhatja. Azt is meghatározhatja, hogy az automatikusan futó alkalmazásokhoz tartozó programok bekerüljenek-e a szolgáltatásprofilba.

Megjegyzések

  • Ha a program már telepítve van a felhasználó számítógépére, ne foglalja bele a szolgáltatásprofilba. Ezzel megnövelné a szolgáltatásprofil méretét, és problémákat okozhatna a felhasználó számítógépén.
  • Ha az Internet Explorert automatikusan futó alkalmazásként szeretné futtatni, az Internet Explorer 4.01-es verzióját ne adja meg automatikusan futó alkalmazásként, mivel az még akkor is futni fog, amikor a felhasználók már bezárták a böngészőt.


Egyéni képek beépítése

A Csatlakozáskezelő felügyeleti csomag varázslóban meg kell adnia, hogy a Csatlakozáskezelő alapértelmezett bitképeket vagy egyéni képeket használjon-e. Testreszabhatja a felhasználói felületet annak érdekében, hogy az tartalmazza a cég emblémáját vagy más olyan képet, amellyel azonosíthatja vállalatát. A bejelentkezési és Telefonkönyv párbeszédpanelen található képeket is kicserélheti. A behelyettesítésre kerülő képnek bitkép (.bmp) fájlnak kell lennie.

Bejelentkezési kép

Ha a bejelentkezési párbeszédpanel tetején megjelenő alapértelmezett Csatlakozáskezelő bejelentkezési bitképet ki szeretné cserélni, a cseréhez létező bitképet, illetve újonnan létrehozott egyéni bitképet is használhat. Az alapértelmezett bitkép mérete 330x141 képpont.

Bejelentkezési kép

Telefonkönyvkép

A Telefonkönyv párbeszédpanelen található bitképet is testreszabhatja – ezt a képet a felhasználók akkor látják, ha telefonos kapcsolathoz jelölnek ki egy telefonszámot. Ez a bitkép a Telefonkönyv párbeszédpanel bal oldalán jelenik meg. Az alapértelmezett bitkép mérete 114x304 képpont.

Telefonkönyvkép

Bitképek létrehozása

Ha a fent említett két cserélhető képhez szeretne létrehozni bitképeket, vegye figyelembe az alábbiakat:

  • A bitkép akkor jeleníthető meg legjobban, ha arányai megegyeznek az alapértelmezett bitkép arányaival.

    • A Csatlakozáskezelő automatikusan méretezi a bitképet annak érdekében, hogy az a megfelelő méretben jelenjen meg, de ha az arányok nem megfelelőek, a kép torz lehet.

  • A Csatlakozáskezelő a megjelenítési módtól függetlenül mindig ugyanazt a bitképkészletet használja.
  • Bitképek létrehozásakor használja a Microsoft Internet Explorer 256 színű (félárnyékos) palettáját.

Mindenképpen tesztelje a bitképet valamennyi célplatformon és operációs rendszeren.

Testreszabhatja a felhasználók által látható három ikont is. További információ az Egyéni ikonok beépítése című témakörben található.


Telefonkönyv-támogatás

A Csatlakozási pont szolgáltatás telefonkönyvek létrehozásához, karbantartásához, valamint frissítéséhez nyújt támogatást. A Csatlakozási pont szolgáltatás segítsége nélkül is létrehozhat telefonkönyvet, de ha több mint egy kapcsolódási ponttal (POP) rendelkezik, a formátum és a követelmények összetettsége ezt nagyban megnehezíti.

A telefonkönyv közzétételének meghatározása

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével az alábbi lehetőségek közül választhat:

  • Telefonkönyv használata a szolgáltatásprofilban, automatikus frissítések támogatása nélkül. Ehhez az alábbiakat kell a Csatlakozáskezelő felügyeleti csomag varázslóval végrehajtania:
    1. Gondoskodjon arról, hogy a Csatlakozás utáni műveletek párbeszédpanelen A telefonkönyv-frissítések automatikus letöltése jelölőnégyzet ne legyen bejelölve.
    2. A Telefonkönyv párbeszédpanelen keresse meg azt a telefonkönyvfájlt (.pbk), amelyet a szolgáltatásprofilba szeretne foglalni. Ellenőrizze, hogy rendelkezik-e a .pbk fájl mappájában a fájllal egyező nevű területfájllal. Ha a telefonkönyvfájl neve például SoftE.pbk, a területfájl neve legyen SoftE.pbr.
  • Telefonkönyv használata a szolgáltatásprofilban, automatikus frissítések támogatásával. Ehhez az alábbiakat kell a Csatlakozáskezelő felügyeleti csomag varázslóval végrehajtania:
    1. A Csatlakozás utáni műveletek párbeszédpanelen jelölje be A telefonkönyv-frissítések automatikus letöltése jelölőnégyzetet.
    2. A Telefonkönyv párbeszédpanelen keresse meg azt a telefonkönyvfájlt (.pbk), amelyet a szolgáltatásprofilba szeretne foglalni. Ellenőrizze, hogy rendelkezik-e a .pbk fájl mappájában a fájllal egyező nevű területfájllal. Ha a telefonkönyvfájl neve például SoftE.pbk, a területfájl neve legyen SoftE.pbr.
    3. A Telefonkönyv frissítései párbeszédpanelen írja be a Csatlakozási pont szolgáltatás kiszolgálójának azt az URL-címet, ahonnan a frissítéseket szeretné letölteni.
  • Ne tartalmazzon telefonkönyvet a szolgáltatásprofil, hanem a telefonkönyvet (és a frissítéseket) később töltse le a felhasználóknak. Ehhez az alábbiakat kell a Csatlakozáskezelő felügyeleti csomag varázslóval végrehajtania:
    1. A Csatlakozás utáni műveletek párbeszédpanelen jelölje be A telefonkönyv-frissítések automatikus letöltése jelölőnégyzetet.
    2. A Telefonkönyv párbeszédpanelen hagyja a Telefonkönyvfájl mezőt üresen.
    3. A Telefonkönyv frissítései párbeszédpanelen írja be a letöltendő telefonkönyvfájl (.pbk) nevét (a fájlkiterjesztés nélkül), valamint írja be a Csatlakozási pont szolgáltatás szolgáltatója számára azt az URL-címet, ahonnan a telefonkönyv (és a frissítések) letölthető.
    Ha a telefonkönyv létrehozásának ezt a módját használja, a megadott telefonkönyvnév és URL-cím segítségével lehetősége lesz felhasználói számára automatikusan frissítéseket letölteni.

A megadott telefonkönyvnévnek egyeznie kell a Csatlakozási pont szolgáltatás segítségével létrehozott telefonkönyvfájl nevével. A fájlnév legfeljebb 8 alfanumerikus karakterből állhat, és nem tartalmazhat szóközt vagy fájlkiterjesztést. Ha beállítja az automatikus frissítések támogatását, a Telefonkönyv-szolgáltatás a felhasználó minden egyes csatlakozásakor automatikusan letölti a telefonkönyv esetleges frissítéseit.

Az alábbi példában a szolgáltatásprofil úgy van beállítva, hogy a SoftE nevű telefonkönyvet töltse le. A telefonkönyv nevének egyeznie kell a Telefonkönyv-felügyelőben megjelenő telefonkönyvfájl nevével.

Telefonkönyv

További telefonszámok használata

A Csatlakozási pont szolgáltatás Telefonkönyv-felügyelője segítségével a telefonkönyveket úgy is beállíthatja, hogy bizonyos csatlakozási pontok a Telefonszámok mezőben, míg más csatlakozási pontok a További telefonszámok mezőben jelenjenek meg. Ha a telefonszámokat szeretné két csoportra osztani, a telefonkönyvet e célra külön konfigurálnia kell, mielőtt a szolgáltatásprofilban használatba venné. A telefonszámokat többféleképpen is csoportosíthatja: a szabványos telefonszámokat elkülönítheti például az ingyenesen hívható telefonszámoktól, vagy a nem emeltdíjas telefonszámokat elkülönítheti az olyan számoktól, amelyekre akkor kell további díjat fizetni, ha a felhasználó ilyen számon keresztül csatlakozik a szolgáltatáshoz. További tájékoztatásért olvassa el a Csatlakozási pont szolgáltatás felügyeleti útmutató című témakört.

Ha a telefonkönyv egy második telefonszámkészletet is tartalmaz, akkor azok a számok a Telefonkönyv párbeszédpanel További telefonszámok mezőjében jelennek meg.

A telefonszámokkal kapcsolatos információ testreszabása:

  • Írjon egy sor szöveget a párbeszédpanel További telefonszámok mezője melletti területre. A szöveg ne legyen hosszabb 100 karakternél. (A legnagyobb méret a sortörés és egyéb formázási szempontok alapján változik.) Ez a szöveg csak akkor jelenik meg, ha a kijelölt földrajzi területhez több telefonszám tartozik.
  • A további telefonszámok listáját a definíciós súgó segítségével szerkesztheti. Az alapértelmezett súgó arról tájékoztat, hogy a további telefonszámok használata esetén a felhasználónak felárat kell fizetnie. Ha ez a megadott további telefonszámok esetében nem igaz, a súgó ezen témakörét a Cmtrb32.rtf fájlban javíthatja ki: IDH_PHONEBOOK_ACCESSNUMS és IDH_PHONEBOOK_MORE. A súgó testreszabásáról további információt talál az Egyéni Windows súgó című témakörben.

A telefonkönyv speciális testreszabása

A speciális testreszabás segítségével az alábbi műveleteket végezheti el:

  • Beállíthatja, hogy a Telefonkönyv párbeszédpanelen melyik szolgáltatástípus (például modem vagy ISDN) jelenjen meg.
  • Módosíthatja a telefonkönyv frissítései során megjelenő üzenetet (például A Soft Számítástechnikai Kft. vállalati telefonkönyve új biztonsági példányának letöltése).
  • Meghatározhatja a telefonkönyv-frissítések letöltése előtti késleltetés mértékét.

A speciális testreszabással kapcsolatban további információt a Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése című témakörben talál.

Egyetlen kapcsolódási pontot tartalmazó telefonkönyv létrehozása

Olyan alapértelmezett telefonkönyvet is megadhat, amely egyetlen telefonszámot tartalmaz. Ez a lehetőség akkor hasznos, ha azt szeretné, hogy az ügyfelek a szolgáltatáshoz egyetlen kapcsolódási ponton (POP-on) keresztül férjenek hozzá. Ha több kapcsolódási pontot tartalmazó telefonkönyvet szeretne létrehozni, használja a Csatlakozási pont szolgáltatást.

Egyetlen kapcsolódási pontot tartalmazó telefonkönyv létrehozása érdekében telefonkönyvfájlt (.pbk) és területfájlt (.pbr) is létre kell hoznia. A Csatlakozáskezelő felügyeleti csomag varázslóban a .pbk fájl nevét kell csak megadnia, a varázsló viszont megköveteli, hogy a .pbk fájl mappájában egy ugyanolyan nevű .pbr fájl is megtalálható legyen.

.pbr fájl létrehozása egyetlen kapcsolódási pontot tartalmazó telefonkönyvhöz

Az egyetlen kapcsolódási pontot tartalmazó telefonkönyvhöz létrehozott területfájl egyszerű szövegfájl (.txt) kell hogy legyen, és két sort kell tartalmaznia:

  • Az első sor egy olyan számot tartalmaz, amely meghatározza, hogy a területfájlban hány állam, illetve megye (földrajzi terület) található.
  • A második sor az állam, illetve megye (vagy földrajzi terület) nevét tartalmazza. Ebbe a sorba ne írjon vesszőt vagy pontosvesszőt. A fájlnév (a fájlkiterjesztés nélkül) nem lehet hosszabb 8 karakternél.

Ha a kapcsolódási pont (POP) például Tolna megyében helyezkedik el, az egyetlen kapcsolódási pontot tartalmazó .pbr fájl tartalma a következőképpen néz ki:

1
Tolna

.pbr fájl létrehozása egyetlen kapcsolódási pontot tartalmazó telefonkönyvhöz

  1. Nyisson meg egy szövegszerkesztő alkalmazást, például a Jegyzettömböt.
  2. A StateOrProvinceID paraméterhez írja be az 1 értéket, majd nyomja meg az ENTER billentyűt.
  3. Írja be az állam vagy a megye nevét, majd nyomja meg az ENTER billentyűt.
  4. Mentse a fájlt egyszerű szöveges (csak szöveg) formátumban, az alábbi módon:

    TKnev.pbr

.pbk fájl létrehozása egyetlen kapcsolódási pontot tartalmazó telefonkönyvhöz

Az egyetlen kapcsolódási pontot tartalmazó telefonkönyvhöz létrehozandó fájlnak az alábbi követelményeknek kell megfelelnie:

  • A fájlnak ugyanabban a mappában kell lennie, mint ahol a .pbr fájl található. A fájlnév (a fájlkiterjesztés nélkül) nem lehet hosszabb 8 karakternél.
  • A fájlnak egyszerű szöveges (.txt), vesszőkkel tagolt formátumúnak kell lennie, és tartalmaznia kell az alábbi karakterlánc-sorozatot, mégpedig szóköz használata nélkül (ha szükséges, görgesse az oldalt, hogy láthassa mind a 11 mezőt):

    Index,TAPICountryOrRegionID,StateOrProvinceID,POPName,AreaCode,PhoneNumber,MinBaud,MaxBaud,Reserved,ServiceType,DUNEntry

    A képzeletbeli Soft Számítástechnikai Kft. egyetlen csatlakozási pontot tartalmazó telefonkönyve például az alábbi beállítást tartalmazhatná:

    1,44,1,Soft - Telephely,94,123-456,9600,56000,0,0,Soft TH

Megjegyzések

  • A TAPI-kódokat a rendszer szükség szerint frissíti. A felhasználó rendelkezésére álló TAPI-kódok a számítógépen futó operációs rendszertől, valamint a telepített szervizcsomag-frissítésektől függnek. Gondoskodjon arról, hogy a közzétett TAPI-kód megfeleljen a felhasználók által használt operációs rendszer szintjének.
  • Az egyes mezők beállításával kapcsolatban a Csatlakozási pont szolgáltatás dokumentációban talál további információt.


Egyéni ikonok beépítése

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével határozhatja meg azt a három ikont, amelyet a felhasználók látnak.

  • Az Asztal ikonjaként a nagy programikon használatos. Ez az ikon jelenik meg az ALT+TAB billentyűváltással előugró ablakban és néhány más felbukkanó párbeszédpanelen is. Az ikon mérete 32 × 32 képpont.
  • A kis címsorikon a bejelentkezési párbeszédpanelen a címsor bal szélén, valamint különféle felbukkanó párbeszédpaneleken, illetve a program futása közben a Tálcán, a programhoz tartozó gombon jelenik meg. Az ikon mérete 16 × 16 képpont.
  • A kapcsolat létrejötte után az állapotjelző terület kis ikonja a Tálca jobb szélső részén, az állapotjelző területen jelenik meg. Az ikon mérete 16 × 16 képpont.

A Csatlakozáskezelő alapértelmezett képeket tartalmaz e három ikonhoz. Ha az alapértelmezett ikonok helyett saját ikonjait szeretné használni, ikonszerkesztő programmal hozhat létre újakat. Minden ikon 16 színű kell, hogy legyen. Hasonló kinézetű ikonok létrehozásával egységesítheti a szolgáltatásprofil megjelenését. Az ikonok megfelelő megjelenése érdekében az alapértelmezett ikonok méretével és alakjával egyező ikonokat hozzon létre.

Ha mindhárom alapértelmezett ikon helyett egyetlen önállóan létrehozott ikont szeretne használni, a rendszer úgy méretezi az ikont, hogy az elférjen a számára kijelölt területen, viszont ez a kép elmosódott vagy torz megjelenéséhez vezethet. Ha az összes szolgáltatásprofil-ikon helyett egyetlen egyéni ikont szeretne használni, a Csatlakozáskezelő felügyeleti csomag varázsló Ikonok párbeszédpaneljén mindhárom mezőben adja meg az egyéni ikonfájl (.ico) nevét. Ha valamelyik mező üresen marad, ott a rendszer a megfelelő alapértelmezett ikont használja.

Megjegyzés

  • Azt a menüt is testreszabhatja, amely akkor jelenik meg, amikor a felhasználó jobb egérgombbal az állapotjelző terület ikonjára kattint. Ha az említett helyi menü testreszabásával kapcsolatban további információra van szüksége, tanulmányozza Az állapotjelzőterület-ikon menüjének testreszabása című témakört.


Az állapotjelzőterület-ikon menüjének testreszabása

Az állapotjelző terület ikonja a Tálca állapotjelző területén jelenik meg, amikor a felhasználó csatlakozik a szolgáltatáshoz. Az állapotjelző területen megjelenő ikon menüje akkor jelenik meg, ha a felhasználó jobb egérgombbal az állapotjelző terület ikonjára kattint. E menü segítségével a felhasználók parancsokkal érhetnek el bizonyos programokat. Windows 2000 operációs rendszer futtatása esetén a menüben megjelenő alapértelmezett parancsok a következők: Állapot, Kapcsolat bontása és Hálózati és telefonos kapcsolatok megnyitása. Ha további parancsokat szeretne megjeleníteni, a Csatlakozáskezelő felügyeleti csomag varázsló segítségével testreszabhatja a menüt.

Ha a menühöz (az alapértelmezett parancsokon kívül) további parancsokat szeretne hozzáadni, az Állapotterület ikonmenüje párbeszédpanelen kattintson a Hozzáadás gombra, majd adja meg a következőket:

  • A parancs nevét, ahogy azt a helyi menüben látni szeretné. Ha a parancsnak nem ad nevet, a menü a futtatandó program fájlnevét és kiterjesztését jeleníti meg.
  • Annak a programnak a fájlnevét (a kiterjesztéssel együtt), amely akkor indul, ha a felhasználó a menüben a hozzá tartozó parancsra kattint.
  • A programmal együtt futtatni kívánt parancssori paramétereket.
  • Azt, hogy felvegye-e a rendszer a programot a szolgáltatásprofilba. Ha a program nem része a célplatformok szabványos operációs rendszereinek, vagy ha más módon nem érhető el a felhasználók számítógépein, a programot felveheti a szolgáltatásprofilba. A telepítés során a szolgáltatásprofil a programot a \Cm\SzolgáltatásprofilFájlnév mappába másolja.

Ha a parancsnév egyik betűjét hívóbetűnek jelöli ki, a helyi menü parancsaihoz a billentyűzet használatával is hozzáférhet. Hívóbetű kijelöléséhez írja az & (ampersand) jelet közvetlenül a használni kívánt betű elé. Ha a Jegyzettömb parancsnév J betűjét szeretné például hívóbetűként használni, írja be az &Jegyzettömb karaktersorozatot. Ha a felhasználó megnyitja a helyi menüt, a hívóbetű (ebben az esetben a J) a parancsnévben aláhúzva jelenik meg (Jegyzettömb). A Jegyzettömb parancs végrehajtásához a felhasználónak tehát a J billentyűt kell megnyomnia.

Ha az ampersand (&) jelet be szeretné foglalni a parancsnévbe, írja be az && karaktersorozatot. Ha a Módosítás & Frissítés parancsnevet szeretné például használni, írja be a Módosítás && Frissítés karaktersorozatot. Ilyenkor az egyik ampersand karakter megjelenik a helyi menüben, vagyis nem hívóbetűként szerepel (Módosítás & Frissítés).

Megjegyzések

  • A .cms fájl [Connection Manager] szakaszának NoTrayIcon bejegyzését szerkesztve határozhatja meg, hogy az állapotjelző terület ikonja megjelenjen-e a Tálca állapotterületén.
  • A Csatlakozáskezelő felügyeleti csomag varázslóban az alapértelmezett parancsok nem jelennek meg a Menüparancsok mezőben, és ezeket a parancsokat a szolgáltatásprofil-fájlok közé sem veszi fel a rendszer. Ezek a parancsok a Csatlakozáskezelő szoftver részét képezik, ezért törölni sem lehet őket.
  • A program a menüparancsok közé csak .exe kiterjesztésű, valamint egyéb parancsértelmező héjprogram által végrehajtható fájlok (például URL-fájlok és a regisztrált kiterjesztésű fájlok) felvételét támogatja. A DLL-fájlokat a program nem támogatja.

A .cms fájl bejegyzésének szerkesztéséhez alkalmazható speciális testreszabási eljárásokról további információt a Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése című témakörben talál.


Egyéni Windows súgó csatolása

A Csatlakozáskezelő felügyeleti csomag varázsló használatával testreszabhatja a Csatlakozáskezelő súgóját, amely definíciós és hibaelhárítási részekből áll.

  • A definíciókat tartalmazó súgó a felület egyes elemeit ismerteti. Ez a típusú súgó felbukkanó ablakban jelenik meg. A felhasználók a témaköröket úgy jeleníthetik meg, hogy jobb gombbal kattintanak a kérdéses elemre, majd a felbukkanó menü Mi ez? parancsát választják. A bejelentkezési párbeszédpanel kivételével az összes párbeszédpanelen megjeleníthető a definíciókat tartalmazó súgó is a címsoron lévő kérdőjelre, majd a felület egy elemére kattintva.
  • A hibaelhárító súgó számos csatlakozási probléma diagnosztizálásának és megoldásának strukturált megközelítését ismerteti. A Csatlakozáskezelő hibaelhárítóját a bejelentkezési párbeszédpanel Súgó gombjára kattintva lehet elindítani. A felhasználó a súgó kérdéseire válaszolva határozhatja meg a problémák legvalószínűbb okait. A hibaelhárító a felhasználó válaszain alapuló megoldásokat javasol. A hibaelhárító súgó bármely párbeszédpanel Súgó gombjára kattintva jeleníthető meg.

A definíciókat tartalmazó és a hibaelhárító súgó egyetlen .hlp fájlba kerül. Ez a lefordított fájl bekerül a szolgáltatásprofilba, hogy a felhasználók hozzáférhessenek. Az alapértelmezett súgófájl a Cmmgr32.hlp. Ha nem az alapértelmezett súgófájlt kívánja használni, a Csatlakozáskezelő felügyeleti csomag varázslóval egyéni súgót határozhat meg, vagy helyettesítheti a szolgáltatásprofil alapértelmezett súgóját.

Megjegyzés

  • A súgó egyetlen olyan része, amely nem módosítható, a Tárcsázási tulajdonságok párbeszédpanel definíciókat tartalmazó súgója. Ez a párbeszédpanel a Tulajdonságok párbeszédpanel Általános lapján lévő Tárcsázási szabályok gombra kattintva jelenik meg. Ez a párbeszédpanel, a hozzá tartozó súgóval együtt, a Telephone Application Programming Interface (TAPI) része, ezért, bár be van építve a Csatlakozáskezelőbe, nem módosítható.

Az alapértelmezett súgófájlok testreszabása

Ha egyéni Windows súgót akar létrehozni, a Csatlakozáskezelő felügyeleti csomag varázsló futtatása előtt el kell készíteni a fájlokat. A Csatlakozáskezelő felügyeleti csomag varázsló mappája tartalmazza az alapértelmezett súgó összes forrásfájlját. Egyéni súgó létrehozásához másolatot kell készítenie az alapértelmezett súgó forrásfájljairól – a projektfájlt (.hpj) is beleértve –, átnevezni azokat és módosítani az átnevezett fájlokat. Az eredeti fájlok véletlen módosításának elkerülése érdekében az átnevezett fájlokat helyezze külön mappába. A következőkben az egyéni súgó létrehozásához szükséges információkat olvashat, többek között a forrásfájlok leírását és a forrásfájlok módosításához használható eszközöket. (Feltételezzük, hogy alapszinten ismeri a Windows súgórendszerét, és tisztában van a felhasználók számára készülő segédanyagok alapvető fogalmaival.)

Megjegyzések

  • A súgófájlok módosítását körültekintően végezze. A fájlokon végrehajtott módosítások következtében fellépő hibák elhárítása nehéz feladat. Ne módosítsa a Windows súgófájljainak lábjegyzeteit. Ne módosítsa a témakörök azonosítóit (a kettős kereszttel [#] jelzett lábjegyzeteket).
  • Amikor a Csatlakozáskezelő felügyeleti csomag varázslóban megadja az egyéni súgófájlt, tallózással tegye meg ezt. Ha begépeli a nevét, a program nem végez fájlnévellenőrzést (a kiterjesztésen sem).
  • A súgófájlokat minden célplatformon tesztelje, mielőtt a szolgáltatásprofilt a felhasználók számára elérhetővé tenné. A súgó teszteléséhez indítsa el a Csatlakozáskezelőt, és használja mind a definíciókat tartalmazó, mind a hibaelhárító súgót. Ha a súgót a .hlp fájl Csatlakozáskezelőn kívüli megnyitásával teszteli, nem győződhet meg annak működőképességéről.

Forrásfájlok

A Csatlakozáskezelő felügyeleti csomag az alább ismertetett fájlokat tartalmazza. Ezeket a fájlokat kell másolnia és módosítania, az egyéni projektfájlt (.hpj) lefordítania, majd a lefordított egyéni súgófájl nevét a Csatlakozáskezelő felügyeleti csomag varázslóban megadnia, ha egyéni súgót kíván létrehozni a felhasználók számára.

  • A Cmmgr32.hlp (az alapértelmezett lefordított súgófájl) a merevlemezen az I\system32 vagy a %rendszergyökér%\rendszermappa helyen van telepítve (a használt operációs rendszertől függően).
  • A következő on-line súgókomponensek a \Program Files\CMAK\Support\CMHelp\ mappában találhatók.
    • Cmmgr32.hpj (a súgó projektfájlja)
    • Cmctx32.rtf (a definíciós súgó szöveges forrása)
    • Cmtrb32.rtf (a hibaelhárító súgó szöveges forrása)
    • Cmmgr32.h (a definíciós súgó azonosítóit tartalmazó fejlécfájl)

Megjegyzés

  • A grafikus elemek (például a felsorolásjelek) és a sablonfájl (What7.dot) nincsenek a fájlok között, így ezeket a fájlokat a kívánt megjelenés érdekében a készítőnek kell létrehoznia.

Az on-line súgórendszer testreszabásához és újjáépítéséhez az összes említett fájl szükséges. Az egyes fájlok bejegyzéseinek testreszabásával kapcsolatban lejjebb találhat információt.

Fontos

  • A szolgáltatásprofil súgófájljainak testreszabásához készítsen másolatot az alapértelmezett súgófájlokról (kivéve a cmmgr32.hlp fájlt), nevezze át azokat, majd módosítsa az átnevezett fájlokat. Ne módosítsa az eredeti alapértelmezett fájlokat! Ha átnevezi a fájlokat, frissítse a .hpj fájlban hivatkozott neveket ennek megfelelően (a .hlp fájl nevét is beleértve). Ha testreszabja a súgót, de nem nevezi át a .hlp fájlt, a Csatlakozáskezelő felügyeleti csomag varázsló a szolgáltatásprofil létrehozásakor az alapértelmezett és az egyéni fájlokat is felveheti a profilba.

Megjegyzés

  • A súgófájlokon kívül egyéni Fontos fájlt és eljárásokat leíró dokumentációt is biztosíthat a felhasználók számára. A felhasználók számára testreszabható további dokumentációkkal kapcsolatban tekintse át a Dokumentáció csatolása című témakört.

Szükséges eszközök

A súgófájlok testreszabásához az alábbi két eszköz szükséges:

  • Egy szövegszerkesztő program (például a Microsoft Word), amely képes .rtf fájlok kezelésére
  • Egy 32 bites súgófordító, például a Help Workshop 4.01, amely a Microsoft Press által kiadott Microsoft Windows 95 Help Authoring Kit részeként szerezhető be.

Megjegyzés

  • A súgófordítót (Hcw.exe) és a hozzá tartozó fájlokat a Microsoft Platform SDK programépítési környezet és a további SDK-komponensek (eszközök) letöltésével szerezheti be. Az említett szoftverek a Microsoft szoftverfejlesztői csomagjai közül tölthetők le a magyar vagy az angol Microsoft Developer Network (MSDN) (http://msdn.microsoft.com/developer/default.htm) webhelyről. Az SDK nem tartalmazza a súgófájlok létrehozásának és módosításának kimerítő leírását, ezért célszerű beszerezni a Microsoft Windows 95 Help Authoring Kit című könyvet (ISBN 1-55615-892-0), amely tartalmazza a súgófájlok testreszabásához szükséges eszközöket és információkat.

Mit érdemes testreszabni?

A leggyakrabban testreszabott súgóinformáció a definíciós és hibaelhárítási súgó .rtf fájlokban található szövege.

Testreszabási javaslatok a definíciós súgóhoz

A definíciós Súgó szövege a Cmctx32.rtf fájlban található. A testreszabási javaslatok alábbi listájában minden témakörre annak azonosítójával (a # lábjegyzettel) hivatkozunk.

Súgótémakör azonosítója | Testreszabási információ
IDH_LOGON_SVCMSG | Ebben a témakörben a bejelentkezési párbeszédpanelen megjelenő támogatási szöveghez adhat meg definíciót. Ez a témakör csak akkor lesz elérhető, ha a Csatlakozáskezelő felügyeleti csomag varázsló futtatásakor támogatási információkat ad meg. Az üzenet alapértelmezett szövege: „Ehhez az elemhez nem tartozik súgótémakör.” Ezt a szöveget módosíthatja, hogy segítséget nyújtson a felhasználók számára megadott támogatási információkkal kapcsolatban. Ha például a bejelentkezési párbeszédpanelen feltüntet egy ügyfélszolgálati telefonszámot, ebben a témakörben ismertetheti az ügyfélszolgálatot.
IDH_PHONEBOOK_SERVICETYP | Ez a témakör a Telefonkönyv párbeszédpanelen a Szolgáltatás típusa listához tartozik. Ezt a témakört testreszabhatja, hogy bemutassa a támogatott szolgáltatástípusokat, és rövid leírást adjon róluk.
IDH_PHONEBOOK_ACCESSNUMS és IDH_PHONEBOOK_MORE | Ezek a témakörök a Telefonkönyv párbeszédpanel Hívószámok és További telefonszámok listáihoz tartoznak. Módosíthatja úgy a szöveget, hogy információt biztosítson az elérhető számokról, például leírhatja, mely számok hívásáért kell tarifát fizetni, és melyek ingyenesek. Az alapértelmezett szöveg szerint a számok használata további díj felszámításával jár.
IDH_PHONEBOOK_SVCMSG | Ez a témakör a Telefonkönyv párbeszédpanelen lévő telefonkönyves ügyfélszolgálati üzenetet megjelenítő területhez tartozik (a További telefonszámok mező mellett). Ez az üzenet csak akkor jelenik meg, ha a kijelölt földrajzi területhez további telefonszámok tartoznak. Ezzel a témakörrel további ügyfélszolgálati információkat adhat meg a További telefonszámok mezőben elérhetővé tett telefonszámokkal kapcsolatban.

A Cmctx32.rtf fájl egészében módosíthatja a „szolgáltatás” szót a saját szolgáltatásának nevére. Például az IDH_LOGON_NAME tartalma: „A szolgáltatásba való bejelentkezéshez használt név.” Ha a „szolgáltatás” szót a „Soft Számítástechnikai Kft” elnevezésre cseréli (az útmutatóban használt fiktív társaság neve), a fenti felirat a következőre módosul: „A Soft Számítástechnikai Kft-hez való bejelentkezéshez használt név.”

Testreszabási javaslatok a hibaelhárító súgóhoz

A hibaelhárító súgó szövege a Cmtrb32.rtf fájlban található. A testreszabási javaslatok alábbi listájában minden témakörre annak azonosítójával (a # lábjegyzettel) és címével hivatkozunk.

Hibaelhárítási témakör azonosítója | Testreszabási információ
ICM_TRB (Bejelentkezési hibaelhárító) | Ez a témakör a lehetséges problémák felderítésének kezdőpontja. Ha egyéb problémák megoldását is hozzá szeretné adni a súgóhoz, létrehozhatja saját elérési útjait akár ettől a ponttól kezdődően, akár bármely más pontról indulva. Tetszés szerinti mennyiségű problémamegoldó témakört hozhat létre.
ICM_TRB_CUSTSUP_NUMS (Kapcsolat az ügyfélszolgálattal) | Ez a témakör az ügyfélszolgálattal kapcsolatos információkat tartalmaz. Hozzáadhatja saját ügyfélszolgálati telefonszámait, az ügyeleti időtartamot és egyéb hasznos információkat. A felhasználók ezt a témakört más témakörökből jelenítik meg, ha a súgó az ügyfélszolgálat igénybe vételét javasolja.
ICM_TRB_GIVEUP és ICM_TRB_GIVEUP_PHONE (További lépések) | Ezen két témakör egyike minden hibaelhárítási útvonal végén megjelenik. További utasításokat adhat azoknak a felhasználóknak, akik az összes hibaelhárítási lehetőséget kipróbálták, de még mindig nem tudnak csatlakozni a szolgáltatáshoz.

Akárcsak a definíciós súgó esetében, a „szolgáltatás” szót itt is kicserélheti saját szolgáltatásának nevére.

A projektfájl testreszabása és lefordítása

Ha testreszabja az .rtf fájlokat, a projektfájlt (.hpj) is módosítania kell (a Help Workshop 4.01 más súgószerkesztő használatával), hogy tartalmazza az egyéni .rtf fájlok neveit. A .hpj fájlban a projekt egyéb információit is módosíthatja. Ha például a súgóablakok címsorában nem a „Csatlakozáskezelő hibaelhárítója” feliratot kívánja használni, a .hpj fájlban megváltoztathatja a címet a „TITLE” módosításával az [Options] alatt, és a „proc4” módosításával a [Windows] alatt.

A .hpj és az .rtf fájlok szerkesztésének végeztével a .hpj fájl lefordításával hozhatja létre a .hlp fájlt. Amikor a Csatlakozáskezelő felügyeleti csomag varázslóval létrehozza a szolgáltatásprofilt, a varázslóban adja meg az egyéni .hlp fájl nevét.

Megjegyzés

  • A .h (hozzárendelési) fájl a definíciós súgó témakör-azonosítóit tartalmazza. A fájl módosítása esetén a Csatlakozáskezelő nem biztos, hogy a megfelelő súgótémaköröket jeleníti meg.


A Csatlakozáskezelő 1.2-es verziójának hozzáadása a szolgáltatásprofilhoz

A felhasználóknak telepíteniük kell a Csatlakozáskezelő 1.2 programot a Csatlakozáskezelő 1.2. szolgáltatásprofilok futtatásához. Ha a felhasználók még nem telepítették, a szoftvert tanácsos felvenni a szolgáltatásprofilba. A Csatlakozáskezelő felügyeleti csomag varázslóban megadhatja, hogy a szoftver része legyen a létrehozandó szolgáltatásprofilnak, így a szoftver a szolgáltatásprofil telepítésekor automatikusan telepítésre kerül.

Ha a Csatlakozáskezelő 1.2 programot felveszi a szolgáltatásprofilba, és a felhasználó már rendelkezik a Csatlakozáskezelő egy korábbi verziójával, a szoftver a telepítéskor automatikusan frissítésre kerül. A Csatlakozáskezelőt nem lehet telepíteni, ha a felhasználó számítógépén a jelenlegi, vagy egy újabb verzió van telepítve. A Csatlakozáskezelő 1.2 például a Windows 2000 operációs rendszer része, így nem kerül telepítésre a Windows 2000 rendszert futtató számítógépeken. A szolgáltatásprofil azonban telepítésre kerül, még akkor is, ha a profilban lévő Csatlakozáskezelő telepítése nem történik meg.

Megjegyzések

  • Ha a szoftvert felveszi a profilba, a hozzá tartozó Fontos.txt fájlt is felveszi. Ha a fájlt testre kívánja szabni, ezt a szolgáltatásprofil létrehozása előtt kell megtennie. A fájl testreszabásával kapcsolatban további információt talál a Dokumentáció csatolása című részben.
  • A telepítési csomag méretének kiszámolásakor ne felejtse el beleszámolni a Csatlakozáskezelő méretét is. A Csatlakozáskezelő méretével kapcsolatban további tudnivalókat talál a Hatékony megvalósítás tervezése című témakörben.


Licencszerződés beépítése

A Csatlakozáskezelő felügyeleti csomag varázsló használatával saját licencszerződést építhet be a szolgáltatásprofilba. Ez a licencszerződés akkor jelenik meg, amikor a felhasználó az OK gombra kattint a szolgáltatásprofil telepítésének megkezdéséhez. Ha a felhasználó elfogadja a licencszerződést, a telepítés folytatódik. Ha nem, a telepítés félbeszakad.

A licencszerződést szövegszerkesztővel (például Jegyzettömb) hozhatja létre, szöveges (.txt) formátumban. A formázási problémák elkerülése érdekében ne használjon kényszerített sortöréseket a sorok végén. A licencszerződés sortördelése automatikusan megtörténik a szolgáltatásprofil létrehozásakor.


További fájlok felvétele

A Csatlakozáskezelő felügyeleti csomag varázsló használatával további fájlokat is felvehet a szolgáltatásprofilba, hogy segítse felhasználóit a szolgáltatás használatában. A szolgáltatáshoz szükséges összes olyan fájlt, amely a varázslóban máshol nincs megadva, a További fájlok párbeszédpanelen kell megadni. Ez a rész a További fájlok párbeszédpanelen megadott fájlokkal kapcsolatban tartalmaz információt.

Csatlakozásiművelet-fájlok és automatikusan futó alkalmazások

Ha csatlakozási műveletet hoz létre, a hozzá tartozó programot a Csatlakozási műveletek hozzáadása/módosítása párbeszédpanelen adhatja meg. Itt azonban csak egy programot adhat meg az egyes csatlakozási műveletekhez. A csatlakozási művelethez szükséges egyéb fájlokat a További fájlok párbeszédpanelen kell megadni. Ugyanez igaz az automatikusan futó alkalmazásokra. A csatlakozási műveletekhez és az automatikusan futó alkalmazásokhoz szükséges egyéb fájlokkal kapcsolatban tekintse át az alábbi témaköröket: Csatlakozási műveletek beépítése és Beépítés, automatikusan futó alkalmazások.

Felhasználói dokumentációs fájlok

Ha a szolgáltatáshoz felhasználói dokumentációt hoz létre, ezt az információt úgy veheti fel a szolgáltatásprofilba, ha a felhasználói dokumentáció fájljait megadja a További fájlok párbeszédpanelen.

Megjegyzés

  • Ha a Csatlakozáskezelő felügyeleti csomag varázslóban megadja, hogy a Csatlakozáskezelő 1.2 szoftver a szolgáltatásprofil része legyen, a Csatlakozáskezelő a Fontos.txt fájlt is automatikusan beépíti a szolgáltatásprofilba. Ha a profilba nem veszi fel a Csatlakozáskezelő 1.2 szoftvert, de fontos fájlt szeretne biztosítani, azt a további fájlok között kell megadnia. A felhasználói dokumentáció létrehozásával és a Fontos fájlokkal kapcsolatban a Dokumentáció csatolása című témakörben találhat további információt.

Egyéb fájlok

Ha a varázsló futtatása után haladó szintű testreszabást végez a szolgáltatásprofil fájljainak módosításával, további információs fájlokat is kell biztosítania az új szolgáltatások támogatásához. A testreszabott szolgáltatásokkal kapcsolatos fájlokat a További fájlok párbeszédpanelen adhatja meg. A speciális testreszabással kapcsolatban további információt a Speciális testreszabás: szolgáltatásprofil-fájlok szerkesztése című témakörben talál.


Dokumentáció csatolása

A Windows súgó mellett más típusú felhasználói dokumentációt is beépíthet a szolgáltatásprofilba. A Csatlakozáskezelő alapértelmezett fontos fájlja testreszabható. Saját felhasználói dokumentációt is készíthet, és beépítheti azt is a profilba. A dokumentáció beépítése előtt tekintse át

  • a rendszerkövetelményeket és az ismert problémákat tartalmazó fontos fájlt, illetve
  • az e témakörben a későbbiekben szereplő mintaeljárásokat:
    • „A Csatlakozáskezelő telepítése” útmutatót, amely a Point-to-Point Tunneling protokoll (PPTP) Windows NT 4.0 rendszerre történő telepítését mutatja be
    • a „Kapcsolat létrehozása” részt, valamint
    • „A szolgáltatás eltávolítása” című szakaszt.

Ügyfélszolgálati teendőinek csökkentése érdekében bizonyosodjon meg róla, hogy a beállításokra és a termékek használatára vonatkozó útmutatásai megfelelő segítséget nyújtanak a Csatlakozáskezelő beállításához, illetve a szolgáltatáshoz történő csatlakozáshoz.

Felhasználói dokumentáció szolgáltatásprofilba építéséhez a fájlokat további fájlokként adhatja meg (a Csatlakozáskezelő felügyeleti csomag varázsló További fájlok lapján). Bővebb információt a További fájlok felvétele című témakörben talál.

Megjegyzés

  • A felhasználók a további dokumentációként csatolt információt csak a szolgáltatásprofil telepítése után érhetik el. Egyes információkat (például telepítési útmutatót) azonban a szolgáltatásprofilhoz mellékelt külön fontos fájlban is szükséges lehet elhelyezni olyan formátumban, amelyhez a felhasználók a telepítés előtt is hozzáférhetnek.

Fontos fájlok

Az alapértelmezett fontos fájlt (Fontos.txt) a Csatlakozáskezelő felügyeleti csomag tartalmazza, és azt a \Program Files\Cmak\Support mappába telepíti. Ez a fájl automatikusan beépül minden, a Csatlakozáskezelő felügyeleti csomag varázsló segítségével létrehozott, a Csatlakozáskezelő szoftver 1.2-es verzióját tartalmazó szolgáltatásprofilba. A fájlban található információk a szolgáltatásnak megfelelően testreszabhatók. A fájl nevét ne módosítsa, és szerkesztés előtt készítsen róla biztonsági másolatot.

Megjegyzések

  • A Fontos.txt fájl CSAK akkor épül be a szolgáltatásprofilba, ha az tartalmazza a Csatlakozáskezelő alkalmazás 1.2-es verzióját. Ha a fontos fájlt be kívánja építeni a profilba, a Csatlakozáskezelő szoftver 1.2-es verzióját azonban nem, hozzon létre egy másik fontos fájlt (az alapértelmezett fontos fájl nevétől eltérő néven), és építse azt be a szolgáltatásprofilba további fájlként.
  • Csakúgy, mint más beépített fájlok estében, a Fontos.txt fájlt a program bemásolja a szolgáltatásprofil mappájába. A fájlt a \Program Files\Cmak\Support mappában szerkesztheti.

Felhasználói eljárások

A felhasználói dokumentáció segítséget nyújt a Csatlakozáskezelő telepítéséhez, használatához, és (szükség esetén) annak eltávolításához is. Az alábbi eljárásokat testreszabás után fontos fájlba vagy egyéb felhasználói dokumentációba helyezheti.

Ezen felhasználói eljárások mindegyikében saját szolgáltatásprofiljának nevét helyettesítse be a szolgáltatásprofil_fájlneve attribútum helyére, függetlenül annak környezetétől. (A behelyettesített név ne legyen dőlt betűs.)

Az alábbi eljárások szószedetcímeket és webhelyhivatkozásokat tartalmaznak. A dokumentációhoz mellékelt támogató fájloktól függően előfordulhat, hogy azok nem az alábbiak szerint működnek. Módosítsa őket a forgalmazott terméknek megfelelően.

Ha a Csatlakozáskezelő felügyeleti csomag varázsló segítségével hoz létre szolgáltatásprofilt, a profilba beépítendő felhasználói dokumentációkat további fájlként adja meg (hogy az elérhető legyen a szolgáltatásprofil telepítése után).

A Csatlakozáskezelő telepítése

Utasítsa a felhasználókat a Csatlakozáskezelő telepítésére az alábbi eljárás segítségével.

A Csatlakozáskezelő telepítése

  1. Keresse meg a szolgáltatásprofil_fájlneve fájlt az alábbi módszerek egyikével:
    • Ha a program hajlékonylemezen vagy CD-lemezen áll rendelkezésre:
      1. Helyezze be a lemezt a megfelelő meghajtóba.
      2. Keresse meg a fájlt a Windows Intéző segítségével.
    • Ha a Csatlakozáskezelőt az Internetről vagy magánhálózatról töltötte le, keresse meg a letöltési mappát.
  2. Kattintson duplán a szolgáltatásprofil_fájlneve.exe fájlra.
  3. A telepítés befejeztével a szolgáltatás indításához kattintson duplán az Asztalon található ikonra. Ha a program további összetevők telepítésére utasít, kattintson az OK gombra.

Megjegyzés

  • Ha a felhasználó telepítéskor megadja, hogy a Csatlakozáskezelő minden felhasználó számára elérhető, a profilt felhasználónként kell telepíteni, nem számítógépenként. Ennek eredményeképpen a profil nem követi a felhasználót másik számítógépre.

A Hálózati és telefonos kapcsolatok szoftver ellenőrzése és telepítése Windows 95 rendszerben

Ha a szolgáltatásprofil támogatja a virtuális magánhálózat (VPN) típusú kapcsolatokat, a Windows 95 rendszerrel rendelkező felhasználók számítógépére a Hálózati és telefonos kapcsolatok szoftver legújabb verzióját kell telepíteni. Az alábbi utasítások segítségével a VPN-felhasználók a megfelelő szintű telepítést végezhetik el:

A Hálózati és telefonos kapcsolatok szoftver ellenőrzése és telepítése Windows 95 rendszerben

  • Ha Windows 95 rendszerrel rendelkezik, a Hálózati és telefonos kapcsolatok szoftver legfrissebb verzióját letöltheti Microsoft Windows frissítésként a Microsoft Support Online webhelyről (http://support.microsoft.com/support/downloads/default.asp).

A PPTP protokoll telepítése Windows NT 4.0 rendszerben

Windows NT 4.0 rendszerrel működő számítógépen a PPTP protokoll telepítését kézzel kell elvégezni. A PPTP protokollt telepítő felhasználók a következő utasításokkal telepíthetik a protokollt.

A PPTP protokoll telepítése Windows NT 4.0 rendszerrel működő számítógépen

  1. Biztosítsa, hogy a Windows NT 4.0 telepítőlemezei, illetve az azokon található rendszerfájlok elérhetők legyenek a telepítés során. Ajánlott a Windows NT Service Pack legfrissebb verzióját telepíteni. A Windows NT Service Pack 3 (és annak későbbi kiadása) több modem használatát és a telefonos parancsfájlokat is támogatja. A Windows NT Service Pack 4 ezen kívül a virtuális magánhálózat (VPN) típusú kapcsolatokat is támogatja. A felhasználók a legfrissebb Hálózati és telefonos kapcsolatok szoftvert (mint a Microsoft Windows egyik frissítését) a Microsoft Support Online webhelyéről (http://support.microsoft.com/support/downloads/default.asp) tölthetik le.
  2. Kattintson a Start gombra, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, végül kattintson duplán a Hálózat ikonra.
  3. A Protokollok lapon kattintson a Hozzáadás gombra.
  4. A Hálózati protokoll listában kattintson a Point To Point Tunneling protokoll elemre, majd az OK gombra.

    Ha a Telepítőnek fájlokat kell másolnia, a megjelenő párbeszédpanelen kattintson a Folytatás gombra.

  5. A megjelenő párbeszédpanelen kattintson az OK gombra, ezzel beállítva a virtuális magánhálózatok számát egyre (1).
  6. A Távoli elérés beállításai párbeszédpanelen kattintson a Hozzáadás gombra, majd a VPN1 – RASPPTM listaelemre, végül pedig az OK gombra.
  7. Kattintson a Beállítás gombra, és győződjön meg róla, hogy a Csak hívásra választógomb be van jelölve.
  8. A Távoli elérés beállításai párbeszédpanelen kattintson a Hálózat gombra, ellenőrizze, hogy a TCP/IP jelölőnégyzet be van jelölve, majd kattintson a Folytatás gombra.

    Ezután bezárhatja a Hálózat segédprogramot és újraindíthatja a számítógépet, ezt követően pedig telepítse újra a Windows NT 4 Service Pack 3 (vagy későbbi) csomagot.

Kapcsolat létrehozása

A felhasználók az alábbi lépések segítségével csatlakozhatnak a szolgáltatásához:

Kapcsolat létrehozása

  1. Kattintson duplán az Asztal szolgáltatásprofil_fájlneve ikonjára.
  2. Írja be felhasználónevét és jelszavát.

    Ha VPN-kapcsolattal csatlakozik valamely magánhálózathoz, a program még egy felhasználónevet és jelszót kérhet. Ebben az esetben írja be az Internet-szolgáltató (ISP) felé használt felhasználónevét és jelszavát.

  3. Ha a Csatlakozáskezelőt első alkalommal használja csatlakozásra, kattintson a Tulajdonságok, majd a Telefonkönyv gombra, és válasszon egy telefonszámot a hívószámok listából. (Vagy írja be a szolgáltatás elérésére használandó telefonszámot.)
  4. Kattintson kétszer az OK gombra.
  5. A kapcsolat létrehozásához kattintson a Csatlakozás gombra.

    A csatlakozáskor a szolgáltatás lehet, hogy frissíti a telefonkönyvet, ha van új vagy megváltozott telefonkönyv-információ.

Megjegyzések

  • A Csatlakozáskezelőt a \\Program Files\Cmak\ mappában található ikonja segítségével is elindíthatja.
  • A Csatlakozáskezelő támogatja több szolgáltatásprofil felhasználói telepítését, több Csatlakozáskezelő egyidejű futtatását, illetve egy szolgáltatásprofilhoz több felhasználói profil használatát is. Ha a felhasználó egynél több szolgáltatásprofilt telepít, mindegyik külön mappába kerül. Annyi profilt bocsáthat a felhasználók rendelkezésére, amennyi a szolgáltatás támogatásához szükséges, de mindegyiknek különböző szolgáltatás- és fájlnévvel kell rendelkeznie.
  • Ha a kapcsolatok létrehozásával vagy hibaelhárítással kapcsolatos segítségre van szüksége, használja a súgót:
    • Hibaelhárítással kapcsolatos segítségért kattintson a Csatlakozáskezelő bejelentkezési párbeszédpaneljének Súgó gombjára.
    • A párbeszédpanelek egyes elemeiről további információt kaphat, ha a címsor kérdőjel [?] gombjára, majd az adott elemre kattint.

      Kattinthat az elemre a jobb oldali egérgombbal is, majd kattintson a Mi ez? feliratra.

A szolgáltatás eltávolítása

A felhasználók az alábbi lépések segítségével távolíthatják el a szolgáltatást.

Megjegyzés

  • Ez az eljárás csak a szolgáltatásprofilt távolítja el. A Csatlakozáskezelő szoftver a felhasználó számítógépén marad, mivel más felhasználók profiljaihoz arra még szükség lehet.

A szolgáltatás eltávolítása

  1. Kattintson az Asztalon az egér jobb gombjával a szolgáltatás ikonjára.
  2. Kattintson a Törlés parancsra.
  3. A törlésre vonatkozó figyelmeztetést megjelenítő párbeszédpanelen kattintson az OK gombra.

Megjegyzés

  • A szolgáltatás törlése nem távolítja el a szolgáltatás futtatásához szükséges Csatlakozáskezelő szoftvert, azt külön el kell távolítani.


Speciális testreszabás: a szolgáltatásprofil-fájlok szerkesztése

A Csatlakozáskezelő felügyeleti csomag varázsló támogatja a legtöbb olyan testreszabási szolgáltatást, amelyre a rendszergazdáknak a Csatlakozáskezelő egyéni szolgáltatásprofiljainak létrehozásához szükségük van. További szolgáltatások is testreszabhatók, ha módosítja a szolgáltatásprofil-fájlokat és megváltoztatja annak a módját, ahogyan a Csatlakozáskezelő bizonyos funkciókat alkalmaz.

A szolgáltatásprofil-fájlok szerkesztésével testreszabhatók a Csatlakozáskezelő felügyeleti csomag varázsló által nem szabályozott funkciók és szolgáltatások. A speciális testreszabás végrehajtható a szolgáltatásprofil-fájlok alábbi két csoportjának szerkesztésével:

  • a sablonfájlok szerkesztésével, amelyeket a Csatlakozáskezelő felügyeleti csomag varázsló minden szolgáltatásprofil készítésekor használ, illetve
  • azoknak a fájloknak a szerkesztésével, amelyeket a Csatlakozáskezelő felügyeleti csomag varázsló az egyes szolgáltatásprofilok készítésekor hoz létre.

A szolgáltatásprofil-fájlok típusai a következők:

  • Szolgáltató fájlok (.cms) A .cms (szolgáltató) fájlok a telefonkönyvnek és a szolgáltatásprofilban megadott legtöbb egyéb funkció beállításait tartalmazzák. A szolgáltatásprofilok speciális egyéni beállításainak nagy része az adott profil .cms fájljában adható meg.
  • Csatlakozásprofil-fájlok (.cmp) A .cmp fájlok a felhasználó által megadott információkat tartalmazzák. Ne módosítsa a .cmp fájlokat! A változtatásokat a felhasználók felülírhatják.
  • Információs fájlok (.inf) Az .inf fájlok a szolgáltatásprofilok telepítéséhez szükséges információkat tartalmazzák. Az .inf fájlok egyes telepítési és eltávolítási információi módosíthatók ugyan, a telepítési problémák elkerülése érdekében azonban rendkívül körültekintően kell eljárni.
  • Csatlakozásprofil-fájlok (.sed)A .sed fájlok a szolgáltatásprofil futtatható önkicsomagoló (.exe) fájljának létrehozásához szükséges utasításokat tartalmazzák. Soha ne módosítsa a .sed fájlokat!

Fontos

  • A fájlok módosítását körültekintően végezze. Az említett fájlok módosításai miatt felmerülő problémák nehezen elháríthatók. Soha ne módosítsa az eredeti fájlt, és mindig készítsen biztonsági másolatokat. A módosításhoz a rendszer konfigurációs fájljainak alapvető ismerete szükséges.

A szolgáltatásprofil-fájlok szerkesztése

A sablonfájlok vagy bizonyos szolgáltatásprofil-fájlok külön-külön, illetve egyszerre szerkeszthetők attól függően, hogy a testreszabást a teljes szolgáltatásprofilra, vagy csak egy bizonyos szolgáltatásprofilra kívánja-e alkalmazni.

Sablonfájlok

A Csatlakozáskezelő felügyeleti varázsló csomag telepítésekor a következő sablonfájlok kerülnek automatikusan a \Program Files\CMAK\Support mappába:

  • Template.cms
  • Template.cmp
  • Template.inf
  • Template.sed
Ezek a fájlok tartalmazzák azokat az alapvető beállításokat, amelyek segítségével a Csatlakozáskezelő felügyeleti csomag varázsló létrehozza a szolgáltatásprofilokat. Ha a létrehozandó szolgáltatásprofilokba egyedi funkciókat is szeretne beépíteni, a szolgáltatásprofilok létrehozása előtt módosítsa a sablonfájlokat.

Általában csak a .cms kiterjesztésű sablonfájlokat kell módosítani.

Megjegyzés

  • A sablonfájlok módosításai csak azokra az új szolgáltatásprofilokra lesznek érvényesek, amelyeket a Csatlakozáskezelő felügyeleti csomag varázslóval a módosítás után hoz létre.

Kész fájlok

Amikor a szolgáltatásprofil létrehozása a Csatlakozáskezelő felügyeleti csomag varázslóval történik, a varázsló egy végrehajtható önkicsomagoló (.exe kiterjesztésű) fájlt és több más, a megadott beállításokat tartalmazó fájlt hoz létre. A szolgáltatásprofil-fájlok a \Program Files\CMAK\Profiles\SzolgáltatásprofilFájlnév mappában kerülnek mentésre. Minden szolgáltatásprofil a Csatlakozáskezelő felügyeleti csomag varázslóban megadott SzolgáltatásprofilFájlnév névvel rendelkezik. Az .exe fájlon kívül a varázsló minden szolgáltatásprofilhoz még a következő fájlokat hozza létre:

  • SzolgáltatásprofilFájlnév.cms
  • SzolgáltatásprofilFájlnév.cmp
  • SzolgáltatásprofilFájlnév.inf
  • SzolgáltatásprofilFájlnév.sed

A .cmp fájlokat kivéve mindegyik típusra igaz, hogy a kész fájlok megelőzik a sablonfájlokat. A szolgáltatásprofil módosítása után a Csatlakozáskezelő felügyeleti csomag varázsló ismételt futtatásával újra fel kell építeni a szolgáltatásprofilt a testreszabott beállításokkal.

Formátumok és egyezményes jelölések

A Csatlakozáskezelő.cms kiterjesztésű szolgáltatásfájlokat hoz létre, amelyek ugyanolyan formátumúak, mint a Windows .ini fájlok és az információs (.inf kiterjesztésű) fájlok. Ezekben a fájlokban

  • két szakasz található, és mindegyik szakaszhoz meghatározott bejegyzések vannak hozzárendelve. A szakaszfejléc szögletes zárójelek között jelenik meg: ([ ]). A [Strings] például olyan szakaszt jelöl, amely az üzenetek szöveges karakterláncait tartalmazza. A szakaszok bejegyzései nincsenek zárójelbe téve.
  • A numerikus bejegyzések értékei csak egész számok lehetnek. A nem egész érték egész számmá csonkul, illetve érvénytelen adatként a program nem veszi figyelembe. Az 1.1 érték például 1 értékké csonkul, vagy a program figyelmen kívül hagyja.
  • A szakaszok megjelenési sorrendje nem lényeges, egy adott szakasz a fájlban bárhol elhelyezhető.
  • A fájlokban szereplő megjegyzések pontosvesszővel (;) kezdődnek.

A szóban forgó formátumokról és egyezményes jelölésekről további információt a Microsoft Platform Software Development Kit (SDK) tartalmaz.

A működések testreszabása

Csak a .cms és .inf fájlokban lévő bejegyzéseket módosítsa, és a változtatásokat kizárólag az alábbiakban meghatározott módon végezze.

Információs fájlok (.inf) bejegyzései

Az .inf fájl módosításával meghatározhat olyan parancsokat, amelyek akkor lépnek működésbe, amikor a felhasználó telepíti vagy eltávolítja a szolgáltatásprofilt. Megadhat például olyan parancsokat, amelyek:

  • beágyazott saját szoftvert integráló telepítő programokat futtatnak
  • a fontos fájlt automatikusan megjelenítő programokat futtatnak
  • konfigurációs segédprogramokat vagy karbantartó programokat futtatnak.

Ha a szolgáltatásprofilhoz saját telepítő és eltávolító parancsokat szeretne hozzáadni, a Csatlakozáskezelő felügyeleti csomag varázsló segítségével először hozza létre a profilt, majd ágyazza be a saját parancsai futtatásához szükséges fájlokat úgy, hogy mindegyiket kiegészítő fájlként adja meg. A szolgáltatásprofil létrehozása után az .inf fájl megfelelő szakaszaiban határozza meg a megfelelő egyéni parancsokat.

Az .inf fájlban négy olyan szakasz található, amelyekben elhelyezhetők a folyamat meghatározott pillanataiban működésbe lépő telepítő és eltávolító parancsok. A fájlnevek nem lehetnek nyolc karakternél hosszabbak. Szóköz nem lehet a fájlnevekben.

Az .inf fájl szakasza | A szakasz parancsainak futtatása
RunPreSetupCommands | A telepítés megkezdése előtt
RunPostSetupCommands | A szolgáltatásprofil telepítése után
RunPreUnInstCommands | Az eltávolítás megkezdése előtt
RunPostUnInstCommands | Az eltávolítás megkezdése után

Minden parancsnak tartalmaznia kell a futtatni kívánt program nevét és a parancssori paramétereket. Az .inf fájlban meghatározott parancsok mindegyike csak egyszer lép működésbe a telepítés vagy az eltávolítás során.

Fontos

  • A hibásan megadott bejegyzések súlyos telepítési problémákat okozhatnak. Az előzőekben megadottakon kívül ne módosítson más bejegyzést az .inf fájlban. Az egyéni .inf bejegyzéseket tartalmazó szolgáltatásprofilokat alaposan tesztelje a verzió-, fájl- vagy más jellegű ütközések szempontjából. Pontosan adja meg a fájl helyét.
  • Ha a Csatlakozáskezelő 1.0-s verziójával készült profilokat a Csatlakozáskezelő felügyeleti csomag 1.2-es verziójával módosítja, akkor a profil 1.2-es verziójúvá frissítődik, és az új .inf fájl bekerül az előző .inf fájl helyére. A frissítést követően az egyéni bejegyzéseket hozzá kell adni az új .inf fájlhoz, ha továbbra is a saját telepítő és eltávolító parancsait szeretné használni a létrehozandó szolgáltatásprofilokban.

Szolgáltató (.cms) fájlok bejegyzései

Egy .cms fájl módosításával megváltozhat a Csatlakozáskezelő számos funkciójának működése. Például:

  • Módosíthatja a RedialDelay bejegyzést, amely az újratárcsázások közötti időtartamot szabályozza.
  • Módosíthatja a PasswordHandling bejegyzést, amely azt határozza meg, hogy a jelszó beírásánál ügyelni kell-e a kis- és nagybetűk használatára.
  • Módosíthatja a HideRememberPassword bejegyzést, amely azt szabályozza, hogy megjelenjen-e a Jelszó mentése jelölőnégyzet.
  • Módosíthatja a HideDialAutomatically bejegyzést, amely azt szabályozza, hogy megjelenjen-e az Automatikus kapcsolódás jelölőnégyzet.
  • Módosíthatja a ResetPassword bejegyzést, amely azt szabályozza, hogy a Csatlakozáskezelő bejelentkezési párbeszédpaneljén megjelenjen-e az Új gomb.
  • Módosíthatja a HideDomain bejegyzést, amely azt szabályozza, hogy megjelenjen-e a Bejelentkezési tartomány mező.
  • Módosíthatja a beállításokat a [Server&EntryName] és a [TCP/IP&EntryName] szakaszokban, ahol olyan további beállítások adhatók meg, amelyek meghatározzák, hogy a Csatlakozáskezelő hogyan kezelje a Hálózat és telefonos kapcsolat bejegyzéseit. A bejegyzések nagy részének szabályozása a Csatlakozáskezelő felügyeleti csomag varázslón keresztül történik, néhányat (például az IP_Header_Compress bejegyzést) azonban a .cms fájlban kell módosítani.
  • Létrehozhat egy TCP/IP&TunnelDUN szakaszt, amely az összes VPN-kapcsolat esetében alkalmazott VPN Hálózat és telefonos kapcsolatok bejegyzést határozza meg.

Megjegyzések

  • Az alábbi táblázatban a Csatlakozáskezelő felügyeleti csomag varázsló által szabályozott bejegyzések mellett a Beállítás helye oszlopban Csatlakozáskezelő felügyeleti csomag megjegyzés látható. Bár ezek a jelzők megjelennek a .cms fájlban, ne ott módosítsa azokat, mert a Csatlakozáskezelő felügyeleti csomag varázsló felülírhatja a .cms fájlokban lévő bejegyzéseket. Ezeket a bejegyzéseket a Csatlakozáskezelő felügyeleti csomag varázslóval frissítse.
  • Ha egy bejegyzés a .cms és a .cmp fájlokban is érvényes, akkor csak a .cms bejegyzést kell módosítani.
  • A .cmp fájl helyét vagy teljes elérési úttal, vagy a helyre mutató hivatkozással kell megadni.

A következő táblázat a .cms és .cmp fájlok egyes szakaszainak érvényes bejegyzéseit tartalmazza, bemutatja a bejegyzések működését és használatát, és megadja, hogy az egyes bejegyzések hol állíthatók be (a Csatlakozáskezelő felügyeleti csomag varázslóban, a .cms fájlban vagy a .cmp fájlban).

[Szakasz] vagy bejegyzés | Jelentés | Beállítás helye
[Csatlakozáskezelő] A szolgáltatásprofil különböző beállításai. .cms
.cmp
Dialup Támogatottak-e a telefonos kapcsolatok.

0 = Nem.
1 (alapértelmezés) = Igen.

 .cms
Direct Támogatottak-e a közvetlen kapcsolatok.

0 = Nem.
1 (alapértelmezés) = Igen.

Ez a bejegyzés csak a virtuális magánhálózati (VPN) szolgáltatásprofilokra érvényes.

 .cms
ConnectionType A használandó csatlakozási metódus.

0 (alapértelmezés) = Csatlakozás telefonos kapcsolat alkalmazásával.
1 = Csatlakozás közvetlen kapcsolat (például helyi hálózat) használatával.

Ez a bejegyzés csak akkor érvényes, ha a Dialup és a Direct bejegyzés értéke egyaránt 1. A felhasználó ezt a beállítást a Tulajdonságok párbeszédpanel Általános lapján módosíthatja. A .cmp fájlban szereplő beállítás az aktuális állapotra vonatkozik.

 .cms
.cmp
CMSFile A szolgáltatásprofil-fájl neve:

(\Elérési_út\SzolgáltatásprofilNév.cms)

ahogy a Szolgáltatás- és fájlnevek párbeszédpanel Fájlnév mezőjében szerepel. Ebben a névben tilos a következő karakterek használata: ! , ; <szóköz> * = \ / : ? ' " < > | . % + [ ] $ #. Ezt a bejegyzést tilos módosítani a .cms fájlban. Ha másik nevet szeretne használni, a Csatlakozáskezelő felügyeleti csomag varázslóval módosítsa a meglévő profilt, és adjon meg új nevet a Szolgáltatásnév és a Fájlnév mezőben, majd fejezze be a varázsló futtatását. 		Csatlakozáskezelő felügyeleti csomag
ServiceName A profil legfontosabb azonosítója. A Csatlakozáskezelő bejelentkezési párbeszédpanelján megjelenő szöveg, amely a szolgáltatás nevére és a kapcsolat nevére utal.

Maximum = körülbelül 35 karakter. Ebben a névben tilos a következő karakterek használata: * \ / : ? " < > | [ ]

Ha a Csatlakozáskezelő-profilt szeretné beágyazni egy, az IEAK használatával létrehozott Microsoft Internet Explorer telepítőcsomagba, akkor ennek a névnek azonosnak kell lennie az Internet Explorer alkalmazás .ins fájljának [Entry] szakaszában szereplő névvel.

 Csatlakozáskezelő felügyeleti csomag
ServiceMessage A Csatlakozáskezelő bejelentkezési párbeszédpanelján megjelenő üzenet, rendszerint a szolgáltatással kapcsolatos ügyféltámogatás telefonszáma.

Maximum = Körülbelül 50 karakter.

 Csatlakozáskezelő felügyeleti csomag
UserName | A felhasználó által beírt név, amely a felhasználó azonosítására szolgál. | .cmp
InternetUserName | A VPN -kapcsolatokhoz használt felhasználói név, amelyet a felhasználó írt be. | .cmp
UseSameUserName Használható-e külön felhasználói név és jelszó az Internet-szolgáltatóhoz történő kapcsolódás során (VPN-kapcsolat esetén).

0 (alapértelmezés) = A felhasználó által a Tulajdonság párbeszédpanel Internetes bejelentkezés lapján megadott másik felhasználói név és jelszó használata.
1 = kapcsolódás az Internet-szolgáltatóhoz ugyanannak a felhasználói névnek és jelszónak a használatával, amely a Csatlakozáskezelő bejelentkezési párbeszédpaneljén a magánhálózatra történő bejelentkezéshez van megadva.

 Csatlakozáskezelő felügyeleti csomag
UserNamePrefix | A felhasználói névhez kapcsolt előtag. Lehetővé teszi olyan szolgáltatás elérését is, amelyhez felhasználói név előtagjaként alkalmazott tartománynév szükséges. | Csatlakozáskezelő felügyeleti csomag
UserNameSuffix | A felhasználói névhez kapcsolt utótag. Lehetővé teszi olyan szolgáltatás elérését is, amelyhez felhasználói név utótagjaként alkalmazott tartománynév szükséges. | Csatlakozáskezelő felügyeleti csomag
MaxUserName A felhasználó által begépelhető felhasználói név maximális hosszúsága.

Alapértelmezés = 256 bájt.

.cms
UserNameOptional Kötelező-e felhasználói nevet megadnia a felhasználónak a Csatlakozáskezelő bejelentkezési párbeszédpanelján.

0 (alapértelmezés) = Kötelező a felhasználói név megadása.
1 = Nem kötelező a felhasználói név megadása.

 .cms
HideUserName Megjelenjen-e a Felhasználónév mező a Csatlakozáskezelő bejelentkezési párbeszédpaneljén telefonos kapcsolatok használatakor.

0 (alapértelmezés) = A mező megjelenik.
1 = A mező nem jelenik meg.

Ha a mező rejtett, akkor az adat megadása nem kötelező.

.cms
HideInternetUsername Megjelenjen-e a Felhasználónév mező a Tulajdonságok párbeszédpanel Internetes bejelentkezés lapján.

0 (alapértelmezés) = A mező megjelenik.
1 = A mező nem jelenik meg.

Ha a mező rejtett, akkor az adat megadása nem kötelező. Ha a HideInternetPassword és a HideInternetUsername bejegyzések értéke egyaránt 1, akkor a lap egyáltalán nem jelenik meg.

.cms
Password | A felhasználó által beírt jelszó. | .cmp
InternetPassword | A felhasználó által beírt, VPN-kapcsolatokhoz használt jelszó. | .cmp
PasswordHandling A jelszó bejelentkezési folyamat során alkalmazott kezelési módja.

0 (alapértelmezés) = Normál (kis- és nagybetű különbözik).
1 = Kisbetűs jelszó.
2 = Nagybetűs jelszó.

 .cms
MaxPassword A felhasználó által begépelhető jelszó maximális hosszúsága.

Alapértelmezés = 256 bájt.

 .cms
PasswordOptional Kötelező-e jelszót megadnia a felhasználónak a Csatlakozáskezelő bejelentkezési párbeszédpaneljén.

0 (alapértelmezés) = Kötelező a jelszó megadása.
1 = Nem kötelező a jelszó megadása.

 .cms
RememberPassword Bejelölte-e a felhasználó a Jelszó mentése jelölőnégyzetet a Csatlakozáskezelő bejelentkezési párbeszédpaneljén.

0 (alapértelmezés) = A jelölőnégyzet nincs bejelölve.
1 = A jelölőnégyzet be van jelölve.

 .cmp
RememberInternetPassword Bejelölte-e a felhasználó a Jelszó mentése jelölőnégyzetet az Internetes bejelentkezés párbeszédpanelen.

0 (alapértelmezés) = A jelölőnégyzet nincs bejelölve.
1 = A jelölőnégyzet be van jelölve.

 .cmp
ResetPassword | Megjelenjen-e a Csatlakozáskezelő bejelentkezési párbeszédpaneljén az Új gomb, amely lehetővé teszi, hogy a felhasználó visszaállítsa a jelszót. Ezzel a gombbal egyéni jelszó-beállítások adhatók meg. Adja meg annak a futtatható programnak a helyét és nevét, amelyet e folyamat támogatásához használni kíván. Ehhez a beállításhoz meg kell adni egy futtatható programot, és azt egy további fájlba kell beágyazni a Csatlakozáskezelő felügyeleti csomag varázsló futtatásakor. | .cms
HidePassword Megjelenjen-e a Jelszó mező a Csatlakozáskezelő bejelentkezési párbeszédpaneljén telefonos kapcsolatok használatakor.

0 (alapértelmezés) = A mező megjelenik.
1 = A mező nem jelenik meg.

Ha a mező rejtett, akkor az adat megadása nem kötelező.

 .cms
HideInternetPassword Megjelenjen-e a Jelszó mező a Tulajdonságok párbeszédpanel Internetes bejelentkezés lapján.

0 (alapértelmezés) = A mező megjelenik.
1 = A mező nem jelenik meg.

Ha a mező rejtett, akkor az adat megadása nem kötelező. Ha a HideInternetPassword és a HideInternetUsername bejegyzések értéke egyaránt 1, akkor a lap egyáltalán nem jelenik meg.

.cms
HideRememberPassword Megjelenjen-e a Jelszó mentése jelölőnégyzet a Csatlakozáskezelő bejelentkezési párbeszédpaneljén és az Internetes bejelentkezés lapon. A VPN-kapcsolatok támogatása céljából kialakított szolgáltatásprofilok tartalmazzák ezt a kiegészítő lapot.

0 (alapértelmezés) = A jelölőnégyzet megjelenik.
1 = A jelölőnégyzet nem jelenik meg.

Ha a HideRememberPassword értéke 1, akkor abban az esetben is hatályon kívül helyezi a HideDialAutomatically beállítást, ha a HideDialAutomatically értéke nem 1.

 .cms
Domain | A bejelentkezési tartomány felhasználó által beírt neve. | .cmp
MaxDomain A felhasználó által begépelhető tartománynév maximális hosszúsága.

Alapértelmezés = 15 karakter.

 .cms
HideDomain Megjelenjen-e a Tartomány mező a Csatlakozáskezelő bejelentkezési párbeszédpaneljén telefonos kapcsolatok használatakor.

0 = A mező megjelenik.
1 = A mező nem jelenik meg.

Az alapértelmezett beállítás 1, ha a profil támogatja a VPN-kapcsolatokat, míg más esetekben az alapértelmezett beállítás 0. Ha a mező rejtett, az adatot nem kötelező megadni.

 .cms
DialAutomatically Bejelölte-e a felhasználó az Automatikus kapcsolódás jelölőnégyzetet a Csatlakozáskezelő bejelentkezési párbeszédpaneljén.

0 (alapértelmezés) = A jelölőnégyzet nincs bejelölve.
1 = A jelölőnégyzet be van jelölve.

 .cmp
HideDialAutomatically Megjelenjen-e az Automatikus kapcsolódás jelölőnégyzet a Csatlakozáskezelő bejelentkezési párbeszédpaneljén.

0 (alapértelmezés) = A jelölőnégyzet megjelenik.
1 = A jelölőnégyzet nem jelenik meg.

 .cms
Phone0 | A felhasználó által beírt vagy kijelölt elsődleges telefonszám. | .cmp
Phone1 | A felhasználó által beírt tartalék telefonszám. | .cmp
PhoneCanonical0 | A telefonkönyvből legutóbb kiválasztott elsődleges telefonszám szabványos formátuma, illetve a felhasználó által szabványos formátumban beírt telefonszám. | .cmp
PhoneCanonical1 | A telefonkönyvből legutóbb kiválasztott tartalék telefonszám szabványos formátuma, illetve a felhasználó által szabványos formátumban beírt telefonszám. | .cmp
PhoneCountry0 | Az elsődleges telefonszám Telefonos szolgáltatások fejlesztői felületen (TAPI) használatos ország- vagy körzetkódja. | .cmp
PhoneCountry1 | A tartalék telefonszám TAPI felületen használatos ország- vagy körzetkódja. | .cmp
UseDialingRules0 A tárcsázási szabályok alkalmazásának módjai az elsődleges telefonszámra.

0 = Pontosan azt a számformátumot kell alkalmazni, ahogy a telefonszám a telefonkönyvben megjelenik vagy begépelésre került.
1 = Tárcsázási szabályok alkalmazása a telefonszámra a megjelenés és a tárcsázás idején.

Ha a .cmp fájl rendelkezik értékkel, akkor ez az érték előnyt élvez a .cms fájlban szereplő értékkel szemben. Ha sem a .cmp, sem a .cms fájl nem tartalmaz értéket, akkor az érték 1 lesz.

 .cms
.cmp
UseDialingRules1 A tárcsázási szabályok alkalmazásának módjai a tartalék telefonszámra.

0 = Pontosan azt a számformátumot kell alkalmazni, ahogy a telefonszám a telefonkönyvben megjelenik vagy begépelésre került.
1 = Tárcsázási szabályok alkalmazása a telefonszámra a megjelenés és a tárcsázás idején.

Ha a .cmp fájl rendelkezik értékkel, akkor ez az érték előnyt élvez a .cms fájlban szereplő értékkel szemben. Ha sem a .cmp, sem a .cms fájl nem tartalmaz értéket, akkor az érték 1 lesz.

 .cms
.cmp
PhoneSource0 | Az elsődleges telefonszámhoz tartozó szolgáltatásprofil. | .cmp
PhoneSource1 | A tartalék telefonszámhoz tartozó szolgáltatásprofil. | .cmp
Description0 | Az elsődleges telefonszám leírása. A Telefonkönyv párbeszédpanelen mint egy kapcsolódási pont (POP) neve jelenik meg. | .cmp
Description1 | A tartalék telefonszám leírása. A Telefonkönyv párbeszédpanelen mint egy kapcsolódási pont neve jelenik meg. | .cmp
DUN0 | Az elsődleges telefonszámra vonatkozó hálózati és telefonos csatlakozási bejegyzések. | .cmp
DUN1 | A tartalék telefonszámra vonatkozó hálózati és telefonos csatlakozási bejegyzések. | .cmp
Modem0 | Az elsődleges telefonszámhoz használt modemeszköz neve. | .cmp
Modem1 | A tartalék telefonszámhoz használt modemeszköz neve. | .cmp
ServiceType0 | A felhasználó által a telefonkönyvből az elsődleges telefonszámhoz legutóbb kiválasztott szolgáltatás típusa. | .cmp
ServiceType1 | A felhasználó által a telefonkönyvből a tartalék telefonszámhoz legutóbb kiválasztott szolgáltatás típusa. | .cmp
Region0 | A felhasználó által a telefonkönyvből az elsődleges telefonszámhoz legutóbb kiválasztott ország vagy megye. | .cmp
Region1 | A felhasználó által a telefonkönyvből a tartalék telefonszámhoz legutóbb kiválasztott ország vagy megye. | .cmp
Version | A telefonkönyv verziószáma. Ha a telefonkönyvek biztosítása a Csatlakozási pont szolgáltatás (CPS) révén történik, a CPS telefonkönyv-kiszolgálója ebből a bejegyzésből állapítja meg a telefonkönyv kezelésének módját. A CPS telefonkönyv-kiszolgálója a változásokat tartalmazó fájlt letölti az ügyfélre, hacsak az ügyfél nem több mint öt verzióval régebbi. Ha a verziószám több mint öt verzióval korábbi, a PBS a teljes telefonkönyvet letölti. | .cms
Hálózati és telefonos kapcsolatok Az alapértelmezés szerinti hálózati és telefonos kapcsolatok bejegyzés használatára kerül sor, ha a Hálózati és telefonos kapcsolatok mező a telefonkönyvben üresen marad.

Alapértelmezés = SzolgáltatásprofilSzolgáltatásnév.

 .cms
DynamicPhoneNumber Beolvassa-e a Csatlakozáskezelő a telefonszámot a tárcsázás előtt.

0 (alapértelmezés) = Nincs ismételt beolvasás.
1 = Van ismételt beolvasás.

 .cms
RedialCount A tárcsázási kísérletek száma.

Alapértelmezés = 3.

 .cms
.cmp
RedialDelay A tárcsázások közötti idő (másodpercben). Az az idő, amely az első telefonszám sikertelen hívása és a következő telefonszám első számjegyének tárcsázása között telik el.

Alapértelmezés = 5 másodperc.

 .cms
IdleTimeout Az az időtartam (percben kifejezve), ameddig a kapcsolatnak tétlennek kell lennie a kapcsolat bontása előtt.

Alapértelmezés = 10 perc.
Ha 0 értéket ad meg, nincs időtúllépés.

 .cms
.cmp
IdleThreshold Percenként fogadott bájtok maximális száma, amikor a kapcsolat még tétlennek tekintendő.

Alapértelmezés = 0.

Ez a bejegyzés csak Windows 95 és Windows 98 operációs rendszerekre érvényes.

 .cms
NoPromptReconnect Értesítse-e a rendszer a kapcsolat ismételt létrehozásáról a felhasználót a kapcsolat véletlen megszakítása esetén.

0 (alapértelmezés) = Értesítés küldése.
1 = A rendszer nem küld értesítést.

 .cms
Icon A nagy programikon ikonfájljának (.ico) helye.

Alapértelmezés = A Csatlakozáskezelő szabványos programikonja.

 Csatlakozáskezelő felügyeleti csomag
SmallIcon A címsorban látható kis programikon ikonfájljának (.ico) helye.

Alapértelmezés = A Csatlakozáskezelő szabványos címsorikonja.

 Csatlakozáskezelő felügyeleti csomag
TrayIcon Az állapotterületen látható ikon ikonfájljának (.ico) helye.

Alapértelmezés = A Csatlakozáskezelő állapotterületen látható ikonja.

 Csatlakozáskezelő felügyeleti csomag
HideTrayIcon Megjelenjen-e az állapotterület ikon a Windows Tálcáján.

0 (alapértelmezés) = Az ikon megjelenik.
1 = Az ikon nem jelenik meg.

Ha úgy dönt, hogy az ikon ne jelenjen meg, a súgófájlból távolítsa el a vonatkozó hivatkozásokat.

 .cms
Logo A Csatlakozáskezelő bejelentkezési párbeszédpaneljén megjelenő .bmp fájl helye.

Alapértelmezés = A Csatlakozáskezelő szabványos bejelentkezési ikonja.

 Csatlakozáskezelő felügyeleti csomag
PBLogo A Telefonkönyv párbeszédpanelt ábrázoló .bmp fájl helye.

Alapértelmezés = A Telefonkönyv szabványos bitképe.

 Csatlakozáskezelő felügyeleti csomag
PBMessage Az a szöveg, amely a Telefonkönyv párbeszédpanelen a További telefonszámok mező mellett látható a telefonkönyv megjelenítésekor, és ha más telefonszámok is használhatók a kijelölt földrajzi terület hívásához.

Maximum = Körülbelül 100 karakter.

 Csatlakozáskezelő felügyeleti csomag
PBUpdateMessage Az a szöveg, amely a telefonkönyv frissítése közben a párbeszédpanelen látható.

Alapértelmezés = „Új telefonkönyv letöltése.”.

 .cms
DownloadDelay A telefonkönyv-frissítések letöltése ennyi idővel (másodperccel) később kezdődik. A késleltetés számlálása az első kapcsolat létrejöttekor kezdődik.

Alapértelmezés = 15 másodperc.

Ez a bejegyzés csak akkor érvényes, ha a Csatlakozáskezelő felügyeleti csomag varázslóban a Csatlakozás utáni műveletek párbeszédpanel A telefonkönyv-frissítések automatikus letöltése jelölőnégyzete be van jelölve.

.cms
HideDelay Ennyi idő (másodperc) múlva kerül sor a Telefonkönyv-frissítések párbeszédpanel megjelenítésére (folyamatjelzővel és üzenettel együtt).

Alapértelmezés = Ne jelenjen meg a párbeszédpanel.

 .cms
HelpFile Az egyéni súgófájl helye (és neve).

Alapértelmezett súgófájl = A normál szolgáltatásprofil súgófájlja.

 Csatlakozáskezelő felügyeleti csomag
Bújtatási alagút Engedélyezett-e VPN-kapcsolatok használata a hivatkozási szolgáltatásprofilhoz.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

 Csatlakozáskezelő felügyeleti csomag
TunnelDUN Telefonos hálózati bejegyzések a VPN-kapcsolatokhoz.

Alapértelmezés = SzolgáltatásprofilSzolgáltatásnév bújtatási alagút.

 .cms
TunnelAddress | A VPN-kiszolgáló IP-címe vagy annak a tartománynak a neve, amelyhez tartozik. | Csatlakozáskezelő felügyeleti csomag
TunnelReferences Engedélyezett-e VPN-kapcsolatok használata az egyesített telefonkönyvből származó telefonszámok esetében.

0 (alapértelmezés) = Ilyen telefonszámok esetén ne használjon VPN-kapcsolatot.
1 = használjon VPN-kapcsolatot hivatkozott profilból származó telefonszám esetén.

 Csatlakozáskezelő felügyeleti csomag
AnimatedLogo Helyettesítse-e animáció a statikus képet a Csatlakozáskezelő bejelentkezési párbeszédpanelján.

0 (alapértelmezés) = Ne legyen animáció.
1 = Legyen animáció.

Az [Animated Logo] szakasz tartalmazza az animációs fájl (.spl vagy .swf) helyét. Ez a funkció biztosítja a kompatibilitást a Csatlakozáskezelő 1.0 programmal, amely támogatja a Macromedia Flash animációs fájlokat.

.cms
CheckOSComponents Ellenőrizze-e a Csatlakozáskezelő az operációs rendszer összetevőit.

0 (alapértelmezés) = Csak hiba esetén ellenőrizze az operációs rendszer összetevőit.
1 = Minden indításkor ellenőrizze az operációs rendszer összetevőit.

 .cms
DoNotCheckBindings Részei legyenek-e a TCP/IP kötések az operációs rendszerösszetevők ellenőrzésének.

0 (alapértelmezés) = A TCP/IP kötések legyenek részei a TCP/IP ellenőrzésnek, és minden kötetlen elem kerüljön lekötésre.
1 = A TCP/IP kötések ne képezzék részét az operációs rendszerösszetevők ellenőrzésének.

Ez a bejegyzés csak Windows 95 és Windows 98 rendszerekre érvényes.

A TCP/IP betétek ellenőrzése csak akkor akadályozható meg, ha ennek a beállításnak az értéke minden telepített szolgáltatásprofil esetében 1. Ez a beállítás nem akadályozza meg, hogy a kötéseket más szolgáltatásprofilok vagy programok ne ellenőrizzék.

 .cms
IsdnDialMode Kapcsolatot teremt-e a Csatlakozáskezelő két csatorna között, amelyek ugyanazon az ISDN-eszközön találhatók.

0 (alapértelmezés) = Nincs kapcsolat (egyetlen csatorna van használatban).
1 = Mindig összeköti a két csatornát (mindkét csatornát automatikusan csatlakoztatja).

Ez a bejegyzés csak Windows 2000 operációs rendszer esetén érvényes.

 .cms
[Profile Format] (Profilformátum) Szolgáltatásprofil verziója. .cms
.cmp
Version A profil vagy szolgáltatásfájl formátumának verziója. .cms
.cmp
[ISP] (Internet-szolgáltató) | Azok a szolgáltatástípusok (például modemes vagy ISDN használatára épülő szolgáltatás), amelyet szerepeltetni kíván a Telefonkönyv párbeszédpanelen, illetve a telefonszámok megjelenésének módja az egyes szolgáltatástípusok esetében. A Mask és a Match sorok szabályozzák, hogy a telefonszám a Telefonkönyv párbeszédpanel mely részén jelenjen meg. Be lehet állítani, hogy a szám a Telefonszámok vagy a További telefonszámok listamezőben jelenjen meg. Minden Mask és Match sor megfelelő szolgáltatási beállítással rendelkezik a Telefonkönyv-felügyelőben. | .cms
PBFile | A szolgáltatásprofil által használt telefonkönyvfájl (.pbk) helye. | Csatlakozáskezelő felügyeleti csomag
RegionFile | A szolgáltatásprofil által használt regionális fájl (.pbr) helye. | Csatlakozáskezelő felügyeleti csomag
PBURL | Egységes erőforrás-elérési útvonal (URL) a telefonkönyv-frissítéshez. | Csatlakozáskezelő felügyeleti csomag
Mask&Szűrőnév | A Szűrőnév maszkértéke. | .cms
Match&Szűrőnév | A Szűrőnév egyezési értéke. | .cms
FilterA&Szolgáltatásprofil A telefonkönyvben a telefonszámok beállítására szolgáló mezőkben alkalmazható szűrőnevek, például:

FilterA& = NosurchargeSignon

A kijelölt telefonszámok a Csatlakozáskezelő Telefonkönyv párbeszédpanelján a Telefonszámok mezőben jelennek meg.

Alapértelmezés = NosurchargeSignon.

 .cms
FilterB&Szolgáltatásprofil A hivatkozott telefonkönyv beállítási mezőiben alkalmazható szűrőnevek, például:

FilterB& = SurchargeSignon

A kijelölt telefonszámok a Csatlakozáskezelő Telefonkönyv párbeszédpanelján a További telefonszámok mezőben jelennek meg.

Alapértelmezés = SurchargeSignon.

 .cms
References | A Csatlakozáskezelő felügyeleti csomag varázsló segítségével összefésült szolgáltatásprofilok. A profilneveket vesszők, tabulátorjelek vagy szóközök választják el. Minden név az adott profilra történő hivatkozásként használatos. | Csatlakozáskezelő felügyeleti csomag
CMSFile&ÖsszefésültProfil Az összefésült szolgáltatásfájl (.cms fájl) helye. Formátuma: CMSFile&ÖsszefésültProfil=Hely, ahol ÖsszefésültProfil az összefésült szolgáltatásprofil neve, Hely pedig az összefésült szolgáltatásprofilhoz tartozó .cms fájl helye. Például:

CMSFile&Soft1 = Soft1\SoftE.cms

 Csatlakozáskezelő felügyeleti csomag
FilterA&ÖsszefésültProfil A hivatkozott telefonkönyv beállítási mezőjében alkalmazható szűrőnevek listája. Formátuma: FilterA&Hivatkozás = SzűrőNév, ahol ÖsszefésültProfil az összefésült szolgáltatásprofil neve abban a formában, ahogy a CMSFileÖsszefésültProfil bejegyzés tartalmazza, SzűrőNév pedig az alkalmazandó szűrő neve. Például:

FilterA&SoftE = NoSurchargeSignon

A kijelölt telefonszámok összefésülésére a Csatlakozáskezelő Telefonkönyv párbeszédpaneljén a Telefonszámok mezőben kerül sor.

 Csatlakozáskezelő felügyeleti csomag
FilterB&ÖsszefésültProfil A hivatkozott telefonkönyv beállítási mezőjében alkalmazható szűrőnevek listája. Formátuma: FilterB&ÖsszefésültProfil = SzűrőNév, ahol ÖsszefésültProfil az összefésült szolgáltatásprofil neve abban a formában, ahogy a CMSFileHivatkozás bejegyzés tartalmazza, SzűrőNév pedig az alkalmazandó szűrő neve. Például:

FilterB&SoftE = SurchargeSignon

A kijelölt telefonszámok összefésülésére a Csatlakozáskezelő Telefonkönyv párbeszédpaneljén a További telefonszámok mezőben kerül sor.

 Csatlakozáskezelő felügyeleti csomag
[Service Types] (Szolgáltatástípusok) | Azok az elemek, amelyek a Telefonkönyv párbeszédpanel Szolgáltatástípus területén szerepelnek. | .cms
SzolgáltatásTípus Egy szolgáltatási típus, amely szűrőnévként a hivatkozott telefonkönyv beállításaira vonatkozó mezőre alkalmazható. A bejegyzés formátuma: SzolgáltatásTípus=SzűrőNév, ahol SzolgáltatásTípus a név abban a formában, ahogyan a Telefonkönyv párbeszédpanel Szolgáltatás típusa listájában látható, SzűrőNév pedig a bejegyzéshez társítani kívánt szűrő neve. Például:

ISDN Multicast = MulticastISDN

A szolgáltatástípus neve lehetőleg ne legyen hosszabb 25 karakternél. Ha szolgáltatástípust szeretne hozzáadni, másolja ki és módosítsa az egyik sort a [Service Types] szakaszban.

.cms
[Pre-Connect Actions] (Csatlakozás előtti műveletek) | Választható csatlakozás előtti műveletek, amelyek a kapcsolat létrejötte előtt futtathatók. A következő környezeti változók be vannak állítva a Csatlakozáskezelőben, és a csatlakozási műveletekben mint parancssori beállítások valósíthatók meg: Profile, UserName, UserPrefix, UserSuffix, ServiceName, DialRasPhoneBook, TunnelRasPhoneBook, AutoRedial, PopName, ErrorCode, DialRasEntry és TunnelRasEntry. További beállítások programszerűen érhetők el a távelérés alkalmazásfejlesztési felületein (API) keresztül, amelynek dokumentációját a Microsoft Platform Software Development Kit (SDK) tartalmazza. | Csatlakozáskezelő felügyeleti csomag
# Egyetlen csatlakozás előtti művelet. A bejegyzés formátuma: # = Program, ahol # egy 0 és x közötti szám, Program pedig a program teljes neve (amely tartalmazza az .exe vagy .dll fájlt és a társított paramétereket is). A programok egymás után indulnak el. A 0 jelzésű indul elsőként, az 1 jelzésű a következő, és így tovább. Csatlakozáskezelő felügyeleti csomag
#&Flags Működésbe lépjen-e egy csatlakozás előtti művelet egy bizonyos típusú kapcsolat létrejöttekor. A bejegyzés formátuma: #&Flags = x, ahol # egy definiált csatlakozás előtti művelet száma, x pedig az az érték, amely az adott csatlakozás előtti művelet telefonos és közvetlen kapcsolatainak kezelési módjára utal:
  • Ha x = 0 (alapértelmezés), akkor a telefonos és közvetlen kapcsolatok is tartalmazzák a csatlakozás előtti műveletet. (Az alapértelmezés szerinti bejegyzés nem jelenik meg a .cms fájlban.)
  • Ha x = 1, akkor csak a közvetlen kapcsolatok tartalmazzák a csatlakozás előtti műveletet.
  • Ha x = 2 , akkor ezt a csatlakozás előtti műveletet csak a telefonos kapcsolatok tartalmazzák.
 Csatlakozáskezelő felügyeleti csomag
#&Description A csatlakozás előtti művelet rövid leírása. A bejegyzés formátuma: #&Description = szöveg, ahol # a definiált csatlakozás előtti művelet száma, szöveg pedig a csatlakozás előtti műveletre vonatkozó leíró információ. Ezzel az eszközzel hasznos információk biztosíthatók, ha az egyidejű csatlakozási műveletek nem működnek megfelelően.

Alapértelmezés = programnév (megadása a csatlakozás előtti műveletre vonatkozó # = Program formátumban történik).

 Csatlakozáskezelő felügyeleti csomag
[Pre-Tunnel Actions] (Bújtatás előtti műveletek) | Az opcionális bújtatás előtti műveleteket a kapcsolat létrejötte után, de még a VPN-kapcsolat létrejötte előtt kell futtatni. A bújtatás előtti műveletek formátuma azonos a többi csatlakozási művelet formátumával (lásd a [Csatlakozás előtti műveletek] szakaszban a #, #&option és #&Description bejegyzéseket). | Csatlakozáskezelő felügyeleti csomag
[Connect Actions] (Csatlakozási műveletek) | Az opcionális csatlakozás utáni műveleteket a csatlakozás létrejötte után, illetve VPN-kapcsolat használata esetén a bújtatás létrejötte után kell futtatni. A csatlakozás utáni műveletek formátuma azonos a többi csatlakozási művelet formátumával (lásd a [Csatlakozás előtti műveletek] szakaszban a #, #&option és #&Description bejegyzéseket). | Csatlakozáskezelő felügyeleti csomag
[Disconnect Actions] (Kapcsolatbontási műveletek) | A nem kötelező kapcsolatbontási műveletek futtatása közvetlenül a kapcsolat bontása előtt történik. A kapcsolatbontási műveletek formátuma azonos a többi csatlakozási művelet formátumával (lásd a [Csatlakozás előtti műveletek] szakaszban a #, #&option és #&Description bejegyzéseket). | Csatlakozáskezelő felügyeleti csomag
[Pre-Dial Actions] (Tárcsázás előtti műveletek) | Az opcionális tárcsázás előtti műveleteket közvetlenül a tárcsázás előtt kell futtatni. A tárcsázás előtti műveletek formátuma azonos a többi csatlakozási művelet formátumával (lásd a [Csatlakozás előtti műveletek] szakaszban a #, #&option és #&Description bejegyzéseket), azonban beállításukra nincs mód a Csatlakozáskezelő felügyeleti csomag varázslóban. Csatlakozás előtti művelet létrehozásához nyissa meg a .cms fájlt, másoljon ki egy csatlakozás előtti, bújtatás előtti vagy csatlakozási műveletet, amelyet a Csatlakozáskezelő felügyeleti csomag varázslóval hozott létre, illessze be a [Csatlakozás előtti műveletek] szakaszba, majd igény szerint módosítsa az információt. | .cms
[On-Cancel Actions] (Megszakításkor végrehajtandó műveletek) | Az opcionális, megszakításkor végrehajtandó műveleteket akkor kell futtatni, amikor a felhasználó visszavon egy munkamenetet a csatlakozási kísérlet megkezdése után (a Csatlakozás gombra való kattintáskor). A megszakításkor végrehajtandó műveletek formátuma azonos a többi csatlakozási művelet formátumával (lásd a [Csatlakozás előtti műveletek] szakaszban a #, #&option és #&Description bejegyzéseket), azonban beállításukra nincs mód a Csatlakozáskezelő felügyeleti csomag varázslóban. Megszakításkor végrehajtandó művelet létrehozásához nyissa meg a .cms fájlt, másoljon ki egy csatlakozás előtti, bújtatás előtti vagy csatlakozási műveletet, amelyet a Csatlakozáskezelő felügyeleti csomag varázslóval hozott létre, illessze be az [On-Cancel Actions] szakaszba, majd igény szerint módosítsa az információt. | .cms
[On-Error Actions] (Hiba esetén végrehajtandó műveletek) | A választható, hiba esetén végrehajtandó műveletek futtatása hiba esetén történik. A hiba esetén végrehajtandó műveletek formátuma azonos a többi csatlakozási művelet formátumával (lásd a [Pre-Connect Actions] szakaszban a #, #&option és #&Description bejegyzéseket), azonban beállításukra nincs mód a Csatlakozáskezelő felügyeleti csomag varázslóban. Hiba esetén végrehajtandó művelet létrehozásához nyissa meg a .cms fájlt, másoljon ki egy csatlakozás előtti, bújtatás előtti vagy csatlakozási műveletet, amelyet a Csatlakozáskezelő felügyeleti csomag varázslóval hozott létre, illessze be az [On-Error Actions] szakaszba, majd igény szerint módosítsa az információt. | .cms
[Auto-Applications] (Automatikusan futó alkalmazások) | Az opcionális, automatikusan futó alkalmazásokat a kapcsolat közben kell futtatni. Az automatikusan futó alkalmazások hasonlítanak a csatlakozási műveletekre, azzal a különbséggel, hogy a kapcsolatbontást az utolsó még működő automatikusan futó alkalmazás befejeződése után azonnal megkezdik. (Az automatikusan futó alkalmazások formátuma azonos a [Pre-Connect Actions] szakaszban bemutatott # bejegyzés formátumával.) A csatlakozási műveletektől eltérően, az automatikusan futó alkalmazások nem használják a #&option vagy #&Description bejegyzéseket, és a DLL-ek használatát sem támogatják. | Csatlakozáskezelő felügyeleti csomag
[Menu Options] (Menübeállítások) | Helyi menü, amely akkor jelenik meg, amikor a felhasználó egy szolgáltatás állapotterületen látható ikonjára kattint az egér jobb gombjával. | Csatlakozáskezelő felügyeleti csomag
MenüelemNév A helyi menüből futtatandó parancs. A helyi menü parancsainak formátuma: MenüelemNév = Program, ahol MenüelemNév a helyi menüben megjelenő leíró név, Program pedig a végrehajtható fájl (.exe vagy más végrehajtható héjprogram) neve a program számára szükséges valamennyi paraméterrel együtt. Ha például a Jegyzettömb alkalmazást „Editor” parancsnévvel szeretné hozzáadni a menühöz, akkor a [Menu Options] sor a következő: Editor = Notepad.exe.

Default commands = Status (Állapot) és Connect (Csatlakozás).

Ezek a programok egy helyi menüben találhatók, amely akkor jelenik meg, amikor a felhasználó jobb egérgombbal az állapotjelző terület ikonjára kattint. Az alkalmazások a menüben egymás után helyezkednek el. 0 jelzi az első alkalmazást, 1-es a következőt, és így tovább.

 Csatlakozáskezelő felügyeleti csomag
[Animated Logo] (Animált embléma) A Csatlakozáskezelő bejelentkezési párbeszédpaneljén megjelenő animáció.

Az [Animated Logo] szakasz tartalmazza az animációs fájl (.spl vagy .swf) helyét. Ez a funkció biztosítja a kompatibilitást a Csatlakozáskezelő 1.0 programmal, amely támogatja a Macromedia Flash animációs fájlokat.

A [Connection Manager] szakasz AnimatedLogo sora határozza meg, hogy sor kerül-e animáció alkalmazására.

 .cms
Movie | Annak a választható mozgóképfájlnak a helye, amely a bejelentkezési párbeszédpanelen a statikus bitkép helyén jelenik meg. Az [Animated Actions] szakaszban megadott beállítások szabályozzák, hogyan kerüljön sor az animáció lejátszására a csatlakozás különböző fázisaiban. | .cms
Paraméter | A szoftvertől származó egyéb animációs paraméterek, amelyek az animáció létrehozásához szükségesek, például: Quality = 3. | .cms
[Animated Actions] (Animált műveletek) | Az animáció egyes szakaszainak lejátszási időpontja. | .cms
Initial | Kezdőkeret száma. Lejátszása a Csatlakozáskezelő elindulásakor történik. | .cms
Dialing0 | Kezdőkeret száma. Lejátszása az elsődleges telefonszám tárcsázásakor történik. | .cms
Pausing | Kezdőkeret száma. Lejátszása két tárcsázás között történik. | .cms
Dialing1 | Kezdőkeret száma. Lejátszása a tartalék telefonszám tárcsázásakor történik. | .cms
Authenticating | Kezdőkeret száma. Lejátszása a felhasználó hitelesítésekor történik. | .cms
Tunneling | Kezdőkeret száma. Lejátszása egy VPN-kapcsolat létrehozása közben történik. | .cms
Connected | Kezdőkeret száma. Lejátszása a csatlakozás létrejöttekor történik. | .cms
Error | Kezdőkeret száma. Lejátszására bármilyen csatlakozási hiba felmerülésekor kerül sor. | .cms
[Server&TunnelDUN] | A hálózati és telefonos kapcsolatokra vonatkozó konfiguráció, amely az összes VPN-kapcsolathoz használható. A szakasz címében a TunnelDUN kifejezés a [Connection Manager] szakasz TunnelDUN bejegyzésében megadott Hálózat és telefonos kapcsolatok bejegyzés nevére utal. Például: [Server&Soft1 Tunnel]. Ennek a szakasznak a formátuma megegyezik a [Server&BejegyzésNév] szakasz formátumával, beleértve az adott szakaszban érvényes összes bejegyzést is. | Csatlakozáskezelő felügyeleti csomag
[Server&BejegyzésNév] | Hálózat és telefonos kapcsolatok konfigurációja, amelyben a BejegyzésNév a hálózat és telefonos kapcsolatra vonatkozó bejegyzés neve, például: [Server&Soft1]. | .cms
NetworkLogon Be kell-e jelentkezni a hálózatba.

0 (alapértelmezés) = Nincs bejelentkezés.
1 = Be kell jelentkezni.

 .cms
SW_Compress Sor kerül-e egyeztetésre az adatok PPP szoftveres tömörítését illetően.

0 = Nincs egyeztetés.
1 (alapértelmezés) = Van egyeztetés.

 .cms
Disable_LCP Engedélyezett-e a Link Control protokoll (LCP) bővítmények használata.

0 = Engedélyezett.
1 (alapértelmezés) = Tiltott.

 .cms
PW_Encrypt Titkosítandó-e a jelszó hitelesítéskor.

0 (alapértelmezés) = Nem titkosítható.
1 = Titkosítható.

.cms
Negotiate_TCP/IP Sor kerül-e a TCP/IP egyeztetésére.

0 = Nincs egyeztetés.
1 = Van egyeztetés. A beállítás értéke mindig 1 legyen.

.cms
Negotiate_IPX Sor kerül-e az IPX-protokoll egyeztetésére.

0 = Nincs egyeztetés.
1 (alapértelmezés) = Van egyeztetés.

 .cms
Negotiate_NetBEUI Sor kerüle-e a NetBIOS kibővített felhasználói felület (NetBEUI) protokoll egyeztetésére.

0 (alapértelmezés) = Nincs egyeztetés.
1 = Van egyeztetés.

 .cms
Require_PAP Engedélyezett-e a Password Authentication protokoll (PAP) használata.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

Csak Windows 2000 (és újabb) operációs rendszerek esetében érvényes.

 .cms
Require_SPAP Engedélyezett-e a SPAP protokoll használata.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
Require_EAP Engedélyezett-e az Extensible Authentication protokoll (EAP) használata. 0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.
Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes. 		.cms
Require_CHAP Engedélyezett-e a Challenge Handshake Authentication protokoll (CHAP) használata.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
Require_MSCHAP Engedélyezett-e az MSCHAP protokoll használata.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
Require_MSCHAP2 Engedélyezett-e az MSCHAP2 protokoll használata.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
Require_W95MSCHAP Engedélyezett-e a W95MSCHAP protokoll használata.

0 (alapértelmezés) = Nem engedélyezett.
1 = Engedélyezett.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
Custom_Security Az alkalmazott biztonsági konfiguráció típusa.

0 (alapértelmezés) = Normál konfiguráció.
1 = Egyéni konfiguráció. E szolgáltatás alkalmazásához a létrehozását követően ezt a szolgáltatást használó kapcsolódási pontokat különíthet el azoktól a kapcsolódási pontoktól, amelyek a További telefonszámok szolgáltatást használják.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
EncryptionType Az alkalmazott titkosítási szint.

0 (telefonos kapcsolat esetén ez az alapértelmezett) = Nincs.
1 (nem telefonos kapcsolat esetén ez az alapértelmezett) = Igényel.
2 = Maximumot igényel.
3 = Választható.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
CustomAuthKey Az aktuális kapcsolathoz használni kívánt Extensible Authentication protokoll (EAP) azonosítója. Formátuma: CustAuthKey=azonosító, ahol azonosító az EAP protokoll Internet Assigned Numbers Authority (IANA) azonosítója. Ha nincs megadva azonosító, akkor a program nem tesz kísérletet a CustomAuthData érték beolvasására.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes, és csak akkor, ha Custom_Security =1 beállítás van érvényben.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
CustomAuthData# Az EAP protokoll konfigurációs adatai. Formátuma: CustomAuthData#=EAPConfigurationData, ahol # az adatok egy bizonyos sorának sorszáma, például:

CustomAuthData0=1AFGKLMOFGH23K

Minden sor legfeljebb 128 karaktert tartalmazhat. Ha az azonosító hosszabb, mint 128 karakter, akkor többsorosként kell megadni úgy, hogy minden adatsor # értéke eggyel növekszik. Például:

CustomAutData0=Első128karakter
CustomAuthData1=Következő128karakter
CustomAuthData2=Utolsó karakterek

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes, és csak akkor, ha Custom_Security =1 beállítás van érvényben.

Csak Windows 2000 (és későbbi) operációs rendszerek esetében érvényes.

 .cms
[TCP/IP&TunnelDUN] A hálózat és telefonos kapcsolatok konfigurációja, amely az összes VPN-kapcsolathoz használható. A szakasz címében a TunnelDUN kifejezés a [Connection Manager] szakasz TunnelDUN bejegyzésében megadott Hálózat és telefonos kapcsolatok bejegyzés nevére utal. Például: [TCP/IP&Soft1 Tunnel]. Ennek a szakasznak a formátuma megegyezik a [TCP/IP&BejegyzésNév&] szakasz formátumával, beleértve az adott szakaszban érvényes összes bejegyzést is. A szakasz létrehozása a Csatlakozáskezelő felügyeleti csomag varázslóval történt, a bejegyzések azonban a .cms fájlban is módosíthatók. Csatlakozáskezelő felügyeleti csomag
.cms
[TCP/IP&BejegyzésNév] Hálózat és telefonos kapcsolatok konfigurációja, amelyben a BejegyzésNév a Hálózat és telefonos kapcsolatok bejegyzés neve, például: [TCP/IP&Soft1] Csatlakozáskezelő felügyeleti csomag
.cms
Specify_IP_Address Meg kell-e adni statikus IP-címet.

0 (alapértelmezés) = Nem kell megadni.
1 = Meg kell adni.

 Csatlakozáskezelő felügyeleti csomag
IP_Address | Statikus IP-címek. | Csatlakozáskezelő felügyeleti csomag
Specify_Server_Address Meg kell-e adni a statikus DNS vagy Windows Internet Name Service (WINS) címeket.

0 (alapértelmezés) = Nem kell megadni.
1 = Meg kell adni.

 Csatlakozáskezelő felügyeleti csomag
DNS_Address | DNS-cím. | Csatlakozáskezelő felügyeleti csomag
DNS_Alt_Address | Másik DNS-cím. | Csatlakozáskezelő felügyeleti csomag
WINS_Address | WINS-cím. | Csatlakozáskezelő felügyeleti csomag
WINS_Alt_Address | Másik WINS-cím. | Csatlakozáskezelő felügyeleti csomag
IP_Header_Compress Engedélyezett-e az IP-fejléc tömörítése.

0 = Nem engedélyezett.
1 (alapértelmezés) = Engedélyezett.

 .cms
Gateway_On_Remote Használható-e az alapértelmezett átjáró a távoli magánhálózatban.

0 = Nem használható.
1 (alapértelmezés) = Használható.

 .cms
[Networking&TunnelDUN] | Az egyetlen olyan hálózati és telefonos kapcsolatokra vonatkozó konfiguráció, amely az összes VPN-kapcsolathoz használható. A szakasz címében a TunnelDUN kifejezés a [Connection Manager] szakasz TunnelDUN bejegyzésében megadott Hálózat és telefonos kapcsolatok bejegyzés nevére utal. Például: [Networking&Soft1 Tunnel]. | Csatlakozáskezelő felügyeleti csomag
VpnStrategy A VPN-kapcsolat létrehozásakor használni kívánt bújtatóprotokoll.

0 (alapértelmezés) = Az elsődleges protokoll automatikus kiválasztása.
1 = Csak a Point-to-Point Tunneling protokoll (PPTP) használata.
2 = Első kísérlet a PPTP protokollal.
3 = Csak az L2TP protokoll használata.
4 = Első kísérlet az L2TP protokollal.

Megjegyzés

  • Jelenleg a PPTP az elsődleges protokoll.

Csak Windows 2000 (és újabb) operációs rendszerek esetében érvényes.

 .cms
[Scripting&BejegyzésNév] szakasz | A hálózati és telefonos kapcsolatokra vonatkozó bejegyzés parancsfájljának (.scp) helye (elérési úttal és névvel), ahol BejegyzésNév a telefonos és hálózati bejegyzés neve. Például: [Scripting&Soft1]). | Csatlakozáskezelő felügyeleti csomag
Name | A telefonos és hálózati bejegyzésre vonatkozó parancsfájl (.scp) helye (a fájlnévvel együtt). | Csatlakozáskezelő felügyeleti csomag


3. fázis: a Csatlakozáskezelő felügyeleti csomag varázsló futtatása és a szolgáltatásprofil létrehozása

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével gyorsan és könnyen hozhat létre a Csatlakozáskezelő beállításához szükséges szolgáltatásprofilokat.

Az egyéni elemeket már a Csatlakozáskezelő felügyeleti csomag varázsló indítása előtt létre kell hozni. A varázsló indítása előtt bizonyosodjon meg róla, hogy megvan minden, ami szükséges:

  • a létrehozandó szolgáltatásprofilokhoz tartozó tervezőlapok másolatai, illetve
  • minden olyan külső fájl, amely az egyéni elemek használatához szükséges – ezeket a fájlokat a tervezőlapon kell megadni.

Ez az útmutató minden olyan információt tartalmaz, amely a Csatlakozáskezelő felügyeleti csomag varázsló futtatásához és szolgáltatásprofil létrehozásához szükséges:

  • A Csatlakozáskezelő felügyeleti csomag varázsló futtatásának előkészítése
  • Szolgáltatásprofil létrehozása a Csatlakozáskezelő felügyeleti csomag varázsló segítségével
  • A testreszabás befejezése a Csatlakozáskezelő felügyeleti csomag varázsló futtatását követően


A Csatlakozáskezelő felügyeleti csomag varázsló futtatásának előkészítése

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével szolgáltatásprofilt hozhat létre. A varázslóban haladva beállításokat kell megadnia és be kell írnia az előkészített egyéni elemek helyét. A varázsló futtatása előtt azt telepítenie kell a számítógépre, és meg kell győződnie róla, hogy az egyéni elemek elérhetők.

A Csatlakozáskezelő felügyeleti csomag varázsló beállítása

A varázsló nem igényel beállítást a telepítést követően, de indítása előtt olvassa el a fontos fájlt (cmakfontos.htm), hogy tisztában legyen a szolgáltatásprofil létrehozásának menetével.

Sablonok szerkesztése

Mielőtt létrehozná a szolgáltatásprofilt a Csatlakozáskezelő felügyeleti csomag varázsló segítségével, keresse meg a hálózati rendszergazdától vagy más technikai vezetőtől kapott munkalap speciális testreszabási információit. A sablonok speciális testreszabását a varázsló futtatása előtt kell elvégezni. A sablonfájlok szerkesztéséről további információt a Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése című témakörben talál.

Az egyéni elemek mappájának létrehozása

Minden, az Ön vagy a csoport más tagja által létrehozott egyéni elemnek a Csatlakozáskezelő felügyeleti csomag varázsló futtatásakor elérhetőnek kell lennie. Hozzon létre egy mappát a szolgáltatásprofilba építendő fájlok számára. Az egyéni elemek megfelelő elhelyezésével megkönnyíthető a profilok Csatlakozáskezelő felügyeleti csomag varázslóval történő létrehozásának folyamata. A mappát hálózaton is elhelyezheti, így a csoport minden tagja elérheti a fájlokat az egyéni elemek fejlesztése közben. A varázsló futtatása előtt ellenőrizze a szolgáltatásprofilhoz készült tervezőlapon a mappa tartalmát annak biztosítása érdekében, hogy a fájlok elérhetők legyenek.

Több testreszabott verzió létrehozása

Több szolgáltatásprofil létrehozásakor minden létrehozandó profilnak külön munkalappal kell rendelkeznie. Meglévőhöz hasonló szolgáltatásprofil létrehozható az eredeti többszörözésével vagy az új példány megfelelő szerkesztésével.

Új szolgáltatásprofil létrehozása meglévőből

  1. A Szolgáltatásprofil forrása párbeszédpanelen jelölje be A következő létező szolgáltatásprofil szerkesztése választógombot, majd válassza ki a megfelelő profilt a legördülő listából.
  2. A Szolgáltatás- és fájlnevek párbeszédpanelen adja meg a profil új szolgáltatás- és fájlnevét.
  3. Haladjon tovább a varázslóban, és végezze el a szükséges beállításokat az új profil létrehozásához.

Fontos

  • Ha más szolgáltatás- és fájlnevet ad meg a létrehozandó szolgáltatásprofilnak, az eljárás a meglévő szolgáltatásprofilra nincs hatással. Ha nem ad meg új fájlnevet, a varázsló figyelmezteti, hogy a meglévő szolgáltatásprofilt felül fogja írni. Ha megad egy új fájlnevet, de szolgáltatásnevet nem, azoknak a felhasználóknak, akik a meglévő profilt használták, és telepítik az újat, csatlakozási problémáik lesznek a szolgáltatásprofil használatakor.

Meglévő szolgáltatásprofil frissítése és szerkesztése

Szolgáltatásprofil létrehozásakor a varázsló minden beépített fájlt a profil Cmak mappájába másol (...Cmak\Profiles\szolgáltatásprofil_fájlneve). Meglévő profil szerkesztésekor a varázsló a beépített fájlokat mindig a Cmak mappából olvassa. A beépített fájlok módosítása kétféleképpen lehetséges: szerkessze azt a Cmak mappában, majd a varázsló újraindításával frissítse a szolgáltatásprofilt, vagy indítsa el a varázslót, törölje a kérdéses fájlt, adja hozzá a frissített fájlt, majd fejezze be a varázslót futtatását.

Megjegyzések

  • A Csatlakozáskezelő felügyeleti csomag korábbi verziójával készült meglévő szolgáltatásprofil szerkesztésekor a varázsló azt automatikusan frissíti. Az .inf fájlon kézzel (speciális testreszabási eljárásokkal) végrehajtott módosításokat a program nem őrzi meg a frissített fájlban. A Csatlakozáskezelő felügyeleti csomag varázsló a frissített fájl létrehozása előtt azonban biztonsági másolatot készít a régi .inf fájlról.
  • Ha a Csatlakozáskezelő felügyeleti csomag varázsló segítségével olyan szolgáltatásprofilt szerkeszt, amely egyesített szolgáltatásprofilt tartalmaz, a varázsló megkísérli az egyesített profil legújabb verzióját használni. Ha a varázsló nem találja az egyesített szolgáltatásprofilt a \Program Files\Cmak\Profiles\szolgáltatásprofil_fájlneve mappában, visszatér a szolgáltatásprofil jelenlegi verziójához, amelyet az eredeti profillal együtt tárol.


Szolgáltatásprofil létrehozása a Csatlakozáskezelő felügyeleti csomag varázsló segítségével

Szolgáltatásprofilt három lépésben hozhat létre:

  1. Indítsa el a Csatlakozáskezelő felügyeleti csomag varázslót.
  2. Futtassa a varázslót, és adja meg a szükséges információkat.
  3. A varázsló létrehozza az egyéni szolgáltatásprofilt.

A Csatlakozáskezelő felügyeleti csomag varázsló elindítása

A varázslót csak akkor indítsa el, ha összegyűjtötte a szükséges információkat, és előkészítette az egyéni bitképeket, súgófájlokat, és az előző részekben megadott egyéb elemeket.

A Csatlakozáskezelő felügyeleti csomag varázsló elindítása

  • Mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson a Csatlakozáskezelő felügyeleti csomag parancsra.

A Csatlakozáskezelő felügyeleti csomag varázsló futtatása

A dokumentáció más részei bemutatják a szolgáltatásprofil létrehozásának részleteit abban a sorrendben, ahogyan a párbeszédpanelek a varázsló futtatása közben megjelennek. Az elemek megjelenésének sorrendje a varázsló futtatása során megegyezik azok tervezőlapon található sorrendjével. A varázslóban megadott beállításoktól függően egyes párbeszédpanelek nem jelennek meg, ezek a tervezőlap ki nem jelölt elemei közé tartoznak.

Egyéni elemek (például telefonkönyvek, bitképek, ikonok, stb.) helyének megadásakor írja be a fájl teljes elérési útját vagy tallózással keresse meg azt.

Ha minden információt megadott, és minden beállítást elvégzett az adott párbeszédpanelen, a Tovább gombra kattintással haladhat előre. Az előző párbeszédpaneleken megadott információk módosításához kattintson a Vissza gombra, ahányszor csak szükséges. Végezze el a módosításokat, majd kattintson a Tovább gombra, és haladjon tovább a varázslóban.

Ha többet akar megtudni egy adott párbeszédpanel valamely eleméről, kattintson a Súgó gombra, amelynek hatására a Csatlakozáskezelő felügyeleti csomag kalauz egy, az adott párbeszédpanelre vonatkozó oldala jelenik meg.

A Csatlakozáskezelő felügyeleti csomag varázsló befejezése és a szolgáltatásprofil létrehozása

Ha minden szükséges információt megadott, és készen áll arra, hogy a varázsló létrehozza a szolgáltatásprofilt, kattintson a Befejezés gombra. Miután a varázsló létrehozta a szolgáltatásprofilt, megjelenik egy párbeszédpanel, amelyen láthatja a szolgáltatásprofil mappáját és fájlnevét.

Megjegyzés

  • A műveletet követően speciális testreszabást hajthat végre, például szerkesztheti a .cms és egyéb szolgáltatásprofil-fájlokat. További információt a Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése című témakörben talál. A speciális testreszabás végeztével indítsa újra a Csatlakozáskezelő felügyeleti csomag varázslót.


A testreszabás befejezése a Csatlakozáskezelő felügyeleti csomag varázsló futtatását követően

Miután elkészítette a szolgáltatásprofilt a Csatlakozáskezelő felügyeleti csomag varázsló segítségével, a speciális testreszabási információk között keresse meg a tervezőlapot, melyet a hálózati rendszergazda vagy más technikai vezető bocsát rendelkezésére. Ha a tervezőlap alapján a .cms vagy más szolgáltatásprofil-fájlokban (nem a sablonfájlokban) változtatásokra van szükség, a varázsló futtatása után a megfelelő fájlokban el kell végezni a módosításokat.

Megjegyzés

  • Egy szolgáltatásprofil .cms fájljában végzett módosítások csak az adott szolgáltatásprofilra vonatkoznak. Ha azt szeretné, hogy a módosítás az összes jövőben létrehozandó szolgáltatásprofilra is érvényes legyen, a változtatásokat a sablonfájlban kell elvégeznie. A sablonfájlok szerkesztéséről további információ A Csatlakozáskezelő felügyeleti csomag varázsló futtatásának előkészítése című témakörben található.

A szolgáltatásprofil .cms fájljának szerkesztése

  1. Keresse meg a SzolgáltatásprofilFájlnév.cms fájlt a \Program Files\CMAK\Profiles\SzolgáltatásprofilFájlnév mappában, és készítsen róla biztonsági másolatokat.
  2. Egy szövegszerkesztő program (például a Jegyzettömb) használatával módosítsa a tervezőlapon meghatározott bejegyzéseket a fájlban. A fájl bezárása előtt ne felejtse el menteni a fájlt.
  3. Indítsa újra a Csatlakozáskezelő felügyeleti csomag varázslót, majd a Tovább gombra kattintva jelenítse meg a Szolgáltatásprofil forrása képernyőt.
  4. A Válasszon profilt csoportban jelölje be A következő létező szolgáltatásprofil szerkesztése választógombot, és válassza ki a szerkeszteni kívánt szolgáltatásprofilt.
  5. A további képernyőkön lépjen át változtatás nélkül, majd kattintson a Befejezés gombra a szolgáltatásprofil újraépítéséhez. A .cms fájlban végzett speciális testreszabási beállítások az újraépítés során kerülnek a szolgáltatásprofilba.

A szolgáltatásprofil más fájljainak szerkesztése

A speciális testreszabási beállítások többségét a .cms fájlban kell megadni, de az .inf és .sed fájlok is szerkeszthetők. Ezek a módosítások azonban nem ajánlottak.

Fontos

  • Az .inf fájlok szerkesztésénél legyen nagyon óvatos.

Ezeket a fájlokat is a .cms fájlok esetén fent ismertetett módszerrel szerkessze, ha a szolgáltatásprofilra vonatkozó tervezőlap azt előírja. A fájlok ugyanabban a mappában találhatók, mint a .cms fájlok. A Csatlakozáskezelő felügyeleti csomag újrafuttatása előtt az összes fájlon végezze el a szükséges módosítást, így időt takaríthat meg.


4. fázis: az integráció, a szállítás és a telepítés előkészítése

A Csatlakozáskezelő és a szolgáltatásprofil szállítható és telepíthető önmagában vagy egy, az IEAK varázsló segítségével létrehozott Internet Explorer telepítőcsomag részeként. Az egyéni verzió csomagolása és szállítási módja határozza meg, hogy miként biztosítja azt a felhasználóknak. Ez a rész az ezzel kapcsolatos lehetőségeket és szempontokat ismerteti:

  • A Csatlakozáskezelő integrálása Internet Explorer telepítőcsomagba
  • Parancssori paraméterek használata
  • Kód aláírása


A Csatlakozáskezelő integrálása Internet Explorer telepítőcsomagba

Ha a Csatlakozáskezelő szolgáltatásprofilt beépíti egy, az Internet Explorer Administration Kit (IEAK) csomag segítségével összeállított Internet Explorer telepítőcsomagba, egyszerűsítheti a telepítést a felhasználók számára, mivel a telepítőcsomag mindkét program telepítését elvégzi. A csomag használatával a telepítési folyamat egyetlen egyszerű eljárásból áll.

Az integrálás támogatásához a telepítőcsomag létrehozásakor meg kell határoznia egy integrált forgalmazási módszert, majd szinkronizálnia kell a szolgáltatásprofilt az Internet Explorer .ins fájljával. Azokat az egyéni felhasználói információkat is testre kell szabnia, amelyeket a felhasználók az előfizetést kezelő kiszolgálóhoz történő első csatlakozáskor kapnak.

Az integrált telepítőcsomag létrehozása

Az IEAK támogatja a Csatlakozáskezelő szolgáltatásprofil beépítését az Internet Explorer testreszabása varázsló segítségével létrehozott Internet Explorer telepítőcsomagba. Az Internet Explorer testreszabása varázsló indítása előtt ajánlott a Csatlakozáskezelő szolgáltatásprofilt létrehozni és tesztelni. A folyamat javasolt menete a következő:

A Csatlakozáskezelő szolgáltatásprofil beépítése az Internet Explorer telepítőcsomagba

  1. Hozza létre és tesztelje a Csatlakozáskezelő szolgáltatásprofilt a Csatlakozáskezelő felügyeleti csomag útmutató utasításai szerint.
  2. Indítsa el a Microsoft Internet Explorer testreszabása varázslót, és hozzon létre egy telepítőcsomagot.
  3. A Szolgáltatások kijelölése párbeszédpanelen (a varázsló 1. lépés – Információgyűjtés részében) jelölje be a Csatlakozáskezelő jelölőnégyzetet.
  4. A Csatlakozáskezelő testreszabása párbeszédpanelen (a varázsló 3. lépés – Telepítés testreszabása részében) kattintson az Egyéni profil használata gombra, és tallózással keresse meg szolgáltatásprofilját az Egyéni profil elérési útja mezőben, jelölje ki a profilt, majd kattintson a Tovább gombra.

    Megjegyzés

    • Az Internet Explorer testreszabása varázsló támogatja a Csatlakozáskezelő létrehozását a Csatlakozáskezelő testreszabása párbeszédpanel Csatlakozáskezelő felügyeleti csomag indítása gombja segítségével, de javasolt a szolgáltatásprofilt már a varázsló indítása előtt létrehozni.
  5. Haladjon tovább az Internet Explorer testreszabása varázslóban, és fejezze be az Internet Explorer telepítőcsomag létrehozását (beleértve a Csatlakozáskezelő szolgáltatásprofilt is).

Az Internet Explorer .ins fájljának testreszabása a Csatlakozáskezelő integrálásának támogatásához

Az Internet Explorer .ins fájlja része a telepítőcsomagnak, vagy ami gyakoribb, az előfizetést kezelő kiszolgáló hozza azt létre dinamikusan. Az utóbbi esetben az Internet-szolgáltatónak az .ins fájlok új beállításokkal történő létrehozásához meg kell változtatnia az előfizetést kezelő kiszolgáló kódját az alábbi eljárás szerint.

Az Internet Explorer .ins fájljának testreszabása a Csatlakozáskezelő integrálásának támogatásához

  1. Az Internet Explorer .ins fájljának [Entry] szakaszában ellenőrizze, hogy a szolgáltatás neve megegyezik-e a Csatlakozáskezelő .cms fájljának [Connection Manager] részében megadott névvel.
  2. A .ins fájl [Custom Dialer] részébe írja be az alábbi két elemet, amelyek hatására a Csatlakozáskezelő lesz az Internet Explorer alapértelmezett tárcsázója:

    3. Auto_Dial_DLL=cmdial32.dll

    Auto_Dial_Function=_InetDialHandler@16

  3. Az .ins fájl [Custom] részébe írja be a következő utasításokat:

    Run=icwconn2.exe

    Keep_Connection=yes

    Ezzel egyesíti az .ins fájlt és a Csatlakozáskezelő .cms fájlját.

  4. Az .ins fájl [ClientSetup] részébe írja be az alábbi utasításokat, az elsőt a Csatlakozáskezelőnek a szolgáltatásban betöltött szerepétől függően:

    5. Done_Message=Előfizetési üzenet vége

    Explore_Command=Előfizetési URL/ablak vége

Megjegyzés

  • A 4. lépésben szereplő üzenetek az Icwconn2.exe program futtatásának eredményei. Ha nem adja meg mindkettőt, a felhasználók hibaüzenetet fognak kapni.

A sablonfájlok szerkesztéséről további információt a Speciális testreszabás: Szolgáltatásprofil-fájlok szerkesztése című témakörben talál. Az Internet Explorer .ins fájljának szerkesztéséről további információt az Internet Explorer Administration Kit csomag nyújt.


Parancssori paraméterek használata

A Csatlakozáskezelőt saját telepítőcsomagja segítségével is telepítheti. A /q:a parancssori paraméter hatására a program nem kér megerősítést a felhasználótól a profil telepítésére, de a sikeres telepítést jelző üzenet ekkor is megjelenik.

Megjegyzés

  • Ha a Csatlakozáskezelő szolgáltatásprofilt az Internet Explorer Administration Kit (IEAK) csomag segítségével integrálja egy Internet Explorer telepítőcsomagba, az Internet Explorer testreszabása varázsló beépíti a két telepítőprogram egyesítéséhez szükséges parancssori paramétereket.

Parancssori paraméterek segítségével a Csatlakozáskezelőt telepítőcsomagba integrálhatja, és azt többféleképpen bocsáthatja a felhasználók rendelkezésére. Szükség lehet például a következő műveletek végrehajtására:

  • a Csatlakozáskezelő szolgáltatásprofil elosztása és telepítése Microsoft Systems Management Server (SMS) rendszert használó vállalati hálózaton keresztül automatikusan, felhasználói beavatkozás nélkül
  • a Csatlakozáskezelő szolgáltatásprofil integrálása egy másik termék telepítőcsomagjába, és mindkettő telepítése egyetlen folyamat segítségével, és
  • a Csatlakozáskezelő szolgáltatásprofil elküldése egy adott webhelyre, így engedélyezve a hozzáférést a felhasználóknak a szolgáltatásprofil szabványos telepítéséhez (bizonyos telepítési beállítások megadása a felhasználó számára).

Ezek a terjesztési és telepítési beállítások elvégezhetők a programból a szolgáltatásprofil Csatlakozáskezelő felügyeleti csomag varázslóval történő létrehozása után. A Csatlakozáskezelő telepítője (Cmstp.exe) támogatja a parancssori paramétereket, amelyek segítségével az alábbi műveletek hajthatók végre:

  • szolgáltatásprofil telepítése
  • szolgáltatásprofil eltávolítása, valamint
  • a Csatlakozáskezelő szoftver eltávolítása.

A Cmstp.exe parancssori formátuma a következő:

szolgáltatásprofil_fájlneve.exe /q:a /c:"cmstp.exe szolgáltatásprofil_fájlneve.inf paraméterek",

ahol:

  • szolgáltatásprofil_fájlneve a Csatlakozáskezelő felügyeleti csomag varázsló segítségével létrehozott szolgáltatásprofil neve
  • a /q:a választható paraméter letiltja azt az üzenetpanelt, amely megerősítést kér a felhasználótól a profil telepítésére
  • a /c:cmstp.exe parancs hatására a kicsomagoló program felülírja az alapértelmezett telepítési értékeket
  • szolgáltatásprofil_fájlneve.inf a fájl teljes elérési útja,
  • paraméterek pedig a Cmstp.exe telepítője által támogatott parancssori paraméterek.
  • A telepítés támogatott paraméterei a következők:
    • /ni – Ne hozzon létre ikont az Asztalon (csak Windows 95, Windows 98 és Windows NT 4.0 operációs rendszerek esetében érvényes). Az Asztalon lévő ikon a Csatlakozáskezelő által nyújtott egyetlen lehetőség profilok törlésére. E parancssori paraméter használata esetén biztosítania kell a felhasználóknak egy másik módszert a szolgáltatásprofilok törlésére, például a Programok telepítése/törlése programot vagy egy olyan parancsfájlt, amely ugyanazt teszi lehetővé, mint az előző program. Az /u paraméter segítségével információt kaphat arról, hogy miként törölhet szolgáltatásprofilt program segítségével.
    • /ns – Ne hozzon létre Asztalon lévő parancsikont a kapcsolathoz a Hálózati és telefonos kapcsolatok mappában (csak Windows 2000 rendszer esetén érvényes). A csendes telepítés kapcsoló egyidejű megadása nélkül ez a kapcsoló csak az alapértelmezett felhasználói beállításokat írja felül, a felhasználói felületen továbbra is megjelenik a jelölőnégyzet. Profil első alkalommal történő telepítésekor alapértelmezés szerint nem jön létre ikon az Asztalon. A felhasználó beállításait a rendszerleíró adatbázis tárolja, és azok minden későbbi telepítés során felhasználhatók.
    • /nf – Ne telepítse a támogató fájlokat. A Csatlakozáskezelő felügyeleti csomag (CMAK) minden szolgáltatásprofilhoz automatikusan telepíti a szükséges támogató fájlokat (.dll fájlok) abban az esetben, ha a szolgáltatásprofil tartalmazza a Csatlakozáskezelő szoftvert. Ha a Csatlakozáskezelő szolgáltatásprofilt nem az Internet Explorer telepítőcsomaggal együtt terjeszti, a beállítás segítségével megakadályozhatja a támogató fájlok telepítését. Ezt a lehetőséget csak akkor használja, ha biztos abban, hogy a szükséges támogató fájlok a felhasználók számítógépén már megtalálhatók (vagyis ha rendelkeznek Windows 98 rendszerrel, illetve az Internet Explorer 3.02-s vagy annak újabb verziójával).
    • /s – Csendes telepítés. A kapcsoló hatására a szolgáltatásprofil telepítése automatikusan, felhasználói beavatkozás nélkül megy végbe.
    • /I – Az /nf és /s paraméterek kombinációja, hatására az IEAK a Csatlakozáskezelő profilt Internet Explorer telepítőcsomag részeként telepíti.
    • /su – Egyfelhasználós telepítés (csak Windows 2000 rendszer esetében érvényes). Ez a beállítás az egyfelhasználós telepítés automatikus kijelölését engedélyezi. A beállítás használata esetén a felhasználó nem telepítheti a szoftvert minden felhasználó általi használatra.
  • Az eltávolítás lehetséges paraméterei a következők:
    • /x – A Csatlakozáskezelő eltávolítása. E paraméter megadása esetén további paraméter nem adható meg.
    • /u – Szolgáltatásprofil eltávolítása. Ezzel a paraméterrel csak az /s paraméter használható: hatására a program a szolgáltatásprofilt automatikusan, felhasználói beavatkozás nélkül távolítja el. Az /u és az /s paraméterek együttes megadása esetén a formátum a következő:

      szolgáltatásprofil_fájlneve.exe /q:a /c:"cmstp.exe szolgáltatásprofil_fájlneve.inf /u /s".

      Ne feledje, hogy a szolgáltatásprofil_fájlneve a fájl teljes elérési útját tartalmazza.

Megjegyzés

  • A parancssori telepítési paraméterek súgójának megjelenítéséhez írja be a cmstp.exe /? parancsot.

A Cmstp.exe fájl paraméter nélküli használata esetén az alábbi alapértelmezett beállítások érvényesek:

  • Windows 95, Windows 98 vagy Windows NT 4.0 rendszert használó számítógépeken a program a profilban lévő támogató fájlokat a profillal együtt automatikusan telepíti, és létrehoz egy ikont az Asztalon. A profil telepítés után elindul.
  • A Windows 2000 rendszert rendszergazdaként futtató számítógépeken a program a profilban található támogató fájlokat és a Csatlakozáskezelő szoftvert automatikusan nem telepíti, a szoftvert telepítés után viszont minden felhasználó használhatja.
  • A Windows 2000 rendszert nem rendszergazdaként futtató számítógépeken egyfelhasználós, nem csendes telepítés megy végbe, a program a profilban lévő támogató fájlokat és a Csatlakozáskezelő szoftvert a profillal együtt automatikusan nem telepíti.


Kód aláírása

A testreszabás befejeztével ajánlatos a kód aláírása annak forgalmazása előtt. A kód aláírására használt digitális aláírás segítségével a felhasználók biztosak lehetnek abban, hogy a program ismert forrásból származik, és azt nem módosították.

Ha testreszabott szolgáltatásprofilját és az egyénileg beépített programokat digitális aláírással látja el, a felhasználók nem kapnak figyelmeztetéseket a Csatlakozáskezelő telepítése során. Ezzel egyben megakadályozhatja, hogy a felhasználók aláíratlan ActiveX vezérlőket és Java csomagokat telepítsenek.

A kódok aláírásával kapcsolatban további információt az Internet Explorer Administration Kit (IEAK) csomagban talál. Ha egy Csatlakozáskezelő szolgáltatásprofilt olyan Internet Explorer telepítőcsomagba épít be, amely az IEAK csomagban (az Internet Explorer Csatlakozás varázsló segítségével) lett létrehozva, és a varázslóban megadja a digitális aláírás beállítását, a telepítőcsomag digitálisaláírás-támogatása tartalmazni fogja a Csatlakozáskezelő szolgáltatásprofilt.

Ha a kód aláírásáról további információra van szüksége, látogassa meg a magyar vagy az angol Microsoft Developer Network (MSDN) (http://msdn.microsoft.com/developer/default.htm) webhelyet, kattintson az MSDN lap Search szövegmezőjébe, írja be a digital signature vagy a code signing kifejezéseket, majd kattintson a Search gombra. Így az egész Microsoft helyre kiterjedő keresést futtathat.


5. fázis: A szolgáltatásprofil összetevőinek tesztelése

A Csatlakozáskezelő felügyeleti csomag varázsló segítségével létrehozott szolgáltatásprofilt terjesztés előtt tesztelni kell. Ebben a részben megismerheti, hogyan telepíthetők és tesztelhetők a szolgáltatásprofilok. Arról is tájékoztat, hogy milyen tényezőket kell figyelembe venni, ha a szolgáltatásprofilok telepítésére saját telepítőprogramot kíván biztosítani a felhasználók számára.

Ez a rész egy tesztelési folyamatot mutat be, beleértve a fájlok tesztelésénél alkalmazandó szempontokat.


A tesztelés lépései

A szolgáltatásprofil tesztelésével győződhet meg arról, hogy minden szükséges művelet elkészült és a vártnak megfelelően működik. A kitöltött tervezőlap segítséget nyújt a szolgáltatásprofilban lévő szolgáltatások és funkciók ellenőrzésében.

A szükséges szolgáltatásprofilokat egyenként telepítse azokra az operációs rendszerekre, melyeken használni kívánja őket. Ha a szolgáltatásprofilt lemezen vagy elektronikus levélben terjeszti, tesztelje a módszer működését. Ha különböző nyelvű verziókat készít, tesztelje azokat egyenként a megfelelő nyelvvel konfigurált operációs rendszeren.

Megjegyzés

  • Ha egyes felhasználók a szolgáltatásprofil korábbi verziójával rendelkeznek, tesztelje a Csatlakozáskezelőt mind az előző verziójú szolgáltatásprofillal rendelkező számítógépeken, mind azokon, melyekre újonnan telepíti a profilt.

A tesztelés az alábbi alaplépésekből áll:

A szolgáltatásprofil tesztelése

Minden egyes szolgáltatásprofil és forgatókönyv esetén végezze el az alábbiakat a Csatlakozáskezelő használatával:

  1. Telepítse a szolgáltatásprofilt a felhasználók számára készített Fontos fájl és más leírások alapján.
  2. Adja meg a kért felhasználói adatokat (felhasználónév, a felhasználó jelszava stb.), melyek a csatlakozáshoz szükségesek.
  3. A telefonkönyvből válasszon egy kapcsolódási pontot (POP) és hozza létre a kapcsolatot.
  4. A szolgáltatáshoz való csatlakozás után tekintse meg a hálózati erőforrásokat (ellenőrizze a Hálózati és telefonos kapcsolatokat az URL megtekintése közben).
  5. Szakítsa meg a kapcsolatot a szolgáltatással.
  6. Távolítsa el a szolgáltatásprofilt.

Tesztelési szempontok

A Csatlakozáskezelő telepítése után győződjön meg arról, hogy minden szolgáltatásprofil a kívánt megjelenéssel, szolgáltatásokkal és funkciókkal rendelkezik.

  • A képernyők a megfelelő címeket, feliratokat és grafikákat tartalmazzák, illetve minden képernyő teljesen és hibátlanul jelenik meg?
  • A szolgáltatásprofil minden szükséges programot tartalmaz? Ha nem, akkor a célként kijelölt operációs rendszeren minden szükséges program elérhető?
  • Az állapotjelző terület ikonjának minden menüeleme megfelelően működik?
  • Minden funkcióhoz és szolgáltatáshoz rendelkezik a megfelelő súgóval (beleértve a hibaelhárításra vonatkozó súgót is)? A súgófájlok megfelelnek a szolgáltatásprofilnak? A testreszabott súgótémakörök megjelenése megfelelő?
  • A szövegek (beleértve a licencszerződést, a képernyőszövegeket, a Csatlakozáskezelő párbeszédpanelen lévő szövegeket és más információkat) formázása és helyesírása megfelelő?
  • Minden információ elérhető a megfelelő időben, ami a Csatlakozáskezelő és a szolgáltatásprofil telepítéséhez és használatához szükséges?
  • A hálózati és telefonos kapcsolatok egyéni bejegyzései (elsősorban a parancsfájlok) megfelelően működnek?
  • A közvetlen és a virtuális magánhálózati kapcsolatok támogatása esetén bármelyik típusú kapcsolat létrehozása lehetséges?
  • A létrehozott csatlakozás előtti, protokollbújtatás előtti, csatlakozás utáni, tárcsázás előtti, hibaüzenet esetén végrehajtandó, megszakítás esetén végrehajtandó és kapcsolatbontási műveletek, valamint az automatikusan futó alkalmazások megfelelően működnek?
  • A szerkesztett .cms és más szolgáltatásprofil-fájlok egyéni bejegyzései megfelelően működnek?
  • Kódaláírás használata esetén a vártnak megfelelően megjelenik a hitelesítési üzenet?
  • Lehetséges úgy csatlakozni a támogatott szolgáltatástípusokhoz, hogy a telefonkönyvben POP-okat használ?
  • Tűzfal használata esetén megfelelőek a tűzfalproxy beállításai?
  • A Csatlakozási pont szolgáltatás a Csatlakozási pont szolgáltatás dokumentációjában leírtaknak megfelelően működik?


6. fázis: Az ügyfelek támogatása

Az ügyfelek hatékony támogatásához az ügyfelek kérdéseinek és problémáinak gyors és hatékony megválaszolására, illetve megoldására van szükség. Ebben a részben olyan tudnivalókat olvashat, melyek segítenek az általános problémák megoldásában.

  • A testreszabott beállítások ellenőrzése
  • A hibaelhárítás lépései


A testreszabott beállítások ellenőrzése

A testreszabott beállításokkal szemben támasztott követelmények sok esetben nagyon szigorúak. Ez a rész azokat az információkat tekinti át, melyek a leggyakoribb problémákat okozzák.

A szolgáltatásnév és a fájlnév érvényességének ellenőrzése

Egy szolgáltatásprofil frissítésekor a szolgáltatás- és fájlneveknek nem szabad változniuk. Ha új profilt hoz létre (elölről kezdve, vagy egy létező szolgáltatásprofil szerkesztésével és átnevezésével), győződjön meg róla, hogy a szolgáltatás- és fájlnevek nem azonosak egyik szolgáltatásprofiléval sem, melyet a felhasználók számára biztosít. Ha ugyanazt a fájlnevet adja meg, ami a felhasználók számítógépén már megtalálható, az új szolgáltatásprofil felülírja az eredetit. Ha megad egy új fájlnevet, de szolgáltatásnevet nem, akkor azoknak a felhasználóknak, akik a meglévő profilt használták és más szolgáltatásnévvel telepítik az újat, csatlakozási problémáik lesznek a szolgáltatásprofil használatakor. Ilyenkor lehetséges, hogy a felhasználó nem képes csatlakozni egyik szolgáltatásprofil használatával sem.

Ha módosítania kell egy meglévő profilt, ne hozzon létre új fájlt ugyanazon a néven, hanem szerkessze a profilt a Csatlakozáskezelő felügyeleti csomag varázsló használatával.

Annak ellenőrzése, hogy a tartomány megfelelő útválasztást és hitelesítést használ

A Microsoft Commercial Internet System (MCIS) használatakor ne felejtse el, hogy a Microsoft Membership System összetevő nem fogad el minden karaktert a kulcsfontosságú rendszerparaméterekben (beleértve a tartományt is), viszont a tartományok számára elválasztójelet igényel. Ha a Csatlakozáskezelő csatlakozási műveletei között ilyen szolgáltatásokat is kíván használni, olvassa el a Membership System dokumentációját és ellenőrizze, hogy mely karakterek használhatók. A Membership Systemhez való csatlakozáskor a zárókarakter a tartományok előtagjához, a kezdőkarakter pedig a tartományok utótagjához kerül leválasztásra. Ellenőrizze, hogy az útválasztást kezelő Internet-szolgáltató megfelelően állította be az útválasztási információkat.

A Hálózati és telefonos kapcsolatok bejegyzésének ellenőrzése a Csatlakozáskezelő felügyeleti csomagban és a telefonkönyvben

A Hálózati és telefonos kapcsolatok telefonkönyvben megadott bejegyzésének egyeznie kell a szolgáltatásprofilban megadott bejegyzéssel. Egy szövegszerkesztő program (például a Jegyzettömb) használatával nyissa meg a Telefonkönyv-felügyelő fájlját és ellenőrizze, hogy a Hálózati és telefonos kapcsolatok összes bejegyzése (az egyes sorok végén) egyezik a Csatlakozáskezelő felügyeleti csomag varázslóban megadott bejegyzésekkel.

A szükséges protokollok helyességének ellenőrzése

Ellenőrizze, hogy a szükséges hálózati protokollok (például TCP/IP, IPX és NetBEUI) be vannak állítva a Hálózati és telefonos kapcsolatok kijelölt bejegyzéséhez tartozó .cms fájl [Server&BejegyzésNév] részében.

A proxybeállítások helyességének ellenőrzése

Ha a szolgáltatás használatához egyedi proxybeállításokat kell megadni, ellenőrizze, hogy a megfelelő csatlakozási műveletek megtervezése és megvalósítása úgy történt-e, hogy szükség szerint módosítsák a beállításokat a felhasználó számítógépén.

Annak ellenőrzése, hogy a rezidens programok megnyithatók-e a felhasználó számítógépén

Ha egy csatlakozási művelet vagy más egyéni beállítás működéséhez egy programnak elérhetőnek kell lennie a felhasználó számítógépén (tehát a szolgáltatásprofil azt nem tartalmazza), ellenőrizze, hogy a program az alapértelmezett helyen található-e, és a Csatlakozáskezelő képes-e a használatára. Előfordulhat, hogy a Start menü egyes programjai nem az alapértelmezett elérési utat használják. Ilyen esetben a Csatlakozáskezelő nem mindig találja meg a programot.

A szolgáltatásprofil frissítésének ellenőrzése

Amikor egy olyan szolgáltatásprofil módosítását végzi, amelyet a Csatlakozáskezelő egyik előző verziójával készítettek, a Csatlakozáskezelő felügyeleti csomag varázsló automatikusan a Csatlakozáskezelő 1.2-es verziójára frissíti azt. Az .inf fájlon kézzel (speciális testreszabási eljárásokkal) végrehajtott módosításokat a program nem őrzi meg a frissített fájlban. Mindazonáltal a Csatlakozáskezelő felügyeleti csomag varázsló a régi .inf fájlról biztonsági másolatot készít, mielőtt a frissített fájlt létrehozná.

Az időtúllépési beállítás ellenőrzése

Virtuális magánhálózati kapcsolatok esetén a felhasználók néha olyan üzenetet kapnak, hogy a tartományvezérlő nem található, noha az útválasztási beállítások helyesek. A .cms fájl LanaTimeout bejegyzésének módosításával megoldhatja a problémát. Ez a VPN-kiszolgálóhoz való csatlakozási kísérlet előtti várakozási időt növeli (másodpercben). Ha a kapcsolat rendszeresen nem talál tartományvezérlőt, növelje ezt az értéket.


A hibaelhárítás lépései

A hibaelhárítás első szintje a szolgáltatásprofilhoz mellékelt súgóban található. Ez lehetővé teszi, hogy sok problémát a felhasználó egyedül is megoldhasson. A nem megoldható problémák a súgó egyik olyan témaköréhez vezetnek, melyek felszólítják a felhasználót az ügyfélszolgálat felhívására. Ezt a témakört érdemes úgy átalakítani, hogy tartalmazza az ügyfélszolgálat telefonszámát.

A problémák hatékony megoldásához kövesse az alábbi módszert:

  1. Győződjön meg arról, hogy rendszerkövetelmények minden feltétele adott.
  2. Győződjön meg arról, hogy a felhasználó a megfelelő hívószámokat használja és azok bevitele pontos. (Ellenőrizze, hogy a felhasználók tisztában vannak-e azzal, hogy a tárcsázási tulajdonságok csak a telefonkönyvből kiválasztott telefonszámokra érvényesek. Ha a hívószámot a felhasználó írja be vagy szerkeszti, minden tárcsázási információt meg kell adnia, beleértve a távolsági hívás kezdeményezéséhez és a külső vonal eléréséhez szükséges számokat is.)
  3. Győződjön meg róla, hogy a felhasználók ismerik a Csatlakozáskezelő hibaelhárítási súgójának elérési módját, és ellenőrizze, milyen útvonalon jutottak el ahhoz.
  4. A megfelelő Fontos fájl (beleértve a CMAKfontos.htm fájlt) vizsgálatával ellenőrizze, hogy a probléma egy ismert jelenség-e.
  5. Általános hibákat keressen. Győződjön meg az alábbiakról:
    • A modem bekapcsolt állapotban van.
    • A Tárcsázási tulajdonságok lapon egyetlen hívókártyaszám sem hosszabb 36 karakternél. Ez gyakran okozza az Általános védelmi hiba üzenetet. (A Tárcsázási tulajdonságok lap megjelenítéséhez kattintson a Tulajdonságok párbeszédpanel Általános fülére, majd a Tárcsázási szabályok gombra.)
    • A Csatlakozáskezelő megfelelő verziója van telepítve.
    • A Hálózati és telefonos kapcsolatok alkalmazás legújabb verziója van telepítve.
    • Telepítve van a legfrissebb szervizcsomag.
    • Megfelelőek a proxybeállítások.
    • A felhasználó számítógépén megfelelően vannak telepítve és konfigurálva a szükséges hálózati protokollok (TCP/IP, IPX és NetBEUI, igény szerint). (Ha a felhasználó képes feljutni a hálózatra, de egy szolgáltatást sem tud elérni, valószínűleg sérült az egyik protokoll.)
    • Ha a szolgáltatásprofil támogatja a virtuális magánhálózati kapcsolatokat, ellenőrizze, hogy a Point to Point Tunneling protokoll (PPTP) telepítése és konfigurálása teljes és hibátlan. (Ez a probléma elsősorban Windows NT 4.0 rendszeren fordul elő, ahol a Csatlakozáskezelő nem telepíti automatikusan a PPTP protokollt.)
    • A Hálózati és telefonos kapcsolatok szükséges bejegyzése rendelkezésre áll a felhasználó számítógépén.
    • Ha egy felhasználó telepítette a távelérési szolgáltatást, újratelepítette a felhasználó a rendszerén már előzőleg is megtalálható szervizcsomagot? (Erre a távelérés telepítése után van szükség.)
  6. A felhasználók minden megfelelő megoldást kézhez kaptak? Ha további információkra van szüksége a táveléréssel és a hálózati és telefonos kapcsolatok alkalmazással kapcsolatos problémákról, olvassa el a Tudásbázis (Knowledge Base) cikkeit a magyar vagy az angol Microsoft Developer Network (MSDN) (http://msdn.microsoft.com/developer/default.htm) webhelyen. (http://msdn.microsoft.com/developer/default.htm)

A hibaelhárításhoz további hasznos információkat és eszközöket találhat a Microsoft Press által kiadott, Windows 2000 Resource Kit és Internet Explorer 5 Resource Kit című kiadványokban. További információ a Windows 2000 Resource Kit című témakörben található.