Attrib

Egyetlen fájl vagy könyvtár attribútumait módosítja. A parancs beállítja vagy eltávolítja a fájlokhoz vagy könyvtárakhoz rendelt írásvédett, rendszer, rejtett és tömörített attribútumot.

Az attrib parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. Az attrib parancs más paraméterekkel a Windows 2000 parancssorából használható.

attrib [+r|-r] [+s|-s] [+h|-h] [+c|-c] [[meghajtó:][elérési út] fájlnév]

Paraméterek

+r

Beállítja az írásvédett attribútumot.

-r

Törli az írásvédett attribútumot.

+s

Beállítja a rendszer attribútumot.

-s

Törli a rendszer attribútumot.

+h

Beállítja a rejtett attribútumot.

-h

Törli a rejtett attribútumot.

+c

Beállítja a tömörített attribútumot.

-c

Törli a tömörített attribútumot.

[[meghajtó:][elérési út] fájlnév]

Megadja a módosítandó fájl vagy könyvtár helyét és nevét. Egyszerre csak egyetlen fájl vagy könyvtár attribútumai módosíthatók.

Megjegyzés

  • Egy paranccsal egy fájl vagy könyvtár több attribútuma is módosítható egyszerre.

Kapcsolódó témakörök


Batch

Szövegfájlban megadott parancsokat hajt végre. A batch parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

batch bemeneti_fájl [kimeneti_fájl]

Paraméterek

bemeneti_fájl

Azt a szövegfájlt határozza meg, amely a végrehajtandó parancsokat tartalmazza. A bemeneti_fájl egy meghajtóbetűjel és egy kettőspont, egy mappanév, egy fájlnév vagy ezek kombinációja lehet.

kimeneti_fájl

Ha meg van adva, a parancsok kimenetét a megnevezett fájlban tárolja. Ha nincs megadva, a kimenet a képernyőn jelenik meg.

Példa

A következő példa végrehajtja a C:\Feladatok\Keresés.txt kötegelt fájlt, és a kimenetet a C:\Feladatok\Eredmény.txt fájlba írja:

batch c:\Feladatok\Keresés.txt c:\Feladatok\Eredmény.txt


Chdir (Cd)

Megjeleníti az aktuális mappa nevét, vagy megváltoztatja az aktuális mappát.

A chdir és a cd parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A chdir parancs más paraméterekkel a Windows 2000 parancssorából használható.

chdir [meghajtó:][elérési út] [..]

-vagy-

cd [meghajtó:][elérési út] [..]

Paraméterek

nincs

Paraméterek nélkül használva a chdir parancs az aktuális meghajtó és mappa nevét jeleníti meg. Meghajtóbetűjellel együtt beírva (például cd C:) a chdir parancs a megadott meghajtó aktuális könyvtárát jeleníti meg.

[meghajtó:][elérési út]

Azt a meghajtót (ha különbözik az aktuális meghajtótól) és könyvtárat adja meg, amelyre át kíván váltani.

[..]

Azt jelzi, hogy a szülőmappára kíván átváltani. A chdir parancs és a két pont közé szóközt kell tenni.

Megjegyzések

  • A Chdir parancs a szóközöket határolóként kezeli. A szóközt tartalmazó könyvtárneveket idézőjelek közé kell tenni. Például:

    cd "meghajtó gyorsítótár"

  • A Chdir parancs csak a jelenlegi Windows telepítés rendszerkönyvtáraiban, a cserélhető adathordozókon, bármely lemezpartíció gyökérkönyvtárában és a helyi telepítési forrásokban működik.


Chkdsk

Állapotjelentést készít a lemezről, és azt megjeleníti. A Chkdsk ezenkívül felsorolja és kijavítja a lemezen található hibákat.

A chkdsk parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A chkdsk parancs más paraméterekkel a Windows 2000 parancssorából használható.

chkdsk [meghajtó:] [/p] [/r]

Paraméterek

nincs

Paraméterek használata nélkül a chkdsk parancs az aktuális meghajtóban található lemez állapotát jeleníti meg.

meghajtó:

Meghatározza azt a meghajtót, amelyet a chkdsk programmal ellenőriztetni szeretne.

/p

A meghajtó alapos ellenőrzését végzi el még akkor is, ha nincs megjelölve, hogy a chkdsk programot futtatni kell. A paraméter hatására nem történik semmilyen módosítás a meghajtón.

/r

Megkeresi a hibás szektorokat, és helyreállítja az olvasható adatokat. Magába foglalja a /p paramétert.

Megjegyzés

  • A Chkdsk parancsnak szüksége van az Autochk.exe fájlra. Ha ez a fájl nem található az indítási könyvtárban (alapértelmezés szerint \Winnt\System32), a program megpróbálja azt megkeresni a Windows 2000 telepítő CD-jén. Ha a számítógépen több operációs rendszer található, figyeljen arra, hogy a parancsot a Windows 2000 rendszert tartalmazó meghajtón adja ki.


Cls

Törli a képernyőt.

A törölt képernyőn csak a parancssor és a kurzor látható.

cls

Paraméterek

nincs


Copy

Átmásol egy fájlt egy másik helyre. A copy parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A copy parancs más paraméterekkel a Windows 2000 parancssorából használható.

copy forrás [cél]

Paraméterek

forrás

Megadja a másolni kívánt fájl helyét és nevét. A forrás egy meghajtóbetűjel és egy kettőspont, egy könyvtárnév, egy fájlnév vagy ezek kombinációja lehet.

cél

Annak a fájlnak vagy fájlkészletnek a helyét és nevét határozza meg, amelybe másolni kíván. A cél egy meghajtóbetűjel és egy kettőspont, egy mappanév, egy fájlnév vagy ezek kombinációja lehet.

Megjegyzések

  • A forrás lehet cserélhető adathordozó, a jelenlegi Windows telepítés rendszerkönyvtárainak bármely alkönyvtára, bármely meghajtó gyökérkönyvtára, a helyi telepítési források vagy a Cmdcons könyvtár.
  • A cél bármi lehet, csakúgy mint a forrás, kivéve a cserélhető adathordozót. Ha a cél nincs megadva, az aktuális könyvtár az alapértelmezett könyvtár.
  • A másolás során a Windows telepítő CD-n található tömörített fájlok ki lesznek tömörítve.
  • A Copy parancs nem támogatja a helyettesítő karakterek használatát.


Delete (Del)

Töröl egyetlen fájlt. A delete és a del parancsok az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhetők el, amely a Windows 2000 telepítőprogramjából indítható. A delete és a del parancsok más paraméterekkel a Windows 2000 parancssorából használhatók.

delete [meghajtó:][elérési út] fájlnév

-vagy-

del [meghajtó:][elérési út] fájlnév

Paraméterek

[meghajtó:][elérési út] fájlnév

Megadja a törölni kívánt fájl helyét és nevét.

Megjegyzés

  • A delete parancs csak a jelenlegi Windows telepítés rendszerkönyvtáraiban, a cserélhető adathordozókon, bármely lemezpartíció gyökérkönyvtárában és a helyi telepítési forrásokban működik.


Dir

Megjeleníti a könyvtárban levő fájlok és alkönyvtárak listáját. A dir parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A dir parancs más paraméterekkel a Windows 2000 parancssorából használható.

dir [meghajtó:][elérési út][fájlnév]

Paraméterek

[meghajtó:][elérési út]

Megadja azt a meghajtót és könyvtárat, amelynek a tartalmát listázni szeretné.

[fájlnév]

Megadja azt a fájlt vagy fájlcsoportot, amelyet listázni szeretne. Több fájlnév is megadható. A fájlnevek szóközzel, vesszővel vagy pontosvesszővel választhatók el. A fájlnévben helyettesítő karakterek (? és *) is használhatók fájlok egy csoportjának megjelenítéséhez.

A dir parancs ezenkívül megjeleníti a lemez kötetcímkéjét és sorozatszámát, a kilistázott fájlok számát és összesített méretét, valamint a lemezen rendelkezésre álló szabad terület méretét (bájtban). A dir parancs minden fájl és alkönyvtár esetén megjeleníti a fájl nevét és kiterjesztését, a fájl méretét bájtban, a fájl utolsó módosításának dátumát és időpontját, valamint az alábbi attribútumokat, ha vannak ilyenek:

Rövidítés | Attribútum
d | Könyvtár
h | Rejtett fájl
s | Rendszerfájl
e | Titkosított
r | Írásvédett
a | Archiválandó fájl
c | Tömörített
p | Újraelemzési pont

Megjegyzés

  • A dir parancs csak a jelenlegi Windows telepítés rendszerkönyvtáraiban, a cserélhető adathordozókon, bármely lemezpartíció gyökérkönyvtárában és a helyi telepítési forrásokban működik.


Disable

Letilt egy Windows 2000 vagy Windows NT 4.0 rendszerszolgáltatást vagy eszközillesztőt. A disable parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

disable [szolgáltatás_neve] | [eszközillesztő_neve]

Paraméterek

szolgáltatás_neve

A letiltani kívánt rendszerszolgáltatás neve.

eszközillesztő_neve

A letiltani kívánt eszközillesztő neve.

Példa

A következő példa letiltja az Eventlog szolgáltatást:

disable eventlog

Megjegyzések

  • A disable parancs a megadott szolgáltatás vagy illesztőprogram indítási típusát SERVICE_DISABLED értékre állítja.
  • Ha a disable parancsot használja egy rendszerszolgáltatás vagy eszközillesztő letiltásához, a rendszerszolgáltatás vagy az eszközillesztő előző indítási típusa megjelenik a képernyőn. Jegyezze fel ezt az értéket, ha később az enable parancs segítségével vissza szeretné állítani az indítási típus régi értékét.
  • Ötféle indítási típus létezik: Az első három (SERVICE_AUTO_START, SERVICE_DISABLED és SERVICE_DEMAND_START) megfelel az Automatikus, Tiltott és Kézi indítási beállításoknak, amelyek beállítása általában a Számítógép-kezelés felügyeleti eszköz Szolgáltatások panelén történik meg. A másik kettő (SERVICE_BOOT_START és SERVICE_SYSTEM_START) általában az eszközillesztők betöltési módjának meghatározásához használatos; például hogy azok a számítógép vagy a Windows 2000 indulásakor töltődjenek be.


Diskpart

Partíciókat hoz létre és töröl a merevlemezen. A diskpart parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

diskpart [/add | /delete] [eszköz_neve | meghajtó_neve | partíció_neve] [méret]

Paraméterek

nincs

Paraméter megadása nélkül a diskpart parancs a Windows 2000 diskpart program karakteres módú verzióját indítja el.

/add

Új partíciót hoz létre.

/delete

Töröl egy létező partíciót.

eszköz_neve

Annak az eszköznek a neve, amelyen partíciót kíván létrehozni vagy törölni. A nevet a map parancs kimenetéből lehet megtudni. Példa eszköznévre:

\Device\HardDisk0

meghajtó_neve

A törölni kívánt partíció neve, meghajtóbetűjellel megadva. Csak a /delete kapcsolóval használható. Példa meghajtónévre:

D:

partíció_neve

A törölni kívánt partíció, a partíció nevével megadva. A meghajtó_neve paraméter helyett használható. Csak a /delete kapcsolóval használható. Példa partíciónévre:

\Device\HardDisk0\Partition1

méret

A létrehozni kívánt partíció mérete megabájtban (MB). Csak az /add kapcsolóval használható.

Példák

A következő példák egy partíciót törölnek:

diskpart /delete \Device\HardDisk0\Partition3

diskpart /delete F:

A következő példa egy 20 MB-os partíciót hoz létre a merevlemezen:

diskpart /add \Device\HardDisk0 20


Enable

Engedélyez egy Windows 2000 vagy Windows NT 4.0 rendszerszolgáltatást vagy eszközillesztőt. Az enable parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

enable {szolgáltatás_neve | eszközillesztő_neve} [indítási_típus]

Paraméterek

szolgáltatás_neve

Az engedélyezni kívánt rendszerszolgáltatás neve.

eszközillesztő_neve

Az engedélyezni kívánt eszközillesztő neve.

indítási_típus

A szolgáltatáshoz vagy eszközillesztőhöz hozzárendelni kívánt indítási típus.

Példa

A következő példa az Eventlog szolgáltatás indítási típusát Automatikus vagy SERVICE_AUTO_START értékre állítja:

enable eventlog service_auto_start

Megjegyzések

  • Ha nem ad meg indítási típust, az enable parancs megjeleníti a szolgáltatás_neve paraméterben megadott szolgáltatás vagy eszközmeghajtó jelenlegi indítási típusát.
  • Ötféle indítási típus létezik. Az első három (SERVICE_AUTO_START, SERVICE_DISABLED és SERVICE_DEMAND_START) megfelel az Automatikus, Tiltott és Kézi indítási beállításoknak, amelyek beállítása általában a Számítógép-kezelés felügyeleti eszköz Szolgáltatások panelén történik meg. A másik kettő (SERVICE_BOOT_START és SERVICE_SYSTEM_START) általában az eszközillesztők betöltési módjának meghatározásához használatos; például hogy azok a számítógép vagy a Windows 2000 indulásakor töltődjenek be.
  • Ha az enable parancsot használja az indítási típus módosításához, az előző indítási típus neve megjelenik a képernyőn. Jegyezze fel ezt az értéket, ha később vissza szeretné állítani az indítási típus régi értékét.


Exit

Bezárja a Windows 2000 Helyreállító konzolt, és újraindítja a számítógépet. Az exit parancs csak a Windows 2000 Helyreállító konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

exit

Paraméterek

nincs


Expand

Kibont egy fájlt egy tömörített fájlból. Ez a parancs használható egy illesztőprogram kibontásához a Windows 2000 CD-n található kabinetfájlból (.cab) vagy tömörített fájlból.

Az expand parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. Az expand parancs más paraméterekkel a Windows 2000 parancssorából használható.

expand [/d] [/y] forrás | forrás.cab [/F:fájl] [cél]

Paraméterek

/d

Kilistázza a kabinetfájlban található fájlokat, azok kibontása nélkül.

/y

Kikapcsolja a felülírásra figyelmeztető üzenetet a fájlok kibontása esetén.

forrás

Kijelöli a kibontani kívánt fájlt. Akkor használja, ha a forrásfájl csak egyetlen fájlt tartalmaz. A forrás egy meghajtóbetűjel és egy kettőspont, egy könyvtárnév, egy fájlnév vagy ezek kombinációja lehet. Helyettesítő karakterek nem használhatók.

forrás.cab /f:fájl

Megadja azt a kabinetfájlt, amelyből a fájlokat ki szeretné bontani, valamint a kibontani kívánt fájl vagy fájlok nevét. Akkor használja, ha a forrásfájl több fájlt tartalmaz. A kibontani kívánt fájlok megadásához használhatók helyettesítő karakterek.

cél

Megadja a kibontott fájl célkönyvtárát és/vagy fájlnevét.

Példák

A következő példa kibontja az Msgame.sys fájlt a Windows 2000 CD-n található Drivers kabinetfájlból, és bemásolja azt a C:\Winnt\System\Drivers könyvtárba:

expand d:\i386\driver.cab \f:msgame.sys c:\winnt\system\drivers

A következő példa kibontja az Access.cp_ tömörített fájlt:

expand d:\i386\acces.cp_ c:\winnt\system32\access.cpl

A következő példa kilistázza a Windows 2000 CD-n található Drivers kabinetfájlban lévő összes fájlt:

expand /d d:\i386\driver.cab

Fontos

  • A Drivers kabinetfájl, amely a Windows 2000 legtöbb illesztőprogramját tartalmazza, több ezer fájlt tartalmaz. Az összes fájl merevlemezre történő kibontása sok időbe telik, és nagy lemezterületet foglal el. Ezért ajánlott csak a szükséges fájlok kibontása.

Megjegyzések

  • Ha a cél nincs megadva, a fájl az aktuális könyvtárba lesz másolva.
  • Célként nem adhat meg hajlékonylemezt vagy CD-ROM-ot.


Fixboot

Egy új partíciós betöltőszektort ír a rendszerpartícióra. A fixboot parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

fixboot [meghajtó]

Paraméter

meghajtó

Az a meghajtó, amelyre a betöltőszektort írni szeretné. Ezzel lecseréli az alapértelmezett meghajtót, amely az a rendszerpartíció, amelyre be van jelentkezve. Példa meghajtóra:

D:

Példa

A következő példa a D: meghajtó rendszerpartíciójára új partíciós betöltőszektort ír:

fixboot d:

Megjegyzés

  • A fixboot parancs paraméter nélkül történő használata esetén arra a rendszerpartícióra ír új partíciós betöltőszektort, amelyre be van jelentkezve.


Fixmbr

Új fő rendszertöltő rekordot ír a merevlemezre. A fixmbr parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

fixmbr [eszköz_neve]

Paraméter

eszköz_neve

Az az eszköz (meghajtó), amelyre új fő rendszertöltő rekordot szeretne írni. A nevet a map parancs kimenetéből lehet megtudni. Példa eszköznévre:

\Device\HardDisk0

Példa

A következő példa a megadott eszközre új fő rendszertöltő rekordot ír:

fixmbr \Device\HardDisk0

Megjegyzések

  • Ha az eszköz_neve nincs megadva, az új fő rendszertöltő rekord a rendszerindító eszközre lesz írva, amely az elsődleges rendszer betöltésére használt meghajtó.
  • Ha a partíciós tábla érvénytelen vagy nem szabványos, egy figyelmeztetés jelenik meg, hogy kívánja-e folytatni a műveletet. Ha probléma nélkül el tudja érni a meghajtókat, akkor ne folytassa a műveletet. Ha a rendszerpartícióra új fő rendszertöltő rekordot ír, akkor megsérülhetnek a partíciós táblák, és a partíciók elérhetetlenné válhatnak.


Format

A megadott meghajtót a megadott fájlrendszerre formázza Windows 2000 rendszerrel történő használathoz. A format parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhetők el, amely a Windows 2000 telepítőprogramjából indítható. A format parancs más paraméterekkel a Windows 2000 parancssorából használható.

format [meghajtó:] [/q] [/fs:fájlrendszer]

Paraméterek

meghajtó:

Megadja a formázni kívánt meghajtót. A Helyreállítási konzolról nem lehet hajlékonylemezt formázni.

/q

A meghajtón gyors formázást hajt végre. Nem vizsgálja meg, hogy a meghajtó tartalmaz-e hibás területeket, tehát csak akkor ajánlott használni, ha a meghajtó előzőleg már formázva volt.

/fs:fájlrendszer

Megadja a használni kívánt fájlrendszert: FAT, FAT32 vagy NTFS. Ha nem ad meg fájlrendszert, a meglévő fájlrendszer szerint történik a formázás.


Help

Megjeleníti a Windows 2000 Helyreállítási konzol parancsaival kapcsolatos tudnivalókat.

help [parancs_neve]

Paraméter

nincs

Felsorolja a Helyreállítási konzolon elérhető parancsokat.

parancs_neve

Információkat jelenít meg a parancsról, többek között a paranccsal együtt használható paraméterekről.

Megjegyzés

  • Kétféleképpen lehet a parancsokkal kapcsolatos tudnivalókat a képernyőn megjeleníteni. Meg lehet adni a parancs nevét a help parancs után, vagy be lehet írni a parancssorba a parancs nevét, majd utána a /? kapcsolót. Ha például az extract paranccsal kapcsolatban van szüksége segítségre, a következők bármelyikét beírhatja:

    help extract
    extract /?


Listsvc

Megjeleníti a számítógépen használható szolgáltatások és illesztőprogramok listáját. A listsvc parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

listsvc

Paraméterek

nincs


Logon

Bejelentkezhet egy Windows 2000 vagy Windows NT 4.0 rendszerbe. A logon parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

logon

Paraméterek

nincs

Megjegyzés

  • A logon parancs megjeleníti az összes telepített Windows 2000 és Windows NT rendszert, és a bejelentkezéshez kéri a helyi rendszergazdajelszót.


Map

Megjeleníti a meghajtóbetűjelek fizikai eszköznevekre történő leképezését. Ez az információ hasznos a fixboot, fixmbr és fdisk parancsokhoz. A map parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

Map [arc]

Paraméter

arc

Utasítja a map parancsot, hogy Advanced RISC Computing (ARC) eszközneveket jelenítsen meg Windows 2000 eszköznevek helyett. Példa ARC eszköznévre:

multi(0)disk(0)rdisk(0)partition(1)

Az ezzel megegyező Windows 2000 eszköznév:

\Device\HardDisk0\Partition1

Példa

A következő példa ARC eszköznevek segítségével képezi le a fizikai eszközneveket meghajtóbetűjelekre:

map arc

Megjegyzések

  • Ha nem adja meg az arc paramétert, a map parancs Windows 2000 eszközneveket jelenít meg.
  • A map parancs megjeleníti a fájlrendszer típusát és a lemezek méretét is (megabájtban).


Mkdir (Md)

Létrehoz egy könyvtárat vagy alkönyvtárat. Az mkdir parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. Az mkdir parancs más paraméterekkel a Windows 2000 parancssorából használható.

mkdir [meghajtó:]elérési út

-vagy-

md [meghajtó:]elérési út

Paraméterek

meghajtó:

Megadja azt a meghajtót, amelyen új könyvtárat szeretne létrehozni.

elérési út

Megadja az új könyvtár nevét és helyét. Helyettesítő karakterek nem használhatók.

Megjegyzés

  • Az mkdir parancs csak a jelenlegi Windows telepítés rendszerkönyvtáraiban, a cserélhető adathordozókon, bármely lemezpartíció gyökérkönyvtárában és a helyi telepítési forrásokban működik.


More

Megjeleníti egy szövegfájl tartalmát. Használja a more vagy a type parancsot, ha egy szövegfájlt meg akar tekinteni, de azt nem akarja módosítani. A more parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A more parancs más paraméterekkel a Windows 2000 parancssorából használható.

more [meghajtó:][elérési út] fájlnév

-vagy-

type [meghajtó:][elérési út] fájlnév

Paraméter

[meghajtó:][elérési út] fájlnév

Megadja a megtekinteni kívánt fájl helyét és nevét.

Ha NTFS meghajtó használata esetén a fájlnév szóközt tartalmaz, a fájlnevet idézőjelek (") közé kell tenni.


Rename (Ren)

Módosítja egy fájl nevét. A rename parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A rename parancs más paraméterekkel a Windows 2000 parancssorából használható.

rename [meghajtó:][elérési út] fájlnév1 fájlnév2

-vagy-

ren [meghajtó:][elérési út] fájlnév1 fájlnév2

Paraméterek

[meghajtó:][elérési út] fájlnév1

Megadja az átnevezni kívánt fájl helyét és nevét. Helyettesítő karakterek nem használhatók.

fájlnév2

Megadja a fájl új nevét. Fájlok átnevezése esetén nem adható meg új meghajtó és elérési út.


Rmdir (Rd)

Eltávolít (töröl) egy könyvtárat. Az rmdir parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. Az rmdir parancs más paraméterekkel a Windows 2000 parancssorából használható.

rmdir [meghajtó:]elérési út

-vagy-

rd [meghajtó:]elérési út

Paraméterek

[meghajtó:]elérési út

Megadja a törölni kívánt könyvtár helyét és nevét. Helyettesítő karakterek nem használhatók.

Megjegyzések

  • A parancs sikeres végrehajtásához a könyvtárnak üresnek kell lennie.
  • Az rmdir parancs csak a jelenlegi Windows telepítés rendszerkönyvtáraiban, a cserélhető adathordozókon, bármely lemezpartíció gyökérkönyvtárában és a helyi telepítési forrásokban működik.


Set

Megjeleníti és beállítja a Helyreállítási konzol környezeti változóit. A set egy választható parancs, amelyet engedélyezni kell a Biztonsági sablonok segítségével.

A set parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A set parancs más paraméterekkel a Windows 2000 parancssorából használható.

set [változó=[karakterlánc]]

Paraméterek

nincs

A set parancs paraméter nélküli kiadása esetén a jelenlegi környezeti beállítások jelennek meg.

változó

Megadja a beállítani kívánt változót.

A Helyreállítási konzol az alábbi környezeti változókat támogatja:

Változó | Leírás
AllowWildCards | Engedélyezi helyettesítő karakterek használatát egyes parancsok esetén (például a del parancs esetén).
AllowAllPaths | Engedélyezi a rendszeren lévő összes fájlhoz és könyvtárhoz történő hozzáférést.
AllowRemovableMedia | Engedélyezi fájlok cserélhető adathordozóra (például hajlékonylemezre) történő másolását.
NoCopyPrompt | Nem jelenik meg figyelmeztető üzenet létező fájl felülírásakor.

karakterlánc

Megadja azt a karakterláncot, amelyet a változóhoz hozzá kíván rendelni.

Példák

A következő példa engedélyezi helyettesítő karakterek használatát a Helyreállítási konzol néhány parancsa esetében:

set allowwildcards=true

A következő példa kikapcsolja a fájlok felülírására figyelmeztető üzenetet:

set nocopyprompt=true

Megjegyzések

  • A set parancs alapértelmezés szerint nem engedélyezett. A set parancs a Biztonsági sablonok segítségével engedélyezhető. A Set parancs engedélyezése a Helyreállítási konzolon attribútum a konzolfában a Helyi számítógép házirendje/Számítógép konfigurációja/Windows-beállítások/Biztonsági beállítások/Helyi házirend/Biztonsági beállítások úton érhető el.
  • Alapértelmezés szerint minden környezeti változó FALSE értékre van állítva.


Systemroot

A jelenlegi könyvtárat állítja be a Windows 2000 rendszer rendszergyökér könyvtárának. A systemroot parancs csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható.

systemroot

Paraméterek

nincs


Type

Megjeleníti egy szövegfájl tartalmát. Használja a type vagy a more parancsot, ha egy szövegfájlt meg akar tekinteni, de azt nem akarja módosítani. A type parancs az alább felsorolt paraméterekkel csak a Windows 2000 Helyreállítási konzol használata esetén érhető el, amely a Windows 2000 telepítőprogramjából indítható. A type parancs más paraméterekkel a Windows 2000 parancssorából használható.

type [meghajtó:][elérési út] fájlnév

-vagy-

more [meghajtó:][elérési út] fájlnév

Paraméter

[meghajtó:][elérési út] fájlnév

Megadja a megtekinteni kívánt fájl helyét és nevét.

Ha NTFS meghajtó használata esetén ha a fájlnév szóközt tartalmaz, a fájlnevet idézőjelek közé kell tenni.