Windows ATM-szolgáltatások

Az aszinkron adatátviteli mód (ATM) olyan szabványos hálózati technológiák halmaza, amelyek a kapcsolatok megfelelő minőségét a Szolgáltatás minősége (QoS) eszközzel garantáló, nagy sebességű hálózatok kiépítésére használhatók. A Windows 2000 operációs rendszer részét képező Windows ATM szolgáltatások szoftver segítségével ATM-hálózatok részesévé válhat, ha rendelkezik ATM-csatolóval.

  • Mielőtt megkezdi az ATM használatát, olvassa el a Feladatlista: ATM-szolgáltatások telepítése című fejezetet.
  • Az ATM használatával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Feladatlista: ATM-szolgáltatások telepítése

Lépés | Hivatkozás
Nézze át az ATM-mel kapcsolatos fogalmakat (cellák, ATM-modell, ATM Szolgáltatás minősége). | Az ATM ismertetése
Szükség esetén nézze át a LAN-emulációval (LANE) kapcsolatos tudnivalókat. | LAN-emuláció
Szükség esetén nézze át a TCP/IP ATM-hálózaton történő alkalmazásával kapcsolatos tudnivalókat. | IP-forgalom ATM-hálózaton keresztül (IP/ATM)
Telepítsen egy ATM-csatolót erre a számítógépre. | ATM-csatoló telepítése
Szükség esetén konfigurálja a LAN-emulációt. | LAN-emulációs ügyfél konfigurálása
Szükség esetén állítsa be az IP/ATM kapcsolatokat, majd telepítse és konfigurálja az ATM ARP/MARS szolgáltatást. | Egyszerű, ATM-kapcsolaton keresztüli TCP/IP-forgalom engedélyezése; Az ATM ARP/MARS szolgáltatás telepítése és konfigurálása
Konfigurálja az állandó virtuális kapcsolatokat (PVC-ket). | Állandó virtuális kapcsolat létesítése ATM használatával
Hárítsa el az ATM-kapcsolatok esetén felmerült hibákat. | Hibaelhárítás


Gyakorlati tanácsok

  • Használja az alapértelmezett ELAN-t.
    A Windows 2000 ATM szolgáltatásai az alapértelmezett meghatározatlan_ELAN_név csoportnévvel vannak konfigurálva. Ha LAN-emuláció megvalósítását tervezi, akkor javasolt az előre konfigurált alapértelmezett, meghatározatlan ELAN használata.

    ATM-kapcsoló beszerzése esetén a termékleírás segítségével állíthatja be a terméket az előre konfigurált alapértelmezett, meghatározatlan ELAN csoportnévre.

  • Használjon támogatott ATM-csatolókat.
    Mielőtt beszerezné a Windows 2000 rendszerrel használni kívánt ATM-csatolót, ellenőrizze, hogy szerepel-e a hardverkompatibilitási listában. További információért olvassa el a hardverkompatibilitási listát tartalmazó Microsoft webhelyet.
  • Frissítse a Windows NT 4.0 rendszert Windows 2000 rendszerre
    Mielőtt a Windows NT 4.0 rendszert Windows 2000 rendszerre frissítené, jegyezze fel a frissíteni kívánt LAN-emulációs ügyfelek alábbi beállításait.
    • Az ELAN neve
    • A LAN-on emulálni kívánt adathordozótípus
    • Az ELAN-hoz társított LES és BUS ATM-címe
    • A legnagyobb csomagméret, amelyet az ELAN még képes kezelni

    Ezután az ATM-kapcsolón található LECS illesztő segítségével konfigurálja az ELAN hálózatokat és azok paramétereit a feljegyzett konfigurációs beállításoknak megfelelően.

    Ezt követően telepítse a Windows 2000 rendszert, majd minden LEC (helyi adatcsere-szállító) esetében konfigurálja az ELAN nevet. Az ELAN név beállításával kapcsolatos tudnivalók a LAN-emulációs ügyfél konfigurálása című témakörben találhatók.

  • Egy virtuális LAN-hoz csak egy ATM ARP/MARS kiszolgálót használjon.
    Ha a hálózatra az IP/ATM használata jellemző, akkor a hálózat minden egyes virtuális LAN hálózatához lehetőleg csak egyetlen ATM ARP/MARS kiszolgálót állítson be. Ha ugyanahhoz a hálózati szegmenshez több ARP kiszolgáló tartozik, és az ARP ügyfél ezeknek a kiszolgálóknak a címeivel lett beállítva, akkor az ARP gyorsítótárak szinkronizáltsága megszűnhet. Ezáltal a hálózat egyes részei elérhetetlenné válhatnak.


Útmutató

  • ATM-csatoló telepítése
  • LAN-emulációs ügyfél beállítása
  • Egyszerű, IP/ATM-kapcsolat engedélyezése
  • Speciális IP/ATM-kapcsolat beindítása
  • Az ATM ARP/MARS szolgáltatás telepítése és beállítása
  • Permanens virtuális kapcsolat létrehozása ATM használatával
  • ATM-kapcsolatra adatainak megtekintése


Fogalmak

Ez a rész általános háttérinformációkkal szolgál az aszinkron adatátviteli mód (ATM) Windows 2000 operációs rendszerben rendelkezésre álló technológiáiról.

  • ATM – áttekintés
  • Az ATM ismertetése
  • Az ATM használata
  • Forrásmunkák


ATM – áttekintés

A rész tartalma:

  • Az ATM definíciója
  • A Windows ATM szolgáltatások definíciója
  • Az ATM előnyei


Az ATM definíciója

Aszinkron adatátviteli mód (ATM) – egymással kapcsolatban álló technológiákat, köztük a szoftvert, a hardvert és a csatlakozáshoz szükséges eszközöket jelöli. Az ATM különbözik a jelenlegi LAN- és WAN-technológiáktól, hiszen kifejezetten a nagy sebességű kommunikáció támogatására tervezték. Az ATM lehetővé teszi, hogy a hálózatok a leghatékonyabban használják ki a sávszélességet mint erőforrást, miközben fenntartja a szigorú szolgáltatási követelményekkel rendelkező felhasználók és programok számára a szolgáltatás minőségét (QoS).

Az ATM alapkomponensei a végponti számítógépek, az ATM-hálózathoz csatlakoztatott számítógépek, valamint azok az ATM-kapcsolók, amelyek összekötik a végponti számítógépeket és biztosítják az adatok sikeres továbbítását.

Az ATM alapkomponensei

Aszinkron – a rendelkezésre álló sávszélesség nincs felosztva időzítő mechanizmus vagy óra által szinkronizált rögzített csatornákra vagy tárolóhelyekre. Az aszinkron kommunikációs módszert használó eszközök között nincs kapcsolat abban a vonatkozásban, hogy milyen sebességgel képesek küldeni és fogadni az információt. A küldő és a fogadó saját fizikai korlátaik és a hálózati információáramlás fenntartására való képességük figyelembe vételével egyeztetést végez az adatátviteli sebességet illetően.

Átviteli mód – a küldő és a fogadó közötti információáramlás módját jelöli. Az ATM esetében a továbbítandó adatok strukturálása és felosztása a kis méretű, fix hosszúságú cellákra vonatkozó koncepció alapján történik. Azzal, hogy nem a legtöbb létező hálózat esetében alkalmazott változó hosszúságú csomagküldési mechanizmust használja, az ATM biztosítja, hogy a kapcsolatok egyeztetése és kezelése során egyetlen adattípus vagy kapcsolat se sajátíthassa ki az adatátviteli útvonalat.


A Windows ATM szolgáltatások definíciója

  • ATM UNI híváskezelő, amely megfelel az ATM Forum ATM-hálózaton keresztül történő jeltovábbításra vonatkozó előírásainak és támogatja a kapcsolt virtuális adatáramkörök (SVC-k)és az állandó virtuális adatáramkörök (PVC-k) létrehozását.
  • A Windows Hardware Quality Laboratories által tesztelt frissített NDIS 5.0 ATM miniport illesztőprogramok, amelyek korlátozott mértékben támogatják a telepített ATM-csatoló hardvert.
  • LAN-emulációs ügyfélmodul, amely megfelel az ATM Forum LANE 1.0 szerinti előírásainak, és lehetővé teszi, hogy az Ethernet és Token Ring hálózatokhoz tervezett, már meglévő programok és protokollok módosítás nélkül futtathatók legyenek ATM-hálózaton is.
  • ARP/MARS szolgáltatás, amely lehetővé teszi, hogy a Microsoft TCP/IP verem az ATM-címeket hardvercímekként oldja fel, az ATM-médiumok még közvetlenebb és hatékonyabb alkalmazása végett. Az ATM-hálózaton keresztüli IP-forgalmat megvalósító modul megfelel az ATM-médiumok Address Resolution protokolljára (ARP) vonatkozó RFC-előírásoknak, valamint támogatja a csoportcímhozzárendelési szolgáltatást (MARS) is.
  • Fokozott támogatás a TAPI alapú alkalmazások és szolgáltatások számára.
  • Támogatás a felhasználatlan csatornák hozzáférésének szűréséhez, amely DirectStreaming objektumot tartalmazó alkalmazási környezetekben használható.
  • A Hálózati és telefonos kapcsolatok bővített támogatása ATM-médiumon keresztül történő PPP tárcsázáshoz, amely lehetővé teszi PPP telefonos hálózati kapcsolat létesítését és használatát minden támogatott, Windows 2000 operációs rendszerre telepített ATM-csatolón keresztül. Ez a szolgáltatás támogatja az ATM DSL vonal, kábelmodem, illetve más igény szerinti csatlakoztatási lehetőség útján történő használatát.
  • Saját ATM-szolgáltatások elérése ATM-en keresztül a Winsock 2.0 alkalmazásával A Windows Sockets ATM Service Provider által biztosított Winsock 2.0 lehetővé teszi az ATM-szolgáltatások felhasználói módú programokból történő közvetlen elérését. Lehetővé teszi továbbá, hogy az átviteli protokollként a TCP/IP protokollt használó programok ATM hálózaton is fussanak és együttműködjenek szabványos LAN alapú IP-ügyfelekkel.


Az ATM előnyei

Az ATM rugalmas és testreszabható megoldást nyújt a minőségi szolgáltatások iránti egyre fokozódó igények kielégítésére olyan hálózatok esetében, amelyek többféle információtípust (adatot, hangot és valós idejű kép- és hanginformációt) is támogatnak. Az ATM segítségével mindezek az információtípusok egyetlen hálózati kapcsolaton keresztül továbbíthatók.

Az ATM használata a következő előnyökkel jár:

  • Nagy sebességű kommunikáció
  • Kapcsolatorientált, a telefonos hálózathoz hasonló szolgáltatás
  • Gyors, hardver alapú átkapcsolás
  • Egyetlen univerzális, más egységekkel együttműködni képes hálózati adatátvitel
  • Egyetlen hálózati kapcsolat, amely megbízhatóan alkalmazható hang, kép és adat továbbítására
  • A hálózati sávszélesség rugalmas és hatékony lefoglalása


Az ATM ismertetése

Az aszinkron adatátviteli mód (ATM) több, egymással kapcsolatban álló, szabványosított technológiát jelöl, melyek célja a nagy sebességű hálózati kapcsolat fenntartása. A technológiákkal kapcsolatos további információ a következő témakörökben található:

  • ATM-cellák
  • Az ATM modell
  • ATM-hálózatok
  • Példa: Kapcsolt csatlakozás (SVC)
  • Példa: Állandó kapcsolat (PVC)
  • ATM Szolgáltatás minősége (QoS)
  • LAN-emuláció
  • IP-forgalom ATM-hálózaton keresztül (IP/ATM)


ATM-cellák

Az ATM-cellák állandó, 53 bájt hosszúságúak. Az állandó hosszúságú cellák használatával az információ előre látható módon továbbítható. Ez az előreláthatóság ugyanazon a hálózaton különböző továbbítási módszerekre (kép, hang, adat) érvényes.

Az ATM-cellák 53 bájtnyi mérete két fő részre van felosztva:

Az ATM-cella
  • A fejléc (5 bájt) tartalmazza a címzési mechanizmust, amely meghatározza, hogyan kerüljön sor a cella kapcsolására.
  • A tartalom (48 bájt), más néven a felhasználói adatmező, amely a tényleges információt (képet, hangot, adatokat) tartalmazza.

Az adattovábbításhoz használt 48 bájtos tartalomhossz révén az ATM kompromisszumos megoldást nyújt a nagyobb, adatok számára optimalizált (például 64 bájtos) cellaméret, és a kisebb, hangátvitelhez optimalizált (például 32 bájtos) cellaméret között.


Az ATM modell

Az ATM vonatkozásában használatos protokoll-hivatkozási modell a Nemzetközi Távközlési Szövetség (ITU) által a szélessávú integrált szolgáltatású digitális hálózat (B-ISDN) számára kidolgozott modellből került át. Mivel az ATM a B-ISDN adatátviteli módja, ezért ez a modell közvetlenül alkalmazható az ATM-re, és gyakran használják az ATM leírására szolgáló protokollmodellként is.

Az ATM protokollmodell síkokból és szintekből áll, amint az a következő ábrán is látható.

Az ATM protokollmodell

Az ATM protokoll-hivatkozási modell

Az ATM modellben három sík található:

  • A felhasználói sík határozza meg, hogy az ATM hogyan továbbítsa a felhasználói információkat a hálózaton keresztül.
  • A vezérlő sík kapcsolt ATM-szolgáltatásokra vonatkozó jelzések használatával végzi a kapcsolatok adminisztrációját, például a hívások kezdeményezését és megszakítását.
  • A kezelő sík karbantartja a hálózatot és végrehajtja a műveleti funkciókat. Ez a sík tovább osztódik a különböző szintek és síkok kezelését végző szintkezelésre és síkkezelésre.

A vezérlő sík és a felhasználói sík a következő szinteket tartalmazza: fizikai szint, ATM-szint, ATM-adaptációs szint és további magasabb szintű protokollok. A három alsó szint használata kötelező, minden kapcsolódó ATM hardver- és szoftvertermékben meg kell jelenniük. Az ATM modell magasabb szintű protokolljai a fordításhoz és beágyazáshoz alkalmazható egyéb szinteket tartalmazzák. Ezeket a felhasználók célzottan, vagy esetleg csak néhány ATM-termékben alkalmazhatják.

Fizikai szint

Ez a szint határozza meg, hogy a cellák hogyan legyenek hozzárendelve az ATM hardvereszközök közötti adatforgalmat bonyolító fizikai adathordozóhoz.

ATM-szint

Az ATM-szint írja le, hogy hogyan továbbítódnak a cellák a hálózaton keresztül, és milyen minőségű szolgáltatást kell fenntartani ahhoz, hogy a kapcsolatok a megállapított szolgáltatási színvonalon működjenek. Az ATM-szint az ötbájtos cellafejlécekben található információt is felhasználja a végrehajtható lehetséges műveletek számának meghatározására.

Az ATM-szint szolgáltatásai:

  • Cellák létrehozása.
  • Cellák többszintű továbbítása és a többszintű továbbítás megszüntetése.
  • Cellasorozat és kombináció kezelése.
  • Eldobott cellák kezelése.
  • Kapcsoló alapú útválasztás virtuális útvonalak és virtuális adatáramkörök használatával.

ATM-adaptációs szint

Az ATM-adaptációs szint (AAL) szolgál az információ 48 bájtonkénti létrehozására és fogadására.

Az adaptációs szint feloldja a diszparitási problémákat a digitális eszközök (például telefonok és videókamerák) bitáramlási technológiájához alkalmazott ATM-szint cella alapú technológiája által biztosított szolgáltatások, illetve a hagyományos adathálózatok csomagáramlási technológiája, többek között a WAN hálózatokban és LAN protokollokban (például Ethernet és TCP/IP) alkalmazott frame relay és X.25 között.

A Nemzetközi Távközlési Szövetség (ITU) fogalmazta meg elsőként azt, hogy több alapvető AAL-t (szolgáltatási osztályt) kell biztosítani a különböző információtípusok ATM-szintű cellákba történő beágyazásával kapcsolatos követelmények kielégítésére.

A következő táblázat az ITU által meghatározott AAL-eket és azok javasolt felhasználási területét ismerteti az egyes szintek vonatkozásában.

Az ATM-adaptációs szintek

Szint | Leírás
AAL1 | Támogatja az ATM-cellák használatával történő adatáramkör-emulációt a hagyományos hang-, a T1 és T3 továbbító szolgáltatások esetében. Az AAL1 két módszert alkalmaz: a strukturált adatátvitelt (SDT) és a szinkron maradékidő-bélyegzést (SRTS). Követelmény az állandó átviteli sebesség és a kapcsolatorientált, egyidejű (időfüggő) szolgáltatás.
AAL2 | Támogatja a változó átviteli sebességek alkalmazására képes, adatcsomagokon alapuló videó- és egyéb, időfüggő alkalmazásokat. Az AAL2 definíciója pillanatnyilag nem szerepel az ATM-szabványok között.
AAL3/4 | Támogatja az adatfolyamok, köztük a kapcsolatorientált és kapcsolat nélküli szolgáltatások többszintű továbbítását. Az AAL3/4 a korai ATM-alkalmazásokban került felhasználásra, de a darabolási és újraszerkesztési (SAR) alszint miatt jelentkező többletköltségek miatt már nem tartozik a kedvelt szintek közé. A SAR fejléce és lezáró kódja egyaránt 2 bájt hosszúságú, ami az adatok tárolására felhasználható cellakapacitást jelentősen, 44 bájtra csökkenti.
AAL5 | A LAN forgalmának hatékony lebonyolítására szolgál. Napjainkban széles körben használják a legtöbb ATM-termékben.

Megjegyzés

  • Az AAL5 gyakorlatilag a leggyakrabban használt adaptációs szint, amely a LAN forgalmát tekintve a legjobb teljesítményt kínálja a többi AAL-hez képest.

Felső szintek

Az ATM protokoll-hivatkozási modell felső szintjei olyan választható szinteket tartalmaznak, amelyekkel az ATM-szolgáltatás a TCP/IP és más protokollokhoz való alkalmazáshoz tovább ágyazható.

A felső szintű protokollok közé tartoznak azok, amelyek az RFC 1483 (többprotokollos beágyazás az AAL5 használatával) és az RFC 1577 (klasszikus IP az ATM használatával) specifikációkban szerepelnek.


ATM-hálózatok

Az ATM-hálózatok a következő három elemből épülnek fel: felhasználók (végponti eszközök), kapcsolók és illesztők.

Az ATM-hálózatok esetében két illesztőtípus segítségével írható le az elemek egymás közötti kommunikációja: a felhasználó-hálózat (UNI) típusú illesztőkkel és a hálózat-hálózat (NNI) típusú illesztőkkel.

Az UNI- és NNI-specifikációk szabványos jelzési metódust tartalmaznak a végponti munkahelyek és az ATM-kapcsolók közötti kommunikációhoz.

UNI- és NNI-jelzés

Megjegyzés

  • A Windows ATM szolgáltatások híváskezelője jelenleg az ATM Forum UNI 3.1-es specifikációt támogatja. A Windows ATM-szolgáltatásokkal kapcsolatos további információért olvassa el A Windows ATM szolgáltatások definíciója című részt.


Példa: Kapcsolt csatlakozás (SVC)

Az alábbi példa részletesen bemutatja, hogyan hozható létre SVC-kapcsolat az ATM-hálózatban.

SVC létesítése

  1. Az ATM-felhasználó (az A számítógép), SETUP üzenetet küld a jelzésre fenntartott virtuális csatornán keresztül (VPI=0, VCI=5) a saját közvetlenül csatlakoztatott ATM-kapcsolójához, az 1-es ATM-kapcsolóhoz.

    A SETUP üzenet tartalma:

    • A B számítógép 20 bájt méretű ATM-címe.
    • A Szolgáltatás minősége (QoS) eszköz kapcsolathoz szükséges paraméterei.

  2. Az 1-es ATM-kapcsoló a SETUP üzenet elemzésével meghatározza, hogy van-e táblázatbejegyzés a B számítógép kapcsolójának címéhez, illetve támogathatja-e a létrehozandó kapcsolathoz szükséges QoS paramétereket.

    Ha az 1-es ATM-kapcsoló megtalálja a B számítógép kapcsolójának címét és támogatja a kapcsolathoz szükséges QoS paramétereket, CALL PROCEEDING üzenetet küld vissza az A számítógéphez.

    Ha az 1-es ATM-kapcsoló nem találja a B számítógép kapcsolójának címét vagy nem tudja létrehozni a kapcsolatot, szabványos hibakódokat tartalmazó RELEASE üzenetet küld vissza az A számítógéphez, a hívási kérelmet pedig elutasítja.

  3. Az 1-es ATM-kapcsoló (az 1. lépésben ismertetett) SETUP üzenetet a jelzésre fenntartott virtuális csatornán keresztül (VPI=0, VCI=5) elküldi a következő hálózati kapcsolóhoz, a 2-es ATM-kapcsolóhoz, a megfelelő útvonalon, a B számítógéphez.

    A SETUP üzenet tartalma a B számítógép ATM-címét a QoS paramétereket illetően ugyanaz, mint az 1. lépésben. Ezen felül a SETUP üzenet most megad egy új, az 1-es ATM-kapcsoló és a 2-es ATM-kapcsoló között használható VPI/VCI párt is.

  4. A 2-es ATM-kapcsoló megkapja a SETUP üzenetet. A B számítógép a 2-es ATM-kapcsolóhoz regisztrált közvetlenül csatlakoztatott végpont. Ha a kért kapcsolathoz szükséges szolgáltatási minőség biztosítható, a 2-es ATM-kapcsoló CALL PROCEEDING üzenetet küld vissza az 1-es ATM-kapcsolóhoz.
  5. A SETUP üzenet megérkezik célpontjához, a B számítógéphez. A B számítógép kétféle módon válaszolhat:
    • Ha a B számítógép elfogadja a hívást, CALL PROCEEDING üzenetet küld vissza a 2-es ATM-kapcsolóhoz, amelyet közvetlenül követ egy CONNECT üzenet.
    • Ha a B számítógép elutasítja a hívást, RELEASE üzenetet küld vissza a 2-es ATM-kapcsolóhoz. A RELEASE üzenet a hálózaton keresztül visszajut az eredeti forrásfelhasználóhoz (az A számítógéphez). Ez az üzenet a visszautasítás okát meghatározó szabványos hibakódokat tartalmaz.
  6. A 2-es ATM-kapcsoló CONNECT ACK üzenetet küld a B számítógéphez, majd az 1-es ATM-kapcsolóhoz továbbítja a CONNECT üzenetet.
  7. Az 1-es ATM-kapcsoló CONNECT ACK üzenetet küld a 2-es ATM-kapcsolóhoz, majd az A számítógéphez továbbítja a CONNECT üzenetet.
  8. Az A számítógép CONNECT ACK üzenetet küld vissza az 1-es ATM-kapcsolóhoz.

Megjegyzés

  • Az előző példa egy egyszerű SVC-kapcsolatot mutat be, amely csak két középszintű kapcsolót, az 1-es ATM-kapcsolót és a 2-es ATM-kapcsolót tartalmazza. A legtöbb SVC-kapcsolatban azonban sok középszintű kapcsoló fordul elő. Több középszintű kapcsoló használata esetén mindegyik kapcsoló SETUP, CONNECT és RELEASE üzeneteket továbbít a szomszédos, alsóbb rétegű kapcsolóhoz, miközben visszaigazolásokat (CONNECT ACK, RELEASE ACK) küld vissza a szomszédos, felsőbb rétegű kapcsolóhoz.

Ennek a kapcsolatfolyamatnak az eredménye az A számítógép és a B számítógép közötti kétirányú virtuális adatáramkör (VC), amelyben:

  • Az A és B számítógépen található valamennyi középszintű kapcsoló és ATM felhasználói hardver támogatja és biztosítja az ehhez a kapcsolathoz szükséges QoS kommunikációs paramétereket.
  • Minden középszintű kapcsoló (ebben az esetben az 1-es és 2-es ATM-kapcsoló) kapcsolótáblázat-bejegyzésekkel van programozva az ATM-cellák A és B számítógépek között útválasztásához használt BVPI/VCI párok sorozatának hozzárendeléséhez.

Fontos!

  • Ha bármelyik középszintű kapcsoló nem képes biztosítani a Szolgáltatás minősége (QoS) eszköz szükséges csatlakozási paramétereit, akkor a kapcsoló RELEASE üzenetet küld a forrásfelhasználó felé. A RELEASE üzenet a szabványos hibakódokat tartalmazza, és felszabadítja az egyes eszközökön lefoglalt erőforrásokat a csatlakozási útvonalon és a forrásnál.


Példa: Állandó kapcsolat (PVC)

Amellett, hogy a kapcsolás és hívási üzenetre vonatkozó jelzés használatával szükség szerint hozhatók létre adatáramkörök bármely két felhasználó között, lehetőség van az ATM-hálózat bármely adott két szolgáltatási végpontját összekötő virtuális ATM adatáramkör folyamatos fenntartására is.

Az állandó virtuális adatáramköröket az ATM-szolgáltatók széles körben alkalmazzák belső hálózataik összetett, ATM alapú infrastruktúrájának létrehozására és kialakítására. A hálózat belső ATM-infrastruktúrájának kiépítése sok esetben olyan állandó virtuális adatáramkörökkel történik, amelyek a kapcsolt virtuális csatlakozások esetében előforduló tényleges végpontok közötti kapcsolatokkal rendelkeznek.

Az állandó virtuális adatáramkörök olyan saját ATM-hálózatok esetében is hasznosak lehetnek, amelyekre az alábbiak jellemzők:

  • Nagyméretű egyetemi LAN, amely nagyobb sebességű ATM-gerincre kerül át. A gerinckonfigurációkban a kapcsolatokat tipikusan néhány statikus konfigurálható kapcsolási útvonal jellemzi, amelyek csak ritkán változnak, így elfogadható az ATM-adatáramkörök állandó konfigurációja.
  • Kis méretű WAN, amely korlátozott számú hellyel rendelkezik, de ezen helyek mindegyikének folyamatos, feladatorientált, nagy sebességű kapcsolatra van szüksége, amely állandó minőségű szolgáltatást garantál az egyes helyek között. Állandó adatáramkör esetében a WAN egyik helyén sincs várakozási idő és a hívásjelző vagy a kapcsolatlétesítő, illetve -megszakító használatából fakadó többletráfordítás, amikor az ATM-cella adatainak továbbítására kerül sor a hálózaton keresztül. Az elküldött adatok közvetlenül az egyes helyek között létesített állandó virtuális adatáramkörökön keresztül továbbíthatók.


ATM Szolgáltatás minősége (QoS)

ATM-hálózatok esetében a Szolgáltatás minősége (QoS) eszközzel biztosíthatók folyamatosan a jó eredmények valamennyi felhasználó számára. A kapcsolatok kiszolgálása közben az ATM a szolgáltatás minőségét három általános megközelítésben biztosítja:

  • Ha meghatározott szintű szolgáltatási minőségre van szükség, az ATM garantálja, hogy a kapcsolatot biztosító valamennyi eszköz megfelelő szintű szolgáltatásban részesüljön.
  • Ha az adott kapcsolathoz egyedileg meghatározott szolgáltatási minőségre van szükség, az ATM megkísérli a hálózat bármely pontján megtalálható erőforrások segítségével biztosítani a kívánt szintet, miközben fenntartja és karbantartja a szolgáltatási garanciákat az azokat igénylő kapcsolatok számára.
  • Ha a kapcsolathoz biztosítandó minőségi szint nincs megadva, az ATM megkísérli a lehető legnagyobb mértékben kihasználni a rendelkezésre álló erőforrásokat annak érdekében, hogy az így biztosított szolgáltatás hasonló legyen a többi LAN/WAN átviteli módban rendelkezésre állóhoz.

ATM szolgáltatási kategóriák

Az ATM szolgáltatási kategóriák létrehozása meghatározott ATM QoS paraméterek felhasználásával és kombinálásával, különböző módokon történik. Minden ATM-kapcsolat megfelel a négy szolgáltatási kategória valamelyikének. A szolgáltatási kategória jelölése közvetlenül az egyes ATM-cellák fejlécében található VPI/VCI információból származik. A kapcsolók a VPI/VCI segítségével határozzák meg a kapcsolatfolyam adott cellájának prioritását, amikor az eltérő szolgáltatási kategóriát használó kapcsolatok többszintű elrendezésére kerül sor.

A hálózati forgalom különböző típusainak irányításához az ATM-szabványokat úgy módosították, hogy meghatározzák a leggyakrabban használt szolgáltatások típusait. Az alábbi táblázat a négy általános ATM szolgáltatási kategóriát ismerteti.

A szolgáltatás kategóriája Leírás
Állandó átviteli sebesség (CBR)
  • Garantált folyamatos adatátviteli sebességet igénylő kapcsolatok, például valós idejű hang- vagy képtovábbítás.
  • Csak kis mértékű átviteli késéseket megengedő kapcsolatok, például adatáramkör-emuláció a bérelt vonalakhoz, illetve a T1 vagy T3 adatátviteli szolgáltatások. Az adatáramkör-emuláció rendszeres időközönként küldött modulált impulzuskódok folyamát jelenti.
Változó átviteli sebesség (VBR)
  • Olyan kapcsolatok, amelyek alacsonyabb (például a saját legkisebb átviteli sebességüknek megfelelő) lekötött sűrűséget igényelnek, de kezelni tudják a magas értékű (saját maximális adatátviteli sebességüknek megfelelő) lekötött sűrűséget a burst átviteli periódusok engedélyezéséhez.
  • Olyan eltérő késési követelményekkel rendelkező változó sebességű kapcsolatok támogatása, amelyek csak kis mértékű cellaveszteséget engednek meg.
Rendelkezésre álló átviteli sebesség (ABR)
  • Olyan kapcsolatok, amelyeknek nincs szükségük garantált adatátviteli sebességre, például a fájlátvitel és az elektronikus levél.
  • Olyan kapcsolatok, amely jobban alkalmazkodnak a megjósolhatatlan viselkedésű vagy burst alakzatokhoz, mint például az Ethernet és Token Ring LAN-okkal kialakított ATM-összeköttetés.
Meghatározatlan átviteli sebesség (UBR)
  • Olyan kapcsolatok, amelyekhez útválasztásra szükség van, garantált sávszélességre azonban nem, például parancsfájl-átvitel vagy alacsony prioritású, nagy mennyiségű elektronikus levél esetében.
  • Kapcsolatok olyan programokkal, amelyek nem alkalmaznak kézbesítési korlátozásokat, viszont maguk végzik a hibaellenőrzést és a folyamatvezérlést.


LAN-emuláció

A LAN-emuláció (LANE) olyan szoftverkomponensek csoportja, amelyek támogatják az örökölt alkalmazások és hálózati protokollok (Ethernet és Token Ring) ATM-hálózatban történő alkalmazását.

A LANE előnyei a következők:

  • Támogatja a hagyományos LAN hálózatok nagy sebességű ATM gerinchálózatokhoz történő csatolását.
  • Támogatja a meglévő LAN-protokollokat és illesztőket az ATM-en keresztül
  • Képes lefordítani és LAN-címekként feloldani az ATM-címeket

A rész tartalma:

  • A LANE szolgáltatások áttekintése
  • A LANE működése
  • LANE-komponensek
  • ATM LANE csoportcímzés Ethernet és Token Ring rendszerű LAN hálózatok felé


A LANE szolgáltatások áttekintése

A LAN-emulációs szolgáltatásokra az OSI protokoll hivatkozási modell 2. szintjének (adatkapcsolati szint) működőképességének biztosításához van szükség az ATM-felhasználók és a hagyományos LAN-környezetek között.

Ez az együttműködési képesség teszi lehetővé, hogy az ATM-hálózatot használók kommunikálhassanak a hagyományos LAN-technológiákat, például Ethernet vagy Token Ring környezetet használó felhasználókkal, mégpedig az emulált LAN (ELAN) segítségével.

Az emulált LAN a következő architektúra és funkciók segítségével biztosít összeköttetést a hagyományos LAN-okkal:

  • Az ATM-címzés leképezése és lefordítása az Ethernet és Token Ring LAN-okban használt hagyományos médiahozzáférés-vezérlő címzésre.
    Amikor egy ATM-felhasználó valamely eszköze ATM-címet küld, a címet le kell képezni és le kell fordítani médiahozzáférés-vezérlő címmé, mégpedig az IEEE 802.x típusú LAN-ok, például az Ethernet és Token Ring LAN-ok által használt formátumban. A médiahozzáférés-vezérlő cím azonosítja az ezeken a LAN-okon alkalmazott csatolóhardvert.

    A fordítás akkor is végbemegy, amikor egy Ethernet vagy Token Ring eszköz küld adatokat egy ATM-felhasználónak. Az adatküldéshez először az ATM-felhasználó médiahozzáférés-vezérlő címe kerül felhasználásra, majd ezután kell elvégezni az ATM-címre történő fordítást, hogy az adatokat továbbítani lehessen az ATM-hálózathoz.

  • Fordítás hagyományos LAN-keretek és ATM cellastruktúrák között.
    Az adatok hálózaton keresztül történő továbbítása során az Ethernet és Token Ring LAN-ok kereteket használnak az adatátvitel alapegységeként. Az ATM esetében adatátviteli alapegységként állandó, 53 bájt hosszúságú cellákra van szükség. Ezen alapvető eltérés miatt van szükség a keret-cella és a cella-keret fordítás végrehajtására az ATM és a hagyományos LAN-környezetek közötti sikeres adatcseréhez.
  • Címregisztráció és címkeresés, valamint az ATM-környezetből származó vagy odaküldendő LAN összcímes csomagok értékelése.
    A hagyományos LAN-környezetek összcímes és csoportcímes csomagok segítségével hajtanak végre számos, a hálózati kommunikációhoz szükséges beépített funkciót. Ilyen funkciók biztosítják például a szolgáltatást egy új eszköz számára, amely megkísérli regisztrálni a hálózati jelenlétét, vagy egy felhasználó számára, aki egy másik eszközt próbál megkeresni a hálózaton.

    Az összcímzéshez és a csoportcímzéshez hasonló műveletek nem illeszkednek az ATM-kapcsolaton alapuló modellhez, így új eljárások szükségesek ahhoz, hogy az ilyen típusú LAN-felhasználói kérelmek az ATM-környezet hasonló szolgáltatásaként legyenek értelmezhetők.


A LANE működése

A LAN-emuláció ATM-en keresztüli megvalósításának általános lépései a következők:

  • Az ügyfél indítása
    A LAN-emulációs ügyfél (LEC) a helyi ATM-kapcsolóval és a LAN-emuláció konfiguráció-kiszolgálójával (LECS) együttműködve inicializálja és konfigurálja saját magát, és ezáltal megszerzi a LAN-emulációs kiszolgáló (LES) címét.

    • A LEC három módon csatlakozhat a LAN-emuláció konfiguráció-kiszolgálójához:

    1. Próbálkozhat az ATM-protokollban definiált jól ismert ATM-címmel.
    2. Használhatja az ATM-protokollban definiált jól ismert virtuális csatornát.
    3. Lekérdezést végezhet az integrált szintkezelő felület (ILMI) alkalmazásával.

  • Ügyfélregisztráció
    A LAN-emulációs ügyfél (LEC) a LANE kiszolgálóhoz kapcsolódik, és megkezdi a csatlakozást egy adott emulált LAN-hoz.
  • Címhozzárendelés
    A médiahozzáférés-vezérlő cím ATM-címként lesz hozzárendelve.
  • Adatátvitel
    Miután egy LANE címhozárendelési lekérdezéssel megtörtént az ATM-cím meghatározása, a LANE ügyfél létrehoz egy kapcsolt virtuális adatáramkört, és ekkor megkezdődhet az adatátvitel.

Példa: LANE ügyfél indítása és regisztrálása

Az alábbi példa részletesen ismerteti egy LANE ügyfélhez tartozó LANE kapcsolat létrehozásának lépéseit:

  1. Az ügyfél saját hálózati kapcsolójával együttműködve saját ATM-címet szerez.
  2. Az ügyfél előre beállított vagy egy jól ismert ATM-cím vagy VC alkalmazásával kapcsolatba lép a LANE konfiguráció-kiszolgálóval. Ha egyik módszer sem jár sikerrel, az ügyfél az ILMI használatához folyamodik.
  3. A LANE konfiguráció-kiszolgáló válaszol az ügyfélnek, és elküldi az emulált LAN nevét és a LANE kiszolgáló ATM-címét.
  4. A LECS által megadott ATM-cím segítségével a LEC kapcsolatot kezdeményez a LANE kiszolgálóval.
  5. Az ügyfél LANE címhozzárendelési kérelmet (LE-ARP) küld a csoportcímes ismeretlen kiszolgáló (BUS) megkereséséhez.
  6. A LANE kiszolgáló válaszában megadja a BUS ATM-címét.
  7. Az ügyfél csoportcímes kapcsolatot létesít a BUS kiszolgálóval.

A LANE ügyfél indítása és az ELAN hálózaton történt regisztrációja után az ügyfél készen áll a címek feloldását célzó összcímzésre és csoportcímzésre.

LANE összcímzés és csoportcímzés

Az összcímzés vagy a csoportcímzés általában egy logikai cím (kiszolgálónév vagy IP-cím) médiahozzáférés-vezérlő címként történő feloldását szolgálja. Az ELAN hálózaton keresztül történő összcímes és csoportcímes küldés két módszerrel hajtható végre:

Összcímzés és csoportcímzés ELAN hálózatban
  1. Az ELAN ügyfél egy ARP összcímes vagy csoportcímes csomagot küld a BUS kiszolgálóhoz.
  2. A BUS továbbítja a csoportcímzést az ELAN valamennyi csatolt ügyféleszközéhez. Ha valamelyik ügyféleszköz bővítőeszköz, akkor a csoportcímes küldés Ethernet vagy Token Ring környezetű LAN hálózaton hajtható végre. További információ az ATM LANE csoportcímzés Ethernet és Token Ring rendszerű LAN hálózatok felé című részben található.


LANE-komponensek

A LANE 1.0 protokollspecifikáció határozza meg az egyszerű emulált LAN létrehozásához szükséges komponenseket. Ezek az komponensek biztosítják a LANE szolgáltatást a következő tipikus konfigurációk bármelyikében:

  • Középszintű hálózatok esetében az Ethernet és Token Ring LAN-ok ATM gerinchálózaton keresztül csatlakoztathatók.
  • Az ATM-felhasználók a LANE segítségével kommunikálhatnak azokkal az Ethernet- és Token Ring-felhasználókkal, akik ugyanahhoz az emulált LAN-hoz kapcsolódnak.

Megjegyzés

  • Nem okoz konfliktust, ha egy ATM-hálózaton több ELAN található. Ugyanakkor mindegyik ELAN csak az ATM-hálózat és egy hagyományos (Ethernet vagy Token Ring) LAN környezet közötti kapcsolatot támogatja. A LANE nem használható az Ethernet és Token Ring típusú helyi hálózatok közötti átjáróként.

Az alábbi négy LANE-komponens segítségével bármely konfigurációban biztosítható szolgáltatás:

  • LAN-emulációs ügyfél (LEC)
    A LEC általánosan alkalmazott komponens az ATM végrendszer-számítógépeken. Néha előfordul ATM-kapcsolókban a szoftver vagy a hardver révén (előbbi esetben az ATM eszközillesztő részeként, utóbbi esetben pedig mint az adott ATM csatolókártya vagy ATM kapcsolóhardver).

    • A LEC továbbítja az adatokat az ATM és a hagyományos LAN környezetek között, és feldolgozza a LAN csoportcímzéseket és az ügyfélrendszer címhozzárendelését. Címhozzárendelés esetén a LEC azonosítása két címmel történik: az ATM-címével, ha az ATM-hálózattal kommunikál, illetve egy médiahozzáférés-vezérlő címmel, ha az Ethernet vagy a Token Ring típusú helyi hálózattal kommunikál.

  • LAN-emulációs kiszolgáló (LES)
    A LES segítségével biztosíthatók az emulált LAN-on található valamennyi ügyfél számára szükséges vezérlési funkciók. Ezek a funkciók magukba foglalják az új LAN-emulációs ügyfelek médiahozzáférés-vezérlő címeinek regisztrációját, ezeknek a címeknek létező LAN-emulációs ügyfelek ATM-címeiként történő hozzárendelésést és az ELAN összes tageszközéhez tartozó ATM-címek és médiahozzáférés-vezérlő címek leképezett párosításainak karbantartását.
  • LAN-emuláció konfiguráció-kiszolgálója (LECS)
    A LECS feladata a LAN-emulációs ügyfelek megadott emulált LAN-okhoz történő hozzárendelése. Amikor egy ügyfél valamely emulált LAN-hoz történő csatlakozáshoz konfigurációs adatokat kér, a LECS megadja az emulált LAN LAN-emulációs kiszolgálójának (LES) ATM-címét.

    • Az ügyfelek megfelelő LES kiszolgálóhoz való irányítása vagy az ügyfél ATM-címének analizálásával megállapított fizikai helyük, vagy egy bizonyos rendeltetési LAN-nal való azonosságuk alapján történik. A konfiguráció-kiszolgáló engedélyezheti az ügyfél számára, hogy konfigurálja és közvetlenül hozzárendelje magát egy megadott LES kiszolgálóhoz és emulált LAN-hoz. Minden hálózathoz csak egy LECS tartozik, amely a hálózat valamennyi LAN-emulációs ügyfelét kiszolgálja.

  • Összcímes és ismeretlen kiszolgáló (BUS)
    A BUS segítségével kezelhető az ügyfelek közötti összcímes, csoportcímes és ismeretlen jellegű forgalom az emulált és a hagyományos LAN-ok esetében is. A BUS kezeli valamennyi emulált LAN ügyfélnek az "FF-FF-FF-FF-FF-FF" csoportcímes médiahozzáférés-vezérlő címre küldött csomagjait. Mindegyik ügyfél egy adott BUS kiszolgálóhoz van társítva, egyedi ATM-címmel rendelkezik, és egy bizonyos ELAN-on helyezkedik el.

Megjegyzés

  • A LANE protokollspecifikáció nem határozza meg, hogy ezeknek az komponenseknek hol kell elhelyezkedniük az ATM-termékekben. A Windows 2000 operációs rendszerrel a Microsoft megkezdi egy olyan LAN-emulációs ügyfélmodul alkalmazását, melynek telepítése automatikusan megtörténik az ATM-hardver telepítésekor. Más LANE kiszolgáló-komponensek, például a LES, a LECS és a BUS tipikusan az ATM kapcsoló-hardverrel kerülnek telepítésre.


ATM LANE csoportcímzés Ethernet és Token Ring rendszerű LAN hálózatok felé

Olyan emulált helyi hálózatban (LAN-ban), amely LAN-kapcsolón (bővítőeszközön) keresztül kapcsolódik egy Ethernet vagy Token Ring LAN-hoz, az összcímzés vagy a csoportcímzés általában egy logikai cím (kiszolgálónév vagy IP-cím) médiahozzáférés-vezérlő címként történő feloldását célozza. Az Ethernet vagy Token Ring LAN felé irányuló, ELAN hálózaton keresztül történő összcímes és csoportcímes küldés két módszerrel hajtható végre:

Összcímes küldés ATM-környezetből médiahozzáférés-vezérlő címzést használó Ethernet vagy Token Ring LAN felé

  1. Az ELAN ügyfél egy ARP összcímes vagy csoportcímes csomagot küld a BUS kiszolgálóhoz.
  2. A BUS továbbítja a csoportcímzést az ELAN valamennyi csatolt ügyféleszközéhez.
  3. Az összcímes csomag továbbítása is a LAN-kapcsolón (bővítőeszközön) keresztül történik, amely kapcsolatot teremt az ATM-hálózat és az Ethernet vagy Token Ring LAN között.

Megadott médiahozzáférés-vezérlő címre vonatkozó ARP-válasz az Ethernet vagy Token Ring LAN-tól az ATM-környezet felé

  1. Az Ethernet és Token Ring csomópontokból küldött összcímes csomagok a LAN-kapcsolón keresztül jutnak vissza az ATM-hálózat BUS kiszolgálójához.
  2. A BUS feldolgozza a csoportcímes küldést az ATM-hálózaton található ELAN-ügyfelek számára.
  3. A BUS ARP válaszcsomagot küld az ARP-kérelmet kezdeményező ELAN-ügyfélhez. A csoportcímes vagy összcímes lekérdezésre adott válasz a médiahozzáférés-vezérlő címet tartalmazza.

LANE címhozzárendelés

Mivel az összcímes vagy csoportcímes lekérdezésre adott válasz az egyik ELAN-ügyfél kívánt médiahozzáférés-vezérlő címét tartalmazza, az ATM-cím megszerzéséhez a következő címhozzárendelés szükséges:

  1. A LANE ügyfél létrehoz egy LANE címhozzárendelési kérelmet (LE-ARP), amelyet elküld a LANE kiszolgálóhoz.
  2. Ha a LANE kiszolgáló azonosítani tudja a médiahozzáférés-vezérlő címet, akkor a megfelelő ATM-címmel válaszol a LE-ARP kérelemre.
  3. Ha a LANE kiszolgáló nem tudja azonosítani a médiahozzáférés-vezérlő címet, akkor a LE-ARP kérelmet más, proxyként működő LANE-ügyfelekhez (LAN-kapcsolókhoz) továbbítja.
  4. A LAN-kapcsoló azoknak a médiahozzáférés-vezérlő címeknek a tárolt táblázatát ellenőrzi, amelyek a nem ATM hálózaton elérhetők.
  5. Ha a LE-ARP kérelmet feldolgozó LAN-kapcsoló válaszként olyan nem ATM ügyféleszköz médiahozzáférés-vezérlő címét adja meg, amely az Ethernet vagy Token Ring hálózaton található, akkor az eszköz ATM-címét az ATM-hálózaton lévő LANE-ügyfélhez küldi vissza.


IP-forgalom ATM-hálózaton keresztül (IP/ATM)

  • IP/ATM – áttekintés
  • Az IP/ATM működése
  • IP/ATM-komponensek


IP/ATM – áttekintés

Az IP/ATM olyan ATM-hálózaton megvalósított kommunikációs szolgáltatáscsoport, amely a LAN-emuláció alternatívájaként alkalmazható. Az IP/ATM kezelését két fő komponens végzi: az IP/ATM ügyfél és az IP/ATM kiszolgáló. Az IP/ATM kiszolgáló magába foglal egy ATM ARP kiszolgálót és egy csoportcímhozzárendelési kiszolgálót (MARS). Az IP/ATM hálózati komponensei egy kiszolgálón vagy egy ATM-kapcsolón találhatók meg.

Az IP/ATM használatának fő előnye, hogy gyorsabb, mint a LANE. IP/ATM használata esetén nem kerülnek kiegészítő fejlécinformációk a csomagokba a protokollveremben történő mozgás során. Ha az IP/ATM ügyfél létrehozott egy kapcsolatot, az adatok módosítás nélkül továbbíthatók.

Az IP/ATM támogatja a Dynamic Host Configuration protokoll (DHCP) kiszolgáló használatát az ATM-hálózatban.


Az IP/ATM működése

Az IP/ATM működésének három általános lépése a következő:

  • Ügyfélinicializálás
  • Ügyfélregisztráció
  • Adatátvitel

Az IP/ATM ügyfél indítása és regisztrálása statikus IP-címmel

A következő példa lépésről-lépésre ismerteti egy IP/ATM ügyfél IP/ATM kapcsolatának statikus IP-cím alkalmazásával történő létrehozását.

Ügyfélregisztráció
  1. Az A ügyfél inicializálódik, és ATM-címet kap az ATM-kapcsolótól.
  2. Az A ügyfél az ATM ARP/MARS kiszolgálóhoz kapcsolódik, majd csatlakozik az összcímes csoporthoz. Az A ügyfél IP-ATM címhozzárendelése hozzáadódik az ATM ARP kiszolgálón lévő adatbázishoz.
  3. Az A ügyfél kapcsolatba lép B ügyféllel, amely a hálózathoz kapcsolódó számítógép, és megkezdi az adatátvitelt.

Az IP/ATM ügyfél indítása és regisztrálása DHCP protokollal

A következő példa lépésről-lépésre ismerteti az IP-címet Dynamic Host Configuration protokoll (DHCP) segítségével megszerző IP/ATM ügyfél IP/ATM kapcsolatának létrehozását.

  1. Az ügyfél inicializálódik, és ATM-címet kap az ATM-kapcsolótól.
  2. Az ügyfél az ATM ARP/MARS kiszolgálóhoz kapcsolódik, majd csatlakozik az összcímes csoporthoz.
  3. Az ügyfél a csoportcímes kiszolgálóhoz csatlakozik, és elküldi a DHCP-kérelmet. A csoportcímes kiszolgáló a DHCP-kérelmet továbbítja az összcímes csoport valamennyi tagjához. A DHCP-kiszolgáló megkapja a kérelmet.
  4. A DHCP-kiszolgáló DHCP-választ küld a csoportcímes kiszolgálóhoz, amely a választ az összcímes csoporthoz továbbítja.
  5. Az ügyfél megkapja a DHCP-választ, majd regisztráltatja saját IP- és ATM-címét az ATM ARP/MARS kiszolgálón.
  6. Ezután az ügyfél képes más gazdaszámítógépekhez kapcsolódni és adatokat továbbítani.

Megjegyzés

  • A DHCP protokollal kapcsolatos további információ a DHCP weblapon található.

Összcímzés és csoportcímzés

Összcímzés vagy csoportcímzés alkalmazására kerül sor a kérelmet küldő ügyfél és a hálózat más számítógépei közötti "pont-több pont" rendszerű kapcsolat létesítésekor. Az IP/ATM alkalmazásával történő összcímes és csoportcímes küldés két módszerrel hajtható végre:

  • Közvetlen, "pont-több pont" rendszerű kapcsolat

    Ha az ügyfél összcímes vagy csoportos küldési IP-címre kíván IP-csomagot küldeni, kérelmet küld a MARS kiszolgálóhoz az IP-cím ügyféllista alapján történő feloldására. A MARS címcsoportot küld az ügyfélhez, amely így létrehozhat egy "pont-több pont" rendszerű kapcsolatot.

  • "Pont-több pont" rendszerű kapcsolat csoportcímes kiszolgálón keresztül

    A MARS csoportcímes kiszolgálóval is képes együttműködni. A Windows ATM ARP/MARS olyan integrált csoportcímes kiszolgálóval rendelkezik, amely a MARS kiszolgálóval egy vagy több csoportcímes csoportot regisztrál, és fogadja az egyes csoportcímes csoportok tagjainak MARS kiszolgálótól érkező listáját. A MARS mindig frissíti a csoportcímes kiszolgálót, amikor ügyfélmozgás (belépés vagy kilépés) történik a csoportcímes küldésű csoportban. Amikor az ügyfél csoportcímes vagy összcímes kérelmet küld a MARS kiszolgálóhoz, a MARS csak a csoportcímes kiszolgáló címét küldi vissza. Az ügyfél a csoportcímes kiszolgálóval lép kapcsolatba, amely "pont-több pont" rendszerű kapcsolatot létesít a csoportcímes csoporttal. A csoportcímes kiszolgáló a "pont-több pont" rendszerű kapcsolatot kezdeményező ügyfél által küldött csomagokat lemásolja és kiosztja a csoportcímes listán szereplő számítógépek között.


IP/ATM-komponensek

Az IP/ATM egy szolgáltatáscsoport, amelyhez egy IP/ATM ügyfél, valamint ATM ARP és MARS kiszolgálók tartoznak.

IP/ATM ügyfél

Az IP/ATM ügyfél telepített ATM-csatolóval rendelkező végponti számítógépen található. Az IP/ATM ügyfél tartalmazza azt a mechanizmust (rendszerint egy konfigurált címet), amellyel kapcsolatba léphet a MARS kiszolgálóval a csoportcímes csoporttal történő regisztráláshoz.

ATM ARP

Az ATM ARP kiszolgáló végzi a hálózaton található valamennyi ügyfél IP- és ATM-címét tartalmazó adatbázis karbantartását úgy, hogy a csoportcímes és összcímes IP-címeket ATM-címekké oldja fel. Az ATM ARP csak az egy címre történő küldést támogatja, amely lehetővé teszi, hogy az ügyfél pont-pont kapcsolatokat hozzon létre más számítógépekkel.

MARS

A csoportcímhozzárendelési kiszolgáló (MARS) olyan adatbázis karbantartását végzi, amely a hálózat valamennyi tagjának összcímes és csoportcímes címét tartalmazza. A MARS a címlistát közvetlenül az ügyfélnek küldheti, így az ügyfél "pont-több pont" rendszerű hívásokat telepíthet. Ha van elérhető csoportcím-kiszolgáló, akkor a MARS a csoportcím-kiszolgáló címét küldi el az ügyfélnek. Ebben az esetben az ügyfél kapcsolatba lép a csoportcím-kiszolgálóval, a kiszolgáló pedig "pont-több pont" típusú kapcsolatot létesít, majd az adatcsomagokat kiosztja a végpontoknak.

Megjegyzés

  • A Windows 2000 Server rendelkezik egy integrált csoportcím-kiszolgálót is magába foglaló ATM ARP/MARS kiszolgálóval.


Az ATM használata

A rész tartalma:

  • ATM-címzés
  • LAN-emuláció beállitása
  • Kapcsolt csatlakozások létesítése
  • Állandó kapcsolatok létesítése
  • Az ATM alapbeállításainak módosítása
  • Ismert címek


ATM-címzés

Az ATM-címek a kapcsolt virtuális csatlakozások (SVC-k) ATM-hálózaton történő használatának támogatásához szükségesek.

A legegyszerűbb szinten az ATM-címek 20 bájt hosszúak és három különböző részből állnak:

  • Hálózati előtag
    Az első 13 bájt azonosítja a hálózat egy bizonyos kapcsolatának helyét. Ennek a címrészletnek a használata a címformátumtól függően jelentősen különbözhet. Mindhárom szabványos ATM-címzési séma eltérő módon tartalmazza az ATM-kapcsolat helyeire vonatkozó információkat. Ezekben a sémákban megtalálható az adat ország/területkódjának (DCC) formátuma, a nemzetközi kódkijelölő (ICD) formátuma, valamint az E.164-es formátum, amelynek szélessávú ISDN-hálózatokban történő használatát az ITU-T javasolta a nemzetközi telefonszámozás vonatkozásában.
  • Csatoló médiahozzáférés-vezérlő címe
    A következő 6 bájt egy olyan fizikai végpontra (például egy adott ATM-csatolóra) utal, amely a hozzáférést szabályzó rétegcímet használ. Ezt a rétegcímet ténylegesen a gyártó rendeli hozzá az ATM hardverhez. Az ATM hardver médiahozzáférés-vezérlő címeinek használata és hozzárendelése ugyanúgy történik, mint az Ethernet, a Token Ring és más IEEE 802.x technológiák esetében.
  • Kiválasztó (SEL)
    Az utolsó bájt a fizikai ATM-csatolón lévő logikai kapcsolódási végpont kiválasztására szolgál. Annak ellenére, hogy valamennyi ATM-cím ehhez a háromrészes struktúrához igazodik, az első 13 bájt pontos formátumában jelentős eltéréseket okozhat az alkalmazott címzési formátum, illetve az, hogy nyilvános vagy saját ATM-hálózatról van-e szó.

A jelenleg széles körben használt három ATM címzési formátum (DCC, ICD és E.164) jellemzői a következők:

  • A Nemzetközi Szabványügyi Szervezet (ISO) nyílt rendszerek összekapcsolására vonatkozó (OSI) protokollgyűjteményben javasolt módon megfelelnek a hálózati szolgáltatáselérési pontra (NSAP) vonatkozó címzési tervezetnek.
  • Mindhárom formátum felhasználható kapcsolt virtuális csatlakozásokat (SVC-ket) támogató, saját ATM-hálózatok létesítésére és összekapcsolására.


LAN-emuláció beállítása

Az emulált LAN alapszolgáltatásai továbbra is az ATM-kapcsolón és az ATM-hardverrel telepített munkahelyeken maradnak. Ha az emulált LAN-hoz Ethernet vagy Token Ring hálózatot szeretne csatlakoztatni, bővítőeszközre van szükség.

LANE-komponens | Ahol a komponens megtalálható
LANE szolgáltatások | A LES, a LECS és a BUS rendszerint az ATM-kapcsolón marad.
LAN-emulációs ügyfél | A LAN-emulációs ügyfél a munkahelyeken, az ATM-kapcsolókon és a bővítőeszközökön helyezkedhet el.

Szolgáltatások

A LAN-emulációval kapcsolatos legtöbb beállítás a LAN-emulációs szolgáltatásokat futtató kapcsolón kerül megadásra. Ezek között a szolgáltatások között megtalálható a LAN-emulációs kiszolgáló (LES), a LAN-emuláció konfiguráció-kiszolgálója (LECS) és az üzenetszóró ismeretlen kiszolgáló (BUS). Az ATM-kapcsoló LANE szolgáltatásainak beállításáról további információ az ATM-kapcsoló dokumentációjában található. Ha ezekkel a szolgáltatásokkal kapcsolatban további információra van szüksége, kattintson a LANE-komponensek hivatkozásra.

Ügyfél

A LAN-emulációs ügyfél (LEC) a munkahelyeken, az ATM-kapcsolókon és a bővítőeszközökön helyezkedhet el. A LAN-emulációs ügyfél a Windows 2000 integrált részét képezi, és alapértelmezés szerint telepítésre kerül, ha a számítógépén rendelkezik telepített ATM hálózati csatolóval. A telepítés befejezése után minden olyan hálózati protokoll-illesztőprogram telepíthető és beállítható, amely Ethernet vagy Token Ring környezetben működik (például: TCP/IP, NetBEUI vagy IPX/SPX). A hálózati protokollok ATM ELAN kapcsolaton történő telepítéséről és beállításáról további információ a Kapcsolat konfigurálása című témakörben található. A LAN-emulációs ügyfél beállításával kapcsolatban további információ a LAN-emulációs ügyfél konfigurálása című témakörben található.


Kapcsolt csatlakozások létesítése

A kapcsolt csatlakozásokat a Windows 2000 ATM híváskezelő dolgozza fel, amely a virtuális adatáramkörök létrehozását és kezelését végzi. Az ATM ARP ügyfél és a LAN-emulációs ügyfél támogatja a kapcsolt virtuális adatáramkörök (SVC-k) használatát. A LAN-emulációs ügyfél és az ATM ARP ügyfél is az ATM Forum UNI specifikációján alapul.

LAN-emuláció kapcsolt virtuális adatáramkörökkel

Alapértelmezés szerint a Windows LAN-emulációs ügyfél kapcsolt virtuális adatáramköröket használ. Az ügyfelet a kapcsolt virtuális adatáramkörök használatához érvényes emulált LAN névvel kell konfigurálni. További információ a LAN-emulációs ügyfél konfigurálása című témakörben található.

IP/ATM használata kapcsolt virtuális áramkörökkel

Alapértelmezés szerint a Windows ATM ARP ügyfél kapcsolt virtuális adatáramköröket használ. Az ATM ARP ügyfelet az ATM ARP/MARS alhálózati címével kell konfigurálni. További információ a Speciális TCP/IP-ATM kapcsolat konfigurálása című témakörben található.


Állandó kapcsolatok létesítése

Az állandó virtuális kapcsolatokat (PVC) rendszerint a nagy szolgáltatók vagy egyetemi gerinchálózatok esetében alkalmazzák az ATM-hálózat virtuális kapcsolatainak fenntartására.

A Windows 2000 ATM Híváskezelő segítségével elvégezhető az állandó virtuális kapcsolatok (PVC-k) kézi telepítése emulált LAN környezetben vagy IP/ATM hálózatban. Az ATM Híváskezelő segítségével meghatározhatja minden egyes PVC tulajdonságait, beleértve a PVC definícióját, alkalmazási gyakorlatát és speciális tulajdonságait.

Állandó virtuális kapcsolat tulajdonsága | Leírás
Állandó virtuális kapcsolat definíciója | Adja meg a nevet, a virtuális elérési út azonosítóját, a virtuális adatáramkör azonosítóját és az ATM adaptációs réteget (AAL).
Alkalmazási gyakorlat | Adja meg az állandó virtuális kapcsolathoz alkalmazni kívánt alkalmazás típusát és ennek a PVC-nek az alapvető hívásmegfeleltetési jellemzőit.
Speciális tulajdonságok | Adja meg a Szolgáltatás minősége (QoS) eszköz adatátviteli és -fogadási paramétereit, valamint a hívásmegfeleltetés és a válaszmegfeleltetés meghatározott szintű protokolljait.

További információ az Állandó virtuális kapcsolat létrehozása ATM használatával című témakörben található.


Az ATM alapbeállításainak módosítása

Amikor ATM-csatolót telepít a számítógépre, a Windows 2000 ATM szolgáltatásainak alapértelmezett LAN-emulációs ügyfélkonfigurációja is automatikusan telepítésre kerül. A LAN-emulációs ügyfél a következő alapértelmezett emulált LAN (ELAN) csoportnév használatára van beállítva:

<meghatározatlan ELAN név>

A meghatározatlan_ELAN_név olyan alapértelmezett ELAN csoportnév, amely úgy van konfigurálva, hogy használható legyen egyrészt a Windows ATM-szolgáltatásokkal, másrészt az ATM kapcsolók többi forgalmazója által is. Lehetővé teszi a Windows 2000 operációs rendszert futtató számítógépek ATM LAN-emulációs ügyfélszolgáltatásainak egyszerűbb konfigurálását olyan ATM-kapcsolók révén, amelyek LAN-emulációs szolgáltatásokat biztosíthatnak az Ön hálózata számára.

Ha a meghatározatlan ELAN név nincs megfelelően beállítva, illetve azt alapértelmezés szerint nem támogatja más ATM hardvertermék (például a hálózatban használt más kapcsolók), az alábbi lehetőségek közül választhat:

  • Adjon hozzá egy másik, támogatott ELAN nevet az itt kezelt listához.
  • Konfigurálja a meghatározatlan ELAN nevet azokon az ATM-kapcsolókon, amelyek a LAN-emulációs szolgáltatást biztosítják a hálózata számára.

A LAN-emulációs ügyfél beállításának módosításával kapcsolatban további információ a LAN-emulációs ügyfél konfigurálása című témakörben található.


Ismert címek

Ismert LANE címek

A Windows LAN-emulációs ügyfelek (LEC) előzetes konfigurálása az ATM Forum LECS kiszolgálócím elérésére vonatkozó specifikációjában definiált jól ismert ATM-címmel és virtuális csatornával történt. A LEC ezeket a címeket az alábbi sorrendben használja:

  1. Próbálkozhat az ATM-protokollban definiált jól ismert LECS címmel.

4700790000000000000000000000A03E00000100
  2. Használhatja az ATM-protokollban definiált jól ismert virtuális csatornát.
  3. Lekérdezést végezhet az ILMI illesztő alkalmazásával.

IP/ATM előre konfigurált cím

A Windows ATM ARP ügyfelek előzetes konfigurálása a Windows ATM szolgáltatások ARP/MARS címeivel történt. Ez a cím a következő:

4700790001020000000000000000A03E00000200

Ez egy jól ismert E.164 cím, amelyet a Microsoft azért választott ki, hogy egyszerűsítse a konfigurálást, illetve fokozza az ATM ARP/MARS és az ATM szolgáltatásokat futtató más, Windows 2000 operációs rendszert használó számítógépek együttműködési képességét.


Forrásmunkák

A rész tartalma:

  • ATM-szabványok
  • ATM frissített technikai információ
  • ATM könyvjegyzék


ATM-szabványok

Az ATM hálózati alkalmazásaira vonatkozó szabványokat három fő csoport határozza meg: az ATM Forum, az IETF és az ITU-T.

ATM Forum

Az ATM Forum az ATM-hardvergyártókat, a hálózati szoftverfejlesztőket és a hálózati szolgáltatókat tömörítő non-profit szervezet, amelyen belül különböző munkacsoportok foglalkoznak az ATM-specifikációkkal.

Ha szeretne többet megtudni az ATM Forum működéséről és az ATM Technical Committee bizottságról, látogassa meg az ATM Forum webhelyet.(http://www.atmforum.com)

Internet Engineering Task Force (IETF)

Az IETF az Internet szabványosításával foglalkozó szervezet. Az IETF keretében működő IETF IP-over-ATM nevű munkacsoport dolgozta ki az IP-forgalom ATM-hálózatokon keresztül történő lebonyolításának szabványait. A következő táblázat az ATM-hálózaton keresztüli IP-forgalmat megvalósító RFC-ket tartalmazza.

RFC | Leírás
1483 | Multiprotocol encapsulation over ATM adaptation layer 5 (Többprotokollos beágyazás az 5. ATM-adaptációs rétegben)
1722 | RIP version 2 protocol applicability statement (A RIP protokoll 2-es verziójának alkalmazhatósági ismertetője)
1754 | IP over ATM Working Group's Recommendations for the ATM Forum's Multiprotocol BOF - Version 1 (Az IP over ATM munkacsoport ajánlásai az ATM Forum által kidolgozott Multiprotocol BOF 1-es verziójához)
1755 | ATM Signaling Support for IP over ATM (ATM jelzéstámogatás ATM-hálózaton keresztüli IP-forgalomhoz)
2022 | Support for Multicast over UNI 3.0/3.1 based ATM Networks (UNI 3.0/3.1 alapú ATM-hálózatokon keresztül történő csoportcímes küldés támogatása)
2225 | Classical IP and ARP over ATM (Hagyományos IP és ARP alkalmazása ATM-hálózatokon – ez az RFC érvényteleníti az RFC 1626 és az RFC 1577 dokumentumokban foglaltakat)

Az IETF munkacsoportról és az ATM-hálózatokon keresztüli IP-forgalomról bővebb felvilágosítást kaphat az IETF webhelyen.(http://www.ietf.org)

Nemzetközi Távközlési Szövetség, telekommunikációs szabványosítást végző részlege (International Telecommunication Union, Telecommunication Standardization Sector – ITU-T)

Az ITU-T határozza meg a világszerte alkalmazandó távközlési és szolgáltatási szabványokat. Az ITU-T dolgozta ki a nagy sávszélességű adatátviteli szolgáltatásokra vonatkozó B-ISDN és SONET szabványokat is.

Ha az ITU-T bizottsággal, valamint annak ajánlásaival kapcsolatban bővebb tájékoztatásra van szüksége, keresse fel az ITU-T webhelyét.(http://www.itu.int)

Megjegyzés


ATM frissített technikai információ

A Microsoft webhelyén található Személyes tanácsadó központ további információval szolgál az ATM-ről. Lásd: Frissített technikai információ.


ATM könyvjegyzék

Ha további információra van szüksége, olvassa el a következő kiadványokat:

K. Gadecki – C. Heckart: ATM for Dummies, 1977, Foster City: IDG Books Worldwide, Inc.

Ferguson, P. – G. Huston: Quality of Service: Delivering QoS on the Internet and in Corporate Networks, 1998, New York: John Wiley and Sons, Inc.

ATM User-Network Interface (UNI) Specification, ATM Forum, Inc., Foster City: Prentice Hall, Inc.


Hibaelhárítás

Mi a probléma?

A gazdaszámítógép nem tud csatlakozni az emulált LAN-hoz.

Ok: Az ügyfélnek és a kapcsolónak az ATM Forum UNI 3.1-es vagy 4.0-s specifikációiban megfogalmazott paraméterek szerinti felhasználó-hálózat (UNI) illesztőt kell futtatnia. Ellenkező esetben a kezdeti "pont-több pont" (PMP) rendszerű híváskezdeményezés nem működik, és nem jön létre kapcsolat. A Windows 2000 LAN-emulációs ügyfél (LEC) az ATM Forum UNI 3.1-es specifikációján alapul.

Megoldás: Az Atmadm segédprogrammal állapítsa meg, hogy hibás-e a híváskezdeményezés. Az Atmadm segédprogrammal figyelemmel kísérheti egy aszinkron adatátviteli módú (ATM) hálózaton az ATM híváskezelő által regisztrált kapcsolatokat és címeket. A segédprogram segítéségével megjelenítheti az ATM-csatolókon áthaladó bejövő és kimenő hívások adatait. Ha az Atmadm azt mutatja, hogy a jelző és ILMI virtuális adatáramkörök kevés adatcsomagot fogadnak, illetve egyáltalán nem fogadnak adatcsomagokat, akkor ellenőrizze a kapcsoló működőképességét. Például:

Signaling and ILMI packets sent     = 90718
Signaling and ILMI packets received = 0

Lásd még: ATM-kapcsolat adatainak megjelenítése és Atmadm példák.

A saját IP/ATM-hálózaton lévő gazdaszámítógépeket nem lehet elérni.

Ok: Ha egynél több ATM ARP/MARS kiszolgálót alkalmaz a hálózat minden egyes virtuális LAN hálózatához, akkor megszűnhet az ARP gyorsítótárak közötti szinkronizáció. Ennek következtében az ügyfelek csak az ugyanazon a kiszolgálón regisztrált ügyfelekkel tudnak kapcsolatba lépni. A más kiszolgálón regisztrált ügyfelek nem érhetők el.

Megoldás: Egy virtuális LAN-hoz csak egy ATM ARP/MARS kiszolgálót használjon.

Hardverhiba lép fel, amikor az ATM-csatoló megkísérli az inicializálást.

Ok: Az ATM-csatoló az IP/ATM és a LAN-emuláció (LANE) futtatását ugyanazon az alhálózaton végzi.

Megoldás: Az IP/ATM és a LAN-emuláció (LANE) külön alhálózatokon történő futtatását biztosító konfigurációt kell alkalmazni.