A Helyreállítási konzol parancsai

Az alábbi parancsok használhatók a Windows 2000 Helyreállítási konzolban:

  • Attrib

    • Módosítja egy fájl vagy könyvtár attribútumait.

  • Batch

    • Végrehajtja a szövegfájlban megadott parancsokat.

  • ChDir (Cd)

    • Megjeleníti az aktuális könyvtár nevét vagy megváltoztatja az aktuális könyvtárat.

  • Chkdsk

    • Ellenőrzi a lemezt és erről állapotjelentést jelenít meg.

  • Cls

    • Törli a képernyőt.

  • Copy

    • Átmásol egy fájlt egy másik helyre.

  • Delete (Del)

    • Töröl egy vagy több fájlt.

  • Dir

    • Megjeleníti a könyvtárban levő fájlok és alkönyvtárak listáját.

  • Disable

    • Letilt egy rendszerszolgáltatást vagy egy eszközillesztőt.

  • Diskpart

    • Kezeli a merevlemezek partícióit.

  • Enable

    • Elindít vagy engedélyez egy rendszerszolgáltatást vagy eszközillesztőt.

  • Exit

    • Kilép a Helyreállítási konzolból és újraindítja a számítógépet.

  • Expand

    • Kibont egy fájlt egy tömörített fájlból.

  • Fixboot

    • Egy új partíciós betöltőszektort ír a rendszerpartícióra.

  • Fixmbr

    • Helyreállítja a partíciós betöltőszektor fő rendszertöltő szektorát.

  • Format

    • Megformáz egy lemezt.

  • Help

    • Megjeleníti a Helyreállítási konzolban használható parancsok listáját.

  • Listsvc

    • Megjeleníti a számítógépen használható szolgáltatások és eszközillesztők listáját.

  • Logon

    • Bejelentkezés a Windows 2000 rendszerbe.

  • Map

    • Megjeleníti a meghajtók betűjelének hozzárendeléseit.

  • Mkdir (Md)

    • Létrehoz egy könyvtárat.

  • More

    • Megjelenít egy szövegfájlt.

  • Rename (Ren)

    • Átnevez egy fájlt.

  • Rmdir (Rd)

    • Töröl egy könyvtárat.

  • Set

    • Megjeleníti és beállítja a környezeti változókat.

  • Systemroot

    • A jelenleg használt rendszer gyökérkönyvtáraként állítja be az aktuális könyvtárat.

  • Type

    • Megjelenít egy szövegfájlt.

A Helyreállítási konzol elindításával és használatával kapcsolatos további tudnivalókat lásd a Kapcsolódó témakörökben. A Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás “Hogyan?” szakaszát.

Kapcsolódó témakörök


Flash memórialemez használata hibatűrő indítóeszközként

  1. Telepítse a flash memórialemezt a számítógépbe, ha még nincs telepítve. A flash lemezen a Windows 2000 rendszerben NTFS fájlrendszert kell kialakítani.
  2. Kattintson duplán az Asztalon a Sajátgép ikonra.
  3. A merevlemez gyökérkönyvtárából másolja át a flash lemezre az alábbi fájlokat. Boot.ini, Ntldr és Ntdetect.com.
  4. Kapcsoljon át a flash lemezre, a jobb oldali egérgombbal kattintson a Boot.ini fájlra, majd kattintson a Tulajdonságok parancsra.
  5. Törölje az Írásvédett jelölőnégyzetet, majd a Tulajdonságok párbeszédpanel bezárásához kattintson az OK gombra.
  6. A Jegyzettömb segédprogramban nyissa meg a Boot.ini fájlt, és módosítsa az alábbiak szerint:
    Az „rdisk(0)” kifejezést mindenhol cserélje ki az „rdisk(1)” kifejezésre.
    Ezen kívül ha a számítógépben SCSI-merevlemez található, akkor az „scsi(0)” kifejezést mindenhol cserélje ki a „multi(0)” kifejezésre.
  7. Mentse a módosításokat és zárja le a Boot.ini fájlt.
  8. Állítsa vissza újból a Boot.ini fájl Írásvédett attribútumát.
  9. Indítsa újra a számítógépet.
  10. Helyezze a flash memórialemezhez mellékelt hajlékonylemezt a lemezmeghajtóba.
  11. A parancssorba írja be a következőt:

    dupdate /win:d000 /s:doc121.exb /first

  12. Vegye ki a hajlékonylemezt a meghajtóból és indítsa újra a számítógépet.
  13. Telepítse a Helyreállítási konzolt. A Helyreállítási konzol használatával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • Az operációs rendszer mindig a flash memórialemezről indul annak ellenére, hogy az operációs rendszerhez tartozó legtöbb fájl a merevlemezen található. Ha hiba keletkezik a számítógép indulásakor, akkor a flash memórialemezről elindítható Helyreállítási konzol segítségével megpróbálhatja helyreállítani az operációs rendszert.
  • Ez a művelet az M-Systems DiskOnChip termékének használatához készült, amely a legújabb verziójú (1.21) beégetett kódú eszköz-illesztőprogramot tartalmazza, de esetleg más flash memórialemezekhez is használható.


Helyreállítási konzol – áttekintés

A Windows 2000 helyreállító konzol a Windows 2000 Telepítő programból indítható parancssori konzol. A Helyreállítási konzol segítségével elindíthatók és leállíthatók a szolgáltatások, formázhatók a meghajtók, a helyi lemezről (NTFS fájlrendszerrel megformázott meghajtókról is) olvashatók és oda írhatók az adatok és számos egyéb adminisztrációs feladat végezhető el. A Helyreállítási konzol különösen hasznos, ha a rendszert a hajlékonylemezről vagy CD-ROM-ról történő másolással akarja visszaállítani, vagy ha át kell konfigurálni a számítógép megfelelő indítását akadályozó szolgáltatást. Mivel a Helyreállítási konzol meglehetősen hatékony, ezért használata kizárólag olyan tapasztalt felhasználók számára ajánlott, akik alaposan ismerik a Windows 2000 operációs rendszert. Ráadásul a Helyreállítási konzolt csak rendszergazda használhatja.

A Helyreállítási konzol kétféleképpen indítható el:

  • Ha a számítógép nem indul el, akkor a Helyreállítási konzol a Windows 2000 Telepítő lemezekről vagy a Windows 2000 Professional CD-ről futtatható (ha a számítógép indítható a CD-ROM-meghajtóról).
  • Alternatív lehetőségként a Helyreállítási konzol telepíthető a számítógépre, hogy használható legyen amikor a Windows 2000 nem indítható el. Ezt követően az operációs rendszerek listájában kiválasztható a Helyreállítási konzol kívánt beállítása.

A Helyreállítási konzol elindítását követően ki kell választani azt a meghajtót, amelyre csatlakozni akar (kettős betöltésű vagy többszörös betöltésű rendszer esetén), majd rendszergazdai jelszóval kell bejelentkezni.

A Helyreállítási konzol elindításával és használatával kapcsolatos további tudnivalókért lásd a Kapcsolódó témaköröket. Ezen kívül a Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás Útmutató szakaszát.

A Helyreállítási konzol futtatásakor a használható parancsokkal kapcsolatos tudnivalókról a parancssorba a help parancs beírásaval kérhető segítség.


Helyreállító lemez létrehozása

  2. Kattintson az Eszközök menü Biztonsági helyreállító lemez készítése parancsára.
  3. Kövesse a képernyőn megjelenő utasításokat.

Fontos

  • A Helyreállító lemez elkészítéséhez egy üres, 1,44 MB kapacitású hajlékonylemez szükséges.
  • A visszaállítási folyamat a rendszergyökér\repair mappában tárolt adatokra épül. Ezt a mappát nem szabad módosítani vagy törölni.

Megjegyzések

  • A Biztonsági másolat készítése a rendszerleíró adatbázisról is, a helyreállítási könyvtárba jelölőnégyzet kiválasztásával az aktuális rendszerleíróadatbázis-fájlok elmenthetők a rendszergyökér/repair mappába. Ez hasznos a rendszer helyreállításához a merevlemez meghibásodása esetén.
  • További tudnivalók is elérhetők a helyreállítási folyamattal kapcsolatban. A Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás “Hogyan?” szakaszát.


A Helyreállítási konzol törlése

  1. Indítsa újra a számítógépet.
  2. Kattintson duplán előbb a Sajátgép ikonra, majd arra a merevlemezre, amelyre telepítette a Helyreállítási konzolt.
  3. Kattintson az Eszközök menüben a Mappa beállításai parancsra.
  4. Kattintson a Nézet fülre.
  5. Kattintson a Rejtett fájlok és mappák megjelenítése elemre, törölje a Az operációs rendszer védett fájljainak elrejtése jelölőnégyzetet, majd kattintson az OK gombra.
  6. A gyökérkönyvtárban törölje a \Cmdcons mappát.
  7. A gyökérkönyvtárban törölje a Cmldr fájlt.
  8. A gyökérkönyvtárban a jobb oldali egérgombbal kattintson a Boot.ini fájlra, majd a Tulajdonságok parancsra.
  9. Törölje az Írásvédett jelölőnégyzetet, majd kattintson az OK gombra.
  10. A Jegyzettömb segédprogramban nyissa meg a Boot.ini fájlt és törölje a Helyreállítási konzolhoz tartozó bejegyzést. A bejegyzés az alábbihoz hasonló:

    C:\cmdcons\bootsect.dat="Microsoft Windows 2000 Recovery Console" /cmdcons

  11. Mentse a fájlt és zárja be.

Figyelmeztetés

  • A Boot.ini fájl helytelen módosítása esetén előfordulhat, hogy a számítógép nem indul újra. Kizárólag a Helyreállítási konzol bejegyzését törölje.

Megjegyzések

  • A fenti műveletek befejezése után javasolt a Boot.ini fájl „írásvédett” attribútumának visszaállítása. Ezt követően ismét elrejtheti a rendszerfájlokat.


A helyreállító folyamat használata, ha a rendszer nem indul

A Windows 2000 helyreállító funkcióival javíthatók azok a hibák, amely miatt a számítógép nem indul. Ezt okozhatja a rendszerleíró-adatbázis, a rendszerfájlok, a partíciós betöltőszektor és a indítási környezet hibája. A helyreállító műveletekkel azonban nem javítható a rendszer, ha nincs a Biztonsági mentés segédprogrammal készíthető Biztonsági helyreállító lemez. Megpróbálhatja használni a helyreállító folyamatot akkor is, ha nem készített Biztonsági helyreállító lemezt, de ilyenkor előfordulhat, hogy a helyreállító folyamat nem képes a hibákat javítani.

A helyreállító folyamat általában a következő lépésekből áll:

A Windows 2000 Telepítő lemezek vagy CD segítségével indítsa el a számítógépet

A rendszer elindítható a Windows 2000 telepítőlemezek vagy a Windows 2000 CD segítségével. A számítógép azonban csak akkor indítható a CD segítségével, ha a számítógépben levő hardver és BIOS támogatja ennek a szolgáltatásnak a használatát.

Telepítés közben válassza a helyreállítás beállítást

A számítógép elindulása után elindul a Telepítő program. Telepítés közben meg kell adni, hogy folytatja-e a Windows 2000 operációs rendszer telepítését. A folytatáshoz le kell ütnie az ENTER billentyűt. Ez elindítja a telepítést, amely lehetővé teszi a rendszer helyreállítását. A folyamat közben kiválasztható, hogy a Windows 2000 egy új változatát akarja-e telepíteni vagy a jelenleg telepített Windows 2000 rendszert akarja-e helyreállítani. A sérült vagy hibás rendszer helyreállításához az R billentyűt kell megnyomnia. Ezután ki kell választania, hogy a Helyreállítási konzol vagy a helyreállító folyamat segítségével akarja-e a rendszert helyreállítani. Ha a helyreállító folyamat segítségével akarja a helyreállítást elvégezni, akkor az R billentyűt kell leütnie.

Válassza ki a helyreállítás típusát

Választható a legkönnyebben végrehajtható, felhasználói közbeavatkozást nem igénylő gyors helyreállítás vagy a felhasználó közreműködését igénylő kézi helyreállítás. A gyors helyreállítás megpróbálja helyreállítani a rendszerleíró-adatbázissal, rendszerfájlokkal, az indítóköteten található partíciós betöltőszektorral és az indítási környezettel (kettős betöltésű vagy többszörös betöltésű rendszer esetén) kapcsolatos hibákat. A kézi helyreállítás során kiválasztható, hogy a rendszerfájlokat, partíciós betöltőszektorral vagy az indítási környezettel kapcsolatos hibákat akarja helyreállítani, de nem teszi lehetővé a rendszerleíró-adatbázis hibáinak javítását. Például ha tudja, hogy a partíciós betöltőszektor és az indítási környezet sértetlen, akkor a kézi helyreállítással megpróbálhatja kizárólag a rendszerfájlokat helyreállítani.

Megjegyzések

  • A kézi helyreállítás használata kizárólag a tapasztalt felhasználók vagy a rendszergazdák számára javasolt.
  • A gyors helyreállítás a rendszeren a Telepítő legelső futtatásakor a rendszerleíró-adatbázisról készített biztonsági másolatot használja. Ennek a helyreállítási módnak a választása esetén elveszhetnek a Telepítő legelső futtatása óta kiválasztott beállítások.
  • Ha az egyes rendszerleíróadatbázis-fájlokat kézzel akarja helyreállítani vagy ki akarja cserélni a teljes rendszerleíró-adatbázist, akkor használja a Helyreállítási konzolt. Azonban ez csak a tapasztalt felhasználók számára javasolt.

Indítsa el a helyreállítást

A helyreállító folyamat elindításához szükséges a Biztonsági mentés segédprogrammal készített 1,44 MB-os Biztonsági helyreállító lemez és az eredeti Windows 2000 telepítő CD. A helyreállító folyamat akkor is megkísérelheti megkeresni a telepített Windows 2000 rendszert és elkezdeni a helyreállítást, ha nincs Biztonsági helyreállító lemez, de előfordulhat, hogy sikertelen lesz a folyamat.

Megjegyzés

  • Ha a helyreállító folyamat nem képes a rendszer helyreállítására, akkor használhatja még a Helyreállító konzolt vagy megpróbálhatja újratelepíteni a Windows 2000 rendszert. További tudnivalókért lásd a Kapcsolódó témaköröket.

A számítógép újraindítása

Ha a helyreállítási folyamat sikeres volt, akkor a számítógép automatikusan újraindul, és a rendszer használható.

További tudnivalók is elérhetők a helyreállítási folyamattal kapcsolatban. A Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás “Hogyan?” című szakaszát.

Fontos

  • A helyreállítási folyamat a rendszergyökér\repair mappában tárolt adatokra épül. Ezt a mappát nem szabad módosítani vagy törölni.


A Helyreállítási konzol telepítése indítási beállításként

  1. A Windows futása közben helyezze a Windows 2000 Professional CD-t a CD-ROM-meghajtóba.
  2. Kattintson a Nem gombra, amikor a rendszer a Windows 2000 frissítésének kiválasztását kéri.
  3. A parancssorban váltson a CD-ROM-meghajtóra, majd írja be az alábbiakat:

    \i386\winnt32.exe /cmdcons

  4. Kövesse a képernyőn megjelenő utasításokat.

Megjegyzések

  • A Helyreállítási konzol futtatásához újra kell indítani a számítógépet és ki kell választani a Helyreállítási konzol parancsot a használható operációs rendszerek listájából.
  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Helyreállítási konzolban használható parancsok listája a parancssorba a help parancs beírásával jeleníthető meg.
  • A Csoportházirend beépülő modulban a Helyreállítási konzol: Automatikus felügyeleti bejelentkezés attribútum megadásával biztosítható, hogy a felhasználó bejelentkezés nélkül futtathassa a Helyreállítási konzolt. Ez az attribútum a konzolon megjelenő fán a Helyi számítógép házirend/Számítógép konfigurációja/Windows beállításai/Biztonsági beállítások/Helyi házirend/Biztonsági beállítások bejegyzésnél található.
  • Ha a számítógép nem indul el, akkor a Helyreállítható konzol a Windows 2000 Professional CD-ről (ha a számítógépben a rendszer indítására alkalmas CD-ROM-meghajtó van) vagy a Telepítő lemezekről futtatható. Abban az esetben, ha a számítógép nem indul, akkor a Helyreállítási konzol futtatásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Javítás – áttekintés

A Windows 2000 számos olyan szolgáltatást tartalmaz, amellyel helyreállítható az indulásra vagy a Windows 2000 betöltésére képtelen rendszer. Ezek a szolgáltatások hasznosak a rendszerfájlok meghibásodásakor, véletlenszerű törlésekor vagy egy a rendszer meghibásodását eredményező szoftver vagy eszközillesztő telepítésekor.

Csökkentett mód

A csökkentett mód lehetővé teszi a rendszer indítását minimális számú eszközillesztő betöltésével és szolgáltatás elindításával. Például ha egy újonnan telepített eszközillesztő vagy program következtében a számítógép nem indul el, akkor a számítógép elindítható csökkentett módban, majd eltávolítható a rendszerről a hibát okozó szoftver vagy illesztőprogram. A csökkentett mód nem működik minden esetben, például ha a rendszerfájlok sérülnek meg vagy hiányoznak, illetve ha a merevlemez sérült vagy hibásodott meg. A csökkentett módról részletes tudnivalók A csökkentett mód indítási beállításai című részben olvashatók.

Windows 2000 helyreállító konzol

A Helyreállítási konzol szolgáltatás minimális számú parancssori parancs kiadására használható parancssori felületet biztosít a rendszer helyreállításához. Például a Helyreállítási konzol segítségével engedélyezhetők vagy letilthatók a szolgáltatások, helyreállítható a megsérült fő rendszertöltő rekord (master boot record) vagy egy hajlékonylemezről vagy CD-ROM-ról átmásolhatók a rendszerfájlok. Ez a – kizárólag tapasztalt felhasználók és rendszergazdák által használható – szolgáltatás biztosítja a legteljesebb körű helyreállítást.

Helyreállítás a Helyreállító lemez segítségével

A Biztonsági helyreállító lemez segítséget nyújt a rendszerfájlokkal, az indítási környezettel (kettős betöltésű, vagy többszörös betöltésű rendszer esetén), és az indítóköteten található partíciós betöltőszektorral kapcsolatos hibák helyreállításában. A rendszer csak a Biztonsági helyreállító lemez létrehozása után állítható helyre a Helyreállító lemez funkcióval. Ez a Biztonsági mentés segédprogrammal végezhető el. Ha nem hozott létre Biztonsági helyreállító lemezt és ennek ellenére megpróbálja használni a Helyreállító lemez funkciót, akkor a rendszeren végzett módosítások (például a szervizcsomag frissítések) elveszhetnek és szükséges lehet az újratelepítésük.

A Windows 2000 egy sérült Windows 2000 rendszeren is újratelepíthető. Ez időigényes művelet lehet, de hasznos, ha a helyreállító folyamat nem oldja meg a problémát. A rendszer újratelepítésekor elveszhetnek a rendszer módosításai (például a szervizcsomag frissítések) és újra kell telepíteni ezeket a frissítéseket.


A Helyreállítási konzol futtatása, ha a rendszer nem indul

  1. Helyezze a (3,5 hüvelykes) Windows 2000 Professional Telepítő lemezt a lemezmeghajtóba vagy ha a CD-ROM meghajtó alkalmas a rendszer indítására, akkor helyezze a Windows 2000 Professional CD-t a CD-ROM-meghajtóba.
  2. Indítsa újra a számítógépet.
  3. Kövesse a képernyőn megjelenő útmutatást. A Telepítő lemezek használata esetén a rendszer kéri a Telepítő lemezek behelyezését a lemezmeghajtóba. A fájlok betöltése néhány percet igénybe vehet. Válassza a Windows 2000 telepítését helyreállító beállítást, majd végül indítsa el a Helyreállítási konzolt.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Helyreállítási konzolban használható parancsok listája a parancssorba a help parancs beírásával jeleníthető meg.
  • A Helyreállítási konzol telepíthető is a számítógépre, így ekkor mindig használható. A Helyreállítási konzol használatával kapcsolatos tudnivalókért lásd a Kapcsolódó témaköröket.