Felhasználói profilok

A felhasználói profilok automatikusan létrehozzák és karbantartják a helyi számítógép egyes felhasználóinak munkakörnyezetét biztosító Asztal beállításait.

  • Azokról a szolgáltatásokról, amelyek helye a Windows 2000 Server operációs rendszerben megváltozott, a következő témakörben olvashat: Megszokott feladatok végrehajtásának új módjai.
  • A felhasználói profilok használatával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat. Útmutató.
  • Az általános tudnivalókat a következő témakörben tekintheti meg: Fogalmak.


Megszokott feladatok végrehajtásának új módjai

Az alábbi táblázat a Windows NT 4.0 rendszerből már ismert, felhasználói profilokkal kapcsolatos feladatokat és a Windows 2000 azonos feladatait hasonlítja össze.
Cél | Windows NT 4.0 operációs rendszerben | Windows 2000 operációs rendszerben
Elérési út hozzáadása felhasználói profilhoz | Felhasználókezelő a Felügyeleti eszközökben | Active Directory – felhasználók és csoportok, majd kattintás a Felhasználók elemre
Felhasználói profil tartalmának megtekintése | Winnt/Profilok, Felhasználó mappa | Windows Intéző. A profilok a Documents and Settings mappa Felhasználó mappájában találhatók.
Felhasználói profil másolása | A Vezérlőpult Rendszer segédprogramja | Rendszertulajdonságok párbeszédpanel, majd kattintás a Felhasználói profilok fülre
Kezdőkönyvtár hozzáadása elérési úthoz | Felhasználókezelő a Felügyeleti eszközökben. | Active Directory – felhasználók és csoportok, majd kattintás a Felhasználók elemre
Bejelentkezési parancsfájl hozzáadása felhasználói profilhoz | Felhasználókezelő a Felügyeleti eszközökben | Az Active Directory - felhasználók és csoportok eszközön keresztül elért Csoportházirend. További információkért olvassa el a Felhasználói bejelentkezési parancsfájl hozzárendelése című témakört.


Gyakorlati tanácsok

  • Különböző hardverkonfigurációk figyelembe vétele

    Mivel a felhasználói profilok több számítógépen is használhatók, szem előtt kell tartani, hogy a különböző számítógépek különböző hardverkonfigurációval rendelkezhetnek, különös tekintettel a videokártyákra és a monitorokra.

    A felhasználói profil a képernyő elhelyezkedését és az ablakok méretét is meghatározza, így a számítógépben lévő megjelenítési hardver is hatással van a felhasználói profil működésére. Például egy Super VGA monitorral rendelkező számítógéphez kialakított felhasználói profil ablakbeállítása hagyományos VGA monitorral rendelkező számítógépen helytelenül jelenhet meg.

  • Felhasználói profilok létrehozása és szerkesztése
    Ha egyetlen felhasználó számára készít vagy szerkeszt felhasználói profilt, olyan számítógépet használjon, amely a felhasználó által leggyakrabban használt számítógép megjelenítési hardverével azonos konfigurációval rendelkezik.
  • Kötelező felhasználói profil létrehozása több felhasználó számára
    Ha több felhasználó számára hoz létre kötelező felhasználói profilt, csak akkor készítsen egyetlen felhasználói profilt a csoport minden tagja számára, ha mindegyikük azonos megjelenítési hardverrel rendelkező számítógépet használ.


Útmutató

  • Központi felhasználói profil létrehozása
  • Felhasználói profil másolása a kiszolgálóra
  • Felhasználói profil törlése
  • Előre beállított központi felhasználói profil létrehozása
  • Kötelező felhasználói profil létrehozása
  • Kezdőkönyvtár hozzáadása profilhoz


Központi felhasználói profil létrehozása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A részleteket megjelenítő ablaktáblában kattintson a megfelelő felhasználói fiókra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • megfelelő tartomány
    • megfelelő tároló (például Felhasználók)
    • megfelelő felhasználói fiók
  3. Kattintson a Tulajdonságok parancsra.
  4. Kattintson a Tulajdonságok párbeszédpanel Profil lapjára.
  5. A Profil elérési útja mezőben adja meg az útvonalat.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Használjon teljes elérési utat minden felhasználói fiók esetében.

    • \\kiszolgáló\megosztás\%felhasználónév%

  • A felhasználói profil elérési útja bármelyik kiszolgálón lehet, annak nem szükséges tartományvezérlőnek lennie. A felhasználó bejelentkezésekor a Windows ellenőrzi, hogy a felhasználói fiók tartalmazza-e a felhasználói profil elérési útját. Ha igen, a rendszer megkeresi a felhasználói profilt, majd a helyi számítógépre másolja.
  • A felhasználói fiók bármilyen szervezeti egységben vagy tárolóban létrehozható a tartományon belül. A felhasználói fiók alapértelmezett helye a Felhasználók mappa.
  • A Windows 2000 központi felhasználói profilok esetén nem támogatja a titkosított fájlok használatát.
  • A Terminálszolgáltatások ügyfeleivel használt központi felhasználói profilokat a rendszer nem replikálja a kiszolgálóra addig, amíg az interaktív felhasználó ki nem lép, és be nem zárja az interaktív munkamenetet.

Kapcsolódó témakörök


Felhasználói profil másolása a kiszolgálóra

  1. Nyissa meg a Rendszertulajdonságok párbeszédpanelt, majd kattintson a Felhasználói profilok fülre.
  2. A Felhasználói profilok lapon kattintson arra a felhasználói profilra, melyet másolni kíván.
  3. Kattintson a Másolás gombra, majd adja meg a célmappa nevét, vagy keresse meg azt a hálózaton.

Megjegyzések

  • Az itt megadott helynek egyeznie kell az Active Directoryban szereplő, a felhasználói fiókra vonatkozó Felhasználói profil bejegyzéssel.
  • A felhasználói profilok másolására a Windows Intéző vagy hasonló fájlkezelő segédprogram nem használható.
  • Ezt az eljárást célszerű használni akkor is, ha profilt kíván kiadni egy meghatározott felhasználó számára, vagy ha alapértelmezett felhasználói profilt szeretne előkészíteni a hálózaton a tartomány új felhasználói számára.
  • Felhasználói profilok másolásakor a Másolás párbeszédpanelen ossza meg a profilt a Mindenki csoporttal. Ennek hatására a felhasználói profil minden számítógép Default User (Hálózat) mappájába letöltődik, amikor a számítógépeket elindítják.

Kapcsolódó témakörök


Felhasználói profil törlése

  1. Nyissa meg a Rendszertulajdonságok párbeszédpanelt.
  2. A Rendszertulajdonságok párbeszédpanelen kattintson a Felhasználói profilok fülre.
  3. Kattintson az eltávolítani kívánt profilra, majd az Eltávolítás gombra.

Megjegyzések

  • A központi felhasználói profilok eltávolításához a rendszergazdának át kell vennie a mappa tulajdonjogát, majd törölnie kell a mappát.

Kapcsolódó témakörök


Előre beállított központi felhasználói profil létrehozása

  1. Nyissa meg a Rendszertulajdonságok párbeszédpanelt.
  2. A Rendszertulajdonságok párbeszédpanelen kattintson a Felhasználói profilok fülre.
  3. A számítógépen tárolt profilok listában kattintson a másolni kívánt profilra.
  4. Kattintson a Másolás gombra, majd adja meg a célmappa nevét, vagy keresse meg azt a hálózaton.
  5. Ha módosítani kívánja azokat a felhasználókat vagy csoportokat, melyek a felhasználói profilt használhatják, kattintson a Módosítás gombra.

Megjegyzések

  • A felhasználói profilok másolása csak akkor engedélyezett, ha a Windows 2000 rendszerbe rendszergazdaként jelentkezett be.
  • Ne hozzon létre olyan helyi felhasználói profilt ezzel az eljárással, mely a Documents and Settings mappára mutat.
  • Amikor a felhasználó először jelentkezik be, nem az alapértelmezett profil, hanem az előre beállított felhasználói profil másolatát kapja meg a kiszolgálóról. Ezt követően a felhasználói profil ugyanúgy működik, mint egy egyszerű központi felhasználói profil. Ha a felhasználó kilép, a rendszer helyileg menti a felhasználói profilt, valamint a kiszolgálón is készít egy másolatot róla.
  • A Windows 2000 központi felhasználói profilok esetén nem támogatja titkosított fájlok használatát.
  • A Terminálszolgáltatások ügyfeleivel használt központi felhasználói profilokat a rendszer nem replikálja a kiszolgálóra addig, amíg az interaktív felhasználó ki nem lép, és be nem zárja az interaktív munkamenetet.

Kapcsolódó témakörök


Kötelező felhasználói profil létrehozása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A részleteket megjelenítő ablaktáblában kattintson a megfelelő felhasználói fiókra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • megfelelő tartomány
    • megfelelő tároló (például Felhasználók)
    • megfelelő felhasználói fiók
  3. Kattintson a Tulajdonságok parancsra.
  4. Kattintson a Tulajdonságok párbeszédpanel Profil lapjára.
  5. A Profil elérési útja mezőbe írja be az elérési utat, és a tegye a végére a .man fájlnévkiterjesztést.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Használjon teljes elérési utat minden felhasználói fiók esetében.

    • \\kiszolgáló\megosztás\%felhasználónév%.man

    A megosztáshoz hozzon létre egy mappát Profilok néven (ha ilyen még nem létezik), majd ossza meg a mappát a hitelesített felhasználókkal. Olyan elérési engedélyeket adjon, melyek csak olvasást tesznek lehetővé. A megosztást a felhasználói profil engedélyezése előtt kell elkészíteni.

  • A kötelező profilok létrehozásánál győződjön meg arról, hogy beállította-e a megfelelő hozzáférési engedélyeket a profilt használó felhasználó vagy felhasználói csoport számára.
  • Kötelező felhasználói profil a Windows Intéző segítségével is létrehozható, ha az ntfelhasználó.dat fájlt átnevezi ntfelhasználó.man fájllá.
  • A kötelező felhasználói profil egy előre megadott beállításokkal rendelkező felhasználói profil. A felhasználók továbbra is módosíthatják az Asztalt, de a változtatásokat a rendszer kilépéskor nem menti. A következő bejelentkezéskor a számítógép ismét letölti a kötelező felhasználói profilt. A felhasználói profilok akkor válnak kötelezővé, amikor a kiszolgálón lévő NTfelhasználó.dat fájlt átnevezi NTfelhasználó.man fájllá. A fájlkiterjesztés megváltoztatásával a felhasználói profil írásvédetté válik.
  • Egy kötelező felhasználói profil tetszőleges számú felhasználóhoz hozzárendelhető.

Kapcsolódó témakörök


Kezdőkönyvtár hozzáadása profilhoz

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot.
  2. A részleteket megjelenítő ablaktáblában kattintson a megfelelő felhasználói fiókra.

    Helye:

    • Active Directory - felhasználók és számítógépek
    • megfelelő tartomány
    • megfelelő tároló (például Felhasználók)
    • megfelelő felhasználói fiók
  3. Kattintson a Tulajdonságok parancsra.
  4. Kattintson a Tulajdonságok párbeszédpanel Profil lapjára.
  5. A Kezdőkönyvtár mezőbe írja be a könyvtárra vonatkozó információkat.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek ablak megnyitásához mutasson a Start menü Programok pontjára, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • A Windows 2000 Asztalon található Dokumentumok mappa alternatívát jelent a kezdőkönyvtárak mellett, de nem helyettesíti azokat. Minden felhasználó rendelkezik Dokumentumok mappával saját felhasználói profiljában.
  • A Dokumentumok mappa célhelye a következő módon változtatható meg: a jobb gombbal kattintson az Asztalon található ikonra, kattintson a Tulajdonságok parancsra, majd adja meg az új helyet a Cél mezőben.
  • A Csoportházirend segítségével megváltoztatható az egyes felhasználókhoz tartozó Dokumentumok mappa célhelye, megvonható a célhely megváltoztatásának joga a felhasználótól, eltávolítható a Dokumentumok mappa az Asztalról, illetve megadható, hogy a programok a Dokumentumok mappát használják-e alapértelmezett fájlmegnyitási és -mentési helyként.
  • Ha nincs hozzárendelt kezdőkönyvtár, a rendszer az alapértelmezett (a \Users\Default nevű, a felhasználó Windows-frissítést tartalmazó helyi merevlemezén, első telepítés esetén a Windows 2000 gyökérkönyvtárában található) helyi kezdőkönyvtárat rendeli a felhasználói fiókhoz. A kezdőkönyvtár és a Dokumentumok mappa azonos helyen is lehet.
  • A Windows 2000 Terminálszolgáltatások használata esetén a felhasználói profil az alapértelmezett kezdőkönyvtár.

Kapcsolódó témakörök


Fogalmak

Ez a rész a felhasználói profilokkal kapcsolatban nyújt általános háttérinformációkat.

  • Felhasználói profilok – áttekintés
  • A felhasználói profilok ismertetése
  • A felhasználói profilok használata
  • Forrásmunkák


Felhasználói profilok – áttekintés

A Windows 2000 rendszert futtató számítógépek felhasználói profiljai automatikusan létrehozzák és karbantartják a helyi számítógép egyes felhasználóinak munkakörnyezetét biztosító Asztal beállításait. Amikor egy felhasználó először jelentkezik be egy számítógépbe, a rendszer létrehozza számára a felhasználói profilt.

A felhasználói profilok használata az alábbi előnyöket nyújtja:

  • Ugyanazt a számítógépet több felhasználó is használhatja különböző asztalbeállításokkal.
  • Bejelentkezéskor a felhasználó megkapja azokat az asztalbeállításokat, melyek kilépéskor léteztek a számítógépen.
  • Ha valamelyik felhasználó módosítja az Asztal beállításait, az a többi felhasználó beállításaira nincs hatással.
  • A felhasználó profilok kiszolgálón is tárolhatók, így azok a hálózat bármelyik számítógépén felhasználhatók, melyek Windows NT 4.0 vagy Windows 2000 rendszert futtatnak. Ezeket központi felhasználói profilnak nevezzük.

Felügyeleti eszközként a felhasználói profilok az alábbi lehetőségeket biztosítják:

  • Létrehozható egy alapértelmezett felhasználói profil, mely a felhasználó feladatainak megfelelően van kialakítva.
  • Kötelező felhasználói profil hozható létre, amely nem menti a felhasználó által végrehajtott változtatásokat az Asztalon. A felhasználók módosíthatják az Asztal beállításait munka közben, de kilépéskor a rendszer azokat nem menti. A kötelező profil beállításai minden alkalommal letöltődnek a helyi számítógépre, amikor a felhasználó bejelentkezik a rendszerbe. Ha további információkra van szüksége a kötelező profilokról, olvassa el a Kötelező felhasználói profil létrehozása című témakört.
  • Megadhatók az alapértelmezett felhasználói beállítások, melyek minden egyes felhasználói profilban szerepelni fognak.

A felhasználói profilok típusai

A felhasználói profilok az Asztal környezetét határozzák meg, beleértve a megjelenítési beállításokat, hálózati kapcsolatokat, nyomtatókat és más beállításokat. Az Asztal környezetét a felhasználó vagy a rendszergazda állíthatja be.

A felhasználói profilok típusai:

  • Helyi felhasználói profil. A helyi felhasználói profil az első bejelentkezéskor jön létre a számítógép helyi merevlemezén. A helyi felhasználói profilon végzett módosítások csak az adott számítógépre érvényesek.
  • Központi felhasználói profil. A központi felhasználói profilt a rendszergazda hozza létre a kiszolgálón. Az ilyen profilok a hálózat bármely számítógépéről elérhetők. A központi felhasználói profilon végzett változtatásokat a rendszer menti a kiszolgálóra.
  • Kötelező felhasználói profil. A kötelező felhasználói profil egy olyan központi felhasználói profil, mellyel meghatározott beállítások adhatók meg a felhasználók vagy felhasználói csoportok számára. A kötelező felhasználói profilokat csak a rendszergazdák módosíthatják.


A felhasználói profilok ismertetése

A rész tartalma:

  • A felhasználói profilok tartalma
  • A felhasználói profilokban mentett beállítások


A felhasználói profilok tartalma

A felhasználói profilok alapját a Default User felhasználói profil másolata képezi, amely minden (Windows 2000 rendszert futtató) számítógépen megtalálható. A Default User profilban lévő NTuser.dat fájl a beállításokat a Windows 2000 rendszerleíró adatbázisából jeleníti meg. A felhasználói profilok a közös programcsoportokat is használják, melyek az All Users mappában találhatók.

A felhasználó profilok mappái az Asztal különböző elemeire mutató hivatkozásokat tartalmaznak.

Felhasználói profil mappája | Tartalom
Application data | Az egyes programokra vonatkozó adatok (például egyéni szótár). A felhasználói profil mappájában tárolandó adatokat a programok készítői határozzák meg.
Cookies | A felhasználói információk és beállítások.
Asztal | Az Asztal elemei (fájlok, parancsikonok és mappák).
Kedvencek | Az Internet leggyakrabban használt helyeire mutató parancsikonok.
Local Settings | Az Application data, History és Temporary mappák fájljai. Az alkalmazásadatok a központi felhasználói profilok által bármely számítógépről elérhetők.
Dokumentumok | Felhasználói dokumentumok.
Képek | Felhasználói képek.
NetHood | A Hálózati helyek elemeire mutató parancsikonok.
PrintHood | A nyomtató mappa elemeire mutató parancsikonok.
Recent | Az utoljára használt dokumentumokra és elért mappákra mutató parancsikonok.
SendTo | Dokumentumkezelő segédprogramokra mutató parancsikonok.
Start menu | Különböző programokra mutató parancsikonok.
Sablonok | Felhasználói sablonok elemei.

NTuser.dat fájl

Az NTuser.dat fájl a felhasználói profil rendszerleíró adatbázisra vonatkozó része. Ha további információra van szüksége a Windows 2000 rendszerleíró adatbázisáról, olvassa el a Windows 2000 Resource Kits című témakört.

All Users

Az All Users mappában szereplő beállításokat a rendszer nem másolja a felhasználói profil mappáiba, de felhasználja őket az egyes felhasználói profilok létrehozásakor.

A Windows 2000 kétféle programcsoportot támogat:

  • A közös programcsoportok mindig elérhetők a számítógépen, függetlenül attól, hogy mely felhasználó van bejelentkezve.
  • A személyes programcsoportokhoz csak a programcsoportot létrehozó felhasználó férhet hozzá.

A közös programcsoportokat a Documents and Settings mappában lévő All Users mappa tartalmazza. Az Asztalra és a Start menüre vonatkozó beállítások is az All Users mappában találhatók.

Megjegyzések

  • Alapértelmezés szerint a Windows Intéző csak a Dokumentumok, Képek, Kedvencek, Start menu és Asztal mappákat jeleníti meg. A NetHood, PrintHood, Local Settings, Recent és Sablonok mappák rejtettek, így a Windows Intézőben nem jelennek meg. Ha a fenti mappákat és azok tartalmát meg kívánja jeleníteni a Windows Intézőben, az Eszközök menüben kattintson a Mappa beállításai parancsra, kattintson a Nézet fülre, majd jelölje be a Rejtett fájlok és mappák megjelenítése beállítást.
  • Az NTFS fájlrendszert használó, Windows 2000 rendszert futtató számítógépeken csak a Rendszergazdák csoport tagjai rendelkeznek közös programcsoportok létrehozásának, törlésének és módosításának jogával.


A felhasználói profilokban mentett beállítások

A felhasználói profilok az egyes felhasználókra vonatkozó beállításokat tartalmazzák, melyek az adott felhasználó Asztalának környezetéről készült pillanatképként képzelhetők el.

Az alábbi táblázat a felhasználói profilokban tárolt beállításokat tartalmazza.

Forrás | Mentett paraméterek
Windows Intéző | A Windows Intéző minden beállítása, mely a felhasználók által megadható.
Dokumentumok | A felhasználók által tárolt dokumentumok.
Képek | A felhasználók által tárolt képek.
Favorites (Kedvencek) | Az Internet leggyakrabban használt helyeire mutató parancsikonok.
Csatlakoztatott hálózati meghajtó | A felhasználó által csatlakoztatott hálózati meghajtók.
Hálózati helyek | A hálózat más számítógépeire mutató hivatkozások
Az Asztal tartalma | Az Asztalon tárolt elemek és parancsikonok.
A megjelenítéshez használt színek és betűtípusok | Minden olyan beállítás, mely a megjelenítéshez használt színekre és betűtípusokra vonatkozik, és a felhasználó által módosítható.
Alkalmazásadatok és a rendszerleíró adatbázis struktúrája | Az alkalmazásokra vonatkozó adatok és felhasználói beállítások.
Nyomtatóbeállítások | A hálózati nyomtatókra vonatkozó információk.
Vezérlőpult | A Vezérlőpult felhasználó által definiált beállításai.
Kellékek | A Windows környezetét meghatározó felhasználóspecifikus programbeállítások (például a Számológép, az Óra, a Jegyzettömb és a Paint beállításai).
Windows 2000 alapú programok | A Windows 2000 rendszerhez készült programok úgy is megírhatók, hogy azok a programbeállításokat felhasználónként kezeljék. Az ilyen jellegű információk tárolása is a felhasználói profilban történik.
Online felhasználói könyvjelzők | A Windows 2000 súgójában elhelyezett könyvjelzők.

Megjegyzés

  • Alapértelmezés szerint a Windows Intéző csak a Dokumentumok, Képek, Favorites, Start Menu és Asztal mappákat jeleníti meg. A NetHood, PrintHood, Recent és Sablonok mappák rejtettek, így a Windows Intézőben nem jelennek meg. Ha a fenti mappákat és azok tartalmát meg kívánja jeleníteni a Windows Intézőben, az Eszközök menüben kattintson a Mappa beállításai parancsra, kattintson a Nézet fülre, majd jelölje be a Rejtett fájlok és mappák megjelenítése beállítást.


A felhasználói profilok használata

A rész tartalma:

  • A központi felhasználói profilok használata
  • Előre beállított felhasználói profilok
  • Helyi felhasználói profilok


A központi felhasználói profilok használata

A központi felhasználói profilok segítségével a felhasználók a tartomány bármely számítógépébe bejelentkezhetnek, mely Windows 2000 rendszert futtat. A központi profil hitelesítése után a rendszer a kiszolgálóról a helyi számítógépre másolja azt. A helyi számítógépre kerül továbbá minden felhasználói beállítás és dokumentum, ami a kiszolgálón lévő központi felhasználói profilban található. Ha további információkra van szüksége a központi felhasználói profilok megvalósításáról, olvassa el a Központi felhasználói profil létrehozása című témakört.

A felhasználói profilok tárolásának helye az Active Directoryból adható meg. Ha a felhasználó tartományfiókjában megadja a felhasználói profil elérési útját, a felhasználó helyi felhasználói profilját kilépéskor a rendszer menti mind helyileg, mind a felhasználói profil elérési útjában megadott helyre. Amikor a felhasználó legközelebb bejelentkezik a számítógépbe, a rendszer összehasonlítja a helyi felhasználói profilt a kiszolgálón lévő felhasználói profillal, és azt nyitja meg, amelyik később lett létrehozva. A helyi felhasználói profil így központi felhasználói profillá válik. A felhasználó beállításai és dokumentumai bármely helyről elérhetők, ahol a felhasználó bejelentkezik.

Ha a kiszolgáló nem elérhető, a rendszer a központi felhasználói profil helyileg mentett verzióját használja. Ha a felhasználó először jelentkezik be, egy új helyi felhasználói profil jön létre. Ha a központilag tárolt felhasználói profil bejelentkezéskor nem érhető el, kilépéskor a rendszer nem menti a profilon végrehajtott változtatásokat. Ha kiszolgálóhiba következtében a felhasználói profil nem tölthető le, kilépéskor a rendszer nem tölti be azt.


Előre beállított felhasználói profilok

Előre beállított felhasználói profil bármelyik fiók használatával létrehozható, sokszor azonban hatékonyabb és kényelmesebb megoldást jelent egy referenciaszámítógép használata. Ha például három különböző központi vagy kötelező felhasználói profilt kíván létrehozni és előre beállítani a kereskedelmi, pénzügyi és fejlesztői részlegek számára, hozzon létre három referenciafiókot Kereskedelmi profil, Pénzügyi profil és Fejlesztői profil néven. Ezután jelentkezzen be az egyes fiókokkal és hozza létre a megfelelő felhasználói profilt a csoportok számára. Jelentkezzen be ismét rendszergazdaként, majd az Active Directory kezelőpult használatával módosítsa a felhasználói fiókokat vagy a megfelelő csoportfiókokat, végül másolja a felhasználói profilokat a megfelelő kiszolgálóra. Ha további információkra van szüksége a felhasználói profilok másolásával kapcsolatban, olvassa el a Felhasználói profil másolása a kiszolgálóra című témakört.


Helyi felhasználói profilok

A Windows 2000 új telepítése esetén a helyi felhasználói profil a felhasználó nevén szereplő %felhasználói_profil%\Documents and Settings mappában van tárolva. Frissítésként telepített Windows 2000 rendszer esetén a helyi felhasználói profil a felhasználó nevén szereplő profilmappában van tárolva a %rendszergyökér%\profilmappában. Ha egy felhasználó nem rendelkezik előre beállított, kiszolgáló alapú központi felhasználói profillal, az első bejelentkezéskor létrejön egy mappa a felhasználói profil számára a felhasználónévhez. A Default User mappa tartalma ezután az új felhasználói profil mappájába kerül. A felhasználó Asztalát a felhasználói profil és az All Users mappában lévő, közös programcsoportokra vonatkozó beállítások alakítják ki. A felhasználó kilépésekor a rendszer menti az alapértelmezett beállításokon végrehajtott módosításokat az új felhasználói profil mappájába. A Default User mappában lévő felhasználói profil nem módosul.

Ha egy felhasználó a tartományfelhasználói fiókon kívül is rendelkezik felhasználói fiókkal, vagy egynél több tartományfelhasználói fiókja van a helyi számítógépen, a helyi felhasználói profil minden fiók esetén más lesz, mivel a rendszer minden bejelentkező felhasználó számára külön felhasználói profilt hoz létre. A felhasználó kilépésekor a megváltozott beállításokat a rendszer csak abban a felhasználói fiókban menti, amellyel a felhasználó bejelentkezett.


Forrásmunkák

  • Frissített technikai információ
  • Windows 2000 Resource Kit