Gyakorlati tanácsok

A Windows 2000-ben a rendszerkonfigurációs információk a rendszerleíró adatbázisban helyezkednek el. Bár ez leegyszerűsíti a számítógép vagy a hálózat felügyeletét, egy téves bejegyzés a rendszerleíró adatbázisban működésképtelenné teheti az operációs rendszert. A következő lista néhány gyakorlati tanácsot tartalmaz a rendszerleíró adatbázis és a Rendszerleíróadatbázis-szerkesztő biztonságos használatához.

  • Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot.

    • Egyes programok, például a Biztonsági másolat segítségével biztonsági másolatot készíthet a rendszerleíró adatbázisról. Miután elkészült a rendszerleíró adatbázis módosításával, frissítse a Helyreállító lemezt (ERD). A hibaelhárítás érdekében tartsa számon, milyen változtatásokat hajtott végre a rendszerleíró adatbázison. További tudnivalók: A Windows 2000 rendszerleíró adatbázisának biztonsági mentése, visszaállítása és helyreállítása.

  • Ne cserélje ki a Windows 2000 rendszerleíró adatbázisát a Windows vagy a Windows NT valamely másik verziójának a rendszerleíró adatbázisával.
  • Ne a Rendszerleíróadatbázis-szerkesztővel szerkessze a rendszerleíró adatbázist, hanem más eszközökkel és programokkal.

    • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Olyan eszközöket és programokat használjon, amelyekkel biztonságosabban szerkesztheti a rendszerleíró adatbázist.

  • Korlátozza a rendszerleíró adatbázishoz hozzáférő felhasználók számát.

    • Mivel a Rendszergazdák csoportnak teljes hozzáférése van a rendszerleíró adatbázishoz, csak olyan felhasználókat adjon hozzá ehhez a csoporthoz, akiknek fontos az ilyen hozzáférés. A Rendszerleíróadatbázis-szerkesztő (a Regedt32.exe és a Regedit.exe programok) felhasználását a Csoportházirend segítségével is megtilthatja azoknak a felhasználóknak, akiknek nincs szükségük a rendszerleíró adatbázishoz való hozzáférésre, vagy egyszerűen eltávolíthatja a Rendszerleíróadatbázis-szerkesztőt ezeknek a felhasználóknak a gépéről.

  • Tartsa írásvédett módban a Rendszerleíróadatbázis-szerkesztőt.

    • Ha a Regedt32.exe programot használja, ellenőrizze, hogy a Beállítások menü Írásvédett mód pontja engedélyezett-e. Ha módosítania kell a rendszerleíró adatbázist, kattintson az Írásvédett mód pontra az írásvédett mód kikapcsolásához, majd ellenőrizze, hogy a Törlés megerősítése pont be engedélyezett-e. Ha kész van a módosításokkal és mentette a módosításokat, az írásvédett mód bekapcsolásához kattintson újra az Írásvédett mód pontra.

  • Soha ne hagyja felügyelet nélkül futni a Rendszerleíróadatbázis-szerkesztőt.


Útmutató

Ez a rész a Windows 2000 Rendszerleíróadatbázis-szerkesztő segédprogramjainak használatához nyújt útmutatást.

  • A Rendszerleíróadatbázis-szerkesztő megnyitása
  • A Rendszerleíróadatbázis-szerkesztő használata


A Rendszerleíróadatbázis-szerkesztő megnyitása

  • Kattintson a Start gombra, a Futtatás parancsra, majd írja be a regedt32 vagy regedit parancsot (attól függően, hogy melyik Rendszerleíróadatbázis-szerkesztőt szeretné megnyitni), és kattintson az OK gombra.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő módosítása súlyosan károsíthatja a rendszert. Mielőtt módosítaná a rendszerleíró adatbázist, készítsen biztonsági másolatot a számítógépen található fontosabb adatokról. Ha csak lehet, ne a Rendszerleíróadatbázis-szerkesztővel szerkessze a rendszerleíró adatbázist, hanem más eszközökkel és programokkal.

Megjegyzés

  • Ha parancssorból szeretné megnyitni a Rendszerleíróadatbázis-szerkesztőt, kattintson a Start gombra, mutasson a Programok pontra, majd a Kellékek pontra, kattintson a Parancssor parancsra, írja be a regedt32 vagy regedit parancsot, majd nyomja le az ENTER billentyűt.

Kapcsolódó témakörök


A Rendszerleíróadatbázis-szerkesztő használata

  • A Rendszerleíróadatbázis-szerkesztő (Regedt32.exe)
  • A Rendszerleíróadatbázis-szerkesztő (Regedit.exe)


Fogalmak

A rész tartalma:

  • A Windows 2000 rendszerleíró adatbázisa – áttekintés
  • A Windows 2000 Rendszerleíró adatbázis ismertetése
  • A Windows 2000 rendszerleíró adatbázisának kezelése


A Windows 2000 rendszerleíró adatbázisa – áttekintés

A Microsoft Windows 2000-ben a rendszerkonfigurációs információ központilag van tárolva egy hierarchikus adatbázisban, melynek neve rendszerleíró adatbázis. A rendszerleíró adatbázis helyettesíti a Windows rendszerben az MS-DOS-hoz és a Microsoft LAN Managerhez használt .ini, .sys és .com konfigurációs fájlokat.

Ha információra van szüksége az egyes rendszerleíró kulcsokról, olvassa el a Windows 2000 Resource Kit című könyvet.


A Windows 2000 Rendszerleíró adatbázis ismertetése

A rendszerleíró adatbázis olyan rendszerinformációkat tartalmaz, amelyekre a Windows 2000 operációs rendszer folyamatosan hivatkozik, például a Vezérlőpult segédprogramjainak beállításait. A rész tartalma:

  • A rendszerleíró adatbázis szerkezete
  • Hogyan használják a rendszerleíró adatbázist a Windows 2000 összetevői?


A rendszerleíró adatbázis szerkezete

A rendszerleíró adatbázis részfák, valamint azok kulcsainak, alkulcsainak és értékbejegyzéseinek hierarchikus struktúrájából áll.

Egy számítógép rendszerleíró adatbázisának tartalma jelentősen eltérhet a másikétól, mivel ez az egyes gépekre telepített eszközöktől, szolgáltatásoktól és programoktól függ. A következő ábrán egy példaadatbázis látható, a Windows 2000 Rendszerleíróadatbázis-szerkesztőjének egyik verziójából (REGEDIT.EXE) nézve.

Példa a rendszerleíró adatbázisra

A kulcsoknak alkulcsaik, az alkulcsoknak pedig újabb alkulcsaik lehetnek. Bár a rendszerleíró adatbázis legtöbb információja a merevlemezen található és állandónak számít, egyes információk, amelyek az ideiglenes kulcsokban vannak tárolva, minden alkalommal felülíródnak, amikor az operációs rendszer elindul.

A rendszerleíró adatbázis részfái

A Windows 2000 rendszerleíró adatbázisának két részfája van: a HKEY_LOCAL_MACHINE és a HKEY_USERS. A rendszerleíró adatbázisban lévő információk egyszerű elérése érdekében a Rendszerleíróadatbázis-szerkesztő segédprogramok öt részfát jeleznek ki, amelyek felsorolása és ismertetése a következő táblázatban található:

Gyökérkulcs neve | Leírás
HKEY_LOCAL_MACHINE | A helyi számítógépes rendszerről tartalmaz információkat, többek között a hardver és az operációs rendszer adatait, például a busztípus, a rendszermemória, az eszközillesztők és az indításvezérlés adatait.
HKEY_CLASSES_ROOT | Különféle OLE technológiák által használt információkat és fájl–osztály hozzárendelési adatokat tartalmaz (egyenértékű a Windows for MS-DOS rendszerleíró adatbázisával). A HKEY_CLASSES_ROOT részfában akkor található meg egy bizonyos kulcs vagy érték, ha egy hozzárendelt kulcs vagy érték létezik a HKEY_LOCAL_MACHINE\SOFTWARE\Classes vagy a HKEY_CURRENT_USER\SOFTWARE\Classes kulcsok valamelyikében. Ha egy kulcs vagy érték mindkét helyen szerepel, akkor a HKEY_CURRENT_USER kulcsban szereplő verziója jelenik meg a HKEY_CLASSES_ROOT részfában.
HKEY_CURRENT_USER | Annak a felhasználónak a felhasználói profilját tartalmazza, aki éppen interaktívan (azaz nem távolról) van bejelentkezve. A profilban megtalálhatók többek közt a környezeti változók, az Asztal beállításai, a hálózati kapcsolatok, a nyomtatók és a programok beállításai. Ez a részfa a HKEY_USERS részfa másik neve, és a HKEY_USERS\aktuális felhasználó biztonsági azonosítója kulcsra mutat.
HKEY_USERS | Az éppen betöltött felhasználói profilokról és az alapértelmezett profilról tartalmaz információkat. Ezek között vannak olyanok, amelyek a HKEY_CURRENT_USER részfában is szerepelnek. Azoknak a felhasználóknak, akik távolról férnek hozzá a kiszolgálóhoz, nem ez alatt a kulcs alatt vannak a profiljaik a kiszolgálón, hanem a saját gépük rendszerleíró adatbázisába vannak betöltve.
HKEY_CURRENT_CONFIG | A helyi számítógép által indításkor használt hardverprofilról tartalmaz információkat. Ezek az információk olyan beállítások konfigurálására szolgálnak, mint a betöltendő eszközillesztők vagy a használni kívánt képernyőfelbontás. Ez a részfa a HKEY_LOCAL_MACHINE részfa része, és a HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current kulcsra mutat.

Minden gyökérkulcs neve a HKEY_ karakterlánccal kezdődik, és azt jelöli a szoftverfejlesztők számára, hogy a gyökérkulcs olyan leíró, amelyet a programok fel tudnak használni. A leíró olyan érték, amely egy erőforrás azonosítására szolgál, hogy a programok hozzá tudjanak férni.

Megjegyzések

  • A Rendszerleíróadatbázis-szerkesztő egyik verziója, a REGEDIT.EXE, egy hatodik részfát is kijelez, a HKEY_DYN_DATA gyökérkulcsot. Ez a Windows 95 és a Windows 98 rendszerleíró adatbázisának részfája, de a Windows 2000 nem használja. További tudnivalók a Rendszerleíróadatbázis-szerkesztőről: A Regedt32.exe és a Regedit.exe használata.
  • A HKEY_CLASSES_ROOT működése eltér a Windows korábbi verzióitól. A Windows 2000-ben egy felhasználónkénti osztályregisztráció nevű funkció segítségével megtekintheti a HKEY_CLASSES_ROOT részfát, amely felhasználó- és számítógép-specifikus osztályregisztrációt egyaránt tartalmaz. Ennek a funkciónak a segítségével az egyes felhasználóknak külön osztályregisztráció-készletei lehetnek (többek közt fájltársításokra, COM-komponensekre és MIME-típusokra vonatkozó osztályregisztráció-készletek). Korábban minden felhasználó közös regisztrációt használt, így egy felhasználó módosíthatta a többi felhasználó regisztrációját. A felhasználónkénti regisztráció elkülöníti egymástól az egyes felhasználók regisztrációját, és biztonságosabbá teszi a HKEY_LOCAL_MACHINE\Software\Classes kulcs használatát.

A rendszerleíró adatbázis struktúrái és fájljai

A struktúra kifejezés kulcsok, alkulcsok és értékek olyan együttesét jelenti, amelynek gyökere a rendszerleíró adatbázis hierarchiájának csúcsán helyezkedik el. A struktúrát egy egyszerű fájl és egy .log fájl alkotja, amelyek a rendszergyökér\System32\Config mappában vagy a rendszermeghajtó\Documents and Settings\felhasználónév mappában vannak. A rendszergyökér karakterlánc azt a könyvtárnevet helyettesíti, amely a Windows 2000 rendszerfájljait tartalmazza; a rendszermeghajtó karakterlánc pedig annak a partíciónak a betűjelét, amely a Windows 2000 rendszerfájljait tartalmazza. Ha például a Windows 2000 egy Anna nevű felhasználóhoz tartozó rendszerfájljai a C: partíció Winnt könyvtárában vannak, akkor a struktúrafájlok a C:\Winnt\System32\Config és a C:\Documents and Settings\Anna mappában helyezkednek el. A struktúrákat hívhatjuk rendszerleíróadatbázis-fájloknak vagy rendszerleíróadatbázis-naplófájloknak is.

Alapértelmezés szerint a legtöbb struktúrafájl (DEFAULT, SAM, SECURITY, SOFTWARE és SYSTEM) a rendszergyökér\System32\Config mappában tárolódik. A Windows 2000-nél a számítógép egyes felhasználóinak felhasználói profiljára vonatkozó információk, többek közt az Ntuser.dat és az Ntuser.dat.log helye eltérhet attól függően, hogy az operációs rendszer frissen lett-e telepítve, vagy pedig a Windows 95, a Windows 98 vagy a Windows NT frissítéseként. Friss telepítések, valamint a Windows 95 és a Windows 98 frissítése esetén az Ntuser.dat és az Ntuser.dat.log fájlok a rendszermeghajtó\Documents and Settings\felhasználónév mappában vannak tárolva. A Windows NT frissítése útján történt telepítések esetén az Ntuser.dat és az Ntuser.dat.log fájlok a rendszergyökér\Profiles\felhasználónév mappában vannak tárolva.

A Windows 2000 rendszerleíró adatbázisában minden struktúra hozzá van rendelve szabványfájlok valamilyen csoportjához. A következő táblázat bemutatja egy Windows 2000 operációs rendszert futtató számítógép szabványstruktúráit és -fájljait.

Rendszerleíróadatbázis-struktúra | Fájlnevek
HKEY_LOCAL_MACHINE\SAM | SAM és SAM.LOG
HKEY_LOCAL_MACHINE\SECURITY | SECURITY és SECURITY.LOG
HKEY_LOCAL_MACHINE\SOFTWARE | SOFTWARE és SOFTWARE.LOG
HKEY_LOCAL_MACHINE\SYSTEM | System and System.log
HKEY_CURRENT_CONFIG | System and System.log
HKEY_CURRENT_USER | NTUSER.DAT és NTUSER.DAT.LOG
HKEY_USERS\.DEFAULT | DEFAULT és DEFAULT.LOG

A rendszerleíró adatbázis kulcsainak értékbejegyzései

A rendszerleíró adatbázis minden kulcsa és alkulcsa tartalmazhat értékbejegyzéseket. Egyes értékbejegyzésekben olyan információk vannak, amelyek az egyes felhasználókra nézve egyediek, másokban viszont olyanok vannak, amelyek a számítógép minden felhasználójára vonatkoznak. Az értékbejegyzés három részből áll: az érték neve, az érték adattípusa és maga az érték. Az értékbejegyzések három része mindig a következő sorrendben jelenik meg:

Az értékbejegyzés szerkezete

Az adattípusok az adat formátumát írják le. A 0-tól 0x7FFFFFFF-ig terjedő adattípusok definiálása a rendszer számára van fenntartva. A programok használhatják ezeket az adattípusokat, de a 0x80000000-tól 0xFFFFFFFF-ig terjedő adattípusok szintén a programok számára vannak fenntartva.

A következő táblázat felsorolja a rendszer által jelenleg definiált és használt adattípusokat:

Adattípus | Leírás
REG_BINARY | Nyers bináris adatok. A legtöbb hardverkomponens-információ bináris adatok formájában van tárolva, a Rendszerleíróadatbázis-szerkesztőben pedig hexadecimális formátumban jelenik meg.
REG_DWORD | 4 bájtos számon ábrázolt adat. Az eszközillesztők és szolgáltatások sok paramétere ebben a típusban van; ezek a Rendszerleíróadatbázis-szerkesztőben bináris, hexadecimális vagy decimális formátumban jelennek meg.
REG_EXPAND_SZ | Változó hosszúságú adatlánc. Ez az adattípus olyan változókat foglal magában, amelyeket a program vagy a szolgáltatás értelmez, amikor használja az adatokat.
REG_MULTI_SZ | Többszörös karakterlánc. Azok az értékek, amelyek listákat vagy több értéket tartalmaznak olvasható formában, általában ehhez a típushoz tartoznak. A bejegyzéseket szóköz, vessző vagy más jel választja el.
REG_SZ | Rögzített hosszúságú szöveglánc.
REG_FULL_RESOURCE_DESCRIPTOR | Beágyazott tömbök sorozata, amely hardverkomponensre vagy meghajtóra vonatkozó erőforráslisták tárolására használatos.

A rendszerleíró adatbázis mérethatárai

A rendszerleíró adatbázis a lapozható készletben, a virtuális memória egy olyan részében van tárolva, amely egy fizikai lemezre van írva, amikor azt nem használják. A rendszerleíró adatbázis mérethatárának nevezett érték megakadályozza, hogy a programok teljesen megtöltsék a lapozható készletet a rendszerleíró adatbázis adataival.

A Vezérlőpult Rendszer programjával megtekintheti és beállíthatja a rendszerleíró adatbázis méretét. A Speciális lapon kattintson a Teljesítménybeállítások, majd a Módosítás gombra. További információ a rendszerleíró adatbázis méretének beállításáról: A rendszerleíró adatbázis maximális méretének módosítása és A lapozófájl méretének módosítása.

A rendszerleíró adatbázis mérethatára alapértelmezés szerint a lapozható készlet méretének 33 százaléka. A rendszerleíró adatbázis mérethatára a lapozható készlet méretének 80 százalékáig növelhető. A rendszerleíró adatbázis minimális mérete 16 megabájt (MB). Ha ennél kisebbre próbálja beállítani a rendszerleíró adatbázis méretét, a rendszer visszaállítja az értéket 16 MB-ra.

Csak akkor módosítsa a rendszerleíró adatbázis méretét, ha a számítógép egy nagy hálózat tartományvezérlője, vagy ha hibaüzenetet kap, amely figyelmezteti, hogy túl kicsi a rendszerleíró adatbázis. Ha a rendszerleíró adatbázis mérethatárát nagy értékre állítja, a rendszer nem használja automatikusan a teljes megadott területet, csak ha a rendszerleíró adatbázisnak valóban szüksége van rá. Továbbá a nagy érték önmagában nem biztosítja, hogy a maximális terület valóban elérhető a rendszerleíró adatbázis számára.


Hogyan használják a rendszerleíró adatbázist a Windows 2000 összetevői?

A következő illusztrációk bemutatják, hogyan használják a rendszerleíró adatbázist a Windows 2000 összetevői és programjai. A következő lista tartalmazza a részleteket:

Hogyan használják a rendszerleíró adatbázist a komponensek és a programok?

A telepítő. A Windows 2000 Telepítő programja és más (programokhoz és hardverekhez készült) telepítőprogramok konfigurációs adatokat adnak hozzá a rendszerleíró adatbázishoz. Amikor például új SCSI csatolót telepít vagy megváltoztatja a képernyőbeállításokat, új információ kerül az adatbázisba. A Telepítő olvas is információt a rendszerleíró adatbázisból, hogy megállapítsa, telepítve vannak-e a szükséges komponensek.

A hardverfelismerő eszköz. Amikor úgy indítja el a számítógépet, hogy a Windows 2000-et futtatja, a hardverfelismerő a rendszerleíró adatbázisba írja a hardverkonfigurációs adatokat. Ezek között az adatok között szerepel a rendszeren felismert hardvereszközök listája. Az Intel alapú számítógépeken a hardverfelismerést a hardverfelismerő (Ntdetect.com) és a Windows 2000 kernel (Ntoskrnl.exe) programjai végzik.

A Windows 2000 kernel. A rendszer indításakor a Windows 2000 kernel információt gyűjt a rendszerleíró adatbázisból, például hogy mely eszközillesztőket töltse be és milyen sorrendben. A Ntoskrnl.exe program önmagáról is ad információkat (például a verziószámát) a rendszerleíró adatbázisnak.

Az eszközillesztők. Az eszközillesztők betöltési paramétereket és beállítási adatokat küldenek és fogadnak a rendszerleíró adatbázisból. Az adatok hasonlóak ahhoz, amit az MS-DOS operációs rendszer CONFIG.SYS fájljának DEVICE= soraiban találhat. Az eszközillesztőnek jelentést kell tennie, hogy milyen rendszererőforrásokat használ, például milyen hardvermegszakításokat és DMA-csatornákat, hogy a rendszer hozzáadhassa ezt az információt a rendszerleíró adatbázishoz. A programok és az eszközillesztők hozzáférhetnek ezekhez a rendszerleíró adatbázisban tárolt információkhoz, így a felhasználók intelligens telepítő- és konfigurációs programokkal dolgozhatnak.

A felügyeleti eszközök. A Windows 2000 beállításai és felügyeleti eszközei (például a Vezérlőpult Felügyeleti eszközök mappájában lévők) arra szolgálnak, hogy közvetetten módosíthassa a konfigurációs adatokat.


A Windows 2000 rendszerleíró adatbázisának kezelése

A Windows 2000 legtöbb felhasználójának nincs szüksége rá, hogy hozzáférjen a rendszerleíró adatbázis hoz. A rendszergazda munkájának viszont fontos része a rendszerleíró adatbázis kezelése. Ez olyan feladatokat jelent, mint például a rendszerleíró adatbázis megjelenítése, szerkesztése, visszaállítása és biztonsági másolat készítése az adatbázisról. A rendszergazdának ezenkívül törődnie kell a biztonsági kérdésekkel is. További tudnivalók az adatvédelemmel és a rendszerleíró adatbázissal kapcsolatban: A rendszerleíró adatbázis adatvédelmének biztosítása

A rész tartalma:

  • A Regedt32.exe és a Regedit.exe használata
  • A Windows 2000 rendszerleíró adatbázisának biztonsági mentése, visszaállítása és helyreállítása


A Regedt32.exe és a Regedit.exe használata

A Windows 2000 a Rendszerleíróadatbázis-szerkesztő két verzióját tartalmazza: a Regedt32.exe és a Regedit.exe fájlokat. A Regedt32.exe telepítése automatikusan megtörténik a rendszergyökér\System32 mappába. A Regedit.exe telepítése automatikusan megtörténik a rendszergyökér mappába.

A rendszerleíró adatbázist a Rendszerleíróadatbázis-szerkesztő segédprogramok valamelyikének használatával módosíthatja. Ajánlott azonban ezek helyett a Windows 2000 más segédprogramjainak és eszközeinek, például a Vezérlőpulton lévőknek a használata. Amikor a Rendszerleíróadatbázis-szerkesztővel módosítja a rendszerleíró adatbázist, az nem ellenőrzi a szintaktikai és egyéb hibákat. Ráadásul egyetlen dolog megváltoztatása a rendszerleíró adatbázisban változások tömegét idézheti elő. Egy, a Rendszerleíróadatbázis-szerkesztővel végrehajtott téves módosítás beláthatatlan következményekkel járhat, és kárt okozhat a Windows 2000 operációs rendszerben, vagy akár működésképtelenné is teheti. Más eszközök és segédprogramok használatával azonban megbizonyosodhat róla, hogy a rendszerleíró adatbázisban történt módosítások érvényesek, és kezelheti mindazokat a változtatásokat, amelyeket egy módosítás idézett elő.

Biztonságosan megtekintheti a rendszerleíró adatbázist, ha a Regedt32.exe programot csak írásvédett módban használja (a Beállítások menüben kattintson az Írásvédett mód elemre), hogy véletlenül se módosíthasson semmit.

A hozzáférési beállításoktól függ, hogy végrehajthat-e módosításokat a rendszerleíró adatbázison a Rendszerleíróadatbázis-szerkesztővel. Általában a Rendszerleíróadatbázis-szerkesztővel ugyanazokat a módosításokat hajthatja végre, mint amelyeket a beállítások a többi felügyeleti eszközhöz megengednek. Azok a felhasználók, akik a Rendszergazdák csoportba tartoznak, a Rendszerleíró adatbázis menü Számítógép kiválasztása pontjával megnézhetik távoli számítógépek rendszerleíró adatbázisát.

A Rendszerleíróadatbázis-szerkesztő elindításakor egy hozzá tartozó ikon jelenik meg a tálcán. A Rendszerleíróadatbázis-szerkesztővel kapcsolatos tudnivalók: A Rendszerleíróadatbázis-szerkesztő megnyitása.

Részletes információk a Rendszerleíróadatbázis-szerkesztővel kapcsolatban: Útmutató.

Javaslatok a Windows 2000 rendszerleíró adatbázisának és Rendszerleíróadatbázis-szerkesztőjének biztonságos használatával kapcsolatban: Gyakorlati tanácsok.


A Windows 2000 rendszerleíró adatbázisának biztonsági mentése, visszaállítása és helyreállítása

Fontos, hogy legyenek friss, megbízható biztonsági másolatai a rendszerleíró adatbázisról. A rendszerleíró adatbázisról készítsen biztonsági másolatot a szokásos biztonsági mentés keretében, illetve mindig, mielőtt hozzáfogna a rendszerleíró adatbázis szerkesztéséhez. Ha bejelöli a Biztonsági másolat nevű eszköz Biztonsági másolat fülén a Rendszerállapot jelölőnégyzetet, akkor a gép automatikusan elvégzi a rendszerleíró adatbázisról a biztonságimásolat-készítést.

A rendszerleíró adatbázisból elveszett adatok visszaállításához a Biztonsági másolat parancsot is használhatja. Ehhez a rendszernek elég stabilnak kell lennie, hogy Ön megnyithassa a biztonsági másolatot. Viszont előfordulhat, hogy a Windows 2000 annyira megsérül a rendszerleíró adatbázis hibás szerkesztései miatt, hogy nem tud elindulni. Ilyenkor előfordulhat, hogy helyre tudja állítani az operációs rendszert, ha előzőleg készített Helyreállító lemezt (ERD). Legrosszabb esetben újra kell telepítenie az operációs rendszert és az eszközillesztőket, és újra kell konfigurálnia a rendszert, mielőtt visszaállíthatja az adatokat.

További információ a Biztonsági másolat nevű eszközről: Windows Biztonsági másolat – áttekintés.

További információ a rendszerleíró adatbázisról való biztonságimásolat-készítésről: Rendszerállapot-adatok biztonsági mentése.

További információ a helyreállító lemez készítéséről: Helyreállító lemez készítése.


Hibaelhárítás

Mi a probléma?

A rendszerleíró adatbázis szerkesztése után egy vagy több hiba merül fel az alábbiak közül: egyes fájlok hiányoznak, egyes komponensek nem a megszokott módon működnek, hibaüzenetek vagy leállási hibák jelennek meg, vagy nem indul el az operációs rendszer.

Ok: hibás vagy sérült a rendszerleíró adatbázis.

Megoldás: mielőtt újratelepítené a Windows 2000-et, hogy kijavítsa a hibát, próbálja meg a következőt:

  • Ha rendelkezik valamilyen feljegyzéssel arról, hogy milyen változtatásokat hajtott végre a rendszerleíró adatbázison, próbaképpen állítsa vissza a legutóbbi változtatás előtti állapotot.
  • Ha tudja, mely komponenseket módosította, állapítsa meg, mik a megfelelő beállítások a rendszerleíró adatbázis megfelelő komponenseihez. A rendszerleíró adatbázis egyedi beállításaival kapcsolatban további információkat a felhasználói kézikönyvnek az adott komponensre vonatkozó részénél vagy a Windows 2000 Resource Kit-ben talál.
  • Próbaképpen állítsa vissza a számítógép utolsó ismert helyes konfigurációját. További információ: A Windows 2000 indítása az utolsó ismert helyes konfigurációval.
  • Ha van biztonsági másolata a rendszerleíró adatbázisról (mint a rendszer állapotára vonatkozó adatok biztonsági másolatának részéről), és meg tudja nyitni a Biztonsági másolat eszközt, próbálja meg visszaállítani a rendszerleíró adatbázis beállításait. További információ: A rendszer állapotára vonatkozó adatok visszaállítása.
  • Ha nem tudja elindítani a Windows 2000 rendszert, a Helyreállító lemez (ERD) segítségével próbálja meg helyreállítani az operációs rendszert. További információ: El nem induló rendszer javítása.
  • Ha az operációs rendszer annyira sérült, hogy nem lehet megjavítani (vagy ha ki kell cserélni a merevlemezt), nézze meg az operációs rendszer újratelepítésére vonatkozó útmutatásokat a Windows 2000 Server - Az első lépések című könyvben, amelyet a Windows 2000 CD-hez kapott.


A Windows 2000 rendszerleíró adatbázisa

A Windows 2000 rendszerleíró adatbázis a olyan adatbázis, amely rendszerkonfigurációs adatokat tartalmaz a Windows 2000 operációs rendszer számára.

  • A rendszerleíró adatbázis és a Rendszerleíróadatbázis-szerkesztő használatával kapcsolatos tippek a következő témakörben találhatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.