Hibatűrés

A hibatűrés célja, hogy a számítógép működését egy összetevő vagy a rendszer egészének meghibásodása esetén is működőképes állapotban tartsa.

  • A RAID lemezkészletek vagy UPS-eszköz hozzáadása előtt tekintse át a Feladatlistákat.
  • A Windows 2000 Server operációs rendszerben a korábbi verzióktól eltérő helyen található szolgáltatásokkal kapcsolatban tájékoztatás a Megszokott feladatok végrehajtásának új módjai című témakörben található.
  • A hibatűrő eljárások használatával kapcsolatos ötletek a Gyakorlati tanácsok című témakörben találhatók.
  • A konkrét feladatokról az Útmutató című témakörben olvashat bővebben.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításával kapcsolatos tennivalókat a Hibaelhárítás című témakörben találja.


Feladatlisták

  • Feladatlista: Tükrözött kötet létrehozása
  • Feladatlista: RAID-5 kötet létrehozása
  • Feladatlista: Az UPS konfigurálása


Feladatlista: Tükrözött kötet létrehozása

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat. Tükrözött kötetek használata;
Gyakorlati tanácsok;
Lemezkonfigurációs információ helyreállítása
Bizonyosodjon meg arról, hogy tagja a Rendszergazdák csoportnak. | Csoportok – áttekintés
Készítsen biztonsági másolatot a létező adatokról. | Biztonsági másolat készítése fájlokról a Biztonságimásolat-készítő varázsló segítségével
Hozza létre a kötetet. | Tükrözött kötet létrehozása


Feladatlista: RAID-5 kötet létrehozása

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat. RAID-5 kötetek használata;
Gyakorlati tanácsok;
RAID módszer választása;
Lemezkonfigurációs információ helyreállítása
Bizonyosodjon meg arról, hogy tagja a Rendszergazdák csoportnak. | Csoportok – áttekintés
Készítsen biztonsági másolatot a létező adatokról. | Adatok biztonsági mentése és visszaállítása
Hozza létre a kötetet. | RAID-5 kötet létrehozása


Feladatlista: Az UPS konfigurálása

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat. | Szünetmentes áramforrások (UPS); Gyakorlati tanácsok
Bizonyosodjon meg arról, hogy tagja a Rendszergazdák csoportnak. | Csoportok – áttekintés
Készítsen biztonsági másolatot a létező adatokról. | Biztonsági másolat készítése fájlokról a Biztonságimásolat-készítő varázsló segítségével
Állítson be úgy egy programot, hogy az akkumulátor lemerülése esetén fusson. | Telepítsen egy UPS-eszközt
Tesztelje az UPS konfigurációját. | Az UPS konfigurációjának tesztelése


Megszokott feladatok végrehajtásának új módjai

Az alábbi táblázat a Windows NT 4.0-s verzió megszokott hibatűrési feladatait és a Windows 2000 megegyező feladatait hasonlítja össze.
Cél | Windows NT 4.0 operációs rendszerben | Windows 2000 operációs rendszerben
Tükrözött készlet létrehozása | Lemezfelügyelő menüpont a Rendszerfelügyeleti eszközök menüben. | Számítógép-kezelés (Helyi) menüpont a Felügyeleti eszközök menüben. További információ a Tükrözött kötetek kezelése című témakörben található.
RAID-5 készlet létrehozása | Lemezfelügyelő menüpont a Rendszerfelügyeleti eszközök menüben. | Számítógép-kezelés (Helyi) menüpont a Felügyeleti eszközök menüben. További információ a RAID-5 kötet létrehozása című témakörben található.
UPS-eszköz konfigurálása | UPS párbeszédpanel a Vezérlőpulton. | Az Energiagazdálkodási lehetőségek ablak a Vezérlőpulton. További információ a UPS konfigurálása című témakörben található.


Gyakorlati tanácsok

  • A rendszer- és a rendszerindító kötetek tükrözése
    Tükrözze a rendszerindító és rendszerköteteket egy másik lemezre. Ha a rendszerindító és rendszerköteteket tartalmazó lemez meghibásodik, a számítógépet elindíthatja a kötetek tükrözését tartalmazó lemezről.
  • A RAID alaplemezek dinamikus lemezekké alakítása
    Alakítsa RAID tömbökhöz tartozó alaplemezeit dinamikus lemezekké. Ha a RAID tömb egyik tagja meghibásodik, új lemezt adhat a számítógéphez és azt újraépítheti anélkül, hogy újra kellene indítani a számítógépet, ezzel időt takarít meg.
  • A szünetmentes áramforrás (UPS) tesztelése
    Áramszünetet szimulálva tesztelje az UPS-eszközt. Ezt megteheti az eszköz hálózati csatlakozójának kihúzásával. Az eljárás segítségével meggyőződhet róla, hogy az UPS helyesen van-e konfigurálva, illetve arról, hogy mennyi ideig fut a számítógép a telep lemerülése előtt. További információ az UPS konfigurációjának tesztelése című témakörben található.
  • Az UPS kiválasztása
    Válasszon olyan UPS-eszközt, amelyik nem csak telepet tartalmaz, de áramszünet esetén ki tudja használni a Windows UPS szolgáltatásának figyelmeztető funkcióit. Ezek a szolgáltatások: az áramszünet azonosítása, az alacsony töltöttségű telep azonosítása és az UPS-leállás. A Microsoft Windows hardverkompatibilitási listán, a Microsoft webhelyén (http://www.microsoft.com/) ellenőrizze, hogy a használt UPS-eszköz együttműködik-e a Windows operációs rendszerrel. Szükséges lehet a megfelelő soros kábel megrendelése az UPS gyártójától. Ezek a kábelek a Windows 2000 UPS-szabványai szerint készültek. Amennyiben számítógépét frissíti a Windows 2000 operációs rendszerre, és már rendelkezik UPS-eszközzel, érdeklődjön a gyártónál, hogy a rendelkezésére álló kábel együttműködik-e a Windows 2000 operációs rendszerrel. A nem megfelelő kábel használatának nem várt következményei lehetnek.
  • Parancs végrehajtása
    Ha az Energiagazdálkodási lehetőségeket úgy állítja be, hogy az áramszünetet követően egy parancsfájlt hajtsanak végre, győződjön meg róla, hogy a parancsfájl 30 másodpercen belül véget ér. A harminc másodpercnél hosszabb futási idő veszélyeztetheti a Windows sikeres leállását. További információ az UPS konfigurálása című témakörben található.


Útmutató

  • RAID lemezek használata
  • Szünetmentes áramforrás (UPS) használata


RAID lemezek használata

  • Hozzon létre egy tükrözött kötetet
  • Tükrözzön egy létező egyszerű kötetet
  • Szinkronizáljon újra egy tükrözött kötetet
  • Válasszon szét egy tükrözött kötetet két kötetre
  • Távolítsa el a tükrözést egy tükrözött kötetből
  • Hozzon létre egy RAID-5 kötetet


Szünetmentes áramforrás (UPS) használata

  • UPS telepítése
  • UPS eltávolítása
  • UPS konfigurálása
  • Egyszerű jelzéses UPS konfigurálása
  • UPS konfigurációjának tesztelése


Fogalmak

Ez a rész általános háttérinformációt kínál a Windows 2000 hibatűrési képességeiről.

  • Hibatűrés – áttekintés
  • A hibatűrés ismertetése
  • Hibatűrő eszközök használata
  • Forrásmunkák


Hibatűrés – áttekintés

A hibatűrés a rendszer azon képessége, melynek segítségével működőképes marad akkor is, ha a rendszer egy része meghibásodik. A hibatűrést általában a lemezalrendszerek leírására használják, de a rendszer más részeire és a rendszer egészére is alkalmazható. A teljes mértékben hibatűrő rendszerek a hibatűrő lemezalrendszereken kívül redundáns lemezvezérlőket és tápegységeket is használnak. Szünetmentes tápegység (UPS) is használható, mely védelmet nyújt helyi áramszünet esetén.

Annak ellenére, hogy a hibatűrő rendszerekben az adatok mindig elérhetők és frissek, a biztonságimásolat-készítés ezekben is szükséges, hogy a lemezalrendszereken tárolt információkat megvédje a felhasználói hibáktól és katasztrófáktól (például tűzeset, földrengés, tornádó vagy áradás). A lemez hibatűrése nem helyettesíti a biztonsági másolatok készítését és azok telephelytől távoli tárolását.

Dinamikus tárolási eljárásokat is használhat, melynek segítségével kötetorientált lemezrendszereket hozhat létre, melyek hibatűrők. Az új lemezkezelési architektúra a számítógép újraindítása nélkül is lehetővé teszi az online változtatásokat. A dinamikus tárolásról a Lemezkezelés részben talál részletes tájékoztatást.


A hibatűrés ismertetése

A rész tartalma:

  • RAID lemeztömbök
  • RAID módszer választása
  • Szünetmentes áramforrás (UPS)


RAID lemeztömbök

A RAID (Redundant Array of Independent Disks - Független lemezek redundáns tömbje) bevezetése hardveres vagy szoftveres megoldásokkal érhető el. A hardveres megoldásoknál a vezérlőcsatoló kezeli a redundáns információ létrehozását és regenerációját. A Windows operációs rendszerben ez a művelet szoftveresen is végrehajtható. Az adatokat mindkét esetben lemezek tömbjén megosztva tárolja.

A lemeztömbök számos lemezmeghajtóból állnak, melyeket egy vezérlő hangol össze. Az egyes adatfájlok jellemzően egynél több lemezre íródnak úgy, hogy a használt RAID szinttől függően a teljesítményt vagy a megbízhatóságot növelhetik.

A rendszer a hiba kijavításáig nem hibatűrő. Csak kevés RAID módszer állhat ellen két, egyidejűleg bekövetkező hibának. Ha a meghibásodott lemezt kicseréli, az adatokat a redundáns információ segítségével helyreállíthatja. Az adatok regenerációja biztonsági másolatok vagy kézi frissítési műveletek nélkül is helyreállítja akár a legutóbbi biztonsági mentés óta végbement változásokat is. Az adatok regenerációjának bevégeztével az összes adat friss és újra védett lemezhibák ellen. Az alacsony relatív költségen elért magas megbízhatóság a lemeztömbök legfontosabb előnye.


RAID módszer választása

A tükrözött és a RAID-5 kötetek közötti legfontosabb különbségek a hardverkövetelményekben, a teljesítményben és az árban mutatkoznak. Az alábbi táblázat a két hibatűrési módszer főbb tulajdonságait illusztrálja:

Tükrözött kötetek | RAID-5 kötetek
Támogatják a FAT és NTFS fájlrendszereket. | Támogatják a FAT és NTFS fájlrendszereket.
Tükrözheti a rendszer vagy rendszerindító köteteket. | Nem csíkozhatja a rendszer vagy rendszerindító köteteket.
Két merevlemezt igényel. | Minimum három merevlemezt igényel.
Magasabb költség megabájtonként (50%-os hasznosíthatóság). | Alacsonyabb megabájtonkénti költség.
Jó olvasási és írási teljesítménnyel rendelkezik. | Megfelelő írási teljesítménnyel és kitűnő olvasási teljesítménnyel rendelkezik.
Kevesebb rendszermemóriát használ. | Több rendszermemóriát igényel.
Csak két merevlemezt támogat. | Maximum 32 merevlemezt támogat.

A tükrözött és RAID-5 kötetek közötti választást a számítástechnikai környezet határozza meg. A RAID-5 kötetek megfelelő adatredundancia-megoldást kínálnak, ha a legtöbb művelet az adatok olvasásából áll. Például, ha a hálózat olyan kiszolgálóval rendelkezik, ami a hálózat összes felhasználója által használt programokat tárolja, az jó okot adhat RAID-5 kötetek használatára. Ez lehetővé teszi, hogy a programokat megóvja az csíkozott kötet valamelyik lemezének sérülése esetén. Növekszik továbbá az olvasási teljesítmény, a RAID-5 kötet lemezei közötti olvasások párhuzamossága miatt.

Olyan környezetben, ahol gyakori az információ frissítése, a tükrözött kötetek használata általában hatékonyabb. Használhat azonban RAID-5 kötetet is, ha redundanciát szeretne, és ha a tükrözött tárolás költségeit nem engedheti meg.

Megjegyzések

  • A Windows NT 4.0-ás verzió hibatűrő lemezstruktúráit, például a tükrözött készleteket vagy a paritásos csíkozott készleteket a Windows 2000 is támogatja. A karbantartásukkal kapcsolatos információ a Tükrözött készletek és paritásos csíkozott készletek használata című témakörben található. Ha ezeket tükrözött vagy RAID-5 kötetté kívánja konvertálni, az eljárás a Alaplemez dinamikus lemezzé alakítása című témakörben található.
  • A hibatűrési funkciókkal nem rendelkező operációs rendszerek, mint például az MS-DOS, nem ismerik fel a Windows 2000 Server által hibatűrés céljából létrehozott köteteket. Ezért, ha egy kettős betöltésű számítógépen az MS-DOS rendszerkötetet tükrözi, az MS-DOS egyik kötetet sem tudja használni vagy elindítani. Elővigyázatosságból hozzon létre egy rendszerindító lemezt is, melynek segítségével a számítógépet rendszerkötet hiányában a tükrözött kötetről is elindíthatja.


Szünetmentes áramforrás (UPS)

Az UPS áramszünet esetén biztosítja az energiaellátást. Általában egy meghatározott feszültséget meghatározott ideig kell fenntartania. Ez a feszültség akkumulátorokból származik, melyek folyamatosan töltődnek, amikor a hálózati feszültség megfelelő. Az általános elvárás az UPS-eszközökkel szemben, hogy a rendszer leállásához, azaz a folyamatok bezárásához és a munkamenetekből történő kilépéshez elegendő időt biztosítsanak.

Sok UPS-eszköz képes az operációs rendszerekkel kommunikálni, ami lehetővé teszi, hogy az operációs rendszer automatikusan figyelmeztesse a felhasználókat a közeledő leállásra, vagy figyelmeztessen, hogy az energiaellátás helyreállt, így a leállás a továbbiakban nem szükséges.

Áramszünet esetén az UPS-szolgáltatás azonnal leállítja a Kiszolgáló szolgáltatást, hogy megakadályozza az új kapcsolatok létrehozását és üzenetben figyelmezteti a felhasználókat az áramszünetre. Az UPS-szolgáltatás ezután egy meghatározott ideig várakozik, mielőtt a felhasználókat felkéri a munkamenetek lezárására. Amennyiben a várakozási időben az energiaellátás helyreáll, új üzenetet küld, melyben tájékoztatja a felhasználókat, hogy az energiaellátás helyreállt, és a normális működés folytatódik.


Hibatűrő eszközök használata

A rész tartalma:

  • RAID használata
  • UPS használata


RAID használata

A rész tartalma:

  • Tükrözött kötetek használata
  • RAID-5 kötetek használata
  • RAID lemezek javítása


Tükrözött kötetek használata

A tükrözött kötetek, melyeket a Windows NT 4.0-s operációs rendszerben tükörkészleteknek neveznek, a kijelölt lemez azonos másolatát készítik el. Mivel az elsődleges lemezre írott minden adat a másodlagos vagy tükröző lemezre is íródik, az eljárás csak a lemezterület 50%-át használja fel. Az egyik lemez meghibásodása esetén a rendszer a másik lemez adatait használja.

A tükrözött kötetek megvédik a lemezen tárolt kötetet az adathordozó és nagy valószínűséggel a vezérlő hibájától azáltal, hogy egy teljes mértékben redundáns másolatot tartanak fenn egy másik lemezen. Ha a tükrözött kötet meghibásodik, azt meg kell szakítani, hogy a számítógép a fennmaradó kötetet saját betűjelével külön kötetként kezelje tovább. Ezután új tükrözött kötetet hozhat létre, egy másik lemeznek az előzővel megegyező, vagy annál nagyobb szabad tárhelyén.

Tükrözött kötet létrehozásakor olyan kötetet hoz létre, amely egy másik lemez szabad tárhelyét használja. Ha a második kötet nagyobb, a fennmaradó tárhely szabadon marad. A két kötethez ugyanazt a meghajtó-betűjelet használja. Bármely létező kötet, még a rendszer-, vagy rendszerbetöltő kötetek is tükrözhetők egy azonos méretű vagy nagyobb másik kötetre, vagy egy másik, azonos vagy más vezérlőt használó lemezre. Tükrözött kötet létrehozásakor ajánlott egyazon gyártó által gyártott, azonos méretű és típusú lemezeket használni.

A tükrözött kötetek általános olvasási és írási teljesítménye jobb, mint a RAID-5 köteteké. A tükrözött kötetek másik nagy előnye a RAID-5 kötetekkel szemben, hogy a tükrözött kötet egyik tagjának meghibásodásakor a teljesítmény nem csökken. A tükrözött kötetek relatív (megabájtonkénti) költsége magasabb, mivel alacsonyabb a lemezterület-kihasználás. A kezdő költség azonban a tükrözött kötetnél alacsonyabb, hiszen csak két lemez szükséges hozzá, míg a RAID-5 kötetek legalább három lemezt igényelnek.

A tükrözött kötetek csökkentik a helyreállíthatatlan hibák előfordulásának esélyét azáltal, hogy az adatokról másolatot készítenek, ez a folyamat azonban lemezre íráskor megkétszerezi a bemeneti/kimeneti (I/O) műveleteket. Bizonyos teljesítménynövekedés azonban elérhető az adatok olvasásakor, mivel az I/O kérések a két kötet között egyenlően oszlanak el.

Ha a tükrözött köteten lévő tárhelyet egyéb célokra kívánja használni, először meg kell szakítania a tükrözési kapcsolatot, majd a kötetek egyikét le kell törölni. A tükrözött kötet megszakítása nem törli az információt, ennek ellenére biztonságosabb, ha előbb az ott tárolt információról biztonsági másolatot készít.

Ha a tükrözött köteten belül az egyik kötet meghibásodik, a tükrözési kapcsolatot meg kell szakítani, hogy a fennmaradó kötetet külön kötetként szerepeljen. Ezután egy másik lemezen lévő szabad tárhelyet rendelhet hozzá, így új tükrözött kötetet hozhat létre.

Tükrözött kötet létrehozásával, megszakításával vagy javításával, kötet hozzáadásával vagy eltávolításával kapcsolatos további információk a Tükrözött kötetek kezelése című részben találhatók.

Egy tükrözött kötet képe


RAID-5 kötetek használata

A RAID-5 kötetek, melyeket a Windows NT 4.0-s operációs rendszerben paritásos csíkképzésnek hívnak, az adatokat minden lemez minden tömbjén megosztják. A RAID 5. szintjének egyedülálló sajátsága, hogy a paritásinformációkat minden lemezre írja. Az adatredundanciát úgy éri el, hogy az adatblokkokat és azok paritásinformációit a tömb különböző lemezeire írja.

A RAID-5 kötetek olvasási teljesítménye magasabb, mint a tükrözött köteteké. Egy tag hiánya esetén azonban, például amikor egy lemez meghibásodik, az olvasási teljesítmény csökken, mivel az adatokat a paritásinformációk segítségével helyre kell állítani.

A tükrözéssel szemben azonban ez a stratégia mégis sokkal inkább ajánlott olyan alkalmazásokhoz, melyek redundanciát igényelnek és elsődlegesen olvasásorientáltak. Az írási teljesítményt csökkenti a paritás számítása. Az írási művelet ezen kívül háromszor annyi memóriát igényel, mint normális működés esetén az olvasási művelet. Ha egy kötet meghibásodik, akkor az olvasás is legalább háromszor annyi memóriát igényel. Mindkettő oka a paritás számítása.

A paritás használatának ismertetése RAID-5 kötetekben

A Windows 2000 által a RAID-5 kötetekhez használt adatredundancia-módszer a kizáró VAGY, más néven XOR logikai művelet egy funkciója. A paritással kapcsolatos lényeges tényező, hogy a regenerációs folyamat a hibátlan lemez paritásinformációi segítségével állítja helyre a hibás lemezen tárolt adatokat. A RAID-5 hibatűrés az adatok XOR értékét tartja fenn. Ez lehetővé teszi a (hibás lemezen vagy szektorban lévő) hiányzó adatok rekonstrukcióját a RAID-5 kötet további lemezeiről.

A RAID-5 kötetek csíkonként egy paritásblokkot tartalmaznak. Ezért az egyébként használt kettővel szemben, legalább három lemezt kell használnia a paritás információ számára. A paritáscsíkok, ahogyan az alábbi illusztráción látható, minden kötetre kiterjednek, hogy kiegyensúlyozzák az I/O terhelést.

A RAID-5, a kötethez adott egyetlen további lemez költségén biztosítja az adatredundanciát. A RAID-5 kötetről történő helyreállítás azonban több időt igényel, mint a tükrözött kötetről történő.

Ha egy RAID-5 kötet kapacitását egyéb célokra vissza kívánja nyerni, először mindenképpen készítsen biztonsági másolatot az ott tárolt információról, ha azt a továbbiakban még használni kívánja. Ezután törölje le a kötetet.

A RAID-5 kötetek létrehozásával és javításával kapcsolatos információk a RAID lemezek használata című témakörben találhatók.

Egy RAID-5 kötet képe


RAID lemezek javítása

A problémahelyzetek gyors és könnyű helyreállításához használja a Windows 2000 hibatűrő segédprogramjait. Ha tükrözött köteteket használ, egy lemez meghibásodása esetén azonnal rendelkezésére áll egy másik lemez a meghibásodott lemezen tárolt információ redundáns másolatával. A RAID-5 kötetekkel az adatokat lemezhiba esetén a paritáscsík segítségével állíthatja helyre. A hibás szektorok feltérképezése a rendszer számára lehetővé teszi a szektorhibák felhasználói beavatkozás nélküli helyreállítását.

Ez a szakasz röviden ismerteti, hogyan állítson helyre adatokat meghibásodott lemez tükrözött vagy RAID-5 köteteiről, és meghibásodott szektorokból:

  • Tükrözött és RAID-5 kötetek javítása
  • Szektorhibák javítása


Tükrözött és RAID-5 kötetek javítása

Ha egy tükrözött vagy RAID-5 kötet tagja meghibásodik, árva lesz. A Windows ekkortól ezt nem használhatja, és az új adatok olvasását és írását a hibatűrő kötet további tagjaihoz irányítja.

Ha egy tükrözött kötet valamelyik tagja elárvul, először meg kell szakítania a tükrözési kapcsolatot, hogy a fennmaradó kötetet a rendszer külön kötetként kezelje tovább. A tükrözött kötet fennmaradó tagjához a számítógép a tükrözött kötet korábbi betűjelét rendeli hozzá. Az elárvult kötet a következő szabad meghajtóbetűjelet kapja, de bármely más betűt is hozzárendelhet.

Ezek után új tükrözési kapcsolatot hozhat létre egy másik lemez használaton kívüli, szabad lemezterületével. A számítógép újraindításkor a működőképes kötetből az adatokat a tükrözött kötet új elemére másolja.

További információ a tükrözött kötetek javításával kapcsolatban a Dinamikus tükrözött kötet javítása című témakörben található.

Ha egy RAID-5 kötet valamelyik tagja elárvul, az elárvult tag adatait a fennmaradó tagok segítségével regenerálhatja. A Lemezkezelés programban jelöljön ki egy új szabad lemezterületet, melynek mérete legalább akkora, mint a RAID-5 kötet további tagjainak területe, ezek után regenerálja az adatokat. Ha szükségessé válik a számítógép újraindítása, a hibatűrő meghajtó a többi tagmeghajtón lévő aprózott részekről beolvassa az információt, majd újra létrehozza a hiányzó tag adatait, és azokat az új tagra írja.

A RAID-5 kötet regenerálásához a kötetet az operációs rendszernek kell lezárni. Egy kötet regenerálásakor annak minden hálózati kapcsolata elvész.

További információ a RAID-5 kötet javításával kapcsolatban a Dinamikus RAID-5 kötet javítása című témakörben található.

Megjegyzés

  • Az ebben a szakaszban említett dinamikus lemezek RAID-5 és tükrözött köteteire vonatkozó megjegyzések az alaplemezek paritásos csíkozott készleteire és tükörkészleteire is vonatkoznak.


Szektorhibák javítása

A fájlrendszer a kötetek formázásakor minden szektort ellenőriz. A hibás szektorokat kizárja a szolgáltatásból. A Windows 2000 hibatűrő szolgáltatásai a rendszert szektorhelyreállító képességekkel látják el.

Redundáns adatmásolatokkal rendelkező hibatűrő rendszerben szektor I/O hiba esetén a hibatűrő meghajtó megkísérli a hibás szektorokat a használatból kizárni. Az SCSI (Small Computer Systems Interface) eszközök képesek erre, de az AT eszközök, mint az IDE (Integrated Device Electronics) vagy az ESDI (Enhanced Small Device Interface) nem.

Ha egy szektor nem zárható ki, akkor a redundáns másolatból nyert helyes információ egy hibás szektort jelző állapotüzenettel együtt kerül a fájlrendszerhez. Ezután a fájlrendszer megkísérli meghatározni a hiba helyét, és kizárni a hibás szektort azáltal, hogy eltávolítja a fájlrendszer szektortérképéről. Ha a redundáns másolatot tartalmazó partíció szintén meghibásodik, akkor a rendszer hibaüzenetet jegyez be az Eseménynaplóba az adatvesztés veszélyéről.

A Lemezkezelés program is használható a lemezhibák ellenőrzésére. A lemez Tulajdonságok párbeszédpanelének Eszközök lapján kattintson az Ellenőrzés gombra.


UPS használata

A rész tartalma:

  • UPS-eszköz használata Windows operációs rendszerrel
  • Parancsfájl futtatása az UPS leállásakor


UPS-eszköz használata Windows operációs rendszerrel

A számítógéphez telepített szünetmentes tápegység (UPS) eszközzel az alábbi Windows szolgáltatásokat ajánlott használni: UPS, riasztási szolgáltatás, üzenetkezelő szolgáltatás és Eseménynapló. További ajánlások találhatók a Gyakorlati tanácsok című részben.

Az UPS szolgáltatás telepítéséhez a Vezérlőpulton kattintson az UPS ikonra. A konfigurációt a használt UPS-eszköz által támogatott szolgáltatásokra kell alapozni. A Windows 2000 operációs rendszer által támogatott három szolgáltatás a következő:

  • Hálózati áramszünet felismerése.
  • Akkumulátor lemerülésének felismerése.
  • Az UPS leállítása.

A helyes beállítások meghatározásához figyelmesen olvassa el az UPS-eszköz felhasználói kézikönyvét, vagy lépjen kapcsolatba a gyártóval. Az UPS-eszköz által támogatott egyéb szolgáltatások alapján további beállításokat végezhet el az UPS párbeszédpanel UPS-eszköz tulajdonságai mezőjén.

Az UPS-szolgáltatás számos módon vezérelhető. Az egyik mód, az UPS párbeszédpanel beállításainak módosítása. Egy üzenet jelenik meg, melyben a rendszer megkérdezi, hogy elindítsa-e az UPS-szolgáltatást. A szolgáltatást elindíthatja aVezérlőpult Szolgáltatások ikonjára kattintva is.

A riasztási és az üzenetkezelő szolgáltatások a Windows 2000 elindításával automatikusan elindulnak. A riasztási szolgáltatás riasztja a kijelölt felhasználókat, az üzenetkezelő szolgáltatás a helyi Windows 2000 alapú számítógépnek és a hálózat más felhasználóinak küld üzenetet. Minden felismert energiaellátás-ingadozásról és áramszünetről bejegyzés készül az eseménynaplóba, ugyanúgy, mint az UPS szolgáltatás indítási hibáiról és a kiszolgáló leállításának kezdeményezéseiről.

Hogy megbizonyosodjon róla, hogy a számítógép védett az áramszünetektől, ellenőrzésképpen szimuláljon áramszünetet: húzza ki a tápkábelt az UPS-eszközből. Ha minden helyesen működik, akkor a számítógép és az UPS-eszközhöz csatlakoztatott perifériák működőképesek maradnak, üzenetek jelennek meg, és a rendszer az eseményt naplózza. Várja meg, amíg az UPS akkumulátora lemerül, így ellenőrizheti, hogy sikeres-e a leállás. Illessze vissza a tápkábelt az UPS-eszközbe, ellenőrizze az eseménynaplót, hogy minden művelet bejegyzésre került-e, és hogy történtek-e hibák.


Parancsfájl futtatása az UPS leállásakor

Parancsfájlokat határozhat meg a Windows szünetmentes tápegység (UPS) szolgáltatás számára. Ez azonban csak akkor szükséges, ha a rendszer különleges műveleteket igényel a leállás előtt. Ha például egy másik számítógéphez kapcsolt egyedi program fut, a parancsfájl segítségével befejezheti a munkamenetet és automatikusan kijelentkezhet a számítógépről, mielőtt a rendszer leáll.

Olyan parancsfájlt nem adhat meg, amely párbeszédpanelt jelenít meg, mert a felhasználói beavatkozást igénylő párbeszédpanelek akadályozhatják a rendszer sikeres leállását.

A parancsfájlnak a Rendszergyökér\System32 mappában kell lennie, és a következő kiterjesztések egyikével kell rendelkeznie: .exe, .com, .bat vagy .cmd. A parancsfájl futtatásával kapcsolatos tájékoztatás Az UPS konfigurálása című témakörben található.

Megjegyzés

  • A parancsfájl futása nem tarthat harminc másodpercnél tovább. A harminc másodpercnél hosszabb futási idő veszélyeztetheti a Windows sikeres leállását. A parancsfájl futását a legrosszabb helyzetnek megfelelő körülmények között kell tesztelni.


Forrásmunkák

  • Információk a Windows 2000 Server családról a Microsoft Windows webhelyen (http://www.microsoft.com/)
  • A Microsoft Windows hardverkompatibilitási lista a Microsoft webhelyen (http://www.microsoft.com/)
  • A Microsoft TechNet a magyar és az angol Microsoft TechNet webhelyen (http://www.microsoft.com/)
  • Microsoft TechNet CD-lemezek
  • Microsoft támogatás a Microsoft webhelyen. (http://www.microsoft.com/)
  • Az első lépések a Windows 2000 Server használatakor
  • Windows 2000 Server Resource Kit
  • Windows 2000 Server Rendszerleíró adatbázis
  • Frissített technikai információ


Hibaelhárítás

Mi a probléma?

A tükrözött kötet állapota: Redundanciahiba

Ok: A tükrözött kötet egyik vagy mindkét tagja meghibásodott, a kötet a továbbiakban nem hibatűrő.

Megoldás: Ha a lemez állapota Kapcsolat nélkül, A lemez visszakapcsolása és a tükrözött kötet javítása című témakörben található bővebb információ. Ha a lemez állapota On-line (hibák), akkor a Lemez visszakapcsolása című témakörben található bővebb információ. A lemez állapota lehet még Hiányzó, ha egyáltalán nem érhető el.

A RAID-5 kötet állapota: Redundanciahiba

Ok: A RAID-5 kötet egyik vagy mindegyik tagja meghibásodott, a kötet a továbbiakban nem hibatűrő.

Megoldás: Ha a lemez állapota Kapcsolat nélkül, A lemez visszakapcsolása és a RAID-5 kötet javítása című témakörben található bővebb információ.


Katasztrófa után helyreállítás

A Katasztrófa után helyreállítás magába foglalja a rendszerproblémákra való felkészülést, az egyébként nem elinduló rendszer elindításakor felkínált lehetőségek közötti választást, és a Windows 2000 operációs rendszerben található javítási és helyreállítási lehetőségeket.

  • A Katasztrófa után helyreállításra való felkészülés módjai a Feladatlistákban találhatók.
  • A Windows 2000 Server operációs rendszerben a korábbi verzióktól eltérő helyen található szolgáltatásokkal kapcsolatban a Megszokott feladatok végrehajtásának új módjai részben talál tájékoztatást.
  • A Katasztrófa után helyreállítással kapcsolatos ötletek a Gyakorlati tanácsok oldalon találhatók.
  • A konkrét feladatokról az Útmutató című témakörben olvashat bővebben.
  • Az általános háttérinformációkat a Fogalmak témakörben tekintheti meg.
  • A problémák elhárításával kapcsolatos tennivalókat a Hibaelhárítás című témakörben találja.


Feladatlisták

  • Feladatlista: A rendszer megóvása
  • Feladatlista: Nem induló rendszer helyreállítása


Feladatlista: A rendszer megóvása

Számos előzetes lépést tehet a rendszer megóvása érdekében, melyekkel felkészül lemezmeghibásodás vagy más súlyos rendszerhiba esetére.

Lépés | Hivatkozás
Határozza meg, hogy a Windows 2000 mit tegyen, ha a rendszer váratlanul leáll. Például meghatározhatja, hogy a számítógép induljon újra automatikusan, és ellenőrizze a naplózási beállításokat. | Határozza meg, hogy a Windows 2000 mit tegyen a rendszer váratlan leállásakor
A Windows 2000 rendszerindító lemezeit tartsa könnyen hozzáférhető helyen. Ez lehet a Windows 2000 CD (olyan számítógépekhez, melyek képesek a CD meghajtóról elindulni), vagy a CD segítségével létrehozott hajlékonylemezek. | Rendszerindító lemezek készítése
Hozzon létre Helyreállító lemezt a Biztonsági mentés segítségével. | Helyreállító lemez készítése


Feladatlista: Nem induló rendszer helyreállítása

Lépés | Hivatkozás
Próbálja meg a csökkentett módot és az ahhoz kapcsolódó indítási beállításokat, melyek segítségével a rendszert a minimálisan szükséges szolgáltatásokkal indíthatja el. | A csökkentett módú indítás beállításai
Amennyiben a csökkentett mód nem működik, fontolja meg a Helyreállítási konzol használatát. Ezt a megoldás csak tapasztalt felhasználóknak vagy rendszergazdáknak javasolt. | A Helyreállítási konzol A számítógép elindítása és a Helyreállítási konzol használata
Ha a csökkentett mód és a Helyreállítási konzol a fennálló helyzetben nem alkalmazható, és a megfelelő előkészületeket idejében megtette, akkor a Helyreállító lemezzel megpróbálhatja megoldani a problémát. | Helyreállító lemez használata a rendszer javításához


Gyakorlati tanácsok

  • A rendszerindító és rendszerkötetek szétválasztása
    Helyezze a Windows 2000 Server rendszer- és rendszerindító köteteit, valamint az adatköteteket különböző meghajtókra. Ez jelentős mértékben megkönnyíti a helyreállítást lemezsérülés esetén.
  • A lemezkonfiguráció mentése
    Mentse a lemezkonfigurációs adatokat, ha a konfigurációt a Lemezkezelés program segítségével megváltoztatta.
  • Írásos feljegyzések készítése
    Készítsen írott feljegyzéseket a lemezkötetekről és azok méretéről, így az esetleges helyreállításkor az adatok rendelkezésére állnak. Ezt az információt ragassza az egyes lemezmeghajtók elejére.


Útmutató

  • A rendszer megóvása
  • Nem induló rendszer helyreállítása


A rendszer megóvása

  • Készítsen rendszerindító lemezeket
  • Készítsen Helyreállító lemezt


Rendszerindító lemezek készítése

  1. Készítsen elő négy, formázott, 3.5 hüvelykes, 1.44 megabájtos (MB) hajlékonylemezt.
  2. A lemezek egyikét helyezze egy bármilyen Windows vagy MS-DOS verziót futtató számítógép hajlékonylemez meghajtójába.
  3. Helyezze be a Windows 2000 CD-t a CD-ROM-meghajtóba.
  4. Kattintson a Start gombra, majd a Futtatás parancsra.
  5. A Megnyitás mezőbe írja be: d:\bootdisk\makeboot a: (ahol d a CD-ROM-meghajtóhoz rendelt betű), majd kattintson az OK gombra.
  6. Kövesse a képernyőn megjelenő utasításokat.

Megjegyzések

  • A Windows 2000 Professional CD-ről létrehozott lemezek nem használhatók a Windows 2000 Server rendszer indításához és viszont.
  • Mielőtt úgy dönt, hogy a számítógépet CD-ről vagy hajlékonylemezről indítja el, kísérelje meg a számítógépet csökkentett módban elindítani.
  • Miután egy leállt számítógépet hajlékonylemezről elindított, használhatja a Helyreállítási konzolt vagy a Helyreállító lemezt (ha korábban készített ilyet).

Kapcsolódó témakörök


Helyreállító lemez készítése

  1. Készítsen elő egy üres, formázott, 1,44 megabájtos (MB) hajlékonylemezt.
  3. Az Üdvözöljük lapon kattintson a Helyreállító lemez ikonra.
  4. Kövessük a képernyőn megjelenő utasításokat.

Fontos

  • A Telepítő befejezésekor az eredeti rendszerbeállításokkal kapcsolatos információt a számítógép a rendszerpartícióba, a rendszergyökér\Repair mappába menti. Ha a rendszer helyreállításához Helyreállító lemezt használ, hozzáférhet a mappában tárolt információhoz. Ezt a mappát ne módosítsa és ne törölje.

Megjegyzés

  • A Biztonságimásolat-készítő programot elindíthatja, ha a Start gombra kattint, a Programok, Kellékek majd a Rendszereszközök pontokra mutat, és a Biztonsági mentés parancsra kattint.

Kapcsolódó témakörök


Nem induló rendszer helyreállítása

  • Indítsa el a Windows 2000 operációs rendszert csökkentett módban
  • Indítsa el a Windows 2000 operációs rendszert a Legutolsó helyes konfiguráció használatával
  • Indítsa el a számítógépet a parancssorból
  • Indítsa el a számítógépet és használja a Helyreállítási konzolt
  • A Helyreállító lemezt használja a rendszer javításához


A számítógép indítása és a Helyreállítási konzol használata

  1. Helyezze be a Windows 2000 Telepítő CD-t, vagy a CD segítségével létrehozott hajlékonylemezek közül az elsőt a megfelelő meghajtóba.
    • Olyan rendszereknél, melyek nem indulnak el (a rendszerindítás nem lehetséges) CD- meghajtóról, a hajlékonylemezeket kell használni.
    • Olyan rendszereknél, melyek elindulnak (a rendszerindítás lehetséges) CD-meghajtóról, a hajlékonylemezek vagy a CD-lemez egyaránt használhatók.
  2. Indítsa újra a számítógépet, és ha hajlékonylemezt használ, a kért lemezeket a megfelelő sorrendben helyezze a meghajtóba.
  3. A telepítő szöveges részének elindulásakor kövesse a képernyőn megjelenő utasításokat, a J billentyű leütésével válassza ki a javítás vagy helyreállítás lehetőséget.
  4. A kérdésre a C billentyűt lenyomva válassza a Helyreállítási konzolt.
  5. Kövesse a képernyőn megjelenő utasításokat, és azoknak megfelelően helyezze be a rendszer elindításához létrehozott hajlékonylemezeket a meghajtóba.
  6. Ha kettős vagy többszörös betöltésű rendszert használ, a Helyreállítási konzolon válassza azt a Windows 2000 telepítést, amihez hozzá kíván férni.
  7. Kérésre írja be a Rendszergazda jelszót.
  8. A Helyreállítási konzol parancsokat a rendszer parancssorába írhatja be, a help paranccsal kérheti a parancsok listáját, a help parancsnév parancs segítségével az egyes parancsokkal kapcsolatos súgót kérheti.
  9. A Helyreállítási konzolból való kilépéshez és a számítógép újraindításához írja be: exit.

Fontos

  • Mivel a Helyreállítási konzol igen nagy hatásfokú eszköz, használata csak gyakorlott felhasználóknak és rendszergazdáknak ajánlott.

Kapcsolódó témakörök


Helyreállító lemez használata a rendszer javításához

  1. Helyezze be a Windows 2000 Telepítő CD-t, vagy a CD segítségével létrehozott hajlékonylemezek közül az elsőt a megfelelő meghajtóba.
    • Olyan rendszereknél, melyek nem indulnak el (a rendszerindítás nem lehetséges) CD- meghajtóról, a hajlékonylemezeket kell használni.
    • Olyan rendszereknél, melyek elindulnak (a rendszerindítás lehetséges) CD-meghajtóról, a hajlékonylemezek vagy a CD-lemez egyaránt használhatók.
  2. Indítsa újra a számítógépet, és ha hajlékonylemezt használ, a kért lemezeket a megfelelő sorrendben helyezze a meghajtóba.
  3. A telepítő szöveges részének kezdetekor kövesse a képernyőn megjelenő utasításokat, a J billentyű leütésével válassza ki a javítási és helyreállítási beállításokat.
  4. Kérésre helyezze be a Windows 2000 Telepítő CD-t a megfelelő meghajtóba.
  5. Kérésre az R billentyű leütésével válassza ki a megfelelő helyreállító folyamatot.
  6. Kérésre válasszon az alábbi lehetőségek közül:
    • Kézi helyreállítás (nyomja le az M billentyűt): Ez a lehetőség csak gyakorlott felhasználók vagy rendszergazdák számára ajánlott. Ezzel a lehetőséggel választhat, hogy a rendszerfájlokat, a partícióbetöltő-szektor problémáit, vagy az indítási környezet problémáit kívánja helyreállítani.
    • Gyors helyreállítás (nyomja le az F billentyűt): Ez a legegyszerűbb lehetőség, külső beavatkozást nem igényel. Ha ezt a lehetőséget választja, a gyors javítás a rendszerfájlokkal, a betöltő egység partícióbetöltő-szektorával, valamint (kettős betöltésű vagy többszörös betöltésű rendszereknél) az indítási környezettel kapcsolatos problémák elhárítására tesz kísérletet.
  7. Kövesse a képernyőn megjelenő utasításokat, és kérésre helyezze be a Helyreállító lemezt a megfelelő meghajtóba.

    A helyreállító folyamat közben a rendszer a hiányzó vagy sérült fájlokat a Windows 2000 CD-n vagy a rendszerpartíció rendszergyökér\Repair könyvtárában lévő fájlokkal cseréli fel. A fájlok bármely forrásból történő cseréje nem befolyásolja a telepítés óta végrehajtott konfigurációs változtatásokat.

  8. Kövesse a képernyőn megjelenő utasításokat, szükséges lehet a hibásnak vagy helytelennek minősített fájlok neveinek rögzítése, ezekből következtethet a rendszer meghibásodásának okára.
  9. Ha a helyreállítás sikeres, hagyja végigfutni a folyamatot, amely újraindítja a számítógépet.

    A számítógép újraindítása jelzi, hogy a fájlokat a helyreállítás sikeresen a merevlemezre másolta.

Fontos

  • Mivel a helyreállító folyamat igen nagy hatásfokú eszköz, használata csak gyakorlott felhasználóknak és rendszergazdáknak ajánlott.

Kapcsolódó témakörök


Fogalmak

  • Katasztrófa után helyreállítás – áttekintés
  • A katasztrófa utáni helyreállítás magyarázata
  • A katasztrófa utáni helyreállítási lehetőségek használata
  • Forrásmunkák


Katasztrófa után helyreállítás – áttekintés

Számítógép-katasztrófa bármely olyan esemény, amely a számítógép elindítását vagy futását megakadályozza. A számítógép-katasztrófák okai a hardverelemek meghibásodásától a rendszer teljes elvesztéséig terjednek (például tűz, vagy hasonló esetek következtében). Ha a Windows 2000 hasonló hibával találkozik, akkor valószínűleg STOP hibát jelent, és megjeleníti a Microsoft Technikai Tanácsadó Szolgáltatások mérnökei számára a hibás területek azonosításához szükséges információt.

A katasztrófa utáni helyreállítás a számítógép helyreállítása annak érdekében, hogy a katasztrófahelyzet után be tudjon jelentkezni, és hozzá tudjon férni a rendszer erőforrásaihoz. A Windows 2000 az alábbi lehetőségeket kínálja a számítógép-katasztrófa azonosításához, és az azt követő helyreállításhoz.

Csökkentett mód
Csökkentett módú indítási beállításokat használhat a rendszer minimálisan szükséges szolgáltatásokkal való elindításához. A csökkentett módú beállítások, például a Legutolsó helyes konfiguráció, különösen akkor hasznosak, ha a rendszerindítási problémát egy újonnan telepített eszközillesztő okozza. További információ A csökkentett módú indítás beállításai című témakörben található.

Helyreállítási konzol
Amennyiben a csökkentett mód nem működik, fontolja meg a Helyreállítási konzol használatát. Ez a megoldás csak tapasztalt felhasználóknak vagy rendszergazdáknak javasolt. A rendszert a Telepítő CD, vagy a CD segítségével létrehozott hajlékonylemezek használatával indíthatja el. Ezután elérheti a Helyreállítási konzol nevű parancssoros felületet, melyről különböző feladatokat hajthat végre, például szolgáltatásokat indíthat el és állíthat le, és hozzáférhet a helyi meghajtókhoz (az NTFS fájlrendszerrel formázott meghajtókhoz is). További információ A Helyreállítási konzol című témakörben található.

Helyreállító lemez
Ha a csökkentett mód és a Helyreállítási konzol a fennálló helyzetben nem alkalmazható, és a megfelelő előkészületeket idejében megtette, akkor megpróbálhatja a Helyreállító lemezzel megoldani a problémát. A Helyreállító lemez segíthet a központi rendszerfájlok helyreállításában.


A katasztrófa utáni helyreállítás ismertetése

A rész tartalma:
  • A csökkentett módú indítás beállításai
  • A Helyreállítási konzol
  • Helyreállító lemez


A Helyreállítási konzol

Ha a csökkentett mód és az egyéb indítási lehetőségek nem működnek, megfontolhatja a Helyreállítási konzol használatát, azonban ez az eljárás csak a tapasztalt felhasználóknak és rendszergazdáknak ajánlott, akik az alapvető parancsok segítségével azonosítani tudják és meg tudják keresni a problémás eszköz-illesztőprogramokat és fájlokat. A Helyreállítási konzol egy parancssoros konzol, mely a számítógép – ha a CD-meghajtó ezt lehetővé teszi – Telepítő CD-vel, ha nem, a CD segítségével létrehozott hajlékonylemezekkel való elindítása után használható. A hajlékonylemezeknek a Telepítő CD segítségével való készítéséről további információ a Rendszerindító lemezek készítése című témakörben található.

A Helyreállítási konzol használatához a Rendszergazda fiókba kell bejelentkezni. A konzollal parancsokat futtathat, ezekkel egyszerű műveleteket hajthat végre, mint a könyvtárváltás vagy könyvtárak megtekintése, és hatékonyabb műveleteket, mint a rendszerindító szektor helyreállítása. A Helyreállítási konzol Súgóját a help parancsot a Helyreállítási konzol parancssorába gépelve érheti el.

A Helyreállítási konzol segítségével elindíthat és leállíthat szolgáltatásokat, olvashat és írhat adatokat a helyi meghajtókra (az NTFS fájlrendszerrel formázottakra is), hajlékonylemezről vagy CD-ről másolhat fájlokat, formázhat meghajtókat, helyreállíthatja a rendszerindító szektort vagy a fő rendszerindító rekordot, és más rendszergazdai feladatokat is elláthat. A Helyreállítási konzol akkor különösen hasznos, ha a rendszer helyreállításához fájlokat kell hajlékonylemezről, vagy CD-ROM-meghajtóról a merevlemezre másolni, vagy egy olyan szolgáltatást kell újra konfigurálni, ami megakadályozza a számítógép helyes elindítását. A Helyreállítási konzolt használhatja például, ha egy felülírt vagy megsérült eszköz-illesztőprogram fájlt annak hajlékonylemezen tárolt hibátlan változatával kíván felcserélni.

Fontos

  • Mivel a Helyreállítási konzol igen nagy hatásfokú eszköz, használata csak gyakorlott felhasználóknak és rendszergazdáknak ajánlott.


Helyreállító lemez

A Windows 2000 Helyreállító lemez segítségével kiküszöbölheti a számítógép elindítását megakadályozó problémákat.

Ha Helyreállító lemezt készít, amikor a számítógép helyesen működik, azzal felkészül arra, hogy szükség esetén a rendszerfájlokat kijavítsa. (Ilyen helyzetben a javítandó számítógép elindításához használja a Windows 2000 Telepítő CD-t, vagy a CD segítségével létrehozott hajlékonylemezeket.) Az ezzel a módszerrel végrehajtható javítások az alapvető rendszerfájlokra, a partícióbetöltő-szektorra és az indítási környezetre korlátozódnak. A helyreállítási folyamat nem állítja helyre a rendszerleíró adatbázist. A rendszerleíróadatbázis-fájlok cseréjéhez használja a Helyreállítási konzolt. A Helyreállító lemez nem készít biztonsági másolatot az adatokról és programokról, így nem helyettesíti a rendszeres biztonságimásolat-készítést.

További információ a Helyreállító lemez létrehozása és A Helyreállító lemez használata a rendszer javításához című témakörökben található.


A katasztrófa utáni helyreállítási lehetőségek használata

  • Rendszerbetöltési hiba javítása
  • Eszközök és technikák


Rendszerindítási hiba javítása

Ha egy lemez rendszer- vagy rendszerindító kötete meghibásodik, a rendszer nem indul el. A rendszerindítási hiba helyreállításának módja a lemezkonfigurációtól függ.

Olyan rendszer- vagy rendszerindító kötet, mely csíkozott kötet részeként van konfigurálva (az egyetlen hibatűrő módszer, mely rendszer- vagy rendszerindító kötetre alkalmazható), helyreállítása történhet rendszerindító lemez használatával.

Rendszerindító lemez

A rendszerindító lemez készítéséhez tekintse meg a Rendszerindító lemezek készítése című részt. Miután létrehozta a rendszerindító lemezt, azt a hibák bekövetkezése előtt ellenőriznie kell, különben előfordulhat, hogy az elsődleges lemez meghibásodása esetén nem tudja a számítógépet a tükrözött kötetről elindítani. A rendszerindító lemezeket a rendszer tükrözött kötetről való elindításával ellenőrizheti. Az első ellenőrzéskor az elsődleges lemez legyen bekapcsolva, a második ellenőrzéskor pedig kikapcsolva. Ha mindkét esetben be tud jelentkezni, a rendszerindító lemezek működnek.

A rendszerindító konfiguráció karbantartása

Miután a Windows sikeresen elindult, készítsen biztonsági másolatot a konfigurációs könyvtárról (\rendszergyökér\System32\Config), és azt a konfiguráció és a fiókok módosításakor minden esetben frissítse. A rendszerleíró adatbázis a konfigurációs könyvtárban található fájlokból áll.

Ha a Windows Telepítő Javítás folyamatát kell használnia a rendszerleíró adatbázis fájljainak helyreállításához, a biztonsági másolat segítségével helyreállíthatja a konfigurációt.

Soha ne törölje a Boot.ini, Ntldr, Bootsect.dos, Ntdetect.com, vagy Ntbootdd.sys (ha a Windows SCSI lemezre van telepítve) fájlokat a rendszerkötet gyökérkönyvtárából.

Ha olyan rendszert módosít, melyen korábban a Windows sikeresen elindult, és a módosítás után ezt nem teszi, a korábbi konfigurációhoz visszatérhet a rendszerindítás Legutolsó helyes konfiguráció lehetőségét választva. Ha a Windows továbbra sem indul el, a Windows Telepítő Javítás eljárása segítségével indítsa újra a rendszert. A rendszer indítása után a biztonsági másolatok segítségével helyreállíthatja az adatokat.

A Config.nt és az Autoexec.nt fájlok javítása

Ha a Windows ezekre a fájlokra vonatkozó hibaüzenetet küld, vagy problémái vannak az MS-DOS alapú programok futtatásával, ellenőrizze, hogy a Config.nt vagy az Autoexec.nt fájlok léteznek és nem hibásak. A fájlok a \Rendszergyökér\System32 könyvtárban találhatók.

Ha ezek a fájlok hibásak vagy hiányoznak, másolja az új változatokat a rendszerbetöltő lemezről a \System32 könyvtárba.


Eszközök és technikák

A Windows 2000 operációs rendszerben az alábbi rendszerdiagnosztikai, helyreállítási és javítási lehetőségek állnak rendelkezésre:

  • A Windows 2000 Rendszerinformáció használata a konfigurációs problémák megállapításához.
  • A Vezérlőpult Rendszer párbeszédpanelének Speciális lapján elindítható Indítás és helyreállítás párbeszédpanel Rendszerhiba mezőjében határozza meg, hogyan rögzítse a Windows 2000 Server a súlyos hibákat, és hogyan reagáljon azokra.
  • A legutóbbi működőképes konfiguráció helyreállítása a Legutolsó helyes konfiguráció segítségével.
  • Rendszerindítás csökkentett módban a rendszer alapvető funkcióinak helyreállítása végett.
  • Sérült vagy hiányzó rendszerfájlok, valamint a rendszertöltő szektor és a konfigurációs információk helyreállítása a Windows 2000 Telepítő Javítás folyamata segítségével.
  • Rendszerindító lemez létrehozása és használata a számítógép elindításához az elsődleges kötet meghibásodása után. Részletek a Rendszerindítási hiba javítása című témakörben találhatók.

Windows 2000 Rendszerinformáció

A Windows 2000 Rendszerinformáció nevű Windows 2000 diagnosztikai eszközt használhatja a helyi vagy hálózati számítógép konfigurációs információinak megtekintésére és kinyomtatására. A Windows 2000 Rendszerinformáció a Felügyeleti eszközök menüből megnyitható Számítógép-kezelés beépülő modul Rendszereszközök pontja alatt érhető el.

A Windows 2000 Rendszerinformáció segítségével az alábbi információkhoz juthat:

  • Erőforrások ütközése és megosztása
  • Az operációs rendszerrel kapcsolatos információk, például a verziószám és a rendszerindító beállítások, illetve a folyamatok, a rendszer és felhasználói környezet változói
  • Hardverrel kapcsolatos részletek, mint a BIOS-információk, a képfelbontás, a CPU típusa és verziószáma
  • Fizikai memória, a lapozófájllal kapcsolatos információk, a közvetlen memóriahozzáférés (DMA) használata
  • A számítógép illesztőprogramjainak és szolgáltatásainak jelenlegi állapota
  • A számítógéphez csatlakoztatott meghajtók és eszközök, valamint a hozzájuk tartozó megszakítás- (IRQ) és portinformációk.
  • Hálózati információk, például átvitelek, konfigurációs beállítások és statisztikák
  • Nyomtatóbeállítások, betűtípus-beállítások és a futó rendszerfolyamatok

Rendszerhiba-jelentések

Súlyos hiba (STOP hiba) esetén a rendszer alapértelmezés szerint az alábbi lépéseket hajtja végre:

  • Bejegyzést készít a rendszernaplóba
  • Riasztja a rendszergazdákat
  • A rendszermemóriát egy fájlba másolja a későbbi hibakereséshez
  • Automatikusan újraindítja a kiszolgálót

A végzetes rendszerhibák rövidebb leállást okoznak, mivel a Windows 2000 Server automatikusan újraindul, ahelyett, hogy a rendszergazda beavatkozására várna.

A rendszermemória naplófájlba másolása igen hasznos lehet a STOP hiba okának felderítéséhez. Ha a hibával kapcsolatban érintkezésbe lép a technikai támogatás képviselőivel, ők kérhetik a naplófájlt. Ne feledje, hogy a Windows 2000 minden STOP hiba előfordulásakor azonos néven menti el a naplófájlt (alapértelmezés szerint Memory.dmp). A naplófájlok megőrzése érdekében azokat a számítógép újraindulása után mentse új néven. A helyreállítási beállításokkal kapcsolatban további információ a Helyreállítási műveletek kiválasztása a Windows 2000 váratlan leállása esetén című témakörben található.

Legutolsó helyes konfiguráció

Ha új illesztőprogram telepítése vagy az illesztőprogram konfigurációjának megváltoztatása után nehézségbe ütközik a Windows elindításakor, a Windows operációs rendszert a Legutolsó helyes konfiguráció segítségével indíthatja újra. Ekkor a konfiguráció visszaáll az indítást megakadályozó változtatások előtti állapotba. Az utolsó sikeres indítás óta végrehajtott konfiguráció-módosítások elvesznek. A Windows 2000 rendszernek a Legutolsó helyes konfiguráció segítségével való elindításával kapcsolatos tájékoztatás a Windows 2000 indítása a Legutolsó helyes konfiguráció segítségével című témakörben található.

Rendszerindítás csökkentett módban

A számítógép sokszor olyankor is elindítható csökkentett módban, ha egyébként nem indul el. Csökkentett módban a Windows csak alapértelmezés szerinti beállításokat használ (VGA monitor, Microsoft egérvezérlő, a Windows indításához minimálisan szükséges eszközillesztők, és nincs hálózat). A Windows 2000 csökkentett módú elindításával kapcsolatos információ A Windows 2000 indítása csökkentett módban című témakörben található.

Egyéb hibakeresési eljárások

Az alábbiakban található néhány más eljárás, melyekkel a Windows 2000 Server jelenti a hibákat, és megőrzi a rendszerkonfigurációt és az adatokat:

  • Ha a rendszer NTFS fájlrendszert használ, a Windows 2000 Server minden fájltranzakciót naplóz, a hibás szektorcsoportokat automatikusan javítja, és tárolja az NTFS-kötetfájlok alapvető információinak másolatát.
  • A szolgáltatások és programok az eseményeket, például a hibákat, bejegyzik az eseménynaplókba, ezeket a bejegyzéseket az Eseménynaplóban megtekintheti. Az Eseménynaplóval kapcsolatos további információ Az Eseménynapló használata című témakörben található.
  • A riasztási és üzenetkezelő szolgáltatások együttesen figyelmeztetik a nyomtatóval, adatbiztonsággal és a felhasználói munkamenetekkel kapcsolatos problémákra. Ezek a szolgáltatások a kiszolgáló leállásáról is küldenek riasztást, ha a rendszer UPS-szolgáltatást használ. A szünetmentes áramforrással kapcsolatos információ az UPS használata című témakörben található.
  • A teljesítménynaplók és riasztások konfigurálhatók úgy, hogy riasztási naplót hozzanak létre a teljesítmény figyeléséhez, és hálózati riasztásokat generáljanak. A Teljesítménynaplókkal és riasztásokkal kapcsolatos információ a Teljesítménynaplók és riasztások – áttekintés című témakörben található.
  • A chkdsk parancs megvizsgálja a lemezterületet, valamint az NTFS és fájlallokációs tábla (FAT) fájlrendszerek használatát. Amennyiben a lemezen hibák találhatók, a chkdsk riasztást küld, és az /f kapcsoló használata esetén a hibákat ki is javítja. Ha egyes fájlok nyitva vannak, amikor a chkdsk megkísérli a lemezhibák helyreállítását, akkor a chkdsk képes a számítógép következő indításakor automatikusan ellenőrizni a lemezt és a kijavítani hibákat. A chkdsk futtatásával kapcsolatos további információ a Chkdsk című témakörben található.

Fontos

  • Ha nagyon nagy kötetekben használja a chkdsk parancsot fájlrendszerhibák és hibás szektorok javítására, akkor több napra elérhetetlenné teheti a kötetet.
  • A Dr. Watson for Windows program segítségével azonosíthatja, diagnosztizálhatja és naplózhatja az alkalmazások hibáit a technikai támogatás szakemberei számára. A Dr. Watson futtatásához a parancssorba írja be: start drwtsn32. Az F1 billentyű lenyomásával Súgót kérhet a Dr. Watson telepítéséhez és használatához.


Forrásmunkák

  • Információ a Windows 2000 Server családról a Microsoft Windows webhelyen (http://www.microsoft.com/)
  • A Microsoft TechNet a magyar és az angol Microsoft TechNet webhelyen (http://www.microsoft.com/)
  • Microsoft TechNet CD-lemezek
  • Microsoft támogatás a Microsoft webhelyen (http://www.microsoft.com/)
  • Az első lépések a Windows 2000 Server használatakor
  • Windows 2000 Server Resource Kit
  • Windows 2000 Server Rendszerleíró adatbázis
  • Frissített technikai információ


Hibaelhárítás

Mi a probléma?

A számítógép leáll, és STOP szóval kezdődő hosszú hibaüzenet jelenik meg.

Ok: A Windows olyan hibával találkozott, melyet nem tud helyreállítani, és a fájlok károsodásának elkerülése érdekében működését leállította.

Megoldás: A STOP hibaüzenetekkel kapcsolatos általános hibaelhárításról a Hibaelhárítás – STOP hibaüzenetek: általános stratégiák című témakörben talál bővebb információt. A STOP hibaüzenetekkel kapcsolatos hibaelhárításról a Hibaelhárítás – meghatározott STOP hibaüzenetek című témakörben található, az egyes hibatípusokra vonatkozó részletes információ.

Lásd még: A töredezettségmentesítés ajánlott gyakorisága, és a Kötet töredezettségmentesítése című témaköröket.

A számítógép támogatja a CD-ROM meghajtóról való indítást. A Windows 2000 CD-ről indításkor azonban nem történik semmi.

Ok: A számítógép csak akkor indítható egyenesen a Windows 2000 CD-ről, ha a számítógép BIOS támogatja az El Torito Bootable CD-ROM (nincs emuláció) formátumot. Előfordulhat, hogy a számítógép BIOS-a nem támogatja ezt a formátumot.

Megoldás: Érdeklődjön a számítógép gyártójánál, ha bizonytalan a BIOS ezen szolgáltatásával kapcsolatban. A BIOS határozza meg a rendszerbetöltés sorrendjét. A CD-ROM meghajtónak az első rendszerbetöltő-eszközként kell szerepelnie.


Megszokott feladatok végrehajtásának új módjai

Az alábbi táblázat a Windows NT 4.0-ás verziónál megismert katasztrófa utáni helyreállítás feladatait, és a Windows 2000 megegyező feladatait hasonlítja össze.
Cél | Windows NT 4.0 operációs rendszerben | Windows 2000 operációs rendszerben
Helyreállító lemez készítése | A Start menü Rdisk parancsával. | A Rendszereszközök menü Biztonsági mentés parancsával. További információ a Helyreállító lemez készítése című témakörben található.


A Helyreállítási konzol használata Windows 2000 operációs rendszert futtató számítógépen

  1. Helyezze be a Windows 2000 CD-t a CD-meghajtóba.
  2. Kattintson a Fájl menüben a Futtatás parancsra.
  3. A Megnyitás mezőbe írja be a megfelelő parancsot:

    d:\i386\winnt32 /cmdcons (ahol d a CD-ROM-meghajtóhoz rendelt betű)

  4. Ha kettős vagy többszörös betöltésű rendszert használ, a Helyreállítási konzolon válassza azt a Windows 2000 telepítést, amihez hozzá kíván férni.
  5. Kérésre írja be a Rendszergazda jelszót.
  6. A Helyreállítási konzol parancsokat a rendszer parancssorába írhatja be, a help paranccsal kérheti a parancsok listáját, a help parancsnév parancs segítségével az egyes parancsokkal kapcsolatos súgót kérheti.
  7. A Helyreállítási konzolból való kilépéshez és a számítógép újraindításához írja be: exit.

Fontos

  • Mivel a Helyreállítási konzol igen nagy hatásfokú eszköz, használata csak gyakorlott felhasználóknak és rendszergazdáknak ajánlott.

Kapcsolódó témakörök