Lemeztöredezettség-mentesítő

A Lemeztöredezettség-mentesítő a helyi kötetek töredezett fájljainak és mappáinak megkeresésére, valamint a fájl- és mappatöredékek egyesítésére szolgáló rendszereszköz.

  • Az adott kötet fájljainak vagy mappáinak töredezettségmentesítése előtt olvassa el a következő témakört: Feladatlista: Lemezek töredezettségmentesítése.
  • A Lemeztöredezettség-mentesítő alkalmazással kapcsolatos gyakorlati tanácsok a következő témakörben olvashatók: Gyakorlati tanácsok.
  • A konkrét feladatokkal kapcsolatban a következő oldalon tájékozódhat: Útmutató.
  • Az általános háttérinformációkat a következő témakörben tekintheti meg: Fogalmak.
  • A problémák elhárításáról a következő témakörben olvashat: Hibaelhárítás.


Feladatlista: Lemezek töredezettségmentesítése

Lépés | Hivatkozás
Tekintse át a kulcsfogalmakat. | Lemeztöredezettség-mentesítő – áttekintés; Gyakorlati tanácsok
Erősítse meg, hogy tagja a Rendszergazdák csoportnak. | Csoportok
Elemezze a kötetet. | Kötet elemzése
Töredezettségmentesítse a kötetet. | Kötet töredezettségmentesítése
Tekintse meg a jelentést. | Jelentések megtekintése


Gyakorlati tanácsok

  • Kötetelemzés töredezettségmentesítés előtt
    Töredezettségmentesítés előtt elemzi a köteteket. Jelzi a felhasználónak, hogy a kötetet töredezettségmentesíteni kell-e vagy sem.
  • Kötetelemzés nagyszámú fájl törlését követően
    Ha a felhasználók nagyszámú fájlt vagy mappát törölnek, az egyes kötetek túlzottan töredezetté válhatnak, ezért ilyen esetben ne feledkezzen meg a kötetek elemzéséről a törlést követően. Az erősen terhelt fájlkiszolgálók köteteit rendszerint gyakrabban kell töredezettségmentesíteni, mint a csak egy felhasználó által használt munkaállomásokét.
  • Kötetelemzés alacsony terheltség időszakában
    A fájlkiszolgáló köteteit célszerű az alacsony terheltség időszakában töredezettségmentesíteni, mivel ilyenkor a legkisebb a töredezettségmentesítési folyamat kiszolgálóteljesítményre gyakorolt hatása. A Lemeztöredezettség-mentesítő alkalmazás az egyes köteteket más és más idő alatt képes töredezettségmentesíteni. Ez az időtartam számos tényezőtől függ, például a kötetmérettől, a köteten lévő fájlok számától, a töredezett fájlok számától és a rendelkezésre álló rendszererőforrásoktól.


Útmutató

  • Kötet elemzése
  • Kötet töredezettségmentesítése


Kötet elemzése

  1. Nyissa meg a Lemez-töredezettségmentesítő segédprogramot.
  2. Kattintson arra a kötetre, amelyen meg kívánja keresni a töredezett fájlokat és mappákat, majd kattintson az Elemzés gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Lemez-töredezettségmentesítő elindításához kattintson a Start gombra, mutasson a Programok, majd a Kellékek, majd a Rendszereszközök pontra, végül kattintson a Lemez-töredezettségmentesítő parancsra.
  • Az elemzés befejeződése után a megjelenő párbeszédpanel tájékoztatja arról, hogy szükséges-e a kötet töredezettségmentesítése.
  • Ha meg akarja szakítani, vagy ideiglenesen szüneteltetni kívánja az elemzést, kattintson a Leállítás illetve a Szüneteltetés gombra.
  • Az elemzett fájlokról és mappákról a Jelentés megtekintése gombra kattintva kaphat további információt.
  • Csak a helyi fájlrendszer-köteteket lehet töredezettségmentesíteni, és egyszerre csak egy Lemez-töredezettségmentesítő kezelőpult futtatható.

Kapcsolódó témakörök


A kötet töredezettségmentesítése

  1. Nyissa meg a Lemez-töredezettségmentesítő segédprogramot.
  2. Válassza ki a töredezettségmentesíteni kívánt kötetet, majd kattintson a Töredezettségmentesítés gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Lemez-töredezettségmentesítő elindításához kattintson a Start gombra, mutasson a Programok, majd a Kellékek, majd a Rendszereszközök pontra, végül kattintson a Lemez-töredezettségmentesítő parancsra.
  • A köteteket töredezettségmentesítés előtt elemezni kell. Elemzés nélkül nem lehet megmondani, hogy érdemes-e töredezettségmentesíteni a köteteket.
  • A kötet töredezettségmentesítéséhez szükséges idő sok tényezőtől függ, többek között a kötet méretétől, a köteten található fájlok számától, a kötet töredezettségi százalékától, és a rendelkezésre álló rendszererőforrásoktól.
  • Ha meg akarja szakítani, vagy ideiglenesen szüneteltetni kívánja a kötet töredezettségmentesítését, kattintson a Leállítás illetve a Szüneteltetés gombra.
  • Csak a helyi fájlrendszer-köteteket lehet töredezettségmentesíteni, és egyszerre csak egy Lemez-töredezettségmentesítő kezelőpult futtatható.

Kapcsolódó témakörök


Fogalmak

A rész tartalma:

  • Lemeztöredezettség-mentesítő – áttekintés
  • A Lemeztöredezettség-mentesítő ismertetése
  • A Lemeztöredezettség-mentesítő használata
  • Forrásmunkák


Lemeztöredezettség-mentesítő – áttekintés

A Lemeztöredezettség-mentesítő a helyi köteteken lévő töredezett fájlokat és mappákat keresi meg.

Ha egy adott kötet sok töredezett fájlt vagy mappát tartalmaz, a Windows rendszernek hosszabb idő kell a megkeresésükhöz, mert a fájlok és mappák egyes darabjainak különböző helyekről történő összegyűjtése több lemezolvasási műveletet igényel. Több időt vesz igénybe az új fájlok és mappák létrehozása is, mivel a kötet felhasználható szabad területe nem egységes. A Windows ezért a kötet különböző helyeire kell, hogy mentse az új fájlokat és mappákat.

A Lemeztöredezettség-mentesítő az adott fájl vagy mappa minden egyes darabját a kötet egyetlen helyére helyezi át, így azok a meghajtó egyetlen, összefüggő területén helyezkednek el. Ennek eredményeként a rendszer hatékonyabban tudja a fájlokat és mappákat olvasni, illetve az újakat menteni. A fájlok és mappák töredezettségének megszüntetésével a Lemeztöredezettség-mentesítő a lemez szabad tárterületét is egységesíti, ezáltal csökken az új fájlok töredezettségének valószínűsége.

A töredezett fájlok és mappák megkeresésének és egységesítésének folyamatát nevezik töredezettségmentesítésnek. A töredezettségmentesítéshez szükséges idő számos tényezőtől függ, például a kötetmérettől, a köteten lévő fájlok számától, a töredezett fájlok és mappák számától, valamint a rendelkezésre álló rendszererőforrásoktól. A kötet töredezettségmentesítés előtti elemzésével megkeresheti az összes töredezett fájlt és mappát. Az elemzés végrehajtása után láthatja, hogy hány töredezett fájl és mappa található a köteten, és eldöntheti, hogy érdemes-e a kötetet töredezettségmentesíteni.

A Lemeztöredezettség-mentesítő a fájlallokációs tábla (FAT), az FAT32, valamint az NTFS fájlrendszerrel formázott kötetek töredezettségét tudja megszüntetni.


A Lemeztöredezettség-mentesítő ismertetése

A rész tartalma:

  • Miért válnak töredezetté a kötetek?
  • Miért nem kerülnek a fájlok az NTFS-formátumú kötet elejére?
  • Miért különböznek a grafikus és a szöveges nézetek?
  • Kötet szabad lemezterületeinek egyesítése


A kötetek töredezetté válásának okai

A kötetek úgy válnak töredezetté, hogy a felhasználók fájlokat és mappákat hoznak létre vagy törölnek, új szoftvert telepítenek, vagy fájlokat töltenek le az Internetről. A számítógépek nem feltétlenül mentik egy helyre a teljes fájlt vagy mappát, a mentés általában a köteten először rendelkezésre álló szabad területre történik. Ha a kötet nagy részén már voltak tárolva fájlok vagy mappák, a rendszer az új fájlok legtöbbjét darabokban menti a kötet különböző részeire. A fájlok vagy mappák törlésekor hátramaradt üres területek véletlenszerűen töltődnek fel az új fájlokkal és mappákkal.

Minél töredezettebb a kötet, annál lassabban írja illetve olvassa a számítógép a fájlokat.

Kapcsolódó témakörök


Miért nem helyezi át a rendszer a fájlokat az NTFS formátumú kötetek elejére?

Az NTFS formátumú köteteken a Windows a szabad terület egy részét a fő fájltáblázat (MFT) nevű rendszerfájl számára tartja fenn. A Windows az MFT fájlban tartja a köteten található fájlok lekéréséhez szükséges valamennyi információt. A Windows az MFT egy részét a kötet elején tárolja. Mivel a Windows kizárólagos használatra tartja fenn az MFT fájlt, a Lemez-töredezettségmentesítő nem helyez fájlokat a kötetek elejére.

Kapcsolódó témakörök


Miért különböznek a grafikus és a szöveges nézetek?

Az adott kötet elemzése után az eredmények az Elemzés megjelenítése nevű ablakban, egy vízszintes színes sávdiagramon jelennek meg, de megtekinthetők az elemzés adatait tartalmazó szöveges jelentésben is. Ha összehasonlítja az ablakban megjelenő és a jelentésben található eredményeket, azok kissé eltérhetnek egymástól. Ennek oka a sávdiagram megjelenítésére szolgáló ablak viszonylag alacsony felbontása.

Mivel az Elemzés megjelenítése ablak túl kicsi ahhoz, hogy a kötet minden egyes szektorcsoportját külön-külön színes oszlop jelölje, a kötet és a szektorcsoport méretétől függően a sávdiagram egyes oszlopai tucatnyi, olykor több száz szektorcsoportot jelölnek. Figyelembe kell venni továbbá azt is, hogy ugyanaz a szektorcsoport egyaránt tartalmazhat töredezett fájlokat, összefüggő fájlokat, rendszerfájlokat és szabad lemezterületet is. Ennek megfelelően a sávdiagram egyes oszlopainak színeit a következő szabályok határozzák meg:

  1. Ha az adott csoport bármely szektorcsoportja egy rendszerfájl része, az oszlop színe zöld (rendszerfájl).
  2. Amennyiben az adott csoport bármely szektorcsoportja egy töredezett fájl része, az oszlop színe piros (töredezett fájl).
  3. Ha a csoport szektorcsoportjai csak szabad lemezterületet és nem töredezett szektorcsoportokat tartalmaznak, a nagyobb hányadot adó típus színe a meghatározó (>50% szabad lemezterület = fehér szín, >50 százaléknyi összefüggő fájl = kék szín).

Előfordulhat, hogy az Elemzés megjelenítése ablakban látható sávdiagram teljesen piros annak ellenére, hogy az elemzés adatait tartalmazó jelentés szerint a szektorcsoportoknak csak kevesebb, mint 1 százaléka tartozik töredezett fájlokhoz. Megtörténhet ugyanakkor az is, hogy az elemzés adatait tartalmazó jelentés szerint 20-30 százaléknyi a szabad lemezterület aránya, az Elemzés megjelenítése ablak viszont egyáltalán nem tartalmaz fehér területet. A jelenség a Töredezettségmentesítés megjelenítése ablakra és a töredezettségmentesítési jelentésre is vonatkozik.

Az Elemzés megjelenítése ablak alapján a kötet töredezettségét csak közelítő pontossággal lehet megállapítani. A pontos, számszerű eredményeket az elemzés adatait tartalmazó jelentésben találja meg.


A szabad lemezterület összevonása a köteten

A Lemez-töredezettségmentesítő nem vonja össze a teljes szabad területet a köteten. Míg a több száz darabra töredezett szabad terület hátrányosan befolyásolja a teljesítményt, a néhány darabra töredezett szabad területnek nincs ilyen hatása. A teljes szabad terület egy helyre történő összevonása csak nagyon kis teljesítménynövekedést eredményez.

A Windows rendszerfájlok, mint például a lapozófájl és a fő fájltáblázat (MFT) mindig kizárólagosan a Windows használatára vannak megnyitva, ezért a Lemez-töredezettségmentesítő nem kap hozzáférést ezekhez a fájlokhoz töredezettségmentesítés céljából.

A kötet töredezettségmentesítésével kapcsolatban további információt A kötet elemzése és A kötet töredezettségmentesítése című témaköröknél talál.

Számos tényező akadályozhatja a lemezpartíción lévő szabad terület töredezettségmentesítését.

  • A lapozófájl töredezett.
  • A lemezpartíció sok könyvtárat tartalmaz.
  • NTFS fájlrendszerrel rendelkező rendszerpartíciókon a lemezpartíción található szabad terület egy részét a Windows az MFT számára tartja fenn.


A Lemeztöredezettség-mentesítő használata

A rész tartalma:

  • A Lemeztöredezettség-mentesítő ablak
  • A töredezettségmentesítés ajánlott gyakorisága
  • A jelentések megtekintése


Lemez-töredezettségmentesítő ablak

A Lemez-töredezettségmentesítő két fő területre oszlik. A felső rész felsorolja azokat a köteteket, amelyek a helyi számítógépen találhatók. Az alsó rész grafikusan ábrázolja, mennyire töredezett a kötet. A megjelenített színek jelzik a kötet állapotát.

  • A vörös területek töredezett fájlokat jeleznek.
  • A kék területek folytonos (nem töredezett) fájlokat jeleznek.
  • A fehér területek a szabad területet jelzik a köteten.
  • A zöld területek rendszerfájlokat jeleznek, amelyeket a Lemez-töredezettségmentesítő nem helyezhet át. Ezek a rendszerfájlok nem a Windows operációs rendszer részei, hanem az NTFS fájlrendszerhez tartoznak. A zöld területek csak az NTFS formátumú köteteken jelennek meg.

Az Elemzés megjelenítése sávot a Töredezettségmentesítés megjelenítése sávval összehasonlítva látható a kötet állapotának javulása a töredezettségmentesítés után.

Kapcsolódó témakörök


A kötet töredezettségmentesítésének gyakorisága

Mivel a kötetek nagyon töredezetté válhatnak amikor a felhasználók sok fájlt vagy mappát törölnek róluk, ilyen esetben mindenképpen elemezze a köteteket a törlést követően. Általában a sokat használt fájlkiszolgálókon található köteteket gyakrabban kell töredezettségmentesíteni, mint az egyfelhasználós munkaállomásokon található köteteket.

A köteteket elemezve lehet azt eldönteni, hogy szükséges-e a töredezettségmentesítés. A kötet elemzése után megjelenő párbeszédpanel tájékoztat a köteten található fájlok és mappák töredezettségének százalékos értékéről, és javaslatot tesz a továbbiakra. A köteteket rendszeresen elemezze, de csak akkor töredezettségmentesítse azokat, ha a Lemez-töredezettségmentesítő erre javaslatot tesz.

Kapcsolódó témakörök


Jelentések megtekintése

Az adott kötet elemzése vagy töredezettségmentesítése után megtekintheti a végrehajtott folyamat eredményeit tartalmazó jelentést.

Az elemzési folyamat adatait tartalmazó jelentés megtekintésekor az Elemzési jelentés párbeszédpanel részletes adatokat jelenít meg arról a kötetről, amelynek töredezett fájljait és mappáit a Lemeztöredezettség-mentesítő megvizsgálta. A párbeszédpanelen megtekinthető a kötet mérete és a rendelkezésre álló szabad lemezterület, a töredezett fájlok és mappák száma (a jelentésben könyvtárakként szerepelnek), valamint a fájlonkénti átlagos töredékek száma. A program megjeleníti a kötet leginkább töredezett fájljainak elérési útvonalát és nevét, valamint az azokban található töredékek számát. Ha gyakran használja ezeket a fájlokat, akkor azok töredezettsége nagyobb mértékben befolyásolja a rendszer teljesítményét, mint azt a Fájlonkénti átlagos töredékek érték jelzi.

A töredékek fájlonkénti átlagos száma jól mutatja, hogy a kötet fájljai milyen mértékben töredezettek. A legjobb érték az 1.00, ami azt jelzi, hogy az összes, illetve majdnem az összes fájl összefüggő, azaz nem töredezett. Ha ez az érték 1.10, akkor a fájlok körülbelül tíz százaléka található két darabban a köteten. Az 1.20 érték húsz százaléknyi, az 1.30 érték harminc százaléknyi (és így tovább) töredezett fájlt jelöl. A 2.00 átlagérték azt jelzi, hogy minden fájl átlagosan két darabban található.

Az elemzést követően a Lemeztöredezettség-mentesítő megjelenít egy párbeszédpanelt, amelyen jelzi, hogy szükséges-e a töredezettségmentesítés.


Forrásmunkák

  • Executive Software International
  • A Windows 2000 Server család a Microsoft Windows webhelyen (http://www.microsoft.com/)
  • A Microsoft TechNet a magyar és az angol Microsoft TechNet webhelyen (http://www.microsoft.com/)
  • Microsoft TechNet CD-lemezek
  • Microsoft technikai tanácsadás a Frissített technikai információ témakörben
  • Az első lépések a Windows 2000 Server használatakor
  • Windows 2000 Server Resource Kit
  • A Windows 2000 Server rendszerleíró adatbázisa


Hibaelhárítás

  • Probléma: Az erőforrások lassan érhetők el.

    Ok: Lehet, hogy a merevlemezen lévő kötetek túlzottan töredezettek, valószínűleg azért, mert nemrégiben nagyszámú fájlt vagy mappát törölt.

    Megoldás: Szüntesse meg a merevlemez köteteinek töredezettségét. Ha további információkra van szüksége, olvassa el A töredezettségmentesítés ajánlott gyakorisága témakörben foglaltakat.

  • Probléma: A töredezettség állapotának megjelenítése és a jelentés nem egyezik meg.

    Ok: Az elemzést megjelenítő ablak viszonylag alacsony felbontása.

    Megoldás: Az Elemzés megjelenítése ablak alapján a kötet töredezettségét csak közelítő pontossággal lehet megállapítani. A pontos, számszerű eredményeket a jelentésben találja meg. A jelenség a Töredezettségmentesítés megjelenítése ablakra és a töredezettségmentesítési jelentésre is vonatkozik. További tájékoztatásért olvassa el a Miért különböznek a grafikus és a szöveges nézetek? témakört.

  • Probléma: Úgy tűnik, hogy nem csak a rendszerköteten és az indítóköteteken vannak rendszerfájlok.

    Ok: A Lemeztöredezettség-mentesítő alkalmazásban a mesterfájltáblák (MFT) és a lapozófájlok rendszerfájlokként jelennek meg.

    Megoldás: Ezen nem lehet változtatni, mert a mesterfájltáblák (MFT) és a lapozófájlok nem helyezhetők át, így töredezettségüket sem lehet megszüntetni. Ha további tájékoztatásra van szüksége, olvassa el a Miért nem kerülnek a fájlok az NTFS-formátumú kötet elejére? témakörben leírtakat.


Lépjen kapcsolatba az Executive Software társasággal

Az Executive Software elérhetősége

  • Telefon

    Az Amerikai Egyesült Államokban: (800) GET-DKNT

    Európából: 44-1342-327477

    Japánból: 813-3447-7544

  • Internet

    Az Executive Software nemzetközi webhelye

    (http://www.microsoft.com/isapi/redir.dll?prd=Win2000&os=Win2000&ar=Partner&sba=execsoft)

  • Elektronikus levél

    sales@executive.com

    tech_support@executive.com