A Telnet elindítása a parancssorból

  1. Nyissa meg a Parancssor ablakot.
  2. Írja be a parancssorba a következő parancsot:

    telnet [állomás_neve port_száma]

Megjegyzések

  • Parancssor megnyitásához kattintson a Start menüre, mutasson a Programok majd a Kellékek pontra, végül a Parancssor elemre.
  • A portszám megadása csak akkor szükséges, ha eltér a Telnet alapértelmezett portszámától.
  • Az állomás_neve megadása nem kötelező. Állomásnév hiányában a Telnet indítás után nem csatlakozik automatikusan a kiszolgálóhoz.


Compile Date

 Fordítás: HU kiadás, 2000.2.9.


Kilépés a Telnet programból

  • A Microsoft Telnet> parancssorába írja be a következő parancsot:
    quit

Kapcsolódó témakörök


A Telnet kiszolgáló beállításainak módosítása parancssorból

  • Nyissa meg a Telnet kiszolgálói felügyeleti segédprogramot.

Vigyázat!

  • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázis módosítása előtt a számítógépen lévő minden fontos adatról készítsen biztonsági másolatot.

Megjegyzések

  • A Telnet kiszolgálói felügyeleti segédprogram megnyitásához kattintson a Start menüben a Futtatás parancsra, írja be a tlntadmn.exe parancsot, majd kattintson az OK gombra.
  • Ha nem tudja megnyitni a Telnet kiszolgálói felügyeleti segédprogramot, lehet, hogy telepíteni kell a Felügyeleti eszközök csomagot.
  • A Telnet kiszolgálói felügyeleti segédprogram használatához a Rendszergazdák csoport tagjaként kell bejelentkezni.
  • A módosítások hatályba lépéséhez le kell állítani és újra kell indítani a Telnet kiszolgálót.

Kapcsolódó témakörök


A Telnet kiszolgáló elindítása parancssorból

  1. Nyisson meg egy parancssor ablakot.
  2. Írja be a net start tlntsvr parancsot, majd nyomja meg az ENTER billentyűt.

Megjegyzés

  • Parancssor megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Kellékek pontra, végül a Parancssor parancsra.


A Telnet kiszolgáló elindítása

  1. Nyissa meg a Szolgáltatások beépülő modult.
  2. A részletek ablaktáblán kattintson a jobb oldali egérgombbal Telnet elemre, majd kattintson az Indítás parancsra.

Megjegyzés

  • A Szolgáltatások beépülő modul megnyitásához kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd a Szolgáltatások ikonra.


A Telnet kiszolgáló leállítása parancssorból

  1. Nyisson meg egy parancssor ablakot.
  2. Írja be a következőt:
    net stop tlntsvr.

Megjegyzés

  • Parancssor megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Kellékek pontra, végül a Parancssor parancsra.


A Telnet kiszolgáló leállítása

  1. Nyissa meg a Szolgáltatások beépülő modult.
  2. A részletek ablaktáblán kattintson a jobb oldali egérgombbal Telnet elemre, majd kattintson a Leállítás parancsra.

Megjegyzés

  • A Szolgáltatások beépülő modul megnyitásához kattintson a Start gombra, mutasson a Beállítások pontra, majd kattintson a Vezérlőpult parancsra. Kattintson duplán a Felügyeleti eszközök, majd a Szolgáltatások ikonra.


Telnet kiszolgálói felügyeleti segédprogram

A Telnet kiszolgálói felügyeleti segédprogrammal elindítható és leállítható a Telnet kiszolgáló, vagy azzal kapcsolatos információ szerezhető. Segítségével megkapható az aktuális felhasználók listája, megszakítható egy felhasználó munkamenete, vagy módosíthatók a Telnet kiszolgálóra vonatkozó rendszerleíróadatbázis-beállítások.

A következő táblázat a Telnet kiszolgálói felügyeleti segédprogram lehetőségeit mutatja be.

Beállítás | Név | Leírás
0 | Kilépés az alkalmazásból | Befejezi a Telnet kiszolgálói felügyeleti segédprogram munkamenetét.
1 | Jelenlegi felhasználók megjelenítése | Megjeleníti az aktuális felhasználók listáját, amely tartalmazza a felhasználónevet, a tartományt, a távoli számítógépet, a munkamenet-azonosítót és a naplózás idejét.
2 | Felhasználói munkamenet megszakítása | Befejezi a kijelölt felhasználó munkamenetét.
3 | Rendszerleíró adatbázis beállításainak megjelenítése vagy módosítása | Megjeleníti a rendszerleíró adatbázis módosítható beállításait. További tudnivalókért tanulmányozza a következő táblázatot.
4 | Kiszolgáló indítása | Elindítja a Telnet kiszolgálót.
5 | Kiszolgáló leállítása | Leállítja a Telnet kiszolgálót.
A következő táblázat mutatja a Telnet kiszolgáló rendszerleíró adatbázisának módosítható beállításait.
Beállítás | Név | Leírás és megengedett értékek | Alapértelmezett érték
0 | Kilépés a menüből | Kilép a menüből, és visszatér az eredeti Telnet kiszolgálói felügyeleti segédprogram beállításaihoz. | -
1 | AllowTrustedDomain | 0: Nem engedélyezi a hozzáférést a tartományi felhasználóknak (csak a helyi felhasználóknak). 1: A hozzáférést csak a meghatalmazotti kapcsolattal rendelkező tartományok tartományi felhasználóinak engedélyezi. | 1
2 | AltKeyMapping | Engedélyezi az ALT billentyű működését (csak VT100 emuláció esetében működik). 0: A Ctrl-A billentyűkombinációt Ctrl-A billentyűkombinációként kezeli. 1: A Ctrl-A billentyűkombinációt Alt billentyűként kezeli. | 1
3 | DefaultDomain | A Defaultdomain bármely tartományra beállítható, amelynek a számítógéppel meghatalmazotti kapcsolata van. Ha az AllowTrustedDomain beállítás értéke 1, és a helyi tartományt szeretné alapértelmezettként beállítani, az érték legyen ".". | Null
4 | DefaultShell | Megjeleníti a rendszerhéj-telepítések elérési útjának helyét. | %rendszergyökér%\System32\Cmd.exe /q /k
5 | LogonScript | Megjeleníti a Telnet kiszolgáló bejelentkezési parancsfájljának elérési útját. A rendszergazda beállíthatja úgy a kiszolgálófüggő bejelentkezési parancsfájlt, hogy minden felhasználónál egyedi funkciót szolgáljon. | %rendszergyökér%\System32\login.cmd
6 | MaxFailedLogins | Megjeleníti a kapcsolat bontása előtt lehetséges sikertelen bejelentkezési kísérletek maximális számát. | 3
7 | NTLM | Hitelesítési beállítások. 0: NTLM-hitelesítés használata nélkül. Hasznos, ha más operációs rendszerből vagy rendszerhez csatlakozik. 1: Először NTLM-hitelesítéssel próbálkozik. Ha ez sikertelen, használja a felhasználónevet és a jelszót. Hasznos, ha Windows NT vagy Windows 2000 rendszert és más operációs rendszert futtató számítógépek között szeretne kapcsolatot létesíteni. 2: Csak NTLM-hitelesítést használata. Hasznos, ha Windows NT vagy Windows 2000 rendszert futtató számítógépek között szeretne kapcsolatot létesíteni. | 2
8 | TelnetPort | Megjeleníti a portot, amelyen a Telnet kiszolgáló a telnetkérelmeket várja. | 23

Vigyázat!

  • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázis módosítása előtt a számítógépen lévő minden fontos adatról készítsen biztonsági másolatot.

Megjegyzések

  • Az alapértelmezett tartományi fiók módosításakor a beállítás csak akkor lép érvénybe, ha újraindítja a Telnet kiszolgálót.
  • A Telnet kiszolgálói felügyeleti segédprogram használatához a Rendszergazdák csoport tagjaként kell bejelentkezni.

Kapcsolódó témakörök


Telnet hitelesítés

A Telnet kiszolgáló a Windows 2000 helyi felhasználóneve és jelszava vagy a tartományi fiók adatainak segítségével érhető el. A biztonsági séma integrálva van a Windows 2000 biztonsági szolgáltatásaiba. Ha nem használja az NTLM-hitelesítés beállítást, a felhasználónevet és a jelszót a Telnet kiszolgáló titkosítatlan szövegként kapja meg.

Ha használ NTLM-hitelesítést, az ügyfél a Windows 2000 biztonsági környezetét használja hitelesítésre, és a rendszer nem kéri a felhasználótól a felhasználónevet és a jelszót. A felhasználónév és a jelszó titkosított.

Megjegyzés

  • Ha a felhasználónak be van jelölve A felhasználónak a következő bejelentkezéskor meg kell változtatnia a jelszavát jelölőnégyzet, a Telnet kiszolgálóra a bejelentkezési kísérlet sikertelen lesz, amikor NTLM-hitelesítést használ. A felhasználónak közvetlenül a kiszolgálóra kell bejelentkeznie, megváltoztatnia a jelszavát, majd ezután Telneten keresztül bejelentkezni.


Telnet ügyfélprogram – áttekintés

A Windows 2000 Telnet ügyfélprogram távoli számítógéphez hálózaton keresztül történő kapcsolódásához a TCP/IP-protokollcsalád Telnet protokollját használja. A Telnet ügyfélprogrammal a számítógép távoli kiszolgálóhoz csatlakoztatható. A Windows 2000 Telnet ügyfélprogram segítségével a távoli számítógéphez történő csatlakozáshoz előbb be kell jelentkeznie a távoli számítógépre, majd úgy dolgozhat a távoli számítógépen, mintha közvetlenül előtte ülne.

A Windows Telnet ügyfélprogram korábbi verzióit használó felhasználók néhány változást fedezhetnek fel a Windows 2000 operációs rendszerben található programverzióban. A legfeltűnőbb változás, hogy a Telnet ügyfélprogram mostantól parancssori alkalmazás, és nem Windows alkalmazás. Parancssori alkalmazásként a Telnet ügyfélprogram nagyon ismerős lesz a UNIX alapú Telnet ügyfélprogramot használóknak.

A Windows 2000 Telnet ügyfélprogram egyik legfontosabb új funkciója az NTLM-hitelesítés használatának támogatása. E funkció révén a Windows 2000 Telnet ügyfélprogram NTLM-hitelesítésen keresztül jelentkezhet be a Windows 2000 Telnet kiszolgálóra.

Megjegyzések

  • Az NTLM-hitelesítés Windows 2000 rendszerben történő használatával kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Server súgóját.
  • A Windows 2000 Telnet ügyfélprogramban a Telnet munkamenetek nem naplózhatók.


Telnet kiszolgáló kapcsolatlicencelése

A Windows 2000 Server minden telepítésekor két kapcsolatlicencet biztosít a Telnet kiszolgálóhoz. Így a Telnet kiszolgáló egyszerre legfeljebb két Telnet ügyfélhez csatlakozhat. Ha további licencekre van szüksége, használja a Telnet kiszolgálót a Microsoft Windows szolgáltatások UNIX rendszerhez kiegészítő csomagból.


Hibakeresés

Mi a probléma?

Hiba: Érvénytelen bemenet

Ok: A bevitt érték nem fogadható el.

Megoldás: Nézze át a választható értékek tartományát, és adja meg újra az értéket.

Hiba: Nem sikerült megnyitni a rendszerleíró kulcsot.

Ok: A rendszerleíró kulcs megnyitásához a Telnet kiszolgálónak futnia kell. A hiba jelzi, hogy a Telnet kiszolgáló nem fut.

Megoldás: El kell indítani a Telnet kiszolgálót.

Hiba: Nem sikerült lekérdezni a rendszerleíró értéket.

Ok: Rendszerleíró érték lekérdezéséhez a Telnet kiszolgálónak futnia kell. A hiba jelzi, hogy a Telnet kiszolgáló nem fut.

Megoldás: El kell indítani a Telnet kiszolgálót.

Hiba: Az NTLM-hitelesítés sikertelen volt a nem megfelelő hitelesítő adatok miatt.

Ok: A felhasználó tiszta szöveges hitelesítés segítségével próbál másik számítógéphez csatlakozni, de az alapértelmezett beállítás csak NTLM-hitelesítés.

Megoldás: Nézze át a választható NTLM-értékek tartományát, és adja meg újra az értéket.