Rendszerleíróadatbázis-szerkesztő – áttekintés

A Rendszerleíróadatbázis-szerkesztő olyan speciális eszköz, amely lehetővé teszi a számítógép működésével kapcsolatos információkat tartalmazó rendszerleíró adatbázis beállításainak megváltoztatását. A Windows 2000 a konfigurációs információkat egy hierarchikus, fa elrendezésű adatbázisban tárolja (a rendszerleíró adatbázisban). Bár a Rendszerleíróadatbázis-szerkesztő lehetővé teszi a rendszerleíró adatbázis vizsgálatát és módosítását, általában e műveletek elvégzésére nincs szükség, sőt a rendszerleíró adatbázis nem megfelelő módosítása a rendszer működésképtelenségét eredményezheti. A tapasztalt felhasználók, akik a rendszerleíró adatbázis szerkesztését és visszaállítását el tudják végezni, kockázat nélkül használhatják a Rendszerleíróadatbázis-szerkesztőt többször szereplő bejegyzések elkerüléséhez, vagy már eltávolított vagy törölt programok bejegyzéseinek törléséhez.

A mappák a rendszerleíró adatbázisban a kulcsokat jelenítik meg, melyek a navigációs ablaktáblán láthatók. A tárgyablaktáblában a kijelölt kulcs értékbejegyzései jelennek meg. Egy értékbejegyzésre történő dupla kattintáskor egy szerkesztési párbeszédpanel jelenik meg.

Csak akkor módosítsa a rendszerleíró adatbázist, ha az feltétlenül szükséges. Amennyiben a rendszerleíró adatbázisban hiba található, és a számítógép nem működik megfelelően, a rendszerleíró adatbázis visszaállítható abba az állapotba, amelyben a számítógép utolsó sikeres indításakor volt. Ezzel kapcsolatos útmutatásért tanulmányozza a Kapcsolódó témaköröket.

Rendszerleíróadatbázis-szerkesztő kulcsok

A Rendszerleíróadatbázis-szerkesztő ablakokat jelenít meg, melyek mindegyike egy előre definiált kulcsot jelképez a helyi számítógépen. Távoli számítógép rendszerleíró adatbázisának elérésekor mindössze két előre definiált kulcs, a HKEY_USERS és a HKEY_LOCAL_MACHINE kulcs jelenik meg.

Ablak/előre definiált kulcs | Leírás
HKEY_CURRENT_USER | A konfigurációs információ legfelsőbb szintjét tartalmazza a jelenleg bejelentkezett felhasználóra vonatkozóan. A felhasználó mappáit, a képernyőszíneket és a Vezérlőpult beállításait tárolja itt a rendszer. Ezt az információt felhasználói profilnak nevezzük.
HKEY_USERS | A számítógépet használó valamennyi felhasználói profiljának legfelső szintjét tartalmazza. HKEY_CURRENT_USER a HKEY_USERS kulcs alkulcsa.
HKEY_LOCAL_MACHINE | A számítógépre (bármely felhasználóra vonatkozóan) jellemző konfigurációs információkat tartalmazza.
HKEY_CLASSES_ROOT | A HKEY_LOCAL_MACHINE\Software kulcs alkulcsa. Az itt tárolt információ biztosítja azt, hogy a Windows Intézővel megnyitott fájlt a megfelelő program nyissa meg.
HKEY_CURRENT_CONFIG | A helyi számítógép által rendszerindításkor használt hardverprofillal kapcsolatos információkat tartalmazza.

A Rendszerleíróadatbázis-szerkesztőben értékbejegyzések rendelhetők új kulcsokhoz, illetve a kijelölt kulcshoz rendelt értékbejegyzések módosíthatók. A rendszerleíró adatbázisban az értékbejegyzés olyan karakterláncként jelenik meg, amely három, kettőspontokkal elválasztott összetevőből áll. Például a

RefCount : REG_DWORD : 0x1
bejegyzés az alábbi értékeknek felel meg:

Bejegyzés neve | RefCount
Bejegyzés típusa | REG_DWORD
Bejegyzés értéke | 0x1

Megjegyzés

  • A Rendszerleíróadatbázis-szerkesztő futtatásához kattintson a Start gombra, a Futtatás parancsra, majd írja be a Regedt32.exe parancsot.

Kapcsolódó témakörök


Gyakori feladatok: Rendszerleíróadatbázis-szerkesztő

Gyakori feladatok

A Rendszerleíróadatbázis-szerkesztő használata közben az alábbi feladatok gyakran felmerülnek. A feladatok részletes listájának megjelenítéséhez kattintson a tartalomjegyzék kívánt könyvére.

A rendszerleíró adatbázis adatainak frissítése

A Rendszerleíróadatbázis-szerkesztő háromféleképpen teszi lehetővé a rendszerleíró adatbázis adatainak frissítését:

További tudnivalók

Kulcs hozzáadása a rendszerleíró adatbázishoz

A rendszerleíró adatbázishoz kulcsok és alkulcsok adhatók.

Tennivalók lépésről lépésre

Engedélyek hozzárendelése rendszerleíró kulcshoz

A rendszerleíró adatbázis biztonsága a kulcsokhoz engedélyeinek megadásával állítható be.

Tennivalók lépésről lépésre

Rendszerleíróadatbázis-szerkesztő ablakának felosztása

Az ablak felosztásával megváltoztatható a Renderleíróadatbázis-szerkesztő megjelenítési módja.

Tennivalók lépésről lépésre


A rendszerleíró adatbázis adatainak frissítése

A Rendszerleíróadatbázis-szerkesztő az alábbi lehetőségeket nyújtja a rendszerleíró adatbázis adatainak frissítésére:

  • Az Automatikus frissítés (a Beállítások menüben) automatikusan frissíti a rendszerleíró adatbázist, amennyiben bármilyen módosítás történik a rendszerleíró adatokban.
  • A Mindent frissít (a Nézet menüben) a valamennyi Rendszerleíróadatbázis-szerkesztő ablakban található összes információt frissíti.
  • Frissítés (a Nézet menüben) csak az aktív Rendszerleíróadatbázis-szerkesztő ablak információit frissíti.

Megjegyzések

  • Amikor az Automatikus frissítés érvényben van, egy pipa jelenik meg a parancs mellett, és a Nézet menü Mindet frissíti, valamint Frissítés parancsai ebben ez esetben nem használhatók.
  • Az Automatikus frissítés parancs nem áll rendelkezésre távoli számítógép rendszerleíró adatbázisának megtekintésekor. Ha az Automatikus frissítés parancsra kattint, mialatt egy távoli számítógép rendszerleíró adatbázisát tekinti meg, a kézi frissítési beállítások (Mindet frissíti és Frissítés) nem használhatók. Bár az Automatikus frissítés parancs látszólag úgy működik, mintha egy helyi rendszerleíró adatbázis ablakát jelenítené meg, a távoli számítógép információit tartalmazó ablak automatikusan nem frissül.


Helyi számítógép rendszerleíró adatbázisának megnyitása

  • A Rendszerleíró adatbázis menüben kattintson a Helyi adatbázis megnyitása parancsra.


Távoli számítógép rendszerleíró adatbázisának megnyitása

  1. A Rendszerleíró adatbázis menüben kattintson Számítógép kijelölése parancsra.
  2. A Számítógép mezőbe gépelje be, illetve a Számítógép kijelölése mezőben kattintson annak a számítógépnek a nevére, melynek rendszerleíró adatbázisát meg kívánja nyitni, majd kattintson az OK gombra.

Megjegyzés

  • A távoli számítógép rendszerleíró adatbázisának két előre definiált kulcsa (a HKEY_USERS és a HKEY_LOCAL_MACHINE kulcsok) nyitható meg.


A Rendszerleíróadatbázis-szerkesztő ablakainak bezárása

  1. Kattintson a bezárni kívánt Rendszerleíróadatbázis-szerkesztő ablakra.
  2. A Rendszerleíró adatbázis menüben kattintson Bezárás parancsra.


Rendszerleíró részfák mentése szövegfájlként

  1. Válassza ki a szövegfájlként menteni kívánt kulcsot.
  2. A Rendszerleíró adatbázis menüben kattintson a Részfa mentése új néven parancsra.
  3. A Hely beviteli mezőben adja meg a fájl helyét.
  4. A Fájlnév mezőben adja meg a fájl nevét.
  5. Figyeljen arra, hogy a Fájl típusa mező Szövegfájlok beállítású legyen.
  6. Kattintson a Mentés gombra.

Megjegyzés

  • A rendszerleíró adatbázis tartamának szövegfájlba menésekor a rendszer belefoglalja a fájlba a kulcs összes alkulcsát és az utód kulcsokhoz rendelt összes értékbejegyzést is. Ezt a rendszer a megadott helyi vagy hálózati helyekre menti.


A rendszerleíró adatbázis helyreállítása

  1. Mivel újra kell indítania a számítógépet, először nyomtassa ki ezt a témakört. Ebben az ablakban kattintson a Beállítások gombra, majd a Nyomtatás parancsra.
  2. A Tálcán kattintson a Start gombra, majd a Leállítás parancsra.
  3. Kattintson az Újraindítás elemre, majd az OK gombra.
  4. Amikor a képernyőn megjelenik a Válassza ki az indítani kívánt operációs rendszert üzenet, nyomja meg az F8 billentyűt.
  5. A nyílbillentyűk segítségével jelölje ki a Legutolsó helyes konfiguráció lehetőséget, majd nyomja meg az ENTER billentyűt.
  6. Kövesse a képernyőn megjelenő utasításokat.

Megjegyzés

  • Ezzel az eljárással a rendszerleíró adatbázis visszaállítható abba az állapotba, amelyben a számítógép utolsó sikeres indításakor volt.


Kulcs hozzáadása a rendszerleíró adatbázishoz

  1. Válassza ki az új kulcs alatt megjeleníteni kívánt kulcsot vagy alkulcsot.
  2. A Szerkesztés menüben kattintson a Kulcs hozzáadása parancsra.
  3. A Kulcsnév mezőbe gépelje be az új kulcshoz hozzárendelni kívánt kulcsnevet.
  4. Szükség szerint az Osztály mezőbe gépelje be a kulcshoz hozzárendelni kívánt osztályt.

Megjegyzések

  • A Kulcs hozzáadása parancs segítségével csak az adhat egy kulcshoz alkulcsot, akinek a kulcs a tulajdonában van, vagy akinek engedélye van a kulcs megnyitásához.
  • Amennyiben a HKEY_USERS vagy a HKEY_LOCAL_MACHINE ablak aktív, a kulcs legfelső szintjén a Kulcs hozzáadása parancs nem használható. Ha egy rendszerleíró kulcsot kíván hozzáadni ezen előre definiált kulcsok legfelső szintjéhez, a Rendszerleíró adatbázis menü Kaptár betöltése parancsát kell használnia.


Értékbejegyzés hozzáadása rendszerleíró kulcshoz

  1. Válassza ki a kulcsot, amelyhez értékbejegyzést kíván adni.
  2. A Szerkesztés menüben kattintson az Azonosító hozzáadása parancsra.
  3. Az Azonosítónév beviteli mezőbe írja be a létrehozni kívánt értékbejegyzés nevét.
  4. Az Adattípus mezőben válassza ki az értékbejegyzéshez hozzárendelni kívánt adattípust.
    • Ha a kiválasztott kulcshoz bináris értékbejegyzést kíván rendelni, válassza a REG_BINARY adattípust.
    • Ha a kiválasztott kulcshoz KÉTSZÓ típusú értékbejegyzést kíván rendelni, válassza a REG_DWORD adattípust.
    • Ha a kiválasztott kulcshoz bővíthető karakterláncot kíván rendelni, válassza a REG_EXPAND_SZ adattípust.
    • Ha az adatot karakterláncsorként kívánja hozzárendelni, válassza a REG_MULTI_SZ adattípust.
    • Ha a kiválasztott kulcshoz adatkarakterláncot kíván rendelni, válassza a REG_SZ adattípust.

Megjegyzés

  • Az egyes bejegyzéstípusok olyan szerkesztővel rendelkeznek, amely lehetővé teszi az osztály vagy a típus értékének módosítását. Az alábbi táblázat azt mutatja be, hogy melyik szerkesztőt használja az egyes bejegyzéstípusok étékének módosításához. Ha ezekhez az osztályokhoz tartozó szerkesztőt szeretné használni, kattintson duplán az értékbejegyzésre, vagy kattintson a Szerkesztés menü megfelelő parancsára.
    Bejegyzés típusa | Szerkesztő
    REG_BINARY | Bináris
    REG_SZ | Karakterlánc
    REG_DWORD | KÉTSZÓ
    REG_MULTI_SZ | Karakterláncsor
    REG_EXPAND_SZ | Bővíthető karakterlánc (karakterlánc vagy karakterláncsor)


Rendszerleíró kulcs mentése

  1. Válassza ki a lemezre menteni kívánt előre definiált kulcsot.
  2. A Rendszerleíró adatbázis menüben kattintson a Kulcs mentése parancsra.
  3. A Hely mezőben kattintson arra a meghajtóra, mappára vagy hálózati számítógépre, ahová a kaptárat menteni kívánja, majd adja meg a mappa pontos elérési útját.
  4. A Fájlnév mezőben adja meg a kaptár nevét.
  5. A Fájl típusa mezőben kattintson a Minden fájl elemre.
  6. Kattintson a Mentés gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • A Rendszerleíróadatbázis-szerkesztő számos olyan parancsról is gondoskodik, melyet a rendszer karbantartására terveztek. Például a Kaptár betöltése és a Kaptár eltávolítása parancsok lehetővé teszik karbantartás céljából a rendszer egy részének ideiglenes letöltését egy másik számítógépre. A kaptárt letöltés vagy visszaállítás előtt kulcsként egy hajlékonylemezre vagy a merevlemezre kell menteni.


Rendszerleíró kulcs helyreállítása

  1. Válassza ki azokat az előre definiált kulcsokat, melyekben a kaptárt helyre kívánja állítani.
  2. A Rendszerleíró adatbázis menüben kattintson a Visszaállítás parancsra.
  3. A Keresés itt mezőben kattintson a kaptárt tartalmazó meghajtóra, mappára vagy hálózati számítógépre, majd adja meg pontosan annak elérési útját.
  4. Válassza ki a kaptár helyes fájlnevét.
  5. Kattintson a Megnyitás gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • A visszaállított struktúra felülírja a meglévő rendszerleíró kulcsot, és a rendszer konfigurációjának állandó részévé válik. Például egy rendszerrészlet karbantartásának elvégzéséhez használható a Kulcs mentése parancs, mellyel egy kaptár lemezre menthető. Ha a műveletet befejezte, a rendszerre mentett kulcs visszaállításához a Rendszerleíró adatbázis menü Visszaállítás parancsa használható.


Kaptár betöltése a rendszerleíró adatbázisba

  1. Kattintson a HKEY_USERS vagy a HKEY_LOCAL_MACHINE ablakra.
  2. A Rendszerleíró adatbázis menüben kattintson a Kaptár betöltése parancsra.
  3. A Keresés itt mezőben kattintson a betöltendő kaptárt tartalmazó meghajtóra, mappára vagy hálózati számítógépre, majd adja meg pontosan annak elérési útját.
  4. Kattintson a Megnyitás gombra.
  5. A Kulcsnév mezőbe gépelje be a struktúrához hozzárendelni kívánt kulcsnevet, majd kattintson az OK gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • A Kaptár betöltése és a Kaptár eltávolítása parancsok csak a HKEY_USERS és a HKEY_LOCAL_MACHINE kulcsokra vannak hatással, és csak ezeknek az előre meghatározott kulcsoknak a kijelölésével válnak aktívvá. Amikor egy kaptárt a rendszerleíró adatbázisba tölt, a kaptár ezen kulcsok egyik alkulcsa lesz.


Kaptár eltávolítása a rendszerleíró adatbázisból

  1. Válaszon ki egy, a rendszerre már előzőleg betöltött kaptárt.
  2. A Rendszerleíró adatbázis menüben kattintson a Kaptár eltávolítása parancsra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • A Kaptár betöltése és a Kaptár eltávolítása parancsok csak a HKEY_USERS és a HKEY_LOCAL_MACHINE kulcsokra vannak hatással, és csak ezeknek az előre meghatározott kulcsoknak a kijelölésével válnak aktívvá. Amikor egy kaptárt a rendszerleíró adatbázisba tölt, a kaptár ezen kulcsok egyik alkulcsa lesz.


Rendszerleíró kulcs vagy értékbejegyzés törlése

  1. Kattintson a törölni kívánt kulcsra vagy értékbejegyzésre.
  2. Kattintson a Szerkesztés menü Törlés parancsára.

Megjegyzések

  • Ha a Rendszerleíróadatbázis-szerkesztőben kulcs, illetve értékbejegyzés törlését kívánja elvégezni a törlés megerősítése nélkül, kattintson a Beállítások menü Törlés megerősítése parancsára.
  • A rendszerleíró adatbázisból a kulcsok és az értékbejegyzések is törölhetők. Az előre definiált kulcsok azonban nem törölhetők (például a HKEY_CURRENT_USER kulcs), továbbá a kulcsok nevei nem módosíthatók.


Törlés jóváhagyása

  • A Beállítások menüben kattintson a Törlés megerősítése parancsra.

Megjegyzés

  • Ha az Írásvédett módot nem használja, a véletlen törlések elkerülése végett, a rendszerleíró adatok védelmére ajánlott a Törlés megerősítése lehetőséget használata. A Törlés megerősítése funkció használatával a Rendszerleíróadatbázis-szerkesztő minden alkalommal, amikor a felhasználó rendszerleíró kulcsot vagy értékbejegyzést töröl, egy párbeszédpanelt jelenít meg és a törlés jóváhagyását kéri.


Kulcs keresése a Rendszerleíróadatbázis-szerkesztőben

  1. A Nézet menüben kattintson a Kulcs keresése parancsra.
  2. A Keresendő mezőbe gépelje be a keresni kívánt kulcs nevét.
  3. A keresés szűkíthető az alábbi műveletek elvégzésével:
    • Ha egy hosszabb szó részét alkotó szó előfordulását kívánja megkeresni, jelölje be a Teljes szóval megegyező jelölőnégyzetet.
    • A Keresendő mezőben megadott, nagy- és kisbetűk kombinációjából álló kulcsok pontos kereséséhez jelölje be a Kis- és nagybetűk megkülönböztetése jelölőnégyzetet.
  4. Az Irány területen kattintson a rendszerleíró adatbázisban való keresési irányra:
    • Ha a beviteli ponttól feljebb elhelyezkedő rendszerleíró fa részben kíván keresni, kattintson a Fel választógombra.
    • Ha a beviteli ponttól lejjebb elhelyezkedő rendszerleíró fa részben kíván keresni, kattintson a Le választógombra.
  5. Kattintson a Következő keresése gombra, ha a megadott szöveg következő előfordulásait kívánja megkeresni mindaddig, amíg az összes előfordulást meg nem találta.


A Karakterlánc-szerkesztő használata

  1. Válasszon ki egy REG_SZ vagy REG_EXPAND_SZ típusú értékbejegyzést.
  2. A Szerkesztés menüben kattintson a Karakterlánc parancsra.
  3. Az Karakterlánc mezőben adja meg a módosításokat, majd kattintson az OK gombra.

Megjegyzés

  • A karakterlánc egy karakterekből álló sorozat. A rendszer számos értékbejegyzést karakterlánc (REG_SZ), illetve bővíthető karakterlánc (REG_EXPAND_SZ) formátumban ír a rendszerleíró adatbázisba. A bővíthető karakterlánc általában szöveget, valamint egy olyan változót tartalmaz, melyet a rendszer behelyettesít, ha egy alkalmazás meghívja. Például a %systemroot%\System32\Bootok.exe értékbejegyzés esetén a %systemroot% rész a változó bővíthető része, melyet a rendszer a Windows 2000 rendszerfájlokat tartalmazó könyvtár aktuális helyével helyettesít. Ha a Rendszerleíróadatbázis-szerkesztőben egy értékbejegyzés a REG_SZ vagy a REG_EXPAND_SZ előtaggal rendelkezik, az értékbejegyzés a Karakterlánc-szerkesztő segítségével szerkeszthető.


Bináris szerkesztő használata

  1. Kattintson a szerkeszteni kívánt értékbejegyzésre.
  2. Kattintson a Szerkesztés menü Bináris parancsára.
  3. Az Adatformátum területen kattintson az alábbi választógombok valamelyikére:
    • Ha az adatokat bináris számokban szeretné megjeleníteni, kattintson a Bináris választógombra.
    • Ha az adatokat hexadecimális számokban szeretné megjeleníteni, kattintson a Hexadecimális választógombra.
  4. Az Érték mezőben adja meg a módosításokat, majd kattintson az OK gombra.

Megjegyzés

  • A rendszer számos értékbejegyzést nyers bináris adatként ír a rendszerleíró adatbázisba. Ha egy értékbejegyzést az REG_BINARY előtag előzi meg, akkor a rendszer az értékbejegyzést bináris adatként rögzíti, így az értékbejegyzés szerkesztéséhez a Bináris szerkesztőt kell használni. Függetlenül a bejegyzések formátumától, más értékbejegyzések szerkesztésére is használható a Bináris szerkesztő.


A Kétszószerkesztő használata

  1. Kattintson egy REG_DWORD adattípusú értékbejegyzésre.
  2. Kattintson a Szerkesztés menü Kétszó parancsára.
  3. Az Érték mezőben adja meg a kívánt módosításokat.
  4. Az Alap területen kattintson a következő megjelenítési beállítások egyikére.
    • Ha az adatokat bináris (kettes alapú) számként szeretné megjeleníteni, kattintson a Bináris választógombra.
    • Ha az adatokat decimális (tízes alapú) számként szeretné megjeleníteni, kattintson a Decimális választógombra.
    • Ha az adatokat hexadecimális (tizenhatos alapú) számként szeretné megjeleníteni, kattintson a Hexadecimális választógombra.

Megjegyzés

  • A kétszó olyan adatokra vonatkozik, melyet a rendszer négy bájton tárol. Amennyiben az értékbejegyzés a REG_DWORD előtaggal van ellátva, akkor a rendszer a bejegyzést kétszó formátumban írja a rendszerleíró adatbázisba.


A Karakterláncsor-szerkesztő használata

  1. Kattintson egy REG_MULTI_SZ típusú értékbejegyzésre.
  2. Kattintson a Szerkesztés menü Karakterláncsor elemére.
  3. Az Érték mezőben adja meg a módosításokat, majd kattintson az OK gombra.

Megjegyzés

  • Ha egy értékbejegyzés a REG_MULTI_SZ előtagot tartalmazza, a rendszer az értékbejegyzést karakterlánc sorként írja a rendszerleíró adatbázisba.


Engedélyek hozzárendelése rendszerleíró kulcshoz

  1. Kattintson arra a kulcsra, melyhez engedélyeket kíván rendelni.
  2. Kattintson az Biztonság menü Engedélyek parancsára.
  3. Az alábbiak szerint rendeljen hozzáférési szintet a kiválasztott kulcshoz:
    • Ha a felhasználónak engedélyt kíván adni a kulcsok tartalmának olvasására, de a fájl módosításainak mentéséhez nem, jelölje be az Engedélyezés jelölőnégyzetet az Olvasás beállításnál.
    • Ha a felhasználónak a kiválasztott kulcsok megnyitására, szerkesztésére, és saját tulajdonba vételére engedélyt kíván adni, jelölje be az Engedélyezés jelölőnégyzetet a Teljes hozzáférés beállításnál.
    • Ha a felhasználónak a kiválasztott kulcsokhoz speciális engedélyeket kíván adni, kattintson a Speciális gombra.
  4. Ha egy alkulcshoz kíván engedélyeket rendelni, és azt szeretné, hogy a szülőkulcshoz rendelt örökölhető engedélyek az alkulcsokra is érvényesek legyenek, jelölje be az Engedélyek öröklésének engedélyezése a szülőtől jelölőnégyzetet.

Megjegyzés

  • Ha egy rendszerleíró kulcs a tulajdonában van, akkor megadhatja azokat a felhasználókat és csoportokat, akik a kulcsot megnyithatják. Ha meg kívánja adni, hogy ki nyithassa meg a rendszerleíró kulcsokat, akkor engedélyt kell nekik adnia. Felhasználók vagy csoportok bármikor hozzáadhatók vagy eltávolíthatók a rendszerleíró kulcshoz hozzáférési joggal rendelkezők listájából.


Speciális hozzáférés hozzárendelése a rendszerleíró kulcshoz

  1. Kattintson arra a kulcsra, melyhez speciális hozzáférést kíván rendelni.
  2. Kattintson a Biztonság menü Engedélyek parancsára.
  3. Kattintson a Speciális gombra, majd kattintson duplán arra a felhasználóra vagy csoportra, melynek speciális hozzáférést kíván adni.
  4. Az Engedélyek területen állítsa be az egyes engedélyeket az Engedélyezés vagy a Megtagadás jelölőnégyzet bejelölésével.

Megjegyzések

  • A speciális hozzáférés használata olyan helyzetben lehet hasznos, amikor az Olvasás vagy a Teljes hozzáférés engedélyek nem határozzák meg a hozzárendelni kívánt engedélyeket.
  • Ha egy alkulcshoz kíván engedélyeket rendelni, és azt szeretné, hogy a szülőkulcshoz rendelt örökölhető engedélyek az alkulcsokra is érvényesek legyenek, jelölje be az Engedélyek öröklésének engedélyezése a szülőtől jelölőnégyzetet.
  • Ha egy szülőkulcshoz rendel engedélyeket, és bármely meglévő alkulcs engedélyét felül szeretné írni a szülőkulcs örökölhető engedélyeivel, jelölje be az Engedélyek alaphelyzetbe állítása az összes gyermekobjektum esetén és az örökölhető engedélyek terjesztésének engedélyezése jelölőnégyzetet.


Felhasználók vagy csoportok hozzáadása az Engedélyek listához

  1. Kattintson arra a kulcsra, melynek Engedélyek listáját módosítani kívánja.
  2. Kattintson a Biztonság menü Engedélyek parancsára, majd a Hozzáadás gombra.
  3. A Felhasználók, számítógépek vagy csoportok kijelölése párbeszédpanelen a Keresés itt mezőben kattintson a megtekinteni kívánt felhasználók és csoportokhoz tartozó tartományra vagy számítógépre.
  4. Kattintson a felhasználó, illetve csoport nevére, majd a Hozzáadás, végül az OK gombra.
  5. Az Engedélyek párbeszédpanelen az Engedélyek területen az alábbiak szerint rendeljen hozzá hozzáférési típust a kiválasztott felhasználóhoz vagy csoporthoz:
    • Ha a felhasználónak a kulcsok tartalmához olvasási engedélyt kíván adni, de a módosítások mentéséhez nem, jelölje be az Engedélyezés jelölőnégyzetet az Olvasás beállításnál.
    • Ha a felhasználónak a kiválasztott kulcsok megnyitására, szerkesztésére, és saját tulajdonba vételére engedélyt kíván adni, jelölje be az Engedélyezés jelölőnégyzetet a Teljes hozzáférés beállításnál.

Megjegyzések

  • Ha az Engedélyek területen lévő jelölőnégyzetek nem használhatók, akkor a kulcs az engedélyeket a szülő kulcstól örökli.
  • Ha a szülőkulcshoz rendelt engedélyeket az alkulcsokra is alkalmazni kívánja, akkor jelölje be az Engedélyek öröklésének engedélyezése a szülőtől jelölőnégyzetet. Ez a jelölőnégyzet csak akkor jelenik meg, ha egy alkulcs engedélyeit állítja.
  • Ha a Felhasználók, számítógépek vagy csoportok kijelölése párbeszédpanelen a név kijelölése helyett azt beírja, akkor az OK gombra kattintás előtt kattintson a Névellenőrzés gombra.


Rendszerleíró kulcshoz teljes hozzáférés megadása

  1. Kattintson arra a kulcsra, melyhez teljes hozzáférést kíván adni.
  2. Kattintson a Biztonság menü Engedélyek parancsára.
  3. A Név területen kattintson arra a felhasználóra, akinek a rendszerleíró kulcshoz teljes hozzáférést kíván adni.
  4. Az Engedélyek területen jelölje be az Engedélyezés jelölőnégyzetet a Teljes hozzáférés beállításnál.

Megjegyzések

  • Csak az teheti lehetővé egy másik felhasználó számára, hogy saját tulajdonába vegyen egy rendszerleíró kulcsot, akinek a kulcs a tulajdonában van.
  • Ha egy másik felhasználó számára engedélyezni szeretné, hogy egy rendszerleíró kulcsot saját tulajdonába vegyen, akkor először a felhasználónak a kulcshoz teljes hozzáférést kell adnia.


Rendszerleíró kulcs naplózási tevékenységei

  1. Kattintson a naplózni kívánt kulcsra.
  2. Kattintson a Biztonság menü Engedélyek parancsára.
  3. Kattintson a Speciális gombra, majd a Naplózás fülre.
  4. Kattintson duplán a csoport vagy a felhasználó nevére.
  5. A Hozzáférés oszlopban jelölje be vagy törölje a jelölést a Sikeres és a Sikertelen jelölőnégyzetekből azokra az eseményekre vonatkozóan, melyeket naplózni szeretne, vagy amelyek naplózását le kívánja állítani:
    Kijelölés | Naplózott esemény
    Érték lekérdezése | A rendszerleíró kulcsban található értékbejegyzések olvasására tett kísérletek
    Érték beállítása | A rendszerleíró kulcsban található értékbejegyzések beállítására tett kísérletek
    Alkulcs létrehozása | A kijelölt rendszerleíró kulcshoz alkulcs létrehozására tett kísérletek
    Alkulcsok enumerálása | A kijelölt rendszerleíró kulcs alkulcsainak azonosítására tett kísérletek
    Értesítés | A rendszerleíró adatbázis kulcsaiból érkező értesítő események
    Csatolás létrehozása | Adott kulcsban szimbolikus csatolás létrehozására tett kísérletek
    Törlés | A rendszerleíró objektum törlésére tett kísérletek
    DAC írás | A kulcson tulajdonosi hozzáférés-szabályozási lista írására tett kísérletek
    Írásra jogosult tulajdonos | A kiválasztott kulcs tulajdonosának módosítására tett kísérletek
    Olvasásszabályozás | A kulcson a tulajdonosi hozzáférés-szabályozási lista megnyitására tett kísérletek

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • A naplózni kívánt események megadása előtt hozzá kell adnia a felhasználókat és a csoportokat.


Felhasználók vagy csoportok hozzáadása a naplózási listához

  1. Kattintson a naplózni kívánt kulcsra.
  2. Kattintson a Biztonság menü Engedélyek parancsára.
  3. Kattintson a Speciális gombra, a Naplózás fülre, majd a Hozzáadás gombra.
  4. A Keresés itt mezőben kattintson a megtekinteni kívánt felhasználókhoz vagy csoportokhoz tartozó számítógépre vagy tartományra.
  5. A Naplózási bejegyzések párbeszédpanel megnyitásához kattintson a hozzáadni kívánt felhasználó vagy csoport nevére, majd az OK gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • A naplózni kívánt események megadása előtt hozzá kell adnia a felhasználót vagy csoportot.


Rendszerleíró kulcs saját tulajdonba vétele

  1. Kattintson arra a kulcsra, melyet saját tulajdonba kíván venni.
  2. Kattintson a Biztonság menü Engedélyek parancsára.
  3. Kattintson a Speciális gombra, majd a Tulajdonos fülre.
  4. Az Új tulajdonos területen kattintson az új tulajdonosra, majd az OK gombra.

Megjegyzés

  • A rendszerleíró kulcs saját tulajdonba vehető, ha rendszergazdaként jelentkezett be, vagy ha a külön engedélyt kapott a rendszerleíró kulcs saját tulajdonba vételére annak jelenlegi tulajdonosától.


Adat megtekintése Írásvédett módban

  • Kattintson a Beállítások menü Írásvédett mód parancsára.

Megjegyzés

  • Az Írásvédett mód megvédi a rendszerleíró adatokat az esetleg kárt okozó, véletlen törlésektől. Az Írásvédett mód kiválasztásakor a Rendszerleíróadatbázis-szerkesztő nem menti az elvégzett módosításokat.


Betűtípus kijelölése

  1. A Beállítások menüben kattintson a Betűtípus parancsra.
  2. A Betűtípus mezőben válassza ki a kívánt betűtípust.
  3. A Betűstílus mezőben válasszon ki egy betűstílust.
  4. A Méret mezőben válassza ki a megfelelő pontméretet.
  5. Az Írásrendszer mezőben válassza ki a számítógép számára megfelelő írásrendszert.

Megjegyzések

  • A Minta területen a kiválasztott betűtípusnak, betűstílusnak, betűméretnek és írásrendszernek megfelelő betűk jelennek meg.
  • A kiválasztott betűtípus a Rendszerleíróadatbázis-szerkesztő valamennyi ablakára érvényes.


Váltás fa- és adatnézetek között

  • A Nézet menüben kattintson a következő megjelenítési beállítások egyikére:
    • A fa- és az adatnézetek együttes megjelenítéséhez kattintson a Fa és adat parancsra.
    • A rendszerleíró fa egyedüli megjelenítéséhez kattintson a Csak fa parancsra.
    • Ha csak az értékbejegyzéseket kívánja megtekinteni a rendszerleíró fában, kattintson a Csak adat parancsra.

Megjegyzések

  • A Fa és adat az alapértelmezett beállítás.
  • A rendszerleíró fa megjelenésének módosításához a Fa menü parancsai használhatók.


Rendszerleíróadatbázis-szerkesztő ablakának felosztása

  1. A Nézet menüben kattintson a Szétvágás parancsra.
  2. Az egérrel vagy a nyílbillentyűkkel mozgassa a függőleges vonalat.
  3. Ott kattintson az egérgombbal, ahol el szeretné helyezni az elválasztó vonalat.

Megjegyzés

  • A Szétvágás művelet megszakításához nyomja le az ESC billentyűt.


Részfa nyomtatása

  1. A Rendszerleíróadatbázis-szerkesztő ablak fát tartalmazó ablaktábláján válasszon ki egy kulcsot.
  2. A Rendszerleíró adatbázis menüben kattintson a Részfa nyomtatása parancsra.

Megjegyzés

  • Egy kulcs nyomtatásakor a Rendszerleíróadatbázis-szerkesztő kinyomtatja a kulcsot, annak alkulcsait, valamint a kulcs összes alkulcsának valamennyi értékbejegyzését.


Felhasználó vagy csoport eltávolítása a Naplózás listából

  1. Kattintson arra a kulcsra, melynek Naplózási listáját módosítani kívánja.
  2. Kattintson az Biztonság menü Engedélyek parancsára.
  3. Kattintson a Speciális gombra, majd a Naplózás fülre.
  4. Kattintson az eltávolítani kívánt felhasználóra vagy csoportra, majd az Eltávolítás gombra.

Megjegyzés

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.


Felhasználó vagy csoport eltávolítása az Engedélyek listából

  1. Kattintson arra a kulcsra, melynek Engedélyek listáját módosítani kívánja.
  2. Kattintson a Biztonság menü Engedélyek parancsára.
  3. Kattintson annak a felhasználónak vagy csoportnak a nevére, amelyiket el akarja távolítani az Engedélyek listából.
  4. Kattintson az Eltávolítás gombra.