Rendszerleíróadatbázis-szerkesztő – áttekintés

A Rendszerleíróadatbázis-szerkesztő olyan speciális eszköz, amely lehetővé teszi a számítógép működésével kapcsolatos információkat tartalmazó rendszerleíró adatbázis beállításainak megváltoztatását. Általában az a legjobb megoldás, ha hagyja, hogy a Windows 2000 alapú programok módosítsák a rendszerleíró adatbázist, és elkerüli a Rendszerleíróadatbázis-szerkesztővel történő módosításokat.

Ha nem feltétlenül szükséges, ne módosítsa a rendszerleíró adatbázist. Ha hiba kerül a rendszerleíró adatbázisba, a számítógép működésében is zavar jelentkezhet. Ha ez fellép, a rendszerleíró adatbázis visszaállítható abba az állapotba, amelyben a számítógép utolsó sikeres indításakor volt. Ezzel kapcsolatos útmutatásért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • A Rendszerleíróadatbázis-szerkesztő elindításához kattintson a Start gombra, a Futtatás parancsra, majd gépelje be a regedit parancsot.
  • Többszörös bejegyzések elkerüléséhez, vagy már eltávolított vagy törölt programok bejegyzéseinek törléséhez el kell sajátítani a rendszerleíró adatbázis szerkesztővel történő biztonságos szerkesztését és a rendszerleíró adatbázis visszaállítását.

Kapcsolódó témakörök


Rendszerleíró adatbázis helyreállítása

  1. Az itt található utasítások nyomtatásához kattintson a Beállítások menü Nyomtatás parancsára. Ezek az utasítások nem érhetők el a 2. lépésben majd végrehajtandó rendszerleállítás után.
  2. Kattintson a Start menü Leállítás parancsára.
  3. Kattintson az Újraindítás elemre, majd az OK gombra.
  4. Amikor a képernyőn megjelenik a Válassza ki az indítani kívánt operációs rendszert üzenet, nyomja meg az F8 billentyűt.
  5. A nyílbillentyűk segítségével jelölje ki a Legutolsó helyes konfiguráció lehetőséget, majd nyomja meg az ENTER billentyűt.

    6. A számbillentyűzeten csak a NUM LOCK kikapcsolása után használhatók a nyílbillentyűk.

  6. A nyílbillentyűk segítségével jelölje ki az operációs rendszert, majd nyomja le az ENTER billentyűt.

Megjegyzések

  • A Legutolsó helyes konfiguráció használata lehetőséget biztosít olyan problémák megoldására, amit például egy újonnan hozzáadott, de a hardver által nem támogatott illesztőprogram okozhat. Sérült vagy hiányzó illesztőprogramok vagy fájlok által okozott problémák megoldásában nem fog segíteni.
  • A Legutolsó helyes konfiguráció választása esetén a Windows 2000 csak a HKLM\System\CurrentControlSet rendszerleíró kulcsban található információt állítja vissza. A többi rendszerleíró kulcson végzett módosítás megmarad.


Karakterlánc, érték vagy kulcs keresése

  1. A Szerkesztés menüben kattintson a Keresés parancsra.
  2. A Keresendő mezőben adja meg a keresni kívánt karakterláncot, értéket vagy kulcsot.
  3. Jelölje be a Kulcs, Azonosító, Érték valamint a Csak teljes szóval egyező jelölőnégyzeteket a keresés típusának megadására, majd kattintson a Következő keresése gombra.

Megjegyzések

  • A keresés jelentősen felgyorsítható, ha egyszerre csak egy típusú adatot keres, például ha tudja, hogy értékbejegyzést keres, törölje a Kulcs és az Érték jelölőnégyzetekből a jelölést, így a rendszer ezeket az objektumokat nem nézi át a kereséskor.
  • A keresés az F3 billentyű lenyomásával megismételhető.


Rendszerleíró kulcs hozzáadása a Kedvencekhez

  1. Válassza ki a Kedvencek mappához hozzáadni kívánt rendszerleíró kulcsot.
  2. A Kedvencek menüben kattintson a Hozzáadás a kedvencekhez parancsra.
  3. A Hozzáadás a kedvencekhez párbeszédpanelen fogadja el az alapértelmezett rendszerleíró kulcs nevet, vagy írjon be egy újat.

    4. Ekkor a rendszer hozzáadja a rendszerleíró kulcsot a Kedvencek listához. Ehhez a listához azután könnyen visszatérhet, mindössze ki kell választania a Kedvencek menüből.

Megjegyzések

  • Lista készíthető a gyakran fellapozott rendszerleíró kulcsokról.
  • Ha el szeretne távolítani egy rendszerleíró kulcsot a Kedvencek listából, kattintson a Kedvencek menü Kedvenc eltávolítása parancsára, majd válassza ki a Kedvencek listából az eltávolítani kívánt rendszerleíró kulcsot vagy kulcsokat.


Kulcs hozzáadása

  1. Kattintson duplán arra a rendszerleíró listára, melyhez egy új kulcsot kíván hozzáadni, majd kattintson az új kulcshoz tartozó hely felett lévő kulcsra.
  2. A Szerkesztés menüben mutasson az Új pontra, majd kattintson a Kulcs parancsra.
  3. Írja be az új kulcs nevét, majd nyomja le az ENTER billentyűt.

Megjegyzés

  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. Ezzel kapcsolatos útmutatásért tanulmányozza a Kapcsolódó témaköröket.


Érték hozzáadása

  1. Kattintson arra a rendszerleíró kulcsra vagy értékbejegyzésre, melyhez az új értéket kívánja adni.
  2. A Szerkesztés menüben mutasson az Új pontra, majd kattintson a hozzáadni kívánt értéktípusra: Karakterlánc, Bináris érték vagy Kétszó.
  3. Írja be az új érték nevét, és nyomja le az ENTER billentyűt.

Megjegyzések

  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. A rendszerleíró adatbázis helyreállításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Érték hozzáadásakor a rendszer az érték nevét és az adattípust alapértelmezett értékkel menti. Az alapértelmezett érték módosításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Érték módosítása

  1. Válassza ki a módosítani kívánt értéket.
  2. Kattintson a Szerkesztés menü Módosítás parancsára.
  3. Az Érték mezőben adja meg az új értéket, majd kattintson az OK gombra.

Megjegyzés

  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. Ezzel kapcsolatos útmutatásért tanulmányozza a Kapcsolódó témaköröket.


Kulcs vagy érték törlése

  1. Kattintson a törölni kívánt rendszerleíró kulcsra vagy értékbejegyzésre.
  2. Kattintson a Szerkesztés menü Törlés parancsára.

Megjegyzések

  • A rendszerleíró adatbázisból a kulcsok és az értékek törölhetők. Az előre definiált kulcsok azonban nem törölhetők (például a HKEY_CURRENT_USER kulcs), továbbá az előre definiált kulcsok nevei nem módosíthatók.
  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. Ezzel kapcsolatos útmutatásért tanulmányozza a Kapcsolódó témaköröket.


Kulcs vagy érték átnevezése

  1. Kattintson az átnevezni kívánt rendszerleíró kulcsra vagy értékbejegyzésre.
  2. A Szerkesztés menüben kattintson az Átnevezés parancsra.
  3. Írja be az új nevet, majd nyomja meg az ENTER billentyűt.

Megjegyzések

  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Egy kulcs gyökérkulcsai vagy alapértelmezett értéke nem nevezhető át.


Csatlakozás rendszerleíró adatbázishoz hálózaton keresztül

  1. Kattintson a Rendszerleíró adatbázis menü Csatlakozás hálózati rendszerleíró adatbázishoz parancsára.
  2. A Csatlakozás hálózati rendszerleíró adatbázishoz párbeszédpanelen írja be annak a számítógépnek a nevét, melynek rendszerleíró adatbázisához csatlakozni kíván.

Megjegyzések

  • Rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie a helyi számítógépre, valamint a távoli számítógépre is, mielőtt bármilyen módosítást végezhetne a távoli számítógép rendszerleíró adatbázisában. A hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. A rendszerleíró adatbázis helyreállításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Hálózati rendszerleíró adatbázissal létesített kapcsolat bontása

  1. Kattintson a Rendszerleíró adatbázis menü Hálózati kapcsolat bontása parancsára.
  2. A Hálózati kapcsolat bontása párbeszédpanelen kattintson annak a számítógépnek a nevére, melynek rendszerleíró adatbázisával létesített kapcsolatot bontani kívánja.

Megjegyzés

  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. A rendszerleíró adatbázis helyreállításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Rendszerleíró kulcs nevének másolása

Rendszerleíró kulcs névének másolása

  1. A rendszerleíró fán (bal oldali ablaktábla) kattintson valamelyik rendszerleíró kulcsra.
  2. Kattintson a Szerkesztés menü Kulcsnév másolása parancsára.
  3. Illessze a rendszerleíró kulcs nevét másik programba vagy egy dokumentumba.

Megjegyzések

  • Ha olyan hibát vét, amely azt eredményezi, hogy a számítógép nem indul megfelelően, a rendszerleíró adatbázis helyreállítható. A rendszerleíró adatbázis helyreállításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Rendszerleíró kulcsok keresésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Rendszerleíró adatbázis teljes vagy részleges exportálása szövegfájlba

  1. A Rendszerleíró adatbázis menüben kattintson a Rendszerleíró adatbázis exportálása parancsra.
  2. A Fájlnév mezőben adja meg a rendszerleíró fájl nevét.
  3. Az Exportálandó tartomány területen kattintson az alábbi lehetőségek valamelyikére:
    • A teljes rendszerleíró adatbázis biztonsági mentéséhez kattintson a Minden ág választógombra.
    • A rendszerleíró fa egy ágának biztonsági mentéséhez kattintson a Kijelölt ág választógombra, majd írja be az exportálni kívánt ág nevét.
  4. Kattintson a Mentés gombra.

Megjegyzés

  • Az exportálással létrehozott rendszerleíró fájlok bármely szövegszerkesztőben módosíthatók. A rendszer a rendszerleíró fájlokat .reg kiterjesztéssel menti.


A regisztrációs adatbázis egy részének vagy egészének importálása

  1. A Rendszerleíró adatbázis menüben kattintson a Rendszerleíró adatbázis importálása parancsra.
  2. Keresse meg az importálni kívánt fájlt és a kiválasztásához kattintson a fájlra, majd kattintson a Megnyitás gombra.


A rendszerleíró adatbázis teljes vagy részleges nyomtatása

  1. Kattintson a sajátgépre vagy a nyomtatni kívánt rendszerleíró terület legfelső szintű kulcsára.
  2. A Rendszerleíró adatbázis menüben kattintson a Nyomtatás parancsra.
  3. Ha a Minden ág választógombot választja, a teljes rendszerleíró adatbázis, ha pedig a Kijelölt ág választógombot választja és a beviteli mezőben megadja a kívánt ágat, akkor a rendszerleíró adatbázis egy része nyomtatható az OK gombra kattintva.