Kapcsolat nélküli fájlok – áttekintés

Kapcsolat nélküli fájlok használata esetén a hálózati kapcsolat megszűnése esetén is dolgozhat a hálózati fájlokkal és programokkal.

Ha megszakad a hálózati kapcsolat, vagy leválasztja a hordozható számítógépet, akkor a kapcsolat nélküli használatra beállított megosztott hálózati elemek ugyanúgy használhatók, mintha a számítógép hálózatra kapcsolódna. A munka a megszokott módon folytatható. A fájlokra és mappákra ugyanazok a hozzáférési engedélyek érvényesek, mintha a számítógép a hálózatra csatlakozna. A kapcsolat állapotának megváltozásakor a Kapcsolat nélküli fájlok ikon megjelenik az állapotterületen, és az állapotterületen megjelenő tájékoztató üzenet jelzi a változást.

A hálózati kapcsolat visszaállításakor, vagy a hordozható számítógép dokkolásakor a kapcsolat nélküli módban végzett módosításokat a rendszer frissíti a hálózatra. Ha Ön és valaki a hálózaton ugyanazt a fájlt módosította, akkor kiválasztható, hogy a rendszer a fájl Ön által módosított verzióját menti a hálózatra, a hálózaton tárolt verziót tartja meg vagy mindkettőt menti.

Megjegyzések

  • A kapcsolat nélküli fájlok hálózattal történő szinkronizálása indítható közvetlenül, vagy kezelhető a Szinkronizáláskezelő segédprogrammal. A Szinkronizáláskezelő segédprogram azt is kezeli, hogy teljes vagy gyors szinkronizálás kell-e végrehajtani. A teljes szinkronizálás biztosítja, hogy minden kapcsolat nélküli használatra beállított hálózati fájl legfrissebb verziója legyen elérhető. A gyors szinkronizálás sokkal gyorsabb a teljes szinkronizálásnál, de előfordulhat, hogy nem érhető el az összes kapcsolat nélküli használatra beállított hálózati fájl legfrissebb verziója. A gyors szinkronizálás azonban biztosítja, hogy minden fájl teljes verziója elérhető legyen, és a munka folytatható legyen.
  • Microsoft hálózaton levő minden fájl és mappa kapcsolat nélküli használata beállítható. Kiszolgáló-üzenetblokkok (Server Message Block) használatára épülő fájl- és nyomtatómegosztást biztosító számítógépeken (például Windows 95, Windows 98 és Windows NT 4.0) tárolt fájlok állíthatók be kapcsolat nélküli használatra. Kapcsolat nélküli fájlok nem használhatók Novell NetWare hálózaton.
  • A rendszergazda beállíthatja úgy a megosztott mappákat, hogy minden megnyitott megosztott mappa automatikusan kapcsolat nélküli módban is használható legyen, vagy csak a kiválasztott hálózati fájlok legyenek kapcsolat nélküli módban használhatók.
  • Ha beállítja egy fájlra mutató parancsikon kapcsolat nélküli használatát, akkor a rendszer a fájl kapcsolat nélküli használatát is beállítja, viszont ha egy mappára mutató parancsikon kapcsolat nélküli használatát állítja be, akkor a mappa tartalma nem használható kapcsolat nélküli módban.

Kapcsolódó témakörök


Gyakori feladatok: kapcsolat nélküli fájlok

Gyakori feladatok

A kapcsolat nélküli fájlok használata közben az alábbi feladatok gyakran felmerülnek. Egy adott szó vagy kifejezés megkereséséhez kattintson a Tárgymutató vagy a Keresés fülre.

A kapcsolat nélküli fájlok használatának beállítása a számítógépen

A fájlok vagy mappák kapcsolat nélküli módban csak akkor használhatók, ha a kapcsolat nélküli fájlok használatát beállítja a számítógépen.

Ennek lépései:

Fájl vagy mappa kapcsolat nélküli használatának beállítása

A megosztott hálózati fájlok vagy más elemek kapcsolat nélküli használatát be kell állítani a kapcsolat nélküli fájlok funkció használatához.

Ennek lépései:

Módosítsa, hogyan viselkedjenek a kapcsolat nélküli fájlok a hálózati kapcsolat bontásakor

A hálózaton fájlokat megosztó számítógépek a hálózati kapcsolat bontására való alapértelmezett viselkedése számítógépenként különbözőképpen beállítható.

Ennek lépései:

Az utazó felhasználók által használható kapcsolat nélküli fájlok

A Kapcsolat nélküli fájlok funkció biztosítja az utazó felhasználók számára, hogy elérhetővé tegyék a hálózati fájlok legújabb verzióját, mielőtt bontják a hálózati kapcsolatot. A kapcsolat nélküli módban elvégzett módosításokat a rendszer a hálózatra való újbóli kapcsolódáskor szinkronizálja.

További tudnivalók


Meghajtó vagy mappa megosztása – áttekintés

A számítógépen tárolt mappa a hálózaton keresztül megosztható másokkal. A mappa megosztásakor kiválaszthatók a mások számára a mappában tárolt fájlok hálózaton keresztül történő elérésekor biztosított vagy megtagadott engedélyek. Az is megadható, hogy mások használhatják-e kapcsolat nélküli módban a megosztott mappát.

A megosztott fájlok kapcsolat nélküli módban történő használatához a Kapcsolat nélküli fájlok segédprogram a számítógép lemezének elkülönített, gyorsítótárnak nevezett részén tárolja a fájlok egy verzióját. A számítógép akkor is képes használni a gyorsítótárat, ha nem kapcsolódik hálózatra. Fájlok megosztásakor a gyorsítótár háromféleképpen állítható be:

Dokumentumok kézi gyorsítótárba helyezése

A Dokumentumok kézi gyorsítótárba helyezése elem választása esetén csak azok a fájlok használhatók kapcsolat nélküli módban, amelyeket a megosztott mappán keresztül valaki közvetlenül beállít. A gyorsítótárnak ez a beállítása ideális olyan megosztott hálózati mappák esetén, amelyeket több ember ér el és módosít. Egy megosztott mappa kapcsolat nélküli használatának beállításakor ez az alapértelmezett beállítás.

Dokumentumok automatikus gyorsítótárba helyezése

A Dokumentumok automatikus gyorsítótárba helyezése elem választása esetén a rendszer a megosztott mappában megnyitott minden fájl kapcsolat nélküli használatát beállítja. Ez a beállítás azonban a megosztott mappában tárolt fájlok közül csak a megnyitott fájlok kapcsolat nélküli használatát teszi lehetővé. Azok a fájlok nem használhatók kapcsolat nélküli módban, amelyeket nem nyitottak meg.

Programok automatikus gyorsítótárba helyezése

A Programok automatikus gyorsítótárba helyezése elem választása esetén azok a megosztott mappák használhatók kapcsolat nélkül, amelyek nem módosítható fájlokat tartalmaznak. A gyorsítótárnak ez a beállítása ideális az olyan fájlok kapcsolat nélküli használatra való beállítására, amelyek írásvédettek, csak hivatkozási célt szolgálnak, a folyamat során csak futtathatók, de nem módosíthatók. A Programok automatikus gyorsítótárba helyezése beállítás csökkenti a hálózati forgalmat, mivel a kapcsolat nélküli fájlok a hálózati verzió elérése nélkül megnyithatók, és általában gyorsabban indulnak és futnak, mint a hálózati verzió.

A Programok automatikus gyorsítótárba helyezése beállítás használata esetén korlátozza a megosztott mappában tárolt fájlok engedélyeit írásvédett hozzáférésre.

Megjegyzések

  • A gyorsítótár alapértelmezett mérete a szabad merevlemez-kapacitás 10%-a. Ez a beállítás a Mappa beállításai párbeszédpanel Kapcsolat nélküli fájlok lapján módosítható. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket. A gyorsítótár által elfoglalt terület is ellenőrizhető, ha megnyitja a Kapcsolat nélküli fájlok mappát, és a Fájl menü Tulajdonságok parancsára kattint.
  • Alaphelyzetben a Kapcsolat nélküli fájlok funkció a megosztott hálózati fájlokat a merevlemez gyökérkönyvtárában tárolja. A gyorsítótár helye módosítható a Windows 2000 Professional Resource Kit csomagban található Offline Files Cache Mover (cachemov.exe) segédprogrammal.


A kapcsolat nélküli fájlok használatának beállítása a számítógépen

  1. Kattintson a Sajátgép ikonra.
  2. Kattintson az Eszközök menü Mappa beállításai parancsára.
  3. A Kapcsolat nélküli fájlok lapon ellenőrizze, hogy a Kapcsolat nélküli fájlok engedélyezése jelölőnégyzet be van-e jelölve.
  4. A teljes szinkronizáláshoz jelölje be Az összes kapcsolat nélküli fájl szinkronizálása kijelentkezés előtt jelölőnégyzetet. Gyors szinkronizáláshoz hagyja üresen a jelölőnégyzetet.

Megjegyzések

  • A Sajátgép ablak megnyitásához az Asztalon kattintson duplán a Sajátgép ikonra.
  • A teljes szinkronizálás biztosítja, hogy minden kapcsolat nélküli használatra beállított hálózati fájl legfrissebb verziója elérhető legyen. A gyors szinkronizálás biztosítja, hogy elérhető legyen minden fájl teljes verziója, de nem feltétlenül a legfrissebb verzió.
  • A Kapcsolat nélküli fájlok engedélyezése jelölőnégyzet alaphelyzetben be van jelölve a Windows 2000 Professional esetében, és üres a Windows 2000 Server esetén.
  • A számítógépen a kapcsolat nélküli fájlok használatának engedélyezése után a kapcsolat nélküli módban használni kívánt hálózati fájlokat és mappákat mindenképpen ki kell választani.
  • A kapcsolat nélküli módban használható hálózati fájlok megjelenítéséhez a Kapcsolat nélküli fájlok lapon kattintson a Fájlok megtekintése gombra.


Fájl vagy mappa kapcsolat nélküli használatának beállítása

  1. A Sajátgép vagy a Hálózati helyek ablakban kattintson arra a megosztott hálózati fájlra vagy mappára, amelyet kapcsolat nélküli módban is akar használni.
  2. Kattintson a Fájl menü Kapcsolat nélküli elérés parancsára.

    Fontos

    • A Kapcsolat nélküli elérés parancs csak akkor jelenik meg a Fájl menüben, ha a számítógépen engedélyezte a kapcsolat nélküli fájlok használatát. A kapcsolat nélküli fájlok használatának engedélyezésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • Egy elem kapcsolat nélküli használatának legelső beállításakor a Kapcsolat nélküli fájlok varázsló végigvezet a beállítás folyamatán. Amikor a Szinkronizálás párbeszédpanel eltűnik, a fájl használható kapcsolat nélküli módban.

  • A megosztott hálózati mappában tárolt egyetlen fájl, vagy a teljes megosztott hálózati mappa kapcsolat nélküli használata is beállítható. Ha a teljes mappa kapcsolat nélküli használatát beállítja, akkor a megosztott mappába helyezett minden fájl a számítógép következő szinkronizálásakor kapcsolat nélküli módban is használhatóvá válik.
  • Ha beállítja egy fájlra mutató parancsikon kapcsolat nélküli használatát, akkor a rendszer a fájl kapcsolat nélküli használatát is beállítja, viszont ha egy mappára mutató parancsikon kapcsolat nélküli használatát állítja be, akkor a mappa tartalma nem használható kapcsolat nélküli módban.
  • Egy hálózati kapcsolat állapotának megváltozásakor a Kapcsolat nélküli fájlok ikon megjelenik az állapotterületen, és az álapotterületen megjelenő tájékoztató üzenet jelzi a változást. Ha a tájékoztató üzenet azt jelzi, hogy kapcsolat nélküli módban dolgozik, akkor a megszokott módon tovább dolgozhat a fájlokon, vagy az állapotterületen a Kapcsolat nélküli fájlok ikonra kattintással további részleteket jeleníthet meg a kapcsolat állapotáról.
  • A fájl vagy mappa kapcsolat nélküli használatának visszavonásához a jobb oldali egérgombbal kattintson újból a Kapcsolat nélküli elérés parancsra a pipa törléséhez.


Az utazó felhasználók által használható kapcsolat nélküli fájlok

Ha gyakran utazik, és hordozható számítógépen kell munkája nagy részét elvégezni, akkor a Kapcsolat nélküli fájlok funkció a hálózati kapcsolat bontása előtt lehetőséget biztosít a hálózati fájlok legújabb verziójának elérhetővé tételére. A kapcsolat nélküli módban elvégzett módosításokat a rendszer a hálózatra való újbóli kapcsolódáskor szinkronizálja. A Kapcsolat nélküli fájlok funkció használatakor a hálózati kapcsolat állapotától (kapcsolódik vagy nem kapcsolódik) függetlenül böngészhetők a megosztott mappák, és a csatlakoztatott hálózati meghajtók.

A megadott sorrendben hajtsa végre az alábbi műveleteket, ha hordozható számítógépen kapcsolat nélküli fájlokkal akar dolgozni:

Fájl vagy mappa kapcsolat nélküli használatának beállítása

A hordozható számítógép hálózati kapcsolatának bontása (dokkolóegységről való leválasztása) előtt elsőként jelölje ki a kapcsolat nélküli módban használni kívánt megosztott hálózati fájlokat és mappákat, és állítsa be ezek kapcsolat nélküli használatát.

Ennek lépései:

Be- vagy kijelentkezéskor szinkronizálja a fájlokat

Második lépésben a Szinkronizáláskezelő segédprogramban állítsa be, hogy a hálózatra való be- és kijelentkezéskor a hordozható számítógép hogyan szinkronizálja a fájlokat.

Ennek lépései:

Válassza le a hordozható számítógépet a dokkolóegységről (szüntesse meg a hálózati kapcsolatot)

A korábbi műveletek végrehajtása után leválasztható a hordozható számítógép, és kapcsolat nélküli módban elkezdhető a munka.

Ennek lépései:

Munka kapcsolat nélküli módban

A hálózati meghajtók és megosztott mappák kapcsolat nélküli módban is használhatók a Sajátgép és a Hálózati helyek ablakban. Csak a kapcsolat nélküli használatra kijelölt, és a hálózati kapcsolat megszakítása után létrehozott fájlok láthatók. Piros X jelenik meg a hálózatra nem csatlakozó hálózati meghajtók mellett. A hálózati fájlokra és mappákra vonatkozó engedélyek megegyeznek hálózatra kapcsolt és a kapcsolat nélküli módban.

További tudnivalók

Az ütköző fájlok kezelése

A kapcsolat nélküli munka befejezése és a hordozható számítógép dokkolása után a fájlokat újból szinkronizálni kell. A szinkronizálás a kapcsolat nélküli módban végrehajtott módosításokkal frissíti a hálózati fájlokat. A Szinkronizáláskezelő beállítható úgy, hogy bejelentkezéskor automatikusan szinkronizálja a fájlokat, így a fájl legutóbbi módosításai megjelennek a hálózaton, és minden ütköző fájlt helyesen kezel a rendszer.

További tudnivalók


Munka kapcsolat nélküli módban – áttekintés

A Kapcsolat nélküli fájlok segédprogram figyelmeztet a hálózati kapcsolat állapotának változásáról. A hálózati kapcsolat állapotának megváltozásakor a Kapcsolat nélküli fájlok ikon megjelenik az állapotterületen, és az álapotterületen megjelenő tájékoztató üzenet jelzi a változást. Ha a tájékoztató üzenet azt jelzi, hogy kapcsolat nélküli módban dolgozik, akkor a megszokott módon tovább dolgozhat a fájlokon, vagy az állapotterületen a Kapcsolat nélküli fájlok ikonra kattintással további részleteket jeleníthet meg a kapcsolat állapotáról.

A hálózati meghajtók és a megosztott mappák kapcsolat nélküli módban is használhatók a Sajátgép és a Hálózati helyek ablakban (függetlenül attól, hogy a hálózatról csatlakozott le, vagy leválasztotta a hordozható számítógépet). Piros X jelenik meg a hálózatra nem csatlakozó hálózati meghajtók mellett. Csak a kapcsolat nélküli használatra kijelölt, és a hálózati kapcsolat megszakítása után létrehozott fájlok láthatók.

A hálózati fájlokra és mappákra vonatkozó engedélyek megegyeznek hálózatra kapcsolt és a kapcsolat nélküli módban. Például a csatlakoztatott hálózati meghajtón tárolt írásvédett dokumentum írásvédett marad a hálózati kapcsolat megszakítása után is.

Ha nem kapcsolódik a hálózatra, akkor nyomtathat a helyi nyomtatókra, de nem nyomtathat a hálózaton keresztül elérhető megosztott nyomtatókra. Ilyenkor a rendszer a fájlt várakozási sorba állítja, és a hálózat újbóli csatlakoztatásakor kinyomtatja a helyi nyomtatóra.

A Szinkronizáláskezelő frissíti a hálózati fájlokat a kapcsolat nélküli módban végzett módosításokkal, amikor a számítógép ismét csatlakozik a hálózatra.


A kapcsolat nélküli fájlok a hálózati kapcsolat bontásakor való viselkedésének módosítása

  1. Kattintson a Sajátgép ikonra.
  2. Kattintson az Eszközök menü Mappa beállításai parancsára.
  3. A Kapcsolat nélküli fájlok lapon kattintson a Speciális gombra.
  4. Az Amikor egy hálózati kapcsolat megszakad részen hajtsa végre az alábbi műveletek egyikét:
    • Ha az Értesítsen, és folytassa a munkát kapcsolat nélküli módban választógombot választja, akkor a hálózati kapcsolat megszakadásakor figyelmeztetés jelenik meg, és a kapcsolat nélküli fájlokon és mappákon folytatható a munka.
    • Ha a Sose engedje a számítógépet kapcsolat nélküli módba váltani választógombot választja, akkor a hálózati kapcsolat megszakadásakor nem használhatók a kapcsolat nélküli fájlok és mappák.

Megjegyzés

  • A Sajátgép ablak megnyitásához az Asztalon kattintson duplán a Sajátgép ikonra.
  • Ha az egyes számítógépekre az alapértelmezettől különböző beállítást akar megadni, akkor kattintson a Hozzáadás gombra. Ha például alapértelmezés szerint folytatni akarja a munkát kapcsolat nélküli módban, de a hálózat egy adott számítógépén tárolt egyetlen fájlt sem akar kapcsolat nélküli módban használni, akkor a számítógép nevét adja hozzá a kivételek listájához, és válassza a Sose engedje a számítógépet kapcsolat nélküli módba váltani viselkedési módot az adott számítógépre.


Az ütköző fájlok kezelése

A fájlok szinkronizálásakor a rendszer a kapcsolat nélküli módban megnyitott vagy módosított fájlokat összehasonlítja a fájlok hálózaton tárolt verziójával. Ha ugyanazt a fájlt más nem módosította amíg kapcsolat nélküli módban dolgozott, akkor a rendszer az Ön által módosított fájlt másolja a hálózatra.

Ha valaki a hálózati kapcsolat mód használata közben ugyanazt a hálózati fájlt módosította, akkor kiválasztható, hogy a rendszer az Ön verzióját, a hálózaton tárolt verziót vagy mindkettőt tartsa-e meg. A fájl mindkét verziójának megtartása esetén az Ön által készített verzió egy új fájlnevet kap, és a fájl mindkét verziója megjelenik mindkét helyen.

Ha kapcsolat nélküli módban törölt egy olyan hálózati fájlt a számítógépen, amelyet e közben valaki módosított a hálózaton, akkor a rendszer a fájlt csak a számítógépről törli.

Ha az Ön által kapcsolat nélküli módban módosított fájlt e közben valaki törli a hálózaton, akkor kiválasztható, hogy menti-e az Ön által módosított verziót a hálózatra, vagy pedig törli a számítógépről.

Ha a kapcsolat nélküli mód használata közben egy új fájl kerül a kapcsolat nélküli használatra beállított megosztott hálózati mappába, akkor az újbóli csatlakozáskor és szinkronizáláskor a rendszer az új fájlt átmásolja a számítógépre.