Biztonsági mentés – áttekintés

A Biztonsági mentés segédprogram segítségével elkerülhető az adatvesztés hardverhiba vagy az adathordozó meghibásodása esetén. A Biztonsági mentés segédprogrammal például másolat készíthető a merevlemezen levő adatokról egy másik tárolóeszközre, például egy másik merevlemezre vagy szalagra. Ha a merevlemezen az eredeti adat véletlenül megsemmisül, felülírják vagy a merevlemez hibás működése miatt használhatatlanná válik, akkor a biztonsági másolat segítségével az adatok könnyen helyreállíthatók.

A Biztonság másolat segédprogram lehetővé teszi a következőket:

  • Biztonsági másolat készíthető a merevlemez kijelölt fájljairól és mappáiról.
  • A mentett fájlok és mappák visszaállíthatók a merevlemezre vagy bármely más, elérhető lemezre.
  • Készíthető helyreállító lemez, mellyel megjavíthatók a rendszerfájlok ha azok megsérülnek, vagy véletlenül törli őket.
  • Másolat készíthető a távtárolókon és a csatlakoztatott meghajtókon levő adatokról.
  • Másolat készíthető a számítógép rendszerállapotáról, ezen belül a rendszerleíró adatbázisról, az indítófájlokról és a rendszerfájlokról.
  • Biztonsági másolat készíthető a kiszolgálókon és a tartományvezérlőkön futó szolgáltatásokról, például az Active Directory címtáradatbázisáról, a bizonyítványszolgáltatás adatbázisáról és a fájlreplikációs szolgáltatás SYSVOL könyvtáráról.
  • A biztonsági mentés ütemezhető a mentett adatok rendszeres aktualizálása érdekében.

A Biztonsági mentés segédprogrammal FAT- vagy NTFS-köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági mentés esetén azonban javasolt a visszaállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Elveszhetnek például az engedélyek és a titkosító fájlrendszer (EFS) beállításai, a lemezkvóta-adatok, valamint a csatlakoztatott meghajtók és a távtárolók adatai, ha Windows 2000 rendszerben használt NTFS-kötetről készült adatokat FAT-kötetre vagy Windows NT 4.0 rendszerbeli NTFS-kötetre állít vissza.

Kapcsolódó témakörök


Gyakori feladatok: biztonsági mentés

Gyakori feladatok

A következő feladatok gyakran előfordulnak a Biztonság mentés segédprogram használata során. Adott szó vagy kifejezés kereséséhez kattintson a Tárgymutató vagy a Keresés fülre.

Biztonsági másolat készítése fájlokról és mappákról fájlba vagy szalagra

A Biztonsági mentés segédprogrammal archiválhatók a fájlok és a mappák; így azok a merevlemez meghibásodása vagy a fájlok véletlen törlése esetén visszaállíthatók.

Tennivalók lépésről lépésre

További tudnivalók

Fájlok és mappák visszaállítása fájlból vagy szalagról

A Biztonsági mentés segédprogrammal visszaállíthatók az archivált fájlok és mappák.

Tennivalók lépésről lépésre

További tudnivalók

Biztonsági mentés készítése a rendszerállapot-adatokról

A Biztonsági mentés segédprogrammal másolat készíthető a fontos rendszerösszetevőkről, például a rendszerleíró adatbázisról, az indítófájlokról, valamint az Active Directory címtáradatbázisáról.

Tennivalók lépésről lépésre

További tudnivalók

A rendszerállapot-adatok visszaállítása

A Biztonsági mentés segédprogrammal visszaállítható a fontos rendszerösszetevők, például a rendszerleíró adatbázis, az indítófájlok, valamint az Active Directory címtáradatbázisának a másolata.

Tennivalók lépésről lépésre

További tudnivalók

Helyreállító lemez létrehozása

A Biztonsági mentés segédprogrammal készíthető helyreállító lemez, mellyel megjavítható a számítógép a rendszerfájlok véletlen törlése vagy megsérülése esetén.

Tennivalók lépésről lépésre

További tudnivalók


Biztonsági mentés készítése fájlokról és mappákról

A Biztonsági mentés funkcióval az adatokról biztonsági másolat készíthető fájlba vagy szalagra. Fájlba történő biztonsági másolat készítésekor meg kell adni annak a fájlnak a nevét és helyét, amelybe az adatokat akarja menteni. A biztonsági másolat fájlok általában .bkf kiterjesztéssel rendelkeznek, de a kiterjesztés tetszés szerint módosítható. A biztonsági másolat fájlok menthetők merevlemezre, hajlékonylemezre, bármilyen cserélhető vagy nem cserélhető adathordozóra, amelyre fájlok menthetők.

Az adatokról akkor készíthető szalagra biztonsági mentés, ha a számítógéphez szalagos eszköz csatlakozik. A szalagok a Cserélhető tároló alkalmazással is kezelhetők. Bár a Biztonsági mentés alkalmazás a Cserélhető tároló alkalmazással együttműködik, bizonyos karbantartási feladatok (például a szalagok előkészítésének és kivételének) végrehajtásához a Cserélhető tároló alkalmazás szükséges.

Az egyszerű biztonsági mentés az alábbi négy lépésből áll:

Azoknak a fájloknak, mappáknak és meghajtóknak a kiválasztása, amelyről biztonsági másolatot akar készíteni.

A Biztonsági mentés alkalmazás fa nézetében választhatók ki a számítógépen levő meghajtók, fájlok és mappák közül azok a fájlok és mappák, amelyekről biztonsági mentést akar készíteni. Ez a fa nézet a Windows Intézőben megszokott módon teszi lehetővé a meghajtók és mappák megnyitását, valamint a fájlok kijelölését.

Válassza ki a biztonsági másolat tárolására szolgáló tárolóeszközt vagy fájlt.

A Biztonsági mentés alkalmazás két lehetőséget biztosít a tárolóeszköz kiválasztására:

Az adatokról egy tárolóeszközön levő fájlba is készíthető biztonsági mentés. A biztonságimásolat-fájlok menthetők merevlemezre, Zip-lemezre, bármilyen cserélhető vagy nem cserélhető adathordozóra, amelyre fájlok menthetők. Ez a beállítás mindig használható.

Az adatokról szalagos eszközre is készíthető biztonsági mentés. Ez a beállítás csak akkor használható, ha a számítógépbe szalagos egység van telepítve. Az adatok szalagos egységre történő biztonsági mentésekor az adathordozót a Cserélhető tároló alkalmazás kezeli.

A biztonsági mentés beállításainak megadása

A Biztonsági mentés alkalmazás Beállítások párbeszédpanelén tetstreszabhatók a biztonsági mentéssel kapcsolatos műveletek. A Beállítások párbeszédpanelen az alábbi beállítások megadását teszi lehetővé:

Kiválasztható a biztonsági mentés típusa. A biztonsági mentésnek a következő típusai használhatók: másolás, napi, különbségi, növekményes és normál.

Megadható, hogy akarja-e naplófájlban rögzíteni a biztonsági mentés műveleteit. E beállítás választásakor az is kiválasztható, hogy teljes, vagy összesítő naplófájlt akar készíteni.

Kiválasztható, hogy akar-e biztonsági másolatot készíteni a csatlakoztatott meghajtókon tárolt adatokról.

Megadhatók azok a fájltípusok, amelyekről nem kell biztonsági másolatot készíteni.

Kiválasztható, hogy ellenőrizni akarja-e a biztonsági mentés hibátlan végrehajtását.

Indítsa el a biztonsági mentést

A biztonsági mentés elindítása után a Biztonsági mentés alkalmazás számára adatokat kell megadni a biztonsági mentésről, valamint megadhatók a biztonsági mentés speciális beállításai. Az adatok megadása, vagy a biztonsági mentés beállításainak módosítása után a Biztonsági mentés alkalmazás elkezdi a kiválasztott fájlok és mappák biztonsági mentését.

A biztonsági mentéssel kapcsolatos adatokat akkor is meg kell adnia, ha a biztonsági mentés felügyelet nélküli futtatását ütemezte be. Az adatok megadása után azonban a Biztonsági mentés alkalmazás nem kezdi el a fájlok biztonsági mentését, hanem az ütemezett biztonsági mentést hozzáadja a Feladatütemező alkalmazáshoz.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekről vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok a rendszerleíró adatbázist, címtárszolgáltatást és további alapvető rendszerösszetevőket tartalmaznak. Biztonsági mentést kell készíteni a rendszerállapot-adatokról, ha biztonsági másolatot akar készíteni ezekről az összetevőkről.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági mentés. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági mentés.
  • A biztonsági mentés ütemezhető, így megadott időpontban és gyakorisággal felügyelet nélkül futtatható. A biztonsági mentés a Biztonsági másolat indítása gombra kattintás után ütemezhető.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági mentést készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának „Biztonsági mentés használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és helyreállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Ha az adathordozók kezelésére a Cserélhető tároló alkalmazás használja vagy az adatok tárolására a Távtároló alkalmazást használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági mentést kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távtároló és a Cserélhető tároló alkalmazás összes adatának helyreállíthatóságát.


A biztonsági mentés típusai

A Biztonsági mentés segédprogrammal a számítógépen és a hálózaton tárolt adatokról ötféleképpen készíthető biztonsági mentés.

Biztonsági másolat

A biztonsági másolat az összes kijelölt fájlt átmásolja, de nem jelöli meg a fájlokat, hogy biztonsági mentés készült róluk (más szóval nem törli az archiválandó attribútumot). A másolás akkor hasznos, ha normál és növekményes biztonsági mentés között akar biztonsági mentést készíteni a fájlokról, mivel a másolás nem befolyásolja ezeket a biztonsági mentéseket.

Napi biztonsági mentés

A napi biztonsági mentés az összes kijelölt, a napi biztonsági mentés napján módosított fájlt átmásolja. A biztonsági mentést a rendszer nem jelöli a fájlokon (más szóval az archiválandó attribútumot nem töli).

Különbségi biztonsági mentés

A különbségi biztonsági mentés során a rendszer az összes olyan fájlt átmásolja, amely a legutóbbi normál vagy növekményes biztonsági mentés óta keletkezett vagy módosult. A biztonsági mentést a rendszer nem jelöli a fájlokon (más szóval az archiválandó attribútumot nem töli). A normál és különbségi biztonsági mentés kombinációjának a használatakor a fájlok és mappák helyreállításához egyaránt szükséges a legutolsó normál és a legutolsó különbségi biztonsági mentés.

Növekményes biztonsági mentés

A növekményes biztonsági mentés csak a legutolsó normál vagy növekményes biztonsági mentés óta létrehozott vagy módosított fájlokról készít biztonsági mentést. A biztonsági mentés végrehajtását a rendszer jelöli a fájlokon (más szóval törli az archiválandó attribútumot). A normál és a növekményes biztonsági mentés kombinációjának a használatakor az adatok helyreállításához egyaránt szükséges a legutolsó normál és az összes növekményes biztonsági mentés.

Normál biztonsági mentés

A normál biztonsági mentés az összes kijelölt fájlt átmásolja, és az összes fájlon jelöli a biztonsági mentés végrehajtását (más szóval törli az archiválandó attribútumot). Normál biztonsági mentés esetén az összes fájl helyreállításához mindössze a biztonsági mentés fájl vagy szalag legutolsó példánya szükséges. A legelső biztonságimásolat-készlet elkészítésekor általában normál biztonsági mentést kell végrehajtani.

A normál és növekményes biztonsági mentés kombinációjának használata esetén szükséges a legkevesebb tárolókapacitás az adatok biztonsági mentéséhez. Ez biztosítja a leggyorsabb biztonsági mentést. A fájlok helyreállítása azonban időigényes és bonyolult lehet, mivel a biztonságimásolat-készletek több lemezen vagy szalagon lehetnek.

Normál és különbségi biztonsági mentés használata esetén az adatok biztonsági mentése több időt vesz igénybe, különösen gyakran módosuló adatok esetén, de könnyebb az adatok helyreállítása, mivel általában a biztonságimentés-készletet a rendszer csupán néhány lemezen vagy szalagon tárolja.


Biztonsági másolat készítése fájlokról fájlba vagy szalagra

  2. Kattintson a Biztonsági másolat fülre, majd a Feladat menü Új parancsára.
  3. A Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában kattintással jelölje be azon fájlok és mappák bal oldalán levő jelölőnégyzetet, amelyekről biztonsági másolatot akar készíteni.
  4. A Biztonsági másolat helye listában hajtsa végre az alábbi műveletek egyikét:
    • Válassza a Fájl elemet, ha biztonsági másolatként fájlt akar készíteni a fájlokról és mappákról. Ha a számítógépen nincs szalagos egység telepítve, akkor ez az alapértelmezett beállítás.
    • Válasszon egy szalagos egységet, ha szalagra akar biztonsági másolatot készíteni a fájlokról és mappákról.
  5. A Biztonsági másolat adathordozója vagy fájlneve beviteli mezőben hajtsa végre az alábbi műveletek egyikét:
    • Ha fájlba készít biztonsági másolatot a fájlokról és mappákról, akkor írja be a biztonságimásolat-fájl (.bkf) elérési útvonalát, vagy a fájl megkereséséhez kattintson a Tallózás gombra.
    • Ha szalagra készít biztonsági másolatot a fájlokról és mappákról, akkor válassza ki a használni kívánt szalagot.
  6. Az Eszközök menü Beállítások parancsára kattintás után válassza ki a biztonsági másolat kívánt beállításait, például a biztonsági másolat típusát és a naplófájl típusát. A biztonsági másolat beállításának befejezése után kattintson az OK gombra.
  7. Kattintson a Biztonsági másolat indítása gombra, majd végezzen el minden szükséges módosítást a Biztonságimásolat-készítési feladat információi párbeszédpanelen.
  8. Ha speciális beállításokat (például adatellenőrzést vagy hardveres tömörítést) akar használni a biztonsági másolat készítéséhez, akkor kattintson a Speciális gombra. A biztonsági másolat speciális beállításainak megadása után kattintson az OK gombra.
  9. A biztonsági mentés elindításához kattintson a Biztonsági másolat indítása gombra.

Fontos

  • A Biztonsági másolat segédprogrammal FAT- vagy NTFS-köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat FAT- vagy Windows NT 4.0 rendszerben használt NTFS-köteten való helyreállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az Eszközök menü Biztonságimásolat-készítő varázsló parancsával elindítható Biztonságimásolat-készítő varázslóval is készíthető biztonsági másolat a fájlokról és mappákról.
  • Ha a rendszerállapot-adatok szalagra történő biztonsági mentésekor a Biztonsági mentés segédprogram azt jelzi, hogy nincs használható adathordozó, akkor a Cserélhető tároló segédprogrammal a szalag hozzáadható a biztonsági másolat adathordozó-készlethez. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ha biztonsági másolatot akar készteni a rendszerleíró adatbázist és az Active Directory címtárszolgáltatás adatbázisát tartalmazó rendszerállapot-adatokról, akkor a Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában válassza a Rendszer állapota elemet.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • A biztonsági másolat fájlok általában .bkf kiterjesztéssel rendelkeznek, de kiterjesztésük tetszés szerint módosítható.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági mentést készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának “Biztonsági másolat használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és visszaállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Ha az adathordozók kezelésére a Cserélhető tároló segédprogramot használja vagy az adatok tárolására a Távtároló segédprogramot használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági másolatot kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távtároló és a Cserélhető tároló segédprogram összes adatának visszaállíthatóságát.


Biztonsági másolat készítése Microsoft Exchange Serveren tárolt fájlokról

  2. Kattintson a Biztonsági másolat fülre, és a Jelölje be azokat a meghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában jelölje be a Microsoft Exchange elem melletti jelölőnégyzetet.
  3. A Kiszolgáló beviteli mezőbe írja be annak a Microsoft Exchange Servernek a nevét, amelyről biztonsági másolatot akar készíteni. A nevet két fordított ferde vonalnak kell megelőznie (például \\Budapest).
  4. Kattintson a Csatlakozás szervezethez elemre, majd az OK gombra.

Fontos

  • A Biztonsági másolat segédprogrammal FAT- vagy NTFS-köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat FAT-vagy Windows NT 4.0 rendszerben használt NTFS-köteten való helyreállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A fentiekben bemutatott eljárás és a hozzáfűzött megjegyzések az 5.5-ös vagy korábbi verzióira érvényesek.
  • Ha a rendszerállapot-adatok szalagra történő biztonsági mentésekor a Biztonsági mentés segédprogram azt jelzi, hogy nincs használható adathordozó, akkor a Cserélhető tároló segédprogrammal a szalag hozzáadható a biztonsági másolat adathordozó-készlethez. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Microsoft Exchange Server adatainak visszaállításakor a rendszer leállítja az Information Store és a Directory szolgáltatást. A visszaállítás befejezése után a szolgáltatások elindításához kattintson az Eszközök menü Microsoft Exchange parancsára, a Szolgáltatás indítása gombra, válassza a Directory vagy Information Store elemet, majd kattintson az OK gombra.


Rendszerállapot-adatok

A Biztonsági másolat segédprogrammal a rendszer alábbi összetevőinek végezhető el a biztonsági mentése és visszaállítása:

  • Rendszerleíró adatbázis
  • COM+ osztályregisztrációs adatbázis
  • Rendszerindító fájlok, amelyek tartalmazzák a rendszerfájlokat
  • Bizonyítványszolgáltatások adatbázis
  • Active Directory címtárszolgáltatás
  • SYSVOL könyvtár
  • Fürtszolgáltatás adatai

A Biztonsági mentés segédprogram ezeket a rendszerösszetevőket együttesen rendszerállapot-adatoknak nevezi. A Windows 2000 Professional operációs rendszerben a rendszerállapot-adatok csak a rendszerleíró adatbázist, a COM+ osztályregisztrációs adatbázist és a rendszerindító fájlokat foglalják magukban. A Windows 2000 Server operációs rendszerben a rendszerállapot-adatok a rendszerleíró adatbázist, a COM+ osztályregisztrációs adatbázist, a rendszerindító fájlokat és a Bizonyítványszolgáltatások adatbázist (ha a kiszolgáló bizonyítványkiszolgálóként működik) foglalják magukban. A tartományvezérlő rendszerállapot-adatainak az Active Directory és a SYSVOL könyvtár is része. A tartományvezérlőn tartománynév-szolgáltatás (DNS) futtatásakor a rendszerállapot-adatok az Active Directory címtárra vonatkozó része is tartalmazza a DNS-zóna összes (a címtárszolgáltatásba integrált és a címtárszolgáltatásba nem integrált) adatát. Ha a kiszolgálón fut a Fürtszolgáltatás, akkor a rendszerállapot-adatok tartalmazzák az összes rendszerleíró adatbázis ellenőrzőpontot és a fürtadatbázis legfrissebb adatait tartalmazó quorum erőforrás helyreállítási naplót.

A rendszerállapot adatok biztonsági mentésekor és visszaállításakor a rendszer a számítógéphez kapcsolódó összes rendszerállapot-adat biztonsági mentését vagy visszaállítását végrehajtja, a rendszerállapot-adatok különálló összetevőinek biztonsági mentése vagy visszaállítása nem hajtható végre. Ezt a rendszerállapot-adatok közötti függőségek indokolják. A rendszerállapot-adatok azonban más helyre is visszaállíthatók. A rendszer ilyenkor csak a rendszerleírófájlokat, a SYSVOL könyvtárban tárolt fájlokat, a fürtadatbázis információs fájljait és a rendszerindító fájlokat állítja vissza az új helyre. Másik helyre történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.

Ráadásul ha a szervezetben egynél több tartományvezérlő működik, és az adott kiszolgáló az Active Directory címtárszolgáltatást a többi kiszolgáló bármelyikére replikálja, akkor az Active Directory adatainak visszaállításához a mérvadó visszaállítást kell használni. Az Active Directory adatainak mérvadó visszaállításához a rendszerállapot-adatok visszaállítása után, de a kiszolgáló újraindítása előtt az Ntdsutil segédprogramot kell futtatni. Az Ntdsutil segédprogram lehetővé teszi az Active Directory objektumok megjelölését a mérvadó visszaállításhoz. Ez garantálja, hogy minden visszaállított, replikált vagy továbbított adatot a rendszer megfelelően replikáljon vagy továbbítson a szervezeten belül.

Például ha az Active Directory címtárszolgáltatásban tárolt objektum véletlen törlését vagy módosítását a rendszer replikálta vagy továbbította más kiszolgálókhoz, akkor mérvadó visszaállításon keresztül kell az objektumot visszaállítani ahhoz, hogy a rendszer a többi kiszolgálóra replikálja vagy továbbítsa az objektumot. Ha nem mérvadó visszaállításon keresztül állítja helyre az objektumot, a rendszer soha nem replikálja vagy továbbítja majd más kiszolgálókra, mert régebbinek tűnik majd a többi kiszolgálón jelenleg tárolt objektumoknál. Ha az Ntdsutil segédprogrammal megjelöli az objektumot a mérvadó visszaállításhoz, akkor az garantálja, hogy a rendszer a visszaállítani kívánt adatokat replikálja vagy továbbítsa a szervezeten belül. Másrészről ha a rendszerlemez meghibásodik, vagy az Active Directory adatbázis megsérül, akkor az adatok a Ntdsutil segédprogram használata nélkül (nem mérvadó visszaállítással) egyszerűen visszaállíthatók.

Az Ntdsutil parancssori segédprogram a parancssorból futtatható. Az Ntdsutil segédprogram súgója az ntdsutil /? parancs beírásával a parancssorban is használható.

Megjegyzések

  • A fájlok és mappák biztonsági mentéséhez és visszaállításához bizonyos engedélyekkel vagy felhasználói engedélyekkel kell rendelkezni.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások helyreállító módban állíthatók helyre. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory visszaállítását.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Bár nem módosíthatók a rendszerállapot-adatok biztonsági mentésébe bevont összetevők, a biztonsági másolat speciális beállításainak megadásával a rendszerállapot-adatokkal együtt biztonsági másolat készíthető az összes védett rendszerfájlról. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Biztonsági mentés készítése a rendszerállapot-adatokról

  2. Kattintson a Biztonsági másolat fülre, majd a Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában jelölje be a Rendszer állapota elem melletti jelölőnégyzetet. E beállítás hatására a rendszer a többi kiválasztott adattal együtt biztonsági másolatot készít a rendszerállapot-adatokról is.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói jogokkal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatokról az Eszközök menü Biztonságimásolat-készítő varázsló parancsával futtatható Biztonságimásolat-készítő varázslóval is készíthető biztonsági másolat.
  • Ha a rendszerállapot-adatok szalagra történő biztonsági mentésekor a Biztonsági mentés segédprogram azt jelzi, hogy nincs használható adathordozó, akkor a Cserélhető tároló segédprogrammal a szalag hozzáadható a Biztonsági mentés segédprogram által használható adathordozó-készlethez. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Ha biztonsági mentést készít a rendszerállapot-adatokról, akkor a rendszer a rendszerleíróadatbázis-fájlokat elmenti a rendszergyökér/repair/regback mappába is. A rendszerleíróadatbázis-fájlok megsérülése vagy véletlenszerű törlése esetén a rendszerállapot-adatok teljes visszaállítása nélkül ezeknek a fájloknak a segítségével állítható helyre a rendszerleíró adatbázis. A rendszerleíró adatbázis helyreállításának ez a módja csak tapasztalt felhasználók számára javasolt.


A biztonsági mentés ütemezése

  2. Kattintson a Biztonsági másolat fülre, majd a Feladat menü Új parancsára.
  3. A Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában jelölje be azon fájlok és mappák bal oldalán levő jelölőnégyzetet, amelyekről biztonsági másolatot akar készíteni.
  4. A Biztonsági másolat helye listában válasszon egy szalagos eszközt vagy a Fájl elemet, majd a Feladat menü Kijelölés mentése parancsára kattintással mentse el a kiválasztott fájlokat és mappákat.
  5. A Biztonsági másolat adathordozója vagy fájlneve beviteli mezőbe írja be a biztonságimásolat-fájl elérési útját és nevét, vagy válasszon egy szalagot.
  6. Az Eszközök menü Beállítások parancsára kattintás után válassza ki a biztonsági másolat kívánt beállításait, például a biztonsági másolat típusát, és a naplófájl típusát. A biztonsági másolat beállításának befejezése után kattintson az OK gombra.
  7. Kattintson a Biztonsági másolat indítása gombra, és végezzen el minden szükséges módosítást a Biztonságimásolat-készítési feladat információi párbeszédpanelen.
  8. Ha speciális beállításokat (például adatellenőrzést vagy hardveres tömörítést) akar használni a biztonsági másolat készítéséhez, akkor kattintson a Speciális gombra. A biztonsági másolat speciális beállításainak befejezése után kattintson az OK gombra.
  9. A Biztonságimásolat-készítési feladat információi párbeszédpanelen kattintson az Ütemezés elemre.
  10. A Fiókinformáció beállítása párbeszédpanelen írja be annak a felhasználónak a nevét és jelszavát, akinek a neve alatt az ütemezett biztonsági mentést futtatni akarja.
  11. Az Ütemezett feladat beállításai párbeszédpanel Feladatnév beviteli mezőjébe írja be az ütemezett biztonságimásolat-feladat nevét, kattintson a Tulajdonságok gombra és állítsa be az ütemezett biztonságimásolat-készítés dátumával, időpontjával és gyakoriságával kapcsolatos paramétereket. A beállítások megadása után kattintson az OK, majd újból az OK gombra.

Fontos

  • A Biztonsági másolat segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való helyreállításakor a engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagra történő biztonsági mentés ütemezésekor a Cserélhető tároló segédprogrammal ellenőrizze, hogy a Biztonságimásolat adathordozó-készletben használható-e a szalag. A Cserélhető tároló segédprogrammal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A biztonságimásolat-készítés csak akkor ütemezhető, ha fut a Feladatütemező szolgáltatás. Ehhez nyissa meg a parancssor ablakot, és írja be a következő parancsot: net start schedule. A szolgáltatások a Számítógépkezelés segédprogram Szolgáltatások csoportjában is elindíthatók, leállíthatók, és az állapotuk is megjeleníthető.
  • Ha biztonsági másolatot akar készteni a rendszerleíró adatbázist és az Active Directory címtárszolgáltatást tartalmazó rendszerállapot-adatokról, akkor a Jelölje be azokat a maghajtókat, mappákat és fájlokat, amelyekről biztonsági másolatot kíván készíteni listában válassza a Rendszer állapota elemet.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Az Ütemezett feladat beállításai párbeszédpanelen a Törlés gombra kattintással törölhető az ütemezett biztonsági mentés a Feladatütemező szolgáltatásból.
  • A biztonságimásolat-készítés beütemezése után az ütemezés módosításához kattintson a Feladatok ütemezése fülre, majd kattintson a naptáron látható biztonságimásolat-ikonra.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági másolatot készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának “Biztonsági mentés használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és visszaállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Ha az adathordozók kezelésére a Cserélhető tároló alkalmazás használja vagy az adatok tárolására a Távtároló alkalmazást használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági másolatot kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távtároló és a Cserélhető tároló segédprogram összes adatának visszaállíthatóságát.


Biztonsági mentés készítése az adatokról parancsfájl segítségével

Biztonsági másolat az ntbackup parancs és annak számos parancssori kapcsolójának segítségével parancsfájlokkal is készíthető. Az adatok parancsfájllal történő biztonsági mentésekor azonban két fontos korlátozást figyelembe kell venni:

  • Az ntbackup paranccsal csak teljes mappáról készíthető biztonsági másolat. Nem készíthető biztonsági másolat egyedi fájlokról. A parancssorban azonban kiadható egy biztonságimásolat-kijelölőfájl (.bks fájl), amely tartalmazza azoknak a fájloknak a listáját, amelyekről biztonsági másolatot akar készíteni. Biztonságimásolat-kijelölőfájl csak a grafikus Biztonsági mentés segédprogrammal készíthető.
  • Az ntbackup parancsban nem használhatók helyettesítő karakterek. Például a *.txt kifejezés megadásának hatására a rendszer nem fog biztonsági másolatot készíteni a .txt kiterjesztésű fájlokról.


Mappák és fájlok helyreállítása

Az egyszerű helyreállítási művelet az alábbi négy lépésből áll:

Válassza ki a helyreállítani kívánt fájlokat és mappákat

A Biztonsági mentés alkalmazás fa nézetben jeleníti meg azokat a fájlokat és mappákat, amelyekről biztonsági mentést készített. Itt választhatók ki azok a fájlok és mappák, amelyeket vissza akar állítani. Ez a fa nézet a Windows Intézőben megszokott módon teszi lehetővé a meghajtók és mappák megnyitását, valamint a fájlok kijelölését.

Válassza ki, hová akarja visszaállítani azokat a fájlokat és mappákat, amelyekről biztonsági mentést készített.

A Biztonsági mentés alkalmazás három hely egyikére teszi lehetővé a visszaállított fájlok mentését:

Az adatok visszaállíthatók eredeti mappájukba vagy mappáikba, ahonnan a biztonsági mentés készült róluk. Ez a beállítás sérült vagy elveszett fájlok és mappák visszaállításához hasznos.

A biztonsági mentésben levő adatok egy másik mappába is visszaállíthatók. E beállítás választása esetén a másik mappában megmarad a mappák és fájlok a biztonsági mentés során érvényes struktúrája. Ez a beállítás akkor hasznos, ha csak néhány régi fájl szükséges, de nem akarja felülírni vagy módosítani a lemezen jelenleg levő fájlokat vagy mappákat.

A biztonsági mentésben levő fájlok egyetlen mappába is visszaállíthatók. Ez a beállítás nem tartja meg a biztonsági mentésben szereplő mappák és fájlok struktúráját. A rendszer a biztonsági mentésben szereplő fájlokat egyetlen mappába helyezi. Ez a beállítás egy olyan fájl keresése esetén hasznos, amelynek nem ismeri a helyét.

Adja meg a visszaállítási beállításokat

A Biztonsági mentés alkalmazás Beállítások párbeszédpanelének Helyreállítás lapján adhatók meg a fájlok és mappák visszaállításának beállításai. Három beállítás egyikét kell kiválasztani:

  • Ne cserélje le a számítógépen lévő fájlt. Ez megakadályozza a merevlemezen levő fájlok felülírását. Ez a fájlok visszaállításának legbiztonságosabb módja.

  • Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi. Ha az adatok legutolsó biztonsági mentése óta bármely fájlban változás történt, akkor ez a beállítás garantálja, hogy egyetlen módosítás se vesszen el.

  • Mindig cserélje le a számítógépen lévő fájlt. Ennek hatására a rendszer a merevlemezen levő összes fájlt lecseréli a biztonságimásolat-készletben levő fájlokkal. Ha az utolsó biztonsági mentés óta bármilyen változás történt, akkor e beállítás használata esetén ezek a módosítások elvesznek.

Indítsa el a visszaállítást

A visszaállítási művelet elindítása után a Biztonsági mentés alkalmazás kéri annak megerősítését, hogy minden készen áll az adatok visszaállításához. Megadhatók speciális visszaállítási beállítások is, például vissza akarja-e állítani a biztonsági beállításokat, a Cserélhető tároló adatbázisát és a csatlakozási pont adatait.

Fontos

  • A Biztonsági mentés segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági mentés esetén azonban javasolt a visszaállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való visszaállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok a rendszerleíró adatbázist, az Active Directory címtárszolgáltatást és további alapvető rendszerösszetevőket tartalmaznak. Biztonsági mentést kell készíteni a rendszerállapot-adatokról, ha el akarja végezni ezeknek az összetevőknek a biztonsági mentését vagy visszaállítását.
  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok visszaállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági mentésben szereplő adatokkal. A rendszerállapot-adatok másik mappába történő visszaállításakor a rendszer csak a rendszerleíró adatbázis fájljait, a SYSVOL könyvtárfájlokat, a fürtadatbázis-leíró fájlokat és a rendszerindító fájlokat állítja vissza a másik mappába. Másik mappába történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások visszaállító módban állíthatók vissza. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory visszaállítását.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.


Fájlok visszaállítása fájlból vagy szalagról

  2. A Visszaállítás lapon a Jelölje be az összes visszaállítandó meghajtót, mappát és fájlt listában a fájl vagy mappa bal oldalán található jelölőnégyzet bejelölésével válassza a visszaállítani kívánt fájlokat és mappákat.
  3. A Visszaállítás helye listában hajtsa végre az alábbi műveletek egyikét:
    • Válassza az Eredeti hely elemet, ha a biztonsági másolatban levő fájlokat és mappákat a biztonsági másolat elkészítésekor elfoglalt eredeti helyükre akarja visszaállítani. Folytassa az 5. lépéssel.
    • Kattintson az Alternatív hely elemre, ha a biztonsági másolatban levő fájlokat és mappákat egy adott mappába akarja visszaállítani. Ez a beállítás megőrzi a visszaállított adatok eredeti mappastruktúráját, de az összes mappa és almappa a megadott új mappában jelenik meg.
    • Kattintson az Egy mappa elemre, ha a biztonsági másolatban levő fájlokat és mappákat egy adott mappába akarja visszaállítani. Ez a beállítás nem tartja meg a visszaállított adatok eredeti mappastruktúráját, mivel az összes fájl a megadott új mappában jelenik meg.
  4. Az Alternatív hely vagy az Egy mappa elem kiválasztása esetén írja be a mappa elérési útvonalát a Másik hely beviteli mezőbe, vagy a mappa megkereséséhez kattintson a Tallózás gombra.
  5. Kattintson az Eszközök menü Beállítások parancsára, a Visszaállítás fülre, majd hajtsa végre az alábbi műveletek egyikét.
    • Válassza a Ne cserélje le a számítógépen lévő fájlt választókapcsolót, ha nem akarja, hogy a visszaállítás során a rendszer átmásolja a merevlemezen már meglevő fájlokat.
    • Válassza a Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsolót, ha a visszaállítás során a lemezen levő régebbi fájlokat le akarja cserélni a biztonsági másolatban levő újabb fájlokkal.
    • Válassza a Mindig cserélje le a számítógépen lévő fájlt választókapcsolót, ha a visszaállítás során a biztonsági másolatban levő fájlokkal minden esetben felül akarja írni a lemezen levő fájlokat.
    • A visszaállítás beállításainak érvényesítéséhez kattintson az OK gombra.
  6. Kattintson a Visszaállítás indítása gombra.
  7. Ha módosítani akarja a speciális visszaállítási beállításokat (például biztonsági beállítások, Cserélhető tároló adatbázisának és a csatlakozási pont adatainak a visszaállítását), akkor kattintson a Speciális gombra. A visszaállítás speciális beállításainak megadása után kattintson az OK gombra.
  8. A visszaállítás elindításához kattintson az OK gombra.

Vigyázat

  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok visszaállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági másolatban levő adatokkal. A rendszerállapot-adatok másik mappába történő visszaállításakor a rendszer csak a rendszerleírófájlokat, a SYSVOL könyvtárfájlokat, a fürtadatbázis-leíró fájlokat és a rendszerindító fájlokat állítja vissza a másik mappába. Másik mappába történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.
  • A Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsoló kiválasztása esetén előfordulhat, hogy a rendszer módosítja a lemezen levő néhány vagy összes fájlt.
  • A Mindig cserélje le a számítógépen lévő fájlt választókapcsoló beállítása esetén előfordulhat adatvesztés, ha a jelenleg módosítás alatt levő fájl szerepel a biztonsági másolatban.
  • A Biztonsági mentés segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való visszaállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • Csak a rendszergazdák vagy biztonságimásolat-felelősök állíthatják vissza a fájlokat és a mappákat. az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagról történő visszaállítás esetén a visszaállítási művelet végrehajtása előtt frissíteni kell a lemezen tárolt katalógust. A katalógus frissítésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az Eszközök menü Visszaállító varázsló parancsával elindítható Visszaállító varázslóval is elvégezhető a fájlok visszaállítása.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások visszaállító módban állíthatók vissza. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory címtárszolgáltatás adatbázisának visszaállítását.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.
  • A Rendszergazdák és a Biztonságimásolat-felelősök a fájlok vagy mappák visszafejtése nélkül állíthatják vissza a titkosított fájlokat és mappákat.


Microsoft Exchange Server fájlok visszaállítása

  2. A Visszaállítás lapon a Jelölje be az összes visszaállítandó meghajtót, mappát és fájlt listában válassza a visszaállítani kívánt Microsoft Exchange adatokat.
    3. Kattintson a Visszaállítás indítása gombra.

    Megjelenik a Microsoft Exchange visszaállítása párbeszédpanel.

  3. Ha az Adadttároló (Infomation Store) adatait állítja vissza, akkor a Visszaállítás helye beviteli mezőbe írja be annak a kiszolgálónak a nevét, amelyre az adatokat vissza akarja állítani.

    4. Megjegyzés

    • Ha a kijelölt kiszolgáló nem az a kiszolgáló, amelyről eredetileg a biztonsági másolat készült, akkor be kell jelölnie a Minden meglévő adat törlése jelölőnégyzetet.
  4. Adja meg a többi szükséges beállítást, majd kattintson az OK gombra.

Fontos

  • A Biztonsági mentés segédprogrammal FAT vagy NTFS köteten tárolt adatok biztonsági mentése vagy visszaállítása végezhető el. Windows 2000 operációs rendszerben használt NTFS-kötetről készített biztonsági másolat esetén azonban javasolt a helyreállítást Windows 2000 rendszerben használt NTFS-kötetre elvégezni, mert egyébként az adatok mellett bizonyos fájl- és mappafunkciók is elveszhetnek. Például a Windows 2000 rendszerben használt NTFS-kötet adatairól készült biztonsági másolat Windows NT 4.0 FAT-kötetben való visszaállításakor az engedélyek és a titkosító fájlrendszer beállításai, a lemezkvóta-adatok, a csatlakoztatott meghajtók és a Távtároló segédprogram adatai elvesznek.

Megjegyzések

  • Csak a rendszergazdák vagy biztonságimásolat-felelősök állíthatják vissza a fájlokat és a mappákat. az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagról történő visszaállítás esetén a visszaállítási művelet végrehajtása előtt frissíteni kell a lemezen tárolt katalógust. A katalógus frissítésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A fentiekben bemutatott eljárás és a hozzáfűzött megjegyzések a Microsoft Exchange 5.5-ös, vagy korábbi verzióira érvényesek.
  • A Microsoft Exchange Server adatainak visszaállításakor a rendszer leállítja az Information Store és a Directory szolgáltatást. A visszaállítás befejezése után a szolgáltatások elindításához kattintson az Eszközök menü Microsoft Exchange parancsára, a Szolgáltatás indítása gombra, válassza a Directory vagy Information Store elemet, majd kattintson az OK gombra.


A rendszerállapot-adatok visszaállítása

  2. Kattintson a Visszaállítás fülre, majd a Jelölje be az összes visszaállítandó meghajtót, mappát és fájlt: listában jelölje be a Rendszer állapota elem melletti jelölőnégyzetet. E beállítás hatására a rendszer a többi kiválasztott adattal együtt visszaállítja a rendszerállapot-adatokat is.

Vigyázat

  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok visszaállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági mentésben szereplő adatokkal. A rendszerállapot-adatok másik mappába történő visszaállításakor a rendszer csak a rendszerleírófájlokat, a SYSVOL könyvtárfájlokat, a fürtadatbázis-leíró fájlokat és a rendszerindító fájlokat állítja vissza a másik mappába. Másik mappába történő visszaállításkor a rendszer nem állítja vissza az Active Directory címtárszolgáltatás-adatbázist, a Bizonyítványszolgáltatások adatbázist és a COM+ osztályregisztrációs adatbázist.

Megjegyzések

  • Csak a rendszergazdák vagy biztonságimásolat-felelősök állíthatják vissza a fájlokat és a mappákat. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Szalagról történő visszaállítás esetén a visszaállítási művelet végrehajtása előtt frissíteni kell a lemezen tárolt katalógust. A katalógus frissítésével kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az Eszközök menü Visszaállító varázsló parancsával elindítható Visszaállító varázslóval is visszaállíthatók a rendszerállapot-adatok.
  • Tartományvezérlő rendszerállapot-adatainak visszaállításakor meg kell adni, hogy mérvadó visszaállítást vagy nem mérvadó visszaállítást akar végrehajtani. A nem mérvadó visszaállítás a tartományvezérlő rendszerállapot-adatainak alapértelmezett visszaállítási módja. Ebben a módban a rendszerállapot-adatok más tartományvezérlővel szinkronizált összetevőit (például az Active Directory címtárszolgáltatást vagy a fájlreplikációs szolgáltatást (így a SYSVOL könyvtárat)) az adatok visszaállítása után a rendszer a replikálás révén naprakésszé frissíti. Ha például az utolsó biztonsági másolat egy héttel korábban készült, és a rendszerállapot-adatokat az alapértelmezett módon (nem mérvadó) állítja vissza, akkor a biztonsági mentést követő módosításokat a rendszer replikálni fogja a többi tartományvezérlőről.

    Bizonyos esetekben nem szükséges az utolsó biztonsági mentést követő módosítások replikálása. Azaz lehetnek olyan kiszolgálók, amelyeknek a biztonsági másolatban szereplő állapottal pontosan egyező állapotban kell lenniük. Ez az állapot mérvadó visszaállítással érhető el.

    Ha például az Active Directory címtárszolgáltatásból véletlenül törölt felhasználókat, csoportokat vagy szervezeti egységeket, vissza akarja állítani és többszörözni akarja a törölt objektumokat, akkor mérvadó visszaállítást kell végrehajtania. Ehhez az adatok visszaállítását követően, de a tartományvezérlő újraindítását megelőzően az Ntdsutil segédprogramot kell futtatni. A segédprogram lehetővé teszi az objektumok központiként való megjelölését, ami garantálja, hogy minden replikált vagy továbbított adatot a rendszer megfelelően replikáljon vagy továbbítson a szervezeten belül. Az Ntdsutil parancssori segédprogram a parancssorból futtatható. Az Ntdsutil segédprogram súgója az ntdsutil /? parancs beírásával a parancssorban is használható.

  • Tartományvezérlőn a rendszerállapot-adatok csak egy speciális csökkentett módban, az ún. Címtárszolgáltatások helyreállító módban állíthatók vissza. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory címtárszolgáltatás adatbázisának visszaállítását. A számítógép csökkentett módban való elindításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.


Mérvadó visszaállítás

A Biztonsági mentés segédprogram az olyan elosztott szolgáltatásokat, mint például az Active Directory címtárszolgáltatást az ún. rendszerállapot-adatok elnevezésű gyűjteményben tárolja. A tartományvezérlő rendszerállapot-adatainak biztonsági mentésekor a rendszer biztonsági másolatot készít az Active Directory kiszolgálón tárolt összes adatáról (más olyan rendszerösszetevőkkel együtt, mint például a SYSVOL könyvtár és a rendszerleíró adatbázis). Az adott kiszolgálón az elosztott szolgáltatások visszaállításához vissza kell állítani a rendszerállapot-adatokat. Ha azonban a szervezeten belül egynél több tartományvezérlő működik, és az Active Directory adatai replikálva vannak a többi tartományvezérlő bármelyikére, akkor ún. mérvadó visszaállítást kell végrehajtani annak érdekében, hogy a visszaállított adatok replikálását a rendszer biztosan végrehajtsa az összes többi kiszolgálón.

Normál visszaállítás végrehajtása során a Biztonsági mentés segédprogram nem mérvadó visszaállítás módban működik. Azaz a visszaállított adatok (így az Active Directory objektumok) eredeti frissítési sorozatszámukat kapják meg. Az Active Directory replikálórendszer e szám alapján érzékeli és továbbítja az Active Directory változásait a szervezeten belüli kiszolgálók között. Ennek következtében a nem mérvadó visszaállítással visszaállított adatok régi adatként jelennek meg az Active Directory replikálórendszerben, és ezeket az adatokat a rendszer soha nem replikálja más kiszolgálókra. E helyett az Active Directory replikálórendszer a visszaállított adatokat frissíti a többi kiszolgálón tárolt újabb adatokkal. A mérvadó visszaállítás oldja meg ezt a problémát.

Az Active Directory adatainak mérvadó visszaállításához a rendszerállapot-adatok visszaállítása és a kiszolgáló újraindítása után az Ntdsutil segédprogramot kell futtatni. Az Ntdsutil segédprogram lehetővé teszi az Active Directory objektumok megjelölését a mérvadó visszaállításhoz. Az objektum mérvadó visszaállításhoz való megjelölése esetén a rendszer úgy frissíti az objektum frissítési sorozatszámát, hogy nagyobb legyen az Active Directory replikálórendszerben tárolt bármilyen más frissítési sorozatszámnál. Ez garantálja, hogy minden visszaállított replikált vagy továbbított adatot a rendszer megfelelően replikáljon vagy továbbítson a szervezeten belül.

Például ha az Active Directory címtárszolgáltatásban tárolt objektum véletlen törlését vagy módosítását a rendszer replikálta vagy továbbította más kiszolgálókhoz, akkor mérvadó visszaállításon keresztül kell az objektumot visszaállítani ahhoz, hogy a rendszer a többi kiszolgálóra replikálja vagy továbbítsa az objektumot. Ha nem mérvadó visszaállításon keresztül állítja vissza az objektumot, a rendszer soha nem replikálja vagy továbbítja majd más kiszolgálókra, mert régebbinek tűnik majd a többi kiszolgálón jelenleg tárolt objektumoknál. Ha az Ntdsutil segédprogrammal megjelöli az objektumot a mérvadó visszaállításhoz, akkor az garantálja, hogy a rendszer a visszaállítani kívánt adatokat replikálja vagy továbbítsa a szervezeten belül. Másrészről ha a rendszerlemez meghibásodik, vagy az Active Directory adatbázis megsérül, akkor az adatok a Ntdsutil segédprogram használata nélkül (nem mérvadó visszaállítással) egyszerűen visszaállíthatók.

Az Ntdsutil parancssori segédprogram a parancssorból futtatható. Az Ntdsutil segédprogram súgója az ntdsutil /? parancs beírásával a parancssorban is használható.

Vigyázat!

  • Ha a rendszerállapot-adatok visszaállításakor nem ad meg egy új helyet az adatok helyreállításához, akkor a rendszer törli a számítógépen jelenleg tárolt rendszerállapot-adatokat, és lecseréli a biztonsági másolatban szereplő rendszerállapot-adatokkal.

Megjegyzések

  • A fájlokról és mappákról csak a rendszergazdák vagy biztonságimásolat-felelősök készíthetnek biztonsági másolatot. Az engedélyekkel vagy a felhasználói engedélyekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Tartományvezérlőn a rendszerállapot-adatok csak Címtárszolgáltatások helyreállító módban állíthatók helyre. Ez lehetővé teszi a SYSVOL könyvtár és az Active Directory visszaállítását. A számítógép csökkentett módban való elindításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A rendszerállapot-adatok csak a helyi számítógépen állíthatók vissza. A rendszerállapot-adatok távoli számítógépen nem állíthatók vissza.


A biztonsági mentés beállításainak megadása

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. Az Általános lapon állítsa be a kívánt beállításokat.

Megjegyzések

  • A Kiválasztási információk számítása biztonsági másolat készítése és visszaállítási műveletek előtt jelölőnégyzet bejelölésekor a biztonsági mentés vagy visszaállítás során a rendszer megbecsüli a biztonsági mentésben vagy a visszaállításban szereplő fájlok számát és méretét. Ezeket az adatokat a rendszer a biztonsági mentés vagy visszaállítás megkezdése előtt kiszámítja, és megjeleníti.
  • A katalógusok használata a visszaállítási katalógusok készítésének felgyorsításához jelölőnégyzet bejelölése azt jelzi, hogy a visszaállítási műveletekhez adathordozón tárolt katalógussal kívánja létrehozni a lemezen tárolt katalógust. Így hozható létre a leggyorsabban a lemezen tárolt katalógus. Ne jelölje be ezt a jelölőnégyzetet, ha több szalagról kívánja visszaállítani az adatokat, és hiányzik az adathordozón tárolt katalógust tároló szalag, vagy sérült adathordozóról kíván adatokat visszaállítani. A Biztonsági mentés segédprogram átvizsgálja a teljes biztonságimásolat-készletet (illetve az abból elérhető részt), és létrehozza az adathordozón tárolt katalógust. Ez több óráig is eltarthat, ha nagy a biztonságimásolat-készlet.
  • Az Adatok ellenőrzése a biztonsági másolat befejezése után jelölőnégyzet bejelölése esetén a rendszer ellenőrzi, hogy a biztonsági márolatban szereplő és a merevlemezen levő eredeti adatok megegyeznek-e. Ha nem, akkor hibás lehet a biztonsági mentéshez használt adathordozó vagy fájl. Ilyenkor másik adathordozót kell használni, vagy másik fájlt kell kijelölni, majd újból futtatni a biztonsági mentést.
  • A Biztonsági másolat készítése a csatlakoztatott meghajtók tartalmáról jelölőnégyzet bejelölése esetén a rendszer biztonsági másolatot készít a csatlakoztatott meghajtón tárolt adatokról. A jelölőnégyzet bejelölése esetén egy csatlakoztatott meghajtó biztonsági mentésekor a rendszer biztonsági másolatot készít a csatlakoztatott meghajtón tárolt adatokról. Ha nem jelöli be a jelölőnégyzetet és biztonsági mentést készít a csatlakoztatott meghajtóról, akkor a rendszer csak a csatlakoztatott meghajtó elérési útvonalát szerepelteti a biztonsági másolatban.
  • A Figyelmeztetési üzenet megjelenítése a biztonsági másolat indításakor, ha a cserélhető tároló vezérlője nem fut jelölőnégyzet bejelölése esetén a Biztonsági mentés segédprogram elindításakor megjelenik egy párbeszédpanel, ha nem fut a Cserélhető tároló beépülő modul. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha az adatokról elsőként szalagra, vagy a Cserélhető tároló beépülő modullal kezelhető adathordozóra készít biztonsági másolatot, akkor jelölje be ezt a jelölőnégyzetet.
  • A Figyelmeztetési üzenet megjelenítése a biztonsági másolat indításakor, ha van szabad kompatibilis import-adathordozó jelölőnégyzet bejelölése esetén a Biztonsági mentés segédporgram elindításakor megjelenik egy párbeszédpanel, ha az import adathordozó-készletben egy új adathordozó áll rendelkezésre. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha az adatokról elsőként szalagra, vagy a Cserélhető tároló beépülő modullal kezelhető adathordozóra készít biztonsági másolatot, akkor jelölje be ezt a jelölőnégyzetet. A Cserélhető tároló beépülő modullal és az adathordozó-készletekkel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Figyelmeztetési üzenet megjelenítése új adathordozó behelyezésekor a cserélhető tároló vezérlőjébe jelölőnégyzet bejelölése esetén megjelenik egy párbeszédpanel, ha a Cserélhető tároló beépülő modul új adathordozót talál. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha az adatokról elsőként szalagra, vagy a Cserélhető tároló beépülő modullal kezelhető adathordozóra készít biztonsági másolatot, akkor jelölje be ezt a jelölőnégyzetet.
  • Az új import-adathordozók mozgatása a biztonsági másolat sorba minden esetben jelölőnégyzet bejelölése esetén a rendszer a Cserélhető tároló beépülő modul által talált új adathordozót automatikusan áthelyezi a biztonsági másolat adathordozó-készletbe. Ha az adatokról elsőként fájlba készít biztonsági másolatot, majd a fájlt hajlékonylemezre, merevlemezre vagy bármilyen cserélhető lemezre menti, akkor nem kell bejelölni ezt a jelölőnégyzetet. Ha a Cserélhető tároló beépülő modullal kezeli az adathordozókat, és csak a Biztonsági mentés segédprogram számára kívánja elérhetővé tenni az összes új adathordozót, akkor jelölje be ezt a jelölőnégyzetet.


A biztonsági másolat típusának beállítása

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. A Biztonsági másolat típusa lapon a Biztonsági másolat alapértelmezett típusa listában válassza ki, milyen típusú biztonsági másolatot akar készíteni.

Megjegyzések

  • Ötféle biztonsági másolat készíthető: másolás, napi, különbségi, növekményes és normál. A biztonsági másolat típusaival kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Fájltípusok kizárása a biztonsági mentésből

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. A Kivételfájlok lapon hajtsa végre az alábbi műveletek egyikét:
    • A Kivétel az összes felhasználó számára listában kattintson az Új hozzáadás gombra, ha az összes felhasználó tulajdonában levő fájlokat akar kizárni a biztonsági mentésből.
    • A Kivétel a következő felhasználó számára listában kattintson az Új hozzáadása gombra, ha csak az ÖN tulajdonában levő fájlokat akar kizárni a biztonsági mentésből.
  4. A Kivételfájlok hozzáadása párbeszédpanelen hajtsa végre az alábbi műveletek egyikét:
    • Ha egy regisztrált fájltípust akar kizárni, akkor a Regisztrált fájltípusok listában kattintson az adott fájltípusra.
    • Ha egy egyedi fájltípust akar kizárni, akkor az Egyéni fájlmaszk beviteli mezőbe írjon be egy pontot, majd az egy-, két- vagy hárombetűs fájlkiterjesztést.
  5. Ha csak egy adott mappára vagy merevlemez-meghajtóra akarja korlátozni a fájltípus kizárását, akkor az Alkalmazás erre az elérési útra beviteli mezőbe írja be az elérési útvonalat, majd kattintson az OK gombra.

Megjegyzések

  • Ha a fájlok kizárását egy adott eléréséi útra (mappára) korlátozza, akkor a korlátozás az elérési útvonalon található összes almappára is érvényes lesz, ha nem törli Az alkönyvtárakra is jelölőnégyzetet.
  • A biztonságimásolat-készletből fájl kizárásának módja módosítható. Ehhez a Kivétel az összes felhasználó számára vagy a Kivétel a következő felhasználó számára listában kattintson a fájlra, majd a Szerkesztés gombra. Megjelenik a Kivételfájlok hozzáadása párbeszédpanel.


A biztonsági mentés speciális beállításainak megadása

  2. Kattintson a Biztonsági mentés fülre, majd válassza ki azokat a fájlokat és mappákat, amelyekről biztonsági mentést akar készíteni.
  3. Kattintson a Biztonsági másolat indítása gombra.
  4. A Biztonságimásolat-készítési feladat információi párbeszédpanelen kattintson a Speciális gombra.
  5. Adja meg a biztonsági mentés speciális beállításait, majd kattintson az OK gombra. Az egyes beállítások leírása a Megjegyzések részen található.

Megjegyzések

  • A Biztonsági másolat a távtárolóban lévő adatokról elem kiválasztásakor a rendszer biztonsági mentést készít a Távtároló segédprogram által használt adatokról. E beállítás kiválasztásakor a Távtároló segédprogram helyfoglaló fájlokról biztonsági mentést készít a rendszer. Ha nem választja ezt a beállítás, akkor nem készül biztonsági mentést a Távtároló segédprogram helyfoglaló fájlokról. A Távtároló segédprogram adatai csak Windows 2000 rendszeren használt NTFS-kötetre állíthatók helyre.
  • Az Adatok ellenőrzése a biztonsági másolat készítése után beállítás választása esetén a rendszer ellenőrzi, hogy a biztonsági mentésben szereplő adatok teljesen megegyeznek-e az eredeti adatokkal. Ez jelentősen megnövelheti a biztonsági mentés végrehajtásához szükséges időt.
  • Az Adatok tömörítése lemeztakarékosság céljából, ha lehetséges beállítás kiválasztása esetén a rendszer a biztonsági mentés közben tömöríti az adatokat, így több adat menthető a szalagra. Általában csak a szalagos meghajtók képesek a tömörítésre. Ha ez a beállítás nem használható, akkor nem kapcsolódik szalagos meghajtó a számítógéphez, vagy a szalagos meghajtó nem képes adattömörítésre.
  • Az Automatikus biztonsági másolat a rendszer védett fájljairól a rendszerállapottal együtt beállítás választása esetén a rendszer a rendszerállapot-adatokhoz tartozó rendszerindító fájlokon kívül biztonsági mentést készít a rendszergyökér könyvtárban található rendszerfájlokról is. Ez a beállítás jelentősen megnöveli a biztonsági másolatok méretét. Ha például Windows 2000 Professional operációs rendszeren választja ezt a beállítást, akkor ez több, mint 200 megabájttal megnöveli a biztonsági másolat méretét.
  • A Biztonsági mentés típusa részen a biztonsági mentés típusának kiválasztásával adható meg, hogyan készítsen a rendszer biztonsági mentést az adatokról. A biztonsági mentés típusai: másolás, napi, különbségi, növekményes és normál.


A visszaállítás beállításainak megadása

  2. Kattintson az Eszközök menü Beállítások parancsára.
  3. A Visszaállítás lapon hajtsa végre az alábbi műveletek egyikét:
    • Válassza a Ne cserélje le a számítógépen lévő fájlt választókapcsolót, ha nem akarja, hogy a visszaállítás során a rendszer átmásolja a lemezen már meglevő fájlokat.
    • Válassza a Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsolót, ha a visszaállítás során a lemezen levő régebbi fájlokat le akarja cserélni a biztonsági másolatban levő újabb fájlokkal.
    • Válassza a Mindig cserélje le a számítógépen lévő fájlt választókapcsolót, ha a visszaállítás során a biztonsági másolatban levő fájlokkal minden esetben felül akarja írni a lemezen levő fájlokat.

Fontos

  • A Csak akkor cserélje le, ha a számítógépen lévő fájl régebbi választókapcsoló kiválasztása esetén előfordulhat, hogy a rendszer módosítja a lemezen levő néhány vagy összes fájlt.
  • A Mindig cserélje le a számítógépen lévő fájlt választókapcsoló beállítása esetén előfordulhat adatvesztés, ha a jelenleg módosítás alatt levő fájl szerepel a biztonsági másolatban.

Megjegyzés


Adja meg a helyreállítási speciális beállításait

A biztonsági mentés speciális beállításainak megadása

  2. Kattintson a Helyreállítás fülre, majd válassza ki a helyreállítani kívánt fájlokat és mappákat.
  3. Kattintson a Visszaállítás indítása gombra.
  4. A Visszaállítás megerősítése párbeszédpanelen kattintson a Speciális gombra.
  5. Adja meg a visszaállítás speciális beállításait, majd kattintson az OK gombra. Az egyes beállítások leírása a Megjegyzések részen található.

Megjegyzések

  • A Biztonsági beállítások visszaállítása beállítás választása esetén a rendszer visszaállítja az összes fájl és mappa biztonsági beállításait. A biztonsági beállítások lehetnek: engedélyek, naplóbejegyzések és tulajdonjog. Ez a beállítás csak Windows 2000 rendszerben használt NTFS-kötetről készített biztonsági mentés Windows 2000 rendszerben használt NTFS-kötetre történő visszaállításakor használható.
  • A cserélhető tároló adatbázisának visszaállítása beállítás választása esetén a rendszer visszaállítja a Cserélhető tároló segédprogram Rendszergyökér\System32\Ntmsdata mappában tárolt adatbázisát. Ha nem a Cserélhető tároló segédprogrammal menedzseli a tárolóeszközöket, akkor nem szükséges kiválasztani ezt a beállítást. A visszaállítás törli a Cserélhető tároló segédprogram meglevő adatbázisát.
  • A Csatlakozási pontok visszaállítása, az alattuk lévő fájlok és mappák visszaállítása az eredeti helyükre beállítás választása esetén a rendszer a merevlemezen visszaállítja a csatlakozási pontokat, és a csatlakozási pontok által hivatkozott adatokat. Ha nem jelöli be ezt a jelölőnégyzetet, akkor a rendszer visszaállítja a csatlakozási pontokat, de a csatlakozási pontok által hivatkozott adatok nem lesznek elérhetőek. Csatlakoztatott meghajtón tárolt adatok visszaállításához is be kell jelölni ezt a jelölőnégyzetet. Ha nem jelöli be ezt a jelölőnégyzetet, akkor a rendszer csak a csatlakoztatott meghajtót tartalmazó mappát állítja vissza.
  • A Replikált adatkészletek visszaállítása esetén az adatok megjelölése elsődleges adatként az összes másolatnál jelölőnégyzet bejelölése biztosítja, hogy a fájlreplikációs szolgáltatás visszaállított adatait a rendszer replikálja a többi kiszolgálóra. A fájlreplikációs szolgáltatás adatainak visszaállításához be kell jelölni ezt a jelölőnégyzetet. Ha nem jelöli be ezt a jelölőnégyzetet, akkor előfordulhat, hogy a fájlreplikációs szolgáltatás visszaállított adatait a rendszer nem replikálja a többi kiszolgálóra, mert a visszaállított adatok régebbinek tűnnek majd, mint a kiszolgálón tárolt jelenlegi adatok. Ennek következtében a többi kiszolgáló felülírja a visszaállított adatokat, így megakadályozzák a fájlreplikációs szolgáltatás adatainak visszaállítását.
  • A meglévő kötetekhez tartozó csatlakozási pontok megtartása jelölőnégyzet bejelölése esetén a visszaállítás során a rendszer nem írja felül a kötet csatlakozási pontjait azon a partíción vagy köteten, amelyre az adatok visszaállítását végzi. Ez a beállítás különösen hasznos, ha teljes meghajtó vagy partíció adatait állítja vissza. Például ha a meghibásodott meghajtót kiváltó meghajtóra végzi az adatok visszaállítását, partícionálta és formázta a meghajtót, valamint visszaállította a csatlakozási pontokat, akkor e beállítás választása esetén a rendszer nem kísérli meg újból a csatlakozási pontok visszaállítását. Ha az adatokat most formázott partícióra vagy meghajtóra kívánja visszaállítani, és vissza kívánja állítani a kötet régi csatlakozási pontjait, akkor ne jelölje be ezt a jelölőnégyzetet.


Szalag formázása

  2. A Visszaállítás lapon a jobb oldali egérgombbal kattintson a formázni kívánt szalagra.
  3. Kattintson a Formázás gombra.

Megjegyzések

  • Ez a művelet csak DC-2000 típusú szalagos meghajtóra vonatkozik, amely esetén a szalagot használat előtt meg kell formázni.


Szalag visszatekerése

  2. A Visszaállítás lapon kattintson a visszatekerni kívánt szalagra.
  3. Kattintson az Eszközök menüre, a Médiaeszközök pontra, majd a Visszatekerés parancsra.

Megjegyzések

  • A Visszatekerés parancs úgy is elérhető, ha a Visszaállítás lapon a jobb oldali egérgombbal a szalagra kattint.


Szalag törlése

  2. A Visszaállítás lapon kattintson a törölni kívánt szalagra.
  3. Kattintson az Eszközök menüre, mutasson a Médiaeszközök pontra, majd kattintson a Törlés parancsra.

Megjegyzések

  • A szalag csak akkor törölhető, ha a szalagos meghajtóban vagy a kazettacserélő betöltőnyílásában van.
  • Törlés után a szalag a biztonsági másolat adathordozó-készletből az üres adathordozó-készletbe kerül.
  • A szalag a Cserélhető tároló segédprogrammal is törölhető.
  • A Törlés parancs úgy is elérhető, ha a Visszaállítás lapon a jobb oldali egérgombbal a szalagra kattint.


Katalógus frissítése

  2. A Visszaállítás lapon a jobb oldali egérgombbal kattintson a kategorizálni kívánt biztonságimásolat-készletre.
  3. Kattintson a Katalógus parancsra.

Megjegyzések

  • Ezzel az eljárással lemezen tárolt katalógus hozható létre. Ezzel az eljárással nem hozható létre az adathordozón tárolt katalógus.
  • Szalagra mentett biztonságimásolat-készlethez tartozó katalógus létrehozásához az eljárás végrehajtása előbb az alábbiak műveletek egyikét el kell végezni:
    • Ha a biztonságimásolat-készlet tartalmazza az összes szalagot, a szalagok nem hibásak és nem sérültek, akkor kattintson az Eszközök menü Beállítások parancsára, az Általános fülre, majd ellenőrizze, hogy A katalógusok használata a visszaállítási katalógusok készítésének felgyorsításához jelölőnégyzet be van-e jelölve. Ez meggyorsítja a kategorizálás folyamatát.
    • Ha a biztonságimásolat-készletből hiányzik szalag, vagy valamelyik szalagok hibás vagy sérült, akkor kattintson az Eszközök menü Beállítások parancsára, az Általános fülre, majd ellenőrizze, hogy A katalógusok használata a visszaállítási katalógusok készítésének felgyorsításához jelölőnégyzet törölve van-e. Ez garantálja, hogy a katalógus teljes és pontos legyen, viszont hosszabb ideig tarthat a katalógus összeállítása.


Katalógus törlése

  2. A Visszaállítás lapon a jobb oldali egérgombbal kattintson a törölni kívánt biztonságimásolat-készletet tartalmazó katalógusra.
  3. Kattintson a Katalógus törlése parancsra, ha a biztonságimásolat-készletet fájlban tárolja, vagy a Törlés a rendszerről parancsra, ha a biztonságimásolat-készletet szalagon tárolja.

Megjegyzések

  • Ez a művelet csak akkor használható, ha sérült vagy elveszett szalagot vagy fájlt akar törölni a lemezen tárolt katalógusból.
  • Ha egy szalaghoz tartozó katalógust akar törölni, akkor ez a művelet csak akkor működik, ha a szalag nincs a szalagos meghajtóban vagy a kazettabetöltő-nyílásban.
  • A Katalógus törlése gombra kattintással törölhető a lemezen tárolt, a kijelölt biztonságimásolat-készlethez tartozó katalógus. A művelet nem törli a biztonságimásolat-fájlt.
  • A Törlés a rendszerről gombra kattintással törölhető a lemezen tárolt, a kijelölt biztonságimásolat-készlethez tartozó katalógus, és ez a művelet törli a szalagot a Cserélhető tároló adatbázisából. A művelet nem törli az adathordozón tárolt katalógust a szalagról.
  • Egy fájlhoz vagy szalaghoz tartozó katalógus visszaállítható, ha a jobb oldali egérgombbal a kategorizálni kívánt fájlra vagy szalagra, majd a Katalógusfájl vagy a Katalógus parancsra kattint. A katalógus létrehozásával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Engedélyek és felhasználói engedélyek

A fájlok és mappák biztonsági mentéséhez és visszaállításához bizonyos engedélyekkel vagy felhasználói engedélyekkel kell rendelkezni. A helyi csoport rendszergazdája vagy biztonságimásolat-felelőse biztonsági másolatot készíthet a csoportot tartalmazó helyi számítógépen levő összes fájlról és mappáról. Ehhez hasonlóan a tartományvezérlő rendszergazdái és biztonságimásolat-felelősei (a rendszerállapot-adatok kivételével, tanulmányozza a lenti megjegyzést) biztonsági másolatot készíthetnek a tartományban vagy a tartománnyal kétirányú megbízhatósági kapcsolatban levő tartományok számítógépén tárolt minden fájlról és mappáról. Ha nem rendszergazda vagy biztonságimásolat-felelős, és biztonsági másolatot akar készíteni a fájlokról, akkor tulajdonosi joggal, vagy az alábbiak közül egy vagy több engedéllyel kell rendelkezni azokhoz a fájlokhoz és mappákhoz, amelyekről biztonsági másolatot akar készíteni. Olvasás, olvasás és végrehajtás, módosítás vagy teljes hozzáférés.

Ellenőrizni kell azt is, hogy a lemezkvóta-beállítások nem korlátozhatják a merevlemez elérését, mivel az meggátolhatná az adatok biztonsági mentését. A lemezkvóta-korlátozás ellenőrzéséhez a jobb oldali egérgombbal kattintson a menteni kívánt adatokat tartalmazó merevlemezre, kattintson a Tulajdonságok parancsra, majd kattintson a Kvóta fülre.

A biztonsági másolathoz való hozzáférés korlátozható a Biztonságimásolat-készítési feladat információi párbeszédpanel Csak a tulajdonos és a rendszergazda fér hozzá a biztonsági másolathoz elemének kiválasztásával. E beállítás kiválasztása esetén csak a rendszergazda és a biztonságimásolat-fájlt készítő személy állíthatja vissza a fájlokat és a mappákat.

Megjegyzés

  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól még a távoli számítógép rendszergazdája vagy biztonságimásolat-felelőse sem készíthet biztonsági másolatot távolról.


Felhasználó hozzáadása a Biztonságimásolat-felelősök csoporthoz

  1. Nyissa meg a Számítógépkezelés segédprogramot.
  2. A konzolfában kattintson a Helyi felhasználók és csoportok elemre.
  3. A részletek ablaktáblában kattintson duplán a Csoportok mappára, majd a Biztonságimásolat-felelősök elemre.
  4. A Biztonságimásolat-felelősök párbeszédpanelen kattintson a Hozzáadás gombra.
  5. A Felhasználók vagy csoportok párbeszédpanelen a Név mezőhöz közel írja be a biztonságimásolat-felelősként kijelölni kívánt személyt tartalmazó tartomány nevét, és a személy felhasználónevét. Előbb a tartomány, majd fordított ferde vonallal elválasztva a felhasználó nevét írja be. Például: \\Budapest\Kovacs.
  6. Kattintson a Hozzáadás, majd az OK gombra.

Fontos

  • Tartományvezérlőn a Kezelők csoporthoz csak az Active Directory Felhasználók és számítógépek segédprogrammal adhatók felhasználók. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • A Biztonságimásolat-felelősök csoporthoz csak a Rendszergazdák csoport tagja adhatnak felhasználókat.
  • A Számítógépkezelés segédprogram megnyitásához kattintson a Start menüre, majd a Vezérlőpult parancsra. A Vezérlőpult ablakban kattintson duplán a Felügyeleti eszközök, majd a Számítógépkezelés ikonra.


Javítás – áttekintés

A Windows 2000 számos olyan szolgáltatást tartalmaz, amellyel helyreállítható az indulásra vagy a Windows 2000 betöltésére képtelen rendszer. Ezek a szolgáltatások hasznosak a rendszerfájlok meghibásodásakor, véletlenszerű törlésekor vagy egy a rendszer meghibásodását eredményező szoftver vagy eszközillesztő telepítésekor.

Csökkentett mód

A csökkentett mód lehetővé teszi a rendszer indítását minimális számú eszközillesztő betöltésével és szolgáltatás elindításával. Például ha egy újonnan telepített eszközillesztő vagy program következtében a számítógép nem indul el, akkor a számítógép elindítható csökkentett módban, majd eltávolítható a rendszerről a hibát okozó szoftver vagy illesztőprogram. A csökkentett mód nem működik minden esetben, például ha a rendszerfájlok sérülnek meg vagy hiányoznak, illetve ha a merevlemez sérült vagy hibásodott meg. A csökkentett módról részletes tudnivalók A csökkentett mód indítási beállításai című részben olvashatók.

Windows 2000 helyreállító konzol

A Helyreállítási konzol szolgáltatás minimális számú parancssori parancs kiadására használható parancssori felületet biztosít a rendszer helyreállításához. Például a Helyreállítási konzol segítségével engedélyezhetők vagy letilthatók a szolgáltatások, helyreállítható a megsérült fő rendszertöltő rekord (master boot record) vagy egy hajlékonylemezről vagy CD-ROM-ról átmásolhatók a rendszerfájlok. Ez a – kizárólag tapasztalt felhasználók és rendszergazdák által használható – szolgáltatás biztosítja a legteljesebb körű helyreállítást.

Helyreállítás a Helyreállító lemez segítségével

A Biztonsági helyreállító lemez segítséget nyújt a rendszerfájlokkal, az indítási környezettel (kettős betöltésű, vagy többszörös betöltésű rendszer esetén), és az indítóköteten található partíciós betöltőszektorral kapcsolatos hibák helyreállításában. A rendszer csak a Biztonsági helyreállító lemez létrehozása után állítható helyre a Helyreállító lemez funkcióval. Ez a Biztonsági mentés segédprogrammal végezhető el. Ha nem hozott létre Biztonsági helyreállító lemezt és ennek ellenére megpróbálja használni a Helyreállító lemez funkciót, akkor a rendszeren végzett módosítások (például a szervizcsomag frissítések) elveszhetnek és szükséges lehet az újratelepítésük.

A Windows 2000 egy sérült Windows 2000 rendszeren is újratelepíthető. Ez időigényes művelet lehet, de hasznos, ha a helyreállító folyamat nem oldja meg a problémát. A rendszer újratelepítésekor elveszhetnek a rendszer módosításai (például a szervizcsomag frissítések) és újra kell telepíteni ezeket a frissítéseket.


Helyreállító lemez létrehozása

  2. Kattintson az Eszközök menü Biztonsági helyreállító lemez készítése parancsára.
  3. Kövesse a képernyőn megjelenő utasításokat.

Fontos

  • A Helyreállító lemez elkészítéséhez egy üres, 1,44 MB kapacitású hajlékonylemez szükséges.
  • A visszaállítási folyamat a rendszergyökér\repair mappában tárolt adatokra épül. Ezt a mappát nem szabad módosítani vagy törölni.

Megjegyzések

  • A Biztonsági másolat készítése a rendszerleíró adatbázisról is, a helyreállítási könyvtárba jelölőnégyzet kiválasztásával az aktuális rendszerleíróadatbázis-fájlok elmenthetők a rendszergyökér/repair mappába. Ez hasznos a rendszer helyreállításához a merevlemez meghibásodása esetén.
  • További tudnivalók is elérhetők a helyreállítási folyamattal kapcsolatban. A Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás “Hogyan?” szakaszát.


A helyreállító folyamat használata, ha a rendszer nem indul

A Windows 2000 helyreállító funkcióival javíthatók azok a hibák, amely miatt a számítógép nem indul. Ezt okozhatja a rendszerleíró-adatbázis, a rendszerfájlok, a partíciós betöltőszektor és a indítási környezet hibája. A helyreállító műveletekkel azonban nem javítható a rendszer, ha nincs a Biztonsági mentés segédprogrammal készíthető Biztonsági helyreállító lemez. Megpróbálhatja használni a helyreállító folyamatot akkor is, ha nem készített Biztonsági helyreállító lemezt, de ilyenkor előfordulhat, hogy a helyreállító folyamat nem képes a hibákat javítani.

A helyreállító folyamat általában a következő lépésekből áll:

A Windows 2000 Telepítő lemezek vagy CD segítségével indítsa el a számítógépet

A rendszer elindítható a Windows 2000 telepítőlemezek vagy a Windows 2000 CD segítségével. A számítógép azonban csak akkor indítható a CD segítségével, ha a számítógépben levő hardver és BIOS támogatja ennek a szolgáltatásnak a használatát.

Telepítés közben válassza a helyreállítás beállítást

A számítógép elindulása után elindul a Telepítő program. Telepítés közben meg kell adni, hogy folytatja-e a Windows 2000 operációs rendszer telepítését. A folytatáshoz le kell ütnie az ENTER billentyűt. Ez elindítja a telepítést, amely lehetővé teszi a rendszer helyreállítását. A folyamat közben kiválasztható, hogy a Windows 2000 egy új változatát akarja-e telepíteni vagy a jelenleg telepített Windows 2000 rendszert akarja-e helyreállítani. A sérült vagy hibás rendszer helyreállításához az R billentyűt kell megnyomnia. Ezután ki kell választania, hogy a Helyreállítási konzol vagy a helyreállító folyamat segítségével akarja-e a rendszert helyreállítani. Ha a helyreállító folyamat segítségével akarja a helyreállítást elvégezni, akkor az R billentyűt kell leütnie.

Válassza ki a helyreállítás típusát

Választható a legkönnyebben végrehajtható, felhasználói közbeavatkozást nem igénylő gyors helyreállítás vagy a felhasználó közreműködését igénylő kézi helyreállítás. A gyors helyreállítás megpróbálja helyreállítani a rendszerleíró-adatbázissal, rendszerfájlokkal, az indítóköteten található partíciós betöltőszektorral és az indítási környezettel (kettős betöltésű vagy többszörös betöltésű rendszer esetén) kapcsolatos hibákat. A kézi helyreállítás során kiválasztható, hogy a rendszerfájlokat, partíciós betöltőszektorral vagy az indítási környezettel kapcsolatos hibákat akarja helyreállítani, de nem teszi lehetővé a rendszerleíró-adatbázis hibáinak javítását. Például ha tudja, hogy a partíciós betöltőszektor és az indítási környezet sértetlen, akkor a kézi helyreállítással megpróbálhatja kizárólag a rendszerfájlokat helyreállítani.

Megjegyzések

  • A kézi helyreállítás használata kizárólag a tapasztalt felhasználók vagy a rendszergazdák számára javasolt.
  • A gyors helyreállítás a rendszeren a Telepítő legelső futtatásakor a rendszerleíró-adatbázisról készített biztonsági másolatot használja. Ennek a helyreállítási módnak a választása esetén elveszhetnek a Telepítő legelső futtatása óta kiválasztott beállítások.
  • Ha az egyes rendszerleíróadatbázis-fájlokat kézzel akarja helyreállítani vagy ki akarja cserélni a teljes rendszerleíró-adatbázist, akkor használja a Helyreállítási konzolt. Azonban ez csak a tapasztalt felhasználók számára javasolt.

Indítsa el a helyreállítást

A helyreállító folyamat elindításához szükséges a Biztonsági mentés segédprogrammal készített 1,44 MB-os Biztonsági helyreállító lemez és az eredeti Windows 2000 telepítő CD. A helyreállító folyamat akkor is megkísérelheti megkeresni a telepített Windows 2000 rendszert és elkezdeni a helyreállítást, ha nincs Biztonsági helyreállító lemez, de előfordulhat, hogy sikertelen lesz a folyamat.

Megjegyzés

  • Ha a helyreállító folyamat nem képes a rendszer helyreállítására, akkor használhatja még a Helyreállító konzolt vagy megpróbálhatja újratelepíteni a Windows 2000 rendszert. További tudnivalókért lásd a Kapcsolódó témaköröket.

A számítógép újraindítása

Ha a helyreállítási folyamat sikeres volt, akkor a számítógép automatikusan újraindul, és a rendszer használható.

További tudnivalók is elérhetők a helyreállítási folyamattal kapcsolatban. A Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás “Hogyan?” című szakaszát.

Fontos

  • A helyreállítási folyamat a rendszergyökér\repair mappában tárolt adatokra épül. Ezt a mappát nem szabad módosítani vagy törölni.


A Helyreállítási konzol futtatása, ha a rendszer nem indul

  1. Helyezze a (3,5 hüvelykes) Windows 2000 Professional Telepítő lemezt a lemezmeghajtóba vagy ha a CD-ROM meghajtó alkalmas a rendszer indítására, akkor helyezze a Windows 2000 Professional CD-t a CD-ROM-meghajtóba.
  2. Indítsa újra a számítógépet.
  3. Kövesse a képernyőn megjelenő útmutatást. A Telepítő lemezek használata esetén a rendszer kéri a Telepítő lemezek behelyezését a lemezmeghajtóba. A fájlok betöltése néhány percet igénybe vehet. Válassza a Windows 2000 telepítését helyreállító beállítást, majd végül indítsa el a Helyreállítási konzolt.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Helyreállítási konzolban használható parancsok listája a parancssorba a help parancs beírásával jeleníthető meg.
  • A Helyreállítási konzol telepíthető is a számítógépre, így ekkor mindig használható. A Helyreállítási konzol használatával kapcsolatos tudnivalókért lásd a Kapcsolódó témaköröket.


A Helyreállítási konzol telepítése indítási beállításként

  1. A Windows futása közben helyezze a Windows 2000 Professional CD-t a CD-ROM-meghajtóba.
  2. Kattintson a Nem gombra, amikor a rendszer a Windows 2000 frissítésének kiválasztását kéri.
  3. A parancssorban váltson a CD-ROM-meghajtóra, majd írja be az alábbiakat:

    \i386\winnt32.exe /cmdcons

  4. Kövesse a képernyőn megjelenő utasításokat.

Megjegyzések

  • A Helyreállítási konzol futtatásához újra kell indítani a számítógépet és ki kell választani a Helyreállítási konzol parancsot a használható operációs rendszerek listájából.
  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Helyreállítási konzolban használható parancsok listája a parancssorba a help parancs beírásával jeleníthető meg.
  • A Csoportházirend beépülő modulban a Helyreállítási konzol: Automatikus felügyeleti bejelentkezés attribútum megadásával biztosítható, hogy a felhasználó bejelentkezés nélkül futtathassa a Helyreállítási konzolt. Ez az attribútum a konzolon megjelenő fán a Helyi számítógép házirend/Számítógép konfigurációja/Windows beállításai/Biztonsági beállítások/Helyi házirend/Biztonsági beállítások bejegyzésnél található.
  • Ha a számítógép nem indul el, akkor a Helyreállítható konzol a Windows 2000 Professional CD-ről (ha a számítógépben a rendszer indítására alkalmas CD-ROM-meghajtó van) vagy a Telepítő lemezekről futtatható. Abban az esetben, ha a számítógép nem indul, akkor a Helyreállítási konzol futtatásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


A Helyreállítási konzol törlése

  1. Indítsa újra a számítógépet.
  2. Kattintson duplán előbb a Sajátgép ikonra, majd arra a merevlemezre, amelyre telepítette a Helyreállítási konzolt.
  3. Kattintson az Eszközök menüben a Mappa beállításai parancsra.
  4. Kattintson a Nézet fülre.
  5. Kattintson a Rejtett fájlok és mappák megjelenítése elemre, törölje a Az operációs rendszer védett fájljainak elrejtése jelölőnégyzetet, majd kattintson az OK gombra.
  6. A gyökérkönyvtárban törölje a \Cmdcons mappát.
  7. A gyökérkönyvtárban törölje a Cmldr fájlt.
  8. A gyökérkönyvtárban a jobb oldali egérgombbal kattintson a Boot.ini fájlra, majd a Tulajdonságok parancsra.
  9. Törölje az Írásvédett jelölőnégyzetet, majd kattintson az OK gombra.
  10. A Jegyzettömb segédprogramban nyissa meg a Boot.ini fájlt és törölje a Helyreállítási konzolhoz tartozó bejegyzést. A bejegyzés az alábbihoz hasonló:

    C:\cmdcons\bootsect.dat="Microsoft Windows 2000 Recovery Console" /cmdcons

  11. Mentse a fájlt és zárja be.

Figyelmeztetés

  • A Boot.ini fájl helytelen módosítása esetén előfordulhat, hogy a számítógép nem indul újra. Kizárólag a Helyreállítási konzol bejegyzését törölje.

Megjegyzések

  • A fenti műveletek befejezése után javasolt a Boot.ini fájl „írásvédett” attribútumának visszaállítása. Ezt követően ismét elrejtheti a rendszerfájlokat.


Helyreállítási konzol – áttekintés

A Windows 2000 helyreállító konzol a Windows 2000 Telepítő programból indítható parancssori konzol. A Helyreállítási konzol segítségével elindíthatók és leállíthatók a szolgáltatások, formázhatók a meghajtók, a helyi lemezről (NTFS fájlrendszerrel megformázott meghajtókról is) olvashatók és oda írhatók az adatok és számos egyéb adminisztrációs feladat végezhető el. A Helyreállítási konzol különösen hasznos, ha a rendszert a hajlékonylemezről vagy CD-ROM-ról történő másolással akarja visszaállítani, vagy ha át kell konfigurálni a számítógép megfelelő indítását akadályozó szolgáltatást. Mivel a Helyreállítási konzol meglehetősen hatékony, ezért használata kizárólag olyan tapasztalt felhasználók számára ajánlott, akik alaposan ismerik a Windows 2000 operációs rendszert. Ráadásul a Helyreállítási konzolt csak rendszergazda használhatja.

A Helyreállítási konzol kétféleképpen indítható el:

  • Ha a számítógép nem indul el, akkor a Helyreállítási konzol a Windows 2000 Telepítő lemezekről vagy a Windows 2000 Professional CD-ről futtatható (ha a számítógép indítható a CD-ROM-meghajtóról).
  • Alternatív lehetőségként a Helyreállítási konzol telepíthető a számítógépre, hogy használható legyen amikor a Windows 2000 nem indítható el. Ezt követően az operációs rendszerek listájában kiválasztható a Helyreállítási konzol kívánt beállítása.

A Helyreállítási konzol elindítását követően ki kell választani azt a meghajtót, amelyre csatlakozni akar (kettős betöltésű vagy többszörös betöltésű rendszer esetén), majd rendszergazdai jelszóval kell bejelentkezni.

A Helyreállítási konzol elindításával és használatával kapcsolatos további tudnivalókért lásd a Kapcsolódó témaköröket. Ezen kívül a Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás Útmutató szakaszát.

A Helyreállítási konzol futtatásakor a használható parancsokkal kapcsolatos tudnivalókról a parancssorba a help parancs beírásaval kérhető segítség.


A Helyreállítási konzol parancsai

Az alábbi parancsok használhatók a Windows 2000 Helyreállítási konzolban:

  • Attrib

    • Módosítja egy fájl vagy könyvtár attribútumait.

  • Batch

    • Végrehajtja a szövegfájlban megadott parancsokat.

  • ChDir (Cd)

    • Megjeleníti az aktuális könyvtár nevét vagy megváltoztatja az aktuális könyvtárat.

  • Chkdsk

    • Ellenőrzi a lemezt és erről állapotjelentést jelenít meg.

  • Cls

    • Törli a képernyőt.

  • Copy

    • Átmásol egy fájlt egy másik helyre.

  • Delete (Del)

    • Töröl egy vagy több fájlt.

  • Dir

    • Megjeleníti a könyvtárban levő fájlok és alkönyvtárak listáját.

  • Disable

    • Letilt egy rendszerszolgáltatást vagy egy eszközillesztőt.

  • Diskpart

    • Kezeli a merevlemezek partícióit.

  • Enable

    • Elindít vagy engedélyez egy rendszerszolgáltatást vagy eszközillesztőt.

  • Exit

    • Kilép a Helyreállítási konzolból és újraindítja a számítógépet.

  • Expand

    • Kibont egy fájlt egy tömörített fájlból.

  • Fixboot

    • Egy új partíciós betöltőszektort ír a rendszerpartícióra.

  • Fixmbr

    • Helyreállítja a partíciós betöltőszektor fő rendszertöltő szektorát.

  • Format

    • Megformáz egy lemezt.

  • Help

    • Megjeleníti a Helyreállítási konzolban használható parancsok listáját.

  • Listsvc

    • Megjeleníti a számítógépen használható szolgáltatások és eszközillesztők listáját.

  • Logon

    • Bejelentkezés a Windows 2000 rendszerbe.

  • Map

    • Megjeleníti a meghajtók betűjelének hozzárendeléseit.

  • Mkdir (Md)

    • Létrehoz egy könyvtárat.

  • More

    • Megjelenít egy szövegfájlt.

  • Rename (Ren)

    • Átnevez egy fájlt.

  • Rmdir (Rd)

    • Töröl egy könyvtárat.

  • Set

    • Megjeleníti és beállítja a környezeti változókat.

  • Systemroot

    • A jelenleg használt rendszer gyökérkönyvtáraként állítja be az aktuális könyvtárat.

  • Type

    • Megjelenít egy szövegfájlt.

A Helyreállítási konzol elindításával és használatával kapcsolatos további tudnivalókat lásd a Kapcsolódó témakörökben. A Windows 2000 Professional használatakor megtekinthető a Bevezetés a Windows 2000 Professional használatába on-line könyv vagy a Windows 2000 CD-vel járó Bevezetés a Windows 2000 Professional használatába című könyv. A Windows 2000 Server használatakor lásd a Helyreállítás “Hogyan?” szakaszát.


Parancssori példák

Az alábbi példák bemutatják, hogyan használható az ntbackup parancs a parancssorban vagy parancsfájlban a fájlok és mappák biztonsági másolatának elkészítésére.

1. példa:

ntbackup backup \\anna-vegyes\c$ /m normal /j "1. saját mentés" /p "Backup" /n "Parancssori 1. biztonsági másolat" /d "Parancssori funkció" /v:yes /r:no /l:s /rs:no /hc:on

A példában megadott parancs “1. saját mentés” néven normál biztonsági másolatot készít az \\anna-vegyes\c$ távoli megosztásról. A parancs kivesz egy szalagot a biztonsági másolat segédprogramhoz használható adathordozó-készletből, és a szalagnak a “Parancssori 1. biztonsági mentés” nevet adja. A “Parancssori funkció” kifejezés a biztonsági mentés leírása lesz. A biztonsági mentés befejezése után a rendszer ellenőrzi az elkészült biztonsági másolatot, a hozzáférést nem korlátozza a tulajdonosra/rendszergazdára, a naplózási szintet csak az összegzés naplózására állítja be, a Cserélhető tároló segédprogram adatairól a rendszer nem készít biztonsági mentést és a parancs engedélyezi a hardveres tömörítés használatát.

2. példa:

ntbackup backup d:\ /j "2. saját mentés" /a /t "Parancssori 1. biztonsági mentés" /m copy

A példában megadott parancs “2. saját mentés” néven másolásos biztonsági másolatot készít a D:\ helyi meghajtóról. A fájlokról és mappákról készített biztonsági másolatot a parancs hozzáfűzi a “Parancssori 1. biztonsági mentés” nevű szalaghoz. Az összes többi beállítás esetén a Biztonsági mentés segédprogram alapbeállításai érvényesek.

3. példa:

ntbackup backup "@C:\Program Files\Windows NT\ntbackup\data\parancssor.bks" /j "3. saját mentés" /t "Parancssori 1. biztonsági mentés" /n "Parancssori 2. biztonsági mentés"

A példában megadott parancs a Biztonsági mentés segédprogramban beállított típusú biztonsági másolatot készít. A parancs a C:\Program Files\Windows NT\ntbackup\data\ könyvtárban elhelyezkedő parancssor.bks nevű biztonságimásolat-kijelölőfájl alapján választja ki azokat a fájlokat, amelyekről biztonsági másolatot készít. A biztonsági mentés neve “3. saját mentés”, és a “Parancssori 1. biztonsági mentés” elnevezésű szalag nevét felülírja a “Parancssori 2. biztonsági mentés” névvel.

4. példa:

ntbackup backup \\anna-vegyes\d$ /j "Parancssori 4. biztonsági mentés" /f "D:\bmentés.bkf"

ntbackup backup \\anna-vegyes\d$ /j "Parancssori 5. biztonsági mentés" /f "D:\bmentés.bkf"

ntbackup backup \\anna-vegyes\d$ /j "Parancssori 6. biztonsági mentés" /f "D:\bmentés.bkf"

A fenti példák azt mutatják be, a parancssorból hogyan végezhető el a biztonsági mentés egy fájlba. Mindhárom példában megadott parancs a Biztonsági másolat segédprogramban alapértelmezett típusú biztonsági másolatot, ellenőrzési beállításokat, naplózási szintet, hardveres tömörítést és egyéb korlátozásokat használja. Az első parancs arra példa, hogyan készíthető biztonsági mentés az \\anna-vegyes\d$ könyvtárról a D:\Bmentés.bkf fájlba. A második parancs azt példázza, hogyan fűzhető egyanez a biztonsági mentés ugyanahhoz a fájlhoz. A harmadik példa azt mutatja be, hogyan írható felül a fájl ugyanazzal a biztonsági mentéssel. Mindhárom példában a meghajtó betűjele helyettesíthető a teljes UNC-névvel (azaz a d:\bmentés.bkf helyett az \\anna-vegyes\d$\bmentés.bkf hely is megadható a biztonsági másolat helyeként).


Parancssori paraméterek

Biztonsági másolat az ntbackup parancs és annak számos parancssori kapcsolójának segítségével a parancssorból vagy parancsfájllal is készíthető.

Szintaxis:

ntbackup backup [systemstate] "bks fájl neve" /J {"feladat neve"} [/P {"készlet neve"}] [/G {"globálisan egyedi azonosító (guid) neve"}] [/T { "szalag neve"}] [/N {"adathordozó neve"}] [/F {"fájl neve"}] [/D {"készlet leírása"}] [/DS {"kiszolgáló neve"}] [/IS {"kiszolgáló neve"}] [/A] [/V:{yes|no}] [/R:{yes|no}] [/L:{f|s|n}] [/M {biztonsági másolat típusa}] [/RS:{yes|no}] [/HC:{on|off}] [/UM]

Paraméterek:

systemstate

Megadásával biztonsági másolat készíthető rendszerállapot-adatokról. Amikor biztonsági másolatot készít a rendszerállapot-adatokról, akkor a rendszer biztonsági másolatot készít az összes rendszerállapot-adatról, ezért a /s kapcsoló hatástalan. A biztonsági másolat típusa is csak normál vagy másolásos lehet.

bks fájl neve

A biztonságimásolat-készítéshez használt biztonságimásolat-kijelölőfájlt (.bks kiterjesztésű fájl) adja meg. A biztonságimásolat-kijelölőfájl azoknak a fájloknak és mappáknak az adatait tartalmazza, amelyekről biztonsági másolatot akar készíteni. Ez a fájl a grafikus felületű Biztonsági mentés segédprogrammal készíthető el.

/J {"feladat neve"}

A naplófájlban használt feladatnevet adja meg. A feladat neve általában az aktuális biztonsági mentésben szereplő fájlok és mappák leírása mellett a biztonsági másolat készítésének dátumát és időpontját tartalmazza.

/P {"készlet neve"}

Azt az adathordozó-készletet adja meg, amelyből az adathordozót akarja használni. Ez általában a biztonsági másolat adathordozó-készlet valamelyik alkészlete, például a 4 mm-es DDS. E beállítás megadása esetén nem használhatók az alábbi kapcsolók: /A /G /F /T.

/G {"globálisan egyedi azonosító (guid) neve"}

Felülírja vagy hozzáfűzi ehhez a szalaghoz. Nem használható a /P kapcsolóval együtt.

/T {"szalag neve"}

Felülírja vagy hozzáfűzi ehhez a szalaghoz. Nem használható a /P kapcsolóval együtt.

/N {"adathordozó neve"}

A szalag új nevét adja meg. Nem használható a /A kapcsolóval együtt.

/F {"fájl neve"}

A logikai lemez elérési útvonala és a fájlnév A következő kapcsolók nem használhatók ezzel a kapcsolóval: /P /G /T.

/D {"készlet leírása"}

Minden egyes biztonságimásolat-készlethez címke rendelhető.

/DS {"kiszolgáló neve"}

Biztonsági másolatot készít a megadott Microsoft Exchange Server címtárszolgáltatását tároló fájlról.

/IS {"kiszolgáló neve"}

Biztonsági másolatot készít a megadott Microsoft Exchange Serverhez tartozó adattároló fájlról.

/A

Hozzáfűzést hajt végre. A /G vagy a /T kapcsolóval kell együtt használni. Nem használható a /P kapcsolóval együtt.

/V:{yes|no}

A biztonsági mentés befejezése után ellenőrzi a biztonsági másolatban tárolt adatokat.

/R:{yes|no}

Megadása esetén csak a tulajdonos vagy a Rendszergazdák csoport tagjai használhatják a szalagot.

/L:{f|s|n}

A naplófájl típusát határozza meg: f=teljes, s=összegzés, n=nincs (a rendszer nem készít naplófájlt).

/M {biztonsági másolat típusa}

A biztonsági másolat típusát határozza meg. A következő típusok használhatók: normál, másolás, különbségi, növekményes vagy napi.

/RS:{yes|no}

Biztonsági másolatot készít a Cserélhető tároló adatbázisáról.

/HC:{on|off}

Ha a szalagos meghajtó támogatja, akkor hardveres tömörítést használ.

/UM

Megkeresi az első használható adathordozót, megformázza, és felhasználja az aktuális biztonsági mentéshez. Az /UM kapcsoló használata esetén a /P kapcsoló megadásával ki kell jelölni egy eszköztípust megadó adathordozó-készletet, így a Biztonsági mentés segédprogram a megfelelő típusú adathordozót (például 4 mm-es DDS) keresi meg. Az /UM kapcsoló használata esetén a Biztonsági másolat segédprogram a következő adathordozó-készletekben keres használható adathordozót: Üres adathordozó-készlet, Import adathordozó-készlet, Ismeretlen adathordozó-készlet, Biztonsági mentés adathordozó-készlet. A használható adathordozó megtalálása után a felhasználó bármiféle közbeavatkozása nélkül automatikusan leáll a keresés, a rendszer megformázza és használatba veszi az adathordozót. Ez a parancs nem használható szalagbetöltőknél, és csak különálló szalagos meghajtó esetén használható.

Megjegyzések

  • A parancssorban az ntbackup parancs segítségével nem állíthatók vissza a fájlok.
  • A következő kapcsolók alapértelmezett értéke a Biztonsági mentés segédprogram grafikus felületén megadott beállításokkal egyezik, ha az adott beállítás értékét nem módosítja parancssori kapcsoló: /V /R /L /M /RS /HC. Ha például a Biztonsági mentés segédprogram Beállítások párbeszédpanelén bekapcsolja a hardveres tömörítést, akkor a rendszer ezt a beállítást alkalmazza, ha a parancssorban nem szerepel a /HC kapcsoló. Ha azonban a parancssorban a /HC:off kapcsolót adja meg, akkor az felülírja a Beállítások párbeszédpanel beállítását, és a rendszer nem használja majd a hardveres tömörítést.
  • Ha a számítógépen használja a Windows adatfolyam-szolgáltatásokat és e szolgáltatásokkal kapcsolatos adatokról akar biztonsági másolatot készíteni, akkor tanulmányozza a Windows adatfolyam-szolgáltatások on-line dokumentációjának „Biztonsági mentés használata a Windows adatfolyam-szolgáltatásokkal” témakörét. A Windows adatfolyam-szolgáltatásokkal kapcsolatos fájlok biztonsági mentéséhez és visszaállításához be kell tartani a Windows adatfolyam-szolgáltatások on-line dokumentációjában bemutatott eljárásokat.
  • Csak a helyi számítógép rendszerállapot-adatairól készíthető biztonsági másolat. Távoli számítógép rendszerállapot-adatairól nem készíthető biztonsági másolat.
  • Ha az adathordozók kezelésére a Cserélhető tároló segédprogramot használja, vagy az adatok tárolására a Távtároló segédprogramot használja, akkor a következő mappákban levő fájlokról rendszeresen biztonsági másolatot kell készíteni:

    rendszergyökér\System32\Ntmsdata

    rendszergyökér\System32\Remotestorage

    Ez biztosítja a Távoli tároló és a Cserélhető tároló segédprogram összes adatának visszaállíthatóságát.


Flash memórialemez használata hibatűrő indítóeszközként

  1. Telepítse a flash memórialemezt a számítógépbe, ha még nincs telepítve. A flash lemezen a Windows 2000 rendszerben NTFS fájlrendszert kell kialakítani.
  2. Kattintson duplán az Asztalon a Sajátgép ikonra.
  3. A merevlemez gyökérkönyvtárából másolja át a flash lemezre az alábbi fájlokat. Boot.ini, Ntldr és Ntdetect.com.
  4. Kapcsoljon át a flash lemezre, a jobb oldali egérgombbal kattintson a Boot.ini fájlra, majd kattintson a Tulajdonságok parancsra.
  5. Törölje az Írásvédett jelölőnégyzetet, majd a Tulajdonságok párbeszédpanel bezárásához kattintson az OK gombra.
  6. A Jegyzettömb segédprogramban nyissa meg a Boot.ini fájlt, és módosítsa az alábbiak szerint:
    Az „rdisk(0)” kifejezést mindenhol cserélje ki az „rdisk(1)” kifejezésre.
    Ezen kívül ha a számítógépben SCSI-merevlemez található, akkor az „scsi(0)” kifejezést mindenhol cserélje ki a „multi(0)” kifejezésre.
  7. Mentse a módosításokat és zárja le a Boot.ini fájlt.
  8. Állítsa vissza újból a Boot.ini fájl Írásvédett attribútumát.
  9. Indítsa újra a számítógépet.
  10. Helyezze a flash memórialemezhez mellékelt hajlékonylemezt a lemezmeghajtóba.
  11. A parancssorba írja be a következőt:

    dupdate /win:d000 /s:doc121.exb /first

  12. Vegye ki a hajlékonylemezt a meghajtóból és indítsa újra a számítógépet.
  13. Telepítse a Helyreállítási konzolt. A Helyreállítási konzol használatával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • Az operációs rendszer mindig a flash memórialemezről indul annak ellenére, hogy az operációs rendszerhez tartozó legtöbb fájl a merevlemezen található. Ha hiba keletkezik a számítógép indulásakor, akkor a flash memórialemezről elindítható Helyreállítási konzol segítségével megpróbálhatja helyreállítani az operációs rendszert.
  • Ez a művelet az M-Systems DiskOnChip termékének használatához készült, amely a legújabb verziójú (1.21) beégetett kódú eszköz-illesztőprogramot tartalmazza, de esetleg más flash memórialemezekhez is használható.