WMI-vezérlő

  • WMI-vezérlő – áttekintés
  • A WMI hibanaplózás ki- és bekapcsolása
  • A tárház biztonsági mentési gyakoriságának megadása
  • A WMI parancsfájlokkal kapcsolatos beállításainak módosítása
  • Biztonság


WMI-vezérlő – áttekintés

A WMI-vezérlő (Windows Management Instrumentation) elnevezésű eszköz segítségével módosíthatók egy távoli számítógép vagy a helyi számítógép WMI-beállításai. A WMI-vezérlővel a következő műveletek hajthatók végre:

Jogosultság megadása felhasználónak vagy csoportnak, illetve engedélyek beállítása

Jogosultságot adhat felhasználóknak vagy csoportoknak a WMI szolgáltatásaihoz való hozzáférésre és feladatok végrehajtására. Minden feljogosított felhasználó vagy csoport esetében az engedélyek szintjét adott névtérhez állíthatja be. Engedélyezheti például valamely csoport tagjai számára, hogy kezeljék a helyi számítógépükön található CIM-objektumokat.

A hibanaplózás konfigurálása

A hibanaplózás be- vagy kikapcsolható, illetve ha be van kapcsolva, akkor beállíthatja csak a hibák (ez az alapértelmezés) vagy minden művelet (részletes) naplózását. A hibanaplózás segíthet a WMI hibáinak elhárításában. Meghatározhatja a naplófájlok maximális méretét és az egyes fájlokat tároló mappák helyét is.

A tárház biztonsági mentése

Beállíthatja, hogy a WMI-vezérlő rendszeres időközönként biztonsági másolatot készítsen a tárházról, vagy saját maga is bármikor elvégezheti a biztonsági mentést. A tárház a WMI használatával elérhető objektumok adatbázisa. A tárház korábbi változatát is visszaállíthatja egy biztonsági másolatból.

A parancsfájlokhoz használt alapértelmezett névtér módosítása

Megváltoztathatja a WMI-parancsfájlokban célként használt alapértelmezett névteret.

Csatlakozás más felhasználóként

A WMI-vezérlő beállításainak módosításához más felhasználónéven is bejelentkezhet. Elképzelhető például, hogy több munkaállomáson beállított egy felügyeleti jogokkal felruházott felhasználói fiókot. E lehetőség révén a megfelelő felhasználónéven jelentkezhet be az adott munkaállomásokra.

Kapcsolódó témakörök


A WMI hibanaplózás ki- és bekapcsolása

  1. Nyissa meg a WMI-vezérlő beépülő modult.
  2. A konzolfán kattintson a jobb oldali egérgombbal a WMI-vezérlő elemre, majd kattintson a Tulajdonságok menüpontra.
  3. Kattintson a Naplózás fülre.
  4. A naplózás kikapcsolásához kattintson a Naplózási szint részen látható Letiltva választógombra, bekapcsolásához pedig kattintson a Csak a hibák vagy a Részletes választógombra.

Megjegyzések

  • A feladat végrehajtásához a kezelt számítógépen rendszergazdaként, a Rendszergazdák csoport tagjaként vagy a szükséges engedélyekkel rendelkező felhasználóként kell bejelentkezni.
  • A WMI-vezérlő konzoljának megnyitásához kattintson a Start menü Futtatás parancsára, gépelje be a wmimgmt.msc fájlnevet, majd kattintson az OK gombra.
  • A Csak a hibák beállítás kiválasztásakor kizárólag a WMI használata során előforduló hibákról, a Részletes lehetőség kiválasztásakor pedig minden műveletről és hibáról készül naplóbejegyzés.
  • A részletes naplózás hátrányosan befolyásolhatja a rendszer teljesítményét, ezért csak akkor válassza a Részletes beállítást, ha bővebb információra van szüksége a hibához vezető eseményekről.
  • A naplózás bekapcsolásakor a rendszer a WMI alapszintű objektumaihoz és a WMI keretrendszeréhez, valamint a WMI használatát támogató minden egyes szolgáltatóhoz létrehozza a szükséges naplófájlt.
  • A naplófájlok maximális méretét a Maximális méret mezőben állíthatja be. Amikor valamelyik naplófájl eléri a maximális méretet, a rendszer átnevezi azonos fájlnevűre de .Lo_ kiterjesztésűre, és létrehoz egy új naplófájlt .Log kiterjesztéssel. Amikor ez a fájl is eléri a maximális méretet, az első fájl törlődik, és a folyamat megismétlődik.
  • Beállíthatja a naplózási szintet valamely távoli számítógépen vagy a helyi számítógépen. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a WMI-vezérlő csomópontra, kattintson a Csatlakozás másik számítógéphez, majd a Másik számítógép menüpontra, végül gépelje be a számítógép nevét, amelyhez csatlakozni kíván.
  • Amennyiben több bejelentkezési nevet használ, más felhasználónéven is bejelentkezhet a távoli számítógépekre. Ha más felhasználóként szeretne csatlakozni, kattintson az Általános lapon látható Módosítás gombra, törölje a jelölést a Bejelentkezés a jelenlegi felhasználói fiók használatával jelölőnégyzetből, majd gépelje be a bejelentkezéshez használni kívánt nevet és jelszót.
  • Amennyiben problémát tapasztal a WMI használatával kapcsolatban, célszerű a naplófájlokat is csatolnia, amikor elküldi észrevételeit az ügyfélszolgálatnak.


A tárház biztonsági mentési gyakoriságának megadása

  1. Nyissa meg a WMI-vezérlő beépülő modult.
  2. A konzolfán kattintson a jobb oldali egérgombbal a WMI-vezérlő elemre, majd kattintson a Tulajdonságok menüpontra.
  3. Kattintson a Biztonsági másolat készítése és visszaállítása fülre.
  4. Jelölje be az Automatikus másolatkészítés minden jelölőnégyzetet, majd adja meg, hogy a Windows Management szolgáltatás milyen időközönként hajtson végre biztonsági mentést.
  5. Az időegység (perc vagy óra) beállításához kattintson a nyílra.

Megjegyzések

  • A feladat végrehajtásához a kezelt számítógépen rendszergazdaként, a Rendszergazdák csoport tagjaként vagy a szükséges engedélyekkel rendelkező felhasználóként kell bejelentkezni.
  • A WMI-vezérlő konzoljának megnyitásához kattintson a Start menü Futtatás parancsára, gépelje be a wmimgmt.msc fájlnevet, majd kattintson az OK gombra.
  • Az automatikus biztonsági mentések közötti idő legfeljebb 24 óra lehet. Ha az időközt percben adja meg, akkor annak hossza legfeljebb 999 perc, a legrövidebb beállítható időköz pedig 5 perc lehet. Akár órában, akár percben adja meg az időközt, csak egész számokat használhat.
  • A tárházat saját maga is bármikor mentheti, ehhez kattintson a Biztonsági másolat készítése most gombra. Elnevezheti a biztonsági másolatot, és később visszaállíthatja a tárházat az adott fájlnevű biztonsági másolatból. Ez a lehetőség különösen adott osztálykonfiguráció mentésekor hasznos.
  • Beállíthatja a biztonsági mentés gyakoriságát valamely távoli számítógépen vagy a helyi számítógépen. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a WMI-vezérlő csomópontra, kattintson a Csatlakozás másik számítógéphez, majd a Másik számítógép menüpontra, végül gépelje be a számítógép nevét, amelyhez csatlakozni kíván.
  • Amennyiben több bejelentkezési nevet használ, más felhasználónéven is bejelentkezhet a távoli számítógépekre. Ha más felhasználóként szeretne csatlakozni, kattintson az Általános lapon látható Módosítás gombra, törölje a jelölést a Bejelentkezés a jelenlegi felhasználói fiók használatával jelölőnégyzetből, majd gépelje be a bejelentkezéshez használni kívánt nevet és jelszót.
  • Amennyiben a kezelt számítógépen a WMI korábbi verziója fut, a Legutóbbi biztonsági másolat készítésének ideje nem jelenik meg a párbeszédpanelen.


A WMI parancsfájlokkal kapcsolatos beállításainak módosítása

  1. Nyissa meg a WMI-vezérlő beépülő modult.
  2. A konzolfán kattintson a jobb oldali egérgombbal a WMI-vezérlő elemre, majd kattintson a Tulajdonságok menüpontra.
  3. Kattintson a Speciális fülre.
  4. Kattintson A parancsfájlok alapértelmezett névtere részen látható Módosítás gombra.
  5. A Névtér tallózása párbeszédpanelen válassza ki, hogy a parancsfájlok ezentúl melyik névteret használják alapértelmezett célként.

Megjegyzések

  • A feladat végrehajtásához a kezelt számítógépen rendszergazdaként, a Rendszergazdák csoport tagjaként vagy a szükséges engedélyekkel rendelkező felhasználóként kell bejelentkezni.
  • A WMI-vezérlő konzoljának megnyitásához kattintson a Start menü Futtatás parancsára, gépelje be a wmimgmt.msc fájlnevet, majd kattintson az OK gombra.
  • Olyan névteret állítson be alapértelmezett névtérként, amelyet gyakran használ WMI-parancsfájlokban. Ha egy parancsfájlban nincs megadva névtér, a rendszer az itt megadott alapértelmezett névteret használja.
  • Amennyiben a kezelt számítógép Windows NT 4.0 operációs rendszer alatt működik, azt is meghatározhatja, hogy engedélyezi-e WMI-parancsfájlok futtatását aktív kiszolgálóoldalakról (ASP fájlokból). Ha engedélyezi, az ASP oldalak mindig az Internet Information Services folyamatszintű azonosítójának használatával csatlakoznak a Windows Management szolgáltatásokhoz, és ezzel veszélyeztethetik a biztonságot.
  • Módosíthatja a parancsfájlok által használt névteret valamely távoli számítógépen vagy a helyi számítógépen. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a WMI-vezérlő csomópontra, kattintson a Csatlakozás másik számítógéphez, majd a Másik számítógép menüpontra, végül gépelje be a számítógép nevét, amelyhez csatlakozni kíván.
  • Amennyiben több bejelentkezési nevet használ, más felhasználónéven is bejelentkezhet a távoli számítógépekre. Ha más felhasználóként szeretne csatlakozni, kattintson az Általános lapon látható Módosítás gombra, törölje a jelölést a Bejelentkezés a jelenlegi felhasználói fiók használatával jelölőnégyzetből, majd gépelje be a bejelentkezéshez használni kívánt nevet és jelszót.


Biztonság

  • A WMI biztonsági szolgáltatásainak kezelése
  • Jogosultság megadása a WMI felhasználóinak, illetve engedélyek beállítása
  • Engedélyek módosítása vagy jogosultság megvonása felhasználóktól


A WMI biztonsági szolgáltatásainak kezelése

A WMI (Windows Management Instrumentation) korlátozott biztonsági funkciókkal rendelkezik, amelyek minden felhasználót azonosítanak, mielőtt engedélyeznék számára a csatlakozást a WMI szolgáltatásaihoz, akár a helyi számítógépen, akár valamely távoli számítógépen. E funkciók az operációs rendszer adatbiztonsági szolgáltatásai feletti biztonsági réteget jelentenek. A WMI nem bírálja felül és nem kerüli meg az operációs rendszer biztonsági beállításait és korlátozásait.

Alapértelmezés szerint a kezelt gépen a Rendszergazdák csoport minden tagja teljes körű hozzáféréssel rendelkezik a WMI szolgáltatásaihoz. Mindenki más csak írási, olvasási és végrehajtási engedélyekkel rendelkezik saját helyi számítógépén.

Az engedélyeket módosíthatja úgy, hogy felveszi a felhasználót a Rendszergazdák csoportba a kezelt számítógépen, vagy úgy, hogy a WMI-vezérlőben megadja a szükséges jogosultságot a kívánt felhasználóknak vagy csoportoknak, és beállítja engedélyeik szintjét. A hozzáférés a WMI névterein alapul.

A Windows 95 vagy Windows 98 rendszer alatt működő számítógépeken minden felhasználó teljes helyi hozzáférési joggal rendelkezik. Beállíthat azonban engedélyeket olyan felhasználók számára is, akik távolról kívánnak kezelni egy Windows 95 vagy Windows 98 operációs rendszerű számítógépet.

A rendszer csak akkor ellenőrzi a biztonsági beállításokat és az engedélyeket, amikor egy felhasználó csatlakozik a Windows Management szolgáltatáshoz. Így valamely felhasználó engedélyeinek módosításai csak akkor lépnek életbe, amikor az adott felhasználó legközelebb elindítja a WMI szolgáltatást. Ha például a rendszergazda visszavonja a felhasználó hozzáférési jogosultságát, a módosítás csak akkor lép életbe, amikor a felhasználó kilép a WMI szolgáltatásból, és legközelebb megpróbál csatlakozni.


Jogosultság megadása a WMI felhasználóinak, illetve engedélyek beállítása

  1. Nyissa meg a WMI-vezérlő beépülő modult.
  2. A konzolfán kattintson a jobb oldali egérgombbal a WMI-vezérlő elemre, majd kattintson a Tulajdonságok menüpontra.
  3. Kattintson a Biztonság fülre.
  4. Válassza ki a névteret, amelyre vonatkozóan be kívánja állítani felhasználók vagy csoportok hozzáférési jogait, majd kattintson a Biztonság gombra.
  5. A Biztonság párbeszédpanelen kattintson a Hozzáadás gombra.
  6. Hajtsa végre a következő lépések egyikét:
    • Amennyiben a helyi számítógépen állít be engedélyeket, először válassza ki a hozzáadni kívánt felhasználót vagy csoportot tartalmazó tartományt a Felhasználók, számítógépek vagy csoportok kijelölése párbeszédpanel Keresés itt listájáról. Ez után a Név listán kattintson duplán a hozzáadni kívánt felhasználó vagy csoport nevére, vagy gépelje be a nevet az alsó mezőbe, végül pedig kattintson az OK gombra.
    • Távoli számítógép engedélyeinek beállításakor a Felhasználó hozzáadása párbeszédpanelen gépelje be a hozzáadni kívánt felhasználó vagy csoport nevét, majd kattintson az OK gombra.
  7. A Biztonság párbeszédpanel Engedélyek listáján a megfelelő jelölőnégyzetek bejelölésével határozza meg, hogy mely műveleteket engedélyezi és melyeket nem az új felhasználónak vagy csoportnak.
    8. Szint | Leírás
Engedélyezés | Olvasási jogosultságot biztosít a névterületen belül található objektumokhoz.
Metódusok végrehajtása | Engedélyezi a CIM objektumkezelőből exportált objektumokra alkalmazható metódusok futtatását.
Teljes hozzáférés | Teljes olvasási, írási és törlési jogosultságot biztosít a CIM minden objektumához, osztályához és példányához.
Részleges írás | Írási jogosultságot biztosít a tárház statikus objektumaihoz.
Szolgáltató írása | Írási jogosultságot biztosít a szolgáltató által szállított objektumokhoz.
Biztonság olvasása | Olvasási jogosultságot biztosít a WMI biztonsági adataihoz.
Biztonság szerkesztése | Írási és olvasási jogosultságot biztosít a WMI biztonsági adataihoz.
Távelérés | Valamely távoli számítógép számára ugyanolyan jogokat biztosít, mint amelyek a helyi számítógépről való csatlakozás esetén engedélyezettek.

Megjegyzések

  • A feladat végrehajtásához a kezelt számítógépen rendszergazdaként, a Rendszergazdák csoport tagjaként vagy a szükséges engedélyekkel rendelkező felhasználóként kell bejelentkezni.
  • A WMI-vezérlő konzoljának megnyitásához kattintson a Start menü Futtatás parancsára, gépelje be a wmimgmt.msc fájlnevet, majd kattintson az OK gombra.
  • Beállíthatja az engedélyeket valamely távoli számítógépen vagy a helyi számítógépen. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a WMI-vezérlő csomópontra, kattintson a Csatlakozás másik számítógéphez, majd a Másik számítógép menüpontra, végül gépelje be a számítógép nevét, amelyhez csatlakozni kíván.
  • Amennyiben több bejelentkezési nevet használ, más felhasználónéven is bejelentkezhet a távoli számítógépekre. Ha más felhasználóként szeretne csatlakozni, kattintson az Általános lapon látható Módosítás gombra, törölje a jelölést a Bejelentkezés a jelenlegi felhasználói fiók használatával jelölőnégyzetből, majd gépelje be a bejelentkezéshez használni kívánt nevet és jelszót.
  • A Windows 95 vagy Windows 98 rendszer alatt működő számítógépeken minden felhasználó teljes helyi hozzáférési joggal rendelkezik. A biztonsági beállításoknak csak abban az esetben van jelentőségük, ha az elérni kívánt távoli számítógép Windows 95 vagy Windows 98 operációs rendszer alatt működik.
  • Amennyiben engedélyeztetés nélkül lehetővé kívánja tenni egy felhasználó vagy csoport számára a WMI szolgáltatásainak elérést, jelölje ki a felhasználót vagy csoportot, majd kattintson az Eltávolítás gombra.
  • Felhasználót a Windows 2000 Helyi felhasználók és csoportok ablakában adhat hozzá egy csoporthoz.


Engedélyek módosítása vagy jogosultság megvonása felhasználóktól

  1. Nyissa meg a WMI-vezérlő beépülő modult.
  2. A konzolfán kattintson a jobb oldali egérgombbal a WMI-vezérlő elemre, majd kattintson a Tulajdonságok menüpontra.
  3. Kattintson a Biztonság fülre.
  4. Válassza ki a névteret, amelyre vonatkozóan módosítani kívánja valamely felhasználó vagy csoport engedélyeit, illetve törölni szeretne egy felhasználót vagy csoportot, majd kattintson a Biztonság gombra.
  5. A Biztonság párbeszédpanel Név listáján jelölje ki azt a felhasználót vagy csoportot, amelynek engedélyeit módosítani kívánja, illetve amelyet el szeretne távolítani.
  6. Hajtsa végre a következő lépések egyikét:
    • A kijelölt felhasználó vagy csoport törléséhez kattintson az Eltávolítás gombra.
    • A biztonsági beállítások módosításához az Engedélyek listán jelölje be a felhasználónak vagy csoportnak megadni kívánt engedélyek jelölőnégyzeteit, illetve törölje a jelölést azon engedélyek jelölőnégyzeteiből, amelyeket nem kíván megadni.

Megjegyzések

  • A feladat végrehajtásához a kezelt számítógépen rendszergazdaként, a Rendszergazdák csoport tagjaként vagy a szükséges engedélyekkel rendelkező felhasználóként kell bejelentkezni.
  • A WMI-vezérlő konzoljának megnyitásához kattintson a Start menü Futtatás parancsára, gépelje be a wmimgmt.msc fájlnevet, majd kattintson az OK gombra.
  • A rendszer csak akkor ellenőrzi a WMI biztonsági beállításait és az engedélyeket, amikor egy felhasználó csatlakozik a Windows Management szolgáltatáshoz. Így valamely felhasználó engedélyeinek módosításai csak akkor lépnek életbe, amikor az adott felhasználó legközelebb bejelentkezik a WMI szolgáltatásra. Ha például a rendszergazda visszavonja a felhasználó hozzáférési jogosultságát, a módosítás csak akkor lép életbe, amikor a felhasználó kijelentkezik a Windows Management szolgáltatásból, és legközelebb megpróbál bejelentkezni.
  • Módosíthatja a felhasználók vagy csoportok engedélyeit valamely távoli számítógépen vagy a helyi számítógépen. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a WMI-vezérlő csomópontra, kattintson a Csatlakozás másik számítógéphez, majd a Másik számítógép menüpontra, végül gépelje be a számítógép nevét, amelyhez csatlakozni kíván.
  • Amennyiben több bejelentkezési nevet használ, más felhasználónéven is bejelentkezhet a távoli számítógépekre. Ha más felhasználóként szeretne csatlakozni, kattintson az Általános lapon látható Módosítás gombra, törölje a jelölést a Bejelentkezés a jelenlegi felhasználói fiók használatával jelölőnégyzetből, majd gépelje be a bejelentkezéshez használni kívánt nevet és jelszót.