Számláló hozzáadása a grafikonhoz

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Számlálónaplók elemre.
  3. A részletek ablaktáblán kattintson duplán a módosítani kívánt naplóra.
  4. Az Általános lapon kattintson a Hozzáadás gombra. A naplóhoz hozzáadni kívánt összes számláló vagy számlálócsoport esetén hajtsa végre a következő lépéseket:
    1. Ha a Teljesítménynaplók és riasztások szolgáltatást futtató számítógép számlálóit szeretné naplózni, kattintson a Helyi számlálók használata választógombra.

      Adott számítógép számlálóinak naplózásához, függetlenül attól, hogy a szolgáltatás hol fut, kattintson a Más számítógép számlálói választógombra, és adja meg a figyelni kívánt számítógép nevét.

    2. A Teljesítményobjektum listában válassza ki a figyelni kívánt objektumot.
    3. A Teljesítményszámlálók listában kattintson egy vagy több figyelni kívánt számlálóra.
    4. Ha a kiválasztott számlálók minden példányát figyelni szeretné, kattintson a Minden példány választógombra. (A bináris naplók tartalmazhatnak olyan számlálókat, amelyek nem elérhetők a naplózás indulásakor, de később azzá válnak.)

      Ha a kiválasztott számlálóknak csak egyes példányait szeretné figyelni, kattintson a Példányok választása listából választógombra, majd válassza ki a figyelni kívánt példányt vagy példányokat.

    5. Kattintson a Hozzáadás gombra.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha a figyelőkonzolt exportálás céljából hozza létre, fontos, hogy a Helyi számlálók használata választógombot válassza. Ellenkező esetben a számlálónaplók a szövegmezőben megadott számítógép adatait fogják tartalmazni függetlenül attól, hogy a konzolfájl hol található.
  • A számláló leírásának megtekintéséhez a Teljesítményszámlálók listában kattintson a számlálóra, majd kattintson a Magyarázat gombra.
  • A hálózatfigyelő számlálók elindításával kapcsolatos tudnivalókért tanulmányozza a Hálózati szegmens számlálók engedélyezése című témakört.
  • Bizonyos objektumtípusok több példánnyal rendelkeznek. Ha például a rendszerben több processzor található, a Processzor objektumtípusnak több példánya lesz. A Fizikai lemez objektumtípusnak két példánya van, ha a rendszerben két lemez található. Néhány objektumtípusnak, például a Memória vagy a Kiszolgáló objektumtípusnak, csak egyetlen példánya van. Ha az objektumtípusnak több példánya van, akkor mindegyik példány statisztikájának követéséhez megadható számláló, vagy sok esetben akár az összes példányhoz egyszerre. Alapértelmezés szerint a számlálók a példány nevével és az indexével együtt jelennek meg. Ennek a szolgáltatásnak a kikapcsolásához kattintson a jobb oldali egérgombbal a Rendszerfigyelő konzolban megjelenő grafikonra, kattintson a Tulajdonságok parancsra, majd törölje a Duplikált számlálópéldányok engedélyezése jelölőnégyzet jelölését.

Kapcsolódó témakörök


Műveletek meghatározása riasztás esetére

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Riasztások elemre.
  3. A részletek ablaktáblában kattintson duplán a riasztásra.
  4. Kattintson a Művelet fülre.
  5. Ha azt akarja, hogy a Teljesítménynaplók és riasztások szolgáltatás az Eseménynaplóban megtekinthető bejegyzéseket hozzon létre, jelölje be a Bejegyzés naplózása az alkalmazások eseménynaplójába jelölőnégyzetet.
  6. Ha azt akarja, hogy a szolgáltatás az üzenetküldőn keresztül egy üzenetet küldjön, jelölje be a Hálózati üzenet küldése a következőnek jelölőnégyzetet, és adja meg annak a számítógépnek a nevét, amelyen meg szeretné jeleníteni a figyelmeztető üzenetet.
  7. Ha a riasztás esetén számlálónaplót akar futtatni, jelölje be a Teljesítménynapló indítása jelölőnégyzetet, és adja meg a futtatni kívánt számlálónaplót.
  8. Ha riasztás esetén egy programot akar futtatni, jelölje be A következő program futtatása jelölőnégyzetet, és adja meg a fájl nevét és elérési útvonalát, vagy a fájl megkereséséhez kattintson a Tallózás gombra. Amikor létrejön egy riasztás, a szolgáltatás létrehoz egy folyamatot, és futtatja a megadott parancsfájlt. A szolgáltatás a megadott parancssori paramétereket is átmásolja a fájl futtatásához használt parancssorba. Kattintson a Parancssori paraméterek gombra, és jelölje be a megfelelő jelölőnégyzeteket a program futtatásakor használni kívánt paraméterek megadásához.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Riasztás számlálóinak és küszöbértékeinek meghatározása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Riasztások elemre.
  3. A részletek ablaktáblában kattintson duplán a riasztásra.
  4. A Megjegyzés mezőben adja meg a riasztás leírását.
  5. Kattintson a Hozzáadás gombra.
  6. A naplóhoz hozzáadni kívánt összes számláló vagy számlálócsoport esetén hajtsa végre a következő lépéseket:
    1. Ha annak a számítógépnek a számlálóit szeretné figyelni, amelyiken a Teljesítménynaplók és riasztások szolgáltatás futni fog, kattintson a Helyi számlálók használata választógombra.

      Adott számítógép számlálóinak figyeléséhez, függetlenül attól, hogy a szolgáltatás hol fut, kattintson a Más számítógép számlálói választógombra és adja meg a figyelni kívánt számítógép nevét.

    2. A Teljesítményobjektum mezőben válassza ki a figyelni kívánt objektumot.
    3. A Teljesítményszámlálók listában kattintson egy vagy több figyelni kívánt számlálóra.
    4. Ha a kiválasztott számlálók minden példányát figyelni szeretné, kattintson a Minden példány választógombra. (A bináris naplók tartalmazhatnak olyan számlálókat, amelyek nem elérhetők a naplózás indulásakor, de később azzá válnak.)

      Ha a kiválasztott számlálóknak csak egyes példányait szeretné figyelni, kattintson a Példányok választása listából választógombra, majd válassza ki a figyelni kívánt példányt vagy példányokat.

    5. Kattintson a Hozzáadás gombra.
  7. Az Figyelmeztetés a következő értéknél mezőben válassza a Kevesebb, mint vagy a Több, mint értéket, majd a Korlát mezőben adja meg az értéket, amely elindítja a riasztást.
  8. A Mintavételezési időköz mezőben adja meg a frissítési időköz értékét és mértékegységét.
  9. Fejezze be a beállítást a Művelet és az Ütemezés lapokon.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha exportálás céljából hoz létre figyelőkonzolt, fontos, hogy a Helyi számlálók használata választógombot válassza. Ellenkező esetben a számlálónaplók a szövegmezőben megadott számítógép adatait fogják tartalmazni függetlenül attól, hogy a konzolfájl hol található.
  • A hálózatfigyelő számlálók elindításával kapcsolatos tudnivalókért tanulmányozza a Hálózati szegmens számlálók engedélyezése című témakört.
  • Bizonyos objektumtípusok több példánnyal rendelkeznek. Ha például a rendszerben több processzor található, a Processzor objektumtípusnak több példánya lesz. A Fizikai lemez objektumtípusnak két példánya van, ha a rendszerben két lemez található. Néhány objektumtípusnak, például a Memória vagy a Kiszolgáló objektumtípusnak, csak egyetlen példánya van. Ha az objektumtípusnak több példánya van, akkor mindegyik példány statisztikájának követéséhez megadható számláló, vagy sok esetben akár az összes példányhoz egyszerre.


Napló vagy riasztás tulajdonságainak megtekintése és módosítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre.
  3. Kattintson a Számlálónaplók, a Követési naplók vagy a Riasztások elemre.
  4. A részletek ablaktáblán kattintson duplán a napló vagy a riasztás nevére.
  5. Tekintse meg vagy szükség esetén módosítsa a napló tulajdonságait.
    6. Módosítandó eszköz | Meghatározandó tulajdonság | Melyik lapon található
Riasztások | Megjegyzés, számlálók, riasztási küszöbértékek és frissítési időköz | Általános
Riasztások | Az esemény bekövetkeztekor végrehajtani kívánt művelet: program futtatása, üzenet küldése, számlálónapló indítása, eseménynapló frissítése | Művelet
Számlálónaplók | Számlálónaplók számlálói és frissítési időköz | Általános
Számlálónaplók | Számlálónaplófájl megjegyzése, fájltípus, fájlméret korlátja, elérési út és név, automatikus elnevezési paraméterek | Naplófájlok
Számlálónaplók | Műveletek kézi vagy automatizált indítása és leállítása, ütemezés | Ütemezés
Követési naplók | Nyomkövetési naplószolgáltatók és naplózandó események | Általános
Követési naplók | Követési naplófájl megjegyzése, fájlméret korlátja, elérési útvonal és név, automatikus elnevezési paraméterek | Naplófájlok
Követési naplók | Követési napló puffermérete, korlátok, átviteli időköz | Speciális

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Napló vagy riasztás elindításához vagy leállításához a részletek ablaktáblán kattintson a nevére a jobb oldali egérgombbal, majd szükség szerint kattintson az Indítás vagy a Leállítás parancsra.

Kapcsolódó témakörök


Riasztás létrehozása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Riasztások elemre.

    Az összes létező riasztás megjelenik a részletek ablaktáblán. A zöld ikon a pillanatnyilag futó riasztásokat jelzi, a piros ikon pedig a leállított riasztásokat.

  3. Kattintson a jobb oldali egérgombbal a részletek ablaktábla egy üres területére, majd kattintson az Új riasztási beállítások parancsra.
  4. A Név mezőbe írja be a riasztás nevét, majd kattintson az OK gombra.
  5. A riasztáshoz megjegyzés, számlálók, riasztási küszöbértékek és mintavételezési időköz az Általános lapon adható meg. Ha azokat a műveleteket szeretné meghatározni, amelyeket akkor kell végrehajtani, ha egy számláló beindít egy riasztást, használja a Művelet lapot. Annak meghatározásához, hogy a szolgáltatás mikor kezdjen riasztásokat keresni, használja az Ütemezés lapot.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Naplófájl vagy riasztási fájl számlálóbeállításainak mentéséhez a részletek ablaktáblán kattintson a jobb oldali egérgombbal a fájlra, majd kattintson a Beállítások mentése másként parancsra. Ekkor megadható egy .htm fájl, amelybe a rendszer menti a beállításokat. Ha új naplóhoz vagy riasztáshoz fel szeretné használni a mentett beállításokat, kattintson a jobb oldali egérgombbal a részletek ablaktáblára, majd kattintson az Új naplózási beállítások a következőtől vagy az Új riasztási beállítások a következőből parancsra. Ezzel a módszerrel könnyen hozhatók létre naplóbeállítások riasztási konfigurációkból.
  • Naplóbeállítás létrehozásához vagy módosításához Teljes hozzáférés engedéllyel kell rendelkeznie a rendszerleíró adatbázis egy alkulcsához. Az alkulcs a következő:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SysmonLog\Log Queries

    Általában alapértelmezés szerint a rendszergazdák rendelkeznek ilyen engedéllyel. A rendszergazdák a felhasználóknak a Regedt32.exe Biztonság menüje segítségével adhatnak hozzáférési engedélyeket. Továbbá a Teljesítménynaplók és riasztások szolgáltatás (amely a telepítés során telepítésre kerül és egy napló futásakor a háttérben fut) futtatásához engedéllyel kell rendelkeznie a rendszer szolgáltatásainak elindításához. A rendszergazdák alapértelmezés szerint rendelkeznek ezzel az engedéllyel, és a felhasználóknak a Csoportházirend használatával adhatók ilyen engedélyek.

    Vigyázat

    • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot. További tudnivalókért tanulmányozza a Rendszerleíróadatbázis-szerkesztő súgóját.

Kapcsolódó témakörök


Számlálónapló létrehozása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Számlálónaplók elemre.

    3. Az összes létező napló megjelenik a részletek ablaktáblán. A zöld ikon a pillanatnyilag futó naplókat jelzi, a piros ikon pedig a leállított naplókat.

  3. Kattintson a jobb oldali egérgombbal a részletek ablaktábla egy üres területére, majd kattintson az Új naplóbeállítások parancsra.
  4. A Név mezőbe írja be a napló nevét, majd kattintson az OK gombra.
  5. Az Általános lapon kattintson a Hozzáadás gombra. Válassza ki a naplózni kívánt számlálókat.
  6. Ha módosítani szeretné az alapértelmezett fájl- és ütemezési adatokat, használja a Naplófájlok és az Ütemezés lapokat.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Naplófájl vagy riasztási fájl számlálóbeállításainak mentéséhez a részletek ablaktáblán kattintson a jobb oldali egérgombbal a fájlra, majd kattintson a Beállítások mentése másként parancsra. Ekkor megadható egy .htm fájl, amelybe a rendszer menti a beállításokat. Ha egy új naplóhoz vagy riasztáshoz fel szeretné használni a mentett beállításokat, kattintson a jobb oldali egérgombbal a részletek ablaktáblára, majd kattintson az Új naplózási beállítások a következőtől vagy az Új riasztási beállítások a következőből parancsra. Ezzel a módszerrel könnyen hozhatók létre naplóbeállítások riasztási konfigurációkból.
  • Egy napló létrehozásához vagy módosításához Teljes hozzáférés engedéllyel kell rendelkeznie a következő rendszerleíró adatbázis kulcshoz, amely a Teljesítménynaplók és riasztások szolgáltatást vezérli:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SysmonLog\Log Queries

    Általában a rendszergazdák alapértelmezés szerint rendelkeznek ilyen engedéllyel. A rendszergazdák a felhasználóknak a Regedt32.exe Biztonság menüje segítségével adhatnak engedélyeket.

    A szolgáltatás (amely egy napló beállításakor a háttérben fut) futtatásához engedéllyel kell rendelkeznie a rendszer szolgáltatásainak elindításához. A rendszergazdák alapértelmezés szerint rendelkeznek ezzel az engedéllyel, és a felhasználóknak a Csoportházirend használatával adhatók ilyen engedélyek.

    Távoli számítógép adatainak naplózásához a Teljesítménynaplók és riasztások szolgáltatás olyan fiók alatt kell futnia, amely hozzáférhet a távoli rendszerhez.

    Vigyázat

    • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot. További tudnivalókért tanulmányozza a Rendszerleíróadatbázis-szerkesztő súgóját.

Kapcsolódó témakörök


Nyomkövetési napló létrehozása

Nyomkövetés napló létrehozása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Követési napló elemre.

    Az összes létező napló megjelenik a részletek ablaktáblán. Zöld ikon jelzi pillanatnyilag futó naplókat, és piros ikon jelzi a leállított naplókat.

  3. Kattintson a jobb oldali egérgombbal a részletek ablaktábla egy üres területére, majd kattintson az Új naplóbeállítások parancsra.
  4. A Név mezőbe írja be a létrehozni kívánt naplófájl nevét, majd kattintson az OK gombra.

    Alapértelmezés szerint a naplófájlt a gyökérkönyvtár PerfLogs mappájában hozza létre a rendszer, sorszámot illeszt a megadott névhez és a naplófájl típusa szekvenciális követési fájl lesz .etl kiterjesztéssel. A Naplófájlok és a Speciális lapokon adhatók meg és módosíthatók a napló paraméterei. A szolgáltatók és a naplózni kívánt események az Általános lapon adhatók meg. Az Ütemezés lapon adható meg, hogy mikor történjen a naplózás.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A naplófájl beállításainak mentéséhez a részletek ablaktáblán kattintson a jobb oldali egérgombbal a fájlra, majd kattintson a Beállítások mentése másként parancsra. Ekkor megadható egy .htm fájl, amelybe a rendszer menti a beállításokat. Ha egy új naplóhoz fel szeretné használni a mentett beállításokat, kattintson a jobb oldali egérgombbal a részletek ablaktáblára, majd kattintson az Új naplózási beállítások a következőtől parancsra.
  • Naplóbeállítás létrehozásához vagy módosításához Teljes hozzáférés joggal kell rendelkeznie a rendszerleíró adatbázis következő alkulcsához:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SysmonLog\Log Queries

    Általában alapértelmezés szerint a rendszergazdák rendelkeznek ilyen engedéllyel. A rendszergazdák a felhasználóknak a Regedt32.exe Biztonság menüjének segítségével adhatnak hozzáférési engedélyeket. Továbbá a Teljesítménynaplók és riasztások szolgáltatás (amely a telepítés során telepítésre kerül és egy napló futásakor a háttérben fut) futtatásához engedéllyel kell rendelkeznie a rendszer szolgáltatásainak elindításához. A rendszergazdák alapértelmezés szerint rendelkeznek ezzel az engedéllyel, és a felhasználóknak a Csoportházirend használatával adhatók ilyen engedélyek.

    Vigyázat

    • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot. További tudnivalókért tanulmányozza a Rendszerleíróadatbázis-szerkesztő súgóját.

Kapcsolódó témakörök


Napló vagy riasztás törlése

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre.
  3. Kattintson a Számlálónaplók, a Követési naplók vagy a Riasztások elemre.
  4. A részletek ablaktáblán kattintson a jobb oldali egérgombbal a napló vagy a riasztás nevére, majd kattintson a Törlés parancsra.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.


Napló fájlparamétereinek beállítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre.
  3. A számlálónapló fájlparamétereinek beállításához kattintson a Számlálónapló elemre.

    A követési napló fájlparamétereinek beállításához kattintson a Követési napló elemre.

  4. A részletek ablaktáblán kattintson duplán a naplóra.
  5. A Naplófájlok lapon hajtsa végre a következő műveleteket:
    • Naplófájl neve. Válassza ki a fájlelnevezési paramétereket az alábbi beállítások segítségével.
      Beállítás | Leírás
      Hely | Írja be a mappa nevét, ahol a naplófájlt létre szeretné hozni, vagy a mappa megkereséséhez kattintson a Tallózás gombra.
      Fájlnév | Írja be a naplófájl részleges vagy alapnevét. Szükség esetén a Fájlnév mezőt használja a Fájlnevek végződése jelölőnégyzettel együtt.
      Fájlnevek végződése | Jelölje be ezt a jelölőnégyzetet, és a listából válassza ki a használni kívánt végződést. A Fájlnevek végződése segítségével különböztethetők meg az automatikusan létrehozott és azonos nevű naplófájlok.
      Kezdő sorszám | Itt állítható be az automatikus fájlszámozás kezdő sorszáma, ha a Fájlnevek végződése listában az nnnnnn beállítást választja.
    • Naplófájl típusa. Válassza ki a listából a naplófájlhoz használni kívánt formátumot.
      Naplófájl formátuma | Leírás | Érvényes
      Szövegfájl—CSV | Ez a beállítás vesszővel tagolt naplófájlt határoz meg (.csv kiterjesztéssel). Ebben a formátumban exportálhatja a naplóadatokat táblázatkezelő programba. | Számlálónaplók
      Szövegfájl—TSV | Ez a beállítás tabulátorral tagolt naplófájlt határoz meg (.tsv kiterjesztéssel). Ebben a formátumban exportálhatja a naplóadatokat táblázatkezelő programba. | Számlálónaplók
      Bináris fájl | Ez a beállítás szekvenciális, bináris formátumú naplófájlt határoz meg (.blg kiterjesztéssel). Akkor használja ezt a formátumot, ha váltakozó adatpéldányokat szeretne rögzíteni (olyan adatpéldányokat, amelyek a napló elindulása után megállnak és újraindulnak). Nem bináris fájlformátumokban nem tárolhatók olyan példányok, amelyek nincsenek jelen a naplózás teljes időtartama alatt. | Számlálónaplók
      Bináris körkörös fájl | Ez a beállítás körkörös, bináris formátumú naplófájlt határoz meg (.blg kiterjesztéssel). Ebben a fájlformátumba rögzíthet folyamatosan adatokat ugyanabba a naplófájlba oly módon, hogy az új adatok felülírják a régebbi bejegyzéseket. | Számlálónaplók
      Körkörös követési fájl | Ez a beállítás körkörös követési naplófájlt határoz meg (.etl kiterjesztéssel). Ebben a fájlformátumba rögzíthet folyamatosan adatokat ugyanabba a naplófájlba oly módon, hogy az új adatok felülírják a régebbi bejegyzéseket. | Követési naplók
      Szekvenciális követési fájl | Ez a beállítás szekvenciális követési naplófájlt határoz meg (.etl kiterjesztéssel), amely mindaddig gyűjti az adatokat, amíg el nem éri a felhasználó által meghatározott korlátot; ekkor a rendszer bezárja, majd új fájlba folytatja a naplózást. | Követési naplók
    • Megjegyzés. Ha szükséges, adjon meg egy megjegyzést vagy leírást a naplófájlhoz.
    • Naplófájl mérete. Az alábbi beállítások segítségével döntse el, hogy szeretné-e korlátozni a naplófájl méretét:
      • Maximális méret. Ha ezt a lehetőséget választja, az adatgyűjtés mindaddig folytatódik, amíg a naplófájl mérete el nem éri a lemezkvóták vagy az operációs rendszer által meghatározott korlátot.
      • Korlátozás. Ha méretbeli korlátot szeretne meghatározni a naplófájlhoz, adja meg a maximális méretet. (Számlálónapló esetén a maximális méretet kilobájtban kell megadni; ez legfeljebb két gigabájt lehet. Követési naplók esetén a maximális méretet megabájtban kell megadni.) Válassza ezt a beállítást, ha körkörös naplózást szeretne használni.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A Windows hibaüzenettel jelez, ha a rendelkezésre álló lemezterület egy megadott minimum alá csökken. Ha engedélyezi, hogy a fájl maximális méretűre növekedjen, vegye figyelembe a rendelkezésre álló lemezterületet és az érvényben lévő lemezkvótákat. Hiba történhet, ha elfogy a szabad terület a naplózás miatt. A Naplófájl mérete beállítás az Ütemezés lapon található az Amikor a naplófájl megtelt beállítással együtt működik.
  • Amikor kiválasztja a naplófájl méretének a korlátját, az Amikor a naplófájl megtelt beállítás szövegében megjelenik az itt megadott méretkorlát.
  • A Fájlnév azonosíthatja az azonos paraméterű naplófájlok egy csoportját.
  • A Fájlnevek végződése utótag lehet számsorozat vagy karakterlánc, amely a napló elindulásának dátumát és idejét jelzi. Ha például a „Napi_adatok” fájlnevet adja meg és a Teljesítménynaplók és riasztások szolgáltatás minden fájlnévhez a dátumot illeszti hozzá, a létrehozott fájlnevek a következők lesznek: Napi_adatok_980101, Napi_adatok_980102 stb.
  • A megjegyzés és a fájlnév megjelenik a Teljesítménynaplók és riasztások konzolablak részletek ablaktáblájában.

Kapcsolódó témakörök


Számlálók részleteinek megtekintése

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Számlálónaplók elemre.
  3. A részletek ablaktáblán kattintson duplán a számlálónaplóra.
  4. Kattintson a Hozzáadás gombra.
  5. A Teljesítményobjektum mezőben kattintson egy objektumra, majd a Teljesítményszámlálók mezőben kattintson egy számlálóra.
  6. Kattintson a Magyarázat gombra.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Amikor a Magyarázat gombra kattint, egy ablak jelenik meg, amely a kijelölt számláló leírását tartalmazza, például a számláló kiszámításának részletes leírását és hogy a teljesítményproblémák diagnosztizálásához hogyan használható. Ha információra van szüksége a Windows 2000 összes számlálójával kapcsolatban, tanulmányozza a Windows 2000 Performance Counter Help Reference (Counters.chm) című témakört a Windows 2000 Professional Resource Kit kiadvány lemezmellékletén.

Kapcsolódó témakörök


Számlálók eltávolítása a naplóból vagy riasztásból

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Számlálónaplók vagy a Riasztások elemre.
  3. A részletek ablaktáblán kattintson duplán a napló vagy a riasztás nevére.
  4. A Számlálók listában kattintson az eltávolítani kívánt számlálóra, majd kattintson az Eltávolítás gombra.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Napló vagy riasztás indítási vagy leállítási paraméterének meghatározása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Számlálónapló, a Követési napló vagy a Riasztások elemre.
  3. A részletek ablaktáblán kattintson duplán a napló vagy a riasztás nevére.
  4. Kattintson az Ütemezés fülre.
  5. A Naplózás indítása csoportban kattintson a következő lehetőségek egyikére:
    • Ha a naplót vagy riasztást kézzel szeretné indítani, kattintson a Kézzel választógombra. Ha ezt a lehetőséget választja, és el szeretné indítani a naplót vagy a riasztást, a részletek ablaktáblán kattintson a jobb oldali egérgombbal a napló nevére, majd kattintson az Indítás parancsra.
    • Ha a naplót vagy a riasztást adott időpontban szeretné indítani, kattintson az Ekkor választógombra, majd adjon meg egy időpontot és dátumot.
  6. A Naplózás leállítása csoportban kattintson a következő lehetőségek egyikére:
    • Ha a naplót vagy riasztást kézzel szeretné leállítani, kattintson a Kézzel választógombra. Ha ezt a beállítást választja, és le szeretné állítani a naplót vagy a riasztást, a részletek ablaktáblán kattintson a jobb oldali egérgombbal a napló nevére, majd kattintson a Leállítás parancsra.
    • Ha a naplót vagy a riasztást adott idő elteltével le szeretné állítani, kattintson az Ezután választógombra, majd adja meg az intervallumok számát és az intervallum típusát (nap, óra stb.).
    • Ha a naplót vagy a riasztást adott időpontban szeretné leállítani, kattintson az Ekkor választógombra, majd adjon meg egy időpontot és dátumot. (Az év mezőbe 4 karakter írható be, a többibe kettő.)
    • Ha akkor szeretné leállítani a naplót, ha a naplófájl betelik, a következő beállításokat használja:
      • Számlálónaplók esetén kattintson az Amikor a naplófájl megtelt választógombra. A fájlba mindaddig gyűlnek az adatok, amíg a fájl mérete el nem éri a Naplófájlok lapon a fájlméretre beállított korlátot (ez kilobájtban van megadva és legfeljebb 2 gigabájt lehet).
      • Követési naplók esetén kattintson az Amikor a(z) n MB-os napló megtelt választógombra. A fájlba mindaddig gyűlnek az adatok, amíg a fájl mérete el nem éri a Naplófájlok lapon a fájlméretre beállított korlátot (megabájtban).

      Ennek a beállításnak a használata esetén vegye figyelembe a rendelkezésre álló lemezterületet és az érvényes lemezkvótákat. Hiba történhet, ha a lemezen elfogy a szabad terület a naplózás miatt.

  7. Adja meg a naplók és a riasztások megfelelő tulajdonságait:
    • Naplók esetén a Naplófájl bezárásakor részen válassza ki a megfelelő beállítást:
      • Ha körkörös (folyamatos, automatizált) számláló- vagy követési naplózást szeretne beállítani, jelölje be az Új naplófájl indítása jelölőnégyzetet.
      • Ha egy programot szeretne futtatni a naplózás befejezése után (ha például át szeretné másolni a kész naplófájlokat egy archív helyre), jelölje be A következő parancs indítása jelölőnégyzetet. Írja be a futtatni kívánt program elérési útvonalát és fájlnevét, vagy a program megkereséséhez kattintson a Tallózás gombra.
    • Riasztások esetén az Amikor egy figyelmeztetési vizsgálat befejeződik alatt jelölje be az Új vizsgálat indítása jelölőnégyzetet, ha folyamatos riasztásvizsgálatot szeretne beállítani.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha a napló kézi, vagy adott időpontban történő leállítását állítja be, az Új naplófájl indítása beállítás nem használható.

Kapcsolódó témakörök


Számlálónapló, követési napló vagy riasztás kézi indítása és leállítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Számlálónapló, a Követési napló vagy a Riasztások elemre.
  3. A részletek ablaktáblán kattintson a jobb oldali egérgombbal annak a naplónak vagy riasztásnak a nevére, amelyiket el szeretné indítani vagy le szeretné állítani, majd a naplózó vagy riasztó tevékenység megkezdéséhez kattintson az Indítás parancsra, illetve a tevékenység befejezéséhez kattintson a Leállítás parancsra.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Eltelhet egy kis idő, amíg a napló vagy a riasztás elindul vagy leáll, amit az ikon színváltozása jelez (az elindítottat jelző zöldről a leállítottat jelző pirosra, vagy fordítva).


Teljesítménynaplók és riasztások – áttekintés

A Teljesítménynaplók és riasztások szolgáltatással naplózhatók a számlálók és az esemény követési adatok, emellett teljesítmény riasztások generálhatók. A számlálónaplók segítségével a hardverhasználattal, illetve a rendszerszolgáltatásokkal kapcsolatos adatokat helyi vagy távoli számítógépről is rögzíteni lehet. A naplózás történhet kézzel, vagy a felhasználó által meghatározott ütemezés szerint, automatikusan. Folyamatos naplózásra is lehetőség van (ekkor a fájlméretet és az időtartamot be kell állítani). A naplózott adatok megjeleníthetők a Rendszerfigyelő kijelzőjén, vagy elemzés és jelentéskészítés céljából exportálhatók táblázatkezelő programokba vagy adatbázisokba.

Nyomkövetési naplókkal rögzíthetők meghatározott események, például a lemez I/O műveletek és a laphibák. Amikor az esemény bekövetkezik, a szolgáltató elküldi az adatokat a naplózást végző szolgáltatásnak.

Beállítható riasztás egy számlálóhoz, ezzel meghatározva, hogy üzenetküldés, programfutatás vagy naplózás elindítása történjen, ha a kiválasztott számláló értéke meghaladja a megadott értéket, vagy az alá esik.

Kapcsolódó témakörök


Nyomkövetési naplók puffereinek megadása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Követési napló elemre.
  3. A részletek ablaktáblán kattintson duplán a naplóra.
  4. Kattintson a Speciális fülre.
  5. A Pufferméret mezőben adja meg a nyomkövetési adatokhoz használni kívánt puffer méretét kilobájtban.
  6. A Minimum mezőben adja meg a nyomkövetési adatokhoz használni kívánt pufferek legkisebb számát.
  7. A Maximum mezőben adja meg a nyomkövetési adatokhoz használni kívánt pufferek legnagyobb számát.
  8. Ha azt szeretné, hogy a nyomkövetési szolgáltató meghatározott időközönként ürítse a puffereket, jelölje be az Adatok rendszeres átvitele a pufferekből a naplófájlba legalább jelölőnégyzetet, és adja meg az átviteli időközt másodpercben.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Nyomkövetési naplószolgáltatók és események meghatározása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson duplán a Teljesítménynaplók és riasztások elemre, majd kattintson a Követési napló lehetőségre.
  3. A részletek ablaktáblán kattintson duplán a naplóra.
  4. A telepített szolgáltatók és azok állapotának megtekintéséhez (engedélyezve vannak-e), kattintson a Szolgáltatók állapota gombra. Alapértelmezés szerint a Nem rendszerszintű szolgáltatók választógomb van kiválasztva, hogy a nyomkövetési naplózás által okozott teljesítményigény-többlet minimális legyen.
  5. Ha A rendszerszintű szolgáltató által naplózott események választógombra kattint, a rendszer az alapértelmezett szolgáltatót (Windows kernel trace provider) használja a folyamatok, szálak és más tevékenységek figyeléséhez. A naplózni kívánt események meghatározásához jelölje be a megfelelő jelölőnégyzeteket.
  6. Ha a Nem rendszerszintű szolgáltatók választógombra kattint, tetszőleges adatszolgáltató választhat – például ha saját szolgáltatót írt. Használja szükség szerint a Hozzáadás és az Eltávolítás gombokat.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A fájlrészletek és a laphibák nyomkövetési naplózása nagy adatmennyiséget eredményezhet. Ezért a fájlrészleteket és a laphibákat nem ajánlott két óránál hosszabb ideig naplózni.
  • Minden nyomkövetési szolgáltatónak egyszerre csak egy példánya engedélyezhető.


A Teljesítménynaplók és riasztások felhasználói felülete

A Teljesítménynaplók és riasztások beépülő modulban számlálónaplók, követési naplók és riasztások beállításai határozhatók meg. A konzolablak részletek ablaktáblájában a már létrehozott naplók és riasztások láthatók. Egyidejűleg több napló és riasztás is futhat. Minden napló és riasztás a felhasználó által meghatározott mentett konfiguráció. Ha a napló automatikus indulását és leállását állította be, egyetlen naplóhoz több naplóadatfájl jöhet létre. Például ha minden nap tevékenységéről külön naplófájlt szeretne készíteni, az egyik fájl érjen véget 23:59-kor, a következő fájl pedig kezdődjön a következő napon 0:00-kor. Az alábbi táblázatban a részletek ablaktáblában látható oszlopok lekérdezési adatait foglalja össze.

Oszlop | Leírás
Név A napló vagy riasztás neve. Használjon “barátságos nevet”, amely leírja a gyűjtött adatok típusát és a figyelt feltételeket. Egyetlen napló több naplófájlt hozhat létre.

Megjegyzés

  • A számlálónaplózáshoz meg van határozva egy mintabeállítás, amelynek a neve Rendszer áttekintése. A naplózást kezdheti ezekkel a beállításokkal, vagy megadhat saját beállításokat.
Megjegyzés | A napló vagy riasztás bármilyen leíró adata lehet.
Naplófájl típusa | A naplófájl formátuma. Riasztás esetén a típus mindig riasztás; követési napló esetén ez mindig szekvenciális. Naplók esetén a típus lehet bináris, bináris körkörös, szövegfájl-CSV (vesszővel tagolt szöveg) vagy szövegfájl-TSV (tabulátorral tagolt szöveg).
Naplófájl neve | A napló által létrehozott fájlok elérési útvonala és alap fájlneve. Az alap fájlnév az új fájlok automatikus elnevezéséhez szükséges.

Az egyes naplókhoz meghatározott paraméterek megtekintéséhez kattintson duplán a naplóra a listában. A megjelenő párbeszédpanelen kiválaszthatja a naplófájlok nevét, a naplózás időpontját, és hogy mely teljesítményobjektumok és számlálók kerüljenek bele a naplóba.

Ha egy napló pillanatnyilag fut, és adatokat gyűjt (a naplóhoz vagy riasztáshoz meghatározott ütemezés alapján), zöld ikon jelenik meg a napló vagy a riasztás mellett. Ha piros ikon látható, akkor a napló vagy riasztás be van állítva, de pillanatnyilag nem fut.

Megjegyzés

  • Több típusú napló is futhat egyszerre. Egyetlen napló több naplófájlt is létrehozhat, ha az újraindítás beállítás ki van választva, vagy ha a felhasználó többször elindítja és leállítja a naplózást. Ezek az egyedi naplófájlok azonban nem láthatók a konzolablakban. Ezeknek a fájloknak a listáját a Windows Intéző segítségével tekintheti meg.


Számlálók hozzáadása a Rendszerfigyelő konzolhoz

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Számláló hozzáadása parancsra.
  3. Ha a figyelőkonzolt futtató számítógépet szeretné figyelni, kattintson a Helyi számlálók használata választógombra.

    Adott számítógép figyeléséhez, függetlenül attól, hogy a figyelőkonzol hol fut, kattintson a Más számítógép számlálói választógombra, és adja meg a számítógép nevét (alapértelmezés szerint a helyi számítógép neve jelenik meg).

  4. A Teljesítményobjektum listában válassza ki a figyelni kívánt objektumot. Alapértelmezés szerint a Processzor objektumot jelöli ki a rendszer.
  5. Az összes számláló figyeléséhez kattintson a Minden számláló választógombra.

    Ha csak egyes számlálókat szeretne figyelni, kattintson a Számlálók választása listából választógombra, majd válassza ki a figyelni kívánt számlálókat. Alapértelmezés szerint A Processzor kihasználtsága (%) számlálót jelöli ki a rendszer.

  6. Ha a kiválasztott számlálók minden példányát figyelni szeretné, kattintson a Minden példány választógombra.

    Ha csak adott példányokat szeretne figyelni, kattintson a Példányok választása listából választógombra, majd válassza ki a figyelni kívánt példányokat. Alapértelmezés szerint a _Total objektum van kijelölve.

  7. Kattintson a Hozzáadás gombra.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha a távoli számítógépen levő objektumot választ ki, a Rendszerfigyelő csak egy kis késleltetéssel frissíti a számítógépen található objektumok listáját.
  • Ha a figyelőkonzolt exportálás céljából hozza létre, fontos, hogy a Helyi számlálók használata választógombot válassza. Ellenkező esetben a Rendszerfigyelő a szövegmezőben megadott számítógép adatait használja függetlenül attól, hogy a konzolfájl hol található.
  • A számláló leírásának megtekintéséhez a Teljesítményszámlálók listában kattintson a számláló nevére, majd kattintson a Magyarázat gombra.
  • Ha egy számláló összes példányának értékeit szeretné összegezni, válassza a _Total példányt.
  • Ha az adatokat nem egy naplóból állítja be, a listában csak aktív példányok választhatók ki.
  • Alapértelmezés szerint a számlálók a példány nevével és az indexével együtt jelennek meg. A szolgáltatásnak a kikapcsolásához kattintson a jobb oldali egérgombbal a részletek ablaktáblára, kattintson a Tulajdonságok parancsra, majd törölje a Duplikált számlálópéldányok engedélyezése jelölőnégyzet jelölését.
  • Bizonyos objektumtípusok több példánnyal rendelkeznek. Ha például a rendszerben több processzor található, a Processzor objektumtípusnak több példánya lesz. A Fizikai lemez objektumtípusnak két példánya van, ha a rendszerben két lemez található. Néhány objektumtípusnak, például a Memória vagy a Kiszolgáló objektumtípusnak, csak egyetlen példánya van. Ha az objektumtípusnak több példánya van, akkor mindegyik példány statisztikájának követéséhez megadható számláló, vagy sok esetben akár az összes példányhoz egyszerre.
  • Ha ugyanannak a számlálónak két példányát választja ki, például ha egy folyamat több szálát figyeli, figyeljen arra, hogy a példányokhoz rendelt példányindex sorszáma megváltozhat, például amikor egy szál elindul vagy megáll. Nem feltételezhető, hogy az index mindvégig ugyanazt a szálat jelzi a folyamat élettartama során.
  • A számlálókhoz hozzárendelt alapértelmezett megjelenítési tulajdonságok (például a szín, a vonalstílus és -szélesség, valamint a grafikon beosztása) a Rendszerfigyelő tulajdonságai párbeszédpanel Adat lapján módosíthatók. Az Adat lap megjelenítéséhez kattintson a jobb oldali egérgombbal a részletek ablaktáblára, majd kattintson a Tulajdonságok parancsra.
Kapcsolódó témakörök


A Rendszerfigyelő beállításainak gyors áttekintése

Az itt bemutatott összes beállítást úgy kezdje, hogy a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára kattint, majd a bal oldalival a Tulajdonságok parancsra.

Ennek a hozzáadásához vagy módosításához | Ezt a lapot használja
Nézet típusa: grafikon, hisztogram vagy jelentés | Általános
Objektumok, számlálók és példányok (hozzáadása vagy törlése) | Adat Megjegyzés: Úgy is hozzáadhat számlálókat, ha a részletek ablaktáblára a jobb oldali egérgombbal kattint, majd a Számláló hozzáadása parancsra kattint, vagy ha az eszközsáv Hozzáadás gombjára kattint. Számlálók törléséhez használja az Adat lapon található Eltávolítás gombot, a billentyűzet DELETE billentyűjét vagy az eszközsáv Törlés gombját. Ha az összes számlálót törölni szeretné, és újakat szeretne megadni, kattintson az eszközsáv Új számlálókészlet gombjára.
A megjelenített adatok forrása: a grafikon pillanatnyi adatbemenete, pillanatnyi adatbemenet egy naplófájlból, archivált adatbemenet egy naplófájlból | Forrás Megjegyzés: Ha adatforrásként naplófájlt szeretne használni, használhatja a Naplófájl adatainak megtekintése gombot az eszközsávon, illetve valós idejű adatok megtekintéséhez használhatja a Jelenlegi aktivitás megtekintése gombot.
A naplófájl időtartománya, és az időtartomány megtekintése | Forrás
Frissítési gyakoriság | Általános Megjegyzés: Kézi mintavételezéshez használhatja az eszközsáv Képernyő fagyasztása és Adatok frissítése gombját.
Jelentés vagy hisztogram értéktípusa (minimum, maximum, átlag) | Általános
Számlálók jelmagyarázatának megjelenítése | Általános
A számláló utolsó, minimum és maximum értékeinek megjelenítése (az értéksáv); több számlálópéldány engedélyezése | Általános
Szín, szélesség, stílus vagy grafikon vonal | Adat
A számláló adatainak skálája | Adat
A grafikonterület körülötti eredmények ablaktábla háttérszíne, az adatmegjelenítő terület színe | Színek
A grafikon címe | Grafikon
A függőleges tengely neve, vízszintes és függőleges rácsvonalak, valamint a tengelyek felső és alsó határa | Grafikon
A grafikonon vagy a jelmagyarázatban megjelenő betűk színe | Színek
Betűtípus, -szín és -stílus | Betűtípus
Rácsvonalak színe, az időzítősáv színe | Színek
Keret stílusa, a grafikon ablak megjelenése | Általános
Eszköztár | Általános

Megjegyzés

  • Ha a Jelenlegi jelentésadat-típustól különböző típust használ valós idejű adatok figyeléséhez, az többletterhelést okoz, mivel a rendszernek minden mintavételkor számításokat kell végeznie.


Számlálóadatok másolása a Rendszerfigyelő példányai között

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. A Rendszerfigyelő részletek ablaktábláján kattintson az eszköztár Tulajdonságok másolása gombjára.

    Ez az összes jelenlegi tulajdonságot a Windows vágólapra másolja HTML formátumban.

  3. Nyissa meg a Rendszerfigyelő másik példányát, majd kattintson az eszköztár Számlálólista beillesztése gombjára a vágólapon levő számlálóútvonal-adatoknak a jelenlegi ablakba történő másolásához.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.


Egyéni figyelőkonzol létrehozása

  1. Nyissa meg a Microsoft Management Console (MMC) segédprogramot.
  2. Kattintson a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsára.
  3. Az Egyedülálló lapon kattintson a Hozzáadás gombra.
  4. A beépülő modulok listájában kattintson az ActiveX-vezérlő elemre, majd kattintson a Hozzáadás gombra.
  5. Az ActiveX vezérlő beszúrása varázslóban kattintson a Tovább gombra.

    A következő párbeszédpanel csak egy kis idő elteltével jelenik meg; ez teljesen normális.

  6. A Vezérlőkategóriák listában válassza ki a Minden kategória elemet.
  7. A Vezérlőtípusok listában kattintson a System Monitor Control elemre.
  8. Kattintson a Tovább gombra.

    A System Monitor control a Rendszerfigyelő funkcióit biztosítja.

  9. A Válasszon egy nevet az ActiveX vezérlő számára mezőbe írja be a vezérlő nevét, majd kattintson a Befejezés gombra.

Megjegyzés

  • Az MMC megnyitásához kattintson a Start menü Futtatás parancsára, majd írja be az mmc parancsot.
  • Egyedi konzol létrehozása akkor lehet hasznos, ha a Rendszerfigyelő konzolt az Eseménynapló konzollal vagy más eszközzel együtt ugyanabba a konzolba szeretné helyezni.


Számlálók és számlálótulajdonságok módosítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Tulajdonságok parancsra.
  3. Az Adat lapon adja meg a használni kívánt beállításokat:
    • Hozzáadás. Megnyitja a Számláló hozzáadása párbeszédpanelt, ahol kiválaszthatók a hozzáadni kívánt számlálók.
    • Eltávolítás. Eltávolítja a számlálólistában kijelölt számlálót.
    • Szín. Módosítja a kijelölt számláló színét.
    • Skála. Módosítja a kijelölt számláló megjelenítési skáláját grafikon vagy hisztogram nézetben. A számlálóértékek exponenciálisan skálázhatók .0000001 és 1000000.0 között. Úgy módosítsa a számláló skálabeállításait, hogy a számláló adatai a grafikonon jobban láthatók legyenek. A skála módosítása nincs hatással az értéksávban megjelenő értékekre.
    • Szélesség. Módosítja a kijelölt számláló vonalszélességét. A vonalszélesség meghatározhatja a rendelkezésre álló vonalstílusokat.
    • Stílus. Módosítja a kijelölt számláló vonalstílusát. Csak akkor választható ki stílus, ha az alapértelmezett vonalszélességet használja.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Számláló törlése a Rendszerfigyelő konzolról

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. A Rendszerfigyelő részletek ablaktábláján kattintson a számláló nevére a jelmagyarázatban.
  3. Nyomja le a DELETE gombot.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A Rendszerfigyelő tulajdonságai párbeszédpanel Adat lapjának segítségével is törölhető számláló.
  • Az összes számláló törléséhez kattintson az eszközsáv Új számlálókészlet gombjára.
  • Ha a képernyőről az összes adatmintát törölni szeretné, kattintson a Képernyő törlése gombra. (Ez a gomb nem érhető el, ha naplózott adatokat jelenít meg.)

Kapcsolódó témakörök


Mintavételi beállítások módosítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Tulajdonságok parancsra.
  3. Az Általános lapon adja meg a kívánt mintavételi beállítást.
    • Ha automatikusan szeretne mintákat venni szabályos időközönként, jelölje be az Automatikus frissítés jelölőnégyzetet, majd a másodpercenként mezőbe írja be az időköz hosszát másodpercben. Az alapértelmezett érték egy másodperc.
    • Ha kézzel szeretne mintákat venni, törölje az Automatikus frissítés jelölőnégyzet jelölését. A mintavételezés kézi indításához az eszközsáv Képernyő fagyasztása gombja is használható.

      Ha a kézi mintavételezést választotta, a minta begyűjtéséhez használja az Adatok frissítése gombot.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha a képernyőről az összes adatmintát törölni szeretné, az eszközsávon kattintson a Képernyő törlése gombra. (Ez a gomb nem érhető el, ha naplózott adatokat jelenít meg.)

Kapcsolódó témakörök


Átváltás grafikon nézetből

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a Hisztogram megtekintése vagy a Jelentés megtekintése gombra az eszközsávon.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A megjelenítési típus úgy is módosítható, ha megváltoztatja a Rendszerfigyelő tulajdonságai párbeszédpanel Általános lapjának Nézet beállítását.
  • A számláló adatai és elérési útja másképpen jelenik meg egy Rendszerfigyelő jelentésben, mint egy grafikonon. Jelentés nézetben az adatok oszlopokban jelennek meg, ahol a számlálók neve és értei teljesítményobjektumok szerint vannak csoportosítva, valamint minden példány és a hozzá tartozó adatok külön oszlopban jelennek meg.

    A grafikon értéksávjában látható értékek nem jelennek meg jelentés nézetben. A Rendszerfigyelő tulajdonságai párbeszédpanel Általános lapján kiválasztható, hogy milyen érték jelenjen meg a jelentésben: utolsó (alapértelmezett), jelenlegi, átlagos, minimum vagy maximum. Az alapértelmezett érték jelenlegi működés esetén a jelenlegi értéket jelenti, naplózott működés esetén pedig az átlagos értéket.

  • Ha az átlag, a minimum vagy a maximum beállítást választja Jelentés nézetben, a rendszer az értékeket minden egyes mintavételkor kiszámítja. Ez kis teljesítménytöbblet-igényt okoz.
  • Hisztogram nézetben vonalak helyett sávok jelennek meg. A képernyő többi része ugyanolyan, mint grafikon nézetben.
  • Ha ki van jelölve, az eszközsáv minden nézetben látható.

Kapcsolódó témakörök


Számlálók részleteinek megtekintése

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Számláló hozzáadása parancsra.
  3. A Teljesítményobjektum listában kattintson egy objektumra.
  4. A Teljesítményszámlálók listában kattintson arra a számlálóra, amelyikről bővebb információt szeretne.
  5. Kattintson a Magyarázat gombra.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A Rendszerfigyelő konzolban a grafikon vonalai és a vonalhoz tartozó számláló adatai könnyedén összepárosíthatók. Ehhez kattintson duplán a vonal egy pontjára. A számláló megjelenik a jelmagyarázatban. Ha a diagram vonalai közel vannak egymáshoz, próbáljon olyan helyet keresni a diagramon, ahol távolabb vannak egymástól. Egyébként nem biztos, hogy a Rendszerfigyelő pont azt az értéket jeleníti meg, amelyikre kíváncsi.
  • Ha bővebb információra van szüksége a teljesítményszámlálókkal kapcsolatban, tanulmányozza a Windows 2000 Performance Counter Reference (Counters.chm) részt a Windows 2000 Resource Kit lemezmellékletén.


Számlálóadatok kiemelése

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. A számlálók listájában kattintson arra a számlálóra, amelyet ki szeretne emelni.
  3. Kattintson a Kijelölés gombra, vagy nyomja meg a CTRL+H billentyűkombinációt.

    A kijelölt számlálóhoz tartozó színes vonal vastag vonalra változik. Fehér vagy világos színű hátterek (amelyet a BackColor tulajdonság határoz meg) esetén, a vonal fekete lesz. Ellenkező esetben a vonal fehér lesz.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha a Rendszerfigyelő vezérlőt a Microsoft Word alkalmazásban használja, figyeljen arra, hogy a Microsoft Word alapértelmezett billentyűbeállításai ütközhetnek a Rendszerfigyelő konzolban használt CTRL+H billentyűkombinációval. Lehet, hogy ezeket meg kell változtatnia, ha a Rendszerfigyelő vezérlőt (Sysmon.ocx a rendszergyökér\System32 mappában) a Microsoft Word programban használja.


A Rendszerfigyelő vezérlő beszúrása Word dokumentumba

  1. Nyisson meg egy Word dokumentumot és helyezze a beviteli pontot oda, ahová a vezérlőt be szeretné szúrni.
  2. A Nézet menüben mutasson az Eszköztárak pontra, majd kattintson a Vezérlők eszköztára parancsra.
  3. Kattintson a További vezérlők ikonra, majd kattintson a Rendszerfigyelő vezérlő elemre.

Megjegyzések

  • A Rendszerfigyelő vezérlőt a dokumentum kijelölt helyére illeszti be a rendszer. A vezérlő tervezési módban van, ami azt jelenti, hogy használható a Visual Basic szerkesztő segítségével. A vezérlő átveszi az alkalmazás környezeti tulajdonságait. Ez azt jelenti, hogy a vezérlő BackColor, ForeColor és Font beállításai alapértelmezés szerint a Word dokumentum beállításait veszik fel. A beállítások módosításához vagy számlálók hozzáadásához kattintson a Kilépés a tervezésből ikonra a tervezői módból való kilépéshez.
  • Miután hozzáadta és tetszése szerint beállította a grafikonokat, kinyomtathatja a teljesítményadatokat vagy mentheti a dokumentumot a Microsoft Word által biztosított megfelelő parancsok használatával.
  • A Microsoft Word 97-es, vagy újabb verzióját használja.

Kapcsolódó témakörök


A Rendszerfigyelő eszköztára

A Rendszerfigyelő eszköztára a gyakran használt funkciók könnyebb eléréséhez tartalmaz gombokat. Az alábbi táblázatban a gombok és a hozzájuk rendelt funkciók leírása látható.

Gomb | Funkció
Új számlálókészlet | Új számlálókészlet
Képernyő törlése | Képernyő törlése
Jelenlegi aktivitás megtekintése | Jelenlegi adatok megtekintése
Naplófájl adatainak megtekintése | Naplófájl adatainak megtekintése
Grafikon megtekintése | Grafikon megtekintése
Hisztogram megtekintése | Hisztogram megtekintése
Jelentés megtekintése | Jelentés megtekintése
Hozzáadás | Hozzáadás
Törlés | Törlés
Számlálólista beillesztése | Számlálólista beillesztése
Tulajdonságok másolása | Tulajdonságok másolása
Tulajdonságok | Tulajdonságok
Képernyő fagyasztása | Képernyő fagyasztása
Adatok frissítése | Adatok frissítése


Másik számítógép figyelése

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Számláló hozzáadása parancsra.
  3. Kattintson a Más számítógép számlálói választógombra, majd a beviteli mezőben adja meg a számítógép nevét.

    A Rendszerfigyelő a megadott számítógép számlálóit használja függetlenül attól, hogy a Rendszerfigyelő hol fut.

  4. A Teljesítményobjektum listában válassza ki a figyelni kívánt objektumot.
  5. A Teljesítményszámlálók listában kattintson egy vagy több számlálóra.
  6. Ha a Rendszerfigyelő használata közben az összes elérhető számlálópéldányt használni szeretné, kattintson a Minden példány választógombra.

    Ha csak egyes számlálópéldányokat szeretne használni, kattintson a Példányok választása listából választógombra, majd válassza ki a használni kívánt példányokat.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha nem rendelkezik megfelelő engedéllyel a számítógép figyeléséhez, hibaüzenet jelenik meg, viszont a számláló megjelenik a hisztogram vagy diagram jelmagyarázatában, de nem tartalmaz adatokat.
  • Ha a távoli számítógépen levő objektumot választ ki, a Rendszerfigyelő csak egy kis késleltetéssel frissíti a számítógépen található objektumok listáját.
  • Ha a figyelni kívánt számláló nem jelenik meg, előfordulhat, hogy a számlálóobjektumot biztosító szolgáltatás nincs engedélyezve vagy telepítve a másik számítógépen, és a hozzá tartozó adatok megfigyelése előtt azt hozzá kell adni.


A Hálózati szegmens számlálók engedélyezése

A Hálózati szegmens objektumszámlálók teljesítményadatainak összegyűjtéséhez telepíteni kell a Hálózatfigyelő illesztőprogramját. További tudnivalókért tanulmányozza A Hálózatfigyelő illesztőprogramjának telepítése című témakört.


Teljesítményadatok nyomtatása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Az ALT+PRINT SCREEN billentyűkombináció megnyomásával készítsen másolatot az aktív ablakról.
  3. Kattintson a Start menüre, mutasson a Programok, majd Kellékek pontra, végül kattintson a Paint parancsra.
  4. Kattintson a Szerkesztés menü Beillesztés parancsára.

    Ha megjelenik a következő figyelmeztető üzenet: A vágólapon lévő kép nagyobb, mint a bitkép. Szeretné a bitképet megnövelni?, kattintson az Igen gombra.

  5. Kattintson a Fájl menü Nyomtatás parancsára.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A teljesítményadatok a következő művelettel is nyomtathatók:
    • Adja hozzá a Rendszerfigyelő vezérlőt egy Microsoft Office alkalmazáshoz, például a Microsoft Wordhöz vagy a Microsoft Excelhez, majd nyomtassa ki abból a programból.
    • Mentse a teljesítményadatokat HTML fájlba, majd nyomtassa ki azt az Internet Explorerből vagy más alkalmazásból.
    • Importálja a naplófájlt vesszővel tagolt (.csv) vagy tabulátorral tagolt (.tsv) formátumban Microsoft Excel munkafüzetbe, majd nyomtassa ki onnan.

Kapcsolódó témakörök


Figyelőkonzol mentése

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. A Rendszerfigyelő konzollal vagy a Teljesítménynaplók és riasztások valamelyik eszközének segítségével válassza ki az eszköz kívánt beállításait.
  3. Kattintson a Konzol menü Mentés másként parancsára, majd adja meg a konzol nevét. A fájl tárolására használt alapértelmezett mappa a gyökérkötet System32 mappája.
  4. Kattintson a Mentés gombra.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Grafikon adatainak mentése HTML oldalként

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Adjon számlálókat a grafikonhoz.
  3. A megjelenő grafikonra kattintson a jobb oldali egérgombbal, majd kattintson a Mentés másként parancsra.
  4. A Mentés másként párbeszédpanelen adja meg az új HTML fájl nevét és elérési útvonalát. A fájl alapértelmezett tárolási helye a gyökérkötet Dokumentumok mappája.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • HTML fájlból is importálhatók a számlálóadatok a Rendszerfigyelő konzolba, vagy a Rendszerfigyelő összes tulajdonsága HTML fájlba exportálható a Windows vágólap segítségével. Használja az eszközsáv Tulajdonságok másolása gombját a Rendszerfigyelő konzolon jelenleg megjelenített számlálók tulajdonságainak Windows vágólapra történő másolásához. Használja az eszközsáv Számlálólista beillesztése gombját a vágólapon található tulajdonságoknak a jelenlegi ablakba történő átviteléhez.

Kapcsolódó témakörök


Napló- vagy riasztási beállítások mentése HTML oldalként

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Hozzon létre egy naplót vagy riasztást.
  3. A részletek ablaktáblán kattintson a jobb oldali egérgombbal a napló vagy a riasztás nevére, majd kattintson a Beállítások mentése másként parancsra. Alapértelmezés szerint a rendszer a beállításokat a felhasználó személyes alapértelmezett mappájába menti, ami általában a Dokumentumok mappa.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


A háttér, a grafikon és a szöveg színének módosítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Tulajdonságok parancsra.
  3. A Színek lap Tulajdonságnév mezőjében adja meg azt az attribútumot, amelynek a színét módosítani szeretné. A következő attribútumok választhatók:
    • BackColorCtl. Az a háttérszín, amely az adatokat megjelenítő ablakterület körül látható.
    • BackColor. A számlálóadatokat megjelenítő ablakterület háttérszíne.
    • ForeColor. A szöveg színe.
    • GridColor. A vízszintes és függőleges rácsvonalak színe.
    • TimerBarColor. Az idősáv színe.
  4. Az attribútumhoz a következő műveletekkel rendelhető szín:
    • Kattintson arra a színű gombra, amilyen színt hozzá szeretne rendelni az attribútumhoz.
    • Válasszon ki egy képernyőelemet a Rendszer szín listában. Ha egy képernyőelemet választ ki, a kijelölt attribútum ugyanolyan színű lesz, mint a képernyőelem. A képernyőelemek színét úgy határozhatja meg, ha duplán kattint a Vezérlőpult Képernyő ikonjára.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Betűtípus tulajdonságainak módosítása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Tulajdonságok parancsra.
  3. A Betűtípusok lapon válassza ki a kívánt beállításokat. A módosítható beállítások a Betűkészlet, a Betűstílus, a Méret és az Effektusok.

Megjegyzés

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.

Kapcsolódó témakörök


Címek, rácsvonalak és egyéb attribútumok hozzáadása

  1. Nyissa meg a Teljesítmény beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Tulajdonságok parancsra.
  3. A Diagram lapon adja meg a kívánt beállításokat.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • A skála alapértelmezett minimum és maximum értéke 0 és 100.
  • A rácsvonalak színe a Színek lapon módosítható.
  • Jelmagyarázat, statisztika vagy eszközsáv az Általános lapon vehető fel vagy távolítható el.
  • A keret stílusa vagy megjelenése az Általános lapon módosítható.

Kapcsolódó témakörök


A Rendszerfigyelő használata

A Rendszerfigyelő valós idejű kijelzőjén a felügyelt helyi és távoli számítógépen nyomon követhető a hardverhasználat és a rendszerszolgáltatások működése. A Rendszerfigyelővel grafikonok és hisztogramok rajzolhatók, emellett megtekinthetők az aktuális és a Számlálónaplók segítségével összegyűjtött, archivált adatok. Az alapértelmezett megjelenítés a vonalgrafikon.

Emellett a grafikonadatok elmenthetők HTML formátumban későbbi kinyomtatás vagy megjelenítés céljából.

Kapcsolódó témakörök


A Windows NT 4.0 Teljesítményfigyelő beállításfájljainak használata

  • Írja be a parancssorba a következő parancsot:

    perfmon.exe fájlnév,

    ahol a fájlnév a használni kívánt beállításfájl neve.

Megjegyzések

  • A parancs a Windows 2000 Teljesítmény konzolját a Windows NT 4.0 Teljesítményfigyelő beállításfájljából származó beállításokkal nyitja meg.
  • Ez csak a következő típusú Windows NT 4.0 Teljesítményfigyelő beállításfájlok esetén működik: diagram (.pmc), jelentés (.pmr), figyelmeztetés (.pma) és napló (.pml).
  • A Windows NT 4.0 beállításfájl Rendszerfigyelőben történő megjelenítéséhez a rendszer átmenetileg átalakítja a fájlt a Rendszerfigyelővel történő használathoz, majd a konzol elindulásakor eldobja az átalakított verziót. Ha a beállításfájlt a továbbiakban is szeretné használni a Rendszerfigyelő konzolhoz, írja be a következő parancsot:

    perfmon.exe /HTMLFILE:átalakított_fájl beállításfájl

    ahol az átalakított_fájl az átalakított fájl neve, a beállításfájl pedig az eredeti Windows NT 4.0 beállításfájl neve.


Teljesítményadatok gyűjtése a Windows Management Instrumentation (WMI) segítségével

  • Írja be a parancssorba a következő parancsot:

    mmc.exe perfmon.msc /s /sysmon_wmi

Megjegyzések

  • Ez az eljárás a teljesítményadatokat nem a rendszerleíró adatbázisból, hanem a WMI-n keresztül gyűjti.
  • A művelet úgy is végrehajtható, ha a következő parancsot írja be:

    perfmon.exe /wmi


A használni kívánt számlálók kiválasztása

Olvassa el az alábbi témaköröket annak meghatározásához, hogy mely számlálókat érdemes kiválasztani az adott erőforrás vagy szolgáltatás használatának megfigyeléséhez, és hogy hogyan szüntethetők meg a szűk keresztmetszetek.

  • A memória szűk keresztmetszeteinek feltárása
  • A lemezerőforrások szűk keresztmetszeteinek feltárása
  • A processzorkapacitás szűk keresztmetszeteinek feltárása
  • A hálózat szűk keresztmetszeteinek feltárása
  • A nyomtatókapacitás szűk keresztmetszeteinek feltárása


A Rendszerfigyelő kezelőfelülete

A Teljesítmény beépülő modul megnyitásakor alapértelmezés szerint üres grafikus terület és egy eszközsáv jelenik meg. Ha hozzáad egy számlálót a diagramhoz, rövid idő elteltével (a kiválasztott frissítési időtartamtól függően) a Rendszerfigyelő megjeleníti a számláló értékeit a grafikus területen. Az adatok frissíthetők automatikusan vagy igény szerint; igény szerinti frissítés esetén az Adatok frissítése gomb segítségével indítható el és állítható le az adatgyűjtés. Az összes adat képernyőről történő eltávolításához kattintson a Képernyő törlése gombra.

A kiválasztott számlálók neve és a hozzájuk tartozó adatok a diagram alatti oszlopokban láthatók. Ennek a neve jelmagyarázat. A jelmagyarázatban a következő adatok láthatók:

  • A számítógép, amelyen a Rendszerfigyelő fut.
  • Teljesítményobjektum.
  • Teljesítményszámláló.
  • Teljesítményobjektum példánya. Megjegyzés: alapértelmezés szerint a számláló példányai név és index szerint rendezve láthatók a listán. Az index a példány neve után látható, kettős kereszt (#) és szám jelzi. Az index megkönnyíti több példány megjelenítését, például ha egy folyamat több szálát akarja megjeleníteni. Az index megjelenítésének kikapcsolásához kattintson a diagramra a jobb oldali egérgombbal, kattintson a Tulajdonságok parancsra, majd törölje a jelölést a Duplikált számlálópéldányok engedélyezése jelölőnégyzetből.
  • Az egyes számlálók grafikus tulajdonságai.

Megjegyzés

  • A diagramon megjelenő vonal és a megjeleníteni kívánt adatok számlálójának párosításához kattintson duplán a vonalra. A számláló megjelenik a jelmagyarázatban. Ha a diagram vonalai közel vannak egymáshoz, próbáljon olyan helyet keresni a diagramon, ahol távolabb vannak egymástól. Egyébként nem biztos, hogy a Rendszerfigyelő pont a kívánt értéket jeleníti meg.

Az oszlopok fölött található az értéksáv, ahol a jelenleg kiválasztott számláló legutóbbi, minimális, maximális és átlagos értékei láthatók. Ezeket az értékeket a diagramon látható időtartam és minták alapján számítja ki a rendszer (ezt az Időtartam érték jelzi), nem pedig a figyelés kezdete óta eltelt idő alapján. Az értéksávban látható Időtartam érték a diagramon látható teljes eltelt időt jelenti (ez a frissítési időköztől függ). Az időzítővonal diagramon látható mozgása jelzi az egyes frissítési időközök elteltét. A frissítési időköztől függetlenül a diagramon 100 minta látható. A Rendszerfigyelő szükség esetén összesűríti a naplófájl adatait, hogy azok elférjenek a képernyőn. Ha a napló összesűrített adatait szerezné megtekinteni, kattintson a jobb oldali egérgombbal a diagramra, kattintson a Tulajdonságok parancsra, majd a Forrás lapon adjon meg rövidebb időtartományt. A rövidebb időtartományhoz kevesebb adat tartozik, ezért kevésbé valószínű, hogy egyes adatpontok nem jelennek meg.

A diagram következő jellemzői állíthatók be:

  • A megjelenítés típusa (amely lehet diagram, hisztogram vagy jelentés)
  • A részletek ablaktábla és az adatmegjelenítő terület háttérszíne
  • A megjelenített szöveg betűtípusának mérete, típusa és stílusa
  • A diagram rajzolásához használt vonal színe, szélessége és stílusa

Ha ki szeretné emelni egy adott számláló adatait, használja a kijelölés szolgáltatást. Ehhez használja a CTRL+H billentyűkombinációt, vagy az eszközsávon kattintson a Kijelölés gombra. A kijelölés bekapcsolt állapotában a kiválasztott számlálóhoz tartozó vonal vagy sáv színe a legtöbb háttér (beleértve az alapértelmezett hátteret is) esetén fehérre, illetve fehér vagy világos háttér esetén feketére változik.

Megjegyzés

  • A Microsoft Word alapértelmezett billentyűzetkiosztása ütközhet a Rendszerfigyelő által a kiemelésre használt CTRL+H billentyűkombinációval. Előfordulhat, hogy ezt meg kell változtatnia, ha a Rendszerfigyelő vezérlőt (Sysmon.ocx a rendszergyökér\System32 mappában) a Microsoft Word programban akarja használni.

A jelmagyarázatban az Objektum, Számláló, Példány vagy Számítógép elemre kattintással az adott kategória bejegyzései növekvő vagy csökkenő sorrendbe rendezhetők. Ha például az összes számlálót név szerint kívánja rendezni, kattintson a Számláló elemre.

További tudnivalókért tanulmányozza A Rendszerfigyelő gyors áttekintése című témakört.


Naplózott adatok használata

  1. A Teljesítmény beépülő modul megnyitása.
  2. Kattintson a jobb oldali egérgombbal a Rendszerfigyelő részletek ablaktáblájára, majd kattintson a Tulajdonságok parancsra.
  3. Kattintson a Forrás fülre.
  4. Az Adatforrás csoportban kattintson a Naplófájl választógombra, majd adja meg a fájl elérési útvonalát, vagy a kereséshez kattintson a Tallózás gombra.
  5. Kattintson az Időtartomány gombra. A naplófájl megtekinteni kívánt részletének megadásához húzza a sávot vagy a fogantyúit a megfelelő kezdő és befejező időpontokhoz.
  6. Kattintson az Érték fülre, majd a Számláló hozzáadása párbeszédpanel megnyitásához kattintson a Hozááadás gombra. A napló beállítása során kiválasztott számlálók megjelennek. Ezek közül mindet vagy csak néhányat felvehet a diagramba.

Megjegyzések

  • A Teljesítmény beépülő modul megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Teljesítmény parancsra.
  • Ha nem kimondottan a rendszerindítási eseményeket kívánja megjeleníteni, akkor ezeket ne vegye bele az időablakba, mivel az átmeneti magas értékek meghamisíthatják az átfogó teljesítményeredményeket.
  • Az eszközsávon található Képernyő törlése gomb nem érhető el a naplófájl adatainak megtekintése közben.
  • A naplófájl adatai úgy is megtekinthetők, ha a vesszővel vagy tabulátorral elválasztott formátumban mentett fájlokat a Microsoft Excel segítségével nyitja meg.


A teljesítményfigyelő eszközök felépítése

A Windows architektúra számos szintje támogatja a Rendszerfigyelő és a Teljesítménynaplók és figyelmeztetések konzol működését. Például alapértelmezés szerint a teljesítményfigyelő eszközök a rendszerleíró adatbázisból kapják az adatokat. Ezen kívül a rendszerre telepített alkalmazásokról és hardvereszközökről a Windows Management Instrumentation (WMI) illesztőn keresztül is gyűjthetők adatok. A Teljesítményadatok segéd (Performance Data Helper) dinamikus csatolású függvénytár (DLL) a WMI és a teljesítményfigyelő eszközök közötti közvetítőként működik, formázza az adatokat, számításokat végez, valamint szükség esetén a nyers adatokat megjeleníthető formátumúvá konvertálja. Azzal kapcsolatban, hogy a teljesítményfigyelő eszközöket hogyan lehet beállítani a WMI segítségével történő adatgyűjtésre, tanulmányozza a Teljesítményadatok gyűjtése WMI segítségével című témakört.

Az operációs rendszerben található DLL-ek az olyan erőforrások viselkedésének figyelésére használható számlálókat biztosítanak, mint például a memória, a processzorok, valamint a hálózati kártyák és protokollok. Ezenkívül sok Windows szolgáltatás és BackOffice alkalmazás saját DLL-eket tartalmaz, amelyek a működésüket figyelő számlálókat telepít.

A Rendszerfigyelő és a Teljesítménynaplók és riasztások konzol a Távoli rendszerleíró szolgáltatást használja, amely a távoli figyelő kapcsolatokhoz szükséges felhasználói bejelentkezéseket és kijelentkezéseket kezeli. Ezenkívül a Windows Üzenetküldő szolgáltatását használják a felhasználók számára történő figyelmeztetésküldésre. (A szolgáltatásnak futnia kell, hogy ilyen figyelmeztető üzeneteket kaphasson.)


A teljesítmény figyelése – bevezetés

A Windows 2000 az alábbi eszközöket biztosítja a számítógép erőforrás-használatának figyelésére:

  • Rendszerfigyelő
  • Teljesítménynaplók és riasztások

A rendszerteljesítmény megfigyelése a Windows 2000 felügyeletének és karbantartásának fontos része. A teljesítményadatok a következőkre használhatók:

  • A munkaterhelésnek, valamint a rendszererőforrásokra kifejtett hatásának kiderítése.
  • A munkaterhelés és az erőforrás-használat változásainak megtekintése, ezzel megkönnyítve a későbbi fejlesztések tervezését.
  • A konfiguráció változásainak vagy más hangolási beállításoknak a tesztelése az eredmények megfigyelésével.
  • Problémák felderítése és összetevők vagy folyamatok optimalizálása.

A Rendszerfigyelő és a Teljesítménynaplók és riasztások konzol részletes adatokat szolgáltat az operációs rendszer adott összetevői által használt erőforrásokról és a kiszolgálóprogramokról, amelyek a teljesítményadatok összegyűjtésére készültek. A diagramok a teljesítményadatok megjelenítésére, a naplók pedig az adatok tárolására szolgálnak. A Riasztások figyelmeztetést küldenek a felhasználónak az Üzenetküldő szolgáltatás segítségével, ha egy számláló értéke eléri vagy meghaladja a megadott küszöbértéket, vagy az alá esik.

A Microsoft technikai tanácsadás gyakran használja a teljesítményfigyelés eredményeit a hibafelderítésben. Ezért a Microsoft ajánlja a rendszerteljesítmény figyelését a felügyeleti feladatok részeként.

Megjegyzés

  • A Feladatkezelő egy másik eszköz, amely teljesítményadatokat szolgáltat a Windows 2000 operációs rendszert futtató rendszerekről. A Feladatkezelő segédprogramban láthatók a számítógépen jelenleg futó programok és folyamatok, valamint a processzor- és a memóriahasználat összefoglalása. Ha információra van szüksége a Feladatkezelővel kapcsolatban, olvassa el a Feladatkezelő súgóját.

A teljesítményfigyelő eszközök áttekintésével kapcsolatban tanulmányozza:

  • Rendszerfigyelő – áttekintés
  • Teljesítménynaplók és riasztások – áttekintés


Rendszerfigyelő – áttekintés

A Rendszerfigyelő konzol segítségével a saját számítógépének vagy a hálózat egy másik számítógépének a teljesítménye mérhető:

  • A helyi számítógép vagy több távoli számítógép valós idejű teljesítményadatai gyűjthetők össze és jeleníthetők meg.
  • A jelenleg vagy előzőleg számlálónaplóba gyűjtött adatok tekinthetők meg.
  • Az adatok nyomtatható diagram, hisztogram vagy jelentés formátumban jeleníthetők meg.
  • Beágyazhatók a Rendszerfigyelő elemei a Microsoft Word programba vagy a Microsoft Office csomag más alkalmazásába az Automatizálás segítségével.
  • HTML oldalak hozhatók létre a teljesítményadatokból.
  • Más számítógépeken is használható megfigyelési beállítások hozhatók létre a Microsoft Management Console segítségével.

A Rendszerfigyelő segítségével rengeteg adat gyűjthető össze és jeleníthető meg a felügyelt számítógépek hardvererőforrásainak használatáról és a rendszerszolgáltatások működéséről. A diagramon megjeleníteni kívánt adatok a következőképpen adhatók meg:

  • Adattípus. Az összegyűjteni kívánt adatok kiválasztásához a
    • teljesítményobjektumokat, a teljesítményszámlálókat és az objektumpéldányokat kell megadni.

    Egyes objektumok a rendszererőforrásokról szolgáltatnak adatokat (például a memóriáról), míg mások az alkalmazások működéséről (például a számítógépen futó rendszerszolgáltatásokról vagy Microsoft BackOffice alkalmazásokról).

  • Adatforrás. A Rendszerfigyelő konzol adatokat képes gyűjteni a helyi számítógépről vagy a hálózat azon számítógépeiről, amelyekhez hozzáféréssel rendelkezik. (Alapértelmezés szerint rendszergazdai engedély szükséges.) Ezenkívül megjeleníthetők valós idejű adatok vagy előzőleg a számlálónaplókba rögzített adatok.
  • Mintavételi paraméterek. A Rendszerfigyelő konzol támogatja a kézi, igény szerinti vagy az automatikus mintavételezést a megadott időközök alapján. Naplózott adatok megtekintésekor megadható a kezdő és a befejező időpont, így egy adott időtartomány adatai jeleníthetők meg.

Az adatok tartalmának beállításán kívül rugalmasan alakítható ki a Rendszerfigyelő megjelenése:

  • Megjelenítés típusa. A Rendszerfigyelő támogatja a grafikon, a hisztogram és a jelentés típusú megjelenítést. A grafikon nézet az alapértelmezett nézet, ez nyújtja a legszélesebb körű beállítási lehetőségeket.
  • Megjelenítési tulajdonságok. Mindhárom nézetben meghatározhatók a képernyőn megjeleníteni kívánt színek és betűtípusok. Grafikon és hisztogram nézetben a teljesítményadatok megtekintésekor sok különböző beállítás közül választhat:
    • Megadható a grafikon vagy hisztogram címe, valamint elnevezhető a függőleges tengely.
    • Beállítható a grafikonon vagy hisztogramon ábrázolt adatok tartománya.
    • Megadhatók a számlálók értékeit jelző vonalak vagy sávok tulajdonságai, például a színük, szélességük, stílusuk és így tovább.
    A Rendszerfigyelő használata kiterjeszthető, ha az Automatizálás segítségével beágyazza a szolgáltatásait a Microsoft Word programba vagy más Microsoft alkalmazásba.

A teljesítményfigyeléssel kapcsolatos további tudnivalókért tanulmányozza A teljesítmény figyelése – bevezetés című témakört.

A Rendszerfigyelő felhasználói felületével kapcsolatos további tudnivalókért tanulmányozza A Rendszerfigyelő felhasználói felülete című témakört.


Teljesítménynaplók és riasztások – áttekintés

A Teljesítménynaplók és riasztások konzol segítségével automatikusan gyűjthetők teljesítményadatok a helyi vagy távoli számítógépekről. A naplózott számlálóadatok megjeleníthetők a Rendszerfigyelő kijelzőjén, vagy elemzés és jelentéskészítés céljából exportálhatók táblázatkezelő programokba vagy adatbázisokba. A Teljesítménynaplók és riasztások a következő tulajdonságokkal rendelkezik:

  • A Teljesítménynaplók és riasztások konzol az adatokat vesszővel vagy tabulátorral elválasztott formátumba gyűjti, hogy a táblázatkezelő programokkal könnyen lehessen importálni azokat. Bináris naplófájlformátum is használható a körkörös naplózás vagy olyan példányok naplózása érdekében, mint például egy folyamat szálai, amelyek az adatgyűjtés megkezdése után indulnak el. (A körkörös naplózás azt jelenti, hogy az adatok naplózása folyamatosan történik egyetlen fájlba oly módon, hogy a régebbi adatokat felülírják az új adatok.)
  • A Teljesítménynaplók és riasztások által összegyűjtött számlálóadatok megtekinthetők adatgyűjtés közben, vagy miután az adatgyűjtés befejeződött.
  • Mivel a naplózás szolgáltatásként fut, az adatgyűjtés megtörténik tekintet nélkül arra, hogy a megfigyelt számítógépre van-e bejelentkezve felhasználó.
  • Meghatározhatók kezdő és leállítási időpontok, a fájlnevek, a fájlok mérete és az automatikus naplókészítés egyéb paraméterei.
  • Több naplózási munkamenetet is kezelhető egyetlen konzolablakból.
  • Beállítható riasztás egy számlálóhoz, ezzel meghatározva, hogy üzenetküldés, programfutatás vagy naplózás elindítása történjen, ha a kiválasztott számláló értéke meghaladja a megadott értéket, vagy az alá esik.

A Rendszerfigyelő konzolhoz hasonlóan a Teljesítménynaplók és riasztások konzol is támogatja teljesítményobjektumok, teljesítményszámlálók és objektumpéldányok meghatározását, valamint a hardvererőforrások és a rendszerszolgáltatások adatainak mintavételi időközének beállítását. A Teljesítménynaplók és riasztások további lehetőségeket is biztosít a teljesítményadatok rögzítésével kapcsolatban:

  • A naplózás elindítása és leállítása vagy kézzel, amikor szükség van rá, vagy automatikusan, a felhasználó által meghatározott ütemezés alapján.
  • További beállítások konfigurálása automatikus naplózáshoz, mint például a fájlok automatikus átnevezése, valamint a naplózás indítási és leállítási paramétereinek beállítása az eltelt idő vagy a fájlméret alapján.
  • Nyomkövetési naplók létrehozása. Az alapértelmezett rendszeradat-szolgáltatók vagy más szolgáltató segítségével a nyomkövetési naplók akkor rögzítenek adatokat, ha adott események (például lemez I/O művelet vagy laphiba) bekövetkeznek. Amikor az esemény megtörténik, a szolgáltató elküldi az adatokat a Teljesítménynaplók és riasztások szolgáltatásnak. Ez különbözik a számlálónaplók működésétől; számlálónaplók használata esetén a szolgáltatás akkor olvas adatot a rendszerből, ha a frissítési időköz letelt, és nem vár egy adott esemény bekövetkeztére. A nyomkövetési napló kimenetének értelmezéséhez elemzőeszközre van szükség. Fejlesztők készíthetnek ilyen eszközt a Microsoft webhelyen található alkalmazásprogramozási felületek (API) segítségével (http://msdn.microsoft.com/).
  • A naplózás leállításakor futtatni kívánt program adható meg.

Megjegyzések

  • Ha a naplózási adatokat a Microsoft Excel programba szeretné exportálni, a Teljesítménynaplók és riasztások szolgáltatást le kell állítani, mert a Microsoft Excel programnak a naplófájlhoz történő kizárólagos hozzáférésre van szüksége. Az nem ismert, hogy más programok számára is szükséges lenne a kizárólagos hozzáférés, ezért általában dolgozhat a naplófájl adataival, miközben a szolgáltatás adatokat gyűjt a fájlba.
  • A Teljesítménynaplók és riasztások felhasználói felületével kapcsolatos további tudnivalókért tanulmányozza A Teljesítménynaplók és riasztások felhasználói felülete című témakört.


Teljesítményfigyelés a Windows NT 4.0 és a Windows 2000 operációs rendszerekben

A Rendszerfigyelő és a Teljesítménynaplók és riasztások konzol továbbfejlesztett képességei helyettesítik a Windows NT 4.0 Teljesítményfigyelő programjának feladatait. Ezeknek az eszközöknek a segítségével megnyithatók a Teljesítményfigyelő Windows NT 4.0-s verziójával létrehozott beállításfájlok.

A Windows 2000 Resource Kit tartalmazza a Teljesítményfigyelő (perfmon4.exe) Windows NT 4.0-s változatát.


A Teljesítmény beépülő modul ismertetése

Ebben a témakörben a Rendszerfigyelő és a Teljesítménynaplók és riasztások konzol működésének és felépítésének leírása olvasható.

  • Teljesítményobjektumok és -számlálók
  • A teljesítményfigyelő eszközök felépítése
  • Teljesítményfigyelés a Windows NT 4.0 és a Windows 2000 operációs rendszerekben


Teljesítményobjektumok és -számlálók

A Windows 2000 a teljesítményadatokat gyűjt a számítógépben lévő összetevőkről. Amikor az összetevő munkát végez a rendszerben, teljesítményadatokat hoz létre. Ezeket az adatokat teljesítményobjektumoknak nevezik, és általában az adatokat létrehozó összetevőről kapják nevüket. Például a Processzor objektum a rendszerben található processzorok teljesítményadatainak gyűjteménye.

Számos teljesítményobjektum be van építve az operációs rendszerbe, ezek általában megfelelnek a fő hardverelemeknek, mint például memória, processzor és így tovább. Más programok is telepíthetik a saját teljesítményobjektumaikat. Például a WINS szolgáltatás vagy a Microsoft Exchange kiszolgálóprogram biztosít teljesítményobjektumokat, és a teljesítménygrafikonok és naplók megjeleníthetik ezeket az objektumokat.

Minden teljesítményobjektum biztosít számlálókat, amelyek egy rendszer vagy szolgáltatás adott szempontjairól szolgáltatnak adatokat. Például a Memória objektum által biztosított Mozgatott lapok (lap/mp) számláló a memórialapozás mértéket követi.

Bár a rendszeren általában sokkal több objektum állhat rendelkezésre, a leggyakrabban használt alapértelmezett objektumok a következők:

  • Gyorsítótár
  • Memória
  • Objektumok
  • Lapozófájl
  • Fizikai lemez
  • Folyamat
  • Processzor
  • Kiszolgáló
  • Rendszer
  • Szál

A Windows 2000 alábbi szolgáltatásai vagy funkciói biztosítanak teljesítményobjektumokat.

Megfigyelni kívánt szolgáltatás vagy funkció | Használható teljesítményobjektum
TCP/IP | ICMP, IP, NBT, TCP, és UDP objektumok
NetBEUI | NetBEUI és NetBEUI erőforrás-objektumok
Böngésző, Munkaállomás és Kiszolgáló szolgáltatások | Böngésző, Átirányító és Kiszolgáló objektumok
QoS-belépésvezérlés | ACS/RSVP szolgáltatás és illesztőobjektumok
Windows Internet Name Service (WINS) | WINS objektum
Csatlakozási pont szolgáltatások | PBServer-figyelő objektum
Indexelő szolgáltatás | Indexelő szolgáltatás, Indexelő szolgáltatás szűrője és Http Indexelő szolgáltatás objektumok
Címtár szolgáltatás | NTDS objektum
Nyomtatókiszolgáló tevékenysége | Nyomtatási sor objektum

A teljesítményobjektum számlálója által biztosított adatok leírásához kattintson a Számlálók hozzáadása párbeszédpanel Magyarázat gombjára. Ha további információra van szüksége a számlálók hozzáadásával kapcsolatban, tanulmányozza a Számlálók hozzáadása a Rendszerfigyelő konzolhoz című témakört.

Bár néhány objektumnak (mint például a Memória vagy a Kiszolgáló) csak egyetlen példánya van, egyes objektumoknak több példánya is lehet. Ha egy objektumnak több példánya van, akkor minden példányhoz megadható számláló a statisztika követéséhez, vagy akár az összes példányhoz egyszerre.

A számláló meghatározásától függően annak értéke a következő lehet:

  • Az erőforrás kihasználtság egy nézőpontjának legutóbb mért értéke. Ezeket azonnali számlálóknak is nevezik.

    Például a Folyamat\ Aktív végrehajtási szálak, amely egy adott folyamat legutóbbi mérési időpontban meglévő szálainak számát mutatja.

  • A két legutóbb mért érték átlaga. (Mivel a számlálókat soha nem törli a rendszer, ez valójában a mért értékek közti különbség átlaga.)

    Például a Memória\ Mozgatott lapok (lap/mp) számláló a memórialapok átlagos számának másodpercenkénti értéke a két legutóbbi minta alapján.

    • Más számlálótípusok is megadhatók a Platform Software Development Kit kiadványban bemutatott módon.

A számítógépnév, objektum, számláló, példány és példányindex kombinációjának elnevezése: számláló útvonala. Az eszközökben a számláló útvonala általában a következő formában jelenik meg:

Számítógép_neve\Objektum_neve(Példány_neve#Index_száma)\Számláló_neve


A teljesítményfigyelő eszközök használata

A témakör tartalma:

  • A figyelőrendszer beállítása
  • A Rendszerfigyelő konzol gyors áttekintése
  • A Rendszerfigyelő konzol eszköztára
  • A Rendszerfigyelő kezelőfelülete
  • A Teljesítménynaplók és riasztások felhasználói felülete
  • A teljesítményadatok elemzése
  • Teljesítményproblémák megoldása
  • A folyamatok értékelése és az erőforrás-bővítés megtervezése


Gyakorlati tanácsok

  • A figyelőrendszer beállítása. A Teljesítménynaplók és riasztások konzolt állítsa be úgy, hogy az a javasolt számlálók adatait rendszeresen jelentse, például 10-15 percenként. A naplófájlokat hosszú ideig őrizze meg, az adatokat tárolja adatbázisban, és az adatokat kérdezze le és analizálja szükség szerint az átfogó teljesítményvizsgálathoz, tendenciaanalízishez és kapacitástervezéshez.

    A legjobb eredmény elérése érdekében a Rendszerfigyelő vagy a Teljesítménynaplók és riasztások konzol azon a számítógépen történő elindítása előtt, amelyet diagnosztikai célból meg szeretne figyelni, tegye a következőket:

    • Állítsa le a képernyőkímélő programokat.
    • Állítsa le azokat a szolgáltatásokat, amelyek nem szükségesek vagy jelentősek a megfigyeléshez.
    • Növelje meg a lapozófájl méretét a fizikai memória méreténél 100 MB-tal nagyobbra.
    • A Rendszerleíróadatbázis-szerkesztő segítségével nézze meg az alábbi kulcsok beállításait, és jegyezze fel azokat a kulcsokat, amelyek értéke nem nulla:
      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\Memory Management
      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

      Vigyázat!

      • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot.

      A rendszerleíró adatbázis ezen értékei közül néhányat át lehet állítani a jobb teljesítmény érdekében. A rendszerleíró adatbázis módosításával kapcsolatos tudnivalókért tanulmányozza a Rendszerleíróadatbázis-szerkesztő súgóját.

    • Ha a megfigyelni kívánt kiszolgáló leállt vagy nem válaszol, futtassa a Rendszerfigyelőt másik számítógépről.
  • A megfigyeléssel járó többletterhelés alacsonyan tartása. Általában a teljesítményfigyelő eszközöket úgy tervezik, hogy azoknak minimális legyen a többleterőforrás-igénye. Azonban a többleterőforrás-igény növekedését tapasztalhatja a következő esetekben:
    • A Rendszerfigyelő konzolt grafikus üzemmódban futtatja.
    • Az alapértelmezettől (jelenlegi érték) különböző beállítást adott meg a jelentés nézet számára.
    • Túl gyakori mintavételt állított be (három másodpercnél gyakoribb).
    • Sok különböző objektum és számláló van kiválasztva.

    A teljesítményfigyelő eszköz működése egy másik vonatkozásban is hatással lehet a teljesítményre, ez pedig a naplófájlok mérete és az elfoglalt lemezterület. A fájlméret, és így az elfoglalt lemezterület csökkentése érdekében növelje meg a frissítési időközt. Ezen kívül a naplófájlokat ne arra a lemezre készítse, amelyiket meg akarja figyelni. A gyakori naplózás is megnöveli a lemez I/O műveletek iránti igényt.

    Ha a megfigyelés által igényelt többletráfordítás nagyon fontos, csak a Teljesítménynaplók és riasztások szolgáltatást futtassa, és ne a Rendszerfigyelő grafikont használja.

    Távoli naplózás esetén a gyakori frissítés is csökkentheti a teljesítményt a hálózati átvitel miatt. Ebben az esetben ajánlott folyamatosan naplózni a távoli számítógépen, viszont a naplókat csak ritkán feltölteni — például naponta egyszer.

  • A teljesítményfigyelés eredményeinek elemzése és a teljesítményvizsgálat viszonyítási alapjának megállapítása. A Rendszerfigyelő konzolban való megjelenítésével nézze át a naplózott adatokat, vagy exportálja azokat nyomtatáshoz. Hasonlítsa össze az értékeket A teljesítményadatok elemzése alatt látható számláló küszöbértékekkel annak ellenőrzésére, hogy az erőforrás-használat vagy más tevékenység az elfogadható határon belül van-e. Állapítsa meg az Ön által a jellemző munkaterhelés mellett elfogadhatónak ítélt teljesítményszintet.
  • Riasztások beállítása. A riasztásokat a viszonyítási alapértékek szerint nem elfogadhatónak ítélt számlálóértékek alapján állítsa be.
  • Teljesítményhangolás. Hangolja be a rendszerbeállításokat és a munkaterhelést a teljesítmény növelése érdekében, majd ismételje meg a megfigyelést, hogy megfigyelhesse a hangolás eredményét. Olvassa el A teljesítményproblémák megoldása című témakört azzal kapcsolatban, hogyan módosítható a konfiguráció, vagy milyen lépésekkel növelhető a teljesítmény.
  • Tervezés. Figyelje meg a trendeket a teljesítménytervezés érdekében, és szükség szerint adjon hozzá új összetevőket vagy frissítse a meglévőket. A naplózott adatokat tárolja adatbázisban és keresse meg a változásokat, hogy azonosítani tudja az erőforrásigényekben fellépő változásokat. A terhelés és erőforrásigények változásának megfigyelése után megállapítható, milyen további erőforrások szükségesek.


A figyelőrendszer beállítása

A figyelőrendszer beállítása a rendszerteljesítmény kiértékelésének első lépése. A Windows 2000 rendszer megfigyeléséhez az adatok megjeleníthetők grafikonon, vagy naplófájlba gyűjthetők, így más programokban is felhasználhatók.

Megjegyzés

  • A legjobb eredmény elérése érdekében olvassa el a következő részt a figyelőrendszer beállításával kapcsolatban. Ha gyorsan el akarja kezdeni a megfigyelést, használhatja a Számlálónaplók alatt található előre definiált naplóbeállításokat. Ezek a Rendszer áttekintése nevet viselő beállítások bináris naplófájlt hoznak létre, amely a kézzel történő indítás után 15 másodpercenként frissít, és mindaddig folyamatosan naplóz, amíg a naplófájl el nem éri a maximális méretet. Ha ezekkel a beállításokkal kezdi meg a naplózást, az adatok a gyökérkönyvtár Perflogs mappájába kerülnek, és a következő számlálókat tartalmazzák: Memória\ Mozgatott lapok (lap/mp), Fizikai lemez(_Total)\ Lemezvezérlő-várólista átlagos hossza és Processzor(_Total)\ A processzor kihasználtsága.

A megfigyelési módszer kiválasztása

A grafikon a helyi vagy egy távoli számítógép rövid ideig tartó, valós idejű megfigyelésére alkalmas — ha például a rendszereseményt annak megtörténése közben szeretne megfigyelni. A frissítési időközt úgy válassza ki, hogy a megfigyelni kívánt esemény észlelhető legyen. A napló az értékek rögzítésére és a hosszabb távú megfigyelésre használható, különösen távoli számítógépek esetén; a naplózott adatok exportálható jelentés létrehozása céljából, illetve megjeleníthetők grafikonon vagy hisztogramon a Rendszerfigyelő segítségével. A naplózás a több számítógép megfigyelésének legpraktikusabb módja.

A megfigyelési gyakoriság kiválasztása

A szokásos megfigyeléshez a naplózási tevékenységet kezdje legalább 15 perces időközökkel. Ha egy adott problémát akar megfigyelni, módosítsa ezt az időközt. Ha egy adott folyamat adott időben történő tevékenységét akarja megfigyelni, állítson be gyakori frissítési időközt; azonban ha egy lassú lefolyású problémát, például a memóriavesztést, akar megfigyelni, használjon hosszabb időközt.

Az időköz kiválasztásakor azt is figyelembe kell venni, hogy milyen hosszú ideig akarja a megfigyelést végezni. A 15 másodpercenkénti frissítés akkor ésszerű, ha négy óránál rövidebb ideig akarja folytatni a megfigyelést. Ha nyolc órán keresztül, vagy annál hosszabb ideig akarja folytatni a megfigyelést, a megfigyelési időközt ne állítsa 300 másodpercnél (öt percnél) rövidebbre. A frissítési időköz túl gyakorira állítása (alacsony érték) azt okozhatja, hogy a rendszer nagy mennyiségű adatot hoz létre, amelynek kezelése nehéz, és növelheti a Teljesítménynaplók és riasztások által igényelt teljesítménybeli többletráfordítást is.

Sok objektum és számláló megfigyelése is nagy mennyiségű adat létrejöttéhez vezethet, amely sok lemezterületet foglal el. Próbálja megtalálni a megfigyelni kívánt objektumok száma és a mintavételi időköz közti egyensúlyt, hogy a naplófájl mérete kezelhető korlátok között maradjon.

Ha a naplózás során hosszú frissítési időközt szeretne használni, akkor is lehetősége van a mintavételi időpontok közt történő adatingadozások megtekintésére. A naplófájlok időtartományának kezelésével kapcsolatban további tudnivalókért tanulmányozza a Naplózott adatok használata című témakört.

A megfigyelni kívánt adatok kiválasztása

A megfigyelést kezdje sorban az alábbi összetevők tevékenységének megfigyelésével:

  • Memória
  • Processzorok
  • Lemezek
  • Hálózat

Az alábbi táblázatban a kiszolgáló megfigyeléséhez szükséges minimálisan ajánlott számlálók láthatók. Az adott erőforrás vizsgálatakor adjon hozzá további számlálókat a társított teljesítményobjektumhoz.

Összetevő | A megfigyelt teljesítményszempont | A megfigyelendő számlálók
Lemez | Használat | Fizikai lemez\ Lemezolvasási gyakoriság (művelet/mp) Fizikai lemez\ Lemezírási gyakoriság (művelet/mp) Logikai lemez\ Szabad terület % Figyelmesen értelmezze a % lemezidő számlálót. Mivel ennek a számlálónak a _Total példánya esetleg nem tükrözi helyesen a többlemezes rendszerek lemezhasználatát, fontos, hogy használja az Üresjárati idő % számlálót is. Megjegyzés: ezek a számlálók nem jeleníthetnek meg 100%-nál nagyobb értéket.
Lemez | Szűk keresztmetszetek | Fizikai lemez\ Lemezvezérlő-várólista átlagos hossza (minden példány)
Memória | Használat | Memória\ Rendelkezésre álló fizikai memória Memória\ A gyorsítótár jelenlegi mérete (bájt)
Memória | Szűk keresztmetszetek vagy memóriavesztés | Memória\ Mozgatott lapok (lap/mp) Memória\ Lapkezelő lemezolvasási gyakoriság (művelet/mp) Memória\ Laphibák száma (művelet/mp) Memória\ A lapozható készlet mérete (bájt) Memória\ Nem lapozható készlet mérete (bájt) Bár a következők nem kimondottan Memóriaobjektum számlálói, hasznosak lehetnek a memóriaelemzés során: Paging File\ Lapozófájl kihasználtsága (%) (minden példány) Gyorsítótár\ Gyorsítótár találatok aránya (%) Kiszolgáló\ A lapozható készlet mérete és a Kiszolgáló\Nem lapozható készlet mérete.
Hálózat | Használat | Hálózati szegmens\ Hálózat kihasználtsága (%) Megjegyzés: ahhoz, hogy ez a számláló megjelenjen, telepíteni kell a Hálózatfigyelő eszközillesztőt.
Hálózat | Átvitel | Protokoll átviteli számlálók (a hálózati protokolltól függ); TCP/IP esetén: Hálózati csatoló\ Összes bájt/sec Hálózati csatoló\ Csomagok (csomag/mp) Kiszolgáló\ Összes bájt/sec vagy Kiszolgáló\ Nyers küldési sebesség (bájt/mp) és Kiszolgáló\ Nyers olvasási sebesség (bájt/mp) A hálózat és a kiszolgáló más objektumainak áteresztőképessége is figyelhető A hálózati tevékenység figyelése című témakörben leírt módon.
Processzor | Használat | Processzor\ A processzor kihasználtsága (%) (minden példány)
Processzor | Szűk keresztmetszetek | Rendszer\ Processzor-várólista hossza (minden példány) Processzor\ Megszakítások (megszakítás/sec) Rendszer\Programkörnyezet-váltások (művelet/sec)

Ha az előző táblázatban szereplő számlálók közül néhány nem áll rendelkezésre a számítógépen, ellenőrizze, hogy telepítette-e a szükséges szolgáltatásokat és aktiválta-e a számlálókat. A Hálózatfigyelő által biztosított Hálózati szegmensobjektum számlálók aktiválásával kapcsolatos útmutatásokért olvassa el A Hálózati szegmens számlálók engedélyezése című témakört.

Megjegyzés

  • A fizikai lemezhez tartozó számlálók adataival ellentétben a logikai lemezhez tartozó számlálók adatait alapértelmezés szerint az operációs rendszer nem gyűjti. Ha a logikai meghajtók vagy tárolókötetek teljesítményszámlálóinak adataira kíváncsi, írja be a diskperf -yv parancsot a parancssorba. Ennek hatására a lemezteljesítmény adatainak gyűjtésére használt lemezteljesítmény statisztika illesztőprogram biztosítja a logikai meghajtók vagy tárolókötetek adatait. Alapértelmezés szerint az operációs rendszer a diskperf -yd parancsot használja a fizikai meghajtók adatainak gyűjtésére. A diskperf paranccsal kapcsolatos további tudnivalókért írja be a diskperf -? parancsot a parancssorba.

A megfigyelésre használt számítógép kiválasztása

Számítógépek távolról történő megfigyelése esetén több lehetőség van az adatgyűjtésre. Például futtatható a teljesítménynaplózás a rendszergazda számítógépén, amely minden távoli számítógépről folyamatosan gyűjti az adatokat. Egy másik esetben minden számítógépen futhat az adatgyűjtő szolgáltatás, majd szabályos időközönként egy kötegelt program segítségével vihetők át az adatok a rendszergazda számítógépére elemzés és archiválás céljából.

A központosított adatgyűjtést (tehát a megfigyelt távoli számítógépek adatainak egy helyi számítógépen történő összegyűjtését) egyszerű megvalósítani, mivel csak egy naplózó szolgáltatásnak kell futni. Több rendszer adatai egyetlen naplófájlba gyűjthetők össze. Ez azonban extra hálózati forgalmat okoz, és a rendszergazda számítógépében lévő memória mennyisége is korlátozhatja. A központosított adatgyűjtéshez használja a Számlálók hozzáadása párbeszédpanelt, ahol kiválaszthatja a távoli számítógépet, miközben a Rendszerfigyelő a helyi számítógépen fut.

Elosztott adatgyűjtés esetén (tehát amikor az adatgyűjtés a megfigyelt számítógépeken történik) nem állnak fönn memória és hálózati forgalom problémák, mint a központosított adatgyűjtés esetén. Ebben az esetben azonban az adatok csak késéssel állnak rendelkezésre, mivel az összegyűjtött adatokat elemzés céljából át kell vinni a rendszergazda számítógépére. Az elosztott adatgyűjtéshez a helyi számítógépen használja a Számítógép-kezelés programot annak a távoli számítógépnek a kiválasztásához, amelyen adatokat akar gyűjteni.

Távoli számítógépek megfigyelése esetén figyeljen arra, hogy a távoli számítógépet csak akkor érheti el, ha azon megfelelő jogosultsággal rendelkezik. Annak érdekében, hogy távoli rendszereket tudjon megfigyelni a számítógépéről, a Teljesítménynaplók és riasztások szolgáltatást olyan felhasználói fiók használatával kell elindítania, amely a megfigyelni kívánt számítógéphez hozzáféréssel rendelkezik. Alapértelmezés szerint a szolgáltatás a helyi számítógép “rendszer” fiókja alatt indul el, amelynek általában csak a helyi számítógép erőforrásainak és szolgáltatásainak eléréséhez van jogosultsága. Ha más felhasználói fiók alatt akarja elindítani, használja a Számítógép-kezelés alatt található Szolgáltatások segédprogramot a Teljesítménynaplók és riasztások tulajdonságainak frissítéséhez.

A teljesítményadatok tárolása

Ha a naplózott adatokat egy adatbázisban tárolja, lekérdezheti az adatokat, és jelentéseket készíthet belőlük. Adatbázis-elemző eszközök segítségével lekérdezheti az eredményeket, és azokat részleteiben vizsgálhatja számos paraméter segítségével. A naplófájlokat tendenciaelemzésre és kapacitástervezésre is használhatja.

A figyelőrendszer beállításainak exportálása

Miután a teljesítményfigyelő eszközök számára beállította a számlálókat, a frissítési időközöket, és a többi lehetőséget, elmentheti ezeket a beállításokat a helyi számítógépre, vagy egy másik számítógépre exportálhatja azokat. Figyeljen arra, hogyha a beállításokat Perfmon.msc néven menti, akkor a számítógépen lévő eszközök beállításait véglegesen megváltoztatja. Ezért ajánlott, hogy a fájlt más néven mentse.

A megfigyelési beállítások mentésén kívül, más eszközöket vagy a Rendszerfigyelő több példányát is hozzá lehet adni, például ha egyszerre akar megfigyelni grafikon és jelentés nézetben. Ha további információra van szüksége azzal kapcsolatban, hogy hogyan lehet eszközöket hozzáadni egy konzolhoz, olvassa el a Testreszabott megfigyelő konzol létrehozása című témakört.


A teljesítményadatok elemzése

A megfigyelési adatok elemzése a rögzített számlálóadatok vizsgálatát jelenti, miközben a rendszer különböző feladatokat hajt végre. A folyamat során azt kell meghatározni, hogy mely folyamatok a legaktívabbak, és hogy mely programok vagy szálak, ha vannak ilyenek, foglalják le az erőforrások nagy részét. A teljesítményadatok ilyen típusú elemzését követően deríthető ki, hogy a rendszer hogyan válaszol a terhelési igényekre.

Az elemzés eredményeként az is tapasztalható, hogy a rendszer néha megfelelő teljesítményt nyújt, máskor viszont nem. E változások okaitól, valamint a különbség mértékétől függően úgy dönthet, hogy megfelelő helyesbítő lépéseket tesz, vagy elfogadja ezeket az ingadozásokat, és az erőforrások hangolását vagy frissítését későbbre halasztja.

A rendszer teljesítményének az a szintje, amit még elfogadhatónak ítél, amikor a rendszer általános terhelés mellett üzemel és minden szükséges szolgáltatás fut, az a viszonyítási alap. A viszonyítási alap egy szubjektív mérték, amit a rendszergazda határoz meg a munkakörnyezet alapján. A számlálóértékek olyan tartományát jelenti, amelybe időlegesen nem elfogadható értékek is beleeshetnek, de amely általában a lehetséges legjobb teljesítményt jelenti a rendszergazda által meghatározott feltételek között. Ez a viszonyítási alap a felhasználók teljesítménybeli elvárásainak mértékéül szolgálhat, és szerepelhet bármely szolgáltatási megegyezésben.

A teljesítményadatok elemzése a következőkből áll:

  • A számlálók elfogadható értékeinek meghatározása
  • A teljesítményadatok változásának okai


A számlálók elfogadható értékének meghatározása

Általában szubjektív módon dönthető el, hogy a teljesítmény elfogadható-e vagy sem, mivel ezt jelentősen befolyásolhatja a felhasználási környezet. Általában a szervezet számára megállapított viszonyítási alap tekinthető az összehasonlítás legjobb alapjának. Mindezek ellenére az alábbi táblázatban látható küszöbértékek segíthetnek annak meghatározásában, hogy a számítógépen mért értékek problémát jeleznek-e. Ha a Rendszerfigyelő mindig ezeket az értékeket jelenti meg, valószínűsíthető, hogy a rendszerben valahol szűk keresztmetszetű erőforrás található, amelyet ajánlatos lehet behangolni vagy frissíteni.

Erőforrás | Objektum\ Számláló | Javasolt küszöbérték | Megjegyzések
Lemez | Fizikai lemez\ Lemezhasználati idő (%) | 90%
Lemez | Fizikai lemez\ Lemezolvasási gyakoriság (művelet/mp), Fizikai lemez\ Lemezírási gyakoriság (művelet/sec) | A gyártó által megadott műszaki adatoktól függ | Ellenőrizze a lemezen mért átviteli sebességet, hogy az ne haladja meg a gyártó által megadott sebességet. Az Ultra Wide SCSI lemezek általában másodpercenként 50 I/O művelet kezelésére képesek.
Lemez | Fizikai lemez\ Lemezvárólista jelenlegi hossza | Tengelyek száma plusz 2 | Ez a számláló pillanatnyi értéke, hosszabb időszakon keresztül figyelje meg. Az átlag kijelzéséhez használja a Fizikai lemez\ Átlag elemet. Lemez várakozási sorának a hossza.
Memória | Memória\ Rendelkezésre álló fizikai memória (bájt) | Kevesebb, mint 4 MB | Vizsgálja meg a memóriahasználatot, és szükség szerint tegyen a gépbe több memóriát.
Memória | Memória\ Mozgatott lapok (lap/mp) | 20 | Vizsgálja meg a memórialapozás mértékét.
Hálózat | Hálózati szegmens\ Hálózat kihasználtsága (%) | A hálózat típusától függ | A küszöbértéket a használt hálózat típusa alapján kell meghatározni. Például Ethernet hálózatok esetén a javasolt küszöbérték 30%.
Lapozófájl | Lapozófájl\ Lapozófájl kihasználtsága (%) | 99% | Ezt az értéket a Rendelkezésre álló fizikai memória és a Mozgatott lapok/mp értékekkel együtt nézze át, hogy megértse a számítógép lapozási tevékenységét.
Processzor | Processzor\ A processzor kihasználtsága (%) | 85% | Keresse meg azt a folyamatot, amely a processzoridő nagy százalékát használja. A processzort cserélje egy gyorsabbra, vagy tegyen a gépbe még egyet.
Processzor | Processzor\ Megszakítások (megszakítás/mp) | A processzortól függ. | Ha ennek a számlálónak az értéke jelentősen megnő, anélkül, hogy a rendszertevékenységek is ezzel arányban nőnének, az valószínűleg hardverhibát jelez. Keresse meg, hogy melyik hálózati kártya okozza a megszakításokat.
Kiszolgáló | Kiszolgáló\ Összes bájt (bájt/mp) | Ha az összes kiszolgáló Összes bájt (bájt/mp) értékének összege nagyjából egyenlő a hálózat maximális átviteli sebességével, akkor hasznos lehet a hálózatot részekre bontani.
Kiszolgáló Kiszolgáló\ Munkaelem hiányok 3 Ha az érték eléri a küszöbértéket, hasznos lehet az InitWorkItems vagy MaxWorkItems kulcsok beállítása a rendszerleíró adatbázisban (a HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer alatt). A rendszerleíró adatbázis módosításával kapcsolatos tudnivalókért tanulmányozza a Rendszerleíróadatbázis-szerkesztő
súgóját.

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot.
Kiszolgáló | Kiszolgáló\ Felhasznált lapozható memória maximuma (bájt) | A fizikai RAM mennyisége | Ez az érték a lapozófájl maximális méretét és a fizikai memória mennyiségét jelenti.
Kiszolgáló | Kiszolgáló munkavárólisták\ Várólista hossza | 4 | Ha az érték eléri ezt a küszöböt, akkor valószínűleg a processzor a szűk keresztmetszet. Ez a számláló pillanatnyi értéke, hosszabb időszakon keresztül figyelje meg.
Több processzor | Rendszer\ Processzor-várólista hossza | 2 | Ez a számláló pillanatnyi értéke, hosszabb időszakon keresztül figyelje meg.

A hangolási és frissítési tanácsokkal kapcsolatban tanulmányozza A teljesítményproblémák megoldása című témakört.


A teljesítményadatok változásának okai

A következő megfontolások segíthetnek a megfigyelt teljesítményváltozások megértésében:

  • Az erőforrások használata jelentősen változhat a különböző időpontokban végzett műveletektől függően.
  • Azok a számlálók, amelyek a használat mértékét egy időtartamon belül mutatják, sokkal kifejezőbb mérési eredményeket szolgáltatnak, mint a pillanatnyi számlálók átlagértékei, mivel az átlagértékek tartalmazhatják a szolgáltatás elindításának vagy olyan eseményeknek az adatait, amelyek egy rövid időre jóval a megengedett érték fölé emelhetik a számokat, ezzel meghamisítják az eredményeket.


A rendszererőforrások felhasználásának megfigyelése

Mivel a processzor és a memória erőforrásai jelentős hatással vannak a számítógép működésére, fontos annak megértése, hogy a programok hogyan használják ezeket az erőforrásokat. Ez a témakör bemutatja, a számlálók a Rendszerfigyelő grafikus megjelenítőjén történő megfigyelése hogyan segíthet a programok processzor- és memóriahasználatának megértésében. Kezdje a megfigyelést a Folyamat\ Processzoridő (%) és a Folyamat\ Munkakészlet számlálókkal:

  • Processzoridő (%). Az eltelt időnek az a része, amelyben a processzor az adott folyamat összes szálának végrehajtását végzi. (Megjegyzés: ha a rendszer nem dolgozik, az Üresjárati folyamathoz tartozó Processzoridő (%) értéke magas.)
  • Munkakészlet. A folyamat által jelenleg használt vagy lefoglalt fizikai memória nagysága (bájtban). Ez az érték magasabb lehet, mint ahány bájtra a folyamatnak minimálisan szüksége van. Ez olyan fizikai bájtokat jelenthet, amelyeket több folyamat oszt meg.

Ezen számlálók segítségével az alábbi ábrán látható módon, grafikonon ábrázolható a számítógépen futó egyes programok (vagy akár az összes program):

Az alkalmazások által használt processzoridő

Megjegyzés: a programok indításakor a Folyamat\ Processzoridő (%) érték mindig nagyon gyorsan emelkedik, majd visszaesik. Fontos, hogy tisztában legyen azzal, hogy programok indításakor a processzorhasználat megugrik; a megfigyelt adatok közül kihagyható az átmenetileg magas indulási értékek, hogy pontosabb képet kapjon a programok által jellemzően használt processzoridőről.

Indítás után a grafikon a processzortevékenység növekedését jelzi, amint a program valamilyen műveletet hajt végre — például amikor a Rendszerfigyelő új számlálóértékeket olvas be. Ezt megfigyelhető, ha a Rendszerfigyelőben megváltoztatja a frissítési időközt. Figyeljen arra, hogy ha a Rendszerfigyelőben rövid frissítési időköz van beállítva, gyakrabban fog adatokat beolvasni, és így magasabb processzortevékenység fog megjelenni. Hosszabb frissítési időköz alacsonyabb processzortevékenységet okoz.

A programok memóriaszámláló-értékeinek figyelése hasonlóan jellemzi a programok rendszererőforrások iránti igényét, és hogy erre az erőforrások hogyan válaszolnak. A számítógépen futó minden program számára az operációs rendszer lefoglal egy részt a fizikai memóriából. Ennek a neve munkakészlet. Az operációs rendszer akkor is lefoglal fizikai memóriát a program munkakészlete számára, ha az nem is végez semmilyen műveletet.

A munkakészlet értéke akkor különösen fontos, ha Memória\ Rendelkezésre álló fizikai memória (bájt) számláló egy adott küszöbérték alá esik. A Windows 2000 a programok memóriaigényét szabad (rendelkezésre álló) bájtokkal elégíti ki. Ha már nincs elegendő szabad hely (bájt), az operációs rendszer elkezdi megszüntetni a hiányt oly módon, hogy a kevésbé aktív programok munkakészleteitől vesz el memóriát. Ez azt eredményezi, hogy miközben egyes programok munkakészletének mérete növekszik, más programoké csökken. Ha a rendszerben nincs elegendő memória minden aktív program igényeinek a kielégítésére, az operációs rendszer a lapozófájlt kezdi használni, miáltal a programok teljesítménye visszaesik. Ha további információra van szüksége a lapozási tevékenység megfigyelésével kapcsolatban, tanulmányozza A gyakori lapozás okának felderítése című témakört.

Az alkalmazások által használt memóriamennyiség

A mintajelentéseket és grafikonokat kibővítheti, hogy azok több programot és számlálót tartalmazzanak. A rendszertevékenységek megértéséhez figyelje ezeket és más számlálóértékeket, miközben változtatja a rendszer aktivitását.

Ha információra van szüksége azzal kapcsolatban, hogy hogyan lehet megfigyelni a processzor kihasználtságát vagy a memóriahasználatot, tanulmányozza az alábbi témaköröket:

  • A rendelkezésre álló memóriamennyiség ellenőrzése
  • A processzorműködés figyelése


A processzorműködés figyelése

A Processzor és a Rendszer objektumszámlálók megfigyelése értékes adatokat szolgáltat a processzorok kihasználtságával kapcsolatban, és segít annak meghatározásában, hogy a processzorok szűk keresztmetszetet okoznak-e a rendszerben. A következő számlálók használhatók:

  • Processzor\ A processzor kihasználtsága (%) a processzorkihasználtság megjelenítéséhez.

    Részletesebb adatok érdekében megjeleníthető a Processzor\ A processzor normál módú használatának aránya (%) és A processzor védett módú használatának aránya (%) számláló is.

  • A Rendszer\ Processzor-várólista hossza számláló a szűk keresztmetszetek felderítéséhez használható.

A processzorhasználati értékek megfigyelése

A processzor aktivitásának kijelzéséhez figyelje a Processzor\ A processzor kihasználtsága (%) számlálót. Ez a számláló az eltelt időnek azt a részét jelzi százalékban, amely alatt a processzor egy nem tétlen szál végrehajtását végzi.

A processzorhasználat vizsgálata során vegye figyelembe a számítógép szerepét és a végrehajtás alatt levő feladat típusát. A számítógép tevékenységétől függően a magas processzorértékek jelenhetik azt, hogy a rendszer hatékonyan kezel nagy munkaterhelést, vagy hogy nem tud lépést tartani az igényekkel. Ha például felhasználó számítógépét figyeli meg, és a felhasználó a számítógépet számítási műveletek elvégzésére használja, a számítást végző program könnyedén elhasználhatja a processzoridő 100 százalékát. Még ha ez a számítógépen futó más alkalmazások teljesítményének kárára történik is, megoldható a munkaterhelés módosításával.

Ha azonban ez az érték egy számos ügyfélkérelmet feldolgozó kiszolgáló esetén 100 százalék körüli, azt jelenti, hogy a folyamatoknak sorban kell állniuk processzoridőre várakozva, és így szűk keresztmetszetet okoznak. A hosszan tartó magas processzorhasználat elfogadhatatlan egy kiszolgáló esetében.

A processzorkapacitás szűk keresztmetszeteinek feltárása

Processzorral kapcsolatos szűk keresztmetszetek akkor alakulnak ki, amikor a folyamat szálai több processzorciklust igényelnek, mint amennyi rendelkezésre áll. Hosszú processzor-várólisták jöhetnek létre, és csökkenhet a rendszerteljesítmény. A processzorral kapcsolatos szűk keresztmetszetek két fő oka a processzort intenzíven használó programok és a sok megszakítást generáló alrendszerek összetevői (általában lemez vagy hálózat összetevői).

Annak meghatározásához, hogy a szűk keresztmetszetet a magas processzoridő-igény okozza-e, ellenőrizze a Rendszer\ Processzor-várólista hossza számláló értékét. Kettő vagy több elem várakozása torlódást jelent. Ha viszonylag sok programfolyamat verseng a processzoridő nagy részéért, egy gyorsabb processzor növelni tudja a teljesítményt. Többszálú folyamatok futtatása esetén egy további processzor használata is segíthet, azonban vegye figyelembe, hogy a több processzor használatának korlátozottak az előnyei. További tudnivalókért tanulmányozza a Többprocesszoros rendszerek figyelése című témakört.

Ezenkívül A kiszolgáló várólistái\ Várólista hossza számláló, amely a számítógép kiszolgáló munka-várólistájának pillanatnyi hosszát mutatja, is jelezhet processzorral kapcsolatos szűk keresztmetszetet. Ha a várólista hossza hosszú ideig 4 fölött van, az valószínűleg processzortorlódást jelent. Ez a számláló egy adott időbeli értéket mutat, nem időben átlagolt értéket.

Annak meghatározásához, hogy a megszakításkérések szűk keresztmetszetet okoznak-e, figyelje a Processzor\ Megszakítások (megszakítás/sec) számláló értékét, amely a bemeneti/kimeneti (I/O) eszközök szolgáltatáskéréseit méri. Ha ennek a számlálónak az értéke jelentősen megnő, anélkül, hogy a rendszertevékenység is ezzel arányban nőne, az hardverhibát jelenthet.

Figyelheti a Processzor\ Megszakítások kiszolgálására fordított időhányad (%) számlálót is a lemezmeghajtók, hálózati csatolók és más, megszakításokat generáló eszközök tevékenységének közvetett megfigyelésére.

Megjegyzés

  • A processzorteljesítményre hatással levő hardverproblémák (például IRQ ütközések) felderítéséhez figyelje a Rendszer\ Fájlvezérlési sebesség (bájt/sec) számláló értékét.

Többprocesszoros rendszerek figyelése

A többprocesszoros számítógép hatékonyságának figyeléséhez használja a következő számlálókat.

Számláló | Leírás
Folyamat\ A processzor kihasználtsága (%) | Az egyes processzorok processzoridejének összege, a folyamat összes szálára vetítve.
Processzor(_Total)\ A processzor kihasználtsága (%) | A számítógépben lévő összes processzor tevékenységének mértéke. Ez a számláló az összes processzor átlagos nem tétlen idejét összegzi a mintavételi időtartamban, majd elosztja a processzorok számával. Ha például az összes processzor a mintavételi időtartam felében foglalt, az átlag 50% lesz. A számláló akkor is 50%-ot mutat, ha a processzorok fele foglalt a teljes időtartamban, míg a másik fele tétlen.
Végrehajtási szál\ A processzor kihasználtsága (%) | A szál által használt processzoridő.

Processzoraffinitás kezelése többprocesszoros rendszereken

Ha egy folyamatot vagy programot egyetlen processzorhoz szeretne hozzárendelni, hogy növelje a teljesítményét más folyamatok kárára, a Feladatkezelőben kattintson az Affinitás beállítása parancsra. Ez a beállítás csak többprocesszoros rendszereken használható.

A processzoraffinitás vezérlése növelheti a teljesítményt, mivel csökkentheti a processzor-gyorsítótár kiürítéseinek számát, amikor a szálak az egyik processzorról a másikra térnek át. Ez hasznos beállítás lehet fájlkiszolgálók esetén. Azonban azt is tartsa szem előtt, hogy ha egy programot egy adott processzorhoz rendel hozzá, más programszálak nem térhetnek át a legkevésbé foglalt processzorra.

A lemez- vagy hálózati csatolók által generált megszakítások esetén is vezérelhető a processzoraffinitás. A Windows 2000 Resource Kit kiadványban található egy eszköz, amely lehetővé teszi a megszakítások ilyen módon történő vezérlését.


A lemezhasználat figyelése

A lemezhasználati statisztikák segítenek a hálózati kiszolgálók munkaterhelésének kiegyenlítésében. A Rendszerfigyelő a fizikai lemezhez tartozó számlálókat biztosít a hibafelderítés, a kapacitástervezés és a fizikai kötetek használatának mérése érdekében.

Legalább a következő számlálókat kell figyelni:

  • Fizikai lemez\ Lemezolvasási gyakoriság (művelet/mp) és Fizikai lemez\ Lemezírási gyakoriság (művelet/mp)
  • Fizikai lemez\ Lemez-várólista jelenlegi hossza
  • Fizikai lemez\ Lemezvezérlő kihasználtsága %
  • Logikai Lemez\ Szabad terület %

A lemezteljesítmény vizsgálatakor a teljesítményadatokat másik lemezen vagy számítógépen naplózza, hogy az ne legyen hatással a vizsgált lemezre.

Ajánlott továbbá a Fizikai lemez\ Átlagos műveleti idő (mp/művelet), Átlagos átvitt adatmennyiség (bájt/átvitel) és az Átviteli sebesség (bájt/mp) számlálók figyelése.

Az Átlagos műveleti idő (mp/művelet) számláló azt mutatja, hogy mennyi időbe telik, amíg egy lemez kielégíti a kérelmeket. A számláló magas értéke azt jelentheti, hogy a lemezvezérlő folyamatosan próbálkozik az olvasással lemezhiba miatt. Ezek a hibázások növelik az átlagos lemezátviteli időt. A legtöbb lemez esetében a magas átlagos lemezátviteli idők 0,3 másodpercnél nagyobb értékeket jelentenek.

Ellenőrizheti az Átlagos átvitt adatmennyiség (bájt/átvitel) számláló értékét is. Ha az értéke 20 Kb-nál nagyobb, az azt jelenti, hogy a lemezmeghajtó megfelelően működik; akkor jelennek meg alacsony értékek, ha egy alkalmazás nem megfelelően fér hozzá egy lemezhez. Például egy, a lemezt véletlenszerűen elérő alkalmazás növeli az Átlagos műveleti idő (mp/művelet) számláló értékét, mivel a véletlen átvitelekhez nagyobb keresési időre van szükség.

Az Átviteli sebesség (bájt/mp) számláló a lemezrendszer átviteli sebességét adja meg.

Mivel a lemezszámlálók kis mértékben növelik a lemezhozzáférési időt, a Windows 2000 nem indítja el automatikusan ezeket a számlálókat a rendszer indulásakor.

Megjegyzés

  • A fizikai lemez számlálóadatival ellentétben a logikai lemez számlálóadatait alapértelmezés szerint nem az operációs rendszer gyűjti. Ha a logikai meghajtókhoz vagy tárolókötetekhez tartozó teljesítményszámláló adataira kíváncsi, írja be a diskperf -yv parancsot a parancssorba. Ennek hatására a lemezteljesítmény adatainak gyűjtésére használt lemezteljesítmény statisztika illesztőprogram biztosítja a logikai meghajtók vagy tárolókötetek adatait. Alapértelmezés szerint az operációs rendszer a diskperf -yd parancsot használja a fizikai meghajtók adatainak gyűjtésére. A diskperf paranccsal kapcsolatos további tudnivalókért írja be a diskperf -? parancsot a parancssorba.

Munkaterhelés egyensúlyának meghatározása

A hálózati kiszolgálók terhelésének elosztása érdekében ismerni kell, hogy a kiszolgáló lemezmeghajtói mennyire foglaltak. A Fizikai lemez\ Lemezvezérlő kihasználtsága (%) számláló a meghajtó aktív állapotban eltöltött idejének arányát jelzi. Ha a Lemezvezérlő kihasználtsága (%) érték magas (90 százalék fölötti), ellenőrizze a Fizikai lemez\ Lemez-várólista jelenlegi hossza számlálót, hogy hány rendszerkérelem várakozik lemezhozzáférésre. A várakozó I/O kérelmek száma hosszú távon nem haladhatja meg a fizikai lemezben található forgó lemezek számának 1,5-2-szeresét.

A legtöbb lemezben egyetlen forgó lemez található, de a RAID eszközökben általában több. A hardveres RAID eszköz egyetlen fizikai lemezként jelenik meg a Rendszerfigyelő konzolon; a szoftveresen létrehozott RAID eszközök több meghajtóként (példányként) jelennek meg. Figyelhetők az egyes fizikai meghajtók (nem RAID) Fizikai lemez számlálói, vagy a _Total példány segítségével a számítógép összes meghajtója figyelhető.

A Lemez-várólista jelenlegi hossza és a Lemezvezérlő kihasználtsága (%) számlálók a lemez alrendszerrel kapcsolatos szűk keresztmetszetek felderítéséhez használhatók. Ha a Lemez-várólista jelenlegi hossza és a Lemezvezérlő kihasználtsága (%) számlálók értéke folyamatosan magas, fontolja meg a lemezmeghajtó frissítését vagy néhány fájl másik lemezre vagy kiszolgálóra történő áthelyezését.

Megjegyzések

  • A Logikai lemez objektumszámlálók el lettek távolítva. A rendszer a fizikai meghajtókat logikai meghajtókra képezi le ugyanazon példánynév használatával. Ezért ha egy dinamikus kötete van, amely több fizikai lemezből áll, a következő példányok jelenhetnek meg: “Disk 0 C:”, “Disk 1 C:” és “Disk 2 D:”, ahol a C: a 0. és az 1. fizikai lemezekből áll. Ha két logikai partíció van egy lemezen, a példány a következőképp jelenik meg: “0 C: D:”.
  • Hardveresen engedélyezett csíkozott készletek esetén lemezenkénti statisztika nem érhető el. Ezek az adatok csak szoftveresen engedélyezett csíkozott készletek esetén érhetők el.
  • RAID eszköz használata esetén a Lemezvezérlő kihasználtsága (%) számláló 100 százaléknál nagyobb értéket is mutathat. Ilyenkor a Lemezvezérlő-várólista átlagos hossza számlál segítségével határozható meg, hogy átlagosan hány rendszerkérelem várakozik lemezhozzáférésre.


A hálózati tevékenység figyelése

A hálózatfigyelés általában a kiszolgáló-erőforrások kihasználtságának figyelését és a teljes hálózati forgalom mérését jelenti. A Rendszerfigyelő segítségével mindkét feladat elvégezhető, bár a részletesebb forgalomelemzéshez ajánlott a Hálózatfigyelő segédprogramot használni.

A kiszolgáló erőforrás-használatának megfigyelését kezdje a Figyelőrendszer felállítása témakörben említett számlálók megfigyelésével. A hálózattal kapcsolatos erőforrás-használat pontosabb megfigyeléséhez adja hozzá a hálózati beállítás különböző rétegeinek megfelelő számlálókat. A hálózati számlálók nem megszokott értékei általában a kiszolgáló memóriájának, processzorának vagy lemezeinek meghibásodását jelzik. Ezért a kiszolgáló figyelésekor ajánlott a hálózati számlálók mellett a Processzor\ A processzor kihasználtsága (%), a Fizikai lemez\ Lemezvezérlő kihasználtsága (%) és a Memória\ Mozgatott lapok (lap/mp) számlálókat is használni.

Ha például a Mozgatott lapok (lap/mp) érték jelentős megnövekedése mellett a kiszolgálóra vonatkozó Nyers feldolgozási sebesség (bájt/mp) érték lecsökken, a számítógép valószínűleg nem rendelkezik elegendő fizikai memóriával a hálózati műveletek elvégzéséhez. A legtöbb hálózati erőforrás, a hálózati kártyákat és a protokollszoftvereket is beleértve, nem lapozható memóriát használ. Ha a számítógép túl sokat használja a lapozófájlt, ez amiatt lehet, hogy a fizikai memória nagy része hálózati műveletek számára van lefoglalva, és a memóriának csak kis része maradt a lapozható memóriát használó folyamatok számára. Ennek ellenőrzéséhez keressen a számítógép rendszeresemény-naplójában olyan bejegyzéseket, amelyek arra utalnak, hogy elfogyott a lapozható vagy a nem lapozható memória.

Megjegyzés

  • Az operációs rendszer automatikusan beállítja a kiosztható nem lapozható memóriakészlet alapértelmezett korlátját. Az alapértelmezett érték körülbelül a számítógépben levő memória 80 százaléka. Ha a számítógép a hálózati műveletek hatására eléri ezt a korlátot, az problémákat okozhat. A korlát megváltoztatásához módosítsa a rendszerleíró adatbázis következő bejegyzését:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\MaxNonpagedMemoryUsage

    A rendszerleíró adatbázis módosításával kapcsolatos tudnivalókért tanulmányozza a Rendszerleíróadatbázis-szerkesztő súgóját.

    Vigyázat!

    • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot.

A Hálózatfigyelő engedélyezésével a Rendszerfigyelőben hálózattal kapcsolatos objektumokat használhat a teljes hálózati teljesítmény vizsgálatához. A teljes hálózati forgalom megfigyelésével kapcsolatos további tudnivalókért tanulmányozza a Teljes hálózati forgalom figyelése című témakört.

Hálózati rétegek átvitelének figyelése

A hálózati teljesítmény vizsgálata a különböző hálózati rétegek aktivitásának figyelését jelenti.

  • Adatkapcsolati réteg. A hálózati csatolót jelenti. Használja a következő Hálózati csatoló objektumszámlálókat:
    • Nyers feldolgozási sebesség (bájt/mp)
    • Elküldött adatok (bájt/mp)
    • Nyers olvasási sebesség (bájt/mp).
  • Hálózati réteg. Használja a következő IP objektumszámlálókat:
    • Továbbított datagramok (datagram/mp)
    • Beérkezett datagramok (darab/mp)
    • Datagramok (datagram/mp)
    • Küldött datagramok (datagram/mp).
  • Átviteli réteg. A használt hálózati protokolltól függ. TCP/IP esetén használja a következő TCP objektumszámlálókat:
    • Beérkezett szegmensek (szegmens/mp)
    • Újraküldött szegmensek (szegmens/mp)
    • Nyers szegmensküldési sebesség (szegmens/mp)
    • Küldött szegmensek (szegmens/mp).

    A magas újraküldési arány hardverhibát jelezhet.

    ICMP és UDP objektumszámlálók is rendelkezésre állnak és hasznosak a TCP/IP hálózati forgalom részletesebb vizsgálatához. Az ICMP teljesítményobjektum olyan számlálókat tartalmaz, amelyek az ICMP protokoll használatával küldött és fogadott ICMP üzenetek átviteli sebességét mérik. ICMP protokollhibákat jelző számlálókat is tartalmaz. Az UDP teljesítményobjektum olyan számlálókat tartalmaz, amelyek az UDP-protokoll használatával küldött és fogadott UDP datagramok átviteli sebességét mérik. UDP hibákat jelző számlálókat is tartalmaz.

    A NetBEUI-protokoll használata esetén figyelje a következő számlálókat:

    • NetBEUI\ Keretekben vett adatok (bájt/mp)
    • NetBEUI\ Vett keretek (keret/mp)
    • NetBEUI\ Elutasított keretek (keret/mp)
    • NetBEUI erőforrás\ Helyi erőforrás hibája miatt bontott kapcsolatok

    Az NWLink-protokoll használata esetén három objektum áll rendelkezésre: Az NWLink IPX és az NWLink NetBIOS az IPX-protokoll segítségével kommunikáló számítógépek esetén, valamint az NWLink SPX az SPX-protokoll segítségével kommunikáló számítógépek esetén. Megjegyzés: ezen objektumok keretekkel kapcsolatos számlálói mindig nullát jeleznek.

  • Megjelenítési/program réteg. Használja a Kiszolgáló objektumszámlálókat, ha egy kiszolgálót figyel meg, vagy használja az Átirányító objektumszámlálókat, ha egy felhasználó ügyfélszámítógépét figyeli meg. (Egyes program rétegű folyamatok, például webkiszolgálók, rendelkezhetnek saját objektumszámlálókkal, amelyek a rétegen keresztüli átvitel figyelésére használhatók.)

    Az Átirányító objektumszámlálók a Munkaállomás szolgáltatás által küldött kérelmekről gyűjtenek adatokat; a Kiszolgáló objektumszámlálók a Kiszolgáló szolgáltatás által fogadott és értelmezett kérelmekről gyűjtenek adatokat.

    Az Átirányító (a megfigyelt ügyfélszámítógépekét) és a Kiszolgáló (a kiszolgáló számítógépekét) objektumoknak legalább a Nyers feldolgozási sebesség (bájt/mp) számlálóját figyelje meg.

    Az objektumok további számlálókat is tartalmaznak, amelyek akkor érdemes megfigyelni, a Munkaállomás vagy a Kiszolgáló szolgáltatás hibájára gyanakszik. Ezek a számlálók a következők:

    • Átirányító\ Kiszolgálásra váró kérések
    • Átirányító\ Hálózathibák (hiba/mp)
    • Átirányító\ Elutasított olvasási kérelmek (olvasás/mp)
    • Átirányító\ Elutasított írási kérelmek (írás/mp)
    • Átirányító\ Megszakított kiszolgáló kapcsolatok
    • Kiszolgáló\ Hiba miatt megszakadt munkamenetek
    • Kiszolgáló\ Megszakított munkamenetek
    • Kiszolgáló\ Felhasznált lapozható memória maximuma (bájt)
    • Kiszolgáló\ Sikertelen nem lapozható memóriafoglalások

    Ha a Megszakított munkamenetek számláló értéke növekszik, hasznos lehet az InitWorkItems vagy MaxWorkItems kulcsok módosítása a rendszerleíró adatbázisban (a HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer alatt).

    A Hiba miatt megszakadt munkamenetek számláló az automatikus lekapcsolódásokat és a hiba miatt leállt munkameneteket is jelzi. Ha a hiba miatt leállt munkamenetekről pontosabb adatokra van szüksége, a Megszakított munkamenetek számláló értékét vonja ki a Hiba miatt megszakadt számláló értékéből. További tudnivalókért tanulmányozza a Források című témakört.

Teljes hálózati forgalom figyelése

Ha a hálózati forgalom meghaladja a helyi hálózat (LAN) kapacitását, a teljesítmény az egész hálózatban lecsökken. Ennek elkerülése érdekében fontos a teljes hálózatra kiterjedő forgalmat figyelni a Hálózati szegmens objektum segítségével, különösen a hidakat és útválasztókat tartalmazó nagyobb hálózatok esetében. A hálózati forgalom figyelésekor három Hálózati szegmens objektumszámláló különösen nagy jelentősséggel bír.

Számláló | Leírás
Hálózati szegmens\ Vett szórásos keret (keret/mp) | Viszonyítási alap megállapítására használható hosszabb ideig tartó megfigyelés esetén. A viszonyítási alaptól való nagy eltéréseket meg lehet vizsgálni a probléma okának felderítése érdekében. Mivel minden szórásos üzenetet az összes számítógép feldolgozza, a sok szórásos üzenet alacsonyabb teljesítményt eredményez.
Hálózati szegmens\ Hálózat kihasználtsága (%) | Azt jelzi, hogy a hálózat mennyire közelíti meg a maximális kapacitását. A küszöbérték a hálózati infrastruktúrától és felépítéstől függ. Ha a számláló értéke 30-40 százalék fölötti, az ütközések problémákat okozhatnak.
Hálózati szegmens\ Összes beérkezett keret (keret/mp) | Jelzi, hogy a hidak és útválasztók mikor vannak telítve.

Ha a hálózati szegmensén elemezni szeretné ezeket az adatokat, telepítse a Hálózatfigyelő segédprogramot. A Hálózatfigyelővel kapcsolatos további tudnivalókért tanulmányozza a Hálózatfigyelő súgóját.

Ha a Hálózatfigyelő segédprogram telepítésével kapcsolatban van szüksége segítségre, amely tartalmazza a hálózat kihasználtságának figyelésére alkalmas számlálókat, tanulmányozza a Hálózati szegmens számlálók engedélyezése című témakört.


Korábbi programok figyelése

Ez a témakör azt mutatja be, hogyan lehet megfigyelni a 16 bites Windows alapú és az MS-DOS alapú programokat.

A Windows 2000 operációs rendszerben a 16 bites Windows alapú programok a Windows virtuális DOS gép (NTVDM) nevű többszálú folyamat külön szálaiként futnak. Az NTVDM folyamat a 16 bites Windows környezetet szimulálja. Az MS-DOS-alapú programok saját NTVDM folyamatukban futnak.

A számítógépen futó 16 bites és MS-DOS alapú programokat a Rendszerfigyelőben a Folyamat teljesítményobjektum ntvdm példányán keresztül lehet megfigyelni. Megjegyzés: az NTVDM-ben futó 16 bites programok úgy jelennek meg, mintha külön memóriaterületen indultak volna el.

Ha úgy találja, hogy a 16 bites programok nem nyújtanak kielégítő teljesítményt Windows 2000 alatt, a program tulajdonságainak egy része elérhető, ha a Windows Intézőben a jobb oldali egérgombbal a program nevére kattint, majd elvégzi a következő beállításokat:

  • Ha program ablakban fut, és lassú a megjelenítés, a Képernyő lapon kattintson a Teljes képernyő választógombra.
  • Ha a program ablakban fut, és úgy tűnik, mintha időnként megállna, a Vegyes lapon állítsa az Üresjárati érzékenység csúszkát Alacsony értékre.

A Kompatíbilis hardveróra-emuláció is kikapcsolható, ha a program teljesítménye az előző beállítások módosítása után sem változik. Ehhez kattintson a jobb oldali egérgombbal a _Default.pif fájlra vagy a program nevére, mutasson a Program pontra, majd kattintson a Windows NT parancsra. A megjelenő párbeszédpanelen törölje a jelölést a Kompatíbilis hardveróra-emuláció jelölőnégyzetből. Ez a módosítás általában teljesítménycsökkenést eredményez, és csak akkor ajánlatos használni, ha az előző beállítások nem hoztak eredményt.


A folyamatok értékelése és az erőforrás-bővítés megtervezése

A mindennapos megfigyelések során összegyűjtött adatok segítséget nyújtanak a tendenciaelemzéshez és a kapacitástervezéshez. Még ha a számítógép jelenleg megfelelően üzemel is, fontos a módosítások megtervezése olyan esetekre, ha új felhasználókat venne fel a rendszerbe, új technológiákat vagy programokat alkalmazna. A nem várt hálózati növekedés az erőforrások túlzott használatát és a hálózati szolgáltatások alacsony színvonalát eredményezheti. A rendszerteljesítmény folyamatos figyelésével azonosíthatja az új erőforrások iránti igényt, még mielőtt az kritikussá válna.

A számlálókból összegyűjtött adatok felhasználásával, A figyelőrendszer felállítása című témakörben leírtak szerint megfigyelhetők az egyes összetevők értékeinek időbeli változását. Ezek a változások jelezhetik az összetevők növelése vagy frissítése iránti igényt, ahogy az a Tippek az összetevők hangolásához és frissítéséhez című témakörben olvasható.


Teljesítményproblémák megoldása

A megfigyelt adatok elemzése feltárhat olyan problémákat, például egy erőforrás iránti túlzott igényt, ami torlódáshoz vezethet. Ebben a fejezetben a szűk keresztmetszetek okairól, valamint a beállítás és a tesztelés ajánlott menetéről olvashat.

Szűk keresztmetszetek okai

Előállhatnak szélsőséges igények, amelyek az erőforrásokon szűk keresztmetszetet okozhatnak a következő okok miatt:

  • Nem áll rendelkezésre elegendő erőforrás; további vagy frissített összetevőkre van szükség.
  • Az erőforrások nem osztják meg egyenlően a munkaterhelést, terheléselosztásra van szükség.
  • Az erőforrás hibásan működik, annak cseréje szükséges.
  • A program kizárólagosan használ egy erőforrást; szükség lehet a program cseréjére, újraírására, erőforrások hozzáadására vagy frissítésére, vagy a programot akkor kell futtatni, amikor a rendszer terhelése kicsi.
  • Az erőforrás helytelenül van beállítva és a konfigurációs beállításokat módosítani kell.

A hangolás és a tesztelés menete

A Számlálók elfogadható értékeinek meghatározása című témakörben szereplő küszöbértékek segítenek a teljesítményproblémák erőforrások szerinti elkülönítésében. Keresse meg a problémára vonatkozó hangolási és frissítési leírást a következő témakörök egyikében:

  • A memóriahasználat figyelése és hangolása
  • A processzorműködés figyelése
  • A lemezhasználat figyelése
  • A hálózati tevékenység figyelése
  • Windows 2000 szolgáltatások figyelése
  • Korábbi programok figyelése

A memória hiánya messze a leggyakoribb oka a számítógépes rendszerekben felmerülő komoly teljesítményproblémáknak. Ha más problémákra gyanakszik, ellenőrizze a memóriával kapcsolatos számlálókat, hogy a memóriahiányt ki lehessen zárni. Az alacsony válaszidőt munkaállomások esetében általában memória- vagy processzorprobléma okozza; a kiszolgálók a lemez- és a hálózati problémákra érzékenyebbek.

A hangolás megkezdése előtt gondolja át az alábbi javaslatokat:

  • Egyszerre csak egy beállítást módosítson. Egyes esetekben az olyan problémák, amelyek látszólag egyetlen összetevővel kapcsolatosak, valójában több összetevő által okozott szűk keresztmetszet eredményei. Ezért fontos a problémák egyenként történő megoldása.

    Ha egyszerre több változtatást hajt végre, lehetetlenné válhat az egyes módosítások okozta hatások felderítése.

  • Minden módosítás után ismételje meg a figyelést. Ez fontos a módosítás hatásának megértéséhez és annak eldöntéséhez, hogy szükség van-e további módosításokra. A beállítást módszeresen hajtsa végre, az erőforrásnak egyszerre csak egy tulajdonságát módosítsa, majd tesztelje a módosítás teljesítményre kifejtett hatását. Mivel a hangoló módosítások más erőforrásokra is hatással lehetnek, fontos, hogy az elvégzett módosításokat feljegyezze, és hogy újra elvégezze a megfigyelést a módosítás után.
  • A figyelésen kívül nézze át az eseménynaplókat is, mivel egyes teljesítményproblémák az Eseményfigyelőben megjeleníthető kimenetet hoznak létre. Az Eseménynapló használatával kapcsolatos további tudnivalókért tanulmányozza az Eseménynapló súgóját.
  • Annak kiderítéséhez, hogy a hálózati összetevők részt vesznek-e a teljesítményproblémákban, hasonlítsa össze a hálózaton futtatott programok teljesítményét a helyileg futtatott programok teljesítményével.

Tippek az összetevők hangolásához és frissítéséhez

Ebben a részben a megfigyelt erőforrásokkal kapcsolatban talál hangolási tanácsokat.

  • Memória:
    • Növelje a fizikai memória méretét a minimálisan szükséges fölé.
    • Hozzon létre több lapozófájlt.
    • Határozza meg a lapozófájl szükséges méretét.
    • Ellenőrizze, hogy a memóriabeállítások A rendelkezésre álló memóriamennyiség ellenőrzése című témakörben bemutatottaknak megfelelően vannak beállítva.
    • A memóriaigényes programokat a legnagyobb teljesítményű számítógépeken futtassa, vagy akkor, amikor alacsony a munkaterhelés.
  • Lemez:
    • Használjon nagyobb sebességű lemezt, vagy használjon több lemezt. Ehhez frissítse a lemezvezérlőt és a buszt.
    • Kiszolgálók esetén használja a Lemezkezelés segédprogramot csíkozott kötetek létrehozásához több fizikai lemezen. Ez a megoldás növeli az átviteli sebességet, mivel az I/O parancsok párhuzamosan adhatók ki.
    • Ossza meg a programokat a kiszolgálók között. Használhat elosztott fájlrendszert (Dfs-t) a munkaterhelés elosztásához.
    • A sok lemez I/O műveletet használó feladatokat helyezze külön fizikai lemezekre vagy lemezvezérlőkre.
    • Használja a Lemeztöredezettség-mentesítő segédprogramot a lemezterület optimalizálásához.
    • Ha növelni szeretné a lemezhozzáférések hatékonyságát, fontolja meg a csatoló legfrissebb illesztőprogramjának telepítését. Tájékoztatásért forduljon a csatoló gyártójához.
  • Processzor:
    • Adjon hozzá egy processzort (különösen többszálú programok esetén) vagy használjon gyorsabb processzort.
    • Többprocesszoros számítógépeken a processzoraffinitást kezelje a folyamatszálak és a megszakítások függvényében.
  • Hálózat:
    • Úgy konfigurálja a hálózatot, hogy az emberek egy csoportja által megosztott rendszerek ugyanabban az alhálózatban legyenek.
    • Csatolja le a ritkán használt hálózati csatolókat. További tudnivalókért tanulmányozza a Protokollok kötési sorrendjének módosítása című témakört.
    • Több protokoll használata esetén beállíthatja a sorrendet, amely szerint a munkaállomás és a NetBIOS szoftver az egyes protokollokhoz kapcsolódik. További tudnivalókért tanulmányozza a Hálózati és telefonos kapcsolatok segédprogram súgóját. A listasorrend módosításának okai a következők lehetnek:
      • Ha a leggyakrabban használt protokoll a kötési lista első helyén szerepel, az átlagos kapcsolati idő lecsökken.
      • Egyes protokollok gyorsabbak lehetnek bizonyos hálózati topológiák esetén. Ügyfélszámítógép optimalizálása esetén, ha a gyorsabb protokollt teszi a lista elejére, növekszik a teljesítmény. Mivel a kiszolgáló a bejövő kapcsolatokat az ügyfélszámítógép által választott protokoll használatával fogadja, a kiszolgáló-számítógép kötési sorrendjét nem kell módosítani.
    • A kiszolgálóban használjon nagy teljesítményű hálózati csatolót. Ha a kiszolgálóban 16 bites csatoló található, annak 32 bites, nagy teljesítményű csatolóra történő cseréje jelentősen növelheti a teljesítményt.
    • Használjon több hálózati csatolót. A Windows 2000 támogatja a több csatoló használatát egy adott protokollhoz, és a több protokoll használatát egy adott csatolóhoz. Bár ez a beállítás azt eredményezheti, hogy a távoli hálózatok nem tudnak kommunikálni egymással, növelheti a fájlmegosztási teljesítményt.

A teljesítményproblémák megoldása a következőkből áll:

  • A memóriahasználat figyelése és hangolása
  • A processzorműködés figyelése
  • A lemezhasználat figyelése
  • A hálózati tevékenység figyelése
  • Windows 2000 szolgáltatások figyelése
  • Korábbi programok figyelése


Forrásmunkák

Ha a teljesítményadatok és azok elemzésének részletesebb leírására kíváncsi, tanulmányozza a Windows 2000 Resource Kit kiadványt.

Ha a programok optimalizálásával és teljesítményszámlálók programokhoz történő írásával kapcsolatban van szüksége tájékoztatásra, látogassa meg a Microsoft webhelyét (http://msdn.microsoft.com/).

A hálózati és szolgáltatásparaméterek rendszerleíró adatbázisban történő módosításával kapcsolatban keressen friss tudnivalókat a Microsoft weblapján. Tanulmányozza a Frissített technikai információ részt.

Vigyázat!

  • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot.

Ha a teljesítményfigyelő eszközök Microsoft Office vagy Visual Basic alkalmazásokba történő beágyazásával kapcsolatban segítségre van szüksége, olvassa el a Teljesítményfigyelő programok kifejlesztése című részt.


Teljesítményfigyelő programok fejlesztése

A számos konfigurálható beállítás mellett a Rendszerfigyelő lehetőséget biztosít arra, hogy a felhasználók programon keresztül kiterjesszék a figyelőképességeket. Mivel a Rendszerfigyelő ActiveX-vezérlőként érhető el (Sysmon.ocx a rendszergyökér\System32 mappában), amely támogatja a Visual Basic automatizálást, a fejlesztők beágyazhatják a Rendszerfigyelő vezérlő képességeit a programjaikba. A kiterjeszthetőség kihasználásának legegyszerűbb módja, ha a Rendszermonitor vezérlőt egy Microsoft Office alkalmazásba, például a Microsoft Wordbe ágyazza be. Ezzel a módszerrel a jelentésekben megjeleníthetők Rendszerfigyelő grafikonok, és ki is nyomtathatók. Az ezzel kapcsolatos további tudnivalókért tanulmányozza A Rendszerfigyelő vezérlő beszúrása egy Microsoft Word dokumentumba című témakört.

Ha a vezérlőt programban helyezi el, a tulajdonságok, az események és a metódusok elérhetők a Visual Basic Editornak a tartalmazó programból történő futtatásával, vagy a Visual Basic közvetlen futtatásával.

A Rendszerfigyelő vezérlő programozásával kapcsolatos tudnivalókért látogassa meg a Microsoft webhelyét (http://msdn.microsoft.com/).

A Rendszerfigyelő vezérlő programozása mellett a fejlesztők új teljesítményszámlálókat is írhatnak programok számára, amelyek nem tartalmaznak ilyeneket. A teljesítményszámlálók programba történő beépítésével kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Resource Kit kiadványt.


Hibaelhárítás

Mi a probléma?

A számláló értéke folyamatosan nulla.

Oka: A megfigyelt folyamat leállt, ezért nincsenek a folyamathoz a teljesítményfigyelő eszközökkel feldolgozható adatok.

Megoldás: Ha a folyamatot kézzel állította le, indítsa újra, hogy az megjelenjen a Rendszerfigyelőben. Ellenkező esetben ellenőrizze az Eseménynaplóban a kapcsolódó bejegyzéseket. Esetleg a folyamattal kapcsolatos hibára akadhat.

Oka: A számláló DLL-t letiltotta, miután a megfelelő számlálót kiválasztotta egy naplóban vagy a képernyőn. A teljesítményeszközök nem észlelik, hogy a számlálót eltávolította vagy letiltotta, és folyamatosan nulla számlálóértéket jeleznek.

Megoldás: Engedélyezze a megfelelő számláló DLL-t.

Oka: Nem rendelkezik megfelelő engedéllyel a figyelni kívánt számítógépen. Ha nem rendelkezik megfelelő engedéllyel a számítógép figyeléséhez, hibaüzenet jelenik meg a számláló kiválasztásakor, viszont a számláló megjelenik a hisztogram vagy diagram jelmagyarázatában, de nem tartalmaz adatokat.

Megoldás: A rendszergazdának biztosítania kell, hogy megfelelő engedéllyel rendelkezzen a teljesítményeszközök használatához.

A Rendszermonitor vonalgrafikonjában rések jelennek meg.

Oka: Ez akkor fordulhat elő, ha egy erősen terhelt rendszeren az adatgyűjtést egy magasabb prioritású folyamat háttérbe szorította. Amikor a rendszer elegendő erőforrással rendelkezik az adatgyűjtés folytatásához, a megjelenítés a megszokott módon folytatódik. Erről egy üzenet jelenik meg.

Megoldás: Csökkentse a rendszerfigyelés által okozott teljesítménytöbblet-igényt.

Tanulmányozza még: Gyakorlati tanácsok

A naplóban rögzített adatok nem jelennek meg grafikon nézetben.

Oka: A grafikon legfeljebb 100 mintát jeleníthet meg.

Megoldás: Csökkentse a kijelölt időtartományt.

Tanulmányozza még: Naplózott adatok használata

Objektumok, számlálók vagy példányok hiányoznak vagy érvénytelenek.

Oka: A Teljesítmény beépülő modul indításakor futtatott tesztrutinok hibát jeleztek a telepített számlálókkal kapcsolatban, és automatikusan letiltották ezeket a számlálókat, hogy azok ne lassítsák le a rendszert. A letiltott objektumok és számlálók nem jelennek meg a Számláló hozzáadása párbeszédpanelen.

Megoldás: A Rendszerleíróadatbázis-szerkesztő segítségével módosítsa a HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Service_name\Performance\Disable Performance Counters alatt levő értéket 1-ről 0-ra. Megjegyzés: a kezdeti tesztelés után letiltott számlálók hibásak lehetnek, és rendszerproblémákat okozhatnak. A számláló DLL-k hibakeresésével kapcsolatos tudnivalókért látogassa meg a Microsoft webhelyét (http://msdn.microsoft.com/).

Vigyázat

  • A rendszerleíró adatbázis nem megfelelő szerkesztése súlyos kárt tehet a rendszerben. A rendszerleíró adatbázisban történő változtatások elvégzése előtt a számítógépen levő minden fontos adatról készítsen biztonsági másolatot.

Oka: Az objektumszámlálókat elindító folyamat nincs elindítva vagy telepítve.

Megoldás: A Feladatkezelő segédprogramban ellenőrizze, hogy fut-e a folyamat. Ha igen, a Windows 2000 Resource Kit csomag CD mellékletén található Exctrlst.exe program segítségével ellenőrizze, hogy a számláló DLL engedélyezve van-e.

Oka: A számlálók nincsenek engedélyezve (például a Hálózati szegmens objektum számlálói).

Megoldás: Ellenőrizze, hogy a számlálót biztosító szolgáltatás telepítve és konfigurálva van-e.

Oka: A számlálókat telepítő DLL hibákat generál. Ez például akkor fordulhat elő, ha a számláló nem kezeli helyesen a honosítási funkciókat.

Megoldás: Ellenőrizze az Eseménynapló beépülő modulban, hogy a számláló DLL vagy a Teljesítményadatok segéd (Performance Data Helper) jelzett-e hibákat. Szükség esetén tiltsa le a hibákat okozó számláló DLL-eket a Windows 2000 Resource Kit CD-mellékletén található Exctrlst.exe program segítségével.

Oka: 16 bites vagy MS-DOS alkalmazást próbál figyelni. A példányok listájában csak 32 bites folyamatok jelennek meg. Az aktív 16 bites folyamatok a Windows virtuális DOS gép (NTVDM) folyamat szálaiként jelennek meg.

Megoldás: Figyelje az alkalmazást az NTVDM folyamaton keresztül.

Tanulmányozza még: Örökölt programok figyelése

Oka: A figyelni kívánt példány jelenleg nem aktív. Ha a Rendszerfigyelőt valós idejű adatok gyűjtésére állítja be, az adatgyűjtéshez csak aktív példányok választhatók ki. (Naplózott adatok megtekintésekor kiválaszthatók az inaktív példányok, amelyek adatait tartalmazza a napló.) Ha kiválaszt egy folyamatot, és az megáll a kiválasztás után, az a listában továbbra is megjelenik, de a jelzett adatok nullák lesznek.

Megoldás: Ellenőrizze, hogy a folyamat aktív-e.

Két azonos nevű folyamat figyelése esetén az egyik példány különösen magas értékeket jelezhet, miközben a másik nem.

Oka: A teljesítményeszközök néha félreértelmezik az ugyanolyan nevű folyamatok különböző szálaihoz tartozó adatokat, mivel a példány összesített értékét egyetlen példány értékeként jelentik.

Megoldás: Használja a példányindexet és figyelje a Folyamat\ Folyamat azonosítója (ID) és a Folyamat\ Folyamatazonosító létrehozása számlálókat.

Több szál figyelése esetén ha az egyik szál leáll, másik szál adatai jelennek meg helyette.

Oka: Ez a szálak számozási módja miatt van így. Tegyük fel például, hogy három szálat figyel meg, amelyek számai 0, 1 és 2. Ha a 0. szál megáll, a rendszer a megmaradó szálakat újraszámozza. Az eredeti 0-s számú szál már nem létezik, és a régi 1-es számú szál száma most 0. Ezért a megállított 0-s szál adatai a futó 1-es szál adataival együtt jelennek meg, mivel az 1-es szál most a régi 0-s szálnak felel meg.

Megoldás: Használja a Szál azonosítója számláló példányindexét a folyamatok figyeléséhez.

Hibaüzenet jelenik meg, ha a naplóadatokat Microsoft Excelbe próbálja exportálni, miközben a Teljesítménynaplók és riasztások szolgáltatás adatokat gyűjt abba a naplóba.

Oka: A Microsoft Excel alkalmazásnak kizárólagos hozzáférésre van szüksége a naplófájlhoz. Az nem ismert, hogy más programok számára is szükséges-e a kizárólagos hozzáférés, ezért általában dolgozhat a naplófájl adataival, miközben a szolgáltatás adatokat gyűjt a fájlba.

Megoldás: Állítsa meg a Teljesítménynaplók és riasztások szolgáltatást, mielőtt az adatokat a Microsoft Excel alkalmazással használná.

Megszakadt a kapcsolat a távoli számítógéppel, amelynek a naplózása folyamatban volt, és a naplózást nem lehet folytatni.

Oka: A távoli számítógép adatainak naplózásához a Távoli rendszerleíró szolgáltatást kell használni. Ha a szolgáltatás hiba miatt leáll, a rendszer alapértelmezés szerint csak egyszer indítja újra automatikusan.

Megoldás: Ha a Távoli rendszerleíró szolgáltatás egynél többször áll le, a szolgáltatást kézzel kell újraindítani minden további hiba után. Az alapértelmezett viselkedés megváltoztatásához használja a Számítógép-kezelés vagy a Szolgáltatások beépülő modult (a Felügyeleti eszközök menüben) a Távoli rendszerleíró szolgáltatás tulajdonságainak módosításához.

A Rendszerfigyelő súgója nem jelenik meg az MMC segédprogram súgójában; ott csak a Teljesítménynaplók és riasztások súgója jelenik meg.

Oka: Mivel a Rendszerfigyelő ActiveX vezérlő, a viselkedése különbözik más MMC beépülő modulok viselkedésétől. Például a Rendszerfigyelő súgója nem érhető el oly módon, hogy a Rendszerfigyelőre a jobb oldali egérgombbal kattint, majd a helyi menüben a Súgó parancsra kattint, vagy ha a Súgó menü Témakörök parancsára kattint.

Megoldás: Kattintson a Súgó gombra a Rendszerfigyelő eszközsávján.


A memória szűk keresztmetszeteinek feltárása

A következő számlálók segítségével azonosíthatók a memória erőforrások szűk keresztmetszetei:
  • Memória\ Rendelkezésre álló fizikai memória (bájt)
  • Memória\ Mozgatott lapok (lap/mp)

A számlálók küszöbértékeivel kapcsolatos tudnivalókért tanulmányozza A teljesítmény elemzése című témakört, a teljesítményproblémák kiküszöbölését elősegítő hangolási technikákkal kapcsolatos tudnivalókért tanulmányozza a Teljesítményproblémák megoldása című témakört.


A processzorkapacitás szűk keresztmetszeteinek feltárása

A következő számlálók segítségével azonosíthatók a processzor erőforrásainak szűk keresztmetszetei:

  • Processzor\ Megszakítások (megszakítás/sec)
  • Processzor\ A processzor kihasználtsága (%)
  • Process(process)\ % Processor Time
  • Rendszer\ Processzor-várólista hossza

A számlálók küszöbértékeivel kapcsolatban tanulmányozza A teljesítmény elemzése című fejezetet, a teljesítményproblémák enyhítésével kapcsolatban pedig olvassa el a Teljesítményproblémák megoldása című részt.


A lemezerőforrások szűk keresztmetszeteinek feltárása

A következő számlálók segítségével azonosíthatók a lemezerőforrások szűk keresztmetszetei:

  • Fizikai lemez\ % Lemezhasználat ideje és % Üresjárási idő
  • Fizikai lemez\ Lemezolvasás/mp és Lemezre írás/mp
  • Fizikai lemez\ Lemezvezérlő-várólista átlagos hossza
  • Logikai lemez\ % Szabad terület

A memóriaszámlálókat is figyelje, hogy a lapozófájl túlzott használata nem terheli-e túl a lemezt.

A számlálók küszöbértékeivel kapcsolatos tudnivalókért tanulmányozza A teljesítmény elemzése című témakört, a teljesítményproblémák kiküszöbölését elősegítő hangolási technikákkal kapcsolatos tudnivalókért tanulmányozza a Teljesítményproblémák megoldása című témakört.

Megjegyzés

  • A fizikai lemezhez tartozó számlálók adataival ellentétben a logikai lemezhez tartozó számlálók adatait alapértelmezés szerint az operációs rendszer nem gyűjti. Ha a logikai meghajtók vagy tárolókötetek teljesítményszámlálóinak adataira kíváncsi, írja be a diskperf -yv parancsot a parancssorba. Ennek hatására a lemezteljesítmény adatainak gyűjtésére használt lemezteljesítmény statisztika illesztőprogram biztosítja a logikai meghajtók vagy tárolókötetek adatait. Alapértelmezés szerint az operációs rendszer a diskperf -yd parancsot használja a fizikai meghajtók adatainak gyűjtésére. A diskperf paranccsal kapcsolatos további tudnivalókért írja be a diskperf -? parancsot a parancssorba.


A hálózat szűk keresztmetszeteinek feltárása

A következő számlálók segítségével azonosíthatók a hálózati erőforrások szűk keresztmetszetei:

  • Hálózati illesztő\ Bájt összesen/mp, Küldött bájt/mp és Fogadott bájt/mp
  • Protokollszintű_objektum\ Fogadott szegmens/mp, Küldött szegmens/mp, Küldött keret/mp és Fogadott keret/mp

    • Az NWLink teljesítményobjektumai esetén a keretekkel kapcsolatos számlálók mindig nullát jeleznek. Ezekhez az objektumokhoz használjon datagram alapú számlálókat.

  • Hálózati csatoló\ Bájt összesen/mp, Küldött bájt/mp és Fogadott bájt/mp
  • Hálózati szegmens\ % Hálózat kihasználtsága

A számlálók küszöbértékeivel kapcsolatos tudnivalókért tanulmányozza A teljesítmény elemzése című témakört, a teljesítményproblémák kiküszöbölését elősegítő hangolási technikákkal kapcsolatos tudnivalókért tanulmányozza a Teljesítményproblémák megoldása című témakört.


A nyomtatókapacitás szűk keresztmetszeteinek feltárása

A következő számlálók segítségével azonosíthatók a nyomtatási erőforrások szűk keresztmetszetei:

  • Nyomtatási sor\ Kinyomtatott adatmennyiség (bájt/mp)
  • Nyomtatási sor\ Feladathibák

A Kinyomtatott adatmennyiség (bájt/mp) alacsony értékei átviteli problémát jelenthetnek. Ez az érték a nyomtató típusától függően változhat. Nézze meg a nyomtató dokumentációjában az átvitel elfogadható értékeit.

A feladathibákat általában helytelen portbeállítás okozza. Ellenőrizze, hogy a portbeállításban nem szerepelnek-e érvénytelen értékek.


A címtárszolgáltatás működésének figyelése

Az NTDS objektum a címtárszolgáltatás működéséről biztosít statisztikákat. Az objektum segítségével figyelhető néhány fontos számláló:

  • DRA csomagban maradó fogadott objektumfrissítések
  • DRA folyamatban levő replikációs szinkronizálások
  • LDAP-ügyfélmunkamenetek
  • LDAP kötési ideje


A QoS-belépésvezérlés figyelése

A QoS-belépésvezérlés megfigyelési célokra telepíti az ACS/RSVP teljesítményobjektumot. A hálózat rendszergazdájának kell megfigyelni az objektum által biztosított számlálókat, ha a QoS-belépésvezérlés engedélyezve van.


A DHCP figyelése

A DHCP-kiszolgáló teljesítményobjektum a DHCP-kiszolgáló szolgáltatás működését figyelő számlálókat tartalmaz. A számlálók használatával kapcsolatos további tudnivalókért tanulmányozza a DHCP – fogalmak című témakört.


A Tallózó szolgáltatás figyelése

Ha a vállalatnál Windows NT Server 4.0 alatt működő tartományok találhatók, a Tallózó szolgáltatás figyeléséhez használja a következő számlálókat:

  • Tallózó\ Teljesíthetetlen mailslot foglalások
  • Tallózó\ Mailslot megnyitási hibák (hiba/mp)
  • Tallózó\ Vehetetlen mailslot üzenetek
  • Tallózó\ Mailslot írási hibák
  • Tallózó\ Elveszített mailslot datagramok
  • Tallózó\ Elveszített körüzenetek száma
  • Tallózó\ Nem teljesített kiszolgálólista-kérelmek száma
  • Tallózó\ Elveszített kiszolgáló-bejelentkezések száma (hiba/mp)


Az internetes hitelesítési szolgáltatás figyelése

A következő objektumok az internetes hitelesítési szolgáltatás (IAS) működésének figyelésére használhatók:

  • IAS számlázási ügyfelek
  • IAS számlázási kiszolgáló
  • IAS hitelesítésű ügyfelek
  • IAS hitelesítési kiszolgáló


A Faxszolgáltatás figyelése

A Faxszolgáltatás objektum a Faxszolgáltatás működését figyeli a szolgáltatás futása közben. A szolgáltatás teljesítményének kiderítéséhez ajánlott a számlálókkal együtt a faxeseményekről szóló eseménynapló adatokat is használni.

Az alábbi számlálók rendszerproblémát jelezhetnek, például ha rossz modem-illesztőprogram van telepítve, amely megakadályozza a faxok küldését vagy fogadását:

  • Beérkező hibás fogadások. Ez a számláló a nem fogadott faxok számát jelzi. Ez lehet olyan fogadott hívás is, amely során nem történt faxfogadás.
  • Kimenő hibás kapcsolatok. Ez a számláló azon faxok számát mutatja, amelyeket a rendszer nem küldött el, mert nem volt tárcsahang, nem volt válasz, a vonal foglalt volt vagy más ismeretlen hiba történt.
  • Kimenő hibás átvitelek. Ez a számláló az el nem küldött faxok számát jelzi.

Ha ennek a számlálónak valamilyen értéke van, a részletekért ellenőrizze az eseménynaplót (nem volt tárcsahang, nem volt válasz vagy foglalt volt a vonal). Az ismeretlen hibák rendszerhibát jelezhetnek. Ebben az esetben ellenőrizze, hogy nem zajos-e a telefonvonal, valamint ellenőrizze a küldő és fogadó fax eszközöket, hogy a helyes modemillesztő van-e telepítve.


A WINS szolgáltatás figyelése

A WINS szolgáltatás telepíti a WINS-kiszolgáló teljesítményobjektumot a szolgáltatás tevékenységének figyelése céljából. A WINS-kiszolgáló teljesítményszámlálókat minden alkalommal lenullázza a rendszer, amikor elindítja vagy leállítja a szolgáltatást.

A WINS teljesítményszámlálókkal kapcsolatos további tudnivalókért tanulmányozza A WINS szolgáltatás teljesítményfigyelési eszközeivel kapcsolatos tudnivalók című témakört.


A telefonos kiszolgáló számlálóinak figyelése

Ha a számítógépet telefonos kiszolgálóként használja (például távelérés-kiszolgálóként), vagy ha nem Windows illesztőprogramot használ, hogy a Windows 2000 Server egy kis alközpontot vagy telefonközpontot emuláljon, figyelje a következő számlálókat és a kiszolgáló tevékenységét, hogy ezek az értékek alacsonyabbak-e a vártnál:
  • Tárcsázó\ Bejövő hívások (hívás/mp)
  • Tárcsázó\ Kimenő hívások (hívás/mp)
  • Tárcsázó\ Aktív vonalak


Az Elosztott tranzakciók koordinátorának figyelése

Az Elosztott tranzakciók koordinátora teljesítményobjektum az Elosztott tranzakciók koordinátoráról biztosít statisztikát, a külső, kétfázisú tranzakciókat koordináló Összetevő-szolgáltatások részeként. További tudnivalókért tanulmányozza az Összetevő-szolgáltatások című témakört.


Az Indexelő szolgáltatás figyelése

Az Indexelő szolgáltatás három különböző teljesítményobjektumot biztosít. Ezek a következők:

  • HTTP indexelő szolgáltatás. Ennek az objektumnak a számlálói az Indexelő szolgáltatás által futtatott lekérdezésekkel kapcsolatban készítenek statisztikát.
  • Indexelő szolgáltatás. Ennek az objektumnak a számlálói az Indexelő szolgáltatás által létrehozott és összefésült indexekkel kapcsolatos statisztikát készítenek.
  • Indexelő szolgáltatás szűrője. Ennek az objektumnak a számlálói az Indexelő szolgáltatás szűrő tevékenységéről készítenek statisztikát.

Használja a HTTP indexelő szolgáltatás\Összes visszautasított kérelem számlálót az Indexelő szolgáltatás által okozott szűk keresztmetszetek felderítéséhez.

További tudnivalókért tanulmányozza az Indexelő szolgáltatás – fogalmak című témakört.


Az SMTP figyelése

Az SMTP-kiszolgáló teljesítményobjektum az SMTP szolgáltatás által létrehozott üzenetforgalom figyelésére szolgál.


Az Internet Information Services figyelése

Az Internet Information Services a következő számlálókat biztosítja a szolgáltatás aktivitásának figyelésére.

  • FTP szolgáltatás objektum
  • Internet Information Services globális objektum
  • Webszolgáltatás objektum
  • Aktív kiszolgáló oldalak objektum

FTP szolgáltatás objektumszámlálók

Az FTP szolgáltatás objektumszámlálók adatokat mutatnak az FTP-kiszolgáló alkalmazással létrejött névtelen és nem névtelen kapcsolatokról. A számlálók helyenkénti bontásban jeleníthetők meg.

Internet Information Services globális objektum

Az Internet Information Services globális objektum olyan számlálókat tartalmaz, amelyek a sávszélesség szabályozásáról és az Internet Information Services (IIS) objektum gyorsítótárról, az IIS szolgáltatások megosztott gyorsítótáráról tartalmaznak adatokat.

A sávszélesség szabályozás az Internet Information Services olyan tulajdonsága, amely az IIS szolgáltatások által felhasznált sávszélességet tudja korlátozni a rendszergazda által megadott értékre. Ha az IIS szolgáltatások által használt sávszélesség megközelíti vagy meghaladja ezt a korlátot, a sávszélesség szabályozás visszautasít minden IIS szolgáltatáskérelmet, amíg nem áll több sávszélesség rendelkezésre.

Az IIS objektum gyorsítótár a gyakran használt objektumokat és az olyan objektumokat tárolja, amelyek ismételt letöltése a teljesítmény visszaesését eredményezné. A számlálók mutatják az IIS objektum gyorsítótár méretét, tartalmát és hatékonyságát (a találatok arányát).

Webszolgáltatás objektum

A webszolgáltatás objektum olyan számlálókat biztosít, amelyek adatokat mutatnak a HTTP-kiszolgáló alkalmazással létrejött névtelen és nem névtelen kapcsolatokról és a HTTP kérelmekről, a kérelmek módja szerint listázva, amelyek a webszolgáltatás elindítása óta történtek.

Aktív kiszolgáló oldalak objektum

Az Aktív kiszolgáló oldalak objektum az olyan, webkiszolgálón futó alkalmazások figyelésére szolgál, amelyek Aktív kiszolgáló oldalakat használnak. A Common Gateway Interface (CGI) alkalmazások vagy Internet Server Application Programming Interface (ISAPI) kiterjesztések által feldolgozott kérelmek a webszolgáltatás objektum számlálóival figyelhetők meg.


A Telefonkönyv szolgáltatás figyelése

A PBServer-figyelő teljesítmény objektum a telefonkönyv-kiszolgáló aktivitását figyeli. Az Összes találat/mp számláló a telefonkönyv-kiszolgáló forgalmának meghatározásához használható.


A számítógépben található RAM mennyiségének meghatározása

  1. A Windows 2000 asztalon kattintson a jobb oldali egérgombbal a Sajátgép ikonra, majd kattintson a Tulajdonságok parancsra.
  2. Az Általános lapon, a Számítógép részen látható a memória mennyisége kilobájtban (KB).


Ismerős feladatok elvégzésének új lehetőségei

A következő táblázatban a Rendszerfigyelő és a Teljesítménynaplók és riasztások ablakban (amely a Teljesítmény konzolon található, neve Perfmon.msc) elvégezhető általános feladatok láthatók, valamint ezek helye a Windows 2000 operációs rendszerben. Azon felhasználók kedvéért, akik a Teljesítményfigyelőt (Perfmon.exe) használják, a táblázatban a feladatok Windows NT 4.0 operációs rendszerben elfoglalt helye is látható. Az eszközsáv gombjainak egy része megegyezik mindkét verzióban, ezek használhatók az alábbiakban leírt lépések helyett.

Teendő: | Windows NT 4.0 esetén ezt használja: | Windows 2000 esetén ezt használja:
Diagram készítése a teljesítményadatokból. | A Felügyeleti eszközök menü Teljesítményfigyelő parancsa. | A Teljesítmény konzol Rendszerfigyelő eleme, amely a Felügyeleti eszközök ablakból indítható.
Jelentés létrehozása. | A Felügyeleti eszközök menü Teljesítményfigyelő parancsa. | A Teljesítmény konzol Rendszerfigyelő eleme, amely a Felügyeleti eszközök ablakból indítható.
Naplófájl létrehozása. | A Felügyeleti eszközök menü Teljesítményfigyelő parancsa. | A Teljesítmény konzol Teljesítménynaplók és figyelmeztetések eleme, vagy Számítógép-kezelés beépülő modulban található Rendszereszközök, amely a Felügyeleti eszközök ablakból indítható.
Naplófájl adatainak megtekintése. | A Felügyeleti eszközök menü Teljesítményfigyelő parancsa. | A Teljesítmény konzol Rendszerfigyelő eleme, amely a Felügyeleti eszközök ablakból indítható.
Figyelmeztetés létrehozása. | A Felügyeleti eszközök menü Teljesítményfigyelő parancsa. | A Teljesítmény konzol Teljesítménynaplók és figyelmeztetések eleme, vagy Számítógép-kezelés beépülő modulban található Rendszereszközök, amely a Felügyeleti eszközök ablakból indítható.
Munkaterület létrehozása több nézettel. | A Felügyeleti eszközök menü Teljesítményfigyelő parancsa. | Microsoft Management Console, a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsa.

A Teljesítményfigyelő Windows NT 4.0 rendszerben használt változatának megkeresésével kapcsolatos tudnivalókért tanulmányozza a Windows 2000 Resource Kit kiadványt.

A Windows 2000 Rendszerfigyelő beépülő modulban megnyithatók a Teljesítményfigyelő Windows NT 4.0 rendszerben használt verziójával létrehozott beállításfájlok.

Kapcsolódó témakörök


Kiszolgálóspecifikus

Az információ nem érhető el.

A keresett információ csak a Windows 2000 Server dokumentációjában található meg. Nem tartalmazza sem a Windows 2000 Professional, sem a Windows 2000 Administration Tools dokumentációja.

Az előző témakörhöz való visszatéréshez kattintson a Vissza gombra.