Internet Information Services

Amennyiben a számítógépre van IIS telepítve, a termékdokumentációt megtekintheti, ha a böngésző címsorába beírja a következőt: http://localhost/iisHelp/, és leüti az ENTER billentyűt.


Az IIS telepítése

Megjegyzés

A témakörben található információk az IIS 5.0-s verziójára vonatkoznak. Az újabb IIS verziókkal kapcsolatos információkat a telepítőprogramhoz mellékelt dokumentációban találja.

Az Internet Information Services 5.0 alapértelmezés szerint telepítve van a Windows 2000 Server operációs rendszerhez. Az IIS eltávolítását vagy további komponensek kiválasztását a Vezérlőpult Programok telepítése/törlése alkalmazásának segítségével végezheti el.

Az IIS telepítése

  1. Kattintson a Start gombra, mutasson a Beállítások pontra, kattintson a Vezérlőpult parancsra, majd indítsa el a Programok telepítése/törlése alkalmazást.
  2. Kattintson a Windows-összetevők hozzáadása/eltávolítása ikonra, majd az IIS-összetevők telepítéséhez, hozzáadásához, illetve eltávolításához kattintson az Összetevők gombra és kövesse a képernyőn megjelenő utasításokat.

Megjegyzés

Amennyiben a számítógépet frissítette a Windows 2000 operációs rendszerre, az IIS 5.0-s verzióját alapértelmezés szerint csak akkor telepíti, ha a PWS a Windows korábbi verziójához telepítve volt.


Szoftverlista

Az Internet Information Services telepítése előtt az alábbi szoftvereket kell a számítógépre telepíteni:

  • Windows TCP/IP protokoll és kapcsolódási segédprogramok. Az Interneten történő közzétételhez Internet-szolgáltatójának biztosítania kell az Ön kiszolgálójának IP-címét, alhálózati maszkját és az alapértelmezett átjáró IP-címét. (Az alapértelmezett átjáró az Internet-szolgáltató azon számítógépe, amelyen keresztül az Ön számítógépe az internetes forgalom egészét irányítja.)

Az alábbi választható összetevők használata ajánlott:

  • Az intranet egyik számítógépére telepített Tartománynévrendszer (DNS) szolgáltatás. Ha az intranet kicsi, a hálózat számítógépein a Hosts vagy Lmhosts fájlokat is alkalmazhatja. Ez a lépés nem kötelező, de ez teszi lehetővé a felhasználók számára a „barátságos” szöveges nevek alkalmazását IP-címek helyett. Az Interneten lévő webhelyek általában a Tartománynévrendszert alkalmazzák. Ha regisztráltat a helynek egy tartománynevet, a felhasználók a webhellyel való kapcsolatvételhez ezt a nevet írhatják a böngésző címsorába.
  • Biztonsági okokból a Microsoft azt ajánlja, hogy az IIS által használt minden meghajtó NTFS fájlrendszerű legyen.
  • Microsoft FrontPage (HTML-lapok készítésére a webhely számára). A FrontPage egy alakhű szerkesztő, mely felhasználóbarát grafikai felületet kínál olyan feladatok elvégzésére, mint a táblázatok, grafikák vagy szkriptek beillesztése.
  • Microsoft Visual InterDev (Interaktív webalkalmazások létrehozásához).

Kapcsolódó témakörök

Amennyiben a számítógépre van IIS telepítve, a további tudnivalókat tartalmazó on-line IIS dokumentációt megtekintheti, ha a böngésző címsorába beírja a következőt: http://localhost/iisHelp/, és leüti az ENTER billentyűt.


IIS – hibaelhárítás

Hibaelhárítás

Amennyiben probléma merül fel a webkiszolgáló működésében, az alábbi témakör információi alapján a következő hibákat keresheti meg.

A telepítés tesztelése

Telepítés után az Internet Explorer segítségével megtekintheti a kezdőkönyvtárban lévő fájlokat és tesztelheti a telepítést.

Internetre csatlakozott webhely tesztelése

  1. Ellenőrizze, hogy a webkiszolgáló Wwwroot mappájában vannak-e HTML-fájlok.
  2. Indítson el egy webböngészőt, például az Internet Explorer programot, egy aktív Internet kapcsolattal rendelkező számítógépen. Ez lehet a tesztelt számítógép is, de a teszteléshez tanácsos a hálózat egy másik számítógépét használni.
  3. Írja be az új webhely kezdőkönyvtárának URL-címét.

    4. Az URL-cím: „http://” melyet a webhely neve és a megtekinteni kívánt fájl elérési útja követ. (Ne feledje a fordított perjeleket.) Ha például a hely DNS-regisztrációja: „peldak.microsoft.com”, és a kezdőkönyvtár gyökérkönyvtárában lévő Kezdolap.htm nevű fájlt szeretné megtekinteni, a Cím mezőbe írja be a következőt: http://peldak.microsoft.com/kezdolap.htm, majd nyomja le az ENTER billentyűt. A kezdőlap megjelenik a képernyőn.

Webhely tesztelése az intraneten

  1. Győződjön meg arról, hogy a számítógép rendelkezik aktív hálózati kapcsolattal, és működik a WINS-kiszolgáló szolgáltatás (vagy más névhozzárendelési módszer).
  2. Indítson el egy webböngészőt, például a Microsoft Internet Explorer alkalmazást.
  3. Írja be az új kiszolgáló kezdőkönyvtárának URL- (Uniform Resource Locator) címét.

    4. Az URL-cím: „http://” melyet a kiszolgáló Windows-hálózati neve és a megtekinteni kívánt fájl elérési útja követ. (Ne feledje a fordított perjeleket.) Ha például a webhely WINS-kiszolgálói regisztrációja: „Admin1”, és a kezdőkönyvtár gyökérkönyvtárában lévő Kezdolap.htm nevű fájlt szeretné megtekinteni, a Cím mezőbe írja be a következőt: http://admin1/kezdolap.htm, majd nyomja le az ENTER billentyűt. A kezdőlap megjelenik a képernyőn.

Kapcsolódó témakörök

Amennyiben a számítógépre van IIS telepítve, a további tudnivalókat tartalmazó on-line IIS dokumentációt megtekintheti, ha a böngésző címsorába beírja a következőt: http://localhost/iisHelp/, és leüti az ENTER billentyűt.


Elektronikus levelezés

Amennyiben a számítógépre van elektronikus levelezés (Simple Mail Transfer protokoll, SMTP) telepítve, a termékdokumentációt megtekintheti, ha a böngésző címsorába beírja a következőt: file:\\%rendszergyökér%\help\mail.chm, majd lenyomja az ENTER billentyűt.

e-mail, elektronikus levelezés, mailto:, Simple Mail Transfer protokoll, SMTP, levelezési protokollok, postafiókok, Lightweight Directory Access protokoll, LDAP, internetes levelezés, elektronikus levelezés konfigurálása, üzenetek.


FrontPage kiszolgálóbővítmények

A FrontPage kiszolgálóbővítmények egy három programból álló csomag, mely olyan szolgáltatásokat támogat, mint a weblapok közös létrehozása, találatszámlálók, elektronikus postai űrlapkezelés és a webhely közvetlenül a kiszolgáló-számítógépen való szerkesztése.

A Microsoft® FrontPage® MMC beépülő modul olyan program, amely a FrontPage kiszolgálóbővítmények és a FrontPage-bővítésű webhelyek felügyeletére szolgál. Egyebek mellett a virtuális kiszolgálók bővítésére, alwebek létrehozására, kiszolgálóbővítmények frissítésére weben, mappák alwebekké, illetve alwebek mappákká történő alakítására, webhivatkozásainak újraszámolására használható.

A Microsoft® FrontPage® MMC beépülő modul teljes súgórendszerrel rendelkezik, mely a FrontPage kiszolgálóbővítmények áttekintését és a kiszolgálóbővítmények felügyeleti eljárásainak leírását kínálja. Ez a súgófájl alapértelmezés szerint a C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\bin\nnnn\Fpmmc.chm helyre van telepítve, ahol nnnn a FrontPage kiszolgálóbővítmények telepítési nyelvétől függő numerikus név. Például az amerikai angol nyelvű telepítéshez az elérési út: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\bin\1033\Fpmmc.chm. A kiszolgálóbővítmények dokumentációja a http://officeupdate.microsoft.com/frontpage/wpp/serk/ címen is elérhető.

FrontPage kiszolgálóbővítmények, webkiszolgáló, webfelügyelet, web felügyelete, FrontPage-bővítésű web


IIS-keresés eredményét megjelenítő lap

Internet Information Services

A keresett témakör megtalálható az IIS on-line súgójában. Amennyiben a számítógépre van IIS telepítve, a dokumentációt megtekintheti, ha a böngésző címsorába beírja a következőt: http://localhost/iisHelp/, és leüti az ENTER billentyűt. Ekkor újra beírhatja a keresett szót vagy kifejezést.

Az Internet Information Services használata

Az Internet Information Services (IIS) olyan Windows-összetevő, amely megkönnyíti az információ közzétételét és az üzleti alkalmazások létrehozását a weben. Az IIS segítségével a hálózati alkalmazások és kommunikáció számára hatékony platformot hozhat létre.

Megjegyzések

  • A Windows Internet Information Services indításához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson a Számítógép-kezelés parancsra. A Microsoft Management Console (MMC) konzolfáján bontsa ki a Szolgáltatások és kiszolgálói alkalmazások csomópontot, és jelölje ki az Internet Information Services elemet.
  • Ha a keresett szó nem szerepel a témakörben, akkor forduljon az Internet Information Services termékdokumentációjához.
Aktív Channel, Active Server Pages, ActiveX, felügyelet, kiszolgáló, névtelen hozzáférés, alkalmazásgyökér, alkalmazások, ASP beépített objektumok, hitelesítés, Alapfokú hitelesítés, gyakorlati tanácsok, Internet, böngésző alapú felügyelet, böngészők, Internet bizonyítványok, digitális, CGI-alkalmazások, kihívás/válasz hitelesítés, csatornák, ügyfelek, Internet, ügyféloldali szkriptírás, fürtkiszolgáló, COM-komponens, MTS, kapcsolat, Internet-tartalom, dinamikus tartalom, interaktív, szabályzás, ActiveX, összeomlás elleni védelem, adatbázis-alkalmazások, DCOM, DHTML, XML, dokumentáció, Internettel összefüggő, elektronikus kereskedelem, titkosítás, űrlap, FTP, File Transfer Protocol, GIF, JPG, JPEG, HTML, közzététel, HTTP, IIS, Admin objektum, Base objektum, minták, telepítés, az Internet Information Server telepítése, Internet Information Services, Internet-kiszolgálók, Internetes szolgáltatások kezelője, Internet-szolgáltató, ISP, intranet, ISAPI, ISAPI-kiterjesztések, ISAPI-szűrők, ISDN, IUSR_számítógépnév, Java, Javascript, JS, Microsoft Management Console, MMC, modem, engedélyek, PICS, folyamatelszigetelés, készletezés, programozás, távfelügyelet, szkriptírás, biztonság, Vállalkozás, telepek, kiszolgálóoldali szkriptírás, munkamenet, állapot, SSL, szabványok, tranzakció, uniform resource locator, URL, VBScript, virtuális könyvtár, Webtelepek, lap, hely, állomások, World Wide Web, WWW, WWWgyökér, InetPub, InetSrv, Personal Web Manager, ISM, PWM, PWS, Personal Web Server, Personal Web Services, Peer Web Server, Peer Web Services, Secure Sockets Layer, Windows 2000, Windows 2000, Professional, Server, Advanced Datacenter.