A hardver – áttekintés

A hardver a számítógéphez csatlakoztatott és annak mikroprocesszora által vezérelt összes fizikai eszköz összefoglaló neve. Magába foglalja azokat az eszközöket, amelyek a gyártás során kerültek a számítógépbe, valamint a később csatlakoztatott perifériákat. Eszköz például a modem, a lemezmeghajtó, a CD-ROM-meghajtó, a nyomtató, a hálózati csatoló, a billentyűzet vagy a videokártya.

Az eszközöket (akár Plug and Play eszközök, akár nem) többféle módon lehet csatlakoztatni a számítógéphez. Egyes eszközöket, például a hálózati csatolókat és a hangkártyákat a számítógép belsejében található bővítőhelyekbe kell illeszteni. Más eszközök, például a nyomtatók és a lapolvasók a számítógép külső portjaira csatlakoznak. Vannak olyan eszközök is (a PC-kártyák), amelyek csak a hordozható számítógépek PC-kártya bővítőhelyeire csatlakoztathatók.

Ahhoz, hogy az eszköz megfelelően működjön együtt a Windows 2000 rendszerrel, eszközillesztő néven ismert programot kell a számítógépre telepíteni (és használat előtt a memóriába tölteni). Minden eszköznek saját eszközillesztője van, amelyet általában a gyártó mellékel az eszközhöz. Néhány eszközillesztőt azonban a Windows 2000 is tartalmaz.

Az eszközöket a Vezérlőpultról indítható Hardver hozzáadása/eltávolítása varázsló vagy az Eszközkezelő segítségével lehet beállítani.

Fontos!

  • A Vezérlőpultról indítható Hardver hozzáadása/eltávolítása varázslóval vagy az Eszközkezelővel történő eszközbeállításhoz rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózathoz van csatlakoztatva, a hálózat házirendjeinek beállításai is megakadályozhatják a hardvertelepítést.

Megjegyzés

  • Ha egyszerre szeretné frissíteni az összes illesztőprogramot, használja a Windows Update parancsot. A rendszer Windows Update paranccsal történő frissítéséről a Kapcsolódó témakörök hivatkozásra kattintva kaphat bővebb tájékoztatást.

Kapcsolódó témakörök


Általános feladatok Hardver hozzáadása/eltávolítása

A hardverek kezelése során az alábbi feladatok gyakran előfordulnak.

Hardvereszközök telepítése és eltávolítása

Új eszközök hozzáadását és eltávolítását jelenti – az eszközök lehetnek Plug and Play, nem Plug and Play, SCSI és USB típusú eszközök.

Az eljárás lépésről lépésre

Kapcsolódó témakörök

Eszközillesztők frissítése

E feladattal eszközillesztőkett lehet frissíteni, és az illesztőprogramok részleteit lehet megtekinteni.

Az eljárás lépésről lépésre

Hardverhibák elhárítása

Az adott eszköz telepítése a hibaelhárítók és egyéb eszközök használatával kiértékelhető és javítható.

Az eljárás lépésről lépésre

Hardvereszköz lecsatlakoztatása vagy kiszerelése

A biztonságos lecsatlakoztatáshoz vagy eszközkiszereléshez állítsa le az eltávolítandó eszközt. A számítógépet nem kell kikapcsolni.

Az eljárás lépésről lépésre


Eszköz telepítése

  • Csatlakoztassa az eszközt gyártójának utasításai szerint a számítógép megfelelő portjához vagy illessze a megfelelő bővítőhelyre. Egyes esetekben ezután kell elindítani a számítógépet, vagy újra kell azt indítani.

Megjegyzések

  • Előfordulhat, hogy a Plug and Play eszközök hozzáadásához és beállításához rendszergazdai jogosultságokkal kell rendelkeznie. Rendszergazdai jogosultságok akkor szükségesek, ha az eszköz telepítéséhez valamilyen felhasználói felületre van szükség, vagy ha hibákat észlel a telepítés során. Közvetlenül a számítógéphez csatlakozó nem Plug and Play eszköz hozzáadásához és beállításához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha számítógépe hálózathoz van csatlakoztatva, a hálózat házirendjeinek beállításai is megakadályozhatják az eljárás végrehajtását.
  • Ha a rendszergazdák egyike már telepítette az eszköz illesztőprogramjait, Ön rendszergazdai jogosultságok nélkül is telepítheti az eszközt.
  • Ha el kell indítani vagy újra kell indítani a számítógépet, a Windows 2000 észleli az eszközt, és elindítja az Új talált hardver varázslót.
  • Ha be is kell szerelnie az eszközt (például hangkártyát) a gép valamelyik bővítőhelyére, állítsa le a Windowst és kapcsolja ki a számítógépet. Távolítsa el a számítógép borítását, és illessze az eszközt a megfelelő bővítőhelyre. Helyezze vissza a borítást, majd kapcsolja be a számítógépet.
  • Ha az eszköz telepítése nem megy automatikusan végbe, régebbi vagy nem Plug and Play eszközről van szó. Ha a Plug and Play eszközök telepítésével kapcsolatban információra van szüksége, kattintson a Kapcsolódó témakörök hivatkozásra.
  • Ha a program kéri, kövesse a képernyőn megjelenő utasításokat az eszköz-illesztőprogramok telepítési helyének kiválasztásához.
  • Ha SCSI (small computer system interface) eszközről van szó, csatlakoztassa azt a gyártó utasításai szerint a számítógép SCSI-portjához. Indítsa újra vagy kapcsolja be a számítógépet.

    Ellenőrizze, hogy az SCSI-eszköz eszközszámát nem használja-e már másik SCSI-eszköz. Az eszközszám megváltoztatásához tanulmányozza az eszköz gyártójának utasításait.

  • Ha USB (universal serial bus) vagy IEEE 1394 típusú eszközről van szó, csatlakoztassa azt a számítógép valamelyik USB- vagy IEEE-portjához. Kövesse a képernyőn megjelenő utasításokat.

    USB vagy IEEE 1394 típusú eszközök telepítésekor vagy azok számítógéphez csatlakoztatásakor nem kell a számítógépet leállítani vagy kikapcsolni. Noha az USB és az IEEE 1394 típusú eszközök működése hasonló, az USB- és IEEE 1394 csatlakozásokat nem lehet felcserélni.

  • Ha Ön nem rendszergazda, illetve nem a Rendszergazdák csoport tagja, egyes rendszergazdai feladatok végrehajtásához használhatja a Futtatás mint parancsot. A Futtatás mint parancs használatával kapcsolatos tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.


Eszközök telepítése

Az új eszközök telepítése többnyire három lépésből áll:

  • az eszköz csatlakoztatása a számítógéphez
  • a megfelelő eszközillesztők telepítése, és
  • az eszköz tulajdonságainak és beállításainak megadása.

Az eszköz megfelelő működésének biztosításához kövesse a gyártó telepítésre vonatkozó utasításait. Ehhez néha le kell állítani a számítógépet és ki kell húzni annak hálózati csatlakozóját, és csak aztán csatlakoztatható az eszköz a megfelelő porthoz vagy illeszthető a megfelelő bővítőhelyre.

Ha Plug and Play eszközről vagy az indításhoz elengedhetetlen eszközről (például merevlemezről) van szó, a program automatikusan felismeri azt. Egyes régebbi eszközök esetében azonban lehet, hogy a számítógéphez csatlakoztatás után újra kell indítani a számítógépet. A Windows 2000 ezután megpróbálja megkeresni az új eszközt.

Ha nem Plug and Play eszközről van szó, ajánlatos a Vezérlőpultról indítható Hardver hozzáadása/eltávolítása varázslót használni – ez az alkalmazás közölni tudja a Windows 2000 operációs rendszerrel, hogy milyen eszköz telepítése zajlik. Az eszköz felismerése (vagy annak a Hardver hozzáadása/eltávolítása varázslóval történő azonosítása) után a Windows 2000 a megfelelő eszközillesztők betöltéséhez kérheti a Windows 2000 CD-ROM vagy a gyártó által mellékelt hajlékonylemez behelyezését.

Az eszközillesztők betöltése után a Windows 2000 konfigurálja az eszköz tulajdonságait és beállításait. Bár ezek kézzel is konfigurálhatók, jobb, ha hagyja, hogy a Windows 2000 végezze el a beállítást. Ha kézzel adja meg a tulajdonságokat és beállításokat, a beállítások állandósulnak, ami azt jelenti, hogy a Windows 2000 nem tudja azokat módosítani, ha a jövőben valamilyen probléma lép fel vagy eszközütközés keletkezik.

Fontos!

  • A Vezérlőpultról indítható Hardver hozzáadása/eltávolítása varázslóval történő eszköztelepítéshez rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózatra van csatlakoztatva, a hálózat házirendjeinek beállításai is megakadályozhatják a hardvertelepítést. Ha a rendszergazdák egyike már telepítette az eszközillesztőket, Ön rendszergazdai jogosultságok nélkül is telepítheti az eszközt.


Eszközök eltávolítása

  1. Nyissa meg a Vezérlőpultról a Hardver hozzáadása/eltávolítása ablakot.
  2. Kattintson a Tovább gombra, jelölje be az Eszköz eltávolítása/kihúzása választógombot, majd kattintson ismét a Tovább gombra.
  3. Jelölje be az Eszköz eltávolítása választógombot, majd kattintson a Tovább gombra.
  4. Kattintson az eltávolítani kívánt eszközre, majd a Tovább gombra.
  5. Kövesse a képernyőn megjelenő utasításokat.
  6. Ha végzett az eltávolítással, csatlakoztassa le az eszközt a számítógépről, vagy szerelje ki belőle.

Megjegyzések

  • Plug and Play eszközök eltávolításához általában nem kell az Eszközkezelőt vagy a Hardver hozzáadása/eltávolítása varázslót használni. Egyszerűen csak csatlakoztassa le a Plug and Play eszközt a számítógépről, vagy szerelje ki belőle. Lehet, hogy újra kell indítani a számítógépet. További információt a gyártó által mellékelt használati utasításban talál.
  • Az eszközök az Eszközkezelő segítségével is eltávolíthatók.
  • Az eszköz eltávolításakor annak eszközillesztőit az operációs rendszer nem törli a számítógép merevlemezéről.
  • Ha Ön nem rendszergazda, illetve nem a Rendszergazdák csoport tagja, egyes rendszergazdai feladatok végrehajtásához használhatja a Futtatás mint parancsot. A Futtatás mint parancs használatával kapcsolatos tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.


Eszközök eltávolítása

A Plug and Play eszközök eltávolítása általában az eszköz lecsatlakoztatásával vagy kiszerelésével történik. Egyes eszközök esetén ehhez előbb ki kell kapcsolni a számítógépet. Ha biztos akar lenni abban, hogy megfelelően hajtja végre az eltávolítást, nézze át az eszköz gyártójának telepítésre és eltávolításra vonatkozó utasításait.

A nem Plug and Play típusú eszközök eltávolítása általában két lépésből áll:
  • az eszköz eltávolítása a Vezérlőpult segítségével, illetve
  • az eszköz kiszerelése a számítógépből.

Azt, hogy el szeretne távolítani egy nem Plug and Play eszközt, a Hardver hozzáadása/eltávolítása varázsló vagy az Eszközkezelő segítségével lehet a Windows 2000 tudomására hozni. Miután közölte a Windows 2000 rendszerrel, hogy eltávolít egy eszközt, le kell azt csatlakoztatnia, vagy el kell távolítania a számítógépből. Ha az eszköz például a számítógép valamelyik külső portjára csatlakozik, ki kell kapcsolni a számítógépet, el kell távolítani az eszközt az adott portról, majd ki kell húzni az eszköz tápkábelét.

Ha olyan eszközről van szó, amelyet később esetleg újra használni fog (például egy modemről), a Plug and Play eszközöket eltávolítás helyett érdemesebb letiltani. A letiltott eszközök fizikailag továbbra is a számítógéphez vannak csatlakoztatva, de a Windows 2000 úgy frissíti a rendszerleíró adatbázist, hogy az eszközillesztők a számítógép következő indításakor már ne töltődjenek be. Ha újra engedélyezi az eszközt, annak illesztőprogramjai ismét betöltődnek. Az eszközök letiltása akkor hasznos, ha a számítógépet többféle hardverkonfigurációval kívánja használni, vagy ha dokkolóegységhez csatlakoztatott hordozható számítógépet használ.

Megjegyzés

  • A Hardver hozzáadása/eltávolítása varázsló és az Eszközkezelő nem távolítja el az eszközillesztőket a merevlemezről. Ha mégis el szeretné távolítani az illesztőprogramokat, nézze át az eszköz gyártója által mellékelt dokumentációt, amelyből megtudhatja, hogy mely illesztőprogramokat kell eltávolítani.


Eszközök beállítása

Plug and Play eszköz telepítése esetén a Windows 2000 automatikusan úgy állítja azt be, hogy megfelelő módon működjön együtt a számítógépben lévő többi eszközzel. A beállítási folyamat részeként a Windows 2000 a rendszer erőforrásainak egy egyedi készletét rendeli a frissen telepített eszközhöz. Az erőforrások az alábbiakat – vagy azok egy részét tartalmazhatják:

  • Megszakításkérés (IRQ) vonalainak száma.
  • Közvetlen memória-hozzáférési (DMA) csatornák.
  • Bemeneti/kimeneti (I/O) portok címei.
  • Memóriacím-tartományok.

Az eszközökhöz rendelt mindegyik erőforrásnak egyedinek kell lennie, különben az eszköz nem működik megfelelően. Plug and Play eszközök esetén a Windows 2000 automatikusan elvégzi ezeknek az erőforrásoknak a helyes beállítását.

Néha előfordulhat, hogy két eszköz ugyanazt az erőforrást igényli, ami eszközütközéshez vezet. Ha ez a helyzet áll elő, kézzel meg lehet változtatni az erőforrás-beállításokat úgy, hogy végül minden beállítás egyedi legyen. Egyes esetekben azonban – az eszköz-illesztőprogramoktól és a számítógép felépítésétől függően – két eszköz is használhat egy erőforrást (például két PCI-eszköz használhat azonos megszakításkérést).

A nem Plug and Play eszközök telepítésekor nincs automatikus erőforrás-hozzárendelés. A beállításokat a telepítendő eszköz típusától függően kézzel kell megadni. A megfelelő beállításokat az eszközhöz mellékelt használati utasításnak kell tartalmaznia.

Az erőforrásokat általában nem szabad kézzel módosítani, mert ekkor a beállítások állandósulnak, és a Windows 2000 operációs rendszer kisebb rugalmassággal tud csak új eszközhöz erőforrásokat rendelni. Ha túl sok erőforrás állandósul, előfordulhat, hogy a Windows 2000 nem lesz képes új Plug and Play eszközöket telepíteni.

Az eszközöket a Vezérlőpultról indítható Hardver hozzáadása/eltávolítása varázsló vagy az Eszközkezelő segítségével lehet beállítani.

Fontos!

  • Ha helytelen erőforrás-beállításokat ad meg, előfordulhat, hogy az adott hardvereszközt az operációs rendszer letiltja, a számítógép pedig működési hibákat produkál vagy működésképtelenné válik. Az erőforrás-beállításokat csak akkor szabad megváltoztatni, ha biztos abban, hogy az új beállítás nem ütközik más hardvereszköz beállításaival, vagy ha az eszköz gyártója speciális erőforrás-beállításokat ír elő.


Eszközhibák diagnosztizálása

  1. Nyissa meg a Vezérlőpultról a Hardver hozzáadása/eltávolítása ablakot.
  2. Kattintson a Tovább gombra, jelölje be az Eszköz hozzáadása/hibaelhárítása választógombot, majd kattintson ismét a Tovább gombra. A Windows 2000 megpróbál új Plug and Play eszközöket keresni.
  3. Jelölje ki azt az eszközt, amelyet diagnosztizálni és javítani szeretne, majd kattintson a Tovább gombra.
  4. Kövesse a képernyőn megjelenő utasításokat.

Megjegyzések

  • Ha az adott eszköz nem szerepel a listán, válassza a lista Új eszköz hozzáadása elemét, majd kövesse a képernyőn megjelenő utasításokat.
  • Egyes diagnosztikai feladatokat – a nem megfelelően működő eszközök javítását is beleértve – az Eszközkezelő segítségével is elvégezhet. Ez csak azoknak a felhasználóknak javasolt, akik alaposan ismerik az eszközök működését és az eszközkonfigurációkat.
  • Ha Ön nem rendszergazda, illetve nem a Rendszergazdák csoport tagja, egyes rendszergazdai feladatok végrehajtásához használhatja a Futtatás mint parancsot. A Futtatás mint parancs használatával kapcsolatos tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.


Eszközök lecsatlakoztatása vagy kiszerelése

  1. Nyissa meg a Vezérlőpultról a Hardver hozzáadása/eltávolítása ablakot.
  2. Kattintson a Tovább gombra, jelölje be az Eszköz eltávolítása/kihúzása választógombot, majd kattintson ismét a Tovább gombra.
  3. Jelölje be az Eszköz kihúzása/kiadása választógombot, majd kattintson a Tovább gombra.
  4. Jelölje ki a lecsatlakoztatni vagy kiszerelni kívánt eszközt, majd kattintson a Tovább gombra.
  5. A Tovább gombra kattintva erősítse meg, hogy valóban le szeretné csatlakoztatni vagy ki szeretné szerelni az eszközt.
  6. Kattintson a Befejezés gombra.

Fontos!

  • Az adatvesztés, illetve a számítógép vagy az eszköz egyéb súlyos működési hibái elkerülése érdekében az eszköz fizikai lecsatlakoztatása előtt mindenképp használja a Hardver hozzáadása/eltávolítása varázslót.

Megjegyzések

  • Ha gyakran kell eszközöket lecsatlakoztatnia, jelölje be A Hardver hozzáadása/eltávolítása varázsló bezárása lapon a Leválasztás/kiadás ikonjának megjelenítése a Tálcán jelölőnégyzetet. Amikor a következő alkalommal le szeretné csatlakoztatni vagy ki szeretné szerelni az eszközt, a Hardver hozzáadása/eltávolítása varázsló helyett használhatja az ikont is.
  • Az eszköz újratelepítéséhez helyezze azt a megfelelő aljzatba, vagy csatlakoztassa a megfelelő portra.


Hordozható számítógép leválasztása

  1. Kattintson a Start gombra.
  2. Kattintson a PC leválasztása parancsra. Egy üzenet jelenik meg, amely arról tájékoztat, hogy a számítógép biztonságosan leválasztható.
  3. Válassza le a hordozható számítógépet, illetve ha automatikus dokkolóegysége van, a hordozható számítógép automatikusan leválik.

Megjegyzések

  • Ha a PC leválasztása parancs nem szerepel a Start menüben, akkor a számítógép első alkalommal történő leválasztására használja a Vezérlőpultról elérhető Hardver hozzáadása/eltávolítása varázslót. További tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.
  • Ha a PC leválasztása parancs még ezután sem jelenik meg a Start menüben, lehet, hogy a számítógép nem támogatja a leválasztást, vagy Önnek nincsenek meg a megfelelő adatvédelmi jogosultságai a hordozható számítógép leválasztására. A megfelelő jogosultságokat a rendszergazdától kaphatja meg.
  • Vannak olyan számítógépek, amelyeknél leválasztó nyomógomb található a dokkolóegységen. Ha a fent leírt eljárás helyett a gombot nyomja meg, azzal szintén leválasztja a hordozható számítógépet. További információt a gyártó által adott használati utasítás tartalmaz.
  • Ha a hálózaton található fájlokkal vagy mappákkal szeretne dolgozni, ellenőrizze, hogy elérhetővé tette-e azokat a leválasztott számítógépen is. További tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.
  • A hordozható számítógéppel úgy tud optimális teljesítményt elérni, ha a Vezérlőpultról elérhető Energiagazdálkodási lehetőségek párbeszédpanelen módosítja az energiaellátási sémát. További tájékoztatásért kattintson a Kapcsolódó témakörök hivatkozásra.
  • A leválasztás után a hálózaton elérhető programok a hordozható számítógépen nem állnak rendelkezésre.


Plug and Play – áttekintés

A Windows 2000 operációs rendszerben nagyon egyszerű a Plug and Play eszközök telepítése. Csak csatlakoztatni kell az eszközt, a Windows 2000 elvégzi a többit, azaz telepíti a szükséges illesztőprogramokat, frissíti a rendszert, és lefoglalja a szükséges erőforrásokat.

Egy hordozható számítógépet például a konfiguráció megváltoztatása nélkül lehet dokkolni és a hálózathoz csatlakoztatni. Később leválaszthatja a számítógépet, és modemmel kapcsolódhat a hálózathoz, de ekkor sem kell semmit módosítani a konfiguráción. A Windows 2000 megteszi ezt Ön helyett.

A Plug and Play technológiát használva biztos lehet benne, hogy bármilyen új eszköz megfelelő módon fog együttműködni a többivel, és hogy a számítógép helyesen indul újra a hardvereszközök telepítése vagy eltávolítása után.

A Plug and Play vezérlő a számítógép indításakor felismer bármilyen új hardvereszközt, és betölti hozzá a megfelelő illesztőprogramokat.

Hardvereszközök telepítésekor vagy eltávolításakor a Plug and Play vezérlő együttműködik a Windows 2000 Energiagazdálkodási lehetőségek nevű eszközével, hogy kezelje a hardver és a perifériák energiaigényét, a használaton kívüli eszközöket pedig energiatakarékos üzemmódba helyezi. Ha más programot is használ eszköztelepítéskor vagy eszközök eltávolításakor, a Plug and Play vezérlő figyelmeztetést küld, hogy mentse eddigi munkáját, mert módosítani fogja a számítógép konfigurációját.

Ha valamilyen hiba lép fel, a Plug and Play vezérlő bejegyzi az információkat az Eseménynaplóba.


Plug and Play eszközillesztők támogatása

A Windows 2000 automatikusan telepíti a Plug and Play eszközöket és azok illesztőprogramjait. Ha azonban régebbi illesztőprogramot vagy hardvereszközt szeretne telepíteni, lehet, hogy csak korlátozott Plug and Play támogatást vehet igénybe, vagy esetleg semmilyet.

Ha nem Plug and Play eszköz telepítésekor Plug and Play illesztőprogramot használ, előfordulhat, hogy a rendszer bizonyos mértékben mégis támogatja a Plug and Play funkciót. Bár a rendszer nem fogja felismerni a hardvert, és nem tölti be hozzá önállóan a megfelelő illesztőprogramokat, a Plug and Play vezérlő képes – a Vezérlőpult Energiagazdálkodási lehetőségek eszközével együttműködve – az erőforrások lefoglalásával felügyelni a telepítést, minden szükséges lépést bejegyezve az Eseménynaplóba.

Nagy általánosságban azonban elmondható, hogy nem Plug and Play eszközöket nem lehet úgy telepíteni, hogy ne kellene néhány beállítást kézzel is elvégezni. A régebbi eszközök által igényelt beállítások elvégzésére használja a Vezérlőpultról elérhető Hardver hozzáadása/eltávolítása varázslót vagy az Eszközkezelőt.

Egy nem Plug and Play eszköz eltávolítása előtt a Hardver hozzáadása/eltávolítása varázsló vagy az Eszközkezelő segítségével közölni kell a Windows 2000 rendszerrel, hogy el szeretné távolítani az adott eszközt. Amint a Windows 2000 értesült erről, többé nem tölti be a számítógép indításakor az eszköz illesztőprogramjait.

Fontos

  • A Vezérlőpultról indítható Hardver hozzáadása/eltávolítása varázslóval vagy az Eszközkezelővel történő eszköztelepítéshez rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózathoz van csatlakoztatva, a hálózat házirendjeinek beállításai is megakadályozhatják a hardvertelepítést. Ha a rendszergazdák egyike már telepítette az eszköz illesztőprogramjait, Ön rendszergazdai jogosultságok nélkül is telepítheti az eszközt.


Plug and Play eszközök használata ACPI-hardverrel

Ha teljes mértékben élvezni akarja a Plug and Play által nyújtott előnyöket, használjon ACPI-üzemmódban futó Speciális konfiguráció és energiagazdálkodás (ACPI) Plug and Play eszközöket. Az ACPI-üzemmódot használó számítógépekben az operációs rendszer – és nem a hardver – állítja be és ellenőrzi a számítógépet.

A Windows 2000 operációs rendszer meghatározza, hogy mely programok aktívak, és kezeli a számítógép alrendszereinek és perifériáinak összes energiaigényét. Az ACPI lehetővé teszi, hogy az operációs rendszer a szükségleteknek megfelelően juttassa el az energiát az eszközökhöz, megelőzve ezzel a rendszerben esetleg jelentkező szükségtelen energiaigényeket.

Mivel a Windows 2000 vezérli a számítógép erőforrásait és beállításait, újraindítás nélkül lehet Plug and Play hardvereszközöket telepíteni. A Windows 2000 automatikusan azonosítja az új hardvereszközöket, és telepíti hozzájuk a megfelelő illesztőprogramokat. Ha más típusú számítógépet használ, lehet, hogy új hardvereszközök telepítésekor a beállítás egyes lépéseit kézzel kell elvégeznie, és esetleg újra is kell indítania a számítógépet.


Energiagazdálkodás Plug and Play eszközök telepítése közben

A Plug and Play eszközök vezérlője együttműködik a Vezérlőpult Energiagazdálkodási lehetőségek nevű eszközével, hogy biztosítsa a rendszer gazdaságos működését a hardvereszközök telepítése és eltávolítása során. Az Energiagazdálkodási lehetőségek eszköz vezérli a számítógéphez kapcsolt eszközök energiaellátását, mégpedig úgy, hogy az éppen használt eszközöket ellátja energiával, a nem használtakat pedig energiatakarékos üzemmódba helyezi. A Windows 2000 automatikusan végzi az eszközök energiaellátását. Egyes eszközökhöz azonban az Eszközkezelőben megadható beállítások tartoznak.

Az Energiagazdálkodási lehetőségek eszköz azokon a Speciális konfiguráció és energiagazdálkodás (ACPI) számítógépeken használható, amelyeket a gyártó úgy állított be, hogy támogassák ezeket a szolgáltatásokat. További információt a számítógép dokumentációjában talál.


Nem Plug and Play eszköz telepítése

  1. Nyissa meg a Vezérlőpultról a Hardver hozzáadása/eltávolítása ablakot.
  2. Kattintson a Tovább gombra, jelölje be az Eszköz hozzáadása/hibaelhárítása választógombot, majd kattintson ismét a Tovább gombra. A Windows 2000 megpróbál új Plug and Play eszközöket keresni.
  3. Ha a telepítendő eszköz nem szerepel a listán, válassza a lista Új eszköz hozzáadása elemét.
  4. Kattintson a Tovább gombra, majd hajtsa végre a következő lépések egyikét:
    • Ha azt szeretné, hogy a Windows 2000 próbálja megkeresni a telepítendő új nem Plug and Play eszközt, jelölje be az Igen, keresse meg az új hardvert választógombot.
    • Ha ismeri a telepítendő eszköz pontos típusát, és Ön szeretné azt kijelölni egy eszközlistáról, jelölje be a Nem, én szeretném kiválasztani a hardvert listából választógombot.
  5. Kattintson a Tovább gombra, majd kövesse a képernyőn megjelenő utasításokat.

Megjegyzések

  • Előfordulhat, hogy a Plug and Play eszközök hozzáadásához és beállításához rendszergazdai jogosultságokkal kell rendelkeznie. Rendszergazdai jogosultságok akkor szükségesek, ha az eszköz telepítéséhez valamilyen felhasználói felületre van szükség, vagy ha hibákat észlel a telepítés során. Közvetlenül a számítógéphez csatlakozó nem Plug and Play eszköz hozzáadásához és beállításához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha számítógépe hálózathoz van csatlakoztatva, a hálózat házirendjeinek beállításai is megakadályozhatják az eljárás végrehajtását.
  • Ha Ön nem rendszergazda, illetve nem a Rendszergazdák csoport tagja, egyes rendszergazdai feladatok végrehajtásához használhatja a Futtatás mint parancsot. A Futtatás mint parancs használatával kapcsolatos tudnivalókért kattintson a Kapcsolódó témakörök hivatkozásra.


Hardverprofilok – áttekintés

A hardverprofil olyan utasításkészlet, amely azt közli a Windows 2000 operációs rendszerrel, hogy mely eszközöket kell elindítania a számítógép elindításakor, illetve, hogy milyen beállításokkal használja az egyes eszközöket. A Windows 2000 első telepítésekor létrejön egy 1. profil (hordozható gépeknél a Rögzített állapot profil vagy a Hordozható állapot) nevű hardverprofil. Az 1. profil nevű hardverprofilban alapértelmezés szerint a Windows 2000 telepítésekor a számítógépre telepített összes eszköz engedélyezve van.

A hardverprofilok különösen hordozható számítógépek esetén hasznosak. A legtöbb hordozható számítógépet több helyen használják, és a hardverprofilok segítségével módosítható, hogy milyen eszközöket használjon a számítógép az egyik vagy a másik helyen. Létrehozhat például egy Dokkolóegység-konfiguráció nevű profilt, amelyet akkor használ, ha a számítógép olyan dokkolóegységhez kapcsolódik, amelyen CD-ROM-meghajtó, hálózati csatolókártya és más hardvereszközök is elérhetők. Emellett lehet egy másik profilja, mondjuk Önálló konfiguráció néven, amelyet akkor vehet igénybe, ha a számítógépet szállodában vagy repülőgépen használja, és nem használ hozzá hálózati csatolót vagy CD-ROM-meghajtót, de modemet és hordozható nyomtatót igen.

A hardverprofilok kezeléséhez kattintson duplán a Vezérlőpult Rendszer ikonjára, kattintson a Hardver fülre, majd a Hardverprofilok gombra. Ha egynél több hardverprofilja van, megadhatja, hogy melyik legyen az alapértelmezett. A számítógép indításakor ezután azt használja az operációs rendszer. Az is beállítható, hogy a Windows 2000 minden indításkor megkérdezze, hogy melyik profilt használja. Hardverprofil készítésekor az Eszközkezelő segítségével tudja a benne lévő eszközöket engedélyezni vagy letiltani. A hardverprofilban letiltott eszközök eszközillesztői a számítógép indításakor nem töltődnek be.


Hardvertípusok – áttekintés

A Windows 2000 hardvertípusok szerint osztályozza az eszközöket. A hardvertípusok közé sorolhatók például a videokártyák, a billentyűzetek, a CD-ROM-meghajtók, a portok, a nyomtatók stb. Az Eszközkezelő vagy a Hardver hozzáadása/eltávolítása varázsló segítségével megtekinthető, hogy milyen hardvertípusok vannak a számítógépre telepítve.

A hardvertípusok tovább csoportosíthatók egyedi eszközökre. A modem hardvertípus például több mint 200 különböző típusú, a Windows 2000 operációs rendszerre telepíthető és vele együttműködő modemet tartalmaz.

Az eszközök osztályozhatók a számítógéphez való kapcsolódási módjuk szerint is. A legtöbb eszköz állandóan a számítógéphez kapcsolódik, és általában csak egyszer kell telepíteni. Ezek a számítógép minden bekapcsolásakor rendelkezésre állnak, kivéve, ha letiltotta vagy eltávolította őket. A hangkártyák, videokártyák, modemek és merevlemezek például ilyen típusú eszközök.

Más eszközöket úgy terveztek, hogy szükség szerint azokat a számítógéphez lehessen csatlakoztatni vagy le lehessen onnan választani. Az ilyen típusú eszközöket a megfelelő portra kell csatlakoztatni vagy a megfelelő bővítőhelyre kell beilleszteni – a Windows 2000 a számítógép újraindítása nélkül felismeri és beállítja azokat. Ha az ilyen eszközöket leválasztja, csak értesítenie kell a Windows 2000 rendszert, hogy kiemeli, eltávolítja vagy lecsatlakoztatja az adott eszközt, de a számítógépet nem kell leállítani vagy újraindítani. Ilyen eszköztípusok például az alábbiak:

  • hordozható számítógépekbe illeszthető PC-kártyák
  • univerzális soros buszhoz (USB) vagy IEEE 1394 típusú buszhoz kapcsolódó hardvereszközök
  • hordozható számítógépek kikapcsolás nélküli rögzítését és szétkapcsolását lehetővé tevő dokkolóegységek, és
  • a soros és párhuzamos portokra kapcsolt hardvereszközök.

A Windows operációs rendszerek által támogatott eszközök teljes listáját a Microsoft Windows hardverkompatibilitási listán, a Microsoft webhelyén találja meg (http://www.microsoft.com/).