A DirectX diagnosztikai eszköz

A Microsoft® DirectX® diagnosztikai eszköz dokumentációjában a következő témakörök találhatók:

  • A DirectX diagnosztikai eszköz
  • Hibakeresés
  • A DirectX összetevők tesztelése
  • Az alapértelmezett működés felülbírálása
  • Az illesztőprogramok helyreállítása
  • Adatok mentése
  • Hibabejelentés


A DirectX diagnosztikai eszköz

A DirectX® diagnosztikai eszköz információt nyújt a Microsoft® DirectX alkalmazásfeljesztői felület összetevőiről és a rendszeren futó illesztőprogramokról, valamint lehetővé teszi a grafikus és hangkimenet, illetve a DirectPlay szolgáltatók tesztelését. Segítségével letiltható néhány hardvergyorsító szolgáltatás is.

Az eszköz alkalmas arra, hogy technikai tanácsadással kapcsolatos hívás esetén információt gyűjtsön a szakember számára. Az eszköz által beszerzett információt menthetjük is, majd elektronikus levélbe illeszthetjük.

Az eszköz nyújtotta adatok egymás melletti lapokon találhatók. A lapok között a következő módon mozoghatunk:

  • Kattintsunk a fülekre.
  • Kattintsunk a Következő oldal gombra.
  • Amikor a beviteli fókusz a fülön van, nyomjuk le a jobbra vagy balra mutató nyílbillentyűt.

Megjegyzés Előfordulhat, hogy néhány – például a videokártya memóriájára vonatkozó – információ csak megközelítő adat.


Hibakeresés

Ha egy DirectX alkalmazás működése közben rendellenességeket tapasztalunk, a DirectX diagnosztikai eszköz segít megtalálni a hiba okát. Íme néhány hibalehetőség:

  • Nem megfelelő verziójú DirectX összetevők. A DirectX fájlok lap Megjegyzések részében keressünk béta és hibakereső fájlokról szóló figyelmeztetést. A béta fájlok korai próbaverziók, azokat kereskedelmi alkalmazásokkal telepíteni tilos. A hibakereső verziókat a programfejlesztés folyamán használják, és szintén nem telepíthetők a kész termékkel. Ezek jelentősen lassíthatják a programokat, ami a kiskereskedelmi verziókkal nem fordul elő.
  • Nem hitelesített illesztőprogramok. A DirectX illesztőprogramok lapon lévő fájllistán keressük meg azokat az illesztőprogramokat, amelyek nincsenek hitelesítve. További problémákról olvashatunk a Képernyő, a Hang és a Bemenet lapok Megjegyzések részében. A nem hitelesített illesztőprogramokat a Microsoft nem tesztelte a DirectX legújabb verziójával való kompatibilitás szempontjából.
  • Nincs hardvergyorsítás. Néhány program csak nagyon lassan, vagy egyáltalán nem fut a DirectDraw® vagy a Direct3D® hardvergyorsítók nélkül. A Képernyő lapon, a DirectX szolgáltatások alatt nézzük meg, hogy a DirectDraw vagy a Direct3D mellett a Nincs gyorsítás” megjegyzés áll-e. Ha igen, érdemes frissítenünk a hardvert.
  • Az eszköz nincs csatlakoztatva. Ha a botkormány vagy más bemeneti eszköz nem válaszol, előfordulhat, hogy nincs megfelelően telepítve. Nézzük meg, hogy az eszköz fel van-e sorolva a DirectX diagnosztikai eszköz Bemenet lapján. Ha nincs, adjuk hozzá a Vezérlőpulton keresztül.


A DirectX összetevők tesztelése

A DirectDraw és a Direct3D a rendszerhez csatlakoztatott minden monitoron, a DirectSound® minden hangkimeneti eszközön, a DirectMusic™ pedig minden zenei porton tesztelhető.

Kattintsunk a Tesztelés gombra, olvassuk el a megjelenő üzeneteket, és figyeljük meg, vagy hallgassuk meg a tesztelés eredményét. Minden tesztet addig futtassunk, amíg meg nem jelenik egy üzenet azzal a kérdéssel, hogy sikeres volt-e a teszt. Ha a Nem gombra kattintunk, a tesztelés félbeszakad.

A DirectMusic esetében egyféle módon zajlik a tesztelés. Egyszerűen kattintsunk az OK gombra, miután tapasztaltuk, hogy a zenét a program megfelelően vagy nem megfelelően lejátszotta.

A DirectPlay működőképességét bármely elérhető szolgáltatón is tesztelhetjük.

A DirectPlay tesztelése:

  1. A Hálózat lapon kattintsunk A DirectPlay tesztelése gombra. A DirectPlay tesztelése párbeszédpanelen írjuk be a felhasználónevet, és válasszunk egy szolgáltatót. Kattintsunk az Új munkamenet létrehozása választógombra, majd az OK gombra. Ha modemes kapcsolatot választunk, a modem automatikus válasz üzemmódba történő beállításához kattintsunk a Válasz gombra a Modemes kapcsolat párbeszédpanelen.
  2. Most futtassuk a DirectX diagnosztikai eszközt egy másik számítógépen, amely az elsővel kapcsolatot tud létesíteni. Kattintsunk A DirectPlay tesztelése gombra, írjunk be egy másik felhasználónevet, válasszuk ugyanazt a szolgáltatót, mint az előbb, válasszuk a Kapcsolódás egy létező munkamenethez lehetőséget, majd kattintsunk az OK gombra. Néhány kapcsolattípus esetén előfordulhat, hogy több adatot, például telefonszámot is meg kell adnunk. Helyi hálózatú TCP/IP-kapcsolat esetén a szövegmezőt üresen hagyhatjuk.
  3. A második számítógépen egy Munkamenetlista jelenik meg, amely tartalmazza az első számítógépen létrehozott munkamenetet. Válasszuk ki e munkamenet nevét, és kattintsunk az OK gombra.
  4. Most mindkét számítógépen egy csevegés párbeszédpanelnek kell megjelennie. Az egyik számítógépen írjunk be egy üzenetet a beviteli mezőbe, majd kattintsunk a Küldés gombra. Az üzenetnek mindkét számítógépen meg kell jelennie a csevegés párbeszédpanel görgetőterületén.


Az alapértelmezett működés felülbírálása

A Hang lapon a csúszka mozgatásával változtathatjuk a hardvergyorsítási szintet. Ez a szint a DirectX diagnosztikai eszköz bezárása után is érvényben marad. (Megjegyzés: ez a szolgáltatás nem található meg a Windows® 95 rendszeren.)

A rendszerre telepített minden egyes megjelenítő eszközhöz tartozó Képernyő lapon letilthatjuk a DirectDraw vagy a Direct3D hardvergyorsítót (amennyiben ilyen gyorsítás elérhető), ha a Tiltás gombra kattintunk. A gyorsítás letiltása a DirectX diagnosztikai eszköz bezárása után is érvényben marad, és más alkalmazások számára nem lesz elérhető. Ha újra engedélyezni akarjuk a gyorsítást, kattintsunk az Engedélyezés gombra.

Megjegyzés A DirectDraw gyorsításának letiltásával a Direct3D gyorsítását is letiltjuk.

Módosíthatjuk a monitor frissítési gyakoriságát is, amelyet a DirectDraw teljes képernyős alkalmazások állítanak be. Ezt csak akkor tegyük, ha bizonyos alkalmazás esetében megjelenítési rendellenességeket tapasztalunk, és okunk van azt gondolni, hogy az alkalmazás érvénytelen frissítési gyakoriságot állít be.

A frissítési gyakoriság beállítása:

  1. A További súgó lapon kattintsunk a Felülbírálás gombra.
  2. A DirectDraw frissítési viselkedésének felülbírálása párbeszédpanelen jelöljük be a mezőt, és írjunk be egy, a monitorunkra érvényes frissítési gyakoriságot. Ilyenkor Az érték felülbírálása választógomb automatikusan bejelölődik.
  3. Kattintsunk az OK gombra.

A frissítési gyakoriság felülbírálásának visszavonása és a DirectDraw alkalmazások saját frissítési gyakoriságának engedélyezése:

  1. A További súgó lapon kattintsunk a Felülbírálás gombra.
  2. A DirectDraw frissítési viselkedésének felülbírálása párbeszédpanelen válasszuk Az alapértelmezett érték használata lehetőséget.
  3. Kattintsunk az OK gombra.


Az illesztőprogramok helyreállítása

Néhány konfiguráción a DirectX® diagnosztikai eszköz lehetővé teszi a korábbi audio- és video-illesztőprogramok helyreállítását. Ez a nem kompatíbilis illesztőprogramokkal kapcsolatos problémák legegyszerűbb megoldása.

Ha a Helyreállítás gomb megjelenik a További súgó lapon, kattintsunk rá a DirectX telepítőprogram indításához.

A DirectX Telepítőnek két gombja van, melyek felirata: Audio-illesztőprogramok helyreállítása és Képernyő-illesztőprogramok helyreállítása. Ha valamelyik gombra kattintunk, helyreállíthatjuk a DirectX telepítésekor kicserélt illesztőprogramokat. Ha valamelyik gomb nem érhető el, akkor nincs korábbi illesztőprogram, amelyet helyreállíthatnánk. Ebben az esetben érdemes a hardvergyártótól beszerezni a legújabb illesztőprogramot.

A DirectX Telepítőben egy jelölőnégyzet segítségével szintén letilthatjuk a D3D hardvergyorsítást, ami már a DxDiag párbeszédpanelén is elvégezhető. (Lásd Az alapértelmezett működés felülbírálása.)


Adatok mentése

A DirectX diagnosztikai eszköz által gyűjtött adatok kétféleképpen menthetők:

  • Kattintsunk a Minden adat mentése gombra. Ezzel minden lap adatait egy fájlba mentjük, amelynek nevét és helyét mi választhatjuk meg.

A diagnosztikai eszköz fejlesztői verziójával rendelkező szoftverfejlesztőként pedig a következőt tehetjük:

  • A További súgó lapon kattintsunk a Report (Bejelentés) gombra. Megjelenik a Bug Report Information (Hibabejelentő adatok) párbeszédpanel. Miután beírtuk az összes szükséges adatot, kattintsunk a Send (Küldés) gombra. Ezzel egy Dxdiag.txt nevű szövegfájlt hoztunk létre az ideiglenes könyvtárban (például a C:\Windows\Temp könyvtárban), amely egy Jegyzettömb ablakban meg is jelenik. Ez a fájl tartalmazza az adatokat, amit az előző módszer segítségével mentettünk, továbbá azokat a személyes és más adatokat is, amelyeket beírtunk.


Hibabejelentés

Ha olyan problémát észlelünk, amely a DirectX egyik összetevőjével vagy illesztőprogramjával lehet összefüggésben, forduljunk a Microsoft Ügyfélszolgálathoz (lásd a Microsoft® Windows® Súgót a Hibaelhárítás címszó alatt). A diagnosztikai eszköz fejlesztői verziójával rendelkező szoftverfejlesztők a problémát elektronikus levélben is bejelenthetik.

Megjegyzés 2 Az alábbi útmutatások csak az eszköz fejlesztői verziójára érvényesek. Ez a lehetőség nem érhető el minden felhasználó számára.

Hibabejelentés elektronikus levélben:

  1. Kattintsunk a Report (Bejelentés) gombra a További súgó lapon.
  2. Töltsünk ki minden vonatkozó részt a Bug Report Information (Hibabejelentő adatok) párbeszédpanelen, majd kattintsunk a Send (Küldés) gombra.
  3. Egy üzenet jelenik meg, amely megadja a létrehozott szövegfájl teljes elérési útvonalát és az elektronikus levélcímet. Jegyezzük fel a címet. Kattintsunk az OK gombra. Egy Jegyzettömb ablakban megjelenik a Dxdiag.txt fájl tartalma.
  4. A Jegyzettömb Szerkesztés menüjében kattintsunk a Mindet kijelöli parancsra, majd a fájl teljes tartalmának a Vágólapra történő másolásához válasszuk a Másolás parancsot.
  5. Hozzunk létre új üzenetet az elektronikus levelezőprogramban, majd illesszük be az üzenetbe a Vágólap tartalmát. Küldjük el az üzenetet arra a címre, amelyet a 3. lépésben feljegyeztünk.


Nincs ilyen témakör.

Nincs egyező témakör. Lehetséges okok és megoldások:

  • A keresett témakört tartalmazó fájl (.chm) nincs a várt a helyen.

    Megoldás: Futassuk újra az MSDN Library telepítőjét.

  • A keresett témakört tartalmazó fájl (.chm) elavult, a hivatkozás már nem érvényes.

    Megoldás: Telepítsük az MSDN Library legújabb verzióját.

  • Az MSDN Library CD nincs a CD-ROM-meghajtóba.

    Megoldás: Helyezzük a MSDN Library CD-t a CD-ROM-meghajtóba.

Készült: 1999. július 08, csütörtök.