Dr. Watson – áttekintés

A DR. Watson – áttekintés

A Dr. Watson for Windows 2000 egy programhiba-kereső alkalmazás.

A Dr. Watson alkalmazással begyűjtött és naplózott adatok a technikai támogatás számára a Windows 2000 operációs rendszert futtató számítógépeken keletkező programhibák meghatározásához szükségesek. Hiba esetén az alkalmazás létrehoz egy szövegfájlt (Drwtsn32.log), amely tetszőleges módon továbbítható a támogató szakembernek. Létrehozható egy az összeomlási memóriaképet tároló bináris fájl is, amit a programozók betölthetnek egy hibakeresőbe.

Programhiba esetén a Dr. Watson alkalmazás automatikus elindul. A Dr. Watson alkalmazás elindításához kattintson a Start menüre, a Futtatás parancsra, majd írja be a drwtsn32 parancsot. A Dr. Watson alkalmazás parancssorból való elindításához váltson a gyökérkönyvtárra, majd írja be a drwtsn32 parancsot.

Kapcsolódó témakörök


A Dr. Watson alkalmazás beállítása

A Dr. Watson alkalmazást (Drwtsn32.exe) a telepítő a Windows 2000 telepítésekor a rendszermappába telepíti. Az alapértelmezett beállításokat a Dr. Watson első futtatásakor (programhiba esetén, vagy ha közvetlenül elindítja a Dr. Watson alkalmazást) adja meg a rendszer.

Ha programhiba keletkezik a Windows 2000 rendszerben, a rendszer programhiba-kezelőt keres. A programhiba-kezelő a program futása közben keletkező hibákat kezeli. Ha a rendszer nem talál programhiba-kezelőt, akkor ellenőrzi, hogy a programon jelenleg nem fut-e hibakeresés, és a hibát ismeretlennek tekinti. A rendszer ezután a Rendszerleíróadatbázis-szerkesztőben programhiba-kereső megkeresésével feldolgozza az ismeretlen hibákat.

A rendszer a Rendszerleíróadatbázis-szerkesztőben a \\HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug kulcsban Hibakereső és Auto nevű bejegyzéseket keres. A Hibakereső bejegyzés értéke határozza meg a hibakereső számára a programhiba elemzésére használandó parancsot. Ha a Hibakereső bejegyzés tartalmaz értéket, akkor a rendszer ellenőrzi, hogy az Auto bejegyzés értéke nulla vagy egy.

  • Ha az Auto bejegyzés értéke nulla, akkor a rendszer egy hibaüzenet megjelenítésével jelzi, hogy programhiba történt. Ha a Hibakereső bejegyzés értéke egy érvényes hibakeresőt ad meg, akkor a hibaüzeneten két gomb jelenik meg: OK és Mégse. Az OK gombra kattintással a program megszakítható. A Mégse gombra kattintással elindítható a megadott hibakereső. Ha a Hibakereső bejegyzés üres, akkor a hibaüzeneten csak az OK gomb jelenik meg, és nem indítható hibakereső.
  • Ha az Auto bejegyzés értéke egy és a Hibakereső bejegyzés értéke egy érvényes hibakeresőt indító parancsot ad meg, akkor a rendszer automatikusan elindítja a hibakeresőt és nem jeleníti meg a hibaüzenetet.

A Windows 2000 telepítésekor a rendszer az Auto bejegyzés alapértelmezett értékét egyre, a Hibakereső bejegyzést pedig a Dr. Watson alkalmazást elindító parancsra állítja be. Így programhiba esetén a Dr. Watson for Windows 2000 alkalmazás automatikusan meghatározza a hibát és naplózza a szükséges diagnosztikai adatokat.

Ha nem a Dr. Watson az alapértelmezett hibakereső és a Dr. Watson alkalmazást akarja használni, akkor váltson a parancssorra és a Dr. Watson elindításához írja be a drwtsn32 -i parancsot. A -i kapcsoló hatására a rendszer elvégzi a rendszerleíró-adatbázis szükséges módosításait.

A megfelelő szimbólumok telepítése és a szimbólumkeresési útvonal beállítása esetén a Dr. Watson beállítható úgy, hogy pontosabb adatokat generáljon a hibakereséshez. Ehhez először másolja a szimbólumokat a Windows 2000 CD-ROM-ról a számítógép egy új mappájába. Ezután létre kell hozni egy új környezeti rendszerváltozót. Előbb a számítógépen lépjen a rendszergyökér mappába, és hozzon létre egy Symbols nevű új mappát. Ezt követően a CD-n keresse meg a \\Support\Debug\i386 mappát, és másolja a szimbólumokat a számítógépen az előbb létrehozott Symbols nevű mappába. A szimbólumok átmásolása után létre kell hozni egy új környezeti rendszerváltozót. Az új környezeti rendszerváltozó létrehozása után az _NT_SYMBOL_PATH nevet és a %rendszergyökér%\Symbol értéket kell beállítani. Különböző helyekre pontosvesszővel elválasztva több szimbólum is telepíthető, és az egyes helyekre ugyanaz a környezeti változó mutathat. A hozzáadott szervizcsomagok esetén is szerepeltesse a változókat. Például: _NT_SYMBOL_PATH=%rendszergyökér%\symbol;%rendszergyökér%\hotfixes;%rendszergyökér%\symbolsNt4Sp3. A környezeti változó létrehozásával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A DR. Watson alkalmazás beállításai

A Dr. Watson for Windows 2000 párbeszédpanelen módosítható a Dr. Watson alkalmazás viselkedése. A megadott adatokat a rendszer a rendszerleíró adatbázis \\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson kulcsában tárolja.

A párbeszédpanelen megadható beállításokkal kapcsolatos tudnivalókért kattintson az alábbi lista megfelelő elemére:

  • Naplófájl elérési útvonala
  • Összeomlási memóriakép
  • Hangfájl
  • Utasítások száma
  • Menteni kívánt hibák száma
  • Szimbólumtábla kiírása
  • Az összes szálkontextus kiírása
  • Hozzáfűzés létező naplófájlhoz
  • Vizuális értesítés
  • Értesítés hangjelzéssel
  • Összeomlási memóriakép létrehozása
  • Megjelenítés
  • Törlés
  • Alkalmazáshibák

Kapcsolódó témakörök


A Dr. Watson naplófájl – áttekintés

Alkalmazáskivétel (vagy programhiba) esetén a Dr. Watson alkalmazás naplófájlt készít (Drwtsn32.log). A naplófájl mindig a következő sorral kezdődik:

Alkalmazáskivétel történt:

A naplófájl ezt követő része mindig a programhibával kapcsolatos adatokat tartalmazza. A megadott hibaszám mindig a rendszer által generált hibára vonatkozik.

A naplófájl következő részében a felhasználóval és azzal a számítógéppel kapcsolatos rendszeradatok találhatók, amelyen a programhiba történt.

A naplófájl következő része a programhiba időpontjában a rendszeren futó feladatok listáját tartalmazza.

A naplófájl következő része a program által betöltött modulokat tartalmazza.

A naplófájl következő része a listán szereplő azonosítójú szálhoz tartozó állapot memóriaképét tartalmazza. A memóriakép tartalmazza a regiszterek állapotát, az aktuális programszámlálót környező kód visszafejtését, az egymásba ágyazott függyvényhívásokat (fordított sorrendben) és a veremtár tartalmát. A memóriaképnek ez az első része tartalmazza a szálazonosítókat.

A 0xbf azonosítójú szál lefagyási listájának állapota

Az állapot-memóriakép következő része a regiszterek állapotát tartalmazza.

Az állapot-memóriakép következő része az utasítások visszafejtését tartalmazza.

Az állapot-memóriakép következő része az egymásba ágyazott függvényhívásokat tartalmazza (fordított sorrendben).

Egymásba ágyazott függvényhívások (fordított sorrendben)

Az állapot-memóriakép utolsó része a veremtár tartalmát tartalmazza.

Az állapot-memórikép után a naplófájl utolsó része a szimbólumtáblát tartalmazza.