Logikai meghajtók – áttekintés

A Logikai meghajtók olyan Windows Management Instrumentation (WMI) eszköz, amely lehetővé teszi a csatlakoztatott és helyi meghajtók kezelését távoli számítógépen vagy helyi számítógépen. A Logikai meghajtók eszköz segítségével a következő műveletek hajthatók végre:

Meghajtó tulajdonságainak megjelenítése

A meghajtó tulajdonsága például a meghajtótípus, a meghajtóhoz rendelt betűjel, a meghajtó formázásához használt fájlrendszer típusa, a szabad lemezterület a meghajtón és a biztonsági beállítások.

Meghajtócímkék beállítása

Minden meghajtóhoz egyéni, legfeljebb 11 karakterből álló címke rendelhető. A meghajtócímke a meghajtóbetűjellel együtt jelenik meg, és segít a meghajtó azonosításában.

Biztonsági beállítások módosítása

A helyi és a csatlakoztatott meghajtó biztonsági beállításai is módosíthatók. A biztonsági beállítás lehet: hozzáférési engedély, naplóbejegyzés és tulajdonjog.

A meghajtó tulajdonságait csak a számítógép rendszergazdája módosíthatja. A biztonsági beállítások továbbá csak az NTFS fájlrendszerrel formázott meghajtókon módosíthatók.

Kapcsolódó témakörök


Meghajtó tulajdonságainak megjelenítése

  2. A konzolfán kattintson a Logikai meghajtók elemre.

    Helye:

    • Számítógép-kezelés (helyi)
    • Tárolás
    • Logikai meghajtók
  3. A jobb oldali egérgombbal kattintson arra a meghajtóra, amelynek meg kívánja jeleníteni az engedélyeit, majd kattintson a Tulajdonságok parancsra.

Megjegyzések

  • A meghajtó tulajdonságait csak a rendszergazdák vagy a Rendszergazdák csoport tagjai módosíthatják.
  • Az Általános lapon jelenik meg a meghajtó címkéje, típusa, a használt fájlrendszer, összkapacitása, a foglalt terület nagysága és a szabad (felhasználható) terület nagysága. A Biztonság lapon láthatók a meghajtóra beállított hozzáférési engedélyek, naplózási bejegyzések és tulajdonosi engedély.
  • A Biztonság lap csak NTFS fájlrendszer használatára megformázott meghajtók esetén jelenik meg.
  • Távoli számítógép vagy helyi számítógép meghajtójának tulajdonságai egyaránt megjeleníthetők. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a Számítógép-kezelés (helyi) elemre, kattintson a Csatlakozás másik számítógéphez parancsra, majd a listából válassza ki a számítógépet, melyhez csatlakozni kíván.


Meghajtócímke módosítása

  2. A konzolfán kattintson a Logikai meghajtók elemre.

    Helye:

    • Számítógép-kezelés (helyi)
    • Tárolás
    • Logikai meghajtók
  3. A jobb oldali egérgombbal kattintson a módosítani kívánt meghajtóra, majd a Tulajdonságok parancsra.
  4. A Címke mezőbe írja be a lemez címkéjét.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • FAT meghajtón a meghajtócímke maximum 11 karakterből állhat. NTFS meghajtón a meghajtócímke maximum 32 karakterből állhat.
  • A meghajtócímke módosítható távoli számítógépen és helyi számítógépen egyaránt. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a Számítógép-kezelés (helyi) elemre, majd kattintson a Csatlakozás másik számítógéphez parancsra, majd a listából válassza ki a számítógépet, melyhez csatlakozni kíván.


Az engedélyek és a naplózás beállítása

Az engedélyek és a naplózás a Biztonság lapon állíthatók be, amely a Logikai meghajtók listájában felsorolt bármelyik meghajtó tulajdonságainak megtekintésével előhívható.

A Biztonság lapon állítható be, mely engedélyeket engedélyezi és tiltja le a csoportok és a felhasználók számára. Például beállítható, hogy az egyik felhasználó olvashatja a meghajtó tartalmát, a másik felhasználó módosíthatja azt, míg az összes többi felhasználó nem érheti el a meghajtón található fájlokat és mappákat.

A naplózás beállításával figyelhetők és rögzíthetők a biztonsággal kapcsolatos események, például amikor a felhasználó egy bizalmas fájlt vagy mappát próbál meg elérni. Meghajtó naplózásakor a rendszer minden alkalommal eltárol egy bejegyzést a Windows 2000 biztonsági naplójába, amikor valaki a meghajtóhoz egy bizonyos módon hozzáfér. A Biztonság lapon megadható, mely objektumokat naplózza a rendszer, kinek a műveleteit és pontosan milyen típusú műveleteket naplózzon a rendszer.

A biztonsági beállításokat csak a számítógép rendszergazdája módosíthatja. A biztonsági beállítások továbbá csak az NTFS fájlrendszerrel formázott meghajtókon módosíthatók.


Meghajtó hozzáférési engedélyeinek beállítása

  2. A konzolfán kattintson a Logikai meghajtók elemre.

    Helye:

    • Számítógép-kezelés (helyi)
    • Tárolás
    • Logikai meghajtók
  3. A jobb oldali egérgombbal kattintson arra a meghajtóra, amelynek be kívánja állítani a hozzáférési engedélyeit, kattintson a Tulajdonságok parancsra, majd a Biztonság fülre.
  4. Hajtsa végre az alábbi művelek egyikét:
    • Új felhasználó vagy csoport hozzáférési engedélyeinek beállításához kattintson a Hozzáadás gombra. A Keresés itt listában válassza ki azt a tartományt, amelynek a felhasználó vagy csoport tagja. A Név beviteli mezőbe írja be annak a felhasználónak vagy csoportnak a nevét, amelynek az engedélyeit be kívánja állítani, kattintson a Hozzáadás, majd az OK gombra a párbeszédpanel lezárásához.
    • Az engedélyek listájáról felhasználó vagy csoport eltávolításához kattintson a csoport vagy felhasználó nevére, az Eltávolítás, majd az OK gombra. Hagyja ki az 5. lépést.
  5. Az Engedélyek listában az Engedélyezés vagy a Megtagadás jelölőnégyzet bejelölésével állítsa be az engedélyezni vagy letiltani kívánt engedélyeket.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • Csak NTFS fájlrendszer használatára megformázott meghajtókon módosíthatók a hozzáférési engedélyek.
  • A meghajtóhoz Teljes hozzáféréssel rendelkező felhasználók és csoportok az adott meghajtó bármelyik fájlját vagy mappáját törölhetik, függetlenül a meghajtó fájljait és mappáit védő hozzáférési engedélyektől.
  • A Logikai meghajtók mappában csak az adott meghajtó gyökérkönyvtárának engedélyei állíthatók be. Mivel azonban beállítható az engedélyek öröklődése, így a gyökérkönyvtár alatti mappák és fájlok örökölhetik a beállított engedélyeket.
  • A hozzáférési engedélyek beállíthatók távoli számítógépen vagy helyi számítógépen egyaránt. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a Számítógép-kezelés (helyi) elemre, kattintson a Csatlakozás másik számítógéphez parancsra, majd a listából válassza ki azt a számítógépet, amelyhez csatlakozni kíván.


Meghajtóengedélyek

A következő meghajtóengedélyek használhatók: Teljes hozzáférés, Módosítás, Olvasás és végrehajtás, Mappa tartalmának listázása, Olvasás, valamint Írás. Ezek az engedélyek speciális engedélyek logikai csoportját jelentik. Az alábbi táblázatban megtalálható az összes meghajtóengedély, valamint az, hogy az egyes engedélyekhez milyen speciális engedélyek tartoznak.

Speciális engedélyek | Teljes hozzáférés | Módosítás | Olvasás és végrehajtás | Mappa tartalmának listázása | Olvasás | Írás
Mappa átjárása/Fájl végrehajtása | x | x | x | x |  |
Mappa listázása/Adatok olvasása | x | x | x | x | x |
Attribútumok olvasása | x | x | x | x | x |
Kiterjesztett attribútumok olvasása | x | x | x | x | x |
Fájlok létrehozása/Adatok írása | x | x |  |  |  | x
Mappák létrehozása/Adatok hozzáfűzése | x | x |  |  |  | x
Attribútumok írása | x | x |  |  |  | x
Kiterjesztett attribútumok írása | x | x |  |  |  | x
Almappák és fájlok törlése | x |  |  |  |  |
Törlés | x | x |  |  |  |
Olvasási engedélyek | x | x | x | x | x | x
Engedélyek módosítása | x |  |  |  |  |
Saját tulajdonba vétel | x |  |  |  |  |
Szinkronizálás | x | x | x | x | x | x

Megjegyzések

  • Bár első látásra a Mappa tartalmának listázása és az Olvasás és végrehajtás engedély ugyanazokat a speciális engedélyeket tartalmazza, ezeknek az engedélyeknek az öröklése különbözőképpen történik. A Mappa tartalmának listázása engedély csak mappák eseten öröklődik, fájlok esetén nem. Az Olvasás és végrehajtás fájlok és mappák esetében egyaránt öröklődik.
  • Az engedélyek beállításával és az egyes speciális engedélyekkel kapcsolatos tudnivalókért lásd a Kapcsolódó témaköröket.


Meghajtó naplózásának beállítása

  2. A konzolfán kattintson a Logikai meghajtók elemre.

    Helye:

    • Számítógép-kezelés (helyi)
    • Tárolás
    • Logikai meghajtók
  3. A jobb oldali egérgombbal kattintson a naplózni kívánt meghajtóra, kattintson a Tulajdonságok parancsra, majd a Biztonság fülre.
  4. Kattintson a Speciális gombra, majd a Naplózás fülre.
  5. Hajtsa végre az alábbi művelek egyikét:
    • Új felhasználó vagy csoport naplóbejegyzéseinek beállításához kattintson a Hozzáadás gombra. A Keresés itt listában válassza ki azt a tartományt, amelyiknek a felhasználó vagy csoport tagja. A Név beviteli mezőbe írja be annak a felhasználónak vagy csoportnak a nevét, amelyhez bejegyzéseket kíván beállítani, majd kattintson az OK gombra. Megnyílik a Naplóbejegyzés párbeszédpanel.
    • Meglevő felhasználó vagy csoport naplóbejegyzéseinek módosításához kattintson a csoport vagy a felhasználó nevére, majd a Megjelenítés/szerkesztés gombra.
    • Meglévő csoport vagy felhasználó naplóbejegyzéseinek megszüntetéséhez kattintson az Eltávolítás gombra. Hagyja ki a 6–8. lépéseket.
  6. Szükség esetén a Naplóbejegyzés párbeszédpanel Alkalmazás listájában válassza ki a naplózás alkalmazási körét.
  7. A naplózni kívánt hozzáférések kiválasztásához a Hozzáférés listában kattintson a Sikeres, a Sikertelen vagy mindkét jelölőnégyzetre.
  8. Ha a fában lévő fájlokra és mappákra nem akarja továbbörökíteni ezeket a naplóbejegyzéseket, akkor válassza ki A naplózási beállítások alkalmazása a fán lejjebb található objektumokra és/vagy tárolókra jelölőnégyzetet.

Fontos

  • A Windows 2000 rendszerben a fájlok és mappák elérésének naplózásához előbb a Csoportházirend beépülő modulban engedélyezni kell a Naplórend Objektum-hozzáférés naplózása beállítását. Ha ezt nem engedélyezi, akkor a fájlok és mappák naplózásának beállításakor hibaüzenet jelenik meg, és a rendszer nem naplózza sem a fájlokat, sem a mappákat. A Csoportházirend beépülő modulban a naplózás engedélyezése után a naplózott fájlokhoz és mappákhoz való sikeres vagy sikertelen hozzáférési próbálkozások az Eseménynapló segédprogramban a biztonsági napló megjelenítésével ellenőrizhetők.

Megjegyzések

  • A naplózási bejegyzéseket csak az adott számítógép rendszergazdája, vagy a csoportházirendben Naplózási és biztonsági napló kezelése engedéllyel rendelkező felhasználók módosíthatják.
  • Csak NTFS fájlrendszer használatára megformázott meghajtókon módosíthatók a naplózási bejegyzések.
  • A naplózás bekapcsolása után az Eseménynapló segédprogramban a biztonsági napló megjelenítésével ellenőrizhetők a naplózott adatok.
  • A naplózási bejegyzések módosíthatók távoli számítógépen vagy helyi számítógépen egyaránt. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a Számítógép-kezelés (helyi) elemre, majd kattintson a Csatlakozás másik számítógéphez parancsra, majd a listából válassza ki a számítógépet, melyhez csatlakozni kíván.


Meghajtó tulajdonosi jogainak beállítása

  2. A konzolfán kattintson a Logikai meghajtók elemre.

    Helye:

    • Számítógép-kezelés (helyi)
    • Tárolás
    • Logikai meghajtók
  3. A jobb oldali egérgombbal kattintson arra a meghajtóra, amelynek tulajdonosi jogait be kívánja állítani, kattintson a Tulajdonságok parancsra, majd a Biztonság fülre.
  4. Kattintson a Speciális gombra, majd a Tulajdonos fülre.
  5. Kattintson az új tulajdonosra, majd az OK gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkezni. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet elvégzését.
  • Csak NTFS fájlrendszer használatára megformázott meghajtókon módosítható a tulajdonosi jog.
  • A tulajdonosi jog beállítható távoli számítógépen vagy helyi számítógépen egyaránt. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a Számítógép-kezelés (helyi) elemre, kattintson a Csatlakozás másik számítógéphez parancsra, majd a listából válassza ki a számítógépet, melyhez csatlakozni kíván.
  • A tulajdonosi jog Logikai meghajtók mappában végrehajtott módosításai csak a meghajtóra vonatkoznak, a meghajtón levő mappákra és fájlokra nem.


Speciális meghajtóengedélyek beállítása

  2. A konzolfán kattintson a Logikai meghajtók elemre.

    Helye:

    • Számítógép-kezelés (helyi)
    • Tárolás
    • Logikai meghajtók
  3. A jobb oldali egérgombbal kattintson arra a meghajtóra, amely spaciális engedélyeit be akarja állítani, kattintson a Tulajdonságok parancsra, majd a Biztonság fülre.
  4. Kattintson a Speciális gombra, majd hajtsa végre az alábbi műveletek egyikét:
    • Új felhasználó vagy csoport speciális engedélyeinek beállításához kattintson a Hozzáadás gombra. A Keresés itt listában válassza ki azt a tartományt, amelyiknek a felhasználó vagy csoport tagja. A Név beviteli mezőbe írja be annak a felhasználónak vagy csoportnak a nevét, akinek az engedélyeit be kívánja állítani, majd kattintson az OK gombra, amelynek hatására megnyílik az Engedélybejegyzés párbeszédpanel.
    • Meglevő felhasználó vagy csoport speciális engedélyeinek módosításához kattintson a csoport vagy a felhasználó nevére, majd a Megjelenítés/szerkesztés gombra.
    • Felhasználó vagy csoport és a hozzá tartozó speciális engedélyek eltávolításához kattintson a csoport vagy felhasználó nevére, majd az Eltávolítás gombra. Hagyja ki az 5–7. lépéseket.
  5. Szükség esetén az Engedélybejegyzés párbeszédpanelen az Alkalmazás listában válassza ki, hol akarja alkalmazni az engedélyeket.
  6. Az Engedélyek listában minden egyes engedély esetén jelölje be az Engedélyezés vagy Megtagadás jelölőnégyzetet.
  7. Ha a fában lévő fájlokra és almappákra nem akarja továbbörökíteni ezeket az engedélyeket, akkor válassza ki Az engedélyek alkalmazása a fán lejjebb található objektumokra és/vagy tárolókra jelölőnégyzetet.

Megjegyzések

  • A speciális engedélyeket csak a számítógép rendszergazdája módosíthatja. A biztonsági beállítások továbbá csak az NTFS fájlrendszerrel formázott meghajtókon módosíthatók.
  • A speciális engedélyek beállíthatók távoli számítógépen vagy helyi számítógépen egyaránt. Távoli számítógép eléréséhez kattintson a jobb oldali egérgombbal a Számítógép-kezelés (helyi) elemre, majd kattintson a Csatlakozás másik számítógéphez parancsra, majd a listából válassza ki a számítógépet, melyhez csatlakozni kíván.
  • A meghajtóhoz Teljes hozzáféréssel rendelkező felhasználók és csoportok az adott meghajtó bármelyik fájlját vagy mappáját törölhetik, függetlenül a meghajtó fájljait és mappáit védő hozzáférési engedélyektől.
  • A Logikai meghajtók mappában csak az adott meghajtó gyökérkönyvtárának engedélyei állíthatók be. Mivel azonban beállítható az engedélyek öröklődése, így a gyökérkönyvtár alatti mappák és fájlok örökölhetik a beállított engedélyeket. Az öröklődés letiltásához jelölje be Az engedélyek alkalmazása a fán lejjebb található objektumokra és/vagy tárolókra jelölőnégyzetet. Ennek hatására az engedélyek a meghajtó gyökérkönyvtárában található fájlok és mappák esetében érvényben lesznek, de nem terjednek ki a gyökérkönyvtár alatt található fájlokra és mappákra.


Speciális engedélyek – áttekintés

A meghajtókra az alábbi speciális engedélyek bármelyike vagy mindegyike beállítható:

Mappa átjárása/Fájl végrehajtása

Ha a felhasználó jogosult bizonyos fájlok vagy mappák elérésére, akkor a Mappa átjárása engedély lehetővé teszi a felhasználó számára, hogy olyan mappán keresztül is elérhesse ezeket a fájlokat vagy mappákat, amelyhez nincs engedélye (csak mappákra vonatkozik). A Mappa átjárása engedélyt csak akkor veszi figyelembe a rendszer, ha a csoport vagy felhasználó számára a csoportházirend nem biztosítja az Átjárás ellenőrzésének mellőzése felhasználói engedélyt. (Alaphelyzetben a Mindenki csoport Átjárás ellenőrzésének mellőzése engedéllyel rendelkezik.)

Ha egy mappához beállítja a Mappa átjárása engedélyt, a rendszer nem állítja be automatikusan a Fájl végrehajtása engedélyt a mappában levő összes fájlra.

A Fájl végrehajtása engedély lehetővé teszi vagy letiltja a programfájlok futtatását (csak fájlokra vonatkozik).

Mappa listázása/Adatok olvasása

A Mappa listázása engedély lehetővé teszi vagy letiltja a mappában levő fájlok vagy almappák nevének megjelenítését (csak mappákra vonatkozik).

Az Adatok olvasása engedély lehetővé teszi vagy letiltja a fájlban levő adatok megjelenítését (csak fájlokra vonatkozik).

Attribútumok olvasása

Lehetővé teszi vagy letiltja – például írásvédett vagy rejtett – fájlok vagy mappák attribútumainak a megjelenítését. Az attribútumokat az NTFS fájlrendszer biztosítja.

Kiterjesztett attribútumok olvasása

Lehetővé teszi vagy letiltja egy fájl vagy mappa kiterjesztett attribútumainak megjelenítését. A kiterjesztett attribútumokat a programok definiálják, és azok programonként különbözhetnek.

Fájlok létrehozása/Adatok írása

A Fájlok létrehozása engedély lehetővé teszi vagy letiltja fájlok létrehozását mappán belül (csak mappákra vonatkozik).

Az Adatok írása engedély lehetővé teszi vagy letiltja a fájl módosítását és meglévő tartalmának felülírását (csak fájlokra vonatkozik).

Mappák létrehozása/Adatok hozzáfűzése

A Mappák létrehozása engedély lehetővé teszi vagy letiltja a mappák létrehozását a mappán belül (csak mappákra vonatkozik).

Az Adat hozzáfűzése jogosultság lehetővé teszi vagy letiltja a fájl végének módosítását, de nincs hatással a fájlban levő adatok módosítására, törlésére vagy felülírására (csak fájlokra vonatkozik).

Attribútumok írása

Lehetővé teszi vagy letiltja – például írásvédett vagy rejtett – fájlok vagy mappák attribútumainak a módosítását. Az attribútumokat az NTFS fájlrendszer biztosítja.

Kiterjesztett attribútumok írása

Lehetővé teszi vagy letiltja egy fájl vagy mappa kiterjesztett attribútumainak a módosítását. A kiterjesztett attribútumokat a programok definiálják, és azok programonként különbözhetnek.

Almappák és fájlok törlése

Lehetővé teszi vagy letiltja az almappák és a fájlok törlését, még ha a Törlés engedély nincs is biztosítva egy adott almappára vagy fájlra.

Törlés

Lehetővé teszi vagy letiltja a fájl vagy a mappa törlését. Ha nem rendelkezik Törlés engedéllyel egy fájlhoz vagy mappához, akkor is törölheti a fájlt vagy a mappát, ha a szülőmappán Almappák és fájlok törlése engedéllyel rendelkezik.

Engedélyek olvasása

Lehetővé teszi vagy letiltja a fájlok vagy mappák engedélyeinek (például a Teljes hozzáférés, Olvasás és Írás engedélyek) olvasását.

Engedélyek módosítása

Lehetővé teszi vagy letiltja a fájlok vagy mappák engedélyeinek (például a Teljes hozzáférés, Olvasás és Írás engedélyek) módosítását.

Saját tulajdonba vétel

Lehetővé teszi vagy letiltja a fájl vagy a mappa tulajdonosi engedélyének átvételét. A fájl vagy mappa tulajdonosa a fájlt vagy mappát védő meglevő engedélyektől függetlenül mindig módosíthatja annak engedélyeit.

Szinkronizálás

Lehetővé teszi vagy letiltja, hogy különböző szálak várakozzanak a fájl vagy mappa leírójára, és szinkronizáljanak más szállal, amely ezt jelzi. Ez az engedély csak többszálú és több processzor használatára képes programokra vonatkozik.