Lemeztöredezettség-mentesítő – áttekintés

A Lemeztöredezettség-mentesítő a helyi köteteken megkeresi a töredezett fájlokat és mappákat. A töredezett fájl vagy mappa sok részből áll, és a köteten elszórva helyezkedik el.

Ha a kötet sok töredezett fájlt és mappát tartalmaz, a Windows rendszer hosszabb idő alatt képes ezeket elérni, mivel a sok töredezett összetevő beolvasása számos plusz lemezolvasási műveletet igényel. Új fájl vagy mappa létrehozása szintén tovább tart, mivel a lemezen található szabad terület szintén töredezett. Így a Windows rendszernek az új fájlt vagy mappát több helyre kell mentenie a köteten.

A Lemeztöredezettség-mentesítő minden egyes fájl vagy mappa darabjait a kötet egyetlen helyére gyűjti össze, így az egyetlen, összefüggő területet foglal a lemezmeghajtón. Ennek eredményeként a rendszer hatékonyabban éri el a meglevő fájlokat és mappákat, és hatékonyabban menti az újakat. A fájlok és mappák összevonása révén a Lemeztöredezettség-mentesítő a szabad terület töredezettségét is megszünteti, így kisebb a valószínűsége annak, hogy az új fájlok töredezetté válnak.

A töredezett fájlok és mappák megkeresésének és összevonásának folyamatát nevezik lemeztöredezettség-mentesítésnek. A lemeztöredezettség-mentesítéshez szükséges idő több tényezőtől függ, például a kötet méretétől, a köteten levő fájlok számától, a töredezettség mértékétől és a rendszer rendelkezésre álló erőforrásaitól. A töredezettség-mentesítés előtt előbb a kötet elemzésével kereshető meg az összes töredezett fájl és mappa. Megtekinthető a köteten levő töredezett fájlok és mappák száma, és eldönthető, biztosít-e előnyöket a kötet töredezettség-mentesítése.

A Lemeztöredezettség-menetsítő segédprogrammal FAT, FAT32 és NTFS fájlrendszerrel megformázott kötetek töredezettsége szüntethető meg.

Kapcsolódó témakörök


Lemez-töredezettségmentesítő ablak

A Lemez-töredezettségmentesítő két fő területre oszlik. A felső rész felsorolja azokat a köteteket, amelyek a helyi számítógépen találhatók. Az alsó rész grafikusan ábrázolja, mennyire töredezett a kötet. A megjelenített színek jelzik a kötet állapotát.

  • A vörös területek töredezett fájlokat jeleznek.
  • A kék területek folytonos (nem töredezett) fájlokat jeleznek.
  • A fehér területek a szabad területet jelzik a köteten.
  • A zöld területek rendszerfájlokat jeleznek, amelyeket a Lemez-töredezettségmentesítő nem helyezhet át. Ezek a rendszerfájlok nem a Windows operációs rendszer részei, hanem az NTFS fájlrendszerhez tartoznak. A zöld területek csak az NTFS formátumú köteteken jelennek meg.

Az Elemzés megjelenítése sávot a Töredezettségmentesítés megjelenítése sávval összehasonlítva látható a kötet állapotának javulása a töredezettségmentesítés után.


Kötet elemzése

  1. Nyissa meg a Lemez-töredezettségmentesítő segédprogramot.
  2. Kattintson arra a kötetre, amelyen meg kívánja keresni a töredezett fájlokat és mappákat, majd kattintson az Elemzés gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Lemez-töredezettségmentesítő elindításához kattintson a Start gombra, mutasson a Programok, majd a Kellékek, majd a Rendszereszközök pontra, végül kattintson a Lemez-töredezettségmentesítő parancsra.
  • Az elemzés befejeződése után a megjelenő párbeszédpanel tájékoztatja arról, hogy szükséges-e a kötet töredezettségmentesítése.
  • Ha meg akarja szakítani, vagy ideiglenesen szüneteltetni kívánja az elemzést, kattintson a Leállítás illetve a Szüneteltetés gombra.
  • Az elemzett fájlokról és mappákról a Jelentés megtekintése gombra kattintva kaphat további információt.
  • Csak a helyi fájlrendszer-köteteket lehet töredezettségmentesíteni, és egyszerre csak egy Lemez-töredezettségmentesítő kezelőpult futtatható.


A kötet töredezettségmentesítése

  1. Nyissa meg a Lemez-töredezettségmentesítő segédprogramot.
  2. Válassza ki a töredezettségmentesíteni kívánt kötetet, majd kattintson a Töredezettségmentesítés gombra.

Megjegyzések

  • A művelet végrehajtásához rendszergazdaként vagy a Rendszergazdák csoport tagjaként kell bejelentkeznie. Ha a számítógép hálózatra csatlakozik, akkor a hálózati házirend beállításai is megakadályozhatják a művelet végrehajtását.
  • A Lemez-töredezettségmentesítő elindításához kattintson a Start gombra, mutasson a Programok, majd a Kellékek, majd a Rendszereszközök pontra, végül kattintson a Lemez-töredezettségmentesítő parancsra.
  • A köteteket töredezettségmentesítés előtt elemezni kell. Elemzés nélkül nem lehet megmondani, hogy érdemes-e töredezettségmentesíteni a köteteket.
  • A kötet töredezettségmentesítéséhez szükséges idő sok tényezőtől függ, többek között a kötet méretétől, a köteten található fájlok számától, a kötet töredezettségi százalékától, és a rendelkezésre álló rendszererőforrásoktól.
  • Ha meg akarja szakítani, vagy ideiglenesen szüneteltetni kívánja a kötet töredezettségmentesítését, kattintson a Leállítás illetve a Szüneteltetés gombra.
  • Csak a helyi fájlrendszer-köteteket lehet töredezettségmentesíteni, és egyszerre csak egy Lemez-töredezettségmentesítő kezelőpult futtatható.


Lépjen kapcsolatba az Executive Software társasággal

Az Executive Software elérhetősége

  • Telefon

    Az Amerikai Egyesült Államokban: (800) GET-DKNT

    Európából: 44-1342-327477

    Japánból: 813-3447-7544

  • Internet

    Az Executive Software nemzetközi webhelye

    (http://www.microsoft.com/isapi/redir.dll?prd=Win2000&os=Win2000&ar=Partner&sba=execsoft)

  • Elektronikus levél

    sales@executive.com

    tech_support@executive.com


A szabad lemezterület összevonása a köteten

A Lemez-töredezettségmentesítő nem vonja össze a teljes szabad területet a köteten. Míg a több száz darabra töredezett szabad terület hátrányosan befolyásolja a teljesítményt, a néhány darabra töredezett szabad területnek nincs ilyen hatása. A teljes szabad terület egy helyre történő összevonása csak nagyon kis teljesítménynövekedést eredményez.

A Windows rendszerfájlok, mint például a lapozófájl és a fő fájltáblázat (MFT) mindig kizárólagosan a Windows használatára vannak megnyitva, ezért a Lemez-töredezettségmentesítő nem kap hozzáférést ezekhez a fájlokhoz töredezettségmentesítés céljából.

A kötet töredezettségmentesítésével kapcsolatban további információt A kötet elemzése és A kötet töredezettségmentesítése című témaköröknél talál.

Számos tényező akadályozhatja a lemezpartíción lévő szabad terület töredezettségmentesítését.

  • A lapozófájl töredezett.
  • A lemezpartíció sok könyvtárat tartalmaz.
  • NTFS fájlrendszerrel rendelkező rendszerpartíciókon a lemezpartíción található szabad terület egy részét a Windows az MFT számára tartja fenn.


Miért nem helyezi át a rendszer a fájlokat az NTFS formátumú kötetek elejére?

Az NTFS formátumú köteteken a Windows a szabad terület egy részét a fő fájltáblázat (MFT) nevű rendszerfájl számára tartja fenn. A Windows az MFT fájlban tartja a köteten található fájlok lekéréséhez szükséges valamennyi információt. A Windows az MFT egy részét a kötet elején tárolja. Mivel a Windows kizárólagos használatra tartja fenn az MFT fájlt, a Lemez-töredezettségmentesítő nem helyez fájlokat a kötetek elejére.


A kötet töredezettségmentesítésének gyakorisága

Mivel a kötetek nagyon töredezetté válhatnak amikor a felhasználók sok fájlt vagy mappát törölnek róluk, ilyen esetben mindenképpen elemezze a köteteket a törlést követően. Általában a sokat használt fájlkiszolgálókon található köteteket gyakrabban kell töredezettségmentesíteni, mint az egyfelhasználós munkaállomásokon található köteteket.

A köteteket elemezve lehet azt eldönteni, hogy szükséges-e a töredezettségmentesítés. A kötet elemzése után megjelenő párbeszédpanel tájékoztat a köteten található fájlok és mappák töredezettségének százalékos értékéről, és javaslatot tesz a továbbiakra. A köteteket rendszeresen elemezze, de csak akkor töredezettségmentesítse azokat, ha a Lemez-töredezettségmentesítő erre javaslatot tesz.


A kötetek töredezetté válásának okai

A kötetek úgy válnak töredezetté, hogy a felhasználók fájlokat és mappákat hoznak létre vagy törölnek, új szoftvert telepítenek, vagy fájlokat töltenek le az Internetről. A számítógépek nem feltétlenül mentik egy helyre a teljes fájlt vagy mappát, a mentés általában a köteten először rendelkezésre álló szabad területre történik. Ha a kötet nagy részén már voltak tárolva fájlok vagy mappák, a rendszer az új fájlok legtöbbjét darabokban menti a kötet különböző részeire. A fájlok vagy mappák törlésekor hátramaradt üres területek véletlenszerűen töltődnek fel az új fájlokkal és mappákkal.

Minél töredezettebb a kötet, annál lassabban írja illetve olvassa a számítógép a fájlokat.