Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra

A következő könyvekben megtalálható a nyilvános kulcsú titkosítás és a nyilvános kulcsra épülő infrastruktúra (PKI) részletes leírása:

  • Ford, Warwick and Michael S. Baum, Secure Electronic Commerce: Building the Infrastructure for Digital Signatures and Encryption. Prentice Hall Press, 1997. április.
  • Garfinkel, Simon and Gene Spafford, Web Security & Commerce. O'Reilly & Associates, 1997. június.
  • Grant, Gail L., Understanding Digital Signatures: Establishing Trust over the Internet and Other Networks. Computing McGraw-Hill, 1997. november.
  • Schneier, Bruce, Applied Cryptography: Protocols, Algorithms, and Source Code in C. John Wiley & Sons, 1995. december.

A következő forrásmunka részletesen bemutatja a Windows 2000 Bizonyítványszolgáltatásokra épülő nyilvános kulcsra épülő infrastruktúra tervezését:

  • Windows 2000 Resource Kit

Az alábbi forrásmunka részletesen bemutatja a Windows 2000 Bizonyítványszolgáltatások testreszabásával kapcsolatos tudnivalókat:

  • Microsoft Platform Software Development Kit

A Windows 2000 rendszerrel kapcsolatos legfrissebb műszaki tudnivalókért tanulmányozza a Friss műszaki tudnivalók című témakört.


A bizonyítványhasználók gyakori feladatai az Interneten

Feladat | Hivatkozás
A bizonyítványokkal kapcsolatos fogalmak áttekintése. | Bizonyítványok – áttekintés
Hitelesítő szervezet gyökérbizonyítványának megszerzése a megbízhatóság megteremtése érdekében. | Hitelesítő szervezet bizonyítványának letöltése
A visszavont bizonyítványok aktuális listájának letöltése a hitelesítő szervezettől. | A visszavont bizonyítványok listájának letöltése
Bizonyítvány igénylése |
Bizonyítvány igénylése a hitelesítő szervezet weblapján keresztül. | Felhasználói bizonyítványkérelem elküldése a weben keresztül
(Speciális kérelmek) Bizonyítvány igénylése a hitelesítő szervezet weblapján keresztül. | Speciális bizonyítványkérelem elküldése a weben keresztül
Bizonyítványigénylés elküldése PKCS #10 fájl segítségével. Abban az esetben hasznos, ha a bizonyítványt kérelmező és a hitelesítő szervezet között nincs hálózati kapcsolat. | Bizonyítvány igénylése PKCS #10 vagy PKCS #7 fájl segítségével
Folyamatban levő bizonyítványkérelem ellenőrzése. | Folyamatban levő bizonyítványkérelem ellenőrzése
Bizonyítványok és kulcsok kezelése |
Bizonyítvány exportálása. | Bizonyítvány exportálása
Bizonyítvány exportálása személyes kulccsal. | Bizonyítvány exportálása a személyes kulccsal
Bizonyítvány importálása. | Bizonyítvány importálása
Bizonyítvány megújítása. | Bizonyítvány megújítása új kulccsal
Bizonyítvány megújítása ugyanazzal a kulccsal. | Bizonyítvány megújítása ugyanazzal a kulccsal


A bizonyítványhasználók gyakori feladatai az intraneten

Feladat | Hivatkozás
A bizonyítványokkal kapcsolatos fogalmak áttekintése. | Bizonyítványok – áttekintés
Bizonyítvány igénylése |
Bizonyítvány igénylése a Bizonyítványigénylő varázsló segítségével. | Bizonyítvány igénylése
(Speciális kérelmek) Bizonyítvány igénylése a hitelesítő szervezet weblapján keresztül. | Speciális bizonyítványkérelem elküldése a weben keresztül
Bizonyítványigénylés elküldése PKCS #10 fájl segítségével. Abban az esetben hasznos, ha a bizonyítványt kérelmező és a hitelesítő szervezet között nincs hálózati kapcsolat. | Bizonyítvány igénylése PKCS #10 vagy PKCS #7 fájl segítségével
Folyamatban levő bizonyítványkérelem ellenőrzése. | Folyamatban levő bizonyítványkérelem ellenőrzése
Bizonyítványok és kulcsok kezelése |
Bizonyítvány exportálása. | Bizonyítvány exportálása
Bizonyítvány exportálása személyes kulccsal. | Bizonyítvány exportálása a személyes kulccsal
Bizonyítvány importálása. | Bizonyítvány importálása
Bizonyítvány megújítása. | Bizonyítvány megújítása új kulccsal
Bizonyítvány megújítása ugyanazzal a kulccsal. | Bizonyítvány megújítása ugyanazzal a kulccsal


Hitelesítés

A hitelesítés nélkülözhetetlen a biztonságos kommunikációhoz. A felhasználónak tudnia kell bizonyítani azonosságát azok számára, akikkel kommunikál, és tudnia kell ellenőrizni mások azonosságát. Hálózaton keresztül nagyon összetett az azonosság hitelesítése, mivel az egymással kapcsolatban álló felek fizikailag nem találkoznak. Ez lehetőséget biztosít egyes erkölcstelen személyek számára, hogy mások üzeneteit lehallgassák, vagy valakit megszemélyesítsenek.

A digitális bizonyítvány egy elterjedt hitelesítőeszköz, amely a személyazonosság ellenőrzését biztosítja. A bizonyítványok titkosítási technikák alkalmazásával küszöbölik ki a fizikai kapcsolat hiánya okozta problémákat. Ezeknek a technikáknak a használata korlátozza az üzenetek lehallgatásának, módosításának vagy hamisításának lehetőségét. A titkosítási technikák megnehezítik a bizonyítványok módosítását, ezért egy másik személy csak nehezen személyesíthető meg.

A bizonyítvány a bizonyítvány tulajdonosának nyilvános és személyes kulcsa közül a nyilvános titkosítási kulcsot tartalmazza. A feladó személyes kulcsával aláírt üzenetet hitelességét a címzett a feladó nyilvános kulcsának segítségével ellenőrizheti. Ez a kulcs megtalálható a feladó bizonyítványának másolatában. Az aláírás nyilvános kulccsal történő ellenőrzése biztosítja, hogy az aláírást a bizonyítvány tulajdonosa a személyes kulcsának segítségével készítette. Ha a feladó óvatos volt, és titokban tartotta a személyes kulcsát, akkor a címzett biztos lehet az üzenet küldőjének személyazonosságában.

Néhány példa arra, hogyan használhatók a bizonyítványok hitelesítésre:

  • Biztonságos webhelyen a felhasználók hitelesítése a Transport Layer Security (TLS) vagy a Secure Sockets Layer (SSL) protokoll segítségével.
  • A kiszolgáló hitelesítése a felhasználó felé a Transport Layer Security protokoll segítségével.
  • Bejelentkezés egy Windows 2000 tartományba.

A hitelesítéssel és a bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.


Bizonyítványok és hitelesítő szervezetek

A bizonyítvány a bizonyítványtulajdonos azonosságának (a bizonyítvány tárgyának) azonosítása érdekében történő bemutatásakor célszerű, ha kizárólag az a személy bízik meg a bizonyítvány kibocsátójában, akinek a bizonyítványt bemutatták. A bizonyítvány kibocsátóját gyakran hitelesítő szervezetnek nevezik.

Amikor megbízik a hitelesítő szervezetben, az azt jelenti, bizonyos abban, hogy a hitelesítő szervezet megfelelő irányelveket alkalmaz a bizonyítványkérelmek elbírálására, és a bizonyítvány kiadását megtagadja minden esetben, amikor ezeket az irányelveket nem teljesítik. Továbbá biztos abban, hogy a hitelesítő szervezet a visszavont bizonyítványok lista frissítésének közzétételével visszavon minden olyan bizonyítványt, amely már nem tekinthető érvényesnek. A visszavont bizonyítványok lista a lejáratáig érvényes. Így ha a hitelesítő szervezet ki is ad egy új listát az újonnan visszavont bizonyítványokkal, a régi visszavont bizonyítványok listát használó ügyfelek az általuk jelenleg használt lista lejáratáig vagy törléséig nem keresik vagy töltik le az új listát. Az ügyfelek a hitelesítő szervezet weblapjáról szükség esetén letölthetik a visszavont bizonyítványok legfrissebb listáját.

A Windows 2000 felhasználók, számítógépek és szolgáltatások akkor tekintenek megbízhatónak egy hitelesítő szervezetet, ha a megbízható legfelső szintű hitelesítő szervezetek tárolóban megtalálható a gyökérbizonyítvány másolata, valamint egy érvényes bizonyítványlánc (a bizonyítványlánc akkor érvényes, ha a bizonyítványlánc egyetlen bizonyítványának sem járt le az érvényességi ideje, és a bizonyítványlánc egyetlen bizonyítványát sem vonta vissza a hitelesítő szervezet). A bizonyítványlánc tartalmazza a bizonyítványhierarchiában az alsóbb szintű hitelesítő szervezettől egészen legfelső hitelesítő szervezetig az összes hitelesítő szervezet számára kiadott minden bizonyítványt. Például a legfelső szintű hitelesítő szervezet bizonyítványlánca egyetlen bizonyítványt tartalmaz: a saját magával aláírt bizonyítványt. A hierarchiában egy szinttel a legfelső szintű hitelesítő szervezet alatt levő hitelesítő szervezet bizonyítványlánca két bizonyítványt tartalmaz: saját bizonyítványát és a legfelső szintű hitelesítő szervezet bizonyítványát.

Ha a szervezet Active Directory címtárat használ, a szervezet hitelesítő szervezeteinek megbízhatósága általában a rendszergazda beállításai és döntései alapján automatikusan jön létre.

A bizonyítványtárolók öröklődése olyan kapcsolódó fogalom, amellyel érdemes tisztában lenni. Ha a legfelső szintű hitelesítő szervezet bizonyítványát a számítógép megbízható legfelső szintű hitelesítő szervezetek tárolóba vagy a vállalati szintű megbízások tárolóba helyezi, akkor a számítógép minden felhasználója saját megbízható legfelső szintű hitelesítő szervezetek tárolójában vagy a vállalati szintű megbízások tárolóban látja majd a bizonyítványt annak ellenére, hogy a gyökérbizonyítvány valójában a számítógép tárolójában van. A felhasználók megbízhatónak tekintenek a számítógép által megbízhatónak tartott minden hitelesítő szervezetet. A bizonyítványtároló öröklődése fordítva nem működik: a felhasználó megbízható legfelső szintű hitelesítő szervezetek tárolójában és a vállalati szintű megbízások tárolójában levő bizonyítványokat nem örökli a számítógép.

Ha a vállalat hitelesítő szervezetét a Windows 2000 Server operációs rendszer Bizonyítványszolgáltatásainak segítségével futtatja, akkor a hitelesítő szervezet kétféle lehet: vállalati vagy különálló. A bizonyítványfelhasználók és bizonyítványigénylők szempontjából a Windows 2000 hitelesítő szervezet két típusa közöti különbségek a következők:

Vállalati hitelesítő szervezet

A vállalati hitelesítő szervezet az Active Directory címtárra épül.

A vállalati hitelesítő szervezettől történő bizonyítványkérelmekhez egyaránt használható a (a Bizonyítványok beépülő modulból elindítható) Bizonyítványigénylő varázsló és a hitelesítő szervezet weblapja.

Beállításától és a kérelmező biztonsági engedélyeitől függően a vállalati hitelesítő szervezet a kérelmezőnek különböző típusú bizonyítványokat ajánl fel. A vállalati hitelesítő szervezet a kérelmező azonosítására az Active Directory címtárban található adatokat használja fel. A vállalati hitelesítő szervezet a visszavont bizonyítványok listáját az Active Directory címtárban és egy megosztott könyvtárban egyaránt közzéteszi.

Különálló hitelesítő szervezet

A különálló hitelesítő szervezet kevésbé automatizált, mint a vállalati hitelesítő szervezet, mivel nem az Active Directory használatára épül.

Alapértelmezés szerint a felhasználók csak weblapokon keresztül kérhetnek bizonyítványt a különálló hitelesítő szervezettől.

A különálló hitelesítő szervezet, amely nem használja az Active Directory szolgáltatást, általában sokkal részletesebb azonosító adatok megadását igényli. A különálló hitelesítő szervezet a visszavont bizonyítványok listáját egy megosztott mappában vagy az Active Directory címtárban (ha rendelkezésre áll) teszi közre.

Megjegyzések

  • A Windows 2000 hitelesítő szervezet vállalati vagy különálló működési módját meghatározó Bizonyítványszolgáltatások házirend- és kilépési modullal kapcsolatos további tudnivalókért tanulmányozza a Házirend- és kilépési modul című témakört.
  • A Windows 2000 hitelesítő szervezet testreszabható egy a Windows 2000 operációs rendszerben levő házirendmodultól különböző házirendmodullal. Ilyenkor a hitelesítő szervezet nem vállalati és nem különálló hitelesítő szervezet, hanem vegyesen biztosíthatja ezek szolgáltatásait. A szervezetben működő, egyedi felépítésű Windows 2000 hitelesítő szervezettel kapcsolatos további tudnivalókért forduljon a hitelesítő szervezet rendszergazdájához.
Tanulmányozza még:
  • Hitelesítő szervezetek
  • Bizonyítványszolgáltatások – áttekintés
  • Bizonyítvány igénylése
  • A Windows 2000 Bizonyítványszolgáltatások weblap használata
  • Bizonyítványtárolók
  • Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra


Titkosító kulcsok és bizonyítványkérelmek létrehozása

Új bizonyítvány iránti kérelem létrehozásakor a kérelmező programból első lépésben a Microsoft titkosítási alkalmazásprogramozó felülethez (más néven CryptoAPI) kerülnek a kérelemben található adatok. A CryptoAPI a szükséges adatokat átküldi a számítógépre, vagy a számítógéphez kapcsolódó eszközre telepített úgynevezett titkosításszolgáltató (CSP) programnak. A szoftveres titkosításszolgáltató a számítógépen létrehoz egy nyilvános kulcsból és egy személyes kulcsból álló kulcspárt. A hardveres titkosításszolgáltató (például intelligens kártya) egy hardvereszköz segítségével hozza létre a kulcspárt.

A kulcsok létrehozása után a szoftveres titkosításszolgáltató titkosítja a személyes kulcsot, és biztonságba helyezi a számítógép rendszerleíró adatbázisában. Az intelligens kártya alapú titkosításszolgáltató a személyes kulcsot a kulcs elérhetőségét vezérlő intelligens kártyán tárolja. A rendszer ezután a nyilvános kulcsot és a bizonyítványkérelmező adatait elküldi a hitelesítő szervezetnek (CA). A bizonyítvány irányelvei alapján történő ellenőrzése után a hitelesítő szervezet saját személyes kulcsával létrehoz egy digitális aláírást a bizonyítványban, majd elküldi azt a kérelmezőnek. Ekkor a bizonyítvány kérelmezője megkapja a bizonyítványt a hitelesítő szervezettől, amelyet telepíthet a számítógép vagy hardvereszköz megfelelő bizonyítványtárolójába.

A kulcsokkal és bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.

Tanulmányozza még:

Bizonyítvány igénylése


Titkosság

A hálózaton (például az Interneten) keresztüli kommunikáció ki van téve az ismeretlen és esetleg rosszakaratú felhasználók által történő lehallgatás veszélyének. Nyilvános hálózaton nem biztonságos az érzékeny adatok titkosítatlan továbbítása, mivel bárki hozzáférhet a hálózathoz, és elemezheti a hálózaton továbbított adatokat. Még a magántulajdonban levő helyi hálózatok (LAN) is sebezhetők az elszánt behatolókkal szemben, akik fizikai hozzáférést próbálnak szerezni a hálózathoz. Ezért ha bármilyen típusú hálózaton érzékeny adatokat küldenek két számítógép között, a felhasználók majdnem biztosan valamilyen titkosítás használatát igénylik adataik védelme érdekében.

A nyilvános kulcsú titkosítást nem használják nagy mennyiségű adat titkosítására. Ehelyett az adatokat egy olyan titkos kulccsal titkosítják, amelyet előzetesen az adatok címzettjének nyilvános kulcsával tikosítottak. Ezután a titkosított titkos kulcsot a titkosított adatokkal együtt elküldik a címzettnek. A címzett a személyes kulcs segítségével visszafejti a titkos kulcsot. Végül a titkos kulcs segítségével visszafejthető maga az üzenetet.

A bizonyítványok több módon is biztosítják az elküldött adatok titkosságát. A leginkább elterjedt titkosítást biztosító protokollok:

  • Secure Multipurpose Internet Mail Extensions (S/MIME)
  • Transport Layer Security (TLS)
  • IP-biztonság (IPSec). Tanulmányozza a következő témakört: IP-biztonság: Alapvető tudnivalók

A titkossággal és a bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.


Bizonyítványok

A nyilvános kulcsú bizonyítvány, a továbbiakban egyszerűen bizonyítvány, olyan digitálisan aláírt okmány, amely a nyilvános titkosító kulcs értékét a hozzá tartozó személyes kulcsot birtokló személy, eszköz vagy szolgáltatás azonosságával kapcsolja össze. A nyilvános kulcsú titkosításról részletes tudnivalók találhatók a Kapcsolódó témakörök Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra című témakörében.

A bizonyítványok kiállításának sokféle célja lehet, például az Web felhasználóinak azonosítása, a webkiszolgálók hitelesítése, a biztonságos elektronikus levelezés (S/MIME) vagy a kódaláírás. Az a személy, számítógép vagy szolgáltatás, aki számára kibocsátották a bizonyítványt, a bizonyítvány tulajdonosa. A bizonyítvány kibocsátójának és aláírójának az úgynevezett hitelesítő szervezet (CA). A szervezeten belül a Windows 2000 vállalati hitelesítő szervezetét használata esetén a bizonyítványok a Windows 2000 tartományokba történő bejelentkezéshez használhatók. A hitelesítő szervezetek egymásnak is bocsátanak ki bizonyítványokat, így jön létre a bizonyítványhierarchia.

A manapság legszélesebb körben használt bizonyítványformátum az X.509-es szabványon alapul, amely egyúttal a Windows 2000 nyilvános kulcsú infrastruktúrában használt technológia alapja is.

A bizonyítványok általában a következő adatokat tartalmazzák:

  • A tulajdonos nyilvános kulcsának az értékét
  • A tulajdonost azonosító adatokat, például nevet és elektronikus postacímet
  • Az érvényességi időtartamot, amelyen belül a bizonyítvány érvényes
  • A kibocsátó azonosító adatait
  • A kibocsátó digitális aláírását, a tulajdonos nyilvános kulcsa és azonosító adatai közötti kapcsolat érvényességének ellenőrzéséhez.

A bizonyítvány csak a benne meghatározott időtartamig érvényes, ezért minden bizonyítvány tartalmazza az Érvényesség kezdete és az Érvényesség lejárta dátumokat, amelyek az érvényességi időtartamot határolják. Ha egy bizonyítvány érvényességi időtartama lejár, a tulajdonosnak új bizonyítványt kell kérnie.

Ha szükségessé válik a bizonyítványban található megfeleltetés megszüntetése, a bizonyítványt a kibocsátó visszavonhatja. Minden kibocsátó fenntart egy listát a visszavont bizonyítványokról, amelyet a programok a bizonyítványok érvényességének ellenőrzésére használhatnak.

A bizonyítvány egyik fő előnye, hogy a gazdagépeknek, például a webkiszolgálóknak, nem kell fenntartaniuk jelszóállományokat vagy hozzáférés-vezérlési listákat a hozzáférésre jogosult felhasználókról. Ehelyett a gazdagép egyszerűen megbízik a bizonyítvány kiállítójában.

Ha a gazdagép megbízik a kibocsátóban, mint a megbízható legfelső szintű szervezetben, akkor fenntartás nélkül megbízik a kibocsátó bizonyítványok kibocsátásával kapcsolatos irányelveiben. Tehát a gazdagép megbízik abban, hogy a kibocsátó ellenőrizte a bizonyítvány tulajdonosának azonosságát. Amikor az állomás megbízható legfelső szintű szervezetnek nyilvánít egy kibocsátót, elhelyezi annak saját aláírású bizonyítványát a megbízható legfelső szintű hitelesítő szervezetek tárolójában. A közbenső vagy alsóbb szintű hitelesítő szervezetek csak akkor megbízhatóak, ha egy megbízható legfelső szintű hitelesítő szervezettől származó érvényes bizonyítványlánccal rendelkeznek.

Kapcsolódó témakörök


Titkosítás

A titkosítás olyan, mintha valami értékeset egy erős dobozba kulcsra zárnánk. Így a visszafejtés a doboz kinyitásához és az értékes tárgy kivételéhez hasonlítható. A számítógépen elektronikus üzenet, lemezen tárolt vagy hálózaton továbbított fájl formájában levő érzékeny adatok kulcs segítségével titkosíthatók. A titkosított adat és a titkosításra használt kulcs önmagában értelmezhetetlen.

A nyilvános kulcsú titkosítást általában nem használják nagy mennyiségű adat titkosítására. A nyilvános kulcsú titkosítás azonban hatékonyan használható a nagy mennyiségű adat szimmetrikus titkosításához használt titkos kulcs elküldésére.

Például tételezzük fel, hogy Róbert sok titkosított fájlt akar küldeni Aliznak. A megfelelő teljesítmény érdekében Róbert olyan szimmetrikus titkosító kulcsú algoritmussal titkosítja az adatokat, mint például a DES (Data Encryption Standard – Adattitkosítási szabvány). A titkosított adatok és az azok visszafejtéséhez szükséges DES titkos kulcs elküldéséhez Róbert titkosítja a titkos kulcsot Aliz nyilvános kulcsával, amely Aliz bizonyítványából nyerhető ki. Mivel Róbert a titkos kulcs titkosításához Aliz nyilvános kulcsát használta, ezért Aliz az egyetlen, aki a személyes kulcsával képes visszafejteni a DES titkos kulcsot, és így a DES-algoritmussal titkosított adatokat.

Tanulmányozza még:

Fájltitkosítás – áttekintés

A titkosítással és a bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.


Bizonyítvány importálása és exportálása

A Bizonyítványok beépülő modul felügyeleti eszközöket biztosít a bizonyítványok (szükség esetén bizonyítványláncukkal és személyes kulcsukkal együtt történő) exportálásához és importálásához. A bizonyítványok importálhatók vagy exportálhatók PKCS #12 vagy PKCS #7 fájlba, illetve bináris kódolású X.509 bizonyítványfájlba.

Bizonyítvány importálása

A következő esetekben lehet szükség bizonyítvány importálására:

  • Másik felhasználó, számítógép vagy hitelesítő szervezet által fájlban küldött bizonyítvány telepítéséhez.
  • Sérült vagy elveszett bizonyítvány helyreállításához, amelyről előzőleg készült biztonsági másolat.
  • Bizonyítvány, és a hozzá tartozó személyes kulcs telepítéséhez a bizonyítvány tulajdonosa által előzőleg használt számítógépről.

Bizonyítvány importálásakor a rendszer egy szabványos bizonyítványtároló formátumot használó fájlból a felhasználói fiókhoz vagy a számítógépfiókhoz tartozó bizonyítványtárolóba másolja a bizonyítványt.

Bizonyítvány exportálása

A következő esetekben lehet szükség bizonyítvány exportálására:

  • Biztonsági másolat készítése bizonyítványról.
  • Biztonsági másolat készítése bizonyítványról és a hozzá tartozó személyes kulcsról.
  • Bizonyítvány másolása másik számítógépen történő használatra.
  • Bizonyítvány és a hozzá tartozó személyes kulcs eltávolításához a bizonyítvány tulajdonosa által jelenleg használt számítógépéről egy másik számítógépre való telepítéshez.

Bizonyítvány exportálásakor a rendszer a bizonyítványtárolóból egy szabványos bizonyítványtároló formátumú fájlba másolja a bizonyítványt.

Bizonyítványok szabványos fájlformátumai

A bizonyítványok a következő formátumokba exportálhatók és importálhatók:

  • Személyes információcsere (PKCS #12)

    A Személyes információcsere formátum (PFX vagy PKCS #12) lehetővé teszi a bizonyítványok és a hozzájuk tartozó személyes kulcsok átvitelét egyik számítógépről a másikra, vagy a számítógépről valamilyen cserélhető adathordozóra.

    A PKCS #12 egy szabványos formátum, amely lehetővé teszi a bizonyítványok és a hozzájuk tartozó személyes kulcsok szállítását, biztonsági mentését és visszaállítását. Ez történhet egyazon gyártó, vagy akár különböző gyártók termékei között.

    A PKCS #12 formátum használatához a titkosításszolgáltatónak (CSP) a bizonyítványt és a kulcsokat exportálhatóként kell tekintenie. Ha a bizonyítványt Windows 2000 hitelesítő szervezett bocsátotta ki, akkor a bizonyítvány személyes kulcsa csak abban az esetben exportálható, ha a következők egyike igaz:

    • A bizonyítványt az EFS (titkosító fájlrendszer) vagy az EFS-helyreállítás számára állították ki.
    • A bizonyítványigénylés a hitelesítő szervezet Speciális bizonyítványigénylés weblapján keresztül történt a Kulcsok megjelölése exportálhatóként jelölőnégyzet bejelölésével.

    Mivel az exportálás következtében illetéktelenek is megszerezhetik a személyes kulcsot, ezért a Windows 2000 operációs rendszerben csak PKCS #12 formátumban exportálhatók a bizonyítványok, és a hozzájuk tartozó személyes kulcsok.

  • Titkosított üzenetszintaxis-szabvány (PKCS #7)

    A PKCS #7 formátum lehetővé teszi egy bizonyítvány és a bizonyítványláncában levő bizonyítványok átvitelét egyik számítógépről a másikra, vagy a számítógépről valamilyen cserélhető adathordozóra. A PKCS #7 fájlok kiterjesztése általában .p7b.

  • DER kódolású bináris X.509

    Bizonyos nem Windows 2000 kiszolgálón működő hitelesítő szervezetek használhatják ezt a formátumot, így ez a formátum a kölcsönös együttműködést szolgálja. A DER-bizonyítványfájlok kiterjesztése .cer.

  • Base64 kódolású X.509

    Bizonyos nem Windows 2000 kiszolgálón működő hitelesítő szervezetek használhatják ezt a formátumot, így ez a formátum a kölcsönös együttműködést szolgálja. A Base64 bizonyítványfájlok kiterjesztése .cer.

Tanulmányozza még:

  • Bizonyítvány importálása
  • Bizonyítvány exportálása
  • Bizonyítvány exportálása a személyes kulccsal
  • PKCS #7 fájlban tárolt bizonyítványok megtekintése


A Bizonyítványok beépülő modul indítása

A Microsoft Management Console (MMC) Bizonyítványok beépülő moduljának segítségével lehet a nyilvános kulcsú bizonyítványokat kezelni.

Ha egy számítógép vagy tartomány rendszergazdája, és a Bizonyítványok beépülő modult hozzáadja az MMC-kezelőpulthoz, akkor kezelheti az alábbi felhasználók számára kibocsátott bizonyítványokat:

  • Saját maga (Saját felhasználói fiókom választógomb)
  • A számítógép (Számítógépfiók választógomb)
  • Helyi szolgáltatások (Szolgáltatásfiók választógomb)

Ha Ön egy felhasználó, és a Bizonyítványok beépülő modult hozzáadja az MMC-kezelőpulthoz, akkor csak a saját felhasználói fiókjához tartozó bizonyítványokat kezelheti.

A Bizonyítványok külön példányát kell betölteni minden személy számára, akinek a bizonyítványait kezeli.

Tanulmányozza még:

  • A felhasználói fiókhoz tartozó bizonyítványok kezelése
  • A számítógéphez tartozó bizonyítványok kezelése
  • Egy szolgáltatáshoz tartozó bizonyítványok kezelése


Bizonyítvány törlése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Hajtsa végre az alábbi művelek egyikét:
    • A konzolfa logikai bizonyítványtárolók szerinti megjelenítési módjának használata esetén kattintson a Bizonyítványok elemre.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Logikai tároló
      • Bizonyítványok
    • A bizonyítvány célja szerinti megjelenítési mód használata esetén a kattintson a konzolfa Cél elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Cél
  3. A részletek ablaktáblában kattintson a törölni kívánt bizonyítványra.

    Több bizonyítvány kiválasztásához a CTRL billentyű nyomva tartása mellett kattintson az egyes bizonyítványokra.

  4. Kattintson a Művelet menü Törlés parancsára. Ha biztos abban, hogy véglegesen törölni akarja a bizonyítványt, kattintson az Igen gombra.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • Törlés előtt a bizonyítvány exportálásával biztonsági másolat készíthető a bizonyítványról. A bizonyítványok exportálásával kapcsolatban tanulmányozza a Kapcsolódó témaköröket.


Bizonyítvány exportálása

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Hajtsa végre az alábbi művelek egyikét:
    • A logikai bizonyítványtárolók szerinti megjelenítési mód használata esetén kattintson a konzolfa Bizonyítványok elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Logikai tároló
      • Bizonyítványok
    • A bizonyítvány célja szerinti megjelenítési mód használata esetén a kattintson a konzolfa Cél elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Cél
  3. A részletek ablaktáblában kattintson az exportálni kívánt bizonyítványra.
  4. A Művelet menüben mutasson a Feladatok pontra, majd kattintson az Exportálás parancsra.
  5. A Bizonyítványexportáló varázslóban válassza a Nem, nem akarom exportálni a személyes kulcsomat lehetőséget. (Ez a lehetőség csak abban az esetben jelenik meg, ha a személyes kulcs exportálhatóként van megjelölve, és megfelelő hozzáféréssel rendelkezik a személyes kulcshoz.)
  6. A Bizonyítványexportáló varázslóban adja meg a következő adatokat:
    • Válassza ki a fájlformátumot, amelyben tárolni szeretné az exportált bizonyítványt: DER kódolású fájl, Base-64 kódolású fájl vagy PKCS #7 fájl.
    • Ha a bizonyítványt PKCS #7 fájlba exportálja, akkor a bizonyítvánnyal együtt a bizonyítványláncban levő összes bizonyítványt exportálhatja.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • A bizonyítványok személyes kulccsal együtt történő exportálásával kapcsolatban tanulmányozza a Kapcsolódó témaköröket.
  • A Bizonyítványexportáló varázsló által végzett művelet befejezése után a bizonyítvány az újonnan létrehozott fájl mellett a bizonyítványtárolóban is megmarad. Ha el akarja távolítani a bizonyítványt a bizonyítványtárolóból, akkor azt törölni kell.


Bizonyítvány exportálása személyes kulccsal

Bizonyítvány exportálása a személyes kulccsal

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Hajtsa végre az alábbi művelek egyikét:
    • A logikai bizonyítványtárolók szerinti megjelenítési mód használata esetén kattintson a konzolfa Bizonyítványok elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Logikai tároló
      • Bizonyítványok
    • A bizonyítvány célja szerinti megjelenítési mód használata esetén kattintson a konzolfa Cél elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Cél
  3. A részletek ablaktáblában kattintson az exportálni kívánt bizonyítványra.
  4. A Művelet menüben mutasson a Feladatok pontra, majd kattintson a Exportálás parancsra.
  5. A Bizonyítványexportáló varázslóban válassza az Igen, a személyes kulcs exportálását választom választógombot. (Ez a választógomb csak abban az esetben jelenik meg, ha a személyes kulcs exportálhatóként van megjelölve, és megfelelő hozzáféréssel rendelkezik a személyes kulcshoz.)
  6. Adja meg az alábbi adatokat:
    • Adja meg, hogy exportálni akarja-e a bizonyítványlánc összes bizonyítványát.
    • Válassza ki, hogy engedélyezni akarja-e az erős védelmet.
    • Válassza ki, hogy sikeres exportálás után törölni kívánja-e a személyes kulcsot.
    • Adjon meg egy jelszót az exportálni kívánt személyes kulcs titkosításához.
    • Adja meg az exportált bizonyítványt és személyes kulcsot tároló PKCS #12 fájl nevét és elérési útvonalát.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • Ha a bizonyítványt Windows 2000 hitelesítő szervezet bocsátotta ki, akkor a bizonyítvány személyes kulcsa csak abban az alábbi esetben exportálható:
    • A bizonyítványkérelem a hitelesítő szervezet Speciális bizonyítványkérelem weblapján keresztül történt a Kulcsok megjelölése exportálhatóként jelölőnégyzet bejelölésével, vagy a bizonyítványt EFS (titkosító fájlrendszer) vagy EFS-helyreállítás számára adták ki.
  • Bizonyítvány, és a hozzá tartozó személyes kulcs együttes exportálásakor az erős védelem (más néven iterációs számlálás) alapértelmezés szerint engedélyezett a Bizonyítványexportáló varázslóban.

    Az erős védelem nem kompatibilis a régebbi programokkal, ezért törölni kell az Erős védelem jelölőnégyzetet, ha a személyes kulcsot Microsoft Internet Explorer 5-nél régebbi böngészővel akarja használni.

  • A Bizonyítványexportáló varázsló által végzett művelet befejezése után a bizonyítvány az újonnan létrehozott fájl mellett a bizonyítványtárolóban is megmarad. Ha el akarja távolítani a bizonyítványt a bizonyítványtárolóból, akkor azt törölni kell.


Bizonyítvány keresése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Kattintson a Bizonyítványok - bizonyítványtulajdonos elemre, ahol a bizonyítványtulajdonos a bizonyítvány egy (adott felhasználóhoz, számítógéphez vagy szolgáltatáshoz tartozó) példányát jelöli.
  3. Kattintson a Művelet menü Bizonyítványok keresése parancsára.
  4. A bizonyítványok kereséséhez adja meg a következő feltételeket:
    • A bizonyítványtárolót, amelyben keresni akar
    • A keresendő szöveget
    • A bizonyítványnak az a mezőjét, amelyben keresni akarja a szöveget. A Kiállítva a következőnek, a Kiállító, a Sorozatszám, az MD5-ujjlenyomat és az SHA1-ujjlenyomat mezőkben végezhető keresés.
  5. Kattintson a Keresés most gombra.

Megjegyzés

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.


Bizonyítvány importálása

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. A konzolfa Személyes eleme alatt kattintson a Bizonyítványok elemre.

    Helye:

    • Bizonyítványok – Bizonyítványtulajdonos
    • Személyes
    • Bizonyítványok
  3. A Bizonyítványimportáló varázsló megnyitásához a Feladatok menüben kattintson az Importálás parancsra.
  4. Hajtsa végre a következő műveleteket:
    • Kattintson az importálni kívánt bizonyítványokat tartalmazó fájlra.
    • (Választható) PKCS #12 fájl esetén adja meg a személyes kulcs titkosítására használt jelszót. Jelölje be a megfelelő jelölőnégyzetet, ha exportálhatóvá kívánja tenni a személyes kulcsot, és válassza ki, hogy engedélyezni akarja-e az erős kulcsvédelmet.
    • Jelölje be a megfelelő jelölőnégyzetet, ha a bizonyítványt típusa alapján automatikusan akarja elhelyezni egy bizonyítványtárolóban, vagy meg akarja adni a tárolás helyét.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • Bizonyítvány bármely logikai tárolóba importálható. Általában a bizonyítványok a személyes tárolóba vagy a megbízható legfelső szintű hitelesítő szervezetek tárolóba kerülnek, attól függően, hogy a bizonyítványt a felhasználó számára állították-e ki, vagy a legfelső szintű hitelesítő szervezet bizonyítványa.
  • Az erős kulcsvédelem engedélyezése esetén a személyes kulcs használatához minden alkalommal meg kell adni a jelszót. Ez akkor hasznos, ha biztos akar lenni abban, hogy tudtán kívül nem használható a személyes kulcsa.
  • A művelet végrehajtásához a logikai bizonyítványtárolók szerinti megjelenítési módot kell beállítani. Tanulmányozza a Kapcsolódó témakörökben.
  • A Bizonyítványimportáló varázsló megnyitásához kattintson a jobb oldali egérgombbal az exportált bizonyítványt tartalmazó fájlra:

    DER (.cer), Base-64 (.cer) és PKCS #7 (.p7b) fájlok esetén a Windows Intézőben a jobb oldali egérgombbal kattintson a fájlra, majd válassza a Bizonyítvány telepítése parancsot.

    #PKCS #12 (.pfx) fájl esetén a Windows Intézőben a jobb oldali egérgombbal kattintson a fájlra, majd válassza a PFX telepítése parancsot.

  • A bizonyítványok importálásához használt fájl nem módosul a bizonyítványok importálásának befejezése után. Ha már nincs szüksége a fájlra, akkor törölheti a Windows Intézővel.

  • Ha Windows NT 4.0 operációs rendszert futtató kiszolgálón levő Internet Information Services (IIS) weblapot, valamint a hozzá tartozó nyilvános és személyes kulcsokat Windows 2000 operációs rendszert futató számítógépre helyezi át, akkor az IIS Webhelybizonyítvány varázslóval létrehozott .key fájlok nem importálhatók a Bizonyítványok beépülő modul segítségével. A .key fájlból a kulcsok és a bizonyítvány csak Windows 2000 operációs rendszeren az IIS 5.0 Webhelybizonyítvány varázslóját futtató kiszolgálóra importálhatók. Ez azonban csak a webhely az egyik számítógépről a másikra történő áthelyezésekor érvényes. Ha a webkiszolgáló operációs rendszerét Windows NT 4.0-ról Windows 2000-re frissíti, akkor az automatikusan a meglevő kulcsokat és bizonyítványokat használja majd.

    Ha a Windows 2000 operációs rendszert futtató kiszolgálón telepítve van az IIS, akkor a .key fájl tartalmának a Webhelybizonyítvány varázsló segítségével történő importálásával kapcsolatos tudnivalókért tanulmányozza az IIS súgójában Az új biztonsági feladatok varázsló (http://localhost/iishelp/iis/htm/core/iikeysc.htm) című témakört.


Számítógép bizonyítványainak kezelése

  1. Jelentkezzen be a rendszerbe rendszergazdaként.
  2. Kattintson a Start menüre, a Futtatás parancsra, írja be az mmc parancsot, majd kattintson az OK gombra.
  3. Kattintson a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsára, majd a Hozzáadás gombra.
  4. A Beépülő modul oszlopban kattintson duplán a Bizonyítványok elemre, kattintson a Számítógépfiók választógombra, majd a Tovább gombra.
  5. Hajtsa végre az alábbi művelek egyikét:
    • A helyi számítógép bizonyítványainak kezeléséhez kattintson a Helyi számítógép választógombra, majd a Befejezés gombra.
    • Távoli számítógép bizonyítványainak kezeléséhez kattintson a Másik számítógép választógombra, adja meg, vagy a Tallózás gombra kattintás után válassza ki a számítógép nevét, majd kattintson a Befejezés gombra.
  6. Kattintson a Bezárás gombra.

    Az új konzolhoz kiválasztott beépülő modulok listájában megjelenik a Bizonyítványok Számítógép neve elem.

  7. Ha már nem akar több beépülő modult hozzáadni a konzolhoz, kattintson az OK gombra.
  8. A konzol mentéséhez kattintson a Konzol menü Mentés parancsára.

Megjegyzések

  • Másik számítógép bizonyítványainak kezeléséhez a konzolon létrehozható a Bizonyítványok beépülő modul újabb példánya, vagy a jobb oldali egérgombbal a Bizonyítványok Számítógép neve elemre kattintás után kiválasztható a Csatlakozás másik számítógéphez parancs.
  • MMC-konzol létrehozásával és használatával kapcsolatos további tudnivalókért kattintson a Súgó menü Témakörök parancsára.


Szolgáltatás bizonyítványainak kezelése

  1. Jelentkezzen be a rendszerbe rendszergazdaként.
  2. Kattintson a Start menüre, a Futtatás parancsra, írja be az mmc parancsot, majd kattintson az OK gombra.
  3. Kattintson a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsára, majd a Hozzáadás gombra.
  4. A Beépülő modul oszlopban kattintson duplán a Bizonyítványok elemre, kattintson a Szolgáltatásfiók választógombra, majd a Tovább gombra.
  5. Hajtsa végre az alábbi művelek egyikét:
    • A helyi számítógép szolgáltatásaihoz tartozó bizonyítványok kezeléséhez kattintson a Helyi számítógép választógombra, majd a Tovább gombra.
    • Távoli számítógép bizonyítványainak kezeléséhez kattintson a Másik számítógép választógombra, adja meg, vagy a Tallózás gombra kattintás után válassza ki a számítógép nevét, majd kattintson a Tovább gombra.
  6. Kattintson arra a szolgáltatásra, amelynek a bizonyítványait kezelni akarja.
  7. Kattintson a Befejezés, majd a Bezárás gombra.

    8. Az új konzolhoz kiválasztott beépülő modulok listájában megjelenik a Bizonyítványok – Szolgáltatás Szolgáltatás neve a következőn: Számítógép neve elem.

  8. Ha már nem akar több beépülő modult hozzáadni a konzolhoz, kattintson az OK gombra.
  9. A konzol mentéséhez kattintson a Konzol menü Mentés parancsára.

Megjegyzések

  • Másik számítógép szolgáltatásához tartozó bizonyítványok kezeléséhez létrehozható a konzol egy újabb példánya, vagy a jobb oldali egérgombbal a Bizonyítványok Számítógép neve elemre kattintás után kiválasztható a Csatlakozás másik számítógéphez parancs.
  • MMC-konzol létrehozásával és használatával kapcsolatos további tudnivalókért kattintson a Súgó menü Témakörök parancsára.


Bizonyítvány tulajdonságainak módosítása

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Hajtsa végre az alábbi művelek egyikét:
    • A logikai bizonyítványtárolók szerinti megjelenítési mód használata esetén a konzolfa Személyes eleme alatt kattintson a Bizonyítványok elemre.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Személyes
      • Bizonyítványok
    • A bizonyítvány célja szerinti megjelenítési mód használata esetén kattintson a konzolfa Cél elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Cél
  3. Kattintson a módosítani kívánt bizonyítványra.
  4. Kattintson a Művelet menü Tulajdonságok parancsára.
  5. Itt az alábbi műveleteket végezheti el:
    • Módosítható a bizonyítvány rövid neve.
    • Módosítható a bizonyítvány leírása.
    • Engedélyezhető a bizonyítvány tetszőleges (minden) célra való felhasználása (a bizonyítvány típusa alapján).
    • Letiltható a bizonyítvány minden felhasználási célja.
    • Adott felhasználási célok rendelhetők a bizonyítványhoz.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • Bizonyítvány tulajdonságainak módosításához először jelenítse meg a bizonyítványt, nyissa meg a Részletek párbeszédpanelt, majd kattintson a Tulajdonságok szerkesztése gombra.


Bizonyítvány áthelyezése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. A bizonyítványt tartalmazó logikai tárolóban kattintson a Bizonyítványok elemre.

    Helye:

    • Bizonyítványok – Bizonyítványtulajdonos
    • Logikai tároló
    • Bizonyítványok
  3. A részletek ablaktáblában kattintson az áthelyezni kívánt bizonyítványra.

    Több bizonyítvány kiválasztásához a CTRL billentyű nyomva tartása mellett kattintson az egyes bizonyítványokra.

  4. Kattintson a Művelet menü Kivágás parancsára.
  5. Kattintson annak a logikai bizonyítványtárolónak a Bizonyítványok elemére, ahová át akarja helyezni a bizonyítványt.

    Helye:

    • Bizonyítványok – Bizonyítványtulajdonos
    • Logikai tároló
    • Bizonyítványok
  6. Kattintson a Művelet menü Beillesztés parancsára.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • A művelet végrehajtásához a logikai bizonyítványtárolók szerinti megjelenítési módot kell beállítani. Tanulmányozza a Kapcsolódó témakörökben.
  • Objektum csak a Bizonyítványok beépülő modul bizonyítványtárolói között helyezhető át. Objektum például nem helyezhető át a Windows Intéző valamelyik mappájába.


Bizonyítvány megújítása új kulccsal

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. A konzolfa Személyes eleme alatt kattintson a Bizonyítványok elemre.

    Helye:

    • Bizonyítványok – Bizonyítványtulajdonos
    • Személyes
    • Bizonyítványok
  3. A részletek ablaktáblában kattintson a megújítani kívánt bizonyítványra.
  4. A Bizonyítványmegújító varázsló megnyitásához a Művelet menüben mutasson a Feladatok elemre, majd kattintson a Bizonyítvány megújítása új kulccsal parancsra.
  5. A Bizonyítványmegújító varázslóban hajtsa végre az alábbi műveletek egyikét:
    • Használja az alapértelmezett értékeket a bizonyítvány megújításához.
    • (Csak tapasztalt felhasználóknak) Adja meg a bizonyítvány megújításának beállításait. Ehhez ismernie kell a titkosításszolgáltatót (CSP), és a bizonyítványt kibocsátó hitelesítő szervezetet (CA).

      A személyes kulcs erős védelme is engedélyezhető. A személyes kulcs erős védelemének engedélyezése esetén a személyes kulcs használatához mindig jelszót kell megadni. Ez akkor hasznos, ha biztos akar lenni abban, hogy tudtán kívül nem használható a személyes kulcsa.

  6. Kattintson a Bizonyítvány telepítése gombra, ha a Bizonyítványmegújító varázsló sikeresen befejezte a műveletet.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • A művelet végrehajtásához a logikai bizonyítványtárolók szerinti megjelenítési módot kell beállítani. Tanulmányozza a Kapcsolódó témakörökben.
  • A megújítás során a régi bizonyítványt archiválja a rendszer. Az archivált bizonyítványok megjelenítésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A fenti művelettel csak vállalati hitelesítő szervezettől igényelhető bizonyítvány. Különálló hitelesítő szervezettől csak weblapokon keresztül igényelhető bizonyítvány. A Windows 2000 hitelesítő szervezet weblapja a http://kiszolgáló_neve/certsrv címen található, ahol a kiszolgáló_neve a hitelesítő szervezetet működtető Windows 2000 kiszolgáló neve.
  • Az Internet Information Services (IIS) 5.0 webkiszolgálók számára kiadott bizonyítványok a Bizonyítványok beépülő modul helyett az Internet szolgáltatáskezelő Webhelybizonyítvány varázslójával újítható meg. Ha a Windows 2000 operációs rendszert futtató kiszolgálón telepítve van az IIS, akkor a kulcsfájl a Webhelybizonyítvány varázslóval történő importálásával kapcsolatos tudnivalókért tanulmányozza az IIS súgójának Az új biztonsági feladatok varázsló című témakörét (http://localhost/iishelp/iis/htm/core/iikeysc.htm).


Bizonyítvány megújítása ugyanazzal a kulccsal.

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. A konzolfa Személyes eleme alatt kattintson a Bizonyítványok elemre.

    Helye:

    • Bizonyítványok – Bizonyítványtulajdonos
    • Személyes
    • Bizonyítványok
  3. A részletek ablaktáblában kattintson a megújítani kívánt bizonyítványra.
  4. A Bizonyítványmegújító varázsló elindításához a Művelet menüben mutasson a Feladatok pontra, majd kattintson a Bizonyítvány megújítása ugyanazzal a kulccsal parancsra.
  5. A Bizonyítványmegújító varázslóban hajtsa végre az alábbi műveletek egyikét:
    • Használja az alapértelmezett értékeket a bizonyítvány megújításához.
    • Adja meg a személyes beállításokat a bizonyítvány megújításához. Ehhez ismernie kell a bizonyítványt kibocsátó hitelesítő szervezetet.
  6. Kattintson a Bizonyítvány telepítése gombra, ha a Bizonyítványmegújító varázsló sikeresen befejezte a műveletet.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • A művelet végrehajtásához a logikai bizonyítványtárolók szerinti megjelenítési módot kell beállítani. Tanulmányozza a Kapcsolódó témakörökben.
  • A megújítás során a régi bizonyítványt archiválja a rendszer. Az archivált bizonyítványok megjelenítésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A fenti művelettel csak vállalati hitelesítő szervezettől igényelhető bizonyítványt. Különálló hitelesítő szervezettől csak weblapokon keresztül igényelhető bizonyítvány. A Windows 2000 hitelesítő szervezet weblapja a http://kiszolgáló_neve/certsrv címen található, ahol a kiszolgáló_neve a hitelesítő szervezetet működtető Windows 2000 kiszolgáló neve.
  • Az Internet Information Services (IIS) 5.0 webkiszolgálók számára kiadott bizonyítványok a Bizonyítványok beépülő modul helyett az Internet szolgáltatáskezelő Webhelybizonyítvány varázslójával újítható meg. Ha a Windows 2000 operációs rendszert futtató kiszolgálón telepítve van az IIS, akkor a kulcsfájl a Webhelybizonyítvány varázslóval történő importálásával kapcsolatos tudnivalókért tanulmányozza az IIS súgójának Az új biztonsági feladatok varázsló című témakörét (http://localhost/iishelp/iis/htm/core/iikeysc.htm).


Bizonyítvány igénylése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. A konzolfán kattintson a Bizonyítványok egyik példányára (például Bizonyítványok – Aktuális felhasználó vagy Bizonyítványok Számítógép neve).
  3. Hajtsa végre az alábbi művelek egyikét:
    • A logikai bizonyítványtárolók szerinti megjelenítési mód használata esetén kattintson a Személyes elemre.
    • A bizonyítvány célja szerinti megjelenítési mód használata esetén a kattintson a kívánt célnak megfelelő módra.
  4. A Bizonyítványigénylő varázsló elindításához a Művelet menüben mutasson a Feladatok pontra, majd kattintson az Új bizonyítvány igénylése parancsra.
  5. A Bizonyítványigénylő varázslóban adja meg az alábbi adatokat:
    • Az igényelni kívánt bizonyítvány típusát.
    • (A Speciális beállítások választása esetén) A használt titkosításszolgáltatót (CSP).
    • (A Speciális beállítások választása esetén) Engedélyezhető a személyes kulcs erős védelme. A személyes kulcs erős védelemének engedélyezése esetén a személyes kulcs használatához mindig jelszót kell megadni. Ez akkor hasznos, ha biztos akar lenni abban, hogy tudtán kívül nem használható a személyes kulcsa.
    • (A Speciális beállítások választása esetén) Ha egynél több hitelesítő szervezet érhető el, akkor a bizonyítványt kiadó hitelesítő szervezet nevét.
    • Az új bizonyítvány rövid nevét.
  6. Kattintson a Bizonyítvány telepítése gombra, ha a Bizonyítványigénylő varázsló sikeresen befejezte a műveletet.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • A fenti művelettel csak vállalati hitelesítő szervezettől igényelhető bizonyítvány. Ha különálló hitelesítő szervezettől akar bizonyítványt kérni, akkor azt csak weblapokon keresztül teheti meg. A Windows 2000 hitelesítő szervezet weblapja a http://kiszolgáló_neve/certsrv címen található, ahol a kiszolgáló_neve a hitelesítő szervezetet működtető Windows 2000 kiszolgáló neve.
  • A vállalati hitelesítő szervezettől digitális aláírás szabvány (DSS) szerinti bizonyítvány igényléséhez a Bizonyítványigénylő varázslóban válassza ki a Csak felhasználói aláírás bizonyítványsablont.


Bizonyítvány megújítása ugyanazzal a kulccsal.

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. A konzolfa Személyes eleme alatt kattintson a Bizonyítványok elemre.

    Helye:

    • Bizonyítványok – Bizonyítványtulajdonos
    • Személyes
    • Bizonyítványok
  3. A részletek ablaktáblán kattintson ahhoz a nyilvános kulcshoz tartozó bizonyítványra, amely nyilvános kulcshoz új bizonyítványt akar rendelni.
  4. A Bizonyítványigénylő varázsló elindításához a Művelet menüben mutasson az Feladatok pontra, majd kattintson a Bizonyítvány igénylése új kulccsal parancsra.
  5. A Bizonyítványigénylő varázslóban adja meg az alábbi adatokat:
    • Az igényelni kívánt bizonyítvány típusát.
    • (A Speciális beállítások választása esetén) Ha egynél több hitelesítő szervezet érhető el, akkor a bizonyítványt kiadó hitelesítő szervezet nevét.
    • Az új bizonyítvány rövid nevét.
  6. Kattintson a Bizonyítvány telepítése gombra, ha a Bizonyítványigénylő varázsló sikeresen befejezte a műveletet.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • A művelet végrehajtásához a logikai bizonyítványtárolók szerinti megjelenítési módot kell beállítani. Tanulmányozza a Kapcsolódó témakörökben.
  • A fenti művelettel csak vállalati hitelesítő szervezettől igényelhető bizonyítványt. Különálló hitelesítő szervezettől csak weblapokon keresztül igényelhető bizonyítvány. A Windows 2000 hitelesítő szervezet weblapja a http://kiszolgáló_neve/certsrv címen található, ahol a kiszolgáló_neve a hitelesítő szervezetet működtető Windows 2000 kiszolgáló neve.


Felhasználói fiók bizonyítványainak kezelése

  1. Kattintson a Start menüre, a Futtatás parancsra, írja be az mmc parancsot, majd kattintson az OK gombra.
  2. Kattintson a Konzol menü Beépülő modul hozzáadása/eltávolítása parancsára, majd a Hozzáadás gombra.
  3. A Beépülő modul oszlopban kattintson duplán a Bizonyítványok elemre, majd hajtsa végre az alábbiakat:
    • Ha rendszergazdaként jelentkezett be, kattintson a Saját felhasználói fiókom választógombra, majd a Befejezés gombra.
    • Ha felhasználóként jelentkezett be, akkor a rendszer automatikusan betölti a Bizonyítványok beépülő modult.
  4. Kattintson a Bezárás gombra.

    Az új konzolhoz kiválasztott beépülő modulok listájában megjelenik a Bizonyítványok – Aktuális felhasználó elem.

  5. Ha már nem akar több beépülő modult hozzáadni a konzolhoz, kattintson az OK gombra.
  6. A konzol mentéséhez kattintson a Konzol menü Mentés parancsára.

Megjegyzések

  • A felhasználói fiókhoz, a számítógéphez és a szolgáltatáshoz tartozó bizonyítványok felváltva történő kezeléséhez a Bizonyítványok több példányát kell a konzolhoz hozzáadni.
  • Az MMC-konzol létrehozásával és használatával kapcsolatos további tudnivalókért kattintson a Súgó menü Témakörök parancsára.


Archivált bizonyítványok megjelenítése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Kattintson a Bizonyítványok - bizonyítványtulajdonos elemre, ahol a bizonyítványtulajdonos a bizonyítvány egy (adott felhasználóhoz, számítógéphez vagy szolgáltatáshoz tartozó) példányát jelöli.
  3. Kattintson a Nézet menü Beállítások parancsára.
  4. A következők megjelenítése alatt jelölje be az Archivált bizonyítványok jelölőnégyzetet.

Megjegyzés

  • Az archivált bizonyítványok azok a bizonyítványok, amelyek érvényessége lejárt vagy érvényességét megújították. Általában ajánlatos törlésük helyett az archivált bizonyítványokat megtartani. Például szükség lehet egy archivált bizonyítványra egy nemrég lejárt vagy megújított bizonyítvány kulcsával aláírt dokumentum digitális aláírásának ellenőrzéséhez.
  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.


Bizonyítvány megtekintése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Hajtsa végre az alábbi művelek egyikét:
    • A logikai bizonyítványtárolók szerinti megjelenítési mód használata esetén kattintson a konzolfa Bizonyítványok elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Logikai tároló
      • Bizonyítványok
    • A bizonyítvány célja szerinti megjelenítési mód használata esetén a kattintson a konzolfa Cél elemére.

      Helye:

      • Bizonyítványok – Bizonyítványtulajdonos
      • Cél
  3. A részletek ablaktáblában kattintson duplán a bizonyítványra.

Megjegyzések

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.
  • Bizonyítvány adatainak a megtekintéséhez a jobb oldali egérgombbal kattintson a bizonyítványra, majd kattintson a Megnyitás parancsra.


Bizonyítványtároló tárolási struktúrájának megjelenítése

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Kattintson a Bizonyítványok - bizonyítványtulajdonos elemre, ahol a bizonyítványtulajdonos a bizonyítvány egy (adott felhasználóhoz, számítógéphez vagy szolgáltatáshoz tartozó) példányát jelöli.
  3. Kattintson a Nézet menü Beállítások parancsára.
  4. A Megjelenítési mód szervezése csoportban kattintson a Logikai bizonyítványtárolók szerint választógombra.
  5. A következők megjelenítése alatt jelölje be a Fizikai bizonyítványtárolók jelölőnégyzetet.

Megjegyzések

  • A bizonyítványtárolók tárolási struktúrájának megjelenítése csak tapasztalt felhasználók és fejlesztők számára javasolt.
  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.


Bizonyítványtároló megjelenítése cél módban

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Kattintson a Bizonyítványok - bizonyítványtulajdonos elemre, ahol a bizonyítványtulajdonos a bizonyítvány egy (adott felhasználóhoz, számítógéphez vagy szolgáltatáshoz tartozó) példányát jelöli.
  3. Kattintson a Nézet menü Beállítások parancsára.
  4. A Megjelenítési mód szervezése csoportban kattintson a Bizonyítvány célja szerint választógombra.

Megjegyzés

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.


PKCS #7 fájlban tárolt bizonyítványok megtekintése

  1. Nyissa meg a Windows Intéző alkalmazást.
  2. Keresse meg a PKCS #7 fájlt, amelynek bizonyítványait meg szeretné tekinteni.
  3. A jobb oldali egérgombbal kattintson a PKCS #7 fájlra, majd kattintson a Megnyitás parancsra. A rendszer betölti a bizonyítványokat.
  4. Kattintson a Bizonyítványok – fájl elemre, a fájlnévre, majd a Bizonyítványok elemre. A részletek ablaktáblában megjelennek a PKCS #7 fájlban tárolt bizonyítványok.

Megjegyzések

  • A Windows Intéző megnyitásához a jobb oldali egérgombbal kattintson a Start gombra, majd kattintson az Intéző parancsra.
  • A PKCS #7 fájlok kiterjesztése általában .p7b, de más is lehet. Mint minden adatfájl esetén, a fájl létrehozója szabadon megválaszthatja a fájl nevét és kiterjesztését.
  • A PKCS #7 fájlok importálásával és exportálásával kapcsolatban tanulmányozza a Kapcsolódó témaköröket.


Bizonyítványtárolók megjelenítése logikai tároló módban

  1. Nyisson meg egy bizonyítványokat tartalmazó MMC-konzolt.
  2. Kattintson a Bizonyítványok - bizonyítványtulajdonos elemre, ahol a bizonyítványtulajdonos a bizonyítvány egy (adott felhasználóhoz, számítógéphez vagy szolgáltatáshoz tartozó) példányát jelöli.
  3. Kattintson a Nézet menü Beállítások parancsára.
  4. A Megjelenítési mód szervezése csoportban kattintson a Logikai bizonyítványtárolók szerint választógombra.

Megjegyzés

  • Ha még nem hozott létre bizonyítványokat tartalmazó MMC-konzolt, tanulmányozza a Kapcsolódó témaköröket.


Bizonyítvány megújítása

Minden bizonyítványhoz érvényességi időtartam tartozik. Az érvényességi időtartam lejárta után a bizonyítvány nem tekinthető elfogadható vagy használható igazolásnak. A Bizonyítványmegújító varázsló révén a Bizonyítványok beépülő modul lehetővé teszi a Windows 2000 hitelesítő szervezet által kiadott bizonyítványok megújítását az érvényességi időtartam lejárta előtt.

A bizonyítvány megújítható az eddig használt vagy akár új kulcskészlettel is. Ha további információra van szüksége azzal kapcsolatban, hogy javasolt-e új kulcskészlet létrehozása, vagy elegendő a régi kulcskészlet újbóli kiadása, akkor tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.

A bizonyítvány megújításához a következőket kell ismernie:

  • A kibocsátó hitelesítő szervezetet.
  • (Nem kötelező) Új nyilvános kulcs és személyes kulcs igényléséhez a kulcspár létrehozásához szükséges titkosításszolgáltatót (CSP).

Tanulmányozza még:

  • Bizonyítvány megújítása új kulccsal
  • Bizonyítvány megújítása ugyanazzal a kulccsal

Ezenkívül a Windows 2000 vállalati hitelesítő szervezet és a Windows 2000 különálló hitelesítő szervezet által kiadott bizonyítványok a Bizonyítványszolgáltatások weblapon is megújíthatók a PKCS #7 fájl tartalmának beillesztésével. További tudnivalókért tanulmányozza a Bizonyítvány igénylése PKCS #10 vagy PKCS #7 fájl segítségével című témakört.


Bizonyítvány igénylése

A bizonyítvány iránti kérelmet annak a személynek, számítógépnek vagy szolgáltatásnak kell kezdeményeznie, amely hozzáférhet a kiadandó bizonyítványnak majd részét képező nyilvános kulcshoz tartozó személyes kulcshoz. A rendszergazda által meghatározott nyilvánoskulcs-irányelvektől függően a számítógépek és a szolgáltatások felhasználói beavatkozás nélkül, automatikusan is igényelhetnek bizonyítványokat. Ezenkívül a rendszergazdák más felhasználó nevében, a másik felhasználó beiktatóügynök-bizonyítványának felhasználásával a rendszerbe történő bejelentkezéshez igényelhetnek intelligens kártya felhasználói bizonyítványokat és intelligens kártya bizonyítványokat.

A Windows 2000 rendszerben kétféleképpen lehet explicit módon bizonyítványt kérelmezni.

A Bizonyítványigénylő varázsló segítségével

A bizonyítvány Windows 2000 vállalati hitelesítő szervezettől történő igényléséhez használható a Bizonyítványok beépülő modulban található Bizonyítványigénylő varázsló. A varázsló végigvezeti a következő lépéseken:

  • Annak a hitelesítő szervezetnek a kiválasztása, amelynek a kérelmet küldi.

    Csak a felhasználó által használt Windows tartományban elérhető vállalati hitelesítő szervezetek képesek bizonyítványt kibocsátani a Bizonyítványigénylő varázsló segítségével.

  • Az új bizonyítványhoz használni kívánt bizonyítványsablon kiválasztása.

    A bizonyítványsablonok a bizonyítványigénylés általános beállításait tartalmazzák. A bizonyítványsablonok leírják a kért bizonyítvány használatának a célját. A használható bizonyítványsablonok listája a hitelesítő szervezet által kibocsátható bizonyítványtípusoktól és a rendszergazda által a bizonyítványsablon eléréséhez biztosított hozzáférési engedélytől függ.

  • (Nem kötelező) A Bizonyítványigénylő varázsló Speciális beállítások lehetőségének segítségével választható ki a bizonyítványigényléshez rendelt kulcspárhoz tartozó titkosításszolgáltató.

A Bizonyítványigénylő varázsló használata esetén csak az Alapvető EFS (titkosító fájlrendszer) és az EFS-helyreállítási megbízott bizonyítványaihoz tartozó személyes kulcsok exportálhatók. Ha más típusú bizonyítványt akar igényelni, és ki tudja exportálni annak személyes kulcsát egy PKCS #12 fájlba, akkor használja a Windows 2000 Bizonyítványszolgáltatások webhely Speciális kérelem oldalát.

A Bizonyítványigénylő varázsló megnyitásával és használatával kapcsolatos tudnivalókért tanulmányozza a Bizonyítvány igénylése című témakört.

A Bizonyítványigénylő varázslót akkor is használhatja, ha egy vállalati hitelesítő szervezettől új bizonyítványt kér olyan létező kulcspárral, amely már más bizonyítványhoz tartozik. A Bizonyítványigénylő varázslót akkor is használhatja, ha egy vállalati hitelesítő szervezettől új bizonyítványt kér olyan létező kulcspárral, amely már más bizonyítványhoz tartozik. Lásd: Bizonyítvány igénylése ugyanazzal a kulccsal.

Bizonyítvány igénylése a Windows 2000 Bizonyítványszolgáltatások weblapok használatával

Minden Windows 2000 kiszolgálóra telepített hitelesítő szervezet rendelkezik olyan weblappal, ahonnan a felhasználók alapvető és speciális bizonyítványigényléseket küldhetnek. Alapértelmezés szerint ezek a lapok a http://kiszolgáló_neve/certsrv helyen találhatók, ahol a kiszolgáló_neve a hitelesítő szervezetnek helyt adó Windows 2000 kiszolgáló neve.

Egy Windows 2000 különálló hitelesítő szervezettől történő bizonyítványigénylés esetén a Bizonyítványszolgáltatások weblapot kell használni. A weblapok Windows 2000 vállalati hitelesítő szervezetektől történő bizonyítványkérelmekre is használhatók, ha a Bizonyítványigénylő varázslóban nem elérhető beállításokat akar használni, mint például a kulcsok megjelölése exportálhatóként, az ujjlenyomat algoritmusának kiválasztása vagy az igénylés mentése egy PKCS #10 fájlba.

A Bizonyítványszolgáltatások weblapokkal kapcsolatos további tudnivalókért tanulmányozza a Windows 2000 Bizonyítványszolgáltatások weblap használata című témakört.

A bizonyítványkérelmek feldolgozása

A Windows 2000 vállalati hitelesítő szervezetnek elküldött bizonyítványkérelmet a hitelesítő szervezet azonnal feldolgozza, és nem helyezi “folyamatban van” állapotba. A bizonyítványkérelem azonnal sikertelen vagy sikeres. Ha sikeres, a hitelesítő szervezet kibocsátja a bizonyítványt, és a telepítésére vonatkozó üzenet jelenik meg.

A különálló Windows 2000 hitelesítő szervezetnek elküldött bizonyítványkérelmet a hitelesítő szervezet azonnal feldolgozza, vagy alapértelmezés szerint folyamatban levőnek minősíti addig, amíg a hitelesítő szervezet rendszergazdája el nem fogadja, vagy vissza nem utasítja. Folyamatban lévő kérelem esetén a bizonyítvány igénylőjének a Bizonyítványszolgáltatások weblapon kell ellenőriznie a folyamatban lévő bizonyítványok állapotát. Lásd: Folyamatban lévő bizonyítványkérelmek ellenőrzése.

A bizonyítványokkal és a hitelesítő szervezetekkel kapcsolatos további tudnivalókért tanulmányozza a Bizonyítványok és hitelesítő szervezetek című témakört.


Digitális aláírások

A digitális aláírás az adatok integritásának és eredetének ellenőrzésének egy módja. A digitális aláírás bizonyíték arra, hogy az aláírás óta az adatok nem módosultak, és azonosítja az adatokat aláíró természetes vagy jogi személyt. Ez lehetővé tesz olyan fontos biztonsági szolgáltatásokat, mint az integritás és letagadhatatlanság, amelyek nélkülözhetetlenek a biztonságos elektronikus kereskedelemhez.

A digitális aláírás általában az adatok egyszerű szövegként vagy nem titkosított formában történő továbbításakor használatos. Ilyenkor az adatok érzékenysége ugyan nem igényelné a titkosítást, viszont lehet olyan ok, ami miatt meg kell győződni arról, hogy az adatok eredeti formájukban érkeztek meg, és nem egy szélhámos küldte. Elosztott hálózati környezetben ugyanis az egyszerű szöveget a hálózaton – jogosultan vagy jogosulatlanul – bárki elolvashatja vagy módosíthatja, aki megfelelő engedélyekkel rendelkezik.

A digitális aláírással és a bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.


Bizonyítványok – áttekintés

A Bizonyítványok beépülő modul a felhasználók, számítógépek vagy szolgáltatások bizonyítványainak kezelésére használható. A bizonyítványok nem biztonságos hálózatokon (például az Interneten) továbbított adatok hitelesítésére és védelmére használható fájlok.

A felhasználók és a rendszergazdák a Bizonyítványok beépülő modul segítségével igényelhetnek új bizonyítványokat a hitelesítő szervezetektől. A felhasználók ezenkívül a bizonyítványtárolókból kereshetik, nézhetik meg, importálhatják és exportálhatják a bizonyítványokat. A legtöbb esetben azonban a felhasználóknak nem kell személyesen kezelniük a bizonyítványaikat és a bizonyítványtárolóikat. Ideális esetben ezt elvégezhetik a rendszergazdák, a házirend-beállítások, valamint minden bizonyítványokat használó alkalmazás és szolgáltatás.

A Bizonyítványok beépülő modul elsődleges felhasználói a rendszergazdák. A rendszergazdák feladatukból adódóan a bizonyítványkezelő feladatok széles körét végezhetik a személyes bizonyítványtárolójukban, valamint minden olyan számítógép vagy szolgáltatás bizonyítványtárolójában, amelyhez megfelelő engedélyekkel rendelkeznek.

Ha a bizonyítványokkal és a kezelésükkel kapcsolatban háttérismeretekre, vagy egy adott művelettel kapcsolatban segítségre van szüksége, a tartalomjegyzékben kattintson duplán a megfelelő könyvre, majd kattintson valamelyik bejegyzésre a hozzá tartozó témakör megjelenítéséhez.

A bizonyítványokkal kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Bizonyítványtárolók

A Windows 2000 a bizonyítványt helyileg tárolja, a bizonyítványt igénylő számítógépen vagy eszközön, illetve felhasználó esetén a bizonyítványkérelem elküldéséhez használt számítógépen vagy eszközön. A tárolás helyének a neve: bizonyítványtároló. A bizonyítványtárolóban általában több bizonyítvány található, amelyeket esetleg több különböző hitelesítő szervezet bocsátott ki.

A Bizonyítványok beépülő modul segítségével kibocsátási cél vagy logikai tárolókategóriák szerint csoportosítva jeleníthető meg a felhasználó, számítógép vagy szolgáltatás bizonyítványtárolója. A bizonyítványok tárolókategóriák szerinti megjelenítésekor megjeleníthetők a fizikai tárolók is, így láthatóvá válik a bizonyítványtároló hierarchiája. (Ez csak tapasztalt felhasználók számára javasolt.)

Ha a megfelelő felhasználói engedélyekkel rendelkezik, akkor a bizonyítványtároló bármely mappájából exportálhat vagy importálhat bizonyítványokat. Ezenkívül ha a bizonyítványhoz tartozó személyes kulcsot exportálhatóként jelölték meg, akkor mindkettő exportálható PKCS #12 fájlba.

A Windows közzé is tudja tenni a bizonyítványokat az Active Directory címtárban. A bizonyítvány Active Directory címtárba történő közzététele esetén minden megfelelő engedéllyel rendelkező felhasználó és számítógép szükség esetén letöltheti a bizonyítványt.

Az alábbi táblázatban bemutatott módon a bizonyítványok megjeleníthetők céljuk vagy logikai tárolójuk szerint. A Bizonyítványok beépülő modul alapértelmezésben logikai tárlók szerint jeleníti meg a bizonyítványokat. (Megjegyzés: a bizonyítványcél-tárolók lista nem tartalmaz minden lehetséges cél-tárolót.)

Megjelenítés | Mappa neve | Tartalom
Logikai tárolók szerint | Személyes | Azokhoz a személyes kulcsokhoz tartozó bizonyítványok, amelyekhez hozzáféréssel rendelkezik.
 | Megbízható legfelső szintű hitelesítő szervezetek | Közvetetten megbízható hitelesítő szervezetek.
 | Vállalati szintű megbízás | A megbízható bizonyítványok listájának tárolója. A megbízható bizonyítványok listája lehetővé teszi a más szervezetektől származó, saját magával aláírt legfelső szintű bizonyítványokban való megbízást, és azoknak a céloknak a korlátozását, amelyekre ezek a bizonyítványok felhasználhatók.
 | Közbenső szintű hitelesítő szervezetek | Más személyeknek és más hitelesítő szervezeteknek kibocsátott bizonyítványok.
 | Active Directory - felhasználóobjektum | A felhasználóobjektumhoz tartozó, és az Active Directory-ban közzétett bizonyítványok.
 | IGÉNYLÉS | Folyamatban lévő vagy visszautasított bizonyítványkérelmek.
Cél | Kiszolgáló hitelesítése | Azok a bizonyítványok, amelyekkel a kiszolgálóprogramok saját magukat hitelesítik az ügyfelek felé.
 | Ügyfél hitelesítése | Azok a bizonyítványok, amelyekkel az ügyfélprogramok saját magukat hitelesítik a kiszolgálók felé.
 | Kód aláírása | Az aktív tartalom aláírásához használt kulcspárokhoz tartozó bizonyítványok.
 | Biztonságos elektronikus levelezés | Az elektronikus üzenetek aláírásához használt kulcspárokhoz tartozó bizonyítványok.
 | Titkosító fájlrendszer | A titkosító fájlrendszer által adatok titkosításához és visszafejtéséhez alkalmazott szimmetrikus kulcs titkosítására és visszafejtésére használt kulcspárokhoz tartozó bizonyítványok.
 | Fájl helyreállítása | A titkosító fájlrendszer által titkosított adatok helyreállításához használt szimmetrikus kulcs titkosítására és visszafejtésére használt kulcspárokhoz tartozó bizonyítványok.
Tanulmányozza még:
  • Titkosító kulcsok és bizonyítványkérelmek létrehozása
  • Bizonyítvány importálása és exportálása
  • Bizonyítványtároló megjelenítése cél módban
  • Bizonyítványtárolók megjelenítése logikai tároló módban
  • Archivált bizonyítványok megjelenítése
  • Bizonyítványtároló tárolási struktúrájának megjelenítése


Bizonyítvány adatainak megjelenítése

Ha a Bizonyítványok beépülő modulban duplán kattint a bizonyítványtárolóban látható bármely bizonyítványra, akkor megjeleníthetők a kibocsátott bizonyítványt felépítő mezők, kiterjesztések és tulajdonságok.

Ehhez | Tanulmányozza az alábbiakat
Bizonyítvány adatai – áttekintés | Általános lap
A bizonyítvány felhasználási módjai | Általános lap
A személy, akinek a bizonyítványt kibocsátották | Általános lap
A bizonyítvány érvényességi időtartama | Általános lap
A bizonyítvány elérési útvonala egy megbízható legfelső szintű hitelesítő szervezethez | Bizonyítványlánc lap
Gyökérbizonyítvány | Bizonyítványlánc lap
Alsóbb szintű hitelesítő szervezet bizonyítványai | Bizonyítványlánc lap
Megbízható-e a legfelső szintű hitelesítő szervezet | Bizonyítványlánc lap
Bizonyítvány állapota | Bizonyítványlánc lap

A Részletek párbeszédpanelen a bizonyítvány alábbi adatai láthatók:

Bizonyítvány mező | Leírás
Verzió | Az X.509-es verziószám.
Sorozatszám | Az egyedi sorozatszám, amelyet a kibocsátó hitelesítő szervezet rendel a bizonyítványhoz. Az adott hitelesítő szervezet által kiállított valamennyi bizonyítvány egyedi sorozatszámmal rendelkezik.
Aláírási algoritmus | A hitelesítő szervezet által a bizonyítvány digitális aláírásához használt ujjlenyomat algoritmus.
Kibocsátó | A bizonyítványt kibocsátó hitelesítő szervezet adatai.
Érvényesség kezdete | A bizonyítvány érvényességi időtartamának kezdődátuma.
Érvényesség vége | A bizonyítvány érvényességi időtartamának lejárati dátuma.
Tulajdonos | Annak a személynek vagy hitelesítő szervezetnek a neve, amelynek a bizonyítványt kibocsátották. Ha a kibocsátó hitelesítő szervezet a szervezeten belül működő tartományhoz kapcsolódó tagkiszolgálón található, akkor a szervezeten belül ez egy egyedi, megkülönböztető név. Ellenkező esetben ez a teljes név és elektronikus levélcím, vagy valamilyen más személyes azonosító.
Nyilvános kulcs | A bizonyítványhoz tartozó kulcs típusa és hossza.
Ujjlenyomat-algoritmus | A digitális aláírásokhoz az adatkivonatot (vagy ujjlenyomatot) létrehozó ujjlenyomat algoritmus.
Ujjlenyomat | A bizonyítvány adatainak kivonata (vagy ujjlenyomat).
Rövid név | (Választható) A Tulajdonos mezőben található név helyett használt rövid, egyszerű név.
Kibővített kulcshasználat | (Választható) Azok a célok, amelyekre a bizonyítvány felhasználható.

A bizonyítványban további X.509v3 kiterjesztések is lehetnek. Ebben az esetben azok is megjelennek.

A bizonyítvány tulajdonságainak megjelenítésével kapcsolatos további tudnivalókért tanulmányozza a Bizonyítvány megtekintése című témakört.


A Windows 2000 Bizonyítványszolgáltatások weblap használata

Alapértelmezés szerint minden Windows 2000 operációs rendszert futtató kiszolgálón működő hitelesítő szervezet rendelkezik olyan weblapokkal, amelyeket a felhasználók és rendszergazdák számos bizonyítványigényléssel kapcsolatos művelet során használhatnak. Ezek a weblapok a http://kiszolgáló_neve/certsrv címen találhatók, ahol a kiszolgáló_neve a hitelesítő szervezetet futtató Windows 2000 kiszolgáló neve. Az URL certsrv részét mindig kisbetűvel kell írni, különben a felhasználóknak gondot okozhat a folyamatban levő hitelességi bizonyítványok ellenőrzése és letöltése. Ezek a weblapok a Microsoft Internet Explorer 4.0 vagy újabb verziójú, illetve a Netscape Navigator 3.01 vagy újabb verziójú webböngészővel érhetők el.

Különálló hitelesítő szervezetektől kizárólag a weblapokon keresztül igényelhetők bizonyítványok. Vállalati hitelesítő szervezettől így is igényelhető bizonyítvány. A hitelesítő szervezetekkel kapcsolatos további tudnivalókért tanulmányozza a Bizonyítványok és hitelesítő szervezetek című témakört.

Ha megfelelő engedélyekkel rendelkezik, akkor a következő műveletek hajthatók végre ezeken a weblapokon:

  • Alapszintű bizonyítvány kérése. Tanulmányozza a Felhasználói bizonyítványkérelem elküldése a Weben keresztül című témakört.
  • Bizonyítvány igénylése speciális beállításokkal. Tanulmányozza a Speciális bizonyítványkérelem elküldése a Weben keresztül című témakört.

    Így részletesebben adható meg a bizonyítványkérelem. A speciális bizonyítványigénylés során a felhasználó által kiválasztható néhány beállítás:

    • Titkosításszolgáltató (CSP) beállításai. A titkosításszolgáltató neve, a kulcs mérete (512, 1024 stb.), az ujjlenyomat-algoritmus (SHA/RSA, SHA/DSA, MD2, MD5) és a kulcs beállítása (csere vagy aláírás).
    • Kulcslétrehozási lehetőségek. Új kulcskészlet létrehozása vagy egy létező kulcskészlet használata, kulcs megjelölése exportálhatóként, erős kulcsvédelem engedélyezése, valamint a kulcs létrehozása és tárolása a helyi számítógépen.
    • Egyéb beállítások. A kérelem mentése PKCS #10 fájlba, vagy további attribútumok hozzáadása a bizonyítványhoz.

    Netscape ügyfélprogrammal nem használhatók a speciális beállítások megadására szolgáló weblapok.

  • Várakozó bizonyítványkérelem ellenőrzése

    Különálló hitelesítő szervezetnek elküldött bizonyítványkérelmek esetén ellenőrizni kell a folyamatban levő kérelem állapotát, hogy a hitelesítő szervezet kibocsátotta-e már a bizonyítványt. Ha igen, akkor az letölthető és telepíthető.

  • A hitelesítő szervezet bizonyítványának letöltése és elhelyezése a megbízható gyökértárolóba. Tanulmányozza a Hitelesítő szervezet bizonyítványának letöltése című témakört.
  • Visszavont bizonyítványok aktuális listájának letöltése. Tanulmányozza a Visszavont bizonyítványok listájának letöltése című témakört.
  • Bizonyítványkérelem elküldése PKCS #10 vagy PKCS #7 fájlban. Tanulmányozza a Bizonyítvány igénylése PKCS #10 vagy PKCS #7 fájl segítségével című témakört.
  • (Csak rendszergazdák részére) Bizonyítvány igénylése intelligens kártyához más felhasználó részére. Tanulmányozza a Intelligens kártya beállítása felhasználó bejelentkezéséhez című témakört.


Bizonyítványkérelem mentése PKCS #10 fájlba

  1. Nyissa meg az Internet Explorer alkalmazást.
  2. Az Internet Explorer programban nyissa meg a http://kiszolgáló_neve/certsrv weblapot, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet található.
  3. Kattintson Bizonyítvány kérése hivatkozásra, majd a Tovább gombra.
  4. Kattintson a Speciális kérelem, majd a Tovább elemre.
  5. Kattintson a Bizonyítványkérelem küldése a CA-nak űrlap használatával, majd a tovább Tovább elemre.
  6. Adja meg a kért azonosító adatokat, és az egyéb szükséges beállításokat.
  7. A További beállítások részen válassza ki a Mentés PKCS #10 fájlba lehetőséget.
  8. A Fájlnév mezőbe írja be a fájl nevét.
  9. Kattintson a Küldés gombra. A rendszer az Asztalra menti a fájlt.
  10. A Bizonyítványszolgáltatások weblap használatának befejezése után zárja be az Internet Explorer programot.

Megjegyzés

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.


Várakozó bizonyítványkérelem ellenőrzése

  1. Nyissa meg az Internet Explorer alkalmazást.
  2. Az Internet Explorer programban nyissa meg a http://kiszolgáló_neve/certsrv weblapot, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet található.
  3. Kattintson a Várakozó bizonyítvány ellenőrzése elemre, majd a Tovább gombra.
  4. Tájékoztató üzenet jelenik meg, ha nincs függőben lévő bizonyítvány. Egyébként válassza ki az ellenőrizni kívánt bizonyítványkérelmet, és kattintson a Tovább gombra.
  5. A várakozó bizonyítványkérelmek ellenőrzése:
    • Folyamatban van. Meg kell várnia, amíg a hitelesítő szervezet rendszergazdája ki nem adja a bizonyítványt. A bizonyítványkérelem törléséhez kattintson az Eltávolítás gombra.
    • Kibocsátva. A bizonyítvány telepítéséhez kattintson a Bizonyítvány telepítése gombra.
    • Megtagadva. További részletekért vegye fel a kapcsolatot a hitelesítő szervezet rendszergazdájával.
  6. A Bizonyítványszolgáltatások weblap használatának befejezése után zárja be az Internet Explorer programot.

Megjegyzés

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.


Speciális bizonyítványkérelem elküldése Weben keresztül

  1. Nyissa meg az Internet Explorer alkalmazást.
  2. Az Internet Explorer programban nyissa meg a http://kiszolgáló_neve/certsrv oldalt, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet található.
  3. Kattintson Bizonyítvány kérése hivatkozásra, majd a Tovább gombra.
  4. Kattintson a Speciális kérelem, majd a Tovább elemre.
  5. Kattintson a Bizonyítványkérelem elküldése űrlap segítségével ennek a hitelesítő szervezetnek, majd a tovább Tovább gombra.
  6. Adja meg a kért azonosító adatokat és az egyéb szükséges beállításokat.
  7. Kattintson az Küldés gombra.
  8. Hajtsa végre az alábbi művelek egyikét:
    • A bizonyítvány folyamatban van című weblap megjelenése esetén a függőben levő bizonyítványok ellenőrzésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
    • Kattintson a Bizonyítvány telepítése elemre, ha A bizonyítvány kiadása megtörtént című weblap jelenik meg.
  9. A Bizonyítványszolgáltatások weblap használatának befejezése után zárja be az Internet Explorer programot.

Megjegyzések

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.
  • A Speciális bizonyítványkérelem weblapon minden kért bizonyítvány következő tuljadonságai állíthatók be:
    • A Bizonyítványsablon (vállalati hitelesítő szervezetektől) vagy a Kívánt célok (különálló hitelesítő szervezetektől) azt jelzi, hogy a bizonyítvány nyilvános kulcsa milyen alkalmazásokhoz használható, például ügyfélhitelesítéshez vagy elektronikus levélhez.
    • Titkosításszolgáltató (CSP)
    • Kulcs mérete. A bizonyítvány nyilvános kulcsának hossza bitben. Általában minél hosszabb a kulcs, annál biztonságosabb.
    • Ujjlenyomat-algoritmus
    • Kulcshasználat. A nyilvános kulcs lehetséges felhasználási módja. Az “Adatcsere” azt jelenti, hogy a nyilvános kulcs érzékeny adatok cseréjéhez használható. Az “Aláírás” azt jelenti, hogy a nyilvános kulcs csak digitális aláírás létrehozásához használható. A “Mindkettő” azt jelenti, hogy a kulcs az adatcsere és az aláírás funkcióhoz is használható.
    • Új kulcskészlet létrehozása vagy meglévő kulcskészlet használata. A bizonyítványhoz használható a számítógépen tárolt meglévő nyilvános és személyes kulcspár, vagy létrehozható új kulcspár. Ha további információra van szüksége azzal kapcsolatban, hogy javasolt-e új kulcs létrehozása, vagy elegendő a régi kulcs újbóli felhasználása, tanulmányozza a következő című témakört: Forrásmunkák: Nyilvános kulcsra épülő infrastruktúra.
    • Erős kulcsvédelem engedélyezése. A személyes kulcsok erős védelmének engedélyezése esetén a személyes kulcs használatához mindig jelszót kell megadni.
    • Kulcsok megjelölése exportálhatóként. Az exportálhatónak megjelölt kulcsok esetén a nyilvános és a személyes kulcs PKCS #12 fájlba menthető. Ez különösen hasznos, ha a számítógép cseréjekor a kulcspárt át akarja vinni az új gépre, vagy ha a kulcspárt el akarja távolítani, és máshol biztonságba helyezni.
    • A helyi számítógép tárolójának használata. Akkor válassza ezt a beállítást, ha a számítógépnek a bizonyítvány személyes kulcsához akkor is hozzá kell férnie, ha más felhasználó jelentkezett be. Abban az esetben is választhatja ezt a beállítást, ha számítógép (például webkiszolgáló), és nem személy számára igényel bizonyítványt.
    • Kérelem mentése PKCS #10 fájlba. Ez olyankor hasznos, ha a hitelesítő szervezet nem képes on-line feldolgozni a bizonyítványkérelmet. A bizonyítványok PKCS #10 fájl segítségével történő létrehozásával és elküldésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.


Hitelesítő szervezet bizonyítványának letöltése

  1. Nyissa meg az Internet Explorer alkalmazást.
  2. Az Internet Explorer programban nyissa meg a http://kiszolgáló_neve/certsrv oldalt, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet (CA) található.
  3. Kattintson a CA-bizonyítvány vagy visszavont bizonyítványok listájának lekérése elemre, majd a Tovább gombra.
  4. Hajtsa végre az alábbi művelek egyikét:
    • Ha meg akar bízni minden olyan bizonyítványban, amelyet ez a hitelesítő szervezet (CA) bocsátott ki, kattintson a CA-bizonyítványlánc telepítése elemre.
    • A hitelesítő szervezet megújítása esetén kiválasztható, hogy a hitelesítő szervezet bizonyítványának melyik verzióját akarja letölteni.
      • A Válassza ki a letöltendő fájlt mezőben kattintson a letölteni kívánt hitelesítő szervezet bizonyítványára, majd kattintson a CA-bizonyítvány letöltése gombra.
      • A Fájl letöltése részen válassza a Megnyitja a fájlt a jelenlegi helyről elemet, majd kattintson az OK gombra.
      • Amikor a Bizonyítvány párbeszédpanel megjelenik, kattintson a Bizonyítvány telepítése gombra.
      • A Bizonyítványimportáló varázslóban kattintson A bizonyítvány típusának megfelelő bizonyítványtároló automatikus választása választógombra.
  5. A Bizonyítványszolgáltatások weblap használatának befejezése után zárja be az Internet Explorer programot.

Megjegyzések

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.
  • A hitelesítő szervezet bizonyítványláncának telepítése beállítás kiválasztása akkor hasznos, ha egy alsóbb szintű hitelesítő szervezetben akar megbízni, de a bizonyítványtároló bizonyítványhierarchiájában a legfelső szintű hitelesítő szervezet bizonyítványával jelenleg még nem rendelkezik.


Felhasználói bizonyítványkérelem elküldése a Weben keresztül

  1. Nyissa meg az Internet Explorer alkalmazást.
  2. Az Internet Explorer programban nyissa meg a http://kiszolgáló_neve/certsrv oldalt, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet (CA) található.
  3. Kattintson a Bizonyítvány kérése hivatkozásra, majd a Tovább gombra.
  4. A Kérelemtípus kiválasztása weblap Felhasználói bizonyítványkérelem részén válassza ki az igényelni kívánt bizonyítvány típusát, majd kattintson a Tovább gombra.
  5. Az Azonosító adatok weblapon hajtsa végre az alábbi műveletek egyikét:
    • Amikor a “Már minden szükséges azonosító adat rendelkezésre áll. Elküldheti a kérelmet.” üzenet megjelenik, kattintson a Küldés gombra.
    • Adja meg a bizonyítványkérelemhez szükséges azonosító adatokat, majd kattintson az Küldés gombra.
  6. Hajtsa végre az alábbi művelek egyikét:
    • A bizonyítvány folyamatban van című weblap megjelenése esetén a függőben levő bizonyítványok ellenőrzésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
    • Kattintson a Bizonyítvány telepítése elemre, ha A bizonyítvány kiadása megtörtént című weblap jelenik meg.
  7. Ha befejezte a Bizonyítványszolgáltatások weblap használatát, zárja be az Internet Explorer programot.

Megjegyzés

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.


Visszavont bizonyítványok listájának letöltése

  1. Nyissa meg az Internet Explorer alkalmazást.
  2. Az Internet Explorer programban nyissa meg a http://kiszolgáló_neve/certsrv oldalt, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet (CA) található.
  3. Kattintson a Hitelesítő szervezet bizonyítványának vagy a visszavont bizonyítványok listájának (CRL) letöltése elemre, majd a Tovább gombra.
  4. Kattintson A visszavont bizonyítványok legújabb listájának letöltése elemre.
  5. Válassza a Lemezre menti választógombot, majd kattintson az OK gombra, amikor megjelenik a Fájl letöltése párbeszédpanel. Válassza ki a mappát, amelyben tárolni szeretné a .crl fájlt, majd kattintson a Mentés gombra.
  6. Nyissa meg a Windows Intézőt, és keresse meg az előbb mentett .crl fájlt.
  7. A jobb oldali egérgombbal kattintson a .crl fájlra, majd válassza a CRL telepítése parancsot.
  8. Amikor megnyílik a Bizonyítványimportáló varázsló, kattintson A bizonyítvány típusának megfelelő bizonyítványtároló automatikus választása választógombra.
  9. A Bizonyítványimportáló varázsló használatának befejezése után zárja be az Internet Explorer programot, ha már nincs szüksége a Bizonyítványszolgáltatások weblapra.

Megjegyzés

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.


Bizonyítvány igénylése PKCS #10 vagy PKCS #7 fájl segítségével

  1. Nyissa meg az Internet Explorer ablakot.
  2. Az Internet Explorer ablakban nyissa meg a http://kiszolgáló_neve/certsrv weblapot, ahol a kiszolgáló_neve annak a Windows 2000 kiszolgálónak a neve, ahol a használni kívánt hitelesítő szervezet (CA) található.
  3. Kattintson Bizonyítvány kérése hivatkozásra, majd a Tovább gombra. Kattintson a Speciális kérelem, majd a Tovább gombra.
  4. Kattintson Bizonyítványkérelem küldése a base64 kódolású PKCS #10 fájl használatával, vagy megújítási kérelem küldése base64 kódolású PKCS #7 fájl használatával elemre, majd a Tovább gombra.
  5. Hajtsa végre az alábbi művelek egyikét:
    • A Jegyzettömb segédprogramban kattintson a Fájl menü Megnyitás parancsára, válassza ki a PKCS #10 vagy PKCS #7 fájlt, kattintson a Szerkesztés menü Az összes kijelölése parancsára, majd a Szerkesztés menü Másolás parancsára. A weblapon kattintson a Mentett kérelem mezőbe. A bizonyítványkérelem tartalmának a mezőbe történő beillesztéséhez kattintson a Szerkesztés menü Beillesztés parancsára.
    • A bizonyítvány iránti kérelemhez használni kívánt fájl megkereséséhez kattintson a Tallózás gombra. Ha ActiveX-vezérlővel kapcsolatos figyelmeztetés jelenik meg, a futtatásához kattintson az Igen, majd a Tallózás gombra. A bizonyítványkérelemhez használni kívánt fájl megkeresése és kiválasztása után kattintson a Megnyitás gombra. A weblapon kattintson az Olvasás! gombra a fájl tartalmának a mezőbe való illesztéséhez. Olvassa el a Tallózás gomb használatával kapcsolatos megjegyzést.
  6. Ha vállalati hitelesítő szervezethez kapcsolódik, válassza ki a használni kívánt bizonyítványsablont.
  7. Kattintson a Küldés gombra.
  8. Hajtsa végre az alábbi művelek egyikét:
    • A Folyamatban levő bizonyítványok weblap megjelenése esetén a függőben levő bizonyítványok ellenőrzésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
    • Kattintson a Bizonyítvány letöltése gombra, ha a Bizonyítvány kiadva weblap jelenik meg. Mentse a fájlt a merevlemezre, majd importálja a bizonyítványt a bizonyítványtárolóba. A bizonyítvány importálásával kapcsolatban tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • Az Internet Explorer megnyitásához kattintson a Start menüre, mutasson a Programok pontra, majd kattintson az Internet Explorer parancsra.
  • A Jegyzettömb segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Kellékek pontra, végül kattintson a Jegyzettömb parancsra.
  • Általában a PKCS #10 fájl új bizonyítvány iránti kérelem elküldéséhez, míg a PKCS #7 fájlt egy már létező bizonyítvány megújítása iránti kérelem elküldéséhez használható. A kérelem fájlban történő elküldése akkor hasznos, ha a bizonyítvány kérelmezője nem tudja a kérelmet on-line módon elküldeni a hitelesítő szervezetnek.
  • A fájlok merevlemezen történő kereséséhez szükség lehet a http://kiszolgáló_neve oldalt megbízhatóként beállítani az Internet Explorer programban. A http://kiszolgáló_neve megbízható helyként való beállításához kattintson az Internet Explorer Eszközök menüjére, válassza az Internet beállítások parancsot, a Biztonság lapon mutasson a Megbízható helyek elemre, majd kattintson a Helyek gombra. Írja be a http://kiszolgáló_neve címet, majd kattintson az OK gombra.
  • Ha a kérelem elküldése után azonnal megjelenik egy üzenet, hogy a kérelmet annak ellenére is el akarja-e küldeni, hogy az nem tartalmaz “BEGIN” vagy “END” címkét, kattintson az OK gombra.
  • A bizonyítvány PKCS #7 fájlba történő exportálásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.