(Cím nélkül)

Kópiaütközés-megtekintő súgója

A Kópiaütközés-megtekintő segítséget nyújt az olyan ütközések megtekintéséhez és feloldásához, amelyek a kópiakészítési folyamat során az összeillesztéskor fordulhatnak elő. Akkor jön létre ütközés, amikor ugyanaz az adat egyszerre változik meg két különálló helyen, például a kiadónál és az előfizetőnél, vagy két különböző előfizetőnél. Kétféle ütközés léphet fel:

  • Frissítési és beszúrási ütközések, amikor ugyanaz az adat két helyen változik meg. Ekkor az egyik változás "győz", míg a másik "veszít".
  • Törlési ütközések, amikor ugyanaz a sor az egyik helyen törlődik, a másik helyen pedig megváltozik.

Az ilyen ütközések feloldását az a fontossági sorrend határozza meg, ami az előfizetés létrehozásakor be lett állítva, vagy azok a feloldási eljárások, amelyeket a felhasználó határozott meg. A Kópiaütközés-megtekintő lehetővé teszi, hogy megtekintsük, milyen módon lettek feloldva az ütközések, és változtassunk a feloldás módján.

Az alábbi táblázat a Kópiaütközés-megtekintő párbeszédpanelen rendelkezésre álló beállítási lehetőségeket és ezek szerepét mutatja be.

Megjegyzés

A megjelenő beállítási lehetőségek a bekövetkezett ütközés típusától függnek. Nem mindegyik beállítás jelenik meg mindegyik párbeszédpanelen. A dátumok nem a helyi formátumban, hanem ISO dátumidő formátumban jelennek meg.

Cél | Művelet
Ütközés oka | Megjeleníti azt az okot, ami miatt ütközés következett be, valamint azt a módot, ahogyan az ütközés fel lett oldva.
Csak az ütközéseket tartalmazó oszlop jelenjen meg | Megjeleníti a GUID (egyedi azonosító) oszlopot és csak azokat az oszlopokat, amelyek ütközéseket tartalmaznak.
Összes oszlop megjelenítése | Megjeleníti a sorban lévő összes oszlopot.
Meglévő adat megtartása | Elfogadja az ütközés jelenlegi feloldását.
Ellenőrzött adat megőrzése | Elfogadja az ütközés jelenlegi feloldását, de magába foglalja a szerkesztőmezőkben végzett módosításokat is.
Törölt adat megtartása | Elfogadja az ütközés jelenlegi feloldását, és az adatok törölve maradnak.
Ütközés kihagyása | Feloldottként jelöli meg az ütközést anélkül, hogy bármi megváltozna. Ez ellentmondást okoz, ezért az ütközést a lehető legrövidebb időn belül más módon fel kell oldani.
Felülírás az ütköző adattal | Megváltoztatja az ütközés előző feloldásának módját, és az ütköző adatokat jeleníti meg.
Felülírás a meglévő adattal | Megváltoztatja az ütközés előző feloldásának módját, és a meglévő adatokat jeleníti meg.
Felülírás az ellenőrzött adattal | Megváltoztatja az ütközés előző feloldásának módját a szerkesztőmezőkben végzett módosításoknak megfelelően, és a módosított adatokat jeleníti meg.
Adat törlése | Törli az oszlopokban megjelenített adatokat.
Az ütközés adatainak naplózása későbbi felhasználásra | Másolatot készít az ütközésről egy külön naplófájlba későbbi használat céljára. A naplót a Windows könyvtár\profiles\felhasználó\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log fájl tárolja.


(Cím nélkül)

Kópiaütközés-megtekintő súgója

A Kópiaütközés-megtekintő segítséget nyújt az olyan ütközések megtekintéséhez és feloldásához, amelyek a kópiakészítési folyamat során az összeillesztéskor fordulhatnak elő. Akkor jön létre ütközés, amikor ugyanaz az adat egyszerre változik meg két különálló helyen, például a kiadónál és az előfizetőnél, vagy két különböző előfizetőnél. Akkor is bekövetkezhetnek ütközések, ha az egyik helyen történt adatváltozások megsértik a másik helyen érvényes adatkorlátokat (divergens ütközés). Miután divergens ütközés lépett fel, a két helyen lévő adatok mindaddig nem egyeznek meg, amíg nem kerül sor az ütközés feloldására.

Az ilyen ütközések feloldását az a fontossági sorrend határozza meg, ami az előfizetés létrehozásakor be lett állítva, vagy azok a feloldási eljárások, amelyeket a felhasználó határozott meg. A Kópiaütközés-megtekintő lehetővé teszi, hogy megtekintsük, milyen módon lettek feloldva az ütközések, és változtassunk a feloldás módján.

Ha úgy döntünk, hogy figyelmen kívül hagyunk egy divergens ütközést, akkor az adatkorlátok közötti, eredendő ellentmondást a lehető legrövidebb időn belül meg kell szüntetni. Naplózzuk az ütközés részleteit, majd küldjük el a naplóbejegyzést a rendszergazdának. Ezt követően minden egyes helyen vizsgáljuk meg az adatok korlátait, és gondoskodjunk arról, hogy ezek mindenütt azonosak legyenek.

Az alábbi táblázat a Kópiaütközés-megtekintő párbeszédpanelen rendelkezésre álló beállítási lehetőségeket és ezek szerepét mutatja be.

Megjegyzés

A megjelenő beállítási lehetőségek a bekövetkezett ütközés típusától függnek. Nem mindegyik beállítás jelenik meg mindegyik párbeszédpanelen. A dátumok nem a helyi formátumban, hanem ISO dátumidő formátumban jelennek meg.

Cél | Művelet
Ütközés oka | Megjeleníti azt az okot, ami miatt ütközés következett be, valamint azt a módot, ahogyan az ütközés fel lett oldva.
Csak az ütközéseket tartalmazó oszlop jelenjen meg | Megjeleníti a GUID (egyedi azonosító) oszlopot és csak azokat az oszlopokat, amelyek ütközéseket tartalmaznak.
Összes oszlop megjelenítése | Megjeleníti a sorban lévő összes oszlopot.
Meglévő adat megtartása | Elfogadja az ütközés jelenlegi feloldását.
Ellenőrzött adat megőrzése | Elfogadja az ütközés jelenlegi feloldását, de magába foglalja a szerkesztőmezőkben végzett módosításokat is.
Törölt adat megtartása | Elfogadja az ütközés jelenlegi feloldását, és az adatok törölve maradnak.
Ütközés kihagyása | Feloldottként jelöli meg az ütközést anélkül, hogy bármi megváltozna. Ez ellentmondást okoz, ezért az ütközést a lehető legrövidebb időn belül más módon fel kell oldani.
Felülírás az ütköző adattal | Megváltoztatja az ütközés előző feloldásának módját, és az ütköző adatokat jeleníti meg.
Felülírás a meglévő adattal | Megváltoztatja az ütközés előző feloldásának módját, és a meglévő adatokat jeleníti meg.
Felülírás az ellenőrzött adattal | Megváltoztatja az ütközés előző feloldásának módját a szerkesztőmezőkben végzett módosításoknak megfelelően, és a módosított adatokat jeleníti meg.
Adat törlése | Törli az oszlopokban megjelenített adatokat.
Az ütközés adatainak naplózása későbbi felhasználásra | Másolatot készít az ütközésről egy külön naplófájlba későbbi használat céljára. A naplót a Windows könyvtár\profiles\felhasználó\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log fájl tárolja.


(Cím nélkül)

Kópiaütközés-megtekintő súgója

A Kópiaütközés-megtekintő segítséget nyújt az olyan ütközések megtekintéséhez és feloldásához, amelyek a kópiakészítési folyamat során az összeillesztéskor fordulhatnak elő. Akkor jön létre ütközés, amikor ugyanaz az adat egyszerre változik meg két különálló helyen. Kétféle ütközés léphet fel:

  • Frissítési és beszúrási ütközések, amikor ugyanaz az adat két helyen változik meg. Ekkor az egyik változás "győz", míg a másik "veszít". Ilyen ütközések esetén lehetőségünk van arra, hogy megtartsuk a meglévő adatokat (a győztes adatokat) vagy a meglévő adatokat felülírjuk a velük ütköző adatokkal (a vesztes adatokkal). Ha megtartjuk a meglévő adatokat, akkor azok megmaradnak a győztes kópiában, és a Microsoft Kópiaütközés-megtekintő felveszi őket abba a kópiába, amelyiknek a frissítési vagy beszúrási művelete kezdetben veszített. Ha a meglévő adatokat felülírjuk az ütközést kiváltó adatokkal, akkor a kópiák úgy változnak meg, hogy az eredetileg vesztes adatokat fogják tartalmazni.
  • Törlési ütközések, amikor ugyanaz a sor az egyik helyen törlődik, a másik helyen pedig megváltozik.

A Kópiaütközés-megtekintő lehetővé teszi, hogy megtekintsük, milyen módon lettek feloldva az ütközések, és változtassunk a feloldás módján.

Az alábbi táblázat a Kópiaütközés-megtekintő párbeszédpanelen rendelkezésre álló beállítási lehetőségeket és ezek szerepét mutatja be.

Megjegyzés

A megjelenő beállítási lehetőségek a bekövetkezett ütközés típusától függnek. Nem mindegyik beállítás jelenik meg mindegyik párbeszédpanelen. A dátumok nem a helyi formátumban, hanem ISO dátumidő formátumban jelennek meg.

Cél | Művelet
Ütközés oka | Megjeleníti azt az okot, ami miatt ütközés következett be, valamint azt a módot, ahogyan az ütközés fel lett oldva.
Csak az ütközéseket tartalmazó mező jelenjen meg | Megjeleníti a GUID (egyedi azonosító) oszlopot és csak azokat a mezőket, amelyek ütközéseket tartalmaznak.
Összes mező megjelenítése | Megjeleníti a rekord összes mezőjét.
Meglévő adat megtartása | Elfogadja az ütközés jelenlegi feloldását.
Ellenőrzött adat megőrzése | Elfogadja az ütközés jelenlegi feloldását, de magába foglalja a szerkesztőmezőkben végzett módosításokat is.
Törölt adat megtartása | Elfogadja az ütközés jelenlegi feloldását, és az adatok törölve maradnak.
Ütközés kihagyása | Feloldottként jelöli meg az ütközést anélkül, hogy bármi megváltozna. Ez ellentmondást okoz, ezért az ütközést a lehető legrövidebb időn belül más módon fel kell oldani.
Felülírás az ütköző adattal | Megváltoztatja az ütközés előző feloldásának módját, és az ütköző adatokat jeleníti meg.
Felülírás a meglévő adattal | Megváltoztatja az ütközés előző feloldásának módját, és a meglévő adatokat jeleníti meg.
Felülírás az ellenőrzött adattal | Megváltoztatja az ütközés előző feloldásának módját a szerkesztőmezőkben végzett módosításoknak megfelelően, és a módosított adatokat jeleníti meg.
Adat törlése | Törli a mezőkben megjelenített adatokat.
Az ütközés adatainak naplózása későbbi felhasználásra | Másolatot készít az ütközésről egy külön naplófájlba későbbi használat céljára. A naplót a Windows könyvtár\profiles\felhasználó\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log fájl tárolja.


(Cím nélkül)

Kópiaütközés-megtekintő súgója

A Kópiaütközés-megtekintő segítséget nyújt az olyan ütközések megtekintéséhez és feloldásához, amelyek a kópiakészítési folyamat során az összeillesztéskor fordulhatnak elő. Akkor jön létre ütközés, amikor ugyanaz az adat egyszerre változik meg két különálló helyen. Akkor is bekövetkezhetnek ütközések, ha az egyik helyen történt adatváltozások megsértik a másik helyen érvényes adatkorlátokat (divergens ütközés). Miután divergens ütközés lépett fel, a két helyen lévő adatok mindaddig nem egyeznek meg, amíg nem kerül sor az ütközés feloldására.

Az ilyen ütközések feloldását az a fontossági sorrend határozza meg, ami a kópia létrehozásakor be lett állítva, vagy azok a feloldási eljárások, amelyeket a felhasználó határozott meg. A Kópiaütközés-megtekintő lehetővé teszi, hogy megtekintsük, milyen módon lettek feloldva az ütközések, és változtassunk a feloldás módján.

Ha úgy döntünk, hogy figyelmen kívül hagyunk egy ütközést, akkor azt valamilyen más módon a lehető legrövidebb időn belül meg kell szüntetni. Naplózzuk az ütközés részleteit, majd küldjük el a naplóbejegyzést a rendszergazdának. Ezt követően minden egyes helyen vizsgáljuk meg az adatok korlátait, és gondoskodjunk arról, hogy ezek mindenütt azonosak legyenek.

Az alábbi táblázat a Kópiaütközés-megtekintő párbeszédpanelen rendelkezésre álló beállítási lehetőségeket és ezek szerepét mutatja be.

Megjegyzés

A megjelenő beállítási lehetőségek a bekövetkezett ütközés típusától függnek. Nem mindegyik beállítás jelenik meg mindegyik párbeszédpanelen. A dátumok nem a helyi formátumban, hanem ISO dátumidő formátumban jelennek meg.

Cél | Művelet
Ütközés oka | Megjeleníti azt az okot, ami miatt ütközés következett be, valamint azt a módot, ahogyan az ütközés fel lett oldva.
Csak az ütközéseket tartalmazó mező jelenjen meg | Megjeleníti a GUID (egyedi azonosító) oszlopot és csak azokat a mezőket, amelyek ütközéseket tartalmaznak.
Összes mező megjelenítése | Megjeleníti a rekord összes mezőjét.
Meglévő adat megtartása | Elfogadja az ütközés jelenlegi feloldását.
Ellenőrzött adat megőrzése | Elfogadja az ütközés jelenlegi feloldását, de magába foglalja a szerkesztőmezőkben végzett módosításokat is.
Törölt adat megtartása | Elfogadja az ütközés jelenlegi feloldását, és az adatok törölve maradnak.
Ütközés kihagyása | Feloldottként jelöli meg az ütközést anélkül, hogy bármi megváltozna. Ez ellentmondást okoz, ezért az ütközést a lehető legrövidebb időn belül más módon fel kell oldani.
Felülírás az ütköző adattal | Megváltoztatja az ütközés előző feloldásának módját, és az ütköző adatokat jeleníti meg.
Felülírás a meglévő adattal | Megváltoztatja az ütközés előző feloldásának módját, és a meglévő adatokat jeleníti meg.
Felülírás az ellenőrzött adattal | Megváltoztatja az ütközés előző feloldásának módját a szerkesztőmezőkben végzett módosításoknak megfelelően, és a módosított adatokat jeleníti meg.
Adat törlése | Törli a mezőkben megjelenített adatokat.
Az ütközés adatainak naplózása későbbi felhasználásra | Másolatot készít az ütközésről egy külön naplófájlba későbbi használat céljára. A naplót a Windows könyvtár\profiles\felhasználó\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log fájl tárolja.